# CONTENTS

## Chapter 1: Introduction
- Benchmark Model Guide ........................................... 2
- Comparison With Theoretical and Benchmark Results ........ 4
- COMSOL Software Verification and Quality Assurance Programs .... 4
- Typographical Conventions ........................................ 4

## Chapter 2: Benchmark Models

<table>
<thead>
<tr>
<th>Model</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Wrapped Thick Cylinder Under Pressure and Thermal Loading</td>
<td>8</td>
</tr>
<tr>
<td>Introduction</td>
<td>8</td>
</tr>
<tr>
<td>Model Definition</td>
<td>8</td>
</tr>
<tr>
<td>Modeling in COMSOL Multiphysics</td>
<td>9</td>
</tr>
<tr>
<td>Results and Discussion.</td>
<td>11</td>
</tr>
<tr>
<td>References</td>
<td>12</td>
</tr>
<tr>
<td>Modeling Using the Graphical User Interface</td>
<td>12</td>
</tr>
<tr>
<td>Large Deformation Beam</td>
<td>19</td>
</tr>
<tr>
<td>Model Definition</td>
<td>19</td>
</tr>
<tr>
<td>Results and Discussion.</td>
<td>20</td>
</tr>
<tr>
<td>Reference</td>
<td>22</td>
</tr>
<tr>
<td>Modeling Using the Graphical User Interface</td>
<td>23</td>
</tr>
<tr>
<td>Thick Plate Stress Analysis</td>
<td>27</td>
</tr>
<tr>
<td>Introduction</td>
<td>27</td>
</tr>
<tr>
<td>Model Definition</td>
<td>27</td>
</tr>
<tr>
<td>Results</td>
<td>28</td>
</tr>
<tr>
<td>Reference</td>
<td>29</td>
</tr>
<tr>
<td>Modeling Using the Graphical User Interface</td>
<td>29</td>
</tr>
<tr>
<td>Kirsch Infinite Plate Problem</td>
<td>37</td>
</tr>
<tr>
<td>Introduction</td>
<td>37</td>
</tr>
<tr>
<td>Model Definition</td>
<td>37</td>
</tr>
<tr>
<td>Model Definition</td>
<td>Results and Discussion</td>
</tr>
<tr>
<td>------------------</td>
<td>------------------------</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Eigenfrequency Analysis of a Free Cylinder</td>
<td>110</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Frequency Response Analysis of a Simply Supported Plate</td>
<td>118</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Single Edge Crack</td>
<td>129</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Elasto-Plastic Plate</td>
<td>139</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Elastoacoustic Effect in Rail Steel</td>
<td>145</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Reference ........................................ 149
Modeling Using the Graphical User Interface . . . . . . . . . . . 150

INDEX ........................................ 155
Introduction

This Structural Mechanics Module Verification Manual consists of a set of benchmark models from various areas of structural mechanics and solid mechanics engineering. These are models with a theoretical solution or a solution from an established benchmark. Their purpose is to show the close agreement between the numerical solution obtained in COMSOL Multiphysics and the established benchmark data, so that you can gain confidence in the solutions provided when using the Structural Mechanics Module.

The models illustrate the use of the various structural-mechanics specific application modes and analysis types. We have tried to cover a wide spectrum of the capabilities in the Structural Mechanics Module.

Note that the model descriptions in this book do not contain details on how to carry out every step in the modeling process. Before tackling these models, we urge you to first read the Structural Mechanics Module User’s Guide. This book introduces you to the functionality in the module, reviews new features in the version 3.5 release, and covers basic modeling techniques with tutorials and example models. Another book, the Structural Mechanics Module Model Library, contain a large number of examples models from important application areas such as automotive applications, dynamics and vibration, fluid-structure interaction, fatigue analysis, and piezoelectric applications. Finally, the Structural Mechanics...
Module Reference Guide contains reference material about command-line programming and functions. It is available in HTML and PDF format from the COMSOL Help Desk.

For more information on how to work with the COMSOL Multiphysics graphical user interface, please refer to the COMSOL Multiphysics User's Guide or the COMSOL Multiphysics Quick Start and Quick Reference manual. An explanation on how to model with a programming language is available in yet another book, the COMSOL Multiphysics Scripting Guide.

The book in your hands, the Structural Mechanics Module Verification Manual, provides details about a large number of ready-to-run models that provide numerical solutions to benchmark problems and textbook examples with theoretical closed-form solutions. Each entry comes with theoretical background, a discussion about the results with a comparison to the benchmark data or the analytical solution, as well as instructions that illustrate how to set it up. The documentation for all models contains references to the textbook or technical publication from which we have collected the benchmark data or other verification data.

Finally note that we supply these models as COMSOL Multiphysics model files so you can open them in COMSOL Multiphysics for immediate access, allowing you to follow along with these examples every step along the way.

Benchmark Model Guide

The table below summarizes key information about the available benchmark models. The solution time is the elapsed time measured on a machine running Windows Vista with a 2.6 GHz AMD Athlon X2 Dual Core 500 CPU and 2 GB of RAM. For models with a sequential solution strategy, the Solution Time column shows the total elapsed time for the combined solution steps. The Application Mode column contains the application modes (such as Plane Stress) we used to solve the model. The following
columns indicate the analysis type (such as eigenfrequency). The rightmost column contains the key features in the model.

<table>
<thead>
<tr>
<th>MODEL</th>
<th>PAGE</th>
<th>SOLUTION TIME</th>
<th>APPLICATION MODE</th>
<th>STATIC EIGENFREQUENCY RESPONSE</th>
<th>PARAMETRIC KEY FEATURES</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>BENCHMARK MODELS</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Wrapped cylinder</td>
<td>8</td>
<td>2 s</td>
<td>Solid, Stress-Strain</td>
<td>√</td>
<td>Composite-materials analysis; user-defined coordinate systems</td>
</tr>
<tr>
<td>Large deformation beam</td>
<td>19</td>
<td>10 s</td>
<td>Plane Stress</td>
<td>√</td>
<td></td>
</tr>
<tr>
<td>Thick plate</td>
<td>27</td>
<td>4 s</td>
<td>Solid, Stress-Strain</td>
<td>√</td>
<td>Large deformation analysis; linear buckling</td>
</tr>
<tr>
<td>Kirsch plate</td>
<td>37</td>
<td>1 s</td>
<td>Plane Stress</td>
<td>√</td>
<td></td>
</tr>
<tr>
<td>Thick wall cylinder</td>
<td>47</td>
<td>1 s</td>
<td>Plane Strain</td>
<td>√</td>
<td>Use of symmetries</td>
</tr>
<tr>
<td>In-plane frame</td>
<td>55</td>
<td>1 s</td>
<td>In-Plane Euler Beam</td>
<td>√</td>
<td>Beam elements</td>
</tr>
<tr>
<td>Thermally loaded beam</td>
<td>64</td>
<td>1 s</td>
<td>3D Euler Beam</td>
<td>√</td>
<td>Multiphysics; beam elements; thermal expansion</td>
</tr>
<tr>
<td>In-plane truss</td>
<td>73</td>
<td>1 s</td>
<td>In-Plane Truss</td>
<td>√</td>
<td>Truss elements</td>
</tr>
<tr>
<td>Scordelis-Lo roof</td>
<td>85</td>
<td>1 s</td>
<td>Shell</td>
<td>√</td>
<td>Shell elements</td>
</tr>
<tr>
<td>Cylinder roller contact</td>
<td>98</td>
<td>15 s</td>
<td>Plane Strain</td>
<td>√</td>
<td>Contact modeling</td>
</tr>
<tr>
<td>Free cylinder</td>
<td>110</td>
<td>1 s</td>
<td>Axial Symmetry Stress-Strain</td>
<td>√</td>
<td>Eigenfrequency analysis</td>
</tr>
<tr>
<td>Harmonically excited plate</td>
<td>118</td>
<td>14 s</td>
<td>Mindlin Plate</td>
<td>√</td>
<td>Plate elements; frequency response analysis</td>
</tr>
<tr>
<td>Single edge crack</td>
<td>129</td>
<td>1 s</td>
<td>Plane Stress</td>
<td>√</td>
<td>Fracture model, J-integral</td>
</tr>
<tr>
<td>Elasto-plastic plate</td>
<td>139</td>
<td>36 s</td>
<td>Plane Stress</td>
<td>√</td>
<td>Elasto-plastic material model</td>
</tr>
<tr>
<td>Elastoacoustic effect in rail steel</td>
<td>145</td>
<td>29 s</td>
<td>Solid, Stress-Strain</td>
<td>√</td>
<td>Murnaghan hyperelastic material model</td>
</tr>
</tbody>
</table>
Note: The full table of all models in the Structural Mechanics Module’s model library, which you find in the Structural Mechanics Module Model Library, includes these benchmark models along with the application-oriented models in that book.

We welcome any questions, comments, or suggestions you might have concerning these models. Contact us at info@comsol.com.

**Comparison With Theoretical and Benchmark Results**

COMSOL Multiphysics and the Structural Mechanics Module use the finite element method to solve problems on a computational mesh using discrete numerical methods. Theoretical, closed-form solutions are typically based on continuous mathematical models and would require infinitely small mesh elements to reproduce exactly. These benchmark models, on the other hand, use relatively coarse meshes. The comparisons of the numerical solution in COMSOL Multiphysics to the benchmark results therefore allow for a small discrepancy. Comparisons to established benchmark results also show similar accuracy. Sources to these differences in the results include different solution methods, different discretization (computational grids), and other differences between the code or method used in the benchmark and the COMSOL Multiphysics code. Also note that the numerical solution might vary slightly depending on the computer platform that you use, because different platforms have small differences handling floating-point operations.

**COMSOL Software Verification and Quality Assurance Programs**

COMSOL uses extensive manual and automatic testing to validate and verify the code. The benchmark models in this book make up a subset of the test cases that are part of a continuous automatic testing program. The automatic test program also frequently rebuilds all models in the COMSOL model libraries to ensure that they work and provide consistent solutions.

**Typographical Conventions**

All COMSOL manuals use a set of consistent typographical conventions that should make it easy for you to follow the discussion, realize what you can expect to see on the
screen, and know which data you must enter into various data-entry fields. In particular, you should be aware of these conventions:

- A **boldface** font of the shown size and style indicates that the given word(s) appear exactly that way on the COMSOL graphical user interface (for toolbar buttons in the corresponding tooltip). For instance, we often refer to the **Model Navigator**, which is the window that appears when you start a new modeling session in COMSOL; the corresponding window on the screen has the title **Model Navigator**. As another example, the instructions might say to click the **Multiphysics** button, and the boldface font indicates that you can expect to see a button with that exact label on the COMSOL user interface.

- The names of other items on the graphical user interface that do not have direct labels contain a leading uppercase letter. For instance, we often refer to the Draw toolbar; this vertical bar containing many icons appears on the left side of the user interface during geometry modeling. However, nowhere on the screen will you see the term “Draw” referring to this toolbar (if it were on the screen, we would print it in this manual as the **Draw** menu).

- The symbol > indicates a menu item or an item in a folder in the **Model Navigator**. For example, **Physics>Equation System>Subdomain Settings** is equivalent to: On the **Physics** menu, point to **Equation System** and then click **Subdomain Settings**. **COMSOL Multiphysics>Heat Transfer>Conduction** means: Open the **COMSOL Multiphysics** folder, open the **Heat Transfer** folder, and select **Conduction**.

- A **Code** (monospace) font indicates keyboard entries in the user interface. You might see an instruction such as “Type 1.25 in the **Current density** edit field.” The monospace font also indicates COMSOL Script codes.

- An **italic** font indicates the introduction of important terminology. Expect to find an explanation in the same paragraph or in the Glossary. The names of books in the COMSOL documentation set also appear using an italic font.
This chapter contains benchmarks models, where the results are compared to theoretical solutions or established benchmark data.
Wrapped Thick Cylinder Under Pressure and Thermal Loading

Introduction

This is a benchmark model for composite materials analysis published by NAFEMS (Ref. 1). A detailed description of the problem as well as analytical results enable comparisons between the COMSOL Multiphysics results and the benchmark values.

This is also a modified version of a test used by Taig (Ref. 2).

Model Definition

The geometry is a long, thick, and hollow cylinder consisting of two layers. The inner layer, with an outer radius of 25 mm, is made of an isotropic material, while the outer layer (outer radius of 27 mm) is made of an orthotropic material. The length of the cylinder is 200 mm. The material properties of the outer layer are equal in the radial and axial directions and differ from those in the angular (hoop) direction.

Figure 2-1: Geometry of the problem (all dimensions in mm).

The model includes analyses of two load cases:

- An internal pressure of 200 MPa.
- An internal pressure of 200 MPa in combination with a uniform increase in the temperature by 130 K.
The purpose of including thermal effects in the second case is to simulate prestress caused by tension in the hoop windings.

The material properties for the isotropic material are:

- \( E = 210 \text{ GPa}, \nu = 0.3, \alpha = 2 \cdot 10^{-5} \text{ K}^{-1} \)

For the orthotropic material the properties read:

- \( E_1 = 130 \text{ GPa}, E_2 = E_3 = 5 \text{ GPa} \)
- \( \nu_{12} = \nu_{13} = 0.25, \nu_{23} = 0 \)
- \( G_{12} = G_{13} = 10 \text{ GPa}, G_{23} = 5 \text{ GPa} \)
- \( \alpha_1 = 3 \cdot 10^{-6} \text{ K}^{-1}, \alpha_2 = \alpha_3 = 2 \cdot 10^{-5} \text{ K}^{-1} \)

Because of the circular symmetry of the geometry, it is sufficient to model a quarter cylinder, with zero normal displacement imposed as the boundary condition on each of the two perpendicular rectangular faces. Reflection symmetry furthermore implies that half of the length of the cylinder can be left out by setting the displacement in the axial direction to zero on the annular cross section at the middle of the cylinder.

The target solution given by NAFEMS is:

<table>
<thead>
<tr>
<th>POSITION</th>
<th>CASE 1</th>
<th>CASE 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hoop stress at inner surface (isotropic)</td>
<td>1565.3 MPa</td>
<td>1381 MPa</td>
</tr>
<tr>
<td>Hoop stress at interface (isotropic)</td>
<td>1429.7 MPa</td>
<td>1259.6 MPa</td>
</tr>
<tr>
<td>Hoop stress at interface (orthotropic)</td>
<td>874.7 MPa</td>
<td>1056 MPa</td>
</tr>
<tr>
<td>Hoop stress at outer surface (orthotropic)</td>
<td>759.1 MPa</td>
<td>936.1 MPa</td>
</tr>
</tbody>
</table>

These results were obtained using standard equations for a compound cylinder, modified to take the orthotropic nature of the outer material into account. For a long cylinder, the so obtained solution is acceptable away from the ends. For this reason, Table 2-1 displays the solution evaluated at the annular cross section in the middle of the cylinder.

*Modeling in COMSOL Multiphysics*

For this model, you can take advantage of the possibility to implement user-defined coordinate systems in the Structural Mechanics Module by defining the material
properties in cylindrical coordinates. The resulting relation between the material orientation and the coordinate labels in the user interface is as follows:

Table 2-2: Relation Between Material Orientation and User Interface Coordinate Labels

<table>
<thead>
<tr>
<th>Description</th>
<th>Material Orientation</th>
<th>User Interface Coordinate Label</th>
</tr>
</thead>
<tbody>
<tr>
<td>angular direction</td>
<td>1</td>
<td>y</td>
</tr>
<tr>
<td>axial direction</td>
<td>2</td>
<td>z</td>
</tr>
<tr>
<td>radial direction</td>
<td>3</td>
<td>x</td>
</tr>
</tbody>
</table>

Note that material properties sometimes are given in an orientation that differs from the one required by COMSOL Multiphysics. This is such a case, since the orthotropic material data are \( \nu_{12}, \nu_{13}, \) and \( \nu_{23}, \) whereas COMSOL Multiphysics requires that you enter the Poisson ratios as \( \nu_{xy}, \nu_{yz}, \) and \( \nu_{xz} \)—that is, \( \nu_{31}, \nu_{12}, \) and \( \nu_{32}, \) respectively.

Since the Poisson ratios are not symmetric, each parameter must be reevaluated in the correct orientation. The relation between the ratios for the orthotropic case reads:

\[
\frac{\nu_{ij}}{E_i} = \frac{\nu_{ji}}{E_j}
\]

Hence

\[
\nu_{xy} = \frac{\nu_{yx} \cdot E_2}{E_y} = \frac{\nu_{12} \cdot E_3}{E_1}
\]

and

\[
\nu_{xz} = \frac{\nu_{zx} \cdot E_2}{E_z} = \frac{\nu_{23} \cdot E_3}{E_2} = 0
\]

The shear moduli, \( G_{ij} \), are symmetric, and you can therefore enter the given values for those directly in COMSOL Multiphysics.
Results and Discussion

A cross-section plot of the hoop stress—that is, the normal stress along the angular direction—gives the following result:

Figure 2-2: Cross-sectional plot of the hoop stress through the tube at z=0 (red dashed line: case2).

<table>
<thead>
<tr>
<th>POSITION</th>
<th>COMSOL MULTIPHYSICS RESULTS CASE 1</th>
<th>NAFEMS TARGET</th>
<th>ERROR</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hoop stress at inner surface (isotropic)</td>
<td>1568.5 MPa</td>
<td>1565.3 MPa</td>
<td>0.2%</td>
</tr>
<tr>
<td>Hoop stress at interface (isotropic)</td>
<td>1429 MPa</td>
<td>1429.7 MPa</td>
<td>0.05%</td>
</tr>
<tr>
<td>Hoop stress at interface (orthotropic)</td>
<td>876 MPa</td>
<td>874.7 MPa</td>
<td>0.15%</td>
</tr>
<tr>
<td>Hoop stress at outer surface (orthotropic)</td>
<td>755 MPa</td>
<td>759.1 MPa</td>
<td>0.54%</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>POSITION</th>
<th>COMSOL MULTIPHYSICS RESULTS CASE 2</th>
<th>NAFEMS TARGET</th>
<th>ERROR</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hoop stress at inner surface (isotropic)</td>
<td>1384.3 MPa</td>
<td>1381 MPa</td>
<td>0.24%</td>
</tr>
<tr>
<td>Hoop stress at interface (isotropic)</td>
<td>1259 MPa</td>
<td>1259.6 MPa</td>
<td>0.05%</td>
</tr>
</tbody>
</table>
As is evident from Table 2-3 and Table 2-4, the COMSOL Multiphysics results are in good agreement with the NAFEMS target.

References


Model Library path: Structural_Mechanics_Module/Benchmark_Models/wrapped_cylinder

**Modeling Using the Graphical User Interface**

**MODEL NAVIGATOR**

1. On the **New** page, select **3D** from the **Space Dimension** list and double-click on **Structural Mechanics Module**.

2. Select **Solid, Stress-Strain** and then **Static analysis**.

3. Click **OK** to close the Model Navigator.

**GEOMETRY MODELING**

You obtain the geometry by extrusion of a structured mesh: first create the geometry in 2D, then mesh it, and finally extrude the mesh in 3D.

1. In the **Draw** menu, choose **Work-Plane Settings**. Select the default one by clicking **OK**.

2. In the **Options** menu, choose **Axes/Grid Settings**.

3. On the **Axis** page, set the axis settings \( x_{\text{min}} = -0.01, x_{\text{max}} = 0.03, y_{\text{min}} = -0.01, \) and \( y_{\text{max}} = 0.03 \).

**TABLE 2-4: COMPARISON OF THE COMSOL MULTIPHYSICS RESULTS VS. NAFEMS TARGET FOR CASE 2**

<table>
<thead>
<tr>
<th>POSITION</th>
<th>COMSOL MULTIPHYSICS RESULTS CASE 2</th>
<th>NAFEMS TARGET</th>
<th>ERROR</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hoop stress at interface (orthotropic)</td>
<td>1058 MPa</td>
<td>1056 MPa</td>
<td>0.19%</td>
</tr>
<tr>
<td>Hoop stress at outer surface (orthotropic)</td>
<td>931 MPa</td>
<td>936.1 MPa</td>
<td>0.54%</td>
</tr>
</tbody>
</table>
4 On the Grid page, clear the Auto option and set x spacing to 5e-3, Extra x to 2.3e-2 2.7e-2, y spacing to 5e-3, and Extra y to 2.3e-2 2.7e-2. When finished, click OK.

5 Click the 2nd Degree Bézier Curve button in the Draw toolbar, then click at the points (0.023, 0), (0.023, 0.023), and (0, 0.023) in that order.

6 Click the Line button on the Draw toolbar, then click at point (0, 0.025).

7 Click the 2nd Degree Bézier Curve button, then click at the points (0.025, 0.025) and (0.025, 0) in that order.

8 Right-click to create the solid object.

Steps 5–8 create the cross section of the inner cylinder. Proceed in the same way to generate the outer cylinder with an inner radius of 25 mm and outer radius of 27 mm.

**Mesh Generation**

1 In the Mesh menu, choose Mapped Mesh Parameters.

2 Click the Boundary tab, select Boundary 1 and Boundary 2, and select the Constrained edge element distribution check box. Set Number of edge elements to 1.

3 Select Boundary 7, select the Constrained edge element distribution check box, and set the Number of edge elements to 10.

4 Click Remesh, then click OK.

   This creates a structured 2D mesh. Next create the 3D mesh by extrusion:

5 In the Mesh menu, choose Extrude Mesh. In the Extrusion parameters area, type 0.1 in the Distance edit field.

6 Click the Mesh tab and type 4 in the Number of element layers edit field.
7 Click **OK**.

**OPTIONS AND SETTINGS**

In order to properly set up the orthotropic material properties regarding the material orientation, a local cylindrical coordinate system is required.

1. From the **Options** menu, choose **Coordinate Systems**.
2. Click **New** and type **Cylindrical** as the name for the new coordinate system. Click **OK**.
3 On the Workplane page, click the Cylindrical coordinate system button.

4 Click OK.

The next step is to enter the constants that you use in the model.

1 From the Options menu, choose Constants and enter constant names, expressions, and descriptions (the descriptions are optional) according to the following table:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>E1</td>
<td>1.3e11[Pa]</td>
<td>theta-component of the Young’s modulus</td>
</tr>
<tr>
<td>E2</td>
<td>5e9[Pa]</td>
<td>z-component of the Young’s modulus</td>
</tr>
<tr>
<td>E3</td>
<td>5e9[Pa]</td>
<td>r-component of the Young’s modulus</td>
</tr>
<tr>
<td>nu12</td>
<td>0.25</td>
<td>theta-z Poisson’s ratio</td>
</tr>
<tr>
<td>nu32</td>
<td>0</td>
<td>r-z Poisson’s ratio</td>
</tr>
<tr>
<td>nu13</td>
<td>0.25</td>
<td>theta-r Poisson’s ratio</td>
</tr>
<tr>
<td>nu31</td>
<td>nu13*E3/E1</td>
<td>r-theta Poisson’s ratio</td>
</tr>
<tr>
<td>G12</td>
<td>10e9[Pa]</td>
<td>theta-z shear modulus</td>
</tr>
<tr>
<td>G32</td>
<td>5e9[Pa]</td>
<td>r-z shear modulus</td>
</tr>
<tr>
<td>G31</td>
<td>10e9[Pa]</td>
<td>r-theta shear modulus</td>
</tr>
</tbody>
</table>

2 Click OK.

PHYSICS SETTINGS

Subdomain Settings
1 From the Physics menu, select Subdomain Settings.
2 Select Subdomain 1. From the Coordinate system list, select Cylindrical.
3 Type 2.1e11, 0.3, and 2e-5 in the Young’s Modulus, the Poisson’s ratio, and the Thermal expansion coeff. edit fields, respectively.

4 Select Subdomain 2. Select Orthotropic from the Material model list and Cylindrical from the Coordinate system list.

5 Enter material property values according to the following table:

<table>
<thead>
<tr>
<th>QUANTITY</th>
<th>VALUE/EXPRESSION</th>
<th>UNIT</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Eₓ, Eᵧ, Eᶻ</td>
<td>E3, E1, E2</td>
<td>Pa</td>
<td>Young’s modulus</td>
</tr>
<tr>
<td>νₓᵧ, νᵧᶻ, νₓᶻ</td>
<td>nu31, nu12, nu32</td>
<td></td>
<td>Poisson’s ratio</td>
</tr>
<tr>
<td>Gₓᵧ, Gᵧᶻ, Gₓᶻ</td>
<td>G31, G12, G32</td>
<td>Pa</td>
<td>Shear modulus</td>
</tr>
<tr>
<td>αₓ, αᵧ, αᶻ</td>
<td>2e-5, 3e-6, 2e-5</td>
<td>1/K</td>
<td>Thermal expansion coeff.</td>
</tr>
</tbody>
</table>

6 Click OK.

Boundary Conditions

1 From the Physics menu, open the Boundary Settings dialog box.

2 Select Boundary 2. On the Load page, select Cylindrical from the Coordinate system list, and enter 200e6 in the Face load (force/area) xl dir. edit field.

3 Click the Constraint tab. Select Boundaries 1, 3, 7, 10, and 11.

4 From the Constraint condition list, select Symmetry plane.

5 Click OK.
COMPUTING THE SOLUTION
Click the Solve button on the Main toolbar.

POSTPROCESSING AND VISUALIZATION
1 From the Postprocessing menu, select the Plot Parameters dialog box.
2 On the General page, clear the Slice check box and select the Subdomain check box in the Plot type area.
3 On the Subdomain page, select \textit{sy normal stress local sys.} in the Predefined quantities list.
4 Click OK.

5 From the Postprocessing menu, choose Cross-Section Plot Parameters. Click the Line/Extrusion plot button on the General page.
6 Click the Line/Extrusion tab and select \textit{sy normal stress local sys.} from the Predefined quantities list.
7 In the Cross-section line data area, type $27 \cdot 3$ in both the $x_1$ and the $y_1$ edit field.
8 Set the Line resolution to 600.
Click **OK**.

![Graph of hoop stress](image)

**Figure 2-3: The hoop stress.**

Do not close the cross-sectional plot; you will use it later to compare the results with the thermal loading case.

This completes the first load case of the benchmark.

**SECOND CASE INCLUDING THERMAL LOADING**

1. From the **Physics** menu, open the **Subdomain Settings** dialog box.
2. Select both Subdomain 1 and Subdomain 2.
3. On the **Load** page, select the **Include thermal expansion** check box and enter 130 in the **Strain temperature** edit field. Click **OK**.
4. Click the **Solve** button on the Main toolbar.
5. From the **Postprocessing** menu, open the **Cross-Section Plot Parameters** dialog box.
   - On the **General** page, select the **Keep current plot** check box.
6. On the **Line/Extrusion** page, click **Line Settings**.
7. Select **Color** and **Dashed line** for **Line color** and **Line style**, respectively. Click **OK**.
8. Click **OK** to reproduce Figure 2-2 on page 11.
Large Deformation Beam

Model Definition

In this example you study the deflection of a cantilever beam undergoing very large deflections. The model is called “Straight Cantilever GNL Benchmark” and is described in detail in section 5.2 of NAFEMS Background to Finite Element Analysis of Geometric Non-linearity Benchmarks (Ref. 1).

![Figure 2-4: Cantilever beam geometry.](image)

In addition to the original problem formulation, where the complete history of the displacement is sought, you undertake a linearized buckling analysis of the structure. This example uses the plane stress application mode.

**GEOMETRY**
- The length of the beam is 3.2 m.
- The cross section is a square with side lengths 0.1 m.

**MATERIAL**
The beam is linear elastic with $E = 2.1 \cdot 10^{11} \text{ N/m}^2$ and $\nu = 0$.

**CONSTRAINTS AND LOADS**
- The left end is fixed. This boundary condition is compatible with beam theory assumptions only in the case $\nu = 0$.
- The right end is subjected to distributed loads with the resultants $F_x = -3.844 \cdot 10^6 \text{ N}$ and $F_y = -3.844 \cdot 10^3 \text{ N}$. 
Results and Discussion

Due to the large compressive axial load and the slender geometry, this is a buckling problem. If you are to study the buckling and post-buckling behavior of a symmetric problem, it is necessary to perturb the symmetry somewhat. Here the small transversal load serves this cause. An alternative approach would be to introduce an initial imperfection in the geometry.

The final state (using 1:1 displacement scaling) is shown below.

The vertical and horizontal displacements of the tip versus the scaled axial force appear in the next graph, using solid and dashed lines, respectively.
The following table contains a summary of some significant results. Because the reference values are given as graphs, an estimate of the error caused by reading this graph is added:

<table>
<thead>
<tr>
<th>RESULT</th>
<th>COMSOL MULTIPHYSICS</th>
<th>REFERENCE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maximum vertical displacement at the tip</td>
<td>-2.58</td>
<td>-2.58 ± 0.02</td>
</tr>
<tr>
<td>Final vertical displacement at the tip</td>
<td>-1.33</td>
<td>-1.36 ± 0.02</td>
</tr>
<tr>
<td>Final horizontal displacement at the tip</td>
<td>-5.08</td>
<td>-5.04 ± 0.04</td>
</tr>
</tbody>
</table>

The results are in excellent agreement, especially considering the coarse mesh used.

The plot of the axial deflection reveals that an instability occurs at a parameter value close to 0.1, corresponding to the axial load $3.84 \times 10^5$.

This problem (without the small transverse load) is usually referred to as the Euler-1 case. The theoretical critical load is

$$ P_c = \frac{\pi^2 EI}{4L^2} = \frac{\pi^2 \cdot 2.1 \cdot 10^{11} \cdot (0.1^4/12)}{4 \cdot 3.2^2} = 4.22 \cdot 10^5 \text{ N} \quad (2-1) $$

The critical buckling load computed using COMSOL Multiphysics is $4.21 \cdot 10^5 \text{ N}$,
which is very close to the theoretical value. Figure 2-5 shows the corresponding buckling mode shape.

![Figure 2-5: Buckling mode shape for critical buckling load.](image)

It is often seen in practice that the critical load of an imperfect structure is significantly lower than that of the ideal structure.

**Reference**


**Model Library path:** Structural_Mechanics_Module/Benchmark_Models/large_deformation_beam
Modeling Using the Graphical User Interface

**MODEL NAVIGATOR**
1. Select 2D in the Space dimension list on the New page in the Model Navigator.
3. Click OK.

**OPTIONS AND SETTINGS**
1. From the Options menu, select Axes/Grid Settings.
2. Specify axis and grid settings according to the following table; when done, click OK.

<table>
<thead>
<tr>
<th>AXIS</th>
<th>GRID</th>
</tr>
</thead>
<tbody>
<tr>
<td>x min</td>
<td>-0.1</td>
</tr>
<tr>
<td>x max</td>
<td>3.3</td>
</tr>
<tr>
<td>y min</td>
<td>-0.1</td>
</tr>
<tr>
<td>y max</td>
<td>0.2</td>
</tr>
</tbody>
</table>

**GEOMETRY MODELING**
Click the Rectangle/Square button on the Draw toolbar and click the left mouse button at (0, 0). Move the mouse to (3.2, 0.1) and click the left mouse button again.

**PHYSICS SETTINGS**

**Boundary Settings**
1. From the Physics menu, select Boundary Settings.
2. Specify boundary settings according to the following tables; when done, click OK.

**BOUNDARY 1**

<table>
<thead>
<tr>
<th>Page</th>
<th>Constraint</th>
<th>Constraint condition</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th><strong>BOUNDARY 4</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Page</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>
Both forces are specified as forces/length (this is the reason for dividing by 0.1). The horizontal force is multiplied with the parameter $\text{Para}$, which increases the force using the parametric solver.

**Subdomain Settings**

1. From the **Physics** menu, select **Subdomain Settings**.
2. Specify material data according to the following table; when done, click **OK**.

<table>
<thead>
<tr>
<th>SUBDOMAIN 1</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Page</td>
<td>Material</td>
</tr>
<tr>
<td>$E$</td>
<td>$2.1\times10^{11}$</td>
</tr>
<tr>
<td>$\nu$</td>
<td>0</td>
</tr>
<tr>
<td>thickness</td>
<td>0.1</td>
</tr>
</tbody>
</table>

**Large Deformation Property**

1. From the **Physics** menu, select **Properties**.
2. From the **Large deformation** list select **On**. Click **OK**.

**MESH GENERATION**

Click the **Initialize Mesh** button on the Main toolbar to generate the mesh.

**COMPUTING THE SOLUTION**

1. From the **Solve** menu, select **Solver Parameters**.
2. In the **Parameter name** edit field, type $\text{Para}$.
3. In the **Parameter values** edit field, type $0:0.01:1$. Click **OK**.
4. Click the **Solve** button on the Main toolbar.

**POSTPROCESSING AND VISUALIZATION**

1. From the **Postprocessing** menu, select **Plot Parameters**.
2 Click the Deform tab.

3 Select the Deformed shape plot check box.

4 Clear the Auto check box, then set the Scale factor to 1. Click OK.

5 Click the Zoom Extents button on the Main toolbar.

6 From the Postprocessing menu, select Cross-Section Plot Parameters.

7 Select all parameter values in the Solutions to use list.

8 Check Keep current plot.

9 Click the Point tab.

10 Enter the coordinates $x = 3.2$ and $y = 0.05$ to plot the solution at the beam end.

11 Select y-displacement in the Predefined quantities list, then click Apply.

12 Click the Line Settings button, then select Dashed line in the Line style list. Click OK.

13 Select x-displacement in the Predefined quantities list, then click OK.

**Computing the Linearized Buckling Load**

A linear buckling analysis consists of two steps: First you apply the load (often a unit load) and run a static analysis. Then you start a second analysis, solving an eigenvalue problem. The result is a critical load factor causing instability of the structure.

**Static Preload**

1 From the Physics menu, select Properties.

2 From the Analysis type list, select Static.

3 From the Large deformation list, select Off. Click OK.

4 From the Physics menu, select Boundary Settings.

5 Change the loads according to the following table; when finished, click OK.

<table>
<thead>
<tr>
<th>Boundary 4</th>
<th>Load</th>
</tr>
</thead>
<tbody>
<tr>
<td>$F_x$</td>
<td>-1/0.1</td>
</tr>
<tr>
<td>$F_y$</td>
<td>0</td>
</tr>
</tbody>
</table>

6 Click the Solve button on the Main toolbar.

**Buckling Analysis**

1 From the Physics menu, select Properties.

2 From the Analysis type list, select Linear buckling. Click OK.

3 From the Solve menu, select Solver Parameters.

4 In the Desired number of critical load factors edit field, type 1.
5 Click **OK** to close the dialog box.
6 Click the **Restart** button on the Main toolbar.
7 From the **Postprocessing** menu, select **Plot Parameters**.
8 Click the **Deform** tab.
9 Select the **Auto** check box under **Scale factor**, then click **OK**.
Thick Plate Stress Analysis

Introduction

In the following example you build and solve a solid mechanics model using the Solid, Stress-Strain application mode.

This model describes the static stress analysis of a simple geometry. The model is NAFEMS Test No LE10, “Thick Plate Pressure,” described on page 77 in the NAFEMS Background to Benchmarks (Ref. 1). The computed stress level is compared with the values given in the benchmark report.

Model Definition

The geometry is an ellipse with an ellipse-shaped hole in it. Due to symmetry in load and geometry, the analysis only includes a quarter of the ellipse.

Figure 2-6: The thick plate geometry, reduced to a quarter of the ellipse due to symmetry.

MATERIAL

Isotropic with, $E=2.1\cdot10^{11}$ Pa, $\nu=0.3$. 

\[
\begin{align*}
E &= 2.1 \cdot 10^{11} \text{ Pa} \\
\nu &= 0.3
\end{align*}
\]
**LOAD**
A distributed force of $10^6$ MPa on the upper surface pointing in the negative $z$ direction.

**CONSTRAINTS**
- Symmetry planes, $x = 0, y = 0$.
- Outer surface constrained in the $x$ and $y$ direction.
- Midplane on outer surface constrained in the $z$ direction.

**Results**
The normal stress $\sigma_y$ on the top surface at the inside of the elliptic hole (marked with $D(2, 0, 0.6)$ in the figure) is in close agreement with the NAFEMS benchmark (Ref. 1). The coordinates of $D$ are $(2, 0, 0.6)$.

<table>
<thead>
<tr>
<th>RESULT</th>
<th>COMSOL MULTIPHYSICS</th>
<th>NAFEMS (REF. 1)</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\sigma_y$ (at $D$)</td>
<td>-5.44 MPa</td>
<td>-5.38 MPa</td>
</tr>
</tbody>
</table>

A COMSOL Multiphysics plot of the stress level appear in Figure 2-7 below.

![Figure 2-7: The normal stress in the y direction.](image)

Subdomain: $sy$ normal stress global sys. [Pa]
Reference

**Model Library path:** Structural_Mechanics_Module/Benchmark_Models/thick_plate

**Modeling Using the Graphical User Interface**

**MODEL NAVIGATOR**
1. Select 3D in the *Space dimension* list on the *New* page in the Model Navigator.
2. Select *Structural Mechanics Module>Solid, Stress-Strain>Static analysis* and click *OK*.

**GEOMETRY MODELING**
The quarter of the ellipse is drawn in a work plane and extruded into a 3D solid.
1. From the *Draw* menu, select *Work-Plane Settings*.
2. Click *OK* in the *Work-Plane Settings* dialog box to create a work plane using the default settings, global xy-plane at z = 0.
3 From the **Options** menu, select **Axes/Grid Settings**. On the **Grid** page, clear **Auto**, and give axis and grid settings according to the following table; when done, click **OK**.

<table>
<thead>
<tr>
<th><strong>AXIS</strong></th>
<th><strong>GRID</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>x min</td>
<td>-4</td>
</tr>
<tr>
<td>x max</td>
<td>4</td>
</tr>
<tr>
<td>y min</td>
<td>-3</td>
</tr>
<tr>
<td>y max</td>
<td>3</td>
</tr>
</tbody>
</table>

| x spacing | 0.25 |
| Extra x   |      |
| y spacing | 0.25 |
| Extra y   |      |

4 Click the **Ellipse/Circle (Centered)** button on the Draw toolbar and click the left mouse button at (0, 0) move the mouse to (2, 1) and click the left mouse button again to create the inner ellipse.

5 Click the **Ellipse/Circle (Centered)** button on the Draw toolbar and click the left mouse button at (0, 0) move the mouse to (3.25, 2.75) and click the left mouse button again to create the outer ellipse.

6 Select both ellipses and click the **Difference** button on the Draw toolbar to cut a hole.

7 Draw a rectangle with bottom left corner at (0, 0) and top right corner at (3.25, 2.75).

8 Select the ellipse with a hole in and the rectangle, and then click the **Intersection** button on the Draw toolbar to create a quarter of the ellipse.
Now you need to extrude the quarter of the ellipse to create a 3D solid object.

1. Select the quarter and then choose **Extrude** from the **Draw** menu.
2. Enter 0.3 as **Distance** in the **Extrude** dialog box and click **OK**.
3. Click the **Array** toolbar button to make a copy of the object.
4. Enter 0.3 as **z Displacement** and 2 as **z Array size** in the **Array** dialog box and click **OK**.
5. In order to remove interior boundaries but keep edges needed for the boundary condition, click the **Create Composite Object** button on the Draw toolbar.
6. Select **EXT1** and **EXT2** in the **Object selection** list, clear the **Keep interior borders** check box and click the **Keep interior edges** check box in the **Create Composite Object** dialog box and click **OK**.
7. Click the **Zoom Extents** button on the Main toolbar to see the finished 3D object.

**PHYSICS SETTINGS**

In this section the analysis type is specified, and the edge, boundary, and subdomain settings is made.
Application Mode Properties
You can control the analysis type from the Application Mode Properties dialog box, which you open by selecting Properties on the Physics menu. Static analysis was selected already in the Model Navigator so there is no need to change the analysis type.

Edge Settings
Constrain the z-displacement along the midplane edge of the outer surface.

1. From the Physics menu, select Edge Settings.
2. Specify edge settings according to the following table; when done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>EDGE 12</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page</td>
<td>Constraint</td>
</tr>
<tr>
<td></td>
<td>R&lt;sub&gt;z&lt;/sub&gt;, 0</td>
</tr>
</tbody>
</table>

Boundary Settings
Constrain the symmetry planes normal to the surface and the outer surface in the x and y directions. Specify the distributed force on the top surface to \(-10^6\) in the z direction.

1. From the Physics menu, select Boundary Settings.
2. Specify boundary settings according to the following tables; when done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 1, 4, 9, 10</th>
<th>BOUNDARIES 7, 8</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page</td>
<td>Constraint</td>
<td>Constraint</td>
</tr>
<tr>
<td></td>
<td>Constraint condition</td>
<td>Symmetry plane</td>
</tr>
<tr>
<td></td>
<td>Prescribed displacement</td>
<td>Prescribed</td>
</tr>
<tr>
<td></td>
<td></td>
<td>displacement</td>
</tr>
</tbody>
</table>
Subdomain Settings
Specify the material properties of the plate.

1. From the Physics menu, select Subdomain Settings.
2. Specify subdomain settings according to the following table; when done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page</td>
<td>Material</td>
</tr>
<tr>
<td></td>
<td>Material model</td>
</tr>
<tr>
<td></td>
<td>E</td>
</tr>
<tr>
<td></td>
<td>v</td>
</tr>
</tbody>
</table>
MESH GENERATION
1. From the Mesh menu, select the Free Mesh Parameters.
2. From the Predefined mesh sizes list, select Fine.
3. Click OK to close the dialog box.
4. Click the Initialize Mesh toolbar button to mesh the geometry.

COMPUTING THE SOLUTION
Click the Solve button on the Main toolbar to compute the solution.

POSTPROCESSING AND VISUALIZATION
Analyze the global $\sigma_y$ stress at $D$.
1. From the Postprocessing menu, select Plot Parameters.
2. On the General page, clear the Slice check box and select the Subdomain check box in the Plot type area.
3. From the Predefined quantities list on the Subdomain page, select $sy$ normal stress global sys.
4 Click **OK** to close the dialog box and view the plot.

Looking at the plot above, the stress level at $D$ seems to be around $-5 \cdot 10^6$. To get a more accurate value use the **Data Display** dialog box.

5 From the **Postprocessing** menu, select **Data Display**>**Subdomain** to open the **Data Display** dialog box.

6 Enter the coordinates of $D$ in the $x$, $y$, and $z$ coordinates edit fields. The coordinates are $(2, 0, 0.6)$.
7 Select *sy normal stress global sys.* from the *Predefined quantities* list.

8 Click **OK** to display the stress. The value appears in the message log. The stress value is -5.44 MPa, which is in close agreement with the NAFEMS value.
Kirsch Infinite Plate Problem

Introduction

In the following example you build and solve a model using the Plane Stress application mode.

This model describes the static stress analysis of a simple geometry, a small hole in an infinite plate. The model is a classic benchmark, and the theoretical solution was derived by G. Kirsch in 1898 (see, for example, Ref. 1.) The stress level is compared with the theoretical values.

Model Definition

The model is the Kirsch plate described on page 184 in D. Roylance Mechanics of Materials (Ref. 1).

The infinite plate is modeled as a 2 m-by-2 m plate with a hole with a radius of 0.1 m in the middle. Due to symmetry in load and geometry only a quarter of the plate is modeled.

Figure 2-8: Geometry model of the Kirsch plate, making use of the symmetry.
MATERIAL
Isotropic material with, $E = 2.1 \cdot 10^{11}$ Pa, $\nu = 0.3$.

LOAD
A distributed force of $10^3$ Pa on the right edge pointing in the $x$ direction.

CONSTRAINTS
Symmetry planes, $x = 0, y = 0$.

Results
The normal stress $\sigma_x$ is plotted as a function of the $y$-coordinate along the left symmetry edge. The theoretical stress according to D. Roylance (Ref. 1) is

$$\sigma_x = \frac{1000}{2} \left( 2 + \frac{0.1^2}{y^2} + 3 \frac{0.1^4}{y^4} \right)$$

In the following plot the theoretical values are plotted as a comparison.

![Graph showing the comparison between simulated results and theoretical values.](image)

Figure 2-9: Normal stress, simulated results versus the theoretical values.
The theoretical values from Ref. 1 are in close agreement with the result from COMSOL Multiphysics.

Reference


**Model Library path:** Structural_Mechanics_Module/Benchmark_Models/kirsch_plate

**Modeling Using the Graphical User Interface**

**MODEL NAVIGATOR**

1. Select 2D in the *Space dimension* list on the *New* page in the *Model Navigator*.
2. Select *Structural Mechanics Module>Plane Stress>Static analysis* and click *OK*.

**OPTIONS AND SETTINGS**

1. Choose *Axes/Grid Settings* from the *Options* menu.
2 Enter axis and grid settings according to the following table. On the Grid page, first clear the Auto check box. When done, click OK.

<table>
<thead>
<tr>
<th>AXIS</th>
<th>GRID</th>
</tr>
</thead>
<tbody>
<tr>
<td>x min</td>
<td>-0.5</td>
</tr>
<tr>
<td>x max</td>
<td>1.5</td>
</tr>
<tr>
<td>y min</td>
<td>-0.5</td>
</tr>
<tr>
<td>y max</td>
<td>1.5</td>
</tr>
</tbody>
</table>

**GEOMETRY MODELING**

1 Click the **Rectangle/Square** toolbar button and click the left mouse button at (0, 0). Press Ctrl while moving the mouse to (1, 1) and click the left mouse button again to create a square.

2 Click the **Ellipse/Circle (Centered)** toolbar button and click the left mouse button at (0, 0) press Ctrl while moving the mouse to (0.1, 0.1) and click the left mouse button again to create a centered circle.

3 Select the square and circle and click the **Difference** toolbar button to cut a hole in the plate.
**PHYSIC SETTINGS**

*Boundary Settings*
Constrain the symmetry edges in the x and y directions. Specify the distributed force on the right edge to $10^3$ in the x direction.

1. Select **Boundary Settings** from the **Physics** menu.
2. Specify boundary settings according to the following tables; when done, click **OK**.

<table>
<thead>
<tr>
<th>BOUNDARIES 1, 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page</td>
</tr>
<tr>
<td>Constraint</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>BOUNDARY 4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Fx</td>
</tr>
<tr>
<td>Load definition</td>
</tr>
</tbody>
</table>

*Subdomain Settings*
Specify the material properties of the plate.

1. Select **Subdomain Settings** from the **Physics** menu.
2 Specify subdomain settings according to the following table; when done, click **OK**.

<table>
<thead>
<tr>
<th>SUBDOMAIN 1</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Page</strong></td>
</tr>
<tr>
<td>Material model</td>
</tr>
<tr>
<td>$E$</td>
</tr>
<tr>
<td>$\nu$</td>
</tr>
<tr>
<td>thickness</td>
</tr>
</tbody>
</table>

**MESH GENERATION**

Use the default mesh settings.

Click the **Initialize Mesh** toolbar button on the Main toolbar to create the mesh.
**COMPUTING THE SOLUTION**

Click the **Solve** button on the Main toolbar to compute the solution.

**POSTPROCESSING AND VISUALIZATION**

Analyze the global $\sigma_x$ stress along the symmetry line $x = 0$ between $y$ coordinates 0.1 and 1.0 and compare it with the analytical solution for the infinite plate.

1. Select **Cross-Section Plot Parameters** from the **Postprocessing** menu.
2. Click the **Line/Extrusion** tab.
3. Select **Plane Stress>$sx$ normal stress global sys.** from the **Predefined quantities** list in the **y-axis data** area.
4. Type 0 and 0.1 in the **X0** and **Y0** edit fields.
5 Type 0 and 1.0 in the $X_1$ and $Y_1$ edit fields.

6 Click **Apply** to view the stress in an $xy$-diagram.

7 Click the **General** tab and select the **Keep current plot** check box to plot the analytical solution in the same diagram.

8 Click the **Line/Extrusion** tab.

9 Type $1000/2*(2+0.1^2/y^2+3*0.1^4/y^4)$ in the **Expression** field.
10 Click **OK** to add the analytic stress to the xy-diagram.

View the $\sigma_x$ normal stress in a surface plot.

II Select **Plot Parameters** from the **Postprocessing** menu.
12. Select *sx normal stress global sys.* from the *Predefined quantities* list and click *OK.*
Thick Wall Cylinder Benchmark Problem

In the following example you build and solve a model using the Plane Strain application mode.

The model is a thick-walled cylinder exposed to both internal and external pressure as well as a thermal load.

The problem is both plane and axisymmetric and has an analytical solution, which can be found in Abdel-Rahman Ragab (Ref. 1).

Model Definition

Both ends of the cylinder are constrained from moving in the axial direction resulting in plane strain conditions. Due to symmetry both in load and geometry it is sufficient to model a slice of the pipe.

MATERIAL

Isotropic material with $E = 2.1 \cdot 10^{11}$ Pa, $\nu = 0.3$, and $\alpha = 1.2 \cdot 10^{-5}/\degree \text{C}$.
**PRESSURE LOADS**
An internal pressure of $5 \cdot 10^6$ Pa and an external pressure of $2 \cdot 10^6$ Pa.

**THERMAL LOAD**
- Thermal strain temperature distribution from analytic solution of thermal problem. Inside temperature $T_i = 500 \, ^\circ C$, outside temperature $T_o = 20 \, ^\circ C$. The analytic solution of thermal problem from Ref. 1 is
  \[
  T(r) = \frac{T_i - T_o}{\ln \left( \frac{r_o}{r_i} \right)} + T_o
  \]
- Thermal strain reference temperature: 20 °C.

**CONSTRAINTS**
Symmetry plane constraint condition on the symmetry planes.

**Results**
The stresses at the inside and outside of cylinder are compared with the analytic solutions according to Abdel-Rahman Ragab (Ref. 1) in the following table.

<table>
<thead>
<tr>
<th>STRESS COMPONENT</th>
<th>COMSOL INSIDE</th>
<th>TARGET INSIDE</th>
<th>COMSOL OUTSIDE</th>
<th>TARGET OUTSIDE</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\sigma_x$ ($\sigma_r$)</td>
<td>-5.0·10$^7$</td>
<td>-5.0·10$^7$</td>
<td>-2.0·10$^7$</td>
<td>-2.0·10$^7$</td>
</tr>
<tr>
<td>$\sigma_y$ ($\sigma_\theta$)</td>
<td>-1.32·10$^9$</td>
<td>-1.33·10$^9$</td>
<td>3.69·10$^8$</td>
<td>3.69·10$^8$</td>
</tr>
<tr>
<td>$\sigma_z$</td>
<td>-1.63·10$^9$</td>
<td>-1.62·10$^9$</td>
<td>1.05·10$^8$</td>
<td>1.05·10$^8$</td>
</tr>
</tbody>
</table>

The stresses are in close agreement having a maximum relative error of 0.1%.

**Reference**

**Model Library path**: Structural_Mechanics_Module/Benchmark_Models/thick_wall_cylinder
MODEL NAVIGATOR
1 Select 2D in the Space dimension list on the New page in the Model Navigator.
2 Select Structural Mechanics Module>Plane Strain>Static analysis and click OK.

OPTIONS AND SETTINGS
1 From the Options menu, select Axes/Grid Settings. On the Grid page, clear Auto and give axis and grid settings according to the following table; when done, click OK.

<table>
<thead>
<tr>
<th>AXIS</th>
<th>GRID</th>
</tr>
</thead>
<tbody>
<tr>
<td>x min</td>
<td>-0.1</td>
</tr>
<tr>
<td>x max</td>
<td>1.0</td>
</tr>
<tr>
<td>y min</td>
<td>-0.1</td>
</tr>
<tr>
<td>y max</td>
<td>1.0</td>
</tr>
</tbody>
</table>

2 From the Options menu, select Constants. Enter constant names, expressions, and descriptions (optional) according to the following table; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>COMMENTS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ti</td>
<td>500[degC]</td>
<td>Temperature on the inside of the cylinder</td>
</tr>
<tr>
<td>To</td>
<td>20[degC]</td>
<td>Temperature on the outside of the cylinder</td>
</tr>
</tbody>
</table>
GEOMETRY MODELING

1. From the Draw menu, choose Specify Objects>Circle.
2. Enter 0.8 as the Radius in the Circle dialog box and click OK to create the circle for the outside of the cylinder.
3. From the Draw menu, choose Specify Objects>Circle.
4. Enter 0.1 as the Radius in the Circle dialog box and click OK to create the circle for the inside of the cylinder.
5. Select both circles and click the Difference toolbar button to cut a hole in the large circle.
6. Click the Line toolbar button and click the left mouse button at (0, 0). Move the mouse to (1, 0) and click the left mouse button followed by the right mouse button to create a line.
7. From the Edit menu, select the line and select Copy.
8. From the Edit menu, select Paste. Click OK to use the default settings and close the Paste dialog box.
9. Click the Rotate toolbar button to open the Rotate dialog box.
10. Enter 30 as the rotation angle and click OK.
11. Click the Line toolbar button and click the left mouse button at the right end of the first line. Move the mouse to the right end of the rotated line and click the left mouse button followed by the right mouse button to create a third line.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>COMMENTS</th>
</tr>
</thead>
<tbody>
<tr>
<td>ri</td>
<td>0.1[m]</td>
<td>Inside radius of the cylinder</td>
</tr>
<tr>
<td>ro</td>
<td>0.8[m]</td>
<td>Outside radius of the cylinder</td>
</tr>
<tr>
<td>K</td>
<td>(Ti-To)/log(ro/ri)</td>
<td>Constant used in analytical strain temperature expression</td>
</tr>
</tbody>
</table>
12. Select all three lines drawn and click the **Coerce to Solid** button on the Draw toolbar.

13. Select all objects and click the **Intersection** button on the Draw toolbar.

14. Click the **Zoom Extents** button on the Main toolbar to look at the finished geometry.

---

**PHYSICS SETTINGS**

*Boundary Settings*

Constrain the symmetry edges in the normal direction. Specify the internal and external pressure.

1. From the **Physics** menu, select **Boundary Settings**.

2. Specify boundary settings according to the following tables; when done, click **OK**.

<table>
<thead>
<tr>
<th>BOUNDARIES 1, 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page</td>
</tr>
<tr>
<td>------</td>
</tr>
<tr>
<td><strong>BOUNDARY 3</strong></td>
</tr>
<tr>
<td><strong>BOUNDARY 4</strong></td>
</tr>
</tbody>
</table>
Subdomain Settings
Specify the material properties and thermal loading of the cylinder slice.

1. From the **Physics** menu, select **Subdomain Settings**.
2. Specify subdomain settings according to the following table; when done, click **OK**.

<table>
<thead>
<tr>
<th></th>
<th><strong>BOUNDARY 3</strong></th>
<th></th>
<th><strong>BOUNDARY 4</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>( F_{n} )</td>
<td>(-5\times10^{7})</td>
<td>( F_{n} )</td>
<td>(-2\times10^{7})</td>
</tr>
<tr>
<td>Load def.</td>
<td>force/area</td>
<td>Load def.</td>
<td>force/area</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th></th>
<th><strong>SUBDOMAIN 1</strong></th>
<th><strong>SUBDOMAIN 1</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Page</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Material model</td>
<td>Isotropic</td>
<td>Include thermal expansion</td>
</tr>
<tr>
<td>( E )</td>
<td>(2.1\times10^{11})</td>
<td>Temp</td>
</tr>
<tr>
<td>( \nu )</td>
<td>0.3</td>
<td>Tempref</td>
</tr>
</tbody>
</table>
MESH GENERATION
1. From the Mesh menu, select Free Mesh Parameters.
2. Click the Custom mesh size button.
3. Type 0.01 in the Maximum element size edit field and click OK.
4. Click the Initialize Mesh toolbar button to create and plot the mesh.
COMPUTING THE SOLUTION
Click the Solve toolbar button on the Main toolbar to compute the solution.

POSTPROCESSING AND VISUALIZATION
Look at the stress levels on the inside and outside of the cylinder and compare with the analytical values.

View the $\sigma_x$ normal stress in a surface plot.

1 Select Plot Parameters from the Postprocessing menu.
2 Click the Surface tab, and select Plane Strain$>$sx normal stress global sys. from the Predefined quantities list under Surface Data and click OK.
In-Plane Framework with Discrete Mass and Mass Moment of Inertia

Introduction

In the following example you build and solve a 2D beam model using the In-Plane Euler Beam application mode. This model describes the eigenfrequency analysis of a simple geometry. A point mass and point mass moment of inertia are used in the model. The two first eigenfrequencies are compared with the values given by an analytical expression.

Model Definition

The geometry consists of a frame with one horizontal and one vertical member. The cross section of both members has an area, \( A \), and an area moment of inertia, \( I \). The length of each member is \( L \) and Young’s modulus is \( E \). A point mass \( m \) is added at the middle of the horizontal member and a point mass moment of inertia \( J \) at the corner (see the figure below).

\[ J = m r^2 \]

\[ E I \]

\[ m \]

\[ L \]

\[ y \]

\[ x \]
**Geometry**
- Framework member lengths, \( L = 1 \) m.
- The framework members has a square cross section with a side length of 0.03 m giving an area of \( A = 9 \times 10^{-4} \) m\(^2\) and an area moment of inertia of \( I = 0.03^4/12 \) m\(^4\).

**Material**
Young’s modulus, \( E = 200 \) GPa.

**Mass**
- Point mass \( m = 1000 \) kg.
- Point mass moment of inertia \( J = mr^2 \) where \( r \) is chosen as \( L/4 \).

**Constraints**
The beam is pinned at \( x = 0, y = 0 \) and \( x = 1, y = 1 \), meaning that the displacements are constrained whereas the rotational degrees of freedom are free.

**Results and Discussion**
The analytical values for the two first eigenfrequencies \( f_{e1} \) and \( f_{e2} \) are given by:

\[
\omega_{e1}^2 = \frac{48EI}{mL^3}
\]

\[
\omega_{e2}^2 = \frac{48 \cdot 32EI}{7mL^3}
\]

and

\[
f_{e1} = \frac{\omega_{e1}}{2\pi}
\]

\[
f_{e2} = \frac{\omega_{e2}}{2\pi}
\]

where \( \omega \) is the angular frequency.
The following table shows a comparison between the eigenfrequencies calculated with COMSOL Multiphysics and the analytical values.

<table>
<thead>
<tr>
<th>EIGENMODE</th>
<th>COMSOL MULTIPHYSICS</th>
<th>ANALYTICAL</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>4.05 Hz</td>
<td>4.05 Hz</td>
</tr>
<tr>
<td>2</td>
<td>8.65 Hz</td>
<td>8.66 Hz</td>
</tr>
</tbody>
</table>
COMSOL plots visualizing the two eigenmodes are shown below.

**Figure 2-11:** First eigenmode.

**Figure 2-12:** Second eigenmode.
Model Library path: Structural_Mechanics_Module/Benchmark_Models/in-plane_framework

MODEL NAVIGATOR
1 Select 2D in the Space dimension list on the New page in the Model Navigator.
2 Select Structural Mechanics Module>In-Plane Euler Beam and click OK.

GEOMETRY MODELING
Two lines and an extra point at the middle of the horizontal member is drawn.

1 Click the Line button on the Draw toolbar.
2 Draw a line from \(x = 0, y = 0\) to \(x = 0, y = 1\) by clicking on the left mouse button at these coordinates. End the line by clicking on the right mouse button.
3 Draw a second line from \(x = 0, y = 1\) to \(x = 1, y = 1\).
4 Click the Point button on the Draw toolbar and place a point at \(x = 0.5, y = 1\) (to do so, you may have to change the grid spacing to 0.1).
OPTIONS AND SETTINGS

1. From the Options menu, choose Constants.

2. Enter the following constant names, expressions, and descriptions (optional); when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>E</td>
<td>2e11[Pa]</td>
<td>Young's modulus</td>
</tr>
<tr>
<td>I</td>
<td>(0.03[m])^4/12</td>
<td>Area moment of inertia</td>
</tr>
<tr>
<td>L</td>
<td>1[m]</td>
<td>Framework member length</td>
</tr>
<tr>
<td>m</td>
<td>1000[kg]</td>
<td>Point mass</td>
</tr>
<tr>
<td>r</td>
<td>L/4</td>
<td>Point mass radius</td>
</tr>
<tr>
<td>J</td>
<td>m*r^2</td>
<td>Point mass moment of inertia</td>
</tr>
<tr>
<td>A</td>
<td>0.03[m]*0.03[m]</td>
<td>Cross-sectional area</td>
</tr>
<tr>
<td>w1</td>
<td>sqrt(48<em>E</em>I/(m*L^3))</td>
<td>Angular frequency, eigenfrequency 1</td>
</tr>
<tr>
<td>w2</td>
<td>sqrt(48<em>32</em>E<em>I/(7</em>m*L^3))</td>
<td>Angular frequency, eigenfrequency 2</td>
</tr>
<tr>
<td>f1</td>
<td>w1/(2*pi)</td>
<td>Eigenfrequency 1</td>
</tr>
<tr>
<td>f2</td>
<td>w2/(2*pi)</td>
<td>Eigenfrequency 2</td>
</tr>
</tbody>
</table>
**PHYSICS SETTINGS**

*Point Settings*

Constrain the x and y-displacements at the beam ends.

1. From the *Physics* menu, select *Point Settings*.

2. Specify constraints on the *Constraint* page according to the following table:

<table>
<thead>
<tr>
<th>POINTS 1, 4</th>
<th>Constraint</th>
<th>Constraint condition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page</td>
<td>Constraint</td>
<td>Pinned</td>
</tr>
</tbody>
</table>

3. Specify the following mass properties on the *Mass* page:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>POINT 2</th>
<th>POINT 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page</td>
<td>Mass</td>
<td>Mass</td>
</tr>
<tr>
<td>Quantity</td>
<td>Mass moment of inertia about z-axis</td>
<td>Mass material</td>
</tr>
<tr>
<td>Expression</td>
<td>$J$</td>
<td>$m$</td>
</tr>
</tbody>
</table>
Boundary Settings
Specify the material and cross-section properties of the framework members:

1. From the Physics menu, select **Boundary Settings**.
2. Specify boundary settings according to the following table; when done, click **OK**.

<table>
<thead>
<tr>
<th>BOUNDARIES 1–3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page</td>
</tr>
<tr>
<td>E</td>
</tr>
<tr>
<td>Iyx</td>
</tr>
</tbody>
</table>

![Image of Boundary Settings window]
MESH GENERATION
Click the Initialize Mesh button on the Main toolbar to mesh the geometry.

COMPUTING THE SOLUTION
1 Click the Solver Parameters button on the Main toolbar.
2 Select Eigenfrequency from the Analysis list.
3 Enter 2 in the Desired number of eigenfrequencies edit field; then click OK.
4 Click the Solve button on the Main toolbar.

POSTPROCESSING AND VISUALIZATION
Plot the two first eigenmodes:
1 Select Plot Parameters from the Postprocessing menu and go to General page.
2 Clear the Surface check box and select the Boundary and Deformed shape check boxes in the Plot type area.
3 Select the first eigenmode/eigenfrequency from Eigenfrequency list.
4 Click the Boundary tab.
5 Select Total displacement from the Predefined quantities list.
6 Click Apply to view the plot (see Figure 2-11).
7 Select the second eigenmode/eigenfrequency from the Eigenfrequency list on the General page and click OK (see Figure 2-12).
3D Thermally Loaded Beam

Introduction

In the following example you build and solve a 3D beam model using the 3D Euler Beam application mode. This model shows how to model a thermally induced deformation of a beam. Temperature differences are applied across the top and bottom surfaces as well as the left and right surfaces of the beam. The deformation is compared with the value given by a theoretical solution given in Ref. 1.

Model Definition

GEOMETRY
The geometry consists of one beam. The beam cross-section area is $A$ and the area moment of inertia $I$. The beam is $L$ long, and the Young’s modulus is $E$.

- Beam length $L = 3$ m.
- The beam has a square cross section with a side length of 0.04 m giving an area of $A = 1.6 \cdot 10^{-3}$ m$^2$ and an area moment of inertia of $I = 0.04^4/12$ m$^4$.

MATERIAL

- Young’s modulus $E = 210$ GPa.
- Poisson’s ratio $\nu = 0.3$.
- Thermal expansion coefficient $\alpha = 11 \cdot 10^{-6}/^\circ$C.

CONSTRAINTS

- Displacements in $x$, $y$, and $z$ direction are constrained to zero at $x = 0$, $y = 0$, and $z = 0$.
- Rotation around $x$-axis are constrained to zero at $x = 0$, $y = 0$, and $z = 0$ to prevent singular rotational degrees of freedom.
- Displacements in the $x$ and $y$ direction are constrained to zero at $x = 3$, $y = 0$, and $z = 0$.

THERMAL LOAD

Figure 2-13 on page 65 shows the surface temperature at each corner of the cross section. The temperature varies linearly between each corner. The deformation caused
by this temperature distribution is modeled by specifying the temperature differences across the beam in the local $y$ and $z$ directions.

$$w = \frac{\alpha L^2}{8t} (T_2 - T_1)$$

where $t$ is the depth of the beam (0.04 m), $T_2$ is the temperature at the top and $T_1$ at the bottom.

The following table shows a comparison of the maximum global $z$-displacement, calculated with COMSOL Multiphysics, with the theoretical solution.

<table>
<thead>
<tr>
<th>$T$</th>
<th>COMSOL MULTIPHYSICS (MAX)</th>
<th>ANALYTICAL</th>
</tr>
</thead>
<tbody>
<tr>
<td>$150^\circ C$</td>
<td>15.5 mm</td>
<td>15.5 mm</td>
</tr>
<tr>
<td>$200^\circ C$</td>
<td>15.5 mm</td>
<td>15.5 mm</td>
</tr>
<tr>
<td>$200^\circ C$</td>
<td>15.5 mm</td>
<td>15.5 mm</td>
</tr>
</tbody>
</table>

Figure 2-14 shows the global $z$-displacement along the beam.
The analytical values for the maximum total camber can be calculated by:

$$\delta = \sqrt{w^2 + v^2}$$

where $v$ is the maximum deformation in the global $y$ direction which is calculated in the same way as $w$.

A comparison of the camber calculated with COMSOL Multiphysics and the analytical values are shown in the table below.

<table>
<thead>
<tr>
<th>TOTAL CAMBER</th>
<th>COMSOL MULTIPHYSICS</th>
<th>ANALYTICAL</th>
</tr>
</thead>
<tbody>
<tr>
<td>22 mm</td>
<td>21.9 mm</td>
<td></td>
</tr>
</tbody>
</table>

Figure 2-15 shows the total camber along the beam.
Figure 2-15: Camber along the beam

Reference

Model Library path: Structural Mechanics Module/Benchmark Models/thermally_loaded_beam

Modeling Using the Graphical User Interface

MODEL NAVIGATOR
1. Select 3D in the Space dimension list on the New page in the Model Navigator.
2. Select Structural Mechanics Module>3D Euler Beam>Static analysis and click OK.
GEOMETRY MODELING

1. Select **Line** from the **Draw** menu.

2. Enter line coordinates according to the figure below and click **OK**.
**PHYSICS SETTINGS**

*Point Settings*

Constrain the \(x\), \(y\), and \(z\)-displacements at the beam ends.

1. From the *Physics* menu, select *Point Settings*.
2. Specify constraints on the *Constraint* page according to the following table; when done, click *OK*.

<table>
<thead>
<tr>
<th>Point 1</th>
<th>Point 2</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Constraint</strong></td>
<td><strong>Constraint</strong></td>
</tr>
<tr>
<td>Prescribed displacement</td>
<td>Prescribed displacement</td>
</tr>
<tr>
<td>(R_x)</td>
<td>0</td>
</tr>
<tr>
<td>(R_y)</td>
<td>0</td>
</tr>
<tr>
<td>(R_z)</td>
<td>0</td>
</tr>
<tr>
<td>(R_{thx})</td>
<td>0</td>
</tr>
</tbody>
</table>
Edge Settings
Specify the material and cross-section properties of the beam.

1 From the Physics menu, select Edge Settings.
2 Specify edge settings according to the following table; when done, click OK.

<table>
<thead>
<tr>
<th>EDGE 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page</td>
</tr>
<tr>
<td>Quantity</td>
</tr>
<tr>
<td>E</td>
</tr>
<tr>
<td>ν</td>
</tr>
<tr>
<td>α</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Page</th>
<th>Cross-Section</th>
</tr>
</thead>
<tbody>
<tr>
<td>Quantity</td>
<td>Expression</td>
</tr>
<tr>
<td>A</td>
<td>0.04*0.04</td>
</tr>
<tr>
<td>Iyy</td>
<td>0.04^4/12</td>
</tr>
<tr>
<td>Izz</td>
<td>0.04^4/12</td>
</tr>
<tr>
<td>heighty</td>
<td>0.04</td>
</tr>
<tr>
<td>heightz</td>
<td>0.04</td>
</tr>
</tbody>
</table>
3D Thermally Loaded Beam

<table>
<thead>
<tr>
<th>Edge 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page</td>
</tr>
<tr>
<td>Load</td>
</tr>
<tr>
<td>Include thermal expansion</td>
</tr>
<tr>
<td>Temp</td>
</tr>
<tr>
<td>Tempref</td>
</tr>
<tr>
<td>dTy</td>
</tr>
<tr>
<td>dTz</td>
</tr>
</tbody>
</table>
MESH GENERATION
Use the default mesh settings.
Click the Initialize Mesh button on the Main toolbar to mesh the geometry.

COMPUTING THE SOLUTION
Click the Solve button on the Main toolbar.

POSTPROCESSING AND VISUALIZATION
Plot the global displacement in the z direction and the total displacement using a domain plot.

1 From the Postprocessing menu, select Domain Plot Parameters.
2 Click the Line/Extrusion tab.
3 Select Edge 1 from the Edge selection list and select z-displacement from the Predefined quantities list.
4 Click Apply; see Figure 2-14.
5 Enter sqrt(w^2+v^2) in the Expression edit field and click OK (see Figure 2-15).
In-Plane Truss

Introduction

In the following example you build and solve a simple 2D truss model using the In-Plane Truss application mode. This model calculates the deformation of a simple geometry. The example is based on problem 11.1 in Aircraft Structures for Engineering Students by T.H.G Megson (Ref. 1). The results are compared with the analytical results given in Ref. 1.

Model Definition

The geometry consists of a square symmetrical truss built up by five members. All trusses have the same cross-sectional area $A$. The side length is $L$ and the Young’s modulus is $E$.

![Figure 2-16: The truss geometry.](image)

**GEOMETRY**
- Truss side length, $L = 2$ m
- The truss members have a circular cross section with a radius of 0.05 m

**MATERIAL**
Aluminum: Young’s modulus, $E = 70$ GPa
CONSTRAINTS
Displacements in both directions are constrained at \( a \) and \( b \).

LOAD
A vertical force \( F \) of 50 kN is applied at the bottom corner.

Results and Discussion
The following table shows a comparison between the results calculated with the Structural Mechanics Module and the analytical results from Ref. 1.

<table>
<thead>
<tr>
<th>RESULT</th>
<th>COMSOL MULTIPHYSICS</th>
<th>REF. 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Displacement at ( d )</td>
<td>-5.15E-4 m</td>
<td>-5.15E-4 m</td>
</tr>
<tr>
<td>Displacement at ( c )</td>
<td>-2.13E-4 m</td>
<td>-2.13E-4 m</td>
</tr>
<tr>
<td>Axial force in member ( ac=bc )</td>
<td>-10.4 kN</td>
<td>-10.4 kN</td>
</tr>
<tr>
<td>Axial force in member ( ad=bd )</td>
<td>25.0 kN</td>
<td>25.0 kN</td>
</tr>
<tr>
<td>Axial force in member ( cd )</td>
<td>14.6 kN</td>
<td>14.6 kN</td>
</tr>
</tbody>
</table>

The results are in total agreement.
Figure 2-11 shows a plot visualizing the deformed geometry together with the axial forces in the trusses.

Figure 2-17: Deformed geometry and axial forces.

Reference


Model Library path: Structural_Mechanics_Module/Benchmark_Models/in-plane_truss

**Modeling Using the Graphical User Interface**

**MODEL NAVIGATOR**

1. Select **2D** in the **Space dimension** list on the **New** page in the **Model Navigator**.
2 Select **Structural Mechanics Module>In-Plane Truss**.

![Model Navigator](image)

3 Click **OK**.

**OPTIONS AND SETTINGS**

1 From the **Options** menu, choose **Axes/Grid Settings**.

2 Set axis and grid settings according to the following table (clear the **Auto** check box before entering the grid spacing); when done, click **OK**.

<table>
<thead>
<tr>
<th>AXIS</th>
<th>GRID</th>
</tr>
</thead>
<tbody>
<tr>
<td>x min</td>
<td>x spacing 2</td>
</tr>
<tr>
<td>x max</td>
<td>Extra x -</td>
</tr>
<tr>
<td>y min</td>
<td>y spacing 2</td>
</tr>
<tr>
<td>y max</td>
<td>Extra y -</td>
</tr>
</tbody>
</table>

**GEOMETRY MODELING**

1 Click the **Line** button on the Draw toolbar.

2 Double-click the **SOLID** button in the Status bar to turn off the solid feature when drawing the lines.
3 Draw a line from $(0, 0)$ through $(0, 2)$, $(2, 2)$, $(2, 0)$, $(0, 0)$, and $(2, 2)$ by clicking on the left mouse button at these coordinates. End the line by clicking on the right mouse button.

4 Click the **Rotate** button on the Draw toolbar to open the **Rotate** dialog box.
5 Enter 45 as the rotating angle and click **OK** to rotate the truss.

6 Click the **Zoom Extents** button on the Main toolbar.
PHYSICS SETTINGS

One helpful feature when specifying loads and constraints are symbols. Use this feature to see where you have specified constraints and applied forces.

1. From the Options menu, select Preferences.

2. On the Visualization page, select All domain types from the Show list in the Symbols area.

3. Select the Automatically update check box and click OK.
Point Settings
Constrain the $x$- and $y$-displacements at the left and right corners of the truss.

1. Select **Point Settings** from the **Physics** menu.
2. Specify constraints on the **Constraint** page according to the following table:

<table>
<thead>
<tr>
<th>Points</th>
<th>Constraint condition</th>
</tr>
</thead>
<tbody>
<tr>
<td>1, 4</td>
<td>Pinned</td>
</tr>
</tbody>
</table>
Specify the vertical force at the bottom corner:

1. Click the **Load** tab in the **Point Settings** dialog box.
2. Select Point 2 and enter -50000 in the $F_y$ edit field.

3. Click **OK** to close the **Point Settings** dialog box.

**Boundary Settings**

Specify the material and cross-section properties of the truss members:

1. From the **Physics** menu, select **Boundary Settings**.
2. Select all five boundaries.
3. Click the **Load** button on the **Material** page to open the **Material/Coefficients Library** dialog box.
4 Select Aluminum from Basic Material Properties in the Materials list and click OK.
5 On the Cross Section page, type $\pi/4 \times 0.05^2$ in the Cross section area (A) edit field.

6 Click OK to close the Boundary Settings dialog box.

**Mesh Generation**

When using the default option (the Constrain edge to be straight (truss) button is selected on the Material page in the Boundary Settings dialog box) the mesh is not critical. The Allow edge to have sag (cable) option makes the mesh critical because the internal nodes along the boundary become singular when they do not have any
stiffness perpendicular to the boundary. You can solve this by using a very coarse mesh with no internal nodes along the boundaries. For more information, see “Straight Edge Option” on page 301 of the Structural Mechanics Module User’s Guide.

In this model, use the default mesh settings, as the model uses the default option for a straight edge (the Constrain edge to be straight (truss) button is selected on the Material page in the Boundary Settings dialog box).

Click the Initialize Mesh toolbar button to mesh the geometry.

**COMPUTING THE SOLUTION**

Click the Solve button on the Main toolbar to start the analysis and compute the solution.

**POSTPROCESSING AND VISUALIZATION**

Plot the deformed geometry together with the axial forces in the truss members.

1. From the Postprocessing menu, select Plot Parameters.
2. On the General page, select the Deformed shape check box in the Plot type area.
3. On the Boundary page, select Axial force from the Predefined quantities list.
4 Click **OK** to close the dialog box and view the plot.
Scordelis-Lo Roof Shell Benchmark

In the following example you build and solve a 3D shell model using the Shell application mode. This model is a widely used benchmark model denoted the Scordelis-Lo roof. The computed maximum $z$-deformation is compared with the value given in Ref. 1.

Model Definition

**Geometry**
The geometry consists of a curved face as depicted in Figure 2-18. Only one quarter is analyzed due to symmetry.

![Figure 2-18: The Scordelis-Lo roof shell benchmark geometry.](image)

- Roof length $2L = 50$ m
- Roof radius $R = 25$ m.
MATERIAL
• Isotropic material with Young’s modulus set to $E = 4.32 \times 10^8 \text{ N/m}^2$.
• Poisson’s ratio $\nu = 0.0$.

CONSTRAINTS
• The outer straight edge is free.
• The outer curved edge of the model geometry is constrained in the $y$ and $z$ directions.
• The straight symmetry edge on the top of the roof has symmetry edge constraints: translation in the $y$ direction is constrained as are rotations about the $x$-axis and $z$-axis.
• The curved symmetry edge also has symmetry constraints: translation in the $x$ direction is constrained as are rotations about the $y$-axis and $z$-axis.

LOAD
A force per area unit of $-90 \text{ N/m}^2$ in the $z$ direction is applied on the surface.
Results and Discussion

The maximum deformation in the global $z$ direction with the default mesh settings is depicted in Figure 2-19.

*Figure 2-19: $z$-displacement with 242 elements.*
The reference solution quoted in Ref. 1 for the midside vertical displacement is 0.3086 m. The FEM solution converges toward 0.302 m with a refined mesh; see Figure 2-20 and Figure 2-21.

Figure 2-20: z-displacement with 832 elements.
Figure 2-21: z-displacement with 1942 elements

This value (0.302) is in fact observed in other published benchmarks treating this problem as the value that this problem converges toward.

Reference


Model Library path: Structural_Mechanics_Module/Benchmark_Models/scordelis_lo_roof

Modeling Using the Graphical User Interface

MODEL NAVIGATOR

1. Select 3D from the Space dimension list on the New page in the Model Navigator.
2 Select **Structural Mechanics Module>Shell>Static analysis**, then click **OK**.

---

**GEOMETRY MODELING**

1. From the **Draw** menu, select **Work-Plane Settings**.
2. Click **OK** in the **Work-Plane Settings** dialog box. This gives you the default work plane.
3. Click the **Line** button and draw a line from \((0, 25)\) to \((25, 25)\).
4. Select **Revolve** from the **Draw** menu.
5. Type \(90\) in the \(\alpha_1\) edit field.
6. Type \(90+40\) in the \(\alpha_2\) edit field.
7. Type \(1\) in the **Second point x** edit field.
8. Type \(0\) in the **Second point y** edit field.
9. Click **OK**.

---

**PHYSICS SETTINGS**

**Edge Settings**

1. From the **Physics** menu, select **Edge Settings**.
2 Specify constraints on the **Constraint** page according to the following table; when done, click **OK**.

<table>
<thead>
<tr>
<th>Edge</th>
<th>Constraint condition</th>
<th>Constraint</th>
<th>Constraint</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edge 1</td>
<td>Prescribed displacement</td>
<td>x-z symmetry plane</td>
<td>y-z symmetry plane</td>
</tr>
<tr>
<td></td>
<td>$R_y$ = 0</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>$R_z$ = 0</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Constraint settings for Edge 1:
Constraint settings for Edge 3:

![Constraint settings for Edge 3](image1.png)

Constraint settings for Edge 4:

![Constraint settings for Edge 4](image2.png)

**Boundary Settings**
Specify the material properties and surface load in the **Boundary Settings** dialog box.

1. From the **Physics** menu, select **Boundary Settings**.
Specify boundary settings according to the following table; when done, click **OK**.

<table>
<thead>
<tr>
<th>Page</th>
<th>Material</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>E</td>
</tr>
<tr>
<td></td>
<td>ν</td>
</tr>
<tr>
<td></td>
<td>thickness</td>
</tr>
<tr>
<td>Load</td>
<td>F_z</td>
</tr>
</tbody>
</table>
MESH GENERATION
Use the default mesh settings. Click the Initialize Mesh button on the Main toolbar to mesh the geometry.

COMPUTING THE SOLUTION
Click the Solve button on the Main toolbar.

POSTPROCESSING AND VISUALIZATION
Plot the global displacement in the z direction and the deformed shape.

1. From the Postprocessing menu, select Plot Parameters.
2. Clear the Slice check box in the Plot type area on the General page.
3. Select the Deformed shape and Boundary check boxes in the Plot type area.
4. Click the Boundary tab.
5. Select z-displacement from the Predefined quantities list.
6. Click OK.
Check the convergence by solving the problem twice with different mesh refinements.

**MESH GENERATION**

1. From the Mesh menu, choose Free Mesh Parameters.
2. Select Finer from the Predefined mesh sizes list.
3. Click the Remesh button.
4. Click OK.
CHAPTER 2: BENCHMARK MODELS

COMPUTING THE SOLUTION

Click the Solve button on the Main toolbar.

MESH GENERATION

1. From the Mesh menu, choose Free Mesh Parameters.
2. Select Extra fine from the Predefined mesh sizes list.
3. Click the Remesh button.
4. Click OK.
COMPUTING THE SOLUTION

Click the Solve button on the Main toolbar.
Cylinder Roller Contact

Introduction

Consider an infinitely long steel cylinder resting on a flat aluminum foundation, where both structures are elastic. The cylinder is subjected to a point load along its top. The objective of this study is to find the contact pressure distribution and the length of contact between the foundation and the cylinder. An analytical solution exists, and this model includes a comparison against the COMSOL Multiphysics solution. This model is based on a NAFEMS benchmark (see Ref. 1).

Model Definition

This is clearly a plane strain problem and the Plane Strain application mode from the Structural Mechanics Module is thus a suitable (two-dimensional) application mode. The geometry is reduced to half of the geometry at the vertical symmetry axis due to symmetry reasons.

![Figure 2-22: Geometry in model](image)

The cylinder is subjected to a point load along its top with an intensity of 35 kN. Both the cylinder and block material are elastic, homogeneous, and isotropic.
The contact modeling method in this example does not include friction as described in Ref. 1. This model uses a contact pair, which is a straightforward way to implement a contact problem using the Structural Mechanics Module.

**Results and Discussion**

The deformed shape and the Von Mises stress distribution are depicted in Figure 2-23.

![Figure 2-23: Deformation and von Mises stress at the contact area.](image)

The analytical solution for the contact pressure as a function of the $x$-coordinate is given by

$$P = \frac{F_n E'}{2\pi R'} \times \left(1 - \left(\frac{x}{a}\right)^2\right)$$

$$a = \frac{8F_n R'}{\pi E'}$$

where $F_n$ is the applied load (load/length), $E'$ the combined elasticity modulus, $R'$ the combined radius, and $x$ is the $x$-axis coordinate.
The combined Young’s modulus and radius are defined as:

\[
E' = \frac{2E_1E_2}{E_2(1-v_1^2) + E_1(1-v_2^2)}
\]

\[
R' = \lim_{{R_1 \to \infty}} \frac{R_1R_2}{R_1 + R_2} = R_1
\]

In these equations, \(E_1\) and \(E_2\) are Young’s modulus of the roller and the block, respectively, and \(R_1\) is the radius of the roller.

This gives a contact length of 6.21 mm and a maximum contact pressure of 3585 MPa.

The contact pressure along the contact area for both the analytical and the COMSOL Multiphysics solution are depicted in Figure 2-24. The COMSOL Multiphysics solution is the solid line, the analytical result is the dashed line.

![Figure 2-24: Analytical pressure distribution and COMSOL Multiphysics solution (dashed).](image)

The maximum contact pressure obtained with COMSOL Multiphysics is 3581 MPa, which is in good agreement with the analytical solution.
The maximum contact length (equivalent to a null contact pressure) is evaluated at 6.31 mm.

References


Modeling Using COMSOL Multiphysics

The Structural Mechanics Module supports contact boundary conditions using contact pairs. The contact pair is defined by a master (contacting) boundary and a slave (contacted) boundary. The contact boundary pair comprises a flat boundary and a curved boundary. The flat boundary is defined as the master boundary and the curved boundary as the slave boundary.

Because contact is only present in a small area, a local mesh refinement is required. Due to the geometry shape, you use a free mesh for the cylinder domain and a mapped mesh for the aluminum block. The block geometry requires some modification in order to set up a refined mesh area.

This example assumes a nominal thickness (thickness = 1).

The selected length unit in this model is mm, so the MPa unit system, which is based on mm as the length unit, is a suitable unit system.

Model Library path: Structural_Mechanics_Module/Benchmark_Models/cylinder_roller_contact

Modeling Using the Graphical User Interface

MODEL NAVIGATOR

1 On the New page, select 2D from the Space dimension list.
2 Expand to the next submenu by clicking on Structural Mechanics Module>Plane Strain>Static analysis.
3 Click OK.
OPTIONS AND SETTINGS

1 From the Options menu select Constants and enter the following constant names, expressions, and descriptions (optional); when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>E1</td>
<td>70e3[MPa]</td>
<td>Block Young’s modulus</td>
</tr>
<tr>
<td>E2</td>
<td>210e3[MPa]</td>
<td>Cylinder Young’s modulus</td>
</tr>
<tr>
<td>nu</td>
<td>0.3</td>
<td>Poisson’s ratio</td>
</tr>
<tr>
<td>Fn</td>
<td>35[kN]</td>
<td>External load</td>
</tr>
<tr>
<td>E_star</td>
<td>2<em>E1</em>E2/((E1+E2)*(1-nu^2))</td>
<td>Combined Young’s modulus</td>
</tr>
<tr>
<td>R</td>
<td>50[mm]</td>
<td>Combined radius</td>
</tr>
<tr>
<td>th</td>
<td>1[mm]</td>
<td>Thickness</td>
</tr>
<tr>
<td>lc</td>
<td>10[mm]</td>
<td>Estimated contact length</td>
</tr>
<tr>
<td>a</td>
<td>sqrt(8<em>Fn</em>R/(pi<em>E_star</em>th))</td>
<td>Contact length</td>
</tr>
<tr>
<td>pmax</td>
<td>sqrt(Fn<em>E_star/(2</em>pi<em>R</em>th))</td>
<td>Maximum contact pressure</td>
</tr>
</tbody>
</table>

GEOMETRY MODELING

1 In the Draw menu select Use Assembly.

1 Shift-click the Ellipse/Circle (Centered) button on the Draw toolbar, then set the Radius to 50 and the position of the center to (0, 50). Click OK.

2 Shift-click the Rectangle/Square button on the Draw toolbar and set both Width and Height to 200. Set the corner position to (−100, −200). Click OK.

3 Click the Zoom Extents button on the Main toolbar.

4 Draw a second rectangle, this one of width 100 and height 300 with the lower left corner at (−100, −200).

5 Click the Create Composite Object button on the Draw toolbar and type the expression (C1+R1)-R2 in the Set formula edit field. Click OK.

6 Choose Specify Objects>Square from the Draw menu to create two squares with the following specifications:

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>SQUARE 1</th>
<th>SQUARE 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>100</td>
<td>25</td>
</tr>
<tr>
<td>Base</td>
<td>Corner</td>
<td>Corner</td>
</tr>
<tr>
<td>x</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>y</td>
<td>−100</td>
<td>−25</td>
</tr>
</tbody>
</table>
7 Choose Specify Objects>Line from the Draw menu and create a line between grid point (25, −25) and grid point (100, −100).

The mesh needs to be refined in the contact area. To do this in an efficient way, divide the curved boundary into two separate boundaries. To achieve this, add a point along the curved boundary.

8 Draw a Point at the origin (0, 0).

9 Click the Rotate button on the Draw toolbar, then set the Rotation angle to 10 degrees and the y-coordinate of the Center point to 50. Click OK.

10 Select all domains (press Ctrl+A), then click the Split Object button on the Draw toolbar.

11 Select all the geometry objects of the top part (CO3 and PT2), then click the Coerce to Solid button on the Draw toolbar.

12 Select all the geometry objects of the bottom part (CO2, CO4, CO5, and B2), then click the Coerce to Solid button.

### PHYSICS SETTINGS

**Model Settings**

1 In the Physics menu, go to Model Settings and select MPa from the Base unit system list.
2 Click **OK**.

**Subdomain Settings**

1 Choose **Physics > Subdomain Settings** to specify the subdomain settings for the Plane Strain application mode according to the following table:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAINS 1–4</th>
<th>SUBDOMAIN 5</th>
</tr>
</thead>
<tbody>
<tr>
<td>E</td>
<td>E1</td>
<td>E2</td>
</tr>
<tr>
<td>ν</td>
<td>νu</td>
<td>νu</td>
</tr>
</tbody>
</table>

The nominal thickness is used; make sure that **thickness** is set to 1 for all subdomains.

2 Click **OK**.

**Boundary Conditions**

1 Choose **Physics > Boundary Settings** to open the **Boundary Settings** dialog box; then specify the following constraint conditions:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 1, 3, 5, 13</th>
<th>BOUNDARY 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constraint condition</td>
<td>Symmetry plane</td>
<td>Fixed</td>
</tr>
</tbody>
</table>

The other boundaries are free, which is the default boundary condition.

2 Click **OK**.

**Point Settings**

The external load is a point load. Due to the symmetry, apply one half of the total force on the studied geometry:

1 From the **Physics** menu select **Point Settings**.
2 In the **Point Settings** dialog box select Point 11.
3 Click the **Load** tab, and then type \(-F_n/2\) in the \(F_y\) edit field.
4 Click **OK**.

**Contact Pairs**

Define a contact pair for Boundaries 7 and 14. A general advice is to set the curved surface as slave (contacting) boundary and the straight surface as master (contacted) boundary. The top boundary (number 7) is set to slave boundary and the bottom boundary (number 14) as master boundary in this model. The steel block is also the correct master surface because it has a high stiffness.

1 From the **Physics** menu select **Contact Pairs**.
2 In the **Contact Pairs** dialog box, click **New**.
3 In the **Master boundaries** list, select Boundary 7.

4 Click the **Check Selected** button below the **Master boundaries** list.

5 In the **Slave boundaries** list select Boundary 14.

6 Click the **Check Selected** button below the **Slave boundaries** list.

7 Click **OK**.

   The next step is to specify the contact parameters in the **Boundary Settings** dialog box.

8 In the **Boundary Settings** dialog box, click the **Pairs** tab, and select **Pair 1 (contact)**.

---

**Note:** To reduce the number of iteration steps and improve convergence, it is good practice to set an initial contact pressure as close to the solution as possible. A good approximation is to use the value of the external pressure, in this case the external point load divided by an estimated contact length and the thickness. In this model you need to set an initial contact pressure to make the model stable for the initial conditions.

9 On the **Contact, Initial** page, type \( \frac{(F_n/2)}{(l \cdot c \cdot th)} \) in the **Contact pressure** edit field (the division by 2 is to account for the symmetry).

10 Click **OK**.

---

**Mesh Generation**

You can achieve an accurate contact pressure by refining the mesh around the contact zone. A general recommendation is to have at least 10 contacting nodes along the slave contact boundary. Apply an element size of 0.59 mm for the cylinder and 1.5 mm for the block. Due to the geometry shape, use a free mesh (triangular elements) for the cylinder and a mapped mesh (quadrilateral elements) for the block.

1 Open the **Free Mesh Parameters** dialog box by selecting **Free Mesh Parameters** from the **Mesh** menu.

2 Click the **Boundary** tab. Select Boundary 14, then type 0.59 in the **Maximum element size** edit field.

3 Click the **Subdomain** tab, then select Subdomain 5. Click **OK**.

4 Click the **Mesh Selected (Free)** button on the Mesh toolbar.

   In the message log you can see that the free mesh is composed of around 360 elements.
5 Open the **Mapped Mesh Parameters** dialog box by selecting **Mapped Mesh Parameters** from the **Mesh** menu.

6 On the **Boundary** page, select Boundaries 3, 5, and 7. Then select **Constrained edge element distribution** and type 20 in the **Number of edge elements** edit field.

7 On the **Boundary** page, select Boundary 1. Then select the **Constrained edge element distribution** and type 10 in the **Number of edge elements** edit field. Click **Apply**.

8 Go to **Subdomain** page and select Subdomains 1, 2, 3, and 4.

9 Click the **Mesh Selected** button. Click **OK**.

The information in the message log shows that the total mesh consists of approximately 1750 elements (roughly 360 elements for the free mesh and 1400 elements for the mapped mesh).

### COMPUTING THE SOLUTION

Click the **Solve** button on the Main toolbar.

### POSTPROCESSING AND VISUALIZATION

The default plot shows the von Mises stress. Because of the point-load constraint, a stress concentration develops on the top of the cylinder. Due to the automatic plot-range settings, the stress around the contact surface looks almost identical.
1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, select the Surface and Boundary check boxes and clear the Geometry edges check box in the Plot type area.

3 On the Surface page, click the Range button. In the Color Range dialog box clear the Auto check box, then type 2500 in the Max edit field. Click OK.

4 On the Boundary page, type 1 in the Expression edit field on the Boundary Data tab. Click the Uniform color option button in the Boundary color area, then click the Color button and select black. Click OK.

5 Click OK.

Zoom in on the contact area to get the following plot:

The instructions below show how to create a line plot to compare the analytical contact pressure distribution with the contact pressure calculated by the model.

1 Choose Options>Expressions>Boundary Expressions and select Boundary 14. Enter the following constant names and expressions:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>theta</td>
<td>atan2(y-50,x)+pi/2</td>
</tr>
</tbody>
</table>
2 Click OK.

3 In the Solve menu, select Update Model.
   You can now plot the analytical expression of the contact pressure.

4 Choose Postprocessing>Domain Plot Parameters.

5 Click the Line/Extrusion tab, then from the Predefined quantities list select Contact pressure, contact Pair 1.

6 Select Boundary 14 (the slave boundary), then click Apply to generate a plot of the contact pressure calculated in the model.

7 In the Expression edit field type p_analytical.

8 Click the Line Settings button, then select Color in the Line color list, and Dashed line in the Line style list. Click OK.

9 Click the General tab, then select Keep current plot.

10 Click the Title/Axis button and type Contact pressure vs. arc length (blue: calculated, red: analytical) in the Title edit field. In the First axis label edit field type mm and in the Second axis label edit field type MPa. Click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>x_local</td>
<td>sqrt((x^2+(y-50)^2)*theta)</td>
</tr>
<tr>
<td>p_analytical</td>
<td>pmax*sqrt(1-(x_local/a)^2)</td>
</tr>
</tbody>
</table>
II Click **OK** in **Domain Plot Parameters** dialog box to generate the plot of the analytical expression for the contact pressure.
Eigenfrequency Analysis of a Free Cylinder

Introduction

In the following example you will build and solve an axial symmetric model using the Axial Symmetry, Stress-Strain application mode.

This model calculates the eigenfrequencies and mode shapes of an axisymmetric free cylinder. The model is taken from NAFEMS Free Vibration Benchmarks (Ref. 1). The eigenfrequencies are compared with the values given in the benchmark report.

Model Definition

The model is NAFEMS Test No 41, “Free Cylinder” described on page 41 in NAFEMS Free Vibration Benchmarks, Volume 3 (Ref. 1). The Benchmark tests the capability to handle rigid body modes and close eigenfrequencies.
The cylinder is 10 m high with an inner radius of 1.8 m and a thickness of 0.4 m.

MATERIAL
Isotropic material with $E = 2.0 \cdot 10^{11}$ Pa and $\nu = 0.3$.

LOADS
In an eigenfrequency analysis loads are not needed.

CONSTRAINTS
No constraints are applied because the cylinder is free.
Results

The rigid body mode with an eigenvalue close to zero is found. The eigenfrequencies are in close agreement with the target values from the NAFEMS Free Vibration Benchmarks (Ref. 1).

<table>
<thead>
<tr>
<th>EIGENFREQUENCY</th>
<th>COMSOL</th>
<th>TARGET (REF. 1)</th>
</tr>
</thead>
<tbody>
<tr>
<td>$f_1$</td>
<td>0 Hz</td>
<td>0 Hz</td>
</tr>
<tr>
<td>$f_2$</td>
<td>243.50 Hz</td>
<td>243.53 Hz</td>
</tr>
<tr>
<td>$f_3$</td>
<td>377.44 Hz</td>
<td>377.41 Hz</td>
</tr>
<tr>
<td>$f_4$</td>
<td>394.30 Hz</td>
<td>394.11 Hz</td>
</tr>
<tr>
<td>$f_5$</td>
<td>398.00 Hz</td>
<td>397.72 Hz</td>
</tr>
<tr>
<td>$f_6$</td>
<td>405.75 Hz</td>
<td>405.28 Hz</td>
</tr>
</tbody>
</table>

The following plot shows the shape of the second eigenmode:

Reference

Model Library path: Structural_Mechanics_Module/Benchmark_Models/free_cylinder

Modeling Using the Graphical User Interface

MODEL NAVIGATOR
1. Select Axial symmetry (2D) in the Space dimension list on the New page in the Model Navigator.
2. Select Structural Mechanics Module>Axial Symmetry, Stress-Strain>Eigenfrequency analysis, then click OK.

OPTIONS AND SETTINGS
1. Select Axes/Grid Settings from the Options menu and give axis and grid settings according to the following table; when done, click OK.

<table>
<thead>
<tr>
<th>AXIS</th>
<th>GRID</th>
</tr>
</thead>
<tbody>
<tr>
<td>r min</td>
<td>-0.2</td>
</tr>
<tr>
<td>r max</td>
<td>2.4</td>
</tr>
<tr>
<td>r spacing</td>
<td>1</td>
</tr>
<tr>
<td>Extra r</td>
<td>1.8 2.2</td>
</tr>
</tbody>
</table>
GEOMETRY MODELING

1 Click the **Rectangle/Square** toolbar button and click the left mouse button at (1.8, 0) move the mouse to (2.2, 10.0) and click the left mouse button again to create the rectangle.

<table>
<thead>
<tr>
<th>AXIS</th>
<th>GRID</th>
</tr>
</thead>
<tbody>
<tr>
<td>z min</td>
<td>-0.2</td>
</tr>
<tr>
<td>z max</td>
<td>10.2</td>
</tr>
</tbody>
</table>

PHYSICS SETTINGS

**Boundary Settings**
No boundary conditions need to specified as the cylinder is free and without loads.

**Subdomain Settings**
Specify the material properties of the free cylinder.

1 From the **Physics** menu, select **Subdomain Settings**.
2 Specify subdomain settings according to the following table; when done, click OK.

<table>
<thead>
<tr>
<th>Page</th>
<th>Material model</th>
<th>Material model</th>
<th>E</th>
<th>2.0E11[Pa]</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td>ν</td>
<td>0.3</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>ρ</td>
<td>8000[kg/m^3]</td>
</tr>
</tbody>
</table>

**MESH GENERATION**

Use the default mesh.

**COMPUTING THE SOLUTION**

1 From the Solve menu, select Solver Parameters to open the Solver Parameters dialog box.
The eigenfrequency solver is already selected because you chose an eigenfrequency analysis in the Model Navigator. Regarding the eigenfrequency solver parameters, the default value of searching for the first 6 eigenfrequencies is OK.

Click OK to close the dialog box.

Click the Solve button on the Main toolbar to compute the solution.

**POSTPROCESSING AND VISUALIZATION**

Look at the eigenfrequencies and mode shapes.

1. Select Plot Parameters from the Postprocessing menu.
2. On the General page, look in the Eigenfrequency list to find the eigenfrequencies.

<table>
<thead>
<tr>
<th>EIGENFREQUENCY</th>
<th>COMSOL</th>
</tr>
</thead>
<tbody>
<tr>
<td>$f_1$</td>
<td>0 Hz</td>
</tr>
<tr>
<td>$f_2$</td>
<td>243.50 Hz</td>
</tr>
<tr>
<td>$f_3$</td>
<td>377.44 Hz</td>
</tr>
<tr>
<td>$f_4$</td>
<td>394.30 Hz</td>
</tr>
</tbody>
</table>
In an axisymmetric model that is free to move there is one rigid body mode. The rigid body mode has an eigenfrequency close to zero. The rigid body mode shape is a pure axial rigid body translation without any radial displacement.

3 Select the second eigenfrequency from the Eigenfrequency list.

4 Select the Deformed shape check box on the General page to plot the second or first true mode shape.

5 Click OK to plot the first true eigenmode.

<table>
<thead>
<tr>
<th>EIGENFREQUENCY</th>
<th>COMSOL</th>
</tr>
</thead>
<tbody>
<tr>
<td>$f_5$</td>
<td>398.00 Hz</td>
</tr>
<tr>
<td>$f_6$</td>
<td>405.75 Hz</td>
</tr>
</tbody>
</table>

EIGENFREQUENCY ANALYSIS OF A FREE CYLINDER
Frequency Response Analysis of a Simply Supported Plate

In the following example you will build and solve a solid mechanics model using the Mindlin Plate application mode.

The model is a simply supported, 10 m-wide, thick square plate exposed to a uniform harmonic pressure. The model is taken from NAFEMS Test no 21 H, “Simply-supported thick square plate harmonic forced vibration response” described on page 29 in NAFEMS Selected Benchmarks for Forced Vibration (Ref. 1). The computed maximum displacement, stress, and excitation frequency that results in maximum response are compared with the values given in the benchmark report.

Model Definition

The geometry is a square. Due to symmetry in load and geometry, the analysis includes only a quarter of the square.

**MATERIAL**

- Isotropic material with $E = 2.0E11$ Pa, $\nu = 0.3$, and $\rho = 8000$ kg/m$^3$
- Rayleigh damping: $\alpha_{dM} = 5.772$, $\beta_{dK} = 6.929 \cdot 10^{-5}$
LOADS
A distributed harmonic force of 1 MPa on the upper surface pointing in the positive $z$ direction. The excitation frequency range is 44–48 Hz.

CONSTRAINTS
Simply-supported edges on the top and left edge, global rotations constrained on the symmetry edges, $x = 0, y = 0$.

Results
The figure below shows the displacement amplitude at the center as a function of the excitation frequency.

The following table shows a comparison between the solution and the NAFEMS benchmark (Ref. 1):

<table>
<thead>
<tr>
<th>RESULT</th>
<th>COMSOL MULTIPHYSICS</th>
<th>NAFEMS (REF. 1)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maximum displacement (mm)</td>
<td>59.66</td>
<td>58.33</td>
</tr>
<tr>
<td>Stress at top of plate at center (MPa)</td>
<td>802.8</td>
<td>800.8</td>
</tr>
<tr>
<td>Frequency at maximum response (Hz)</td>
<td>45.9</td>
<td>45.90</td>
</tr>
</tbody>
</table>
All results are in close agreement with the benchmark.

Reference


**Model Library path:** Structural_Mechanics_Module/Benchmark_Models/harmonically_excited_plate

**Modeling Using the Graphical User Interface**

**MODEL NAVIGATOR**

1. Select **2D** in the **Space dimension** list on the **New** page in the **Model Navigator**.
2. Select **Structural Mechanics Module>Mindlin Plate>Frequency response analysis** and click **OK**.
GEOMETRY MODELING
1 Select Axes/Grid Settings from the Options menu and give axis and grid settings according to the following table:

<table>
<thead>
<tr>
<th>AXIS</th>
<th>GRID</th>
</tr>
</thead>
<tbody>
<tr>
<td>x min</td>
<td>-5</td>
</tr>
<tr>
<td>x max</td>
<td>5</td>
</tr>
<tr>
<td>y min</td>
<td>-5</td>
</tr>
<tr>
<td>y max</td>
<td>5</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th></th>
<th>x spacing</th>
<th>Extra x</th>
</tr>
</thead>
<tbody>
<tr>
<td>x</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>y</td>
<td>1</td>
<td></td>
</tr>
</tbody>
</table>

2 Click the Rectangle/Square toolbar button and click the right mouse button at (0, 0). Move the mouse while holding down the right mouse button, release the mouse button at (5, 5) to create a square.

3 Click the Zoom Extents button on the Main toolbar to zoom in on the created square.

PHYSICS SETTINGS
In this section you specify the analysis type and the boundary and subdomain settings (boundary conditions, material properties, damping, and loads).
**Boundary Settings**
Constrain the outer edges as simply supported. Specify the symmetry edges to have the global rotation corresponding with the symmetry constrained.

1. Select **Boundary Settings** from the **Physics** menu.
2. Specify boundary settings according to the following tables:

<table>
<thead>
<tr>
<th>BOUNDARIES 3-4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page</td>
</tr>
<tr>
<td>Coordinate system</td>
</tr>
<tr>
<td>Condition</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>BOUNDARY 1</th>
<th>BOUNDARY 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page</td>
<td>Constraint</td>
</tr>
<tr>
<td>Coordinate system</td>
<td>Global coordinate system</td>
</tr>
<tr>
<td>Constraint</td>
<td>Coordinate system</td>
</tr>
<tr>
<td>Coordinate system</td>
<td>Global coordinate system</td>
</tr>
<tr>
<td>$R_y$</td>
<td>0</td>
</tr>
<tr>
<td>$R_x$</td>
<td>0</td>
</tr>
</tbody>
</table>

**Subdomain Settings**
Specify the material properties, damping properties, and load of the Mindlin plate.

1. From the **Physics** menu, select **Subdomain Settings**.
2 Specify subdomain settings according to the following table:

<table>
<thead>
<tr>
<th>SUBDOMAIN 1</th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Material</td>
<td>Load</td>
<td>Damping</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Material model</td>
<td>Isotropic material</td>
<td>$F_z$</td>
<td>1e6</td>
<td>Damping model</td>
<td>Rayleigh</td>
</tr>
<tr>
<td>$E$</td>
<td>2.0e11</td>
<td></td>
<td></td>
<td>$\alpha_M$</td>
<td>5.772</td>
</tr>
<tr>
<td>$v$</td>
<td>0.3</td>
<td></td>
<td></td>
<td>$\beta_M$</td>
<td>6.929e-5</td>
</tr>
<tr>
<td>$\rho$</td>
<td>8000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>thickness</td>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**MESH GENERATION**
Use the default mesh settings. Click the **Initialize Mesh** button on the Main toolbar to create a mesh.

**COMPUTING THE SOLUTION**
Specify the excitation frequency and range:

1. Select **Solver Parameters** from the **Solve** menu.
   The parametric solver is the solver connected to the frequency response analysis type, and the **Auto select solver** option make sure that it has already been selected.
2. Type `freq_smdm` in the **Parameter name** edit field.
3 Type 44:0.1:48 in the **Parameter values** edit field to perform a frequency sweep between 44 Hz and 48 Hz in 0.1 Hz increments.

4 Click **OK**.

5 Click the **Solve** button on the Main toolbar to compute the solution.

**POSTPROCESSING AND VISUALIZATION**

Analyze the maximum displacement amplitude.

1 Select **Domain Plot Parameters** from the **Postprocessing** menu.

2 Go to the **General** page and select all excitation frequencies in the **Solutions to use** list.

3 Select the **Point** page.

4 Select **Disp. amplitude z dir.** from the **Predefined quantities** list.
5 Select 1 from the **Point selection** list to look at the result in the middle of the plate or select the point by clicking on it in the GUI.

6 Click **Apply** to perform the selected plot, click **Cancel** to close the dialog box.
The maximum displacement amplitude is about 60 mm and appears at 45.9 Hz.

Find the maximum stress at the center of the plate:

1. Select **Cross-Section Plot Parameters** from the **Postprocessing** menu.
2. Go to the **General** page and select all excitation frequencies in the **Solutions to use** list.
3. Select the **Point** page.
4. Select **sx normal stress amp. global sys.** from the **Predefined quantities** list.
5. The default x and y coordinates coincide with the request to look at the result in the middle, x = 0, y = 0.
The maximum stress is just above 800 MPa.

Look at the maximum displacement in a surface plot.

1. Select **Plot Parameters** from the **Postprocessing** menu.
2. Go to the **General** page and select **45.9** from the **Parameter value** list in the **Solution to use** area.
3. Click the **Surface** tab.
4. Select **Disp. amplitude z dir.** from the **Predefined quantities** list on the **Surface Data** tab.
5. Click the **Height Data** tab and select the **Height data** check box.
6. Select **Disp. amplitude z dir.** from the **Predefined quantities** list on the **Height Data** page.
7. Click **OK** to close the **Plot Parameters** dialog box.
8. Click the **Scene Light** and **Headlight** buttons on the Camera toolbar.
9 Click the **Zoom Extents** button on the Main toolbar.
Single Edge Crack

**Introduction**

This model deals with the stability of a plate with an edge crack that is subjected to a tensile load. To analyze the stability of exciting cracks, you can use fracture mechanics.

A common parameter in fracture mechanics, the so-called stress intensity factor $K_I$, provides a means to predict if a specific crack will cause the plate to fracture. When this calculated value becomes equal to the critical fracture toughness of the material $K_{IC}$ (a material property), then fast, usually catastrophic fracture occurs.

**The J-Integral**

In this model, you determine the stress intensity factor $K_I$ using the so-called J-integral.

The J-integral is a two-dimensional line integral along a counterclockwise contour, $\Gamma$, surrounding the crack tip. The J-integral is defined as

$$J = \int_{\Gamma} W \, dy - T_i \frac{\partial u_i}{\partial x} \, ds = \int_{\Gamma} \left( W n_x - T_i \frac{\partial u_i}{\partial x} \right) \, ds$$

where $W$ is the strain energy density

$$W = \frac{1}{2} \left( \sigma_{xx} \varepsilon_x + \sigma_{yy} \varepsilon_y + \sigma_{xy} \varepsilon_{xy} + 2 \varepsilon_{xy} \varepsilon_{xy} \right)$$

and $T$ is the traction vector defined as

$$T = [\sigma_x \cdot n_x + \sigma_{xy} \cdot n_y, \sigma_{xy} \cdot n_x + \sigma_y \cdot n_y]$$

$\sigma_{ij}$ denotes the stress components, $\varepsilon_{ij}$ the strain components, and $n_i$ the normal vector components.

The J-integral has the following relation to the stress intensity factor for a plane stress case and a linear elastic material:

$$J = \frac{K_I^2}{E}$$

where $E$ is Young’s modulus.
**Analytical Solution**

This problem has an analytical solution (see Ref. 1) for the stress intensity factor:

\[ K_{Ia} = \sigma \cdot \sqrt{\pi \cdot a} \cdot cef \]

where \( \sigma = 20 \text{ MPa} \) (tensile load (force /area)), \( a = 0.6 \text{ m} \) (crack length), and \( cef = 2.1 \) (configuration correction factor). This correction factor is determined for this configuration using a polynomial equation from Ref. 1. This gives the following analytical stress intensity factor: \( K_{Ia} = 57.66 \text{ MPa} \cdot \text{m}^{1/2} \).

**Model Definition**

**Geometry**

A plate with a width \( w \) of 1.5 m has a single horizontal edge-crack of length \( a = 0.6 \text{ m} \) on the left vertical edge (see Figure 2-25). The total height of the plate is 3 m, but due to symmetry reasons the model only includes half of the plate. The model geometry also includes two smaller domains, thus adding interior boundaries.

---

**Figure 2-25: Plate geometry.**
**Domain Equations**

Due to the interior boundaries the geometry consists of three subdomains. The same material properties apply to all three domains:

<table>
<thead>
<tr>
<th>Quantity</th>
<th>Name</th>
<th>Expression</th>
</tr>
</thead>
<tbody>
<tr>
<td>Young's modulus</td>
<td>E</td>
<td>$206 \cdot 10^9$</td>
</tr>
<tr>
<td>Poisson's ratio</td>
<td>ν</td>
<td>0.3</td>
</tr>
</tbody>
</table>

**Boundary Conditions**

You apply a tensile load to the upper horizontal edge, while the lower horizontal edge is constrained in the y direction from $x = 0.6$ m to $x = 1.5$ m.

**Modeling in COMSOL Multiphysics**

The analysis computes the J-integrals for three different contours traversing three different regions around the crack tip. The first contour follows the exterior boundaries of the plate. The second contour follows the interior boundaries at $x = 0.2$ m, $y = 0.8$ m, and $x = 1.2$ m. The third and last contour follows the interior boundaries at $x = 0.4$ m, $y = 0.4$ m, and $x = 1$ m.

To calculate the J-integral, you define boundary integration variables for each contour. This creates two variables for each contour. The first variable, denoted $W$, contains the integrated strain energy density, while the second, denoted $T \text{dudx}$, contains the traction vector times the spatial $x$-derivative of the deformation components. The sum of these two variables then provides the J-integral value as a scalar expression variable. Finally, you can compute the stress intensity factor from the J-integral value, also using a scalar expression variable.

Note that the boundaries along the crack are not included in the J-integral, because they do not give any contribution to the J-integral. This is due to the following facts: for an ideal crack $dy$ is zero along the crack faces, and all traction components are also zero ($T_j = 0$) as the crack faces are not loaded.

When calculating the J-integral, the contour normals must point outward of the region which the contour encloses. The boundary normals of the plate geometry are all pointing outward. However, some of the normals of the interior boundaries that are used for the second and third contour do not point outward of the regions that they enclose. This means that you need to define additional normals to get the correct alignment of the normals. You define these normals as boundary expressions and use them in the boundary integration variables.
Results

The following table shows the stress intensity factors for the three different contours:

<table>
<thead>
<tr>
<th>CONTOUR</th>
<th>STRESS INTENSITY FACTOR</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>57.79 MPa·m$^{1/2}$</td>
</tr>
<tr>
<td>2</td>
<td>57.71 MPa·m$^{1/2}$</td>
</tr>
<tr>
<td>3</td>
<td>57.67 MPa·m$^{1/2}$</td>
</tr>
</tbody>
</table>

It is clear from these results that the values for the stress intensity factor in the COMSOL Multiphysics model are in good agreement with the reference value for all contours.

It is also clear that the accuracy of the calculated stress intensity factors increases for the inner contours.

Figure 2-26 shows the stress singularity at the crack tip.

*Figure 2-26: Von Mises stresses and the deformed shape of the plate.*
Modeling Using the Graphical User Interface

MODEL NAVIGATOR
1. Select 2D from the Space dimension list.
2. Select Structural Mechanics Module>Plane Stress from the list of application modes.
3. Click OK.

GEOMETRY MODELING
First create the upper half of the plate and add two rectangles so that the interior boundaries that the drawing creates can be used as contours.

1. Choose Draw>Specify Objects>Square.
2. In the Width edit field type 1.5.
3. Click OK.
4. Click the Zoom Extents button on the Main toolbar.
5. Add a rectangle by choosing Draw>Specify Objects>Rectangle.
6. In the Width edit field type 1 and in the Height edit field type 0.8.
7. In the x edit field type 0.2 and in the y edit field type 0.
8. Click OK.
9. To add a second rectangle, first choose Draw>Specify Objects>Rectangle.
10. In the Width edit field type 0.6 and in the Height edit field type 0.4.
11. In the x edit field type 0.4 and in the y edit field type 0.
12. Click OK.

Next add a point to define the crack tip.
13. Choose Draw>Specify Objects>Point.
In the $x$ edit field type 0.6 and in the $y$ edit field type 0.

15 Click **OK**.

This completes the geometry. Compare your result with Figure 2-25 on page 130.

**PHYSICS SETTINGS**

1 *Subdomain Settings*
   1 From the **Physics** menu, choose **Subdomain Settings**.
   2 Select Subdomains 1–3.
   3 In the **Young’s modulus** edit field type 2e11.
   4 In the **Poisson’s ratio** edit field type 0.3.
   5 Click **OK**.

2 *Boundary Conditions*
   1 From the **Physics** menu, choose **Boundary Settings**.
   2 Select Boundaries 10, 12, and 14, then select **Symmetry plane** from the **Constraint condition** list.
   3 Click the **Load** tab.
   4 Select Boundary 3. In the $F_y$ edit field type 20e6.
   5 Click the **Edge load is defined as force/area using the thickness** option button, then click **OK**.

3 *Point Conditions*
   1 From the **Physics** menu, choose **Point Settings**.
   2 Select Point 7 and select the $R_x$ check box. Leave the displacement at 0.
   3 Click **OK**.

4 *Boundary Expressions*
   The interior boundaries, which you use for the two inner J-integral contours, need to have user-defined normal direction variables.
   1 Choose **Options>Expressions>Boundary Expressions**.
Specify expressions for each of the normal vector components according to the following table. When finished, click OK.

<table>
<thead>
<tr>
<th>BOUNDARY</th>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>4, 7</td>
<td>Nx</td>
<td>-1</td>
</tr>
<tr>
<td></td>
<td>Ny</td>
<td>0</td>
</tr>
<tr>
<td>6, 9</td>
<td>Nx</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td>Ny</td>
<td>1</td>
</tr>
<tr>
<td>11, 13</td>
<td>Nx</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>Ny</td>
<td>0</td>
</tr>
</tbody>
</table>

**Boundary Integration Variables**

1. From the Options menu, choose Integration Coupling variables and click on Boundary Variables.
2. Select Boundaries 1, 3, and 15.
3. Specify expressions according to the following table:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>W</td>
<td>(sx_sm<em>ex_sm+sy_sm</em>ey_sm+2<em>sxy_sm</em>exy_sm)*nx/2</td>
</tr>
<tr>
<td>Tdudx</td>
<td>-(sx_sm<em>nx+sxy_sm</em>ny)<em>ux+(sxy_sm</em>nx+sy_sm*ny)*vx</td>
</tr>
</tbody>
</table>

4. Select Boundaries 4, 6, and 13.
5. Specify additional expressions according to the following table:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>W1</td>
<td>(sx_sm<em>ex_sm+sy_sm</em>ey_sm+2<em>sxy_sm</em>exy_sm)*Nn/2</td>
</tr>
<tr>
<td>Tdudx</td>
<td>-(sx_sm<em>Nn+sxy_sm</em>Ny)<em>ux+(sxy_sm</em>Nn+sy_sm*Ny)*vx</td>
</tr>
</tbody>
</table>

6. Select Boundaries 7, 9, and 11.
7. Specify additional expressions according to the following table:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>W2</td>
<td>(sx_sm<em>ex_sm+sy_sm</em>ey_sm+2<em>sxy_sm</em>exy_sm)*Nn/2</td>
</tr>
<tr>
<td>Tdudx</td>
<td>-(sx_sm<em>Nn+sxy_sm</em>Ny)<em>ux+(sxy_sm</em>Nn+sy_sm*Ny)*vx</td>
</tr>
</tbody>
</table>

8. Click OK.

**Scalar Expressions**

Compute the J-integrals for each contour by summing the two integral expressions. In addition, define scalar expressions to compute the stress intensity factors.

1. Choose Options>Expressions>Scalar Expressions.
2 Specify expressions according to the following table. When finished, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>KI</td>
<td>$\sqrt{E_{smps} \cdot</td>
</tr>
<tr>
<td>J</td>
<td>$2 \cdot (W + Tdudx)$</td>
</tr>
<tr>
<td>KI1</td>
<td>$\sqrt{E_{smps} \cdot</td>
</tr>
<tr>
<td>J1</td>
<td>$2 \cdot (W_1 + Tdudx_1)$</td>
</tr>
<tr>
<td>KI2</td>
<td>$\sqrt{E_{smps} \cdot</td>
</tr>
<tr>
<td>J2</td>
<td>$2 \cdot (W_2 + Tdudx_2)$</td>
</tr>
</tbody>
</table>

**MESH GENERATION**

1 Choose **Mesh>Free Mesh Parameters**.

2 On the **Global** page, click the **Custom mesh size** option button.

3 In the **Maximum element size** edit field, type 0.4.

4 Click the **Point** tab.

5 Select Point 7, then type 0.05 in the **Maximum element size** edit field.

6 Click **OK**.

7 Click the **Refine Mesh** button on the Main toolbar.

   This action first generates a mesh according to the specifications you gave in the **Free**
Mesh Parameters dialog box and then refines it once.

Computing the Solution
Click the Solve button on the Main toolbar to start the analysis.

Postprocessing and Visualization
First display the stress intensity factor calculated with the outer contour:

1. From the Postprocessing menu, choose Data Display>Global.
2. In the Expression edit field type KI, then click Apply.
   The value for the stress intensity parameter $KI$ appears in the message log.
   Next display the stress intensity factor values calculated by the two inner contours.
3. In the Expression edit field type $KI_1$, then click Apply.
4. In the Expression edit field type $KI_2$, then click OK.
   The message log displays the stress intensity parameter values for the inner contours.

To plot the von Mises stress field and the deformed shape, follow these steps:

1. From the Postprocessing menu, choose Plot Parameters.
2. Click the General tab and select the Surface, Deformed shape, and Geometry edges check boxes only.
3 Click the **Surface** tab and select **von Mises stress** from the **Predefined quantities** list.

4 Click **OK**.

5 Click the **Zoom Extents** button on the Main toolbar.

See Figure 2-26 for the von Mises stresses and the deformed shape plot.
**Elasto-Plastic Plate**

*Introduction*

In this example you analyze a plate with a hole when it is loaded above the elastic limit. The example is derived from section 7.10 of *The Finite Element Method* by O.C. Zienkiewicz (Ref. 1). In addition to the original problem formulation, you follow the unloading history.

*Model Definition*

Figure 2-27 shows the plate’s geometry.

![Plate Geometry](image)

*Figure 2-27: The plate geometry.*

Because the plate is thin and the loads are in plane, you can assume a plane-stress condition. Double symmetry means you only need to analyze a quarter of the plate.

**MATERIAL**

- Elastic properties: $E = 70000$ MPa and $\nu = 0.2$.
- Plastic properties: Yield stress 243 MPa and a linear isotropic hardening with tangent modulus 2171 MPa.
CONSTR AN TS AND LOADS

- Symmetry plane constraints are applied on the left most vertical boundary and the lower horizontal boundary.
- The right vertical edge is subjected to a stress, which increases from zero to a maximum value of 133.65 MPa and then is released again. The peak value is selected so that the mean stress over the section through the hole is 10% above the yield stress ($\sigma = 1.1 \cdot 243 \cdot (20 - 10)/20$).

Results and Discussion

Figure 2-28 shows the development of the plastic region. The parameter values are 0.59, 0.68, 0.78, 0.88, 0.98, and 1.08. These values are proportional to the load with parameter value 1.0 corresponding to the yield limit as average stress over the cross
section through the hole. For a material without strain hardening, the structure would thus have collapsed before reaching the final load level.

*Figure 2-28: Development of plastic region (purple) with increased load.*

Because an elasto-plastic solution is load-path dependent, it is important not to use too large steps in the load parameter when you anticipate a plastic flow. Usually you can take one large step up to the elastic limit, as this example shows. Moreover, reversed plastic flow can occur during the unloading. This is why small parameter steps are used at the end of the parameter range in this analysis.
Reference

**Model Library path:** Structural_Mechanics_Module/Benchmark_Models/elasto_plastic_plate

**Modeling Using the Graphical User Interface**

1. Select **2D** from the **Space dimension** list on the **New** page in the **Model Navigator**.
2. Select **Structural Mechanics Module>Plane Stress>Static analysis elasto-plastic material**.
3. Click **OK**.

**Options and Settings**

1. Select **Model Settings** from the **Physics** menu to open the **Model Settings** dialog box.
2. Select **MPa** from the **Base unit system** list to use mm as the length scale unit and MPa as the stress unit. Click **OK**.

**Geometry Modeling**

1. Shift-click the **Rectangle/Square** button on the Draw toolbar. In the **Width** edit field type 18 and in the **Height** edit field type 10. Click **OK**.
2. Shift-click the **Ellipse/Circle (Centered)** button. In the **Radius** edit field type 5, then click **OK**.
3. Select both objects by pressing Ctrl+A, then click the **Difference** button on the Draw toolbar to create the composite object CO1.
4. Click the **Zoom Extents** button on the Main toolbar.

**Physics Settings**

**Boundary Settings**

1. Select **Boundary Settings** from the **Physics** menu.
2 Specify boundary settings according to the following tables:

<table>
<thead>
<tr>
<th>BOUNDARIES 1, 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page</td>
</tr>
<tr>
<td>------</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>BOUNDARY 4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page</td>
</tr>
<tr>
<td>------</td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>

**Subdomain Settings**

1. Select **Subdomain Settings** from the **Physics** menu.
2. Select Subdomain 1, then specify data on the **Material** page according to the following table:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>$E$</td>
<td>70000</td>
</tr>
<tr>
<td>$\nu$</td>
<td>0.2</td>
</tr>
</tbody>
</table>

3. Click the **Elasto-Plastic Material Settings** button to open the **Elasto-Plastic Material Settings** dialog box.
4. In the $\sigma_{ys}$ edit field type 243 and in the $E_{tiso}$ edit field type 2171.
5. Click **OK**.

The Gauss point order defaults to 2 times the order of the shape function. When solving a static problem with second-order triangular elements, you can improve the performance by lowering the Gauss point order from 4 to 2. For a linear elastic problem this does not make a large difference, but when solving an elasto-plastic problem the difference in memory and speed are much larger, because the solver computes the plastic strain in the Gauss points of the elements.

6. On the **Element** page, type $2 \ 2 \ 2$ in the **gorder** edit field.

**Note:** Lowering the Gauss point order to the same value as the shape function order does not work together with quad and hex elements.
7 Click **OK** to close the **Subdomain Settings** dialog box.

**MESH GENERATION**
1 Click the **Initialize Mesh** button on the Main toolbar to generate the mesh.
2 Click the **Refine Mesh** button to refine the mesh.

**COMPUTING THE SOLUTION**
1 Click the **Solver Parameters** button on the Main toolbar.
2 Type the name `para` in the **Parameter name** edit field.
3 Enter `0 0.44:0.05:0.59 0.63:0.05:1.08 1.1:0.2:1.9 1.95:0.05:2.2` in the **Parameter values** edit field. Click **OK**.
4 Click the **Solve** button on the Main toolbar.

**POSTPROCESSING AND VISUALIZATION**
1 Click the **Plot Parameters** button on the Main toolbar.
2 On the **General** page select `0.59` from the **Parameter value** list.
3 Click the **Surface** tab.
4 Type `epe_smps>0` in the **Expression** edit field to get a flag for plastic deformation (`epe_smps` is the variable name for the effective plastic strain). This logical expression is 1 in the plastic region and 0 elsewhere.
5 Select `wave` from the **Colormap** list.
6 Return to the **General** page and step through the values in the **Parameter value** list, clicking **Apply** in between to generate the plots as shown in Figure 2-28 on page 141.
Elastoacoustic Effect in Rail Steel

Introduction

The elastoacoustic effect is a change in the speed of elastic waves that propagate in a structure undergoing static elastic deformations. The effect is used in many ultrasonic techniques for nondestructive testing of prestressed states within structures.

This example model studies the elastoacoustic effect in steels typically used in railroad rails. The analysis is based on the Murnaghan material model, which represents a hyperelastic isotropic material, and is based on an expansion of the elastic potential in terms of displacement gradients keeping the terms up to 3rd order. This material model can be used to study various nonlinear effects in materials and structures, of which the elastoacoustic effect is an example.

Model Definition

The geometry represents a head of a railroad rail. It is a beam with a length of \( L_0 = 0.607 \text{ m} \) and a cross section of 0.0624 m by 0.0262 m; see Figure 2-29 on page 146. The rail is made of steel with the following properties (taken from Ref. 1):

- Density: \( \rho = 7800 \text{ kg/m}^3 \)
- Lamé elastic moduli: \( \lambda = 11.58 \cdot 10^{10} \text{ Pa} \) and \( \mu = 7.99 \cdot 10^{10} \text{ Pa} \).
- Murnaghan third-order elastic constants: \( l = -24.8 \cdot 10^{10} \text{ Pa} \), \( m = -62.3 \cdot 10^{10} \text{ Pa} \), and \( n = -71.4 \cdot 10^{10} \text{ Pa} \).

To create a prestressed state, the beam is stretched to a length \( L = (1 + \varepsilon)L_0 \), where \( \varepsilon = 5 \cdot 10^{-4} \). The model computes the eigenfrequencies of the beam for the free and prestressed states and the relative change in the speed of propagating elastic waves.
Figure 2-29: Geometry and mesh.
Results and Discussion

The prestressed state is shown in Figure 2-30 below.

![Figure 2-30: The static displacement field in the prestressed beam.](image)

For a stress free sample, the computed eigenfrequency is $f_0 = 4236.42$ Hz, which is shown in Figure 2-31.
When the piece of rail is stretched, the length of the piece changes, but most importantly, we get a prestressed state, which changes the wave speed in the material. Therefore, the eigenfrequency changes to $f = 4228.78$ Hz as shown in Figure 2-32.

Figure 2-31: Eigenfrequency and normalized eigenfunction for a stress-free rail
The relative change in the wave speed per unit strain can be estimated by the following formula:

$$\frac{c - c_0}{c_0} = 1 + \frac{f - f_0}{f_0} + \frac{f - f_0}{f_0}$$  \hspace{1cm} (2-2)

The resulting value is $-2.61$, which is in a good agreement with the experimental value of $-2.52$ reported in Ref. 1 (Table III, specimen 1).

Reference

Model Library path: Structural_Mechanics_Module/Benchmark_Models/rail_steel

Modeling Using the Graphical User Interface

MODEL NAVIGATOR
1 Select 3D from the Space dimension list.
2 Select Structural Mechanics Module>Solid, Stress-Strain from the list of application modes.
3 Click OK.

OPTIONS AND SETTINGS
1 From the Options menu, select Constants.
2 Enter constant names, expressions, and descriptions (optional) according to the following table; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>L0</td>
<td>0.607[m]</td>
<td>Initial length</td>
</tr>
<tr>
<td>epsilon</td>
<td>5e-4</td>
<td>Relative elongation</td>
</tr>
</tbody>
</table>

GEOMETRY MODELING
1 Click the Block button on the Draw toolbar.
2 In the Length area, enter 0.607 for X, 0.0624 for Y, and 0.0262 for Z.
3 Click OK to create a block labeled BLK1.
4 Click the Zoom Extents button on the Main toolbar.

PHYSICS SETTINGS

Subdomain Settings
1 From the Physics menu, select Subdomain Settings.
2 On the Material page, specify the material properties according to the following table:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN I</th>
</tr>
</thead>
<tbody>
<tr>
<td>Material model</td>
<td>Hyperelastic</td>
</tr>
<tr>
<td>Hyperelastic model</td>
<td>Murnaghan</td>
</tr>
<tr>
<td>l</td>
<td>-24.8e10</td>
</tr>
<tr>
<td>m</td>
<td>-62.3e10</td>
</tr>
<tr>
<td>n</td>
<td>-71.4e10</td>
</tr>
<tr>
<td>λ</td>
<td>11.58e10</td>
</tr>
<tr>
<td>μ</td>
<td>7.99e10</td>
</tr>
<tr>
<td>α</td>
<td>1.2e-5</td>
</tr>
<tr>
<td>ρ</td>
<td>7800</td>
</tr>
</tbody>
</table>

3 Click OK to close the dialog box.

Boundary Settings
1 From the Physics menu, select Boundary Settings.
2 Select Boundaries 2, 3, and 6.
3 Select Symmetry plane from the Constraint condition list.
4 Select Boundary 1 and then select Prescribed displacement from the Constraint condition list.
5 Select the Rx check box, then type -epsilon*L0 in the Constraint x-dir. edit field.
6 Click OK to close the dialog box.

Mesh Generation
1 From the Mesh menu, select Mapped Mesh Parameters.
2 Select Boundary 3, then select Extra fine from the Predefined mesh sizes list.
3 Click the Mesh Selected button to mesh Boundary 3, then click OK.
4 Click the Subdomain Mode toolbar button.
5 Select the subdomain and click the Mesh Selected (Swept) toolbar button.
6 Click the Zoom Extents button on the Main toolbar to examine the mesh, it should be similar to that shown in Figure 2-29.

Computing the Solution
First, you precompute the prestressed state, and store the solution:
1 Click the Solve button on the Main toolbar.
2 From the Solve menu, select Solver Manager.
3 On the Initial Value page, click the Store Solution button to save the current solution to be used as initial condition.
4 Click OK.

To visualize the resulting displacement field, follow these steps:

1 From the Postprocessing menu, choose Plot Parameters.
2 In the Plot type area, select only the Subdomain and Geometry edges check boxes; clear any others, if selected.
3 Click the Subdomain tab.
4 From the Predefined quantities list, select Total displacement.
5 Click OK to see the displacement plot similar to that shown Figure 2-30.

As a next step, you perform the eigenvalue analysis for a stress-free state.

1 From the Solve menu, select Solver Parameters.
2 In the Analysis types area, select Eigenfrequency from the list of analysis types.
3 Click OK.
4 Click the Solve button on the Main toolbar.
5 When the solver has finished, select Plot Parameters from the Postprocessing menu.
6 On the Subdomain page, clear the Color scale check box.
7 Return to the General page and select New figure from the Plot in list.
8 Click Apply to open a new window containing Figure 1. The plot should be similar to that shown in Figure 2-31.
9 From the Plot in list, select Main axes.
10 Click OK to close the dialog box.

Finally, you compute the eigenfrequencies for the prestressed state.

1 From the Solve menu, select Solver Manager.
2 Click the Stored solution button in the Values of variables not solved for and linearization point area.
3 Click OK to close the dialog box.
4 Click the Solve button on the Main toolbar to compute the eigenfrequency shown in Figure 2.32.

When the solver has finished, you should see a plot similar to that shown in Figure 2.32.

5 Optionally, compare the computed eigenfrequencies and use the formula in Equation 2.2 to calculate the relative change in the wave speed.
**INDEX**

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>analysis</td>
<td>benchmark 37</td>
<td>constraint</td>
</tr>
<tr>
<td>eigenfrequency</td>
<td>Axial Symmetry, Stress-Strain</td>
<td>normal displacement 51</td>
</tr>
<tr>
<td></td>
<td>NAFEMS 8</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Plane Stress 19, 37</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Solid, Stress-Strain 8, 28</td>
<td></td>
</tr>
<tr>
<td></td>
<td>benchmark models 7</td>
<td></td>
</tr>
<tr>
<td></td>
<td>wrapped cylinder 8</td>
<td></td>
</tr>
<tr>
<td></td>
<td>benchmark models, list of 2</td>
<td></td>
</tr>
<tr>
<td></td>
<td>buckling 21</td>
<td></td>
</tr>
<tr>
<td>eigenfrequency</td>
<td></td>
<td></td>
</tr>
<tr>
<td>large deformation</td>
<td></td>
<td></td>
</tr>
<tr>
<td>linear buckling</td>
<td></td>
<td></td>
</tr>
<tr>
<td>parametric</td>
<td></td>
<td></td>
</tr>
<tr>
<td>static analysis</td>
<td></td>
<td></td>
</tr>
<tr>
<td>elasto-plastic</td>
<td></td>
<td></td>
</tr>
<tr>
<td>material</td>
<td></td>
<td></td>
</tr>
<tr>
<td>contact pairs</td>
<td></td>
<td></td>
</tr>
<tr>
<td>contact pressure</td>
<td></td>
<td></td>
</tr>
<tr>
<td>critical buckling</td>
<td></td>
<td></td>
</tr>
<tr>
<td>load</td>
<td></td>
<td></td>
</tr>
<tr>
<td>path</td>
<td></td>
<td></td>
</tr>
<tr>
<td>dialog box</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Elasto-Plastic Material Settings</td>
<td></td>
<td></td>
</tr>
<tr>
<td>difference operation</td>
<td></td>
<td></td>
</tr>
<tr>
<td>eigenfrequency analysis</td>
<td></td>
<td></td>
</tr>
<tr>
<td>model 110, 116</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Elasto-Plastic Material Settings dialog</td>
<td></td>
<td></td>
</tr>
<tr>
<td>box 143</td>
<td></td>
<td></td>
</tr>
<tr>
<td>extrude geometry</td>
<td></td>
<td></td>
</tr>
<tr>
<td>31</td>
<td></td>
<td></td>
</tr>
<tr>
<td>fracture toughness</td>
<td></td>
<td></td>
</tr>
<tr>
<td>free vibration</td>
<td></td>
<td></td>
</tr>
<tr>
<td>110</td>
<td></td>
<td></td>
</tr>
<tr>
<td>geometry modeling</td>
<td></td>
<td></td>
</tr>
<tr>
<td>example 29</td>
<td></td>
<td></td>
</tr>
<tr>
<td>geometry operation</td>
<td></td>
<td></td>
</tr>
<tr>
<td>difference 40</td>
<td></td>
<td></td>
</tr>
<tr>
<td>headlight</td>
<td></td>
<td></td>
</tr>
<tr>
<td>hoop stress</td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td></td>
<td></td>
</tr>
<tr>
<td>isotropic hardening</td>
<td></td>
<td></td>
</tr>
<tr>
<td>139</td>
<td></td>
<td></td>
</tr>
<tr>
<td>J-integral</td>
<td></td>
<td></td>
</tr>
<tr>
<td>129, 131</td>
<td></td>
<td></td>
</tr>
<tr>
<td>large deformation</td>
<td></td>
<td></td>
</tr>
<tr>
<td>24</td>
<td></td>
<td></td>
</tr>
<tr>
<td>large deformation analysis</td>
<td></td>
<td></td>
</tr>
<tr>
<td>19</td>
<td></td>
<td></td>
</tr>
<tr>
<td>linear buckling</td>
<td></td>
<td></td>
</tr>
<tr>
<td>21</td>
<td></td>
<td></td>
</tr>
<tr>
<td>linear buckling analysis</td>
<td></td>
<td></td>
</tr>
<tr>
<td>25</td>
<td></td>
<td></td>
</tr>
<tr>
<td>load</td>
<td></td>
<td></td>
</tr>
<tr>
<td>buckling 21</td>
<td></td>
<td></td>
</tr>
<tr>
<td>path 141</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mass page</td>
<td></td>
<td></td>
</tr>
<tr>
<td>61</td>
<td></td>
<td></td>
</tr>
<tr>
<td>material model</td>
<td></td>
<td></td>
</tr>
<tr>
<td>isotropic hardening</td>
<td></td>
<td></td>
</tr>
<tr>
<td>139</td>
<td></td>
<td></td>
</tr>
<tr>
<td>model</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3D Euler Beam</td>
<td></td>
<td></td>
</tr>
<tr>
<td>67</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

*Note: The index contains terms related to finite element analysis, beam mechanics, and material properties.*
eigenfrequency analysis 110, 116
large deformation beam 19
single edge crack 129
thermally loaded beam 67
wrapped cylinder 8
MPa units 101
N  NAFEMS benchmark 8, 19, 28, 110
O  orthotropic model 8
P  pinned
model example 61
Plane Strain
postprocessing 54
Plane Stress
application mode 23
benchmark 19
large deformation beam model 19
postprocessing 43
single edge crack 129
plastic region 140
point mass 55
postprocessing
amplitude 127
Axial Symmetry, Stress-Strain 116
cross-section plot 43
headlight 127
Plane Strain 54
Plane Stress 43
scene light 127
Shell 94
Solid, Stress-Strain 34
pressure
load from internal and external 48
R  restart 26
rigid body modes 112
S  scene light 127
Shell
benchmark 85
postprocessing 94
single edge crack model 129
Solid, Stress-Strain
postprocessing 34
wrapped cylinder 8
store solution 152
stress intensity factor 129, 130
symmetry 98
T  tangent modulus 139
thermal load
3D Euler Beam 64
element 48, 52
specification 52
thermally loaded beam 67
typographical conventions 4
W  wrapped cylinder 8
Y  yield stress 139