MEMS MODULE

Version 3.5

Comsol Multiphysics
CONTENTS

Chapter 1: Introduction

Model Library Guide .............................................. 2
Typographical Conventions ...................................... 6

Chapter 2: MEMS Actuator Models

Cantilever Beam .................................................... 8
Introduction ......................................................... 8
Model Definition .................................................... 8
Results ............................................................. 11
Modeling in COMSOL Multiphysics ......................... 17
Reference .......................................................... 17
Modeling Using the Graphical User Interface—2D Version .................. 18
Evaluating the AC Capacitance .................................. 26
Modeling Using the Graphical User Interface—3D Version .................. 28

Comb Drive .......................................................... 34
Introduction ......................................................... 34
Model Definition .................................................... 34
Modeling in COMSOL Multiphysics ......................... 35
Results and Discussion .......................................... 36
Reference .......................................................... 38
Modeling Using the Graphical User Interface ................ 38

Capacitive 3D Comb Drive ....................................... 50
Introduction ......................................................... 50
Theoretical Background ........................................... 51
Results and Discussion .......................................... 52
Modeling in COMSOL Multiphysics ......................... 52
Modeling Using the Graphical User Interface ................ 53
Chapter 3: MEMS Sensor Models

Squeezed-Film Gas Damping in an Accelerometer 130
Introduction ............................................. 130
Model Definition ........................................ 131
Results and Discussion. ............................... 133
References .............................................. 135
Modeling Using the Graphical User Interface (2D) ........ 135
Modeling Using the Graphical User Interface (3D) ........ 139

Estimating the Q Factor of a MEMS Gyroscope 145
Introduction ............................................. 145
Model Definition ........................................ 146
Results and Discussion. ............................... 148
References .............................................. 150
Modeling in COMSOL Multiphysics ................. 150
Modeling Using the Graphical User Interface ......... 151

Capacitive Pressure Sensor 161
Introduction ............................................. 161
Model Definition ........................................ 163
Results and Discussion. ............................... 166
Modeling in COMSOL Multiphysics ................. 171
Modeling Using the Graphical User Interface—2D Example. 172
Modeling Using the Graphical User Interface—3D Example. 181

SAW Gas Sensor 190
Introduction ............................................. 190
Model Definition ........................................ 190
Results ..................................................... 194
References .............................................. 196
Modeling Using the Graphical User Interface ........ 196
Sensor without Gas Exposure .......................... 201
Sensor with Gas Exposure ............................. 203

Thermal Expansion in a MEMS Device 205
Introduction ............................................. 205
Chapter 4: Microfluidics Models

AC Electrokinetically Enhanced Surface Reactions 220
Introduction 220
Model Definition 220
Results and Discussion 226
Modeling in COMSOL Multiphysics 229
References 230
Modeling Using the Graphical User Interface 231
Re-Solve the Model with an Applied Electric Field 244
Step-Response Simulation 246

Transport in an Electrokinetic Valve 249
Introduction 249
Model Definition 249
Results and Discussion 254
Modeling in COMSOL Multiphysics 258
Reference 260
Modeling Using the Graphical User Interface 260

ALE Fluid-Structure Interaction 273
Introduction 273
Model Definition 274
Results and Discussion 276
Modeling in COMSOL Multiphysics 281
Modeling Using the Graphical User Interface 281

Lamella Mixer 286
Introduction 286
Model Definition 287
Results and Discussion 289
Modeling in COMSOL Multiphysics 292
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inkjet Nozzle</td>
<td>370</td>
</tr>
<tr>
<td>Introduction</td>
<td>370</td>
</tr>
<tr>
<td>Model Definition</td>
<td>370</td>
</tr>
<tr>
<td>Results and Discussion</td>
<td>376</td>
</tr>
<tr>
<td>Modeling in COMSOL Multiphysics</td>
<td>379</td>
</tr>
<tr>
<td>References</td>
<td>380</td>
</tr>
<tr>
<td>Modeling Using the Graphical User Interface—Level Set Method</td>
<td>380</td>
</tr>
<tr>
<td>Modeling Using the Graphical User Interface—Phase Field Method</td>
<td>386</td>
</tr>
<tr>
<td>Filling of a Capillary Channel</td>
<td>392</td>
</tr>
<tr>
<td>Introduction</td>
<td>392</td>
</tr>
<tr>
<td>Model Definition</td>
<td>392</td>
</tr>
<tr>
<td>Results and Discussion</td>
<td>397</td>
</tr>
<tr>
<td>Modeling in COMSOL Multiphysics</td>
<td>401</td>
</tr>
<tr>
<td>Modeling Using the Graphical User Interface—Level Set Method</td>
<td>402</td>
</tr>
<tr>
<td>Modeling Using the Graphical User Interface—Phase Field Method</td>
<td>407</td>
</tr>
<tr>
<td>Hydrocarbon Dehalogenation in a Tortuous Microreactor</td>
<td>413</td>
</tr>
<tr>
<td>Introduction</td>
<td>413</td>
</tr>
<tr>
<td>Model Definition</td>
<td>413</td>
</tr>
<tr>
<td>Results</td>
<td>417</td>
</tr>
<tr>
<td>Modeling Using COMSOL Multiphysics</td>
<td>421</td>
</tr>
<tr>
<td>Modeling Using the COMSOL Reaction Engineering Lab</td>
<td>423</td>
</tr>
<tr>
<td>Modeling Using COMSOL Multiphysics</td>
<td>426</td>
</tr>
<tr>
<td>Two-Phase Fluid-Structure Interaction</td>
<td>429</td>
</tr>
<tr>
<td>Introduction</td>
<td>429</td>
</tr>
<tr>
<td>Model Definition</td>
<td>429</td>
</tr>
<tr>
<td>Problem Formulation</td>
<td>430</td>
</tr>
<tr>
<td>Results and Discussion</td>
<td>432</td>
</tr>
<tr>
<td>Modeling in COMSOL Multiphysics</td>
<td>434</td>
</tr>
<tr>
<td>Reference</td>
<td>435</td>
</tr>
<tr>
<td>Modeling Using the Graphical User Interface</td>
<td>435</td>
</tr>
<tr>
<td>Droplet Breakup in a T-Junction</td>
<td>441</td>
</tr>
<tr>
<td>Introduction</td>
<td>441</td>
</tr>
<tr>
<td>Model Definition</td>
<td>441</td>
</tr>
<tr>
<td>Results and Discussion</td>
<td>443</td>
</tr>
</tbody>
</table>
Chapter 5: Models of Piezoelectric Devices

Piezoceramic Tube 453
Introduction 453
Model Definition 453
Results and Discussion 455
Modeling in COMSOL Multiphysics 458
Reference 458
Modeling Using the Graphical User Interface 459

Piezoelectric Shear Actuated Beam 466
Introduction 466
Model Definition 466
Results 468
Modeling in COMSOL Multiphysics 468
References 469
Modeling Using the Graphical User Interface 469

Composite Piezoelectric Transducer 478
Introduction 478
Results 479
Reference 479
Modeling Using the Graphical User Interface 480

Thin Film BAW Composite Resonator 489
Introduction 489
Model Definition 490
Results and Discussion 492
Modeling in COMSOL Multiphysics 496
References 497
Modeling Using the Graphical User Interface—Eigenfrequency 497
Modeling Using the Graphical User Interface—Frequency Response 501
Introduction

The MEMS Module Model Library consists of a set of models that demonstrate the use of this module for modeling of various types of MEMS devices. The purpose of these models is to assist you in learning, by example, how to create sophisticated multiphysics models for design and analysis of microelectromechanical systems. In addition to serving as a reference, the model library can also give you a big head start if you are developing a model of a similar nature.

We have divided these models into four different groups:

- Actuator models
- Sensor models
- Microfluidics models
- Piezoelectric models

The models also illustrate the use of the various application modes in the MEMS Module that we used to build these models. Some models also make use of the PDE modes in COMSOL Multiphysics for equation-based modeling.

The book in your hands, the MEMS Module Model Library, provides details about a large number of ready-to-run models that illustrate real-world uses of the module.
Each model starts with a model definition and results presentation. This part also includes information about how to implement the analysis using the MEMS Module. The last part of the model contains step-by-step instructions on how to build the model, perform the analysis, and finally visualize and postprocess the solution. For an overview of the functionality in the MEMS Module and a detailed introductory example, see the *MEMS Module User’s Guide* and the *MEMS Module Reference Guide*. For more information on how to work with the COMSOL Multiphysics user interface, please refer to the *COMSOL Multiphysics User’s Guide* or the *COMSOL Multiphysics Quick Start & Quick Reference* manual. An explanation on how to model using a programming language is available in yet another book, the *COMSOL Multiphysics Scripting Guide*.

Finally note that we supply these models as COMSOL Multiphysics Model MPH-files, available in the MEMS Module section on the Model Library page in the Model Navigator. You can open these models in COMSOL Multiphysics for immediate access making it possible to follow these examples every step along the way.

**Model Library Guide**

The table below summarizes key information about the entries in this model library. One column indicates which application modes (such as Plane Stress) the model includes. The solution time is the elapsed time measured on a machine running Windows Vista with a 2.6 GHz AMD Athlon X2 Dual Core 500 CPU and 2 GB of RAM. For models with a sequential solution strategy, the Solution Time column shows the total solution time. The following columns indicate the analysis type (such as eigenfrequency), and if multiphysics modeling or parametric studies are part of the model.

**TABLE 1-1: MEMS MODULE MODEL LIBRARY MODELS**

<table>
<thead>
<tr>
<th>MODEL</th>
<th>PAGE</th>
<th>APPLICATION MODES</th>
<th>SOLUTION TIME</th>
<th>STATIONARY</th>
<th>EIGENFREQUENCY</th>
<th>TIME DEPENDENT</th>
<th>PARAME TRIC</th>
<th>MULTIPHYSICS</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACTUATOR MODELS</td>
<td>7</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cantilever Beam</td>
<td>8</td>
<td>Plane Stress; Moving Mesh; Electrostatics</td>
<td>3 min</td>
<td>✓</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Actuator Beam 2D</td>
<td>18</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>MODEL</td>
<td>PAGE</td>
<td>APPLICATION MODES</td>
<td>SOLUTION TIME</td>
<td>STATIONARY</td>
<td>EIGENFREQUENCY</td>
<td>TIME DEPENDENT</td>
<td>PARAMETRIC</td>
<td>MULTIPHYSICS</td>
</tr>
<tr>
<td>------------------------------</td>
<td>------</td>
<td>-----------------------------------------------------------------------------------</td>
<td>---------------</td>
<td>------------</td>
<td>----------------</td>
<td>----------------</td>
<td>------------</td>
<td>--------------</td>
</tr>
<tr>
<td>Cantilever Beam 3D</td>
<td>28</td>
<td>Solid, Stress-Strain; Moving Mesh; Electrostatic</td>
<td>2 min</td>
<td>√</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Comb Drive</td>
<td>34</td>
<td>Plane Stress; Moving Mesh; Electrostatic</td>
<td>4 min</td>
<td>√</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Capacitive 3D Comb Drive</td>
<td>50</td>
<td>Electrostatic</td>
<td>1 s</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Gecko Foot</td>
<td>60</td>
<td>Solid, Stress Strain</td>
<td>37 s</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Microresistor Beam</td>
<td>64</td>
<td>Solid, Stress-Strain; Heat Transfer; Conductive Media DC</td>
<td>17 s</td>
<td>√</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Micromirror</td>
<td>67</td>
<td>Solid, Stress-Strain</td>
<td>17 min</td>
<td>√</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Resonator Models</td>
<td>79</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Resonator, Straight 2D</td>
<td>84</td>
<td>Plane Stress</td>
<td>5 s</td>
<td>√</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Resonator, Folded 2D</td>
<td>90</td>
<td>Plane Stress</td>
<td>9 s</td>
<td>√</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Resonator, Straight 3D</td>
<td>97</td>
<td>Solid, Stress-Strain</td>
<td>34 s</td>
<td>√</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Resonator, Folded 3D</td>
<td>105</td>
<td>Solid, Stress-Strain</td>
<td>42 s</td>
<td>√</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Thermoelastic Damping Models</td>
<td>112</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Thermoelastic Damping 3D</td>
<td>121</td>
<td>Solid, Stress-Strain; Heat Transfer by Conduction</td>
<td>51 s</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Thermoelastic Damping 2D</td>
<td>124</td>
<td>Plane Stress; Heat Transfer by Conduction</td>
<td>1 s</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SENSOR MODELS</td>
<td>129</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Accelerometer Models</td>
<td>130</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Accelerometer 2D</td>
<td>135</td>
<td>Plane Stress; Weak Form PDE</td>
<td>52 s</td>
<td>√</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Accelerometer 3D</td>
<td>139</td>
<td>Solid, Stress-Strain; Weak Form PDE</td>
<td>56 min</td>
<td>√</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>MEMS Gyroscope</td>
<td>145</td>
<td>Solid, Stress-Strain; Film Damping</td>
<td>7 min</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Capacitive Pressure Sensor</td>
<td>161</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
## Table 1-1: MEMS Module Model Library Models

<table>
<thead>
<tr>
<th>Model</th>
<th>Page</th>
<th>Application Modes</th>
<th>Solution Time</th>
<th>Stationary</th>
<th>Eigenfrequency Dependent</th>
<th>Time Dependent</th>
<th>Parametric</th>
<th>Multiphysics</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pressure Sensor 2D</td>
<td>172</td>
<td>Plane Stress; Weak Form PDE; Electrostatics</td>
<td>2 min</td>
<td>√</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Pressure Sensor 3D</td>
<td>181</td>
<td>Solid Stress-Strain; Plane Strain</td>
<td>5 min</td>
<td>√</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SAW Gas Sensor</td>
<td>190</td>
<td>Piezo Plane Strain</td>
<td>42 s</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Thermal Expansion in a MEMS Device</td>
<td>205</td>
<td>Solid, Stress-Strain; Heat Transfer by Conduction</td>
<td>7 s</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Microfluidics Models</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>AC Electrokinetic 2D</td>
<td>220</td>
<td>Electrostatics; Convection and Conduction; Incompressible Navier-Stokes; Diffusion and Convection; Diffusion</td>
<td>5 min</td>
<td>√</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Electrokinetic Valve 3D</td>
<td>249</td>
<td>Electrokinetic Flow; Incompressible Navier-Stokes; Conductive Media DC; Poisson’s Equation</td>
<td>44 s</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fluid-Structure Interaction</td>
<td>273</td>
<td>Plane Strain with Fluid Interaction</td>
<td>2 min</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Lamella Mixer</td>
<td>286</td>
<td>Incompressible Navier-Stokes; Diffusion and Convection</td>
<td>4 min</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Electroosmotic Flow in a Biochip</td>
<td>301</td>
<td>Electroosmotic Flow</td>
<td>1 s</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Low-Voltage Electroosmotic Micropump</td>
<td>314</td>
<td>Electroosmotic Flow</td>
<td>25 s</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Electroosmotic Mixer</td>
<td>328</td>
<td>Incompressible Navier-Stokes; Conductive Media DC</td>
<td>3 min</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Star-Shaped Microchannel Chip</td>
<td>343</td>
<td>Incompressible Navier-Stokes</td>
<td>60 s</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>MODEL</td>
<td>PAGE</td>
<td>APPLICATION MODES</td>
<td>SOLUTION TIME</td>
<td>STATIONARY</td>
<td>EIGENFREQUENCY</td>
<td>TIME DEPENDENT</td>
<td>PARAMETRIC</td>
<td>MULTIPHYSICS</td>
</tr>
<tr>
<td>-----------------------------------------------</td>
<td>------</td>
<td>-------------------------------------------------------</td>
<td>---------------</td>
<td>------------</td>
<td>----------------</td>
<td>----------------</td>
<td>------------</td>
<td>--------------</td>
</tr>
<tr>
<td>Microchannel H-Cell</td>
<td>356</td>
<td>Flow with Species Transport</td>
<td>5 min</td>
<td>√</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Inkjet Nozzle, Level Set</td>
<td>370</td>
<td>Two-Phase Flow, Laminar, Level Set</td>
<td>4 h</td>
<td>√</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Inkjet Nozzle, Phase Field</td>
<td>370</td>
<td>Two-Phase Flow, Laminar, Phase Field</td>
<td>169 min</td>
<td>√</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Filling of a Capillary Channel, Level Set</td>
<td>392</td>
<td>Two-Phase Flow, Laminar, Level Set</td>
<td>30 min</td>
<td>√</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Filling of a Capillary Channel, Phase Field</td>
<td>392</td>
<td>Two-Phase Flow, Laminar, Phase Field</td>
<td>43 min</td>
<td>√</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Hydrocarbon Dehalogenation in a Tortuous Microreactor†</td>
<td>413</td>
<td>Incompressible Navier-Stokes</td>
<td>35 s</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Two-Phase Fluid-Structure Interaction</td>
<td>429</td>
<td>Plane Strain with Fluid Interaction; Two-Phase Flow, Laminar, Phase Field</td>
<td>77 min</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Droplet Breakup in a T-Junction</td>
<td>441</td>
<td>Two-Phase Flow, Laminar, Level Set</td>
<td>7 h</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>PIEZOELECTRICITY MODELS</td>
<td>451</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Piezoceramic Tube</td>
<td>453</td>
<td>Piezo Axial Symmetry; Axial Symmetry, Stress-Strain</td>
<td>1 s</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Piezoelectric Shear Actuated Beam</td>
<td>466</td>
<td>Piezo Solid</td>
<td>4 s</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Composite Piezoelectric Transducer</td>
<td>478</td>
<td>Piezo Solid; Solid, Stress-Strain</td>
<td>6 min</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Thin Film BAW Composite Resonator</td>
<td>489</td>
<td>Piezo Plane Strain</td>
<td>8 min</td>
<td>√</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Tunable Piezoelectric Actuator</td>
<td>507</td>
<td>Piezo Plane Strain</td>
<td>2 min</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

* In the MEMS Module User’s Guide.
† This model requires the COMSOL Reaction Engineering Lab.
We welcome any questions, comments, or suggestions you might have concerning these models. Contact us at info@comsol.com or call your local COMSOL representative.

Typographical Conventions

All COMSOL manuals use a set of consistent typographical conventions that should make it easy for you to follow the discussion, realize what you can expect to see on the screen, and know which data you must enter into various data-entry fields. In particular, you should be aware of these conventions:

• A **boldface** font of the shown size and style indicates that the given word(s) appear exactly that way on the COMSOL graphical user interface (for toolbar buttons in the corresponding tooltip). For instance, we often refer to the **Model Navigator**, which is the window that appears when you start a new modeling session in COMSOL; the corresponding window on the screen has the title **Model Navigator**. As another example, the instructions might say to click the **Multiphysics** button, and the boldface font indicates that you can expect to see a button with that exact label on the COMSOL user interface.

• The names of other items on the graphical user interface that do not have direct labels contain a leading uppercase letter. For instance, we often refer to the Draw toolbar; this vertical bar containing many icons appears on the left side of the user interface during geometry modeling. However, nowhere on the screen will you see the term “Draw” referring to this toolbar (if it were on the screen, we would print it in this manual as the **Draw** menu).

• The symbol `>` indicates a menu item or an item in a folder in the **Model Navigator**. For example, **Physics>Equation System>Subdomain Settings** is equivalent to: On the **Physics** menu, point to **Equation System** and then click **Subdomain Settings**. **COMSOL Multiphysics>Heat Transfer>Conduction** means: Open the **COMSOL Multiphysics** folder, open the **Heat Transfer** folder, and select **Conduction**.

• A **Code** (monospace) font indicates keyboard entries in the user interface. You might see an instruction such as “Type 1.25 in the **Current density** edit field.” The monospace font also indicates COMSOL Script codes.

• An **italic** font indicates the introduction of important terminology. Expect to find an explanation in the same paragraph or in the Glossary. The names of books in the COMSOL documentation set also appear using an italic font.
MEMS Actuator Models

This chapter contains example models of MEMS actuators such as cantilever beams, comb drives, gecko feet, micromirrors, and resonators. These models often include movements and geometry changes. Using the Moving Mesh (ALE) application mode you can include such effects in your own models, and the cantilever beam and comb drive models show how to do so. The Capacitive 3D Comb Drive model is an example of how to make a quick 3D analysis of the electrostatic field and calculate a base capacitance value based on that. Prestressed Micromirror and Thin-Film Resonator are pure continuum mechanics models. They demonstrate how you can model residual stresses using initial stress option. The model Microresistor Beam exemplifies electro-thermal-structural couplings. The idea is to move the structure by conducting a current through conductive layers and generate a temperature increase that leads to a displacement through thermal expansion. The Gecko Foot model uses assembly features and interactive meshing to model both the nanohair and microhair of a synthetic gecko foot.
Cantilever Beam

Introduction

The elastic cantilever beam is an elementary structure in MEMS design. This example shows the bending of a beam due to electrostatic forces. The primary problem the model addresses is the 2-way coupling between the deformations and the electric field and how it affects the stability and impedance of the device.

The model solves the electrostatic equation in the air domain surrounding the beam using the arbitrary Lagrangian-Eulerian (ALE) method to account for geometry changes associated with the deformation. There are two versions: a 2D model and a 3D model. The 2D model uses the Plane Strain and the Electrostatics application modes from the MEMS Module and then the Moving Mesh (ALE) application mode from COMSOL Multiphysics. The 3D model uses the Solid, Stress-Strain application mode for the structural part.

Model Definition

Figure 2-1 and Figure 2-2 show the model geometry both in 2D and 3D. The dimensions of the beam are: Length: 300 µm; Width: 20 µm; and Thickness 2 µm. The cantilever beam, made of polysilicon (Young’s modulus, $E$, for the material is 153 GPa, and its Poisson’s ratio, $\nu$, is 0.23), is fixed at one end but is otherwise free to move. It is coated with a thin conductive layer from the lower side. The beam resides in an air-filled chamber that is electrically insulated. However, the lower side of the chamber has a grounded electrode.

An electrostatic force caused by an applied potential difference between the two electrodes bends the beam toward the grounded layer below it. To compute the electrostatic force, this example calculates the electric field in the surrounding air. The model considers a layer of air 20 µm thick both above and to the sides of the beam, and the air gap between the bottom of the beam and the grounded layer is initially 2 µm. As the beam bends, the geometry of the air changes continuously. Using the ALE method, the model takes this displacement into account when computing the potential field. When the geometry deforms, the electric field between the electrodes continuously changes as a result of the bending.
Figure 2-1: The cantilever-beam model's initial geometry. In 2D the beam has a length of 300 µm and a height of 2 µm, and it is fixed at the left boundary. The lower boundary of the surrounding air domain represents the grounded substrate.

Figure 2-2: The cantilever beam's initial geometry in 3D. The beam is 300 µm long and 2 µm thick, and it is fixed at x = 0. The model uses symmetry on the xz-plane at y = 0. The lower boundary of the surrounding air domain represents the grounded substrate. The model has 20 µm of free air above and to the sides of the beam, while the gap below the beam is 2 µm.

The electrostatic field in the air and in the beam is governed by the electrostatic equation

\[-\nabla \cdot (\varepsilon \nabla V) = 0\]

where derivatives are taken with respect to the spatial coordinates. These are independent of the deformation of the material. The numerical model, however, needs to represent the electric potential and its derivatives on a mesh which is moving with respect to the spatial frame. The necessary transformations are taken care of by the Moving Mesh (ALE) application mode, which also contains smoothing equations governing the movement of the mesh in the air domain.

The lower boundary of the cantilever connects to a voltage source with a specified bias potential, \(V_{in}\). The bottom of the chamber is grounded, while all other boundaries are electrically insulated. Weak constraints make it possible to evaluate the total surface
charge, $Q$, on the beam electrode with high accuracy, something which is necessary for calculating the capacitance of the system.

The force density that acts on the electrode of the beam results from Maxwell’s stress tensor:

$$ F_{es} = -\frac{1}{2}(E \cdot D)n + (n \cdot E)D^T, $$

where $E$ and $D$ are the electric field and electric displacement vectors, respectively, and $n$ is the outward normal vector of the boundary. This force is always oriented along the normal of the boundary.

Navier’s equations which govern the deformation of a solid are more conveniently written in a coordinate system which follows and deforms with the material. In this case, these reference or material coordinates are identical to the actual mesh coordinates. Therefore, the solid equations are not affected by the use of ALE for the electrostatic field.

This 2D model solves the structural deformation of the beam using the plane strain approximation. A plane stress assumption is probably closer to reality, but would not be consistent with the 2D electrostatics formulation which is intrinsically of the same kind as the structural plane strain equations.

**DC Capacitance and AC Impedance**

Because the electrostatic field in and the structural deformations are tightly coupled in this model, the capacitance of the system depends very much on its structural properties. Here, it is necessary to differentiate between the incremental DC capacitance $C_{DC}$ and the frequency-dependent AC capacitance $C_{AC}$. The former is defined as the change in surface charge, $\Delta Q$, induced by a step change in the applied voltage from $V_{in} = V_0$ to $V_{in} = V_0 + \Delta V_{in}$, that is,

$$ C_{DC} = \frac{\Delta Q}{\Delta V_{in}} \quad (2-1) $$

When the stationary parametric solver has been used to increase the applied voltage step by step until pull-in, you can easily estimate the DC capacitance as a quotient between the surface charge increment and the voltage increment between two consecutive solution steps.

To define the AC capacitance, it is necessary to make a detour via the definition of the AC impedance, $Z_{AC}$:
where $V_{AC}$ is the amplitude of a small sinusoidal signal with angular frequency $\omega$ overlaid on the bias voltage such that $V_{in} = V_0 + V_{AC}e^{i\omega t}$. In the above equation, $I_{AC}$ is the resulting AC current. Using the definition

$$I_{AC} = \frac{dQ_{AC}}{dt} = i\omega Q_{AC}$$

where $Q_{AC}$ is the complex-valued surface charge response to the applied small signal, you can rewrite Equation 2-2 as

$$C_{AC} = \frac{1}{i\omega V_{AC}} I_{AC} = \frac{1}{i\omega V_{AC}} \frac{dQ_{AC}}{dt} = \frac{Q_{AC}}{V_{AC}}$$  (2-3)

To find the small signal response of a nonlinear system about a stationary solution, all you need to do is change the model into a frequency response problem, add the small harmonic excitation and solve using the small utility function \texttt{femssr} in a simple solver script.

\textbf{Results}

A positive feedback exists between the electrostatic forces and the deformation of the cantilever beam. The forces bend the beam and thereby reduce the gap to the grounded substrate. This action, in turn, increases the forces. At a certain voltage the electrostatic forces overcome the stress forces, the system becomes unstable, and the gap collapses. This critical voltage is called the pull-in voltage.

At applied voltages lower than the pull-in voltage, the beam stays in an equilibrium position where the stress forces balance the electrostatic forces. Figure 2-3 shows the potential field and the deformations for the 2D case and Figure 2-4 shows the solution for the 3D case. Figure 2-5 shows the shape of the cantilever’s deformation extracted from 3D results along the long edge for different applied potential values.

When solving for a level higher than the pull-in voltage, the solution ceases to converge before the beam touches the substrate. This is an effect of the ALE method not being able to handle topology changes. By scanning over different applied voltages and using the parametric solver, you can study the beam’s behavior and estimate the pull-in voltage. Figure 2-6 shows the deflection of the beam’s end in a 2D model for different applied potential values.
Figure 2-3: (2D model) The potential field and deformations at the cantilever beam’s equilibrium position for an applied potential of 6.3 V.

Figure 2-4: (3D model) Steady-state solution for the 3D cantilever-beam model with an applied potential of 6.1 V. The boundaries display the electric potential; the arrows show the electric field; the black edges indicate the nondeformed beam geometry; and the white edges delineate the deformed geometry.
Figure 2-5: (3D model) The deformed shape of the cantilever along the long edge for several applied potential values between 1 V. and 6.1 V.

Figure 2-6: (2D model) Vertical displacement at the beam tip as a function of the applied voltage. The solution ceases to converge just before the beam touches the substrate.
The Figure 2-6 indicates that the pull-in voltage of the 300 µm long cantilever beam is somewhere between 6.3 V and 6.4 V. Using a finer mesh and computing the solution for a number of voltages in this range should reduce the size of this interval. The deformation of the 3D model with applied potential 6.1 V is roughly the same as for the 2D model with the larger applied potential, which suggests that the pull-in should appear at roughly between 6.1 V and 6.2 V.

For comparison, computations in Ref. 1 lead to the pull-in voltage of

\[ V_{PI} = \sqrt{\frac{4c_1 B}{\epsilon_0 L^4 c_2 c_3 g_0 g_0}} \]

where \( c_1 = 0.07, c_2 = 1.00, \) and \( c_3 = 0.42; g_0 \) is the initial gap between the beam and the ground plane; and

\[ B = \frac{E H^3}{\bar{E} g_0^3}. \]

If the beam has a narrow width (W) relative to its thickness (H) and length (L), \( E \) is Young’s modulus, \( \bar{E} \). Otherwise, \( E \) and \( \bar{E} \), the plate modulus, are related by

\[ \frac{E}{\bar{E}} = 1 - \nu^2 \left[ (W/L)^{1.37} \right] \frac{0.98(L/H)^{4.04}}{0.5 + (W/L)^{1.37}} \]

where \( \nu \) is Poisson’s ratio. Because the calculation in Ref. 1 uses a parallel-plate approximation for calculating the electrostatic force and because it corrects for fringing fields, these results are not directly comparable with those from the simulation. Inserting the data from the model in the formula and using an infinite width, \( W \), to disable the fringing-field correction gives \( V_{PI} = 6.35 \) V. Setting \( W = 20 \) µm results in \( V_{PI} = 6.07 \) V.

**CAPACITANCE**

A simple finite difference approximation following Equation 2-1 shows that the DC capacitance increases with increasing bias (Figure 2-7). On one hand, this is consistent with the behavior of an ideal parallel plate capacitor, whose capacitance increases with decreasing distance between the plates. But this does not explain all of the increase. In fact, most of it is due to the gradual softening of the coupled electro-mechanical system. This effect leads to a larger structural response for a given voltage increment.
at higher bias, which in turn means that more charge must be added to retain the voltage difference between the electrodes.

Figure 2-7: You can estimate the DC capacitance as a quotient between consecutive increases in surface charge and applied voltage.

The AC capacitance evaluated at 6.3 V bias shows a typical behavior (Figure 2-8). Below the fundamental resonance, the capacitance increases with frequency because there is increasing positive feedback between the voltage and the displacement. Above the resonance, the beam vibrates out-of-phase with the electrical forces acting on it.
leading to negative capacitance for frequencies where the displacement is large. In the low frequency end, the AC capacitance converges towards the DC capacitance.

Figure 2-8: The AC capacitance of the 2D cantilever beam reaches a maximum at the fundamental resonance frequency of the coupled system, where it also switches sign because of the rapid phase shift in the structural response.

Note that the fundamental frequency decreases with increasing bias. At 6.3 V, the frequency has decreased to less than half its unbiased value of about 29 kHz. For a simple beam, this frequency is easily calculated from

\[
 f_0 = \frac{1.875^2}{2\pi} \frac{EH^2}{12\rho L^4}
\]

where \( \rho \) is the beam density 2330 kg/m\(^3\), and other dimensions as above.

While the non-convergence of the nonlinear solver at and above the pull-in voltage can be explained from the physical point of view as a pull-in or collapse, and from the numerical view point can be blamed on the ALE method’s inability to handle topological changes, the pure mathematical explanation is that at pull-in, the fundamental eigenfrequency approaches zero.
Modeling in COMSOL Multiphysics

The COMSOL Multiphysics model requires three application modes: one for the structural deformation, which uses the reference frame and is only active in the beam; one for the electrostatic field, which exists everywhere and uses the spatial frame; and one Moving Mesh (ALE) application mode, which defines the relation between the spatial frame and the reference frame. The Moving Mesh (ALE) application mode solves mesh smoothing equations in the air domain, but uses the solid displacements to define the coordinate transformations inside the beam.

Because the solid deformations are described on the reference frame and the electrostatics on the spatial frame, there is a slight mismatch in the boundary conditions connecting them. The electrostatic forces as calculated by the electrostatic application mode are true surface tractions, while the forces entered in the solid application mode are first Piola-Kirchhoff stresses. These pseudo-stresses have true direction but magnitude referred to the undeformed configuration. If the surface area is changed appreciably by the deformation, this mismatch affects the global force balance. In this case, the effect is negligible, though. Otherwise it is quite easy to compensate for.

The parametric solver efficiently simulates the beam’s stationary response to a range of applied potentials. For the 2D case, the fully coupled solver is efficient and easy to set up. The 3D case uses the Segregated parametric solver, which saves memory and can often be a more robust way to handle a coupled nonlinear problem.

For performing a frequency sweep, estimating the small-signal response of the system about a stationary state, you can use a small utility function, \texttt{femssr}. This function is essentially a wrapper for the linear solver, which assembles the tangent stiffness matrix and small-signal load vectors in a special way. Given a frequency domain model and a stationary nonlinear solution valid at zero frequency, \texttt{femssr} returns the frequency response for a specified frequency range.

Reference

Model Library path: MEMS_Module/Actuator_Models/ale_cantilever_beam_2d

Model Library path: MEMS_Module/Actuator_Models/ale_cantilever_beam_3d

Modeling Using the Graphical User Interface—2D Version

**Model Navigator**

1. In the Model Navigator select 2D from the Space dimension list and then click Multiphysics.
2. From the list of application modes on the left side of the dialog box select MEMS Module>Structural Mechanics>Plane Strain and then click Add.
3. From the list of application modes select COMSOL Multiphysics>Deformed Mesh>Moving Mesh (ALE) and then click Add.
4. In the Multiphysics list on the right side of the dialog box, select Frame (ale) then add MEMS Module>Electrostatics>Electrostatics to that list. As a result, the selected application modes in Model Navigator window look like this:

![Model Navigator window with selected application modes](image)

5. Click OK to close the Model Navigator.

**Geometry Modeling**

1. From the Options menu, choose Axes/Grid Settings.
2. Clear the Axis equal check box, then click OK.
3. While holding down the Shift key, click the Rectangle/Square button on the Draw toolbar on the far left side of the graphical user interface; this action opens the Rectangle dialog box. Enter dimensions as in the following table, then click OK.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>300e-6</td>
</tr>
<tr>
<td>Height</td>
<td>2e-6</td>
</tr>
<tr>
<td>X</td>
<td>0</td>
</tr>
<tr>
<td>Y</td>
<td>2e-6</td>
</tr>
</tbody>
</table>
Repeat the procedure to make another rectangle but with these dimensions:

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>320e-6</td>
</tr>
<tr>
<td>Height</td>
<td>10e-6</td>
</tr>
<tr>
<td>X</td>
<td>0</td>
</tr>
<tr>
<td>Y</td>
<td>0</td>
</tr>
</tbody>
</table>

Click the **Zoom Extents** button on the Main toolbar at the top of the graphical user interface.

The inner rectangle represents the cantilever beam and the outer rectangle the surrounding air. These two objects would be enough to model the geometry with an unstructured mesh. However, in this model you use a mapped mesh, and for that purpose you add a rectangle that divides the air into three subdomains. This helps you create a rectangular mesh later on.

Repeat the procedure to create a third rectangle with these dimensions:

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>20e-6</td>
</tr>
<tr>
<td>Height</td>
<td>2e-6</td>
</tr>
<tr>
<td>X</td>
<td>300e-6</td>
</tr>
<tr>
<td>Y</td>
<td>2e-6</td>
</tr>
</tbody>
</table>

The resulting geometry should look like that in the figure below:

*Completed 2D model geometry.*
OPTIONS
To calculate the DC and AC capacitances, you need access to the total surface charge on the electrodes. The local surface charge density is given by the application mode variable nD_emes.

Boundary Integration Variables
1. From the Options menu, select Integration Coupling Variables>Boundary Variables.
2. Select the beam-side electrode, boundary 4.
3. Enter Q in the Name column and nD_emes in the Expression column, both on the first line of the table.
4. Click OK to accept and close the dialog box.

PHYSICS SETTINGS
Application Mode Properties—Electrostatics
By using weak constraints in the Electrostatics application mode, you can improve the accuracy of the total surface charge evaluation substantially.
1. Go to the Multiphysics menu and make sure that Electrostatics (emes) is selected.
2. Choose Properties from the Physics menu.
3. Set Weak contraints to on and click OK to close the dialog box.

Subdomain Settings—Electrostatics
4. Open the Physics>Subdomain Settings dialog box and select Subdomains 1, 3, and 4. The default settings ($\varepsilon_r = 1$) corresponds to air, so keep them.
5. While still in that dialog box, select Subdomain 2. For the relative permittivity, $\varepsilon_r$, enter the value 4.5 (for polysilicon).
6. Click the Force tab. In the first row enter $F_{\text{es}}$. The software automatically generates the variables $F_{\text{es}_nTx_\text{emes}}$ and $F_{\text{es}_nTy_\text{emes}}$ for the electrostatic force components. Later on you use these variables to define the boundary load in the Plane Strain application mode.
7. Click OK.

Boundary Conditions—Electrostatics
8. From the Physics menu, open the Boundary Settings dialog box.
9 Select the **Interior boundaries** check box, then specify conditions as follows:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 1, 3, 5, 7, 11–13</th>
<th>BOUNDARY 4</th>
<th>BOUNDARY 2</th>
<th>BOUNDARIES 6, 8, 9, 10</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Zero charge/ Symmetry</td>
<td>Electric potential</td>
<td>Ground</td>
<td>Continuity</td>
</tr>
<tr>
<td>$V_0$</td>
<td></td>
<td></td>
<td>$V_{in}$</td>
<td></td>
</tr>
</tbody>
</table>

10 Click **OK**.

**Subdomain Settings—Moving Mesh**

1 From the **Multiphysics** menu, select **Moving Mesh (ale)**.

2 In the **Subdomain Settings** dialog box select the those for air (Subdomains 1, 3, and 4). Keep the default **Free displacement** setting.

3 While still in that dialog box select Subdomain 2. Inside the cantilever beam use **Physics induced displacement**. For the displacement variables, $dx$ and $dy$, enter $u$ and $v$, respectively. These are the displacements from the Plane Strain application mode.

4 Click **OK**.

**Boundary Conditions—Moving Mesh**

5 In the **Boundary Settings** dialog box, for the mesh displacements, $dx$ and $dy$, enter the following values for outer settings (do not assign any settings for interior boundaries, which appear dimmed):

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 4, 6, 8</th>
<th>ALL OTHERS</th>
</tr>
</thead>
<tbody>
<tr>
<td>$dx$</td>
<td>$u$</td>
<td>0</td>
</tr>
<tr>
<td>$dy$</td>
<td>$v$</td>
<td>0</td>
</tr>
</tbody>
</table>

6 Click **OK**.

**Application Mode Properties—Plane Strain**

1 From the **Multiphysics** menu, choose **Plane Strain (smpn)**.

2 From the **Physics** menu, choose **Properties** to open the **Application Mode Properties** dialog box.

3 From the **Large deformation** list, select **On**.

4 Click **OK** to close the dialog box.

The large-deformation option ensures that the solver uses a nonlinear stress-strain relationship to calculate the results in the Plane Strain application mode.
Subdomain Settings—Plane Strain
5 In the Subdomain Settings dialog box select Subdomain 2 and enter the following settings. Later on you use the parametric solver to find an estimate for the pull-in voltage, thus you only need to specify Young’s modulus, $E$, Poisson’s ratio, $v$, and the thickness.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>$E$</td>
<td>$153e9$</td>
</tr>
<tr>
<td>$v$</td>
<td>$0.23$</td>
</tr>
<tr>
<td>$\alpha$</td>
<td>$4.15e-6$</td>
</tr>
<tr>
<td>$\rho$</td>
<td>$2330$</td>
</tr>
<tr>
<td>thickness</td>
<td>$20e-6$</td>
</tr>
</tbody>
</table>

6 While still in the dialog box select Subdomains 1, 3, and 4. To make this application mode inactive outside the cantilever, clear the Active in this domain check box.

7 Click OK.

Boundary Conditions—Plane Strain
8 From the Physics menu, select Boundary Settings. In the resulting dialog box verify that the Interior boundaries check box is cleared.

9 Click the Constraint tab. Select Boundary 3. From the Constraint condition list select Fixed.

10 Click the Load tab. Enter boundary loads according to the following table; when finished, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 3, 6, 8</th>
<th>BOUNDARY 4</th>
</tr>
</thead>
<tbody>
<tr>
<td>$F_x$</td>
<td>$0$</td>
<td>$Fes_{nTx_emes}$</td>
</tr>
<tr>
<td>$F_y$</td>
<td>$0$</td>
<td>$Fes_{nTy_emes}$</td>
</tr>
</tbody>
</table>

$Fes_{nTx\_emes}$ and $Fes_{nTy\_emes}$ are automatically generated variables from the Electrostatics application mode (\_emes) that define the $x$- and $y$-components of the electrostatic force, respectively.

11 Click OK to accept the boundary conditions.

Mesh Generation
1 From the Mesh menu, open the Mapped Mesh Parameters dialog box.

2 Click the Boundary tab. Select Boundaries 1, 3, and 5.
3 Check the **Constrained edge element distribution** check box and type 5 in the **Number of edge elements** edit field.

4 Repeat the previous step for Boundaries 6 and 10, in turn, using the values 60 and 4, respectively, for the **Number of edge elements**.

5 Click **Remesh**.

6 When the mesher has finished, click **OK**.

The completed mesh should look like that in the following figure.

![Mesh for the 2D model.](image)

**Computing the Solution**

1 From the **Solver** menu, open the **Solver Parameters** dialog box.

2 Go to the **Solver** list and select **Parametric**.

3 In the **Parameter name** edit field, type $V_{\text{in}}$.

4 In the **Parameter values** edit field type $1:6, 6.1:0.1:6.3$. Because the cantilever deforms less at lower voltages, start with a long step (1.0 V) and then, when the solution gets closer to the pull-in value, use a shorter step (0.1 V).

5 Click **OK**.

6 Click the **Solve** button on the Main toolbar.
Note: If you try to solve the model for higher values of the applied voltage (for example, 6.4) the solver ceases to find a proper solution and you receive an error message ("Failed to find a solution for all parameters, even when using the minimum parameter step."). This indicates that you have exceeded the pull-in voltage. In that case, you can scroll up the log area of the solver’s Progress window to find out the latest parameter values that the solver tried to use. That way you can get a more accurate estimate for the pull-in voltage.

POSTPROCESSING AND VISUALIZATION
The default plot shows the von Mises stress at the last successful parameter value $V_{in}(9) = 6.3$ V. To see deformations inside the cantilever beam, follow these instructions:

1. From the Postprocessing menu, open the Plot Parameters dialog box.
2. On the General page select the Surface check box. Make sure the check boxes for all other plot types are cleared.
3. Click the Surface tab. Go to the Predefined quantities list and select Plane Strain (smps)>Total displacement.
4. Click Apply.

To visualize the deformed mesh in the air domain, do as follows:

1. Click the General tab.
2. Clear the Element refinement: Auto check box and type 1 in the associated edit field. This makes a wireframe plot that represents the computational mesh.
3. Make sure that only the Surface and Geometry edges check boxes are selected.
4. Make sure that Frame (ale) is selected from the Frame list.
5. Click the Surface tab. From the Predefined quantities list on the Subdomain Data page, select Electrostatics (emes)>Electric potential. From the Fill style list in the Coloring and fill area, select Wireframe.
6. Click OK. This generates the plot in Figure 2-3 on page 12.

Next, plot the displacement of the cantilever beam’s tip as a function of the voltage:

7. From the Postprocessing menu, select Domain Plot Parameters.
8 Click the **Title/Axis** button. Click the option button next to the **First axis label** edit field and enter the label **Applied voltage [V]**. Click **OK**.

9 Click the **Point** tab. From the **Point selection** list, select Point 5. From the **Predefined quantities** list, select **Plane Strain (smnp)>Y-displacement**. From the **Unit** list, select **um** to get the plot unit micrometer.

10 Click **OK** to close the dialog box and generate the plot in Figure 2-6.

When estimating the DC capacitance, you can exploit the fact that the first 6 input voltages are integer numbers which coincide with the corresponding solution numbers. This means you can use the input voltage to select which solution to use for evaluation in the **with** operator.

1 From the **Postprocessing** menu, select **Global Variables Plot**.

2 Type **with(V_in,Q)-with(V_in-1,Q)** in the **Expression** field and click the **>** button just next to it.

3 Select input voltages 2, 3, 4, 5, and 6 in the **Solutions to use** list.

4 Click **OK** to close the dialog box and display the result.

5 On the toolbar in the figure window, click **Edit Plot**.

6 In the **Title** and **y label** edit fields type **DC Capacitance [F]**.

7 Click **OK** to update the figure.

**Evaluating the AC Capacitance**

Now proceed to evaluate the AC capacitance at the highest input voltage. This requires some minor modifications to the model and a solver script.

To perform a frequency sweep around a stationary biased solution, you must first put the equations on frequency response form and add the small-signal excitation on top of the bias. When using the parametric solver, the input voltage was controlled from **Solver Settings**. This time, you must specify **V_in** explicitly in the model. If you choose 1 V as small-signal amplitude, evaluating the capacitance according to Equation 2-3 becomes particularly easy. Therefore, set **V_in** to 7.3 V

**OPTIONS**

**Constants**

1 Choose **Constants** from the **Options** menu.

2 Create a new constant **V_in** with value 7.3.
3 Click **OK** to accept and close the dialog box.

**PHYSICS SETTINGS**

*Application Mode Properties—Plane Strain*

1 From the **Multiphysics** menu, choose **Plane Strain (smn)**.
2 Select **Properties** from the **Physics** menu.
3 From the **Analysis type** list, select **Frequency response**.
4 Click **OK** to close the dialog box.

**COMPUTING THE SOLUTION**

The small utility script `femssr.m` takes four required arguments: the `fem` structure, the stationary bias solution, the frequency parameter name, and a list of frequencies. As output, it returns a parametric solution where the stationary solution has been stored corresponding to frequency 0.

1 Click the **Solver Manager** button on the Main toolbar.
2 Go to the **Script** page and select the **Solve using a script** checkbox.
3 Enter the following solver script:

   ```matlab
   biassol = asseminit(fem,'init',fem0.sol,'solnum',9);
   fem.sol=femssr(fem,biassol,'freq_smpn',1000:1000:30000);
   fem0=fem
   ```

   The first line extracts the last stationary solution step, corresponding to a 6.3 V bias, to be used as bias solution. The second line sets up the `femssr` utility script to calculate the frequency response between 1 kHz and 30 kHz in steps of 1 kHz.
4 Click **OK** to close the dialog box.
5 Click the **Solve** button on the Main toolbar to start the script.

**POSTPROCESSING AND VISUALIZATION**

The plot immediately shows the incremental deformation induced by the overlaid AC signal. Note that the beam is pointing up rather than down because it is oscillating out of phase with the applied voltage at 30 kHz.

The plot shows nothing in the air domain, because the incremental mesh displacement is now used as mesh position in the ALE frame—so the entire mesh in this domain is curled up in a mess at the origin. To avoid plotting anything in the air domain, switch surface expression to something which only exists in the solid:

1 Click the **Plot Parameters** button on the Main toolbar.
2 Go to the Surface page and select Total displacement from the list of Predefined quantities.

3 Click OK to close the dialog box and display the new plot.

Because the small signal excitation is 1 V, the AC capacitance is simply equal to the induced AC surface charge, according to Equation 2-3. To reproduce Figure 2-8 on page 16, do the following:

1 From the Postprocessing menu, choose Global Variables Plot.
2 Click the Remove All Quantities to Plot button (marked <<).
3 Type Q in the Expression field, then click the Add Entered Expression button (marked >).
4 Click OK to display the AC capacitance plot.
5 On the toolbar in the figure window, click Edit Plot.
6 In the Title and y label edit fields, type AC Capacitance [F].
7 Click OK to update the figure.

Modeling Using the Graphical User Interface—3D Version

MODEL NAVIGATOR
1 In the Model Navigator select 3D in the Space dimension list, then click Multiphysics.
2 From the list of application modes on the left side of the dialog box, select MEMS Module>Structural Mechanics>Solid, Stress-Strain. Click Add.
3 Click the Application Mode Properties button.
4 Select On from the Large deformation list; then click OK.
5 From the list of application modes, select COMSOL Multiphysics>Deformed Mesh>Moving Mesh (ALE) and then click Add.
6 Click the Application Mode Properties button.
7 Select Off from the Weak constraints list; then click OK.
8 In the Multiphysics list on the right side of the dialog box, select Frame (ale) then add MEMS Module>Electrostatics>Electrostatics to that list.
9 Click OK to close the Model Navigator.

GEOMETRY MODELING
1 Click the Block button on the Draw toolbar.
2 In the Length area, set X to 300e-6, Y to 10e-6, and Z to 2e-6.
3 Click OK.
4 Click the Arrow button.
5 In the Displacement, Z-field type 2e-6, and in the Array size, Z-field type 2; then click OK.
6 Click the Block button on the Draw toolbar.
7 Set X to 120e-6, Y to 40e-6, and Z to 24e-6.
8 Click OK.
9 Click the Zoom Extents button on the Main toolbar.

Figure 2-9: The geometry for 3D cantilever beam model. The inner block represents the cantilever beam and the outer rectangle the surrounding air. Symmetry is defined along the plane y = 0.

PHYSICS SETTINGS

Subdomain Settings—Solid, Stress-Strain
1 Go to the Multiphysics menu and make sure that the Solid, Stress-Strain (smsld) application mode is selected.
2 Open the Physics>Subdomain Settings dialog box and select Subdomains 1 and 3. To deactivate this application mode outside the cantilever, clear the Active in this subdomain check box.
1 While still in the dialog box, select Subdomain 2 and enter the following settings. Later on you use a static solver to find the cantilever’s displacement. Thus, you only need to specify Young’s modulus, \( E \), and Poisson’s ratio, \( \nu \).

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>( E )</td>
<td>153e9</td>
</tr>
<tr>
<td>( \nu )</td>
<td>0.23</td>
</tr>
<tr>
<td>( \alpha )</td>
<td>4.15e-6</td>
</tr>
<tr>
<td>( \rho )</td>
<td>2330</td>
</tr>
</tbody>
</table>

2 Click **OK**.

**Boundary Conditions—Solid, Stress-Strain**

1 From the **Physics** menu, select **Boundary Settings**.

2 Click the **Constraint** tab, then select Boundary 4. From the **Constraint condition** list select **Fixed**.

3 Select Boundary 5. From the **Constraint condition** list, select **Symmetry plane**.

4 Click the **Load** tab. Select Boundary 6, then enter the following settings:

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>( F_x )</td>
<td>( \text{Fes}_nT_x_emes )</td>
</tr>
<tr>
<td>( F_y )</td>
<td>( \text{Fes}_nT_y_emes )</td>
</tr>
<tr>
<td>( F_z )</td>
<td>( \text{Fes}_nT_z_emes )</td>
</tr>
</tbody>
</table>

Here, \( \text{Fes}_nT_x\_emes \), \( \text{Fes}_nT_y\_emes \), and \( \text{Fes}_nT_z\_emes \) are automatically generated variables from the Electrostatics application mode that define the \( x \)-, \( y \)-, and \( z \)-components of the electrostatic force toward the air.

5 Click **OK** to accept the boundary conditions.

**Subdomain Settings—Moving Mesh**

1 From the **Multiphysics** menu, select **Moving Mesh (ALE)**.

2 In the **Subdomain Settings** dialog box select the air (Subdomain 1 and 3). Keep the default **Free displacement** settings.

3 While still in the dialog box, select Subdomain 2. Inside the cantilever beam use **Physics induced** displacement. For the displacement variables, \( dx \), \( dy \), and \( dz \), enter \( u \), \( v \), and \( w \), respectively. These are the displacements from the Solid, Stress-Strain application mode.

4 Click **OK**.
Boundary Conditions—Moving Mesh

1. In the Boundary Settings dialog box for the mesh displacements, enter these settings:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 6, 9, 13, 16</th>
<th>BOUNDARIES 1, 3, 7, 10, 12, 14, 17</th>
<th>BOUNDARIES 2, 8</th>
</tr>
</thead>
<tbody>
<tr>
<td>dx</td>
<td>u</td>
<td>0</td>
<td>not selected</td>
</tr>
<tr>
<td>dy</td>
<td>v</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>dz</td>
<td>w</td>
<td>0</td>
<td>not selected</td>
</tr>
</tbody>
</table>

2. Click OK.

Subdomain Settings—Electrostatics

1. From the Multiphysics menu, select Electrostatics (emes).
2. From the Physics menu, open the Subdomain Settings dialog box.
3. For Subdomain 1 and 3, the default settings ($\varepsilon_r = 1$) corresponds to air, so keep them.
4. While still in that dialog box, select Subdomain 2.
5. For the relative permittivity, $\varepsilon_r$, enter the value 4.5 (for polysilicon).
6. Click the Force tab. In the first row enter $F_{es}$. The software automatically generates the variables $F_{es\_nTx\_emes}$, $F_{es\_nTy\_emes}$, and $F_{es\_nTz\_emes}$ for the electrostatic force components.
7. Click OK.

Boundary Conditions—Electrostatics

1. From the Physics menu, open the Boundary Settings dialog box.
2. First select all the boundaries and change the Boundary condition to Zero charge/Symmetry.
3. Next select only Boundaries 3 and 12, and for the Boundary condition select Ground.
4. Activate the Interior boundaries check box.
5. Select Boundary 6. Change the Boundary condition to Electric potential, and in the $V_0$ edit field type $V_{in}$.
6. Click OK.

Mesh Generation

You will use several interactive meshing tools to create the mesh.

1. From the Mesh menu select Mapped Mesh Parameters.
2. Change Predefined mesh sizes to Extra fine.
3 Select boundaries 1, 2, 4, and 5, and click Mesh Selected.

4 Change Predefined mesh sizes back to Normal; then click OK.

5 From the Mesh menu select Swept Mesh Parameters.

6 Select subdomains 1 and 2, and click Mesh Selected; then click OK.

7 Keep the two subdomains selected and click the Convert Selected button in the Meshing toolbar.

8 Finally, click the Mesh Remaining (Free) button in the Meshing toolbar.

The mesh consists of roughly 2060 elements.

COMPUTING THE SOLUTION
1 From the Solver menu, open the Solver Parameters dialog box.
2 Go to the Solver list and select Parametric segregated.
3 In the Parameter name edit field, type \( V_\text{in} \).
4 In the Parameter values edit field type 1:6 6.05 6.1. Because the cantilever deforms less at lower voltages, start with a long step and then, when the solution gets closer to the pull-in value, use a shorter step.
5 Click OK.

6 Click the Solve button on the Main toolbar.

POSTPROCESSING AND VISUALIZATION
The default plot shows a slice plot of the von Mises stress. To see the deformed structure and the electrostatic fields inside the air, follow these instructions:

1 From the Options menu, select Suppress>Suppress Boundaries. Select Boundaries 10, 14, and 17. Click OK.

2 Click the Camera Parameters button on the Camera toolbar. Change the Camera constraint to \( Z \) and the Mouse constraint to Horizontal, then click OK. Using the mouse, rotate the graphics 180 degrees so that the tip of the cantilever points toward you.

3 From the Postprocessing menu, open the Plot Parameters dialog box. In the Plot type area on the General page, clear the Slice and Geometry check boxes and select the Boundary, Edge, and Arrow check boxes.

4 Click the Boundary tab. From the Predefined quantities list on the Boundary Data page, select Electrostatics (emes)>Electric potential.
5 Click the **Edge** tab. In the **Edge color** area, click first the **Uniform color** option and then the **Color** button. From the palette on the **Edge Color** dialog box, select white. Click **OK**.

6 Click the **Arrow** tab and go to the **Subdomain Data** page.

7 From the **Predefined quantities** list, select **Electrostatics (emes)>Electric field**. In the **Arrow positioning** area go to the **Number of points** edit fields and enter 5 for **Z points**.

8 Change the **Arrow type** to **3D arrow** and the **Arrow length** to **Normalized**. Clear the **Auto** check box for the **Scale factor** and enter a value of 0.5.

9 Click **OK**.

10 On the Camera toolbar, click the **Scene Light** and **Headlight** buttons to turn them on.

To visualize the shape of the deformed cantilever, generate a domain plot:

1 From the **Postprocessing** menu, select **Domain Plot Parameters** and then click the **Line/Extrusion** tab.

2 From the **Edge selection** list, select 6.

3 From the **Predefined quantities** list in the **y-axis data** area, select **Solid, Stress-Strain (smlsd)>Z-displacement**.

4 From the **Unit** list, select **um** to see the results in micrometers.

5 In the **x-axis data** area, select **X** from the drop-down list.

6 Click **OK**.
Comb Drive

Introduction

Rectangular comb drives find use in a variety of MEMS applications. The following model of an electrostatically actuated comb drive opens and closes a pair of microtweezers. To facilitate controlled partial engagement, this design gives the comb fingers jagged edges. This model comes from Isabelle P. F. Harouche and Dr. Cyrus Shafai of the Department of Electrical and Computer Engineering, University of Manitoba, Canada (Ref. 1).

Model Definition

Figure 2-10 shows the microtweezers (top) and a close-up of part of the comb drive (bottom). Applying a voltage across the gaps between the combs actuates the tweezers. The structure is made of polysilicon and has a thickness of a few micrometers.

Figure 2-10: The microtweezers (top) and the comb-drive mechanism (bottom).
The model includes just a few of the teeth. It simulates only the comb drive and its attachment using double-folded beam springs. Taking advantage of symmetries means that you only have to set up a quarter of the geometry, see Figure 2-11.

![Initial (undeformed) model geometry.](image)

The upper half of the comb is fixed, as is the end of the beam spring. The system applies an electric potential to the beam spring and the lower comb; the upper comb is grounded. In the air surrounding the comb drive, the model solves the electrostatic equation

\[ \nabla \cdot (\varepsilon \nabla V) = 0. \]

The electrostatic force density is

\[ F_{es} = \frac{\varepsilon E^2}{2}, \]

and the simulation applies it to each comb as a perpendicular boundary load.

**Modeling in COMSOL Multiphysics**

Because electrostatic forces attract the combs to each other, any geometric change has an impact on the electric field between them. To account for this effect, the model uses an arbitrary Lagrangian-Eulerian (ALE) method implemented in COMSOL Multiphysics' Moving Mesh application mode. This application mode automatically keeps track of the movements and translates application mode equations between the fixed (reference) and moving frames.
In this model the displacements are relatively large. Therefore, you use the Plane Stress application mode’s support for large deformations.

To define the electrostatic force, you use the Electrostatics application mode’s Maxwell surface stress tensor boundary variables.

The geometry of this model is rather complex and thus the boundary conditions are laborious to enter. For an example that is faster and easier to set up, see the Cantilever beam model, which is a good introduction to using the Moving Mesh application mode.

**Results and Discussion**

The following two figures show the comb drive and the electric field at equilibrium for an actuation voltage of 600 V.

![Figure 2-12: The electric-potential field for an actuation voltage of 600 V.](image)
The next figure plots the displacement at the tip of one of the fingers of the lower comb as a function of the actuation voltage. The teeth have some effect on the displacements, but in order to make step-by-step actuation possible (like a switch gear), they would need to be wider, almost touching each other.

To reduce actuation voltages it is common to construct comb drives with many more teeth than in this model. Preferably, you would model such comb drives using a periodic approximation, thereby allowing the simulation of only one pair of fingers. The model could handle plane stress analysis in a separate geometry using the parametric solver to find the displacement of the comb base as a function of the applied force. Then a boundary integration variable could integrate the force density and dictate the displacements.

Another extension of the model would include fringing-field effects. A full 3D model might not be realistic, but you could estimate the size of the fringing fields by modeling two fingers in both 2D and 3D. You could then include the result of this
simulation in the full 2D model as, for instance, an approximate correction factor applied directly to the actuation voltage.

Figure 2-14: The displacement of the innermost comb finger as a function of the actuation voltage. For mid-range voltages the teeth suppress the displacement so that it is almost linear with voltage. Without teeth in the comb you could expect that the displacement would resemble a quadratic function of the voltage.

Reference


Model Library path: MEMS_Module/Actuator_Models/comb_drive_2d

Modeling Using the Graphical User Interface

MODEL NAVIGATOR

In the Model Navigator, select 2D in the Space dimension list.
2 Click Multiphysics.

3 From the Application Modes list select MEMS Module>Structural Mechanics>Plane Stress>Static analysis.

4 Click Add.

5 Click the Application Mode Properties button. From the Large deformation list, select On, then click OK.

6 From the Application Modes list, select COMSOL Multiphysics>Deformed mesh>Moving Mesh (ALE). Click Add.

7 Click the Application Mode Properties button and select Winslow in the Smoothing method list. Winslow smoothing works better for this model.

8 Click OK to close the Application Mode Properties dialog box.

9 In the Multiphysics list on the right side of the Model Navigator, select Frame (ale).

10 From the Application Modes list, select MEMS Module>Electrostatics>Electrostatics.

11 Click Add.

12 Click OK to close the Model Navigator.

GEOMETRY MODELING

Please follow these geometry-modeling steps carefully; the following discussion assumes that the boundary numbering is that resulting from these steps. After you complete the geometry it should have a total of 337 boundaries.

Notice also that you first enter the geometric objects as if they would be measured in micrometers (in other words, without the $e^{-6}$ after all numbers) and then, scale the entire geometry by $10^{-6}$ to have it in SI units. This approach reduces the amount of typing and avoids the likely error of forgetting to include $e^{-6}$ on one of the dimensions.

1 From the Draw menu, select Specify Objects>Rectangle to create rectangles (alternatively, press and hold the Shift key and click on the Rectangle/Square button on the Draw toolbar on the far left of the user interface). In the dialog box that opens, create four rectangles with these properties:

<table>
<thead>
<tr>
<th>NAME</th>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>X</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>7</td>
<td>5</td>
<td>-3.5</td>
<td>81</td>
</tr>
<tr>
<td>R2</td>
<td>3</td>
<td>5</td>
<td>-1.5</td>
<td>86</td>
</tr>
<tr>
<td>R3</td>
<td>7</td>
<td>5</td>
<td>6.5</td>
<td>106</td>
</tr>
<tr>
<td>R4</td>
<td>3</td>
<td>5</td>
<td>8.5</td>
<td>101</td>
</tr>
</tbody>
</table>
2 Select all the rectangles (use Ctrl+A) and click the **Array** button on the Draw toolbar.

3 Enter the data from this table:

<table>
<thead>
<tr>
<th>DATA</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>X displacement</td>
<td>20</td>
</tr>
<tr>
<td>Y displacement</td>
<td>10</td>
</tr>
<tr>
<td>X size</td>
<td>5</td>
</tr>
<tr>
<td>Y size</td>
<td>4</td>
</tr>
</tbody>
</table>

4 Click **OK**.

5 Select all the rectangles and click the **Union** button on the Draw toolbar.

6 Create another rectangle with these properties:

<table>
<thead>
<tr>
<th>NAME</th>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>X</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>91.5</td>
<td>60</td>
<td>0</td>
<td>81</td>
</tr>
</tbody>
</table>

7 Select both objects and click the **Intersection** button on the Draw toolbar.

8 Create seven new rectangles with these properties:

<table>
<thead>
<tr>
<th>NAME</th>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>X</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>91.5</td>
<td>60</td>
<td>0</td>
<td>141</td>
</tr>
<tr>
<td>R2</td>
<td>86.5</td>
<td>12</td>
<td>0</td>
<td>69</td>
</tr>
<tr>
<td>R3</td>
<td>45</td>
<td>17</td>
<td>0</td>
<td>52</td>
</tr>
<tr>
<td>R4</td>
<td>150</td>
<td>2</td>
<td>45</td>
<td>54</td>
</tr>
<tr>
<td>R5</td>
<td>150</td>
<td>2</td>
<td>45</td>
<td>34</td>
</tr>
<tr>
<td>R6</td>
<td>25</td>
<td>15</td>
<td>20</td>
<td>25</td>
</tr>
<tr>
<td>R7</td>
<td>15</td>
<td>40</td>
<td>195</td>
<td>25</td>
</tr>
</tbody>
</table>

9 From the **Draw** menu select **Create Composite Object**.

10 In the dialog box that opens click **Select All**, then clear the **Keep interior boundaries** check box.

11 Click **OK**.

12 Create yet another rectangle:

<table>
<thead>
<tr>
<th>NAME</th>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>X</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>235</td>
<td>178</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>
Select all the objects and click the **Scale** button. Enter $1 \times 10^{-6}$ for both the X and Y scale factors.

Click **OK**.

Click the **Zoom Extents** button.

The completed comb-drive geometry.

**Physics Settings**

*Subdomain Settings—Electrostatics*

1. From the **Multiphysics** menu, choose **Electrostatics (emes)**.
2. Open the **Subdomain Settings** dialog box, choose Subdomain 1, and verify that the relative permittivity, $\varepsilon_r = 1$.
3. Select Subdomains 2 and 3.
4. For the relative permittivity, $\varepsilon_r$, enter the value 4.5 (polysilicon).
5. Click the **Force** tab. On the first row enter $F_{es}$. COMSOL Multiphysics then automatically generates the variables $F_{es\_nTx\_emes}$ and $F_{es\_nTy\_emes}$ for the electrostatic force components. Later on you will use these variables to define the boundary load in the Plane Stress application mode.
6. Click **OK**.

*Boundary Conditions—Electrostatics*

1. From the **Physics** menu, select **Boundary Settings**.
2. In the dialog box that opens, make sure that the **Interior boundaries** check box is selected.
Enter the settings in the following table. Note that the physical boundaries of the upper comb are all grounded, while those of the lower comb have an electric potential of $V_{in}$. The arms and the contact pads of the lower comb are electrically inactive. When you have entered all boundary conditions click the Groups tab and enter the group names. This helps you identify the boundaries if you want to make changes to the model.

<table>
<thead>
<tr>
<th>Boundary condition</th>
<th>Zero charge/symmetry</th>
<th>Continuity</th>
<th>Electric potential</th>
<th>Ground</th>
</tr>
</thead>
<tbody>
<tr>
<td>$V_0$</td>
<td></td>
<td></td>
<td>$V_{in}$</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Group name</th>
<th>Zero charge/symmetry</th>
<th>Continuity</th>
<th>$V_{in}$</th>
<th>Ground</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

4 Click **OK**.

*Boundary conditions for the Electrostatics application mode. Grounded boundaries: cyan; electric potential ($V_{in}$): green; Zero charge/Symmetry boundaries: black; Continuity boundaries: blue.*
Subdomain Settings—Moving Mesh

1. From the Multiphysics menu, select Moving Mesh (ALE) (ale).
2. From the Physics menu, open the Subdomain Settings dialog box.
3. Select Subdomain 1 (air) and make sure that the Free displacement option is selected.
4. Select Subdomains 2 and 3 (comb drives).
5. Select the Physics included displacement check box. For the displacement variables $dx$ and $dy$, enter the values $u$ and $v$, respectively. These variables represent the displacements calculated in the Plane Stress application mode.
6. Click OK.

Boundary Conditions—Moving Mesh

1. From the Physics menu, select Boundary Settings. In the dialog box that opens, make sure that the Interior boundaries check box is not selected.
2. Enter the settings in the following table:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 1, 14, 18</th>
<th>BOUNDARIES 2, 20, 337</th>
<th>BOUNDARIES 4, 15, 17, 19, 21–336</th>
</tr>
</thead>
<tbody>
<tr>
<td>$dx$</td>
<td>0</td>
<td>0</td>
<td>$u$</td>
</tr>
<tr>
<td>$dy$</td>
<td>0</td>
<td>0</td>
<td>$v$</td>
</tr>
<tr>
<td>Group name</td>
<td>Symmetry</td>
<td>Fixed</td>
<td>Comb drive</td>
</tr>
</tbody>
</table>
Boundary settings for Moving Mesh (ALE) application mode. Inactive boundaries: black; symmetry boundaries: blue; moving comb drive: cyan; the fixed outer boundaries: green.

Subdomain Settings—Plane Stress

1 From the Multiphysics menu, choose Plane Stress (smps).
2 Open the Subdomain Settings dialog box.
3 Choose Subdomains 2 and 3, then enter these settings:

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>E</td>
<td>158e9</td>
</tr>
<tr>
<td>ν</td>
<td>0.22</td>
</tr>
<tr>
<td>thickness</td>
<td>2e-6</td>
</tr>
</tbody>
</table>

The thermal expansion coefficient (α) is needed only if you have included thermal expansion in the load settings. Similarly, the density (ρ) is used only in time-dependent, eigenfrequency, and frequency-response analyses. In this case you use a nonlinear parametric analysis, and it is therefore not necessary to enter these values.
4 While still in the dialog box, select Subdomain 1. To make sure that the application mode is inactive outside the comb drive, clear the **Active in this domain** check box.

5 Click **OK**.

**Boundary Conditions—Plane Stress**

1 Open the **Boundary Settings** dialog box and make sure that the **Interior boundaries** check box is not selected.

2 On the **Constraint** and **Load** pages, define boundary conditions according to the following table. On the **Load** page, click the **Edge load is defined as load/area using the thickness** option button. This makes the loads from the Electrostatics application mode match the structural loads.

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Constraint condition</td>
<td>Symmetry</td>
<td>Fixed</td>
<td>Free</td>
<td></td>
</tr>
<tr>
<td>Edge load X dir.</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>Fes_nTx_emes</td>
</tr>
<tr>
<td>Edge load Y dir.</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>Fes_nTy_emes</td>
</tr>
<tr>
<td>Group name</td>
<td>Symmetry</td>
<td>Fixed</td>
<td>Free</td>
<td>Es force</td>
</tr>
</tbody>
</table>
3 Click OK.

Boundary settings for the Plane Stress application mode. Electrostatically actuated boundaries: cyan; symmetry boundaries: blue; fixed boundaries: green; free boundaries (and inactive boundaries): black.

**MESH GENERATION**

1 From the Mesh menu, choose Free Mesh Parameters.

2 On the General page, select Finer from the Predefined mesh sizes list.

3 Click the Remesh button and then click OK.
The mesh generated using the predefined settings for a fine mesh.

**COMPUTING THE SOLUTION**

1. From the **Solve** menu, choose **Solver Parameters**.
2. On the General page, select **Parametric** from the **Analysis** list.
3. In the **Parameter name** edit field type `V_in`, and in the **Parameter values** edit field type `0:50:600`.
4. Click the **Advanced** tab.
5. In the **Scaling of variables** area, select **Manual** from the **Type of scaling** list.
6. Type `V 100 u 1e-4 v 1e-4 x 1e-4 y 1e-4` in the **Manual scaling** edit field.

   This scales the variables using the magnitudes of the dependent variables (about 100 for the potential `V` and about $10^{-4}$ for the displacement (`u`, `v`, and `w`). The Lagrange multipliers have a magnitude of roughly 1 and do not need any scaling.

7. Click **OK**.
8. Click the **Solve** button on the Main toolbar.
The default results show von Mises stresses with colors on the deformed shape for the last parametric value, $V_m(12) = 600$ V. To study the electric potential in the moving frame do the following:

1. From the **Postprocessing** menu, select **Plot Parameters** to open the like-named dialog box.
2. On the **General** page, verify that only **Surface** plot type is selected and that the selection in the **Frame** list is **Frame (ale)**.
3. On the **Surface** page, select **Electrostatics (emes)>Electric potential** from the **Predefined quantities** list.
4. Click **Apply** to generate the plot displayed in Figure 2-12 on page 36.

To see the deformation inside the comb drive do as follows:

5. On the **Surface** page, select **Plane Stress (smps)>Total displacement** from the **Predefined quantities** list.
6. Click **Apply** to generate the plot in Figure 2-13.

It is also possible to visualize the deformed mesh in the air domain:

7. On the **General** page clear the **Auto Element refinement** check box, then type 1 in the associated edit field.
8. Click the **Surface** tab.
9. From the **Predefined quantities** list, select **Moving Mesh (ALE) (ale)>y-displacement (ale)**.
10. From the **Fill style** list, select **Wireframe**.
11. Click **OK**.

The resulting plot is reproduced in Figure 2-15.
Next, plot the displacement of the central tooth as a function of the applied voltage:

12. From the Postprocessing menu, choose Domain Plot Parameters.

13. On the General page, click the Title/Axis button. Select the option button next to the First axis label edit field, then enter the label Actuation voltage [V]. Click OK.

14. Click the Point tab. Select Point 12. From the Predefined quantities list, select Plane Stress (smns)>Y-displacement. From the Unit list, select um (for micrometers).

15. Click OK. The plot given in Figure 2-14 on page 38 appears in a new window.

Finally, to reproduce the plot that appears in the Model Navigator when you open the preconfigured model, do the following:

16. Go to the Postprocessing menu and select Plot Parameters.

17. On the General page select the Element refinement Auto check box.

18. Make sure that only the Surface check box is selected in the Plot type area.

19. On the Surface page, select Electrostatics (emes)>Electric potential from the Predefined quantities list.

20. From the Fill style list, select Filled, then click OK.

21. Click the Zoom Extents button on the Main toolbar.
Capacitive 3D Comb Drive

This model illustrates how to approach a 3D electrostatics problem, create a geometry using the array and extrusion tools, and compute capacitances using the Electrostatics application mode’s port boundary condition.

Introduction

Capacitive comb drives are commonly used both as actuators and position sensors. For actuators, electrostatic forces typically pull on a MEMS flexure to provide highly accurate position control. The following model focuses on the other common usage of comb drives: position measurement. Many approaches exist for positional measurements with MEMS devices including changes in capacitance or inductance, optical schemes, and others. Of these, capacitance measurement is the most widely used, particularly in microaccelerometers.

A pair of interdigitated combs for capacitance-based position measurement. Note that the fingers of one comb do not touch those of the other.

Comb drives and capacitive sensors based on them consist of a series of interdigitated tines or fingers. In a pair of interdigitated combs (see the previous figure) the fingers of one comb do not touch those of the other comb, but they do slide in and out relative to each other with a variable overlap. The fingers in MEMS combs are typically a few microns wide and 40 to 100 microns long. The gap between the interdigitated tines is normally 0.5 to 2 microns.
You typically can get a rough idea of a drive’s capacitance by approximating the 3D structure as multiple parallel-plate capacitors. This sizing approach is reasonable if the structures are tall compared to the gap and if fringing of the electrostatic field is negligible—which is not the case in most plated MEMS structures. In many cases the tine height is on the same order as its width as well as the gap between the tines; in fact, it can sometimes even be smaller. In these configurations electrostatic fringing dominates the field, and the parallel-plate approximation can be quite inaccurate, even for sizing. Here a quick 3D analysis of the electrostatic field gives a capacitance value that you can combine with the parallel-plate theory to provide considerable design information. Additionally, you can use the capacitance in reduced-order electrical circuit models to simulate the electrical system as a whole.

**Theoretical Background**

The energy required to charge a capacitor should equal that of the electrostatic field, which is

\[ W_e = \frac{Q^2}{2C}. \]

\( W_e \) is readily available in the Electrostatics application mode; the software calculates it by integrating across the domain

\[ W_e = \int (D \cdot E)d\Omega \]

where \( D \) is the electric displacement, and \( E \) is the electric field. The capacitance, \( C \), is related to the charge on the two conductive plates, \( Q \), and the voltage difference across those plates, \( \Delta V \), by

\[ C = \frac{Q}{\Delta V}. \]

Now calculate \( C \) from the stored electric energy in the capacitor, \( W_e \), and the voltage across the capacitor:

\[ C = \frac{Q^2}{2W_e} = \frac{C^2 \Delta V^2}{2W_e} \Rightarrow C = \frac{2W_e}{\Delta V^2}. \quad (2-4) \]
Results and Discussion

The next figure shows the electric potential on the comb drive’s surfaces, the silicon substrate, and the bounding box. Calculating capacitance using the energy-storage distribution in the electric field and integrating over the volumetric domain leads to a value of 0.021 pF. Changing the geometry—for example, by shifting the fingers on the right side closer to those on the left—likewise changes the value of the stored energy and thus the capacitance.

Figure 2-16: Electric potential on the surfaces of a comb drive.

Modeling in COMSOL Multiphysics

Static comb drives are relatively easy to set up in COMSOL Multiphysics. They typically consist of a series of interdigitated rectangles of the same size. Thus you can create one rectangle and reproduce it in a regular pattern to create the fingers of a comb. Then simply copy, paste, and move the entire geometry to create a second comb. Finally recall that electrostatic fields have only one degree of freedom per node: the voltage. Therefore these types of models do not tend to lead to huge system matrices and memory requirements. True, you can make problems quite large, but you can generally expect quick solutions to reasonably complex 3D electrostatics problems.
To solve electrostatics problems in the MEMS Module, use the Electrostatics application mode, which solves for the electric potential.

**Model Library path:** MEMS_Module/Actuator_Models/comb_drive_3d

---

**Modeling Using the Graphical User Interface**

**MODEL NAVIGATOR**
1. Open the Model Navigator to the New tab and select 3D in the Space dimension list.
2. Select Application modes>MEMS Module>Electrostatics>Electrostatics.
3. Click OK.

**GEOMETRY MODELING**

**Work-Plane Settings**
1. From the Draw menu choose Work-Plane Settings.
2. Click the Quick tab, and on that page click the x-y button.
3. For the z-value use 0 (the default) and click OK.

**Drawing the 2D Work Geometry**
1. Shift-click the Rectangle/Square icon on the Draw toolbar and create a rectangle:

<table>
<thead>
<tr>
<th>NAME</th>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>BASE</th>
<th>X</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>40e-6</td>
<td>2e-6</td>
<td>Corner</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

2. Click the Zoom Extents button on the Main toolbar.
3. From the Draw select first Modify and then Array.
4. In the Array dialog box enter these values:

<table>
<thead>
<tr>
<th>DISPLACEMENT</th>
<th>ARRAY SIZE</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>Y</td>
</tr>
<tr>
<td>X</td>
<td>Y</td>
</tr>
<tr>
<td>0</td>
<td>8e-6</td>
</tr>
<tr>
<td>1</td>
<td>5</td>
</tr>
</tbody>
</table>

5. Click OK.
6. Click the Zoom Extents button on the Main toolbar.
7. Press Ctrl+A to select all the geometry objects.
8 Press Ctrl+C and then Ctrl+V to copy and paste the selected objects.

9 In the Paste dialog box that appears, enter these values:

<table>
<thead>
<tr>
<th>DISPLACEMENT</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>Y</td>
</tr>
<tr>
<td>14e-6</td>
<td>4e-6</td>
</tr>
</tbody>
</table>

10 Click OK.

11 Click the Zoom Extents button on the Main toolbar.

Creating the comb-drive geometry using a 2D work plane.

12 Select rectangle R10 and delete it.

13 Add two more rectangles:

<table>
<thead>
<tr>
<th>NAME</th>
<th>SIZE</th>
<th>POSITION</th>
<th>BASE</th>
<th>X</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>R10</td>
<td>10e-6</td>
<td>26e-6</td>
<td>Corner</td>
<td>54e-6</td>
<td>4e-6</td>
</tr>
<tr>
<td>R11</td>
<td>10e-6</td>
<td>34e-6</td>
<td>Corner</td>
<td>-10e-6</td>
<td>0</td>
</tr>
</tbody>
</table>

14 Select the rectangles forming the left comb (R1, R2, R3, R4, R5, and R11).

15 To create a composite object, click the Union button on the Draw toolbar.

16 Click the Delete Interior Boundaries button near the bottom of the Draw toolbar.

17 Select the rectangles that form the right comb (R6, R7, R8, R9, and R10).

18 Click the Union button.
19 Click the **Delete Interior Boundaries** button.

Two composite objects, one for each side of the comb.

Next draw the outline of the substrate and bounding air space for the analysis. In this case, extend the space 10 microns on either side of the comb teeth.

20 Create another rectangle:

<table>
<thead>
<tr>
<th>NAME</th>
<th>SIZE</th>
<th>HEIGHT</th>
<th>POSITION</th>
<th>X</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>74e-6</td>
<td>54e-6</td>
<td>Corner</td>
<td>-10e-6</td>
<td>-10e-6</td>
</tr>
</tbody>
</table>

21 Click **Zoom Extents**.

The comb with the substrate and bounding air space.
Extruding the Geometry

First extrude the two comb drives into a 3D geometry:

1. From the **Draw** menu, choose **Extrude**.
2. From the **Objects to extrude** list, select **CO2** and **CO3**.
3. In the **Distance** edit field, type **2e-6**.
4. Click **OK**.
5. Click then **Zoom Extents** button on the Main toolbar.

![Extruded comb drive alone.](image)

Now continue extruding, this time with the air surrounding the combs.

6. Switch back to the 2D window; to do so, go to the top of the work area and select the tab for **Geom2**.
7. From the **Draw** menu, choose **Extrude**.
8. In the **Objects to extrude** list, select **R1**.
9. In the **Distance** edit field, type **12e-6**.
10. Click **OK**.

Because it is not necessary to model the electrostatic field inside the combs, subtract the comb geometries from the air; later you model the electrostatic field only in the air and substrate.

11. On the Draw toolbar, click the **Create Composite Object** button.
12. In the **Set formula** edit field, type **EXT3-EXT1-EXT2**.
13. Clear the **Keep interior boundaries** check box.
14 Click OK.

To complete the 3D geometry, extrude the silicon substrate under the two combs.

15 Click the Geom2 tab to switch back to the 2D geometry.

16 From the Draw menu, choose Extrude.

17 From the Objects to extrude list, select R1.

18 In the Distance edit field, type -10e-6.

19 Click OK.

Extruding the geometry to create the silicon substrate below the combs.

PHYSICS SETTINGS

Subdomain Settings
The model consists of two subdomains: the first is the silicon substrate under the comb drives; the second is the surrounding air. Set a value of 11.9 for the substrate’s relative permittivity and use the default value of 1.0 for the air.

1 From the Physics menu, choose Subdomain Settings.
2 Enter the following values for the subdomains; when finished, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN 1</th>
<th>SUBDOMAIN 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\varepsilon_r$</td>
<td>11.9</td>
<td>1.0</td>
</tr>
<tr>
<td>$\rho$</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>
**Boundary Conditions**

Continue the physics settings by specifying the boundary conditions. The first comb is tied to the ground, and the second is defined as a port. You model the surrounding boundaries with the symmetry condition.

1. From the **Physics** menu, choose **Boundary Settings**.

2. On the **Conditions** page specify the following settings:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 1–5, 7, 12, 13, 52, 53</th>
<th>BOUNDARIES 8–11, 16–27, 42–46</th>
<th>BOUNDARIES 28–41, 47–51</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Zero charge/Symmetry</td>
<td>Ground</td>
<td>Port</td>
</tr>
</tbody>
</table>

3. While still in the **Boundary Settings** dialog box select one of the port boundaries and select the **Select by group** check box. Doing so selects all port boundaries. Then click the **Port** tab.

4. On the **Port** page, verify that the port number is 1. Then select the **Use port as input** check box, and from the **Input property** list select **Energy method**. Using these settings ensure that a unit voltage is forced on the boundaries of the second comb drive, and the capacitance value is integrated from electric energy density.

---

**MESH GENERATION**

Click the **Initialize Mesh** button on the Main toolbar. The resulting mesh consists of roughly 7800 elements.

**COMPUTING THE SOLUTION**

Click the **Solve** button on the Main toolbar. The model contains about 12,400 degrees of freedom and COMSOL Multiphysics solves it in just a few seconds.
POSTPROCESSING AND VISUALIZATION

To see the voltage distribution on the surface of the comb drive (Figure 2·16), suppress some of the outer boundaries. The suppression visualization settings are available from the Options menu.

1. From the Postprocessing menu, select Plot Parameters.
2. In the dialog box that opens, click the General tab.
3. Clear the Slice check box and select the Boundary check box.
4. Click OK.
5. From the Options menu, choose Suppress>Suppress Boundaries.
6. Select Boundaries 1, 2, 4, 5, and 7.
7. Click OK.
8. On the Main toolbar, click the Postprocessing Mode button to return to the postprocessing plot.

Computing the Capacitance

As a final step, display the capacitance value computed by integrating the electric energy density over the geometry.

1. From the Postprocessing menu, choose Data Display>Global.
2. In the Expression edit field, type $C_{11_{\text{emes}}}$.
3. Click OK.

The value of the integral, $2.1 \cdot 10^{-14}$—corresponding to 0.021 pF—appears in the message log at the bottom of the screen.
Gecko Foot

Introduction

In nature, various species apply advanced techniques for specialized tasks. For instance, gecko lizards use dry adhesion forces such as Van der Waals forces to climb walls. Dry adhesion is an interesting phenomena for sticking because it requires no energy to hold on, and no residue is left on the surface. Gecko lizards have inspired researchers to develop synthetic gecko foot hairs to be used in, for example, robot application for purposes where humans cannot go.

Model Definition

Hair on a gecko foot is a very complex biological structure with hierarchical nano and micro sections. On its feet, a gecko has billions of nanoscale hairs that are in contact with surfaces while it climbs. These nanohairs are attached to microscale hairs, which are on the tip of a gecko’s toes.

Critical design parameters for nanohairs to achieve the optimal sticking are hair length, detach angle, distance between nanohairs, and the cross section area of one hair. By varying these parameters, the hairs can stick onto very rough surfaces, but on the other hand they must be stiff enough to avoid sticking to each others. Proper material choices help achieving the design goals while providing the required adhesion force. Typically the Young’s modulus for materials used in synthetic nanohair vary in between 1 GPa and 15 GPa.

This model contains the hierarchy of synthetic gecko foot hair where cantilever beams both in nano and micro scales describe the seta and spatula parts of one spatular stalk attached to a gecko foot. The basis of the analyzed structure is the micro stalk with these dimensions: width, 4.53 µm; height, 4.33 µm; and length, 75 µm. At the end of the micro hair, 169 nanohairs are attached and they have dimensions of 0.18 µm, 0.17 µm, and 3 µm, respectively. The micro hair is fixed at the far end, while the contact and friction forces appear as surface loads at the end of each nanohair. The free-body diagram of one micro/nanohair (see nearby figure) illustrates the applied forces, which are set to 0.4 µN for the contact force and 0.2 µN for the friction force with 60° contact angle to target surface. The structure is made of β-keratin with a Young’s modulus of 2 GPa and a Poisson’s ratio of 0.4. The model was inspired by Ref. 1.
Results and Discussion

The following plot shows the von Mises effective stress in the model, stress that reaches a maximum at 97.73 MPa. The total displacement is 13.01 µm. This information helps in selecting the material and certain criteria for polymers to be used in synthetic gecko foot design as well as in setting design parameters for the geometrical dimensions.

The maximum von Mises stress in the analyzed model is almost twice the value of the material’s yield stress. Further analysis requires either a stronger material or some geometrical changes. An optimal solution likely depends on a combination of both these design parameters.
Figure 2-17: Von Mises stress in a synthetic Gecko foot with a length of the microbeam of 75 µm and nanohairs with a length of 3 µm. This plot shows only the end with the nanohairs.

References


Model Library path: MEMS_Module/Actuator_Models/gecko_foot
MODEL NAVIGATOR
1. Open the Model Navigator to create a new model.
2. Select 3D from the Space dimension list.
3. Select the MEMS Module>Structural Mechanics>Solid, Stress-Strain application mode.
4. Click OK.

OPTIONS AND SETTINGS
1. Choose Options>Constants to open the Constants dialog box.
2. Defined the following constants by typing the name, expression, and description into the table using a new row for each constant (the Description field is optional):

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fc</td>
<td>0.4[μN]</td>
<td>Contact force</td>
</tr>
<tr>
<td>Ff</td>
<td>0.2[μN]</td>
<td>Friction force</td>
</tr>
<tr>
<td>Fcy</td>
<td>Fc*sin(pi/3)</td>
<td>Contact force, y component</td>
</tr>
<tr>
<td>Fcz</td>
<td>Fc*cos(pi/3)</td>
<td>Contact force, z component</td>
</tr>
<tr>
<td>Ffy</td>
<td>Ff*cos(pi/3)</td>
<td>Friction force, y component</td>
</tr>
<tr>
<td>Ffz</td>
<td>Ff*sin(pi/3)</td>
<td>Friction force, z component</td>
</tr>
<tr>
<td>Area</td>
<td>0.17[μm]*0.18[μm]</td>
<td>Cross-sectional area of the spatulae</td>
</tr>
</tbody>
</table>

3. Click OK.

GEOMETRY MODELING
To be able to mesh the microscale and nanoscale sections independently, use the assembly feature, which keeps each geometry object as a separate part. First create the microscale part as a block. Then create one of the nanohairs and use the array feature to create an array of identical nanohairs.

1. From the Draw menu, choose Use Assembly.
2. Click the Block button on the Draw toolbar. Enter the following dimensions in the Length area: X: 4.53e-6, Y: 75e-6; Z: 4.33e-6.
   Use the default values for all other properties, then click OK to create the block.
3 Click the **Block** button on the Draw toolbar to create another block. Enter the following dimensions in the **Length** area: \(X: 0.18 \times 10^{-6}, Y: 3 \times 10^{-6}, Z: 0.17 \times 10^{-6}\). Enter the following base point in the **Axis base point** area: \(x: 0, y: 3 \times 10^{-6}, z: 0\).

Use the default values for all other properties, then click **OK** to create the block.

4 Make sure that the second block (BLK2) is selected.

5 Click the **Array** button on the Draw toolbar to make an array of blocks similar to BLK2. Together they form a group of \(13 \times 13\) nanohairs. Enter the following values in the **Displacement** area:

\[x: \frac{(4.53 \times 10^{-6} - 0.18 \times 10^{-6})}{12}, \ y: 0, \ z: \frac{(4.33 \times 10^{-6} - 0.17 \times 10^{-6})}{12}\]

Enter the following values in the **Array size** area:

\[x: 13, \ y: 1, \ z: 13\]

6 Click **OK**.

7 Press Ctrl+A to select all the objects.

8 Choose **Mate Objects** from the Draw menu. In the **Mate Objects** dialog box, clear the **Create imprints** check box, then click **OK**.

This final step creates the identity pairs that connect the parts to form a continuous field problem in the entire assembly. There are a total of 169 pairs, one for each nanohair. There is no need to create imprints of the nanohairs because the displacement field is continuous across the entire assembly, and there are no loads or constraints where the nanohairs meet the microsection.

**PHYSICS SETTINGS**

**Subdomain Settings**

1 From the **Physics** menu choose **Subdomain Settings**.

2 Select all the subdomains and then enter the following material properties on the **Material** page: \(E: 2 \times 10^9\) (Young’s modulus), \(\nu: 0.4\) (Poisson’s ratio).

3 Click **OK**.

**Boundary Conditions**

Specify the loads and constraints.

1 From the **Physics** menu, choose **Boundary Settings**.

2 Select Boundary 83.

3 Select **Fixed** from the **Constraint condition** list.

4 Use the zoom tools and rotate the geometry so that you can reach the ends of all nanohairs. Then disable the zoom and rotate operations by clicking the **Orbit/Pan/Zoom** button on the Camera toolbar so that you can use the mouse to select boundaries.
Using the mouse, select the ends of all the nanohairs. The following table contains the numbers for all these boundaries:

<table>
<thead>
<tr>
<th>2</th>
<th>8</th>
<th>14</th>
<th>20</th>
<th>26</th>
<th>32</th>
<th>38</th>
<th>44</th>
<th>50</th>
<th>56</th>
<th>62</th>
<th>68</th>
<th>74</th>
</tr>
</thead>
<tbody>
<tr>
<td>86</td>
<td>92</td>
<td>98</td>
<td>104</td>
<td>110</td>
<td>116</td>
<td>122</td>
<td>128</td>
<td>134</td>
<td>140</td>
<td>146</td>
<td>152</td>
<td>158</td>
</tr>
<tr>
<td>164</td>
<td>170</td>
<td>176</td>
<td>182</td>
<td>188</td>
<td>194</td>
<td>200</td>
<td>206</td>
<td>212</td>
<td>218</td>
<td>224</td>
<td>230</td>
<td>236</td>
</tr>
<tr>
<td>242</td>
<td>248</td>
<td>254</td>
<td>260</td>
<td>266</td>
<td>272</td>
<td>278</td>
<td>284</td>
<td>290</td>
<td>296</td>
<td>302</td>
<td>308</td>
<td>314</td>
</tr>
<tr>
<td>320</td>
<td>326</td>
<td>332</td>
<td>338</td>
<td>344</td>
<td>350</td>
<td>356</td>
<td>362</td>
<td>368</td>
<td>374</td>
<td>380</td>
<td>386</td>
<td>392</td>
</tr>
<tr>
<td>398</td>
<td>404</td>
<td>410</td>
<td>416</td>
<td>422</td>
<td>428</td>
<td>434</td>
<td>440</td>
<td>446</td>
<td>452</td>
<td>458</td>
<td>464</td>
<td>470</td>
</tr>
<tr>
<td>476</td>
<td>482</td>
<td>488</td>
<td>494</td>
<td>500</td>
<td>506</td>
<td>512</td>
<td>518</td>
<td>524</td>
<td>530</td>
<td>536</td>
<td>542</td>
<td>548</td>
</tr>
<tr>
<td>554</td>
<td>560</td>
<td>566</td>
<td>572</td>
<td>578</td>
<td>584</td>
<td>590</td>
<td>596</td>
<td>602</td>
<td>608</td>
<td>614</td>
<td>620</td>
<td>626</td>
</tr>
<tr>
<td>632</td>
<td>638</td>
<td>644</td>
<td>650</td>
<td>656</td>
<td>662</td>
<td>668</td>
<td>674</td>
<td>680</td>
<td>686</td>
<td>692</td>
<td>698</td>
<td>704</td>
</tr>
<tr>
<td>710</td>
<td>716</td>
<td>722</td>
<td>728</td>
<td>734</td>
<td>740</td>
<td>746</td>
<td>752</td>
<td>758</td>
<td>764</td>
<td>770</td>
<td>776</td>
<td>782</td>
</tr>
<tr>
<td>788</td>
<td>794</td>
<td>800</td>
<td>806</td>
<td>812</td>
<td>818</td>
<td>824</td>
<td>830</td>
<td>836</td>
<td>842</td>
<td>848</td>
<td>854</td>
<td>860</td>
</tr>
<tr>
<td>866</td>
<td>872</td>
<td>878</td>
<td>884</td>
<td>890</td>
<td>896</td>
<td>902</td>
<td>908</td>
<td>914</td>
<td>920</td>
<td>926</td>
<td>932</td>
<td>938</td>
</tr>
<tr>
<td>944</td>
<td>950</td>
<td>956</td>
<td>962</td>
<td>968</td>
<td>974</td>
<td>980</td>
<td>986</td>
<td>992</td>
<td>998</td>
<td>1004</td>
<td>1010</td>
<td>1016</td>
</tr>
</tbody>
</table>

6 Click the **Load** tab.

7 Enter the following loads: \( F_x: 0, F_y: \frac{(-F_{cy}+F_{fy})}{\text{Area}}, F_z: \frac{(F_{cz}-F_{fz})}{\text{Area}} \).

8 Click **OK**.

**Mesh Generation**

Create swept meshes for each subdomain, which is possible due to the assembly geometry where each block is an individual part.

1 Choose **Mesh>Interactive Meshing>Mesh Selected (Mapped)**. This creates a mapped 2D mesh on all nanohair ends.

2 Choose **Mesh>Swept Mesh Parameters**.

3 Select all subdomains except Subdomain 14 (the microsection).

4 On the **Element Layers** page select the Manual specification of element layers check box, then type 8 in the **Number of element layers** edit field.

5 Click the **Mesh Selected** button, then click **OK**.

This creates hexahedral mesh elements for all the nanohairs. Next create another swept hexahedral mesh for the microsection.

1 Choose **Mesh>Mapped Mesh Parameters**.
2 Select Boundary 83 (the back end of the microsection).

3 Click the Edge tab, then select Edges 162, 163, 164, and 168.

4 Select the Constrained edge element distribution check box and type 5 in the Number of edge elements edit field.

5 Click the Boundary tab, then click the Mesh Selected button. Click OK.

6 Choose Mesh>Swept Mesh Parameters.

7 Select Subdomain 14 (the microsection).

8 On the Element Layers page select the Manual specification of element layers check box, then type 10 in the Number of element layers edit field.

9 Click the Mesh Selected button, then click OK.

The total number of mesh elements should be approximately 1600.

Computing The Solution
Click the Solve button on the Main toolbar to start the analysis.

Postprocessing And Visualization
1 Choose Postprocessing>Plot Parameters.

2 On the General page clear the Slice check box. Select the Subdomain and Deformed shape check boxes in the Plot type area.

3 Click the Subdomain tab.

4 Select MPa from the Unit list to display the von Mises stress in MPa instead of Pa.

5 Click OK.
Prestressed Micromirror

Introduction

One method of creating spring-like structures or inducing curvature in plated structures is to plate materials onto a substrate such that the layer has a residual stress after the plating process. The plating process can control this stress, which can be either compressive or tensile, even for similar materials. The automotive industry has studied this phenomenon at length because highly stressed chrome is appreciably shinier than nonstressed chrome. MEMS device manufacturers sometimes use this effect to create curved cantilevers or spring-loaded micromechanical structures that lift off the substrate when deliberately undercut by an etchant.

One such device is the electrostatically controlled micromirror. It is typically quite small, and arrays of such devices can implement a projection system. They serve as optical redirectors and similar reflection devices. This section shows the fundamentals of how to set up and solve lift-off of a prestressed plated device.

Model Definition

This single-physics model uses 3D structural analysis. The micromirror has a stiff, flat, reflective center portion, which is supported by four prestressed plated cantilever springs. To keep the mesh size small and the solution time reasonable, this exercise studies the plated structure with two layers. It also assumes that the plating process creates equal and opposite (compressive and tensile) initial stresses in the top and bottom layers. This convenience makes the model straightforward to set up. You can make the initial-stress distribution as complex as desired and set it up as shown in this example. Depending on the magnitude of the deformations, you are likely best advised to solve such simulations with a large-deformation analysis using a nonlinear or parametric nonlinear solver, noting that the latter is more likely to converge. Thus this illustrative model uses the large-deformation analysis type with both the linear and parametric linear solvers.

Note in particular that a 3D structure with thin layers such as the one in this model leads to a very large unstructured tetrahedral mesh. To avoid this case, this example first generates a 2D quadrilateral mesh by mesh mapping and then extrudes it into 3D to produce a mesh with hexahedral (brick) elements. This way you can have the mesh generator create structured elements with a high aspect ratio.
One of the key process parameters you wish to determine in this class of problem is generally what prestress level is necessary to result in a desired lift-off. Another common concern is how much effect variations in the prestress might have on displacement. A parametric study answers this question.

Results and Discussion

The following two images compare lift-off for aluminum and steel plates. The steel, being harder than aluminum, deforms less.

![Figure 2-18: Lift-off for aluminum (top) and steel (bottom).](image)

The following two figures show the mirror response to the different levels of applied prestress. According to Figure 2-19, the center point deflection is almost linearly dependent of the prestress. Figure 2-20 shows the mirror’s curvature along its
centerline for different values of prestress. In line with expectations, increasing the stress bends the mirror more.

**Figure 2-19:** Vertical deflection of the center of the mirror for different prestress levels.

**Figure 2-20:** Mirror curvature along the centerline for different prestress levels.
Because of bonding the structure cannot move freely when it cools down, which causes residual stresses. The following plot shows this released stress state using the first principal stress after deformation.

![Plot of the first principal stress after deformation.](image)

**Figure 2-21:** Plot of the first principal stress after deformation.

**Reference**


---

**Model Library path:** MEMS_Module/Actuator_Models/micromirror

---

**Modeling Using the Graphical User Interface**

**MODEL NAVIGATOR**

1. In the Model Navigator click the New tab. From the Space dimension list, select 3D.
2. In the list of application modes select MEMS Module>Structural Mechanics>Solid, Stress-Strain>Static analysis.
3 Click OK.

OPTIONS AND SETTINGS

Constants
1 From the Options menu, choose Constants.
2 Enter a variable with the Name Stress, the Expression $8\text{[GPa]}$, and the description Initial normal stress.
3 Click OK.

Work Plane
1 From the Draw menu, select Work-Plane Settings.
2 Click the Quick tab.
3 Choose the x-y plane, and for z use a value of 0.
4 Click OK.

Axes and Grid Settings
1 From the Options menu, choose Axes/Grid Settings.
2 Click the Grid tab.
3 Clear the Auto check box.
4 In both the x spacing and y spacing edit fields type 0.1.
5 Click OK.

GEOMETRY MODELING
1 Shift-click the Rectangle/Square button on the Draw toolbar and create five rectangles:

<table>
<thead>
<tr>
<th>NAME</th>
<th>SIZE</th>
<th>POSITION</th>
<th>X</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Width</td>
<td>Height</td>
<td>Base</td>
<td></td>
</tr>
<tr>
<td>R1</td>
<td>1</td>
<td>1</td>
<td>Corner</td>
<td>0</td>
</tr>
<tr>
<td>R2</td>
<td>0.2</td>
<td>0.2</td>
<td>Corner</td>
<td>0</td>
</tr>
<tr>
<td>R3</td>
<td>0.2</td>
<td>0.2</td>
<td>Corner</td>
<td>1</td>
</tr>
<tr>
<td>R4</td>
<td>0.2</td>
<td>0.2</td>
<td>Corner</td>
<td>0.8</td>
</tr>
<tr>
<td>R5</td>
<td>0.2</td>
<td>0.2</td>
<td>Corner</td>
<td>-0.2</td>
</tr>
</tbody>
</table>
2 Click the **Zoom Extents** button.

![Initial geometry after drawing five rectangles.](image1)

*The initial geometry after drawing five rectangles.*

These steps create the mirror along with support structure for the cantilevers. This assembly is made of a metal stiffer than the prestressed cantilever springs. Next chamfer the corners.

3 From the **Draw** menu, select **Fillet/Chamfer**.

4 Click the **Chamfer** option button.

5 In the **Distance** edit field, type 0.1.

6 In the **Vertex selection** list, choose the four vertices R2>4, R3>3, R4>2, and R5>1.

7 Click **OK**.

![Mirror geometry after chamfering.](image2)

*The mirror geometry after chamfering.*
8 Use the **Rectangle/Square** tool and data from the following table to create the spring:

<table>
<thead>
<tr>
<th>NAME</th>
<th>SIZE</th>
<th>HEIGHT</th>
<th>POSITION</th>
<th>BASE</th>
<th>X</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>0.9</td>
<td>0.1</td>
<td>Corner</td>
<td>0.2</td>
<td>1.1</td>
<td></td>
</tr>
<tr>
<td>R2</td>
<td>0.1</td>
<td>0.9</td>
<td>Corner</td>
<td>1.1</td>
<td>-0.1</td>
<td></td>
</tr>
<tr>
<td>R3</td>
<td>0.9</td>
<td>0.1</td>
<td>Corner</td>
<td>-0.1</td>
<td>-0.1</td>
<td></td>
</tr>
<tr>
<td>R4</td>
<td>0.1</td>
<td>0.9</td>
<td>Corner</td>
<td>-0.2</td>
<td>0.2</td>
<td></td>
</tr>
</tbody>
</table>

The geometry with the springs added.

**Rescaling the Geometry**

1. From the **Edit** menu, choose **Select All**.
2. From the **Draw** menu, select **Modify** and then **Scale**.
3. In the **Scale factor** edit fields for x and y, type 1e-3.
4. Click **OK**.
5. Click the **Zoom Extents** button.
6. From the **Options** menu, choose **Axes/Grid Settings**.
7. Click the **Grid** tab.
8. Select the **Auto** check box.
9. Click **OK**.
CREATING A MAPPED MESH
1 From the Mesh menu, choose Mapped Mesh Parameters.
2 Click the Boundary tab.
3 Select Boundaries 12, 16, 27, and 31.
4 Select the Constrained edge element distribution check box.
5 In the Number of edge elements edit field, type 6.
6 Select Boundaries 3, 7, 13, 14, 20, 23, 30, and 39.
7 Select the Constrained edge element distribution check box.
8 In the Number of edge elements edit field, type 12.
9 Next select Boundaries 4, 11, 19, 21, 24, 26, 32, and 36.
10 Select the Constrained edge element distribution check box.
11 In the Number of edge elements edit field, type 3.
12 Click the Remesh button.
13 Click OK.

The geometry with the 2D mapped mesh.

EXTRUDING MESH INTO 3D
1 From the Mesh menu, select Extrude Mesh.
2 On the Geometry page, type 20e-6 40e-6 in the Distance edit field.
   This specifies a 3D geometry meshed in two sections: a first section between the planes \( z = 0 \) and \( z = 20 \mu m \), and a second section between \( z = 20 \mu m \) and \( z = 40 \mu m \). On the Mesh page, you can specify the number of element layers for each
section. The default is in this case a single element layer per section. In general, the default number of element layers is a function of the 2D mesh-element size to give 3D prism elements of roughly the same size in all directions.

3 Click **OK**.

---

**PHYSICS SETTINgS**

*Application Mode Properties*

1 From the **Physics** menu, select **Properties**.

2 In the **Application Mode Properties** dialog box, change the value in the **Large deformation** list to **On**.

3 Click **OK**.

*Subdomain Settings*

1 From the **Physics** menu, choose **Subdomain Settings**.

2 In the **Subdomain Selection** list, select all subdomains (1–18).

3 Click the **Material** tab, then click the **Load** button.

4 From the **Basic Material Properties** list, choose **Aluminum 3003-H18**.

5 Click **OK**.

6 Click the **Initial Stress and Strain** tab.

7 From the **Subdomain selection** list, choose Subdomains 3, 5, 11, and 17.

8 Select the **Include initial stress** check box.

9 For both $\sigma_{xi}$ and $\sigma_{yi}$ enter the value -Stress.
10 From the **Subdomain selection** list, choose Subdomains 4, 6, 12, and 18.

11 Select the **Include initial stress** check box.

12 For both $\sigma_{x1}$ and $\sigma_{y1}$ enter the value $+$Stress.

13 Click **OK**.

**Boundary Conditions**

1 From the **Physics** menu, choose **Boundary Settings**.

2 In the **Boundary selection** list, select Boundaries 15, 16, 17, 20, 92, 95, 102, and 103 (see the image below).

3 On the **Constraint** page select, set the check boxes for **Constraint condition** list to **Fixed**.

4 Click **OK**.

Geometry with the fixed boundaries highlighted.

**COMPUTING THE SOLUTION**

For large stress values this model is very nonlinear and needs a lot of solver steps to converge. Thus you need to increase the default number of allowed steps before solving the model.

1 From the **Solve** menu, select **Solver Parameters**.

2 Verify that the **Analysis** list has selection **Static** and that the **Auto select solver** is selected.

3 Go to the **Stationary** page.

4 In the **Maximum number of iterations** field, type 50.
5 Click OK.
6 Click the Solve button on the Main toolbar.

**POSTPROCESSING AND VISUALIZATION**

Generate Figure 2-18 on page 68 with the following steps.

1 From the Postprocessing menu, choose Plot Parameters.
2 On the General page, clear the Slice check box in the Plot type area.
3 Select both the Boundary and Deformed shape check boxes.
4 Click the Deform tab.
5 Clear the Auto check box, and in the Scale factor edit field type 1.0.
6 Click OK.
7 Click the Zoom Extents button.
8 Click the Headlight button on the Camera toolbar on the left side of the user interface.

**STIFFENING THE CENTER SECTION**

1 From the Physics menu, choose Subdomain Settings.
2 In the Subdomain selection list, choose 1, 2, 7–10, and 13–16.
3 On the Material page, click the Load button.
4 From the Basic Material Properties list, choose Steel AISI 4340.
5 Click OK twice.
6 Click the Solve button.

The resulting plot is shown in Figure 2-18 on page 68.

**DISPLACEMENT VS. PRESTRESS**

1 From the Solve menu, choose Solver Parameters.
2 From the Analysis list, choose Parametric.
3 Click the General tab. In the Parameter name edit field, type Stress.
4 In the Parameter values edit field, type 0:1e9:10e9. Click OK.
5 Click the Solve button. The analysis can require several minutes to complete.

**POSTPROCESSING AND VISUALIZATION**

1 From the Postprocessing menu, choose Cross-Section Plot Parameters.
2 In the Solutions to use list, verify that all solutions are selected. If not, click in the list and press Ctrl+A.

3 Click the Title/Axis button. Select the option button next to the First axis label edit field, then enter the label Prestress [N/m²]. Click OK.

4 Click the Point tab. In the y-axis data area, select Solid, Stress-Strain (smsld)>Total displacement from the Predefined quantities list and um from the Unit list.

5 In the Coordinates area, change the x, y, and z values to 0.5e-3, 0.5e-3, and 40e-6, respectively.

6 Click Apply.

The resulting plot appears in Figure 2-19 on page 69.

7 On the General page, click the Title/Axis button. Click the Auto option button for the First axis label, then click OK.

8 On the Line/Extrusion page, click the Line plot option button.

9 In the y-axis data area, select Solid, Stress-Strain (smsld)>Total displacement from the Predefined quantities list and um from the Unit list.

10 In the x-axis data area, click the lower option button, then click Expression. From the Predefined quantities list, select Geometry and Mesh>x-coordinate. From the Unit list, select mm, then click OK.

11 Change the values in the Cross-section line data area as follows:

<table>
<thead>
<tr>
<th>NAME</th>
<th>VALUE</th>
<th>NAME</th>
<th>VALUE</th>
<th>NAME</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>x0</td>
<td>0</td>
<td>y0</td>
<td>0.5e-3</td>
<td>z0</td>
<td>40e-6</td>
</tr>
<tr>
<td>x1</td>
<td>1e-3</td>
<td>y1</td>
<td>0.5e-3</td>
<td>z1</td>
<td>40e-6</td>
</tr>
</tbody>
</table>

12 Click the Line Settings button. From the Line marker list, select Cycle. Select the Legend check box, then click OK to close the Line Settings dialog box.

13 Click OK.

The results appear in Figure 2-20 on page 69.

Visualizing the Released Stress State
Follow the steps below to create Figure 2-21 on page 70.

1 From the Postprocessing menu, choose Plot Parameters.

2 Click the Boundary tab.

3 Find the Boundary data area, and in the Expression edit field type s1_smsld.

4 Click OK.
Residual Stress in a Thin-Film Resonator

Introduction

Almost all surface-micromachined thin films are subject to residual stress. The most common is likely thermal stress, which accompanies a change in temperature and is due to the difference in the coefficient of thermal expansion between the film and the substrate. The examples in this section show how to add thermal residual stress to a structural-mechanical model and observe how it changes the structure’s resonant frequency.

For a lateral resonator with four cantilever-beam springs, the resonant frequency is

\[ f_0 = \frac{1}{2\pi} \sqrt{\frac{4Et^5}{mL^3} + \frac{24\sigma_r t^5}{5mL}} \]

where \( m \) is the mass of the resonator plate, \( E \) is Young’s modulus, \( t \) is the thickness, \( L \) is the length, \( b \) is the width, and \( \sigma_r \) is the residual stress in the cantilevers. The stress is typically a sum of external stresses, the thermal stress, and intrinsic components. Assuming the material is isotropic, the stress is constant through the film thickness, and the stress component in the direction normal to the substrate is zero. The stress-strain relationship is then
where \(\nu\) is Poisson’s ratio.

A process deposits a thin film onto a thick substrate at a high temperature. When the assembly cools to room temperature, the film and the substrate shrink differently and cause strain in the film. The strain comes from \(\varepsilon = \Delta\alpha \Delta T\) where \(\Delta\alpha\) is the difference between the thermal-expansion coefficients, and \(\Delta T\) is the difference between the deposition temperature and the normal operating temperature.

You can relieve thermal residual stress in thin-film spring structures by folding the flexures as shown in the next figure. The flexures relieve axial stress because each is free to expand or contract in the axial direction.

The film resonator with folded cantilever beam strings.

The basic folded structure is a U-shaped spring. For springs in series, the equivalent spring constant is

\[
\frac{1}{k_{eq}} = \frac{1}{k_1} + \frac{1}{k_2} + \frac{1}{k_3}
\]

The first and last springs are cantilever beams. You obtain the spring constant for them from \(k = 3EI/L^3\), where \(I\) is the moment of inertia. For a rectangular beam with a rotation about the y-axis, the moment of inertia is \(I = wt^3/12\), where \(w\) is the width and \(t\) is the structure’s thickness. You can treat the second spring as a column with a spring constant of \(k = AE/L\), where \(A\) is the cross-sectional area \(A = wt\). Assuming the spring thickness and width are the same everywhere, the equation comes to
which can help estimate the lengths of the folded springs.

Model Definition

This example took the dimensions and the material properties presented in the following tables from the example in Chapter 27.2.5 in Ref. 1. It calculates the lengths of the folded cantilever using the equivalent spring-constant relationship.

This simulation models thermal residual stress using the thermal expansion option in the Structural Mechanics application mode. It calculates the coefficient of thermal expansion using the stress-strain relationship. It sets the deposition temperature to 605 °C (see Chapter 16.13.2.3 in Ref. 1).

\[
L_{eq}^3 = L_1^3 + \frac{wt^2L_2}{4} + L_3^3,
\]

In order to determine the eigenfrequencies for the case with residual stress, you must use the large-deformation analysis available in the structural mechanics application modes. First solve for the residual stress using a nonlinear solver. Then store the linear solution and solve for the eigenfrequencies using that stored solution. To obtain the eigenfrequency without the stress, solve the problem using the initial settings.

<table>
<thead>
<tr>
<th>PARAMETER</th>
<th>STRAIGHT CANTILEVERS</th>
<th>FOLDED CANTILEVERS</th>
<th>SHUTTLE MASS</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Straight</td>
<td>L1</td>
<td>L2</td>
</tr>
<tr>
<td>Length</td>
<td>200 µm</td>
<td>170 µm</td>
<td>10 µm</td>
</tr>
<tr>
<td>Width</td>
<td>2 µm</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Thickness</td>
<td>2.25 µm</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Material</td>
<td>polysilicon</td>
</tr>
<tr>
<td>Young's modulus</td>
<td>155 GPa</td>
</tr>
<tr>
<td>Poisson's ratio</td>
<td>0.23</td>
</tr>
<tr>
<td>Density</td>
<td>2330 kg/m³</td>
</tr>
<tr>
<td>(T_0)</td>
<td>605 °C</td>
</tr>
<tr>
<td>(T_1)</td>
<td>25 °C</td>
</tr>
</tbody>
</table>
Results and Discussion

Table summarizes the resonant frequencies for the first horizontal eigenmode. For the 2D models this is the lowest found eigenmode, but for the 3D models this is the second mode. In 3D modes, the lowest resonance corresponds to eigenmode with rotational movement. You can see these modes for the resonator with straight cantilevers in the pictures below the table.

The von Mises stress is close to 50 MPa in the legs of the resonators with straight cantilevers. But for folded cantilevers, the stress is much less, about 140 kPa (See pictures in the step-by-step instructions). The analytical reference value for straight cantilevers was calculated using 50 MPa stress.

As the table shows, the resonant frequency for the straight cantilevers increases significantly when the model includes residual stress. Moreover, the model results agree closely with the analytical estimates. By folding the springs you can decrease the sensitivity to stress.

<table>
<thead>
<tr>
<th></th>
<th>STRAIGHT CANTILEVERS</th>
<th>FOLDED CANTILEVERS</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>ANALYTICAL</td>
<td>2D MODEL</td>
</tr>
<tr>
<td>Without stress</td>
<td>15.0 kHz</td>
<td>14.8 kHz</td>
</tr>
<tr>
<td>With residual stress</td>
<td>33.1 kHz</td>
<td>31.9 kHz</td>
</tr>
</tbody>
</table>

The first and rotational eigenmode of the resonator with straight cantilevers.
The second and horizontal eigenmode of the resonator with straight cantilevers.

Reference


**Model Library path:** MEMS_Module/Actuator_Models/resonator_straight_2d

**Model Library path:** MEMS_Module/Actuator_Models/resonator_folded_2d

**Model Library path:** MEMS_Module/Actuator_Models/resonator_straight_3d

**Model Library path:** MEMS_Module/Actuator_Models/resonator_folded_3d
CHAPTER 2: MEMS ACTUATOR MODELS

MODEL NAVIGATOR
1. Open the Model Navigator, click the New tab, and in the Space dimension list select 2D.
2. In the list of application modes, select MEMS Module>Structural Mechanics>Plane Stress>Static analysis.
3. Click OK.

OPTIONS AND SETTINGS
1. From the Options menu choose Constants.
2. In the Constants dialog box enter the following names and expressions; the descriptions are optional. When finished, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>E</td>
<td>155[MPa]</td>
<td>Young’s modulus</td>
</tr>
<tr>
<td>nu</td>
<td>0.23</td>
<td>Poisson’s ratio</td>
</tr>
<tr>
<td>rho</td>
<td>2330[kg/m^3]</td>
<td>Density</td>
</tr>
<tr>
<td>sigma</td>
<td>50[MPa]</td>
<td>Residual stress</td>
</tr>
<tr>
<td>epsilon</td>
<td>sigma*(1-nu)/E</td>
<td>Residual strain</td>
</tr>
<tr>
<td>T1</td>
<td>605[degC]</td>
<td>Deposition temperature</td>
</tr>
<tr>
<td>T0</td>
<td>25[degC]</td>
<td>Room temperature</td>
</tr>
<tr>
<td>daT</td>
<td>epsilon/(T1-T0)</td>
<td>Coefficient of thermal expansion (1/K)</td>
</tr>
</tbody>
</table>

GEOMETRY MODELING
1. Shift-click the Rectangle/Square button on the Draw toolbar to create these five rectangles:

<table>
<thead>
<tr>
<th>NAME</th>
<th>SIZE</th>
<th>POSITION</th>
<th>X</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>250e-6</td>
<td>120e-6</td>
<td>Corner</td>
<td>0</td>
</tr>
<tr>
<td>R2</td>
<td>2e-6</td>
<td>200e-6</td>
<td>Corner</td>
<td>100e-6</td>
</tr>
<tr>
<td>R3</td>
<td>2e-6</td>
<td>200e-6</td>
<td>Corner</td>
<td>148e-6</td>
</tr>
<tr>
<td>R4</td>
<td>2e-6</td>
<td>200e-6</td>
<td>Corner</td>
<td>100e-6</td>
</tr>
<tr>
<td>R5</td>
<td>2e-6</td>
<td>200e-6</td>
<td>Corner</td>
<td>148e-6</td>
</tr>
</tbody>
</table>
2. Click the **Zoom Extents** button on the Main toolbar.

*Initial geometry for the thin-film resonator in 2D with straight cantilevers.*

**PHYSICS SETTINGS**

*Application Mode Properties*

1. From the **Physics** menu, choose **Properties**.
2. In the **Application Mode Properties** dialog box, go to the **Large deformations** list and select **On**. Click **OK**.

*Subdomain Settings*

1. From the **Physics** menu, choose **Subdomain Settings**.
2. Select all subdomains by first clicking in the **Subdomain selection** list or the drawing area and then pressing Ctrl+A.
3. Enter the following values on the **Material** page of the **Subdomain Settings** dialog box; when finished, click **OK**.

<table>
<thead>
<tr>
<th>QUANTITY</th>
<th>VALUE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>E</td>
<td>E</td>
<td>Young’s modulus</td>
</tr>
<tr>
<td>ν</td>
<td>νu</td>
<td>Poisson’s ratio</td>
</tr>
<tr>
<td>α</td>
<td>daT</td>
<td>Thermal expansion coefficient</td>
</tr>
<tr>
<td>ρ</td>
<td>rho</td>
<td>Density</td>
</tr>
<tr>
<td>thickness</td>
<td>2.25e-6</td>
<td>Thickness</td>
</tr>
</tbody>
</table>

*Boundary Conditions*

1. From the **Physics** menu, choose **Boundary Settings**.
2 In the **Boundary selection** list, select Boundaries 5, 9, 15, and 19.

3 On the **Constraint** page, set the **Constraint condition** list to **Fixed**.

4 Click **OK**.

**MESH GENERATION**

1 From the **Mesh** menu, choose **Free Mesh Parameters**.

2 Verify that **Normal** is selected from the **Predefined mesh sizes** list.

3 Click **Custom mesh size**.

4 In the **Resolution of narrow regions** field type 2.

5 Click **Remesh**, then click **OK**.

**COMPUTING THE SOLUTION—EIGENMODES WITHOUT STRESSES**

Follow the steps below to compute the eigenmodes with the applied stress stiffening:

1 From the **Solve** menu, choose **Solver Parameters**.

2 From the **Analysis** list, select **Eigenfrequency**.

3 Click **OK**.

4 Click the **Solve** button.

**POSTPROCESSING AND VISUALIZATION**

1 From the **Postprocessing** menu, choose **Plot Parameters**.

2 On the **General** page, choose from the **Eigenfrequency** list the mode you want to plot.

   The first eigenfrequency is approximately 14 kHz

3 Click the **Surface** tab.

   The default plot in this page is the von Mises stress. Because the solution from the
   Eigenfrequency analysis is scaled, the stress levels is arbitrarily scaled also. Thus, it is
   more informative to plot, for example, the Total displacement.

4 Select **Plane Stress (smps)>Total displacement** from the **Predefined quantities** list.

5 Click the **Deform** tab.

6 Select the **Deformed shape plot** check box.

7 Click **OK**.

**PHYSICS SETTINGS—THERMAL STRAINS**

**Subdomain Settings**

1 From the **Physics** menu, choose **Subdomain Settings**.
2 Select all subdomains.

3 On the **Load** page, enter the values in the following table; when done, click **OK**.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>SETTING/VALUE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Include thermal expansion</td>
<td>Selected</td>
<td></td>
</tr>
<tr>
<td>Temp</td>
<td>T0</td>
<td>Strain temperature</td>
</tr>
<tr>
<td>Tempref</td>
<td>T1</td>
<td>Strain ref. temper.</td>
</tr>
</tbody>
</table>

**Computing the Solution — Static Residual Stress**

Using the steps below, solve the model and store the solution for later use.

1 From the **Solve** menu, choose **Solver Parameters**.

2 From the **Analysis** list, select **Static**, then click **OK**.

3 Click the **Solve** button on the Main toolbar.

4 From the **Solve** menu, choose **Solver Manager**.

5 Click the **Initial Value** tab.

6 Click the **Store Solution** button at the bottom of the dialog box.

7 In the **Values of variables not solved for and linearization point** area, select **Stored solution**.

   It is important to define the linearization point correctly. Using this information, the stress stiffening effect enters into the following eigenfrequency solution computed below.

8 Click **OK**.

**Postprocessing and Visualization — Static Residual Stress**

To gain information about the thermally generated stresses change the surface plot back to von Mises stress:

1 From the **Postprocessing** menu, choose **Plot Parameters**.

2 Click the **Surface** tab.

3 Select **Plane Stress (smps)>>von Mises stress** from the **Predefined quantities** list.

4 Click **OK**.
Deformed shape of the geometry for the thin-film resonator in 2D with straight cantilevers.

Next create a cross-section plot to inspect the stress distribution in more detail.

1. From the Postprocessing menu choose Cross-Section Plot Parameters.
2. Click the Line/Extrusion tab.
3. Enter the following values:

<table>
<thead>
<tr>
<th>PARAMETER</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plot type</td>
<td>Line plot</td>
</tr>
<tr>
<td>Predefined quantities</td>
<td>von Mises stress</td>
</tr>
<tr>
<td>x-axis data</td>
<td>y</td>
</tr>
<tr>
<td>CROSS-SECTION LINE DATA</td>
<td></td>
</tr>
<tr>
<td>x0</td>
<td>101e-6</td>
</tr>
<tr>
<td>x1</td>
<td>101e-6</td>
</tr>
<tr>
<td>y0</td>
<td>0</td>
</tr>
<tr>
<td>y1</td>
<td>320e-6</td>
</tr>
<tr>
<td>Line resolution</td>
<td>321</td>
</tr>
</tbody>
</table>
4 Click **OK**.

![Line plot of von Mises stress going first through the resonator body and then through one of the legs.](image)

**COMPUTING THE SOLUTION—EIGENMODES WITH THERMAL STRESSES**

Follow the steps below to compute the eigenmodes with the applied stress stiffening:

1. From the **Solve** menu choose **Solver Parameters**.
2. From the **Analysis** list select **Eigenfrequency**.
3. Click **OK**.
4. Click the **Solve** button on the Main toolbar. The value of the eigenfrequency appears in the message log. Notice that the first eigenfrequency has changed to approximately 31,950 Hz.

**POSTPROCESSING AND VISUALIZATION**

1. From the **Postprocessing** menu, choose **Plot Parameters**.
2. Click the **Surface** tab.
3. Select **Plane Stress (smps)>Total displacement** from the **Predefined quantities** list.
4 Click OK.

Deformation associated with the first eigenfrequency for the thin-film resonator in 2D with straight cantilevers.

Modeling Using the Graphical User Interface—2D, Folded Cantilevers

**MODEL NAVIGATOR**
1. Open the Model Navigator, click the New tab, and in the Space dimension list select 2D.
2. Click the New tab, and in the list of application modes select MEMS Module>Structural Mechanics>Plane Stress>Static analysis.
3. Click OK.

**OPTIONS AND SETTINGS**
1. From the Options menu choose Constants.
In the **Constants** dialog box enter the following names and expressions; the descriptions are optional. When finished, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>E</td>
<td>155 [GPa]</td>
<td>Young's modulus</td>
</tr>
<tr>
<td>nu</td>
<td>0.23</td>
<td>Poisson's ratio</td>
</tr>
<tr>
<td>rho</td>
<td>2330 [kg/m^3]</td>
<td>Density</td>
</tr>
<tr>
<td>sigma</td>
<td>50 [MPa]</td>
<td>Residual stress</td>
</tr>
<tr>
<td>epsilon</td>
<td>sigma*(1-nu)/E</td>
<td>Residual strain</td>
</tr>
<tr>
<td>T1</td>
<td>605 [degC]</td>
<td>Deposition temperature</td>
</tr>
<tr>
<td>T0</td>
<td>25 [degC]</td>
<td>Room temperature</td>
</tr>
<tr>
<td>daT</td>
<td>epsilon/(T1-T0)</td>
<td>Coefficient of thermal expansion</td>
</tr>
</tbody>
</table>

**GEOMETRY MODELING**

1. Shift-click the **Rectangle/Square** button on the Draw toolbar to create these 13 rectangles:

<table>
<thead>
<tr>
<th>NAME</th>
<th>SIZE</th>
<th>POSITION</th>
<th>X</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>250e-6</td>
<td>Corner</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>R2</td>
<td>2e-6</td>
<td>170e-6</td>
<td>100e-6</td>
<td>120e-6</td>
</tr>
<tr>
<td>R3</td>
<td>12e-6</td>
<td>2e-6</td>
<td>100e-6</td>
<td>290e-6</td>
</tr>
<tr>
<td>R4</td>
<td>2e-6</td>
<td>146e-6</td>
<td>110e-6</td>
<td>144e-6</td>
</tr>
<tr>
<td>R5</td>
<td>2e-6</td>
<td>170e-6</td>
<td>148e-6</td>
<td>120e-6</td>
</tr>
<tr>
<td>R6</td>
<td>12e-6</td>
<td>2e-6</td>
<td>138e-6</td>
<td>290e-6</td>
</tr>
<tr>
<td>R7</td>
<td>2e-6</td>
<td>146e-6</td>
<td>138e-6</td>
<td>144e-6</td>
</tr>
<tr>
<td>R8</td>
<td>2e-6</td>
<td>170e-6</td>
<td>100e-6</td>
<td>-170e-6</td>
</tr>
<tr>
<td>R9</td>
<td>12e-6</td>
<td>2e-6</td>
<td>100e-6</td>
<td>-172e-6</td>
</tr>
<tr>
<td>R10</td>
<td>2e-6</td>
<td>146e-6</td>
<td>110e-6</td>
<td>-170e-6</td>
</tr>
<tr>
<td>R11</td>
<td>2e-6</td>
<td>170e-6</td>
<td>148e-6</td>
<td>-170e-6</td>
</tr>
<tr>
<td>R12</td>
<td>12e-6</td>
<td>2e-6</td>
<td>138e-6</td>
<td>-172e-6</td>
</tr>
<tr>
<td>R13</td>
<td>2e-6</td>
<td>146e-6</td>
<td>138e-6</td>
<td>-170e-6</td>
</tr>
</tbody>
</table>
2 Click the **Zoom Extents** button on the Main toolbar.

*Initial geometry for the thin-film resonator in 2D with folded cantilevers.*

**PHYSICS SETTINGS**

*Application Mode Properties*

1 From the **Physics** menu, choose **Properties**.

2 In the **Application Mode Properties** dialog, go to the **Large deformations** list and select **On**.

*Subdomain Settings*

1 From the **Physics** menu, choose **Subdomain Settings**.

2 Select all subdomains.

3 On the indicated pages, specify the following settings; when finished, click **OK**.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>VALUE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>MATERIAL PAGE</td>
<td></td>
<td></td>
</tr>
<tr>
<td>E</td>
<td>E</td>
<td>Young’s modulus</td>
</tr>
<tr>
<td>ν</td>
<td>ν</td>
<td>Poisson’s ratio</td>
</tr>
<tr>
<td>α</td>
<td>daT</td>
<td>Thermal expansion coefficient</td>
</tr>
<tr>
<td>ρ</td>
<td>ρ</td>
<td>Density</td>
</tr>
<tr>
<td>thickness</td>
<td>2.25e-6</td>
<td>Thickness</td>
</tr>
<tr>
<td>LOAD PAGE</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Include thermal expansion</td>
<td>selected</td>
<td></td>
</tr>
</tbody>
</table>
Boundary Conditions
1. From the Physics menu, choose Boundary Settings.
2. In the Boundary selection list, select Boundaries 22, 24, 34, and 36.
3. On the Constraint page, set the Constraint condition list to Fixed.
4. Click OK.

Mesh Generation
1. From the Mesh menu, choose Free Mesh Parameters.
2. Verify that Normal is selected from the Predefined mesh sizes list.
3. Click Custom mesh size.
4. In the Resolution of narrow regions edit field type 2.
5. Click Remesh, then click OK.

Computing the Solution—Eigenmodes Without Stresses
Follow the steps below to compute the eigenmodes with the applied stress stiffening:
1. From the Solve menu, choose Solver Parameters.
2. From the Analysis list, select Eigenfrequency.
3. Click OK.
4. Click the Solve button on the Main toolbar.

Postprocessing and Visualization
1. From the Postprocessing menu, choose Plot Parameters.
2. On the General page, choose the mode you want to plot from the Eigenfrequency list; the first eigenfrequency is approximately 14 kHz.
3. Click the Surface tab.
   The default plot in this page is the von Mises stress. Because the solution from the Eigenfrequency analysis is scaled, the stress levels will be arbitrarily scaled also. Thus, it is more informative to plot for example the Total displacement.
4. Select Plane Stress (smps)>Total displacement from the Predefined quantities list.
5. Click the Deform tab.
6. Select the Deformed shape plot check box.
7 Click OK.

**PHYSICS SETTINGS—THERMAL STRAINS**

1 From the Physics menu, choose Subdomain Settings.
2 Select all subdomains.
3 On the Load page, enter the values in the following table; when finished, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>VALUE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Include thermal expansion</td>
<td>selected</td>
<td></td>
</tr>
<tr>
<td>Temp</td>
<td>T0</td>
<td>Strain temperature</td>
</tr>
<tr>
<td>Tempref</td>
<td>T1</td>
<td>Strain ref. temperature</td>
</tr>
</tbody>
</table>

**COMPUTING THE SOLUTION—STATIC RESIDUAL STRESS**

Using the steps below, solve the model and store the solution for later use.

1 From the Solve menu, choose Solver Parameters.
2 From the Analysis list, select Static, then click OK.
3 Click the Solve button on the Main toolbar.
4 From the Solve menu, choose Solver Manager.
5 Click the Initial Value tab.
6 Click the Store Solution button at the bottom of the dialog box.
7 In the Values of variables not solved for and linearization point area select Stored solution.
   It is important to define the linearization point correctly. Using this information, the stress stiffening effect enters into the following eigenfrequency solution computed below.
8 Click OK.

**POSTPROCESSING AND VISUALIZATION—STATIC RESIDUAL STRESS**

To gain information about the thermally generated stresses change the surface plot back to von Mises stress:

1 From the Postprocessing menu, choose Plot Parameters.
2 Click the Surface tab.
3 Select Plane Stress (smps)>von Mises stress from the Predefined quantities list.
4 Click OK.
Deformed shape of the geometry for the thin-film resonator in 2D with folded cantilevers.

Next create a cross-section plot to inspect the stress distribution in more detail:

1. From the Postprocessing menu, choose Cross-Section Plot Parameters.
2. Click the Line/Extrusion tab.
3. Enter these values; when done, click OK.

<table>
<thead>
<tr>
<th>PARAMETER</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plot type</td>
<td>Line plot</td>
</tr>
<tr>
<td>Predefined quantities</td>
<td>von Mises stress</td>
</tr>
<tr>
<td>Expression</td>
<td>mises_smse</td>
</tr>
<tr>
<td>x-axis data</td>
<td>y</td>
</tr>
<tr>
<td>CROSS-SECTION LINE DATA</td>
<td></td>
</tr>
<tr>
<td>x0</td>
<td>101e-6</td>
</tr>
<tr>
<td>x1</td>
<td>101e-6</td>
</tr>
<tr>
<td>y0</td>
<td>0</td>
</tr>
</tbody>
</table>
CHAPTER 2: MEMS ACTUATOR MODELS

LINE PLOT OF VON MISES STRESS GOING FIRST THROUGH THE RESONATOR BODY AND THEN THROUGH ONE OF THE LEGS.

COMPUTING THE SOLUTION—EIGENMODES WITH STRESSES

Follow the steps below to compute the eigenmodes with the applied stress stiffening:

1. From the Solve menu, choose Solver Parameters.
2. From the Analysis list, select Eigenfrequency.
3. Click OK.
4. Click the Solve button on the Main toolbar. Notice that the first eigenfrequency is almost the same as without thermal stresses.

POSTPROCESSING AND VISUALIZATION

1. From the Postprocessing menu, choose Plot Parameters.
2. Click the Surface tab.
3. Select **Plane Stress (smrs)** > **Total displacement** from the **Predefined quantities** list.

4. Click **OK**.

Deformation associated with the first eigenfrequency for the thin-film resonator in 2D with folded cantilevers.

**Modeling Using the Graphical User Interface—3D, Straight Cantilevers**

**MODEL NAVIGATOR**

1. In the **Model Navigator**, click the **New** tab. In the **Space dimension** list, select **3D**.

2. In the list of application modes, select **MEMS Module>Structural Mechanics>Solid, Stress-Strain**.

3. Click **OK**.

**OPTIONS AND SETTINGS**

1. From the **Options** menu, choose **Constants**.
In the Constants dialog box, enter these variable names, expressions, and (optionally) descriptions; when done, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>E</td>
<td>155 [GPa]</td>
<td>Young’s modulus</td>
</tr>
<tr>
<td>nu</td>
<td>0.23</td>
<td>Poisson’s ratio</td>
</tr>
<tr>
<td>rho</td>
<td>2330 [kg/m³]</td>
<td>Density</td>
</tr>
<tr>
<td>sigma</td>
<td>50 [MPa]</td>
<td>Residual stress</td>
</tr>
<tr>
<td>epsilon</td>
<td>$\sigma(1-nu)/E$</td>
<td>Residual strain</td>
</tr>
<tr>
<td>T1</td>
<td>605 [°C]</td>
<td>Deposition temperature</td>
</tr>
<tr>
<td>T0</td>
<td>25 [°C]</td>
<td>Room temperature</td>
</tr>
<tr>
<td>daT</td>
<td>$\epsilon/(T1-T0)$</td>
<td>Coefficient of thermal expansion</td>
</tr>
</tbody>
</table>

**GEOMETRY MODELING**

1. Shift-click the **Block** button on the Draw toolbar to create these five solid blocks; when complete, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>LENGTH</th>
<th>AXIS BASE POINT</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>X</td>
<td>Y</td>
</tr>
<tr>
<td>BLK1</td>
<td>250e-6</td>
<td>120e-6</td>
</tr>
<tr>
<td>BLK2</td>
<td>2e-6</td>
<td>200e-6</td>
</tr>
<tr>
<td>BLK3</td>
<td>2e-6</td>
<td>200e-6</td>
</tr>
<tr>
<td>BLK4</td>
<td>2e-6</td>
<td>200e-6</td>
</tr>
<tr>
<td>BLK5</td>
<td>2e-6</td>
<td>200e-6</td>
</tr>
</tbody>
</table>
2. Click the **Zoom Extents** button on the Main toolbar.

*Initial geometry for the thin-film resonator in 3D with straight cantilevers.*

**PHYSICS SETTINGS**

*Application Mode Properties*

1. From the **Physics** menu, choose **Properties**.
2. In the **Application Mode Properties** dialog box, go to the **Large deformations** list and select **On**.

*Subdomain Settings*

1. From the **Physics** menu, choose **Subdomain Settings**.
2. Select all subdomains.
3. Enter the following values on the **Material** page of the **Subdomain Settings** dialog box; when finished, click **OK**.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>E</td>
<td>E</td>
<td>Young’s modulus</td>
</tr>
<tr>
<td>ν</td>
<td>nu</td>
<td>Poisson’s ratio</td>
</tr>
<tr>
<td>α</td>
<td>daT</td>
<td>Thermal expansion coeff.</td>
</tr>
<tr>
<td>ρ</td>
<td>rho</td>
<td>Density</td>
</tr>
</tbody>
</table>

*Boundary Conditions*

1. From the **Physics** menu, select **Boundary Settings**.
2. In the **Boundary selection** list, select Boundaries 7, 15, 21, and 29.
3. On the **Constraint** page, set the **Constraint condition** list to **Fixed**.
4 Click **OK**.

**Mesh Generation**

1 From the **Mesh** menu, choose **Free Mesh Parameters**.
2 Click the **Global** tab.
3 Verify that the selection from the **Predefined mesh sizes** list is **Normal**.
4 Click the **Advanced** tab.
5 For the **z-direction scale factor** enter **2.0**.
6 Click **Remesh**.
7 Click **OK**.

**Computing the Solution—Eigenmodes Without Stresses**

Follow the steps below to compute the eigenmodes with the applied stress stiffening:

1 From the **Solve** menu, choose **Solver Parameters**.
2 From the **Analysis** list, select **Eigenfrequency**.
3 Click **OK**.
4 Click the **Solve** button on the Main toolbar.

**Postprocessing and Visualization—Static Residual Stress**

1 From the **Postprocessing** menu, choose **Plot Parameters**.
2 Click the **General** tab.
3 From the **Eigenfrequency** list, choose the mode you want to plot; the eigenmode for the horizontal movement has an eigenfrequency of approximately **14.8 kHz**
4 Clear the **Slice** check box.
5 Select the **Boundary** and **Deformed shape** check boxes.
6 Click **OK**.

**Physics Settings—Thermal Strains**

**Subdomain Settings**

1 From the **Physics** menu, choose **Subdomain Settings**.
2 Select all subdomains.
3 Go to the **Load** page and enter the values in the following table; when done, click **OK**.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>VALUE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Include thermal expansion</td>
<td>yes</td>
<td></td>
</tr>
<tr>
<td>Temp</td>
<td>T0</td>
<td>Strain temperature</td>
</tr>
<tr>
<td>Tempref</td>
<td>T1</td>
<td>Strain ref. temperature</td>
</tr>
</tbody>
</table>

**COMPUTING THE SOLUTION—STATIC RESIDUAL STRESS**

Using the steps below, solve the model and store the static solution for later use.

1 From the **Solve** menu, choose **Solver Parameters**.
2 From the **Analysis** list, select **Static**, then click **OK**.
3 Click the **Solve** button on the Main toolbar.
4 From the **Solve** menu, choose **Solver Manager**.
5 Click the **Initial Value** tab.
6 Click the **Store Solution** button at the bottom of the dialog box.
7 In the **Values of variables not solved for and linearization point** area select **Stored solution**.
8 Click **OK**.
Deformed shape of the geometry for the thin-film resonator in 3D with straight cantilevers.

Next create a cross-section plot to inspect the stress distribution in more detail.

1. From the Postprocessing menu, choose Cross-Section Plot Parameters.
2. Click the Line/Extrusion tab.
3. Enter the following values; when finished, click OK.

<table>
<thead>
<tr>
<th>PARAMETER</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plot type</td>
<td>Line plot</td>
</tr>
<tr>
<td>Predefined quantities</td>
<td>von Mises stress</td>
</tr>
<tr>
<td>Expression</td>
<td>mises_smsld</td>
</tr>
<tr>
<td>x-axis data</td>
<td>y</td>
</tr>
<tr>
<td>CROSS-SECTION LINE DATA</td>
<td></td>
</tr>
<tr>
<td>x0</td>
<td>101e-6</td>
</tr>
<tr>
<td>x1</td>
<td>101e-6</td>
</tr>
</tbody>
</table>
Line plot of von Mises stress going first through the resonator body and then through one of the legs.

**COMPUTING THE SOLUTION—EIGENMODES WITH STRESSES**

1. From the **Solve** menu, choose **Solver Parameters**.
2. From the **Analysis** list, select **Eigenfrequency**.
3. Click **OK**.
4. From the **Solve** menu, choose **Solver Manager**.

<table>
<thead>
<tr>
<th>PARAMETER</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>y0</td>
<td>0</td>
</tr>
<tr>
<td>y1</td>
<td>320e-6</td>
</tr>
<tr>
<td>z0</td>
<td>1.125e-6</td>
</tr>
<tr>
<td>z1</td>
<td>1.125e-6</td>
</tr>
<tr>
<td>Line resolution</td>
<td>321</td>
</tr>
</tbody>
</table>
Click the **Solve** button. Observe the eigenfrequency from the plot title; the first found eigenmode corresponds to rotational movement.

Deformation associated with the first eigenfrequency for the thin-film resonator in 3D with straight cantilevers.

**POSTPROCESSING AND VISUALIZATION—EIGENFREQUENCY**

1. From the **Postprocessing** menu, choose **Plot Parameters**.
2. Click the **General** tab.
3. Go to the **Solution to use** area, and in the **Eigenfrequency** list select the second value, which should be near 32 kHz.
4. Click **OK**.

Deformation associated with the second eigenfrequency for the thin-film resonator in 3D with straight cantilevers.
MODEL NAVIGATOR
1 In the Model Navigator click the New tab, and in the Space dimension list select 3D.
2 In the list of application modes select MEMS Module>Structural Mechanics>Solid, Stress-Strain.
3 Click OK.

OPTIONS AND SETTINGS
1 From the Options menu, choose Constants.
2 In the Constants dialog box, enter these variable names, expressions, and (optionally) descriptions; when finished, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>E</td>
<td>155[GPa]</td>
<td>Young’s modulus</td>
</tr>
<tr>
<td>nu</td>
<td>0.23</td>
<td>Poisson’s ratio</td>
</tr>
<tr>
<td>rho</td>
<td>2330[kg/m³]</td>
<td>Density</td>
</tr>
<tr>
<td>sigma</td>
<td>50[MPa]</td>
<td>Residual stress</td>
</tr>
<tr>
<td>epsilon</td>
<td>sigma*(1-nu)/E</td>
<td>Residual strain</td>
</tr>
<tr>
<td>T1</td>
<td>605[degC]</td>
<td>Deposition temperature</td>
</tr>
<tr>
<td>T0</td>
<td>25[degC]</td>
<td>Room temperature</td>
</tr>
<tr>
<td>daT</td>
<td>epsilon/(T1-T0)</td>
<td>Coefficient of thermal expansion</td>
</tr>
</tbody>
</table>

GEOMETRY MODELING
1 Shift-click the Block button on the Draw toolbar to create these 13 solid blocks; when finished, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>LENGTH</th>
<th>AXIS BASE POINT</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>X</td>
<td>Y</td>
</tr>
<tr>
<td>BLK1</td>
<td>250e-6</td>
<td>120e-6</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>CANTILEVER 1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>BLK2</td>
<td>2e-6</td>
<td>170e-6</td>
</tr>
<tr>
<td>BLK3</td>
<td>12e-6</td>
<td>2e-6</td>
</tr>
<tr>
<td>BLK4</td>
<td>2e-6</td>
<td>146e-6</td>
</tr>
<tr>
<td>CANTILEVER 2</td>
<td></td>
<td></td>
</tr>
<tr>
<td>BLK5</td>
<td>2e-6</td>
<td>170e-6</td>
</tr>
</tbody>
</table>
**CHAPTER 2: MEMS ACTUATOR MODELS**

Initial geometry for the thin-film resonator in 3D with folded cantilevers.

**PHYSICS SETTINGS**

*Application Mode Properties*

1. From the *Physics* menu, choose *Properties*.
2. In the *Application Mode Properties* dialog box, go to the *Large deformations* list and select *On*.
3. Click *OK*.

*Subdomain Settings*

1. From the *Physics* menu, choose *Subdomain Settings*.

<table>
<thead>
<tr>
<th>NAME</th>
<th>LENGTH</th>
<th>AXIS BASE POINT</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>BLK6</td>
<td>12e-6</td>
<td>2e-6</td>
</tr>
<tr>
<td>BLK7</td>
<td>2e-6</td>
<td>146e-6</td>
</tr>
<tr>
<td><strong>CANTILEVER 3</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>BLK8</td>
<td>2e-6</td>
<td>170e-6</td>
</tr>
<tr>
<td>BLK9</td>
<td>12e-6</td>
<td>2e-6</td>
</tr>
<tr>
<td>BLK10</td>
<td>2e-6</td>
<td>146e-6</td>
</tr>
<tr>
<td><strong>CANTILEVER 4</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>BLK11</td>
<td>2e-6</td>
<td>170e-6</td>
</tr>
<tr>
<td>BLK12</td>
<td>12e-6</td>
<td>2e-6</td>
</tr>
<tr>
<td>BLK13</td>
<td>2e-6</td>
<td>146e-6</td>
</tr>
</tbody>
</table>

2. Click the *Zoom Extents* button on the Main toolbar.

![Initial geometry for the thin-film resonator in 3D with folded cantilevers.](image)
2. Select all subdomains.
3. On the Material page of the Subdomain Settings dialog box, enter the following values; when finished, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>VALUE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>E</td>
<td>E</td>
<td>Young’s modulus</td>
</tr>
<tr>
<td>ν</td>
<td>νu</td>
<td>Poisson’s ratio</td>
</tr>
<tr>
<td>α</td>
<td>daT</td>
<td>Thermal expansion coefficient</td>
</tr>
<tr>
<td>ρ</td>
<td>ρho</td>
<td>Density</td>
</tr>
</tbody>
</table>

**Boundary Conditions**
1. From the Physics menu, select Boundary Settings.
2. In the Boundary selection list, select 34, 36, 52, and 54.
3. On the Constraint page, set the Constraint condition list to Fixed.
4. Click OK.

**Mesh Generation**
1. From the Mesh menu, choose Free Mesh Parameters.
2. Click the Global tab.
3. Verify that the selection from the Predefined mesh sizes list is Normal.
4. Click the Advanced tab.
5. For the z-direction scale factor enter 2.0.
6. Click Remesh.
7. Click OK.

**Computing the Solution—Eigenmodes Without Stresses**
Follow the steps below to compute the eigenmodes with the applied stress stiffening:
1. From the Solve menu, choose Solver Parameters.
2. From the Analysis list, select Eigenfrequency.
3. Click OK.
4. Click the Solve button.

**Postprocessing and Visualization**
1. From the Postprocessing menu, choose Plot Parameters.
2 Go to the General page.
3 From the Eigenfrequency list, choose the mode you want to plot; The eigenmode for the horizontal movement has an eigenfrequency of approximately 14 kHz.
4 Click the Deform tab.
5 Select the Deformed shape plot check box.
6 Click OK.

**PHYSICS SETTINGS—THERMAL STRAINS**

*Subdomain Settings*
1. From the Physics menu, choose Subdomain Settings.
2. Select all subdomains.
3. On the Load page, enter the values in the following table; when finished, click OK.

<table>
<thead>
<tr>
<th>QUANTITY</th>
<th>VALUE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Temp</td>
<td>T0</td>
<td>Strain temperature</td>
</tr>
<tr>
<td>Tempref</td>
<td>T1</td>
<td>Strain ref. temperature</td>
</tr>
</tbody>
</table>

**COMPUTING THE SOLUTION—STATIC RESIDUAL STRESS**

Using the steps below, solve the model and store the static solution for later use.

1. From the Solve menu, choose Solver Parameters.
2. From the Analysis list, select Static, then click OK.
3. Click the Solve button on the Main toolbar.
4. From the Solve menu, choose Solver Manager.
5. Click the Initial Value tab.
6. Click the Store Solution button at the bottom of the dialog box.
7. In the Values of variables not solved for and linearization point area select Stored solution.
8. Click OK.
POSTPROCESSING AND VISUALIZATION—STATIC RESIDUAL STRESS

According to the plot settings you defined before, the deformed plot with total displacement appears in the user interface:

Deformed shape of the geometry for the thin-film resonator in 3D with folded cantilevers.

Next create a cross-section plot to inspect the stress distribution in more detail.

1. From the Postprocessing menu, choose Cross-Section Plot Parameters.
2. Click the Line/Extrusion tab.
3. Enter the following values; when finished click OK.

<table>
<thead>
<tr>
<th>PARAMETER</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plot type</td>
<td>Line plot</td>
</tr>
<tr>
<td>Predefined quantities</td>
<td>von Mises stress</td>
</tr>
<tr>
<td>Expression</td>
<td>mises_smsld</td>
</tr>
<tr>
<td>x-axis data</td>
<td>y</td>
</tr>
<tr>
<td>CROSS-SECTION LINE DATA</td>
<td></td>
</tr>
<tr>
<td>x0</td>
<td>101e-6</td>
</tr>
<tr>
<td>x1</td>
<td>101e-6</td>
</tr>
</tbody>
</table>
CHAPTER 2: MEMS ACTUATOR MODELS

COMPUTING THE SOLUTION—EIGENMODES WITH STRESSES

1. From the Solve menu, choose Solver Parameters.
2. From the Analysis list, select Eigenfrequency.
3. Click OK.

<table>
<thead>
<tr>
<th>PARAMETER</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>y0</td>
<td>0</td>
</tr>
<tr>
<td>y1</td>
<td>290e-6</td>
</tr>
<tr>
<td>z0</td>
<td>1.125e-6</td>
</tr>
<tr>
<td>z1</td>
<td>1.125e-6</td>
</tr>
<tr>
<td>Line resolution</td>
<td>291</td>
</tr>
</tbody>
</table>

Line plot of von Mises stress going first through the resonator body and then through one of the legs.
4 Click the **Solve** button. Observe the eigenfrequency from the plot title; the first found eigenmode corresponds to rotational movement.

![Deformation associated with the first eigenfrequency for the thin-film resonator in 3D with folded cantilevers.](image)

**POSTPROCESSING AND VISUALIZATION—EIGENFREQUENCY**

1 From the **Postprocessing** menu, choose **Plot Parameters**.

2 Click the **General** tab.

3 From the **Eigenfrequency** list, select the second value, which should be near 14 kHz.

4 Click **OK**.

![Deformation associated with the second eigenfrequency for the thin-film resonator in 3D with folded cantilevers.](image)
Thermoelastic Damping in a MEMS Resonator

Introduction

A high Q value is a key factor of a MEMS resonator. It is essential that the resonator vibrates consistently at the desired frequency and that it requires as little energy as possible to maintain its vibration. These features can be characterized by the resonator’s Q value, which is a measure of the sharpness of its spectrum’s peak. There are several ways to define the Q value, for example:

\[
Q = \frac{2\pi W_0}{\Delta W} = \frac{\omega_0}{2\delta} = \frac{\omega_0}{\Delta \omega}
\]  

(2-5)

where \(W_0\) is the total stored vibrational energy, \(\Delta W\) is the energy lost per cycle, \(\omega_0\) is the natural angular frequency, \(\delta\) is the damping factor (vibration decays exponentially with \(\delta t\)), and \(\Delta \omega\) is the half power width of the spectrum.

In order to improve the resonator, the designer needs to consider all aspects that produce damping and noise to the system. For example, resonators are usually run in vacuum to minimize effects of air and squeeze-film damping.

Thermoelastic damping (Ref. 1, Ref. 2, and Ref. 3) is an important factor that the resonator designer needs to address. It is a result of a phenomenon called thermoelastic friction, which takes place when you subject any material to cyclic stress. The stress results in deformation, and the required energy is mostly stored as internal potential energy. However, materials heat under compressive stress and cool under tensile stress. Thus, due to the heat flow from warmer to cooler regions energy is also lost as nonrecoverable thermal energy. The amount of thermoelastic friction and damping depends on the rate of this energy loss. The magnitude of the energy loss depends on the vibrational frequency and on the structure’s thermal relaxation time constant, which is the effective time the material requires to relax after an applied constant stress or strain. Therefore, the effect of thermoelastic dissipation, and consequently the damping, is most pronounced when the vibration frequency is close to the thermal relaxation frequency.
For simple structures, researchers have developed analytical expressions to estimate thermoelastic damping. According to Zener (Ref. 1 and Ref. 2), you can calculate the Q value for a resonator with a single thermal mode by:

\[
\frac{1}{Q} = \left( \frac{E\alpha^2T_0}{\rho C_p} \right) \left( \frac{\omega\tau}{1 + (\omega\tau)^2} \right)
\]  

(2-6)

where \( E \) is the Young’s modulus, \( \alpha \) is the thermal expansion coefficient, \( T_0 \) is the resonator temperature at rest, \( \rho \) is the density, \( C_p \) is the heat capacity of the material, \( \omega \) is the vibration angular frequency, and \( \tau \) is the thermal relaxation time of the system. Thus it is easy to see that in order to have good Q value, the system needs to be designed so that \( \omega \) is as far from \( 1/\tau \) as possible.

The natural frequency of a beam clamped at both ends can be calculated as (Ref. 4)

\[
\omega_0 = a_0 \frac{h}{L^2} \frac{E}{\rho} \left( \frac{\pi}{a_0} \right)^2
\]  

(2-7)

where \( a_0 \) equals 4.730; \( h \) and \( L \) are the thickness and length of the beam, respectively; and \( E \) and \( \rho \) are material parameters as above.

The thermal relaxation time of the beam is given by

\[
\tau = \frac{\rho C_p h^2}{\pi^2 \kappa}
\]  

(2-8)

where \( \kappa \) is the thermal conductivity and other parameters are as above.

The problem is that Equations 2-6 through 2-8 are valid only for very simple structures. Therefore more advanced methods, such as FEA, are preferable.

This example shows how to model thermoelastic damping with COMSOL Multiphysics. To be able to compare with measurements and analytical expressions, this example illustrates a simple beam resonator in 2D and 3D. The Q value and natural frequency is solved with an eigenfrequency analysis that combines heat transfer and structural mechanics in one equation system. Thus the eigenmodes are thermoelastic.

This example was inspired by the work of Amy Duwel and others (Ref. 1).
Model Definition

Figure 2-22 shows the geometry. The resonator is a beam of silicon with length 400 µm, height 12 µm, and width 20 µm. The beam is fixed at both ends, and it vibrates in a flexural mode in the z direction (that is, along the smallest dimension). The model assumes that the vibration takes place in vacuum. Thus there is no transfer of heat from the free boundaries. The model also assumes that the contact boundaries are thermally insulated.

Table 2-4 lists the physical properties of the beam material and the surroundings:

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Young's modulus, $E$</td>
<td>157 GPa</td>
</tr>
<tr>
<td>Density, $\rho$</td>
<td>2330 kg/m³</td>
</tr>
<tr>
<td>Poisson’s ratio, $\nu$</td>
<td>0.3</td>
</tr>
<tr>
<td>Thermal expansion coefficient, $\alpha$</td>
<td>$2.6 \times 10^{-6}$ K$^{-1}$</td>
</tr>
<tr>
<td>Specific heat, $C_p$</td>
<td>700 J/(kg·K)</td>
</tr>
<tr>
<td>Thermal conductivity, $k$</td>
<td>90 W/(m·K)</td>
</tr>
<tr>
<td>Ambient and initial beam temperature, $T_{init}$</td>
<td>300 K</td>
</tr>
</tbody>
</table>
To gain information about the quality of the resonator, it is of interest to know its natural frequency and \( Q \) value. To do this, you run an eigenfrequency analysis to find the eigenvalues for this system. For a system with damping, the eigenvalue \( \lambda \) contains information about the natural frequency and \( Q \) value according to:

\[
\omega_0 = |\text{Im}(\lambda)| \\
Q = \frac{|\text{Im}(\lambda)|}{2|\text{Re}(\lambda)|}
\]  

(2-9)

The eigenvalues appear as complex conjugates, and \( \omega_0 \) and \( Q \) are therefore given as absolute values.

At this point, to avoid any confusion it is good to note that here \( Q \) refers to the resonator’s quality, whereas later in this text \( Q_{\text{heat}} \) refers to the heat source term in the heat equation.

To model thermoelastic damping, you must consider both the thermal problem and the structural problem. Furthermore, there is a 2-way coupling between them: the strain rate heats or cools the material locally, which produces thermal strains.

The relation between the material stress \( \sigma \) and strain \( \varepsilon \) is given by

\[
\sigma = D\varepsilon_{\text{el}} = D(\varepsilon - \varepsilon_{\text{th}})
\]  

(2-10)

where \( \varepsilon_{\text{el}} \) and \( \varepsilon_{\text{th}} \) are the elastic and thermal strains, respectively, \( D \) is the \( 6 \times 6 \) elasticity matrix, and all stresses and strains are denoted with 6-component vectors consisting of \( x, y, \) and \( z \) normal components followed by the \( xy, yx, \) and \( xz \) shear components.

It is possible to expand this for an isotropic material:

\[
\begin{bmatrix}
\sigma_x \\
\sigma_y \\
\sigma_z \\
\sigma_{xy} \\
\sigma_{yz} \\
\sigma_{xz}
\end{bmatrix} = \frac{E}{(1 + \nu)(1 - 2\nu)}\begin{bmatrix}
1 - \nu & \nu & 0 & 0 & 0 \\
\nu & 1 - \nu & \nu & 0 & 0 \\
\nu & \nu & 1 - \nu & 0 & 0 \\
0 & 0 & 0 & \frac{1 - 2\nu}{2} & 0 \\
0 & 0 & 0 & 0 & \frac{1 - 2\nu}{2} \\
0 & 0 & 0 & 0 & 0
\end{bmatrix}\begin{bmatrix}
\varepsilon_x - \alpha(T - T_{\text{ref}}) \\
\varepsilon_y - \alpha(T - T_{\text{ref}}) \\
\varepsilon_z - \alpha(T - T_{\text{ref}}) \\
\varepsilon_{xy} \\
\varepsilon_{yz} \\
\varepsilon_{xz}
\end{bmatrix}
\]  

(2-11)
where $T$ is the strain temperature, $T_{\text{ref}}$ is the stress-free reference temperature, and $\alpha$ is the thermal expansion coefficient.

The heat balance equation is

$$ T \frac{\partial S}{\partial t} - \nabla \cdot (k \nabla T) = 0 \quad (2-12) $$

where $k$ is the thermal conductivity. For a linear thermoelastic solid, the entropy per unit volume is:

$$ S = \rho C_P \log \left( \frac{T}{T_0} \right) + S_{\text{elast}} \quad (2-13) $$

where $T_0$ is the reference temperature, the volumetric heat capacity $\rho C_P$ is assumed independent of the temperature, and

$$ S_{\text{elast}} = \alpha_{\text{vec}} \cdot \sigma \quad (2-14) $$

where $\sigma$ is the stress vector, and $\alpha_{\text{vec}}$ is the thermal expansion vector. For an isotropic material, Equation 2-14 simplifies into

$$ S_{\text{elast}} = \alpha (\sigma_x + \sigma_y + \sigma_z) \quad (2-15) $$

For small deformations and small variation of the temperature, Equation 2-12 is linearized as:

$$ \rho C_P \frac{\partial T}{\partial t} + T_0 \frac{\partial}{\partial t} S_{\text{elast}} - \nabla \cdot (k \nabla T) = 0 \quad (2-16) $$

Finally, the frequency decomposition for the temperature is performed

$$ T = T(x_i) \exp(j\omega t) \quad (2-17) $$

where $j\omega = -\lambda$ is the complex angular frequency. Equation 2-16 gives

$$ -\nabla \cdot (k \nabla T) = Q_{\text{heat}} \quad (2-18) $$

where the heat source term is

$$ Q_{\text{heat}} = -j\omega (\rho C_P T + T_0 S_{\text{elast}}) \quad (2-19) $$

You model the problem with the damped eigenfrequency analysis for the beam, which is coupled with the thermal problem Equation 2-18.
In the eigenfrequency analysis, you use the temperature computer from Equation 2-18 as the strain temperature and set the strain reference temperature to zero, $T_{ref}=0$. This is because the solution physically corresponds to thermoelastic oscillations of small amplitude—it is initialized to zero. However, $T_0$ in Equation 2-16 and Equation 2-19 is the actual temperature of the beam at rest.

**Results and Discussion**

Figure 2-23 and Figure 2-24 show the eigenmodes and temperature distribution corresponding to the found eigenvalue. Solved natural frequencies and Q values are given in Table 2-5. Reference data, one calculated with Equation 2-6 to Equation 2-8 and the others from measurements (see Ref. 1), are also given.

<table>
<thead>
<tr>
<th>SOURCE</th>
<th>$f_0$ (MHz)</th>
<th>Q</th>
</tr>
</thead>
<tbody>
<tr>
<td>3D model</td>
<td>0.63 MHz</td>
<td>9151</td>
</tr>
<tr>
<td>2D model</td>
<td>0.63 MHz</td>
<td>10,170</td>
</tr>
<tr>
<td>Equation</td>
<td>0.63 MHz</td>
<td>10,260</td>
</tr>
<tr>
<td>Measurements (Ref. 1)</td>
<td>0.57 MHz</td>
<td>10,281</td>
</tr>
</tbody>
</table>

The Q value given by the 3D model appear to be roughly 10% smaller than the other estimates. One reason for this difference comes from the simplifying assumption that concerns both the Zener’s equation (Equation 2-6) and the plane stress method. For example, the plane stress method assumes that the structure is very thin and that there are no stresses perpendicular to the plane. However, looking at the 3D model in more detail, you find that stresses and their spatial derivatives have components of equal magnitude in all three dimensions. The model also assumes that the beam was perfectly fixed at its ends. Physically, this cannot happen, and allowing more loose contact lowers the natural frequency and improves the Q value.

One factor that also affects the simulated Q values is the boundary condition for the thermal equation. This example uses thermal insulation on all boundaries, but you can assume that there is a flux of heat at least from both ends of the beam. If you simply assign a constant temperature ($T=0$) to the beam ends, the Q value improves considerably. The physically correct result should be somewhere between these two estimates.

A look at Figure 2-23 and Figure 2-24 shows a temperature distribution that appears to agree with the theory: the temperature is higher near the compressive strain and lower near the tensile strain.
Note, however, that you should not take the displayed temperature range (−4 K to 4 K) literally because the software normalizes the solution from the eigenfrequency solver.

*Figure 2-23: First eigenmode and temperature distribution of the 3D model.*
Figure 2-24: First eigenmode and temperature distribution of the 2D model.

Modeling in COMSOL Multiphysics

To create a model of thermoelastic damping with COMSOL Multiphysics requires two application modes. For the 3D model, use the Solid, Stress-Strain application mode from the MEMS Module and the steady-state Conduction application mode from the base package. In 2D, use the Plane Stress application mode from the MEMS Module with the same Conduction application mode as in 3D.

In this example you guide the eigenfrequency solver to find the eigenfrequency near the expected natural frequency (Equation 2.7). Alternatively, you can first solve the undamped eigenfrequency $f_0$ (select Eigenfrequency analysis in the Solver Parameters dialog box and solve only for the structural application mode). This approach is also valid for more complex geometries where you do not have an analytical expression for the estimated natural frequency.

This model, which consists of 2nd-order (structural) and 1st-order (thermal) eigenvalue problems, is numerically quite challenging. You can improve the results’ accuracy by manually scaling the dependent variables. This is an approach that you can use more generally. Once you know the magnitudes of the dependent variables, go to
the **Advanced** page in the **Solver Parameters** dialog box and define manual scaling of the dependent variables.

For the 3D problem you can utilize its symmetry. The beam is truncated to 10 μm in the width direction. Thus you get a smaller mesh size, but it also makes the problem easier to solve because the symmetry condition also prevents any flexural vibrations in this direction.

This example uses both rectangular and brick meshes. In 2D, first draw the geometry and use a mapped mesh to mesh it. In 3D, you utilize work planes by drawing a 2D view of the beam into the work plane. Then mesh it using the mapped mesh, and finally, a mesh extrusion creates the true 3D geometry.

In the damped eigenfrequency analysis, the resonator’s quality factor $Q$ is available as a predefined variable $Q_{fastor}$. In the 3D analysis, you can use a predefined variable $\text{Ent}$ for the elastic part of the entropy $S_{elast}$. Use the explicit expression given in Equation 2-19 for the 2D problem.

**References**


**Model Library path:** MEMS_Module/Actuator_Models/thermoelastic_damping_2d

**Model Library path:** MEMS_Module/Actuator_Models/thermoelastic_damping_3d
Modeling Using the Graphical User Interface—3D Example

**Model Navigator**

1. In the Model Navigator select **3D** in the **Space dimension** list.

2. Click **Multiphysics**.

3. From the list of application modes, select **MEMS Module>Structural Mechanics> Solid, Stress-Strain>Damped eigenfrequency analysis**.

4. Click **Add**.

5. From the list of application modes select **COMSOL Multiphysics>Heat Transfer>Conduction>Steady-state analysis**.

6. Click **Add**.

7. Click **OK**.

**Options and Settings**

Select **Options>Constants** and enter constants from the following table; when finished, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>E</td>
<td>157[GPa]</td>
<td>Young’s modulus</td>
</tr>
<tr>
<td>rho</td>
<td>2330[kg/m^3]</td>
<td>Density</td>
</tr>
<tr>
<td>nu</td>
<td>0.3</td>
<td>Poisson’s ratio</td>
</tr>
<tr>
<td>alpha</td>
<td>2.6e-6[1/K]</td>
<td>Thermal expansion coefficient</td>
</tr>
<tr>
<td>Cp</td>
<td>700[J/(kg*K)]</td>
<td>Specific heat capacity</td>
</tr>
<tr>
<td>k</td>
<td>90[W/(m*K)]</td>
<td>Thermal conductivity</td>
</tr>
<tr>
<td>T0</td>
<td>300[K]</td>
<td>Ambient and initial beam temperature</td>
</tr>
<tr>
<td>f0</td>
<td>4.730^2<em>sqrt(E/(rho</em>12))<em>12[um]/(2</em>pi*(400[um])^2)</td>
<td>Theoretical estimate for the natural frequency</td>
</tr>
</tbody>
</table>

The constant f0 serves as an initial guess for the eigenfrequency solver.

**Geometry Modeling**

1. Select **Draw>Work-Plane Settings**.

2. On the **Quick** page select the **z-x** check box.

3. Click **OK**. The 2D work plane becomes active.

4. Shift-click the **Rectangle/Square** button on the Draw toolbar.
CHAPTER 2: MEMS ACTUATOR MODELS

In the Width edit field type $12 \times 10^{-6}$, and in the Height edit field type $400 \times 10^{-6}$.

Click OK, then click the Zoom Extents button on the Main toolbar.

MESH GENERATION

1 In the work plane select Mesh>Mapped Mesh Parameters.
2 In the Subdomain page select the first subdomain and click the Boundary tab.
3 Select Boundary 1.
4 Select the Constrained edge element distribution check box, then enter 25 in the Number of edge elements edit field.
5 Select Boundary 2.
6 Select the Constrained edge element distribution check box, then enter 4 in the Number of edge elements edit field.
7 Click Remesh, then click OK.
8 Select Mesh>Extrude Mesh.
9 In the Distance edit field type $10 \times 10^{-6}$.
10 Change to the Mesh page
11 In the Number of element layers edit field type 2.
12 Click OK.

The 3D geometry should open automatically.

PHYSICS SETTINGS

Subdomain Settings

1 From the Multiphysics menu select 1 Geom1: Solid, Stress-Strain (smsld).
2 Select Physics>Subdomain Settings.
3 Select Subdomain 1, and in the Material page enter settings according to the following table:

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>E</td>
<td>E</td>
</tr>
<tr>
<td>ν</td>
<td>νu</td>
</tr>
<tr>
<td>α</td>
<td>alpha</td>
</tr>
<tr>
<td>ρ</td>
<td>rho</td>
</tr>
</tbody>
</table>
4 Click the Load tab.
5. Select **Include thermal expansion** and type T for **Temp** and 0 for **Tempref**.

6. Change to the **Damping** page.

7. From the **Damping model** list select **No damping**.

8. Click **OK**.

9. From the **Multiphysics** menu select **2 Geom1: Heat Transfer by Conduction (ht)**.

10. Select **Physics>Subdomain Settings**.

11. See that Subdomain 1 is selected and in the **Material** page enter settings from the following table:

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>k (isotropic)</td>
<td>k</td>
</tr>
<tr>
<td>Q</td>
<td>-j<em>omega_smsld</em>(rho<em>Cp</em>T+T0*Ent_smsld)</td>
</tr>
</tbody>
</table>

12. Click **OK**.

**Boundary Conditions**

1. From the **Multiphysics** menu, select **1 Geom1: Solid, Stress-Strain (smsld)**.

2. Select **Physics>Boundary Settings**.

3. Select Boundaries 1 and 6.

4. On the **Constraint** page, set **Constraint condition** to **Fixed**.

5. Select Boundary 2.

6. Set **Constraint condition** list to **Symmetry plane**.

7. Click **OK**.

8. From the **Multiphysics** menu, select **2 Geom1: Heat Transfer by Conduction (ht)**.

9. Select **Physics>Boundary Settings**.

10. Verify that **Thermal insulation** is the default value.

11. Click **OK**.

**Computing the Solution**

1. Choose **Solve>Solver Parameters**.

2. Go to the **General** page.

3. Type 1 for **Desired number of eigenfrequencies**.

4. Type f0 for **Search for eigenfrequencies around**.

5. Go to the **Advanced** page.

6. Locate the **Scaling of variables** area and choose **Manual** for **Type of scaling**.
7 In the Manual scaling edit field, type \( u \times 10^{-4} \ v \times 10^{-4} \ w \times 10^{-4} \ T \ 1 \). Click OK.

8 Click the Solve button on the Main toolbar.

The solver finds a solution with an eigenfrequency of approximately \( 63,394 \) Hz.

**POSTPROCESSING AND VISUALIZATION**

To generate the plot in Figure 2-23 follow these steps:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General Page verify that the Boundary, Deformed shape, and Geometry edges check boxes are selected and that all others are cleared.

3 Go to the Boundary page and select Heat Transfer by Conduction (ht)>Temperature from the Predefined quantities list.

4 Click OK.

You can see the eigenfrequency in the postprocessing plot. Use the Global Data Display dialog box to calculate the Q value:

1 Choose Postprocessing>Data Display>Global.

2 In the Expression edit field, type Qfactor_smsld.

3 Click Apply. You find the Q value in the message log.

**Modeling Using the Graphical User Interface—2D Example**

Start the model in the Model Navigator.

1 In the Model Navigator select 2D.

2 Click Multiphysics.

3 From the list of application modes select MEMS Module>Structural Mechanics>Plane Stress>Damped eigenfrequency analysis.

4 Click Add.

5 From the list of application modes select COMSOL Multiphysics>Heat Transfer>Conduction>Steady-state analysis.

6 Click Add, then click OK.
OPTIONS AND SETTINGS
Choose Options>Constants and enter constants from the following table:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>E</td>
<td>157[GPa]</td>
<td>Young’s modulus</td>
</tr>
<tr>
<td>rho</td>
<td>2330[kg/m^3]</td>
<td>Density</td>
</tr>
<tr>
<td>nu</td>
<td>0.3</td>
<td>Poisson’s ratio</td>
</tr>
<tr>
<td>alpha</td>
<td>2.6e-6[1/K]</td>
<td>Thermal expansion coefficient</td>
</tr>
<tr>
<td>Cp</td>
<td>700[J/(kg*K)]</td>
<td>Specific heat capacity</td>
</tr>
<tr>
<td>k</td>
<td>90[W/(m*K)]</td>
<td>Thermal conductivity</td>
</tr>
<tr>
<td>T0</td>
<td>300[K]</td>
<td>Ambient and initial beam temperature</td>
</tr>
<tr>
<td>f0</td>
<td>(4.730^2\times\sqrt{E/(\rho\times12)}\times\frac{12[\text{um}]}{(2\pi\times(400[\text{um}])^2)})</td>
<td>Theoretical estimate for the natural frequency</td>
</tr>
</tbody>
</table>

The constant \(f_0\) serves as an initial guess for the eigenfrequency solver.

GEOMETRY MODELING
1 Shift-click the Rectangle/Square button on the Draw toolbar.
2 In the Width edit field type 400e-6, and in the Height edit field type 12e-6.
3 Click OK, then click the Zoom Extents button on the Main toolbar.

MESH GENERATION
1 In the work plane select Mesh>Mapped Mesh Parameters.
2 On the Subdomain page, select Subdomain 1.
3 Click the Boundary tab. Select Boundary 1.
4 Select the Constrained edge element distribution check box, then type 5 in the Number of edge elements edit field.
5 Select Boundary 2.
6 Select the Constrained edge element distribution check box, then type 25 in the Number of edge elements edit field.
7 Click Remesh, then click OK.

PHYSICS SETTINGS
Subdomain Settings—Plane Stress
1 From the Multiphysics menu, select Plane Stress (smens).
2 Choose Physics>Subdomain Settings.
3 Select Subdomain 1. On the **Material** page, enter the following settings:

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>E</td>
<td>E</td>
</tr>
<tr>
<td>ν</td>
<td>nu</td>
</tr>
<tr>
<td>α</td>
<td>alpha</td>
</tr>
<tr>
<td>ρ</td>
<td>rho</td>
</tr>
<tr>
<td>thickness</td>
<td>20e-6</td>
</tr>
</tbody>
</table>

4 Click the **Load** tab.

5 Select the **Include thermal expansion** check box. Enter T for **Temp** and 0 for **Tempref**.

6 Change to the **Damping** page.

7 From the **Damping model** list, select **No damping**, then click **OK**.

**Subdomain Settings—Heat Transfer by Conduction**

1 From the **Multiphysics** menu, select **2 Heat Transfer by Conduction (ht)**.

2 Choose **Physics>Subdomain Settings**.

3 Verify that Subdomain 1 is selected, then on the **Physics** page enter settings according to the following table; when finished, click **OK**.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>k (isotropic)</td>
<td>k</td>
</tr>
<tr>
<td>Q</td>
<td>-jomega_sm* (rho<em>Cp</em>T+T0*Ent_sm)</td>
</tr>
</tbody>
</table>

**Boundary Conditions—Plane Stress**

1 From the **Multiphysics** menu, select **1 Plane Stress (smps)**.

2 Choose **Physics>Boundary Settings**. Select Boundaries 1 and 4.

3 On the **Constraint** page, set **Constraint condition** to **Fixed**, then click **OK**.

**Boundary Conditions—Heat Transfer by Conduction**

1 From the **Multiphysics** menu, select **2 Heat Transfer by Conduction (ht)**.

2 Choose **Physics>Boundary Settings**.

3 Verify that **Thermal insulation** is the default value, then click **OK**.

**Computing the Solution**

1 Choose **Solve>Solver Parameters**.

2 On the **General** page, enter 1 for **Desired number of eigenfrequencies**.
3 Enter \( f_0 \) for Search for eigenfrequencies around.

4 Go to the Advanced page.

5 Locate the Scaling of variables area and choose Manual for Type of scaling.

6 In the Manual scaling edit field, type \( 1e^{-4} v \), \( 1e^{-4} T \), and click OK.

7 Click the Solve button on the Main toolbar.

The solver finds a solution with an eigenfrequency of approximately \( 63,045 \text{ Hz} \).

**POSTPROCESSING AND VISUALIZATION**

To generate the plot in Figure 2-24 follow the steps below:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, verify that the Boundary, Deformed shape, and Geometry edges check boxes are selected, and that all others are cleared.

3 On the Surface page, select Heat Transfer by Conduction (ht)>Temperature from the Predefined quantities list. Click OK.

You can see the eigenfrequency in the postprocessing plot. Use the Global Data Display dialog box to calculate the Q value:

1 Select Postprocessing>Data Display>Global.

2 In the Expression edit field type Qfactor_smPBS.

3 Click Apply. The Q value appears in the message log below the drawing area.
MEMS Sensor Models

This chapter highlights models that describe different types of sensors in MEMS devices. The accelerometer example shows modeling in both 2D and 3D. An example of a pressure sensor describes a device that measures static pressures in the range from zero up to atmospheric pressure. Another model uses the Material Library to simulate thermal expansion in a MEMS device that could be part of a microgyroscope.
Squeezed-Film Gas Damping in an Accelerometer

Micromechanical structures that use capacitance to measure another parameter such as acceleration typically have a very narrow gap between their electrodes. The gap usually contains gas, which damps the movements of the mechanical parts. This model of a microsystem accelerometer shows how to couple squeezed-film gas damping, which you model with the linearized Reynolds equation, to displacements in the sensor.

Introduction

Squeezed-film gas damping is a critical aspect of many MEMS transducers and actuators. An example of a microsystem component where gas-damping properties are important is the accelerometer common in vehicle motion-control and safety systems.

In accelerometers, inertia produces a motion that the device detects. A typical structure connects a large proof mass, with dimensions typically in millimeters, to surrounding structures with elastic beams. This combination forms a mechanical oscillator with a specific resonance frequency. However, in accurate motion-detection applications these resonances are unwanted, and the device damps the movements to produce smooth time-step and frequency responses. Such a device can usually achieve suitable damping with a low gas pressure (100 Pa–1000 Pa) which, considering the dimensions of the device, lead to rarefied gas effect in the system.

A narrow gap formed by two solid horizontal plates restricts the displacement of the gas perpendicular to the surfaces. When the sensor squeezes the gap, the gas flows out from its edges. The narrow pathway restricts the flow, which causes gas pressure to increase, which decelerates the plates’ movement.

You can model the pressure distribution in the narrow gap with the modified Reynolds equation

\[ \nabla \cdot (h^3 Q_{ch} p \nabla p_F) = 12 \eta \left( \frac{dp_F}{dt} h + p \frac{dh}{dt} \right) \]

where \( p_F \) denotes the gas film pressure variation, \( p = p_A + p_F \) is the total fluid pressure consisting of the initial/ambient pressure and the variation, \( h = h_0 + \Delta h \) is the gap height consisting of the initial gap and the deformation in the normal direction of the
boundary, and \( \eta \) is the fluid viscosity at normal conditions. The term \( Q_{ch} \) denotes the relative flow rate function that accounts for the rarefied gas effects. Veijola and others (Ref. 2) have used a simple equation for the relative flow coefficient

\[
Q_{ch} = 1 + 9.638(\sigma_P K_n)^{1.159}
\]

which is valid for \( 0 \leq K_n \leq 880 \). The Knudsen number is the ratio between the gas’ mean free path, \( \lambda \), and the gap height, \( h \):

\[
K_n = \frac{\lambda}{h}
\]

The coefficient \( \sigma_P \) is calculated from the tangential momentum accommodation coefficient, \( \alpha_v \):

\[
\sigma_P = \frac{2 - \alpha_v}{\alpha_v}(1.016 - 0.1211(1 - \alpha_v)).
\]

The mean free path at a pressure \( p \) comes from

\[
\lambda = \frac{p_0 \lambda_0}{p}
\]

where \( \lambda_0 \) is the mean free path at the reference pressure \( p_0 \).

Another way to tune the damping is to perforate the structure with holes. By adding a term related to the gas flow through the holes, it is also possible to use the Reynolds equation for perforated plates. For more information about this approach see Ref. 3.

Model Definition

This example models the solid moving parts in the accelerometer using the Solid, Stress-Strain application mode in 3D and using the Plane Strain application mode in 2D. This model solves the squeezed-film air damping on the lower and upper surfaces using the Film Damping application mode. The model constrains the film pressure, \( p_F \), to 0 at the edges of the boundary.

The following two figures show the accelerometer geometry in 3D and in 2D. The model consists of two thin silicon cantilever beams and a silicon proof mass. The cantilever beams are fixed to the surrounding structures at one end. The proof mass reacts to inertial forces and bends the cantilevers. The external acceleration, \( a \), acts in the \( z \) direction and causes a body volume force \( F_z = p_{\text{solid}}a \).
In 2D the two cantilevers are lumped as one structure whose thickness equals the sum of the two cantilevers. Consequently, the model has two domains with different thicknesses at the connecting boundary. Thus you should be prudent when inspecting stress levels near this area.

*Model geometry in 3D.*

*Model geometry in 2D.*
The following tables list the structures’ dimensions as well as pertinent material and gas properties used to calculate the effective viscosity:

<table>
<thead>
<tr>
<th>PARAMETER</th>
<th>CANTILEVERS</th>
<th>PROOF MASS</th>
<th>GAP</th>
</tr>
</thead>
<tbody>
<tr>
<td>Length</td>
<td>520 µm</td>
<td>1780 µm</td>
<td>1780 µm</td>
</tr>
<tr>
<td>Height</td>
<td>40 µm</td>
<td>400 µm</td>
<td>3.95 µm</td>
</tr>
<tr>
<td>Width</td>
<td>100 µm</td>
<td>2960 µm</td>
<td>2960 µm</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>PARAMETER</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Structure material</td>
<td>Silicon</td>
</tr>
<tr>
<td>Young’s modulus</td>
<td>131 GPa</td>
</tr>
<tr>
<td>Poisson’s ratio</td>
<td>0.27</td>
</tr>
<tr>
<td>Density</td>
<td>2330 kg/m$^3$</td>
</tr>
<tr>
<td>Viscosity of the gas</td>
<td>$2.26 \times 10^{-6}$ Ns/m$^2$</td>
</tr>
<tr>
<td>$\lambda_0$</td>
<td>70 nm</td>
</tr>
<tr>
<td>$\rho_0$</td>
<td>101.325 kPa</td>
</tr>
</tbody>
</table>

Results and Discussion

Figure 3-1 shows the pressure distribution on the surface of the proof mass after 4 ms of simulation. The ambient pressure, $p_A$, in this case is 300 Pa, and the acceleration switches on at the beginning of the simulation. The acceleration’s magnitude is half that due to gravity, $g$. In this figure, the maximum displacement at the tip of the proof mass is roughly 0.4 µm, or 0.1% of its thickness.

Figure 3-2 shows the total displacement of the proof mass tip as a function of time for ambient pressures of 3 Pa, 30 Pa, and 300 Pa. As ambient pressure increases, the film damping at the upper and lower surfaces increases through the increase in the gas’ effective viscosity and density. This increased damping results in a substantial decrease in oscillation with increasing pressure. At 300 Pa, there is no apparent oscillations, and the proof mass seems asymptotically to reach the value of 0.2 µm in total displacement.
Figure 3-1: A load on the face of the proof mass in the z direction leads to a deformation.

Figure 3-2: Plot of the displacement of the proof mass tip at ambient pressures of 3 Pa (dashed line), 30 Pa (dashed-dotted line), and 300 Pa (solid line).
References


Modeling Using the Graphical User Interface (2D)

Model Library path: MEMS_Module/Sensor_Models/squeezed_film_accelerometer_2d

Use the following instructions to create the 2D version of the accelerometer model.

MODEL NAVIGATOR

1. Open the Model Navigator.

2. From the Space dimension list, select 2D.

3. From the Application Modes tree, select MEMS Module>Structural Mechanics>Plane Strain with Film Damping>Transient analysis.

4. Click OK.

OPTIONS AND SETTINGS

1. From the Options menu, choose Constants.

2. In the Constants dialog box, enter names, expressions, and descriptions (optional) for the following constants; when done click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>a</td>
<td>9.81[m/s^2]/2</td>
<td>Applied acceleration</td>
</tr>
<tr>
<td>p_A</td>
<td>300[Pa]</td>
<td>Ambient gas pressure</td>
</tr>
</tbody>
</table>
**GEOMETRY MODELING**

1. Open the Rectangle dialog box either by Shift-clicking the Rectangle/Square button on the Draw toolbar or by going to the Draw menu and choosing Specify Objects>Rectangle. Specify a rectangle R1 using the data in the following table; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>POSITION</th>
<th>X</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>1780e-6</td>
<td>400e-6</td>
<td>Corner</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>R2</td>
<td>520e-6</td>
<td>40e-6</td>
<td>Corner</td>
<td>-520e-6</td>
<td>180e-6</td>
</tr>
</tbody>
</table>

2. Repeat the previous step to create the rectangle R2.

3. Click the Zoom Extents button on the Main toolbar.

**PHYSICS SETTINGS**

*Subdomain Settings*

1. From the Multiphysics menu, choose the Plane Strain (smpn) application mode.

2. From the Physics menu, choose Subdomain Settings.

3. In the Subdomain Settings dialog box, enter the following settings:

<table>
<thead>
<tr>
<th>QUANTITY</th>
<th>VALUE IN SUBDOMAIN</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>MATERIAL PAGE</td>
<td>Silicon</td>
<td>Click the Load button, go to Materials&gt;Basic Material Properties, and select Silicon.</td>
</tr>
<tr>
<td>E</td>
<td>131e9[Pa]</td>
<td>Young's modulus</td>
</tr>
<tr>
<td>ν</td>
<td>0.27</td>
<td>Poisson's ratio</td>
</tr>
<tr>
<td>α</td>
<td>4.15e-6[1/K]</td>
<td>Coefficient of thermal expansion</td>
</tr>
<tr>
<td>ρ</td>
<td>2330[kg/m^3]</td>
<td>Density</td>
</tr>
<tr>
<td>thickness</td>
<td>200e-6</td>
<td>2960e-6</td>
</tr>
<tr>
<td>LOAD PAGE</td>
<td>F_x</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td>F_y</td>
<td>-rho_smpn*a</td>
</tr>
<tr>
<td>DAMPING PAGE</td>
<td>Damping model</td>
<td>No damping</td>
</tr>
</tbody>
</table>
4 While still on the Load page, click the **Body load is defined as force/volume using the thickness** option button for both subdomains.

5 Click **OK**.

**Boundary Conditions**

1 From the **Physics** menu, choose **Boundary Settings**.

2 Select Boundary 1, and on the **Constraint** page select **Fixed** from the **Constraint condition** list.

3 Click the **Groups** tab. In the **Name** edit field (under the **Group selection** list) type **Fixed**, then press Enter.

4 Click the **Boundaries** tab.

5 Select Boundaries 5 and 8. From the **Group** list, select **Film damping** (click the **Load** tab to see the predefined loads)

6 Click **OK**.

7 From the **Multiphysics** menu, choose the **Film Damping (mmfd)** application mode.

8 From the **Physics** menu, choose **Boundary Settings**.

9 Select Boundaries 5 and 8, then select **Film damping** from the **Group** list.

10 On the **Settings** page, enter the following boundary settings (some of them are correct initially); when done, click **OK**.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 5, 8</th>
</tr>
</thead>
<tbody>
<tr>
<td>dx, dy</td>
<td>u, v</td>
</tr>
<tr>
<td>h₀</td>
<td>3.95e⁻⁶</td>
</tr>
<tr>
<td>Pₐ</td>
<td>pₐ</td>
</tr>
<tr>
<td>λ₀</td>
<td>70e⁻⁹</td>
</tr>
<tr>
<td>Pₐ, 0</td>
<td>101325</td>
</tr>
<tr>
<td>η</td>
<td>22.6e⁻⁶</td>
</tr>
<tr>
<td>αᵥ</td>
<td>1</td>
</tr>
<tr>
<td>Qₙₜ</td>
<td>Model 1</td>
</tr>
<tr>
<td>Use perforation effects</td>
<td>No</td>
</tr>
</tbody>
</table>

**Point Settings**

The default point setting, which sets the film pressure to zero, is sufficient for this model.
COUPLING VARIABLES
To observe the total damping force, create two integration coupling variables with these steps:

1. From the Options menu, select Integration Coupling Variables>Boundary Variables.
2. In the dialog that opens define coupling variables according to the following table (each variable on a separate row); when done, click OK.

<table>
<thead>
<tr>
<th>BOUNDARY</th>
<th>NAME</th>
<th>EXPRESSION</th>
<th>INTEGRATION ORDER</th>
<th>GLOBAL DESTINATION</th>
</tr>
</thead>
<tbody>
<tr>
<td>5</td>
<td>force_bot</td>
<td>-ny<em>pf</em>thickness_smpn</td>
<td>4</td>
<td>yes</td>
</tr>
<tr>
<td>8</td>
<td>force_top</td>
<td>-ny<em>pf</em>thickness_smpn</td>
<td>4</td>
<td>yes</td>
</tr>
</tbody>
</table>

MESH GENERATION
1. From the Mesh menu, select Free Mesh Parameters.
2. Keep the Predefined mesh sizes selection Normal, then click the Custom mesh size button.
3. Set the Resolution of narrow regions to 2.
4. Click Remesh, then click OK.

COMPUTING THE SOLUTION
1. From the Solve menu, choose Solver Parameters.
2. Keep the time-dependent analysis and solver, and make the following changes in the Solver Parameters dialog box; when done, click OK.

<table>
<thead>
<tr>
<th>PARAMETER</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Analysis</td>
<td>Time dependent</td>
</tr>
<tr>
<td>Auto select solver</td>
<td>yes</td>
</tr>
<tr>
<td>GENERAL PAGE</td>
<td></td>
</tr>
<tr>
<td>Times</td>
<td>0:1e-5:4e-3</td>
</tr>
<tr>
<td>Absolute tolerance</td>
<td>u 1e-10 v 1e-10 pf 1e-2</td>
</tr>
<tr>
<td>TIME STEPPING PAGE</td>
<td></td>
</tr>
<tr>
<td>Time steps taken by the solver</td>
<td>Intermediate</td>
</tr>
</tbody>
</table>

3. Click the Solve button on the Main toolbar to start the analysis.

POSTPROCESSING AND VISUALIZATION
1. From the Postprocessing menu, choose Plot Parameters.
2 On the **General** page, select the **Arrow** and **Deformed shape** check boxes.

3 Click the **Surface** tab.

4 In the **Surface data** area, choose **Plane Strain (smpn)>Total displacement** from the **Predefined quantities** list.

5 Click the **Arrow** tab.

6 From the **Plot arrows on** list, select **Boundaries**. On the **Boundary Data** page, select **Film Damping (mmfd)>Pressure load** from the **Predefined quantities** list.

7 Click **OK**.

8 From the **Postprocessing** menu, choose **Domain Plot Parameters**.

9 Click the **Point** tab. Select Point 7.

10 From the **Predefined quantities** list, select **Plane Strain (smpn)>y-displacement**.

11 Click **Apply**.

12 In the **Expression** edit field, type `force_bot`.

13 Click **OK**.

If you want to compare the step responses in the same figure window for different pressures, open the **Constants** dialog box and change the value of `p A` to 3\([\text{Pa}]\) or 300\([\text{Pa}]\). Then click the **Solve** button again, and when the solution is ready, open the **Domain Plot Parameters** dialog box. Go to the **General** page and select the **Keep current plot** check box. Following this procedure plots both step responses in the same graph when you click **OK** or **Apply**.

You might also want to animate the step response. To do so:

1 Open the **Plot Parameters** dialog box and click the **Animate** tab.

2 Select **AVI** or **QuickTime** from the **File type** list.

3 Click the **Start Animation** button.

---

**Modeling Using the Graphical User Interface (3D)**

---

**Model Library path:** `MEMS_Module/Sensor_Models/squeezed_film_accelerometer_3d`

---

Use the following instructions to create the 3D version of the accelerometer model.
MODEL NAVIGATOR
1 Open the Model Navigator and select 3D from the Space dimension list.
2 Select the application mode MEMS Module>Structural Mechanics>Solid, Stress-Strain with Film Damping>Transient analysis.
3 Click OK.

OPTIONS AND SETTINGS
1 From the Options menu select Constants.
2 In the Constants dialog box enter these variable names, expressions, and descriptions (optional); when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>a</td>
<td>9.81[m/s^2]/2</td>
<td>Applied acceleration</td>
</tr>
<tr>
<td>p_A</td>
<td>300[Pa]</td>
<td>Ambient gas pressure</td>
</tr>
</tbody>
</table>

GEOMETRY MODELING
1 Open the Block dialog box; to do so either go to the Draw menu and choose Block, or Shift-click the Block button on the Draw toolbar on the left side of the user interface.
2 Create these three solid blocks:

<table>
<thead>
<tr>
<th>NAME</th>
<th>LENGTH</th>
<th>AXIS BASE POINT</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>X</td>
<td>Y</td>
</tr>
<tr>
<td></td>
<td>X</td>
<td>Y</td>
</tr>
<tr>
<td>BLK1</td>
<td>1780e-6</td>
<td>2960e-6</td>
</tr>
<tr>
<td>BLK2</td>
<td>520e-6</td>
<td>100e-6</td>
</tr>
<tr>
<td>BLK3</td>
<td>520e-6</td>
<td>100e-6</td>
</tr>
</tbody>
</table>
3 Click the Zoom Extents button.

PHYSICS SETTINGS
Subdomain Settings
1 From the Multiphysics menu, select the Solid, Stress-Strain (smsld) application mode.
2 From the Physics menu, select Subdomain Settings.
3 Enter the following subdomain settings; when done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAINS 1-3</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>MATERIAL PAGE</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Library material</td>
<td>Silicon</td>
<td>Click the Load button, go to Materials&gt;Basic Material Properties and select Silicon</td>
</tr>
<tr>
<td>E</td>
<td>131e9 [N/m²]</td>
<td>Young's modulus</td>
</tr>
<tr>
<td>ν</td>
<td>0.27</td>
<td>Poisson’s ratio</td>
</tr>
<tr>
<td>α</td>
<td>4.15e-6 [1/K]</td>
<td>Coefficient of thermal expansion</td>
</tr>
<tr>
<td>ρ</td>
<td>2330 [kg/m³]</td>
<td>Density</td>
</tr>
<tr>
<td><strong>LOAD PAGE</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Coordinate system</td>
<td>Global coordinate system</td>
<td></td>
</tr>
<tr>
<td>Fₓ</td>
<td>0</td>
<td>Body load (force/volume) x dir.</td>
</tr>
<tr>
<td>Fᵧ</td>
<td>0</td>
<td>Body load (force/volume) y dir.</td>
</tr>
<tr>
<td>Fᵢ</td>
<td>-rho_smsld*a</td>
<td>Body load (force/volume) z dir.</td>
</tr>
<tr>
<td><strong>DAMPING PAGE</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Damping model</td>
<td>No damping</td>
<td></td>
</tr>
</tbody>
</table>

**Boundary Conditions**

1 From the Physics menu, select Boundary Settings.
2 Select Boundaries 1 and 6.
3 On the Constraint page, select Fixed from the Constraint condition list.
4 Click the Group tab. Type Fixed in the Name edit field, then press Enter.
5 Click the Boundaries tab.
6 Select Boundaries 13 and 14, and from the Group list select Film damping; notice the predefined load on the Load page. Click OK.
7 From the Multiphysics menu, select the Film Damping (mmfd) application mode.
8 From the Physics menu, select Boundary Settings.
9 Select Boundaries 13 and 14.
10 In the Group list select Film damping, then enter the settings from the following table (some are correct by default); when done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 13, 14</th>
</tr>
</thead>
<tbody>
<tr>
<td>dx, dy, dz</td>
<td>u v w</td>
</tr>
<tr>
<td>h₀</td>
<td>3.95e-6</td>
</tr>
<tr>
<td>p₀</td>
<td>p_A</td>
</tr>
</tbody>
</table>
CHAPTER 3: MEMS SENSOR MODELS

Edge Settings

The default edge setting, which sets the film pressure to zero, applies to this model.

COUPLING VARIABLES

To observe the total damping force, create two integration coupling variables according to the following steps.

1. From the Options menu, select Integration Coupling Variables>Boundary Variables.
2. In the dialog box that opens, define coupling variables according to the following tables (one coupling variable per row); when done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 13, 14</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \lambda_0 )</td>
<td>( 70 \cdot 9 )</td>
</tr>
<tr>
<td>( P_{\lambda,0} )</td>
<td>( 101325 )</td>
</tr>
<tr>
<td>( \eta )</td>
<td>( 22.6 \cdot 6 )</td>
</tr>
<tr>
<td>( \alpha_v )</td>
<td>1</td>
</tr>
<tr>
<td>( Q_{ch} )</td>
<td>Model 1</td>
</tr>
<tr>
<td>Use perforation effects</td>
<td>No</td>
</tr>
</tbody>
</table>

Boundary

Edge Settings

The default edge setting, which sets the film pressure to zero, applies to this model.

COUPLING VARIABLES

To observe the total damping force, create two integration coupling variables according to the following steps.

1. From the Options menu, select Integration Coupling Variables>Boundary Variables.
2. In the dialog box that opens, define coupling variables according to the following tables (one coupling variable per row); when done, click OK.

<table>
<thead>
<tr>
<th>BOUNDARY</th>
<th>NAME</th>
<th>EXPRESSION</th>
<th>INTEGRATION ORDER</th>
<th>GLOBAL DESTINATION</th>
</tr>
</thead>
<tbody>
<tr>
<td>13</td>
<td>force_bot</td>
<td>-nz*pf</td>
<td>4</td>
<td>yes</td>
</tr>
<tr>
<td>14</td>
<td>force_top</td>
<td>-nz*pf</td>
<td>4</td>
<td>yes</td>
</tr>
</tbody>
</table>

MESH GENERATION

1. From the Mesh menu, select Free Mesh Parameters.
2. In the Predefined mesh sizes list, choose Fine.
3. Go to the Boundary page.
4. Select Boundaries 15 and 16, then click Mesh Selected.
5. On the Global page, choose Normal from the Predefined mesh sizes list.
6. Click the Subdomain tab. Select Subdomain 3, then click Mesh Selected.
7. Click OK to close the Free Mesh Parameters dialog box.
8. From the Mesh menu, select Swept Mesh Parameters.
9. In the Predefined mesh sizes list, choose Finer.
10. Select Subdomains 1 and 2, then click Mesh Selected.
11. Click OK.
**Computing the Solution**

1. From the Solve menu, select Solver Parameters.
2. Keep the time-dependent analysis and solver, but otherwise make the following changes in the Solver Parameters dialog box; when done, click OK.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Analysis</td>
<td>Time dependent</td>
</tr>
<tr>
<td>Auto select solver</td>
<td>yes</td>
</tr>
</tbody>
</table>

**General Page**

<table>
<thead>
<tr>
<th>Times</th>
<th>0:1e-5:4e-3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Absolute tolerance</td>
<td>u 1e-13 v 1e-13 w 1e-13 pf 1e-2</td>
</tr>
</tbody>
</table>

**Time Stepping Page**

| Time steps taken by the solver | Intermediate |

3. Click the Solve button on the Main toolbar to start the simulation.

**Postprocessing and Visualization**

1. From the Postprocessing menu, select Plot Parameters.
2. In the Plot type area, select the Boundary, Edge, and Deformed plot check boxes, and clear the Slice check box.
3. Click the Boundary tab.
4. In the Boundary data area, choose Solid Stress-Strain (smsld)>Face load in global z dir. from the Predefined quantities list.
5. Click the Edge tab.
6. Click the Uniform color option button, then click the Color button.
7. Select black from the color palette, then click OK.
8. Click OK.

Also plot the z-displacement at the bottom corner and the damping force at the bottom versus time:

1. From the Postprocessing menu, select Domain Plot Parameters.
2. Click the Point tab. Select Point 21.
3. From the Predefined quantities list, select Solid, Stress-Strain (smsld)>z-displacement.
4. Click Apply.
5. In the Expression edit field, type force_bot.
6. Click OK.
If you want to compare the step responses in the same figure for different pressures, go to the Constant dialog box and change the value of \( p \) to \( 3\text{[Pa]} \) or \( 30\text{[Pa]} \); then click the Solve button again. When the solution is ready and you want to plot both step responses in the same graph, open the Domain Plot Parameters dialog box, click the General tab, and select the Keep current plot check box.

You might also want to animate the step response. To do so:

1. Open the Plot Parameters dialog box and click the Animate tab.
2. In the File type list, select your preference of AVI or QuickTime.
3. Click the Start Animation button.
Estimating the Q Factor of a MEMS Gyroscope

A particularly simple type of MEMS gyroscope is a 2-DOF vibrational system with a single proof mass. The complete system with proof mass, support structure, drive and sense units can be fabricated in one piece out of polysilicon. High sensitivity and low power consumption are important design goals. Both are affected by a number of possible dissipative processes where vibrational energy is turned into heat inside the structure or in interaction with its surroundings.

This model focuses on the slide film damping due to air viscosity in the thin air layer between the gyroscope’s proof mass and the substrate. The Q factor obtained from this analysis is therefore an upper bound for the considered design. All other processes contribute to the damping work to further decrease the Q factor. Therefore, if the slide film damping can be assumed to be the dominating dissipative process in the system, optimizing the Q value obtained from this simplified model will be a good starting point for improving the design.

The model is inspired by Ref. 1.

Introduction

The working principle of a vibrational gyroscope is surprisingly simple. A proof mass is suspended above a surface in such a way that its first two vibrational modes are orthogonal and tangential to the surface. If one of the modes, from now on referred to as the drive mode, is excited using for example a comb drive unit, any rotation about an out-of-plane axis will induce Coriolis forces, which transfer energy to the other, orthogonal, mode. This induced excitation of the sense mode can be detected by
measuring capacitance between the proof mass and a pair of sense electrodes. See Figure 3-3.

Figure 3-3: Schematic drawing of one half of a generic 2-DOF gyroscope.

Model Definition

To model the vibration in the drive direction, you only need to include one half of the real structure in the geometry. The symmetry boundary condition on the mirror plane saves computation time and memory but also removes any modes oscillating in the sense direction. Therefore, the coupling between the modes cannot be studied and the sense electrodes are excluded from the model.

To simplify further, the model does not include the details of the comb drive. It is assumed that the drive is working in its region of linear response so that the unit can be replaced by a corresponding driving force. Considering the comb drive to act like a stack of idealized plate capacitors leads to the following expression for the total force acting on the drive assembly (Ref. 1):

\[
F_{cd} = 4 \frac{e_0 \pi d^2 N}{y_0} V_{DC} V_{AC}
\]

(3-1)
Here $\varepsilon_0 = 8.854 \, \text{pF/m}$ is the permittivity of free space, $z_0 = 10 \, \mu\text{m}$ the height of the fingers, $y_0 = 4 \, \mu\text{m}$ the distance between neighboring fingers, $N = 10$ the number of fingers, $V_{DC} = 30 \, \text{V}$ the bias voltage, and finally $V_{AC} = 2 \, \text{V}$ the applied driving voltage.

As mentioned above, all damping processes except slide-film damping between the proof mass and the substrate are excluded from the model. Internal viscous damping in the polysilicon structure can be assumed to be small, as well as thermo-elastic damping in the supporting beams. The slide-film and squeeze-film damping in the comb drives may be considered in a refined model.

This particular gyroscope is intended for use under atmospheric conditions. The $2 \, \mu\text{m}$ thick gas film between the proof mass and the substrate is therefore assumed to contain air at atmospheric pressure. The following parameters are relevant for describing the film behavior under these conditions:

<table>
<thead>
<tr>
<th>SYMBOL</th>
<th>VALUE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>$h_0$</td>
<td>2 $\mu$m</td>
<td>Film thickness</td>
</tr>
<tr>
<td>$p_A$</td>
<td>1 atm</td>
<td>Ambient pressure</td>
</tr>
<tr>
<td>$\lambda_0$</td>
<td>70 nm</td>
<td>Mean free path at 1 atm</td>
</tr>
<tr>
<td>$\eta$</td>
<td>$18 \times 10^{-6}$ Pa$\cdot$s</td>
<td>Dynamic viscosity</td>
</tr>
</tbody>
</table>

The Q factor is a measure of the ratio between stored energy and energy lost per cycle in a free oscillation. Two possible definitions are

$$Q = \frac{2\pi W_0}{\Delta W} = \frac{\omega_0}{2\delta}$$

where $W_0$ is the stored vibrational energy, $\Delta W$ is the energy lost per cycle, $\omega_0$ is the natural angular frequency, and $\delta$ is the damping factor (vibrations decay exponentially with $\delta t$). When considering steady-state driven oscillations, the Q factor is commonly defined as the resonance frequency divided by the bandwidth

$$Q = \frac{\omega_0}{\Delta \omega}$$

where the bandwidth $\Delta \omega$ is in turn defined as the half-power width of the spectrum.

To evaluate the Q factor as the ratio between frequency and bandwidth you can, for example, run a frequency sweep with high resolution close to the resonant frequency. Then a standard eigenvalue analysis is a natural starting point. Once you know the eigenfrequency, you can add the slide-film damping and switch to a frequency response analysis for frequencies in the immediate vicinity of the resonance.
It is, however, more efficient and accurate to extract the Q factor using the equivalent definition

\[ Q = \frac{\omega_0}{2\delta} = \frac{\text{imag}(\lambda)}{2\text{real}(\lambda)} \]

where \( \lambda \) is a complex eigenvalue. The last part of this example illustrates how COMSOL Multiphysics’ eigenvalue solver can be applied directly on a model set up for frequency response analysis.

The relation between eigenvalue \( \lambda \) and a complex frequency \( f \) is

\[ \lambda = i\omega = 2\pi if \iff f = \frac{\lambda}{2\pi i} \]

where \( \omega \) is the angular frequency. This expression for the frequency can be inserted directly into the frequency response equations. The eigenvalue solver provides the damped eigenvalue in one step when the system of equations is a quadratic polynomial in the angular frequency, otherwise a few steps of fix-point iteration is usually enough to reach convergence.

**Results and Discussion**

The drive direction resonance is found to be close to 433 kHz. Since the mesh resolution is rather low, the eigenfrequency may depend somewhat on the details of the mesh. Running a frequency sweep of a ±1 kHz interval around the obtained resonance frequency and plotting the square of the proof mass velocity gives you
Figure 3-4. Carefully measuring the half-height width of the peak leads to an estimated \( Q = 8000 \).

The drive mode resonance peak is very sharp despite the added slide-film damping. The \( Q \) value obtained from measuring the width at half power is therefore not very accurate.

The \( Q \) value obtained from measuring the bandwidth agrees well with the value given by the simple formula (Ref. 2)

\[
Q = \frac{\omega m h_0}{\eta A} \tag{3-2}
\]

Inserting the angular frequency at resonance \( \omega = 2.73 \times 10^6 \) rad/s, proof mass \( m = 3.9 \times 10^{-11} \) kg, gap height \( h_0 = 2 \) \( \mu \)m, dynamic viscosity \( \eta = 18 \times 10^{-6} \) Pa·s, and slide film area \( A = 1.68 \times 10^{-9} \) \( \text{m}^2 \), gives an estimated \( Q = 7030 \). This formula does not account for the breakdown of the continuum assumption at small scales, and will therefore underestimate the \( Q \) value.

Using the eigenvalue solver to extract the desired value instead gives \( Q = 7524 \), which is also well in agreement with both the previous estimates. In fact, considering the many simplifications in the present model, the value obtained from Equation 3-2 is for most practical purposes good enough. When other dissipative processes are added, or
the geometry is made more complex, the numerical modeling technique illustrated here will be justified, though.

References


Modeling in COMSOL Multiphysics

The Solid, Stress-Strain with Film Damping predefined Multiphysics coupling by default solves for both the structural displacements and the pressure in the air film between the proof mass and the substrate. The tangential velocity \( \mathbf{u}_T \) given by Navier’s equation in the solid are inserted into the modified Reynolds equation describing the film pressure, \( p_F \), on the slide-film boundary:

\[
\nabla_T \cdot (h_0^3 Q_{ch} p \nabla_T p_F - 6 \eta h_0 \mathbf{u}_T) = 12 j \omega \eta h_0 p_F
\]

Here, the gap width \( h_0 \), relative flow rate function \( Q_{ch} \), and viscosity \( \eta \) are taken to be constant, and \( \nabla_T \) represents differentiation in the tangential direction. The slide film in return applies a stress

\[
F = -\eta \frac{\mathbf{u}_T}{h_0(1 + 2 K_s)} \frac{h_0 \nabla_T p_F}{2}
\]

on the structure, where \( K_s \) is the scaled Knudsen number. In the present situation, where the sliding surfaces are parallel, the contribution from the pressure in the second term is very small. Therefore, you can actually save some computation time without sacrificing much accuracy by simply switching off the film pressure variable during solving.

As a first step, the undamped vibrational modes of the gyroscope are found with only the Solid, Stress-Strain application mode active. Adding slide-film damping does not change the natural frequency perceptibly, so when measuring the half-power width of the resonance peak, you can safely restrict the frequency sweep to a very narrow band around the first pure structural eigenfrequency. Finally, the eigenvalue solver lets you find the same result in a more convenient way.
ESTIMATING THE Q FACTOR OF A MEMS GYROSCOPE

Model Library path: MEMS_Module/Sensor_Models/mems_gyroscope

Modeling Using the Graphical User Interface

MODEL NAVIGATOR
1. Select 3D from the Space dimension list.
2. Expand the predefined Multiphysics node MEMS Module>Structural Mechanics>Solid, Stress-Strain with Film Damping and select Frequency response analysis.
3. Click OK to close the Model Navigator.

OPTIONS AND SETTINGS
1. Open the Constants dialog box from the Options menu, and enter the following constants.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>e0</td>
<td>8.854e-12[F/m]</td>
<td>Permittivity of free space</td>
</tr>
<tr>
<td>z0</td>
<td>10[um]</td>
<td>Structure thickness</td>
</tr>
<tr>
<td>y0</td>
<td>4[um]</td>
<td>Distance between fingers</td>
</tr>
<tr>
<td>N</td>
<td>10</td>
<td>Number of comb fingers</td>
</tr>
<tr>
<td>V_dc</td>
<td>30[V]</td>
<td>Bias voltage</td>
</tr>
<tr>
<td>V_ac</td>
<td>2[V]</td>
<td>Drive voltage</td>
</tr>
<tr>
<td>F_cd</td>
<td>4<em>e0</em>z0<em>N</em>V_dc*V_ac/y0</td>
<td>Comb drive force</td>
</tr>
<tr>
<td>A_cd</td>
<td>40[um]*10[um]</td>
<td>Comb drive area</td>
</tr>
</tbody>
</table>

2. Click OK to close the dialog box.
GEOMETRY MODELING

1 The somewhat idealized geometry is built entirely from blocks. First, use the Block button on the Draw toolbar repeatedly to create four blocks with the following dimensions and positions:

<table>
<thead>
<tr>
<th>LENGTH</th>
<th>X</th>
<th>Y</th>
<th>Z</th>
<th>AXIS BASE POINT</th>
<th>X</th>
<th>Y</th>
<th>Z</th>
</tr>
</thead>
<tbody>
<tr>
<td>100e-6</td>
<td>50e-6</td>
<td>10e-6</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>20e-6</td>
<td>49e-6</td>
<td>10e-6</td>
<td>0</td>
<td>1e-6</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>20e-6</td>
<td>49e-6</td>
<td>10e-6</td>
<td>80e-6</td>
<td>1e-6</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>58e-6</td>
<td>20e-6</td>
<td>10e-6</td>
<td>21e-6</td>
<td>2e-6</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

2 Press Ctrl+A to select all objects and click the Difference button on the Main toolbar.

3 Add two more blocks to represent the simplified comb drives:

<table>
<thead>
<tr>
<th>LENGTH</th>
<th>X</th>
<th>Y</th>
<th>Z</th>
<th>AXIS BASE POINT</th>
<th>X</th>
<th>Y</th>
<th>Z</th>
</tr>
</thead>
<tbody>
<tr>
<td>2e-6</td>
<td>20e-6</td>
<td>10e-6</td>
<td>18e-6</td>
<td>30e-6</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>2e-6</td>
<td>20e-6</td>
<td>10e-6</td>
<td>80e-6</td>
<td>30e-6</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

4 Click the Zoom Extents button on the main toolbar to fit the geometry to your screen.

PHYSICS SETTINGS

Subdomain Settings
The gyroscope structure is made entirely of polycrystalline silicon, which shows negligible internal viscous damping at these scales. Poly-Si is a standard material that can be found in the MEMS Material Library.

1 Select the Solid, Stress-Strain (smdsl) application mode from the Model Tree.

2 Open the Subdomain Settings dialog box by clicking in the Model Tree or choosing Subdomain Settings from the Physics menu.

3 Select all three subdomains in the list and click the Load button.
4 In the Materials/Coefficients Library, select MEMS Material Properties>Semiconductors>Poly-Si.

5 Click OK to close the dialog box and return to Subdomain Settings.

Cubic Lagrange elements can be used to somewhat compensate for the fact that it is difficult to create a mesh with more than one element across the thickness of the thin support beams. In fact, third-order elements in general give considerably better accuracy in relation to the number of degrees of freedom when applied to bending of thin structures compared to the default second-order elements.

6 Click the Element tab, then choose Lagrange - Cubic from the Predefined elements list.

7 Click OK to close the dialog box.

Boundary Conditions—Solid, Stress-Strain
The first step in the analysis is to find the frequency of the drive-direction resonance. For that purpose, it is enough to solve the pure, undamped structural eigenvalue problem. The Film Damping application mode is by default disabled on all boundaries. Therefore, it is enough, for now, to set appropriate constraints on the structure.

1 Open the Boundary Settings dialog box for the Solid, Stress-Strain application mode.
2 Select Boundaries 1 and 26, which represent anchor points, and select Fixed from the Constraint condition list.
3 Select Boundaries 10, 13, and 24 (the mirror plane boundaries) and set the Constraint condition to Symmetry plane.

4 Click OK to close the dialog box.

**MESH GENERATION**

1 While still in Boundary mode, select the top surface Boundaries 4, 9, and 23 and click the Interactive Meshing button on the Mesh toolbar.

2 Then click the Decrease Mesh Size button once to decrease the mesh size from Normal to Fine.

3 Mesh the selected surfaces by clicking the Mesh Selected (Free) button.

4 Choose Swept Mesh Parameters from the Mesh menu.

5 Select all subdomains in the Subdomain selection list and select the Manual specification of element layers check box.

6 Enter 1 in the Number of element layers edit field.

7 Click OK to close the dialog box.
To create the final mesh, click the **Mesh Remaining (Swept)** button on the Mesh toolbar.

**Figure 3-5:** The swept mesh is rather coarse, but the use of cubic shape functions ensures that the accuracy is sufficient.

**COMPUTING THE SOLUTION**

As a preliminary step, before evaluating the Q factor, use the eigenvalue solver to find the first few resonance frequencies of the structure.

1. From the **Solve** menu, open the **Solver Parameters** dialog box.
2. In the **Analysis types** area, select **Eigenfrequency** from the list of analysis types for the **Solid, Stress-Strain** application mode; then click **OK**.
3. Click the **Solve** button on the Main toolbar.

**POSTPROCESSING AND VISUALIZATION**

The default plot shows the von Mises stress on a number of cross sections. A deformed-shape plot makes it easier to classify the different eigenmodes.

1. Open the **Plot Parameters** dialog box by choosing it from the **Postprocessing** menu or clicking the corresponding button on the Main toolbar.
2 In the Plot type frame, clear the Slice check box and select the Boundary and Deformed shape check boxes.

3 Click OK to display the shape of the first eigenmode.

Figure 3-6: The first eigenmode shows the proof mass oscillating in the drive direction with a frequency of about 433 kHz. Due to the limited mesh resolution, the exact frequency obtained might vary slightly.

PHYSICS SETTINGS

Now, knowing the resonance frequency of the drive mode, it is time to apply the comb drive forcing according to Equation 3-1 and activate the slide-film damping.

Boundary Conditions—Solid, Stress-Strain

1 Open the Boundary Settings dialog box for the Solid, Stress-Strain application mode again.

2 On the Load page, select Boundaries 6 and 25. Apply the driving force on these boundaries by entering the distributed load $F_{cd}/A_{cd}$ in the $F_x$ edit field.

3 Select the lower surface of the model, consisting of Boundaries 3, 8, and 22, and choose Film damping from the Group list.

4 Click OK to close the dialog box.
Boundary Conditions—Film Damping

1. Locate `Geom1>Film Damping (mmfd)>Boundary Settings` in the Model Tree and double-click the node.

2. Make sure the slide-film boundaries (Boundaries 3, 8, and 22) are still selected and choose `Film damping` from the Group list.

3. Change the Gas film settings according to the following table:

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Damping type</td>
<td>Slide film</td>
</tr>
<tr>
<td>( h_0 )</td>
<td>2 ([\mu m])</td>
</tr>
<tr>
<td>( P_A )</td>
<td>1 ([\text{atm}])</td>
</tr>
<tr>
<td>( \lambda_0 )</td>
<td>70 ([\text{nm}])</td>
</tr>
<tr>
<td>( p_{h,0} )</td>
<td>1 ([\text{atm}])</td>
</tr>
<tr>
<td>( \eta )</td>
<td>18e-6 ([\text{Pa*s}])</td>
</tr>
<tr>
<td>( Q_{ch} )</td>
<td>Slip</td>
</tr>
</tbody>
</table>

4. Click OK to close the dialog box.

Edge Settings—Film Damping

1. Open the Edge Settings dialog box, either from the Physics menu or by clicking in the Model Tree.

2. Select Edges 15, 24, and 49, which are part of the symmetry plane, and choose Closed/Symmetry as End condition.

3. Click OK to close the dialog box.

Computing the Solution

Above, the eigenvalue solver was used to calculate the resonance frequency of the drive mode. Next, apply the parametric solver to obtain the frequency response of the damped model for frequencies in the immediate neighborhood of the known resonance. With a clever choice of frequency steps, you can resolve the resonance peak accurately without having to use a short sampling interval everywhere. For example, using

\[
\text{sort}([433775, 433775-\text{logspace}(1,3,15), 433775+\text{logspace}(1,3,15)])
\]

gives you a sorted frequency list, as expected by the solver, which resolves the neighborhood of 433775 Hz.

The damping in the model is rather weak, with an estimated Q factor close to 8000. The expected band width of the resonance peak is then less than 100 Hz, which is less
than the errors caused by the rather coarse mesh. Small differences between meshes created on different hardware platforms can potentially move the peak more than its bandwidth. Therefore it might be necessary to modify the suggested parameter list to reflect the actual resonance frequency found in the first solution step.

**Solver Settings**

1. From the **Solve** menu, open the **Solver Parameters** dialog box.
2. In the **Analysis types** area, select **Frequency response** from the list of analysis types for the **Solid, Stress-Strain** application mode, which both modifies the implementation of the structural equations and switches to the parametric solver.

   Note that the Film Damping application mode is already set to the Frequency response analysis type because it was started in that mode.
3. Enter `freq` in the **Parameter name** edit field. This defines the variable `freq`, which becomes the excitation frequency for the frequency response analysis.
4. In the **Parameter values** edit field, enter `sort([433775 433775-logspace(1,3,15) 433775+logspace(1,3,15)])`.
5. Click **OK** to close the **Solver Parameters** dialog box.

**Scalar Variables**

Both application modes are now set to the Frequency response analysis type, which means that they describe harmonic motion at a fixed frequency. You must specify this frequency for both modes:

1. Choose **Scalar Variables** from the **Physics** menu.
2. In the **Application Scalar Variables** dialog box, set both variables described as **Excitation frequency** to `freq`.
3. Click **OK** to accept the changes and close the dialog box.

**Probe Plot**

When working with the parametric solver, it is often convenient to set up a probe plot that lets you check your results as they are produced. In this model, the quantity of interest is the vibrational energy at steady state for each frequency. Looking at the shape of the drive mode, it is obvious that the vibrational energy will be very nearly proportional to the square of the proof mass’s peak velocity, which is constant throughout the proof mass.

1. Choose **Probe Plot Parameters** from the **Postprocessing** menu.
2. In the dialog box, click **New**.
3 Select **Point probe** from the **Plot type** list, then click **OK** to create the new probe plot.

4 Select Point 32 and change the **Expression** field to \( \text{abs}(u_{t smsld})^2 \).

5 Click **OK** to close the dialog box.

*Computing the Frequency Sweep*

Click the **Solve** button on the Main toolbar to compute the frequency sweep.

As the sweep progresses, the probe plot appears in the **Progress** window, showing a distinct peak in the vibrational energy curve. When the solving stage finishes, the resulting plot is automatically copied to a separate figure window. The curve should be similar to that in Figure 3-4 on page 149.

*POSTPROCESSING AND VISUALIZATION*

The **Q** factor can be estimated directly from the probe plot by measuring the width of the resonance peak at half its maximum value and dividing the resonance frequency by the measured bandwidth. This, however, gives you a very rough estimate.

It is possible to use the **Point Evaluation** dialog box to manually look for the frequencies that give values for the squared velocity at Point 32 close to half the peak value. Using some back-of-the-envelope interpolation you can conclude that the **Q** factor must lie somewhere close to 8000, not far from what is predicted by Equation 3-2. This result serves to verify that the frequency response model is likely to be correct. With a working frequency response model and knowledge about what the drive mode looks like, you can proceed to the final step.

*COMPUTING THE SOLUTION*

The slide-film damping application mode does not explicitly support the eigenvalue analysis type to calculate damped eigenvalue solutions. Instead, you can do an eigenvalue analysis of the equations solved above for frequency response just by switching solver and rewriting the frequency in terms of the eigenvalue variable \( \lambda \).

1 From the **Solve** menu, open the **Solver Parameters** dialog box.

2 Select **Eigenvalue** from the **Solver** list, then click **OK**.

3 Choose **Scalar Variables** from the **Physics** menu.

4 In the **Application Scalar Variables** dialog box, set the **Excitation frequency** for both application modes to \( \lambda/(2\pi i) \).

5 Click **OK** to close the dialog box.

6 Click the **Solve** button on the Main toolbar.
POSTPROCESSING AND VISUALIZATION

Solving a damped eigenvalue problem like this gives you a number of complex eigenvalues which do not necessarily show up in the same order as for the lossless model. Your first task is therefore to locate the drive mode. If the displayed plot does not already look like Figure 3-6 on page 156, do the following:

1. Open the Plot Parameters dialog box by choosing it from the Postprocessing menu or clicking the corresponding button on the Main toolbar.

2. Because $\lambda = 2\pi f$, search the Eigenvalue list on the General page for an eigenvalue with imaginary part close to $2.7 \cdot 10^6$. There should be two, one with positive and one with negative imaginary part.

3. Click Apply and check the plot to verify that you have indeed found the drive mode.

4. Click OK or Cancel to close the dialog box.

Finally, proceed to evaluate the Q factor as half the ratio between imaginary and real part of the eigenvalue:

5. Choose Data Display>Global from the Post menu.

6. Enter `abs(imag(lambda)/real(lambda))/2` in the Expression field and select the drive mode from the Eigenvalue list.

7. Click OK to close the dialog box and display the final result in the message log.
**Capacitive Pressure Sensor**

*Introduction*

This example examines the operation of a capacitive MEMS pressure sensor, treating both 2D and 3D model versions.

The operating principle of a capacitive pressure sensor is to measure the change in capacitance between two electrodes when a change in pressure displaces one of the electrodes, located on a thin diaphragm. The diaphragm separates a reference compartment kept at vacuum pressure and a pressurized compartment; see Figure 3-7.

*Figure 3-7: One quarter of the pressure sensor (the two vertical cross-sectional planes are symmetry planes). The vacuum compartment looks like a small ashtray with a thin diaphragm at its bottom. Between this diaphragm and the fixed base is a very thin pressurized compartment.*

At the bottom of the pressurized compartment is a fixed base (with one electrode), while the diaphragm (with a counterelectrode) is located at its top. As the pressure changes, the diaphragm that separates the two compartments is displaced, and the
change in separation between the two electrodes results in a corresponding change in the capacitance.

Although the deformation of the sensor is primarily caused by the applied pressure, any initial stresses in the material also affect the deformation. Therefore, the manufacturing process and the selected materials directly influence sensor operation. For example, in some structures the membrane and cavities are engraved onto silicon and sealed with layers of glass. Because the materials are bonded together at a high temperature, cooling them down to the sensor’s normal operating temperature produces undesirable stresses in the material that affect device performance.

The sensor in this example measures static pressures of a magnitude from zero to atmospheric pressure. The model first computes the initial stresses from the manufacturing process; then it accounts for the structure’s mechanical deformation resulting from an applied pressure. It finally calculates the sensor’s capacitance for the deformed shape: the 2D model calculates the capacitance from a computed electric field, whereas the 3D model simply integrates infinitesimal capacitance contributions over the electrode boundary.

The 2D model describes a geometry that differs from that of a true 3D sensor (and of the 3D model). The deforming diaphragm is rectangular and fixed at all boundaries. When viewed in 2D, however, a bridge-like structure, fixed only at the two edges, results. Figure 3-8 illustrates the model’s deformed geometry in 2D.
Figure 3-8: 2D view of a pressure sensor.

Model Definition

Model Geometry

The pressure sensor consists of a silicon structure that includes a micrometer-thick diaphragm situated between two glass layers. Figure 3-9 shows the geometry and the dimensions are given in Table 3-1. In addition, two 1 mm$^2$ rectangular plates at the pressurized compartment’s top (applied potential) and bottom (grounded) form the electrodes.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>TOP AND BOTTOM LAYERS</th>
<th>MIDDLE LAYER</th>
<th>VACUUM COMPARTMENT</th>
<th>PRESSURIZED COMPARTMENT</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shape</td>
<td>Rectangular</td>
<td>Rectangle with engraved cavities</td>
<td>Symmetric trapezoid</td>
<td>Rectangular</td>
</tr>
<tr>
<td>Width/Length</td>
<td>2.5 mm</td>
<td>2.5 mm</td>
<td>top: 1.9 mm</td>
<td>1.5 mm</td>
</tr>
<tr>
<td></td>
<td>diaphragm: 1.5 mm</td>
<td></td>
<td>bottom: 1.5 mm</td>
<td></td>
</tr>
</tbody>
</table>
Figure 3-9: Materials used in the structural analysis of the capacitive pressure sensor in 3D.

**STRESS AND DEFORMATION**

During manufacturing, the sensor is bonded together in a vacuum and at a high temperature before it is cooled down. Therefore, during this process no external forces act on the sensor’s boundaries, but internal stresses appear because the two materials have different coefficients of thermal expansion. This process also produces a vacuum in the upper cavity that serves as the reference pressure.

During regular operation, the sensor is fixed to a solid surface, and ambient pressure pushes on all outer boundaries. The temperature also changes, which produces extra stresses due to thermal expansion.
For a linear elastic material, the stress-strain relationship—taking into account initial stress, \( \sigma_0 \), initial strain, \( \varepsilon_0 \), and thermal strain, \( \varepsilon_{\text{th}} \)—is

\[
\sigma = D \varepsilon_{\text{el}} = D(\varepsilon - \varepsilon_{\text{th}} - \varepsilon_0) + \sigma_0
\]

where \( D \) is the elasticity tensor, and the 6-dimensional vectors \( \sigma \) and \( \varepsilon \) give the normal and shear values of the stresses and strains.

Initially only thermal expansion is active. It is given by

\[
\varepsilon_{\text{th}} = \begin{bmatrix}
\varepsilon_x \\
\varepsilon_y \\
\varepsilon_z \\
\gamma_{xy} \\
\gamma_{yz} \\
\gamma_{xz}
\end{bmatrix}
= \alpha_{\text{vec}}(T - T_{\text{ref}})
\]

where \( \alpha_{\text{vec}} \) are the coefficients of thermal expansion, \( T \) is the ambient temperature, and \( T_{\text{ref}} \) is the reference temperature. The manufacturing stage produces the initial stress for normal operation, where further thermal expansion takes place. This model assumes that the sensor is close to its initial geometry after manufacturing, so that the initial strain equals zero. Furthermore, you solve the first application mode using the small deformation assumption but allow large deformations for the second one.

**CAPACITANCE**

To compute the sensor’s capacitance, the 2D model solves for the electric field in the deformed geometry (or frame), which is defined by the Moving Mesh (ALE) application mode. Using a port boundary condition, the capacitance is obtained from the energy of the electric field from the equation

\[
C = \frac{1}{U^2} \int_{\Omega_d} W_e d\Omega_d
\]

where \( U \) is the potential difference between the plates (\( U = 1 \) V for the port boundary condition) and \( W_e \) is the electric energy density. The area \( \Omega_d \) corresponds to the narrow air gap in the sensor.

The 3D model uses another method for the capacitance calculation, namely integrating over the surface of the capacitor according to
\[ C = \varepsilon \int \frac{1}{h} dA \]

where \( h \) denotes the local distance across the capacitor and \( \varepsilon \) is the permittivity of air. This calculation rests on the assumption that the lower glass block does not deform much, so that the local separation only depends on the initial distance and the diaphragm deformation. In the model this expression is further multiplied by 4 to get the full capacitance of the model.

**Results and Discussion**

Figure 3-10 shows the results from the 2D model after the bonding phase, where bonding took place at 400 °C and the sensor is then cooled down to 22 °C. In the image the \( x \)-axis and \( y \)-axis have different scales, and the structural deformation is scaled by a factor 20.

It appears that the membrane slightly pulls toward the larger cavity even though there are no applied loads. Stresses appear near the boundaries of the different materials and in the silicon membrane, which is narrower than other parts of the sensor. The maximum appears at the lower left corner of the smaller cavity.

*Figure 3-10: Initial stresses of the materials in the pressure sensor.*
Figure 3-11 shows the results from the 3D model when the sensor is in operation: it is exposed to a pressure of one atmosphere at 15 °C. The largest stress in the diaphragm appears near the position where the diaphragm connects the surrounding material.

Figure 3-12 shows the results from the 2D mode at the same conditions. The figure is arbitrarily scaled and is focused on the left half of the lower cavity. The diaphragm deforms toward the vacuum with maximum deformation in the middle. Maximum stresses appear at the upper corners of the lower cavity where the membrane attaches to the silicon boundaries.

The streamlines show the electric field in the lower cavity. The lines are vertical between the two electrodes. Some field lines appear outside of the electrode region, but the field strength is very small there (dark blue color).
Figure 3-11: Sensor deformation and von Mises Stress (MPa) when exposed to ambient pressure.

Figure 3-12: Sensor deformation, stresses (von Mises Stress in MPa; left colorbar) and electric field (electric field strength in kV/m; right colorbar) when exposed to ambient pressure.
Figure 3-13 show the capacitance values computed from the electric field for four conditions as described in Table 3-2. Conditions A and B have the same ambient temperature but a higher bonding temperature. In Condition C all temperature values are the same so no stresses or deformations arise from thermal effects. For Condition D, thermal deformation does result from the ambient temperature.

The capacitance for the full sensor modeled in the 3D model is shown in Figure 3-14. This capacitance corresponds to condition A in Table 3-2.

You can also compare the computed capacitance values to those for a plate capacitor with a plate size of 1 mm times unity and a gap of 5 µm when not deformed. The capacitance for this plate capacitor is \( C = \varepsilon_0 A/d = 1.771 \times 10^{-9} \) F; the corresponding value from the COMSOL Multiphysics model is 1.7760763 \( \times 10^{-9} \) F computed with settings for Condition C and zero pressure.

<table>
<thead>
<tr>
<th>TEMPERATURE</th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>High bonding (°C)</td>
<td>400</td>
<td>200</td>
<td>22</td>
<td>22</td>
</tr>
<tr>
<td>Low bonding (°C)</td>
<td>22</td>
<td>22</td>
<td>22</td>
<td>22</td>
</tr>
<tr>
<td>Ambient (°C)</td>
<td>15</td>
<td>15</td>
<td>22</td>
<td>-18</td>
</tr>
</tbody>
</table>

**TABLE 3-2: TEMPERATURE CONDITIONS FOR COMPUTING THE CAPACITANCE VALUES**
Figure 3-13: Computed capacitance vs. ambient pressure for different temperature conditions from the 2D model: Condition A, triangles; Condition B, squares; Condition C, +; Condition D, *.
Figure 3-14: Capacitance of the sensor as the function of the operating pressure from the 3D model.

Modeling in COMSOL Multiphysics

In COMSOL Multiphysics you solve the 2D problem using four application modes: two Plane Strain application modes, one Moving Mesh (ALE) application mode, and one Electrostatics application mode. The latter two are defined in a frame to allow the mesh to move.

In the 2D model you solve for the mesh movement and the electric field only in the small air gap where the ambient pressure is applied to the sensor. The mesh movement follows the structural deformation on the model’s parts.

The solution process takes place in four steps:

1. The first Plane Strain application mode represents the sensor’s fabrication, and it computes the initial stresses that result from thermal expansion. This is solved with the static solver.

2. The second Plane Strain application mode solves the deformation and stresses that result when the sensor is exposed to ambient temperature and pressure. It uses the
initial stresses and deformation from the first Plane Strain application mode. This is solved with a parametric solver for different values of ambient pressure.

3 Using a parametric solver, you solve the ALE mesh for each ambient pressure.

4 Finally, you solve the electric field for each ambient pressure using a parametric solver.

You solve 3D problem using only two Solid, Stress-Strain application modes. Similarly, for the 2D model, you must use a large deformation analysis for the second structural application mode.

The solution process of the 3D model takes place in two steps, which are the same as the first two steps for the 2D model, but using the Solid, Stress-Strain application mode.

The following table contains descriptions and default values for constants that define the different manufacturing and ambient conditions. If you want to conduct a static analysis to solve for single solutions, you can define a constant $P_{\text{ambient}}$; it is not needed for the parametric analysis.

<table>
<thead>
<tr>
<th>CONSTANT</th>
<th>VALUE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>$T_{\text{bondingH}}$</td>
<td>400 °C</td>
<td>High bonding temperature</td>
</tr>
<tr>
<td>$T_{\text{bondingL}}$</td>
<td>22 °C</td>
<td>Low bonding temperature</td>
</tr>
<tr>
<td>$T_{\text{ambient}}$</td>
<td>15 °C</td>
<td>Ambient temperature</td>
</tr>
<tr>
<td>$P_{\text{ambient}}$</td>
<td>101 kPa</td>
<td>Ambient pressure</td>
</tr>
</tbody>
</table>

**Model Library path:** MEMS_Module/Sensor_Models/pressure_sensor_2d

**Model Library path:** MEMS_Module/Sensor_Models/pressure_sensor_3d

**Modeling Using the Graphical User Interface—2D Example**

**MODEL NAVIGATOR**

1 Open the Model Navigator, go to the New page, and select 2D from the Space dimension list.
2. Click the Multiphysics button.

3. From the list of application modes select MEMS Module>Structural Mechanics>Plane Strain>Static analysis. Add it to the model two times by clicking the Add button twice. Note that COMSOL Multiphysics adds both to a 2D geometry it labels Geom1 (2D).

4. In the Multiphysics area select Plane Strain (smpn2).

5. Click the Application Mode Properties button, find the Large deformation list, and select On. Click OK.

6. In the Multiphysics area select COMSOL Multiphysics>Deformed Mesh>Moving Mesh (ALE)>Static analysis. Click Add.

7. From the list of application modes select MEMS Module>Electrostatics>Electrostatics. Click Add. Note that this application mode appears under Frame (ale).

8. In the Multiphysics area select Electrostatics (emes) and click the Application Mode Properties button. In the Weak Constraints list select On and in the Constraint type list choose Non-ideal.

9. Find the Ruling application mode list at the bottom of the dialog box and select Moving Mesh (ALE) (ale).

10. Click OK.

OPTIONS AND SETTINGS

1. From the Options menu select Axes/Grid Settings.

2. In the dialog box that opens, go to the Axis page and clear the Axis equal check box. Then define axis settings according to the following table:

<table>
<thead>
<tr>
<th>x min</th>
<th>-1e-3</th>
</tr>
</thead>
<tbody>
<tr>
<td>x max</td>
<td>3e-3</td>
</tr>
<tr>
<td>y min</td>
<td>-1e-3</td>
</tr>
<tr>
<td>y max</td>
<td>2e-3</td>
</tr>
</tbody>
</table>

3. Go to the Grid page and clear the Auto check box. Then define axis settings according to the following table; when finished, click OK.

<table>
<thead>
<tr>
<th>x spacing</th>
<th>0.5e-3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Extra x</td>
<td>0.3e-3  0.75e-3 1.75e-3 2.2e-3</td>
</tr>
<tr>
<td>y spacing</td>
<td>0.5e-3</td>
</tr>
<tr>
<td>Extra y</td>
<td>5e-6  25e-6</td>
</tr>
</tbody>
</table>
4 From the **Options** menu, select **Constants**. In the resulting dialog box enter the following names and expressions (you can change these values to model different bonding and ambient conditions); when done, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>T_bondingH</td>
<td>400[degC]</td>
<td>High bonding temperature</td>
</tr>
<tr>
<td>T_bondingL</td>
<td>22[degC]</td>
<td>Low bonding temperature</td>
</tr>
<tr>
<td>T_ambient</td>
<td>15[degC]</td>
<td>Ambient temperature</td>
</tr>
</tbody>
</table>

5 From the **Options** menu select **Materials/Coefficients Library**. In the resulting dialog box select **Model** and then click **New**.

6 Go to the **Name** edit field and enter Glass HOYA, then in the **Material properties** area set these parameter values; when done, click **OK**.

<table>
<thead>
<tr>
<th>QUANTITY</th>
<th>VALUE/EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>E</td>
<td>86.667e9</td>
<td>Young’s modulus</td>
</tr>
<tr>
<td>nu</td>
<td>0.244</td>
<td>Poisson ratio</td>
</tr>
<tr>
<td>rho</td>
<td>2600</td>
<td>Density</td>
</tr>
<tr>
<td>alpha</td>
<td>3.41e-6</td>
<td>Thermal expansion</td>
</tr>
</tbody>
</table>

**GEOMETRY MODELING**

1 Draw four rectangles as given in the following table. To do so, go to the Draw toolbar and Shift-click the **Rectangle/Square** button; alternatively, from the Main menu choose **Draw>Specify Objects>Rectangle**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>SIZE</th>
<th>POSITION</th>
<th>BASE</th>
<th>X</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>2.5e-3 0.5e-3</td>
<td>Corner 0</td>
<td>-0.5e-3</td>
<td></td>
<td></td>
</tr>
<tr>
<td>R2</td>
<td>2.5e-3 0.5e-3</td>
<td>Corner 0</td>
<td>0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>R3</td>
<td>2.5e-3 0.5e-3</td>
<td>Corner 0</td>
<td>0.5e-3</td>
<td></td>
<td></td>
</tr>
<tr>
<td>R4</td>
<td>1.5e-3 5e-6</td>
<td>Corner 0.5e-3</td>
<td>0</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

2 Create the composite object CO1, which consists of the points in the following table. To do so, go to the Draw toolbar, click the **Line** button, and left-click through the points in sequence. Finish the geometry by right-clicking on the drawing area. Alternatively, go to the Draw toolbar and Shift-click the **Line** button. In the resulting dialog box go to the **Style** list and select **Closed polyline (solid)**. In the **Name** edit field, verify that the name is CO1; if not, enter it. Then enter the coordinates (all four
3 Create a composite object of objects R2 and CO1. On the Draw toolbar select the
Create Composite Object button, go to the Set formula edit field and enter R2·CO1,
then click OK.

4 Draw four points on the coordinates given on the following table. To do so,
successively select the Point button from the Draw toolbar and click the grid points.
Alternatively, from the Draw toolbar shift-click the Point button four times, each
time entering a coordinate pair.

<table>
<thead>
<tr>
<th>NAME</th>
<th>COORDINATES</th>
<th>X</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>PT1</td>
<td></td>
<td>7.5e-4</td>
<td>5e-6</td>
</tr>
<tr>
<td>PT2</td>
<td></td>
<td>1.75e-3</td>
<td>5e-6</td>
</tr>
<tr>
<td>PT3</td>
<td></td>
<td>7.5e-4</td>
<td>0</td>
</tr>
<tr>
<td>PT4</td>
<td></td>
<td>1.75e-3</td>
<td>0</td>
</tr>
</tbody>
</table>

PHYSICS SETTINGS

Subdomain Settings
You supply material parameters separately for each application mode. Furthermore,
here you define in which subdomain the model solves each application mode.

Specify the subdomain settings for the Plane Strain (smpn) application mode as follows:

1 From the Multiphysics menu, choose Plane Strain (smpn).
2 From the Physics menu, choose Subdomain Settings.
3 Go to the Material page.
4 Select Subdomain 4 and clear the Active in this domain check box.
5 Select Subdomains 1 and 3.
6 Click Load, then from the Materials list select Model (1)>Glass HOYA (mat1). Click OK.
7 In the thickness edit field, type 2.5 [mm].
8 Select Subdomain 2.
9 Click Load. From the Materials list, select Basic Material Properties > Silicon, then click OK.
10 In the thickness edit field, type 2.5 [mm].
11 To enable thermal stresses first select Subdomains 1–3.
12 Click the Load tab. Select the Include thermal expansion check box. In the Temp edit field, type T_bondingL, and in the Tempref edit field, type T_bondingH.
13 Click OK.

Specify the subdomain settings for the Plane Strain (smpn2) application mode as follows:

1 From the Multiphysics menu, choose Plane Strain (smpn2).
2 From the Physics menu, choose Subdomain Settings.
3 Set the material parameters for Subdomains 1–3, and deactivate subdomain 4 following the same procedures as for the first Plane Strain application mode in the previous list (Steps 3 to 10). Note, though, that you can select materials directly from the Library material list on the Material page.
4 To include initial stresses and further thermal stresses first select Subdomains 1–3.
5 Click the Load tab. Select the Include thermal expansion check box. In the Temp edit field, type T_ambient, and in the Tempref edit field, enter T_bondingL.
6 Click the Initial Stress and Strain tab. Select the Include initial stress check box. Enter values for $\sigma_{xi}$ ($sX_smpn$), for $\sigma_{yi}$ ($sY_smpn$), for $\sigma_{zi}$ ($sZ_smpn$), and for $\sigma_{xyi}$ ($sXY_smpn$).
7 Click OK.

Specify the subdomain settings for the Moving Mesh (ALE) (ale) application mode as follows:

1 From the Multiphysics menu, choose Moving Mesh (ALE) (ale).
2 From the Physics menu, choose Subdomain Settings.
3 Select Subdomains 1–3 and select the Physics induced displacement check box.
4 Enter u2 and v2 in the dx and dy edit fields, respectively.
5 Select Subdomain 4.
6 Verify that the Free displacement option button is selected, then click OK.
When configuring the Electrostatics application mode, use material parameters corresponding to air.

1. From the Multiphysics menu, choose Electrostatics (emes).
2. From the Physics menu, choose Subdomain Settings.
3. Select Subdomains 1–3 and clear the Active in this domain check box.
4. Leave parameter values for Subdomain 4 at their initial values (that is, the constitutive relationship is \( D = \varepsilon_0 \varepsilon_r E \) with \( \varepsilon_r = 1 \) and \( \rho = 0 \)). Check the Init page to verify that the setup has initialized \( V \) to zero.
5. Click OK.

**Boundary Conditions**
The manufacturing process applies no loads or constraints on the boundaries. Thus you do not need to set any boundary conditions for Plane Strain (smpn) because, by default, there are not any loads or constraints. Define boundary conditions for the other application modes according to the following steps:

1. Select Multiphysics>Plane Strain (smpn2) and open the Physics>Boundary Settings dialog box.
2. Select Boundary 2, and on the Constraint page set Constraint condition to Fixed.
3. Go to the Load page and select all boundaries.
4. Select all boundaries 1, 3, 5, 7, 10–12, 14–18, and 22–24.
5. From the Type of load list select Follower Load.
6. In the Follower pressure field type \( P_{\text{ambient}} \).
7. Click OK.
8. Select Multiphysics>Moving Mesh (ALE) (ale) and then Physics>Boundary Settings.
9. Select all active boundaries, that is, Boundaries 10–12 and 14–18.
10. Select the \( dx \) and \( dy \) check boxes and type \( u_2 \) and \( v_2 \), respectively, in the corresponding edit fields.
11. Click OK.
12. Select Multiphysics>Electrostatics (emes) and then Physics>Boundary Settings.
Define boundary settings for the active boundaries as in the following table. Note that you define the port settings on the separate Port page; when done click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 10–12, 16–18</th>
<th>BOUNDARY 14</th>
<th>BOUNDARY 15</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Zero charge/Symmetry</td>
<td>Ground</td>
<td>Port</td>
</tr>
<tr>
<td>Port number</td>
<td>1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Use port as input</td>
<td>Selected</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Input property</td>
<td></td>
<td></td>
<td>Forced voltage</td>
</tr>
</tbody>
</table>

**Point Settings**

1. Select **Multiphysics>Plane Stress (smps)** and then **Physics>Point Settings**.
2. Make sure the **Standard notation** button is selected. Then define point constraints according to the following table. Check also that **Global coordinate system** is selected in the **Coordinate system** list; when done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>POINT 1</th>
<th>POINT 17</th>
</tr>
</thead>
<tbody>
<tr>
<td>$R_x$</td>
<td>0</td>
<td>(not selected)</td>
</tr>
<tr>
<td>$R_y$</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

**Mesh Generation**

1. From the **Mesh** menu, choose **Free Mesh Parameters**.
2. On the **Global** page, select **Coarse** from the **Predefined mesh sizes** list.
3. Click the **Custom mesh size** button, then set the **Resolution of narrow regions** to 2.
4. Click **Remesh** to generate the mesh.
5. When the mesher has finished, click **OK**.

**Computing the Solution**

The following steps use a static solver to first solve the bonding phase and the parametric solver to solve the sensor operation for different pressures.

To make it easier to test the model with different temperature settings, use solver scripting. Before proceeding with the steps below, go to the **Solver Manager** dialog box, click the **Script** tab, select **Automatically add commands when solving**, and then close the **Solver Manager** dialog box. Next perform the steps below, and finally clear the **Automatically add commands when solving** check box. Later on you can return to the **Script** page of the **Solver Manager**, select the **Solve using a script** check box, and click the **Solve** button. The script automatically performs all the steps needed for the solution.

1. From the **Solve** menu, select **Solver Parameters**.
On the General page, verify that the Analysis list has the selection Static and that the Solver list has the selection Stationary. Click OK.

From the Solve menu, choose the Solver Manager; alternatively, click the Solver Manager button on the Main toolbar.

The default values on the Initial Value page are correct: Initial value: Initial value expression evaluated using current solution; Value of variables not solved for and linearization point: Use setting from Initial value frame.

Click the Solve For tab. Select Plane Strain (smpn) and then click Solve.

Keeping the Solver Manager open, select Solver Parameters from the Solve menu.

On the General page, select Parametric from the Solver list.

In the Parameter name field, type \( P_{\text{ambient}} \).

In the Parameter values list, type \( 0 \ 10^4:10^4:10^5 \). Click OK.

Go back to the Solver Manager.

Click the Initial Value tab. In the Value of variables not solved for and linearization point area click the Current solution button.

Click the Solve For tab. Select Plane Strain (smpn2) and then click Solve.

On the Initial Value page, find the Value of variables not solved for and linearization point area. Verify that the Parameter value list is active and has the selection All.

On the Solve For page, select the Moving Mesh (ALE) (ale) application mode. Click Solve.

Select the Electrostatics (emes) application mode. Click Solve.

Click OK to close the Solver Manager.

POSTPROCESSING AND VISUALIZATION

Bonding Phase

Use the following steps to create Figure 3-10 on page 166:

From the Postprocessing menu, choose Plot Parameters.

Go to the General page.

In the Plot type area, verify that only the Surface, Boundary, and Deformed shape check boxes are selected. Verify that the Frame list shows Frame (ref).

Examine the Parameter value list. Any solution is fine because there is only one solution, that for the first step.

Click the Surface tab.
6 From the Predefined quantities list on the Surface Data page, select von Mises stress (smpn), and set the Unit to MPa.

7 Click the Deform tab. Clear the Auto check box, then set the Scale factor to 20.

8 Click the Boundary tab. Any selection in the Predefined quantities list is fine.

9 In the Boundary color area, click first the Uniform color button and then the Color button. In the dialog box that opens, select black and then click OK.

10 Click OK to close the Plot Parameters dialog box and generate the plot.

Response to Ambient Pressure

Use the following steps to create Figure 3-12 on page 168:

1 From the Postprocessing menu, choose Plot Parameters.

2 On the General page, go to the Plot type area and make sure that only the Surface, Boundary, and Streamline check boxes are selected.

3 Verify that the Frame list shows Frame (ale).

4 From the Parameter value list, select the solution you want to plot.

5 Click the Surface tab. From the Predefined quantities list, select Plane Strain (smpn2)>von Mises stress.

6 Click the Streamline tab. On the Streamline Data page, select Electric field (emes) from the Predefined quantities list.

7 On the Start Points page, set the Number of start points to 100.

8 On the Line Color page, click first the Use expression button and then the Color Expression button.

9 In the dialog box that opens, set the Predefined quantities list to Electrostatics (emes)>Electric field, norm. In the Unit edit field type kV/m, then click OK.

10 Click the Advanced button. Select the Normalize vector field check box, then click OK.

11 Click OK.

Capacitance

To display the capacitance, perform the following steps:

1 From the Postprocessing menu, choose Data Display>Global.

2 From the Predefined quantities list, select Electrostatics (emes)>Capacitance matrix, element 11.

3 From the Parameter value list, select the solution you want to plot.

4 Click OK.
You find the result in the message log at the bottom of the main window. The model calculates a capacitance of approximately 1.77 nF for zero pressure.

You can also plot the capacitance:

1. From the Postprocessing menu, choose Global Variables Plot.
2. From the Predefined quantities list, select Capacitance matrix, element 11, then click the Add Selected Predefined Quantities button to the right of the list (marked >).
3. Click OK.

_Modeling Using the Graphical User Interface—3D Example_

**Model Navigator**

1. From the Space dimension list, select 3D.
2. Click Multiphysics.
3. Select MEMS Module>Structural Mechanics>Solid, Stress-Strain and click Add twice.
4. In the Multiphysics area, select Plane Strain (smpn2).
5. Click the Application Mode Properties button, find the Large deformation list, and select On. Click OK.
6. Click OK.

_Options and Settings_

1. From the Options menu, select Constants.
2. Type in the following variables (the descriptions are optional); when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>VALUE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>T_bondingH</td>
<td>400[degC]</td>
<td>High bonding temperature</td>
</tr>
<tr>
<td>T_bondingL</td>
<td>22[degC]</td>
<td>Low bonding temperature</td>
</tr>
<tr>
<td>T_ambient</td>
<td>15[degC]</td>
<td>Ambient, operating temperature</td>
</tr>
<tr>
<td>eps_vacuum</td>
<td>8.854187817e-12[F/m]</td>
<td>Permittivity of free space</td>
</tr>
</tbody>
</table>

3. From Options menu, select Materials/Coefficient library.
4. Select Model from the Materials list and then click New.
5. In the Name edit field, type Glass Hoya.
6 On the Elastic page, edit the material properties according to the following table; when done, click OK.

<table>
<thead>
<tr>
<th>QUANTITY</th>
<th>VALUE/EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>$E$</td>
<td>$86.667 \times 10^9 \text{[Pa]}$</td>
<td>Young's modulus</td>
</tr>
<tr>
<td>alpha</td>
<td>$3.41 \times 10^{-6} \text{[1/K]}$</td>
<td>Thermal expansion coefficient</td>
</tr>
<tr>
<td>nu</td>
<td>0.244</td>
<td>Poisson's ratio</td>
</tr>
<tr>
<td>rho</td>
<td>$2600 \text{[kg/m}^3\text{]}$</td>
<td>Density</td>
</tr>
</tbody>
</table>

**GEOMETRY MODELING**

1 From the Draw menu, select Work-Plane Settings. Leave all the default values and click OK.

2 Shift-click the Reacting/Square button. Enter the following values:

<table>
<thead>
<tr>
<th>Name</th>
<th>R1</th>
<th>Width</th>
<th>1.25e-3</th>
<th>Height</th>
<th>1.25e-3</th>
<th>Base</th>
<th>Corner</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>X</td>
<td>0</td>
<td>Y</td>
<td>0</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

3 Click OK.

4 Click the Zoom Extents button on the Main toolbar.

5 To create two more rectangles, repeat Steps 2–4 twice with the following values:

<table>
<thead>
<tr>
<th>Name</th>
<th>R2</th>
<th>Width</th>
<th>750e-6</th>
<th>Height</th>
<th>750e-6</th>
<th>Base</th>
<th>Corner</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>X</td>
<td>0</td>
<td>Y</td>
<td>0</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Name</th>
<th>R3</th>
<th>Width</th>
<th>500e-6</th>
<th>Height</th>
<th>500e-6</th>
<th>Base</th>
<th>Corner</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>X</td>
<td>0</td>
<td>Y</td>
<td>0</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

6 Press Ctrl+A to select the rectangles R1, R2, and R3.

7 From the Draw menu, select Extrude. Type $5e-6$ in the Distance edit field for Extrusion parameters. Click OK.
8. Return to Geom2, then Extrude the rectangles with the Distance value -500e-6 (see Step 7). Click OK.

9. Repeat Step 8 with the distance value 20e-6. Click OK.

10. Keeping the extruded objects selected, click the Move button and type 5e-6 in the z-displacement edit field.

11. Click OK.

12. Return to Geom2 and select only object R1. Extrude it with distance value 475e-6 according to the instruction in Step 7. Click OK.

13. Return to Geom2 again, select object R2, and then select Extrude from the Draw menu.

14. Type 475e-6 in the Distance edit field, then enter 1.9/1.5 for both Scale x and Scale y.

15. Click OK.

16. Select the geometry objects EXT10 and EXT11, then click the Move button.

17. Set the z-displacement to 25e-6, then click OK.

18. With EXT10 and EXT11 selected, click the Difference button.

19. Return to Geom2 one more time.

20. Click the Projection of all 3D geometries button.

21. Shift-click the Rectangle/Square button. Define another rectangle with corner points (0, 0) and (950e-6, 950e-6). Click OK.

22. Select rectangles R1 and R4.

23. From the Draw menu, select Extrude. Type 500e-6 in the Distance edit field. Make sure that the x-scaling and y-scaling values are both set to 1, then click OK.

24. Keeping the extruded objects selected, click the Move button, and type 500e-6 in the z-displacement edit field. Click OK.

25. Select all geometry objects with Ctrl+A. Click the Create Composite Object button, then click OK.

PHYSICS SETTINGS

1. Ensure that the Model Tree appear in the left of the window. If not, click the Model Tree button on the Main toolbar.

2. Click the Detail button immediately above the Model Tree.
Subdomain Settings

1. In the Model Tree, click the + sign before the Solid, Stress-Strain (smld) node, then double-click on Subdomain Settings.

2. Select Subdomains 2 and 6, then clear the Active in this domain check box.

3. Go to Groups page and select (unnamed1). Select Glass HOYA from the Library material list.

4. In the Name edit field type Glass.

5. Go back to the Subdomain page and select Subdomains 3, 7, and 9–11.

6. Click the Load button. Select Silicon from the Basic Material Properties list.

7. Return to the Groups page and keep the (unnamed2) group selected.

8. In the Name edit field type Silicon.

9. Select both the Glass and the Silicon groups, and then go to Load page.

10. Select the Include thermal expansion check box.

11. Type T_bondingL in the Temp edit field and T_bondingH in the Tempref edit field. Click Apply.

12. Return to the Groups page and select the group Glass (this helps you to define subdomain settings for the next application mode). Click OK.

13. In the Model Tree, click the + sign before the Solid, Stress-Strain (smld2) node, then double-click on Subdomain Settings.

14. With the Glass subdomains active, select Glass HOYA from the Library material list.

15. Select Subdomains 2 and 6, then clear the Active in this domain check box.

16. Go to the Groups page.

17. Select (unnamed1) and choose Silicon from the Library material list.

18. In the Name edit field type Silicon.

19. Select (unnamed1) and in the Name edit field type Glass.

20. Select both Glass and Silicon groups and then go to Load page.

21. Select the Include thermal expansion check box.

22. Type T_ambient in the Temp edit field and T_bondingL in the Tempref edit field, then click Apply.

23. On the Initial Stress and Strain page, select the Include initial stress check box.
Define the initial stress fields according to the following table:

<table>
<thead>
<tr>
<th>INITIAL NORMAL STRESS</th>
<th>EXPRESSION</th>
<th>INITIAL SHEAR STRESS</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\sigma_{xi}$</td>
<td>sx_smsld</td>
<td>$\sigma_{yi}$</td>
<td>sxy_smsld</td>
</tr>
<tr>
<td>$\sigma_{yi}$</td>
<td>sy_smsld</td>
<td>$\sigma_{yzi}$</td>
<td>syz_smsld</td>
</tr>
<tr>
<td>$\sigma_{zi}$</td>
<td>sz_smsld</td>
<td>$\sigma_{xzi}$</td>
<td>sxz_smsld</td>
</tr>
</tbody>
</table>

Click OK.

Boundary Settings

The following steps define Boundary and Edge settings for the first application mode:

1. Double-click Boundary Settings for Solid, Stress-Strain (smsld) in the Model Tree.
2. Select Boundaries 2, 8, 12, 47, 51, 53, 55, 57, 59, and 61, then choose $x$-$z$ symmetry plane from the Constraint condition list.
3. Click Apply.
4. Select Boundaries 1, 7, 11, 15, 21, 25, 28, 31, 34, and 37, then choose $y$-$z$ symmetry plane from Constraint condition list.
5. Click OK.

The following steps define Boundary settings for the second application mode:

1. Double-click Boundary Settings for Solid, Stress-Strain (smsld2) in the Model Tree.
2. Select Boundaries 3, 17, and 27, then choose Fixed from the Constraint condition list.
3. Select Boundaries 2, 8, 12, 47, 51, 53, 55, 57, 59, and 61, then choose $x$-$z$ symmetry plane from the Constraint condition list.
4. Click Apply.
5. Select Boundaries 1, 7, 11, 15, 21, 25, 28, 31, 34, and 37, then choose $y$-$z$ symmetry plane from the Constraint condition list.
6. Click Apply.
7. Select Boundaries 6, 9, 20, 23, 29, and 54.
8. Go to the Load page.
9. From the Type of load list, select Follower load.
10. Type $P_{ambient}$ into $P$ edit field and then click OK. You define the variable $P_{ambient}$ later when specifying the parameterized solver settings.
11. Click OK.
Point Settings
1. Double-click **Point settings** for **Solid, Stress-Strain (smstd)** in the Model Tree.
2. See that the **Standard notation** button is selected. Then activate all three constraints: $R_x$, $R_y$, and $R_z$.
3. Click **OK**.

Integration Coupling Variables
The capacitance can be estimated by assuming that the gap operates as a plate capacitor. Then you can integrate the infinitesimal capacitance $C(x, y) = \varepsilon_0 / \text{gap}(x, y)$ over the surface of the membrane electrodes:
1. From the **Options** menu, select **Integration Coupling Variables＞Boundary Variables**.
2. Select Boundary 9.
3. Type $C$ in the **Name** edit field and $4*\varepsilon_0/(5[\mu m]+w2)$ in the **Expression** edit field.
4. Click **OK**.

Mesh Generation
1. From the **Mesh** menu, choose **Free Mesh Parameters**.
2. From the **Predefined mesh sizes** list, select **Fine**.
3. Change to the **Boundary** page and select Boundaries 3, 17, and 27 from the **Boundary selection** list.
4. Under **Boundary Mesh Parameters** change **Method** to **Quad**.
5. Click **Mesh Selected**.
6. Go to the **General** page, and change the **Predefined mesh sizes** list to **Normal**; Then click **OK**.
7. Select **Swept Mesh Parameters** under **Mesh** menu.
8. Select Subdomains 1–3 and 5–12.
9. Click **Mesh Selected**.
10. Keeping the **Swept Mesh Parameters** window open, select **Mapped Mesh Parameters** from the **Mesh** menu.
11. Select Boundary 13 from the boundary list and click **Mesh Selected**. Click **OK**.
12. In the **Swept Mesh Parameters** dialog box, select Subdomain 4 and then click **Mesh Selected**.
The mesh should contain about 1440 brick elements.

Figure 3-15: Element mesh for 3D pressure sensor model.

**COMPUTING THE SOLUTION**

The following steps use a static solver to first solve the bonding phase and the parametric solver to solve the sensor operation for different pressures.

To make it easier to test the model with different temperature settings, use solver scripting. Before proceeding with the steps below, go to the *Solver Manager* dialog box, click the *Script* tab, select *Automatically add commands when solving*, and then click *OK* to close the dialog box. Next perform the steps below, and finally clear the *Automatically add commands when solving* check box. Later on you can return to the *Script* page of the *Solver Manager*, select the *Solve using a script* check box, and click the *Solve* button. The script automatically performs all the steps needed for the solution.

1. From the *Solve* menu, select *Solver Parameters*.
2. On the *General* page, verify that the *Analysis* list has the selection *Static* and that the *Solver* list has the selection *Stationary*. Click *OK*.
3. From the *Solve* menu choose the *Solver Manager*; alternately, click the *Solver Manager* button on the Main toolbar.
4 On the Initial Value page the default values are correct (Initial value: Initial value expression evaluated using current solution; Value of variables not solved for and linearization point: Use setting from Initial value frame).

5 Click the Solve For tab. Select Solid, Stress-Strain (smsld) and then click Solve.

6 Keeping the Solver Manager open, select Solver Parameters from the Solve menu.

7 On the General page, select Parametric from the Solver list.

8 In the Parameter name edit field type $P_{ambient}$.

9 In the Parameter values list type 0:2e4:1e5. Click OK.

10 Go back to the Solver Manager.

11 Click the Initial Value tab.

12 In the Value of variables not solved for and linearization point area click the Current solution button.

13 Click the Solve For tab. Select Solid, Stress-Strain (smsld2) and then click Solve.

14 Click OK to close the Solver Manager.

**POSTPROCESSING AND VISUALIZATION**

**Stress Distribution**
First investigate the stresses in the sensor:

1 From the Postprocessing menu, select Plot Parameters.

2 On the General page, select the Subdomain, Edge, and Deformed shape check boxes in the Plot type area; clear all others (including Geometry).

3 On the Subdomains page, select Solid, Stress-Strain (smsld2)$>\text{von Mises stress}$ from the Predefined quantities list. Change the Unit to MPa.

4 Click the Edge tab.

5 Click first the Uniform color button and then the Color button.

6 On the Swatches page, select black. Click OK.

7 Go to the Deform page. Under Deformation Data, select Solid, Stress-Strain (smsld2)$>\text{Displacement}$ from the Predefined quantities lists for Subdomain Data, Boundary Data, and Edge Data.

8 Click OK.

For easier investigation of the stress in the membrane hide other domains except the membrane:
1 From the **Options** menu, select **Suppress>Suppress Subdomains**. From the **Subdomain Selection** list, select all subdomains except 3 and 7. Click **OK**.

2 Click the **Postprocessing Mode** button on the Main toolbar.

   Finally, show all subdomains again:

3 From the **Options** menu, select **Suppress>Suppress Subdomains**.

4 Click the **Suppress None** button, then click **OK**.

**Capacitance**

1 From the **Postprocessing** menu, select **Global Variables Plot**.

2 Type \( C \) in the **Expression** edit field, then click > to include this variable in the **Quantities to plot** list.

3 Click **OK**.
SAW Gas Sensor

Introduction

A surface acoustic wave (SAW) is an acoustic wave propagating along the surface of a solid material. Its amplitude decays rapidly, often exponentially, with the depth of the material. SAWs are featured in many kinds of electronic components, including filters, oscillators, and sensors. SAW devices typically use electrodes on a piezoelectric material to convert an electric signal to a SAW, and back again.

In this model, you investigate the resonance frequencies of a SAW gas sensor. The sensor consists of an interdigitated transducer (IDT) etched onto a piezoelectric LiNbO$_3$ (lithium niobate) substrate and covered with a thin polyisobutylene (PIB) film. The mass of the PIB film increases as PIB selectively adsorbs CH$_2$Cl$_2$ (dichloromethane, DCM) in air. This causes a shift in resonance to a slightly lower frequency.

Model Definition

Figure 3-16 shows a conceptual view of the gas sensor in this model. IDTs used in SAW devices may have hundreds of identical electrodes, and each electrode can be about 100 times longer than it is wide. You can therefore neglect the edge effects and reduce the model geometry to the periodic unit cell shown in Figure 3-17. The height of this cell does not have to extend all the way to the bottom of the substrate but only a few wavelengths down, so that the SAW has almost died out at the lower boundary. In the model, this boundary is fixed to a zero displacement.
Figure 3-16: Conceptual view of the SAW gas sensor, showing the IDT electrodes (in black), the thin PIB film (light gray), and the LiNbO$_3$ substrate (dark gray). For the sake of clarity, the dimensions are not to scale and the IDT has fewer electrodes than in common devices. A slice of the geometry is removed to reveal the modeled unit cell (in white).
Figure 3-17: The modeled geometry of the model. A 500 nm PIB film covers two 1 µm-wide electrodes on top of the LiNbO$_3$ substrate. The substrate subdomain continues below the lower frame of the picture and has a total height of 22 µm. In the first version of the model, the substrate is the only active subdomain.

You set up the model in the Piezo Plane Strain application mode, which requires the out-of-plane strain component to be zero. This should be a valid assumption, considering that the SAW is generated in the model plane and that the sensor is thick in the out-of-plane direction.

The first version of the model deals only with free SAW propagation in the LiNbO$_3$ substrate, without any applied electric field. In order to find the velocity of the wave, we use periodic boundary conditions to dictate that the voltage and the displacements be the same along both vertical boundaries of the geometry. This implies that the wavelength will be an integer fraction of the width of the geometry. The lowest SAW eigenmode has its wavelength equal to the width of the geometry, 4 µm. The eigenfrequency of this mode multiplied by 4 µm hence gives the velocity of the wave.

In a second version of the model, the aluminum IDT electrodes and the PIB film are added. This causes the lowest SAW mode to split up in two eigensolutions, the lowest one representing a series resonance, where propagating waves interfere constructively.
and the other one a parallel (“anti-”) resonance, where they interfere destructively. These two frequencies constitute the edges of the stopband, within which no waves can propagate through the IDT.

The adsorption of DCM gas is represented as a slight increase of the density of the PIB film. In the third and final version of the model, the sensor is exposed to 100 ppm of DCM in air at atmospheric pressure and room temperature. The “partial density” of DCM in the PIB film is then calculated as

$$\rho_{\text{DCM,PIB}} = KMc,$$

where $K = 10^{1.4821}$ (Ref. 1) is the air/PIB partition coefficient for DCM, $M$ is its molar mass, and

$$c = 100 \cdot 10^{-6} \cdot p/(RT)$$

is its concentration in air.

The substrate used in the simulation is YZ-cut LiNbO$_3$ with properties cited in Ref. 2. The density of the PIB film is from Ref. 1. The Poisson’s ratio is taken to be 0.48, which corresponds to a rather rubbery material. The Young’s modulus is set to 10 GPa. Even at the comparatively high frequencies considered in this model, this is likely an overestimation. However, a much lower value would result in a multitude of eigenmodes located inside the film. While those may be important to consider in designing a SAW sensor, the focus in this model is on the SAW modes. Also, any effects of the DCM adsorption on other material properties than the density are neglected.
Results

Figure 3-18 shows the SAW as it propagates along the surface of the piezoelectric substrate. The frequency corresponding to a 4 μm wavelength computes to 870 MHz, giving a phase velocity of 3479 m/s.

**Figure 3-18:** Deformed shape plot of a freely propagating SAW in the substrate. The color scale shows the magnitude of the displacements.

In the full model with the periodic IDT and the thin film included, the resonance and anti-resonance frequencies evaluate to 841 MHz and 850 MHz, respectively. Figure 3-19 and Figure 3-20 show the electric potential distribution characteristics for these solutions.
Exposing the sensor to a 100 ppm concentration of DCM in air leads to a resonance frequency shift of 227 Hz downwards. This is computed by evaluating the resonance frequency before and after increasing the density of adsorbed DCM to that of the PIB domain.

Note that the computational mesh is identical in both these solutions. This implies that the relative error of the frequency shift is similar to that of the resonance frequency itself. Thus the shift is accurately evaluated despite being a few magnitudes smaller than the absolute error of the resonance frequency.

In a real setup, the drift is often measured by mixing the signal from a sensor exposed to a gas with a reference signal from one protected from the gas. The beat frequency then gives the shift.
Figure 3-20: Electric potential distribution and deformations at antiresonance, 851 MHz. The potential is antisymmetric with respect to the center of the electrodes.

References


Model Library path: MEMS_Module/Sensor_Models/SAW_gas_sensor

Modeling Using the Graphical User Interface

MODEL NAVIGATOR

1. Open the Model Navigator and click the New tab.
2. From the **Space dimension** list, select **2D**.

3. In the list of application modes, select **MEMS Module>Structural Mechanics>Piezo Plane Strain> Eigenfrequency analysis**.

4. Click **OK**.

**GEOMETRY MODELING**

1. Create the following rectangles by repeatedly using **Draw>Specify Objects>Rectangle**. Click **OK** after specifying the data for each rectangle.

<table>
<thead>
<tr>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>BASES: CORNER X</th>
<th>BASE: CORNER Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>4</td>
<td>22</td>
<td>0</td>
<td>-22</td>
</tr>
<tr>
<td>1</td>
<td>0.2</td>
<td>0.5</td>
<td>0</td>
</tr>
<tr>
<td>1</td>
<td>0.2</td>
<td>2.5</td>
<td>0</td>
</tr>
<tr>
<td>4</td>
<td>0.5</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

2. Select all objects and choose **Draw>Modify>Scale**. In the dialog box that appears, enter **1e-6** for both scale factors; then click **OK**.

3. Click the **Zoom Extents** button on the Main toolbar to zoom in on the now micron-sized geometry.

**OPTIONS AND SETTINGS**

1. Choose **Options>Constants**.

2. Define the following constant names, expressions, and (optionally) descriptions:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>p</td>
<td>101.325[kPa]</td>
<td>Air pressure</td>
</tr>
<tr>
<td>T</td>
<td>25[degC]</td>
<td>Air temperature</td>
</tr>
<tr>
<td>R</td>
<td>8.3145[Pa<em>m^3/(K</em>mol)]</td>
<td>Gas constant</td>
</tr>
<tr>
<td>c_DCM_air</td>
<td>1000e-6<em>p/(R</em>T)</td>
<td>DCM concentration in air</td>
</tr>
<tr>
<td>M_DCM</td>
<td>84.93[g/mol]</td>
<td>Molar mass of DCM</td>
</tr>
<tr>
<td>K</td>
<td>10^1.4821</td>
<td>PIB/air partition constant for DCM</td>
</tr>
<tr>
<td>rho_DCM_PIB</td>
<td>K<em>M_DCM</em>c_DCM_air</td>
<td>Mass concentration of DCM in PIB</td>
</tr>
<tr>
<td>rho_PIB</td>
<td>0.918[g/cm^3]</td>
<td>Density of PIB</td>
</tr>
<tr>
<td>E_PIB</td>
<td>10[GPa]</td>
<td>Young's modulus of PIB</td>
</tr>
<tr>
<td>nu_PIB</td>
<td>0.48</td>
<td>Poisson's ratio of PIB</td>
</tr>
<tr>
<td>eps_PIB</td>
<td>2.2</td>
<td>Relative permittivity of PIB</td>
</tr>
</tbody>
</table>
PHYSICS SETTINGS
In the first version of the model, you compute the velocity for SAW propagation in a homogenous, electrically insulated LiNbO$_3$ substrate. The supplied material data are with reference to the xy-plane.

**Subdomain Settings**
1. From the Physics menu, open the Subdomain Settings dialog box.
2. Select Subdomains 2–4, then clear the Active in this domain check box.
3. Select Subdomain 1, then select xy plane from the Material orientation list.
4. Click the Edit button associated with $c_E$. Enter the following values in the Elasticity matrix dialog box; when finished, click OK.
   
   $$
   \begin{pmatrix}
   2.424e+11 & 0.752e+11 & 0.752e+11 & 0 & 0 & 0 \\
   2.03e+11 & 0.573e+11 & 0 & 0.085e11 & 0 \\
   2.03e+11 & 0 & -0.085e11 & 0 \\
   0.752e11 & 0 & 0.085e11 & 0.595e11 & 0 \\
   0.595e11 & 0 
   \end{pmatrix}
   $$

5. Click the Edit button associated with $e$. Enter the following values in the Coupling matrix dialog box; when finished, click OK.

   $$
   \begin{pmatrix}
   1.33 & 0.23 & 0.23 & 0 & 0 & 0 \\
   0 & 0 & 0 & -2.5 & 0 & 3.7 \\
   0 & -2.5 & 2.5 & 0 & 3.7 & 0 
   \end{pmatrix}
   $$

6. Click the Edit button associated with $\varepsilon_{rS}$. Enter the following values in the Relative permittivity dialog box; when finished, click OK.

   $$
   \begin{pmatrix}
   28.7 & 0 & 0 \\
   85.2 & 0 \\
   85.2 
   \end{pmatrix}
   $$

7. In the Density edit field, type 4647.
8. Click OK to close the Subdomain Settings dialog box.

**Boundary Conditions**
1. From the Physics menu, choose Boundary Settings.
2. Select Boundary 2, then set the Constraint condition to Fixed.
3. Select all exterior boundaries (Boundaries 1, 2, 4, 7, 10, 12, 15, and 16).
4 On the Electric BC page, set the Boundary condition to Zero charge/Symmetry.
5 Click OK.
6 Choose Physics>Periodic Conditions>Periodic Boundary Conditions.
7 On the Source page, select Boundary 1. On the first row in the Expression column, type u, then press Enter; the software automatically adds the corresponding Constraint name pconstr1 to the table.
8 On the Destination page, check Boundary 16 and type u in the Expression edit field.
9 On the Source Vertices page, Ctrl-click to select Vertices 1 and 2, then click the >> button.
10 On the Destination Vertices page, Ctrl-click to select Vertices 12 and 13, then click the >> button.
11 Repeat Steps 7 through 10 to define the expressions v and V in an analogous fashion, starting by entering them in the Expression edit field on the Source page, on the 2nd and 3rd row, respectively.
12 When done, click OK to close the Periodic Boundary Conditions dialog box.

Mesh Generation
1 Choose Mesh>Free Mesh Parameters.
2 From the Predefined mesh sizes list, choose Extremely fine.
3 On the Subdomain page, select all subdomains and set the Method to Quad.
4 On the Boundary page, select the upper boundaries of the substrate (Boundaries 4, 7, 10, 12, and 15) and set the Maximum element size to 0.05e-6.
5 Click Remesh, then click OK. When done, a zoom-in on the upper part of the geometry should look like Figure 3-21.
Computing the Solution

1. From the Solve menu, open the Solver Parameters dialog box.
2. Enter 850e6 in the Search for eigenfrequencies around edit field, then click OK.
3. Click the Solve button on the Main toolbar.

Postprocessing and Visualization

The solver returns 6 eigensolutions with eigenfrequencies in the vicinity of 850 MHz. At 869.8 MHz, two of them are—within the numerical accuracy—the same. These show the shape and the frequency for a SAW with wavelength equal to the width of the geometry.

1. From the Postprocessing menu, open the Plot Parameters dialog box.
2. On the General page, select one of the eigenfrequencies equal to 869.8 MHz.
3. On the Deform page, select the Deformed shape plot check box. Clear the Auto check box and type 400 in the Scale factor edit field.
4 Click OK to close the dialog box and see a plot of the total displacement. If you want to, you can repeat the procedure with the other solution to verify that they are the same, only shifted by 90 degrees. One of the solutions look like that in Figure 3-18.

5 To evaluate the velocity, choose Postprocessing>Data Display>Global.

6 In the Expression edit field, type eigfreq_smppn*4[um].

7 In the Eigenfrequency list, select one of the 869.8 MHz entries.

8 Click OK to see the value of the velocity in the message log. It evaluates to approximately 3479 m/s.

This concludes the first part of the model. Proceed to find out how the electrodes and the PIB film affect the behavior of the SAW.

Sensor without Gas Exposure

Subdomain Settings

1 From the Physics menu, open the Subdomain Settings dialog box.

2 Select Subdomains 2–4, then select the Active in this domain check box.

3 From the Material model list, select Decoupled, isotropic.

4 Select only Subdomain 2.

5 On the Structural page, enter E_PIB for the Young’s modulus, nu_PIB for the Poisson’s ratio, and rho_PIB for the Density.

6 On the Electrical page, select the Enable electrical equation check box and enter eps_PIB in the Relative permittivity edit field.

7 Select Subdomains 3 and 4, then click the Load button.

8 In the Materials/Coefficients Library dialog box, select Basic Material Properties>Aluminum and click OK.

9 Click OK to close the Subdomain Settings dialog box.

Boundary Conditions

1 From the Physics menu, choose Boundary Settings.

2 Select the Interior boundaries check box.

3 Select Boundaries 6–9 and 11–14. On the Electric BC page, set the condition to Electric potential. Keep the default zero potential.

4 Select Boundaries 3, 5, and 17, and set the condition to Zero charge/Symmetry.

5 Click OK to close the dialog box.
**Note:** The eigenfrequencies and hence the stopband do not depend on the values of the potentials. In fact, for linear eigenfrequency problems, they are automatically set to zero at the electrodes, regardless of the applied value. You can solve the corresponding driven problem by switching to a frequency response analysis and applying different potentials to the electrodes.


7. On the Source page, select Boundary 3. Enter \( u \) in the first Expression edit field and \( v \) in the row below, and \( V \) in the third row.

8. Click the Destination tab.

9. From the Constraint name list, select pconstr1; check Boundary 17 (in addition to the already selected Boundary 16); and type \( u \) in the Expression edit field.

10. From the Constraint name list, select pconstr2; check Boundary 17; and type \( v \) in the Expression edit field.

11. From the Constraint name list, select pconstr3; check Boundary 17; and type \( V \) in the Expression edit field.

12. Click OK to close the dialog box.

You have now established the periodicity in the PIB film.

**COMPUTING THE SOLUTION**

Click the Solve button on the Main toolbar.

**POSTPROCESSING AND VISUALIZATION**

If you are still using the manual scaling of the deformations from the previous exercise, the plot that appears after solving will look rather distorted. Proceed as follows to find the SAW modes and use more suitable plot parameters:

1. From the Postprocessing menu, open the Plot Parameters dialog box.

2. On the General page, select the 850 MHz eigenfrequency.

3. On the Deform page, type 40 in the Scale factor edit field.

4. Click Apply to view a plot of the total displacement at anti-resonance.

5. On the General page, select the 841 MHz eigenfrequency, then click Apply to see the deformations at resonance. This plot should look like Figure 3-22.
Figure 3-22: Deformations at resonance.

A plot of the electric potential shows a qualitative difference between the two solutions.

6 On the Surface page, select Piezo Plane Strain (smppn)>Electric potential from the Predefined quantities list.

7 Click Apply to see the potential distribution at resonance, as shown in Figure 3-19 on page 195. Notice that it is symmetric with respect to each individual electrode.

8 On the General page, select the 850 MHz eigenfrequency and click OK to see the potential distribution at anti-resonance, as in Figure 3-20 on page 196. This time, it is antisymmetric.

Sensor with Gas Exposure

In the final version of this model, you expose the sensor to DCM gas. The eigenfrequencies then shift by a very small amount. To see the shift, you need to include more digits in the output.

1 Choose Postprocessing>Data Display>Global.
2 Enter the expression `eigfreq_smppn` and select the 841 MHz eigenfrequency.

3 Select the Display result in full precision check box, then click OK.

The message log now shows all computed digits of the eigenfrequency.

**Subdomain Settings**

1 From the Physics menu, select Subdomain Settings.

2 Select Subdomain 2. On the Structural page, change the Density so that it reads `rho_PIB+rho_DOM_PIB`.

3 Click OK to close the Subdomain Settings dialog box.

**Computing the Solution**

Click the Solve button.

**Postprocessing and Visualization**

1 Choose Postprocessing>Data Display>Global.

2 Make sure that the expression still says `eigfreq_smppn` and select the 841 MHz eigenfrequency.

3 Click OK.

The first 6 digits of the eigenfrequency are the same as before. Subtracting the new value from the previous value (which is most easily done by copying and pasting the results from the message log) shows that the eigenfrequency with gas exposure is lower by 227 Hz.
Thermal Expansion in a MEMS Device

The purpose of this model is to exemplify the use of the Material Library in COMSOL Multiphysics. This library contains more than 20,000 property functions for 2500 materials. The larger part of these properties are mechanical and thermal properties for solid materials given as functions of temperature. You need the Material Library to build the model.

Introduction

Thermal expansion is a common method used in the microscale to displace a part of a component, for example in an actuator. In this example model the opposite is required; that is, there should be a minimum of thermal expansion. Such a device could be included in a microgyroscope or any other sensor for acceleration or positioning.

Model Definition

Figure 3-23 below shows the model geometry:

![Figure 3-23: Geometry of the device.](image)

Surfaces attached to a solid frame
The model consists of two sets of physics:

- A thermal balance with a heat source in the device, originating from Joule heating (ohmic heating). Air cooling is applied on the boundaries except at the position where the device is attached to a solid frame, where an insulation condition is set.
- A force balance for the structural analysis with a volume load caused by thermal expansions. The device is fixed at the positions where it is attached to a solid frame (see Figure 3-23).

The device is made of the copper-beryllium alloy UNS C17500.

The thermal balance consists of a balance of flux at steady state. The heat flux is given by conduction only. The heat source is a constant heat source of $1 \cdot 10^8$ W/m$^3$. The air cooling at the boundaries is expressed using a constant heat transfer coefficient of 10 W/m$^2$ and an ambient temperature of 298 K.

The stress and strains are well within the elastic region for the material. The expression for thermal expansion requires a strain reference temperature for the copper-beryllium alloy, which in this case is 293 K.

All other thermal and mechanical properties are obtained from the Material Library.

**Results and Discussion**

The following figure shows the temperature distribution in the device. The heat source increases the temperature to 323 K from an ambient temperature of 298 K. The temperature varies less than 1/100 of a degree in the device. The displacements vary
accordingly, and the model shows that it is possible to study the device using only one unit cell, for example, 1/2 of a U-shaped section.

*Figure 3-24: Temperature and displacement of the device. The edges of the original geometry are shown in black. The deformed shape is exaggerated by a factor of almost 200.*

The following figure (Figure 3-25) shows the displacement of a curve that follows the top inner edges of the device from left to right. It is clear from Figure 3-25 that the displacement follows a repetitive pattern along the length of the device. This also
supports the hypothesis that 1/2 of a U-shaped section is enough to represent the behavior of the device.

![Graph of Displacement along the Inner Edge](image)

**Figure 3-25:** The displacement along the inner edge of the device shows a repetitive pattern, which means that a model of half of the u-shaped structure is enough to study the effects of thermal expansion on the device.

---

**Model Library path:** MEMS_Module/Sensor_Models/thermal_expansion

---

**Modeling Using the Graphical User Interface**

1. Open the **Model Navigator**.
2. Select **3D** from the **Space dimension** list.
3. Select **MEMS Module>Thermal-Structural Interaction>Solid, Stress-Strain with Thermal Expansion>Static analysis**.
4. Click **OK**.

---

**GEOMETRY MODELING**

1. From the **Draw** menu, select **Work-Plane Settings**.
2. Click the **x-y** plane option button if it is not already selected.
3. Click **OK**.
4. From the **Options** menu, select **Axes/Grid Settings**.
5. Enter `-1.3e-4` in the **x min** edit field, `1.3e-4` in the **x max** edit field, `-0.3e-4` in the **y min** edit field, and `1.3e-4` in the **y max** edit field.
6. Click the Grid tab.

7. Clear the Auto check box.

8. Enter 1e-5 in the x spacing and 1e-5 in the y spacing edit fields, respectively.

9. Click OK.

Next, draw a projection of the 3D geometry and then extrude it to create a 3D object:

1. From the Draw menu, select Specify Objects>Rectangle.

2. Type 1e-5 in the Width and 8e-5 in the Height edit fields, respectively.

3. Type -1e-4 in the x edit field in the Position area using the Corner option in the Base list.

4. Click OK.

5. Click the 2nd Degree Bézier Curve button on the Draw toolbar.

6. Click the coordinates (−9e-5, 8e-5), (−9e-5, 9e-5), and (−8e-5, 9e-5) to create an arc.

7. Click the Line button on the Draw toolbar.

8. Click the coordinate (−8e-5, 1e-4).

9. Click the 2nd Degree Bézier Curve button on the Draw toolbar.

10. Click the coordinates (−1e-4, 1e-4) and (−1e-4, 8e-5).

11. Click the right mouse button to form a composite object with the shape of an elbow.

12. Press Ctrl+A to select all objects.

13. Click the Mirror button on the Draw toolbar.
14 Enter \(-8\times10^{-5}\) in the \(x\) edit field in the \textbf{Point on line} row in the \textbf{Mirror} dialog box. Make sure that the normal vector of the line has the default values \((1, 0)\).

15 Click \textbf{OK}.

16 Press Ctrl+A to select and Ctrl+C to copy all objects.
17 Press Ctrl+V to open the \textbf{Paste} dialog box.
18 In the \textbf{Displacement} area, type \(5\times10^{-5}\) in the \(x\) edit field.
19 Click \textbf{OK} to paste all objects.
20 Press Ctrl+A to select and Ctrl+C to copy all objects.
21 Press Ctrl+V to open the \textbf{Paste} dialog box.
22 In the \textbf{Displacement} area, type \(1\times10^{-4}\) in the \(x\) edit field.
23 Click \textbf{OK} to paste all objects.
Click Zoom Extents.

From the Draw menu, select Specify Objects>Rectangle.

Enter 3e-5 in the Width, 1e-5 in the Height, and -7e-5 in the x edit fields, respectively.

Click OK.

Press Ctrl+C followed by Ctrl+V to copy and paste the selected rectangle.

In the Displacement area, type 5e-5 in the x edit field.

Click OK.

Press Ctrl+C followed by Ctrl+V to copy and paste the selected rectangle.

In the Displacement area, type 5e-5 in the x edit field.

Click OK.

Press Ctrl+A and click the Union button on the Draw toolbar to create one composite object.

From the Draw menu, select Extrude.

Enter 1e-5 in the Distance edit field.

Click OK.

Click the Headlight button on the Camera toolbar.

The completed geometry in the drawing area should now look like that in the following figure.
PHYSICS SETTINGS

Start by setting the properties and boundary conditions for the thermal analysis.

**Note:** If your license includes the Heat Transfer Module, the General Heat Transfer application mode replaces the Heat Transfer by Conduction application mode, but the modeling steps are the same.

*Subdomain Settings—Heat Transfer by Conduction*

1. From the **Physics** menu, select **Subdomain Settings**.
2. Click the **Subdomain selection** list and press Ctrl+A to select all subdomains.
3. Click the **Load** button.
4. Click the **Material Library** node, which is second in the **Materials** list.
5. Click the **Al & Cu Alloys** node.
6. Click the **Copper Alloys** node.
7 Select the copper alloy **UNS C17500** from the list.

8 Click **OK**.

9 Enter **1e8** in the **Heat source** edit field.

10 Click **OK**.

*Boundary Conditions—Heat Transfer by Conduction*

1 From the **Physics** menu, select **Boundary Settings**.
2 Click the **Boundary selection** list.

3 Press Ctrl+A to select all boundaries.

4 In the **Boundary selection** list, press Ctrl and click Boundaries 2, 17, 26, 32, 52, 61, 67, 87, 96, 102, and 122 to clear them from the current selection. Note that you can also do this directly in the user interface by selecting all boundaries, clicking the right mouse button to keep the selection, and then selecting the boundaries corresponding to the attachment to the base one at the time. When you click on a boundary, it turns green. If this is the boundary you want to clear from the selection list, click the right mouse button. Repeat this procedure until all boundaries listed above are cleared from the selection.

5 Select **Heat flux** from the **Boundary condition** list.

6 Enter 10 in the **Heat transfer coefficient** edit field and 298 in the **External temperature** edit field.

7 Click **OK**.

**Subdomain Settings—Solid, Stress-Strain**

1 From the **Multiphysics** menu, select the **Solid, Stress-Strain (smsld)** application mode.

2 From the **Physics** menu, select **Subdomain Settings**.

3 Select all the subdomains in the **Subdomain selection** list, if they are not already selected.

4 In the **Library material** list, select **UNS C17500**.

5 Click the **Load** tab. Notice that the **Include thermal expansion** check box is selected and that the variable for the temperature field, $T$, and the correct strain reference temperature, 293 K, already appear in the **Strain temperature** and **Strain ref. temperature** edit fields (these are the default settings provided by the Thermal-Structural Interaction predefined multiphysics coupling).

You can get the strain reference temperature from the Material Library. In this case, it is included in the notes for the thermal expansion coefficient function, alpha, in the Material Library.

6 Click **OK**.

**Boundary Settings—Solid, Stress-Strain**

1 From the **Physics** menu, select the **Boundary Settings**.

2 Click the **Boundary selection** list and press Ctrl+D to clear the current selection.

3 Press Ctrl and click Boundaries 2, 17, 26, 32, 52, 61, 67, 87, 96, 102, and 122 to select the surfaces attached to the solid frame.
4 Select **Fixed** from the **Constraint condition** list.

5 Click **OK**.

**MESH GENERATION**

1 Click the **Interactive Meshing** button on the Mesh toolbar.

2 Select Boundary 2, which is the left-most boundary attached to the solid frame.

3 Click the **Decrease Mesh Size** button on the Mesh toolbar to decrease the mesh size from normal to fine.

4 Click the **Decrease Mesh Size** button a second and a third time to decrease the mesh size to extra fine.

5 Click the **Mesh Selected (Mapped)** button on the Mesh toolbar.

6 Click the **Subdomain Mode** button on the Main toolbar.

7 Select Subdomains 1–5, which are the five first domains from left to right. Note that you can do this by clicking the mouse until you get the desired subdomain highlighted, then you can right-click to save the selection. Then continue to the next subdomain, highlight it by clicking on it, and right-click to save the selection and so on until you have selected all five subdomains.

8 Click the **Mesh Selected (Swept)** button on the Mesh toolbar.

   The reason for not sweeping the mesh throughout all subdomains is that the meshing of the cube sections, which unite the U-shaped sections of the geometry, requires that you change the sweep direction in order to create only hexagonal mesh elements. If you instead mesh all U-shaped sections first, COMSOL Multiphysics detects the sweep dimension automatically by the fact that two opposite faces of the cubes are meshed. You can therefore first create a swept mesh for all U-shaped sections and then mesh the cubes to create a hexagonal mesh for the whole geometry.

9 Click the **Boundary Mode** button on the Main toolbar.

10 Select Boundaries 32, 67, and 102 by clicking on them in the user interface. Note that you can use the same strategy as outlined above—that is, to click on the desired boundary until it gets highlighted—then right-click to save the selection, and so on for multiple selections.

11 Click the **Mesh Selected (Mapped)** button on the Mesh toolbar.

12 Click the **Subdomain Mode** button on the Main toolbar.

13 Press Ctrl+D to clear the current selection.
Select Subdomains 7–12, 14–19, and 21–25 by using the strategy outlined in Step 7 above.

Click the Mesh Selected (Swept) button on the Mesh toolbar.

Select Subdomains 6, 13, and 20.

Click the Mesh Selected (Swept) button on the Mesh toolbar.

**Computing the Solution**

Click the Solve button on the Main toolbar. The default solver settings use the segregated stationary solver to solve the heat equation first because it does not depend on the structural analysis.

**Postprocessing and Visualization**

To generate the plot in Figure 3-24, visualizing the surface temperature and the structural deformation of the device, follow these instructions:

1. Click the Plot Parameters button on the Main toolbar.
2. Click the General tab.
3. Clear the Slice check box.
4. Select the Boundary check box.
Select the Deformed shape check box.

Click the Boundary tab.

In the Expression edit field type T.

Click the Deform tab.

On the Subdomain Data page, select Solid, Stress-Strain (smsld)>Displacement in the Predefined quantities list (the default option).

Click OK.

Create the deformation plot in Figure 3.25 as follows:

Choose Postprocessing>Domain Plot Parameters.

Click the Line/Extrusion tab.

Select the inner boundary segments marked in the following figure. Right-click to add a segment that you have highlighted in red by clicking with the mouse to the selection. The segment then turns blue in the drawing area. Repeat this procedure until you have selected all inner boundary segments (Edges 3, 12, 15, 19, 26, 27,
In the Predefined quantities list select Solid, Stress-Strain (smalld)>Total displacement.

On the General page, click the Title/Axis button.

Click the option button next to the Title edit field. Leave the edit field empty to obtain a plot without title.

Click the option button next to the First axis label edit field, then enter the label Position along the edge [m].

Click the option button next to the Second axis label edit field, then enter the label Displacement [m].

Click OK to close the Title/Axis Settings dialog box.

Click OK to close the Domain Plot Parameters dialog box and generate the plot.
Microfluidics Models

This chapter presents several microfluidics models including those that describe AC electrokinetically adjusted fluid flow in a microchannel, pressure-driven flow and electrophoresis in a microchannel system, fluid-structure interaction, fluid flow in a star-shaped microchannel, capillary filling, droplet breakup, and electroosmotic flow and lamella micromixer models.
AC Electrokinetically Enhanced Surface Reactions

Introduction

This model studies the use of AC electrokinetic forces to enhance the rate of transport of reactants to a reaction surface on the wall of a microchannel. It was developed for the MEMS Module by Gaurav Soni, Marin Sigurdson, and Carl Meinhart of the Department of Mechanical and Environmental Engineering, University of California, Santa Barbara.

The modeled system mixes a small concentration of a biological analyte with the fluid in a microchannel where a reaction surface is located on the channel walls. The flow velocity perpendicular to the surface is so small that the analyte, which is supposed to bind to an antibody ligand on this surface, is transported mainly by diffusion. The rate of the binding reaction on the surface is usually large enough to bind practically all analyte molecules appearing there. Thus, the process is said to be transport limited and, in order to increase the reaction rate, the system must increase the transport of molecules to the reaction surface.

AC electrokinetic forces can generate swirling patterns in the fluid and thereby enhance the transport of the analyte to the reaction surface (Ref. 1). Biological immunoassays, which detect an analyte through their binding response to an antibody ligand, can use these flow patterns to great advantage.

The AC electrokinetic forces arise when the fluid absorbs energy from an applied nonuniform AC electric field by means of Joule heating. The temperature increase changes the fluid’s conductivity and permittivity. Consequently the fluid experiences an effective or time-averaged volume force, which depends on the conductivity and permittivity gradients and on the field intensity. By changing the shape of the electric field it is possible to alter the fluid-flow pattern so that required amounts of analyte molecules reach the reaction surface.

Model Definition

Figure 4-1 shows the model geometry, which consists of a section of the channel 40 µm high and 250 µm long. Two electrodes, each 60 µm wide, are located on the
lower boundary at distances of 50 \( \mu \text{m} \) and 130 \( \mu \text{m} \) from the inlet. The reaction surface, 20 \( \mu \text{m} \) wide, is located on the top wall, 90 \( \mu \text{m} \) from the inlet.

The fluid flows from left to right. The incoming flow profile is characteristic for fully developed laminar flow, that is, it is parabolic with zero velocity at the channel walls. An applied electrothermal force creates swirling patterns in the flow at the channel’s center.

The two electrodes produce an AC electric field that heats the fluid and creates the electrothermal force. The model assumes that the electrodes are perfect heat conductors and remain at a constant ambient temperature. At the inlet and the outlet, the temperature gradually approaches the ambient. At all other boundaries the model assumes that the channel is thermally and electrically insulated.

The incoming flow has a small concentration of a biological analyte, which the reaction surface on the upper boundary transports and adsorbs. Any remaining concentration exits the channel with the fluid at the right boundary.

Having solved for the steady-state flow for a given electric field and the resulting electrothermal force, this example reviews a transient simulation of the material balance of the analyte, assuming that the initial concentration in the channel is zero and that a given concentration of the analyte is injected at the inlet at time zero.

Figure 4-1: Model geometry for the microchannel with electrodes and a reaction surface.

**FLUID FLOW**

Fluid flow in the channel follows the Navier-Stokes equations

\[
\rho \frac{\partial \mathbf{u}}{\partial t} - \eta \nabla^2 \mathbf{u} + \rho \mathbf{u} \cdot \nabla \mathbf{u} + \nabla p = \mathbf{F}
\]

\[
\nabla \cdot \mathbf{u} = 0
\]
where \( \mathbf{u} \) denotes the velocity, \( \rho \) is the density, \( \eta \) is the dynamic viscosity, and \( p \) refers to the pressure. At steady state, the first time-dependent term disappears. The volume force \( \mathbf{F} \) appearing in the equation is the electrothermal force \( \mathbf{f}_E \) given by

\[
\mathbf{F} = \mathbf{f}_E
\]

\[
\mathbf{f}_E = -0.5 \left[ \nabla \frac{\sigma}{\varepsilon} + \frac{\varepsilon}{\sigma} \right] \cdot \mathbf{E} - \frac{\varepsilon}{1 + (\omega \tau)^2} \left( \frac{1}{2} |\mathbf{E}|^2 \right) \nabla \varepsilon
\]  

(4-1)

where \( \sigma \) is the conductivity, \( \varepsilon = \varepsilon_r \varepsilon_0 \) equals the fluid’s permittivity, \( \omega \) represents the electric field’s angular frequency, and \( \tau = \varepsilon / \sigma \) gives the fluid’s charge-relaxation time. The field vector \( \mathbf{E} \) contains the amplitude and orientation of the AC electric field but not its instantaneous value.

The following table gives the input data for the model:

<table>
<thead>
<tr>
<th>NAME</th>
<th>VALUE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \rho )</td>
<td>1000 kg/m(^3)</td>
<td>Density of water</td>
</tr>
<tr>
<td>( \eta )</td>
<td>1.08 \times 10^{-3} kg/(m\cdot s)</td>
<td>Dynamic viscosity of water</td>
</tr>
<tr>
<td>( \sigma )</td>
<td>5.75 \times 10^{-2} S/m</td>
<td>Conductivity of water</td>
</tr>
<tr>
<td>( \varepsilon_r )</td>
<td>80.2</td>
<td>Relative permittivity of water</td>
</tr>
<tr>
<td>( \omega )</td>
<td>2\pi \times 15 \times 10^{3} rad/s</td>
<td>Angular frequency of the AC electric field</td>
</tr>
</tbody>
</table>

As a result of Joule heating, \( \varepsilon \) and \( \sigma \) are temperature dependent. You can rewrite the gradients of these entities using chain differentiation, which yields

\[
\nabla \varepsilon = (\partial \varepsilon / \partial T) \nabla T
\]

and

\[
\nabla \sigma = (\partial \sigma / \partial T) \nabla T
\]

where \( T \) is the fluid’s temperature. For water,

\[
(1 / \varepsilon)(\partial \varepsilon / \partial T) = -0.004 \text{ K}^{-1}
\]

and

\[
(1 / \sigma)(\partial \sigma / \partial T) = 0.02 \text{ K}^{-1}
\]

Thus you can rewrite the electrothermal force (Equation 4-1) as
The following table contains the boundary conditions for the incompressible Navier-Stokes equations:

<table>
<thead>
<tr>
<th>BOUNDARY</th>
<th>CONDITION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left</td>
<td>Parabolic inflow with average velocity 0.1 mm/s and zero velocity at the upper and lower boundaries</td>
</tr>
<tr>
<td>Upper</td>
<td>No slip condition</td>
</tr>
<tr>
<td>Lower</td>
<td>No slip condition</td>
</tr>
<tr>
<td>Right</td>
<td>Outflow with pressure ( p = 0 )</td>
</tr>
</tbody>
</table>

**ELECTROSTATICS**

Because the electrothermal force is a time-averaged entity, it is sufficient to solve the static electric field that corresponds to the root mean square (rms) value of the AC field. The rms value of the AC voltage is \( V_{\text{rms}} = 10 \text{ V} \).

To solve the electrostatics problem, turn to Laplace’s equation

\[
- \nabla \cdot (\varepsilon \nabla V) = 0
\]

with

\[
E = -\nabla V
\]

and the constitutive equation

\[
D = \varepsilon_0 \varepsilon_r E
\]

The boundary conditions for the electrostatic problem are as follows:

<table>
<thead>
<tr>
<th>BOUNDARY</th>
<th>CONDITION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left electrode</td>
<td>Electric potential, ( V = V_{\text{rms}}/2 = 5 \text{ V} )</td>
</tr>
<tr>
<td>Right electrode</td>
<td>Electric potential, ( V = -V_{\text{rms}}/2 = -5 \text{ V} )</td>
</tr>
<tr>
<td>Other boundaries</td>
<td>Electric insulation</td>
</tr>
</tbody>
</table>

**HEAT TRANSFER**

The power that a unit volume of fluid absorbs through Joule heating is

\[
Q = \sigma |E|^2
\]
where $E$ is the rms value of the electric field and $\sigma$ is the fluid’s conductivity. The heat source, $Q$, appears in the stationary heat balance equation

$$\nabla \cdot (-k \nabla T) = Q - \rho C_p u \cdot \nabla T$$

where $C_p$ denotes the heat capacity and $k$ is the fluid’s thermal conductivity.

The following table gives the relevant input data for the heat-transfer problem:

<table>
<thead>
<tr>
<th>NAME</th>
<th>VALUE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\rho$</td>
<td>1000 kg/m$^3$</td>
<td>Density of water</td>
</tr>
<tr>
<td>$C_p$</td>
<td>$4.184 \times 10^3$ J/(kg·K)</td>
<td>Heat capacity of water</td>
</tr>
<tr>
<td>$k$</td>
<td>0.598 W/(m·K)</td>
<td>Thermal conductivity of water</td>
</tr>
</tbody>
</table>

In general, the Navier-Stokes equations along with the convection and conduction equation form a coupled system that you should solve simultaneously.

This example assumes an ambient temperature $T = 0$ °C, and the electrodes are held steady at this temperature. The flow rate is small, and you can therefore assume that the temperature decreases symmetrically at the inlet and the outlet. The magnitude of the temperature gradient at both boundaries is such that the fluid reaches the ambient temperature at a distance of 1 mm from the boundary. At all other boundaries the model assumes that the channel is insulated.

**CONVECTION AND DIFFUSION OF THE ANALYTE**

The material balance of the analyte comes from the equation

$$\delta_t \frac{\partial c}{\partial t} + \nabla \cdot (-D \nabla c) = R - u \cdot \nabla c,$$

where $D$ denotes the diffusion coefficient and $R$ represents the reaction rate. Here $R$ equals zero because no reactions take place in the bulk of the fluid, only on the reaction surface.

The boundary conditions are as follows:

<table>
<thead>
<tr>
<th>BOUNDARY</th>
<th>CONDITION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left</td>
<td>The incoming flow has constant analyte concentration</td>
</tr>
<tr>
<td>Right</td>
<td>Remaining concentration leaves the system through convection</td>
</tr>
</tbody>
</table>
The following table gives the input data for the material balance:

<table>
<thead>
<tr>
<th>NAME</th>
<th>VALUE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\delta_{ts}$</td>
<td>1</td>
<td>Time-scaling coefficient</td>
</tr>
<tr>
<td>$D$</td>
<td>$1 \cdot 10^{-11}$ m$^2$/s</td>
<td>Diffusivity of the analyte in the fluid</td>
</tr>
<tr>
<td>$R$</td>
<td>0 M/s</td>
<td>No reaction takes place within the fluid</td>
</tr>
<tr>
<td>$c_0$</td>
<td>1 nM = 1µmol/m$^3$</td>
<td>Inlet analyte concentration</td>
</tr>
</tbody>
</table>

**BINDING REACTION**

The reaction surface contains a total concentration $R_t$ of antibody ligands. The portion of the bonded molecules is the concentration $B$. The binding rate depends on the analyte concentration on the surface, $c$, on the concentration of free antibodies, and on the association rate constant, $k_{on}$. Similarly, bonded antibodies dissociate with a rate that depends on the concentration of the bonded ligands and on the dissociation rate constant, $k_{off}$. Therefore, the equation that describes the material balance of adsorbed species (see Ref. 2) is:

$$\frac{dB}{dt} = k_{on} c (R_t - B) - k_{off} B \quad (4-2)$$

The reaction rate of the analyte on the surface equals the negative of the binding rate on the surface.

The table below gives the input data for the material balance of the adsorbed species:

<table>
<thead>
<tr>
<th>NAME</th>
<th>VALUE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>$k_{on}$</td>
<td>$10^5$ (M·s)$^{-1}$ = $10^5$ m$^2$/mol·s</td>
<td>Association rate constant</td>
</tr>
<tr>
<td>$k_{off}$</td>
<td>0.02 s$^{-1}$</td>
<td>Dissociation rate constant</td>
</tr>
<tr>
<td>$R_t$</td>
<td>$1.67 \cdot 10^{-11}$ M·m = $1.67 \cdot 10^{-8}$ mol/m$^2$</td>
<td>Total surface concentration of the antibody ligand</td>
</tr>
</tbody>
</table>

The model assumes that the antibodies do not diffuse on the surface and that there is no leakage of the molecules at the edges of the surface.
To study the effect of the applied electric field, you first run the model with \( V_{\text{rms}} = 0 \) V and then repeat the simulation for \( V_{\text{rms}} = 10 \) V.

**STEP-RESPONSE ANALYSIS**

Another interesting aspect to analyze is the system’s behavior when injecting a fixed amount of analyte over a limited time with a sudden cutoff in the analyte supply. To simulate such an experiment, use the analyte inlet concentration expression

\[
e(t) = \begin{cases} 
    c_0 & t < t_1 \\
    0 & t > t_1 
\end{cases}
\]

with \( t_1 = 1000 \) s and \( c_0 = 75 \) nM = 75 \( \mu \text{mol/m}^3 \). For this analysis, modify the material balance input data according to the following table to obtain a reaction-rate limited process.

<table>
<thead>
<tr>
<th>NAME</th>
<th>VALUE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>( k_{\text{on}} )</td>
<td>100 m(^3)/mol/s</td>
<td>Association rate constant</td>
</tr>
<tr>
<td>( k_{\text{off}} )</td>
<td>( 5 \cdot 10^{-3} ) s(^{-1} )</td>
<td>Dissociation rate constant</td>
</tr>
<tr>
<td>( R_t )</td>
<td>( 1.67 \cdot 10^{-11} ) mol/m(^2 )</td>
<td>Total surface concentration of the antibody ligand</td>
</tr>
</tbody>
</table>

**Results and Discussion**

Figure 4-2 shows the flow profile and concentration distribution without any applied electric field. In this case, the flow is laminar and has a parabolic profile. The effect of the reaction surface on the analyte concentration is visible only in the narrow region near the surface. Compare it to the flow and concentration with an applied electric field (Figure 4-3). Now the flow profile is far from parabolic: it has two distinct swirls and a narrow region with high flow velocity between the electrodes. Both of these figures represent the situation 5 s after the system introduces analyte at the left boundary.

Figure 4-4 depicts the flow and concentration just 1 s after introducing the analyte. It shows more clearly how the swirling patterns in the flow focus the analyte on a narrower path near the reaction surface. This flow results in a difference in the adsorption rate of the molecules with and without the electric field, (Figure 4-5). The average number of adsorbed molecules—the ratio between the total amount and the surface width—on the surface increases more rapidly with the electric field (the curve with squares) than without the electric field (the curve with triangles).
Figure 4-2: Microchannel flow and concentration at 5 s without any applied electric field.

Figure 4-3: Microchannel flow and concentration at 5 s with an applied electric field.
CHAPTER 4: MICROFLUIDICS MODELS

Figure 4-4: Microchannel flow and concentration at 1 s with an applied electric field.

Figure 4-5: Binding of molecules on the reaction surface in the microchannel with (squares) and without (triangles) an applied electric field.
Figure 4-6 shows the result for the average concentration of bonded molecules of the third and final simulation, in which you cut off the analyte supply at $t = 1000$ s. During the phase when the analyte supply is kept constant, the concentration of molecules on the binding surface approaches a constant maximum value near $10^{-11}$ mol/m$^2$. When the supply at the inlet then stops, the concentration starts to decay. By varying the antibody ligand concentration and the association and dissociation rate constants, you can study the effects on the maximum concentration and the decay rate. Simulations of this kind can thus be useful for fitting a model to experimental data.

![Graph](image)

**Figure 4-6:** System response when the analyte supply at the inlet is cut off at $t = 1000$ s.

**Modeling in COMSOL Multiphysics**

This model solves the problem with two geometries and five application modes. Table 4-1 lists the geometries and their application modes.

The first geometry, named *channel*, is in 2D and represents the channel. Within this geometry the model uses four application modes: Electrostatics, Convection and Conduction, Incompressible Navier-Stokes, and Convection and Diffusion. The second geometry, named *surface*, is in 1D and simulates the reaction surface with the Diffusion application mode. The overall model couples this solution with the reaction...
surface boundary condition of the Convection and Diffusion application mode on the first geometry. For this purpose you must define two extrusion-coupling variables.

You solve the model in three steps with different solvers in a progression using results from the previous step:

- First, solve the Electrostatics application mode with a stationary linear solver.
- Next, solve the Convection and Conduction and the Incompressible Navier-Stokes application modes together using a stationary nonlinear solver, because they form a coupled system through their subdomain settings.
- In the third step you use the time-dependent solver to solve the transport of the analyte. At this point the software solves two application modes simultaneously: Convection and Diffusion, and Diffusion.

COMSOL Multiphysics’ solver scripting capabilities allow you to record these solving stages, a feature which greatly facilitates repeated simulations.

<table>
<thead>
<tr>
<th>GEOMETRY</th>
<th>APPLICATION MODE</th>
<th>VARIABLES</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>channel</td>
<td>Electrostatics</td>
<td>V</td>
<td>Solves the static electric potential in the channel</td>
</tr>
<tr>
<td>channel</td>
<td>Convection and Conduction</td>
<td>T</td>
<td>Solves the temperature distribution in the channel</td>
</tr>
<tr>
<td>channel</td>
<td>Incompressible Navier-Stokes</td>
<td>u, v, p</td>
<td>Solves the velocities in the x and y directions and the pressure distribution in the channel</td>
</tr>
<tr>
<td>channel</td>
<td>Convection and Diffusion</td>
<td>c</td>
<td>Solves the concentration of the analyte in the channel</td>
</tr>
<tr>
<td>surface</td>
<td>Diffusion</td>
<td>B</td>
<td>Solves the concentration of the binded antibodies on the reaction surface</td>
</tr>
</tbody>
</table>

References


Modeling Using the Graphical User Interface

Model Library

1. In the Model Navigator, click the New tab, then click the Multiphysics button.
2. Click the Add Geometry button.
3. Enter these settings in the dialog box:

<table>
<thead>
<tr>
<th>FIELD</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry name</td>
<td>channel1</td>
</tr>
<tr>
<td>Space dimension</td>
<td>2D</td>
</tr>
<tr>
<td>Independent variables</td>
<td>x y z</td>
</tr>
</tbody>
</table>

4. Click OK.

5. Click the Add Geometry button once again and enter these settings:

<table>
<thead>
<tr>
<th>FIELD</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry name</td>
<td>surface</td>
</tr>
<tr>
<td>Space dimension</td>
<td>1D</td>
</tr>
<tr>
<td>Independent variables</td>
<td>x y z</td>
</tr>
<tr>
<td>Unit system</td>
<td>None</td>
</tr>
</tbody>
</table>

Because the available unit systems give the wrong reference dimension for the 1D geometry, use the last setting to disable units for this geometry.

6. Click OK.

7. In the Multiphysics area, select the geometry channel (2D).

8. In the list of application modes, select MEMS Module>Electrostatics>Electrostatics, then click the Add button in the Multiphysics area.

9. Select the application mode COMSOL Multiphysics>Heat Transfer>Convection and Conduction, then click the Add button.

10. Select MEMS Module>Microfluidics>Incompressible Navier-Stokes, then click Add.
II Select MEMS Module>Microfluidics>Convection and Diffusion>Transient analysis, then click Add.

II In the Multiphysics area, select the geometry surface (1D).

III Select COMSOL Multiphysics>Convection and Diffusion>Diffusion>Transient analysis. In the Dependent variables edit field type B, then click Add.

IV Click OK.

OPTIONS AND SETTINGS

1 From the Options menu, choose Constants.

2 Define the following names, expressions, and (optionally) descriptions; when finished, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>epsilon0</td>
<td>8.854188e-12[F/m]</td>
<td>Permittivity of free space</td>
</tr>
<tr>
<td>epsilonr_f</td>
<td>80.2</td>
<td>Relative permittivity, fluid</td>
</tr>
<tr>
<td>epsilon_f</td>
<td>epsilonr_f*epsilon0</td>
<td>Permittivity, fluid</td>
</tr>
<tr>
<td>k_f</td>
<td>0.598[W/(m*K)]</td>
<td>Thermal conductivity, fluid</td>
</tr>
<tr>
<td>rho_f</td>
<td>1000[kg/m^3]</td>
<td>Density, fluid</td>
</tr>
<tr>
<td>Cp_f</td>
<td>4.184[kJ/(kg*K)]</td>
<td>Heat capacity, fluid</td>
</tr>
<tr>
<td>eta_f</td>
<td>1.08e-3[Pa*s]</td>
<td>Dynamic viscosity, fluid</td>
</tr>
<tr>
<td>sigma_f</td>
<td>5.75e-2[S/m]</td>
<td>Electric conductivity, fluid</td>
</tr>
<tr>
<td>tau</td>
<td>epsilon_f/sigma_f</td>
<td>Charge relaxation time, fluid</td>
</tr>
<tr>
<td>D_a</td>
<td>1e-11[m^2/s]</td>
<td>Diffusion coefficient, analyte</td>
</tr>
<tr>
<td>omega</td>
<td>2*pi[rad]*15[KHz]</td>
<td>Angular frequency, AC electric field</td>
</tr>
<tr>
<td>V_rms</td>
<td>0[V]</td>
<td>Electric potential, RMS value</td>
</tr>
<tr>
<td>T_amb</td>
<td>0[degC]</td>
<td>Ambient temperature</td>
</tr>
<tr>
<td>u_av</td>
<td>0.1[mm/s]</td>
<td>Average flow velocity at the inlet</td>
</tr>
<tr>
<td>c0</td>
<td>1[umol/m^3]</td>
<td>Analyte concentration at the inlet</td>
</tr>
<tr>
<td>k_on</td>
<td>1e5[m^3/(mol*s)]</td>
<td>Association rate constant</td>
</tr>
<tr>
<td>k_off</td>
<td>0.02[1/s]</td>
<td>Dissociation constant</td>
</tr>
<tr>
<td>R_t</td>
<td>1.67e-8[mol/m^2]</td>
<td>Total surface concentration, antibody ligand</td>
</tr>
</tbody>
</table>

Later, you change the value of the electric potential to 10 V and re-solve the model.

GEOMETRY MODELING

First create the 2D geometry for the channel.
1 Click the channel tab in the drawing area.

2 From the Options menu, choose Axes/Grid Settings.

3 In the dialog box, click the Axis tab, select the Axes equal check box, and enter these settings:

<table>
<thead>
<tr>
<th>SETTING</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>x min</td>
<td>-5e-5</td>
</tr>
<tr>
<td>x max</td>
<td>30e-5</td>
</tr>
<tr>
<td>y min</td>
<td>-5e-5</td>
</tr>
<tr>
<td>y max</td>
<td>10e-5</td>
</tr>
</tbody>
</table>

4 Click the Grid tab.

5 Clear the Auto check box and make these settings:

<table>
<thead>
<tr>
<th>SETTING</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>x spacing</td>
<td>1e-5</td>
</tr>
<tr>
<td>y spacing</td>
<td>1e-5</td>
</tr>
</tbody>
</table>

6 Click OK.

7 Click the Rectangle/Square button on the Draw toolbar and draw a rectangle with diagonally opposite corners at (0, 0) and (2.5·10^{-4}, 4·10^{-5}).

8 Draw the following points by successively using the Point tool in the Draw toolbar.

<table>
<thead>
<tr>
<th>NAME</th>
<th>x</th>
<th>y</th>
</tr>
</thead>
<tbody>
<tr>
<td>PT1</td>
<td>0.5e-4</td>
<td>0</td>
</tr>
<tr>
<td>PT2</td>
<td>1.1e-4</td>
<td>0</td>
</tr>
<tr>
<td>PT3</td>
<td>1.3e-4</td>
<td>0</td>
</tr>
<tr>
<td>PT4</td>
<td>1.9e-4</td>
<td>0</td>
</tr>
<tr>
<td>PT5</td>
<td>0.9e-4</td>
<td>0.4e-4</td>
</tr>
<tr>
<td>PT6</td>
<td>1.1e-4</td>
<td>0.4e-4</td>
</tr>
</tbody>
</table>
The completed 2D geometry should look like that in the following picture:

Next create the 1D geometry for the reaction surface.

1. Click the **surface** tab.
2. From the **Options** menu, choose **Axes/Grid Settings**.
3. In the dialog box, click the **Axis** tab, then enter these settings:

<table>
<thead>
<tr>
<th>SETTING</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>x min</td>
<td>-5e-5</td>
</tr>
<tr>
<td>x max</td>
<td>30e-5</td>
</tr>
</tbody>
</table>

4. Click the **Grid** tab. Clear the **Auto** check box. In the **x spacing** edit field type \(1e-5\), then click **OK**.
5. On the Draw toolbar select the **Line** tool and draw a line from \(0.9 \cdot 10^{-4}\) to \(1.1 \cdot 10^{-4}\).

The geometry is now complete.
Expressions and Coupling Variables

Follow these steps to create the expressions for computing the electrothermal force, to define the expressions and coupling variables needed to solve the binding reaction, and to provide the integration-coupling variables needed for postprocessing.

**Note:** You create expressions separately for the two geometries.

Start by defining scalar expressions for the electrothermal force components.

1. Click the **channel** tab to select that geometry.
2. From the **Options** menu, choose **Expressions>Scalar Expressions**.
3. In the dialog box, enter the expressions in the following table for the \(x\)- and \(y\)-components of the electrothermal force. Note that this example uses the expressions \(\text{tmp1}\) and \(\text{tmp2}\) only to simplify the writing of \(F_x_{\text{et}}\) and \(F_y_{\text{et}}\).

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>(\text{tmp1})</td>
<td>((\text{Tx<em>Ex}_{\text{emes}}+\text{Ty</em>Ey}_{\text{emes}})/(1+(\omega*\text{tau})^2))</td>
</tr>
<tr>
<td>(\text{tmp2})</td>
<td>(\text{normE}_{\text{emes}}^2)</td>
</tr>
<tr>
<td>(F_x_{\text{et}})</td>
<td>(-0.5*\epsilon_{\text{f}}<em>(0.016[1/K]</em>\text{tmp1<em>Ex}_{\text{emes}}-0.5</em>0.004[1/K]<em>\text{tmp2</em>Tx}))</td>
</tr>
<tr>
<td>(F_y_{\text{et}})</td>
<td>(-0.5*\epsilon_{\text{f}}<em>(0.016[1/K]</em>\text{tmp1<em>Ey}_{\text{emes}}-0.5</em>0.004[1/K]<em>\text{tmp2</em>Ty}))</td>
</tr>
</tbody>
</table>

4. Click **OK**.

Next set the expressions and extrusion-coupling variables you need to solve the surface reaction.

1. From the **Options** menu, choose **Expressions>Boundary Expressions**.
2. In the **Boundary selection** list, select Boundary 5.
3. Create the following boundary expression (\(c_{\text{surf}}\) is an extrusion coupling variable that you define later):

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>(\text{react}_{\text{bulk}})</td>
<td>(k_{\text{off}}*c_{\text{surf}}-k_{\text{on}}<em>c</em>(\text{R_t-c}_{\text{surf}}))</td>
</tr>
</tbody>
</table>

COMSOL Multiphysics marks the unit of \(\text{react}_{\text{bulk}}\) as inconsistent because of the coupling variable. You can disregard this warning.

4. Click **OK**.
5 Click the **surface** tab to select that geometry.

6 From the **Options** menu, choose **Expressions>Subdomain Expressions**.

7 In the **Subdomain selection** list, select Subdomain 1.

8 Define the following subdomain expression (the term $c_{\text{bulk}}$ is an extrusion-coupling variable that you define next); when done, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>react_surf</td>
<td>$k_{\text{on}}c_{\text{bulk}}(R_t-B)-k_{\text{off}}B$</td>
</tr>
</tbody>
</table>

9 Click the **channel** tab to select that geometry.

10 From the **Options** menu, choose **Extrusion Coupling Variables>Boundary Variables**.

11 Select Boundary 5. In the first row of the **Name** column type $c_{\text{bulk}}$, then type $c$ in the corresponding **Expression** column.

12 Click the **General transformation** option button.

13 Click the **Destination** tab.

14 From the **Geometry** list select **surface**, and from the **Level** list select **Subdomain**.
15 In the Subdomain selection list, click the check box to select Subdomain 1. Make sure the Use selected subdomains as destination check box is selected.

![Subdomain selection list](image1)

Configuring the destination of the extrusion coupling variable for the channel geometry.

16 Click OK.

17 Verify that you still have the surface tab selected; if it is not selected, click it.

18 From the Options menu, choose Extrusion Coupling Variables>Subdomain Variables.

19 From the Subdomain selection list select 1, go to the first row in the Name column and enter c_surf, then type B in the corresponding Expression column.

20 Click the General transformation option button.

![General transformation option button](image2)

Configuring the source of the extrusion coupling variable for the surface geometry.
21 Click the **Destination** tab.

22 From the **Geometry** list select channel, and from the **Level** list select **Boundary**.

23 In the **Boundary selection** list, click the check box to select Boundary 5. Make sure the **Use selected boundaries as destination** check box is selected.

![Subdomain Extrusion Variables](image)

Configuring the destination of the extrusion coupling variable for the surface geometry.

24 Click **OK**.

Finally set the integration-coupling variables needed for postprocessing. They represent the total amount of bonded molecules on the reaction surface and its length, respectively. Their ratio thus gives the average concentration of bonded molecules at the surface.

1 Select the **surface** geometry.

2 From the **Options** menu, select **Integration Coupling Variables**>**Subdomain Variables**.

3 Select Subdomain 1 and enter these settings:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>INTEGRATION ORDER</th>
<th>GLOBAL DESTINATION</th>
</tr>
</thead>
<tbody>
<tr>
<td>B_total</td>
<td>B</td>
<td>4</td>
<td>Selected</td>
</tr>
<tr>
<td>x_length</td>
<td>1</td>
<td>4</td>
<td>Selected</td>
</tr>
</tbody>
</table>

4 Click **OK**.

*Subdomain Settings*

1 From the **Multiphysics** menu, select **1 channel: Electrostatics (emes)**.
2 From the Physics menu, select Subdomain Settings.

3 Select Subdomain 1.

4 Under the options for the Constitutive relation click the option button corresponding to \( \mathbf{D} = \varepsilon_0 \varepsilon_r \mathbf{E} \).

5 In the Relative permittivity edit field type \( \text{epsilon}_r_f \), then click OK.

6 From the Multiphysics menu, select 2 channel: Convection and Conduction (cc).

7 From the Physics menu, select Subdomain Settings.

8 Select Subdomain 1, then enter settings as in this table; when finished, click OK.

<table>
<thead>
<tr>
<th>QUANTITY</th>
<th>VALUE/EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>( k ) (isotropic)</td>
<td>( k_f )</td>
<td>Thermal conductivity</td>
</tr>
<tr>
<td>( \rho )</td>
<td>( \rho_f )</td>
<td>Density</td>
</tr>
<tr>
<td>( C_p )</td>
<td>( C_p_f )</td>
<td>Heat capacity at constant pressure</td>
</tr>
<tr>
<td>( Q )</td>
<td>( \text{sigma}_f^* \text{normE}_em^*2 )</td>
<td>Heat source</td>
</tr>
<tr>
<td>( u )</td>
<td>( u )</td>
<td>x-velocity</td>
</tr>
<tr>
<td>( v )</td>
<td>( v )</td>
<td>y-velocity</td>
</tr>
</tbody>
</table>

9 From the Multiphysics menu, select 3 channel: Incompressible Navier-Stokes (mmgf).

10 From the Physics menu, select Subdomain Settings.

11 In the dialog box select Subdomain 1, then enter these settings:

<table>
<thead>
<tr>
<th>QUANTITY</th>
<th>VALUE/EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \rho )</td>
<td>( \rho_f )</td>
<td>Density</td>
</tr>
<tr>
<td>( \eta )</td>
<td>( \eta_f )</td>
<td>Dynamic viscosity</td>
</tr>
<tr>
<td>( F_x )</td>
<td>( F_x_{et} )</td>
<td>Volume force, x dir.</td>
</tr>
<tr>
<td>( F_y )</td>
<td>( F_y_{et} )</td>
<td>Volume force, x dir.</td>
</tr>
</tbody>
</table>

12 Click the Init tab. In the x-velocity edit field, type \( u_{av} \). Click OK.

13 From the Multiphysics menu, select 4 channel: Convection and Diffusion (chcd).

14 From the Physics menu, select Subdomain Settings.
Select Subdomain 1, then enter settings as in the following table; for the Time-scaling coefficient and the Reaction rate, leave the default settings.

<table>
<thead>
<tr>
<th>QUANTITY (isotropic)</th>
<th>VALUE/EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>D</td>
<td>( D_a )</td>
<td>Diffusion coefficient</td>
</tr>
<tr>
<td>u</td>
<td>( u )</td>
<td>x-velocity</td>
</tr>
<tr>
<td>v</td>
<td>( v )</td>
<td>y-velocity</td>
</tr>
</tbody>
</table>

Click the Artificial Diffusion button.

In the dialog box that opens, activate the Streamline diffusion method and keep its default settings (Petrov-Galerkin/Compensated, 0.25); then click OK.

The artificial diffusion reduces the noisy component from the concentration solution. The noise results from the large cell-Peclet number of the convection and diffusion problem.

Click OK to close the Subdomain Settings window.

From the Multiphysics menu, choose 5 surface: Diffusion (di).

From the Physics menu, select Subdomain Settings.

Select Subdomain 1, then enter these settings; when finished, click OK.

<table>
<thead>
<tr>
<th>QUANTITY</th>
<th>VALUE/EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>D</td>
<td>0</td>
<td>Diffusion coefficient</td>
</tr>
<tr>
<td>R</td>
<td>react_surf</td>
<td>Reaction rate</td>
</tr>
</tbody>
</table>

Boundary Conditions

1. From the Multiphysics menu, choose 1 channel: Electrostatics (emes).

2. From the Physics menu, select Boundary Settings.

3. Enter boundary settings from the following table; when finished, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 4</th>
<th>BOUNDARY 8</th>
<th>BOUNDARIES 1–3, 5–7, 9, 10</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Electric potential</td>
<td>Electric potential</td>
<td>Zero charge/ Symmetry</td>
</tr>
<tr>
<td>( V_0 )</td>
<td>( V_{\text{rms}}/2 )</td>
<td>(-V_{\text{rms}}/2 )</td>
<td></td>
</tr>
</tbody>
</table>
6. Enter boundary settings from the following table; when finished, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 1, 10</th>
<th>BOUNDARIES 4, 8</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Heat flux</td>
<td>Temperature</td>
</tr>
<tr>
<td>$q_0$</td>
<td>$-k_f(T-T_{amb})/1$ [mm]</td>
<td></td>
</tr>
<tr>
<td>$T_0$</td>
<td>$T_{amb}$</td>
<td></td>
</tr>
</tbody>
</table>

The default boundary condition (thermal insulation) applies to the boundaries not listed in the table.

7. From the Multiphysics menu, select 3 channel: Incompressible Navier-Stokes (mmglf).
8. From the Physics menu, select Boundary Settings.
9. Enter boundary settings from the following table; when finished, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 1</th>
<th>BOUNDARY 10</th>
<th>BOUNDARIES 2–9</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary type</td>
<td>Inlet</td>
<td>Outlet</td>
<td>Wall</td>
</tr>
<tr>
<td>Boundary condition</td>
<td>Laminar inflow</td>
<td>Pressure, no viscous stress</td>
<td>No slip</td>
</tr>
<tr>
<td>$U_0$</td>
<td>$u_{av}$</td>
<td></td>
<td></td>
</tr>
<tr>
<td>$L_{entr}$</td>
<td>$1e^{-4}$</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Constrain end points to zero</td>
<td>Yes</td>
<td></td>
<td></td>
</tr>
<tr>
<td>$p_0$</td>
<td></td>
<td>0</td>
<td></td>
</tr>
</tbody>
</table>

10. From the Multiphysics menu, select 4 channel: Convection and Diffusion (chcd).
11. From the Physics menu, select Boundary Settings.
12. Enter boundary settings from the following table; when finished, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 1</th>
<th>BOUNDARY 5</th>
<th>BOUNDARY 10</th>
<th>BOUNDARIES 2–4, 6–9</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Concentration</td>
<td>Flux</td>
<td>Convective flux</td>
<td>Insulation/Symmetry</td>
</tr>
<tr>
<td>$c_0$</td>
<td>$c_0$</td>
<td></td>
<td></td>
<td>react bulk</td>
</tr>
</tbody>
</table>

13. From the Multiphysics menu, select 5 surface: Diffusion (di).
14. From the Physics menu, select Boundary Settings.
15. Verify that the Boundary condition is set to Insulation/Symmetry on both boundaries.
16. Click OK.
MESH GENERATION
1. Select the channel geometry.
2. From the Mesh menu, select Free Mesh Parameters.
3. From the Predefined mesh sizes list select Fine.
4. Go to the Subdomain page.
5. See that subdomain 1 is selected and in the Maximum element size edit field type 8e-6.
6. Click the Boundary tab.
7. Select Boundary 5.
8. In the Maximum element size edit field type 1e-7.
10. In the Maximum element size edit field type 2e-7.
11. Click the Remesh button to initialize the mesh for the channel geometry. Click OK.
12. Select the surface geometry.
13. From the Mesh menu, select Free Mesh Parameters.
15. Click Remesh; Then click OK to close the window.

COMPUTING THE SOLUTION
You solve the model in three steps using three different solvers.
1. Click the Solver Manager button on the Main toolbar to launch the Solver Manager.
2. On the Script page, select the Automatically add commands when solving check box. With this setting, COMSOL Multiphysics records the subsequent solver commands so that you can reuse them when you later solve the model for \( V_{rms} = 10 \) V.
3. On the Solve For page, select channel (2D)>Electrostatics (emes).
4. Click Solve.
5. Click the Initial Value tab. In the Values of variables not solved for and linearization point area, select the Current solution option button.
6. Return to the Solve For page. Select the application modes channel (2D)>Convection and Conduction (cc) and channel (2D)>Incompressible Navier-Stokes (mmglf).
7. Click Solve.
8. Click the Solver Parameters button on the Main toolbar to launch the Solver Parameters dialog box.
9. From the Solver list, select Time dependent.
10. On the General page, type 0:0.1:5 in the Times edit field in the Time stepping area.
11. In the Absolute tolerance edit field type c 1e-8 B 1e-13.
12. Click OK to close the Solver Parameters dialog box.
13. Return to the Solver Manager.
14. On the Solve For page, select the application modes channel (2D)>Convection and Diffusion (chcd) and surface (1D)>Diffusion (di).
15. Click OK to close the Solver Manager dialog box.
16. Click Solve button on the Main toolbar.

POSTPROCESSING AND VISUALIZATION

Begin by visualizing the fluid flow and the analyte concentration in the flow channel after 5 s.

1. In the drawing area, select the channel geometry.
2. Click the Plot Parameters button on the Main toolbar.
3. On the General page of the Plot Parameters dialog box, select the check boxes for Surface, Arrow, Streamline, and Geometry edges. Make sure the Solution at time list is initialized to 5.
4. Click the Surface tab. From the Predefined quantities list, select Convection and Diffusion (chcd)>Concentration, c. In the Unit edit field, type umol/m^3.
5. Click the Arrow tab. In the Plot arrows on list select Subdomains.
6. Click the Subdomain Data tab. From the Predefined quantities list, select Incompressible Navier-Stokes (mmglf)>Velocity field.
7. In the Arrow parameters area, find the Arrow length list and select Proportional.
8. Click the Color button. Select black, then click OK to close the Arrow Color dialog box.
9. Go to the Streamline page. Click the Streamline Data tab, then in the Predefined quantities list select Incompressible Navier-Stokes (mmglf)>Velocity field.
10. From the Streamline plot type list, select Magnitude controlled.
11. Click the Line Color tab. Select the Uniform color option button. Click the Color button, then select the orange color corresponding to the RGB values (255, 102, 0). To do so, click the RGB tab and enter the values directly. Click OK to close the Streamline Color dialog box.
12. Return to the General page. From the Plot in list, select New figure.
Click OK to generate the plot in Figure 4-2 on page 227.

Next, generate the first graph in Figure 4-5 on page 228 with the following steps:

1. Select the surface geometry.
2. From the Postprocessing menu, select Cross-Section Plot Parameters.
3. On the General page, verify that all solutions in the Solutions to use list are selected. From the Plot in list, select New figure.
4. Click the Point tab. In the $y$-axis data area, type $B_{\text{total}}/x_{\text{length}}$ in the Expression edit field. In the Coordinates area, type $10^{-4}$ in the $x$ edit field.
5. Click the Line Settings button. From the Line marker list select Triangle, then click OK to close the Line Settings dialog box.
6. Click OK.

Leave the figure windows open to enable comparison with the solutions for the case where an electric field has been applied.

Re-Solve the Model with an Applied Electric Field

In this second part of the modeling session, you apply an external electric field.

OPTIONS AND SETTINGS

Choose Options>Constants. Change the Expression for $V_{\text{rms}}$ to $10[V]$, then click OK.

COMPUTING THE SOLUTION

1. Click the Solver Manager button on the Main toolbar.
2 On the **Script** page, select **Solve using a script** check box. The following solver script appears in the script area (the orders between the entries in the **solcomp** and **outcomp** lists can vary):

![Solver Manager screenshot](image)

3 Click **OK** to close the **Solver Manager**.

4 Click the **Solve** button on the Main toolbar. The software automatically repeats all the solving stages you recorded in the first part of this model to compute the solution for $V_{\text{rms}} = 10$ V.

**POSTPROCESSING AND VISUALIZATION**

1 In the drawing area, select the **channel** geometry.

2 Click the **Plot Parameters** button on the Main toolbar.

3 On the **General** page, select **New figure** from the **Plot in** list. Click **Apply**.

   The plot displayed in Figure 4-3 on page 227—visualizing the fluid flow and the analyte concentration in the flow channel after 5 s in the presence of an electric field—should now appear in the Figure 3 window. To plot the same quantities at $t = 1$ s, proceed with the following steps:

4 Still on the **General** page, from the **Solution at time** list select 1.

5 From the **Plot in** list select **New figure**, then click **OK**.
The new figure window now contains a plot resembling that in Figure 4-4. This is the plot you see in the Model Navigator if you open the model from the Model Library.

Finally, finish reproducing Figure 4-5, which illustrates the binding rate of the analyte, by executing the following instructions:

1. Select the surface geometry.
2. From the Postprocessing menu, select Cross-Section Plot Parameters.
3. On the Point page, click the Line Settings button. From the Line marker list select Square, then click OK to close the Line Settings dialog box.
4. Click the General tab.
5. Select the Keep current plot check box.
6. Click the Title/Axis button.
7. Activate the Title edit field, then enter the title Average concentration of bonded molecules [mol/m^2].
   The HTML tags produce a superscript figure “2” for the exponent.
8. Click OK to close the Title/Axis Settings dialog box.
9. Click OK to generate the plot.

The two graphs in the Figure 2 window should now look like those in Figure 4-5.

To study an animation of the solution, click the Animate button on the Plot toolbar.

Step-Response Simulation

**OPTIONS AND SETTINGS**
From the Physics menu, select Constants. Edit the expressions for the four last constants according to the following table; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>c0</td>
<td>75[umol/m^3]</td>
</tr>
<tr>
<td>k_on</td>
<td>100[m^3/(mol*s)]</td>
</tr>
<tr>
<td>k_off</td>
<td>5e-3[1/s]</td>
</tr>
<tr>
<td>R_t</td>
<td>1.67e-11[mol/m²]</td>
</tr>
</tbody>
</table>

**PHYSICS SETTINGS**
1. From the Multiphysics menu, select 4 channel: Convection and Diffusion (chcd).
2. From the Physics menu, select Boundary Settings. Select Boundary 1.
3 Change the entry in the \( c_0 \) edit field to \( c_0^*(t<1000\,\text{s}) \), then click OK.

The logical expression implements the step function in Equation 4-3.

**Computing the Solution**

1 Click the Solver Parameters button on the Main toolbar.
3 In the Absolute tolerance edit field type \( 1\times10^{-6} \, \text{B} \times 1\times10^{-13} \).
4 Click the Time Stepping tab.
5 From the Time steps taken by solver list, select Intermediate.
6 Click OK to close the Solver Parameters dialog box.
7 Click the Solver Manager button on the Main toolbar.
8 On the Script page, click the Add Current Solver Settings button.

A femtime command with the current solver settings appears in the script area.
9 Because this command should replace the previous one, cut out the complete upper femtime command together with the asseminit command line immediately before it as well as the fem0=xfe; line immediately after it. When you are done, the contents of the script area should be as in the following figure (again, the entries in the solcomp and outcomp lists can be ordered differently).
10 Click **OK** to close the **Solver Manager**.

11 Click the **Solve** button on the Main toolbar.

**POSTPROCESSING AND VISUALIZATION**

To reproduce the plot in Figure 4-6, follow these steps:

1 Select the **surface** geometry.

2 From the **Postprocessing** menu, select **Cross-Section Plot Parameters**.

3 On the **General** page, select **New figure** from the **Plot in** list.

4 On the **Point** page, click the **Line Settings** button. From the **Line marker** list select **None**, then click **OK** to close the **Line Settings** dialog box.

5 Click **OK** to close the **Cross-Section Plot Parameters** dialog box and generate the plot.
Transport in an Electrokinetic Valve

Introduction

This model presents an example of pressure-driven flow and electrophoresis in a microchannel system.

Researchers often use a device similar to the one in this model as an electrokinetic sample injector in biochips to obtain well-defined sample volumes of dissociated acids and salts and to transport these volumes. The model presents a study of a pinched injection cross valve during the focusing, injection, and separation stages. Inspiration for the model comes from a study by Ermakov and others (Ref. 1). Focusing is obtained through pressure-driven flow of the sample and buffer solution, which confines the sample in the focusing channel. When the system reaches steady state, the pressure-driven flow is turned off and an electric field is applied along the channels. This field drives the dissociated sample ions in the focusing zone at right angles to the focusing channel and through the injection channel. A clean separation of the sample ions is important, so the model examines the effect on ion separation of different configurations of the electric field.

This specific case does not account for electroosmosis because the channel surfaces are subjected to a treatment that minimizes the extension of the electric double layer.

Model Definition

Figure 4-7 shows a 2D cross section of the geometry in the xz-plane and points out the different channels and boundaries. The horizontal channel serves as the focusing channel, while the vertical channel is the injection channel. The actual model is in 3D with rectangular pipes whose corners are rounded. For geometry dimensions refer to Table 4-3 on page 258.
CHAPTER 4: MICROFLUIDICS MODELS

Figure 4-7: The focusing stage involves pressure-driven flow of both the sample and the buffering solution. The device applies an electric field over the focusing channel.

The device operation and hence the modeling procedure takes place in two stages: focusing and injection.

In the focusing stage, the device injects a buffering solution through pressure-driven convection into the vertical channels from the top and bottom. At the same time, it forces the sample solution through the horizontal focusing channel (see Figure 4-7). The buffering solution neutralizes the acids contained in the sample except for a very thin region confined to the crossing between the horizontal and vertical channels. This means that the dissociated ions are only in a needle-shaped region in the focusing zone.

Next, in the injection stage the device turns off the convective flow and then applies a vertical field to migrate the sample from the focusing channel to the injection point at the lower end of the vertical channel. The sample ions are negatively charged and migrate in opposite direction to the electric field. This model studies two different configurations (See Table 4-2) for the applied electric field. In the first configuration (Injection stage, Mode A) electric field is only applied in the vertical direction. In the second configuration (Injection stage, Mode B) the electric field is applied in both the...
horizontal and vertical directions (Figure 4-8). The horizontal field focuses the sample during the initial part of the injection stage in order to obtain a well-separated sample.

![Diagram of electric field vectors](image)

*Figure 4-8: During the injection stage, the device turns off convective flow and applies an electric field. The horizontal field avoids the broadening of the sample, while the vertical field injects the sample into the vertical channel in the direction opposite to the electric field.*

**TABLE 4-2: APPLIED ELECTRIC FIELD CONFIGURATION**

<table>
<thead>
<tr>
<th>INLET</th>
<th>MODE A</th>
<th>MODE B</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sample inlet</td>
<td>Electric insulation</td>
<td>Electric potential, V = -1V</td>
</tr>
<tr>
<td>Outlet</td>
<td>Electric insulation</td>
<td>Electric potential, V = 0V</td>
</tr>
<tr>
<td>Upper buffer inlet</td>
<td>Electric potential, V = -3.2V</td>
<td>Electric potential, V = -3.2V</td>
</tr>
<tr>
<td>Lower buffer inlet</td>
<td>Electric potential, V = 0V</td>
<td>Electric potential, V = 0V</td>
</tr>
</tbody>
</table>

The model assumes that the charged sample concentration is very low compared to other ions dissolved in the solution. This implies that the sample concentration does not influence the solution’s conductivity and that you can neglect the concentration gradients of the charge-carrying species, which are present in a much higher concentration than the sample ions. Such an electrolyte is known as a supporting electrolyte.
Several equations describe the model: the Stokes flow equations, the equation for current balance, and a mass balance using the Nernst–Planck equation. This model uses the steady-state solution for the focusing stage as the initial condition for the injection stages.

Now consider the formulation of the model equations.

THE FOCUSING STAGE

The Stokes flow equations give the global mass a momentum balance in the focusing stage:

\[ \nabla \cdot \left[ -p \mathbf{I} + \eta \left( \nabla \mathbf{u} + (\nabla \mathbf{u})^T \right) \right] = \nabla \cdot \mathbf{u} = 0. \]

In these equations, \( \eta \) denotes the dynamic viscosity (kg/(m·s)), \( \mathbf{u} \) is the velocity (m/s), and \( p \) is the pressure (Pa).

The total balance of charges for a supporting electrolyte comes from the divergence of the current-density vector, which in a supporting electrolyte is given by Ohm’s law:

\[ \mathbf{i} = -\kappa \nabla \mathbf{V} \]

Here \( \kappa \) is the electrolyte’s conductivity (S/m) and \( \mathbf{V} \) is the potential (V). The balance of current at steady state then becomes

\[ \nabla \cdot \mathbf{i} = 0 \]

which gives

\[ \nabla \cdot (-\kappa \nabla \mathbf{V}) = 0 \]

The flux vector for the sample ions comes from the Nernst–Planck equation

\[ \mathbf{N}_i = -D_i \nabla c_i - z_i u_{mi} \mathbf{F} c_i \nabla \mathbf{V} + c_i \mathbf{u} \]

which leads to the following mass balance equation at steady state for species \( i \):

\[ \nabla \cdot (-D_i \nabla c_i - z_i u_{mi} \mathbf{F} c_i \nabla \mathbf{V} + c_i \mathbf{u}) = 0 \]

Here \( c_i \) is the concentration (mol/m\(^3\)), \( D_i \) represents the diffusivity (m\(^2\)/s), \( z_i \) equals the charge number (which equals 1 for this model), \( u_{mi} \) is the mobility (s·mol/kg), and \( \mathbf{F} \) is Faraday’s constant (C/mol).
For the pressure-driven flow, assume that the flow has fully developed laminar form in all inlets, that all sides have no-slip conditions, and that the fluid flows freely out from the end of the focusing channel.

The boundary conditions for the charge balance determine the potential at the respective inlet and outlet boundary

\[ V = V_{0,i} \]

where \( i \) denotes the index for each boundary. This model also assumes that all wall boundaries are insulating:

\[ \nabla V \cdot n = 0 \]

The boundary conditions for the mass balance of the sample during the focusing stage appear below. The equation

\[ c = c_{in} \]

gives the concentration at the inlet of the sample, while the equation

\[ c = c_{buffer} \]

gives the concentration of the buffer at the inlet of the two vertical channels, and the buffer inlets are at both boundaries in the vertical channel. At the outlet boundary, convection and migration are the dominating transport mechanisms (that is, diffusion is negligible), so that

\[ \mathbf{N}_i \cdot n = (-z_i u_m_i F c_i \nabla V + c_i \mathbf{u}) \cdot n \]

**The Injection Stage**

In the injection and separation stages, the device turns the flow off and changes the configuration of the electric field. You again solve the charge-balance equations but with new boundary conditions:

\[ \nabla \cdot (-\kappa \nabla V) = 0 \]

The mass balance for the dilute species comes from a time-dependent mass balance:

\[ \frac{\partial c}{\partial t} + \nabla \cdot (-D_i \nabla c_i - z_i u_m_i F c_i \nabla V) = 0 \]

The model assumes that the convective contribution is zero.
The boundary conditions for the current-balance equation imply that the potential is locked at all boundaries except for the walls,

\[ V = V_{0,t} \]

Further assume the walls are electrically insulated, which yields

\[ \nabla V \cdot \mathbf{n} = 0 \]

As opposed to the focusing state, the boundary conditions for the mass balance are changed. In the injection stage, set the concentration at the inlet boundary:

\[ c = c_{\text{in}} \]

For all other boundaries, assume that migration is the dominating transport mechanism, so that

\[ \mathbf{N}_i \cdot \mathbf{n} = \left( -z_i u_{z_i} F c_i \nabla V \right) \cdot \mathbf{n} \quad \text{(4-4)} \]

The time-dependent solution requires an initial condition for the mass balance, which you obtain from the steady-state solution of the focusing stage:

\[ c(t = 0) = c_{\text{focus}} \]

Results and Discussion

This example analyzes the focusing stage and two configurations for the injection stages. Recall that the first injection-stage configuration (Mode A) applies the electric field only over the injection channel while the inlet and outlet boundaries of the focusing channel are insulated; the second injection-stage configuration (Mode B) applies the electric field over both channels.

Figure 4-9 shows the steady-state concentration distribution during the focusing stage along with the distribution at the beginning of the injection stage. Note that the vertical flows from the upper and lower injection channels focus the concentration on
a very narrow region near the crossing area of the channels. Further away from the crossing area, however, the concentration spreads again more equally over the channel.

Figure 4-9: The steady-state concentration distribution during the focusing stage and prior to the injection stage.

Figure 4-10 and Figure 4-11 compare the concentration distribution for the two configurations at two times, specifically 0.06 s and 0.12 s after the beginning of the injection stage. The figures on the left show that for Mode A the concentration boundary is practically stationary in the horizontal direction. Consequently, the vertical electric field can continuously draw ions from the focusing channel, which results in poor separation and a poorly defined sample volume of the substance. For Mode B the situation is very different. The horizontal electric field draws the concentration boundary to the left, and the channels separate rapidly. Consequently,
this scheme draws a well-defined sample volume of the substance into the injection channel.

Figure 4-10: The concentration distribution at a time 0.06 s after starting the injection stage for the Mode A configuration (left) and Mode B configuration (right).

Figure 4-11: The concentration distribution at a time 0.12 s after starting the injection stage for the Mode A configuration (left) and Mode B configuration (right).

It is also possible to observe the difference between the two configurations if you look at the concentration along a line through the middle of the injection channel, examining it at several times after the start of the injection stage (Figure 4-12). The maximum concentration moves down the injection channel with time. The peaks are higher in the upper axis corresponding to Mode A, but they are much wider than for Mode B. A considerable amount of concentration appears at the left of the peak, and the sample remains attached to the focusing area—resulting in an unwanted distortion of the sample package. The narrow peaks of Mode B, on the other hand, form nice bell
curves throughout the downward transport in the injection channel, resulting in a well-defined sample package.

Figure 4-12: Concentration profile for Mode A (top) and Mode B (bottom) along the injection channel at various time steps: 0 s, 0.06 s, 0.12 s, 0.18 s, 0.24 s, 0.30 s, 0.36 s, 0.42 s, 0.48 s, 0.54 s, and 0.6 s after initialization of the injection stage. The origin of the x-axis marks the centerline of the focusing channel.
This study illustrates that modeling is extremely valuable in the investigation of electrophoretic transport. You can vary the configuration of the potential to obtain even better focusing and injection stages for the valve under study.

**Modeling in COMSOL Multiphysics**

**APPLICATION MODES**

In COMSOL Multiphysics you define the model with three application modes:

- The Stokes Flow application mode solves the fluid flow in the channels with Stokes equations.
- The Conductive Media DC application mode solves the equation for current balance.
- The Electrokinetic Flow application mode solves the Nernst-Planck equation.

**GEOMETRY MODELING**

Table 4-3 gives the dimensions of the model geometry. To draw it, proceed in four steps:

1. Initialize the geometry with simple blocks that represent the crossing of the channels.
2. Create a 2D work plane geometry in which you draw the cross section of the channel and a few assisting objects.
3. To finalize to channel crossing, apply the revolve operator to the 2D objects and subtract the resulting 3D objects from the original 3D blocks.
4. Finally apply the extrude operator to the 2D channel cross section to create the channels.

**TABLE 4-3: MODEL DIMENSIONS**

<table>
<thead>
<tr>
<th>Dimensions (µm)</th>
<th>HORIZONTAL CHANNEL</th>
<th>VERTICAL CHANNEL</th>
<th>CROSSING AREA</th>
</tr>
</thead>
<tbody>
<tr>
<td>- x</td>
<td>340</td>
<td>20</td>
<td>28</td>
</tr>
<tr>
<td>- y</td>
<td>20</td>
<td>20</td>
<td>20</td>
</tr>
<tr>
<td>- z</td>
<td>20</td>
<td>340</td>
<td>28</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Position (µm)</th>
<th>HORIZONTAL CHANNEL</th>
<th>VERTICAL CHANNEL</th>
<th>CROSSING AREA</th>
</tr>
</thead>
<tbody>
<tr>
<td>- x</td>
<td>-100</td>
<td>0</td>
<td>-4</td>
</tr>
<tr>
<td>- y</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>
The operation of the actual device proceeds in two stages, the focusing stage and the injection stage. This model simulates two settings of the injection stage so in total it works in three phases.

The first phase defines the subdomain settings and boundary conditions for the focusing phase. Then the model solves the application modes sequentially with a nonlinear solver in the following sequence:

1. Stokes Flow application mode
2. Conductive Media DC application mode
3. Electrokinetic Flow application mode

Each step uses the solution from the previous one. The model stores the last solution for use as the initial value for the consequent modeling.

In the second phase you change the subdomain settings and boundary conditions to handle the injection stage Mode A. In a real device you would turn off the convective flow; in the model you simulate this by setting the velocity parameters of the Electrokinetic Flow application mode to zero. Thus it uses no information from the Stokes Flow application mode.

Solving the second phase starts from the stored solution of the first phase, and the model solves the Conductive Media DC application mode with a nonlinear solver. Then you select a time-dependent solver and solve the Electrokinetic Flow application mode. This solution is the result for the injection stage Mode A.

In the third phase you again change subdomain settings and boundary conditions but this time for the injection stage Mode B; you then solve for the final solution the same way as in the second phase.

### TABLE 4.3: MODEL DIMENSIONS

<table>
<thead>
<tr>
<th></th>
<th>HORIZONTAL CHANNEL</th>
<th>VERTICAL CHANNEL</th>
<th>CROSSING AREA</th>
</tr>
</thead>
<tbody>
<tr>
<td>- z</td>
<td>0</td>
<td>-200</td>
<td>-4</td>
</tr>
<tr>
<td>Rounding (µm)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>- radius</td>
<td>4</td>
<td>4</td>
<td>4</td>
</tr>
<tr>
<td>- direction</td>
<td>in</td>
<td>in</td>
<td>out</td>
</tr>
</tbody>
</table>
Reference


Model Library path: MEMS_Module/Microfluidics_Models/electrokinetic_valve_3d

Modeling Using the Graphical User Interface

MODEL NAVIGATOR
1. Open the Model Navigator, select the New page, and from the Space dimension list select 3D.
2. Click the Multiphysics button.
3. In the Application Modes tree, select MEMS Module>Microfluidics>Stokes Flow. Click Add.
4. In the Application Modes tree, select MEMS Module>Electrostatics>Conductive Media DC. Click Add.
5. In the Application Modes tree, select MEMS Module>Microfluidics>Electrokinetic Flow>Transient analysis. Click Add.
6. Click OK.

OPTIONS AND SETTINGS
Next define some constants for the model.

1. From the Options menu, choose Constants.
2. In the dialog box that opens, specify names, expressions, and (optionally) descriptions for the following constants; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>u_a</td>
<td>0.2[mm/s]</td>
<td>Average velocity, sample inlet</td>
</tr>
<tr>
<td>w_a</td>
<td>0.67[mm/s]</td>
<td>Average velocity, buffer inlets</td>
</tr>
<tr>
<td>rho</td>
<td>1e3[kg/m^3]</td>
<td>Fluid density</td>
</tr>
<tr>
<td>eta</td>
<td>1e-3[Pa*s]</td>
<td>Fluid viscosity</td>
</tr>
<tr>
<td>D</td>
<td>1e-9[m^2/s]</td>
<td>Sample ion diffusivity</td>
</tr>
</tbody>
</table>
GEOMETRY MODELING

3D Geometry—Step 1
Start the geometry by creating a simple set of rectangular blocks.

1 Click the Block tool on the 3D Draw toolbar and create two rectangular blocks using the settings from the following table; keep all other settings at their default values.

<table>
<thead>
<tr>
<th>BLOCK</th>
<th>AXIS BASE POINT</th>
<th>LENGTH</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>X</td>
<td>Y</td>
</tr>
<tr>
<td>BLK1</td>
<td>-4e-6</td>
<td>0</td>
</tr>
<tr>
<td>BLK2</td>
<td>-20e-6</td>
<td>0</td>
</tr>
</tbody>
</table>

2 Click the Zoom Extents button on the Main toolbar.

Work Plane Geometry
Next create a 2D geometry on a work plane. After you extrude and revolve the objects, they shape the 3D geometry.

1 From the Draw menu, choose Work Plane Settings.
2 On the Quick page, click the y-z option button. Type -4e-6 in the associated x edit field. Click OK.
3 Click the Geom2 tab to activate the 2D work plane geometry.
4 Shift-click the Rectangle/Square button on the Draw toolbar.
5 Create a rectangle as in the following table; when done, click OK.

<table>
<thead>
<tr>
<th>SIZE</th>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>POSITION</th>
<th>X</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>20e-6</td>
<td>20e-6</td>
<td>Corner</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

6 Click the Zoom Extents button on the Main toolbar.
7 Click the Fillet/Chamfer button on the Draw toolbar.
8 In the dialog box go to the **Vertex selection** area, open the menu tree under **R1**, then select the four corners. Click the **Fillet** option button, and in the **Radius** edit field type **4e-6**. Click **OK**.

9 Shift-click the **Rectangle/Square** button on the Draw toolbar. Create a rectangle as in the following table; when done, click **OK**.

<table>
<thead>
<tr>
<th>OBJECT</th>
<th>SIZE</th>
<th>POSITION</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>WIDTH</td>
<td>HEIGHT</td>
</tr>
<tr>
<td>R1</td>
<td>20e-6</td>
<td>28e-6</td>
</tr>
</tbody>
</table>

10 Click the **Create Composite Object** button on the Draw toolbar.

11 Verify that the **Keep interior boundaries** check box is selected.

12 In the **Set formula** edit field, type **C01+R1**. Click **OK**.

13 Click the **Split Object** button on the Draw toolbar.

---

*Zoom-in view of the completed 2D geometry.*

**3D Geometry—Step 2**

After creating the work plane geometry, keep **Geom2** activated and use it to shape the 3D geometry.

1 From the **Draw** menu, choose **Revolve**.
2 In the resulting dialog box, enter settings as in the following figure.

![Settings for the Revolve operation.](image)

3 Click **OK**. The revolved object automatically becomes activated in **Geom1**.

4 Click the **Array** button on the Draw toolbar.

5 In the dialog box that appears, specify the following settings, then click **OK**.

<table>
<thead>
<tr>
<th>DISPLACEMENT</th>
<th>ARRAY SIZE</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>Y</td>
</tr>
<tr>
<td>28e-6</td>
<td>0</td>
</tr>
</tbody>
</table>

6 Click the **Create Composite Object** button on the Draw toolbar.

7 In the **Set formula** edit field, type `BLK2-REV1-REV2-REV3-REV4`. Click **Apply**.

8 In the **Set formula** edit field, type `BLK1*CO1`. Click **OK**.

9 Click the **Geom2** tab.

10 From the **Draw** menu, choose **Extrude**.

11 From the **Objects to extrude** list, select **CO3**. In the **Distance** edit field, type `-96e-6`. Click **OK**.

12 Click the **Geom2** tab.

13 From the **Draw** menu, choose **Work Plane Settings**.

14 On the **Quick** page, click the **y-z** button, and in the corresponding **x** edit field type `24e-6`. Click **OK**.

15 From the **Draw** menu, choose **Extrude**.
In the dialog box that appears, set the **Distance** to $216 \times 10^{-6}$. Click **OK**.

The following figure shows the 3D geometry when you have executed this step.

3D geometry after an extrusion operation on one of the arms.

**17** Click the **Geom2** tab.

**18** From the **Draw** menu, choose **Work Plane Settings**.

**19** On the **Quick** page, click the **x-y** button. In the associated **z** edit field, type $-4 \times 10^{-6}$. Click **OK**.

**20** From the **Draw** menu choose **Extrude**. Set the **Distance** to $-196 \times 10^{-6}$, then click **OK**.

**21** Click the **Geom2** tab.

**22** From the **Draw** menu, choose **Work Plane Settings**.

**23** On the **Quick** page, click the **x-y** button. In the associated **z** edit field type $24 \times 10^{-6}$. Click **OK**.

**24** From the **Draw** menu, choose **Extrude**. Set the **Distance** to $96 \times 10^{-6}$, then click **OK**.

The completed geometry should look like that in the following figure.
The completed 3D geometry after extrusion of all four arms.

PHYSICS SETTINGS—THE FOCUSING STAGE

Subdomain Settings
1. From the **Multiphysics** menu, choose **1 Geom1: Stokes (mmglf)**.
2. From the **Physics** menu, choose **Subdomain Settings**.
3. In the **Subdomain selection** list, select all the subdomains.
4. Enter the settings from the following table. When done, click **OK**.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \rho )</td>
<td>( \rho )</td>
</tr>
<tr>
<td>( \eta )</td>
<td>( \eta )</td>
</tr>
</tbody>
</table>

5. From the **Multiphysics** menu, choose **2 Geom1: Conductive Media DC (emdc)**.
6. From the **Physics** menu, choose **Subdomain Settings**.
7. For all subdomains, set \( \sigma \) to \( \sigma \). Click **OK**.
8. From the **Multiphysics** menu, choose **3 Geom1: Electrokinetic Flow (chekf)**.
9. From the **Physics** menu, choose **Subdomain Settings**.
With all subdomains still selected, enter the settings in the following table; when done, click **OK**.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>$D$ (isotropic)</td>
<td>$D$</td>
</tr>
<tr>
<td>$R$</td>
<td>$0$</td>
</tr>
<tr>
<td>$u_m$</td>
<td>$u$</td>
</tr>
<tr>
<td>$z$</td>
<td>$-1$</td>
</tr>
<tr>
<td>$u$</td>
<td>$u$</td>
</tr>
<tr>
<td>$v$</td>
<td>$v$</td>
</tr>
<tr>
<td>$w$</td>
<td>$w$</td>
</tr>
<tr>
<td>$V$</td>
<td>$V$</td>
</tr>
</tbody>
</table>

**Boundary Conditions**

1. From the **Multiphysics** menu, choose **1 Geom1:Stokes (mmglf)**.
2. From the **Physics** menu, choose **Boundary Settings**.
3. Specify the following boundary conditions (for boundaries not listed in the table, the default No slip condition applies); when done, click **OK**.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 1</th>
<th>BOUNDARIES 21, 26</th>
<th>BOUNDARY 54</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary type</td>
<td>Inlet</td>
<td>Inlet</td>
<td>Outlet</td>
</tr>
<tr>
<td>Boundary condition</td>
<td>Laminar inflow</td>
<td>Laminar inflow</td>
<td>Pressure, no viscous stress</td>
</tr>
<tr>
<td>$U_0$</td>
<td>$u_a$</td>
<td>$w_a$</td>
<td></td>
</tr>
<tr>
<td>$L_{entr}$</td>
<td>$1e-4$</td>
<td>$1e-4$</td>
<td></td>
</tr>
<tr>
<td>Constrain outer edges to zero</td>
<td>Yes</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>$p_0$</td>
<td></td>
<td></td>
<td>$0$</td>
</tr>
</tbody>
</table>

4. From the **Multiphysics** menu, choose **2 Geom1: Conductive Media DC (emdc)**.
5. From the **Physics** menu, choose **Boundary Settings**.
6. Click in the **Boundary selection** list and press Ctrl+A to select all boundaries. From the **Boundary condition** list, select **Electric insulation**.
7 Edit the boundary conditions according to the following table; when done, click **OK**.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 1</th>
<th>BOUNDARY 54</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Electric potential</td>
<td>Ground</td>
</tr>
<tr>
<td>V₀</td>
<td>-1</td>
<td>-</td>
</tr>
</tbody>
</table>

8 From the **Multiphysics** menu, choose **3 Geom1: Electrokinetic Flow (chekf)**.

9 From the **Physics** menu, choose **Boundary Settings**.

10 Specify boundary settings as in the following table (for boundaries not listed, the default Insulation/Symmetry condition applies); when done, click **OK**.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 1</th>
<th>BOUNDARIES 21, 26</th>
<th>BOUNDARY 54</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Concentration</td>
<td>Concentration</td>
<td>Convective flux</td>
</tr>
<tr>
<td>c₀</td>
<td>c_in</td>
<td>0</td>
<td>-</td>
</tr>
</tbody>
</table>

**MESH GENERATION**

1 Click **Geom1** to activate the 3D geometry.

2 Click the **Initialize Mesh** button on the Main toolbar.

**COMPUTING THE SOLUTION—THE FOCUSING STAGE**

First, compute the solution for the velocity field, and then use that solution when solving the mass-transport problem.

1 Click the **Solver Manager** button on the Main toolbar.

2 Click the **Solve For** tab.

3 From the **Solve for variables** tree, select **Geom1 (3D)>Stokes (mmglf)**.

4 Click the **Solve** button.

5 When the solver has finished, click the **Initial Value** tab.

6 Click the **Current solution** option button in the **Initial value** area, then return to the **Solve For** page.

7 From the **Solve for variables** tree, select **Geom1 (3D)>Conductive Media DC (emdc)**.

8 Click **Solve**

9 From the **Solve for variables** tree, select **Geom1 (3D)>Electrokinetic Flow (chekf)**.

10 Click **Solve**.

11 On the **Initial Value** page, click the **Store Solution** button.

12 Click **OK** to close the **Solver Manager**.
PHYSICS SETTINGS—INJECTION STAGE, MODE A

Subdomain Settings
1. From the Multiphysics menu, choose 3 Geom1: Electrokinetic Flow (chekf).
2. From the Physics menu, choose Subdomain Settings.
3. In the Subdomain selection list, select all the subdomains, then change the settings for velocity parameters as in the following table; when done, click OK.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>u</td>
<td>0</td>
</tr>
<tr>
<td>v</td>
<td>0</td>
</tr>
<tr>
<td>w</td>
<td>0</td>
</tr>
</tbody>
</table>

Boundary Conditions
1. From the Physics menu, choose Boundary Settings.
2. Select Boundaries 1, 21, 26, and 54 (the inlets and outlets).
3. From the Boundary condition list, select Flux.
4. In the $N_0$ edit field, type \(-\text{nmflux}_c_{\text{chekf}}\).
   The predefined boundary variable \(\text{nmflux}_c_{\text{chekf}}\) gives the outward normal electrophoretic flux, \(N_0 \cdot n\).
5. Click OK.
6. From the Multiphysics menu, choose 2 Geom1: Conductive Media DC (emdc).
7. From the Physics menu, choose Boundary Settings.
8. Change the boundary settings as in the following table; when done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 1, 54</th>
<th>BOUNDARY 21</th>
<th>BOUNDARY 26</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Electric insulation</td>
<td>Electric potential</td>
<td>Electric potential</td>
</tr>
<tr>
<td>(V_0)</td>
<td>-</td>
<td>0</td>
<td>-3.2</td>
</tr>
</tbody>
</table>

COMPUTING THE SOLUTION—INJECTION STAGE, MODE A
1. Click the Solver Manager button on the Main toolbar.
2. Click the Script tab. Select the Automatically add commands when solving check box.
   This setting instructs the software to record the subsequent solver settings and commands, which you can then reuse when solving Mode B.
3 Click the Initial Value tab. In the Initial value area, click the Stored solution option button. This makes the steady-state solution from the focusing stage the initial solution.

4 Click the Solve For tab.

5 In the Solve for variables tree, select Geom1 (3D)>Conductive Media DC (emdc).

6 Click Solve.

7 Click the Solver Parameters button on the Main toolbar.

8 From the Analysis list, select Transient.

9 In the Time stepping area go to the Times edit field and enter 0:0.03:0.6.

10 Click OK.

11 Activate the Solver Manager window.

12 Click the Initial Value tab.

13 In the Initial value area, click the Current solution option button.

14 Click the Solve For tab.

15 In the Solve for variables tree, select Geom1 (3D)>Electrokinetic Flow (chekf).

16 Click Solve.

17 Click OK.

POSTPROCESSING AND VISUALIZATION—INJECTION STAGE, MODE A

Reproduce the plot in Figure 4-9 on page 255 with the following steps:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, select the Subdomain and Geometry edges check boxes in the Plot type area and clear all the others.

3 From the Solution at time list, select 0.

4 Click the Subdomain tab. From the Predefined quantities list on the Color Data page, select Electrokinetic Flow (chekf)>Concentration, \( c \). Click Apply.

5 Click the Go to Default 3D View button on the Camera toolbar, then click the Zoom Extents button on the Main toolbar.

To visualize the solution at two later times, as in the left panels of Figure 4-10 and Figure 4-11 on page 256, do as follows:

6 Return to the Subdomain page of the Plot Parameters dialog box.

7 Clear the Color scale check box in the Element color area.
8 Click the General tab. From the Solution at time list, select 0.06. Click Apply to generate the plot in the left panel.

9 From the Solution at time list, select 0.12. Click OK to generate the plot in the left panel.

To make an animation of the solution, click the Animate button on the Plot toolbar. On the Animate page of the Plot Parameters dialog box, you can customize the movie settings.

Generate the upper plot of Figure 4-12, by executing the following instructions:

1 From the Postprocessing menu, choose Cross-Section Plot Parameters.
2 On the General page, select Interpolated times from the Select via list.
3 In the Times edit field, type 0:0.06:0.6.
4 Click the Line/Extrusion tab.
5 In the Predefined quantities list, select Electrokinetic Flow (chekf)>Concentration, c.
6 In the x-axis data area, click the option button next to the Expression button and then click Expression.
7 In the Expression edit field, type 10[µm]-z. Click OK.
8 In the Cross-section line data area, enter the settings listed in the following table; when done, click OK.

<table>
<thead>
<tr>
<th>CROSS-SECTION LINE DATA</th>
<th>x0</th>
<th>x1</th>
</tr>
</thead>
<tbody>
<tr>
<td>x</td>
<td>1e-5</td>
<td>1e-5</td>
</tr>
<tr>
<td>y</td>
<td>1e-5</td>
<td>1e-5</td>
</tr>
<tr>
<td>z</td>
<td>2e-5</td>
<td>-2e-4</td>
</tr>
</tbody>
</table>

| Line resolution | 200 |

**PHYSICS SETTINGS—INJECTION STAGE, MODE B**

**Boundary Conditions**

1 From the Physics menu, choose Boundary Settings.

2 Change the boundary settings for the Conductive Media DC application mode to those in the following table; when done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 1</th>
<th>BOUNDARIES 21, 54</th>
<th>BOUNDARY 26</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Electric potential</td>
<td>Electric potential</td>
<td>Electric potential</td>
</tr>
<tr>
<td>V_0</td>
<td>-1</td>
<td>0</td>
<td>-3.2</td>
</tr>
</tbody>
</table>
Computing the Solution—Injection Stage, Mode B

1. Click the Solver Manager button on the Main toolbar.
2. On the Script page, select the Solve using a script check box.
3. Click Solve to execute the script you see in the edit window.

4. Click OK to close the Solver Manager.

Postprocessing and Visualization—Injection Stage, Mode B

Generate the plots in the right panels of Figure 4-10 and Figure 4-11 on page 256 as follows:

1. Click the Plot Parameters button on the Main toolbar.
2. On the General page, select 0.06 from the Solution at time list. Click Apply.
   This generates the right plot in Figure 4-10.
3. Repeat Step 2 but select 0.12 from the Solution at time list to generate the right plot in Figure 4-11.
4. From the Solution at time list, select 0.
5. Click OK to close the dialog box and generate the plot you see when you open the model from the Model Library.

Finally, generate the lower plot in Figure 4-12 with the following steps:
1. From the Postprocessing menu, select Cross-Section Plot Parameters.
2. Accept the settings from Mode A by clicking OK.
ALE Fluid-Structure Interaction

Introduction

The following example demonstrates techniques for modeling fluid-structure interactions in COMSOL Multiphysics. It illustrates how fluid flow can deform surrounding structures and how to solve for the flow in a continuously deforming geometry using the arbitrary Lagrangian-Eulerian (ALE) technique.

The model geometry consists of a horizontal flow channel in the middle of which is an obstacle, a narrow vertical structure (Figure 4-13). The fluid flows from left to right, except the obstacle forces it into a narrower path in the upper part of the channel, and it imposes a force on the structure’s walls resulting from the viscous drag and fluid pressure. The structure, being made of a deformable material, bends under the applied load. Consequently, the fluid flow also follows a new path, so solving the flow in the original geometry would generate incorrect results.

The ALE method handles the dynamics of the deforming geometry and the moving boundaries with a moving grid. COMSOL Multiphysics computes new mesh coordinates on the channel area based on the movement of the structure’s boundaries and on so called mesh smoothing. The Navier-Stokes equations that solve the flow are formulated for these moving coordinates.

The structural mechanics portion of the model does not require the ALE method, and COMSOL Multiphysics solves it in a fixed coordinate system as usual. However, the strains the model computes in this way are the only source for computing the deformed coordinates with ALE.
Figure 4-13: Fluid flows into this horizontal flow channel from the left, and it enters with a parabolic velocity profile. A narrow vertical structure in the channel (the straight vertical structure) forces the flow into a narrower path. Due to fluid pressure and viscous drag, the originally vertical structure bends (the vertical structure shifted to the right). This simulation models the fluid flow in a deformed, moving mesh that follows the movement of the bending structure.

Model Definition

In this example the flow channel is 100 µm high and 300 µm long. The vertical structure—5 µm wide, 50 µm high, and with a semicircular top—sits 100 µm away from the channel’s left boundary. Assume that the structure is long in the direction perpendicular to the image.

The fluid is a water-like substance with a density \( \rho = 1000 \text{ kg/m}^3 \) and dynamic viscosity \( \eta = 0.001 \text{ Pa·s} \). To demonstrate the desired techniques, assume the structure consists of a flexible material with a density \( \rho = 7850 \text{ kg/m}^3 \) and Young’s modulus \( E = 200 \text{ kPa} \).

The model consists of a fluid part, solved with the Navier-Stokes equations in the flow channel, and a structural mechanics part, which you solve in the obstacle. A Moving
Mesh (ALE) application mode makes sure the flow domain is deformed along with the obstacle.

Transient effects are taken into account in both the fluid and the structure. The structural deformations are modeled using large deformations in the Plane Strain application mode. The displacements and displacement velocities are denoted $u, v, u_t,$ and $v_t,$ respectively. Fluid flow is described by the Navier-Stokes equations, where the velocity components and pressure are denoted $u_2, v_2,$ and $p_2,$ respectively.

**FLUID FLOW**

The fluid flow in the channel is described by the Navier-Stokes equations for the velocity field, $\mathbf{u} = (u, v),$ and the pressure, $p,$ in the spatial (deformed) moving coordinate system:

$$
\rho \frac{\partial \mathbf{u}}{\partial t} - \nabla \cdot [-p \mathbf{I} + \eta (\nabla \mathbf{u} + (\nabla \mathbf{u})^T)] + \rho ((\mathbf{u} - \mathbf{u}_m) \cdot \nabla) \mathbf{u} = \mathbf{F}
$$

$$
- \nabla \cdot \mathbf{u} = 0
$$

(4-5)

In these equations, $\mathbf{I}$ denotes the unit diagonal matrix and $\mathbf{F}$ is the volume force affecting the fluid. Assume that no gravitation or other volume forces affect the fluid, so that $\mathbf{F} = 0.$ The coordinate system velocity is $\mathbf{u}_m = (u_m, v_m)$.

At the channel entrance on the left, the flow has fully developed laminar characteristics with a parabolic velocity profile but its amplitude changes with time. At first flow increases rapidly, reaching its peak value at $0.215$ s; thereafter it gradually decreases to a steady-state value of 5 cm/s. The centerline velocity in the $x$ direction, $u_{in}$ (see Figure 4-16 on page 279), with the steady-state amplitude $\bar{U}$ comes from the equation

$$
u_{in} = \frac{\bar{U} \cdot t^2}{\sqrt{(0.04 - t^2)^2 + (0.1t)^2}}
$$

(4-6)

where $t$ must be expressed in seconds.

At the outflow (right-hand boundary), the condition is $p = 0.$ On the solid (non deforming) walls, no-slip conditions are imposed, $u = 0, v = 0,$ while on the deforming interface the velocities equal the deformation rate, $u_0 = u_t$ and $v_0 = v_t.$

**STRUCTURAL MECHANICS**

The structural deformations are solved for using an elastic formulation and a nonlinear geometry formulation to allow large deformations.
For boundary conditions, the obstacle is fixed to the bottom of the fluid channel. All other object boundaries experience a load from the fluid, given by

\[ F_T = -\mathbf{n} \cdot (-p \mathbf{I} + \eta(\nabla \mathbf{u} + (\nabla \mathbf{u})^T)) \]  \hspace{1cm} (4.7)

where \( \mathbf{n} \) is the normal vector to the boundary. This load represents a sum of pressure and viscous forces.

**MOVING MESH**

The motion of the deformed mesh is modeled using Winslow smoothing. For more information on this formulation, please refer to “The Moving Mesh Application Mode” on page 463 in the *COMSOL Multiphysics Modeling Guide*. This is the default smoothing when using the predefined Fluid-Structure Interaction coupled application modes. The boundary conditions control the displacement of the moving mesh with respect to the initial geometry. At the boundaries of the obstacle, this displacement is the same as the structural deformation. At the exterior boundaries of the flow domain, the deformation is set to zero in all directions.

**Results and Discussion**

Figure 4.14 shows the geometry deformation and flow at \( t = 4 \) s when the system is close to its steady state. Due to the channel’s small dimensions, the Reynolds number of the flow is small (\( R \ll 100 \)), and the flow stays laminar in most of the area. The swirls are restricted to a small area behind the structure. The amount of deformation
as well as the size and location of the swirls depend on the magnitude of the inflow velocity.

Figure 4-14: Flow velocity and geometry deformation at $t = 4$ s. The streamlines indicate the flow direction and the color scale indicates flow-velocity magnitude. Here the geometry deformation is scaled by unity.

Figure 4-15 shows the mesh velocity at $t = 0.15$ s. The boundaries of the narrow structure are the only moving boundaries of the flow channel. Therefore the mesh velocity also has its largest values near the structure. Depending on the current state of the deformation—whether it is increasing, decreasing or stationary—the mesh velocity can have a very different distribution. Figure 4-16 further illustrates this point; it compares the average inflow velocity to the horizontal mesh velocity and the horizontal mesh displacement just beside the top of the structure at the physical point $(1.05 \times 10^{-4}, 0.5 \times 10^{-4})$. Most of the time the deformation follows the inflow velocity quite closely. Whenever the inflow velocity starts to decrease, the deformation also decreases, which you can observe as the negative values on the horizontal mesh.
velocity. Toward the end of the simulation, when inflow and structure deformation approach their steady-state values, the mesh velocity also decreases to zero.

Figure 4-15: Mesh velocity (arrows) and mesh and geometry deformation at $t = 0.15$ s.
Figure 4-16: Inflow velocity, horizontal mesh velocity, and mesh deformation. The curve with triangles shows the average x direction velocity at the inflow boundary (m/s); the curve with circles shows $10^4 \times$ mesh displacement in the x direction ($dx_{ale}; m$) at the geometry point $(1.05 \times 10^{-4}, 0.5 \times 10^{-4})$; and the curve with squares shows $10^3 \times$ mesh velocity in the x direction ($xt; m/s$), also at the point $(1.05 \times 10^{-4}, 0.5 \times 10^{-4})$.

Figure 4-17 and Figure 4-18 compare the meshes at different times. The first image shows the initial mesh, which you generate prior to solving the model. This mesh is equally distributed around the top of the structure. The second image shows the mesh in its deformed form. Because the structure deforms more in the horizontal direction,
the mesh also changes more in this direction: On the left, the mesh elements are stretched; on the right, they are compressed in the $x$ direction.

Figure 4-17: Initial (undeformed) geometry and mesh near the top of the structure.

Figure 4-18: Deformed geometry and deformed mesh near the top of the structure at $t = 2$ s.
Modeling in COMSOL Multiphysics

This example implements the model using three application modes, which the predefined Fluid-Structure Interaction multiphysics entry sets up automatically:

- The Incompressible Navier-Stokes application mode computes the fluid dynamics. It is active only in the area of the flow channel.
- The Plane Strain application mode solves the model’s structural mechanics portion. You activate it only in the area of the narrow structure. To get a more accurate computation of the large strains, large deformation analysis is the default setting. The deformation velocity solved with this application mode acts as the boundary condition for the Incompressible Navier-Stokes and the Moving Mesh (ALE) application modes.
- The Moving Mesh (ALE) application mode solves for the deformed mesh.

To solve the FSI problem efficiently, the model makes use of the transient segregated solver to solve for the fluid velocity and pressure in one group and the structural displacements and the mesh displacements in another group.

Model Library path: MEMS_Module/Microfluidics_Models/fluid_structure_interaction

Modeling Using the Graphical User Interface

MODEL NAVIGATOR

1. In the Model Navigator, select 2D from the Space dimension list.
2. From the Application Modes list, select MEMS Module>Fluid-Structure Interaction>Plane Strain with Fluid Interaction>Transient analysis.
3. Click OK to close the Model Navigator.

GEOMETRY MODELING

1. Shift-click the Rectangle/Square button on the Draw toolbar.
2. In the Width edit field type 3e-4, and in the Height edit field type 1e-4. Click OK.
3. Click the Zoom Extents button on the Main toolbar.
4. Shift-click the Rectangle/Square button on the Draw toolbar.
In the **Width** edit field type $5e^{-6}$, and in the **Height** edit field type $4.75e^{-5}$. Enter the following positions: $X: 1e^{-4}$ $Y: 0$. Click **OK**.

6 Draw a circle by shift-clicking the **Ellipse/Circle (Centered)** button.

7 Enter $2.5e^{-6}$ in the **Radius** edit field and the positions $X: 1.025e^{-4}$ $Y: 4.75e^{-5}$. Click **OK**.

8 From the **Draw** menu, open the **Create Composite Object** dialog box. Select C1 and R2, clear the **Keep Interior Boundaries** check box, and then click **OK**.

**PHYSICS SETTINGS**

1 From the **Options** menu, choose **Constants**.

2 In the **Constants** dialog box, define the following constants with names, expressions, and (optionally) descriptions; when done, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>eta</td>
<td>$1e^{-3}[Pa*s]$</td>
<td>Fluid viscosity</td>
</tr>
<tr>
<td>rho</td>
<td>$1000[kg/m^3]$</td>
<td>Fluid density</td>
</tr>
<tr>
<td>U</td>
<td>$3.33[cm/s]$</td>
<td>Inlet mean velocity at steady state</td>
</tr>
<tr>
<td>E</td>
<td>$200[kPa]$</td>
<td>Young’s modulus</td>
</tr>
</tbody>
</table>

3 From the **Options** menu, choose **Scalar Expressions**.

4 Define the following expression (the description is optional); when done, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>u_in</td>
<td>$u_in = \frac{U*t^2}{\sqrt{t^4-0.07[s^2]*t^2+0.0016[s^4]}}$</td>
<td>Inlet mean velocity</td>
</tr>
</tbody>
</table>

**Subdomain Settings**

1 In the **Multiphysics** menu, make sure **Incompressible Navier-Stokes (mmgfl)** is selected.

2 From **Physics** menu, select **Subdomain Settings**.

3 Select Subdomain 1. From the **Group** list, select **Fluid domain**, then apply the following settings:

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\rho$</td>
<td>rho</td>
</tr>
<tr>
<td>$\eta$</td>
<td>eta</td>
</tr>
</tbody>
</table>

4 Select Subdomain 2, then select **Solid domain** from the **Group** list. This deactivates the incompressible Navier-Stokes equations in Subdomain 2 (the solid).
5 Click OK to close the dialog box.
6 From the Multiphysics menu, select Plane Strain (smpn).
7 From the Physics menu, select Subdomain Settings.
8 Select Subdomain 1, then select Fluid domain from the Group list to deactivate the structural mechanics equations in the fluid.
9 Select Subdomain 2, then select Solid domain from the Group list. In the E edit field for the Young’s modulus, type E.
10 Click OK to close the dialog box.
11 From the Multiphysics menu, select Moving Mesh (ALE).
12 From the Physics menu, open the Subdomain Settings dialog box.
13 Apply the following settings by selecting from the Group list.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN 1</th>
<th>SUBDOMAIN 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group</td>
<td>Fluid domain</td>
<td>Solid domain</td>
</tr>
</tbody>
</table>

For the fluid domain, this means that the displacements are free. In the solid domain, the deformation of the solid determines the mesh displacement.

Boundary Conditions
1 From the Multiphysics menu, select Incompressible Navier-Stokes (mmglf).
2 From the Physics menu, open the Boundary Settings dialog box.
3 Select Boundaries 4, 6, 9, and 10 (the sides and top of the obstacle), then select Structural velocity from the Group list.
4 For the remaining active boundaries, apply the following settings:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 1</th>
<th>BOUNDARY 8</th>
<th>ALL OTHERS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary type</td>
<td>Inlet</td>
<td>Outlet</td>
<td>Wall</td>
</tr>
<tr>
<td>Boundary condition</td>
<td>Laminar inflow</td>
<td>Pressure, no viscous stress</td>
<td>No slip</td>
</tr>
<tr>
<td>$U_0$</td>
<td>$u_{_in}$</td>
<td></td>
<td></td>
</tr>
<tr>
<td>$p_0$</td>
<td></td>
<td>0</td>
<td></td>
</tr>
</tbody>
</table>

5 Click OK.
6 From the Multiphysics menu, select Plane Strain (smpn).
7 In the Boundary Settings dialog box, select Boundary 5 (the bottom of the obstacle). Then select Fixed from the Constraint condition list.
8. Select Boundaries 4, 6, 9, and 10 (the sides and top of the obstacle), then select **Fluid load** from the **Group** list. This sets up the edge loads using the Lagrange multipliers and specifies them to be defined as force/area.

9. Click **OK**.

10. From the **Multiphysics** menu, select **Moving Mesh (ALE)**.

11. In the **Boundary Settings** dialog box, select the following groups from the **Group** list to apply the appropriate mesh displacements:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 4, 6, 9, 10</th>
<th>ALL OTHERS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group</td>
<td>Structural displacement</td>
<td>Fixed</td>
</tr>
</tbody>
</table>

**MESH GENERATION**

1. From the **Mesh** menu, choose **Free Mesh Parameters**.

2. On the **Global** page, click the **Custom mesh size** button, then set the **Element growth rate** to 1.2. This setting gives a slightly finer mesh near the tip of the pin.

3. Click the **Subdomain** tab, then select both subdomains. Set the **Method** to **Quad**.

4. Click **Remesh**. When the mesher has finished, click **OK**.

**COMPUTING THE SOLUTION**

1. Click the **Solver Parameters** button on the Main toolbar.

2. From the **Solve** list, choose **Time dependent segregated**.

3. In the **Times** edit field type **0:0:0.005:0.4 0.41:0:0.8 0.85:0:0.05:4**.

4. In the **Segregated groups** area, type **u2 v2 p2 lm5 lm6 lm7 Pinl_mmglf** in the **Components** edit field for Group 1. Type **u v x y** in the **Components** edit field for Group 2. Click the **Delete** button for Group 3 to remove that step.

5. Select the **Manual specification of segregated steps** check box.

6. In the **Manual specification of segregated steps** area, click the **Settings** button for Group 1.

7. In the **Damping/Termination Settings (Step 1)** dialog box, type **0.5** in the **Damping constant** edit field. Click **OK**.

8. In the **Manual specification of segregated steps** area, click the **Settings** button for Group 2.
In the Damping/Termination Settings (Step 2) dialog box, type 0.5 in the Damping constant edit field. Click OK.

The reduced damping is necessary to prevent that the moving mesh gives rise to inverted elements.

Click the Time Stepping tab.

Choose BDF from the Method list. For this multiphysics application, the BDF method works better than the generalized-α method for the time stepping.

Click OK.

Click the Solve button on the Main toolbar.

POSTPROCESSING AND VISUALIZATION

To reproduce the plot in Figure 4-14 (this is also the plot that appears in the Model Navigator and when you open the prepared model file), follow these steps:

1. Click the Plot Parameters button on the Main toolbar.
2. On the General page, find the Plot type area. Select the Surface, Boundary, and Streamline check boxes; clear all the other check boxes.
3. Click the Surface tab. From the Predefined quantities list on the Surface Data page, select Incompressible Navier-Stokes (mmglf)>Velocity field.
4. Click the Boundary tab. Type 1 in the Expression edit field on the Boundary Data page.
5. Click the Uniform color option button, then click the Color button. Set the color to black, then click OK to close the Boundary Color dialog box.
6. Click the Streamline tab. From the Predefined quantities list on the Streamline Data page, select Incompressible Navier-Stokes (mmglf)>Velocity field.
7. Click the Specify start point coordinates option button. In the X and Y edit fields enter these expressions:

| X    | linspace(0,0,15) linspace(1.2e-4,1.2e-4,3) |
| Y    | linspace(0,1e-4,15) linspace(0,0.35e-4,3) |

8. Click OK to close the Plot Parameters dialog box and generate the plot.
Lamella Mixer

Introduction

At the macroscopic level, systems usually mix fluids using mechanical actuators or turbulent 3D flow. At the microscale level, however, neither of these approaches is practical or even possible. This model demonstrates the mixing of fluids using laminar-layered flow in a MEMS mixer.

To characterize the fluid flow’s turbulent behavior scientists generally use the Reynolds number

\[ \text{Re} = \frac{\rho u L}{\eta} \]

where \( \rho \) is the fluid density, \( u \) is flow velocity, \( L \) is a characteristic length, and \( \eta \) is the fluid’s dynamic viscosity. Turbulent flow takes place when the Reynolds number is high, typically when \( \text{Re} > 2000 \). At MEMS scales, the width of a channel is in the range of 100 \( \mu \)m and the velocity is approximately 1 cm/s. In this case, for water-like substances \( \text{Re} \) is close to unity. The fluid flow is thus clearly laminar, so effective mixing of fluids in MEMS devices requires other means.

Figure 4-19 shows a section of a component that uses layered flow to improve mixing. The mixer has several lamellae of microchannels, and the two fluids being mixed are alternated for every second layer. Pressure forces the fluid to travels in the channels from back to front. The fluid enters a larger space, the mixing chamber (visible at the front of the image). The figure does not include this chamber, but it covers the area beyond where the grid of the microchannel ends. Near the ends of the microchannels the mixing chamber has distinct lamellae of the two fluids, but this separation vanishes towards the end of the chamber.
Figure 4-19: Geometry of a lamella mixer (mixing chamber not visible).

Model Definition

This model analyzes the steady-state condition of the fluid flow as well as the convection and diffusion of a dissolved substance in a lamella mixer. The geometry in Figure 4-20 corresponds to Figure 4-19 except it includes only a small vertical section of the mixer with a height of 30 µm. The model starts from a plane in the middle of the channel bending to the left and ends at a plane in the middle of the channel bending to the right.

Each microchannel in the mixer has a quadratic cross section with a side of 20 µm. Because of the chosen geometry, microchannel height in the model is only 10 µm. To create the curved channel shape, the model uses concentric circles with inner radii of 240 µm, 270 µm, and 300 µm. Except for the direction of the curvature, the geometry and dimensions of the channel layers are the same.
The fluid exiting the microchannels enters a mixing chamber of length is 200 µm and width 80 µm.

![Diagram of lamella mixer model geometry](image)

Figure 4-20: The model geometry for a lamella mixer takes advantage of symmetry so it is not necessary to model the entire height of the device.

You solve the fluid flow in the channels and in the chamber with the incompressible Navier-Stokes equations

\[
\rho \frac{\partial \mathbf{u}}{\partial t} - \nabla \cdot [p \mathbf{I} + \eta (\nabla \mathbf{u} + (\nabla \mathbf{u})^T)] + \rho \mathbf{u} \cdot \nabla \mathbf{u} = \mathbf{F}
\]

\[-\nabla \cdot \mathbf{u} = 0\]

where \(\rho\) is fluid density, \(\mathbf{u} = (u, v, w)\) is the flow-velocity field, \(p\) is fluid pressure, \(\mathbf{I}\) is the unit diagonal matrix, \(\eta\) is the fluid’s dynamic viscosity, and \(\mathbf{F} = (f_x, f_y, f_z)\) is a volume force affecting the fluid. In this model, the fluid is water with \(\rho = 1000\ \text{kg/m}^3\), \(\eta = 0.001\ \text{Pa-s}\), and \(\mathbf{F} = \mathbf{0}\) because there are no volume forces.

The system applies a pressure of 10 Pa on all six microchannel inputs to drive the flow through the mixing chamber to where there is zero pressure. At the chamber exit the flow velocity has components only in the normal direction of the boundary.
On the microchannel and mixing-chamber walls, the no-slip boundary condition applies. However, in the vertical direction, due to the geometry, you can use a symmetry boundary condition.

The following convection-diffusion equation describes the concentration of the dissolved substances in the fluid:

\[
\frac{\partial c}{\partial t} + \nabla \cdot (D \nabla c) = R + \mathbf{u} \cdot \nabla c
\]  

(4-9)

where \(c\) is the concentration, \(D\) is the diffusion coefficient, and \(R\) is the reaction rate. In this model, \(D = 10^{-10} \text{ m}^2/\text{s}\), and \(R = 0\) because the concentration is not affected by any reactions.

There is a concentration of 50 mol/m\(^3\) on the input boundaries of the channels curving to the left, but the channels curving to the left have zero concentration. At the output boundary of the mixing chamber the substance flows through the boundary by convection. The walls of the channels and the chamber are insulated for this dissolved substance, and on the top and bottom boundaries you use a symmetry boundary condition.

Results and Discussion

Figure 4-21 details fluid flow in the mixer. On a PC screen you can see a gradual change in the color of the slices, which indicates a laminar parabolic flow. The streamlines do not show swirls, and there are only small changes in the flow direction. The figure also shows that the maximum velocity of the microchannels is at the model’s boundary because it is located in the middle of the channel. In the mixing chamber, the change of flow velocity is visible only in horizontal direction because the chamber is high and flow at the model boundaries is unchanged.
The peak velocity is roughly 1.4 mm/s in the microchannels and 0.5 mm/s in the mixing chamber. Given the corresponding lengths (20 µm and 80 µm), the Reynolds numbers are $Re = 0.028$ and $Re = 0.04$, so the flow is clearly laminar.

Figure 4-21: Fluid flow in the lamella mixer.

Figure 4-22 shows the concentration distribution on the model boundaries. The inflow channels see a constant concentration of 0 or 50 mol/m$^3$ depending on the channel. Mixing starts when the fluid enters the mixing chamber. At the entrance there is a clear separation of the concentration, but this diminishes toward the end of the chamber. On the sides of the mixing chamber where the flow velocity is smaller the mixing is better than at its center. The mixing, however, is not perfect, and a reduced flow velocity, a longer mixing chamber, or some other means to increase mixing is preferable.
Figure 4-22: Concentration plot on the boundaries of the lamella mixer model.

To get another point of view, examine Figure 4-23, which shows the concentration profile at the chamber’s centerline. Near the channels the transition is very rapid, but closer to the chamber’s end the profile has a flatter sigmoid shape. On the chamber’s sides the concentration profile has the same shape, but its amplitude is between approximately 17 mol/m$^3$ and 33 mol/m$^3$.

If you generalize the concentration profile to cover the entire component (Figure 4-19 on page 287), the profile would be a wave-like curve where concentration would alternate between its minimum and maximum values with a spatial frequency related to the layer thickness.
CHAPTER 4: MICROFLUIDICS MODELS

Figure 4-23: Concentration profile along a line in the z direction in the middle of the mixing chamber at various distances from the microchannels: 20 µm (solid), 80 µm (dotted), 140 µm (dashed), and 200 µm (dash-dotted).

Modeling in COMSOL Multiphysics

In COMSOL Multiphysics you build the model with two application modes: The Incompressible Navier-Stokes application mode solves the fluid flow, and the Convection and Diffusion application mode solves the transport of the concentration within the fluid. For both modes use the default values for the equation forms: For the Incompressible Navier-Stokes application mode the default value is the full stress tensor formulation in Equation 4-8; for the Convection and Diffusion application mode the default value is the non-conservative equation form in Equation 4-9. The selection for the Convection and Diffusion application mode ensures that no artificial accumulation of concentration arises when solving the model.

Because the concentration does not affect the fluid flow it is not necessary to solve the application modes simultaneously. By solving them sequentially, first using the Navier-Stokes equations, you improve the solution’s convergence and reduce the solution time. Using this technique it takes only a few minutes to solve this model.
It is good practice to save the solution steps in a solver script using the Solver Manager. You can then use this script when trying different values for pressure, concentration, and diffusion coefficients.

To create the 3D geometry (in this example named Geom1), start with three 2D geometries named Geom2, Geom3, and Temp and extrude the 2D drawings. The geometry Temp is a temporary drawing area for creating initial objects that you copy to Geom2 and Geom3, which are work planes in the xy-plane located at $z = 0$ and $z = 0.2 \times 10^{-4}$ m, respectively. They show the geometry viewed from the top so that the upper channels curve to the right and the lower channels curve to the left.

**Model Library path:** MEMS_Module/Microfluidics_Models/lamella_mixer

**Modeling Using the Graphical User Interface**

**MODEL NAVIGATOR**

1. Open the Model Navigator, and on the New page click the Multiphysics button.
2. Click Add Geometry. From the Space dimension list, select 3D. Click OK.
3. From the list of application modes, select MEMS Module>Microfluidics>Incompressible Navier-Stokes>Steady-state analysis. Click Add.
4. From the list of application modes, select MEMS Module>Microfluidics>Convection and Diffusion. Click Add.
5. Click Add Geometry. From the Space dimension list, select 2D. Click OK. This action creates the geometry Geom2 (2D).
6. Click Add Geometry, then click OK. This creates the geometry Geom3 (2D).
7. Click Add Geometry. In the Geometry Name edit field, type Temp. Click OK.
8. Click OK to close the Model Navigator.

COMSOL Multiphysics opens in the Draw mode with the geometry Temp activated.

**GEOMETRY MODELING**

**Initial Drawings**

1. From the Options menu, select Axes/Grid Settings.
2 On the Axis page, enter x-y limits settings as given in this table; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>x min</td>
<td>-25e-5</td>
</tr>
<tr>
<td>x max</td>
<td>25e-5</td>
</tr>
<tr>
<td>y min</td>
<td>-25e-5</td>
</tr>
<tr>
<td>y max</td>
<td>25e-5</td>
</tr>
</tbody>
</table>

You are now ready to draw the initial geometries.

1 Draw six concentric circles centered at the point (\(-2.4e-4, 0\)) with radii 2.4e-4, 2.6e-4, 2.7e-4, 2.9e-4, 3.0e-4, and 3.2e-4, respectively. To do so, shift-click on the Ellipse/Circle (Centered) button on the Draw toolbar and enter the data in the dialog box.

2 Shift-click on the Rectangle/Square button on the Draw toolbar, then enter the following Size and Position settings:

<table>
<thead>
<tr>
<th>NAME</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>3.2e-4</td>
</tr>
<tr>
<td>Height</td>
<td>2e-4</td>
</tr>
<tr>
<td>Base</td>
<td>Corner</td>
</tr>
<tr>
<td>x</td>
<td>-2.4e-4</td>
</tr>
<tr>
<td>y</td>
<td>0</td>
</tr>
</tbody>
</table>

3 Click OK.

4 From the Edit menu, choose Select All.

5 Click the Union button on the Draw toolbar.

6 Click the Split Object button on the Draw toolbar.

2D Geometries

1 In the Temp geometry, select the objects CO5, CO9, and CO13 (first select CO5 and then Ctrl-click on the other two objects).

2 From the Edit menu, choose Copy.

3 Click the Geom2 tab.

4 From the Edit menu, choose Paste. In the dialog box that appears, leave the displacement values at zero. Click OK.

5 Click the Zoom Extents button on the Main toolbar.
6 Select the new objects CO1, CO2, and CO3.
7 Click the Mirror button on the Draw toolbar. In the dialog box that appears, click OK.
8 From the Edit menu, choose Cut.
9 Click the Geom3 tab.
10 From the Edit menu, choose Paste.
11 In the dialog box that appears, type 0.8e-4 in the x edit field; leave the y edit field at zero. Click OK.
12 Click the Zoom Extents button on the Main toolbar.
13 From the Draw menu, select Work-Plane Settings.
14 On the Quick page, type 0.2e-4 in the z edit field. Click OK.
15 Click the Geom2 tab.
16 Shift-click the Rectangle/Square button, then enter the following Size and Position settings:

<table>
<thead>
<tr>
<th>NAME</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>0.8e-4</td>
</tr>
<tr>
<td>Height</td>
<td>2e-4</td>
</tr>
<tr>
<td>Base</td>
<td>Corner</td>
</tr>
<tr>
<td>x</td>
<td>0</td>
</tr>
<tr>
<td>y</td>
<td>-2e-4</td>
</tr>
</tbody>
</table>

17 Click OK.
18 Click the Zoom Extents button on the Main toolbar.

3D Geometry
1 Click the Geom2 tab.
2 From the Draw menu, choose Extrude.
3 From the Objects to extrude list, select CO1, CO2, and CO3.
4 In the Distance edit field, type 1e-5. Click OK.
5 Click the Geom2 tab.
6 From the Draw menu, choose Extrude.
7 From the Objects to extrude list, select R1.
8 In the Distance edit field, type 3e-5. Click OK.
9 Click the Geom3 tab.
10 From the Draw menu, choose Extrude.
11 In the Objects to extrude list, select all of them.
12 In the Distance edit field, type 1e-5. Click OK.
13 When the software activates Geom1, click the Zoom Extents button on the Main toolbar.

OPTIONS AND SETTINGS
1 From the Options menu, choose Constants.
2 Define the following constants (the descriptions are optional); when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>p0</td>
<td>10[Pa]</td>
<td>Driving pressure</td>
</tr>
<tr>
<td>rho</td>
<td>1e3[kg/m^3]</td>
<td>Density of water</td>
</tr>
<tr>
<td>eta</td>
<td>1e-3[Pa*s]</td>
<td>Dynamic viscosity of water</td>
</tr>
<tr>
<td>c0</td>
<td>50[mo1/m^3]</td>
<td>Input concentration</td>
</tr>
<tr>
<td>D_i</td>
<td>1e-10[m^2/s]</td>
<td>Isotropic diffusion coefficient of the substance in water</td>
</tr>
</tbody>
</table>

PHYSICS SETTINGS

Subdomain Settings
1 From the Multiphysics menu, select 1 Geom1: Incompressible Navier-Stokes (mmglf).
2 From the Physics menu, select Subdomain Settings.
3 From the Subdomain selection list, select all the subdomains.
4 In the Density edit field, type rho.
5 In the Dynamic viscosity edit field, type eta.
6 Click OK.
7 From the Multiphysics menu, select 2 Geom1: Convection and Diffusion (chcd).
8 From the Physics menu, select Subdomain Settings.
9 In the D (isotropic) edit field, type D_i.
10 In the u edit field type u, in the v edit field type v, and in the w edit field type w.
11 Click OK to close the Subdomain Settings dialog box.

Boundary Conditions
1 From the Multiphysics menu, select 1 Geom1: Incompressible Navier-Stokes (mmglf).
2. From the **Physics** menu, select **Boundary Settings**.

3. Enter boundary settings from the following table. When done, click **OK**. For the exterior boundaries that are not explicitly mentioned, the default no-slip boundary condition applies.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 1, 6, 11, 38, 41, 42</th>
<th>BOUNDARIES 3, 8, 13, 17, 18, 24, 31, 37</th>
<th>BOUNDARY 16</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary type</td>
<td>Inlet</td>
<td>Symmetry boundary</td>
<td>Outlet</td>
</tr>
<tr>
<td>Boundary condition</td>
<td>Pressure, no viscous stress</td>
<td>Pressure, no viscous stress</td>
<td></td>
</tr>
<tr>
<td>$p_0$</td>
<td>$p_0$</td>
<td>0</td>
<td></td>
</tr>
</tbody>
</table>

4. From the **Multiphysics** menu, select **2 Geom4: Convection and Diffusion (chcd)**.

5. From the **Physics** menu, select **Boundary Settings**.

6. Enter boundary settings from the following table. The **Insulation/Symmetry** condition is the default and need not be set. Do not specify any conditions for the interior boundaries (Boundaries 19, 21, 27, 28, 33, and 34). When done, click **OK**.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 1, 6, 11</th>
<th>BOUNDARIES 38, 41, 42</th>
<th>BOUNDARY 16</th>
<th>ALL OTHERS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Concentration</td>
<td>Concentration</td>
<td>Convective flux</td>
<td>Insulation/Symmetry</td>
</tr>
<tr>
<td>$c_0$</td>
<td>0</td>
<td>$c_0$</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**MESH GENERATION**

1. Activate **Geom1**.

2. From the **Mesh** menu, choose **Free Mesh Parameters**.

3. From the **Predefined mesh sizes** list on the **Global** page, select **Extremely fine**.

4. Click **OK** to close the **Free Mesh Parameters** dialog box.

5. Click the **Initialize Mesh** button on the Main toolbar.

**COMPUTING THE SOLUTION**

Solve the model with the default solver. You can review the default settings in the **Solver Parameters** dialog box.

The first time you solve the model, it is a good idea to record the solution steps and use them later when solving the model with different values. To automate this process, use solver scripting.
1. Click the Solver Manager button on the Main toolbar.
2. Click the Script tab.
3. Select the Automatically add commands when solving check box.
4. Click the Solve For tab.
5. In the Solve for variables list, select Geom1 (3D)>Incompressible Navier-Stokes (mmglf).
6. Click Solve.
7. Click the Initial Value tab.
8. In the Values of variables not solved for and linearization point area, click the
   Current solution button.
9. Click the Solve For tab.
10. In the Solve for variables list, select Geom1 (3D)>Convection and Diffusion (chcd).
11. Click Solve.
12. Click the Script tab.
13. Clear the Automatically add commands when solving check box.
14. Click OK.

If you want to solve the model with other parameter values, follow the steps below.
Alternatively, you can go through the steps already listed. In the latter case, remember
to skip the tasks (Steps 2 and 3) that would add extra lines to the script.

1. Click the Solver Manager button on the Main toolbar.
2. Click the Script tab.
3. Select the Solve using a script check box.
4. Click Solve.
5. Clear the Solve using a script check box.
6. Click OK.

POSTPROCESSING AND VISUALIZATION
First inspect the fluid flow by reproducing the plot in Figure 4-21.

1. Click the Plot Parameters button on the Main toolbar.
2. On the General page, go to the Plot type area and select the Slice, Streamline, and
   Geometry edges check boxes. Clear all the other check boxes.
3. Click the Slice tab.
4 From the **Predefined quantities** list in the **Slice data** area, select **Incompressible Navier-Stokes (mmglf)>>Velocity field**.

5 From the **Unit** list, select **mm/s**.

6 In the **Slice positioning** area, set **x levels** to 0 and **y levels** to 5.

7 Click the **Streamline** tab.

8 From the **Predefined quantities** list, select **Incompressible Navier-Stokes (mmglf)>>Velocity field**.

9 From the **Streamline plot type** list, select **Magnitude controlled**.

10 On the **Density** page, set the **Min distance** to 0.01 and the **Max distance** to 0.025.

11 Click **OK**.

12 Click the **Go to Default 3D View** button on the Camera toolbar, then click the **Zoom Extents** button on the Main toolbar.

Next, reproduce the plot of the concentration field given in Figure 4-22.

1 Click the **Plot Parameters** button on the Main toolbar.

2 On the **General** page, go to the **Plot type** area and select the **Boundary and Geometry edges** check boxes. Clear all the other check boxes.

3 On the **Boundary** page, go to the **Predefined quantities** list and select **Convection and Diffusion (chcd)>>Concentration, c**. Click **OK**.

4 Click the **Go to Default 3D View** button on the Camera toolbar, then click the **Zoom Extents** button on the Main toolbar.

Finally draw the concentration profiles on the centerline of mixing chamber displayed in Figure 4-23.

1 From the **Postprocessing** menu, choose **Cross-Section Plot Parameters**.

2 On the **Line/Extrusion** page, select **Convection and Diffusion (chcd)>>Concentration, c** from the **Predefined quantities** list.

3 From the **x-axis data** list, select **z**. Enter the following **Cross-section line data**:

<table>
<thead>
<tr>
<th>SETTING</th>
<th>VALUE</th>
<th>SETTING</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>x0</td>
<td>4e-5</td>
<td>x1</td>
<td>4e-5</td>
</tr>
<tr>
<td>y0</td>
<td>-2e-5</td>
<td>y1</td>
<td>-2e-5</td>
</tr>
<tr>
<td>z0</td>
<td>0</td>
<td>z1</td>
<td>3e-5</td>
</tr>
<tr>
<td>Line resolution</td>
<td>200</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

4 Click **Apply**.
5 Click the **General** tab.

6 Select the **Keep current plot** check box.

7 Click the **Line/Extrusion** tab.

8 Change the values in the \( y_0 \) and \( y_1 \) edit fields to \( -8 \times 10^{-5} \).

9 Click the **Line Settings** button. Set **Line style** to **Dotted line**, then click **OK**.

10 Click **Apply**.

11 Change the values in the \( y_0 \) and \( y_1 \) edit fields to \( -14 \times 10^{-5} \).

12 Click the **Line Settings** button. Set **Line style** to **Dashed line**, then click **OK**.

13 Click **Apply**.

14 Change the values in the \( y_0 \) and \( y_1 \) edit fields to \( -20 \times 10^{-5} \).

15 Click the **Line Settings** button. Set **Line style** to **Dash-dot line**, then click **OK**.

16 Click **OK** to close the **Cross-Section Plot Parameters** dialog box and generate the plot.
Electroosmotic Flow in a Biochip

This model was developed by Dr. Jordan MacInnes at the University of Sheffield, UK. The modeling work at his department has been combined with experimental studies.

Introduction

Miniature laboratories (Ref. 1) are required to efficiently analyze the information in human DNA, and they can facilitate tailor-made diagnosis and treatment of hereditary diseases for individuals. A problem that arises in these lab-on-chip devices concerns the transport of the liquid samples and other solutions in the chip, which are of very small dimensions. Moving parts of micrometer scale make the chips very expensive and fragile and are therefore to be avoided if at all possible. An alternative method for transporting fluid in the samples is through electrokinetic effects, where charged ions in the solutions are subjected to an electric field. These ions can drag the entire solution through the channels in the microchip from one analyzing point to the other.

Two mechanisms can drive the flow of a saline solution in an electric field. In the presence of solid surfaces, like the micromachined surfaces of the channels of a biochip, a charged solution is formed close to the wall surfaces. This layer is referred to as a diffuse double layer. Depending on the material used, it is formed by negatively or positively charged groups on the wall’s surfaces. The electric field displaces the charged liquid in the charged double layer generating an electroosmotic flow. Figure 4-24 shows the velocity field shortly after the application of the electric field.

![Figure 4-24: Velocity field near a solid wall. The fluid flows in the direction of the electric field.](image)

Figure 4-24: Velocity field near a solid wall. The fluid flows in the direction of the electric field.
A force is imposed on the positively charged solution close to the wall surface, and the fluid starts to flow in the direction of the electric field. The velocity gradients perpendicular to the wall give rise to viscous transport in this direction. In the absence of other forces, the velocity profile eventually becomes almost uniform in the cross section perpendicular to the wall. The time constant of the overall flow is roughly 1 ms, while the flow in the double layer responds to changes far more rapidly. The layer model of MacInnes (Ref. 1) replaces the double layer with the Helmholtz-Smoluchowski relationship between wall velocity and wall electric field (Ref. 2).

The second effect arises due to differences in mobility and charge of the ionic species. Negatively and positively charged ions migrate in different directions, and these ions drag water molecules, to different extents, through the channel system. Water is dragged by the sodium ions, which can coordinate more water molecules than the chloride ions in the solution. This type of flow is called electrophoretic flow; Figure 4-25 depicts its basic principle.

Figure 4-25: Electrophoretic flow.

This particular model does not include the mass balances of dissolved species in the sample (see Ref. 1), but you could easily add these through the Electrokinetic Flow application mode. As another possible model extension, you could use a time-dependent expression for the voltage at the inlet and outlet boundaries.

Model Definition

The flow in the chip is given by the electroosmotic effect just described. To simulate this type of flow, the model must couple the electric potential distribution in the ionic solution in the chip and the equations for fluid flow.

Figure 4-26 shows the chip’s geometry. The potential difference imposed between its different parts produces a flow in the vertical or horizontal direction, depending on
the direction of the imposed field. Mode A generates a horizontal flow from right to left in the main channel; Mode B generates a flow that is vertical in the vertical channels and horizontal, from right to left, in the part of the main channel that unites the vertical branches.

![Figure 4-26: Geometry and electric field setup in the two modes: Mode A, where the flow is expected to flow in the horizontal branch, and Mode B, with flow in the vertical branch.](image)

You set the potentials at the open boundaries, where the fluid is allowed to enter or leave the channel system. The wall boundaries are denoted diffuse layer boundaries. From the published work of Dr. MacInnes (Ref. 1), you can expect the flow to be laminar and of low Reynolds number. This implies that you can use the Stokes Flow application mode. The Stokes flow equations are almost the same as the Navier-Stokes equations with the exception that they assume that the inertial term \( \rho \mathbf{u} \cdot \nabla \mathbf{u} \) is zero. Therefore they describe flow with a very low Reynolds number and very small inertial forces. Unlike the Navier-Stokes equations, the Stokes equations form a nearly linear system of equations.

The Stokes flow equations are

\[
\frac{\partial \mathbf{u}}{\partial t} - \nabla \cdot \left[ -\mathbf{p} \mathbf{1} + \eta (\nabla \mathbf{u} + (\nabla \mathbf{u})^T) \right] = \mathbf{F}
\]

\[
\nabla \cdot \mathbf{u} = 0
\]

where \( \eta \) denotes the dynamic viscosity (Pa·s), \( \mathbf{u} \) is the velocity (m/s), \( \rho \) denotes the fluid’s density (kg/m\(^3\)), and \( \mathbf{p} \) is the pressure (Pa).

The boundary conditions, according to the notations just given, are...
where $\varepsilon_0$ denotes the permittivity of free space (F/m), $\varepsilon_r$ is the relative permittivity of water (dimensionless), $\zeta_0$ refers to the zeta potential at the channel wall (V), and $V$ denotes the potential (V). For a more detailed review of the diffuse layer wall boundary condition, see Ref. 1 and Ref. 3.

Assuming that there are no concentration gradients for the ions carrying the current, it is possible to express the current balance in the channel through Ohm’s law and the balance equation for current density:

$$ u = \frac{\varepsilon_0 \varepsilon_r \zeta_0}{\eta} \nabla V $$

$$ [-p I + \eta (\nabla u + (\nabla u)^T)] \cdot n = 0 \quad \text{diffuse layer, wall} $$

$$ p = 0 \cdot [\eta (\nabla u + (\nabla u)^T)] \cdot n = 0 \quad \text{voltage boundary and inlet} $$

$$ p = 0 \quad \text{outlet} $$

The corresponding boundary conditions for the current balance are

$$ -\sigma \nabla V \cdot n = 0 \quad \text{diffuse layer, wall} $$

$$ V = V_0 \quad \text{voltage boundary, inlet or outlet} $$

where $V_0$ corresponds to the voltage shown in the previous figure at the neutral boundaries. At these boundaries, the potential and current distribution in the chip determine if the fluid enters or exits the chip or stays at rest.

The relevant material properties for water are listed in the following table.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\rho$</td>
<td>$10^3$ kg/m$^3$</td>
<td>Fluid density</td>
</tr>
<tr>
<td>$\eta$</td>
<td>$10^{-3}$ kg/(m·s)</td>
<td>Dynamic viscosity</td>
</tr>
<tr>
<td>$\sigma$</td>
<td>0.11845 S/m</td>
<td>Electric conductivity</td>
</tr>
<tr>
<td>$\varepsilon_r$</td>
<td>80.2</td>
<td>Relative permittivity</td>
</tr>
<tr>
<td>$\zeta_0$</td>
<td>0.1 V</td>
<td>Zeta potential</td>
</tr>
</tbody>
</table>
Results

Figure 4-27 shows the potential distribution for Mode A in the chip. From this plot it is clear that the largest potential differences are in the horizontal direction. This also implies that the main flow is in the same direction.

![Potential distribution in the chip when electric field from mode A is applied](image)

Figure 4-27: Potential distribution in the chip when electric field from mode A is applied.

The plot in Figure 4-28 shows that the average velocity in the channel is approximately 1 mm/s. The largest velocity is at the corner walls where the electric field is large. This clearly shows the effect of the driving force located at the walls. In normal pressure-driven flow, the velocity at the solid surfaces is zero. In fact, looking at the pressure field, you would find that it is constant in the channels.

Studying the velocity flow lines in the channel, Figure 4-29 shows that flow takes a small deviation at the T-junctions in the chip. This can also be detected in the color scale of the velocity, which decreases in the middle of the junction.

Regulating the potential can quickly and efficiently change the path of the flow in the channels. This makes it possible to mix different solutions in different branches of the chip. Figure 4-30 shows a different flow direction with the same magnitude as the potential configuration given in Mode A. In this plot you can also find the corner effects and the low-velocity regions in the T-junctions, as the channel width increases.
Figure 4-31 shows that the flow decreases in the outer parts of the turns while a maximum is seen in the inner parts. This maximum is larger in this case compared to the first case. This is because the electric field is much stronger around the corners compared to the straight path in the first simulation.
Figure 4-28: Velocity distribution in the chip with the electric field from Mode A applied.

Figure 4-29: Close-up of the velocity field. The surface color is given by the modulus of the velocity vector and the flow lines by the velocity field.
Figure 4-30: Flow distribution in the chip with the electric field from Mode B applied.

Figure 4-31: Close-up of the flow distribution near the T-junctions.
References


Model Library path: MEMS_Module/Microfluidics_Models/electroosmotic_biochip

Modeling Using the Graphical User Interface

1. In the Model Navigator, select 2D in the Space dimension list.

2. From the Application Modes list, select MEMS Module>Microfluidics>Electroosmotic Flow>Stokes Flow.

3. Click OK.

OPTIONS AND SETTINGS

1. From the Options menu, select Constants.

2. Define the following constants for water’s material properties; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>eta</td>
<td>1e-3 [Pa*s]</td>
<td>Dynamic viscosity</td>
</tr>
<tr>
<td>rho</td>
<td>1e3 [kg/m^3]</td>
<td>Density</td>
</tr>
<tr>
<td>sigma</td>
<td>0.11845 [S/m]</td>
<td>Conductivity</td>
</tr>
<tr>
<td>eps_r</td>
<td>80.2 [F/m]</td>
<td>Relative permittivity</td>
</tr>
<tr>
<td>zeta0</td>
<td>0.1 [V]</td>
<td>Zeta potential</td>
</tr>
</tbody>
</table>

GEOMETRY MODELING

You can easily create the geometry using the CAD tools in COMSOL Multiphysics.

1. Press the Shift key and click the Rectangle/Square button on the Draw toolbar.

2. In the Size area of the Rectangle dialog box, enter the Width 0.25e-3 and the Height 5.35e-3. In the Position area, set x to 2.5e-3 and y to 2.5e-4. Click OK.
Repeat this procedure to create two additional rectangles with the following properties:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>RECTANGLE 2</th>
<th>RECTANGLE 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>0.25e-3</td>
<td>1.45e-2</td>
</tr>
<tr>
<td>Height</td>
<td>5.35e-3</td>
<td>2.5e-4</td>
</tr>
<tr>
<td>x</td>
<td>5e-3</td>
<td>0</td>
</tr>
<tr>
<td>y</td>
<td>-5.35e-3</td>
<td>0</td>
</tr>
</tbody>
</table>

4. Click the **Zoom Extents** button on the Main toolbar.
5. Press Ctrl+A to select all geometry objects.
6. Click the **Union** button on the Draw toolbar.
7. Click the **Delete Interior Boundaries** button.
8. From the **Draw** menu, select **Fillet/Chamfer**.
9. In the drawing area, Ctrl-click to select the four vertices connecting the vertical channels with the horizontal one (Vertices 3, 5, 8, and 10).

10. In the **Fillet/Chamfer** dialog box, specify the fillet **Radius 0.5e-4**.
11. Click **OK** to close the dialog box.

This completes the geometry modeling stage.
PHYSICS SETTINGS

Subdomain Settings
1 From the Multiphysics menu, select 1 Stokes Flow (mmglf).
2 From the Physics menu, open the Subdomain Settings dialog box.
3 Select Subdomain 1.
4 In the ρ edit field, type rho, and in the η edit field, type eta. Click OK.
5 In the Multiphysics menu, switch to the 2 Conductive Media DC (emdc) application mode.
6 From the Physics menu, open the Subdomain Settings dialog box.
7 In the σ edit field, type sigma. Click OK.

Boundary Conditions
1 From the Multiphysics menu, select 1 Stokes Flow (mmglf).
2 From the Physics menu, open the Boundary Settings dialog box.
3 Specify boundary conditions according to the following table; when done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 1</th>
<th>BOUNDARIES 2–4, 6–8, 10, 11, 13–16</th>
<th>BOUNDARIES 5, 9, 12</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary type</td>
<td>Outlet</td>
<td>Wall</td>
<td>Open boundary</td>
</tr>
<tr>
<td>Boundary condition</td>
<td>Pressure, no viscous stress</td>
<td>Electroosmotic velocity</td>
<td>Normal stress</td>
</tr>
<tr>
<td>p₀</td>
<td>0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Eₓ</td>
<td>Ex_emdc</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Eᵧ</td>
<td>Ey_emdc</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ζ</td>
<td>zeta0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>f₀</td>
<td>0</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

4 From the Multiphysics menu, select 2 Conductive Media DC (emdc).
5 From the Physics menu, open the Boundary Settings dialog box.
6 Enter boundary conditions according to the following table; when done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 1</th>
<th>BOUNDARY 5</th>
<th>BOUNDARY 9</th>
<th>BOUNDARY 12</th>
<th>BOUNDARIES 2–4, 6–8, 10, 11, 13–16</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Electric potential</td>
<td>Electric potential</td>
<td>Electric potential</td>
<td>Electric potential</td>
<td>Electric insulation</td>
</tr>
<tr>
<td>V₀</td>
<td>283</td>
<td>248</td>
<td>213</td>
<td>79</td>
<td></td>
</tr>
</tbody>
</table>
MESH GENERATION
1 From the Mesh menu, select Free Mesh Parameters.
2 Click the Custom mesh size button, then set the Mesh curvature factor to 0.6.
3 Click the Boundary tab. From the Boundary selection list, select 1, 5, 9, and 12.
4 In Maximum element size edit field, type $1\times10^{-4}$.
5 Click the Remesh button to generate the mesh.
6 When the mesher has finished, click OK.

COMPUTING THE SOLUTION
Click the Solve button on the Main toolbar.

POSTPROCESSING AND VISUALIZATION
Follow these instructions to generate the plot in Figure 4-27:
1 Click the Plot Parameters button on the Main toolbar.
2 On the General page, make sure that only the Surface and Geometry edges plot types are selected.
3 On the Surface page, select Conductive Media DC (emdc)>Electric potential from the Predefined quantities list on the Surface Data page.
4 Click Apply.

Proceed to generate the plots in Figure 4-28 and Figure 4-29 with these steps:
1 On the Surface page, select Stokes Flow (mmglf)>Velocity field from the Predefined quantities list on the Surface Data page. From the Unit list, select mm/s.
2 Click Apply to obtain the plot in Figure 4-28.
3 On the Streamline page, select the Streamline plot check box.
4 From the Predefined quantities list on the Streamline Data page, select Stokes Flow (mmglf)>Velocity field.
5 From the Streamline plot type list, select Magnitude controlled. Set the Density to 9.
6 On the Line Color page, click first the Uniform color option button and then the Color button. In the Streamline Color dialog box, select the black swatch, then click OK.
7 Click the Advanced button. Set the Maximum number of integration steps to 4000.
8 Click OK to close the Advanced Streamline Parameters dialog box.
9 Click OK in the Plot Parameters dialog box.
10 From the Options menu, select Axes/Grid Settings.
11 On the Axis page, specify the following settings:

<table>
<thead>
<tr>
<th>x min</th>
<th>2e-3</th>
</tr>
</thead>
<tbody>
<tr>
<td>x max</td>
<td>6e-3</td>
</tr>
<tr>
<td>y min</td>
<td>-1e-3</td>
</tr>
<tr>
<td>y max</td>
<td>1e-3</td>
</tr>
</tbody>
</table>

12 Click OK to generate the plot in Figure 4-29.

**PHYSICS SETTINGS—MODE B**

Now switch the electric field to Mode B (see the right panel of Figure 4-26).

*Boundary Conditions*

1. From the Multiphysics menu, select 2 Conductive Media DC (emdc).
2. From the Physics menu, open the Boundary Settings dialog box.
3. Modify the boundary conditions according to the table below; when done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 1</th>
<th>BOUNDARY 5</th>
<th>BOUNDARY 9</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Electric potential</td>
<td>Electric potential</td>
<td>Electric potential</td>
</tr>
<tr>
<td>( V_0 )</td>
<td>114</td>
<td>193</td>
<td>0</td>
</tr>
</tbody>
</table>

**COMPUTING THE SOLUTION—MODE B**

Click the Restart button on the Main toolbar.

**POSTPROCESSING AND VISUALIZATION—MODE B**

The plot that appears in the drawing area when the solver has finished reproduces the one in Figure 4-31. To generate the plot in Figure 4-30, follow these steps:

1. Click the Plot Parameters button on the Main toolbar.
2. On the Streamline page, clear the Streamline plot check box, then click OK.
3. Click the Zoom Extents button on the Main toolbar.
Low-Voltage Electroosmotic Micropump

Micropumps, especially those based on electroosmotic flow (EOF), are essential components in microfluidic lab-on-a-chip devices, because they contain no moving parts and are relatively easy to integrate in microfluidic circuits during fabrication. One major drawback in the conventional design of electroosmotic micropumps is the use of a high driving voltage. Therefore, the development of a low-voltage cascade EOF pump is interesting, because it could draw power from batteries and be suitable for portable devices (Ref. 1).

This model, simulated in 2D, shows how to use the MEMS Module to study the electroosmotic flow described by the electroosmotically-induced boundary velocity. The model uses the predefined Electroosmotic Flow multiphysics coupling, which builds on the Stokes Flow and the Conductive Media DC application modes.

Introduction

When a polar liquid (such as water) and a solid (such as glass) come into contact, the solid surface acquires an electric charge, which influences the charge distribution within the liquid and causes a 2-layer charge distribution called the electric double layer or EDL (Ref. 2). The charges close to the wall are strongly drawn toward the surface, but the application of an electric field can change the charge distribution deeper in the fluid (Figure 4-32).

![Figure 4-32: Diagram of an electric double layer and the principle of electroosmotic flow.](image-url)
Because the thickness of the electric double layer is typically on the order of nanometers, you can model the electroosmotic flow velocity, $u_{eof}$, as a boundary velocity

$$u_{eof} = \mu_{eof} E = \mu_{eof} \nabla V$$  \hspace{1cm} (4-10)

where $\mu_{eof}$ is the fluid’s empirically obtained electroosmotic mobility, and $E$ is the strength of the electric field tangential to the surface. Due to the fluid’s viscous force, all the fluid in the channel moves at once.

To study the electroosmotic pumping effect, this discussion works with results published by A. Brask and others (Ref. 1) as well as Y. Takamura and others (Ref. 3). The original pump was designed to work as an effective pressure source for low applied voltages. The main idea is to connect multiple pumps in series to build up pressure (Figure 4-33). Each elementary pump consists of ten narrow channels followed by a wide single channel. The EOF in the narrow channel section acts as a high-pressure pump with a forward electric field. In the wide channel section the electric field is reversed, but here the induced back pressure is small compared to the pressure produced by the narrow channel section. After flowing through one such pump section, the accumulated voltage is zero while the electroosmotically generated pressure maintains a net flow. This feature ensures a low operating voltage, which is an attractive feature that allows the pump to be operated by batteries.

*Figure 4-33: Top view of the low-voltage cascade EOF pump with three steps (adapted from Ref. 1 and Ref. 3).*
Model Definition

The model geometry (Figure 4-34) contains only half of one pump section (Ref. 1). The flow pattern in the upper half of this section equals that in the lower half, thus reducing the geometry’s complexity.

Figure 4-34: The 2D geometry. To more clearly show the dimensions, this diagram extends the aspect ratio in the y direction.

The governing equations for flow, defined by the Stokes flow are:

\[-\nabla \cdot (\eta (\nabla u + (\nabla u)^T)) + \nabla p = 0\]
\[\nabla \cdot u = 0\]

where \( u \) is the velocity, \( \eta \) is the viscosity, and \( p \) is the pressure inside the fluid.

The model uses the Pressure boundary condition for the inlet and the outlets. To analyze the free-flow condition, there are no pressure gradients in the flow. The Neutral boundary condition for the outlets would be more precise, but in practice it leads to numerical instabilities and less accurate results. In addition, a model can use the Velocity boundary condition in a parametric analysis to study the maximum back pressure against which the pump can operate. The electroosmotic velocity boundary condition is assigned on the other boundaries. This defines the boundary velocity according to Equation 4-10.

For a conductive material, you can calculate the electric potential from the equation

\[-\nabla \cdot \sigma \nabla V = 0\]

where \( \sigma \) is the electric conductivity of the fluid and \( V \) is the electric potential. The model employs the Electric potential boundary condition to set the potential equal to
$V_0 = 10 \text{ V}$ on the electrode and to $V_0/2$ on the channel ends. At all other boundaries, the model uses the Electric insulation boundary condition.

Further, the model assumes that the fluid in the pump is water with the following material properties: density, $\rho = 1000 \text{ kg/m}^3$; dynamic viscosity, $\eta = 0.001 \text{ Pa\cdot s}$; electroosmotic mobility, $\mu_{eo} = 0.06 \text{ mm}^2/(\text{V\cdot s})$; relative permittivity, $\varepsilon_r = 78.5$; and isotropic electric conductivity, $\sigma = 0.01 \text{ S/m}$.

You start the modeling by selecting a predefined Electroosmotic Flow multiphysics coupling from the Model Navigator, which adds the two application modes to the model. You can then build the model using the predefined index groups in the **Boundary Settings** dialog boxes. For example, you can assign boundaries to the Electrode, Outlet, or Electroosmosis groups, which automatically set up the actual boundary conditions discussed earlier in this section.

**Results and Discussion**

Figure 4-35 shows the flow field when there is no applied pressure. The flow streamlines show an interesting curved behavior close to the electrode caused by the stronger electric field. Even though the electroosmotic velocity always points downward, the larger number of small channels forces a net flow through the pump: the flow through the left channel is directed upward and that through the smaller channels downward.

Figure 4-36 further illustrates this effect. In the absence of an applied pressure, the smaller channels have flat flow-velocity profiles. In the wider channel, in contrast, the forced flow leads to a laminar flow profile. Note also that at the wider channel’s boundaries, electroosmosis leads to a boundary flow in the opposite direction.

Figure 4-37 plots the flow through the pump against an applied back pressure. It gives an estimate of the strength of a single pump step. Increasing the back pressure decreases the flow, with the graph intersecting the zero line at 124 \text{ Pa}. To obtain the pump’s total strength, multiply this value by the number of steps. For the pump depicted in Figure 4-33, the result corresponds to a total maximum back pressure of roughly 372 \text{ Pa}.
Figure 4-35: Flow streamlines.

Figure 4-36: The inlet (solid) and outlet (dashed) velocity profiles.
Figure 4-37: Influx versus back pressure.

**Modeling in COMSOL Multiphysics**

To solve this model using the MEMS Module in COMSOL Multiphysics, you need the Stokes Flow and Conductive Media DC application modes. However, to simplify the model set-up, use the predefined Electroosmotic Flow multiphysics coupling, which adds those two application modes and implements the required couplings between the fluid and the electric field.

Because the flow has no effect on the electric field, you can first solve for the electric potential and then use that solution when computing the flow and pressure fields.

The first solution for the total flux is rather inaccurate. Thus it is a good idea to refine the solution using weak constraints. The advantage of this option is that it computes the fluxes very accurately; for more information on this topic, see the section “Using Weak Constraints” on page 358 in the *COMSOL Multiphysics Modeling Guide*.

This example involves a parametric study to find the maximum back pressure against which the pump can operate. For this analysis you add an integration variable that calculates the flux through the inlet channel, which you plot as a function of the applied back pressure.

**References**


---

**Model Library path:** MEMS_Module/Microfluidics_Models/electroosmotic_micropump_2d

---

**Modeling Using the Graphical User Interface**

**MODEL NAVIGATOR**

1. In the **Model Navigator**, click the **New** tab.  
2. From the **Space dimension** list, select **2D**.  
3. From the **Application Modes** list, select **MEMS Module>Microfluidics>Electroosmotic Flow>Stokes Flow**.  
4. Click **OK**.

**OPTIONS AND SETTINGS**

1. From the **Options** menu, select **Constants**.  
2. Define the following constants (the descriptions are optional); when done, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>sigma</td>
<td>0.01[S/m]</td>
<td>Electric conductivity, water</td>
</tr>
<tr>
<td>V0</td>
<td>10[V]</td>
<td>Applied voltage</td>
</tr>
<tr>
<td>d</td>
<td>20[um]</td>
<td>Device thickness</td>
</tr>
<tr>
<td>eps_r</td>
<td>78.5</td>
<td>Relative permittivity, water</td>
</tr>
<tr>
<td>mu_eo</td>
<td>0.06[mm^2/(V*s)]</td>
<td>Electroosmotic mobility</td>
</tr>
<tr>
<td>p0</td>
<td>0[Pa]</td>
<td>Outlet pressure</td>
</tr>
</tbody>
</table>

**GEOMETRY**

You can import the geometry as a COMSOL Multiphysics binary file, `electroosmotic_micropump.mphbin`. Step-by-step instructions for how to manually create the geometry are available in an appendix on page 326.
1. From the **File** menu, select **Import>CAD Data From File**.
2. From the **Files of type** list, select COMSOL Multiphysics file (*.mphtxt; *.mphbin; ...).
3. Browse to the directory where the file `electroosmotic_micropump_2d.mphbin` is stored (the same directory as the model file, that is, `models/MEMS_Module/Microfluidics_Models` under the COMSOL Multiphysics installation folder).
4. Click **Import**.

**PHYSICS SETTINGS**

**Subdomain Settings—Conductive Media DC**
1. From the **Multiphysics** menu, select **2 Conductive Media DC (emdc)**.
2. From the **Physics** menu, select **Subdomain Settings**.
3. From the **Subdomain selection** list, select all the subdomains (press Ctrl+A).
4. In the $d$ edit field, type $d$.
5. In the $\sigma$ edit field, type $\sigma$ to specify an isotropic conductivity.
6. Click **OK**.

**Boundary Conditions—Conductive Media DC**
1. From the **Physics** menu, select **Boundary Settings**.
2. Click in the **Boundary selection** list, then press Ctrl+A to select all boundaries.
3. From the **Group** list, select **Electroosmosis**.
4. Select Boundary 16.
5. From the **Group** list, select **Electrode**. In the $V_0$ edit field, type $V_0$.
6. Select the inlet and all outlet boundaries (Boundaries 2, 11, 20, 25, 30, 35, 40, 45, 50, 55, and 60). Note that you can easily do this by clicking and dragging in the drawing area to enclose the desired boundaries. From the **Group** list select **Electrode**, then type $V_0/2$ in the $V_0$ edit field.
7. On the **Groups** page, type **Middle potential** in the **Name** edit field.
8. Click **OK**.

**Subdomain Settings—Stokes Flow**
1. From the **Multiphysics** menu, select **1 Stokes Flow (mmglf)**.
2. From the **Physics** menu, select **Subdomain Settings**.
3. Select all the subdomains (press Ctrl+A).
4. On the **Physics** page, the default settings apply to water, so you need only set the **Channel thickness** to $d$. 
5 On the Microfluidic page, set the Relative permittivity $\varepsilon_r$ to $\varepsilon_{p_r}$.

6 Click OK.

**Boundary Conditions—Stokes Flow**

1 From the Physics menu, select Boundary Settings.

2 Specify boundary conditions as in the following table. The table lists only those Boundary type and Boundary condition settings that you explicitly need to change, having chosen the appropriate entry from the Group list.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 2</th>
<th>BOUNDARIES 11, 20, 25, 30, 35, 40, 45, 50, 55, 60</th>
<th>ALL OTHERS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group</td>
<td>Inlet</td>
<td>Outlet</td>
<td>Electroosmosis</td>
</tr>
<tr>
<td>Boundary condition</td>
<td>Pressure</td>
<td>Pressure, no viscous stress</td>
<td></td>
</tr>
<tr>
<td>$p_0$</td>
<td>0</td>
<td>$p_0$</td>
<td></td>
</tr>
<tr>
<td>$\mu_{eo}$</td>
<td></td>
<td></td>
<td>$\mu_{eo}$</td>
</tr>
</tbody>
</table>

Again, click and drag in the drawing area to quickly select all Outlet boundaries. To conveniently select the Electroosmosis boundaries, first select Boundary 1 and then select the Select by group check box.

3 Click OK.

**MESH GENERATION**

For this model, a mixed mesh is suitable: use mapped quad meshes for the elongated channels and a free mesh for the rest of the geometry.

1 From the Mesh menu, select Mapped Mesh Parameters.

2 Click the Boundary tab. For all of the boundaries in the following table, select the Constrained edge element distribution check box, then enter a value in the Number of edge elements edit field as indicated in the table. Note that the boundaries in the last row are all in the same line at the lower ends of the narrow channels; you can select all of them most easily by using the mouse to enclose them in the drawing area.

<table>
<thead>
<tr>
<th>BOUNDARIES</th>
<th>NUMBER OF EDGE ELEMENTS</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>90</td>
</tr>
<tr>
<td>2</td>
<td>20</td>
</tr>
<tr>
<td>10, 19, 24, 29, 34, 39, 44, 49, 54, 59</td>
<td>80</td>
</tr>
<tr>
<td>11, 20, 25, 30, 35, 40, 45, 50, 55, 60</td>
<td>8</td>
</tr>
</tbody>
</table>
3 Click the Subdomain tab. Select Subdomains 1, 4, and 7–15 (the channels).
4 Click the Mesh Selected button, then click OK.
5 From the Mesh menu, select Free Mesh Parameters.
6 On the Global page, select Extra fine from the Predefined mesh sizes list.
7 Click the Subdomain tab. Select Subdomains 2, 3, 5, and 6.
8 In the Subdomain mesh parameters area, set the Maximum element size to 1e-5.
9 Click the Mesh Selected button, then click OK.

As you can verify in the Mesh Statistics dialog box (that you open from the Mesh menu), the completed mesh consists of about 8200 quadrilateral and 6887 triangular elements.

COMPUTING THE SOLUTION
1 Click the Solver Manager button on the Main toolbar.
2 Click the Solve For tab.
3 From the Solve for variables list, select Conductive Media DC (emdc).
4 Click Solve. Doing so should result in roughly 48,600 degrees of freedom, and the solution time should be a couple of seconds.
5 Click the Initial Value tab. In the Value of variables not solved for and linearization point area, click the Current solution button.
6 Click the Solve For tab. In the Solve for variables list select Stokes Flow (mmglf).
7 Click Solve. The solution time for this solving stage should be roughly four times longer than for the electrostatics part (this time you solve for about 117,700 DOFs).
8 Click OK.

POSTPROCESSING AND VISUALIZATION
First study the velocity-field distribution inside the pump by reproducing the combined surface and streamline plot given in Figure 4-35.

1 Click the Plot Parameters button on the Main toolbar.
2 On the General page, select the Surface, Arrow, Streamline, and Geometry edges check boxes in the Plot type area. Clear all the others.
3 Click the Surface tab. On the Surface Data page, verify that the selection in the Predefined quantities list is Stokes Flow (mmglf)>Velocity field. From the Unit list, select mm/s.
4 Click the Arrow tab. On the Subdomain Data page, verify that the selection in the Predefined quantities list again is Stokes Flow (mmglf)>Velocity field.

5 In the Arrow positioning area, click the Vector with coordinates option button for x points. In the associated edit field type -2.5e-5:1e-5:2.5e-5 1.97e-4:2e-5:3.77e-4.

6 In the Arrow parameters area, select 3D arrow from the Arrow type list. Click the Color button. In the Arrow Color dialog box, click the black swatch, then click OK.

7 Click the Streamline tab. On the Streamline Data page, verify that the selection in the Predefined quantities list is Stokes Flow (mmglf)>Velocity field. From the Streamline plot type list, select Uniform density. Set the Separating distance to 0.02.

8 Click OK to generate the plot.

Next use domain plots to analyze the inlet and outlet velocity profiles.

1 From the Postprocessing menu, select Domain Plot Parameters.

2 On the General page, click the Title/Axis button at the bottom of the dialog box. Go to the Axis settings for line and point plots area. Select the option button next to the edit field for the First axis label, then enter the text Normalized channel width. Click OK.

3 Select the Keep current plot check box.

4 Click Line/Extrusion tab.

5 In the Plot type area, click the Line plot button. Select Boundary 2.

6 In the y-axis data area, select Stokes Flow (mmglf)>y-velocity from the Predefined quantities list. From the Unit list, select mm/s.

7 In x-axis data area, click the Expression option button, then click the associated Expression button. In the Expression edit field, type s (this is a predefined variable for the normalized distance along the boundary). Click OK.

8 Click Apply to generate the first graph.

9 Select Boundary 11.

10 Click the Line Settings button. From the Line style list, select Dashed line. Click OK.

11 Click OK to reproduce the plot in Figure 4-36.

Next study the total fluxes through the inlet and outlets.

1 From the Postprocessing menu, select Boundary Integration.

2 From the Boundary selection list, select 2.
In the **Expression to integrate** area, type \((-nx*u-ny*v) \cdot d\) in the **Expression** edit field and \(\text{nl/s}\) in the **Unit** edit field to obtain the result expressed in nanoliters per second. The constant \(d\) gives the structure’s thickness, while \(-nx\) and \(-ny\) are the \(x\)- and \(y\)-components of the inward-pointing normal vector.

4. **Click** **Apply**.

This setup should result in a value of 0.638 \(\text{nl/s}\), a value that appears in the message log at the bottom of the user interface.

Next, compute the total flux through the outlets.

5. **Using the mouse**, select the outlet boundaries (Boundaries 11, 20, 25, 30, 35, 40, 45, 50, 55, and 60).

6. **Click** **OK**.

The resulting value of \(-0.618\) \(\text{nl/s}\) differs slightly from the value for the inlet. You can evaluate all the other boundaries and observe that due to numerical inaccuracies the walls appear to leak slightly. Reducing this mass “leak” requires a finer mesh. For the purpose of the present analysis, assume the error to be small enough (roughly 3%) to continue the analysis.

**FINDING THE MAXIMUM BACK PRESSURE**

Finally make a parametric study where you vary the back pressure and identify the maximum back pressure from a plot of flux vs. pressure. Start by defining a global integration variable for the influx.

1. From **Options** menu, select **Integration Coupling Variables>Boundary Variables**.

2. From the **Boundary selection** list, select 2.

3. In the **Name** edit field type **Inflow**, and in the **Expression** edit field type \((-nx*u-ny*v) \cdot d\) (that is, the same expression you used for the flux studies).

4. **Click** **OK**.

5. **Click** the **Solver Parameters** button on the Main toolbar.

6. From the **Solver** list, select **Parametric**. In the **Parameter name** edit field, type \(p0\) and in the **Parameter values** edit field, type \(0:10:200\).

7. **Click** **OK**.

8. **Click** the **Solve** button on the Main toolbar. Solving this parametric study can take several minutes.

Next, plot the inflow as a function of the back pressure (see Figure 4-37).

1. From the **Postprocessing** menu, select **Global Variables Plot**.
In the Expression field, type $\text{Inflow} \cdot 1 [\text{m}^3/\text{nl}]$, then click the Add Entered Expression button immediately to the right of the edit field. Multiplying the boundary integration variable $\text{Inflow}$ (which has no unit, but by its definition is the inflow value measured in m$^3$/s) by the factor $1 [\text{m}^3/\text{nl}]$ gives the result in nanoliters/second.

Click the Title/Axis button. Enter the Title $\text{Inflow}$ vs. back pressure, the First axis label Back pressure [Pa], and the Second axis label Inflow [nl/s].

Click OK to close the Title/Axis Settings dialog box.

Click OK to close the Global Variables Plot dialog box and generate the plot.

By zooming in on the plot you can see that the inflow changes sign (that is, turns into an net outflow) around 124 Pa.

**Appendix—Geometry Modeling**

Follow these instructions to create the geometry by hand.

Shift-click the Rectangle/Square button on the Draw toolbar on the left side of the user interface and create the following rectangles:

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>R1</th>
<th>R2</th>
<th>R3</th>
<th>R4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>50e-6</td>
<td>405e-6</td>
<td>185e-6</td>
<td>5e-6</td>
</tr>
<tr>
<td>Height</td>
<td>630e-6</td>
<td>200e-6</td>
<td>230e-6</td>
<td>400e-6</td>
</tr>
<tr>
<td>x</td>
<td>-25e-6</td>
<td>-25e-6</td>
<td>195e-6</td>
<td>195e-6</td>
</tr>
<tr>
<td>y</td>
<td>0</td>
<td>430e-6</td>
<td>400e-6</td>
<td>0</td>
</tr>
</tbody>
</table>
2 Click the **Zoom Extents** button on the Main toolbar.

![The geometry before creating the array of narrow channels.](image)

3 Select **R4**, then click the **Array** button on the Draw toolbar.

4 In the **Displacement area**, for \( x \) enter \( 20 \times 10^{-6} \) and for \( y \) enter 0. In the **Array size area**, for \( x \) enter 10 and for \( y \) enter 1. Click **OK**.

![The geometry after creating the array of channels.](image)
Electroosmotic Micromixer

This model was originally done in COMSOL Multiphysics by H. Chen, Y. T. Zhang, I. Mezic, C. D. Meinhart, and L. Petzold of the University of California, Santa Barbara (Ref. 1 and Ref. 2).

Introduction

Microlaboratories for biochemical applications often require rapid mixing of different fluid streams. At the microscale, flow is usually highly ordered laminar flow, and the lack of turbulence makes diffusion the primary mechanism for mixing. While diffusional mixing of small molecules (and therefore of rapidly diffusing species) can occur in a matter of seconds over distances of tens of micrometers, mixing of larger molecules such as peptides, proteins, and high molecular-weight nucleic acids can require equilibration times from minutes to hours over comparable distances. Such delays are impractically long for many chemical analyses. These problems have led to an intense search for more efficient mixers for microfluidic systems.

Most microscale mixing devices are either passive mixers that use geometrical stirring, or active mixers that use moving parts or external forces, such as pressure or electric field.

In a passive mixer, one way of increasing the mixing is by “shredding” two or several fluids into very thin alternating layers, which decreases the average diffusion length for the molecules between the different fluids. However, these mixers often require very long mixing channels because the different fluids often run in parallel. Another way of improving mixing efficiency is to use active mixers with moving parts that stir the fluids. At the microscale level moving parts in an active mixer are very fragile. One alternative is to use electroosmotic effects to achieve a mixing effect that is perpendicular to the main direction of the flow.

This model takes advantage of electroosmosis to mix fluids. The system applies a time-dependent electric field, and the resulting electroosmosis perturbs the parallel streamlines in the otherwise highly ordered laminar flow.

Model Definition

This example of a rather simple micromixer geometry (Figure 4-38) combines two fluids entering from different inlets into a single 10 μm wide channel. The fluids then
enter a ring-shaped mixing chamber that has four microelectrodes placed on the outer wall at angular positions of 45, 135, −45, and −135 degrees, respectively. Assume that the aspect ratio (channel depth to width) is large enough that you can model the mixer using a 2D cross-sectional geometry. The material parameters relevant for the model are given in Table 4-4.

The Navier-Stokes equations for incompressible flow describe the flow in the channels:

\[
\frac{\partial \mathbf{u}}{\partial t} - \nabla \cdot (\eta (\nabla \mathbf{u} + (\nabla \mathbf{u})^T)) + \rho \mathbf{u} \cdot \nabla \mathbf{u} + \nabla p = 0
\]

\[
\n \cdot \mathbf{u} = 0
\]

Here \( \eta \) denotes the dynamic viscosity (kg/(m·s)), \( \mathbf{u} \) is the velocity (m/s), \( \rho \) equals the fluid density (kg/m\(^3\)), and \( p \) refers to the pressure (Pa).

Because you do not model the two inlet channels, assume that the entrance channel starts at a position where the flow has a fully developed laminar profile. The mixed fluid flows freely out of the right end boundary, where you specify vanishing total stress components normal to the boundary:

\[
\mathbf{n} \cdot [-\rho \mathbf{I} + \eta (\nabla \mathbf{u} + (\nabla \mathbf{u})^T)] = 0
\]

When brought into contact with an electrolyte, most solid surfaces acquire a surface charge. In response to the spontaneously formed surface charge, a charged solution forms close to the liquid-solid interface. Known as an electric double layer, it forms because of the charged groups located on the surface that faces the solution. When the operator applies an electric field, the electric field generating the electroosmotic flow.
displaces the charged liquid in the electric double layer. This scheme imposes a force on the positively charged solution close to the wall surface, and the fluid starts to flow in the direction of the electric field. The velocity gradients perpendicular to the wall give rise to viscous transport in this direction. In the absence of other forces, the velocity profile eventually becomes almost uniform in the cross section perpendicular to the wall.

This model replaces the thin electric double layer with the Helmholtz-Smoluchowski relation between the electroosmotic velocity and the tangential component of the applied electric field:

$$\mathbf{u} = \frac{\varepsilon_w \zeta_0 V}{\eta}$$

In this equation, $\varepsilon_w = \varepsilon_0 \varepsilon_r$ denotes the fluid’s electric permittivity (F/m), $\zeta_0$ represents the zeta potential at the channel wall (V), and $V$ equals the potential (V). This equation applies on all boundaries except for the entrance and the outlet.

Assuming that there are no concentration gradients in the ions that carry the current, you can express the current balance in the channel with Ohm’s law and the balance equation for current density

$$\nabla \cdot (-\sigma \nabla V) = 0$$

where $\sigma$ denotes conductivity (S/m) and the expression within parentheses represents the current density (A/m$^2$).

The electric potentials on the four electrodes are sinusoidal in time with the same maximum value ($V_0 = 0.1$ V) and the same frequency (8 Hz), but they alternate in polarity. Potentials on electrodes 1 and 3 are $V_0 \sin(2\pi f t)$, whereas potentials on electrodes 2 and 4 are $-V_0 \sin(2\pi f t)$ (see Figure 4-38).

Assume all other boundaries are insulated. The insulation boundary condition

$$-\sigma \nabla V \cdot \mathbf{n} = 0$$

sets the normal component of the electric field to zero.

At the upper half of the inlet (see Figure 4-38) the solute has a given concentration, $c_0$; at the lower half the concentration is zero. Thus, assume that the concentration changes abruptly from zero to $c_0$ at the middle of the inlet boundary. The mixed solution flows out from the right outlet by convection, and all other boundaries are assumed insulated.
Inside the mixer, the following convection-diffusion equation describes the concentration of the dissolved substances in the fluid:

\[
\frac{\partial c}{\partial t} + \nabla \cdot (-D \nabla c) = R - \mathbf{u} \cdot \nabla c
\]  \hspace{1cm} (4-11)

Here \( c \) is the concentration, \( D \) represents the diffusion coefficient, \( R \) denotes the reaction rate, and \( \mathbf{u} \) equals the flow velocity. In this model \( R = 0 \) because the concentration is not affected by any reactions.

Results and Discussion

Figure 4-39 shows a typical instantaneous streamline pattern. It reveals that electroosmotic recirculation of the fluid vigorously stirs the flow, typically in the form of two rotating vortices near the electrodes.

The fundamental processes of effective mixing involve a combination of repeated stretching and folding of fluid elements in combination with diffusion at small scales. As the system applies the AC field (Figure 4-40), the resulting electroosmotic flow perturbs the laminar pressure-driven flow such that it pushes the combined stream pattern up and down at the beginning of the mixing chamber, causing extensive folding and stretching of material lines.

<table>
<thead>
<tr>
<th>PARAMETER</th>
<th>VALUE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \rho )</td>
<td>1000 kg/m(^3)</td>
<td>Density of the fluid</td>
</tr>
<tr>
<td>( \eta )</td>
<td>( 10^{-3} ) Pa·s</td>
<td>Dynamic viscosity of the fluid</td>
</tr>
<tr>
<td>( U_0 )</td>
<td>0.1 mm/s</td>
<td>Average velocity through the inlet</td>
</tr>
<tr>
<td>( \varepsilon_r )</td>
<td>80.2</td>
<td>Relative electric permittivity of the fluid</td>
</tr>
<tr>
<td>( \zeta )</td>
<td>-0.1 V</td>
<td>Zeta potential on the wall-fluid boundary</td>
</tr>
<tr>
<td>( \sigma )</td>
<td>0.11845 S/m</td>
<td>Conductivity of the ionic solution</td>
</tr>
<tr>
<td>( D )</td>
<td>( 10^{-11} ) m(^2)/s</td>
<td>Diffusion coefficient</td>
</tr>
<tr>
<td>( c_0 )</td>
<td>1 mol/m(^3)</td>
<td>Initial concentration</td>
</tr>
</tbody>
</table>
Figure 4-39: Fluid streamlines in an electroosmotic micromixer at $t = 0.0375 \text{s}$.

Figure 4-40: Electric potential lines for an electroosmotic micromixer. The contour lines show the shape when the device uses maximal potentials ($\pm V_0$).
The following plots further exemplify how the mixer operates. Figure 4-41 shows the concentration at steady state when the electric field is not applied. The flow is laminar and the diffusion coefficient is very small, so the two fluids are well separated also at the outlet. When the alternating electric field is applied, the mixing increases considerably owing to the alternating swirls in the flow. Figure 4-42 depicts the system at the instant when the electric field and the electroosmotic velocity have their largest magnitudes during the cycle (that is, when $|\sin \omega t| = 1$). From the plot you can estimate that the concentration at the output fluctuates with the same frequency as the electric field. Thus, this mixer should be further improved to get a steadier output.

*Figure 4-41: Steady-state solution in the absence of an electric field.*
This example demonstrates a rather simple and effective use of electrokinetic forces for mixing. The scheme is easy to implement, and you can easily control both the amplitude and the frequency. At low Reynolds numbers the inertial forces are small, which makes it possible to calculate stationary streamlines patterns using the parametric solver to control amplitude.

**Modeling in COMSOL Multiphysics**

Cummings and others (Ref. 3) have shown that in order to use the Helmholtz-Smoluchowski equation at the fluid-solid boundaries, the electric field must be at least quasi-static to neglect transient effects. In other words, the time scale of the unsteady electric field must be much larger than that of the transient flow. Y. T. Zhang and others (Ref. 1) estimated that the time scale of the transient effect in the modeled micromixer (with a channel width of 10 microns) is roughly 0.0127 s. In this simulation the frequency of the applied electric potential is 8 Hz, which corresponds to a time scale of the electric field 10 times larger than that of the flow.
Because you can model the time-dependent electric field as a product of a stationary electric field and a time-dependent phase factor ($\sin \omega t$), it is possible to reduce the simulation time and memory requirements by dividing the solution into two stages. In the first, calculate the amplitude of the electric potential field and the initial state for the time-dependent flow model using a stationary solver. In the second stage, you deactivate the DC Conductive Media application mode and calculate the transient solution for the Incompressible Navier-Stokes and the Convection and Diffusion application modes. You obtain the tangential electric field components used in the electroosmotic velocity boundary condition by multiplying the stationary DC solution by $\sin \omega t$. This approach is permissible because there is only a one-way coupling between the electric field and the fluid fields.

References


*Model Library path:* MEMS_Module/Microfluidics_Models/ electroosmotic_mixer

Modeling Using the Graphical User Interface

**MODEL NAVIGATOR**

1. In the Model Navigator, go to the New page and in the Space dimension list select 2D.
2. Click the Multiphysics button.
3 In the Application Modes list, select MEMS Module>Microfluidics>Incompressible Navier-Stokes>Transient analysis. Click Add.

4 In the Application Modes list, select MEMS Module>Electrostatics>Conductive Media DC. Click Add.

5 In the Application Modes list, select MEMS Module>Microfluidics>Convection and Diffusion>Transient analysis. Click Add.

6 Click OK.

OPTIONS AND SETTINGS

1 From the Options menu, select Constants.

2 In the dialog box that opens, define the following constants (the descriptions are optional); when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>U0</td>
<td>0.1[mm/s]</td>
<td>Mean inflow velocity</td>
</tr>
<tr>
<td>sigma_w</td>
<td>0.11845[S/m]</td>
<td>Conductivity of the ionic solution</td>
</tr>
<tr>
<td>eps_r</td>
<td>80.2</td>
<td>Relative permittivity of the fluid</td>
</tr>
<tr>
<td>zeta</td>
<td>-0.1[V]</td>
<td>Zeta potential</td>
</tr>
<tr>
<td>V0</td>
<td>0.1[V]</td>
<td>Maximum value of the AC potential</td>
</tr>
<tr>
<td>freq</td>
<td>8[Hz]</td>
<td>Frequency of the AC potential</td>
</tr>
<tr>
<td>omega</td>
<td>2*π[rad]*freq</td>
<td>Angular frequency of the AC potential</td>
</tr>
<tr>
<td>t</td>
<td>0[s]</td>
<td>Start time</td>
</tr>
<tr>
<td>D</td>
<td>1e-11[m^2/s]</td>
<td>Diffusion coefficient of the solution</td>
</tr>
<tr>
<td>c0</td>
<td>1[mol/m^3]</td>
<td>Initial concentration</td>
</tr>
</tbody>
</table>

You need the constant t (used in the scalar expressions below) when first solving the model using a stationary solver. In the time-dependent simulation, the internal time variable, t, overwrites this constant (the red color is just a warning signalling that t is an internal variable).

GEOMETRY MODELING

1 Shift-click the Rectangle/Square button on the Draw toolbar.
2 In the Rectangle dialog box that appears, enter these properties; when done, click OK.

<table>
<thead>
<tr>
<th>PARAMETER</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>80e-6</td>
</tr>
<tr>
<td>Height</td>
<td>10e-6</td>
</tr>
<tr>
<td>Base</td>
<td>Center</td>
</tr>
<tr>
<td>x position</td>
<td>0</td>
</tr>
<tr>
<td>y position</td>
<td>0</td>
</tr>
</tbody>
</table>

3 Click the Zoom Extents button on the Main toolbar.

4 Shift-click the Ellipse/Circle (Centered) button on the Draw toolbar.

5 In the Circle dialog box that appears, enter these properties; when done, click OK.

<table>
<thead>
<tr>
<th>PARAMETER</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Radius</td>
<td>15e-6</td>
</tr>
<tr>
<td>Base</td>
<td>Center</td>
</tr>
<tr>
<td>x position</td>
<td>0</td>
</tr>
<tr>
<td>y position</td>
<td>0</td>
</tr>
</tbody>
</table>

6 Repeat Steps 4 and 5 for another circle centered at (0, 0) and with a radius of 5e-6. Click OK.

7 Select all the geometry objects (for example by pressing Ctrl+A).

8 From the Draw menu, select Create Composite Object.

9 In the Set formula edit field, enter the expression (R1+C1) - C2.

10 Clear the Keep interior boundaries check box, then click OK.

11 Shift-click the Rectangle/Square (Centered) button in the Draw toolbar. (Steps 12 to 15 create boundaries for the four electrodes.)

12 In the Square dialog box, enter these properties; when done, click OK.

<table>
<thead>
<tr>
<th>PARAMETER</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>22.27e-6</td>
</tr>
<tr>
<td>Base</td>
<td>Center</td>
</tr>
<tr>
<td>x position</td>
<td>0</td>
</tr>
<tr>
<td>y position</td>
<td>0</td>
</tr>
</tbody>
</table>
13. Select all the geometry objects (press Ctrl+A).
14. From the Draw menu select Create Composite Object.
15. In the Set formula edit field, enter the expression \((C01*SQ1)+C01\). Verify that the Keep interior boundaries check box is cleared. Click OK.
16. Shift-click the Point button on the Draw toolbar. Specify values according to the following table; when finished, click OK.

<table>
<thead>
<tr>
<th>PARAMETER</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Coordinate x</td>
<td>-4e-5</td>
</tr>
<tr>
<td>Coordinate y</td>
<td>0</td>
</tr>
<tr>
<td>Name</td>
<td>PT1</td>
</tr>
</tbody>
</table>

**Physics Settings**

Subdomain Settings

1. From the Multiphysics menu, select 1 Incompressible Navier-Stokes (mmgfl).
2. From the Physics menu, select Subdomain Settings.
4. On the Physics page, verify that the default values are as in the following table:

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \rho )</td>
<td>1e3</td>
</tr>
<tr>
<td>( \eta )</td>
<td>1e-3</td>
</tr>
<tr>
<td>( F_x )</td>
<td>0</td>
</tr>
<tr>
<td>( F_y )</td>
<td>0</td>
</tr>
</tbody>
</table>

5. On the Microfluidic page, type \( \epsilon_r \) in the \( \varepsilon \) edit field; when done, click OK.
6. From the Multiphysics menu, select 2 Conductive Media DC (emdc).
7. From the Physics menu, select Subdomain Settings.
8. In the \( \sigma \) edit field, type \( \sigma_{\text{w}} \), then click OK.
9. From the Multiphysics menu, select 3 Convection and Diffusion (chcd).
10. From the Physics menu, select Subdomain Settings.
Specify the following properties; when done, click **OK**.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>D (isotropic)</td>
<td>D</td>
</tr>
<tr>
<td>R</td>
<td>0</td>
</tr>
<tr>
<td>u</td>
<td>u</td>
</tr>
<tr>
<td>v</td>
<td>v</td>
</tr>
</tbody>
</table>

**Boundary Conditions**

1. From the **Multiphysics** menu, choose **1 Incompressible Navier-Stokes (mmglf)**.
2. From the **Physics** menu, select **Boundary Settings**.
3. Enter the boundary conditions in the following table; when done, click **OK**.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 1, 3</th>
<th>BOUNDARIES 2, 4–6, 8–23</th>
<th>BOUNDARY 7</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary type</td>
<td>Inlet</td>
<td>Wall</td>
<td>Outlet</td>
</tr>
<tr>
<td>Boundary condition</td>
<td>Laminar inflow</td>
<td>Electroosmotic velocity</td>
<td>Normal stress</td>
</tr>
<tr>
<td>$U_0$</td>
<td>$U_0$</td>
<td>$U_0$</td>
<td>$U_0$</td>
</tr>
<tr>
<td>$l_{entr}$</td>
<td>$1e-5$</td>
<td>$1e-5$</td>
<td>$1e-5$</td>
</tr>
<tr>
<td>Constrain end points to zero</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>$E_x$</td>
<td>$E_{x_{emdc}}\sin(\omega t)$</td>
<td>$E_{x_{emdc}}\sin(\omega t)$</td>
<td>$E_{x_{emdc}}\sin(\omega t)$</td>
</tr>
<tr>
<td>$E_y$</td>
<td>$E_{y_{emdc}}\sin(\omega t)$</td>
<td>$E_{y_{emdc}}\sin(\omega t)$</td>
<td>$E_{y_{emdc}}\sin(\omega t)$</td>
</tr>
<tr>
<td>$\zeta$</td>
<td>$\zeta$</td>
<td>$\zeta$</td>
<td>$\zeta$</td>
</tr>
<tr>
<td>$f_0$</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

4. From the **Multiphysics** menu, select **2 Conductive Media DC (emdc)**.
5. From the **Physics** menu, select **Boundary Settings**.
6. Specify the boundary conditions in the following table; when done, click **OK**.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 10, 21</th>
<th>BOUNDARIES 11, 20</th>
<th>BOUNDARIES 1–9, 12–19, 22, 23</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Electric potential</td>
<td>Electric potential</td>
<td>Electric insulation</td>
</tr>
<tr>
<td>$V_0$</td>
<td>$-V_0$</td>
<td>$V_0$</td>
<td>$V_0$</td>
</tr>
</tbody>
</table>

7. From the **Multiphysics** menu, select **3 Convection and Diffusion (chcd)**.
8. From the **Physics** menu, select **Boundary Settings**.
9 Enter these boundary conditions; when done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 1, 3</th>
<th>BOUNDARIES 2, 4-6, 8-23</th>
<th>BOUNDARY 7</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Concentration</td>
<td>Insulation/Symmetry</td>
<td>Convective flux</td>
</tr>
<tr>
<td>$c_0$</td>
<td>$c_0 \cdot f_{1c2hs}(y[1/m],1e-7)$</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The concentration condition on Boundaries 1 and 3 give a sharp but smooth concentration gradient in the middle of the channel entrance.

**MESH GENERATION**

1. From the **Mesh** menu, select **Free Mesh Parameters**.
2. On the **Global** page, select **Extra fine** from the **Predefined mesh sizes** list.
3. Click the **Custom mesh size** option button. Set the **Maximum element size scaling factor** to 0.25.
4. Click the **Boundary** tab. Select Boundaries 10, 11, 20, and 21 (the electrodes).
5. In the **Boundary mesh parameters** area, set the **Maximum element size** to 0.2e-6 and the **Element growth rate** to 1.1. These settings result in a finer mesh near the electrodes.
6. Click the **Point** tab. Select Point 2.
7. In the **Point mesh parameters** area, set the **Maximum element size** to $1e-7$ and the **Element growth rate** to 1.1. With these settings, the concentration gradient at the entrance is properly resolved.
8. Click **OK** to close the **Free Mesh Parameters** dialog box.
9. Click the **Initialize Mesh** button on the Main toolbar.

**COMPUTING THE SOLUTION**

Start by computing the stationary solution for velocity, pressure, concentration, and electric potential amplitude. In the transient simulation stage, you then solve only the Incompressible Navier-Stokes and the Convection and Diffusion application modes.

1. Click the **Solver Parameters** button on the Main toolbar.
2. From the **Analysis** list, select **Stationary**, then click **Apply**.
3. Click the **Solve** button on the Main toolbar to compute the initial solutions for all application modes.
4. In the **Solver Parameters** dialog box, restore the **Analysis** list selection to **Transient**.
5. In the **Time stepping** area, type 0:0.125/60:0.5 in the **Times** edit field.
6. Click OK.

7. Click the Solver Manager button on the Main toolbar.

8. On the Initial Value page, click the Store Solution button.

9. In the Initial value area click the Stored solution option button.

10. On the Solve For page, select Incompressible Navier-Stokes (mmglf) and Convection and Diffusion (chcd) (first select one, then Ctrl-click the other).

11. Click OK.

12. Click the Solve button on the Main toolbar.

**POSTPROCESSING AND VISUALIZATION**

First study the swirls in the flow (see Figure 4-39 on page 332):

1. Click the Plot Parameters button on the Main toolbar.

2. In the Plot type area on the General page, select only Streamline and Geometry edges.

3. From the Solution at time list, select 0.0375.

4. Click the Streamline tab. From the Predefined quantities list on the Streamline Data page, select Incompressible Navier-Stokes (mmglf)>Velocity field.

5. From the Streamline plot type list, select Uniform density.

6. Set the Separating distance to 0.01, then click Apply.

Next visualize the electric potential (see Figure 4-40 on page 332):

1. Click the General tab. In the Plot type area, select only Contour and Geometry edges.

2. Click the Contour tab. On the Contour Data, page find the Predefined quantities list and select Conductive Media DC (emdc)>Electric potential.

3. In the Contour levels area, click the Vector with isolevels option button; in the associated edit field, type linspace(-0.1,0.1,20).

4. In the Contour color area click the Uniform color option button.

5. Clear the Color scale check box.

6. Click Apply.

Finally examine the mixing of the fluid:

1. On the General page, select the Surface and Streamline check boxes and clear the Contour check box in the Plot type area.

2. From the Solution at time list, select the time you want: 0 corresponds to the steady state value, and at 0.46875 the electric field has its maximum amplitude.
3  Click the **Surface** tab. From the **Predefined quantities** list, select **Convection and Diffusion (chcd)>Concentration, c**.

4  Click **Apply** to generate the plot.

5  When you are done, click **OK** to close the **Plot Parameters** dialog box.
Star-Shaped Microchannel Chip

Introduction

Lab-on-a-chip devices have become quite popular for analyses in fields such as biochemistry and bioengineering as well as MEMS in general. Through various techniques they incorporate all the equipment involved in a chemical process such as chemical reactors, heat exchangers, separators, and mixers.

This example involves the design of an infuser, a device that feeds a reactor or analysis equipment with a specific amount of fluid. Controlling pressure is an accurate way to introduce a set quantity of fluid at a certain velocity to some piece of equipment.

flushing the equipment can also be important. Optimizing such an infuser to maximize its use would involve spending the least amount of time (and fluid) flushing the equipment. Modeling this process in the time domain can lead to an optimization of the infusing pressure, microchannel design, and time control.

This model demonstrates two useful tools in COMSOL Multiphysics modeling:

• The ability to easily define a time-dependent boundary condition
• The ability to easily extrude meshes into 3D to save memory

Model Definition

This exercise arbitrarily sets the geometry and conditions of the microchannel lab-on-a-chip (Figure 4-43). The differential pressure at the five inlets relative to the outlet pressure is time-controlled so that the inlet flow passes from one to the next in a smooth way. At any particular instant, one of the inlet flows dominates, although flow could be significant from more than one inlet. The pressure at the outlet is set to zero.
Figure 4-43: Model geometry for a star-shaped infuser with five inlets and one outlet. The model sets up a varying pressure differential at each inlet in the time domain in such a way that the dominant inlet flow alternates among them.

The example models only fluid flow whose velocity is of a magnitude that suggests laminar behavior. This implies that you can get a numerical solution of the full momentum balance and continuity equations for incompressible flow with a reasonable number of elements. The equations you must solve are the Navier-Stokes equations in the time domain

\[
\rho \frac{\partial \mathbf{u}}{\partial t} - \nabla \cdot \eta (\nabla \mathbf{u} + (\nabla \mathbf{u})^T) + \rho \mathbf{u} \cdot \nabla \mathbf{u} + \nabla p = 0
\]

\[
\nabla \cdot \mathbf{u} = 0
\]

where \(\rho\) denotes density (kg/m\(^3\)), \(\mathbf{u}\) is the velocity (m/s), \(\eta\) denotes dynamic viscosity (Pa·s), and \(p\) equals pressure (Pa). The fluid in this case is water, with the corresponding density and viscosity values.

The boundary conditions for the inlets and the outlet assume a set pressure; they also assume vanishing viscous stress:

\[
[\nabla \cdot \eta (\nabla \mathbf{u} + (\nabla \mathbf{u})^T) \cdot \mathbf{n}] = 0
\]

\[
\rho = p_i
\]

Set the pressure at the outlet to zero; at the inlets, use the time-dependent expressions

\[
p_i = 50 + 10 \sin (\pi t + \alpha) \text{ Pa}
\]
where \( t \) is time (s), and \( k \) is a value between zero and one. This simplified example sets the phase \( \alpha \) to 0, \( \pi/4 \), \( \pi/2 \), \( 3\pi/4 \), or \( \pi \), depending on the inlet boundary.

Apply the no-slip condition to all other boundaries; it states that the velocity is zero in the \( x \), \( y \), and \( z \) directions at the wall:

\[
\mathbf{u} = (0, 0, 0)
\]

**Results**

Figure 4-44 shows the velocity field as a combined slice and arrow plot through the middle of the geometry at \( t = 0.5 \) s. The figure also displays the pressures at the walls. Setting up and observing this plot as an animation gives an informative qualitative description of the process as the largest pressure differential rolls from one inlet to the next.

![Figure 4-44: The velocity field in a microchannel infuser through the middle of the geometry. The plot also shows pressure at the walls.](image)

Figure 4-45 and Figure 4-46 display the pressure and velocity field’s \( x \) component (the direction of the long channel), respectively. The model includes a point in the middle of the geometry, just prior to the outlet, to investigate these two parameters. The figures show almost perfect sine curves (more frequent time sampling in the initial
stages would improve the graphs) for both of them. These results are close to those obtained with a refined mesh.

Figure 4-45: Pressure as a function of time at a point located just before the outlet.

Figure 4-46: Velocity in the x direction as a function of time at a point located just before the outlet.

Modeling in COMSOL Multiphysics

This example illustrates how to use time-dependent boundary conditions to simulate a changing process. You can implement this scenario using a boundary condition that is a function of time. The user interface provides direct access to the built-in time variable \( t \) and the mathematical functions you need.
In 3D models, results at the walls are important but they can also hide what occurs within the geometry. This example also illustrates how to better display results with the help of suppressed (hidden) boundaries.

Finally, this model approaches meshing in a way that deviates from the default settings. In most cases COMSOL Multiphysics automatically generate a 3D mesh made completely of tetrahedrons. Here—as is the case in many other microchannels and minichannels—the top and the bottom boundaries are significant in modeling the flow profile because the distance between them is of the same magnitude as that between the two sides. This means that you must model the device in 3D. However, because the microchannel’s height does not change along its length, the software does not require much meshing to resolve this dimension.

As an alternative to its default meshing, it is possible to extrude a mesh. To illustrate this concept, you create the mesh in this model by first taking a cross section of the full geometry to construct a 2D geometry. After meshing that, you then extrude both the geometry and the mesh in the height dimension. This approach allows for some mesh and memory conservation.

Model Library path: MEMS_Module/Microfluidics_Models/star_chip

Modeling Using the Graphical User Interface

MODEL NAVIGATOR
1 Start COMSOL Multiphysics.
2 On the New page in the Model Navigator, select 3D from the Space dimension list.
3 From the Application Modes list, select MEMS Module>Microfluidics>Incompressible Navier-Stokes>Transient analysis.
4 Click OK.

OPTIONS AND SETTINGS
1 From the Options menu, select Constants.
2 Enter the following variable names, expressions, and (optionally) descriptions; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>eta</td>
<td>1e-3[Pa*s]</td>
<td>Dynamic viscosity</td>
</tr>
<tr>
<td>rho</td>
<td>1e3[kg/m^3]</td>
<td>Density</td>
</tr>
<tr>
<td>p0</td>
<td>50[Pa]</td>
<td>Pressure offset</td>
</tr>
<tr>
<td>p1</td>
<td>10[Pa]</td>
<td>Pressure amplitude</td>
</tr>
<tr>
<td>omega</td>
<td>pi[rad/s]</td>
<td>Angular velocity</td>
</tr>
</tbody>
</table>

3 From the Options menu, select Expressions>Scalar Expressions.

4 Define the following expressions (the descriptions are optional); when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>p_in_rm</td>
<td>p0+p1<em>sin(omega</em>t)</td>
<td>Pressure, rightmost inlet</td>
</tr>
<tr>
<td>p_in_ir</td>
<td>p0+p1<em>sin(omega</em>t+pi/4)</td>
<td>Pressure, inner right inlet</td>
</tr>
<tr>
<td>p_in_c</td>
<td>p0+p1<em>sin(omega</em>t+pi/2)</td>
<td>Pressure, central inlet</td>
</tr>
<tr>
<td>p_in_il</td>
<td>p0+p1<em>sin(omega</em>t+3*pi/4)</td>
<td>Pressure, inner left inlet</td>
</tr>
<tr>
<td>p_in_lm</td>
<td>p0+p1<em>sin(omega</em>t+pi)</td>
<td>Pressure, leftmost inlet</td>
</tr>
</tbody>
</table>

GEOMETRY MODELING
1 From the Draw menu, choose Work-Plane Settings.
2 Click OK to use the default Quick work plane (the xy-plane at z = 0).
3 From the Options menu, select Axes/Grid Settings.
4 On the Axis page, enter the following settings:

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>x min</td>
<td>-2e-4</td>
</tr>
<tr>
<td>x max</td>
<td>4e-4</td>
</tr>
<tr>
<td>y min</td>
<td>-1.5e-4</td>
</tr>
<tr>
<td>y max</td>
<td>2e-4</td>
</tr>
</tbody>
</table>
5 On the Grid page, clear the Auto check box. In the x-y grid area, specify the grid properties according to the following table; when done, click OK.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>x spacing</td>
<td>2.5e-5</td>
</tr>
<tr>
<td>Extra x</td>
<td>-11.5e-5 -9.7e-5 -3e-5 3e-5</td>
</tr>
<tr>
<td>y spacing</td>
<td>2.5e-5</td>
</tr>
<tr>
<td>Extra y</td>
<td>1.25e-5 3e-5 5.5e-5 11e-5</td>
</tr>
</tbody>
</table>

6 Click the Line button on the Draw toolbar.

7 Click on the points in the drawing area with the following (x,y) coordinate pairs in the given order:

<table>
<thead>
<tr>
<th>ORDER</th>
<th>X-COORDINATE</th>
<th>Y-COORDINATE</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>3.25e-4</td>
<td>0.125e-4</td>
</tr>
<tr>
<td>2</td>
<td>3.25e-4</td>
<td>0.25e-4</td>
</tr>
<tr>
<td>3</td>
<td>0.3e-4</td>
<td>0.25e-4</td>
</tr>
<tr>
<td>4</td>
<td>0</td>
<td>0.3e-4</td>
</tr>
<tr>
<td>5</td>
<td>0</td>
<td>1.5e-4</td>
</tr>
<tr>
<td>6</td>
<td>-0.25e-4</td>
<td>1.5e-4</td>
</tr>
<tr>
<td>7</td>
<td>-0.25e-4</td>
<td>0.55e-4</td>
</tr>
<tr>
<td>8</td>
<td>-0.97e-4</td>
<td>1.25e-4</td>
</tr>
<tr>
<td>9</td>
<td>-1.15e-4</td>
<td>1.1e-4</td>
</tr>
<tr>
<td>10</td>
<td>-0.3e-4</td>
<td>0.25e-4</td>
</tr>
<tr>
<td>11</td>
<td>-1.5e-4</td>
<td>0.25e-4</td>
</tr>
<tr>
<td>12</td>
<td>-1.5e-4</td>
<td>0.125e-4</td>
</tr>
<tr>
<td>13</td>
<td>-0.3e-4</td>
<td>0.125e-4</td>
</tr>
</tbody>
</table>

8 Once you have clicked on the last point and have closed the geometry, right-click to create the 2D object.

9 Click the Mirror button on the Draw toolbar.

10 In the Point on line edit fields, enter 0.825e-4 as the x value and 0.125e-4 as the y value. In the Normal vector edit fields, enter 0 as the x value and 1 as the y value. Click OK.

11 Select both objects by pressing Ctrl+A.

12 Click the Union button on the Draw toolbar.
Click the **Delete Interior Boundaries** button.

![Image of microchannel infuser]

The basic 2D geometry of the microchannel infuser.

**MESH GENERATION**

This step appears earlier in the modeling process than you might be accustomed to seeing it. This happens because you are extruding a 2D mesh into 3D to create a more structured mesh than the one the default procedure gives.

1. From the **Mesh** menu, select **Free Mesh Parameters**.
2. From the **Predefined mesh sizes** list, select **Finer**.
3. Click **Remesh**, then click **OK**.
4. From the **Mesh** menu, choose **Extrude Mesh**.
5. On the **Geometry** page, type `2.5e-5` in the **Distance** edit field.
6. On the **Mesh** page, type `4` in the **Number of element layers** edit field.
7. Click **OK**.

This sequence automatically creates the 3D geometry and gives a view of the resulting mesh.
**PHYSICS SETTINGS**

**Boundary Conditions**

1. From the **Physics** menu, select **Boundary Settings**.
2. Specify boundary conditions as in the following table (all external boundaries not listed use the default no-slip condition). When done, click **OK**.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 1, 5</th>
<th>BOUNDARY 7</th>
<th>BOUNDARY 9</th>
<th>BOUNDARY 14</th>
<th>BOUNDARY 16</th>
<th>BOUNDARIES 23, 24</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary type</td>
<td>Inlet</td>
<td>Inlet</td>
<td>Inlet</td>
<td>Inlet</td>
<td>Inlet</td>
<td>Outlet</td>
</tr>
<tr>
<td>Boundary condition</td>
<td>Pressure, no viscous stress</td>
<td>Pressure, no viscous stress</td>
<td>Pressure, no viscous stress</td>
<td>Pressure, no viscous stress</td>
<td>Pressure, no viscous stress</td>
<td>Pressure, no viscous stress</td>
</tr>
<tr>
<td>p</td>
<td>p_in_c</td>
<td>p_in_ir</td>
<td>p_in_il</td>
<td>p_in_rm</td>
<td>p_in_lm</td>
<td>0</td>
</tr>
</tbody>
</table>

**Subdomain Settings**

1. From the **Physics** menu, select **Subdomain Settings**.
For Subdomain 1, specify the settings in the following table; when done, click OK.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \rho )</td>
<td>( \rho )</td>
</tr>
<tr>
<td>( \eta )</td>
<td>( \eta )</td>
</tr>
</tbody>
</table>

**COMPUTING THE SOLUTION**

1. Click the **Solver Parameters** button on the Main toolbar.
2. From the **Analysis** list, select **Transient**.
3. In the **Times** edit field, type \( 0:0.1:4 \).
4. In the **Absolute tolerance** edit field, type \( 1e-6 \).
5. Click **OK**.
6. Click the **Solve** button on the Main toolbar.

The default result plot in the user interface displays the velocity field.

A slice plot of the velocity field.

**POSTPROCESSING AND VISUALIZATION**

Reproduce the combined pressure and velocity plot in Figure 4-44 as follows:

1. Click the **Plot Parameters** button on the Main toolbar.
2 On the General page, select the Slice, Boundary, Arrow, and Geometry edges check boxes.

3 From the Solution at time list, select 0.5.

4 Clear Auto check box for the Element refinement. Type 8 in the associated edit field.

5 Click the Slice tab. From the Predefined quantities list in the Slice data area, select Velocity field. From the Unit list, select mm/s.

6 In the Slice positioning area, set x levels to 0, y levels to 0, and z levels to 1.

7 Click the Boundary tab. From the Predefined quantities list, select Pressure.

8 In the Boundary color area, select hot from the Colormap list.

9 Click the Arrow tab. Keep the default selection on the Subdomain Data page.

10 In the Arrow positioning area, set x points to 35, y points to 35, and z points to 1. In the Arrow parameters area, select 3D arrow from the Arrow type list and Normalized from the Arrow length list. Clear the Auto check box and set the Scale factor to 0.3.

11 Click OK to close the Plot Parameters dialog box and generate the plot.

To see both the pressure and the velocity field you must suppress some boundaries:

12 From the Options menu, select Suppress>Suppress Boundaries.
In the **Suppress Boundaries** dialog box, select Boundaries 1, 2, 4, 5, 7, 10, 11, 13, 14, 15, 18, and 21. Click **OK**.

**Microchannel infuser geometry after suppressing selected boundaries.**
Click the **Postprocessing Mode** button on the Main toolbar to display the solution again. To adjust the camera angle, click and drag in the drawing area.

**Velocity and pressure fields in the microchannel infuser.**

To create the two figures showing the pressure and the velocity in the $x$ direction at a point just near the outlet (Figure 4-45 and Figure 4-46), perform the following steps:

15 From the **Postprocessing** menu, choose **Cross-Section Plot Parameters**.

16 On the **Point** page, find the **Coordinates** area. In the $x$ edit field type $3.24e^{-4}$, in the $y$ edit field type $0.125e^{-4}$, and in the $z$ edit field type $0.125e^{-4}$.

17 From the **Predefined quantities** list, select **Pressure**. Click **Apply** to plot the pressure.

18 From the **Predefined quantities** list, select **x-velocity**. From the **Unit** list, select **mm/s**, then click **OK** to plot the velocity’s $x$ component.
Microchannel Cell

Introduction

This example was originally formulated by Albert Witarsa under Professor Bruce Finlayson’s supervision at the University of Washington in Seattle. It was part of a graduate course in which the assignment consisted of using mathematical modeling to evaluate the potential of patents in the field of microfluidics.

This model treats an H-microcell for separation through diffusion. The cell puts two different laminar streams in contact for a controlled period of time. The contact surface is well defined, and by controlling the flow rate it is possible to control the amount of species transported from one stream to the other through diffusion.

Figure 4-47: Diagram of the H-microcell.

![Diagram of the H-microcell](image)
Model Definition

The geometry of the microcell (Figure 4-43) is taken from Albert Witarsa’s and Professor Finlayson’s assignment. The cell geometry is divided in half because of symmetry. The design aims to avoid upsets in the flow field when the two streams, A and B, are united. This is to avoid the two streams mixing through convection, which would mix all species equally and lead to loss of control over the separation abilities. The transport of species between streams A and B should take place only by diffusion in order that species with low diffusion coefficients stay in their respective streams.

Figure 4-48: Model geometry. To avoid any type of convective mixing, the design must smoothly let both streams come in contact with each other. Due to symmetry, it is sufficient to model half the geometry.

The simulations involve solving the fluid flow in the H-cell. According to the specifications, the flow rate at the inlet is roughly 0.1 mm/s. This implies a low Reynolds number, well inside the region of laminar flow:

\[
Re = \frac{d\rho u}{\eta} = \frac{1 \cdot 10^{-5} \cdot 1 \cdot 10^3 \cdot 1 \cdot 10^{-4}}{1 \cdot 10^{-3}} \quad (4-12)
\]

Equation 4-12 gives a Reynolds number of 0.001 for a water solution and the channel dimensions given in Figure 4-43, a value typical for microchannels. Thus it is easy to get a numerical solution of the full momentum balance and continuity equations for incompressible flow with a reasonable number of elements. The equations that you need to solve are the Navier-Stokes equations at steady state:

\[
\rho (\mathbf{u} \cdot \nabla) \mathbf{u} = \nabla \cdot \left[ -\rho \mathbf{I} + \eta (\nabla \mathbf{u} + (\nabla \mathbf{u})^T) \right] \quad \nabla \cdot \mathbf{u} = 0 \quad (4-13)
\]

Here \(\rho\) denotes density (kg/m\(^3\)), \(\mathbf{u}\) is the velocity (m/s), \(\eta\) denotes viscosity (Pa·s), and \(\rho\) equals pressure (Pa).
Separation in the H-cell involves species in relatively low concentrations compared to the solvent, in this case water. This means that the solute molecules interact only with water molecules, and it is safe to use Fick’s law to describe the diffusive transport in the cell. This mass-balance equation for a solute appears in the Convection and Diffusion application mode and reads

\[-\nabla \cdot (-D \nabla c + c \mathbf{u}) = 0 . \tag{4-14}\]

In this equation, \(D\) denotes the diffusion coefficient \((\text{m}^2/\text{s})\) and \(c\) represents the concentration \((\text{mol} / \text{m}^3)\). In this model, you use the parametric solver to solve Equation 4-14 for three different values of \(D\): \(1\cdot10^{-11} \text{m}^2/\text{s}\), \(5\cdot10^{-11} \text{m}^2/\text{s}\), and \(1\cdot10^{-10} \text{m}^2/\text{s}\) to simulate the mixing of different species.

You solve two versions of the model:

- In the first version, you assume that a change in solute concentration does not influence the fluid’s density and viscosity. This implies that it is possible to first solve the Navier-Stokes equations and then solve the mass balance equation.
- In the second version, you include a correction term in the viscosity that depends quadratically on the concentration:

\[\eta = \eta_0 (1 + \alpha c^2). \tag{4-15}\]

Here \(\alpha\) is a constant of dimension \((\text{concentration})^{-2}\). An influence of concentration on viscosity of this kind is usually observed in solutions of larger molecules.

Next, consider the boundary conditions, starting with the Navier-Stokes equations. For the relevant boundary groupings, refer to Figure 4-49.

Figure 4-49: Model domain boundaries.
At the inlets and outlets, *Pressure* conditions apply along with vanishing viscous stress:

\[
p = p_0
\]
\[
\mathbf{n} \cdot \eta (\nabla \mathbf{u} + (\nabla \mathbf{u})^T) = 0
\]  
\text{(4-16)}

Setting the pressure at the outlets to zero, the pressure at the inlets represents the pressure drop over the cell. These inlet and outlet conditions comply with the H-cell being a part of a channel system of constant width, which justifies the assumption of developed flow.

At the symmetry plane, choosing the boundary type *Symmetry boundary* sets the velocity component in the normal direction of the surface to zero:

\[
\mathbf{n} \cdot \mathbf{u} = 0
\]
\[
\mathbf{t} \cdot \eta (\nabla \mathbf{u} + (\nabla \mathbf{u})^T) \mathbf{n} = 0
\]  
\text{(4-17)}

At the walls, *No slip* conditions state that the velocity is zero:

\[
(u, v, w) = (0, 0, 0) \quad \text{at the walls}
\]  
\text{(4-18)}

For the mass balances, the assumption that solute molecules interact only with water molecules implies that it is sufficient to consider a single species A of concentration \( c \).

At the inlets, use the *Concentration* boundary condition with the following values:

\[
c = c_0 \quad \text{at inlet A}
\]
\[
c = 0 \quad \text{at inlet B}
\]  
\text{(4-19)}

Model the symmetry plane and cell walls with the *Insulation/Symmetry* condition:

\[
(-D \nabla c + c \mathbf{u}) \cdot \mathbf{n} = 0 \quad \text{at the symmetry plane and walls}
\]  
\text{(4-20)}

This equation states that the flux of species perpendicular to the boundary equals zero. At the outlets, the *Convective flux* condition applies, stating that the diffusive transport perpendicular to the boundary normal is negligible:

\[
(-D \nabla c) \cdot \mathbf{n} = 0 \quad \text{at the outlets}
\]  
\text{(4-21)}

This condition eliminates concentration gradients in the flow direction.
Results

Figure 4-44 shows the velocity field. The flow is symmetric and is not influenced by the concentration field.

![Figure 4-44: Flow velocity field.](image)

Figure 4-45 shows the concentration distribution for the lightest species in this study.

![Figure 4-45: Concentration distribution for a species with diffusivity $1 \times 10^{-10} \text{m}^2/\text{s}$.](image)
Because of the relatively large diffusion coefficient, the degree of mixing is almost perfect for the lightest species. The species with a diffusion coefficient ten times smaller than that of the lightest species shows a different result.

![Concentration distribution for a species with diffusivity $1 \cdot 10^{-11} \text{m}^2/\text{s}$](image)

**Figure 4-52:** Concentration distribution for a species with diffusivity $1 \cdot 10^{-11} \text{m}^2/\text{s}$.

The concentration distribution in Figure 4-52 indicates that the diffusion coefficient for the species is low enough to avoid any significant mixing between streams A and B. The simulation clearly shows that the H-cell can separate lighter molecules from heavier ones. A cascade of H-cells can achieve a very high degree of separation.

In some cases, especially those involving solutions of macromolecules, the macromolecule concentration has a large influence on the liquid’s viscosity. In such situations, the Navier-Stokes and the convection-diffusion become coupled, and they therefore must be solved simultaneously. Figure 4-53 shows the results of such a simulation, which you repeat in the second version of this model. You can see that changes in the concentration influence the flow field. It is clear from this plot that the velocity becomes asymmetric due to changes in viscosity. As a consequence of the modified flow field, the transport of molecules to the outlet B is also different from the result using a constant flow field. You can see the difference by comparing Figure 4-54 with Figure 4-52 on page 361.
CHAPTER 4: MICROFLUIDICS MODELS

Figure 4-53: Velocity field. The viscosity varies with the concentration according to \( \eta = \eta_0(1 + \alpha c^2) \) with \( \alpha = 0.5 \text{ (m}^3\text{/mol})^2 \). The figure shows that the velocity field is affected by variations in concentration. Compare it to the velocity field in Figure 4-44.

Figure 4-54: Concentration distribution for the species with diffusivity \( 1 \times 10^{-11} \text{m}^2/\text{s} \) for the case where the fluid viscosity varies with concentration. Comparison with the plot in Figure 4-52 shows that fewer molecules of the species are transported to outlet B.
Model Library path: MEMS_Module/Microfluidics_Models/microchannel_h_cell

Modeling Using the Graphical User Interface

1. Start COMSOL Multiphysics.
2. On the New page, set the Space dimension to 3D.
3. From the list of application modes, select MEMS Module>Microfluidics> Flow with Species Transport>Incompressible Navier-Stokes.
4. Click the Multiphysics button, then click Add. As you can verify by inspection of the Multiphysics area on the right, this adds an Incompressible Navier-Stokes and a Convection and Diffusion application mode to the model. Later you will also see that a predefined coupling of the Navier-Stokes flow velocity has been included for the Convection and Diffusion application mode.
5. Click OK.

Options and Settings

1. From the Options menu, select Constants.
2. Enter the following variable names, expressions, and (optionally) descriptions in the Constants dialog box; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>rho</td>
<td>1e3[kg/m^3]</td>
<td>Density</td>
</tr>
<tr>
<td>eta</td>
<td>1e-3[Pa*s]</td>
<td>Viscosity</td>
</tr>
<tr>
<td>D</td>
<td>1e-10[m^2/s]</td>
<td>Diffusion constant</td>
</tr>
<tr>
<td>p0</td>
<td>2[Pa]</td>
<td>Pressure drop</td>
</tr>
<tr>
<td>c0</td>
<td>1[mol/m^3]</td>
<td>Inlet concentration</td>
</tr>
<tr>
<td>alpha</td>
<td>0.5[(m^3/mol)^2]</td>
<td>Viscosity c^2-term prefactor</td>
</tr>
</tbody>
</table>

Geometry Modeling

1. From the Draw menu, select Work-Plane Settings.
2. Use the default Quick work plane (the xy-plane at z = 0) by clicking OK.
3. From the Options menu, open the Axes/Grid settings.
4 On the **Axis** page, enter the following settings:

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>x min</td>
<td>-1</td>
</tr>
<tr>
<td>x max</td>
<td>15</td>
</tr>
<tr>
<td>y min</td>
<td>-7</td>
</tr>
<tr>
<td>y max</td>
<td>7</td>
</tr>
</tbody>
</table>

5 On the **Grid** page, clear the **Auto** check box and set both the **x spacing** and the **y spacing** to 1. Click **OK**.

6 Click the **Line** button on the Draw toolbar, then click the points with the **x**- and **y**-coordinates at (0, 6) and (0, 2).

7 Select the **2nd Degree Bezier Curve** tool on the Draw toolbar and click at the coordinate pairs (0, 0) and (2, 0).

8 Select the **Line** tool and click at the coordinates (12, 0).

9 Select the **2nd Degree Bezier Curve** tool and click at the coordinates (14, 0) and (14, 2).

10 Select the **Line** tool and click at the coordinates (14, 6). Continue by clicking at the coordinates (13, 6) and (13, 2).

11 Select the **2nd Degree Bezier Curve** tool and click at the coordinates (13, 1) and (12, 1).

12 Select the **Line** tool and click at the coordinates (2, 1).

13 Select the **2nd Degree Bezier Curve** tool and click at the coordinates (1, 1) and (1, 2).

14 Select the **Line** tool and click at the coordinates (1, 6).

15 Click the right mouse button to close the set of lines and create a solid object, CO1.

You have now created half of the 2D cross section and can use copy, paste, and rotate operations to create the other half.

1 Click first the **Copy** button and then the **Paste** button, both on the **Main** toolbar. Leave the **Displacement** components at 0 and click **OK** to create the composite object CO2.

2 Click the **Scale** button on the Draw toolbar. Change the **y** component of the **Scale factor** to -1 (leave the other parameters at their default values).

3 Click **OK** to flip CO2 over the **x**-axis.

4 From the **Edit** menu, choose **Select All**. (Alternatively, press Ctrl+A.)
5 Click the **Create Composite Object** button on the Draw toolbar.
6 Clear the **Keep interior boundaries** check box. Click **OK**.

   The cross section is now finished and you can extrude it to the full 3D geometry.
7 Select **Extrude** from the **Draw** menu. Let the **Distance** remain equal to 1. Click **OK**.

   The final geometry-modeling step is to scale the geometry to the correct scale.
8 Click the **Scale** button on the Draw toolbar.
9 Type $1 \times 10^{-5}$ in all three **Scale factor** edit fields. Click **OK**.
10 Click the **Zoom Extents** button on the Main toolbar.

You do not need the 2D work plane any more, so you can remove it from the model:
1 From the **Multiphysics** menu, choose **Model Navigator**.
2 In the **Multiphysics** area to the right, select **Geom2 (2D)** and then click **Remove**.
3 Click **OK** to close the **Model Navigator**.

**PHYSICS SETTINGS**

**Subdomain Settings**
1 From the **Multiphysics** menu, select **1 Incompressible Navier-Stokes (mmglf)**.
2 From the **Physics** menu, select **Subdomain Settings**.
3 Select Subdomain 1, then specify the settings in this table; when done, click **OK**.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\rho$</td>
<td>$\rho$</td>
</tr>
<tr>
<td>$\eta$</td>
<td>$\eta$</td>
</tr>
</tbody>
</table>

4 From the **Multiphysics** menu, select **2 Convection and Diffusion (chcd)**.
5 From the **Physics** menu, select **Subdomain Settings**.
6 Select Subdomain 1.
7 In the **D (isotropic)** edit field, type $D$. Note that the velocity variables from the Incompressible Navier-Stokes application mode appear as predefined couplings.
8 Click **OK** to confirm the settings and close the dialog box.

**Boundary Conditions**
1 From the **Multiphysics** menu, select **1 Incompressible Navier-Stokes (mmglf)**.
2 From the **Physics** menu, select **Boundary Settings**.
3 Specify boundary conditions as in the following table; when done, click **OK**.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 2, 8</th>
<th>BOUNDARIES 20, 22</th>
<th>BOUNDARY 4</th>
<th>ALL OTHERS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary type</td>
<td>Inlet</td>
<td>Outlet</td>
<td>Symmetry boundary</td>
<td>Wall</td>
</tr>
<tr>
<td>Boundary condition</td>
<td>Pressure, no viscous stress</td>
<td>Pressure, no viscous stress</td>
<td>No slip</td>
<td></td>
</tr>
<tr>
<td>( p_0 )</td>
<td>( p_0 )</td>
<td>0</td>
<td>-</td>
<td>-</td>
</tr>
</tbody>
</table>

4 From the **Multiphysics** menu, select **2 Convection and Diffusion (chcd)**.

5 From the **Physics** menu, select **Boundary Settings**.

6 Specify the boundary conditions in the following table; when done, click **OK**.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 2</th>
<th>BOUNDARY 8</th>
<th>BOUNDARIES 20, 22</th>
<th>ALL OTHERS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Concentration</td>
<td>Concentration</td>
<td>Convective flux</td>
<td>Insulation/ Symmetry</td>
</tr>
<tr>
<td>( c_0 )</td>
<td>( c_0 )</td>
<td>0</td>
<td>-</td>
<td>-</td>
</tr>
</tbody>
</table>

**MESH GENERATION**

1 From the **Mesh** menu, select **Free Mesh Parameters**.

2 From the **Predefined mesh sizes** list, select **Extra fine**.

3 Click the **Remesh** button.

4 When the mesher has finished, click **OK**.

**COMPUTING THE SOLUTION**

Start by first computing the solution for the velocity field and then use that solution for solving the mass transport problem.

1 Click the **Solver Parameters** button on the Main toolbar.

2 On the **General** page, select **Direct (PARDISO)** from the **Linear system solver** list.

3 Click **OK**.

4 Click the **Solver Manager** button on the Main toolbar.

5 On the **Solve For** page, select **Incompressible Navier-Stokes (mmglf)**.

6 On the **Initial Value** page, click the **Initial value expression** option button in the **Initial value** area.

7 Click **OK**.

8 Click the **Solve** button on the Main toolbar.
You have now computed the velocity field and can use that solution to make a parametric analysis for the mass transport problem with varying diffusivity.

1. Click the **Solver Manager** button on the Main toolbar.
2. On the **Solve For** page, select **Convection and Diffusion (chcd)**.
3. Click the **Initial Value** tab, then click the **Current solution** option button in the **Initial value** area.
4. Click **OK**.
5. Click the **Solver Parameters** button on the Main toolbar.
6. From the **Solver** list, select **Parametric**.
7. In the **Parameter name** edit field, type **D**.
8. In the **Parameter values** edit field, type **1e-10 5e-11 1e-11**.
9. Click **OK**.
10. Click the **Solve** button on the Main toolbar.

**POSTPROCESSING AND VISUALIZATION**

To generate Figure 4-44 follow these steps:

1. From the **Postprocessing** menu, open the **Plot Parameters** dialog box.
2. On the **General** page, select the **Slice** and **Arrow** check boxes in the **Plot type** area.
3. Clear the **Element refinement Auto** check box and type **5** in the associated edit field.
4. Click the **Slice** tab.
5. In the **Predefined quantities** list, select **Incompressible Navier-Stokes (mmglf)>>Velocity field**.
6. From the **Unit** list, select **mm/s**.
7. In the **Slice positioning** area, set **x levels** to **5**, **y levels** to **2**, and **z levels** to **1**.
8. Click the **Arrow** tab.
9. On the **Subdomain Data** page, verify that **Velocity field** is selected in the **Predefined quantities** list.
10. In the **Arrow positioning** area, set the numbers of **x points**, **y points**, and **z points** to **14**, **21**, and **3**, respectively.
11. In the **Arrow parameters** area, click the **Color** button. Select the black swatch from the palette in the **Arrow Color** dialog box, then click **OK**.
12. Select **3D arrow** from the **Arrow type** list.
13. Click **Apply** to generate the plot.
To generate Figure 4-45, continue with the following steps:

1. Clear the Arrow plot check box, then click the Slice tab.
2. From the Predefined quantities list, select Convection and Diffusion (chdd)>Concentration, c.
3. On the General page, select 1e-10 from the Parameter value list. Click OK.

Generate Figure 4-52 the same way as Figure 4-45, except use the parameter value 1e-11.

**Physics Settings—Study 2**

1. From the Multiphysics menu, select Incompressible Navier-Stokes (mnglf).
2. From the Physics menu, select Subdomain Settings.
3. Change the viscosity expression to $\eta*(1+\alpha*c^2)$. Click OK.

**Computing the Solution—Study 2**

When the viscosity is concentration dependent you must solve all equations simultaneously.

1. Click the Solver Manager button on the Main toolbar.
2. On the Solve For page, select Geoml (3D) from the Solve for variables list. Click OK.
3. Click the Solver Parameters button on the Main toolbar.
4. From the Solver list, select Stationary. Click OK.
5. Click the Solve button on the Main toolbar.

**Postprocessing and Visualization—Study 2**

Finally, generate Figure 4-53 and Figure 4-54 with the following steps:

1. Click the Plot Parameters button on the Main toolbar.
2. On the General page, select the Arrow check box in the Plot type area.
3. Click the Slice tab.
4. In the Predefined quantities list, select Incompressible Navier-Stokes (mnglf)>Velocity field.
5. In the Unit list, select mm/s, then click Apply to generate Figure 4-53.
6. In the Predefined quantities list, select Convection and Diffusion (chdd)>Concentration, c.
7. On the General page, clear the Arrow check box in the Plot type area.
Click **OK** to close the dialog box and generate Figure 4-54.
Inkjet Nozzle

Introduction

Inkjet printers are attractive tools for printing text and images because they combine low cost and high resolution with acceptable speed. The working principle behind inkjet technology is to eject small droplets of liquid from a nozzle onto a sheet of paper. Important properties of a printer are its speed and the resolution of the final images. Designers can vary several parameters to modify a printer’s performance. For instance, they can vary the inkjet geometry and the type of ink to create droplets of different sizes. The size and speed of the ejected droplets are also strongly dependent on the speed at which ink is injected into the nozzle. Simulations can be useful to improve the understanding of the fluid flow and to predict the optimal design of an inkjet for a specific application.

Although initially invented to produce images on paper, the inkjet technique has since been adopted for other application areas. Instruments for the precise deposition of microdroplets often employ inkjets. These instruments are used within the life sciences for diagnosis, analysis, and drug discovery. Inkjets have also been used as 3D printers to synthesize tissue from cells and to manufacture microelectronics. For all of these applications it is important to be able to accurately control the inkjet’s performance.

This example demonstrates how to model the fluid flow within an inkjet using two application modes available in the MEMS module. For the two-phase flow, you can use either the Two-Phase Flow, Laminar, Level Set or the Two-Phase Flow, Laminar, Phase Field application mode. The Level Set application mode uses a reinitialized level set method to represent a discrete fluid interface between the air and ink. The Phase Field application mode, on the other hand, uses a Cahn-Hilliard equation, including a chemical potential, to represent a diffuse interface separating the two phases. Both application modes use the Navier-Stokes equations to describe the momentum transport, including surface tension, and conservation of mass.

Model Definition

Figure 4-55 shows the geometry of the inkjet studied in this example. Because of its symmetry you can use an axisymmetric 2D model. Initially, the space between the inlet and the nozzle is filled with ink. Additional ink is injected through the inlet during a
period of 10 µs, and it consequently forces ink to flow out of the nozzle. When the injection stops, a droplet of ink snaps off and continues to travel until it hits the target.

Figure 4-55: Geometry of the inkjet.

**REPRESENTATION AND CONVECTION OF THE FLUID INTERFACE**

**Level Set Method**
The Level Set application mode uses a reinitialized, conservative level set method to describe and convect the interface. The 0.5 contour of the level set function \( \phi \) defines the interface, where \( \phi = 0 \) in air and \( \phi = 1 \) in ink. In a transition layer close to the interface, \( \phi \) goes smoothly from 0 to 1. The interface moves with the fluid velocity, \( \mathbf{u} \), at the interface. The following equation describes the convection of the reinitialized level set function:

\[
\frac{\partial \phi}{\partial t} + \nabla \cdot (\phi \mathbf{u}) + \gamma \left[ \nabla \cdot \left( \phi (1-\phi) \frac{\nabla \phi}{|\nabla \phi|} \right) - \varepsilon \nabla \cdot \nabla \phi \right] = 0 \quad (4-22)
\]

The thickness of the transition layer is proportional to \( \varepsilon \). For this model you can use \( \varepsilon = \frac{h_c}{2} \), where \( h_c \) is the typical mesh size in the region passed by the droplet.

The parameter \( \gamma \) determines the amount of reinitialization. A suitable value for \( \gamma \) is the maximum magnitude occurring in the velocity field.

The application mode uses the level set function to smooth the density and viscosity jump across the interface by letting

\[
\rho = \rho_{\text{air}} + (\rho_{\text{ink}} - \rho_{\text{air}}) \phi
\]

\[
\mu = \mu_{\text{air}} + (\mu_{\text{ink}} - \mu_{\text{air}}) \phi
\]
**Phase Field Method**

In the Phase Field application mode the interface dynamics of the two phase flow is governed by a Cahn-Hilliard equation, which tracks a diffuse interface separating the phases. Over the interface, the dimensionless phase field variable $\phi$ goes from $-1$ to $1$. In the application mode a volume fraction is therefore defined as

$$V_f = \frac{1 + \phi}{2}$$

The density ($\text{kg/m}^3$) and the viscosity ($\text{Pa} \cdot \text{s}$) of the mixture vary smoothly over the interface according to

$$\rho = \rho_{\text{air}} + (\rho_{\text{ink}} - \rho_{\text{air}})V_f$$
$$\eta = \eta_{\text{air}} + (\eta_{\text{ink}} - \eta_{\text{air}})V_f$$

When solved in COMSOL Multiphysics, the application mode breaks the Cahn-Hilliard equation up into two equations:

$$\frac{\partial \phi}{\partial t} + \mathbf{u} \cdot \nabla \phi = \nabla \cdot \left( \frac{\gamma \lambda}{\varepsilon^2} \nabla \psi \right)$$

$$\psi = -\nabla \cdot \mathbf{e}^2 \nabla \phi + (\phi^2 - 1)\phi$$

where $\mathbf{u}$ is the fluid velocity ($\text{m/s}$), $\gamma$ is the mobility ($\text{m}^3 \cdot \text{s/kg}$), $\lambda$ is the mixing energy density ($\text{N}$) and $\varepsilon$ ($\text{m}$) is the interface thickness parameter. The mixing energy density and the interface thickness are related to the surface tension coefficient through Equation 4-25 (Ref. 3):

$$\sigma = \frac{2\sqrt{2} \lambda \varepsilon}{3\varepsilon}$$

The mobility parameter $\gamma$ determines the time scale of the Cahn-Hilliard diffusion and must be chosen judiciously. It must be large enough to retain a constant interfacial thickness but small enough so that the convective terms are not overly damped. The default value, $\gamma = \varepsilon^2$, is usually a good initial guess.

**Transport of Mass and Momentum**

In both the Two-Phase Flow, Laminar, Level Set and the Two-Phase Flow, Laminar, Phase Field mode, the incompressible Navier-Stokes equations, including surface tension, describe the transport of mass and momentum. Both ink and air can be
considered incompressible as long as the fluid velocity is small compared to the speed of sound. The Navier-Stokes equations are

\[ \rho \left( \frac{\partial \mathbf{u}}{\partial t} + \mathbf{u} \cdot \nabla \mathbf{u} \right) - \nabla \cdot (\mu (\nabla \mathbf{u} + \nabla \mathbf{u}^T)) + \nabla p = \mathbf{F}_{\text{st}} \]  

(4-26)

\[ (\nabla \cdot \mathbf{u}) = 0 \]  

(4-27)

Here, \( \rho \) denotes density (kg/m\(^3\)), \( \mu \) equals the dynamic viscosity (N·s/m\(^2\)), \( \mathbf{u} \) represents the velocity (m/s), \( p \) denotes pressure (Pa), and \( \mathbf{F}_{\text{st}} \) is the surface tension force.

In the Level Set application mode the surface tension force is computed as

\[ \mathbf{F}_{\text{st}} = \nabla \cdot \mathbf{T} \]  

(4-28)

\[ \mathbf{T} = \sigma (\mathbf{I} - (\mathbf{n} \mathbf{n}^T)) \delta \]  

(4-29)

where \( \mathbf{I} \) is the identity matrix, \( \mathbf{n} \) is the interface normal, \( \sigma \) is the surface tension coefficient (N/m), and \( \delta \) equals a Dirac delta function that is nonzero only at the fluid interface. The normal to the interface is

\[ \mathbf{n} = \frac{\nabla \phi}{|\nabla \phi|} \]

while the delta function is approximated by

\[ \delta = 6|\phi (1 - \phi)||\nabla \phi| \]

In the Phase Field application mode, the diffuse interface representation makes it possible to compute the surface tension by

\[ \mathbf{F}_{\text{st}} = G \nabla \phi \]  

(4-30)

where \( \phi \) is the phase field parameter, and \( G \) is the chemical potential (J/m\(^3\))

\[ G = \lambda \left[ -\nabla^2 \phi + \frac{\phi (\phi^2 - 1)}{\varepsilon^2} \right] = \frac{\lambda}{\varepsilon^2} \psi \]  

(4-31)

As seen above, the phase field surface tension is computed as a distributed force over the interface using only \( \psi \) and the gradient of the phase field variable. This computation avoids using the surface normal and the surface curvature, which are troublesome to represent numerically.
The following table gives the physical parameters of ink and air used in the model:

<table>
<thead>
<tr>
<th>MEDIUM</th>
<th>DENSITY</th>
<th>DYNAMIC VISCOSITY</th>
<th>SURFACE TENSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>ink</td>
<td>$10^3$ kg/m$^3$</td>
<td>0.01 Ns/m$^2$</td>
<td>0.07 N/m</td>
</tr>
<tr>
<td>air</td>
<td>1.225 kg/m$^3$</td>
<td>1.789·$10^{-5}$ Ns/m$^2$</td>
<td></td>
</tr>
</tbody>
</table>

**INITIAL CONDITIONS**

Figure 4-56 shows the initial distribution ($t = 0$) of ink and air. The velocity is initially 0.

![Figure 4-56: Initial distribution of ink. Black corresponds to ink and white corresponds to air.](image)

**BOUNDARY CONDITIONS**

*Inlet*

The inlet velocity in the $z$ direction increases from 0 to the parabolic profile

$$v(r) = 4.5 \left( \frac{r + 1 \cdot 10^{-4}}{2 \cdot 10^{-4}} \right) \left( 1 - \frac{r + 1 \cdot 10^{-4}}{2 \cdot 10^{-4}} \right)$$
during the first 2 µs. The velocity is then \( v(r) \) for 10 µs and finally decreases to 0 for another 2 µs. You can obtain this effect by using the built-in smooth Heaviside step function \( H(t - \delta_1, \delta_2) \), which is 0 for \( t > \delta_1 - \delta_2 \), increases from 0 to 1 as \( t \) goes from \( \delta_1 - \delta_2 \) to \( \delta_1 + \delta_2 \), and it is 1 for \( t > \delta_1 + \delta_2 \) as shown in Figure 4-57.

![Figure 4-57: Smooth step function](image)

The time-dependent velocity profile in the \( z \) direction can then be defined as

\[
v(r, t) = (H(t - 1 \cdot 10^{-6}, 1 \cdot 10^{-6}) - H(t - 13 \cdot 10^{-6}, 1 \cdot 10^{-6})) \cdot v(r)
\]

where \( t \) is given in seconds.

In the Level Set application mode, use \( \phi = 1 \) as the inlet boundary condition. In the Phase Field application mode use \( V_f = 0 \).

**Outlet**

Set a constant pressure at the outlet. The value of the pressure given here is not important because the velocity depends only on the pressure gradient. You thus obtain the same velocity field regardless of whether the pressure is set to 1 atm or to 0.

**Walls**

On all other boundaries except the target, set No-slip conditions. Use a Wetted wall condition on the target, and a contact angle between the fluid and the wall of \( \pi/2 \).

Note that the in the Level Set application mode the interface cannot move along a no-slip boundary. In this application mode the Wetted wall boundary allows for a small amount of slip according to

\[
u = -\lambda \frac{\partial u}{\partial z}
\]
where $\lambda$ is the slip length, which in this example is set to $1 \cdot 10^{-5}$ m.

**Results and Discussion**

Figure 4-58 and Figure 4-59 show the ink surface and the velocity field at different times. The droplet motion is qualitatively similar comparing the results from the Level Set and the Phase Field model. In the Phase Field model, however, the separating interface is more diffuse, especially at the end of the domain, and as a result the droplet velocity decreases and the droplet hits the target somewhat later. In the Level Set model, small droplets are also shed behind the large one.
Figure 4.58: Position of air/ink interface and velocity field at various times. Results from the Level Set model (left) and Phase Field model (right).
Figure 4-59: Position of air/ink interface and velocity field at various times. Results from the Level Set model (left) and Phase Field model (right).
Figure 4-60 illustrates the mass of ink that is further than $0.7 \cdot 10^{-3}$ m from the inlet. Both figures show that the mass of the ejected droplet is approximately $2.0 \cdot 10^{-10}$ kg.

This example studies only one inkjet model, but it is easy to modify the model in several ways. You can, for example, change properties such as the geometry or the inlet velocity and study the influence on the size and the speed of the ejected droplets. You can also investigate how the inkjet would perform if the ink were replaced by a different fluid. It is also easy to add forces such as gravitation to the model.

**Modeling in COMSOL Multiphysics**

You can readily set up the model using the Two-Phase Flow, Laminar, Level Set or the Two-Phase Flow, Laminar, Phase Field application mode. The application modes set up the equations automatically, and you need only specify physical parameters of the fluids and the initial and boundary conditions.

Use a structured mesh and refine it in the regions where the fluid interface passes.

The simulation procedure, both when using the Level Set and the Phase Field application mode, involves two consecutive computations. First you calculate a smooth initial condition for the level set variable (or the phase field variable). Then you store the solution, switch the analysis type to a transient analysis, and start the time-dependent simulation of the fluid motion.

To calculate the droplet’s mass, use an integration coupling variable. To visualize the droplet in 3D, revolve the 2D axisymmetric solution to a 3D geometry.
References


Model Library path: MEMS Module/Microfluidics Models/inkjet_nozzle_ls

Modeling Using the Graphical User Interface—Level Set Method

**MODEL NAVIGATOR**

1. In the **Model Navigator**, go to the **Space dimension** list and select **Axial symmetry (2D)**.
2. From the list of application modes, select **MEMS Module>Microfluidics>Two-Phase Flow, Laminar, Level Set**. Click **OK**.

**GEOMETRY MODELING**

1. From the **Draw** menu, select **Specify Objects>Line**.
2. Select **Closed polyline (solid)** from the **Style** list.
3. In the r edit field, enter 0 1e-4 1e-4 2.5e-5 2.5e-5 1e-4 1e-4 2e-4 2e-4 0, and in the z edit field 0 0 2e-4 5.75e-4 6e-4 6e-4 1.5e-3 1.5e-3 1.6e-3 1.6e-3.
4. Click **OK**.
5. Click the **Zoom Extents** button on the Main toolbar.
6. Shift-click the **Rectangle/Square** button on the Draw toolbar. Type 1e-4 in the **Width** edit field, 2e-4 in the **Height** edit field, and 0 in both the r and the z edit field. Make sure **Corner** is selected in the **Base** list, then click **OK**.
Repeat the previous step three times to specify three more rectangles according to the following table:

<table>
<thead>
<tr>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>BASE</th>
<th>R</th>
<th>Z</th>
</tr>
</thead>
<tbody>
<tr>
<td>2.5e-5</td>
<td>2.5e-5</td>
<td>Corner</td>
<td>0</td>
<td>5.75e-4</td>
</tr>
<tr>
<td>2.5e-5</td>
<td>9e-4</td>
<td>Corner</td>
<td>0</td>
<td>6e-4</td>
</tr>
<tr>
<td>7.5e-5</td>
<td>1e-4</td>
<td>Corner</td>
<td>2.5e-5</td>
<td>1.5e-3</td>
</tr>
</tbody>
</table>

**OPTIONS AND SETTINGS**
1. From the **Options** menu, select **Constants**.
2. Define the following constants (the descriptions are optional):

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>rhoair</td>
<td>1.225[kg/m^3]</td>
<td>Density of air</td>
</tr>
<tr>
<td>rhoink</td>
<td>1e3[kg/m^3]</td>
<td>Density of ink</td>
</tr>
<tr>
<td>etaair</td>
<td>1.7894e-5[Pa*s]</td>
<td>Viscosity of air</td>
</tr>
<tr>
<td>etaink</td>
<td>1e-2[Pa*s]</td>
<td>Viscosity of ink</td>
</tr>
<tr>
<td>sigma</td>
<td>0.07[N/m]</td>
<td>Surface tension</td>
</tr>
<tr>
<td>lambdaslip</td>
<td>10[um]</td>
<td>Slip length</td>
</tr>
</tbody>
</table>

3. Click **OK**.
4. From the **Options** menu, select **Expressions>Scalar Expressions**.
5. Define the following expressions:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>inletr</td>
<td>4.5[m/s]<em>((r[1/m]+1e-4)/2e-4)^</em>(1-((r[1/m]+1e-4)/2e-4))</td>
<td>inlet velocity</td>
</tr>
<tr>
<td>inlett</td>
<td>flc2hs(t[1/s]-1e-6,1e-6)-flc2hs(t[1/s]-13e-6,1e-6)</td>
<td></td>
</tr>
<tr>
<td>inletvel</td>
<td>inletr*inlett</td>
<td></td>
</tr>
</tbody>
</table>

6. Click **OK**.

**PHYSICS SETTINGS**

**Subdomain Settings**
1. In the **Model Tree**, right-click **Two-Phase Flow, Laminar, Level Set (mmglf)** and select **Subdomain Settings**.
Note: There are a number of different ways to open the Subdomain Settings and the Boundary Settings dialog boxes. This description assumes that you have the Model Tree visible in Overview mode. To open the Model Tree, click the Model Tree button on the Main toolbar, then click the Overview button on the toolbar at the top of the Model Tree.

2 Select Subdomain 1 and press Ctrl+A to select all the subdomains. Enter physical parameters according to the following table.

<table>
<thead>
<tr>
<th>QUANTITY</th>
<th>VALUE/EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \rho_1 )</td>
<td>rhoair</td>
<td>Density, fluid 1</td>
</tr>
<tr>
<td>( \eta_1 )</td>
<td>etaair</td>
<td>Dynamic viscosity, fluid 1</td>
</tr>
<tr>
<td>( \rho_2 )</td>
<td>rhoink</td>
<td>Density, fluid 2</td>
</tr>
<tr>
<td>( \eta_2 )</td>
<td>etaink</td>
<td>Dynamic viscosity, fluid 2</td>
</tr>
</tbody>
</table>

3 On the Sources/Sinks page, type \( \sigma \) in the Surface tension coefficient edit field.

4 Click the Artificial diffusion button to open the corresponding window.

5 On the Navier-Stokes Equations tab select the Streamline diffusion check box, select Anisotropic diffusion from the corresponding list, and click OK.

6 Click the Level Set tab and type 10 in the \( \gamma \) edit field and \( 2.5e-6 \) in the \( \varepsilon \) field.

7 Click the Init tab. Select Subdomains 1, 2, and 3 and click the Fluid 2 button. These subdomains are initially filled with ink.

8 Click OK.

Boundary Conditions

1 In the Model Tree right-click Two-Phase Flow, Laminar, Level Set (mmglf) and select Boundary Settings. Set boundary conditions according to the following table.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 1, 3, 5, 7, 9</th>
<th>BOUNDARY 2</th>
<th>BOUNDARY 24</th>
<th>BOUNDARIES 11, 18, 23</th>
<th>BOUNDARIES 12, 13, 19, 20, 22</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary type</td>
<td>Symmetry boundary</td>
<td>Inlet</td>
<td>Outlet</td>
<td>Wall</td>
<td>Wall</td>
</tr>
<tr>
<td>Boundary condition</td>
<td>Axial symmetry</td>
<td>Velocity</td>
<td>Pressure, no viscous stress</td>
<td>Wetted wall</td>
<td>No slip</td>
</tr>
<tr>
<td>( U_0 )</td>
<td>inletvel</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
2 Select Boundary 8, then select the Interior boundaries check box. From the Boundary condition list, select Initial fluid interface.

3 Click OK.

**Mesh Generation**

1 From the Mesh menu, select Mapped Mesh Parameters.

2 Click the Boundary tab.

3 Select Boundaries 1, 2, 3, 5, 7, 9, 15, and 22, then select the Constrained edge element distribution check box. Next select each boundary separately and specify the Number of edge elements according to this table:

<table>
<thead>
<tr>
<th>Boundary</th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>5</th>
<th>7</th>
<th>9</th>
<th>15</th>
<th>22</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of edge elements</td>
<td>10</td>
<td>10</td>
<td>8</td>
<td>10</td>
<td>180</td>
<td>20</td>
<td>20</td>
<td>10</td>
</tr>
</tbody>
</table>

4 Click Remesh, then click OK.

**Computing the Solution**

First, use transient initialization in order to obtain a consistent and smoothly varying $\phi$ over the separating interface.

1 Click the Solver Parameters button on the Main toolbar.

2 On the General page, type $0 \cdot 2e-6$ in the Times edit field.

3 Click OK.

4 Click the Solve button on the Main toolbar.

Use the obtained solution as an initial condition to the simulation of the droplet motion:

1 Click the Solver Manager button on the Main toolbar.

2 On the Initial Value page, click the Store Solution button. Select the time $2e-6$, then click OK.

3 In the Initial value area, select Stored solution.
4 From the Solution at time list, select 2e-6. Click OK.
5 Click the Solver Parameters button on the Main toolbar.
6 On the General page, type 0:1e-5:2e-4 in the Times edit field. Click OK.
7 From the Physics menu, select Properties. Change the Analysis type to Transient, then click OK.
8 Click the Solve button on the Main toolbar.

POSTPROCESSING AND VISUALIZATION
To visualize the solution in 3D, perform these steps:
1 From the Draw menu, select Revolve.
2 In the Objects to revolve list, select all the elements (select any object and then press Ctrl+A). Click OK.
3 In the Model Tree, click Geom1 to return to the 2D model.
4 Select Options>Extrusion Coupling Variables>Subdomain Variables.
5 Select any subdomain, then press Ctrl+A to select all the subdomains.
6 In the Name edit field, type ph13d, and in the Expression edit field type phi.
7 Click the General transformation option button.
8 Type vel13d in the Name edit field on the second row and sqrt(u^2+v^2) in the corresponding Expression edit field.
9 Select General transformation for this variable as well.
10 Click the Destination tab. In the Geometry list, select Geom2. In the Level list, select Subdomain.
11 Select any subdomain then press Ctrl+A to select all the subdomains.
12 Select the Use selected subdomains as destination check box.
13 In the x edit field, type sqrt(x^2+z^2).
14 From the Variable list, select phi3d.
15 Select the Use selected subdomains as destination check box and type sqrt(x^2+z^2) in the x edit field. Click OK.
16 From the Solve menu, select Update Model.
17 Click the Plot Parameters button on the Main toolbar.
18 On the General page, clear the Geometry edges check box and select the Isosurface check box.
Clear the Auto check box for Element refinement, then type 4 in the associated edit field.

Click the Slice tab. In the Expression edit field, type vel3d; in the x levels edit field, type 0; and in the z levels edit field, type 1.

Click the Isosurface tab. In the Expression edit field, type phi3d. Select Vector with isolevels, then type 0.5 in the corresponding edit field.

Click the Uniform color option button, then click the Color button. Choose a gray color to plot the ink/air interface. Click OK.

Click the General tab. In the Solution at time list, select 0. Click OK to plot the initial position of the interface.

Click the Scene Light button on the Camera toolbar.

To plot the solution at other times, click the Plot Parameters button and select other values from the Solution at time list. Click Apply to plot the solution at the corresponding time.

Click OK.

Go through the following steps to calculate the mass of the ejected droplet:

1. Click the Geom1 tab.
2. Choose Options>Integration Coupling Variables>Subdomain Variables.
3. Select one of the subdomains, then press Ctrl+A to select them all.
4. In the first Name edit field, type mass_droplet. In the corresponding Expression field, type rhoink*phi*(z>7e-4)*2*pi*r. Click OK.
5. From the Solve menu, select Update Model.
6. From the Postprocessing menu, select Global Variables Plot.
7. In the Expression edit field, type mass_droplet, then click the Add Entered Expression button (the one marked >).
8. Click OK to generate the plot.

Model Library path: MEMS_Module/Microfluidics_Models/inkjet_nozzle_pf
Modeling Using the Graphical User Interface—Phase Field Method

MODEL NAVIGATOR
1. In the Model Navigator, go to the Space dimension list and select Axial symmetry (2D).
2. From the list of application modes, select MEMS Module>Microfluidics>Two-Phase Flow, Laminar, Phase Field. Click OK.

GEOMETRY MODELING
1. From the Draw menu, select Specify Objects>Line.
2. Select Closed polyline (solid) from the Style list.
3. In the r edit field, enter 0 1e-4 1e-4 2.5e-5 2.5e-5 1e-4 1e-4 2e-4 2e-4 0, and in the z edit field 0 0 2e-4 5.75e-4 5.75e-4 6e-4 6e-4 1.5e-3 1.5e-3 1.6e-3 1.6e-3.
4. Click OK.
5. Click the Zoom Extents button on the Main toolbar.
6. Shift-click the Rectangle/Square button on the Draw toolbar. Type 1e-4 in the Width edit field, 2e-4 in the Height edit field, and 0 in both the r and the z edit field. Make sure Corner is selected in the Base list, then click OK.
7. Repeat the previous step three times to specify three more rectangles according to the following table:

<table>
<thead>
<tr>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>BASE</th>
<th>R</th>
<th>Z</th>
</tr>
</thead>
<tbody>
<tr>
<td>2.5e-5</td>
<td>2.5e-5</td>
<td>Corner</td>
<td>0</td>
<td>5.75e-4</td>
</tr>
<tr>
<td>2.5e-5</td>
<td>9e-4</td>
<td>Corner</td>
<td>0</td>
<td>6e-4</td>
</tr>
<tr>
<td>7.5e-5</td>
<td>1e-4</td>
<td>Corner</td>
<td>2.5e-5</td>
<td>1.5e-3</td>
</tr>
</tbody>
</table>

OPTIONS AND SETTINGS
1. From the Options menu, select Constants.
2. Define the following constants (the descriptions are optional):

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>rhoair</td>
<td>1.225[kg/m^3]</td>
<td>Density of air</td>
</tr>
<tr>
<td>rhoink</td>
<td>1e3[kg/m^3]</td>
<td>Density of ink</td>
</tr>
<tr>
<td>etair</td>
<td>1.7894e-5[Pa*s]</td>
<td>Viscosity of air</td>
</tr>
<tr>
<td>etaink</td>
<td>1e-2[Pa*s]</td>
<td>Viscosity of ink</td>
</tr>
<tr>
<td>sigma</td>
<td>0.07[N/m]</td>
<td>Surface tension</td>
</tr>
</tbody>
</table>
3 Click **OK**.

4 From the **Options** menu, select **Expressions>Scalar Expressions**.

5 Define the following expressions:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>inletr</td>
<td>[4.5\text{m/s} \times ((r[1/m]+1\times10^{-4})/2\times10^{-4}) \times (1-((r[1/m]+1\times10^{-4})/2\times10^{-4}))]</td>
<td></td>
</tr>
<tr>
<td>inlett</td>
<td>[f1c2hs(t[1/s]-1\times10^{-6},1\times10^{-6})-f1c2hs(t[1/s]-13\times10^{-6},1\times10^{-6})]</td>
<td></td>
</tr>
<tr>
<td>inletvel</td>
<td>[\text{inletr*inlett}]</td>
<td>Inlet velocity</td>
</tr>
</tbody>
</table>

6 Click **OK**.

**PHYSICS SETTINGS**

**Subdomain Settings**

1 In the **Model Tree**, right-click **Two-Phase Flow, Laminar, Phase Field (mmgfl)** and select **Subdomain Settings**.

**Note:** There are a number of different ways to open the **Subdomain Settings** and the **Boundary Settings** dialog boxes. This description assumes that you have the **Model Tree** visible in **Overview** mode. To open the **Model Tree**, click the **Model Tree** button on the Main toolbar, then click the **Overview** button on the toolbar at the top of the **Model Tree**.

2 Select Subdomain 1 and press Ctrl+A to select all the subdomains. Enter physical parameters according to the following table.

<table>
<thead>
<tr>
<th>QUANTITY</th>
<th>VALUE/EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\rho_1$</td>
<td>rhoair</td>
<td>Density, fluid 1</td>
</tr>
<tr>
<td>$\eta_1$</td>
<td>etaair</td>
<td>Dynamic viscosity, fluid 1</td>
</tr>
<tr>
<td>$\rho_2$</td>
<td>rhoink</td>
<td>Density, fluid 2</td>
</tr>
<tr>
<td>$\eta_2$</td>
<td>etaink</td>
<td>Dynamic viscosity, fluid 2</td>
</tr>
</tbody>
</table>

3 On the **Sources/Sinks** tab, type sigma in the **Surface tension coefficient** edit field.

4 Click the **Artificial diffusion** button to open the corresponding window.

5 Select the **Streamline diffusion** check box, in the corresponding list select **Anisotropic diffusion**, and click **OK**.
6 On the Phase Field tab, set the Mobility tuning parameter to 1 and the Parameter controlling the interface thickness to $2.5 \times 10^{-6}$.

7 Click the Init tab. Select Subdomains 1, 2, and 3 and click the Fluid 2 button. These subdomains are initially filled with ink.

8 Click OK.

Boundary Conditions

1 In the Model Tree right-click Two-Phase Flow, Laminar, Phase Field (mmglf) and select Boundary Settings. Set boundary conditions according to the following table.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 1, 3, 5, 7, 9</th>
<th>BOUNDARY 24</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary type</td>
<td>Symmetry boundary</td>
<td>Inlet</td>
</tr>
<tr>
<td>Boundary condition</td>
<td>Axial symmetry</td>
<td>Velocity</td>
</tr>
</tbody>
</table>

| $U_0$ | inletvel |
| $p_0$ | 0 |
| $Vf_0$ | 1 |
| $\theta$ | $\pi/2$ |

2 Select Boundary 8, then select the Interior boundaries check box. From the Boundary condition list, select Initial fluid interface.

3 Click OK.

Mesh Generation

1 From the Mesh menu, select Mapped Mesh Parameters.

2 Click the Boundary tab.

3 Select Boundaries 1, 2, 3, 5, 7, 9, 15, and 22, then select the Constrained edge element distribution check box. Next select each boundary separately and specify the Number of edge elements according to this table:

<table>
<thead>
<tr>
<th>Boundary</th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>5</th>
<th>7</th>
<th>9</th>
<th>15</th>
<th>22</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of edge elements</td>
<td>10</td>
<td>10</td>
<td>8</td>
<td>10</td>
<td>225</td>
<td>25</td>
<td>20</td>
<td>10</td>
</tr>
</tbody>
</table>

4 Click Remesh, then click OK.
**Computing the Solution**

First, use transient initialization to obtain a consistent and smoothly varying $\phi$ over the separating interface:

1. Click the **Solver Parameters** button on the Main toolbar.
2. On the **General** page, type $0:1e-4:2e-3$ in the **Times** edit field.
3. Type $0.005$ in the **Relative tolerance** edit field and $0.0005$ in the **Absolute tolerance** field.
4. Click **OK**.
5. Click the **Solve** button on the Main toolbar.

Use the obtained solution as an initial condition to the simulation of the droplet motion:

1. Click the **Solver Manager** button on the Main toolbar.
2. On the **Initial Value** page, click the **Store Solution** button. Select the time $2e-6$, then click **OK**.
3. In the **Initial value** area, select **Stored solution**.
4. From the **Solution at time** list, select $2e-3$. Click **OK**.
5. Click the **Solver Parameters** button on the Main toolbar.
6. On the **General** page, type $0:1e-5:2e-4$ in the **Times** edit field. Click **OK**.
7. From the **Physics** menu, select **Properties**. Change the **Analysis type** to **Transient**, then click **OK**.
8. Click the **Solve** button on the Main toolbar.

**Postprocessing and Visualization**

To visualize the solution in 3D, perform these steps:

1. From the **Draw** menu, select **Revolve**.
2. In the **Objects to revolve** list, select all the elements (select any object and then press Ctrl+A). Click **OK**.
3. In the **Model Tree**, click **Geom1** to return to the 2D model.
4. Select **Options>Extrusion Coupling Variables>Subdomain Variables**.
5. Select any subdomain and then press Ctrl+A to select all the subdomains.
6. In the **Name** edit field, type $Vf2_3d$, and in the **Expression** edit field type $Vf2_mmg1f$.
7. Click the **General transformation** option button.
1. Type vel_3d in the Name edit field on the second row and sqrt(u^2+v^2) in the corresponding Expression edit field.

2. Select General transformation for this variable as well.

3. Click the Destination tab. In the Geometry list, select Geom2. In the Level list, select Subdomain.

4. Select any subdomain then press Ctrl+A to select all the subdomains.

5. Select the Use selected subdomains as destination check box.

6. In the x edit field, type sqrt(x^2+z^2).

7. From the Variable list, select vel_3d.

8. Select the Use selected subdomains as destination check box and type sqrt(x^2+z^2) in the x edit field. Click OK.

9. From the Solve menu, select Update Model.

10. Click the Plot Parameters button on the Main toolbar.

11. On the General page, clear the Geometry edges check box and select the Isosurface check box.

12. Clear the Auto check box for Element refinement, then type 4 in the associated edit field.

13. Click the Slice tab. In the Expression edit field, type vel_3d; in the x levels edit field, type 0; and in the z levels edit field, type 1.

14. Click the Isosurface tab. In the Expression edit field, type Vf2_3d. Select Vector with isolevels, then type 0.5 in the corresponding edit field.

15. Click the Uniform color option button, then click the Color button. Choose a gray color to plot the ink/air interface. Click OK.

16. Click the General tab. In the Solution at time list, select 0. Click OK to plot the initial position of the interface.

17. Click the Scene Light button on the Camera toolbar.

18. To plot the solution at other times, click the Plot Parameters button and select other values from the Solution at time list. Click Apply to plot the solution at the corresponding time.

19. Click OK.

20. Go through the following steps to calculate the mass of the ejected droplet:

   1. Click the Geom1 tab.

   2. Choose Options>Integration Coupling Variables>Subdomain Variables.
3 Select one of the subdomains, then press Ctrl+A to select them all.

4 In the first Name edit field, type mass_droplet. In the corresponding Expression field, type \( \text{rho}_{\text{ink}} \cdot V_f \cdot (z > 7 \cdot 10^{-4}) \cdot 2 \cdot \pi \cdot r \). Click OK.

5 From the Solve menu, select Update Model.

6 From the Postprocessing menu, select Global Variables Plot.

7 In the Expression edit field, type mass_droplet, then click the Add Entered Expression button (the one marked >).

8 Click OK to generate the plot.
Filling of a Capillary Channel

Introduction

Surface tension and wall adhesive forces are often used to transport fluid through microchannels in MEMS devices or to measure the transport and position of small amounts of fluid using micropipettes. Multiphase flow through a porous medium and droplets on solid walls are other examples where wall adhesion and surface tension strongly influence the dynamics of the flow.

This example studies a narrow vertical cylinder placed on top of a reservoir filled with water. Because of wall adhesion and surface tension at the air/water interface, water rises through the channel. The model calculates the velocity field, the pressure field, and the shape and position of the water surface.

This example demonstrates how to model the filling of a capillary channel using two application modes available in the MEMS Module. You can use either the Two-Phase Flow, Laminar, Level Set or the Two-Phase Flow, Laminar, Phase Field application mode. The Level Set application mode uses a reinitialized level set method to represent a discrete fluid interface between the air and ink. The Phase Field application mode, on the other hand, uses a Cahn-Hilliard equation, including a chemical potential to represent a diffuse interface separating the two phases. Both application mode uses the Navier-Stokes equations to describe the momentum transport, including surface tension, and conservation of mass.

Model Definition

The model consists of a capillary channel of radius 0.15 mm attached to a water reservoir. Water can flow freely into the reservoir. Because both the channel and the reservoir are cylindrical, you can use the axisymmetric geometry illustrated in Figure 4-61. Initially, the thin cylinder is filled with air. Wall adhesion causes water to creep up along the cylinder boundaries. The deformation of the water surface induces surface tension at the air/water interface, which in turn creates a pressure jump across the interface. The pressure variations cause water and air to move upward. The fluids continue to rise until the capillary forces are balanced by the gravity force building up as the water rises in the channel. In the present example, the capillary forces dominate over gravity throughout the simulation. Consequently, the interface moves upwards during the entire simulation.
Figure 4-61: Axisymmetric geometry description.

**REPRESENTATION AND CONVECTION OF THE FLUID INTERFACE**

*Level Set Method*

The Two-Phase Flow, Laminar, Level Set application mode automatically sets up the equations for the convection of the interface. The application mode represents the interface as the 0.5 contour of the level set function $\phi$. In air $\phi = 0$ and in water $\phi = 1$. The level set function can thus be thought of as the volume fraction of water. The transport of the fluid interface separating the two phases is given by

$$\frac{\partial \phi}{\partial t} + \mathbf{u} \cdot \nabla \phi = \gamma \nabla \cdot \left( \frac{\varepsilon}{\nabla \phi} \nabla \phi - \phi (1 - \phi) \frac{\nabla \phi}{|\nabla \phi|} \right)$$

The $\varepsilon$ parameter determines the thickness of the interface. When stabilization is used for the level set equation, you can typically use an interface thickness of $\varepsilon = h_c/2$, where $h_c$ is the characteristic mesh size in the region passed by the interface. The $\gamma$ parameter determines the amount of reinitialization. A suitable value for $\gamma$ is the maximum velocity magnitude occurring in the model. The application mode uses the level set function $\phi$ to smooth the density and viscosity jump across the interface by letting
The delta function is approximated by
\[ \delta = 6\phi(1 - \phi)||\nabla\phi|| \]
and the interface normal is calculated from
\[ \mathbf{n} = \frac{\nabla\phi}{||\nabla\phi||} \]

Phase Field Method
In the Two-Phase Flow, Laminar, Phase Field application mode the two-phase flow dynamics is governed by a Cahn-Hilliard equation. The equation tracks a diffuse interface separating the immiscible phases. The diffuse interface is defined as the region where the dimensionless phase field variable \( \phi \) goes from \(-1\) to \(1\). When solved in COMSOL Multiphysics, the application mode breaks the Cahn-Hilliard equation up into two equations
\[
\frac{\partial \phi}{\partial t} + \mathbf{u} \cdot \nabla \phi = \nabla \cdot \left( \frac{\gamma \lambda}{\varepsilon^2} \nabla \psi \right) \quad (4-32)
\]
\[
\psi = -\nabla \cdot \varepsilon^2 \nabla \phi + (\phi^2 - 1)\phi \quad (4-33)
\]
where \( \mathbf{u} \) is the fluid velocity (m/s), \( \gamma \) is the mobility (m\(^3\)/s/kg), \( \lambda \) is the mixing energy density (N) and \( \varepsilon \) (m) is the interface thickness parameter. The \( \psi \) variable is referred to as the phase field help variable. The following equation relates the mixing energy density and the interface thickness to the surface tension coefficient:
\[
\sigma = \frac{2\sqrt{2\lambda}}{3\varepsilon} \quad (4-34)
\]
You can typically set the interface thickness parameter to \( \varepsilon = \frac{h_c}{2} \), where \( h_c \) is the characteristic mesh size in the region passed by the interface. The mobility parameter \( \gamma \) determines the time scale of the Cahn-Hilliard diffusion and must be chosen judiciously. It must be large enough to retain a constant interfacial thickness but small enough so that the convective terms are not overly damped. The default value, \( \gamma = \varepsilon^2 \), is usually a good initial guess. This model uses a higher mobility to obtain the correct pressure variation over the interface.

In the Phase Field application mode, the volume fractions of the individual fluids are

\[
\rho = \rho_{\text{air}} + (\rho_{\text{water}} - \rho_{\text{air}})\phi
\]
\[
\mu = \mu_{\text{air}} + (\mu_{\text{water}} - \mu_{\text{air}})\phi
\]
In the present model water is defined as Fluid 1 and oil as Fluid 2. The density (kg/m$^3$) and the viscosity (Pa·s) of the mixture are defined to vary smoothly over the interface by letting

\[
\rho = \rho_w + (\rho_o - \rho_w)V_{f2} \\
\eta = \eta_w + (\eta_o - \eta_w)V_{f2}
\]

where the single phase water properties are denoted by $w$ and the oil properties by $o$.

**MASS AND MOMENTUM TRANSPORT**

The Navier-Stokes equations describe the transport of mass and momentum for fluids of constant density. In order to account for capillary effects, it is crucial to include surface tension in the model. The Navier-Stokes equations are then

\[
\rho \frac{\partial \mathbf{u}}{\partial t} + \rho (\mathbf{u} \cdot \nabla) \mathbf{u} = \nabla \cdot \left[ -\rho \mathbf{I} + \eta (\nabla \mathbf{u} + (\nabla \mathbf{u})^T) \right] + \mathbf{F}_{st} + \rho \mathbf{g}
\]

\[
\nabla \cdot \mathbf{u} = 0
\]

Here, $\rho$ denotes the density (kg/m$^3$), $\eta$ equals the dynamic viscosity (Ns/m$^2$), $\mathbf{u}$ represents the velocity (m/s), $p$ denotes the pressure (Pa), and $\mathbf{g}$ is the gravity vector (m/s$^2$). $\mathbf{F}_{st}$ is the surface tension force acting at the air/water interface.

**Surface Tension**

In the Level Set application mode the surface tension force is computed as

\[
\mathbf{F}_{st} = \nabla \cdot \mathbf{T}
\]

\[
\mathbf{T} = \sigma (\mathbf{I} - (\mathbf{n} \mathbf{n}^T))\delta
\]

Here, $\mathbf{I}$ is the identity matrix, $\mathbf{n}$ is the interface normal, $\sigma$ equals the surface tension coefficient (N/m), and $\delta$ equals a Dirac delta function that is nonzero only at the fluid interface. When you use the finite element method to solve the Navier-Stokes equations, you multiply the equations by test functions and then integrate over the computational domain. If you use integration by parts, you can move derivatives of $\mathbf{T}$ to the test functions. This is used in the Level Set and Laminar Flow application mode and results in an integral over the computational domain plus a boundary integral of the form
where $\theta$ is the contact angle (see Figure 4-62). If you apply a no-slip boundary condition, the boundary term vanishes because $\text{test}(u) = 0$ on that boundary, and you cannot specify the contact angle. Instead, the interface remains fixed on the wall.

However, if you allow a small amount of slip, it is possible to specify the contact angle. The Wetted wall boundary condition adds the term given by Equation 4-35 and consequently makes it possible to set the contact angle.

In the Phase Field application mode, the diffuse interface representation makes it possible to compute the surface tension by

$$\mathbf{F}_{st} = G\nabla \phi$$

(4-36)

where $\phi$ is the phase field parameter, and $G$ is the chemical potential $(J/m^3)$

$$G = \frac{\lambda}{\varepsilon^2} \left[ -\nabla^2 \phi + \frac{\phi(\phi^2 - 1)}{\varepsilon^2} \right] = \frac{\lambda}{\varepsilon^2} \psi$$

(4-37)

As seen above, the phase field surface tension is computed as a distributed force over the interface using only $\psi$ and the gradient of the phase field variable. This computation avoids using the surface normal and the surface curvature, which are troublesome to represent numerically.

**INITIAL CONDITIONS**

Initially, the reservoir is filled with water and the capillary channel is filled with air. The initial velocity is zero.

**BOUNDARY CONDITIONS**

*Inlet*

The hydrostatic pressure, $p = \rho gz$, gives the pressure at the inflow boundary. Only water enters through the inlet, so the level set function (that is, the volume fraction of water) is 1 here.

*Outlet*

At the outlet, the pressure is equal to zero, that is, equal to the pressure at the top of the inflow boundary. Because it is an outflow boundary, you do not have to set any condition on the level set function.
Walls

The Wetted wall boundary condition is suitable for solid walls in contact with a fluid interface. It sets the velocity component normal to the wall to zero; that is,

\[ \mathbf{u} \cdot \mathbf{n}_{\text{wall}} = 0 \]

and adds a frictional boundary force

\[ F_{fr} = -\frac{\eta}{\beta} \mathbf{u} \]

Here, \( \beta \) is the slip length. The boundary condition also allows you to specify the contact angle \( \theta \), that is, the angle between the wall and the fluid interface (see Figure 4-62 according to “Mass and Momentum Transport” on page 395). In this example, the contact angle is 67.5° and the slip length equals the mesh element size, \( h \).

Results and Discussion

The initial development of the fluid interface is shown in Figure 4-63. During this stage the surface changes drastically in order for it to obtain the prescribed contact angle with the wall. When this is achieved, the surface tension imposed by the surface
curvature begins to pull water up through the vertical cylinder. Due to the instantaneous start, the surface oscillates slightly during the rise.

Figure 4-63: Snapshots of the position of the interface during the first 0.15 ms. Level Set (left) and Phase Field model results (right).

Figure 4-64 shows the interface and the velocity field at three different times following the initial stage. After about 0.6 ms the shape of the water surface remains approximately constant and forms a rising concave meniscus. Comparing the velocity
field in the Level Set and the Phase Field model, the Level Set results display a small velocity near the wall/interface contact point, something that is not present in the Phase Field results. This is due to a difference in the Wetted wall boundary condition in the application modes. The Level Set application mode requires a wall slip length for the interface to move along the wall. As shown in Figure 4-64, the imposed slip velocity at the wall is small. In the Phase Field application mode a slip length is not necessary and the fluid velocity is truly zero on the wall.

Figure 4-64: Interface and velocity field at different times. Level Set (top) and Phase Field model results (bottom).
Figure 4-65 shows surface plots of the pressure at \( t = 0.6 \) ms. At the fluid interface there is a pressure jump of roughly 300 Pa. The jump is caused by the surface tension, and forces the water and air to rise through the vertical cylinder.

Figure 4-65: Pressure at \( t = 0.6 \) ms. Level Set (left) and Phase Field models results (right).

You can easily calculate the position of the interface/wall contact point by integrating the level set function along the thin cylinder wall. Figure 4-66 shows the position of the contact point as a function of time. The slight oscillations of the water surface noted above is here seen also in the contact point plot. The contact plots from the Level Set and Phase Field model compare very well, except for two minor points. The surface oscillation is a bit more pronounced in the Level Set model, and the surface end point is somewhat higher up in this case. Both these differences are small and are most likely related to the different implementations of the Wetted wall boundary condition.

Figure 4-66: Position of the interface/wall contact point as a function of time. Level Set (left) and Phase Field model result (right). The velocity is approximately constant after \( t = 0.6 \) ms.
Finally, you can verify the obtained contact angle. It is defined by $\cos \theta = \mathbf{n}^T \mathbf{n}_{\text{wall}}$. In this case, the normal to the wall is $\mathbf{n}_{\text{wall}} = (1, 0)$. The contact angle is thus $\theta = \arccos n_r$, where $n_r$ is the radial component of the interface normal. Due to the slight oscillations of the surface, the contact angle varies during the rise. As Figure 4-67 shows, at $t = 0.6$ ms the contact angle is 66.4° in the Level Set model and 68.6° in the Phase Field model. Both results are close to the imposed contact angle of $3\pi/8 = 1.18$ rad = 67.5°. The contact angle further approaches the imposed value if the mesh is refined.

![Figure 4-67: Plot of $\arccos(n_r)$. At the wall, this gives the contact angle. In the Level Set model (left) the wall angle is 66.4° and in the Phase Field model (right) it is 68.6°.](image)

**Modeling in COMSOL Multiphysics**

The model is straightforward to set up using either the Two-Phase Flow, Laminar, Level Set or the Two-Phase Flow, Laminar, Phase Field application mode. At walls in contact with the fluid interface, the Wetted wall boundary condition is used.

The simulation procedure, both when using the Level Set and the Phase Field application mode, involves two consecutive computations. First you calculate a smooth initial condition for the level set variable (or the phase field variable). Then you store the solution, switch the analysis type to a transient analysis, and start the time-dependent simulation of the fluid motion.

**Model Library path:** MEMS_Module/Microfluidics_Models/capillary_filling_ls
Modeling Using the Graphical User Interface — Level Set Method

Model Navigator
1. In the Model Navigator, go to the Space dimension list and select Axial symmetry (2D).
2. From the list of application modes, select MEMS Module>Microfluidics>Two-Phase Flow, Laminar, Level Set.
3. In the Application mode name edit field, type twophase, then click OK.

Geometry Modeling
1. Shift-click the Rectangle/Square button on the Draw toolbar. Type 1.5e-4 in the Width edit field, 5e-4 in the Height edit field, 0 in the r edit field, and -1.5e-4 in the z edit field. Click OK. Click the Zoom Extents button on the Main toolbar.
2. Create another rectangle with these settings:

<table>
<thead>
<tr>
<th>Width</th>
<th>Height</th>
<th>Base</th>
<th>r</th>
<th>z</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.5e-4</td>
<td>5e-4</td>
<td>Corner</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>
3. Click the Zoom Extents button on the Main toolbar.

Options and Settings
1. From the Options menu, select Constants.
2. Define the following constants:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>theta</td>
<td>(3*pi/8)[rad]</td>
<td>Contact angle</td>
</tr>
<tr>
<td>p_ref</td>
<td>1e5[Pa]</td>
<td>Reference pressure</td>
</tr>
<tr>
<td>T_ref</td>
<td>293[K]</td>
<td>Temperature</td>
</tr>
<tr>
<td>g</td>
<td>9.81[m/s^2]</td>
<td>Acceleration due to gravity</td>
</tr>
</tbody>
</table>
3. Click OK.

Physics Settings

Subdomain Settings
1. In the Model Tree, right-click Two-Phase Flow, Laminar, Level Set (twophase) and select Subdomain Settings.
Note: There are a number of different ways to open the Subdomain Settings and the Boundary Settings dialog boxes. This description assumes that you have the Model Tree visible in Overview mode. To open the Model Tree click the Model Tree button on the Main toolbar, then click the Overview button on the toolbar at the top of the Model Tree.

2 Press Ctrl and select both subdomains. In the Fluid 1 area, click the Load button. Select Liquids and Gases>Gases>Air from the Materials list, then click OK.
3 Click the Load button in the Fluid 2 area. Select Liquids and Gases>Liquids>Water, liquid, then click OK.
4 For both fluids, replace $p$ and $T$ in the expressions for the Dynamic viscosity and Density by $p_{ref}$ and $T_{ref}$.
5 Click the Sources/Sinks tab.
6 In the Library coefficients area, click the Load button. Select Liquids and Gases>Liquid/Gas surface tension>Water from the Materials list and click OK.
7 Replace $T$ in the Interfacial tension expression by $T_{ref}$.
8 Type -$g$ in the Gravity, z component edit field.
9 Click the Artificial Diffusion button to open the corresponding window.
10 On the tab for the Navier-Stokes Equations, select the Streamline diffusion check box, select Anisotropic diffusion from the list, and click OK.
11 Click the Level Set tab, and set the interface thickness parameter, $\varepsilon$, to $5e-6$.
12 Click the Init tab, select Subdomain 1, and set Fluid 2 as Initial Fluid in this domain.
13 Click OK.

Boundary Conditions
1 In the Model Tree right-click Two-Phase Flow, Laminar, Level Set (twophase) and select Boundary Settings.
Assign boundary conditions for the exterior boundaries according to the following table.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 1, 3</th>
<th>BOUNDARY 8</th>
<th>BOUNDARY 5</th>
<th>BOUNDARIES 6, 7</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary type</td>
<td>Symmetry boundary</td>
<td>Inlet</td>
<td>Outlet</td>
<td>Wall</td>
</tr>
<tr>
<td>Boundary condition</td>
<td>Axial symmetry</td>
<td>Pressure, no viscous stress</td>
<td>Pressure, no viscous stress</td>
<td>Wetted wall</td>
</tr>
<tr>
<td>$p_0$</td>
<td>$\rho_{\text{twophase}} z^* g_{\text{twophase}}$</td>
<td>0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>$\phi_0$</td>
<td>1</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>$\theta$</td>
<td>$\theta$</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>$\beta$</td>
<td>$h$</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Select Boundary 4 and select the Interior boundaries check box. Select the boundary condition Initial fluid interface.

Click OK.

**Mesh Generation**

1. From the Mesh menu select Mapped Mesh Parameters.
2. Select both subdomains and select Extremely fine from the Predefined mesh sizes list.
3. Click the Boundary tab.
4. Select Boundaries 4 and 5, then select the Constrained edge element distribution check box.
5. In the Distribution area, type 3 in the Element ratio edit field and check the Reverse direction check box.
6. Click Remesh to generate the mesh, then click OK.

**Computing the Solution**

First initialize $\phi$ to obtain a smoothly varying function over the interface.

1. From the Solve menu select Solver Parameters.
2. Click the General tab and enter 10^-3 in the Times edit field.
3. Click OK.
4. Click the Solve button on the Main toolbar. This creates a good initial solution for the level set function.
Use the obtained solution as an initial condition for the simulation of the droplet motion.

1. Click the Solver Manager button on the Main toolbar.
2. Click the Store Solution button. Select the time 0.001. Click OK.
3. In the Initial value area click the Stored solution option button.
4. Select 0.001 from the Solution at time list, then click OK.
5. Click the Solver Parameters button on the Main toolbar.
6. In the Analysis types area, select Transient from the list of analysis types.
7. Click the General tab, then enter 0:0.25e-4:1e-3 in the Times edit field.
8. Click OK.
9. Click the Solve button on the Main toolbar.

**POSTPROCESSING AND VISUALIZATION**

1. Click the Plot Parameters button on the Main toolbar.
2. On the General page, clear the Surface check box and select the Contour and Arrow check boxes.
3. On the Contour page, go to the Contour levels area and click the Vector with isolevels option button. Type 0.5 in the corresponding edit field.
4. Click the Arrow tab. From the Predefined quantities list on the Subdomain Data page, select Velocity field. In the Number of points edit field for z points, type 30.
5. Click Apply.
6. On the General page, select a value from the Solution at time list and then click Apply to visualize the result at the corresponding value. Repeat to view the solution at other times.
7. Click OK.
8. To create a movie from the plots at the different times, click the Animate button on the Plot toolbar.

To create filled contour plots as in Figure 4-63, perform the following steps:

1. Click the Plot Parameters button on the Main toolbar.
2. On the General page, clear the Arrow check box in the Plot type area.
3. On the Contour page, select the Filled check box.
4. Click OK.
Next, create the pressure plot in Figure 4-65.

1. Click the Plot Parameters button on the Main toolbar.
2. On the General page, clear the Contour check box and select the Surface check box in the Plot type area. In the Solution to use area, select 6e-4 from the Solution at time list.
3. Click the Surface tab. From the Predefined quantities list on the Surface Data page, select Pressure.
4. Click OK.

Follow the next steps to calculate and plot the position of the contact point as in Figure 4-66.

1. From the Options menu, select Integration Coupling Variables>Boundary Variables.
2. Select Boundary 6. Type cont_pos in the Name edit field on the first row of the table and phi in the corresponding Expression edit field. Click OK.
3. From the Solve menu, select Update Model.
4. From the Postprocessing menu, select Global Variables Plot.
5. Type cont_pos in the Expression edit field, then click the Add Entered Expression button next to the edit field. Click OK to generate the plot.

Finally, check the obtained contact angle.

1. Click the Plot Parameters button on the Main toolbar.
2. On the General page, clear the Surface check box and select the Contour check box in the Plot type area.
3. Click the Contour tab. On the Color Data page, click the Color data option button.
4. Clear the Filled check box.
5. In the Expression edit field, type \( \text{acos}(\text{normr_twophase})*180/\pi \), then click OK.

Model Library path: MEMS_Module/Microfluidics_Models/capillary_filling_pf
MODEL NAVIGATOR
1 In the Model Navigator, go to the Space dimension list and select Axial symmetry (2D).
2 From the list of application modes, select MEMS Module>Microfluidics>Two-Phase Flow, Laminar, Phase Field.
3 In the Application mode name edit field, type twophase, then click OK.

GEOMETRY MODELING
1 Shift-click the Rectangle/Square button on the Draw toolbar. Type 3e-4 in the Width edit field, 1.5e-4 in the Height edit field, 0 in the r edit field, and -1.5e-4 in the z edit field. Click OK. Click the Zoom Extents button on the Main toolbar.
2 Create another rectangle with these settings:

<table>
<thead>
<tr>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>BASE</th>
<th>R</th>
<th>Z</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.5e-4</td>
<td>5e-4</td>
<td>Corner</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

3 Click the Zoom Extents button on the Main toolbar.

OPTIONS AND SETTINGS
1 From the Options menu, select Constants.
2 Define the following constants:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>theta</td>
<td>(3*pi/8)[rad]</td>
<td>Contact angle</td>
</tr>
<tr>
<td>p_ref</td>
<td>1e5[Pa]</td>
<td>Reference pressure</td>
</tr>
<tr>
<td>T_ref</td>
<td>293[K]</td>
<td>Temperature</td>
</tr>
<tr>
<td>g</td>
<td>9.81[m/s^2]</td>
<td>Acceleration due to gravity</td>
</tr>
</tbody>
</table>

3 Click OK.
4 From the Options>Expressions menu, open the Global Expressions dialog box.
5 Define the following global expressions:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>gradphi_twophase</td>
<td>sqrt(phir^2+phiz^2+eps)</td>
<td>Phi gradient magnitude</td>
</tr>
<tr>
<td>normr_twophase</td>
<td>ppr(phir/ (gradphi_twophase+eps))</td>
<td>Interface normal, r-component</td>
</tr>
<tr>
<td>normz_twophase</td>
<td>ppr(phiz/ (gradphi_twophase+eps))</td>
<td>Interface normal, z-component</td>
</tr>
</tbody>
</table>

Using the ppr operator gives improved derivative evaluation; see “The ppr and pprint Operators” on page 167 in the COMSOL Multiphysics User’s Guide.

Click OK.

PHYSICS SETTINGS

Subdomain Settings

1 In the Model Tree, right-click Two-Phase Flow, Laminar, Phase Field (twophase) and select Subdomain Settings.

Note: There are a number of different ways to open the Subdomain Settings and the Boundary Settings dialog boxes. This description assumes that you have the Model Tree visible in Overview mode. To open the Model Tree click the Model Tree button on the Main toolbar, then click the Overview button on the toolbar at the top of the Model Tree.

2 Press Ctrl and select both subdomains. In the Fluid 1 area, click the Load button. Select Liquids and Gases>Gases>Air from the Materials list, then click OK.

3 Click the Load button in the Fluid 2 area. Select Liquids and Gases>Liquids>Water, liquid, then click OK.

4 For both fluids, replace \( p \) and \( T \) in the expressions for the Dynamic viscosity and Density by \( p_{\text{ref}} \) and \( T_{\text{ref}} \).

5 Click on the Sources/Sinks tab.

6 In the Library coefficients area, click the Load button. Select Liquids and Gases>Liquid/Gas surface tension>Water from the Materials list and click OK.

7 Replace \( T \) in the Interfacial tension expression by \( T_{\text{ref}} \).

8 Type \(-g\) in the Gravity, z component edit field.
9. Click the Artificial Diffusion button.

10. In the Artificial Diffusion window, select the Streamline diffusion check box, select Anisotropic diffusion in the corresponding drop-down list, and then click OK.

11. On the Phase Field page, type 50 in the Mobility tuning parameter edit field and 6.5e-6 in the Parameter controlling interface thickness field.

12. Click the Init tab, select Subdomain 1, then set Fluid 2 as Initial Fluid in this domain.

13. Click OK.

**Boundary Conditions**

1. In the Model Tree right-click Two-Phase Flow, Laminar, Level Set (twophase) and select Boundary Settings.

2. Assign boundary conditions for the exterior boundaries according to the following table.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 1, 3</th>
<th>BOUNDARY 2</th>
<th>BOUNDARY 5</th>
<th>BOUNDARIES 6, 7</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary type</td>
<td>Symmetry boundary</td>
<td>Inlet</td>
<td>Outlet</td>
<td>Wall</td>
</tr>
<tr>
<td>Boundary condition</td>
<td>Axial symmetry</td>
<td>Pressure, no viscous stress</td>
<td>Pressure, no viscous stress</td>
<td>Wetted wall</td>
</tr>
<tr>
<td>( p_0 )</td>
<td>( \rho_{twophase} z^* g_{twophase} )</td>
<td>0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>( Vf_0 )</td>
<td>1</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>( \theta )</td>
<td></td>
<td></td>
<td></td>
<td>( \theta )</td>
</tr>
</tbody>
</table>

3. Select Boundary 4 and select the Interior boundaries check box. Select the boundary condition Initial fluid interface.

4. Click OK.

**Mesh Generation**

1. From the Mesh menu select Mapped Mesh Parameters.

2. Select both subdomains, then select Extremely fine from the Predefined mesh sizes list.

3. Click the Boundary tab.

4. Select Boundaries 4 and 5, then select the Constrained edge element distribution check box.

5. In the Distribution area, type 4 in the Element ration edit field and select the Reverse direction check box.
6 Click the Remesh button, then click OK.

**Computing the Solution**

First initialize $\phi$ and $\psi$ to obtain a smoothly varying $\phi$ function over the interface.

1 From the Solve menu select Solver Parameters.
2 Click the General tab and enter $0 : 0.25 \cdot 10^{-4} : 10^{-3}$ in the Times edit field.
3 Enter $0.005$ in the Relative tolerance edit field and $0.0005$ in the Absolute tolerance edit field.
4 Click OK.
5 Click the Solve button on the Main toolbar. This creates a good initial solution for the phase field variables.

Use the obtained solution as an initial condition for the simulation of the droplet motion:

1 Click the Solver Manager button on the Main toolbar.
2 Click the Store Solution button. Select the time $0.001$. Click OK.
3 In the Initial value area click the Stored solution option button.
4 Select $0.001$ from the Solution at time list, then click OK.
5 Click the Solver Parameters button on the Main toolbar.
6 In the Analysis types area, select Transient from the list of analysis types.
7 Click OK.
8 Click the Solve button on the Main toolbar.

**Postprocessing and Visualization**

1 Click the Plot Parameters button on the Main toolbar.
2 On the General page, clear the Surface check box and select the Contour and Arrow check boxes.
3 On the Contour page, go to the Contour levels area and click the Vector with isolevels option button. Type $0.5$ in the corresponding edit field.
4 Click the Arrow tab. From the Predefined quantities list on the Subdomain Data page, select Velocity field. In the Number of points edit field for z points, type $30$.
5 Click Apply.
6 On the General page, select a value from the Solution at time list and then click Apply to visualize the result at the corresponding value. Repeat to view the solution at other times.

7 Click OK.

8 To create a movie from the plots at the different times, click the Animate button on the Plot toolbar.

To create filled contour plots as in Figure 4-63, perform the following steps:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, clear the Arrow check box in the Plot type area.

3 On the Contour page, select the Filled check box.

4 Click OK.

Next, create the pressure plot in Figure 4-65.

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, clear the Contour check box and select the Surface check box in the Plot type area. In the Solution to use area, select 6e-4 from the Solution at time list.

3 Click the Surface tab. From the Predefined quantities list on the Surface Data page, select Pressure.

4 Click OK.

Follow the next steps to calculate and plot the position of the contact point as in Figure 4-66.

1 From the Options menu, select Integration Coupling Variables>Boundary Variables.

2 Select Boundary 6. Type cont_pos in the Name edit field on the first row of the table and phi in the corresponding Expression edit field. Click OK.

3 From the Solve menu, select Update Model.

4 From the Postprocessing menu, select Global Variables Plot.

5 Type cont_pos in the Expression edit field, then click the Add Entered Expression button next to the edit field. Click OK to generate the plot.

Finally, check the obtained contact angle.

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, clear the Surface check box and select the Contour check box in the Plot type area.
3 Click the Contour tab. On the Color Data page, click the Color data option button.

4 Clear the Filled check box.

5 In the Expression edit field, type \( \text{acos(normr}_{\text{twophase}}) \times 180/\pi \), then click OK.
Hydrocarbon Dehalogenation in a Tortuous Microreactor

Introduction

Removing halogen groups from hydrocarbons is an important reaction step in several chemical processes. One application is water purification. Other examples involve organic synthesis, where the removal of halogen groups serves as a starting point for carbon-carbon coupling reactions. Typically, the carbon-halogen bond scission is activated by precious metal catalysts based on platinum or palladium.

The model presented here shows hydrocarbon dehalogenation as it occurs in a microreactor. The reactants are transported from the fluid bulk to the catalytic surfaces at the reactor walls, where they react. A first model is set up in Reaction Engineering Lab, where two competing reactions are analyzed. Subsequently, the reaction kinetics are exported to the MEMS Module, where a space-dependent model of the microreactor is set up and solved.

Note: This model requires the COMSOL Reaction Engineering Lab and the MEMS Module.

Model Definition

The adsorption of halogenated hydrocarbons onto the surface of a platinum catalyst leads to cleavage of the carbon halogen bond. The hydrocarbon fragments then undergo either hydrogenation or coupling reactions. Figure 4-68 illustrates the overall reactions for a brominated hydrocarbon species.

\[ R\text{-Br} + \frac{k_1}{[Pt]} \rightarrow R\text{-H} \]

\[ 2R\text{-Br} + \frac{k_2}{[Pt]} \rightarrow R\text{-R} \]

Figure 4-68: The dehalogenation of RBr can result either in hydrogenation or coupling of the hydrocarbon fragments.
The reaction rates are:

\[ r_1 = k_1 c_{RBr} \quad (4-38) \]

and

\[ r_2 = k_2 c_{RBr}^2 \quad (4-39) \]

where the rate constants are given by the Arrhenius expression:

\[ k_j = A_j \exp \left( \frac{E_j}{R T} \right) \quad (4-40) \]

In Equation 4-40, \( A \) is the frequency factor, and \( E \) the activation energy (J/mol). The table below lists the values of the Arrhenius parameters for the two reactions.

<table>
<thead>
<tr>
<th></th>
<th>FREQUENCY FACTOR</th>
<th>ACTIVATION ENERGY</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reaction 1</td>
<td>2e-3</td>
<td>10e3</td>
</tr>
<tr>
<td>Reaction 2</td>
<td>1e-3</td>
<td>30e3</td>
</tr>
</tbody>
</table>

**Ideal Reactor Model**

The mass balance equation for a flow-through reactor is given by

\[ \frac{dF_i}{dV} = R_i \quad (4-41) \]

where \( F \) is the molar flow rate (mol/s), \( V \) the reactor volume (m\(^3\)), and \( R_i \) the net reaction term (mol/(m\(^3\) s)). If the reactor has constant cross-section and constant flow velocity, the left hand side of Equation 4-41 can be rewritten as

\[ \frac{dF_i}{dV} = u \frac{dc_i}{dx} = \frac{dc_i}{d\tau} \quad (4-42) \]

The reactor mass balance thus becomes

\[ \frac{dc_i}{d\tau} = R_i \quad (4-43) \]

where \( \tau \) represents the residence time (s). The assumption of constant flow velocity is valid for incompressible liquids or liquids where the effect of temperature on the density is small. Equation 4-43 is identical to the balance equation of the batch reactor,
except that residence time replaces the reaction time. You can therefore make use of the Batch reactor type when solving the model in the Reaction Engineering Lab.

The ideal reactor model assumes by default that reactions take place in the entire reactor volume. In the 3D microreactor model, reactions occur at catalytic surfaces located at the reactor walls. In order to make the ideal model represent a reactor with surface reactions, Equation 4-43 has to be scaled by the reactive area per reactor volume. Scaling the ideal reactor equations by the dimensions of the microreactor makes the 1D and 3D models comparable. The area to volume ratio is

\[
\frac{WL}{WHL} = \frac{1}{H} \quad (4-44)
\]

where \( W \) is the width of the channel (m), \( H \) the channel height (m), and \( L \) the length of a reactive section (m). The scaled ideal reactor equation is then

\[
\frac{d\epsilon_i}{d\tau} = \frac{R_i}{H} \quad (4-45)
\]

Note that the net reaction term \( (R_i) \) in this case represents surface reactions \((\text{mol}/(\text{m}^2 \cdot \text{s})))\).

**SPACE-DEPENDENT MODEL**

The microreactor considered in this example consists of a tortuous channel, fitted with inlet and outlet adapter sections, as illustrated in Figure 4-69.

![Figure 4-69: Microreactor geometry.](image-url)
In the straight sections of the reactor, the channel walls are in part coated with platinum catalyst. As water with small amounts of a brominated hydrocarbon flows through the reactor, dehalogenation reactions occur at the catalytic surfaces.

**MOMENTUM BALANCES**

The flow in the channel is described by the Navier-Stokes equations:

\[
\nabla \cdot [-\eta(\nabla \mathbf{u} + (\nabla \mathbf{u})^T) + \rho I] = -\rho (\mathbf{u} \cdot \nabla) \mathbf{u}
\]

\[
\nabla \cdot \mathbf{u} = 0
\]

(4-46)

where \( \rho \) denotes density (kg/m\(^3\)), \( \mathbf{u} \) represents the velocity (m/s), \( \eta \) denotes viscosity (kg/(m·s)), and \( p \) equals pressure (Pa).

A pressure difference drives the flow through the reactor, as indicated by the boundary conditions

\[
p = p_{\text{inlet}} \quad \text{inlet}
\]

\[
p = 0 \quad \text{outlet}
\]

(4-47)

Each pressure condition is specified along with a vanishing viscous stress condition at the boundary

\[
\eta(\nabla \mathbf{u} + (\nabla \mathbf{u})^T) \mathbf{n} = 0
\]

At the wall the velocity is zero

\[
\mathbf{u} = 0 \quad \text{walls}
\]

(4-48)

**MASS BALANCES**

The mass balances set up and solved are the diffusion-convection equations at steady state:

\[
\nabla \cdot (-D_i \nabla c_i + c_i \mathbf{u}) = 0
\]

(4-49)

Here \( D_i \) denotes the diffusion coefficient (m\(^2\)/s), \( c_i \) is the species concentration (mol/m\(^3\)), and \( \mathbf{u} \) equals the velocity (m/s).

No reactions take place in the fluid bulk. Rather, the reactions take place on the catalytic surfaces. The boundary fluxes at the catalytic surfaces thus become

\[
\mathbf{n} \cdot (-D_i \nabla c_i + c_i \mathbf{u}) = R_i
\]

(4-50)
where $R_i$ represents the reaction term. Note that these boundary conditions are set up automatically as you export the reaction kinetics from the Reaction Engineering Lab to COMSOL Multiphysics.

Inlet conditions are equal to the inlet concentrations

\[ c = c_{\text{in}} \quad (4-51) \]

At the outlet, you can set the convective flux condition, assuming that the transport of mass across the boundary is dominated by convection

\[ \mathbf{n} \cdot (-D \nabla c) = 0 \quad (4-52) \]

All other boundaries use the insulating condition

\[ \mathbf{n} \cdot (-D \nabla c + c \mathbf{u}) = 0 \quad (4-53) \]

**Results**

First review the results of the ideal reactor model, which you set up and solve in the Reaction Engineering Lab.

Figure 4-70 through Figure 4-72 show concentration profiles of reactant and products as function of residence time, evaluated at 288 K, 343 K, and 363 K.

![Figure 4-70: Concentration of the RBr, RH, and RR species as function of residence time. Reactions occur at 288 K.](image_url)
Figure 4-71: Concentration of the RBr, RH, and RR species as function of residence time. Reactions occur at 343 K.

Figure 4-72: Concentration of the RBr, RH, and RR species as function of residence time. Reactions occur at 363 K.

The hydrocarbon coupling reaction has the higher activation energy and is hence more temperature sensitive than the hydrogenation reaction (see Table 4-5). The concentration plots of the ideal reactors outline the effect quite clearly. At 288 K, the hydrogenation product RH is dominant, while at 363 K the coupling product is the more prominent. Notably, at 343 K, the concentration dependency on the reaction rates becomes accentuated, so that RBr dominates only at shorter τ and RH at longer τ.
Although the primary goal may be to remove the halogenated reactant, RBr, it may also be important to set reaction conditions in such a way that the most favorable by-product is formed. The present model shows how such design aspects can readily be investigated in the Reaction Engineering Lab.

The next set of results refer to the space-dependent model of a tortuous microreactor, set up and solved in COMSOL Multiphysics.

Figure 4-73 shows the velocity of the laminar flow field in the reactor. The flow is driven by a pressure difference of 1500 Pa between inlet and outlet. The resulting maximum velocity is close to 5 mm/s.

Figure 4-73: Velocity field in the reactor where the pressure difference between inlet and outlet is 1500 Pa.
Figure 4-74 shows the concentration distribution of the reactant RBr in the reactor. At relatively low temperature, 288 K, the outlet concentration is 10.6 mol/m$^3$.

Running the reactor at 363 K, the outlet concentration of RBr is still 6.7 mol/m$^3$.

Judging from the results of the ideal reactor models, a more pronounced temperature effect would be expected. The reason for this apparently moderate influence on conversion is that the increased temperature also affects the flow.

Figure 4-74: Concentration distribution of the halogenated reactant RBr. Fluid properties and reaction rates are evaluated at 288 K.

Figure 4-75: Concentration distribution of the halogenated reactant RBr. Fluid properties and reaction rates are evaluated at 363 K.
Raising the temperature from 282 K to 363 K decreases the viscosity of water from $1.36 \times 10^{-3}$ to $3.17 \times 10^{-4}$. This is automatically taken into account by the temperature dependent fluid properties. As the flow through the reactor is driven by a constant pressure difference, the velocity will increase as viscosity decreases. Results show that the maximum fluid velocity at 363 K is ~3.6 times greater than at 282 K, resulting in a shorter residence time.

The following path shows the location of the COMSOL Multiphysics model:

**Model Library path:** MEMS_Module/Microfluidics_Models/tortuous_reactor

---

**Modeling Using COMSOL Multiphysics**

**MODEL NAVIGATOR**
1. Start COMSOL Multiphysics by clicking the desktop icon.
2. Select 3D from the Space dimension list.
3. In the list of application modes select MEMS Module>Microfluidics>Incompressible Navier-Stokes.
4. Click OK.

**GEOMETRY MODELING**
Choose File>Import CAD Data From File. Browse to the file tortuous_reactor.mphbin in the models/Reaction_Engineering_Lab/Microfluidics folder and click Import.

**PHYSICS SETTINGS**

*Subdomain Settings—Incompressible Navier-Stokes*
1. Choose Physics>Subdomain Settings.
2. In the Subdomain selection list, select all subdomains by pressing Ctrl+A and clicking the list.
3. Go to the Materials/Coefficients Library by clicking the Load button.
4. Browse to Liquids and Gases>Liquids>Water and click OK to load the properties.
5. Click OK.
Boundary Conditions—Incompressible Navier-Stokes


2. Enter the following boundary conditions:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 6</th>
<th>BOUNDARY 104</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary type</td>
<td>Inlet</td>
<td>Outlet</td>
</tr>
<tr>
<td>Boundary condition</td>
<td>Pressure, no viscous stress</td>
<td>Pressure, no viscous stress</td>
</tr>
<tr>
<td>$P_0$</td>
<td>$\delta_p$</td>
<td>0</td>
</tr>
</tbody>
</table>

Leave all other boundaries at their default setting (Wall, No slip).

3. Click OK.

Options and Settings

1. Choose Options>Constants then enter the following data:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\delta_p$</td>
<td>1.5[kPa]</td>
<td>Inlet overpressure</td>
</tr>
<tr>
<td>$T$</td>
<td>288[K]</td>
<td>Temperature</td>
</tr>
</tbody>
</table>

2. Click OK.

Mesh Generation

1. Select the menu item Mesh>Free Mesh Parameters.

2. On the Global page select Finer from the Predefined mesh sizes list.

3. Click the Boundary page, select Boundary 8, and click the Mesh Selected button.

4. Choose Mesh>Swept Mesh Parameters.

5. Select Subdomains 2–19 and 21 from the Subdomain selection list by pressing Ctrl and clicking in the list.

6. Click the Mesh Selected button.

7. Click OK to close the Swept Mesh Parameters dialog.

8. Go to the Free Mesh Parameters dialog, and click the Subdomain page.

9. Select Subdomains 1 and 20 from the Subdomain selection list by pressing Ctrl and clicking in the list.

10. Click the Mesh Selected button.
Click **OK** to close the **Free Mesh Parameters** dialog box.

**COMPUTING THE SOLUTION**

1. Solve the problem by clicking the **Solve** button ( = ) on the Main toolbar.
2. Select the menu item **Solve>Solver Manager**.
3. Click the **Store Solution** button, then click **OK**.

**POSTPROCESSING THE SOLUTION**

The following steps reproduce Figure 4-73:

1. Choose **Postprocessing>Plot Parameters**.
2. On the **Slice** page, select the **Slice plot** check box.
3. Type 0 in the **x levels** edit field and 1 in the **z levels** edit field.
4. Click **OK**.

**Modeling Using the COMSOL Reaction Engineering Lab**

1. In the main user interface of COMSOL Multiphysics, choose **File>Reaction Engineering Lab**.
   - The main user interface of COMSOL Reaction Engineering Lab opens up.
2. Click the **COMSOL Reaction Engineering Lab** window.

**OPTIONS AND SETTINGS**

1. Click the **Model Settings** button on the Main toolbar.
2. On the **General** page type 288 in the **Temperature** edit field.
3. Click **Close**.
Choose Model>Constants then enter the following data:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>H</td>
<td>5e-6</td>
<td>Reactor channel height (m)</td>
</tr>
</tbody>
</table>

Click OK.

**REACTIONS INTERFACE**

1. Click the Reaction Settings button on the Main toolbar.
2. Make sure the Reactions page is active. Create two entries in the Reaction selection list by clicking the New button twice.
3. Enter the following reaction formulas by first selecting the appropriate row in the Reaction selection list and then entering the corresponding text in the Formula edit field.

<table>
<thead>
<tr>
<th>REACTION ID #</th>
<th>REACTION FORMULA</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>RBr=&gt;RH</td>
</tr>
<tr>
<td>2</td>
<td>2RBr=&gt;RR</td>
</tr>
</tbody>
</table>

4. Select row 1 from the Reaction selection list.
5. Select the Use Arrhenius expression check box.
6. Enter 2e-3 in the A edit field and 10e3 in the E edit field.
7. Select row 2 from the Reaction Selection list.
8. Select the Use Arrhenius expression check box.
9. Enter 1e-1 in the A edit field and 30e3 in the E edit field.
10. Select Reaction 1 from the Reaction selection list and type kf_1*c_RBr/H in the r edit field.
11. Select Reaction 2 from the Reaction selection list and type kf_2*c_RBr^2/H in the r edit field.

You have now modified the automatically generated reaction rates by dividing with the scale factor H, according to Equation 4-45.

**SPECIES INTERFACE**

1. Click the Species tab.
2. Select RBr from the Species selection list and type 50 in the c0 edit field.
3. Click Close.
COMPUTING THE SOLUTION
1 Open the Simulation>Solver Parameters dialog box.
2 Type 1 in the Times edit field.
3 Click OK.
4 Click the Solve Problem button ( ) on the Main toolbar.

POSTPROCESSING AND VISUALIZATION
The results of Figure 4-70 are shown in the default plot. To generate the results shown in Figure 4-71 follow these steps.

1 Click the Model Settings button on the Main toolbar.
2 On the General page type 343 in the Temperature edit field.
3 Click Close.
4 Click the Solve Problem button.

To generate the results shown in Figure 4-72:

1 Click the Model Settings button on the Main toolbar.
2 On the General page type 363 in the Temperature edit field.
3 Click Close.
4 Click the Solve Problem button.

EXPORT SETTINGS
Now proceed to export the reaction kinetics to the reacting boundaries in the Multiphysics model. Recall that the rate constants are temperature dependent. To export a temperature variable while only exporting mass balances, follow these steps:

1 Click the Model Settings button on the Main toolbar.
2 On the General page type Temp in the Temperature edit field.
3 Click Close.

This exports a variable name Temp rather than a constant temperature, which would otherwise be the case.

Recall also that the reaction rates were scaled in order to make the 1D ideal reactor comparable to the 3D microreactor. As you are about to export the reaction kinetics to the 3D model, the effect of the scaling should first be removed.
1 Choose Model>Constants then set the scaling factor H to 1:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>H</td>
<td>1</td>
<td>reactor channel height (m)</td>
</tr>
</tbody>
</table>

2 Click OK.

Now, move on to export the reaction model.

1 Click the Export to COMSOL Multiphysics button on the Main toolbar.
2 The Export to COMSOL Multiphysics dialog box appears.
3 Select Boundary in the Domain level drop down list.
4 Go to the Export mass balance area, and in the Application mode list select Convection and Diffusion: New.
5 In the Group name edit field type reactions.
6 Move to the Export energy balance area and clear the check box in the upper left corner.
7 Click the Export button at the bottom of the dialog box.

**Modeling Using COMSOL Multiphysics**

It is now time to investigate the chemistry taking place in a space-dependent model.

Click the COMSOL Multiphysics window.

**Subdomain Settings—Convection and Diffusion**

1 From the Multiphysics menu, select Convection and Diffusion (chcd).
2 From the Physics menu select Subdomain Settings.
3 In the Subdomain selection list, select all subdomains by pressing Ctrl+A and clicking the list.
4 On the c_RBr page type the following:

<table>
<thead>
<tr>
<th>EDIT FIELD</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Diffusion coefficient</td>
<td>D</td>
</tr>
<tr>
<td>x-velocity</td>
<td>u</td>
</tr>
<tr>
<td>y-velocity</td>
<td>v</td>
</tr>
<tr>
<td>z-velocity</td>
<td>w</td>
</tr>
</tbody>
</table>

5 Type in the same entries on the c_RH page and the c_RR page.
6. Click OK.

**Boundary Conditions—Convection and Diffusion**

1. From the Physics menu, select **Boundary Settings**.

2. In the **Boundary selection** list, select 27, 41, 57, 71, and 87 by pressing Ctrl and clicking the entries. These boundaries represent the reactive surfaces.

3. Select **reactions** from the **Group** list.

   This associates the exported kinetics from Reaction Engineering Lab with the catalytic surfaces. The **Flux** boundary condition is automatically set on all mass balance pages, and the appropriate reaction terms appear in the **Inward flux** edit fields.

4. Enter the remaining boundary conditions for each of the species \( c_{RBr} \), \( c_{RH} \), and \( c_{RR} \) according to the following table:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 6</th>
<th>BOUNDARY 104</th>
<th>ALL OTHERS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Concentration</td>
<td>Convective flux</td>
<td>Insulation/Symmetry</td>
</tr>
<tr>
<td>( c_{RBr} )</td>
<td>0</td>
<td>50</td>
<td></td>
</tr>
<tr>
<td>( c_{RH} )</td>
<td>0</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>( c_{RR} )</td>
<td>0</td>
<td>0</td>
<td></td>
</tr>
</tbody>
</table>

5. Click **OK**.

**OPTIONS AND SETTINGS**

1. From the **Options** menu, select **Constants**.

2. Add entries to complete the list of constants as follows:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>delta_p</td>
<td>1.5[kPa]</td>
<td>Inlet overpressure</td>
</tr>
<tr>
<td>T</td>
<td>288[K]</td>
<td>Temperature</td>
</tr>
<tr>
<td>D</td>
<td>1e-6[m^2/s]*exp(-2000[K]/T)</td>
<td>Diffusivity</td>
</tr>
<tr>
<td>Temp</td>
<td>T</td>
<td>Temperature</td>
</tr>
</tbody>
</table>

3. Click **OK**.

**COMPUTING THE SOLUTION**

1. Select the menu item **Solve>Solver Manager**.
2 In the Values of variables not solved for and linearization point, click the Stored solution option button.

3 Click the Solve For tab.

4 Select only the Convection and Diffusion (chcd) folder in the Solve for variables tree.

5 Click OK.

6 Solve the problem by clicking the Solve button (=) on the Main toolbar.

POSTPROCESSING THE SOLUTION

The following steps reproduce Figure 4-74:

1 Choose Postprocessing>Plot Parameters.

2 On the General page, clear the Slice check box in the Plot type area.

3 On the Boundary page, select the Boundary plot check box.

4 Type c_RBr in the Expression edit field.

5 Click OK.

To reproduce the results in Figure 4-75, change the variable T in the Constants dialog box to 363[K], and solve for the flow and mass balances as outlined above.
Two-Phase Fluid-Structure Interaction

Introduction

The following example demonstrates techniques for modeling a fluid-structure interaction containing two fluid phases in COMSOL Multiphysics. It illustrates how a heavier fluid can induce movement in an obstacle using the arbitrary Lagrangian-Eulerian (ALE) technique along with the Two-Phase Flow, Phase Field application mode in the MEMS Module.

The model geometry consists of a small container, in the middle of which is an obstacle. Initially a heavier fluid (water) is present in the left domain and air is present everywhere else. A return passage allows the displaced air to move from the right domain back to the left domain. The model is similar to a classic dam break benchmark, except the obstacle disrupts the flow of the water into the right domain. The obstacle begins to bend due to the inertial force of the heavier fluid.

The arbitrary Lagrangian-Eulerian (ALE) method handles the dynamics of the deforming geometry and the moving boundaries with a moving grid. The fluid/fluid boundary is tracked using the phase field method. On the obstacle surface, a “moving wetted wall” boundary condition is applied, which allows a wall velocity and a contact angle to be specified. COMSOL Multiphysics computes new mesh coordinates on the channel area based on the movement of the structure’s boundaries and on so called mesh smoothing.

The structural mechanics portion of the model does not require the ALE method, and COMSOL Multiphysics solves it in a fixed coordinate system as usual. However, the strains the model computes in this way are the only source for computing the deformed coordinates with ALE.

Model Definition

Initially, the heavier fluid forms a dam. The container is 3 cm long and 1 cm high. The top of the rubber obstacle is fixed to the container and it hangs freely inside the container. An initial barrier of water is released and when it reaches the obstacle, it pushes it away from its original position. The displaced air naturally feeds into the opposite side of the obstacle thanks to the return path. If no return path were defined,
the water would not be able to penetrate into the right domain. In the real world, this effect is observed when pouring milk or orange juice from a container. The liquid tends to exit the container in a periodic motion. If the carton is pierced so that displaced air can re-enter, a very smooth pour results. The two fluids are air and water, whose physical properties are \(1.25 \, \text{kg/m}^3\) and \(1000 \, \text{kg/m}^3\) for the density and \(2 \times 10^{-5} \, \text{Pa-s}\) and \(0.001 \, \text{Pa-s}\) for the dynamic viscosity. The surface tension coefficient is \(0.0729 \, \text{N/m}\). The Young's modulus of the obstacle is set to \(200 \, \text{kPa}\).

\[\text{Figure 4-76: Initial fluid density inside the container. The rubber obstacle hangs down from the container and is free to move.}\]

**Problem Formulation**

The phase field equations are taken from Ref. 1 and solved along with a suitable equation for the mesh and structural deformation.

**Subdomain Equations**

The velocity field and pressure for the liquid phase are described by the Navier-Stokes equations:

\[
\frac{\partial \rho u}{\partial t} + \rho (u \cdot \nabla) u = \nabla \cdot \left[ -p \mathbf{I} + \eta (\nabla u + (\nabla u)^T) \right] + \rho \mathbf{g} + G \nabla \phi
\]  
(4-54)
\[ \nabla \cdot \mathbf{u} = 0 \]

where \( \mathbf{u} \) is the fluid velocity \((\text{m/s})\). The density and viscosity are denoted by \( \rho \) \((\text{kg/m}^3)\) and \( \eta \) \((\text{N} \cdot \text{s/m}^2)\). The chemical potential is denoted by \( G \) \((\text{J/m}^3)\). The last term on the right-hand side of Equation 4.54 is a body force due to surface tension. The Cahn-Hilliard equation describe the interface dynamics of a two-phase flow:

\[ \frac{\partial \phi}{\partial t} + \mathbf{u} \cdot \nabla \phi = \nabla \cdot \left( \frac{\gamma \lambda}{\varepsilon^2} \nabla \psi \right) \]

where \( \phi \) is the dimensionless phase field variable so that the concentration of the components of the fluid are \((1 + \phi)/2\) and \((1 - \phi)/2\). The quantity \( \lambda \) is the mixing energy density \((\text{N})\) and \( \varepsilon \) is a capillary width that scales with the thickness of the interface \((\text{m})\). These two parameters are related to the surface tension coefficient via:

\[ \sigma = \frac{2 \sqrt{\gamma \lambda}}{3 \varepsilon} \]

The variable \( \gamma \) is the mobility \((\text{m}^3 \cdot \text{s/kg})\). The mobility determines the time scale of the Cahn-Hilliard diffusion and must be large enough to retain a constant interfacial thickness but small enough so that the convective terms are not overly damped. The equation governing \( \psi \) is:

\[ \psi = -\nabla \cdot \varepsilon^2 \nabla \phi + (\phi^2 - 1) \phi \]

The motion of the deformed mesh is modeled using Winslow smoothing. For more information on this formulation, please refer to “The Moving Mesh Application Mode” on page 463 of the COMSOL Multiphysics Modeling Guide. This is the default smoothing when using the predefined Fluid-Structure Interaction coupled application modes. The boundary conditions control the displacement of the moving mesh with respect to the initial geometry. At the boundaries of the obstacle, this displacement is the same as the structural deformation. At the exterior boundaries of the flow domain, the deformation is set to zero in all directions.

**BOUNDARY CONDITIONS**

The coupling of the Navier Stokes equations to the structural mechanics and moving mesh application modes arises through appropriate boundary conditions. On the surface of the rubber obstacle, the mesh displacement is equal to the structural displacement:

\[ \mathbf{x}_{\text{mesh}} = \mathbf{x}_{\text{rubber}} \]
A fluid velocity equal to the mesh velocity is imposed on the rubber obstacle according to:

\[ \mathbf{u} = \mathbf{u}_m \]

Additionally, a contact angle on the rubber obstacle of \( \theta_w = \pi/3 \) is specified:

\[ \mathbf{n} \cdot \varepsilon^2 \nabla \phi = \varepsilon^2 \tan\left(\pi/2 - \theta_w\right) |\nabla \phi - (\mathbf{n} \cdot \nabla \phi) \mathbf{n}| \]

For the structural mechanics application mode, a load due to the fluid motion is imposed:

\[ \mathbf{F} = \mathbf{n} \cdot [-p \mathbf{I} + \eta (\nabla \mathbf{u} + (\nabla \mathbf{u})^T)] \]

where \( \mathbf{n} \) is the unit vector normal to the boundary. This load represents a sum of pressure and viscous forces.

**POINT SETTINGS**

In order to make the pressure unique everywhere in the container, the pressure is constrained at a point.

**Results and Discussion**

Figure 4-77 shows the deformation of the rubber obstacle at \( t = 0.12 \) s. The water (indicated by the red color) is traveling from left to right and the return passage allows the displaced air to naturally recirculate between the two sides of the obstacle. After the initial release of the heavier fluid, the obstacle begins to relax back toward its original position and the liquid level starts to evenly distribute on either side of the obstacle.
Figure 4-77: Plot of fluid density and deformed geometry at 0.12 s.
CHAPTER 4: MICROFLUIDICS MODELS

Figure 4-78: Plot of density at final solution time. The rubber obstacle has nearly returned to its original position. Notice that the contact angle on the container walls is 90 degrees, but on the rubber obstacle the angle is 30 degrees.

Modeling in COMSOL Multiphysics

This example implements the model using three application modes, which the predefined Fluid-Structure Interaction multiphysics entry sets up automatically. First, the Two-Phase Flow, Laminar, Phase Field application mode solves for the velocity, pressure, and volume fraction of the two phases. You activate the two-phase flow option via the Application Mode Properties dialog box.

Second, the Plane Strain application mode solves the model’s structural mechanics portion. You activate it only inside the rubber obstacle. To get a more accurate computation of the large strains, the large deformation analysis type is the default setting. The deformation velocity solved with this application mode acts as the boundary condition for the Two-Phase Flow, Laminar, Phase Field and the Moving Mesh (ALE) application modes.

Third, the Moving Mesh (ALE) application mode solves for the mesh deformation.
Reference


Model Library path: MEMS_Module/Microfluidics_Models/twophase_fsi

Modeling Using the Graphical User Interface

**MODEL NAVIGATOR**

1. In the Model Navigator, select 2D from the Space dimension list.
2. From the Application Modes list, select MEMS Module>Fluid-Structure Interaction>Plane Strain with Fluid Interaction>Transient analysis.
3. Click OK to close the Model Navigator.

**GEOMETRY MODELING**

1. In Draw mode, hold down shift and click the Rectangle/Square button on the Draw toolbar.
2. In the Width edit field type 0.01, and in the Height edit field type 0.01. Click OK.
4. In the Width edit field type 0.02, and in the Height edit field type 0.01.
5. In the X edit field type 0.01.
6. Click OK.
7. Click the Zoom Extents button on the Main toolbar.
8. Shift-click the Rectangle/Square button on the Draw toolbar.
9. In the Width edit field type 0.0085, and in the Height edit field type 0.0025.
10. In the X edit field type 0.012. In the Y edit field type 0.01.
11. Click OK.
12. Shift-click the Rectangle/Square button on the Draw toolbar.
13. In the Width edit field type 0.0045, and in the Height edit field type 0.002.
14. In the X edit field type 0.014. In the Y edit field type 0.01.
15 Click **OK**.
16 Select objects R3 and R4. Click the **Difference** button on the Draw toolbar. This will create a new composite object called CO1.
17 Select objects CO1 and R2. Click the **Union** button on the Draw toolbar and then the **Delete Interior Boundaries** button.
18 Shift-click the **Rectangle/Square** button on the Draw toolbar.
19 In the **Width** edit field type \(5 \times 10^{-4}\), and in the **Height** edit field type \(0.00775\).
20 In the **X** edit field type \(0.016\). In the **Y** edit field type \(0.00225\).
21 Click **OK**.
22 Shift-click the **Ellipse/Circle (Centered)** button on the Draw toolbar.
23 In the **Radius** edit field type \(2.5 \times 10^{-4}\).
24 In the **X** edit field type \(0.01625\). In the **Y** edit field type \(0.00225\).
25 Click **OK**.
26 Select objects C1 and R2, then click the **Union** button on the Draw toolbar. Click the **Delete Interior Boundaries** button on the Draw toolbar.
27 Click the **Zoom Extents** button on the Main toolbar.

**PHYSICS SETTINGS**
1 From **Physics** menu, select **Model Settings**.
2 Under **Frames**, select **Frame (ref)**. Set the geometry shape order to **Linear**.
3 Under **Frames**, select **Frame (ale)**. Set the geometry shape order to **Linear**.
4 Click **OK**.
5 From **Physics** menu, select **Properties** to open the **Application Mode Properties** dialog box.
6 Set the **Two-phase flow** property to **Non-conservative phase field**.
7 Click **OK**.

**Subdomain Settings**
1 From the **Physics** menu, select **Subdomain Settings**.
2 Select Subdomains 1 and 2 and then select **Fluid domain** from the **Group** list.
3 For **Fluid 1**, for the density edit field type \(1.25\) and for the dynamic viscosity edit field type \(2 \times 10^{-5}\).
4 For **Fluid 2**, for the density edit field type \(1000\) and for the dynamic viscosity edit field type \(1 \times 10^{-3}\). Click **Apply**.
5. Click the Sources/Sinks tab. In the surface tension coefficient edit field type 0.0729. In the Gravity, y-component edit type -9.81.

6. Click the Phase Field tab. In the Parameter controlling interface thickness edit field type 4e-4.

7. Click the Init tab. Select only Subdomain 1, then click the Fluid 2 button.

8. Select Subdomain 3, then select Solid domain from the Group list. This deactivates the fluid equations in Subdomain 3 (the solid).

9. Click OK to close the dialog box.

10. From the Multiphysics menu, select Plane Strain (smn).

11. From the Physics menu, select Subdomain Settings.

12. Select Subdomains 1 and 2, then select Fluid domain from the Group list to deactivate the structural mechanics equations in the fluid.

13. Select Subdomain 3, then select Solid domain from the Group list. In the E edit field for the Young’s modulus, type 200[kPa].

14. Click OK to close the dialog box.

15. From the Multiphysics menu, select Moving Mesh (ALE) (ale).

16. From the Physics menu, open the Subdomain Settings dialog box.

17. Select all Subdomains and click the Element tab. Select Lagrange - Linear from the list of Predefined elements.

18. Click the Mesh tab in the Subdomain Settings dialog box. Select Subdomain 1, then click the No displacement radio button.

19. Select Subdomain 2, then select Fluid domain from the Group list.

20. Select Subdomain 3, then select Solid domain from the Group list. For the fluid domain, this means that the displacements are free. In the solid domain, the deformation of the solid determines the mesh displacement.

21. Click OK.

Boundary Conditions

1. From the Multiphysics menu, select Two-Phase Flow, Laminar, Phase Field (mmglf).

2. From the Physics menu, open the Boundary Settings dialog box.

3. Select Boundaries 12, 14, 20, and 21. With Wall as the selection in the Boundary type list, select Moving wetted wall from the Boundary condition list.

4. Type xt in the x-velocity of moving wall edit field and yt in the y-velocity of moving wall edit field.
5 In the Contact angle edit field type $\pi/3$.
6 Select Boundary 19 from the Boundary selection list and then select the Select by group check box.
7 With Wall as the selection in the Boundary type list, select Wetted wall from the Boundary condition list.
8 Make sure that $\pi/2$ is entered in the Contact angle edit field.
9 Clear the Select by group check box.
10 Click OK.
11 From the Multiphysics menu, select Plane Strain (smpn).
12 From the Physics menu, open the Boundary Settings dialog box.
13 Select Boundaries 12, 14, 20, and 21. Select Fluid load from the Group list. This automatically adds the force due to the fluid motion which you can see by clicking on the Load tab.
14 Select Boundary 13, then set the Constraint condition to Fixed.
15 Click OK.
16 From the Multiphysics menu, select Moving Mesh (ALE) (ale).
17 From the Physics menu, open the Boundary Settings dialog box.
18 Select all boundaries, then select Fixed from the Group list.
19 Select Boundaries 12, 14, 20, and 21 and select Structural displacement from the Group list.
20 Finally, select Boundary 5 and clear the dx check box under Mesh displacement. This allows the mesh to slip along this boundary in the x direction and so the mesh avoids becoming tangled up as the rubber obstacle begins to deform.
21 Click OK.

Point Settings
1 From the Multiphysics menu, select Two-Phase Flow, Laminar, Phase Field (mmglf).
2 From the Physics menu, open the Point Settings dialog box.
3 Select Point 6 and check the Point constraint check box.
4 Click OK.

Mesh Generation
1 From the Mesh menu, choose Mapped Mesh Parameters.
2 Select Subdomain 1, then select Extremely fine from the Predefined mesh sizes list.
3 Click the **Mesh Selected** button.
4 Click **OK**.
5 From the **Mesh** menu, choose **Free Mesh Parameters**.
6 Select **Normal** from the **Predefined mesh sizes** list.
7 Click the **Boundary** tab.
8 Select Boundaries 8 and 11 and set the **Maximum element size** to $2 \times 10^{-4}$.
9 Click the **Subdomain** tab.
10 Select Subdomains 2 and 3 and set the **Maximum element size** to $4 \times 10^{-4}$.
11 Set the **Method** to **Quad**.
12 Click the **Mesh Selected** button.
13 Click **OK**.

**COMPUTING THE SOLUTION**

You compute the solution in two stages. First, the phase field variable is initialized. In order for the phase field variable to reach a steady-state value, the end time is selected as 40 seconds. In general it might be necessary to run the initialization stage for a longer time than the full fluid model. Once the phase field variable is initialized, you solve the full problem by clicking the **Restart** button.

1 From the **Physics** menu, choose **Properties**.
2 Set the **Analysis type** to **Transient initialization**.
3 Click **OK**.
4 Click the **Solver Parameters** button on the Main toolbar.
5 In the **Times** edit field type $0:2:40$.
6 In the **Relative tolerance** edit type 0.002.
7 On the **Time Stepping** page, enter 10 for the **Maximum time step**.
8 Click **OK**.
9 Click the **Solver Manager** button on the Main toolbar.
10 On the **Solve For** page, select only $\phi$ and $\psi$.
11 Click **OK**.
12 Click the **Solve** button on the Main toolbar.
13 When the solver has computed the transient initialization, click the **Solver Parameters** button on the Main toolbar.
14 On the **General** page, set the **Times** to $0:0.002:0.2$. 
Select Transient from the list of analysis types for the Two-Phase Flow, Laminar, Phase Field application mode.

Click OK.

Click the Solver Manager button on the Main toolbar.

On the Solve For page, select all variables.

Click OK.

Click the Restart button on the Main toolbar.

**POSTPROCESSING AND VISUALIZATION**

To reproduce the plots given in “Results and Discussion” on page 432, do the following:

1. Click the Plot Parameters button on the Main toolbar.
2. On the General page, find the Plot type area. Select the Contour, Boundary, and Arrow check boxes; clear all the other check boxes.
3. Click the Contour tab. From the Predefined quantities list on the Contour Data page, select Two-Phase Flow, Laminar, Phase Field (mmglf)>Density.
4. Click the Vector with isolevels option button and type 500 in the associated edit field.
5. Set the Colormap to jet and select the Filled check box.
6. Click the Boundary tab. Type 1 in the Expression edit field on the Boundary Data page.
7. Click the Uniform color option button, then click the Color button. Set the color to black, then click OK to close the Boundary Color dialog box.
8. Click the Arrow tab. From the Predefined quantities list on the Subdomain Data page, select Two-Phase Flow, Laminar, Phase Field (mmglf)>Velocity field.
9. Set the number of X points to 30 and the number of Y points to 35.
10. Click OK.

To see the deformation of the beam at maximum displacement, do the following:

1. Click the Plot Parameters button on the Main toolbar.
2. On the General page, set the Solution at time to 0.12.
3. Click OK.
Droplet Breakup in a T-Junction

Introduction

Emulsions consist of small liquid droplets immersed in another liquid, typically oil in water or water in oil. Emulsions find wide application in the production of food, cosmetics, and pharmaceutical products. The properties and quality of an emulsion typically depend on the size and the distribution of the droplets. This model studies in detail how to create uniform droplets in a microchannel T-junction.

Setting up the model you can make use of the Two-Phase Flow, Laminar, Level Set application mode. The model uses the predefined wetted wall boundary condition at the solid walls, with a contact angle of 135°. From the results, you can determine the size of the created droplets and the rate with which they are produced.

Model Definition

Figure 4-79 shows the geometry of the T-shaped microchannel with a rectangular cross section. For the separated fluid elements to correspond to droplets, the geometry is modeled in 3D. Due to symmetry, it is sufficient to model only half of the junction geometry. The modeling domain is shown in Figure 4-79. The fluid to be dispersed into small droplets, Fluid 2, enters through the vertical channel. The other fluid, Fluid 1, flows from the right to left through the horizontal channel.

Figure 4-79: The modeling domain of the T-junction.
The problem described is straightforward to set up with the Two-Phase Flow, Laminar, Level Set application mode. The application mode sets up a momentum transport equation, a continuity equation, and a level set equation for the level set variable. The fluid interface is defined by the 0.5 contour of the level set function.

The application mode uses the following equations

\[ \rho \frac{\partial \mathbf{u}}{\partial t} + \rho (\mathbf{u} \cdot \nabla) \mathbf{u} = \nabla \cdot [-p \mathbf{I} + \eta (\nabla \mathbf{u} + (\nabla \mathbf{u})^T)] + \mathbf{F}_{st} \]  

(4-55)

\[ \nabla \cdot \mathbf{u} = 0 \]  

(4-56)

\[ \frac{\partial \phi}{\partial t} + \mathbf{u} \cdot \nabla \phi = \gamma \nabla \cdot \left( -\phi (1-\phi) \frac{\nabla \phi}{|\nabla \phi|} + \varepsilon \nabla \phi \right) \]  

(4-57)

In the equations above, \( \rho \) denotes density (kg/m\(^3\)), \( \mathbf{u} \) velocity (m/s), \( t \) time (s), \( \eta \) dynamic viscosity (Pa·s), \( p \) pressure (Pa), and \( \mathbf{F}_{st} \) the surface tension force (N/m\(^3\)). Furthermore, \( \phi \) is the level set function, and \( \gamma \) and \( \varepsilon \) are numerical stabilization parameters. The density and viscosity are calculated from

\[ \rho = \rho_1 + (\rho_2 - \rho_1) \phi \]

\[ \eta = \eta_1 + (\eta_2 - \eta_1) \phi \]

where \( \rho_1, \rho_2, \eta_1, \) and \( \eta_2 \) are the densities and viscosities of Fluid 1 and Fluid 2.

**Physical Parameters**

The two liquids have the following physical properties:

<table>
<thead>
<tr>
<th>Quantity</th>
<th>Value, Fluid 1</th>
<th>Value, Fluid 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Density (kg/m(^3))</td>
<td>1000</td>
<td>1000</td>
</tr>
<tr>
<td>Dynamic viscosity (Pa·s)</td>
<td>0.00195</td>
<td>0.00671</td>
</tr>
</tbody>
</table>

The surface tension coefficient is 5·10\(^{-3}\) N/m.

**Boundary Conditions**

At both inlets, Laminar inflow conditions with prescribed volume flows are used. At the outflow boundary, the Pressure, no viscous stress condition is set. The Wetted wall boundary condition applies to all solid boundaries with the contact angle specified as 135\(^\circ\) and a slip length equal to the mesh size parameter, \( h \). The contact angle is the angle between the fluid interface and the solid wall at points where the fluid interface
attaches to the wall. The slip length is the distance to the position outside the wall where the extrapolated tangential velocity component is zero (see Figure 4-80).

**Figure 4-80:** The contact angle, $\theta$, and the slip length, $\beta$.

**Results and Discussion**

Figure 4-81 shows the fluid interface (the level set function $\phi = 0.5$) and velocity streamlines at various times. The first droplet is formed after approximately 0.03 s.

**Figure 4-81:** Velocity streamlines, and the phase boundary at $t = 0.02$ s, 0.04 s, 0.06 s, and 0.08 s.
You can calculate the effective diameter, \(d\)—that is, the diameter of a spherical droplet with the same volume as the formed droplet—using the following expression:

\[
d = 2 \cdot \frac{3}{4 \pi} \int_{\Omega} (\phi > 0.5) \, d\Omega
\]

Here, \(\Omega\) represents the leftmost part of the horizontal channel, where \(x < -2 \cdot 10^{-4}\) m. In this case, the results show that \(d\) is about \(1.15 \cdot 10^{-4}\) m. The results are in fair agreement with those presented in Ref. 1.

Reference


Model Library path: MEMS_Module/Microfluidics_Models/droplet_breakup

---

**Modeling Using the Graphical User Interface**

**MODEL NAVIGATOR**

1. In the Model Navigator, select 3D from the Space dimension list.
2. Select MEMS Module>Microfluidics>Two-Phase Flow, Laminar, Level Set.
3. Click OK.

**GEOMETRY MODELING**

1. From the Draw menu, select Work-Plane Settings and click OK.
2. Press Shift and click the Rectangle/Square button on the Draw toolbar.
3. Type in the following values:

<table>
<thead>
<tr>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>BASE, X</th>
<th>BASE, Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>1e-4</td>
<td>4e-4</td>
<td>0</td>
<td>1e-4</td>
</tr>
</tbody>
</table>

4. Click OK.
5. Click the Zoom Extents button on the Main toolbar.
In the same way, create another rectangle with the following settings:

<table>
<thead>
<tr>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>BASE, X</th>
<th>BASE, Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>1e-3</td>
<td>1e-4</td>
<td>-7e-4</td>
<td>0</td>
</tr>
</tbody>
</table>

7. From the Draw menu, select Specify Objects>Line.
8. In the x edit field, type 0 1e-4.
9. In the y edit field, type 2e-4 2e-4.
10. Click OK.
11. Click the Zoom Extents button on the Main toolbar.
12. From the Draw menu, select Extrude.
13. Select all objects in the list by selecting one and then pressing Ctrl+A
14. Type 0.5e-4 in the Distance field.
15. Click OK.

**Options and Settings**

1. From the Options menu, select Constants.
2. Define constants according to the following table. The descriptions are optional.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>rho1</td>
<td>1e3[kg/m^3]</td>
<td>Density, Fluid 1</td>
</tr>
<tr>
<td>eta1</td>
<td>1.95e-3[Pa*s]</td>
<td>Viscosity, Fluid 1</td>
</tr>
<tr>
<td>rho2</td>
<td>1e3[kg/m^3]</td>
<td>Density, Fluid 2</td>
</tr>
<tr>
<td>eta2</td>
<td>6.71e-3[Pa*s]</td>
<td>Viscosity, Fluid 2</td>
</tr>
<tr>
<td>sigma</td>
<td>5e-3[N/m]</td>
<td>Surface tension coefficient</td>
</tr>
</tbody>
</table>

3. Click OK.
4. From the Options menu, select Expressions>Global Expressions.
5. Add the following three expressions:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>ramp</td>
<td>flc1hs(t[1/s]-1e-3,1e-3)</td>
<td>Smooth step function</td>
</tr>
<tr>
<td>V1</td>
<td>0.4e-6/3600*ramp[m^3/s]</td>
<td>Volume flow, inlet 1</td>
</tr>
<tr>
<td>V2</td>
<td>0.2e-6/3600*ramp[m^3/s]</td>
<td>Volume flow, inlet 2</td>
</tr>
</tbody>
</table>

6. Click OK.
PHYSICS SETTINGS

Subdomain Settings

1. Open the Subdomain Settings dialog box for the Two-Phase Flow, Laminar, Level Set application mode, either from the Physics menu, or using the Model Tree.

2. Select all subdomains by selecting one subdomain and then pressing Ctrl+A.

3. Enter the following values in the different edit fields:

<table>
<thead>
<tr>
<th>QUANTITY</th>
<th>VALUE/EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>ρ₁</td>
<td>rho1</td>
</tr>
<tr>
<td>η₁</td>
<td>eta1</td>
</tr>
<tr>
<td>ρ₂</td>
<td>rho2</td>
</tr>
<tr>
<td>η₂</td>
<td>eta2</td>
</tr>
</tbody>
</table>

4. Click the Sources/Sinks tab. In the σ edit field, type sigma.

5. Click the Artificial Stabilization button.

6. In the Artificial Stabilization dialog box, click the Navier-Stokes Equations tab.

7. Select the Streamline diffusion check box and select Anisotropic diffusion from the associated list.

8. Click OK.

9. Click the Level Set tab. In the γ edit field type 0.05, and in the ε edit field type 6.25e-6.

10. Click the Init tab. Select Subdomain 3 only. As Initial fluid in this domain, select Fluid 2.

11. Click OK to close the dialog box.

Boundary Conditions

1. From the Physics menu, select Boundary Settings.

2. Select Boundary 11, then select the Interior boundaries check box. From the Boundary condition list, select Initial fluid interface.

3. Set the conditions on the other boundaries according to the following tables:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 3, 8, 12</th>
<th>BOUNDARY 14</th>
<th>BOUNDARY 18</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary type</td>
<td>Symmetry boundary</td>
<td>Inlet</td>
<td>Inlet</td>
</tr>
<tr>
<td>Boundary condition</td>
<td>Laminar inflow</td>
<td>Laminar inflow</td>
<td>Laminar inflow</td>
</tr>
<tr>
<td>V₀</td>
<td>V2</td>
<td>V1</td>
<td></td>
</tr>
</tbody>
</table>
MESH GENERATION

1. From the Mesh menu, select Mapped Mesh Parameters.
2. Click the Edge tab.
3. Select Edge 6. Select the Constrained edge element distribution check box and type 4 in the Number of edge elements edit field.
4. In the same manner set the Number of edge elements on Edge 8 to 56, on Edge 13 to 8, and on Edge 26 to 16.
5. Click Apply and go to the Boundary tab.
6. While pressing Ctrl, select Boundaries 5, 7, and 16.
7. Click Mesh Selected, then click OK.
8. From the Mesh menu, select Swept Mesh Parameters.
10. Type 8 in the Number of element layers field, and click Mesh selected.
11. Select Subdomain 2 and mesh it, in the same manner, using 8 layers.
12. Select Subdomain 3 and mesh it, in the same manner using 24 layers.
13. Click OK.

Computing the Solution

First you must initialize the level set variable using a suitable time scale. This can be approximated by the expression $\frac{5\varepsilon}{\gamma}$.

1. From the Solve menu, select Get Initial Value.
2 Click the **Plot Parameters** button on the Main toolbar.
3 Click the **Slice** tab.
4 Type $5*\epsilon_{\text{mmglf}}/\gamma_{\text{mmglf}}$ in the **Expression** edit field.
5 Set the number of x levels to 0 and the number of z levels to 1, click **OK**.
6 The plot shows that a suitable time scale for the initialization is $6 \times 10^{-4}$ s.
7 Click the **Solver Parameters** button on the Main toolbar.
8 In the **Times** edit field, type $6e\cdot4$.
9 Click **OK**.
10 Click the **Solve** button on the Main toolbar.
11 Click the **Plot Parameters** button, type $\phi_1$ in the **Expression** edit field, and click **OK**.

The plot shows your initialized level set function. Now continue with the fluid flow calculation.

---

1 From the **Physics** menu, select **Properties** to open the **Application Mode Properties** dialog box.
2 From the **Analysis type** list, select **Transient**. Click **OK**.
3 Click the **Solver Manager** button on the Main toolbar.
4 Click the **Store Solution** button. Select only $6e\cdot4$ in the dialog box that appears, then click **OK**.
5 In the **Initial value** area, click the **Stored solution** button and select $6e\cdot4$ from the **Solution at time** list.
6 Click **OK**.
7 Click the **Solver Parameters** button on the Main toolbar.
8 In the **Times** edit field, type $0:0.5e\cdot2:0.08$, then click **OK**.
9 Click the **Solve** button on the Main toolbar.

---

**Note:** Using a single processor, the solution time is in the order of 15 hours.

---

**POSTPROCESSING AND VISUALIZATION**

1 Click the **Plot Parameters** button on the Main toolbar.
2 On the **Slice** tab, select the **Vector with coordinates** option button in the z-direction, and type $1e\cdot6$ in the corresponding edit field.
3 On the Isosurface tab, select the Isosurface plot check box.
4 Click the Vectors with isolevels button and type 0.5 in the corresponding edit field.
5 Click the Uniform color button and click the Color button.
6 Choose a green color in the Isosurface Color dialog box and click OK.
7 On the Streamline tab, select the Streamline plot check box.
8 Select Velocity field from the Predefined quantities list.
9 From the Streamline plot type list, select Uniform density. In the Separating distance edit field (on the Density tab) type 0.065.
10 Select Tube radius in the Line type list.
11 Click the Tube Radius button to open the Tube Radius Parameters dialog box.
12 Clear the Auto check box for the Radius scaling factor, type 0.6 in the corresponding edit field, and click OK.
13 Click Apply to view the solution.
14 Click the Headlight button in the Plot toolbar.
15 In the Plot Parameters dialog box, go to the Animate page and click the Start Animation button.
16 Click OK to close the Plot Parameters dialog box.

Finally, calculate the droplet diameter:

1 From the Options menu, choose Integration Coupling Variables>Subdomain Variables.
2 Select Subdomain 1 and specify an integration coupling variable with the Name dρpvol and the Expression (φ>0.5)*(x<-2e-4). Click OK.
3 From the Solve menu, select Update Model.
4 From the Postprocessing menu, select Global Variables Plot.
5 Type 2*(3*dρpvol/4/π)^(1/3) in the Expression edit field. Click the Add Entered Expression (> button, then click OK.

The plot shows that the diameter of the droplets is approximately $1.15 \times 10^{-4}$ m.
Models of Piezoelectric Devices

The piezoelectric effect is a transfer of electric energy to mechanical energy and vice versa. It arises in many crystalline materials, and some of them—for example, quartz, Rochelle salt, and lead titanate zirconate ceramics—display the phenomenon strongly enough that it can be useful.

The *direct* piezoelectric effect consists of an electric polarization in a fixed direction when the piezoelectric crystal is deformed. The polarization is proportional to the deformation and causes an electric potential difference over the crystal.

The *inverse* piezoelectric effect, on the other hand, constitutes the opposite of the *direct* effect. This means that an applied electric field induces a deformation of the crystal.

The following models show the application of the MEMS Module for modeling piezoelectric effects:

- An axisymmetric example of a piezoceramic tube that models both the direct and the inverse piezoelectric effect
- A 3D shear bender example modeling the inverse piezoelectric effect
- A 3D model of a composite piezoelectric transducer
• A plane strain model of a thin film bulk acoustic wave composite resonator
• A tunable piezoelectric actuator, modeling the connection to an electric circuit using a SPICE netlist
Piezoceramic Tube

**Introduction**

This example involves a static 2D axisymmetric analysis of a piezoelectric actuator using the 2D Piezo Axial Symmetry application mode. It models a radially polarized piezoelectric tube, as described by S. Peelamedu and others (Ref. 1). A application area where radially polarized tubes are employed is in nozzles for fluid control in inkjet printers.

**Model Definition**

**GEOMETRY**

The tube has a height of 0.62 mm and an inner and outer radius of 0.38 mm and 0.62 mm, respectively.

**MATERIAL**

The material properties for the piezoceramic (PZT-5H) are:

\[
\varepsilon = \begin{bmatrix}
127 & 80.2 & 84.7 & 0 & 0 & 0 \\
127 & 84.7 & 0 & 0 & 0 \\
117 & 0 & 0 & 0 & 0 \\
23.0 & 0 & 0 & 0 & 0 \\
sym & 23.0 & 0 & 0 & 0 \\
23.5 & & & & \\
\end{bmatrix} \text{GPa}
\]

\[
e = \begin{bmatrix}
0 & 0 & 0 & 0 & 17.03448 & 0 \\
0 & 0 & 0 & 17.0345 & 0 & 0 \\
-6.62812 & -6.62812 & 23.24031 & 0 & 0 & 0 \\
\end{bmatrix} \text{C/m}^2
\]

\[
\varepsilon = \begin{bmatrix}
1.5 & 0 & 0 \\
0 & 1.5 & 0 \\
0 & 0 & 1.3 \\
\end{bmatrix} \cdot 10^{-8} \text{F/m}
\]
BOUNDARY CONDITIONS
The model studies two cases, distinguished by the boundary conditions. Case 1 represents the inverse piezoelectric effect, and Case 2 represents the direct piezoelectric effect.

Case 1:
- Structural mechanics boundary condition—constrain the bottom surface from moving axially (in the z-direction).
- Electrostatics boundary condition—apply a 1 V potential difference between the tube’s inner and outer surfaces.

Case 2:
- Structural mechanics boundary condition—constrain the bottom surface from moving axially (in the z direction), but also add an internal fluid pressure of 0.1 MPa.
- Electrostatics boundary condition—ground the inner and outer surfaces.
Results and Discussion

The image in Figure 5-1 shows the deformation due to the applied voltage difference in Case 1. For the same case, Figure 5-2 shows the radial displacement as a function of the tube thickness at the top boundary.

Figure 5-1: Deformed shape and radial displacement of the piezoceramic-tube actuator due to the radial electric field (Case 1).
For the Case 2, Figure 5-3 displays the deformed shape and Figure 5-4 shows the radial displacement as a function of tube thickness. These results show good agreement with those from S. Peelamedu (Ref. 1).
Figure 5-3: Deformed shape and radial displacement due to an internal pressure of 0.1 MPa (Case 2).

Figure 5-4: Radial displacement as a function of tube thickness for Case 2.
Modeling in COMSOL Multiphysics

**CONSTITUTIVE EQUATION AND MATERIAL DATA**

You specify the material parameters for the piezoelectric material in the **Subdomain Settings** dialog box in the piezoelectric application mode. Then select the stress-charge form for the constitutive equation because this suits the form in which you give the material data. Further, enter the elasticity-matrix elements in the $e_e$ matrix, the piezoelectric coupling-matrix elements in the $e$ matrix, and the relative permittivities in the $\varepsilon_r S$ matrix.

You enter the material properties in this example such that the polarization is in the $z$ direction (in a 3D Cartesian coordinate system), which is a common orientation for published material data. This orientation means that you must rotate the material so that its polarization direction is aligned with the $r$ direction (radially polarized). To do so, use the material-orientation feature in the Piezo Axial Symmetry application mode. By selecting the material orientation as the $zx$-plane, you rotate the material so that its $z$ direction is aligned with the $r$ direction of the model, and the material’s $x$ direction is aligned with the model’s $z$ direction.

The piezoceramic material in this example (PZT-5H) is a transversely isotropic material, which is a special class of orthotropic materials. Such a material has the same properties in one plane (isotropic behavior) and different properties in the direction normal to this plane. Thus you can use either the $zx$-plane material orientation or the $zy$-plane material orientation; both give the same solution.

**MESHING**

The rectangular geometry is well suited for quadrilaterals, and the model uses a 6-by-6-element grid.

Reference


Model Library path: MEMS_Module/Piezo_Models/piezoceramic_tube
MODEL NAVIGATOR

1. Start COMSOL Multiphysics. This invokes the Model Navigator, which you can also open from an already running COMSOL Multiphysics session by choosing New from the File menu.

2. Select Axial symmetry (2D) from the Space dimension list.

3. Select MEMS Module>Structural Mechanics>Piezo Axial Symmetry>Static analysis from the list of application modes.

4. Click OK to close the Model Navigator. Note that this gives second-order elements, Lagrange - Quadratic, by default.

GEOMETRY MODELING

Define the model geometry in Draw mode.

1. Shift-click the Rectangle/Square button in the Draw toolbar to open the Rectangle dialog box.

2. Type 0.24e-3 in the Width edit field and 0.62e-3 in the Height edit field. In the Position area, type 0.38e-3 in the r edit field and 0 in the z edit field. This creates a rectangle with opposite corners at (0.38e-3, 0) and (0.62e-3, 0.62e-3). Click OK.
3 Click the **Zoom Extents** button on the Main toolbar.

![Image of a 3D model with a red rectangular region highlighted.](image)

**PHYSICS SETTINGS—MODEL CASE 1**

*Boundary Conditions*

1. Open the **Boundary Settings** dialog box by choosing **Boundary Settings** from the **Physics** menu.
2. From the **Boundary selection** list, select Boundary 2.
3. On the **Constraint** page, select **Roller** from the **Constraint condition** list.
4. Select all boundaries by pressing Ctrl+A.
5. On the **Electric BC** page, select **Zero charge/Symmetry** from the **Boundary condition** list.
6. Select Boundary 1, then select **Ground** from the **Boundary condition** list.
7. Select Boundary 4, then select **Electric potential** from the **Boundary condition** list. Set the **Electric potential** to 1.
8. Click **OK** to close the dialog box.

*Subdomain Settings*

1. Open the **Subdomain Settings** dialog box by selecting **Subdomain Settings** from the **Physics** menu.
2 Select Subdomain 1 and click the Structural tab.

3 From the Material orientation list, select zx plane.

4 Click the Edit button associated with \( c_E \) and enter the following values into the Elasticity matrix dialog box; when done, click OK.

Entries for the elasticity matrix.

\[
\begin{array}{cccccc}
1.27e11 & 8.02e10 & 8.47e10 & 0 & 0 & 0 \\
1.27e11 & 8.47e10 & 0 & 0 & 0 & 0 \\
1.17e11 & 1.74e11 & 0 & 0 & 0 & 0 \\
1.17e11 & 2.30e10 & 0 & 0 & 0 & 0 \\
2.30e10 & 2.30e10 & 0 & 0 & 0 & 0 \\
2.35e10 & 2.35e10 & 0 & 0 & 0 & 0 \\
\end{array}
\]
5 Click the **Edit** button associated with \( \mathbf{e} \) and enter the following values into the **Coupling matrix** dialog box; when done, click **OK**.

```
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th>17.03448</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>17.03448</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>0</td>
<td>0</td>
<td>17.0345</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>-6.62812</td>
<td>-6.62812</td>
<td>23.24031</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>
```

Entries for the coupling matrix.

6 Click the **Edit** button associated with \( \varepsilon_{rS} \) and enter the following values into the **Relative permittivity matrix** dialog box; when done, click **OK**.

```
1694
1694
1468
```

Entries for the relative permittivity matrix.

7 Click **OK** again to close the **Subdomain Settings** dialog box.

**MESH GENERATION**

1 From the **Mesh** menu, choose **Mapped Mesh Parameters**.
2 Click the **Boundary** tab.
3 Select Boundaries 1–4, then click the **Constrained edge element distribution** button.
4. Set the **Number of edge elements** to 6.

![Mapped Mesh Parameters](image1)

5. Click the **Remesh** button.

![Meshed geometry for the piezoceramic-tube actuator](image2)

6. Click **OK**.

**COMPUTING THE SOLUTION**

Click the **Solve** button on the Main toolbar.
POSTPROCESSING AND VISUALIZATION

1. Choose Plot Parameters from the Postprocessing menu to open the Plot Parameters dialog box.

2. On the General page, go to the Plot type area and select the Deformed shape and Surface check boxes.

3. Click the Surface tab.

4. Verify that the selection in the Predefined quantities list is Piezo Axial Symmetry (smpaxi)>r-displacement. From the Unit list, select nm.

5. Click OK to reproduce the plot in Figure 5-1.

6. From the Postprocessing menu, choose Cross-Section Plot Parameters.

7. Click the Line/Extrusion tab.

8. In the y-axis data area, select Piezo Axial Symmetry (smpaxi)>r-displacement from the Predefined quantities list.

9. In the x-axis data area, click first the lower option button and then the Expression button. In the X-Axis Data dialog box, type r in the Expression edit field and select mm from the Unit list. Click OK to close the dialog box.

10. In the Cross-section line data area, set r0 to 3.8e-4, r1 to 6.2e-4, and both z0 and z1 to 3e-4.

11. Click OK to reproduce the plot in Figure 5-2.

PHYSICS SETTINGS—MODEL CASE 2

Boundary Conditions

1. From the Physics menu, select Boundary Settings.

2. Select Boundary 1. On the Load page, type 0.1e6 in the F_r edit field.

3. Select Boundary 4 and then select Ground from the Boundary condition list on the Electric BC page.

4. Click OK to close the dialog box.

COMPUTING THE SOLUTION

Click the Solve button on the Main toolbar.

POSTPROCESSING AND VISUALIZATION

If you followed the postprocessing instructions for Case 1 previously, the plot in the main user interface should reproduce the one in Figure 5-3. If not follow Steps 1–5 in the previous “Postprocessing and Visualization” section.
To reproduce the plot in Figure 5-4, execute the following instructions.

1. From the Postprocessing menu, choose Cross-Section Plot Parameters.
2. Click the Line/Extrusion tab.
3. Verify that the settings from Steps 8–10 on page 464 are still active, then click OK.
Piezoelectric Shear Actuated Beam

Introduction

This example performs a static analysis on a piezoelectric actuator based on the movement of a cantilever beam, using the static 3D Piezo Solid application mode. Inspired by work done by V. Piefort (Ref. 1) and A. Benjeddou (Ref. 2), it models a sandwich beam using the shear mode of the piezoelectric material to deflect the tip.

Model Definition

**Geometry**

The model consists of a sandwiched cantilever beam 100 mm long; it consists of a rigid foam core 2 mm thick sandwiched by two 8-mm thick aluminum layers. Further, the device replaces part of the foam core with a 10-mm long piezoceramic actuator that is positioned between \( z = 55 \) mm and \( z = 65 \) mm (Figure 5-5). The cantilever beam is orientated along the \( x \)-axis.

![Piezoelectric Shear Actuated Beam](image)

*Figure 5-5: In this geometry for the shear bender note that a piezoceramic material replaces part of the foam core.*

**Boundary Conditions**

- The structural mechanics boundary conditions for this model are that the cantilever beam is fixed at its surfaces at \( x = 0 \) and that all other surfaces are free.
- The electrostatic boundary conditions for this model are that the system applies a 20 V potential difference between the top and bottom surfaces of the piezoceramic subdomain. This gives rise to an electric field perpendicular to the poling direction (\( x \)-direction) and thus induces a transverse shear strain.
MATERIAL PROPERTIES

The following table lists the material properties for the aluminum layers and the foam core:

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>ALUMINUM</th>
<th>FOAM</th>
</tr>
</thead>
<tbody>
<tr>
<td>E</td>
<td>70 GPa</td>
<td>35.3 MPa</td>
</tr>
<tr>
<td>ν</td>
<td>0.345</td>
<td>0.383</td>
</tr>
<tr>
<td>ρ</td>
<td>2690 kg/m³</td>
<td>32 kg/m³</td>
</tr>
</tbody>
</table>

The matrices later in the section contain the material properties for the piezoceramic (PZT-5H): $c_E$ is the elasticity matrix, $e$ is the piezoelectric coupling matrix, and $\epsilon$ is the absolute permittivity matrix.

Note that it is necessary to recalculate the absolute permittivity matrix using the permittivity of vacuum $\epsilon_0$ to the relative permittivity matrix.

Note also that the order of the material properties is such that the polarization direction is in the $z$ direction. The polarization direction of the piezoceramic material in this model is however aligned with the $x$-axis and thus a local coordinate system must be used in the material settings to rotate the piezoceramic material.

$$c_E = \begin{bmatrix} 126 & 79.5 & 84.1 & 0 & 0 & 0 \\ 126 & 84.1 & 0 & 0 & 0 \\ 117 & 0 & 0 & 0 & 23.0 \\ 23.0 & 0 & 0 & \text{sym} \\ 23.3 \end{bmatrix} \text{ GPa}$$

$$e = \begin{bmatrix} 0 & 0 & 0 & 0 & 17 & 0 \\ 0 & 0 & 0 & 17 & 0 & 0 \\ -6.5 & -6.5 & 23.3 & 0 & 0 & 0 \end{bmatrix} \text{ C/m}^2$$

$$\epsilon = \begin{bmatrix} 1.503 & 0 & 0 \\ 0 & 1.503 & 0 \\ 0 & 0 & 1.3 \end{bmatrix} \cdot 10^{-8} \text{ F/m}$$
Results

The shear deformation of the piezoceramic core layer and the flexible foam layer induce the bending action. Figure 5-6 shows the resulting tip deflection. The model calculates this deflection as 83 nm, which is in good agreement with the work in Ref. 1 and Ref. 2.

Figure 5-6: Tip deflection with the piezoceramic positioned at z = 60 mm.

Modeling in COMSOL Multiphysics

Constitutive Equation and Material Data

You specify the material parameters for the piezoelectric material in the Subdomain Settings dialog box in the corresponding piezoelectric application mode. You select the stress-charge form for the constitutive equation because it suits the form in which you give the material data. Enter data for the elasticity matrix into the \( c_e \) matrix; enter data for the piezoelectric coupling matrix into the \( e \) matrix; and enter the relative permittivities into the \( \varepsilon_{rs} \) matrix.
You must also define a local coordinate system that is rotated 90 degrees about the $y$-axis. Then use this coordinate system and the piezoelectric material settings in order to rotate the material so that the poling direction is aligned with the $x$-axis.

**MESHING**

The thin central core that holds the piezoelectric actuator and the foam normally creates a relatively dense isotropic mesh. You can avoid this situation by scaling the mesh in the $z$ direction with a factor of three. Doing so reduces the degrees of freedom from approximately 85,000 to 23,000 (by a factor of approximately 3.7) and hence it reduces both the solution time and memory requirements.

**References**


**Model Library path:** MEMS_Module/Piezo_Models/shear_bender

**Modeling Using the Graphical User Interface**

**MODEL NAVIGATOR**

1. Start COMSOL Multiphysics. This invokes the Model Navigator, which you can also open from an already running COMSOL Multiphysics session by choosing New from the File menu.

2. On the New page select 3D from the Space dimension list.

3. Select MEMS Module>Structural Mechanics>Piezo Solid>Static analysis from the list of application modes.

4. Click OK to close the Model Navigator.

Note that this gives you second-order elements, Lagrange - Quadratic, by default.
**GEOMETRY MODELING**

Define the model geometry in draw mode:

1. Draw a block by first clicking the **Block** button on the Draw toolbar and then entering the following parameters in the **Block** dialog box; when done, click **OK**.

<table>
<thead>
<tr>
<th>LENGTH</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>0.1</td>
</tr>
<tr>
<td>Y</td>
<td>0.03</td>
</tr>
<tr>
<td>Z</td>
<td>0.018</td>
</tr>
</tbody>
</table>

2. Draw a second block by clicking the **Block** button and entering the following parameters; when done, click **OK**.

<table>
<thead>
<tr>
<th>LENGTH</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>0.1</td>
</tr>
<tr>
<td>Y</td>
<td>0.03</td>
</tr>
<tr>
<td>Z</td>
<td>0.002</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>AXIS BASE POINT</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>x</td>
<td>0</td>
</tr>
<tr>
<td>y</td>
<td>0</td>
</tr>
<tr>
<td>z</td>
<td>0.008</td>
</tr>
</tbody>
</table>

3. Draw a third block by clicking the **Block** button and entering the following parameters; when done, click **OK**.

<table>
<thead>
<tr>
<th>LENGTH</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>0.01</td>
</tr>
<tr>
<td>Y</td>
<td>0.03</td>
</tr>
<tr>
<td>Z</td>
<td>0.002</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>AXIS BASE POINT</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>x</td>
<td>0.055</td>
</tr>
<tr>
<td>y</td>
<td>0</td>
</tr>
<tr>
<td>z</td>
<td>0.008</td>
</tr>
</tbody>
</table>

4. Click the **Zoom Extents** button on the Main toolbar.
The basic geometry of the shear-actuated beam consisting of three blocks.

**OPTIONS AND SETTING**

1. From the **Options** menu choose **Coordinate Systems**.
2. In the **Coordinate System Settings** dialog box click the **New** button, then click **OK** in the **New Coordinate System** dialog box to use the default coordinate name.
3. Click the **General** tab. Click the **Define using global coordinates** option button, then click the **Rotation angle method** option button.
In the x, y, z rotation angles edit fields type 0, 90, and 0, respectively, then click OK to close the dialog box.

Configuring the coordinate system.

The material properties for the foam and the aluminum are specified in the Materials/Coefficients Library dialog box:

1. From the Options menu choose Materials/Coefficients Library.
2. Click the New button.
3. Change the Name to Aluminum and specify the following set of material parameters:

<table>
<thead>
<tr>
<th>PARAMETER</th>
<th>EXPRESSION/VALUE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>E</td>
<td>70e9</td>
<td>Young's modulus</td>
</tr>
<tr>
<td>nu</td>
<td>0.345</td>
<td>Poisson's ratio</td>
</tr>
<tr>
<td>rho</td>
<td>2690</td>
<td>Density</td>
</tr>
</tbody>
</table>
4 Click **Apply**.

Material property values for aluminum.

5 Click the **New** button.
6 Change the Name to Foam and specify the following set of material parameters:

<table>
<thead>
<tr>
<th>PARAMETER</th>
<th>EXPRESSION/VALUE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>E</td>
<td>35.3e6</td>
<td>Young’s modulus</td>
</tr>
<tr>
<td>nu</td>
<td>0.383</td>
<td>Poisson’s ratio</td>
</tr>
<tr>
<td>rho</td>
<td>32</td>
<td>Density</td>
</tr>
</tbody>
</table>

Material property values for foam.

7 Click OK.

PHYSICS SETTINGS

Subdomain Settings
1 Open the Subdomain Settings dialog box by choosing Subdomain Settings from the Physics menu. Go to the Structural page.
2 Select Subdomains 1 and 3 from the Subdomain selection list.
3 Select Decoupled, isotropic from the Material model list.
4 Select Aluminum from the Library material list; then click Apply.
5 Select Subdomains 2 and 5 from the Subdomain selection list.
6. Select **Decoupled, isotropic** from the Material model list.

7. Select **Foam** from the Library material list; then click **Apply**.


9. Select Coordinate system 1 from the Coordinate system list.

10. Click the **Edit** button associated with $c_E$ and enter the following values into the Elasticity matrix dialog box; when complete, click **OK**.

   Entries for the elasticity matrix:

   $$
   \begin{bmatrix}
   126e9 & 79.5e9 & 84.1e9 & 0 & 0 & 0 \\
   126e9 & 84.1e9 & 0 & 0 & 0 & 0 \\
   117e9 & 0 & 0 & 23e9 & 0 & 0 \\
   23e9 & 0 & 23e9 & 0 & 0 & 0 \\
   \end{bmatrix}
   $$

11. Click the **Edit** button associated with $e$ and enter the following values into the Coupling matrix, stress-charge form dialog box; when complete, click **OK**.

   Entries for the coupling matrix:

   $$
   \begin{bmatrix}
   0 & 0 & 0 & 0 & 17 & 0 \\
   0 & 0 & 0 & 17 & 0 & 0 \\
   -6.5 & -6.5 & 23.3 & 0 & 0 & 0 \\
   \end{bmatrix}
   $$
12 Click the **Edit** button associated with \( \varepsilon_{rs} \) and enter the following values into the *Relative permittivity matrix, stress-charge form* dialog box; when complete, click **OK**.

\[
\begin{array}{ccc}
1698 & 0 & 0 \\
0 & 1698 & 0 \\
0 & 0 & 1468 \\
\end{array}
\]

Entries for the relative permittivity matrix.

13 Click **OK**.

**Boundary Conditions**

1. Open the **Boundary Settings** dialog box by selecting **Boundary Settings** from the **Physics** menu.
2. Activate the **Interior boundaries** check box.
3. Fix the beam by selecting the following boundary condition on the **Constraint** page:

<table>
<thead>
<tr>
<th>SETTING</th>
<th>BOUNDARIES 1, 4, 7</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constraint condition</td>
<td>Fixed</td>
</tr>
</tbody>
</table>

4. Select Boundaries 14–19 from the **Boundary selection** list.
5. Go to the **Electric BC** page and select **Zero charge/Symmetry** from the **Boundary condition** list on the **Electric BC** page.
6. Select Boundary 16 and **Electric potential** from the **Boundary condition** list and enter 20 in the **Electric potential** edit field.
7. Select Boundary 17 and **Ground** from the **Boundary condition** list.
8. Click **OK** to close the dialog box.

**Mesh Generation**

1. From the **Mesh** menu choose **Free Mesh Parameters**.
2. Click the **Advanced** tab.
3. Type 3 in the **z-direction scale factor** edit field.
4. Click **Remesh**, then click **OK**.
POSTPROCESSING AND VISUALIZATION
Before computing the solution change the default plot to display a boundary plot using the deformed shape:

1 From the Postprocessing menu choose Plot Parameters.
2 On the General page clear the Slice check box, then select the Boundary check box and the Deformed shape check box.
3 Click the Boundary tab and select Piezo Solid (smpz3d)>z-displacement from the Predefined quantities list.
4 Click OK.

COMPUTING THE SOLUTION
To start computing the solution, click the Solve button on the Main toolbar.

POSTPROCESSING AND VISUALIZATION, CONTINUED
Figure 5-6 on page 468 shows the resulting plot.
**CHAPTER 5: MODELS OF PIEZOELECTRIC DEVICES**

**Composite Piezoelectric Transducer**

*Introduction*

This example shows how to set up a piezoelectric transducer problem following the work of Y. Kagawa and T. Yamabuchi (Ref. 1). The composite piezoelectric ultrasonic transducer has a cylindrical geometry that consists of a piezoceramic (NEPEC 6) layer, two aluminum layers, and two adhesive layers. The layers are organized as follows: aluminum layer–adhesive layer–piezoceramic layer–adhesive layer–aluminum layer.

The system applies an AC potential on the electrode surfaces of both sides of the piezoceramic layer. The potential in this example has a peak value of 1 V in the frequency range 20 kHz to 106 kHz. The goal is to compute the susceptance (the imaginary part of the admittance) \( Y = \frac{I}{V} \), where \( I \) is the total current and \( V \) is the potential, for a frequency range around the four lowest eigenfrequencies of the structure.

The first step finds the eigenmodes, and the second step runs a frequency sweep across an interval that encompasses the first four eigenfrequencies. Both analyses are fully coupled, and COMSOL Multiphysics assembles and solves both the electric and mechanical parts of the problem simultaneously.

The problem is axially symmetric, and you could analyze it using an axisymmetric application mode in 2D. However, in order to illustrate the modeling principles for more complicated problems, this example is in 3D.

When creating the model geometry, you make use of the symmetry by first making a cut along a midplane perpendicular to the central axis and then cutting out a 10 degree wedge; doing so reduces memory requirements significantly.
Results

Figure 5-7 shows the input admittance in the transducer as a function of the excitation frequency.

![Graph showing input admittance vs excitation frequency]

The result is in agreement with the work in Ref. 1. A small discrepancy close to the eigenfrequencies appears because the simulation uses no damping.

Reference


Model Library path: MEMS_Module/Piezo_Models/composite_transducer
CHAPTER 5: MODELS OF PIEZOELECTRIC DEVICES

MODEL NAVIGATOR
1 Open the Model Navigator and click the New tab. From the Space dimension list select 3D.
2 In the list of application modes select MEMS Module>Structural Mechanics>Piezo Solid>Eigenfrequency analysis.
3 Click OK.

GEOMETRY MODELING
1 From the Draw menu, choose Work-Plane Settings.
2 This model uses the default work plane at \( z = 0 \), so simply click OK. Doing so creates the work plane and opens a 2D drawing area.
3 Click the Ellipse/Circle (Centered) button on the Draw toolbar. Use the right mouse button to create a circle centered on the origin and with a radius of approximately 1 (the exact size is not important).
4 Double-click the circle. In the Radius edit field, enter \( 27.5 \cdot 10^{-3} \). Click OK.
5 Click the Zoom Extents button on the Main toolbar.
6 Click the Line button on the Draw toolbar. Draw a line from \((0, 0)\) to \((0.03, 0)\). Use the right mouse button to finish drawing lines.
7 Copy and paste the line onto itself with no displacements (either use Ctrl+C and Ctrl+V or use the Edit menu items).
8 Click the Rotate button on the Draw toolbar. In the Rotation angle edit field enter 10. Click OK.
9 Press Ctrl+A to select all objects.
10 Click the Coerce to Solid button on the Draw toolbar.
11 Click the Split Object button on the Draw toolbar.
12 Select the larger object and press the Delete key.
13 Click the **Zoom Extents** button on the Main toolbar.

Geometry for the composite piezoelectric transducer.

**MESH GENERATION**

This model uses prism elements by extruding a triangular mesh.

1. Click the **Initialize Mesh** button on the Main toolbar.
2. From the **Mesh** menu, select **Extrude Mesh**.
3. In the **Distance** edit field, enter `5e-3 5.275e-3 15.275e-3` (being careful to separate the entries with a space). Click **OK**. This step extrudes a mesh with three
domains corresponding to the piezoceramic (Subdomain 1), the adhesive layer (Subdomain 2), and the aluminum layer (Subdomain 3).

Extruding the mesh to create three subdomains.

The finalized mesh with the three subdomains.
**OPTIONS AND SETTINGS**

1. From the **Options** menu, select **Materials/Coefficients Library**.
2. Click **New**.
3. Change the **Name** to **Adhesive**.
4. Enter the following material properties; when done, click **Apply**.

<table>
<thead>
<tr>
<th>PARAMETER</th>
<th>EXPRESSION/VALUE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>E</td>
<td>1e10</td>
<td>Young’s modulus</td>
</tr>
<tr>
<td>nu</td>
<td>0.38</td>
<td>Poisson’s ratio</td>
</tr>
<tr>
<td>rho</td>
<td>1700</td>
<td>Density</td>
</tr>
</tbody>
</table>

5. Click the **New** button.
6. Change the name to **Aluminum2**.
7. Enter the following material properties; when done, click **OK**.

<table>
<thead>
<tr>
<th>PARAMETER</th>
<th>EXPRESSION/VALUE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>E</td>
<td>7.03e10</td>
<td>Young’s modulus</td>
</tr>
<tr>
<td>nu</td>
<td>0.345</td>
<td>Poisson’s ratio</td>
</tr>
<tr>
<td>rho</td>
<td>2690</td>
<td>Density</td>
</tr>
</tbody>
</table>
Material values to enter for the aluminum.

**PHYSICS SETTINGS**

**Subdomain Settings**

1. From the Physics menu, select Subdomain Settings.
2. Select Subdomain 1.
3. On the Structural page, verify that the Material model list has the value Piezoelectric. In the Density edit field, type 7730.
4 Click the **Edit** button associated with \( c_E \). In the **Elasticity matrix** dialog box, enter the following values; when finished, click **OK**.

![Elasticity matrix](image)

Entries for the elasticity matrix.

5 Click the **Edit** button associated with \( e \). In the **Coupling matrix** dialog box, enter the following values; when finished, click **OK**.

```
0 0 0 0 0
0 0 0 0 0
-6.1 -6.1 15.7 0 0
```

Entries for the coupling matrix.

6 Click the **Edit** button associated with \( \varepsilon_{rS} \). In the **Relative permittivity** dialog box, enter the following values; when finished, click **OK**.

```
993.53 0
993.53 0
993.53 0
```

Entries for the relative permittivity matrix.

7 Select Subdomains 2 and 3.

8 From the **Material model** list, select **Decoupled, isotropic**.

9 Select Subdomain 2. From the **Library material** list, select **Adhesive**.
10 Select Subdomain 3. From the Library material list, select Aluminium2.

11 Click OK.

Boundary Conditions
The total potential difference between the two electrodes (only one modeled here) is 1 V, but symmetry dictates that the potential is 0 V on the symmetry plane and 0.5 V on the electrode.

1 From the Physics menu, choose Boundary Settings.

2 Select the Interior boundaries check box.

3 Click in the Boundary selection list and then press Ctrl+A to select all boundaries.

4 Click the Electric BC tab. In the Boundary condition list, select Zero charge/Symmetry.

5 Select Boundary 6.

6 In the Boundary condition list, select Electric potential. Set $V_0$ to 0.5.

7 Select Boundary 3.

8 In the Boundary condition list, select Ground.

9 Click the Constraint tab.

10 Select Boundaries 1–5, 7, and 8.

11 From the Constraint condition list, select Symmetry plane.

The outer boundary is free to move, so you do not set any constraints.

12 Click OK.

Computing the Eigenfrequency Solution
Click the Solve button on the Main toolbar.

Postprocessing and Visualization of the Eigenfrequencies
The lowest eigenfrequency is at approximately 43 kHz.

1 To visualize the solution of the lowest eigenfrequency, open the Plot Parameters dialog box from the Postprocessing menu.

2 On the General page, clear the Slice check box.

3 On the Boundary page, select the Boundary plot check box. From the Predefined quantities list, select Piezo Solid (smpz3d)>z-displacement.

4 On the Deform page, select the Deformed shape plot check box. Verify that Piezo Solid (smpz3d)>Displacement is selected in the Predefined quantities list.
5 Click **OK** to generate the visualization where you can see that the lowest eigenfrequency is at approximately 43 kHz.

![Visualization of the lowest eigenfrequency for the piezoelectric transducer.](image)

**COMPUTING THE FREQUENCY RESPONSE SOLUTION**

Next sweep over a frequency range from 20 kHz to 106 kHz in steps of 2 kHz.

1. From the **Physics** menu, select **Properties**.
2. In the **Analysis types** area, select **Frequency response**. Click **OK**.
3. From the **Solve** menu, select **Solver Parameters**.
4. On the **General** page, verify that the **Parameter name** edit field shows `freq_smpz3d`.
5. In the **Parameter values** edit field, type `20e3:2e3:106e3`. Click **OK**.
6. Click the **Solve** button on the Main toolbar.

**POSTPROCESSING AND VISUALIZATION OF THE FREQUENCY RESPONSE**

To compute the input admittance, use the current-density outflow variable, $nJ$, on the electrode surface. The total input current for the 10-degree wedge is then the surface integral of $-\text{imag}(nJ)$ over one of the electrode surfaces. To obtain the total current for the entire structure, multiply the result by $\frac{360}{10} = 36$.

1. From the **Options** menu, select **Integration Coupling Variables>Boundary Variables**.
2 Select Boundary 6 (corresponding to the electrode surface).

3 On the top row, enter I as the name of the integration variable, then in the Expression column enter -imag(nJ_smpz3d)*36. Click OK.

4 From the Solve menu, select Update Model.

The coupling variable I has global scope, and you can access it anywhere in the geometry model (the mesh). Use a domain plot to plot the value of Y versus frequency.

1 From the Postprocessing menu, select Domain Plot Parameters.

2 Click the Point tab. From the Point selection list, choose a point on the electrode surface (for this exercise, select Point 2).

3 In the Expression edit field enter \( \frac{I}{2V} \). Click OK to close the dialog box and plot the susceptance.

![Plot of susceptance versus frequency for the piezoelectric transducer.](image)

Recall that this example uses 0.5 V for the electrode potential but the overall potential difference is 1 V. Thus, to take symmetry into account, multiply the potential by 2.
Thin Film BAW Composite Resonator

Introduction

Bulk Acoustic Wave (BAW) resonators can be used as narrow band filters in radio-frequency applications. The chief advantage compared with traditional ceramic electromagnetic resonators is that BAW resonators, thanks to the acoustic wavelength being much smaller than the electromagnetic wavelength, can be made much smaller.

In addition to the desired bulk acoustic mode, the resonator structure may have many spurious modes with very narrow spacing. The design goal is usually to maximize the quality of the main component and to reduce the effect of spurious modes.

This example shows how you can model thin film BAW resonators in 2D using eigenfrequency and frequency response analysis. The considered geometry is the same as in Ref. 1 and Ref. 2.

Figure 5-8: Geometry of a thin film BAW resonator, arbitrarily scaled.
Model Definition

Figure 5-8 shows the geometry of the resonator from Ref. 1, which is modeled in this example. The lowest layer of the resonator is silicon. On top of that, there is an aluminum layer, which operates as the ground electrode. The next layer is the active piezoelectric layer, made of zinc oxide (ZnO). On top of the resonator there is another aluminum electrode.

A block of silicon has been removed from the center of the resonator. Thus the thickness of the stacked resonator structure at the active center area is very small, making this resonator a thin film composite BAW resonator.

The thickness of the silicon layer at the central area is 7 µm. Both aluminium layers are 200 nm thick, and the piezoelectric layer is 9.5 µm thick. The width of the rectangular top electrode is 500 µm. The thin silicon area is roughly 1.7 mm wide.

The model geometry (Figure 5-9) is a symmetric 1-mm section in the center of the geometry. In the frequency response version we apply PML domains outside the truncation boundaries, to effectively increase the length of the resonator.

This example is modeled in 2D, using the plane strain assumption.

![Figure 5-9: The 2D geometry used in the example.](image-url)
This example consists of two steps. First you compute and investigate the eigenmodes of a 950 µm wide structure, with its ends fixed. In the second step you analyze the frequency response of the resonator. For this analysis, you extend the geometry by 25 µm wide perfectly matched layer (PML) domains at both ends. You also estimate the losses in the piezoelectric material using complex material parameters, which you supply as structural and dielectric loss factors.

In the frequency response analysis, evaluate the admittance of the resonator as

\[ Y(\omega) = \frac{J_{ns}}{V_0}, \]  

where \( J_{ns} \) is the current through the top electrode and \( V_0 \) the applied potential at the electrode, and the quality of the resonator using

\[ Q(\omega) = \frac{\omega W_{es, tot}}{Q_{es, tot}}, \]  

where \( \omega \) is the angular frequency, \( W_{es, tot} \) is the peak stored energy, and \( Q_{es, tot} \) is the time average power dissipation. \( Q_{es, tot} \) consists of two components: the power dissipation in the piezoelectric material and the mechanical power outflow into the PML domains. You can get the power outflow from the integral of the time-averaged normal mechanical energy flux \( I_n = n \cdot I_{av} \) where \( n \) is the outward pointing normal and \( I_{av} \) the time-averaged mechanical energy flux vector:

\[ I_{av} = -\frac{1}{2} \text{real}(\sigma \text{conj}v) \]  

Here \( \sigma \) is the stress matrix and \( v \) is the velocity vector.

With the exception of loss factors, all material parameters used in this model are taken directly from the MEMS Module material library. Ref. 3 gives material quality \( Q_m \) and dielectric loss tangent \( \tan \delta \) for many materials. The magnitude of \( Q_m \) is roughly 100–1000, and the magnitude of \( \tan \delta \) is roughly 0.001–0.01. Based on that data, the following values are used:

- Structural loss factor: \( \eta_{eE} = 1/Q_m = 0.001 \)
- Dielectric loss factor: \( \eta_{eS} = \tan \delta = 0.01 \)
Results and Discussion

Figure 5-10 shows the lowest BAW mode of the structure, at 0.221 GHz. This is the fundamental longitudinal thickness mode. Due to the finite extent of the structure, and the constraints on the sides, this mode also has a small Lamb wave component. This is visible mostly near the ends, as seen in Figure 5-11.

Figure 5-10: The lowest bulk acoustic mode of the resonator.
Figure 5-11: The lowest bulk acoustic mode of the resonator, zoomed to the left end of the resonator.
From the frequency response analysis, Figure 5-12 shows a graph of the admittance as a function of the frequency. Throughout the investigated range, from 0.215 GHz to 0.235 GHz, the admittance is very similar to that computed in Ref. 2. Note that the peak frequency coincides with the eigenfrequency of the lowest BAW mode, 0.221 GHz.
Figure 5-13 shows the quality factor as a function of the frequency. The value at 0.221 GHz is around 1300, which is not far from the global maximum.

Figure 5-13: Quality of the resonator.

Figure 5-14, finally, shows the resonator at the frequency of maximum admittance. The distribution of the displacements resembles that of the lowest BAW mode, confirming that this mode is properly excited.
CHAPTER 5: MODELS OF PIEZOELECTRIC DEVICES

Figure 5-14: Bulk acoustic vibration of the resonator at the frequency of maximum admittance.

**Modeling in COMSOL Multiphysics**

The eigenfrequency analysis in this model is set up in the Piezo Plane Strain application mode of the MEMS Module.

In the frequency response analysis, a Plane Strain application mode without piezoelectricity is added, in order to enable PMLs. This application mode is active only in the PML subdomains, while the Piezo Plane Strain application mode is kept active in all other subdomains. The solution will automatically be continuous across the boundaries between these two application modes. Note that because the PMLs are designed for structural waves, there can be slight reflections due to the piezoelectric component. They are however expected to give significantly better results than leaving the side boundaries without termination.

The Piezo Plane Strain application mode automatically calculates the power dissipation in the piezoelectric material and the quality factor given this power dissipation. To include the mechanical power outflow into the PML domains, you need to add this to the expression for the total power dissipation. This mechanical power outflow, as well
as the current for the admittance calculation, is evaluated using a boundary integration coupling variable.

References


Model Library path: MEMS_Module/Piezo_Models/thin_film_baw_resonator_eig

Model Library path: MEMS_Module/Piezo_Models/thin_film_baw_resonator_freq

Modeling Using the Graphical User Interface—Eigenfrequency

First initialize the model for the eigenfrequency analysis.

1. In the Model Navigator, make sure that 2D is selected from the Space dimension list.

2. From the Application modes tree select MEMS Module>Structural Mechanics>Piezo Plane Strain>Eigenfrequency analysis.

3. Click OK.

GEOMETRY MODELING

Using the following steps create the geometry for the eigenfrequency analysis:

1. Double-click on the EQUAL button at the bottom of the main user interface; this will make it easier to work with the very thin geometry.
2. Shift-click the **Rectangle/Square** button on the Draw toolbar to define the first rectangle, R1, in the following table; when done, click **OK**. Similarly define the other three rectangles:

<table>
<thead>
<tr>
<th>RECTANGLE NAME:</th>
<th>R1</th>
<th>R2</th>
<th>R3</th>
<th>R4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>950e-6</td>
<td>950e-6</td>
<td>950e-6</td>
<td>500e-6</td>
</tr>
<tr>
<td>Height</td>
<td>7e-6</td>
<td>0.2e-6</td>
<td>9.5e-6</td>
<td>0.2e-6</td>
</tr>
<tr>
<td>Base</td>
<td>Corner</td>
<td>Corner</td>
<td>Corner</td>
<td>Corner</td>
</tr>
<tr>
<td>x</td>
<td>-475e-6</td>
<td>-475e-6</td>
<td>-475e-6</td>
<td>-250e-6</td>
</tr>
<tr>
<td>y</td>
<td>-7e-6</td>
<td>0</td>
<td>0.2e-6</td>
<td>9.7e-6</td>
</tr>
</tbody>
</table>

3. Click the **Zoom Extents** button on the Draw toolbar to show the geometry.

![Geometry Diagram](image)

**PHYSICS SETTINGS**

*Subdomain Settings*

1. From the **Physics** menu, select **Subdomain Settings**.
2. Select Subdomain 1.
3. Click the **Load** button to open the **Materials/Coefficients Library** dialog box.
4. From the Materials tree, select MEMS Material Properties>Semiconductors>Silicon (single-crystal). Click OK.

5. From the Material model list, select Decoupled, anisotropic.

6. In the Thickness edit field, type 1.7[mm].

7. Select Subdomain 2.

8. Click the Load button to open the Materials/Coefficients Library dialog box.

9. From the Materials tree, select MEMS Material Properties>Metals>Al. Click OK.

10. From the Material model list, select Decoupled, isotropic.

11. In the Thickness edit field, type 1.7[mm].

12. Select Subdomain 3.

13. Click the Load button to open the Materials/Coefficients Library dialog box.

14. From the Materials tree, select Piezoelectric Material Properties>Zinc Oxide. Click OK.

15. In the Thickness edit field, type 1.7[mm].


17. From the Library material list, select Al.

18. From the Material model list, select Decoupled, isotropic.

19. In the Thickness edit field, type 1.7[mm].

20. Click OK to close the Subdomain Settings window.

Boundary Conditions

1. From the Physics menu, select Boundary Settings.

2. Select the Interior boundaries check box.


4. Go to the Electric BC page and set the Boundary condition to Ground.

5. Select Boundary 9.

6. From the Boundary condition list, select Electric potential. Set $V_0$ to 1[V].

7. Click OK to close the Boundary Settings dialog box.

Mesh Generation

1. From the Mesh menu, select Mapped Mesh Parameters.

2. Click the Boundary tab.

3. Select Boundary 2. Activate Constrained edge element distribution, then set the Number of edge elements to 200.
4 Select Boundary 1. Activate **Constrained edge element distribution**, then set the **Number of edge elements** to 2.

5 Select Boundary 5. Activate **Constrained edge element distribution**, then set the **Number of edge elements** to 3.

6 Click **Remesh**, then click **OK**.

7 Click **OK** to close the dialog box.

---

**COMPUTING THE SOLUTION**

1 From the **Solve** menu, select **Solver Parameters**.

2 In the **Solver Parameters** dialog box, verify that both the **Analysis types** and **Solver** lists have **Eigenfrequency** selected.

3 In the **Desired number of eigenfrequencies** edit field, type 50.

4 In the **Search for eigenfrequencies around** edit field, type 220e6.

5 Click **OK** to close the **Solver Parameters** dialog box.

6 Click the **Solve** button on the Main toolbar.
**POSTPROCESSING AND VISUALIZATION**

1. Double-click the **EQUAL** button at the bottom of the main user interface to see the postprocessing plot in true scale.

2. From the **Postprocessing** menu, select **Plot Parameters**.

3. On the **General** page, select the **Surface**, **Deformed shape**, and **Geometry edges** check boxes in the **Plot type** area.

4. In the **Solution to use** area, select a frequency from the **Eigenfrequency** list.

5. Click **Apply** to see the solution at the frequency you selected.

Most of the modes are spurious, and the plot looks strange due to the automatic scaling defined on the **Deform** page. The lowest BAW mode should appear close to eigenfrequency $2.214 \times 10^8$ Hz (see Figure 5-10 on page 492).

6. Zoom to the left end of the resonator side and observe that the wavelength of the wave near the end is roughly 15 $\mu$m–25 $\mu$m (see Figure 5-11 on page 493).

---

**Modeling Using the Graphical User Interface—Frequency Response**

This part is a direct continuation of the instructions above, and the instructions below assume that you have followed all the steps above.

To use PML feature in the model, add a Plane Stress application mode to the model:

1. From the **Multiphysics** menu, select **Model Navigator**.

2. In the **Application Modes** tree select **MEMS Module>Structural Mechanics>Plane Strain>Frequency response analysis**.

3. Click **Add**, then click **OK**.

---

**GEOMETRY MODELING**

Using the following steps to extend the geometry with additional PML domains:

1. Click the **Draw Mode** button on the Main toolbar.

2. Double-click the **EQUAL** button at the bottom of the main user interface, then click the **Zoom Extents** button on the Main toolbar.

3. Click on the rectangle R1, then Shift-click on R2 and R3 to select those three geometry objects.

4. Press Ctrl+C to copy and then Ctrl+V to paste the objects. In the dialog box that appears, leave the **Displacement** values at zero and click **OK**.

5. With the pasted objects (R5, R6, R7) selected, click the **Scale** button.
6 Go to the **Scale factor** area and in the x edit field type 10/9. Click **OK**.

7 Click the **Zoom Extents** button on the Main toolbar.

---

**OPTIONS AND SETTINGS**

Using the following steps edit the Zinc Oxide material parameters in such a way that you can model PML in a material whose stiffness matrix is the same as the \( c_E \) matrix of ZnO:

1 From the **Options** menu, select **Materials/Coefficients Library**.

2 In the **Materials** tree, select **Model(3)>Zinc Oxide (mat3)**.

3 Go to the **Elastic** page and locate the field \( \text{Delastic2D} \).

4 Type in the following data, which is the left-top part of the \( c_E \) matrix (you can also copy the 10 first values from \( c_E \) edit field located on the **Piezoelectric** page):

<table>
<thead>
<tr>
<th>2.09714e11</th>
<th>1.2114e11</th>
<th>1.05359e11</th>
<th>0</th>
</tr>
</thead>
<tbody>
<tr>
<td>2.09714e11</td>
<td>1.05359e11</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>2.11194e11</td>
<td>0</td>
<td>4.23729e10</td>
<td></td>
</tr>
</tbody>
</table>

5 Click **OK**.
Next create boundary level integration variables to calculate admittance and the power loss into the PML domains:

1. From the Options menu, select Integration Coupling Variables>Boundary Variables.
2. Select Boundary 16. On the first table row, enter the following data:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>INTEGRATION ORDER</th>
<th>GLOBAL DESTINATION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Y</td>
<td>0.5[mm]*nJs_smppn/1[V]</td>
<td>4</td>
<td>Yes</td>
</tr>
</tbody>
</table>

3. Select Boundaries 8, 10, 12, 20, 22, and 24. On the second row, enter the following data:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>INTEGRATION ORDER</th>
<th>GLOBAL DESTINATION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Q_pml</td>
<td>nIav_smppn*1.7[mm]</td>
<td>4</td>
<td>Yes</td>
</tr>
</tbody>
</table>

4. Click OK.

**PHYSICS SETTINGS—PIEZO PLANE STRAIN**

Properties

Change the piezo mode to use frequency response analysis:

1. From the Multiphysics menu, select 1 Piezo Plane Strain (smppn).
2. From the Physics menu, select Properties.
3. From the Analysis type list, select Frequency response, then click OK.

Subdomain Settings

1. From the Physics menu, select Subdomain Settings.
2. Select Subdomains 1–3 and 8–10. Clear the Active in this domain check box.
3. Select Subdomain 6 and go to the Damping page.
4. From the Structural damping list select Isotropic loss. Type 0.001 in the $\eta_{\varepsilon}$ edit field.
5. From the Dielectric loss list select Isotropic loss. Type 0.01 in the $\eta_{E}$ edit field.
6. Click OK.

**PHYSICS SETTINGS—PLANE STRAIN**

Subdomain Settings

1. From the Multiphysics menu, select 2 Plane Strain (smppn).
2. From the Physics menu, select Subdomain Settings.
Select Subdomains 4–7. Clear the Active in this domain check box.

Select Subdomains 1 and 8. From the Library material list, select Silicon (single-crystal).

From the Material model list, select Anisotropic.

In the Thickness edit field, type 1.7 [mm].

Select Subdomains 2 and 9, then select Al from the Library material list.

In the Thickness edit field, type 1.7 [mm].

Select Subdomains 3 and 10. From the Library material list, select Zinc Oxide.

From the Material model list, select Anisotropic.

In the Thickness edit field, type 1.7 [mm].

Select Subdomains 1–3 and 8–10. Click the PML tab.

In the Type of PML list, select Cartesian.

Select the Absorbing in x-direction check box, then set the PML scaling exponent to 2.

Click OK.

Boundary Conditions

From the Physics menu, select Boundary Settings.

Select Boundaries 1, 3, 5, and 27–29.

From the Constraint condition list, select Fixed.

Mesh Generation

From the Mesh menu, select Mapped Mesh Parameters.

Go to the Boundaries page. Select Boundaries 2 and 21.

Select the Constrained edge element distribution check box, then set the Number of edge elements to 10.

Click Remesh.
5 When the mesher has finished, click **OK**.

**COMPUTING THE SOLUTION**

First define that the frequency variables in the two application modes contain the same frequency. Also define that the total power dissipation contains the PML loss.

1. From the **Physics** menu, select **Scalar Variables**.
2. Enter `freq` as the **Expression** for both `freq_smppn` and `freq_smppn`.
3. In the **Expression** edit field for `Qtot_smppn`, type `Qes_tot_smppn+Q_pml`.
4. Click **OK**.

Proceed to define solver settings for the frequency response analysis.

1. From the **Solve** menu, select **Solver Parameters**.
2. In the **Solver Parameters** dialog box, verify that the selection in the **Analysis types** area is **Frequency response** and that the **Solver** is **Parametric**.
3. In the **Parameter names** edit field, type `freq`.
4. In the **Parameter values** edit field, type `215e6:0.1e6:235e6`.
5. Click **OK** to close the dialog box.
6. Click the **Solve** button on the Main toolbar.
POSTPROCESSING AND VISUALIZATION

1. Double-click the EQUAL button at the bottom of the user interface to see the postprocessing plot in its true scale.

2. From the Postprocessing menu, select Domain Plot Parameters.

3. On the Point page, select Point 1.

4. In the Expression edit field, type abs(Y). Click Apply.

5. In the dialog box that appears, click the y log button to see the absolute value of admittance in a logarithmic scale (see Figure 5-12 on page 494). The maximum admittance should be near 2.215·10^8 Hz.

6. From the Predefined quantities list, select Electromechanical quality factor.

7. Click OK to reproduce the plot in Figure 5-13 on page 495.

8. From the Postprocessing menu, select Plot Parameters.

9. On the General page, under Solution to use, select the frequency of maximum admittance from the Parameter value list.

10. Click OK.

The generated image is shown in Figure 5-14 on page 496.

11. Again, zoom to the left end of the resonator side and observe how the vibration vanishes rapidly in the PML domain.
**Tunable Piezoelectric Actuator**

This model analyzes a piezoelectric device connected to an external circuit.

**Introduction**

A piezoelectric device can actuate a cantilever beam simply by applying an AC voltage over the device. The cantilever beam itself has resonant modes that causes peaks in the vibration when the frequency of the applied voltage passes the resonance frequency of each mode. If another piezoelectric device is attached to the cantilever, it is possible to tune the resonance by connecting that device to a passive external circuit. This model investigates how the external circuit influence the resonance peaks of the cantilever beam.

**Model Definition**

The actuator consists of a thin bar of silicon with an active piezoelectric device below the bar, and a second passive piezoelectric device on top. These devices are located at one end of the actuator (see Figure 5-15 below).

![Figure 5-15: A piezoelectric actuator with an active piezoelectric device below and a passive piezoelectric device above the silicon bar.](image)

The piezoelectric material is lead zirconate titanate (PZT), and each of the devices has two electrical connections to an external circuit, realized with the Floating potential boundary condition of the Piezo Plane Strain application mode.

The following listing contains the SPICE netlist for the external circuit:

```
* RL circuit with voltage source
.FREQ 10Hz
R0 0 1 1MEG
R1 1 2 1k
L1 2 3 50mH
```
Vapp 0 4 100V
X1 1 3 4 0 Piezo

.SUBCKT Piezo sens1 sens2 appl gnd COMSOL: *
.ENS

The statements beginning with an R represents resistances, L represents inductances, and V represents voltage sources. The statement that begins with an X is an instantiation of a subcircuit, which is defined in the .SUBCKT statement. This particular subcircuit statement provides the link to the current COMSOL Multiphysics model because it has the option COMSOL: *. The name of the subcircuit is Piezo and it connects to the four Floating potential boundary conditions named sens1, sens2, appl, and gnd. This means that the X-statement that uses this subcircuit has four nodes and ends by specifying the name of the subcircuit, Piezo. The two first nodes, 1 and 3, are connected to the floating potential terminals sens1 and sens2. These nodes are part of the passive external circuit that contains the inductor L1 and the resistor R1 in series. The resistor R0 is only present to get a voltage reference for the external circuit. The nodes 4 and 0 are connected to the floating potential terminals appl and gnd. In the circuit they are connected to the 100 V voltage source Vappl, which drives the actuator. Because the analysis type is frequency response, this voltage source supplies an AC voltage.

Results and Discussion

The analysis of the actuator is performed through a frequency sweep that goes from 200 kHz up to 1 MHz while logging the displacement amplitude in the y-direction. As shown in Figure 5-16 on page 509, the vibration shows several resonance peaks in this range. The external inductance for this sweep was 50 mH.
Figure 5-16: The amplitude of the horizontal displacement as a function of frequency.

It is not obvious from the plot how the external circuit affects the vibration. Therefore a second sweep is performed using a higher inductance value of 60 mH. By inspecting Figure 5-17 on page 510, it is clear that the peak around 660 kHz is affected by the change in inductance. The inductance causes a sharp spike in the spectrum that moves toward lower frequencies when the inductance increases.
Figure 5-17: A comparison between the amplitude versus frequency for two inductance values in the external circuit, 50mH (blue curve) and 60mH (red curve).

The spike is caused by a resonance between the capacitance of the piezoelectric device and the inductance of the external circuit. The resonant frequency for a LC-circuit is

$$f = \frac{1}{\sqrt{LC}}$$

Because the values for L and f are known, it is possible to roughly estimate the capacitance of the piezoelectric device

$$C = \frac{1}{L f^2} = \frac{1}{60 \text{ mH} \cdot (660 \text{ kHz})^2} = 40 \text{ pF}$$

**Model Library path:** MEMS_Module/Piezo_Models/

tunable_piezoelectric_actuator
Modeling Using the Graphical User Interface

**MODEL NAVIGATOR**
1. Select the application mode **MEMS Module>Structural Mechanics>Piezo Plane Strain**.
2. Click **OK** to close the **Model Navigator**.

**GEOMETRY MODELING**
1. From the **Draw** menu, use **Specify Object>Rectangle** to create three rectangles with the following dimensions.

<table>
<thead>
<tr>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>X</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>2.5e-5</td>
<td>2e-6</td>
<td>7e-6</td>
<td>8e-7</td>
</tr>
<tr>
<td>0.3e-3</td>
<td>8e-7</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>2.5e-5</td>
<td>2e-6</td>
<td>7e-6</td>
<td>-2e-6</td>
</tr>
</tbody>
</table>

2. Click the **Zoom Extents** button on the Main toolbar to see the geometry.

**PHYSICS SETTINGS**

*Subdomain Settings*
1. Go to the **Physics** menu and choose **Subdomain Settings**.
2. In the **Subdomain Settings** dialog box, select Subdomain 1, and click the **Load** button.
3. In the **Materials/Coefficients Library** dialog box, select the material **MEMS Material Properties>Silicon (single-crystal)**.
4. Click **OK**.
5. From the **Material model** list, choose **Decoupled, isotropic**.
6. In the **thickness** edit field, type 1 [mm].
7. Select Subdomains 2 and 3, then click the **Load** button.
8. In the **Materials/Coefficients Library** dialog box, select the material **Piezoelectric Material Properties>Lead Zirconate Titanate (PZT-5A)**.
9. Click **OK**.
10. For the **Material orientation**, choose **zx plane**.
11. In the **thickness** edit field, type 1 [mm].
12. Click **OK**.

*Boundary Settings*
1. From the **Physics** menu, choose **Boundary Settings**.
2 In the Boundary Settings dialog box, select Boundary 1 and choose Fixed from the Constraint condition list.


4 From the Boundary condition list, choose Floating potential and type appl in the Group index edit field.

5 In the same way, set the following boundaries to floating potential with the specified index:

<table>
<thead>
<tr>
<th>BOUNDARY</th>
<th>GROUP INDEX</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>gnd</td>
</tr>
<tr>
<td>7</td>
<td>sens1</td>
</tr>
<tr>
<td>12</td>
<td>sens2</td>
</tr>
</tbody>
</table>

6 Click OK.

SPICE Circuit Editor

1 From the Physics menu, choose SPICE Circuit Editor.

2 In the SPICE Circuit Editor dialog box, enter the following netlist in the Netlist text area:

```
* RL circuit with voltage source
.FREQ 10Hz
R0 0 1 1MEG
R1 1 2 1k
L1 2 3 50mH
Vapp 0 4 100V
X1 1 3 4 0 Piezo

.SUBCKT Piezo sens1 sens2 appl gnd COMSOL: *
.ENDS
```

As an alternative to writing the text manually, you can open a prepared circuit file called rl_circuit.cir located in the Model Library path of this model. To load that file, click the Load Netlist from File button on the toolbar, locate the file, and click Import in the dialog box that appears.
3 Select the **Force AC analysis** check box, then click **OK**.

![Diagram](image.png)

**Scalar Variables**
1 From the **Physics** menu, choose **Scalar Variables**.
2 In the **Application Scalar Variables** dialog box, change the value of the `freq_smppn` variable to `freq_cir`.
3 Click **OK**.

**MESH PARAMETERS**
1 From the **Mesh** menu choose **Mapped Mesh Parameters**.
2 Go to the **Boundary** page and select Boundaries 1, 4, and 7.
3 Select the **Constrained edge element distribution** check box and type 2 in the **Number of edge segments** edit field.
4 Select Boundaries 5 and 9, then set the number of edge segments to 10 in same way as in the previous step.
5 Finally, set the number of edge segments to 50 for Boundaries 11 and 13.
6 Click **OK**.
7 Click the **Mesh All (Mapped)** button on the Mesh toolbar.
**Computing the Solution**

*Probe Plot Parameters*

Probe plotting is a convenient technique to plot while solving, which is very useful for parameter sweeps. It is possible to discover problems before the solution step has finished, and then stop the sweep to save time.

1. From the *Postprocessing* menu, choose *Probe Plot Parameters*.

2. In the *Probe Plot Parameters* dialog box, click the *New* button.

3. In the *New Probe Plot* dialog box, choose *Point probe* from the *Plot type* list. Type *Displacement* in the *Plot name* edit field and click *OK*.

4. Select Point 12 at the right end of the bar.

5. From the *Predefined quantities* list, choose *Piezo Plane Strain (smppn)>Disp. amplitude y-dir*.

6. Click the *Title/Axis* button.

7. In the dialog box that appears, select the *Log scale* check box for the second axis and click *OK*.

8. Click *OK* to close the *Probe Plot Parameters* dialog box.

*Solver Parameters*

1. From the *Solve* menu, select *Solver Parameters*.

2. In the *Solver Parameters* dialog box, select *Parametric* in the *Solver* area.

3. Type *freq_cir* in the *Parameter names* edit field and *linspace(2e5,1e6,100)* in the *Parameter values* edit field. This tells the solver to perform a linear sweep from 200 kHz up to 1 MHz in 100 steps.

4. Click *OK*.

5. Click the *Solve* button on the Main toolbar.

**Postprocessing and Visualization**

The probe plot shows the amplitude of the vertical displacement at the end of the cantilever. This plot gets copied to a new figure window when the parameter sweep has finished, which is the plot shown in Figure 5-16 on page 509.

1. From the *Postprocessing* menu, choose *Plot Parameters*.

2. In the *Plot Parameters* dialog box, click the *Deform* check box.

3. Click *OK* to see the following plot.
CHANGING THE INDUCTANCE

This section investigates how the frequency sweep changes if you change the value of the inductance.

1. From the Options menu, choose Constants.
2. In the Constants dialog box, locate the constant with name sim_L1_value and change its value to 60[mH].
3. Click OK to close the Constants dialog box.
4. Run the sweep again by clicking the Solve button.

When the sweep has completed you again get the probe plot in a new figure. To see the two plots in the same figure you perform the following steps.

1. From the Postprocessing menu, open the Domain Plot Parameters dialog box.
2. On the General page, select the Keep current plot check box and choose Figure 1 from the Plot in list.
3. Click the Title/Axis button. In the dialog box that appears you select the Log scale check box for the second axis. Click OK to close the dialog box.
4. Go to the Point page and select Point 12.
5 From the Predefined quantities list, choose Disp. amplitude y-dir.

6 Click the Line Settings button. In the dialog box that appears, choose Color from the Line color list. Click OK to close the dialog box.

7 Click OK to get the plot shown in Figure 5-17 on page 510.
INDEX

A  AC electric field 222
   AC electrokinetically adjusted fluid flow 220
   accelerometer 130, 161
   actuator models
      cantilever beam 8
      capacitive comb drive 50
      comb drive 34
   list of 2
      micromirror 67
      resonator 79
   admittance 478
   adsorption rate 226
   ALE method 8, 35, 273
   application mode
      Incompressible Navier Stokes 320
      arbitrary Lagrangian-Eulerian method 8, 35, 273

B  binding rate 225
   binding reaction 225
   biochips 301
   boundary integration 324
   breakup of droplets 441

C  Cahn-Hilliard equation 372, 394, 431
   cantilever beam 8, 67, 79, 131, 466
   capacitance
      displaying 180
      of a pressure sensor 165
      versus ambient pressure 170
   capacitive comb drive 50
   capillary channel 392
   capillary forces 392
   comb drive 34, 50
   composite piezoelectric transducer 478
   contact angle 397
   coordinate system
      fixed 273
      moving 273

D  deforming geometry 273
   dialog box
      Materials/Coefficients Library 484
   diffuse double layer 301
   direct piezoelectric effect 451
   DNA Chip 301
   droplet breakup 441

E  electric double layer 329
   electric double layers 314
   electrokinetics 220
   electroosmotic flow 301, 314, 329
   electroosmotic micromixer 328
   electroosmotic micropumps 314
   electroosmotic mobility 315
   electrophoretic flow 302
   electrostatic force 35
   electrostatically actuated comb drive 34
   electrothermal force 221, 222
   excitation frequency 479
   extruding a mesh 74

F  Fick's law 358
   fluid-structure interaction 273, 429
   frequency response 478
   frequency sweep 478

G  gecko foot model 60
   gyroscope 145

H  Helmholtz-Smoluchowski equation 330
   high aspect ratio elements 67

I  Incompressible Navier Stokes application mode 320
   incompressible Navier-Stokes equations
<table>
<thead>
<tr>
<th>Page</th>
<th>Index</th>
</tr>
</thead>
<tbody>
<tr>
<td>221</td>
<td>initial stress 67, 75, 162</td>
</tr>
<tr>
<td></td>
<td>inkjet model 370</td>
</tr>
<tr>
<td></td>
<td>interdigitated transducer 190</td>
</tr>
<tr>
<td></td>
<td>inverse piezoelectric effect 451</td>
</tr>
<tr>
<td>J</td>
<td>Joule heating 220, 223</td>
</tr>
<tr>
<td>L</td>
<td>lab-on-a-chip devices 343</td>
</tr>
<tr>
<td></td>
<td>lamella mixer 286</td>
</tr>
<tr>
<td></td>
<td>laminar fluid flow 275</td>
</tr>
<tr>
<td></td>
<td>large deformations 36, 81</td>
</tr>
<tr>
<td></td>
<td>level set function 371</td>
</tr>
<tr>
<td></td>
<td>level set method 371, 393</td>
</tr>
<tr>
<td></td>
<td>lift-off</td>
</tr>
<tr>
<td></td>
<td>of a prestressed plated device 67</td>
</tr>
<tr>
<td>M</td>
<td>mapped mesh 74</td>
</tr>
<tr>
<td></td>
<td>materials library</td>
</tr>
<tr>
<td></td>
<td>examples of using 484</td>
</tr>
<tr>
<td></td>
<td>Materials/Coefficients Library dialog box 484</td>
</tr>
<tr>
<td></td>
<td>MEMS gyroscope 145</td>
</tr>
<tr>
<td></td>
<td>MEMS resonators 112</td>
</tr>
<tr>
<td></td>
<td>meniscus 398</td>
</tr>
<tr>
<td></td>
<td>mesh</td>
</tr>
<tr>
<td></td>
<td>extruding 67, 74</td>
</tr>
<tr>
<td></td>
<td>mapping 67, 74</td>
</tr>
<tr>
<td></td>
<td>mesh parameters</td>
</tr>
<tr>
<td></td>
<td>scale factor 476</td>
</tr>
<tr>
<td></td>
<td>microfluidics models</td>
</tr>
<tr>
<td></td>
<td>AC electrokinetically adjusted fluid flow 220</td>
</tr>
<tr>
<td></td>
<td>electroosmotic flow in a biochip 301</td>
</tr>
<tr>
<td></td>
<td>electroosmotic micromixer 328</td>
</tr>
<tr>
<td></td>
<td>electroosmotic micropump 314</td>
</tr>
<tr>
<td></td>
<td>fluid-structure interaction 273</td>
</tr>
<tr>
<td></td>
<td>lamella mixer 286</td>
</tr>
<tr>
<td></td>
<td>list of 4</td>
</tr>
<tr>
<td></td>
<td>transport in an electrokinetic valve 249</td>
</tr>
<tr>
<td></td>
<td>micromirror 67</td>
</tr>
<tr>
<td></td>
<td>micromixer 328</td>
</tr>
<tr>
<td></td>
<td>micropumps 314</td>
</tr>
<tr>
<td></td>
<td>migration 250</td>
</tr>
<tr>
<td></td>
<td>Model Library, models in 2</td>
</tr>
<tr>
<td></td>
<td>moving boundaries 273</td>
</tr>
<tr>
<td>N</td>
<td>Navier-Stokes equations 252, 275, 303, 329</td>
</tr>
<tr>
<td></td>
<td>with surface tension 373, 395</td>
</tr>
<tr>
<td></td>
<td>NEPEC 6 478</td>
</tr>
<tr>
<td></td>
<td>Nernst-Planck 252</td>
</tr>
<tr>
<td></td>
<td>Nernst-Planck equation 252</td>
</tr>
<tr>
<td>P</td>
<td>parametric solver 67</td>
</tr>
<tr>
<td></td>
<td>phase field method 372, 394</td>
</tr>
<tr>
<td></td>
<td>piezoceramic 453</td>
</tr>
<tr>
<td></td>
<td>piezoceramic actuator 466</td>
</tr>
<tr>
<td></td>
<td>piezoceramic layer 478</td>
</tr>
<tr>
<td></td>
<td>piezoceramic tube 453</td>
</tr>
<tr>
<td></td>
<td>piezoelectric actuator 453</td>
</tr>
<tr>
<td></td>
<td>piezoelectric effects 451</td>
</tr>
<tr>
<td></td>
<td>piezoelectricity models 451</td>
</tr>
<tr>
<td></td>
<td>composite piezoelectric transducer 478</td>
</tr>
<tr>
<td></td>
<td>list of 5</td>
</tr>
<tr>
<td></td>
<td>piezoceramic tube 453</td>
</tr>
<tr>
<td></td>
<td>shear actuated piezo beam 466</td>
</tr>
<tr>
<td></td>
<td>tunable piezoelectric actuator 507</td>
</tr>
<tr>
<td></td>
<td>plate modulus 14</td>
</tr>
<tr>
<td></td>
<td>polarization 458</td>
</tr>
<tr>
<td></td>
<td>postprocessing</td>
</tr>
<tr>
<td></td>
<td>boundary integration 324</td>
</tr>
<tr>
<td></td>
<td>pressure sensor 161, 162</td>
</tr>
<tr>
<td></td>
<td>prestressed structure 67</td>
</tr>
<tr>
<td></td>
<td>pull-in voltage 11, 14</td>
</tr>
<tr>
<td></td>
<td>PZT-5H 453, 467</td>
</tr>
<tr>
<td>Q</td>
<td>Q factor 147</td>
</tr>
<tr>
<td></td>
<td>Q-value 112</td>
</tr>
</tbody>
</table>
R  reaction surface 225
  residual stress 79
  resonance frequency 79, 130
  resonator 79
  Reynolds equation 130
  Reynolds number 276
S  sandwiched cantilever beam 466
  SAW gas sensor 190
  scaled mesh 476
  sensor models
    accelerometer 130, 161
    list of 3
    pressure sensor 161
  shear actuated piezo beam 466
  slide film damping 145
  SPICE netlist 507
  spring constants 80
  spring structures 35, 67, 80
  squeezed film gas damping 130
  Stoke's flow 316
  stress-strain relation 79, 165
  Subdomain Settings dialog box 474
  supporting electrolyte 251
  surface acoustic waves 190
  surface reactions 220
  surface tension 392
  susceptance 478
T  thermal expansion 165
  thermal relaxation 112
  thermal stress 79
  thermoelastic damping 112
  thermoelastic friction 112
  transducer 478
  transversely isotropic material 458
  tunable piezoelectric actuator 507
  typographical conventions 6
U  ultrasonic transducer 478

INDEX | 519