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 1
I n t r o d u c t i o n
The Heat Transfer Module Model Library  consists of a set of models that 
simulate problems in various areas of heat transfer and other engineering disciplines 
where heat transfer plays an important role. Their purpose is to assist you in 
learning, by example, how to model sophisticated heat transfer processes. Through 
them you can tap the expertise of the top researchers in the field, examining how 
they approach some of the most difficult modeling problems you might encounter. 
You can thus get a feel for the power that COMSOL Multiphysics® offers as a 
modeling tool. In addition to serving as a reference, the models can also give you 
a big head start if you are developing a model of a similar nature.

This book divides these models into three chapters: 

• Electronics and power systems

• Process and manufacturing

• Medical technology

The models illustrate the application modes specific to the Heat Transfer Module, 
application modes unavailable in the base COMSOL Multiphysics package. These 
application modes come with their own graphical user interfaces that make it quick 
and easy to access their power. You can even modify them for custom requirements. 
COMSOL Multiphysics itself is very powerful and, with sufficient expertise in a 
 1



2 |  C H A P T E R  1
given field, you certainly could develop these modes by yourself—but why spend the 
hundreds or thousands of hours that would be necessary when our team of experts has 
already done the work for you?

Note that the model descriptions in this book do not contain every detail on how to 
carry out every step in the modeling process. Before tackling these in-depth models, 
we urge you to first read the other book in the Heat Transfer Module documentation 
set. Titled the Heat Transfer Module User’s Guide, it introduces you to the basic 
functionality in the module, covers basic modeling techniques, and includes reference 
material of interest to those working with problems involving heat transfer. The 
models it presents are far simpler than those in this Model Library and might be more 
appropriate for a first introduction to COMSOL Multiphysics.

In addition, to gain further information on how to work with the graphical user 
interface you can turn to the COMSOL Multiphysics User’s Guide or the COMSOL 
Multiphysics Quick Start and Quick Reference manual. An explanation on how to 
perform modeling with a programming language is available in the COMSOL 
Multiphysics Scripting Guide.

This Heat Transfer Module Model Library provides details about a large number of 
ready-to-run models that illustrate real-world uses of the software. Each entry comes 
with theoretical background as well as instructions that illustrate how to set it up. They 
come from our staff engineers, who have years of experience in heat transfer modeling. 
The terminology in the book should be familiar to you.

Finally, each example in the Heat Transfer Module Model Library as well as in the 
Heat Transfer Module User’s Guide  comes with the software as a loadable COMSOL 
Multiphysics Model MPH-file (with the extension .mph). To find these files, start the 
Model Navigator, click the Model Library tab and then look under the chapter headings 
listed earlier. These models are great to investigate if you are sufficiently familiar with 
COMSOL Multiphysics and its GUI but would like to learn more about how to set up 
a certain model. You can even use these entries as a starting point for your own models 
that are similar in nature.

Model Library Guide

The following table summarizes key information about the entries in this model 
library. The “Application Modes” column indicates which modes we chose to solve the 
model, and the subsequent column indicates the number of spatial dimensions in the 
model. 
:  I N T R O D U C T I O N
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 AND POWER SYSTEMS

 Cooling of Circuit 
ced 3D Model

10 General Heat Transfer, 
Weakly Compressible 
Navier-Stokes

3D 6 min  √  √  √

 Cooling of Circuit 
ural 2D Model

10 General Heat Transfer, 
Weakly Compressible 
Navier-Stokes

2D 20 s  √  √  √

 Cooling of Circuit 
ural 3D Model

10 General Heat Transfer, 
Weakly Compressible 
Navier-Stokes

3D 4 min  √  √  √

 Cooling of Circuit 
plified 1D Model

31 General Heat Transfer 1D 1 s  √  √  √

 Cooling of Circuit 
plified 3D Model

31 General Heat Transfer 3D 6 s  √  √

ulent Convection 43 General Heat Transfer, 
k-ε Turbulence Model

2D 16 min  √  √  √

ulent Convection 
plified Model

43 General Heat Transfer 2D 1 s  √  √

unt Resistor 63 General Heat Transfer, 
Solid Stress-Strain

3D 2 min  √  √

ction in a Light 78 General Heat Transfer 
Weakly Compressible 
Navier-Stokes,

2D-axi 6 min  √  √  √  √
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Microchann  √

Microchann
Resistance

 √

Heat Transf
Surface-Mou
Silicon Chip

 √

Rapid Therm

Thermo-Ph

Convective 
Potcore Ind

 √

Temperatur
Disc-Type T

 √

PROCESS AND

Heat Gener
Brake

Convection
Patties

 √

Continuous  √

Cooling Flan

Friction Stir

MODEL

O
U

T
-O

F
-P

L
A

N
E

H
IG

H
L

Y
 C

O
N

D
U

C
T

IV
E

 L
A

Y
E

R

M
U

LT
IP

H
Y

S
IC

S

cuit 91 General Heat Transfer, 
Thin Conductive Shell, 
Solid Stress-Strain, Shell

3D 4 min  √  √

el Heat Sink 107 General Heat Transfer, 
Weakly Compressible 
Navier-Stokes

3D 2 min  √  √  √

el Heat Sink, 107 General Heat Transfer, 
Weakly Compressible 
Navier-Stokes

3D 2 min  √  √  √

er in a 
nt Package for a 

123 General Heat Transfer 3D 1 s  √  √

al Annealing 135 General Heat Transfer 3D 9 s  √  √  √

oto-Voltaic Cell 144 General Heat Transfer 2D 2 min  √  √  √

Cooling of a 
uctor

160 General Heat Transfer, 
Weakly Compressible 
Navier-Stokes

2D axi 2 min  √  √  √  √

e Distribution in a 
ransformer

169 General Heat Transfer, 
Weakly Compressible 
Navier-Stokes

2D axi 2 min  √  √  √

 MANUFACTURING

ation in a Disc 184 General Heat Transfer; 
Weak Form, Point

3D 2 min  √  √  √  √

 Cooking of Chicken 197 General Heat Transfer, 
Diffusion

2D axi 2 s  √  √

 Casting 234 General Heat Transfer, 
Weakly Compressible 
Navier-Stokes

2D axi 2 min  √  √  √

ge 209 General Heat Transfer 3D 41 s  √  √

 Welding 223 General Heat Transfer 3D 37 s  √  √  √  √
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Fluid-Struct
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 √  √

MEDICAL TEC

Microwave  √

Tumor Rem  √

TUTORIAL MO
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Copper Lay  √

Copper Lay
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low Through a 
be Heat Exchanger

248 General Heat Transfer, 
k-ω Turbulence Model

2D 2 min  √  √

ure Interaction in 
xtrusion†‡

262 General Heat Transfer; 
Non-Newtonian Flow; 
Solid, Stress-Strain

3D 30 min  √  √  √

HNOLOGY

Cancer Therapy 278 Bioheat Equation, TM 
Waves

3D 17 s  √  √

oval 291 Bioheat Equation, 
Conductive Media DC

3D 38 s  √  √

DELS

 a Cavity 131* General Heat Transfer 2D 4 s  √  √  √

er on Silica Glass 142* General Heat Transfer 2D 1 s  √  √

er on Silica Glass, 142* General Heat Transfer 2D 3 s  √  √

 in a Cylinder 87* General Heat Transfer 2D 1 s  √  √

nt Ventilations 248* General Heat Transfer, 
k-ε Turbulence Model

3D 100 min √ √ √

nger 91* General Heat Transfer 3D 7 s  √  √  √

nger, Nonisothermal 91* General Heat Transfer, 
Weakly Compressible 
Navier-Stokes

3D 2 min  √  √  √

e 231* General Heat Transfer, 
Weakly Compressible 
Navier-Stokes

2D 3 min  √  √  √

ction 163* Thin Conductive Shell 3D 1 s  √  √

nvection Cooling in 
 Heat Transfer 
Model

109* General Heat Transfer 2D axi 1 s  √  √
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 * This page number refers to the Heat Transfer Module User’s Guide. 
 † This model requires the Chemical Engineering Module and the Structural 
Mechanics Module. 
 ‡ This model uses the Material Library.

We welcome any questions, comments or suggestions you might have concerning 
these models. Contact us at info@comsol.com.

Typographical Conventions

All COMSOL manuals use a set of consistent typographical conventions that should 
make it easy for you to follow the discussion, realize what you can expect to see on the 
screen, and know which data you must enter into various data-entry fields. In 
particular, you should be aware of these conventions:

• A boldface font of the shown size and style indicates that the given word(s) appear 
exactly that way on the COMSOL graphical user interface (for toolbar buttons in 
the corresponding tooltip). For instance, we often refer to the Model Navigator, 
which is the window that appears when you start a new modeling session in 
COMSOL; the corresponding window on the screen has the title Model Navigator. 
As another example, the instructions might say to click the Multiphysics button, and 
the boldface font indicates that you can expect to see a button with that exact label 
on the COMSOL user interface.

• The names of other items on the graphical user interface that do not have direct 
labels contain a leading uppercase letter. For instance, we often refer to the Draw 
toolbar; this vertical bar containing many icons appears on the left side of the user 

nvection Cooling in 
Laminar Flow 

109* General Heat Transfer, 
Weakly Compressible 
Navier-Stokes

2D axi 34 s  √  √  √

D Model 146* General Heat Transfer 2D 1 s  √  √  √

D Model 146* General Heat Transfer 3D 3 s  √  √  √

PAGE APPLICATION MODES

S
P

A
T

IA
L

 D
IM

E
N

S
IO

N
S

S
O

L
U

T
IO

N
 T

IM
E

S
T

A
T

IC

T
IM

E
 D

E
P

E
N

D
E

N
T

C
O

N
D

U
C

T
IO

N

C
O

N
V

E
C

T
IO

N

R
A

D
IA

T
IO

N

:  I N T R O D U C T I O N



interface during geometry modeling. However, nowhere on the screen will you see 
the term “Draw” referring to this toolbar (if it were on the screen, we would print 
it in this manual as the Draw menu).

• The symbol > indicates a menu item or an item in a folder in the Model Navigator. 
For example, Physics>Equation System>Subdomain Settings is equivalent to: On the 
Physics menu, point to Equation System and then click Subdomain Settings. 
COMSOL Multiphysics>Heat Transfer>Conduction means: Open the COMSOL 

Multiphysics folder, open the Heat Transfer folder, and select Conduction.

• A Code (monospace) font indicates keyboard entries in the user interface. You might 
see an instruction such as “Type 1.25 in the Current density edit field.” The 
monospace font also indicates COMSOL Script codes.

• An italic font indicates the introduction of important terminology. Expect to find 
an explanation in the same paragraph or in the Glossary. The names of books in the 
COMSOL documentation set also appear using an italic font.
 |  7
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E l e c t r o n i c s  a n d  P o w e r - S y s t e m  M o d e l s
This chapter contains models of heat transfer in application such as electronic 
cooling and power systems.
 9
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Con v e c t i o n  Coo l i n g  o f  C i r c u i t  Boa r d s

Introduction

This discussion models the air cooling of circuit boards populated with multiple 
integrated circuits (ICs), which act as heat sources. It provides two examples as 
depicted in Figure 2-1: vertically aligned boards using natural convection, and 
horizontal boards with forced convection (fan cooling). Convective contributions 
caused by the induced (forced) flow of air dominate the cooling. To achieve high 
accuracy, the simulation models heat transport in combination with the fluid flow.

Figure 2-1: Stacked circuit boards with multiple in-line heat sources. Line A represents the 
center line of the row of ICs, and the area between lines A-B on the board represents the 
symmetry.

A good technique is to describe convective heat flux with a film-resistance coefficient, 
h. The heat-transfer equations then become simple to solve. However, this 
simplification requires that the coefficient be well determined. Many systems and 
conditions suffer from a lack of detailed knowledge of  h, making accurate calculations 
of convective heat transfer difficult.

Instead of simplifying the equations, an alternative way to thoroughly describe the 
convective heat transfer is to model the heat transfer in combination with the fluid-flow 
field. The results then accurately describe the heat transport and temperature changes. 
From such simulations it is also possible to derive accurate estimations of the film 

A
B

Natural convection cooling Forced convection cooling
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coefficients. Such models are somewhat more complex but they are useful for unusual 
geometries and complex systems such as circuit-board cooling.

The following examples model the heat transfer of a circuit-board assembly using two 
application modes: General Heat Transfer and Weakly Compressible Navier-Stokes. 
The modeled scenario is based on work published by A. Ortega (Ref. 1), and this 
discussion also compares model results with Ortega’s experimental results. The first 
example simulates natural convection cooling of a vertical circuit board as depicted in 
Figure 2-1.

It is a good idea to first set up a 2D model for the case of natural convection. The 
geometry is the cross section, from the board’s back side to the next board’s back side, 
through the center of a row of ICs (as indicated by line A in Figure 2-1). Next create 
a 3D model for the same case. Due to symmetry, it is sufficient to model a unit cell, 
from the back side of a board to the next back side, covering the area between lines A 
and B in Figure 2-1. Figure 2-2 depicts the two geometries for the case of natural 
convection.

Figure 2-2: The modeled geometries in 2D (a) and 3D (b).

The dimensions of the original geometry are: 

• Board: length (in the flow direction) 0.13 m, and the thickness is 0.002 m

• ICs: length and width are both 0.02 m, and thickness is 0.002 m

• The distance of air between the boards is 0.010 m

For the forced-convection case, set up the 3D model by rotating the geometry of 
Figure 2-2 (b) so that the boards are aligned horizontally.

(b)(a)
C O N V E C T I O N  C O O L I N G  O F  C I R C U I T  B O A R D S  |  11
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Model Definition

The model makes use of two stationary application modes to simulate the problem: 
General Heat Transfer and Weakly Compressible Navier-Stokes. 

The Weakly Compressible Navier-Stokes, describes the fluid velocity, u, and the 
pressure, p as

Due to heating of the fluid, deviations occur in the local density, ρ, compared to the 
inlet density, ρ0. This results in a local buoyancy force expressed as (ρ − ρ0) g. The 
model also treats the viscosity, η, as temperature dependent.

The General Heat Transfer application mode is based on the general energy balance

where k represents thermal conductivity; Cp is the specific heat capacity; and Q is the 
heating power per unit volume, set to 1.25 MW/m3 (1 W/component) for the 3D 
cases. For the 2D cases, you should set it to 2/3 of that value to represent the lateral 
average heating power (that is, taking into account the open slots between the ICs). 
The material properties appear in Table 2-1.

The model treats properties for air as temperature dependent according to the 
following equations (Ref. 3):

with p0 = 101.3 kPa, Mw = 0.0288 kg/mol, and R = 8.314 J/(mol·K). Further,

TABLE 2-1:  MATERIAL PROPERTIES

MATERIAL PROPERTY HEAT SOURCE (SILICON) CIRCUIT BOARD (FR4; REF. 2)

ρ (kg/m3) 2330 1900

Cp (J/(kg·K)) 703 1369

k (W/(m·K)) 163 0.30

ρu ∇⋅ u ∇ pI– η ∇u ∇u( )T
+( ) 2η 3⁄ κ–( ) ∇ u⋅( )I–+[ ]⋅ ρ ρ0–( )g+=

∇ ρu( )⋅ 0=

∇ k∇T–( )⋅ Q ρ CPu ∇T⋅–=

ρ p p+ 0( )Mw RT( )⁄=

Cp 1100 J/(kg·K)=

k 10
3.723 + – 0.865log10 T( )

 W/(m·K)=
 2 :  E L E C T R O N I C S  A N D  P O W E R - S Y S T E M  M O D E L S



where T must be expressed in kelvin. 

Specify the boundary conditions for the flow inlet as boundary-normal flow with a 
known velocity field. For the natural-convection models, set the inlet velocity to zero. 
For the forced-convection cases, set up an inlet-velocity profile, uy, that is uniform in 
the (horizontal) x direction and parabolic (similar to a fully developed laminar profile) 
in the (vertical) z direction. In terms of an equation this reads

where  parameterizes the height above the board and umax, the 
maximal inlet speed, equals 1 m/s. At the outlet all the models use the normal flow, 
zero pressure boundary condition. In addition, they apply no-slip conditions at the 
surfaces of the board and the ICs. At the inlet boundary then fix the temperature to 
300 K (room temperature). At the outlet the models use purely convective heat flux. 
You should also set the lateral boundaries periodic with respect to temperature, making 
the temperatures equal on both boundaries at every y value. Finally, the models apply 
continuity of temperature and heat flux at all interior boundaries.

η 6.0 10 6–⋅ 4.0 10 8– T   Pa·s⋅+=

uy 4 z̃ 1 z̃–( ) u– max( )=

z̃ z 0.010 m⁄=
C O N V E C T I O N  C O O L I N G  O F  C I R C U I T  B O A R D S  |  13
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Results and Discussion

N A T U R A L  C O N V E C T I O N

Figure 2-3: Temperature distribution for the 2D model. 

The results of the 2D model (Figure 2-3) show that the temperature of the ICs (the 
heat sources) increases considerably under a heating load of 1 W/component. Note 
that the temperature increase of the sources varies from 30 K for the lowest IC up to 
almost 90 K at the top IC. This is a result of the thermal “footprint” of the heat 
sources. Another interesting result is that the circuit board contributes a large amount 
of cooling power on its back side, although the thermal conductivity is quite small. 
This is apparent in the result plots as a temperature rise in the fluid at the right-hand 
boundary (that is, the back side of the next board in the stack).

The fluid flow in the 3D problem is a bit more complex to solve because of the 
increased number of mesh nodes necessary to resolve the flow and heat transport 
fields. The results (Figure 2-4) show that the temperature increase at the hottest spot 
 2 :  E L E C T R O N I C S  A N D  P O W E R - S Y S T E M  M O D E L S



of each component is approximately two degrees higher for the 3D case than for the 
2D case. 

Figure 2-4: Temperature distribution for the 3D model.

In addition, the temperature difference among the various ICs is smaller in the 3D 
model, which predicts a more uniform temperature rise of the ICs. The ICs have an 
operating temperature between 70 K and 80 K above ambient. This result is probably 
closer to reality compared to the 2D simulation because it also includes the horizontal 
gaps between the ICs. The difference in temperature rise along the board’s height is 
explained primarily by the fluid-flow pattern.

Figure 2-5 plots the fluid velocity for both the 2D and 3D models. The maximum fluid 
velocity is slightly higher in the 3D case than in the 2D case. More importantly, the 
flow field behaves differently in the two cases. When comparing Figure 2-5 (a) and (b), 
C O N V E C T I O N  C O O L I N G  O F  C I R C U I T  B O A R D S  |  15
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note that the velocity fields are rather similar along the center line of the heat sources. 
However, there is a channeling effect from the horizontal gaps.

Figure 2-5: Fluid-velocity distribution for the 2D model (a) and the 3D model (b).

(a)

(b)
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F O R C E D  C O N V E C T I O N — H O R I Z O N T A L  B O A R D S

This model includes a forced fluid inlet velocity that represents the situation when a 
fan cools the ICs. As Figure 2-6 shows, the temperature rise in the ICs is approximately 
20 K to 35 K smaller compared to the natural-convection case due to the higher 
average fluid velocity. In the forced-convection case, the temperature difference along 
the board is also less pronounced than for the natural convection case.

Figure 2-6: Temperature distribution in the case of forced convection cooling of horizontal 
boards.

Another interesting result, visible in Figure 2-7, is that the channeling effect of the gap 
causes a reduction in the fluid’s flow rate above the sources. The cooling of the ICs is 
therefore somewhat reduced compared to an ideal case with an even flow field.
C O N V E C T I O N  C O O L I N G  O F  C I R C U I T  B O A R D S  |  17
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Figure 2-7: Velocity distribution for the case of forced convection.

From the simulation results you can also determine the effective convection heat 
transfer film coefficient, h. Calculate it by integrating the heat flux across the fluid 
boundary of the source objects. Then divide that value with the temperature difference 
between that of the fluid at the surface and the inlet temperature. Put in terms of an 
equation this reads

where Ω1 is the source surface, Ω2 is the fluid cross section, qi is the heat flux, while 
Tf,0 and Ts,i represent the inlet fluid temperature and the surface temperature of 
source  i, respectively. Thus, the value of h varies between the rows of the sources due 
to thermal footprints from upstream heat sources.

In the case of forced convection, it is common to use the adiabatic film resistance, had. 
Its definition is similar to h except it uses Tcup instead of Tf,0. Tcup is the cross-section 
average of the fluid temperature, Tf, upstream of each source, defined as

hi
1

Ω1
------- qidΩ1∫⎝ ⎠
⎛ ⎞ 1

Ω2
------- Ts,i Tf,0–( )dΩ2∫⎝ ⎠
⎛ ⎞ 1–

=
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Figure 2-8 compares the calculated values of h and had for the convection cases with 
experimentally achieved values using similar geometries.

Figure 2-8: Comparison of experimentally measured film resistances, h (asterisks, solid 
line), for natural convection (Ref. 1) with those calculated from the 2D model (squares, 
dash-dot line) and the 3D model (triangles, dashed line).

The deviation from the experimental values for the natural convection might stem 
from differences in the geometry (which is not fully defined in Ref. 1). 

In the forced-convection case you can compare the achieved results with experimental 
results by calculating the Nusselt number, Nu. It follows from:

where  L in this case is the length of the heat source (20 mm). The calculated Nusselt 
numbers for the 2D model decrease from 16 to 11 between rows 1 and 4. These values 
agree well with the experimentally measured ones for similar geometries, being in the 
range of 15 (Ref. 1). 

Tcup

ρn u⋅( )Tf Ω2d∫
ρn u⋅( ) Ω2d∫

-----------------------------------------=

NuL had L k⁄( )=
C O N V E C T I O N  C O O L I N G  O F  C I R C U I T  B O A R D S  |  19
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A general conclusion you can draw from this example is that modeling can achieve 
accurate values of convective heat transfer film coefficients, although the values do 
differ somewhat between the 2D and 3D models. In addition, the good agreement 
between experimental and simulated values indicates the models’ high accuracy.
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Modeling Using the Graphical User Interface—2D Natural 
Convection

Model Library path: Heat_Transfer_Module/
Electronics_and_Power_Systems/circuit_board_nat_2d

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics, and in the Model Navigator click the New tab.

2 From the Space dimension list, select 2D.

3 From the Application Modes tree, select 
Heat Transfer Module>Fluid-Thermal Interaction>Non-Isothermal Flow.

4 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants, and in the resulting dialog box define the 
following names and expressions. When finished, click OK.

NAME EXPRESSION

q_source (2/3)*1[W]/(20*20*2[mm^3])

T0 300[K]
 2 :  E L E C T R O N I C S  A N D  P O W E R - S Y S T E M  M O D E L S



2 From the Options menu, select Expressions>Scalar Expressions, then define the 
following names and expressions; when finished, click OK.

G E O M E T R Y  M O D E L I N G

1 Create three rectangles. To do so, go to the Draw menu, select Specify 

Objects>Rectangle, and then enter the information from the following table; after 
creating each rectangle, click OK.

2 Click the Zoom Extents button on the Main toolbar.

3 In the drawing area, select the rectangle designated R3, then click the Array button 
on the Draw toolbar. In the resulting dialog box, go to the Displacement area and in 
the y edit field type 0.03; go to the Array size area and in the y edit field type 4. Click 
OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 In the Multiphysics menu, select the Weakly Compressible Navier-Stokes (chns) 

application mode.

2 From the Physics menu, select Subdomain Settings.

3 Select Subdomains 1 and 3–6. Select Solid domain from the Group list. This 
deactivates the Weakly Compressible Navier-Stokes application mode in these 
subdomains.

rho0_air 1.013e5[Pa]*28.8[g/mol]/(8.314[J/(mol*K)]*T0)

Cp_air 1.1[kJ/(kg*K)]

NAME EXPRESSION

k_air 10^(-3.723+0.865*log10(abs(T[1/K])))[W/(m*K)]

rho_air 1.013e5[Pa]*28.8[g/mol]/(8.314[J/(mol*K)]*T)

eta_air 6e-6[Pa*s]+4e-8[Pa*s/K]*T

OBJECT WIDTH HEIGHT BASE X Y

R1 0.002 0.13 Corner 0 0

R2 0.01 0.13 Corner 0.002 0

R3 0.002 0.02 Corner 0.002 0.01

NAME EXPRESSION
C O N V E C T I O N  C O O L I N G  O F  C I R C U I T  B O A R D S  |  21
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4 Select Subdomain 2 and enter these expressions in the appropriate edit fields:

The density will automatically be imported from the General Heat Transfer 
application mode.

5 Click OK to close the Subdomain Settings dialog box.

6 In the Multiphysics menu, select the General Heat Transfer (htgh) application mode.

7 From the Physics menu, open the Subdomain Settings dialog box.

8 Click the General tab and select Subdomain 1.

9 Select Solid domain from the Group list and enter the following expressions:

10 Select Subdomain 2 and enter k_air in the k edit field, rho_air in the ρ edit field, 
and Cp_air in the Cp edit field.

11 Click the Convection tab. Select the Enable convective heat transfer check box, then 
select Ideal gas from the Matter state list.

12 Click the Ideal Gas tab.

13 Click the Mn option button and enter 0.0288 in the corresponding edit field.

14 Click the General tab and select Subdomains 3–6.

15 Select Solid domain from the Group list.

16 Click the Load button to open the Materials/Coefficients Library.

17 From the Basic Material Properties library, choose Silicon, then click OK.

18 In the Q edit field, type q_source.

19 Select all subdomains. Go to the Init page, and in the Temperature edit field enter T0.

20 Click OK to close the Subdomain Settings dialog box.

Boundary Conditions
1 From the Physics menu, open the Boundary Settings dialog box.

PARAMETER EXPRESSION

 η eta_air

 Fy 9.81[m/s^2]*(rho0_air-rho_htgh)

SETTINGS SUBDOMAIN 1

 k 0.3

 ρ 1900

 Cp 1369
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2 Set the boundary conditions as in the following table; when done, click OK.

3 In the Multiphysics menu, select Weakly Compressible Navier-Stokes (chns). 

4 From the Physics menu, open the Boundary Settings dialog box.

You must only change the boundary condition at in- and outlet because no slip is 
default for all boundaries.

5 Select Boundaries 5 and 22, then set the Boundary type to Open boundary and the 
Boundary condition to Normal stress. Leave f0 at zero.

6 Click OK.

7 From the Physics>Periodic Conditions menu, open the Periodic Boundary Conditions 
dialog box.

8 On the Source page select Boundary 1, go to the Expression edit field and type T, 
then press Enter.

9 Click the Destination tab, select the check box corresponding to Boundary 27, and 
in the Expression edit field type T.

10 Click the Source Vertices tab, find the Vertex selection list, select Vertices 1 and 2, 
then click the >> button.

11 Click the Destination Vertices tab. Select and add Vertices 21 and 22. Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, open the Free Mesh Parameters dialog box. Go to the Global 
page. From the Predefined mesh sizes list select Normal.

2 On the Subdomain page, select Subdomain 2, then in the Maximum element size edit 
field type 1.5e-3. Click OK.

3 On the Mesh menu, select Initialize Mesh.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar to calculate the solution.

SETTINGS BOUNDARY 5 BOUNDARY 22

Boundary condition Temperature Convective flux

T0 T0

Radiation type None
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PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 In order to create Figure 2-3 open the Plot Parameters dialog box from the 
Postprocessing menu.

2 Click the Surface tab.

3 On the Surface Data page, select General Heat Transfer (htgh)>Temperature from the 
Predefined quantities list. Click Apply.

4 To reproduce Figure 2-5 (a) select Weakly Compressible Navier-Stokes 

(chns)>Velocity field from the Predefined quantities list on the Surface Data page, then 
click OK.

Modeling Using the Graphical User Interface—3D Natural 
Convection

Model Library path: Heat_Transfer_Module/
Electronics_and_Power_Systems/circuit_board_nat_3d

Repeat the steps from the 2D model in the sections “Model Navigator” and “Options 
and Settings” with two exceptions: in the Space dimension list select 3D and q_source 
should be equal to 1[W]/(20*20*2[mm^3]).

G E O M E T R Y  M O D E L I N G

1 Create three blocks using data from this table. To do so, go to the Draw menu and 
select Block.

2 Click the Zoom Extents button on the Main toolbar.

3 Select the object BLK2, then click the Array button on the Draw toolbar. Go to the 
Displacement area and in the z edit field type 0.03. Go to the Array size area and in 
the z edit field type 4. Click OK.

OBJECT LENGTH X LENGTH Y LENGTH Z BASE X BASE Y BASE Z

BLK1 0.015 0.002 0.13 0 0 0

BLK2 0.01 0.002 0.02 0 -0.002 0.01

BLK3 0.015 0.01 0.13 0 -0.01 0
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P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Multiphysics menu, select the Weakly Compressible Navier-Stokes (chns) 

application mode.

2 From the Physics menu, select Subdomain Settings.

3 Select Subdomains 2–6. Select Solid domain from the Group list. This will deactivate 
the Weakly Compressible Navier-Stokes application mode in these subdomains.

4 Select Subdomain 1, then enter the following expressions in the appropriate edit 
fields:

The density will automatically be imported from the General Heat Transfer 
application mode.

5 Click OK to close the Subdomain Settings dialog box.

6 In the Multiphysics menu, select the General Heat Transfer application mode.

7 From the Physics menu, open the Subdomain Settings dialog box.

8 Click the General tab and select Subdomain 6.

9 From the Group list, select Solid domain. Then enter the following settings:

10 Select Subdomain 1. Enter k_air in the k edit field and Cp_air in the Cp edit field.

11 Click the Convection tab. Select the Enable convective heat transfer check box, then 
select Ideal gas from the Matter State list.

12 Click the Ideal gas tab.

13 Click the Mn button and enter 0.0288 in the corresponding edit field.

14 Click the General tab, then select Subdomains 2–5. 

15 From the Group list, select Solid domain.

16 Click the Load button to open the Materials/Coefficients Library.

PARAMETER EXPRESSION

 η eta_air

 Fz 9.81[m/s^2]*(rho0_air-rho_htgh)

SETTINGS SUBDOMAIN 6

 k (isotropic) 0.3

 ρ 1900

 Cp 1369
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17 From the Basic Material Properties library, choose Silicon, then click OK.

18 In the Q edit field, type q_source.

19 Select all subdomains. Click the Init tab, then in the Temperature edit field type T0.

20 Click OK to close the Subdomain Settings dialog box.

Boundary Conditions
1 From the Physics menu, select Boundary Settings.

2 Set the boundary conditions as follows; when done, click OK.

3 From the Multiphysics menu, select Weakly Compressible Navier-Stokes (chns). 

4 From the Physics menu, select Boundary Settings.

The default boundary condition is no-slip. Hence, only those boundaries that are 
not walls have to be specified.

5 Select Boundaries 3 and 4, then set the Boundary type to Open Boundary and the 
Boundary Condition to Normal stress. Leave f0 at zero.

6 Select Boundaries 1 and 34, then apply the boundary Type Symmetry Boundary.

7 Click OK.

8 From the Physics menu, select Periodic Conditions>Periodic Boundary Conditions.

9 On the Source page select Boundary 2. In the Expression edit field type T, then press 
Enter.

10 Click the Destination tab, and click the check box to select Boundary 29. In the 
Expression field type T.

11 Click the Source Vertices tab. Select and add (using the >> button), in this order, 
Vertices 1, 2, 39, and 40.

12 Click the Destination Vertices tab. Select and add Vertices 21, 22, 43, and 44, again 
in the mentioned order. Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters. On the Global page, go to the 
Predefined mesh sizes list and select Finer.

SETTINGS BOUNDARY 3 BOUNDARY 4

Boundary condition Temperature Convective flux

T0 T0

Radiation type None
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2 Click the Boundary tab and select Boundary 2. In the Maximum element size edit 
field, type 2e-3.

3 Click the Advanced tab. In the x-direction scale factor edit field type 0.5. Click OK.

4 On the Mesh menu, select Initialize Mesh.

C O M P U T I N G  T H E  S O L U T I O N

1 From the Solve menu, open the Solver Parameters dialog box.

2 On the General page, select Direct (PARDISO) from the Linear system solver list.

3 Click OK.

4 Click the Solve button on the Main toolbar to compute the solution.

The problem is rather large because of the strong coupling between temperature and 
velocity and because of the dense mesh. A computer needs approximately 500 MB of 
free memory to solve the problem. The problems can take a few minutes to solve.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate the temperature plot in Figure 2-4 execute the following instructions:

1 From the Postprocessing menu, open the Plot Parameters dialog box.

2 On the General page, clear the check box for the Boundary plot type and select the 
check box for the Slice plot type.

3 Click the Slice tab. Go to the Slice data area. In the Predefined quantities list, select 
General Heat Transfer (htgh)>Temperature.

4 Go to the Slice positioning area. In the Number of levels edit fields for x levels and 
z levels type 1 and 8, respectively. For y levels, select the option button next to the 
Vector with coordinates edit field, then type 0 in this edit field.

5 Click Apply to launch the plot.

To generate the plot in Figure 2-5 (b), proceed as follows:

6 Still on the Slice page, select Weakly Compressible Navier-Stokes (chns)>Velocity field 
from the Predefined quantities list.

7 Click the option button next to the Number of levels edit field for y levels, then type 
0 in this edit field. Click Apply.

Finally, you can reproduce the model image—that is, the plot shown in the Model 

Navigator and when the model opens—by the following modifications:

8 In the Predefined quantities list on the Slice page, select General Heat Transfer 

(htgh)>Temperature.
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9 Click the Arrow tab. Select the Arrow plot check box.

10 In the Predefined quantities list on the Subdomain Data page, leave the default 
selection, which is Weakly Compressible Navier-Stokes (chns)>Velocity field.

11 Go to the Arrow positioning area. In the Number of points edit fields for x points, 
y points, and z points type 5, 5, and 8, respectively.

12 In the Arrow parameters area, select 3D arrow from the Arrow type list, then click OK.

Modeling Using the Graphical User Interface—3D Forced 
Convection

Model Library path: Heat_Transfer_Module/
Electronics_and_Power_Systems/circuit_board_forced_3d

You implement this model by modifying the previous one 
(circuit_board_nat_3D.mph). Begin by loading or building that previous model.

G E O M E T R Y  M O D E L I N G

1 Click the Draw Mode button on the Main toolbar to enter the Draw mode.

2 Select all objects, then select the menu item Draw>Modify>Rotate.

3 In the Rotation angle edit field type -90.

4 Go the Rotation axis direction vector area, and in the in the x, y, and z edit fields type 
1, 0, and 0, respectively. Click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings
Since you rotated the model geometry, and you are modeling forced convection here, 
the volume force that acts on the fluid will have different magnitude and direction. The 
volume force is represented by gravitation. However, for this problem we will neglect 
the gravitational force, which is a fair assumption. Therefore, zero-out the volume 
force present in the Weakly Compressible Navier-Stokes application mode according 
to the following steps:

1 From the Physics menu, select Subdomain Settings.

2 Select Subdomain 2 and type 0 in the Volume force, z dir. edit field. 

3 Click OK.
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Boundary Conditions
1 From the Physics menu, select Boundary Settings.

2 Select Boundary 29. Set the Boundary type to Inlet and the Boundary condition to 
Velocity.

3 Click the u0, v0, w0 option button.

4 In the y-velocity edit field, type 4e4*z*(0.01-z)[1/m^2]*(-1[m/s]), then click 
OK.

5 From the Multiphysics menu, select General Heat Transfer.

6 From the Physics menu, select Boundary Settings.

7 In the dialog box that opens, set the boundary conditions as follows; when done, 
click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters. On the Global page verify that 
Finer is selected from the Predefined mesh sizes list.

2 Click the Custom mesh size button and set the Resolution of narrow regions parameter 
to 1.

3 On the Boundary page, select Boundary 7. In the Maximum element size edit field 
type 2.8e-3, then click OK.

4 Click the Initialize Mesh button on the Main toolbar.

C O M P U T I N G  T H E  S O L U T I O N

1 From the Solve menu, open the Solver Manager dialog box.

2 On the Initial Value page, go to the Initial value area and select the Initial value 

expression option button.

3 Click OK.

4 Click the Solve button on the Main toolbar. 

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 To create Figure 2-6, first go to the Postprocessing menu and open the Plot 

Parameters dialog box.

SETTINGS BOUNDARY 5 BOUNDARY 29

Boundary condition Convective flux Temperature

T0 T0

Radiation type None
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2 On the General page, select the check box for the Slice plot type and clear the check 
box for the Boundary plot type.

3 Click the Slice tab, then go to the Slice data area. In the Predefined quantities list 
select General Heat Transfer (htgh)>Temperature. 

4 Go to the Slice positioning area. In the Number of levels edit fields for x levels and 
y levels type 1 and 10, respectively. For z levels, click the option button next to the 
Vector with coordinates edit field, then type 0 in this edit field. Click Apply.

5 To produce Figure 2-7, select Weakly Compressible Navier-Stokes (chns)>Velocity 

field from the Predefined quantities list.

6 In the Number of levels edit field for x levels type 0. Click the option button next to 
the Number of levels edit field for z levels, then type 0 in this edit field. Click OK.

Generate the plot shown in the Model Navigator and when the model opens in the 
following way:

1 From the Postprocessing menu, select Plot Parameters.

2 On the General page clear the check boxes for the Slice and Arrow plot types and then 
select the check boxes for the Boundary and Streamline plot types.

3 Click the Streamline tab.

4 On the Start Points tab click the Specify start point coordinates button.

5 In the x edit field type linspace(1e-3,13e-3,13).

6 In the y edit field type linspace(0.13,0.13,13).

7 In the z edit field type linspace(1.3e-3,1.3e-3,13).

8 Click the Line Color tab, then click the Use expression button.

9 Click the Color Expression button to open the Streamline Color Expression dialog box.

10 In the Expression field type T-296[K], then click OK.

11 In the Line type list, select Tube.

12 Click the Tube Radius button at the bottom of the dialog box. 

13 Click the Radius data check box, and in the Predefined quantities list select General 

Heat Transfer (htgh)>Temperature gradient.

14 Clear the Radius scale factor>Auto check box, and in the edit field for the scale factor 
enter 0.5. Click OK.

15 Click the Advanced button. In the Maximum number of integration steps edit field 
type 1000, then click OK.
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16 On the Boundary page, select General Heat Transfer (htgh)>Temperature from the 
Predefined quantities list.

17 Click OK.

18 From the Options menu, select Suppress>Suppress Boundaries.

19 Select Boundaries 4–7, 9, 29, and 35, then click OK.

20 Click the Postprocessing Mode button on the Main toolbar.

21 Click the Scene Light button on the Camera toolbar.

22 Double-click the AXIS button on the status bar at the bottom of the COMSOL 
Multiphysics window to disable the coordinate axes.

Forced Convection Cooling—Simplified Models

The two following examples illustrate simplified approaches to simulating forced 
convection cooling. This discussion starts with the exact problem from the section 
“Forced Convection—Horizontal Boards” on page 17 and shows how to simplify it. 
Specifically, if you know the heat transfer film coefficient, h, it is not necessary to 
include the flow field; the General Heat Transfer application mode is then sufficient 
for modeling the temperature distribution. And while the following examples take 
their h values from the results of the rigorous model “Convection Cooling of Circuit 
Boards” on page 10 (the case of forced convection), you can also use the methodology 
of known values or expressions for h.

The dimensions of the problem geometry (Figure 2-9) and its parameters are the same 
as in the previous example. In brief, the system cools a stack of circuit boards with four 
in-line ICs, each producing 1 W of heat, through forced convection. The aim of both 
of the following models is to determine the temperature development of the board and 
ICs.
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Figure 2-9: Starting geometry for the problem.

1 D  P L U G  F L O W

First, this example sets up a 1D adiabatic plug-flow model describing the cup mixing 
temperature of the air (fluid), Tf,cup, in the channel between the boards during forced 
convection. It uses the equation

.

The model does not include the temperature distribution in the air. In addition, the 
model assumes the sources are infinite in the board’s lateral direction. Thus, in 
principle the model describes the distribution of temperature in the flow direction 
along a line in the air channel. Figure 2-10 depicts the resulting 1D geometry.

Figure 2-10: The geometry of the 1D-model.

1 W / IC

Tf,cup

ρn u⋅( )Tf Ω2d∫
ρn u⋅( ) Ω2d∫

------------------------------------------=
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The model uses the General Heat Transfer application mode. It sets the convective 
velocity to 0.667 m/s at the inlet (that is, the average velocity of the previous models) 
and assume that it varies with temperature according to

.

The next equation describes the heat transfer

where k represents the thermal conductivity, Cp gives the specific heat capacity, and Q 
is the heating power per unit volume. The model sets Q to zero for the subdomains 
between the sources while it equals 1666.67 W/m2 (that is, (2/3)·1 W/ 
((20·10−3)2 m2)) at the source subdomains. The factor 2/3 represents the lateral 
average heating power, taking the open slots between the ICs into account. 

The material properties are the same as those in the previous models, also taking 
temperature variations into account. At the inlet boundary, the temperature is fixed to 
300 K, and at the outlet the model applies convective heat flux.

The goal is to calculate the ICs’ surface temperature, Ts. It is a function of the fluid 
temperature and the adiabatic heat transfer film coefficients, had, according to 

where q is the heat flux. This equation calculates the IC surface temperature.

This example calculates values of had using the results of the previous 3D model 
(“Forced Convection—Horizontal Boards” on page 17) with the formula

where A2D is the IC’s xy-projected area, and Qtot is the IC’s total heating power (in 
this case, 1 W).

You can easily perform these calculations using the postprocessing capabilities of 
COMSOL Multiphysics. Specifically, with the model “circuit_board_3d_forced” 
open, first calculate Tf,cup for each cross section of the air domain. Next calculate the 

u x( ) u0
Tf,cup

T0
---------------=

∇ k∇Tf,cup–( )⋅ Q ρ Cp u ∇Tf,cup⋅–=

Ts
q

had
--------- Tf,cup+=

had
Qtot

A2D TS Tf,cup–( )
--------------------------------------------=
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total heat flux, Qtot, from each surface. Finally use the equation just given to derive the 
following values of had (a discussion of h0 follows shortly):

S I M P L I F I E D  3 D  M O D E L

This second example sets up a transient 3D model describing the temperature of the 
board and ICs during startup. In this case the modeled geometry consists of the board 
and ICs but not the air. The simplified model makes it possible to investigate the 
temperature transient of a entire row of ICs.

Figure 2-11: Geometry of the 3D model.

In contrast to the model in the previous section, which used both conduction and 
convection, this model works only with the conduction feature of the General Heat 
Transfer application mode. It uses the isothermal film coefficients, h0, to calculate the 
convective cooling. You calculate them from the results of the previous 3D model 
(“Forced Convection—Horizontal Boards” on page 17), doing so in a similar way as 
you did for the 1D-plug-flow model just described except using the formula

REGION  had (W/(m2·K))  h0
 (W/(m2·K)) 

Source 1 57.5 35.0

Source 2 44.4 22.1

Source 3 40.6 19.2

Source 4 39.2 18.0

h0 Qtot
A2D TS T0–( )
------------------------------------=
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where T0 is the air’s inlet temperature. To model the heat transfer coefficient of the 
board, a function from the built-in Heat Transfer Coefficients library is used. The 
function is valid for forced convection on plates. For more information about the Heat 
Transfer Coefficients library, see the Heat Transfer Module User’s Guide.

Further, the material properties specified in the subdomain settings for this model are 
identical to those in the previous models. The initial temperature of all components is 
300 K, as is the surrounding temperature. For the ICs it applies a volume heat source 
of 1.25 MW/m. In the heat flux boundary conditions, for the downside segments of 
the board and for the circuit surface boundaries, it uses the h0 values. 

Results and Discussion

1 D  P L U G  F L O W

Figure 2-12 shows the results of the 1D model for the ICs’ surface temperature.

Figure 2-12: 1D model results for the surface temperature of the ICs (dashed line) and the 
average temperature of the fluid (solid line).

The profile agrees rather well with that of the previous 3D model, in this case 
experiencing a maximum surface temperature of 357 K. This indicates that you can 
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model the heat transfer with good accuracy in a simplified way if you know the values 
of the film coefficient, had. The simplified 1D model is thus a good predictor even 
though it does not simulate the temperature distribution in the fluid and the fluid flow 
field.

S I M P L I F I E D  3 D  M O D E L

This model results in an accurate determination of the source surface temperatures. A 
benefit of having an easy-to-solve model is that you can proceed and analyse the 
transient behavior. Figure 2-13 shows the transient 3D model results at 1000 s.

Figure 2-13: Temperature of the source surfaces 1000 s after applying the heat load 
according to the simplified 3D model.

The results indicate that this amount of time is approximately sufficient to reach steady 
state.
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Modeling Using the Graphical User Interface—1D Plug Flow

Model Library path: Heat_Transfer_Module/
Electronics_and_Power_Systems/simplified_circuit_board_1d

M O D E L  N A V I G A T O R

1 In the Model Navigator click the New tab, and in the Space dimension list select 1D.

2 From the Application Modes tree, select Heat Transfer Module>General Heat Transfer.

3 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants. In the dialog box, define the following 
names and expressions; when done, click OK.

2 From the Options menu, select Expressions>Scalar Expressions. In the dialog box, 
define the following names and expressions; when done, click OK.

G E O M E T R Y  M O D E L I N G

1 Create three line segments. To do so, go to the Draw menu and select Specify 

Objects>Line.

NAME EXPRESSION

v_in (2/3)*1[m/s]

T0 300[K]

width 0.01

q_s (2/3)*1.25[MW/m^3]*2[mm]

h1 57.5[W/(m*K)]

h2 44.4[W/(m*K)]

h3 40.6[W/(m*K)]

h4 39.2[W/(m*K)]

NAME EXPRESSION

k_f 10^(-3.723+0.865*log10(T[1/K]))[W/(m*K)]

rho_f 1.013e5[Pa]*28.8[g/mol]/8.314[J/(mol*K)]/T

Cp_f 1.1[kJ/(kg*K)]

v v_in*width*T/T0
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2 In the Line dialog box, enter the following settings; when done, click OK.

3 Click the Zoom Extents button on the Main toolbar.

4 Copy line segments 2 and 3 by selecting these objects and pressing Ctrl+C.

5 To complete the geometry, perform a paste operation three times by pressing 
Ctrl+V; each time use a different Displacement in the x edit field of 0.03, 0.06, and 
0.09.

6 Once again click the Zoom Extents button.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Physics menu, select Subdomain Settings.

2 On the Init page, select all subdomains, then in the T(t0) edit field type T0.

3 On the General page, enter these settings:

4 Click the Convection tab, select all subdomains, and click the Enable convective heat 

transfer check box. In the u edit field for the x-velocity, type v. Click OK.

5 From the Options menu, select Expressions>Subdomain Expressions.

6 Enter the name of the subdomain expression and the expressions that define it in 
the various subdomains; when done, click OK.

Boundary Conditions
1 From the Physics menu, open the Boundary Settings dialog box.

LINE SEGMENT X-COORDINATES

1 0 0.01

2 0.01 0.03

3 0.03 0.04

SETTINGS SUBDOMAINS 1, 3, 5, 7, 9 SUBDOMAINS 2, 4, 6, 8

k (isotropic) k_f k_f

 ρ rho_f rho_f

Cp Cp_f Cp_f

Q 0 q_s

NAME  SUBDOMAIN 2  SUBDOMAIN 4  SUBDOMAIN 6  SUBDOMAIN 8

Ts q_s/h1+T q_s/h2+T q_s/h3+T q_s/h4+T
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2 Specify the boundary conditions as follows; when done, click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 From the Postprocessing menu, open the Plot Parameters dialog box.

2 Click the Line tab.

3 In the Expression edit field, type Ts, then click OK.

4 To reproduce Figure 2-12, go to the Postprocessing menu and select Domain Plot 

Parameters.

5 On the General page, select the Keep current plot check box.

6 On the Line/Extrusion page, select all the subdomains, then click Apply.

7 In the y-axis data area, type Ts in the Expression edit field.

8 In the x-axis data area, click the Expression button. In the X-Axis Data dialog box, 
type x in the Expression edit field. From the Unit list, select mm.

9 Click OK to close the X-Axis Data dialog box.

10 Click the Line Settings button and from the Line style list select Dashed line. Click OK.

11 Click OK to generate the figure.

Modeling Using the Graphical User Interface—3D Model

Model Library path: Heat_Transfer_Module/
Electronics_and_Power_Systems/simplified_circuit_board_3d_hcoeff

M O D E L  N A V I G A T O R

1 Open the Model Navigator, click the New tab, and from the Space dimension list select 
3D.

2 From the Application Modes tree, select Heat Transfer Module>General Heat Transfer, 
then click OK.

SETTINGS BOUNDARY 1 BOUNDARY 10

Boundary condition Temperature Convective flux

T0 T0
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O P T I O N S  A N D  S E T T I N G S

In the Options menu, select Constants. In the dialog box, define the following names 
and expressions; when done, click OK.

G E O M E T R Y  M O D E L I N G

1 Create two blocks according to the specifications in the table below. To do so, select 
Block from the Draw menu; click OK after specifying each block.

2 Click the Zoom Extents button on the Main toolbar.

3 Select both blocks with the mouse, then go to the Draw menu and select 
Modify>Array.

4 In the Displacement area, go to the x edit field and type 0.03; in the Array size area 
find the x edit field and type 4. Click OK. 

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Physics menu, open the Subdomain Settings dialog box.

2 On the Init page, select all subdomains, then in the T(t0) edit field type T0.

3 Click the General tab and enter the following settings. For Subdomains 2, 4, 6, and 
8, click the Load button and select Silicon from the Basic Material Properties library 

NAME EXPRESSION

T0 300[K]

q_s 1[W]/(20*20*2[mm^3])

hs1 35.0[W/(m^2*K)]

hs2 22.1[W/(m^2*K)]

hs3 19.2[W/(m^2*K)]

hs4 18.0[W/(m^2*K)]

u_in 1[m/s]

OBJECT LENGTH X LENGTH Y LENGTH Z BASE X BASE Y BASE Z

BLK1 0.03 0.03 0.002 0 0 0

BLK2 0.02 0.02 0.002 0.005 0.005 0.002
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in the Materials/Coefficients Library dialog box. This defines k, ρ, and Cp for those 
subdomains. When done, click OK.

Boundary Conditions
1 From the Physics menu, open the Boundary Settings dialog box.

2 Select Boundaries 3, 4, 14, 15, 25, 26, 36, and 37. Specify a Heat flux boundary 
condition.

3 Click the Load button to load a heat transfer coefficient. This opens the Materials/

Coefficients Library dialog box.

4 In the Materials/Coefficients Library dialog box, select Heat Transfer Coefficients>Air, 

Ext. Forced Convection>Forc. Plate, h_loc, s=position, U=velocity, then click OK. This 
brings you back to the Boundary Settings dialog.

5 Edit the function call expression in the h edit field to read 
h_loc(T,Tinf_htgh,x,u_in).

6 Type T0 in the Tinf edit field for the external temperature.

7 Set the remaining boundary conditions as follows; when done, click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 From the Solve menu, open the Solver Parameters dialog box.

2 In the Solver list, select Time dependent. In the Times edit field, type 0 1000.

3 Click the Time Stepping tab. In the Times to store in output list, select Time steps from 

solver. Click OK.

4 Click the Solve button on the Main toolbar.

QUANTITY SUBDOMAINS 1, 3, 5, 7 SUBDOMAINS 2, 4, 6, 8

k (isotropic) 0.3 163

 ρ 1900 2330

Cp 1369 703

Q 0 q_s

SETTINGS BOUNDARIES 
6, 7, 9–11

BOUNDARIES 
17, 18, 20–22

BOUNDARIES 
28, 29, 31–33

BOUNDARIES 
39, 40, 42–44

Boundary condition Heat flux Heat flux Heat flux Heat flux

h hs1 hs2 hs3 hs4

Tinf T0 T0 T0 T0
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PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 To generate an animation of temperature over time (and reproduce Figure 2-13), 
go to the Postprocessing menu and open the Plot Parameters dialog box.

2 On the General page, go to the Plot type area and clear the check box next to Slice, 
then select the check box next to Boundary.

3 On the Animate page click the Start Animation button at the bottom of the dialog 
box. The software now generates the animation, which might take a few seconds. 
To replay the animation, use the icons in the lower left corner of the COMSOL Movie 

Player dialog box.
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Fo r c e d  Tu r bu l e n t  C on v e c t i o n  Coo l i n g

Introduction

The following set of models demonstrates how to model a conjugate heat transfer 
problem with COMSOL Multiphysics. The models show two different approaches. 
The first one uses the Turbulent Non-Isothermal Flow predefined multiphysics 
coupling from the Heat Transfer Module. The second approach is a simplified one 
making use of the Heat Transfer Coefficients library supplied with the Heat Transfer 
Module. In addition, this discussion shows how to modify the k-ε Turbulence Model 
application mode’s equations to take density variations into account (weakly 
compressible flow).

Figure 2-14 depicts the geometry: a horizontal stream of air that cools a thin and 
infinitely wide horizontal plate. The plate is at a uniform temperature at the bottom, 
and the flow is turbulent. This is a well-studied case of convection cooling that works 
well as a benchmark that demonstrates the accuracy of the modeling methods.

Figure 2-14: Forced convection cooling of a horizontal plate.

You can take two main approaches when simulating forced convection cooling: first, 
model the heat transfer by using heat transfer coefficients; second, also solve for the 
fluid flow field and include heat transfer in the fluid domain. The first approach works 
well for simple geometries such as the one in this example, for which accurate heat 
transfer coefficient expressions and correlations exist. For more complex geometries, 
however, such correlations might not describe the situation very well, and so the 
second approach is the best choice. If you are interested in the flow field or the 
temperature distribution in the fluid, the second alternative is, of course, the only 
choice. This exercise explains how to set up both approaches and then compares the 
results.

Inflow

Hot plate

Symmetry

Outflow
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Model Definition

S O L I D  A N D  F L U I D  H E A T  TR A N S F E R — I N C L U D I N G  T H E  F L U I D  D Y N A M I C S

The model works with the following equations:

• Reynolds-averaged Navier-Stokes (RANS) equations in the air domain.

• The conductive and convective heat equation in the air and the solid (copper) wall.

The Turbulent Non-Isothermal Flow predefined multiphysics coupling sets up these 
application modes together with applicable couplings, making it easy to model the 
fluid-thermal interaction.

The material properties for the fluid are those of air at atmospheric pressure, and for 
the solid plate those of copper. You can load these properties from the built-in 
materials library where the air properties are temperature dependent.

It is necessary to correct the fluid’s thermal conductivity to take into account the effect 
of mixing due to eddies. The turbulence results in an effective thermal conductivity, 
keff, according to the equation

.

Here k is the physical thermal conductivity of the fluid, kT is the turbulent 
conductivity, ηT denotes the turbulent viscosity, Cp equals the heat capacity and PrT is 
the turbulent Prandtl number. With COMSOL Multiphysics you can easily obtain the 
effective conductivity by using the ‘default’ group setting in the fluid domain. In the 
group, the variable for turbulent conductivity is already given in the General Heat 
Transfer application mode for the fluid.

Figure 2-15 depicts the model with its boundary conditions.

Figure 2-15: Modeled 2D geometry with boundary conditions.

keff k kT+= kT
CpηT

PrT
--------------=

Symmetry

Inflow/ Convective
Temperature outflow

Constant temperature

Logarithmic wall function
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The boundary conditions for the problem are:

• k-ε equations in the fluid domain

- Specified velocity at the inlet

- Pressure and no viscous stress at the outlet

- Symmetry at the top boundary

- Logarithmic wall function at the plate’s surface boundaries

• Heat transport equations

- Room temperature at the inlet

- Convection-dominated transport at the outlet

- Symmetry at the top boundary

- Thermal wall function at the plate/air interface

- Fixed temperature at the bottom of the heated plate

To model the solid-fluid interfaces, the model uses the logarithmic wall function 
boundary condition for turbulent flow, in which an algebraic relationship—the 
logarithmic wall function—describes the momentum transfer at the solid-fluid 
interface. This means that the modeled domain ends at the top of the laminar 
boundary layer where the fluid experiences a significant wall-tangential velocity. This 
is an important aspect to consider when modeling the heat transfer. Like the fluid 
velocity, the temperature is not modeled in the laminar sublayer. Instead of assuming 
the temperature to be continuous across the layer, the model uses a thermal wall 
function. This creates a jump in temperature between the solid surface and the fluid 
due to the omitted laminar sublayer. The predefined group for the wall domains 
defines this wall function in the following way.

To implement the thermal wall function, the model uses two heat transfer application 
modes: one for the solid and one for the fluid. These are connected through a heat flux 
boundary condition, the thermal wall function. This means that the resistance to heat 
transfer through the laminar sublayer is related to that for momentum transfer for the 
fluid. You therefore determine the heat flux, q, from the equation

where ρ and Cp are the fluid’s density and heat capacity, respectively;  is a numerical 
constant of the turbulence model; and kw is the value of the turbulent kinematic 
energy at the wall. Furthermore, Tw equals the temperature of the solid at the wall, 

q
ρCpCµ

1 4⁄ kw
1 2⁄ Tw T–( )

T+
---------------------------------------------------------------=

Cµ
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while T is the fluid temperature on the other side of the omitted laminar sublayer. The 
dimensionless quantity  is the dimensionless temperature and depends 
on the dimensionless wall offset, δw

+.

At the front of the hot plate a stagnation point for the flow develops. Typical for 
two-equation turbulence models such as the k-ε model is an unphysical production of 
turbulence at stagnation points. The remedy is to apply a realizability constraint, 
which is a physical constraint on the turbulent viscosity. The realizability constraint 
makes the simulation less stable and is therefore applied only when necessary.

C O N V E C T I O N  M O D E L E D  A S  A  B O U N D A R Y  C O N D I T I O N

This simplified model uses only an energy-balance condition for the solid wall. The 
heat transfer at the fluid/solid interface is calculated with established theoretical 
correlations. This means that it is not necessary to model the fluid domain. The model 
determines the heat transfer at the fluid-cooled side of the wall using a heat transfer 
coefficient correlation from the built-in library. If the aspect of primary interest is heat 
transfer at the wall/fluid interface, then this method is very useful.

The simplified model uses the same geometry although it applies the heat transfer 
equations only inside the plate. The model works with the heat transport equations in 
the solid (copper) plate. For this purpose you can use a General Heat Transfer 
application mode from the Heat Transfer Module.

The boundary conditions for the heat transport equations are

• Fixed temperature at the bottom of the heated plate

• Flux boundary condition at the plate’s top boundary (interface with fluid) using a 
heat transfer coefficient.

To describe the heat transfer coefficient for atmospheric air under various conditions, 
this example models the heat transfer coefficient using the built-in heat transfer 
coefficient library, which is based on general Nusselt correlations. 

T+ T+ δw
+( )=
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Results for the Flow/Heat Model

The example solves the problem for a set of inlet velocities between 1 m/s and 100 m/
s. Figure 2-16 depicts the temperature distribution for the inlet velocity 1 m/s.

Figure 2-16: Temperature distribution at an inlet velocity of 1 m/s.
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The heated layer of air at the plate surface is rather thick considering the relatively high 
velocity. This is an effect of the turbulent thermal conductivity caused by the eddies in 
the flow. The next figure depicts the turbulent thermal conductivity of the air.

Figure 2-17: Turbulent thermal conductivity of the air at an inlet velocity of 100 m/s.

The turbulent conductivity is much higher than the physical thermal conductivity of 
air, which is 0.03 W/(m·K) at 323 K. This means that the added turbulent 
conductivity dominates over the laminar conductivity, and hence that the turbulent 
eddies cause a significantly higher heat flux at the cooled surface compared to a laminar 
flow.
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In this example you also modify the turbulent flow model to take density variations 
into account. The density of air decreases with temperature; the following figure shows 
its variation at an inlet velocity of 1 m/s.

Figure 2-18: Fluid density at an inlet velocity of 1 m/s.

These results point out the importance of taking density variations into account. As the 
density decreases, the fluid velocity increases. This effect becomes apparent in the next 
figure, which shows the velocity distribution at the same inlet velocity.
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Figure 2-19: Velocity field at an inlet velocity of 1 m/s.

If you had treated the flow as being isothermal, the average would not have varied 
between the inlet and the outlet. However, for a nonisothermal flow the average 
velocity is inversely proportional to the average density, and it varies with changing 
average temperature. This means that the flow field for the fluid is different when 
taking density variations into account.

As the fluid heats up, its velocity increases slightly. Thus the boundary layer decreases 
and the local heat transfer coefficient should become larger. So if you neglect density 
variations when modeling forced convection cooling, the model slightly 
underestimates the cooling/heating power.

The accuracy in predicting the heat transfer coefficient in this example is dictated by 
the accuracy of the Reynolds analogy and the accuracy of the flow model. The situation 
this example models is very well studied, so you can readily verify the results in terms 
of heat transfer coefficient predictions. The following figure compares the local 
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h coefficient from the model with an empirical expression valid for the geometry and 
conditions studied (assuming turbulent flow).

Figure 2-20: Local heat transfer coefficient as determined empirically (solid) and with the 
model (dashed) for various inlet velocities.

The model agrees well with empirical data for low to intermediate inlet velocities. The 
deviations at the leading edge of the plate are due to the correlation, which assumes 
that the boundary layer is fully developed for all x. However, at high inlet velocities the 
results do not match quite as well due to the model of the flow. The logarithmic wall 
function in COMSOL Multiphysics is valid under certain conditions that depend on 
the resolution, the velocity, and the viscosity. As mentioned previously on page 46, the 
wall function uses the dimensionless wall offset, δw

+ (defined in Equation 4-10 on 
page 59 if the Heat Transfer Module User’s Guide). For the wall function to be an 
accurate approximation, δw

+ for the first internal node should be larger than 30 but 
less than some upper limit dependent on the Reynolds number (for more details see 
the section “Logarithmic Wall Function” on page 212 of the Heat Transfer Module 
User’s Guide). Figure 2-21 depicts the parameter δw

+ against plate surface for various 
inlet velocities.
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Figure 2-21: Dimensionless wall distance at the plate surface for various inlet velocities.

A maximum δw
+ value of a few hundreds is always acceptable, whereas a value above 

1000 is always questionable. Note that the value of δw
+ exceeds 1000 when the inlet 

velocity is 50 m/s or higher. Hence, the mesh is a bit too coarse for this case. As a 
consequence, both the fluid velocity at the boundary and the heat transfer coefficient 
become less accurate. You can easily correct this situation by making the mesh finer at 
the boundary at the leading edge of the plate.

Results for the Simplified Model

Now examine the results of the much simpler model, which uses h coefficients from 
the built-in library. This simplified case does not model the flow field or the 
temperature distribution in the fluid. Therefore, it is “inexpensive” to solve in terms 
of memory requirements and calculation time—it solves in just a few seconds. 
Nevertheless, the results are rather accurate because the heat transfer coefficient is 
based on an empirical relationship.

Figure 2-22 compares the heat flux at the plate interface as calculated by this model to 
that of the previous, more complex, model.
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Figure 2-22: Comparison of normal total heat flux at the plate surface for the simplified 
(solid) and the flow/heat (dashed) models at various inlet air velocities.

The figure shows that the heat flux of the simplified model differs from the that of the 
flow/heat model. Because the simplified model uses well-established empirical 
relationships, you can consider its result more accurate. It shows the heat flux being 
significantly lower in the inlet region (at low values of x). This is a consequence of the 
initially laminar flow, which results in a much lower heat transfer coefficient. Then, 
above a certain x value, the flow turns turbulent and the heat transfer coefficient grows 
significantly. This appears in the plot as a sudden increase in the heat flux. On the other 
hand, the flow/heat model assumes that the flow is turbulent in the entire geometry, 
and therefore the heat flux is significantly larger.

To conclude, the flow/heat approach results in rather good predictions of the local 
boundary heat flux compared to reference values, but it assumes that the flow is 
turbulent at the inlet. That method is rather straightforward to model in COMSOL 
Multiphysics but requires a few minutes of computational time. On the other hand, 
the simplified approach is very powerful for situations where you are interested only in 
the solid’s boundary heat flux. You can employ this approach, however, only if you can 
find a well-established correlation. For many geometries such correlations do not exist, 
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and then the flow/heat approach is useful. The choice of method for modeling 
convective cooling or heating depend on your needs and the particular case.
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Modeling in COMSOL Multiphysics

The COMSOL Multiphysics implementation is straightforward using the Heat 
Transfer Module’s Turbulent Non-Isothermal Flow multiphysics coupling, combining 
the General Heat Transfer and k-ε Turbulence Model application modes. In the 
following steps you begin by setting up and solving the model with the fluid included. 
In the next section you then simplify the model.

Model Library path: Heat_Transfer_Module/
Electronics_and_Power_Systems/forced_turbulent_convection

Modeling Using the Graphical User Interface—The Flow/Heat Model

M O D E L  N A V I G A T O R

1 Open the Model Navigator, and from the Space dimension list select 2D.

2 In the list of application modes, select  
Heat Transfer Module>Fluid-Thermal Interaction>Turbulent Non-Isothermal Flow, k-ε.

3 Click OK.

G E O M E T R Y

1 Using the Rectangle dialog box, create two rectangles with specifications according 
to the following table. You launch the Rectangle dialog box by shift-clicking the 
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Rectangle/Square button on the Draw toolbar or by choosing Specify 

Objects>Rectangle from the Draw menu.

2 Click the Zoom Extents button on the Main toolbar.

You should now see the following geometry:

C O N S T A N T S ,  E X P R E S S I O N S ,  A N D  V A R I A B L E S

1 From the Options menu, open the Constants dialog box. Specify the following 
names, expressions, and descriptions (optional); when finished, click OK.

OBJECT WIDTH HEIGHT BASE X Y

R1 1.1 0.2 Corner -0.1 0

R2 1 0.01 Corner 0 0

NAME EXPRESSION DESCRIPTION

T_amb 293[K] Surrounding air temperature

delta_T 100[K] Plate-to-air temperature difference

T_av T_amb+delta_T/2 Average temperature

p_ref 1.013e5[Pa] Reference pressure

u_in 1[m/s] Inlet velocity
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2 Choose Options>Expressions>Scalar Expressions. Specify the following names, 
expressions, and descriptions (optional); when finished, click OK.

P H Y S I C S  S E T T I N G S

Now it is time to set up the physics in the subdomain and the boundary conditions. In 
this model you load the material properties from the built-in materials library.

1 From the Multiphysics menu, select 3 k-ε Turbulence Model.

2 From the Physics menu, select Properties.

3 Set Realizability to On, then click OK.

4 Choose Physics>Subdomain Settings. Select Subdomain 2 (the plate).

5 Select Solid domain from the Group list underneath the Subdomain selection list.

6 Select Subdomain 1 (the fluid) and click the Load button to open the Materials/

Coefficients Library dialog box.

7 Select Basic Material Properties>Air, then click OK.

8 edit the predefined entry for the density. Click in the Density edit field, and replace 
p with p_ref and T with Tf; the entry should read 
rho(p_ref[1/Pa],Tf[1/K])[kg/m^3].

9 Modify the expression in the Dynamic viscosity edit field by replacing T with Tf.

10 Click OK to close the Subdomain Settings dialog box.

NAME EXPRESSION DESCRIPTION

L x Distance from leading edge

ReL_ref u_in*L/mat1_nu0(T_av[1/K]) 
[m^2/s]

Reference Reynolds number

Pr_ref mat1_eta(T_av[1/K])[Pa*s]* 
mat1_Cp(T_av[1/K])[J/(kg*K)]/ 
mat1_k(T_av[1/K])[W/(m*K)]

Reference Prandtl number

NuL_ref 0.037*ReL_ref^0.8*Pr_ref^0.33 Reference Nusselt number

h_ref mat1_k(T_av[1/K])[W/(m*K)]* 
NuL_ref/L

Handbook h coefficient
 2 :  E L E C T R O N I C S  A N D  P O W E R - S Y S T E M  M O D E L S



11 Choose Physics>Boundary Settings. Then apply the following boundary conditions:

The small values of LT and IT are appropriate for essentially non-turbulent 
free-stream flows.

12 Click OK.

Now set up the parameters for the heat transfer.

1 From the Multiphysics menu, select 1 General Heat Transfer (htgh). 

2 From the Physics menu, select Subdomain Settings.

3 Select Subdomain 2. Then select Solid domain from the Group list.

4 Select Subdomain 1. From the Library material list, select Air.

5 For that material, edit the expressions for the Thermal Conductivity, the Density, and 
the Heat capacity by replacing p with p_ref and T with Tf.

6 Click the Init tab. In the Tf(t0) edit field type T_amb, then click OK.

7 From the Physics menu, open the Boundary Settings dialog box.

8 Specify boundary conditions according to the following table. When done, click OK.

9 From the Multiphysics menu select, 2 General Heat Transfer (htgh2).

10 From the Physics menu, select Subdomain Settings.

SETTINGS BOUNDARY 1 BOUNDARIES 2, 3 BOUNDARIES 4, 6 BOUNDARY 8

Type Inlet Symmetry boundary Wall Outlet

Condition Velocity Logarithmic wall 
function

Pressure

 u0 u_in

 LT 0.001

 IT 0.01

 δw h

 p0 0

SETTINGS BOUNDARY 1 BOUNDARIES 2, 3 BOUNDARIES 4, 6 BOUNDARY 8

Object Inlet Top and inlet 
bottom boundary

Plate surface Outlet

Group wall

Boundary 
condition

Temperature Insulation/Symmetry Convective flux

 T0 T_amb
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11 Select Subdomain 2, then select Solid domain from the Group list. The default 
physical parameters correspond to copper and are correct. Click OK.

12 From the Physics menu, select Boundary Settings.

13 Specify the following boundary conditions; when finished, click OK.

M E S H  G E N E R A T I O N

To solve the problem and get an accurate solution, the mesh must be fine at the solid/
fluid interface, especially at the point of first contact. Generate such a mesh with the 
following steps: 

1 Choose Mesh>Free Mesh Parameters. In the list of Predefined mesh sizes select Coarse.

2 Go to the Boundary page and select Boundaries 4 and 6. Set the Maximum element 

size to 3e-3 and the Element growth rate to 1.2.

3 Go to the Point page and select Point 4. Set the Maximum element size to 1e-3.

4 Click Remesh to generate the mesh. When the mesher has finished, click OK.

C O M P U T I N G  T H E  S O L U T I O N

Solve this model for a range of inlet velocities with the parametric solver. The solution 
procedure involves a first solution step that solves for the fluid velocity without any 
influence from temperature using only one inlet velocity. This is necessary to get a 
good initial value for the thermally coupled calculations. That solution then works in 
the parametric solver, which solves the problem as fully coupled for a set of inlet 
velocities.

1 Click the Solver Parameters button on the Main toolbar. 

2 From the Solver list, select Parametric segregated.

3 Select the Manual specification of segregated steps check box.

4 Set the Damping for Group 1 to 0.25.

5 In the Parameter name edit field type u_in, and in the Parameter values edit field 
type 1 20 50 100.

6 Click the Parametric tab. From the Predictor list, select Constant.

SETTINGS BOUNDARY 5 BOUNDARIES 4, 6

Object Plate bottom (hot side) Plate surface

Group wall

Boundary condition Temperature

 T0 T_amb+delta_T
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7 Select the Manual tuning of parameter step size check box. In the three edit fields 
(Initial step size, Minimum step size, and Maximum step size) type 2, 20, and 50, 
respectively. These settings force the parameter solver to take larger steps than it 
would do by default, which in turn reduces the solution time.

8 Click OK, then click the Solve button on the Main toolbar. The software needs 
roughly 30 minutes to solve this setup on a 3-GHz PC.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Reproduce the plots in Figure 2-16–Figure 2-19 using the Plot Parameters dialog box.

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, select 1 from the Parameter value list.

3 Click Apply to generate the plot in Figure 2-16.

Proceed to generate the plot in Figure 2-17 of the turbulent thermal conductivity, 
kT with the following steps:

4 On the General page, select 100 from the Parameter value list.

5 Click the Surface tab. Type kT_htgh in the Expression edit field on the Surface Data 
page, then click Apply to generate the plot.

Next reproduce Figure 2-18 as follows:

6 While still on the Surface page, type rho_htgh in the Expression edit field on the 
Surface Data page. 

7 On the General page, select 1 from the Parameter value list. Click Apply.

To generate Figure 2-19 execute the following instructions:

8 Click the Surface tab. From the Predefined quantities list on the Surface Data page, 
select k-ε Turbulence Model (chns)>Velocity field.

9 Click OK.

Use the Domain Plot Parameters dialog box to generate Figure 2-20–Figure 2-22:

1 From the Postprocessing menu, select Domain Plot Parameters.

2 On the Line/Extrusion page, select Boundary 6.

3 In the y-axis data area, type abs(ntflux_htgh)/(Ts-Tf)) in the Expression edit 
field. From the x-axis data list, select x.

4 Click the Line Settings button. From the Line style list, select Dashed line. Select the 
Legend check box, then click OK.

5 Click Apply to generate the first lines of the plot.
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6 On the General page, select the Keep current plot check box.

7 Return to the Line/Extrusion page. In the Expression edit field, type h_ref.

8 Click the Line Settings button. From the Line style list, select Solid line. Click OK.

9 Click Apply to finalize the plot in Figure 2-20.

Next, turn to the plot in Figure 2-21:

10 On the General page, clear the Keep current plot check box.

11 On the Line/Extrusion page, type dwplus_chns in the Expression edit field.

12 Click Apply.

Finally, you reproduce the plot in Figure 2-22 with the following steps:

13 From the Predefined quantities list select 
General Heat Transfer (htgh2)>Normal total heat flux.

14 Click the Line Settings button. From the Line style list select Dashed line, then click 
OK.

15 Click OK to close the Domain Plot Parameters dialog box and generate the plot.

If you want to overlay the results from the simplified model, keep the Figure 1 window 
open and then proceed as follows:

1 To open the other model, choose File>Open Model Library, browse to the location 
Model Library>Heat Transfer Module>Electronics and Power Systems> 
forced_turbulent_convection_hcoeff, and click OK.

2 From the Postprocessing menu, select Domain Plot Parameters.

3 On the General page, select Figure 1 from the Plot in list and select the Keep current 

plot check box.

4 On the Line/Extrusion page, select Boundary 3.

5 Select General Heat Transfer (htgh)>Normal total heat flux from the Predefined 

quantities list.

6 From the x-axis data list select x, then click OK.

Modeling Using the Graphical User Interface—Simplified Model

Model Library path: Heat_Transfer_Module/
Electronics_and_Power_Systems/forced_turbulent_convection_hcoeff
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You can build this model from scratch or modify the previous one. If you prefer to 
modify the previous model, simply alter the boundary settings of the second General 
Heat Transfer application mode and the solver settings so that you only solve for the 
htgh2 application mode.

To build the model from scratch, follow these steps:

M O D E L  N A V I G A T O R

1 Open the Model Navigator, and from the Space dimension list select 2D.

2 In the list of application modes select  
Heat Transfer Module>General Heat Transfer>Steady-state analysis. Click OK.

G E O M E T R Y

For this model it suffices to draw the plate because you model only the temperature in 
the solid plate.

Shift-Click the Rectangle/Square button on the Draw toolbar. Create a rectangle with 
the following specifications; when finished, click OK.

C O N S T A N T S ,  E X P R E S S I O N S ,  A N D  V A R I A B L E S

From the Options menu open the Constants dialog box. Specify the following names 
and expressions, then click OK.

P H Y S I C S

The default material settings are those for copper. This means you do not have to 
modify the material properties. However, for the model to run smoothly, it is 
important to specify a suitable initial value in the domain.

1 Select the menu item Physics>Subdomain Settings.

2 Select Subdomain 1.

3 Click the Init tab. In the T(t0) edit field type T_amb+delta_T, then click OK.

4 From the Physics menu open the Boundary Settings dialog box.

OBJECT WIDTH HEIGHT BASE X Y

R1 1 0.01 Corner 0 0

NAME EXPRESSION DESCRIPTION

T_amb 293[K] Surrounding air temperature

delta_T 100[K] Plate-to-air temperature difference
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5 Select Boundary 2 (the bottom of the plate). In the Boundary condition list select 
Temperature, then in the T0 edit field type T_amb+delta_T.

6 Select Boundary 3 (the fluid interface that is cooled). In the Boundary condition list 
select Heat flux.

7 To load a heat transfer coefficient function from the Materials/Coefficients Library, 
click the Load button to open the Materials/Coefficients Library dialog box.

8 Select the coefficient function with the name Forc. Plate, h_loc, s=position, 

U=velocity from the Heat Transfer Coefficients>Air, Ext. Forced Convection folder; then 
click OK.

9 When back in the Boundary Conditions dialog box, edit the last two input variables 
to the h_loc function so that the value in the h edit field becomes h_loc(T[1/
K],Tinf_htgh[1/K],x[1/m],u_in)[W/(m^2*K)]. The x coordinate and the inlet 
velocity replace the default input variables for length and velocity.

10 In the Tinf edit field and type T_amb, then click OK.

S O L U T I O N  A N D  PO S T P R O C E S S I N G

1 Open the menu item Solve>Solver Parameters. From the Solver list select Parametric.

2 Go to the Parameter name edit field and type u_in. In the Parameter values edit field 
type 1 20 50 100.

3 Click the Parametric tab. In the Predictor list select Constant.

4 Select Manual tuning of parameter step size check box. In all three edit fields (Initial 

step size, Minimum step size, and Maximum step size) type 50. This setting forces the 
parameter solver to take steps as large as possible, which reduces the solution time.

5 Click OK, then click the Solve button on the Main toolbar. The model solves in a few 
seconds.

6 To generate the part of Figure 2-22 related to these results, select 
Postprocessing>Domain Plot Parameters. Go to the Line/Extrusion page.

7 Select Boundary 3. Select Normal total heat flux (htgh) from the list of Predefined 

quantities.

8 From the x-axis data list select x, then click OK.
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S u r f a c e -Moun t  R e s i s t o r

Introduction

The drive for miniaturizing electronic devices has resulted in today’s extensive use of 
surface-mount electronic components. An important aspect in electronics design and 
the choice of materials is a product’s durability and lifetime. For surface-mount 
resistors and other components producing heat it is a well-known problem that 
temperature cycling can lead to cracks propagating through the solder joints, resulting 
in premature failure (Ref. 1). For electronics in general there is a strong interest in 
changing the soldering material from lead- or tin-based solder alloys to other mixtures.

The following multiphysics example models the heat transport and structural stresses 
and deformations resulting from the temperature distribution using the General Heat 
Transfer application mode and the Solid, Stress-Strain application mode.
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Model Definition

Figure 2-23 shows a photograph of a surface-mount resistor together with a diagram 
of it on a printed circuit board (PCB).

Figure 2-23: A photo and diagram of a typical surface-mounted resistor soldered to a 
PCB.

Table 2-2 shows the dimensions of the resistor and other key components in the model 
including the PCB.

TABLE 2-2:  COMPONENT DIMENSIONS

COMPONENT LENGTH WIDTH HEIGHT

Resistor (Alumina) 6 mm 3 mm 0.5 mm

PCB (FR4) 16 mm 8 mm 1.6 mm

Cu pad 2 mm 3 mm 35 µm

Ag termination 0.5 mm 3 mm 25 µm

Stand-off (gap to PCB) - - 105 µm
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The simulation uses a symmetry cut along the length of the resistor so that it needs to 
include only half of the component (Figure 2-24).

Figure 2-24: The simulation models only half the resistor.

In operation, the resistor dissipates 0.2 W of power as heat. Conduction to the PCB 
and convection to the surrounding air provide cooling. In this model, the heat transfer 
occurs through conduction in the subdomains. The model simplifies the surface 
cooling and describes it using a heat transfer coefficient, h, in this case set to 5 W/
(m2·K); the surrounding air temperature, Tinf, is at 300 K. The resulting heat-transfer 
equation and boundary condition (included in the model using the General Heat 
Transfer application mode) are

where k is the thermal conductivity, and Q is the heating power per unit volume of the 
resistor (set to 16.7 MW/m3 corresponding to 0.2 W in total).

The model handles thermal expansion using a static structural analysis using the Solid, 
Stress-Strain application mode (a description of the corresponding equations is 

∇ k∇T–( )⋅ Q=

n– k∇T–( )⋅ h Tinf T–( )=
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available in the Structural Mechanics Module User’s Guide). The thermal and 
mechanical material properties in this model are:

The model treats properties of air as temperature dependent according to the 
following equations (Ref. 3):

with p0 = 1 atm, Mw = 0.0288 kg/mol, and R = 8.314 J/(mol·K). Further,

The stresses are zero at 293 K. The boundary condition for the Solid, Stress-Strain 
application mode is that both ends, in the length direction of the circuit board, are 
fixed with respect to x, y, and z.

Note: This model requires the Heat Transfer Module and the Structural Mechanics 
Module.

TABLE 2-3:  MATERIAL PROPERTIES

MATERIAL E (GPa) n α (ppm) k (W/(m·K)) ρ (kg/m3) Cp (J/(kg·K))

Ag 83 0.37 18.9 420 10500 230

Alumina 300 0.222 8.0 27 3900 900

Cu 110 0.35 17 400 8700 385

Fr4 22 0.28 18 0.3 1900 1369

60Sn-40Pb 10 0.4 21 50 9000 150

ρ
p0Mw

RT
----------------=

Cp 1100 J/(kg·K)=

k 10 3.723 + – 0.865 log T( )  W/(m·K)=
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Results and Discussion

The isosurfaces in Figure 2-25 show the temperature distribution at steady state. The 
highest temperature is approximately 424 K, appearing in the center of the resistor. 
The circuit board also heats up significantly.

Figure 2-25: Temperature distribution in the resistor and the circuit board at steady state.
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Thermal stresses appear as a result of the temperature increase; they arise from the 
materials’ different expansion coefficients. Figure 2-26 plots the effective stress (von 
Mises) together with the resulting deformation of the assembly.

Figure 2-26: The thermally induced distribution of von Mises effective stress together with 
the deformation (magnified) and the isotherms.

The highest stresses seem to occur in the termination material. It is interesting to 
compare these effective stresses to the yield stress and thereby investigate whether or 
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not the material is irreversibly deformed. In that case the solder is the weak point. The 
following graph plots the stress in the solder points alone.

Figure 2-27: Close-up of the von Mises effective stresses in the solder joint.

The yield stress for solder is approximately 220 MPa. The highest effective stress seems 
to fall in the range near 220 MPa. This means that the assembly functions without 
failure for the tested power loads. However, if the heating power increases slightly, 
permanent deformation and possibly failure occur.
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Modeling in COMSOL Multiphysics

Use the predefined multiphysics coupling Thermal-Structure Interaction to set up the 
model. The General Heat Transfer application mode and the Solid, Stress-Strain 
application mode are then automatically added to the model, with the temperature 
variable from the heat equation predefined as the strain temperature in the equation 
for the structural deformations.

Take advantage of the assembly functionality and interactive meshing tools to create a 
swept mesh for the geometry; in this way you can keep the memory requirements for 
solving the problem at a minimum.

The default solver settings use the segregated stationary solver to solve the heat 
equation first, because it does not depend on the structural analysis. The GMRES 
iterative solver with the Geometric multigrid preconditioner is the default for the heat 
equation. This iterative solver requires less memory for solving the equation than a 
direct solver. Select the same solver combination also for the structural mechanics 
equation to further reduce the memory needed. In order that it work well with the 
mesh of the model, you can tune the Geometric multigrid preconditioner; read more 
in the sections “The GMRES Iterative Solver” on page 548 of the COMSOL 
Multiphysics Reference Guide and “The Preconditioned Linear System” on page 435 
of the COMSOL Multiphysics User’s Guide.

Model Library path: Heat_Transfer_Module/
Electronics_and_Power_Systems/surface_resistor

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator.

2 On the New page, select 3D from the Space dimension list.

3 Select Structural Mechanics Module>Thermal-Structural Interaction>Solid, Stress-Strain 

with Thermal Expansion>Static analysis.

4 Click OK.
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O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, choose Constants.

2 Define the following constants (the descriptions are optional); when done, click OK.

G E O M E T R Y  M O D E L I N G

1 From the Draw menu, select Work Plane Settings.

2 On the Quick page, click the y-z option button in the Plane area.

3 Click OK.

COMSOL Multiphysics adds a new 2D geometry to the model. Use this geometry 
to draw the cross section of the resistor geometry.

4 Create four rectangles. Shift-click the Rectangle/Square button on the Draw toolbar 
for each one and enter the data from this table:

5 Click the Zoom Extents button on the Main toolbar.

6 Copy rectangle R4 by selecting it and then pressing Ctrl+C.

7 Click the Create Composite Object button on the Draw toolbar. (Alternatively, select 
Create Composite Object from the Draw menu.)

8 In the Set formula edit field type R3-R4, then click OK.

9 Paste a copy of R4 with zero displacement. To do so, press Ctrl+V, then click OK in 
the Paste dialog box.

10 Click the 2nd Degree Bézier Curve button on the Draw toolbar.

11 Draw a curve between the upper corner of the termination and the left corner of the 
copper plate as in the figure below. You may want to zoom in the area before you 
start drawing the curve. Draw the line by clicking the coordinates 

NAME EXPRESSION DESCRIPTION

T_air 293[K] Air temperature

h_air 5[W/(m^2*K)] Heat transfer coefficient

q_source 0.2[W]/(0.5*3*8[mm^3]) Heating power per unit volume

p0 1[atm] Air pressure

RECTANGLE WIDTH HEIGHT X Y

R1 0.002 35e-6 0 0

R2 5.25e-4 4.5e-5 9.75e-4 3.5e-5

R3 5.25e-4 5.5e-4 9.75e-4 8e-5

R4 6e-3 5e-4 1e-3 1.05e-4
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(9.75·10−4, 6.3·10−4), (8·10−4, 2·10−4), and (0, 3.5·10−5). The coordinates that 
the mouse is pointing to appears in the lower left corner of the user interface.

12 After clicking the third coordinate pair click the Line button on the Draw toolbar. 
This allows you to continue the drawing with lines along the copper plate boundary 
and the termination boundary. Click on the coordinates  
(9.75·10−4, 3.5·10−5) and (9.75·10−4, 6.3·10−4). Then complete the drawing by 
right-clicking using the mouse. The drawing should now look like in this figure:

13 Copy the objects R1, R2, CO1, and CO2 by selecting them and pressing Ctrl+C.

14 Press Ctrl+V to open the Paste dialog box. Go to the Displacement area and in the 
x edit field type 0.006. Click OK.

15 From the Draw menu, select Modify>Scale. Find the Scale factor area, then in the 
x edit field type -1. Go to the Scale base point area and in the x edit field type 0.007. 
Click OK.

16 Click the Zoom Extents button on the Main toolbar.

17 Click the Line button on the Draw toolbar and draw a line between the coordinates 
(0.002, 0) and (0.006, 0).

18 To finalize the geometry select all the objects by pressing Ctrl+A and click the Coerce 

to Solid button on the Draw toolbar.
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19 Shift-click the Rectangle/Square button. Specify settings according to the following 
table. When done, click OK.

20 From the Draw menu, open the Extrude dialog box.

21 From the Objects to extrude list, select CO5. In the Distance edit field type 1.5e-3, 
then click OK.

22 Return to the 2D geometry by clicking the Geom2 tab.

23 From the Draw menu, open the Extrude dialog box.

24 Select R1 from the Objects to extrude list and type 4e-3 in the Distance edit field. 
Click OK.

M E S H  G E N E R A T I O N

1 From the Draw menu, select Create Pairs. Select both EXT1 and EXT2. Clear the 
Create imprints check box so that the meshes of the two extruded objects do not 
have to match at their shared boundary. This makes the mesh generation easier and 
reduces the number of elements.

2 Click OK.

3 From the Mesh menu, open the Free Mesh Parameters dialog box and click the 
Boundary tab.

4 Select Boundaries 7, 10, 13, 16, 33, 37, 40, and 48, then click the Mesh Selected 
button.

5 Now select Boundaries 20 and 24 and click the Mesh Selected button again.

6 Click OK to close the Free Mesh Parameters dialog box.

7 Open the Mapped Mesh Parameters dialog box from the Mesh menu, then click the 
Edge tab.

8 Select 1 from the Edge selection list. Select the Constrained edge element distribution 

check box and set the Number of edge elements to 5.

9 Repeat Step 8 for Edge 2, and set the number of edge elements to 30.

10 Click the Boundary tab and select 1 from the Boundary selection list.

11 Click Mesh Selected, then click OK.

12 From the Mesh menu, open the Swept Mesh Parameters dialog box.

13 Select Subdomain 1, then press Ctrl+A to select all subdomains.

WIDTH HEIGHT BASE X Y

16e-3 1.6e-3 Center 4e-3 -8.0e-4
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14 Select the Manual specification of element layers check box and set the Number of 

element layers to 10. Click OK.

15 Click the Subdomain Mode button on the Main toolbar.

16 Select only the PCB domain, that is, the largest subdomain.

17 Click Mesh>Interactive Meshing>Mesh Selected (Swept).

18 Click Mesh>Interactive Meshing>Mesh Remaining (Swept).

The meshed geometry in the drawing area should now look like that in the following 
figure:

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Multiphysics menu, select Geom2: Solid, Stress-Strain (smsld).

2 From the Physics menu, select Subdomain Settings.

3 Select all subdomains, then click the Load tab (not the Load button). In the Tempref 
edit field, type T_air.

4 Click the Material tab.

5 Select Subdomain 1. Click the Load button to open the Materials/Coefficients Library 
dialog box. Select Basic Material Properties>FR4 (Circuit Board). Click OK.
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6 Repeat the previous step for the other subdomains with materials according to the 
following table (the material data for silver, Ag, is available in the Metals section of 
the MEMS Material Properties library):

7 Select Subdomain 7, then clear the Active in this domain check box.

8 Click OK to close the dialog box.

9 Change the active application mode. From the Multiphysics menu select Geom2: 

General Heat Transfer (htgh).

10 From the Physics menu, select Subdomain Settings. Go to the General page, select 
Subdomain 1, and then select FR4 (Circuit Board) from the Library material list.

11 Repeat for the other subdomains according to:

For Subdomain 7, change the name of the pressure variable in the expression for the 
density from p to p0, the air pressure, so that the expression in the ρ edit field 
becomes rho(p0[1/Pa],T[1/K])[kg/m^3].

12 Go to the Init page. Select all subdomains and in the Temperature edit field, type 
T_air. Click OK.

Boundary Conditions
1 From the Physics menu, open the Boundary Settings dialog box.

2 Select the exterior boundaries in contact with air, that is, Boundaries 3, 4, 8, 12, 19, 
29, 30, 44, 46, and 52–63. From the Boundary condition list, select Heat flux.

3 In the Heat transfer coefficient edit field type h_air, and in the External temperature 

edit field type T_air. Click OK.

4 In the Multiphysics menu, change the active application mode to 
Geom2: Solid, Stress-Strain (smsld).

5 From the Physics menu, open the Boundary Settings dialog box.

6 Select Boundaries 1, 7, 10, 13, 16, 20, 33, 37, 40, and 48. From the Constraint 

condition list, select Symmetry plane.

PROPERTY SUBDOMAINS 2, 8 SUBDOMAINS 3, 4, 9, 11 SUBDOMAINS 5, 10 SUBDOMAIN 6

Material Copper Solder, 60Sn-40Pb Ag Alumina

PROPERTY SUBDOMAINS 
2, 8

SUBDOMAINS 
3, 4, 9, 11

SUBDOMAINS 
5, 10

SUBDOMAIN 6 SUBDOMAIN 7

Material Copper Solder, 
60Sn-40Pb

Ag Alumina Air

Q 0 0 0 q_source 0
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7 Select Boundaries 2 and 5. From the Constraint condition list, select Fixed. Click OK.

C O M P U T I N G  T H E  S O L U T I O N

Change the default solver settings to reduce the memory requirements for solving the 
model.

1 Click the Solver Parameters button on the Main toolbar.

2 Locate the Segregated groups area on the General page and click the Settings button 
for Group 1.

3 In the Linear System Solver Settings dialog box that opens, choose Right from the 
Preconditioning list; click OK.

4 Click the Settings button for Group 2.

5 In the dialog box that opens, select GMRES from the Linear system solver list.

6 From the Preconditioning list, select Right.

7 In the Linear system solver tree on the left, select Preconditioner.

8 From the Preconditioner list, select Geometric multigrid.

9 Click OK to close the Linear System Solver Settings dialog box.

10 Click OK to close the Solver Parameters dialog box.

11 Click the Solve button on the Main toolbar. 

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To reproduce the temperature plot in Figure 2-25, follow these instructions:

1 From the Postprocessing menu, open the Plot Parameters dialog box.

2 Click the General tab.

3 In the Plot type area, clear the Slice check box and select the Isosurface check box.

4 Click the Isosurface tab.

5 From the Predefined quantities list, select General Heat Transfer (htgh)>Temperature.

6 In the Isosurface levels area, click the Levels button, then type 30 in the Number of 

levels edit field.

7 In the Isosurface color area, set the Colormap to hot.

8 Click Apply.

9 Click the Scene Light button on the Camera toolbar to finish off the plot.

Reproduce Figure 2-26 with these steps:
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1 While still on the Isosurface page in the Plot Parameters dialog box, change the 
Number of levels to 15.

2 In the Coloring and fill area, set the Fill style to Wireframe.

3 Click the Subdomain tab and enable this plot type by selecting the Subdomain plot 
check box at the top of the dialog box. From the Predefined quantities list, select 
Solid, Stress-Strain (smsld)>von Mises stress. From the Unit list, select MPa.

4 Click the Deform tab and select the Deformed shape plot check box.

5 In the Domain types to deform area clear the Boundary and Edge check boxes. 

6 In the Deformation data area click the Subdomain Data.

7 From the Predefined quantities list, select Solid, Stress-Strain (smsld)>Displacement.

8 Click OK.

Finally, to reproduce Figure 2-27, do the following:

1 From the Options menu, select Suppress>Suppress Subdomains.

2 Select Subdomains 1, 2, 5, 6, 7, 8, and 10, then click OK.

3 From the Postprocessing menu, open the Plot Parameters dialog box.

4 On the General page, clear the Isosurface and Deformed Shape check boxes in the Plot 

type area.

5 Click OK to generate the plot.
S U R F A C E - M O U N T  R E S I S T O R  |  77



78 |  C H A P T E R
F r e e  Con v e c t i o n  i n  a  L i g h t  Bu l b

Introduction

This model simulates the nonisothermal flow of argon gas inside a light bulb. The 
purpose of the model is to show the coupling between energy transport—through 
conduction, radiation, and convection—and momentum transport induced by density 
variations in the argon gas.

Model Definition

A light bulb contains a tungsten filament that is resistively heated when a current is 
conducted through it. At temperatures around 2000 K the filament starts to emit 
visible light. To prevent the tungsten wire from burning up, the bulb is filled with a 
gas, usually argon. The heat generated in the filament is transported to the 
surroundings through radiation, convection, and conduction. As the gas heats up, 
density and pressure changes induce a flow inside the bulb.

Figure 2-28 shows a cross section of the axially symmetric model geometry.

Figure 2-28: The model geometry.
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The filament is approximated with a solid torus, an approximation that implies 
neglecting any internal effects inside the filament wire.

The equations governing the nonisothermal flow in the argon gas are

where ρ denotes the density (kg/m3), u the velocity (m/s), η the viscosity (Pa·s), p 
the pressure (Pa), and g the gravity vector (m/s2). The density is given by the ideal 
gas law

where M denotes the molar weight (kg/mol), R the universal gas constant (J/
(mol·K)) and T the temperature (K).

The convective and conductive heat transfer inside the bulb is described by the 
equation

where Cp denotes the heat capacity (J/(kg·K)), k is the thermal conductivity (W/
(m·K)), and Q refers to the power density (W/m3) in the filament that serves as a heat 
source. Assuming a total light bulb power of 60 W and a uniform power density leads 
to 

where r is the filament’s radius and 2πRo gives its perimeter around the bulb.

B O U N D A R Y  C O N D I T I O N S

At the bulb’s inner surfaces, radiation is described by surface-to-surface radiation. This 
means the mutual irradiation from the surfaces that can be seen from a particular 
surface, and radiation to the surroundings are accounted for. At the outer surfaces of 
the bulb, radiation is described by surface-to-ambient radiation, which means that 
there is no reflected radiation from the surroundings (blackbody radiation).

ρ u∂
t∂

------ ρ u u∇⋅( ) p ∇ η u u∇( )T+∇( ) 2η
3

------- ∇ u⋅( )I– ρg+⋅+∇–=+

ρ∂
t∂

------ ∇+ ρu( ) 0=⋅

ρ Mp
RT
---------=

ρCp
∂T
∂t
------- ∇ k∇T–( )⋅+ ρCpu ∇T Q+⋅–=

Q 60 W

πr22πRo

-----------------------=
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The top part of the bulb where the bulb is mounted on the cap is assumed to be 
insulated:

Results

The heating inside the bulb has a long and a short time scale from t = 0, when the light 
is turned on. The shorter scale captures the heating of the filament and the gas close 
to it. The following series of pictures shows the temperature distribution inside the 
bulb at t = 2, 6, and 10 s.

Figure 2-29: Temperature distribution at t = 2, 6, and 10 s. The temperature ranges 
between 298 (black) and 2010 K (yellow).

When the temperature changes, the density of the gas changes, inducing a gas flow 
inside the bulb. The following series of pictures shows the velocity field inside the bulb 
after 2, 6, and 10 s.

Figure 2-30: Velocity field after 2, 6, and 10 s. The velocity ranges between 0 and 0.24 m/s.

n– k∇T–( )⋅ 0=
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On the longer time scale, the glass on the bulb’s outer side heats up. The following 
plot shows the temperature distribution in the bulb after 5 minutes.

Figure 2-31: Temperature distribution after 5 minutes.

Figure 2-32 shows the temperature distribution at a point on the boundary of the bulb 
at the same vertical level as the filament. This plot shows the slow heating of the bulb. 
After 5 minutes, the bulb has reached a steady-state temperature of 580 K.
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Figure 2-32: Temperature distribution at a point on the boundary of the bulb at the same 
vertical level as the filament.

Heat is transported from the boundary of the bulb through both convective heat flux 
and radiation. The net radiative heat flux leaving the bulb at t = 300 s is plotted in 
Figure 2-33, as function of the z-coordinate. The top boundaries of the bulb where 
the bulb is mounted on the cap are excluded from this plot. The distinct bump in the 
curve occurs at the same vertical level as the filament.
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Figure 2-33: The net radiative heat flux leaving the bulb.

Modeling in COMSOL Multiphysics

To set up the model, use the Heat Transfer Module’s Non-Isothermal Flow predefined 
multiphysics coupling. The model uses material from the Material Library to accurately 
account for temperature-dependent properties over a wide range. The model setup is 
straightforward and also shows how to create your own material to treat argon as an 
ideal gas. When working with surface-to-surface radiation in COMSOL Multiphysics, 
you have to specify which subdomains are transparent and which are opaque. 
Furthermore, to allow for surface-to-surface radiation, an opaque subdomain must be 
adjacent to a transparent subdomain. To achieve this, you can set the argon gas to be 
transparent and the glass and filament to be opaque. The assumption that the glass on 
the bulb is opaque, might seem odd, but is in fact valid because glass is almost opaque 
to heat radiation, but transparent to radiation in the visible spectrum.
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Model Library path: Heat_Transfer_Module/
Electronics_and_Power_Systems/light_bulb

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 In the Model Navigator, select Axial symmetry (2D) from the Space dimension list.

2 From the Application Modes list, select Heat Transfer Module>Fluid-Thermal 

Interaction>Non-Isothermal Flow>Transient analysis.

3 Click OK.

G E O M E T R Y  I M P O R T

The model geometry is available as a CAD file. Import it to the COMSOL 
Multiphysics user interface by following these steps:

1 Choose File>Import>CAD Data From File.

2 Locate the COMSOL Multiphysics installation directory on your system, browse to 
the folder models/Heat_Transfer_Module/Tutorial_Models, and select the file 
light_bulb.mphbin.

3 Click Import.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

2 Enter constants according to the following table (the descriptions are optional); 
when done, click OK.

NAME EXPRESSION DESCRIPTION

rho_glass 2595[kg/m^3] Density, glass

k_glass 1.09[W/(m*K)] Thermal conductivity, glass

cp_glass 750[J/(kg*K)] Heat capacity, glass

h0 5[W/(m^2*K)] Heat transfer coefficient

eps_glass 0.8 Surface emissivity, glass

vol pi*(0.5[mm])^2*2*pi*10[mm] Filament volume

Q 60[W]/vol Heat source in filament
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3 From the Options menu, open the Scalar Expressions dialog box.

4 Specify the density according to the following table; when done, click OK.

P H Y S I C S  S E T T I N G S — G E N E R A L  H E A T  TR A N S F E R

1 Open the Subdomain Settings dialog box.

2 Select all Subdomains and click the Init tab.

3 In the Temperature edit field, type 25[degC].

4 Click the Convection tab.

5 Select Subdomains 1 and 3.

6 Clear the Enable convective heat transfer check box.

7 Select Subdomain 2.

8 In the Absolute pressure edit field, type p.

9 Click the General tab.

10 Select Subdomain 1.

11 Enter parameters according to the following table:

12 Select Subdomain 3.

13 Click the Load button to open the Materials/Coefficients Library.

14 In the Materials area, select Material Library>Elements>Tungsten.

15 Click OK.

g 9.81[m/s^2] Gravitational constant

R 8.314[J/(mol*K)] Universal gas constant

p0 50[kPa] Initial pressure

k_tungsten 179[W/(m*K)] Thermal conductivity, 
tungsten

Mw_a 39.94[g/mol] Molar mass, argon (ideal gas)

NAME EXPRESSION DESCRIPTION

NAME EXPRESSION DESCRIPTION

rho_a p*Mw_a/(R*T) Density of argon, ideal gas

QUANTITY VALUE/EXPRESSION DESCRIPTION

 k k_glass Thermal conductivity

 ρ rho_glass Density

 Cp cp_glass Heat capacity at constant pressure
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16 In the Thermal conductivity edit field, type k_tungsten.

17 In the Heat source edit field, type Q.

18 Select Subdomain 2.

19 Click the Load button to open the Materials/Coefficients Library.

20 Select Material Library>Elements>Argon.

21 From the Phase/Condition list, select gas.

22 Click OK.

23 From the Opacity list, select Transparent.

24 Click OK.

When modeling surface-to-surface radiation, it is important that a solid Subdomain is 
adjacent to a transparent Subdomain. In this case, the argon gas is modeled as a 
transparent domain.

1 Open the Boundary Settings dialog box.

2 Select Boundaries 1–6.

3 From the Boundary condition list, select Axial symmetry.

4 Select the Interior boundaries check box.

5 Define boundary settings for the glass boundaries according to the following table:

6 Select Boundaries 15–18 from the list (the filament boundaries).

7 From the Boundary condition list, select Heat source/sink.

8 From the Library coefficient list, select Tungsten.

9 Set the Radiation type to Surface-to-surface.

10 In the Tinf edit field type 25[degC], and in the Tamb edit field type T.

11 Click OK.

SETTINGS BOUNDARIES 8, 9, 12–14, 19, 21, 22–24 BOUNDARIES 11, 25

Boundary condition Heat source/sink Heat flux

h 0 h0

Tinf 25[degC] 25[degC]

Radiation type Surface-to-surface Surface-to-ambient

 ε eps_glass eps_glass

Tamb T 25[degC]
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This completes the setup of the heat-transfer problem. Next, edit the material 
properties for argon to model it as an ideal gas.

1 From the Options menu, select Materials/Coefficients Library.

2 In the Materials area, select Model (2)>Argon (mat2).

3 Select the Hide undefined properties check box.

4 In the Value/Expression edit field for rho, substitute the existing expression with 
rho_a.

5 Click OK.

Because you have altered the material properties for tungsten, you must reload the 
material on the appropriate subdomain.

6 Open the Subdomain Settings dialog box and select Subdomain 2.

7 From the Library material list, select the blank entry to alter the settings in the 
material-property edit fields.

8 From the Library material list, select Argon to obtain the updated material properties.

9 Click OK.

P H Y S I C S  S E T T I N G S — W E A K L Y  C O M P R E S S I B L E  N A V I E R - S T O K E S

1 From the Model Tree, select Weakly Compressible Navier-Stokes (chns).

2 Open the Subdomain Settings dialog box by double-clicking Subdomain Settings 
under Weakly Compressible Navier-Stokes (chns) in the Model Tree.

3 Select Subdomains 1 and 3.

4 Deactivate the two solid domains by clearing the Active in this domain check box.

5 Select Subdomain 2.

6 From the Library material list, select Argon.

7 In the Volume force, z dir. edit field, type -rho_chns*g.

8 Click the Init tab.

9 In the Pressure edit field, type p0.

10 Click OK.

11 Open the Boundary Settings dialog box.

12 Select Boundaries 2–4.

13 In the Boundary type list, select Symmetry boundary.

14 From the Boundary condition list, select Axial symmetry.

15 Click OK.
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This completes the setup for the momentum transport. You do not need to fix the 
pressure at a point because it is implicitly defined through the ideal gas law.

M E S H  G E N E R A T I O N

1 Open the Free Mesh Parameters dialog box.

2 Select Boundaries 12 and 24.

3 Click the Distribution tab.

4 Select the Constrained edge element distribution check box.

5 In the Number of edge elements edit field, enter 50.

6 Select Boundaries 15–18 (the filament boundary).

7 Select the Constrained edge element distribution check box.

8 In the Number of edge elements edit field, enter 2.

9 Click the Remesh button.

10 Click OK.

S O L V I N G  T H E  M O D E L

1 Open the Solver Parameters dialog box.

2 In the Times edit field, type 0:0.1:1 1.5:0.5:20 21:3:300.

3 In the Relative tolerance field, type 1e-5.

4 In the Absolute tolerance edit field, type T 1e-4 J 1e-4 u 1e-4 v 1e-4 p 1e-3.

The default absolute tolerance value is 10−4 for all dependent variables. To make this 
model converge quickly, you increase the tolerance for the pressure by a factor 10.

5 From the Linear system solver list, select Direct (UMFPACK).

6 Click the Time Stepping tab.

7 In the Time step edit field, enter if(t<10,10,100)*dt_cfl_g1_chns. This means 
that the time step is 10 times the CFL number for the first 10 seconds, and then 100 
times the CFL number.

8 Click OK.

9 Because of the small dimensions in the model, also adjust the viscous velocity factor. 
To do so, choose Scalar Variables from the Physics menu.

10 In the Application Scalar Variables dialog box, enter 0.1 in the Viscous velocity factor 
edit field.

11 Click OK.

12 Click the Solve button on the Main toolbar to solve the model.
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PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To produce the series of pictures in Figure 2-29, proceed as follows:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, select 2 from the Solution at time list.

3 Click the Surface tab.

4 From the Predefined quantities list, select General Heat Transfer (htgh)>Temperature.

5 Click the Range button.

6 Clear the Auto check box. Enter 298 and 2010 in the Min and Max edit fields, 
respectively. Click OK.

7 From the Colormap list, select hot.

8 Click Apply to generate the leftmost plot.

You can produce the middle and rightmost plots in Figure 2-29 by repeating the above 
steps but selecting 6 and 10, respectively, from the Solution at time list.

The three snapshots in Figure 2-30 are produced following these steps:

1 On the General page, select 2 from the Solution at time list.

2 On the Surface page, select Weakly Compressible Navier-Stokes (chns)>Velocity field.

3 Click the Range button.

4 Enter 0 and 0.24 in the Min and Max edit fields, respectively. Click OK.

5 From the Colormap list, select jet.

6 Click Apply to generate the leftmost plot.

The two other plots in the same picture are created by selecting 6 and 10 from the 
Solution at time list respectively.

Figure 2-31 shows the temperature distribution in the bulb after 5 minutes. To 
produce this plot, do the following:

1 On the General page, select 300 from the Solution at time list.

2 Click the Surface tab.

3 From the Predefined quantities list, select General Heat Transfer (htgh)>Temperature.

4 From the Colormap list, select hot.

5 Click OK.
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Figure 2-32 shows how the temperature evolves over time at a point on the outer 
boundary of the bulb at the same vertical level as the filament. To produce this plot, 
follow these instructions:

1 From the Postprocessing menu, open the Domain Plot Parameters dialog box.

2 Click the Point tab.

3 From the Predefined quantities list, select General Heat Transfer (htgh)>Temperature.

4 From the Point selection list, select Point 24.

5 Click Apply.

Figure 2-33 shows the net radiative heat flux on the outer boundary of the bulb after 
5 minutes. You can create this plot with the following instructions:

1 Click the General tab.

2 Select 300 from the Solutions to use list.

3 Click the Line/Extrusion tab.

4 From the Predefined quantities list, select General Heat Transfer (htgh)>Radiative flux.

5 From the Boundary selection list, select 11 and 25.

6 In the x-axis data area, first click the lower option button and then click the 
Expression button to open the X-Axis Data dialog box.

7 From the Predefined quantities list, select Geometry and Mesh>z-coordinate and from 
the Unit list select cm. Click OK.

8 Click OK.
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Hea t i n g  C i r c u i t

Introduction

Small heating circuits find use in many applications. For example, in manufacturing 
processes they heat up reactive fluids. Figure 2-34 illustrates a typical heating device 
for this application. The device consists of an electrically resistive layer deposited on a 
glass plate. The layer causes Joule heating when a voltage is applied to the circuit. The 
layer’s properties determine the amount of heat produced.

Figure 2-34: Geometry of a heating device.

In this particular application, you must observe three important design considerations:

• Noninvasive heating

• Minimal deflection of the heating device

• Avoidance of overheating the process fluid

The heater must also work without failure. You achieve the first and second 
requirements by inserting a glass plate between the heating circuit and the fluid; it acts 
as a conducting separator. Glass is an ideal material for both these purposes because it 
is nonreactive and has a low thermal-expansion coefficient.

You must also avoid overheating due to the risk of self-ignition of the reactive fluid 
stream. Ignition is also the main reason for separating the electrical circuit from direct 
contact with the fluid. The heating device is tailored for each application, making 
virtual prototyping very important for manufacturers.

For heating circuits in general, detachment of the resistive layer often determines the 
failure rate. This is caused by excessive thermally induced interfacial stresses. Once the 
layer has detached, it gets locally overheated, which accelerates the detachment. 
Finally, in the worst case, the circuit might overheat and burn. From this perspective, 

Glass plate

Electric heater

Heated fluid
stream

Air
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it is also important to study the interfacial tension due to the different 
thermal-expansion coefficients of the resistive layer and the substrate as well as the 
differences in temperature. The geometric shape of the layer is a key parameter to 
design circuits that function properly. You can investigate all of the above-mentioned 
aspects by modeling the circuit.

This multiphysics example simulates the electrical heat generation, the heat transfer, 
and the mechanical stresses and deformations of a heating circuit device. The model 
uses the General Heat Transfer application mode of the Heat Transfer module in 
combination with the Shell, Conductive Media DC application mode from the AC/
DC Module and the Solid, Stress-Strain and Shell application modes from the 
Structural Mechanics Module.

Note: This model requires the AC/DC Module, the Heat Transfer Module, and the 
Structural Mechanics Module.

Model Definition

Figure 2-35 shows a drawing of the modeled heating circuit. 

Figure 2-35: Drawing of the heating circuit deposited on a glass plate.

The device consists of a serpentine-shaped Nichrome resistive layer, 10 µm thick and 
5 mm wide, deposited on a glass plate. At each end, it has a silver contact pad 
measuring 10 mm × 10 mm × 10 µm. When the circuit is in use, the deposited side of 
the glass plate is in contact with surrounding air, and the back side is in contact with 
the heated fluid. Assume that the edges of the glass plate are thermally insulated.

Silver pads

Nichrome circuit
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Table 2-4 gives the resistor’s dimensions.

During operation the resistive layer produces heat. Model the electrically generated 
heat using the Shell, Conductive Media DC application mode from the AC/DC 
Module. The governing equation is

where  d is the thin layer’s thickness (m), σ is the electric conductivity (S/m), V is the 
electric potential (V), and  denotes the gradient operator in the tangential 
directions. An actual applies 12 V to the pads. In the model you achieve this effect by 
setting the potential at one edge of the first pad to 12 V and that of one edge of the 
other pad to 0 V.

To model the heat transfer in the thin conducting layer, use the Highly Conductive 
Layer feature of the General Heat Transfer application mode. It is then not necessary 
to add a separate application mode for it.

The heat power per unit area (measured in W/m2) produced inside the thin layer is 
given by

 (2-1)

where QDC = J · E =  (W/m3) is the power density. The generated heat 
appears as an inward heat flux at the surface of the glass plate. 

At steady state, the resistive layer dissipates the heat it generates in two ways: on its up 
side to the surrounding air (at 293 K), and on its down side to the glass plate. The glass 
plate is similarly cooled in two ways: on its circuit side by air, and on its back side by a 
process fluid (353 K). You model the heat fluxes to the surroundings using heat 
transfer film coefficients, h. For the heat transfer to air, h = 5 W/(m2·K), representing 
natural convection. On the glass plate’s back side, h = 20 W/(m2·K), representing 
convective heat transfer to the fluid. The sides of the glass plate are insulated.

TABLE 2-4:  DIMENSIONS

OBJECT DIMENSION SIZE

glass plate length 130 mm

width 80 mm

thickness 2 mm

pads and circuit thickness 10 µm

∇t dσ∇tV–( )⋅ 0=

∇t

qprod d QDC=

σ ∇tV
2
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The resulting heat transfer equation for the device, together with the boundary 
condition used to describe the heat fluxes at the front and back sides, is

where n is the normal vector of the boundary, k is the thermal conductivity (W/
(m·K)), h is the heat transfer film coefficient (W/(m2·K)), and Tinf is the temperature 
(K) of the surrounding medium. The last term on the right-hand side represents the 
additional flux given by the thin conducting layer, and the constant ks is the thermal 
conductivity in the layer (W/(m·K)). This term is only present on the boundaries 
where the layer is present. Similarly, the inward heat flux, q0, is equal to qprod (see 
Equation 2-1) at the layer but vanishes elsewhere.

The model simulates thermal expansion using static structural-mechanics analyses. It 
uses the Solid, Stress-Strain application mode for the glass plate, and the Shell 
application mode for the circuit layer. The equations of these two application modes 
are described in the Structural Mechanics Module User’s Guide. The stresses are set 
to zero at 293 K. You determine the boundary conditions for the Solid, Stress-Strain 
application mode by fixing one corner with respect to x-, y-, and z-displacements and 
rotation.

Table 2-5 summarizes the material properties used in the model.

TABLE 2-5:  MATERIAL PROPERTIES

MATERIAL E [GPa]  ν α [ppm] k [W/(m·K)] ρ [kg/m3] Cp [J/(kg·K)]

Silver 83 0.37 18.9 420 10500 230

Nichrome 213 0.33 10.0 15 9000 20

Glass 73.1 0.17 55 1.38 2203 703

∇ k∇T–( )⋅ 0=

n– k∇T–( )⋅ q0 h Tinf T–( ) ∇t ds ks∇tT–( )⋅–+=
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Results and Discussion

Figure 2-36 shows the heat that the resistive layer generates.

Figure 2-36: Stationary heat generation in the resistive layer when 12 V is applied.

The highest heating power arises in the inner corners of the curves due to the higher 
current density at these spots. The total generated heat, as calculated by integration, is 
approximately 13.8 W.
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Figure 2-37 shows the temperature of the resistive layer and the glass plate at steady 
state.

Figure 2-37: Temperature distribution in the heating device at steady state.

The highest temperature is approximately 430 K, and it appears in the central section 
of the circuit layer. It is interesting to see that the differences in temperature between 
the fluid side and the circuit side of the glass plate are quite small because the plate is 
very thin. Using boundary integration, the integral heat flux on the fluid side evaluates 
to approximately 8.5 W. This means that the device transfers the majority of the heat 
it generates—8.5 W out of 13.8 W—to the fluid, which is good from a design 
perspective, although the thermal resistance of the glass plate results in some losses.

The temperature rise also induces thermal stresses due the materials’ different 
coefficients of thermal expansion. As a result, mechanical stresses and deformations 
arise in the layer and in the glass plate. Figure 2-38 shows the effective stress 
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distribution in the device and the resulting deformations. During operation, the glass 
plate bends towards the air side.

Figure 2-38: The thermally induced von Mises effective stress plotted with the deformation.

The highest effective stress, approximately 7 MPa, appears in the corners of the silver 
pads. The yield stress for high quality glass is roughly 250 MPa, and for Nichrome it 
is 360 MPa. This means that the individual objects remain structurally intact for the 
simulated heating power loads.

You must also consider stresses in the interface between the resistive layer and the glass 
plate. Assume that the yield stress of the surface adhesion in the interface is in the 
region of 50 MPa—a value significantly lower than the yield stresses of the other 
materials in the device. If the effective stress increases above this value, the resistive 
layer will locally detach from the glass. Once it has detached, heat transfer is locally 
impeded, which can lead to overheating of the resistive layer and eventually cause the 
device to fail.

Figure 2-39 displays the effective forces acting on the adhesive layer during heater 
operation. As the figure shows, the device experiences a maximum interfacial stress that 
is an order of magnitude smaller than the yield stress. This means that the device will 
be OK in terms of adhesive stress.
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Figure 2-39: The effective forces in the interface between the resistive layer and the glass 
plate.

Finally study the device’s deflections, depicted in Figure 2-40.

Figure 2-40: Total displacement on the fluid side of the glass plate.
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The maximum displacement, located at the center of the plate, is approximately 
30 µm. For high-precision applications, such as semiconductor processing, this might 
be a significant value that limits the device’s operating temperature.

Model Library path: Heat_Transfer_Module/
Electronics_and_Power_Systems/heating_circuit

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator.

2 In the Space dimension list select 3D. Click the Multiphysics button.

3 From the list of application modes select AC/DC Module>Statics, Electric>Shell, 

Conductive Media DC. In the Application mode name edit field type DC, then click Add.

4 From the list of application modes select Heat Transfer Module>General Heat Transfer, 
then click Add.

5 Similarly add two more application modes: Structural Mechanics Module>Solid, 

Stress-Strain and Structural Mechanics Module>Shell. When done, click OK.

O P T I O N S  A N D  S E T T I N G S

From the Options menu select Constants. Define the following names, expressions, and 
descriptions (the descriptions are optional); when done, click OK.

NAME EXPRESSION DESCRIPTION

V_in 12[V] Input voltage

d_layer 10[um] Layer thickness

sigma_Silver 6.3e7[S/m] Electric conductivity of silver

sigma_Nichrome 9.3e5[S/m] Electric conductivity of Nichrome

T_ref 293[K] Reference temperature

T_air T_ref Air temperature

h_air 5[W/(m^2*K)] Heat transfer film coefficient, air

T_fluid 353[K] Fluid temperature

h_fluid 20[W/(m^2*K)] Heat transfer film coefficient, fluid
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G E O M E T R Y  M O D E L I N G

1 Create a 2D work plane at z = 0 by first choosing Draw>Work-Plane Settings and then 
clicking OK in the dialog box that appears to accept the default settings.

2 Create nine rectangles. Open the Draw>Specify Objects>Rectangle dialog box, and 
for each one enter the appropriate data from this table:

3 Click the Zoom Extents button on the Main toolbar.

4 Create a circle with the menu item Draw>Specify Objects>Circle. In the Radius edit 
field type 0.01, then click OK.

5 Create another circle the same way bit with a Radius of 0.005.

6 Click the Create Composite Object button on the Draw toolbar. In the Set formula 
edit field type C1-C2-R2, then click OK. This step generates the composite object 
CO1.

7 Select CO1 by clicking on it, click the Mirror button on the Draw toolbar, then click 
OK. This step creates a mirror copy of CO1 called CO2.

8 Select CO2 and then click the Move button on the Draw toolbar. Go to the 
Displacement area, and in the y edit field type 0.015. Click OK.

9 Select both CO1 and CO2 by pressing Ctrl while clicking on the objects. Copy both 
by pressing Ctrl+C.

10 Paste twice by pressing Ctrl+V, specifying the displacement, and clicking OK. For the 
first copy specify the y-displacement as 0.030, and for the second specify 0.060.

11 Select CO1, copy it, and paste it with zero displacement.

12 Click the Rotate button on the Draw toolbar. In the Rotation angle edit field type 
-90, then click OK.

RECTANGLE WIDTH HEIGHT X-BASE Y-BASE

R1 0.08 0.13 -0.02 -0.035

R2 0.01 0.02 -0.01 -0.01

R3 0.005 0.075 0.015 0

R4 0.01 0.005 0 0.08

R5 0.01 0.01 0 0.075

R6 0.005 0.015 0.045 0.06

R7 0.02 0.005 0.02 -0.025

R8 0.01 0.01 0.01 -0.027

R9 0.01 0.01 -0.013 -0.025
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13 Click the Move button on the Draw toolbar. In the x edit field type 0.025, then click 
OK.

14 Click the Mirror button on the Draw toolbar. In the Normal vector edit field for x 
type 0, and in the y edit field type 1. Click OK. 

15 Click the Move button on the Draw toolbar. In the x edit field type -0.015, and in 
the y edit field type 0.075. Click OK.

16 Click the Create Composite Object button on the Draw toolbar. In the Set formula 
edit field type CO8-R5, then click OK. This step generates composite object CO9.

17 Copy and paste CO9 with x- and y-displacements of -0.02 and -0.08, respectively.

18 Click the Rotate button on the Draw toolbar. In the α edit field in the Rotation angle 
area type 90, and in the y edit field in the Center point area type -0.005. Click OK.

19 Select objects CO7 and R3. Click the Mirror button on the Draw toolbar. In the 
Normal vector edit field for x type 0, and in the y edit field type 1. Click OK. 

20 Click the Move button on the Draw toolbar. Specify the displacement by typing 
0.015 in the x edit field and 0.075 in the y edit field, then click OK. These steps 
generate composite objects CO10 and CO11.

21 Select objects CO9 and R3. Repeat the procedures in the previous two steps, using 
the Move dialog box with values for the x- and y-displacements of 0.03 and 0.06. 
The following figure shows the geometry after this step.

22 Select all objects except the glass plate (R1) and the silver tabs (R8 and R9). Click 
the Create Composite Object button on the Draw toolbar. Clear the Keep interior 

boundaries check box, then click OK. This step generates composite object CO14.

23 Select CO14, R8, and R9, then click the Coerce to Solid button on the Draw toolbar.
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M E S H  G E N E R A T I O N

1 From the Mesh menu open the Free Mesh Parameters dialog box.

2 On the Global page go to the Predefined mesh sizes list and select Coarse.

3 On the Subdomain page select Subdomain 3, then in the Maximum element size edit 
field type 2e-3.

4 Click the Remesh button, then click OK.

5 From the Mesh menu open the Extrude Mesh dialog box. On the Geometry page find 
the Distance edit field and type 1e-3. From the Extrude to geometry list select Geom1.

6 Click the Mesh tab. In the Number of element layers edit field type 2, then click OK.

7 Double-click the EQUAL button on the status bar at the bottom of the user interface, 
then click the Zoom Extents button on the Main toolbar to expand the geometry’s 
z-axis.

P H Y S I C S  S E T T I N G S

1 From the Options menu open the Materials/Coefficients Library dialog box.

2 Set up the materials silver and NiChrome. To do so, click New, then enter the 
settings from the following table in the corresponding edit fields. When done, click 
OK.

3 Choose Options>Expressions>Scalar Expressions. In the Name edit field type q_prod, 
and in the Expression edit field type d_layer*Q_DC. Enter Heat power per unit 
area inside thin layer in the Description edit field (optional). Click OK.

Boundary Settings—Shell, Conductive Media DC (DC)
1 From the Multiphysics menu select Shell, Conductive Media DC (DC).

2 From the Physics menu select Boundary Settings.

3 Select all the boundaries, then clear the Active in this domain check box.

4 Select Boundary 14, then click the Active in this domain check box. In the Electric 

conductivity edit field for σ type sigma_Nichrome, and in the Thickness edit field 
type d_layer.

5 Repeat the previous step for Boundaries 9 and 47 but in the Electric conductivity edit 
field type sigma_Silver. Click OK.

6 From the Physics menu select Edge Settings.

NAME C E alpha k nu rho

Silver 230 83e9 18.9e-6 420 0.37 10500

Nichrome 230 213e9 10e-6 15 0.33 9000
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7 Select Edge 13. In the Boundary condition list select Electric potential, then in the 
Electric potential edit field type V_in.

8 Select Edge 109. In the Boundary condition list select Ground, then click OK.

Subdomain Settings—General Heat Transfer
1 From the Multiphysics menu select General Heat Transfer (htgh).

2 From the Physics menu open the Subdomain Settings dialog box, then select all the 
subdomains.

3 Go to the General page. Click the Load button. From the Materials list select 
Basic Material Properties>Silica glass, then click OK.

4 Go to the Init page, and in the T(t0) edit field type T_ref. Click OK.

Boundary Conditions—General Heat Transfer
1 From the Physics menu open the Boundary Settings dialog box. Select Boundaries 9, 

14, and 47.

2 Click the Highly Conductive Layer tab. Select the Enable heat transfer in highly 

conductive layer check box, then in the ds edit field type d_layer.

3 Select Boundary 14. In the Library material list select Nichrome.

4 Similarly, for Boundaries 9 and 47 select Silver.

5 Click the Boundary Condition tab. Select Boundaries 9, 14, and 47. In the Boundary 

condition list select Heat flux. In the q0 edit field type q_prod, in the h edit field type 
h_air, and in the Tinf edit field type T_air.

6 Repeat the settings in the previous step for Boundary 4 but without specifying q0.

7 Select Boundaries 3, 8, 13, and 46. In the Boundary condition list select Heat flux. In 
the h edit field type h_fluid, and in the Tinf edit field type T_fluid. Click OK.

Subdomain Settings—Solid, Stress-Strain
1 From the Multiphysics menu select Solid, Stress-Strain (smsld).

2 From the Physics menu open the Subdomain Settings dialog box, then select all the 
subdomains.

3 Go to the Material page. In Library material list select Silica glass.

4 Click the Load tab. Select the Include thermal expansion check box. In the Temp edit 
field type T and in the Tempref edit field type T_ref.

5 Go to the Element page. In the Predefined elements list select Lagrange - Linear. Click 
OK.
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Point Settings—Solid, Stress-Strain
1 From the Physics menu open the Point Settings dialog box.

2 Select Point 1. Select the check boxes next to Rx, Ry, and Rz.

3 Select Point 3, then select the Rz check box.

4 Select Point 125, then select the Ry and Rz check boxes. Click OK.

Boundary Settings—Shell
1 From the Multiphysics menu select Shell (smsh).

2 From the Physics menu open the Boundary Settings dialog box.

3 Select all the boundaries, then clear the Active in this domain check box.

4 Select Boundaries 9, 14, and 47. Select the Active in this domain check box.

5 In the thickness edit field type d_layer.

6 Go to the Load page. Select the Include thermal expansion check box. In the Temp 
edit field type T and in the Tempref edit field type T_ref.

7 Click the Material tab. Select Boundaries 9 and 47. In the Library material list select 
Silver.

8 Similarly, for Boundary 14 select Nichrome. Click OK.

C O M P U T I N G  T H E  S O L U T I O N

This model is best solved using a script. Follow these steps to create the script and solve 
the model.

1 From the Solve menu open the Solver Manager.

2 On the Solve For page select Geom1 (3D)>Shell, Conductive Media DC (DC) and 
Geom1 (3D)>General Heat Transfer (htgh), then click Apply.

3 Go to the Script page. Select the Solve using a script check box. Then click the Add 

Current Solver Settings button to generate the first half of the script.

4 From the Solve menu, choose Solver Parameters.

5 In the Linear system solver list select Direct (SPOOLES) to use this solver’s ability to 
utilize the symmetric system matrices. Click OK.

6 Return to the Solver Manager. Go to the Initial Value page, then to the Initial value 
area, and click the Current solution option button.

7 Go to the Solve For page. Select Geom1>Solid, Stress-Strain (smsld) and Geom1>Shell 

(smsh). Click Apply.
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8 On the Script page click the Add Current Solver Settings button to generate the 
second half of the script. Click OK to close the Solver Manager.

9 Finally, click the Solve button on the Main toolbar to compute the solution.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Generate Figure 2-36 as follows:

1 From the Postprocessing menu open the Plot Parameters dialog box.

2 On the General page clear the Slice check box, then select the Boundary check box.

3 Go to the Boundary page. In the Expression edit field type q_prod. Click OK.

4 Click the Zoom Extents button on the Main toolbar.

To calculate the total heat generated in the circuit, follow these steps:

1 From the Postprocessing menu open the Boundary Integration dialog box.

2 Select Boundaries 9, 14, and 47. In the Expression edit field type q_prod. Click OK. 

The calculated value, roughly 13.8 W, appears in the message log at the bottom of 
the graphical user interface.

Generate Figure 2-37 by executing these instructions:

1 From the Postprocessing menu open the Plot Parameters dialog box. On the General 

page go to the Plot type area and select the Slice, Boundary, and Deformed shape check 
boxes.

2 Go to the Slice page, and in the Predefined quantities list select 
General Heat Transfer (htgh)>Temperature. In the Slice positioning area find the x 
levels edit field and type 0, and in the y levels edit field type 1.

3 Click the option button for Vector with coordinates associated with z levels, then in 
the corresponding edit field type 0.

4 On the Boundary page find the Expression edit field and type T*q_prod/q_prod.

The use of q_prod/q_prod makes the expression for the temperature valid on the 
resistive layer boundary only, which is the desired effect.

5 On the Deform page, go to the Deformation data area and click the Subdomain Data 
tab. In the Predefined quantities list select Solid, Stress-Strain (smsld)>Displacement.

6 While still in the Deformation data area, click the Boundary Data tab. In the Predefined 

quantities list select Shell (smsh)>Displacement. Click Apply.

Calculate the total heat flux to the fluid in the following way:
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1 From the Postprocessing menu open the Boundary Integration dialog box.

2 Select Boundaries 3, 8, 13, and 46. In the Expression edit field type 
h_fluid*(T-T_fluid), then click OK.

A value for the total heat flux of approximately 8.47 W appears in the message log.

To generate Figure 2-38 follow these steps:

1 While still in the Plot Parameters dialog box, go to the Slice page. In the Predefined 

quantities list select Solid, Stress-Strain (smsld)>von Mises stress. 

2 Click the Boundary tab. In the Predefined quantities list select Shell (smsh)>von Mises 

stress. Click Apply.

Figure 2-39 is obtained by executing the following instructions: 

1 From the Postprocessing menu select Domain Plot Parameters.

2 On the Surface page select Boundaries 9, 14, and 47. In the Expression edit field type 
sqrt(Tax_smsld^2+Tay_smsld^2). Click Apply.

This gives a plot of the norm of the surface traction vector (N/m2) in the surface 
plane,

Finally, to obtain Figure 2-40, proceed as follows:

1 Still on the Surface page of the Domain Plot Parameters dialog box, select Boundaries 
3, 8, 13, and 46.

2 In the Predefined quantities list select Solid, Stress-Strain (smsld)>Total displacement, 
then click OK.

Tax

Tay

σx τxy τxz

τyx σy τyz

0
0
1

τxz

τyz

= =
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Introduction

This example models a microchannel heat sink mounted on an active electronic 
component. The model geometry is based on a paper by B.C. Pal and others (Ref. 1) 
as well as another from S.P. Jang and others (Ref. 2).

Thermal management has become a critical aspect of today’s electronic systems, which 
often include many high-performance circuits that dissipate large amounts of heat. 
Many of these components require efficient cooling to prevent overheating. Some of 
these components, such as processors, require a heat sink with cooling fins that are 
exposed to forced air from a fan. This discussion develops the model of an aluminum 
microchannel heat sink whose manifolds work as flow dividers to improve its cooling 
performance (see Figure 2-41).

This case examines the temperature field in the air, in the aluminum, and in the heat 
source. The air transports heat by convection and conduction. Because the geometry 
is fairly complicated, it is not possible to use an analytical expression for the velocity 
profile, so you must also model the fluid flow and couple it to the heat equation. The 
aluminum heat sink transports thermal energy by pure conduction. Finally, to 
approximate the electronic component that requires cooling, the model uses a 
rectangular block with a given volume heat source.

Figure 2-41: Microchannel heat sink with manifolds.

Manifolds

Microchannels
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Model Definition

The model geometry consists of three subdomains: the electronic component, the 
aluminum heat sink, and the cooling air. Because of symmetry, it is sufficient to model 
just a small element of the entire geometry as shown in Figure 2-42.

Figure 2-42: Symmetry element for modeling the heat sink and the heat source. 

In particular, the surfaces labeled “inlet” and “outlet” in the figure each constitutes a 
quarter of the actual inlet and outlet, respectively.

This simulation employs the General Heat Transfer and the Weakly Compressible 
Navier-Stokes application modes for stationary analysis. The first mode models the 
temperature field in the entire geometry; the second one serves only to model the 
airflow. 

Both the component and the heat sink transport heat by pure conduction as described 
by the conductive heat equation

where k (W/(m·K)) is the thermal conductivity, Q (W/m3) is the heat source, and T 
(K) denotes the temperature. The model’s heat source relates to the component’s 
output power, and Q equals zero for the heat sink because that device has no heat 
sources.

The temperature field in the air is governed by the heat equation for conduction and 
convection

air chamber

heat sink

electronic component

inlet
outlet

(ceramic)

(aluminum)

∇ k T∇–( )⋅ Q  =
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where k refers to the thermal conductivity (W/(m·K)), ρ is the density (kg/m3) and 
Cp denotes the specific heat capacity (J/(kg·K)) for air. You obtain the velocity vector 
u (m/s) from the equations for the airflow as described later in this section.

The boundary conditions for the heat-transfer equations are:

The last equation applies equally well at thermally insulated boundaries and at 
boundaries through which no heat flows because of symmetry. In addition, assume 
heat-flux continuity on all interior boundaries.

Now use the Weakly Compressible Navier-Stokes equations for the momentum 
equations and the equation of continuity to describe the air’s velocity and pressure 
field:

where η denotes the dynamic viscosity (Pa·s), u is the velocity (m/s), ρ is the fluid 
density (kg/m3), p represents pressure (Pa), and F is the volume force (N/m3).

The air density depends on the pressure and temperature according to the ideal gas 
equation

where R is the mass-based gas constant, equal to 287 J/(kg·K) for air.

You can assume that the volume force, F, is zero because gravitational forces due to 
changes in density most likely have very little impact on this model.

At the inlet, the fluid enters with a parabolic velocity profile modeling fully developed 
laminar flow. The mean velocity is approximately 1 m/s, and the air temperature is 
293 K. At the outlet the pressure is 105 Pa, and heat leaves through convection.

These assumptions lead to the following boundary conditions for the Weakly 
Compressible Navier-Stokes application mode:

ρCpu ∇T⋅ ∇ k T∇( )⋅– 0=

T Tin= at the inlet,

n k∇T–( )⋅ 0= elsewhere.

ρu ∇⋅ u ∇ pI– η ∇u ∇u( )T
+( ) 2η 3⁄( ) ∇ u⋅( )I–+[ ]⋅ F+=

∇ ρu( )⋅ 0=
in the air

ρ p
RT
--------=
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Here, the outlet pressure equals p0 = 1.0·105 Pa, and the z-component of the inlet 
velocity is

with x and y expressed in meters. The prefactor is calculated to give an average inflow 
speed of 1 m/s at the rectangular inlet surface measuring 5·10−4 m × 2·10−4 m and 
centered at x = 0, y = 0. The model geometry covers only the part where x ≥ 0, y ≥ 0.

Adding Thermal Contact Resistance

The model described thus far assumes perfect thermal contact at the interface between 
the heat source and the aluminum heat sink. A more realistic model accounts for the 
interface’s thermal contact resistance. That resistance is an important factor in the 
design of electronics cooling because it can significantly reduce a heat sink’s cooling 
performance. The following discussion describes how to account for the thermal 
contact resistance, starting from the initial model.

u 0= at walls
n u⋅ 0= at symmetry boundaries 

p p0= η ∇u ∇u( )T
+( ) 2η 3⁄( ) ∇ u⋅( )I–[ ]n 0=, at the outlet

u 0 0 w, ,( )= at the inlet

w 0.3– ·1016 2.5·10 4– x+( ) 2.5·10 4– x–( ) 1·10 4– y+( ) 1·10 4– y–( )  m/s=
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The analysis is based partly on reference Ref. 3, which presents an analysis of how to 
calculate the interface resistance for a ceramic package/aluminum heat-sink assembly.

Figure 2-43: The interface between the heat source and the heat sink. 

Figure 2-43 shows the interface between the heat source and the heat sink. The 
surfaces of the heat sink and the ceramic heat source are not in perfect contact because 
of their roughness; air fills the gaps between the surfaces.

Modeling the interface with the geometry of the rough surfaces would require a very 
dense mesh. An alternative, more practical, way of modeling the interface is to define 
a thermal joint conductivity, hj (W/(m2·K)), that is representative for the interface.

Using the thermal joint conductivity, the heat flux from the heat source to the heat 
sink is

 (2-2)

where Tsink is the temperature of the aluminum heat sink at the interface, and Tsource 
is the temperature of the ceramic heat source at the interface. Equation 2-2 states that 
the difference in temperature across the interface drives the heat flux.

Similarly, the heat flux from the heat sink to the heat source is

 (2-3)

Note that  has a negative value as long as the source temperature is 
higher than the sink temperature.

heat source

heat sink

interface

air

qsource sink→ hj Tsource Tsink–( )=

qsink source→ hj Tsink Tsource–( )=

qsink source→
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These two heat-flux conditions maintain heat flux continuity through the interface, 
that is, the heat flux out of the heat source equals the heat flux into the heat sink.

Ref. 3 shows how to calculate the thermal joint conductivity of an interface that is 
similar to the one in this model; here follows a brief summary.

The thermal joint conductivity, hj, is defined as the sum of the conductivity through 
those regions that are in contact and those where there is a gap,

 (2-4)

where hc is the contact conductivity and hg is the gap conductivity, both measured in 
W/(m2·K). The contact conductivity is determined by the expression

 (2-5)

where ks, m, σ, and Hc are parameters specifying the material and surface 
characteristics of the surfaces, and P is the contact pressure.

The gap conductance is

 (2-6)

where kg is the thermal conductivity of the air in the gap, Y is the effective gap 
thickness, and M is a gas parameter that accounts for rarefaction effects at high 
temperatures and low pressures.

For this model you apply the value hj = 5400 W/(m2·K). For more details on how to 
compute these properties according to Equation 2-4, Equation 2-5, and 
Equation 2-6, see Ref. 3.

In COMSOL Multiphysics you model thermal contact resistance by applying the Thin 
thermally resistive layer boundary condition:

 (2-7)

This boundary condition, known as a slit boundary condition, can accommodate a 
discontinuity in the temperature field across the boundary. The parameters of the 

hj hc hg+=

hc 1.25ks
m
σ
----- P

Hc
-------⎝ ⎠

⎛ ⎞ 0.95
=

hg
kg

Y M+
----------------=

nu– ku Tu∇–( )⋅
kres
dres
----------- Td Tu–( )=

nd– kd Td∇–( )⋅
kres
dres
----------- Tu Td–( )=
 2 :  E L E C T R O N I C S  A N D  P O W E R - S Y S T E M  M O D E L S



boundary condition are the layer thermal conductivity kres, and layer thickness dres. 
For this model, we only know the factor kres/dres, which is equal to our thermal joint 
conductivity hj. We can specify the correct thermal joint conductivity by applying the 
values kres = hj·1.0 m and dres = 1.0 m.

Slit boundary conditions are only available on assembly pair boundaries, which 
requires us to set up an assembly geometry to model contact resistance.

Results and Discussion

Figure 2-44 shows the resulting temperature field for the initial model. It indicates that 
this scheme holds the component’s temperature at roughly 337 K. The air temperature 
increases from 295 K to approximately 337 K on its way from the inlet to the outlet, 
something you could expect because the air absorbs heat energy from the aluminum. 
The figure also shows streamlines for the total heat flux. The streamlines show that the 
heat energy leaves the aluminum and escapes through the outlet.

Figure 2-44: Temperature field and heat-flux streamlines.
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The velocity field and its streamlines appear in Figure 2-45. Again, as expected, the 
velocities are highest at the inlet and outlet.

Figure 2-45: Velocity field with velocity streamlines.

Figure 2-46 shows the temperature field of the extended model, which accounts for 
the thermal contact resistance of the interface between the heat source and sink. A 
small temperature jump is observed on the interface. The maximum temperature of the 
component is roughly 1 K higher than the result obtained with the initial model. This 
confirms that the interface’s thermal contact resistance does have an impact on the heat 
sink’s cooling performance, albeit a small one.
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Most importantly, the results show that the electronic component does not overheat 
when operating continuously at the given power.

Figure 2-46: Temperature field when accounting for the thermal contact resistance.
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Model Library path: Heat_Transfer_Module/
Electronics_and_Power_Systems/microchannel_heatsink
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Model Library path: Heat_Transfer_Module/
Electronics_and_Power_Systems/microchannel_heatsink_res

Modeling Using the Graphical User Interface

The first part of this section describes how to build and solve the initial model, which 
does not account for the thermal contact resistance at the interface between the heat 
source and the heat sink.

M O D E L  N A V I G A T O R

3 In the Model Navigator go to the New page. From the Space dimension list select 3D.

4 In the list of application modes, select Heat Transfer Module> 
Fluid-Thermal Interaction>Non-Isothermal Flow>Steady-state analysis.

5 Click OK.

O P T I O N S  A N D  S E T T I N G S

From the Options menu select Constants. Enter these names, expressions, and 
(optionally) descriptions; when done, click OK.

G E O M E T R Y  M O D E L I N G

1 Go to the Draw menu and select Work-Plane Settings.

2 On the Quick page, select the x-y option button and in the z edit field type 2.85e-3.

3 Click OK.

4 Shift-click the Rectangle/Square button on the Draw toolbar.

NAME EXPRESSION DESCRIPTION

T0 295[K] Inlet air temperature

eta_air 18e-6[Pa*s] Dynamic viscosity, air

k_air 27[mW/(m*K)] Thermal conductivity, air

Cp_air 1006[J/(kg*K)] Specific heat capacity, air

p0 1e5[Pa] Outlet air pressure

k_ceramic 20.9[W/(m*K)] Thermal conductivity, ceramic

Q_source 5[W/cm^3] Heat production, ceramic
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5 In the dialog box that appears, enter these properties; when done, click OK.

6 Click the Zoom Extents button on the Main toolbar.

7 In the same manner, create a second rectangle with these properties:

8 From the Draw menu open the Extrude dialog box.

9 From the Object selection list select R1. In the Distance edit field type -2.85e-3, then 
click OK.

10 Click the Geom2 tab.

11 Using the method of Steps 8 and 9, extrude the large rectangle, R1, once again but 
now by a Distance of -1.85e-3.

12 Click the Geom2 tab.

13 Extrude the small rectangle, R2, by a Distance of -1.65e-3.

14 Click the Geom2 tab.

15 Draw two new rectangles with the properties in the following tables:

OBJECT DIMENSIONS EXPRESSION

Width 1e-3

Height 2e-4

Base Corner

x-position 0

y-position 0

OBJECT DIMENSIONS EXPRESSION

Width 1e-3

Height 1e-4

Base Corner

x-position 0

y-position 0

OBJECT DIMENSIONS EXPRESSION

Width 5e-4

Height 1e-4

Base Corner

x-position 2.5e-4

y-position 0
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16 Click the Create Composite Object button on the Draw toolbar.

17 In the Object selection list select R3 and R4, the two rectangles you just created. Click 
OK to create their union, CO1.

18 From the Draw menu choose Extrude. Select the new composite object, CO1

19 In the Distance edit field type -2.5e-4, then click OK.

20 Click the Create Composite Object button.

21 In the Set formula edit field type EXT1+EXT2+EXT3-EXT4, then click OK.

22 Double-click the AXIS button on the status bar at the bottom of the user interface 
to hide the coordinate axes.

P H Y S I C S  S E T T I N G S

1 Go to the Options menu and select Expressions>Boundary Expressions.

2 Select Boundary 10 and enter the following expression; when done, click OK.

This gives a parabolic inlet-velocity profile with a maximum inflow speed of 
1.875 m/s and average inflow speed of 0.833 m/s.

Subdomain Settings—Weakly Compressible Navier-Stokes
1 From the Multiphysics menu select Weakly Compressible Navier-Stokes (chns).

2 Go to the Physics menu and select Subdomain Settings.

3 Select Subdomains 1 and 2.

4 From the Group list, select Solid domain.

5 Select Subdomain 3 and enter eta_air in the η edit field.

6 Click the Init tab, then in the p(t0) edit field type p0.

7 Click OK.

OBJECT DIMENSIONS EXPRESSION

Width 1e-3

Height 1e-4

Base Corner

x-position 0

y-position 1e-4

NAME EXPRESSION

w_inlet -0.3e16[1/(m^3*s)]*(2.5e-4+x)*(2.5e-4-x)* 
(1e-4+y)*(1e-4-y)
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Boundary Conditions—Weakly Compressible Navier-Stokes
1 From the Physics menu select Boundary Settings.

2 Enter settings from the following table; when done, click OK.

Subdomain Settings—General Heat Transfer
1 Go to the Multiphysics menu and select 2 Geom1: General Heat Transfer (htgh).

2 In the Physics menu select Subdomain Settings.

3 Select Subdomain 1. From the Group list, select Solid domain.

4 Enter the following properties. When done, click OK.

5 Select Subdomain 2. From the Group list, select Solid domain.

6 Click the Load button.

7 In the Materials list, select Basic Material Properties>Aluminum, then click OK.

8 Select Subdomain 3. On the General page, enter the following settings (for 
properties not listed, keep the default settings):

9 Click the Convection tab, then select Ideal gas from the Matter statelist.

10 In the pA edit field, type p.

11 Click the Init tab.

SETTINGS BOUNDARIES 7, 8, 23 BOUNDARIES 9, 11, 
12, 16, 17, 18, 20

BOUNDARY 10 BOUNDARY 19

Boundary 
type

Symmetry 
boundary

Wall Inlet Outlet

Boundary 
condition

No slip Velocity Pressure, no 
viscous stress

u0 0

v0 0

w0 w_inlet

p0 p0

PROPERTY VALUE

k (isotropic) k_ceramic

Q Q_source

PROPERTY VALUE

k (isotropic) k_air

Cp Cp_air
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12 Select all three subdomains, and in the Temperature edit field enter T0.

13 Click OK.

Boundary Conditions—General Heat Transfer
1 Go to the Physics menu and select Boundary Settings.

2 Enter the settings from the following table; when done, click OK.

For all other boundaries, keep the default setting, Insulation/Symmetry.

M E S H  G E N E R A T I O N

1 From the Mesh menu select Free Mesh Parameters.

2 Click the Boundary tab and select Boundaries 10, 12, and 16–20.

3 In the Maximum element size edit field type 9e-5.

4 Go the Advanced page, then in the y-direction scale factor edit field type 5.

5 Click Remesh, then click OK.

C O M P U T I N G  T H E  S O L U T I O N

By default, COMSOL Multiphysics solves 3D models with Navier-Stokes as the ruling 
application mode using the GMRES iterative solver. However, for models (such as this 
one), with less than 100,000 degrees of freedom, the direct PARDISO solver is more 
efficient. Therefore, change the default settings according to the following 
instructions.

1 Click the Solver Parameters button on the Main toolbar.

2 On the General page of the Solver Parameters dialog box find the Linear system solver 
list and select Direct (PARDISO).

3 Click OK to close the Solver Parameters dialog box.

4 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows a slice plot of the temperature field. To create Figure 2-44, 
which also shows the heat-flux streamlines, follow these steps:

1 Click the Plot Parameters button on the Main toolbar.

SETTINGS BOUNDARY 10 BOUNDARY 19

Boundary condition Temperature Convective flux

T0 T0
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2 Go to the Streamline page and select the Streamline plot check box.

3 In the Predefined quantities list select General Heat Transfer (htgh)>Total heat flux.

4 In the Streamline plot type list select Magnitude controlled. 

5 On the Density page set the Min distance to 0.02 and the Max distance to 0.12.

6 Click the Line Color tab. Select the Uniform color option button, then click the Color 
button to launch the Streamline Color dialog box. On the Swatches page, select a 
yellow color, then click OK.

7 Back on the Streamline page, select Tube from the Line type list, then click the Tube 

Radius button.

8 In the Tube Radius Parameters dialog box, clear the Auto check box for the Radius 

scale factor, then type 0.3 in the corresponding edit field. Click OK.

9 Go to the Slice.

10 In the Predefined quantities list select General Heat Transfer (htgh)>Temperature.

11 Click Apply.

The following steps describe how to create Figure 2-45, which shows the velocity field 
and the velocity streamlines:

1 Return to the Plot Parameters dialog box.

2 On the Streamline page, in the Predefined quantities list select Weakly Compressible 

Navier-Stokes (chns)>Velocity field.

3 Go to the Slice page and in the Predefined quantities list select Weakly Compressible 

Navier-Stokes (chns)>Velocity field.

4 Click OK.

Modeling Using the Graphical User Interface—Extended Model

To build the extended model, which accounts for the thermal contact resistance, 
continue with these steps:

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu select Constants. Add this constant; when done, click OK.

NAME EXPRESSION DESCRIPTION

h_j 5400[W/(m^2*K)] Thermal joint conductivity
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G E O M E T R Y  M O D E L I N G

1 Click the Draw Mode button on the Main toolbar.

2 Select the geometry and click the Split Object button in the Draw toolbar.

3 Select the geometry objects CO3 and CO4, then click the Union button on the 
Draw toolbar.

4 Select the geometry objects CO1 and CO2, then click the Create Pairs button on 
the Draw toolbar.

Boundary Conditions—General Heat Transfer (htgh)
1 Go to the Physics menu and select Boundary Settings.

2 Click the Pairs tab and select Pair 1 (identity).

3 Select Thin thermally resistive layer from the Boundary condition list.

4 Enter the settings from thus table; when done, click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows a slice plot of the temperature field and streamlines for the total 
heat flux. To create Figure 2-46, remove the streamlines with the following steps:

1 Click the Plot Parameters button on the Main toolbar.

2 On the Streamline page, clear the Streamline plot check box.

3 Click OK.

SETTINGS VALUE

kres h_j*1.0[m]

dres 1.0[m]
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Hea t  T r a n s f e r  i n  a  S u r f a c e -Moun t  
Pa c k a g e  f o r  a  S i l i c o n  Ch i p

Introduction

All integrated circuits—especially high-speed devices—produce heat. In today’s dense 
electronic system layouts heat sources are many times placed close to heat-sensitive 
ICs. Designers of printed-circuit boards often need to consider the relative placement 
of heat-sensitive and heat-producing devices, so that the sensitive ones do not 
overheat.

One type of heat-generating device is a voltage regulator, which can produce several 
watts of heat and reach a temperature higher than 70 °C. If the board design places 
such a device close to a surface-mounted package that contains a sensitive silicon chip, 
the regulator’s heat could cause reliability problems and failure due to overheating. 

Figure 2-47: Layout of the simulated silicon device, its package, and a voltage regulator. 
The chip and the voltage regulator are connected through a ground plane, a pin, and the 
interconnect.

This simulation investigates the thermal situation for a silicon chip in a surface-mount 
package placed on a circuit board close to a hot voltage regulator. The chip is subjected 
to heat from the regulator and from internally generated heat.
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Model Definition

The model is based on a SMD IC and voltage regulator layout as in Figure 2-47. The 
silicon chip sits in the center of the package and dissipates its heat to the surrounding 
environments. The chip also connects to a ground plane through an interconnect and 
one of the pins. A heat generating voltage regulator is placed on the same ground 
plane. This means that the voltage regulator may affect the silicon chip by the 
conducted heat and this may lead to overheating of the chip.

Heat transfers through the mounted package to the surroundings through conduction 
according to:

.

Q is negligible in the circuit board, pins and package, while in the chip this model sets 
that parameter to a value equivalent to 20 mW. The conductivities of the components 
are chosen to be similar to:

• silicon, for the chip

• aluminum, for the pins

• FR4, for the pc board

• copper, for the ground plane and interconnect

• an arbitrary plastic, for the chip package

Heat dissipates from all air-exposed surfaces through forced heat convection, which is 
modeled using a heat transfer coefficient, h:

The voltage regulator is simulated by setting a fixed temperature at that surface. The 
thin conducting layers of the ground plane and interconnect within the package is 
modeled using a 2D shell approximation, according to:

where ds is the layer’s thickness, and  represents the nabla operator projected onto 
the direction of the plane. The model uses a General Heat Transfer application mode 
to describe the 3D heat transfer as well as the 2D shell heat transfer.

∇ k– ∇T( )⋅ Q=

n– q⋅ h Tinf T–( )=

∇ dsk– ∇tT( )⋅ 0=

∇t
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Results and Discussions

Figure 2-48 illustrates the temperature distribution through the thickness. Being a 
good conductor, the interconnect delivers heat to the outer edge of the package, which 
gives the fairly constant temperature distribution around the interconnect.

Figure 2-48: Slice plot of the temperature through the circuit board, interconnect, chip, 
and package. The effect of the interconnect is evident by its ability to conduct heat from the 
chip to the outer parts of the package.

An alternative view is achieved by using the transparency feature in the postprocessing 
tools of COMSOL Multiphysics. This results in a transparent 3D view of the 
temperature distribution, as depicted in Figure 2-49. In that figure you can see the 
temperature distribution around the chip and along the interconnect.
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Figure 2-49: Boundary plot of the temperature created with the assistance of the 
transparency tool in COMSOL Multiphysics. This view also gives the temperature 
distribution on the chip and along the interconnect.
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To get a closer look at the stationary temperature of the silicon chip, plot the 
temperature at the bottom boundary of the chip. 

Figure 2-50: Temperature distribution on the bottom surface of the silicon chip.

The simulation predicts a maximum temperature of the silicon device of 46.6 °C. This 
means that the device will not overheat in the present configuration.

Model Library path: Heat_Transfer_Module/
Electronics_and_Power_Systems/surf_mount_pack

Modeling in COMSOL Multiphysics

This model uses the General Heat Transfer application mode from the Heat Transfer 
Module, and that application mode allows the definition of highly conductive layers. 
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They are thin layers that conduct heat well so you need not define them in 3D. The 
two layers that have this definition are:

• The interconnect between the chip and the grounded pin.

• The ground plane that is also thermally connected to the temperature constraint 
coming from the voltage regulator.

While the numerical method considers these two modeling domains as interior 
boundaries, the model still includes a thickness to take the 3D heat flux into account.

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics and get to the Model Navigator by double-clicking the 
COMSOL Multiphysics icon on the Windows desktop or, on Unix/Linux systems, 
enter the command comsol.

2 Click the New tab, and in the Space dimension list select 3D.

3 This problem is ideally suited for the Heat Transfer Module. Therefore, go to the 
list of application modes and select Heat Transfer Module>General Heat Transfer> 

Steady-state analysis, and click OK.

C R E A T I N G  T H E  G E O M E T R Y

The 3D workspace is now ready. You can, of course, create the 3D geometry with the 
built-in CAD tools of COMSOL Multiphysics, but an interesting alternative is to 
import a ready-made geometry from a dedicated CAD tool.

1 From the File menu select Import>CAD Data From File. Find the file 
surf_mount_pack.mphtxt or surf_mount_pack.igs (if you have the CAD 
Import Module) and then click OK.
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2 To get a good view, rotate the geometry with the mouse and then click the Zoom 

Extents button on the Main toolbar. The geometry in the drawing area on your 
screen should look like that in the figure below.

To this base geometry you must add the interconnect between the pin and the chip 
as well as the ground plane and the temperature surface resulting from the voltage 
regulator. These details are all 2D surfaces that you can best add on work planes. 
Thus, start by adding the work plane for the interconnect, which is on the zx-plane 
at y = 0.

3 Choose Draw>Work-Plane Settings, and on the Quick tab choose z-x and click OK.

4 To see the 3D geometry projected on the 2D plane, click the Projection of All 3D 

Geometries on the Draw toolbar, and then click the Zoom Extents on the Main 
toolbar.

5 To simplify the drawing of the 2D object, and add some extra grid points. Choose 
Options>Axes/Grid Settings, then click the Grid tab. Clear the Auto check box. In the 
following edit fields enter the these values: x-spacing: 0.002, Extra x: 5e-4 
4.245e-3 4.645e-3, y-spacing: 0.002, and Extra y: -2e-4 2e-4. Click OK.
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6 Press Shift and click the Line button on the Draw toolbar.

7 In the Line dialog box, go to the Coordinates area and type in the following data:

8 From the Style list, select Closed polyline (solid) and then click OK to generate the 
interconnect between the chip and the connector as depicted in the following 
figure.

x 5e-4 5e-4 4.645e-3 4.645e-3 4.245e-3 4.245e-3 5e-4

y 2e-4 -2e-4 -2e-4 1.95e-3 1.95e-3 2e-4 2e-4
 2 :  E L E C T R O N I C S  A N D  P O W E R - S Y S T E M  M O D E L S



9 To embed the object CO1 in the 3D workspace, choose Draw>Embed, then click OK.

Now, finalize the geometry by adding the ground plane for the voltage regulator.

10 Choose Draw>Work-Plane Settings.

11 In the Work-Plane Settings dialog box, click the Add button.

You do not know for certain the exact position of the circuit board’s top surface, so 
project this surface to the work plane and then use the fixed positions of this 
projection’s vertices to draw the two surfaces.

12 Click the Vertices tab. Select three vertices on the corners of the circuit board’s top 
surface by clicking at one point at a time and adding it to the list using the >> 

button. Add the points in this order: CO2:3, CO2:4, CO2:8. This gives the work 
plane the proper orientation for the next step. Click Apply to view the work plane 
axis. Click OK, then click the Zoom Extents button on the Main toolbar.
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13 Click the Rectangle/Square button on the Draw toolbar to draw the two rectangles 
shown in the next figure. Use the existing grid points to snap the rectangles while 
drawing them. Press Ctrl+A to select both of them.

14 Select the menu item Draw>Embed and then click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings
This section deals with the setting the material’s physical properties.

1 Choose Physics>Subdomain Settings and press Ctrl+A to select all subdomains.

2 Click the Element tab and select Lagrange - Linear from the Predefined elements list. 
Doing so saves computation time and memory.

3 Click the General tab and then the Load tab to load a predefined material property 
set. Select Aluminum in the list, then click OK. 

In COMSOL Multiphysics you can enter individual numerical values of material 
properties such as thermal conductivity directly in the Subdomain Settings dialog 
box. An alternative is to use predefined materials from the materials library. The next 
step shows how to add some new materials to the materials library. 
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4 Choose Options>Materials/Coefficients Library. Click New and in the Name field type 
PCB (FR4). Also set the thermal conductivity k to 0.3 (W/(m·K)). Click OK. 
Complete the new material additions as in the following list.

5 Return to the Subdomain Settings dialog box and highlight Subdomain 1 (the circuit 
board), then go to the Library material list and select PCB (FR4). Next select 
Subdomain 10 (the package) and select Plastic from the materials menu. Finally 
select Subdomain 11 (the chip) and click the Load button to load the Silicon material 
property set from the built-in list, and click OK.

6 Keep the chip highlighted and add an internal heat source (W/m3) by going to the 
Q edit field and entering 2e8, which corresponds to 20 mW for the whole volume 
of the device. Click OK.

Boundary Conditions
1 Select the menu item Physics>Boundary Settings and press Ctrl+A to select all 

boundaries to the exterior (the interior boundaries are grayed out).

2 To set a cooling rate by assuming a heat transfer coefficient of 50 W/(m2·K) to the 
surroundings at a temperature of 30 °C, set the Boundary condition to Heat flux and 
then set h to 50 and Tinf to 30[degC].

3 Select the surface to which the voltage regulator is connected (Boundary 141), then 
select Temperature from the Boundary condition list. In the T0 edit field, type 
50[degC].

4 Select the ground plane (Boundary 140), then click the Highly Conductive Layer tab. 
Select the check box Enable heat transfer in highly conductive layer. Specify the layer 
thickness ds as 1e-4. The other material properties are those of copper, which is 
what the ground plane is made of.

5 Select the Interior boundaries check box and select the interconnect (Boundary 
138). Again select the check box Enable heat transfer in highly conductive layer and 
here specify a layer thickness ds of 5e-6. Click OK.

G E N E R A T I N G  T H E  M E S H

1 Choose Mesh>Free Mesh Parameters.

MATERIAL NAME THERMAL CONDUCTIVITY, K

PCB (FR4) 0.3

Plastic 0.2
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2 Click the Boundary tab and select the surfaces for the ground plane and voltage 
regulator (Boundaries 140 and 141). On each of these boundaries set the Maximum 

element size to 1e-4. Click Remesh, then click OK.

C O M P U T I N G  T H E  S O L U T I O N

Because this model has a limited size you can use a direct solver. Also, for two reasons, 
you can utilize that the system matrices become symmetric: The model only involves 
conduction in the subdomain, and the boundary conditions only depend on the 
temperature variable T.

1 Choose Solve>Solver Parameters.

2 Select Direct Cholesky (TAUCS) from the Linear system solver list, then click OK.

3 Click the Solve button on the Main toolbar.

V I S U A L I Z I N G  T H E  S O L U T I O N

The default plot shows a slice plot of the temperature throughout a number of cross 
sections in the device. Note that the temperature is displayed in Kelvin, which is the 
default temperature unit in the SI system.

1 To generate Figure 2-49, click the Plot Parameters button on the top toolbar. On 
the General page, clear the Slice check box and select the Boundary check box. 

2 Go to the Boundary page and select °C from the Unit list.

3 Click OK to display the boundary plot.

4 To see the interior, click the Increase Transparency button on the lower part of the 
left toolbar.

5 To generate Figure 2-50, first choose Postprocessing>Domain Plot Parameters.

6 Click the Surface tab and select Boundary 134 (bottom plane of the chip) from the 
list.

7 Select °C from the Unit list to display the result in degrees Celsius.

8 Select zx-plane from the list of x- and y-axis data, then click OK.
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Rap i d  Th e rma l  Ann e a l i n g

Introduction

In the semiconductor industry, rapid thermal annealing (RTA) is a semi-conductor 
process step used for the activation of dopants and the interfacial reaction of metal 
contacts. In principle, the operation involves rapid heating of a wafer from ambient to 
approximately 1000–1500 K. As soon as the wafer reaches this temperature, it is held 
there for a few seconds and then finally quenched. A rapid process step is crucial in 
order to avoid too much diffusion of the dopants. Furthermore, it is also important to 
avoid overheating and nonuniform temperature distribution to occur. An RTA 
apparatus uses high-power IR lamps as heat sources (Ref. 1).

Figure 2-51: Diagram of a typical RTA (rapid thermal annealing) apparatus.

A technical difficulty lies in how to properly measure the wafer’s temperature during 
the process. Two commonly used technical solutions are: thermocouples and IR 
sensors.

To achieve an accurate measurement, it is important that the temperature sensor not 
be subjected to direct radiation from the lamp. Ideally positioned, the sensor only 
receives secondary radiation; that is, the radiation reflected and emitted by the silicon 
wafer. Desirable characteristics of the sensor are high accuracy and short response time. 
While a high-performance design requires superior electronics, the sensor geometry 
plays a big role. In a nutshell, the sensor needs to be large enough to register a 
sufficient amount of radiation but light enough to minimize its own thermal inertia. 
Since COMSOL Multiphysics gives you control over the geometry, a parameter 

wafer sensor
infrared filter
photo-diode detector

wafer quartz tubelamp

lamp sensor

oven enclosure
R A P I D  T H E R M A L  A N N E A L I N G  |  135



136 |  C H A P T E R
optimization of the sensor could be an exciting project. But first, justify that an infrared 
sensor is indeed more appropriate than the inexpensive thermocouple.

Model Definition

Figure 2-51 illustrates a typical RTA configuration. In many applications, RTA makes 
use of double-sided heating, in which IR lamps are positioned both above and below 
the silicon wafer. In this example we are modeling a single-sided heating apparatus, as 
depicted in Figure 2-52.

Figure 2-52: The model geometry.

The components in Figure 2-52 are contained in a chamber with 
temperature-controlled walls with a set point of 400 K. This results in a closed cavity 
so you can omit the geometry of the chamber walls. Furthermore, the model assumes 
that this physical system is dominated by radiation and convection cooling. The 
convective cooling of the wafer and sensor to the gas (at 400 K) is modeled using a 
heat transfer coefficient, h (in this example set to 20 W/(m2·K)).

The problem is governed by the heat equation, given below together with its boundary 
conditions:

silicon wafer

sensor

heater

ρCp
∂T
∂t
------- ∇ k T∇–( )⋅+ Q=

n– k∇T–( )⋅ h Tinf T–( ) ε 1 ε–( )⁄( ) J0 σT4
–( )+=
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Here ρ is the density; k denotes the thermal conductivity; Q represents the volume heat 
source; n is the surface normal vector; Tinf equals the temperature of the convection 
cooling gas; ε denotes the surface emissivity; J0 is the expression for surface radiosity 
(further described in the Heat Transfer Module User’s Guide); and σ is the 
Stefan-Boltzmann constant.

The model simulates the lamp as a solid object with a volume heat source of 25 kW. It 
is insulated on all surfaces except the for the top, which faces the silicon wafer. At this 
surface, heat leaves the lamp as radiation only. In order to capture the lamp’s transient 
startup time, the model uses a low heat capacity, Cp, for the solid (10 J/(kg·K)). The 
lamp’s other thermal properties are identical to those of copper metal (the default 
value in the application mode).

In this case assume that the wafer dissipates energy via radiation and convection on all 
surfaces. The sensor is insulated at all surfaces except the top, which is subjected to 
both convection and radiation. The thermal material properties are set to those of 
alumina.

The following table summarizes the material properties used in the model:

The model simulates the transient temperature field for 10 s of heating. The initial 
temperature is 400 K for all objects.

TABLE 2-6:  MATERIAL PROPERTIES

MATERIAL  k (W/(m·K))  ρ (kg/m3)  Cp (J/(kg·K))  ε 

IR lamp 400 8700 10 0.99

Silicon wafer (silicon) 163 2330 703 0.5

Sensor 27 2000 500 0.8
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Results and Discussion

Figure 2-53 displays the temperature distribution after 10 s of heating.

Figure 2-53: Temperatures of the lamp, wafer, and sensor after 10 s of heating.

After 10 seconds, the temperatures of the wafer and sensor differ significantly: the 
wafer is at 1800 K, whereas the sensor is at 1100 K.

Notice that the temperature distribution in the wafer with a delta of several hundred 
degrees is not very uniform, and that you probably can do much better by 
reconfiguring the heat source. However, such a reconfiguration is not included in this 
model.

To investigate how well the sensor’s temperature reflects that of the wafer surface, it is 
useful to plot the temperature transient of the wafer surface’s centerpoint that faces the 
 2 :  E L E C T R O N I C S  A N D  P O W E R - S Y S T E M  M O D E L S



lamp (Twafer), together with the temperature at a point on the sensor top surface 
(Tsensor) (see Figure 2-54).

Figure 2-54: The temperature transients of the lamp, the silicon wafer, and the sensor, 
together with the irradiation power at the sensor surface.

The sensor temperature reflects that of the silicon wafer poorly. This means that the 
signal of a thermocouple, positioned anywhere in the sensor domain of Figure 2-52, is 
of little use for regulating this process.

The IR-detector transient (Sensirrad) matches the wafer temperature characteristic 
quite well. A scalar amplification allows for a high accuracy measurement of the wafer 
temperature. The precise amplification factor is system-dependent and subject to a 
calibration requirement.

However, IR-sensor methodology also has drawbacks. The IR signal depends on the 
emissivity of the wafer, which will vary with temperature making the response 
nonlinear. Furthermore, the IR signal is very sensitive to geometry changes.

The bright side is that COMSOL Multiphysics does not set any limits with respect to 
these phenomena and allows you to study them fully.
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Model Library path: Heat_Transfer_Module/
Electronics_and_Power_Systems/thermal_anneal

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator.

2 From the Space dimension list, select 3D.

3 In the list of application modes select Heat Transfer Module>General Heat 

Transfer>Transient analysis, then click OK.

C O N S T A N T S  A N D  E X P R E S S I O N S

1 From the Options menu, select Constants.

2 Define the following constants; when done, click OK.

NAME EXPRESSION DESCRIPTION

T_wall 400[K] Temperature, wall

T_gas 400[K] Temperature, gas

h_gas 20[W/(m^2*K)] Heat transfer coefficient

k_sens 27[W/(m*K)] Thermal conductivity, sensor

rho_sens 2000[kg/m^3] Density, sensor

Cp_sens 500[J/(kg*K)] Heat capacity, sensor

e_sens 0.8 Surface emissivity, sensor

e_lamp 0.99 Surface emissivity, lamp

q_lamp 25[kW]/(pi*50^2*1[mm^3]) Heating power, lamp

e_wafer 0.5 Surface emissivity, wafer

Cp_lamp 10[J/(kg*K)] Heat capacity, lamp

ampl 50 Amplification factor
 2 :  E L E C T R O N I C S  A N D  P O W E R - S Y S T E M  M O D E L S



G E O M E T R Y  M O D E L I N G

1 Create three cylinders. To do so, open the menu item Draw>Cylinder and enter these 
settings; when finished, click OK.

2 Click the Zoom Extents button on the Main toolbar.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Physics menu, select Subdomain Settings.

2 In the General page, select Subdomain 1. In the Cp edit field type Cp_lamp, and in 
the Q edit field type q_lamp. Use the default values for both the conductivity and 
the density.

3 Select Subdomain 2, then click the Load button. In the Material list, select Basic 

Material Properties>Silicon. Click OK.

4 Select Subdomain 3. In the k edit field type k_sens, in the ρ edit field type 
rho_sens, and in the Cp edit field type Cp_sens.

5 Select all subdomains. Click the Init tab, then in the T(t0) edit field type T_wall.

6 Click OK.

Boundary Conditions
1 From the Physics menu, open the Boundary Settings dialog box.

2 Select Boundary 4. In the Boundary condition list select Heat flux, and in the Radiation 

type list select Surface-to-surface. In the ε edit field type e_lamp, and in the Tamb edit 
field type T_wall.

3 Select Boundaries 5–8, 10, 12, and 16. 

4 In the Boundary condition list select Heat flux. In the h edit field type h_gas, and in 
the Tinf edit field type T_gas.

5 In the Radiation type list select Surface-to-ambient. In the ε edit field type e_wafer, 
and in the Tamb edit field type T_wall.

6 Select Boundaries 7 and 16. From the Radiation type list, select Surface-to-surface.

7 Select Boundary 16 alone. Change the entry in the ε edit field to e_sens. Click OK.

OBJECT RADIUS HEIGHT AXIS BASE POINT, X AXIS BASE POINT, Z

CYL1 0.05 5e-4 0 0

CYL2 0.05 1e-3 0 -5e-2

CYL3 1e-2 1e-3 0.07 -5e-2
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M E S H  G E N E R A T I O N

1 From the Mesh menu, open the Free Mesh Parameters dialog box.

2 In the Predefined mesh sizes list, select Coarser. Click the Advanced tab. In the 
z-direction scale factor edit field type 5. Click the Remesh button, then click OK.

P R E P A R E  P O S T P R O C E S S I N G

To prepare some postprocessing operations, you need to define an integration 
coupling variable. In addition, a line intersecting the lamp and wafer surfaces is also 
helpful in later postprocessing.

1 Choose Options>Integration Coupling Variables>Boundary Variables.

2 Select Boundary 16. In the Name edit field type Sens_irrad, and in the Expression 

edit field type G_htgh (a predefined application mode variable representing inward 
radiation which includes both surface-to-surface and surface-to-ambient 
contributions). Click OK.

3 From the Draw menu select Line. In the edit fields for x, y, and z type 0 0, 0 0, and 
-5e-2 1e-3, respectively. Click OK. (This step is not necessary if you loaded the 
geometry file).

C O M P U T I N G  T H E  S O L U T I O N

1 From the Solve menu, select Solver Parameters.

2 On the General page, type 0 10 in the Times edit field.

3 In the Linear system solver list, select Direct (UMFPACK).

4 Click the Time Stepping tab. In the Times to store in output list, select Time steps from 

solver.

5 From the Consistent initialization of DAE systems list, select On.

6 From the Error estimation strategy list, select Exclude algebraic. Click OK.

The last setting instructs the solver to omit the radiation calculations, which is 
always a stationary solution (algebraic equation), from the time-stepping error 
analysis. This greatly speeds up the solution process in terms of time stepping.

7 Click the Solve button on the Main toolbar (the solving process should take less than 
a minute).

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N  

Generate Figure 2-53 by executing the following instructions:

1 From the Postprocessing menu open the Plot Parameters dialog box.
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2 On the General page, clear the Slice check box and select the Boundary check box in 
the Plot type area. Click OK.

The following steps generate Figure 2-54:

1 From the Postprocessing menu, open the Domain Plot Parameters dialog box.

2 On the General page, select the Keep current plot check box. 

3 On the Point page, select Point 10.

4 In the y-axis data area, verify that the selection in the Predefined quantities list is 
Temperature.

5 Click the Line Settings button. In the Line marker list, select Triangle.

6 Select the Legend check box, then click OK.

7 Click Apply to plot the lamp temperature.

8 Select Point 12, then click the Line Settings button.

9 In the Line marker list select Square, then click OK.

10 Click Apply to add the plot of the wafer temperature.

11 Select Point 23, then click the Line Settings button.

12 In the Line marker list select Circle, then click OK.

13 Click Apply to generate the sensor temperature plot.

Finally, add the IR-detector transient to the plot:

14 In the Expression edit field, type Sens_irrad*ampl.

15 Click the Line Settings button.

16 Set the Line color to Color, the Line style to Dashed line, and the Line marker to None. 
Click OK.

17 Click OK to generate the plot and close the Domain Plot Parameters dialog box.

18 Click the Edit Plot toolbar button in the figure window.

19 Select the first Line object in the Axes tree on the left, then type T<sub>lamp</sub> 
in the Legends dialog box.

20 Repeat the previous step for the remaining three line objects, entering the legends 
T<sub>wafer</sub>, T<sub>sensor</sub>, and Sens<sub>irrad</sub>, 
respectively.

21 Click OK to close the Edit Plot dialog box and finish the plot.
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Th e rmo -Pho t o - V o l t a i c  C e l l

Introduction

The following example illustrates an application that maximizes surface-to-surface 
radiative fluxes and minimizes conductive heat fluxes.

A thermo-photo-voltaic (TPV) cell generates electricity from the combustion of fuel 
and through radiation (Ref. 1). Figure 2-55 depicts the general operating principle. 
The fuel burns inside an emitting device that radiates intensely. Photo-voltaic (PV) 
cells—almost like solar cells—capture the radiation and convert it to electricity. The 
efficiency of a TPV device ranges from 1% to 20%. In some cases, TPVs are used in heat 
generators to co-generate electricity, and the efficiency is not so critical. In other cases 
TPVs are used as electric power sources, for example in automobiles (Ref. 2). In those 
cases efficiency is a major concern.

Figure 2-55: Operating principle of a TPV device (Ref. 3), and an image of a prototype 
system (Ref. 4).
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TPV systems, unlike typical electronic systems, must maximize radiation heat transfer 
to improve efficiency. However, inherent radiation losses—radiation not converted to 
electric power—contributes to the PV cells’ increased temperature. Further, heat 
transfer through conduction results in increased cell temperature. PV cells have a 
limited operating temperature range that depends on the type of material used. Solar 
cells are limited to temperatures below 80 °C, whereas high-efficiency semiconductor 
materials can withstand as much as 1000 °C. Photovoltaic efficiency is often a function 
of temperature with a maximum at some temperature above ambient.

To improve system efficiency, engineers prefer to use high-efficiency PV cells, which 
however can be quite expensive. To reduce system costs, engineers work with 
smaller-area PV cells and then use mirrors to focus the radiation on them. However, 
there is a limit for how much you can focus the beams; if the radiation intensity 
becomes too high, the cells can overheat. Thus engineers must optimize system 
geometry and operating conditions to achieve maximum performance at minimum 
material costs.

The following model, which uses the General Heat Transfer application mode, 
investigates the influence of operating conditions (flame temperature) on system 
efficiency and the temperature of components in a typical TPV system. The model can 
also assess the influence of geometry changes.
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Model Definition

Figure 2-56: Geometry and dimensions of the modeled TPV system.

Figure 2-56 depicts the geometry and dimensions of the system under study. To 
reduce the temperature, the PV cells are water cooled on their back side (at the 
interface with the insulation).

The following equation describes the heat fluxes, radiative flux, and conductive flux; 
after it comes the boundary condition equation

where ρ is the density, k denotes the thermal conductivity (W/(m·K)), Q represents 
the volume heat source (W/m3), n is the surface normal vector, h is the convective 
heat transfer film coefficient (W/(m2·K)), Tinf equals the temperature of the 
convection coolant, ε equals the surface emissivity, J0 is the surface radiosity expression 
(W/m2, further described in the Heat Transfer Module User’s Guide), and σ equals 
the Stefan-Boltzmann constant.

Mirrors

PV-cells

Emitter

Insulation

Flame

ρ Cp
∂T
∂t
------- k T∇–( )∇+ Q=

n– k∇T–( )⋅ h Tinf T–( ) ε 1 ε–( )⁄( ) J0 σ T4
–( ) q+ +=
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Conduction is always present on the different boundaries. The model simulates the 
emitter with a specific temperature, Theater, on the inner boundary. At the outer 
emitter boundary, it takes radiation (surface-to-surface) into account in the boundary 
condition. It simulates the mirrors by taking radiation into account on all boundaries 
and applying a low emissivity. The inner boundaries of the PV cells and of the 
insulation also make use of radiation boundary conditions. However, the PV cells have 
a high emissivity and the insulation a low emissivity. Further, the PV cells convert a 
fraction of the irradiation to electricity instead of heat. Heat sinks on their inner 
boundaries simulate this effect according to

where G is the irradiation flux (W/m2) and ηpv is the PV cell’s voltaic efficiency. The 
latter depends on the local temperature, with a maximum of 0.2 at 800 K:

Figure 2-57 illustrates this expression for temperatures above 1000 K.

Figure 2-57: PV cell voltaic efficiency versus temperature.

At the outer boundary of the PV cells, the model applies convective water cooling by 
setting h to 50 W/(m2·K), and Tamb to 273 K. Finally, at the outer boundary of the 
insulation it applies convective cooling with h set to 5 W/(m2·K) and Tamb to 293 K.
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Table 2-7 summarizes the material properties.

The model calculates the stationary solution for a range of emitter temperatures 
(1000 K to 2000 K) using the parametric solver.

Results and Discussion

The results shows that the device experiences a significant temperature distribution 
that varies with operating conditions. Figure 2-58 depicts the stationary distribution 
at operating conditions with an emitter temperature of 2000 K.

Figure 2-58: Temperature distribution in the TPV system when the emitter temperature is 
2000 K.

As the upper plot in Figure 2-59 shows, the PV cells reach a temperature of 
approximately 1800 K. This is significantly higher than their maximum operating 

TABLE 2-7:  MATERIAL PROPERTIES

COMPONENT  k [W/(m·K)]  ρ [kg/m3]  Cp [J/(kg·K)]  ε 

emitter 10 2000 900 0.99

mirror 10 5000 840 0.01

PV cell 93 2000 840 0.99

insulation 0.05 700 100 0.1
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temperature of 1600 K, above which their photovoltaic efficiency is zero (see 
Figure 2-57 on page 147).

It is interesting to investigate what the optimal operating temperature is. The lower 
plot in Figure 2-59 investigates at what temperature the system achieves the maximum 
electric power output. The optimal emitter temperature for this configuration seems 
to be between 1600 K and 1700 K, where the electric power (irradiation multiplied by 
voltaic efficiency) is maximum.

Figure 2-59: PV cell temperature (top) and electric output power (bottom) versus 
operating temperature.
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The next step is to look at the temperature distribution at the optimal operating 
conditions (Figure 2-60).

Figure 2-60: Temperature distribution and surface irradiation flux in the system at an 
operating emitter temperature of 1600 K.

When the emitter is at 1600 K, the PV cells reach a temperature of approximately 
1200 K, which they can withstand without any problems. Note that the insulation 
reaches a temperature of approximately 800 K on the outside, suggesting that the 
system transfers a significant amount of heat to the surrounding air.

The plot also depicts the irradiative flux, which varies significantly along the 
circumference of the PV cell and insulation jacket. To further investigate this effect, 
Figure 2-61 plots the irradiative flux along a quarter of the circumference separately at 
this operating condition. Clearly the variation it shows is related to the positions of the 
mirrors and is an effect of shadowing.
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Figure 2-61: Irradiation flux along the PV cell and insulation inner surface for one 
quarter of the device circumference.

This plot can help optimize the mirror geometry as well as help decide how large the 
PV cells should be and where they should be placed.

A general conclusion is that this type of modeling can shortcut the prototype 
development time and optimize the operating conditions for the finalized TPV device.
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Model Library path: Heat_Transfer_Module/
Electronics_and_Power_Systems/TPV_cell

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator. From the Space dimension list, select 2D.

2 In the list of application modes, select Heat Transfer Module>General Heat Transfer.

3 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu open the Axes/Grid Settings dialog box. Go to the Axis page. 
In both the x min and y min edit fields, type -0.05, and in both the x max and y max 
edit fields, type 0.05.

2 On the Grid page, clear the Auto check box. In both the x spacing and y spacing edit 
fields type 0.002. Click OK.

3 From the Options menu, select Constants. In the dialog box that opens, enter the 
following names, expressions, and (optionally) descriptions; when done, click OK.

NAME EXPRESSION DESCRIPTION

T_heater 1000[K] Temperature, emitter inner boundary

Cp_air 1100[J/(kg*K)] Specific heat capacity, air

h_air 5[W/(m^2*K)] Heat transfer coefficient, air

T_air 293[K] Temperature, air

k_ins 0.05[W/(m*K)] Thermal conductivity, insulation

rho_ins 700[kg/m^3] Density, insulation

Cp_ins 100[J/(kg*K)] Specific heat capacity, insulation

e_ins 0.1 Surface emissivity, insulation

k_m 10[W/(m*K)] Thermal conductivity, mirror

rho_m 5000[kg/m^3] Density, mirror

Cp_m 840[J/(kg*K)] Specific heat capacity, mirror

e_m 0.01 Surface emissivity, mirror

k_emit 10[W/(m*K)] Thermal conductivity, emitter

rho_emit 2000[kg/m^3] Density, emitter
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4 Choose Options>Expressions>Scalar Expressions, then define the following 
expressions:

5 Optionally, enter the descriptions Density, air; Thermal conductivity, air; 
and Voltaic efficiency, PV cell.

6 Click OK.

G E O M E T R Y  M O D E L I N G

1 Create two circles. To do so, choose Draw>Specify Objects>Circle. For the first circle, 
type 0.035 in the Radius edit field, and for the second, type 0.037.

2 Click the Create Composite Object button on the Draw toolbar. In the Set formula 

edit field, type C2-C1, then click OK.

3 Specify a rectangle by pressing Shift and clicking the Rectangle button on the Draw 
toolbar. In both the Width and Height edit fields, type 0.05, and in the x-base edit 
field, type -0.05. Click OK.

4 Select all the objects and click the Intersection button on the Draw toolbar. This 
creates the composite object CO2, which is a quarter of an annulus.

Cp_emit 900[J/(kg*K)] Specific heat capacity, emitter

e_emit 0.99 Surface emissivity, emitter

k_pv 93[W/(m*K)] Thermal conductivity, PV-cell

rho_pv 2000[kg/m^3] Density, PV-cell

Cp_pv 840[J/(kg*K)] Specific heat capacity, PV-cell

e_pv 0.99 Surface emissivity, PV-cell

h_cool 50[W/(m^2*K)] Heat transfer coefficient, cooling water

T_cool 273[K] Temperature, cooling water

NAME EXPRESSION

rho_air 1.013e5[Pa]*28.8e-3[kg/mol]/(8.31[J/(mol*K)]*T)

k_air 10^(-3.723+0.865*log10(abs(T[1/K])))[W/(m*K)]

eta_pv 0.2*(1-(T/800[K]-1)^2)*(T<1600[K])

NAME EXPRESSION DESCRIPTION
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5 To create the first mirror, create two rectangles: For each rectangle, press Shift then 
click the Rectangle button on the Draw toolbar, enter settings from the table below, 
and then click OK.

6 Select both rectangles, then click the Create Composite Object button on the Draw 
toolbar. Clear the Keep interior boundaries check box, then click OK to create the 
union.

7 From the Draw menu open the Fillet/Chamfer dialog box.

8 In the Vertex selection list click the CO1 folder, then select Vertices 1, 2, 5, and 8–10. 
In the Radius edit field, type 0.5e-3, then click OK. This step creates the composite 
object CO3.

9 Copy and paste CO3 by pressing Ctrl+C and then Ctrl+V. When pasting, specify the 
Displacement for x as 0.014 and for y as 0.006. Click OK.

10 Select CO3. Click the Rotate button on the Draw toolbar. In the Rotation angle edit 
field type 45. Go to the Center point area; in the x edit field type -0.014, and in the 
y edit field type 0.014. Click OK.

11 Click the Line button on the Draw toolbar. Draw a line by left-clicking at (0, 0)—
you can read the position in the lower left corner of the user interface—and at 
(−0.046, 0.012). Finalize the line by right-clicking in the drawing area.

12 Repeat the procedure in the previous step to draw three additional lines between the 
coordinates (0, 0) and (−0.024, 0.040), between (0, 0) and (−0.012, 0.046), as well 
as between (0, 0) and (−0.04, 0.024).

13 Select the circle object CO2 and the first line, B1. Click the Coerce to Solid button 
on the Draw toolbar.

14 Using the mouse, select the annulus object (now named CO4) and the second line. 
Click Coerce to Solid.

15 Select the annulus object (now named CO2) and the third line, B3. Click Coerce to 

Solid.

16 Select all objects (press Ctrl+A) and click Coerce to Solid.

17 Press Ctrl+C to copy the new composite object. Press Ctrl+V, then click OK to paste 
it with zero displacement.

18 Click Rotate. For the Rotation angle specify 90, then click OK.

OBJECT WIDTH HEIGHT BASE X-BASE Y-BASE

R1 0.01 0.002 Center -0.014 0.015

R2 0.002 0.006 Center -0.014 0.017
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19 Repeat the paste-and-rotate procedure for 180 and 270 degrees to complete the 
circular object. Press Ctrl+D to clear the selection before selecting the original 
composite object to make a copy and then rotate it.

20 Draw two circles using the menu item Draw>Specify Objects>Circle. For the first one, 
type 0.04 in the Radius edit field, and for the second one, type 0.037.

21 Click the Zoom Extents button on the Main toolbar.

22 Select the two circles, click the Create Composite Object button on the Draw toolbar, 
and in the Set formula edit field type the expression C1-C2. Click OK.

23 Select all objects (press Ctrl+A).

24 Click the Split Object button on the Draw toolbar.

25 Select the objects indicated in the following figure, then click the Create Composite 

Object button on the Draw toolbar. Clear the Keep interior boundaries check box, 
then click OK.

26 Draw two circles using the menu item Draw>Specify Objects>Circle. For the first one, 
type 0.01 in the Radius edit field, and for the second one, type 0.011.

27 Click the Create Composite Object button on the Draw toolbar, then in the Set 
formula edit field type C2-C1. Click OK.
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28 To finalize the geometry select all objects, then click Coerce to Solid.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Physics menu, select Subdomain Settings.

2 In the Init page, select all the subdomains. In the T(t0) edit field enter T_air.

3 Go to the General page and specify the following settings; when done, click OK.

Boundary Conditions
1 From the Physics menu, open the Boundary Settings dialog box.

2 Select the Interior boundaries check box to enable the specification of interior 
boundaries.

3 Select all the boundaries of the mirror objects by using the mouse to draw a box 
around each mirror. Press and hold the Ctrl key on the keyboard to add selections.

4 Click the Boundary Condition tab. In the Boundary condition list, select Heat source/

sink. In the Radiation type list, select Surface-to-surface. In the ε edit field for Surface 

emissivity, type e_m.

SETTINGS SUBDOMAIN 1 SUBDOMAINS 2, 3, 
6, 7, 12, 13, 17, 18

SUBDOMAINS 5, 8, 
9, 10, 11, 14, 15, 16

SUBDOMAIN 19 SUBDOMAINS 4, 
20

 k k_ins k_pv k_m k_emit k_air

 ρ rho_ins rho_pv rho_m rho_emit rho_air

 Cp Cp_ins Cp_pv Cp_m Cp_emit Cp_air

 Opacity Opaque Opaque Opaque Opaque Transparent
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5 In the Boundary selection list, choose 97, 98, 141, and 148 (the outer boundaries of 
the insulation). In the Boundary condition list, select Heat flux. In the h edit field for 
the Heat transfer coefficient, type h_air, and in the Tinf edit field for External 

temperature, type T_air. In the Radiation type list, select Surface-to-ambient. In the 
ε edit field, type e_ins, and in the Tamb edit field for Ambient temperature, type 
T_air.

6 In the Boundary selection list, choose 101, 102, 105, 106, 133, 134, 142, 147, 167, 
168, 183, and 184 (the inner boundaries of the insulation). In the Boundary 

condition list, select Heat source/sink. In the Radiation type list, select 
Surface-to-surface. In the ε edit field, type e_ins.

7 In the Boundary selection list, choose 99, 100, 119, 120, 157, 158, 181, and 182 
from the list (the outer boundaries of the cells). In the Boundary condition list, select 
Heat source/sink. In the h edit field, type h_cool, and in the Tinf edit field type 
T_cool.

8 In the Boundary selection list, choose 103, 104, 115, 116, 155, 156, 179, and 180 
(the inner boundaries of the cells). In the Boundary condition list, select Heat source/

sink. In the Radiation type list select Surface-to-surface. In the q0 edit field for Heat 

source/sink, type -G_htgh*eta_pv, and in the ε edit field type e_pv.

9 In the Boundary selection list, choose 127, 128, 143, and 146 (the outer boundaries 
of the emitter). In the Boundary condition list, select Heat source/sink. In the 
Radiation type list, select Surface-to-surface. In the ε edit field, type e_emit.

10 Finally, in the Boundary selection list, choose 131, 132, 144, and 145 (the inner 
boundaries of the emitter). In the Boundary condition list, select Temperature. In the 
T0 edit field for Temperature, type T_heater.

11 Click OK.

M E S H

1 From the Mesh menu open the Free Mesh Parameters dialog box.

2 In the Predefined mesh sizes list select Coarser.

3 Go to the Boundary page. Using the mouse, select all boundaries of the mirrors and 
of the emitter’s outer boundary. In the Maximum element size edit field type 1e-3.

4 Select all inner boundaries of the insulation and the PV cells (101, 102, 103, 104, 
105, 106, 119, 120, 133, 134, 142, 147, 155, 156, 167, 168, 179, 180, 183, and 
184). In the Maximum element size edit field type 2e-3. Click Remesh, then click OK.
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C O M P U T I N G  T H E  S O L U T I O N

1 From the Solve menu open the Solver Parameters dialog box.

2 On the General page, find the Solver list and select Parametric. In the Linear system 

solver list select Direct (UMFPACK). In the Parameter name edit field type T_heater, 
and in the Parameter values edit field type 1000:100:2000.

3 On the Parametric page, select the Manual tuning of parameter step size check box. 
In the Initial step size edit field type 100. Specify a Minimum step size of 25 and a 
Maximum step size of 100.

4 Click the Stationary tab. In the Maximum number of iterations edit field type 50.

5 Click OK.

6 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N  

Figure 2-58 is the default postprocessing plot. To reproduce the plots in Figure 2-59, 
follow these steps:

1 From the Postprocessing menu open the Domain Plot Parameters dialog box.

2 On the General page, clear the check box next to the label Element refinement (doing 
so disables automatic refinement), then in the corresponding edit field type 1.

3 Go to the Point page. In the Point selection list, choose Point 6.

4 In the Expression edit field, type G_htgh*eta_pv, then click Apply to generate the 
upper plot.

5 Click the General tab. From the Plot in list, select New figure.

6 Return to the Point page. In the Expression edit field, type T.

7 Click OK to close the dialog box and generate the lower plot.

To generate Figure 2-60, follow these steps:

1 From the Postprocessing menu, open the Plot Parameters dialog box.

2 On the General page, find the Parameter value list and select 1600.

3 On the Boundary page, select the Boundary plot check box.

4 On the Boundary Data page, select Surface irradiation from the Predefined quantities 
list.

5 On the Height Data page, select the Height data check box.

6 From the Predefined quantities list, select Surface irradiation.

7 In the Boundary color area, select hsv from the Colormap list.
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8 Click OK to close the dialog box and generate the plot.

9 To make the axes and the grid disappear, double-click the AXIS and GRID buttons on 
the status bar at the bottom of the user interface.

To reproduce Figure 2-61, follow these steps:

1 From the Postprocessing menu, open the Domain Plot Parameters dialog box.

2 On the General page, find the Solutions to use list and select 1600. From the Plot in 
list, select New figure.

3 Click the Line/Extrusion tab, and in the Predefined quantities list select Surface 

irradiation. 

4 In the Boundary selection list, choose 102, 104, 106, 116, and 134 (a quarter of the 
system’s inner wall). Click OK.
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Con v e c t i v e  Coo l i n g  o f  a  Po t c o r e  
I n du c t o r

Introduction

The inductor is a common component in a variety of different electrical devices. Its 
usage ranges from power transformation to measurement systems. In small devices 
with many components, such as in laptop computers, heat generation can be a problem 
and has to be accounted for in the design. This model describes the heat transfer in a 
potcore inductor that is cooled by convective cooling.

Model Definition

The problem is axisymmetric, so the model only requires two space dimensions. The 
following figure describes the model geometry:

Figure 2-62: 3D view of the model geometry.

A varying current in the copper induces a magnetic field that is strengthened by the 
ferrite core. Heat is generated in the core and the winding due to resistive heating.

This model does not include the resistive heating due to induced currents, but instead 
assumes that a specific amount of heat is generated uniformly in the core and in the 
copper.
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The component is cooled by air that enters from the top of the geometry and exits 
through the center and the lower part of the outer boundary.

Results and Discussion

Figure 2-63 shows the temperature distribution together with an arrow plot of the 
velocity field. The temperature has a a maximum in the copper winding where most of 
the heat is generated. It is clear that the air flow has a cooling effect on the temperature 
although this effect is not optimal. The arrow plot reveals that the air flow between the 
barrier and the ferrite core is very close to zero. Note also the recirculation zone in 
right part of the plot.

Figure 2-63: Surface plot of the temperature and arrow plot of the velocity field.

In the overall heat balance, radiation is responsible for about 10% of the total heat loss 
at steady state. The plot in Figure 2-64 shows a cross-sectional plot of the net radiative 
flux along the inner, vertical, boundary of the central hole (see Figure 2-62). Note that 
away from the open ends, the emitted and reflected radiation is almost balanced by the 
incident energy, so even if the temperature and radiation levels are high, the net flux is 
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small in this region. The main part of the radiative losses instead take place from the 
outside of the inductor.

Figure 2-64: Cross-sectional plot of the net radiative flux.

Modeling in COMSOL Multiphysics

This model uses the General Heat Transfer application mode to solve for the 
temperature distribution. To provide cooling for the component, air enters the domain 
at the top of the geometry at the speed of 1 m/s. To include the air flow, the model 
also uses the Weakly Compressible Navier-Stokes application mode. The viscosity and 
density of air and hence the air flow depend on the temperature; on the other hand, 
the temperature distribution depends on the flow around the component. This means 
that this multiphysics model has to be solved simultaneously.

In this axisymmetric model, some of the surfaces are exposed to heat radiation from 
other surfaces, which means that surface-to-surface radiation must be accounted for. 
This type of radiation is quite complex because it depends on radiation from both the 
ambient and other surfaces. However, on some surfaces this complex boundary 
condition can be simplified to surface-to-ambient radiation. These are the surfaces that 
cannot be seen from any other radiating surfaces.

Model Library path: Heat_Transfer_Module/
Electronics_and_Power_Systems/potcore_inductor
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Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 In the Model Navigator, select Axial symmetry (2D) from the Space dimension list.

2 Select Heat Transfer Module>Fluid-Thermal Interaction>Non-Isothermal Flow.

3 Click OK to close the Model Navigator.

O P T I O N S  A N D  S E T T I N G S

1 Open the Constants dialog box from the Options menu and enter the constants 
according to the following table (the descriptions are optional).

2 Click OK to close the dialog box.

NAME EXPRESSION DESCRIPTION

Q_core 7.64e4[W/m^3] Heat source in the core

Q_copper 8.657e5[W/m^3] Heat source in the copper

p0 101.3[kPa] Atmosphere pressure

T_amb 25[degC] Ambient temperature

eps_ferrite 0.2 Surface emissivity of ferrite

eps_quartz 0.8 Surface emissivity of quartz
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G E O M E T R Y  M O D E L I N G

1 Create rectangles according to the following table by shift-clicking on the Rectangle/

Square button on the Draw toolbar and then specifying their width, height, and 
corner position.

2 Click the Zoom Extents button on the Main toolbar to fit the model geometry to 
your window.

3 Draw a line from (0.05, 0) to (0.05, 0.02).

The geometry should now look like that in Figure 2-65.

Figure 2-65: The model geometry.

WIDTH HEIGHT CORNER

0.05 0.05 (0,0)

0.03 0.02 (0,0.05)

0.0185 0.0294 (0.0027,0)

0.00895 0.0203 (0.00885,0.00455)

0.002 0.015 (0.011,0.0072)

0.001 0.03 (0.03,0)
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P H Y S I C S  S E T T I N G S

Subdomain Settings—General Heat Transfer
1 Select the General Heat Transfer application mode from the Model Tree.

2 From the Physics menu, choose Subdomain Settings.

3 Select Subdomains 1 and 2, then click the Load button.

4 Select Air from the Basic Material Properties library, then click OK.

Some of the boundaries in the model are exposed to surface-to-surface radiation. 
Before specifying this boundary condition you must first specify which subdomains 
that are opaque and which are transparent. By default, all subdomains are assumed 
to be opaque.

5 Select Transparent from the Opacity list.

6 Click the Convection tab.

7 Edit the field for the Absolute pressure so that it reads p.

8 Return to the General page.

9 Select Subdomains 3 through 6 and from the Group list, select Solid domain.

10 Select Subdomain 5, then click the Load button.

11 Select Copper from the Basic Material Properties library, then click OK.

12 Type Q_copper in the Heat source edit field.

13 For the remaining subdomains, specify the material properties according to the 
following table:

14 Select the ferrite subdomain (Subdomain 3), then type Q_core in the Heat source 
edit field.

15 Click OK.

Boundary Conditions—General Heat Transfer
1 From the Physics menu, open the Boundary Settings dialog box.

SETTINGS SUBDOMAIN 3 (FERRITE) SUBDOMAIN 4 (MYLAR) SUBDOMAIN 6 (QUARTZ)

k (isotropic) 5 0.2 6.1

 ρ 4800 1393 2648

 Cp 750 1000 759
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2 Select the Interior boundaries check box, then specify the boundary conditions 
according to the following tables; when done, click OK.

Subdomain Settings—Weakly Compressible Navier-Stokes
1 Select the Weakly Compressible Navier-Stokes application mode from the Model Tree.

2 From the Physics menu, open the Subdomain Settings dialog box.

The solid domains can be deactivated because there is no flow in them.

3 Select Subdomains 3–6, then from the Group list, select Solid domain.

4 Select Subdomains 1 and 2, then select Air from the Library material list.

5 On the Init page, type p0 in the Pressure edit field.

6 On the Stabilization page, enter 0.3 in the Tuning parameter edit field for Crosswind 

diffusion.

7 Click OK to close the Subdomain Settings dialog box.

The extra crosswind diffusion is needed to deal with the shear layers that appears in this 
model.

Boundary Conditions—Weakly Compressible Navier-Stokes
1 From the Physics menu, open the Boundary Settings dialog box.

SETTINGS BOUNDARIES 1, 3 BOUNDARIES 5, 
22, 23, 27

BOUNDARIES 2, 
26

BOUNDARIES 7, 
18, 20, 25

Boundary 
condition

Axial 
symmetry

Temperature Convective flux Insulation/
Symmetry

T0 T_amb

Radiation type None

SETTINGS BOUNDARIES 6, 
17

BOUNDARY 8 BOUNDARIES 21, 
24

BOUNDARY 19

Boundary 
condition

Heat source/
sink

Heat source/
sink

Heat source/
sink

Heat source/
sink

Tamb T_amb T_amb T_amb T_amb

Radiation type Surface-to- 
surface

Surface-to- 
surface

Surface-to- 
surface

Surface-to- 
surface

Surface 
emissivity

eps_ferrite eps_ferrite eps_quartz eps_quartz
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2 Specify boundary conditions according to the following table; when done, click OK.

3 From the Physics menu, select Point settings.

4 Select Point 22, then select the Point constraint check box.

5 In the P0 edit field, type p0, then click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, open the Free Mesh Parameters dialog box.

2 On the Global page, select Extra fine from the Predefined mesh sizes list.

3 On the Subdomain page, select subdomains 1 and 2.

4 From the Method list, select Triangle.

5 Click Remesh to create the mesh and then OK to close the dialog box.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar to compute the solution.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows the temperature distribution. To create Figure 2-63, follow 
these steps:

1 Click the Plot Parameters button on the Main toolbar.

2 Click the Arrow tab.

3 Select the Arrow plot check box.

4 From the Predefined quantities list, select Weakly Compressible Navier-Stokes 

(chns)>Velocity field.

5 In the z points edit field, type 18.

6 Clear the Auto check box for Scale factor, and type 1.2 in the associated edit field.

7 Click the Color button. Select white from the palette, then click OK.

8 Click OK.

SETTINGS BOUNDARIES 1, 3 BOUNDARY 5 BOUNDARY 2 BOUNDARY 26

Boundary type Symmetry 
boundary

Inlet Outlet Outlet

Boundary 
condition

Axial 
symmetry

Velocity Pressure, no 
viscous stress

No viscous 
stress

U0 1[m/s]

p0 p0
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To view a cross-sectional plot of the surface irradiation, proceed with the following 
steps:

1 From the Postprocessing menu, open the Domain Plot Parameters dialog box.

2 Go to the Line/Extrusion page and select General Heat Transfer (htgh)>Radiative flux 
from the Predefined quantities list.

3 Select Boundary 6, then click OK to generate the plot in Figure 2-64.
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T empe r a t u r e  D i s t r i b u t i o n  i n  a  
D i s c - T y p e  T r a n s f o rme r

Introduction

This example illustrates a multiphysics application that involves heat transfer and fluid 
flow. The model simulates the steady-state temperature distribution in an oil-cooled 
ring-shaped transformer. It is based on published work by J.-M. Mufuta and others 
(Ref. 1).

Thermal aspects have a great importance in the design of large power transformers. 
First, sufficient cooling is necessary to avoid overheating. Second, the ageing of 
electrically insulating materials in transformers is directly proportional to the increase 
above a certain temperature. In order to design a transformer properly, it is necessary 
to study both the overall cooling power and the temperature distribution, which 
reveals where hot spots appear. They are a limiting factor in terms of ageing.

Figure 2-66: Geometry of the transformer coils.

The metallic transformer coils (Figure 2-66) heat up during operation. Transformer oil 
pumped through the coils perform the necessary cooling. The oil has a viscosity and 

A-A

a)
Top view

Inlet 
cooling oil

b)
Side view
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density that vary with temperature, so heating affects the fluid-flow pattern. The 
model in this example simulates the steady-state temperature distribution in the 
transformer by modeling both the conduction-convection problem and the 
nonisothermal flow field. The geometry is axisymmetric, and this example models a 
unit cell consisting of 20 coils divided in two rows.

Model Definition

The model uses two stationary application modes to simulate the problem: Weakly 
Compressible Navier-Stokes and General Heat Transfer.

It simulates the momentum transport and mass conservation with the Weakly 
Compressible Navier-Stokes equations that describe the fluid velocity, u, and the 
pressure field, p. In this case, the density, ρ, and the viscosity, η, are temperature 
dependent:

Variations in density result in buoyancy forces, expressed as ρ g, and a continuity 
equation for the total mass, as expressed in the previous equations.

The General Heat Transfer application mode is based on a general energy balance:

Here k represents thermal conductivity, Cp is the (temperature-dependent) specific 
heat capacity, and Q is the heating power per unit volume. For this model, use the value 
32,400 W/m3 for Q. Furthermore, set the thermal conductivities for the oil and the 
conductor material to 0.125 W/(m·K) and 383 W/(m·K), respectively.

The temperature-dependent expressions for ρ, η, and Cp used in the model read (this 
information comes from the producer of the transformer oil, 10GBN: Nynäs 
Petroleum AB, Stockholm, Sweden):

In these expressions, T refers to the temperature value in degrees Celsius.

ρu ∇⋅ u ∇ pI– η ∇u ∇u( )T
+( ) 2η 3⁄( ) ∇ u⋅( )I–+[ ]⋅ ρg+=

∇ ρu( )⋅ 0=

∇ k∇T–( )⋅ Q ρ Cp u ∇T⋅–=

ρ 875.6 0.63– T  kg/m3
=

η ρ 10 4.726– 0.0091– T( ) m2/s=

Cp 1960 4.005T  J/(kg·K)+=
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The transformer’s cylindrical geometry allows for 2D axisymmetric modeling of a cross 
section as in Figure 2-67. The conductor coils are 25 mm wide and 15 mm high in 
cross section. The rows of coils have a radial separation of 10 mm and a vertical 
separation of 5 mm. The first row has a distance of 5 mm from the center. The gap 
between the second row and the outer wall is 10 mm.

Figure 2-67: Transformer cross section. Because of axisymmetry you can use cylindrical 
coordinates and only need to include the shaded half in the model geometry.

At the boundary in the center of the cylinder, the model uses the axisymmetry 
condition for both application modes.

The fluid flow application boundary conditions are as follow. At the bottom boundary 
(the inlet), the fluid velocity is 5 mm/s in the z direction. At the top boundary (the 
outlet), the pressure is constant, and the r-velocity is zero. On the outer wall and on 
all coil surfaces, the fluid velocity is zero (no slip).

The boundary conditions for the heat equation application mode are:

• Oil inlet temperature of 50 °C

• Only convective heat flux at the outlet boundaries: 

• Axisymmetry at the center (r = 0)

r

z

Axisymmetry

n k∇T–( )⋅ 0=
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• Insulation at the outer wall (r = 0.075 m)

• The outer boundaries of the top and bottom conductor are thermally insulated

The solution of the specified equations and boundary conditions gives the temperature 
and flow field in the transformer.

Results and Discussion

One interesting result from this simulation concerns the temperature of the hot spot. 
Figure 2-68 depicts the temperature distribution at steady state for both the 
nonisothermal and an isothermal flow model, neglecting the variation in viscosity and 
density.

Figure 2-68: Temperature distribution in the transformer cross section.

For the nonisothermal model, the maximum temperature (at the hot spot) is 55 °C, 
occurring at the top inner coil, and note that the isothermal-flow model predicts a 
somewhat higher temperature. Also, there is no difference between the temperatures 
of the two columns. You can explain the differences between the models with their 
different fluid flows, which are affected by the temperature change.

Nonisothermal Isothermal
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Figure 2-69: Fluid flow field in the transformer cross section.

Figure 2-69 shows the flow field for the two cases. The fluid velocity is higher for the 
non-isothermal case close to the center in the upper part of the transformer. This effect 
is caused mainly by the reduced viscosity due to a higher temperature. The buoyancy 
effects can also contribute to some extent. Furthermore, the flow field is more uniform 
between the vertical openings. In the isothermal case, the flow field is close to identical 
in the two outer vertical shafts. In this case, the velocity experiences a decrease in the 
central shaft due to the smaller shaft area.

Nonisothermal Isothermal
TE M P E R A T U R E  D I S T R I B U T I O N  I N  A  D I S C - TY P E  TR A N S F O R M E R  |  173



174 |  C H A P T E R
In the non-isothermal model it is interesting to see that there exists a radial fluid 
velocity between the coils.

Figure 2-70: The radial component of the flow field in the nonisothermal case.

Figure 2-70 and Figure 2-71 display the radial velocity in the horizontal openings 
between the conductors. There is a flux of oil from the outer parts toward the middle 
of the transformer. The radial-velocity component varies in the transformer. Generally, 
the fluid flows toward the center of the transformer. The flow is more pronounced in 
the outer and lower regions.

Nonisothermal
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Figure 2-71: Radial fluid velocity for the non-isothermal model as a function of vertical 
position (z) at: r = 1.75 cm (solid line); and r = 5.25 cm (dashed line).

A general conclusion drawn from this model is that the variation in viscosity and 
density improve cooling. If you use modeling to optimize the transformer design with 
respect to hot spots, you should take the non-isothermal flow effects into account to 
produce more accurate simulation results.

Reference

1. J.-M. Mufuta and E. van Den Bulck, “Modeling of mixed convection in the 
windings of a disc-type power transformer,” Applied Thermal Engineering, vol. 20, 
pp. 417–437, 2000.

Model Library path: Heat_Transfer_Module/
Electronics_and_Power_Systems/power_transformer
TE M P E R A T U R E  D I S T R I B U T I O N  I N  A  D I S C - TY P E  TR A N S F O R M E R  |  175



176 |  C H A P T E R
Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 In the Model Navigator, go to the Space dimension list and select Axial symmetry (2D).

2 In the list of application modes select 
Heat Transfer Module>Fluid-Thermal Interaction>Non-Isothermal Flow.

3 Click OK.

G E O M E T R Y  M O D E L I N G

1 Press the Shift key and click the Rectangle/Square button on the Draw toolbar.

2 In the dialog box that appears enter these rectangle properties; when done, click OK.

3 Click the Zoom Extents button on the Main toolbar.

4 Add a second rectangle, R2, with these properties:

5 With R2 selected, click the Array button on the Draw toolbar.

6 In the Array dialog box, enter the following settings; when done, click OK.

PROPERTY VALUE

Width 0.075

Height 0.18

Base Corner

r 0

z 0

PROPERTY VALUE

Width 0.025

Height 0.0075

Base Corner

r 0.005

z 0

DISPLACEMENT ARRAY SIZE

r 0.035 2

z 0.1725 2
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7 Add a rectangle, R6, with these properties:

8 With R6 selected, click the Array button on the Draw toolbar.

9 In the Array dialog box, enter the following settings; when done, click OK.

The geometry-modeling stage is now complete, with the following result:

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

2 Define the following names, expressions, and (optionally) descriptions; when done, 
click OK.

PROPERTY VALUE

Width 0.025

Height 0.015

Base Corner

r 0.005

z 0.0125

DISPLACEMENT ARRAY SIZE

r 0.035 2

z 0.02 8

NAME EXPRESSION DESCRIPTION

T0 50[degC] Inlet temperature, fluid

k_f 0.125[W/(m*K)] Thermal conductivity, fluid
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P H Y S I C S  S E T T I N G S

1 From the Options menu select Expressions>Scalar Expressions.

2 Define the following names and expressions; when done, click OK.

Appending the operator [1/degC] to the variable T extracts the temperature value 
in degrees Celsius.

Subdomain Settings—Weakly Compressible Navier-Stokes
1 From the Multiphysics menu, select Weakly Compressible Navier-Stokes (chns).

2 From the Physics menu, open the Subdomain Settings dialog box. 

3 Choose Subdomains 2–21 (select 2 in the list, hold the Shift key down, then click 
number 21). From the Group list, select Solid domain.

4 Select Subdomain 1.

5 On the Physics page, set η to eta and Fz to -9.81[m^2/s]*rho.

6 Click OK.

Subdomain Settings—General Heat Transfer
1 From the Multiphysics menu, select General Heat Transfer (htgh).

2 From the Physics menu, select Subdomain Settings.

3 Select all subdomains. Click the Init tab, then type T0 in the T(t0) edit field.

4 Choose Subdomains 2–21 (select 2 in the list, hold the Shift key down, then click 
number 21). From the Group list, select Solid domain.

5 Click the General tab.

k_s 383[W/(m*K)] Thermal conductivity, solid

Q_s 32400[W/m^3] Heating source

v0 5[mm/s] Inlet flow velocity

NAME EXPRESSION DESCRIPTION

rho (875.6-0.63*T[1/degC])[kg/m^3] Fluid density

Cp (1960+4.0005*T[1/degC])[J/(kg*K)] Specific heat capacity

eta rho*10^(-4.726-0.0091*T[1/degC])[m^2/s] Dynamic viscosity

NAME EXPRESSION DESCRIPTION
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6 Enter settings according to the following table (where the table entry is “-” leave 
the predefined setting); when done, click OK.

Boundary Conditions—Weakly Compressible Navier-Stokes
1 From the Multiphysics menu, select Weakly Compressible Navier-Stokes (chns). 

2 From the Physics menu, open the Boundary Settings dialog box.

3 Select all boundaries by pressing Ctrl+A. In the Boundary type list, select Wall.

4 Adjust the boundary settings according to the following table; when done, click OK.

Boundary Conditions—General Heat Transfer
1 From the Multiphysics menu, select General Heat Transfer (htgh).

2 From the Physics menu, open the Boundary Settings dialog box.

3 Enter the following boundary conditions; when done, click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, choose Free Mesh Parameters.

2 From the Predefined mesh sizes list, select Coarser.

3 Click the Custom mesh size button and type 4 in the Resolution of narrow regions edit 
field.

SETTINGS SUBDOMAIN 1 SUBDOMAINS 2–21

 k (isotropic) k_f k_s

 ρ rho -

 Cp Cp 0

 Q - Q_s

SETTINGS BOUNDARY 1 BOUNDARIES 2, 35, 77 BOUNDARIES 3, 45, 87

Boundary type Symmetry boundary Inlet Outlet

Boundary 
condition

Axial symmetry Velocity Pressure, no viscous 
stress

v0 v0

p0 0

SETTINGS BOUNDARY 1 BOUNDARIES 2, 
35, 77

BOUNDARIES 3, 
45, 87

BOUNDARIES 5, 
33, 47, 75, 88

Boundary 
condition

Insulation/
Symmetry

Temperature Convective flux Insulation/
Symmetry

T0 T0
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4 Click OK.

5 Click the Initialize Mesh button on the Main toolbar.

C O M P U T I N G  T H E  S O L U T I O N

For forced convection flows, it is often beneficial to use the stationary segregated 
solver.

1 Click the Solver Parameters button on the Main toolbar.

2 In the Solver list, select Stationary segregated, then click OK.

3 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate Figure 2-68, follow these steps:

1 Click the Plot Parameters button on the Main toolbar.

2 Click the Surface tab. On the Surface Data page, select General Heat Transfer 

(htgh)>Temperature from the Predefined quantities list. Select oC from the Unit list, 
then click Apply.

To generate Figure 2-69 (the velocity field in the fluid), do this:

3 Still on the Surface Data page, change the entry in the Predefined quantities list to 
Weakly Compressible Navier-Stokes (chns)>Velocity field. Select mm/s from the Unit 
list, then click Apply.

To create Figure 2-70, follow this step:

4 Still on the Surface Data page, change the selection in the Predefined quantities list to 
Weakly Compressible Navier-Stokes (chns)>r-velocity. Select mm/s from the Unit list, 
then click OK.

To produce Figure 2-71 execute the following instructions:

1 From the Postprocessing menu open the Cross-Section Plot Parameters dialog box.

2 On the Line/Extrusion page, go to the y-axis data area and from the Predefined 

quantities list, select Weakly Compressible Navier-Stokes (chns)>r-velocity. From the 
Unit list, select mm/s.

3 In the x-axis data area, click first the lower option button and then the Expression 
button.

4 In the X-Axis Data dialog box, type z in the Expression edit field and cm in the Unit 
edit field. Click OK to close the dialog box.
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5 Go to the Cross-section line data area. In both the r0 and r1 edit fields, type 0.0175. 
In the z0 edit field type 0, and in the z1 edit field type 0.18. Click Apply.

6 On the General page, select the Keep current plot check box.

7 Return to the Line/Extrusion page, and type 0.0525 in both the r0 and r1 edit fields.

8 Click the Line Settings button. In the resulting dialog box, go to the Line style list 
and select Dashed line. Click OK.

9 Click OK.

To set up and solve the isothermal model, do the following:

1 From the Options menu, select Expressions>Scalar Expressions. In all the expressions 
in the table, replace the variable T with T0.

2 Repeat the steps from the section “Computing the Solution” to solve the new 
model. Repeat the steps from the section “Postprocessing and Visualization” to 
generate the result plots.
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P r o c e s s i n g  a n d  M a n u f a c t u r i n g  M o d e l s
In this chapter you find models that show heat transfer applications within the 
processing and manufacturing industries.
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Hea t  Gen e r a t i o n  i n  a  D i s c  B r a k e

Introduction

This example models the heat generation and dissipation in a disc brake of an ordinary 
car during panic braking and the following release period. As the brakes slow the car, 
they transform its kinetic energy into thermal energy, resulting in intense heating of 
the brake discs. If the discs overheat, the brake pads stop working and, in a worst-case 
scenario, can melt. Braking power starts to fade already at temperatures above 600 K.

In the model, the car (1800 kg) initially travels at 25 m/s (90 km/h) when the driver 
brakes hard for 2 s, causing the vehicle’s eight brake pads to slow the car down at a rate 
of 10 m/s2. The wheels are assumed not to skid against the road surface. After this 
period of time, the driver releases the brake and the car travels at 5 m/s for an 
additional 8 s without any braking. The questions to analyze with the model are:

• How hot do the brake discs and pads become during the braking stage?

• How much do they cool down during the subsequent rest?

Model Definition

Model the brake disc as a 3D (x, y, z) solid with shape and dimensions as in Figure 3-1. 
The disc has a radius of 0.14 m and a thickness of 0.013 m.

Figure 3-1: Geometry and dimensions of the modeled brake disc, including the brake pad.
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Neglecting drag and other losses outside the brakes, the brakes’ retardation power is 
given by the negative of the time derivative of the car’s kinetic energy:

.

Here m is the car’s mass, v denotes its speed, R equals the wheel radius (0.25 m), ω is 
the angular velocity, and α is the angular acceleration. The acceleration is constant in 
this case, so ω(t) = ω0 + αt.

By definition, the retardation power equals the negative of the work per unit time done 
by the friction forces on the discs at the interfaces between the pads and the discs for 
the eight brakes. You can calculate this work as eight times an integral over the contact 
surface of a single brake pad. The friction force per unit area, ff, is approximately 
constant over the surface and is directed opposite the disc velocity vector, , 
where  denotes a unit vector in the azimuthal (angular) direction and the 
magnitude of vd at the distance r from the center equals vd( r, t ) = ω(t) r. Thus, writing 

 gives the following result for the retardation power:

You can approximate the last integral with the pad’s area, A (0.0035 m2), multiplied 
by the distance from the center of the disc to the pad’s center of mass, rm (0.1143 m).

Combining the two expressions for P gives the following result for the magnitude of 
the friction force, ff:

(Note that α is negative during retardation.)

Under the previously stated idealization that retardation is due entirely to friction in 
the brakes, the heat power generated per unit contact area at time t and the distance r 
from the center becomes

The disc and pad dissipate the heat produced at the boundary between the brake pad 
and the disc by convection and radiation. This example models the rotation as 
convection in the disc. The local disc velocity vector is

P
td

d mv2

2
-----------⎝ ⎠
⎛ ⎞– m– v vd

td
------ m– R2ω t( )α= = =

vd vdeϕ=

eϕ

fd ffeϕ=

P 8– ff Ad vd⋅∫∫ 8 ff t( ) ω t( ) r Ad∫∫= =

ff
mR2α
8rmA
-----------------–=

q r t,( ) f– f vd r t,( )⋅ mR2α
8rmA
----------------- r ω0 αt+( )–= =
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The model also includes heat conduction in the disc and the pad through the transient 
heat transfer equation

where k represents the thermal conductivity (W/(m·K)), Cp is the specific heat 
capacity (J/(kg·K)), and Q is the heating power per unit volume (W/m3), which in 
this case is set to zero.

At the boundary between the disc and the pad, the brake produces heat according to 
the expression for q given earlier. The heat dissipation from the disc and pad surfaces 
to the surrounding air is described by both convection and radiation

In this equation, h equals the convective film coefficient (W/(m2·K)), ε is the 
material’s emissivity, and σ is the Stefan-Boltzmann constant (5.67·10−8 W/(m2·K4)).

To calculate the convective film coefficient as a function of the vehicle speed, v, use the 
following formula (Ref. 1):

Here  l is the disc’s diameter. The material properties—the thermal conductivity, k, the 
density, ρ, the viscosity, µ, and the specific heat capacity, Cp—are those for air.

Table 3-1 summarizes the thermal properties, which come from (Ref. 1). You calculate 
the density of air at a reference temperature of 300 K using the ideal gas law.

TABLE 3-1:  MATERIAL PROPERTIES

PROPERTY DISC PAD AIR

 ρ (kg/m3) 7870 2000 1.170

 Cp (J/(kg·K)) 449 935 1100

 k (W/(m·K)) 82 8.7 0.026

 ε 0.28 0.8 -

 µ (Pa·s) - - 1.8·10-5

vd ω t( ) y– x( , )=

ρ Cp
T∂
t∂

------- ∇+ k∇T–( )⋅ Q ρ CP u ∇T⋅–=

qdiss h– T Tref–( ) εσ T4 Tref
4

–( )–=

h 0.037k
l

------------------ Re0.8 Pr0.33 0.037k
l

------------------ ρ l v
µ

----------⎝ ⎠
⎛ ⎞ 0.8 Cp µ

k
-----------⎝ ⎠
⎛ ⎞

0.33
= =
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Results and Discussion

The surface temperatures of the disc and the pad vary with both time and position. At 
the contact surface between the pad and the disc the temperature increases when the 
brake is engaged and then decreases again as the brake is released. You can best see 
these results in COMSOL Multiphysics by generating an animation. Figure 3-2 
displays the surface temperatures just before the end of the braking. A “hot spot” is 
visible at the contact between the brake pad and disc, just at the pad’s edge—this is 
where the temperature could become critical during braking. The figure also shows the 
temperature decreasing along the rotational trace after the pad. During the rest, the 
temperature becomes significantly lower and more uniform in the disc and the pad.

Figure 3-2: Surface temperature of the brake disc and pad just before releasing the brake 
(t = 1.8 s).

To investigate the position of the hot spot and the time of the temperature maximum, 
it is helpful to plot temperature versus time along a line from the center to the pad’s 
edge as in Figure 3-3. You can see that the maximum temperature is approximately 
440 K. The hot spot is positioned close to the radially outer edge of the pad. The 
highest temperature occurs approximately 1 s after engaging the brake.
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Figure 3-3: Temperature profile along the indicated line at the disc surface (z = 0.013 m) 
as a function of time.

To investigate how much of the generated heat is dissipated to the air, study the surface 
integrals of the produced heat and the dissipated heat. These integrals give the total 
heat flux (J/s) for heat production, Qprod, and heat dissipation, Qdiss, as functions of 
time for the brake disc. The time integrals of these two quantities give the total heat 
(J) produced and dissipated, respectively, in the brake disc. Figure 3-4 shows a plot of 
the total produced heat and dissipated heat versus time. You can see that 8 s after 
disengagement the brake has dissipated only a fraction of the produced heat. The plot 
indicates that the resting time must be extended significantly in order to dissipate all 
the generated heat.

r [m]

T [K]

t [s]
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Figure 3-4: Comparison of total heat produced (solid line) and dissipated (dashed).

The results of this model can help engineers investigate how much abuse, in terms of 
specific braking sequences, a certain disc-break design can tolerate before overheating. 
It is also possible to vary the parameters affecting the heat dissipation and investigate 
their influence.

Reference

1. J.M. Coulson and J.F. Richardson, Chemical Engineering, vol. 1, eq. 9.88; 
material properties from appendix A2.

Model Library path: Heat_Transfer_Module/Process_and_Manufacturing/
brake_disc
H E A T  G E N E R A T I O N  I N  A  D I S C  B R A K E  |  189



190 |  C H A P T E R
Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator. Click the New tab. From the Space dimension list select 3D.

2 From the Application Modes tree, select Heat Transfer Module> 
General Heat Transfer>Transient analysis. Click OK.

O P T I O N S  A N D  S E T T I N G S

From the Options menu, select Constants. Define the following names, expressions, and 
(optionally) descriptions; when done, click OK.

NAME EXPRESSION DESCRIPTION

rho_disc 7870[kg/m^3] Density, disc

rho_pad 2000[kg/m^3] Density, pad

C_disc 449[J/(kg*K)] Heat capacity, disc

C_pad 935[J/(kg*K)] Heat capacity, pad

k_disc 82[W/(m*K)] Thermal conductivity, disc

k_pad 8.7[W/(m*K)] Thermal conductivity, pad

e_disc 0.28 Emissivity, disc

e_pad 0.8 Emissivity, pad

v0 25[m/s] Initial vehicle speed

a0 -10[m/s^2] Vehicle acceleration

r_wheel 0.25[m] Wheel radius

omega0 v0/r_wheel Initial angular velocity, disc

alpha a0/r_wheel Angular acceleration, disc

m_car 1800[kg] Vehicle mass

A_pad 35e-4[m^2] Surface area, pad

r_m 0.1143[m] Center-of-mass radius, pad

f_f -m_car*r_wheel^2*alpha/ 
(8*r_m*A_pad)

Friction force

t_brake 2[s] Braking time

T_air 300[K] Temperature, air

k_air 0.026[W/(m*K)] Thermal conductivity, air

C_air 1100[J/(kg*K)] Heat capacity, air

mu_air 1.8e-5[Pa*s] Dynamic viscosity, air

rho_air 1.013e5[Pa]*28.8e-3[kg/mol]/ 
(8.314[J/(K*mol)]*T_air)

Density, air
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G E O M E T R Y  M O D E L I N G

1 Create two cylinders. To do so, click the Cylinder button on the Draw toolbar. Then 
enter settings from the following table. After creating each cylinder, click OK.

2 Click the Zoom Extents button on the Main toolbar.

3 Create a work plane along the disc surface. From the Draw menu select Work-Plane 

Settings. On the Quick page select the x-y option button, and in the a z edit field for 
the offset enter 0.013. Click OK.

4 From the Options menu, open the Axes/Grid Settings dialog box.

5 On the Axis page and the Grid page, in turn, clear the Auto check box and enter 
settings from the following table; when finished, click OK.

Next, draw the brake pad profile:

6 On the user interface, click the Geom2 tab.

7 Click the 3rd Degree Bézier Curve button on the Draw toolbar. 

8 Draw a curve with the control points listed in the following table.

To find the points with the mouse, look at the coordinate indicator in the bottom 
left corner of the user interface. Mark each point by clicking the left mouse button. 
After the last point, click the right mouse button to close the curve and change it to 
a solid.

CYLINDER PARAMETER CYL1 CYL2

Radius 0.14 0.08

Height 0.013 0.01

Axis base point x 0 0

Axis base point y 0 0

Axis base point z 0 0.013

AXIS GRID

x min -0.07 x spacing 0.005

x max 0.07

y min 0.08 y spacing 0.005

y max 0.15

CONTROL POINTS

(0, 0.135), (0.02, 0.135), (0.05, 0.13), (0.04, 0.105), (0.03, 0.08), (0.035, 0.09), (0, 0.09), 
(-0.035, 0.09), (-0.03, 0.08), (-0.04, 0.105), (-0.05, 0.13), (-0.02, 0.135), (0, 0.135)
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9 To complete the pad, you must make the top left and right corners sharper. Do so 
by changing the weights of the Bézier curves. From the Draw menu open the Object 

Properties dialog box, then change the weights for two of the curves using the 
information in the following table; when finished, click OK.

The geometry in the drawing area should now look like that in the figure below.

10 Make sure the object is selected, then from the Draw menu select Extrude. In the 
Distance edit field type 0.0065, then click OK.

CURVE POINT WEIGHT 

2 2 2.5

4 3 2.5
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P H Y S I C S  S E T T I N G S

1 From the Options menu, select Expressions>Scalar Expressions. Specify the following 
names, expressions, and (optionally) descriptions; when done, click OK.

Here sigma_htgh is a predefined scalar variable for the Stefan-Boltzmann constant.

2 Make sure Geom1 is the active page in the user interface.

3 Now set up some variables needed for postprocessing. From the Options menu, 
select Integration Coupling Variables>Boundary Variables. In the Name column, enter 
the two variables Dis_heat and Prod_heat. For certain boundaries, you must make 
an entry in the Expression column for one of those variables as specified in this table; 
when done, click OK.

Subdomain Settings
1 From the Physics menu, select Subdomain Settings.

2 Select all the subdomains. Click the Init tab. In the Temperature edit field enter 
T_air.

3 Click the General tab. Enter the following settings:

NAME EXPRESSION DESCRIPTION

v (v0+a0*t)*(t<=t_brake)+ 
(v0+a0*t_brake)*(t>t_brake)

Vehicle speed

omega v/r_wheel Angular velocity, disc

h_air 0.037*k_air/(0.14[m]*2)* 
(rho_air*0.14[m]*2*v/mu_air)^0.8* 
(C_air*mu_air/k_air)^0.33

Convective film 
coefficient

q_prod f_f*sqrt(x^2+y^2)*(omega0+alpha*t)* 
flc2hs((t_brake-t)[1/s],0.01)

Produced heat power 
per unit contact area

q_d_disc h_air*(T_air-T)+e_disc* 
sigma_htgh*(T_air^4-T^4)

Dissipated heat power 
per unit disc area

q_d_pad h_air*(T_air-T)+e_pad* 
sigma_htgh*(T_air^4-T^4)

Dissipated heat power 
per unit pad area

SETTINGS BOUNDARY 11 BOUNDARIES 1, 2, 4–6, 8, 13–15 BOUNDARIES 9, 10, 12, 16, 17

Dis_heat -q_d_disc -q_d_pad

Prod_heat q_prod

SETTINGS SUBDOMAINS 1, 2 SUBDOMAIN 3

 k (isotropic) k_disc k_pad

 ρ rho_disc rho_pad

 Cp C_disc C_pad
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4 Select Subdomains 1 and 2. Click the Convection tab. Select the Enable convective 

heat transfer check box.

5 From the Matter state list, select Solid.

6 In the leftmost u edit field for the x velocity type -y*omega, and in the middle edit 
field for the y velocity type x*omega.

7 Click the Stabilization tab. Click the Elements of type button; leave the default 
selection (Lagrange - Quadratic) in the corresponding list.

(The default solver is GMRES with geometric multigrid as preconditioner, but the 
problem is small enough to be solved with a direct solver).

8 Click OK.

Boundary Conditions
1 From the Physics menu, open the Boundary Settings dialog box. Select the Interior 

boundaries check box to enable boundary conditions on interior boundaries.

2 Specify the boundary conditions by entering the settings from this table; when 
done, click OK:

M E S H  G E N E R A T I O N

1 From the Mesh menu, open the Free Mesh Parameters dialog box.

2 Click the Boundary tab. Select Boundary 4. In the Maximum element size edit field 
type 10e-3. Similarly, select Boundary 11 and type 5e-3.

3 Go to the Advanced page. In the z-direction scale factor edit field type 2. Click 
Remesh, then click OK.

SETTINGS BOUNDARY 3 BOUNDARIES 1, 2, 
4–6, 8, 13–15, 18

BOUNDARY 11 BOUNDARY 9, 10, 
12, 16, 17,

Type Insulation/
Symmetry

Heat flux Heat source/
sink

Heat flux

q0 0 q_prod 0

h h_air 0 h_air

Tinf T_air 0 T_air

Radiation 
type

None Surface-to- 
ambient

None Surface-to- 
ambient

 ε e_disc e_pad

 Tamb T_air T_air
 3 :  P R O C E S S I N G  A N D  M A N U F A C T U R I N G  M O D E L S



A D D I T I O N A L  A P P L I C A T I O N  M O D E

In order to integrate the heat produced and dissipated over time, this model uses a 
Weak Form, Point application mode. 

1 From the Multiphysics menu, open the Model Navigator.

2 In the list of application modes select  
COMSOL Multiphysics>PDE Modes>Weak Form, Point>Time-dependent analysis.

3 Change the dependent variable names. In the Dependent variables edit field type 
uP uD. Click Add, then click OK.

4 From the Physics menu, open the Point Settings dialog box. Deactivate the 
application mode in all points; to do so, select all the points, then clear the Active in 

this domain check box.

5 Select Point 1, then select the Active in this domain check box to activate the Weak 
Form, Point application mode.

6 For Point 1, make the following entries in the edit fields on the weak and dweak 
pages; when done, click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 From the Solve menu, open the Solver Parameters dialog box. On the General page, 
go to the Times edit field and type 0:0.2:3 4:10.

2 In the Linear system solver list, select Direct (UMFPACK), then click OK.

3 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows the temperature at the last time step. Because the problem is 
time dependent, the natural way to view the solution is as an animation. 

1 From the Postprocessing menu, open the Plot Parameters dialog box. In the General 
page go to the Plot type area. Clear the Slice check box, then select the Boundary 
check box.

2 Go to the Animate page, then click the Start Animation button. The animation 
appears in a separate window.

To create Figure 3-2, continue with this step:

EDIT FIELD POINT 1 POINT 2

weak uP_test*Prod_heat uD_test*Dis_heat

dweak uP_test*uP_time uD_test*uD_time
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1 While still working in the Plot Parameters dialog box, click the General tab.

2 In the Solution at time list, select 1.8, then click OK.

To create Figure 3-3, which shows the temperature along a cross section as a function 
of time, continue with these steps:

1 From the Postprocessing menu, select Cross-Section Plot Parameters. 

2 Go to the General page and find the Solutions to use  area. Select all the solutions 
from 0 to 2.4 seconds.

3 Click the Line/Extrusion tab, go to the Plot type area, and select the Extrusion plot 

option button.

4 Go to the x-axis data area. In the list at the top of this area select y.

5 Still on the Line/Extrusion page, go to the Cross-section line data area. Enter settings 
as in the following table; when finished, click OK.

To create Figure 3-4, continue with these steps:

1 From the Postprocessing menu, open the Domain Plot Parameters dialog box, then 
go to the General page. In the Plot type area click the Point plot option button. Also 
select the Keep current plot check box at the bottom of the dialog box.

2 Click the Title/Axis button at the bottom of the dialog box. Near the First axis label 
text, click the option button next to the edit field and in that field type Time [s]. 
Click the option button for the Second axis label edit field and type log(Q_tot)[J]. 
Click OK.

3 Go to the Point page, then select Point 1. In the Expression edit field type 
log10(uP+1). Click Apply, and a new figure appears.

4 In the Expression edit field, type log10(uD+1).

5 Click the Line Settings button. In the Line style list, select Dashed line, then click OK.

6 Click OK to close the Domain Plot Parameters dialog box.

ENTRY VALUE

x1 -0.047

y1 0.1316

z0 0.013

z1 0.013

Line resolution 50
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Con v e c t i o n  Cook i n g  o f  Ch i c k e n 
Pa t t i e s

Introduction

This example models the convection cooking of a chicken patty. The model was 
originally developed by H. Chen and others (Ref. 1). 

To increase consumer convenience, many of today’s food products are precooked so 
that you can quickly re-heat the product, for example in a microwave oven. One 
industrial precooking method is air-convection cooking. This example builds a 
time-dependent model of the convection cooking process for a chicken patty, and it 
shows the temperature rise over time in the patty.

This simulation also models the moisture concentration in the patty, which is defined 
as the mass of water per volume of meat. From the viewpoint of product quality, it is 
of interest to minimize the loss of moisture during cooking. In this regard, cooking 
yield is a quantity that measures how much moisture, in percent, remains in the patty 
after the cooking process. Furthermore, the moisture concentration also influences the 
temperature field by heat loss due to vaporization and also by changing the patty’s 
thermal conductivity.

Figure 3-5: Convection cooking of a chicken patty.

Model Definition

This COMSOL Multiphysics example couples two time-dependent application modes 
describing the temperature and the moisture concentration, respectively. The 
simulation does not model the convective velocity field outside the patty because the 
coefficients for convective heat and moisture transfer to the surrounding air are given.

Inside the patty, diffusive processes describe both heat transfer and moisture transport. 
For the temperature, the heat equation describes the diffusive process as in

Chicken patty

Hot air convection
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where ρ is the patty’s density (kg/m3), Cp denotes the specific heat capacity (J/
(kg·K)), T is the temperature (K), and k is the thermal conductivity (W/(m·K)). This 
model assumes that the specific heat capacity increases with temperature according to 
the expression

where ∆T = (T − 0 °C) and the dimensions of the numerical coefficients are such that 
the dimension of Cp is as stated.

For the moisture concentration, apply the diffusion equation

where  c is the moisture concentration (kg/m3), and D is the diffusion coefficient 
(m2/s).

Figure 3-6 depicts the patty’s geometry, which is simple and allows for 2D 
axisymmetric modeling of its cross section. Additional symmetry in the cross section 
makes it possible to model just one quarter of the cross section.

Figure 3-6: Geometry of the chicken patty.

These simplifications result in a simple rectangular domain with the dimension 
31 mm ×  5 mm. Figure 3-7 describes the boundary numbering used when specifying 
the boundary conditions.

ρCp
∂T
∂t
------- ∇+ k– ∇T( )⋅ 0=

Cp 3017.2 2.05 T∆ 0.24 T∆( )2 0.002 T∆( )3  (J/(kg·K))+ + +=

c∂
t∂

----- ∇ D– ∇c( )⋅+ 0=

3D to 2D-axisymmetry

31 mm

5 mm
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Figure 3-7: Model domain and boundary numbering.

The equations describing moisture diffusion are coupled to the heat equation in the 
following two ways:

• The thermal conductivity, k, increases with moisture concentration according to 
k = (0.194 + 0.436 ( c/ρ)) W/(m·K), where the concentration, c, and the density, ρ, 
must be expressed in the previously stated units.

• The vaporization of water at the patty’s outer boundaries generates a heat flux out 
of the patty. Represent this heat flux with the term  in the boundary 
conditions for Boundaries 3 and 4, where Dm is the moisture diffusion coefficient 
(m2/s) from the patty to the surrounding air and λ is the latent heat of vaporization 
(J/kg).

Assume symmetry for the temperature field on Boundaries 1 and 2. Air convection 
adds heat on Boundaries 3 and 4. According to the assumptions made earlier, add a 
term for the heat flux out of the patty due to moisture vaporization on Boundaries 3 
and 4.

Summarizing, the boundary conditions for the general heat transfer application mode 
are

where hT is the heat transfer coefficient (W/(m2·K)), and Tinf is the oven air 
temperature.

Ω1 ∂Ω4

∂Ω2

∂Ω3

∂Ω1

Dmλ∇c

n k T∇–( )⋅ 0=

n k T∇( )⋅ hT Tinf T–( ) n Dmλ∇c( )⋅+=

at Ω1 and Ω2 ∂∂

at Ω3 and Ω4 ∂∂
C O N V E C T I O N  C O O K I N G  O F  C H I C K E N  P A T T I E S  |  199



200 |  C H A P T E R
The boundary conditions for the diffusion application mode are

where D is the moisture diffusion coefficient in the patty (m2/s), kc refers to the mass 
transfer coefficient (m/s), and cb denotes the outside air (bulk) moisture 
concentration (kg/m3). The diffusion coefficient and the mass transfer coefficient are 
given, respectively, by

where Cm equals the specific moisture capacity (kg moisture/kg meat), km refers to 
the moisture conductivity (kg/(m·s)), and hm denotes the mass transfer coefficient in 
mass units (kg/(m2·s)).

Assume that the patty’s temperature is 22 °C at the start of the cooking process, and 
the moisture concentration of the air is 22 kg/m3 on a wet basis, which means that the 
moisture is expressed in mass per volume of meat. Additional data are given in the 
modeling section below.

To obtain the temperature and moisture concentration over time, the model solves the 
equations with the boundary conditions discussed above.

Results and Discussion

The most interesting result from this simulation is the time required to heat the patty 
from room temperature (22 °C) to at least 70 °C throughout the entire patty. The 
section at the middle of the patty (at the lower left corner of the modeling domain) 
takes the longest time to reach this temperature. It is also interesting to determine how 
much moisture remains in the patty after cooking. For this purpose, compute the 
cooking yield, defined as (initial moisture mass)/(final moisture mass).

The model shows that at an oven air temperature of 135 °C, a cooking time of 840 s 
is required to reach a center temperature of 70 °C. Figure 3-8 shows how the 
temperature increases over time.

n D c∇–( )⋅ 0=

n D c∇( )⋅ kc cb c–( )=

at Ω1 and Ω2∂∂

at Ω3 and Ω4∂∂

D
km

ρCm
------------ ,   = kc

hm
ρCm
------------ ,=
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Figure 3-8: Temperature increase over time in the middle of the patty at an air 
temperature of 135 °C.

Figure 3-9 illustrates the resulting temperature field after 840 s. The temperature at 
the lower left corner is 70 °C, and the temperature rises toward the outside 
boundaries.

Figure 3-9: Temperature field after 840 s at a cooking temperature of 135 °C.
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At this oven air temperature, the cooking yield is approximately 0.93 (93%). 
Figure 3-10 shows the resulting moisture concentration for these conditions. As 
expected, note that the convective loss of moisture at the boundaries results in a lower 
moisture concentration at the outer parts of the patty compared to its inner parts.

Figure 3-10: Moisture concentration after 840 s at a cooking temperature of 135 °C.

Simulations show that an increased air temperature both shortens the time required to 
reach 70 °C in the middle and increases the cooking yield. The drawback, however, is 
that the temperature gradients in the chicken patty increase. Figure 3-11 shows the 
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temperature field obtained after 370 s at a cooking temperature of 218 °C; the 
corresponding cooking yield is 0.97 (97%).

Figure 3-11: Temperature field after 370 s at a cooking temperature of 218 °C.

Reference

1. H. Chen, B.P. Marks and R.Y. Murphy, “Modeling coupled heat and mass transfer 
for convection cooking of chicken patties,” Journal of Food Engineering, vol. 42, 
1999, pp. 139–146.

Model Library path: Heat_Transfer_Module/Process_and_Manufacturing/
chicken_patties
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Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator and go to the New page. From the Space dimension list 
select Axial symmetry (2D).

2 From the list of application modes select  
Heat Transfer Module>General Heat Transfer>Transient analysis.

3 Click the Multiphysics button, then click Add.

4 Similarly select the application mode COMSOL Multiphysics> 
Convection and Diffusion>Diffusion>Transient analysis, then click Add.

5 Click OK.

O P T I O N S  A N D  S E T T I N G S

From the Options menu select Constants. Enter the following names, expressions, and 
(optionally) descriptions; when done, click OK.

G E O M E T R Y  M O D E L I N G

1 Press the Shift key and click the Rectangle/Square button on the Draw toolbar.

NAME EXPRESSION DESCRIPTION

T_air 135[degC] Oven air temperature

T0 22[degC] Initial patty temperature

rho 1100[kg/m^3] Density of patty

h_T 25[W/(m^2*K)] Heat transfer coefficient

c0 0.78*rho Initial moisture concentration

c_b 0.02*rho Air moisture concentration

C_m 0.003 Specific moisture capacity

k_m 1.29e-9[kg/(m*s)] Moisture conductivity

h_m 1.67e-6[kg/(m^2*s)] Mass transfer coefficient in mass units

D k_m/(rho*C_m) Diffusion coefficient

k_c h_m/(rho*C_m) Mass transfer coefficient

D_m 5e-10[m^2/s] Surface moisture diffusivity

lda 2.3e6[J/kg] Latent heat of vaporization
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2 In the dialog box that appears, enter the rectangle properties given below; when 
done, click OK.

3 Click the Zoom Extents button on the Main toolbar.

P H Y S I C S  S E T T I N G S

From the Options menu select Expressions>Subdomain Expressions. In the dialog box 
enter the following details; when done, click OK.

The unit label “[kg/mol]” is inserted in the expression for kT because the dependent 
variable in the Diffusion application mode, the concentration c, has the default unit 
mol/m3; the above insertion gives kT the correct dimension. In this model, whenever 
the concentration unit mol/m3 appears in the user interface, read instead kg/m3.

Boundary Conditions—General Heat Transfer
1 From the Multiphysics menu select 1 General Heat Transfer (htgh).

2 From the Physics menu select Boundary Settings.

OBJECT DIMENSIONS EXPRESSION

Width 31e-3

Height 5e-3

Base Corner

Position, r 0

Position, z 0

NAME EXPRESSION

k_T (0.194+0.436[kg/mol]*c/rho)[W/(m*K)]

dT (T-0[degC])[1/K]

C_p (3017.2+2.05*dT+0.24*dT^2+0.002*dT^3)[J/(kg*K)]
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3 Enter the settings from the following table; when done, click OK.

Following standard COMSOL Multiphysics syntax, the variables cz and cr 
represent the concentration-gradient components ∂c/∂z and ∂c/∂r, respectively.

Note: If the preference Highlight unexpected units is set (on the Modeling page of the 
Preferences dialog box that you open from the Options menu), the entries in the q0 
edit field for Boundaries 3 and 4 appear in red. This is because, as just mentioned, the 
software expects concentrations to be given in amount of substance per unit volume 
(with SI unit mol/m3). Because, in this model, the concentration is consistently 
expressed in mass per unit volume, you can just ignore this warning.

Subdomain Settings—General Heat Transfer
1 From the Physics menu select Subdomain Settings.

2 Select Subdomain 1, and note that only conductive heat transfer is enabled by 
default.

3 Click the General tab, then enter properties for the chicken meat as in the following 
table:

4 Click the Init tab. In the Temperature edit field type T0, then click OK.

Boundary Conditions—Diffusion
1 From the Multiphysics menu select 2 Diffusion (di).

SETTINGS BOUNDARY 1 BOUNDARY 2 BOUNDARY 3 BOUNDARY 4

Boundary 
condition

Axial 
symmetry

Insulation/
Symmetry

Heat flux Heat flux

q0 D_m*lda*cz D_m*lda*cr

h h_T h_T

Tinf T_air T_air

SETTINGS SUBDOMAIN 1

 k (isotropic) k_T

 ρ rho

 Cp C_p
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2 From the Physics menu open the Boundary Settings dialog box. Enter boundary 
coefficients as in the following table; when done, click OK.

Subdomain Settings—Diffusion
1 From the Physics menu open the Subdomain Settings dialog box. In the Subdomain 

selection list select 1, then go to the D isotropic edit field and type D.

2 Go to the Init page, then in the c(t0) edit field type c0.

3 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu select Free Mesh Parameters.

2 Click the Boundary tab. In the Boundary selection list choose 3 and 4. In the Maximum 

element size edit field type 1e-3.

3 Click Remesh, then click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 From the Solve menu open the Solver Parameters dialog box.

2 On the General page find the Time stepping area. In the Times edit field type 
0:10:900, then click OK.

3 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows the temperature in the chicken patty (in kelvin) at t = 900 s. To 
generate Figure 3-9, follow these steps:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, from Solution at time list select 840.

3 Click the Surface tab. On the Surface Data page, select oC from the Unit list.

4 Click Apply.

To generate Figure 3-10, which shows the moisture concentration, proceed as follows:

SETTINGS BOUNDARY 1 BOUNDARY 2 BOUNDARIES 3, 4

Boundary 
condition

Axial 
symmetry

Insulation/ 
Symmetry

Flux

kc k_c

cb c_b
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1 While still on the Surface page, in the Expression edit field type c*1[kg/mol], then 
press Enter.

The entry in the Unit list should now read kg/m3, which is the same as g/liter.

2 Click the General tab, then click the Title button.

3 In the Title dialog box, select the option button next to the edit field, then enter the 
title Moisture concentration [g/liter]. Click OK.

4 Click OK to generate the plot.

To create Figure 3-8, which shows temperature versus time, follow these instructions:

1 From the Postprocessing menu select Domain Plot Parameters.

2 On the General page, find the Plot type area and select the Point plot option button.

3 Click the Point tab. In the Point selection list select 1 and in the Unit list select oC.

4 Click OK.

The following steps describe how to compute the cooking yield:

1 From the Postprocessing menu open the Subdomain Integration dialog box.

2 Make sure the Compute volume integral check box is selected.

3 Select Subdomain 1, then in the Expression edit field type (c[kg/mol]/c0)/
1.509e-5[m^3]. The denominator, 1.509·10−5 m3, is the value of the volume 
integral of the modeling geometry.

4 Click OK to obtain the cooking yield; the result (approximately 0.93) appears in the 
message log at the bottom of the user interface.

To investigate the model further, you can solve the problem for other air temperatures 
using the same steps for postprocessing.
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Introduction

In the chemical industry, processes often cool reaction fluids using glass flanges. In 
most cases the coolant is the surrounding air. An obvious design parameter for this type 
of device is the cooling power, and the surface temperatures might also be of interest. 
Heat transfer in this type of device is dominated by convection to and from the 
surfaces, although the conduction within the glass flange can also influence 
performance. A convenient method to analyze convection cooling is to use a heat 
transfer coefficient, h. This coefficient describes the influence of the fluid-flow field 
and the convective fluxes. Thus it is not necessary to model the flow field, which 
greatly simplifies simulations.

Figure 3-12: Operating principle of the cooling flange.

Semi-empirical expressions for computing the heat transfer coefficient for different 
cases are available in the literature. For this model, the author obtained the heat 
transfer coefficient for the outer surface by using semi-empirical data available for 
natural convection around a cylinder. The heat transfer coefficient for the surface that 
faces the tube is valid for forced convection in a tube. The model uses the General Heat 
Transfer application mode.

Hot process fluid

Cooling air
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Model Definition

Figure 3-13 presents a drawing of the modeled geometry.

Figure 3-13: Drawing of the cooling flange.

The pipe connecting the flange has an inner diameter of 16 mm and a wall thickness 
of 3 mm. In the flange section, the pipe is 4 mm thick. The flanges are 4 mm thick and 
10 mm in height.

During operation, the hot process fluid heats the inside of the tube. The flange 
conducts the heat and transfers it to the surrounding air. As the air is heated, buoyancy 
effects cause a convective flow.

The heat transfer within the flange is described by the stationary heat equation

where k is the thermal conductivity (W/(m·K)), and T is the temperature (K). On the 
flange’s exterior boundaries, which face the air and process fluid, the applicable 
boundary condition is

∇ k T∇–( )⋅ 0=

n– k∇T–( )⋅ q0 h Tinf T–( )+=
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where n is the normal vector of the boundary, h is the heat transfer coefficient (W/
(m2·K)), and Tinf is the temperature of the surrounding medium (K). For this 
simulation, set Tinf to 298 K for the cooling air and to 363 K for the process fluid.

You can approximate the value for the heat transfer coefficient, h, on the process fluid 
side with a constant value of 15 W/(m2·K)) because the fluid’s velocity is close to 
constant and the model assumes that its temperature decreases only slightly. 

The h expression on the air side is more elaborate. Assume that the free-convection 
process around the flange is similar to that around a cylinder. The heat transfer 
coefficient for a cylinder is available in the literature (Ref. 1), and you can use the 
expression:

where k is the thermal conductivity of air (0.06 W/(m·K)), L is the characteristic 
length that in this case is the outer diameter of the flange (44 mm), and f(θ) is an 
empirical coefficient tabulated in Table 3-2. (Figure 3-14 illustrates the definition of 
the angle θ). Finally, Gr is the Grashof number defined as

where β is the thermal expansion coefficient (1/K), which equals  for an ideal 
gas, g is the gravitational acceleration (9.81 m/s2), and µ is the kinematic viscosity 
(18·10−6 Pa·s).

TABLE 3-2:  EMPIRICAL TRANSFER COEFFICIENTS

INCIDENT ANGLE [DEG.]  f(θ) 

0 0.48

90 0.46

100 0.45

110 0.435

120 0.42

130 0.38

140 0.35

150 0.28

160 0.22

180 0.15

h k
L
---- f θ( ) Gr1 4/=

Gr β g∆TL3

µ2
-----------------------=

1 T∞⁄
C O O L I N G  F L A N G E  |  211



212 |  C H A P T E R
Figure 3-14: Definition of the angle θ.

Table 3-3 summarizes the material properties of the flange material.

Results and Discussion

Figure 3-16 shows the surface temperature of the flange at steady state.

Figure 3-15: Stationary surface temperature of the flange.

TABLE 3-3:  MATERIAL PROPERTIES

MATERIAL  k [W/(m·K)]  ρ [kg/m3]  Cp [J/(kg·K)] 

Silica glass 1.38 2203 703

θ
gravity
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The temperature at the flange shoulders is approximately 14 K lower than that at the 
tube surface. The temperature difference between the process fluid at 363 K and the 
inner surface of the pipe is approximately 40 K, while that between the outer flange 
surface and the air stream is approximately 10 K. These values indicate that the heat 
transfer from the flange outer surfaces is efficient. It also indicates that the heat transfer 
from the fluid to the flange is a limiting factor. To improve the flange’s performance, 
it is a good idea to increase the tube diameter.

Figure 3-16 shows the heat transfer coefficient for the flange and pipe walls.

Figure 3-16: Heat transfer film coefficient, h, for the flange.

As you can see, the coefficient decreases significantly along the vertical position of the 
flange’s outer boundary.

Calculate the flange’s total cooling power by integrating the heat flux on the outer 
surfaces. The entire flange, that is, taking both symmetry halves into account, has a 
cooling power of approximately 1.2 W.
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Reference

1. B. Sundén, Kompendium i värmeöverföring [Notes on Heat Transfer], Sec. 10-3, 
Dept. of Heat and Power Engineering, Lund Inst. of Technology, 2003 (in Swedish).

Model Library path: Heat_Transfer_Module/Process_and_Manufacturing/
cooling_flange

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

Open the Model Navigator and go to the New page. In the Space dimension list select 2D, 
then click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu select Constants. Define the following names, expressions, 
and (optionally) descriptions; when done, click OK.

2 From the Options menu select Functions. In the dialog box that appears, click New to 
open the New Function dialog box.

3 In the Function name edit field, type graph. Click Interpolation and select Table in 
the Use data from list. Click OK.

NAME EXPRESSION DESCRIPTION

D 44[mm] Outer flange diameter

k 0.06[W/(m*K)] Thermal conductivity

Tair 298[K] Cooling air temperature

Tinner 363[K] Process fluid temperature

Hh 15[W/(m^2*K)] Heat transfer coefficient

visc 18e-6[m^2/s] Kinematic viscosity

beta 1/Tair Thermal expansion coefficient

grav 9.81[m/s^2] Gravitational acceleration
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4 Select Linear in the Interpolation method list in the Functions dialog box that appears. 
Enter the following values in the columns for x and f(x); when done, click OK.

5 From the Options menu select Axes/Grid Settings.

6 Clear the Axis equal check box, then enter the properties in the following table:

7 Go to the Grid page. Clear the Auto check box, then enter the properties in the 
following table; when done, click OK.

 x  f(x) 

0 0.48

90 0.46

100 0.45

110 0.435

120 0.42

130 0.38

140 0.35

150 0.28

160 0.22

180 0.15

PROPERTY VALUE

x min -1.4

x max 2.6

y min 0.2

y max 2.8

PROPERTY VALUE

x spacing 0.1

y spacing 0.1
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G E O M E T R Y  M O D E L I N G

Start by creating this 2D geometry:

Create the rectangle R1 with these steps:

1 Shift-click the Rectangle/Square button on the Draw toolbar.

2 In the dialog box that appears, enter the following settings; when done, click OK.

Create the composite object CO1 with these steps:

1 Click the 2nd Degree Bézier Curve button on the Draw toolbar.

2 Click on the coordinates (0, 1.2), (0.2, 1.2), and (0.2, 1.4).

3 Click the Line button on the Draw toolbar, then click on the coordinate (0.6, 1.4).

4 Click the 2nd Degree Bézier Curve on the Draw toolbar.

5 Draw the Bézier curve by clicking on the coordinates (0.6, 1.4), (0.6, 1.2), and 
(0.8, 1.2).

6 Click the right mouse button to create the geometry object.

Create the composite object CO2 with these steps:

1 Click the Line button on the Draw toolbar, then click on the coordinates (0.2, 1.4), 
(0.2, 2.0), (0.4, 1.9), (0.6, 2.0), and (0.6, 1.4).

2 Click the right mouse button to create the geometry object.

OBJECT DIMENSIONS EXPRESSION

Width 0.8

Height 0.4

Base Corner

x-position 0

y-position 0.8
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Create the composite object CO4 with these steps:

1 Click the 2nd Degree Bézier Curve button on the Draw toolbar.

2 Click on the coordinates (0.2, 2.0), (0.2, 2.2), (0.4, 2.2), (0.6, 2.2), and (0.6, 2.0).

3 Click the Line button on the Draw toolbar, then click on the coordinates (0.4, 1.9) 
and (0.2, 2.0). Click the right mouse button.

This creates a composite geometry object, CO3. To create CO4, you still must add 
a square and some lines to the object.

4 Shift-click the Rectangle/Square (Centered) button on the Draw toolbar.

5 In the dialog box that appears, enter the following settings; when done, click OK.

6 Click the Line button on the Draw toolbar. Click on the left corner of the small 
rectangle, then click on the coordinate (0.2, 2.1). Click the right mouse button.

7 Click the Line button on the Draw toolbar, click on the right corner of the small 
rectangle, then click on the coordinate (0.6, 2.1). Click the right mouse button.

8 Click the Line button on the Draw toolbar, click on the upper corner of the small 
rectangle, then click on the coordinate (0.4, 2.2). Click the right mouse button.

9 Click the Line button on the Draw toolbar, click on the lower corner of the small 
rectangle, then click on the coordinate (0.4, 1.9). Click the right mouse button.

10 To create the composite object, select CO3, SQ1, B1, B2, B3, and B4, then click 
the Coerce to Solid button on the Draw toolbar.

Create the other two flanges with these steps:

1 Select R1, CO1, CO2, and CO4, then click the Array button on the Draw toolbar.

2 In the dialog box that appears, enter the following properties; when done, click OK.

PROPERTY VALUE

Width 0.1

 α 45

Base Center

x-position 0.4

y-position 2.05

PROPERTY VALUE

Displacement, x 0.8

Displacement, y 0
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Create the composite object CO10 with these steps:

1 Click the Line button on the Draw toolbar.

2 Click on the lower left corner of rectangle R1, then click, in order, on the 
coordinates (−1.2, 0.8), (−1.2, 1.1), and (−0.8, 1.1).

3 Click the 3rd Degree Bézier Curve button on the Draw toolbar.

4 Click, in order, on the coordinates (−0.4, 1.1), (−0.4, 1.2), and (0, 1.2).

5 Click the right mouse button to create the geometry object CO10.

Conclude the geometry modeling by scaling the geometry with these steps:

1 Select all geometry objects by pressing Ctrl+A.

2 Click the Scale button on the Draw toolbar.

3 In the dialog box that appears, enter the following scaling properties; when done, 
click OK.

4 Double-click the EQUAL button on the status bar at the bottom of the user interface.

5 Click the Zoom Extents button on the Main toolbar.

M E S H  G E N E R A T I O N

1 From the Mesh menu select Mapped Mesh Parameters.

Array size, x 3

Array size, y 1

PROPERTY VALUE

Scale factor, x 0.01

Scale factor, y 0.01

Scale base point, x 0

Scale base point, y 0

PROPERTY VALUE
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2 On the Boundary page, select the boundaries marked in the following figure:

3 Select the Constrained edge element distribution check box (keep the default value 
for the Number of edge elements at 1).

4 Select the boundaries marked in the following figure:

5 Select the Constrained edge element distribution check box, then in the Number of 

edge elements edit field type 2.
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6 Click Remesh, then click OK.

7 From the Mesh menu select Revolve Mesh.

8 In the dialog box that appears, in the α2 edit field type 180.

9 Click the Angle from x-axis button, and in the θ edit field type 0.

10 Click OK.

P H Y S I C S  S E T T I N G S

1 From the Multiphysics menu select Model Navigator.

2 In the Multiphysics menu on the right side of the dialog box select Geom2 (3D).

3 From the list of application modes on the left side of the dialog box select 
Heat Transfer Module>General Heat Transfer>Steady-state analysis.

4 Click Add, then click OK.

Subdomain Settings
1 From the Physics menu, select Subdomain Settings.

2 Select all subdomains.

Next, select the material properties from the materials library:

3 Press the Load button. In the dialog box that appears, in the Materials list select 
Library1>Silica glass. Click OK.

4 Click the Init tab, then in the Temperature edit field type 323.

5 Click OK.

Boundary Settings
1 From the Physics menu select Boundary Settings.

2 Select the boundaries at the geometry’s ends and the symmetry boundaries, as 
shown in the following figure:

3 In the Boundary condition list select Insulation/Symmetry.
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4 Select the boundaries that face the inner channel, as shown in the following figure:

5 In the Boundary condition list select Heat flux, then enter the following properties:

6 Select Boundary 3, then select the Select by group check box. All boundaries on the 
outside of the geometry should now be selected, as in the following figure:

7 In the Boundary condition list select Heat flux, then enter the following properties:

8 Click OK.

9 From the Options menu select Expressions>Boundary Expressions. Keep the selection 
of all outward-facing boundary segments from Step 6.

PROPERTY VALUE

h Hh

Tinf Tinner

PROPERTY VALUE

h Hc

Tinf Tair
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10 Enter the following expressions; when done, click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 In the Linear system solver list select GMRES.

3 In the Preconditioner list select Algebraic multigrid.

4 Click OK.

5 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To reproduce the plot in Figure 3-15, displaying the boundary temperature 
distribution, follow these instructions:

1 Click the Plot Parameters button on the Main toolbar.

2 Clear the Slice check box and select the Boundary check box, then click Apply.

3 Double-click the GRID button on the status bar at the bottom of the user interface.

To reproduce the plot in Figure 3-16, continue with these steps:

1 Still in the Plot Parameters dialog box, click the Boundary tab. 

2 In the Predefined quantities list select Heat transfer coefficient, then click OK.

To integrate the heat flux over the outer surface area of the flange, do as follows:

1 From the Postprocessing menu open the Boundary Integration dialog box.

2 In order to select all outer boundaries, open the Boundary Settings dialog box, then 
select Boundary 3 and select the Select by group check box. Click Cancel to close the 
Boundary Settings dialog box.

3 Return to the Boundary Integration dialog box. From the Predefined quantities list 
select Normal total heat flux, then click OK.

The integrated value appears in the message log at the bottom of the user interface.

EXPRESSION VALUE

angle atan(y/z)*180/pi+90

Gr grav*beta*(T-Tair)*D^3/visc^2

Hc k*graph(angle)*Gr^0.25/D
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F r i c t i o n  S t i r  We l d i n g

Introduction

Manufacturers use a modern welding method called friction stir welding to join 
aluminum plates. This model analyzes the heat transfer in this welding process. The 
model is based on a paper by M. Song and R. Kovacevic (Ref. 1).

In friction stir welding, a rotating tool moves along the weld joint and melts the 
aluminum through the generation of friction heat. The tool’s rotation stirs the melted 
aluminum such that the two plates are joined. Figure 3-17 shows the rotating tool and 
the aluminum plates being are joined.

Figure 3-17: Two aluminum plates being joined by friction stir welding.

The rotating tool is in contact with the aluminum plates along two surfaces: the tool’s 
shoulder, and the tool’s pin. The tool adds heat to the aluminum plates through both 
interfaces.

During the welding process, the tool moves along the weld joint. This movement 
would require a fairly complex model if you want to model the tool as a moving heat 
source. This example takes a different approach that uses a moving coordinate system 
that is fixed at the tool axis (Ref. 1 also takes this approach). After making the 
coordinate transformation, the heat transfer problem becomes a stationary 
convection-conduction problem that is straightforward to model.

The model includes some simplifications. For example, the coordinate transformation 
assumes that the aluminum plates are infinitely long. This means that the analysis 
neglects effects near the edges of the plates. Neither does the model account for the 
stirring process in the aluminum, which is very complex because it includes phase 
changes and material flow from the front to the back of the rotating tool.

aluminum

shoulder

pin

welded region

joint
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Model Definition

The model geometry is symmetric around the weld. It is therefore sufficient to model 
only one aluminum plate. The plate dimensions are 120 mm × 102 mm × 12.7 mm, 
surrounded by two infinite domains in the x direction. Figure 3-18 shows the resulting 
model geometry: 

Figure 3-18: Model geometry for friction stir welding.

The following equation describes heat transfer in the plate. As a result of fixing the 
coordinate system in the welding tool, the equation includes a convective term in 
addition to the conductive term. The equation is

where k represents thermal conductivity, ρ is the density, Cp denotes specific heat 
capacity, and u is the velocity.

The model sets the velocity to u = 1.59·10−3 m/s in the negative x direction.

The model simulates the heat generated in the interface between the tool’s pin and the 
workpiece as a surface heat source (expression adapted from Ref. 2):

Here µ is the friction coefficient, rp denotes the pin radius, ω refers to the pin’s angular 
velocity (rad/s), and  is the average shear stress of the material. As indicated, the 
average shear stress is a function of the temperature; for this model, you approximate 
this function with an interpolation function determined from experimental data given 
in Ref. 1 (see Figure 3-20).

qs

Qpin

u

T0

insulation

symmetry surface

natural convection and 
surface-to-ambient radiation

infinite domains

∇ k∇T–( )⋅ Q ρ CPu ∇T⋅–=

qpin T( ) µ

3 1 µ2
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----------------------------rpωY T( )  (W/m2)=

Y T( )
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Additionally, heat is generated at the interface between the tool’s shoulder and the 
workpiece; the following expression defines the local heat flux per unit area (W/m2) 
at the distance r from the center axis of the tool:

Here Fn represents the normal force, As is the shoulder’s surface area, and Tmelt is 
aluminum’s melting temperature. As before, µ is the friction coefficient and ω is the 
angular velocity of the tool (rad/s).

Above the melting temperature of aluminum, the friction between the tool and the 
aluminum plate is very low. Therefore, the model sets the heat generation from the 
shoulder and the pin to zero when the temperature is equal to or higher than the 
melting temperature.

Symmetry will be assumed along the weld joint boundary.

The upper and lower surfaces of the aluminum plates lose heat due to natural 
convection and surface-to-ambient radiation. The corresponding heat flux expressions 
for these surfaces are

where hup and hdown are heat transfer coefficients for natural convection, T0 is an 
associated reference temperature, ε is the surface emissivity, σ is the Stefan-Boltzmann 
constant, and Tamb is the ambient air temperature. 

The modeling of an infinite domain on the left-hand side, where the aluminum leaves 
the computational domain, makes sure that the temperature is in equilibrium with the 
temperature at infinity through natural convection and surface-to-ambient radiation. 
You therefore set the boundary condition to insulation at that location.

You can compute values for the heat transfer coefficients using empirical expressions 
available in the heat-transfer literature, for example, Ref. 3. In this model, use the 
values hup = 12.25 W/(m2·K) and hdown = 6.25 W/(m2·K)

qshoulder r T,( )
µFn As⁄( )ωr ; T Tmelt<

0 ; T Tmelt≥
⎩
⎪
⎨
⎪
⎧

=

qup hup T0 T–( ) εσ Tamb
4 T4

–( )+=

qdown hdown T0 T–( ) εσ Tamb
4 T4

–( )+=
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Results and Discussion

Figure 3-19 shows the resulting temperature field. Consider this result as what you 
would see through a window fixed to the moving welding tool.

Figure 3-19: Temperature field in the aluminum plate.

The temperature is highest where the aluminum is in contact with the rotating tool. 
Behind the tool, the process transports hot material away, while in front of the tool, 
new cold material enters.
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Model Library path: Heat_Transfer_Module/Process_and_Manufacturing/
friction_welding

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator and click the New tab. In the Space dimension list select 3D.

2 From the list of application modes select 
Heat Transfer Module>General Heat Transfer>Steady-state analysis.

3 Click OK.

O P T I O N S  A N D  S E T T I N G S

Constants
From the Options menu, select Constants. Define the following names, expressions, and 
(optionally) descriptions; when done, click OK.

NAME EXPRESSION DESCRIPTION

T0 300[K] Reference temperature

T_melt 933[K] Workpiece melting temperature

rho_pin 7800[kg/m^3] Pin density

k_pin 42[W/(m*K)] Thermal conductivity

Cp_pin 500[J/(kg*K)] Specific heat capacity

h_upside 12.25[W/(m^2*K)] Heat transfer coefficient, upside

h_downside 6.25[W/(m^2*K)] Heat transfer coefficient, downside

epsilon 0.3 Surface emissivity

u_weld 1.59[mm/s] Welding speed

mu 0.4 Friction coefficient

n 637[1/min] Rotation speed (RPM)

omega 2*pi[rad]*n Angular velocity (rad/s)

F_n 25[kN] Normal force

r_pin 6[mm] Pin radius

r_shoulder 25[mm] Shoulder radius

A_s pi*(r_shoulder^2
-r_pin^2)

Shoulder surface area
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Functions
Next, define an interpolation function for the aluminum yield stress, , as a function 
of the temperature, T, based on experimental material data listed in Ref. 1.

1 From the Options menu open the Functions dialog box.

2 Click New.

3 In the New Function dialog box, type Ybar in the Function name edit field.

4 Select the Interpolation option button, then click OK.

5 Back in the Functions dialog box, leave the default settings for Interpolation method 
and Extrapolation method. In the x and f(x) columns enter the following data:

The x values are temperatures (in kelvin) and the f values corresponding yield 
stresses (in MPa) for 6061-T6 aluminum.

6 When finished, click Plot to view the resulting interpolation function (Figure 3-20), 
then click OK to close the Functions dialog box.

Figure 3-20: Yield stress (MPa) vs. temperature (K) for 6061-T6 aluminum.

x 311 339 366 394 422 450 477 533 589 644

f(x) 241 238 232 223 189 138 92 34 19 12

Y
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G E O M E T R Y  M O D E L I N G

1 Create the aluminum plate. From the Draw menu, select Block.

2 In the dialog box that appears, go to the Length area and enter the settings in the 
following table; when done, click OK.

3 Repeat Steps 1 and 2 to draw another block using the settings in the following table:

4 In the Axis base point area, type -50e-3 in the x edit field. Click OK.

5 To create a third block of the same dimensions as the one you just created, press 
Ctrl+C and then press Ctrl+V. In the Paste dialog box that appears, type 170e-3 in 
the x edit field, then click OK.

6 Click the Zoom Extents button on the Main toolbar.

7 Go to the Draw menu and select Work-Plane Settings.

8 On the Quick page, click the x-y option button, then in the z edit field enter 
12.7e-3. Click OK.

9 Click the Zoom Extents button on the Main toolbar.

10 Press the Shift key and click the Ellipse/Circle (Centered) button on the Draw toolbar.

11 In the dialog box that appears, enter the following circle properties; when done, 
click OK:

OBJECT DIMENSIONS EXPRESSION

X 120e-3

Y 102e-3

Z 12.7e-3

OBJECT DIMENSIONS EXPRESSION

X 50e-3

Y 102e-3

Z 12.7e-3

OBJECT DIMENSIONS EXPRESSION

Radius 25e-3

Base Center

x-position 61.5e-3

y-position 0
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12 In the same manner, create a second circle with the following properties:

13 Press the Shift key and click the Rectangle/Square button on the Draw toolbar.

14 In the dialog box that appears, enter the following rectangle properties; when done, 
click OK:

15 Create another rectangle with the following properties:

16 Select the circle C1 and the rectangle R1, then click the Difference button on the 
Draw toolbar.

17 Similarly, select the circle C2 and the rectangle R2, then click the Difference button.

18 Select the object CO1, then from the Draw menu select Embed.

19 In the dialog that appears, click OK.

20 Return to the Geom2 geometry.

21 Select the object CO2, then from the Draw menu select Extrude.

22 In the dialog that appears, find the Distance edit field and type -12.7e-3.

23 Click OK.

OBJECT DIMENSIONS EXPRESSION

Radius 6e-3

Base Center

x-position 61.5e-3

y-position 0

OBJECT DIMENSIONS EXPRESSION

Width 50e-3

Height 25e-3

Base Corner

x-position 36.5e-3

y-position -25e-3

OBJECT DIMENSIONS EXPRESSION

Width 12e-3

Height 6e-3

Base Corner

x-position 55.5e-3

y-position -6e-3
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24 Click the Zoom Extents button on the Main toolbar.

P H Y S I C S  S E T T I N G S

Boundary Expressions
1 From the Options menu, select Expressions>Boundary Expressions.

2 Select Boundary 11, then enter the following expressions.

3 Select Boundaries 12 and 16, then enter the following expressions (on the third line 
of the table); when finished, click OK.

Note: The boundary expressions defined above include a smoothed step function, 
flc1hs, which models that the generation of friction heat is zero above the melting 
temperature of aluminum. Using this function is computationally more stable than 
multiplying the expressions by the logical expression (T<T_melt).

Subdomain Settings
1 Choose Physics>Subdomain Settings.

2 Select Subdomains 1, 2 and 4, then click the Load button.

3 From the Materials list, select Basic Material Properties>Aluminum, then click OK.

4 Select Subdomain 3 and enter the following settings:

5 Click the Convection tab and select Subdomains 1, 2 and 4.

6 Select the Enable convective heat transfer check box.

NAME EXPRESSION

R sqrt((x-0.0615)^2+y^2)

q_shoulder (mu*F_n/A_s)*(R*omega)*flc1hs((T_melt-T)[1/K],5)

NAME EXPRESSION

q_pin mu/sqrt(3*(1+mu^2))*(r_pin*omega)*Ybar(T[1/K])[MPa]* 
flc1hs((T_melt-T)[1/K],5)

PROPERTY VALUE

 k (isotropic) k_pin

 ρ rho_pin

 Cp Cp_pin
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NDARY 23

perature
7 In the Matter state list, select Solid.

8 In the leftmost u edit field for the x velocity, type -u_weld.

9 Select Subdomains 1 and 4, and click the Infinite Elements tab.

10 From the Type of infinite element list, select Cartesian. Then select the Stretched in x 

direction check box.

11 Enter the following properties in the x0, y0, and z0 edit fields:

12 Select all subdomains and click the Init tab. Type T0 in the T(t0) edit field for the 
initial value.

13 Click OK.

Boundary Settings
1 From the Physics menu, select Boundary Settings.

2 Select the Interior boundaries check box.

3 Enter settings as in the following table; when finished, click OK.

For the boundaries not mentioned in the table, the default setting (Insulation/
Symmetry) applies.

PROPERTY VALUE

x0 61.5e-3

y0 3e-3

z0 6e-3

SETTINGS BOUNDARY 1 BOUNDARIES 3, 
8, 20

BOUNDARY 4, 
9, 21

BOUNDARY 11 BOUNDARIES 
12, 16

BOU

Type Insulation/
Symmetry

Heat flux Heat flux Heat flux Heat source/
sink

Tem

q0 q_shoulder q_pin

h h_downside h_upside 0

Tinf T0 T0 273.15

T0 T0

Radiation 
type

Surface-to- 
ambient

Surface-to- 
ambient

None

 ε epsilon epsilon

Tamb T0 T0
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M E S H  G E N E R A T I O N

From the Mesh menu, select Initialize Mesh.

C O M P U T I N G  T H E  S O L U T I O N

1 From the Solve menu, open the Solver Parameters dialog box.

2 Click the Stationary tab.

3 Type 60 in the Maximum number of iterations edit field.

4 Click OK.

5 From the Solve menu, choose Solve Problem.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows a slice plot of the temperature field. To create Figure 3-19, 
which shows a slice plot and some temperature isosurfaces, follow these steps:

1 From the Postprocessing menu, open the Plot Parameters dialog box.

2 Go to the Slice page and find the Slice positioning area.

3 In the Number of levels edit field for x levels, change the value to 0.

4 From the Colormap list in the Slice color area, select hot.

5 In the Vector with coordinates edit field for z levels, type 1e-3.

6 Click Apply.

7 On the Isosurface page, select the Isosurface plot check box.

8 In the Vector with isolevels edit field, type 300:20:980.

9 From the Colormap list in the Isosurface color area, select hot.

10 Clear the Color scale check box.

11 Click OK.
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Con t i n uou s  C a s t i n g

Introduction

This example simulates the process of continuous casting of a metal rod from a melted 
state (Figure 3-21). To optimize the casting process in terms of casting rate and 
cooling, it is helpful to model the thermal and fluid dynamic aspects of the process. To 
get accurate results, you must model the melt flow field in combination with the heat 
transfer and phase change. The model includes the phase transition from melt to solid, 
both in terms of latent heat and the varying physical properties. The following model 
was originally developed by J. Fjellstedt (Outokumpu Copper, R&D).

Figure 3-21: Continuous metal-casting process with an exploded view of the modeled 
section.

The model simplifies the rod’s 3D geometry in Figure 3-21 to an axisymmetric 2D 
model in the rz-plane. Figure 3-22 shows the dimensions of the 2D geometry.

Modeled geometry

z

die
mold air exposure
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Figure 3-22: 2D axisymmetric model of the casting process.

As the melt cools down in the mold it solidifies. The phase transition releases latent 
heat, which the model includes. Furthermore, for metal alloys, the transition is often 
spread out over a temperature range. As the material solidifies, the material properties 
change considerably. Finally, the model also includes the “mushy” zone—a mixture of 
solid and melted material that occurs due to the rather broad transition temperature of 
the alloy and the solidification kinetics.

This example models the casting process as being stationary using two application 
modes: General Heat Transfer and Weakly Compressible Navier-Stokes.

Model Definition

The process operates at steady state, because it is a continuous process. The heat 
transport is described by the equation:
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where k, Cp, and Q denote thermal conductivity, specific heat, and heating power per 
unit volume (heat source term), respectively. 

As the melt cools down in the mold, it solidifies. During the phase transition, a 
significant amount of latent heat is released. The total amount of heat released per unit 
mass of alloy during the transition is given by the change in enthalpy, ∆H. In addition 
the specific heat capacity, Cp, also change considerably during the transition. As 
opposed to pure metals, an alloy generally undergoes a broad temperature transition 
zone, over several kelvin, in which a mixture of both solid and molten material co-exist 
in a “mushy” zone. To account for the latent heat related to the phase transition, 
replace Cp in the heat equation with (Cp + δ  ∆H), where ∆H is the latent heat of the 
transition, and δ is a Gaussian curve given by

Here Tm is the melting point and ∆T denotes the half-width of the curve, in this case 
set to 5 K, representing half the transition temperature span. The change in specific 
heat can be approximated by:

The change in specific heat also appears during the phase transition. You represent it 
using COMSOL Multiphysics’ built-in smooth Heaviside step function flc2hs (for 
more details on flc2hs, see the COMSOL Multiphysics Reference Guide).

This example models the laminar flow using the Weakly Compressible Navier-Stokes 
application mode. The application mode describes the fluid velocity, u, and the 
pressure, p, according to the equations:

where ρ is the density (in this case constant), η is the viscosity, and κ is the dilatational 
viscosity (here assumed to be zero). The source term, F, is in this model used to 
dampen the velocity at the phase-change interface so that it becomes that of the 
solidified phase after the transition. The source term follows from the equation (see 
Ref. 1):

δ
T Tm–( )2 ∆T( )2⁄–( )exp

∆T π
----------------------------------------------------------------=

∆Cp
∆H
T

---------=

ρ
t∂

∂u ρu ∇⋅ u+ ∇ pI– η ∇u ∇u( )T
+( ) 2η 3⁄ κ–( ) ∇ u⋅( )I–+[ ]⋅ F+=

t∂
∂ρ ∇+ ρu( )⋅ 0=
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where B is the volume fraction of the liquid phase; Amush and ε represent arbitrary 
constants, (Amush should be large and ε small to produce a proper damping); and ucast 
is the velocity of the cast rod. The fraction of liquid phase, B, is given by

Table 3-4 reviews the material properties in this model.

Furthermore, the melting temperature, Tm, and enthalpy, ∆H, are set to 1356 K and 
205 kJ/(kg·K), respectively.

The model uses the parametric solver in combination with adaptive meshing to solve 
the problem efficiently.

Results and Discussion

The plots in Figure 3-23 display the temperature and phase distributions, showing that 
the melt cools down and solidifies in the mold region. Interestingly, the transition zone 
stretches out towards the center of the rod because of poorer cooling in that area.

TABLE 3-4:  MATERIAL PROPERTIES

PROPERTY MELT SOLID

ρ (kg/m3) 8500 8500

Cp (J/(mol·K)) 530 380

k (W/(m·K)) 200 200

η (Ns/m2) 0.0434 - 

F 1 B–( )2

B3 ε+
---------------------Amush u ucast–( )=

B

1               T Tm ∆T+>( )

T Tm– ∆T+( ) 2∆T( )   Tm ∆T–( ) T Tm ∆T+( )≤ ≤⁄

0             T Tm ∆T–<
⎩
⎪
⎪
⎨
⎪
⎪
⎧

=
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Figure 3-23: Temperature distribution (top) and fraction of liquid phase (bottom) in the 
lower part of the cast at a casting rate of 1.6 mm/s.
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With the modeled casting rate, the rod is fully solidified before leaving the mold (the 
first section after the die). This means that the process engineers can increase the 
casting rate without running into problems, thus increasing the production rate.

The phase transition occurs in a very narrow zone although the model utilizes a 
transition half width, ∆T, of 5 K. In reality it would be even more distinct if a pure 
metal were being cast but somewhat broader if the cast material were an alloy with a 
wider ∆T.

It is interesting to study in detail the flow field in the melt as it exits the die. 
Figure 3-24 shows a zoom of this region.

Figure 3-24: Velocity field with streamlines the lower part of the process.

Notice that there is disturbance in the streamlines close to the die wall resulting in a 
vortex. This eddy flow could create problems with nonuniform surface quality in a real 
process. Process engineers can thus use the model to avoid these problems and find an 
optimal die shape.

In order to help determine how to optimize process cooling, Figure 3-25 plots the 
conductive heat flux. It shows that the conductive heat flux is very large in the mould 
zone. This is a consequence of the heat released during the phase transition, which is 
cooled by the water-cooling jacket of the mould. An interesting phenomenon of the 
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process is the peak of conductive heat flux appearing in the center of the flow at the 
transition zone.

Figure 3-25: The cooling viewed as conductive heat flux in the domains (top), and along 
the outer boundary (the cooling zones) after the die (bottom).
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Furthermore, by plotting the conductive heat flux at the outer boundary for the 
process as in the lower plot in Figure 3-25, you can see that a majority of the process 
cooling occurs in the mold. More interestingly, the heat flux varies along the mold wall 
length. This information can help in optimizing the cooling of the mold (that is, the 
cooling rate and choice of cooling method).

You solve the model using a built-in adaptive meshing technique. This is necessary 
because the transition zone—that is, the region where the phase change occurs—
requires a fine discretization. Figure 3-26 depicts the final mesh of the model. Notice 
that the majority of the elements are concentrated to the transition zone.

Figure 3-26: The final computational mesh, resulting from the built-in adaptive 
technique.

The adaptive meshing technique allows for fast and accurate calculations even if the 
transition width is brought down to a low value, such as for pure metals.
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Model Library path: Heat_Transfer_Module/Process_and_Manufacturing/
continuous_casting

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator and click the New tab. In the Space dimension list select 
Axial symmetry (2D).

2 From the list of application modes, select Heat Transfer Module> 
Fluid-Thermal Interaction>Non-Isothermal Flow>Steady-state analysis.

3 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants. Define the following names and 
expressions; when done, click OK.

2 From the Options menu, select Expressions>Scalar Expressions. Define the following 
expressions; when finished, click OK.

NAME EXPRESSION DESCRIPTION

T0 300[K] Ambient temperature

T_in 1473[K] Melt inlet temperature

v_cast 1.6[mm/s] Casting speed

T_m 1356[K] Melting temperature

dT 20[K] Temperature transition zone half width

dH 205[kJ/kg] Latent heat

NAME EXPRESSION

D exp(-(T-T_m)^2/(dT^2))/sqrt(pi*dT^2)

B (T-T_m+dT)/(2*dT)*((T<=(T_m+dT))*(T>=(T_m-dT)))+(T>(T_m+dT))

Sr (1-B)^2/(B^3+1e-3)*1e5[kg/(m^3*s)]*u

Sz (1-B)^2/(B^3+1e-3)*1e5[kg/(m^3*s)]*(v-v_cast)

H flc2hs(T-T_m,dT)

Cp1 380[J/(kg*K)]+dH/T_m*H
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G E O M E T R Y  M O D E L I N G

1 Create six rectangles. To do so, go to the Draw menu and select 
Specify Objects>Rectangle. Each time you open the dialog box, enter the following 
data for one of the rectangles, then click OK.

2 Click the Zoom Window button on the Main toolbar, then click and drag in the 
drawing area to expand the viewing area between rectangles R2 and R3.

3 Draw two lines that join R2 and R3. To do so, click the Line button on the Draw 
toolbar, then click the right mouse button to complete each line.

4 Select all objects by pressing Ctrl+A.

5 From the Draw menu, select Coerce To>Solid to fill in the trapezoidal area between 
R2 and R3 and form one large solid.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Multiphysics menu, select the Weakly Compressible Navier-Stokes 

application mode.

1 From the Physics menu, select Subdomain Settings.

2 Select all subdomains, then enter the following expressions in the edit fields on the 
Physics page:

The default stabilization method for Navier-Stokes is GLS streamline diffusion and 
crosswind diffusion. For diffusive flows with strong source terms, using bubble 
elements, also known as mini-elements, is a good alternative.

OBJECT WIDTH HEIGHT BASE  r  z 

R1 0.065 0.1 Corner 0 0

R2 0.0625 0.025 Corner 0 0.1

R3 0.11575 0.04 Corner 0 0.165

R4 0.11575 0.3675 Corner 0 0.205

R5 0.11575 0.4 Corner 0 0.5725

R6 0.11575 0.6 Corner 0 0.9725

PARAMETER EXPRESSION

 η 0.0434

 Fr -Sr

 Fz -Sz
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RY 21 BOUNDARIES 
22, 23

x Heat flux

10

T0
3 Click the Stabilization tab.

4 Clear the Streamline diffusion (GLS) and the Crosswind diffusion check boxes, then 
click OK.

5 Click the Element tab, then from the Predefined elements list, select p1+p1 (Mini).

6 Click the Init tab, then in the z-velocity edit field type v_cast. Click OK.

7 From the Multiphysics menu, select the General Heat Transfer application mode.

8 From the Physics menu, open the Subdomain Settings dialog box.

9 Select all subdomains.

10 On the Init page, go to the Temperature edit field and type T_in.

11 Click the General tab. Enter the following settings; when finished, click OK.

12 Click the Convection tab.

The predefined multiphysics coupling sets up the convective heat transfer part 
automatically (click the Convection tab if you want to verify the settings).

13 Click the Element tab, then from the Predefined elements list, select Lagrange - Linear.

14 Click the Stabilization tab.

15 Select the Crosswind diffusion checkbox, and from the Elements of type list select 
Lagrange - Linear to match the element type on the Element page.

16 Click OK.

Boundary Conditions
1 From the Physics menu open the Boundary Settings dialog box.

2 Set boundary conditions according to the following table. Note that h is different 
for Boundaries 20 and 21. When done, click OK.

PARAMETER EXPRESSION

 k (isotropic) 200

 ρ 8500

 Cp Cp1+D*dH

SETTINGS BOUNDARIES 1, 
3, 5, 7, 9, 11, 13

BOUNDARY 2 BOUNDARY 15 BOUNDARIES 
16–19

BOUNDARY 20 BOUNDA

Type Axial 
symmetry

Temperature Convective 
flux

Insulation/
Symmetry

Heat flux Heat flu

h 25 800

Tinf T0 T0
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Surface-to- 
ambient

0.8

T0

RY 21 BOUNDARIES 
22, 23
3 In the Multiphysics menu, select Weakly Compressible Navier-Stokes.

4 From the Physics menu, open the Boundary Settings dialog box.

5 Enter the following settings; when finished, click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Initialize Mesh.

2 Click the Refine Mesh button on the Main toolbar.

C O M P U T I N G  T H E  S O L U T I O N

A three-step solution process calculates the solution. First you solve the problem using 
the parametric solver on the default mesh, gradually decreasing the value of dT. Then 
you use the adaptive solver to adapt the mesh. Finally, you use the Parametric solver to 
decrease dT further down to a value of 5.

1 From the Solve menu, open the Solver Parameters dialog box.

2 On the General page, select Parametric from the Solver list. 

3 In the Parameter name edit field type dT, and in the Parameter values edit field type 
300 100 50 20.

4 On the Stationary page, set the Maximum number of iterations to 50.

5 Click Apply.

T0 T_in

Radiation 
type

None None None

 ε

Tamb

SETTINGS BOUNDARIES 1, 
3, 5, 7, 9, 11, 13

BOUNDARY 2 BOUNDARY 15 BOUNDARIES 
16–19

BOUNDARY 20 BOUNDA

SETTINGS BOUNDARIES 1, 3,  
5, 7, 9, 11, 13

BOUNDARY 2 BOUNDARIES 15, 21–23 BOUNDARIES 16–20

Boundary 
type

Symmetry 
boundary

Inlet Outlet Wall

Boundary 
condition

Axial symmetry Pressure, no 
viscous stress

Velocity No slip

u0 0

v0 v_cast

p0 0
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6 Click the Solve button on the main toolbar to compute the first solution.

7 In the Solver Parameters dialog box, return to the General page and select the 
Stationary solver from the Solver list.

8 Select the Adaptive mesh refinement check box below the Solver list.

9 Click Apply.

10 Select Solve>Restart to start the adaptive solver based on the last solution.

11 To view the adapted mesh, choose Mesh>Mesh Mode.

You should now have a mesh resembling that in Figure 3-26, based on 
approximately 17,000 elements. You can view the statistics of the mesh by choosing 
Mesh>Mesh Statistics.

12 In the Solver Parameters dialog box, select the Parametric solver again.

13 Clear the Adaptive mesh refinement check box.

14 Change the Parameter values to 20 10 5.

15 Click the Parametric tab and select the Manual tuning of parameter step size.

16 Set the Initial step size to 5, the Maximum step size to 2.5, and the Maximum step 

size to 5.

17 Click the Stationary tab. Clear the Highly nonlinear problem check box.

18 Click OK.

19 To compute the last solution, click the Restart button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate the upper plot in Figure 3-23, follow these steps:

1 From the Postprocessing menu, open the Plot Parameters dialog box.

2 Go to the Surface page, then in the Predefined quantities list select Temperature.

3 Click the Arrow tab. Select the Arrow plot check box at the top of the dialog box to 
enable this type of plot. On the Subdomain Data page, select Velocity field from the 
Predefined quantities list.

4 Click Apply.

5 Use the Zoom Window tool on the Main toolbar to zoom in on the geometry’s lower 
half.

To generate the lower plot in Figure 3-23, continue with these steps:

1 Return to the Plot Parameters dialog box and clear the Arrow plot check box, then 
click the Surface tab.
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2 On the Surface Data page, type B in the Expression edit field. (This variable represents 
the fraction of the volume in the liquid phase.)

3 Click Apply.

To generate Figure 3-24 execute the following instructions:

1 Still on the Surface page of the Plot Parameters dialog box, select Velocity field from 
the Predefined quantities list on the Surface Data page.

2 Click the Streamline tab. Select the Streamline plot check box.

3 On the Streamline Data page, select Velocity field from the Predefined quantities list. 
In the Number of start points edit field, type 33.

4 Click Apply.

You reproduce the upper plot in Figure 3-25 as follows:

1 In the Plot Parameters dialog box, clear the Streamline plot check box.

2 Click the Arrow tab. Select Total heat flux from the Predefined quantities list.

3 Click the Surface tab. Select Conductive heat flux from the Predefined quantities list 
on the Surface Data page.

4 Click OK to generate the plot and close the Plot Parameters dialog box.

Finally, generate the lower plot in Figure 3-25 with the following steps:

1 From the Postprocessing menu, select Domain Plot Parameters. Go to the Line/

Extrusion page.

2 From the Predefined quantities list, select Normal conductive heat flux.

3 In the x-axis data area, click first the lower option button and then the Expression 
button.

4 In the X-Axis Data dialog box, type z in the Expression edit field and then click OK.

5 Select Boundaries 20–23, then click OK.
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Tu r bu l e n t  F l ow Th r ough a 
S h e l l - a nd - T ub e  Hea t  E x c h ang e r

Introduction

This model describes a part of a shell-and-tube heat exchanger (see Figure 3-27), 
where hot water enters from above. The cooling medium, which is also commonly 
water, flows through the pipes and enters from the side. The tubes are assumed to be 
made of stainless steel.

Figure 3-27: A tube bundle from a shell-and-tube heat exchanger. The arrows indicate the 
flow directions.

Assuming that the cooling water is in abundant supply, the flow through the pipes has 
a constant temperature. Under that assumption, you can model this heat exchanger by 
a 2D model as shown in Figure 3-28, and the corresponding 2D domain appears in 
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Figure 3-29. Note that the pipe interiors are not part of the domain because the model 
assumes the temperature to be constant there.

Figure 3-28: The dashed line marks the model region, which is shown in Figure 3-29.

T H E  N E E D  F O R  A  TU R B U L E N C E  M O D E L

The characteristic of a flow is often described by the Reynolds number, which is 
defined as

where U is a velocity scale and L is a length scale. If the Reynolds number is low, no 
turbulence model is needed. If, on the other hand, the Reynolds number is high, then 
the flow is dominated by convection, and a turbulence model is necessary. 

In this case, a suitable velocity scale is the mean inlet velocity, which is 0.5 m/s, and L 
is set to the pipe diameter. Then, using standard values for water for the density and 
viscosity, the equation gives an approximate Reynolds number of 50,000, which is high 
enough to warrant the use of a turbulence model. See Ref. 4 for more information on 
flow regimes for different Reynolds numbers.

The following example demonstrates how to model a conjugate heat transfer problem 
with COMSOL Multiphysics, using the Turbulent Fluid-Thermal Interaction 
predefined multiphysics coupling from the Heat Transfer Module. It also demonstrates 

Re ρUL
η

------------=
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how to generate a fully developed flow field when you know the mass flow rate but not 
the pressure drop.

Figure 3-29: The modeled 2D region. The arrows indicate the flow.

Model Definition

S O L I D  A N D  F L U I D  H E A T  TR A N S F E R — I N C L U D I N G  T H E  F L U I D  D Y N A M I C S

The governing equations in this model are:

• Reynolds Averaged Navier-Stokes (RANS) equations and a Wilcox revised k-ω 
turbulence model from 1998 in the water domain.

• Heat transport equations in the water and the solid (steel) tube walls.

The Turbulent Fluid–Thermal Interaction predefined multiphysics coupling sets up 
the appropriate application modes together with applicable couplings, making it easy 
to model the fluid-thermal interaction. 

Temperature dependent properties for water and steel can be loaded from the built-in 
material library. It is necessary to correct the fluid’s thermal conductivity to take into 
account the effect of mixing due to eddies. The turbulence results in an effective 
thermal conductivity, keff, according to the equation
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where k is the fluid’s physical thermal conductivity and kT is the turbulent 
conductivity. ηT denotes the turbulent dynamic viscosity, and Cp is the heat capacity. 
PrT is the turbulent Prandtl number. It is easy to obtain the effective conductivity in 
COMSOL Multiphysics by using the ‘default’ group in the fluid domain. In this 
group, the variable for turbulent conductivity is already given in the heat transfer 
application mode for the fluid. Be careful not to confuse k in the meaning of thermal 
conductivity with k in the meaning of turbulent kinetic energy.

Figure 3-30 depicts the model with its boundary conditions.

Figure 3-30: Modeled 2D geometry with boundary conditions.

keff k kT+= kT
CpηT
PrT

--------------=

Convective

Temperature

outflow

x

 

 
Logarithmic walls

Constant
temperature

Periodic conditions
for v, k, and ω

Symmetry

Constant
temperature

Constant
temperature

Symmetry

Symmetry
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The boundary conditions describing the problem are:

• k-ω equations in the fluid domain

- Specified mass flow through the domain.

- Pressure difference between inlet and outlet given by the mass flow

- Normal flow at the inlet and outlet

- Stream-wise periodic conditions for v, k, and ω.

- Symmetry at the region borders

- Logarithmic wall function at the pipes’ surface boundaries

• Heat transport equations

- 50 °C temperature at the inlet

- Convection-dominated transport at the outlet

- Symmetry (thermal insulation) at the region borders

- Thermal wall function at the pipe/water interfaces

- Fixed temperature at the inside of the heat pipes

The periodicity of the flow is important because you are modeling a part of the heat 
exchanger where the flow is fully developed. It is hard to make a periodic configuration 
converge from a homogeneous initial guess, however, and therefore, an initial 
calculation with constant inlet velocity and fixed outlet pressure is first performed.

The logarithmic wall function boundary condition for turbulent flow is used to model 
the solid-fluid interfaces. An algebraic relationship—the logarithmic wall function—
describes the momentum transfer at the solid-fluid interface. This means that the 
solid-fluid boundaries in the model actually represent lines within the logarithmic 
regions of the boundary layers. Similar to the fluid velocity, the temperature is not 
modeled in innermost part of the boundary layer. Instead of assuming continuity of 
the temperature across the layer, a thermal “wall function” is used. There is a jump in 
temperature from the solid surface to the fluid due to the omitted innermost part of 
the boundary layer. The predefined group for the wall domains defines this wall 
function in the following way.

To achieve the thermal wall function, the model uses two heat transfer application 
modes: one for the solid, and one for the fluid. These are connected through a heat 
flux boundary condition, the thermal wall function. This means that the resistance to 
heat transfer through the innermost part of the boundary layer is related to that for 
momentum transfer for the fluid. The heat flux, q, is determined by the equation
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where ρ and Cp are the fluid’s density and heat capacity, respectively;  is a constant 
of the turbulence model; and kw is the value of the turbulent kinetic energy at the wall. 
Tw equals the temperature of the solid at the wall, while T is the temperature of the 
fluid on the other side of the omitted laminar sublayer. The dimensionless quantity 

 is the dimensionless temperature and depends on the dimensionless 
wall offset, δw

+.

Results for the Flow/Heat Model

Figure 3-31 depicts the temperature distribution and velocity streamlines. As the plot 
shows, the flow field is periodic in the y direction. This is important because the heat 
transfer is strongly influenced by the details of the velocity field. Observe the 
low-temperature zones behind the pipes created by the recirculation zones there.

Figure 3-31: Temperature distribution for the periodic boundary case with a specified 
mean mass flow.

q
ρCpCµ

1 4⁄ kw
1 2⁄ Tw T–( )

T+
---------------------------------------------------------------=

Cµ

T+ T+ δw
+( )=
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Model Library path: Heat_Transfer_Module/Process_and_Manufacturing/
turbulent_heat_exchanger

Modeling Using the Graphical User Interface

The COMSOL Multiphysics implementation is straightforward using the Heat 
Transfer Module. You build the model in several steps to ensure accurate results.

M O D E L  N A V I G A T O R

1 Open the Model Navigator, and in the Space dimension list select 2D.

2 In the list of application modes select Heat Transfer Module>Fluid-Thermal 

Interaction>Turbulent Non-Isothermal Flow, k-ω.

3 Click OK.

G E O M E T R Y  M O D E L I N G

To save time, load the CAD model as a COMSOL Multiphysics Geometry file:

1 From the File menu select Import>CAD Data From File. A dialog box opens.

2 Select All 2D CAD files from the Files of type list.

3 Browse to the folder Models/Heat_Transfer_Module/
Process_and_Manufacturing in the COMSOL Multiphysics installation 
directory. Find and select the file turbulent_heat_exchanger.mphbin.

4 Click Import to load the model.
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You should now see the following geometry:

C O N S T A N T S ,  E X P R E S S I O N S ,  A N D  V A R I A B L E S

1 From the Options menu open the Constants dialog box.

2 Specify the following names, expressions, and descriptions (optional); when done, 
click OK.

P H Y S I C S  A N D  B O U N D A R Y  S E T T I N G S

You first make a computation without periodic boundary conditions. This yields a 
velocity field that can be used as an initial guess for the periodic case.

1 Make sure that the k-ω Turbulence Model (chns) application mode is the active 
application mode.

2 Choose Physics>Subdomain Settings. Select Subdomains 1, 3, and 4 (the pipes).

3 Select Solid domain from the Group list.

4 Select Subdomain 2 (the fluid). Click the Load button to open the Materials/

Coefficients Library dialog box. 

NAME EXPRESSION DESCRIPTION

T_in 323[K] Inflow temperature

T_pipe 278[K] Pipe temperature

v_in -0.5[m/s] Inflow velocity

rho0 988[kg/m^3] Reference density, water

L_in 0.025[m] Width of inflow boundary

mf_in L_in*rho0*v_in Mass inflow
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5 From the Materials tree, choose Liquids and Gases>Liquids>Water. Click OK.

6 Click OK to close the Subdomain Settings dialog box.

7 Choose Physics>Boundary Settings.

8 Apply the following boundary settings; when done, click OK.

Now set up the parameters for the heat transfer.

1 In the Multiphysics menu, select the first General Heat Transfer application mode 
(htgh).

2 Choose Physics>Subdomain Settings.

3 Select Subdomains 1, 3, and 4. Select Solid domain from the Group list.

4 Select Subdomain 2. From the Library material list select Water.

5 Click OK.

6 From the Physics menu, open the Boundary Settings dialog box.

7 Specify boundary settings according to the following table. When done, click OK.

8 In the Multiphysics menu, select the second General Heat Transfer application mode 
(htgh2).

SETTINGS BOUNDARY 7 BOUNDARIES 2, 8, 11 BOUNDARIES 13, 
14, 16, 17

BOUNDARY 6

Object Inlet Symmetry boundaries Pipe surfaces Outlet

Boundary 
type

Inlet Symmetry boundary Wall Outlet

Boundary 
condition

Velocity Logarithmic 
wall function

Pressure

u0 0

v0 v_in

p0 0

SETTINGS BOUNDARY 7 BOUNDARIES 2, 8, 11 BOUNDARIES 13, 
14, 16, 17

BOUNDARY 6

Object Inlet Symmetry 
boundaries

Pipe surfaces Outlet

Group wall

Boundary 
condition

Temperature Insulation/
Symmetry

Convective flux

T0 T_in
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9 Choose Physics>Subdomain Settings.

10 For Subdomains 1, 3, and 4, select Solid domain from the Group list. 

11 Click the Load button to open the Materials/Coefficients Library dialog box.

12 From the Materials tree, select Basic Material Properties>Steel AISI 4340. Click OK.

13 Click OK to close the Subdomain Settings dialog box.

14 Open the Physics>Boundary Settings dialog box and specify the following boundary 
conditions. When done, click OK.

M E S H  G E N E R A T I O N

1 Click the Initialize Mesh button on the Main toolbar.

2 Click the Refine Mesh button on the Main toolbar once to generate the final mesh.

C O M P U T I N G  T H E  S O L U T I O N

The solution procedure involves a first solution step that solves a given inlet velocity. 
This yields a good initial condition for the final calculation with periodic boundary 
conditions.

1 Click the Solve button on the Main toolbar.

2 Choose Solve>Solver Manager.

3 On the Initial Value page, click the Store Solution button.

4 Click the Current solution option button in the Initial value area.

5 Click OK.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 To generate Figure 3-32 open the Postprocessing>Plot Parameters dialog box.

2 On the General page, clear the Surface check box, then select the Contour check box.

SETTINGS BOUNDARIES 12, 15, 18, 19 BOUNDARIES 13, 14, 16, 17

Object Pipe inner temperature Pipe surfaces

Group wall

Boundary condition Temperature

T0 T_pipe
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3 On the Contour page, select Velocity field in the Predefined quantities list and click OK.

Figure 3-32: Velocity contours for a uniform inflow velocity.

In Figure 3-32 it is clear that the velocity profile on the outflow boundary is not 
uniform; instead, it varies considerably. Because the heat exchanger system is periodic 
in its structure, the velocity field should be periodic. The next step is therefore to add 
periodic boundary condition for the  y-velocity, v, and for k and ω. The mass flux is 
controlled by an integral constraint implemented in the Global Equations dialog box. 

1 Open the Physics>Periodic Conditions>Periodic Boundary Conditions dialog box, then 
select Boundary 7. Select the first row in the Expression column and type v. Type 
logk on the second row in the same column and logw on the third row.

2 On the Destination page select Boundary 6. 

3 Type logw in the Expression edit field and select the Use selected boundaries as 

destination check box.

The following two steps, Steps 4 and 5, specify the relative orientation of the fields 
on the source and destination boundaries.

4 On the Source Vertices page add Vertices 10 and 16 to the Source vertices list in this 
order by selecting them in the Vertex selection list and then clicking the >> button.
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5 On the Destination Vertices page add Vertices 9 and 11 to the Destination vertices 
list. This identifies Vertex 10 with Vertex 9, and Vertex 16 with Vertex 11.

6 On the Destination page select pconstr2 from the Constraint name list.

7 Type logk in the Expression edit field and select the Use selected boundaries as 

destination check box.

8 Repeat Steps 4 and 5.

9 On the Destination page select pconstr1 from the Constraint name list.

10 Type v in the Expression edit field and select the Use selected boundaries as 

destination check box.

11 Repeat Steps 4 and 5.

12 Click OK.

The next step is to add an integration coupling variable that evaluates the total mass 
flux through the inlet. It is later used in an ODE to calculate an inlet pressure. 

1 In the Options menu select Integration Coupling Variables>Boundary Variables, and 
choose Boundary 7.

2 Select the first row in the list. Type mf in the Name edit field and rho_chns*v in the 
Expression edit field. Click OK.

The next step is to add a global equation that constrains the mass flux. The Global 

Equations variable controls the inflow pressure level and yields the desired mass flow, 
mf_in. Also, a point pressure constraint must be added to keep the absolute pressure 
level fixed.

1 Open the Physics>Global Equations dialog box.

2 On the States page, select the first row. Type p_in in the Name (u) column, then 
enter mf-mf_in in the Equation f(u,ut,utt,t) column.

3 Click OK to close the dialog box.

4 In the Multiphysics menu, select the k–ω Turbulence Model (chns) application mode.

5 Choose Physics>Boundary Settings.

6 Select the inlet boundary (Boundary 7).

7 Change the Boundary type from Inlet to Stress. Set the Boundary condition to 
Normal stress and set f0 to p_in.

8 Click OK.
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C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 Add p_in as a Component of Group 1.

3 Click OK.

4 Click the Solve button on the Main toolbar.

Figure 3-33: Velocity contours for periodic velocity conditions.

From Figure 3-33 it is now evident that the inflow and outflow velocity profiles match. 
In addition, the velocity is higher close to the pipe at the inflow region. This is clearly 
important when it comes to heat transfer, and it is a considerable improvement when 
compared to the uniform inflow profile.

PO S T P R O C E S S I N G

1 To generate Figure 3-31, open the Postprocessing>Plot Parameters dialog box.

2 On the General page, clear the Contour check box and select the Surface and 
Streamline check boxes.

3 On the Surface page, choose General Heat Transfer (htgh)>Temperature in the 
Predefined quantities list.
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4 On the Streamline page, choose k-ω Turbulence model (chns)>Velocity field in the 
Predefined quantities list. Set the Streamline plot type to Magnitude controlled.

5 Click the Line Color tab, then click the Uniform color option button. Click the Color 
button and select black, then click OK.

6 Click the Advanced button. Select the Normalize vector field check box, then click OK 
to close the Advanced Streamline Parameters dialog box.

7 Click OK to close the Plot Parameters dialog box and generate the plot.
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F l u i d - S t r u c t u r e  I n t e r a c t i o n  i n  
A l um i num Ex t r u s i o n

Introduction

In massive forming processes like rolling or extrusion, metal alloys are deformed in a 
hot solid state with material flowing under ideally plastic conditions. Such processes 
can be simulated effectively using computational fluid dynamics, where the material is 
considered as a fluid with a very high viscosity that depends on velocity and 
temperature. Internal friction of the moving material acts as a heat source, so that the 
heat transfer equations are fully coupled with those ruling the fluid dynamics part. This 
approach is especially advantageous when large deformations are involved.

This model is adapted from a benchmark study in Ref. 1. The original benchmark 
solves a thermal-structural coupling, because it is common practice in the simulation 
of such processes to use specific finite element codes that have the capability to couple 
the structural equations with heat transfer. The alternative scheme discussed here 
couples non-Newtonian flow with heat transfer equations. In addition, because it is 
useful to know the stress in the die due to fluid pressure and thermal loads, the model 
adds a structural mechanics analysis to the other two.

The die design is courtesy of Compes S.p.A., while the die geometry, boundary 
conditions, and experimental data are those of Ref. 1.

Note: This model requires the Chemical Engineering Module, the Heat Transfer 
Module, and the Structural Mechanics Module. In addition, the model uses the 
Material Library.

Model Definition

The model considers steady-state conditions, assuming a billet of infinite length 
flowing through the die. In the actual process, the billet is pushed by the ram through 
the die and its volume is continuously reducing.

Figure 3-34 shows the original complete geometry with four different profiles. To 
have a model with reasonable dimensions, consider only a quarter of the original 
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geometry. The simplification involved in neglecting the differences between the four 
profiles does not affect the numerical scheme proposed. Figure 3-35 shows the 
resulting model geometry.

Figure 3-34: Original benchmark geometry.

Figure 3-35: Quarter of the original geometry considered in the model.

M A T E R I A L  P R O P E R T I E S

The documentation associated with the benchmark (Ref. 1) serves as the data source 
for properties of the two main materials: AISI steel for the die and the container (the 
ram here is not considered) and aluminum for the billet.

Structural Analysis
Because only the steel part is active in the structural analysis, consider a simple linear 
elastic behavior where the elastic properties are those of the material H11 mod (AISI 
610) that can be found in the COMSOL Multiphysics Material Library. 
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Heat Transfer Analysis
The documentation associated with the benchmark suggested to use for aluminum and 
for steel the following properties:

Non-Newtonian Flow
The properties of the aluminum were experimentally determined and then checked 
using literature data for the same alloy and surface state. However the benchmark 
proposes an experimental constitutive law, suited for the structural mechanics codes 
usually used to simulate such processes, in the form of the flow stress data. For this 
model this requires a recalculation of the constitutive law to derive a general expression 
for the viscosity. The equivalent von Mises stress, σeqv, can be defined in terms of the 
total contraction of the deviatoric stress tensor as

or, using  where  is the strain rate and η is the viscosity, as

 (3-1)

Introducing the equivalent strain rate

Equation 3-1 can be expressed as 

The strain rate tensor is defined as (Ref. 2)

ALUMINUM VALUE DESCRIPTION

 Kal 210 N/(s·K) Conductivity

 ρal 2700 kg/m3 Density

 Cpal 2.94 N/(mm2·K)/ρal Specific heat

STEEL VALUE DESCRIPTION

 Kfe 24.33 N/(s·K) Conductivity

 ρfe 7850 kg/m3 Density

 Cpfe 4.63 N/(mm2·K)/ρfe Specific heat

σeqv
3
2
---τ:τ=

τ 2ηε·= ε·

σeqv 6η2ε:ε=

φ· eqv
2
3
---ε:ε≡

σeqv 3ηφ· eqv=
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Equation 5-26 on page 142 in the Chemical Engineering Module User’s Guide states 
that the shear rate  is defined as

so that

The flow rule

states that plastic yielding occurs if the equivalent stress, σeqv, reaches the flow stress, 
κf. The viscosity is defined as (see Ref. 2 for further details)

The organizers of the benchmark propose specific flow-stress data expressed in terms 
of a generalized Zener-Hollomon function

where A = 2.39·108 s−1, n = 2.976, α = 0.052 MPa−1, and

with Q = 153 kJ/mol and R = 8.314 J/(K·mol).

ε· u∇ u∇( )T
+

2
------------------------------- 1

2
---γ·= =

γ·

γ· γ· 1
2
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1
3
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S O U R C E S ,  I N I T I A L  C O N D I T I O N S ,  A N D  B O U N D A R Y  C O N D I T I O N S

Structural Analysis
Because the model geometry is a quarter of the actual geometry, use symmetric 
boundary conditions for the two orthogonal planes. On the external surfaces of the 
die, apply roller boundary conditions because in reality other dies, not considered here, 
are present to increase the system’s stiffness.

The main loads are the thermal loads from the heat transfer analysis and pressures from 
the fluid dynamics analysis.

Heat Transfer Analysis
For the billet, use a volumetric heat source related to the viscous heating effect.

The external temperature of the ram and the die is held constant at 450 °C. The 
ambient temperature is 25 °C. For the heat exchange between aluminum and steel, use 
the heat transfer coefficient of 11 N/(s·mm·K). Also consider convective heat 
exchange with air outside the profiles with a fixed convective heat transfer coefficient 
of 15 W/(m2·K).

Apply initial temperatures as given in the following table:

Non-Newtonian Flow
At the inlet, the ram moves with a constant velocity of 0.5 mm/s. Impose this 
boundary condition by simply applying a constant inlet velocity. At the outlet, a 
normal stress condition with zero external pressure applies. On the surfaces placed on 
the two symmetry planes, use symmetric conditions. Finally, apply slip boundary 
conditions on the boundaries placed outside the profile.

Results and Discussion

The general response of the proposed numerical scheme, especially in the zone of the 
profile, is in good accordance with the experience of the designers. A comparison 
between the available experimental data and the numerical results of the simulation 
shows good agreement.

PART VALUE

Ram 380 °C

Container 450 °C

Billet 460 °C

Die 404 °C
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On the basis of the results from the simulation, the engineer can improve the 
preliminary die design by adjusting relevant physical parameters and operating 
conditions. For this purpose, the slice plot in Figure 3-36 showing the temperature 
field inside the profile gives important information. Furthermore, the combined 
streamline and slice plot in Figure 3-37 reveals any imbalances in the velocity field that 
could result in a crooked profile. A proper design should also ensure that different 
parts of the profile travel at the same speed. In Figure 3-38 you can see von Mises 
equivalent strain in the steel part considering the thermal load and also the pressure 
due to the presence of the fluid.

Figure 3-36: Temperature distribution in the billet.
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Figure 3-37: Velocity field and streamlines at the profile section.

Figure 3-38: Equivalent von Mises distribution in the container.
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Model Library path: Heat_Transfer_Module/Process_and_Manufacturing/
aluminum_extrusion_fsi

Modeling Using the Graphical User Interface

M O D E L  N AV I G AT O R

1 Double-click the COMSOL Multiphysics icon on your desktop to open the Model 

Navigator.

2 Select 3D from the Space dimension list and click the Multiphysics button.

3 From the list of application modes, select Structural Mechanics Module>Solid, 

Stress-Strain, then click Add.

4 Select Chemical Engineering Module>Momentum Transport>Laminar 

Flow>Non-Newtonian Flow, then click Add.

5 Select Heat Transfer Module>General Heat Transfer. Change the Element to 
Lagrange - Linear, then click Add.

6 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

2 Enter the following constant names, expressions, and descriptions (the descriptions 
are optional); when finished, click OK.

NAME EXPRESSION DESCRIPTION

K_al 210[N/(s*K)] Thermal conductivity, aluminum

Rho_al 2700[kg/m^3] Density, aluminum
F L U I D - S T R U C T U R E  I N T E R A C T I O N  I N  A L U M I N U M  E X T R U S I O N  |  269



270 |  C H A P T E R
G E O M E T RY  M O D E L I N G

Import the model geometry from a CAD file:

1 Choose File>Import>CAD Data From File.

2 In the Look in list, browse to the folder models/Structural_Mechanics_Module/
Fluid-Structure_Interaction in your COMSOL Multiphysics installation 
directory.

3 Select the file aluminum_extrusion_fsi.mphbin, then click Import.

Cp_al 2.94[N/(mm^2*K)]/Rho_al Specific heat, aluminum

D_alfe 1[mm] Thickness, highly conductive 
layer

Heat_alfe 11[N/(s*mm*K)] Aluminum-steel heat exchange 
coefficient

T_billet 460[degC] Temperature, billet

T_container 450[degC] Temperature, container

T_ram 380[degC] Temperature, ram

T_pd1 404[degC] Initial temperature around 
thermocouple at point PD1

V_ram 0.5[mm/s] Velocity, ram

P_init 0[bar] External reference pressure

Radius 0.073[m] Radius, ram

T_Air 25[degC] Ambient temperature

Q_eta 153000[J/mol] Parameter Q for the generalized 
Zener Hollomon function

R_eta 8.314[J/(K*mol)] Ideal gas constant

n_eta 2.976 Parameter n for the generalized 
Zener-Hollomon function

A_eta 2.39e8[1/s] Parameter A for the generalized 
Zener-Hollomon function

Alfa_eta 0.052[1/MPa] Parameter alpha for the 
generalized Zener-Hollomon 
function

H_conv 15 Convective heat exchange 
coefficient with air

Factor sqrt(1/3) Factor for the conversion of 
the shear rate to COMSOL’s 
definition

NAME EXPRESSION DESCRIPTION
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P H Y S I C S  S E T T I N G S

Start by defining the physical properties in the different subdomains.

S U B D O M A I N  S E T T I N G S — H E A T  TR A N S F E R

1 From the Physics menu, select Subdomain Settings.

2 In the Subdomain selection list, select Subdomains 1 and 2.

3 Click the Load button to open the Materials/Coefficients Library dialog box.

4 In the Search string edit field, type AISI, then click the Search button. From the 
Search results list, select H11 mod (AISI 610), then click OK.

5 Change the entry in the Cp edit field so that it reads 4.63[N/(mm^2*K)]/
mat1_rho(T[1/K])[kg/m^3].

6 Select Subdomains 3–5. Set k to K_al, ρ to Rho_al, and Cp to Cp_al.

7 Click the Convection tab. Select the Enable convective heat transfer check box, then 
enter the velocity components u2, v2, and w2 in the u edit fields. Select the Viscous 

heating check box, then specify the dynamic viscosity η as eta_chns.

8 Click the Init tab. Set the initial temperatures according to the following table:

9 Click OK.

S U B D O M A I N  S E T T I N G S — S T R U C T U R A L  M E C H A N I C S

1 From the Multiphysics menu, select Solid, Stress-Strain (smsld).

2 From the Physics menu, select Subdomain Settings.

3 Select Subdomains 3–5, then clear the Active in this subdomain check box to 
deactivate these subdomains.

4 Select Subdomains 1 and 2. From the Library material list, select H11 mod (AISI610).

5 On the Load page, select the Include thermal expansion check box and set the Strain 

temperature to T for both subdomains. Set the Strain ref. temperature for 
Subdomain 1 to T_container and that for Subdomain 2 to T_pd1.

6 Click OK.

S U B D O M A I N  S E T T I N G S — N O N - N E W T O N I A N  F L O W

1 From the Multiphysics menu, select Non-Newtonian Flow (chns).

2 From the Physics menu, select Properties.

SETTING SUBDOMAIN 1 SUBDOMAINS 2, 4 SUBDOMAIN 3 SUBDOMAIN 5

T(t0) T_container T_pd1 T_billet T_air
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3 Set the Weakly compressible flow option to On, then click OK.

4 From the Physics menu, select Subdomain Settings.

5 Select Subdomains 1 and 2, then clear the Active in this subdomain check box.

6 Select Subdomains 3–5. From the Viscosity model list, select User-defined model. Set 
ρ to Rho_al, η to Eta_al, and κdv to Eta_al/3.

7 On the Init page, set P2(t0) to P_init.

8 Click OK to close the Subdomain Settings dialog box.

9 Select Options>Expressions>Subdomain Expressions.

10 Create two new expressions for Subdomains 3–5 by entering the following data:

11 Click OK.

B O U N D A R Y  C O N D I T I O N S — N O N - N E W T O N I A N  F L O W

1 From the Physics menu, select Boundary Settings.

2 Select Boundaries 10 and 96, then set the Boundary type to Symmetry boundary.

3 Select Boundary 11. Set the Boundary type to Inlet and the Boundary condition to 
Velocity. In the w0 edit field, type V_ram.

4 Select Boundaries 36, 37, 41, 45, 47, 62, 68, 69, 73, 79, 85, and 87. Set the 
Boundary condition to Slip.

5 Select Boundary 39. Set the Boundary type to Outlet and the Boundary condition to 
Normal stress. In the f0 edit field, type P_init.

6 Click OK.

B O U N D A R Y  C O N D I T I O N S — S T R U C T U R A L  M E C H A N I C S

1 From the Multiphysics menu, select Solid, Stress-Strain (smsld).

2 From the Physics menu, select Boundary Settings.

3 Select Boundaries 2, 5, 7, and 8, then set the Constraint condition to Roller.

4 Select Boundaries 1, 4, 94, and 95, then set the Constraint condition to Symmetry 

plane.

NAME EXPRESSION

Z_eta Factor*sr_chns*exp(Q_eta/(R_eta*T))

Eta_al asinh((Z_eta/A_eta)^(1/n_eta))/
(3*Alfa_eta*Factor*sr_chns+sqrt(eps))
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5 Select Boundaries 9, 12, 15, 16, 21, 22, 26, 30, 31, 32, 33, 34, 35, 40, 44, 46, 50–
52, 56, 64–66, 67, 72, 74–78, 84, 86, 88, and 91. On the Load page, set the 
Coordinate system to Tangent and normal coord. sys. and Fn to p2.

6 Select Boundary 61, then set the Coordinate system to Tangent and normal coord. sys. 
and Fn to -p2.

7 Click OK.

B O U N D A R Y  C O N D I T I O N S — H E A T  TR A N S F E R

1 From the Multiphysics menu, select General Heat Transfer (htgh).

2 From the Physics menu, select Boundary Settings.

3 Select Boundaries 2, 5, 7, and 8, then set the Boundary condition to Temperature. In 
the T0 edit field, type T_container.

4 Select Boundary 11, then set the Boundary condition to Heat flux. Set h to 
Heat_Alfe and Tinf to T_ram.

5 Select Boundaries 36, 37, 41, 45, 47, 62, 68, 69, 73, 79, 85, and 87, then set the 
Boundary condition to Heat flux. Set h to H_conv and Tinf to T_air.

6 Select Boundary 39, then set the Boundary condition to Convective flux.

7 Select the Interior boundaries check box, then select Boundaries 9, 12, 15, 16, 21, 
22, 26, 30–35, 40, 44, 46, 50–52, 56, 61, 64–67, 72, 74–78, 84, 86, 88, and 91. 
On the Highly Conductive Layer page, select the Enable heat transfer in highly 

conductive layer check box. Set ks to Heat_Alfe*D_alfe and ds to D_alfe.

8 Click OK.

M E S H  G E N E R AT I O N

1 Choose Mesh>Free Mesh Parameters.

2 From the Predefined mesh sizes list, select Coarser.

3 Click the Subdomain tab. Select Subdomains 1–3, then set the Maximum element size 
to 0.0085. Select subdomain 4, then set the Maximum element size to 0.0025.

4 Click the Boundary tab. Select Boundaries 2, 5, and 8, then set the Maximum element 

size to 0.0085.

5 Select Boundaries 13–16, 21, 22, 26, 29–35, 38, 40, 44, 46, 50–52, 56, 61, 64–67, 
72, 74–78, 84, 86, 88, and 91, then set the Maximum element size to 0.002.

6 Select Boundaries 18–20, 23–25, 27, 28, 42, 43, 48, 49, 54, 55, 57–60, 63, 70, 71, 
80–83, 89, 90, 92, and 93, then set the Maximum element size to 0.0025.

7 Click Remesh.
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8 Click OK.

9 Select Subdomain 5 and from the interactive mesh column delete the mesh on this 
subdomain. Select Mesh>Swept Mesh Parameters and set the Number of element layers 
to 24. Click Mesh Selected.

10 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 From the Linear system solver list, select PARDISO. Click the Settings button.

3 In the Linear System Solver Settings dialog box, set Check tolerances to Off. Click OK.

4 Click the Stationary tab. Select the Manual tuning of damping parameters check box, 
then set the Minimum damping factor to 1e-8.

5 Click OK to close the Solver Parameters dialog box.

6 Click the Solver Manager button on the Main toolbar.

7 On the Solve For page, select General Heat Transfer (htgh) only in the Solve for 

variables list.

8 Click the Solve button.

It is important to obtain a good initial guess for the velocity field. To do this, 
temporarily set the properties of the fluid-dynamics part to those for incompressible 
Navier-Stokes flow:

9 Choose first Multiphysics>Non-Newtonian Flow (chns) and then Physics>Properties. 
Set both the Weakly compressible flow and Non-Newtonian Flow options to Off, then 
click OK.

10 Return to the Solver Manager. On the Solve For page, select Incompressible 

Navier-Stokes (chns) in the Solve for variables list.

11 On the Initial Value page, select as the Initial value the Current solution.

12 Click the Solve button.

13 On the Solve For page, select General Heat Transfer (htgh) in the Solve for variables list.

14 Click the Solve button.

15 Now reset the fluid-dynamics properties to those for Non-Newtonian flow. Choose 
Physics>Properties. Set both the Weakly compressible flow and Non-Newtonian Flow 
options to On, then click OK.

16 Return to the Solver Manager and on the Solve For page, select Non-Newtonian Flow 

(chns) and General Heat Transfer (htgh) from the Solve for variables list.
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17 Click the Solve button.

Now turn to the structural mechanics analysis.

18 From the Solve for variables list, select Solid, Stress-Strain (smsld) only.

19 Click OK to close the Solver Manager.

20 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate the plot shown in Figure 3-38 on page 268, follow these steps:

1 Click the Plot Parameters button on the Main toolbar to open the Plot Parameters 
dialog box.

2 In the Plot type area on the General page, clear the Slice check box and select the 
Subdomain check box.

3 On the Subdomain page, select Solid, Stress-Strain (smsld)>von Mises stress from the 
Predefined quantities list.

4 Click the Range button to change the plot range.

5 In the Color Range dialog box, clear the Auto check box and enter 0 in the Min edit 
field and 1e9 in the Max edit field. Click OK.

6 Click Apply to show the plot.

7 Rotate the geometry to find the interesting stress concentrations on the inside.

With the following steps you can reproduce the temperature plot in Figure 3-36:

1 On the General page, clear the Subdomain check box and select the Slice check box.

2 Click the Slice tab. From the Predefined quantities list, select General Heat Transfer 

(htgh)>Temperature.

3 From the Unit list, select degC.

4 Click the Vector with coordinates buttons for the x levels and y levels. For both 
directions, type -0.01475+0.0015 in the associated edit field.

5 From the Options menu, select Suppress Subdomains.

6 From the Subdomain selection list, select Subdomains 1 and 2, then click OK.

7 Click Apply to plot the results.

8 Rotate the geometry to view the temperature distribution.

Finally, to visualize the velocity field, as in Figure 3-37, do as follows:

1 In the Plot Parameters dialog box, click the Slice tab.
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2 From the Predefined quantities list, select Non-Newtonian Flow (chns)>Velocity field.

3 Click the x levels and y levels option buttons, then type 0 in the corresponding 
Number of levels edit fields.

4 Click the Vector with coordinates button for the z levels. In the associated edit field, 
type 0.0151.

5 On the Streamline page, select the Streamline plot check box.

6 From the Predefined quantities list, select Non-Newtonian Flow (chns)>Velocity field.

7 From the Streamline plot type list, select Uniform density. Set the Separating distance 

to 0.035.

8 Click the Line Color tab. Click first the Use expression button and then the Color 

Expression button. In the Streamline Color Expression dialog box, select 
Non-Newtonian Flow (chns)>Velocity field from the Predefined quantities list. Because 
(as it turns out) the plot range effectively coincides with that for the slice plot, you 
can turn off the color scale for the streamlines. Thus, clear the Color scale check box, 
then click OK to close the Streamline Color Expression dialog box.

9 Set the Line type to Tube, then click the Tube Radius button.

10 In the Tube Radius Parameters dialog box, clear the Auto check box. Set the Radius 

scale factor to 0.2, then click OK.

11 Click OK to close the Plot Parameters dialog box and generate the plot.

12 Rotate the geometry and zoom in around the extruding part.
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M e d i c a l  T e c h n o l o g y  M o d e l s
This chapter includes two models that describe heat transfer in medical 
applications using the bioheat equation.
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M i c r owa v e  C an c e r  T h e r a p y

Introduction

Electromagnetic heating appears in a wide range of engineering problems and is ideally 
suited for modeling in COMSOL Multiphysics because of its multiphysics capabilities. 
This example comes from the area of hyperthermic oncology and it models the 
electromagnetic field coupled to the bioheat equation. The modeling issues and 
techniques are generally applicable to any problem involving electromagnetic heating.

In hyperthermic oncology, cancer is treated by applying localized heating to the tumor 
tissue, often in combination with chemotherapy or radiotherapy. Some of the 
challenges associated with the selective heating of deep-seated tumors without 
damaging surrounding tissue are:

• Control of heating power and spatial distribution

• Design and placement of temperature sensors

Among possible heating techniques, RF and microwave heating have attracted much 
attention from clinical researchers. Microwave coagulation therapy is one such 
technique where a thin microwave antenna is inserted into the tumor. The microwaves 
heat up the tumor, producing a coagulated region where the cancer cells are killed.

This model computes the temperature field, the radiation field, and the specific 
absorption rate (SAR)—defined as the ratio of absorbed heat power and tissue 
density—in liver tissue when using a thin coaxial slot antenna for microwave 
coagulation therapy. It closely follows the analysis found in Ref. 1. It computes the 
temperature distribution in the tissue using the bioheat equation.

Model Definition

Figure 4-1 shows the antenna geometry. It consists of a thin coaxial cable with a 
ring-shaped slot measuring 1 mm cut on the outer conductor 5 mm from the 
short-circuited tip. For hygienic purposes, the antenna is enclosed in a sleeve (catheter) 
made of PTFE (polytetrafluoroethylene). The following tables give the relevant 
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geometrical dimensions and material data. The antenna operates at 2.45 GHz, a 
frequency widely used in microwave coagulation therapy.

Figure 4-1: Antenna geometry for microwave coagulation therapy. A coaxial cable with 
a ring-shaped slot cut on the outer conductor is short-circuited at the tip. A plastic catheter 
surrounds the antenna.

TABLE 4-1:  DIMENSIONS OF THE COAXIAL SLOT ANTENNA.

PROPERTY VALUE

Diameter of the central conductor 0.29 mm

Inner diameter of the outer conductor 0.94 mm

Outer diameter of the outer conductor 1.19 mm

Diameter of catheter 1.79 mm

TABLE 4-2:  MATERIAL PROPERTIES.

PROPERTY INNER DIELECTRIC OF 
COAXIAL CABLE

CATHETER LIVER TISSUE

Relative permittivity 2.03 2.60 43.03

Conductivity 1.69 S/m
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The model takes advantage of the problem’s rotational symmetry, which allows 
modeling in 2D using cylindrical coordinates as indicated in Figure 4-2. When 
modeling in 2D, you can select a fine mesh and achieve excellent accuracy. The model 
uses a frequency-domain problem formulation with the complex-valued azimuthal 
component of the magnetic field as the unknown.

Figure 4-2: The computational domain appears as a rectangle in the rz-plane.

The radial and axial extent of the computational domain is in reality larger than 
indicated in Figure 4-2. This problem does not model the interior of the metallic 
conductors, and it models metallic parts using boundary conditions, setting the 
tangential component of the electric field to zero.

D O M A I N  A N D  B O U N D A R Y  E Q U A T I O N S — E L E C T R O M A G N E T I C S

An electromagnetic wave propagating in a coaxial cable is characterized by transverse 
electromagnetic fields (TEM). Assuming time-harmonic fields with complex 
amplitudes containing the phase information, the appropriate equations are

r
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E er
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where z is the direction of propagation, and r, , and z are cylindrical coordinates 
centered on the axis of the coaxial cable. Pav is the time-averaged power flow in the 
cable, Z is the wave impedance in the dielectric of the cable, while rinner and router are 
the dielectric’s inner and outer radii, respectively. Further, ω denotes the angular 
frequency. The propagation constant, k, relates to the wavelength in the medium, λ, as

.

In the tissue, the electric field also has a finite axial component whereas the magnetic 
field is purely in the azimuthal direction. Thus, you can model the antenna using an 
axisymmetric transverse magnetic (TM) formulation. The wave equation then 
becomes scalar in : 

.

The boundary conditions for the metallic surfaces are

.

The feed point is modeled using a port boundary condition with a power level set to 
10 W. This is essentially a first-order low-reflecting boundary condition with an input 
field : 

where

for an input power of Pav deduced from the time-average power flow.

The antenna radiates into the tissue where a damped wave propagates. Because you can 
discretize only a finite region, you must truncate the geometry some distance from the 
antenna using a similar absorbing boundary condition without excitation. Apply this 
boundary condition to all exterior boundaries. Finally, apply a symmetry boundary 
condition for boundaries at r = 0.
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D O M A I N  A N D  B O U N D A R Y  E Q U A T I O N S — H E A T  TR A N S F E R

The bioheat equation describes the stationary heat transfer problem as

where k is the liver’s thermal conductivity (W/(m·K)), ρb represents the blood density 
(kg/m3), Cb is the blood’s specific heat capacity (J/(kg·K)), and ωb denotes the blood 
perfusion rate (1/s). Further, Qmet is the heat source from metabolism, and Qext is an 
external heat source, both measured in W/m3.

This model neglects the heat source from metabolism. The external heat source is 
equal to the resistive heat generated by the electromagnetic field:

.

The model assumes that the blood perfusion rate is ωb = 0.0036 s−1, and that the 
blood enters the liver at the body temperature Tb = 37 °C and is heated to a 
temperature, T. The blood’s specific heat capacity is Cb = 3639 J/(kg·K).

For a more realistic model, you might consider letting ωb be a function of the 
temperature. At least for external body parts such as hands and feet, it is evident that 
a temperature increase results in an increased blood flow.

This example models the heat-transfer problem only in the liver domain. Where this 
domain is truncated, it uses insulation, that is

.

Results and Discussion

Figure 4-3 shows the resulting steady-state temperature distribution in the liver tissue 
for an input microwave power of 10 W. The temperature is highest near the antenna. 
It then decreases with distance from the antenna and reaches 37 °C closer to the outer 
boundaries of the computational domain. The perfusion of relatively cold blood seems 
to limit the extent of the area that is heated.

∇ k T∇–( )⋅ ρbCbωb Tb T–( ) Qmet Qext+ +=

Qext
1
2
---Re σ jωε–( )E E*⋅[ ]=

n T∇⋅ 0=
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Figure 4-3: Temperature in the liver tissue.

Figure 4-4 shows the distribution of the microwave heat source. Clearly the 
temperature field follows the heat-source distribution quite well. That is, near the 
antenna the heat source is strong, which leads to high temperatures, while far from the 
antenna, the heat source is weaker and the blood manages to keep the tissue at normal 
body temperature.
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Figure 4-4: The computed microwave heat-source density takes on its highest values near 
the tip and the slot. The scale is cut off at 1 W/cm3.
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Figure 4-5 plots the specific absorption rate (SAR) along a line parallel to the antenna 
and at a distance of 2.5 mm from the antenna axis normalized by its maximal value 
along the line. The results are in good agreement with those found in Ref. 1.

Figure 4-5: Normalized SAR value along a line parallel to the antenna and at a distance 
2.5 mm from the antenna axis. The tip of the antenna is located at 70 mm, and the slot is 
at 65 mm.

Reference

1. K. Saito, T. Taniguchi, H. Yoshimura, and K. Ito, “Estimation of SAR Distribution 
of a Tip-Split Array Applicator for Microwave Coagulation Therapy Using the Finite 
Element Method,” IEICE Trans. Electronics, vol. E84-C, 7, pp. 948–954, July 2001.

Modeling in COMSOL Multiphysics

The COMSOL Multiphysics implementation is straightforward. Drawing the 
geometry is best done creating rectangles and setting their dimensions directly from 
the Draw menu. The scale differences together with the strong radial dependence of 
the electromagnetic fields make some manual adjustment of the mesh parameters 
necessary. In addition, 4th-order elements for the electromagnetic problem and a 
dense mesh in the dielectric result in well-resolved fields. The model computes the 
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solutions for both the electromagnetic problem and the heat transfer problem in 
parallel. This takes into account the coupling of the resistive heating from the 
electromagnetic solution into the bioheat equation. In principle, however, you could 
solve the two problems in sequence because there is only a 1-way coupling from the 
electromagnetic problem to the bioheat problem.

Model Library path: Heat_Transfer_Module/Medical_Technology/
microwave_cancer_therapy

Note: This model requires the RF Module and the Heat Transfer Module.

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator. In the Space dimension list select Axial symmetry 2D.

2 In the list of application modes select  
Heat Transfer Module>Bioheat Equation>Steady-state analysis.

3 Click the Multiphysics button, then click the Add button.

4 In the list of application modes select 
RF Module>Electromagnetic Waves>TM Waves>Harmonic propagation.

5 In the Element list select Lagrange - Quartic.

6 Click Add, then click OK.

O P T I O N S  A N D  S E T T I N G S

From the Options menu select Constants. Enter the following names and expressions; 
when done, click OK.

NAME EXPRESSION EXPRESSION

k_liver 0.56[W/(kg*K)] Thermal conductivity, liver

rho_blood 1000[kg/m^3] Density, blood

C_blood 3639[J/(kg*K)] Specific heat, blood

omega_blood 3.6e-3[1/s] Blood perfusion rate
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G E O M E T R Y  M O D E L I N G

1 Create two rectangles. Select the menu item Draw>Specify Objects>Rectangle, then 
enter the following settings; when done with each one, click OK.

2 Click the Zoom Extents button on the Main toolbar.

3 From the Draw menu open the Create Composite Object dialog box. Clear the Keep 

interior boundaries check box. In the Object selection box select both rectangles, then 
click the Union button. Click OK.

4 Following the procedure in Step 1, specify two more rectangles with the following 
properties:

5 Add a line to the geometry. Select the menu item Draw>Specify Objects>Line. In the 
r edit field enter the coordinates 0 8.95e-4 8.95e-4, and in the z edit field enter 
the coordinates 9.5e-3 0.01 0.08. Click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings—Bioheat Equation
1 From the Multiphysics menu select 1 Bioheat Equation (htbh).

2 From the Physics menu select Subdomain Settings.

3 Select Subdomains 2, 3, and 4, then clear the Active in this domain check box.

T_blood 37[degC] Blood temperature

P_in 10[W] Input microwave power

nu 2.45[GHz] Microwave frequency

eps_diel 2.03 Relative permittivity, dielectric

eps_cat 2.6 Relative permittivity, catheter

eps_liver 43.03 Relative permittivity, liver

sig_liver 1.69[S/m] Electric conductivity

WIDTH HEIGHT BASE CORNER R BASE CORNER Z

0.595e-3 0.01 0 0

29.405e-3 0.08 0.595e-3 0

WIDTH HEIGHT BASE CORNER R BASE CORNER Z

0.125e-3 1e-3 0.47e-3 0.0155

0.335e-3 0.0699 0.135e-3 0.0101

NAME EXPRESSION EXPRESSION
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4 Select Subdomain 1, then enter the following settings; when done, click OK.

Boundary Conditions—Bioheat Equation
1 From the Physics menu select Boundary Settings.

2 Select all the exterior boundaries (get them by pressing Ctrl+A, and note that the 
following step ignores the interior boundaries). 

3 In the Boundary condition list select Thermal insulation, then click OK.

Note: Because the model neglects metabolic heat generation you set Qmet to 0. The 
variable Qav_rfwh is a subdomain expression for the resistive heating provided by the 
TM Waves application mode.

Scalar Variables—TM Waves
1 From the Multiphysics menu select 2 TM Waves (rfwh).

2 From the Physics menu select Scalar Variables to open the Application Scalar Variables 
dialog box.

3 Find the variable nu_rfwh and set its value to nu, then click OK.

Boundary Conditions—TM Waves
1 From the Physics menu select Boundary Settings. 

PROPERTY VALUE

 k (isotropic) k_liver

 ρb rho_blood

 Cb C_blood

 ωb omega_blood

 Tb T_blood

 Qmet 0

 Qext Qav_rfwh
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2 Specify boundary settings according to the following table (to enter the port 
settings for Boundary 8 go to the Port page); when finished, click OK.

For the (exterior) boundaries not mentioned in the table, the default condition 
(perfect electric conductor) applies.

Subdomain Settings—TM Waves
1 From the Physics menu select Subdomain Settings.

2 Enter the following settings; when finished, click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu open the Free Mesh Parameters dialog box. 

2 Go to the Global page, click the Custom mesh size button and in the Maximum 

element size edit field type 3e-3.

3 Go to the Subdomain page and select Subdomain 3. In the Maximum element size edit 
field type 1.5e-4.

4 Click Remesh, then click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows the temperature field. To change the unit to degrees Celsius, 
reproducing the plot in Figure 4-3, do as follows:

SETTINGS BOUNDARIES 1, 3 BOUNDARIES 2, 14, 18, 20, 21 BOUNDARY 8

Boundary condition Axial symmetry Scattering boundary 
condition

Port

Wave excitation at 
this port

selected

Pin P_in

Mode specification Coaxial

Wave type Spherical wave

SETTINGS SUBDOMAIN 1 SUBDOMAIN 2 SUBDOMAIN 3 SUBDOMAIN 4

 εr (isotropic) eps_liver eps_cat eps_diel 1

 σ (isotropic) sig_liver 0 0 0

 µr 1 1 1 1
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1 Click the Plot Parameters button on the Main toolbar.

2 Click the Surface tab. From the Unit list select oC, then click Apply.

The following steps describe how to visualize the resistive heating of the tissue:

1 In the Predefined quantities list select TM Waves (rfwh)>Resistive heating, time 

average. In the Unit edit field type W/cm^3, then click Apply.

Heating decreases rapidly in the liver tissue, resulting in an almost uniformly blue 
plot. To get a better feeling for the heating at a distance from the antenna, do as 
follows:

2 In the Expression edit field type min(Qav_rfwh,1[W/cm^3]), then click OK.

In the resulting plot, which reproduces that in Figure 4-4, the region around the 
antenna in which the time-averaged resistive heating exceeds 1 W/cm3 has a 
uniform, deep red color. Outside this region, you can read off the heating 
distribution from the color scale on the right.

To compute the total heating power deposited in the liver, follow these steps:

1 From the Postprocessing menu open the Subdomain Integration dialog box.

2 Select Subdomain 1. From the Predefined quantities list select 
TM Waves (rfwh)>Resistive heating, time average.

3 Select the Compute volume integral (for axisymmetric modes) check box. Click OK.

The result appears in the message log at the bottom of the user interface. The value 
of approximately 9.37 W indicates that the tissue absorbs most of the 10 W input 
power at stationary conditions.

These steps reproduce the plot in Figure 4-5, displaying the normalized SAR value:

1 From the Postprocessing menu open the Cross-Section Plot Parameters dialog box.

2 On the Line/Extrusion page, type Qav_rfwh/3.01[W/cm^3] in the Expression edit 
field. In both the r0 and r1 edit fields type 2.5e-3; in the z0 edit field type 0.08; 
and in the z1 edit field type 0.

3 Click the General tab, then click the Title/Axis button. In the Title/Axis Settings dialog 
box, select the option button next to the Title edit field, then enter the title 
Off-axis SAR values (distance = 2.5 mm).

4 In a similar way, enter the first axis label Insertion depth [m] and the second axis 
label SAR (normalized), then click OK to close the Title/Axis Settings dialog box.

5 Click OK to generate the plot.
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Introduction

One method for removing cancerous tumors from healthy tissue is to heat the 
malignant tissue to a critical temperature that kills the cancer cells. This example 
accomplishes the localized heating by inserting a four-armed electric probe through 
which an electric current runs. Equations for the electric field for this case appear in 
the Conductive Media DC application mode, and this example couples them to the 
bioheat equation, which models the temperature field in the tissue. The heat source 
resulting from the electric field is also known as resistive heating or Joule heating. The 
original model comes from S. Tungjitkusolmun and others (Ref. 1), but we have made 
some simplifications. For instance, while the original uses RF heating (with AC 
currents), the COMSOL Multiphysics model approximates the energy with DC 
currents.

This medical procedure removes the tumorous tissue by heating it above 45 °C to 
50 °C. Doing so requires a local heat source, which physicians create by inserting a 
small electric probe. The probe is made of a trocar (the main rod) and four electrode 
arms as shown in Figure 4-6. The trocar is electrically insulated except near the 
electrode arms.

An electric current through the probe creates an electric field in the tissue. The field is 
strongest in the immediate vicinity of the probe and generates resistive heating, which 
dominates around the probe’s electrode arms because of the strong electric field.

Figure 4-6: Cylindrical modeling domain with the four-armed electric probe in the 
middle, which is located next to a large blood vessel.

electrodes

trocar tip

blood vessel

trocar base (coated)

liver tissue
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Model Definition

This model uses the Bioheat Equation and the Conductive Media DC application 
modes to implement a transient analysis.

The standard temperature unit in COMSOL Multiphysics is kelvin (K). This model 
uses the Celsius temperature scale, which is more convenient for models involving the 
Bioheat Equation.

The model approximates the body tissue with a large cylinder and assumes that its 
boundary temperature remains at 37 °C during the entire procedure. The tumor is 
located near the center of the cylinder and has the same thermal properties as the 
surrounding tissue. The model locates the probe along the cylinder’s center line such 
that its electrodes span the region where the tumor is located. The geometry also 
includes a large blood vessel.

The bioheat equation governs heat transfer in the tissue

where δts is a time-scaling coefficient; ρ is the tissue density (kg/m3); C is the tissue’s 
specific heat (J/(kg·K)); and k is its thermal conductivity (W/(m·K)). On the right 
side of the equality, ρb gives the blood’s density (kg/m3); Cb is the blood’s specific 
heat (J/(kg·K)); ωb is its perfusion rate (1/s); Tb is the arterial blood temperature 
(°C); while Qmet and Qext are the heat sources from metabolism and spatial heating, 
respectively (W/m3).

In this model, the bioheat equation also models heat transfer in various parts of the 
probe with the appropriate values for the specific heat, C (J/(kg·K)), and thermal 
conductivity, k (W/(m·K)). For these parts, all terms on the right-hand side are zero.

The model next sets the boundary conditions at the outer boundaries of the cylinder 
and at the walls of the blood vessel to a temperature of 37 °C. Assume heat flux 
continuity on all other boundaries.

The initial temperature equals 37 °C in all domains.

The governing equation for the Conductive Media DC application mode is

where V is the potential (V), σ the electric conductivity (S/m), Je an externally 
generated current density (A/m2), Qj the current source (A/m3).

δtsρ C
t∂

∂T ∇ k T∇–( )⋅+ ρb Cb ωb Tb T–( ) Qmet Qext+ +=

∇– σ V∇ Je
–( )⋅ Qj=
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In this model both Je and Qj are zero. The governing equation therefore simplifies 
into:

.

The boundary conditions at the cylinder’s outer boundaries is ground (0 V potential). 
At the electrode boundaries the potential equals 22 V. Assume continuity for all other 
boundaries.

The boundary conditions for the Conductive Media DC application mode are:

The boundary conditions for the bioheat equation are:

The model solves the above equations with the given boundary conditions to obtain 
the temperature field as a function time.

Results and Discussion

The model shows how the temperature increases with time in the tissue around the 
electrode.

∇– σ V∇( )⋅ 0=

V 0= on the cylinder wall
V V0= on the electrode surfaces

n J1 J2–( )⋅ 0= on all other boundaries

T Tb= on the cylinder wall and blood-vessel wall

n k1 T1∇ k2 T2∇–( )⋅ 0= on all interior boundaries
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The slice plot in Figure 4-7 illustrates the temperature field 60 seconds after starting 
the procedure.

Figure 4-7: Temperature field at time = 60 seconds.

Figure 4-8 shows the temperature at the tip of one of the electrode arms. The 
temperature rises quickly until it reaches a steady-state temperature of about 90 °C.

Figure 4-8: Temperature versus time at the tip of one of the electrode arms.
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It is also interesting to visualize the region where cancer cells die, that is, where the 
temperature has reached at least 50 °C. You can visualize this area with an isosurface 
for that temperature; Figure 4-9 shows one after 8 minutes.

Figure 4-9: Visualization of the region that has reached 50 °C after 8 minutes.

Reference

1. S. Tungjitkusolmun, S. Tyler Staelin, D. Haemmerich, J.Z. Tsai, H. Cao, J.G. 
Webster, F.T. Lee, Jr., D.M. Mahvi, and V.R. Vorperian, “Three-Dimensional Finite 
Element Analyses for Radio-Frequency Hepatic Tumor Ablation,” IEEE Transactions 
on Biomedical Engineering, vol. 49, no. 1, 2002.

Model Library path: Heat_Transfer_Module/Medical_Technology/
tumor_ablation

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator. On the New page, select 3D in the Space dimension list.

2 Go to the Heat Transfer Module menu and select Bioheat Equation>Transient analysis.
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3 Click the Multiphysics button and add the application mode to the model by clicking 
the Add button.

4 Similarly add the Conductive Media DC application mode, from the 
COMSOL Multiphysics>Electromagnetics menu.

5 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, choose Constants.

2 Define the following constants (the descriptions are optional):

3 Click OK.

NAME EXPRESSION DESCRIPTION

rho_e 6450[kg/m^3] Density, electrodes

rho_t 21500[kg/m^3] Density, trocar tip

rho_l 1060[kg/m^3] Density, liver tissue

rho_b 1000[kg/m^3] Density, blood

rho_c 70[kg/m^3] Density, trocar base

c_e 840[J/(kg*K)] Heat capacity, electrodes

c_t 132[J/(kg*K)] Heat capacity, trocar tip

c_l 3600[J/(kg*K)] Heat capacity, liver tissue

c_b 4180[J/(kg*K)] Heat capacity, blood

c_c 1045[J/(kg*K)] Heat capacity, trocar base

k_e 18[W/(m*K)] Thermal conductivity, electrodes

k_t 71[W/(m*K)] Thermal conductivity, trocar tip

k_l 0.512[W/(m*K)] Thermal conductivity, liver tissue

k_b 0.543[W/(m*K)] Thermal conductivity, blood

k_c 0.026[W/(m*K)] Thermal conductivity, trocar base

sigma_e 1e8[S/m] Electric conductivity, electrodes

sigma_t 4e6[S/m] Electric conductivity, trocar tip

sigma_l 0.333[S/m] Electric conductivity, liver tissue

sigma_b 0.667[S/m] Electric conductivity, blood

sigma_c 1e-5[S/m] Electric conductivity, trocar base

omega_b 6.4e-3[1/s] Blood perfusion rate

T_b 37[degC] Arterial blood temperature

T0 37[degC] Initial and boundary temperature

V0 22[V] Electric voltage
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G E O M E T R Y  M O D E L I N G

1 Go to the Draw menu and select Work-Plane Settings.

2 Create an x-y plane at the z coordinate 0.06.

3 Click OK.

4 Press the Shift key and click the Ellipse/Circle (Centered) button.

5 In the dialog box that appears, enter the following circle properties:

6 Click OK.

7 Click the Zoom Extents button on the Main toolbar.

8 Repeat Steps 4–6 to create five additional circles, for smaller ones and a large one. 
The properties of each circle appear in the following five tables:

OBJECT DIMENSIONS EXPRESSION

Radius 9.144e-4

Base Center

x 0

y 0

OBJECT DIMENSIONS EXPRESSION

Radius 2.667e-4

Base Center

x -5e-4

y 0

OBJECT DIMENSIONS EXPRESSION

Radius 2.667e-4

Base Center

x 5e-4

y 0

OBJECT DIMENSIONS EXPRESSION

Radius 2.667e-4

Base Center

x 0

y -5e-4
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9 Click the Zoom Extents button on the Main toolbar.

This completes the geometry needed in the 2D work plane, and the result appears in 
Figure 4-10.

Figure 4-10: 2D working plane geometry.

The following steps describe how to create the 3D geometry by extruding and 
revolving the 2D geometry:

1 To create the conducting part of the trocar, go to the Draw menu and select Extrude.

2 In the dialog box that appears, select C1 in the Objects to extrude list and type 10e-3 
in the Distance edit field.

3 Click OK.

OBJECT DIMENSIONS EXPRESSION

Radius 2.667e-4

Base Center

x 0

y 5e-4

OBJECT DIMENSIONS EXPRESSION

Radius 5e-3

Base Center

x 2.6e-2

y 0
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4 To create the insulated part of the trocar, return to the Geom2 work plane, then go 
to the Draw menu and select Extrude.

5 Select C1 in the Objects to extrude list and type 50e-3 in the Distance edit field.

6 Click OK.

7 Select the EXT2 geometry object.

8 Click the Move button on the Draw toolbar.

9 Enter the following displacement values; when finished, click OK.

To create the electrode arms, proceed as follows:

10 Return to the Geom2 work plane.

11 From the Draw menu select Revolve.

12 From the Objects to revolve list select C2.

13 Enter the following values in the dialog box; when finished, click OK.

PROPERTY VALUE

x 0

y 0

z 10e-3

PROPERTY VALUE

α1 0

α2 180

x (point on axis) -8e-3

y (point on axis) 0

x (second point) -8e-3

y (second point) 1
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14 Revolve the circles C3, C4, and C5 in the same manner using the following values:

- Revolve parameters for the circle C3:

- Revolve parameters for the circle C4:

- Revolve parameters for the circle C5:

15 To create the blood vessel, return to the Geom2 work plane and select C6.

16 From the Draw menu, select Extrude.

17 In the Distance field, type 120e-3.

18 Click OK.

19 Select the EXT3 geometry object, go to the Draw menu, and select Move under 
Modify.

PROPERTY VALUE

α1 0

α2 -180

x (point on axis) 8e-3

y (point on axis) 0

x (second point) 8e-3

y (second point) 1

PROPERTY VALUE

α1 -180

α2 0

x (point on axis) 0

y (point on axis) -8e-3

x (second point) 1

y (second point) -8e-3

PROPERTY VALUE

α1 180

α2 0

x (point on axis) 0

y (point on axis) 8e-3

x (second point) 1

y (second point) 8e-3
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20 Enter the following displacement values; when finished, click OK.

21 To create the large cylinder, press the Shift key and then click the Cylinder button.

22 Enter the following cylinder properties; when finished, click OK.

23 Click the Zoom Extents button on the Main toolbar.

This concludes the drawing stage. To get a better view of the geometry you have 
created, do as follows:

1 To hide the coordinate axes, double-click the AXIS button on the status bar at the 
bottom of the user interface.

2 From the Options menu, select Visualization/Selection Settings.

3 Clear the Geometry labels check box, then click OK.

4 Choose Options>Suppress>Suppress Boundaries.

5 Select Boundaries 34, 47, 58, 59, 62, and 63, then click OK.

6 Click the Perspective Projection button on the Camera toolbar.

7 Finally, after rotating the geometry in the drawing area upside down you should 
have a view similar to that in Figure 4-6 on page 291.

P H Y S I C S  S E T T I N G S

Subdomain Settings—Bioheat Equation
1 From the Multiphysics menu, select 1 Bioheat Equation (htbh).

2 From the Physics menu, select Subdomain Settings.

3 Select Subdomain 8 and clear the Active in this domain check box.

PROPERTY VALUE

x 0

y 0

z -60e-3

PROPERTY VALUE

Radius 0.05

Height 0.12
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4 Enter the properties for the remaining subdomains as follows:

5 On the Init page, select all active subdomains and in the T(t0) edit field type T0.

6 To reduce the size of the computation problem, select a lower element order by first 
clicking the Element tab and then selecting Lagrange - Linear from the Predefined 

elements list for all active subdomains.

7 Click OK.

Boundary Conditions—Bioheat Equation
8 From the Physics menu, select Boundary Settings.

9 Enter boundary coefficients as follows:

10 Click OK.

Subdomain Settings—Conductive Media DC
1 From the Multiphysics menu, select 2 Conductive Media DC (dc).

2 From the Physics menu, select Subdomain Settings.

3 Enter the subdomain properties as in the following table:

SETTINGS SUBDOMAIN 1 SUBDOMAINS 2, 5-7 SUBDOMAIN 3 SUBDOMAIN 4

k k_l k_e k_t k_c

 ρ rho_l rho_e rho_t rho_c

C c_l c_e c_t c_c

 ρb rho_b

Cb c_b

 ωb omega_b

Tb T_b

Qmet 0

Qext Q_dc

SETTINGS BOUNDARIES 1-4, 34 47, 
58, 59, 62, 63

BOUNDARY 20

Boundary condition Temperature Thermal insulation

T0 T_b

SETTINGS SUBDOMAIN 1 SUBDOMAINS 2, 5–7 SUBDOMAIN 3 SUBDOMAIN 4 SUBDOMAIN 8

 σ sigma_l sigma_e sigma_t sigma_c sigma_b
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4 Reduce the element order also for this application mode: On the Element page, 
select Lagrange - Linear from the Predefined elements list for all subdomains.

5 Click OK.

Boundary Conditions—Conductive Media DC
1 From the Physics menu, open the Boundary Settings dialog box.

2 Select the Interior boundaries check box and enter boundary coefficients as in the 
table below. You only need to set the boundary condition on the boundaries that 
use Electric potential. The remaining boundaries already have the correct conditions 
set by default, that is, Ground for outer boundaries and Continuity for interior 
boundaries.

3 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters.

2 From the Predefined mesh sizes list, select Fine.

3 Click the Custom mesh size button, then modify the Element growth rate from the 
default value to 1.7.

4 Click Remesh, then click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 From the Solver list, select Time dependent.

3 On the General page, type 0 600 in the Times field.

4 From the Linear system solver list, select Direct (PARDISO).

5 On the Time Stepping page, select Time steps from solver from the Times to store in 

output list.

6 Select the Manual tuning of step size check box. Type 0.01 in the Initial time step 
edit field and 50 in the Maximum time step edit field.

7 Click OK.

SETTINGS BOUNDARIES 5-16, 21-33, 35-39, 
41-43, 45, 46, 48-57

BOUNDARIES 1-4, 
20, 34, 47, 60, 61

BOUNDARIES 17-19, 40, 
44, 58, 59, 62, 63

Boundary 
condition

Electric potential Ground Continuity

V V0
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8 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot is a slice plot of the temperature at time = 600 seconds. In order to 
generate Figure 4-7, follow these steps:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, select Interpolated from the Solution at time list.

3 In the Time edit field, type 60.

4 Click the Slice tab and locate the Slice data area. From the Predefined quantities list 
select Temperature and from the Unit list select oC.

5 In the Slice positioning area set the number of x levels, y levels, and z levels to 1, 1, 
and 0, respectively.

6 Click Apply.

The following steps describe how to generate the plot in Figure 4-9, which shows the 
isosurface for the temperature 50 °C after 8 minutes:

1 Return to the General page, then clear the Slice check box and select the Isosurface 
check box.

2 In the Time edit field type 480.

3 Click the Isosurface tab. On the Isosurface Data page, select Temperature from the list 
of Predefined quantities and select oC from the Unit list.

4 In the Isosurface levels area, type 50 in the edit field for Vector with isolevels.

5 Click OK.

6 To finish the plot, click the Scene Light button on the Plot toolbar, then click the 
Increase Transparency button 5–6 times.

Clicking the Decrease Transparency button repeatedly returns the transparency 
settings to the original state.

To create Figure 4-8, which shows temperature versus time, do the following steps:

1 From the Postprocessing menu, select Domain Plot Parameters.

2 On the General page, click the Point plot option button under Plot type.

3 On the Point page, select Point 43. From the Unit list select oC, then click OK.

The postprocessing image that is shown when you open the tumor ablation model 
from the model library is created with the following steps:
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.04,10)

,10)
1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, clear the Isosurface check box and select the Streamline and Slice 
check boxes.

3 On the Streamline page, select Heat flux from the Predefined quantities list.

4 On the Start Points page, select Specify start point coordinates, then specify the 
following settings in the x, y, and z edit fields:

5 On the Line Color page, click the Use expression option button, then click the Color 

Expression button. In the dialog box that appears, clear the Color scale check box 
(leave the default settings in the Streamline color data area). Click OK.

6 Set the Line type to Tube, then click the Tube Radius button. In the dialog box that 
appears, clear the Auto check box for the Radius scale factor, then type 0.1 in the edit 
field. Click OK.

7 Click the Slice tab. In the Slice positioning area set the number of x levels, y levels, 
and z levels to 1, 0, and 0, respectively.

8 Click OK.

COORD. VALUE

x linspace(0.02,0.02,30)

y linspace(-0.04,0.04,10) linspace(-0.04,0.04,10) linspace(-0.04,0

z linspace(0.05,0.05,10) linspace(0.08,0.08,10) linspace(0.02,0.02
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I N D E X

A AC/DC Module 92

application mode

Bioheat equation 286

Conductive Media DC 291

General Heat Transfer 11, 31, 34, 63, 

108, 170

Solid, Stress-Strain 63

TM waves 286

Weakly Compressible Navier-Stokes 

11, 108, 170

axisymmetric radiation 161

B bioheat equation 291, 292

bioheat equation model 278, 291

buoyancy effects 210

C Conductive Media DC application mode 

291

conjugate heat transfer 43, 249

contact resistance

thermal 110

convection

forced 10

forced turbulent 43

natural 10

convection cooling of circuit boards 10

simplified models 31

cup mixing temperature 32

D deflection 91

density

of blood 292

of tissue 292

detachment 91

E enthalpy 236

F forced convection 10

G General Heat Transfer application mode 

11, 31, 34, 63, 108, 170

Grashof number 211

H heat capacity

of tissue 292

heat sink

microchannel 43

heat transfer coefficient 31, 199, 209, 211

heat transfer coefficients

library of 43

I interfacial stresses 91

interfacial tension 92

J Joule heating 91, 291

L latent heat 235

M mass transfer coefficient 200

microchannel heat sink 43

Model Library

models 2

N natural convection 10

Nusselt number 19

P potcore inductor 160

printed circuit board 64

R radiation 135, 161

surface-to-ambient 224, 225

surface-to-surface 144

radiative losses 162

RANS 44

resistive heating 291

Reynolds Averaged Navier-Stokes 250

Reynolds-averaged Navier-Stokes 44

S Solid, Stress-Strain 63

specific absorption rate 278

Structural Mechanics Module 66, 92

surface-to-ambient radiation 224, 225
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surface-to-surface radiation 144, 162

T thermal

contact resistance 110

thermal conductivity

of tissue 292

thermal expansion coefficient 211

thermo-photo-voltaic cell 144

TM waves model 278

turbulent convection 43

turbulent kinematic viscosity 251

turbulent viscosity 44

typographical conventions 6

V velocity profile

parabolic 13

virtual prototyping 91

viscosity

turbulent 44

W Weakly Compressible Navier-Stokes ap-

plication mode 11, 108, 170
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