ACOUSTICS
MODULE

VERSION 3.5

COMSOL
MULTIPHYSICS
CONTENTS

Chapter 1: Introduction

Model Library Guide ........................................... 2
Typographical Conventions ................................. 5

Chapter 2: Tutorial Models

Bessel Panel .................................................. 8
Introduction ................................................... 8
Model Definition ............................................... 8
Results and Discussion ...................................... 10
Modeling in COMSOL Multiphysics ....................... 13
Reference ....................................................... 13
Modeling Using the Graphical User Interface ............ 14

Hollow Cylinder ............................................. 19
Introduction ................................................... 19
Model Definition ............................................... 19
Results ......................................................... 23
Modeling in COMSOL Multiphysics ....................... 23
Modeling Using the Graphical User Interface ............ 24
Point-Source Version ........................................ 29

Optimizing the Shape of a Horn ......................... 34
Introduction ................................................... 34
Model Definition ............................................... 34
Results and Discussion ...................................... 38
Modeling in COMSOL Multiphysics ....................... 39
Reference ....................................................... 40
Modeling Using the Graphical User Interface ............ 41

Jet Pipe ....................................................... 48
Introduction ................................................... 48
<table>
<thead>
<tr>
<th>Chapter 3: Industrial Models</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Piezoelectric Transducer</strong></td>
</tr>
<tr>
<td>Introduction .................. 59</td>
</tr>
<tr>
<td>Model Definition .............. 59</td>
</tr>
<tr>
<td>Results and Discussion ........ 61</td>
</tr>
<tr>
<td>Modeling Using the Graphical User Interface .................. 64</td>
</tr>
<tr>
<td><strong>Transient Gaussian Explosion</strong></td>
</tr>
<tr>
<td>Introduction .................. 69</td>
</tr>
<tr>
<td>Model Definition .............. 69</td>
</tr>
<tr>
<td>Results and Discussion ........ 72</td>
</tr>
<tr>
<td>Modeling in COMSOL Multiphysics .................. 73</td>
</tr>
<tr>
<td>References ...................... 74</td>
</tr>
<tr>
<td>Modeling Using the Graphical User Interface .................. 74</td>
</tr>
<tr>
<td><strong>Ultrasound Scattering Off a Cylinder</strong></td>
</tr>
<tr>
<td>Introduction .................. 78</td>
</tr>
<tr>
<td>Model Definition .............. 78</td>
</tr>
<tr>
<td>Results and Discussion ........ 79</td>
</tr>
<tr>
<td>Reference ....................... 81</td>
</tr>
<tr>
<td>Modeling Using the Graphical User Interface .................. 81</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Chapter 3: Industrial Models</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Absorptive Muffler</strong></td>
</tr>
<tr>
<td>Introduction .................. 88</td>
</tr>
<tr>
<td>Model Definition .............. 88</td>
</tr>
<tr>
<td>Results and Discussion ........ 90</td>
</tr>
<tr>
<td>Modeling in COMSOL Multiphysics .................. 93</td>
</tr>
<tr>
<td>References ...................... 94</td>
</tr>
<tr>
<td>Modeling Using the Graphical User Interface—Rigid Walls ........ 94</td>
</tr>
<tr>
<td>Absorptive Muffler—Absorbing Walls .................. 99</td>
</tr>
</tbody>
</table>
Absorptive Muffler—Propagating Mode Analysis .......................... 100

**Car Interior** .................................................. 104
Introduction .................................................. 104
Model Definition ................................................. 104
Results and Discussion ........................................... 106
Modeling in COMSOL Multiphysics ................................. 108
References ......................................................... 109
Modeling Using the Graphical User Interface ......................... 109

**Flow Duct** .................................................. 115
Introduction .................................................. 115
Model Definition ................................................. 115
Results and Discussion ........................................... 118
Modeling in COMSOL Multiphysics .................................. 124
References ......................................................... 124
Modeling Using the Graphical User Interface ......................... 125
Initial Stage—Geometry, Mesh, and Common Settings .................. 125
Stage I—The Background Flow ..................................... 131
Stage II—The Boundary Source Mode .................................. 133
Stage III—The Acoustic Field ....................................... 135
The Case Without a Background Flow .................................. 140

**Loudspeaker Driver** ........................................... 145
Introduction .................................................. 145
Model Definition ................................................. 145
Results and Discussion ........................................... 148
Modeling in COMSOL Multiphysics .................................. 154
Modeling Using the Graphical User Interface—Force Factor ........... 156
Modeling Using the Graphical User Interface—Blocked Impedance ... 160
Modeling Using the Graphical User Interface—Acoustics ............... 163
Preparing for the Vented Loudspeaker Enclosure Model .................. 170

**Loudspeaker Driver in a Vented Enclosure** ......................... 175
Introduction .................................................. 175
Model Definition ................................................. 175
Results and Discussion ........................................... 179
Modeling in COMSOL Multiphysics .................................. 182


<table>
<thead>
<tr>
<th>Model</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Modeling Using the Graphical User Interface</td>
<td>183</td>
</tr>
<tr>
<td><strong>Muffler with Perforates</strong></td>
<td>193</td>
</tr>
<tr>
<td>Introduction</td>
<td>193</td>
</tr>
<tr>
<td>Model Definition</td>
<td>193</td>
</tr>
<tr>
<td>Results and Discussion.</td>
<td>198</td>
</tr>
<tr>
<td>References</td>
<td>199</td>
</tr>
<tr>
<td>Modeling Using the Graphical User Interface</td>
<td>200</td>
</tr>
<tr>
<td>Postprocessing with COMSOL Script/MATLAB</td>
<td>208</td>
</tr>
<tr>
<td><strong>SAW Gas Sensor</strong></td>
<td>210</td>
</tr>
<tr>
<td>Introduction</td>
<td>210</td>
</tr>
<tr>
<td>Model Definition</td>
<td>210</td>
</tr>
<tr>
<td>Results</td>
<td>214</td>
</tr>
<tr>
<td>References</td>
<td>216</td>
</tr>
<tr>
<td>Modeling Using the Graphical User Interface</td>
<td>216</td>
</tr>
<tr>
<td>Sensor without Gas Exposure</td>
<td>221</td>
</tr>
<tr>
<td>Sensor with Gas Exposure</td>
<td>223</td>
</tr>
<tr>
<td><strong>Chapter 4: Benchmark Models</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Vibrations of a Disk Backed by an Air-Filled Cylinder</strong></td>
<td>226</td>
</tr>
<tr>
<td>Introduction</td>
<td>226</td>
</tr>
<tr>
<td>Model Definition</td>
<td>226</td>
</tr>
<tr>
<td>Results and Discussion.</td>
<td>227</td>
</tr>
<tr>
<td>Reference</td>
<td>228</td>
</tr>
<tr>
<td>Modeling Using the Graphical User Interface</td>
<td>228</td>
</tr>
<tr>
<td>Adding the 3D Pressure Acoustics Application Mode</td>
<td>231</td>
</tr>
<tr>
<td>Coupling the Equations</td>
<td>233</td>
</tr>
<tr>
<td><strong>Open Pipe</strong></td>
<td>238</td>
</tr>
<tr>
<td>Introduction</td>
<td>238</td>
</tr>
<tr>
<td>Model Definition</td>
<td>238</td>
</tr>
<tr>
<td>Results and Discussion.</td>
<td>241</td>
</tr>
<tr>
<td>Modeling in COMSOL Multiphysics</td>
<td>244</td>
</tr>
<tr>
<td>Reference</td>
<td>244</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>----------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Modeling Using the Graphical User Interface</td>
<td>244</td>
</tr>
<tr>
<td>Lumped Impedance Version</td>
<td>249</td>
</tr>
<tr>
<td>Scattering from a Plate with Ribs</td>
<td>252</td>
</tr>
<tr>
<td>Introduction</td>
<td>252</td>
</tr>
<tr>
<td>Model Definition</td>
<td>253</td>
</tr>
<tr>
<td>Results and Discussion</td>
<td>254</td>
</tr>
<tr>
<td>Modeling in COMSOL Multiphysics</td>
<td>256</td>
</tr>
<tr>
<td>Reference</td>
<td>257</td>
</tr>
<tr>
<td>Modeling Using the Graphical User Interface</td>
<td>257</td>
</tr>
<tr>
<td>INDEX</td>
<td>265</td>
</tr>
</tbody>
</table>
Introduction

The Acoustics Module Model Library consists of a set of models from various areas of acoustics engineering simulation. Its purpose is to assist you in learning, by example, how to model sophisticated acoustics systems and effects. Through the library models, you can tap the expertise of the top researchers in the field, examining how they approach some of the most difficult modeling problems you might encounter. You can thus get a feel for the power that COMSOL Multiphysics offers as a modeling tool. In addition to serving as references, the models can give you a head start if you are developing a model of a similar nature.

We have divided the models into three groups:

• Benchmark models—this category consists of models for which you can compare the COMSOL Multiphysics solution with either an analytical solution or some reference numerical solution
• Industrial models—these are models in applied fields of acoustics with direct industrial relevance
• Tutorial models—the models in this group are deemed particularly suitable for learning how to model with the Acoustics Module

The models also illustrate the use of the various acoustics-specific application modes from which we built them. These specialized modes are not available in the
base COMSOL Multiphysics package, and they come with their own graphical user interfaces that make it quick and easy to access their power. You can even modify them for custom requirements. COMSOL Multiphysics itself is very powerful, and with sufficient expertise in a given field you could certainly develop these modes by yourself. But why spend the hundreds or thousands of hours that would be necessary when our team of experts has already done the work for you?

Note that the model descriptions in this book do not contain every detail on how to carry out every step in the modeling process. Before tackling these in-depth models, we urge you to first read the second book in the Acoustics Module documentation set. Titled the Acoustics Module User’s Guide, it introduces you to the basic functionality in the module, covers basic modeling techniques, and includes reference material of interest to those working in acoustics. For more information on how to work with the COMSOL Multiphysics graphical user interface, please refer to the COMSOL Multiphysics User’s Guide or the COMSOL Multiphysics Quick Start manual. An explanation of how to model with a programming language is available in yet another book, the COMSOL Multiphysics Scripting Guide.

The book in your hands, the Acoustics Module Model Library, provides details about a large number of ready-to-run models that illustrate real-world uses of the module. Each entry comes with theoretical background as well as instructions illustrating how to set it up. They were written by our staff engineers who have years of experience in acoustics; they are your peers, using the language and terminology needed to get across the sophisticated concepts in these advanced topics.

Finally, note that we supply these models as COMSOL Multiphysics Model MPH-files so that you can import them into COMSOL Multiphysics for immediate execution.

Model Library Guide

The table below summarizes key information about the entries in the Acoustics Module Model Library. A series of columns states the application mode (such as Pressure Acoustics) used to solve the corresponding model. The solution time is the elapsed time measured on a machine running Windows Vista with a 2.6 GHz AMD Athlon X2 Dual Core 500 CPU and 2 GB of RAM. For models with a sequential solution strategy, the Solution Time column shows the total combined solution time for all solution steps. Additional columns point out the modeling features that a given
example highlights. The categories here include the type of analysis (such as time harmonic or transient) and whether multiphysics or parametric studies are included.

<table>
<thead>
<tr>
<th>MODEL</th>
<th>PAGE</th>
<th>APPLICATION MODES</th>
<th>SOLUTION TIME</th>
<th>STATIONARY</th>
<th>TIME-HARMONIC</th>
<th>TRANSIENT</th>
<th>EIGENFREQUENCY/EIGENMODE</th>
<th>SENSITIVITY/OPTIMIZATION</th>
<th>MULTIPHYSICS</th>
<th>PARAMETRIC STUDY</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bessel Panel</td>
<td>8</td>
<td>Pressure Acoustics</td>
<td>2 min</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Doppler Shift</td>
<td>136</td>
<td>Aeroacoustics</td>
<td>2 s</td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Hollow Cylinder</td>
<td>19</td>
<td>Solid, Stress-Strain; Pressure Acoustics</td>
<td>41 s</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Optimizing the Shape of a Horn</td>
<td>34</td>
<td>Pressure Acoustics, Moving Mesh (ALE) Optimization</td>
<td>42 s</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Jet Pipe</td>
<td>48</td>
<td>Aeroacoustics (aca, acab)</td>
<td>12 s</td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Piezoacoustic Transducer</td>
<td>59</td>
<td>Piezo; Pressure Acoustics</td>
<td>1 s</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cylindrical Subwoofer</td>
<td>14</td>
<td>Pressure Acoustics</td>
<td>21 s</td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Transient Gaussian Explosion</td>
<td>69</td>
<td>Pressure Acoustics</td>
<td>3 min</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Ultrasound Scattering Off a Cylinder</td>
<td>78</td>
<td>Pressure Acoustics, UWVF</td>
<td>9 s</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>INDUSTRIAL MODELS</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Absorptive Muffler</td>
<td>88</td>
<td>Pressure Acoustics (acpr, acbm)</td>
<td>8 min</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>MODEL</td>
<td>PAGE</td>
<td>APPLICATION MODES</td>
<td>SOLUTION TIME</td>
<td>STATIONARY</td>
<td>TIME-HARMONIC</td>
<td>TRANSIENT</td>
<td>EIGENFREQUENCY/EIGENMODE</td>
<td>SENSITIVITY/OPTIMIZATION</td>
<td>MULTIPHYSICS</td>
<td>PARAMETRIC STUDY</td>
</tr>
<tr>
<td>-------------------------------------------</td>
<td>------</td>
<td>--------------------------------------------------------</td>
<td>---------------</td>
<td>------------</td>
<td>---------------</td>
<td>-----------</td>
<td>--------------------------</td>
<td>--------------------------</td>
<td>--------------</td>
<td>-----------------</td>
</tr>
<tr>
<td>Car Interior</td>
<td>104</td>
<td>Pressure Acoustics</td>
<td>88 min</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Flow Duct</td>
<td>115</td>
<td>Compressible Potential Flow, Aeroacoustics (aca, acab)</td>
<td>32 s</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Loudspeaker Driver†</td>
<td>145</td>
<td>Pressure Acoustics; AC Power Electromagnetics; Axial Symmetry, Stress-Strain</td>
<td>15 min</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Loudspeaker Suspension†</td>
<td>145</td>
<td>(Pressure Acoustics; AC Power Electromagnetics)</td>
<td>57 s</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Loudspeaker Driver in a Vented Enclosure</td>
<td>175</td>
<td>Pressure Acoustics</td>
<td>35 min</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Muffler with Perforates</td>
<td>193</td>
<td>Pressure Acoustics</td>
<td>27 min</td>
<td>✓</td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SAW Gas Sensor</td>
<td>210</td>
<td>Piezo Plane Strain</td>
<td>42 s</td>
<td>✓</td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>BENCHMARK MODELS</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Vibrations of a Disk Backed by an Air-Filled Cylinder†</td>
<td>226</td>
<td>Pressure Acoustics, Mindlin Plate</td>
<td>12 s</td>
<td>✓</td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Typographical Conventions

All COMSOL manuals use a set of consistent typographical conventions that should make it easy for you to follow the discussion, realize what you can expect to see on the screen, and know which data you must enter into various data-entry fields. In particular, you should be aware of these conventions:

- A **boldface** font of the shown size and style indicates that the given word(s) appear exactly that way on the COMSOL graphical user interface (for toolbar buttons in the corresponding tooltip). For instance, we often refer to the **Model Navigator**, which is the window that appears when you start a new modeling session in COMSOL; the corresponding window on the screen has the title **Model Navigator**. As another example, the instructions might say to click the **Multiphysics** button, and the boldface font indicates that you can expect to see a button with that exact label on the COMSOL user interface.

- The names of other items on the graphical user interface that do not have direct labels contain a leading uppercase letter. For instance, we often refer to the Draw toolbar; this vertical bar containing many icons appears on the left side of the user interface during geometry modeling. However, nowhere on the screen will you see

<table>
<thead>
<tr>
<th>MODEL</th>
<th>PAGE</th>
<th>APPLICATION MODES</th>
<th>SOLUTION TIME</th>
<th>STATIONARY</th>
<th>TIME-HARMONIC</th>
<th>TRANSIENT</th>
<th>EIGENFREQUENCY/EIGENMODE</th>
<th>SENSITIVITY/OPTIMIZATION</th>
<th>MULTIPHYSICS</th>
<th>PARAMETRIC STUDY</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open Pipe</td>
<td>238</td>
<td>Pressure Acoustics</td>
<td>22 s</td>
<td>√</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scattering from a Plate with Ribs</td>
<td>252</td>
<td>Pressure Acoustics</td>
<td>5 min</td>
<td>√</td>
<td></td>
<td></td>
<td></td>
<td>√</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

* This page number refers to the *Acoustics Module User’s Guide*.
† This model requires the Optimization Lab.
‡ This model requires the AC/DC Module.
§ This model requires the COMSOL Multiphysics Structural Mechanics Module.
the term “Draw” referring to this toolbar (if it were on the screen, we would print it in this manual as the Draw menu).

- The symbol > indicates a menu item or an item in a folder in the Model Navigator. For example, Physics>Equation System>Subdomain Settings is equivalent to: On the Physics menu, point to Equation System and then click Subdomain Settings.
  COMSOL Multiphysics>Heat Transfer>Conduction means: Open the COMSOL Multiphysics folder, open the Heat Transfer folder, and select Conduction.

- A Code (monospace) font indicates keyboard entries in the user interface. You might see an instruction such as “Type 1.25 in the Current density edit field.” The monospace font also indicates COMSOL Script codes.

- An italic font indicates the introduction of important terminology. Expect to find an explanation in the same paragraph or in the Glossary. The names of books in the COMSOL documentation set also appear using an italic font.
In this chapter you can find a selection of tutorial models that show how to use the features in the Acoustics Module to solve common acoustics problems.
Bessel Panel

Introduction

The Bessel panel (patented by Philips, see Ref. 1) is a way to arrange a number of loudspeakers so that the angular sound distribution resembles that of a single speaker. This benchmark model is a study of the near and far sound fields created by 25 loudspeakers arranged as an array of Bessel panels. The solution is compared with analytical results.

Model Definition

A Bessel panel consists of a number of loudspeakers placed equidistantly in a row. The speakers are driven with different signals, some of them in counter-phase. For a system of five speakers, the input (voltage and current) is weighted by the factors $1, 2, 2, -2, \text{ and } 1$. This results in an approximately homogeneous polar far-field distribution.

This model combines five Bessel panels in the same pattern to approximate a purely radial sound field. Figure 2-1 is a drawing of this assembly and the input to each speaker.

![Figure 2-1: The Bessel panel combination used in the model. The circles represent the speakers and the numbers represent their input. Each row and each column is a Bessel panel in itself.](image)
For the harmonic sound waves of acoustic pressure \( p(\mathbf{x},t) = p(\mathbf{x})e^{i\omega t} \) that you study in this model, the following frequency-domain Helmholtz equation applies for \( p(\mathbf{x}) \):

\[
\nabla \cdot \left( \frac{1}{\rho_0} \nabla p \right) - \frac{\omega^2 p}{\rho_0 c_s^2} = \sum L Q_L
\]

Here \( \rho_0 \) is the density of the medium (kg/m\(^3\)), \( \omega = 2\pi f \) denotes the angular frequency (rad/s), \( c_s \) refers to the speed of sound (m/s), and \( Q_L \) (1/s\(^2\)) is a monopole source representing a loudspeaker.

For air, \( \rho_0 = 1.25 \) kg/m\(^3\) and \( c_s = 343 \) m/s. For the frequency use \( f = 100 \) Hz. Each loudspeaker, \( L \), is represented by a point source emitting a flow of strength \( S_L = 10^{-2} n_L \) m\(^3\)/s, where \( n_L \) is the weight factor shown in Figure 2-1. It holds that

\[
Q_L = \omega S_L \delta(3)(\mathbf{R} - \mathbf{R}_L)
\]

where \( \delta(3) \) refers to the 3D Dirac delta function and \( \mathbf{R}_L \) is the location of the speaker \( L \).

See Figure 2-2 for the model geometry. The distance between two neighboring loudspeakers is 0.5 m. A sphere of radius of 5 m represents an infinite air domain surrounding the loudspeakers.

---

**Figure 2-2**: The model geometry.
The predefined \textit{radiation condition} within the \textit{spherical wave} option minimizes reflections on the exterior boundaries of the air sphere. This boundary condition allows a spherical wave to travel out of the system while generating only minimal reflections for the wave’s non-spherical components. The radiation boundary condition is useful when the surroundings are simply a continuation of the domain.

For mathematical details on the radiation boundary condition, see the description under the heading “Radiation Boundary Condition” on page 79 of the \textit{Acoustics Module User’s Guide}.

\textbf{Results and Discussion}

Figure 2-3 shows the sound pressure distribution in a slice of the sphere close to the loudspeakers. In this immediate vicinity of the sources, the sound field is still very inhomogeneous.

\begin{figure}[h]
\centering
\includegraphics[width=0.7\textwidth]{slice_plot.png}
\caption{Slice plot of the sound pressure distribution at 500 Hz. The slice is parallel with the \textit{yz}-plane and situated at \textit{x} = 0.2 m.}
\end{figure}

Another way of visualizing the near sound field is as an isosurface plot. Figure 2-4 shows the isobar for the absolute value of the sound pressure of 4 Pa.
Figure 2-4: Isosurface plot showing the location of the isobar $\text{abs}(p) = 4 \text{ Pa}$.

Figure 2-5 shows the far-field sound distribution at a distance of 100 m from the speakers. Note that the scale limits are equal to the global extremes of the sound pressure level. Hence the sound pressure level in any two given directions does not differ by more than 2.3 dB.
Figure 2-5: Sound pressure level (dB) at a distance of 100 m from the loudspeakers.

Figure 2-6 plots the computed far-field pressure at a radial distance of 100 m versus polar angle in the positive $xz$-plane and compares it to the analytical solution. As the plot shows, the computed solution is close to the analytical solution. Besides refining the mesh, you can refine the accuracy by adding perfectly matched layers outside the computational domain; for more information see page 73 of the Acoustics Module.
Finally, the accuracy is bounded by the far-field transformation itself: the longer the distance from the sources, the better the accuracy.

*Figure 2-6: Sound pressure level (dB) at a radial distance of 100 m in the xz-plane (zero azimuthal angle) as a function of the polar angle from the xy-plane. The solid line represents the computed solution and the dashed line the analytical solution.*

**Modeling in COMSOL Multiphysics**

Use the Pressure Acoustics application mode of the Acoustics Module to set up the model of the Bessel panel. The GMRES solver with the Geometric multigrid preconditioner ensures low memory consumption at a high mesh resolution. In an optional exercise that requires COMSOL Script or MATLAB, you run a script to calculate the analytical solution for comparison.

**Reference**

Model Library path: Acoustics_Module/Tutorial_Models/bessel_panel

Modelling Using the Graphical User Interface

**MODEL NAVIGATOR**

1. In the Model Navigator select 3D from the Space dimension list.
2. From the list of application modes select Acoustics Module>Pressure Acoustics>Time-harmonic analysis.
3. Click OK to close the Model Navigator.

**GEOMETRY MODELING**

1. Choose Draw>Sphere. In the Radius edit field type 5, then click OK.
2. Choose Draw>Point. Add a point to the geometry by typing the following values in the Coordinates edit fields, then click OK.

<table>
<thead>
<tr>
<th>Coordinates x</th>
<th>0</th>
</tr>
</thead>
<tbody>
<tr>
<td>Coordinates y</td>
<td>-1</td>
</tr>
<tr>
<td>Coordinates z</td>
<td>-1</td>
</tr>
</tbody>
</table>
3. With the point selected, choose Draw>Modify>Array. Enter the following data, then click OK.

<table>
<thead>
<tr>
<th>Displacement x</th>
<th>0</th>
</tr>
</thead>
<tbody>
<tr>
<td>Displacement y</td>
<td>0.5</td>
</tr>
<tr>
<td>Displacement z</td>
<td>0.5</td>
</tr>
<tr>
<td>Array size x</td>
<td>1</td>
</tr>
<tr>
<td>Array size y</td>
<td>5</td>
</tr>
<tr>
<td>Array size z</td>
<td>5</td>
</tr>
</tbody>
</table>

**OPTIONS AND SETTINGS**

Choose Options>Constants and define the following constant.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>S</td>
<td>0.01[m^3/s]</td>
<td>Flow source</td>
</tr>
</tbody>
</table>
**PHYSICS SETTINGS**

*Subdomain Settings*
The Bessel loudspeaker array is modeled in air. Because this is the default medium no changes are needed.

*Boundary Conditions*

2. Select all the boundaries, then select `Radiation condition` from the `Boundary condition` list.
3. From the `Wave type` list select `Spherical wave`.
   
   In preparation for studying the far field, you must supply a postprocessing variable. Plotting on boundaries gives you the far field for all angles. When plotting on edges you are limited to fixed azimuthal or polar angles, but as there is a lower number of computations involved these plots display much faster.
4. Go to the `Far-Field` page.
5. Select Boundaries 5–8.
6. In the top `Name` edit field type `farp`. When you select the next edit field in the table the default values for the field and the normal derivative appears.
7. Select the `Symmetry planes: x=0` check box. Keep the default `Symmetric pressure`.
8. Click **OK** to close the dialog box.

*Point Settings*

1. Choose `Physics>Point Settings`.
2. For all points, select `Flow` from the `Type of source` list. Assign the values of the flow according to the table below.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>POINTS 3, 7, 25, 29</th>
<th>POINTS 4, 8, 12, 26</th>
<th>POINTS 5, 6, 14, 16, 20, 24, 27, 28</th>
<th>POINTS 9, 16, 17, 22, 23</th>
<th>POINTS 10, 11, 15, 21</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>iS</code></td>
<td><code>S</code></td>
<td><code>-2*S</code></td>
<td><code>2*S</code></td>
<td><code>4*S</code></td>
<td><code>-4*S</code></td>
</tr>
</tbody>
</table>

The minus signs correspond to sources with the opposite phase.

3. Click **OK** to close the dialog box.

**GENERATING THE MESH**

1. From the `Mesh` menu open the `Free Mesh Parameters` dialog box. On the `Global` page, select `Custom mesh size` and type `0.85` in the `Maximum element size` edit field.
2. Click `Remesh`, then click **OK**.
**CHAPTER 2: TUTORIAL MODELS**

**COMPUTING THE SOLUTION**

1. Choose **Solve>Solver Parameters** or click the corresponding button on the Main toolbar to open the **Solver Parameters** dialog box.

2. From the **Linear system solver** list select **GMRES**, and from the **Preconditioner** list select **Geometric multigrid**.

3. Click the **Settings** button. In the dialog box that appears click **Preconditioner**, then select **Refine mesh** from the **Hierarchy generation method** list.

4. Click **OK** twice to close both the **Linear System Solver Settings** dialog box and the **Solver Parameters** dialog box. Click the **Solve** button on the Main toolbar.

**POSTPROCESSING AND VISUALIZATION**

The default plot shows the acoustic pressure on five equidistant slices along the x-axis. The central slice comprises the point sources, resulting in singular pressure values. For a better view of the local pressure distribution close to the sources, try a single slice offset by a small distance from the sources.

1. Choose **Postprocessing>Plot Parameters** or click the corresponding button on the Main toolbar.

2. On the **Slice** page find the **Slice positioning** area. Click the **Vector with coordinates** option button for the **x levels** entry and type 0.2 in the corresponding edit field.

3. Click **OK** to generate the plot.

4. Click the **Go to YZ View** button. The plot should now resemble the one in Figure 2-3.

The near-field radiation pattern is well represented by an isosurface plot of the absolute value of the sound pressure.

1. Click the **Go to Default 3D View** button.

2. Return to the **Plot Parameters** dialog box and click the **General** tab. Clear the **Slice** check box and select the **Isosurface** check box.

3. On the **Isosurface** page, type `abs(p)` in the **Expression** edit field on the **Isosurface Data** page.

4. Select the **Vector with isolevels** option button and type 4 in the corresponding edit field.

5. Select the **Uniform color** option button. Click the **Color** button, select a violet hue and click **OK**.
The far-field pressure $f_{ar,p}$ is normalized to give the pressure at a distance of 1 m from the source. The sound intensity, $I$, is proportional to $p^2$, and the total power radiated, $P = 4\pi I r^2$, is independent of the distance, $r$, from the source. It then follows that $p$ scales as $r^{-1}$. Thus, to get the sound pressure level in dB at a distance of 100 m from the panel, proceed as follows.

1. Choose Postprocessing>Domain Plot Parameters and click the Line/Extrusion tab.
2. Select Edge 11 and type $10\log_{10}\left(1/100^2 \cdot 0.5 \cdot \text{abs}(f_{ar,p})^2/\text{abs}(p_{\text{ref acpr}})^2\right)$ in the Expression edit field in the y-axis data area.
3. Click the Expression option button and then click the Expression button in the x-axis data area.
4. In the dialog box that appears, type $\text{atan2}(z,x)$ in the Expression edit field and select the degree sign (°) from the Unit list.
5. Click OK twice to see the plot.

What you see now is the sound pressure level at a distance of 100 m from the panel as a function of the polar angle at zero azimuthal angle. This plot should resemble the solid line in Figure 2-6.

You can visualize the far field in all possible directions using the boundaries of the sphere. Please note that it takes approximately 30 minutes before this plot shows. If you do not want to see the far field on the boundaries, skip the next two steps.

1. In the Plot Parameters dialog box click the Boundary tab. In the Expression edit field type $10\log_{10}\left(1/100^2 \cdot 0.5 \cdot \text{abs}(f_{ar,p})^2/\text{abs}(p_{\text{ref acpr}})^2\right)$.
2. Select the Boundary plot check box, then click OK to see the plot.

When the far-field boundary plot eventually shows up, the values should vary between 68.7 dB and 71.0 dB.

The plot that appears when you open this model in the Model Library is a combination of the isosurface plot that you already have and a surface plot of the local sound pressure level:

1. Choose Options>Suppress>Suppress Boundaries. In the dialog box that appears, select Boundary 2 and click OK.
2. In the Plot Parameters dialog box click the Boundary tab. Select Sound pressure level from the Predefined quantities list and click OK.
POSTPROCESSING WITH COMSOL SCRIPT

If you have access to COMSOL Script or MATLAB, you can easily compare the results from your simulation with the analytical solution. The `bessel_pressure` script returns the pressure at the coordinates \((x, y, z)\). The script is stored in the `multiphysics` folder as `bessel_pressure.m`.

To compare the simulation results with the analytical solution as in Figure 2-6, follow these steps:

1. Choose **Options>Functions**.
2. Click the **New** button. In the **Function name** edit field type `bessel_pressure`, then click **OK** to return to the **Functions** dialog box.
3. In the **Arguments** edit field type \(x, y, z\), and in the **Expression** edit field type `bessel_pressure(x,y,z)`.
4. Select the **May produce complex output for real arguments** check box.
5. Click **OK** to close the dialog box.
6. Choose **Solve>Update Model**.
7. Choose **Postprocessing>Domain Plot Parameters**.
8. If you have closed the far-field plot, recreate it by selecting Edge 11 on the **Line/Extrusion** tab and then clicking **Apply**.
9. On the **General** page select the **Keep current plot** check box and click the **Title/Axis** button.
10. In the **Title/Axis Settings** dialog box go to the **Title** edit field and type **Computed (solid) and analytic (dashed) far-field pressure**, then in the **Second axis label** edit field type **Sound pressure level (dB)**. Click **OK** to close the dialog box.
    The radius of the model geometry is 5 m. To get the sound level at a distance of 100 m from the source, you therefore must multiply the input coordinates with a factor of 20.
11. Go to the **Line/Extrusion** page of the **Domain Plot Parameters** dialog box.
12. In the **Expression** edit field type
    \[10 \log_{10}(0.5 \cdot \text{abs}(\text{bessel_pressure}(20 \cdot x, 20 \cdot y, 20 \cdot z))^2/\text{abs}(p_{\text{ref}})^2)\].
13. Click the **Line Settings** button. From the **Line style** list select **Dashed line**, then click **OK**.
14. Click **OK** to see the plot, which should resemble the one in Figure 2-6.
Hollow Cylinder

Introduction

Fluid acoustics coupled to structural objects, such as membranes or plates, represents an important application area in many engineering fields. Some examples are:

- Loudspeakers
- Acoustic sensors
- Nondestructive impedance testing
- Medical ultrasound diagnostics of the human body

Model Definition

This model provides a general demonstration of an acoustic fluid phenomenon in 3D coupled to a solid object. In this study, the solid object is a capped, hollow aluminum cylinder filled with and immersed in water.

The acoustic waves created by a source inside the cylinder impact on the cylinder walls. In the model, you first calculate the frequency response from the solid object and then feed the information back to the acoustics domain so that you can analyze the wave pattern.
Figure 2-7: A hollow aluminum cylinder is immersed in water. The white line inside the cylinder indicates the line source, and the tiny sphere next to the line shows the position of the point source. The simulation domain is bounded by a large sphere.

Figure 2-7 illustrates the aluminum cylinder immersed in water. The cylinder is 2 cm in height and has an outer diameter of 1 cm. The thickness of its walls is 1.5 mm.

The water-filled acoustic domain outside the cylinder is truncated to a sphere with a reasonably large diameter. In two different versions of the model, the system is driven either by a line source coinciding with the axis of the cylinder and located entirely within the cylinder, or by a point source in the interior of the cylinder. The frequency is 60 kHz, that is, in the ultrasound region. The harmonic acoustic pressure in the water at the surface of the cylinder acts as a boundary load on the 3D solid to ensure continuity in pressure. In solving the model, the harmonic displacements and stresses in the solid cylinder are calculated, using the normal acceleration of the solid surface at the acoustics domain boundary to ensure continuity in acceleration.

**Domain Equations**

**Water Subdomain**

For harmonic sound waves we use the frequency-domain Helmholtz equation for sound pressure:
Here, the acoustic pressure is a harmonic quantity, \( p = p_0 e^{i\omega t} \) (N/m\(^2\)), \( p_0 \) is the density of the medium (kg/m\(^3\)), \( q \) is an optional dipole source (N/m\(^3\)), \( \omega \) is the angular frequency (rad/s), and \( c_s \) is the speed of sound (m/s). In the present model, no dipole source is included.

In the above table, \( p_{wref} \) denotes the standard reference pressure used when defining the sound pressure level in water; its value differs from that of air, which is the default setting in COMSOL Multiphysics.

**Solid Subdomain**

You calculate the harmonic stresses and strains inside the solid cylinder walls using a frequency response analysis in the 3D Solid, Stress-Strain application mode. The material data comes from the built-in database for Aluminum 3003-H18.

**Boundary Conditions**

**Outer Perimeter**

On the outer spherical perimeter of the water domain (Figure 2-7), use the predefined Radiation condition with the Spherical wave option. This boundary condition allows a spherical wave to travel out of the system, giving only minimal reflections for the non-spherical components of the wave. The radiation boundary condition is useful when the surroundings are only a continuation of the domain.

For mathematical details on the radiation boundary condition, see the subsection “Radiation Boundary Conditions” on page 79 of the Acoustics Module User’s Guide.

**Cylinder-Water Interface**

To couple the acoustic pressure wave to the solid cylinder, set the boundary load \( \mathbf{F} \) (force/units area) on the cylinder to

\[
\mathbf{F} = -\mathbf{n} \cdot \rho \mathbf{u}
\]
where $\mathbf{n}_s$ is the outward-pointing unit normal vector seen from inside the solid domain.

To couple the frequency response of the solid back to the acoustics problem, use the boundary condition that the normal acceleration

$$a_n = -\mathbf{n}_a \left( \frac{1}{\rho_0} (\nabla p - \mathbf{q}) \right)$$

equal that of the solid structure. Here, $\mathbf{n}_a$ is the outward-pointing unit normal vector seen from inside the acoustics domain.

These boundary conditions are available as boundary groups using the Acoustic-Structure Interaction predefined multiphysics coupling.

**EDGE AND POINT SETTINGS**

In the two cases considered, the sound waves are generated by either a point source or a line source. A line source along the $z$-axis is defined as follows:

$$\nabla \cdot \left( \frac{1}{\rho_0} \nabla p \right) = 2 \frac{P \omega}{\eta \rho_0} \delta^{(2)}(r)$$

Here $P$ is the power per unit length of an infinitely long line source placed in a homogeneous medium extending to infinity. Furthermore, $\delta^{(2)}(r)$ is the Dirac delta function in two dimensions, $r$ denoting the projection of the position vector onto the $xy$-plane.

For a point source of power $P$ located at the point $\mathbf{R} = \mathbf{R}_0$ in an infinite homogeneous space, the definition is

$$\nabla \cdot \left( \frac{1}{\rho_0} \nabla p \right) = 2 \frac{\pi P c}{\eta \rho_0} \delta^{(3)}(\mathbf{R} - \mathbf{R}_0)$$

where $\delta^{(3)}(\mathbf{R})$ is the Dirac delta function in three dimensions. Any type of confinement will result in higher power usage.
Results

Figure 2-8: Sound-pressure plot (dB) of the acoustic waves in the coupled problem, using a point source inside the cylinder. The surfaces of the cylinder show its deformation (m). Some of the surfaces are hidden to reveal the pressure distribution inside the cylinder.

Figure 2-8 shows the sound pressure in the near field as a slice plot, for the case of an off-center point source. Far-field results are shown in the “Postprocessing and Visualization” section of the step-by-step instructions.

Modeling in COMSOL Multiphysics

The implementation of this model does not require any special tricks, but relies on standard equations and conditions in COMSOL Multiphysics and the Acoustics Module. Thanks to an internal scaling of the equations, the system of equations is symmetric. This means that you can use a solver designed for problems that generate symmetric stiffness matrices, thereby saving a considerable amount of system memory and shortening the calculation time.

Model Library path: Acoustics_Module/Tutorial_Models/hollow_cylinder
MODEL NAVIGATOR
1 Start COMSOL Multiphysics.
2 In the Model Navigator, select 3D from the Space dimension list.
3 Select Acoustics Module>Acoustic-Structure Interaction from the list of application modes.
4 Click OK.

OPTIONS
1 Open the Constants dialog box from the Options menu and enter the following values (the descriptions are optional):

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Freq</td>
<td>60[kHz]</td>
<td>Frequency</td>
</tr>
<tr>
<td>rhow</td>
<td>997[kg/m^3]</td>
<td>Water density</td>
</tr>
<tr>
<td>cw</td>
<td>1500[m/s]</td>
<td>Speed of sound in water</td>
</tr>
<tr>
<td>pw_ref</td>
<td>1[uPa]</td>
<td>Reference sound pressure in water</td>
</tr>
<tr>
<td>R</td>
<td>3[cm]</td>
<td>Radius of modeling domain</td>
</tr>
<tr>
<td>edgeL</td>
<td>1.7[cm]</td>
<td>Length of line source</td>
</tr>
</tbody>
</table>
2 Click OK.
3 Choose Physics>Scalar Variables and enter the following values:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>freq_acsld</td>
<td>Freq</td>
<td>Excitation frequency</td>
</tr>
<tr>
<td>freq_acpr</td>
<td>Freq</td>
<td>Excitation frequency</td>
</tr>
<tr>
<td>p_ref_acpr</td>
<td>pw_ref</td>
<td>Pressure reference</td>
</tr>
</tbody>
</table>
4 Click OK.

GEOMETRY MODELING
All the buttons used in creating the geometry of this model are located in the leftmost of the vertical toolbars.
1 Click the **Cylinder** button. In the dialog box that appears, enter property values according to the following table:

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Radius</td>
<td>0.005</td>
</tr>
<tr>
<td>Height</td>
<td>0.02</td>
</tr>
<tr>
<td>Axis base point, z</td>
<td>-0.01</td>
</tr>
</tbody>
</table>

Let all other entries retain their default values. Click **OK** to close the dialog box.

2 Click the **Cylinder** button once more and create a cylinder with the following specifications; when done, click **OK**.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Radius</td>
<td>0.0035</td>
</tr>
<tr>
<td>Height</td>
<td>0.017</td>
</tr>
<tr>
<td>Axis base point, z</td>
<td>-0.0085</td>
</tr>
</tbody>
</table>

3 Click the **Line** button. Create a line with the following endpoints; when done, click **OK**.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>x</td>
<td>0 0</td>
</tr>
<tr>
<td>y</td>
<td>0 0</td>
</tr>
<tr>
<td>z</td>
<td>-0.0085 0.0085</td>
</tr>
</tbody>
</table>

4 Click the **Point** button. Create a point located at the following coordinate; when done, click **OK**.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>x</td>
<td>0.001</td>
</tr>
<tr>
<td>y</td>
<td>0.002</td>
</tr>
<tr>
<td>z</td>
<td>0.005</td>
</tr>
</tbody>
</table>

5 Click the **Sphere** button. In the dialog box that appears, type 0.03 in the **Radius** edit field, and let the other entries retain their default values. Click **OK** to close the dialog box.

6 Click the **Zoom Extents** button on the Main toolbar.
PHYSICS SETTINGS

Subdomain Settings—Solid
1 From the Multiphysics menu, select Solid, Stress-Strain (acsld).
2 From the Physics menu, select Subdomain Settings. Select Subdomains 1 and 3, then select Fluid domain from the Group list.
3 Select Subdomain 2, then select Solid domain from the Group list.
4 On the Material page, click Load. Select Aluminum 3003-H18 under the Basic Material Properties entry in the Materials list. Click OK.
5 Click the Damping tab, then select No damping from the Damping model list.
6 Click OK.

Boundary Conditions—Solid
1 In the Boundary Settings dialog box select all the exterior boundaries (5–12, 15–16, and 19–20).
2 From the Group list, select Fluid load.
   The variables nx_acpr, ny_acpr, and nz_acpr in the predefined face load components are the Cartesian components of the normal vector directed outward from the subdomains where the Pressure Acoustics (acpr) application mode is active.
3 Click OK.

Subdomain Settings—Pressure Acoustics
1 From the Multiphysics menu, select Pressure Acoustics (acpr).
2 Choose Physics>Subdomain Settings.
3 Select Subdomain 2 and then select Solid domain from the Group list.
4 Select Subdomains 1 and 3 and then select Fluid domain from the Group list. Enter the following data for the density and the speed of sound:

<table>
<thead>
<tr>
<th>QUANTITY</th>
<th>VALUE/EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>(\rho_0)</td>
<td>(\rho_{how})</td>
</tr>
<tr>
<td>(c_s)</td>
<td>(c_{sw})</td>
</tr>
</tbody>
</table>

5 Click OK.

Boundary Conditions—Pressure Acoustics
1 Select Physics>Boundary Settings. Hold down the Ctrl key and select Boundaries 1–4, 13–14, and 17–18. Select Radiation condition from the Boundary condition list, and choose Spherical wave as the wave type.
2. Select the **Select by group** check box, then select Boundary 5 to get a group selection of all the remaining boundaries.

3. From the **Group** list, select **Structural acceleration**.

4. Click **OK**.

The variables $u_{tt\_acsld}$, $v_{tt\_acsld}$, and $w_{tt\_acsld}$ in the predefined setting for the normal acceleration are the acceleration components from the **Solid**, **Stress-Strain (acsld)** application mode.

---

**Edge Settings—Pressure Acoustics**

1. Select **Physics>Edge Settings**.

2. In the dialog box that appears, select Edge 26.

3. Select **Power** in the **Type of source** list, then set $P$ to $1/edgeL$.

4. Click **OK**.

Note that the presence of a Dirac delta function is not explicitly indicated on the right-hand side of the equation in the **Equation** area; instead, the localization of the source to the selected edge is implicitly understood.

---

**Generating the Mesh**

1. From the **Mesh** menu open the **Free Mesh Parameters** dialog box. On the **Global** page select **Custom mesh size** and type 0.005 in the **Maximum element size** edit field.

   This value corresponds to $0.2L$, where $L = c/f$ is the wavelength of the sound waves in the acoustics domain. Combined with the (default) choice of second-order elements, it follows that the rule-of-thumb minimum of ten to twelve degrees of freedom per wavelength for the solution to be reliable is satisfied.

2. Click the **Subdomain** tab. Select Subdomain 2 and set the **Maximum element size** to 0.002.

3. Click **Remesh**, then click **OK** to close the dialog box.

---

**Computing the Solution**

1. Select **Solve>Solver Parameters**.

2. From the **Solver** list, select **Stationary**.

3. From the **Linear system solver** list, select **GMRES**.

   The GMRES solver by default uses the geometric multigrid preconditioner to solve the system in two iterations: first with 1st-order elements and then with 2nd-order elements. In solving the present model, GMRES is faster and requires less memory (about 400 MB versus 900 MB) than the SPOOLES linear solver.
4 Click OK.
5 Click the Solve button on the Main toolbar.

**POSTPROCESSING AND VISUALIZATION**

![Image](image_url)

**Figure 2-9:** The sound pressure level (dB) inside and outside the cylinder, and the deformations (m) of the cylinder when using a line pressure source along the axis of the cylinder.

The default plot is a slice plot of the von Mises stress. There is much more information hidden in the solution, and there is a lot you can do to improve the result’s readability and enhance its looks. For example, to arrive at the plot in Figure 2-9, do as follows:

1. Choose Options>Suppress>Suppress Boundaries.
2. Select Boundaries 5–6 and 9–10 from the list. Click OK.
3. Choose Postprocessing>Plot Parameters. On the General page, select the check boxes for Slice, Boundary, and Deformed shape in the Plot type area. Leave all the other check boxes cleared.
4. Click the Slice tab, then select Pressure Acoustics (acpr)>Sound pressure level among the Predefined quantities. In the Slice positioning area type 0 in all three Number of levels edit fields. On the y levels line, click the Vector with coordinates button, then type 0.002 in the corresponding edit field.
5 Click the Boundary tab and select Solid, Stress-Strain (acsld)>Total displacement in the list of Predefined quantities. Click the Colormap button and select hsv from the corresponding list.

6 Click the Deform tab. In the Domain types to deform area, make sure that only the Boundary check box is selected. Click the Boundary Data tab, and verify that the selection in the Predefined quantities list is Displacement.

7 Click OK.

To refine the visual quality of the model, do as follows:

1 Click both the Headlight button and the Scene Light button on the Main toolbar.

2 Choose Options>Visualization/Selection Settings.

3 On the Camera page click the Perspective button in the Projection area.

4 Click the Lighting tab. In the Scene light area click all four light sources and clear the Enabled check box on each one of them.

5 Click the New button. Select Spot in the Type list. Click OK.

6 Specify the light source as in the following table, then click OK.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Position</td>
<td>-0.01 -0.01 0</td>
</tr>
<tr>
<td>Direction</td>
<td>0 1 0</td>
</tr>
<tr>
<td>Spread angle</td>
<td>90</td>
</tr>
<tr>
<td>Concentration</td>
<td>0.05</td>
</tr>
</tbody>
</table>

You can experiment with the viewing angle by clicking the Zoom and Dolly In/Out buttons on the Plot toolbar and clicking and dragging the geometry.

Point-Source Version

Once you are done solving and postprocessing the line-source version of this model, save it and proceed to set up a point-source version. Whereas the line source gives an axially symmetric pressure field, the point source is displaced from the origin and thus motivates a 3D model. Starting from your line source model, do the following to shift to a point source version.
PHYSICS SETTINGS

Point Settings—Pressure Acoustics
Choose Physics>Point Settings. In the dialog box that appears select Point 20. In the Type of source list select Power and set P to 1 W.

Edge Settings—Pressure Acoustics
To turn off the line source choose Physics<Edge Settings. In the dialog box that appears select Edge 26 and set P to 0.

COMPUTING THE SOLUTION
Click the Solve button on the Main toolbar.

POSTPROCESSING AND VISUALIZATION
The location of the slice plot now coincides with the point source, where the pressure field is singular. You get a nicer plot if you move the slice away from the source:

1 In the Plot Parameters dialog box, click the Slice tab.
2 In the y levels edit field, type 0 in the Vector with coordinates column.
3 Click OK.

Your plot should now resemble Figure 2-8 on page 23.

Far-Field Postprocessing
1 Choose Physics<Boundary Settings and go to the Far-Field page.
2 Select Boundaries 1–4, 13–14, and 17–18.
3 Define a variable with the Name pfar.
4 Click OK to close the dialog box.
5 Choose Solve<Update Model.

You can now plot the far pressure field in the direction from the origin towards any point To see, for instance, the field as a function of the elevation angle along Edge 16, do the following:

6 Choose Postprocessing<Domain Plot Parameters.
7 On the Line/Extrusion page, select Edge 16.
8 From the Predefined quantities list, select Pressure Acoustics (acpr)>Sound pressure level for pfar.
For the x-axis data click the Expression button and specify the expression atan2(-\(y,z\)). Click OK to close the dialog box and then click OK again to see the plot. Verify that it looks similar to Figure 2-10.

Figure 2-10: The far-field sound pressure level in dB as a function of the polar angle from 0 to \(\pi/2\) at the fixed azimuthal angle of \(-\pi\) and a distance of 1 m from the source.

If you are patient and have some spare time, you can try to plot the far-field radiation pattern at all possible angles around the sphere. This is typically done as a deformed surface plot. Because postprocessing the far field is computationally heavy this might take several minutes.

1 Choose Options>Constants. Add the following constants; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lpfarmin</td>
<td>122</td>
<td>Min sound pressure level (dB)</td>
</tr>
<tr>
<td>Lpfarmax</td>
<td>163</td>
<td>Max sound pressure level (dB)</td>
</tr>
</tbody>
</table>

2 Choose Options>Expressions>Boundary Expressions.

3 On Boundaries 1–4, 13–14, and 17–18, define the variable deformation as 
\((Lpfar\_acpr-Lpfarmax)/(Lpfarmax-Lpfarmin)\).

4 Click OK.
5 Choose Solve>Update Model.

6 Open the Plot Parameters dialog box. On the General page, select the check boxes for Boundary and Deformed shape only.

7 Click the Boundary tab. From the Predefined quantities list, select Pressure Acoustics (acpr)>Sound pressure level for pfar.

8 Click the Deform tab, then click the Boundary Data tab. In the Domain types to deform area select the Boundary check box only. Enter the following Boundary Data:

- x component: deformation*x
- y component: deformation*y
- z component: deformation*z

9 Click OK and wait for a few minutes to see the plot.

10 Rotate the plot to explore the directional dependence of the pressure in the far-field region. If you prefer, you can manually enter settings from Options>Visualization/Selection Settings. For a nice view, click the Camera tab and enter the following data:

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Camera position</td>
<td>0.18 0.39 0.29</td>
</tr>
<tr>
<td>Camera target</td>
<td>0 0 0</td>
</tr>
<tr>
<td>Camera up vector</td>
<td>0.11 0.55 -0.83</td>
</tr>
<tr>
<td>Camera view angle</td>
<td>11.6</td>
</tr>
</tbody>
</table>
Figure 2-11 shows a zoom in of the resulting radiation pattern.

![Figure 2-11: Radiation pattern of the far-field sound pressure level at a distance of 1 m from the source.](image)

The lower the pressure, the larger the inward deformation from the original spherical boundary.

This plot gives a useful overview of the far-field sound pressure level. The first thing to notice is that the plot has a mirror symmetry with respect to the plane spanned by the $z$-axis and the point of excitation. This may be easier to verify by inspection if you turn off the light sources. Furthermore, there are two distinct maxima, above and below the end caps of the cylinder, respectively. The minima approximately correspond to nodes in the structural deformation.
Optimizing the Shape of a Horn

Introduction

This model shows how to apply boundary shape optimization to a simple axisymmetric horn. For the sake of simplicity, the far-field sound pressure level is maximized for a single frequency and in a single direction. The focus is on the optimization procedure, which involves parametrization of the geometry, choice of objective function and optimization solver settings.

The model was inspired by the work of Erik Bängtsson, Daniel Noreland, Martin Berggren, and others (Ref. 1).

Note: This model requires the Optimization Lab.

Model Definition

A plane-wave mode feeds an axisymmetric horn radiating from an infinite baffle towards an open half space. The radius of the feeding waveguide is assumed to be fixed, as well as the depth of the horn and the size of the hole where the horn is attached to
the baffle. By varying the curvature of the initially conical surface of the horn, its directivity and impedance can be changed.

![Figure 2-12: The initial configuration is a simple cone.](image)

The surface is parameterized by assuming that the radius of the horn (as function of the distance from the baffle) deviates from the simple cone by a function of the form

\[
d_r = \sum_{i=1}^{N} q_i d_i \sin(i\pi s)
\]  

where \( s \) is a parameter varying between 0 and 1 along the edge of the cone, \( d_i \) are scale factors and the \( q_i \) are the optimization variables to be optimized. Note that \( d_r(0) = d_r(1) = 0 \), and that the function is smooth. The number of optimization variables can be varied; using more variables gives more freedom and potentially a better final value of the objective function, but will also make the optimization process more sensitive and may generate a shape which is less suitable for production.

Optimization can only be applied to real-valued functions, because the minimum of a complex-valued function is not well-defined. But the raw result from a frequency-domain acoustics simulation is a complex-valued pressure field. From this
you will have to generate a scalar, real-valued quantity to be used as objective function in the optimization process. However, any operation which converts a complex number to a real value is necessarily non-analytical, which means that its derivative is not uniquely defined.

The gradient-based optimization solver in COMSOL’s Optimization Lab by default evaluates derivatives of the objective function via the solution of an adjoint equation. This procedure requires that the symbolic derivative of any non-analytic function is selected in a special way. The default behavior of the composite functions $\text{abs}(z)$ and $\text{conj}(z)$, which are most commonly used to obtain a real-valued objective function, is to return a derivative parallel to the real axis. However, this behavior is not appropriate for the adjoint method, where you instead need the definitions

$$
\frac{d}{dz} |z| = \frac{z}{|z|} \\
\frac{d}{dz_1}(z_1 \overline{z_2}) = \overline{z_2} \\
\frac{d}{dz_2}(z_1 \overline{z_2}) = \overline{z_1} \tag{2-2}
$$

It is indeed possible to redefine the symbolic derivatives of built-in functions in COMSOL Multiphysics, but in this case it is more convenient to use the special function $\text{realdot}(z_1, z_2)$, which evaluates as $\text{real}(z_1 \text{conj}(z_2))$ but differentiates according to Equation 2-2. In particular, as a measure of the transmission properties of the horn, you will use a an expression of the form $\text{realdot}(p_m, p_m)/p_0^2$, where $p_m$ is the pressure measured at a specific point in front of the horn and $p_0$ is the (real-valued and constant) amplitude of the incoming wave.

If you choose to evaluate $p_m$ in the near-field, or can afford to include a sufficiently large domain in front of the horn to effectively measure a far-field value at a point in the model, you can simply measure $p_m$ as the local pressure in a geometry vertex. However, in order to optimize the far-field directivity pattern in an efficient way, $p_m$ should be defined using an integral representation of the far-field pressure as function of the angle from the axis.

COMSOL Multiphysics contains optimized code for evaluating such far-field integrals. This is, however, a pure post-processing feature which does not support the automatic differentiation required by the adjoint method. Therefore, you will have to return to the definition of the Helmholtz-Kirchhoff integral as given in its asymptotic axisymmetric form by Equation 3-5 on page 33 in the Acoustics Module User’s Guide:
If the infinite baffle is placed at \( z = 0 \), its effect is the same as if adding a mirror image of the horn and at the same time removing the baffle. If, in addition, the integration surface is taken to be the wide end of the horn, in the plane of the baffle, most of the terms in Equation 2-3 cancel out, and all that is left is

\[
\begin{align*}
 p_{\text{fast}}(R) &\equiv -\frac{1}{2} \oint_S \frac{i k p(r)}{|R|} \left( j_{0} \left( \frac{k r R}{|R|} \right) \right) \nabla p(r) \cdot \mathbf{n} - \\
 &\quad \left( i n_r R j_{1} \left( \frac{k r R}{|R|} \right) + n_z Z J_{0} \left( \frac{k r R}{|R|} \right) \right) \] dS
\end{align*}
\]

If the infinite baffle is placed at \( z = 0 \), its effect is the same as if adding a mirror image of the horn and at the same time removing the baffle. If, in addition, the integration surface is taken to be the wide end of the horn, in the plane of the baffle, most of the terms in Equation 2-3 cancel out, and all that is left is

\[
p_m(\Theta) = \int_S r J_0(k r \sin(\Theta)) \frac{\partial p}{\partial z} dr
\]

where \( J_0 \) is the Bessel function of the first kind of order 0, and the angle \( \Theta \) from the axis has been introduced as a parameter. This integral is easily implemented in COMSOL Multiphysics as an integration coupling variable.

Optimization as a rule implies many evaluations of the model for different designs, which may be very time consuming. In addition, the solver can be asked to evaluate each design at a number of frequencies and optimize with respect to the sum of the objective function evaluated for each frequency. In this tutorial, a single frequency of 4000 Hz has been selected in order to make it possible to experiment with other aspects of the model. For example, changing the parameter \( \Theta \), you can easily study the effect on the horn shape of optimizing the output at a specified angle from the axis.
Results and Discussion

By changing the shape of the horn within the limits of the selected parametrization, the on-axis sound pressure level can be raised by about 1 dB compared to the simple cone in Figure 2-12.

Figure 2-13: The final shape of the horn, optimized for on-axis SPL at 5000 Hz.
The improvement is rather small, because also the initial configuration shows a marked directivity, as can be seen from Figure 2-14. Obviously, the optimal shape with respect to on-axis SPL leads to deep undesirable minima in other directions.

![Figure 2-14: Far-field patterns for the original (solid blue) and final (dashed red) designs.](image)

Optimizing with respect to a slight off-axis direction can give you a more uniform far-field pattern, but may also result in a deep minimum on the axis. Try for example to set the off-axis angle $\Theta$ to 22$^\circ$.

To search for a stable and practically useful horn design, you might instead create a composite objective function as a weighted sum of transmission values evaluated for a number of discrete directions, or choose to minimize the deviation from the mean SPL over a range of angles. In addition, you would also want to optimize with respect to more than one frequency, and experiment with different parameterizations.

**Modeling in COMSOL Multiphysics**

COMSOL Multiphysics implements the parametrization as a prescribed boundary displacement in a Moving Mesh application mode. The mesh is allowed to move freely in the conical part of the horn, but otherwise kept fix. Some measures must be taken...
to avoid inverted elements when the shape of the cone is changed. Firstly, a quad mesh will be used, since quads are less likely to become inverted, compared to triangles.

Secondly, the amplitude of the boundary displacement is restricted by limits on the optimization variables. These artificial constraints are intended to keep the mesh element volumes positive at all times and must not be active at the optimum point. You will perform this sanity check as a final postprocessing step.

A time-harmonic Pressure Acoustics application mode solves for the pressure field inside the horn and in a small spherical domain surrounding its opening. The air domain is terminated by a spherical PML layer which absorbs outgoing waves in such a way that the artificial termination of the domain has no influence on the near-field. An accurate near-field is sufficient, since the far-field result is based on an integral representation evaluated in the plane of the baffle. A matched boundary condition on the waveguide attached to the narrow end feeds the horn with a plane wave of amplitude $p_0$.

An Optimization application mode adds five scalar optimization variables, $q_1$ to $q_5$, which are constrained to vary in the interval $[-1, 1]$. The maximum effect of each variable on the boundary displacement is controlled by the scale factors $d_i$ in Equation 2-1. The pressure measured by an integration coupling variable according to Equation 2-4 is inserted into a scalar objective function contribution equal to the negative of the SPL value, or $-10 \log_{10}(0.5 \cdot \text{realdot}(p_m, p_m)/(20 \cdot 10^{-6})^2)$.

Reference


Model Library path: Acoustics_Module/Tutorial_Models/horn_shape_optimization
Modeling Using the Graphical User Interface

MODEL NAVIGATOR
1 In the Model Navigator, select Axial Symmetry (2D) from the Space dimension list, then go to the list of application modes and select COMSOL Multiphysics>Deformed Mesh>Moving Mesh (ALE).
2 Click the Multiphysics button, then click Add.
3 Select Acoustics Module>Pressure Acoustics from the application mode list, then click Add.
4 Select COMSOL Multiphysics>Optimization and Sensitivity>Optimization, then click Add.
5 Click OK to close the Model Navigator.

GEOMETRY MODELING
1 Shift-click the Rectangle/Square button on the Draw toolbar. In the dialog box that appears, change the following settings; when done, click OK.

<table>
<thead>
<tr>
<th>Size</th>
<th>Width</th>
<th>Height</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>0.025</td>
<td></td>
</tr>
<tr>
<td>Height</td>
<td>0.025</td>
<td></td>
</tr>
</tbody>
</table>

2 Create another rectangle with the following changes compared to the defaults:

<table>
<thead>
<tr>
<th>Size</th>
<th>Width</th>
<th>Height</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>0.3</td>
<td></td>
</tr>
<tr>
<td>Height</td>
<td>0.3</td>
<td></td>
</tr>
</tbody>
</table>

3 Zoom in to the geometry by clicking the Zoom Extents button on the Main toolbar.
4 Click the Ellipse/Circle (Centered) button on the Draw toolbar. Right-click at the origin and drag to create a circle of radius 0.3.
5 Draw another circle of radius 0.2 inside the first one.
6 Shift-click to select both circles, then click the Union button on the Draw toolbar.
7 Select the joined circles together with the larger of the rectangles (R2), then click the Intersection button.
8 To draw the actual horn, click the Line button on the Draw toolbar; click consecutively at (0, 0), (0.1, 0), (0.025, -0.15), (0, -0.15), and (0, 0); and finally right-click once anywhere in the geometry to close the curve and turn it into a solid object.
OPTIONS AND SETTINGS

1. Choose **Options>Constants**.

2. Define the following constants; when finished, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>r0</td>
<td>0.025[m]</td>
<td>Radius of waveguide</td>
</tr>
<tr>
<td>p0</td>
<td>1[Pa]</td>
<td>Incident pressure amplitude</td>
</tr>
<tr>
<td>theta</td>
<td>0[deg]</td>
<td>Polar angle</td>
</tr>
<tr>
<td>d1</td>
<td>0.02[m]</td>
<td>Scale factor</td>
</tr>
<tr>
<td>d2</td>
<td>0.01[m]</td>
<td>Scale factor</td>
</tr>
<tr>
<td>d3</td>
<td>0.01[m]</td>
<td>Scale factor</td>
</tr>
<tr>
<td>d4</td>
<td>0.01[m]</td>
<td>Scale factor</td>
</tr>
<tr>
<td>d5</td>
<td>0.01[m]</td>
<td>Scale factor</td>
</tr>
</tbody>
</table>

3. Choose **Options>Expressions>Global Expressions** and add the expression for the radial displacement of the horn surface:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>dr</td>
<td>q1<em>d1</em>sin(1<em>pi</em>s)+q2<em>d2</em>sin(2<em>pi</em>s)+q3<em>d3</em>sin(3<em>pi</em>s)+q4<em>d4</em>sin(4<em>pi</em>s)+q5<em>d5</em>sin(5<em>pi</em>s)</td>
<td>Radial displacement</td>
</tr>
</tbody>
</table>

4. Choose **Options:Integration Coupling Variables>Boundary Variables**.

5. Select Boundary 6 and create a variable with the following properties:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>INTEGRATION ORDER</th>
<th>FRAME</th>
<th>GLOBAL DESTINATION</th>
</tr>
</thead>
<tbody>
<tr>
<td>pm</td>
<td>r<em>besselj(0,k_acpr</em>r*sin(theta))*pz</td>
<td>4</td>
<td>ref</td>
<td>yes</td>
</tr>
</tbody>
</table>

6. Click **OK**.

PHYSICS SETTINGS

Subdomain Settings—Moving Mesh (ALE)

1. From the **Multiphysics** menu, select the **Moving Mesh (ALE)** application mode.

2. Choose **Physics>Subdomain Settings** to open the **Subdomain Settings** dialog box.

3. Select Subdomains 1, 3, and 4, click the **No displacement** button, and then click **OK**.

Boundary Conditions—Moving Mesh (ALE)

4. From the **Physics** menu, open the **Boundary Settings** dialog box.
5 Select Boundaries 3, 4, and 6.
6 Select the \( \text{dr} \) and \( \text{dz} \) check boxes to lock these boundaries at their initial positions.
7 Select Boundary 9, again select the \( \text{dr} \) and \( \text{dz} \) check boxes, and enter \( \text{dr} \) in the \textit{Mesh displacement, r direction} edit field.
8 Click \textit{OK} to close the dialog box.

\textit{Subdomain Settings—Pressure Acoustics}

The default medium in the Pressure acoustics application mode is air, so the only thing you have to do is activate the PML domain.

1 From the \textit{Multiphysics} menu, choose the \textit{Pressure Acoustics} application mode.
2 From the \textit{Physics} menu, open the \textit{Subdomain Settings} dialog box.
3 Select Subdomain 4 and click the \textit{PML} tab.
4 From the Type of PML list, choose \textit{Spherical}.
5 Select the \textit{Absorbing in radial dir.} check box, then click \textit{OK} to close the dialog box.

\textit{Boundary Conditions—Pressure Acoustics}

The default boundary condition is \textit{sound hard}, which is appropriate for the horn surface and the baffle, and does no harm on the outside of the PML or on the axis. Therefore, only the waveguide port requires the boundary condition to be changed. In addition, far-field postprocessing variables must also be defined in \textit{Boundary Settings}.

1 Choose \textit{Physics>Boundary Settings}.
2 Select Boundary 2. From the Boundary condition list, choose \textit{Matched boundary} and set the Pressure source field to \( p_0 \).
3 Click the Interior boundaries check box, then select Boundary 6.
4 On the Far-Field page, type \( p_f \) in the first row of the Name column.
5 Press Tab to automatically fill in the remaining columns.
6 Select the \( z=0 \) check box under Symmetry planes but leave the list box at Symmetric Pressure. This procedure accounts for the infinite baffle.
7 Click \textit{OK} to close the dialog box.

\textit{Scalar Settings—Optimization}

In the Optimization application mode, you define the objective function, declare optimization variables, and constraints.

8 Activate the \textit{Optimization} application mode by selecting it from the \textit{Multiphysics} menu or in the \textit{Model Tree}.
Choose Physics>Scalar Settings to open the Scalar Settings dialog box.

In the Scalar contribution field on the Objective page, enter 
\[-2\pi \text{realdot}(p_m, \text{pm})/(\pi \cdot r_0^2 \cdot p_0^2)\].

Click the Variables tab. Enter Variable names \(q_1\), \(q_2\), \(q_3\), \(q_4\), and \(q_5\) on separate lines in the table, all with Init value 0.

Click the Scalar Constraints tab and limit the allowed value of each of the optimization variables to the range \([-1, 1]\). When you are done, the Scalar constraints table should look as follows:

<table>
<thead>
<tr>
<th>LB</th>
<th>EXPRESSION</th>
<th>UB</th>
</tr>
</thead>
<tbody>
<tr>
<td>-1</td>
<td>(q_1)</td>
<td>1</td>
</tr>
<tr>
<td>-1</td>
<td>(q_2)</td>
<td>1</td>
</tr>
<tr>
<td>-1</td>
<td>(q_3)</td>
<td>1</td>
</tr>
<tr>
<td>-1</td>
<td>(q_4)</td>
<td>1</td>
</tr>
<tr>
<td>-1</td>
<td>(q_5)</td>
<td>1</td>
</tr>
</tbody>
</table>

Click OK to close the dialog box.

**Generating the Mesh**
The model will be run at a frequency of 5000 Hz, corresponding to a wavelength of just under 7 cm. Using the standard at-least-six-elements-per-wavelength rule, a maximum element size of 1 cm seems like a good choice. A quad mesh is in general more resistant to element warping when the mesh is deformed. Therefore, use an unstructured quad mesh everywhere except in the PMLs, which perform better with a mapped mesh aligned with the radial and tangential directions.

Choose Mesh>Free Mesh Parameters.

Click the Custom mesh size option button, type 0.01 in the Maximum element size edit field, and then click OK to close the dialog box.

Go to Subdomain Mode by clicking the corresponding button on the main toolbar.

Select all subdomains except the PML, then click the Mesh Selected (Free, Quad) button on the Mesh toolbar.

To set the number of mesh layers in the PML, begin by selecting Mapped Mesh Parameters from the Mesh menu.

On the Boundary page, select Boundary 7 and then select the Constrained edge element distribution check box.

Set the Number of edge elements to 8, then click OK.
Click the **Mesh Remaining (Mapped)** button on the Mesh toolbar to complete the mesh.

**COMPUTING THE SOLUTION**

Before starting the actual optimization solver it is good practice to check the model set-up by running the sensitivity solver once. This way, you can also study the reference state on which you intend to improve.

1. Choose **Solve>Solver Parameters** or click the corresponding button on the Main toolbar to open the **Solver Parameters** dialog box.
2. Select **Parametric** from the **Solver** list and select the **Optimization/Sensitivity** check box.
3. In the **Parameter Names** field, enter the name of the frequency variable: `freq_acpr`.
4. As **Parameter values**, enter just 5000.
5. Click the **Optimization/Sensitivity** tab and verify that the **Analysis** is set to **Sensitivity** rather than **Optimization**.
6. Click **Apply** in the dialog box, then click the **Solve** button on the Main toolbar.

**POSTPROCESSING AND VISUALIZATION**

The default plot in the main window shows the mesh displacement in the Moving Mesh application mode. Because the initial optimization variable values are zero, so is the displacement. The acoustical quantities are far more interesting for visualization, but for clarity, the PML zone should not be included in the plot.

1. Click the **Plot Parameters** button on the Main toolbar to open the dialog box with that name.
2. On the **Surface** page, select **Pressure Acoustics (acpr)>Sound pressure level** from the list of **Predefined quantities**.
3. Click **OK** to close the dialog box and display the SPL value.
4. Go to **Subdomain Mode** by clicking the corresponding button on the Main toolbar.
5. Select the PML domain, then click **Hide Selected Objects**.
6 Return to **Postprocessing Mode** using the button on the Main toolbar.

7 To see the far-field SPL pattern, first choose **Postprocessing>Domain Plot Parameters**.

8 On the **Line/Extrusion** page, select Boundary 12 and find **Pressure Acoustics (acpr)>Sound pressure level for pf** in the list of **Predefined quantities**.

9 Click the lower option button in the **x-axis data** area, then click the **Expression** button to open the **X-Axis Data** dialog box.

10 Type `atan2(r,z)` in the **Expression** field, press Tab, and select the degree sign from the **Unit** list.

11 Click **OK** to close the dialog box, then click **Apply** in the **Domain Plot Parameters** dialog box to display the far-field pattern.

**COMPUTING THE SOLUTION**

Now return to solving the actual optimization problem. In this tutorial, the optimization is performed only for a single frequency. This can also be seen as a preparation step before starting a time-consuming optimization over a frequency range.

1 Return to the **Optimization/Sensitivity** page in the **Solver Settings** dialog box and change the **Analysis** type to **Optimization**.
2. Increase the **Optimality tolerance** to $10^{-4}$, which is still stricter than the accuracy of this low-resolution finite element model.

3. Optionally, to follow the optimization solver's progress, select the **Plot while solving** check box. When you run the optimization, the software then plots the SPL field (according to the current settings in the **Plot Parameters** dialog box) in a separate figure window and updates it after each model evaluation.

4. Click **OK** to close the dialog box, then click the **Solve** button on the Main toolbar.

The solution requires about 20 model evaluations, which should not take more than a minute on a modern computer. You can follow the

**POSTPROCESSING AND VISUALIZATION**

When the solution is ready, you can immediately study the optimal (within the constraints imposed by the parametrization) shape of the horn. To see a direct comparison of the far-field pattern before and after optimization (Figure 2-14) do the following:

1. Return to the **Domain Plot Parameters** dialog box, select again Boundary 12 on the **Line/Extrusion** page, and click the **Line Settings** button.

2. In the **Line Settings** dialog box, select **Color** from the **Line color** list. Click **OK**.

3. Click the **General** tab. Select the **Keep current plot** check box, then click **Apply**.

   The solution returned by the optimization solver is only guaranteed to be a local optimum within the given constraints. It is good practice to check whether any constraints imposed to keep the problem well posed (in this case avoid inverted mesh elements) are active at the optimum point. If some artificial constraint is active, try to relax it a little and restart the solution.

4. Choose **Postprocessing** > **Data Display** > **Global**.

5. From the **Predefined quantities** list, select **Optimization (opt)>q1**.

6. Click **Apply** and check that the value lies inside the specified range $-1 < q_1 < 1$.

7. Check $q_2$, $q_3$, $q_4$, and $q_5$ in the same way.

8. When done, click **OK**.

Because none of the parameters take on a limiting value, the obtained solution can be assumed independent of the artificial bounds.
Jet Pipe

Introduction

This example models the radiation of fan noise from the annular duct of a turbofan aeroengine. When the jet stream exits the duct, a vortex sheet appears along the extension of the duct wall. In the model you calculate the near field on both sides of the vortex sheet.

Model Definition

The model is axisymmetric with the symmetry axis coinciding with the engine’s centerline. The flows both inside and outside the duct are uniform mean flows, but because the flow velocities differ, a vortex sheet separates them.

The Aeroacoustics application mode in the Acoustics Module describes acoustic waves in a moving fluid with the potential, $\phi$, for the local particle velocity as the basic dependent variable; see the chapter “Aeroacoustics” on page 107 of the Acoustics Module User’s Guide for further details. However, the field equation is only valid when the velocity field is irrotational, a condition that is not satisfied across a vortex sheet. As a consequence, the velocity potential is discontinuous across this sheet. To model this discontinuity you use assemblies that are connected through pairs. The following boundary condition on the pair models the vortex sheet:
In these equations, \( \omega \) is the angular velocity, \( V \) is the mean flow velocity, \( w \) is the normal displacement, \( \phi \) is the velocity potential, and \( p \) is the pressure. The subscripts 1 and 2 refer to the two sides of the boundary.

The velocity normal to the vortex sheet is zero, which implies that the last term in the condition vanishes. In the model the variables are made dimensionless. The velocities are divided by the speed of sound in air and the densities are divided by the density for air. For example the model uses the Mach number \( M = \frac{V}{c_0} \) as the mean flow velocity. This leads to the boundary conditions

\[
\rho (i \omega + M_1 V_T) w = -n \cdot \left( \rho V \phi_1 - \frac{V}{c} \rho (i \omega \phi_1 + (V \phi_1 \cdot V)) \right)
\]

\[
\rho (i \omega + M_2 V_T) w = -n \cdot \left( \rho V \phi_2 - \frac{V}{c} \rho (i \omega \phi_2 + (V \phi_2 \cdot V)) \right)
\]

\[p_1 = p_2\]

where \( M \) denotes the transverse Mach number.

The duct has a hard wall, which you also model using a boundary condition on a pair.

The acoustic field inside the duct can be described as a sum of eigenmodes propagating in the duct and then radiating in the free space. This is discussed in section 2.1 in Ref. 1. In this example you study the radiated acoustic waves produced by a single eigenmode at a time. First you calculate the eigenmodes with the circumferential mode order 4 on the inlet boundary. From these eigenmodes, the one with radial mode order 0 is used as incident wave. You then calculate the velocity fields with circumferential mode numbers, \( m = 17 \) and 24 and with radial mode order, \( n = 0 \).

---

**Results and Discussion**

The boundary mode analysis made with the circumferential wave number \( m = 4, 17 \), and 24 gives several eigenmodes corresponding to different radial mode numbers. This
example, as well as in Ref. 1, uses the following eigenmodes as incident waves in the duct.

![Diagram](image)

**Figure 2-15:** (a) Mode shape for $m = 4, n = 0$; (b) Mode shape for $m = 17, n = 1$; (c) Mode shape for $m = 24, n = 1$.

The near field around the duct obtained by COMSOL Multiphysics can be compared to the results for the near field in Ref. 1. Figure 2-16 to Figure 2-18 show the near-field solution for a Mach number equal to 0.45 in the pipe and 0.25 on the outside. The figures show the field for the different eigenmodes shown in Figure 2-15.
Figure 2-16: The near-field solution for $m = 4$ and $n = 0$.

Figure 2-17: The near-field solution for $m = 17$ and $n = 1$. 
Figure 2-18: The near-field solution for $m = 24$ and $n = 1$.

Reference


Model Library path: Acoustics_Module/Tutorial_Models/jet_pipe

Modeling Using the Graphical User Interface

MODEL NAVIGATOR

1. In the Model Navigator go to the Space dimension list and select Axial symmetry (2D), then click the Multiphysics button.
2. From the list of application modes select Acoustics Module>Aeroacoustics>Boundary modal analysis. In the Dependent variables edit field type phi_b. Click Add.
3 From the list of application modes select Acoustics Module>Aeroacoustics>Time-harmonic analysis. Click Add.

4 Click OK.

**GEOMETRY MODELING**

1 From the Draw menu select Specify Objects>Rectangle.

2 Specify the following rectangles, all with Corner as the Position Base.

<table>
<thead>
<tr>
<th>RECTANGLE</th>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>R</th>
<th>Z</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>0.25</td>
<td>0.5</td>
<td>0.75</td>
<td>-0.5</td>
</tr>
<tr>
<td>R2</td>
<td>0.25</td>
<td>1</td>
<td>0.75</td>
<td>0</td>
</tr>
<tr>
<td>R3</td>
<td>0.25</td>
<td>0.2</td>
<td>0.75</td>
<td>1</td>
</tr>
<tr>
<td>R4</td>
<td>1</td>
<td>1.5</td>
<td>1</td>
<td>-0.5</td>
</tr>
<tr>
<td>R5</td>
<td>1.2</td>
<td>0.2</td>
<td>1</td>
<td>-0.7</td>
</tr>
<tr>
<td>R6</td>
<td>0.2</td>
<td>1.9</td>
<td>2</td>
<td>-0.7</td>
</tr>
<tr>
<td>R7</td>
<td>1.2</td>
<td>0.2</td>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>

3 Click the Zoom Extents button.

4 Select R1, R2, and R3, then click the Union button on the Draw toolbar.

5 Select R4, R5, R6, and R7, then click the Union button.

6 Select CO1 and CO2, then click the Create Pairs and Imprints button.

This completes the geometry-modeling state. The geometry in the drawing area of the user interface on your screen should now look like that in the figure below.
OPTIONS AND SETTINGS
Enter the following constants in the Constants dialog that you open from the Options menu. When finished, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>VALUE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>M0</td>
<td>0.25</td>
<td>Mach number outside the duct</td>
</tr>
<tr>
<td>M1</td>
<td>0.45</td>
<td>Mach number inside the duct</td>
</tr>
<tr>
<td>m</td>
<td>4</td>
<td>Circumferential wave number</td>
</tr>
</tbody>
</table>

PHYSICS SETTINGS

Units
1. From the Physics menu, select Model Settings.
2. Set the Base unit system to None.
3. Click OK.

Identity Pairs
1. From the Physics menu, select Identity Pairs>Identity Boundary Pairs.
2. Click New and check Boundary 8 as source boundary and Boundary 13 as destination boundary.
3. Select Pair 1 and clear the check boxes for Boundaries 8 and 13 that you selected in the previous step.
4. Click OK.

Subdomain Settings
1. From the Physics menu, open the Subdomain Settings dialog box.
2. Select Subdomains 1–3. Set $V_z$ to M1, and both $c_s$ and $\rho$ to 1.
3. Select Subdomains 4–9. Set $V_z$ to M0, and both $c_s$ and $\rho$ to 1.
4. Go to the PML page.
5. Select Subdomains 3, 4, 6, 7, and 9. Set Type of PML to Cylindrical and select the Absorbing in z direction check box.
   The settings that differ between the subdomains are now highlighted in yellow; these settings will not be affected unless you explicitly change them.
7. From the Type of PML list, select Cylindrical; this changes the setting for Subdomain 8. Select the Absorbing in r direction check box.
8. Click OK.
Boundary Conditions
1 From the **Multiphysics** menu, select **Aeroacoustics, Boundary Modal Analysis (acab)**.
2 From the **Physics** menu, open the **Boundary Settings** dialog box.
3 Select all boundaries and clear the **Active in this domain** check box.
4 Select Boundary 2 only, then select the **Active in this domain** check box.
5 Set $V_z$ to $M1$ and both $c_s$ and $\rho$ to 1.
6 Click **OK**.

Application Scalar Variables
1 From the **Physics** menu, select **Scalar Variables**.
2 Set the **Excitation frequency** to $30/(2*\pi)$ and the **Circumferential wave number** to $m$.
3 Click **OK**.

Generating the Mesh
1 From the **Mesh** menu, select **Mapped Mesh Parameters**.
2 From the **Predefined mesh sizes** list, select **Extremely fine**. Click **Remesh**.
3 When the mesh is finished, click **OK** to close the dialog box.

Computing the Solution
1 From the **Solve** menu, open the **Solver Parameters** dialog box.
2 Set **Desired number of propagation constants** to 10.
3 Click **OK**.
4 From the **Solve** menu, open the **Solver Manager**.
5 On the **Solve For** page, select **Aeroacoustics, Boundary Modal Analysis (acab)**.
6 Click **Apply**, then click **Solve**.
7 On the **Initial Value** page click the **Store Solution** button and click **OK** in the dialog box that appears to store all solutions.
8 Click **OK** in the **Solver Manager** dialog box to close it.

Postprocessing and Visualization
1 From the **Postprocessing** menu, select **Domain Plot Parameters**.
2 On the **Line/Extrusion** page select Boundary 2 and make sure the **Expression** is $p h i \_b$. 
On the **General** page select the value with the highest real part in the **Solutions to use** list. Click **Apply**.

The figure that appears is the same as in Figure 2-15 (a). This corresponds to the lowest radial mode \((n = 0)\).

You can look at higher modes by selecting values with lower real part in the **Solution to use** list.

When you solve for \(m = 17\) or \(24\) you can generate Figure 2-15 (b) or (c) by selecting the value with the second highest real part, \(n = 1\).

Click **OK** to close the dialog when you are ready.

**PHYSICS SETTINGS**

**Boundary Conditions**

1. From the **Multiphysics** menu select **Aeroacoustics (acae)**.
2. Select Boundary 2. Set the **Boundary condition** to **Velocity potential** and \(\phi_0\) to \(\phi_{\text{b}}\).
3. Go to the **Pairs** page and select **Pair 1**. Set the **Boundary condition** to **Vortex sheet**.
4. Select **Pair 2** and set the **Boundary condition** to **Sound hard boundary (wall)**.
5. Click **OK**.

**COMPUTING THE SOLUTION**

1. From the **Solve** menu, open the **Solver Manager**.
2. Set the **Initial value** to **Stored solution** and the **Propagation constant** to the one with highest real part to get the lowest radial mode.
3. On the **Solve For** page, select **Aeroacoustics (acae)**.
4. Click **OK**.
5. Open the **Solver Parameters** dialog and set the solver to **Stationary**. Click **OK**.
6. Click the **Solve** button on the Main toolbar.

**POSTPROCESSING AND VISUALIZATION**

Follow these steps to generate Figure 2-16 on page 51.

1. From the **Postprocessing** menu, open the **Plot Parameters** dialog box.
2. On the **Surface** page, select the **Surface plot** check box, then set the **Colormap** to **gray**.
3. On the **General** page, set the **Solution at angle (phase)** to 180.
4. Clear the **Boundary** check box in the **Plot type** area.
5. Click **OK**.
6 From the Options menu, choose Suppress>Suppress Subdomains.
7 Select Subdomains 3, 4, and 6–9, then click OK.
8 Click first the Postprocessing Mode button and then the Zoom Extents button.
You have now solved the example for the eigenmode $m = 4$ and $n = 0$. To generate Figure 2-17 on page 51 you need to solve the example with $m = 17$ and $n = 1$ and to generate Figure 2-18 you need to use $m = 24$ and $n = 1$. To solve the example again with a different eigenmode you can follow these steps.
1 From the Options menu, open the Constants dialog box.
2 Change the value of $m$ to 17 to generate Figure 2-17 or 24 to generate Figure 2-18 in the Constants dialog. Click OK.
3 From the Physics menu, select Boundary Settings.
4 Select Boundary 2 and set $\phi_0$ to 0, then click OK.
Go through the steps to solve the model once again with the new value of the circumferential mode number. Start from the section “Computing the Solution” on page 55.

When choosing the eigenmode to use as incident wave you need to take the one with second highest real part to get the radial mode number $n$ equal to 1.

Finally, the image you see when opening this model from the Acoustics Module model library is produced from the last obtained solution ($m = 24$, $n = 1$) with the following steps:
1 Click the Plot Parameters button on the Main toolbar.
2 On the General page, select the Contour check box and clear the one for Geometry edges.
3 Click the Surface tab.
4 From the Predefined quantities list on the Surface Data page, select Aeroacoustics (acae)>Sound pressure level.
5 From the Colormap list inside the Surface color area select jet.
6 On the Height Data page, select the Height data check box.
7 From the Predefined quantities list select Aeroacoustics (acae)>Sound pressure level.
8 Click the Contour tab.
9 From the Predefined quantities list on the Contour Data page select Aeroacoustics (acae)>Sound pressure level.
10 Inside the Contour levels area, select the option button next to the Vector with isolevels edit field. Type `linspace(60, 125, 66)` in this edit field to obtain a contour-line distance of 1 dB.

11 Clear the Color scale check box inside the Contour color area.

12 On the Height Data page, select the Height data check box.

13 From the Predefined quantities list, select Aeroacoustics (aca)>Sound pressure level.

14 Go to the General page and click the Title button.

15 Select the option button next to the edit field and enter the title `Sound pressure level (dB)`, then click OK to close the Title dialog box.

16 Click OK to generate the plot and close the Plot Parameters dialog box.

17 Click both the Scene Light button and the Perspective Projection button on the Camera toolbar to the left of the drawing area.

18 Double-click to clear the AXIS and CSYS buttons on the status bar at the bottom of the user interface.

19 Click the Zoom Extents button on the Main toolbar.

After rotating the view by clicking and dragging in the drawing area you should see a plot similar to that in the figure below.
Piezoacoustic Transducer

Introduction

A piezoelectric transducer can be used either to transform an electric current to an acoustic pressure field or, the opposite, to produce an electric current from an acoustic field. These devices are generally useful for applications that require the generation of sound in air and liquids. Examples of such applications include phased array microphones, ultrasound equipment, inkjet droplet actuators, drug discovery, sonar transducers, bioimaging, and acousto-biotherapeutics.

Model Definition

In a phased-array microphone, the piezoelectric crystal plate fits into the structure through a series of stacked layers that are divided into rows. The space between these layers is referred to as the kerf, and the rows are repeated with a periodicity, or pitch.

This model simulates a single crystal plate in such a structure. The element is rotationally symmetric, making it possible to use an axisymmetric 2D application mode in COMSOL Multiphysics.
In the air domain, the wave equation describes the pressure distribution:

\[ \frac{1}{\rho_0 c_s^2} \frac{\partial^2 p}{\partial t^2} + \nabla \cdot \left( \frac{1}{\rho_0} (\nabla p - q) \right) = Q \]  \hspace{1cm} (2-5)

For this model, assume that the pressure varies harmonically in time as

\[ p(x, t) = p(x)e^{i\omega t} \]

Hence Equation 2-5 simplifies to

\[ \nabla \cdot \left( \frac{1}{\rho_0} (\nabla p - q) \right) - \frac{\omega^2 p}{\rho_0 c_s^2} = Q \]  \hspace{1cm} (2-6)

Because there are no sources present, Equation 2-6 simplifies further to

\[ \nabla \cdot \left( \frac{1}{\rho_0} (\nabla p) \right) - \frac{\omega^2 p}{\rho_0 c_s^2} = 0 \]
The piezoelectric domain is made of the crystal PZT5-H, which is a common material in piezoelectric transducers. The structural analysis is also time harmonic although, for historical reasons, in structural-mechanics terminology it is a frequency response analysis.

The frequency is set to 300 kHz, which is in the ultrasonic range (dolphins and bats, for example, communicate in the range of 20 Hz to 150 kHz, while humans can only hear frequencies in the range 20 Hz to 20 kHz).

**BOUNDARY CONDITIONS**
A voltage of 100 V is applied to the upper part of the transducer, while the bottom part is grounded. At the interface between the air and solid domain, the boundary condition for the acoustics application mode is that the pressure is equal to the normal acceleration of the solid domain

\[ n \cdot \left( \frac{1}{\rho_0} \nabla p \right) = a_n \]

where \( a_n \) is the normal acceleration.

This drives the pressure in the air domain. The solid domain is on the other hand subjected to the acoustic pressure changes in the air domain. Because of the high voltage applied to the transducer, this load is probably negligible in comparison. Yet because the model is in 2D, it is possible to include this load and solve the full model simultaneously on any computer.

**Results and Discussion**

Figure 2-20 shows the pressure distribution in the air domain. This plot clearly shows how the PML (perfectly matched layer) absorbs the wave effectively.
Figure 2-20: Surface and height plot of the pressure distribution.

Figure 2-21 shows the pressure distribution along the air-solid interface. The acoustic pressure load is small in comparison to the electrical load, which is plotted in Figure 2-22 on page 63.
Figure 2-21: Acoustic pressure at the air-solid interface.

Figure 2-22: von Mises Stress along the air-solid interface.

The results from a far-field analysis appear in Figure 2-23 on page 64. This figure shows that the sound pressure level reaches a maximum right in front of the transducer. This result also shows that the sound pressure level is fairly low. Although humans cannot hear these high frequencies, it can be mentioned for comparison that 15 dB is about the same sound pressure level as rustling leaves. On the other hand, because this is just one element in an array of elements, a more detailed study is necessary in order to draw further conclusions.
In the Model Navigator, begin by selecting Axial symmetry (2D) from the Space dimension list, then click the Multiphysics button.

Navigate to Acoustics Module>Piezoelectric Effects>Piezo Axial Symmetry>Frequency response analysis, then click Add.

Select Acoustics Module>Pressure Acoustics>Time-harmonic analysis; then click Add.

Click OK to close the Model Navigator.

From the Physics menu, select Scalar Variables.

Select the Synchronize equivalent variables check box.

Enter a value of 200e3 Hz for the excitation frequency freq_smpaxi.

COMSOL Multiphysics automatically updates the other excitation frequency, freq_acpr, to the same value.
4. Click **OK**.

**GEOMETRY MODELING**

1. Draw a rectangle, R1, by first selecting **Draw>Specify Objects>Rectangle** and then specifying the following properties; when done, click **OK**.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>1e-3</td>
</tr>
<tr>
<td>Height</td>
<td>0.5e-3</td>
</tr>
<tr>
<td>Position, base</td>
<td>Corner</td>
</tr>
<tr>
<td>Position, r</td>
<td>0</td>
</tr>
<tr>
<td>Position, z</td>
<td>-0.5e-3</td>
</tr>
</tbody>
</table>

2. Click the **Zoom Extents** button on the Main toolbar to automatically fit the geometry to your window.

The geometry for the transducer is now complete. Continue by creating the acoustics domain, which consists of two domains: one air domain and one PML domain.

3. Choose **Draw>Specify Objects>Circle**. Specify a **Radius** of 4e-3, then click **OK**.

4. Choose **Draw>Specify Objects>Square**. Specify a **Width** of 4e-3, then click **OK**.

5. Click the **Zoom Extents** button on the Main toolbar.

6. Select the circle and the square, then click the **Intersection** button on the Draw toolbar.

7. Select the geometry object CO1. Press Ctrl+C to copy it, then press Ctrl+V and click **OK** in the dialog box that opens to paste the copy with no displacement.

8. Select the geometry object CO2, then click the **Scale** button. In the **Scale factor** area, type 1.5 in both the r and the z edit field. (You can select the geometry objects from a list in the **Create Composite Objects** dialog box.) Click **OK**.

9. Once again, click the **Zoom Extents** button on the Main toolbar to automatically fit the geometry to your window.

**SUBDOMAIN SETTINGS—PIEZO AXIAL SYMMETRY**

1. Select the **Piezo Axial Symmetry (smpaxi)** application mode from the **Model Tree** or from the **Multiphysics** menu.

2. From the **Physics** menu, choose **Subdomain Settings**.

3. Select Subdomains 2 and 3, then clear the **Active in this domain** check box.
4 Select Subdomain 1, then click the Load button.

5 From the Basic Material Properties library, select Lead Zirconate Titanate (PZT-5H).
   In the Piezoelectric Material Properties library, you find more than 20 additional
   piezoelectric materials.

6 Click OK to close the Materials/Coefficients Library dialog box.

**Note:** For a piezoelectric material, you can specify an orientation and a coordinate
system. In this model, use the default settings: the $xz$-plane in the global coordinate
system.

7 Click OK to close the Subdomain Settings dialog box.

**BOUNDARY CONDITIONS—PIEZO AXIAL SYMMETRY**

1 From the Physics menu, choose Boundary Settings.

2 On the Constraint page, enter the following structural boundary conditions:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 1</th>
<th>BOUNDARY 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constraint condition</td>
<td>Symmetry plane</td>
<td>Roller</td>
</tr>
</tbody>
</table>

3 Click the Electric BC tab, and set the electric boundary condition as follows:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 1</th>
<th>BOUNDARY 2</th>
<th>BOUNDARY 4</th>
<th>BOUNDARY 6</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Axial symmetry</td>
<td>Ground</td>
<td>Electric potential</td>
<td>Zero charge/Symmetry</td>
</tr>
<tr>
<td>$V_0$</td>
<td></td>
<td></td>
<td></td>
<td>100</td>
</tr>
</tbody>
</table>

4 Select Boundary 4.

5 On the Load page, type $-p$ in the $F_z$ edit field to specify the acoustic pressure load,
   and then click OK. $p$ is the name of the dependent variable for pressure in the
   Pressure Acoustics application mode. The pressure acts from the air toward the
   piezo domain (in the negative $z$ direction), which explains the minus sign in front
   of $p$. Click OK to close the dialog box.

**SUBDOMAIN SETTINGS—PRESSURE ACOUSTICS**

1 Select the Pressure Acoustics (acpr) application mode from the Model Tree or from
   the Multiphysics menu.

2 From the Physics menu, select Subdomain Settings.
3 Select Subdomain 1, then clear the **Active in this domain** check box.

4 Select Subdomain 3.

5 On the **PML** page, select **Spherical** from the **Type of PML** list.

6 Select the **Absorbing in radial dir.** check box, then enter a value of $2 \times 10^{-3}$. This value corresponds to the PML’s extension in the radial direction.

7 Set the inner PML radius, $R_0$, to $4 \times 10^{-3}$.

8 Click **OK** to close the dialog box.

Because the default values correspond to the properties of air, you do not have to specify the subdomain settings for Subdomain 2.

**BOUNDARY CONDITIONS—PRESSURE ACOUSTICS**

1 From the **Physics** menu, choose **Boundary Settings**.

2 Select Boundary 4, then select **Normal acceleration** as the boundary condition.

3 Set the value of the inward acceleration, $a_n$, to $w_{tt_smpaxi}$ (this is the second-order time derivative of the structural displacement).

4 Click **OK**.

**MESH GENERATION**

1 From the **Mesh** menu, choose **Free Mesh Parameters**.

2 On the **Global** page, click the **Custom mesh size** option button.

3 Specify a **Maximum element size** of $(343/200e3)/5$. This value corresponds to $1/5$th of the acoustic wavelength. For wave models it is important to use a mesh size sufficiently small to properly resolve the wavelength.

4 Click **Remesh**. When the mesher has finished, click **OK** to close the dialog box.

**COMPUTING THE SOLUTION**

1 Click the **Solver Parameters** button on the Main toolbar.

2 From the **Solver** list, select **Stationary**.

3 Click **OK** to close the dialog box.

4 Click the **Solve** button from the Main toolbar.

**POSTPROCESSING AND VISUALIZATION**

To reproduce the plot in Figure 2-20, proceed as follows:

1 Click the **Plot Parameters** button on the Main toolbar.
Click the Surface tab.

On the Surface Data page, select Pressure Acoustics (acpr)>Pressure from the Predefined quantities list.

On the Height Data page, select the Height data check box.

From the Predefined quantities list, select Pressure Acoustics (acpr)>Pressure.

Click OK to generate the plot.

Click the Headlight button on the Camera toolbar for clearer visualization.

To create Figure 2-21 and Figure 2-22 do the following:

1. Open the Domain Plot Parameters dialog box from the Postprocessing menu.
2. Go to the Line/Extrusion page.
3. In the Expression edit field, enter \( p \).
4. From the Boundary selection list, select boundary 4 and then click on Apply.
5. To plot von Mises stress along the same boundary (Figure 2-22), enter \( \text{mises}_\text{smpaxi} \) in the Expression edit field, and then click OK.

To create Figure 2-23, you need to define a far-field variable.

1. Assure that the Pressure Acoustics (acpr) is selected from the Model Tree, then open the Boundary Settings dialog box.
2. Select Boundary 10, then click the Far-Field tab.
3. Type \( p\_\text{far} \) in the Name edit field, then click OK.
4. From the Solve menu, choose Update Model.
5. From the Postprocessing menu, open the Domain Plot Parameters dialog box.
7. From the Predefined quantities list, select Pressure Acoustics (acpr)>Sound pressure level for \( p\_\text{far} \).
8. Click the Expression button in the x-axis data area, then click the Expression button.
9. In the Expression edit field, type \( \text{atan2}(z, r) \). Click OK.
10. Click OK to create Figure 2-23.
Transient Gaussian Explosion

Introduction

This model introduces some important concepts to have in mind when solving transient problems. In particular, it examines the relationship between the frequency content in the sources driving the model, the mesh resolution, and the time step.

Model Definition

An ellipse with sound-hard walls has the interesting property that an acoustic signal emanating from one of the foci refocuses at the other focal point \( b/c \) seconds later, where \( b \) (in meters) is the major axis length and \( c \) (m/s) is the speed of sound.

Inspired by Ref. 1 and Ref. 2, this model involves a Gaussian explosion at one focus of an ellipse to illustrate some properties of time-dependent acoustic problems. The major and minor axis lengths are 10 m and 8 m, respectively. The major axis coincides with the \( x \)-axis and the foci are located at \( x = -3 \) m and \( x = 3 \) m. Because of symmetry, the model can be limited to the upper half-plane.

Denoting the fluid density by \( \rho \) and the speed of sound by \( c_s \), the acoustic pressure field, \( p(x, t) \), inside the elliptical chamber is governed by the wave equation

\[
\frac{1}{\rho c_s^2} \frac{\partial^2 p}{\partial t^2} + \nabla \cdot \left( \frac{1}{\rho} \nabla p \right) = S(x, t)
\]
where the point-source term on the right-hand side is given by

\[ S(\mathbf{x}, t) = \frac{dg}{dt}(t) \delta^{(2)}(\mathbf{x} - \mathbf{x}_0) \]

The time dependence of the explosion is determined by the cutoff Gaussian pulse

\[ g(t) = \begin{cases} \quad A e^{-\pi f_0^2 (t - \tau)^2} & 0 < t < 2\tau \\ \quad 0 & \text{otherwise} \end{cases} \]

describing the rate of air flow (measured in \( m^2/s \)) away from the source, located at \( \mathbf{x} = \mathbf{x}_0 \). The parameter \( f_0 \), which is proportional to the pulse bandwidth, is chosen as \( f_0 = c/(Nh) \), where \( h \) is a typical mesh-element size, and \( N \) is the number of elements per wavelength required to resolve a harmonic wave with some accuracy. The following discussion uses \( N = 6 \), but \( N = 4 \) should be acceptable for many purposes.

As the following plots show, by taking \( \tau = 1/f_0 \) the pulse very closely approximates a full Gaussian, the effect of the cutoff tails being numerically insignificant.

![Normalized Gaussian pulse and its derivative.](image)

A particularly interesting property of the Gaussian function is that its Fourier transform is equally simple (neglect cutoff effects):

\[
G(\omega) = \int_{-\infty}^{\infty} g(t) e^{-i\omega t} dt = \frac{2A\sqrt{\pi}}{\omega_0} e^{-\omega^2 \omega_0^2} e^{-i\omega_0 t}
\]

where \( \omega_0 = 2\pi f_0 \). The magnitude of the Fourier transform falls off quickly for increasing angular frequencies, \( \omega \). Practically all the energy in the signal is contained in the frequency band \(-2\omega_0 < \omega < 2\omega_0\) with most of it concentrated between \(-\omega_0\) and \(\omega_0\).
Therefore, when using a forcing function of this type, it is enough to resolve wavelengths corresponding to the angular frequency, \(\omega_0\), which in turn corresponds to the frequency \(f_0\). The frequency was chosen on the basis of mesh-element size and resolving power of the spatial discretization, so, in practice, the pulse shape is a function of the mesh resolution. The important point is that there is little to gain in prescribing a forcing function that contains frequencies that the mesh cannot resolve.

In addition to controlling the pulse shape and the amount of time the solver needs to take a single time step, the mesh resolution imposes a restriction on the time step size. The relationship between mesh size and time-step size is closely related to the CFL number (Ref. 3), which is defined as

\[
\text{CFL} = \frac{c \Delta t}{h}
\]

This nondimensional number can be interpreted as the fraction of an element the wave travels in a single time step. A CFL number around 1 would correspond to the same resolution in space and time if the discretization errors were of the same size; however, that is normally not the case.

COMSOL Multiphysics uses by default the implicit second-order accurate method generalized-\(\alpha\) to solve transient acoustics problems (see the section “The Time-Dependent Solver” on page 391 of the COMSOL Multiphysics User’s Guide for more details) and in space the default is 2nd-order elements. Generalized-\(\alpha\) introduces some numerical damping of high frequencies, but much less than the BDF method.

The temporal discretization errors for generalized-\(\alpha\) are thus larger than the spatial discretization errors when 2nd-order elements are used in space. The limiting step size, where the errors are of roughly the same size, can be found somewhere at CFL < 0.2. You can get away with a longer time step if the forcing does not make full use of the mesh resolution, that is, if high frequencies are absent from the outset.

When the excitation contains all the frequencies the mesh can resolve, there is no point in using the automatic time-step control provided by the time-dependent solver. The tolerances in the automatic error control are difficult to tune when there is weak but important high-frequency content. Instead, you can use your knowledge of the typical mesh size, speed of sound, and CFL number to calculate and prescribe a fixed time step. To check that the accuracy is acceptable, it is recommended that you run a short sequence of typical excitations with progressively smaller time steps and check the convergence.
**Results and Discussion**

Using the properties of air for the medium and selecting a mesh density based on the parameters $h = 0.15$ m and $N = 6$ gives a pulse half-width of $t_0 = 2.624$ ms. To be on the safe side, requiring $\text{CFL} < 0.05$ gives a fixed time step of $0.02$ ms. The model runs for $0.035$ s so that you can study the refocusing at the right-hand focus point at roughly $0.0315$ s.

![Figure 2-25: The refocusing occurs at roughly 0.0315 s. An animation gives a better feeling for the process.](image)

For the selected combination of mesh size, pulse shape, and time step, the solution can be shown to be both smooth and accurate. Selecting a smaller value for $N$ leads to oscillations if the CFL number is small enough, while selecting a higher CFL number (and consequentially a larger time step) leads to an inaccurate solution.

The next figure shows the pressure along the left-hand part of the major axis at $t = 9$ ms—right after the wave is reflected from the apex at $x = -5$ m—for four
different CFL numbers: 0.2, 0.1, 0.05, and 0.025. The difference between the last two is small enough to call the solution practically converged.

Figure 2-26: The CFL number has a pronounced effect on the accuracy of the final solution. The difference is marked between CFL = 0.2 (dash-dot), CFL = 0.1 (dotted), and CFL = 0.05 (dashed), but essentially indiscernible between the latter time and CFL = 0.025 (solid line).

To get a better view of the graphs in Figure 2-26, go to the COMSOL Help Desk and open the PDF version of the Acoustics Module Model Library. At a magnification of 300% the lines are readily distinguishable.

Modeling in COMSOL Multiphysics

You set up this tutorial model using the transient analysis type in the Pressure Acoustics application mode of the Acoustics Module. For material properties and boundary conditions use the default settings, which correspond to an air-filled chamber with sound-hard walls.

The modeling instructions are written for a parameter set that gives a converged and stable solution. You are encouraged to experiment with the resolution number, $N$, the CFL number, and other parameters to see their effects on the result.
References


Model Library path: Acoustics_Module/Tutorial_Models/ gaussian_explosion

Modeling Using the Graphical User Interface

MODEL NAVIGATOR

1. In the Model Navigator, select 2D from the Space dimension list, then go to the list of application modes and select Acoustics Module>Pressure Acoustics>Transient analysis.

2. Click OK to close the Model Navigator.

GEOMETRY MODELING

1. Shift-click the Rectangle/Square button on the Draw toolbar. In the dialog box that appears, change the following settings, then click OK.

<table>
<thead>
<tr>
<th>Size</th>
<th>Width</th>
<th>Height</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>10</td>
<td>4</td>
</tr>
</tbody>
</table>

2. Zoom out by clicking the Zoom Extents button on the Main toolbar.

3. Shift-click the Ellipse/Circle button on the Draw toolbar. Modify the following entries, then click OK.

| A-semiaxes | 5 |
| B-semiaxes | 4 |

4. Press Ctrl+A to select both objects, then click the Intersection button.
5 Click the **Point** button, then draw a point at the coordinates (−3, 0).

The completed geometry in the drawing area should look like that in the figure below.

![Diagram of Point Settings](image)

**OPTIONS AND SETTINGS**

Choose **Options>Constants** and define the following constants; when finished, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>c_air</td>
<td>343[m/s]</td>
<td>Speed of sound in air</td>
</tr>
<tr>
<td>h_max</td>
<td>0.15[m]</td>
<td>Typical element size</td>
</tr>
<tr>
<td>N</td>
<td>6</td>
<td>Points per wavelength</td>
</tr>
<tr>
<td>A</td>
<td>4[m^2/s]</td>
<td>Point-source amplitude</td>
</tr>
<tr>
<td>f0</td>
<td>c_air/(h_max*N)</td>
<td>Frequency bandwidth</td>
</tr>
<tr>
<td>t0</td>
<td>1/f0</td>
<td>Pulse half width</td>
</tr>
<tr>
<td>CFL</td>
<td>0.05</td>
<td>CFL number</td>
</tr>
<tr>
<td>t_step</td>
<td>CFL*h_max/c_air</td>
<td>Maximum time step</td>
</tr>
</tbody>
</table>

Note the value of roughly $2\times10^{-5}$ s for the maximum time step; you will use this result at the solving stage.

**PHYSICS SETTINGS**

**Point Settings**

1. Choose **Physics>Point Settings**.

2. Select Point 2, then select **Gaussian pulse** from the **Type of source** list.
In the \( A \) edit field type \( A \) and in the \( f_0 \) edit field type \( f_0 \).

Click \textbf{OK}.

**GENERATING THE MESH**

With the choice of a typical mesh size of \( h = 0.15 \), the mesh must be made as isotropic as possible. You can accomplish this by setting the maximum mesh size explicitly while keeping the other mesh parameters relaxed.

1. Choose \textbf{Mesh} > \textbf{Free Mesh Parameters}.
2. Click the \textbf{Custom mesh size} option button and type \( 0.15 \) in the \textbf{Maximum element size} edit field.
3. Click the \textbf{Remesh} button, then click \textbf{OK}.

**COMPUTING THE SOLUTION**

1. Choose \textbf{Solve} > \textbf{Solver Parameters} or click the corresponding button on the Main toolbar to open the \textbf{Solver Parameters} dialog box.
2. Specify the output \textbf{Times} in the \textbf{Time stepping} frame as \( 0:0.0005:0.035 \).
3. Click the \textbf{Time Stepping} tab and set \textbf{Time step taken by solver} to \textbf{Manual}.
4. Set the time step to the value calculated from the chosen mesh density and the CFL number by typing \( 2 \times 10^{-5} \) in the \textbf{Time step} edit field. Click \textbf{OK} to close the dialog box.
5. Click the \textbf{Solve} button on the Main toolbar to start solving.

To compare the effect of different choices of CFL number and resolution parameter, \( N \), do the following:

6. Open the \textbf{Constants} dialog box, change \( N \) or \textbf{CFL} to some other interesting value, then click \textbf{Apply}.
7 If you changed the CFL number, check the new value of $t_{\text{step}}$ and transfer it to the \textit{Time step} edit field on the \textit{Time Stepping} page in the \textit{Solver Parameters} dialog box.

8 Solve again by clicking the \textit{Solve} button.

\textbf{POSTPROCESSING AND VISUALIZATION}

The default plot shows the pressure at the final time.

1 For a more attractive plot, click first the \textit{3D Surface Plot} button and then the \textit{Headlight} button on the Plot toolbar.

2 To see the solution close to the refocusing moment, click the \textit{Plot Parameters} button on the Main toolbar, select $0.0315$ from the \textit{Solution at time} list, then click \textit{OK}. The result should look like that in Figure 2-25 on page 72.

3 It is illustrative to animate transient problems in general and wave propagation in particular; you can do this by clicking the \textit{Animate} button on the Plot toolbar.
Ultrasound Scattering Off a Cylinder

Introduction

This model, which is inspired by a benchmark problem discussed in Ref. 1, exemplifies ultrasound acoustics modeling with the ultraweak variational formulation (UWVF) in a simple setting. The main advantage of the UWVF for modeling high-frequency acoustic phenomena is its economy with regards to computational complexity compared to low-order finite element analysis. This advantage stems from the property of the UWVF’s elements containing information about the solution to the Helmholtz scalar wave equation in free space.

Model Definition

The modeling domain, depicted in Figure 2-27, consists of a circle of radius 5 cm surrounded by a concentric annulus of outer radius 10 cm. In the circle domain, representing an obstacle, the speed of sound is $c_o = 3000 \text{ m/s}$ and the density $\rho_o = 2000 \text{ kg/m}^3$. Outside the circular obstacle, the speed of sound is $c_a = 1500 \text{ m/s}$ and the density $\rho_a = 1000 \text{ kg/m}^3$. From a location 1 cm outside the outer boundary of the annulus, a sound source emits cylindrical ultrasound waves of frequency $f_0 = 250 \text{ kHz}$, corresponding to wavelengths in the two domains of $\lambda_o = c_o/f_0 = 1.2 \text{ cm}$ and $\lambda_a = c_a/f_0 = 0.6 \text{ cm}$, respectively. On the outer annulus boundary, you impose a radiation boundary condition that absorbs outgoing cylindrical waves. This boundary condition also allows you to model the incoming waves.

![Figure 2-27: Modeling domain.](image-url)
Results and Discussion

Figure 2-28 shows the acoustic pressure field, $p$, using the wave colormap. The difference in wavelength between the two subdomains is clearly visible, as is the interference pattern between the incident and scattered waves. Notice also how no artificial distortion of the waves leaving the modeling domain can be discerned.

Figure 2-28: The acoustic pressure field. The wavelength inside the obstacle is twice that in the surrounding medium. A radiation boundary condition on the modeling domain’s outer boundary both specifies the source and absorbs outgoing waves.

The incoming and scattered waves are most easily distinguishable in the grayscale plots in Figure 2-29 of the pressure field’s real (left) and imaginary (right) parts. (Because COMSOL Multiphysics by default plots the real part of a time-harmonic variable such as $p(\mathbf{x}, t) = p(\mathbf{x})e^{i\omega t}$, the plots in Figure 2-28 and the left panel of Figure 2-29 depict the same quantity.)
You solve this problem using a mesh with 822 elements, shown in Figure 2-30. With the default Ultraweak Helmholtz elements of order 20, the resulting number of DOFs is 16,440. The solution time with the default UMFPACK solver is about 8.6 s with a peak memory usage of 481 MB on a machine running Windows Vista with a 2.6 GHz AMD Athlon X2 Dual Core 500 CPU and 2 GB of RAM. (Using the SPOOLES solver, the solution time is doubled but peak memory usage is reduced to 322 MB.)

Solving the same problem with the same resolution using 2nd-order Lagrange elements requires about 220,000 DOFs (the maximum element size set equal to 1/6th of a wavelength), and takes about five times longer and consumes roughly 75% more memory. In this simple comparison, the UWVF thus shows its strengths.
Reference


Model Library path: Acoustics_Module/Tutorial_Models/ultrasound_scattering

Modeling Using the Graphical User Interface

**MODEL NAVIGATOR**

1. In the Model Navigator, select **2D** from the **Space dimension** list.
2. From the list of application modes, select **Acoustics Module>Pressure Acoustics>Time-harmonic analysis with UWVF**.
3. Click **OK** to close the Model Navigator.

**GEOMETRY MODELING**

1. Shift-click the **Ellipse/Circle (Centered)** button on the Draw toolbar.
2. Specify a **Radius** of 0.1, then click **OK**.
3. Click the **Zoom Extents** button on the Main toolbar.
4. Repeat Steps 1–2 to add a second, concentric, circle, of radius 0.05.
5. Click in the drawing area and press Ctrl+A to select both circles.
6. Click the **Create Composite Object** button on the Draw toolbar. In the dialog box that appears, click **OK** to accept the default settings.
The finished geometry in the drawing area should look like that in the following figure.

![Diagram of a geometry with two concentric circles](image.png)

**OPTIONS**

**Constants**
1. From the **Options** menu, select **Constants**.
2. Enter the following names, expressions, and descriptions (the descriptions are optional); when done, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>c_o</td>
<td>3000[m/s]</td>
<td>Speed of sound in obstacle</td>
</tr>
<tr>
<td>c_s</td>
<td>1500[m/s]</td>
<td>Speed of sound in surrounding medium</td>
</tr>
<tr>
<td>rho_o</td>
<td>2000[kg/m³]</td>
<td>Density in obstacle</td>
</tr>
<tr>
<td>rho_s</td>
<td>1000[kg/m³]</td>
<td>Density in surrounding medium</td>
</tr>
<tr>
<td>f0</td>
<td>250[kHz]</td>
<td>Sound frequency</td>
</tr>
<tr>
<td>lda_o</td>
<td>c_o/f0</td>
<td>Wavelength in obstacle</td>
</tr>
<tr>
<td>lda_s</td>
<td>c_s/f0</td>
<td>Wavelength in surrounding medium</td>
</tr>
<tr>
<td>k_s</td>
<td>2*pi[rad]/lda_s</td>
<td>Wave number in surrounding medium</td>
</tr>
</tbody>
</table>

Note the values of the wavelengths, $\lambda_o = 12$ mm and $\lambda_s = 6$ mm, which are important for determining an appropriate mesh element size.

**Scalar Expressions**
1. From the **Options** menu, point to **Expressions**, and then select **Scalar Expressions**.
2. Define the following constants; when done, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>R</td>
<td>sqrt((x+0.11[m])^2+y^2)</td>
<td>Distance from source</td>
</tr>
<tr>
<td>p_in</td>
<td>(i/4)<em>(besselj(0,k_s</em>R)-i<em>bessely(0,k_s</em>R))</td>
<td>Incoming wave</td>
</tr>
</tbody>
</table>

The point-source expression, \( p_{\text{in}} \), representing the incoming wave is proportional to the 0th-order Hankel function of the 2nd kind:

\[
p_{\text{in}} = \frac{i}{4} H_0^{(2)}(k_s R) = \frac{i}{4}(J_0(k_s R) - i Y_0(k_s R))
\]

where \( R = \sqrt{(x-x_0)^2 + (y-y_0)^2} \) is the distance from the source location \((x_0,y_0)\).

**PHYSICS SETTINGS**

*Subdomain Settings*

1. From the **Physics** menu, choose **Subdomain Settings**.
2. Enter settings according to the following table; when done, click **OK**.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN 1</th>
<th>SUBDOMAIN 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \rho_0 )</td>
<td>( \rho_{\text{h}} )</td>
<td>( \rho_{o} )</td>
</tr>
<tr>
<td>( c_s )</td>
<td>( c_{\text{s}} )</td>
<td>( c_{o} )</td>
</tr>
</tbody>
</table>

*Boundary Conditions*

1. From the **Physics** menu, choose **Boundary Settings**.
2. Select Boundaries 1, 2, 5, and 8 (all segments of the outer boundary).
3. From the **Boundary condition** list, select **Radiation condition**.
4. For the outgoing wave, select **Cylindrical wave** from the **Wave type** list.
5 Click the $p_0 = p_1$ option button to use the application mode variable $p_{\text{in\_acpr}}$ for the incoming wave.

6 Click OK.

Scalar Variables

1 From the Physics menu, choose Scalar Variables.
2 Set the excitation frequency by changing the expression for $f_{\text{acpr}}$ to $f_0$.
3 Specify the incoming wave by changing the expression for $p_{\text{i\_acpr}}$ to $p_{\text{in}}$.
4 Click OK.

Generating the Mesh

To give acceptable accuracy, the Acoustics Module’s ultraweak variational formulation needs a relatively uniform mesh, governed by the maximum element size parameter, $h_{\text{max}}$, rather than by sharp geometry details. As a rule of thumb, when using the default UWVF settings, specifying an $h_{\text{max}}$ equal to or slightly larger than $2\lambda$ gives a good balance between convergence and accuracy.

Because the wavelength differs between the two subdomains in this model, specify $h_{\text{max}}$ at the subdomain level in the Free Mesh Parameters dialog box:

1 From the Mesh menu, select Free Mesh Parameters.
2 Click the Subdomain tab.
3 Specify the maximum element sizes in the two subdomains as follows:

<table>
<thead>
<tr>
<th>SETTING</th>
<th>SUBDOMAIN 1</th>
<th>SUBDOMAIN 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maximum element size</td>
<td>0.012</td>
<td>0.024</td>
</tr>
</tbody>
</table>

4 Click the Remesh button.

5 Click OK.

**COMPUTING THE SOLUTION**
Click the Solve button on the Main toolbar.

**POSTPROCESSING AND VISUALIZATION**
The default plot, shown in the following figure, displays the acoustic pressure field, $p$—or, more precisely, the real part of the complex quantity $|p|e^{i \arg(p)}$. The coarse appearance is a consequence of the ultraweak variational formulation’s high element order. Moreover, the jet colormap is not ideally suited for visualizing the wave pattern.

To modify the settings for element refinement and colormap, follow these steps:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, clear the Auto check box for Element refinement and type 20 in the associated element field (the order of the default Ultraweak Helmholtz elements).

3 On the Surface page, find the Surface color area. From the Colormap list, select wave.

4 Click Apply.

The wave colormap is ideally suited for visualizing waves, because of its clear distinction between the low and high ends of the scale. For optimal effect, the range
should be symmetric around zero, which then is rendered white. To ensure this feature for the current plot, you need to adjust the range slightly.

5 Click the **Range** button. Clear the **Auto** check box, then set **Min** to -0.0725 and **Max** to 0.0725 (these limits are sufficient for all phases of the pressure field). Click **OK**.

6 Click **Apply** to generate the plot in Figure 2-28.

Proceed to generate the plots in Figure 2-29 with the following steps:

7 In the **Expression** edit field on the **Surface Data** page, type `real(p)`.

   Because COMSOL Multiphysics plots the real part of a complex quantity by default, this setting only affects the plot title.

8 Change the **Colormap** to **gray** (or **grayprint**, if you want to print the plot on paper).

9 Click **Apply** to generate the plot in the left panel of Figure 2-29.

10 Change the entry in the **Expression** edit field to `imag(p)`.

11 Click **Apply** to generate the plot in the right panel.

12 Change the **Expression** to `p` and the **Colormap** to **wave**, then click **OK** to close the **Plot Parameters** dialog box with the plot you see when you open the model in the drawing area.
Industrial Models

This chapter contains a selection of models from the automotive and aerospace industries as well as a model of a loudspeaker.
Absorptive Muffler

Introduction

This model describes the pressure-wave propagation in a muffler for an internal combustion engine. The approach is generally applicable to analyzing the damping of propagation of harmonic pressure waves.

The model’s purpose is to show how to analyze both inductive and resistive damping in pressure acoustics. In addition to a 3D model in two versions—with and without resistive damping—this example includes a 2D analysis of propagation modes in the muffler chamber. It then calculates the transmission loss for the frequency range 50 Hz–1500 Hz.

Model Definition

The muffler—schematically depicted in Figure 3-1—consists of a 24-liter resonator chamber with a section of the centered exhaust pipe included at each end. In the first version of the model the chamber is empty. In the second version it is lined with 15 mm of absorbing glass wool.

Figure 3-1: Geometry of the lined muffler with the upper half removed. The exhaust fumes enter through the left pipe and exit through the right pipe.

Domain Equations

This model solves the problem in the frequency domain using the time-harmonic Pressure Acoustics application mode. The model equation is a slightly modified version of the Helmholtz equation for the acoustic pressure, \( p \):
\[ \nabla \cdot \left( \frac{-\nabla p}{\rho} \right) - \frac{\omega^2 p}{c_s^2 \rho} = 0 \]

where \( \rho \) is the density, \( c_s \) equals the speed of sound, and \( \omega \) gives the angular frequency.

In the absorbing glass wool, the damping enters the equation as a complex speed of sound, \( c_c = \omega/k_c \), and a complex density, \( \rho_c = k_c Z_c/\omega \), where \( k_c \) is the complex wave number and \( Z_c \) equals the complex impedance.

For a highly porous material with a rigid skeleton, the well-known model of Delany and Bazley estimates these parameters as functions of frequency and flow resistivity. Using the original coefficients of Delany and Bazley (Ref. 1), the expressions are

\[
\begin{align*}
\frac{k_c}{k_a} &= \left(1 + 0.098 \cdot \left( \frac{\rho_a f}{R_f} \right)^{-0.7} - i \cdot 0.189 \cdot \left( \frac{\rho_a f}{R_f} \right)^{-0.595} \right) \\
\frac{Z_c}{Z_a} &= \left(1 + 0.057 \cdot \left( \frac{\rho_a f}{R_f} \right)^{0.734} - i \cdot 0.087 \cdot \left( \frac{\rho_a f}{R_f} \right)^{-0.732} \right)
\end{align*}
\]

where \( R_f \) is the flow resistivity, and where \( k_a = \omega/c_a \) and \( Z_a = \rho_a c_a \) are the free-space wave number and impedance of air, respectively. You can find flow resistivities in tables.

For glass-wool-like materials, Bies and Hansen (Ref. 2) give an empirical correlation

\[
R_f = \frac{3.18 \cdot 10^{-9} \cdot \rho_{ap}^{1.53}}{d_{av}^2}
\]

where \( \rho_{ap} \) is the material’s apparent density and \( d_{av} \) is the mean fiber diameter. This model uses a rather lightweight glass wool with \( \rho_{ap} = 12 \text{ kg/m}^3 \) and \( d_{av} = 10 \text{ \mum} \).

**BOUNDARY CONDITIONS**

The boundary conditions are of three types.

- At the solid boundaries, which are the outer walls of the resonator chamber and the pipes, the model uses sound hard (wall) boundary conditions:
  \[ \left( -\frac{\nabla p}{\rho} \right) \cdot n = 0 \]

- The boundary condition at the inlet involves a combination of incoming and outgoing plane waves:
In this equation, $p_0$ represents the applied outer pressure, $\Delta_T$ is the boundary tangential Laplace operator, and $i$ equals the imaginary unit (see Ref. 3). This boundary condition is valid as long as the frequency is kept below the cutoff frequency for the second propagating mode in the tube.

- At the outlet boundary, the model specifies an outgoing plane wave:

$$\mathbf{n} \cdot \frac{1}{\rho_0} \nabla p + i \frac{k}{\rho_0} p + \frac{i}{2k} \Delta_T p = 0$$

The wave numbers and mode shapes through a cross section of the chamber are found as the solution of a related eigenvalue problem:

$$\nabla \cdot \left( \frac{\nabla p(y,z)}{\rho_0} \right) - \left( \frac{\omega^2}{\rho_0 c^2} - \frac{\kappa_x^2}{\rho_0} \right) p(y,z) = 0$$

For a given angular frequency $\omega = 2\pi f$, only modes such that $\kappa_x^2$ is positive can propagate. The cutoff frequency of each mode is calculated as

$$f_j = \frac{\sqrt{\omega^2 - c^2 \kappa_x^2}}{2\pi}$$

**Results and Discussion**

The following equation defines the attenuation (in dB) of the acoustic energy, $d_w$:

$$d_w = 10 \log \left( \frac{w_o}{w_i} \right)$$

Here $w_o$ and $w_i$ denote the outgoing power at the outlet and the incoming power at the inlet, respectively. You can calculate each of these quantities as an integral over the corresponding surface:

$$w_o = \int_{\partial \Omega} \frac{|p|^2}{2\rho c_s} dA$$
Figure 3-2 shows the result of a parametric frequency study for the case of an empty muffler without any absorbing material. The plot shows that the damping works rather well for most low frequencies with the exception of a few distinct dips where the muffler chamber displays resonances.

At frequencies higher than approximately 1250 Hz, the plot’s behavior is more complicated and there is generally less damping. This is because, for such frequencies, the tube supports not only longitudinal resonances but also cross-sectional propagation modes. The first propagation mode that is excited is symmetric with respect to both the y-axis and the z-axis. Figure 3-3 shows this mode, which for an infinitely long chamber occurs at 1239 Hz. Not very far above this frequency a whole

\[
    w_i = \int_{\partial \Omega} \frac{p_0^2}{2 \rho c_s} dA
\]
range of modes that are combinations of this propagation mode and the longitudinal modes participate, making the damping properties increasingly unpredictable.

*Figure 3-3: The chamber’s first symmetric propagation mode. The plot shows the absolute value of the pressure.*
The glass-wool lining improves attenuation at higher frequencies. Figure 3-4 shows the attenuation with a layer of lining on the chamber’s upper and lower walls.

Figure 3-4: Attenuation (dB) in the absorbing muffler as a function of frequency (Hz). The dips are still present, but the general trend is that the higher the frequency, the better the damping.

Modeling in COMSOL Multiphysics

Setting up this model in COMSOL Multiphysics requires the Acoustics Module. You employ two application modes: Pressure Acoustics for the full 3D model, and Boundary Modal Analysis for the propagating mode analysis.

The software has predefined expressions for the Delany-Bazley coefficients, so the only damping parameter you must supply is the flow resistivity.

The parametric solver provides results for a range of frequencies. The software computes integrals in the power expressions using boundary integration coupling variables, and it plots the resulting attenuation versus frequency.
References


**Model Library path:** Acoustics_Module/Industrial_Models/absorptive_muffler

---

**Modeling Using the Graphical User Interface—Rigid Walls**

**MODEL NAVIGATOR**

1. In the **Model Navigator** find the **Space dimension** list and select 3D.

2. In the list of application modes select **Acoustics Module>Pressure Acoustics>Time-harmonic analysis**.

3. Click **OK** to close the **Model Navigator**.

**OPTIONS AND SETTINGS**

Choose **Options>Constants** and enter the data in this table (the descriptions are optional); when finished, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>c_air</td>
<td>343[m/s]</td>
<td>Speed of sound in air</td>
</tr>
<tr>
<td>p0</td>
<td>1[Pa]</td>
<td>Amplitude of incoming pressure wave</td>
</tr>
</tbody>
</table>

**GEOMETRY MODELING**

1. Choose **Draw>Work-Plane Settings**. Go to the **Quick** page and select the y-z option button, then in the x edit field type 0. Click **OK**.
Create four circles with the specifications in the following table. Use the Circle dialog box, which you open by shift-clicking the Ellipse/Circle (Centered) button on the Draw toolbar; after specifying each cylinder, click OK.

<table>
<thead>
<tr>
<th>RADIUS</th>
<th>BASE CENTER</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>0.075</td>
<td>-0.075 0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>0.075</td>
<td>0.075 0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>0.06</td>
<td>-0.075 0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>0.06</td>
<td>0.075 0</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Shift-click the Rectangle/Square button on the Draw toolbar. Create two rectangles with the following specifications; after each rectangle, click OK.

<table>
<thead>
<tr>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>BASE CENTER</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>0.15</td>
<td>0.15</td>
<td>0 0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>0.15</td>
<td>0.12</td>
<td>0 0</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Choose Draw>Create Composite Object. In the dialog box that appears, enter the Set formula as C1+C2+R1. Clear the Keep interior boundaries check box, then click Apply to create a union of these objects.

In the same dialog box, enter the Set formula as C3+C4+R2. Click OK to create the union and close the dialog box.

Choose Draw>Extrude. Select both objects, type 0.6 in the Distance edit field, and click OK.

Shift-click the Cylinder button on the Draw toolbar. Specify properties according to the first line in the following table, then click OK to create the cylinder.

<table>
<thead>
<tr>
<th>RADIUS</th>
<th>HEIGHT</th>
<th>AXIS BASE POINT</th>
<th></th>
<th></th>
<th>AXIS DIRECTION VECTOR</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>0.04</td>
<td>0.15</td>
<td>-0.15 0</td>
<td></td>
<td></td>
<td>1 0 0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>0.04</td>
<td>0.15</td>
<td>0.6 0</td>
<td></td>
<td></td>
<td>1 0 0</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Repeat the previous step but enter the properties on the second table row.

Click the Zoom Extents button on the Main toolbar.
If you select all the objects, the geometry should now look like that in Figure 3-5.

**PHYSICS SETTINGS**

**Subdomain Settings**
In the second version of this model you insert a lining in Subdomain 2. For now, however, the muffler is completely hollow. Leave all subdomain settings at their default values, which represent air.

**Boundary Conditions**

2. Go to the Boundary list and Ctrl-click to select Boundaries 1 and 28.
3. From the Boundary condition list select Radiation condition. Leave the Wave type at the corresponding default selection, which is Plane wave.
4. Select Boundary 1 only, and in the \( p_0 \) edit field type \( p_0 \).
   
   This setting results in a pressure source value of \( p_0 \) on Boundary 1, and a setting of 0 on Boundary 28. On all other boundaries use the default condition, Sound hard boundary (wall).
5. Click OK to confirm the settings and close the dialog box.
**Coupling Variables**

1. Choose Options > Integration Coupling Variables > Boundary Variables.

2. In the Boundary Integration Variables dialog box select Boundary 1, then create a boundary integration variable with the Name w\_in and defined by the Expression \( p_0^2/(2\\rho_{acpr}\cdot c_{s_acpr}) \).

3. Select Boundary 28 and create a second boundary integration variable. To do so, add it to the second row of the table with the Name w\_out and define it by the Expression \( \text{abs}(p)^2/(2\rho_{acpr}\cdot c_{s_acpr}) \).

4. Click OK.

**Mesh Generation**

1. From the Mesh menu open the Free Mesh Parameters dialog box.

2. From the Predefined mesh sizes list select Coarse.

3. Click the Custom element size button and type 1.2 in the Resolution of narrow regions edit field.

4. On the Advanced page go to the x-direction scale factor edit field and type 0.25.

5. Click OK.

6. Click the Initialize Mesh button on the Main toolbar to generate the mesh.

**Computing the Solution**

1. From the Solve menu open the Solver Parameters dialog box.

2. In the Solver list select Parametric.

3. In the Parameter name edit field type freq\_acpr, and in the Parameter values edit field type 50:25:1500. This setting computes the solution for frequencies from 50 Hz to 1500 Hz in steps of 25 Hz.

**Note:** The solution process as set up here takes approximately 10 minutes. If you want to run a faster but less detailed analysis, try a frequency range of 100 Hz to 1500 Hz with a step of 50 Hz; to do so, type 100:50:1500 in the Parameter values edit field.

4. Click OK.

5. Click the Solve button on the Main toolbar to compute the solution.
POSTPROCESSING AND VISUALIZATION

The default plot shows the pressure on five equidistant slices of the geometry at 1500 Hz, the last frequency in the frequency sweep. To get a better view of what goes on inside the muffler, you might want to look at other slices.

1. From the Postprocessing menu open the Plot Parameters dialog box.
2. On the Slice page set the Number of levels to 1 along all three coordinate directions.
3. Click Apply to generate the plot.
4. On the General page go to the Solution to use area, where you can select which frequency to look at among the entries in the Parameter value list. Try, for example, 1250 Hz, which is just where the damping becomes less efficient.
5. Click the Slice tab and type abs(p) in the Expression edit field.
6. Click Apply to generate the new plot.

As you can see, the pressure field varies primarily with the y-coordinate, while it is nearly constant in the z direction. The reason is that 1250 Hz is just higher than the cutoff frequency for the first symmetric propagating mode, which is excited by the incoming wave. You can get an indication of the mode’s shape by looking at a cross section of the chamber:

7. Click the Go to YZ View button on the Camera toolbar to the left of the drawing area. Take a quick glance at Figure 3-3, which shows the true shape of the corresponding eigenmode for an infinite tube with the same cross section as the chamber; this should resemble what you have. In the last exercise for this model you reproduce the eigenmode calculation.

As an alternative way of visualizing the pressure, try an isosurface plot.

1. Click the Go to Default 3D View button on the Camera toolbar.
2. In the Plot Parameters dialog box, go to the General page. Clear the Slice check box and select the Isosurface check box.
3. On the Isosurface page, enter 15 for the Number of levels.
4. On the General page, select 1400 from the Parameter value list.
5. Click OK to close the dialog box and generate the plot.
Click the **Scene Light** button on the Camera toolbar to make the pressure field look even nicer.

**Figure 3-6: The pressure field in the muffler for a frequency of 1400 Hz.**

To study the attenuation as a function of frequency, plot some global variables.

1. Choose **Postprocessing>Global Variables Plot**.
2. In the **Expression** edit field type $10 \times \log_{10}(w_{\text{in}}/w_{\text{out}})$. Click the > button next to the edit field to copy your expression to the **Quantities to plot** list.
3. Click **OK** to see the plot, which should look like the one in Figure 3-2.

**Absorptive Muffler—Absorbing Walls**

In this, the second version of the model, you line the muffler with a layer of absorptive glass wool. Continue working from where you left off with the model developed thus far and make the following changes and additions.
**OPTIONS AND SETTINGS**

Choose **Options>Constants**. In the resulting dialog box, retain the existing constants and add new ones according to the following table; when done, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>rho_ap</td>
<td>12</td>
<td>Apparent density of glass wool (kg/m^3)</td>
</tr>
<tr>
<td>d_av</td>
<td>10e-6[m]</td>
<td>Mean fiber diameter</td>
</tr>
<tr>
<td>R_f</td>
<td>3.18e-9[N*s/m^4]*rho_ap^1.53/d_av^2</td>
<td>Flow resistivity (Ns/m^4)</td>
</tr>
</tbody>
</table>

**PHYSICS SETTINGS**

**Subdomain Settings**

Choose **Physics>Subdomain Settings**. In the resulting dialog box select Subdomain 2 and change its settings according to the following table; when done, click **OK**.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type of damping</td>
<td>Delany-Bazley</td>
</tr>
<tr>
<td>R_f</td>
<td>R_f</td>
</tr>
</tbody>
</table>

**COMPUTING THE SOLUTION**

Click the **Solve** button on the Main toolbar to compute the solution.

**POSTPROCESSING AND VISUALIZATION**

Looking at the pressure field at a selection of frequencies, it is clear that the damping is now better than before, especially at higher frequencies. To see the attenuation and reproduce Figure 3-4, return to the **Global Variables Plot** dialog box and again plot 10*log10(w_in/w_out).

**Absorptive Muffler—Propagating Mode Analysis**

As an additional exercise, use a 2D perpendicular boundary mode analysis to calculate the chamber’s propagating eigenmodes.

**Model Library path:** Acoustics_Module/Industrial_Models/muffler_eigenmodes
MODEL SETTINGS
1 Choose Multiphysics>Model Navigator.
2 From the list of application modes select Acoustics Module>Pressure Acoustics>Boundary modal analysis, then click Add.
3 From the Ruling application mode list select Pressure Acoustics, Boundary Modal Analysis (acbm).
4 Click OK.

PHYSICS SETTINGS

Boundary Conditions
The model performs a boundary-mode analysis on a cross section of the muffler, so you should deactivate it elsewhere. Keep the default boundary conditions for air and the wall-edge conditions.
1 Choose Physics>Boundary Settings.
2 Select all boundaries and clear the Active in this domain check box.
3 Select Boundaries 6, 9, and 16, then select the Active in this domain check box.
4 Click OK to confirm and close the dialog box.

Scalar Variables
1 Choose Physics>Scalar Variables and set the value of freq_acbm to 1500. This means that the software looks for propagating modes with cutoff frequencies as high as 1500 Hz.
2 Click OK to close the Application Scalar Variables dialog box.

COMPUTING THE SOLUTION
1 Open the Solver Manager dialog box either by clicking the corresponding button on the Main toolbar or from the Solve menu.
2 On the Solve For page instruct the software to solve only for p2, then click OK.
3 Open the Solver Parameters dialog box.
4 From the Solver list select Eigenvalue.
5 On the General page go to the Propagation constant area. In the Desired number of propagation constants edit field type 8, and in the Search for propagation constants around edit field type 20.
6 Click OK.
7 Click the Solve button on the Main toolbar.
You should expect to find the free-space propagation mode with a propagation constant equal to $\omega/c = 27.5 \text{ rad/m}$, along with all other propagating modes—the higher the mode, the lower the propagation constant. In this case there are five propagating modes all together. However, the solver does not stop at zero but instead moves on to find three damped modes with imaginary propagation constants.

**POSTPROCESSING AND VISUALIZATION**

Visualize the boundary eigenmodes as follows:

1. Open the **Plot Parameters** dialog box.
2. On the **General** page clear the **Isosurface** check box and select the **Boundary** check box.
3. Click the **Boundary** tab and type p2 in the **Expression** edit field.
4. Return to the **General** page and study the propagating modes by selecting, in turn, the real-valued entries in the **Propagation constant** list, then clicking **Apply** to generate each plot.

Next calculate the cutoff frequencies for the five propagating modes.

1. Choose **Postprocessing>Data Display>Global**. In the **Expression** edit field type $\sqrt{(\omega_{acb}^2-kz_{acb}^2)c_{air}^2)/(2\pi)}$.
2. Select a real-valued entry in the **Propagation constant** list, then click **Apply** to evaluate the corresponding cutoff frequency.

The following is a list of the cutoff frequencies that you should obtain when repeating the last step for all five propagating modes, together with their symmetry properties:

<table>
<thead>
<tr>
<th>CUTOFF FREQUENCY (HZ)</th>
<th>CHARACTERISTICS</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Plane wave</td>
</tr>
<tr>
<td>635</td>
<td>Antisymmetric with respect to $\gamma$, symmetric with respect to $z$</td>
</tr>
<tr>
<td>1209</td>
<td>Symmetric with respect to $\gamma$, antisymmetric with respect to $z$</td>
</tr>
<tr>
<td>1239</td>
<td>Symmetric with respect to $\gamma$ and $z$</td>
</tr>
<tr>
<td>1466</td>
<td>Antisymmetric with respect to $\gamma$ and $z$</td>
</tr>
</tbody>
</table>

Finally, to reproduce the plot in Figure 3-3 for the symmetric propagating mode, follow these steps:
1. In the Plot Parameters dialog box go to the General page and select the symmetric mode (propagation constant equal to 15.5 m\(^{-1}\)).

2. Click the Boundary tab and type abs(p2) in the Expression edit field.

3. Click OK to generate the plot.

The mode shape you see should resemble the profile of the propagating-wave solution at 1250 Hz derived in the time-harmonic 3D analysis of the model.
**Car Interior**

**Introduction**

In this model, a point source generates a pressure wave in the Sound Brick, a test bench car interior (Ref. 1). The sound level is measured at another point and at a range of frequencies high enough that a good mesh resolution is required to properly resolve the wave. To get an idea of the accuracy of the model, the sound level is studied using a couple of different resolutions.

**Model Definition**

The geometrical and material parameters in this model come from Ref. 2. For the dimensions of the Sound Brick see Figure 3-7.

For the harmonic sound waves of acoustic pressure, \( p(\mathbf{x}, t) = p(\mathbf{x})e^{i\omega t} \), that you study in this model, the following frequency-domain Helmholtz equation applies for \( p(\mathbf{x}) \):

\[
\nabla \cdot \left( \frac{1}{\rho_0} \nabla p \right) - \frac{\omega^2 p}{\rho_0 c_s^2} = Q
\]

Here \( \rho_0 \) is the density (kg/m\(^3\)), \( \omega = 2\pi f \) denotes the angular frequency (rad/s), \( c_s \) refers to the speed of sound (m/s), and \( Q \) (1/s\(^2\)) is a monopole source.

A point source flow of strength \( S = 10^{-5} \text{ m}^3/\text{s} \) located at the point \( \mathbf{R}_0 = (0.21, 0, 1.28) \) drives the system, so that

\[
Q = \omega S \delta^{(3)}(\mathbf{R} - \mathbf{R}_0)
\]

where \( \delta^{(3)}(\mathbf{R}) \) is the 3D Dirac delta function. Assume, furthermore, that the walls of the Sound Brick are perfectly reflecting.

The sound level is measured at the point \( \mathbf{R}_1 = (1.34, 1.22, 0.8) \) at a range of frequencies from 490 Hz to 500 Hz.
Figure 3-7: The geometry of the car interior. The dimensions are length × height × depth = 3.0 m × 1.4 m × 1.7 m. The windshield has its lower end 0.8 m above the floor and with an inclination such that the entire volume of the geometry is 6.5 m³.
Results and Discussion

Figure 3-8 shows the sound pressure distribution in the car interior at 500 Hz.

![Slice plot of the sound pressure distribution at 500 Hz.](image)

A direct comparison of the computational results with those published in Ref. 2 is difficult for two reasons:

- The sampling frequency is too small to resolve some of the resonances at the higher frequencies
- The amplitude for the point source is not given

Nevertheless, it is possible to examine the accuracy of the results by studying how they converge when using successively greater mesh resolutions.

Table 3-1 shows how the number of wavelengths per element (first column) and the resulting number of degrees of freedom (second column) affect the memory usage (third column) and the time needed to solve for each frequency (fourth column). The fifth column indicates the line style used in Figure 3-9. The numbers were measured
while solving on a workstation running Windows Vista with a 2.6 GHz AMD Athlon X2 Dual Core 500 CPU and 2 GB of RAM.

To provide an idea of the accuracy of the various solutions, Figure 3-9 shows the measured sound level between 490 Hz and 500 Hz, computed at 0.1 Hz intervals for the listed mesh resolutions. As you can see in the plot, all the curves follow each other closely except at the dips and peaks, where the curves for the two coarsest meshes are off somewhat in frequency and substantially in amplitude. The two finest meshes agree very well on the location of the resonances but differ regarding the amplitude. This is because without energy losses in the system, the resonances are singular. A perfect resolution in space and time would result in infinite sound levels in the peaks and absolutely no sound in the dips. In real-life applications, the extremes would be much less pronounced than in the plot because the sound sources are rarely point-like and

<table>
<thead>
<tr>
<th>ELEMENTS PER WAVELENGTH</th>
<th>DOFS</th>
<th>MEMORY (MB)</th>
<th>SOLUTION TIME PER FREQUENCY (S)</th>
<th>LINE STYLE</th>
</tr>
</thead>
<tbody>
<tr>
<td>5.6</td>
<td>85,733</td>
<td>300</td>
<td>5</td>
<td>Dotted</td>
</tr>
<tr>
<td>6.4</td>
<td>125,413</td>
<td>360</td>
<td>8</td>
<td>Dash-dot</td>
</tr>
<tr>
<td>7.2</td>
<td>179,335</td>
<td>520</td>
<td>12</td>
<td>Dashed</td>
</tr>
<tr>
<td>8.0</td>
<td>248,791</td>
<td>720</td>
<td>20</td>
<td>Solid</td>
</tr>
</tbody>
</table>
the walls are usually not perfectly reflecting. In such cases, you can expect a similar solution accuracy at the peaks and the dips as in between them.

![Figure 3-9: Sound pressure level (dB) at the point of measurement as a function of frequency for a few different mesh densities. For a legend see Table 3-1.](image)

**Modeling in COMSOL Multiphysics**

You set up the Sound Brick model using the Acoustics Module’s Pressure Acoustics application mode. The GMRES solver with the Geometric Multigrid preconditioner ensures low memory consumption at a high mesh resolution.

The preconditioner operates on two meshes:

- An initial mesh that you specify, on which a coarse approximation to the solution is computed.
- An automatically generated mesh, finer than the initial one, on which the final solution is obtained.

In the case treated in the step-by-step instructions, you generate the initial mesh by specifying a maximum element size of \( L/3.2 \), where \( L = c_s/f \) is the free-space wavelength of the sound waves at 500 Hz. The maximum element size that the
preconditioner can handle for 2nd-order Lagrange elements is just less than $L/2$, as given by the Nyquist criterion. However, using such a coarse mesh would give an ill-conditioned problem, resulting in higher memory usage and a longer solution time.

During the solution procedure, COMSOL Multiphysics automatically generates a finer mesh from the coarse one using a regular refinement method where every element is split into eight identical smaller elements. The maximum element size is hence smaller by a factor of two compared to the original mesh. It follows that the rule-of-thumb minimum of ten to twelve degrees of freedom per wavelength for the solution to be reliable is fulfilled.

For a detailed description of the geometric multigrid technique and its use in modeling, see the section “The Geometric Multigrid Solver/Preconditioner” on page 555 of the COMSOL Multiphysics Reference Guide.

References

1. The Sound Brick is located in Acoustic Competence Centre, Inffeldgasse 25, A-8010 Graz, Austria. Web site: http://www.accgraz.com


Model Library path: Acoustics_Module/Industrial_Models/car_interior

Modeling Using the Graphical User Interface

MODEL NAVIGATOR

1 In the Model Navigator select 3D from the Space dimension list.
2 From the list of application modes select Acoustics Module>Pressure Acoustics>Time-harmonic analysis.
3 Click OK to close the Model Navigator.

GEOMETRY MODELING

4 Choose Draw>Work-Plane Settings. On the Quick tab select z-x y: 0, then click OK.
5 Choose **Draw>Specify Objects>Line**. In the dialog box that appears, make the following entries; when done, click **OK**.

<table>
<thead>
<tr>
<th>Coordinates x</th>
<th>0 1.4 1.4 0.8 0</th>
</tr>
</thead>
<tbody>
<tr>
<td>Coordinates y</td>
<td>0 0 1.7451 3 3</td>
</tr>
<tr>
<td>Style</td>
<td>Closed polyline (solid)</td>
</tr>
</tbody>
</table>

6 Choose **Draw>Extrude**. Make sure the object you just created (CO1) is selected, then type 1.7 in the **Distance** edit field. Click **OK** to extrude CO1 and close the dialog box.

7 Choose **Draw>Point**. In the dialog box that appears, make the following entries:

<table>
<thead>
<tr>
<th>Coordinates x</th>
<th>0.21 1.34</th>
</tr>
</thead>
<tbody>
<tr>
<td>Coordinates y</td>
<td>0 1.22</td>
</tr>
<tr>
<td>Coordinates z</td>
<td>1.28 0.8</td>
</tr>
</tbody>
</table>

8 Click **OK** to close the dialog box.

**OPTIONS AND SETTINGS**

Choose **Options>Constants** and define the following constants (the descriptions are optional). When done, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>rho</td>
<td>1.2[kg/m^3]</td>
<td>Air density</td>
</tr>
<tr>
<td>cs</td>
<td>343.8[m/s]</td>
<td>Speed of sound</td>
</tr>
<tr>
<td>S</td>
<td>1e-5[m^3/s]</td>
<td>Flow source strength</td>
</tr>
</tbody>
</table>

**PHYSICS SETTINGS**

**Subdomain Settings**

1. Choose **Physics>Subdomain Settings**.

2. Select Subdomain 1, then in the **Fluid density** edit field type `rho` and in the **Speed of sound** edit field type `cs`.

3. Click **OK** to close the dialog box.

**Boundary Conditions**

Use the default **Sound hard boundary (wall)** condition for all boundaries.

**Point Settings**

1. Choose **Physics>Point Settings**.
2 Select Point 5, then type $ in the **Flow out from source** edit field.

3 Click **OK** to close the dialog box.

**GENERATING THE MESH**
1 From the **Mesh** menu open the **Free Mesh Parameters** dialog box.
2 On the **Global** page, select **Custom mesh size** and type 343.8/500/3.2 in the **Maximum element size** edit field.
3 Click **Remesh**, then click **OK**.

**COMPUTING THE SOLUTION**
1 Choose **Solve>Solver Parameters** or click the corresponding button on the Main toolbar to open the **Solver Parameters** dialog box.
2 From the **Solver** list, select **Parametric**.
3 In the **Parameter name** edit field type freq_acpr, and in the **Parameter values** edit field type linspace(490,500,11).
4 Select **GMRES** from the **Linear system solver** list, then select **Geometric multigrid** from the **Preconditioner** list.
5 Click the **Settings** button. In the dialog box that appears select **Preconditioner** from the **Linear system solver** tree, and then select **Refine mesh** from the **Hierarchy generation method** list.
   These settings implement the solution procedure described in the subsection “Modeling in COMSOL Multiphysics” on page 108. In particular, the choice of hierarchy-generation method ensures that the automatically generated mesh satisfies the Nyquist criterion.
6 Click **OK** twice to close first the **Linear System Solver Settings** dialog box and then the **Solver Parameters** dialog box.
7 Click the **Solve** button on the Main toolbar.

**POSTPROCESSING AND VISUALIZATION**
The default plot shows the acoustic pressure on five equidistant slices along the x-axis. As a first postprocessing step, generate a couple of more informative plots.
1 Choose **Postprocessing>Plot Parameters** or click the corresponding button on the Main toolbar.
2 On the **Slice** page find the **Number of levels** edit fields. Enter 4, 1, and 1 for the **x levels**, **y levels**, and **z levels**, respectively.
3 Click **Apply** to see the plot, which should resemble the one in Figure 3-8.

To get an idea of the location of the resonances, try an isosurface plot of the sound pressure level.

4 Return to the **Plot Parameters** dialog box and click the **General** tab.

5 Clear the **Slice** check box and select the **Isosurface** check box.

6 Clear the **Element refinement: Auto** check box and type 1 in the corresponding edit field. At the cost of a less refined plot, this setting is done to avoid running out of graphics memory.

7 On the **Isosurface** page select **Sound pressure level** from the **Predefined quantities** list.

8 Select the **Vector with isolevels** option button and type 50 60 70 80 in the corresponding edit field.

9 Click **OK** to generate the plot, then click the **Headlight** button on the Camera toolbar to get a clearer view. The plot should resemble that in Figure 3-10.

![Isosurface plot](image)

**Figure 3-10:** Isosurface plot of the sound pressure level in dB at 500 Hz.

Finally, display the sound pressure level at the point of measurement as a function of frequency:

10 Choose **Postprocessing>Domain Plot Parameters**.
11 On the **General** page, select the **Keep current plot** check box.
12 On the **Point** page, select Point 6. In the **Expression** field, type `Lp_acpr`.
13 Click **OK** to close the dialog box and generate the plot.

If you want to compare the results from this solution with a finer mesh resolution, take the following steps:

1. Choose **Mesh>Mesh Cases**.
2. From the **Mesh cases** list select 1, then click the **Delete** button.
3. Click **OK** to close the dialog box.
4. Choose **Mesh>Free Mesh Parameters**.
5. Enter a different value for the **Maximum element size**. For example, `343.8/500/3.6` gives 3.6 elements per wavelength in the coarse mesh and 7.2 elements per wavelength in the solution mesh. Make sure that you check with Table 3-1 for an estimate of the time and memory consumption before solving.
6. Click the **Remesh** button, then click **OK**.
7. In the **Solver Parameters** dialog box, click the **Settings** button.
8. In the **Linear System Solver Settings** dialog box, select **Preconditioner** from the **Linear system solver** tree to the left. From the **Hierarchy generation method** list, select **Refine mesh**. Click **OK** twice to close the dialog boxes.
9. Click the **Solve** button.
10. Open the **Domain Plot Parameters** dialog box.
11. On the **Point** page, click the **Line Settings** button. Select a different **Line color**, **Line style**, or **Line marker** to separate the new solution from the previous one. Click **OK** to close the **Line Settings** dialog box.
12. Click **OK**.
   A new plot should now appear in the same figure as the old one.
13. Start over with another mesh resolution if desired.

Figure 3-11 shows the measured sound pressure level as a function of frequency for a four different meshes and with a frequency pitch of 1 Hz. To reproduce Figure 3-9 with a pitch of 0.1 Hz, open the **Solver Parameters** dialog box and edit the entry in the **Parameter values** edit field to read `linspace(490,500,101)` before going through the solution procedure again. Note, however, that such a detailed frequency sweep takes a few hours of computing time even on a comparatively powerful workstation.
Figure 3-11: The measured sound pressure level plotted against the frequency with a 1 Hz pitch and for a few different mesh resolutions. With this pitch, the resonances are not sufficiently resolved for the plot to give a fair representation of the convergence. However, it is clear that the difference between the solutions decreases as you increase the resolution.

<table>
<thead>
<tr>
<th>LINE STYLE</th>
<th>ELEMENTS PER WAVELENGTH</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dotted</td>
<td>5.6</td>
</tr>
<tr>
<td>Dash-dot</td>
<td>6.4</td>
</tr>
<tr>
<td>Dashed</td>
<td>7.2</td>
</tr>
<tr>
<td>Solid</td>
<td>8</td>
</tr>
</tbody>
</table>
Flow Duct

Introduction

The modeling of aircraft-engine noise is a central problem in the field of computational aeroacoustics. In this example you simulate the harmonically time-varying acoustic field from a turbofan engine under various conditions and calculate the attenuation of the acoustic noise made possible by introducing a layer of lining inside the engine duct.

Model Definition

Assume that the flow in the axisymmetric duct is compressible, inviscid, perfectly isentropic, and irrotational. In terms of variables made dimensionless by division by suitable combinations of a reference duct radius, $R_\infty$, a reference speed of sound, $c_\infty$, and a reference density, $\rho_\infty$, it is described by

$$\begin{align*}
\frac{\partial \hat{\rho}}{\partial t} + \nabla \cdot (\hat{\rho} \hat{v}) &= 0 \\
\hat{\rho} \left( \frac{\partial \hat{v}}{\partial t} + \hat{v} \cdot \nabla \hat{v} \right) + \nabla \hat{p} &= 0 \\
\hat{c}^2 &= \frac{d \hat{p}}{d \hat{\rho}} = \hat{\rho}^{\gamma-1}
\end{align*}$$

where $\hat{\rho}$ is the density, $\hat{v}$ equals the velocity, $\hat{p}$ denotes the pressure, $\hat{c}$ equals the speed of sound, and $\gamma$ is the constant ratio of the specific heats at constant pressure and volume.

Because the flow is irrotational, you can describe the velocity field, $\hat{v} = \hat{v}(r, z, t)$, in terms of a potential, $\hat{\phi}$, defined by the equation $\hat{v} = \nabla \hat{\phi}$. The basic time- and space-dependent variables describing the flow are then the velocity potential and the density, $\hat{\rho}$. These variables (and the velocity field itself) are split into a stationary mean-flow part and a harmonically time-varying acoustic part:

$$\begin{align*}
\hat{\phi} &= \Phi + \phi e^{i\omega t} \\
\hat{v} &= \hat{V} + \hat{v} e^{i\omega t} \\
\hat{\rho} &= \rho + \rho_a e^{i\omega t}
\end{align*}$$

Also assume that the amplitudes of the acoustic variables are small compared to the corresponding mean-flow quantities. This allows for a linearization of the equations of...
motion and the equation of state, and it extends the mean-flow + acoustic split to the pressure:

\[ p = \bar{P} + pe^{i\omega t} \]

In particular, the linearized equations for the acoustic variables are

\[ i\omega p_a + \nabla \cdot (-\rho \nabla \phi + \rho_a V) = 0 \]

\[ \rho (i \omega \phi + V \cdot \nabla \phi) = p \]

\[ p = C^2 \rho_a \]

The duct geometry used in this model, depicted in Figure 3-12, is taken from Ref. 1. It is an approximate model of the inlet section of a turbofan engine in the very common CFM56 series.

![Figure 3-12: The duct geometry.](image)

The spinner and duct-wall profiles are given, respectively, by the equations

\[ R_1(z') = \max[0, 0.64212 - (0.04777 + 0.98234 z^2)^{1/2}] \]

\[ R_2(z') = 1 - 0.18453 z'^2 + 0.10158 e^{-11(1-z')^2} - e^{-11(1-z')^2} \]

where \( 0 \leq z' = z/L \leq 1 \), and \( L = 1.86393 \) is the duct length. A noise source is imposed at \( z' = 0 \), henceforth referred to as the source plane. This is where the fan would be located in the actual engine geometry. The plane \( z = L \) corresponds to the fore end of the engine and is referred to as the inlet plane.
For the reference quantities in this model, choose the duct radius, the mean flow speed of sound, and the mean flow density at the source plane. Hence, all three of these quantities take the value 1.

To facilitate the COMSOL Multiphysics modeling, add a set of auxiliary domains to the geometry:

- A cylindrical domain—adjoined at the inlet plane and extending to the terminal plane, $z = 2.86393$—extends the modeling domain into a region where you can consider the mean flow as being uniform. This allows you to impose the simple boundary condition of a constant velocity potential and a vanishing tangential velocity for the background flow at the terminal plane.
- PML domains, adjoined at the source and terminal planes, allow you to conveniently implement non-reflecting boundary conditions for the aeroacoustic field. At the source plane, the PML domain is split into three annular sections with the innermost and outermost sections damping both in the axial and radial directions, while the central one is damping only in the axial direction.

The remaining boundary conditions for the mean flow consist of a natural boundary condition specifying the mass-flow rate through the source plane via the normal velocity and the density; slip conditions (vanishing tangential velocity) at the duct wall and at the spinner; and axial symmetry at $r = 0$.

For the aeroacoustic field, the model considers two different boundary conditions at the duct wall:

- **Sound hard**—the normal component of the acoustic particle velocity vanishes at the boundary.
- **Impedance**—the normal component of the acoustic particle velocity is related to the particle displacement through the equation

$$i \omega (v \cdot n) = [i \omega + V \cdot \nabla - (n \cdot (n \cdot \nabla V))] \left( \frac{\rho}{Z} \right)$$

where $Z$ is the impedance. This boundary condition, first derived by Myers (Ref. 2), was later recast in a weak form by Eversman (Ref. 3); it is this weak version, which is directly suitable for finite element modeling, that is implemented in the Aeroacoustics application mode of the COMSOL Multiphysics Acoustics Module. The impedance boundary condition represents a lined duct wall. In this model, following Ref. 1, the impedance is taken to be $Z = 2-i$.

The spinner, in contrast, is always assumed to be acoustically hard.
This study examines two cases for the mean-flow normal velocity component at the source plane, $V_z$, which (owing to the choice of reference speed) alternatively can be referred to as the source-plane axial Mach number, $M$: $M = -0.5$, approximately representative of a passenger aircraft at cruising speed, and $M = 0$.

The dimensionless angular frequency (nondimensionalized through division by $R_\infty/c_\infty$) is $\omega = 16$, and the circumferential mode number is $m = 10$. If you want to obtain a deeper understanding of the duct’s aeroacoustic characteristics, you can, of course, perform a systematic exploration of parameter space by varying these quantities independently.

**Results and Discussion**

**THE MEAN-FLOW FIELD**

For the nontrivial case of a source-plane axial Mach number of $M = -0.5$, the resulting mean-flow field appears in Figure 3-13. Note, in particular, that the velocity potential is uniform well beyond the terminal plane, thus justifying the boundary condition imposed there. Furthermore, as could be expected, deviations from the mean density
value appear primarily near the nonuniformities of the duct geometry, such as at the tip of the spinner.

Figure 3-13: Mean-flow velocity potential and density for source-plane Mach number $M = -0.5$.

As a complement, a more quantitative picture of the variations of the mean-flow velocity and density profiles along the axial direction appear in the cross-section plots in Figure 3-14.
The Noise Source

With the solution for the mean-flow field at hand, it is possible to calculate the corresponding eigenmodes for the acoustic field at the source plane. Figure 3-15 shows the resulting velocity-potential profile for the lowest mode. This is the boundary mode used as the source of the acoustic noise field in the duct for the case $M = -0.5$. 

Figure 3-14: Mean-flow cross-section plot at a sample radius of 0.8.
Figure 3-15: The first axial boundary mode at the source plane \((z = 0)\) for the case of a background flow with Mach number \(M = -0.5\).

**THE AEROACOUSTIC FIELD**

The pressure fields for the case without a background mean flow, depicted in Figure 3-16, very closely match those for the corresponding FEM solutions presented in Figure 6 of Ref. 1. Similarly, the results for the attenuation between the source and
inlet planes in the lined-wall case are in good agreement: 50.3 dB for the COMSOL Multiphysics solution versus 51.6 dB for the FEM solution in Ref. 1.

Turning to the case with a mean flow, the pressure field for the hard-wall case in the upper image of Figure 3-17 closely resembles the FEM solution obtained by Rienstra and Eversman in Ref. 1. For the lined-wall case in the lower image, although the agreement is still quite good, you can note some differences, especially near the source plane. This observation extends to the attenuation, for which the calculated value of 22.0 dB differs significantly from the value of 27.2 dB obtained in Ref. 1.
Figure 3-17: Acoustic pressure distribution for the cases of hard (top) and lined (bottom) duct wall with mean flow \((M = -0.5)\) and at circumferential mode number \(m = 10\) and angular frequency \(\omega = 16\).

However, these discrepancies have a natural explanation: the source mode in the COMSOL Multiphysics calculation was derived for the case of a hard duct wall, whereas Rienstra and Eversman used a noise source adapted to the acoustic lining. The lowest mode for the lined-wall case is a linear combination of the two forward-propagating hard-wall modes. Thus, the noise source term used to obtain the FEM solution in the lower half of Figure 3-17 is not optimally adapted to the duct, and it is consequently not maximally attenuated.
Modeling in COMSOL Multiphysics

The model involves three application modes, the last of which is used twice:

- **Compressible Potential Flow (acpf)**—for modeling the mean-flow velocity field
- **Aeroacoustics, Boundary modal analysis (acab)**—for calculating the boundary eigenmode to be used as the source of the acoustic noise in the mean-flow background
- **Aeroacoustics, Time-harmonic analysis (acae, acae2)**—for modeling the acoustic field above and below the source plane

After an initial modeling stage—consisting of creating the geometry and the mesh, then defining expressions and variables—you proceed by solving the model of the aero-engine duct in a mean-flow background in three steps. Thereafter you repeat part of the procedure in order to derive the corresponding solution in the absence of a background flow.

**References**


**Model Library path:** Acoustics_Module/Industrial_Models/flow_duct
Modeling Using the Graphical User Interface

Initial Stage—Geometry, Mesh, and Common Settings

**MODEL NAVIGATOR**

1. In the Model Navigator go to the Space dimension list and select Axial symmetry (2D), then click Multiphysics.

2. From list of application modes select Acoustics Module>Aeroacoustics>Boundary modal analysis. In the Dependent variables edit field type \( \phi_b \), then click Add.

3. From the list of application modes select Acoustics Module>Aeroacoustics with flow, then click Add.

4. From the list of application modes select Acoustics Module>Aeroacoustics>Time-harmonic analysis. In the Dependent variables edit field type \( \phi_{b2} \), then click Add.

5. Click OK to close the Model Navigator.

**GEOMETRY MODELING**

First import the duct geometry, which is supplied in the form of an mphbin file:

1. Choose File>Import>CAD Data From File, browse to the folder Acoustics Module/Industrial Models, select the file flow_duct.mphbin, and click Import.

Next attach rectangles at the inlet and outlet. These are not part of the duct but allow you to implement the appropriate boundary conditions using perfectly matched layers (PMLs).

2. If the SNAP field on the Status bar at the bottom of the workspace is not already selected, double-click to select it.

3. Choose Draw>Draw Objects>Rectangle/Square or click the corresponding button at the top of the Draw toolbar. In the drawing area click at the top right corner of the duct and drag to the point \((r = 0, z = 3)\).

4. With the rectangle (R1) that you just created still selected, choose Draw>Object Properties to open the Rectangle dialog box. In the Height edit field type 0.2, then click OK.

5. Click the Rectangle/Square button on the Draw toolbar. In the drawing area click at the bottom left corner of the duct and drag to the point \((r = 1, z = -0.5)\).
6 With the rectangle (R2) that you just created still selected, choose
Draw>Object Properties. In the Height edit field type 0.2, and in the z edit field type -0.2. Click OK.

7 Click the Rectangle/Square button on the Draw toolbar. In the drawing area click at the bottom left corner of rectangle R2 and drag to the origin \((r = 0, z = 0)\).

8 With the rectangle (R3) that you just created still selected choose
Draw>Object Properties. In the Width edit field type 0.2, and in the r edit field type 0.223557. Click OK.

9 Click the Rectangle/Square button on the Draw toolbar. In the drawing area click at the bottom right corner of rectangle R2 and drag to the point \((r = 1.5, z = 0)\).

10 With the rectangle (R4) that you just created still selected, choose
Draw>Object Properties. In the Width edit field type 0.2. Click OK.

11 Click the Zoom Extents button on the Main toolbar to get a proper overview of the duct geometry, which should look like the one in Figure 3-18.

![Figure 3-18: The axisymmetric duct geometry with auxiliary PML domains (R1–R4).](image)

**MESH GENERATION**

1 Choose Mesh>Mapped Mesh Parameters, then in the resulting dialog box go to the Boundary page.
2 Select Boundary 7. Select the **Constrained edge element distribution** check box, and in the **Number of edge elements** edit field type 40.

3 Repeat the procedure in Step 2 using the data in the following table:

<table>
<thead>
<tr>
<th>Boundaries</th>
<th>Number of edge elements</th>
</tr>
</thead>
<tbody>
<tr>
<td>22, 61, 98, 99</td>
<td>18</td>
</tr>
<tr>
<td>60</td>
<td>60</td>
</tr>
<tr>
<td>1</td>
<td>39</td>
</tr>
<tr>
<td>2</td>
<td>1</td>
</tr>
<tr>
<td>44–59, 62–65</td>
<td>2</td>
</tr>
<tr>
<td>8–19, 23–39, 66–94</td>
<td>3</td>
</tr>
<tr>
<td>40, 95</td>
<td>5</td>
</tr>
</tbody>
</table>

4 Click **OK** to close the dialog box.

5 Click the **Mesh All (Mapped)** button on the Mesh toolbar to generate the mesh. The result should look like that in Figure 3.19.

![Figure 3.19: The meshed geometry.](image)

Note that the mesh you just created is significantly denser than required to accurately model the background flow. However, in order to resolve the acoustic perturbations—which appear on a smaller scale—it is necessary to use a fine mesh.
OPTIONS AND Settings

Model Settings
As explained in the introduction, this model uses nondimensional variables obtained by dividing each variable by a suitable reference quantity of the same dimension. The reference length is the duct radius at the source plane (which is why it has the value 1). The mean-flow density and speed of sound at the source plane \( z = 0 \) complete the set of reference variables. To reflect these nondimensionalizations, change the unit system from the default SI units to none:

1. Choose Physics>Model Settings.
2. From the Base unit system list choose None, then click OK.

Constants
1. Choose Options>Constants.
2. In the dialog box that opens, enter the data given in the following table (the descriptions are optional); when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>gamma</td>
<td>1.4</td>
<td>Ratio of specific heats</td>
</tr>
<tr>
<td>M</td>
<td>-0.5</td>
<td>Mean flow Mach number</td>
</tr>
<tr>
<td>m</td>
<td>10</td>
<td>Circumferential mode number</td>
</tr>
<tr>
<td>omega</td>
<td>16</td>
<td>Angular frequency</td>
</tr>
<tr>
<td>A</td>
<td>0.01</td>
<td>Acoustic source strength</td>
</tr>
<tr>
<td>Z</td>
<td>2 \text{i}</td>
<td>Duct wall impedance</td>
</tr>
<tr>
<td>b</td>
<td>0.01</td>
<td>Impedance onset rate</td>
</tr>
<tr>
<td>z_i</td>
<td>1.86393</td>
<td>Axial coordinate, inlet plane</td>
</tr>
<tr>
<td>z_t</td>
<td>2.86393</td>
<td>Axial coordinate, terminal plane</td>
</tr>
</tbody>
</table>

Global Expressions
1. Choose Options>Expressions>Global Expressions.
2. In the dialog box that opens define an expression for the mean-flow speed of sound with the following data; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>C</td>
<td>sqrt(gamma<em>p0_acpf</em>rho^(gamma-1)/rho0_acpf^gamma)</td>
<td>Mean flow speed of sound</td>
</tr>
</tbody>
</table>

Subdomain Expressions
1. Choose Options>Expressions>Subdomain Expressions.
Define variables with the scope, name, and expressions from the following table; when done, click **OK**.

<table>
<thead>
<tr>
<th>SUBDOMAINS</th>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>4–6</td>
<td>rho</td>
<td>rho0_acpf</td>
</tr>
<tr>
<td>5</td>
<td>V</td>
<td>M</td>
</tr>
</tbody>
</table>

**Boundary Expressions**

1. Choose **Options>Expressions>Boundary Expressions**.

2. Select Boundary 43, then define an expression for the source mode’s intensity component normal to the source boundary according to the following table:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Iz_source</td>
<td>$A^2 \times 0.5 \times \text{real}((p_{acab}/\rho_{0_acpf}+v_r_{acab}v_r_{acab}v_z_{acab}\times i<em>kz_{\phi_b})\text{conj}(\rho v_z_{acab}-\rho_{0_acpf}\times i</em>kz_{\phi_b}))$</td>
</tr>
</tbody>
</table>

   This expression is the acab application mode’s equivalent of $I_z$ in Table 6-3 on page 121 of the *Acoustics Module User’s Guide*. The expression involves a constant $k_z$ for the out-of-plane wave number that you specify later. It is convenient to introduce this constant here instead of using the application scalar variable $i k_z_{acab}$ set equal to $i \times k_z$. This is because $i k_z_{acab}$ must take its default value $-\lambda$ when you solve for the boundary mode, and you would therefore have to change its value back and forth repeatedly between the various modeling stages.

3. Click **OK** to close the **Boundary Expressions** dialog box.

   Because the definition of the boundary mode’s acoustic pressure variable, $p_{acab}$, involves $i k_z_{acab}$, you must additionally modify its expression as follows:

4. From the **Physics** menu, choose **Equation System>Boundary Settings**.

5. In the **Boundary Settings - Equation System** dialog box, click the **Variables** tab.

6. With Boundary 43 still selected, edit the **Expression** for $p_{acab}$ by replacing $i k_z_{acab}$ with $i \times k_z$.

7. Click **OK** to close the **Equation System>Boundary Settings** dialog box.

   Note that $p_{acab}$ is just a postprocessing variable, so changing its expression does not affect the solution.

**Boundary Variables**

Define some expressions that you later use to extend the mean-flow density and velocity variables to the upper PML domain by means of extrusion from the terminal plane at $z = 2.86393$. Do so by executing the following instructions:
1. Choose **Options>Extrusion Coupling Variables>Boundary Variables**.
2. Go to the **Source** page. Select Boundary 6, then define variables with the following data:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>TRANSFORMATION</th>
</tr>
</thead>
<tbody>
<tr>
<td>V</td>
<td>vz_acpf</td>
<td>General</td>
</tr>
<tr>
<td>rho</td>
<td>rho</td>
<td>General</td>
</tr>
</tbody>
</table>

3. Click the **Destination** tab.
4. In the **Level** list select **Subdomain**, and in the **Variable** list select **V**.
5. In the **Subdomain selection** list select the check box next to Subdomain 3. The **Use selected subdomains as destination** check box is then automatically selected.
6. From the **Variable** list select **rho**, then select the **Use selected subdomains as destination** check box.
7. Click **OK**.

Next define two integration coupling variables that evaluate to the input acoustic power produced by the noise source and the power through the inlet plane.

1. Choose **Options>Integration Coupling Variables>Boundary Variables**.
2. Enter the data given in the following table below, leaving the Global destination check box selected (the default) for both variables; when done, click **OK**.

<table>
<thead>
<tr>
<th>BOUNDARY</th>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>43</td>
<td>w_source</td>
<td>Iz_source</td>
</tr>
<tr>
<td>4</td>
<td>w_inlet</td>
<td>Iz_acae</td>
</tr>
</tbody>
</table>

**Scalar Expressions**

1. Choose **Options>Expressions>Scalar Expressions**.
2. In the dialog box that opens define an expression for the acoustic attenuation with the following data; when done, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>dw</td>
<td>10*log10(w_source/w_inlet)</td>
<td>Acoustic attenuation (dB)</td>
</tr>
</tbody>
</table>

**PHYSICS SETTINGS**

**Application Mode Properties**

1. Choose **Physics>Scalar Variables** to open the **Application Scalar Variables** dialog box.
With the Synchronize equivalent variables check box selected, modify the variables according to the following table; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>freq_acab</td>
<td>omega/(2*pi)</td>
</tr>
<tr>
<td>m_acab</td>
<td>10</td>
</tr>
<tr>
<td>p0_acpf</td>
<td>rho0_acpf*gamma/gamma</td>
</tr>
<tr>
<td>rho0_acpf</td>
<td>1</td>
</tr>
<tr>
<td>v0_acpf</td>
<td>M</td>
</tr>
</tbody>
</table>

**Stage I—The Background Flow**

In this modeling stage you derive the stationary background on which propagate the time-harmonic acoustic perturbations that you model in Stage III. You calculate this flow field using the Compressible Potential Flow application mode defined on the duct geometry proper (Subdomain 1) and on the auxiliary region (Subdomain 2) appended at the inlet plane ($z = 1.86393$), and subsequently extend the flow to the PML domains by continuity. A mass-flow boundary condition is imposed at the source plane, and a Dirichlet condition for the velocity potential is applied at the terminal plane ($z = 2.86393$). The duct wall and the spinner are both impervious to the flow.

**PHYSICS SETTINGS**

**Subdomain Settings**

1. In the Multiphysics menu select Compressible Potential Flow (acpf).
2. Choose Physics>Subdomain Settings.
3. In the Subdomain selection list select Subdomains 1–2, then type gamma in the $\gamma$ edit field.
4. In the Subdomain selection list select Subdomains 3–6, then clear the Active in this domain check box.
5. Click OK.

**Boundary Conditions**

2. In the Boundary selection list select Boundaries 1 and 3.
3. From the Boundary condition list choose Axial symmetry.
4. Select Boundary 6 (the terminal plane), and as the Boundary condition select Normal flow.
5 Select Boundary 43 (the source plane), and as the **Boundary condition** select **Mass flow**. Leave the **Normal velocity** and **Fluid density** edit fields at their default values.

6 Click **OK**.

**COMPUTING THE SOLUTION**

1 Choose **Solve>Solver Manager** or click the corresponding button on the Main toolbar. Either action opens the **Solver Manager** dialog box.

2 Click the **Solve For** tab.

3 In the **Solve for variables** list select **Compressible Potential Flow (acpf)**, then click **Apply**.

4 Choose **Solve>Solver Parameters** (or click the corresponding button on the Main toolbar) to open the **Solver Parameters** dialog box.

5 From the **Solver** list select **Stationary**, then click **OK**.

6 Return to the **Solver Manager** dialog box and click **Solve**.

7 On the **Initial Value** page, click the **Store Solution** button.

8 Click **OK**.

**POSTPROCESSING AND VISUALIZATION**

First zoom in on the interesting part of the geometry.

1 Choose **Options>Suppress>Suppress Subdomains**.

2 From the **Subdomain selection** list select Subdomains 3–6, then click **OK**.

3 Click the **Zoom Extents** button on the Main toolbar.

Next visualize the mean-flow field.

1 Choose **Postprocessing>Plot Parameters** or click the corresponding button on the Main toolbar.

2 On the **General** page, go to the **Plot type** area and select only the **Surface**, **Contour**, and **Geometry edges** check boxes.

3 On the **Surface** page go to the **Predefined quantities** list and select **Compressible Potential Flow (acpf)>Density** (alternatively, type \( \rho \) in the **Expression** edit field).

4 On the **Contour** page go to the **Predefined quantities** list and select **Compressible Potential Flow (acpf)>Velocity potential**.

5 On the **General** page click the **Title** button.

6 Click the option button next to the edit field and enter the title **Surface: density** **Contour: velocity potential (M=-0.5)**.
7 Click **OK** to close the **Title** dialog box, then click **OK** to close the **Plot Parameters** dialog box and generate the plot presented in Figure 3-13 on page 119.

To get a detailed view of the density and velocity profiles along the length of the duct, proceed as follows:

1 Choose **Postprocessing>Cross-Section Plot Parameters**.
2 On the **General** page select the **Keep current plot** check box and clear the **Display cross-section in main axes** check box.
3 Click the **Line/Extrusion** tab.
4 In the **y-axis data** area, find the **Expression** edit field and enter $\rho_0$.
5 In the **x-axis data** area, select $z$ from the list next to the upper option button.
6 In the **Cross-section line data** area, modify the coordinate values according to the following table; when done, click **Apply**.

<table>
<thead>
<tr>
<th>$r_0$, $r_1$</th>
<th>0.8</th>
</tr>
</thead>
<tbody>
<tr>
<td>$z_1$</td>
<td>1.86393</td>
</tr>
</tbody>
</table>

7 In the **y-axis data** area, go to the **Expression** edit field and type $-v_z_{acpf}$.
8 Click the **Line Settings** button.
9 From the **Line color** list, select **Color**, then in the **Line style** list select **Dashed line**. Click **OK** to close the **Line Settings** dialog box.
10 In the **Cross-Section Plot Parameters** dialog box, click the **General** tab.
11 Click the **Title/Axis** button to open the **Title/Axis Settings** dialog box.
12 Click the option button next to the **Title** edit field and enter the text **Mean flow cross-section plots at r=0.8**.
13 Click the option button next to the **Second axis label** edit field and enter the text **Density (solid) axial Mach number (dashed)**.
14 Click **OK** to close the **Title/Axis Settings** dialog box, then click **OK** to close the **Cross-Section Plot Parameters** dialog box. Doing so generates the graphs in Figure 3-14 on page 120.

**Stage II—The Boundary Source Mode**

As the source generating the acoustic field in the duct, use a single boundary mode imposed at $z=0$. More specifically, take this mode to be the lowest propagating axial mode in the duct computed in the background flow field from the previous stage of
the modeling process. The subsequent instructions demonstrate how to derive this boundary mode.

**PHYSICS SETTINGS**

*Boundary Conditions*

1. In the *Multiphysics* menu select *Aeroacoustics, Boundary Modal Analysis (acob)*.
2. Choose *Physics* > *Boundary Settings*.
3. In the *Boundary selection* list select Boundary 43.
4. In the left and right parts of the \( V \) edit field type \( v_{r\_acpf} \) and \( v_{z\_acpf} \), respectively.
5. In the \( c_s \) edit field type \( C \), and in the \( \rho \) edit field type \( \rho \).
6. Select Boundary 40, then select the *Select by group* check box and clear the *Active in this domain* check box.
7. Click *OK*.

**COMPUTING THE SOLUTION**

1. Click the *Solver Manager* button on the Main toolbar to open the *Solver Manager* dialog box.
2. On the *Initial Value* page select the *Stored solution* option button in both the *Initial value* area and the *Values of variables not solved for and linearization point* area.
3. Click the *Solve For* tab.
4. In the *Solve for variables* list select *Aeroacoustics, Boundary Modal Analysis (acob)*, then click *Apply*.
5. Click the *Solver Parameters* button on the Main toolbar to open the *Solver Parameters* dialog box.
6. From the *Solver* list select *Eigenvalue*.
7. In the *Desired number of propagation constants* edit field type \( 8 \), and in the *Search for propagation constants around* edit field type \( 10 \).
8. Click *OK* to close the *Solver Parameters* dialog box.
9. Return to the *Solver Manager* dialog box and click *Solve*.
10. Go to the *Initial Value* page and click the *Store Solution* button to open the *Store Solution* dialog box.

   Inspect the *Propagation constant* list and notice that there are four solutions with a purely real propagation constant, three of them positive and one negative. In other words, there are four propagating waves, three of which propagate in the positive
in the $z$ direction and one in the opposite direction. The strong background flow has shifted the propagation constants, which in the absence of a mean flow would be symmetrically distributed around zero.

In the subsequent modeling stage, you will use the value of the largest positive propagation constant ($\approx 27.12$) and the absolute value of the single negative propagation constant ($\approx 5.778$); these propagation constants correspond to the lowest forward-propagating and backward-propagating modes, respectively.

11 Select the last entry from the Propagation constant list to store the solution corresponding to the lowest forward-propagating mode. Click OK.

12 Choose Options>Constants and add the following entries to the list of constants:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>$k_z$</td>
<td>27.123744</td>
<td>Axial propagation constant</td>
</tr>
<tr>
<td>$k_{zr}$</td>
<td>5.778166</td>
<td>Axial propagation constant, reflected mode</td>
</tr>
</tbody>
</table>

(In the expression column, preferably use the exact values you obtained for the propagation constants, although they should be quite close to those displayed here.)

13 Click OK to close the Solver Manager dialog box.

**POSTPROCESSING AND VISUALIZATION**

To verify that you have found the lowest axial mode, plot the boundary mode velocity potential as follows:

1 Choose Postprocessing>Domain Plot Parameters.

2 On the General page select the last entry in the Solutions to use list.

3 From the Plot in list select New figure, then select the Keep current plot check box.

4 Click the Title/Axis button, then select the option button next to the Title edit field. Enter the text First axial mode at source plane ($z=0$). Click OK.

5 On the Line/Extrusion page go to the Boundary selection list and select Boundary 43.

6 In the $x$-axis data area select $r$ from the list next to the upper option button. In the $y$-axis data area keep the default variable choice, phi_b.

7 Click OK to close the dialog box and generate the plot in Figure 3-15 on page 121.

**Stage III—The Acoustic Field**

Equipped with the solution derived in the two previous stages, you can now go on to simulate the acoustic field. You model the noise source through the judicious choices
of boundary conditions at the source plane \((z = 0)\) for the two time-harmonic Aeroacoustics application modes. Furthermore, implement non-reflecting boundary conditions at both ends of the duct geometry by using the auxiliary PML domains that you added to the model earlier in the geometry creation steps.

Here are the detailed instructions for the procedure.

**OPTIONS AND SETTINGS**

**Constants**
1. Choose Options>Constants.
2. Add a constant with the name \(p_{\text{max}}\) defined by the expression \(1.500211\).
3. Click OK.

**PHYSICS SETTINGS**

**Subdomain Settings—Aeroacoustics (acae)**
1. In the Multiphysics menu select Aeroacoustics (acae).
2. Choose Physics>Subdomain Settings.
3. In the Subdomain selection list select Subdomains 4–6, then clear the Active in this domain check box.
4. Select Subdomains 1–3, then in the \(c_s\) edit field type \(C\).
5. Select Subdomain 3 only.
6. In the left part of the \(V\) edit field type 0, and in the right part type \(V\).
7. Click the PML tab.
8. In the Type of PML list select Cylindrical.
9. Select the Absorbing in z direction check box. Specify the PML width in this direction by typing 0.2 in the corresponding edit field.
10. In the \(L_z\) edit field type \(2*\pi/\kappa z\) to specify the scaled PML length.
11. Click OK.

**Subdomain Settings—Aeroacoustics (acae2)**
1. In the Multiphysics menu select Aeroacoustics (acae2).
2. Choose Physics>Subdomain Settings.
3. Select Subdomains 1–3, then clear the Active in this domain check box.
5. In the \(c_s\) edit field type \(C\), and in the \(\rho\) edit field type \(\rho\).
6 Select Subdomain 5 by itself.
7 In the right-hand part of the V edit field type V, and in the left-hand part leave the default value, 0.
8 Click the PML tab.
9 In the Type of PML list select Cylindrical.
10 Select the Absorbing in z direction check box and type 0.2 in the corresponding edit field.
11 In the $L_z$ edit field type $2*p_1/kzr$.
12 Select the two Subdomains 4 and 6.
13 From the Type of PML list select Cylindrical.
14 Select both the Absorbing in r direction and the Absorbing in z direction check boxes, then type 0.2 in the corresponding edit fields.
15 In both the $L_r$ and $L_z$ edit fields enter $2*p_1/kzr$.
16 Select Subdomain 4 only, then in the $R_0$ edit field type 0.223557.
17 Click OK.

Boundary Conditions
1 Choose Physics>Boundary Settings.
2 Select Boundary 43.
3 In the Boundary condition list select Velocity potential.
4 In the $\phi_0$ edit field type $\phi_1-A*\phi_b$, then click OK.
5 Choose Physics>Properties to open the Application Mode Properties dialog box.
6 In the Weak constraints list select On, then click OK.
7 In the Multiphysics menu select Aeroacoustics (acae).
8 Choose Physics>Boundary Settings.
9 With Boundary 43 still selected, go to the Boundary condition list and select Normal mass flow. Then in the $m_n$ edit field type $\rho_0*(-i*kz*A*\phi_1_b)$.
10 Select Boundaries 1, 3, and 5, then in the Boundary condition list select Axial symmetry.
11 Click OK.

Computing the Solution
1 Click the Solver Manager button on the Main toolbar.
2 Click the Solve For tab.
In the **Solve for variables** list select both **Aeroacoustics (acea)** and **Aeroacoustics (acea2)**, then click **OK**.

4 Click the **Solver Parameters** button on the Main toolbar.

5 From the **Solver** list select **Stationary**, then click **OK**.

6 Click the **Solve** button on the Main toolbar to compute the solution.

**POSTPROCESSING AND VISUALIZATION**

Zoom in on the duct geometry proper, that is, Subdomain 1.

1 Choose **Options>Suppress>Suppress Subdomains**.

2 Select Subdomains 2–6, then click **OK**.

3 Click the **Zoom Extents** button on the Main toolbar.

4 Next visualize the aeroacoustic field.

   1 Click the **Plot Parameters** button on the Main toolbar.
   2 On the **General** page clear the **Surface** check box.
   3 Click the **Contour** tab.
   4 In the **Expression** edit field type \( \frac{p_{acea}}{p_{max}} \).
   5 Select the **Vector with isolevels** option button, then type the following vector in the corresponding edit field: 0.0001 0.001 0.01 0.02 0.04 0.06 0.1 0.2 0.3 0.4 0.5 0.6 0.7 0.8 0.9.
   6 In the **Colormap** list select **hsv**, then click **Apply**.
   7 Click the **General** tab.
   8 Select the **Keep current plot** check box, and then return to the **Contour** page.
   9 In the **Colormap** list select **jet**.
   10 Select the **Filled** check box, then click **Apply**.
   11 Go to the **General** page and click the **Title** button.
   12 Select the check box next to the edit field and enter the title **Hard wall, flow**.
   13 Click **OK** to close the **Title** dialog box, then click **OK** to close the **Plot Parameters** dialog box.

In the drawing area of the COMSOL Multiphysics user interface you should now see the upper image in Figure 3-17 on page 123, which shows the acoustic field in a mean-flow field of axial Mach number \(-0.5\) for the case of a hard duct wall.
Next change the model to that of a duct with a lined wall by implementing an impedance boundary condition. Begin by adjusting the value of $p_{\text{max}}$ so as to obtain a normalized plot.

**OPTIONS AND SETTINGS**

*Constants*
1. Choose Options>Constants.
2. Change the value of $p_{\text{max}}$ to 1.718862, then click OK.

**PHYSICS SETTINGS**

*Boundary Conditions*
3. From the Boundary condition list select Impedance boundary condition.
4. In the $Z$ edit field type $Z/f_{\text{linc}}(Z/zi,b)$.
5. Select Boundary 60 by itself, then from the Boundary condition list select Impedance boundary condition.
6. In the $Z$ edit field type $Z/f_{\text{linc}}((zt-z)/(zt-zi),b)$, then click OK.

The reason behind using the smoothed Heaviside function $f_{\text{linc}}$ in Steps 4 and 6 above is to make the impedance a continuous (albeit abruptly changing) function across the interfaces between regions with and without an acoustic lining. This is a condition required for the equivalence of Myers’s original impedance boundary condition and its weak reformulation due to Eversman used here to hold (see Ref. 3).

**COMPUTING THE SOLUTION**

Click the Solve button on the Main toolbar.

**POSTPROCESSING AND VISUALIZATION**

1. Click the Plot Parameters button on the Main toolbar.
2. On the General page clear the Keep current plot check box.
3. Click the Contour tab.
4. In the Colormap list select hsv.
5. Clear the Filled check box, then click Apply.
6. Click the General tab.
7 Select the **Keep current plot** check box, then return to the **Contour** page.

8 In the **Colormap** list select **jet**.

9 Select the **Filled** check box, then click **Apply**.

10 Go to the **General** page and click the **Title** button.

11 Change the text in the title edit field to **Lined wall, flow**, then click **OK** to close the **Title** dialog box.

12 Click **OK** to close the **Plot Parameters** dialog box.

The plot in the main window should now closely resemble the lower image in Figure 3-17.

With a lined duct wall, the acoustic perturbations emanating from the noise source no longer propagate without loss. To display the acoustic attenuation between the source plane and the inlet plane at $z = 1.86393$, execute the following commands:

1 Choose **Postprocessing>Data Display>Global**.

2 In the **Expression** edit field type $dw$, then click **OK**.

The value for the current solution of this previously defined expression—approximately 22.0 dB—now appears in the Message log at the bottom of the COMSOL Multiphysics user interface.

**Note:** The source mode used in these calculations was derived for the case of a hard duct wall, whereas the lowest mode for the lined-wall case would be a linear combination of the two forward-propagating hard-wall modes. For this reason, the noise source is not an eigenmode and is, consequently, not maximally attenuated. This observation is borne out by a comparison of the calculated attenuation of 22.0 dB with the corresponding quantity calculated in Ref. 1, where a value of approximately 27 dB was obtained.

---

*The Case Without a Background Flow*

Follow these instructions to repeat the calculations for the case when no background mean-flow field is present.
OPTIONS AND SETTINGS

Constants
Choose Options>Constants. Change the value of M to 0, then click OK.

COMPUTING THE SOLUTION

1 Click the Solver Manager button on the Main toolbar.
2 On the Solve For page go to the Solve for variables list and select Compressible Potential Flow (acpf).
3 Click the Initial Value tab.
4 In the Initial value area select the Initial value expression option button.
5 In the Values of variables not solved for and linearization point area, select the Use selection from Initial value frame option button.
6 Click the Solve button, then click the Store Solution button.
7 Select the Stored solution option button in both the Initial value area and the Values of variables not solved for and linearization point area.
8 Go back to the Solve For page and select Aeroacoustics, Boundary Modal Analysis (acab), then click Apply.
9 Click the Solver Parameters button, select Eigenvalue from the Solver list, then click OK to close the Solver Parameters dialog box.
10 Return to the Solver Manager dialog box and click the Solve button.
11 Go to the Initial Value page and click the Store Solution button.
12 Return to the main user interface and from the Options menu open the Constants dialog box.
13 Change the expressions for both k2 and k2r to the value of the last entry in the Propagation constant list, which should be approximately 10.83. Click OK.
14 Return to the Store Solution dialog box and from the Propagation constant list select the last entry (with a value of the propagation constant approximately equal to 10.83). Click OK.
15 Click OK to close the Solver Manager dialog box.

Having computed and saved the mean-flow-free background and boundary mode solution, turn next to the calculation of the acoustic field.
OPTIONS AND SETTINGS

Constants
1 Choose Options>Constants.
2 Change the value of pmax to 0.422433, then click OK.

PHYSICS SETTINGS

Boundary Conditions
1 Choose Physics>Boundary Settings.
2 From the Boundary selection list select Boundary 44.
3 Select the Select by group check box, then in the Boundary condition list select Sound hard boundary (wall).
4 Select Boundary 60, then in the Boundary condition list select Sound hard boundary (wall).
5 Click OK.

COMPUTING THE SOLUTION
1 Click the Solver Manager button on the Main toolbar.
2 On the Solve For page go to the Solve for variables list and select both Aeroacoustics (acae) and Aeroacoustics (acae2). Click OK.
3 Click the Solver Parameters button on the Main toolbar.
4 From the Solver list select Stationary, then click OK.
5 Click the Solve button on the Main toolbar to compute the solution.

POSTPROCESSING AND VISUALIZATION
1 Click the Plot Parameters button on the Main toolbar.
2 On the General page clear the Surface check box.
3 Click the Contour tab.
4 In the Colormap list select hsv.
5 Clear the Filled check box, then click Apply.
6 Click the General tab.
7 Select the Keep current plot check box, then return to the Contour page.
8 In the Colormap list select jet.
9 Select the Filled check box, then click Apply.
10 Go to the General page and click the Title button.
11 Select the check box next to the edit field and enter the title Hard wall, no flow.
12 Click OK to close the Title dialog box, then click OK to close the Plot Parameters dialog box.

A plot similar to the one in the upper half of Figure 3-16 on page 122 should now appear in the drawing area. It depicts the acoustic field in the duct in the absence of a background mean flow and for the case of a hard duct wall.

As the fourth and final case of study, consider a lined duct wall in the absence of a background flow.

OPTIONS AND SETTINGS

Constants
1 Choose Options>Constants.
2 Change the value of pmax to 0.264331, then click OK.

PHYSICS SETTINGS

Boundary Conditions
1 Choose Physics>Boundary Settings.
2 Select Boundaries 44–59 and 62–95, then in the Boundary condition list select Impedance boundary condition.
   The expression \( Z/\frac{f c^2 h s(z/\bar{z}_1, b)}{ } \) should appear in the Z edit field.
3 Select Boundary 60, then in the Boundary condition list select Impedance boundary condition.
   Now the expression in the Z edit field should read \( Z/\frac{f c^2 h s((z_t-z)/(z_t-\bar{z}_1), b)}{ } \).
4 Click OK.

COMPUTING THE SOLUTION
Click the Solve button on the Main toolbar.

POSTPROCESSING AND VISUALIZATION

1 Click the Plot Parameters button on the Main toolbar.
2 On the General page clear the Keep current plot check box.
3 Click the Contour tab.
4 In the Colormap list select hsv.
5 Clear the Filled check box, then click Apply.
6 Click the General tab.
7 Select the Keep current plot check box, then return to the Contour page.
8 In the Colormap list select jet.
9 Select the Filled check box, then click Apply.
10 Go to the General page and click the Title button.
11 Change the text in the edit field to Lined wall, flow, then click OK to close the Title dialog box.
12 Click OK.

The plot in the main window should now closely resemble the lower one in Figure 3-16.

Finally display the value of the acoustic attenuation. To do so, choose Postprocessing>Data Display>Global, then click OK.

The value of dw—for this case approximately 50.3 dB—should appear in the Message log at the bottom of the user interface.

---

**Note:** In contrast to the attenuation calculated for the case of a mean-flow background in the first part of this exercise, the latest value is quite close to that in Ref. 1 (51.6 dB). The reason is that both use the same source mode as a result of the fact that there is a single forward-propagating mode in the flow-free case, thus making the two calculations directly comparable.
Introduction

This is a model of a loudspeaker of the dynamic cone driver type, common for low and medium frequencies. The instructions walk you through modeling its electromagnetic, structural, and acoustic properties. The output from the model includes the total electric impedance and the on-axis sound pressure level at a nominal driving voltage, as functions of the frequency.

When performing the acoustic measurements in this model, the driver is set up in an infinite baffle—a wide reflective surface acting to shut out the sound produced on the backside of the cone. An extended 3D version of the model, “Loudspeaker Driver in a Vented Enclosure” on page 175, uses the electromechanical properties modeled here and adds a vented enclosure.

The model starts out with the Small-Signal analysis from the AC/DC Module to compute the driving force and the blocked voice coil impedance. It then uses these results and adds application modes from the Acoustics Module for the acoustic-structure analysis. As an optional final modeling step, you can choose to extract and export the data needed for the 3D model.

Model Definition

Figure 3-20 shows the geometry of the baffled driver with its functional parts. The field from the magnet is supported and focused by the iron pole piece and top plate to the thin gap where the voice coil is wound around a former extending from the apex of the cone. Although the voice coil consists of many turns of wire, it is for simplicity modeled as a homogenized domain. When a driving AC voltage is applied to the voice coil, the resulting force causes it to vibrate, and the cone to create sound.

The dust cap protects the magnetic motor. In this design, it is made of the same stiff and light composite material as the cone and also contributes to the sound. A centered hole in the pole piece counteracts pressure buildup beneath the dust cap. The suspension, consisting of the surround, made of a light foam material, and the spider, a flexible cloth, keep the cone in place and provide damping and spring forces.

The outer perimeters of the magnet and suspension are normally attached to a basket, a hollow supporting metal structure. The basked is not included in this model, but the
magnet assembly and outer rims of the spider and surround are considered to be fixed. The omission of the basket means that the considered geometry is rotationally symmetric and can be modeled in the $rz$-plane.

**Figure 3-20: Geometry of the modeled loudspeaker driver.**

The loudspeaker is driven by a time-harmonic voltage, $V = V_0 \exp(i\omega t)$, applied to the voice coil. The following theory section first describes the electromagnetic analysis of the current in the voice coil and the driving force that this current gives rise to. Once the relation between the driving voltage and the force is established, the force is applied in an acoustic-structure interaction analysis set up to compute the sound production.

The force on a wire of length $L$ and with the current $I$ in a magnetic flux density $B$ perpendicular to the wire is given by $F = IBL$. The voice coil consists of $N = 100$ turns of thin copper wire and occupies a cross-sectional area $A$ in the $rz$-plane. The total force $F_e$ from the current on the coil hence becomes

$$F_e = -I 2\pi N \int_B r r B, dA$$

where the integral is taken over the coil domain.

The current through the voice coil relates to the applied voltage as
where $Z_b$ is the blocked electric impedance (the electric impedance of the voice coil measured while the speaker’s moving parts are stationary) and $-V_{be}$ denotes the back EMF (the voltage induced in the coil due to its motion through the permanent magnetic field in the gap).

To evaluate the back EMF, consider the same wire of length $L$ in the magnetic flux density $B$, but now traveling at a velocity $v$ perpendicular to the wire. The wire gets an induced back EMF equal to $vBL$. The total back EMF in the coil becomes

$$-V_{be} = -v \frac{2\pi N}{A} \int r B_{r} dA \quad (3-3)$$

The common factor in $F_e$ and $V_{be}$ is known in the loudspeaker community as the force factor, “BL”:

$$BL = \frac{2\pi N}{A} \int r B_{r} dA.$$

To find the blocked coil impedance, an external current density corresponding to a time-harmonic loop voltage of $(V_0 + V_i)/N$ is applied to the domain of the still stationary coil. The induced voltage $V_i$ is computed as the calculated induced azimuthal electric field in the coil times the length of the wire. The blocked coil impedance, finally, is obtained as $Z_b = V_0/I_b$, where $I_b$ is the current through the blocked coil.

With the constant $BL$ and the frequency-dependent $Z_b$ now both known, Equations 3-1 to 3-4 can be rearranged to form the sought relationship between $V_0$ and $F_e$:

$$F_e = BL \frac{V_0 - BLv}{Z_b} \quad (3-5)$$

Note the dependence of the driving force on the velocity of the moving coil, which is unknown prior to the acoustic-structure interaction computation.

In computing the acoustic-structure interaction, $F_e$ is applied to the voice coil domain. A structural equation is solved in the moving parts of the driver, and a pressure acoustics equation in the surrounding air. The pressure acoustics equation uses a normal acceleration boundary condition for the structural vibrations to propagate into the air. Conversely, the acoustic pressure is applied as a boundary load on the structure.
The air domains and the baffle should ideally extend to infinity. To avoid unphysical reflections where you truncate the geometry, you will use Perfectly Matched Layers (PMLs), as seen in Figure 3-21. For more information, see “Perfectly Matched Layers (PMLs)” on page 37 in the Acoustics Module User’s Guide.

Although the modeled air domain has a radius of only 0.12 m, the local acoustic pressure can be extracted anywhere thanks to COMSOL’s functionality for far-field pressure computation. The sensitivity is calculated as the sound pressure level on the axis at 1 m, for the applied voltage \( V_0 = 4 \) V.

As a final modeling step, results are extracted from this model for use as lumped parameters in the Vented Loudspeaker Enclosure. The documentation to that example contains a circuit representation of the force balance on the cone.

**Results and Discussion**

The magnetic flux density in and around the voice coil appears in Figure 3-22. The maximum flux density in the air arises in the gap between the pole piece and the top
Performing the integral in Equation 3-4 over the voice coil domain gives a force factor $BL = 7.55 \text{ N/A}$.

The iron in the pole piece and top plate is modeled as a nonlinear magnetic material, with the relationship between the $B$ and $H$ fields described by interpolation from measured data. Figure 3-23 shows the local effective relative permeability $\mu_r = B/(\mu_0H)$. The plot shows that the iron is close to saturation in the center of the pole piece, but remains in the linear regime above and below the magnet. This indicates that if you want to use less material, you can likely decrease the radius of the pole piece and top plate with very little effect on the magnetic field in the gap.

*Figure 3-22: Magnetic flux density near the voice coil.*
CHAPTER 3: INDUSTRIAL MODELS

Figure 3-23: The local relative permeability in the pole piece and top plate, when subjected to the field from the magnet.

In computing the blocked coil impedance, the AC equation is linearized around the local permeability resulting from the static solution. Figure 3-24 shows the induced currents at two different frequencies.

Figure 3-24: Induced currents in the pole piece and top plate, at 52 Hz (left) and 905 Hz (right).
At the higher frequency, the skin effect brings the currents closer to the surfaces. This causes the inductance as well as the resistive part of the impedance to change with the frequency. Figure 3-25 shows a plot of the blocked coil inductance versus frequency.

![Blocked coil inductance graph](image)

*Figure 3-25: The inductance of the blocked coil as a function of frequency.*

From the acoustic-structure interaction analysis, Figure 3-26 shows the sound pressure level distribution at 3500 Hz. A minimum has formed in a direction about 45 degrees above the baffle. At lower frequencies, the sound pressure level is rather evenly distributed but peaks in the on-axis direction.
Figure 3-27 presents the loudspeaker’s sensitivity. The preferred operating range is where the response is rather even, that is, roughly in the range 100 Hz–1500 Hz. A vented enclosure can extend the range to lower frequencies, as shown in the Vented Loudspeaker Enclosure model.
Figure 3-27: Loudspeaker sensitivity, measured as the on-axis sound pressure level (dB) at a distance of 1 m from the unit. The pressure is evaluated using an input signal of 4 V, or 2.83 V RMS, which corresponds to a power of 1 W at an 8 Ω nominal impedance. Note the logarithmic frequency scale.

The total electrical impedance, defined as $Z = V_0/I$, appears in Figure 3-28. The features of this plot are very characteristic of loudspeaker drivers. The peak at approximately 40 Hz coincides with the mechanical resonance; at this frequency the reactive part of the impedance switches sign from inductive to capacitive. In most of the operational range the impedance is largely resistive. Between 100 Hz and 1 kHz it varies only between 6.1 Ω and 8.3 Ω. These are typical values for speakers with a nominal impedance of 8 Ω, as the nominal impedance is usually taken to represent a mean value over the usable frequency range, which for this driver extends between somewhat below 100 Hz and above 1 kHz. At frequencies higher than 1 kHz, the impedance continues to increase as the inductance of the voice coil starts playing a more important part.
Figure 3-28: Electrical impedance (Ω) of the loudspeaker as a function of frequency (Hz).

**Modeling in COMSOL Multiphysics**

The step-by-step instructions takes you through the following steps:

- Perform a static analysis of the magnetic field distribution to evaluate the force factor, $BL$.
- Sweep the frequency in an AC analysis where you apply a time-harmonic voltage to the voice coil, to compute the blocked coil impedance, $Z_b$.
- Use $BL$ and $Z_b$ in an acoustic-structure interaction analysis computing the sound pressure level and total electrical impedance of the driver as functions of the frequency.
- (Optional): Prepare for the Vented Loudspeaker Enclosure model by performing a separate mechanical analysis of the suspension, exporting its frequency-dependent resistance and compliance as well as $Z_b$.

The static magnetic field computation and the AC analysis use the Small-Signal Analysis multiphysics node available in COMSOL’s AC/DC Module. This node contains two application modes. First, the field from the magnet is computed in a static
application mode. The iron used in the pole piece and top plate is a nonlinear magnetic material, with interpolation data describing the relationship between the $B$ and $H$ fields. After solving this step of the model, you can evaluate $BL$ by integrating the magnetic flux density over the voice coil domain.

The time-harmonic application mode in the small-signal analysis inherits the permeability distribution from the static application mode. For the time-harmonic assumption to be strictly valid, the applied AC voltage must be so small that the resulting current creates a magnetic field which does not significantly alter this permeability. Even though this is hardly the situation here, linearizing around a local biased permeability should still be a better approximation than assuming a constant permeability. The very most accurate way to compute the impedance would be in a fully transient analysis, which is outside the scope of this model.

The Acoustic-Structure Interaction multiphysics node features a structural Stress-Strain application mode for the moving structures and a Pressure Acoustics application mode for the air. It also provides the boundary conditions for the two-way acoustic coupling between the air and the structures.

In most loudspeaker specifications, the suspension is characterized by a mechanical compliance $C_s$ and resistance $R_s$. In order to keep the resistance constant over a range of frequencies, the material needs to have a damping factor that increases linearly with the frequency or, equivalently, Rayleigh damping with $\alpha_{M} = 0$ and a constant $\beta_{MK} = \eta_0/\omega_0$, where $\eta_0$ is the loss factor measured at the angular frequency $\omega_0$. In this model, the frequency where the loss factor is measured is chosen to be near the lowest mechanical resonance of the driver.
Modeling Using the Graphical User Interface—Force Factor

MODEL NAVIGATOR
1 In the Model Navigator go to the Space dimension list and select Axial symmetry (2D).
2 In the list of application modes select AC/DC Module>Quasi-Statics, Magnetic>Azimuthal Induction Currents, Vector Potential>Small-signal analysis.
3 Click OK.

Selecting the Small-signal analysis makes two Azimuthal Induction Currents, Vector Potential application modes appear in the Multiphysics menu. They are named emqa and emqa2. The emqa application mode is for computing the static magnetic field. The time-harmonic emqa2 application mode uses the static field solution in evaluating the permeability in the partially saturated iron core.

OPTIONS AND SETTINGS
Choose Options>Constants. Enter the data given in this table (the descriptions are optional); when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>N</td>
<td>100</td>
<td>Number of turns in coil</td>
</tr>
<tr>
<td>B0</td>
<td>0.4[T]</td>
<td>Remanent flux density in magnet</td>
</tr>
</tbody>
</table>

GEOMETRY MODELING
The geometry in this model can be created with COMSOL’s drawing tools, but to save time, you will import it from a prepared file.
1 Choose File>Import>CAD Data From File.
2 Browse to the file loudspeaker_driver.mphbin, which is located in your COMSOL Multiphysics installation folder under models/Acoustics_Module/Industrial_Models.

PHYSICS SETTINGS
Subdomain Settings
In order to evaluate the loudspeaker’s force factor you need to compute the magnetic flux density in the voice coil’s air gap. This simulation is made with the emqa application mode.
1 In the Multiphysics menu, select the first one of the two application modes, named emqa.
The field from the static magnet is mostly contained in the magnetic motor of the driver, and decreases the further out you get from it. To minimize the computational effort, it makes sense to deactivate those subdomains where you can expect the field to be negligible.

2 Choose Physics>Subdomain Settings.

3 Select Subdomains 1, 3–5, 10, and 13. Clear the Active in this domain check box.

Next, apply a magnetization to the magnet.

4 Select Subdomain 12. For the Constitutive relation pick \( B = \mu_0 \mu_r H + B_r \), then type \( B_0 \) in the right-most of the two edit fields for remanent flux density. This gives a remanent flux density equal to 0.4 T in the z direction.

The pole piece and top plate will take their nonlinear B-H relation from the Material Library. The electric conductivity is also assigned and will be used in the subsequent impedance computation.

5 Select Subdomains 6 and 11. Click the Load button, then in the Electric (AC/DC) Material Properties list select Soft Iron (with losses) and click OK.

The cone apex, the voice coil, and the spider are not magnetic. Therefore, as for the surrounding air, these parts will use the default value for the relative permittivity, \( \mu_r = 1 \).

6 Click OK to close the dialog box.

Boundary Conditions

1 Choose Physics>Boundary Settings.

2 Select Boundary 2, then in the Boundary condition list select Axial symmetry.

Of the boundaries along the \( z \)-axis, Boundary 2 is the only one that is active in the magnetic model. All other exterior boundaries use the default Magnetic insulation, which is reasonable where the field is small.

3 Click OK to close the dialog box.

Coupling Variables

1 Choose Options>Integration Coupling Variables>Subdomain Variables.

2 In the Subdomain Integration Variables dialog box select the voice coil (Subdomain 8) and create the following subdomain integration variables:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>1</td>
</tr>
<tr>
<td>BL</td>
<td>-N<em>Br_emqa</em>2<em>pi</em>r/A</td>
</tr>
</tbody>
</table>
(Use the default settings for Integration order and Global destination.) The Expression field contains the integrand to be integrated over the voice coil subdomain. \( A \) will hence evaluate to the cross-sectional area of the voice coil, making the force factor \( BL \) roughly equal to the number of windings times the mean flux density in the voice coil.

**Mesh Generation**

To optimize the accuracy of the force factor and prepare for the impedance computation, you need a dense mesh throughout the magnetic motor. The voice coil, where your integration coupling variable evaluates the force factor, is so thin that the default settings automatically will give a sufficient resolution.

1. Choose Mesh>Free Mesh Parameters and click the Subdomain tab.
2. Press Ctrl+A to select all subdomains, then set the Method to Triangle.
3. Select only Subdomains 6, 11, and 12, then set the Maximum element size to \( 1e^{-3} \).
4. Click the Remesh button.
5. When the mesher has finished, click OK to close the Free Mesh Parameters dialog box.

**Computing the Solution**

1. Choose Solve>Solver Manager.
2. On the Solve For page, select only the first application mode, solving for \( Aphi \).
3. Click OK, then the Solve button on the Main toolbar to compute the solution.

**Postprocessing and Visualization**

The default plot shows the magnetic flux density. You can use the Zoom Window button to zoom in on the magnetic motor. If you keep only the air subdomain visible and suppress all others from the view, it will become apparent that the gap acts to focus the flux.

1. Choose Options>Suppress>Suppress Subdomains.
2. Select Subdomain 2, then click Apply.
3. Click the Invert Suppression button, then click OK.
4. Click the Postprocessing Mode button on the Main toolbar.

Proceed to visualize the direction and relative magnitude of the flux with an arrow plot.

1. Choose Postprocessing>Plot Parameters and click the Arrow tab.
2. On the Arrow page, select the Arrow plot check box.
3 From the list of Predefined quantities, select Azimuthal Induction Currents, Vector Potential (emqa)>Magnetic flux density.

4 Under Number of points, enter 60 both for r points and z points.

5 Click OK to see the plot and reproduce Figure 3-22.

The force factor should ideally be independent of the momentary location of the voice coil in the air gap. For this to happen, the flux density should be nearly constant in the air gap and close to zero outside of it. Proceed to visualize the flux density as a function of the z-coordinate along the voice coil.

1 Choose Postprocessing>Domain Plot Parameters.

2 On the Line/Extrusion page select Boundary 29 and type normB_emqa in the Expression edit field. Click OK to generate the new plot, which should resemble that in Figure 3-29.

![Figure 3-29: Magnetic flux density along the voice coil.](image)

Next, find out the value of the force factor.

1 Choose Postprocessing>Data Display>Global.

2 In the Expression edit field type BL. Click OK.
The force factor evaluates to 7.55 (N/A). As a final postprocessing step on the static solution, make a plot of the relative permeability.

1. Choose Options>Suppress>Suppress Subdomains.
2. Click the Suppress None button, then OK.
3. In the Plot Parameters dialog box, go to the Arrow page and clear the Arrow plot check box.
4. Go to the Surface page. From the list of Predefined quantities, select Azimuthal Induction Currents, Vector Potential (emqa)>Relative permeability.
5. Click OK to see the plot and reproduce Figure 3-23.

**Modeling Using the Graphical User Interface—Blocked Impedance**

**OPTIONS AND SETTINGS**
Choose Options>Constants and add the following constants to the list. The descriptions are optional.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>VO</td>
<td>4[V]</td>
<td>Peak driving voltage</td>
</tr>
<tr>
<td>R0</td>
<td>5.6[ohm]</td>
<td>DC resistance of coil</td>
</tr>
<tr>
<td>freq</td>
<td>100[Hz]</td>
<td>Sample driving frequency</td>
</tr>
</tbody>
</table>

The peak driving voltage of 4 V corresponds to an RMS level of 2.83 V. Defining freq, which you will use as the solver parameter, as a constant is not necessary. However, it gives you the option of verifying that your model setup is complete by solving for a single frequency with the stationary solver before doing the full frequency sweep.

**Coupling Variables**
1. Choose Options>Integration Coupling Variables>Subdomain Variables.
2. In the Subdomain Integration Variables dialog box select the voice coil (Subdomain 8) and add the following subdomain integration variables:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vi</td>
<td>N<em>Ephi_emqa2</em>2<em>pi</em>r/A</td>
</tr>
<tr>
<td>Ib</td>
<td>Jphi_emqa2/N</td>
</tr>
</tbody>
</table>

You have now defined $V_i$, the induced voltage in the blocked voice coil, as the mean induced azimuthal electric field in the coil subdomain times the total wire length.
the current through the blocked coil, is the total current through the subdomain divided by the number of turns.

3 Choose Options>Expressions>Global Expressions. In the resulting dialog box enter the following expressions and descriptions; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zb</td>
<td>V0/Ib</td>
<td>Blocked coil impedance (ohm)</td>
</tr>
<tr>
<td>Lb</td>
<td>imag(Zb)/(2<em>pi</em>freq)</td>
<td>Blocked coil inductance (H)</td>
</tr>
</tbody>
</table>

The blocked coil impedance and inductance are now defined in terms of the applied voltage and the yet-to-be-computed current through the blocked coil. Note that because they are functions of coupling variables, which do not support units, these expressions have undefined units in the COMSOL user interface.

**PHYSICS SETTINGS**

**Subdomain Settings**

1 In the Multiphysics menu, select the second one of the two application modes, named emqa2.

2 Choose Physics>Subdomain Settings.

3 Select the same subdomains that you deactivated in the emqa application mode (Subdomains 1, 3–5, 10, and 13). Clear the Active in this domain check box.

4 Select Subdomain 8 and set the **External current density** to \(N \times (V0 + V1)/R0/A\).

The current through each of the \(N\) turns of the coil is now equal to the sum of the applied voltage and the negative induced voltage, divided by the resistance of the coil. The emqa2 application mode inherits the conductivity and the computed relative permeability from the emqa application mode, so there is no need to reapply any material settings.

**Note:** Normally, the Loop potential edit field is the most convenient way to apply a voltage. The reason you used an equivalent external current density instead is that with a loop potential, you would also need to supply a nonzero Electric conductivity to describe the material in the coil. This would result in the induced current being inhomogeneously distributed over the coil domain, as if it were a continuous metal...
cylinder. In contrast, setting the conductivity to zero and letting the coil resistance appear in the external current density means that the induced current density is forced to be constant over the coil domain. Since the current in each turn of the coil wire by necessity is the same, this is the desired homogenization of the coil.

\[\text{Boundary Conditions}\]

1. Choose \textit{Physics>Boundary Settings}.
2. Select Boundary 2, then in the \textit{Boundary condition} list select \textit{Axial symmetry}.
3. Click \textit{OK} to close the dialog box.

\textbf{Mesh Generation}

The mesh used in computing the impedance needs to resolve the induced eddy currents in the pole piece and top plate. For the results to be accurate, the skin depth needs to be resolved by at least 1, preferably 2 quadratic elements.

With a conductivity of \(1.17 \times 10^7\) S/m and a peak relative permeability of 1200, the skin depth in the iron at the maximum frequency of 3.5 kHz does not go below 0.07 mm. In practice, most of the induced currents will run in regions of the pole piece where the biased relative permeability is much less than 1200, which makes the skin depth greater. In this model, it is therefore sufficient to use a mesh size of 0.1 mm along the iron surfaces that are closest to the voice coil. To apply this fine mesh mostly where it is needed, you will at the same time increase the global mesh growth rate.

1. Choose \textit{Mesh>Free Mesh Parameters}.
2. On the \textit{Global} page click the \textit{Custom mesh size} button and set the \textit{Element growth rate} to 2.
3. On the \textit{Boundary} page select Boundaries 8, 9, 11, 12, 30–32, and 37. Set the \textit{Maximum element size} to \(10^{-4}\).
4. Click the \textit{Remesh} button.
5. When the mesher has finished, click \textit{OK}.

\textbf{Computing the Solution}

1. Choose \textit{Solve>Solver Manager}.
2. On the \textit{Initial Value} page, click the \textit{Store Solution} button and set \textit{Value of variables not solved for} and \textit{linearization point} to \textit{Stored solution}.
3. On the \textit{Solve For} page, select only the second application mode, solving for \textit{Aphi2}. 
4 Click OK to close the dialog box.

By setting the Value of variables not solved for to Stored solution, you have now told
the software to use the static magnetic field solution when doing the impedance
computation.

5 Choose Physics>Scalar Variables. In the dialog box that appears, find the frequency
nu_emqa2 and type freq in the Expression edit field; click OK to close the dialog box.

6 From the Solve menu open the Solver Parameters dialog box.

7 From the Solver list, select Parametric.

8 In the Parameter names edit field, type freq.

9 In the Parameter values edit field type logspace(1,log10(3500),40). This will
generate 40 logarithmically-spaced frequencies between 10 Hz and 3.5 kHz.

10 Click OK, then click the Solve button on the Main toolbar to compute the solution.

POSTPROCESSING AND VISUALIZATION
The plot still shows the relative permeability. Zoom in on the iron core and study the
induced currents for a couple of frequencies.

1 From the Postprocessing menu select the Plot Parameters dialog box. Go to the
Surface page and from the list of Predefined quantities select Azimuthal Induction
Currents, Vector Potential (emqa2)>Induced current density, phi component.

2 On the General page, set the Element refinement to 3 and try a few different
frequencies from the Parameter value list. Verify that the current extends further into
the core at lower frequencies.

You can also plot the blocked coil impedance and inductance as functions of the
frequency.

3 Choose Postprocessing>Global Variables Plot.

4 From the Predefined quantities list, select the Blocked coil inductance.

5 Click first the > button and then OK to see a plot of the blocked coil inductance
versus frequency. It decreases from near 1.2 mH at 10 Hz to just below 0.6 mH at
3.5 kHz.

Modeling Using the Graphical User Interface—Acoustics

Now knowing the constant force factor and the blocked impedance versus the
frequency, it is time to set up the mechanical and the acoustic parts of the loudspeaker
model.
1 Choose Multiphysics>Model Navigator.
2 In the list of application modes select Acoustics Module>Acoustic-Structure Interaction>Frequency response analysis. Click Add.
3 Click OK.

Selecting Acoustic-Structure Interaction gives you an Axial Symmetry, Stress-Strain application mode for the moving parts in the driver and a Pressure Acoustics application mode for the acoustic pressure wave in the air.

OPTIONS AND SETTINGS

Constants
Choose Options>Constants and add the following constants to the existing list; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>f0</td>
<td>40[Hz]</td>
<td>Frequency where loss factor is given</td>
</tr>
<tr>
<td>omega0</td>
<td>2<em>pi</em>f0</td>
<td>Angular frequency where loss factor is given</td>
</tr>
</tbody>
</table>

Coupling Variables
1 Choose Options>Integration Coupling Variables>Subdomain Variables.
2 In the Subdomain Integration Variables dialog box select the voice coil (Subdomain 8) and add the following subdomain integration variable:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>v</td>
<td>w_t_acaxi/A</td>
</tr>
<tr>
<td>Vol</td>
<td>2<em>pi</em>r</td>
</tr>
</tbody>
</table>

The expression \( w_t_acaxi \) is the local \( z \)-velocity of the voice coil. You can find the definition of this and other application mode-specific variables from Physics>Equation System>Subdomain Settings, on the Variables page. Integrating over Subdomain 8 and dividing by its area means that the variable \( v \) will now contain the average \( z \)-velocity of the voice coil. The expression \( Vol \) will evaluate to the volume of the coil.
Global Expressions
Choose Options>Expressions>Global Expressions. Add the following scalar expressions; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>I</td>
<td>((V_0 - BL*v) / Z_b)</td>
<td>Total current (A)</td>
</tr>
<tr>
<td>Z</td>
<td>(V_0/I)</td>
<td>Total electrical impedance (ohm)</td>
</tr>
<tr>
<td>F_e</td>
<td>(BL*I)</td>
<td>Total electric force (N)</td>
</tr>
</tbody>
</table>

You have now defined the current and the electric impedance of the voice coil in motion, as well as the electric force driving the coil. Note that in the case of zero velocity, both the current and the impedance reduce to their blocked coil counterparts, \(I_b\) and \(Z_b\).

Application Scalar Variables
1 Choose Physics>Scalar Variables.
2 Make sure that the Synchronize equivalent variables check box is checked, then in the Expression field for freq_acaxi enter freq.
   Note that because the Synchronize equivalent variables check box is selected, freq_acpr will automatically change and become freq.
3 Click OK.

Physics Settings
Subdomain Settings—Stress-Strain
1 Choose Multiphysics>Axial Symmetry, Stress-Strain (acaxi).
2 Choose Physics>Subdomain Settings.
3 Select all subdomains that represent air: 1, 2, 4, and 5.
4 From the Group list (not the Groups tab), select Fluid domain.
   The subdomains that you have made fluid domains will be deactivated from the solid equation. The magnet assembly will not move or deform in this simulation, and should therefore also be deactivated.
5 Select Subdomains 6, 11, and 12, then clear the Active in this domain check box.
6 The active subdomains need material properties. Assign properties according to the table below. The damping parameters are located on the Damping page.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAINS 3, 10</th>
<th>SUBDOMAIN 7</th>
<th>SUBDOMAIN 8</th>
<th>SUBDOMAIN 9</th>
<th>SUBDOMAIN 13</th>
</tr>
</thead>
<tbody>
<tr>
<td>E</td>
<td>140e9</td>
<td>70e9</td>
<td>110e9</td>
<td>0.48e9</td>
<td>1.6e6</td>
</tr>
<tr>
<td>ν</td>
<td>0.42</td>
<td>0.33</td>
<td>0.35</td>
<td>0.3</td>
<td>0.4</td>
</tr>
<tr>
<td>ρ</td>
<td>720</td>
<td>2e3</td>
<td>8.7e3</td>
<td>650</td>
<td>67</td>
</tr>
<tr>
<td>Damping: loss factor</td>
<td>0.04</td>
<td>0.04</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Damping: Rayleigh, α</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Damping: Rayleigh, β</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>0.14/omega0</td>
<td>0.46/omega0</td>
</tr>
</tbody>
</table>

The material properties used in this model are partly made up, but aim to resemble those used in a real driver. The diaphragm and dust cap both consist of a HexaCon®-like material; a light and very stiff composite. The apex has properties representative of glass fibre materials. The spider, acting as a spring, is made of a phenolic cloth with a much lower stiffness. The surround, finally, is a light resistive foam.

7 Select Subdomain 8 and click the Load tab. In the \( F_z \) edit field, type \( F_\theta/V_\text{vol} \) to apply the electric force to the voice coil.

8 Click OK.

Boundary Conditions—Stress-Strain
Except for the symmetry boundary and those where the spider and the surround are attached to the case, all boundaries experience the pressure load from the surrounding air.

1 Choose Physics>Boundary Settings.
2 Press Ctrl+A to select all active boundaries.
3 In the Group list, select Fluid load.
4 Select Boundaries 58 and 62.
5 Set the Constraint condition to Fixed, then on the Load page change the load to 0 in both directions.
6 Select Boundary 3 and change the load to 0 in both directions.
7 Click OK.
Subdomain Settings—Pressure Acoustics
In the Pressure Acoustics application mode, only the air subdomains should be active. There is no need to set any material properties, since the defaults are those for air.

1. Choose Multiphysics>Pressure Acoustics (acpr).
2. Choose Physics>Subdomain Settings.
3. Select all the solid subdomains: 3 and 6–13.
4. From the Group list (not the Groups page), select Solid domain.
   The subdomains that you have turned into solid domains will be deactivated from the pressure acoustics equation.
5. Select Subdomains 1 and 5. On the PML page, set the Type of PML to Spherical and select the Absorbing in radial direction check box.
6. Click OK.

Boundary Conditions—Pressure Acoustics
The same boundaries as experienced a pressure load in the Stress-Strain application mode should create a pressure wave due to the structural vibrations. The easiest way to select those boundaries is to briefly return to the Stress-Strain application mode and select them as a group.

1. Choose Multiphysics>Axial Symmetry, Stress-Strain (acaxi).
2. Choose Physics>Boundary Settings.
3. Click the Groups tab and select the Fluid load group.
4. Click Cancel to leave the dialog box.
5. Without clicking in the geometry, choose Multiphysics>Pressure Acoustics.
7. With the same boundaries still selected, set the Group drop-list to Structural acceleration.
8. Select the active boundaries along the symmetry axis: 1, 2, 4, and 5, then in the Boundary condition list select Axial symmetry.
   All remaining exterior boundaries will use the default condition, Sound hard boundary (wall). In order to compute the far-field sound pressure, you will also need a source boundary.
9. Select the Interior boundaries check box.
10. Select Boundary 70 and click the Far-Field tab.
11. Enter a new far-field variable with the Name pfar.
12. Click in the Field edit field, and the Field and Normal derivative entries will automatically be filled in.

13. Select the \texttt{z=0: Symmetric pressure} check box and click the Full integral radio button.

14. Click OK.

You have now supplied a source boundary encompassing all local sound sources and applied a symmetry plane to account for the infinite baffle. After computing the solution, you can evaluate the pressure in a point \((r, z)\) by entering \(\text{pfar}(r, z)\). To facilitate extraction of the sensitivity, define a new expression for the on-axis sound pressure level at a 1 m distance:

15. Choose Options>Expressions>Scalar Expressions.

16. Define a new variable with the Name SPL and the Expression

\[10 \log_{10}\left(0.5 \times \text{pfar}(0, 1) \times \text{conj}(\text{pfar}(0, 1))/\text{p_ref}_{\text{acpr}}^2\right)\]

**MESH GENERATION**

In this computation, the air domain and the thin moving structures need to be well resolved.

1. Choose Mesh>Free Mesh Parameters.

2. On the Global page, click the Reset to Defaults button, then in the Predefined mesh sizes list select Extra fine.

3. Click the Custom mesh size button. Set both the Element growth rate and the Resolution of narrow regions to 2.

4. Click the Subdomain tab. Press Ctrl+A to select all subdomains, then set the Method to Triangle.

5. Click the Remesh button.

6. When the mesher has finished, click OK.

**COMPUTING THE SOLUTION**

1. From the Solve menu select the Solver Manager.

2. On the Initial Value page, click the Store Solution button.

3. In the dialog box that appears, all parameter values should be selected. Click OK to store all solutions.

4. In the Values of variables not solved for and linearization point area, select All from the Parameter value list.

5. On the Solve For page select Axial Symmetry, Stress-Strain (acaxi) and Pressure Acoustics (acpr).
Click **OK** to close the **Solver Manager**.

6. Click the **Solve** button on the Main menu to compute the solution.

**POSTPROCESSING AND VISUALIZATION**

The plot still shows the induced currents, but now on a mesh that is not optimized for this analysis. Proceed to visualize the acoustic pressure field in the air.

1. Choose **Options>Suppress>Suppress Subdomains**. Select the PML subdomains (number 1 and number 5), then click **OK**.

2. Choose **Postprocessing>Plot Parameters**.

3. Click the **Surface** tab, and in the **Predefined quantities** list select **Pressure Acoustics (acpr)>Pressure**, or **Pressure Acoustics (acpr)>Sound pressure level** if you want to see the sound pressure measured in dB.

4. On the **General** page, use the **Parameter value** list to plot the pressure field for a few different frequencies; click **Apply** after making each selection to generate the plot. Figure 3-26 shows the sound pressure level at 3500 Hz.

5. When finished, click **OK**.

To view the sensitivity as a function of the pressure, execute the following instructions:

1. Choose **Postprocessing>Domain Plot Parameters**. On the **General** page click the **Title/Axis** button and select to use a **Log scale** for the **First axis**.

2. On the **Point** page select an arbitrary point, then in the **Expression** edit field enter **SPL**.

   Being defined as a scalar expression, the sensitivity needs to be evaluated somewhere in the geometry. No matter which point you choose, the result will still be that at a 1 m on-axis distance.

3. Click **Apply** to see the plot. You should see something similar to the image in Figure 3-27.

4. To see the total electric impedance, type **abs(Z)** in the **Expression** edit field and then click **Apply** again to reproduce Figure 3-28.

The impedance could also have been shown as a global plot.
Preparing for the Vented Loudspeaker Enclosure Model

The model “Vented Loudspeaker Enclosure” is an extension of the model that you are currently working on. It investigates how the sensitivity of this driver is affected by placing it in a bass-reflex enclosure. Because this by necessity becomes a large 3D model, it is important to consider the time and memory required to solve it, and, if needed, reduce them. The Vented Loudspeaker Enclosure model does this by modeling only the pressure acoustics. Its electromagnetic and mechanical properties are modeled as lumped parameters exported from this model. To extract these data, proceed as follows:

**BLOCKED COIL IMPEDANCE**

1. Choose Postprocessing→Global Variables Plot.
2. Select all entries in the Quantities to plot list, then click the < button.
3. From the Predefined quantities list, select Blocked coil impedance (ohm).
4. Click the > button, then click Apply.

   The plot that appears shows the real (resistive) part of the blocked coil impedance.
5. In the figure window, click the ASCII button to export the plot data.
6. Use the Browse button, select a suitable folder, and save the plot as Rb.txt.
7. Repeat the procedure to save the Blocked coil inductance (H) as Lb.txt.

Figure 3-30 shows the results.

![Figure 3-30: Blocked coil resistance (Ω) and blocked coil inductance vs. frequency (Hz).](image)

**MECHANICAL SUSPENSION IMPEDANCE**

The mechanical suspension impedance is an idealized way of describing the suspension’s mechanical behavior. It is defined as the complex-valued ratio between a force applied where the suspension would otherwise connect to the cone and the
velocity at the same place. To isolate the mechanical suspension from the rest of the model, run a structural simulation of only the spider and the surround.

**OPTIONS AND SETTINGS**

1. Choose **Options>Constants**.
2. Add the following constant to the existing list; when done, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>v0</td>
<td>1[m/s]</td>
<td>Velocity for suspension impedance simulation</td>
</tr>
</tbody>
</table>

**PHYSICS SETTINGS**

*Subdomain Settings*

1. Choose **Multiphysics>Axial Symmetry, Stress-Strain (acaxi)**.
2. Choose **Physics>Subdomain Settings** and select the solid subdomains that now should be excluded from the simulation: 3, 7, 8, and 10.
3. Clear the **Active in this domain** check box, then click **Apply**.
4. In the list of subdomains, verify that 9 and 13 are the only ones not grayed out, then click **OK** to close the dialog box.

*Boundary Settings*

1. Choose **Physics>Boundary Settings** and select the boundaries where the suspension connects to the cone, Boundaries 22 and 59.
2. In the **Constraint condition** list, select **Prescribed velocity**.
3. Select the **V_r** and **V_z** check boxes. For **Velocity r dir.**, keep the default 0. For **Velocity z dir.**, enter v0.
4. Click **OK** to close the dialog box.

From the earlier simulation, the outer perimeter of the suspension is still fixed.

**COMPUTING THE SOLUTION**

1. Choose **Solve>Solver Manager**.
2. On the **Solve For** page, select to solve only for **Axial Symmetry, Stress-Strain (acaxi)**.
3. On the **Initial Value** page, set **Values of variables not solved for and linearization point** to **Zero**.

Setting the value of the variables not solved for to zero means that you can keep the fluid load boundary condition and still not have any forces from the previous pressure acoustics solution acting on the suspension.
4 Click OK to close the dialog box.
5 Click the Solve button on the Main menu to compute the solution.

POSTPROCESSING AND VISUALIZATION
The plot now shows zero acoustic pressure everywhere. Follow the instructions below to show the suspension’s deformation.

1 Choose Postprocessing>Plot Parameters, then click the Surface tab.
2 From the Predefined quantities list on the Surface Data page, choose Axial Symmetry, Stress-Strain (acaxi)>Total displacement. From the Unit list, choose \( \mu \text{m} \).
3 Click the Deform tab, then select the Deformed shape plot check box.
4 From the Predefined quantities list, choose Axial Symmetry, Stress-Strain (acaxi)>Displacement.
5 On the General page, type 90 in the Solution at angle (phase) edit field.
6 Click OK to see the plot, which now shows the shape of the suspension at the time of maximal displacement (90° out of phase with the applied velocity). The plot should look like that in the picture below.

![Figure 3-31: The deformed suspension at 3500 Hz.](image)

Proceed to view and store the suspension resistance and compliance.
7 Choose Postprocessing>Boundary Integration.

8 In the Expression to integrate area, select Axial Symmetry, Stress-Strain (acaxi)>Reaction Force, z-dir. from the Predefined quantities list; the expression RFz_acaxi then appears in the Expression edit field with the unit N for newton displayed in the Unit of integral list.

The predefined boundary variables RFr_acaxi and RFz_acaxi provide a convenient way to compute accurate reaction forces. They are only defined in the node points of the finite element mesh and specifically designed to be used for postprocessing in the Boundary Integration dialog box.

9 Edit the Expression to read real(RFz_acaxi/v0). This is the suspension’s resistance. Verify that its unit is kg/s, which is the same as Ns/m.

10 Select the Compute surface integral (for axisymmetric modes) check box.

11 Click Plot to plot the resistance vs. frequency.

12 To obtain a logarithmic frequency scale, click the X log button in the figure window’s toolbar.

Figure 3-32 shows the resulting plot. The title and axis labels in this figure have been modified in the Edit Plot dialog box, which you open by clicking the figure-window toolbar button with the same name.

![Figure 3-32: Suspension resistance (Ns/m) vs. frequency (Hz).](image)

13 In the figure window, click the ASCII button to export the plot data.

14 In the Save Current Plot in ASCII File dialog box, click the Browse button.

15 In the Save Data As dialog box, select a suitable location, enter the File name Rs.txt, and then click Save.
Back in the **Save Current Plot in ASCII File** dialog box, the full file path now appears in the **Export to file** edit field. Click **OK** to export the plot in the default format, which gives a text file with a header followed by frequencies and the corresponding resistance values in two separate columns.

Return to the **Boundary Integration** dialog box, and change the **Expression** to 

$$-1/(2\pi f \text{imag}(RF_{z_{acaxi}}/v0))$$

This is the suspension’s compliance with unit kg²/m or, equivalently, m/N.

Click **Plot** to plot the compliance vs. frequency. Compare your result to Figure 3-33 (again, a logarithmic frequency scale, has been used).

Repeat Steps 13 through 16 to store the plot data in a text file, but this time use the file name **Cs.txt**.

![Graph showing suspension compliance (m/N) vs. frequency (Hz).](image)

*Figure 3-33: Suspension compliance (m/N) vs. frequency (Hz).*
Loudspeaker Driver in a Vented Enclosure

Introduction

This example models the acoustic behavior of a loudspeaker driver mounted in a bass reflex enclosure.

One of the most important design parameters for a loudspeaker driver is its sensitivity as a function of the frequency. The sensitivity is commonly defined as the on-axis sound pressure level, measured at a 1 m distance, as the driver is loaded by an AC voltage of 4 V. To isolate the driver's performance from that of the environment it usually operates in, the driver is often set directly in an infinite baffle. This approach is used in another example model in the Acoustics Module Model Library, called Loudspeaker Driver. This model borrows the electromechanical parameters from that example and shows how the enclosure affects the sensitivity.

The model uses the time-harmonic Pressure Acoustics application mode, available in the Acoustics Module, and a Global Equation connecting the driving voltage with the motion of the cone.

Model Definition

Figure 3-34 shows the geometry of the considered driver as modeled in the Loudspeaker Driver example. In the model described here, the driver is set in a frame and placed in a bass reflex enclosure (Figure 3-35). The defining feature of this enclosure type is the vent, which in a properly designed enclosure acts to boost the sound at low frequencies.

As seen in Figure 3-36, the infinite baffle is now flush with the front wall of the enclosure. Figure 3-37 shows the complete model geometry, which includes a spherical domain for the air outside the enclosure. The concentric spherical mantle that envelopes the air domain is a perfectly matched layer (PML), acting to absorb the outgoing waves with a minimum of reflections.
Figure 3-34: The driver, here set in an infinite baffle as in the Loudspeaker Driver model.

Figure 3-35: The frame and the vented enclosure.
Figure 3-36: The geometry of the loudspeaker. The black half circle represents the baffle, which, in the model, forms a full half-plane extending to infinity.

Figure 3-37: The complete model geometry. Thanks to the symmetry with respect to the $xz$-plane, the model consists of only one half of the speaker and the outside air.
The motion and deformation of the cone and the suspension as they interact with the sound pressure waves in the air should ideally be set up as a complete acoustic-structure interaction analysis, with the structural deformations computed locally. This approach is demonstrated in a number of models in the Model Library of COMSOL’s Acoustics Module, including the Loudspeaker Driver.

This model however makes the assumption that the cone operates in piston-mode (that is as a perfectly rigid object). Furthermore, it approximates the motion of the spider and the surround by linear functions decreasing with the distance from where they attach to the cone, to where they are fixed to the immobile frame. These simplifications mean that the motion of all deforming parts can be described by just one scalar, here chosen to be the $z$-directed acceleration applied to the cone, $a$.

The equation of motion for the cone then reads:

$$m a = F_e + F_s + F_a,$$  \hspace{1cm} (3-6)

where $m$ is the mass of the cone, $F_e$ is the electric driving force, $F_s$ is the reacting mechanical force from the suspension and spider, and $F_a$ is the acoustic pressure force from the air. The forces are defined as follows:

$$F_e = \frac{BLV_0}{Z_b} - v \frac{(BL)^2}{Z_b}$$

$$F_s = -v Z_s = -v \left( R_s + \frac{1}{j\omega C_s} \right)$$

$$F_a = 2 \int p n_z ds$$

Here, $\omega$ is the angular velocity and $v = a/(j\omega)$ is the cone velocity. $BL$ is known as the force factor of the voice coil and $Z_b$ is its blocked impedance; the electric impedance as measured when the coil is at stand-still. These parameters, as well as the mechanical resistance $R_s$ and compliance $C_s$, forming the impedance $Z_s$, are imported from the Loudspeaker Driver model. While the impedances have been computed as complex-valued functions of the frequency, $BL$ is a constant equal to 7.55 N/A. The documentation to the Loudspeaker Driver model (“Loudspeaker Driver” on page 145) contains a discussion of the terms in the expression for the electric force.

In the definition of $F_a$, the surface integral of the pressure, $p$, times the $z$-component of the normal (pointing outwards from the acoustics domain), is taken over both sides of the surface of the cone and suspension. The reason the suspension is included in the
domain is that the suspension impedance was modeled in vacuum. The factor 2 accounts for the fact that only half of the total geometry is included in the model.

$V_0$, finally, is the driving voltage. The definition of sensitivity assumes a driving power that equals 1 W when the total impedance of the loudspeaker is at its nominal value. The modeled driver has a nominal impedance of 8 $\Omega$, which translates to a driving voltage of $V = V_0 \exp(i\omega t)$ with the amplitude $V_0 = 4$ V.

The model defines $a$ in terms of the forces and $V_0$ as a function of $F_e$. It then solves a scalar equation adapting $a$ so that $V_0 = 4$ V is fulfilled.

For an alternative view of the force balance on the cone, see the circuit model in Figure 3-38.

![Circuit model of equations 3-6 and 3-7.](image)

**Figure 3-38: Circuit model of equations 3-6 and 3-7.**

**Results and Discussion**

The model produces a sound pressure distribution inside and outside the enclosure for all frequencies solved for. As one example of how you can visualize the solution, see Figure 3-39, which shows the pressure at 1052 Hz as an isosurface plot. An alternative option is shown in Figure 3-40, where the sound pressure level in dB is plotted on a slice near the symmetry plane.
Figure 3-39: Isosurface plot of the sound pressure at 1052 Hz.

Figure 3-40: Slice plot of the sound pressure level at 1052 Hz.
Thanks to COMSOL’s full integral far-field evaluation, you can evaluate the pressure not only inside the computational domain, but also anywhere outside the domain. This allows you to for instance plot the sound pressure level versus the elevation angle, or evaluate the directivity. The step-by-step instructions to this model show you how to plot the sensitivity (Figure ).

![SPL diagram]

Figure 3-41: Loudspeaker sensitivity measured as the on-axis sound pressure level (dB) at a distance of 1 m from the unit. The pressure is evaluated using an RMS input signal of 2.83 V, corresponding to a power of 1 W at 8 Ω. Note the logarithmic scale for the frequency.

Compared to the sensitivity of the baffled driver in the Loudspeaker Driver model (Figure 3-27 on page 153), adding the enclosure clearly results in a “boost” for the lower frequencies, roughly the range between 30 and 100 Hz. On the flip side, it also causes an undesired peak at approximately 700 Hz, due to a resonance forming in the box. While you cannot completely avoid such resonances, loudspeaker manufacturers typically make them less prominent by careful positioning of the driver and the vent, as well as shaping of the vent and the enclosure. It is also common to line or partly stuff the enclosure with damping materials.
Modeling in COMSOL Multiphysics

This model requires the Acoustics Module and uses the time-harmonic version of the Pressure Acoustics application mode to solve for the acoustic pressure distribution. The frequency-dependent data from the Loudspeaker Driver model is imported by interpolation functions reading from text files.

![Diagram of the driver and vent](image)

Figure 3-42: Cross-sectional view of the driver and vent. The parts, shown by numbers, are separated by black boundaries, representing pressure discontinuities, and gray identity pairs, across which the pressure is continuous.

In order to simplify the geometry, the cone and suspension are represented as boundaries. To allow for a discontinuous pressure across these boundaries, each boundary needs to constitute a border between two parts of an assembly (see “Using Assemblies” on page 413 in the COMSOL Multiphysics Modeling Guide). As shown in Figure 3-42, this implies that a total of 3 parts is required. The parts are joined with identity boundaries at the locations marked with arrows in the same figure, to make the pressure continuous in the air domains.

The model uses the parametric solver to sweep the frequency through a logarithmically spaced range of values from 10 Hz to 3.5 kHz.

**Model Library path:** Acoustics_Module/Industrial_Models/vented_loudspeaker_enclosure
MODEL NAVIGATOR
1 In the Model Navigator go to the Space dimension list and select 3D.
2 In the list of application modes select Acoustics Module>Pressure Acoustics.
3 Click OK.

GEOMETRY MODELING
The geometry in this model can be created with COMSOL’s drawing tools, but to save time, you will import it from a prepared file.

1 Choose File>Import>CAD Data From File.
2 Browse to the file vented_loudspeaker_enclosure.mphbin, which is located in your COMSOL Multiphysics installation folder under models/Acoustics_Module/Industrial_Models.
3 Click Import to import the geometry.
If you zoom in on the driver and click in the geometry, you will find that as depicted in Figure 3-42, it consists of three objects: one beneath the dustcap (CO2), one between the cone and the spider (CO3), and one for the rest of the geometry (CO1). The solid domains are part of CO1, but do not participate in the simulation and could in principle be excluded. In this model, they are kept in order to enable visualization of all parts of the speaker.
4 Choose Draw>Use Assembly.
You have now told the software to disconnect the solution between the objects. Proceed to create pairs reconnecting the objects only where the boundaries between them are not meant to represent physical barriers. Start with the boundaries between CO1 and CO2 (Pair 1 in Figure 3-43):
5 Choose Physics>Identity Pairs>Identity Boundary Pairs.
6 Click the New button. In the Source boundaries list, select the check boxes for Boundaries 99 and 118.
7 In the Destination boundaries list, select the check boxes for Boundaries 238 and 252.
Define Pair 2 between CO1 and CO2:
8 Click the New button. In the Source boundaries list, select the check boxes for Boundaries 108 and 110.
9 In the Destination boundaries list, select the check boxes for Boundaries 246 and 247.

Finally, create Pair 3 between CO1 and CO3:

10 Click the New button. In the Source boundaries list, select the check boxes for Boundaries 42, 53, 162, and 178.

11 In the Destination boundaries list, select the check boxes for Boundaries 186, 196, 227, and 233.

12 Click OK to close the dialog box.

Figure 3-43: The pair boundaries.

OPTIONS AND SETTINGS

1 Choose Options>Constants. Enter the data given in this table (the descriptions are optional); when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>BL</td>
<td>7.55[N/A]</td>
<td>Force factor</td>
</tr>
<tr>
<td>m</td>
<td>0.017[kg]</td>
<td>Cone mass</td>
</tr>
<tr>
<td>su_a</td>
<td>66[mm]</td>
<td>Inner radius of surround</td>
</tr>
<tr>
<td>su_b</td>
<td>82[mm]</td>
<td>Outer radius of surround</td>
</tr>
<tr>
<td>sp_a</td>
<td>18.4[mm]</td>
<td>Inner radius of spider</td>
</tr>
<tr>
<td>sp_b</td>
<td>66[mm]</td>
<td>Outer radius of spider</td>
</tr>
</tbody>
</table>

The force factor is the one computed in the Loudspeaker Driver model. You will use the measures of the spider and surround in defining the linear decrease of the acceleration from their inner to their outer radii.

2 Choose Physics>Scalar Variables.
For the **Excitation frequency**, type `freq` in the **Expression** edit field; click **OK** to close the dialog box.

The following steps take you through importing the electric impedance of the blocked voice coil and the mechanical impedance of the suspension, both of them as computed for a range of frequencies in the Loudspeaker Driver model. Since you cannot interpolate from complex-valued data, you will import the real and imaginary constituents separately.

4. Choose **Options->Functions**. Click the **New** button.

5. In the **Function name** edit field, type `Rb`.

6. Click the **Interpolation** button and select to **Use data from File**.

7. Click the **Browse** button, browse to `Rb.txt` (in your COMSOL installation folder under `models/Acoustics_Module/Industrial_Models`) and click **Open**.

8. Click **OK**, then the **New** button; repeat the procedure for `Lb`, `Rs`, and `Cs`.

9. Click **OK** to close the dialog box.

10. Choose **Options->Expressions->Global Expressions**. Enter the data given in this table (the descriptions are optional); when done, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>omega</td>
<td><code>2*pi*freq</code></td>
<td>Angular frequency (rad/s)</td>
</tr>
<tr>
<td>Zb</td>
<td><code>Rb(freq)+j*omega*Lb(freq)</code></td>
<td>Blocked coil impedance (ohm)</td>
</tr>
<tr>
<td>Zs</td>
<td><code>Rs(freq)+1/(j*omega*Cs(freq))</code></td>
<td>Suspension impedance (Ns/m)</td>
</tr>
<tr>
<td>v</td>
<td><code>a/(j*omega)</code></td>
<td>Cone velocity (m/s)</td>
</tr>
<tr>
<td>Fs</td>
<td><code>-v*Zs</code></td>
<td>Force from suspension (N)</td>
</tr>
<tr>
<td>Fe</td>
<td><code>m*a-(Fs+Fa)</code></td>
<td>Driving electric force (N)</td>
</tr>
<tr>
<td>V0</td>
<td><code>Fe*Zb/BL+v*BL</code></td>
<td>Driving voltage (V)</td>
</tr>
<tr>
<td>r</td>
<td><code>sqrt(x^2+y^2)</code></td>
<td>Radial coordinate for scaling (m)</td>
</tr>
<tr>
<td>surround</td>
<td><code>(r-su_b)/(su_a-su_b)</code></td>
<td>Acceleration scaling on surround</td>
</tr>
<tr>
<td>spider</td>
<td><code>(r-sp_b)/(sp_a-sp_b)</code></td>
<td>Acceleration scaling on spider</td>
</tr>
</tbody>
</table>

The expressions for $Z_b$ and $Z_s$ reconstruct the blocked coil and suspension impedances by calling the interpolation functions containing your imported data. The velocity, force, and voltage expressions define the relation between the cone acceleration $a$ and the driving voltage $V_0$, as described in the Model Definition. Note that $F_a$, the acoustic pressure force on the cone and suspension, is yet to be defined. The acceleration scaling expressions evaluate to 1 on the inner perimeters of the surround and spider, and decrease linearly to 0 on their outer perimeters.
PHYSICS SETTINGS

Global Equations
2. Create a new equation with the Name a and the Expression V0 - 4.
The equation you just entered means “adapt a so that V0 - 4 V = 0 can be fulfilled.”

Subdomain Settings
1. Choose Physics>Subdomain Settings.
2. Select the solid subdomains, that is Subdomains 2 and 4–9. Clear the Active in this domain check box.
3. Select Subdomain 1 and click the PML tab.
4. From the Type of PML list, select Spherical.
5. Select the Absorbing in r direction check box.
6. For the PML center point, set x0 to -0.07.
7. Set the PML scaling exponent to 2.
8. Click OK to close the dialog box.
The PML center point is set to coincide with the geometric center point of the PML domain. A scaling exponent of 2 means that the damping increases the further into the PML you go. This lowers the risk that any internal reflections due to insufficient mesh resolution substantially affect the solution.

Boundary Conditions
The first boundary setting you will apply is the acceleration condition on the spider. Start by selecting the boundaries constituting the spider:
1. Click the Boundary Mode button on the Main toolbar.
2. Click the Go to YZ View button on the Camera toolbar.
3. Click to deselect the Orbit/Pan/Zoom button on the Camera toolbar.
3 Use the **Zoom Window** button on the Main toolbar to zoom in on the driver; then draw a box to select the spider boundaries, as in Figure 3-44, which also shows an isometric view of the same selected boundaries.

![Figure 3-44: The spider boundaries, in the yz plane and in the default 3D view.](image)

4 Choose **Physics>Boundary Settings**. If you want to verify that you selected the right boundaries, you can scroll through the **Boundary selection** list. The selected boundaries should be 59, 66, 75, 85, 88, 91, 92, 96, 122, 127, 131, 132, 134, 135, 141, 145, 146, 197, 200–207, 211, and 213–220. Note that because the spider constitutes the border between two parts of an assembly, it consists of two layers of boundaries, one for each part.

5 From the **Boundary condition** list, select **Normal acceleration**.

6 In the **Inward acceleration** text field, type \(-a \cdot n_{\text{spider}}\). The term “inward” here refers to the direction of a normal vector pointing from the boundary into its assembly part. The acceleration you applied is equal to the factor governing the linear decrease multiplied by \(-a \cdot n\), where \(a = ae_z\), and \(n\) is the normal vector pointing outward from each part of the assembly.

7 By clicking in the geometry or picking from the **Boundary selection** list, select the boundaries on both sides of the surround: Boundaries 46, 48, 148, 150, 190, 192, 222, and 223. See Figure 3-45.

8 From the **Boundary condition** list, select **Normal acceleration**.

9 In the **Inward acceleration** text field, type \(-a \cdot n_{\text{surround}}\).
By clicking in the geometry or picking from the **Boundary selection** list, select the boundaries on both sides of the cone and dust cap: Boundaries 61, 100, 111, 123, 198, 212, 240, and 248. See Figure 3-45.

**Figure 3-45:** The boundaries of the surround (left) and cone and dust cap (right).

From the **Boundary condition** list, select **Normal acceleration**.

In the **Inward acceleration** edit field, type \(-a^*\text{nz}\).

The remaining boundaries will use the default **Sound hard boundary (wall)** condition. Proceed to specify the source boundaries for the far-field pressure computation.

Select the **Interior boundaries** check box.

Select Boundaries 16 and 55, then click the **Far-Field** tab.

Enter a new far-field variable with the **Name** \(p_{\text{far}}\).

Click in the **Field** edit field, and the **Field** and **Normal derivative** entries will automatically be filled in.

Click the **Full integral** button.

Select the \(y=0\): **Symmetric pressure** and \(z=0\): **Symmetric pressure** check boxes.

Click **OK**.

You have now supplied a source boundary encompassing all local sound sources and applied symmetry planes to account for the infinite baffle and the geometric symmetry. After computing the solution, you can evaluate the pressure in a point \((x, y, z)\) by entering \(p_{\text{far}}(x, y, z)\). To facilitate extraction of the sensitivity, define a new expression for the on-axis sound pressure level at a 1 m distance:

**Choose Options>Expressions>Scalar Expressions.**

Define a new variable with the **Name** \(\text{SPL}\) and the **Expression**

\[10\times\log_{10}(0.5\times p_{\text{far}}(0, 0, 1)\times \text{conj}(p_{\text{far}}(0, 0, 1))/p_{\text{ref acpr}}^2)\], then click **OK**.
The variable $p_{\text{ref acpr}}$ is a reference level, defined from Physics>Scalar Variables. Per default, it is set to 20 $\mu$Pa, which is the most commonly used value for air.

The $z$-component of the pressure force on the moving parts is given by an integral on all the moving boundaries. Now that you have applied the acceleration boundary conditions, it is easy to select these boundaries.

1. Open the Boundary Settings dialog box again, from Physics>Boundary Settings.
2. Click the Groups tab and select the groups where you have applied an acceleration; these groups are unnamed3, unnamed4, and unnamed5.
3. Click Cancel to close the dialog box without applying any further settings.
4. With the boundaries still selected, choose Options>Integration Coupling Variables>Boundary Variables.
5. Create a new boundary integration variable with the Name Fa and the Expression $2*p*nz$.
6. Click OK.

Mesh Generation

For the solution to properly connect across the identity pairs, the mesh on the destination boundary cannot be coarser than that on the source boundary. The optimal way to mesh an identity pair is to use the Copy mesh feature to get an identical mesh on both boundaries. This can only be done sequentially, two boundaries at a time. The effort pays off however, as the result is a mesh that allows an iterative solver to converge. Compared to a direct solver, the iterative solver operates slightly faster and uses much less memory.

The other thing to keep in mind when you mesh this model is that you need to resolve the wave at all frequencies, with at least 5 to 6 elements per wavelength to obtain a good accuracy. The highest frequency you will solve for is 3.5 kHz.

1. Choose Mesh>Free Mesh Parameters.
2. In the Predefined mesh sizes list select Coarse, then click the Custom mesh size button.
3. In the Maximum element size edit field, type $343/3500/4.5$. The next step in the instruction will guide you through creating the boundary mesh, so make sure to keep the dialog box open and do not generate the mesh just yet.

This setting will give you a mesh size less than or equal to the wavelength at 3.5 kHz divided by 4.5. Due to the exact definition of mesh size and the way the mesh elements are distributed, you will in practice get around 6 mesh elements per wavelength at this frequency.
**Note:** With the maximum element size that you just applied, the solution process will use roughly 1 GB of memory.


5 Click the Mesh Selected button.

6 In the Boundary selection list, select only Boundaries 42 and 186.

7 With the Free Mesh Parameters dialog box still open, click the Copy Mesh button on the Mesh toolbar.

8 Repeat the procedure for the following pairs of boundaries: 53 and 196, 99 and 238, 108 and 246, 110 and 247, 118 and 252, 162 and 227, 178 and 233.

9 Click OK, then click the Mesh remaining (free) button on the Mesh toolbar to generate the mesh.

**COMPUTING THE SOLUTION**

1 From the Solve menu choose Solver Parameters.

2 In the Solver list, select Parametric.

3 In the Parameter names edit field, type freq.

4 In the Parameter values field, type logspace(1,log10(3500),40).

   This gives you a logarithmically spaced list of 40 frequencies between 10 Hz and 3.5 kHz.

**Note:** Depending on the specifications of your computer, the solution may take up to a few minutes per frequency. If you want to save time, you can choose to solve for fewer frequencies by entering a number less than 40.

5 From the Linear system solver list, select GMRES.

6 From the Preconditioner list, select Geometric multigrid.

7 Click the Settings button.

8 In the tree structure, select Coarse solver.

9 From the Coarse solver list, select PARDISO.

10 Click OK twice to close both open dialog boxes.
Click the **Solve** button on the Main toolbar to compute the solution.

**POSTPROCESSING AND VISUALIZATION**

The default plot shows the pressure distribution on five equidistant slices parallel with the \( yz \)-plane, at 3500 Hz. To get a better view, try excluding the PML and plotting the sound pressure level on a slice near the symmetry boundary:

1. Choose **Options>Suppress>Suppress Subdomains**.
2. Select Subdomain 1 and click **OK**.
3. Choose **Postprocessing>Plot Parameters** and click the **Slice** tab.
4. From the list of **Predefined quantities** select **Sound pressure level**.
5. Under **Slice positioning**, set **Number of x levels** to 0.
6. For **y levels**, click the option button under **Vector with coordinates** and enter **1e-3**.
7. Click **OK** to see the plot, which should look like Figure 3-46.

![Figure 3-46: Sound pressure level (dB) at 3500 Hz.](image)

8. To study the sensitivity, choose **Postprocessing>Domain Plot Parameters** and click the **Point** tab.
9. In the **Expression** edit field, enter **SPL**.
10 Select Point 1 and click OK.

11 Click the x log button to get logarithmically spaced frequencies and reproduce Figure 3-41.

**Note:** If you would like to compare the sensitivity in this model with that of the driver in an infinite baffle, keep the figure window open while opening the Loudspeaker Driver model from the Model Library. On the **General** page of the **Domain Plot Parameters** dialog box in that model, select to **Keep current plot** and **Plot in Figure 1** before plotting SPL. Now both sensitivity plots will appear.

Figure 3-39 shows the pressure distribution as isosurfaces at 1052 Hz. The boundaries are yellow on the driver and vent, red on the enclosure, and black on the infinite baffle. To find out which plot parameters were used in creating this plot, you can open the model from the Model Library and choose **Postprocessing>Plot Parameters**. Note that the expression `bndcol`, which is used on the **Boundary** page, was defined from **Physics>Expressions>Boundary Expressions** to take on different values on the different boundaries. Note also that certain edges have been suppressed, using **Options>Suppress>Suppress Edges**.
Muffler with Perforates

The original version of this model was developed by Dr. Sabry Allam and Prof. Mats Åbom at the Marcus Wallenberg Laboratory for Sound and Vibration Research, Royal Institute of Technology, Stockholm, Sweden. Dr. Allam and Prof. Åbom also provided the experimental data used in the model.

Introduction

There are two basic types of mufflers:

• **Reflective (or reactive) mufflers**—those that reflect acoustic waves by abrupt area expansions or changes of impedance.

• **Dissipative mufflers**—mufflers based on dissipation of acoustic energy into heat through viscous losses in fibrous materials or flow-related (resistive) losses in perforated pipes.

Reflective mufflers are best suited for the low frequency range where only plane waves can propagate in the system, while dissipative mufflers with fibers are efficient in the mid-to-high frequency range. Dissipative mufflers based on flow losses, on the other hand, work also at low frequencies. A typical automotive exhaust system is a hybrid construction consisting of a combination of reflective and dissipative muffler elements. The reflective parts are normally tuned to remove dominating low-frequency engine harmonics while the dissipative parts are designed to take care of higher-frequency noise.

In the industry, exhaust systems are typically analyzed with nonlinear 1D gas-dynamics codes. Such codes, however, do not capture 3D acoustic effects such as higher-order duct modes, and the modeling of fibrous materials is not satisfactory. In practice, there is therefore a need to use linear acoustic models of exhaust and intake systems to enable detailed modeling and optimization of the acoustic response, at the cost of neglecting nonlinear effects.

Model Definition

The muffler you analyze in this model is an example of a complex hybrid muffler in which the dissipative element is created completely by flow through perforated pipes.
and plates. When designing a model for a muffler without fibrous materials you need to consider the following aspects:

- **Geometry**—The design for this model is based on a modular muffler developed for research purposes. It closely resembles commercially available automotive mufflers, and was used as a test case for muffler modeling in a recent EC-project (ARTEMIS).

- **Mean flow distribution**—The Mach number in an exhaust system is normally less than 0.3. This means that in mufflers with flow expansions the average Mach number is quite small (less than 0.1). For such cases you can neglect the convective flow effects, and the only important effect of the mean flow is its influence on the impedance of perforated pipes/plates. This model treats the case where there is no mean flow in the muffler.

- **Temperature distribution**—In a running engine, the air temperature inside the muffler is typically in the range 300–400 °C. There is also a temperature gradient through the muffler. However, the acoustic effect of this gradient is small and the average temperature is normally used to calculate the speed of sound. In this case, the experiments were performed at room temperature (20 °C). The model therefore assumes the temperature in the muffler to be constant and uses the default values for air density and speed of sound.

A schematic cross-section of the muffler geometry is depicted in Figure 3-47.

![Figure 3-47: Muffler geometry cross section.](image)

The detailed design and dimensions of the outlet pipe and the four baffles (as seen from the right in Figure 3-47) are given in Figure 3-48 through Figure 3-51.
Figure 3-48: Outlet pipe. A stainless steel sleeve is located above the left perforated section with 288 holes. The other two pipe perforates contain 144 holes each.

Figure 3-49: Baffle number 1, outlet side to the left and inlet side to the right.

Figure 3-50: Baffles number 2 and 3.
Figure 3-51: Baffle number 4.

The model geometry is supplied as a CAD file. To reduce computation time only the upper half of the muffler is included; imposing the homogeneous Neumann sound-hard boundary condition at \( z = 0 \) accounts for the reflection symmetry in the central horizontal plane through the muffler. (A careful inspection of the drawings in Figure 3-49–Figure 3-51 shows that the reflection symmetry is not perfect for the perforates on the outlet side. However, the asymmetry is so minor that it is safe to neglect its effects.)

In the CAD geometry, the perforated regions are outlined by edges drawn on the corresponding boundaries. This is illustrated for baffle number 1 in Figure 3-52 where the perforated regions have been shaded for emphasis.

Figure 3-52: Perforated regions of baffle number 1.
You model the acoustic effects of the perforates by applying the Acoustics Module’s lumped perforated-plate impedance pair boundary condition on these regions. The semiempirical expression for the impedance, $Z_i$, then reads (Refs 1–2):

$$Z_i = \frac{1}{\sigma} (\theta + i \chi) + \theta_f$$

Here $\sigma$ denotes the area porosity, that is, the fraction of a model-geometry perforate region that is covered by holes in the real muffler geometry. Furthermore, $\theta$ is the specific resistance and $\chi$ the specific reactance, given by

$$\theta = \frac{8 \mu k}{\rho c_s} \left(1 + \frac{t_p}{d_h}\right)$$

and

$$\chi = k(t_p + \delta_h)$$

where $\mu$ is the dynamic viscosity, $k$ is the wave number, $\rho$ is the density, $c_s$ the speed of sound, $t_p$ is the plate thickness, $d_h$ is the hole diameter, and $\delta_h$ is the end correction. The default expression for the end correction is $0.25d_h$.

Finally, the term $\theta_f$ allows you to specify additional contributions to the specific impedance, for example the resistance caused by a mean flow in the muffler. Different models have been proposed for such a flow resistance; for a discussion and further references, see Refs 3–4. In this model, you use $\theta_f$ to include the effects of the metallic sleeve above pipe perforate number 1.

The relevant input parameters for the model are listed in Table 3-2. The porosity values were obtained by dividing the total area of the holes in each perforate with the area of the corresponding region in the CAD geometry. The resistance of the metallic sleeve was experimentally measured.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>$t_p$</td>
<td>1.5 mm</td>
<td>Plate thickness</td>
</tr>
<tr>
<td>$d_h$</td>
<td>5 mm</td>
<td>Hole diameter in perforates</td>
</tr>
<tr>
<td>$\sigma_p$</td>
<td>0.22</td>
<td>Porosity, pipe perforates</td>
</tr>
<tr>
<td>$\sigma_{bi}$</td>
<td>0.46</td>
<td>Porosity, baffle perforates on inlet side</td>
</tr>
<tr>
<td>$\sigma_{bo}$</td>
<td>0.30</td>
<td>Porosity, baffle perforates on outlet side</td>
</tr>
<tr>
<td>$\theta_{sleeve}$</td>
<td>1</td>
<td>Specific resistance, metallic sleeve</td>
</tr>
<tr>
<td>$\rho$</td>
<td>1.25 kg/m$^3$</td>
<td>Density of air</td>
</tr>
<tr>
<td>$c_s$</td>
<td>343 m/s</td>
<td>Speed of sound</td>
</tr>
<tr>
<td>$\mu$</td>
<td>$1.8 \cdot 10^{-5}$ Pa·s</td>
<td>Dynamic viscosity</td>
</tr>
</tbody>
</table>
The wave number, \( k \), is given by \( 2\pi f/c_a \) where \( f \) denotes the frequency. You run the simulation for a range of frequencies between 20 Hz and 600 Hz.

**Results and Discussion**

The transmission loss in the muffler is defined as

\[
TL = 10\log_{10}\left(\frac{P_{\text{in}}}{P_{\text{out}}}\right)
\]

where \( P_{\text{in}} \) and \( P_{\text{out}} \) denote the total acoustic power at the inlet and the outlet, respectively. Figure 3-53 displays the Acoustics Module modeling results for the transmission loss as a function of sound frequency together with experimentally measured data.

![Figure 3-53: Transmission loss versus frequency.](image)

As the figure shows, the agreement is excellent except in the range 170–300 Hz. The deviation here is presumably related to some coupled shell vibration that modifies the interior acoustic field.
You can get a better sense of the results by studying the sound pressure level field inside the muffler for selected frequencies. The plots in Figure 3-54 display this field for the frequencies 530 Hz and 555 Hz, respectively; as Figure 3-53 shows, the former frequency corresponds to a local maximum for the transmission loss whereas the latter gives a local minimum. In Figure 3-54 you can see these how these properties are related to the sound pressure level distributions near the muffler inlet and outlet.

Figure 3-54: Sound pressure level distributions at 530 Hz (top) and 555 Hz.

References


**Model Library path:** Acoustics_Module/Industrial_Models/perforated_muffler

---

**Modeling Using the Graphical User Interface**

**MODEL NAVIGATOR**

1. In the Model Navigator, select 3D from the Space dimension list.
2. From the list of application modes select Acoustics Module>Pressure Acoustics>Time-harmonic analysis.
3. Click OK.

**GEOMETRY MODELING**

A horizontal symmetry plane through the muffler means that it is sufficient to model only half of the geometry. This geometry is available as a CAD file that comes with the Acoustics Module. To import the geometry, perform the following steps:

1. From the File menu select Import>CAD Data From File.
3. Select the file perforated_muffler.mphbin, then click Import.

When the import procedure has finished, you should see the upper half of a muffler in the drawing area. At this point, the geometry consists of a number of composite objects; to allow you to impose the appropriate boundary conditions on the baffles and the interior parts of the pipes, you need to turn it into an assembly and create boundary pairs.

4. From the Draw menu, select Use Assembly.
5. Select all objects in the drawing area by pressing Ctrl+A, then click the Create Pairs and Imprints button on the Draw toolbar.
This completes the geometry-modeling stage. After repeated clicks on the Increase Transparency button on the Camera toolbar, the geometry in the drawing area of the user interface on your screen should look like that in the Figure 3-55. (To return to the default visualization settings, click the Decrease Transparency button an equal number of times.

![Figure 3-55: The muffler geometry as an assembly.](image)

### OPTIONS AND SETTINGS

#### Constants

1. From the **Options** menu choose **Constants**.
2. Enter the names, values, and descriptions listed in the table. When finished, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>VALUE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>p0</td>
<td>1[Pa]</td>
<td>Inlet pressure</td>
</tr>
<tr>
<td>t_w</td>
<td>1.5[mm]</td>
<td>Wall thickness</td>
</tr>
<tr>
<td>d_h</td>
<td>5[mm]</td>
<td>Hole diameter</td>
</tr>
<tr>
<td>sigma_p</td>
<td>0.24</td>
<td>Porosity, pipe perforates</td>
</tr>
<tr>
<td>sigma_bi</td>
<td>0.35</td>
<td>Porosity, baffle panels on inlet side</td>
</tr>
<tr>
<td>sigma_bo</td>
<td>0.30</td>
<td>Porosity, baffle panels on outlet side</td>
</tr>
<tr>
<td>freq</td>
<td>20[Hz]</td>
<td>Frequency</td>
</tr>
</tbody>
</table>

The frequency value in this table is the initial frequency in the range of 20–600 Hz for which you later solve the model using the parametric solver.

#### Integration Coupling Variables

To determine the transmission loss in the muffler you first need to calculate the total acoustic power at the inlet and at the outlet. To this end, define two integration coupling variables as follows:
1 Choose **Options>Integration Coupling Variables>Boundary Variables**.

2 On the **Source** page, select Boundary 8 (the inlet).

3 Define the surface integral

\[
P_{in} = 2 \int_{S_i} \frac{P_0^2}{2 \rho c_s}
\]

as an integration coupling variable by typing \( P_{in} \) in the **Name** edit field and \( 2*P_0^2/(2*\rho_{acpr}*c_{acpr}) \) in the **Expression** edit field of the first row of the table. Leave the default settings for the **Integration order** and the **Global destination**.

4 Select Boundary 1 (the outlet).

5 Now define the integral

\[
P_{out} = 2 \int_{S_i} \frac{|p|^2}{2 \rho c_s}
\]

by typing \( P_{out} \) in the **Name** edit field and \( 2*p*\text{conj}(p)/(2*\rho_{acpr}*c_{acpr}) \) in the **Expression** edit field of the second row of the table. As above, leave the **Integration order** and **Global destination** settings at their default values.

**Global Expressions**

Next, make the transmission loss (see Equation 3-8) available at the postprocessing stage as a global expression:

1 Choose **Options>Expressions>Global Expressions**.

2 Define a global expression by the **Name** TL and the **Expression** \( 10*\log_{10}(P_{in}/P_{out}) \).

3 Click **OK**.

**PHYSICS SETTINGS**

**Identity Pairs**

Before applying the boundary conditions, you need to create separate pairs for the perforated regions of the baffles.

1 Choose **Physics>Identity Pairs>Identity Boundary Pairs**.

2 In the **Identity pairs** list select **Pair 8**.

3 In the **Source boundaries** list, clear the check boxes for Boundaries 32 and 33.

4 With the check box for Boundary 31 still selected click the **Select Source** button.
5 In the **Destination boundaries** list, clear the check boxes for Boundaries 51 and 56.

6 With the check box for Boundary 48 still selected, click the **Select Destination** button.

7 Click the **New** button.

   In the **Name** edit field it now reads Pair 26; keep this entry as it is.

8 In the **Source boundaries** list select Boundary 32, then click the **Check Selected** button below the list. (Alternatively, select the check box for Boundary 32 directly.)

9 Click the **Select Source** button.

10 In the **Destination boundaries** list select Boundary 51, then click the **Check Selected** button below the list.

11 Click the **Select Destination** button.

12 Define Pair 27 by repeating Steps 7 through 11, but use Boundary 33 as the source and Boundary 56 as the destination.

13 Repeat this procedure (Steps 2–12) for the remaining baffles and the inner ends of the pipes using the data in the table below; already existing pairs (to be modified in analogy with Pair 8 above) are marked with an asterisk. When done, click **OK**.

<table>
<thead>
<tr>
<th>PAIR</th>
<th>SOURCE BOUNDARIES</th>
<th>BOUNDARIES TO CLEAR</th>
<th>DESTINATION BOUNDARY</th>
<th>BOUNDARIES TO CLEAR</th>
</tr>
</thead>
<tbody>
<tr>
<td>*15</td>
<td>64</td>
<td>65, 66</td>
<td>83</td>
<td>86, 91</td>
</tr>
<tr>
<td>28</td>
<td>65</td>
<td></td>
<td>86</td>
<td></td>
</tr>
<tr>
<td>29</td>
<td>66</td>
<td></td>
<td>91</td>
<td></td>
</tr>
<tr>
<td>*22</td>
<td>99</td>
<td>100, 101</td>
<td>114</td>
<td>117, 121</td>
</tr>
<tr>
<td>30</td>
<td>100</td>
<td></td>
<td>117</td>
<td></td>
</tr>
<tr>
<td>31</td>
<td>101</td>
<td></td>
<td>121</td>
<td></td>
</tr>
<tr>
<td>*25</td>
<td>126</td>
<td>127</td>
<td>128</td>
<td>131</td>
</tr>
<tr>
<td>32</td>
<td>127</td>
<td></td>
<td>131</td>
<td></td>
</tr>
<tr>
<td>*24</td>
<td>111, 112</td>
<td>113</td>
<td>118, 119</td>
<td>125</td>
</tr>
<tr>
<td>33</td>
<td>113</td>
<td></td>
<td>125</td>
<td></td>
</tr>
<tr>
<td>*19</td>
<td>80, 81</td>
<td>82</td>
<td>133, 134</td>
<td>135</td>
</tr>
<tr>
<td>34</td>
<td>82</td>
<td></td>
<td>135</td>
<td></td>
</tr>
</tbody>
</table>

**Boundary Conditions**

1 From the **Physics** menu select **Boundary Settings**.

2 Select Boundary 8 (the inlet). From the **Boundary condition** list select **Radiation condition**. In the **Pressure source** edit field type p0.
3 Select Boundary 1 (the outlet). From the Boundary condition list select Radiation condition. For this boundary, keep the default value (0) in the Pressure source edit field.

4 Click the Pairs tab.

5 Define boundary conditions for the pairs according to the following table (for pairs and parameters not explicitly mentioned, leave the default settings):

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>Pairs 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 14, 15, 17-19, 21, 22, 24, 25</th>
<th>Pairs 6</th>
<th>Pairs 13, 20</th>
<th>Pairs 26, 28, 30, 32</th>
<th>Pairs 27, 29, 31</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Sound hard boundary (wall)</td>
<td>Impedance boundary condition, Perforated plate</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>( \sigma )</td>
<td>( \text{sigma}_p )</td>
<td>( \text{sigma}_p )</td>
<td>( \text{sigma}_b )</td>
<td>( \text{sigma}_b )</td>
<td></td>
</tr>
<tr>
<td>( \theta_f )</td>
<td>( t_w )</td>
<td>( t_w )</td>
<td>( t_w )</td>
<td>( t_w )</td>
<td></td>
</tr>
<tr>
<td>( \tau_p )</td>
<td>( d_h )</td>
<td>( d_h )</td>
<td>( d_h )</td>
<td>( d_h )</td>
<td></td>
</tr>
</tbody>
</table>

The setting \( \theta_f = 1 \) for Pair 6 represents the impedance contribution \( \rho_{c_a} \) from the metallic sleeve outside the perforated pipe section closest to the outlet.

6 Click OK.

**APPLICATION SCALAR VARIABLES**

1 From the Physics menu select Scalar Variables.
2. In the **Expression** edit field for `freq_acpr` type `freq`.
3. Click **OK**.

**GENERATING THE MESH**

Because boundary conditions are defined on the destination boundary in a pair, you obtain the best numerical result if the mesh on the destination boundary is finer than that on the source boundary. With the following steps you specify a finer mesh on the destination boundaries for pairs with an impedance boundary condition. For the pairs using the sound-hard boundary condition there is no connection between the parts. Therefore, there is no reason to use different mesh sizes on the two parts of those pairs.

1. From the **Mesh** menu select **Free Mesh Parameters**.
2. Go to the **Boundary** page and select Boundaries 35, 37, 51, 56, 68, 70, 86, 91, 103, 105, 117, 121, and 131. Set the **Maximum element size** to 0.012.
3. Click **OK**.
4. Click the **Initialize Mesh** button on the Main toolbar.

For this model, the limiting factor when determining the mesh size is resolving the geometry details—not the smallest wave length, which is roughly 57 cm.

**COMPUTING THE SOLUTION**

1. Click the **Solver Parameters** button on the Main toolbar.
2. In the **Solver** list select **Parametric**.
3. In the **Parameter** area on the **General** page, type `freq` in the **Parameter name** edit field and type `20:5:600` in the **Parameter values** edit field.

   This setting gives a frequency sweep from 20 Hz to 600 Hz in steps of 5 Hz. This suffices to resolve the main features in the muffler’s frequency response. However, it leads to a solution time on the order of 100 minutes. If you want to reduce the solution time you can either reduce the range or increase the step size.

4. Click **OK**.
5. Click the **Solve** button on the Main toolbar.

**POSTPROCESSING AND VISUALIZATION**

The default plot is a slice plot of the acoustic pressure field for the final frequency in the sweep. For many purposes, visualizing the sound pressure level field is more informative.

1. Click the **Plot Parameters** button on the Main toolbar.
2 Click the **Slice** tab. From the **Predefined quantities** list, select **Sound pressure level**.

3 In the **Slice positioning** area, type 0 in the **Number of levels** edit fields for **x levels** and **y levels**. For **z levels**, click the option button next to the **Vector with coordinates** edit field and enter the level $10^{-4}$.

4 Click **Apply** to generate a plot of the sound pressure level distribution near the muffler’s symmetry plane.

To include information about the sound pressure level away from this symmetry plane, add some isolevel curves:

5 On the **Isosurface** page, select the **Isosurface plot** check box.

6 On the **Isosurface Data** page, select **Sound pressure level** from the **Predefined quantities** list.

7 In the **Isosurface levels** area, type 25 in the **Number of levels** edit field.

8 In the **Isosurface color** area, clear the **Color scale** check box.

9 Click **Apply**.

After clicking the **Headlight** button on the Camera toolbar, the plot in the drawing area should resemble that in the figure below.
To generate the plot of transmission loss vs. frequency displayed by the solid blue line in Figure 3-53, follow these instructions:

1. From the **Postprocessing** menu select **Cross-Section Plot Parameters**.
2. Click the **Point** tab, then in the **Expression** edit field type **TL**.
   
   Because you are plotting a global expression, the choice of point is irrelevant. Therefore, leave the default plot-point coordinates.
3. Click **OK** to generate the graph displayed in the following figure.

![Plot of transmission loss vs. frequency](image)

The plots in Figure 3-54, comparing the sound pressure level fields for the local transmission-loss maximum near 530 Hz and the corresponding local minimum near 555 Hz, are obtained as follows:

1. Click the **General** tab in the **Plot Parameters** dialog box.
2. In the **Plot type** area, clear the **Isosurface** check box.
3. In the **Solution to use** area, select **530** from the **Parameter value** list.
4. Click **Apply** to generate the upper plot in Figure 3-54 in the drawing area.

The contrast in color near the inlet and outlet reflects the high transmission-loss value. Compare this plot to the corresponding one at the frequency 555 Hz:
In the Solution to use area, select 555 from the Parameter value list.

To keep the previous plot for comparison, select New figure from the Plot in list.

Click Apply to generate the lower plot in Figure 3-54.

In this case, the color contrast between inlet and outlet is significantly less marked. Indeed, as the transmission loss vs. frequency curve shows, the transmission loss at 555 Hz is below 10 dB compared to roughly 48 dB at 530 Hz.

The plot displayed in the drawing area when you open the model is generated with the following commands:

1. On the General page of the Plot Parameters dialog box, select 600 from the Parameter value list.
2. In the Plot type area, select the Streamline check box, then click the Streamline tab.
3. From the Predefined quantities list inside the Streamline data area, select Intensity.
4. From the Streamline plot type list, select Magnitude controlled.
5. On the Density page, set the Min distance to 0.03 and the Max distance to 0.04.
6. On the Line Color page, select the Uniform color option button, then click the Color button.
7. From the palette, select a yellow color, then click OK.
8. From the Line type list select Tube, then click the Tube Radius button.
9. Clear the Auto check box for the Radius scale factor, then type 0.3 in the associated edit field. Click OK to close the Tube Radius Parameters dialog box.
10. From the Tube resolution list, select Low.
11. Click OK to generate the plot and close the Plot Parameters dialog box.

Postprocessing with COMSOL Script/MATLAB

The experimental data visualized with red rings in Figure 3-53 is included with the Acoustics Module. If you have a license for COMSOL Script or MATLAB, you can add these data to the transmission-loss plot, thereby completing the reproduction of Figure 3-53, as follows.

1. First, if you are running COMSOL via a server, choose File>Client/Server/MATLAB>Disconnect from Server/MATLAB. Click Yes to confirm the closure of the server connection. This step allows you to open COMSOL Script on your local desktop.
2 Choose File>COMSOL Script (or File>Client/Server/MATLAB>Connect to MATLAB).

Next, import the data:

3 In the COMSOL Script window that opens, use the commands `pwd` and `cd` to navigate to the root directory of your COMSOL installation and from there to the directory `models/Acoustics_Module/Industrial_Models`.

4 At the command-line prompt, type `perforated_muffler_exp_data` to load the data.

5 Type `who` to inspect the variables in your COMSOL Script workspace.

The list displayed should include the variable `TLexp`. This is a 296-by-2 matrix whose first and second columns contain a set of frequencies in the range 20–600 Hz and the corresponding transmission-loss measurements, respectively.

6 Finally, plot the data in the open figure window by executing the following commands:

```matlab
hold on
plot(TLexp(:,1),TLexp(:,2),'linestyle','none','marker','o','color','r')
```
SAW Gas Sensor

Introduction

A surface acoustic wave (SAW) is an acoustic wave propagating along the surface of a solid material. Its amplitude decays rapidly, often exponentially, with the depth of the material. SAWs are featured in many kinds of electronic components, including filters, oscillators, and sensors. SAW devices typically use electrodes on a piezoelectric material to convert an electric signal to a SAW, and back again.

In this model, you investigate the resonance frequencies of a SAW gas sensor. The sensor consists of an interdigitated transducer (IDT) etched onto a piezoelectric LiNbO$_3$ (lithium niobate) substrate and covered with a thin polyisobutylene (PIB) film. The mass of the PIB film increases as PIB selectively adsorbs CH$_2$Cl$_2$ (dichloromethane, DCM) in air. This causes a shift in resonance to a slightly lower frequency.

Model Definition

Figure 3-56 shows a conceptual view of the gas sensor in this model. IDTs used in SAW devices may have hundreds of identical electrodes, and each electrode can be about 100 times longer than it is wide. You can therefore neglect the edge effects and reduce the model geometry to the periodic unit cell shown in Figure 3-57. The height of this cell does not have to extend all the way to the bottom of the substrate but only a few wavelengths down, so that the SAW has almost died out at the lower boundary. In the model, this boundary is fixed to a zero displacement.
Figure 3-56: Conceptual view of the SAW gas sensor, showing the IDT electrodes (in black), the thin PIB film (light gray), and the LiNbO$_3$ substrate (dark gray). For the sake of clarity, the dimensions are not to scale and the IDT has fewer electrodes than in common devices. A slice of the geometry is removed to reveal the modeled unit cell (in white).
You set up the model in the Piezo Plane Strain application mode, which requires the out-of-plane strain component to be zero. This should be a valid assumption, considering that the SAW is generated in the model plane and that the sensor is thick in the out-of-plane direction.

The first version of the model deals only with free SAW propagation in the LiNbO$_3$ substrate, without any applied electric field. In order to find the velocity of the wave, we use periodic boundary conditions to dictate that the voltage and the displacements be the same along both vertical boundaries of the geometry. This implies that the wavelength will be an integer fraction of the width of the geometry. The lowest SAW eigenmode has its wavelength equal to the width of the geometry, 4 $\mu$m. The eigenfrequency of this mode multiplied by 4 $\mu$m hence gives the velocity of the wave.

In a second version of the model, the aluminum IDT electrodes and the PIB film are added. This causes the lowest SAW mode to split up in two eigensolutions, the lowest one representing a series resonance, where propagating waves interfere constructively.
and the other one a parallel (“anti-”) resonance, where they interfere destructively. These two frequencies constitute the edges of the stopband, within which no waves can propagate through the IDT.

The adsorption of DCM gas is represented as a slight increase of the density of the PIB film. In the third and final version of the model, the sensor is exposed to 100 ppm of DCM in air at atmospheric pressure and room temperature. The “partial density” of DCM in the PIB film is then calculated as

$$\rho_{\text{DCM}, \text{PIB}} = K M e,$$

where $K = 10^{1.4821}$ (Ref. 1) is the air/PIB partition coefficient for DCM, $M$ is its molar mass, and

$$e = 100 \cdot 10^{-6} \cdot p/(RT)$$

is its concentration in air.

The substrate used in the simulation is YZ-cut LiNbO$_3$ with properties cited in Ref. 2. The density of the PIB film is from Ref. 1. The Poisson’s ratio is taken to be 0.48, which corresponds to a rather rubbery material. The Young’s modulus is set to 10 GPa. Even at the comparatively high frequencies considered in this model, this is likely an overestimation. However, a much lower value would result in a multitude of eigenmodes located inside the film. While those may be important to consider in designing a SAW sensor, the focus in this model is on the SAW modes. Also, any effects of the DCM adsorption on other material properties than the density are neglected.
Results

Figure 3-58 shows the SAW as it propagates along the surface of the piezoelectric substrate. The frequency corresponding to a 4 µm wavelength computes to 870 MHz, giving a phase velocity of 3479 m/s.

In the full model with the periodic IDT and the thin film included, the resonance and anti-resonance frequencies evaluate to 841 MHz and 850 MHz, respectively. Figure 3-59 and Figure 3-60 show the electric potential distribution characteristics for these solutions.
Figure 3-59: Electric potential distribution and deformations at resonance, 841 MHz. The potential is symmetric with respect to the center of each electrode.

Exposing the sensor to a 100 ppm concentration of DCM in air leads to a resonance frequency shift of 227 Hz downwards. This is computed by evaluating the resonance frequency before and after increasing the density of adsorbed DCM to that of the PIB domain.

Note that the computational mesh is identical in both these solutions. This implies that the relative error of the frequency shift is similar to that of the resonance frequency itself. Thus the shift is accurately evaluated despite being a few magnitudes smaller than the absolute error of the resonance frequency.

In a real setup, the drift is often measured by mixing the signal from a sensor exposed to a gas with a reference signal from one protected from the gas. The beat frequency then gives the shift.
CHAPTER 3: INDUSTRIAL MODELS

Figure 3-60: Electric potential distribution and deformations at antiresonance, 851 MHz. The potential is antisymmetric with respect to the center of the electrodes.

References


Model Library path: Acoustics_Module/Industrial_Models/SAW_gas_sensor

Modeling Using the Graphical User Interface

MODEL NAVIGATOR
1. Open the Model Navigator and click the New tab.
2 From the **Space dimension** list, select 2D.

3 In the list of application modes, select *Acoustics Module>Piezo Plane Strain>Eigenfrequency analysis*.

4 Click **OK**.

**GEOMETRY MODELING**

1 Create the following rectangles by repeatedly using **Draw>Specify Objects>Rectangle**. Click **OK** after specifying the data for each rectangle.

<table>
<thead>
<tr>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>BASES: CORNER X</th>
<th>BASE: CORNER Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>4</td>
<td>22</td>
<td>0</td>
<td>-22</td>
</tr>
<tr>
<td>1</td>
<td>0.2</td>
<td>0.5</td>
<td>0</td>
</tr>
<tr>
<td>1</td>
<td>0.2</td>
<td>2.5</td>
<td>0</td>
</tr>
<tr>
<td>4</td>
<td>0.5</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

2 Select all objects and choose **Draw>Modify>Scale**. In the dialog box that appears, enter $1 \times 10^{-6}$ for both scale factors; then click **OK**.

3 Click the **Zoom Extents** button on the Main toolbar to zoom in on the now micron-sized geometry.

**OPTIONS AND SETTINGS**

1 Choose **Options>Constants**.

2 Define the following constant names, expressions, and (optionally) descriptions:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>p</td>
<td>101.325[kPa]</td>
<td>Air pressure</td>
</tr>
<tr>
<td>T</td>
<td>25[degC]</td>
<td>Air temperature</td>
</tr>
<tr>
<td>R</td>
<td>$8.3145(Pa<em>m^3/(K</em>mol))$</td>
<td>Gas constant</td>
</tr>
<tr>
<td>c_DCM_air</td>
<td>$1000<em>6</em>(R*T)$</td>
<td>DCM concentration in air</td>
</tr>
<tr>
<td>M_DCM</td>
<td>84.93[g/mol]</td>
<td>Molar mass of DCM</td>
</tr>
<tr>
<td>K</td>
<td>$10^1.4821$</td>
<td>PIB/air partition constant for DCM</td>
</tr>
<tr>
<td>rho_DCM_PIB</td>
<td>$K<em>M_DCM</em>c_DCM_air$</td>
<td>Mass concentration of DCM in PIB</td>
</tr>
<tr>
<td>rho_PIB</td>
<td>$0.918[g/cm^3]$</td>
<td>Density of PIB</td>
</tr>
<tr>
<td>E_PIB</td>
<td>10[GPa]</td>
<td>Young’s modulus of PIB</td>
</tr>
<tr>
<td>nu_PIB</td>
<td>0.48</td>
<td>Poisson’s ratio of PIB</td>
</tr>
<tr>
<td>eps_PIB</td>
<td>2.2</td>
<td>Relative permittivity of PIB</td>
</tr>
</tbody>
</table>
3 Click **OK**.

**PHYSICS SETTINGS**

In the first version of the model, you compute the velocity for SAW propagation in a homogenous, electrically insulated LiNbO$_3$ substrate. The supplied material data are with reference to the $xy$-plane.

**Subdomain Settings**

1. From the **Physics** menu, open the **Subdomain Settings** dialog box.
2. Select Subdomains 2–4, then clear the **Active in this domain** check box.
3. Select Subdomain 1, then select $xy$ plane from the **Material orientation** list.
4. Click the **Edit** button associated with $c_E$. Enter the following values in the **Elasticity matrix** dialog box; when finished, click **OK**.

\[
\begin{bmatrix}
2.424 \times 10^0 & 0.752 \times 10^1 & 0.752 \times 10^1 & 0 & 0 & 0 \\
2.03 \times 10^1 & 0.573 \times 10^1 & 0 & 0.085 \times 10^1 & 0 & 0 \\
2.03 \times 10^1 & 0 & -0.085 \times 10^1 & 0 & 0 & 0 \\
0.752 \times 10^1 & 0 & 0.085 \times 10^1 & 0 & 0.595 \times 10^1 & 0 \\
0.595 \times 10^1 & 0 & 0.595 \times 10^1 & 0 & 0 & 0
\end{bmatrix}
\]

5. Click the **Edit** button associated with $e$. Enter the following values in the **Coupling matrix** dialog box; when finished, click **OK**.

\[
\begin{bmatrix}
1.33 & 0.23 & 0.23 & 0 & 0 & 0 \\
0 & 0 & 0 & -2.5 & 0 & 3.7 \\
0 & -2.5 & 2.5 & 0 & 3.7 & 0
\end{bmatrix}
\]

6. Click the **Edit** button associated with $\varepsilon_{rs}$. Enter the following values in the **Relative permittivity** dialog box; when finished, click **OK**.

\[
\begin{bmatrix}
28.7 & 0 & 0 \\
85.2 & 0 \\
85.2 & 0
\end{bmatrix}
\]

7. In the **Density** edit field, type 4647.

8. Click **OK** to close the **Subdomain Settings** dialog box.

**Boundary Conditions**

1. From the **Physics** menu, choose **Boundary Settings**.
2. Select Boundary 2, then set the **Constraint condition** to **Fixed**.
3. Select all exterior boundaries (Boundaries 1, 2, 4, 7, 10, 12, 15, and 16).
4 On the Electric BC page, set the Boundary condition to Zero charge/Symmetry.
5 Click OK.
6 Choose Physics>Periodic Conditions>Periodic Boundary Conditions.
7 On the Source page, select Boundary 1. On the first row in the Expression column, type \( u \), then press Enter; the software automatically adds the corresponding Constraint name \( \text{pconst}r1 \) to the table.
8 On the Destination page, check Boundary 16 and type \( u \) in the Expression edit field.
9 On the Source Vertices page, Ctrl-click to select Vertices 1 and 2, then click the >> button.
10 On the Destination Vertices page, Ctrl-click to select Vertices 12 and 13, then click the >> button.
11 Repeat Steps 7 through 10 to define the expressions \( v \) and \( V \) in an analogous fashion, starting by entering them in the Expression edit field on the Source page, on the 2nd and 3rd row, respectively.
12 When done, click OK to close the Periodic Boundary Conditions dialog box.

MESH GENERATION

1 Choose Mesh>Free Mesh Parameters.
2 From the Predefined mesh sizes list, choose Extremely fine.
3 On the Subdomain page, select all subdomains and set the Method to Quad.
4 On the Boundary page, select the upper boundaries of the substrate (Boundaries 4, 7, 10, 12, and 15) and set the Maximum element size to \( 0.05e^{-6} \).
5 Click Remesh, then click OK. When done, a zoom-in on the upper part of the geometry should look like Figure 3-61.
CHAPTER 3: INDUSTRIAL MODELS

FIGURE 3-61: The meshed geometry.

Computing the Solution
1. From the Solve menu, open the Solver Parameters dialog box.
2. Enter 850e6 in the Search for eigenfrequencies around edit field, then click OK.
3. Click the Solve button on the Main toolbar.

Postprocessing and Visualization
The solver returns 6 eigensolutions with eigenfrequencies in the vicinity of 850 MHz. At 869.8 MHz, two of them are—within the numerical accuracy—the same. These show the shape and the frequency for a SAW with wavelength equal to the width of the geometry.

1. From the Postprocessing menu, open the Plot Parameters dialog box.
2. On the General page, select one of the eigenfrequencies equal to 869.8 MHz.
3. On the Deform page, select the Deformed shape plot check box. Clear the Auto check box and type 400 in the Scale factor edit field.
4 Click OK to close the dialog box and see a plot of the total displacement. If you want to, you can repeat the procedure with the other solution to verify that they are the same, only shifted by 90 degrees. One of the solutions look like that in Figure 3.58.

5 To evaluate the velocity, choose Postprocessing>Data Display>Global.

6 In the Expression edit field, type eigfreq_smppn*4[um].

7 In the Eigenfrequency list, select one of the 869.8 MHz entries.

8 Click OK to see the value of the velocity in the message log. It evaluates to approximately 3479 m/s.

This concludes the first part of the model. Proceed to find out how the electrodes and the PIB film affect the behavior of the SAW.

Sensor without Gas Exposure

Subdomain Settings
1 From the Physics menu, open the Subdomain Settings dialog box.
2 Select Subdomains 2–4, then select the Active in this domain check box.
3 From the Material model list, select Decoupled, isotropic.
4 Select only Subdomain 2.
5 On the Structural page, enter E_PIB for the Young’s modulus, nu_PIB for the Poisson’s ratio, and rho_PIB for the Density.
6 On the Electrical page, select the Enable electrical equation check box and enter eps_PIB in the Relative permittivity edit field.
7 Select Subdomains 3 and 4, then click the Load button.
8 In the Materials/Coefficients Library dialog box, select Basic Material Properties>Aluminum and click OK.
9 Click OK to close the Subdomain Settings dialog box.

Boundary Conditions
1 From the Physics menu, choose Boundary Settings.
2 Select the Interior boundaries check box.
3 Select Boundaries 6–9 and 11–14. On the Electric BC page, set the condition to Electric potential. Keep the default zero potential.
4 Select Boundaries 3, 5, and 17, and set the condition to Zero charge/Symmetry.
5 Click OK to close the dialog box.
Note: The eigenfrequencies and hence the stopband do not depend on the values of the potentials. In fact, for linear eigenfrequency problems, they are automatically set to zero at the electrodes, regardless of the applied value. You can solve the corresponding driven problem by switching to a frequency response analysis and applying different potentials to the electrodes.

6 Choose Physics>Periodic Conditions>Periodic Boundary Conditions.
7 On the Source page, select Boundary 3. Enter $u$ in the first Expression edit field and $v$ in the row below, and $V$ in the third row.
8 Click the Destination tab.
9 From the Constraint name list, select pconstr1; check Boundary 17 (in addition to the already selected Boundary 16); and type $u$ in the Expression edit field.
10 From the Constraint name list, select pconstr2; check Boundary 17; and type $v$ in the Expression edit field.
11 From the Constraint name list, select pconstr3; check Boundary 17; and type $V$ in the Expression edit field.
12 Click OK to close the dialog box.

You have now established the periodicity in the PIB film.

Computing the Solution
Click the Solve button on the Main toolbar.

Postprocessing and Visualization
If you are still using the manual scaling of the deformations from the previous exercise, the plot that appears after solving will look rather distorted. Proceed as follows to find the SAW modes and use more suitable plot parameters:

1 From the Postprocessing menu, open the Plot Parameters dialog box.
2 On the General page, select the 850 MHz eigenfrequency.
3 On the Deform page, type 40 in the Scale factor edit field.
4 Click Apply to view a plot of the total displacement at anti-resonance.
5 On the General page, select the 841 MHz eigenfrequency, then click Apply to see the deformations at resonance. This plot should look like Figure 3-62.
A plot of the electric potential shows a qualitative difference between the two solutions.

6 On the Surface page, select Piezo Plane Strain (smppn)>Electric potential from the Predefined quantities list.

7 Click Apply to see the potential distribution at resonance, as shown in Figure 3-59 on page 215. Notice that it is symmetric with respect to each individual electrode.

8 On the General page, select the 850 MHz eigenfrequency and click OK to see the potential distribution at anti-resonance, as in Figure 3-60 on page 216. This time, it is antisymmetric.

**Sensor with Gas Exposure**

In the final version of this model, you expose the sensor to DCM gas. The eigenfrequencies then shift by a very small amount. To see the shift, you need to include more digits in the output.

1 Choose Postprocessing>Data Display>Global.
2 Enter the expression `eigfreq_smppn` and select the 841 MHz eigenfrequency.
3 Select the **Display result in full precision** check box, then click **OK**.

The message log now shows all computed digits of the eigenfrequency.

**Subdomain Settings**
1 From the **Physics** menu, select **Subdomain Settings**.
2 Select Subdomain 2. On the **Structural** page, change the **Density** so that it reads `rho_PIB+rho_DOM_PIB`.
3 Click **OK** to close the **Subdomain Settings** dialog box.

**COMPUTING THE SOLUTION**
Click the **Solve** button.

**POSTPROCESSING AND VISUALIZATION**
1 Choose **Postprocessing>Data Display>Global**.
2 Make sure that the expression still says `eigfreq_smppn` and select the 841 MHz eigenfrequency.
3 Click **OK**.

The first 6 digits of the eigenfrequency are the same as before. Subtracting the new value from the previous value (which is most easily done by copying and pasting the results from the message log) shows that the eigenfrequency with gas exposure is lower by 227 Hz.
Benchmark Models

This chapter covers benchmarks models solving acoustics problems with an established or analytic solution. The benchmark data provide the possibility to validate results obtained with the Acoustics Module.
Vibrations of a Disk Backed by an Air-Filled Cylinder

Introduction

The vibration modes of a thin or thick circular disk are well known, and it is possible to compute the corresponding eigenfrequencies to arbitrary precision from a series solution. The same is true for the acoustic modes of an air-filled cylinder with perfectly rigid walls. A more interesting question to ask is: What happens if the cylinder is sealed in one end not by a rigid wall but by a thin disk? This is the question you address in this model.

Note: This model requires the Acoustics Module and the Structural Mechanics Module.

Model Definition

In COMSOL Multiphysics you can model an air-filled cylinder sealed by a thin disk in one end using at least two different approaches. You describe the pressure in the cavity with a Pressure Acoustics application mode, while the model of the disk can be either a thin shell in 3D, using shell elements, or a 2D plate. The latter approach to modeling this acoustic-structure interaction is possible thanks to nonlocal couplings and COMSOL Multiphysics’ ability to model in different numbers of space dimensions at the same time—extended multiphysics.

In Ref. 1, D. G. Gorman and others have thoroughly investigated the model at hand, and they have developed a semi-analytical solution verified by experiments and simulations. The geometry is a rigid steel cylinder with a height of 255 mm and a radius of 38 mm. One end is welded to a heavy slab, while the other is sealed with a steel disk only 0.38 mm thick. Some of the theoretical eigenfrequencies of a thin disk
in vacuum and of a rigidly sealed chamber are given in the following table (according to Ref. 1).

**TABLE 4-1: BENCHMARK VALUES FOR EIGENFREQUENCIES OF THE DISK AND THE CYLINDER**

<table>
<thead>
<tr>
<th>NUMBER</th>
<th>CLAMPED DISK IN VACUUM (HZ)</th>
<th>RIGIDLY SEALED CYLINDER (HZ)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>671.8</td>
<td>672.5</td>
</tr>
<tr>
<td>2</td>
<td>1398</td>
<td>1345</td>
</tr>
<tr>
<td>3</td>
<td>2293</td>
<td>2018</td>
</tr>
<tr>
<td>4</td>
<td>2615</td>
<td>2645</td>
</tr>
<tr>
<td>5</td>
<td>3356</td>
<td>2690</td>
</tr>
<tr>
<td>6</td>
<td>4000</td>
<td>4387</td>
</tr>
</tbody>
</table>

Here you model the coupled system using the extended multiphysics approach. This means that you draw the disk in a 2D geometry and model it with Mindlin-theory DRM-plate elements, while you draw the cylinder in a separate 3D geometry. The acoustics in the cylinder is described in terms of the acoustic (differential) pressure. The eigenvalue equation for the pressure is

\[-\Delta p = \frac{\omega^2}{c^2} p\]

where \(c\) is the speed of sound and \(\omega = 2\pi f\) defines the eigenfrequency, \(f\).

A first step is to calculate the eigenfrequencies for the disk and the cylinder separately and compare them with the theoretical values in Table 4-1. This way you can verify the basic components of the model and assess the accuracy of the FEM solution before modeling the coupled system.

**Results and Discussion**

Most of the modes show rather weak coupling between the structural bending of the disk and the pressure field in the cylinder. It is, however, interesting to note that some of the uncoupled modes have been split into one co-vibrating and one contra-vibrating mode with distinct eigenfrequencies. This is the case for modes 1 and 2 and for modes 9 and 12 in the FEM solution. The table below shows a comparison of the eigenfrequencies from the COMSOL Multiphysics analysis with the semi-analytical and experimental frequencies reported by D. G. Gorman and others in Ref. 1. The
table also states whether the modes are structurally dominated (str), acoustically dominated (ac), or tightly coupled (str/ac).

<table>
<thead>
<tr>
<th>TYPE</th>
<th>SEMI-ANALYTICAL (HZ)</th>
<th>COMSOL MULTIPHYSICS (HZ)</th>
<th>EXPERIMENTAL (HZ)</th>
</tr>
</thead>
<tbody>
<tr>
<td>str/ac</td>
<td>636.9</td>
<td>637.2</td>
<td>630</td>
</tr>
<tr>
<td>str/ac</td>
<td>707.7</td>
<td>707.7</td>
<td>685</td>
</tr>
<tr>
<td>ac</td>
<td>1347</td>
<td>1347.4</td>
<td>1348</td>
</tr>
<tr>
<td>str</td>
<td>1394</td>
<td>1395.3</td>
<td>1376</td>
</tr>
<tr>
<td>ac</td>
<td>2018</td>
<td>2018.6</td>
<td>2040</td>
</tr>
<tr>
<td>str</td>
<td>2289</td>
<td>2293.1</td>
<td>2170</td>
</tr>
<tr>
<td>str/ac</td>
<td>2607</td>
<td>2612.1</td>
<td>2596</td>
</tr>
<tr>
<td>ac</td>
<td>2645</td>
<td>2646.3</td>
<td>–</td>
</tr>
<tr>
<td>str/ac</td>
<td>2697</td>
<td>2697.1</td>
<td>2689</td>
</tr>
<tr>
<td>ac</td>
<td>2730</td>
<td>2730.9</td>
<td>2756</td>
</tr>
<tr>
<td>ac</td>
<td>2968</td>
<td>2969.3</td>
<td>2971</td>
</tr>
</tbody>
</table>

As the table shows, the FEM solution is in good agreement with both the theoretical predictions and the experimentally measured values for the eigenfrequencies. As you might expect from the evaluation of the accuracies for the uncoupled problems, the precision is generally better for the acoustics-dominated modes.

**Reference**


**Model Library path:** Acoustics_Module/Benchmark_Models/coupled_vibration

**Modeling Using the Graphical User Interface**

**MODEL NAVIGATOR**

1. Select 2D from the *Space dimension* list.
2. In the list of application modes, select

   **Structural Mechanics Module>**Mindlin Plate>**Eigenfrequency analysis.**

3. Click **OK**.

**GEOMETRY MODELING**

The geometry of the disk is a solid circle. Its location does not really matter because you embed it in 3D using coupling variables, but the transformations are trivial if you center the disk at the origin:

1. Press the Shift key and click the **Ellipse/Circle (Centered)** button.

2. In the **Circle** dialog box, type **0.038** in the **Radius** edit field and click **OK** to create a circle of radius 0.038 m, centered at the origin.

3. Click the **Zoom Extents** button on the Main toolbar.

**PHYSICS SETTINGS**

**Boundary Conditions**

The edges of the disk are welded to the cylinder and can therefore be described as rigidly **clamped** or fixed.

1. From the **Physics** menu, choose **Boundary Settings**.

2. Select one of the boundaries and then press Ctrl+A to select all boundaries.

3. Make sure that you have selected **Tangent and normal coord. sys. (t,n)** in the **Coordinate system** list.

4. Select **Fixed** in the **Condition** list.

5. Click **OK**.

**Subdomain Settings—Material Properties**

The steel disk has the following material properties (in the default SI units):

- Young’s modulus, \( E = 2.1\times10^{11} \)
- Poisson’s ratio, \( \nu = 0.3 \)
- Density, \( \rho = 7800 \)

1. From the **Physics** menu, choose **Subdomain Settings**.

2. Select Subdomain 1.
3 Enter material data according to the following table:

<table>
<thead>
<tr>
<th>MATERIAL PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>E</td>
<td>2.1e11</td>
</tr>
<tr>
<td>ν</td>
<td>0.3</td>
</tr>
<tr>
<td>ρ</td>
<td>7800</td>
</tr>
<tr>
<td>thickness</td>
<td>0.00038</td>
</tr>
</tbody>
</table>

4 Click OK.

**MESH GENERATION**

To obtain accurate values of the eigenfrequencies of the disk, you need a mesh that is finer than the one produced with the default settings.

1 Open the Free Mesh Parameters dialog box from the Mesh menu.
2 Click the Custom mesh size option button and type 0.002 in the Maximum element size edit field.
3 Click the Remesh button and then click OK.

**COMPUTING THE SOLUTION**

When solving for the eigenfrequencies of the disk in vacuum, only the frequency interval between 500 Hz and 3250 Hz is of interest. Start by searching for the 20 first eigenfrequencies (some of these are almost identical and come from double eigenvalues) and make the solver start its search around 500 Hz:

1 From the Solve menu, choose Solver Parameters.
2 Type 20 in the Desired number of eigenfrequencies edit field.
3 Type 500 in the Search for eigenfrequencies around edit field.
4 Click OK.
5 Click the Solve button on the Main toolbar.

**POSTPROCESSING AND VISUALIZATION**

1 Click the 3D Surface Plot button to see the deflection of the disk.
   Next, try looking at some of the eigenmodes.
2 From the Postprocessing menu, choose Plot Parameters.
3 On the General page, choose an eigenfrequency from the Eigenfrequency list in the Solution to use area; click Apply to generate the corresponding plot.
4. When done, click **Cancel** or **OK** to close the **Plot Parameters** dialog box.

The eigenmode associated with the eigenfrequency around 3360 Hz.

You can now compare the eigenfrequencies with the theoretical values for a thin disk. The discrepancy is below 2% for all eigenmodes in the interval, so the conclusion is that the mesh resolution is sufficient.

**Adding the 3D Pressure Acoustics Application Mode**

Now add a second geometry that will contain the cylinder and the acoustic pressure variable using a 3D Pressure Acoustics application mode.

1. From the **Multiphysics** menu, choose **Model Navigator**.
2. Click the **Add Geometry** button to add a second geometry.
3. In the **Add Geometry** dialog box, select **3D** from the **Space dimension** list.
4. Click **OK**.
5. In the list of application modes, select
   - Acoustics Module>Pressure Acoustics>Eigenfrequency analysis.
6. Click **Add**.
7 Click **OK**.

**GEOMETRY MODELING**
1 Click the Cylinder toolbar button.
2 Type 0.038 in the Radius edit field and 0.255 in the Height edit field.
3 Click **OK**.
4 Click the Zoom Extents button on the Main toolbar.

**PHYSICS SETTINGS**

*Boundary Conditions*
For the moment, assume that all boundaries are perfect hard walls, which is the default boundary condition.

*Subdomain Settings*
1 From the Physics menu, choose Subdomain Settings.
2 Select Subdomain 1.
3 Type 1.2 in the Fluid density \((\rho_0)\) edit field. Leave the other properties at their default value.
4 Click **OK**.

**MESH GENERATION**
Click the Initialize Mesh button to create a mesh using the default parameters.

**COMPUTING THE SOLUTION**
To solve for the acoustic modes only, you must deactivate the Mindlin Plate application mode during the solution. If the plate is not deactivated, COMSOL Multiphysics solves the two eigenvalue problems simultaneously but independently of one another.

1 From the Solve menu, choose Solver Manager.
2 Click the Solve For tab.
3 Ctrl-click on the Mindlin Plate (smdrm) folder to clear that application mode’s variables from the list of variables to solve for, then click **OK**.
4 Click the Solve button on the Main toolbar.

**POSTPROCESSING AND VISUALIZATION**
1 Click the Plot Parameters button on the Main toolbar.
2 On the General page, clear the Slice check box and select the Isosurface check box.
3 In the **Solution to use** area, select one of the solutions near 2730 Hz from the **Eigenfrequency** list.

4 Click the **Isosurface** tab. In the edit field for isosurface levels under **Number of levels**, type 10. From the **Colormap** list select **hot**, then click **Apply**.

5 Click the **Headlight** button on the Camera toolbar.

6 Return to the **General** page and try a few different eigenmodes by selecting the corresponding eigenfrequencies, clicking **Apply** to generate each plot.

![Pressure isosurfaces for one of two eigenmodes associated with an eigenfrequency near 2969 Hz.](image)

You can also compare these eigenfrequencies with the theoretical values in Table 4-2 on page 228. This time, the relative error seems to be much smaller than for the disk, which means that any additional mesh refinement should be done on the plate part.

**Coupling the Equations**

The first step in the process of coupling the Mindlin plate elements to the acoustic equation is to create the nonlocal couplings; use coupling variables to make the pressure available as a load on the plate and the out-of-plane displacement of the plate a valid parameter in the coefficients for the acoustic equation.
OPTIONS AND SETTINGS—COUPLING VARIABLES

First define a coupling variable for the acoustic pressure from the top face of the cylinder to the disk (Mindlin plate):

1. On the Options menu, point to Extrusion Coupling Variables and then click Boundary Variables.
2. In the Boundary Extrusion Variables dialog box, select Boundary 4 (the top face) of the cylinder.
3. Type \( p \) in the top row under both Name and Expression.
4. Click the Destination tab.
5. Select Geom1 in the Geometry list, then select Subdomain 1 (the disk) in the 2D geometry.
6. Click the Source Vertices tab.
7. In the Vertex selection list, select Vertices 2, 4, and 8. Click the >> button.
8. Click the Destination Vertices tab.
9. In the Vertex selection list, select Vertices 1, 2, and 4. Click the >> button.
10. Click OK.

Now define a coupling variable for the out-of-plane displacement, \( w \), from the disk to the top face of the cylinder. Also the acceleration, \( w_{tt} \), is needed.

1. If you are in the Pressure Acoustics application mode, switch to the Mindlin Plate application mode by choosing Geom1: Mindlin Plate (smdrm) from the Multiphysics menu.
2. On the Options menu, point to Extrusion Coupling Variables and then click Subdomain Variables.
3. In the Subdomain Extrusion Variables dialog box, select Subdomain 1.
4. Type \( w \) in the top row under both Name and Expression. Type \( w_{tt} \) in the second row under both Name and Expression.
5. Click the Destination tab.
6. Select \( w \) from the Variable list.
7. Select Geom2 in the Geometry list, then select the check box next to Boundary 4.
8. Click the Source Vertices tab.
9. In the Vertex selection list, select Vertices 1, 2, and 4. Click the >> button.
10. Click the Destination Vertices tab.
11. In the Vertex selection list, select Vertices 2, 4, and 8. Click the >> button.
12 Click the Destination tab.
13 Select \( wtt \) from the Variable list.
14 Select Geom2 in the Geometry list, then select the check box next to Boundary 4.
15 Click the Source Vertices tab.
16 In the Vertex selection list, select Vertices 1, 2, and 4. Click the >> button.
17 Click the Destination Vertices tab.
18 In the Vertex selection list, select Vertices 2, 4, and 8. Click the >> button.
19 Click OK.

**PHYSICS SETTINGS**

**Boundary Conditions**
The sound-hard boundary condition for a rigid wall is that the normal acceleration vanishes. For a moving wall, such as the thin disk that now seals the cylinder, the appropriate condition is instead

\[
\frac{n \cdot \nabla p}{\rho a} = -a
\]

where \( a \) is the normal acceleration of the wall.

1 If the Mindlin Plate application mode is selected, switch to the Pressure Acoustics application mode by choosing Geom2: Pressure Acoustics (acpr) from the Multiphysics menu.
2 From the Physics menu, choose Boundary Settings.
3 Select the top of the cylinder where the plate is located, that is, Boundary 4.
4 From the Boundary condition list, select Normal acceleration.
5 In the \( a_n \) edit field, type \(-wtt\) (the structural acceleration in the negative \( z \) direction).
6 Click OK.

**Subdomain Settings**
The acoustic pressure acting as a normal load constitutes the coupling in the opposite direction.

1 From the Multiphysics menu, choose Geom1: Mindlin Plate (smdrm).
2 Open the Subdomain Settings dialog box.
3 Click the Load tab.
4 Select Subdomain 1.
5 In the $F_z$ edit field, type $p$ to specify the pressure as a surface load on the disk.
6 Click OK.
7 Switch back to the 3D geometry by choosing 2 Geom2: Pressure Acoustics (acpr) from the Multiphysics menu.

**COMPUTING THE SOLUTION**
1 From the Solve menu, choose Solver Manager.
2 In the Solver Manager dialog box, click the Solve For tab.
3 Reactivate the Mindlin Plate application mode by selecting both Geom1 (2D) and Geom2 (3D) and all corresponding variables in the Solve for list.
4 Click the Solve button to compute the solution. When done, click OK.

**POSTPROCESSING AND VISUALIZATION**
1 Open the Plot Parameters dialog box.
2 On the General page, add boundary and deformed shape plots to the isosurface plot by selecting the Boundary and Deformed shape check boxes in the Plot type area.
3 Click the Boundary tab.
4 In the Boundary data area, enter the Expression $\lambda^2 w$, that is, the normal acceleration of the disk. On the other boundaries, $w$ is not defined so those boundaries are invisible.
5 Click the Deform tab and select the Boundary check box only in the Domain types to deform area.
6 In the Deformation data area, click the Boundary Data tab and type 0, 0, and $w$ in the $x$ component, $y$ component, and $z$ component edit field, respectively.
7 Click the General tab.
8 Select an entry from the Eigenfrequency list, then click Apply to examine the corresponding eigenmode.
9 When finished, click Cancel or OK to close the Plot Parameters dialog box.
One of the two eigenmodes with an eigenfrequency near 2730 Hz.
Open Pipe

Introduction

If you plan on setting up a large, complicated acoustics model, it can be useful to break it up in smaller, simpler problems. In this example, a vibrating piston is mounted inside one end of a cylindrical pipe. The other end is open and set in a plane baffle. A first version of the model studies the air outside the baffle as a PML (perfectly matched layer) region. A second version measures and then uses the impedance load on the piston, where it replaces the air region with an impedance boundary condition applied to the tube’s open end. The impedance boundary condition uses a radiation impedance given as a function of the measured impedance at the piston. You can employ the technique of measuring impedances and reusing them in impedance boundary conditions to handle arbitrary kinds of pipe openings.

Model Definition

Figure 4-1: Pipe geometry. The flange is cut off in the illustration but is assumed to extend to infinity. The piston makes up the bottom of the pipe.
Figure 4-1 shows the geometry simulated in this model. A pipe of length $L = 1.5$ m and radius $a = 0.25$ m has a driving piston at one end. The other end is open and flush with the infinite hard wall in which it is set. The piston vibrates harmonically with a velocity $v = v_0 e^{i \omega t}$ where $v_0 = 1$ m/s, and $\omega = 2 \pi f$ is the angular frequency (rad/s). The model sweeps the frequency, $f$, through a range of values between 10 Hz and 700 Hz. The acoustic medium is air with a density of 1.25 kg/m$^3$ and a speed of sound of 343 m/s.

The axial symmetry of the geometry and the physics makes it natural to set the model up in a 2D axisymmetric application mode. Two cylindrical PMLs represent the air outside the pipe as shown in Figure 4-2.

![Figure 4-2: Model geometry. PML 1 is damping only in the z direction, while PML 2 is damping in both the r direction and the z direction.](image)

The PMLs serve to absorb the outgoing waves so that the nonphysical reflections at their exterior boundaries have a minimal influence on the pressure field inside the pipe. PMLs require the tangential component of the damping to be continuous across a
boundary. Hence the PML just above the pipe is damping only in the \( z \) direction, while the one outside the pipe is damping both in the \( r \) direction and the \( z \) direction. For further details about the PML implementation in the Acoustics Module, please refer to “Perfectly Matched Layers (PMLs)” on page 37 in the *Acoustics Module User’s Guide*.

**DOMAIN EQUATIONS**

For harmonic sound waves this model uses the frequency-domain Helmholtz equation for sound pressure:

\[
\nabla \cdot \left( \frac{1}{\rho_0} \nabla p - q \right) - \frac{\omega^2 p}{\rho_0 c_s^2} = 0
\]

Here the acoustic pressure is a harmonic quantity, \( p = \rho_0 e^{i\omega t} \) (N/m\(^2\)), \( \rho_0 \) is the density (kg/m\(^3\)), \( q \) denotes an optional dipole source (N/m\(^3\)), and \( c_s \) is the speed of sound (m/s). The model under study includes no dipole source.

**BOUNDARY CONDITIONS**

The first version of the model uses two distinct boundary conditions. First, it represents the hard walls of the pipe and the flange by the equation

\[
\mathbf{n} \cdot \left( \frac{1}{\rho_0} \nabla p - q_s \right) = 0
\]

where \( \mathbf{n} \) is the outward-pointing unit normal vector seen from inside the acoustics domain. The model also uses this condition at the exterior boundaries of the PMLs.

Second, the piston is modeled with a normal acceleration condition:

\[
\mathbf{n} \cdot \left( \frac{1}{\rho_0} \nabla p - q_s \right) = a_n
\]

where the normal acceleration, \( a_n \), is defined as \( i\omega \upsilon_0 \).

The second version of the model replaces the PML domains with an impedance boundary condition at the opening of the pipe:

\[
-\mathbf{n} \cdot \left( \frac{1}{\rho_0} \nabla p - q_s \right) = \frac{i\omega p}{Z}
\]

The impedance \( Z \) is a function of the frequency obtained by measuring and transforming the radiation load on the piston. Given a piston impedance \( Z_0 = p/\upsilon \) evaluated at the piston, introduce the quantities \( \upsilon_0 \) and \( \beta_0 \) such that
\[ Z_0 = \rho_0 c_s \tanh \pi (\alpha_0 + i\beta_0) \quad (4-1) \]

With \( \alpha_L = \alpha_0 \) and \( \beta_L = \beta_0 - kL/\pi \), where \( k = \omega/c_s \), define
\[ Z = Z_L = \rho_0 c_s \tanh \pi (\alpha_L + i\beta_L) \quad (4-2) \]

This transformation is derived in Ref. 1 as a valid approximation in the long-wavelength limit where only plane waves can propagate inside the tube. Note that this reference uses the definition \( p = p_0 e^{i\omega t} \), which makes the formulas look slightly different. Because \( Z \) corresponds to the radiation impedance of a membrane set in an infinite hard wall plane, it is possible to analytically derive values for \( \alpha_L \) and \( \beta_L \); these values appear in Ref. 1.

**Results and Discussion**

*Figure 4-3: Acoustic pressure field in the pipe at 700 Hz.*

The pressure field in the pipe at 700 Hz (Figure 4-3) is dominated by an outgoing and a reflected plane wave except close to the opening.
Figure 4-4 shows the reactance measured at the piston. The zero crossings of the reactance plot occur at the acoustic eigenfrequencies of the tube and the outside air. Comparing these to the simple analytic case of zero pressure at the open end, the eigenfrequencies of the open tube are consistently lower. This is to be expected because the computed eigenmodes are not restrained to the inside of the pipe but can spill out into the open.

![Figure 4-4: The reactance at the piston as a function of frequency.](image)

The analytical eigenfrequencies are given by the expression

\[ f_n = \frac{nc_s}{4L} \]

The accuracy of the computed eigenfrequencies is limited by the pitch of the frequency sweep. The following table is based on a pitch of 1 Hz.

<table>
<thead>
<tr>
<th>COMPUTED (HZ)</th>
<th>SIMPLIFIED ANALYTIC (HZ)</th>
</tr>
</thead>
<tbody>
<tr>
<td>50.4</td>
<td>57.2</td>
</tr>
<tr>
<td>101.8</td>
<td>114.3</td>
</tr>
<tr>
<td>154.2</td>
<td>171.5</td>
</tr>
</tbody>
</table>

*TABLE 4-3: COMPUTED AND SIMPLIFIED ANALYTIC FREQUENCIES IN THE OPEN PIPE*
TABLE 4-3: COMPUTED AND SIMPLIFIED ANALYTIC FREQUENCIES IN THE OPEN PIPE

<table>
<thead>
<tr>
<th>COMPUTED (HZ)</th>
<th>SIMPLIFIED ANALYTIC (HZ)</th>
</tr>
</thead>
<tbody>
<tr>
<td>207.5</td>
<td>228.7</td>
</tr>
<tr>
<td>261.6</td>
<td>285.8</td>
</tr>
<tr>
<td>316.3</td>
<td>343.0</td>
</tr>
<tr>
<td>371.4</td>
<td>400.2</td>
</tr>
<tr>
<td>426.8</td>
<td>457.3</td>
</tr>
<tr>
<td>482.7</td>
<td>514.5</td>
</tr>
<tr>
<td>538.9</td>
<td>571.7</td>
</tr>
<tr>
<td>595.6</td>
<td>628.8</td>
</tr>
<tr>
<td>652.8</td>
<td>686.0</td>
</tr>
</tbody>
</table>

Using values for $\alpha_L$ and $\beta_L$ from Ref. 1 in Equation 4-1 and Equation 4-2 lets you calculate semi-analytical values for the piston impedance, $Z_0$. Figure 4-5 compares this impedance with the computed impedance.

Figure 4-5: Measured (solid) and semi-analytical (dashed) impedance at the piston. Because the fit is so good that it is difficult to tell the curves apart, the figure zooms in on the frequency range from 100 to 300 Hz.
**Modeling in COMSOL Multiphysics**

This model is set up in 2D axisymmetry using the Pressure Acoustics application mode of the Acoustics Module. This application mode has automated support for PMLs, making it a straightforward task to set up the model. Using the Solver Manager, you store the PML solution for reuse in the impedance boundary condition of the second version of the model.

**Reference**


**Model Library path:** Acoustics_Module/Benchmark_Models/open_pipe

---

**Modeling Using the Graphical User Interface**

**MODEL NAVIGATOR**

1. Start COMSOL Multiphysics.
2. In the Model Navigator, select **Axial symmetry (2D)** from the Space dimension list.
3. From the list of application modes select **Acoustics Module>Pressure Acoustics>Time-harmonic analysis**.
4. Click OK.

**OPTIONS**

1. Open the Constants dialog box from the Options menu and enter the values in the following table (the descriptions are optional); when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>v0</td>
<td>1[m/s]</td>
<td>Maximum piston velocity</td>
</tr>
<tr>
<td>a</td>
<td>0.25[m]</td>
<td>Pipe radius</td>
</tr>
<tr>
<td>L</td>
<td>1.5[m]</td>
<td>Pipe length</td>
</tr>
<tr>
<td>rho_air</td>
<td>1.25[kg/m^3]</td>
<td>Air density</td>
</tr>
<tr>
<td>cs_air</td>
<td>343[m/s]</td>
<td>Speed of sound in air</td>
</tr>
</tbody>
</table>

2. Choose Options>Expressions>Scalar Expressions and enter the expressions in the following table. Alternatively, to avoid entering the expressions, click the
Import Variables From File button in the same dialog box. The file open_pipe_expr.txt contains all the expressions. Load this file from the COMSOL Multiphysics installation directory under /models/Acoustics_Module/Benchmark_Models/.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>k_air</td>
<td>omega_acpr/cs_air</td>
<td>Wave number</td>
</tr>
<tr>
<td>a0</td>
<td>i<em>omega_acpr</em>v0</td>
<td>Piston acceleration</td>
</tr>
<tr>
<td>z0</td>
<td>P/v0</td>
<td>Piston impedance</td>
</tr>
<tr>
<td>eta0</td>
<td>z0/(rho_air*cs_air)</td>
<td>Normalized piston impedance</td>
</tr>
<tr>
<td>alpha0</td>
<td>real(atanh(eta0))/pi</td>
<td>Hyperbolic piston impedance factor</td>
</tr>
<tr>
<td>beta0</td>
<td>imag(atanh(eta0))/pi</td>
<td>Hyperbolic piston impedance factor</td>
</tr>
<tr>
<td>alphaL</td>
<td>alpha0</td>
<td>Hyperbolic radiation impedance</td>
</tr>
<tr>
<td>betaL</td>
<td>beta0-k_air*L/pi</td>
<td>Hyperbolic radiation impedance</td>
</tr>
<tr>
<td>etaL</td>
<td>tanh(pi*(alphaL+i*betaL))</td>
<td>Normalized radiation impedance</td>
</tr>
<tr>
<td>zL</td>
<td>nojac(etaL)<em>rho_air</em>cs_air</td>
<td>Radiation impedance</td>
</tr>
</tbody>
</table>

The nojac operator ensures that zL does not contribute to the Jacobian matrix. In practice, this means that when you eventually use zL in a boundary condition, it depends on the previous solution and does not affect the current one.

3 Click OK.

GEOMETRY MODELING

1 Use the Rectangle dialog box (which you reach, for example, by shift-clicking the Rectangle/Square button on the Draw toolbar) to create two rectangles with the following properties:

<table>
<thead>
<tr>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>BASE CORNER R</th>
<th>BASE CORNER Z</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.5</td>
<td>0.5</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>0.25</td>
<td>2</td>
<td>0</td>
<td>-1.5</td>
</tr>
</tbody>
</table>

2 Click the Zoom Extents button on the Main toolbar.
PHYSICS SETTINGS

Subdomain Settings
Choose Physics>Subdomain Settings and apply the following settings; when done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN 1</th>
<th>SUBDOMAIN 2</th>
<th>SUBDOMAIN 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \rho_0 )</td>
<td>( \rho_{\text{air}} )</td>
<td>( \rho_{\text{air}} )</td>
<td>( \rho_{\text{air}} )</td>
</tr>
<tr>
<td>( c_s )</td>
<td>( c_s_{\text{air}} )</td>
<td>( c_s_{\text{air}} )</td>
<td>( c_s_{\text{air}} )</td>
</tr>
<tr>
<td>Type of PML</td>
<td>None</td>
<td>Cylindrical</td>
<td>Cylindrical</td>
</tr>
<tr>
<td>Absorbing in ( r ) direction</td>
<td>-</td>
<td>unchecked</td>
<td>0.25</td>
</tr>
<tr>
<td>Absorbing in ( z ) direction</td>
<td>-</td>
<td>0.5</td>
<td>0.5</td>
</tr>
<tr>
<td>( R_0 )</td>
<td>-</td>
<td>-</td>
<td>0.25</td>
</tr>
</tbody>
</table>

Boundary Conditions
Choose Physics>Boundary Settings and apply the following boundary conditions; when done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 1, 3</th>
<th>BOUNDARY 2</th>
<th>BOUNDARIES 5, 6, 8–10</th>
</tr>
</thead>
<tbody>
<tr>
<td>( a_n )</td>
<td>Axial symmetry</td>
<td>Normal acceleration</td>
<td>Sound hard boundary (wall)</td>
</tr>
<tr>
<td>( a_0 )</td>
<td>-</td>
<td>( a_0 )</td>
<td>-</td>
</tr>
</tbody>
</table>

Boundary Integration Variables
Choose Options>Integration Coupling Variables>Boundary Variables. Select boundary 2 and define the following boundary integration coupling variable; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>( P )</td>
<td>( 2*\pi*\rho/\pi^2 )</td>
</tr>
</tbody>
</table>

This variable represents the mean value of the pressure over the piston.

MESH GENERATION

1. Choose Mesh>Free Mesh Parameters.
2. On the Global page, click the Custom mesh size button and in the Maximum element size edit field type 0.04.
3. Click the Boundary tab and select Boundaries 2 and 4. In the Maximum element size edit field type 0.02.
4. Click OK.
5 Click the Initialize Mesh button on the Main toolbar to create the mesh.

**Computing the Solution**

1. Choose Solve>Solver Parameters.
2. From the Solver list select Parametric.
3. In the Parameter name edit field type `freq_acpr`, and in the Parameter values edit field type `10:10:700`.
4. Click the Stationary tab, then select Linear from the Linearity list to ensure that the parametric sweep uses the linear solver.
5. Click OK.
6. Click the Solve button on the Main toolbar.

**Postprocessing and Visualization**

![Figure 4-6: The acoustic pressure in the tube and in the PMLs at 700 Hz.](image)

The default plot should look like Figure 4-6. It displays the acoustic pressure in the tube at the final frequency of the sweep, 700 Hz. It also shows that the damping is efficient in the PML regions.

To get a better view of the damping, try plotting the sound level in dB:
1. Choose **Postprocessing>Plot Parameters**.

2. On the **Surface** page choose **Pressure Acoustics (acpr)>Sound pressure level** from the **Predefined quantities** list. Click **OK**.

With a visual inspection you can see that the pressure drop from the open end of the tube to the top boundary of the PML region that makes up the air domain is roughly 50 dB. This means that the part of the wave that is reflected at this boundary experiences a total of 100 dB damping before it returns to the tube. This is more than enough for all practical purposes.

From now on suppress the PMLs and look exclusively at the physical pressure field inside the tube.

1. Choose **Options>Supress>Supress Subdomains**.

2. Select Subdomains 2 and 3, then click **OK**.

3. Open the **Plot Parameters** dialog box again and click the **Surface** tab.

4. From the **Predefined quantities** list choose **Pressure Acoustics (acpr)>Pressure**. Click **OK**.

Note how the pressure field deviates from the simple plane wave behavior in the vicinity of the open end of the tube. Now examine the impedance at the piston.

5. Choose **Postprocessing>Domain Plot Parameters** and click the **Point** tab.

6. Select an arbitrary point in the **Point selection** list. In the **Expression** field, type \( \text{real}(z_0) \), then click **Apply** to see the plot.

You are now looking at the acoustic resistance as a function of frequency. The peaks show the resonance frequencies for the semi-open tube with a resolution given by the pitch of the frequency sweep.

You can get the same resonance frequencies with the accuracy improved by the linear interpolation between neighboring frequencies if you instead study the zeros of the reactance plot.

7. Remaining on the **Point** page, enter \( \text{imag}(z_0) \) in the **Expression** field and click **Apply** to see the plot.

By zooming in on the zeros in this plot, you should find frequencies similar to those in Table 4-3. To get the same accuracy as in this table, though, you would have to resolve the model with a frequency pitch of 1 Hz.

Finally, plot the real and the imaginary parts of the radiation impedance:

1. Still on the **Point** page, type \( \text{real}(z_L) \) in the **Expression** field and click **Apply**.
2. On the General page select the Keep current plot check box.

3. Click the Title/Axis button. In the Title edit field type Radiation resistance (solid) and reactance (dashed), and in the Second axis label edit field type (ohm). Click OK.

4. On the Point page click the Line Settings button. Set the Line style to Dashed line. Click OK.

5. In the Expression field type $\text{imag}(z_L)$, then click OK to reproduce the plot in Figure 4-7.

![Graph of Radiation resistance and reactance at the opening of the pipe.](image)

*Figure 4-7: Radiation resistance and reactance at the opening of the pipe.*

**Lumped Impedance Version**

In this version of the model, replace the PMLs with an impedance boundary condition using the radiation impedance that you have already calculated.

**SUBDOMAIN SETTINGS**

From the Physics menu open the Subdomain Settings dialog box. Select Subdomains 2 and 3, clear the Active in this domain check box, and then click OK.
BOUNDARY CONDITIONS

From the Physics menu open the Boundary Settings dialog box. Select Boundary 4. In the Boundary condition list select Impedance boundary condition. Enter zL for the Input impedance, then click OK.

COMPUTING THE SOLUTION

1. Click the Solver Manager button on the Main toolbar.
2. Click the Store Solution button. In the dialog box that appears, make sure that all frequencies are selected, then click OK.
3. In the Values of variables not solved for and linearization point list select Stored solution.
4. From the Parameter value list select All.
5. Click OK.
6. Click the Solve button on the Main toolbar.

POSTPROCESSING AND VISUALIZATION

The pressure field is now everywhere independent of the r coordinate. The impedance boundary condition still leaves the piston impedance unchanged.

1. Choose Postprocessing>Domain Plot Parameters and click the General tab.
2. Clear the Keep current plot check box. Click the Title/Axis button. Select the Auto buttons for all options, then click OK to close the Title/Axis dialog box.
3. On the Point page, click Line Settings. Set the Line style to Solid line, then click OK.
4. In the Expression edit field type real(z0). Click Apply to see the plot.
5. Enter imag(z0) in the Expression edit field. Click OK to see the plot.

The resistance and reactance plots appear to be virtually identical to those from the solution using PMLs. If you want to compare these results to the analytical solution, follow these steps:

1. Choose Options>Functions.
2. In the Functions dialog box, click the New button.
3. In the New Function dialog box, enter the Function name alphaL_ana.
4. Click the Interpolation button. In the Use data from list, select File.
5. Browse to find the file alpha.txt, which is located in the COMSOL Multiphysics installation directory under /models/Acoustics_Module/Benchmark_Models/. Click Open, then click OK to close the New Function dialog box.
6 Repeat Steps 2 through 5 to create another interpolation function, but this time use the function name betaL_ana and the data file beta.txt, which you find in the same folder as alpha.txt.

7 Click OK to close the Functions dialog box.

8 If you previously entered the scalar expressions manually, now choose Options>Expressions>Scalar Expressions and add the following scalar expressions; when done, click OK.

9 Choose Solve>Update Model.

10 Choose Postprocessing>Domain Plot Parameters.

11 Click the Point tab. In the Expression edit field type abs(z0), then click Apply.

12 On the General page select the Keep current plot check box.

13 Click the Title/Axis button. In the Title edit field type Analytical (dashed) and computed (solid) piston impedance, and in the Second axis label edit field type (ohm). Click OK.

14 On the Point page click the Line Settings button. Set the Line style to Dashed line, then click OK.

15 In the Expression field type abs(z0_ana), then click OK to generate the plot.

If you zoom in on the range between 100 Hz and 300 Hz, what you get should look like the image in Figure 4-5.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>alpha0_ana</td>
<td>alphaL_ana(k_air*a)</td>
<td>Hyp. piston imp. factor</td>
</tr>
<tr>
<td>beta0_ana</td>
<td>betaL_ana(k_air<em>a)+k_air</em>L/pi</td>
<td>Hyp. piston imp. factor</td>
</tr>
<tr>
<td>eta0_ana</td>
<td>tanh(pi*(alpha0_ana+i*beta0_ana))</td>
<td>Normalized piston imp.</td>
</tr>
<tr>
<td>z0_ana</td>
<td>eta0_ana<em>rho_air</em>cs_air</td>
<td>Piston impedance</td>
</tr>
</tbody>
</table>
Scattering from a Plate with Ribs

Introduction

The following model has been suggested as a benchmark for acoustic scattering from a thin 3D structure (Ref. 1). Problems of this kind have traditionally been the domain of boundary element (BEM) codes, and the test case was designed with such solvers in mind. The purpose of the present model is to show that scattering problems can be handled very well also by a finite element software like COMSOL Multiphysics, using the built-in PML functionality to reduce the model domain to a minimum.

There is no closed-form reference solution to this benchmark problem, but the presented results correlate very well with the boundary element solutions reported in Ref. 1.
Model Definition

The test geometry consists of a quadratic plate with a pair of stiffening ribs welded on top along the two lines of symmetry. The side length is 60 cm and the ribs are 15 cm high.

Figure 4-8: Target geometry and surface mesh.

All parts are assumed to have negligible thickness and to be perfectly rigid. You can therefore model the entire structure as boundaries with sound-hard surfaces on both sides. To be able to set separate boundary conditions on the two sides of a boundary, you must create the geometry as an assembly and disconnect the boundaries representing the structure.

Scattering problems are best modeled using the scattered-field formulation. This means that you write the acoustic pressure as the sum of a known incident field, \( p_i \), and an unknown scattered field, \( p_s \). Inserting this sum in the standard acoustic Helmholtz equation and assuming that the incident field by itself is a solution to the same equation, you are left with an equation for the scattered field:
Here $\rho_0$ is the equilibrium density ($\text{kg/m}^3$), $\omega = 2\pi f$ denotes the angular frequency (rad/s), and $c_s$ refers to the speed of sound (m/s). The incident field does not appear in the equation but it modifies the boundary conditions.

The benchmark case specifies the material properties of air as $\rho_0 = 1.225 \text{ kg/m}^3$ and $c_s = 340 \text{ m/s}$. Two frequencies are used in the test: 1000 Hz and 1500 Hz. In each case, a plane wave with an intensity of 100 dB SPL is travelling in the $(1, -1, -1)$ direction.

To avoid the scattered waves spuriously reflecting back from the model boundaries onto the target structure, the latter can be padded tightly in PMLs. In this case, it is easiest to define axis-parallel PMLs outside the minimal box around the structure. Note that this means you have a PML directly on the bottom target surface, with no air domain in between, and that there is no reason not to build the model in this way. The PMLs are set to be just one half wavelength thick and three quadratic elements across, which is by far enough to match the accuracy in the reference solutions. For an introduction to using PMLs when modeling with the Acoustics Module, see “Perfectly Matched Layers (PMLs)” on page 73 of the Acoustics Module User’s Guide.

The entire model can be constructed as a six-by-six-by-three grid of identical cubes. This gives you more subdomains than strictly necessary, but it greatly simplifies the process of creating a structured hexahedral mesh. The final geometry consists of an assembly of six separate parts, which are joined with identity pairs on all internal boundaries that are not part of the target structure. (For an explanation of the terminology concerning assemblies, refer to the section “The Object Properties dialog box for a 3D solid object.” on page 76 of the COMSOL Multiphysics User’s Guide.)

Results and Discussion

Of the 108 domains making up the geometry, 92 are PMLs. The pressure solution inside the PMLs has very little to do with the true scattered field. In the 16 domains
representing the actual geometry, the pressure field is correct to the extent the
discretization allows.

The reference solutions are given as SPL values along a vertical line from $Z = -2$ to
$Z = 2$ situated at $X = 1, Y = -1$. Producing these values at an intermediate distance
from the target is easy for a boundary element code. However, while solving this
benchmark problem in the presented way is straightforward, obtaining numbers
comparable to the reference solutions requires some additional work.

The easiest way to evaluate the pressure at an intermediate distance from a radiating
object is by using the Helmholtz-Kirchhoff integral representation formula. For the
particular case of a thin scatterer this formula simplifies to

$$
p_s(R) = \frac{1}{4\pi} \int_{S} e^{-ik|r - R|} p_s(r) \left( \frac{1 + ik|r - R|}{|r - R|^2} \right) (\mathbf{n} \cdot (r - R)) d\mathbf{r} \quad (4-3)
$$

where $k$ is the wave number, $\mathbf{n}$ is the outward-facing normal vector, and the integral
is taken over the target surface, $S$. Note that the two sides of a thin structure are
separate surfaces in the integral, with opposite normal directions. The far-field feature
in the Acoustics Module allows you to solve the above integral.
Knowing the scattered pressure field at the probe positions, the total sound pressure level can be calculated as

\[ L_p(R) = 10\log\left(\frac{|p_s(R) + p_d(R)|^2}{2p_{ref}^2}\right) \]

where the reference pressure for air is taken to be \( p_{ref} = 2 \cdot 10^{-5} \text{ Pa} \). The results are presented in Table 4-4.

<table>
<thead>
<tr>
<th>Z COORDINATE</th>
<th>1000 HZ</th>
<th>1500 HZ</th>
</tr>
</thead>
<tbody>
<tr>
<td>-2.0</td>
<td>99.2</td>
<td>101.4</td>
</tr>
<tr>
<td>-1.6</td>
<td>97.6</td>
<td>96.3</td>
</tr>
<tr>
<td>-1.2</td>
<td>100.1</td>
<td>100.0</td>
</tr>
<tr>
<td>-0.8</td>
<td>100.3</td>
<td>100.4</td>
</tr>
<tr>
<td>-0.4</td>
<td>96.7</td>
<td>97.6</td>
</tr>
<tr>
<td>0.0</td>
<td>101.7</td>
<td>98.7</td>
</tr>
<tr>
<td>0.4</td>
<td>99.2</td>
<td>99.7</td>
</tr>
<tr>
<td>0.8</td>
<td>98.8</td>
<td>101.6</td>
</tr>
<tr>
<td>1.2</td>
<td>101.6</td>
<td>102.4</td>
</tr>
<tr>
<td>1.6</td>
<td>98.4</td>
<td>100.3</td>
</tr>
<tr>
<td>2.0</td>
<td>101.4</td>
<td>99.5</td>
</tr>
</tbody>
</table>

The obtained values are indistinguishable from one of the reference solutions in Ref. 1, with the other being slightly off.

**Modeling in COMSOL Multiphysics**

You set up this benchmark model using the scattered-field formulation in the Pressure Acoustics application mode. Perfectly matched layers (PMLs) allow you to truncate the domain close to the target geometry. To further reduce memory requirements, you can use a multigrid solver, although direct solvers are faster when applicable. With the far-field variable for the scattered pressure field at the probe positions you can extract the benchmark results.
Reference

Model Library path:
Acoustics_Module/Benchmark_Models/plate_with_ribs

Modeling Using the Graphical User Interface

MODEL NAVIGATOR
1. In the Model Navigator select 3D from the Space dimension list.
2. From the Application Modes tree select Acoustics Module>Pressure Acoustics>Time-harmonic analysis, scattered wave.
3. Click OK to close the Model Navigator.

GEOMETRY MODELING
The geometry consists of 108 identical cubes. You start by creating one such cube and thereafter, step by step, duplicate and copy this single cube until the final geometry is obtained.

1. Choose Draw>Use Assembly to put COMSOL Multiphysics in assembly mode.
2. Choose Draw>Block. In the dialog box that appears, modify the following entries; when finished, click OK.

<table>
<thead>
<tr>
<th>Length</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>0.15</td>
<td></td>
</tr>
<tr>
<td>Y</td>
<td>0.15</td>
<td></td>
</tr>
<tr>
<td>Z</td>
<td>0.15</td>
<td></td>
</tr>
</tbody>
</table>

3. With the single cube selected, choose Edit>Copy or press Ctrl+C to put a copy of the cube on the clipboard.
4. Choose Edit>Paste or press Ctrl+V to paste a copy of the cube into the drawing area. Enter the following information into the Paste dialog box; when finished click OK.

<table>
<thead>
<tr>
<th>Displacement</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>x</td>
<td>-0.3</td>
</tr>
</tbody>
</table>
5 Repeat Step 4 to paste a second copy in the same position.

6 Paste one more copy, specifying:

\[
\begin{array}{c|c|c}
\text{Displacement} & \text{x} & -0.45 \\
& \text{y} & -0.45 \\
& \text{z} & -0.15 \\
\end{array}
\]

7 Now select the first block, BLK1, and choose Draw>Modify>Array or press the Array button on the Draw toolbar. Enter the following data; when finished, click OK.

\[
\begin{array}{c|c|c}
\text{Displacement} & \text{x} & 0.15 \\
& \text{y} & 0.15 \\
& \text{z} & 0 \\
\end{array}
\]

8 Select the original block together with the newly created three, then press the Union button on the Draw toolbar.

9 With the new composite object still selected, again open the Array dialog box and set the following values; when finished, click OK.

\[
\begin{array}{c|c|c}
\text{Displacement} & \text{x} & -0.3 \\
& \text{y} & -0.3 \\
& \text{z} & 0 \\
\end{array}
\]

10 Return to the second cube created, BLK2, select it and open the Array dialog box. Enter the following data; when finished, click OK.

\[
\begin{array}{c|c|c}
\text{Displacement} & \text{x} & 0.15 \\
& \text{y} & 0.15 \\
& \text{z} & 0 \\
\end{array}
\]
Join the original and the 15 new copies in a single object by selecting them and then clicking the **Union** button.

Return to the **Array** dialog box, but with the cube BLK3 as selected source object. Create copies as follows; when finished, click **OK**.

Select the new copies together with BLK3, then click the **Union** button.

Select the last of the original four cubes, BLK4, and for the final time open the **Array** dialog box. This time you will create 107 copies.

Add the original cube BLK4 to the selection and click the **Union** button.

Finally, add the composite object CO6 to the selection and click the **Difference** button on the Draw toolbar.

Before leaving draw mode you must create identity pairs on the objects’ common surfaces. Do this by selecting all objects and clicking the **Create Pairs** button.
OPTIONS AND SETTINGS

1 Choose Options>Constants and create the following constants; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lp_i</td>
<td>100</td>
<td>Incident wave sound pressure level</td>
</tr>
<tr>
<td>p0</td>
<td>sqrt(2<em>2e-5</em>2*10^&quot;(Lp_i/10&quot;)</td>
<td>Incident wave amplitude (Pa)</td>
</tr>
<tr>
<td>kx</td>
<td>1/sqrt(3)</td>
<td>Incident wave direction, x component</td>
</tr>
<tr>
<td>ky</td>
<td>-1/sqrt(3)</td>
<td>Incident wave direction, y component</td>
</tr>
<tr>
<td>kz</td>
<td>-1/sqrt(3)</td>
<td>Incident wave direction, z component</td>
</tr>
<tr>
<td>X</td>
<td>1</td>
<td>Probe x coordinate</td>
</tr>
<tr>
<td>Y</td>
<td>-1</td>
<td>Probe y coordinate</td>
</tr>
<tr>
<td>Z</td>
<td>0</td>
<td>Probe z coordinate</td>
</tr>
</tbody>
</table>

PHYSICS SETTINGS

Subdomain Settings

The material properties are the same in all domains, those of air, while the PMLs have different settings depending on in which directions they are absorbing. It is easiest to set the same PML parameters everywhere first, and then disable the damping in directions where it is not needed.

1 Choose Physics>Subdomain Settings.

2 Select all domains by pressing Ctrl+A. In the Fluid density edit field type 1.225 and in the Speed of sound edit field type 340.

3 With all domains still selected, go to the PML page and select Cartesian from the Type of PML list.

4 For all three directions, select the check box for absorption and change the corresponding Scaled PML width to 0.5*cs_acpr/freq_acpr, which is half the default value. When combined with a radiation boundary condition applied on the outer PML boundary, this setting typically results in sufficient damping while requiring half the number of mesh layers in the PML to resolve the acoustic waves.

5 Now select all subdomains which do not have a boundary face at $x = -0.45$ or at $x = 0.45$ and clear the Absorbing in x direction check box. You do this most easily by clicking the Go to XY view toolbar button for a top view, then clicking the Orbit/Pan/Zoom button to clear it, and finally drawing a rubber-band box around all domains except the leftmost and rightmost columns.
6. Repeat Step 5 for the y direction, that is, clear the **Absorbing in y direction** check box for all domains which do not have a boundary at \( y = -0.45 \) or \( y = 0.45 \).

7. Click the **Go to YZ view** toolbar button, use a rubber band to select the middle row of domains and clear the **Absorbing in z direction** check box.

8. Click **OK** to close the **Subdomain Settings** dialog box.

**Boundary Conditions**

To define the scattering structure, use the sound-hard boundary condition on the pairs, which sets sound-hard boundary conditions on all boundaries in each pair. Also define the far-field variable for the scattered field at the probe positions (\( p_{s\_probe} \)).

1. Choose **Physics>Boundary Settings**.

2. Select Boundary 1, then double-click the **Select by group** check box to select all exterior boundaries. From the **Boundary condition** list, select **Radiation condition**. The PMLs work best with a radiation condition on the outside.

3. Click the **Pairs** tab to enable pair selection. Select Pairs 6–13 and **Sound hard boundary (wall)** from the **Boundary condition** list.

4. Click the **Boundaries** tab, then go to the **Far-Field** page.

5. Type \( p_{s\_probe} \) in the **Name** column of the first table row. When moving to the next cell in the table default values appear in the **Field** and **Normal derivative** columns.

All the selected boundaries have a sound-hard boundary condition. This means that the normal derivative of the **total** pressure, \( p_t \), is zero. Because you use the scattered field formulation, the normal derivative for the pressure variable, \( p = p_t - p_i \), is equal to \(-\mathbf{n} \cdot \nabla p_t\). The accuracy of the far-field calculation increases if you enter this expression as the normal derivative. However, because the scatterer is thin, you can simplify the problem further by noting that the normal derivative of the incident pressure, \( p_i \), is equal in magnitude but of opposite signs for two points on opposite sides of the thin scatterer surface. Therefore, as is expressed in Equation 4-3, the corresponding contributions to the Helmholtz-Kirchhoff integral cancel.

6. In view of the preceding discussion, set the **Normal derivative** to 0.

7. Set the **Type of integral** to **Full integral**.

8. Click **OK** to close the dialog box.

**Application Scalar Variables**

The incident wave field is a global quantity defined in the **Application Scalar Variables** dialog box.

1. Choose **Physics>Scalar Variables**.
2. Set the incident pressure wave to $p_0 \exp(-i k_{acpr} (kx x + ky y + kz z))$.

3. Click OK to close the dialog box.

**Generating the Mesh**

1. Click the Boundary Mode button on the Main toolbar, then click the Decrease Mesh Size button on the Mesh toolbar twice to set the mesh size to Finer.

2. Press Ctrl+A to select all boundaries, then click the Mesh Selected (Mapped) button to mesh all boundary faces with regular quadrilateral elements.

3. Click the Subdomain Mode button on the Main toolbar, then select all subdomains.

4. Click the Mesh Remaining (Swept) button to mesh the interior of the model with solid hexahedra.

5. Choose Mesh>Mesh Statistics and verify that you have 64,854 degrees of freedom and 6912 hexahedral elements. When done, click OK.

**Computing the Solution**

On many computers, you can solve the model directly with the default SPOOLES direct symmetric solver. When memory is not a limiting factor, a direct solver is usually the fastest option, but for the sake of illustration, the following steps describe a possible set of iterative solver settings:

1. Choose Solve>Solver Parameters or click the corresponding button on the Main toolbar to open the Solver Parameters dialog box.

2. Select the Parametric solver, set Parameter name to freq_acpr and set the Parameter values to 1000 1500. If you want to use the default direct solver, you can now jump directly to Step 12.

3. Click the Settings button in the Linear system solver area to open the Linear System Solver Settings dialog box.

4. Select Geometric multigrid as Linear system solver. New nodes labeled Presmoother, Postsmoother, and Coarse solver appear in the tree to the left. Leave the geometric multigrid settings as they are to create a coarse level by reducing the element order only.

5. Select the Presmoother node in the tree and select GMRES from the Presmoother list.

6. Keep the Number of iterations at 2 but change the Number of iterations before restart to 2.

7. Expand the Presmoother tree node by clicking the plus sign to its left and select the Preconditioner node.
8 Select SSOR as Preconditioner for the GMRES presmoother.

9 Repeat the presmoother settings in Steps 5–8 for the Postsmoother node, that is, select GMRES with two iterations before restart as smoother and SSOR as preconditioner for the smoother.

10 The Coarse solver setting can be left at the default choice. Using SPOOLES would save some memory by exploiting the matrix symmetries but UMFPACK is faster for small problems.

11 Click OK to close the Linear System Solver Settings dialog box.

12 Click OK to close the Solver Parameters dialog box, then click the Solve button on the Main toolbar to compute the solution.

**POSTPROCESSING AND VISUALIZATION**

The default plot shows the scattered wave pressure on five equidistant slices along the x-axis. To get a better view of the wave pattern, you can change the slice positions:

1 Choose Postprocessing>Plot Parameters or click the corresponding button on the Main toolbar.

2 Clear the Element refinement: Auto check box and type 3 or 4 in the edit field.

3 On the Slice page, select the three option buttons next to the Vector with coordinates edit fields in the Slice positioning area, then make the following entries:

<table>
<thead>
<tr>
<th>FIELD</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>x levels</td>
<td>-0.01 0.01</td>
</tr>
<tr>
<td>y levels</td>
<td>-0.01 0.01</td>
</tr>
<tr>
<td>z levels</td>
<td>-0.01 0.01</td>
</tr>
</tbody>
</table>

4 Select which quantity to visualize among the Predefined quantities, for example Sound pressure level.

5 Click OK to see the plot.

6 For better visibility, turn on some light by pressing the Headlight button on the Camera toolbar.

To extract the values in Table 4-4 do the following steps:

The line along which you want the values is not a part of the geometry. Therefore use the line $x = 0, y = 0, -0.1 \leq z \leq 0.1$. In the expression you use $X = x + 1, Y = y - 1, Z = 20z$.

1 Choose Postprocessing>Data Display>Subdomain to open the Data Display dialog box.
2 In the Expression field, type $10 \log_{10} \left( 0.5 \cdot \text{abs} \left( p_{s \_probe}(1, -1, 20z) + p0 \cdot \exp (-i k_{acpr} \cdot (kx-ky+kz*20z)) \right)^2 / 2 \cdot 5^{-2} \right)$.

3 In the $z$ edit field type $-2/20:0.4/20:2/20$, select an entry from the Parameter value list, and click Apply.
# Index

**A**  absorptive muffler 88  
acoustically-dominated modes 228  
acoustics of a muffler 88  
acoustic-structure interaction 226  
aeroacoustics 115  
aircraft-engine noise modeling 115  
area porosity, for perforated plate 197  

**B**  Bessel panel 8  
boundary conditions, for perforated plate 197  

**C**  car interior 104  
CFL number 71  
contra-vibrating mode 227  

**D**  damping  
  Delany-Bazley 89  
  inductive 88  
  resistive 88  
  Delany-Bazley damping 89  
dissipative muffler 193  

**E**  end correction, for perforated plate 197  
extended multiphysics 226  

**F**  far-field plots 31  
flow duct 115  

**G**  Gaussian explosion 69  

**H**  Helmholtz-Kirchhoff integral 255  

**I**  interdigitated transducer 210  
irrotational velocity field 48  

**K**  kerf 59  

**M**  models, overview of 2  
muffler  
  acoustics model of 88  
dissipative 193  
reflective 193  
muffler with perforates 193  

**N**  numerical damping 71  

**P**  perfectly matched layers 117, 238, 252  
perforated plate  
  impedance boundary condition for 197  
piezoelectric transducer 59  
piezoelectricity models  
piezooacoustic transducer 59  
SAW gas sensor 210  
pitch 59  
porosity, for perforated plate 197  

**R**  radiation condition 10, 21  
radiation patterns 31  
reflective muffler 193  

**S**  SAW gas sensor 210  
scattering problems 252  
Sound Brick 104  
structurally-dominated modes 228  
surface acoustic waves 210  

**T**  tightly coupled modes 228  
transmission 88  
transmission loss 88  
typographical conventions 5  

**U**  ultrasound diagnostics 19  
ultrasound scattering 78  
UWVF, tutorial model for 78  

**V**  verification, of experiments 226  
vortex sheet 48  

**W**  water acoustics 19

**INDEX** 265