CONTENTS

Chapter 1: Introduction

Model Library Guide .................. 2
Typographical Conventions ......... 6

Chapter 2: Tutorial Models

Electromagnetic Forces on Parallel Current-Carrying Wires 8
Introduction .................................. 8
Model Definition ............................ 9
Results and Discussion. ................. 9
Modeling Using the Graphical User Interface .............. 10

Inductive Heating of a Copper Cylinder 19
Introduction .................................. 19
Model Definition ............................ 19
Results and Discussion. ................. 20
Modeling Using the Graphical User Interface .............. 20

Permanent Magnet 24
Introduction .................................. 24
Model Definition ............................ 24
Results and Discussion. ................. 25
Modeling Using the Graphical User Interface .............. 25

Chapter 3: Motors and Drives Models

Linear Electric Motor of the Moving Coil Type 34
Introduction .................................. 34
Model Definition ............................ 34
Results and Discussion. ................. 36
Modeling Using the Graphical User Interface .............. 36
Chapter 4: Electrical Component Models

Tunable MEMS Capacitor

Introduction
<table>
<thead>
<tr>
<th>Model Definition</th>
<th>104</th>
</tr>
</thead>
<tbody>
<tr>
<td>Results and Discussion</td>
<td>105</td>
</tr>
<tr>
<td>Modeling Using the Graphical User Interface</td>
<td>106</td>
</tr>
<tr>
<td>Modeling Using the Programming Language</td>
<td>111</td>
</tr>
</tbody>
</table>

**Induction Currents from Circular Coils**  
113
| Introduction | 113 |
| Model Definition | 113 |
| Results and Discussion | 115 |
| Harmonic Analysis in the Graphical User Interface | 116 |
| Transient Analysis | 120 |
| Modeling Using the Programming Language | 121 |

**Magnetic Field of a Helmholtz Coil**  
124
| Introduction | 124 |
| Model Definition | 125 |
| Results and Discussion | 127 |
| Modeling Using the Graphical User Interface | 128 |

**Inductance in a Coil**  
134
| Introduction | 134 |
| Model Definition | 134 |
| Results and Discussion | 135 |
| Modeling Using the Graphical User Interface | 136 |

**Integrated Square-Shaped Spiral Inductor**  
144
| Introduction | 144 |
| Model Definition | 144 |
| Results | 147 |
| Modeling Using the Graphical User Interface | 147 |
| Modeling Using the Programming Language | 155 |

**Inductance of a Power Inductor**  
157
| Introduction | 157 |
| Model Definition | 157 |
| Results and Discussion | 159 |
| Modeling Using the Graphical User Interface | 159 |
## Planar Transformer on PCB

**Introduction** .......................... 165
**Model Definition** ...................... 165
**Results and Discussion** ............... 167
**Modeling Using the Graphical User Interface** .......................... 169

## Bonding Wires to a Chip

**Introduction** .......................... 183
**Model Definition** ...................... 183
**Results and Discussion** ............... 185
**Modeling Using the Graphical User Interface** .......................... 186
**Modeling Using the Programming Language** .......................... 190

## High Current Cables in a Circuit

**Introduction** .......................... 192
**Model Definition** ...................... 192
**Results and Discussion** ............... 194
**Modeling Using the Graphical User Interface** .......................... 198
**Modeling the Entire Circuit** ........... 204

## Inductor in an Amplifier Circuit

**Introduction** .......................... 211
**Model Definition** ...................... 211
**Results and Discussion** ............... 214
**Reference** ............................... 215
**Modeling Using the Graphical User Interface** .......................... 216

## Chapter 5: General Industrial Application Models

## Eddy Currents in 3D

**Introduction** .......................... 224
**Model Definition** ...................... 224
**Alternate Modeling Technique Using Reduced Form** .......................... 226
**Results and Discussion** ............... 228
**Modeling Using the Graphical User Interface** .......................... 229
**Changing to Aluminum and Stainless Steel** .......................... 232
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Changing to Magnetic Iron</td>
<td>232</td>
</tr>
<tr>
<td>Modeling Using Reduced Form</td>
<td>234</td>
</tr>
<tr>
<td>Cold Crucible</td>
<td>242</td>
</tr>
<tr>
<td>Introduction</td>
<td>242</td>
</tr>
<tr>
<td>Model Definition</td>
<td>242</td>
</tr>
<tr>
<td>Results and Discussion</td>
<td>244</td>
</tr>
<tr>
<td>Modeling Using the Graphical User Interface</td>
<td>245</td>
</tr>
<tr>
<td>Electric Impedance Sensor</td>
<td>253</td>
</tr>
<tr>
<td>Introduction</td>
<td>253</td>
</tr>
<tr>
<td>Model Definition</td>
<td>253</td>
</tr>
<tr>
<td>Results and Discussion</td>
<td>255</td>
</tr>
<tr>
<td>Modeling Using the Graphical User Interface</td>
<td>255</td>
</tr>
<tr>
<td>One-Sided Magnet and Plate</td>
<td>260</td>
</tr>
<tr>
<td>Introduction</td>
<td>260</td>
</tr>
<tr>
<td>Model Definition</td>
<td>260</td>
</tr>
<tr>
<td>Results and Discussion</td>
<td>261</td>
</tr>
<tr>
<td>Reference</td>
<td>262</td>
</tr>
<tr>
<td>Modeling Using the Graphical User Interface</td>
<td>262</td>
</tr>
<tr>
<td>Modeling Using a Nonlinear Magnetic Material in the Plate</td>
<td>268</td>
</tr>
<tr>
<td>Magnetic Signature of a Submarine</td>
<td>272</td>
</tr>
<tr>
<td>Introduction</td>
<td>272</td>
</tr>
<tr>
<td>Model Definition</td>
<td>273</td>
</tr>
<tr>
<td>Results and Discussion</td>
<td>274</td>
</tr>
<tr>
<td>Modeling Using the Graphical User Interface</td>
<td>275</td>
</tr>
<tr>
<td>3D Quadrupole Lens</td>
<td>283</td>
</tr>
<tr>
<td>Introduction</td>
<td>283</td>
</tr>
<tr>
<td>Model Definition</td>
<td>283</td>
</tr>
<tr>
<td>Results</td>
<td>284</td>
</tr>
<tr>
<td>Modeling Using the Graphical User Interface</td>
<td>285</td>
</tr>
<tr>
<td>Superconducting Wire</td>
<td>290</td>
</tr>
<tr>
<td>Introduction</td>
<td>290</td>
</tr>
<tr>
<td>Model Definition</td>
<td>290</td>
</tr>
</tbody>
</table>
Results and Discussion .......................... 292
Reference .............................................. 293
Modeling Using the Graphical User Interface .. 293

**RF-Heated Hot Wall Furnace for Semiconductor Processing**  298
Introduction ........................................... 298
Model Definition ..................................... 298
Results and Discussions ............................ 301
Modeling Using the Graphical User Interface .. 304

**An RFID System** .................................. 322
Introduction ........................................... 322
Results .................................................. 324
Modeling Using the Graphical User Interface .. 326
Time-Harmonic Simulations .......................... 343

**Magnetic Prospecting of Iron Ore Deposits**  345
Introduction ........................................... 345
Model Definition ..................................... 345
Results and Discussion ............................. 349
References ............................................. 353
Modeling Using the Graphical User Interface .. 354

INDEX .................................................. 359
The **AC/DC Module Model Library** consists of a set of models from various areas of low-frequency electromagnetic field simulations. Their purpose is to assist you in learning, by example, how to model sophisticated electromagnetic components, systems, and effects. Through them, you can tap the expertise of the top researchers in the field, examining how they approach some of the most difficult modeling problems you might encounter. You can thus get a feel for the power that COMSOL Multiphysics® offers as a modeling tool. In addition to serving as a reference, the models can also give you a big head start if you are developing a model of a similar nature.

We have divided these models into four groups: electrical components, general industrial applications, motor and drives, and tutorial models. The models also illustrate the use of the various electromagnetics-specific application modes from which we built them. These specialized modes are unavailable in the base COMSOL Multiphysics package, and they come with their own graphical-user interfaces that make it quick and easy to access their power. You can even modify them for custom requirements. COMSOL Multiphysics itself is very powerful and, with sufficient expertise in a given field, you certainly could develop these modes by yourself—but why spend the hundreds or thousands of hours that would be necessary when our team of experts has already done the work for you?
Note that the model descriptions in this book do not contain every detail on how to carry out every step in the modeling process. Before tackling these in-depth models, we urge you to first read the second book in the AC/DC Module documentation set. Titled the AC/DC Module User's Guide, it introduces you to the basic functionality in the module, reviews new features in the version 3.5 release, covers basic modeling techniques and includes reference material of interest to those working in electromagnetics. A third book, the AC/DC Module Reference Guide, contains reference material about application mode implementations and command-line programming. It is available in HTML and PDF format from the COMSOL Help Desk. For more information on how to work with the COMSOL Multiphysics graphical user interface, please refer to the COMSOL Multiphysics User's Guide or the COMSOL Multiphysics Quick Start manual. Extensive information about command-line modeling using COMSOL Script is available in yet another book, the COMSOL Multiphysics Scripting Guide.

The book in your hands, the AC/DC Module Model Library, provides details about a large number of ready-to-run models that illustrate real-world uses of the module. Each entry comes with theoretical background as well as instructions that illustrate how to set it up. They were written by our staff engineers who have years of experience in electromagnetics; they are your peers, using the language and terminology needed to get across the sophisticated concepts in these advanced topics.

Finally note that we supply these models as COMSOL Multiphysics Model MPH-files so you can import them into COMSOL Multiphysics for immediate execution, allowing you to follow along with these examples every step along the way.

Model Library Guide

The table below summarizes key information about the entries in the AC/DC Module Model Library. A series of columns states the application mode (such as Perpendicular Currents) used to solve the corresponding model. The solution time is the elapsed time measured on a machine running Windows Vista with a 2.6 GHz AMD Athlon X2 Dual Core 500 CPU and 2 GB of RAM. For models with a sequential solution strategy, the Solution Time column shows the combined total time for all solution steps. Additional columns point out the modeling features that a given example...
highlights. The categories here include the type of analysis (such as time dependent) and whether multiphysics or parametric studies are included.

<table>
<thead>
<tr>
<th>MODEL</th>
<th>PAGE</th>
<th>APPLICATION MODE</th>
<th>SOLUTION TIME</th>
<th>STATIONARY</th>
<th>TIME-HARMONIC</th>
<th>TIME DEPENDENT</th>
<th>EIGENFREQUENCY/EIGENMODE</th>
<th>SENSITIVITY</th>
<th>MULTIPHYSICS</th>
<th>PARAMETRIC STUDY</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>TUTORIAL MODELS</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Eddy Currents</td>
<td>21*</td>
<td>Azimuthal Induction Currents</td>
<td>3 s</td>
<td>√</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Floating Potentials and Electric Shielding</td>
<td>33*</td>
<td>Conductive Media DC</td>
<td>19 s</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Coil with Infinite Elements</td>
<td>46*</td>
<td>Azimuthal Induction Currents</td>
<td>11 s</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Microstrip</td>
<td>70*</td>
<td>Electrostatics, In-Plane Electric and Induction Currents, Potentials</td>
<td>3 s</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Small-Signal Analysis of an Inductor</td>
<td>101*</td>
<td>Azimuthal Induction Currents</td>
<td>59 s</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Electromagnetic Forces on Parallel Current-Carrying Wires</td>
<td>8</td>
<td>Perpendicular Currents</td>
<td>2 s</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Inductive Heating of a Copper Cylinder</td>
<td>19</td>
<td>Azimuthal Currents, Heat Transfer</td>
<td>7 s</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Permanent Magnet</td>
<td>24</td>
<td>Magnetostatics, No Currents</td>
<td>12 s</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

| **MOTORS AND DRIVES MODELS** | | | | | | | | | | |

TABLE 1-1: AC/DC MODULE MODEL LIBRARY

<table>
<thead>
<tr>
<th>MODEL</th>
<th>PAGE</th>
<th>APPLICATION MODE</th>
<th>SOLUTION TIME</th>
<th>STATIONARY</th>
<th>TIME-HARMONIC</th>
<th>TIME-DEPENDENT</th>
<th>EIGENFREQUENCY/EIGENMODE</th>
<th>SENSITIVITY</th>
<th>MULTIPHYSICS</th>
<th>PARAMETRIC STUDY</th>
</tr>
</thead>
<tbody>
<tr>
<td>Linear Electric Motor of the Moving Coil Type</td>
<td>34</td>
<td>Perpendicular Currents</td>
<td>1 s</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Generator in 2D</td>
<td>43</td>
<td>Perpendicular Currents, Moving Mesh</td>
<td>2 min</td>
<td></td>
<td>√</td>
<td>√</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Generator with Mechanical Dynamics and Symmetry</td>
<td>57</td>
<td>Perpendicular Currents</td>
<td>2 min</td>
<td></td>
<td>√</td>
<td>√</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Generator in 3D</td>
<td>69</td>
<td>Magnetostatics, No Currents</td>
<td>5 min</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>√</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Magnetic Brake in 3D</td>
<td>76</td>
<td>Magnetostatics</td>
<td>7 min</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>√</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Railgun</td>
<td>88</td>
<td>3D Quasi-Statics, Conductive Media DC</td>
<td>37 min</td>
<td></td>
<td>√</td>
<td>√</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

ELECTRICAL COMPONENT MODELS

<table>
<thead>
<tr>
<th>MODEL</th>
<th>PAGE</th>
<th>APPLICATION MODE</th>
<th>SOLUTION TIME</th>
<th>STATIONARY</th>
<th>TIME-HARMONIC</th>
<th>TIME-DEPENDENT</th>
<th>EIGENFREQUENCY/EIGENMODE</th>
<th>SENSITIVITY</th>
<th>MULTIPHYSICS</th>
<th>PARAMETRIC STUDY</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tunable MEMS Capacitor</td>
<td>104</td>
<td>Electrostatics</td>
<td>7 s</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Induction Currents from Circular Coils</td>
<td>113</td>
<td>Azimuthal Currents</td>
<td>7 s</td>
<td></td>
<td>√</td>
<td>√</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Magnetic Field of a Helmholtz Coil</td>
<td>124</td>
<td>Magnetostatics</td>
<td>33 s</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>√</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Inductance in a Coil</td>
<td>134</td>
<td>Azimuthal Currents</td>
<td>12 s</td>
<td></td>
<td>√</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Integrated Square-Shaped Spiral Inductor</td>
<td>144</td>
<td>Magnetostatics</td>
<td>10 s</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>√</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Inductance of a Power Inductor</td>
<td>157</td>
<td>3D Quasi-Statics</td>
<td>3 min</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>√</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Planar Transformer on PCB</td>
<td>165</td>
<td>Magnetostatics, Electrostatics</td>
<td>56 min</td>
<td></td>
<td>√</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### TABLE 1-1: AC/DC MODULE MODEL LIBRARY

<table>
<thead>
<tr>
<th>MODEL</th>
<th>PAGE</th>
<th>APPLICATION MODE</th>
<th>SOLUTION TIME</th>
<th>STATIONARY</th>
<th>TIME-HARMONIC</th>
<th>TIME DEPENDENT</th>
<th>EIGENFREQUENCY</th>
<th>EIGENMODE</th>
<th>SENSITIVITY</th>
<th>MULTIPHYSICS</th>
<th>PARAMETRIC STUDY</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bonding Wires to a Chip†</td>
<td>183</td>
<td>3D Quasi-Statics</td>
<td>7 min</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>High Current Cables in a Circuit</td>
<td>192</td>
<td>Joule Heating</td>
<td>56 s</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Inductor in an Amplifier Circuit</td>
<td>211</td>
<td>Azimuthal Currents, ODE</td>
<td>27 s</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>GENERAL INDUSTRIAL APPLICATION MODELS</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Eddy Currents in 3D</td>
<td>224</td>
<td>3D Quasi-Statics</td>
<td>2 min</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cold Crucible</td>
<td>242</td>
<td>3D Quasi-Statics</td>
<td>19 s</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Electric Impedance Sensor</td>
<td>253</td>
<td>Small In-Plane Currents</td>
<td>38 s</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>One-Sided Magnet and Plate</td>
<td>260</td>
<td>Magnetostatics, No Currents</td>
<td>2 min</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Magnetic Signature of a Submarine</td>
<td>272</td>
<td>Magnetostatics, No Currents</td>
<td>11 s</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3D Quadrupole Lens</td>
<td>283</td>
<td>Magnetostatics, No Currents</td>
<td>21 s</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Superconducting Wire</td>
<td>290</td>
<td>PDE, General Form</td>
<td>17 s</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>RF-Heated Hot Wall Furnace for Semiconductor Processing</td>
<td>298</td>
<td>3D Quasi-Statics, General Heat Transfer</td>
<td>19 min</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>An RFID System</td>
<td>322</td>
<td>Magnetostatics</td>
<td>4 min</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Magnetic Prospecting</td>
<td>345</td>
<td>Magnetostatics, No Currents</td>
<td>19 s</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

* This page number refers to the AC/DC Module User’s Guide.
† This model requires a 64-bit platform.
**Typographical Conventions**

All COMSOL manuals use a set of consistent typographical conventions that should make it easy for you to follow the discussion, realize what you can expect to see on the screen, and know which data you must enter into various data-entry fields. In particular, you should be aware of these conventions:

- A **boldface** font of the shown size and style indicates that the given word(s) appear exactly that way on the COMSOL graphical user interface (for toolbar buttons in the corresponding tooltip). For instance, we often refer to the **Model Navigator**, which is the window that appears when you start a new modeling session in COMSOL; the corresponding window on the screen has the title **Model Navigator**. As another example, the instructions might say to click the **Multiphysics** button, and the boldface font indicates that you can expect to see a button with that exact label on the COMSOL user interface.

- The names of other items on the graphical user interface that do not have direct labels contain a leading uppercase letter. For instance, we often refer to the Draw toolbar; this vertical bar containing many icons appears on the left side of the user interface during geometry modeling. However, nowhere on the screen will you see the term “Draw” referring to this toolbar (if it were on the screen, we would print it in this manual as the **Draw** menu).

- The symbol > indicates a menu item or an item in a folder in the **Model Navigator**. For example, **Physics>Equation System>Subdomain Settings** is equivalent to: On the **Physics** menu, point to **Equation System** and then click **Subdomain Settings**.

- **A Code** (monospace) font indicates keyboard entries in the user interface. You might see an instruction such as “Type 1.25 in the **Current density** edit field.” The monospace font also indicates COMSOL Script codes.

- An **italic** font indicates the introduction of important terminology. Expect to find an explanation in the same paragraph or in the Glossary. The names of books in the COMSOL documentation set also appear using an italic font.
This chapter contains a selection of models that demonstrate important features and modeling techniques. Therefore, this chapter contains models from many different application areas. For pedagogical reasons, these models are kept as simple as possible with the main focus on the feature that they demonstrate.
Electromagnetic Forces on Parallel Current-Carrying Wires

Introduction

One ampere is defined as the constant current in two straight parallel conductors of infinite length and negligible circular cross section, placed one meter apart in vacuum, that produces a force of $2 \cdot 10^{-7}$ newton per meter of length (N/m). This model shows a setup of two parallel wires in the spirit of this definition, but with the difference that the wires have finite cross sections.

For wires with circular cross section carrying a uniform current density as in this example, the mutual magnetic force will be the same as for line currents. This can be understood by the following arguments: Start from a situation where both wires are line currents ($I$). Each line current will be subject to a Lorentz force ($I \times B$) where the magnetic flux density ($B$) is the one produced by the other wire. Now, give one wire a finite radius. It follows directly from circular symmetry and Maxwell-Ampère’s law that, outside this wire, the produced flux density is exactly the same as before so the force on the remaining line current is unaltered. Further, the net force on the wire with the distributed current density must be of exactly the same magnitude (but with opposite direction) as the force on the line current so that force did not change either. If the two wires exchange places, the forces must still be the same and it follows from symmetry that the force is independent of wire radius as long as the wire cross sections do not intersect. The wires can even be cylindrical shells or any other shape with circular symmetry of the cross section that. For an experimental setup, negligible cross section is required as resistive voltage drop along the wires and Hall effect may cause electrostatic forces that increase with wire radius but such effects are not included in this model.

The force between the wires is computed using three different methods: by integrating the volume (Lorentz) force density over the wire cross section; by integrating the stress tensor on the boundary; and finally by using the principle of virtual work. The results converge to $2 \cdot 10^{-7}$ N/m for the 1 ampere definition, as expected.
**Model Definition**

The model is built using the 2D Perpendicular Induction Currents application mode. The modeling plane is a cross section of the two wires and the surrounding air.

**DOMAIN EQUATIONS**

The equation formulation in the 2D Perpendicular Induction Currents application mode assume that the only nonzero component of the magnetic vector potential is \( A_z \). This corresponds to all currents being perpendicular to the modeling plane. The following equation is solved:

\[
\nabla \times (\mu \nabla \times A_z) = J_z^e
\]

where \( \mu \) is the permeability of the medium and \( J_z^e \) is the externally applied current. \( J_z^e \) is set so that the applied current in the wires equals 1 A, but with different signs.

**BOUNDARY CONDITIONS**

At the exterior boundary of the air domain, \( A_z \), is fixed to zero. The interior boundaries between the wires and the air only assume continuity, corresponding to a homogeneous Neumann condition.

**Results and Discussion**

The expression for the surface stress reads

\[
\mathbf{n}_1 T_2 = -\frac{1}{2}(\mathbf{H} \cdot \mathbf{B})\mathbf{n}_1 + (\mathbf{n}_1 \cdot \mathbf{H})\mathbf{B}_T^T
\]

where \( \mathbf{n}_1 \) is the boundary normal pointing out from the conductor wire and \( T_2 \) the stress tensor of air. The closed line integral of this expression around the circumference of either wire evaluates to \(-1.99 \times 10^{-7}\) N/m. The minus sign indicates that the force between the wires is repulsive.

The volume force density is given by

\[
\mathbf{F} = \mathbf{J} \times \mathbf{B} = \begin{bmatrix}
-J_z^e \cdot B_y - J_z^e \cdot B_x, 0
\end{bmatrix}
\]

The surface integral of the \( x \) component of the volume force on the cross section of a wire gives the result \(-1.99 \times 10^{-7}\) N/m.
The model also computes the electromagnetic force by using the principle of virtual work. It adds the application modes for parameterized geometry and sensitivity to introduce the displacement and differentiate the energy with respect to the displacement according to

$$F = \frac{\delta W}{\delta x} \quad (2-1)$$

By refining the mesh and re-solving the problem, you can verify that the solution indeed converges to $-2 \cdot 10^{-7}$ (N/m).

**Model Library path:** ACDC_Module/Tutorial_Models/parallel_wires

**Modeling Using the Graphical User Interface**

**MODEL NAVIGATOR**

1. Start COMSOL Multiphysics.
2. In the Model Navigator, select **2D** from the **Space dimension** list.
3. From the **Application Modes** tree, select the node **AC/DC Module>Virtual Work>Virtual Work for Perpendicular Currents**.
4. Click **OK**.

**OPTIONS AND SETTINGS**

1. Choose **Options>Constants**.
2. In the **Constants** dialog box, enter the following names, expressions, and (optionally) descriptions:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>$r$</td>
<td>0.2[m]</td>
<td>Wire radius</td>
</tr>
<tr>
<td>$A$</td>
<td>$\pi r^2$</td>
<td>Wire area</td>
</tr>
<tr>
<td>$I_0$</td>
<td>1[A]</td>
<td>Current through wire</td>
</tr>
<tr>
<td>$J_0$</td>
<td>$I_0/A$</td>
<td>Current density</td>
</tr>
</tbody>
</table>

The radius $r$ of each wire is 0.2 m, and the cross-section area is $A = \pi r^2$. The total current is $I_0 = 1$ A and the current density is $J_0 = I_0/A$.

3. Click **OK**.
**Geometry Modeling**

1. Press Shift, then click the **Ellipse/Circle (Centered)** button on the Draw toolbar.
2. In the **Circle** dialog box, specify a circle C1 with **Radius** 0.2 centered at (-0.5, 0), then click **OK**.
3. In the same way, create circles C2, C3, and C4 according to the following table (for properties not mentioned, use the default settings):

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>C2</th>
<th>C3</th>
<th>C4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Radius</td>
<td>0.2</td>
<td>1</td>
<td>1.5</td>
</tr>
<tr>
<td>X</td>
<td>0.5</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Y</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

4. Click the **Zoom Extents** button on the Main toolbar.

This completes the geometry-modeling stage. The finished geometry on your screen should look like that in Figure 2-1.

*Figure 2-1: The model geometry.*
PHYSICS SETTINGS

Subdomain Settings—Perpendicular Induction Currents

1 In the Multiphysics menu, make sure that Perpendicular Induction Currents, Vector Potential (emqa) is the active application mode.

2 From the Physics menu, choose Subdomain Settings.

3 On the Physics page, enter the following settings:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN 3</th>
<th>SUBDOMAIN 4</th>
</tr>
</thead>
<tbody>
<tr>
<td>$J^e_z$</td>
<td>$J_0$</td>
<td>$-J_0$</td>
</tr>
</tbody>
</table>

4 On the Infinite Elements page, enter the following settings:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type of Infinite Element</td>
<td>Cylindrical</td>
</tr>
</tbody>
</table>

5 On the Forces page, specify the following Electromagnetic force variables:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN 3</th>
<th>SUBDOMAIN 4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>wire1</td>
<td>wire2</td>
</tr>
<tr>
<td>Point</td>
<td>0 0</td>
<td>0 0</td>
</tr>
</tbody>
</table>

Note that you do not need to enter the point coordinates, just press Enter after typing the name.

6 Click OK to close the Subdomain Settings dialog box.
Boundary Conditions—Perpendicular Induction Currents
Use the default boundary conditions.

Subdomain Settings—Parameterized Geometry
1. From the Multiphysics menu, select Parameterized Geometry (pg).
2. From the Physics menu, open the Subdomain Settings dialog box.
3. Select Subdomain 1 and click the No displacement option button.
   It is important that the inside of the infinite element domain is kept fixed. The formulation is invalid for a deformed circular domain.
4. Click OK.

Boundary Conditions—Parameterized Geometry
1. From the Physics menu, open the Boundary Settings dialog box.
2. Select the Interior boundaries check box.
3. Select Boundaries 13–16 (the right wire), then select the group fixed from the Group list. Boundaries in this group remain fixed with no displacement.
4. Select Boundaries 5–8 (the left wire), then select displacement from the Group list. Boundaries in this group are displaced using the variables deltaX and deltaY, the dependent variables for the Sensitivity Analysis application mode.
5. Click OK.

Subdomain Settings—Sensitivity Analysis
When part of a Virtual Work predefined coupling, you do not need to specify any settings for the Sensitivity Analysis application mode. It can nevertheless be instructive to inspect the predefined coupling to the Perpendicular Induction Currents, Vector Potential application mode. However, if you want to, you can skip directly to the section “Mesh Generation” on page 15.

1. From the Multiphysics menu, select Sensitivity Analysis (sa).
2. From the Physics menu, select Subdomain Settings.
3. Select all subdomains.
4. In the Objective contribution area on the Objective page, note that the q2 edit field contains the predefined entry dW_emqa, as the following figure also shows.
The quantity \( dW_{emqa} \) is the integrand for the total electromagnetic energy density. The objective function \( Q_{sa} \)—defined as the integral of all objective contributions at all domain levels—thus equals the total electromagnetic energy, \( W \). Consequently, according to the principal of virtual work, the sensitivities \( \delta x \) and \( \delta y \) encode the force components \( F_x \) and \( F_y \); see Equation 2-1 on page 10.
MESH GENERATION
Click the Initialize Mesh button on the Main toolbar to initialize the mesh.

Figure 2-2: The mesh.

COMPUTING THE SOLUTION
1. From the Solve menu, open the Solver Parameters dialog box.
2. From the Linear system solver list on the General page, select Direct (PARDISO).
   Note that the Optimization/Sensitivity check box is selected. On the Optimization/ Sensitivity page you should also be able to verify that the Design variables edit field contains the entry deltaX deltaY.
3. Click OK.
4. Click the Solve button on the Main toolbar.

POSTPROCESSING AND VISUALIZATION
The default plot shows the x-displacement from the parameterized geometry, which is almost zero everywhere. Follow these steps to visualize the magnitude of the volume force density:
1. Click the Plot Parameters button on the Main toolbar.
2 Click the Surface tab. In the Expression edit field, type 
$sqrt(FLt(x_{emqa}^2+FLt(y_{emqa}^2))$ in order to plot the magnitude of the Lorentz force distribution.

3 On the Contour page, select the Contour plot check box.

4 From the Predefined quantities list, select Perpendicular Induction Currents, Vector Potential (emqa)\(\rightarrow\)Magnetic field, norm.

5 Click Apply to generate the plot.

6 To zoom in on the wires, choose Axes/Grid Settings from the Options menu. On the Axis page, type -1 in the x min and y min edit fields, and type 1 in the x max and y max edit fields. Make sure that the Axis equal check box is selected, then click Apply.

Figure 2-3 shows the result.

![Force density and magnetic field](image)

Figure 2-3: Force density and magnetic field.

To visualize the air stress tensor on the boundary, proceed as follows:

1 Return to the Contour page of the Plot Parameters dialog box and clear the Contour plot check box.

2 On the Arrow page, select the Arrow plot check box and select Boundaries from the Plot arrows on list.
3 On the **Boundary Data** page, select **Perpendicular Induction Currents, Vector Potential (emqa)>Maxwell surface stress tensor (wire1)** from the **Predefined quantities** list.

4 In the **Arrow parameters** area, clear the **Auto** check box for **Scale factor**, then type 0.1 in the associated edit field.

5 Click **OK** to close the dialog box and generate the plot shown in Figure 2-4.

![Figure 2-4: Stress tensor and magnetic field.](image)

**COMPUTING THE ELECTROMAGNETIC FORCE**

Finally, compute the resulting forces on the wires. You can do this in three different ways.

First, compute the resulting force in the $x$ direction on the left wire using the stress tensor method as follows:

1. Choose **Postprocessing>Data Display>Global** to open the **Global Data Display** dialog box.

2. In the **Expression** edit field type `wire1_forcex_emqa`, then click **OK**.

   You should get a result near $-1.99 \times 10^{-7}$ N in the message log. The result here is given in N, while the results below are given in N/m. This is due to a difference in the integration between the force variable calculated from the stress tensor and the
integration in the postprocessing routine. The force variable assumes that the 2D domain is 1 m thick and multiply all integrations with this thickness. Note that the value of the force is the same, but it is either interpreted as a force on a 1 m section or as a force per length.

To compute the resulting force by integrating $\mathbf{J} \times \mathbf{B}$, perform the following steps.

1. Choose Postprocessing>Subdomain Integration.
2. Select Subdomain 3 and type $-Jz_{\text{emu}} \times B_y$ in the Expression edit field inside the Expression to integrate area.
3. Finally, click OK to evaluate the integral.

The result displayed in the message log is again approximately $-1.99 \times 10^{-7}$ N/m. The force in the $y$ direction should be negligible. Confirm this by integrating $Jz_{\text{emu}} \times B_x$ on Subdomain 3.

To compute the electromagnetic force using the principle of virtual work, you use the results from the geometric parameterization and sensitivity analysis. The forces computed in the previous section were obtained from the ordinary PDE solution, also known as the forward solution. The adjoint sensitivity solver also returns a second solution, which gives you the derivative of the total energy with respect to the displacement variables, $\Delta X$ and $\Delta Y$. Only the $\Delta X$ variable is of interest in this model because there is no net force in the $y$ direction.

2. In the Expression edit field, type $fsens(\Delta X)$.
3. Click OK.

Again, you obtain a result near $-2 \times 10^{-7}$ (N) in the message log.

By refining the mesh and re-solving the problem, you can verify that the solution indeed converges to $-2 \times 10^{-7}$ N/m.
Inductive Heating of a Copper Cylinder

Introduction

The induced currents in a copper cylinder produce heat, and when the temperature rises, the electric conductivity of the copper changes. Solving the heat transfer simultaneously with the field propagation is therefore crucial for an accurate description of this process.

The heating caused by the induced currents is called inductive heating. Generally heating due to currents is also called resistive heating or ohmic heating.

Model Definition

The system to be solved is given by

\[ j\omega \sigma(T_0) A + \nabla \times (\mu^{-1} \nabla \times A) = 0 \]
\[ \rho C_p \frac{\partial T}{\partial t} - \nabla \cdot k \nabla T = Q(T, A) \]

where \( \rho \) is the density, \( C_p \) is the specific heat capacity, \( k \) is the thermal conductivity, and \( Q \) is the inductive heating.

The electric conductivity of copper, \( \sigma \), is given by the expression

\[ \sigma = \frac{1}{\rho_0 (1 + \alpha(T - T_0))} \]

where \( \rho_0 \) is the resistivity at the reference temperature \( T_0 = 293 \) K, \( \alpha \) is the temperature coefficient of the resistivity, and \( T \) is the actual temperature in the domain.

The time average of the inductive heating over one period, is given by

\[ Q = \frac{1}{2} \sigma |E|^2 \]
Results and Discussion

The temperature after 1200 s is shown in Figure 2-5 below. The average temperature of the copper cylinder has increased from 293 K to 300 K during this time. The current in the coil has an amplitude of 1 kA.

![Figure 2-5: Temperature distribution in the cylinder and its surroundings after 1200 s.](image)

Model Library path: ACDC_Module/Tutorial_Models/inductive_heating

Modeling Using the Graphical User Interface

The modeling steps below assume that the Heat Transfer Module is not present. If it is, the Azimuthal Induction Heating multiphysics node uses the Heat Transfer Module’s General Heat Transfer application mode. As a result, some names referring to components in the graphical user interface are slightly different.

MODEL NAVIGATOR

1. Select Axial symmetry (2D) from the Space dimension list.
2 Select the AC/DC Module>Electro-Thermal Interaction>Azimuthal Induction Heating>Transient analysis predefined multiphysics coupling.

3 Click OK.

OPTIONS AND SETTINGS
1 From the Options menu, choose Axes/Grid Settings.
2 Specify axis and grid settings according to the following table; when done, click OK.

<table>
<thead>
<tr>
<th>AXIS</th>
<th>VALUE</th>
<th>GRID</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>r min</td>
<td>-0.05</td>
<td>r spacing</td>
<td>0.05</td>
</tr>
<tr>
<td>r max</td>
<td>0.5</td>
<td>Extra r</td>
<td>0.03</td>
</tr>
<tr>
<td>z min</td>
<td>-0.3</td>
<td>z spacing</td>
<td>0.05</td>
</tr>
<tr>
<td>z max</td>
<td>0.3</td>
<td>Extra z</td>
<td>-0.01 0.01</td>
</tr>
</tbody>
</table>

3 From the Options menu, choose Constants.
4 In the Constants dialog box, specify the following constants (the descriptions are optional); when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>I0</td>
<td>1e3[A]</td>
<td>Current</td>
</tr>
<tr>
<td>diam</td>
<td>0.02[m]</td>
<td>Diameter</td>
</tr>
<tr>
<td>circ</td>
<td>pi*diam</td>
<td>Circumference</td>
</tr>
<tr>
<td>Js0</td>
<td>I0/circ</td>
<td>Surface current density</td>
</tr>
<tr>
<td>T0</td>
<td>293[K]</td>
<td>Reference temperature</td>
</tr>
<tr>
<td>r0</td>
<td>1.754e-8[ohm*m]</td>
<td>Resistivity at T = T0</td>
</tr>
<tr>
<td>alpha</td>
<td>0.0039[1/K]</td>
<td>Temperature coefficient</td>
</tr>
<tr>
<td>rho1</td>
<td>1.293[kg/m^3]</td>
<td>Density of air</td>
</tr>
<tr>
<td>Cp1</td>
<td>1.01e3[J/(kg*K)]</td>
<td>Heat capacity of air</td>
</tr>
<tr>
<td>k1</td>
<td>0.026[W/(m*K)]</td>
<td>Thermal conductivity of air</td>
</tr>
<tr>
<td>rho2</td>
<td>8930[kg/m^3]</td>
<td>Density of copper</td>
</tr>
<tr>
<td>Cp2</td>
<td>340[J/(kg*K)]</td>
<td>Heat capacity of copper</td>
</tr>
<tr>
<td>k2</td>
<td>384[W/(m*K)]</td>
<td>Thermal conductivity of copper</td>
</tr>
</tbody>
</table>

GEOMETRY MODELING
1 Draw a circle C1 with radius 0.01 centered at (0.05, 0).
2 Draw a rectangle R1 with opposite corners at (0, -0.25) and (0.2, 0.25).
3 Draw a rectangle R2 with opposite corners at (0, -0.05) and (0.03, 0.05).
4 Click the Zoom Extents button on the Main toolbar.

**PHYSICS SETTINGS**

*Application Scalar Variables*

In the Application Scalar Variables dialog box, set the frequency $\nu_\text{qa}$ to 500 Hz.

*Boundary Conditions*

1 From the Multiphysics menu, select the Azimuthal Induction Currents, Vector Potential ($\text{emqa}$) application mode.

2 From the Physics menu, open the Boundary Settings dialog box.

3 Select the Interior boundaries check box, then enter boundary coefficients according to the following table; when done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 1, 3, 5</th>
<th>BOUNDARIES 2, 7, 9</th>
<th>BOUNDARIES 10-13</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Axial symmetry</td>
<td>Magnetic insulation</td>
<td>Surface current</td>
</tr>
<tr>
<td>$J_s \phi$</td>
<td></td>
<td></td>
<td>$J_s \phi$</td>
</tr>
</tbody>
</table>

4 From the Multiphysics menu, select the Heat Transfer by Conduction (ht) application mode.

5 Open the Boundary Settings dialog box.

6 Enter boundary conditions and settings according to the following table; when done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 1, 3, 5</th>
<th>BOUNDARIES 2, 7, 9</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Axial symmetry</td>
<td>Temperature</td>
</tr>
<tr>
<td>$T_0$</td>
<td></td>
<td>$T_0$</td>
</tr>
</tbody>
</table>

*Subdomain Settings*

1 From the Multiphysics menu, select the Azimuthal Induction Currents, Vector Potential ($\text{emqa}$) application mode.

2 From the Physics menu, open the Subdomain Settings dialog box.

3 Enter the electric conductivity according to the following table; when done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN 1</th>
<th>SUBDOMAIN 2</th>
<th>SUBDOMAIN 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\sigma$</td>
<td>0</td>
<td>$1/(r_0^* (1+ \alpha \text{a} (T-T_0)) )$</td>
<td>0</td>
</tr>
</tbody>
</table>
4 From the Multiphysics menu, select the Heat Transfer by Conduction (ht) application mode.

5 From the Physics menu, open the Subdomain Settings dialog box.

6 Enter the expressions according to the following table:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN 1</th>
<th>SUBDOMAIN 2, 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>k</td>
<td>k₁</td>
<td>k₂</td>
</tr>
<tr>
<td>ρ</td>
<td>ρ₁</td>
<td>ρ₂</td>
</tr>
<tr>
<td>Cₚ</td>
<td>Cₚ₁</td>
<td>Cₚ₂</td>
</tr>
</tbody>
</table>

The variable Qav_emqa is the resistive heating defined by the Azimuthal Currents application mode. This variable is automatically inserted as the heat source in the Heat Transfer application mode.

Initial Conditions
1 Still in the Subdomain Settings dialog box, click the Init tab.
2 Select all domains in the Subdomain selection list and set the initial value to T₀.
3 Click OK.

Mesh Generation
Click the Initialize Mesh button on the Main toolbar.

Computing the Solution
1 Click the Solver Parameters button on the Main toolbar.
2 In the Times edit field on the General page, type `linspace(0,1200,21)`.
3 On the Advanced page, select the Use complex functions with real input check box.
4 Click OK to close the dialog box.
5 Click the Solve button on the Main toolbar.

Postprocessing and Visualization
The default plot should closely resemble that in Figure 2-5 on page 20, which visualizes the temperature distribution at the end of the simulation period.

To view the temperature distribution as a function of time, click the Animate button on the Plot toolbar.
Permanent Magnet

Introduction

In magnetostatic problems, where no currents are present, the problem can be solved using a scalar magnetic potential. This model illustrates this technique for a horse shoe-shaped permanent magnet placed near an iron rod.

![Permanent Magnet](image)

Figure 2-6: A full 3D view of the geometry. Left-right and top-down symmetry is used to minimize the problem size.

Model Definition

In a current free region, where

\[ \nabla \times \mathbf{H} = 0 \]

it is possible to define the scalar magnetic potential, \( V_m \), from the relation

\[ \mathbf{H} = -\nabla V_m \]

This is analogous to the definition of the electric potential for static electric fields. Using the constitutive relation between the magnetic flux density and magnetic field

\[ \mathbf{B} = \mu_0 (\mathbf{H} + \mathbf{M}) \]
together with the equation

$$\nabla \cdot \mathbf{B} = 0$$

you can derive an equation for $V_m$.

$$-\nabla \cdot (\mu_0 \nabla V_m - \mu_0 \mathbf{M}_0) = 0$$

**Results and Discussion**

The force on the rod is calculated by integrating the surface stress tensor over all boundaries of the rod. The expression for the stress tensor reads,

$$\mathbf{n}_1 \mathbf{T}_2 = -\frac{1}{2}(\mathbf{H} \cdot \mathbf{B})\mathbf{n}_1 + (\mathbf{n}_1 \cdot \mathbf{H})\mathbf{B}^T$$

where $\mathbf{n}_1$ is the boundary normal pointing out from the rod and $\mathbf{T}_2$ the stress tensor of air. The integration gives 148 N, which corresponds to one quarter of the rod. The actual force on the rod is therefore four times this value, 592 N.

**Model Library path:** ACDC_Module/Tutorial_Models/rod_and_permanent_magnet

**Modeling Using the Graphical User Interface**

**Model Navigator**

1. Open the Model Navigator.
2. On the New page, select **3D** from the Space dimension list.
3. From the Application Modes list, select **AC/DC Module>Statics, Magnetic>Magnetostatics, No Currents**. Click OK.

**Options and Settings**

1. From the Options menu, select **Constants**.
In the **Constants** dialog box enter the following names, expressions, and (optionally) descriptions; when done, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>murFe</td>
<td>5000</td>
<td>Relative permeability of iron</td>
</tr>
<tr>
<td>Mpre</td>
<td>750000</td>
<td>Magnetization of magnet (A/m)</td>
</tr>
</tbody>
</table>

**GEOMETRY MODELING**

You can use symmetries to reduce the size of the model. Only one arm of the magnet needs to be included in the model, and a horizontal cut can also be made. Thus, only one quarter of the magnet and rod will be modeled.

1. Create a work plane by opening the **Work-Plane Settings** dialog box and clicking **OK** to obtain the default work plane in the xy-plane.

2. In the **Axes/Grid Settings** dialog box, clear the **Auto** check box on the **Grid** tab and set both the grid **x spacing** and **y spacing** to 0.2.

3. Draw a rectangle R1 with corners at (0, 0.2) and (0.4, 0.4).

4. Draw another rectangle R2 with corners at (0.4, 0.2) and (0.6, 0.4).

5. Click the **Ellipse/Circle (Centered)** button on the Draw toolbar. Draw a circle C1 with center at (0.6, 0) and radius 0.2. Use the right mouse button to make sure a circle is obtained rather than an ellipse.

6. Draw another circle C2 also with center at (0.6, 0) but with radius 0.4.

7. Select both circles and click the **Difference** button to create the object CO1.

8. Draw a rectangle R3 with corners at (0.2, 0) and (0.6, 0.4), and a rectangle R4 with corners at (0.2, −0.4) and (1, 0).

9. Select CO1, R3, and R4 and click the **Difference** button to create the object CO2.
10 Select CO2 and R2 and click the **Union** button. Then click the **Delete Interior Boundaries** button.

11 Open the **Extrude** dialog box and select both R1 and CO2. Enter the **Distance** 0.1 and click **OK** to extrude the magnet.

12 Create the rod by combining a cylinder and a sphere. Click the **Cylinder** button to open the **Cylinder** dialog box, and enter the **Radius** 0.1 and **Height** 0.4. Set the **Axis base point** to (−0.3, 0, 0) and the **Axis direction vector** to (0, 1, 0). Click **OK** to create the cylinder.

13 Click the **Sphere** button and enter the **Radius** 0.1. Set the **Axis base point** to (−0.3, 0.4, 0) then click **OK** to create the sphere.

14 Half of the rod should now be removed. This can be done by subtracting a block from the cylinder and sphere. Click the **Block** button and enter the **Length** coordinates (0.4, 0.6, 0.2). Set the **Axis base point** to (−0.5, −0.1, −0.2), then click **OK** to create a block.

15 Open the **Create Composite Object** dialog box, and type the formula CYL1+SPH1-BLK1 in the **Set formula** edit field. Clear the **Keep interior boundaries** check box and then click **OK**.
Finally add a block surrounding the magnets and rod. In the Block dialog box use the Length coordinates (5, 2, 2) and the Axis base point (−2, 0, 0).

**PHYSICS SETTINGS**

*Boundary Conditions*

Along the boundaries far away from the magnet, the magnetic field should be tangential to the boundary as the flow lines should form closed loops around the magnet. The natural boundary condition is

\[ \mathbf{n} \cdot (\mu_0 \nabla V_m - \mu_0 \mathbf{M}_0) = \mathbf{n} \cdot \mathbf{B} = 0 \]

Thus the magnetic field is made tangential to the boundary by a Neumann condition on the potential.

Along the symmetry boundary below the magnet, the magnetic field should also be tangential, and therefore you can apply the same Neumann condition there.

On the other hand, the magnetic field should be normal to the other symmetry boundary at the front in the figure above in order for the magnetic flow lines to form closed loops around the magnet. This means that the magnetic field is symmetric with respect to the boundary. This can be achieved by setting the potential to zero along
the boundary, and thus making the potential antisymmetric with respect to the boundary.

1. From the Physics menu, choose Boundary Settings.
2. Enter boundary conditions according to the following table; when done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 2, 8, 24</th>
<th>ALL OTHERS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Zero potential</td>
<td>Magnetic insulation</td>
</tr>
</tbody>
</table>

**Subdomain Settings**

1. From the Physics menu, choose Subdomain Settings.
2. In the Subdomain Settings dialog box, enter coefficients according to the table below; when done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN 1</th>
<th>SUBDOMAIN 2</th>
<th>SUBDOMAIN 3</th>
<th>SUBDOMAIN 4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constitutive relation</td>
<td>( B = \mu_0 \mu_r H )</td>
<td>( B = \mu_0 \mu_r H )</td>
<td>( B = \mu_0 H + \mu_0 M )</td>
<td>( B = \mu_0 \mu_r H )</td>
</tr>
<tr>
<td>( \mu_r )</td>
<td>1</td>
<td>( \mu_r )</td>
<td>( \mu_r )</td>
<td>( \mu_r )</td>
</tr>
<tr>
<td>( M )</td>
<td>( \text{murFe} )</td>
<td>( \text{Mpre 0 0} )</td>
<td>( \text{murFe} )</td>
<td></td>
</tr>
<tr>
<td>Force variables</td>
<td>rod</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**MESH GENERATION**

1. Choose Mesh>Free Mesh Parameters.
2. From the Predefined mesh sizes list select Fine.
3. In order to make the mesh finer in the magnet and in the rod, click the Subdomain tab, then set the Maximum element size for Subdomains 2, 3, and 4 to 0.025.
4. Click OK to close the dialog box.
5. Click the Initialize Mesh button on the Main toolbar.

**COMPUTING THE SOLUTION**

Click the Solve button on the Main toolbar.

**POSTPROCESSING AND VISUALIZATION**

The default plot shows a slice plot of the magnetic potential.

1. Click the Plot Parameters button on the Main toolbar.
2. On the General page, select the Slice and Arrow check boxes in the Plot type area.
3 On the Slice page, set the x levels to 0 and the y levels to 0 in the Slice positioning area. For the z levels select Vector with coordinates and enter 0.05. Select hot from the Colormap list.

4 On the Arrow page, select the Magnetic flux density as Arrow data. Set the x points to 200 and the y points to 100 in the Arrow positioning area. For the z points select Vector with coordinates and enter 0.051. Select Arrow from the Arrow type list.

5 Click OK to close the dialog and generate the plot.

6 Click the button Goto XY View and use the zoom tool to zoom in on the magnet and rod.

---

**Force Calculation**

To calculate the force on the rod, use the surface stress tensor, which is derived in “Electromagnetic Forces” on page 133 in the AC/DC Module User's Guide,

\[
\mathbf{n}_1 T_2 = -\frac{1}{2} (\mathbf{H} \cdot \mathbf{B}) \mathbf{n}_1 + (\mathbf{n}_1 \cdot \mathbf{H}) \mathbf{B}^T
\]

where \(\mathbf{n}_1\) is the boundary normal pointing out from the rod and \(T_2\) the stress tensor of air. The electromagnetic force variable rod, which was defined on the rod in the Subdomain Settings dialog box, generates the variables rod_forcex_emnc, rod_forcey_emnc, and rod_forcez_emnc, which are the forces on the rod in the x, y, and z directions, respectively.
To evaluate the force in the $x$ direction, open the Global Data Display dialog box and enter the expression $\text{rod\_force}_x\_emnc$. The result is about 148 N. Because the model only includes one quarter of the rod, the actual force is four times this value, 592 N.
This chapter contains examples of models in the area of electric motors and drives. It includes static models with force computations as well as transient models with motion.
Linear Electric Motor of the Moving Coil Type

Introduction

Linear electric motors (LEMs) are electromechanical devices that produce motion in a straight line, without the use of any mechanism to convert rotary motion to linear motion. The benefits over conventional rotary-to-linear counterparts are the absence of mechanical gears and transmission systems, which results in a higher dynamic performance and improved reliability. The acceleration available from these motors is remarkable compared to traditional motor drives that convert rotary to linear motion.

A LEM is similar to a rotary motor whose stator and rotor have been cut along a radial plane and unrolled so that it provides linear thrust. The same electromagnetic force that produces torque in a rotary motor produces a direct linear force in a linear motor.

The force that develops in the motor depends on the magnetic field and the current in the coils and of course on the shape of the different parts. A parameter of interest is the maximum force in standstill operation, that is, when the magnetic field is constant and the force depends only on the current density distribution. The current density in the coils is limited by the maximum temperature allowed in the coils. For a certain motor topology you can estimate the maximum electromagnetic force in standstill by first performing a heat transfer simulation to get the maximum current density, and then using this value in the magnetostatic problem where the forces are computed.

Model Definition

A LEM of moving coil type consists of a stationary primary and a moving secondary. The stationary primary is a permanent magnet assembly consisting of a double magnet array with alternating polarities bounded inside a U-shaped iron former. The moving secondary is centered within the U-shaped magnet assembly, and consists of 3-phase core coils mounted on a T-shaped aluminum armature. Figure 3-1 shows a cross-sectional view of the moving coil.

1. Model provided by Hans Johansson and Mikael Hansson, The Royal Institute of Technology, Stockholm.
Figure 3-1: Cross section of the LEM’s moving coil

The permanent magnets in the primary have a residual induction $B_r$ of 1.23 T, giving the magnetization

$$M = \frac{B_r}{\mu_0} = 0.98 \times 10^6 \text{A/m}$$

The current in the coil is obtained via a heat transfer simulation. If a temperature of 65 $^\circ$C is allowed in the coil and the surrounding temperature is 25 $^\circ$C, the simulation in the heat transfer mode gives a maximum heat source $Q$ of 230,000 W/m$^3$.

The heat source is equivalent to the resistive losses in the copper, which are given by the expression

$$Q = \mathbf{J} \cdot \mathbf{E} = \frac{1}{\rho_{\text{Cu}}} \cdot j_z^2$$

where $\rho_{\text{Cu}}$ is the resistivity of copper, which is 1.72 $\times$ $10^{-8}$ $\Omega$m. This gives the maximum current density $J_z$ of 3.66 A/mm$^2$.

EQUATION

COMSOL Multiphysics solves the problem using a magnetostatic equation for the magnetic potential $\mathbf{A}$. This is a 2D model, so it is possible to formulate an equation for the $z$ component of the potential,

$$-\nabla \left( \mu_0^{-1} \mu_r^{-1} \nabla A_z - \left[ \begin{array}{c} \mu_0^{-1} \mu_r^{-1} B_{ry} \\ \mu_0^{-1} \mu_r^{-1} B_{rz} \end{array} \right] \right) = J_z^e$$

where $\mu_0$ is the permeability of vacuum, $\mu_r$ the relative permeability, $\mathbf{B}$ the remanent flux density, and $J_z^e$ is the current density.
Results and Discussion

To calculate the force on the coils you can use either the method of virtual displacement making a small perturbation and calculating the change in magnetic energy

\[ W_m = \frac{B \cdot H}{2} \]

or the Lorentz force expression

\[ \mathbf{F} = \mathbf{J} \times \mathbf{B} \]

The resulting force in the \( x \) direction is \( F_x = 276 \, \text{N/m} \). The air gap shear stress \( \tau \) is the force developed per unit air gap area and gives an indication of the specific force capability. \( F/(l \cdot A) \) is the force per moving volume. This can be compared with the force per moving mass, which indicates the acceleration capabilities. The air gap length is 40 mm and the air gap area is 190 mm\(^2\).

<table>
<thead>
<tr>
<th>QUANTITY</th>
<th>RESULT</th>
</tr>
</thead>
<tbody>
<tr>
<td>( F/l )</td>
<td>276 N/m</td>
</tr>
<tr>
<td>( \tau )</td>
<td>0.69 N/cm(^2)</td>
</tr>
<tr>
<td>( F/(l \cdot A) )</td>
<td>1.45 N/cm(^3)</td>
</tr>
</tbody>
</table>

Model Library path: ACDC_Module/Motors_and_Drives/coil_LEM

Modeling Using the Graphical User Interface

MODEL NAVIGATOR

1. Select 2D in the Space dimension list.
2. Select the AC/DC Module>Statics, Magnetic>Magnetostatics>Perpendicular Induction Currents, Vector Potential application mode.
3. Select Lagrange - Linear as element type in the Element list.
4. Click OK.

OPTIONS AND SETTINGS

1. From the Options menu, choose Axes/Grid Settings.
2 Specify axis and grid settings according to the following table; when done, click OK.

<table>
<thead>
<tr>
<th>AXIS</th>
<th>GRID</th>
</tr>
</thead>
<tbody>
<tr>
<td>x min</td>
<td>-0.06</td>
</tr>
<tr>
<td>x max</td>
<td>0.06</td>
</tr>
<tr>
<td>y min</td>
<td>-0.01</td>
</tr>
<tr>
<td>y max</td>
<td>0.03</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>x spacing</th>
<th>Extra x</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.002</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>y spacing</th>
<th>Extra y</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.01</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>x spacing</th>
<th>Extra x</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.0025</td>
<td></td>
</tr>
<tr>
<td>0.0035</td>
<td></td>
</tr>
<tr>
<td>0.0075</td>
<td></td>
</tr>
<tr>
<td>0.0105</td>
<td></td>
</tr>
</tbody>
</table>

3 From the Options menu, choose Constants.

4 In the Constants dialog box, enter the following variable names, expressions, and descriptions (the descriptions are optional); when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>sigCu</td>
<td>5.99e7[S/m]</td>
<td>Conductivity of copper</td>
</tr>
<tr>
<td>sigFe</td>
<td>1.03e7[S/m]</td>
<td>Conductivity of iron</td>
</tr>
<tr>
<td>muFe</td>
<td>2e3</td>
<td>Relative permeability of iron</td>
</tr>
<tr>
<td>Br</td>
<td>1.23[T]</td>
<td>Remanent flux density of the magnets</td>
</tr>
<tr>
<td>Jin</td>
<td>3.66e6[A/m^2]</td>
<td>Current density</td>
</tr>
</tbody>
</table>

**GEOMETRY MODELING**

1 Draw a rectangle R1 with opposite corners at (-0.05, 0) and (0.05, 0.0105).
2 Draw a rectangle R2 with opposite corners at (-0.05, 0.0075) and (0.05, 0.0105).
3 Draw a rectangle R3 with opposite corners at (-0.058, 0.0035) and (-0.042, 0.0075).
4 Select R3 and click the Array button. Set the Displacement in the x direction to 0.02 and the Array size in the x direction to 6.
5 Draw a rectangle R9 with opposite corners at (-0.018, 0) and (0.022, 0.0025).
6 Copy R9 into two new rectangles, pasting them at the same location.
7 Select R11 and click the Scale button on the draw toolbar. If it is difficult to select R11, a useful trick is to click the Create Composite Object button in the vertical toolbar, select the desired object in the Object selection list and click Cancel. Set the Scale factor in the x direction to 2/3 and the Scale factor in the y direction to 1 and change the Scale base point to (0.002, 0).
8 Select R10 and click the Scale button on the Draw toolbar. Set the Scale factor in the x direction to 1/3 and the Scale factor in the y direction to 1 and change the Scale base point to (0.002, 0).

9 Press Ctrl+A to select all objects and then open the Create Composite Object dialog box. Enter the expression \((R1+\ldots+R11)\times R1\) in the Set formula edit field.

10 Draw a line L1 from (0.002, 0) to (0.002, 0.0025).

**PHYSICS SETTINGS**

**Boundary Conditions**
Specify boundary conditions according to the following table.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 2, 16, 22, 25, 30, 36, 39, 44</th>
<th>ALL OTHERS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Electric insulation</td>
<td>Magnetic insulation</td>
</tr>
</tbody>
</table>
Subdomain Settings
Specify the subdomain properties according to the following table.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN 1</th>
<th>SUBDOMAIN 3</th>
<th>SUBDOMAINS 2, 6, 13</th>
<th>SUBDOMAINS 4, 10, 14</th>
</tr>
</thead>
<tbody>
<tr>
<td>$B \leftrightarrow H$</td>
<td>$B = \mu_0 H_r$</td>
<td>$B = \mu_0 H_r$</td>
<td>$B = \mu_0 H_r + B_r$</td>
<td>$B = \mu_0 H_r + B_r$</td>
</tr>
<tr>
<td>$\sigma$</td>
<td>0</td>
<td>sigFe</td>
<td>sigFe</td>
<td>sigFe</td>
</tr>
<tr>
<td>$\mu_r$</td>
<td>1</td>
<td>muFe</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>$B_r$</td>
<td>0 0</td>
<td>0 0</td>
<td>0 Br</td>
<td>0 -Br</td>
</tr>
<tr>
<td>$J^e$</td>
<td>0 0</td>
<td>0 0</td>
<td>0 0</td>
<td>0</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAINS 5, 7</th>
<th>SUBDOMAINS 9, 11</th>
<th>SUBDOMAINS 8, 12</th>
</tr>
</thead>
<tbody>
<tr>
<td>$B \leftrightarrow H$</td>
<td>$B = \mu_0 H_r$</td>
<td>$B = \mu_0 H_r$</td>
<td>$B = \mu_0 H_r$</td>
</tr>
<tr>
<td>$\sigma$</td>
<td>sigCu</td>
<td>sigCu</td>
<td>sigCu</td>
</tr>
<tr>
<td>$\mu_r$</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>$B_r$</td>
<td>0 0</td>
<td>0 0</td>
<td>0 0</td>
</tr>
<tr>
<td>$J^e$</td>
<td>Jin</td>
<td>-Jin</td>
<td>0</td>
</tr>
</tbody>
</table>

Mesh Generation
Click the Initialize Mesh button on the Main toolbar.

Computing the Solution
1. Select the Adaptive mesh refinement check box in the Solver Parameters dialog box.
2. Click the Solve button on the Main toolbar to start the simulation.
**POSTPROCESSING AND VISUALIZATION**

1. In the **Plot Parameters** dialog box, select **Contour** plot and select the magnetic potential as **Contour data**.

   ![Contour: Magnetic potential, z component [Wb/m]](image)

You can now calculate the force on the coils by using the built-in Lorentz force variable provided in the AC/DC Module. To calculate the total force it is necessary to integrate the Lorentz force over all the conducting subdomains.

1. From the **Postprocessing** menu, select **Subdomain Integration**.
2. Select Subdomains 5, 7, 8, 9, 11, and 12; these are the subdomains which represent conducting materials.
3. Enter `Fltzx_emqa` as the expression to integrate, then click **OK**. This should give the result `-137.77 N`.

Another way to compute the force on the coils is to use `cemforce` from the command line. The `cemforce` function uses the method of virtual displacement based on a given solution in order to calculate the force. This requires that you run COMSOL Multiphysics together with COMSOL Script or MATLAB.

1. From the **File** menu, select **Export>FEM Structure as 'fem'**.
2. Give the following command at the prompt:
\[ F = \text{cemforce}(\text{fem},'Wm_emqa'..'dl',[5 7 8 9 11 12]) \]

This gives the result
\[
F =
\begin{align*}
-137.14 \\
3756.61
\end{align*}
\]

Note that only the force in the \(x\) direction makes sense in this case. The reason is that when moving the coils in the \(y\) direction, the total area of the simulation structure changes, which causes the energy balance to break down. Because the model only includes half of the linear motor, you need to multiply the results by a factor of 2 to obtain the total force density.

**Modeling Using the Programming Language**

```matlab
% Clear the FEM and application structures.
clear fem appl

% Define the FEM structure constants.
fem.const = {
    'sigCu',5.99e7,
    'sigFe',1.03e7,
    'muFe',2e3,
    'Br0',1.23,
    'Jin',3.66e6};

% Create the geometry by first setting all solid objects in a cell % array and then calling geomcsg.
ss = cell(6,1);
ss{1} = rect2(-0.05,0.05,0,0.0105);
ss{2} = rect2(-0.05,0.05,0.0075,0.0105);
dx = 0;
for i1 = 3:8
    ss{i1} = rect2(-0.058+dx,-0.042+dx,0.0035,0.0075);
    dx = dx+0.02;
end
ss{9} = rect2(-0.018,0.022,0,0.0025);
ss{10} = scale(ss{9},2/3,1,0.002,0);
ss{11} = scale(ss{9},1/3,1,0.002,0);
cc{1} = curve2([0.002,0.002],[0 0.0025]);
g1 = solid2(geomcsg(ss,cc));
fem.geom = solid2(g1*ss{1});
fem.sdim = {'x' 'y'};

% Create the application structure.
appl.mode = 'PerpendicularCurrents';
appl.bnd.type = {'AO' 'tH0'};
```
appl.bnd.ind = ones(1,55);
appl.bnd.ind([2 16 22 25 30 36 39 44]) = 2;
appl.equ.sigma = {'0' 'sigFe' 'sigFe' 'sigFe'...
'sigCu' 'sigCu' 'sigCu'};
appl.equ.mur = {'1' 'muFe' '1' '1'...
'1' '1' '1'};
appl.equ.Br = {{'0' '0'} {'0' '0'} {'0' 'Br0'}...
{'0' '-Br0'} {'0' '0'} {'0' '0'}};
appl.equ.magconstrel = {'mur' 'mur' 'Br' 'Br' 'mur' 'mur'};
appl.equ.Jez=('0' '0' '0' '0'...
'Jin' '-Jin' '0'};
appl.equ.ind = [1 3 2 4 5 3 5 7 6 4 6 7 3 4];
appl.prop.elemdefault = 'lag1';

% Generate the PDE coefficients and boundary conditions for the
% FEM structure.
fem.appl = appl;
fem = multiphysics(fem);

% Generate the mesh.
fem.mesh = meshinit(fem);
fem.xmesh = meshextend(fem);

% Solve the problem using the adaptive solver with two
% refinements.
fem = adaption(fem,'ngen',3,'report','on');

% Visualize the solution.
postplot(fem,'contdata','Az','geom','on')

% You can compute the forces in the same way as for the GUI-based
% analysis.
F = cemforce(fem,'Wm','dl',[5 7 8 9 11 12])
Fx = postint(fem,'-Jez*By','dl',[5 7 8 9 11 12])
Generator in 2D

Introduction

This example shows how the circular motion of a rotor with permanent magnets generates an induced EMF in a stator winding. The generated voltage is calculated as a function of time during the rotation. The model also shows the influence on the voltage from material parameters, rotation velocity, and number of turns in the winding.

The center of the rotor consists of annealed medium carbon steel, which is a material with a high relative permeability. The center is surrounded with several blocks of a permanent magnet made of samarium and cobalt, creating a strong magnetic field. The stator is made of the same permeable material as the center of the rotor, confining the field in closed loops through the winding. The winding is wound around the stator poles. Figure 3-2 shows the generator with part of the stator sliced in order to show the winding and the rotor.

Figure 3-2: Drawing of a generator showing how the rotor, stator, and stator winding are constructed. The winding is also connected between the loops, interacting to give the highest possible voltage.

Modeling in COMSOL Multiphysics

The COMSOL Multiphysics model of the generator is a time-dependent 2D problem on a cross section through the generator. This is a true time-dependent model where
CHAPTER 3: MOTORS AND DRIVES MODELS


the motion of the magnetic sources in the rotor is accounted for in the boundary condition between the stator and rotor geometries. Thus, there is no Lorentz term in the equation, resulting in the PDE

\[
\sigma \frac{\partial \mathbf{A}}{\partial t} + \nabla \times \left( \frac{1}{\mu} \nabla \times \mathbf{A} \right) = 0
\]

where the magnetic vector potential only has a \(z\) component.

Rotation is modeled using a deformed mesh application mode (ALE), in which the center part of the geometry, containing the rotor and part of the air-gap, rotates with a rotation transformation relative to the coordinate system of the stator. The rotation of the deformed mesh is defined by the transformation

\[
\begin{bmatrix}
  x_{\text{rot}} \\
  y_{\text{rot}}
\end{bmatrix} = \begin{bmatrix}
  \cos(\omega t) & -\sin(\omega t) \\
  \sin(\omega t) & \cos(\omega t)
\end{bmatrix} \begin{bmatrix}
  x_{\text{stat}} \\
  y_{\text{stat}}
\end{bmatrix}
\]

The rotor and the stator are drawn as two separate geometry objects, so it is possible to use an assembly (see “Using Assemblies” on page 413 of the COMSOL Multiphysics Modeling Guide for further details). This has several advantages: the coupling between the rotor and the stator is done automatically, the parts are meshed independently, and it allows for a discontinuity in the vector potential at the interface between the two geometry objects (called slits). The rotor problem is solved in a rotating coordinate system where the rotor is fixed (the rotor frame), whereas the stator problem is solved in a coordinate system that is fixed with respect to the stator (the stator frame). An identity pair connecting the rotating rotor frame with the fixed stator frame is created between the rotor and the stator. The identity pair enforces continuity for the vector potential in the global fixed coordinate system (the stator frame).

The material in the stator and the center part of the rotor has a nonlinear relation between the magnetic flux, \(\mathbf{B}\) and the magnetic field, \(\mathbf{H}\), the so called B-H curve. In COMSOL Multiphysics, the B-H curve is introduced as an interpolation function; see Figure 3-3. The function can be used in the subdomain settings. Usually B-H curves are specified as \(|\mathbf{B}|\) versus \(|\mathbf{H}|\), but the perpendicular waves application mode must have \(|\mathbf{H}|\) versus \(|\mathbf{B}|\). It is therefore important that the \(H\)-data is entered as \(fx\)-data of the interpolation function and the \(B\)-data entered as \(x\)-data. This relationship for \(|\mathbf{H}|\) is
predefined for the material **Soft Iron (without losses)** in the materials library that is shipped with the AC/DC Module, *acdc_lib.txt*.

The generated voltage is computed as the line integral of the electric field, \( \mathbf{E} \), along the winding. Because the winding sections are not connected in the 2D geometry, a proper line integral cannot be carried out. A simple approximation is to neglect the voltage contributions from the ends of the rotor, where the winding sections connect. The voltage is then obtained by taking the average \( z \) component of the \( \mathbf{E} \) field for each winding cross-section, multiplying it by the axial length of the rotor, and taking the sum over all winding cross sections.

\[
V_z = NN \sum_{\text{windings}} \frac{L}{A} \int \mathbf{E} \cdot d\mathbf{A}
\]

where \( L \) is the length of the generator in the third dimension, \( NN \) is the number of turns in the winding, and \( A \) is the total area of the winding cross-section.
Results and Discussion

The generated voltage in the rotor winding is a sinusoidal signal. At a rotation speed of 60 rpm the voltage will have an amplitude around 2.3 V for a single turn winding; see Figure 3-4.

Figure 3-4: The generated voltage over one quarter of a revolution. This simulation used a single-turn winding.
The norm of the magnetic flux, $|\mathbf{B}|$, and the field lines of the $\mathbf{B}$ field are shown below in Figure 3-5 at time 0.20 s.

**Figure 3-5:** The norm and the field lines of the magnetic flux after 0.2 s of rotation. Note the brighter regions, which indicate the position of the permanent magnets in the rotor.

**Model Library path:** ACDC_Module/Motors_and_Drives/generator_2d

**Modeling Using the Graphical User Interface**

**MODEL NAVIGATOR**
1. In the Model Navigator, make sure that 2D is selected in the Space dimension list.
2. In the AC/DC Module folder, select Rotating Machinery>Rotating Perpendicular Currents.
3. Click OK to close the Model Navigator.

**OPTIONS AND SETTINGS**
1. From the Options menu, choose Constants.
In the Constants dialog box, define the following constants with names and expressions. The description field is optional. When done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>t</td>
<td>0[s]</td>
<td>Time for stationary solution</td>
</tr>
<tr>
<td>rpm</td>
<td>60[1/min]</td>
<td>Revolutions per minute</td>
</tr>
<tr>
<td>A</td>
<td>(\pi*(0.02[m])^2)</td>
<td>Area of wires in the stator</td>
</tr>
<tr>
<td>L</td>
<td>0.4[m]</td>
<td>Length of the generator</td>
</tr>
<tr>
<td>NN</td>
<td>1</td>
<td>Number of turns in stator winding</td>
</tr>
</tbody>
</table>

When you enter the constant \(t\) in the table, the text turns red. The reason is that \(t\) is the reserved variable name for time in COMSOL Multiphysics. However, because of the solution procedure in this model—you first compute a stationary solution which you then use as the initial condition for a subsequent time-dependent simulation—\(t\) needs to be given a value (zero) also for the stationary case. It will subsequently be overridden by the \(t\) values from the transient solver.

**GEOMETRY MODELING**

The geometry modeling of this model is rather extensive, so you can choose to import the generator geometry from a binary file. Select the section that you prefer.

*Importing the Geometry from a Binary File*

1. From the File menu, select **Import>CAD Data From File**.
2. In the **Import CAD Data From File** dialog box, make sure that either **All 2D CAD files** or **COMSOL Multiphysics file** is selected in the **Files of type** list.
3. From the COMSOL Multiphysics installation directory, go to the model library path given on page 47. Select the **generator_2d.mphbin** file, and click **Import**.
4. Skip the section “Creating the Geometry from Scratch” and continue at “Assemble the Geometry” on page 51.

*Creating the Geometry from Scratch*

Please follow the steps in the geometry modeling carefully. The instructions in the following sections assume that the boundary numbering is that resulting from these steps. After all geometry operations and the assembly step, there should be a total of 152 boundaries.
1. Choose **Draw>Specify Objects>Circle** to create circles with the following properties:

<table>
<thead>
<tr>
<th>NAME</th>
<th>RADIUS</th>
<th>BASE</th>
<th>X</th>
<th>Y</th>
<th>ROTATION ANGLE</th>
</tr>
</thead>
<tbody>
<tr>
<td>C1</td>
<td>0.3</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>22.5</td>
</tr>
<tr>
<td>C2</td>
<td>0.235</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>C3</td>
<td>0.225</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>C4</td>
<td>0.4</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

2. Choose **Draw>Specify Objects>Rectangle** to create rectangles with the following properties:

<table>
<thead>
<tr>
<th>NAME</th>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>BASE</th>
<th>X</th>
<th>Y</th>
<th>ROTATION ANGLE</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>0.1</td>
<td>1</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>R2</td>
<td>0.1</td>
<td>1</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>45</td>
</tr>
<tr>
<td>R3</td>
<td>0.1</td>
<td>1</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>90</td>
</tr>
<tr>
<td>R4</td>
<td>0.1</td>
<td>1</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>135</td>
</tr>
</tbody>
</table>

3. Open the **Create Composite Object** dialog box from the **Draw** menu or click on the toolbar button with the same name.

4. In the dialog box clear the **Keep interior boundaries** check box.

5. Type \( C2+C1^+ (R1+R2+R3+R4) \) in the **Set formula** edit field.

6. Click **OK**.

7. Open the **Create Composite Object** dialog box again and select the **Keep interior boundaries** check box.

8. Type \( C4+C01-C03 \) in the **Set formula** edit field.

9. Click **OK**.

10. Create two new circles according to the table below.

<table>
<thead>
<tr>
<th>NAME</th>
<th>RADIUS</th>
<th>BASE</th>
<th>X</th>
<th>Y</th>
<th>ROTATION ANGLE</th>
</tr>
</thead>
<tbody>
<tr>
<td>C1</td>
<td>0.015</td>
<td>Center</td>
<td>0.025</td>
<td>0.275</td>
<td>0</td>
</tr>
<tr>
<td>C2</td>
<td>0.015</td>
<td>Center</td>
<td>-0.025</td>
<td>0.275</td>
<td>0</td>
</tr>
</tbody>
</table>

11. Click the **Zoom Extents** button to get a better view of the geometry.

12. Select the circles C1 and C2.

13. Press Ctrl+C to copy the circles.

14. Press Ctrl+V to paste the circles. Make sure that the displacements are zero and click **OK**.
Go to **Draw>Modify>Rotate** and type 45 in the **Rotation angle** edit field before clicking **OK**.

Repeat the last two steps but with rotation angles 90, 135, 180, −45, −90, and −135.

Select all objects by pressing Ctrl+A, then click the **Union** toolbar button.

Create four circles with the following properties:

<table>
<thead>
<tr>
<th>NAME</th>
<th>RADIUS</th>
<th>BASE</th>
<th>X</th>
<th>Y</th>
<th>ROTATION ANGLE</th>
</tr>
</thead>
<tbody>
<tr>
<td>C1</td>
<td>0.215</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>C2</td>
<td>0.15</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>22.5</td>
</tr>
<tr>
<td>C3</td>
<td>0.15</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>22.5</td>
</tr>
<tr>
<td>C4</td>
<td>0.225</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

Create four rectangles with the following properties:

<table>
<thead>
<tr>
<th>NAME</th>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>BASE</th>
<th>X</th>
<th>Y</th>
<th>ROTATION ANGLE</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>0.1</td>
<td>1</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>22.5</td>
</tr>
<tr>
<td>R2</td>
<td>0.1</td>
<td>1</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>-22.5</td>
</tr>
<tr>
<td>R3</td>
<td>0.1</td>
<td>1</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>67.5</td>
</tr>
<tr>
<td>R4</td>
<td>0.1</td>
<td>1</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>-67.5</td>
</tr>
</tbody>
</table>

Open the **Create Composite Object** dialog box and clear the **Keep interior boundaries** check box.

Type \( C2+C1 \times (R1+R2+R3+R4) \) in the **Set formula** edit field.

Click **OK**.

Open the **Create Composite Object** dialog box again and select the **Keep interior boundaries** check box.

Type \( CO2+C3+C4 \) in the **Set formula** edit field.

Click **OK**.
Assemble the Geometry

1. Open the Create Pairs dialog box from the Draw menu.
2. Select both objects (CO1 and CO3), and click OK.

You have now created two separate geometry objects in an assembly. You have also created an identity pair connecting the physics in the rotor and the stator, taking the rotation into account. An interface between two assemblies is actually two groups of overlapping boundaries that are, without the pair connection, completely separated in terms of mesh and solution variables. This is necessary to allow a sliding mesh at the interface between the stator and rotor where the solution variable becomes discontinuous across that interface.

Physics Settings

1. From the Options menu point to Integration Coupling Variables and click Subdomain Variables.
In the Subdomain Integration Variables dialog box define a variable with integration order 4 and global destination according to the following table:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION IN SUBDOMAINS 5–8, 13–16</th>
<th>EXPRESSION IN SUBDOMAINS 3, 4, 9–12, 17, 18</th>
</tr>
</thead>
<tbody>
<tr>
<td>( V_i )</td>
<td>(-L*E_z_{\text{emqa}}/A)</td>
<td>(L*E_z_{\text{emqa}}/A)</td>
</tr>
</tbody>
</table>

3 Click OK.

Steps 4–6 below are only necessary to check that the library you need is loaded and to view the interpolation function of one of the materials in this library. These steps can be skipped if you know that you have the library loaded. If you later notice that you are missing this library, just go back to these steps and add the library.

4 Open the Options menu and select Materials/Coefficients Library.

5 Make sure that the library `acdc_lib.txt` is loaded (click the minus in front of other libraries to remove their content from the view). If you cannot find the library, load the library by clicking the Add Library button. The file should be located under the data folder in the COMSOL installation directory.

6 Click OK to close the Materials/Coefficients Library dialog box.

Subdomain Settings

1 From the Multiphysics menu, select Perpendicular Induction Currents, Vector Potential (emqa) if it is not already selected.

2 Choose Physics>Properties.

3 In the Application Mode Properties dialog box, choose On from the Weak constraints list. The ideal weak constraints help conserving the magnetic flux across the assembly boundaries between the rotor and the stator. This allows you to specify an absolute tolerance for this entity when solving the time-dependent model.

4 Click OK.

5 From the Physics menu open the Subdomain Settings, then select any entry in the Subdomain selection list.

6 Click the Load button to open the Materials/Coefficients Library dialog box.

7 In the dialog box select the Soft Iron (without losses) material from the Electric (AC/DC) Material Properties library.

8 Click Apply. The material Soft Iron (without losses) has now been added to the model. You see which materials you have added to the model under the Model item in the Materials tree view.
9 Repeat the last two steps for the materials **Samarium Cobalt (Radial, inward)** and **Samarium Cobalt (Radial, outward)**. Before you close the dialog box, make sure that you see all three materials under **Model** in the **Materials** tree view.

10 Click **Cancel** to close the **Materials/Coefficients Library** dialog box.

11 Enter subdomain settings and select materials according to the table below. To change the constitutive relation, you need to choose the relation from the **Constitutive relation** list.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAINS 20, 23, 24, 27</th>
<th>SUBDOMAINS 21, 22, 25, 26</th>
<th>SUBDOMAINS 2, 28</th>
<th>ALL OTHER SUBDOMAINS</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>B ↔ H</strong></td>
<td><strong>B</strong> = μ₀μ₅₅H + <strong>B</strong>ₚ</td>
<td><strong>B</strong> = μ₀μ₅₅H + <strong>B</strong>ₚ</td>
<td><strong>H</strong> = f(</td>
<td>B</td>
</tr>
<tr>
<td>Library material</td>
<td>Samarium Cobalt (Radial, inward)</td>
<td>Samarium Cobalt (Radial, outward)</td>
<td>Soft Iron (without losses)</td>
<td></td>
</tr>
</tbody>
</table>

12 Click **OK**.

13 From the **Multiphysics** menu select **Moving Mesh (ALE) (ale)**.

14 From the **Physics** menu open the **Subdomain Settings**.

15 Select Subdomains 19–28, then select the predefined group **rotate_CCW** from the **Group** list.

![Subdomain Settings - Moving Mesh (ALE) (ale)](image)

This group uses a prescribed displacement with expressions that define counterclockwise rotation around the origin. The default setting for all other subdomains is no displacement.

16 Click **OK** to close the dialog box.

**Boundary Conditions**

Leave the boundary settings at their defaults. The identity pair creates a coupling between the rotor and the stator in the ALE frame.
**Mesh Generation**

1. From the **Mesh** menu, open the **Free Mesh Parameters** dialog box.
2. From the **Predefined mesh sizes** list, select **Finer**.
3. Click the **Custom mesh size** option button and type 2 in the **Resolution of narrow regions** edit field.
4. Click **Remesh** to generate the mesh.
5. Click **OK** to close the dialog box.

**Computing the Solution**

Begin by computing the initial solution for the subsequent time-dependent simulation.

1. Open the **Solver Parameters** dialog box by clicking the corresponding button on the **Main toolbar** or from the **Solve** menu.
2. With the **Auto select solver** check box selected, select **Static** from the **Analysis** list.
3. Click **OK**.
4. Click the **Solve** button.

Next, simulate the generator with the rotor in motion. By default, the solution you just calculated will be used as the initial solution.

1. Open the **Solver Parameters** dialog box again and select **Transient** from the **Analysis** list.
2 In the **Times** edit field type `linspace(0,0.25,26)`, and in the **Absolute tolerance** edit field type `Az 1e-3 lm1 5e3`.

3 Click **OK**.

4 Click the **Restart** button.

**POSTPROCESSING AND VISUALIZATION**

1 From the **Postprocessing** menu, open the **Plot Parameters** dialog box.

2 On the **General** page, select the solution for time 0.2 s from the **Solution at time** list. Clear the **Geometry edges** check box.

3 On the **Surface** page select **Magnetic flux density, norm** from the **Predefined quantities** list or type `normB_emqa` in the **Expression** edit field.

4 On the **Contour** page type `Az` in the **Expression** edit field and type 15 in the **Levels** edit field. Click to select the **Contour plot** check box.

5 In the **Contour color** area click the **Uniform color** option button, and clear the **Color scale** check box.

6 Click the **Color** button and select a black color. Click **OK** to close the **Contour Color** dialog box.
7 On the **Boundary** page type 1 in the **Expression** edit field. Click to select the **Boundary plot** check box.

8 In the **Boundary color** area click the **Uniform color** option button.

9 Click the **Color** button and select a black color. Click **OK** to close the **Boundary Color** dialog box.

10 Click **OK** to close the **Plot Parameters** dialog box.

To view the induced voltage as a function of time, proceed with the steps below.

1 From the **Postprocessing** menu, select **Domain Plot Parameters**.

2 On the **Point** page select an arbitrary point in the **Point selection** list, then type \( V_i \times N \) in the **Expression** edit field.

3 Click **OK**.

To create an animation of the rotating rotor, do the following steps.

1 Open the **Plot Parameters** dialog box.

2 Click the **Animate** tab and make sure that all time steps are selected.

3 Click the **Start Animation** button. When the movie has been generated, the **COMSOL Movie Player** opens it.
Generator with Mechanical Dynamics and Symmetry

Introduction
This is an extension of the generator model including an ordinary differential equation for the mechanical dynamics and computation of the torque resulting from the magnetic forces. In addition it exploits symmetry to reduce the model size to 1/8 of the original size. The model also involves a lumped winding resistance.

Modeling in COMSOL Multiphysics
To continue with this model, you need to be familiar with the generator model in the preceding section. Here the focus is on concepts that the previous model does not cover. The smallest possible model of the generator is a sector obtained by cutting radially through two adjacent rotor poles (see Figure 3-7).

![Figure 3-7: The smallest possible sector model.](image-url)
Because adjacent rotor poles are magnetized radially but in opposite directions, such a sector model exhibits antisymmetry. This is readily accounted for in COMSOL Multiphysics by the support for periodic boundary conditions. In addition, the sliding mesh coupling must be modified to keep the coupling coordinates within the modeled geometry sector. There is a special sliding mesh condition for such symmetry or antisymmetry connections that defines one coupling operator for each sector in the model. In this case there are 8 such coupling operators. The first operator just performs a direct coupling between the rotor and stator. After a little less than half revolution for example, the third and fourth operator perform the coupling. This special sector symmetry condition requires that you use assemblies with the Moving Mesh application mode, similar to how it is done in the preceding generator model. The main difference with that model, is that you will use the fact that the magnetic fields do not change between the reference and moving frame, and that the mesh in the moving domains are not deformed, only rotated. As a consequence, you can turn off the moving mesh transformations for the electromagnetic application mode and use them only for the coupling operators. You save a significant amount of execution time by not performing the mesh transformations, and the result is the same.

The ODE for the mechanical dynamics

\[
\frac{d^2 \theta}{dt^2} = \frac{T_z + M}{I_0 + I_{\text{rotor}}}
\]

involves the torque \( T_z + M \) and the moment of inertia \( I_0 + I_{\text{rotor}} \). \( M \) is the externally applied driving torque and \( T_z \) is the electromagnetic torque. \( \theta \) is the rotation angle. The model computes the latter automatically by boundary integration of the cross product between the radius vector \((x, y)\) and the normal Maxwell stress components \( (nT_x, nT_y) \) over the rotor boundary. Because the model depth is not unity, the torque variable must be multiplied with the variable \( L \), and a factor \( 8 \) to account for the entire device.

\[
T_z = 8LT_z^{\text{(auto)}}
\]

The moment of inertia is composed of an external moment of inertia, \( I_0 \) (flywheel and turbine), and the moment of inertia of the rotor itself, \( I_{\text{rotor}} \). The model computes the latter by subdomain integration of the material density \( \rho \) times radius vector squared times the model depth \( L \). Again, the factor \( 8 \) accounts for the entire generator.
The model accounts for the lumped winding resistance by setting the winding current to the induced voltage divided by the winding resistance. This corresponds to a generator operating with the output terminals in short circuit. The model computes the induced voltage using a subdomain integration coupling variable.

**Results and Discussion**

The startup of the generator was simulated for 2 s which is sufficient for reaching steady state. The time evolution of the rotation angle is shown in Figure 3-8.

\[
I_{\text{rotor}} = \int_A 8\rho L(x^2 + y^2) dA
\]

*Figure 3-8: The time evolution of the rotation angle is shown. After about 1 s, the rotation angle increases linearly with time corresponding to constant rotation speed.*

**Model Library path:** ACDC_Module/Motors_and_Drives/generator_sector_dynamic
MODEL NAVIGATOR
1 In the Model Navigator, make sure that 2D is selected in the Space dimension list.
2 In the AC/DC Module folder select Rotating Machinery>Rotating Perpendicular Currents.
3 In the Dependent variables edit field, enter Az X Y Z.
4 Click OK to close the Model Navigator.

OPTIONS AND SETTINGS
1 From the Options menu choose Constants.
2 In the Constants dialog box define the following constants with names and expressions. When done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>pi*(0.02[m])^2</td>
<td>Area of wires in the stator</td>
</tr>
<tr>
<td>L</td>
<td>0.4[m]</td>
<td>Length of the generator</td>
</tr>
<tr>
<td>NN</td>
<td>1</td>
<td>Number of turns in stator winding</td>
</tr>
<tr>
<td>M</td>
<td>1400[N*m]</td>
<td>Externally applied torque</td>
</tr>
<tr>
<td>Rc</td>
<td>1e-4[ohm]</td>
<td>Resistance of winding</td>
</tr>
<tr>
<td>Io</td>
<td>100[kg*m^2]</td>
<td>External moment of inertia</td>
</tr>
</tbody>
</table>

GEOMETRY MODELING
1 From the File menu, select Import>CAD Data From File.
2 In the Import CAD Data From File dialog box, make sure that All 2D CAD files or COMSOL Multiphysics file is selected in the Files of type drop-down menu.
3 From the COMSOL Multiphysics installation directory, browse to the folder given on page 59. Select the file generator_2d.mphbin, then click Import.
4 Choose Draw>Specify Objects>Line and select Closed polyline (solid) in the Style list. Enter Coordinates x: 0 0.4*cos(67.5*pi/180) 0.4 0.4*cos(22.5*pi/180) 0 and Coordinates y: 0 0.4*sin(67.5*pi/180) 0.4 0.4*sin(22.5*pi/180) 0.
5 Click OK to create the composite object CO3.
6 Press Ctrl+C to copy the created object.
7 Select the objects (CO1 and CO3), then click the Intersection button on the Draw toolbar to create the geometry object, CO4.
8 Press Ctrl+V to paste the polyline object, just click **OK** in the dialog box that appears. Then select the pasted object and the second imported object (CO1 and CO2).

9 Click the **Intersection** button on the Draw toolbar.

10 Click the **Zoom Extents** button on the Main toolbar. You now have a 1/8 sector of the original generator model geometry, with one object for the rotor and one for the stator.

11 Select both remaining objects and click the **Create Pairs** button on the Draw toolbar.

12 From the **Physics** menu, choose **Identity Pairs>Identity Boundary Pairs**.

13 Select Pair 1 and click the **Interchange source and destination** button between the **Source boundaries** and **Destination boundaries** fields.

14 Click **OK**. It is important that the source side of the assembly pair is on the fixed side, and that the destination side is on the moving side. Otherwise the solver does not detect the motion.

**PHYSICS SETTINGS**

*Global Expressions*

1 From the **Options** menu, point to **Expressions** and click **Global Expressions**.

2 In the **Global Expressions** dialog box, define the following expression:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tz</td>
<td>8*L[1/m]*F_torquez_emqa</td>
<td>Total torque for the entire device</td>
</tr>
</tbody>
</table>

3 Click **OK**. The unit specification in the expression is there to keep the correct unit of the torque.

*Subdomain Expressions*

1 From the **Options** menu, point to **Expressions** and click **Subdomain Expressions**.

2 In the **Subdomain Expressions** dialog box, define the following expressions:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION IN SUBDOMAINS 1–4</th>
<th>EXPRESSION IN ALL OTHER SUBDOMAINS</th>
</tr>
</thead>
<tbody>
<tr>
<td>u</td>
<td>-y*omegat</td>
<td>0</td>
</tr>
<tr>
<td>v</td>
<td>x*omegat</td>
<td>0</td>
</tr>
</tbody>
</table>

3 Add another variable \( \rho \) for the material density and set it to 7870\[\text{kg/m}^3\] in Subdomain 1 and to 8400\[\text{kg/m}^3\] in Subdomains 2 and 4.

4 Click **OK**.
Integration Coupling Variables

1. In the Options menu, point to Integration Coupling Variables and select Subdomain Variables.

2. In the Subdomain Integration Variables dialog box, define variables according to the table below with default global destination and default integration order 4.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION IN SUBDOMAINS 1, 2, 4</th>
<th>EXPRESSION IN SUBDOMAINS 7, 8</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vi</td>
<td>8<em>L</em>NN*Ez_emqa/A</td>
<td></td>
</tr>
<tr>
<td>I</td>
<td>8<em>L</em>rho*(x^2+y^2)</td>
<td>8<em>L</em>NN*Ez_emqa/A</td>
</tr>
</tbody>
</table>

3. Click OK.

Because of the use of coupling variables, COMSOL Multiphysics cannot determine the unit for other variables that directly or indirectly depend on these coupling variables. This causes the warnings for inconsistent units in the specification of the magnetic potential and external current density. You can disregard these warnings.

Subdomain Settings (Moving Mesh Application Mode)

1. From the Physics menu, open the Subdomain Settings dialog box.

2. Select Subdomains 1–4. From the Group list, select the predefined group called angle_CCW. This group uses the variable named omega as a counterclockwise rotation. You later declare this variable as an ODE variable.

3. Click OK to close the dialog box.

Application Mode Properties (Perpendicular Induction Currents)

1. From the Multiphysics menu, select Perpendicular Induction Currents, Vector Potential (emqa) to switch application mode.

2. From the Physics menu, choose Properties.

3. Choose On from the Weak constraints list and Frame (ref) from the Frame list.

4. Click OK.

Subdomain Settings

1. Open the Subdomain Settings dialog box from the Physics menu.

2. Select any entry from the Subdomain selection list, then click the Load button to open the Materials/Coefficients Library dialog box.

4. Click **Apply**. The material **Soft Iron (without losses)** is added to the model. You see which materials you have added to the model under the **Model** item in the **Materials** tree view.

5. Repeat the two last steps for the materials **Samarium Cobalt (Radial, inward)** and **Samarium Cobalt (Radial, outward)**. Before you close the dialog box, make sure that you see all three materials under **Model** in the **Materials** tree view.

6. Click **Cancel** to close the **Materials/Coefficients Library** dialog box.

7. Enter subdomain settings and select materials according to the table below. To change the constitutive relation, you need to choose the relation from the **Constitutive relation** list.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN 4</th>
<th>SUBDOMAIN 2</th>
<th>SUBDOMAIN 1, 6</th>
<th>ALL OTHERS</th>
</tr>
</thead>
<tbody>
<tr>
<td>B ↔ H</td>
<td>B = μ₀μᵣH + Bᵣ</td>
<td>B = μ₀μᵣH + Bᵣ</td>
<td>H = f(</td>
<td>B</td>
</tr>
<tr>
<td>Library material</td>
<td>Samarium Cobalt (Radial, inward)</td>
<td>Samarium Cobalt (Radial, outward)</td>
<td>Soft Iron (without losses)</td>
<td></td>
</tr>
</tbody>
</table>

8. Select Subdomains 7 and 8, and enter \( N N^*V_1/(R_ε^*A) \) in the **External current density** edit field.

9. Click the **Forces** tab. Select Subdomains 1, 2, and 4 from the **Subdomain selection** list, then set the **Name** field to \( F \). This setting generates variables for the force and torque on the selected subdomains. The torque variable gets the name \( F_{torque\_emqa} \).

10. Click **OK**.

**Boundary Conditions**

1. In the **Boundary Settings** dialog box, enter the following settings:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 1–4, 7, 8, 15, 16, 19, 20</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Periodic condition</td>
</tr>
<tr>
<td>Type of periodicity</td>
<td>Antiperiodicity</td>
</tr>
</tbody>
</table>

2. Click the **Weak Constr.** tab, select the Boundaries 1–4, 7, 8, 15, 16, 19–21 and 23, and clear the **Use weak constraints** check box. It is not necessary to use weak constraint on these boundaries, and they disturb the weak constraints on the sliding mesh boundaries if activated.

3. Click the **Pairs** tab and select Pair 1.

4. From the **Boundary condition** list, select **Sector antisymmetry**, then enter 8 in the **Number of sectors** edit field.
5 Click OK.

Periodic Point Conditions
You need to make the Lagrange multiplier variable lm1, associated with the weak boundary constraint, antisymmetric.

1 Choose Physics>Periodic Conditions>Periodic Point Conditions.
2 On the Source page, select Point 4 from the Point selection list, then enter lm1 in the first row in the Expression column and press Return.
3 Click the Source Vertices tab, and click the >> button to use Point 4 as source vertex.
4 Click the Destination tab, then select Point 11.
5 Select the Use selected points as destination check box, then enter the expression -lm1.
6 Click the Destination Vertices tab, then click the >> button to add Point 11.
7 Click OK.

Global Equations
1 From the Physics menu, open the Global Equations dialog box.
2 Define an equation according to the following table (the description is optional):

<table>
<thead>
<tr>
<th>NAME</th>
<th>EQUATION</th>
<th>INIT(U)</th>
<th>INIT(UT)</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>omega</td>
<td>(\omega-(m+Tz)/(I+I0))</td>
<td>0</td>
<td>0</td>
<td>Rotation angle</td>
</tr>
</tbody>
</table>

3 Click OK.

Mesh Generation
You get the best performance for periodic boundary conditions if the mesh is identical for the source and destination boundaries of the periodic condition. The steps below use the Copy mesh feature to ensure an identical mesh.

1 In the Free Mesh Parameters dialog box, select the Predefined mesh sizes option button, then select Finer from the list.
2 On the Boundary page, select Boundaries 2, 5–8, 10–12, 14, and 19–21 from the Boundary selection list and enter a Maximum element size of 0.005.
3 Click the Mesh Selected button.
4 Select Boundaries 1 and 2. The click the Copy Mesh button on the Mesh toolbar, which is located on the toolbar on the left side of the COMSOL Multiphysics window.
5 Repeat this step for the remaining four boundary pairs: 3 and 7, 4 and 8, 15 and 19, and 16 and 20. The mesh on the right side and the mesh on the left side are now identical.

6 Click **OK** to close the **Free Mesh Parameters** dialog box. This was only open under the copy mesh operation in order to have a numbered list of boundaries available.

7 Finally, click the **Mesh Remaining (Free)** button on the Mesh toolbar, to mesh the rest of the geometry. The resulting mesh looks like the one in the figure below.

**Computing the Solution**

1 In the **Solver Parameters** dialog box, select **Stationary** from the **Solver** area.

2 Click **OK**.

3 Open the **Solver Manager** and go to the **Solve For** page.

4 Clear the variable **omega** under **ODE**.

5 Click **OK**.

6 Click the **Solve** button on the Main toolbar.

7 Open the **Solver Parameters** dialog box again, and select **Time dependent** from the **Solver** list.
8 In the Times edit field type linspace(0,2,101), and in the Absolute tolerance edit field type Az 1e-3 1m1 5e3 omega 0.015. This sets different tolerances for each variable.

9 Click OK.

10 Open the Solver Manager, click the Solve For tab, and select all variables.

11 Click OK.

12 Click the Restart button on the Main toolbar.

POSTPROCESSING AND VISUALIZATION

1 Open the Plot Parameters dialog box. From the Solution at time list on the General page, select the solution for time 0.2 s.

2 On the Contour page, select Magnetic potential, z component from the Predefined quantities list and type 15 in the Levels edit field. Select the Contour plot check box.

3 In the Contour color area, click the Uniform color button. Click the Color button. Select a black color, then click OK to close the Contour Color dialog box. Clear the Color scale check box.

4 Click OK to close the Plot Parameters dialog box.
You should now see the following surface plot of the norm of the magnetic flux with contours indicating magnetic flux field lines.

![Surface plot of magnetic flux norm and field lines](image)

**Figure 3-9:** Magnetic flux norm (surface) and field lines (contours) at $t=0.2\text{ s}$.

To view the rotation angle as a function of time, proceed with the steps below.

1. From the **Postprocessing** menu, select **Global Variables Plot**.
2. In the **Predefined quantities** area, choose **Rotation angle**, then click the **>** button.
3. Click **Apply** to generate Figure 3-8 on page 59.

Using the same dialog box, create plots for $\omega_t$, $\tau_z$, $(M+\tau_z)/(I+I_0)$, and $V_i/R_c$ to plot angular velocity, electromagnetic torque, acceleration, and winding current, respectively, by repeating the steps given below for the angular velocity.

1. Select the item in the **Quantities to plot** frame and click the **<** button to remove it from the list.
2. In the **Expression** edit field enter $\omega_t$.
3. Click the **>** button to the right of the edit field.
4. Click **Apply** to view the plot.

To create an animation of the rotating rotor, perform the following steps:
1. Open the **Plot Parameters** dialog box, click the **Animate** tab, and make sure that all time steps are selected.

2. Click the **Start Animation** button. When the movie has been generated, the COMSOL Movie Player opens it.
Generator in 3D

Introduction

This model is a 3D version of the 2D generator model on page 43, so most of the details about the model are explained there. The main difference is that this is a static example, calculating the magnetic fields around and inside the generator.

Modeling in COMSOL Multiphysics

The model has some differences compared to the 2D generator model. The PDE is simplified to solve for the magnetic scalar potential, \( V_m \), instead of the vector potential, \( A \). It is based on the assumption that currents can be neglected, which holds true when the generator terminals are open. The equation for \( V_m \) becomes

\[
-\nabla \cdot (\mu \nabla V_m - \mathbf{B}_r) = 0
\]

The stator and center of the rotor are made of annealed medium-carbon steel (soft iron), which is a nonlinear magnetic material. This is implemented in COMSOL Multiphysics as an interpolation function of the B-H curve of the material. The difference compared to the 2D version is that the norm of the magnet flux, \( |\mathbf{B}| \), has to be calculated from the norm of the magnetic field, \( |\mathbf{H}| \), in this model.

Results and Discussion

Figure 3-10 shows the norm of the magnetic flux for a slice through a centered cross section of the generator. The plot also shows the streamlines of the magnetic flux. The starting points of the streamlines have been carefully selected to show the closed loops...
between neighboring stator and rotor poles. A few streamlines are also plotted at the edge of the generator to illustrate the field there.

Figure 3-10: A combined slice and streamline plot of the magnetic flux density.

Model Library path: ACDC_Module/Motors_and_Drives/generator_3d

Modeling Using the Graphical User Interface

MODEL NAVIGATOR
1. Select 3D in the Space dimension list.
2. In the AC/DC Module folder, select Statics, Magnetic>Magnetostatics, No Currents.
3. Click OK to close the Model Navigator.

GEOMETRY MODELING
2. In the dialog box that appears, click OK.
3 Choose **Draw>Specify Objects>Circle** twice to create circles with the following properties:

<table>
<thead>
<tr>
<th>NAME</th>
<th>RADIUS</th>
<th>BASE</th>
<th>X</th>
<th>Y</th>
<th>ROTATION ANGLE</th>
</tr>
</thead>
<tbody>
<tr>
<td>C1</td>
<td>0.3</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>22.5</td>
</tr>
<tr>
<td>C2</td>
<td>0.235</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

4 Choose **Draw>Specify Objects>Rectangle** four times to create rectangles with the following properties:

<table>
<thead>
<tr>
<th>NAME</th>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>BASE</th>
<th>X</th>
<th>Y</th>
<th>ROTATION ANGLE</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>0.1</td>
<td>1</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>R2</td>
<td>0.1</td>
<td>1</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>45</td>
</tr>
<tr>
<td>R3</td>
<td>0.1</td>
<td>1</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>90</td>
</tr>
<tr>
<td>R4</td>
<td>0.1</td>
<td>1</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>135</td>
</tr>
</tbody>
</table>

5 In the **Create Composite Object** dialog box, clear the **Keep interior boundaries** check box.

6 Enter the formula \( C2+C1 \times (R1+R2+R3+R4) \).

7 Click **OK**.

8 Create a circle with the following properties:

<table>
<thead>
<tr>
<th>NAME</th>
<th>RADIUS</th>
<th>BASE</th>
<th>X</th>
<th>Y</th>
<th>ROTATION ANGLE</th>
</tr>
</thead>
<tbody>
<tr>
<td>C1</td>
<td>0.215</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

9 Draw four rectangles with the following properties:

<table>
<thead>
<tr>
<th>NAME</th>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>BASE</th>
<th>X</th>
<th>Y</th>
<th>ROTATION ANGLE</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>0.1</td>
<td>1</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>22.5</td>
</tr>
<tr>
<td>R2</td>
<td>0.1</td>
<td>1</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>-22.5</td>
</tr>
<tr>
<td>R3</td>
<td>0.1</td>
<td>1</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>67.5</td>
</tr>
<tr>
<td>R4</td>
<td>0.1</td>
<td>1</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>-67.5</td>
</tr>
</tbody>
</table>

10 In the **Create Composite Object** dialog box, enter the formula \( C1 \times (R1+R2+R3+R4) \).

11 Click **OK**.

12 Create a circle with the following properties:

<table>
<thead>
<tr>
<th>NAME</th>
<th>RADIUS</th>
<th>BASE</th>
<th>X</th>
<th>Y</th>
<th>ROTATION ANGLE</th>
</tr>
</thead>
<tbody>
<tr>
<td>C1</td>
<td>0.15</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>22.5</td>
</tr>
</tbody>
</table>
13 In the Create Composite Object dialog box, make sure that the Keep interior boundaries check box is not selected.

14 Enter the formula C1+C02.

15 Click OK.

16 Draw a circle with parameters according to the table below.

<table>
<thead>
<tr>
<th>NAME</th>
<th>RADIUS</th>
<th>BASE</th>
<th>X</th>
<th>Y</th>
<th>ROTATION ANGLE</th>
</tr>
</thead>
<tbody>
<tr>
<td>C1</td>
<td>0.15</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>22.5</td>
</tr>
</tbody>
</table>

17 Click the Zoom Extents button to get a better view of the geometry.

18 Choose Draw>Extrude.

19 In the dialog box that appears, select all objects and type 0.4 in the Distance edit field.

20 Click OK.

21 Use the Cylinder tool to create cylinders with parameters according to the table below.

<table>
<thead>
<tr>
<th>NAME</th>
<th>AXIS BASE POINT Z</th>
<th>RADIUS</th>
<th>HEIGHT</th>
</tr>
</thead>
<tbody>
<tr>
<td>CYL1</td>
<td>-0.2</td>
<td>0.4</td>
<td>0.2</td>
</tr>
<tr>
<td>CYL2</td>
<td>0</td>
<td>0.4</td>
<td>0.4</td>
</tr>
<tr>
<td>CYL3</td>
<td>0.4</td>
<td>0.4</td>
<td>0.2</td>
</tr>
</tbody>
</table>
2. Click the **Zoom Extents** button to get a better view of the geometry.

### PHYSICS SETTINGS

#### Constants

1. From the **Options** menu, select **Constants**.
2. In the **Constants** dialog box, define the following constants with names, expressions, and (optionally) descriptions; when done, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>BrSmCo</td>
<td>0.84[T]</td>
<td>Remanent flux in permanent magnets</td>
</tr>
<tr>
<td>murSmCo</td>
<td>1</td>
<td>Relative permeability in permanent magnets</td>
</tr>
</tbody>
</table>

#### Scalar Expressions

1. From the **Options** menu, select **Expressions>Scalar Expressions**.
2. In the **Scalar Expressions** dialog box, define the following expression; when done, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>R</td>
<td>sqrt(x^2+y^2)</td>
<td>Radial coordinate</td>
</tr>
</tbody>
</table>
**Subdomain Settings**

1. Enter subdomain settings for the active subdomains according to the table below.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAINS 1, 3, 4</th>
<th>SUBDOMAINS 5, 9, 10, 13</th>
<th>SUBDOMAINS 6, 8, 11, 12</th>
<th>SUBDOMAINS 2, 7</th>
</tr>
</thead>
<tbody>
<tr>
<td>Library material</td>
<td></td>
<td></td>
<td></td>
<td>Soft Iron (without losses)</td>
</tr>
<tr>
<td>$B \leftrightarrow H$</td>
<td>$B = \mu_0 \mu_r H$</td>
<td>$B = \mu_0 \mu_r H + B_r$</td>
<td>$B = \mu_0 \mu_r H + B_r$</td>
<td>$B = f(</td>
</tr>
<tr>
<td>$\mu_r$</td>
<td>1</td>
<td>$\mu_r \text{SmCo}$</td>
<td>$\mu_r \text{SmCo}$</td>
<td></td>
</tr>
<tr>
<td>$B_{rx}$</td>
<td>$-B_r \text{SmCo} \cdot x / R$</td>
<td>$B_r \text{SmCo} \cdot x / R$</td>
<td></td>
<td></td>
</tr>
<tr>
<td>$B_{ry}$</td>
<td>$-B_r \text{SmCo} \cdot y / R$</td>
<td>$B_r \text{SmCo} \cdot y / R$</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

For Subdomains 2 and 7, choose the material from the Electric (AC/DC) Material Properties library in the Materials/Coefficients Library dialog box, which you open by clicking Load.

2. Click OK.

**Boundary Conditions**

In the Boundary Settings dialog box, apply the Magnetic insulation condition to all boundaries, then click OK.

**MESH GENERATION**

1. In the Free Mesh Parameters dialog box, select Finer from the Predefined mesh sizes list.

2. Click Remesh, then click OK.

**COMPUTING THE SOLUTION**

Click the Solve button on the Main toolbar to compute the solution.

**POSTPROCESSING AND VISUALIZATION**

1. Open the Plot Parameters dialog box.

2. On the General page, select the check boxes for Slice plot and Streamline plot.

3. Click the Slice tab. From the Predefined quantities list, select Magnetic flux density, norm.

4. Type 0 in the edit field for x levels, and type 1 in the edit field for z levels.

5. Click the Streamline tab and select Magnetic flux density in the Predefined quantities list.
6  Click the **Specify start point coordinates** button and enter the values according to the table below.

<table>
<thead>
<tr>
<th>FIELD</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>x</td>
<td>0 0 0 0 0 0 0</td>
</tr>
<tr>
<td>y</td>
<td>0.35 0.35 0.35 0.35 0.35 0.3 0.2</td>
</tr>
<tr>
<td>z</td>
<td>linspace(0.1,0.59,7)</td>
</tr>
</tbody>
</table>

7  Select **Tube** in the **Line type** list, then click **OK**.
Magnetic Brake in 3D

Introduction

A magnet brake in its simplest form consists of a disk of conductive material and a permanent magnet. The magnet generates a constant magnetic field, in which the disk is rotating. When a conductor moves in a magnetic field it induces currents, and the Lorentz forces from the currents slow the disk.

Model Definition

This 3D problem is solved using a stationary formulation for the electromagnetic part coupled to an ordinary differential equation for the rotational rigid body dynamics. It also illustrates the proper use of a Lorentz type induced current density term. An ungauged A-V formulation is used to solve the electromagnetic part in a fast and memory efficient way.

For a disk rotating with angular velocity $\omega$ about the $z$-axis, the velocity $\mathbf{v}$ at a point $(x, y)$ is given by

$$\mathbf{v} = \omega(-y, x, 0)$$

Maxwell-Ampère's law, expressed using a magnetic vector potential $\mathbf{A}$, a scalar electric potential $V$, and an induced current density term of Lorentz type is the fundamental field equation used in this model. It is complemented by a current balance but no explicit gauging is provided.
\[ \nabla \times (\mu^{-1} \nabla \times \mathbf{A}) - \sigma \mathbf{v} \times (\nabla \times \mathbf{A}) + \sigma \nabla \nabla = 0 \]
\[ -\nabla \cdot (-\sigma \mathbf{v} \times (\nabla \times \mathbf{A}) + \sigma \nabla \nabla) = 0 \]

Such a formulation is inherently singular because the divergence of the magnetic vector potential is not uniquely determined and there is an infinite number of possible solutions to the problem. All such solutions yield the same magnetic flux and current densities, however. It is further known that the above formulation, when solved using an iterative solver, converges quickly and robustly provided that any explicitly supplied source current density (zero here) is divergence free and no direct coarse grid solver is involved in the solution scheme.

The induced Lorentz current density term is a common source of confusion in electromagnetic modeling. In situations when the moving domain is of bounded extent in the direction of the motion or varies in this direction or contains magnetic sources that also move, Lorentz terms cannot be used. This is because the part of the magnetic flux generated by moving sources must not be included in the Lorentz term. In this situation, the induced current distribution is stationary (it stays where the magnet is and does not move with the spinning disk). Thus, the moving domain does not contain any magnetic sources that move along with it and it is unbounded and invariant in the direction of the motion.

The magnetic and electric boundary conditions on external boundaries are

\[ \mathbf{n} \times \mathbf{A} = 0, \quad \mathbf{n} \cdot \mathbf{J} = 0 \]

Now consider how the system evolves over time. The induced torque slows the disk down, described by an ordinary differential equation (ODE) for the angular velocity \( \omega \).

\[ \frac{d\omega}{dt} = \frac{T_z}{I} \]

Where the torque \( T_z \) is obtained as the \( z \) component of the vector

\[ \mathbf{T} = \int_{\text{disk}} r \times (\mathbf{J} \times \mathbf{B}) dV \]

and the moment of inertia \( I \) for a disk with radius \( r \) and unit thickness equals

\[ I = m \frac{r^2}{2} = \frac{\rho r^4 r}{2} \]

Here \( m \) is the disk mass and \( \rho \) is the density.
Results and Discussion

The COMSOL Multiphysics model is set up for a 1 cm thick copper disk with a radius of 10 cm and an initial angular speed of 1000 rpm. The magnet consists of a 1 T, hard ($\mu_r = 1$) permanent magnet connected to an iron yoke with a 1.5 cm air gap in which the copper disk spins. The figures below show the induced eddy current density and the time evolution of the angular velocity, braking torque and dissipated power respectively.

The eddy current magnitude and direction at $t = 0$ s.
The time evolution of the angular velocity.

The time evolution of the braking torque.
The time evolution of the dissipated power.

Model Library path: ACDC_Module/Motors_and_Drives/magnetic_brake_3d

Modeling Using the Graphical User Interface

MODEL NAVIGATOR
1. Select 3D from the Space dimension list.
2. In the AC/DC Module folder, select Statics, Magnetic>Magnetostatics, Vector Potential>Ungauged potentials. This node contains an application mode that solves for magnetic (A) and electric (V) potentials using solver settings for a special ungauged technique.
3. Click OK to close the Model Navigator.

GEOMETRY MODELING
1. Use the Cylinder tool to create a cylinder with Radius 0.1, Height 0.01 and Axis base point z: -0.005. All other parameters are kept at their defaults.
2. Go to Draw>Work-Plane Settings.
3. In the dialog box that appears, select the y-z plane at x = 0. Click OK.
4. Go to **Draw>Specify Objects>Rectangle** to create rectangles with the following properties:

<table>
<thead>
<tr>
<th>NAME</th>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>BASE</th>
<th>X0</th>
<th>Y0</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>0.02</td>
<td>-0.0075+0.06</td>
<td>Corner</td>
<td>0.06</td>
<td>-0.06</td>
</tr>
<tr>
<td>R2</td>
<td>0.06</td>
<td>0.02</td>
<td>Corner</td>
<td>0.08</td>
<td>-0.06</td>
</tr>
</tbody>
</table>

5. From the **Draw** menu, open the **Create Composite Object** dialog box.

6. Clear the **Keep interior boundaries** check box.

7. Enter the formula R1+R2 in the **Set formula** edit field.

8. Click **OK**.

9. With the newly formed composite object selected, click the **Mirror** button, change the **Normal vector** to (0,1) and click **OK**.

10. Create another rectangle with the following properties:

<table>
<thead>
<tr>
<th>NAME</th>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>BASE</th>
<th>X0</th>
<th>Y0</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>0.02</td>
<td>0.08</td>
<td>Corner</td>
<td>0.12</td>
<td>-0.04</td>
</tr>
</tbody>
</table>

11. You now have three objects, which together form the cross section of the magnet.
**SELECT ALL THREE OBJECTS AND SELECT** **Extrude** **from the** **Draw** **menu. Extrude a distance of 0.02.**

**B** In the 3D view, with the extrusion objects selected, click the **Move** toolbar button and move the objects -0.01 in the x direction.

---

**OPTIONS AND SETTINGS**

**Constants**

1. From the **Options** menu, choose **Constants**.
2. Enter the following constants; when done, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>rpm</td>
<td>1000 [1/min]</td>
<td>Initial rpm value</td>
</tr>
<tr>
<td>W0</td>
<td>2<em>pi</em>rpm</td>
<td>Initial angular velocity</td>
</tr>
<tr>
<td>I0</td>
<td>0 [kg*m^2]</td>
<td>External inertia</td>
</tr>
</tbody>
</table>

**Expression Variables**

1. On the **Options** menu, point to **Expressions** and then click **Scalar Expressions**.
2. Enter Lorentz force variables according to the following table; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fx</td>
<td>( J_y , B_z - J_z , B_y )</td>
</tr>
<tr>
<td>Fy</td>
<td>( J_z , B_x - J_x , B_y )</td>
</tr>
<tr>
<td>Fz</td>
<td>( J_x , B_y - J_y , B_x )</td>
</tr>
</tbody>
</table>

3. On the Options menu, point to Expressions and then click Subdomain Expressions.

4. Enter the following subdomain expression; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>SUBDOMAINS 3–5</th>
</tr>
</thead>
<tbody>
<tr>
<td>core</td>
<td>1</td>
</tr>
</tbody>
</table>

**Coupling Variables**

Define integration coupling variables for the torque and the moment of inertia.

1. On the Options menu, point to Integration Coupling Variables and then click Subdomain Variables.

2. Enter the following variables; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>SUBDOMAIN 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Iz</td>
<td>8700((x^2+y^2))</td>
</tr>
<tr>
<td>Tqz</td>
<td>(x , F_y - y , F_x)</td>
</tr>
</tbody>
</table>

**PHYSICS SETTINGS**

**Subdomain Settings**

1. From the Physics menu, choose Subdomain Settings.

2. Enter subdomain settings for the active subdomains according to the table below.

To change the constitutive relation, you need to choose the relation from the Constitutive relation list. Click the Load button to access the material libraries. For subdomain 2, you can use the predefined material Copper that you find in the Basic Material Properties material library.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN 1</th>
<th>SUBDOMAIN 2</th>
<th>SUBDOMAIN S 3,4</th>
<th>SUBDOMAIN S</th>
</tr>
</thead>
<tbody>
<tr>
<td>Material</td>
<td>Copper</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Velocity x</td>
<td>0</td>
<td>-y*W</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Velocity y</td>
<td>0</td>
<td>x*W</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Velocity z</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>
### Boundary Conditions
Use the default magnetic boundary condition but change the electric boundary condition to **Electric insulation**.

### Global Equations
1. From the Physics menu, open the Global Equations dialog box and enter entities according to the following table. The description field is optional.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EQUATION</th>
<th>INIT(U)</th>
<th>INIT(UT)</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>W</td>
<td>$W = \frac{T - T_0}{(I_z + I_0)}$</td>
<td>W0</td>
<td>0</td>
<td>Angular velocity</td>
</tr>
</tbody>
</table>

Make sure that **SI** is selected in the **Base unit system** list.

2. Click **OK**.

### Mesh Generation
1. Go to Subdomain Mode by clicking the Subdomain Mode button on the Main toolbar.
2. Select Subdomain 2 (copper disk) only.
3. Open the Free Mesh Parameters dialog box by selecting Free Mesh Parameters from the Mesh menu.
4. Select **Extremely fine** from the list of Predefined mesh sizes.
5. Click the Advanced tab, and enter 1.1 in the z-direction scale factor edit field.
6. Click the Mesh Selected button to mesh just the disk.
7. Click the Global tab, and select Coarser from the list of Predefined mesh sizes.
8. Click **OK**.
9. Click the Mesh Remaining (Free) button on the Mesh toolbar to mesh the rest of the geometry.
COMPUTING THE SOLUTION

1. Open the Solver Parameters dialog box by clicking the corresponding button on the Main toolbar or select it from the Solve menu.

2. Set Solver to Time dependent.

3. In the Times edit field type 0:1:25.

4. In the Relative tolerance edit field type 0.001.

5. In the Absolute tolerance edit field type \( W 0.1 V 10^{-5} tA^* 10^{-7} \). The asterisk is a wildcard character and provides a shorthand for specifying that \( tAxAyAz10 \), \( tAxAyAz20 \), and \( tAxAyAz21 \) all get the same tolerance value \( 10^{-7} \).

6. Click the Time Stepping tab, set Time steps taken by solver to Intermediate, and select the Manual tuning of nonlinear solver check box.

7. Click the Nonlinear Settings button.

8. In the dialog box that appears, type 0.2 in the Tolerance factor edit field and 7 in the Maximum number of iterations edit field.

9. Clear the Use limit on convergence rate check box. From the Jacobian update list, select Once per time step.

10. Click OK to close the dialog box.

11. Click the Advanced tab and select Manual from the Type of scaling list.

12. In the Manual scaling edit field type \( W 0.01 V 10^{-5} tA^* 10^{-7} \).

13. Click OK to close the Solver Parameters dialog box.

14. Open the Probe Plot Parameters dialog box from the Postprocessing menu.

15. Click New and select Global from the Plot type list.

16. Type \( \Omega \) for Plot name.

17. Click OK.

18. Type \( W \) in the Expression edit field.

19. Click New and select the Global from the Plot type list.

20. Type Torque for Plot name.

21. Click OK.

22. Type \(-Tqz\) in the Expression edit field.

23. Click New and select Integration as Plot type and Subdomain as Domain type.

24. Type Power for Plot name.

25. Click OK.
26 Type Q_emqav in the Expression edit field and select Subdomain 2 from the Subdomain selection list.

27 Click OK.

28 Click the Solve button on the Main toolbar to compute the solution. The model takes roughly 10–20 minutes and uses less than 1 GB of memory to solve on a standard PC. The probe plots already shown in the results section appear as the solution is in progress.

POSTPROCESSING AND VISUALIZATION
1 Open the Plot Parameters dialog box from the Postprocessing menu.

2 Clear the check box for Slice plot and select the ones for Subdomain, Boundary, Edge, and Arrow plots on the General page. Select 0 from the Solution at time list.

3 Click the Subdomain tab. Type core in the Expression field. Set the Element color to Uniform color. Click the Color button and choose a medium gray color from the palette.

4 Click the Boundary tab. Type normJ_emqav in the Expression field.

5 Click the Edge tab. Type 1 in the Expression field. Select gray from the Colormap list and clear the Color scale check box.

6 Click the Arrow tab. Select Boundaries from the Plot arrows on list. Click the Boundary Data tab and enter Jx_emqav, Jy_emqav, and Jz_emqav, respectively, in the edit fields. Set the Arrow type to 3D arrow. Clear the Auto check box for Scale factor and enter 2 in the associated edit field.

7 Move the Plot Parameters dialog box to the side but keep it open.

8 From the Options menu, select Suppress Suppress Subdomains.

9 Select Subdomains 1 and 2.

10 Click OK.

11 From the Options menu, select Suppress Suppress Boundaries.

12 Select all boundaries except numbers 5–8, 32, and 35.

13 Click OK.

14 From the Options menu, select Suppress Suppress Edges.

15 Select Edges 1–5, 21, 31, 44–47, 50–54, 57, and 76.

16 Click OK.

17 Click OK in the Plot Parameters dialog box.

18 Click the Scene Light button on the Camera toolbar.
In the status bar at the bottom of the main window, double-click \textbf{AXIS}. 
Railgun

Introduction

A railgun is a type of magnetic accelerator gun that utilizes an electromagnetic force to propel an electrically conductive projectile (armature) that is initially part of the current path. The current flowing through the rails sets up a magnetic field between them and through the projectile perpendicular to the current in it. This results in an acceleration of the projectile along the rails. As no ferromagnetic materials are involved, there are no saturation effects and the muzzle speed of the projectile is only limited by the available electric power and the structural and thermal durability of the device. In theory, muzzle speeds of several km/s are possible.

Model Definition

This 3D problem is solved using a transient inductive formulation for the electromagnetic part coupled to an ordinary differential equation for the lumped kinematics of the armature. The railgun is a predominantly inductive and resistive device where the input power is transformed into three different entities:

- Joule heating
• Magnetic energy as more and more of the rails become energized as the armature moves forward
• Kinetic energy of the armature

As the current is limited by inductive and resistive effects, capacitive effects do not play any major role in the dynamics of the railgun itself. A practical railgun implementation may be driven by a high energy capacitor bank that can be included as a driving circuit (not implemented here).

Maxwell-Ampères law, expressed using a magnetic vector potential $A$ and a scalar electric potential $V$, is the fundamental field equation used in this model. It is complemented by a DC current balance.

$$\sigma \frac{\partial A}{\partial t} + \nabla \times (\mu^{-1} \nabla \times A) = -\sigma \nabla V$$
$$\nabla \cdot (-(\sigma \nabla V)) = 0$$

The armature is not modeled as a separate domain but as a moving conductivity distribution that is interpolated on a fixed mesh. Note that induced current terms of Lorentz type cannot be used in this modeling situation as the armature is of finite extent in the direction of motion and it carries an externally driven flux source that moves along with the motion. That is, part of the magnetic flux is stationary in the moving frame, see also the discussion in connection with the model “Magnetic Brake in 3D” on page 76.

The magnetic and electric boundary conditions on external boundaries are;

$$\mathbf{n} \times \mathbf{A} = 0$$
$$\mathbf{n} \cdot \mathbf{J} = 0$$

except for the voltage driven ends of the rails where suitable constraints are applied on the electric potential.

Now consider how the system evolves over time. The Lorentz force accelerates the armature. This is modeled as an ordinary differential equation (ODE) for the armature position $x_0$.

$$\frac{dx_0}{dt} = \frac{F_x}{M}$$

Where $M$ is the armature mass and the force $F_x$ is obtained as the $x$-component of the volume integral of the Lorentz force density over the armature:
Results and Discussion

The COMSOL Multiphysics model is set up for an armature that is a 4 cm cube made of aluminum. Each rail has a cross section that is 4 cm by 2 cm and a length of 4.8 m. As the armature is initially inserted 4 cm, the effective length is slightly shorter. The rails are made of copper. The device is driven by a constant applied voltage of 300 V. The following figures contain snapshots of the solution and time traces of rail current, position, speed, and the accelerating Lorentz force.

\[ \mathbf{F} = \int (\mathbf{J} \times \mathbf{B}) \, dV \]

Figure 3-11: A snapshot of the solution at \( t = 1.895 \) ms. The electric potential is plotted as color on the rails. Streamlines and streamline color represent the magnetic flux density and magnitude respectively.
The time evolution of the rail current.

The time evolution of the armature position.
The time evolution of the armature velocity.

The time evolution of the Lorentz force is shown.

Model Library path: ACDC_Module/Motors_and_Drives/railgun_3d
**Modeling Using the Graphical User Interface**

**MODEL NAVIGATOR**
1. Select 3D from the Space dimension list.
2. Click the Multiphysics button.
3. In the AC/DC Module folder, select Quasi-Statics, Magnetic> Induction Currents>Transient analysis.
4. Select Vector - Linear from the Element list.
5. Click Add to include the selected application mode in the list to the right.
6. In the AC/DC Module folder, select Statics, Electric>Conductive Media DC.
7. Select Lagrange - Linear in the Element list.
8. Click Add to include the selected application mode in the list to the right.
9. Click OK to close the Model Navigator.

**GEOMETRY MODELING**
2. In the dialog box that appears, select the y-z plane at x = 0, click OK.
3. Choose Draw>Specify Objects>Circle to create a circle with a radius of 0.5 and the center at (0, 0).
4. Choose Draw>Specify Objects>Rectangle three times to create rectangles with the following properties:

<table>
<thead>
<tr>
<th>NAME</th>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>BASE</th>
<th>X0</th>
<th>Y0</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>0.02</td>
<td>0.04</td>
<td>Corner</td>
<td>-0.04</td>
<td>-0.02</td>
</tr>
<tr>
<td>R2</td>
<td>0.02</td>
<td>0.04</td>
<td>Corner</td>
<td>0.02</td>
<td>-0.02</td>
</tr>
<tr>
<td>R3</td>
<td>0.08</td>
<td>0.04</td>
<td>Corner</td>
<td>-0.04</td>
<td>-0.02</td>
</tr>
</tbody>
</table>
5 Click the **Zoom Extents** button on the Main toolbar.

You should now have three objects that together form the cross section of the railgun:

6 Press Ctrl+A to select all four objects, then select **Extrude** from the **Draw** menu. Extrude a **Distance** of 5.

7 Click on the **Geom2** tab in the main window to go back to the 2D geometry.

8 Select only the circle object and select **Embed** from the **Draw** menu.

9 Click **OK**.

10 In the 3D geometry with the embedded circle object selected, click the **Move** button on the Draw toolbar.
In the Move dialog box, specify a Displacement of 4.8 in the x direction. Click OK.

**OPTIONS AND SETTINGS**

**Constants**

1. From the Options menu, choose Constants.
2. Enter the following constants; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>V</td>
<td>0.04^3[m^3]</td>
<td>Armature volume</td>
</tr>
<tr>
<td>rho_A1</td>
<td>2700[kg/m^3]</td>
<td>Armature density</td>
</tr>
<tr>
<td>M</td>
<td>rho_A1*V</td>
<td>Armature mass</td>
</tr>
<tr>
<td>w</td>
<td>0.04[m]</td>
<td>Armature length</td>
</tr>
<tr>
<td>k</td>
<td>100</td>
<td>Constant in exponential factor</td>
</tr>
<tr>
<td>sigma_A1</td>
<td>1/2.65e-8[ohm*m]</td>
<td>Armature conductivity</td>
</tr>
<tr>
<td>V0</td>
<td>300[V]</td>
<td>Applied voltage</td>
</tr>
</tbody>
</table>

**Coupling Variables**

Define integration coupling variables for the force on the armature and the rail current.
1 On the Options menu, point to Integration Coupling Variables and then click Subdomain Variables.

The force on the armature can be calculated using predefined variables for the Lorentz force provided in the application mode. To see the expression used to define the Lorentz forces, go to Physics>Equation System>Subdomain Settings. Click the Variables tab and find the Fltz variables in the list.

2 Enter the following variable; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>SUBDOMAIN 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>FX</td>
<td>FLtzx_emqa</td>
</tr>
</tbody>
</table>

3 On the Options menu, point to Integration Coupling Variables and then click Boundary Variables.

4 Enter the following variable:

<table>
<thead>
<tr>
<th>NAME</th>
<th>BOUNDARIES 1, 4</th>
</tr>
</thead>
<tbody>
<tr>
<td>I</td>
<td>nj_emdc-Jix_emqa</td>
</tr>
</tbody>
</table>

5 Click OK.

**PHYSICS SETTINGS**

*Subdomain Settings*

1 In the Multiphysics menu, make sure that the Conductive Media DC application mode is selected.

2 From the Physics menu, choose Subdomain Settings.

3 Select Subdomains 1 and 5, then clear the Active in this domain box to avoid solving this part of the problem in the air.

4 Enter subdomain settings for the active subdomains according to the table below; when done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAINS 2, 4</th>
<th>SUBDOMAIN 3</th>
<th>SUBDOMAINS 6–8</th>
</tr>
</thead>
<tbody>
<tr>
<td>Electric conductivity</td>
<td>5.98e7</td>
<td>1+sigma_A1<em>exp(-k</em>(abs(x-x0)&gt;(w/2))*(abs(x-x0)-(w/2)))</td>
<td>1</td>
</tr>
</tbody>
</table>

*Boundary Conditions*

1 From the Physics menu, choose Boundary Settings.
2 Use the Electric insulation boundary condition for all active boundaries except for Boundaries 4 and 14 where you apply the Electric potential $V_0/2$ and $-V_0/2$, respectively.

3 Click OK.

Subdomain Settings
1 From the Multiphysics menu, select the Induction Currents application mode.
2 From the Physics menu, choose Subdomain Settings.
3 Enter subdomain settings for the active subdomains according to the table below.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAINS 1, 5</th>
<th>SUBDOMAINS 2, 4</th>
<th>SUBDOMAIN 3</th>
<th>SUBDOMAINS 6-8</th>
</tr>
</thead>
<tbody>
<tr>
<td>Electric conductivity</td>
<td>1</td>
<td>5.98e7</td>
<td>$1 + \sigma_{Al} \exp(-k(\text{abs}(x-x_0)&gt;(w/2))\text{abs}(x-x_0)-(w/2)))$</td>
<td>1</td>
</tr>
<tr>
<td>$j_x^e$</td>
<td>0</td>
<td>Jx_emdc</td>
<td>Jx_emdc</td>
<td>Jx_emdc</td>
</tr>
<tr>
<td>$j_y^e$</td>
<td>0</td>
<td>Jy_emdc</td>
<td>Jy_emdc</td>
<td>Jy_emdc</td>
</tr>
<tr>
<td>$j_z^e$</td>
<td>0</td>
<td>Jz_emdc</td>
<td>Jz_emdc</td>
<td>Jz_emdc</td>
</tr>
</tbody>
</table>

Boundary Conditions
Use the default Magnetic insulation boundary condition for all active boundaries.

Global Equations
1 From the Physics menu, open the Global Equations dialog box and enter entities according to the following table. The description field is optional.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EQUATION</th>
<th>INIT(U)</th>
<th>INIT(UT)</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>x0</td>
<td>x0tt-FX/M</td>
<td>0.04</td>
<td>0</td>
<td>armature position</td>
</tr>
</tbody>
</table>

2 Click OK.

Mesh Generation
1 Go to Boundary Mode by clicking the Boundary Mode button on the Main toolbar.
2 Select Boundaries 1, 4, 8, and 14 (the railgun inlet end).
3 Select Free Mesh Parameters from the Mesh menu to open the Free Mesh Parameters dialog box.
4 From the Predefined mesh sizes list, select Coarse.
5 Click the Mesh Selected button to mesh the inlet end of the railgun.
6 Click OK.

7 Go to Subdomain Mode by clicking the Subdomain Mode button on the Main toolbar.

8 From the Mesh menu, select Swept Mesh Parameters.

9 In the Subdomain selection list, select Subdomains 1–4.

10 Select the Manual specification of element layers check box and specify 240 for Number of element layers.

11 Click the Mesh Selected button.

12 In the Subdomain selection list, select Subdomains 5–8.

13 Select the Manual specification of element layers check box and specify 10 for Number of element layers.
Click the Mesh Selected button.

Click OK.

**COMPUTING THE SOLUTION**

1. Open the Solver Parameters dialog box by clicking the corresponding button on the Main toolbar or selecting it from the Solve menu.

2. Set Solver to Time dependent.

3. In the Times edit field type \( \text{linspace}(0,4e^{-3},20) \).

4. In the Absolute tolerance edit field type: \( t \text{AxAyAz10 0.03e-4 V2 0.03 x0 0.01} \).

5. Set the Linear system solver to Direct (PARDISO).

6. Click OK to close the Solver Parameters dialog box.

7. Open the Probe Plot Parameters dialog box from the Postprocessing menu.

8. Click New and select Global from the Plot type list.

9. Type Position in the Plot name edit field.

10. Click OK.

11. Type x0 in the Expression edit field.

12. Click New and select Global from the Plot type list.
13 Type Velocity for Plot name.
14 Click OK.
15 Type x0t in the Expression field.
16 Click New and select Global from the Plot type list.
17 Type Current for Plot name.
18 Click OK.
19 Type I in the Expression field.
20 Click New and select Global from the Plot type list.
21 Type Force for Plot name.
22 Click OK.
23 Type FX in the Expression field.
24 Click OK.
25 Click the Solve button on the Main toolbar to compute the solution.

The model takes on the order of 2–4 hours and uses less than 1 GB of memory to solve on a standard PC. The probe plots already shown in the results section appears as the solution is in progress.

POSTPROCESSING AND VISUALIZATION
To reproduce Figure 3-11, follow these instructions:
1 From the Options menu, select Suppress>Suppress Subdomains.
2 Select Subdomains 2, 4, 6, and 8.
3 Click OK.
4 From the Options menu, select Suppress>Suppress Boundaries.
5 Select Boundaries 1–3, 8, 10–13, 19–21, 26, 28–31, 37, and 39.
6 Click OK.
7 From the Options menu, select Suppress>Suppress Edges.
8 Select Edges 1–3, 10, 12, 14–17, 26–31, 33, 35, 36, 38, 40–45, 47, 49, 52–54, and 59–62.
9 Click OK.
10 Open the Plot Parameters dialog box from the Postprocessing menu.
11 Clear the check box for Plot type: Slice and Geometry edges, and select the ones for Isosurface, Boundary, Edge and Streamline on the General page.
On the General page, select the Solution at time 0.001895.

Click the Isosurface tab. Type sigma_emqa in the Expression field. Set the Isosurface levels to Vector with isolevels and enter 1e7 in the corresponding field. Set Isosurface color to Uniform color. Click the Color button and choose a yellow color from the palette. Clear the Color scale check box.

Click the Boundary tab. Type V2 in the Expression field.

Click the Edge tab. Type 1 in the Expression field. Set Edge color to Uniform color. Click the Color button and choose black from the palette.

Click the Streamline tab.

Set the Streamline data fields to Bx_emqa, By_emqa, and Bz_emqa, respectively.

Click the Start Points tab, select Specify start point coordinates and enter [linspace(0.02,5,20) linspace(0.02,5,20)], [0.01*ones(1,20) -0.01*ones(1,20)], 0 in the x, y, and z data fields, respectively.

Click the Line Color tab, select Use expression and click the Color Expression button.

Type normB_emqa in the Expression field.

Select hot from the Colormap list.

Click OK to close the Streamline Color Expression dialog box.

Set the Line type to Tube and click the Tube Radius button.

Select the Radius data check box.

Type normB_emqa in the Expression field.

Clear the Auto check box for Radius scale factor and enter 0.1.

Click OK to close the Tube Radius Parameters dialog box.

Click the Advanced button and decrease the Maximum number of integration steps to 1000.

Click OK to close the Advanced Streamline Parameters dialog box.

Click OK in the Plot Parameters dialog box.

Click the Scene Light button on the Camera toolbar.
In the status bar at the bottom of the main window, double-click **AXIS** and **CSYS**. Use the mouse to adjust the view.
This chapter contains models of electrical components. In most cases, the models make use of the static and quasi-static application modes in the AC/DC Module.
**Tunable MEMS Capacitor**

*Introduction*

In an electrostatically tunable parallel plate capacitor you can modify the distance between the two plates when the applied voltage changes. For tuning of the distance between the plates the capacitor includes a spring that attaches to one of the plates. If you know the characteristics of the spring and the voltage between the plates, you can compute the distance between the plates. This model includes an electrostatic simulation for a given distance. A postprocessing step then computes the capacitance.

The capacitor in this model is a typical component in various microelectromechanical systems (MEMS) for electromagnetic fields in the radio frequency range 300 MHz to 300 GHz.

*Model Definition*

To solve the problem, use the 3D Electrostatics application mode in the AC/DC Module. The capacitance is available directly as a variable for postprocessing.

*Domain Equations*

The electric scalar potential, \( V \), satisfies Poisson’s equation,

\[
-\nabla \cdot (\varepsilon_0 \varepsilon_r \nabla V) = \rho
\]
where \( \varepsilon_0 \) is the permittivity of free space, \( \varepsilon_r \) is the relative permittivity, and \( \rho \) is the space charge density. The electric field and the displacement are obtained from the gradient of \( V \):

\[
E = -\nabla V \\
D = \varepsilon_0 \varepsilon_r E
\]

**Figure 4-2:** The computational domain. The interiors of the capacitor plates and the connecting bars are not included.

**Boundary Conditions**

Potential boundary conditions are applied to the capacitor plates and bars. A port condition maintains the potential 1 V at the upper plate and the connecting bars, whereas the lower plate is kept at ground potential. For the surface of the surrounding box, apply conditions corresponding to zero surface charge at the boundary,

\[
n \cdot D = 0
\]

**Results and Discussion**

Figure 4-3 shows the computed electric field and potential distribution in the capacitor. The potential on each capacitor plate is constant, as dictated by the boundary condition. Right between the plates, the electric field is almost uniform, but
close to the edges of the plates, you can see fringing fields that change magnitude and
direction rapidly in space.

![Diagram of electric field and potential](image)

*Figure 4-3: The electric potential is shown as a surface plot while the cones indicate the
strength and orientation of the electric field.*

The capacitance, $C$, obtained from the simulation is approximately $0.09 \text{ pF}$.

**Model Library path:** ACDC_Module/Electrical_Components/capacitor_tunable

---

**Modeling Using the Graphical User Interface**

**MODEL NAVIGATOR**

1. Select **3D** in the **Space dimension** list.
2. In the list of application modes, select **AC/DC Module>Statics, Electric>Electrostatics**.
3. Click **OK**.
OPTIONS AND SETTINGS

In the Axes/Grid Settings dialog box clear the Axis auto check box and specify axis settings according to the following table.

<table>
<thead>
<tr>
<th>AXIS</th>
<th>MIN</th>
<th>MAX</th>
</tr>
</thead>
<tbody>
<tr>
<td>x</td>
<td>-50</td>
<td>300</td>
</tr>
<tr>
<td>y</td>
<td>-50</td>
<td>300</td>
</tr>
<tr>
<td>z</td>
<td>-25</td>
<td>75</td>
</tr>
</tbody>
</table>

GEOMETRY MODELING

The geometry of this model can be created either by drawing in a work plane and then extruding the 2D geometry or by using 3D primitives. The advantage of the latter approach is that the coordinates of the blocks can be given explicitly.

1. Draw solid blocks according to the following table.

<table>
<thead>
<tr>
<th>NAME</th>
<th>LENGTH</th>
<th>AXIS BASE POINT</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>X</td>
<td>Y</td>
</tr>
<tr>
<td>BLK1</td>
<td>22</td>
<td>60</td>
</tr>
<tr>
<td>BLK2</td>
<td>40</td>
<td>22</td>
</tr>
<tr>
<td>BLK3</td>
<td>176</td>
<td>262</td>
</tr>
<tr>
<td>BLK4</td>
<td>40</td>
<td>22</td>
</tr>
<tr>
<td>BLK5</td>
<td>22</td>
<td>60</td>
</tr>
<tr>
<td>BLK6</td>
<td>40</td>
<td>22</td>
</tr>
<tr>
<td>BLK7</td>
<td>22</td>
<td>60</td>
</tr>
<tr>
<td>BLK8</td>
<td>40</td>
<td>22</td>
</tr>
<tr>
<td>BLK9</td>
<td>22</td>
<td>229</td>
</tr>
<tr>
<td>BLK10</td>
<td>40</td>
<td>22</td>
</tr>
</tbody>
</table>
2. Draw a solid cylinder with radius 5.5 and height 38 with the axis parallel to the $z$-axis, and the base point of the axis located at $(11, 250, 8)$.

3. Select all geometry objects using the Select All command from the Edit menu, then open the Create Composite Object dialog box. Be sure to clear the Keep interior boundaries check box and verify that all objects are selected. Then click OK to create a composite object as the union of all objects. The advantage with removing the interior boundaries in this geometry is that it makes it easier to create a high quality mesh later on.

4. Now, draw two more solid block objects according to the following table.

<table>
<thead>
<tr>
<th>NAME</th>
<th>LENGTH</th>
<th>AXIS BASE POINT</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>X</td>
<td>Y</td>
</tr>
<tr>
<td>BLK1</td>
<td>176</td>
<td>262</td>
</tr>
<tr>
<td>BLK2</td>
<td>181</td>
<td>22</td>
</tr>
</tbody>
</table>

5. Using the Shift key, select both block objects, then click the Union button to form another composite object. The interior boundaries of this object are not kept because the settings in the Create Composite Object dialog box are applied for all set operations until modified again.
6 Now draw a block surrounding the two objects corresponding to the two plates in the capacitor. Create a block of size 360-by-340-by-94, with the base point of the axis at $(-40, -20, -20)$.

7 Once again open the **Create Composite Object** dialog box, and now enter the formula $\text{BLK1 - (CO1+CO2)}$ in the **Set formula** edit field.

8 The geometry of the model is now ready, except for the size. The capacitor dimensions you have entered should be given in $\mu$m. This is easily accounted for by clicking the **Scale** button and giving the value $1 \times 10^{-6}$ for all three scaling factors. Then click the **Zoom Extents** button on the Main toolbar to see the object.

**PHYSICS SETTINGS**

**Subdomain Settings**

Because there is silica-glass between the plates, you need to modify the permittivity.

1 From the **Physics** menu, open the **Subdomain Settings** dialog box.

2 Specify the following settings; when done, click **OK**.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\varepsilon_r$</td>
<td>4.2</td>
</tr>
<tr>
<td>$\rho$</td>
<td>0</td>
</tr>
</tbody>
</table>
**Boundary Conditions**

The lower plate is grounded while a positive potential is applied to the upper plate. The surrounding boundaries are kept electrically insulated. Enter these boundary conditions as follows:

1. From the **Physics** menu, open the **Boundary Settings** dialog box.
2. Specify the following settings; when done, click **OK**.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>ALL BOUNDARIES</th>
<th>BOUNDARIES 1–4, 9, 76</th>
<th>BOUNDARIES 37–40, 45, 47–51, 57</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Port</td>
<td>Zero charge/Symmetry</td>
<td>Ground</td>
</tr>
<tr>
<td>Port tab</td>
<td>Use port as input</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Input property</td>
<td>Energy method</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Mesh Generation**

1. Open the **Free Mesh Parameters** dialog box. On the **Global** tab, select **Coarse** from the **Predefined mesh sizes** list. Then select **Custom mesh size** and set the **Resolution of narrow regions** parameter to 1.5 to help the mesh generator resolve the thin regions in the geometry.
2. Click **Remesh** to initialize the mesh, then click **OK** to close the **Free Mesh Parameters** dialog box.

**Computing the Solution**

Click the **Solve** button on the Main toolbar.

**Postprocessing and Visualization**

Use the electric field distribution together with a plot of the potential to visualize the result of the simulation. You have access to the capacitance as a variable, $C_{11\_emes}$, that you can plot or display directly.

1. Start by suppressing some boundaries not to be used for visualization: from the **Options** menu, select **Suppress Boundaries**. Select Boundaries 1, 2, and 4, then click **OK**.
2. Click the **Plot Parameters** button on the Main toolbar.
3. On the **General** page of the **Plot Parameters** dialog box, clear the **Slice** check box and select the **Boundary** and **Arrow** check boxes in the **Plot type** area.
4. Click **OK** to accept the default plot settings and reproduce the plot in Figure 4-3 on page 106.
5 Choose **Postprocessing>Data Display>Global** to open the **Global Data Display** dialog box. Type `C11_emes` in the **Expression** edit field, then click **OK** to display the capacitance in the message log.

**Modeling Using the Programming Language**

% Start the modeling by clearing the fem variable in the COMSOL Script or MATLAB workspace.

```matlab
clear fem
```

% Begin by specifying space dimensions and defining a geometry.

```matlab
fem.sdim = {'x', 'y', 'z'};
```

```matlab
blks{1} = block3(22, 60, 8, 'corner', [0 240 46]);
blks{2} = block3(40, 22, 8, 'corner', [22 259 46]);
blks{3} = block3(176, 262, 8, 'corner', [62 19 46]);
blks{4} = block3(40, 22, 8, 'corner', [238 259 46]);
blks{5} = block3(22, 60, 8, 'corner', [278 240 46]);
blks{6} = block3(40, 22, 8, 'corner', [238 19 46]);
blks{7} = block3(22, 60, 8, 'corner', [278 0 46]);
blks{8} = block3(40, 22, 8, 'corner', [22 0 46]);
blks{9} = block3(22, 218, 8, 'corner', [22 0 0]);
cyl1 = cylinder3(5.5, 38, [11 250 8]);
```

```matlab
co1 = geomcomp({blks{:} cyl1}, 'face', 'all', 'edge', 'all');
```

```matlab
blk1 = block3(176, 262, 8, 'corner', [62 19 8]);
blk2 = block3(181, 22, 8, 'corner', [139 139 0]);
co2 = blk1 + blk2;
```

```matlab
blk3 = block3(360, 340, 94, 'corner', [-40 -20 -20]);
co3 = geomcomp(co1, co2, blk3, 'ns', {'C01', 'C02', 'BLK1'}, ... 'sf', 'BLK1-(C01 + C02)', 'face', 'all', 'edge', 'all');
```

```matlab
fem.geom = scale(co3, 1e-6, 1e-6, 1e-6, 0, 0, 0);
```

% The application mode structure contains all the physical properties of the model. Create this with the following commands:

```matlab
clear appl
```

```matlab
appl.mode = 'EmElectrostatics';
```

```matlab
appl.equi.rho0 = '0';
appl.equi.epsilonrr = '4.2';
```

% Use Energy method for capacitance calculation

```matlab
clear prop
```
prop.input='We';
appl.prop = prop;

% Assign zero charge, port, and ground boundary conditions to
% correct boundary numbers.
appl.bnd.inport = {0,1,0};
appl.bnd.type = {'nD0','port','V0'};
appl.bnd.ind = ones(1,76)*2;
appl.bnd.ind(1,[1:4 9 76]) = 1;
appl.bnd.ind(1,[37:40 45:51 57]) = 3;

% Generate the coefficients in the FEM structure.
fem.appl = appl;
fem = multiphysics(fem);

% Create a coarse mesh for the geometry with the following commands.
% The extended mesh structure contains all the necessary data
% defining the different elements.
fem.mesh = meshinit(fem, ...
    'hauto',6, ...
    'hnarrow',1.5);

fem.xmesh = meshextend(fem);

% Solve the problem and visualize the result.
fem.sol = femstatic(fem,'linsolver','spooles');

% Plot the voltage on all boundaries except on number 1, 2, and 4.
% The electric field is plotted as arrows for all subdomains.
bdlList = setdiff(1:76,[1 2 4]);
postplot(fem,...
    'bd1', bdlList, ...
    'tridata',{'V','cont','on'}, ... 
    'trbar', 'on', ... 
    'arrowdata',{'Ex','Ey','Ez'}, ... 
    'axisequal','on', ...
    'axisvisible','off')

% The capacitance value (evaluated at an arbitrary point):
I1 = postinterp(fem,'C11',[0;0;0])
Induction Currents from Circular Coils

Introduction

A time-varying current induces a varying magnetic field. This field induces currents in neighboring conductors. The induced currents are called eddy currents. The following model illustrates this phenomenon by a time-harmonic field simulation as well as a transient analysis, which provides a study of the eddy currents resulting from switching on the source.

Two current-carrying coils are placed above a copper plate. They are surrounded by air, and there is a small air gap between the coils and the metal plate. A potential difference provides the external source. To obtain the total current density in the coils you must take the induced currents into account. The time-harmonic case shows the skin effect, that is, that the current density is high close to the surface and decreases rapidly inside the conductor.

Model Definition

Equation

To solve the problem in the AC/DC Module, use a quasi-static equation for the magnetic potential $A$.

$$\sigma \frac{\partial A}{\partial t} + \nabla \times (\mu_0^{-1} \mu_r^{-1} \nabla \times A) = \frac{V_{\text{loop}}}{2\pi r}$$
where \( \mu_0 \) is the permeability of vacuum, \( \mu_r \) the relative permeability, \( \sigma \) the electric conductivity, and \( V_{\text{loop}} \) is the voltage over one turn in the coil. In the time-harmonic case the equation reduces to

\[
j_0 \sigma A + \nabla \times (\mu_0^{-1} \mu_r^{-1} \nabla \times A) = \frac{V_{\text{loop}}}{2\pi r}
\]

FORCES

It is also possible to compute the forces on the plate caused by the eddy currents. The following expression gives the Lorentz force on the plate:

\[
F = J \times B
\]

When dealing with time-harmonic fields, you must take the complex nature of the field representation into special consideration. In the time domain, the force in the axial direction in this axisymmetric model is

\[
F_z = -J_\phi B_r = -\text{Re}(J_\phi e^{j\omega t}) \cdot \text{Re}(B'_r e^{j\omega t})
\]

where \( J_\phi \) and \( B'_r \) are the current and magnetic flux in the frequency domain, obtained from the harmonic equation.
Results and Discussion

The applied voltage is constant across each wire, but the induced current makes the current density higher toward the end facing the copper plate. Figure 4-4 below shows this and also displays the field lines from the magnetic flux.

*Figure 4-4: The $\psi$ component of the current density plotted together with the field lines of the magnetic flux.*
The eddy currents in the wires and in the copper plate give rise to a force between the parts. Figure 4-5 below shows a plot of the force on the plate over one period.

Figure 4-5: The force on the copper plate over one period. Although the solution only gives the amplitude and phase, these can easily be converted to a real signal in the time domain.

Model Library path: ACDC_Module/Electrical_Components/coil_above_plate

Harmonic Analysis in the Graphical User Interface

MODEL NAVIGATOR
1 From the Space dimension list, select Axial symmetry (2D).
2 Select the AC/DC Module>Quasi-Statics, Magnetic>Azimuthal Induction Currents, Vector Potential>Time-harmonic analysis application mode.
3 Click OK.

OPTIONS AND SETTINGS
1 From the Options menu, choose Axes/Grid Settings.
2 Set axis and grid settings according to the following table. Before enter the settings on the Grid page, clear the Auto check box. When done, click OK.

<table>
<thead>
<tr>
<th>AXIS</th>
<th>GRID</th>
</tr>
</thead>
<tbody>
<tr>
<td>r min</td>
<td>-0.05</td>
</tr>
<tr>
<td>r max</td>
<td>0.15</td>
</tr>
<tr>
<td>z min</td>
<td>-0.08</td>
</tr>
<tr>
<td>z max</td>
<td>0.08</td>
</tr>
</tbody>
</table>

**GEOMETRY MODELING**

1 Draw the surrounding rectangle R1 with opposite corners at (0, -0.05) and (0.1, 0.05).

2 Draw the rectangle representing the metal plate R2 with the corners at (0, -0.02) and (0.08, 0). Now change the position of R2 by clicking the Move button on the Draw toolbar or selecting it in the Draw menu under Modify. Set the z displacement to -0.001, then click OK.

3 Draw a circle C1 representing the first current-carrying coil, centered at (0.0125, 0.0025) with radius 0.0025.

4 Select C1 and click the Array button. Set the Displacement in the r direction to 0.006 and the Array size in the r direction to 2.

**PHYSICS SETTINGS**

*Scalar Variables*

1 From the Physics menu, select Scalar Variables.
2 Set the frequency variable nu_emqa to 50, then click OK.

Subdomain Settings
In this model, use the COMSOL Multiphysics materials library to specify material parameters in the subdomains. Only the conductivity, the permeability, and the permittivity are determined by the material selected.

1 From the Physics menu, open the Subdomain Settings dialog box.
2 Select Subdomains 2–4.
3 On the Electric Parameters page, click the Load button. In the dialog box that appears, select Copper. Click OK.
4 Enter subdomain settings according to the following table; when done, click OK.

<table>
<thead>
<tr>
<th>SETTING</th>
<th>SUBDOMAINS 1, 2</th>
<th>SUBDOMAINS 3, 4</th>
</tr>
</thead>
<tbody>
<tr>
<td>V_loop</td>
<td>0</td>
<td>1e-4</td>
</tr>
</tbody>
</table>

Boundary Conditions
1 From the Physics menu, open the Boundary Settings dialog box.
2 Specify boundary conditions according to the following table; when done, click OK.

<table>
<thead>
<tr>
<th>SETTING</th>
<th>BOUNDARIES 1, 3</th>
<th>BOUNDARIES 2, 7, 9</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Axial symmetry</td>
<td>Magnetic insulation</td>
</tr>
</tbody>
</table>

Mesh Generation
1 Initialize the mesh by clicking the Initialize Mesh button on the Main toolbar.
2 Click the Refine Mesh button to refine the mesh.

Computing the Solution
Click the Solve button on the Main toolbar.

Postprocessing and Visualization
The magnetic potential is the default visualization quantity. In this case it is of interest to plot the eddy currents together with the magnetic flux density. These fields are used to examine the magnetic forces that arise in current-carrying conductors.

1 Click the Plot Parameters button on the Main toolbar.
2 On the General page, select the Surface and Streamline check boxes.
3 Click the Surface tab. Select Induced current density, phi component from the Predefined quantities list on the Surface Data page.
Click the Streamline tab. Select **Magnetic flux density** from the **Predefined quantities** list on the Streamline Data page.

From the **Streamline plot type** list, select **Magnitude controlled**.

On the Line Color page, click first the **Use expression** option button and then the **Color Expression** button.

In the **Streamline Color Expression** dialog box, select **Magnetic flux density, norm** from the **Predefined quantities** list. Type uT in the **Unit** edit field and select **hot** from the **Colormap** list. Click **OK** to close the Streamline Color Expression dialog box.

Click **OK** to close the **Plot Parameters** dialog box and generate the plot.

For a better view of the current-intensive region, use the **Zoom Window** button on the Main toolbar. The current density is highest near the edge of the plate.

The resulting plot should resemble that in Figure 4-4 on page 115.

If you are running COMSOL Multiphysics with COMSOL Script or MATLAB, you can visualize the force over one period.

From the **File** menu, select **Export>FEM Structure as 'fem'** (alternatively, press Ctrl+F).

Use the following commands to show the magnetic force on the plate over one period.

```matlab
wt = linspace(0,2*pi,40);
for i = 1:length(wt)
    Fv(i) = postint(fem,'-2*pi*r*real(Jiphi_emqa)*real(Br_emqa)',...
                  'dl',2,'phase',wt(i));
end
figure
plot(wt,Fv)
xlabel('angle (wt)'),ylabel('axial force (Fz)')
```
Transient Analysis

The previous model was an example of harmonic field variations. To study a transient case where the current increases abruptly from zero to a constant value, you only need to make a few alterations. To adapt the application mode to a transient analysis, you must first change the analysis type.

**COMPUTING THE SOLUTION**

1. From the Solve menu, open the Solver Parameters dialog box and select *Transient* from the list of analysis types in the Analysis types area.
2. In the Times edit field, type `logspace(-4,-1,10)`.
3. Set the Absolute tolerance to `1e-8`, then click OK.
4. Click the Solve button on the Main toolbar.

**POSTPROCESSING AND VISUALIZATION**

In a way similar to the harmonic analysis, you can visualize the magnetic flux density, the induced currents, and the magnetic forces.

1. Open the Plot Parameters dialog box.
2. In the Plot type area on the General page, select the Surface and Arrow check boxes and clear the Streamline check box.
3. Click the Arrow tab. On the Subdomain Data page, select Magnetic flux density from the Predefined quantities list. In the Arrow positioning area, set the Number of points...
to 25 in both directions. In the **Arrow parameters** area, set the **Arrow length** to **Normalized** and the **Scale factor** to 0.5.

4 Click **OK**.

5 Use the zoom features to see the eddy current distribution.

6 To see how the current distribution changes in time, return to the **Plot Parameters** dialog box and change the evaluation time on the **General** page or click **Start Animation** on the **Animate** page; the plot below shows the solution for $t = 0.002154$ s.

![Image of eddy current distribution]

---

**Modeling Using the Programming Language**

```matlab
% Start modeling by defining the names of the cylindrical coordinates and by defining the geometry of the structure.
clear fem
fem.sdim={'r' 'z'};
fem.geom=rect2(0,0.1,-0.05,0.05)+...  
    rect2(0,0.08,-0.019,-0.001)+...  
    circ2(0.0125,0.0025,0.0025)+...  
    circ2(0.0185,0.0025,0.0025);

% Create the application structure.
clear appl
```
appl.mode.class='AzimuthalCurrents';
appl.mode.type='axi';
appl.prop.analysis='harmonic';
appl.var.nu=50;
appl.bnd.type={'ax' 'A0'};
appl.bnd.ind=[1 2 1 0 1 0 2 0 2 0 0 0 0 0 0 0 0];
appl.equ.sigma={'0' '5.99e7' '5.99e7'};
appl.equ.Vloop={'0' '0' '1e-4'};
appl.equ.ind=[1 2 3 3];
fem.appl=appl;
fem=multiphysics(fem);

% Create the mesh.
fem.mesh=meshinit(fem);
fem.mesh=meshrefine(fem);
fem.xmesh = meshextend(fem);

% Solve and visualize the solution.
fem.sol=femlin(fem);
postplot(fem,'tridata','Jiphi',
    'arrowdata',{'Br' 'Bz'},'arrowscale',0.3,...
    'arrowstyle','normal')

% You can handle the postprocessing in exactly the same way as
% above, when solving the problem in the graphical user interface.
wt=linspace(0,2*pi,40);
for i=1:length(wt)
    Fv(i)=postint(fem,'-2*pi*r*real(Jiphi)*real(Br)','dl',2,...
    'phase',wt(i));
end
figure
plot(wt,Fv)
xlabel('angle (wt)'),ylabel('axial force (Fz)')

% To simulate the transient case, the analysis type has
% to be modified.
fem.appl.prop.analysis='transient';

% Generate the PDE coefficients for the transient analysis.
fem=multiphysics(fem);

% Regenerate the extended mesh.
fem.xmesh = meshextend(fem);

% To solve the problem, the solver femtime is invoked. You can
% visualize the result with the same command as in the time
% harmonic case. To study the result at a specific output time,
% set the parameter solnum.
fem.sol=femtime(fem,'tlist',[0 logspace(-4,-1,10)],'atol',1e-8);
postplot(fem,'tridata','Jiphi',...
'arrowdata', {'Br', 'Bz'}, 'arrowscale', 0.3,...
'arrowstyle', 'normal', 'solnum', 6)

% The axial force is visualized with the following commands.
F = postint(fem, 'abs(2*pi*r*Jiphi*Br)',
'dl', 2, 'solnum', 1:length(fem.sol.tlist));
loglog(fem.sol.tlist(:, F(:, 'k')));
xlabel('time (t)');
ylabel('axial force (F_z)');
Magnetic Field of a Helmholtz Coil

Introduction

A Helmholtz coil is a parallel pair of identical circular coils spaced one radius apart and wound so that the current flows through both coils in the same direction. This winding results in a uniform magnetic field between the coils with the primary component parallel to the axis of the two coils. The uniform field is the result of the sum of the two field components parallel to the axis of the coils and the difference between the components perpendicular to the same axis.

The purpose of the device is to allow scientists and engineers to perform experiments and tests that require a known ambient magnetic field. Helmholtz field generation can be static, time-varying DC, or AC, depending on the applications.

Applications include cancelling the earth’s magnetic field for certain experiments; generating magnetic fields for determining magnetic shielding effectiveness or susceptibility of electronic equipment to magnetic fields; calibration of magnetometers and navigational equipment; and biomagnetic studies.

Figure 4-6: The Helmholtz coil consists of two coaxial circular coils, one radius apart along the axial direction. The coils carry parallel currents of equal magnitude.
**Model Definition**

The model is built using the 3D Magnetostatic application mode. The model geometry is shown in Figure 4-7.

![Figure 4-7: The model geometry.](image)

**DOMAIN EQUATIONS**

Assuming static currents and fields, the magnetic vector potential \( \mathbf{A} \) must satisfy the following equation:

\[
\nabla \times (\mu^{-1} \nabla \times \mathbf{A}) = \mathbf{J}^e
\]

where \( \mu \) is the permeability, and \( \mathbf{J}^e \) denotes the externally applied current density.

The relations between fields and potentials are given by

\[
\mathbf{B} = \nabla \times \mathbf{A} \\
\mathbf{H} = \mu^{-1} \mathbf{B}
\]

This model uses the permeability of vacuum, that is, \( \mu = 4\pi \cdot 10^{-7} \) H/m. The external current density is zero except in the circular coils, where a current density of 1 A/m\(^2\).
is specified. This corresponds to a coil current of 2.5 mA. The currents are specified to be parallel for the two coils.

To avoid numerical instability, the application mode by default use an extra equation that sets the divergence of the $A$ field to zero (gauge fixing). This model uses a more efficient approach where the divergence of $A$ is numerically adjusted to zero by using special pre- and postsmoothers called SOR gauge. See “Solver Settings for Numerical Gauge Fixing in Magnetostatics” on page 114 in the AC/DC Module User’s Guide for more details on this topic.

**BOUNDARY CONDITIONS**

The only boundary conditions that you need to specify is for the exterior boundary, that is, the spherical surface, where you apply conditions corresponding to zero magnetic flux:

$$ \mathbf{n} \times \mathbf{A} = 0 $$
Results and Discussion

Figure 4-8 shows the magnetic flux density between the coils. You can see that the flux is fairly uniform between the coils, except for the region close to the edges of the coil.

![Image of magnetic flux density]

*Figure 4-8: The surface color plot shows the magnetic flux density. The arrows indicate the magnetic field (H) strength and direction.*

The main property of the Helmholtz coil is that the magnetic flux becomes uniform in a reasonably large region with a rather simple coil system. This is illustrated in Figure 4-9 (a), which shows a radial flux density profile for an axial position right between the coils. Figure 4-9 (b) shows an axial magnetic flux density profile. The model clearly demonstrates the highly uniform magnetic field obtained in a Helmholtz coil.

In the absence of any test object, this model is fully axisymmetric and could be implemented as a 2D axisymmetric model, which would be much less computationally...
demanding. However, a full 3D model has the advantage that it is possible to include a non-axisymmetric test object in the analysis as a slight modification of the model.

![Magnetic flux density profile](image)

Figure 4-9: The magnetic flux density profile. The plots show the profile taken along a radial cross-sectional line through the axis right between the coils (a) and a profile taken along the axis (b). A high degree of uniformity is clearly shown.

**Model Library path:** ACDC_Module/Electrical_Components/helmholtz_coil

**Modeling Using the Graphical User Interface**

**MODEL NAVIGATOR**

1. Select 3D from the **Space dimension** list.
2. In the list of application modes, select **AC/DC Module>Statics, Magnetic>Magnetostatics, Vector Potential**.
3. Click **OK**.

**OPTIONS AND SETTINGS**

From the **Options** menu, open the **Constants** dialog box and enter the following name, expression, and description (optional); when done, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>J0</td>
<td>1[A/m²]</td>
<td>Current density in coil</td>
</tr>
</tbody>
</table>
GEOMETRY MODELING

The coils are made from squares in a 2D work plane, which you then revolve into a 3D geometry.

1. From the Draw menu open the Work-Plane Settings dialog box. Click OK to obtain the default work plane in the xy-plane.

2. In the 2D geometry, choose Options>Axes/Grid Settings and specify the settings according to the following table (you must clear the Auto check box on the Grid page to be able to enter the grid settings).

<table>
<thead>
<tr>
<th>AXIS</th>
<th>GRID</th>
</tr>
</thead>
<tbody>
<tr>
<td>x min</td>
<td>-0.6 x spacing 0.4</td>
</tr>
<tr>
<td>x max</td>
<td>-0.2 Extra x</td>
</tr>
<tr>
<td>y min</td>
<td>-0.4 y spacing 0.2</td>
</tr>
<tr>
<td>y max</td>
<td>0.4 Extra y -0.225 -0.175 0.175 0.225</td>
</tr>
</tbody>
</table>

3. Draw a square with corners at (−0.425, 0.175) and (−0.375, 0.225).
4. Draw another square with corners at (−0.425, −0.225) and (−0.375, −0.175).
5. Select both squares and use the Revolve dialog box available from the Draw menu to revolve into the 3D geometry.
6. Finally add a sphere with radius 1 and center at the origin to the 3D geometry.

PHYSICS SETTINGS

Subdomain Settings

Apply the current in the coils as a given source current. Open the Subdomain Settings dialog box from the Physics menu and enter the source current according to the following table.

<table>
<thead>
<tr>
<th>SETTING</th>
<th>SUBDOMAIN 1</th>
<th>SUBDOMAINS 2, 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>J_e</td>
<td>0 0 0</td>
<td>-J_0<em>z/sqrt(x^2+z^2) 0 J_0</em>x/sqrt(x^2+z^2)</td>
</tr>
</tbody>
</table>

Boundary Conditions

Use the default Magnetic insulation boundary condition.

MESH GENERATION

1. Open the Free Mesh Parameters dialog box and select Coarser from the Predefined mesh sizes list on the General tab. Click the Subdomain tab, select the Subdomains 2 and 3, and set the Maximum element size to 0.05.
2 Click Remesh to generate the mesh, then click OK.

**COMPUTING THE SOLUTION**

Because the default solver settings for this model efficiently handle the gauge fixing with the SOR gauge smoothers for the geometric multigrid preconditioner, simply click the Solve button on the Main toolbar to start solving.

**POSTPROCESSING AND VISUALIZATION**

1 Suppress the surface of the sphere, that is, Boundaries 1, 2, 3, 4, 21, 22, 31, and 32 using the Suppress Boundaries dialog box in the Options menu.

2 On the General page of the Plot Parameters dialog box select the Slice, Boundary, and Arrow check boxes and clear the Geometry edges check box.

3 On the Slice page use the default Slice data, which is magnetic flux density, norm. Set the number of x levels to 0 and the number of z levels to 1.

4 On the Boundary page set Boundary data to 1 and select a Uniform color of your choice.

5 On the Arrow page select Magnetic field as Arrow data, set the x points to 24, the y points to 10, and the z points to 1. Enter 0.5 as Scale factor.
To add some lighting to the plot open the Visualization/Selection Settings dialog box from the Options menu and select Scenelight on the Lighting page. Disable lights 1 and 3.

You can visualize the magnetic flux density profile using cross-section plots.

Open the Cross-Section Plot Parameters dialog box. On the General page click the Title/Axis button and set the title to Magnetic flux density.
On the Line tab use the default \textit{y-axis data} which is \textbf{Magnetic flux density, norm}. Set the \textit{x-axis data} to \textit{x} and set \textit{x}_0 to -0.8 and \textit{x}_1 to 0.8. Click \textbf{Apply} to make a plot of the magnetic flux density along a line through the axis right between the coils.
To make a plot in the other direction change the x-axis data to y and set x0 to 0, x1 to 0, y0 to -0.8 and y1 to 0.8.

![Magnetic flux density graph](image-url)
Inductance in a Coil

Introduction

This is a model of a simple AC coil: a single-turn thick copper wire. A parametric study shows the current distribution in the coil at different frequencies. The skin effect becomes increasingly important at higher frequencies.

Model Definition

You build the 2D axisymmetric model with the Azimuthal Induction Currents, Vector Potential application mode, using a time-harmonic formulation. The modeling takes place in the \( rz \)-plane. The model domain only includes the part where \( r > 0 \), in a manner such that revolving this view around the \( z \)-axis retrieves the full 3D geometry.

Domain Equations

The dependent variable in this application mode is the azimuthal component of the magnetic vector potential \( A \), which obeys the following relation:

\[
(j \omega \sigma - \omega^2 \epsilon \mu^{-1}) A_\phi + \nabla \times (\mu^{-1} \nabla \times A_\phi) = \frac{\sigma V_{\text{loop}}}{2 \pi r}
\]

where \( \omega \) denotes the angular frequency, \( \sigma \) the conductivity, \( \mu \) the permeability, \( \epsilon \) the permittivity, and \( V_{\text{loop}} \) the voltage applied to the coil. Outside the coil, \( \sigma \) is set to zero.

Boundary Conditions

The model includes boundary conditions for the exterior boundary and the symmetry axis. For the exterior boundary, use magnetic insulation. This implies that the magnetic vector potential is zero at the boundary, corresponding to a zero magnetic flux. For the symmetry boundary use a symmetry condition. The magnetic potential is continuous across the interior boundary between the copper wire and the surrounding air.
Results and Discussion

Figure 4-10 and Figure 4-11 show the total current density in the coil at frequencies of 10 Hz and 2 kHz, respectively.

**Figure 4-10**: The current density at 10 Hz.

**Figure 4-11**: The current density at 2 kHz.
At 10 Hz, the current density is largely inversely proportional to the radial distance; at 2 kHz, the current is concentrated to the surface of the coil due to the skin effect.

The inductance versus frequency appears in Figure 4-12. The model discusses two alternative ways to calculate the inductance: the principle of virtual work and Ohm’s law. The difference between the two approaches is less than 0.01 percent.

Figure 4-12: The inductance as a function of the frequency calculated using the virtual work method.

---

**Model Library path:** ACDC_Module/Electrical_Components/coil_inductance

---

**Modeling Using the Graphical User Interface**

**MODEL NAVIGATOR**

1. Start COMSOL Multiphysics.

2. On the New page of the Model Navigator, select Axial symmetry (2D) in the Space dimension list.

3. Click on AC/DC Module, then select Quasi-Static, Magnetic> Azimuthal Induction Currents, Vector Potential>Time-harmonic analysis.

4. Click OK.
GEOMETRY MODELING

1 Start by drawing the half circle representing the air domain. A half circle is conveniently created as the union of a circle and a rectangle. First draw the circle. To do so, press Shift and click the Ellipse/Circle (Centered) button on the Draw toolbar to the left of the drawing area. In the Circle dialog box that opens, enter the Radius 0.2, then click OK.

2 Click the Zoom Extents button on the Main toolbar above the drawing area.

3 Press Shift and click the Rectangle/Square button on the Draw toolbar. In the Rectangle dialog box that opens, specify a rectangle according to the following table:

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>0.2</td>
</tr>
<tr>
<td>Height</td>
<td>0.4</td>
</tr>
<tr>
<td>Base</td>
<td>Corner</td>
</tr>
<tr>
<td>r</td>
<td>-0.2</td>
</tr>
<tr>
<td>z</td>
<td>-0.2</td>
</tr>
</tbody>
</table>

4 Click OK to close the dialog box.

5 Now create the half circle by first pressing Ctrl+A to select both geometry objects and then clicking the Difference button in the Draw toolbar.

6 Click the Zoom Extents button on the Main toolbar to center the geometry in the drawing area.

Continue by drawing the circle representing the coil.

7 Press Shift and click the Ellipse/Circle (Centered) toolbar button again. In the Circle dialog box, specify a circle according to the following table:

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Radius</td>
<td>0.01</td>
</tr>
<tr>
<td>Base</td>
<td>Center</td>
</tr>
<tr>
<td>r</td>
<td>0.03</td>
</tr>
<tr>
<td>z</td>
<td>0</td>
</tr>
</tbody>
</table>

8 Click OK to close the dialog box and finish the model geometry.
Double-click **GRID** in the status bar at the bottom of the GUI to hide the grid lines.

**Model geometry.**

**OPTIONS AND SETTINGS**

You can make your simulation easier by defining variables that you can use later when defining your problem.

**Constants**

1. To define global constants, select **Constants** from the **Options** menu. This opens the **Constants** dialog box. This model uses only two constant parameters, namely the voltage applied to the coil and the conductivity.

2. Enter names, expressions, and descriptions for these constants according to the table below (the descriptions are optional):

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>V0</td>
<td>1[V]</td>
<td>Voltage applied to coil</td>
</tr>
<tr>
<td>sigma</td>
<td>5.998e7[S/m]</td>
<td>Conductivity, coil</td>
</tr>
</tbody>
</table>

3. Click **OK** to close the dialog box.
Coupling Variables

This model uses scalar coupling variables for integrating the current density and the magnetic energy, to calculate the inductance and resistance of the coil.

1. From the Options menu, select Integration Coupling Variables>Subdomain Variables.
2. In the Subdomain Integration Variables dialog box, specify the variable names and expressions according to the following tables. Use the default Integration order 4 and keep the Global destination check boxes selected. Put each coupling variable on a separate row in the table on the Source page.

<table>
<thead>
<tr>
<th>NAME</th>
<th>SUBDOMAINS 1, 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>W_m</td>
<td>2<em>pi</em>r*Wmav_emqa</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>NAME</th>
<th>SUBDOMAIN 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>I_tot</td>
<td>Jphi_emqa</td>
</tr>
</tbody>
</table>

3. Click OK.

Scalar Expressions

Use scalar expression variables for completing the inductance and resistance calculations.

1. From the Options menu, select Expressions>Global Expressions.
2. In the Global Expressions dialog box, specify the variable names and expressions according to the following table:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>L_e</td>
<td>imag(V0/I_tot)/(2<em>pi</em>freq)</td>
<td>Coil inductance (Ohm’s law)</td>
</tr>
<tr>
<td>L_vw</td>
<td>4*W_m/abs(I_tot)^2</td>
<td>Coil inductance (virtual work)</td>
</tr>
<tr>
<td>R_c</td>
<td>real(V0/I_tot)</td>
<td>Coil resistance</td>
</tr>
</tbody>
</table>

3. Click OK.

Physics Settings

Scalar Variables

1. Open the Application Scalar Variables dialog box by selecting Scalar Variables from the Physics menu.
2. The solution should be calculated for a range of frequencies. Type freq in the Expression field for nu_emqa. Leave the permittivity and the permeability of vacuum at their default values.
3 Click **OK**.

**Subdomain Settings**

1 From the **Physics** menu, select **Subdomain Settings**.

2 The domain properties on the **Electric Parameters** page for this model are given in the following table. Use the default values for the properties that are not given here for Subdomain 2, and for all properties for Subdomain 1.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>$V_{loop}$</td>
<td>$V_0$</td>
</tr>
<tr>
<td>$\sigma$</td>
<td>$\sigma$</td>
</tr>
</tbody>
</table>

3 Click **OK**.

**Boundary Conditions**

1 From the **Physics** menu, select **Boundary Settings**.

2 In the **Boundary Settings** dialog box, give the boundary conditions according to the following table.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 1</th>
<th>BOUNDARIES 2, 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Axial symmetry</td>
<td>Magnetic insulation</td>
</tr>
</tbody>
</table>

Boundary 1 is the vertical boundary along the $z$-axis. The axial symmetry boundary condition makes sure that the solution is symmetric around this axis. The magnetic insulation condition sets the magnetic potential $A_\phi$ to zero along the Boundaries 2 and 3.

3 Click **OK**.

**Mesh Generation**

In this model, as in many others dealing with electromagnetic phenomena, the effects on the fields near interfaces between materials are of special interest. To get accurate results make sure you generate a mesh that is very fine in these areas. To achieve this, refine the mesh once.

1 Select **Initialize Mesh** from the **Mesh** menu or click the **Initialize Mesh** button on the Main toolbar to generate a default mesh.

2 Select **Refine Mesh** in the **Mesh** menu or click the **Refine Mesh** button on the Main toolbar.
To get a better view of the interesting region of the mesh, select **Zoom Window** from the **Options** menu and then draw a rectangular window around the coil and the cylinder.

The mesh for the inductance computation.

**COMPUTING THE SOLUTION**

1. Open the **Solver Parameters** dialog box by selecting **Solver Parameters** in the **Solve** menu, or by clicking the **Solver Parameters** button. In the **Solver** list, select **Parametric**. Type `freq` in the **Parameter name** edit field, and `linspace(10,2000,20)` in the **Parameter values** edit field. This means that the solution is computed for 20 equally-spaced values of `freq`, running from 10 Hz through 2000 Hz.

2. Click **OK** to close the dialog box.

3. Select **Solve** in the **Solve** menu, or click the **Solve** button on the Main toolbar, to compute the solution.

**POSTPROCESSING AND VISUALIZATION**

After the solution is calculated, a surface plot is automatically shown for the magnetic flux density. The buttons on the plot toolbar are shortcuts to get plots of other types. Full control over the plot generation is provided in the **Plot Parameters** dialog box.
1 From the Postprocessing menu, select Plot Parameters.
2 In the Plot type area on the General page, select the Surface and Geometry edges check boxes.
3 Click the Surface tab. From the Predefined quantities list on the Surface Data page, select Azimuthal Induction Currents, Vector Potential (emqa)>Total current density, phi component.
4 Click Apply to generate the plot.
5 By default, the plot is rendered for the last entry in the frequency list. To view another solution, select the desired frequency from the Parameter value list on the General page. Click OK to generate the plot and close the dialog box.

The resistance and the inductance are calculated for all frequencies and can be visualized using global plots.

1 Open the Global Variables Plot dialog box from the Postprocessing menu. Make sure all solutions in the Solutions to use list are selected. Note that the global expressions that you have entered earlier are shown in the Predefined quantities list.
2 Select Coil resistance from the Predefined quantities list and click the > button in order to add the coil resistance into the Quantities to plot list.
3 Click Apply to generate a plot of the resistance as a function of the frequency.

![Coil resistance graph](image)

Resistance (Ω) as a function of frequency (Hz).

You can visualize the calculated values of the inductance in the same way as the resistance; Figure 4-12 on page 136, for example, shows the result for $L_{vw}$, the inductance calculated using the method of virtual work. Note that you first need to remove the previous variables from the Quantities to plot list in order to avoid
plotting several variables in the same graph. To remove the quantities simply select them and click the < button. To reproduce the $L_{vw}$ plot in a new figure window proceed as follows:

4 Make sure the New figure option is selected from the Plot in list in the Global Variables Plot dialog box.

5 Select all the quantities in the Quantities to plot list and click < to remove them. Now select Coi Inductance from the Predefined quantities list, click the > button, then click Apply.

The relative difference between the results from the two calculation methods for the inductance gives an indication of the errors introduced from the discretization and the finite geometry. Visualize this entity by executing the following instructions:

6 Make sure the New figure option is selected from the Plot in list in the Global Variables Plot dialog box.

7 Select all the quantities in the Quantities to plot list and click < to remove them. In the Expression edit field type $\text{abs} \left( \frac{(L_{vw} - L_{e})}{L_{vw}} \right)$, click the > button and then click OK.
Integrated Square-Shaped Spiral Inductor

Introduction

This example presents a model of a micro-scale square inductor, used for LC bandpass filters in microelectromechanical systems (MEMS).

The modeling is carried out in two steps. Because this is a static simulation, it is possible to compute the electric and magnetic fields separately. The first step computes the currents in the inductor. You then introduce these currents as sources for the magnetic flux computations in a second step.

The purpose of the model is to calculate the self-inductance of the microinductor. Given the magnetic field, you can compute the self-inductance, $L$, from the relation

$$ L = \frac{2W_m}{I^2} $$

where $W_m$ is the magnetic energy and $I$ is the current. The model includes a boundary condition that sets the current to 1 A. The self-inductance $L$ is the $L_{11}$ component of the inductance matrix, available for postprocessing as a predefined variable (L11_emqa).

Model Definition

The model geometry consists of the spiral-shaped inductor and the air surrounding it. The subdomain corresponding to air can be done arbitrary large depending on the position of the device. Figure 4-13 below shows the inductor and air subdomains used in the model. The outer dimensions of the model geometry are around 0.3 mm.
Figure 4-13: Inductor geometry and the surrounding subdomain.

The model equations are the following:

\[-\nabla \cdot (\sigma \nabla V - J^e) = 0\]
\[\nabla \times (\mu_0^{-1} \mu_r^{-1} \nabla \times A) + \sigma \nabla V = J^e\]

In the equations above, \(\sigma\) denotes the electric conductivity, \(A\) the magnetic vector potential, \(V\) the electric scalar potential, \(J^e\) the externally generated current density vector, \(\mu_0\) the permittivity in vacuum, and \(\mu_r\) the relative permeability.

The electric conductivity in the coil is set to \(10^6\) S/m and 1 S/m in air. The conductivity of air is arbitrarily set to a small value in order to avoid singularities in the solution, but the error becomes small as long as the value of the conductivity is small.

The constitutive relation is specified with the expression

\[B = \mu_0 \mu_r H\]

where \(H\) denotes the magnetic field.
The boundary conditions are of three different types corresponding to the three different boundary groups; see Figure 4-14 (a), (b), and (c) below.

Figure 4-14: Boundaries with the same type of boundary conditions.

The boundary condition for the boundary highlighted in Figure 4-14 (a) is a magnetic insulating boundary with a port boundary condition. For the boundaries in Figure 4-14 (b), both magnetic and electric insulation prevail. The last set of boundary conditions, Figure 4-14 (c), are magnetically insulating but set to a constant potential of 0 V (ground).
Results

Figure 4-15 shows the electric potential in the inductor and the magnetic flux lines. The thickness of the flow lines represents the magnitude of the magnetic flux. As expected, this flux is largest in the middle of the inductor.

![Electric potential and magnetic flux lines]

**Figure 4-15: Electric potential in the device and magnetic flux lines around the device.**

The model gives a self-inductance of 7.58e-10 H.

**Model Library path:** ACDC_Module/Electrical_Components/square_inductor

**Modeling Using the Graphical User Interface**

**MODEL NAVIGATOR**

1. Start COMSOL Multiphysics.
2. In the Model Navigator, click the Multiphysics button.
3. Select 3D from the Space dimension list.
From the Application Modes tree, select AC/DC Module>Statics, Magnetic>Magnetostatics, Vector Potential>Gauged vector potential.

Click the Add button.

Open the Application Mode Properties dialog box by clicking the corresponding button.

Set the property Potentials to Electric and magnetic.

Click OK to close the Application Mode Properties dialog box.

Click OK to close the Model Navigator.

OPTIONS AND SETTINGS

From the Options menu, select Axes/Grid Settings.

In the Axes/Grid Settings dialog box, click the first clear the Auto check box on the Axis page. Specify axis settings according to the following table:

<table>
<thead>
<tr>
<th>AXIS</th>
<th>MIN</th>
<th>MAX</th>
</tr>
</thead>
<tbody>
<tr>
<td>x</td>
<td>-50</td>
<td>300</td>
</tr>
<tr>
<td>y</td>
<td>-50</td>
<td>300</td>
</tr>
<tr>
<td>z</td>
<td>-25</td>
<td>25</td>
</tr>
</tbody>
</table>

Click OK.
GEOMETRY MODELING

Start the modeling of this geometry by creating a number of solid block objects that form the base of the inductor. Use the data for the blocks given in the table below.

<table>
<thead>
<tr>
<th>NAME</th>
<th>LENGTH</th>
<th>X</th>
<th>Y</th>
<th>Z</th>
<th>X</th>
<th>Y</th>
<th>Z</th>
</tr>
</thead>
<tbody>
<tr>
<td>BLK1</td>
<td>51</td>
<td>22</td>
<td>20</td>
<td>-20</td>
<td>99</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>BLK2</td>
<td>22</td>
<td>98</td>
<td>20</td>
<td>9</td>
<td>121</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>BLK3</td>
<td>232</td>
<td>22</td>
<td>20</td>
<td>9</td>
<td>219</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>BLK4</td>
<td>22</td>
<td>188</td>
<td>20</td>
<td>219</td>
<td>31</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>BLK5</td>
<td>192</td>
<td>22</td>
<td>20</td>
<td>49</td>
<td>9</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>BLK6</td>
<td>22</td>
<td>148</td>
<td>20</td>
<td>49</td>
<td>31</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>BLK7</td>
<td>152</td>
<td>22</td>
<td>20</td>
<td>49</td>
<td>179</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>BLK8</td>
<td>22</td>
<td>108</td>
<td>20</td>
<td>179</td>
<td>71</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>BLK9</td>
<td>112</td>
<td>22</td>
<td>20</td>
<td>89</td>
<td>49</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>BLK10</td>
<td>22</td>
<td>68</td>
<td>20</td>
<td>89</td>
<td>71</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>BLK11</td>
<td>62</td>
<td>22</td>
<td>20</td>
<td>89</td>
<td>139</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>BLK12</td>
<td>51</td>
<td>22</td>
<td>20</td>
<td>249</td>
<td>139</td>
<td>0</td>
<td></td>
</tr>
</tbody>
</table>

When you have added all blocks, click the Zoom Extents button on the Main toolbar. The geometry in the drawing area should then look like that in the following
2 From the Draw menu, open the Work-Plane Settings dialog box.

3 On the Face Parallel page, expand the BLK12 node in the Face selection tree, and select Face 3.

4 Click OK to close the Work-Plane Settings dialog box.

5 From the Options menu, select Axes/Grid Settings.

6 Specify axis and grid settings as in the following table; when done, click OK.

<table>
<thead>
<tr>
<th>AXIS</th>
<th>GRID</th>
</tr>
</thead>
<tbody>
<tr>
<td>x min</td>
<td>-30</td>
</tr>
<tr>
<td>x max</td>
<td>10</td>
</tr>
<tr>
<td>y min</td>
<td>-130</td>
</tr>
<tr>
<td>y max</td>
<td>30</td>
</tr>
</tbody>
</table>

| x spacing | 5    |
| Extra x   | -27  |
| y spacing | 5    |
| Extra y   | -98  22 |
7 Click the **Line** button on the Draw toolbar, and click at \((-27, -120), (-27, 22), (0, 22), (0, 0), (-5, 0), (-5, -98), (0, -98),\) and \((0, -120)\). Finally right-click to create a composite solid object.

8 From the **Draw** menu, open the **Extrude** dialog box.

9 Set the **Distance** to 22, then click **OK** to create the extruded object.

10 Select all geometry objects by pressing Ctrl+A or choosing the **Select All** option from the **Edit** menu. Open the **Create Composite Object** dialog box. Be sure to clear the **Keep interior boundaries** check box, and verify that all objects are selected. Click **OK** to create the composite object as the union of all objects.

11 Now, draw a block that surrounds the inductor. Set the length of the sides to 320, 300, and 200, for the \(x\)-, \(y\)-, and \(z\)-coordinates respectively. Set the axis base point to \((-20, -25, -100)\).

12 Press Ctrl+A to select both the block object and the composite object CO1.

13 Open the **Create Composite Object** dialog box. Select the **Keep interior boundaries** check box and click **OK**.

14 All distances in this model are given in \(\mu m\), so you must scale the geometry with a factor of \(10^{-6}\) in order to obtain the correct size. Do this by clicking the **Scale**
button, and then giving the value $10^{-6}$ for all three scaling factors. After that, click the **Zoom Extents** button on the Main toolbar to be able to see the object.

**PHYSICS SETTINGS**

*Subdomain Settings*

1. From the **Physics** menu, choose **Subdomain Settings**.
2. Enter the following settings:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN 1</th>
<th>SUBDOMAIN 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\sigma$</td>
<td>1</td>
<td>$10^6$</td>
</tr>
</tbody>
</table>

Setting the conductivity to zero in air (Subdomain 1) would lead to a numerically singular problem. You avoid this problem by setting the conductivity to $1 \text{ S/m}$—a value chosen to be much smaller than the electric conductivity in the inductor, $10^6 \text{ S/m}$, so that the electric and magnetic fields are only marginally affected.

3. Click **OK**.

*Boundary Conditions*

1. From the **Physics** menu, choose **Boundary Settings**.
2 Specify boundary conditions according to the following table:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 5</th>
<th>BOUNDARIES 75, 76</th>
<th>BOUNDARIES 1–4, 10</th>
</tr>
</thead>
<tbody>
<tr>
<td>Electric</td>
<td>Port</td>
<td>Ground</td>
<td>Electric</td>
</tr>
<tr>
<td>Magnetic</td>
<td>Magnetic</td>
<td>Magnetic</td>
<td>Magnetic</td>
</tr>
<tr>
<td>Parameters</td>
<td>insulation</td>
<td>insulation</td>
<td>insulation</td>
</tr>
<tr>
<td>Port</td>
<td>Use port as import</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The Boundaries 5 and 76 are the two ends of the inductor.

3 Click OK.

**MESH GENERATION**

1 From the Mesh menu, open the Free Mesh Parameters dialog box.
2 On the Global page, select Coarser from the Predefined mesh sizes list.
3 Click the Subdomain tab. Select Subdomain 2 and set the Maximum element size to 3e-5.
4 Click the Remesh button to generate the mesh. Click OK.

**COMPUTING THE SOLUTION**

Click the Solve button on the Main toolbar to start solving

This model uses an efficient approach for handling the gauge fixing with the SOR gauge smoothers for the geometric multigrid preconditioner; see “Solver Settings for Numerical Gauge Fixing in Magnetostatics” on page 114 in the AC/DC Module User’s Guide for more information.

**POSTPROCESSING AND VISUALIZATION**

Now add a visualization of the magnetic flux density lines to illustrate the results from the simulation.

1 From the Options menu, choose Suppress>Suppress Boundaries.
2 In the Suppress Boundaries dialog box, select Boundaries 1–4, 10, and 75. Click OK.
3 Open the Plot Parameters dialog box and clear the Slice and Geometry edges check boxes, and select Streamline and Boundary as plot types.
4 On the Boundary page, choose Magnetostatics (emqa)>Electric potential from the Predefined quantities list.
5 Select hot from the Colormap list.
6 Click the Streamline tab. In the Streamline data area, select Magnetic flux density from the Predefined quantities list. On the Start Points page, set the Number of start points to 31.

7 Change the Line type to Tube and click the Tube Radius button. Select the Radius data check box and select Magnetic flux density, norm as Radius data. Set the Radius scale factor to 0.7. Click OK to close the Tube Radius Parameters dialog box.

8 Click the Line Color tab and then click the Use expression option button.

9 Click the Color Expression button and select Electric potential as Streamline color data. Clear the Color scale check box. Click OK to close the Streamline Color Expression dialog box.

10 Click the Advanced button and set the Maximum number of integration steps to 100. Click OK to close the Advanced Streamline Parameters dialog box.

11 Click OK to close the Plot Parameters dialog box.

12 For improved visualization click the Headlight button on the Camera toolbar.

To extract the self-inductance, select Data Display>Global from the Postprocessing menu and then select Magnetostatics (emqa)>Inductance matrix, element 11 from the Predefined quantities list. Click OK. The value of the self-inductance appears in the message log.
Modeling Using the Programming Language

You can create the Inductor model from COMSOL Script or MATLAB using COMSOL Multiphysics command-line functions. The following script contains all the steps for defining the model, computing the solution, visualizing the results, and evaluating the inductance:

```matlab

% Start by defining the geometry.
clear fem

g = {
    block3(51,22,20,'corner',[-20 99 0]),
    block3(22,98,20,'corner',[9 121 0]),
    block3(232,22,20,'corner',[9 219 0]),
    block3(22,188,20,'corner',[219 31 0]),
    block3(192,22,20,'corner',[49 9 0]),
    block3(22,148,20,'corner',[49 31 0]),
    block3(152,22,20,'corner',[49 179 0]),
    block3(22,108,20,'corner',[179 71 0]),
    block3(112,22,20,'corner',[89 49 0]),
    block3(22,68,20,'corner',[89 71 0]),
    block3(62,22,20,'corner',[89 139 0]),
    block3(51,22,20,'corner',[249 139 0]),
};

l2 = line2([-25 -25 0 0 -5 -5 0 0],[-120 22 22 0 0 -98 -98 -120]);

g{end+1} = extrude(l2,'Distance',22,
    'Wrkpln',[249 249 600;139 139 139;0 351 0]);

c01 = geomcomp(g,'face','all','edge','all');

b1 = block3(320,300,200,'corner',[-20 -25 -100]);

c02 = geomcomp({c01 b1});

fem.geom = scale(c02,1e-6,1e-6,1e-6);

% The physical properties of the model is defined in the
% application mode structure. Continue the modeling by creating
% this structure. The commands to use are given below.
clear appl

appl.mode='QuasiStatics';
appl.prop.analysis='static';
appl.equ.sigma={'1','1e6'};

appl.bnd.inport={'1','0','0'};
appl.bnd.eltype={'port','V0','nJ0'};
```

INTEGRATED SQUARE-SHAPED SPIRAL INDUCTOR | 155
appl.bnd.magtype='A0';
appl.bnd.ind=zeros(1,76);
appl.bnd.ind([5])=1;
appl.bnd.ind([75 76])=2;
appl.bnd.ind([1 2 3 4 10])=3;

fem.appl=appl;

fem=multiphysics(fem);

% Generate the mesh, by issuing the following command.
% fem.mesh=meshinit(fem, ...
% 'hauto',7, ...
% 'hmaxsub',[2,3e-5]);

% Generate the extended mesh structure.
% fem.xmesh=meshextend(fem);

% You can now solve the problem.
% fem.sol=femstatic(fem);

% Visualize the result of the simulation, with the following
% properties to the plot function.
% nBdl = setdiff(1:76,[1:4 10 75]);
postplot(fem,...
  'bd1',nBdl,...
  'cont', 'internal',...
  'tridata','V',...
  '=trabar', 'on',...
  'flowtubescale',0.3,...
  'flowcolor','k',...
  'flowdata',{Bx,'By','Bz'},...
  'flowlines',50,...
  'flowback','off',...
  'flowsteps',150,...
  'scenelight','on',...
  'axisequal','on',...
  'axisvisible','off');

% The inductance can be calculated with the command
inductance=postinterp(fem, 'L11_emqa',[0;0;0])
Inductance of a Power Inductor

The model shows an inductance calculation on a large 3D geometry using higher-order vector elements and memory-efficient iterative solver settings.

Introduction

Power inductors are a central part of many low-frequency power applications. They are, for example, used in switched power supplies and DC-DC converters. The inductor is used in conjunction with a high-power semiconductor switch that operates at a certain frequency, stepping up or down the voltage on the output. The relative low voltage and high power consumption puts high demands on the design of the power supply and especially on the inductor, which must be designed with respect to switching frequency, current rating, and warm environments.

A power inductor usually has a magnetic core to increase its inductance value, reducing the demands for a high frequency while keeping the sizes small. The magnetic core also reduces the electromagnetic interference with other devices. There are only crude analytical formulas or empirical formulas available for calculating impedances, so computer simulations or measurements are necessary in the design of these inductors. This model uses a design drawn in an external CAD software, imports the geometry to COMSOL Multiphysics, and finally calculates the inductance from the specified material parameters and frequency.

Model Definition

The model uses the Quasi-static application mode taking electric induced and inductively induced currents into account. This formulation, often referred to as an AV formulation, solves both for the magnetic vector potential $\mathbf{A}$ and the electric potential $V$. In addition, it must also solve for the Gauge fixing on the vector potential,

$$\nabla \cdot \mathbf{A} = 0$$

At low frequencies the inductance is almost constant. For high frequencies the capacitive effects play a role, and the permeability usually decreases, causing a frequency-dependent inductance. A model limiting factor in increasing the frequency is the skin depth, so at a frequency in the vicinity of 10 kHz the model either needs a
finer mesh at the conductor boundary or an impedance boundary condition. The following table lists the material properties used in this model:

<table>
<thead>
<tr>
<th>MATERIAL PARAMETER</th>
<th>COPPER</th>
<th>CORE</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \sigma )</td>
<td>( 5.997 \times 10^7 )</td>
<td>10</td>
</tr>
<tr>
<td>( \varepsilon_r )</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>( \mu_r )</td>
<td>1</td>
<td>( 10^3 )</td>
</tr>
</tbody>
</table>

Using a low conductivity for the surrounding air improves the stability of the iterative solver. This has negligible impact on the solution.

The outer boundaries are mainly magnetic insulation and electric insulation,

\[
\mathbf{n} \times \mathbf{A} = 0 \\
\mathbf{n} \cdot \mathbf{J} = 0
\]

For the boundaries to the conductor, one end is grounded, and the other end has a port boundary condition. The port boundary condition gives the admittance of the inductor, and you can calculate the inductance from the formula,

\[
L_{11} = \text{Im}\left(\frac{1}{Y_{11}}\right)/\omega
\]

where \( \omega \) is the angular frequency, and \( \text{Im}(1/Y_{11}) \) is the imaginary part of the impedance.

**Computing the Solution**

An analysis using the AV formulation with gauge fixing turned on consumes large amounts of memory when you use direct solvers like UMFPACK or SPOOLES. This model has almost 200,000 degrees of freedom, so an iterative solver is necessary. The geometric multigrid (GMG) solver with the Vanka pre- and postsmoother solves this problem efficiently. Different element order defines the multigrid hierarchy, which means that a direct solver solves the problem on linear vector and Lagrange elements. The iterative solver then produce the solution for the quadratic versions of these elements.
Results and Discussion

At a frequency of 1 kHz the inductance is 92 µH, and the figure below shows the electric potential and the magnetic flux density in a combined plot.

Figure 4-16: The final plot of the power inductor, showing the potential on the coil, the magnitude of the flux density inside the ferrite core, and the direction of the same as arrows.

Model Library path: ACDC_Module/Electrical_Components/power_inductor

Modeling Using the Graphical User Interface

MODEL NAVIGATOR
1. Select 3D in the Space dimension list.
2. In the list of application modes, select AC/DC Module>Quasi-Statics,
   Electromagnetic>Electric and Induction Currents.
3. Click OK.
OPTIONS AND SETTINGS
1. From the Options menu, choose Materials/Coefficients Library. In the dialog box that appears, click the New button.
2. Type Core in the Name edit field for the new material.
3. Click the Electric tab and type the values for each material parameter listed in the table below.

<table>
<thead>
<tr>
<th>MATERIAL PARAMETER</th>
<th>CORE</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\sigma$</td>
<td>10</td>
</tr>
<tr>
<td>$\varepsilon_r$</td>
<td>1</td>
</tr>
<tr>
<td>$\mu_r$</td>
<td>1e3</td>
</tr>
</tbody>
</table>

4. Click OK.

GEOMETRY MODELING
1. From the File menu, choose Import>CAD Data From File.
2. In the Import CAD Data From File dialog box, make sure that the COMSOL Multiphysics file or All 3D CAD files is selected in the Files of type list.
3 Locate the `power_inductor.mphbin` file in the model path specified on page 159, and click Import.

4 From the Draw menu, choose Block.

5 In the dialog box that appears, define the block properties according to the table below.

<table>
<thead>
<tr>
<th>LENGTH X</th>
<th>LENGTH Y</th>
<th>LENGTH Z</th>
<th>BASE</th>
<th>AXIS BASE POINT (X, Y, Z)</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.15</td>
<td>0.12</td>
<td>0.2</td>
<td>Corner</td>
<td>(-0.07, -0.031, -0.1)</td>
</tr>
</tbody>
</table>

**PHYSICS SETTINGS**

*Scalar Variables*

1. From the Physics menu, open the Scalar Variables dialog box.
2. Type 1e3 for the frequency, `nu_emqav`. Click OK.

*Subdomain Settings*

1. From the Physics menu, open the Subdomain Settings dialog box.
2. Select Subdomain 1 and click Electric Parameters tab. Type 1 in the edit field for the electric conductivity.
3. Select Subdomain 2 and select Core from the Materials list. This is the material you defined in the Materials library earlier.
4 Select Subdomain 3 and click the **Load** button. Locate and select **Copper** in the dialog box and click **OK**.

5 Click **OK** again to close the **Subdomain Settings** dialog box.

**Boundary Conditions**

1 From the **Physics** menu, open the **Boundary Settings** dialog box.

2 Select all boundaries and make sure that the default **Magnetic insulation** is selected from the **Boundary condition** list.

3 Click the **Electric Parameters** tab. From the **Boundary condition** list, select **Electric insulation**.

4 Select Boundary 78, which is one of the boundaries for the inductor coil. From the **Boundary condition** list, choose the **Ground** boundary condition.

5 Select the other coil boundary, which is number 79. Select the **Port** boundary condition.

6 Next, click the **Port** tab, and select the **Use port as input** check box. Leave the other settings at their defaults, which is 1 for **Port number** and **Fixed current density** for **Input property**.

7 Click **OK**.

**Mesh Generation**

1 From the **Mesh** menu, open the **Free Mesh Parameters** dialog box.

2 From the **Predefined mesh sizes** list, select **Coarse** mesh size.

3 Click the **Custom mesh size** option button. Set the **Element growth rate** to 1.8, the **Mesh curvature factor** to 0.4, and the **Mesh curvature cutoff** to 0.02.

4 Click **Remesh**. When the mesher has finished, click **OK**.

**Computing the Solution**

The program can use the linear order element combination for a coarse solution and solve for the quadratic elements using the geometric multigrid solver. The linear solution is then used in the preconditioning step. COMSOL Multiphysics does this automatically with the setting selected in step 3.

1 From the **Solve** menu, open the **Solver Parameters** dialog box.

2 Click the **Settings** button. In the dialog box that appears, make sure that the **Linear system solver** node is selected to the left. Set the **Factor in error estimate** to 20.
3 Select the Coarse solver node on the left. From the Coarse solver list, select PARDISO. Set the Tolerance to 1.0e-5.

You can leave all other settings at their default values. For details on the default settings, see “Solving Large 3D Problems” on page 106 of the AC/DC Module User’s Guide.

4 Click OK to close the Linear System Solver Settings dialog.

5 On the Stationary page of the Solver Parameters dialog box, select Linear from the Linearity list. This model is linear, but the solver interprets the model as nonlinear, because of the coupling variable that the port condition introduces. Furthermore, with the additional dependent variable for the gauge fixing, the model has large differences in scale, which makes it difficult for the nonlinear solver to converge.

6 Click the Solve button.

POSTPROCESSING AND VISUALIZATION

1 From the Postprocessing menu, select Plot Parameters.

2 Make sure that the Slice, Boundary, Arrow, and Geometry edges check boxes are selected under the General tab.

3 Click the Slice tab, and select Magnetic flux density, norm from the Predefined quantities list.

4 Type 1 in the x levels edit field.

5 Click the Boundary tab, and select Electric potential from the Predefined quantities list.

6 Click the Arrow tab, and select Magnetic flux density from the Predefined quantities list.

7 In the x points, y points, and z points edit fields for the Number of points, type 20, 7, and 20, respectively.

8 From the Arrow type list, select Cone.

9 Click OK.

It is now necessary to remove some boundaries and subdomains from the plot:

10 From the Options menu, choose Suppress>Boundaries. Select all boundaries that are part of the coil. Click Apply, then click the Invert Suppression button, and finally click Cancel.

11 From the Options menu, choose Suppress>Subdomains. Select Subdomain 1 and click OK.
Click on the **Postprocessing mode** button, and the plot in Figure 4-16 on page 159 should appear after proper rotation and zoom operations.

To get the inductance value, choose **Data Display>Global** from the **Postprocessing** menu. Type `\text{imag}(1/Y1_{\text{rf}_{\text{emqav}}})/\omega_{\text{emqav}}` in the **Expression** edit field.

Click **OK**.

You should get a value close to 92 µH in the message log at the bottom of the user interface.
Planar Transformer on PCB

This model does a static analysis of a planar transformer integrated onto a printed circuit board.

Introduction

A planar transformer is a transformer that is integrated onto a printed circuit board (PCB). They can either be manufactured as standalone devices, or integrated into the PCB of a module. The planar structure improves the cooling characteristics and gives the device a low profile. Therefore, the main use of planar transformers are in power supplies and DC/DC converters where a slim high-power design is crucial. In this model, you perform a static analysis of the inductance and capacitance parameter values. The entire layout, including the footprint of the transformer ferrite core, is imported from an ODB++(X) file. It is imported using the ECAD Import feature, which reads the layout and automatically creates the 3D geometry of the PCB and the ferrite core.

Model Definition

The model performs a stationary analysis of the inductive and capacitive effects of a planar transformer design. In statics and for low frequency, the electric and magnetic fields are de-coupled, so it is therefore possible to separate the inductance analysis from the capacitance analysis. For the inductance analysis you use the Magnetostatics application mode, and for the capacitive analysis you use the Electrostatics application mode.

The Magnetostatics application mode solves both for the magnetic vector potential, \( A \), using Ampère’s law, and the electrostatics potential, \( V \), using Poisson’s equation. Poisson’s equation is only present to calculate the currents in the coils. When you solve for the \( A \) and \( V \) potentials (AV-formulation), you can use the port boundary condition to excite a terminal. This model uses a different approach that suits iterative solvers better. Instead you assign a surface current on a boundary between two terminals (signal and ground), given by

\[
J_s = \frac{I_{\text{port}}}{h_{\text{metal}}}
\]
where \( I_{\text{port}} \) is the current that flows in the coil and \( h_{\text{metal}} \) is the thickness of the metal layer. This approach works better than the port boundary condition when the terminals are located at interior boundaries.

For the Electrostatics application mode the port boundary condition works fine. You model the coils with a very high permittivity to force the voltage to be almost constant in the coil domains. It is also possible to deactivate the coil domains from the simulation and replace them with a fixed potential boundary condition. This involves specifying a boundary condition on several boundary groups, so the former approach is easier to setup.

**Inductance Analysis**

The energy method is an accurate approach to calculate inductances. In this method you first calculate the self inductance for the primary and secondary coil of the transformer. You do this by exciting a current through one coil while the other coil is passive. Then you excite a current through both coils in such a way that the flux linkage is additive. This means that the current flows in the same direction (clockwise or counter clockwise) in both coils. The total energy from this simulation then gives the mutual inductance between the coils. The formulas for these calculations are presented in “Calculating Lumped Parameters Using the Energy Method” on page 66 of the AC/DC Module User’s Guide, and they are repeated here for convenience.

\[
L_{ii} = \frac{2}{I_i^2} \int_{\Omega} W_m d\Omega
\]

\[
L_{ij} = \frac{1}{I_i I_j} \int_{\Omega} W_m d\Omega - \frac{1}{2} \left( L_{ii}^{-1} I_i L_{jj}^{-1} I_j \right)
\]

\[
I_j = \begin{cases} 
0 & j \neq i \\
I_i & j = i 
\end{cases}
\]

\[
I_k = \begin{cases} 
0 & k \neq i, j \\
I_i & k = i \\
I_j & k = j 
\end{cases}
\]

This means that you have to do three simulations:

- \( I_1 = 1 \text{ A} \) and \( I_2 = 0 \text{ A} \)
- \( I_1 = 0 \text{ A} \) and \( I_2 = 1 \text{ A} \)
- \( I_1 = 1 \text{ A} \) and \( I_2 = 1 \text{ A} \)

In COMSOL Multiphysics you can do this by using the parameter sweep, where you sweep a parameter called \( \text{port} \) that takes the values 1, 2, and 3. The \( \text{port} \) parameter controls the surface currents that you apply on the primary and secondary coils using
the if operator, see “The if Operator” on page 166 of the COMSOL Multiphysics User’s Guide. The following expressions corresponds to the previous list:

- \( J_{\text{sport1}} = \text{if}(\text{port}==2,0,I_{\text{port1}}/h_{\text{metal}}) \)
- \( J_{\text{sport2}} = \text{if}(\text{port}==1,0,I_{\text{port2}}/h_{\text{metal}}) \)

The variable \( h_{\text{metal}} \) holds the thickness of the copper layer that the currents are applied to. When you have done the sweep, it is necessary to access different solutions in the expression for the mutual inductance, \( L_{ij} \). To do this you use the with-operator, see “The with Operator” on page 166 of the COMSOL Multiphysics User’s Guide. The expressions for the three inductances then become:

- \( L_{11} = 2*\text{with}(1,\text{intWm})/I_{\text{port1}}^2 \)
- \( L_{22} = 2*\text{with}(2,\text{intWm})/I_{\text{port2}}^2 \)
- \( L_{12} = \text{with}(3,\text{intWm})/(I_{\text{port1}}*I_{\text{port2}})-0.5*(I_{\text{port1}}/I_{\text{port2}}*L_{11}+I_{\text{port2}}/I_{\text{port1}}*L_{22}) \)

It does not matter for which solution you evaluate these expressions for, because the with operator always access the solution given in the first argument.

**CAPACITANCE ANALYSIS**

Capacitive effects can be quite important for planar transformers, because they sometimes operate at frequencies in the MHz range. Here you do an analysis of the capacitance between the coils when each coil have a constant potential. You set the port boundary condition on the two terminals at the primary coil and let the two terminals at the secondary coil be grounded. You get the capacitance automatically through the \( C_{11} \) variable, which comes in two versions. The variable \( C_{11\_\text{emes}} \) calculates the capacitance using the normal current density, which can suffer from numerical errors in 3D. The other variable, \( C_{11\_\text{rf\_emes}} \), uses stored reaction terms from the voltage constraint, and gives the same accuracy as weak constraints. For more details, see “Lumped Parameters” on page 76 of the AC/DC Module User’s Guide.

**Results and Discussion**

All lumped parameters are calculated by the parameter sweep of the port variable although it is not necessary to calculate the capacitance between coils more than once. This step is so fast to calculate so it hardly makes any difference compared to the much
more time consuming magnetostatic calculation. The results are summarized in Table 4-1 below.

<table>
<thead>
<tr>
<th>PARAMETER</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>L11</td>
<td>15.17 µH</td>
</tr>
<tr>
<td>L12</td>
<td>15.17 µH</td>
</tr>
<tr>
<td>L22</td>
<td>15.11 µH</td>
</tr>
<tr>
<td>C11_emes</td>
<td>2.84 pF</td>
</tr>
</tbody>
</table>

The holes in the PCB made for the transformer core are necessary to effectively link the flux between the two coils. In Figure 4-17 you can clearly see how the magnetic flux density follows the core through both coils and around on the outside.

*Figure 4-17: The plot shows the electrostatic potential for the two coil layers and the magnetic flux density as arrows.*

**Model Library path:** ACDC_Module/Electrical_Components/planar_transformer
Modeling Using the Graphical User Interface

MODEL NAVIGATOR
1. Select 3D from the Space dimension list.
2. Select the application mode AC/DC Module>Statics, Magnetic>Magnetostatics.
3. Click the Multiphysics button followed by the Add button.
4. Select the application mode AC/DC Module>Statics, Electric>Electrostatics.
5. Click Add to add this application mode to the model.
6. Click OK to close the Model Navigator.

GEOMETRY MODELING
The major part of the geometry is imported using the ECAD Import tool, which automatically reads a PCB layout and extrudes the layers to a 3D geometry. The ODB++ file contains the different layers of the PCB. It also contains footprint layers for the ferrite core of the transformer. By doing three separate import steps it is possible to create the full geometry of the PCB board with traces, the holes for the ferrite core, and the actual ferrite core.

1. Click the Block button on the Draw toolbar.
2. In the Block dialog box, click the Center option button, and then specify the dimension according to the following table:

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Length (X, Y, Z)</td>
<td>(0.022, 0.016, 0.005)</td>
</tr>
<tr>
<td>Axis base point (x, y, z)</td>
<td>(0, 0, 0.000325)</td>
</tr>
</tbody>
</table>

3. From the File menu, choose Import>ECAD Import.
4. In the dialog box that appears, browse to the file called planar_transformer_layout.xml. It is located in the same folder as specified by the Model Library Path on page 168. This path originates from the folder models under the COMSOL Multiphysics installation folder.
5. Click Import when you have selected the file.
6. Then the ECAD Import Options dialog box appears. Go to the Layers tab and clear the Import check box for the layer named THROUGH.HOLES. This layer represents the holes for the ferrite core, which are neglected at this stage.
7. Click OK to start importing the geometry. After the geometry objects have been imported, the program automatically switch to Subdomain mode. It does this to
add named subdomain and boundary groups, which helps you select the subdomains or boundaries that are electrically connected.

8 Choose Import>ECAD Import from the File menu again, select the same file as before, and click Import.

9 On the ECAD page you choose Metal shells from the Type of import list and clear the Import dielectric regions check box.

10 Go to the Layers page and clear the Import check box for the layers named TOP.LAYER, INNER.LAYER, BOTTOM.LAYER, and VIAS.

11 Click OK. You have now added the part of the ferrite core that goes through the PCB.

12 Once again, choose Import>ECAD Import from the File menu, select the same file, and click Import.

13 On the ECAD page, choose By layer in the Grouping of geometries list.
Go to the **Layers** page and make the changes specified in the table below. An empty cell in the table means that the corresponding cell in the dialog box should be left unchanged.

<table>
<thead>
<tr>
<th>NAME</th>
<th>THICKNESS [MM]</th>
<th>IMPORT</th>
</tr>
</thead>
<tbody>
<tr>
<td>UPPER.COMP</td>
<td>0.75</td>
<td>selected</td>
</tr>
<tr>
<td>UPPER.DIST</td>
<td>0.25</td>
<td>selected</td>
</tr>
<tr>
<td>TOP.LAYER</td>
<td></td>
<td>cleared</td>
</tr>
<tr>
<td>TOP.LAYER.DIEL</td>
<td></td>
<td>cleared</td>
</tr>
<tr>
<td>INNER.LAYER</td>
<td></td>
<td>cleared</td>
</tr>
<tr>
<td>INNER.LAYER.DIEL</td>
<td></td>
<td>cleared</td>
</tr>
<tr>
<td>BOTTOM.LAYER</td>
<td></td>
<td>cleared</td>
</tr>
<tr>
<td>LOWER.DIST</td>
<td>0.25</td>
<td>selected</td>
</tr>
<tr>
<td>LOWER.COMP</td>
<td>0.75</td>
<td>selected</td>
</tr>
<tr>
<td>VIAS</td>
<td></td>
<td>cleared</td>
</tr>
<tr>
<td>THROUGH.HOLES</td>
<td></td>
<td>cleared</td>
</tr>
</tbody>
</table>

The selected layers here are outlines of the ferrite core footprints, which are used to construct the part in this case. The actual purpose of the footprint layers are for drawing figures on the top and bottom sides of the PCB board; therefore the default thickness is zero. These layers should normally be ignored when importing an ECAD file, but here you can use them to construct the ferrite core.

Click **OK** to start the final import.

Now continue by adding the faces between the terminals of the primary coil and between the terminals of the secondary coil.
16 Choose **Workplane Settings** from the **Draw** menu.

17 Select the vertical face of the primary coil that is facing you (CO1>239) and click **OK**.

18 Click the **Zoom Extent** toolbar button to get a better view of the workplane.

19 Make sure that point snapping is activated. It is if the word **SNAP** shows up black at the bottom of the main window. If not, double-click the text to activate it.

20 With point snapping activated, draw a rectangle with its upper-left corner coincident with the upper-left point of the left coil conductor, and its lower-right corner coincident with the lower-left point of the right coil conductor.

21 From the **Draw** menu, choose **Embed**.

22 Make sure that the rectangle is selected and click **OK**.

23 After embedding, you are back at the 3D geometry again. Open the **Workplane Settings** dialog box again.

24 Select the vertical face of the secondary coil that is farthest from you (CO1>365) and click **OK**.

25 You can reuse the rectangle you created earlier, so just choose **Embed** from the **Draw** menu and click **OK**.
**Options and Settings**

**Constants**
1. From the **Options** menu, choose **Constants**.
2. In the **Constants** dialog box, define the following constants with names, expressions, and (optionally) descriptions:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>h_metal</td>
<td>7.508788e-5[m]</td>
<td>Metal thickness</td>
</tr>
<tr>
<td>Iport1</td>
<td>1[A]</td>
<td>Current for port number 1</td>
</tr>
<tr>
<td>Iport2</td>
<td>1[A]</td>
<td>Current for port number 2</td>
</tr>
</tbody>
</table>

3. Click **OK**.

**Global Expressions**
1. From the **Options** menu, choose **Expressions>Global Expressions**.
2. In the **Global Expressions** dialog box, define the following variables with names, expressions, and (optionally) descriptions:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jsport1</td>
<td>if(port==2,0,Iport1/h_metal)</td>
<td>Surface current for port number 1</td>
</tr>
<tr>
<td>Jsport2</td>
<td>if(port==1,0,Iport2/h_metal)</td>
<td>Surface current for port number 2</td>
</tr>
<tr>
<td>L11</td>
<td>2*with(1,intWm)/Iport1^2</td>
<td>Self inductance of primary coil</td>
</tr>
<tr>
<td>L22</td>
<td>2*with(2,intWm)/Iport2^2</td>
<td>Self inductance of secondary coil</td>
</tr>
<tr>
<td>L12</td>
<td>with(3,intWm)/(Iport1<em>Iport2)-0.5</em>(Iport1/Iport2<em>L11+Iport2/Iport1</em>L22)</td>
<td>Mutual inductance between coils</td>
</tr>
</tbody>
</table>

3. Click **OK**.

**Integration Coupling Variables**
1. From the **Options** menu, choose **Integration Coupling Variables>Subdomain Variables**.
2. In the **Subdomain Integration Variables** dialog box, select all subdomains, and define a variable named `intWm` with the expression `Wm_emqa`. Use the default **Global destination** and **Integration order** 4.
3. Click **OK**.
PHYSICS SETTINGS

Application Mode Properties (Magnetostatics, emqa)
1 Choose the Multiphysics menu and make sure that the Magnetostatics (emqa) application mode is active.
2 From the Physics menu, choose Properties.
3 In the Application Mode Properties dialog box, choose Electric and magnetic from the Potentials list.
4 Click OK.

Subdomain Settings (Magnetostatics, emqa)
1 Go to the Physics menu and choose Subdomain Settings.
2 In the Subdomain Settings dialog box, select Subdomain 1 and type 25 in the Electric conductivity edit field.
3 Go to the Groups page in the left part of the dialog box.
4 Select the groups PRI and SEC. These groups are automatically generated by the ECAD Import and represent the primary and secondary coil regions.
5 Click the Load button to open the Materials/Coefficients Library dialog box.
6 Expand the Basic Material Properties library and choose the FR4 (Circuit Board) material. Click Apply to add this material to the model.
7 Then choose the Copper material from the same library.
8 Click OK to select the copper material for the selected groups and to close the dialog box.

9 Select the groups DIELECTRIC_INNER.LAYER.DIEL and DIELECTRIC_TOP.LAYER.DIEL. From the Library material list, choose FR4 (Circuit Board).

10 Select the group NONE, then type 1000 in the Relative permeability edit field and 25 in the Electrical conductivity edit field.

11 Go to the Subdomain page again to activate subdomain selection. Select Subdomain 6, then click the Select by group check box.

12 Choose NONE from the Group lists to use the same settings as the group NONE.

13 Click OK.

14 From the Options menu, choose Material/Coefficient Library.

15 In the Material/Coefficient Library, expand the Model item in the tree view and select the FR4 (Circuit Board) (mat2) material.
Go to the Electric page and type 25 in the Value/Expression column for the sigma row.

Click OK.

**Boundary Settings (Magnetostatics, emqa)**

1 Go to the Physics menu and choose Boundary Settings.

2 In the Boundary Settings dialog box, select Boundary 19 and choose Surface current density from the Boundary condition list.

3 Type Jsport1 in the second edit field for the Surface current density.

4 Select Boundary 488 and choose the Surface current density boundary condition again.

5 Type -Jsport2 in the second edit field for the Surface current density. The sign makes the currents in the two coils to produce an additive flux.

6 Click OK.

**Subdomain Settings (Electrostatics, emes)**

1 Choose the Multiphysics menu and make sure that the Electrostatics (emes) application mode is active.

2 Go to the Physics menu and choose Subdomain Settings.
3 In the Subdomain Settings dialog box, go to the Groups page in the left part of the dialog box.

4 Select the groups DIELECTRIC_INNER.LAYER.DIEL and DIELECTRIC_TOP.LAYER.DIEL. From the Library material list, choose FR4 (Circuit Board).

5 Then select the groups PRI and SEC and type 1e6 in the Relative permittivity edit field.

6 Click OK.

Boundary Settings (Electrostatics, ems)

1 Go to the Physics menu and choose Boundary Settings.

2 Select Boundary 1, then select the Select by group check box.

3 From the Boundary condition list, choose Zero charge/Symmetry.

4 Clear the Select by group check box and select the Interior boundaries check box.

5 Select Boundaries 15 and 21 and choose the Port boundary condition. Go to the Port page and select the Use port as input check box.

6 Select Boundaries 487 and 489, then choose the Ground boundary condition.

7 Click OK.

Mesh Parameters

1 From the Mesh menu choose Free Mesh Parameters.

2 Select Coarse from the Predefined mesh sizes list.

3 Go to the Advanced page and type 1.5 in the z-direction scale factor edit field.
4 Click **OK**. It is not necessary to create the mesh because this will automatically be done prior to the first solution step.

**COMPUTING THE SOLUTION**

1 From the **Solve** menu, choose **Solver Parameters**.
2 In the **Solver** area, select **Parametric segregated**.
3 Type `port` in the **Parameter name** edit field and `1:3` in the **Parameter values** edit field.
4 In the **Segregated groups** frame, click the **New group** button. Then type `V` in the **Components** edit field for the new group.

![Solver Parameters dialog box](image)

5 Click the **Settings** button for the first segregated group.
6 In the dialog that appears, type `40` in the **Factor in error estimate**, and then click **OK**.
7 Click the **Settings** button for the second group.
8 In the dialog that appears, select the **Linear system solver** and choose **GMRES** from the **Linear system solver** list.
9 Select **Preconditioner** and choose **Geometric multigrid** from the **Preconditioner** list.
In the same way, set SOR as Presmoother, SORU as Postsmoother, and PARDISO as Coarse solver.

Click **OK** to close the dialog box.

Repeat Steps 7 to 11 for the third segregated group.
Select the **Manual specification of segregated steps** check box. Then click the Down button for Group 2 beneath this check box, and then click the Up button for the new Group 2.

![Solver Parameters](image)

Click the **Settings** button under the **Manual specification of segregated steps** check box for Group 3.

In the dialog box that appears, type 1 in the **Damping constant** edit field.

Click **OK**.

Repeat Steps 14 to 16 for Groups 1 and 2. This ensures that the full step is taken for each segregated solve steps, which is most efficient for one-way coupled problems like this one.

Go to the **Parametric** page and select the **Manual tuning of parameter step size** check box.
19 Type 1 in the three edits fields, \textit{Initial steps size}, \textit{Minimum steps size}, and \textit{Maximum step size}. This forces the parametric solver to take integer steps for the \textit{port} parameter.

20 Click \textbf{OK} to close the \textbf{Solver Parameters} dialog box.

21 Click the \textbf{Solve} button on the Main toolbar.

\textbf{POSTPROCESSING AND VISUALIZATION}

1 From the \textbf{Postprocessing} menu, choose \textbf{Plot Parameters}.

2 In the \textbf{Plot Parameters} dialog box, go to the \textbf{Slice} page.

3 Select \textbf{Electric potential} from the \textbf{Predefined quantities} list.

4 Set the \textbf{Number of levels} in the \textit{x} to 0, click the \textbf{Vector with coordinates} option button for \textbf{z levels}, and type \textit{6e-4 4e-5} in the edit field next to the option button.

5 On the \textbf{Arrow} page, select the \textbf{Arrow plot} check box. Keep the default quantity, which is the magnetic flux density.

6 Click the \textbf{Vector with coordinates} option button for \textbf{x points}, and type 
\textit{-0.0015:0.001:0.0015} in the edit field next to the option button.
7 Type 40 in the **Number of points** edit field for **y points**, and 20 in the same edit field for **z points**.

8 Click **OK** to see the plot in Figure 4-17 on page 168.

9 To display the values for the inductances and capacitance you first go to the **Postprocessing** menu and choose **Data Display>Global**.

10 From the **Predefined quantities** list, choose **Global Expressions>L11** and click **Apply** to see the $L_{11}$ inductance value in the message log at the bottom of the main window.

11 Repeat this step for **Global Expressions>L12** and **Global Expressions>L22** to display the inductance values $L_{12}$ and $L_{22}$.

12 Choose **Electrostatics (emes)>Capacitance matrix, element 11 (from reaction charge)** to display the accurate version of the capacitance between the coils. The other capacitance value uses numerical derivatives and is therefore less accurate.
Bonding Wires to a Chip

Electronics manufacturers use bonding wires to connect pads on an integrated circuit (IC) to the pins of the package that houses it. These bonding wires introduce relatively large inductances that can introduce crosstalk and signal distortion. This model calculates the inductance and the mutual inductance between several bonding wires.

Introduction

In today’s electrical systems, high-speed communications place high demands on the packages that allow the connection of an IC to a circuit board. The most common method is to use bonding wires, which connect the pads on a semiconductor chip to the pins of a package. These bonding wires introduce relatively large inductances that can result in crosstalk and signal distortion. This model investigates the inductance of single wires and the mutual inductance between several bonding wires. The model extracts these parameters and presents them in the form of a lumped-parameter matrix, from which you can determine an impedance value. In addition, the harmonic nature of the signals results in a complex-valued matrix. Although the model extracts admittance or impedance parameters, you can also convert them to an S-parameter matrix.

Model Definition

**BONDING-WIRE MODEL**

Each bonding wire carries a current that results from an applied current. One end of the wire connects to the package, and the other end connects to a small pad on a chip; these pads cause a capacitive load (not included in this model). This example studies four wires at the corner of a package (Figure 4-18).
The model geometry, which studies the corner of an IC where four bonding wires connect a chip to a package.

The model tackles the problem using the Quasi-Statics, Electromagnetic application mode, where the solution variables are the electrostatic potential, $V$, and the magnetic vector potential, $A$. Each wire has a finite conductivity, which the model handles as a separate subdomain. Because this simulation investigates effects due to the wire, it excludes any effects from vias (vertical interconnections between layers in a multilayer circuit board) and pins in the package. As a result, the model applies the potential directly to the boundary on a side of the package close to the wire, whose other side ties to the chip. The chip is modeled as a grounded plate.

**LUMPED-PARAMETER CALCULATION**

This model uses the *port boundary condition* with the *fixed current density* mode to model the terminals that connects each bonding wire. The fixed current density mode sets a fixed current density, so the total current gets equal to 1 A. The voltage is taken as the average over each port boundary.

The extracted voltages represent a column in the impedance matrix, $Z$, which determines the relationship between the applied currents and the corresponding voltages with the formula
Thus, when $I_1 = 1$ and all the other currents are zero, the $V$ vector equals the first column of $Z$. You get the full matrix by setting each of the currents to one. With this matrix, you can calculate other types of parameter matrices. For more information on lumped parameter calculations in the AC/DC Module, see “Lumped Parameters” on page 63 in the AC/DC Module User’s Guide.

To calculate the entire matrix, you must export the model’s entire FEM structure to the COMSOL Script command line. A function called `rlcmatrix` performs the calculation, which solves all the necessary port conditions to extract the parameter matrix. See the function `rlcmatrix` on page 117 in the on-line manual AC/DC Module Reference Guide for more information.

### Results and Discussion

The inductive effects clearly dominate in this model. At a frequency of 10 MHz, the inductance matrix is

$$
\begin{bmatrix}
V_1 \\
V_2 \\
V_4 \\
V_4
\end{bmatrix} =
\begin{bmatrix}
Z_{11} & Z_{12} & Z_{13} & Z_{14} \\
Z_{21} & Z_{22} & Z_{23} & Z_{24} \\
Z_{31} & Z_{32} & Z_{33} & Z_{34} \\
Z_{41} & Z_{42} & Z_{43} & Z_{44}
\end{bmatrix}
\begin{bmatrix}
I_1 \\
I_2 \\
I_3 \\
I_4
\end{bmatrix}.
$$

Thus, when $I_1 = 1$ and all the other currents are zero, the $V$ vector equals the first column of $Z$. You get the full matrix by setting each of the currents to one. With this matrix, you can calculate other types of parameter matrices. For more information on lumped parameter calculations in the AC/DC Module, see “Lumped Parameters” on page 63 in the AC/DC Module User’s Guide.

To calculate the entire matrix, you must export the model’s entire FEM structure to the COMSOL Script command line. A function called `rlcmatrix` performs the calculation, which solves all the necessary port conditions to extract the parameter matrix. See the function `rlcmatrix` on page 117 in the on-line manual AC/DC Module Reference Guide for more information.

### Results and Discussion

The inductive effects clearly dominate in this model. At a frequency of 10 MHz, the inductance matrix is

$$
L = \begin{bmatrix}
2.6 & 0.59 & 0.0052 & 0.0039 \\
0.59 & 3.5 & 0.029 & 0.015 \\
0.0052 & 0.029 & 3.7 & 0.96 \\
0.0039 & 0.015 & 0.96 & 3.5
\end{bmatrix} \text{ nH}
$$

where the model calculates $L$ from the imaginary part of the impedance matrix, $Z$, using the relationship $\text{imag}(Z) = \omega L$. The $L$ matrix is symmetric, which is a property most lumped parameter matrices have.

It is always important to check the extracted $Z$ matrix before analyzing the other parameters, especially the ratio between the real and complex parts, and the condition number of the matrix. Furthermore, the boundary conditions create mirror wires outside the simulation domain, and they influence the extracted parameters.
Figure 4-19: This plot shows a slice plot, an arrow plot of the magnetic flux density, and a boundary plot of the current density. For this solution, the third bonding wire is used as input, giving the third column in the parameter matrix.

Model Library path: ACDC_Module/Electrical_Components/bond_wires_to_chip

Modeling Using the Graphical User Interface

MODEL NAVIGATOR
1. In the Model Navigator, select 3D in the Space dimension list.
2. In the AC/DC Module>Quasi-Statics, Electromagnetic folder, select the Electric and Induction Currents application mode.
3. Select Vector - Linear from the Element list.
4. Click OK.
OPTIONS AND SETTINGS
1 From the Options menu, choose Constants.
2 In the Constants dialog box, define the following constants with names, expressions, and (optionally) descriptions:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>sigma_pcb</td>
<td>10[S/m]</td>
<td>Conductivity, package material</td>
</tr>
<tr>
<td>epsilon_pcb</td>
<td>2.5</td>
<td>Relative permittivity, package material</td>
</tr>
</tbody>
</table>

3 Click OK.

GEOMETRY MODELING
1 From the File menu, select Import>CAD Data From File.
2 In the Import CAD Data From File dialog box, make sure that the COMSOL native format or All 3D CAD files is selected in the Files of type list.
3 Locate the bond_wires_to_chip.mphbin file, and click Import.
4 Click the Zoom Extents button on the Main toolbar.

PHYSICS SETTINGS
Scalar Variables
1 From the Physics menu, choose Scalar Variables.
2 In the Scalar Variables dialog box, change the value of the frequency, nu_omqav, to 10e6.
3 Click OK.

Subdomain Settings
1 From the Physics menu, open the Subdomain Settings dialog box.
2 Define the subdomain settings according to the following table:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAINS 1, 4, 5</th>
<th>SUBDOMAIN 2</th>
<th>SUBDOMAINS 6–13</th>
</tr>
</thead>
<tbody>
<tr>
<td>Material</td>
<td>Silicon</td>
<td>Aluminum</td>
<td></td>
</tr>
<tr>
<td>e_r</td>
<td>epsilon_pcb</td>
<td></td>
<td></td>
</tr>
<tr>
<td>σ</td>
<td>sigma_pcb</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

3 Click OK.

Boundary Conditions
1 From the Physics menu, open the Boundary Settings dialog box.
2 Select all boundaries, click the Electrical Parameters tab, and select the Electric insulation boundary condition from the Boundary Condition list.

3 Select the Interior boundaries check box to allow settings on interior boundaries.

4 Enter the other boundary settings according to the following two tables (leave all fields not specified at their default values):

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 30</th>
<th>BOUNDARY 42</th>
</tr>
</thead>
<tbody>
<tr>
<td>Electric boundary condition</td>
<td>Port</td>
<td>Port</td>
</tr>
<tr>
<td>Port number</td>
<td>1</td>
<td>2</td>
</tr>
<tr>
<td>Use port as input</td>
<td>cleared</td>
<td>cleared</td>
</tr>
<tr>
<td>Input property</td>
<td>Fixed current density</td>
<td>Fixed current density</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 81</th>
<th>BOUNDARY 80</th>
<th>BOUNDARIES 33, 45, 50, 52</th>
</tr>
</thead>
<tbody>
<tr>
<td>Magnetic boundary condition</td>
<td>Magnetic insulation</td>
<td>Magnetic insulation</td>
<td>Magnetic insulation</td>
</tr>
<tr>
<td>Electric boundary condition</td>
<td>Port</td>
<td>Port</td>
<td>Ground</td>
</tr>
<tr>
<td>Port number</td>
<td>3</td>
<td>4</td>
<td></td>
</tr>
<tr>
<td>Use port as input</td>
<td>selected</td>
<td>cleared</td>
<td></td>
</tr>
<tr>
<td>Input property</td>
<td>Fixed current density</td>
<td>Fixed current density</td>
<td></td>
</tr>
</tbody>
</table>

5 Click OK.

![Boundary Settings - Electric and Induction Currents (emu)](image)

MESH GENERATION

1 From the Mesh menu choose Free Mesh Parameters.
2 In the **Element growth rate** edit field type 1.4.
3 Click the **Remesh** button, then click **OK**.
4 From the **Options** menu select **Suppress>Suppress Boundaries**. Select Boundaries 7, 8, 10, 24, and 79. Click **OK**. Click the **Mesh mode** button to see the following figure.

![Mesh mode figure](image)

**COMPUTING THE SOLUTION**

1 From the **Solve** menu, choose **Solver Parameters**.
2 From the **Linear solver** list, select the **GMRES** solver.
3 From the **Preconditioner** list, select **Vanka**.
4 Click the **Settings** button.
5 In the **Linear System Settings** dialog box, enter 10 in the **Factor in error estimate** edit field and 200 in the **Number of iterations before restart** edit field.
6 Select **Preconditioner** for the tree view, and enter 3 in the **Number of iterations** edit field.
7 Click **OK**.
8 Click **OK** to close the **Solver Parameters** dialog box.
9 Click the **Solve** button on the Main toolbar.
POSTPROCESSING AND VISUALIZATION

1. From the Postprocessing menu, select Plot Parameters.
2. On the General page, make sure that the Slice, Boundary, Arrow, and Geometry edges check boxes are selected.
3. On the Slice page, select Magnetic flux density, norm from the Predefined quantities list.
4. Type 0 in the x levels edit field. Click the Vector with coordinates option button for the y levels. Enter 4e-3 in the corresponding edit field.
5. On the Boundary page, type \( \text{normJ}_{emqav} \times (\text{normJ}_{emqav} < 5e6[A/m^2]) + 5e6[A/m^2] \times (\text{normJ}_{emqav} \geq 5e6[A/m^2]) \) in the Expression edit field. This caps the plot of the current-density norm at the value \( 5 \times 10^6 \text{A/m}^2 \).
6. Click the Range button. Clear the Auto check box and type 0 and 5e6 in the Min and Max edit fields, respectively. Click OK.
7. In the Boundary color area, select hsv from the Colormap list.
8. On the Arrow page, select Magnetic flux density from the Predefined quantities list.
9. Click the Vector with coordinates option button for the y points. Type the coordinate 3.9e-3 in the edit field next to that option button.
10. In the x points and z points edit fields for the Number of points type 40.
11. Select the 3D arrow in the Arrow type list.
12. Click the Color button, then select the white color from the palette. Click OK.
13. Click OK in the Plot Parameters dialog box to get the plot in Figure 4-19 on page 186.

Modeling Using the Programming Language

Note: This section requires COMSOL Script or MATLAB.

PARAMETER-MATRIX CALCULATION

The rlcmatrix function goes through all the port boundary conditions, setting the Use port as input property on one port at a time, and solves the problem. To execute this script, you first need to export the FEM structure to the COMSOL Script command line. Do the following steps to get the full \( Z \) lumped parameter matrix. Note
that this requires a 64-bit platform, and that the calculation of the matrix takes about 2 hours.

1 Export the FEM structure by pressing Ctrl+F. The COMSOL Script window opens automatically.

2 Enter the following at the command prompt:

```matlab
Z = rlcmatrix(fem,'Z');
freq = postint(fem,'nu_emqav','edim',0,'dl',1);
L = imag(Z)/(2*pi*freq)*1e9
```

The output reads

```
L =

 2.6482    0.5944    0.0052    0.0039
0.5944    3.4833    0.0285    0.0149
0.0052    0.0285    3.6593    0.9607
0.0039    0.0149    0.9607    3.4919
```

This is the inductance matrix given in nH presented in “Results and Discussion” on page 185.
High Current Cables in a Circuit

This model connects two high current cables to a battery in a battery charger circuit.

Introduction

When charging a car battery, a significant amount of current can pass in the cables from the charger to the battery. The cable has two sensitive areas that cause additional voltage drop; the junction between the copper wire and the clip, and the contact junction at the battery pole. See Figure 4-20 for a complete view over the system. At high currents these junctions produce a lot of heat, which can melt the cables if the junctions suffer from high contact resistances. The contact resistance can degrade in corrosive environments.

Figure 4-20: A view of the entire system, where the cables, clips, and poles are modeled in a physical model. All other components are modeled as circuit models.

Model Definition

This model uses simple circuit models for the charger and the battery. A physical model in a separate model file contains the copper wire, clip and battery pole. Because the two cables between the battery and charger are identical, two instances of this separate model file represent the cables. The circuit models and the two identical physical models then represent the entire system.
The circuit model of the charger is simply a voltage source with a resistor in series. The resistor has a low value, so a significant amount of current can be delivered from the charger. The battery circuit model is also a voltage source but without the series resistor, because it can be neglected in comparison to the series resistor of the charger. As mentioned previously, the cables originate from the same COMSOL Multiphysics model, implementing two subcircuit instances in the circuit. The cable on the minus side of the battery also has a resistor in parallel, representing the alternative current paths to ground.

Figure 4-21: A block diagram over the entire charger system.

The physical model of the cable uses an imported geometry created in SolidWorks®, which was directly imported to COMSOL Multiphysics using the SolidWorks direct connection. After importing the geometry, it was exported to the COMSOL native format (an mphbin-file) for easier access. The cable geometry consists of a copper cable, a clip, and a battery pole, which the software treats as separate geometry objects to allow assembly modeling. Assemblies are necessary to model the relatively high contact resistance at the junctions between the different objects, because assemblies allow a discontinuity in the potential.

The contact resistance depends on several properties of the junction, like contact pressure, ambient conditions, and surface oxides, so it is hard to find exact values of the quantity. The values used here are just coarse approximations, and summarized in Table 4-2 on page 193. You must provide the model parameters for the contact resistance pair conditions as an equivalent interfacial layer, where the layer thickness has no resemblance to reality.

<table>
<thead>
<tr>
<th>JUNCTION</th>
<th>CONTACT RESISTANCE</th>
<th>MODEL PARAMETERS</th>
</tr>
</thead>
<tbody>
<tr>
<td>cable-clip</td>
<td>100 μΩcm</td>
<td>σ = 10^6 S/m, d = 1 m</td>
</tr>
<tr>
<td>clip-pole</td>
<td>10 μΩcm</td>
<td>σ = 10^7 S/m, d = 1 m</td>
</tr>
</tbody>
</table>
The boundaries connecting to the circuit use a boundary condition called Circuit terminal, which is specialized for circuit connections. The SPICE import automatically finds the circuit terminals defined in the model and connect them to the specified nodes in the circuit for a particular instance. All other boundaries use the electric insulation boundary condition.

The wire and clip are made of copper, and the battery pole is made of a lead alloy. The only lead alloy present in the basic material library is a solder material, so to simplify the modeling this material is used as the lead alloy in the battery pole. All relevant material properties are summarized in the table below.

<table>
<thead>
<tr>
<th>MATERIAL</th>
<th>RESISTIVITY</th>
<th>TEMPERATURE COEFFICIENT</th>
<th>THERMAL CONDUCTIVITY</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copper</td>
<td>17.8 nΩm</td>
<td>0.0039 K⁻¹</td>
<td>400 K/(m·W)</td>
</tr>
<tr>
<td>Solder, 60Sn-40Pb</td>
<td>499 nΩm</td>
<td>0.0 K⁻¹</td>
<td>50 K/(m·W)</td>
</tr>
</tbody>
</table>

The heat generated at the junctions has to be accounted for. Using the pair condition called Heat flux discontinuity, you can specify a heat source that is equal to the formula

\[ q_0 = d \mathbf{E} \cdot \mathbf{J} = d \frac{V_{src} - V_{dst}}{\sigma} (V_{src} - V_{dst}) = \sigma (V_{src} - V_{dst})^2 \]

where \( V_{src} \) is the voltage at the source side of the pair, and \( V_{dst} \) the voltage at the destination side. The variable \( q_{s_emdc} \) returns the value of the above formula if it is used on the boundaries of a contact resistance pair condition. The boundaries attached to the charger and battery are fixed at room temperature. All other boundaries have thermal insulation, so the dissipation to air is neglected.

**Results and Discussion**

When the cables are part of the charger circuit the currents flowing in the cables are different. An electrical system using car batteries usually has the minus side of the battery connected to all metal parts, which represents the alternative path to ground.
in the circuit. This results in a larger current in the cable connected to the plus side of the battery. The following figures show the potential distribution of both cables.

Figure 4.22: The potential distribution of the cable on the plus side of the battery. Almost the entire voltage drop is over the two junctions.
Figure 4-23: The potential distribution of the cable on the minus side of the battery.

Because most of the voltage drop is over the junctions, the major part of the heat generation is also located there. A temperature plot of both cables confirms this.
Especially the cable-clip junction is sensitive to heat if the cable is soldered to the clip (common on less expensive cables) or if the junction has suffered from corrosion.

Figure 4-24: The temperature distribution on the plus side of the battery. The area around the cable-clip junction gets a high temperature that can damage a soldered junction.
Figure 4-25: The temperature distribution on the minus side of the battery. The distribution is less critical here due to the alternative path for the current.

**Model Library path:** ACDC_Module/Electrical_Components/high_current_cables_circuit

---

**Modeling Using the Graphical User Interface**

The modeling steps below assume that the Heat Transfer Module is not present. If it is, the Joule Heating multiphysics node uses the Heat Transfer Module’s General Heat Transfer application mode. As a result, some names referring to components in the graphical user interface are slightly different.

**MODEL NAVIGATOR**

1. In the Model Navigator, select 3D from the Space dimension list.
2. In the AC/DC Module>Electro-Thermal Interaction folder, select the Joule Heating multiphysics node.
3 Click **OK**.

**GEOMETRY MODELING**

1 From the **File** menu, select **Import>CAD Data From File**.
2 In the **Import CAD Data From File** dialog box, make sure that the **COMSOL Multiphysics file** or **All 3D CAD files** is selected in the **Files of type** list.
3 Locate the **high_current_cable.mphbin** file in the **models/ACDC_Module/Electrical_Components** folder, and click **Import**.
4 Click the **Zoom Extents** button on the **Main toolbar**.
5 Select all objects by pressing Ctrl+A.
6 Click the **Create Pairs and Imprints** button on the **Draw toolbar**.

**PHYSICS SETTINGS (CONDUCTIVE MEDIA DC)**

**Subdomain Settings**

1 From the **Physics** menu, open the **Subdomain Settings** dialog box.
2 Select Subdomains 2, 3, and 4, then click the **Load** button.
3 In the **Materials/Coefficients Library** dialog box, expand the **Basic Material Properties** library and choose **Copper**.
4 Click **OK** to close the dialog box.
5 From the **Conductivity relation** list, choose **Linear temperature relation**.
6 Select Subdomain 1 and click the **Load** button.
7 In the **Materials/Coefficients Library** dialog box, expand the **Basic Material Properties** library and choose **Solder, 60Sn-40Pb**.
8 Click **OK** to close the dialog box.
9 From the **Conductivity relation** list, choose **Linear temperature relation**.
10 Click **OK** to close the **Subdomain Settings** dialog box.

**Boundary Conditions**

1 From the **Physics** menu, open the **Boundary Settings** dialog box.
2 Select all boundaries and choose the **Electric insulation** boundary condition from the **Boundary condition** list.
3 Select Boundary 1 and choose **Ground** from the **Boundary condition** list.
4 Select Boundary 163, choose **Electric potential**, and enter 1 in the **Electric potential** edit field.
5 Click the **Pairs** tab and select **Pair 1 (identity)** from the **Pair selection** area.
6 From the **Boundary condition** list, choose **Contact resistance** and enter $1\times10^7$ in the **Electric conductivity** edit field.
7 Select the second pair, **Pair 2 (identity)**, choose **Contact resistance** and enter $1\times10^6$ in the **Electric conductivity** edit field.
8 Click **OK**.

**PHYSICS SETTINGS (HEAT TRANSFER BY CONDUCTION)**

**Subdomain Settings**
1 From the **Model Tree** browser, double-click on the item **Geom1>Heat Transfer by Conduction>Subdomain Settings**. This opens the **Subdomain Settings** dialog box for the Heat Transfer application mode.
2 In the dialog box, select Subdomains 2, 3 and 4, then choose **Copper** from the **Library material** list.
3 Select Subdomain 1, and choose **Solder, 60Sn-40Pb** from the **Library material** list.
4 Click the **Init** tab, select all subdomains, and enter $28[^{\circ}\text{C}]$ in the **Temperature** edit field. The unit $^{\circ}\text{C}$ specifies the unit to degrees Celsius.
5 Click **OK**.

**Boundary Conditions**
1 From the **Model Tree** browser, double-click on the item **Geom1>Heat Transfer by Conduction>Boundary Settings**.
2 In the **Boundary Settings** dialog box, select Boundaries 1 and 163, and choose **Temperature** from the **Boundary condition** list.
3 Enter $28[^{\circ}\text{C}]$ in the **Temperature** edit field.
4 Click the **Pairs** tab, select both pairs and choose **Heat flux discontinuity** from the **Boundary condition** list (if you use the General Heat Transfer application mode, choose **Heat source/sink** from the **Boundary condition** list instead).
5 Enter $Qs_{emdc}$ in the **Inward heat flux** edit field (the **Heat source/sink** edit field in the General Heat Transfer application mode).
6 Click **OK**.

**MESH GENERATION**
1 From the **Mesh** menu choose **Free Mesh Parameters**.
2 Click the **Boundary** tab, and select Boundaries 103, 104, 167, and 168. Then enter $10^{-3}$ in the **Maximum element size** edit field.

3 Click the **Remesh** button, then click **OK**.

**Computing the Solution**

Models with external circuits requires some extra settings due to the extra solution variables for the circuit. These variables must be treated with the smoother/solver Vanka. It is also necessary to use manual scaling to make the model converge.

1 From the **Solve** menu, choose **Solver Parameters**.

2 In the **Solver Parameters** dialog box, select the **GMRES** solver as **Linear system solver**, and **Geometric multigrid** as **Preconditioner**.

3 Click the **Settings** button.

4 In the **Linear System Solver Settings** dialog box, select **Presmoother** from the tree view. From the **Presmoother** list, choose **Vanka**.

5 Type `sim_*` in the **Variables** edit field, and Choose **Direct** from the **Solver** list. The list of variables is entered as a wild-card search that finds all solution variables that begins with `sim_*`, which is true for all variables produced by the SPICE Import.

6 Repeat steps 4 and 5 for the **Postsmoother** item in the tree view.

7 Select **Coarse solver** from the tree view and choose the **PARDISO** solver from the **Coarse solver** list.

8 Click **OK** to close the dialog box.

9 In the **Solver Parameters** dialog box, go to the **Advanced** page.

10 From the **Type of scaling** list, choose **Manual**. Then type $T$ 300 V 10 Vconstr* 0.1 `sim_*` 0.1 in the **Manual scaling** edit field. Here you also use wild card searches to match the solution variables from the circuit with `sim_*`, and the variables for the circuit connection to the two cable models with `Vconstr*`.

11 Click **OK**.

12 Click the **Solve** button on the Main toolbar.

**Postprocessing and Visualization**

1 From the **Postprocessing** menu, choose **Plot Parameters**.

2 In the **Plot Parameters** dialog box, clear the **Slice** check box, and select the **Boundary** check box.

3 Click the **Boundary** tab, and choose **Conductive Media DC (emdc)>Electric potential** from the **Predefined quantities** list.
Click **Apply** to see the following plot.
5 To plot the temperature, choose Heat Transfer by Convection (ht)>Temperature for the Predefined quantities list, and click OK.

**PREPARING FOR CIRCUIT CONNECTION**

The following steps are a preparation for the SPICE connection, which has to be done before the model is used in a circuit.

*Boundary Conditions*

1. From the Model Tree browser, double-click on the item **Geom1>Conductive Media DC (emdc)>Boundary Settings**.

2. In the Boundary Settings dialog box, select Boundary 163 and choose Circuit terminal from the Boundary condition list.

3. Enter charger in the Group index edit field.
Select Boundary 1 and choose Circuit terminal, then enter battery in the Group index edit field.

Click OK.

Save the Model
From the File menu, choose Save As, then choose a proper location for the file. The file name should be high_current_cable.mph to be compatible with the modeling steps in the next section.

Modeling the Entire Circuit

Model Navigator
The following steps assume that you continue from the previous section and make sure that the model has the desired settings for the segregated solver.

1. From the File menu, choose New. In the Model Navigator, make sure that the New tab is selected.
2. Make sure that AC/DC Module>Electro-Thermal Interaction>Joule Heating is selected in the Application Modes list.
3. Click OK.
5. One by one delete both application modes by first selecting an application mode and then clicking the Remove button in the Multiphysics area.
6. Click OK.
SPICE IMPORT

1. From the Physics menu, choose SPICE Circuit Editor.
2. In the SPICE Circuit Editor dialog box, click the Create Voltage Source toolbar button.
3. In the Create Voltage Source dialog box, enter V1 in the Device instance name edit field.
4. Then enter 1 0 in the Terminal names edit field, and 14.4V in the Device value edit field.
5. Click OK. You should now see the following text in the text area: V1 1 0 14.4V.
6. Click the Create Resistor toolbar button.
7. In the dialog box that appears, enter R1 in the Device instance name edit field, 1 2 in the Terminal names edit field, and 0.05 in the Device value edit field.
8. Click OK. This adds a statement representing a resistor between nodes 1 and 2 with a value of 0.05 Ω.
9. Click the Create Subcircuit Instance toolbar button, enter X1 in the Device instance name edit field, 2 3 in the Terminal names edit field, and cable in the Subcircuit reference name edit field.
10. Click OK. This adds a statement representing a subcircuit instance of the subcircuit cable between nodes 2 and 3.
11. Click the Create Voltage Source toolbar button, enter Vbattery in the Device instance name edit field, 3 4 in the Terminal names edit field, and 10.5V in the Device value edit field.
12. Click OK. This adds the voltage source representing the battery.
13. Click the Create Subcircuit Instance toolbar button, enter X2 in the Device instance name edit field, 0 4 in the Terminal names edit field, and cable in the Subcircuit reference name edit field.
14. Click OK. This statement adds a second subcircuit instance of the same subcircuit as X1.
15. Click the Create Resistor toolbar button, enter R2 in the Device instance name edit field, 4 0 in the Terminal names edit field, and 0.05 in the Device value edit field.
16. Click OK. This statement represents the alternative paths to ground in the system.
17. Click the Create Link to Model File toolbar button, enter cable in the Subcircuit reference name edit field, and charger battery in the Terminal names edit field.
18. Click the Select File button.
19 In the dialog box that appears, browse to the file named high_current_cable.mph you saved in the previous section. As an alternative, you can also browse to the Model Library version of the file with the same name located in the Model Library path of this model.

20 Click the Create Link button. The entire netlist should look similar to the figure below.

![SPICE Circuit Editor dialog box with netlist](image)

21 Click OK to close the SPICE Circuit Editor dialog box. COMSOL Multiphysics now adds all the global variables and ODE expression that represents the netlist. For the subcircuit instances, it adds the model in the model file twice as two new geometries, using the add component feature.

**COMPUTING THE SOLUTION**

This is a problem that can benefit from a segregated solver approach, both regarding stability and memory consumption. Scaling of the circuit variables can sometimes be an issue, so it is also necessary to scale them manually. You set the scaling of these variables an order of magnitude lower than the expected value to increase the weight of them in the solution of the problem.

1. From the Solve menu, choose Solver Parameters.
2. In the Solver Parameters dialog box, select the Stationary segregated solver.
3. Click the Settings button for group number 1.
4. In the Linear System Solver Settings dialog box, choose Direct (SPOOLES) from the Linear system solver list.
5. Click OK.
6. Click the Settings button for group number 2.
7 In the Linear System Solver Settings dialog box, choose Direct (SPOOLES) from the Linear system solver list.

8 Click OK.

9 In the Components edit field of group number 2, enter all solution variables except the temperature variable T. The list below shows the variables to enter, but you enter them as a space-separated list in the edit field.

<table>
<thead>
<tr>
<th>SOLUTION VARIABLE</th>
</tr>
</thead>
<tbody>
<tr>
<td>V</td>
</tr>
<tr>
<td>Vconstrbattery_g2_emdc</td>
</tr>
<tr>
<td>Vconstrcharger_g2_emdc</td>
</tr>
<tr>
<td>Vconstrbattery_g3_emdc</td>
</tr>
<tr>
<td>Vconstrcharger_g3_emdc</td>
</tr>
<tr>
<td>I0_X2_cir</td>
</tr>
<tr>
<td>I2_X1_cir</td>
</tr>
<tr>
<td>I3_X1_cir</td>
</tr>
<tr>
<td>I4_X2_cir</td>
</tr>
<tr>
<td>I_V1_cir</td>
</tr>
<tr>
<td>I_VBATTERY_cir</td>
</tr>
<tr>
<td>V1_cir</td>
</tr>
</tbody>
</table>
Select the Manual specification of segregated steps check box, and specify the steps according the following table.

<table>
<thead>
<tr>
<th>GROUP</th>
<th>DAMPING</th>
<th>NUMBER OF ITERATIONS</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>0.8</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
<td>2</td>
</tr>
</tbody>
</table>

The dialog box at this step is shown below.

11 Click the Advanced tab.

12 From the Type of scaling list, choose Manual.
Enter a space-separated list containing all solution variables followed by their scaling in the Manual scaling edit field. The following list shows all solution-variable–scale-value pairs:

<table>
<thead>
<tr>
<th>SOLUTION VARIABLE</th>
<th>SCALE VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>T</td>
<td>300</td>
</tr>
<tr>
<td>V</td>
<td>10</td>
</tr>
<tr>
<td>Vconstrbattery_g2_emdc</td>
<td>0.1</td>
</tr>
<tr>
<td>Vconstrcharger_g2_emdc</td>
<td>0.1</td>
</tr>
<tr>
<td>Vconstrbattery_g3_emdc</td>
<td>0.1</td>
</tr>
<tr>
<td>Vconstrcharger_g3_emdc</td>
<td>0.1</td>
</tr>
<tr>
<td>I0_X2_cir</td>
<td>0.1</td>
</tr>
<tr>
<td>I2_X1_cir</td>
<td>0.1</td>
</tr>
<tr>
<td>I3_X1_cir</td>
<td>0.1</td>
</tr>
<tr>
<td>I4_X2_cir</td>
<td>0.1</td>
</tr>
<tr>
<td>I_V1_cir</td>
<td>0.1</td>
</tr>
</tbody>
</table>

The beginning of the space-separated list then looks like

T 300 V 10 Vconstrbattery_g2_emdc 0.1 Vconstrcharger_g2_emdc ...

Click OK to close the Solver Parameters dialog box.

Click the Solve button on the Main toolbar.

1 Click the Geom2 tab in the main user interface.
2 From the Postprocessing menu, choose Plot Parameters.
3 In the Plot Parameters dialog box, clear the Slice check box, and select the Boundary check box.
4 Click the Boundary tab, and choose Conductive Media DC (emdc)>Electric potential from the Predefined quantities list.
5 Click **Apply** to see the following plot, which is also shown in the section “Results and Discussion” on page 194.

6 Repeat these steps for the temperature and for both variables in the last geometry to get the other plots in the “Results and Discussion” section.
This model studies a finite element model of an inductor inserted into an electrical amplifier circuit.

Introduction

Modern electronic systems are very complex and depend heavily on computer aided design in the development and manufacturing process. Common tools for such calculations are based on the SPICE format originally developed at Berkeley University (Ref. 1). The SPICE format consists of a standardized set of models for describing electrical devices—especially semiconductor devices such as transistors, diodes, and thyristors. SPICE also includes a simple, easy-to-read text format for circuit netlists and model parameter specifications. Although the netlist format is essentially the same as it was from the beginning, the set of models and model parameters constantly changes, with new models being added according to the latest achievements in semiconductor device development. When the devices are scaled down, new effects appear that have to be properly modeled. The new models are the result of ongoing research in device modeling.

When an engineer is designing a new electronic component, like a capacitor or an inductor, the SPICE parameters for that device are not known. They are either extracted from finite element tools such as COMSOL Multiphysics or from measurements on a prototype. To speed up the design process it can be convenient to include the finite element model in the SPICE circuit simulation, calculating the device behavior in an actual circuit.

This model takes a simple amplifier circuit and exchanges one of its components with a finite element model of an inductor with a magnetic core. COMSOL Multiphysics calculates the transient behavior of the entire system. A script adds the circuit elements as ordinary differential equations (ODEs) to the inductor model along with the necessary model parameters for the SPICE devices in the circuit.

Model Definition

The inductor model uses the Azimuthal Induction Currents application mode of the AC/DC Module, solving for the magnetic potential $\mathbf{A}$:
\[ \sigma \frac{\partial A}{\partial t} + \nabla \times (\mu_0^{-1} \mu_r^{-1} \nabla \times A) = \mathbf{J}_e \]

where \( \mu_0 \) is the permeability of vacuum, \( \mu_r \) the relative permeability, and \( \sigma \) the electric conductivity.

Because the inductor has a large number of turns it is not efficient to model each turn as a separate wire. Instead the model treats the entire coil as a block with a constant external current density corresponding to the current in each wire. The conductivity in this block is zero to avoid eddy currents, which is motivated by the fact that no currents can flow between the individual wires. The eddy currents within each wire is neglected.

**Connection to a SPICE Circuit**

The electrical circuit is a standard amplifier circuit with one bipolar transistor, biasing resistors, input filter, and output filter (see the figure below).

The input is a sine signal of 1 V and 10 kHz. The following listing shows the SPICE netlist for this circuit:

```plaintext
* BJT Amplifier Circuit
.OPTIONS TNOM=27
.TEMP 27
Vin 1 0 sin(0 1 10kHz)
Vcc 4 0 15
Rg 1 2 100
```

212 | **Chapter 4: Electrical Component Models**
The device X1 refers to a subcircuit defined at the end of the file. The subcircuit definition is part of the SPICE standard to define blocks of circuits that can be reused in the main circuit. The special implementation used here defines a subcircuit that really is a COMSOL Multiphysics model, referenced with the option COMSOL: <file name> | <application mode name> | *. The asterisk means that COMSOL Multiphysics looks for the first occurrence of the specified parameters V_coil and I_coil in the current model. These parameters are the variables that links the model with the circuits, and must be defined in the model in a certain way. The variable V_coil must give the voltage over the device, defined in the global scope. I_coil must be a global variable used in the model as a current through the device.

The script can also handle model files with more than two terminals. It is then necessary to define each terminal as a floating-potential boundary condition. Note that any use of the ground boundary condition connects those boundaries directly to the ground node of the circuit, labeled 0.

The model parameters of the transistor do not correspond to a real device, but the numbers are nevertheless chosen to be realistic.

The import of the SPICE netlist does not fully support the SPICE format; especially for the semiconductor device models it only supports a limited set of parameters. Supplying unsupported parameters does not give an error message, but the parameter is not used in the circuit model. For example, the transit time capacitance and the temperature dependence are not supported for the transistor model.
Results and Discussion

Biasing of an amplifier is often a complicated compromise, especially if you only use resistors. Adding an inductor as the collector impedance simplifies the biasing design, since the instantaneous voltage on the collector of the transistor can be higher than the supply voltage, which is not possible with resistors. Amplifiers using inductors can be quite narrow banded.

Before starting the transient simulation, proper initial conditions have to be calculated. For this model it is sufficient to ramp the supply voltage to 15 V with the nonlinear parametric solver. After the ramp, the DC bias conditions have been calculated properly, and you can use this solution as initial condition for the transient simulation. After 0.2 ms the magnetic flux density should look like Figure 4-26 below.

![Figure 4-26: Magnetic flux density (color) after the bias point calculation.](image)
Using a global variables plot, you can easily plot input signal, output signal, and inductor voltage in the same figure.

Figure 4-27: Input signal \( U_{\text{VIN\_cir}} \), output signal \( U_{\text{RL\_cir}} \), and inductor voltage \( U_{\text{X1\_cir}} \) as functions of time.

The output signal is about 1.5 times the input signal in amplitude.

Reference


Model Library path: ACDC_Module/Electrical_Components/amplifier_and_inductor
CHAPTER 4: ELECTRICAL COMPONENT MODELS

MODEL NAVIGATOR
1 In the Model Navigator, select Axial symmetry (2D) from the Space dimension list.
2 In the AC/DC Module folder, select Magnetostatics>Azimuthal Induction Currents, Vector Potential.
3 Click OK to close the Model Navigator.

OPTIONS AND SETTINGS
1 From the Options menu, choose Constants.
2 In the Constants dialog box, define the following constants with names, expressions, and (optionally) descriptions:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>t</td>
<td>0[s]</td>
<td>Time for stationary solution</td>
</tr>
<tr>
<td>N</td>
<td>1e3</td>
<td>Turns in coil</td>
</tr>
<tr>
<td>freq</td>
<td>10[kHz]</td>
<td>Frequency</td>
</tr>
<tr>
<td>r_coil</td>
<td>0.05[mm]</td>
<td>Wire radius in coil</td>
</tr>
<tr>
<td>sigma_coil</td>
<td>5e7[S/m]</td>
<td>Wire conductivity</td>
</tr>
</tbody>
</table>

COMSOL Multiphysics displays the constant \( t \) in red to alert you that it is the reserved variable for time. Because this is the role you give \( t \) here, you can ignore the warning.

3 Click OK.
4 From the Options menu, choose Expressions>Global Expressions.
5 In the Global Expressions dialog box, define the following variables with names, expressions, and (optionally) descriptions; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>I_coil</td>
<td>1[A]</td>
<td>Current in coil</td>
</tr>
<tr>
<td>J_coil</td>
<td>I_coil*N/A</td>
<td>Equivalent current density in coil</td>
</tr>
</tbody>
</table>

GEOMETRY MODELING
1 Choose Draw>Specify Objects>Circle to create a circle with the following properties:

<table>
<thead>
<tr>
<th>NAME</th>
<th>RADIUS</th>
<th>BASE</th>
<th>R</th>
<th>Z</th>
</tr>
</thead>
<tbody>
<tr>
<td>C1</td>
<td>0.03</td>
<td>Center</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>
2. Choose Draw>Specify Objects>Rectangle to create rectangles with the following properties:

<table>
<thead>
<tr>
<th>NAME</th>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>BASE</th>
<th>R</th>
<th>Z</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>5e-3</td>
<td>2e-2</td>
<td>Corner</td>
<td>0</td>
<td>-1e-2</td>
</tr>
<tr>
<td>R2</td>
<td>3e-3</td>
<td>2e-2</td>
<td>Corner</td>
<td>7.5e-3</td>
<td>-1e-2</td>
</tr>
<tr>
<td>R3</td>
<td>0.04</td>
<td>0.08</td>
<td>Corner</td>
<td>0</td>
<td>-0.04</td>
</tr>
</tbody>
</table>

3. Click the Zoom Extents button on the Main toolbar to see the objects.
4. Select the circle and the third rectangle (C1 and R3), then click the Intersection button on the Draw toolbar.
5. From the Draw menu, open the Fillet/Chamfer dialog box.
6. In the dialog box, expand rectangle R1 and select Vertices 2 and 3. Then expand rectangle R2 and select all vertices there. Hold down the Ctrl key to do multiple selections.
7. Set the Radius to 5e-4, then click OK.

**PHYSICS SETTINGS**

**Variables**

1. From the Options menu, point to Integration Coupling Variables and choose Subdomain Variables.
2. In the Subdomain Integration Variables dialog box, define two variables with integration order 4 and global destination according to the table below.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION IN SUBDOMAIN 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>V_coil</td>
<td>(N<em>2</em>\pi<em>r</em>I_{coil}/(A*\sigma_{coil}<em>\pi</em>r_{coil}^2))</td>
</tr>
<tr>
<td>A</td>
<td>1</td>
</tr>
</tbody>
</table>

3. Click OK.

**Subdomain Settings**

1. From the Physics menu, open the Subdomain Settings dialog box.
2. Select Subdomain 2 and click the Load button to open the Materials/Coefficients Library dialog box.
3. In the Materials area, open the Electric (AC/DC) Material Properties library and select Soft Iron (without losses). (You may have to scroll both vertically and horizontally to see the library name.)
4 Click OK to close the Materials/Coefficients Library dialog box.
5 Select Subdomain 3 and enter $J_{\text{coil}}$ in the External current density edit field.
6 Click the Init tab, select all subdomains, and type 1 in the edit field for the initial value.
7 Click OK.

Boundary Conditions
1 From the Physics menu, open the Boundary Settings dialog box.
2 Select Boundaries 1, 2, and 4, then choose Axial symmetry from the Boundary condition list. For all other boundaries keep the default condition, Magnetic insulation.
3 Click OK.

Mesh Generation
1 From the Mesh menu, open the Free Mesh Parameters dialog box.
2 Click the Custom mesh size button, then type 4 in the Resolution of narrow regions edit field.
3 Click Remesh, then click OK.

Computing the Solution
1 Click the Solve button.
2 From the File menu, choose Save As. Save the model to the file name amplifier_and_inductor_nocircuit.mph.

This completes the first part of the model.

SPICE Import
1 From the Physics menu, choose SPICE Circuit Editor.
2 In the SPICE Circuit Editor dialog box, click on the Load Netlist from File toolbar button.
3 Browse to the file amplifier.cir, located in the model library path ACDC_Module/Electrical_Components/amplifier_and_inductor.
4 Click **Import Netlist**. The entire file replaces the content of the **SPICE netlist** text area.

![SPICE Circuit Editor](image)

5 Click **OK** to close the **SPICE Circuit Editor** dialog box.

An alternative to importing text files is to manually type in the code in the SPICE circuit editor:

```
* BJT Amplifier circuit
.OPTIONS TNOM=27
.TEMP 27
Vin  1  0  sin(0 1 10kHz)
Vcc  4  0  15
Rg   1  2  100
Cin  2  3  10u
R1   4  3  47k
R2   3  0  10k
X1   4  5  inductor
RE   7  0  1k
Cout 5  6  10u
Rl   6  0  10k
Q1   5  3  7  BJT
.MODEL BJT NPN(Is=15f Ise=15f Isc=0 Bf=260 Br=6.1
+ Ikf=.3 Xtb=1.5 Ne=1.3 Nc=2 Rc=1 Rb=10 Eg=1.11
+ Cjc=7.5p Mjc=.35 Vjc=.75 Fc=.5 Cje=20p Mje=0.4 Vje=0.75
+ Vaf=75 Xtf=3 Xti=3)
.SUBCKT inductor V_coil I_coil COMSOL: *
.ENDS
.END
```

The model is the same as before but with global variables and ODE variables added that represent the amplifier circuit. The syntax of these variables are related to the names in the file. The variable `I_R1_cir` stands for the current in resistor R1, `value_VCC_cir` is the voltage value of the supply voltage generator VCC, and
$U_{X1\_cir}$ is the voltage over the device $X1$, which is the inductor model you created earlier. The variables beginning with the letter $V$ are node potentials referenced to the ground node, 0, of the circuit.

As an alternative to the steps above, you can open the netlist from the model library path.

**COMPUTING THE SOLUTION WITH A CIRCUIT**

1. From the *Solve* menu, choose *Solver Parameters*.
2. In the *Solver Parameters* dialog box, select *Parametric* from the *Solver* list.
3. In the *Parameter name* edit field type *value_VCC_cir*, and in the *Parameter values* edit field type 1:15.
4. Click *OK*.
5. Click the *Restart* button.

This solving step ramps the supply voltage stored in *value_VCC_cir* up to 15 V. The ramp is necessary to handle the highly nonlinear effects in the bipolar transistor model. The circuit is now at its bias point, and the plot should look like Figure 4-26 on page 214.

**Transient Case**

We will now make a transient calculation. In the previous static case we have no induced electric field, but when we change it to a transient case, the induced electric field needs to be added as a contribution to the coil voltage $V_{coil}$, in addition to the resistive effects. In the application mode the induced electric field is available as the variable $Ephi\_emqa$, and is computed as the time derivative of the magnetic potential.

1. From the *Options* menu, point to *Integration Coupling Variables* and click *Subdomain Variables*. 
2 In the **Subdomain Integration Variables** dialog box, change the expression for the \( V_{\text{coil}} \) variable so it matches the expression below.

![Subdomain Integration Variables dialog box](image)

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION IN SUBDOMAIN 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>( V_{\text{coil}} )</td>
<td>( N^\ast2\pi^\ast r^\ast(I_{\text{coil}}/(\sigma_{\text{coil}}\pi^\ast r_{\text{coil}}^2)-E_{\phi_{\text{emqa}}})/A )</td>
</tr>
</tbody>
</table>

3 Click **OK**.

4 From the **Solve** menu, choose **Solver Parameters**.

5 In the **Solver Parameters** dialog box, select **Transient** from the **Analysis** list.

6 Type `linspace(0,5e-4,101)` in the **Times** edit field, type `1e-4` in the **Relative tolerance** edit field, and type `1e-6` in the **Absolute tolerance** edit field. The last steps are required because the accuracy obtained with default error tolerances is not sufficient in this model.

7 Click **OK**.

8 Click the **Restart** button on the **Main toolbar**.

**POSTPROCESSING AND VISUALIZATION**

1 From the **Postprocessing** menu, choose **Global Variables Plot**.

2 From the **Predefined quantities** list, select the variables \( U_{\text{X1}_{\text{cir}}} \), \( U_{\text{VIN}_{\text{cir}}} \), and \( U_{\text{RL}_{\text{cir}}} \). Click the > button to add the selected variables to the **Quantities to plot** list.
3 From the **Solutions to use** list, select all the time steps from **4e-4** to **5e-4**.

4 Click the **Line Settings** button. In the dialog box that appears, select **Cycle** from the **Line marker** list, and select the **Legend** check box. Click **OK**.

5 Click **OK** to see the plot in Figure 4-27 on page 215.
In this chapter you find models of general industrial applications that do not fit into any of the other chapters. Typically, these models deal with eddy currents, electric impedance, and other static or low-to-intermediate frequency applications.
Eddy Currents in 3D

Introduction

Induced eddy currents and associated thermal loads are of interest in many high power AC applications. This example is of general nature and illustrates some of the involved physics as well as suitable modeling techniques in the AC/DC Module.

Model Definition

A metallic plate is placed near a 50 Hz AC conductor. The resulting eddy current distribution in the plate depends on the conductivity and permeability of the plate. The model considers four different materials: copper, aluminum, stainless steel, and magnetic iron. The geometry consists of a single wire and a plate with dimensions as shown below.
Because you cannot afford meshing an infinite volume, it is necessary to specify a finite volume to mesh and solve for. In this case, it makes sense to enclose the wire and the plate in a cylinder with the wire on the axis of this cylinder.

The conductor is modeled as a line current with 0° phase and an effective value of 24 kA.

In the subdomains the magnetic vector potential is calculated from

\[
(j\omega\sigma - \omega^2\varepsilon)\mathbf{A} + \nabla \times \left(\frac{1}{\mu} \nabla \times \mathbf{A}\right) = \mathbf{0}
\]

where \(\sigma\) is the conductivity, \(\varepsilon\) the permittivity, and \(\mu\) the permeability.

An important parameter in eddy current modeling is the skin depth, \(\delta\).

\[
\delta = \frac{2}{\sqrt{\omega\mu\sigma}}
\]
The following table lists the skin depth for the different materials at a frequency of 50 Hz.

<table>
<thead>
<tr>
<th>MATERIAL</th>
<th>REL. PERMEABILITY</th>
<th>CONDUCTIVITY</th>
<th>SKIN DEPTH</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copper</td>
<td>1</td>
<td>5.998·10⁷ S/m</td>
<td>9 mm</td>
</tr>
<tr>
<td>Aluminum</td>
<td>1</td>
<td>3.774·10⁷ S/m</td>
<td>12 mm</td>
</tr>
<tr>
<td>Stainless steel</td>
<td>1</td>
<td>1.137·10⁶ S/m</td>
<td>67 mm</td>
</tr>
<tr>
<td>Iron</td>
<td>4000</td>
<td>1.12·10⁷ S/m</td>
<td>0.34 mm</td>
</tr>
</tbody>
</table>

The combination of a high permeability and a high conductivity can make it impossible to resolve the skin depth when modeling. When the skin depth is small in comparison to the size of conducting objects, you can exclude the interior of those objects from the model and replace them with an impedance boundary condition accounting for induced surface currents. This condition uses the following relation between the magnetic and electric field at the boundary:

\[
\mathbf{n} \times \mathbf{H} + \frac{\varepsilon - j\sigma / \omega}{\mu} \mathbf{n} \times (\mathbf{E} \times \mathbf{n}) = 0
\]

The distribution of the dissipated power, \( P_d \), has the unit W/m², and can be calculated from

\[
P_d = \frac{1}{2} (\mathbf{J}_S \cdot \mathbf{E}^*)
\]

where \( \mathbf{J}_S \) is the induced surface current density, and the asterisk denotes the complex conjugate.

**Alternate Modeling Technique Using Reduced Form**

It is possible to reduce the size of the geometry in this model to only include the plate because the field from the straight wire can be represented by an analytical solution. The model needs to predict the perturbations in that field caused by the presence of the plate. An important modeling assumption is that the presence of the plate in the vicinity of the wire does not affect the current in the wire.

The magnetic vector potential around an infinitely long wire surrounded by air, oriented along the \( x \)-axis and carrying a current \( J \) is given by

\[
A_x = \frac{\mu_0 J \log r}{2\pi}
\]
where \( r \) is the distance of the field point from the wire.

The following plot shows the reduced modeling geometry. Infinite elements are used in the outer spherical shell to further reduce the size of the computational domain.
Results and Discussion

The induced eddy current distribution for a plate made of copper is shown as streamlines, whereas the distribution of the ohmic losses is shown as a slice plot.

A total dissipated power of 6 W was obtained from integration through the plate. By repeating the simulation for different materials, the model shows that lowering the conductivity decreases the dissipated power. However, for high permeability materials like soft iron, the dissipated power is higher than in a copper despite a much lower conductivity.

The corresponding reduced form solution to the model with the iron plate is shown below.
It is possible to compare the results from the full model with those from the reduced form model. The total losses in the iron plate is a good measure to use for comparison, and the results predicted by the two models are fairly close (approximately 27 and 28 W, respectively). The difference can be accounted for by the fact that the reduced model represents the field from the wire to a higher accuracy because this field is given as an exact solution. Also, because the modeling domain is smaller, it is possible to use a finer mesh with no increase in memory usage.

**Model Library path:** ACDC_Module/General_Industrial_Applications/eddy_currents_3d

### Modeling Using the Graphical User Interface

**MODEL NAVIGATOR**

Create a new 3D model using the **AC/DC Module>Quasi-Statics, Magnetic>Induction Currents** application mode.
GEOMETRY MODELING

The entire geometry is drawn in mm for simplicity. The final step in the geometry creation is a conversion of all dimensions to meters because this model uses SI units. Use the toolbar buttons and the Draw menu.

2D Cross Section

The geometry is created from a 2D cross section, that lies in the yz-plane of the final geometry.

1. Begin by specifying a yz work plane at \( x = 0 \) from the Draw menu.
2. In the 2D work plane, draw a circle with a radius of 250 mm.
3. Add a point at the center of the circle.
4. Draw a 60 mm tall and 100 mm wide rectangle that is centered at \( x = 0, y = 100 \) mm.

Extruding to 3D

Create the 3D geometry from the cross section.

1. Select both the circle and the point and Extrude (from the Draw menu) these objects a distance of 300 mm.
2. Go back to the 2D view and Extrude the rectangle by 10 mm.
3. In the 3D view, select the resulting box and Move it by 145 mm in the x direction.

The next step is to convert the length scale to meters. Select all objects and Scale them with the factor \( 1 \times 10^{-3} \) in all directions.

PHYSICS SETTINGS

Open the Application Scalar Variables dialog from the Physics menu, and make sure that the Frequency is set to 50 Hz.

Subdomain Settings

Open the Subdomain Settings dialog box and select the plate. Click the Electric Parameters tab, click the Load button, and choose Copper from the Basic Material Properties. For the air domain, enter a small conductivity of 100 [S/m] to improve convergence for the iterative solver. Any parameters not specified can be left at their default values.

Boundary Conditions

Leave the boundary conditions at the default settings, which is magnetic insulation.
**Edge Settings**

Open the Edge Settings dialog box and specify a line current of $24e3*sqrt(t) (2) A$ for the conductor (Edge 6).

**Mesh Generation**

In order to resolve the skin depth while maintaining a good mesh economy, proceed as follows:

1. Choose Mesh>Free Mesh Parameters.
2. On the Subdomain page, select Subdomain 2 and set the Maximum element size to $5e-3$.
3. On the Advanced page, set the Scale factor to 0.4 in the y and z directions.
4. Click the Mesh Selected button.
5. On the Global page, click the Reset to Defaults button, then select Predefined mesh sizes: Extremely coarse.
6. On the Subdomain page, select Subdomain 1 and set the Maximum element size to 0.1.
7. Click the Mesh Selected button and then OK to close the dialog box.

These settings force a fine mesh in the plate but allow for a quick growth of the element size outside of the plate. In order not to get a too coarse mesh in the air, the settings limit the element size to 10 cm.

**Computing the Solution**

Click the Solve button on the Main toolbar to solve the model.

**Postprocessing and Visualization**

The default plot is not what you want so open the Plot Parameters dialog box. Create a slice plot of the Resistive heating, time average $(Q_{av_emqa})$ at $x = 0.1451$ only, and do a streamline plot of the Total current density. Change the Number of start points to
In order to plot the streamlines only in the plate, **Suppress** the air domain from the **Options** menu.

The final step is to calculate the total power dissipated in the plate by the induced eddy currents. This is done by going to the **Postprocessing** menu and select **Subdomain Integration**. In the dialog that appears, select the plate subdomain and from the list of **Predefined quantities** select **Resistive heating, time average (Q\text{av}_{emqa})** before clicking **OK**. The result should be close to 6 W.

**Changing to Aluminum and Stainless Steel**

Repeating the analysis for aluminum and stainless steel is simple—just change the material properties for the plate subdomain and solve again. Aluminum is available from the Basic Material Properties whereas you have to enter stainless steel by typing the corresponding conductivity $1.137e6$ (S/m) value in the dialog box.

**Changing to Magnetic Iron**

For magnetic iron, the skin depth is too small to be resolved with reasonable computational effort. The solution is to use the impedance boundary condition.
Subdomain Settings

1. Open the Subdomain Settings dialog box from the Physics menu.
2. Select the plate, then clear the Active in this domain check box. This tells the solver not to include this domain in the solution process and also makes the impedance boundary condition available on the boundaries of this domain.
3. Click OK.

Boundary Conditions

1. Open the Boundary Settings dialog box from the Physics menu.
2. Select the plate’s boundaries, then select Impedance boundary condition from the Boundary condition list.
3. Click the Material Properties tab, then click the Load button and select Iron in the Basic Materials Properties list in the Materials/Coefficients Library dialog box that appears. Click OK.
4. Click OK.

Computing the Solution

Use the same settings as before. Click the Solve button on the Main toolbar to solve the model. This takes a few minutes.

Postprocessing and Visualization

The default plot may now give an error message as the plotted quantity no longer is defined in the plate domain.

1. Click the Plot Parameters button on the Main toolbar.
2. On the General page, clear the Slice and Streamline check boxes and select the Boundary check box in the Plot type area.
3. Click the Boundary tab. In the Boundary data area, select Surface resistive heating, time average from the Predefined quantities list to generate a plot of the resistive heating.
4. To see the results on the plate, point to Suppress in the Options menu.
Select Boundaries 1–5 and 12, then click OK.

The final step is to calculate the total power dissipated in the plate.

1 From the Postprocessing menu, select Boundary Integration.
2 In the Expression to integrate area, select Surface resistive heating, time average from the Predefined quantities list.
3 Click OK.

The result displayed in the message log should be close to 27 W.

Modeling Using Reduced Form

GEOMETRY MODELING

Removing the current-carrying wire from the geometry
The first step is to modify the drawing to make use of the fact that the wire is no longer needed in the geometry.

1 From the Draw menu, select Draw Mode.
2 With the long wire no longer in the model, the size of the air domain required will be much smaller. To delete the large air domain, select the large cylinder by clicking on it, then press Delete.

3 To delete the wire, select the long straight line by clicking on it, then press Delete.

Creating a new air domain
1 To draw the new, smaller air domain go to the Draw menu and select Sphere. Set the Radius to 0.09 and the Axis base point coordinates to 0.15, 0, and 0.1. Click OK.

2 To create the spherical shell that will be used for infinite elements, repeat the last step, this time with a radius of 0.11.

3 To see the spheres and the plate inside better you can increase the transparency by clicking the Increase Transparency button on the Draw toolbar.

The result should look as shown below.

Infinite elements subdomain modification
The next step is to slice the spherical shell infinite element domain into eight subdomains in order to aid effective meshing of the infinite elements domain. You can do this by creating a plane that cuts through the sphere at the desired locations and then coerce this plane with the spherical shell.

1 To draw the plane, go to the Draw menu and select Work Plane Settings.
2 Click the z-x option button and leave the y edit field at 0. Click the Add button to add a new work plane. Click **OK**.

3 In the resulting empty 2D geometry, draw a rectangle with width and height 0.3 and centered at (−0.05, 0).

4 Select **Embed** from the Draw menu. In the Objects to Embed list select R1, then click **OK**.

5 You need three copies of this cutting plane. To create the first extra copy, select the plane EMB1, then press first Ctrl+C and then Ctrl+V. Leave the x, y, z displacements in the Paste dialog box at 0 and click **OK**.

6 To rotate the resulting copy EMB2 about a line parallel to the z-axis and placed in the middle of the plate, select Draw>Modify>Rotate. Set the Rotation angle to 90, the Rotation axis direction vector to 0, 0, 1 and the Point on rotation axis to 0.15, 0, 0.1. Click **OK**.

7 To create the third copy, select the original EMB1 plane by clicking on it, then repeat Step 5.

8 To rotate the resulting copy about a line parallel to the y-axis and placed in the middle of the plate, repeat Steps 6 and 7, but this time using the Rotation axis direction vector 0,1,0.

9 Now select all three cutting planes (EMB1, EMB2, EMB3) and the larger sphere, SPH2 by clicking on each of the objects while pressing the Ctrl key. To perform the cut, select Draw>Coerce to>Solid. This results in a combined geometry object named CO2.

10 The object CO2 is now a full sphere cut into slices. To turn it into a shell suitable for the infinite elements, you can create a copy of the inner sphere SPH1 and subtract it from the larger object, CO2. To do this, first press Ctrl+D to make sure all objects are deselected, and then select SPH1 and CO2 simultaneously. Click the **Difference** button on the Draw toolbar.

The following figure shows the geometry of the reduced-form model.
**Options and Settings**

1. From the Options menu select **Constants**.

2. Enter the following constants; when done, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>z0</td>
<td>0[m]</td>
<td>z position of wire</td>
</tr>
<tr>
<td>y0</td>
<td>0[m]</td>
<td>y position of wire</td>
</tr>
<tr>
<td>I</td>
<td>24e3*sqrt(2)[A]</td>
<td>current</td>
</tr>
</tbody>
</table>

3. From the Options menu select **Expressions>Scalar Expressions**.

4. Enter the following expressions; when done, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>A_bg</td>
<td>mu0<em>emqa</em>I/(2*pi)*log(r)</td>
<td>Magnetic potential from wire</td>
</tr>
<tr>
<td>r</td>
<td>sqrt((z-z0)^2+(y-y0)^2)</td>
<td>Distance from wire</td>
</tr>
</tbody>
</table>

5. To activate the reduced form analysis select **Properties** from the Physics menu and set the **Solve for** option to **Reduced potential**. Click **OK**.
6 Select Scalar variables from the Physics menu and set the External magnetic vector potential $x$ component to $A_{bg}$. Leave the $y$ and $z$ components at 0.

7 Click OK.

**SUBDOMAIN SETTINGS**

1 Select Physics>Subdomain Settings. Select Subdomains 1–4 and 7–10 (the outer shell subdomains) in the Subdomain selection list. In the Electric Parameters tab, set the conductivity $\sigma$ to 100, as in the first version of the model.

2 In the Infinite Elements tab set the Type of infinite element to Spherical.

3 Select Subdomain 5 (the air domain) and set the conductivity $\sigma$ to 100 on the Electric Parameters page.

4 Select Subdomain 6 (the metal plate) and clear the Active in this domain check box. The skin depth in iron is very small, so the plate can, as earlier, be treated through a surface model.

**BOUNDARY SETTINGS**

1 Select Physics>Boundary Settings. Select Boundaries 13–17 and 34 (the metal plate boundaries). From the Boundary condition list select, as before, Impedance boundary condition.

2 In the Material Properties tab select Iron from the Library material drop down list.

3 Click OK.

**MESH GENERATION**

1 To make sure the mesh is sufficiently fine on the metal plate boundary, go to Mesh>Free Mesh Parameters. On the Boundary tab, select Boundaries 13–17 and 34 (the metal plate boundaries) and set the Maximum element size to $10^{-2}$.

2 Click Mesh Selected, then click OK.

3 To decrease the global overall mesh size (in the full version of the model a very coarse mesh was used in order to use little memory), click on the Decrease Mesh Size button on the bottom of the left hand vertical toolbar three times.

4 Now create a swept mesh on the infinite element layer. From the Mesh menu select Swept Mesh Parameters. From the Subdomain selection list select Subdomains 1–4 and 7–10. Select the Manual specification of element layers check box and make sure the Number of element layers is set to 3. Click the Mesh Selected button, then click OK.
5 Select the Mesh Remaining, Free option from the Mesh>Interactive Meshing menu. To visualize the mesh inside the 3D drawing, it can be useful to press the Increase transparency button on the left hand vertical toolbar. The model including the mesh should look as in the figure shown below:

SOLVING THE MODEL
To compute the solution, click the Solve button on the Main toolbar.

POSTPROCESSING AND VISUALIZATION
1 To view the solution on the metal plate boundaries you can hide the outer boundaries. Go to the Options menu, and select Suppress>Boundaries.

2 Select the metal plate boundaries (Boundaries 13–17 and 34). Click Apply, then click Invert. Click Cancel to close the Suppress Boundaries dialog box.

3 From the Postprocessing menu select Plot Parameters. Make sure that the Boundary plot is activated on the General page, and make sure that Surface resistive heating, time-average is selected in the Predefined quantities list.

4 Go to the Slice tab and select Magnetic field from the Predefined quantities list. Click OK to see the plot below.
To exclude the wire field from the view, you can plot the reduced field. To do this, select Postprocessing>Plot Parameters and select the Slice tab. In the Predefined quantities list select Reduced magnetic field. Click OK to see the plot below.
The final step is to integrate the total resistive losses over the metal plate surfaces. To do this select **Boundary Integration** from the **Postprocessing** menu. Select the metal boundaries (Boundaries 13–17 and 34), and pick **Surface resistive heating** from the **Predefined quantities** list. Click **OK**.

The result is shown at the bottom of the graphical user interface. The result shows a total loss of around 28 W.
Cold Crucible

Introduction

A cold crucible is used for the manufacturing of alloys that require a high degree of purity, like titanium alloys for the aeronautic industry. The cold crucible in this model is made of several water-cooled copper sectors forming the container in which the alloy is manufactured.

Model Definition

The crucible is sketched in the figure below. The harmonic current flowing in the coils induces a current flowing in the opposite direction along the edge of the crucible. The induced currents produced in each of the sectors make the cold crucible act as field concentrator.

To save computation time, exploit the symmetries of the model and set up only one quarter of the crucible. The flow lines of the magnetic field are normal to the symmetry plane inserted in the figure below. To understand this, note that the geometry is symmetric with respect to the plane, and that the current is tangential to the plane.

1. Model made in cooperation with Roland Ernst, Centre National de la Recherche Scientifique, Grenoble, France.
The first symmetry can be achieved by letting this plane be a boundary of the model. To this boundary, apply a boundary condition setting the tangential component of the magnetic field to zero.

The following figure indicates a second symmetry plane. As the flow lines of the magnetic field make closed loops around the coils, the field must be tangential to the symmetry plane.

To model this symmetry, use a boundary condition that sets the tangential component of the magnetic potential to zero.

The crucible operates at 10 kHz. At this frequency the currents flow very close to the surface of the conducting regions. The skin depth
is less than one millimeter, and the inner radius of the crucible is 5 cm. You can therefore model the currents as surface currents.

Because the electric potential does not need to be specified to generate currents, it is possible to work with the potential

$$\tilde{A} = A - \frac{i}{\omega} V$$

and thereby reduce the set of four equations for the $A$ and $V$ potentials to three equations for the $\tilde{A}$ potential (see “3D and 2D Quasi-Statics Application Modes” on page 170 in the AC/DC Module User’s Guide).

**Results and Discussion**

To compute the surface currents flowing into and out of the end of the crucible, you can use integrals at that boundary. From Kirchhoff’s current law the total current flowing into the boundary should be equal to the currents flowing out of it. The figure below shows the integrations along the $x$ side and $z$ side, where the start and end points of each curve correspond to the flow in and out of the boundary, respectively.

The total inflow to the boundary is 1.38 A and the total outflow is 1.40 A, which agrees with Kirchhoff’s power law within 2%.

**Model Library path:** ACDC_Module/General_Industrial_Applications/crucible
MODEL NAVIGATOR
1 In the Model Navigator, select 3D from the Space dimension list.
2 Then click on AC/DC Module>Quasi-Statics, Magnetic>Induction Currents to select the Quasi-Statics application mode.
3 Click OK.

OPTIONS AND SETTINGS
1 In the Constants dialog box in the Options menu, enter the following names and expressions.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>sigMetal</td>
<td>5e7[S/m]</td>
<td>Conductivity of metal</td>
</tr>
<tr>
<td>sigAir</td>
<td>1[S/m]</td>
<td>Conductivity of air</td>
</tr>
<tr>
<td>Js0</td>
<td>16.5[A/m]</td>
<td>Coil surface current</td>
</tr>
</tbody>
</table>

The electric conductivity \(\sigma = 1 \text{ S/m}\) for air is obviously not the physically correct value, but too large a contrast between the conductivities makes it difficult for the numerical algorithms to find a solution. The error you make by using an incorrect value for the conductivity in air is negligible for the currents on the surfaces.

2 In the Application Scalar Variables dialog box in the Physics menu, set the frequency variable \(\nu_{\text{emqav}}\) to 10000.

GEOMETRY MODELING
Draw the crucible and inductor in a 2D work plane and then extrude them into 3D.

1 Create a work plane by opening the Work-Plane Settings dialog box in the Draw menu and clicking OK to obtain the default work plane in the \(xy\)-plane.

2 Open the Axes/Grid Settings dialog box from the Options menu. Enter the axis settings in the table below on the Axis tab.

3 Then click on the Grid tab and clear the Auto check box and enter the grid settings according to the table below.

<table>
<thead>
<tr>
<th>AXIS</th>
<th>GRID</th>
</tr>
</thead>
<tbody>
<tr>
<td>x min</td>
<td>-0.3</td>
</tr>
<tr>
<td>x max</td>
<td>0.3</td>
</tr>
<tr>
<td>x spacing</td>
<td>0.1</td>
</tr>
<tr>
<td>Extra x</td>
<td>-0.17, -0.16, 0.155</td>
</tr>
</tbody>
</table>
4. Draw a circle C1 with radius 0.17 and a circle C2 with radius 0.16, both centered at the origin.

5. Select C1 and C2 and click the **Difference** button to create the solid object CO1.

6. Draw a circle C1 with radius 0.15 and a circle C2 with radius 0.05, both centered at the origin.

7. Select C1 and C2 and click the **Difference** button to create the solid object CO2.

8. Draw a rectangle R1 with the lower left corner at (−0.2, −0.2), **Width** 0.4, and **Height** 0.2.

9. Open the **Create Composite Object** dialog box and enter the set formula CO1 - R1 to create the composite object CO3.

10. Draw a new rectangle R1 with the lower left corner at (−0.2, −0.2), **Width** 0.4, and **Height** 0.2.

11. Open the **Create Composite Object** dialog box and enter the set formula CO2 - R1 to create the composite object CO1.

12. Draw a rectangle R1 with the lower left corner at (0, 0), **Width** 0.155, and **Height** 0.01.
13 Open the **Create Composite Object** dialog box and enter the set formula CO1-R1 to create the composite object CO2.

14 Select **Extrude** from the **Draw** menu to open the **Extrude** dialog box. Select the object CO3 and set the **Distance** to 0.05. Click **OK** to close the dialog box and create the extruded object EXT1.

15 Click on the **Geom2** tab to return to the work plane.

16 Open the **Extrude** dialog box again, and select the object CO2 and set the **Distance** to 0.1 to create the extruded object EXT2.

17 Now create a region of air surrounding the crucible. Press the **Block** button to open the **Block** dialog box and set the **Length** coordinates to (1, 0.5, 0.5). Click **More** and set the coordinates of the **Axis base point** to (-0.5, 0, 0). Click **OK** to close the dialog box and create the block BLK1.

18 Press the **Cylinder** button to open the **Cylinder** dialog box and set the **Radius** to 0.5 and the **Height** to 0.5. Click **OK** to close the dialog box and create the cylinder CYL1.

19 Open the **Create Composite Object** dialog box and enter the set formula BLK1*CYL1. Click the **Apply** button to create the object CO1.

20 Enter the set formula CO1-EXT1-EXT2 and click **OK**.
**PHYSICS SETTINGS**

**Boundary Conditions**

Enter boundary conditions according to the following table. Note that the impedance boundary condition has a Material Properties page where you enter the conductivity. For the surface current, enter the $x$, $y$, and $z$ components, which are $J_{s0}(-\sin\alpha, \cos\alpha, 0)$, where $\alpha$ is the azimuthal angle.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 1, 2, 4, 16</th>
<th>BOUNDARIES 3, 8</th>
<th>BOUNDARIES 5, 6, 7, 14, 15</th>
<th>BOUNDARIES 9–13, 17</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Magnetic insulation</td>
<td>Electric insulation</td>
<td>Surface current</td>
<td>Impedance boundary condition</td>
</tr>
<tr>
<td>$J_x$, $x$ comp.</td>
<td></td>
<td></td>
<td>$(-y/sqrt(x^2+y^2)) \cdot J_{s0}$</td>
<td></td>
</tr>
<tr>
<td>$J_y$, $y$ comp.</td>
<td></td>
<td></td>
<td>$(x/sqrt(x^2+y^2)) \cdot J_{s0}$</td>
<td></td>
</tr>
<tr>
<td>$J_z$, $z$ comp.</td>
<td></td>
<td></td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>$\sigma$</td>
<td></td>
<td></td>
<td></td>
<td>sigMetal</td>
</tr>
<tr>
<td>$\mu_r$</td>
<td></td>
<td></td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>$\varepsilon_r$</td>
<td></td>
<td></td>
<td>1</td>
<td></td>
</tr>
</tbody>
</table>

**Subdomain Settings**

On the Electric Parameters page, enter properties according to the following table:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\sigma$</td>
<td>sigAir</td>
</tr>
</tbody>
</table>

**OPTIONS AND SETTINGS**

After solving the problem, the postprocessing includes a study of how the current flows on the rectangular end of the crucible (Boundary 17). To prepare for that, define two coupling variables constituting the integrated current over a cross section of this boundary. $J_{sx\_emqav}$ is the $x$ component of the surface current, and $I_{sx}$ is the integral of $J_{sx\_emqav}$ in the vertical direction across Boundary 17,

$$I_{sx}(x) = \int J_{sx}(x, z) \, dz$$

$J_{sz\_emqav}$ is the $z$ component of the surface current, and $I_{sz}$ is the integral of $J_{sz\_emqav}$ in the horizontal direction across Boundary 17,

$$I_{sz}(z) = \int J_{sz}(x, z) \, dx$$
The table below summarizes the variable definitions.

<table>
<thead>
<tr>
<th>VARIABLE</th>
<th>TYPE</th>
<th>SOURCE</th>
<th>DESTINATION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Isx</td>
<td>Projection</td>
<td>Boundary: 17</td>
<td>Edge: 38</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Integrand: Jsx_emqa</td>
<td>Destination transformation: x</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Integration order: 2</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Source transformation, x: x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Source transformation, y: z</td>
<td></td>
</tr>
<tr>
<td>Isz</td>
<td>Projection</td>
<td>Boundary: 17</td>
<td>Edge: 40</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Integrand: Jsz_emqa</td>
<td>Destination transformation: z</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Integration order: 2</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Source transformation, x: z</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Source transformation, y: x</td>
<td></td>
</tr>
</tbody>
</table>

1. In the **Boundary Projection Variables** dialog box, select Boundary 17, enter the **Name** Isx, set the **Expression** to Jsx_emqa, and use the **Integration order** 2. Select the **General transformation** and fill in the **x** and **y** edit fields with **x** and **z**, respectively. The integration will be performed over the second coordinate, **z**, and Isx will therefore be a function of **x**.

2. On the **Destination** page, set the **Level** to **Edge**, and select Edge 38, which is one of the edges of Boundary 17, and set the **Destination transformation** to **x**.

3. Go back to the **Source** page and add a second projection variable, Isz, select Boundary 17 and set the **Integrand** to Jsz_emqa, the **Integration order** to 2. Select the **General transformation**, and fill in **z** and **x** in the fields **x** and **y**. In this case the integration will be performed over **x**.

4. On the **Destination** page, select Edge 40, and set the **Destination transformation** to **z**.

**MESH GENERATION**

To get a good quality mesh, set the maximum mesh element size manually on the boundaries adjacent to the thin regions in the model.

1. Open the **Free Mesh Parameters** dialog box

2. Go to the **Boundary** page, select Boundaries 5, 7, 9, 13, 14, and 15 and set the **Maximum element size** to 0.04.

3. Initialize the mesh.

**COMPUTING THE SOLUTION**

1. Press the **Solve** button. (use the default solver)
To see the currents on the crucible, open the Suppress Boundaries dialog box from the Options menu and suppress Boundaries 1–4, 8, and 16.

2 Open the Plot Parameters dialog box.

3 On the General page, clear the Slice check box and select the Boundary and Arrow check boxes in the Plot type area.

4 Click the Boundary tab and select Surface current density, norm from the Predefined quantities list on the Boundary Data page.

5 Click the Arrow tab. From the Plot arrows on list, select Boundaries. In the Arrow parameters area, set the Arrow type to Arrow. Clear the Auto check box, and set the Scale factor to 3.

To verify the current conservation on the end boundary of the crucible, Boundary 17, make use of the coupling variables $I_{sx}$ and $I_{sz}$:

1 From the Postprocessing menu, open the Domain Plot Parameters dialog box.

2 Click the Line tab and select Edge 38. Enter the Line expression $\text{abs}(I_{sx})$, then click Apply to generate the plot.

3 The left side of the plot corresponds to $x = 0.15$ and the right side to $x = 0.05$. The value at $x = 0.15$ is the total current flowing in through the right edge of the
boundary, and the value at $x = 0.05$ is the total current flowing out through the left edge of the boundary.
Select Edge 40 and change the Line expression to \( \text{abs}(I_{sz}) \). The left side of the plot corresponds to \( z = 0 \) and the right side to \( z = 0.1 \). The value at \( z = 0.1 \) is the total current flowing out through the top edge of the boundary.

By studying the plots, you can see that the current flowing in equals the current flowing out. To more accurately verify this, export the FEM structure to the COMSOL Script or MATLAB workspace by selecting Export FEM structure as 'fem' from the File menu. (This requires that you run COMSOL Multiphysics together with COMSOL Script or MATLAB.) Then enter the commands

\[
\begin{align*}
I_{inx} &= \text{postinterp}(\text{fem},'\text{abs}(I_{sx})',0.1,'\text{dom}',38); \\
I_{inz} &= \text{postinterp}(\text{fem},'\text{abs}(I_{sz})',0.0,'\text{dom}',40); \\
I_{outx} &= \text{postinterp}(\text{fem},'\text{abs}(I_{sx})',0.0,'\text{dom}',38); \\
I_{outz} &= \text{postinterp}(\text{fem},'\text{abs}(I_{sz})',0.1,'\text{dom}',40); \\
\frac{(I_{outx}+I_{outz})}{(I_{inx}+I_{inz})} &= 1.0322
\end{align*}
\]

The evaluation points along the edges are given in the local coordinate of the edge. As the length of these edges is 0.1, the coordinate lie in the range 0 to 0.1. The current flowing in and the current flowing out differ by less than two percent.
Electric Impedance Sensor

Introduction

Electric impedance measurements are used for imaging and detection. The applications range from nondestructive testing and geophysical imaging to medical imaging. One example is to monitor the lung function of babies in neonatal intensive care. The frequency ranges from less than 1 Hz to about 1 GHz depending on the application.

This model simulates a single electrode placed on a conducting block with an air filled cavity inside. The block is connected to ground on the lower face and on the sides. The analysis shows how the lateral position of the cavity affects the measured impedance, which you compute in a postprocessing step.

![Figure 5-1: The electrode is placed on a conducting block with an air-filled cylindrical cavity inside.](image)

Model Definition

In the AC/DC Module you solve the problem using the 2D Small In-Plane Currents application mode. This application mode is useful for the modeling of AC problems when inductive effects are negligible. A sufficient requirement for this is that the skin depth is large compared to the size of the geometry. The skin depth, $\delta$, is given by
where $\omega$ is the angular frequency, $\mu$ is the permeability, and $\sigma$ is the conductivity. This model uses nonmagnetic materials with a frequency of 1 MHz and a typical electric conductivity of 1 mS/m, so the skin depth is about 15 m. The size of the geometry is about 1 m.

**DOMAIN EQUATIONS**

When induction is neglected, the electric field is curl free and can be assigned a scalar potential, $V$. The equation of continuity for the conduction and displacement currents then becomes

$$\nabla \cdot (\sigma j \omega \varepsilon_0 V V) = 0$$

where $\varepsilon_0$ is the permittivity of free space, and $\varepsilon_r$ is the relative permittivity. The electric field $E$ and displacement $D$ are obtained from the gradient of $V$:

$$E = -\nabla V$$

$$D = \varepsilon_0 \varepsilon_r E$$

**BOUNDARY CONDITIONS**

Ground potential boundary conditions are applied on the lower and vertical edges of the domain. The upper edge is set to insulation except at the electrode, where a uniformly distributed current source of 1 A is applied.

$$n \cdot J = J_n$$
Results and Discussion

Figure 5-2 shows the calculated impedance and its phase angle as functions of air cavity coordinate. When the cavity passes under the electrode, a sharp peak appears in the impedance value.

![Graph showing impedance and phase angle as functions of air cavity coordinate. Peaks occur when the cavity is beneath the electrode.](image.png)

Figure 5-2: Absolute value and phase for the impedance as functions of air cavity coordinate. The peaks occur when the cavity is beneath the electrode.

Model Library path: ACDC_Module/General_Industrial_Applications/electric_impedance

Modeling Using the Graphical User Interface

**MODEL NAVIGATOR**

1. Select 2D in the Space dimension list.

2. In the AC/DC Module>Quasi-Statics, Electric>In-Plane Electric Currents application mode.

3. Click OK.

**OPTIONS AND SETTINGS**

1. Select Axes/Grid Settings from the Options menu to open the Axes/Grid Settings dialog box.

2. On the Axis tab set x min to -0.55 and x max to 0.55. Set the interval limits on the y-axis to -0.55 and 0.
3 Click the **Grid** tab and then clear the **Auto** check box to manually define new grid settings.

4 Set **x spacing** to 0.1 and give the values -0.01 0.01 in the **Extra x** text field. Set **y spacing** to 0.1.

5 To define some global constants to be used in your model, select **Constants** from the **Options** menu.

6 In the **Constants** dialog box, enter the following variable names, expressions, and (optionally) descriptions:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>sig_bulk</td>
<td>1[mS/m]</td>
<td>Bulk conductivity</td>
</tr>
<tr>
<td>eps_r_bulk</td>
<td>5</td>
<td>Relative permittivity in bulk</td>
</tr>
<tr>
<td>x0</td>
<td>0[m]</td>
<td>x position of cavity center</td>
</tr>
<tr>
<td>y0</td>
<td>-0.1[m]</td>
<td>y position of cavity center</td>
</tr>
<tr>
<td>r0</td>
<td>0.09[m]</td>
<td>Cavity radius</td>
</tr>
</tbody>
</table>

**GEOMETRY MODELING**

1 Click the **Rectangle/Square** button on the Draw toolbar or select the corresponding entry in the **Draw** menu, then draw a rectangle with opposite corners at (−0.5, −0.5) and (0.5, 0), using the left mouse button.

2 Click the **Point** button on the Draw toolbar and draw a point at (−0.01, 0) and another point at (0.01, 0).
**PHYSICS SETTINGS**

*Scalar Variables*
Open the dialog box by selecting *Scalar Variables* from the *Physics* menu and set the frequency $\nu_{emqvw}$ to $1e6$.

*Boundary Conditions*
Ground potential boundary conditions are applied on the lower and vertical edges of the domain. The upper edge is set to insulation except at the electrode, where a port is defined using the fixed current density property. This applies a uniformly distributed current source of 1 A to the electrode. The following table shows the corresponding boundary settings:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 4</th>
<th>BOUNDARIES 1, 2, 6</th>
<th>BOUNDARIES 3, 5</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Port</td>
<td>Ground</td>
<td>Electric insulation</td>
</tr>
<tr>
<td>Port number</td>
<td>1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Use port as input</td>
<td>selected</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Input property</td>
<td>Fixed current density</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

*Subdomain Settings*
To model the cavity, use functions and logical expressions for the permittivity and conductivity distributions. This has the advantage that you can change the position of the cavity without modifying the geometry. Use the default constitutive relation,

$$D = \varepsilon_0 \varepsilon_r E$$

and enter the material parameters according to the table below.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\sigma$</td>
<td>sig_bulk*(((x-x0)^2+(y-y0)^2)&gt;r0^2)</td>
</tr>
<tr>
<td>$\varepsilon_r$</td>
<td>1+(eps_r_bulk-1)*(((x-x0)^2+(y-y0)^2)&gt;r0^2)</td>
</tr>
</tbody>
</table>

**MESH GENERATION**
1. Open the *Free Mesh Parameters* dialog box.
2. Select *Normal* from the *Predefined mesh sizes* list on the *Global* page. Select *Custom mesh size* and specify a *Maximum element size* of 0.01.
3. Initialize the mesh.

**COMPUTING THE SOLUTION**
1. In the *Solver Parameters* dialog box, select *Parametric* in the *Solver* list.
2 Type $x_0$ in the Parameter name edit field and `linspace(-0.5,0.5,21)` in the Parameter values edit field. Click OK.

3 Click the Solve button on the Main toolbar.

**POSTPROCESSING AND VISUALIZATION**

After solving the problem, a surface plot for the electric potential appears. You can use the buttons on the Plot toolbar to get other types of plots. To visualize the current distribution on a dB scale, open the Plot Parameters dialog box.

1 Select Plot Parameters from the Postprocessing menu to open the Plot Parameters dialog box.

2 On the General page, select Surface as the Plot type and select the Parameter value 0.

3 On the Surface page, set the Surface Expression to $20\log_{10}(\text{norm}_\text{emqvw})$.

4 Click Apply to generate a plot.

5 To better see the variations the color range can be changed. Click Range to open the Color Range dialog box.

6 Clear the Auto check box to manually define new range settings.

7 Keep the value for Max but change the Min value to -35. Click OK.

![](image)

The impedance is defined as the ratio of voltage to total current at the electrode. You can visualize it as a function of the cavity position using the cross-sectional domain plot.
tool available from the Postprocessing menu. The impedance is available as a postprocessing variable, $Z_{11\_emqvw}$.

1. Open the Domain Plot Parameters dialog.
2. Select all solutions from the Solution to use list by pressing Ctrl+A.
3. Now click the Point tab and set Expression to $\text{abs}(Z_{11\_emqvw})$ and select Point 1. Click Apply to get the following figure.

![Graph showing $\text{abs}(Z_{11\_emqvw})$ as a function of $x_0$.](image)

4. Finally, repeat the last step but set the Expression to $180 \times \text{angle}(Z_{11\_emqvw})/\pi$ to get the phase angle of the impedance.

![Graph showing $180 \times \text{angle}(Z_{11\_emqvw})/\pi$ as a function of $x_0$.](image)
One-Sided Magnet and Plate

Introduction

Permanent magnets with a one-sided flux are used to attach posters and notes to refrigerators and notice boards but can also be found in advanced physics applications like particle accelerators. The one-sided flux behavior is obtained by giving the magnet a magnetization that varies in the lateral direction (Ref. 1). As no currents are present, it is possible to model a permanent magnet using a scalar magnetic potential formulation. This model shows this technique to model a cylindrical one-sided permanent magnet. A special technique to model thin sheets of high permeability material was used to model a thin $\mu$-metal plate next to the magnet. This circumvents the difficulty of volumetric meshing of thin extended structures in 3D.

![Figure 5-3: A cylindrical magnet above a $\mu$-metal plate is modeled.](image)

Model Definition

In a current free region, where

$$\nabla \times \mathbf{H} = 0$$

you can define the scalar magnetic potential, $V_m$, from the relation

$$\mathbf{H} = -\nabla V_m$$
This is analogous to the definition of the electric potential for static electric fields. Using the constitutive relation between the magnetic flux density and magnetic field

\[ \mathbf{B} = \mu_0 (\mathbf{H} + \mathbf{M}) \]

together with the equation

\[ \nabla \cdot \mathbf{B} = 0 \]

you can derive the following equation for \( V_m \):

\[ -\nabla \cdot (\mu_0 \nabla V_m - \mu_0 \mathbf{M}) = 0 \]

It can be shown that applying a laterally periodic magnetization of

\[ \mathbf{M} = (M_{\text{pre}} \sin (kx), 0, M_{\text{pre}} \cos (kx)) \]

results in a magnetic flux that only emerges on one side of the magnet.

**Results and Discussion**

Figure 5-4 shows the calculated magnetic flux density and direction for the one-sided magnet. The resulting force on the plate is considerably higher for the case with the one-sided magnetization compared to the case with uniform magnetization of the same amplitude.
Figure 5-4: The magnetic flux density and direction is plotted in a cross section of the geometry. The one-sided behavior is clearly seen as the flux does not emerge on the top of the magnet.

Reference

Model Library path: ACDC_Module/General_Industrial_Applications/one_sided_magnet

Modeling Using the Graphical User Interface

MODEL NAVIGATOR
1. Select 3D from the Space dimension list.
2 Select the **AC/DC Module>Statics, Magnetic>Magnetostatics, No Currents** application mode.

3 Click **OK**.

**OPTIONS AND SETTINGS**

In the **Constants** dialog box enter the following names and expressions. The description field is optional and can be omitted.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>k</td>
<td>pi/10[mm]</td>
<td>Wave number in x direction</td>
</tr>
<tr>
<td>M_pre</td>
<td>5e5[A/m]</td>
<td>Magnetization amplitude in magnet</td>
</tr>
<tr>
<td>mu_r</td>
<td>4e4</td>
<td>Relative permeability in plate</td>
</tr>
<tr>
<td>th</td>
<td>0.5[mm]</td>
<td>Plate thickness</td>
</tr>
</tbody>
</table>

**GEOMETRY MODELING**

1 Use the **Cylinder** tool to create a cylinder with the radius 0.01 and the height 0.005.

2 Use the **Sphere** tool to create a sphere with the radius 0.02.

3 Open the **Work-Plane Settings** dialog from the **Draw** menu and use the default work plane in the xy-plane. Set z to -0.005 and click **OK**.

4 First click the **Projection of All 3D Geometries** toolbar button and then click the **Zoom Extents** toolbar button to adapt the axis settings of the drawing board.

5 Draw a circle C1 with radius 0.01 centered at (0, 0).
Select C1, select **Embed** from the **Draw** menu, and then click **OK**.

**PHYSICS SETTINGS**

**Subdomain Settings**

In the **Subdomain Settings** dialog box, change the **Constitutive relation** in Subdomain 2 to allow for a premagnetization vector \( \mathbf{M} \) and enter the values according to the table below.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \mathbf{M} )</td>
<td>( \mathbf{M}<em>{\text{pre}} \sin(kx) \ 0 \ 0 \mathbf{M}</em>{\text{pre}} \cos(kx) )</td>
</tr>
</tbody>
</table>

This kind of premagnetization will result in a magnetic flux that only emerges on the lower side of the magnet. That is, on the side where the \( \mu \)-metal plate is. Click **OK**.

**Boundary Conditions**

Along the exterior boundaries, the magnetic field should be tangential to the boundary as the flow lines should form closed loops around the magnet. The natural boundary condition from the equation is

\[
\mathbf{n} \cdot (\mu_0 \nabla V_m - \mu_0 \mathbf{M}) = \mathbf{n} \cdot \mathbf{B} = 0
\]

Thus the magnetic field is made tangential to the boundary by a Neumann condition on the potential. On the interior boundary representing the \( \mu \)-metal plate, you apply
a special boundary condition for thin sheets of highly permeable material. Such plates are often used for the purpose of magnetic shielding.

Enter these boundary conditions according to the following table. To access interior boundaries, select the **Interior boundaries** check box.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 1–4, 10, 11, 13, 14</th>
<th>BOUNDARY 5</th>
<th>BOUNDARIES 6–9, 12, 15</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Magnetic insulation</td>
<td>Magnetic shielding</td>
<td>Continuity</td>
</tr>
<tr>
<td>Relative permeability</td>
<td></td>
<td>$\mu_r$</td>
<td></td>
</tr>
<tr>
<td>Thickness</td>
<td></td>
<td>$th$</td>
<td></td>
</tr>
</tbody>
</table>

**Point Settings**
So far the magnetic potential is not constrained anywhere and the problem has infinite number of solutions. Thus, you must supply a condition fixing it to a specific value somewhere. In the **Point Settings** dialog box, constrain the **Magnetic potential** to zero at Point 1.

**Mesh Generation**
Click the **Initialize Mesh** button on the Main toolbar.

**Computing the Solution**
There is no need to change the solver settings. The default solver settings are the conjugate gradients solver and the algebraic multigrid preconditioner. This is normally the most efficient solver setting for Poisson’s equation, which is the type of equation that this model solves. This problem generates symmetric matrices so this option is selected as default. Click the **Solve** button on the Main toolbar. The computation time is about 6 seconds on a 3 GHz P4 machine.

**Postprocessing and Visualization**
The default plot shows a slice plot of the magnetic potential. To reproduce the plot in Figure 5-4 on page 262, follow these steps:

1. Click the **Plot Parameters** button on the Main toolbar.
2. On the **General** page, select the **Slice** and **Arrow** check boxes in the **Plot type** area.
3. Click the **Slice** tab. In the **Predefined quantities** list, select **Magnetic flux density, norm**. Set the **Slice positioning x levels** to 0, set **y levels** to 1, and set **z levels** to 0.
4. Click the **Arrow** tab. From the **Predefined quantities** list on the **Subdomain Data** page, select **Magnetic flux density**.
5 In the Arrow positioning area, set the numbers of x points to 50, y points to 1, and z points to 50.

6 In the Arrow parameters area, select Cone from the Arrow type list.

7 Click OK to close the dialog box and generate the plot.

8 Use the Zoom Window tool on the Main toolbar to zoom in on the magnet and plate.

Magnetic Field in the Plate
The magnetic field in the plate is not available as a predefined postprocessing variable. To make this quantity more readily available, define extra expressions that you can use for postprocessing:

1 From the Options menu, select Expressions>Boundary Expressions.

2 Specify the variable names and expressions on Boundary 5 (the plate) according to the following table.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>NORMH</td>
<td>sqrt(VmTx<em>VmTx+VmTy</em>VmTy+VmTz*VmTz)</td>
</tr>
<tr>
<td>NORMB</td>
<td>mu0_emnc<em>mu_r</em>NORMH</td>
</tr>
</tbody>
</table>

3 Click OK to close the dialog box.

4 From the Solve menu, select Update Model to compute values for the newly defined variables using the existing solution.

It is now possible to display the magnetic flux density in the plate using the available postprocessing functionality:

1 Select Plot Parameters from the Postprocessing menu or click the Plot Parameters button on the Main toolbar to open the Plot Parameters dialog box.

2 In the Plot type area on the General page, clear the Slice and Arrow check boxes and select the Boundary check box.

3 On the Boundary page, set the Expression to NORMB.
Force Calculation

To calculate the force on the plate, use the surface stress tensor

$$\mathbf{n}_1^T \mathbf{T}_2 = -\frac{1}{2} (\mathbf{H} \cdot \mathbf{B}) \mathbf{n}_1 + (\mathbf{n}_1 \cdot \mathbf{H}) \mathbf{B}^T$$

where $\mathbf{n}_1$ is the boundary normal pointing out from the plate and $\mathbf{T}_2$ the stress tensor for air.

In this model the $\mathbf{H}$ and $\mathbf{B}$ fields are discontinuous across the plate, which makes it necessary to evaluate the fields on both sides of the plate.

All surfaces have an up and a down side. To find out which side is up and which is down, you can make an arrow plot of the components of the up normal ($\mathbf{unx}$, $\mathbf{uny}$, $\mathbf{unz}$) on the boundaries. The up normal is the outward normal from the up side. In this case, you evaluate the fields on both sides and there is no need to know the direction of the up normal. The application mode defines variables for the surface stress tensor on the up and down side of the boundaries, for example, $\mathbf{unTz_emnc}$ and $\mathbf{dnTz_emnc}$ for the $z$ component of the surface stress tensor.
Now, the $x$ and $y$ components of the force vanish for symmetry reasons. To find the force in the $z$ direction, integrate the surface stress tensor over the plate. In the **Boundary Integration** dialog box, select Boundary 5 and enter the **Expression** \(\text{unTz\_emnc+dnTz\_emnc}\). Click **OK** to evaluate the integral, which gives 1.2 N. This result is displayed in the message log at the very bottom of the user interface.

**Force Calculation with Uniform Magnetization**

In the **Constants** dialog box change the constant $k$ to 0 in order to obtain a uniform magnetization of \((0, 0, M_{\text{pre}})\). Solve and calculate the force on the plate again. What is the conclusion?

**Modeling Using a Nonlinear Magnetic Material in the Plate**

Magnetic saturation effects are important in many applications. This step of the modeling process shows how to include a nonlinear magnetic material with saturation in the plate. The relative permeability \(\mu_r\) is a function of the magnitude, \(|H|\) of the magnetic field as described by the following equation:

\[
\mu_r = 1 + \left(\left(\mu_{r_{\text{max}}} - 1\right)^{-1} + \left(\frac{\mu_0|H|}{B_{\text{sat}}}\right)^n\right)^{-1}
\]

\(B_{\text{sat}}\) is the magnetic saturation flux, which for \(\mu\text{-metal}\) is about 1.2 T.
Before modifying the model, we recommend that you save it under a new name. You do this from the **File** menu by selecting **Save As**.

**OPTIONS AND SETTINGS**

1. In the **Constants** dialog box enter the following names, expressions, and descriptions (the descriptions are optional); when done, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>k</td>
<td>(\pi/10[\text{mm}])</td>
<td>Wave number in x direction</td>
</tr>
<tr>
<td>(N_{pre})</td>
<td>5e5[A/m]</td>
<td>Magnetization amplitude in magnet</td>
</tr>
<tr>
<td>(\mu_r_{max})</td>
<td>4e4</td>
<td>Maximum relative permeability in plate</td>
</tr>
<tr>
<td>(th)</td>
<td>0.5[\text{mm}]</td>
<td>Plate thickness</td>
</tr>
<tr>
<td>(B_{sat})</td>
<td>1.2[T]</td>
<td>Saturation flux density</td>
</tr>
<tr>
<td>(N)</td>
<td>1</td>
<td>Model order parameter</td>
</tr>
</tbody>
</table>

Use expression variables for the nonlinear permeability.

2. From the **Options** menu, select **Expressions>Boundary Expressions**.

3. Specify the variable names and expressions on Boundary 5 (plate) according to the following table; when done, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>(\text{NORMH})</td>
<td>(\sqrt{\text{VmTx}^2+\text{VmTy}^2+\text{VmTz}^2})</td>
</tr>
<tr>
<td>(\text{NORMB})</td>
<td>(\mu_0_{\text{emnc}}\mu_r\times\text{NORMH})</td>
</tr>
<tr>
<td>(\mu_r)</td>
<td>(\frac{1}{1/(1-\mu_r_{max})-(\mu_0_{\text{emnc}}\text{NORMH}/B_{sat})^{1/N}})</td>
</tr>
</tbody>
</table>

**PHYSICS SETTINGS**

*Initial Conditions*

The nonlinear solver works by performing iterations, linearizing and solving the model for a sequence of operating points that converges to the final solution. For this to work properly in the first iteration, you need to start using an initial guess with a nonzero gradient:

1. From the **Physics** menu, open the **Subdomain Settings** dialog box.
2. Click the **Init** tab. Select all subdomains in the **Subdomain selection** list.
3. In the \(\text{Vm}(t_0)\) edit field, type \(1[A/m]\times\sqrt{x^2+y^2+z^2}\).
4. Click **OK**.
CHAPTER 5: GENERAL INDUSTRIAL APPLICATION MODELS

Computing the Solution

Click the Solve button on the Main toolbar.

The computation time is about 35 seconds on a 3 GHz P4 machine.

Postprocessing and Visualization

Plot the relative permeability in the plate and the magnetic flux density using the available postprocessing functionality:

1. Click the Plot Parameters button on the Main toolbar.
2. On the General page, select the Boundary and Arrow check boxes in the Plot type area.
3. On the Boundary page, set the Expression to \( \mu_r \).
4. For the Arrow plot, use the same settings as when generating Figure 5-4. Thus, click OK to close the dialog box and generate the plot.
The plate has begun to saturate as the relative permeability is well below \(4 \cdot 10^4\) in the blue areas. Try increasing the value of the premagnetization \(M_{\text{pre}}\) to \(10^6\) in the Constants dialog box and solve again to see a more pronounced saturation effect.

The computation time is about 100 seconds on a 3 GHz P4 machine.

**Force Calculation**

In the **Boundary Integration** dialog box, select Boundary 5 and enter the **Expression** \(u\n Tz_\text{emnc} + dTz_\text{emnc}\). Click **OK** to evaluate the integral, which gives 3.3 N. This result appears in the message log at the bottom of the COMSOL Multiphysics user interface.
Magnetic Signature of a Submarine

Introduction

A vessel traveling on the surface or under water gives rise to detectable local disturbances in the Earth’s magnetic field. These disturbances can be used to trigger weapon systems. The magnetic signature of a ship can be reduced by generating a counteracting magnetic field of suitable strength and direction based on prior knowledge of the magnetic properties of the vessel. An important step in the design of a naval ship is therefore to predict its magnetic signature. Another application where magnetic signatures are of great importance is in urban traffic control: magnetic sensors, buried in our streets, are used to sense vehicles and control traffic lights.

Ships and cars are both to a large extent made of sheet metal. This makes them hard to simulate using standard finite element analysis because volume meshes of thin extended structures are difficult to generate and tend to become very large. This model demonstrates a powerful technique that circumvents the problem by modeling the sheet metal as 2D faces embedded in a 3D geometry. Thus it is only necessary to create comparatively inexpensive 2D face meshes in addition to the 3D volume mesh used for the surrounding medium. A tangential projection of the 3D equation is then solved on the 2D face mesh.

Figure 5-5: Submarine HMAS Collins. Image courtesy of Kockums AB.

This model also demonstrates the use of the Reduced field formulation available in the AC/DC module. This feature provides a convenient way to obtain the magnetic
signature of the submarine by allowing the user to define the background field as a predefined quantity and solving only for the perturbations in this field.

**Model Definition**

In magnetostatic problems, where no currents are present, the problem can be solved using a scalar magnetic potential. This model demonstrates a special technique for modeling thin sheets of high permeability materials, and also shows the use of the Reduced field formulation in the AC/DC module for conveniently modeling perturbations in a known background field.

The model geometry is shown in Figure 5-6. It consists of face objects representing the submarine enclosed in a 3D box representing the surrounding water.

![Figure 5-6: The model geometry.](image)

**DOMAIN EQUATIONS**

In a current-free region, where

\[
\nabla \times \mathbf{H} = \mathbf{0}
\]

it is possible to define the scalar magnetic potential, \( V_m \), from the relation
This is analogous to the definition of the electric potential for static electric fields. Using the constitutive relation between the magnetic flux density and magnetic field
\[ \mathbf{B} = \mu_0(\mathbf{H} + \mathbf{M}) \]
together with the equation
\[ \nabla \cdot \mathbf{B} = 0 \]
you can derive an equation for \( V_m \),
\[-\nabla \cdot (\mu_0 \nabla V_m - \mu_0 \mathbf{M}) = 0 \]
In this model you use the reduced field formulation, which means that you only solve for the potential \( V_m \) corresponding to the perturbation (reduced) field. Also keeping in mind that the magnetization, \( \mathbf{M} \), is zero for the materials considered in this model, the equation you solve reads
\[-\nabla \cdot (\mu_0 \nabla V_m + \mathbf{B}_{ext}) = 0 \]
where \( \mathbf{B}_{ext} \) is a known background field, in this case the earth’s magnetic field of 0.5 G.

**Boundary Conditions**
The exterior boundaries of the box are insulating for the reduced magnetic field:
\[-\mathbf{n} \cdot \mathbf{B}_{red} = 0 \]
On the face objects representing the hull of the submarine, you apply a 2D tangential projection of the 3D domain equation where the thickness and permeability of the hull are introduced as parameters. This is readily available in the used formulation as a shielding boundary condition, which is useful for modeling of highly permeable thin sheets. Corresponding boundary conditions are available in the Conductive Media DC and Electrostatics application modes for modeling of thin sheets with high conductance and high permittivity respectively.

**Results and Discussion**
Figure 5-7 shows the total magnetic flux density in a horizontal slice plot 7.5 m below the keel of the submarine. A distinct field perturbation due to the presence of the vessel can be seen. The magnitude and direction of the tangential magnetic field in the hull of the vessel is shown using arrows. The reduced field is visualized as isolevels of the
reduced magnetic potential. This gives a good picture of the perturbation caused by the presence of the submarine in the background field.

Figure 5-7: The slice color plot shows the total magnetic flux density (left color scale). The arrows show the direction and strength of the tangential magnetic field in the hull. The isolevels show the reduced magnetic potential (right color scale).

**Model Library path:** ACDC_Module/General_Industrial_Applications/submarine

**Modeling Using the Graphical User Interface**

**MODEL NAVIGATOR**

1. Start COMSOL Multiphysics.
2. From the **Space dimension** list, select **3D**.
3. From the **Application Modes** list, select **AC/DC Module>Statics, Magnetic>Magnetostatics, No Currents>Reduced potential**.
4. Click **OK**.
GEOMETRY MODELING

1. Open the Work-Plane Settings dialog box from the Draw menu, use the default xy work plane and click OK.

2. From the Options menu, open the Axes/Grid Settings dialog box.

3. On the Grid page, clear the Auto check box.

4. Enter grid settings according to the following table; when done, click OK.

<table>
<thead>
<tr>
<th>GRID</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>x spacing</td>
<td>0.5</td>
</tr>
<tr>
<td>y spacing</td>
<td>0.5</td>
</tr>
</tbody>
</table>

5. Click the Rectangle/Square button on the Draw toolbar to create a rectangle with its lower left corner at (−12.5, −2.5) with a width of 22.5 and a height of 5.

6. Click the Ellipse/Circle (Centered) button on the Draw toolbar to create a circle with the radius 2.5 and its center at (−12.5, 0).

7. Click the 3rd Degree Bézier Curve button on the Draw toolbar and then click in sequence at the following points (10.0, 2.5), (13.0, 2.5), (13.0, 1.0) and (17.0, 1.0). Then, select the Line tool from the toolbar and click at (17.0, -1.0). Finally, go back to the 3rd Degree Bézier Curve tool and click at (13.0, -1.0), (13.0, -2.5) and (10.0, -2.5). Close the curve by clicking the right mouse button.

8. Press Ctrl+A to select all objects and then click the Union button on the toolbar.
9 Click the **Delete Interior Boundaries** button on the Draw toolbar, then click the **Zoom Extents** button.

10 Click the **Rectangle/Square** button on the Draw toolbar to create a rectangle with its lower-left corner at \((-15, -2.5)\), a width of 32, and a height of 2.5.

11 Press Ctrl+A to select all objects and then click the **Difference** button on the Draw toolbar.
12 Click the **Zoom Extents** button.

13 Select the composite object CO2.

14 From the **Draw** menu, open the **Revolve** dialog box. Set the coordinates for the **Second point** to (1, 0), then click **OK** to revolve into the 3D geometry.

15 Go back to the work plane **Geom2**.

16 From the **Draw** menu, choose **Specify Objects>Ellipse**. Create an ellipse with the **A-semiaxis** 2.5 and the **B-semiaxis** 0.625 and its center at (0, 0). When done, click **OK**.

17 With the ellipse selected, open the **Extrude** dialog box from the **Draw** menu and extrude it a **Distance** of 2 m.

18 In the 3D view, click the **Move** button in the Draw toolbar to move the extruded object a distance of 2 m in the z direction.

19 Press Ctrl+A to select all objects and then click the **Union** button on the toolbar.

20 Click the **Delete Interior Boundaries** button on the Draw toolbar.
21. Click the **Coerce to Face** button on the toolbar, then click the **Zoom Extents** button.

![Diagram of a submarine](image)

22. Click the **Block** button on the Draw toolbar, set the **Base** to **Center**, the **Axis base point** to (0, 0, 0), and the **Length** to (100, 50, 50); when done, click **OK**.

### PHYSICS SETTINGS

**Application Scalar Variables**

1. To define the external magnetic field, choose **Physics>Scalar Variables** to open the **Application Scalar Variables** dialog box.

2. Verify that the external magnetic flux density is defined as follows (these should be the default settings):

<table>
<thead>
<tr>
<th>VARIABLE</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>extH0x_emnc</td>
<td>0</td>
</tr>
<tr>
<td>extH0y_emnc</td>
<td>0</td>
</tr>
<tr>
<td>extH0z_emnc</td>
<td>(-5 \times 10^{-5}[T]/\mu_0_emnc)</td>
</tr>
</tbody>
</table>

3. Click **OK** to close the **Application Scalar Variables** dialog box.

**Subdomain Settings**

Keep the default subdomain settings (these represent air).
**Boundary Conditions**

On all of the exterior boundary conditions, apply magnetic insulation on the reduced field, leaving the background field unaffected. This is represented by the condition **External magnetic flux density**. Note that this is different from **Magnetic insulation** which will operate on the total field.

On the interior boundaries representing the hull of the submarine, apply a special boundary condition denoted **Magnetic shielding**. This makes use of a 2D tangential projection of the 3D domain equation where the thickness and permeability of the hull are introduced as parameters.

Enter the boundary conditions according to the following table. In order to access the interior boundaries, select the **Interior boundaries** check box.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 1–5, 27</th>
<th>BOUNDARIES 6–26</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>External Magnetic flux density</td>
<td>Magnetic shielding</td>
</tr>
<tr>
<td>( \mu_r )</td>
<td>700</td>
<td></td>
</tr>
<tr>
<td>( d )</td>
<td>0.05</td>
<td></td>
</tr>
</tbody>
</table>

**Mesh Generation**

1. Open the **Free Mesh Parameters** dialog box.
2. Click the **Custom mesh size** button. Type 0.5 in the field **Maximum element size scaling factor**, and type 0.4 in the **Mesh curvature factor** edit field. This limits the maximum mesh size to one half of the default value and provides a higher resolution of the curvature than the default settings for a normal 3D mesh.
3. Click **OK**, then click the **Initialize Mesh** button.

**Computing the Solution**

Click the **Solve** button on the Main toolbar. This starts the analysis using the default solver, the Conjugate gradients solver, and the default preconditioner, Algebraic multigrid.

The computation time is about 1 minute on a 3 GHz P4 machine.

**Postprocessing and Visualization**

The default plot shows a slice plot of the magnetic potential with 5 slices perpendicular to the \( x \) axis. A more interesting plot can easily be obtained.

1. Select **Plot Parameters** from the **Postprocessing** menu to open the **Plot Parameters** dialog box and click the **Slice** tab.
2 From the **Predefined quantities** list, select **Magnetic flux density, norm**.

3 Set the numbers of x-levels and y-levels to 0.

4 For z, select **Vector with coordinates** and set the value to -10. Click **OK** to close the dialog and make the plot.

**Tangential Magnetic Field in the Hull**

The magnetic field in is available as predefined postprocessing variables available everywhere. To display variables only on some boundaries, use the **Suppress>Boundaries** option from the **Options** menu.

1 Select **Options>Suppress>Suppress Boundaries**.

2 Select Boundaries 1–5 and 27.

3 Click **OK** to suppress (hide) these boundaries.

The magnetic field in the hull can now be displayed using the available postprocessing functionality in COMSOL Multiphysics.

1 Select **Plot Parameters** from the **Postprocessing** menu to open the **Plot Parameters** dialog box.

2 On the **General** page, select the **Slice, Boundary, Arrow, and Isosurface** check boxes in the **Plot type** area.

3 On the **Isosurface** page, make sure that the quantity plotted is **Magnetic potential** and that the number of levels is 5. On the **Color Data** page, type `if(x<0,NaN,1)*Vm` in the **Expression** edit field. This expression ensures that only half of each isosurface is visible, namely the half for which \( x > 0 \), allowing you to see inside the closed equipotential surfaces.

4 On the **Slice** page, keep the previous settings.

5 Go to the **Boundary** page. To offset the arrows, use a gray uniform color canvas on the surface of the submarine. To achieve this, click the **Uniform color** button in the **Boundary color** area, then click the **Color** button and select a light gray color. Finally, click **OK**.

6 On the **Arrow** page, select **Boundaries** from the **Plot arrows on list**. On the **Boundary Data** page, select **Tangential magnetic field** from the **Predefined quantities** list.

7 In the **Arrow parameters** area, click the **Color** button. In the **Arrow Color** dialog box, select black, then click **OK**.
Click **OK** to generate the plot.
3D Quadrupole Lens

Introduction

This is a full 3D version of the Quadrupole Lens model in the COMSOL Multiphysics Model Library. For a general overview of the setup and the physics, see “Quadrupole Lens” on page 85 in the COMSOL Multiphysics Model Library. The 3D model version additionally takes fringing fields into account, and the calculation of the forces on the ions uses all components of their velocities.

Model Definition

The geometry of the quadrupole lens is the same as outlined in the documentation to the 2D model: three quadrupoles in a row, followed by 1 m of empty space, where the ions are left to drift. The AC/DC Module features an application mode for magnetostatics without currents. This reduces the memory usage considerably compared to the formulation including currents.

Domain Equations

The magnetic field is described using the Magnetostatics equation, solving for the magnetic scalar potential $V_m$ (Wb/m):

$$-\nabla \cdot (\mu_0 \nabla V_m - \mu_0 \mathbf{M}) = 0$$

where $\mu_0 = 4\pi \times 10^{-7}$ H/m denotes the permeability of vacuum and $\mathbf{M}$ is the magnetization (A/m). In the iron subdomain

$$-\nabla \cdot (\mu_0 \mu_r \nabla V_m) = 0$$

where $\mu_r = 4000$ is the relative permeability. The magnetic scalar potential is everywhere defined so that $\mathbf{H} = -\nabla V_m$.

Boundary Conditions

The magnetic insulation boundary condition, reading $\mathbf{n} \cdot \mathbf{B} = 0$, is used all around the iron cylinder, and at the lateral surfaces of the air domain that encloses the drift length. At the base surface of the same air domain, the magnetic potential is zero.
Results

The magnetic field density and arrows showing its direction are depicted in the figure below.

![Figure 5-8: Slice plot and arrows of the magnetic field density in the quadrupole lens.](image)

Each ion passing through the assembly experiences Maxwell forces equal to $F = q \mathbf{v} \times \mathbf{B}$, where $\mathbf{v}$ (m/s) is the velocity of the ion. To find the transverse position as
a function of time, solve Newton’s second law for each ion: $q \mathbf{v} \times \mathbf{B} = m \mathbf{a}$. Figure 5-9 shows the traces of the ions as they fly through the quadrupole lens.

\[ \text{Figure 5-9: Particle tracing plot of the ions. The line colors show the local force acting on each ion. The force grows larger (red) far away from the center of the beam line and smaller (blue) where two oppositely polarized quadrupoles join.} \]

**Model Library path:** ACDC_Module/General_Industrial_Applications/quadrupole_3d

**Modeling Using the Graphical User Interface**

**MODEL NAVIGATOR**

1. In the Model Navigator, select 3D in the Space dimension list.
2. Select **AC/DC Module>Statics, Magnetic>Magnetostatics, No Currents** from the list of application modes.
3. Click **OK** to close the dialog box.
CHAPTER 5: GENERAL INDUSTRIAL APPLICATION MODELS

OPTIONS AND SETTINGS

1. In the Constants dialog box, enter the following constant names, expressions, and (optionally) descriptions; when done, click **OK** to close the dialog box.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>M</td>
<td>11</td>
<td>Ion mass number</td>
</tr>
<tr>
<td>Z</td>
<td>5</td>
<td>Ion charge number</td>
</tr>
<tr>
<td>vz</td>
<td>0.01*3e8[m/s]</td>
<td>Ion velocity</td>
</tr>
<tr>
<td>mp</td>
<td>1.672e-27[kg]</td>
<td>Proton mass</td>
</tr>
<tr>
<td>Ze</td>
<td>1.602e-19[C]</td>
<td>Proton charge</td>
</tr>
<tr>
<td>m</td>
<td>M*mp</td>
<td>Ion mass</td>
</tr>
<tr>
<td>q</td>
<td>Z*Ze</td>
<td>Ion charge</td>
</tr>
<tr>
<td>MQ</td>
<td>5.8e3[A/m]</td>
<td>Quadrupole magnetization</td>
</tr>
</tbody>
</table>

GEOMETRY MODELING

1. Choose **Draw>Work-Plane Settings**. Click **OK** to get the default xy-plane.

2. Choose **Draw>Specify Objects>Rectangle**. Specify the following properties; when done, click **OK**.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>0.177</td>
</tr>
<tr>
<td>Height</td>
<td>0.07</td>
</tr>
<tr>
<td>Position: Base</td>
<td>Corner</td>
</tr>
<tr>
<td>Position: x</td>
<td>0</td>
</tr>
<tr>
<td>Position: y</td>
<td>-0.035</td>
</tr>
</tbody>
</table>

3. Choose **Draw>Modify>Rotate**. Rotate the rectangle by 45° around the origin. When done, click **OK**.

4. Choose **Draw>Specify Objects>Circle**. Specify the following properties, then click **OK**.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Radius</td>
<td>0.2</td>
</tr>
<tr>
<td>Position: Base</td>
<td>Center</td>
</tr>
<tr>
<td>Position: x</td>
<td>0.2</td>
</tr>
<tr>
<td>Position: y</td>
<td>0.2</td>
</tr>
</tbody>
</table>

5. Press Ctrl+A to select both objects. Click the **Intersection** button on the Draw toolbar.
6 Press Ctrl+C to make a copy of the composed object (CO1), then press Ctrl+V to paste it at the same location, that is with zero displacements.

7 Rotate the copied object (CO2) by 90° around the origin.

8 Paste two more copies of CO1 at the same location, and rotate them by 180° and 270°, respectively.

9 Create a circle centered at the origin with a radius of 0.2 m.

10 Create another circle centered at the origin, with a radius of 0.12 m.

11 Click the Create Composite Object button. Create an object using the formula \( C1+C2-(CO1+CO2+CO3+CO4) \). Click OK.

12 Once more, draw a circle centered at the origin with a radius of 0.2 m.

The geometry should now look like that in the figure below.

![Figure 5-10: Work-plane view of the geometry.](image)

13 Select all objects, then choose Draw>Extrude. Click OK to extrude the geometry to a height of 1 m.

14 In the 3D view, copy the object you just extruded, and paste it to the same location.

You find the copy and paste commands in the Edit menu.
Choose Draw>Modify>Scale. Scale the pasted object by a factor of 2 in the $z$ direction. When done, click OK.

Choose Draw>Modify>Move. Move the scaled object 1 m in the $z$ direction. When done, click OK.

Paste another copy of the first object into the geometry, but now with a displacement of 3 m in the $z$ direction.

Choose Draw>Cylinder. Create a cylinder with the following specifications; when done, click OK.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Radius</td>
<td>0.2</td>
</tr>
<tr>
<td>Height</td>
<td>1</td>
</tr>
<tr>
<td>Axis base point $z$</td>
<td>4</td>
</tr>
</tbody>
</table>

PHYSICS SETTINGS

Subdomain Settings

1 In the Subdomain Settings dialog box, select Subdomains 1–3 and load Iron from the list of materials.

2 Leave the default settings in Subdomains 4 and 11–13.

3 In all the other subdomains, set the constitutive relation to $\mathbf{B} = \mu_0 \mathbf{H} + \mu_0 \mathbf{M}$ and set the magnetization according to the table below.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAINS, 5, 7, 18</th>
<th>SUBDOMAINS 8, 10, 15</th>
<th>SUBDOMAINS 9, 14, 16</th>
<th>SUBDOMAINS 6, 17, 19</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\mathbf{M}$ (x component)</td>
<td>$MQ/\sqrt{2}$</td>
<td>-$MQ/\sqrt{2}$</td>
<td>$MQ/\sqrt{2}$</td>
<td>-$MQ/\sqrt{2}$</td>
</tr>
<tr>
<td>$\mathbf{M}$ (y component)</td>
<td>$MQ/\sqrt{2}$</td>
<td>$MQ/\sqrt{2}$</td>
<td>-$MQ/\sqrt{2}$</td>
<td>-$MQ/\sqrt{2}$</td>
</tr>
</tbody>
</table>

Boundary Conditions

1 In the Boundary Settings dialog box, set the boundary conditions according to the table below. The easiest way to do this is to first select all the exterior boundaries, by selecting the Select by group check box and select one of them. Apply magnetic insulation to all the boundaries, and change the condition on Boundary 13 back to zero potential.

<table>
<thead>
<tr>
<th>SETTING</th>
<th>BOUNDARY 13</th>
<th>ALL OTHERS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Zero potential</td>
<td>Magnetic insulation</td>
</tr>
</tbody>
</table>
**Mesh Generation**

1. In the Free Mesh Parameters dialog box, select Finer among the Predefined mesh sizes.
2. On the Subdomain tab, select Subdomains 4 and 11–13, and enter 0.03 for the Maximum element size.
3. On the Advanced page, set the z-direction scale factor to 0.2.
4. Click the Remesh button. When the mesher has finished, click OK.

**Computing the Solution**

Click the Solve button on the Main toolbar.

**Postprocessing and Visualization**

The default plot shows the magnetic potential. Follow the instructions to get an overview of the magnetic field.

1. In the Plot Parameters dialog box, go to the Slice page and select Magnetic field, norm from the Predefined quantities list. Set the Number of levels to (1, 1, 0).
2. On the Arrow page, select the Arrow plot check box. Set the Number of points to (2, 2, 20) and the Scale factor to 0.2.
3. Click Apply to see the magnetic field.

To see how the ions travel through the system of quadrupoles, do the following:

1. On the General page, clear the Slice and Arrow check boxes, and select the Particle tracing check box.
2. On the Particle tracing page, select Electromagnetic force from the Predefined forces list. In the Mass edit field, type $m$.
3. On the Start Points page, type $0.03*\cos(\text{linspace}(0,2*\pi,41))$ in the x edit field and $0.03*\sin(\text{linspace}(0,2*\pi,41))$ in the y edit field.
4. On the Initial Values page, type $v_z$ in the rightmost Initial velocity edit field to set the initial $z$-velocity.
5. On the Line Color page, click the Use expression option button.
6. Click the Color Expression button to open the Pathline Color Expression dialog box. In the Expression edit field, type $q*v_z*\text{normB_emnc}$ (this is an approximate value of the local force acting on each ion). Click OK.
7. Click the Advanced button and set the Relative tolerance to $1e^{-6}$.
8. Click OK to close the Plot Parameters dialog box and generate the particle tracing plot.
Superconducting Wire

Current can flow in a superconducting wire with practically zero resistance, although factors including temperature, current density, and magnetic field can limit this phenomenon. This model solves a time-dependent problem of a current building up in a superconducting wire close to the critical current density. This model is based on a suggestion by Dr. Roberto Brambilla, CESI - Superconductivity Dept., Milano, Italy.

Introduction

The Dutch physicist Heike Kamerlingh Onnes discovered superconductivity in 1911. He cooled mercury to the temperature of liquid helium (4 K) and observed that its resistivity suddenly disappeared. Research in superconductivity reached a peak during the 1980s in terms of activity and discoveries, especially when scientists uncovered the superconductivity of ceramics. In particular, it was during this decade that researchers discovered YBCO—a ceramic superconductor composed of yttrium, barium, copper, and oxygen with a critical temperature above the temperature of liquid nitrogen. However, researchers have not yet created a room-temperature superconductor, so much work remains for the broad commercialization of this area.

This model illustrates how current builds up in a cross section of a superconducting wire; it also shows where critical currents produce a swelling in the non-superconducting region.

Model Definition

The dependence of resistivity on the amount of current makes it difficult to solve the problem using the standard application modes in the AC/DC Module. The reason is this: A circular dependency arises because the current-density calculation contains the resistivity, leading to a resistivity that is dependent on itself.

An alternate approach uses the magnetic field as the dependent variable, and you can then calculate the current as

$$\mathbf{J} = \nabla \times \mathbf{H}.$$  

The electric field is a function of the current, and Faraday’s law determines the complete system as in
where \( \mathbf{E}(\mathbf{J}) \) is the current-dependent electric field. The model calculates this field with the empirical formula

\[
\mathbf{E}(\mathbf{J}) = \begin{cases} 
0 & |\mathbf{J}| < J_C \\
E_0 \left( \frac{|\mathbf{J}| - J_C}{J_C} \right)^\alpha \frac{\mathbf{J}}{|\mathbf{J}|} & |\mathbf{J}| \geq J_C 
\end{cases}
\]

where \( E_0 \) and \( \alpha \) are constants determining the nonlinear behavior of the transition to zero resistivity, and \( J_C \) is the critical current density, which decreases as temperature increases.

For the superconductor YBCO, this model uses the following parameter values (Ref. 1):

<table>
<thead>
<tr>
<th>PARAMETER</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>( E_0 )</td>
<td>0.0836168 V/m</td>
</tr>
<tr>
<td>( \alpha )</td>
<td>1.449621256</td>
</tr>
<tr>
<td>( J_C )</td>
<td>17 MA</td>
</tr>
<tr>
<td>( T_C )</td>
<td>92 K</td>
</tr>
</tbody>
</table>

Systems with two curl operators are best dealt with using vector elements (edge elements). This is the default element for the application modes in the AC/DC Module that solve similar equations. This particular formulation for the superconducting system is not available in the AC/DC Module, so you must define it using the PDE, General Form application mode. In addition, the model uses higher-order vector elements, called curl elements in COMSOL Multiphysics. The resulting system becomes

\[
D \frac{d\mathbf{H}}{dt} + \nabla \cdot \Gamma = \mathbf{F} = \begin{bmatrix} \mu_0 & 0 \\ 0 & \mu_0 \end{bmatrix} \begin{bmatrix} \frac{dH_z}{dt} \\ \frac{dH_x}{dt} \end{bmatrix} + \nabla \cdot \begin{bmatrix} 0 & E_z(J_z) \\ -E_z(J_z) & 0 \end{bmatrix} = \begin{bmatrix} 0 \\ 0 \end{bmatrix}.
\]

For symmetry reasons, the current density has only a \( z \)-component.

The model controls current through the wire with its outer boundary condition. Because Ampere’s law must hold around the wire, a line integral around it must add
up to the current through the wire. Cylindrical symmetry results in a known magnetic field at the outer boundary

\[
\oint H \cdot dl = 2\pi r H_\phi = I_{\text{wire}} \Rightarrow H_\phi = \frac{I_{\text{wire}}}{2\pi r}.
\]

For vector elements, the Dirichlet boundary conditions add a constraint on the tangential component of the vector field. If the field components are called \( H_x \) and \( H_y \), the tangential counterparts are \( tH_x \) and \( tH_y \).

\section*{Results and Discussion}

The model applies a simple transient exponential function as the current through the wire, reaching a final value of 1 MA. This extremely large current is necessary if the superconducting wire is to reach its critical current density. Figure 5-11 plots the current density at two times after the current starts.

\begin{figure}[h]
\centering
\includegraphics[width=\textwidth]{figure511}
\caption{The current density at \( t = 0.02, 0.05, \text{ and } 0.1 \). The swelling of the ring comes from the transition out of the superconducting state at current densities exceeding \( J_C \).}
\end{figure}
Reference


Model Library path: ACDC_Module/General_Industrial_Applications/superconducting_wire

Modeling Using the Graphical User Interface

MODEL NAVIGATOR

1. In the Model Navigator, select 2D from the Space dimension list.

2. Select the COMSOL Multiphysics>PDE Modes>PDE, General Form>Time-dependent analysis application mode.

3. In the Dependent variables edit field, type $H_x$ $H_y$. Click OK.

OPTIONS AND SETTINGS

Because the PDE modes do not support units, disable COMSOL Multiphysics’ unit handling:

1. From the Physics menu, choose Model Settings.

2. From the Base unit system list, select None, then click OK.

Next, proceed with defining the model.

1. From the Options menu, choose Constants.

2. In the Constants dialog box, define the following constants with names, expressions, and descriptions (optional):

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>mu0</td>
<td>4<em>pi</em>1e-7</td>
<td>Permeability of vacuum (H/m)</td>
</tr>
<tr>
<td>alpha</td>
<td>1.449621256</td>
<td>Parameter for resistivity model</td>
</tr>
<tr>
<td>Jc</td>
<td>1.7e7</td>
<td>Critical current density (A/m^2)</td>
</tr>
<tr>
<td>I0</td>
<td>1e6</td>
<td>Applied current (A)</td>
</tr>
<tr>
<td>rho_air</td>
<td>1e6</td>
<td>Resistivity of air (ohm*m)</td>
</tr>
<tr>
<td>tau</td>
<td>0.02</td>
<td>Time constant for applied current (s)</td>
</tr>
</tbody>
</table>
GEOMETRY MODELING
You can access all the dialog boxes for specifying primitive objects from the Draw menu under Specify Objects. The first column in the table below contains the labels of the geometric objects. These are automatically generated by COMSOL Multiphysics, and you do not have to enter them. Just check that you get the correct label for the objects that you create.

1. Draw two circles with properties according to the table below.

<table>
<thead>
<tr>
<th>LABEL</th>
<th>RADIUS</th>
<th>BASE</th>
<th>BASE, X</th>
<th>BASE, Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>C1</td>
<td>0.1</td>
<td>Center</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>C2</td>
<td>1</td>
<td>Center</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

2. Click the Zoom Extents button on the Main toolbar.

PHYSICS SETTINGS
1. From the Options menu, choose Expressions>Scalar Expressions.
2. In the Scalar Expressions dialog box, define the following variables with names, expressions, and (optionally) descriptions:

<table>
<thead>
<tr>
<th>NAME</th>
<th>VALUE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jz_sc</td>
<td>HyxHxy</td>
<td>Current density (A/m^2)</td>
</tr>
<tr>
<td>normH_sc</td>
<td>sqrt(Hx^2+Hy^2)</td>
<td>Norm of the H-field (H/m)</td>
</tr>
<tr>
<td>I1</td>
<td>I0*(1-exp(-t/tau))</td>
<td>Applied current (A)</td>
</tr>
<tr>
<td>Q_sc</td>
<td>Ez_sc*Jz_sc</td>
<td>Generated heat in superconductor (W/m^3)</td>
</tr>
</tbody>
</table>

The expression \( HyxHxy \) is a predefined short form for \( Hyx - Hxy \), the \( z \)-component of the curl of the \( \mathbf{H} \) field:

\[
\frac{\partial H_y}{\partial x} - \frac{\partial H_x}{\partial y}
\]
3 Click OK.

4 From the Options menu, choose Expressions>Boundary Expressions.

5 In the Boundary Expressions dialog box, define the following variable:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION ON BOUNDARIES 1, 2, 5, 8</th>
<th>ALL OTHERS</th>
</tr>
</thead>
<tbody>
<tr>
<td>H0phi</td>
<td>( \frac{I_1}{2\pi^1 \sqrt{x^2+y^2}} )</td>
<td></td>
</tr>
</tbody>
</table>

6 Click OK.

7 From the Options menu, choose Expressions>Subdomain Expressions.

8 In the Subdomain Expressions dialog box, define the following variable:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION IN SUBDOMAIN 1</th>
<th>EXPRESSION IN SUBDOMAIN 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ez_sc</td>
<td>( \rho_{air}J_z_{sc} )</td>
<td>( E_0((J_z_{sc}-J_c)\frac{\text{flc2hs}(J_z_{sc}-J_c-dJ,dJ)}{J_c})^{\alpha} )</td>
</tr>
</tbody>
</table>

Boundary Conditions

1 From the Physics menu, open the Boundary Settings dialog box.

2 Enter boundary conditions according to the following table:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 2, 8</th>
<th>BOUNDARIES 1, 5</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Dirichlet</td>
<td>Dirichlet</td>
</tr>
<tr>
<td>( R_1 )</td>
<td>( H_0\phi t_1 x + t_2 x )</td>
<td>( H_0\phi t_1 x - t_2 x )</td>
</tr>
<tr>
<td>( R_2 )</td>
<td>( H_0\phi t_1 y + t_2 y )</td>
<td>( H_0\phi t_1 y - t_2 y )</td>
</tr>
</tbody>
</table>

3 Click OK.

Subdomain Settings

1 From the Physics menu, open the Subdomain Settings dialog box.

2 Specify subdomain settings according to the following table:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAINS 1, 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \Gamma_{11} )</td>
<td>0</td>
</tr>
<tr>
<td>( \Gamma_{12} )</td>
<td>Ez_sc</td>
</tr>
<tr>
<td>( \Gamma_{21} )</td>
<td>-Ez_sc</td>
</tr>
<tr>
<td>( \Gamma_{22} )</td>
<td>0</td>
</tr>
<tr>
<td>( F_1 )</td>
<td>0</td>
</tr>
<tr>
<td>( F_2 )</td>
<td>0</td>
</tr>
<tr>
<td>( D_{a,11} )</td>
<td>( \mu_0 )</td>
</tr>
</tbody>
</table>
3 Click the Element tab.

4 Make sure that both subdomains are selected, then type `shcurl(2, {'Hx', 'Hy'})` in the shape edit field to use second-order vector elements when solving the model.

5 Click OK.

**Mesh Generation**

1 From the Mesh menu, choose Free Mesh Parameters.

2 From the Predefined mesh sizes list, select Coarse.

3 Click the Subdomain tab. Select Subdomain 2, then type `2e-2` in the Maximum element size edit field.

4 Click the Remesh button, then click OK.

**Computing the Solution**

1 From the Solve menu, choose Solver Parameters.

2 In the Times edit field, type `linspace(0, 0.1, 21)`.

3 On the Time Stepping page, clear both Auto check boxes in the Time step tuning area. Set the Initial time step to `1e-9` and the Maximum time step to `1e-3`.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAINS 1, 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>$D_{a,12}$</td>
<td>0</td>
</tr>
<tr>
<td>$D_{a,21}$</td>
<td>0</td>
</tr>
<tr>
<td>$D_{a,22}$</td>
<td>$\mu_0$</td>
</tr>
</tbody>
</table>

The shape function entry turns red when you enter a shape function using the syntax with curly braces, but you can disregard this indication.
POSTPROCESSING AND VISUALIZATION

1. From the Postprocessing menu, select Plot Parameters.
2. On the General page, make sure that the Surface and Geometry edges check boxes are selected in the Plot type area.
3. On the Surface page, verify that Hx is in the Expression edit field.
4. Click OK.

You should now see the following plot in the drawing area on your screen.

5. From the Postprocessing menu, select Domain Plot Parameters.
6. On the General page, select the solutions at times 0.02, 0.05, and 0.1.
7. Click the Surface tab. From the Subdomain selection list, select Subdomain 2. In the Expression edit field, type Jz_sc.
8. Click OK.

You should now see the plot shown in Figure 5-11 on page 292.
RF-Heated Hot Wall Furnace for Semiconductor Processing

Introduction

Furnace reactors are used in semiconductor fabrication to grow layers of semiconductor materials on wafers. An important aspect is to grow the layers with a crystal structure that matches that of the wafer substrate. This is called epitaxial growth and is a key technology for the fabrication of electronic devices. For silicon carbide (a wide-bandgap semiconductor), epitaxial growth is one of the great challenges towards manufacturing reliable devices.

The layer growth takes place with the wafers sitting in graphite susceptors (wafer holders) at very high temperatures in the range of 2000 °C. The susceptors are heated with radio-frequency (RF) coils at power levels in the 10 kW range. The design of the reactor chamber is crucial for maintaining a uniform temperature, efficient heating, and control of high-temperature regions. It is especially important that the quartz tube surrounding the susceptor remains at moderate temperatures.

This COMSOL Multiphysics model examines a simple furnace design that heats a graphite susceptor using an 8-kW RF signal at 20 kHz. It determines the temperature distribution over the wafer along with the temperature on the outer quartz tube. At these high temperatures the heat flux is dominated by radiation. The model requires the AC/DC Module and the Heat Transfer Module.

Model Definition

Figure 5-12 shows the furnace geometry. The quartz tube is surrounded by six coils that carry the RF power. The alternating field induces currents in the conductive center of the graphite susceptor, and these currents heat that wafer holder. The wafer is placed at the bottom of a chamber located inside the susceptor, where almost the entire bottom is made of silicon carbide to avoid contamination. The outer part of the susceptor is made of graphite foam, which serves as thermal insulation.
Figure 5-12: The furnace geometry cut in half. Note that you need model only one quarter of the full geometry due to symmetry.
Thanks to symmetry, you can divide the furnace in half twice, and thus need include only a quarter of its geometry in the simulation.

The coils are made of copper, and at the frequency of interest the skin depth is in the order of 0.5 mm, so it is possible to model the current as a surface current. In fact, because the center core of the coils does not conduct current, they are constructed as tubes. These surface currents make it possible to use one of the AC/DC Module’s induction-current application modes, which solves only for the $A$ field. The total current used in this case is 21.5 kA, which corresponds roughly to 8 kW of heating power.

This example solves for the temperature only in the susceptor and the quartz tube. It models heat flux between the susceptor and the tube with surface-to-surface radiation. The only part where heating occurs is in the inner part of the susceptor, which is made of pure graphite. The graphite foam outside has a lower thermal conductivity and zero electric conductivity. The bottom surface of the hole in the susceptor is modeled as a highly conductive layer because it is made of silicon carbide, which has a very high thermal conductivity. The layer’s thickness is 1 mm, which also includes the wafer thickness.
The following table summarizes all the material properties used in this simulation:

<table>
<thead>
<tr>
<th>PARAMETER</th>
<th>COPPER</th>
<th>GRAPHITE</th>
<th>GRAPHITE FELT</th>
<th>QUARTZ</th>
<th>SILICON CARBIDE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Heat capacity</td>
<td>584</td>
<td>710</td>
<td>200</td>
<td>820</td>
<td>1200</td>
</tr>
<tr>
<td>Density</td>
<td>8700</td>
<td>1950</td>
<td>120</td>
<td>2600</td>
<td>3200</td>
</tr>
<tr>
<td>Thermal conductivity</td>
<td>400</td>
<td>150·(300[K]/T)</td>
<td>0.3</td>
<td>3</td>
<td>450·(300[K]/T)^0.75</td>
</tr>
<tr>
<td>Electric conductivity</td>
<td>5.998·10^7</td>
<td>10^3</td>
<td>100</td>
<td>10^{-12}</td>
<td>10^3</td>
</tr>
<tr>
<td>Permittivity</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>4.2</td>
<td>10</td>
</tr>
<tr>
<td>Emissivity</td>
<td>0.5</td>
<td>1</td>
<td>1</td>
<td>0.7</td>
<td>0.5</td>
</tr>
</tbody>
</table>

The temperature dependence of the thermal conductivity is necessary due to the high temperature range in the susceptor.

In this model you neglect the temperature dependence of the electric conductivity. This enables COMSOL Multiphysics to solve the application modes sequentially, which saves memory. The problem can be solved fully coupled with a temperature dependent conductivity on high-performance computers. By using the Induction Heating predefined multiphysics coupling, it is easy to take the electro-thermal interaction into account.

Results and Discussions

The temperature difference over the wafer should be as small as possible; a large difference can cause nonuniform thicknesses and properties in the grown layer. The
heating cycle is also interesting to view, and Figure 5-14 compares the temperature at the center of the wafer to that at the edge during 1 hour of heating at 8 kW.

![Figure 5-14: The temperature at two locations on the wafer during a heating cycle of one hour.](image)

The graphite felt around the susceptor acts as a high-temperature thermal insulator for the system. This makes the furnace more efficient in terms of power usage, and it also keeps high temperatures away from the quartz tube. The temperature distribution in Figure 5-15 shows how hot the quartz tube gets and how well the graphite felt insulates the susceptor. The maximum temperature of the quartz tube is approximately 900 K, and that tube should be water or air cooled to further reduce its temperature; this model takes only radiation to the ambient into account. To get a more complete plot, you can use extrusion coupling variables to copy the solution to the other symmetry half in this model.
Figure 5-15: Temperature distribution for the important parts of the furnace after 1 hour of heating. The coils are plotted only to show their location; there is no temperature information on their surfaces.

The temperature distribution across the wafer can often be seen in variations of the layer properties, so it is crucial that the temperature be uniform across the surface. The surface plot in Figure 5-16 shows the temperature over one half of the silicon-carbide
wafer. The 80 °C difference is rather large. Gas flow is another important source of nonuniformities, but this simulation does not consider it.

![Temperature distribution across the surface of the wafer.](image)

**Figure 5-16: Temperature distribution across the surface of the wafer.**

**Model Library path:** ACDC_Module/General_Industrial_Applications/hot_wall_furnace

**Note:** This model requires both the AC/DC Module and the Heat Transfer Module.

**Modeling Using the Graphical User Interface**

**Model Navigator**
1. In the Model Navigator, select 3D in the Space dimension list.
3 Select Vector, Lagrange - Linear from the Element list.

4 Click OK to close the Model Navigator dialog box.

OPTIONS AND SETTINGS
1 From the Options menu, choose Constants.
2 In the Constants dialog box, define the following constant with name and expression. The description field is optional.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>I_coil</td>
<td>2150[A]</td>
<td>Coil current</td>
</tr>
</tbody>
</table>

3 Click OK.

4 From the Options menu, choose Expressions>Scalar Expressions.
5 In the Scalar Expressions dialog box, define the following expressions:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Js_coil</td>
<td>I_coil/C_coil</td>
<td>Surface current on coil</td>
</tr>
<tr>
<td>Pav_coil</td>
<td>4<em>2.5</em>0.5<em>real(I_coil</em>conj(V_coil))</td>
<td>Heating power in coils</td>
</tr>
</tbody>
</table>

Because of the use of integration coupling variables (C_coil and V_coil), COMSOL Multiphysics cannot determine the unit for other variables that directly or indirectly depend on these integration coupling variables. This causes the warnings for inconsistent units here and in the specification of the surface current density. You can disregard these warnings.

6 Click OK.

GEOMETRY MODELING
The geometry modeling of this model is rather extensive, so it is possible to import the furnace geometry from a binary file. Select the section that you prefer.

Importing the Geometry from a Binary File
1 From the File menu, select Import>CAD Data From File.
2 In the Import CAD Data From File dialog box, make sure that either COMSOL Multiphysics file or All 3D CAD files is selected in the Files of type list.
3 From the COMSOL Multiphysics installation directory, go to the model library path given on page 304. Select the hot_wall_furnace.mphbin file, and click Import.
4 Skip the section “Creating the Geometry from Scratch” and continue at “Physics Settings” on page 308.

Creating the Geometry from Scratch

1 From the Draw menu, choose Work-Plane Settings, and click the y-z option button.

2 Click OK.

3 Create three rectangles with the specifications in the table below. You create them easiest from the dialog box that you open by choosing

   Draw>Specify Objects>Rectangle.

<table>
<thead>
<tr>
<th>NAME</th>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>X</th>
<th>Y</th>
<th>BASE</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>0.075</td>
<td>0.02</td>
<td>0</td>
<td>-0.01</td>
<td>Corner</td>
</tr>
<tr>
<td>R2</td>
<td>0.1</td>
<td>0.05</td>
<td>0</td>
<td>-0.025</td>
<td>Corner</td>
</tr>
<tr>
<td>R3</td>
<td>0.15</td>
<td>0.1</td>
<td>0</td>
<td>-0.05</td>
<td>Corner</td>
</tr>
<tr>
<td>R4</td>
<td>0.1</td>
<td>0.05</td>
<td>0</td>
<td>-0.025</td>
<td>Corner</td>
</tr>
</tbody>
</table>

4 Click the Zoom Extents button on the Main toolbar.

5 From the Draw menu, choose Fillet/Chamfer.

6 In the Fillet/Chamfer dialog box, expand rectangle R1, and select its vertex numbers 2 and 3. Enter 5e-3 in the Radius edit field.

7 Click Apply. The former rectangle R1 is now labeled CO1.

8 Then expand rectangle R3, select its Vertices 2 and 3, and enter 0.02 in the Radius edit field.

9 Click OK. The former rectangle R3 is now labeled CO2.

10 Select the objects labeled R2 and CO1, and click the Difference button on the Draw toolbar.

11 Select the objects labeled R4 and CO2, and click the Difference button again.

12 From the Draw menu, choose Extrude.

13 In the Extrude dialog box, select the objects CO1 and CO3, and enter 0.15 in the Distance edit field.

14 Click OK. The program switches to the 3D view, where the extruded objects represents the susceptor and its thermal insulation.

15 From the Draw menu, choose Work-Plane Settings again, and click the z-x option button to use a different work plane.

16 Click OK.
17 Press Ctrl+A to select all objects in the work plane, and then press the Delete key to clear the work plane.

18 Create three rectangles with the specifications according to the table below.

<table>
<thead>
<tr>
<th>NAME</th>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>X</th>
<th>Y</th>
<th>BASE</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>0.18</td>
<td>0.01</td>
<td>0</td>
<td>0.25</td>
<td>Corner</td>
</tr>
<tr>
<td>R2</td>
<td>0.01</td>
<td>0.25</td>
<td>0.17</td>
<td>0</td>
<td>Corner</td>
</tr>
<tr>
<td>R3</td>
<td>0.45</td>
<td>0.5</td>
<td>0</td>
<td>0</td>
<td>Corner</td>
</tr>
</tbody>
</table>

19 Select both rectangles and click the Union toolbar button.

20 Click the Delete Interior Boundaries toolbar button to remove unnecessary boundaries.

21 Use the menu option Draw>Specify Objects>Circle to create three circles with the specifications according to the table below.

<table>
<thead>
<tr>
<th>NAME</th>
<th>RADIUS</th>
<th>X</th>
<th>Y</th>
<th>BASE</th>
</tr>
</thead>
<tbody>
<tr>
<td>C1</td>
<td>0.015</td>
<td>0.21</td>
<td>0</td>
<td>Center</td>
</tr>
<tr>
<td>C2</td>
<td>0.015</td>
<td>0.21</td>
<td>5e-2</td>
<td>Center</td>
</tr>
<tr>
<td>C3</td>
<td>0.015</td>
<td>0.21</td>
<td>1e-1</td>
<td>Center</td>
</tr>
</tbody>
</table>

22 Create a line going from the coordinate (0.195, 0) to the coordinate (0.225,0).

23 Select the line B1 and the circle C1 and click the Coerce to Solid toolbar button.

24 Click the Split Object toolbar button and select the side of the circle labeled CO4.

25 Press the Delete key to delete this side.

26 From the Draw menu, choose Revolve.

27 Select the objects CO2, CO3, C2, C3, R3. Enter -180 in the $\alpha_2$ edit field.

28 Click OK. You are in the 3D view again, and now you have created the quartz tube and the coils. One of the coils was split in half due to the use of symmetry in this model. Define one last work plane to draw the items inside the susceptor.

29 From the Draw menu, choose Work-Plane Settings again, and click the x-y option button.

30 Click OK.

31 Press Ctrl+A to select all objects in the work plane, and then press the Delete key to clear the work plane.

32 Create a circles with radius 0.05 centered at the origin.

33 Create a line going from the coordinate (0, 0) to the coordinate (0.05,0).
Select the circle and the line, click the Coerce to Solid toolbar button, and then click the Split Object toolbar button.

Select and delete the lower part of the circle labeled CO2.

Create a rectangle with width 0.15, height 0.055, and the corner coordinate in the origin.

Choose Embed from the Draw menu, select all objects (CO2 and R1), and click OK.

The simulation domain is now finished. However, to improve the plot view, some parts of the furnace can be mirrored to the other side of the $x = 0$ symmetry plane. The mirrored part is only used for postprocessing and does not influence the simulation.

Select all objects except the largest cylinder. The selected objects should have the labels EXT1, EXT2, REV1, REV2, REV3, REV4, EMB1, and EMB2.

Click the Mirror toolbar button.

In the Mirror dialog box, set the Normal vector edit fields to (1,0,0), and click OK.

Click the Zoom Extents button on the Main toolbar and the Headlight button on the Camera button. With the proper objects selected the geometry should look like that in Figure 5-12 on page 299.

PHYSICS SETTINGS

Variables

1. From the Physics menu, choose Scalar Variables.

2. Enter $20e3$ in the nu_emqa edit field, then click OK.

3. From the Options menu, choose Integration Coupling Variables>Edge Variables.

4. In the Edge Integration Variables dialog box, enter the following variables with names and expressions at the specified edges. The Global destination check box should be selected for all variables.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EDGES</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>C_coil</td>
<td>221, 222, 230, 232</td>
<td>1</td>
<td>Gives the circumference of one coil</td>
</tr>
<tr>
<td>V_coil</td>
<td>217</td>
<td>$\text{Ex}<em>{\text{emqa}}t1x+\text{Ey}</em>{\text{emqa}}t1y+\text{Ez}_{\text{emqa}}t1z$</td>
<td>Induced voltage along one coil</td>
</tr>
<tr>
<td></td>
<td>220</td>
<td>$-(\text{Ex}<em>{\text{emqa}}t1x+\text{Ey}</em>{\text{emqa}}t1y+\text{Ez}_{\text{emqa}}t1z)$</td>
<td>Induced voltage along one coil</td>
</tr>
</tbody>
</table>

5. From the Options menu, choose Extrusion Coupling Variables>Subdomain Variables.
6 In the Subdomain Extrusion Variables dialog box, select Subdomains 9, 11, and 12, and enter T_map in the Name column.

7 Click the General Transformation option button. Leave the transformation expressions at their defaults.

8 Enter the T in the Expression column in the same row as the T_map variable.

9 Click the Destination tab. Make sure that the Geometry list has Geom1 chosen, then choose Subdomain in the Level list.

10 Select Subdomains 1–3. Select the Use the selected subdomains as destination check box.

11 Enter -x in the x edit field for the Destination transform.

12 Click OK. The temperature in Subdomains 9, 11, and 12 are now mirrored into Subdomains 1–3. The mirrored version of the temperature is available there as the variable T_map.

13 From the Options menu, choose Expressions>Boundary Expressions.

14 In the Boundary Expressions dialog box, define a variable named T_bnd with the expressions for the specified boundary numbers given in the table below. Due to the large number of boundaries, a technique for how to select them all directly from the geometry is outlined below the table.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION FOR BOUNDARIES</th>
<th>EXPRESSION FOR BOUNDARIES</th>
</tr>
</thead>
<tbody>
<tr>
<td>T_bnd</td>
<td>T</td>
<td>T_map</td>
</tr>
</tbody>
</table>

68–94, 97, 104–112, 133–140 1–32, 51

15 If you already defined T_bnd by selecting the boundaries by number according to the table above, click OK and proceed directly to the “Physics Settings” section.

16 The technique alluded to in Step 14 involves rectangular mouse selections in 3D. By default the mouse controls the 3D view (panning, rotating, zooming), so first click the Orbit/Pan/Zoom toolbar button to disable the 3D view control.

17 Click the Go to ZX View toolbar button to get a proper view for the selection.

18 Place the mouse pointer just outside the quartz tube and click and drag it to the other side of the tube that you solve for. View the left figure below for guidance,
which shows the selection rectangle to draw with the mouse and the selection after you release the mouse button.

19 Right-click with the mouse on the selected region to lock the selection. The selected objects then get a blue color as in the right figure above.

20 Go back to the Boundary Expressions dialog box and enter $T$ in the Expression column in the same row as the $T_{bnd}$ name.

21 Do a new selection starting at the same point as before, but extend it to include the entire tube. The selection now looks like that in the left figure below.
The green selection shows the locked boundaries (previously colored blue) that are scheduled for deselection. The pink ones are the boundaries you selected that where not selected before. Right-click on the selection to confirm the green deselection and lock the pink selection. The view should now look as in the right figure above.

Go to the Boundary Expressions dialog box and enter $T_{\text{map}}$ in the Expression column in the same row as the $T_{\text{bnd}}$ name.

Click OK to close the dialog box.

Click the Go to Default 3D View toolbar button and then click the Orbit/Pan/Zoom toolbar button to restore the previous view.

**PHYSICS SETTINGS**

*Subdomain Settings—General Heat Transfer*

For multiphysics modeling with several application modes present in the model, there is a convenient feature on the left side of the graphical user interface. It is called the Model Tree, and you can show it or hide it by clicking the Model Tree button on the Main toolbar. Adjust the size of the Model Tree area and the size of its frames so it looks similar to what you see in the figure of the final geometry above. The steps below assume that you have the Model Tree visible and sized correctly. Also, make sure to select the Detail view.

1. In the Model Tree, double click $\text{Geom1}\rightarrow\text{General Heat Transfer (htgh)}\rightarrow\text{Subdomain Settings}$.

2. In the Subdomain Settings dialog box, select Subdomain 9 and then click the Load button to open the Materials/Coefficients Library dialog box.

3. Select the Quartz material under the $\text{acdc_lib.txt}$ library.

4. Click Apply. This adds the material Quartz to the model. You see which materials you have added to the model when you expand the Model node in the Materials list to the left in the Materials/Coefficients Library dialog box.
5 Repeat the two last steps for the materials Graphite, Graphite felt, Copper, and Silicon Carbide. Before you close the dialog box, make sure that you see all five materials under Model in the Materials tree view.

6 Click Cancel to close the Materials/Coefficients Library dialog box. The selected materials are now available in the Library material list.

7 Choose Quartz from the Library material list.
8 Click the **Groups** tab, and enter Tube in the **Name** edit field.

![Subdomain Settings - General Heat Transfer (mph)](image)

9 Click the **Color** tab, select the **Manual control of color** check box, and click the **Color** button.

10 Select the a bright purple color from the palette, or enter (255, 153, 253) on the **RGB** page. Click **OK**.

![Subdomain Settings - General Heat Transfer (mph)](image)

The previous two steps and subsequent steps that change the color of a group are only necessary to get a nicer view of the geometry; thus, you can choose to skip these steps.
11 In the **Subdomain Settings** dialog box, define settings for the other subdomains according to the table below. If desired, repeat Steps 9 and 10 to define a color for each group.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN 11</th>
<th>SUBDOMAIN 12</th>
</tr>
</thead>
<tbody>
<tr>
<td>Material</td>
<td>Graphite felt</td>
<td>Graphite</td>
</tr>
<tr>
<td>Group name</td>
<td>Felt</td>
<td>Susceptor</td>
</tr>
<tr>
<td>Color</td>
<td>(153, 153, 153)</td>
<td>(51, 51, 51)</td>
</tr>
</tbody>
</table>

12 On the **Groups** page, select the group default in the **Group selection** field. Click the **Subdomains** tab and clear the **Active in this subdomain** check box.

13 Click **OK** to close the **Subdomain Settings** dialog box.

**Subdomain Settings—Induction Currents**

1 In the **Model Tree**, double click the item `Geom1>Induction Currents (emqa)>Subdomain Settings`.

2 Define settings for the other subdomains according to the table below in the same as for the Heat Transfer application mode. If desired, repeat Steps 9 and 10 to define a color for each group.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN 9</th>
<th>SUBDOMAIN 11</th>
<th>SUBDOMAIN 12</th>
</tr>
</thead>
<tbody>
<tr>
<td>Material</td>
<td>Quartz</td>
<td>Graphite felt</td>
<td>Graphite</td>
</tr>
<tr>
<td>Group name</td>
<td>Tube</td>
<td>Felt</td>
<td>Susceptor</td>
</tr>
</tbody>
</table>

3 Click the **Subdomains** tab and select Subdomains 1–6, 8, 13, and 14. Clear the **Active in this subdomain** check box.

4 Select Subdomains 7 and 10, click the **Groups** tab, and type **Air** in the **Name** edit field.

5 Click **OK** to close the **Subdomain Settings** dialog box.

The coils are not included in this simulation since the skin-depth is very short for the applied frequency. The coils are instead modeled as a surface current boundary condition.

**Boundary Conditions—General Heat Transfer**

1 In the **Model Tree**, double click the item `Geom1>General Heat Transfer (htgh)>Boundary Settings`.
2 In the **Boundary Settings** dialog box, define settings according to the table below.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES</th>
<th>BOUNDARIES</th>
<th>BOUNDARIES</th>
<th>BOUNDARIES</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Material</th>
<th>Graphite felt</th>
<th>Silicon Carbide</th>
<th>Quartz</th>
<th>Quartz</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Heat flux</td>
<td>Heat flux</td>
<td>Heat flux</td>
<td>Heat flux</td>
</tr>
<tr>
<td>Radiation type</td>
<td>Surface-to-Surface</td>
<td>Surface-to-Surface</td>
<td>Surface-to-Surface</td>
<td>Surface-to-Ambient</td>
</tr>
<tr>
<td>Tamb</td>
<td>T</td>
<td>T</td>
<td>T</td>
<td>293.15</td>
</tr>
<tr>
<td>Group name</td>
<td>Susceptor</td>
<td>Slide</td>
<td>Tube_inner</td>
<td>Tube_outer</td>
</tr>
</tbody>
</table>

3 Select Boundaries 81 and 104 again, click the **Highly Conductive Layer** tab, and select the **Enable heat transfer in highly conductive layer** check box.

4 In the **Distance** edit field type $1 \times 10^{-3}$ to set the thickness of this highly conductive layer.

5 Click **OK** to close the **Boundary Settings** dialog box.

**Boundary Conditions—Induction Currents**

1 In the **Model Tree** double click the item

   **Geom1>Induction Currents (emqa)>Boundary Settings**.

2 In the **Boundary Settings** dialog box define settings according to the table below.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES</th>
<th>BOUNDARIES</th>
<th>ALL OTHERS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Electric insulation</td>
<td>Surface current</td>
<td>Magnetic insulation</td>
</tr>
<tr>
<td>$J_s$</td>
<td>0</td>
<td>$J_{s _coil}t_{2y}$</td>
<td>$J_{s \coilet}t_{2z}$</td>
</tr>
<tr>
<td>Group name</td>
<td>Symmetry</td>
<td>Coil</td>
<td></td>
</tr>
</tbody>
</table>

3 Click **OK** to close the **Boundary Settings** dialog box.

**MESH PARAMETERS**

1 Open the **Free Mesh Parameters** dialog box from the **Mesh** menu.

2 Click the **Custom mesh size** option button, and enter 0.5 in the **Mesh curvature factor** edit field.
3  Click the **Boundary** tab and select all boundaries between the felt and the susceptor. The numbers of these boundaries are 16, 18, 23, 29, 79, 89, 109, and 134.

4  Set the **Maximum element size** to $6 \cdot 10^{-3}$, then click **Remesh**.

5  When the mesher has finished, click **OK**.

**SOLVER PARAMETERS**

1  From the **Solve** menu, open the **Solver Parameters** dialog box.

2  With the **Auto select solver** check box selected, select **Stationary** from the **Analysis** list.

3  Click the **Stationary** tab and choose **Linear** from the **Linearity** list (the model is linear, but the automatic selection chooses the nonlinear solver for this model because of the coupling variables).

4  Click **OK**.

5  Open the **Solver Manager** dialog box from the **Solve** menu.
Click the Solve For tab and select only the Induction Currents (emqa) application mode in the tree view.

7 Click OK.

8 Click the Solve button on the Main toolbar.

9 When the solution process is done open the Solver Parameters dialog box again.

10 From the Analysis list, select Transient, then type 0 3600 in the Times edit field.
11 Click the **Time Stepping** tab and choose **Time steps from solver** in the **Times to store in output** list.

![Solver Parameters](image)

12 Click **OK**.

13 Open the **Solver Manager**, select to solve only for the **General Heat Transfer (htgh)** application mode on the **Solve For** page.

14 Click the **Initial Value** tab, and in the frame **Values of variables not solved for and linearization point** click the **Current solution** button. This ensures that the solution for the induction currents problem is kept while solving the transient heat transfer problem.

15 Click **OK** to close the **Solver Manager**.

16 Click the **Solve** button on the Main toolbar.

**POSTPROCESSING AND VISUALIZATION**

1 From the **Postprocessing** menu, open the **Plot Parameters** dialog box.

2 On the **General** page, clear the **Slice** and **Geometry edges** check boxes, and select the **Boundary** and **Edge** check boxes.

3 Click the **Boundary** tab and enter $T_{bnd}$ in the **Expression** edit field.
4 In the **Boundary color** area, select **hot** from the **Colormap** list.

5 Click the **Edge** tab, enter 1 in the **Expression** edit field, click the **Uniform** color option button, and select black color for the edges.

6 Click **OK** to show the plot in the main window.

To get the plot in Figure 5-15 on page 303 takes some extra steps. Begin by suppressing the outer edges of the modeling domain:

1 From the **Options** menu, select **Suppress>Suppress Edges**.


3 Click **OK**.

4 Click first the **Default 3D View** button on the Visualization toolbar and then the **Zoom Extents** button on the Main toolbar to zoom in on the furnace.

Next, define a dummy expression on the coil subdomains to be able to give them a uniform color in the postprocessing stage:

5 From the **Options** menu, select **Expressions>Subdomain Expressions**.

6 Select Subdomains 4–6, 8, 13, and 14. Define a constant expression on these subdomains with the **Name** coils by the **Expression** 1.
7 Click OK.
8 From the Solve menu, select Update Model to make the subdomain expression you just defined available for postprocessing.
9 Open the Plot Parameters dialog box.
10 Click the Subdomain tab. Select the Subdomain plot check box.
11 In the Color data area, type coils in the Expression edit field.
12 In the Element color area, click first the Uniform color option button and then the Color button.
13 In the Element Color dialog box, select a copper-like color (the color in Figure 5-15 corresponds to the RGB values (204, 204, 0)). Click OK to close the dialog box.
14 Clear the Color scale check box.
15 On the General page, click the Title button.
16 Activate the Title edit field and enter Susceptor and tube: temperature [K] at t=1 h, or some other title of your choice. Click OK to close the Title dialog box.
17 Click OK to close the Plot Parameters dialog box and generate the plot.

As an alternative to defining a dummy subdomain expression, you can plot in a separate figure window and do separate, overlaid plots for the susceptor, the tube, and the coils. Remember to select the Keep current plot check box in the Plot Parameters dialog box. Make the plot for the coils with a uniform copper-like color. In the resulting figure you can click the Edit Plot toolbar button, and select properties for the individual plots.

The next step is to generate line plots of the temperature versus time at the center and periphery of the silicon carbide wafer.

1 From the Postprocessing menu, choose Domain Plot Parameters.
2 In the Domain Plot Parameters dialog box, click the Point tab and select Points 64 and 102, corresponding to the center and periphery of the SiC wafer.
3 Click the Line settings button, and choose Cycle in the Line marker list.
4 Select the Legend check box, then click OK.
5 Click OK again to get the line plot in a new figure window.
6 In the new figure, click the Edit Plot toolbar button. Select the Line (64) item from the tree view, and then type Center Periphery in the Legends edit field.
7 Click Apply. You should now see a plot similar to that in Figure 5-14 on page 302.
The final plot is a surface plot of the temperature across SiC wafer. Because half the wafer is outside the simulated region you must use the boundary variable, \( T_{bnd} \), to see the temperature.

1. In the **Domain Plot Parameters** dialog box, click the **General** tab.
2. Select only the solution at time **3600** from the list of time steps.
3. Click the **Surface** tab, select Boundaries 51 and 81, enter \( T_{bnd} \) in the **Expression** edit field, and choose **xy-plane** from the list in **x- and y-axis data**.
4. Click **OK** to get the surface plot in the figure window.
5. In the figure window, click the **Edit Plot** toolbar button.
6. In the **Edit Plot** dialog box, select the **Axes** item from the tree view. Enter **Temperature \([K]\)** in the **Title** edit field, and append the unit label \([m]\) in the **x label** and **y label** edit fields.
7. Select the **Patch** item from the tree view and set the **Colormap** to **hot**.
8. Click **OK** to close the **Edit Plot** dialog box and get the plot in Figure 5-16 on page 304.
An RFID System

This example illustrates the modeling of a reader-transponder pair for radio-frequency identification (RFID) applications.

Introduction

An RFID system consists of two main parts:

- A tag or transponder with a printed circuit-board (PCB) antenna
- A reader unit with a larger RF antenna

The reader antenna generates an electromagnetic field that energizes a chip (IC-circuit) inside the tag. The electromagnetic field is modulated by the tag’s circuit and the modulated signal is recovered by the reader antenna.

The transponder antenna is typically a conductor pattern on a substrate:
and a common type of reader antenna is a larger dual coil:

\begin{center}
\includegraphics[width=0.5\textwidth]{antenna.png}
\end{center}

**Inductive Coupling**

The coupling of the antennas is mainly inductive and is characterized by the mutual inductance, denoted $L_{12}$. The mutual inductance is defined as the total magnetic flux intercepted by one antenna for a unit current flowing in the other antenna

\[
L_{12} = \frac{\int \int \mathbf{B} \cdot \mathbf{n} dS}{I_1}
\]

where $S_2$ is the area of coil number 2, $\mathbf{B}$ is the flux intercepted by coil 2, $I_1$ is the current running in coil number 1, $\mathbf{n} = (n_x, n_y, n_z)$ is the unit surface normal vector, and $dS$ is an infinitesimal area element.

It is possible to transform the surface integral in Equation 5-1 into a simpler line integral by using the magnetic vector potential

\[
\mathbf{B} = \nabla \times \mathbf{A}
\]

together with Stokes’ theorem, which states that a surface integral of the curl of a field equals the closed line integral over the rim of the surface:

\[
L_{12} = \frac{\int \int (\nabla \times \mathbf{A}) \cdot \mathbf{n} dS}{I_1} = \frac{\oint \mathbf{A} \cdot d\mathbf{l}}{I_1}
\]

Here $\mathbf{t} = (t_x, t_y, t_z)$ is the unit tangent vector of the curve $\Gamma_S$ and $d\mathbf{l}$ is an infinitesimal line element.
Because the coupling is dominated by near-field inductive effects, it is sufficient to compute the mutual inductance for the static case (frequency equals zero) and neglect capacitive effects along with wave propagation phenomena. The appropriate application mode to use is called 3D Magnetostatics and is available in the AC/DC Module. It has the magnetic vector potential \( \mathbf{A} = (A_x, A_y, A_z) \) as its unknown field quantity.

**EDGE COMPUTATIONS**

This example approximates coils and wires as edges (1D entities) embedded in 3D space and the variables and techniques used are somewhat different than for a regular magnetostatics boundary value problem. The magnetic vector potential components are available at edges as the variables \( tA_x, tA_y, \) and \( tA_z \), which form the projection of the vector potential on edges. On the other hand, the bulk components are denoted \( A_x, A_y, \) and \( A_z \).

In COMSOL Multiphysics, each edge has a direction associated with it, and in order to form a closed line integral it is necessary to manually find the direction of each edge and flip this if needed. Flip the edge directions by the following procedure: for each edge that participates in a line integral or line source, define an **Edge Expression** that takes the values -1 and +1 depending on if the built-in direction of the edge agrees with the global direction of the closed line integral. (It is up to the user to decide for a global direction of a closed line integral.)

**Results**

The computed value for the mutual inductance \( L_{12} \) is about 1 nH.
The following visualization shows magnetic flux lines and the base-10 logarithm of the magnetic flux intensity as color.

The following visualization shows the edges of the finite elements used:
Model Library path: ACDC_Module/General_Industrial_Applications/rfid

Modeling Using the Graphical User Interface

MODEL NAVIGATOR
1 From the Model Navigator, set the Space Dimension to 3D.
2 In the list of application modes, select AC/DC Module>Statics, Magnetic>Magnetostatics, Vector Potential.
3 Click OK to open the main GUI.

DRAW MODE
We will start by drawing the transponder antenna in a 2D work plane and then embed it into 3D space.

Transponder Antenna
1 From the Draw menu, select Work-Plane Settings.
2 Click the z-x plane button with y = 0.
3 Click OK to create the work plane.
4 From the Draw menu, select Specify Objects>Line.
5 In the Line dialog box, type a space separated list of vertex coordinates according to the following:
   X: 0.8875 0.8875 0.9125 0.9125 0.89 0.89 0.91 0.91 0.8925 0.8925 0.9075 0.9075 0.895 0.895 0.8875
   Y: 0 0.01 0.01 -0.01 -0.01 0.0075 0.0075 -0.0075 -0.0075 0.005 0.005 -0.005 -0.005 0 0
6 Click OK to create the transponder profile.
7 Click the Zoom Extents button on the main toolbar to automatically adjust the axis settings to get a good view of the transponder profile.

Reader Antenna
Next, create the reader antenna.
1 From the Draw menu, select Specify Objects>Rectangle.
2 Specify a rectangle with **Width** 1.8, **Height** 0.8, **Base Corner**, x 0, y -0.4, and **Style Curve**.
3 Click **OK** to create the rectangle.
4 Click the **Zoom Extents** button.
5 To create rounded corners, or fillets, for the rectangle, click the **Fillet/Chamfer** button.
6 In the **Vertex selection** list, click the object R1 (the rectangle) and select all 4 vertices by using Ctrl+left click or Ctrl+A.
7 Specify a **Radius** of 0.2.
8 Click **OK** to apply the fillets.

**Embedding into 3D Space**
Now embed the two flat shapes into 3D space.
1 From the **Draw** menu, select **Embed**.
2 Highlight both objects B1 and B2.
3 Click **OK** to embed the objects into 3D space.
4 Click on the edge on the larger coil to select it. Make sure it is highlighted in red.
5 Click the **Move** button.
6 For the **y-displacement**, type -0.4.
7 Click **OK** to displace the large coil element 0.4 m in the negative y direction.
8 To create a mirror-image of the large coil, make sure it is highlighted and click the **Mirror** button.
9 Change the **Normal vector** from 0 0 1 to 0 1 0.
10 Click **OK** to create the mirrored image.

**Truncation Sphere**
You also need to truncate the computational domain, because the finite element calculation requires a finite-sized mesh. Do this with a large sphere with center in the middle of the coil system.
1 From the **Draw** menu, select **Sphere**.
2 Set the **Radius** to 3.
3 In the **Axis base point** area, set x to 0, y to 0, and z to 0.9.
4 Click **OK** to create the sphere.

Make sure to save the model at this point to be able to revert to this stage if needed.
CHAPTER 5: GENERAL INDUSTRIAL APPLICATION MODELS

SUBDOMAIN SETTINGS
1. From the Physics menu, select Subdomain Settings.
2. The material parameter that you can alter for a magnetostatic simulation is the magnetic permeability $\mu_r$. However, assume that the truncation sphere is filled with air and leave the default setting $\mu_r = 1$.
3. Click OK to close the dialog box.

BOUNDARY SETTINGS
1. From the Physics menu, select Boundary Settings.
2. The default boundary condition for the faces that constitute the sphere is Magnetic insulation. This allows for surface currents to run across the sphere in such a way as to make the tangential component of the magnetic vector potential equal to zero. This is a good approximation in place of an infinite domain. It approximates that the tangential component of the vector potential approaches zero as the distance from the coils approaches infinity. Thus there is no need to change the boundary settings.
3. Click OK to close the dialog box.

EDGE SETTINGS
Now define the driving line currents of the reader antenna. To do this you need to find the direction of all edges of the reader antenna and flip the direction when needed. You also need the suppress edges feature available from the Options menu to conveniently visualize and click the edges. This is a bit technical compared to regular use of the graphical user interface, and the reason is that edges fill up a much smaller part of the screen than boundaries and subdomains and hence edges are harder to select by mouse clicking.

To enhance the visualization of edges before you start the selection process, widen the appearance of the edges and turn on a smoothing feature called antialiasing. Hardware acceleration standards supported by many graphics cards support this edge-smoothing feature.

1. From the Options menu, select Preferences.
2. Click the Visualization tab and change the line width from 1.0 to 1.5.
3. Select the check box for Antialiasing.
4. Click OK to close the dialog box.

Now, to the edge suppression:
1. From the **Options** menu, select **Suppress>Suppress Edges**. Keep this dialog open but move it aside while performing steps 2 and 3.

2. Click the **Orbit/Pan/Zoom** toolbar button on the Camera toolbar to disable this feature.

3. Click and drag, using the left mouse button, a rubber-band box enclosing the reader antenna and the transponder antenna. Make sure the edges are highlighted in red.

4. In the **Suppress Edges** dialog box, click **Apply**.

5. Click **Invert Suppression**.

6. Click **OK** to close the dialog box.

7. Click the **Zoom Extents** button.

8. Click the **Orbit/Pan/Zoom** toolbar button on the Camera toolbar to enable this feature.

Now visualize the direction of the edges. To do this you need to enter Postprocessing mode. You normally cannot do this until you have solved the problem. However, for these situations there is a feature to help called Update Model.

1. From the **Solve** menu, select **Update Model**. This creates a mesh and puts you in Postprocessing mode. Please note that for a general situation you might need to adjust the mesh parameter settings before selecting **Update Model**.

2. From the **Postprocessing** menu, select **Plot Parameters**.

3. On the **General** page, clear the **Slice** and **Geometry Edges** check boxes.

4. Select the **Plot type** called **Arrow**.

5. Click the **Arrow** tab.

6. Change the **Plot arrows on** setting to **Edges**.

7. For the **x component**, **y component**, and **z component** type **t1x**, **t1y**, and **t1z**, respectively. These are the components of the edge tangent vector.

8. For the **Arrow type**, change to **3D arrow**.
9 Click **OK**.

To see which edge corresponds to which edge number, we need to turn on the edge label visualization.

1 From the **Options** menu, select **Labels>Show Edge Labels**.

2 To see the edge labels you need to switch to the Edge mode. To alter between the Postprocessing mode and Edge mode, click the corresponding buttons on the main toolbar.

Apply a right-hand rule for the edge directions so that edges circling in the direction from the $z$-axis to the $x$-axis with the thumb pointing in the $y$ direction are considered to be of positive sign.

We will now define an **Edge Expression** $\varepsilon_{\text{sgn}}$ that controls the flip of the edge directions.

1 From the **Options** menu, select **Expressions>Edge Expressions**.

Use the left mouse button to click the edges or the edge labels and to highlight them in red. Then click the right mouse button to lock the selection. You can undo all selections by pressing Ctrl+D or by selecting **Deselect all** from the **Edit** menu.

2 Select Edges 5, 7, 8, 10, 12, 14, 42, and 44. While all these are highlighted, type $\varepsilon_{\text{sgn}}$ for the **Name** and 1 for the **Expression**.
3 Select Edges 6, 9, 11, 13, 41, 43, 45, and 46. While all these are highlighted, type -1 for the Expression. These are the edges for which you will flip the direction.

4 Click OK to close the dialog box.

5 From the Physics menu, select Edge Settings.

6 Select Edges 5 through 14 and 41 through 46.

7 In the text field for the Current in edge segment direction, type esgn.

8 Click OK to close the dialog box.

**MESH SETTINGS**

1 From the Mesh menu, select Free Mesh Parameters.

2 Change the Predefined mesh sizes to Extremely coarse.

3 Click the Remesh button.

4 Click OK to close the dialog box.

**SOLVER SETTINGS**

1 From the Solve menu, select Solver Parameters.

2 Click the Settings button in the Linear system solver area.

3 In the Linear Systems Solver Settings dialog box, select Preconditioner from the tree view.

4 From the Preconditioner list, select SSOR gauge.

5 Click OK twice to close both dialog boxes.

6 To solve, click the Solve button on the Main toolbar.

**POSTPROCESSING**

**Visualization**

1 From the Postprocessing menu, select Plot Parameters.

2 On the General page, clear the Arrow check box.

3 Select the Plot type called Slice.

4 Click the Slice tab.

5 Change the x levels, y levels, and z levels to 1, 1, and 1, respectively.

6 Click Apply.
7 Click **Zoom Extents**.

![Image of magnetic flux density](image)

8 Click the **Streamline** tab.

9 Select the **Streamline plot** check box in the upper left corner.

10 Click **OK** to generate the visualization.

The starting point for the magnetic field lines (streamlines) is randomized and they are unevenly distributed. However, you can see that the magnetic field lines are qualitatively following the expected pattern.

This solution was obtained using a very coarse mesh. Later you will solve for a finer mesh and get better accuracy.

**Inductance Computation**

Now compute the line integral for the close transponder antenna loop. This also requires that you flip direction of edges and you will continue to define the `esgn` variable also for the transponder edges. For convenience, first suppress all edges except those of the transponder.

1 From the **Options** menu, select **Suppress>Suppress Edges**.

2 Click the **Orbit/Pan/Zoom** toolbar button on the Camera toolbar to disable this feature.
3 Click the **Zoom Extents** button.

4 Click and drag, using the left mouse button, a rubber-band box enclosing the transponder antenna. Make sure the edges are highlighted in red.

5 In the **Suppress Edges** dialog box, click **Apply**.

6 Click **Invert Suppression**.

7 Click **OK** to close the dialog box.

8 Click the **Zoom Extents** button.

9 Click the **Orbit/Pan/Zoom** toolbar button on the Camera toolbar to enable this feature.

Now visualize the direction of the transponder edges.

1 From the **Postprocessing** menu, select **Plot Parameters**.

2 On the **General** page, clear all check boxes.

3 In the **Plot type** area, select the **Arrow** and **Edge** check boxes.

4 Click the **Arrow** tab.

5 Change the **Plot arrows on** setting to **Edges**.

6 Make sure that the **x component**, **y component**, and **z component** are set to \( t_1x \), \( t_1y \), and \( t_1z \), respectively.

7 For the **Arrow type**, select **3D arrow**, if not already selected.

8 Click the **Edge** page.

9 For the **Edge color**, click **Uniform color**. This aids in the visualization by outlining the edges using a uniform color.
10 Click **OK** to close the dialog box and to create the visualizations.

Repeat the same steps as before to flip the edges. You can toggle between Edge mode and Postprocessing mode to see which edge number has a positive direction.

1 From the **Options** menu, select **Expressions>Edge Expressions**.

2 Use the left mouse button to click the edges or the edge labels and to highlight them in red. Then click the right mouse button to lock the selection. You can undo all selections by clicking Ctrl+D or select **Deselect all** from the **Edit** menu. Alternatively, select directly from the Edge selection list in the dialog box by pressing the Ctrl key while clicking with the left mouse button.

3 Select Edges 15, 17, 18, 20, 21, 23, 29, 31, and 33. While all these are highlighted, type 1 for the **Expression** corresponding to the **Name esgn**.

4 Select Edges 16, 19, 22, 30, 32, 34, 38, 39, and 40. While all these are highlighted, type -1 for the **Expression** corresponding to the **Name esgn**.

5 Click **OK** to close the dialog box.

Now compute the integral that gives the mutual inductance:
The current of the reader antenna is set to unity, so there is no computation needed for the denominator $I_1$.

For computing the line integral for the mutual inductance use an edge integration coupling variable that you name $L_{12}$ and that sums up the contributions to the closed-line integral for each individual segment.

The integrand at each segment is $\theta sgn \cdot tA$, where $tA$ is the projection of the magnetic vector potential in the direction of the unit tangent vector to that edge. The magnetic vector potential components at edges are available as $tAx$, $tAy$, and $tAz$ and the edge-tangent vector components are denoted $t1x$, $t1y$, and $t1z$. The tangent vector terminology is inherited from the fact that for a surface the tangent vector comes in pairs as $t1x$, $t1y$, $t1z$, and $t2x$, $t2y$, $t2z$. The projection $tA$ is then defined by dot-product of the tangent vector and the magnetic potential:

$$ tA = tAx \cdot t1x + tAy \cdot t1y + tAz \cdot t1z $$

Define $tA$ as a scalar expression that is available globally.

1. From the **Options** menu, select **Expressions>Scalar Expressions**.
2. Define a **Scalar Expression** with name $tA$ and Expression $tAx \cdot t1x + tAy \cdot t1y + tAz \cdot t1z$.
3. Click **OK**.

To define the edge integration coupling variable:

1. From the **Options** menu, select **Integration Coupling Variables>Edge Variables**.
2. Select Edges 15–23, 29–34, and 38–40. For this selection you can use Ctrl+left click.
3. Define a variable with the **Name** $L_{12}$ and **Expression** $tA \cdot \theta sgn$. You can leave the **Integration order** and **Global destination** by their defaults. The variable $L_{12}$ will have global scope for use in postprocessing - it can be used in any of the postprocessing dialog boxes.
4. Click **OK**.

You need to explicitly tell the software to evaluate these newly defined variables:
1 From the Solve menu, select Update Model. This re-evaluates all variables without re-solving.

To get the value of the mutual inductance variable $L_{12}$:

1 From the Postprocessing menu, select Data Display>Global.
2 For the Expression to evaluate, type $L_{12}$.

Click OK to evaluate. A value of about $9 \times 10^{-10}$ is displayed in the history log at the bottom of the GUI window. This corresponds to a mutual inductance of 0.9 nH.

**SOLVING FOR A FINE MESH USING GMG+GMRES SOLVER**

Next, solve the problem using the geometric multigrid (GMG) preconditioner and the iterative FGMRES linear system solver. The GMG preconditioner creates a hierarchy of meshes and solves for the coarsest mesh using a direct solver. Then it interpolates the results to an automatically or manually created finer mesh in a process toward a final solution. In this case, GMG is terminated before it reaches the final solution and instead the partial results is used as a so called preconditioner for the FGMRES iterative solver. This combination of iterative solver and preconditioner is very efficient for solving a large class of problems and proves efficient also for this example.

1 From the Solve menu, select Solver Parameters.
2 Change the Linear system solver to FGMRES.
3 Click the Settings button.
4 In the Linear Systems Solver Settings dialog box, select Preconditioner from the tree view.
5 From the Preconditioner list, select Geometric multigrid.
6 From the Hierarchy generation method list, select Refine mesh.
7 Click OK twice to close both dialog boxes.
8 Click the Solve button.

**Visualization**

1 From the Postprocessing menu, select Plot Parameters.
2 On the General page, clear the Arrow and Edge check boxes.
3 Select the Plot type called Slice.
4 Click OK.
5 Click Zoom Extents.
The GMG preconditioner automatically saves all mesh refinement cases and makes them accessible from the **Mesh** menu. To see the mesh, go to the **Mesh** menu and change to **Mesh case 1**. Click the **Mesh Mode** button on the Main toolbar to visualize the mesh (or select **Mesh Mode** from the **Mesh** menu):
This mesh corresponds to about 12,000 degrees of freedom.

To get an even more accurate solution now increase the order of the elements from linear to quadratic. This gives you a solution that would be computationally demanding if you had used a direct solver instead of the GMG+GMRES combination. In doing this you will create mesh case 2 in addition to the already created mesh cases 0 and 1.

1. From the Mesh menu, select Mesh Cases.
2. In the Mesh Case Settings dialog box click New.
3. From the Mesh cases list, select mesh case 2.
4. Select and set the check box for Use same mesh as mesh case to 1.
5. Click OK to close the dialog box.
6. From the Mesh menu verify that Mesh case 2 is the selected mesh case.
7. From the Physics menu select Subdomain Settings.
8. In the Subdomain selection list select Subdomain 1.
9. Click the Element page.
10. Change the Predefined elements from Vector - Linear to Vector - Quadratic.
11. Click OK to close the dialog box.
12. Click the Solve button. The GMG preconditioner now utilizes all three meshes.

The resulting mesh corresponds to about 60,000 degrees of freedom and the computations require about 300 MB of RAM.

You may get warnings about inverted mesh elements in the solver Progress–Log window. This means that some elements are numerically turned inside out due to the second order geometrical representation of the element edges. It typically happens at curved faces or edges in the geometry. In this model, it may happen at the rounded “corners” of the reader antenna. The problem can be avoided by using a linear geometry representation of the element edges. Go to the Physics menu, select Model Settings, and change Geometry shape order from Automatic to Linear. However, unless the inverted elements are located in a critical region, for example on edges where the mutual inductance is computed, or if the solver does not converge, you can safely ignore the warnings.

You can optimize the mesh even more. The mesh should accurately describe the shape of the antenna. This is not a problem for the transponder antenna because it consists of straight edges. However, the reader antenna has some curved edges, and you need
to manually refine the mesh adjacent to the reader antenna by setting a maximum mesh density for the edges that makes up the reader antenna.

1. From the **Mesh** menu select **Mesh Cases**.
2. In the **Mesh Case Settings** dialog box click **New**.
3. Click **OK** to close the dialog box.
4. From the **Mesh** menu verify that **Mesh case 3** is the selected mesh case.
5. From the **Mesh** menu select **Free Mesh Parameters**.
6. Click the **Edge** tab. Keep this dialog open but move it aside for later use.

You now need to enable the visualization of all edges:

1. From the **Options** menu select **Suppress>Suppress Edges**.
2. Click the **Suppress None** button and click **OK** to close the dialog box.
3. Deselect the **Orbit/Pan/Zoom** button and enclose both the reader and transponder antenna with a rubber-band box resulting in them being highlighted in red.
4. Go back to the **Edge** page of the **Free Mesh Parameters** dialog box.
5. For the **Maximum element size for edges**, set 0.05.
6. Click the **Global** tab.
7. Set the **Predefined mesh sizes** to **Coarse**.
8. Click the **Remesh** button.
9. Click **OK** to close the dialog box.

Later, you can visualize the interior of the mesh to see the refined mesh around the reader antenna. First you need to raise the order of the elements also for this last mesh case.

1. From the **Physics** menu, select **Subdomain Settings**.
2. In the **Subdomain selection** list select Subdomain 1.
3. Click the **Element** tab.
4. Change the **Predefined elements** from **Vector - Linear** to **Vector - Quadratic**.
5. Click **OK** to close the dialog box. The resulting mesh has about 30,000 elements and corresponds to more than 180,000 degrees of freedom. The model, at this stage, requires about 400 MB to solve.
6. From the **Solve** menu, select **Solver Parameters**.
7. Click the **Settings** button in the **Linear system solver** area.
8 In the Linear Systems Solver Settings dialog box, select Preconditioner from the tree view.

9 On the Automatic page, choose Lover element order first (all) from the Hierarchy generation method list. Clear the Keep generated mesh cases check box.

10 Click OK twice to close the dialog boxes.

11 Click the Solve button on the Main toolbar. Inverted mesh element warnings may appear.

12 From the Postprocessing menu, select Plot Parameters.

13 On the General page, select Slice and Geometry edges, clear all other Plot type check boxes.

14 On the Slice page, for the Slice data Expression type \( \log_{10}(\text{norm}\_\text{B}\_\text{emqa}) \). This visualizes the base-10 logarithm of the magnitude of the magnetic flux density.

15 Make sure the Slice positioning is set to 1, 1, and 1, for the Number of levels in the x direction, y direction, and z direction.

16 Click OK to close the dialog box.

To get the value of the mutual inductance variable \( L_{12} \), this time for the refined mesh:

1 From the Postprocessing menu, select Data Display>Global.

2 For the Expression to evaluate, type \( L_{12} \).
3 Click **OK** to evaluate.

A value of **9.90337E-10** (this may vary slightly on different computers) is displayed in the history log at the bottom of the GUI window. This corresponds to a mutual inductance of about 1 nH (rounded).

**ADVANCED MESH VISUALIZATION**

Start by visualizing the interior of the mesh.

1. From the **Mesh** menu, select the **Mesh Visualization Parameters**.
2. Clear the **Boundary elements** check box.
3. Select the **Subdomain elements** and **Edge elements** check boxes.
4. Change the **Edge elements** color to a red color.
5. Change the **Subdomain elements, Element color** to a light gray color.
6. In the **Subdomain elements** area, select the **Wireframe color** check box. Click the associated **Color** button, set the color to dark gray, and then click **OK**.
7. Select the **Element selection** check box, then set the **Logical expression for inclusion** field to \((y\geq0.4)\).
8. Click **OK** to apply the settings and close the dialog box.
9. Click the **Mesh Mode** button on the Main toolbar to visualize the mesh.
10. From the **Options** menu, select **Preferences**.
11. On the **Visualization** page, change the **Line width** to **1.0**.
12. Click **OK** to close the dialog box.
13. Click the **Headlight** button on the Camera toolbar.
14. Click the **Zoom Window** button and enclose the upper part of the antenna system.
Click **Zoom Extents** to start over if you zoom in too much.

The visualization shows (in red color) that the edges of the curved sections of the reader antennas are discretized so that the curvature is resolved quite well.

**MAGNETIC FLUX-LINE VISUALIZATION**

1. From the **Options** menu, select **Visualization/Selection Settings**.
2. On the **Rendering/Selection** page, change the **Transparency** to 1.0 (or use the **Decrease Transparency** toolbar button repeatedly).
3. Click **OK** to apply and close the dialog box.
4. From the **Postprocessing** menu, select **Plot Parameters**.
5. On the **Slice** page, set the **Number of levels** in both the **x direction** and **y direction** to 0. Leave the **z direction** setting at 1.
6. On the **Streamline** page, from the **Predefined quantities** list, select **Magnetic flux density**.
7. Change the **Number of start points** to 100. Please note that if the graphics card on the computer has limited memory, this operation might fail. If so, try then to reduce the number from 100 to, say, 50.
8. Select the **Streamline plot** check box in the upper-left corner.
9. Click **OK** to apply and close the dialog box.
Click the **Headlight** button on the Camera toolbar to switch off the light.

Time-Harmonic Simulations

The RFID tag model also makes sense to solve in time-harmonic setting where you solve for a certain frequency, or frequency-sweep, instead of the case of steady-currents and fields.

To change the model from being static to time-harmonic is fairly straightforward and is described by the following steps.

1. From the **Physics** menu, select **Properties**.
2. Change the **Analysis type** to **Time-harmonic**.
3. Change the **Potentials** (solved for) to **Electric and magnetic**.
4. Make sure **Gauge fixing** is **On**.
5. Click **OK** to close the dialog box.
6. From the **Physics** menu, select **Scalar Variables**.
7. Change the **Frequency** to the desired one, say 50000 Hz. Note that the frequency variable is available as **nu_emqa** (by default).
Click **OK** to close the dialog box.

The solver settings change when you change the analysis type. To change to GMRES with GMG, adjust the corresponding **Solver Parameters**. The default element type for this analysis type is linear elements: linear vector elements for the magnetic vector potential and linear Lagrange (isoparametric) elements for the electric potential and the gauge-fix variable psi. In order to change the element order for the mesh cases, select each mesh case you want to change the settings for and adjust the settings on the **Element** page of the **Subdomain Settings** dialog box. Please note that if you change the defaults, from linear to quadratic for this example, you might run out of memory unless you are using a computer with 2 GB of RAM or more.

These are all the necessary changes for solving a time-harmonic problem. Please note that because this problem is induction dominated, the computed value of the inductance, $L_{12}$, do not change significantly unless the frequency is very high.

Increasing the frequency of the RFID system does increase radiation losses and eventually artificial reflections from the truncation sphere will appear. (So far we have ignored radiation losses.) When this becomes a problem you need to add absorbing layers or boundary conditions to the outside of the domain. In such a case, you also need to use the Electromagnetic Waves, Harmonic Propagation application mode found in the RF Module. Such high frequencies are unusual for an RFID system. However, if you apply the above modeling technique to another type of wire-antenna system you might need to take this into consideration. See the RF Module documentation for more information on absorbing layers (called perfectly matched layers or PMLs) and boundary conditions.
Magnetic Prospecting of Iron Ore Deposits

Introduction

Magnetic prospecting is one of the methods of geological exploration applicable to certain types of iron ore deposits, in particular those made up of magnetite and hematite. Estimates of center-of-mass coordinates and the spatial extent of iron-rich layers help decrease the cost of exploration. Passive magnetic prospecting relies on accurate mapping of local geomagnetic anomalies—deviations of the natural magnetostatic fields from their predicted values based on the magnetic dipole model of the Earth’s field. This model investigates magnetic anomaly estimation for both surface and aerial prospecting.

Crustal magnetic anomalies may result from either induced or remnant magnetization of iron-rich rocks. Amongst all terrestrial iron minerals, magnetite has the largest magnetic permeability (up to \( \mu_r = 650 \) in small-grain magnetite) and the strongest naturally occurring thermo-remnant magnetization (up to \( M_r = 5000 \) A/m) (Ref. 1). Another mineral with relatively strong magnetization is hematite (Ref. 1). Magnetite and hematite are the major minerals of high-grade iron ore. This model uses modest values of magnetic permeability (\( \mu_r = 3.5 \)) and remnant magnetization (\( M_r = 60 \) A/m) that are typical for terrestrial magnetite with a grain size distribution of 20–200 \( \mu \)m (Ref. 1). The concentration of magnetite in the iron-rich ore is assumed to be 25%.

Model Definition

Magnetostatic problems without significant electrical currents can be solved in terms of a scalar magnetic potential. Variations of the magnetic permeability or remnant magnetization cause small deviations of magnetic fields from the norm (local geomagnetic anomalies), which you can model accurately using the Reduced Potential formulation of the Magnetostatics, No Currents application mode. The background magnetic field is assumed to be uniform within the simulation domain. Intensity and orientation of the natural magnetic field is estimated using the data from National Geophysical Data Center of the U.S. Government (Ref. 2).

This model neglects the induced and remnant magnetization of the rocks outside the iron ore body. The iron ore bed is approximated by a uniform flat ellipsoid with a
maximum vertical thickness of 100 m, a maximum North-South width of 400 m, and a East-West extent of 2000 m. Center-of-mass coordinates of the ore bed (2500, 1500) meters from the lower-left corner, 200 meters above sea level) are positioned underneath the Eastern Pit of the Eagle Mountain Mine, a former Kaiser Steel Co. mining operation in Riverside Co., California (Ref. 3). The specific location and shape of magnetic ore in this model are not based on any actual geological prospecting but are chosen to simulate a basic size and shape of such. Figure 5-17 shows the model geometry.

Figure 5-17: The model geometry.

TOPOGRAPHY
The topographical map used for this model consists of a rectangular grid containing 157-by-111 points spaced by 1 arc second (1/3600°) in both horizontal directions. The curvature of geoid is neglected in drawing this geometry from elevation data. The lower-left (south-west) corner of the map is located at a latitude 33.85° (North) and longitude 115.5° (West). The size of the simulation domain is 4836 m in an East-West (x-axis), 3410 m in a North-South direction (y-axis), and 1934.4 m in the up-down direction (z-axis). A satellite image of this area can be seen in (Ref. 4).
A digital elevation model (DEM) for this example has been derived from the National Elevation Dataset (NED) of the U.S. Geological Survey data center (Ref. 5). A free program, MicroDEM (Ref. 6), was used to convert the USGS elevation data into an ASCII file containing the elevation matrix. The elevation matrix was then converted into a COMSOL spline surface object in COMSOL Script by means of the geomsurf command. The surface was further embedded into a 3D domain (rectangular box) using the geomcoerce command. The resulting geometry was then saved in COMSOL’s internal binary CAD file format (.mphbin). Importing the saved CAD file into the user interface is the starting point for the step-by-step instructions for this model. Figure 5-18 contains a plot of the resulting elevation map as it appears in COMSOL Multiphysics.

![Figure 5-18: Elevation map of the simulation domain (boundary plot of z-coordinate on Boundary 6). Note that the plot uses unequal axis scaling.](image)

**Domain Equations**

In a current-free region, where

\[ \nabla \times \mathbf{H} = 0 \]

it is possible to define the scalar magnetic potential, \( V_m \), such that
This is analogous to the definition of the electric potential for static electric fields. Using the constitutive relation between the magnetic flux density and magnetic field,

\[ \mathbf{B} = \mu \mathbf{H} + \mathbf{B}_r \]

together with the equation,

\[ \nabla \cdot \mathbf{B} = 0 \]

one can derive an equation for \( V_m \):

\[ \nabla \cdot (-\mu \nabla V_m + \mathbf{B}_r) = 0 \]

The Reduced potential formulation used in this model splits the total magnetic potential into external and reduced parts, \( V_{\text{tot}} = V_{\text{ext}} + V_m \), where the reduced potential \( V_{\text{red}} = V_m \) is the dependent variable:

\[ \nabla \cdot (-\mu \nabla (V_{\text{ext}} + V_m) + \mathbf{B}_r) = 0 \]

The external magnetic potential is more easily defined as an external magnetic field, so the equation that is used in practice is rather

\[ \nabla \cdot (-\mu \nabla V_m + \mathbf{B}_r + \mu \mathbf{H}_{\text{ext}}) = 0 \]

To simulate the background geomagnetic field, components of the external magnetic field are expressed through total intensity, magnetic declination, and inclination angles as follows:

\[
\begin{align*}
\text{extHO}_x &= \text{HO} \cdot \cos(\text{Incl}) \cdot \sin(\text{Decl}) \\
\text{extHO}_y &= \text{HO} \cdot \cos(\text{Incl}) \cdot \cos(\text{Decl}) \\
\text{extHO}_z &= -\text{HO} \cdot \sin(\text{Incl})
\end{align*}
\]

Based on the data provided by NOAA’s data center (Ref. 3), inclination and declination angles for this location (N 33.85°, W 115.5°) are approximately

\[ \text{Incl} = 59.357^\circ \] and \[ \text{Decl} = 12.275^\circ \], respectively. The magnitude of natural magnetic flux density \( \mathbf{B}_0 = \mu_0 H_0 \) is estimated as 48.163 \( \mu \text{T} \).

Remnant magnetic flux density is assumed to be aligned with the local contemporary direction of geomagnetic field.
In general, thermo-remnant magnetization does not have to be aligned with the Earth’s magnetic field.

The values of magnetic permeability and remnant flux used for the iron ore are based on the typical parameters of magnetite ore and a simple homogenization model taking into account dilution of magnetization in the ore bed:

\[
\begin{align*}
\mu_{r,\text{ore}} - 1 &= (\mu_{r,\text{magn}} - 1) \cdot c_{\text{magn}} \\
B_{r,\text{ore}} &= B_{r,\text{magn}} \cdot c_{\text{magn}}
\end{align*}
\]

Concentration of magnetite \(c_{\text{magn}}\) in the ore is assumed to be 25%.

**BOUNDARY CONDITIONS**

Along the exterior boundaries of the surrounding box, perturbation of the magnetic field \(H_{\text{red}}\) is assumed to be tangential to the boundaries. The natural boundary condition from the equation is

\[
\mathbf{n} \cdot \mathbf{B}_{\text{red}} = \mathbf{n} \cdot \mu \cdot \nabla V_m = 0
\]

Thus the reduced magnetic field is made tangential to the boundary by a Neumann condition on the reduced potential. Interior boundaries are modeled as continuity boundary conditions, and require no user input.

Note that the Magnetostatics, No Currents application mode automatically adds a point constraint \(V_m = 0\) using a weak term on the equation-system level (choose \textit{Physics}\textgreater\textit{Equation System}\textgreater\textit{Point Settings}), if there are no boundary conditions that constrain the value of \(V_m\) (such as Magnetic potential or Zero potential). This ensures that the scalar potential \(V_m\) is uniquely defined in problems with pure Neumann boundary conditions.

**Results and Discussion**

Figure 5-19 shows deviations of the magnetic field intensity on the ground (boundary plot), and at an altitude of 1300 meters. The maximum magnetic field perturbation on the ground is 2 A/m and at 1300 meters altitude it has fallen to 0.1 A/m. In both locations the maximum is located approximately above the center of mass of the
magnetite ore body. These results show that aerial magnetic prospecting may reveal the location and provide estimates of the horizontal extent of magnetite-rich deposits but also that ground-based magnetic prospecting apparently is a much more sensitive exploration tool than aerial prospecting.

Figure 5-19: The slice color plot shows perturbations of magnetic intensity (norm of reduced magnetic field) at an altitude 1300 m. The boundary plot shows the same quantity on the ground.
Figure 5-20: Boundary plot shows magnitude of reduced magnetic field on the surface of the Earth. Arrows show the direction and magnitude of reduced magnetic field on the surface of the Earth.

Figure 5-21 shows a boundary plot of the boundary distance variable dist1, which is defined as the distance from the boundaries of the iron ore bed. Plotted on the surface of the formation, this variable helps determine the depth of occurrence of ore and its location. In this model, depth of occurrence is about 115 m.
Figure 5-21: The boundary plot shows the approximate distance from the Earth’s surface to the iron ore bed.

Figure 5-22 shows a slice plot of the dimensionless ratio of remanent and induced magnetizations, $B_r/\mu_0 M$, inside the iron ore body, at elevation 200 m above sea level. This plot indicates that contributions of remanent and induced magnetizations to the magnetic anomaly can be comparable for realistic magnetic parameters of magnetite (Ref. 1).
Figure 5-22: Slice plot of the dimensionless ratio of remanent to induced magnetizations inside the iron ore body at an elevation of 200 m above sea level. The two contributions to the magnetic anomaly are of comparable magnitude.

References


2. NOAA’s Geophysical Data Center, http://www.ngdc.noaa.gov/geomagmodels/IGRFGrid.jsp


Model Library path: ACDC_Module/General_Industrial_Applications/magnetic_prospecting

Modeling Using the Graphical User Interface

**MODEL NAVIGATOR**
1. Start COMSOL Multiphysics.
2. From the **Space dimension** list, select **3D**.
3. From the **Application Modes** list, select **AC/DC Module>Statics, Magnetic>Magnetostatics, No Currents>Reduced Potential**.
4. Click **OK**.

**GEOMETRY MODELING**
The main geometry has been created from elevation data outside COMSOL Multiphysics, so you import it from an MPHBIN-file (COMSOL’s native geometry format). The iron ore bed is not included in the CAD file so you add it after importing.

1. From the **File** menu, choose **Import>CAD Data From File**.
2. In the **Import CAD Data From File** dialog box, make sure that **COMSOL Multiphysics file or All 3D CAD files** is selected in the **Files of type** list.
3. Browse to the **models/ACDC_Module/General_Industrial_Applications** folder in the COMSOL installation directory, locate the file magnetic_prospecting.mphbin, and then click **Import**.
4. From the **Draw** menu, choose **Ellipsoid**.
5. In the **Ellipsoid** dialog box, specify an ellipsoid with the **Length semiaxes** (1000, 200, 50) and the **Axis base point** (2500, 1500, 200). Click **OK**.
OPTIONS AND SETTINGS

1 From the Options menu, select Constants.
2 Enter the following constants; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>mur_magn</td>
<td>3.5</td>
<td>Magnetic permeability, magnetite</td>
</tr>
<tr>
<td>Mr_magn</td>
<td>60[A/m]</td>
<td>Remanent magnetization, magnetite</td>
</tr>
<tr>
<td>Incl</td>
<td>59.357[deg]</td>
<td>Magnetic inclination</td>
</tr>
<tr>
<td>Decl</td>
<td>12.275[deg]</td>
<td>Magnetic declination</td>
</tr>
<tr>
<td>B0</td>
<td>48163[nT]</td>
<td>Earth magnetic flux density</td>
</tr>
<tr>
<td>c_magn</td>
<td>0.25</td>
<td>Concentration of magnetite in ore</td>
</tr>
<tr>
<td>mur_ore</td>
<td>1+(mur_magn-1)*c_magn</td>
<td>Average permeability of ore</td>
</tr>
</tbody>
</table>

3 From the Options menu, select Expressions>Global Expressions.
4 Enter the following expressions; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>H0</td>
<td>B0/mu0_emnc</td>
<td>Average magnetic field of Earth</td>
</tr>
<tr>
<td>Br_magn</td>
<td>Mr_magn*mu0_emnc</td>
<td>Remanent magnetic flux, magnetite</td>
</tr>
<tr>
<td>Br_ore</td>
<td>Br_magn*c_magn</td>
<td>Averaged remanent flux, magnetite</td>
</tr>
</tbody>
</table>

5 From the Options menu, select Boundary Distance Variables.
6 In the Boundary Distance Variables dialog box, click New to create a Distance variable dist1. Make sure that only Boundaries 10–17 are selected in the Boundaries list.
7 Click OK to close the dialog box.

PHYSICS SETTINGS

Application Scalar Variables
1 To define the external magnetic field, choose Physics>Scalar Variables to open the Application Scalar Variables dialog box.
2 Verify that the external magnetic flux density is defined as follows (these should be the default settings):

<table>
<thead>
<tr>
<th>VARIABLE</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>extHx_emnc</td>
<td>H0*cos(Incl)*sin(Decl)</td>
</tr>
<tr>
<td>extHy_emnc</td>
<td>H0*cos(Incl)*cos(Decl)</td>
</tr>
<tr>
<td>extHz_emnc</td>
<td>-H0*sin(Incl)</td>
</tr>
</tbody>
</table>
3 Click **OK** to close the *Application Scalar Variables* dialog box.

**Subdomain Settings**

There are three subdomains.

1 From the *Physics* menu, choose *Subdomain Settings*.
2 Select Subdomain 3 (the iron ore bed).
3 From the $\mathbf{H} \leftrightarrow \mathbf{B}$ list, select $\mu_0 \mu_r \mathbf{H} + \mathbf{B}_r$ as the constitutive relation.
4 In the $\mu_r$ edit field, enter the relative permeability $\mu_{r\_ore}$.
5 In the $\mathbf{B}_r$ edit fields, enter the remanent flux density components $(\mathbf{B}_r\_ore*\cos(Incl)*\sin(Decl), \mathbf{B}_r\_ore*\cos(Incl)*\cos(Decl),$ and $-\mathbf{B}_r\_ore*\sin(Incl))$.

For Subdomains 1 and 2, keep the default material settings.
6 Click **OK** to close the *Subdomain Settings* dialog box.

**Boundary Conditions**

1 From the *Physics* menu, choose *Subdomain Settings*.
2 In the *Boundary selection* list, select Boundary 1 and then select the *Select by group* check box to select all exterior boundaries.
3 From the *Boundary condition* list, select *External magnetic flux density*. Note that this condition is different from *Magnetic insulation*, which operates on the total field.
4 Click **OK** to close the dialog box.

**Mesh Generation**

1 From the *Mesh* menu, open the *Free Mesh Parameters* dialog box.
2 On the *Boundary* page, select Boundaries 10–17. Set the *Mesh curvature factor* to 0.4 and the *Mesh curvature cutoff* to 0.01. This limits the maximum element size on the ellipsoid surface where the high curvature needs to be resolved.
3 Click **Remesh**.
4 When the mesher has finished, click **OK**.

**Computing the Solution**

Click the *Solve* button on the Main toolbar. This starts the analysis using the default solver, which is the Conjugate gradients solver, and the default preconditioner, Algebraic multigrid. The solution takes roughly 1 minute to compute.
**POSTPROCESSING AND VISUALIZATION**

The default plot shows a slice plot of the magnetic potential with 5 slices perpendicular to the x-axis. You can easily obtain more interesting plots.

**Boundary Plot of Elevation Data**

To display variables only on some boundaries, use the **Suppress>Boundaries** option from the **Options** menu.

1. Choose **Options>Suppress>Suppress Boundaries**.
2. Select Boundary 6.
3. Click **Apply** to suppress (hide) this boundary.
4. Click **Invert Suppression** to suppress all boundaries except number 6.
5. Click **OK**.

You can now display the elevation data on the formation using the available postprocessing functionality in COMSOL Multiphysics:

1. Click the **Plot Parameters** button on the Main toolbar.
2. On the **General** page, clear the **Slice** check box and select the **Boundary** check box in the **Plot type** area.
3. On the **Boundary** page, enter the **Expression** z, then click **OK**.
4. Double-click **EQUAL** on the status bar at the bottom of the user interface to switch off the equal scaling of the plot axes. Finally, click the **Zoom Extents** button on the Main toolbar to generate the plot in Figure 5-18 on page 347.

Continue to display the result plots:

1. Open the **Plot Parameters** dialog box again.
2. On the **General** page, select the **Slice** check box in the **Plot type** area, then click the **Slice** tab.
3. From the **Predefined quantities** list, select **Magnetostatics, No Currents (emnc)>Reduced magnetic field, norm**.
4. Set the numbers of **x levels** and **y levels** to 0.
5. For **z levels**, select **Vector with coordinates** and set the value to 1300.
6. Select **hot** as the **Colormap**.
7. Go to the **Boundary** page, enter the **Expression** normredH_emnc, and then click **OK** to generate Figure 5-19 on page 350.

Proceed as follows to generate Figure 5-20 on page 351.
Open the Plot Parameters dialog box.

On the General page, clear the Slice check box and select the Arrow check box in the Plot type area.

On the Arrow page, select to Plot arrows on: Boundaries. Set the x component to redHx_emnc, the y component to redHy_emnc, and the z component to redHz_emnc.

Set the Arrow type to 3D arrow, then click OK.

You need to rotate and zoom in on the resulting plot to exactly reproduce Figure 5-20 on page 351. The next figure is a pure boundary plot.

Open the Plot Parameters dialog box.

On the General page, clear the Arrow check box in the Plot type area.

Go to the Boundary page, enter the Expression dist1, and then click OK to generate Figure 5-21 on page 352.

The final plot is Figure 5-22 on page 353:

Open the Plot Parameters dialog box.

On the General page, clear the Boundary check box and select the Slice check box in the Plot type area.

Click the Slice tab. Enter the Expression normBr_emnc/(mu0_emnc*normM_emnc).

Set the numbers of x levels and y levels to 0.

For z levels, select Vector with coordinates and set the value to 200.

As the Colormap, select jet.

Click OK.
INDEX

3D electrostatics model 104
3D magnetostatics model 69, 144, 272
3D quasi-statics model 124, 245

A  AC coil 134
   adaptive solver 39
   adjoint sensitivity 18
   algebraic multigrid preconditioner 265, 280
   application mode
       Azimuthal Induction Currents, Vector Potential 136
       Magnetostatics 275, 354
       Magnetostatics, Vector Potential 148
   Perpendicular currents 10, 36
   Quasi-statics (3D) 245
   Small in-plane currents 255
   application modes
       Azimuthal Induction Currents, Vector Potential 116
       Electrostatics 106
       Magnetostatics, No Currents 25, 70
       Magnetostatics, Vector Potential 80
   arrow plot 120
   azimuthal currents
       model 113
       azimuthal currents model 19, 134

B  B-H curves 44
   bonding wires 183
   boundary integration 268, 271
   boundary plot 250

C  capacitance
   computing 104
   capacitor
       for MEMS applications 104
       cenforce 41
   coil 134
   coupling variable
       projection 249
       crucible 242
       curl elements 291

E  eddy currents 225
   forces 114
   model 113
   electromagnetic force 34
   electromagnetic forces 8, 267
   electrostatics model 104
   energy 10

F  force computation 17, 30, 41, 267, 271
   forward solution 18

G  generator 43, 57, 69

H  Helmholtz coil 124
   high current cables 192
   higher-order vector elements 157

I  impedance boundary condition 232
   impedance matrix 184
   impedance sensor 253
   inductance 136, 144, 157
   inductive heating 19
   interpolation function 69

K  Kirchhoff's power law 244

L  linear electric motors 34
   Lorentz force 76, 114

M  magnet brake 76
   magnetic forces 57
   magnetic iron 232
   magnetic material, nonlinear 44
   magnetic potential
       scalar 24, 260, 273
magnetic prospecting 345
magnetic shielding 274
magnetostatics model 8, 24, 34, 69, 144, 272
magnets 260
materials library 118
Maxwell stress tensor 9, 30, 267
mechanical dynamics 58
MEMS inductor 144
models, overview of 2
moment of inertia 58
motor, electric 34
moving geometry 43, 57

N  nonlinear permeability 44, 69

O  ohmic heating 19
one-sided magnet 260
ordinary differential equation 77, 89

P  parameterized geometry 10
particle tracing 285
periodic boundary conditions 58
permanent magnets 24, 43, 260
permeability, nonlinear 44, 69
perpendicular currents model 8, 34, 43, 57
plot
arrow 120
boundary 250
surface 258, 266
Poisson’s equation 104, 265
port boundary condition 184
power inductor 157
preconditioner
algebraic multigrid 265, 280
principle of virtual work 8

Q  quadrupole lens 283
quasi-statics model 124, 245
small currents 253

R  radio-frequency identification 322
railgun model 88
residual induction 35
resistive heating 19
resistive loss, computing 35
RF applications 104
RFID system 322
rotor 43

S  samarium cobalt magnet 43
scalar magnetic potential 24, 260, 273
self-inductance 144
sensitivity 10
sensitivity analysis 18
shielding boundary condition 274
skin depth 225, 243, 253
skin effect 134
sliding mesh 58
solver, adaptive 39
stress tensor
Maxwell 9, 30, 267
superconductivity 290
surface plot 258, 266
surface stress 9, 30, 267
symmetry 57

T  torque 57
transient analysis 120
typographical conventions 6

V  virtual work 8