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 1
I n t r o d u c t i o n
The Structural Mechanics Module Model Library consists of a set of models that 
simulate problems in various areas of structural mechanics and solid mechanics 
engineering. Their purpose is to assist you in learning, by example, how to model 
sophisticated structural elements and systems. Through them you can tap the 
expertise of the top researchers in the field, examining how they approach some of 
the most difficult modeling problems you might encounter. You can thus get a feel 
for the power that COMSOL Multiphysics offers as a modeling tool. In addition 
to serving as a reference, the models can also give you a big head start if you are 
developing a model of a similar nature. 

We have divided these models into application areas such as automotive 
applications, civil engineering, fluid-structure interaction, and piezoelectric effects. 
The models illustrate the use of the various structural-mechanics specific 
application modes from which we built them. These specialized application modes 
are not available in the base COMSOL Multiphysics package, and they come with 
their own graphical user interfaces that make it quick and easy to access their power. 
You can even modify them for custom requirements. COMSOL Multiphysics itself 
is very powerful and, with sufficient expertise in a given field, you certainly could 
develop these application modes by yourself—but why spend the hundreds or 
 1



2 |  C H A P T E R  
thousands of hours that would be necessary when our team of experts has already done 
the work for you?

Note that the model descriptions in this book do not contain details on how to carry 
out every step in the modeling process. Before tackling these in-depth models, we urge 
you to first read the second book in the Structural Mechanics Module documentation 
set. Titled the Structural Mechanics Module User’s Guide, it introduces you to the 
basic functionality in the module, reviews new features in the version 3.4 release, 
covers basic modeling techniques with tutorial and benchmark example models, and 
includes reference material of interest to those working in structural mechanics. A third 
book, the Structural Mechanics Module Reference Guide, contains reference material 
about command-line programming and functions. It is available in HTML and PDF 
format from the COMSOL Help Desk. For more information on how to work with 
the COMSOL Multiphysics graphical user interface, please refer to the COMSOL 
Multiphysics User’s Guide or the COMSOL Multiphysics Quick Start manual. An 
explanation on how to model with a programming language is available in yet another 
book, the COMSOL Multiphysics Scripting Guide. 

The book in your hands, the Structural Mechanics Module Model Library, provides 
details about a large number of ready-to-run models that illustrate real-world uses of 
the module. Each entry comes with theoretical background as well as instructions that 
illustrate how to set it up. They were written by our staff engineers who have years of 
experience in structural mechanics; they are your peers, using the language and 
terminology needed to get across the sophisticated concepts in these advanced topics.

Finally note that we supply these models as COMSOL Multiphysics model files so you 
can open them in COMSOL Multiphysics for immediate access, allowing you to follow 
along with these examples every step along the way.

Model Library Guide

The table below summarizes key information about the entries in this model library. 
The solution time is the elapsed time measured on a machine running Windows Vista 
with a 2.6 GHz AMD Athlon X2 Dual Core 500 CPU and 2 GB of RAM. For models 
with a sequential solution strategy, the Solution Time column shows the elapsed time 
for the longest solution step. The Application Mode column contains the application 
modes (such as Plane Stress) we used to solve the model. The following columns 
1 :  I N T R O D U C T I O N
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TRUCTURE 
N

of a disk 
an air-filled 

10 8 s Mindlin Plate, Acoustics √

tructure 22 2 min Solid, Stress-Strain; 
Acoustics

√

tic transducer 34 1 s Piezo Plane Strain; 
Acoustics

√

E 
NS

ine piston 46 2 min Solid, Stress-Strain; Heat 
Transfer by Conduction

√

polar plate 62 20 s Solid, Stress-Strain; Heat 
Transfer by Conduction

√

ar 82 8 s Plane Stress √ √

e wheel rim 108 13 min Solid, Stress-Strain √ √
 MODELS

ylinder 122 1 s Solid, Stress-Strain √

rmation beam 134 29 s Plane Stress √ √ √

142 6 s Solid, Stress-Strain √

e 152 1 s Plane Stress √

cylinder 161 2 s Plane Strain √

me 169 1 s In-Plane Euler Beam √

loaded beam 177 1 s 3D Euler Beam √

uss 186 1 s In-Plane Truss √

o roof 197 1 s Shell √
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BIOENGINEE
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Rotor
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RING

el 210 9 min Solid, Stress-Strain; 
Navier-Stokes

√ √

222 14 min Solid, Stress-Strain √

l stent 235 138 min Solid, Stress-Strain √ √ √
EERING

 bridge 246 4 s 3D Euler Beam, Shell √ √
ND FRICTION

ge 262 53 s Plane Stress √

oller contact 271 17 s Plane Strain √ √

ection 283 17 min Solid, Stress-Strain √ √

 fastener 297 38 min Solid, Stress-Strain √ √ √

unch 310 106 min Axial Symmetry 
Stress-Strain

√ √ √

ND VIBRATION

320 8 s Solid, Stress-Strain √

er 326 1 s Axial Symmetry 
Stress-Strain

√

lly excited 334 25 s Mindlin Plate √

fillet 346** 19 s Solid, Stress-Strain √ √

 cutout 357** 5 s Shell √ √

ith hole 372** 10 min Solid, Stress-Strain √ √ √

lysis of an 
 wheel rim

386** 30 min Solid, Stress-Strain √ √
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il 404 5 min Heat Transfer, Axial 
Symmetry Stress-Strain, 
Darcy’s Law

√

 fluid 417 11 min Solid, Stress-Strain; 
Incompressible 
Navier-Stokes; Moving 
Mesh (ALE)

√

 crack 426 1 s Plane Stress √
 MATERIAL 

tic plate 438 42 s Plane Stress √ √ √

c material 443 50 s Plane Strain, PDE √ √

ic seal 467 4 min Plane Strain √ √

induced creep 479 2 min Axial Symmetry 
Stress-Strain, PDE 

√

el 500 61 min Plane Strain √

d smooth 
g

516 43 s Plane Strain √ √ √

RIC EFFECTS

ic tube 528 1 s Piezo Axial Symmetry √

ctric shear 
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541 7 s Piezo Solid; Solid, 
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√

 piezoelectric 553 6 min Piezo Solid; Solid, 
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√ √
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Electric Currents***

√

ensor 582 11 s Piezo Plane Strain √
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ical effects in a 
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598 2 s Plane Strain, 
Perpendicular 
Hybrid-Mode Waves

√ √

ical effects 
alized plane 

615 7 s Plane Strain, 
Perpendicular 
Hybrid-Mode Waves

√ √

RUCTURAL 
N

resses in a 
te

634 1 s Plane Stress, Heat 
Transfer by Conduction

√

unt resistor 644 3 min General Heat Transfer; 
Solid, Stress-Strain

√ √

cuit 657 2 min Solid, Stress-Strain; 
General Heat Transfer; 
Thin Conductive Shell; 
Shell

√

t 3D 673 10 min General Heat Transfer; 
Solid, Stress-Strain; 
Shell, Conductive Media 
DC

√ √

xpansion in a 
ice using the 
brary

689 19 s Solid, Stress-Strain; Heat 
Transfer by Conduction

√

ration in a 
tructure

703 31 s Solid, Stress-Strain; Heat 
Transfer by Conduction

√ √

ODELS

t static 17* 1 s Plane Stress √

t eigen 28* 1 s Plane Stress √

t transient 32* 17 s Plane Stress √

t frequency 41* 22 s Plane Stress √
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* this page number refers to the Structural Mechanics Module User’s Guide.

** these models require COMSOL Script or MATLAB.

***this model requires the AC/DC Module.

We welcome any questions, comments, or suggestions you might have concerning 
these models. Contact us at info@comsol.com.

Typographical Conventions

All COMSOL manuals use a set of consistent typographical conventions that should 
make it easy for you to follow the discussion, realize what you can expect to see on the 
screen, and know which data you must enter into various data-entry fields. In 
particular, you should be aware of these conventions:

• A boldface font of the shown size and style indicates that the given word(s) appear 
exactly that way on the COMSOL graphical user interface (for toolbar buttons in 
the corresponding tooltip). For instance, we often refer to the Model Navigator, 
which is the window that appears when you start a new modeling session in 
COMSOL; the corresponding window on the screen has the title Model Navigator. 
As another example, the instructions might say to click the Multiphysics button, and 
the boldface font indicates that you can expect to see a button with that exact label 
on the COMSOL user interface.

• The names of other items on the graphical user interface that do not have direct 
labels contain a leading uppercase letter. For instance, we often refer to the Draw 
toolbar; this vertical bar containing many icons appears on the left side of the user 
interface during geometry modeling. However, nowhere on the screen will you see 

t parametric 48* 2 s Plane Stress √

t quasi-static 53* 6 s Plane Stress, Heat 
Transfer

√
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the term “Draw” referring to this toolbar (if it were on the screen, we would print 
it in this manual as the Draw menu).

• The symbol > indicates a menu item or an item in a folder in the Model Navigator. 
For example, Physics>Equation System>Subdomain Settings is equivalent to: On the 
Physics menu, point to Equation System and then click Subdomain Settings. 
COMSOL Multiphysics>Heat Transfer>Conduction means: Open the COMSOL 

Multiphysics folder, open the Heat Transfer folder, and select Conduction.

• A Code (monospace) font indicates keyboard entries in the user interface. You might 
see an instruction such as “Type 1.25 in the Current density edit field.” The 
monospace font also indicates COMSOL Script codes.

• An italic font indicates the introduction of important terminology. Expect to find 
an explanation in the same paragraph or in the Glossary. The names of books in the 
COMSOL documentation set also appear using an italic font.
1 :  I N T R O D U C T I O N
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A c o u s t i c - S t r u c t u r e  I n t e r a c t i o n
This chapter contains models of the interaction between acoustics and structures, 
often called acoustic-structure interaction.
 9
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V i b r a t i o n s  o f  a  D i s k  Ba c ked  b y  an 
A i r - F i l l e d  C y l i n d e r

Introduction

The vibration modes of a thin or thick circular disk are well known, and it is possible 
to compute the corresponding eigenfrequencies to arbitrary precision from a series 
solution. The same is true for the acoustic modes of an air-filled cylinder with perfectly 
rigid walls. A more interesting question to ask is: What happens if the cylinder is sealed 
in one end not by a rigid wall but by a thin disk? This is the question you address in 
this model.

Note: This model requires the Acoustics Module and the Structural Mechanics 
Module.

Model Definition

In COMSOL Multiphysics you can model an air-filled cylinder sealed by a thin disk in 
one end using at least two different approaches. You describe the pressure in the cavity 
with a Pressure Acoustics application mode, while the model of the disk can be either 
a thin shell in 3D, using shell elements, or a 2D plate. The latter approach to modeling 
this acoustic-structure interaction is possible thanks to nonlocal couplings and 
COMSOL Multiphysics’ ability to model in different numbers of space dimensions at 
the same time—extended multiphysics.

In Ref. 1, D. G. Gorman and others have thoroughly investigated the model at hand, 
and they have developed a semi-analytical solution verified by experiments and 
simulations. The geometry is a rigid steel cylinder with a height of 255 mm and a 
radius of 38 mm. One end is welded to a heavy slab, while the other is sealed with a 
steel disk only 0.38 mm thick. Some of the theoretical eigenfrequencies of a thin disk 
 2 :  A C O U S T I C - S T R U C T U R E  I N T E R A C T I O N



in vacuum and of a rigidly sealed chamber are given in the following table (according 
to Ref. 1).

Here you model the coupled system using the extended multiphysics approach. This 
means that you draw the disk in a 2D geometry and model it with Mindlin-theory 
DRM-plate elements, while you draw the cylinder in a separate 3D geometry. The 
acoustics in the cylinder is described in terms of the acoustic (differential) pressure. 
The eigenvalue equation for the pressure is

where  c is the speed of sound and ω = 2π f defines the eigenfrequency, f.

A first step is to calculate the eigenfrequencies for the disk and the cylinder separately 
and compare them with the theoretical values in Table 2-1. This way you can verify the 
basic components of the model and assess the accuracy of the FEM solution before 
modeling the coupled system.

Results and Discussion

Most of the modes show rather weak coupling between the structural bending of the 
disk and the pressure field in the cylinder. It is, however, interesting to note that some 
of the uncoupled modes have been split into one  co-vibrating and one contra-vibrating 
mode with distinct eigenfrequencies. This is the case for modes 1 and 2 and for modes 
9 and 12 in the FEM solution. The table below shows a comparison of the 
eigenfrequencies from the COMSOL Multiphysics analysis with the semi-analytical 
and experimental frequencies reported by D. G. Gorman and others in Ref. 1. The 

TABLE 2-1:  BENCHMARK VALUES FOR EIGENFREQUENCIES OF THE DISK AND THE CYLINDER

NUMBER CLAMPED DISK IN VACUUM (HZ) RIGIDLY SEALED CYLINDER (HZ)

1 671.8 672.5

2 1398 1345

3 2293 2018

4 2615 2645

5 3356 2690

6 4000 4387

∆ p–
ω2

c2
------ p=
V I B R A T I O N S  O F  A  D I S K  B A C K E D  B Y  A N  A I R - F I L L E D  C Y L I N D E R  |  11
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table also states whether the modes are structurally dominated (str), acoustically 
dominated (ac), or tightly coupled (str/ac).

As the table shows, the FEM solution is in good agreement with both the theoretical 
predictions and the experimentally measured values for the eigenfrequencies. As you 
might expect from the evaluation of the accuracies for the uncoupled problems, the 
precision is generally better for the acoustics-dominated modes.

Reference

1. D. G. Gorman, J. M. Reese, J. Horacek, and D. Dedouch: “Vibration analysis of a 
circular disk backed by a cylindrical cavity,” Proc. Instn. Mech. Engrs., vol. 215, Part 
C, 2001.

Model Library path: Structural_Mechanics_Module/Acoustic-
Structure_Interaction/coupled_vibration

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select 2D from the Space dimension list.

TABLE 2-2:  RESULTS FROM SEMI-ANALYTICAL AND COMSOL MULTIPHYSICS ANALYSES AND EXPERIMENTAL 
DATA

TYPE SEMI-ANALYTICAL (HZ) COMSOL MULTIPHYSICS (HZ) EXPERIMENTAL (HZ)

str/ac 636.9 637.2 630

str/ac 707.7 707.7 685

ac 1347 1347.4 1348

str 1394 1395.3 1376

ac 2018 2018.6 2040

str 2289 2293.1 2170

str/ac 2607 2612.1 2596

ac 2645 2646.3 –

str/ac 2697 2697.1 2689

ac 2730 2730.9 2756

ac 2968 2969.3 2971
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2 In the list of application modes, select 
Structural Mechanics Module>Mindlin Plate>Eigenfrequency analysis.

3 Click OK.

G E O M E T R Y  M O D E L I N G

The geometry of the disk is a solid circle. Its location does not really matter because 
you embed it in 3D using coupling variables, but the transformations is trivial if you 
center the disk at the origin:

1 Press the Shift key and click the Ellipse/Circle (Centered) button.

2 In the Circle dialog box, type 0.038 in the Radius edit field and click OK to create a 
circle of radius 0.038 m, centered at the origin.

3 Click the Zoom Extents button on the Main toolbar.

P H Y S I C S  S E T T I N G S

Boundary Conditions
The edges of the disk are welded to the cylinder and can therefore be described as 
rigidly clamped or fixed.

1 From the Physics menu, choose Boundary Settings.

2 Select one of the boundaries and then press Ctrl+A to select all boundaries.

3 Make sure that you have selected Tangent and normal coord. sys. (t,n) in the 
Coordinate system list.

4 Select Fixed in the Condition list.

5 Click OK.

Subdomain Settings—Material Properties
The steel disk has the following material properties (in the default SI units):

• Young’s modulus, E = 2.1·1011

• Poisson’s ratio, ν = 0.3

• Density, ρ = 7800

1 From the Physics menu, choose Subdomain Settings.

2 Select Subdomain 1.
V I B R A T I O N S  O F  A  D I S K  B A C K E D  B Y  A N  A I R - F I L L E D  C Y L I N D E R  |  13
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3 Enter material data according to the following table:

4 Click OK.

M E S H  G E N E R A T I O N

To obtain accurate values of the eigenfrequencies of the disk, you need a mesh that is 
finer than the one produced with the default settings.

1 Open the Free Mesh Parameters dialog box from the Mesh menu.

2 Click the Custom mesh size option button and type 0.002 in the Maximum element 

size edit field.

3 Click the Remesh button and then click OK.

C O M P U T I N G  T H E  S O L U T I O N

When solving for the eigenfrequencies of the disk in vacuum, only the frequency 
interval between 500 Hz and 3250 Hz is of interest. Start by searching for the 20 first 
eigenfrequencies (some of these are almost identical and come from double 
eigenvalues) and make the solver start its search around 500 Hz:

1 From the Solve menu, choose Solver Parameters.

2 Type 20 in the Desired number of eigenfrequencies edit field.

3 Type 500 in the Search for eigenfrequencies around edit field.

4 Click OK.

5 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Click the 3D Surface Plot button to see the deflection of the disk.

2 From the Postprocessing menu, choose Plot Parameters.

3 Try looking at some of the eigenmodes by selecting the corresponding 
eigenfrequencies on the General page of the Plot Parameters dialog box. To do so, 
open the Plot Parameters dialog box from the Postprocessing menu. On the General 

MATERIAL PROPERTY VALUE

E 2.1e11

ν 0.3

ρ 7800

thickness 0.00038
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page, choose the eigenfrequencies from the Eigenfrequency list in the Solution to use 
area.

Figure 2-1: The eigenmode associated with the eigenfrequency around 3356 Hz.

You can now compare the eigenfrequencies with the theoretical values for a thin disk. 
The discrepancy is below 2% for all eigenmodes in the interval, so the conclusion is that 
the mesh resolution is sufficient.

Adding the 3D Pressure Acoustics Application Mode

Now add a second geometry that will contain the cylinder and the acoustic pressure 
variable using a 3D Pressure Acoustics application mode. 

1 From the Multiphysics menu, choose Model Navigator.

2 Click the Add Geometry button to add a second geometry.

3 In the Add Geometry dialog box, select 3D from the Space dimension list.

4 Click OK.

5 In the list of application modes, select 
Acoustics Module>Pressure Acoustics>Eigenfrequency analysis.

6 Click Add.
V I B R A T I O N S  O F  A  D I S K  B A C K E D  B Y  A N  A I R - F I L L E D  C Y L I N D E R  |  15
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7 Click OK.

G E O M E T R Y  M O D E L I N G

1 Click the Cylinder toolbar button. 

2 Type 0.038 in the Radius edit field and 0.255 in the Height edit field.

3 Click OK.

4 Click the Zoom Extents button on the Main toolbar.

P H Y S I C S  S E T T I N G S

Boundary Conditions
For the moment, assume that all boundaries are perfect hard walls, which is the default 
boundary condition.

Subdomain Settings
1 From the Physics menu, choose Subdomain Settings.

2 Select Subdomain 1.

3 Type 1.2 in the Fluid density (ρ0) edit field. Leave the other properties at their 
default value.

4 Click OK.

M E S H  G E N E R A T I O N

Click the Initialize Mesh button to create a mesh using the default parameters.

C O M P U T I N G  T H E  S O L U T I O N

To solve for the acoustic modes only, you must deactivate the Mindlin Plate application 
mode during the solution. If the plate is not deactivated, COMSOL Multiphysics 
solves the two eigenvalue problems simultaneously but independently of one another.

1 From the Solve menu, choose Solver Manager.

2 Click the Solve For tab.

3 Ctrl-click on the Mindlin Plate (smdrm) folder to clear that application mode’s 
variables from the list of variables to solve for, then click OK.

4 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Clear the Slice check box and select the Isosurface check box on the General page of 
the Plot Parameters dialog box.
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2 In the Solution to use area select one of the solutions near 2730 Hz from the 
Eigenfrequency list.

3 Click the Isosurface tab, and type 10 in the edit field for isosurface levels under 
Number of levels. From the Colormap list select cool, then click Apply.

4 Click the Headlight button on the Camera toolbar.

5 Try some of the different eigenfrequencies by selecting the corresponding 
eigenfrequencies on the General page of the Plot Parameters dialog box.

You can also compare these eigenfrequencies with the theoretical values in Table 2-2 
on page 12. This time, the relative error seems to be much smaller than for the disk, 
which means that any additional mesh refinement should be done on the plate part.

Coupling the Equations

The first step in the process of coupling the Mindlin plate elements to the acoustic 
equation is to create the nonlocal couplings; use coupling variables to make the 
pressure available as a load on the plate and the out-of-plane displacement of the plate 
a valid parameter in the coefficients for the acoustic equation.
V I B R A T I O N S  O F  A  D I S K  B A C K E D  B Y  A N  A I R - F I L L E D  C Y L I N D E R  |  17
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O P T I O N S  A N D  S E T T I N G S — C O U P L I N G  V A R I A B L E S

First define a coupling variable for the acoustic pressure from the top face of the 
cylinder to the disk (Mindlin plate):

1 On the Options menu, point to Extrusion Coupling Variables and then click Boundary 

Variables.

2 In the Boundary Extrusion Variables dialog box, select Boundary 4 (the top face) of 
the cylinder.

3 Type p in the top row under both Name and Expression.

4 Click the Destination tab.

5 Select Geom1 in the Geometry list, then select Subdomain 1 (the disk) in the 2D 
geometry.

6 Click the Source Vertices tab.

7 In the Vertex selection list, select Vertices 2, 4, and 8. Click the >> button.

8 Click the Destination Vertices tab.

9 In the Vertex selection list, select Vertices 1, 2, and 4. Click the >> button.

10 Click OK.

Now define a coupling variable for the out-of-plane displacement, w, from the disk to 
the top face of the cylinder. Also the acceleration, wtt, is needed.

1 If you are in the Pressure Acoustics application mode, switch to the Mindlin Plate 
application mode by choosing Geom1: Mindlin Plate (smdrm) from the Multiphysics 
menu.

2 On the Options menu, point to Extrusion Coupling Variables and then click Subdomain 

Variables.

3 In the Subdomain Extrusion Variables dialog box, select Subdomain 1.

4 Type w in the top row under both Name and Expression. Type wtt in the second row 
under both Name and Expression.

5 Click the Destination tab.

6 Select w from the Variable list.

7 Select Geom2 in the Geometry list, then select the check box next to Boundary 4.

8 Click the Source Vertices tab.

9 In the Vertex selection list, select Vertices 1, 2, and 4. Click the >> button.

10 Click the Destination Vertices tab.

11 In the Vertex selection list, select Vertices 2, 4, and 8. Click the >> button.
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12 Click the Destination tab.

13 Select wtt from the Variable list.

14 Select Geom2 in the Geometry list, then select he check box next to Boundary 4.

15 Click the Source Vertices tab.

16 In the Vertex selection list, select Vertices 1, 2, and 4. Click the >> button.

17 Click the Destination Vertices tab.

18 In the Vertex selection list, select Vertices 2, 4, and 8. Click the >> button.

19 Click OK.

P H Y S I C S  S E T T I N G S

Boundary Conditions
The sound-hard boundary condition for a rigid wall is that the normal acceleration 
vanishes. For a moving wall, such as the thin disk that now seals the cylinder, the 
appropriate condition is instead

where a is the normal acceleration of the wall.

1 If you are in the Mindlin Plate application mode, switch to the Pressure Acoustics 
application mode by choosing Geom2: Pressure Acoustics (acpr) from the Multiphysics 
menu.

2 On the Physics menu, point to Boundary Settings.

3 Select the top of the cylinder where the plate is located, that is, Boundary 4.

4 Select Normal acceleration from the Boundary condition list.

5 Type -wtt (the structural acceleration in the negative z direction) in the Inward 

acceleration (an) field and click OK.

Subdomain Settings
The coupling in the other direction is described by the acoustic pressure acting as a 
normal load.

1 Choose the Geom1: Mindlin Plate (smdrm) application mode from the Multiphysics 
menu.

2 Open the Subdomain Settings dialog box.

3 Click the Load tab. 

n ∇p⋅
ρa

---------------- a–=
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4 Select Subdomain 1.

5 Type p in the Fz edit field as a surface load on the disk.

6 Click OK.

7 Switch back to the 3D geometry by choosing Geom2: Pressure Acoustics (acpr) from 
the Multiphysics menu.

C O M P U T I N G  T H E  S O L U T I O N

1 From the Solve menu, choose Solver Manager.

2 In the Solver Manager dialog box, click the Solve For tab.

3 Reactivate the Mindlin Plate application mode by selecting both Geom1(2D) and 
Geom2(3D) and all corresponding variables in the Solve for list.

4 Click the Solve button to compute the solution. When done, click OK.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Open the Plot Parameters dialog box.

2 Add boundary and deformed shape plots in addition to the isosurface plot by 
selecting the Boundary and Deformed shape check boxes.

3 Click the Boundary tab.

4 Type lambda^2*w in the Expression edit field in the Boundary data area, that is, the 
normal acceleration of the disk. On the other boundaries w is not defined so those 
boundaries are invisible.

5 Click the Deform tab and select the Boundary check box only in the Domain types to 

deform area.

6 In the Deformation data area, click the Boundary Data tab and type 0, 0, and w in the 
x component, y component, and z component edit field, respectively.
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7 To examine the different eigenmodes, click the General tab and select an 
eigenfrequency from the Eigenfrequency list. Click Apply to plot the solution.
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A c ou s t i c - S t r u c t u r e  I n t e r a c t i o n

Introduction

Liquid or gas acoustics coupled to structural objects such as membranes, plates, or 
solids represents an important application area in many engineering fields. Some 
examples include:

• Loudspeakers

• Acoustic sensors

• Nondestructive impedance testing

• Medical ultrasound diagnostics of the human body

Model Definition

This model provides a general demonstration of an acoustic fluid phenomenon in 3D 
that is coupled to a solid object. The object’s walls are impacted by the acoustic 
pressure. The model calculates the frequency response from the solid and then feeds 
this information back to the acoustics domain so that it can analyze the wave pattern. 
As such, the model becomes a good example of a scattering problem.

Figure 2-2: Geometric setup of an aluminum cylinder immersed in water.

Water acoustics domain

3D solid stress-strain domain

Incident plane wave

Scattered wave
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Figure 2-2 illustrates an aluminum cylinder immersed in water. The incident wave is 
60 kHz, in the ultrasound region. The cylinder is 2 cm high and has a diameter of 1 
cm. The water acoustic domain is truncated as a sphere with a reasonably large 
diameter. What drives the system is an incident plane wave from the surroundings into 
the spherical boundary. The harmonic acoustic pressure in the water on the surface of 
the cylinder acts as a boundary load in the 3D solid to ensure continuity in pressure. 
The model calculates harmonic displacements and stresses in the solid cylinder, and it 
then uses the normal acceleration of the solid surface in the acoustics domain boundary 
to ensure continuity in acceleration.

D O M A I N  E Q U A T I O N S

Water Subdomain
For harmonic sound waves we use the frequency-domain Helmholtz equation for 
sound pressure

where the acoustic pressure is a harmonic quantity, , and p is the pressure 
(N/m2), ρ0 is the density (kg/m3), q is an optional dipole source (m/s2), ω is the 
angular frequency (rad/s), and c is the speed of sound (m/s).

Solid Subdomain
In the solid cylinder you calculate the harmonic stresses and strains using a frequency 
response analysis in the 3D Solid, Stress-Strain application mode. The material data 
comes from the built-in database for Aluminum 3003-H18.

B O U N D A R Y  C O N D I T I O N S

Outer Perimeter
On the outer spherical perimeter of the water domain (Figure 2-2) we specify an 
incident plane wave to represent an incoming sound wave. A superimposed spherical 
wave is allowed to travel out of the system as a response from the cylinder. In 

TABLE 2-3:  ACOUSTICS DOMAIN DATA

QUANTITY VALUE DESCRIPTION

ρ0 997 kg/m3 Density

c 1500 m/s Speed of sound

f=ω/2π 60 kHz Frequency

∇ 1
ρ0
------– ∇p q+⎝ ⎠

⎛ ⎞⋅ ω2p

ρ0c2
-----------– 0=

p p0eiωt=
A C O U S T I C - S T R U C T U R E  I N T E R A C T I O N  |  23



24 |  C H A P T E R
COMSOL Multiphysics’ Acoustics application mode you implement this scenario by 
using the prepared Radiation condition with the Spherical wave option. The 
radiation boundary condition is useful when the surroundings are only a continuation 
of the domain.

The incident wave direction is controlled by the two angles 0 < θ < 2π and 0 <  < π.

For mathematical details on the radiation boundary condition, see the section 
“Radiation Boundary Conditions” on page 26 of the COMSOL Multiphysics 
Modeling Guide.

Interface Cylinder-Water
To couple the sound-pressure wave to the solid cylinder, set the boundary load F 
(force/unit area) on the solid cylinder to

where ns is the outward-pointing unit normal vector seen from inside the solid 
domain.

To couple back the frequency response of the solid to the acoustics problem, use a 
normal acceleration boundary condition

where na is the outward-pointing unit normal vector seen from inside the acoustics 
domain. Also set the normal acceleration an to ( na ·  u )  ω2, where u is the calculated 
harmonic-displacement vector of the solid structure.

H A R D - WA L L  C O M P A R I S O N

As a reference we also study a simpler model where the solid interface is regarded as a 
hard wall. In this model we turn off the structural analysis of the cylinder, and we set 
the cylinder surface to an acoustic hard wall with the boundary condition

.

TABLE 2-4:  RADIATION BOUNDARY CONDITION SETTINGS

QUANTITY VALUE DESCRIPTION

Incident wave direction vector

p0 1 Pa Pressure amplitude

k̂ θ ϕcossin θ ϕsinsin θcos, ,( )

ϕ

F ns– p=

na–
1
ρ0
------∇p– q+⎝ ⎠

⎛ ⎞⋅ an=

na
1
ρ0
------∇p– q+⎝ ⎠

⎛ ⎞⋅ 0=
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Results and Discussion

Figure 2-3: Sound-pressure plot (dB) of the acoustic waves in the coupled problem. The cone 
lengths are proportional to the surface acceleration, which is a direct measure of the sound-
pressure interaction between the water and the cylinder.
A C O U S T I C - S T R U C T U R E  I N T E R A C T I O N  |  25



26 |  C H A P T E R
Figure 2-3 displays the sound pressure as a slice plot. It is clear from which direction 
the sound wave propagates into the domain. The values of the deformation are very 
small, but the acceleration is enough to have an impact on the sound waves.

Figure 2-4: Sound pressure level on impact and on the shadow side of the cylinder.

Figure 2-4 shows a comparison between the hard-wall example and the full aluminum 
solid model. Near the cylinder wall the plot shows that the sound pressure level is 
higher on the upstream side for the hard-wall case than for the aluminum model. 
Inversely, the amplitude is lower for the hard-wall model than for the aluminum model 
on the downstream side. This shows that the hard wall reflects more and transmits less 
energy than the aluminum cylinder. The conclusion is that the mechanical properties 
of the metal object have an impact on the acoustic signature.

Modeling in COMSOL Multiphysics

COMSOL Multiphysics provides specialized direct solvers for symmetric systems. You 
can employ such solvers for problems that generate symmetric stiffness matrices and 
thereby save a considerable amount of system memory and shorten the calculation 
time.

Propagation direction

Aluminum cylinder

Hard cylinder
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Model Library path: Structural_Mechanics_Module/Acoustic-
Structure_Interaction/acoustic_structure

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics.

2 In the Model Navigator, select 3D from the Space dimension list, then select Structural 

Mechanics Module>Solid, Stress-Strain>Frequency response analysis in the list of 
application modes.

3 Type u v w psolid in the Dependent variables edit field.

4 Click the Multiphysics button, then click Add.

5 Select COMSOL Multiphysics>Acoustics>Acoustics in the list of application modes, click 
the Add button, then click OK.
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O P T I O N S  A N D  S E T T I N G S

1 Open the Constants dialog box from the Options menu and enter the following 
values (the descriptions are optional):

2 Click OK.

3 Choose the Physics>Scalar Variables menu item. Enter the items from the following 
table.

4 Click OK.

G E O M E T R Y  M O D E L I N G

1 Click the Cylinder button on the left toolbar. In the dialog box that appears specify 
the following values:

and let all other entries retain their default values. Click OK, then click the Zoom 

Extents button on the main toolbar.

NAME EXPRESSION DESCRIPTION

Freq 60[kHz] Frequency

phi (-pi/6)[rad] Wave direction angle, phi

theta (4*pi/6)[rad] Wave direction angle, theta

rhow 997[kg/m^3] Density

cw 1500[m/s] Speed of sound

k1 sin(theta)*cos(phi) Incident wave direction vector, 
x component

k2 sin(theta)*sin(phi) Incident wave direction vector, 
y component

k3 cos(theta) Incident wave direction vector, 
z component

NAME EXPRESSION DESCRIPTION UNIT

freq_smsld Freq Excitation frequency Hz

freq_aco Freq Excitation frequency Hz

p_ref_aco 20e-6 Pressure reference Pa

Radius 0.005

Height 0.02

Axis base point, z -0.01
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2 Click the Sphere button on the left toolbar. In the dialog box that appears specify a 
Radius of 0.03 and let the other entries retain their default values. Click OK, then 
click the Zoom Extents button on the Main toolbar.

P H Y S I C S  S E T T I N G S — H A R D - WA L L  C A S E

Subdomain Settings
1 Select the Multiphysics menu and Solid, Stress-Strain (smsld).

2 Select the Subdomain Settings on the Physics menu. Select all subdomains by 
selecting one subdomain, and then pressing Ctrl+A. Clear the Active in this domain 
check box, then click OK.

3 Select the Multiphysics item menu and then select Acoustics (aco).

4 Select the Physics>Subdomain Settings menu, then select Subdomain 2, and finally 
clear the Active in this domain check box. 

5 Select Subdomain 1 and enter the following data:

6 Click OK.

Boundary Conditions
1 Select the menu item Physics>Boundary Settings. Hold down the Ctrl key and select 

Boundaries 1–4, 9, 10, 12, and 13. Select the boundary condition Radiation 

condition with Wave type: Spherical wave. Fill out the dialog box with values from 
the following table:

2 Leave the remainder of the boundaries at their default value Sound hard boundary 

(wall).

3 Click OK.

QUANTITY VALUE/EXPRESSION

ρ0 rhow

cs cw

q 0 0 0

QUANTITY VALUE/EXPRESSION

p0 1

x0 0

y0 0

z0 0

nk k1 k2 k3
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G E N E R A T I N G  T H E  M E S H

1 Select the Mesh>Free Mesh Parameters menu item. On the Global page select Coarse 
from the Predefined mesh sizes list.

2 Go to the Subdomain page and set the Maximum element size to 0.005 for 
Subdomain 1 and to 0.003 for Subdomain 2. Click Remesh, then click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button.

2 Select Stationary in the Solver list.

3 Click OK.

4 Click the Solve button on the Main toolbar.

Postprocessing
To render the hard-wall line in Figure 2-4 on page 26 follow these steps:

1 Select the menu item Postprocessing>Cross-Section Plot Parameters.

2 On the General page click the Line/Extrusion plot option button, then select the Keep 

current plot check box. 

3 Go to the Line/Extrusion page and click the Line plot option button.

4 From the Predefined quantities list select Acoustics (aco)>Sound pressure level.

5 Define the line through the origin that coincides with the incident-wave 
propagation vector . You can conveniently take the vector components from the 
Value column for the constants k1, k2, and k3 in the Constants list in the Options 
menu.

6 Click OK.

7 Leave this figure window open in the background during the next stage of the 
solution.

P H Y S I C S  S E T T I N G S — C O U P L E D  A C O U S T I C S - S O L I D

Subdomain Settings
1 Select the Multiphysics menu, then select Solid, Stress-Strain (smsld).

x0, x1 0.03*(-.75) 0.03*.75

y0, y1 0.03*.433013 0.03*(-.433013)

z0, z1 0.03*.5 0.03*(-.5)

k̂
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2 Choose Physics>Subdomain Settings. Select Subdomain 2, then select the Active in 

this domain check box.

3 Click Load and select Aluminum 3003-H18 from the Basic Material Properties list. Click 
OK.

4 Click the Damping tab. Select No damping from the Damping model list.

5 Click OK.

Boundary Conditions
1 Select the menu item Physics>Boundary Settings. Select Boundaries 5–8, 11, and 14, 

then go to the Load page. Specify Fx: -p*nx_smsld, Fy: -p*ny_smsld, and Fz: -
p*nz_smsld, then click OK.

p is the dependent variable for the pressure, and nx_smsld, ny_smsld, and 
nz_smsld represent the outward unit normal pointing out from the structural 
domain.

2 Select the Multiphysics menu and then select Acoustics (aco).

3 Select the menu item Physics>Boundary Settings. Select the Select by group check 
box. Select Boundary 5 to get a group selection of all the hard-wall boundaries.

4 Set the boundary condition to Normal acceleration, then specify an as 
nx_smsld*u_tt_smsld+ny_smsld*v_tt_smsld+nz_smsld*w_tt_smsld. Click 
OK.

Here, u_tt_smsld, v_tt_smsld, and w_tt_smsld are the structural acceleration 
components in the x, y, and z directions, respectively, so the expression that you 
enter corresponds to an = n·utt.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar to start the analysis.

Postprocessing
To overlay the sound pressure of the coupled problem on the hard-wall problem in 
Figure 2-4 on page 26 follow these steps:

1 Choose Postprocessing>Cross-Section Plot Parameters.

2 On the General page click the Line/Extrusion plot option button. Click OK.

To generate Figure 2-3 on page 25, do as follows:

1 Choose Options>Suppress>Suppress Boundaries.

2 Select Boundaries 1, 2, 9, and 10 from the list. Click OK.
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3 Click the Plot Parameters button. On the General page, select the check boxes for 
Slice, Boundary, Arrow, and Deformed shape. Leave all the other check boxes 
unchecked.

4 Clear the Element refinement: Auto check box, then type 7 in the Refinement edit 
field.

5 Click the Slice page, then select Acoustics (aco)>Sound pressure level from the 
Predefined quantities list. In the Slice positioning area type 0 in all three Number of 

levels edit fields. On the y-levels line click Vector with coordinates and type 0.005 in 
the y-levels position.

6 Go to the Boundary page and from the Predefined quantities list select Solid, Stress-

Strain (smsld)>Total displacement. Use Colormap: cool.

7 Go to the Arrow page.

8 Select Boundaries from the Plot arrows on list.

9 Click the Boundary Data tab, then select Acceleration from the Predefined quantities 
list.

10 In the Arrow parameters area, select Cone from the Arrow type list and set the Arrow 

length to Proportional. Clear the Scale factor: Auto check box, then enter 0.6 as the 
scale factor.
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11 Click the Deform tab.

12 Go to the Domain types to deform area and make sure that only the Boundary check 
box is selected.

13 Clear the Scale factor: Auto check box, then type 3.8e9 in the associated edit field.

14 Click OK.

To refine the image’s visual quality do as follows:

1 Click both the Headlight and Scene Light buttons on the Camera toolbar.

2 Select the menu item Options>Visualization/Selection Settings.

3 Go to the Camera page and select Projection: Perspective.

4 Go to the Lighting page. In the Scene light area, click all four light sources and clear 
the Enabled check box on each of them. 

5 Click the New button. Select Type: Spot, then click OK.

6 Specify the light source as in the following table, then click OK.

You can experiment with the view angle by clicking the Zoom and Dolly In/Out buttons 
on the Plot toolbar and clicking and dragging the geometry.

PROPERTY VALUE

Position -0.01 -0.01 0

Direction 0 1 0

Spread angle 90

Concentration 0.05
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P i e z o a c ou s t i c  T r a n s du c e r

Introduction

A piezoelectric transducer can be used either to transform an electric current to an 
acoustic pressure field or, the opposite, to produce an electric current from an acoustic 
field. These devices are generally useful for applications that require the generation of 
sound in air and liquids. Examples of such applications include phased array 
microphones, ultrasound equipment, inkjet droplet actuators, drug discovery, sonar 
transducers, bioimaging, and acousto-biotherapeutics.

Model Definition

In a phased-array microphone, the piezoelectric crystal plate fits into the structure 
through a series of stacked layers that are divided into rows. The space between these 
layers is referred to as the kerf , and the rows are repeated with a periodicity, or pitch.

This model simulates a single crystal plate in such a structure. The element is 
rotationally symmetric, making it possible to use an axisymmetric 2D application mode 
in COMSOL Multiphysics.
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Figure 2-5: The model geometry.

In the air domain, the wave equation describes the pressure distribution:

 (2-1)

For this model, assume that the pressure varies harmonically in time as

Hence equation 2-1 simplifies to

 (2-2)

Because there are no sources present, Equation 2-2 simplifies further to

1

ρ0 cs
2

--------------
t2

2

∂
∂ p ∇ 1

ρ0
------– ∇p q–( )⎝ ⎠

⎛ ⎞⋅+ Q=

p x t,( ) p x( ) eiωt
=

∇ 1
ρ0
------– ∇p q–( )⎝ ⎠

⎛ ⎞⋅ ω2p

ρ0 cs
2

--------------– Q=

∇ 1
ρ0
------– ∇p( )⎝ ⎠

⎛ ⎞⋅ ω2p

ρ0 cs
2

--------------– 0=
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The piezoelectric domain is made of the crystal PZT5-H, which is a common material 
in piezoelectric transducers. The structural analysis is also time harmonic although, for 
historical reasons, in structural-mechanics terminology it is a frequency response 
analysis.

The frequency is set to 300 kHz, which is in the ultrasonic range (dolphins and bats, 
for example, communicate in the range of 20 Hz to 150 kHz, while humans can only 
hear frequencies in the range 20 Hz to 20 kHz).

B O U N D A R Y  C O N D I T I O N S

A voltage of 100 V is applied to the upper part of the transducer, while the bottom 
part is grounded. At the interface between the air and solid domain, the boundary 
condition for the acoustics application mode is that the pressure is equal to the normal 
acceleration of the solid domain

where an is the normal acceleration.

This drives the pressure in the air domain. The solid domain is on the other hand 
subjected to the acoustic pressure changes in the air domain. Because of the high 
voltage applied to the transducer, this load is probably negligible in comparison. Yet 
because the model is in 2D, it is possible to include this load solve the full model 
simultaneously on any computer.

Results and Discussion

Figure 2-6 shows the pressure distribution in the air domain. This plot clearly shows 
how the PML (perfectly matched layer) absorbs the wave effectively.

n 1
ρ0
------ ∇p( )⎝ ⎠
⎛ ⎞⋅ an=
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Figure 2-6: Surface and height plot of the pressure distribution.

Figure 2-7 shows the pressure distribution along the air-solid interface. The acoustic 
pressure load is small in comparison to the electrical load, which is plotted in Figure 2-
8 on page 38.
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Figure 2-7: Acoustic pressure at the air-solid interface.

Figure 2-8: von Mises Stress along the air-solid interface.

The results from a far-field analysis appear in Figure 2-9 on page 39. This figure shows 
that the sound pressure level reaches a maximum right in front of the transducer. This 
result also shows that the sound pressure level is fairly low. Although humans cannot 
here this high frequencies, it can be mentioned for comparison that 15 dB is about the 
same sound pressure level as rustling leaves. On the other hand, because this is just one 
element in an array of elements, a more detailed study is necessary in order to draw 
further conclusions.
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Figure 2-9: The far-field sound pressure level.

Model Library path: Structural Mechanics Module/Acoustic-Structure 
Interaction/piezoacoustic_transducer

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 In the Model Navigator, begin by selecting Axial symmetry (2D) from the Space 

dimension list, then click the Multiphysics button.

2 Navigate to Structural Mechanics Module>Piezoelectric Effects>Piezo Axial 

Symmetry>Frequency Response Analysis, then click Add.

3 Select Acoustics Module>Pressure Acoustics>Time-harmonic analysis; then click Add.

4 Click OK to close the Model Navigator.

S C A L A R  V A R I A B L E S

1 From the Physics menu, select Scalar Variables.

2 Select the Synchronize equivalent variables check box.

3 Enter a value of 200e3 Hz for the excitation frequency freq_smpaxi.

COMSOL Multiphysics automatically updates the other excitation frequency, 
 freq_acpr, to the same value.
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4 Click OK.

G E O M E T R Y  M O D E L I N G

1 Draw a rectangle, R1, by first selecting Draw>Specify Objects>Rectangle and then 
specifying the following properties; when done, click OK.

2 Click the Zoom Extents button on the Main toolbar to automatically fit the geometry 
to your window.

The geometry for the transducer is now complete. Continue by creating the 
acoustics domain, which consists of two domains: one air domain and one PML 
domain.

3 Choose Draw>Specify Objects>Circle. Specify a Radius of 4e-3, then click OK.

4 Choose Draw>Specify Objects>Square. Specify a Width of 4e-3, then click OK.

5 Click the Zoom Extents button on the Main toolbar.

6 Select the circle and the square, then click the Intersection button on the Draw 
toolbar.

7 Select the geometry object CO1. Press Ctrl+C to copy it, then paste the copy at the 
same location by pressing Ctrl+V.

8 Select the geometry object CO2, then click the Scale button. In the Scale factor area, 
type 1.5 in both the r and the z edit field. (You can select the geometry objects from 
a list in the Create Composite Objects dialog box.)

9 Once again, click the Zoom Extents button on the Main toolbar to automatically fit 
the geometry to your window.

S U B D O M A I N  S E T T I N G S — P I E Z O  A X I A L  S Y M M E T R Y

1 Select the Piezo Axial Symmetry (smpaxi) application mode from the Model Tree or 
from the Multiphysics menu.

2 From the Physics menu, choose Subdomain Settings.

3 Select Subdomains 2 and 3, then clear the Active in this domain check box.

PROPERTY VALUE

Width 1e-3

Height 0.5e-3

Position, base Corner

Position, r 0

Position, z -0.5e-3
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4 Select Subdomain 1, then click the Load button.

5 From the Basic Material Properties library, select Lead Zirconate Titanate (PZT-5H).

In the Piezoelectric Material Properties library, you find more than 20 additional 
piezoelectric materials.

6 Click OK to close the Materials/Coefficients Library dialog box.

Note: For a piezoelectric material, you can specify an orientation and a coordinate 
system. In this model, use the default settings: the xz-plane in the global coordinate 
system.

7 Click OK to close the Subdomain Settings dialog box.

B O U N D A R Y  C O N D I T I O N S — P I E Z O  A X I A L  S Y M M E T R Y

1 From the Physics menu, choose Boundary Settings.

2 On the Constraint page, enter the following structural boundary conditions:

3 Click the Electric BC tab, and set the electric boundary condition as follows:.

4 Select Boundary 4.

5 On the Load page, type -p in the Fz edit field to specify the acoustic pressure load. 
p is the name of the dependent variable for pressure in the Pressure Acoustics 
application mode. The pressure acts from the air toward the piezo domain (in the 
negative z direction), which explains the minus sign in front of p.

S U B D O M A I N  S E T T I N G S — P R E S S U R E  A C O U S T I C S

1 Select the Pressure Acoustics (acpr) application mode from the Model Tree or from 
the Multiphysics menu.

2 From the Physics menu, select Subdomain Settings.

3 Select Subdomain 1, then clear the Active in this domain check box.

4 Select Subdomain 3.

SETTINGS BOUNDARY 1 BOUNDARY 2

Condition Symmetry Plane Roller

SETTINGS BOUNDARY 1 BOUNDARY 2 BOUNDARY 4 BOUNDARY 6

Type Axial symmetry Ground Electric potential Zero charge/Symmetry

V0 100
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5 On the PML page, select Spherical from the Type of PML list.

6 Select the Absorbing in radial dir. check box, then enter a value of 2e-3. This value 
corresponds to the PML’s extension in the radial direction.

7 Set the inner PML radius, R0, to 4e-3.

8 Click OK to close the dialog box.

Because the default values correspond to the properties of air, you do not have to 
specify the subdomain settings for Subdomain 2.

B O U N D A R Y  C O N D I T I O N S — P R E S S U R E  A C O U S T I C S

1 From the Physics menu, choose Boundary Settings.

2 Select Boundary 4, then select Normal acceleration as the boundary condition.

3 Set the value of the inward acceleration, an, to w_tt_smpaxi (this is the second-
order time derivative of the structural displacement).

4 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, choose Free Mesh Parameters.

2 On the Global page, click the Custom mesh size option button.

3 Specify a Maximum element size of (343/200e3)/5. This value corresponds to 1/
5th of the acoustic wavelength. For wave models it is important to use a mesh size 
sufficiently small to properly resolve the wavelength. 

4 Click Remesh. When the mesher has finished, click OK to close the dialog box.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 From the Solver list, select Stationary.

3 Click OK to close the dialog box.

4 Click the Solve button from the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To create figure 2-6, proceed as follows:

1 Click the Plot Parameters button on the Main toolbar.

2 Click the Surface tab.

3 On the Surface Data page, select Pressure Acoustics (acpr)>Pressure from the 
Predefined quantities list .
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4 On the Height Data page, select the Height data check box.

5 From the Predefined quantities list, select Pressure Acoustics (acpr)>Pressure.

6 Click OK to generate the plot.

7 Click the Headlight button on the Camera toolbar for clearer visualization.

To create Figure 2-7 and Figure 2-8 do the following:

1 Open the Domain Plot Parameters dialog box from the Postprocessing menu.

2 Go to the Line/Extrusion page.

3 In the Expression edit field, enter p.

4 From the Boundary selection list, select boundary 4 and then click on Apply.

5 To plot von Mises stress along the same boundary (Figure 2-8), enter 
mises_smpaxi in the Expression edit field, and then click OK.

To create Figure 2-9, you need to define a far-field variable.

1 Assure that the Pressure Acoustics (acpr) is selected from the Model Tree, then open 
the Boundary Settings dialog box.

2 Select Boundary 10 from the list and then click the Far-Field tab.

3 Enter p_far in the Name edit field and then click OK.

4 From the Solve menu, choose Update Model.

5 Open the Domain Plot Parameters dialog box from the Postprocessing menu.

6 Go to the Line/Extrusion page.

7 Select Boundary 10 from the list of boundaries.

8 Select Sound pressure level for p_far from the Predefined quantities list.

9 Click the Expression button in the x-axis data area, and then click on the Expression 
button.

10 Enter atan2(z,r) in the Expression edit field and click OK.

11 Click OK to create Figure 2-9.
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 3
A u t o m o t i v e  A p p l i c a t i o n  M o d e l s
This chapter presents models of automotive applications.
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D i e s e l  En g i n e  P i s t on

Introduction

A diesel engine piston is studied at steady-state conditions, that is, at a continuous 
engine speed and load. The combustion process at steady state produces cyclic pressure 
loads and a high constant temperature. These load conditions could yield a piston 
failure due to fatigue cracking, so-called high cycle fatigue cracks. 

Model Definition

To reduce the size of this model you can use the symmetries. The model has two 
symmetry planes, and the geometry is therefore reduced to a quarter of the original 
geometry. 
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M E C H A N I C A L  L O A D S

The applied mechanical loads consist of the following two parts:

• The peak combustion pressure which is applied on the combustion bowl, crown, 
and top land area (see Figure 3-1).

Figure 3-1: Boundaries which are subjected to the combustion pressure.

• The inertia (maximum) load at top dead center, TDC, that is, at the top of the 
stroke. The acceleration at TDC is calculated from:

where r is the crankshaft radius (half of the engine stroke), ω is the angular 
frequency, and λ is the crankshaft radius (r) divided with the connecting rod length 
(l) ratio (r/l).

a rω2 1 λ+( )=
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M E C H A N I C A L  C O N S T R A I N T S

Symmetry boundary conditions are applied at the symmetry planes of the one-fourth 
model; that is, the deformations in the normal directions of these boundaries are 
constrained to zero (see Figure 3-2).

Figure 3-2: Symmetry boundaries.

The piston pin is assumed to be rigid in this model. This means that the boundaries at 
the pin hole (see Figure 3-3) must be contrained from moving in the positive normal 
direction. To include these contact boundary conditions to the model displacement 
dependent boundary forces are applied to the piston pin hole boundaries. These forces 
depend on the normal displacement of the pin hole boundaries in a very nonlinear way. 
A penalty/barrier method is used to model the contact forces Fc as follows

Fc tn en g⋅+= g 0>

Fc tn
en

tn
----- g⋅⎝ ⎠
⎛ ⎞exp⋅= g 0≤
 3 :  A U T O M O T I V E  A P P L I C A T I O N  M O D E L S



where tn is the input estimate of the contact force, en is the penalty stiffness, g is the 
gap, that is, the normal distance between the piston pin hole and the rigid pin.

Figure 3-3: Contact boundary conditions at the pin hole.

T H E R M A L  B O U N D A R Y  C O N D I T I O N S

The effects of the cyclic swing in surface temperature during the combustion cycle are 
small compared to the time-averaged temperatures. The major effect of the heat 
transfer on thermal stresses are therefore taken into account by time-averaged 
boundary conditions (Ref. 1), that is, through constant convective boundary 
conditions. 

The heat transfer coefficients on all boundaries are some typical values for a high speed 
diesel engine, as well as the bulk combustion gas temperature, engine oil temperature, 
and cooling water temperatures (see Ref. 1).
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The following thermal boundary conditions are applied: 

• The combustion gas temperature (900 °C) is applied to the combustion bowl and 
piston crown areas as an external temperature. The heat transfer coefficient is set to 
500 W/(m2·°C) in these areas.
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• At the symmetry boundaries including the pin hole boundaries insulation/
symmetry conditions are applied.

• The outside of the piston is cooled by a cooling water whereas the inside is cooled 
by the engine oil, both at a temperature of 80 °C. Different heat transfer coefficients 
are applied on different boundaries and thereby reflecting the different cooling rates 
at each boundary. For example, a high heat transfer coefficient is applied to the 
bottom of the piston inside as this is the area where the piston oil cooling jet is 
directed.
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Results and Discussion

The temperature distribution is depicted in Figure 3-4. The highest temperatures are 
located at the bowl edge as the figure clearly shows. High temperatures at the bowl 
edge lowers the fatigue limit of the material in this area. 

Figure 3-4: Temperature distribution.

Figure 3-5 shows the total displacement for the piston. The figure shows that the 
piston bends over the piston pin due to the combustion gas pressure. This bending 
action creates a high tensile stress in the bowl edge area above the pin hole. 
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The fact that the temperatures and the tensile stresses are high at the bowl edge can 
produce so-called high cycle fatigue cracks in this area.

Figure 3-5: Total displacement.

Reference

1. Borman G., Internal-Combustion Engine Heat Transfer, Mechanical Engineering 
Department, University of Wisconsin-Madison, 1987.

Modeling in COMSOL Multiphysics

The nonlinear solver and the highly nonlinear option are used due to the contact 
boundary conditions at the piston pin hole (these boundary conditions result in very 
nonlinear boundary loads). 

Model Library path: Structural_Mechanics_Module/
Automotive_Applications/piston_3d
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Modeling Using the Graphical User Interface

1 Start COMSOL Multiphysics. This invokes the Model Navigator, which you can also 
open from an already running COMSOL Multiphysics session by choosing New 
from the File menu.

2 On the New page, select 3D from the Space dimension list.

Note: To start a new model without any application modes from a running 
COMSOL Multiphysics session of the same space dimension you must first Ctrl-click 
to clear the current selection in the Application Modes list.

3 Click OK to close the Model Navigator. Note that the model does not include any 
physics modes yet; these will be added later on.

G E O M E T R Y  M O D E L I N G

Select Import>CAD Data From File from the File menu and browse to the geometry file 
piston_3D_geometry.mphbin which is located in the folder models/
Structural_Mechanics_Module/Automotive_Applications/ in the COMSOL 
installation directory.
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O P T I O N S  A N D  S E T T I N G S

1 Select Constants from the Options menu and enter the following constant names, 
expressions, and descriptions (optional); when done, click OK.

2 From the Options menu select Materials/Coefficients Library and click New.

3 Enter then the following material parameters:

4 Type Aluminum in the Name edit field click OK to close the Materials/Coefficients 

Library dialog box.

M O D E L  N A V I G A T O R

1 Select Model Navigator from the Multiphysics menu.

2 Select 3D from the Space dimension list.

3 In the application list double-click the Structural Mechanics Module folder, then select 
Solid, Stress-Strain, and finally click the Add button.

4 In the application list double-click first COMSOL Multiphysics and then Heat Transfer. 
Select Conduction, then click Add.

NAME EXPRESSION DESCRIPTION

n 2000[1/min] Revolutions per minute

omega n*2*pi Angular velocity

stroke 0.144[m] Engine stroke

r stroke/2 Crankshaft radius

conrod_length 0.26[m] Connecting rod length

lda r/conrod_length

pistonacc omega^2*r*(1+lda) Piston acceleration

P 130e5[N/m^2] Face load

tn 5e5[N/m^2] Input estimate of contact force

en 1.0e14[N/m^3] Penalty stiffness

MATERIAL PARAMETER EXPRESSIO
N

E 70e9

nu 0.33

rho 2700

alpha 23e-6

C 944

k 236
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5 Click OK to close the Model Navigator.

P H Y S I C S  S E T T I N G S

Boundary Settings—Mechanical
1 Select Solid, Stress-Strain (smsld) from the Multiphysics menu.

2 Enter the combustion pressure load on the Load page in the Boundary Settings dialog 
box for the Solid, Stress-Strain application mode according to the following table 
(see also Figure 3-1):

3 Enter the symmetry constraints on the Constraint page in the Boundary Settings 

dialog box. 

SETTINGS BOUNDARIES 4–9, 11, 12, 27

Coordinate system Tangent and normal coord. sys. (t1, t2, n)

Fn -P

SETTING BOUNDARIES 1, 2, 29, 34, 35

Constraint condition Symmetry plane
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4 From the Options menu select Expressions>Boundary Expressions.

5 Enter the following Boundary Expressions variables on Boundaries 31 and 32. An 
additional boolean expression, gap<=0, is included in the exponent to avoid 
problems with numerical overflow.

6 You can now use the boundary expression variable Fc to enter the contact boundary 
condition to the pin hole.

7 Enter the following load expression to include a contact boundary condition on the 
Load page in the Boundary Settings dialog box. 

Subdomain Settings—Mechanical
1 Select Aluminum from the Library material list on the Material page in the Subdomain 

Settings dialog box for the Solid, Stress-Strain application mode.

NAME EXPRESSION

gap nx*u+ny*v+nz*w

Fc (gap>0)*(tn+en*gap)+(gap<=0)*tn*exp(gap*(gap<=0)*en/tn)

SETTINGS BOUNDARIES 31, 32

Coordinate system Tangent and normal coord. sys. (t1, t2, n)

Fn -Fc
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2 On the Load page enter the following inertia load.

3 Select the Include thermal expansion check box and enter T in the Temp edit field and 
25 in the Tempref edit field.

Boundary Settings—Thermal
1 Select Heat Transfer by Conduction (ht) from the Multiphysics menu.

2 Enter the combustion gas temperature and the associated heat transfer coefficients 
for the combustion bowl and piston crown area according to the following table in 
the Boundary Settings dialog box for the Heat Transfer by Conduction application 
mode.

3 Next set the thermal insulation boundary condition on the symmetry boundaries.

SETTINGS SUBDOMAIN 1

Coordinate system Global coordinate system

Fz pistonacc*rho_smsld

SETTINGS BOUNDARIES 4–9, 11, 12

Boundary condition Heat flux

h 500

Tinf 900

SETTING BOUNDARIES 1, 2, 29, 31, 32, 34, 35

Boundary condition Thermal insulation
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4 The outer and inner surfaces that are cooled by the cooling water and the engine oil 
are given the following convective boundary conditions: 

5 The upper and inner areas of the piston rings have somewhat lower heat transfer 
coefficients compared to the surrounding areas. 

6 The ring lands, which are located between the ring grooves, have relatively low heat 
transfer coefficients. 

7 Finally the area where the piston is cooled by the oil jet a high heat transfer 
coefficient is applied. 

Subdomain Settings—Thermal
Select Aluminum from the Library material list on the Physics page in the Subdomain 

Settings dialog box for the Heat Transfer by Conduction application mode.

M E S H  G E N E R A T I O N

1 Click the Initialize Mesh button.

SETTINGS BOUNDARIES 10, 13, 15, 18, 21, 23, 27, 28, 30, 33

Boundary condition Heat flux

h 700

Tinf 80

SETTINGS BOUNDARIES 14, 16, 17, 19, 20, 22

Boundary condition Heat flux

h 500

Tinf 80

SETTINGS BOUNDARIES 24–26

Boundary condition Heat flux

h 250

Tinf 80

SETTINGS BOUNDARY 3

Boundary condition Heat flux

h 2400

Tinf 80
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C O M P U T I N G  T H E  S O L U T I O N

1 Open the Solver Parameters dialog box on the Solve menu.

2 Select GMRES from the Linear system solver list.

3 Select Geometric multigrid from the Preconditioner list.

4 On the Stationary page, select the Highly nonlinear problem check box.

5 Click OK.

6 Solve the problem by clicking the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

First create the temperature distribution plot.

1 Select Plot Parameters from the Postprocessing menu.

2 Check Deformed shape plot and Boundary plot on the General page.

3 Click the Boundary tab. Select Heat Transfer by Conduction (ht)>Temperature from 
the Predefined quantities list and click OK. 

The next plot shows the total displacement from a YZ view.

4 Still on the Boundary page, select Solid, Stress-Strain (smsld)>Total displacement from 
the Predefined quantities list and click OK. 
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5 Click the Go to YZ View button on the Camera toolbar.
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Fu e l  C e l l  B i p o l a r  P l a t e

This study presents a model that couples the thermal and structural analysis in a bipolar 
plate in a proton exchange membrane fuel cell (PEMFC). The fuel cell stack consists 
of unit cell of anode, membrane, and cathode connected in series through bipolar 
plates. The bipolar plates also serve as gas distributors for hydrogen and air that is fed 
to the anode and cathode compartments, respectively. Figure 3-6 below shows a 
schematic drawing of a fuel cell stack. The unit cell and the surrounding bipolar plates 
are shown in detail in the upper right corner of the figure.

Figure 3-6: Schematic drawing of the fuel cell stack. The unit cell consists of an anode, 
membrane electrolyte, and a cathode. The unit cell is supported and supplied with 
reactants through the bipolar plates. The bipolar plates also serve as current collectors and 
feeders.

The PEMFC is one of the strongest alternatives for automotive applications where it 
has the potential of delivering power to a vehicle with a higher efficiency, from oil to 
propulsion, than the internal combustion engine.

The fuel cell operates at temperatures just below 100 °C, which means that it has to 
be heated at start-up. The heating process induces thermal stresses in the bipolar plates. 
The analysis in this model reveals the magnitude and nature of these stresses.
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Model Definition

Figure 3-7 below show the detailed model geometry. The plate consists of gas slits that 
form the gas channels in the cell, holes for the tie rods that keep the stack together, 
and the heating elements, which are positioned in the middle of the gas feeding 
channel for the electrodes. Due to symmetry, it is possible to reduce the model 
geometry to 1/8 of the actual size of the cell.

Figure 3-7: The modeled geometry.

The study consists of a thermal analysis and a structural analysis, both for steady 
operation. In the following specification of the problem a number of constants are 
used; their values are listed in the table below. The constant Q1 represents a power of 
200 W distributed over the hole through the 25 bipolar plates in the fuel cell stack.

CONSTANT EXPRESSION DESCRIPTION UNITS

Q1 200/25/(pi*0.005^2*0.01) Volume power in one heating element W/m3

P1 9.82e5 Pressure on the active part N/m2

P2 7.85e6 Pressure on the manifold N/m2

h1 5 Heat transfer coefficient to the 
surroundings

W/(m2·K

h2 50 Heat transfer coefficient in the gas 
channels

W/(m2·K
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T H E R M A L  A N A L Y S I S

The general equation is the steady-state heat equation according to:

 (3-1)

where k denotes the thermal conductivity of the different materials, T the temperature, 
and Q a heat source or heat sink.

The modeled domain consists of three different subdomains. The first subdomain 
corresponds to the active part of the cell, where the electric energy is produced and the 
current is conducted. The production and conduction of current involve some losses. 
It is assumed in this model that the cell is heated prior to operation. This means that 
the model does not account for the heat sources due to the production and conduction 
of current; see Figure 3-8.

Figure 3-8: The active part of the cell bipolar plate is made of titanium.

The second subdomain corresponds to the heating element in the bipolar plate, which 
is made of aluminum. The power from this element is assumed to be uniformly 

∇ k T∇–( ) Q+⋅ 0=

Q = 0 Titanium
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distributed in the small cylindrical subdomain; see Figure 3-9.

Figure 3-9: The heating element in the bipolar plate is made of aluminum.

The last subdomain forms the manifold in the cell. In this subdomain, only heat 
conduction is present. The construction material is titanium.

Figure 3-10: The subdomain that forms the manifold of the cell.

The thermal conductivity of the materials and the magnitude of the heat source form 
the input data needed in the model. You can find the data in the COMSOL 
Multiphysics file for this model.

Q = Q1
Aluminum

Q = 0
Manifold
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The boundary conditions for the heat transfer analysis are symmetry conditions and 
convective conditions. The symmetry condition states that the flux is zero 
perpendicular to the boundary.:

 (3-2)

The convective conditions set the heat flux proportional to the temperature difference 
between the fluid outside and the temperature at the boundary. The heat transfer 
coefficient is the proportionality constant:

 (3-3)

In this equation, h denotes the heat transfer coefficient.

Figure 3-11 below shows the insulation boundaries.

Figure 3-11: Insulation boundaries.

k T∇–( ) n⋅ 0.=

k T∇–( ) n⋅ h T Tfluid–( ).=
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Figure 3-12 shows the convective boundaries. The heat transfer coefficient is different 
for the different groups of boundaries in the figure.

Figure 3-12: The convective boundaries.

S T R U C T U R A L  A N A L Y S I S

The material properties for titanium and aluminum are obtained from COMSOL 
Multiphysics’ materials database. The only volume loads present in the domain are 
those generated by thermal expansion. The thermal loads are proportional to the 
temperature difference between the reference state and the actual temperature.

The loads and constraints on the boundaries are shown in Figure 3-13 below. There 
are no displacements in the direction perpendicular to the symmetry boundaries.

Figure 3-13: The symmetry boundaries.
F U E L  C E L L  B I P O L A R  P L A T E  |  67



68 |  C H A P T E R
The base surface of the plate is also a symmetry boundary, which implies that there are 
no displacements in the z direction at the position of the boundary.

Figure 3-14: No displacement perpendicular to the symmetry plane.

In addition, the load applied by the tie rods on the stack is applied in the manifold and 
the active part at the bipolar plate. The pressure is different in these two subdomains.

The loads and constraints on all other boundaries are assumed to be negligible. In this 
context, the only questionable assumption is the possible loads and constraints 
imposed by the tie rods on the holes in the bipolar plate. In a more detailed analysis, 
it would be possible to couple a model for the tie rods with a detailed model of the 
bipolar plate.

Figure 3-15: Pressure applied externally.

Results

To estimate the influence of the temperature on the displacements and stresses and 
strains in the plate, you can solve the problem for the structural part first, assuming 
constant temperature at the reference state. Figure 3-16 shows the displacement and 
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the von Mises stresses in the plate. As you can see from the plots, the von Mises 
effective stresses are relatively large in the manifold region of the plate.

Figure 3-16: The displacement in the plate (top) and the von Mises stresses caused by the 
external pressure applied by the end plates and the tie rods.
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Figure 3-17 shows the temperature field at steady state. The slits for the gas present 
the largest sinks of heat at the boundaries. The temperature decreases almost radially 
with the distance from the heating element.

Figure 3-17: Temperature distribution in the plate.
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The displacements and stresses generated due to the external pressure and the 
temperature gradients are shown in Figure 3-18.

Figure 3-18: Displacements (top) and von Mises stresses due to temperature and external 
loads.
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Figure 3-18 shows that the thermal loads generate stresses that are one order of 
magnitude larger than those generated by the external pressure loads. The loads are far 
from the critical values, but the displacements can be even more important. The 
displacements should be small enough to grant that the membrane can fulfill its 
function in separating hydrogen and oxygen in the anode and cathode compartments, 
respectively.

Model Library path: Structural_Mechanics_Module/
Automotive_Applications/bipolar_plate

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Click the New button or start COMSOL Multiphysics to open the Model Navigator.

2 Select 3D from the Space dimension list.

3 Click the Multiphysics button.

4 Open the Structural Mechanics Module folder and then Solid, Stress-Strain. Select the 
Static analysis and click the Add button to add the application mode.

5 Open the COMSOL Multiphysics>Heat Transfer>Conduction folder. Select Steady-state 

analysis and click Add to add the heat transfer application mode.

6 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

2 Enter the following constant names, expressions, and (optionally) descriptions. 
When finished, click OK.

G E O M E T R Y  M O D E L I N G

Create the geometry by extruding a 2D triangular mesh, resulting in prism elements.

NAME EXPRESSION DESCRIPTION

P1 9.82e5[Pa] Pressure on the active part

P2 7.856e6[Pa] Pressure on the manifold
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1 Select Work-Plane Settings from the Draw menu to open the Work-Plane Settings 
dialog box, and click OK to create a default x-y work plane.

2 Choose Options>Axes/Grid Settings. On the Grid page, clear Auto, and set axis and 
grid settings in Geom2 according to the following table. Click OK.

3 Draw a rectangle with opposite corners at (0, 0) and (0.12, 0.09).

4 Draw a rectangle with opposite corners at (0.03, 0.035) and (0.12, 0.09).

5 Draw three centered circles with radius 0.005 and center at (0.015, 0.015), (0.015, 
0.09), and (0.12, 0.015).

6 Draw a rectangle with opposite corners at (0.01, 0.035) and (0.02, 0.07).

7 Draw a rectangle with opposite corners at (0.035, 0.01) and (0.105, 0.02).

Create fillets on the two last created rectangles.

8 Click the Fillet/Chamfer toolbar button to open the Fillet/Chamfer dialog box.

9 Select all vertices in the two rectangle by clicking in the drawing area or in the Vertex 

selection list.

10 Type 2.5e-3 in the Radius edit field, then click OK to create the fillets.

11 Select all objects except the second largest rectangle (R2) and click the Difference 
button on the Draw toolbar to cut out the holes.

Create the subdomain where the heating is done.

12 Draw a centered circle with radius 0.005 and center at (0.07, 0.09).

13 Draw a rectangle with opposite corners at (0.065, 0.09) and (0.075, 0.095).

AXIS GRID

x min -0.01 x spacing 2.5e-3

x max 0.15 Extra x

y min -0.01 y spacing 2.5e-3

y max 0.1 Extra y
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14 Select both the circle and the rectangle, then click the Difference button.

You are now finished with the drawing of the 2D geometry. Create the 3D geometry 
by extruding the 2D mesh. To do this you must first create the 2D mesh.

M E S H  G E N E R A T I O N

1 Open the Free Mesh Parameters dialog box from the Mesh menu.

2 Select Coarse from the Predefined mesh sizes list.
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3 Click the Remesh button to mesh the 2D geometry and click OK. 

4 Choose Extrude Mesh from the Mesh menu to open the Extrude Mesh dialog box.

5 Type 0.005 in the Distance edit field, then click OK to create the extruded mesh.
F U E L  C E L L  B I P O L A R  P L A T E  |  75



76 |  C H A P T E R
P H Y S I C S  S E T T I N G S

Boundary Conditions
Start with the structural boundary conditions.

1 Choose Geom1: Solid, Stress-Strain (smsld) from the Multiphysics menu.

2 Choose Physics>Boundary Settings and enter the boundary settings according to the 
following table; when done, click OK.

Continue with the heat transfer boundary conditions:

3 Choose Geom1: Heat Transfer by Conduction (ht) from the Multiphysics menu to set 
the boundary conditions for the heat transfer application mode.

4 Choose Physics>Boundary Settings and enter the boundary settings according to the 
following table; when done, click OK.

Subdomain Settings
Define the material properties using the materials library. Start with the structural 
mechanics application mode.

1 Choose Geom1: Solid, Stress-Strain (smsld) from the Multiphysics menu.

2 Choose Physics>Subdomain Settings.

3 Select Subdomains 1 and 2 from the Subdomain selection list. Click the Load button 
on the Material page to open the Materials/Coefficients Library dialog box.

4 Select Titanium beta-21S from the Materials tree and click OK to close the Materials/

Coefficients Library dialog box. Click OK to close the Subdomain Settings dialog box.

5 Select Subdomain 3 from the subdomain list and clear the Active in this domain 
check box to disable the structural application mode in this domain.

6 Choose Geom1: Heat Transfer by Conduction (ht) from the Multiphysics menu to 
change to the heat transfer application mode.

BOUNDARIES 3, 5, 20, 23, 25, 36, 42–44 BOUNDARY 24 BOUNDARY 4

Page Constraint Load Load

Constraint condition Symmetry plane Fz -P1 Fz -P2

SETTINGS BOUNDARIES 1, 2 BOUNDARIES 8–10, 12, 13, 
17–19, 26–30, 37–39

Boundary condition Heat flux Heat flux

h 5 50

Tinf 20 80
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7 Choose Physics>Subdomain Settings.

8 Select Subdomains 1 and 2 from the Subdomain selection list. Click the Load button 
on the Material page to open the Materials/Coefficients Library dialog box.

9 Select Titanium beta-21S from Model in the Materials tree and click OK to close the 
Materials/Coefficients Library dialog box. 

10 Select Subdomain 3 from the Subdomain list. Click the Load button on the Material 

page to open the Materials/Coefficients Library dialog box.

11 Select Aluminum from the Materials tree and click OK to close the Materials/Coefficients 

Library dialog box. 

12 Type 200/25/(pi*0.005^2*0.01) as the heat source in the Q edit field. Click OK 
to close the Subdomain Settings dialog box.

C O M P U T I N G  T H E  S O L U T I O N  W I T H O U T  T H E R M A L  E X P A N S I O N

In the first analysis, solve the structural part without thermal expansion.

1 Select Solver Manager from the Solve menu to open the Solver Manager dialog box.

2 On the Solve For page select Solid, Stress-Strain (smsld) from the Solve for variables 
list and click OK to close the dialog box.

3 Click the Solve button on the Main toolbar to compute the solution.

The structural mechanics problem without thermal expansion is now solved.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Look at the total displacement and von Mises stresses. 

1 Choose Plot Parameters from the Postprocessing menu.

2 Select the Subdomain and Geometry edges check boxes in the Plot type area on the 
General page.

3 Click the Subdomain tab.

4 From the Predefined quantities list select Solid, Stress-Strain (smsld)>Total 

displacement.
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5 Click Apply.

6 From the Predefined quantities list select Solid, Stress-Strain (smsld)>von Mises stress, 
then click Apply.
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C O M P U T I N G  T H E  S O L U T I O N  W I T H  T H E R M A L  E X P A N S I O N

Start to calculate the temperature field.

1 Open the Solver Manager dialog box.

2 Select Heat Transfer by Conduction (ht) from the Solve for variables list on the Solve 

For page, then click OK to close the dialog box.

3 Click the Solve button on the Main toolbar to solve for the temperature.

Next, specify the temperature load in the structural mechanics application mode.

4 Choose Geom1: Solid, Stress-Strain (smsld) from the Multiphysics menu.

5 Choose Physics>Subdomain Settings.

6 Select Subdomains 1 and 2 from the Subdomain selection list. 

7 Click the Load tab.

8 Select the Include thermal expansion check box and type T in the Temp edit field.

9 Open the Solver Manager dialog box and click the Initial value tab.

10 Click the Stored solution option button in the Values of variables not solved for and 

linearization point area.

11 Click the Store Solution button to save the temperature solution.

12 Select Solid, Stress-Strain (smsld) from the Solve for variables list on the Solve For page 
and click OK to close the dialog box.

13 Click the Solve toolbar button to solve the structural mechanics application mode 
including thermal expansion.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Visualize the temperature field, total displacement, and von Mises stress level including 
thermal expansion.

1 From the Postprocessing menu, select Plot Parameters.

2 Select the Boundary check box and clear the Subdomain check box in the Plot type 
area on the General page to clear the Subdomain plot type.

3 Click the Boundary tab.

4 Select Heat Transfer by Conduction (ht)>Temperature from the Predefined quantities 
list.
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5 Click Apply.

6 Select the Subdomain and Geometry edges check boxes in the Plot type area on the 
General page.

7 Click the Subdomain tab.

8 Select Solid, Stress-Strain (smsld)>Total displacement from the Predefined quantities 
list.
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9 Click Apply.

10 Select Solid, Stress-Strain (smsld)>von Mises stress from the Predefined quantities list, 
then click Apply.

11 Click the Head Light toolbar button, then click the Zoom Extents toolbar button.
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S p i n n i n g  Gea r

Introduction

Figure 3-19: Stresses and deformation at 1600 Hz.

One way to fasten a gear to a shaft is by thermal interference. In preparation of the 
assembly, the shaft diameter is oversized and the gear thermally expanded in a heat 
treating oven. At an appropriate expansion state, the gear is removed from the oven, 
slid onto the shaft, and allowed to cool. As the gear temperature drops, the gear shrinks 
and comes into contact with the shaft before it reaches its original shape. From this 
point on, additional gear shrinkage results in hoop stresses in the gear as well as normal 
compression of the shaft. At thermal equilibrium, an intimate bond between the two 
components is reached.

Such an assembly can operate safely in many situations. However, there are operating 
conditions under which the fastening stresses become insufficient—for instance, when 
spinning the assembly at high rpm.
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The goal of this analysis is to determine the critical spinning frequency at which gear 
and shaft separate.

Model Definition

The model computations consist of two steps:

• Thermal interference fit

- Import the gear geometry from a given CAD file and draw the shaft using 
COMSOL Multiphysics solid modeling tools. 

- Fasten the gear to the shaft by thermal interference: Initially, both shaft and gear 
reside at room temperature (23 ºC). Then, the gear is heated to 700 ºC, 
positioned on the shaft, and allowed to cool.

• Spinning the shaft-gear assembly

- Spin the shaft-gear assembly and determine the separation frequency.

Assume plane stress conditions for all computations and neglect contact phenomena 
during separation.

G E O M E T R Y

The geometry in Figure 3-20 consists of a shaft and a gear.

Shaft specifications:

• Material: Steel AISI 4340

• Radius: 0.015 m

• Length: 0.1 m

Gear specifications:

• CAD file: gear.dxf. This file is included in the model folder and was taken from 
Ref. 1.

• Material: Steel AISI 4340
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• Thickness: 0.01 m

Figure 3-20: Gear geometry

D O M A I N  E Q U A T I O N S

The given problems are solved by computing the stress and deflection fields of the 
steady thermal interference and critical separation states. Starting with the stress-strain 
relation

and the thermal strain relation

 (3-4)

where the subscript “el” stands for elastic and αt is the coefficient of thermal expansion, 
you can state that
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where

For more information about the underlying equations for the Plane Stress application 
mode, see the Structural Mechanics Module User’s Guide.

In the second part of the analysis, the forcing term f represents the centripetal body 
force:

B O U N D A R Y  C O N D I T I O N S

To prevent rigid body translation and rotation, you must impose some constraints 
(Dirichlet conditions): For computational efficiency, the analysis only includes a 
symmetric quarter of the geometry. By setting the normal displacements on the 
symmetry boundaries to zero, it is easy to constrain the model.

Modeling in COMSOL Multiphysics

Because the analysis neglects the contact phenomena, the gear geometry is modeled at 
the thermal expansion of  700 °C, at which it fits precisely on the shaft. The model 
assumes that the gear expands freely in the heat-treating oven and that the heating 
profile removes all internal stresses. When the assembly is spun, the gear expands more 
quickly than the shaft and reaches a critical separation point.

Results

I N T E R F E R E N C E

In the first analysis step, you obtain the stress distribution of the thermal interference. 
Figure 3-21 illustrates the hoop stresses in the gear which increase gradually toward 
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the interface between shaft and gear. As a result, the shaft is exposed to normal 
compression.

Figure 3-21: Von Mises stresses superimposed on shaft and gear. Note the hoop stresses.

S E P A R A T I O N

The parametric analysis spins the prestressed assembly at various frequencies, and you 
can plot the displacement between the shaft and the gear. Figure 3-22 and Figure 3-
23 illustrate an advanced displacement state at 1600 Hz and a displacement versus 
frequency plot, respectively. The separation frequency occurs at the minimum of about 
1550 Hz (Figure 3-23).
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Figure 3-22: Von Mises stresses and deflection at 1600 Hz.

Figure 3-23: Displacement vs. frequency; separation occurs at 1550 Hz.
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S C R I P T I N G  A N D  O P T I M I Z A T I O N

The above frequency sweep was obtained by trial and error. If COMSOL Script or 
MATLAB is available, you can obtain the separation frequency by optimization 
(Figure 3-24).

Figure 3-24: Result of the optimization study: 1550.18 Hz.

Reference

1. http://claymore.engineer.gvsu.edu/~schmitte/assign5.html.

Model Library path: Structural_Mechanics_Module/
Automotive_Applications/spinning_gear

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select 2D from the Space dimension list.

2 Select Structural Mechanics Module>Plane Stress in the list of application modes (see 
Figure 3-25).
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3 Click OK.

Figure 3-25: Selection of the Plane Stress application mode.

G E O M E T R Y  M O D E L I N G

1 Choose File>Import>CAD Data From File.

2 Browse to gear.dxf in the models/Structural_Mechanics_Module/
Automotive_Applications directory located in the COMSOL installation 
directory.

3 Click Import.

4 Make sure the geometry object is selected, then click the Coerce to Solid button on 
the Draw toolbar.

The imported geometry is not centered at the origin. However, centering the gear 
simplifies the modeling process.

Note: Selected geometry objects are highlighted in red and are subject to subsequent 
geometry operations. Ensure that the gear is highlighted before proceeding.

1 Click the Move button in the Draw toolbar.

2 Type -1.228991 in the x edit field and 0.001573 in the y edit field.
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3 Click OK. The gear is now centered at the origin.

4 Click the Zoom Extents button on the Main toolbar.

Next, reduce the size of the imported object by a factor of 10:

5 Click the Scale button on the Draw toolbar. In the Scale factor area type 0.1 in both 
the x and the y edit field, then click OK.

6 Click Zoom Extents.

7 Click the Rectangle/Square button. Draw a square with opposite corner points at 
(0, 0) and (0.06, 0.06) by pointing at one corner and dragging to the opposite one 
using the right mouse button.

8 Copy the resulting object, SQ1, to the clipboard by pressing Ctrl+C. You will reuse 
this object in a later step.

Note: Using the right mouse button in Step 7 constrains the side lengths to be equal, 
thus resulting in the square object, SQ1. If you had used the left mouse button 
instead, the side lengths would not be constrained in this way and the created object 
would be a rectangle—therefore labeled R1—even though its sides were equal. In 
that case, just replace R1 for SQ1 in the following instructions.

9 Click the Create Composite Object button on the Draw toolbar.

10 Type CO1*SQ1 in the Set formula edit field to do a Boolean intersection of the square 
and the gear, then click OK.

11 Shift-click the Circle/Ellipse (Centered) button in the Draw toolbar.

12 Type 0.015 in the Radius edit field, then click OK.

13 Press Ctrl+V to paste the stored object from the clipboard. Click OK to accept zero 
displacements from the original object.

14 Click the Create Composite Object button on the Draw toolbar.

15 Type C1*SQ1 in the Set formula edit field to do a Boolean intersection of the square 
and the circle, then click OK.

16 Click the Zoom Extents button.

This completes the geometry. Compare your result with Figure 3-26.
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Figure 3-26: Completed shaft and gear geometries in 2D.

P H Y S I C S  S E T T I N G S — I N T E R F E R E N C E  F I T

Boundary Conditions
1 On the Options menu point to Labels, then click Show Edge Labels.

2 From the Physics menu choose Boundary Settings.

3 Select Boundaries 1, 2, 3, and 12 and select Symmetry plane from the Constraint 

condition list on the Constraint page.

4 Click OK.

Subdomain Settings
1 From the Physics menu choose Subdomain Settings.

2 Select Subdomains 1 and 2.

3 Click the Load button on the Material page to open the Materials/Coefficients Library 
dialog box.

4 Select the Steel AISI 4340 material from the list of materials. Click OK.

5 Select Subdomain 1 (the shaft) and type 0.1 in the thickness edit field.
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6 Select Subdomain 2 (the gear) and type 0.01 in the thickness edit field.

7 Click the Load tab and select Subdomain 2 only.

8 Select the Include thermal expansion check box.

9 Type 23[degC] in the Temp edit field and type 700[degC] in the Tempref edit field 
to set the strain temperature to 23 °C and the strain reference temperature to 700 
°C. Click OK.

M E S H  G E N E R A T I O N

1 Click the Initialize Mesh button in the Main toolbar.

The initial mesh is quite coarse at the interface between the shaft and the gear. 
Because the hoop stresses of the thermal interference drop steeply from this interface 
into the periphery of the gear, you need to refine the mesh at the interface.

2 From the Mesh menu choose Free Mesh Parameters.

3 Click the Boundary tab.

4 Select Boundary 45 in the geometry and type 1e-4 in the Maximum element size edit 
field.

5 Click Remesh and then click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar to start the analysis.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 From the Postprocessing menu, choose Plot Parameters.

2 Select the Surface, Contour, Arrow, Max/min marker, and Deformed shape check boxes 
on the General page to create a plot with these plot types.

3 Click the Arrow tab.

4 Select Boundaries in the Plot arrows on list. Click OK.

Compare your result with Figure 3-27.

1 For a second plot, click the 3D Surface Plot button in the Plot toolbar.

2 From the Postprocessing menu, choose Plot Parameters.

3 Click the General tab.

4 Clear the Deformed shape check box and select the Contour and Arrow check boxes.

5 Click OK.

6 Click the Headlight button in the Camera toolbar.
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You can rotate the plot by moving the mouse. Compare your result with Figure 3-28.

Note: There are spikes in the von Mises stress field which are due to singularities. 
They are caused by unsmooth corners in the imported CAD geometry.

Figure 3-27: Von Mises stresses and deflection after thermal interference process.
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Figure 3-28: 3D surface plot of Figure 3-27.

This completes the first modeling stage.

S P I N N I N G  T H E  S H A F T - G E A R  A S S E M B L Y — S E P A R A T I O N  F R E Q U E N C Y

The next analysis determines the separation frequency by spinning the shaft-gear 
assembly. In a strict sense, this is a contact problem and the description of the shaft-
gear interface complex. However, because the resulting centripetal body load is nearly 
radially symmetric, it is not much of a liberty to assume that the entire contact interface 
separates at one specific frequency. Two body loads describe this problem:

• Residual stress field from the interference fit

• Rotational body force from spinning the assembly

To reference the interference stress fields and allow component mobility, add two 
additional Plane Stress application modes to the model and assign them to the shaft 
and gear domains, respectively. This enables a displacement comparison between the 
surfaces of the outer shaft and the inner gear. The independence of these two 
application modes implies that the displacement comparison has practical meaning 
only at frequencies greater than or equal to the separation frequency.
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M U L T I P H Y S I C S  S E T T I N G S

1 From the Multiphysics menu choose Model Navigator.

2 With Structural Mechanics Module>Plane Stress already selected, click the Add button 
twice to add two more Plane Stress application modes: Plane Stress (smps2) and Plane 

Stress (smps3). 

3 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, choose Constants.

2 Enter the following constants in the Name, Expression, and Description (optional) 
columns; when done, click OK,

3 Click OK.

4 From the Options menu, point to Expressions, and then click Scalar Expressions.

5 Specify expressions according to the following table (the descriptions are optional):

6 Click OK.

When specifying expressions for the first time, it is useful to graph them by using 
postprocessing functions. To superimpose a vector plot of the body force onto the 
geometry, do as follows:

1 From the Solve menu, choose Update Model (this updates all expressions and makes 
them available for postprocessing).

2 From the Postprocessing menu, choose Plot Parameters.

3 Select the Arrow and Geometry edges check boxes only.

4 Click the Arrow tab.

NAME EXPRESSION DESCRIPTION

shaftLength 0.1[m] Shaft length

gearWidth 0.01[m] Gear width

rho 7850[kg/m^3] Density

f 1000[Hz] Frequency

NAME EXPRESSION DESCRIPTION

theta atan2(y,x) Angle

Force 4*pi^2*f^2*rho*sqrt(x^2+y^2) Body load

Fx Force*cos(theta) Body load x-component

Fy Force*sin(theta) Body load y-component
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5 Select Subdomains in the Plot arrows on list.

6 Type Fx and Fy in the x component and y component edit fields, respectively.

7 Click OK to display the body load F. Compare the result with Figure 3-30.

Figure 3-29 shows these plot settings for this plot.

Figure 3-29: Plot settings for checking the centripetal body load.
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Figure 3-30: Graphical output based on input specified in Figure 3-29.

P H Y S I C S  S E T T I N G S

Subdomain Settings—Plane Stress (smps3), Gear
Because it was created last, the application mode Plane Stress (smps3) is now active. 
This is indicated in the title bar of the COMSOL Multiphysics user interface and by a 
bullet in the Multiphysics menu. Assign the shaft to the Plane Stress (smps2) application 
mode and the gear to the Plane Stress (smps3) application mode by deactivating the 
other subdomain in the respective application modes:

1 From the Physics menu choose Subdomain Settings.

2 Select Subdomain 1 and clear the Active in this domain check box.

3 Select Subdomain 2 and click the Material tab.

4 Click the Load button to open the Materials/Coefficients Library dialog box.

5 Select the Steel AISI 4340 material from the list of materials. Click OK.

6 Type the constant gearWidth in the thickness edit field.
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7 Click the Load tab and specify the body load as follows:

8 Click the Body load is defined as force/volume using the thickness option button.

9 Click the Initial Stress and Strain tab.

10 Select the Include initial stress check box and type the residual stresses sx_smps, 
sy_smps, and sxy_smps from the Plane Stress (smps) application mode in the edit 
fields for the initial normal stress and initial shear stress according to Figure 3-31.

Figure 3-31: Specification of residual stresses sx_smps, sy_smps, and sxy_smps.

11 Click OK.

Subdomain Settings—Plane Stress (smps2), Shaft
1 From the Multiphysics menu, choose Plane Stress (smps2).

2 From the Physics menu, choose Subdomain Settings.

3 Clear the Active in this domain check box for the already selected Subdomain 2.

4 Select Subdomain 1.

5 Click the Load button on the Material page to open the Materials/Coefficients Library 
dialog box.

6 Select the Steel AISI 4340 material from the list of materials. Click OK.

7 Type the constant shaftLength in the thickness edit field.

QUANTITY NAME VALUE / EXPRESSION UNITS

Body load x dir Fx Fx N/m3

Body load y dir Fy Fy N/m3
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8 Specify the same load and initial stress and strain expressions as for the Plane Stress 
(smps3) application mode.

9 Click OK to exit the Subdomain Settings dialog box.

Boundary Conditions
1 From the Physics menu, choose Boundary Settings.

2 Select Boundaries 1 and 2 and select Symmetry plane in the Constraint condition list.

3 Click OK.

4 From the Multiphysics menu, choose Plane Stress (smps3).

5 From the Physics menu, choose Boundary Settings.

6 Select Boundaries 3 and 12 and select Symmetry plane in the Constraint condition list.

7 Click OK.

Options and Settings—Integration Coupling Variable
1 From the Options menu, point to Integration Coupling Variables, and then click 

Boundary Variables.

2 Select Boundary 45 and define the integration coupling variable int_disp 
according to the following table:

3 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

The residual stresses sx_smps, sy_smps, and sxy_smps and the added centripetal 
body loads are now used to compute the relative displacements of the gear and the 
shaft. Because the residual stresses are already available from the previous computation, 
the next step instructs COMSOL Multiphysics to use this existing data. There is no 
need to recompute the solution for the Plane Stress (smps) application mode:

1 Click the Solver Manager button and click the Current solution option button in the 
Values of variables not solved for and linearization point area.

2 Click the Solve For tab.

3 Select Plane Stress (smps2) and Plane Stress (smps3) such that both of them are 
highlighted. (Ctrl-clicking accomplishes this.)

4 Click OK.

QUANTITY NAME EXPRESSION

Displacement integral int_disp ((u3-u2)^2+(v3-v2)^2)^0.5
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At this point, it is unknown at which frequency the shaft and the gear separate. More 
time effective than many trial and error iterations of single test frequencies is a 
frequency sweep. For instance, specify a sweep from 1000 Hz to 2000 Hz in 
increments of 50 Hz as follows:

1 Click the Solver Parameters button.

2 Select Parametric from the Solver list.

3 On the General page, type f in the Parameter name edit field and the vector 
1000:50:2000 in the Parameter values edit field.

4 Click OK.

5 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 From the Postprocessing menu choose Cross-Section Plot Parameters.

2 In the Plot type area on the General page click the Point plot option button.

3 All parametric solutions in the Solutions to use list are highlighted by default.

4 Click the Point tab.

5 Type int_disp in the Expression edit field.

6 Click OK.
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Figure 3-32 reveals that the gear separates from the shaft at approximately 1550 Hz.

Figure 3-32: Displacement versus frequency; separation occurs at 1550 Hz.

To plot the von Mises stress field at 1600 Hz, follow this procedure:

1 Close Figure 3-32. 

2 On the Options menu, point to Expressions, and then click Subdomain Expressions.

3 Select Subdomain 1.

4 Define the variables mises_all, u_all, and v_all, and specify the corresponding 
expressions mises_smps2, u2, and v2, respectively.

5 Select Subdomain 2 and specify the expressions mises_smps3, u3, and v3.

6 Click OK.

7 To update these newly introduced subdomain expressions with the current solution, 
choose Update Model from the Solve menu.

8 From the Postprocessing menu choose Plot Parameters.

9 On the General page select the Surface, Deformed shape, and Geometry edges check 
boxes only.

10 In the Solution to use area select 1600 in the Parameter value list. 
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11 Click the Surface tab. On the Surface Data page type mises_all in the Expression 
edit field. On the Height Data page clear the Height data check box.

12 Click the Deform tab, then click the Subdomain Data tab in the Deformation data area. 
In the x component edit field type u_all and in the y component edit field type 
v_all.

13 Click OK.

14 Click the Zoom Extents button.

Note: At 1600 Hz, the assembly has passed the separation point and a gap between 
the components is visible in Figure 3-33.

Figure 3-33: Von Mises stresses and deflection at 1600 Hz.

Minimizing the Model and Determining the Separation Frequency

Note: This section requires that you run COMSOL Script or MATLAB.
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Finding the separation frequency is an inverse problem. The parametric solver enables 
you to find increasingly accurate solutions via narrowing the sweep range by 
inspection. A more systematic solution uses M-file scripting in which you can obtain a 
result within a specified tolerance by programmatic iterations. 

The resulting physics model describes the spinning gear at any frequency. The 
optimization problem is the inverse: find the frequency at which the gear and shaft 
separate. The optimization equation is

where intdisp is the displacement integral. 

The optimization routine does not need to know the details of the physics model, it 
simply queries for the distance between shaft and gear at any given frequency.

O P T I M I Z I N G  O N  T H E  C O M M A N D  L I N E

Export the model to COMSOL Script by choosing File>Export>FEM structure as 'fem'. 
COMSOL Script opens automatically.

The spinning gear model should now be present in the workspace as the variable fem. 

The following functions solve the optimization problem:

[freq,int_disp] = cl_gear(fem,arclength)
f = cl_gear_obj(x,fem,arclength)
fem = cl_gear_minimal(starting_point)

Note: All these functions are available from COMSOL Script or MATLAB. 

cl_gear_obj defines the value of the objective at a given frequency x:

% Solve the problem at frequency x
fem.sol=femlin(fem, ...
               'solcomp',{'u2','v3','v2','u3'}, ...
               'outcomp',{'u2','v3','u','v2','u3','v'}, ...
               'pname','f', ...
               'plist',x, ...
               'nonlin','off');
% Pick up displacement integral
pd = posteval(fem,'int_disp','edim',0,'dl',1);
% Normalize
f = pd.d/arclength;

minimize
x

        intdisp x( )
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cl_gear is the main function that defines the optimization problem and calls the 
solver.

% Start from first existing solution
% (e.g. opt.init.x = 1000;)
x0 = fem.sol.plist(1);
% Solve
[freq,int_disp] = fminsearch('cl_gear_obj',x0,[],fem,arclength);

For the initial solution, this script uses the first solution among those in the physics 
model although it is not the best one. This is for demonstration purposes only; it is 
always advisable to start with the best available solution. (In this case, the initial sweep 
range happens to have hit very close to the optimum at a frequency of 1550 Hz; this 
would normally be the solution from which to begin optimization.) 

Note that cl_gear also outputs three plots: the separation frequency during 
optimization (Figure 3-34), and the stress distribution at separation as a 2D (Figure 3-
35) and 3D plot (Figure 3-36).

To run the optimization call the cl_gear function:

[freq,int_disp]=cl_gear(fem,(2*pi*0.015)/4)

This prints the frequency and distance during the iterations and returns an optimal 
solution of 1550.19 Hz. (The second argument, (2*pi*0.015)/4, is the length of the 
circle segment and is used in cl_gear_obj to normalize the displacement integral.)

You can also solve this problem using the solvers of the COMSOL Optimization Lab. 
See “Spinning Gear” in Chapter 4 of the Optimization Lab User’s Guide for details.

Figure 3-34: Convergence of the separation frequency during optimization.
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Figure 3-35: Stress distribution at separation.

Figure 3-36: Stress distribution at separation.
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E X P L O I T I N G  M O D E L  S Y M M E T R Y

To reduce the required computation time, you can exploit the remaining model 
symmetries instead of solving the complete model as above. Figure 3-37 illustrates the 
stresses superimposed on the minimal model at the separation frequency.

Figure 3-37: Von Mises stresses superimposed on the minimal model

To run the example on the minimal model, load the modified FEM structure, then 
proceed as before.

1 At the prompt, type:

fem = cl_gear_minimal(1000);

This solves the reduced physics problem at an initial frequency of 1000 Hz. 

2 Solve the optimization problem as before, but normalize with the reduced segment 
length (1/32 of the full circle). Type: 

[freq,int_disp]=cl_gear(fem,(2*pi*0.015)/32);

Figure 3-38 shows the resulting stress distribution plot.
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Figure 3-38: Stress distribution at separation.
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Au t omob i l e  Whee l  R im

Introduction

In this model you analyze the stress distribution in a lightweight automobile wheel 
rim. Because the wheel is rotating, the analysis includes a number of different load 
cases. By using symmetric and antisymmetric boundary conditions together with 
superposition of load cases, you can perform the modeling in a fast and efficient way.

Model Definition

The wheel rim for this analysis is a ten-spoke model where the design elements of the 
geometry cause the finite element mesh to become quite large. To reduce the size of 
the problem, you can use an iterative solver and make use of the symmetry. Loading 
on the tire is composed of both the tire pressure and a rotating load transferred from 
the tire to the rim. In this case, only the geometry is symmetric, while the moving load 
is not. Because the problem is linear, you can use superposition of load cases. Any load 
on a symmetric structure can be separated into one symmetric and one antisymmetric 
load, as illustrated in Figure 3-39.

Figure 3-39: Superposition of a symmetric and an antisymmetric load case results in the 
total applied load to the symmetric geometry of the wheel rim.

For an applied load at a certain position, you can solve the model using one half of the 
geometry with symmetric and antisymmetric boundary conditions, respectively. As 
illustrated above, the two superposed solutions (symmetric + antisymmetric) represent 
the total solution.

Symmetry plane

P/2 P/2 P

P/2 -P/2

Symmetric load case Antisymmetric load case Applied load
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In the analysis, you study the problem in a coordinate system fixed to the wheel rim, 
where the load rotates around the wheel. Assume that the load on the rim extends 30° 
in each direction from the point of contact. It seems reasonable to analyze the stress 
distribution in the rim as the load passes by one of the spokes. For the current 
geometry, this movement is equivalent to a 36° rotation of the point of contact, which 
you can choose to divide into five load positions with 9° intervals between them. In 
the following figure you can see the studied locations, given by an angle of rotation in 
the rim’s coordinate system.

Figure 3-40: Angular positions for the point of contact for the chosen locations.

You can model the moving load by letting the parametric solver step through the 
values of a parameter, which you can then use in the load expression to control its 
location and distribution. Use Table 3-1 and Table 3-2 to find each load case by its 
parameter value and load angle. Combine the load cases according to Table 3-3 to 
calculate the stress distribution for load positions around the entire wheel. The 
designations used in the Combination column correspond to load cases listed in 
Table 3-1 and Table 3-2.

TABLE 3-1:  SYMMETRIC LOAD CASES

PARAMETER 
VALUE

DESCRIPTION DESIGNATION

1 Rotating load 90o sr1

2 Rotating load 81o sr2

3 Rotating load 72o sr3

4 Rotating load 63o sr4

5 Rotating load 54o sr5

6 Tire pressure st6

90°
81°
72°

63°
54°
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M A T E R I A L

Assume that the wheel rim is made of aluminum which has a Young’s modulus 
E = 70 GPa and a Poisson’s ratio ν = 0.33.

C O N S T R A I N T S

• A region around each bolt hole is fixed.

Figure 3-41: Constrained boundaries of the wheel rim.

TABLE 3-2:  ANTISYMMETRIC LOAD CASES

PARAMETER 
VALUE

DESCRIPTION DESIGNATION

2 Rotating load 81o ar2

3 Rotating load 72o ar3

4 Rotating load 63o ar4

5 Rotating load 54o ar5

TABLE 3-3:  COMBINED LOAD CASES

PARAMETER 
VALUE

DESCRIPTION COMBINATION

0 Tire pressure + Rotating load 90o st6 + sr1

9 Tire pressure + Rotating load 81o st6 + (sr2 + ar2)/2

18 Tire pressure + Rotating load 72o st6 + (sr3 + ar3)/2

27 Tire pressure + Rotating load 63o st6 + (sr4 + ar4)/2

36 Tire pressure + Rotating load 54o st6 + (sr5 + ar5)/2

Symmetric or antisymmetric boundary condition

Fixed boundary condition
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• Symmetric load cases: Symmetry condition (normal displacement fixed) in the 
symmetry plane.

• Antisymmetric load cases: Antisymmetry condition (transverse displacement fixed) 
in the symmetry plane.

L O A D S

• Tire pressure: The overpressure is 2 bar = 200 kPa. Use the last parameter step to 
apply this load.

• Rotating (“road”) load: The total load carried by the wheel corresponds to a weight 
of 1120 kg. Apply this as a pressure on the rim surfaces where the tire is in contact. 
Assume that the load distribution in the circumferential direction can be 
approximated as p = p0 cos (3ϑ) where ϑ is the angle from the point of contact 
between the rim and the tire. The loaded area thus extends 30° in each direction. 
The solver parameter, ksolv, in the following expression is used to control the 
location of the load:

Figure 3-42: Applied loads.

p p0 ksolv 6<( ) 3 y
x
---⎝ ⎠
⎛ ⎞atan

3π 11 ksolv–( )
20

------------------------------------– ⋅cos–=

y
x
---⎝ ⎠
⎛ ⎞atan

π 43 3ksolv–( )
60

------------------------------------< y
x
---⎝ ⎠
⎛ ⎞atan

π 23 3ksolv–( )
60

------------------------------------>⋅ ⋅

Rotating tire load

Tire pressure
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T H E  F I N I T E  E L E M E N T  M E S H

Meshing of curved surfaces, like many of those found in the geometry of the wheel rim, 
can cause inverted surface elements. By default these are automatically linearized to 
avoid problems during solution. The linearized elements can however give rise to high 
local stresses, since they can introduce sharp corners into the surface mesh. This does 
not influence the global accuracy of the solution, but you may be required to manually 
set the range for the stress diagrams during postprocessing due to high local stresses. 
For the regions around the spoke, you can refine the surface mesh, to avoid inverted 
and thus linearized elements.

The final finite element mesh consists of approximately 126,000 tetrahedral elements, 
giving a total of approximately 615,000 degrees of freedom.

Results

The figure below shows the von Mises stress for the rotating load at 90° superposed 
with the tire pressure. The region with the highest stresses is at the foot of the spoke 
where the load is located.

Figure 3-43: The von Mises stress distribution in the wheel rim under the combined loading 
of the tire pressure and the rotating load at the 90°position.
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The von Mises stress for the remaining point of contact positions, 81°, 72°, 63°, and 
54°, superposed with the inner pressure of the tire are shown below, illustrating how 
the stress field moves along the load path.

Figure 3-44: The von Mises stress distribution for the combined loading of the tire pressure 
and the rotating load at the locations specified in the figure. The color scale is the same as 
in Figure 3-43.

Modeling in COMSOL Multiphysics

You can build and solve two models, one containing the symmetric load cases and the 
pressure load and a second one containing the antisymmetric load cases.

point of contact at 81° point of contact at 72°

point of contact at 63° point of contact at 54°
A U T O M O B I L E  W H E E L  R I M  |  113



114 |  C H A P T E
To superpose the symmetric and antisymmetric load cases, export the FEM structures 
from these two models to COMSOL Script where you can extract and add the solution 
vectors.

Finally, to visualize the solution, import the FEM structure with the superposed 
solution back into the COMSOL Multiphysics user interface.

Model Library path: Structural_Mechanics_Module/
Automotive_Applications/wheel_rim

Modeling in the Graphical User Interface

M O D E L  N A V I G A T O R

1 Click the New button or start COMSOL Multiphysics to open the Model Navigator.

2 Select 3D from the Space dimension list.

3 Open the Structural Mechanics Module folder and then Solid, Stress-Strain. Select 
Parametric analysis.

4 Click OK.

I M P O R T  O F  C A D  G E O M E T R Y

1 On the File menu select Import>CAD Data From File.

2 In the Files of type list select COMSOL Multiphysics file.

3 Browse to the models/Structural_Mechanics_Module/
Automotive_Applications directory located in the COMSOL installation 
directory and select the file wheel_rim.mphbin.

4 Click Import.

O P T I O N S  A N D  S E T T I N G S

1 Select Options>Constants.

2 Enter the following constants in the Constants dialog box; when done, click OK.

NAME EXPRESSION

pressure 2e5[Pa]

tire_load 5.194e6[Pa]
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3 Select Options>Visualization/Selection Settings.

4 On the Rendering/Selection page, select Coarse from the Visualization mesh list.

This setting reduces the time it takes to render the geometry when switching modes 
in the user interface.

5 Click OK.

M E S H  G E N E R A T I O N

1 Select Mesh>Free Mesh Parameters.

2 On the Boundary page select boundaries and enter the parameters according to the 
following table.

3 Click OK.

4 Click the Mesh All (Free) button in the Mesh toolbar.

P H Y S I C S  S E T T I N G S  ( S Y M M E T R I C  L O A D  C A S E S )

Subdomain Settings
1 On the Physics menu select Subdomain Settings.

2 In the Subdomain selection list select subdomain 1.

3 On the Material page click the Load button to open the Materials/Coefficients Library 
dialog box.

4 In the Materials list expand Basic Material Properties then select Aluminum.

5 Click OK to apply the material and close the dialog box.

6 Click OK to close the Subdomain Settings dialog box.

Boundary Conditions
1 From the Physics menu choose Boundary Settings.

2 On the Boundaries page locate the Boundary selection list and select Boundaries 56, 
156, and 232.

BOUNDARIES MESH CURVATURE 
FACTOR

MESH CURVATURE 
CUTOFF

89, 90 0.5

72, 85, 94, 96, 98, 106, 107, 132, 
197, 206, 265

0.4

84, 92, 95, 131, 229, 251 0.4 0.02

74, 97, 145, 148, 177, 196, 207, 228 0.4 0.015
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3 On the Constraint page select Fixed from the Constraint condition list.

4 In the Boundary selection list select Boundaries 1, 26, 48, 64, and 76.

5 On the Constraint page select Symmetry plane from the Constraint condition list.

6 In the Boundary selection list select Boundaries 10–15, 18, 19, 22, 81–83, 86, 87, 
89–91, and 93.

7 On the Load page select Distributed load from the Type of load list.

8 Select Tangent and normal coord. sys. (t1, t2, n) from the Coordinate system list.

9 Enter -pressure*(load_param>5) in the Fn edit field.

10 In the Boundary selection list select Boundaries 6, 7, 92 and 94.

11 On the Load page select Distributed load from the Type of load list.

12 Select Tangent and normal coord. sys. (t1, t2, n) from the Coordinate system list.

13 In the Fn edit field enter -tire_load*(load_param<6)*cos(3*atan2(y,x)-
3*pi/20*(11-load_param))*(atan2(y,x)<(pi/60*(43-

3*load_param)))*(atan2(y,x)>(pi/60*(23-3*load_param)))

14 Click OK to close the Boundary Settings dialog box.

C O M P U T I N G  T H E  S O L U T I O N  ( S Y M M E T R I C  L O A D  C A S E S )

1 Click the Solver Parameters button on the Main toolbar.

2 On the General page, type load_param in the Parameter name edit field and the 
vector 1:6 in the Parameter values edit field.

3 In the Linear system solver list select Conjugate gradients.

4 In the Preconditioner list select Geometric multigrid.

5 Click the Settings button.

6 In the dialog box that opens select 
Linear system solver>Preconditioner>Coarse solver.

7 In the Coarse solver list box select SPOOLES.

8 Click OK.

9 Click OK.

10 Click the Solve button on the Main toolbar.

S A V I N G  T H E  S Y M M E T R I C  L O A D  C A S E S

After the problem is solved you can optionally save the model, in case you want to open 
and examine the solution to the symmetric load cases. If you do not wish to save the 
model continue with the next section.
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1 Select File>Save.

2 Navigate to the directory of your choice.

3 In the File name edit field enter wheel_rim_sym.mph.

4 Click OK.

A solved model with the symmetric load cases is available in the COMSOL installation 
directory under models/Structural_Mechanics_Module/
Automotive_Applications/wheel_rim_sym.mph.

E X P O R T I N G  T H E  S Y M M E T R I C  L O A D  C A S E S  T O  C O M S O L  S C R I P T

You can export the model to COMSOL Script as an FEM structure containing the 
geometry, mesh, physics settings, as well as the solution. From the FEM structure you 
can then extract the solution vector, which you can add to the solution vector of the 
antisymmetric load cases.

1 Select File>Export>FEM Structure.

2 In the dialog box that opens enter fem_sym_cases in the Variable name for FEM 

structure edit field.

3 Click OK. COMSOL Script opens automatically.

4 Switch back to COMSOL Multiphysics before continuing with the next step.

P H Y S I C S  S E T T I N G S  ( A N T I S Y M M E T R I C  L O A D  C A S E S )

On the symmetry plane of the geometry you need to change the boundary condition 
to antisymmetry before computing the antisymmetric load cases. Also, you can skip the 
last parameter step because it corresponds to the pressure load.

Boundary Conditions
1 On the Physics menu select Boundary Settings.

2 In the Boundary selection list select Boundaries 1, 26, 48, 64, and 76.

3 On the Constraint page select Antisymmetry plane from the Constraint condition list.

4 Click OK to close the Boundary Settings dialog box.

C O M P U T I N G  T H E  S O L U T I O N  ( A N T I S Y M M E T R I C  L O A D  C A S E S )

1 Click the Solver Parameters button on the Main toolbar.

2 On the General page, change the vector to 2:5 in the Parameter values edit field.

3 Click OK.

4 Click the Solve button on the Main toolbar.
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S A V I N G  T H E  A N T I S Y M M E T R I C  L O A D  C A S E S

Carry out the following steps to optionally save the model at this stage. If you do not 
wish to save the model continue with the next section.

1 Select File>Save As.

2 Navigate to the directory of your choice.

3 In the File name edit field enter wheel_rim_asym.mph.

4 Click Save.

A solved model with the antisymmetric load cases is available in the COMSOL 
installation directory under models/Structural_Mechanics_Module/
Automotive_Applications/wheel_rim_asym.mph.

E X P O R T I N G  T H E  A N T I S Y M M E T R I C  L O A D  C A S E S  T O  C O M S O L  S C R I P T

After the antisymmetric model is solved you can export the solution to COMSOL 
Script.

1 Select File>Export>FEM Structure.

2 In the dialog box that opens enter fem_asym_cases in the Variable name for FEM 

structure edit field.

3 Click OK. COMSOL Script opens automatically.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To obtain the total solution you need to superpose, or add, the solutions from the 
pressure load and the symmetric and antisymmetric load cases. With the two FEM 
structures exported to COMSOL Script add the solution vectors according to Table 3-
3 and create a new FEM structure, which you can import into the graphical user 
interface to visualize the results. To do this use the script wheel_rim_superpose.m, 
which you find in the sme directory located in the COMSOL installation directory.

1 With both FEM structures exported to COMSOL Script, run the script 
wheel_rim_superpose.m by typing wheel_rim_superpose at the prompt and 
pressing Return.

2 Switch back to COMSOL Multiphysics and select File>Import>FEM Structure.

3 In the Enter name of FEM structure variable enter fem_added.

4 Click OK.

5 Click the Plot Parameters button on the Main toolbar.

6 Select the General page.
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7 In the Plot type area clear the Slice check box.

8 Select the Subdomain check box.

9 In the Parameter value list select 54 to display the von Mises stress for the point of 
contact at 54°.

10 Select the Make rough plots check box.

The above feature generates plots with a bit lower quality than normal for faster and 
more memory-efficient rendering.

11 Click OK.
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 4
B e n c h m a r k  M o d e l s
This section contains examples of benchmarks models. You find more benchmark 
models in the Structural Mechanics Module User’s Guide.
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Wrapped Th i c k  C y l i n d e r  Unde r  
P r e s s u r e  and Th e rma l  L o ad i n g

Introduction

This is a benchmark model for composite-materials analysis published by NAFEMS 
(Ref. 1). A detailed description of the problem as well as analytical results enable 
comparisons between the COMSOL Multiphysics results and the benchmark values.

This is also a modified version of a test used by Taig (Ref. 2).

Model Definition

The geometry is a long, thick, and hollow cylinder consisting of two layers. The inner 
layer, with an outer radius of 25 mm, is made of an isotropic material, while the outer 
layer (outer radius of 27 mm) is made of an orthotropic material. The length of the 
cylinder is 200 mm. The material properties of the outer layer are equal in the radial 
and axial directions, and differ from those in the angular (hoop) direction.

Figure 4-1: Geometry of the problem (all dimensions in mm).

Two load cases are considered:

1 An internal pressure of 200 MPa is applied.

2 An internal pressure of 200 MPa is applied in combination with a uniform increase 
in the temperature by 130 K.

200

Orthotropic
1

2
27

25

23

material
orientation
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The purpose of including thermal effects in the second case is to simulate prestress 
caused by tension in the hoop windings.

The material properties for the isotropic material are:

• E = 210 GPa, ν = 0.3, α = 2·10-5 K−1

For the orthotropic material the properties read:

• E1 = 130 GPa, E2 = E3 = 5 GPa

• ν12 = ν13 = 0.25, ν23 = 0

• G12 = G13 = 10 GPa, G23 = 5 GPa

• α1 = 3·10−6 K−1, α2 = α3 = 2·10−5 K−1

Because of the circular symmetry of the geometry, it is sufficient to model a quarter 
cylinder, with zero normal displacement imposed as the boundary condition on each 
of the two perpendicular rectangular faces. Reflection symmetry furthermore implies 
that half of the length of the cylinder can be left out by setting the displacement in the 
axial direction to zero on the annular cross section at the middle of the cylinder.

The target solution given by NAFEMS is:

These results were obtained using standard equations for a compound cylinder, 
modified to take the orthotropic nature of the outer material into account. For a long 
cylinder, the so obtained solution is acceptable away from the ends. For this reason, 
Table 4-1 displays the solution evaluated at the annular cross section in the middle of 
the cylinder.

Modeling in COMSOL Multiphysics

For this model, you can take advantage of the possibility to implement user-defined 
coordinate systems in the Structural Mechanics Module by defining the material 

TABLE 4-1:  NAFEMS TARGET FOR THE TWO CASES.

POSITION CASE 1 CASE2

Hoop stress at inner surface (isotropic) 1565.3 MPa 1381 MPa

Hoop stress at interface (isotropic) 1429.7 MPa 1259.6 MPa

Hoop stress at interface (orthotropic) 874.7 MPa 1056 MPa

Hoop stress at outer surface (orthotropic) 759.1 MPa 936.1 MPa
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properties in cylindrical coordinates. The resulting relation between the material 
orientation and the coordinate labels in the user interface is as follows:

Note that material properties sometimes are given in an orientation that differs from 
the one required by COMSOL Multiphysics. This is such a case, since the orthotropic 
material data are ν12, ν13, and ν23, whereas COMSOL Multiphysics requires that you 
enter the Poisson ratios as νxy, νyz, and νxz—that is, ν31, ν12, and ν32, respectively. 
Since the Poisson ratios are not symmetric, each parameter must be reevaluated in the 
correct orientation. The relation between the ratios for the orthotropic case reads:

Hence

and

The shear moduli, Gij, are symmetric, and you can therefore enter the given values for 
those directly in COMSOL Multiphysics.

TABLE 4-2:  RELATION BETWEEN MATERIAL ORIENTATION AND USER INTERFACE COORDINATE LABELS.

DESCRIPTION MATERIAL 
ORIENTATION

USER INTERFACE 
COORDINATE LABEL

angular direction 1 y

axial direction 2 z

radial direction 3 x

νij

Ei
------

νji

Ej
------=

νxy
νyx Ex⋅

Ey
-------------------

ν13 E3⋅
E1

--------------------= =

νxz
νzx Ex⋅

Ez
-------------------

ν23 E3⋅
E2

-------------------- 0= = =
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Results and Discussion

A cross-section plot of the hoop stress—that is, the normal stress along the angular 
direction—gives the following result:

Figure 4-2: Cross-sectional plot of the hoop stress through the tube at z=0 (red dashed line: 
case2).

TABLE 4-3:  COMPARISON OF THE COMSOL MULTIPHYSICS RESULTS VS. NAFEMS TARGET FOR CASE 1.

POSITION COMSOL 
MULTIPHYSICS 
RESULTS CASE1

NAFEMS TARGET

case1
ERROR

Hoop stress at inner surface (isotropic) 1568.5 MPa 1565.3 MPa 0.2%

Hoop stress at interface (isotropic) 1429 MPa 1429.7 MPa 0.05%

Hoop stress at interface (orthotropic) 876 MPa 874.7 MPa 0.15%

Hoop stress at outer surface (orthotropic) 755 MPa 759.1 MPa 0.54%

TABLE 4-4:  COMPARISON OF THE COMSOL MULTIPHYSICS RESULTS VS. NAFEMS TARGET FOR CASE 2.

POSITION COMSOL 
MULTIPHYSICS 
RESULTS CASE 2

NAFEMS TARGET ERROR

Hoop stress at inner surface (isotropic) 1384.3 MPa 1381 MPa 0.24%

Hoop stress at interface (isotropic) 1259 MPa 1259.6 MPa 0.05%
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As is evident from Table 4-3 and Table 4-4, the COMSOL Multiphysics results are in 
good agreement with the NAFEMS target.

References

1. Wrapped Thick Cylinder under Pressure and Thermal Loading, NAFEMS test No. 
R0031/2, Composite Benchmarks Issue 2, NAFEMS, 2001.

2. Finite element analysis of composite materials, I.C. Taig, NAFEMS R0003, 
NAFEMS, 1992.

Model Library path: Structural_Mechanics_Module/Benchmark_Models/ 
wrapped_cylinder

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 On the New page, select 3D from the Space Dimension list and double-click on 
Structural Mechanics Module.

2 Select Solid, Stress-Strain and then Static analysis.

3 Click OK to close the Model Navigator.

G E O M E T R Y  M O D E L I N G

You obtain the geometry by extrusion of a structured mesh: first create the geometry 
in 2D, then mesh it, and finally extrude the mesh in 3D.

1 In the Draw menu choose Work-Plane Settings. Select the default one by clicking OK.

2 In the Options menu choose Axes/Grid Settings. 

3 On the Axis page set the axis settings x min as -0.01, x max as 0.03, y min as -0.01, 
and y max as 0.03.

Hoop stress at interface (orthotropic) 1058 MPa 1056 MPa 0.19%

Hoop stress at outer surface (orthotropic) 931 MPa 936.1 MPa 0.54%

TABLE 4-4:  COMPARISON OF THE COMSOL MULTIPHYSICS RESULTS VS. NAFEMS TARGET FOR CASE 2.

POSITION COMSOL 
MULTIPHYSICS 
RESULTS CASE 2

NAFEMS TARGET ERROR
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4 On the Grid page clear the Auto option and set x spacing to 5e-3, Extra x to 2.3e-2 
2.7e-2, y spacing to 5e-3, and Extra y to 2.3e-2 2.7e-2. When finished, click OK.

5 Click the 2nd Degree Bézier Curve button in the Draw toolbar, then click at the points 
(0.023, 0), (0.023, 0.023), and (0, 0.023) in that order.

6 Click the Line toolbar button, then click at point (0, 0.025).

7 Click the 2nd Degree Bézier Curve button, then click at the points (0.025, 0.025) and 
(0.025, 0) in that order.

8 Right-click to create the solid object.

Steps 5–8 create the cross section of the inner cylinder. Proceed in the same way to 
generate the outer cylinder with an inner radius of 25 mm and outer radius of 27 mm.

M E S H  G E N E R A T I O N

1 In the Mesh menu, choose Mapped Mesh Parameters.

2 Click the Boundary tab, select Boundary 1 and Boundary 2, and select the 
Constrained edge element distribution check box. Set Number of edge elements to 1.

3 Select Boundary 7, select the Constrained edge element distribution check box, and 
set the Number of edge elements to 10.

4 Click Remesh, and then click OK. This creates a structured 2D mesh. Next create the 
3D mesh by extrusion:

5 In the Mesh menu, choose Extrude Mesh. In the Extrusion parameters area, type 0.1 
in the Distance edit field.

6 Click the Mesh tab and type 4 in the Number of element layers edit field.
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7 Click OK.

O P T I O N S  A N D  S E T T I N G S

In order to properly set up the orthotropic material properties regarding the material 
orientation, a local cylindrical coordinate system is required.

1 From the Options menu, choose Coordinate Systems.

2 Click New and type Cylindrical as the name for the new coordinate system. Click 
OK.
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3 On the Workplane page click the Cylindrical coordinate system button.

4 Click OK.

The next step is to enter the constants that you use in the model.

1 From the Options menu choose Constants and enter constant names, expressions, 
and descriptions (the descriptions are optional) according to the following table:

2 Click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 Select Subdomain Settings from the Physics menu.

2 Select Subdomain 1 and select Cylindrical from the Coordinate system list.

NAME EXPRESSION DESCRIPTION

E1 1.3e11[Pa] theta-component of the Young’s modulus

E2 5e9[Pa] z-component of the Young’s modulus

E3 5e9[Pa] r-component of the Young’s modulus

nu12 0.25 theta-z Poisson’s ratio

nu32 0 r-z Poisson’s ratio

nu13 0.25 theta-r Poisson’s ratio

nu31 nu13*E3/E1 r-theta Poisson’s ration

G12 10e9[Pa] theta-z shear modulus

G32 5e9[Pa] r-z shear modulus

G31 10e9[Pa] r-theta shear modulus
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3 Type 2.1e11, 0.3, and 2e-5 in the Young's Modulus, the Poisson's ratio, and the 
Thermal expansion coeff. edit fields, respectively.

4 Select Subdomain 2. Then select Orthotropic material from the Material model list 
and Cylindrical from the Coordinate system list.

5 Enter material property values according to the following table:

6 Click OK.

Boundary Conditions
1 Open the Boundary Settings dialog box.

2 Select Boundary 2. On the Load page, select Cylindrical from the Coordinate system 
list, and enter 200e6 in the Face load (force/area) xl dir. edit field.

3 Click the Constraint tab. Select Boundaries 1, 3, 5, 7, 10, and 11.

4 Select Symmetry plane from the Constraint condition list.

5 Click OK.

QUANTITY VALUE/EXPRESSION UNIT DESCRIPTION

Ex, Ey, Ez E3 E1 E2 Pa Young’s modulus

νxy, νyz, νxz nu31 nu12 nu32 Poisson’s ratio

Gxy, Gyz, Gxz G31 G12 G32 Pa Shear modulus

αx, αy, αz 2e-5 3e-6 2e-5 1/K Thermal expansion coeff.
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C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Select the Plot Parameters dialog box from the Postprocessing menu.

2 On the General page, clear the Slice check box and select the Subdomain check box 
in the Plot type area.

3 Click the Subdomain tab and select sy normal stress local sys. in the Predefined 

quantities list.

4 Click OK.

5 From the Postprocessing menu choose Cross-Section Plot Parameters. Click the Line/

Extrusion plot button on the General page.

6 Click the Line/Extrusion tab and select sy normal stress local sys. from the Predefined 

quantities list.

7 In the Cross-section line data area, type 27e-3 in both the x1 and the y1 edit field.

8 Set the Line resolution to 600.
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9 Click OK.

Do not close the cross-sectional plot; you will use it later to compare the results with 
the thermal loading case.

This completes the first load case of the benchmark.

S E C O N D  C A S E  I N C L U D I N G  T H E R M A L  L O A D I N G

1 Open the Subdomain Settings dialog box from the Physics menu, and select both 
Subdomain 1 and Subdomain 2.

2 On the Load page, select the Include thermal expansion check box and enter 130 in 
the Strain temperature edit field.

3 Click OK.

4 Click the Solve button on the Main toolbar.

5 Open the Cross-Section Plot Parameters dialog box from the Postprocessing menu, 
and select the Keep current plot check box on the General page.

6 Click the Line/Extrusion tab; then click Line Settings.

7 Select Color and Dashed line for Line color and Line style, respectively.

8 Click OK.
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9 Click OK.
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L a r g e  De f o rma t i o n  Be am

Model Definition

In this example you study the deflection of a cantilever beam undergoing very large 
deflections. The model is called “Straight Cantilever GNL Benchmark” and is 
described in detail in section 5.2 of NAFEMS Background to Finite Element Analysis 
of Geometric Non-linearity Benchmarks (Ref. 1).

In addition to the original problem formulation, where the complete history of the 
displacement is sought, you undertake a linearized buckling analysis of the structure.

This example uses the plane stress application mode.

G E O M E T R Y

• The length of the beam is 3.2 m.

• The cross section is a square with side lengths 0.1 m.

M A T E R I A L

The beam is linear elastic with E = 2.1·1011 N/m2 and ν = 0.

C O N S T R A I N T S  A N D  L O A D S

• The left end is fixed. This boundary condition is actually compatible with beam 
theory assumptions only in the case ν = 0.

• The right end is subjected to distributed loads with the resultants 
Fx = −3.844·106 N and Fy = −3.844·103 N.

Results and Discussion

Due to the large compressive axial load and the slender geometry, this is a buckling 
problem. If you are to study the buckling and post buckling behavior of a symmetric 

y

x

3.2 m

0.1 m

0.1 m

Cross section
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problem, it is necessary to perturb the symmetry somewhat. Here the small transversal 
load serves this cause. An alternative approach would be to introduce an initial 
imperfection in the geometry.

The final state (using 1:1 displacement scaling) is shown below.

The vertical and horizontal displacements of the tip versus the scaled axial force are 
shown in the next graph, using solid and dashed lines, respectively.
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The following table contains a summary of some significant results. Because the 
reference values are given as graphs, an estimate of the error caused by reading this 
graph is added:

The results are in excellent agreement, especially considering the coarse mesh used.

The plot of the axial deflection reveals that an instability occurs at a parameter value 
close to 0.1, corresponding to the axial load 3.84·105.

This problem (without the small transverse load) is usually referred to as the Euler-1 
case. The theoretical critical load is

 (4-1)

The critical buckling load computed using COMSOL Multiphysics is 4.21·105 N, very 

RESULT COMSOL MULTIPHYSICS REFERENCE

Maximum vertical displacement at the tip -2.58 -2.58 ± 0.02

Final vertical displacement at the tip -1.33 -1.36 ± 0.02

Final horizontal displacement at the tip -5.08 -5.04± 0.04

Pc
π2EI

4L2
-------------

π2 2.1 1011 0.14

12
-----------⋅ ⋅ ⋅

4 3.22⋅
--------------------------------------------------- 4.22 105 N⋅= = =
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close to the theoretical value. The corresponding buckling mode shape is shown below.

It is often seen in practice that the critical load of an imperfect structure is significantly 
lower than that of the ideal structure.

Reference

1. Becker, A. A., Background to Finite Element Analysis of Geometric Non-linearity 
Benchmarks, NAFEMS, Ref: -R0065, Glasgow.

Model Library path: Structural_Mechanics_Module/Benchmark_Models/ 
large_deformation_beam

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select 2D in the Space dimension list on the New page in the Model Navigator.

2 Select Structural Mechanics Module>Plane Stress>Parametric analysis.
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3 Click OK.

O P T I O N S  A N D  S E T T I N G S

Select Axes/Grid Settings from the Options menu and specify axis and grid settings 
according to the following table:

G E O M E T R Y  M O D E L I N G

Click the Rectangle/Square toolbar button and click the left mouse button at (0, 0). 
Move the mouse to (3.2, 0.1) and click the left mouse button again.

P H Y S I C S  S E T T I N G S

Boundary Settings
1 Select Boundary Settings from the Physics menu.

2 Specify boundary settings according to the following tables:

Both forces are specified as forces/length (this is the reason for dividing with 0.1). The 
horizontal force is multiplied with the parameter Para, which increases the force using 
the parametric solver.

Subdomain Settings
1 Select Subdomain Settings from the Physics menu.

AXIS GRID

x min -0.1 x spacing 0.1

x max 3.3 Extra x

y min -0.1 y spacing 0.1

y max 0.2 Extra y

BOUNDARY 1 

Page Constraint

Constraint condition Fixed

BOUNDARY 4

Page Load

Fx -3.844e6/0.1*Para

Fy -3.844e3/0.1
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2 Specify material data according to the following table

Large Deformation Property
1 Select Properties from the Physics menu.

2 From the Large deformation list select On.

M E S H  G E N E R A T I O N

Click the Initialize Mesh toolbar button to generate the mesh.

C O M P U T I N G  T H E  S O L U T I O N

1 Select Solver Parameters from the Solve menu.

2 Enter the name Para in the Parameter name edit field.

3 Type 0:0.01:1 in the Parameter values edit field.

4 Click OK to close the dialog box.

5 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Select Plot Parameters from the Postprocessing menu.

2 Click the Deform tab.

3 Select the Deformed shape plot check box.

4 Clear the Auto check box, then set the Scale factor to 1. Click OK.

SUBDOMAIN 1

Page Material

E 2.1e11

ν 0

thickness 0.1
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5 Click the Zoom Extents button on the Main toolbar.

6 Select Cross-Section Plot Parameters from the Postprocessing menu.

7 Select all parameter values in the Solutions to use list.

8 Check Keep current plot.

9 Click the Point tab.

10 Enter the coordinates x = 3.2 and y = 0.05 to plot the solution at the beam end.

11 Select y-displacement in the Predefined quantities list, then click Apply.

12 Click the Line Settings button, then select Dashed line in the Line style list. Click OK.

13 Select x-displacement in the Predefined quantities list, then click OK.

C O M P U T I N G  T H E  L I N E A R I Z E D  B U C K L I N G  L O A D

A linear buckling analysis consists of two steps: First you apply the load (often a unit 
load) and run a static analysis. Then you start a second analysis, solving an eigenvalue 
problem. The result is a critical load factor causing instability of the structure.

Static Preload
1 Select Properties from the Physics menu.

2 Select Static from the Analysis type list.

3 Select Off from the Large deformation list, then click OK.

4 Select Boundary Settings from the Physics menu and change the loads according to 
the following table. When finished, click OK.

5 Click the Solve button on the Main toolbar.

Buckling Analysis
1 Select Properties from the Physics menu.

2 Select Linear buckling from the Analysis type list, then click OK.

3 Select Solver Parameters from the Solve menu.

4 Enter 1 in the Desired number of critical load factors edit field.

5 Click OK to close the dialog box.

6 Click the Restart button on the Main toolbar.

7 Select Plot Parameters from the Postprocessing menu.

BOUNDARY 4

Page Load

Fx -1/0.1 Fy 0
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8 Click the Deform tab.

9 Select the Auto check box under Scale factor, then click OK.
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T h i c k  P l a t e  S t r e s s  Ana l y s i s

In the following example you build and solve a solid mechanics model using the Solid, 
Stress-Strain application mode. 

This model describes the static stress analysis of a simple geometry. The model is 
NAFEMS Test No LE10, “Thick Plate Pressure” described on page 77 in NAFEMS 
Background to Benchmarks (Ref. 1). The computed stress level is compared with the 
values given in the benchmark report.

Model Definition

The geometry is an ellipse with an ellipse shaped hole in it. Due to symmetry in load 
and geometry, the analysis only includes a quarter of the ellipse.

M A T E R I A L

Isotropic with, E=2.1·1011 Pa, ν=0.3.

L O A D

A distributed force of 106 MPa on the upper surface pointing in the negative 
z direction.

x

y

2.0

1.
0

1.
75

1.25

Thickness 0.6 m

D

Force 1MPa

z
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C O N S T R A I N T S

• Symmetry planes, x = 0, y = 0.

• Outer surface constrained in the x and y direction.

• Mid plane on outer surface constrained in the z direction.

Results

The normal stress σy on the top surface at the inside of the elliptic hole (marked with 
D (2, 0, 0.6) in the figure) is in close agreement with the NAFEMS benchmark 
(Ref. 1). The coordinates of D are (2, 0, 0.6).

A COMSOL Multiphysics plot visualizing the stress level is shown below.

Reference

1. Davies, G. A. O., Fenner, R. T., and Lewis, R. W., Background to Benchmarks, 
NAFEMS, Glasgow, 1993.

RESULT COMSOL MULTIPHYSICS NAFEMS (REF. 1)

σy (at D) -5.45 MPa -5.38 MPa
T H I C K  P L A T E  S T R E S S  A N A L Y S I S  |  143



144 |  C H A P T E
Model Library path: Structural_Mechanics_Module/Benchmark_Models/
thick_plate

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select 3D in the Space dimension list on the New page in the Model Navigator.

2 Select Structural Mechanics Module>Solid, Stress-Strain>Static analysis and click OK.

G E O M E T R Y  M O D E L I N G

The quarter of the ellipse is drawn in a work plane and extruded into a 3D solid.

1 Select Work-Plane Settings from the Draw menu.

2 Click OK in the Work-Plane Settings dialog box to create a work plane using the 
default settings, global xy-plane at z = 0.
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3 Select Axes/Grid Settings from the Options menu, clear Auto on the Grid page, and give 
axis and grid settings according to the following table:

4 Click the Ellipse/Circle (Centered) button on the Draw toolbar and click the left 
mouse button at (0, 0) move the mouse to (2, 1) and click the left mouse button 
again to create the inner ellipse.

5 Click the Ellipse/Circle (Centered) button on the Draw toolbar and click the left 
mouse button at (0, 0) move the mouse to (3.25, 2.75) and click the left mouse 
button again to create the outer ellipse.

6 Select both ellipses and click the Difference button on the Draw toolbar to cut a hole.

7 Draw a rectangle with bottom left corner at (0, 0) and top right corner at (3.25, 
2.75).

8 Select the ellipse with a hole in and the rectangle, and then click the Intersection 
button on the Draw toolbar to create a quarter of the ellipse.

AXIS GRID

x min -4 x spacing 0.25

x max 4 Extra x

y min -3 y spacing 0.25

y max 3 Extra y
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Now you need to extrude the quarter of the ellipse to create a 3D solid object.

9 Select the quarter and then choose Extrude from the Draw menu.

10 Enter 0.3 as Distance in the Extrude dialog box and click OK.

11 Click the Array toolbar button to make a copy of the object.

12 Enter 0.3 as z Displacement and 2 as z Array size in the Array dialog box and click OK.

13 In order to remove interior boundaries but keep edges needed for the boundary 
condition, click the Create Composite Object button on the Draw toolbar.

14 Select EXT1 and EXT2 in the Object selection list, clear the Keep interior borders check 
box and click the Keep interior edges check box in the Create Composite Object dialog 
box and click OK.

15 Click the Zoom Extents button on the Main toolbar to see the finished 3D object.

P H Y S I C S  S E T T I N G S

In this section the analysis type is specified, and the edge, boundary, and subdomain 
settings is made.
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ement

 system
Application Mode Properties
The analysis type is controlled from the Application Mode Properties dialog box, opened 
from Properties on the Physics menu. Static analysis was selected already in the Model 

Navigator so there is no need to change the analysis type.

Edge Settings
Constrain the z-displacement along the midplane edge of the outer surface.

1 Select Edge Settings from the Physics menu.

2 Specify edge settings according to the following table:

Boundary Settings
Constrain the symmetry planes normal to the surface and the outer surface in the x and 
y directions. Specify the distributed force on the top surface to −106 in the z direction.

1 Select Boundary Settings from the Physics menu.

2 Specify boundary settings according to the following tables:

SETTINGS EDGE 12

Page Constraint

Rz 0

SETTINGS BOUNDARIES 1, 4, 9, 10 BOUNDARIES 7, 8

Page Constraint Constraint

Constraint condition Symmetry plane Constraint condition Prescribed displac

Coordinate system Global coordinate
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Subdomain Settings
Specify the material properties of the plate.

1 Select Subdomain Settings from the Physics menu.

2 Specify subdomain settings according to the following table:

Rx 0

Ry 0

SETTINGS BOUNDARIES 1, 4, 9, 10 BOUNDARIES 7, 8

SETTINGS BOUNDARY 6

Page Load

Fz -1E6

SETTINGS SUBDOMAIN 1

Page Material

Material model Isotropic material

E 2.1E11

ν 0.3
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M E S H  G E N E R A T I O N

1 Select the Free Mesh Parameters from the Mesh menu to open the Free Mesh 

Parameters dialog box.

2 Select Fine from the Predefined mesh sizes list, click OK to close the dialog box.

3 Click the Initialize Mesh toolbar button to mesh the geometry.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve toolbar button in order to compute the solution.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Analyze the global σy stress at D.

1 Select Plot Parameters from the Postprocessing menu.

2 On the General page, clear the Slice check box and select the Subdomain check box 
in the Plot type area 

3 Select sy normal stress global sys. from the Predefined quantities list on the Subdomain 

page.
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4 Click OK to close the dialog box and view the plot.

Looking at the plot above the stress level at D seem to be around −5·106. To get a 
more accurate value use the Data Display dialog box.

5 Select Data Display>Subdomain from the Postprocessing menu to open the Data 

Display dialog box.

6 Enter the coordinates of D in the x, y, and z coordinates edit fields. The coordinates 
are (2, 0, 0.6).
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7 Select sy normal stress global sys. from the Predefined quantities list.

8 Click OK to display the stress. The value appears in the message log. The stress value 
is -5.45 MPa, which is in close agreement with the NAFEMS value.
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K i r s c h  I n f i n i t e  P l a t e  P r ob l em

In the following example you will build and solve a model using the Plane Stress 
application mode. 

This model describes the static stress analysis of a simple geometry, a small hole in an 
infinite plate. The model is a classic benchmark, and the theoretical solution was 
derived by G. Kirsch in 1898 (see for example D. Roylance, Mechanics of Material, 
Wiley, 1996 4.) The stress level is compared with the theoretical values.

Model Definition

The model is the Kirsch plate described on page 184 in D. Roylance Mechanics of 
Materials (Ref. 1).

The infinite plate is modeled as a 2 m-by-2 m plate with a hole with a radius of 0.1 m 
in the middle. Due to symmetry in load and geometry only a quarter of the plate is 
modeled.

M A T E R I A L

Isotropic material with, E = 2.1·1011 Pa, ν = 0.3.

1000 Pa

thickness 0.1 m

1 m

1 m

0.1 m

y

x
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L O A D

A distributed force of 103 Pa on the right edge pointing in the x direction.

C O N S T R A I N T S

Symmetry planes, x = 0, y = 0.

Results

The normal stress σx is plotted as a function of the y-coordinate along the left 
symmetry edge. The theoretical stress according to D. Roylance (Ref. 1) is

In the following plot the theoretical values are plotted as a comparison.

The theoretical values from Ref. 1 are in close agreement with the result from 
COMSOL Multiphysics.

σx
1000

2
------------- 2 0.12

y2
----------- 30.14

y4
-----------+ +

⎝ ⎠
⎜ ⎟
⎛ ⎞

=
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Reference

1. Roylance, D., Mechanics of Materials, Wiley, 1996.

Model Library path: Structural_Mechanics_Module/Benchmark_Models/
kirsch_plate

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select 2D in the Space dimension list on the New page in the Model Navigator.

2 Select Structural Mechanics Module>Plane Stress>Static analysis and click OK.

O P T I O N S  A N D  S E T T I N G S

Select Axes/Grid Settings from the Options menu and give axis and grid settings 
according to the following table:

AXIS GRID

x min -0.5 x spacing 0.1

x max 1.5 Extra x
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G E O M E T R Y  M O D E L I N G

1 Click the Rectangle/Square toolbar button and click the left mouse button at (0, 0). 
Press Ctrl while moving the mouse to (1, 1) and click the left mouse button again 
to create a square.

2 Click the Ellipse/Circle (Centered) toolbar button and click the left mouse button at 
(0, 0) press Ctrl while moving the mouse to (0.1, 0.1) and click the left mouse 
button again to create a centered circle.

3 Select the square and circle and click the Difference toolbar button to cut a hole in 
the plate.

P H Y S I C  S E T T I N G S

Boundary Settings
Constrain the symmetry edges in the x and y directions. Specify the distributed force 
on the right edge to 103 in the x direction.

1 Select Boundary Settings from the Physics menu.

y min -0.5 y spacing 0.1

y max 1.5 Extra y

AXIS GRID
K I R S C H  I N F I N I T E  P L A T E  P R O B L E M  |  155



156 |  C H A P T E
2 Specify boundary settings according to the following tables:

Subdomain Settings
Specify the material properties of the plate.

1 Select Subdomain Settings from the Physics menu.

2 Specify subdomain settings according to the following table:

BOUNDARIES 1, 3

Page Constraint

Constraint condition Symmetry plane

BOUNDARY 4

Page Load

Fx 1e3

Load def. force/area

SUBDOMAIN 1

Page Material

Material model Isotropic material

E 2.1E11

ν 0.3

thickness 0.1
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M E S H  G E N E R A T I O N

Use the default mesh settings.

1 Click the Initialize Mesh toolbar button on the main toolbar to create the mesh.
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C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solve toolbar button in order to compute the solution.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Analyze the global σx stress along the symmetry line x=0 between y coordinates 0.1 
and 1.0 and compare it with the analytical solution for the infinite plate.

1 Select Cross-Section Plot Parameters from the Postprocessing menu.

2 Click the Line/Extrusion tab.

3 Select Plane Stress>sx normal stress global sys. from the Predefine quantities list in y-
axis data.

4 Type 0 and 0.1 in the X0 and Y0 edit fields.

5 Type 0 and 1.0 in the X1 and Y1 edit fields.

6 Click Apply to view the stress in an xy-diagram.

7 Click the General tab and select the Keep current plot check box to plot the analytical 
solution in the same diagram.

8 Click the Line/Extrusion tab.

9 Type 1000/2*(2+0.1^2/y^2+3*0.1^4/y^4) in the Expression field.
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10 Click OK to add the analytic stress to the x-y diagram.

View the σx normal stress in a surface plot.

11 Select Plot Parameters from the Postprocessing menu.
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12 Select sx normal stress global sys. from the Predefined quantities list and click OK.
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Th i c k  Wa l l  C y l i n d e r  B en chma r k  
P rob l em

In the following example you build and solve a model using the Plane Strain 
application mode.

The model is a thick-walled cylinder exposed to both internal and external pressure as 
well as a thermal load.

The problem is both plane and axisymmetric and has an analytical solution, which can 
be found in Abdel-Rahman Ragab (Ref. 1).

Model Definition

Both ends of the cylinder are constrained from moving in the axial direction resulting 
in plane strain conditions. Due to symmetry both in load and geometry it is sufficient 
to model a slice of the pipe.

M A T E R I A L

Isotropic material with E = 2.1·1011 Pa, ν = 0.3, and α = 1.2·10−5 °C−1.

P R E S S U R E  L O A D S

An internal pressure of 5·106 Pa and an external pressure of 2·106 Pa.

Pi = 5 MPa

Po=2 MPa

ro= 0.8 mri= 0.1 m
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T H E R M A L  L O A D

• Thermal strain temperature distribution from analytic solution of thermal problem. 
Inside temperature Ti = 500 °C, outside temperature To = 20 °C. The analytic 
solution of thermal problem from Ref. 1 is

• Thermal strain reference temperature: 20 °C.

C O N S T R A I N T S

Symmetry plane constraint condition on the symmetry planes.

Results

The stresses at the inside and outside of cylinder are compared with the analytic 
solutions according to Abdel-Rahman Ragab (Ref. 1) in the following table.

The stresses are in close agreement having a maximum relative error of 0.1%.

Reference

1. Abdel-Rahman Ragab, Salah Eldin Bayoumi, Engineering Solid Mechanics, CRC 
Press, 1998.

Model Library path: Structural_Mechanics_Module/Benchmark_Models/
thick_wall_cylinder

STRESS 
COMPONENT

COMSOL INSIDE TARGET INSIDE COMSOL OUTSIDE TARGET OUTSIDE

σx (σr) -5.0·107 -5.0·107 -2.0·107 -2.0·107

σy ( ) -1.32·109 -1.33·109 3.69·108 3.69·108

σz -1.63·109 -1.62·109 1.05·108 1.05·108

T r( )
Ti To–

r0
ri
-----⎝ ⎠
⎛ ⎞ln

------------------
r0
r
-----⎝ ⎠
⎛ ⎞ To+ln=

σθ
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Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select 2D in the Space dimension list on the New page in the Model Navigator.

2 Select Structural Mechanics Module>Plane Strain>Static analysis and click OK.

O P T I O N S  A N D  S E T T I N G S

1 Select Axes/Grid Settings from the Options menu, clear Auto on the Grid page, and give 
axis and grid settings according to the following table:

2 Select Constants from the Options menu and enter constant names, expressions, and 
descriptions (optional) according to the following table; when done, click OK.

AXIS GRID

x min -0.1 x spacing 0.1

x max 1.0 Extra x

y min -0.1 y spacing 0.1

y max 1.0 Extra y

NAME EXPRESSION COMMENTS

Ti 500[degC] Temperature on the inside of the cylinder

To 20[degC] Temperature on the outside of the cylinder
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G E O M E T R Y  M O D E L I N G

1 Choose Specify Objects>Circle from the Draw menu.

2 Enter 0.8 as the Radius in the Circle dialog box and click OK to create the circle for 
the outside of the cylinder.

3 Choose Specify Objects>Circle from the Draw menu.

4 Enter 0.1 as the Radius in the Circle dialog box and click OK to create the circle for 
the inside of the cylinder.

5 Select both circles and click the Difference toolbar button to cut a hole in the large 
circle.

6 Click the Line toolbar button and click the left mouse button at (0, 0). Move the 
mouse to (1, 0) and click the left mouse button followed by the right mouse button 
to create a line.

7 Select the line and select Copy from the Edit menu.

8 Select Paste from the Edit menu.

9 Click the Rotate toolbar button to open the Rotate dialog box.

10 Enter 30 as the rotation angle and click OK.

11 Click the Line toolbar button and click the left mouse button at the right end of the 
first line. Move the mouse to the right end of the rotated line and click the left 
mouse button followed by the right mouse button to create a third line.

ri 0.1[m] Inside radius of the cylinder

ro 0.8[m] Outside radius of the cylinder

K (Ti-To)/log(ro/ri) Constant used in analytical strain 
temperature expression

NAME EXPRESSION COMMENTS
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12 Select all three lines drawn and click the Coerce to Solid button on the Draw toolbar.

13 Select all objects and click the Intersection button on the Draw toolbar.

14 Click the Zoom Extents button on the Main toolbar to look at the finished geometry.

P H Y S I C S  S E T T I N G S

Boundary Settings
Constrain the symmetry edges in the normal direction. Specify the internal and 
external pressure.

1 Select Boundary Settings from the Physics menu.

2 Specify boundary settings according to the following tables:

BOUNDARIES 1, 2

Page Constraint

Constraint condition Symmetry plane

BOUNDARY 3 BOUNDARY 4

Page Load Load

Coordinate 
system

Tangent and normal 
coord. sys. (t, n)

Coordinate 
system

Tangent and normal 
coord. sys. (t, n)
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Subdomain Settings
Specify the material properties and thermal loading of the cylinder slice.

1 Select Subdomain Settings from the Physics menu.

2 Specify subdomain settings according to the following table:

Fn -5e7 Fn -2e7

Load def. force/area Load def. force/area

BOUNDARY 3 BOUNDARY 4

SUBDOMAIN 1 SUBDOMAIN 1

Page Material Load

Material model Isotropic 
material

Include thermal 
expansion

√

 E 2.1E11 Temp K*log(ro/sqrt(x^2+y^2))+20

 ν 0.3 Tempref 20
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M E S H  G E N E R A T I O N

1 Select Free Mesh Parameters from the Mesh menu to open the Free Mesh Parameters 

dialog box.

2 Click the Custom mesh size button.

3 Type 0.01 in the Maximum element size edit field and click OK.

4 Click the Initialize Mesh toolbar button to create and plot the mesh.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve toolbar button on the Main toolbar to compute the solution.
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P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Look at the stress levels on the inside and outside of the cylinder and compare with the 
analytical values.

View the σx normal stress in a surface plot.

1 Select Plot Parameters from the Postprocessing menu.

2 Click the Surface tab, and select Plane Strain>sx normal stress global sys. from the 
Predefined quantities list under Surface Data and click OK.
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I n - P l a n e  F r amewo r k  w i t h  D i s c r e t e  
Ma s s  and Ma s s  Momen t  o f  I n e r t i a

In the following example you build and solve a 2D beam model using the In-Plane 
Euler Beam application mode. This model describes the eigenfrequency analysis of a 
simple geometry. A point mass and point mass moment of inertia are used in the 
model. The two first eigenfrequencies are compared with the values given by an 
analytical expression.

Model Definition

The geometry consists of a frame with one horizontal and one vertical member. The 
cross section of both members has an area, A, and an area moment of inertia, I. The 
length of each member is L and Young’s modulus is E. A point mass m is added at the 
middle of the horizontal member and a point mass moment of inertia J at the corner 
(see the figure below).

G E O M E T R Y

• Framework member lengths, L = 1 m

• The framework members has a square cross section with a side length of 0.03 m 
giving an area of A = 9·10−4 m2 and an area moment of inertia of  I = 0.034/12 m4

J=m r2

E I

m

L

L/2 L/2

E IE I

y

x
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M A T E R I A L

Young’s modulus, E = 200 GPa.

M A S S

• Point mass m = 1000 kg.

• Point mass moment of inertia J = m r2 where r is chosen to L/4.

C O N S T R A I N T S

The beam is pinned at x = 0, y = 0 and x = 1, y = 1, meaning that the displacement are 
constrained whereas the rotational degrees of freedom are free.

Results and Discussion

The analytical values for the two first eigenfrequencies fe1 and fe2 are given by:

and

where ω is the angular frequency. 

The following table shows a comparison between the eigenfrequencies calculated with 
COMSOL Multiphysics and the analytical values.

EIGENMODE COMSOL MULTIPHYSICS ANALYTICAL

1 4.05 Hz 4.05 Hz

2 8.65 Hz 8.66 Hz

ωe1
2 48 E I⋅ ⋅

m L3⋅
----------------------=

ωe2
2 48 32 E I⋅ ⋅ ⋅

7 m L3⋅ ⋅
---------------------------------=

fe1
ωe1
2π
---------=

fe2
ωe2
2π
---------=
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COMSOL plots visualizing the two eigenmodes are shown below.

Figure 4-3: First eigenmode.

Figure 4-4: Second eigenmode.
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Model Library path:  
Structural_Mechanics_Module/Benchmark_Models/in-plane_framework

M O D E L  N A V I G A T O R

1 Select 2D in the Space dimension list on the New page in the Model Navigator.

2 Select Structural Mechanics Module>In-Plane Euler Beam and click OK.

G E O M E T R Y  M O D E L I N G

Two lines and an extra point at the middle of the horizontal member is drawn. 

1 Click the Line button on the Draw toolbar.

2 Draw a line from x = 0, y = 0 to x = 0, y = 1 by clicking on the left mouse button at 
these coordinates. End the line by clicking on the right mouse button. 

3 Draw a second line from x = 0, y = 1 to x = 1, y = 1.

4 Click the Point button on the Draw toolbar and place a point at x = 0.5, y = 1 (to 
do so, you may have to change the grid spacing to 0.1).
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.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu. choose Constants.

2 Enter the following constant names, expressions, and descriptions (optional); when 
done, click OK.

NAME EXPRESSION DESCRIPTION

E 2e11[Pa] Young’s modulus

I (0.03[m])^4/12 Area moment of inertia

L 1[m] Framework member length

m 1000[kg] Point mass

r L/4 Point mass radius

J m*r^2 Point mass moment of inertia

A 0.03[m]*0.03[m] Cross-sectional area

w1 sqrt(48*E*I/(m*L^3)) Angular frequency, eigenfrequency 1

w2 sqrt(48*32*E*I/(7*m*L^3)) Angular frequency, eigenfrequency 2

f1 w1/(2*pi) Eigenfrequency 1

f2 w2/(2*pi) Eigenfrequency 2
I N - P L A N E  F R A M E W O R K  W I T H  D I S C R E T E  M A S S  A N D  M A S S  M O M E N T  O F  I N E R T I A  |  173



174 |  C H A P T E
P H Y S I C S  S E T T I N G S

Point Settings
Constrain the x and y-displacements at the beam ends.

1 Select Point Settings from the Physics menu.

2 Specify constraints on the Constraint page according to the following table:

3 Specify the following mass properties on the Mass page:

POINTS 1, 4

Page Constraint

Constraint condition Pinned

SETTINGS POINT 2 POINTS 2, 3

Page Mass Mass

Quantity mass Mass moment of inertia about the z-axis

Expression m J
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Boundary Settings
Specify the material and cross section properties of the framework members

1 Select Boundary Settings from the Physics menu.

2 Specify boundary settings according to the following table:

BOUNDARIES 1–3

Page Material

E E

Page Cross Section

A A

Iyy I
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M E S H  G E N E R A T I O N

Click the Initialize Mesh button on the Main toolbar to mesh the geometry.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 Select Eigenfrequency from the Analysis list.

3 Enter 2 in the Desired number of eigenfrequencies edit field; then click OK.

4 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Plot the two first eigenmodes:

1 Select Plot Parameters from the Postprocessing menu and go to General page.

2 Clear the Surface check box and select the Boundary and Deformed shape check boxes 
in the Plot type area.

3 Select the first eigenmode/eigenfrequency from Eigenfrequency list.

4 Click the Boundary tab.

5 Select Total displacement from the Predefined quantities list.

6 Click Apply to view the plot (see Figure 4-3).

7 Select the second eigenmode/eigenfrequency from the Eigenfrequency list on the 
General page and click OK (see Figure 4-4).
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3D Th e rma l l y  L o ad ed Beam

In the following example you will build and solve a 3D beam model using the 3D Euler 
Beam application mode. This model shows how a thermally induced deformation of a 
beam is modeled. Temperature differences are applied across the top and bottom 
surfaces as well as the left and right surfaces of the beam. The deformation is compared 
with the value given by a theoretical solution given in Ref. 1.

Model Definition

G E O M E T R Y

The geometry consists of one beam. The beam cross-section area is A and the area 
moment of inertia I. The beam is L long, and the Young’s modulus is E. 

• Beam length L = 3 m

• The beam has a square cross section with a side length of 0.04 m giving an area of 
A = 1.6·10−3 m2 and an area moment of inertia of I = 0.044/12 m4

M A T E R I A L

• Young’s modulus set to E = 210 GPa

• Poisson’s ratio ν = 0.3

• Thermal expansion coefficient α = 11·10−6/°C

C O N S T R A I N T S

• Displacements in x, y, and z direction are constrained to zero at x=0, y=0, and z=0.

• Rotation around x-axis are constrained to zero at x = 0, y = 0, and z = 0 to prevent 
singular rotational degrees of freedom.

• Displacements in the x and y direction are constrained to zero at x = 3, y = 0, and 
z = 0.

T H E R M A L  L O A D

The surface temperature at each corner of the cross section is depicted in the figure 
below. The temperature varies linearly between each corner. The deformation caused 
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by this temperature distribution is modeled by specifying the temperature differences 
across the beam in the local y and z directions.

Results and Discussion

Based on Ref. 1, you can compare the maximum deformation in the global z direction 
with analytical values for a simply supported 2D beam with a temperature difference 
between the top and the bottom surface. The maximum deformation (according to 
Ref. 1) is:

where t is the depth of the beam (0.04 m), T2 is the temperature at the top and T1 at 
the bottom.

The following table shows a comparison of the maximum global z-displacement, 
calculated with COMSOL Multiphysics, with the theoretical solution.

Figure 4-5 shows the global z-displacement along the beam.

W COMSOL MULTIPHYSICS (MAX) ANALYTICAL

15.5 mm 15.5 mm

T=150

E IA

z

y

T=250

T=200

T=200

w α L⋅ 2

8 t⋅
--------------- T2 T1–( )⋅=
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Figure 4-5: z -displacement along the beam

The analytical values for the maximum total camber can be calculated by:

where v is the maximum deformation in the global y direction which is calculated in 
the same way as w.

A comparison of the camber calculated with COMSOL Multiphysics and the analytical 
values are shown in the table below.

Figure 4-6 shows the total camber along the beam.

TOTAL CAMBER COMSOL MULTIPHYSICS ANALYTICAL

22 mm 21.9 mm

δ w2 v2
+=
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Figure 4-6: Camber along the beam

Reference

1. Young, W, Roark’s Formulas for Stress & Strain, McGraw-Hill, 1989.

Model Library path: Structural_Mechanics_Module/Benchmark_Models/
thermally_loaded_beam

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select 3D in the Space dimension list on the New page in the Model Navigator.

2 Select Structural Mechanics Module>3D Euler Beam>Static analysis and click OK.
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G E O M E T R Y  M O D E L I N G

1 Select Line from the Draw menu.

2 Enter line coordinates according to the figure below and click OK.
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P H Y S I C S  S E T T I N G S

Point Settings
Constrain the x-, y-, and z-displacements at the beam ends.

1 Select Point Settings from the Physics menu.

2 Specify constraints on the Constraint page according to the following table:

POINT 1 POINT 2

Page Constraint Constraint

Constraint condition Prescribed displacement Prescribed displacement

Rx 0

Ry 0 Ry 0

Rz 0 Rz 0

Rthx 0
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Edge Settings
Specify the material and cross section properties of the beam.

1 Select Edge Settings from the Physics menu.

2 Specify edge settings according to the following table:

EDGE 1

Page Material

Quantity Expression

E 210e9

ν 0.3

α 11e-6

Page Cross Section

Quantity Expression

A 0.04*0.04

Iyy 0.04^4/12

Izz 0.04^4/12

heighty 0.04

heightz 0.04
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Page Load

Include thermal expansion √

Temp 200

Tempref 0

dTy 50

dTz 50

EDGE 1
R  4 :  B E N C H M A R K  M O D E L S



M E S H  G E N E R A T I O N

Use the default mesh settings.

Click the Initialize Mesh toolbar button to mesh the geometry.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Plot the global displacement in the z direction and the total displacement using a 
domain plot.

1 Select Domain Plot Parameters from the Postprocessing menu.

2 Click the Line/Extrusion tab.

3 Select Edge 1 from the Edge selection list and select z-displacement from the 
Predefined quantities list.

4 Click Apply; see Figure 4-5.

5 Enter sqrt(w^2+v^2) in the Expression edit field and click OK (see Figure 4-6).
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I n - P l a n e  T r u s s

In the following example you build and solve a simple 2D truss model using the In-
Plane Truss application mode. This model calculates the deformation of a simple 
geometry. The example is based on problem 11.1 in Aircraft Structures for 
Engineering Students by T.H.G Megson (Ref. 1). The results are compared with the 
analytical results given in Ref. 1.

Model Definition

The geometry consists of a square symmetrical truss built up by five members. All 
trusses have the same cross-sectional area A. The side length is L and the Young’s 
modulus is E.

G E O M E T RY

• Truss side length, L = 2 m

• The truss members have a circular cross section with a radius of 0.05 m

M A T E R I A L

Aluminum: Young’s modulus, E = 70 GPa

C O N S T R A I N T S

Displacements in both directions are constrained at a and b.

L, E, A

F

ab

c

d
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L O A D

A vertical force F of 50 kN is applied at the bottom corner.

Results and Discussion

The following table shows a comparison between the results calculated with the 
Structural Mechanics Module and the analytical results from Ref. 1.

The results are in total agreement.

Figure 4-3 shows a plot visualizing the deformed geometry together with the axial 
forces in the trusses.

Figure 4-7: Deformed geometry and axial forces.

RESULT COMSOL MULTIPHYSICS REF. 1

Displacement at d -5.15E-4 m -5.15E-4 m

Displacement at c -2.13E-4 m -2.13E-4 m

Axial force in member ac=bc -10.4 kN -10.4 kN

Axial force in member ad=bd 25.0 kN 25.0 kN

Axial force in member cd 14.6 kN 14.6 kN
I N - P L A N E  TR U S S  |  187



188 |  C H A P T E
Reference

1. T.H.G Megson, Aircraft Structures for Engineering Students, Edward Arnold, 
1985, p. 404.

Model Library path:  
Structural_Mechanics_Module/Benchmark_Models/in-plane_truss

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select 2D in the Space dimension list on the New page in the Model Navigator.

2 Select Structural Mechanics Module>In-Plane Truss and click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, choose Axes/Grid Settings.
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2 Set axis and grid settings according to the following table (clear the Auto check box 
before entering the grid spacing):

G E O M E T R Y  M O D E L I N G

1 Click the Line button on the Draw toolbar.

2 Double-click the SOLID button in the Status bar, to turn off the solid feature when 
drawing the lines.

3 Draw a line from (0, 0) through (0, 2), (2, 2), (2, 0), (0, 0), and (2, 2) by clicking 
on the left mouse button at these coordinates. End the line by clicking on the right 
mouse button. 

4 Click the Rotate button on the Draw toolbar to open the Rotate dialog box.

AXIS GRID

x min -4 x spacing 2

x max 4 Extra x -

y min -3 y spacing 2

y max 3 Extra y -
I N - P L A N E  TR U S S  |  189



190 |  C H A P T E
5 Enter 45 as the rotating angle and click OK to rotate the truss.

6 Click the Zoom Extents button on the Main toolbar.

P H Y S I C S  S E T T I N G S

One helpful feature when specifying loads and constraints are symbols. Use this feature 
to see where you have specified constraints and applied forces.

1 Select Preferences from the Options menu to open the Preferences dialog box.

2 Click the Visualization tab, and select All domain types from the Show list in the 
Symbols area.
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3 Select the Automatically update check box and click OK.

Point Settings
Constrain the x- and y-displacements at the left and right corners of the truss.

1 Select Point Settings from the Physics menu.

2 Specify constraints on the Constraint page according to the following table:

POINTS 1, 4

Page Constraint condition

Pinned
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Specify the vertical force at the bottom corner:

1 Click the Load tab in the Point Settings dialog box.

2 Select Point 2 and enter -50e3 in the Fy edit field.

3 Click OK to close the Point Settings dialog box.

Boundary Settings
Specify the material and cross-section properties of the truss members:

1 Select Boundary Settings from the Physics menu.

2 Select all five boundaries.
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3 Click the Load button on the Material page to open the Material/Coefficients Library 
dialog box.

4 Select Aluminum from Basic Material Properties in the Materials list and click OK.
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5 Click the Cross Section tab, and enter pi/4*0.05^2 in the Cross section area (A) edit 
field.

6 Click OK to close the Boundary Settings dialog box.

M E S H  G E N E R A T I O N

When using the default option (the Constrain edge to be straight (truss) button in 
selected on the Material tab in the Boundary Settings dialog box) the mesh is not critical. 
The Allow edge to have sag (cable) option makes the mesh critical. The reason for this 
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is that the internal nodes along the boundary become singular because they do not 
have any stiffness perpendicular to the boundary. You can solve this by using a very 
coarse mesh with no internal nodes along the boundaries. For more information, see 
“Straight Edge Option” on page 281 of the Structural Mechanics Module User’s 
Guide.

In this model, use the default mesh settings, as the model uses the default option for 
a straight edge (the Constrain edge to be straight (truss) button is selected on the 
Material page in the Boundary Settings dialog box).

Click the Initialize Mesh toolbar button to mesh the geometry.

C O M P U T I N G  T H E  S O L U T I O N

Click the = toolbar button to start the analysis and compute the solution.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Plot the deformed geometry together with the axial forces in the truss members.

1 Select Plot Parameters from the Postprocessing menu.

2 Select the Deformed shape check box in the Plot type area on the General page.

3 Click the Boundary tab, and select Axial force from the Predefined quantities list.
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4 Click OK to close the dialog box and view the plot.
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S c o r d e l i s - L o  Roo f  S h e l l  B en c hma r k

In the following example you build and solve a 3D shell model using the Shell 
application mode. This model is a widely used benchmark model denoted the 
Scordelis-Lo roof. The computed maximum z-deformation is compared with the value 
given in Ref. 1.

Model Definition

G E O M E T R Y

The geometry consists of a curved face as depicted in the figure below. Only one 
quarter is analyzed due to symmetry.

• Roof length 2L = 50

• Roof radius R = 25.

M A T E R I A L

• Isotropic material with Young’s modulus set to E = 4.32·108.

• Poisson’s ratio ν = 0.0.

Symmetry edge

Free edge

y

x

z
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C O N S T R A I N T S

• The outer straight edge is free.

• The outer curved edge of the model geometry is constrained in the y and 
z directions.

• The straight symmetry edge on the top of the roof has symmetry edge constraints, 
that is, translation in the y direction is constrained as well as the rotations about the 
x-axis and z-axis.

• The curved symmetry edge has also symmetry constraints, that is, translation in the 
x direction is constrained as well as the rotations about the y-axis and z-axis.

L O A D

A force per area unit of −90 N/m2 in the z direction is applied on the surface.

Results and Discussion

The maximum deformation in the global z direction with the default mesh settings is 
depicted in Figure 4-8.

Figure 4-8: z-displacement with 242 elements.
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The reference solution quoted in Ref. 1 for the midside vertical displacement is 
0.3086 m. The FEM solution converges toward 0.302 m with a refined mesh; see 
Figure 4-9 and Figure 4-10.

Figure 4-9: z-displacement with 832 elements.
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Figure 4-10: z-displacement with 1942 elements 

This value (0.302) is in fact observed in other published benchmarks treating this 
problem as the value which this problem converges toward.

Reference

1. MacNeal R.H., Harder R.L., Proposed Standard Set of Problems to Test Finite 
Element Accuracy, Finite Elements in Analysis and Design, 1, 1985.

Modeling Using the Graphical User Interface

Model Library path: Structural_Mechanics_Module/Benchmark_Models/
scordelis_lo_roof

M O D E L  N A V I G A T O R

1 Select 3D in the Space dimension list on the New page in the Model Navigator.
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2 Select Structural Mechanics Module>Shell>Static analysis and click OK.

G E O M E T R Y  M O D E L I N G

1 Select Work-Plane Settings from the Draw menu.

2 Click OK in the Work-Plane Settings dialog box. This gives you the default work 
plane.

3 Click the Line button and draw a line from (0, 25) to (25, 25). 

4 Select Revolve from the Draw menu.

5 Type 90 in the α1 edit field.

6 Type 90+40 in the α2 edit field.

7 Type 1 in the Second point x edit field.

8 Type 0 in the Second point y edit field

9 Click OK.
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P H Y S I C S  S E T T I N G S

Edge Settings
1 Select Edge Settings from the Physics menu.

2 Specify constraints on the Constraint page according to the following table:

EDGE 1 EDGE 3 EDGE 4

Page Constraint Constraint Constraint

Constraint condition Prescribed

displacement

x-z symmetry 
plane

y-z symmetry 
plane

Ry 0

Rz 0
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Constraint settings for Edge 1:

Constraint settings for Edge 3:
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Constraint settings for edge 4:

Boundary Settings
Specify the material properties and surface load in the Boundary Settings dialog box.

1 Select Boundary Settings from the Physics menu.

2 Specify boundary settings according to the following table:

BOUNDARY 1

Page Material

E 4.32e8

ν 0.0

thickness 0.25

Page Load

Fz -90
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M E S H  G E N E R A T I O N

Use the default mesh settings. Click the Initialize Mesh toolbar button to mesh the 
geometry.
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C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Plot the global displacement in the z direction and the deformed shape.

1 Select Plot Parameters from the Postprocessing menu.

2 Clear the Slice check box in the Plot type area on the General page.

3 Select the Deformed shape and Boundary check boxes in the Plot type area.

4 Click the Boundary tab.

5 Select z-displacement from the Predefined quantities list.

6 Click OK.

Check the convergence by solving the problem twice with different mesh refinements.

M E S H  G E N E R A T I O N

1 Choose Free Mesh Parameters from the Mesh menu.

2 Select Finer from the Predefined mesh sizes list.

3 Click the Remesh button.

4 Click OK.
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C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button.

M E S H  G E N E R A T I O N

1 Select Free Mesh Parameters from the Mesh menu.

2 Select Extra fine from the Predefined mesh sizes list.

3 Click the Remesh button.

4 Click OK.
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C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button.
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B i o e n g i n e e r i n g
This section contains examples from the bioengineering field.
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F l u i d - S t r u c t u r e  I n t e r a c t i o n  i n  a  
Ne two r k  o f  B l o od V e s s e l s

Introduction

This model studies a portion of the vascular system, in particular the upper part of the 
aorta (Figure 5-1). The aorta and its ramified blood vessels are embedded in biological 
tissue, specifically the cardiac muscle. The flowing blood applies pressure to the 
artery’s internal surfaces and its branches, thereby deforming the tissue. The analysis 
consists of two distinct but coupled procedures: first, a fluid-dynamics analysis 
including a calculation of the velocity field and pressure distribution in the blood 
(variable in time and in space); second, a mechanical analysis of the deformation of the 
tissue and artery. In this model, any change in the shape of the vessel walls does not 
influence the fluid domain, which implies that there is only a 1-way fluid-structural 
coupling. However, in COMSOL Multiphysics it is possible to simulate a 2-way 
coupling using the ALE (arbitrary Lagrangian-Eulerian) method.

Figure 5-1: The model domain consists of part of the aorta, its branches, and the 
surrounding tissue.
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Model Definition

Figure 5-2 shows two views of the problem domain, one with and one without the 
cardiac muscle. The model’s mechanical analysis must consider the cardiac muscle 
because it presents a stiffness that resists artery deformation due to the applied pressure.

Figure 5-2: A view of the aorta and its ramification (branching vessels) with blood 
contained, shown both with (left) and without (right) the cardiac muscle.

The main characteristics of the analyses are:

•  Fluid dynamics analysis

Here the model solves the Navier-Stokes equations. This analysis considers only the 
subdomains of the blood. At the point where the model brings the vessels to an 
abrupt end it represents the load with a known pressure distribution.

• Mechanical analysis

This analysis is highly nonlinear due to the assumption of a large displacement and 
the constitutive behavior of the materials (the model describes the response of the 
artery and cardiac muscle with an hyperelastic law similar to those for rubber 
components). Only the subdomains related to the biological tissues are active in this 
analysis. The model represents the load with the pressure distribution it computes 
during the fluid-dynamics analysis.

A N A L Y S I S  O F  R U B B E R - L I K E  T I S S U E  A N D  A R T E R Y  M A T E R I A L  M O D E L S

The analysis of rubber-like elastomers is generally a difficult task for several reasons:

• The material can undergo very large strains (finite deformations).

• The stress-strain relationship is generally nonlinear.

• Many rubber-like materials are almost incompressible. You must revise standard 
displacement-based finite element formulations in order to arrive at correct results 
(mixed formulations).
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You must pay particular attention to the definition of stress and strain measures. Finite 
deformations are displacements where standard assumptions about infinitesimal 
displacements are no longer valid. It is permissible to consider finite deformations in a 
model when:

• Significant rigid-body rotations occur (finite rotations).

• The strains are no longer small (larger then a few percent).

• The loading of the body depends on the deformation.

Luckily, all of these issues are dealt with in the hyperelastic material model built-in the 
Structural Mechanics Module.

M A T E R I A L S

The model in this discussion uses the following material properties:

• Blood

- density = 1060 kg/m3

- dynamic viscosity = 0.005 Ns/m2

• Artery

- density = 960 kg/m3

- Neo-Hookean hyperelastic behavior: the coefficient µ equals 6,204,106 N/m2, 
while the bulk modulus equals 20 µ and corresponds to a value for Poisson’s 
ratio, ν, of 0.45. An equivalent elastic modulus equals 1.0·107 N/m2.

• Cardiac muscle

- density = 1200 kg/m3

- Neo-Hookean hyperelastic behavior: the coefficient µ equals 719,676 N/m2, 
while the bulk modulus equals 20 µ and corresponds to a value for Poisson’s 
ratio, ν, of 0.45. An equivalent elastic modulus equals 1.16·106 N/m2.

F L U I D  D Y N A M I C S  A N A L Y S I S

The fluid dynamics analysis considers the solution of the 3D Navier-Stokes equations. 
You can do so in both a stationary case or in the time domain. To establish the 
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boundary conditions, the model uses six pressure conditions with the configuration in 
Figure 5-3.

Figure 5-3: Boundary conditions for the fluid-flow analysis.

The pressure conditions are:

• Section 1: 11,208 N/m2

• Section 2: 11,192 N/m2

• Section 3: 11,148 N/m2

• Section 4: 11,148 N/m2

• Section 5: 11,148 N/m2

• Section 6: 11,120 N/m2

For the time-dependent analysis, the model uses a simple trigonometric function to 
vary the pressure distribution over time:

 (5-1)

You can implement this effect in COMSOL Multiphysics with an expression that you 
define on the active subdomain.

Results and Discussion

First examine the steady flow field so as to compare its result to the transient case. 
Figure 5-4 shows a slice plot of the velocity field (that gives values in m/s) and a 
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streamline plot (that shows velocity as a directional vector). The model is of moderate 
size with a total of 10,000 elements for the fluid-flow analysis.

Figure 5-4: Velocity field color slice and flow lines in the aorta and its ramification 
(branching).

In comparison, the transient analysis reveals only a small difference between two 
pressure distributions (the one computed with the time-dependent analysis, and the 
one from the stationary analysis with pressure defined as in Equation 5-1). In other 
words, the pressure field reaches its steady state very quickly when changing the 
boundary conditions.

Figure 5-5 shows the pressure at a point in center of the vessel as computed with a 
time-dependent model where the boundary conditions change at a slow, continuous 
rate. The small difference implies that you can scale the pressure computed in a 
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fluid-dynamics stationary analysis in the subsequent parametric nonlinear mechanical 
analysis by multiplying the value p with the Amplitude function in Equation 5-1.

Figure 5-5: Pressure at a given point in the transient model (data points) and the 
steady-flow model (solid line). Both cases take the value of the boundary condition from 
Equation 5-1, but the steady-flow model varies time using the parametric solver assuming 
a steady-state condition at every point.

A final model accounts for the influence of large displacements, and it accounts for the 
hyperelastic behavior of the biological tissues. 

Figure 5-6 shows the total displacement at the peak load (after 1 s).
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Figure 5-6: Displacements in the blood vessel using a hyperelastic model.

Model Library path: Structural_Mechanics_Module/Bioengineering/
blood_vessel

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Double-click the COMSOL Multiphysics icon on your desktop to open the Model 

Navigator.

2 Select 3D from the Space dimension list.

3 In the list of application modes, select the COMSOL Multiphysics>Fluid Dynamics> 

Incompressible Navier-Stokes application mode.

4 Click OK.
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You solve the problem using SI units (meters, seconds, newtons, and so on). Because 
the plane-view geometry is measured in centimeters, first enter the geometry as if the 
length unit were centimeter and then scale each coordinate direction by 10−2 to obtain 
the geometry in SI units (meters). This approach reduces the amount of typing and 
reduces the risk of errors when building the geometry.

O P T I O N S  A N D  S E T T I N G S

Constants
1 Select Constants from the Options menu and enter constants with names, 

expressions, and descriptions (optional) according to the following table:

2 Click OK.

G E O M E T R Y  M O D E L I N G

Import the model geometry from a CAD file:

1 Choose File>Import>CAD Data From File.

2 In the Look in list browse to the folder models/Structural_Mechanics_Module/
Bioengineering in your COMSOL Multiphysics installation directory.

3 Select the file blood_vessel.mphbin, then click Import.

NAME EXPRESSION DESCRIPTION

p1 11208[Pa] Pressure condition 1

p2 11192[Pa] Pressure condition 2

p3 11148[Pa] Pressure condition 3

p4 11148[Pa] Pressure condition 4

p5 11148[Pa] Pressure condition 5

p6 11120[Pa] Pressure condition 6

rho_blood 1060[kg/m^3] Density of blood

eta_blood 0.005[Pa*s] Dynamic viscosity of blood

m_muscle 719676[Pa] Neo-Hookean hyperelastic behavior, 
mu coefficient for muscle

v_muscle 20*m_muscle Bulk modulus for muscle

rho_muscle 1200[kg/m^3] Density of muscle

m_artery 6204106[Pa] Neo-Hookean hyperelastic behavior, 
mu coefficient for artery

v_artery 20*m_artery Bulk modulus for artery

rho_artery 960[kg/m^3] Density of artery
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Rescaling the Geometry
1 Press Ctrl+A to select all objects.

2 Click the Scale button on the Draw toolbar.

3 Type 1e-2 in the x, y, and z edit fields

4 Click OK.

5 Click the Zoom Extents button on the Main toolbar.

P H Y S I C S  S E T T I N G S

Start by defining the physical properties in the different subdomains.

Subdomain Settings
1 Select Subdomain Settings from the Physics menu.

2 Select Subdomains 1 and 2 in the Subdomain Selection list and clear the Active in this 

subdomain box to deactivate these subdomains.

3 Select Subdomain 3 and type rho_blood in the Density edit field and type 
eta_blood in the Dynamic Viscosity edit field. Note that you have already defined 
these variables.

4 Click OK.

Boundary Conditions
Before defining the boundary conditions, you need to define an expression for the 
heart frequency.

1 Select Expressions>Scalar Expressions in the Options menu.

2 Type amp in the Name column and type (t<=0.5)*sin(pi*t[1/s])+ 
(t>0.5)*(1.5-0.5*cos(-2*pi*(0.5-t[1/s]))) in the Expression column.

The reason for the unit multiplication with [1/s] is to make the input to the 
trigonometric functions nondimensional.

3 Select Boundary Settings in the Physics menu.

4 In the Boundary selection list, select Boundary 38. Set the Boundary type to Inlet and 
the Boundary condition to Pressure, no viscous stress. In the Pressure edit field, type 
p1*amp.

5 Select Boundaries 9, 19, 41, 70, and 86 and set the Boundary type to Outlet.
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6 Select each of the six boundaries in turn and specify the Pressure according to the 
following table:

For all other boundaries, the default No slip boundary condition applies.

7 Click OK.

M U L T I P H Y S I C S

The next step is to add the structural analysis to the existing model.

1 Select Model Navigator in the Multiphysics menu.

2 Select the Solid, Stress-Strain>Quasi-static analysis application mode from Structural 

Mechanics Module to the model.

3 Click Add, then click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 Select Subdomain Settings from the Physics menu.

2 Select Subdomain 3 in the Subdomain selection list and clear the Active in this 

subdomain box.

3 Select Subdomain 1 and select Hyperelastic material in the Material model list.

4 Type m_muscle in the Initial shear modulus edit field, v_muscle in the Initial bulk 

modulus edit field and rho_muscle in the Density edit field.

5 Click the Element tab and select Lagrange-linear in the Predefined elements 
drop-down menu.

6 Click the Material tab. Select Subdomain 2 and select Hyperelastic material in the 
Material model drop-down list.

7 Type m_artery in the Initial shear modulus edit field, v_artery in the Initial bulk 

modulus edit field and rho_artery in the Density edit field.

8 Click the Element tab and select Lagrange-linear in the Predefined elements list.

9 Click OK.

10 Select Properties from the Physics menu

11 Select On in the Large deformation list.

12 Click OK.

PROPERTY BOUNDARY 9 BOUNDARY 19 BOUNDARY 41 BOUNDARY 70 BOUNDARY 86

p0 p3*amp p2*amp p4*amp p5*amp p6*amp
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Boundary Conditions
1 Select Boundary Settings from the Physics menu.

2 Select Boundaries 1–6, 12, 26, 27, 30, 33, 64, 67, 85, and 87.

3 Select Roller from the Constraint condition list.

4 Select the remaining boundaries: 10, 11, 16, 17, 20, 21, 23, 24, 36, 37, 39, 40, 42, 
43, 45, 46, 50, 51, 52, 53, 58, 59, 61, 62, 68, 69, 71, 72, 75, 76, 79, 80, 82, and 
83. You can select all these by clicking Select by group and then selecting one of the 
boundaries in the list.

5 Click the Load tab.

6 Type -p*nx_smsld in the Fx (Face load x dir.) edit field.

7 Type -p*ny_smsld in the Fy (Face load y dir.) edit field.

8 Type -p*nz_smsld in the Fz (Face load z dir.) edit field.

9 Click OK.

M E S H  G E N E R A T I O N

Click the Initialize Mesh button.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 Select Time dependent in the Solver list.

3 Type 0:0.05:1 in the Times edit field.

4 Select UMFPACK from the Linear system solver list.

5 Click OK.

6 Click the Solve Manager button.

7 Click the Solve For tab.

8 Select Incompressible Navier-Stokes from the Solve for variables list.

9 Click the Solve button.

10 Click the Initial Value tab.

11 Click the Store Solution button.

12 In the Store Solution dialog box, make sure that all time steps are selected, then click 
OK.

13 Select Stored solution in the Values of variables not solved for and linearization point 

area.
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14 Select All from the Solution at time list.

15 On the Solve For page, select Solid Stress-Strain from the Solve for variables list.

16 Click OK to close the Solver Manager dialog box.

17 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G
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Dynam i c s  o f  a  B l a dd e r

Introduction

This model is related to a functional study of the main organs of the female pelvic floor 
and the phenomenon under investigation is the dynamic response of a bladder 
subjected to a particular load, in this case a short cough. From a clinical point of view 
and in particular in urology, a specific test is available in order to establish the degree 
of functionality of the bladder. This test and the related measurements are more 
properly defined as “urodynamics.” This model provides an analysis of the 
displacements and stresses that the bladder can be subjected to during such a test.

The aim of the analysis is to reproduce the dynamics of the bladder, placed in the pelvic 
floor, when subjected to the movement caused by a short cough. The pelvic floor is 
characterized by the presence of numerous organs, bones, and muscles. To simplify the 
analysis, the model includes four principal components: the bladder itself (full of fluid), 
the muscles of the pelvic floor, and the two pelvis bones shown in Figure 5-7 below. 
One of the main difficulties of the model is the generation of the geometry of the 
various components from the CAT (computed axial tomography) scan images; here 
COMSOL Multiphysics’ interface with COMSOL Script comes very handy.

Model Definition

Figure 5-7 shows the main components considered in the finite element model: the 
bladder, the pelvis muscles, and a portion of the bones of the pelvis to which the 
muscles are attached.
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Figure 5-7: The bladder placed on the muscles of the pelvic floor, between the pelvic bones.

T H E  G E O M E T R Y

The geometry of the bladder is derived entirely from CAT scan images, illuminated on 
a diaphanoscope, in order to get the profiles of the bladder in various sections. The 
distance between the cross sections given in each of the scan is 1 cm.

The bladder can be considered as a little bag with variable thickness that at rest is 5 mm 
on average. For this particular case, a CAT scan was executed on a patient placed in a 
vertical position, with the bladder filled with fluid so that the thickness is 2 mm. 
Figure 5-8 shows a section of the bladder including the junction with the urethra. The 
thin three-dimensional structure is built up using contours of the cross sections of the 
internal and external walls of the bladder. Figure 5-9 shows an example of such a set 
of cross sections obtained from a CAT scan.

Bladder

Pelvis bones

Coccyx

Pelvis muscles
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Figure 5-8: Cross section of the bladder including the junction with the urethra.

Each section is defined by 24 points taken with 15 degrees angles around the central 
axis of the structure. 22 sections (11 external and 11 internal) are collected in 22 spline 
curves and two groups of 11 splines are then joined to create two 3D geometries using 
the “loft” function. Two COMSOL Script files automatize this process.

Figure 5-9: Contours of the internal walls of the bladder. The geometry is defined by 11 
contour curves along the depth of the bladder.
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The created geometry objects are exported to COMSOL Multiphysics from the 
COMSOL Script workspace. The remaining part of the model is created using the 
CAD tools in COMSOL Multiphysics. Figure 5-10 shows the resulting geometry as 
seen in the COMSOL Multiphysics user interface.

Figure 5-10: Bladder geometry used in the COMSOL Multiphysics model.
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The resulting mesh consists of about 40,000 elements, which gives about 25,000 
degrees of freedom. Figure 5-11 shows the mesh generated by COMSOL 
Multiphysics.

Figure 5-11: Finite element mesh created by COMSOL Multiphysics.

I N P U T  D A T A

Biological tissues in general have peculiar constitutive properties and can also show 
time-dependent behavior. It is difficult to find literature data for such materials, but in 
the last few years a lot of research has been dedicated to the mechanical properties of 
biological tissue. One possible way of treating these materials is through the use of 
hyperelastic models. However, this model (where the mechanical loads are comparably 
small) uses linear elastic behavior for all materials. Also the fluid that fills the bladder is 
treated as an elastic material with a very small value of Young’s modulus. This is 
acceptable in this case because only the mass contribution of the fluid during the 
dynamic analysis is of interest. The material properties are defined as follows:

Bladder
• Density = 956 kg/m3

• Young’s modulus = 3.5·105 N/m2

• Poisson’s ratio ν = 0.45
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Pelvis muscles
• Density = 1200 kg/m3

• Young’s modulus = 1.162·106 N/m2

• Poisson’s ratio ν = 0.4

Pelvis bones
• Density = 2570 kg/m3

• Young’s modulus = 1.0·109 N/m2

• Poisson’s ratio ν = 0.3

Fluid
• Density = 1000 kg/m3

• Young’s modulus = 1.0·103 N/m2

• Poisson’s ratio ν = 0.495

D Y N A M I C  A N A L Y S I S

The aim is to simulate the effect of two short coughs and the relaxation of the modeled 
components after such an excitation. The coughs are applied by imposing a 
displacement to the pelvis bones because these are almost rigid. The time duration of 
each single cough is 0.5 seconds (2 Hz), and the model assumes that a sinusoidal 
amplitude describes the applied displacements. A vertical and a rotational motion is 
applied for 1 second. During the remaining part of the time interval the imposed 
displacements are set to zero.

The critical damping ratio for low-frequency damping is estimated to be 0.2. The 
Rayleigh damping parameters are calculated assuming this damping ratio at two 
frequencies (1 Hz and 3 Hz) around the frequency of the cough (2 Hz). You can do 
this at the COMSOL Script command prompt with the following commands:

b = [0.2;0.2];
A = [1/(2*1*2*pi) 2*pi*1/2; 1/(2*3*2*pi) 2*pi*3/2];
% A*damp = b
damp = A\b;
alphadM = damp(1)
betadK = damp(2)

Resulting in αdM = 1.88 and βdK = 0.016.

For more details about damping, see the section “Damping” on page 121 in the 
Structural Mechanics Module User’s Guide.
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Results

Figure 5-12 shows the vertical displacement after 0.14 seconds of the analysis, 
corresponding to the positive peak value of the displacement during the first cough.

Figure 5-12: Y-displacement of the bladder taken as a snap shot after 0.14 s of the analysis.
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Figure 5-13 shows a cross-sectional plot of the same displacement.

Figure 5-13: Vertical cross section of the displacement of the bladder after 0.14 s.

It is also of interest to determine the stresses in the bladder and their variation during 
the process. Figure 5-14 shows the distribution of the Von Mises stress after 
0.14 seconds along the vertical cross section corresponding to the displacements in 
Figure 5-13.
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Figure 5-14: Von Mises stresses along a vertical cross section of the bladder after 0.14 s.

Model Library path: Structural_Mechanics_Module/Bioengineering/
bladder

Modeling Using the Graphical User Interface

1 Click on the COMSOL Multiphysics icon to open the Model Navigator.

2 Select 3D from the Space dimension list.

3 In the list of application modes, select the Structural Mechanics 

Module>Solid, Stress-Strain>Transient analysis application mode.
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4 Click OK.

This presentation solves the problem using SI units (meters, seconds, Newtons, etc.).

O P T I O N S  A N D  S E T T I N G S

In the Constants dialog box, which you open from the Options menu, define constants 
according to the following table (the descriptions are optional); when finished, click 
OK.

NAME EXPRESSION DESCRIPTION

E_bone 1.0e9[Pa] Young's modulus of bone

v_bone 0.3 Poisson's ratio of bone

rho_bone 2570[kg/m^3] Density of bone

E_bladder 3.5e5[Pa] Young's modulus of bladder

v_bladder 0.45 Poisson's ratio of bladder

rho_bladder 956[kg/m^3] Density of bladder

E_fluid 1.0e3[Pa] Young's modulus of fluid

v_fluid 0.495 Poisson's ratio of fluid

rho_fluid 1000[kg/m^3] Density of fluid

E_muscle 1.162e6[Pa] Young's modulus of muscle

v_muscle 0.4 Poisson's ratio of muscle
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G E O M E T R Y  M O D E L I N G

1 Select Import and Cad Data From File from the File menu.

2 Select All files in the Files of type list.

3 Select the file bladder.mphbin located in the folder 
Structural_Mechanics_Module/Bioengineering in the COMSOL installation 
directory and click Import. 

4 Click the Zoom Extents button.

5 Click the Headlight button and rotate the geometry to get a proper view according 
to the figure below.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Physics menu, choose Subdomain Settings.

2 Select Subdomain 1 and set Young’s modulus to E_bone, Poisson’s ratio to v_bone, 
and Density to rho_bone. 

rho_muscle 1200[kg/m^3] Density of muscle

gravity 9.81[m/s^2] Acceleration due to gravity

NAME EXPRESSION DESCRIPTION
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3 Click the Constraint tab and select Prescribed displacement from the Constraint 

condition list.

4 Select the Rx and Ry check boxes to constrain the displacement.

5 Type (t<=1)*((0.2*z+5[mm])*sin(2*pi*2[Hz]*t)) in the Ry edit field.

6 Click the Load tab and set Fy to -rho_bone*gravity. 

7 Click the Element tab and select Lagrange-Linear elements.

8 Select Subdomain 2 and set Young’s modulus to E_muscle, Poisson’s ratio to 
v_muscle, and Density to rho_muscle. 

9 Click the Load tab and set Fy to -rho_muscle*gravity. 

10 Click the Element tab and select Lagrange-Linear elements. 

11 Select Subdomain 3 and set Young’s modulus to E_bladder, Poisson’s ratio to 
v_bladder, and Density to rho_bladder.

12 Click the Load tab and set Fy to -rho_bladder*gravity.

13 Click the Element tab and select Lagrange-Linear elements. 

14 Select Subdomain 4 and set Young’s modulus to E_fluid, Poisson’s ratio to v_fluid, 
and Density to rho_fluid.

15 Click the Load tab and set Fy to -rho_fluid*gravity. 

16 Click the Element tab and select Lagrange-Linear elements. 

17 Select Subdomain 5 and set Young’s modulus to E_bone, Poisson’s ratio to v_bone, 
and Density to rho_bone.

18 Click the Constraint tab and select Prescribed displacement from the Constraint 

condition list.

19 Select the Rx, Ry, and Rz check boxes to specify the displacement.

20 Type (t<=1)*(5[mm]*sin(2*pi*2[Hz]*t)) in the Ry edit field.

21 Click the Load tab and set Fy to -rho_bone*gravity. 

22 Click the Element tab and select Lagrange-Linear elements.

23 Click the Damping tab and select all subdomains to specify the same Rayleigh 
damping parameters to all subdomains.

24 Set αdM to 1.88 and set βdK to 0.016.

25 Click OK.

26 Select Properties in the Physics menu and select On in the Large deformation list.
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M E S H  G E N E R A T I O N

1 Click the Initialize Mesh button.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 Select Time dependent analysis from the Solver list 

3 Type 0:0.02:2 in the Times edit field.

4 Type 1e-3 in the Relative tolerance edit field.

5 Type u 2e-7 v 3e-6 w 5e-7 in the Absolute tolerance edit field to specify individual 
tolerances for each displacement component.

6 Click OK.

7 Click the Solve button on the Main toolbar.
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B i omed i c a l  S t e n t

Introduction

Percutaneous transluminal angioplasty with stenting is a widely spread method for the 
treatment of atherosclerosis. During this procedure a stent, which is a small tube like 
structure, is deployed in the blood vessel by using a balloon as an expander. Once the 
balloon-stent package is in place in the artery, the balloon is inflated to expand the 
stent. The balloon is then removed, but the expanded stent remains to act as a scaffold 
that keeps the blood vessel open.

Stent design is of significance for the procedure, since damage can be inflicted on the 
artery during the expansion process. One way this may happen is by the non-uniform 
deformation of the stent, where the ends expand more than the mid parts, which is also 
called dogboning. Foreshortening of the stent can also be damaging to the artery, and 
it can make the positioning difficult.

The dogboning is defined according to

where rend and rmid are the radii at the end and middle of the stent, respectively.

The foreshortening is defined as

where Lorig is the original length of the stent and Lload is the deformed length of the 
stent.

To check the viability of a stent design, you can study the deformation process under 
the influence of a radial pressure which expands the stent. With a model you can easily 
monitor both the dogboning and foreshortening and draw conclusions on how to 
change the geometry design parameters for optimum performance.

dogboning
rend rmid–

rmid
---------------------------=

foreshortening
Lorig Lload–

Lorig
-------------------------------=
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Model Definition

Due to the circumferential and longitudinal symmetry of the stent, it is possible to 
model only one twenty-fourth of the geometry. But, for easier visualization of the 
deformation you can use one quarter of the geometry in the model.

Figure 5-15: One quarter of the stent geometry.

M A T E R I A L

Assume that the stent is made of stainless steel with material parameters according to 
the following table.

MATERIAL PROPERTY VALUE

Young’s modulus 193 GPa

Poisson’s ratio 0.3

Yield strength 300 MPa

Isotropic hardening modulus 2GPa

Free end

Symmetry boundary condition

Symmetry boundary
condition

Fixed point
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C O N S T R A I N T S

To prevent rigid body translation and rotation, apply the following constraints, which 
are also shown in Figure 5-15.

• Symmetry boundary conditions (normal displacements zero) for the boundaries 
lying in xy-plane and for the boundaries in the plane parallel to zx-plane going 
through the middle of the stent.

• Fix the rigid body translation in the remaining direction by constraining a point in 
the x direction.

L O A D S

Apply a radially outward pressure on the inner surface of the stent. During loading, 
increase the pressure with the parametric solver to a maximum value of 
pmax = 0.3 MPa. Follow by decreasing the load to zero to obtain the final shape of the 
deformed stent.

T H E  F I N I T E  E L E M E N T  M E S H

Use the predefined fine mesh size to mesh the geometry with the free mesher. The 
mesh created this way consists of approximately 7300 tetrahedral elements.

Results

The stent is expanded from an original diameter of 1.2 mm to a diameter of 3.6 mm 
in the mid section after unloading. The dogboning is 61% and the foreshortening is 
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-18%. These values are quite large and may require a change of the geometry 
parameters to improve the stent design.

Figure 5-16: Deformed shape plot of the total displacement of the stent after unloading.

In the figure below you can see the diameter of the stent versus the load parameter. 
Parameter values above one signify the unloading phase. You can follow the 
deformation, which is initially linear and gets larger as the material is loaded beyond 
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the yield stress. The unloading is purely elastic for this elasto-plastic material model 
with isotropic hardening.

Figure 5-17: Diameter increase in the middle of the stent versus the load parameter.

You can also study the dogboning as the stent is expanded. In the following figure you 
can notice that the free end of the stent reaches the yield point sooner than the mid 
parts. As a result of this the dogboning parameter increases until the sections further 
in also start to deform plastically.

Figure 5-18: Dogboning versus the load parameter.
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Model Library path: Structural_Mechanics_Module/Bioengineering/
biomedical_stent

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Click the New button or start COMSOL Multiphysics to open the Model Navigator.

2 Select 3D from the Space dimension list.

3 Select Structural Mechanics Module>Solid, Stress-Strain>Static analysis elasto-plastic 

material.

4 Click OK.

I M P O R T  O F  C A D  G E O M E T R Y

1 On the File menu select Import>CAD Data From File.

2 In the Files of type list select COMSOL Multiphysics file (*.mphtxt; *.mphbin; ...)

3 Browse to the directory models/Structural_Mechanics_Module/
Bioengineering located in the COMSOL installation directory and select the file 
biomedical_stent.mphbin.

4 Click Import.

O P T I O N S  A N D  S E T T I N G S

Constants
1 From the Options menu select Constants.

2 Enter the constants from the following table.

3 Click OK.

NAME EXPRESSION DESCRIPTION

Load_max 3e5 Maximum applied load to the stent

E 1.93e11 Young’s modulus

nu 0.3 Poisson’s ratio

S_yield 3e8 Yield stress

E_tan 2e9 Isotropic tangent modulus
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Extrusion Coupling Variables
You can set up extrusion coupling variables to gain access to coordinates and 
displacements of points on the entire geometry.

1 Select Options>Extrusion Coupling Variables>Point Variables.

2 Use the following table to enter variables for selected points on the Source page. 
Click the General transformation option button for each variable, after entering both 
the name and expression.

3 Click the Destination tab.

4 Select first x_mid from the Variable list, then from the Level list select Subdomain and 
select the check box next to Subdomain 1 in the Subdomain selection list.

5 Repeat the previous step for all the variables you have entered under step 2.

6 Click OK.

Global Expressions
By defining the quantities you are interested in as global expressions you can access 
them for postprocessing or during the solution process.

1 From the Options menu select Expressions>Global Expressions.

2 Enter expressions according to the following table.

POINTS NAME EXPRESSION

6 x_mid x

6 y_mid y

6 u_mid u

272 y_end1 y

272 z_end1 z

272 u_end1 u

272 v_end1 v

272 w_end1 w

12 x_end2 x

12 u_end2 u

12 w_end2 w

NAME EXPRESSION

foreshortening (l_orig-l_load)/l_orig

l_orig abs(y_mid-y_end1)
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3 Click OK.

P H Y S I C S  S E T T I N G S

Application Mode Properties
1 Select Physics>Properties to open the Application Mode Properties dialog box.

2 In the Large deformation list box select On.

3 Click OK.

Subdomain Settings
1 Select Physics>Subdomain Settings to open the Subdomain Settings dialog box.

2 Select Subdomain 1.

3 On the Material page, select Elasto-plastic from the Material model list.

4 In the E edit field enter E.

5 In the ν edit field enter nu.

6 Click the Elasto-plastic material data button.

7 In the σys edit field enter S_yield.

8 In the ETiso edit field enter E_tan.

9 Click OK.

10 Click OK.

Boundary Conditions
By applying the symmetry boundary conditions you can prevent rigid body translation 
in the y and z direction and rotation around all coordinate axes.

1 Select Physics>Boundary Settings.

2 From the Boundary selection list select Boundaries 2, 5, 8, 10, 42, 86, 130, 144, 145, 
and 146.

3 On the Constraint page select Symmetry plane from the Constraint condition list.

l_load l_orig+v_end1

dogboning (r_end-r_mid)/r_mid

r_mid r_orig+abs(u_mid)/2

r_orig abs(x_mid)

r_end sqrt((z_end1+w_end1)^2+(dist12/2)^2)

dist12 sqrt((w_end2-w_end1)^2+(u_end2-u_end1+2*x_end2)^2)

NAME EXPRESSION
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4 Select Boundary 28.

5 On the Load page, from the Coordinate system list box select Tangent and normal 

coord. sys. (t1, t2, n).

6 In the Fn edit field enter -Load_max*((para<=1)*para+(para>1)*(2-para)).

7 Click OK.

Point Settings
To fix the rigid body translation in the remaining x direction constrain a point in this 
direction.

8 Select Physics>Point Settings.

9 From the Point selection list select Point 288.

10 On the Constraint page make sure that the Standard notation button is selected.

11 Select the Rx check box and check that the value in the corresponding edit field is 
zero.

12 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, choose Free Mesh Parameters.

2 Select Fine from the Predefined mesh sizes list.

3 Click the Remesh button, then click OK.

C O M P U T I N G  T H E  S O L U T I O N

Solver Parameters
1 Click the Solver Parameters button on the Main toolbar.

2 On the General page, in the Parameter name edit field enter para.

3 In the Parameter values edit field enter 0 0.3 0.35 0.4 0.45 0.5 0.54 0.58 
0.6 0.62 0.64:0.04:1 1.05 1.5 2.

4 Click OK.

Probe Plot
To monitor the deformation of the stent during the solution process, you can create a 
probe plot. You can see this diagram, updated for each parameter step, on the Plot page 
of the Progress dialog box, that COMSOL Multiphysics displays while the solver is 
running.

1 Select Postprocessing>Probe Plot Parameters.
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2 In the Probe Plot Parameters dialog box click the New button.

3 In the dialog box that opens select Global from the Plot type list box.

4 In the Plot name edit field enter Stent diameter plot.

5 Click OK.

6 In the Expression edit field type 2*r_mid.

7 Click OK.

8 Click the Solve button on the Main toolbar to solve the problem.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

When the solution is done the plot of the stent diameter versus the solver parameter is 
automatically displayed in a separate figure window. You can also visualize the 
deformation of the stent after unloading.

1 Switch back to the COMSOL Multiphysics window.

2 Click the Plot Parameters button on the Main toolbar.

3 On the General page deselect the Slice check box under the Plot type area.

4 Deselect the Geometry edges check box.

5 Select the Boundary check box.

6 Select the Deformed shape check box.

7 Click OK.

You can also display the foreshortening and dogboning of the stent.

8 Select Postprocessing>Data Display>Global.

9 In the Expression edit field type dogboning.

10 Click Apply to display the value in the message log.

11 In the Expression edit field type foreshortening.

12 Click OK to display the value in the message log and close the Global Data Display 
dialog box.
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C i v i l  E n g i n e e r i n g  M o d e l s  
This chapter contains an analysis of a truss bridge.
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P r a t t  T r u s s  B r i d g e

The following procedure steps through the analysis of a bridge using the Structural 
Mechanics Module. 

Model Definition

The geometry of the bridge is inspired by a common bridge type called a Pratt truss 
bridge. You can identify a Pratt truss by its diagonal members, which (except for the 
very end ones) all slant down and in toward the center of the span. All the diagonal 
members are subject to tension forces only, while the shorter vertical members handle 
the compressive forces. This allows for thinner diagonal members resulting in a more 
economic design.

A truss structure supports only tension and compression forces in its members and you 
would normally model it using bars, but as this model uses 3D beams it also includes 
bending moments to some extent in a frame structure. In the model, shell elements 
represent the roadway.

A N A L Y S I S  TY P E S

The model includes three different analyses of the bridge:

• The goal of the first analysis is to evaluate the stress and deflection fields of the 
bridge when exposed to a pure gravity load.

• The goal for second analysis is to evaluate stress and deflection fields with a load 
corresponding to a truck parked at the middle of the bridge.

• Finally, an eigenfrequency analysis shows the eigenfrequencies and eigenmodes of 
the bridge.

L O A D S  A N D  C O N S T R A I N T S

To prevent rigid body motion of the bridge, it is important to constrain it properly. All 
translational degrees of freedom are constrained at the left-most horizontal edge. 
Constraints at the right-most horizontal edge prevent if from moving in the  y and 
z directions but allow the bridge to expand or contract in the x direction. Figure 6-1 
shows the bridge geometry with constraint symbols and load symbols for the gravity 
load on the roadway.
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Figure 6-1: The bridge geometry together with constraints symbols (red arrows) and 
gravity load/truck load symbols on the roadway and frame (blue arrows).

M A T E R I A L  P R O P E R T I E S

The material in the frame structure is steel and the cross-section data for the frame 
beam members is for a standard HEA 100 beam (H-beam). The roadway material is 
concrete.

The frame members are orientated so that their local xy-planes are parallel to the global 
xy-plane (see Figure 6-2). 

Figure 6-2: The local beam coordinate system.
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Results

Figure 6-3 and Figure 6-4 illustrate the result. The distribution of axial stresses 
demonstrates the functionality of the frame: The interplay of members in tension and 
compression achieve the load bearing function. The upper horizontal members are in 
compression and the lower in tension. All the diagonal members are subject to tension 
forces only while the shorter vertical members handle the compressive forces. 
Figure 6-3 also shows that the maximum deflection amounts to 9.8 cm.

Figure 6-3: Axial stresses in the frame and von Mises stresses in the roadway (magenta 
members in tension, blue members in compression).

To evaluate the added deflection that a truck causes, the second analysis includes a 
parked truck in the middle of the bridge on one side of the road. The truck has a mass 
of 10,000 kg and measures 10 meters in length and 2 meters in width. The maximum 
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deflection of the truss bridge is now 11.8 cm compared to the earlier unloaded value 
of 9.8 cm (see Figure 6-4).

Figure 6-4: Truck load analysis: Axial stresses in the frame (magenta members in tension, 
blue members in compression).

The study of eigenfrequencies is important with respect to the excitation and 
frequency content from various loads such as wind loads and earthquakes.
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Figure 6-5 shows the fourth eigenmode of the bridge.

Figure 6-5: The fourth eigenmode.

Model Library path: Structural_Mechanics_Module/Beam_Models/bridge

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

This model uses Euler beam elements to model the frame members.

1 Select 3D in the Space dimension list.

2 In the list of application modes, select Structural Mechanics Module>3D Euler Beam> 

Static analysis.

3 Click OK.
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O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, choose Constants to specify the gravitational constant gc 
and the mass m_Truck of the largest truck that is allowed on the truss bridge:

2 Click OK.

G E O M E T R Y  M O D E L I N G

Start the modeling by adding a suitable work plane to create the profile of the bridge. 
Use a work plane at y = −2.5.

1 Select Work-Plane Settings from the Draw menu. Create a workplane from the Quick 
page by selecting the z-x option button and typing -2.5 in the y edit field.

2 Change the grid spacing to 1 in the Axes/Grid Settings dialog box that you open from 
the Options menu.

3 Start by double-clicking SOLID in the Status bar to create curve objects by default 
when drawing. On the Draw menu, select Draw Objects>Line and make a closed 
polygon with the corners in (−2, 20), (−2, −20), (2, −15), and (2, 15). Finalize the 
polygon by right-clicking.

4 Select Extrude from the Draw menu, and change the extrusion distance to 5. This 
will create the extruded profile of the bridge model.

5 Now add a work plane on one of the sides of the bridge. Do this by first clicking Add 
in the Work-Plane Settings dialog box, and then selecting Vertices 1, 7, and 3 on the 
extruded object in that order. A vertex is selected by clicking >> on the Vertices page 
in the Work-Plane Settings dialog box. The order of the vertices defines the 
orientation of the plane.

6 Change the grid spacing to 1 in the new work plane, and change to curve object 
default by double-clicking SOLID.

7 Draw an open line object with corners in (5, 0), (5, 4), (10, 0), (10, 4), (15, 0), 
(15, 4), (20, 0), and (20, 4).

8 Select mirror and enter 20 in the edit field for the x coordinate of Point on line. This 
should give the other half of the frame of the bridge.

9 Select both objects and click the Coerce to Curve button on the Draw toolbar.

NAME EXPRESSION DESCRIPTION

m_Truck 1e4[kg] Mass of truck

gc 9.81[m/s^2] Acceleration due to gravity
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10 Select Embed from the Draw menu. To embed the curve object in 3D, accept the 
default choices in the dialog box by clicking OK.

11 Create a copy of the 3D curve object, and enter the y-displacement 5 when pasting.

12 Next create a work plane on the bottom of the bridge. Open Work-Plane Settings 
dialog box, click Add, and then define the new work plane in the Edge Angle page by 
selecting Edge 1 and Face 2 of the extruded object.

13 Double-click SOLID in the Status bar, click the Line toolbar button, and draw an open 
polygon curve with corners in (0, 40), (5, 35), (0, 30), (5, 25), (0, 20), (5, 15), 
(0, 10), (5, 5), and (0, 0).

14 Draw a line from (0, 35) to (5, 35). Click the Array button and enter 7 as array size 
in the y direction with a displacement of -5.

15 Select all curves (including lines), then click Coerce to Curve.

16 From the Draw menu choose Embed, then click OK in the dialog box that opens.

17 Once again, click Add in the Work-Plane Settings dialog box, then define the plane 
by selecting Edge 6 and Face 3 on the Edge Angle tab.

18 Double-click SOLID in the Status bar.

19 Create the open polygon with corners in (0, 30), (5, 25), (0, 20), (5, 15), (0, 10), 
(5, 5), and (0, 0).

20 Draw a line from (0, 25) to (5, 25). Then click the Array button and enter 5 as array 
size in the y direction with a displacement of -5.

21 Select all curves, then click Coerce to Curve.

22 Embed the object by choosing Draw>Embed and then clicking OK.

23 In 3D, select the extruded object and click Split.

24 Select all objects but the planar face forming the road of the bridge. Use Ctrl-click 
to do this. Click Coerce to Curve to generate one curve object out of this.

25 In Geom4, Shift-click the Rectangle/Square button on the Draw toolbar to create a 
rectangle with width 2, length 10, and corner in (0.25,15). Then select Embed from 
the Draw menu to embed the rectangle.

Bridge Under Gravity Load

M O D E L  N A V I G A T O R

1 Open the Model Navigator from the Physics menu. Select 3D in the Space dimension 
list.
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2 In the list of application modes, select Structural Mechanics Module>Shell>Static 

analysis.

3 Click Add, then click OK.

P H Y S I C S  S E T T I N G S

Edge Settings—Shell
The goal of the first analysis is to evaluate the stress and deflection fields of the bridge 
when it is exposed to gravity only. To prevent rigid-body motion of the bridge, it is 
important to constrain it properly.

1 From the Physics menu, choose Edge Settings.

2 Click the Constraint tab and specify the following constraints:

3 Click OK.

Boundary Settings—Shell
Gravity acts on the entire road.

1 From the Physics menu, choose Boundary Settings.

2 Select all shell domains by selecting one boundary, and then pressing Ctrl+A.

3 Click the Material tab.

4 Click the Load button.

5 Select Concrete in the Materials list in the Materials/Coefficients Library dialog box.

6 Click OK.

7 Type 0.2 in the Thickness edit field.

8 Click the Load tab.

9 In the Fz edit field type -rho_smsh*gc.

SETTINGS EDGE 1 EDGE 106

Constraint condition Pinned Prescribed displacement

Ry 0

Rz 0
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10 Click the Load is defined as force/volume and moment/volume using the thickness 
option button.

11 Click OK.

Edge Settings—3D Euler Beam
1 From the Multiphysics menu, choose 1 Geom1: 3D Euler Beam (smeul3d).

2 From the Physics menu, choose Edge Settings.

3 Select all edges by selecting one boundary, and then pressing Ctrl+A.

4 Click the Material tab.

5 Click the Load button.

6 Select Structural steel in the Materials list in the Materials/Coefficients Library dialog 
box.

7 Click OK.

8 Click the Cross Section tab.

9 Click the Load button to open the Cross-Section Library dialog box.

10 In the Cross sections list, select the HEA 100 beam cross section.

11 Click OK.

12 Next, specify the frame members local x-y plane, that is, the orientation of the beams 
about their local x-axis (see the figure below) using a point. Enter the point x-, y-, 
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and z-coordinates in the localxp, localyp, and localzp edit fields.

13 For each side, select all edges and assign local point coordinates according to the 
following tables:

14 Click the Load tab.

15 Press Ctrl+A to select all edges and type -rho_smeul3d*A_smeul3d*gc in the Fz 
edit field.

When you added the smaller rectangle for the truck load that resulted in some 
additional edges. Deactivate these edges from the beam application mode:

16 Select Edges 39, 41, 48, 50, 59, 61, 68, and 69.

EDGE 10, 12, 13, 18, 23, 25, 
28, 30, 34, 36, 37, 46, 
56, 57, 65, 66, 75, 76, 
77, 84, 90, 91, 95, 96, 
100

1,2,4, 5, 8, 9, 15, 16, 20, 
21, 22, 27, 32, 33, 38, 
40, 43, 44, 47, 49, 52, 
53, 54, 58, 60, 63, 67, 
70, 72, 73, 78, 79, 81, 
82, 86, 87, 89, 93, 98, 
99, 103, 104, 106

localxp 1 1

localyp 5 5

localzp 2 -2

EDGE 3, 7, 11, 19, 24, 31, 35, 
51, 55, 71, 74, 85, 88, 
97, 101

6, 14, 17, 26, 29, 42, 45, 
62, 64, 80, 83,92, 94, 
102, 105

localxp 1 1

localyp -2.5 2.5

localzp 3 3
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17 Deactivate these edges by clearing the Active in this domain check box.

18 Click OK.

M E S H  G E N E R A T I O N

1 From the Multiphysics menu, choose 2 Geom1: Shell (smsh).

2 From the Mesh menu, choose Free Mesh Parameters.

3 Select Extremely fine from the Predefined mesh sizes list.

4 Click Remesh, then click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot illustrates the total displacement by superposition of edge and color 
plots. In addition, visualize the axial stresses in the individual members as follows:

1 From the Postprocessing menu, choose Plot Parameters.

2 Click the General tab and clear the Geometry edges check box. Select the Deformed 

shape check box.

3 Because of the beam elements, the automatic element refinement sets the 
refinement level to 6, which is unnecessarily high considering the fine mesh in the 
shell. To the right of Element refinement, clear the Auto check box and type 2 in the 
edit field.

4 Click the Edge tab. In the Predefined quantities list, select 3D Euler Beam 

(smeul3d)>Axial stress.

5 Click the Max/Min tab.

6 Select the Max/min marker check box.

7 On the Edge Data tab, select the Edge max/min data check box and select 3D Euler 

Beam (smeul3d)>Total displacement in the Predefined quantities list.

8 Click Apply.

The following figure illustrates the result. You can see that the maximum deflection 
amounts to 9.8 cm. The distribution of axial stresses demonstrates the functionality of 
the frame: The load bearing function is achieved by the interplay of members in tension 
and compression. The upper horizontal members are in compression and the lower in 
tension.
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Furthermore, it may be of interest to visualize the equivalent (von Mises) stress 
imposed on the road:

1 Open the Plot Parameters dialog box.

2 Click the General tab.

3 Select the Boundary check box to activate a plot on the boundary (face) representing 
the road.

4 Click the Boundary tab.

5 Select Shell (smsh)>von Mises stress in the Predefined quantities list.

6 Click Apply.

In addition, to visualize the distribution of members in tension and compression the 
stress range for the beam axial stress plot is changed to show the sign of the axial stress 
in the individual members (tension—positive stress values, compression—negative 
stress values).

1 Click the Edge tab.

2 Type sign(sn_smeul3d) in the Expression edit field.

3 In the Colormap list select cool.
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4 Click Apply.

Truck on the Bridge

To evaluate the added deflection that a truck causes, park it in the middle of the bridge 
on one side of the road. The truck has a mass of 10,000 kg and measures 10 meters in 
length and 2 meters in width.

P H Y S I C S  S E T T I N G S

Boundary Conditions
1 From the Physics menu, choose Boundary Settings.

2 Click the Load tab.

3 Select Boundaries 8, 11, 15, and 17 in the Boundary selection list (the area 
representing the truck) and type -rho_smsh*gc-m_Truck*gc/
(thickness_smsh*10[m]*2[m]) in the Fz edit field.

4 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.
R  6 :  C I V I L  E N G I N E E R I N G  M O D E L S



PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The plot shows the same properties as for the previous analysis.

The maximum deflection of the truss bridge is now 11.8 cm compared to the earlier 
unloaded value of 9.8 cm.

Eigenfrequencies of the Bridge

An eigenfrequency analysis is important with respect to impact of the target 
environment.

C O M P U T I N G  T H E  S O L U T I O N

1 From the Solve menu, choose Solver Parameters.

2 In the Analysis list, choose Eigenfrequency.

Change the analysis type for the Shell application mode to eigenfrequency as well.

3 From the Physics menu, choose Properties.

4 Select Eigenfrequency from the Analysis type list.

5 Click OK to close the Application Mode Properties dialog box.
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6 Open the Solver Parameters dialog box from the Solve menu. On the General page, 
type 20 in the Desired number of eigenfrequencies edit field and -1 in the Search for 

eigenfrequencies around edit field.

7 Click OK.

8 Click the Solve button.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Review the eigenfrequencies and plot a mode shape:

1 From the Postprocessing menu, choose Plot Parameters.

2 Investigate the eigenmodes by selecting the corresponding eigenfrequencies in the 
Eigenfrequency list on the General page. Select the eigenfrequency at approximately 
5.3 Hz and click Apply.

Figure 6-5 on page 250 shows the result of the plot.
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C o n t a c t  a n d  F r i c t i o n  M o d e l s
This section contains examples of contact and friction models that you can study 
using the Plane Stress, Plane Strain, and Solid Stress-Strain application modes in the 
Structural Mechanics Module.
 261
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S l i d i n g  Wedg e

Introduction

This is a benchmark model for contact and friction described in the NAFEMS 
publication in Ref. 1. An analytical solution exists, and this model includes a 
comparison of the COMSOL Multiphysics solution against the analytical solution. 

Model Definition

A contactor wedge under the gravity load G is forced to slide due to a boundary load, 
F, over a target wedge surface, both infinitely thick (see Figure 7-1). Horizontal linear 
springs are also connected between the left vertical boundary of the contactor and the 
ground. The total spring stiffness is K. 

This is a large sliding problem including contact pressure, for a constant contact area, 
and friction. A boundary contact pair is created and the contact functionality of the 
Structural Mechanics module is used to solve the contact/friction problem. Friction is 
modeled with the Coulomb friction model. 

Figure 7-1: Sliding wedge with linear springs and a boundary load.

The aim of this benchmark is to calculate the horizontal sliding distance and compare 
it with an elementary statics calculation.

The overall spring stiffness, K, is determined to K = 563.9 N/m by an elementary 
statics calculation for the following values: the sliding distance x = 1.0 m, the 
horizontal force F = 1500 N, the total vertical gravity load G = 3058 N (which 

Target wedge

F

K

G

Contactor wedge

θ
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divided by the wedge volume gives a load/volume of 764.5 N/m3), the wedge angle 
tan θ = 0.1, and the coefficient of friction µ = 0.2. The overall spring stiffness is 
determined to K = 563.9 N/m.

The spring is modeled as an x-displacement dependent boundary load, that is, a 
deformation-dependent load.

A suitable element type for this model is the linear quadrilateral element (see Figure 7-
2).

Figure 7-2: Linear quadrilateral elements is used to mesh the model.

The total number of elements in this model is 3686 and the number of degrees of 
freedom is 8554.

A suitable solver for contact/friction problems is the parametric solver where the 
gravity load G and the boundary load F are increased incrementally.

This model uses manual scaling of the solution components to reduce the solution 
time. You can find further explanation of manual scaling for contact models on page 
129 of the Structural Mechanics Module User’s Guide.
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Results and Discussion

The model is in good agreement with Ref. 1. Figure 7-3 shows the result from the 
analysis.

Figure 7-3: A surface plot of the x-displacement of the contactor wedge.

Reference

1. Feng Q., NAFEMS Benchmark Tests for Finite Element Modelling of Contact, 
Gapping and Sliding. NAFEMS Ref. R0081, UK, 2001.

Model Library path: Structural_Mechanics_Module/Contact_and_Friction/
sliding_wedge
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Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 On the New page select 2D from the Space dimension list.

2 From the list of application modes select Structural Mechanics Module>Plane 

Strain>Static analysis, then click OK.

O P T I O N S  A N D  S E T T I N G S

From the Options menu select Constants and enter the following constant names, 
expressions, and descriptions (the descriptions are optional). When finished, click OK.

G E O M E T R Y  M O D E L I N G

1 Shift-click the Line button on the Draw toolbar to open the Line dialog box.

2 In the x edit field type 0 0 6 6 and in the y edit field type 0 0.7 1.3 0.

3 From the Style list select Closed polyline (solid), then click OK.

4 Shift-click the Line button on the Draw toolbar.

5 In the x edit field type 1 1 5 5 and in the y edit field type 0.8 2 2 1.2.

6 From the Style list select Closed polyline (solid), then click OK.

7 Click the Zoom Extents button on the Main toolbar.

8 Select Use Assembly from the Draw menu.

NAME EXPRESSION DESCRIPTION

G 3058[N] Gravity load

V_wedge 4[m^3] Volume of wedge

gravity G/V_wedge Gravity load/volume

mu 0.2 Coefficient of friction

F 1500[N] Boundary load (force)

L_edge 1.2[m] Length of left vertical edge

F_per_unit_area F/L_edge Force per unit area

K 563.9[N/m] Overall spring stiffness

K_per_length K/L_edge Spring stiffness per length
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9 Check your geometry against the figure below.

Figure 7-4: Sliding wedge geometry.

P H Y S I C S  S E T T I N G S

Subdomain Settings
Click Physics>Subdomain Settings and specify the material properties and body load 
according to the following table:

Boundary Conditions

Contact Pairs   

1 Select Physics>Contact Pairs.

2 Click the New button.

3 Select Boundary 3 from the Master boundaries list.

SUBDOMAIN PAGE SETTINGS/INPUT

1, 2 Material E 206e9

ν 0.3

2 Load Fy -gravity*para

1,2 Element Predefined element Lagrange - Linear
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4 Click the Check Selected button below the Master boundaries list.

5 Select Boundary 6 from the Slave boundaries list.

6 Click the Check Selected button below the Slave boundaries list.

7 Click OK to close the Contact Pairs dialog box.

Boundary Settings   

1 Select Physics>Boundary settings.

2 From the Boundary selection list select Boundary 5.

3 Click the Load tab.

4 Click the Edge load is defined as force/length button.

5 In the Fx edit field type F_per_unit_area*para-K_per_length*u.
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6 Click the Constraint tab.

7 Select Boundary 2 from the Boundary selection list.

8 Select Fixed from the Constraint condition list.

9 Click the Pairs tab, then select Pair 1 (contact) from the Pair selection list.

10 On the Contact page, select Coulomb from the Friction model list.

11 In the Static friction coefficient edit field type mu.

12 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Select Solve>Solver Parameters.

2 Select Parametric from the Analysis list in the Solver Parameters dialog box.

3 Enter para in the Parameter name edit field on the General page.

4 In the Parameter values edit field type 0 0.03 0.2 0.4 0.8 1.

5 Click the Stationary tab.

6 Enter 1e-13 in the Relative tolerance edit field.

This is necessary to ensure convergence; see the section “Solver Settings for Contact 
Modeling” on page 129 of the Structural Mechanics Module User’s Guide  for a 
description of the calculation of this tolerance.

7 Click the Advanced tab.

8 Select Manual from the Type of scaling list in the Scaling of variables area.
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9 In the Manual scaling edit field type u 1 v 1 Tn_cp1_smpn 1000 Ttx_cp1_smpn 
100 Tty_cp1_smpn 10

This is an example of the so-called property-pair syntax, where you first enter a 
variable and then the corresponding scaling factor, and so on. The first two variables 
in the list, u and v, are the dependent variables, that is, the displacements. The rest 
of the variables are related to contact modeling; see the subsection “Contact 
Modeling” on page 186 of the Structural Mechanics Module User’s Guide  for a 
description of these variables.

10 Click OK.

11 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To visualize the displacement of the wedge, proceed with the following instructions:

1 Click the Plot Parameters button.

2 Click the Surface tab.

3 Make sure that the Surface plot check box is selected, then select x-displacement from 
the Predefined quantities list.

4 Click OK.
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You should now see the following plot in the main user interface window.
R  7 :  C O N T A C T  A N D  F R I C T I O N  M O D E L S



2D C y l i n d e r  Ro l l e r  C on t a c t

Introduction

Consider an infinitely long steel cylinder resting on a flat aluminum foundation, where 
both structures are elastic. The cylinder is subjected to a point load along its top. The 
objective of this study is to find the contact pressure distribution and the length of 
contact between the foundation and the cylinder. An analytical solution exists, and this 
model includes a comparison against the COMSOL Multiphysics solution. This model 
is based on a NAFEMS benchmark (see Ref. 1).

Model Definition

This is clearly a plane strain problem and the Plane Strain application mode from the 
Structural Mechanics Module is thus a suitable (two-dimensional) application mode. 
The geometry is reduced to half of the geometry at the vertical symmetry axis due to 
symmetry reasons.

Figure 7-5: Geometry in model

The cylinder is subjected to a point load along its top with an intensity of 35 kN. Both 
the cylinder and block material are elastic, homogeneous, and isotropic. 
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The contact modeling method in this example does not include friction as described 
in Ref. 1. This model uses a contact pair, which is a straightforward way to implement 
a contact problem using the Structural Mechanics Module.

Results and Discussion

The deformed shape and the Von Mises stress distribution are depicted in Figure 7-6. 

Figure 7-6: Deformation and Von Mises stress at the contact area.

The analytical solution for the contact pressure as a function of the x-coordinate is 
given by

P
FnE′

2πR′
------------- 1 x

a
---⎝ ⎠
⎛ ⎞ 2

–⎝ ⎠
⎛ ⎞×=

a
8FnR′

πE′
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where Fn is the applied load (load/length), E‘ the combined elasticity modulus, R´ the 
combined radius, and x is the x-axis coordinate.

The combined Young’s modulus and radius are defined as:

In these equations, E1 and E2 are Young’s modulus of the roller and the block, 
respectively, and R1 is the radius of the roller.

This gives a contact length of 6.21 mm and a maximum contact pressure of 3585 MPa.

The contact pressure along the contact area for both the analytical and the COMSOL 
Multiphysics solution are depicted in Figure 7-7. The COMSOL Multiphysics 
solution is the solid line, the analytical result is the dashed line.

Figure 7-7: Analytical pressure distribution and COMSOL Multiphysics solution 
(dashed).
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The maximum contact pressure obtained with COMSOL Multiphysics is 3581 MPa, 
which is in good agreement with the analytical solution.

The maximum contact length (equivalent to a null contact pressure) is evaluated at 
6.31 mm.

References

1. Konter A.W.A., Advanced finite element contact benchmarks, NAFEMS, 2006

2. Crisfield M. A., Non-linear Finite Element Analysis of Solids and Structures, 
volume 2: Advanced Topics, John Wiley & Sons Ltd., England, 1997.

Modeling Using COMSOL Multiphysics

The Structural Mechanics Module supports contact boundary conditions using 
contact pairs. The contact pair is defined by a master (contacting) boundary and a slave 
(contacted) boundary. The contact boundary pair comprises a flat boundary and a 
curved boundary. The flat boundary is defined as the master boundary and the curved 
boundary as the slave boundary.

Because contact is only present in a small area, a local mesh refinement is required. Due 
to the geometry shape, you use a free mesh for the cylinder domain and a mapped 
mesh for the aluminum block. The block geometry requires some modification in 
order to set up a refined mesh area.

This example assumes a nominal thickness (thickness = 1).

The selected length unit in this model is mm, so the MPa unit system, which is based 
on mm as the length unit, is a suitable unit system.

Model Library path: Structural_Mechanics_Module/Contact_and_Friction/
cylinder_roller_contact

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 On the New page, select 2D from the Space dimension list.
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2 Expand to the next submenu by clicking on Structural Mechanics Module> 
Plane Strain>Static analysis.

3 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu select Constants and enter the following constant names, 
expressions, and descriptions (optional); when done, click OK.

G E O M E T R Y  M O D E L I N G

1 In the Draw menu select Use Assembly.

1 Shift-click the Ellipse/Circle (Centered) button on the Draw toolbar, then set the 
Radius to 50 and the position of the center to (0, 50). Click OK.

2 Shift-click the Rectangle/Square button on the Draw toolbar and set both Width and 
Height to 200. Set the corner position to (−100, −200). Click OK.

3 Click the Zoom Extents button on the Main toolbar.

4 Draw a second rectangle, this one of width 100 and height 300 with the lower left 
corner at (−100, −200).

5 Click the Create Composite Object button on the Draw toolbar and type the 
expression (C1+R1)-R2 in the Set formula edit field. Click OK.

6 Choose Specify Objects>Square from the Draw menu to create two squares with the 
following specifications:

NAME EXPRESSION DESCRIPTION

E1 70e3[MPa] Block Young's modulus

E2 210e3[MPa] Cylinder Young's modulus

nu 0.3 Poisson's ratio

Fn 35[kN] External load

E_star 2*E1*E2/((E1+E2)*(1-nu^2)) Combined Young's modulus

R 50[mm] Combined radius

th 1[mm] Thickness

lc 10[mm] Estimated contact length

a sqrt(8*Fn*R/(pi*E_star*th)) Contact length

pmax sqrt(Fn*E_star/(2*pi*R*th)) Maximum contact pressure

PROPERTY SQUARE 1 SQUARE 2

Width 100 25
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7 Choose Specify Objects>Line from the Draw menu and create a line between grid 
point (25, −25) and grid point (100, −100).

The mesh needs to be refined in the contact area. To do this in an efficient way, 
divide the curved boundary into two separate boundaries. To achieve this, add a 
point along the curved boundary.

8 Draw a Point at the origin (0, 0).

9 Click the Rotate button on the Draw toolbar, then set the Rotation angle to 10 
degrees and the y-coordinate of the Center point to 50.

10 Select all domains (press Ctrl+A), then click the Split Object button on the Draw 
toolbar.

11 Select all the geometry objects of the top part (CO3 and PT2), then click the Coerce 

to Solid button on the Draw toolbar.

12 Select all the geometry objects of the bottom part (CO2, CO4, CO5, and B2), then 
click the Coerce to Solid button.

Base Corner Corner

x 0 0

y -100 -25
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P H Y S I C S  S E T T I N G S

Model Settings
1 In the Physics menu, go to Model Settings and select MPa from the Base unit system 

list.

2 Click OK.

Subdomain Settings
1 Choose Physics>Subdomain Settings to specify the subdomain settings for the Plane 

Strain application mode according to the following table:

The nominal thickness is used; make sure that thickness is set to 1 for all subdomains.

2 Click OK.

Boundary Conditions
1 Choose Physics>Boundary Settings to open the Boundary Settings dialog box; then 

specify the following constraint conditions:

The other boundaries are free, which is the default boundary condition.

2 Click OK.

Point Settings
The external load is a point load. Due to the symmetry, apply one half of the total force 
on the studied geometry:

1 From the Physics menu select Point Settings.

2 In the Point Settings dialog box select Point 11.

3 Click the Load tab, and then type -Fn/2 in the Fy edit field.

4 Click OK.

Contact Pairs
Define a contact pair for Boundaries 7 and 14. A general advice is to set the curved 
surface as slave (contacting) boundary and the straight surface as master (contacted) 
boundary. The top boundary (number 7) is set to slave boundary and the bottom 

SETTINGS SUBDOMAINS 1–4 SUBDOMAIN 5

E E1 E2

ν nu nu

SETTINGS BOUNDARIES 1, 3, 5, 13 BOUNDARY 2

Constraint condition Symmetry plane Fixed
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boundary (number 14) as master boundary in this model. The steel block is also the 
correct master surface because it has a high stiffness.

1 From the Physics menu select Contact Pairs.

2 In the Contact Pairs dialog box, click New.

3 In the Master boundaries list, select Boundary 7.

4 Click the Check Selected button below the Master boundaries list.

5 In the Slave boundaries list select Boundary 14.

6 Click the Check Selected button below the Slave boundaries list.

7 Click OK.

The next step is to specify the contact parameters in the Boundary Settings dialog 
box.

8 In the Boundary Settings dialog box, click the Pairs tab, and select Pair 1 (contact).

Note: To reduce the number of iteration steps and improve convergence, it is good 
practice to set an initial contact pressure as close to the solution as possible. A good 
approximation is to use the value of the external pressure, in this case the external 
point load divided by an estimated contact length and the thickness. In this model 
you need to set an initial contact pressure to make the model stable for the initial 
conditions.

9 On the Contact, Initial page, type (Fn/2)/(lc*th) in the Contact pressure edit field 
(the division by 2 is to account for the symmetry).

10 Click OK.

M E S H  G E N E R A T I O N

You can achieve an accurate contact pressure by refining the mesh around the contact 
zone. A general recommendation is to have at least 10 contacting nodes along the slave 
contact boundary. Apply an element size of 0.59 mm for the cylinder and 1.5 mm for 
the block. Due to the geometry shape, use a free mesh (triangular elements) for the 
cylinder and a mapped mesh (quadrilateral elements) for the block.

1 Open the Free Mesh Parameters dialog box by selecting Free Mesh Parameters from 
the Mesh menu.

2 Click the Boundary tab. Select Boundary 14, then type 0.59 in the Maximum element 

size edit field.
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3 Click the Subdomain tab, then select Subdomain 5. Click OK.

4 Click the Mesh Selected (Free) button on the Mesh toolbar.

In the message log you can see that the free mesh is composed of around 360 
elements.

5 Open the Mapped Mesh Parameters dialog box by selecting Mapped Mesh Parameters 

from the Mesh menu.

6 On the Boundary page, select Boundaries 3, 5, and 7. Then select Constrained edge 

element distribution and type 20 in the Number of edge elements edit field.

7 On the Boundary page, select Boundary 1. Then select the Constrained edge element 

distribution and type 10 in the Number of edge elements edit field. Click Apply.

8 Go to Subdomain page and select Subdomains 1, 2, 3, and 4.

9 Click the Mesh Selected button. Click OK.

The information in the message log shows that the total mesh consists of 
approximately 1750 elements (roughly 360 elements for the free mesh and 1400 
elements for the mapped mesh).

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.
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P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows the von Mises stress. Because of the point-load constraint, a 
stress concentration develops on the top of the cylinder. Due to the automatic plot-
range settings, the stress around the contact surface looks almost identical.

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, select the Surface and Boundary check boxes and clear the 
Geometry edges check box in the Plot type area.

3 On the Surface page, click the Range button. In the Color Range dialog box clear the 
Auto check box, then type 2500 in the Max edit field. Click OK.

4 On the Boundary page, type 1 in the Expression edit field on the Boundary Data tab. 
Click the Uniform color option button in the Boundary color area, then click the Color 

button and select black. Click OK.

5 Click OK.

Zoom in on the contact area to get the following plot:

The instructions below show how to create a line plot to compare the analytical contact 
pressure distribution with the contact pressure calculated by the model.
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1 Choose Options>Expressions>Boundary Expressions and select Boundary 14. Enter 
the following constant names and expressions:

2 Click OK.

3 In the Solve menu, select Update Model.

You can now plot the analytical expression of the contact pressure.

4 Choose Postprocessing>Domain Plot Parameters.

5 Click the Line/Extrusion tab, then from the Predefined quantities list select Contact 

pressure, contact Pair 1.

6 Select Boundary 14 (the slave boundary), then click Apply to generate a plot of the 
contact pressure calculated in the model.

7 In the Expression edit field type p_analytical.

8 Click the Line Settings button, then select Color in the Line color list, and Dashed line 
in the Line style list. Click OK.

9 Click the General tab, then select Keep current plot.

10 Click the Title/Axis button and type Contact pressure vs. arc length (blue: 
calculated, red: analytical) in the Title edit field. In the First axis label edit 
field type mm and in the Second axis label edit field type MPa. Click OK.

NAME EXPRESSION

theta atan2(y-50,x)+pi/2

x_local sqrt(x^2+(y-50)^2)*theta

p_analytical pmax*sqrt(1-(x_local/a)^2)
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11 Click OK in Domain Plot Parameters dialog box to generate the plot of the analytical 
expression for the contact pressure.
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Tub e  Conn e c t i o n

A tube connection consisting of a flange with four prestressed bolts is subjected to 
tensile forces. A sketch of the connection is shown below.

Model Definition

The tube is made of steel and has an outer diameter of 220 millimeters and an inner 
diameter of 200 millimeters. The flange has a diameter of 360 millimeters and it is 
30 millimeters thick. The connection consists of four prestressed M24 bolts. The bolts 
are prestressed to 80% of the yield strength. The tensile force in the tube varies from 0 
to 500 kN.

To compute the influence of the tensile force on the stress level in the bolt, the model 
includes a parametric analysis. Because of symmetry in both load and geometry, you 
only need to analyze one eighth of one of the flanges. The geometry has been created 
in the CAD software SolidWorks and is available both as an IGES file and as a 
SolidWorks file. The model exists in two different versions depending how the 
geometry is imported. The IGES version (tube_connection_igs.mph) is created 
from the IGES file through the IGES file import. Read more about IGES import in 
the section Importing 3D IGES Files in the CAD Import Module User’s guide. The 
SolidWorks version (tube_connection_sw.mph) is created from the SolidWorks live 
connection. Read more about the SolidWorks interface in the section “SolidWorks 
Live Connection” on page 30 in the CAD Import Module User’s guide.
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A contact pair between the bottom surface of the flange and the top surface of an 
additional fixed solid models the contact. To represent the bolt, the model uses a 
distributed linear boundary condition on a surface of the size of the washer.

Note: This model requires both the Structural Mechanics Module and the CAD 
Import Module.

Modeling in COMSOL Multiphysics

Two application modes for 3D solid stress-strain analysis are used to solve the problem. 
One application mode models the initial prestress problem of calculating the 
deformation from the prestressed bolts. The other is used for solving the parametric 
problem including the tensile force, using the solution from the prestress application 
mode to set up the correct boundary conditions.

Results and Discussion

Figure 7-8: The bolt stress as a function of the tensile force.
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For a tensile force below 250 kN the prestressed connection works well, the bolt stress 
increasing less than 2%. In the region 250 kN–500 kN the bolt stress increases by more 
than 13% due to the nonlinear effects in the connection.

Model Library path: Structural_Mechanics_Module/Contact_and_Friction/ 
tube_connection_igs

Model Library path: Structural_Mechanics_Module/Contact_and_Friction/
tube_connection_sw

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Click the New button or start COMSOL Multiphysics to open the Model Navigator.

2 Select 3D in the Space dimension list.

3 In the list of application modes, open the Structural Mechanics Module folder and 
then Solid, Stress-Strain. Select the Static analysis.

4 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

2 Enter the following constant names, expressions, and (optionally) descriptions. 
When finished, click OK.

NAME EXPRESSION DESCRIPTION

Abolt pi/4*24e-3^2[m^2] Bolt area

Atube pi/4*(0.22^2-0.2^2)[m^2] Tube area

Force 0[N] Tensile force in the tube

Sboltini 800*0.8*0.8*1e6[N/m^2] Prestress in the bolt

Awash pi/4*(0.05^2-0.025^2)[m^2] Washer area

thickness 0.03[m] Flange thickness
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G E O M E T R Y  M O D E L I N G

There are two different ways to create the geometry:

• From an IGES file, through the IGES file import.

• From a SolidWorks file, through the SolidWorks live connection.

IGES File Import
1 On the File menu, select Import>CAD Data From File to open the Import CAD Data 

From File dialog box.

2 Open the IGES file tube_connection.igs located in the 
models\Structural_Mechanics_Module\Contact_and_Friction folder in the 
COMSOL installation directory.

3 Click Import.

Emod 2e11[N/m^2] Modulus of elasticity of the 
bolt

Kbolt Emod*Abolt/thickness/Awash Distributed stiffness of the 
bolt (N/m3)

Fbolt Sboltini*Abolt/Awash Distributed prestress from 
the bolt (N/m2)

NAME EXPRESSION DESCRIPTION
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Due to symmetry, you can reduce the geometry to one eighth of the full geometry. To 
do so, create a 45-degree wedge and then intersect it with the imported geometry:

1 Select Work-Plane Settings from the Draw menu.

2 Click OK in the Work-Plane Settings dialog box as you will use the default settings.

3 Click the Zoom Extents toolbar button.

4 Draw a rectangle with opposite corners at (0, −0.1) and (0.2, 0.2).

5 Select Revolve from the Draw menu and enter 45 as α2 in the Revolve dialog box. 
Click OK.

6 Press Ctrl+A to select all objects and then click the Intersection button on the Draw 
toolbar to create an eighth.

Model a washer by creating a boundary around the hole. The distributed forces from 
the bolt are applied on this boundary.

1 Select Work-Plane Settings from the Draw menu.

2 Click the Add button, select the z-x option in the Plane area and click OK.

3 Set grid settings in Geom 3 according to the following table:

4 Click the Zoom Extents button on the Main toolbar to see the geometry.

5 Press the Shift key and click the Ellipse/Circle (Centered) button on the Draw toolbar 
to create a centered circle with radius 0.025 and center at (0, 0.15).

6 Draw another centered circle with radius 0.0125 and center at (0, 0.15).

7 Select both circles and click the Difference button to create a washer.

8 Draw a rectangle with opposite corners at (0, 0.12) and (0.03, 0.18).

9 Click the Create Composite Object button on the Draw toolbar, type CO1-R1 in the 
Set formula edit field, and click OK to close the dialog box.

GRID

x spacing 5e-3

Extra x

y spacing 5e-3

Extra y
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10 Select Embed from the Draw menu, then click OK.

Create an additional solid below the bottom flange (this solid is needed for the contact 
modeling).

1 Select Work-Plane Settings from the Draw menu.

2 Click the Add button, select the x-y option in the Plane area and click OK.

3 Set grid settings in Geom4 according to the following table:

4 Draw a rectangle with opposite corners at (0.09, −0.04) and (0.19, −0.03). To do 
so, press Shift and click the Rectangle/Square button on the Draw toolbar. In the 
Rectangle dialog box, enter (0.09, −0.04) as the coordinates for lower-left corner 
and a width and height of 0.10 and 0.01, respectively.

5 Select Revolve from the Draw menu and enter 45 as α2 in the Revolve dialog box. 
Click OK.

GRID

x spacing 0.01

Extra x

y spacing 0.01

Extra y
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You need to work in assembly mode to model the contact between the two initially 
connecting solids. The embedded washer surface must be a part of a solid to be 
included in the assembly between solids.

1 Select the upper solid part, CO2, and the embedded surface, EMB1.

2 Click the Coerce to Solid button on the Draw toolbar to make the washer a part of 
the solid.

3 Select Use Assembly from the Draw menu to leave draw mode in assembly mode.

SolidWorks Live Connection
Another way to create your geometry is to import it directly from SolidWorks. To 
follow these instructions you need to have SolidWorks installed on your computer.

1 Start SolidWorks and open the SolidWorks file tube_connection.SLDPRT located 
in the models/Structural_Mechanics_Module/Contact_and_Friction in the 
COMSOL installation directory.

2 Switch to COMSOL and select File>SolidWorks Connection>Initialize.

Create an additional solid below the bottom flange, this solid is needed for the contact 
modeling.

1 Select Work-Plane Settings from the Draw menu.

2 Click OK in the Work-Plane Settings dialog box as you will use the default settings.

3 Set grid settings in Geom2 according to the following table:

4 Draw a rectangle with opposite corners at (0.09, −0.04) and (0.19, −0.03).

5 Select Revolve from the Draw menu and enter 45 as α2 in the Revolve dialog box. 
Click OK.

You need to work in assembly mode to model the contact between the two initially 
connecting solids.

6 Select Use Assembly from the Draw menu to leave draw mode in assembly mode.

GRID

x spacing 0.01
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y spacing 0.01

Extra y
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P H Y S I C S  S E T T I N G S

Boundary Settings
In the first application mode you compute the initial deformation from the prestressed 
bolt. You then use a second Solid Stress-Strain application mode for the parametric 
analysis where the tensile force in the tube is increased. You need the solution from the 
first application mode to set up the boundary conditions for the parametric analysis.

1 Select Model Navigator from the Multiphysics menu to open the Model Navigator.

2 Select Structural Mechanics Module>Solid, Stress-Strain from the application mode 
tree and click the Add button to add a second solid stress-strain application mode to 
your 3D geometry. Click OK to close the Model Navigator.

To model the contact, use contact pairs. Start by creating two contact pairs, one for 
each application mode. Make the weaker boundary the slave and the stiffer one the 
master boundary.

3 Select Physics>Contact Pairs to open the Contact Pairs dialog box.

4 Click the New button to create a contact pair.

5 Select Boundary 4 in the Master boundaries list.

6 Select the check box in front of 4 in the Master boundaries list.

7 Select Boundary 9 in the Slave boundaries list.

8 Select the check box in front of 9 in the Slave boundaries list.

9 Click the New button to create an additional contact pair.

10 Select the same boundaries as master and slave boundaries as you made for the first 
pair.

11 Click OK to close the dialog box.

12 Select 1 Geom1: Solid, Stress-Strain (smsld) from the Multiphysics menu.

13 Select Physics>Boundary Settings and clear the Active pair check box for Pair 2.

14 Select 2Geom1: Solid, Stress-Strain (smsld2) from the Multiphysics menu.

15 Select Physics>Boundary Settings and clear the Active pair check box for Pair 1.

16 Select 1 Geom1: Solid, Stress-Strain (smsld) from the Multiphysics menu.
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17 Select Physics>Boundary Settings and specify the boundary and contact-pair settings 
according to the following tables:

The auglagiter variable is the iteration number in the augmented Lagrange solver. 
It makes the penalty parameter soft at the beginning (to help the solver get started) 
and then gradually makes it stiffer (to speed up convergence).

18 Select 2 Geom1: Solid, Stress-Strain (smsld2) from the Multiphysics menu.

19 Select Physics>Boundary Settings and specify the boundary and contact pair settings 
according to the following tables:

20 For enabling plotting of the bolt stress as a function of the applied tensile force an 
integration coupling variable is created, representing the integral of the force on the 
washer boundary.

21 Select Options>Integration Coupling Variables>Boundary Variables to open the 
Boundary Integration Variables dialog box.

22 Select Boundary 15 in the Boundary selection list.

23 In the Name column type Boltstress.

24 In the Expression column type (Fbolt+Kbolt*(v2-v))/(Abolt/2).

BOUNDARIES 8, 14, 18 BOUNDARY 15

Page Constraint Load

Symmetry plane Fy -Fbolt

PAIR 1 PAIR 2

Page Contact

pn E_smsld/h*min(1e-3*5^auglagiter,100)

Page Contact, Initial

Tn 1e7

BOUNDARIES 8, 14, 18 BOUNDARY 10 BOUNDARY 15

Page Constraint Load Load

Symmetry plane Fy Force/Atube Fy -Fbolt-Kbolt*(v2-v)

PAIR 2 PAIR 1

Page Contact

pn E_smsld2/h*min(1e-3*5^auglagiter,100)

Page Contact, Initial

Tn Tn_cp1_smsld
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25 Leave Global destination enabled and click OK to close the dialog box.

Subdomain Settings
The material properties will be defined using the materials library and are identical for 
both application modes. Specify the extra solid (added for the contact modeling) to be 
fixed.

1 Select 1 Geom1: Solid, Stress-Strain (smsld) from the Multiphysics menu to set the 
subdomain parameters for the first application mode.

2 Select Physics>Subdomain Settings.

3 Select Subdomain 2 from the subdomain list. Click the Load button on the Material 

page to open the Materials/Coefficients Library dialog box.

4 Select Structural Steel from the Basic Material Properties folder and click OK to close 
the Materials/Coefficients Library dialog box. 

5 Select Subdomain 1 from the subdomain list. Click the Constraint page and select 
Fixed from the Constraint condition list.

6 Click OK to close the Subdomain Settings dialog box.

Do the same for the other application mode:

7 Select 2 Geom1: Solid, Stress-Strain (smsld2) from the Multiphysics menu to set the 
subdomain parameters for the second application mode.

8 Select Physics>Subdomain Settings.

9 Select Subdomain 2 from the subdomain list.

10 Select Structural Steel from the Library material list.

11 Select Subdomain 1 from the subdomain list. Click the Constraint page and select 
Fixed from the Constraint condition list.

12 Click OK to close the Subdomain Settings dialog box.

M E S H  G E N E R A T I O N

The default mesh settings are used.

C O M P U T I N G  T H E  S O L U T I O N

1 Select Solver Parameters from the Solve menu.

2 Click the Stationary tab and find the Augmented Lagrangian solver area.

3 In the Tolerance edit field type 1e-5.

4 Click OK to close the Solver Parameters dialog box
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First solve the initial problem (no tensile force, only prestress) to determine the initial 
displacements.

1 Select Solver Manager from the Solve menu to open the Solver Manager dialog box.

2 On the Solve For page select Geom1: Solid, Stress-Strain (smsld) from the Solve for 

variables list, then click OK to close the dialog box.

3 Click the Solve button on the Main toolbar to compute the solution.

You have now solved the prestress problem without any external load.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Visualize the displacement in the y direction and the deformation as follows:

1 Select Plot Parameters from the Postprocessing menu.

2 On the General page select Frame (ref) from the Frame list.

3 Clear Slice plot, then select Deformed shape plot and Subdomain plot.

4 Click the Subdomain tab.

5 From the Predefined quantities list select Solid, Stress-Strain (smsld)>y displacement.

6 Click OK.

Now consider the externally applied tensile force.
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C O M P U T I N G  T H E  S O L U T I O N

Switch to the parametric solver and solve for the displacements in the second 
application mode using the solution from the first application mode in the boundary 
condition and as initial condition.

1 Select Solver Parameters from the Solve menu to open the Solver Parameters dialog 
box.

2 Select Parametric in the Analysis list.

3 On the General page type Force in the Parameter name edit field and type 
0:50e3:500e3 in the Parameter values edit field. Click OK.

4 Choose Solve>Solver Manager, then click the Initial Value tab.

5 Click the Initial value expression evaluated using stored solution option button in the 
Initial value area.

6 Click the Stored solution option button in the Values of variables not solved for and 

linearization point area.

7 Click the Store Solution button to save the initial solution.

8 Select Geom1: Solid, Stress-Strain (smsld2) from the Solve for variables list on the Solve 

For page, then click OK to close the dialog box.

Set the initial values in the second application mode to the result from the first 
application mode.

1 Select 2 Geom1: Solid, Stress-Strain (smsld2) from the multiphysics menu.

2 From the Physics menu, choose Subdomain Settings.

3 Click the Init tab and specify the initial values according to the following table.

4 Click OK.

5 Click the Solve button on the Main toolbar to start the parametric solver.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To visualize the result of the parametric analysis, you can use a plot of the von Mises 
stress combined with a deformation plot:

SUBDOMAIN 1, 2

Page Init

u2(t0) u

v2(t0) v

w2(t0) w
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1 From the Postprocessing menu, select Plot Parameters.

2 Select 5e5 in the Parameter value list on the General page.

3 Click the Deform tab.

4 In the Deformation data area, select Solid, Stress-Strain (smsld2)>Displacement in the 
Predefined quantities list.

5 Click the Subdomain tab.

6 Select Solid, Stress-Strain (smsld2)>von Mises stress from the Predefined quantities list.

7 Click OK.

To plot the stress in the bolt as a function of the external tensile force, do the following 
steps:

1 From the Postprocessing menu, choose Global Variables Plot Parameters.

2 Make sure that all parameter values are selected in the Solutions to use list.

3 Enter Boltstress in the Expression edit field and click the > button.

4 Select Boltstress from the Quantities to plot list.
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5 Click OK to create the plot.
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S n ap Hook

Introduction

This model simulates the insertion of a snap hook in its groove. Fasteners like this are 
common in the automotive industry, for example, in the control panel of a car. In this 
case it is important to know the force that must be applied in order to place the hook 
in the slot but also the force needed to remove it. From a numerical point of view, this 
is a highly nonlinear structural analysis, mainly due to the contact interaction between 
the hook and the slot, but also due to the elasto-plastic constitutive law selected for the 
hook, and finally due to the geometrical nonlinearity originating from the large 
deformation.

Model Definition

Due to symmetry, you can study only half of the original snap hook geometry, this way 
reducing the size of the model.

Figure 7-9: Geometry of the modeled snap hook.

M A T E R I A L  P R O P E R T I E S

Assume a linear elastic material for the groove with the default material properties 
(steel). For the hook, assume an elasto-plastic material model with isotropic hardening 

Groove

Hook
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and a constant tangent hardening modulus, with material parameters according to the 
following table.

B O U N D A R Y  C O N D I T I O N S

As you can see in Figure 7-10 the applied boundary conditions are:

• A symmetry boundary condition (zero normal displacements) for boundaries in the 
symmetry plane.

• A fixed boundary condition (all displacement components zero) for the face of the 
groove where it is attached to the remainder of the geometry.

• A prescribed displacement boundary condition for the face of the hook where it is 
attached to the rest of the geometry. Displacement in the x direction controlled by 
the parametric solver while the other displacement components are zero.

Figure 7-10: Boundary conditions in the model.

MATERIAL PARAMETER VALUE

Young’s modulus 10 GPa

Poisson’s number 0.35

Yield stress 120 MPa

Isotropic tangent modulus 1.2 GPa

Symmetry boundary
condition

Fixed boundary
condition

Prescribed boundary
condition controlled by
the solver parameter
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Results

The maximum effective stress levels are found at parameter step 0.8, that is, just before 
the hook enters the groove; see also figure Figure 7-11.

Figure 7-11: The effective stress levels in the hook just before it enters the groove.
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The figure below shows the total force required for the insertion and removal of the 
fastener versus the parameter step. The hook is in its groove at parameter step 1. For 
parameter values above 1 the hook is removed from the groove.

Figure 7-12: The mounting force as a function of the parameter step.

The insertion of the hook causes it to become permanently deformed. As you can see 
in Figure 7-13, after the hook has been removed there is a region where the plastic 
strains are greater than zero. This means that the hook has not returned to its original 
shape.
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Figure 7-13: Effective plastic strain in the hook, after its removal from the groove.

Model Library path: Structural_Mechanics_Module/Contact_and_Friction/
snap_hook_fastener

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Click the New button or start COMSOL Multiphysics to open the Model Navigator.

2 Select 3D from the Space dimension list.

3 Open the Structural Mechanics Module folder and then Solid, Stress-Strain. Select 
Parametric analysis.

4 From the Element list box select Lagrange - Linear.

5 Click OK.
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G E O M E T R Y  M O D E L I N G

The geometry for the model is available as a CAD file, and you have the option of 
skipping the procedure of building the geometry from scratch. If you want to create 
the geometry yourself, skip directly to the section “Building the Geometry Step by 
Step” where you find detailed instructions for the procedure.

Importing the Geometry from a CAD File
1 Choose File>Import>CAD Data From File.

2 In the Look in list browse to the folder 
models\Structural_Mechanics_Module\Contact_and_Friction in your 
COMSOL Multiphysics installation directory.

3 Select the file snap_hook.mphbin, then click Import.

Skip the following subsection and continue building the model at “Options and 
Settings” on page 305.

Building the Geometry Step by Step
First you start by creating a workplane, which you can use to draw the cross-sections 
of the snap hook assembly.

1 Select Work-Plane Settings from the Draw menu.

2 On the Quick page click the x-y button.

3 Click OK.

The view in the drawing area changes to the 2D workplane, which is Geom2. You can 
continue in the workplane by drawing the cross-section of the groove that will hold 
the hook.

1 Hold down the Shift key and click the Line button on the Draw toolbar.

2 In the dialog box that opens enter -0.7 -3.2 in the x edit field and 1.5 1.5 in the 
y edit field.

3 Click OK.
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4 According to Steps 1 to 3 above create three more lines based on the coordinates 
from the following table:

To make the lines visible in the drawing area you can use the Zoom Extents toolbar 
button.

5 Press Ctrl+A to select all the line objects and then click the Coerce to Solid toolbar 
button.

6 Click the Fillet/Chamfer toolbar button.

7 In the Fillet/Chamfer dialog box select Vertices 2 and 4 belonging to the object CO1 
and enter 0.1 in the Radius edit field.

8 Click OK.

9 Select Draw>Extrude to open the Extrude dialog box.

10 In the Objects to extrude list select CO2 and in the Distance edit field enter 1.2.

11 Click OK.

Now, in a similar manner, you can create the geometry for the solid body that makes 
up the hook.

1 Click the Geom2 tab above the drawing area to switch back to the 2D workplane.

2 Draw each line in the following table by first holding down the Shift key while 
clicking the Line button on the Draw toolbar, then entering the values in the x and 
y edit fields of the Line dialog box, followed by clicking OK.

LINE X Y

1 -3.2 -3.2 1.5 2.5

2 -3.2 -0.7 2.5 2.25

3 -0.7 -0.7 2.25 1.5

LINE X Y

1 0 0 2.5 3

2 0 5.75 3 3

3 5.75 6.75 3 2.75

4 6.75 7.75 2.75 1.25

5 7.75 6 1.25 1.25

6 6 5.75 1.25 1.75

7 5.75 4.75 1.75 2.5

8 4.75 1.4 2.5 2.5
S N A P  H O O K  |  303



304 |  C H A P T E
3 Click Zoom Extents on the Main toolbar.

4 In the drawing area select the lines B1 through B11 and click the Coerce to Solid 
button on the Draw toolbar.

5 Click the Fillet/Chamfer toolbar button.

6 In the Fillet/Chamfer dialog box select Vertex 1 from the object CO1 and enter 0.3 
in the Radius edit field.

7 Click Apply.

8 Select Vertices 7 and 11 from the object CO3 and enter 0.5 in the Radius edit field.

9 Click Apply.

10 Select Vertices 4 and 5 from the object CO1 and enter 0.2 in the Radius edit field.

11 Click OK.

12 Select Draw>Extrude to open the Extrude dialog box.

13 In the Objects to extrude list select CO3 and in the Distance edit field enter 1.

14 Click OK.

As the last step you can create a stiffening rib on the top of the hook, and finally scale 
the geometry.

1 Click the Geom2 tab above the drawing area to switch back to the 2D workplane.

2 Create the four lines from the following table by first holding down the Shift key 
while clicking the Line button on the Draw toolbar, then entering the values in the x 
and y edit fields of the Line dialog box, followed by clicking OK.

3 In the drawing area select the lines B1 through B4 and click the Coerce to Solid 
button on the Draw toolbar.

4 Select Draw>Extrude to open the Extrude dialog box.

9 1.4 1.25 2.5 2.1

10 1.25 0.5 2.1 2

11 0.5 0 2 2.5

LINE X Y

1 0.5 1 3 3.25

2 1 4.75 3.25 3.25

3 4.75 5.75 3.25 3

4 5.75 0.5 3 3

LINE X Y
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5 In the Objects to extrude list select CO1 and in the Distance edit field enter 0.5.

6 Click OK.

The Geom1 tab becomes active again with all three 3D objects visible.

7 Select all geometry objects by pressing Ctrl+A and click the Scale button on the Draw 
toolbar.

8 In the Scale factor area, enter 1e-3 in all three of the x, y, and z edit fields.

9 Click OK.

10 Click the Go to Default 3D View toolbar button to visualize the entire geometry of 
the snap hook and groove.

O P T I O N S  A N D  S E T T I N G S

Constants
1 From the Options menu select Constants.

2 Enter the constants from the following table.

3 Click OK.

Integration Coupling Variables
To obtain the total force, necessary to insert and pull out the hook, you can integrate 
the variables lm1, lm2, and lm3 on the appropriate boundary. These are variables 
corresponding to the reaction forces in the x-, y-, and z-directions, respectively.

1 Select Options>Integration Coupling Variables>Boundary Variables.

2 Select Boundary 30 and enter the variables from the following table.

NAME EXPRESSION DESCRIPTION

Displ_max 5e-3 Maximum displacement of the hook

E_hook 1e10 Young’s modulus for the hook

nu_hook 0.35 Poisson’s number for the hook

S_yield_hook 1.2e8 Yield stress for the hook

E_tan_hook 1.2e9 Isotropic tangent modulus for the 
hook

NAME EXPRESSION

F_x lm1

F_y lm2

F_z lm3
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3 Click OK.

Expressions
1 From the Options menu select Expressions>Scalar Expressions.

2 In the Name edit field enter Force and in the Expression edit field enter 
2*sqrt(F_x^2+F_y^2+F_z^2). The multiplication by 2 is due to symmetry.

3 Click OK.

P H Y S I C S  S E T T I N G S

Application Mode Properties
Because of the large deformations present you need to turn on the large deformations 
options for the model. This ensures that the model uses the correct material model that 
can handle the large displacements. The weak constraints option adds the variables 
lm1, lm2, and lm3 for the reaction forces to the solution components. You can read 
more about reaction forces on page 96 of the Structural Mechanics Module User’s 
Guide.

1 Select Physics>Properties to open the Application Mode Properties dialog box.

2 From the Large deformation list select On.

3 From the Weak constraints list select On.

4 Click OK.

Contact Pairs
The two solid bodies are not in contact initially and you need to specify which faces 
will be in contact by setting up a contact pair.

1 From the Physics menu select Contact Pairs.

2 In the Contact Pairs dialog box click the New button.

3 On the Boundaries page, in the Master boundaries list select the check boxes in front 
of Boundaries 1, 5, 6, 7, and 8.

4 In the Slave boundaries list select the check boxes in front of Boundaries 14, 15, and 
20, 22, and 23.

5 Click OK.

Subdomain Settings
1 Select Physics>Subdomain Settings to open the Subdomain Settings dialog box.

2 Select Subdomains 2 and 3.

3 On the Material page select Elasto-plastic from the Material model list box.
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4 In the E edit field enter E_hook.

5 In the ν edit field enter nu_hook.

6 Click the Elasto-plastic material data button.

7 In the σys edit field enter S_yield_hook.

8 In the ETiso edit field enter E_tan_hook.

9 Click OK.

10 Click OK.

Boundary Settings
1 Select Physics>Boundary Settings.

2 From the Boundary selection list select Boundary 2.

3 On the Constraint page select Fixed from the Constraint condition list box.

4 Select Boundaries 3, 11, and 18.

5 On the Constraint page select Symmetry plane from the Constraint condition list box.

6 Select Boundary 30.

7 On the Constraint page select Prescribed displacement from the Constraint condition 
list box.

You can control the motion of the hook by the use of the solver parameter and 
boolean expressions in the expression for the x-displacement.

8 Select the Rx, Ry, and Rz check boxes.

9 In the Rx edit field enter -Displ_max*((para<=1)*para+(para>1)*(2-para)).

10 In the Ry and Rz edit fields enter 0.

11 On the Pairs page select the contact pair Pair 1.

Since the hook and the groove are not in initial contact you need to specify the initial 
contact pressure to zero.

12 On the Contact, Initial page, enter 0 in the Tn edit field.

13 Click OK.

M E S H  G E N E R A T I O N

You can mesh the slave boundaries in the contact pair finer than the master boundaries. 
By using the geometry scaling factors during meshing you can keep the number of 
elements down and thus reduce the size of the model.

1 Select Mesh>Free Mesh Parameters.

2 On the Subdomain page select Subdomains 2 and 3 from the Subdomain selection list.
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3 Enter 1.1e-4 in the Maximum element size edit field.

4 Switch to the Advanced page.

5 Enter 0.5 in the x-direction scale factor edit field.

6 Enter 0.4 in the z-direction scale factor edit field.

7 Click OK to close the Free Mesh Parameters dialog box.

8 Click the Mesh All (Free) toolbar button.

C O M P U T I N G  T H E  S O L U T I O N

Solver Parameters
1 Click the Solver Parameters toolbar button.

2 On the General page, in the Parameter name edit field enter para.

3 In the Parameter values edit field enter 0 0.2:0.1:2.

4 On the Advanced page, from the Type of scaling list box select Manual.

5 In the Manual scaling edit field enter u 0.0005 v 0.0005 w 0.0005 lm1 1e7 lm2 
1e7 lm3 1e7 Tn_cp1_smsld 5e7.

Since the initial value of the contact pressure is zero, you need to use manual scaling 
of the variables. Read more about scaling of variables for contact problems on page 
129 of the Structural Mechanics Module User’s Guide.

6 Click OK.

Probe Plot
To monitor the force necessary to insert and retrieve the hook, you can create a probe 
plot. This plot is then displayed on the Plot page of the Progress dialog box, that 
COMSOL Multiphysics displays while the solver is running.

1 Select Postprocessing>Probe Plot Parameters.

2 In the Probe Plot Parameters dialog box click the New button.

3 In the dialog box that opens select Global from the Plot type list box.

4 In the Plot name edit field enter Force plot.

5 Click OK.

6 In the Expression edit field type Force.

7 Click OK.

8 Click the Solve toolbar button to solve the problem.
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PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

You can visualize the effective plastic strain in the hook by doing the following.

1 Click the Plot Parameters toolbar button.

2 Switch to the Subdomain page.

3 From the Predefined quantities list box select Solid, Stress-Strain (smsld)>effective 

plastic strain.

4 Click OK to close the dialog box and to update the plot.
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S ph e r i c a l  Pun ch

Introduction

In this model a spherical punch is used to deform a circular plate, which is held in place 
by two jaws. Such a process is typically used for forming of sheet metal or for testing 
of material properties. The model demonstrates nonlinear structural analysis with 
contact, large deformations, and the use of elasto-plastic material model. This model 
is courtesy of CESI Ricerca, Dept. SSG, Milano, Italy.

Model Definition

By taking into account the axial symmetry of the problem you can build a 2D 
axisymmetric model to simulate the process.

Figure 7-14: The geometry of the spherical punch and boundary conditions.

M A T E R I A L  P R O P E R T I E S

• Use the default material properties (steel) for the punch and the jaws.

Prescribed displacement
controlled by parametric solver

Spherical Prescribed displacement

Plate

Jaws

punch boundary condition

Fixed boundary
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• Use an elasto-plastic material model with kinematic hardening for the plate, with 
material properties outlined in the following table.

B O U N D A R Y  C O N D I T I O N S

• Apply a fixed boundary condition to the lower horizontal boundary of the jaw 
located below the plate.

• Apply a prescribed displacement boundary condition of −1 µm to the upper 
horizontal boundary of the jaw above the plate. This boundary condition models a 
force that maintains the upper jaw in contact with the plate. The easiest way to do 
this is to apply a displacement because a force probably causes convergence 
problems.

• Apply a prescribed displacement boundary condition to the upper boundary of the 
punch and use the solver parameter to gradually lower the sphere. The maximum 
displacement is −0.5 mm.

T H E  F I N I T E  E L E M E N T  M E S H

Create a mesh that takes into account the contact pairs in the model. For these, make 
sure that the slave boundaries are meshed at least twice as fine as the master boundaries. 
Since the main interest is the plastic deformation of the plate, mesh it with a finer mesh 
compared to the punch and the jaws.

Results

Figure 7-15 shows the von Mises stress distribution in the plate at the final parameter 
step, which corresponds to 0.5 mm displacement. Note that the highest stresses are on 
the bottom surface of the plate, below the punch. This is where the material reaches 
the yield stress first.

MATERIAL PARAMETER VALUE

Young’s modulus 2·105 MPa

Poisson’s number 0.33

Yield stress 300 MPa

Kinematic tangent modulus 2·104 MPa
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Figure 7-15: The von Mises stress distribution at the maximum displacement of the punch.
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Figure 7-16 displays the force necessary to deform the plate plotted against the 
displacement parameter. The force-displacement relationship is linear initially, until the 
material in the plate reaches the yield point.

Figure 7-16: The force on the punch versus the displacement parameter.

Model Library path: Structural_Mechanics_Module/Contact_and_Friction/
spherical_punch

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select Axial symmetry (2D) from the Space dimension list.

2 From the list of application modes select Structural Mechanics Module> 
Axial Symmetry, Stress-Strain>Parametric Analysis.

3 Click OK.
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I M P O R T  O F  G E O M E T R Y

1 Choose File>Import>CAD Data From File.

2 In the Look in list browse to the folder models/Structural_Mechanics_Module/
Contact_and_Friction in your COMSOL Multiphysics installation directory.

3 Select the file spherical_punch.mphbin, then click Import.

Before leaving the draw mode you need to set the assembly mode in order to be able 
to define the contact pairs between the different objects.

4 From the Draw menu select Use Assembly.

O P T I O N S  A N D  S E T T I N G S

Constants
1 From the Options menu select Constants.

2 Enter the constants from the following table:

3 Click OK.

Integration Coupling Variables
To obtain the force which is necessary to push down the punch you can integrate the 
variable lm2 which corresponds to the reaction force in this direction. This variable is 
automatically added to the solution components when you turn on weak constraints 
for the model. The variable you define here is available for postprocessing or to use in 
any expression. You can read more about reaction forces on page 96 of the Structural 
Mechanics Module User’s Guide.

1 Select Options>Integration Coupling Variables>Boundary Variables.

2 Select Boundary 14.

3 In the Name column enter Force.

NAME EXPRESSION DESCRIPTION

Displ_scale -1[mm] Displacement scale

displ_param 0 Displacement multiplier

E_plate 2e5[MPa] Young’s modulus for the plate

nu_plate 0.33 Poisson’s ratio for the plate

S_yield_plate 300[MPa] Yield stress for the plate

E_tan_plate 2e4[MPa] Kinematic tangential modulus for 
the plate
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4 In the Expression column enter 2*pi*lm2.

The factor 2π helps to take into account the integration around the circumferential 
direction for this 2D axisymmetric model.

5 Click OK.

P H Y S I C S  S E T T I N G S

Contact Pairs
1 Select Physics>Contact Pairs to open the Contact Pairs dialog box.

2 Click New to create a new contact pair.

3 In the Master boundaries list select the check box in front of Boundaries 17, 19, and 
21.

4 In the Slave boundaries list select the check box in front of Boundaries 9 and 10.

5 By repeating Steps 2–3, create two more contact pairs according to the table below.

6 Click OK.

Application Mode Properties
By turning on large deformations for the model you make sure that the correct 
formulation of the underlying equations that can handle large displacements are used 
to solve the problem. The weak constraints option in the model adds variables for the 
reaction forces to the solution components, which you can use to compute the force 
needed to push down on the punch.

1 Select Physics>Properties.

2 From the Large deformation list box select On.

3 From the Weak constraints list box select On.

4 Click OK.

Subdomain Settings
1 Select Physics>Subdomain Settings.

2 From the Subdomain selection list select Subdomains 1 and 2.

3 Enter E_plate in the E edit field.

4 Enter nu_plate in the ν edit field.

CONTACT PAIR MASTER BOUNDARIES SLAVE BOUNDARIES

Pair 2 25, 27 8

Pair 3 15, 16 3, 5
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5 From the Material model list select Elasto-plastic.

6 Click the Elasto-plastic material data button.

7 From the Hardening model list select Kinematic.

8 Enter S_yield_plate in the σys edit field.

9 Enter E_tan_plate in the ETkin edit field.

10 Click OK.

11 Click OK to close the Subdomain Settings dialog box.

Boundary Settings
1 Select Physics>Boundary Settings.

2 From the Boundary selection list select Boundary 14.

3 From the Constraint condition list box select Prescribed displacement.

4 Select the Rr and Rz check boxes.

5 Enter Displ_scale*displ_param in the Rz edit field.

6 From the Boundary selection list select Boundary 18.

7 From the Constraint condition list box select Fixed.

8 From the Boundary selection list select Boundary 24.

9 From the Constraint condition list box select Prescribed displacement.

10 Select the Rr and Rz check boxes.

11 Enter -1e-6 in the Rz edit field.

12 Click OK to close the Boundary Settings dialog box.

M E S H  G E N E R A T I O N

1 Select Mesh>Free Mesh Parameters.

2 On the Subdomain page select Subdomains 1 and 2 from the Subdomain selection list.

3 Enter 8e-5 in the Maximum element size edit field.

4 On the Boundary page select boundaries and enter settings on the Parameters page 
according to the table below.

5 From the Boundary selection list select Boundaries 19 and 25.

BOUNDARIES MAXIMUM ELEMENT SIZE

15, 16 5e-5

1, 5, 7, 8, 9, 10 2e-5

3 1e-5
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6 On the Distribution page select the Constrained edge element distribution check box.

7 Select the Edge vertex distribution radio button and enter 0:1/38:1 in the edit field.

8 From the Boundary selection list select Boundaries 21, 22, 27, and 28.

9 On the Distribution page select the Constrained edge element distribution check box.

10 Click the Number of edge elements button and enter 2 in the edit field.

11 Click OK to apply the settings and close the Free Mesh Parameters dialog box.

12 Click the Mesh All (Free) button on the Mesh toolbar.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters toolbar button.

2 On the General page enter displ_param in the Parameter name edit field.

3 Enter 0 0.001 0.002 0.005 0.01 0.02 0.025:0.025:0.5 in the Parameter 

values edit field.

4 Click OK to close the Solver Parameters dialog box.

5 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Select Postprocessing>Global Variables Plot.

2 Enter Force in the Expression edit field.

3 Click the Add Entered Expression button.

4 Click OK to close the dialog box and to plot the force versus the displacement 
parameter.
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D y n a m i c s  a n d  V i b r a t i o n  M o d e l s
This chapter presents models that simulate dynamics and vibration.
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Ro t o r

This model contains an eigenfrequency analysis of a rotor in an electric motor. In the 
design of a motor it is important that no eigenfrequencies for the rotor lie within the 
operating interval of the revolution speed (in revolutions per second) for the motor.

Model Definition

G E O M E T R Y

The geometry is fully axisymmetric, so you can create a cross section about the 
symmetry axis and rotate it to create the full 3D geometry.

M A T E R I A L  P R O P E R T I E S  A N D  B O U N D A R Y  C O N D I T I O N S

The rotor is made of solid steel. The only settings that you need to change are the 
boundary conditions:

• The left end of the rotor is fully fixed.

• The left end is constrained to only rotate about and slide along the axis of the rotor. 
This means that the boundary condition is zero displacement in the normal 
direction.
R  8 :  D Y N A M I C S  A N D  V I B R A T I O N  M O D E L S



Results

The analysis provides the six first eigenfrequencies, of which the 2nd and 3rd are the 
same. The plots below show the 2nd and 6th eigenmodes. They correspond to 
eigenfrequencies of 366 and 905 Hz.
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Model Library path: Structural_Mechanics_Module/
Dynamics_and_Vibration/rotor

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Click the New button or start COMSOL Multiphysics to open the Model Navigator.

2 Select 3D in the Space dimension list.

3 In the list of application modes choose Structural Mechanics Module>Solid, Stress-

Strain>Eigenfrequency analysis.

4 Click OK.

G E O M E T R Y  M O D E L I N G

Create the rotor by revolving a cross section about the symmetry axis.

1 From the Draw menu, choose Work-Plane Settings.

2 In the Work-Plane Settings, click OK to create a work plane in the x-y plane (the 
default).

3 From the Options menu, choose Axes/Grid Settings.

4 Set axis and grid settings in the work plane geometry (Geom2) according to the 
following table. To specify the grid settings, click the Grid tab and clear the Auto 
check box.

5 Click OK.

6 Shift-click the Line button on the Draw toolbar to open the Line dialog box.

7 In the x edit field type 0 0 0.171 0.213 0.213 0.266 0.266 0.356 0.356 
0.406 0.406 1.106 1.106 1.186 1.186 1.226 1.226 and in the y edit field 

AXIS GRID

x min -0.2 x spacing 0.2

x max 1.4 Extra x 0.171 0.213 0.266 0.356 0.406 
1.106 1.186 1.226

y min -0.4 y spacing 0.1

y max 0.4 Extra y -0.1475 -0.083 -0.066 -0.055 
-0.053 -0.045 -0.0425
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type 0 -0.045 -0.045 -0.045 -0.055 -0.055 -0.066 -0.066 -0.083 -0.083 
-0.1475 -0.1475 -0.053 -0.053 -0.0425 -0.0425 0. From the Style list select 
Closed polyline (solid), then click OK.

8 From the Draw menu, choose Revolve.

9 Use the x-axis as the revolution axis. Specify this by typing 1 and 0 in the x and y 
edit fields under the Second point button to define the second point on the 
revolution axis.

10 Click OK to revolve the cross section 360 degrees about the x-axis.

11 Click the Zoom Extents button on the Main toolbar.

P H Y S I C S  S E T T I N G S

Boundary Conditions
1 From the Physics menu choose Boundary Settings.

2 On the Constraint page of the Boundary Settings dialog box specify constraints 
according to the following table.

Subdomain Settings
The rotor is made of steel so you can use the default settings for the material 
properties.

BOUNDARY 2, 4, 6, 8 55, 56, 58, 60

Constraint condition Fixed Roller
R O T O R  |  323



324 |  C H A P T E
M E S H  G E N E R A T I O N

Click the Initialize Mesh button to create a mesh using the default mesh settings.

C O M P U T I N G  T H E  S O L U T I O N

Solve the problem by clicking the Solve toolbar button. With the default settings, 
COMSOL Multiphysics computes the first six eigenmodes and eigenfrequencies.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

COMSOL Multiphysics plots the first eigenmode using a slice plot. To change the plot 
to show the deformed shape and other eigenmodes, follow these steps:

1 Postprocessing menu, choose Plot Parameters.

2 In the Plot Parameters dialog box, clear the Slice check box and select the Boundary 
and Deformed shape check boxes in the Plot type area.

3 Select the second eigenfrequency in the Eigenfrequency list and click Apply to plot the 
second eigenmode.
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4 Select the last eigenfrequency in the Eigenfrequency list and click OK to plot the sixth 
eigenmode.
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E i g e n f r e qu en c y  Ana l y s i s  o f  a  F r e e  
C y l i n d e r

Introduction

In the following example you will build and solve an axial symmetric model using the 
Axial Symmetry, Stress-Strain application mode. 

This model calculates the eigenfrequencies and mode shapes of an axisymmetric free 
cylinder. The model is taken from NAFEMS Free Vibration Benchmarks (Ref. 1). The 
eigenfrequencies are compared with the values given in the benchmark report.

Model Definition

The model is NAFEMS Test No 41, “Free Cylinder” described on page 41 in 
NAFEMS Free Vibration Benchmarks, Volume 3 (Ref. 1). The Benchmark tests the 
capability to handle rigid body modes and close eigenfrequencies.
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The cylinder is 10 m high with an inner radius of 1.8 m and a thickness of 0.4 m.

M A T E R I A L

Isotropic material with E=2.0·1011 Pa and ν=0.3.

L O A D S

In an eigenfrequency analysis loads are not needed.

C O N S T R A I N T S

No constraints are applied because the cylinder is free.

z

r
1.8 m 0.4 m

10
.0

 m
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Results

The rigid body mode with an eigenvalue close to zero is found. The eigenfrequencies 
are in close agreement with the target values from the NAFEMS Free Vibration 
Benchmarks (Ref. 1).

The following plot shows the shape of the second eigenmode:

Reference

1. Abassian, F., Dawswell, D. J., and Knowles, N. C., Free Vibration Benchmarks, 
Volume 3, NAFEMS, Glasgow, 1987.

EIGENFREQUENCY COMSOL TARGET [1]

f1 0 Hz 0 Hz

f2 243.50 Hz 243.53 Hz

f3 377.40 Hz 377.41 Hz

f4 394.24 Hz 394.11 Hz

f5 397.88 Hz 397.72 Hz

f6 405.46 Hz 405.28 Hz
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Model Library path: Structural_Mechanics_Module/
Dynamics_and_Vibration/free_cylinder

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select Axial symmetry (2D) in the Space dimension list on the New page in the Model 

Navigator.

2 Select Structural Mechanics Module>Axial Symmetry, Stress-Strain>Eigenfrequency 

analysis and click OK.

O P T I O N S  A N D  S E T T I N G S

1 Select Axes/Grid Settings from the Options menu and give axis and grid settings 
according to the following table:

AXIS GRID

r min -0.2 r spacing 1

r max 2.4 Extra r 1.8 2.2
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G E O M E T R Y  M O D E L I N G

1 Click the Rectangle/Square toolbar button and click the left mouse button at (1.8, 0) 
move the mouse to (2.2, 10.0) and click the left mouse button again to create the 
rectangle.

P H Y S I C S  S E T T I N G S

Boundary Settings
No boundary conditions need to specified as the cylinder is free and without loads. 

Subdomain Settings
Specify the material properties of the free cylinder.

1 Select Subdomain Settings from the Physics menu.

z min -0.2 z spacing 1

z max 10.2 Extra z

AXIS GRID
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2 Specify subdomain settings according to the following table:

M E S H  G E N E R A T I O N

Use the default mesh.

C O M P U T I N G  T H E  S O L U T I O N

1 Select Solver Parameters from the Solve menu to open the Solver Parameters dialog 
box.

SUBDOMAIN 1

Page Material

Material model Isotropic material

E 2.0E11 (Pa)

ν 0.3

ρ 8000 (kg/m3)
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2 The eigenfrequency solver is already selected because you chose an eigenfrequency 
analysis in the Model Navigator. Regarding the eigenfrequency solver parameters, the 
default value of searching for the first 6 eigenfrequencies is OK.

3 Click OK to close the dialog box.

4 Click the Solve button on the Main toolbar to compute the solution.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Look at the eigenfrequencies and mode shapes.

1 Select Plot Parameters from the Postprocessing menu.

2 On the General page, look in the Eigenfrequency list to find the eigenfrequencies.

EIGENFREQUENCY COMSOL

f1 0 Hz

f2 243.50 Hz

f3 377.40 Hz

f4 394.24 Hz

f5 397.88 Hz

f6 405.46 Hz
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In an axisymmetric model that is free to move there is one rigid body mode. The rigid 
body mode has an eigenfrequency close to zero. The rigid body mode shape is a pure 
axial rigid body translation without any radial displacement.

3 Select the second eigenfrequency from the Eigenfrequency list.

4 Select the Deformed shape check box on the General page to plot the second or first 
true mode shape.

5 Click OK to plot the first true eigenmode.
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F r e qu en c y  R e s pon s e  Ana l y s i s  o f  a  
S imp l y  S uppo r t e d  P l a t e

In the following example you will build and solve a solid mechanics model using the 
Mindlin Plate application mode.

The model is a simply-supported thick square plate 10 m wide exposed to a uniform 
harmonic pressure. The model is taken from NAFEMS Test no 21 H, “Simply-
supported thick square plate harmonic forced vibration response” described on page 
29 in NAFEMS Selected Benchmarks for Forced Vibration (Ref. 1). The computed 
maximum displacement, stress, and excitation frequency that results in maximum 
response are compared with the values given in the benchmark report.

Model Definition

The geometry is a square. Due to symmetry in load and geometry, only a quarter of 
the square is analyzed.

M A T E R I A L

• Isotropic material with E = 2.0E11 Pa, ν = 0.3, and ρ = 8000 kg/m3

• Rayleigh damping: αdM = 5.772, βdK = 6.929·10−5

x

y

5.0 m

5.
0 

m

thickness 1.0 m

Force 1 MPa

z

sy
m

m
et

ry

symmetry
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L O A D S

A distributed harmonic force of 1 MPa on the upper surface pointing in the positive 
z direction. The excitation frequency range is 44–48 Hz.

C O N S T R A I N T S

Simply-supported edges on the top and left edge, global rotations constrained on the 
symmetry edges, x = 0, y = 0.

Results

The displacement amplitude at the center as a function of the excitation frequency is

The following table shows a comparison between the solution and the NAFEMS 
benchmark (Ref. 1): 

All results are in close agreement with the benchmark.

RESULT COMSOL MULTIPHYSICS NAFEMS (REF. 1)

Maximum displacement (mm) 59.66 58.33

Stress at top of plate at center (MPa) 802.8 800.8

Frequency at maximum response (Hz) 45.9 45.90
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Reference

1. J. Maguire, D.J. Dawswell, and L. Gould, Selected Benchmarks for Forced 
Vibration, NAFEMS, Glasgow, 1989.

Model Library path: Structural_Mechanics_Module/
Dynamics_and_Vibration/harmonically_excited_plate

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select 2D in the Space dimension list on the New page in the Model Navigator.

2 Select Structural Mechanics Module>Mindlin Plate>Frequency response analysis and 
click OK.
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G E O M E T R Y  M O D E L I N G

1 Select Axes/Grid Settings from the Options menu and give axis and grid settings 
according to the following table:

2 Click the Rectangle/Square toolbar button and click the right mouse button at (0, 0). 
Move the mouse while holding down the right mouse button, release the mouse 
button at (5, 5) to create a square.

3 Click the Zoom Extents button on the Main toolbar to zoom in on the created 
square.

P H Y S I C S  S E T T I N G S

In this section the analysis type is specified, and the boundary and subdomain settings 
is made.

AXIS GRID

x min -5 x spacing 1

x max 5 Extra x

y min -5 y spacing 1

y max 5 Extra y
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Boundary Settings
Constrain the outer edges as simply supported. Specify the symmetry edges to have the 
global rotation corresponding with the symmetry constrained.

1 Select Boundary Settings from the Physics menu.

2 Specify boundary settings according to the following tables:

Subdomain Settings
Specify the material properties, damping properties, and load of the Mindlin plate.

1 Select Subdomain Settings from the Physics menu.

BOUNDARY 3. 4

Page Constraint

Coordinate 
system

Tangent and normal coord. sys. (t,n)

Condition Simply supported

BOUNDARY 1 2

Page Constraint Constraint

Coordinate 
system

Global coordinate system Coordinate 
system

Global coordinate system

Ry 0 Rx 0
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2 Specify subdomain settings according to the following table:

M E S H  G E N E R A T I O N

Use the default mesh settings. Click the Initialize Mesh button on the Main toolbar to 
create a mesh.

C O M P U T I N G  T H E  S O L U T I O N

Specify the excitation frequency and range:

1 Select Solver Parameters from the Solve menu.

The parametric solver is the solver connected to the frequency response analysis 
type, and the Auto select solver option make sure that it has already been selected.

2 Type freq_smdrm in the Parameter name edit field.

SUBDOMAIN 1 1 1

Page Material Load Damping

Material model Isotropic material Fz 1e6 Damping model Rayleigh

E 2.0E11 αdM 5.772

ν 0.3 βdK 6.929E-5

ρ 8000

thickness 1
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3 Type 44:0.1:48 in the Parameter values to perform a frequency sweep between 
44 Hz and 48 Hz in 0.1 Hz increments.

4 Click OK.

5 Click the Solve button on the Main toolbar to compute the solution.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Analyze the maximum displacement amplitude.

1 Select Domain Plot Parameters from the Postprocessing menu.

2 Go to the General page and select all excitation frequencies in the Solutions to use list.

3 Select the Point page.

4 Select Disp. amplitude z dir. from the Predefined quantities list.
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5 Select 1 from the Point selection list to look at the result in the middle of the plate 
or select the point by clicking on it in the GUI.
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6 Click Apply to perform the selected plot, click Cancel to close the dialog box.

The maximum displacement amplitude is about 60 mm and appears at 45.9 Hz.

Find the maximum stress at the center of the plate:

1 Select Cross-Section Plot Parameters from the Postprocessing menu.

2 Go to the General page and select all excitation frequencies in the Solutions to use list.

3 Select the Point page.

4 Select sx normal stress amp. global sys. from the Predefined quantities list.
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5 The default x and y coordinates coincide with the request to look at the result in the 
middle, x=0, y=0.

6 Click Apply to perform the selected plot, click Cancel to close the dialog box.
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The maximum stress is just above 800 MPa.

Look at the maximum displacement in a surface plot.

1 Select Plot Parameters from the Postprocessing menu.

2 Go to the General page and select 45.9 from the Parameter value list in the Solution 

to use area.

3 Click the Surface tab.

4 Select Disp. amplitude z dir. from the Predefined quantities list on the Surface Data 
tab.

5 Click the Height Data tab and select the Height data check box.

6 Select Disp. amplitude z dir. from the Predefined quantities list on the Height Data tab.

7 Click OK to close the Plot Parameters dialog box.

8 Click the Scene Light and Headlight button on the Camera toolbar.

9 Click the Zoom Extents button on the Main toolbar
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F a t i g u e  M o d e l s
This chapter contains a number of models using fatigue analysis. Note that the 
commands for fatigue analysis require COMSOL Script or MATLAB. The table 
below lists the models categorized by the type of fatigue analysis performed.

MODEL PAGE FATIGUE SCRIPT

H
IG

H
 C

Y
C

L
E

 F
A

T
IG

U
E

L
O

W
 C

Y
C

L
E

 F
A

T
IG

U
E

P
R

O
P

. L
O

A
D

IN
G

N
O

N
P

R
O

P
. L

O
A

D
IN

G
Shaft with Fillet 346 shaft_with_fillet_fatigue.m √ √

Frame with Cutout 357 frame_with_cutout_fatigue.m √ √

Cylinder with Hole 372 cylinder_hole_linear_fatigue.m 
cylinder_hole_plastic_fatigue.m

√ √

Fatigue Analysis of 
Automobile Wheel 
Rim

386 wheel_rim_fatigue_superpose.m 
wheel_rim_fatigue_analysis.m

√ √
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S h a f t  w i t h  F i l l e t

Introduction

This model is of “benchmark” type, based on the example found in section 5.4.3 of 
Ref. 1, and shows how to perform a high-cycle fatigue analysis for nonproportional 
loading using critical planes.

Model Definition

The geometry is a circular shaft with two different diameters, 10 mm and 20 mm. At 
the transition, between the two parts, there is a fillet with a radius of 3 mm.

Figure 9-1: Model geometry
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Two time-dependent loads are applied to the small end of the shaft: a transverse force, 
causing bending, and a twisting moment. As Figure 9-2 shows, the force varies 
between 0 and 2.95 kN and the torque between −30.3 Nm and +30.3 Nm.

Figure 9-2: Variation of the bending force and twisting moment during one load cycle.

Compute the fatigue usage factor by analyzing the total stress distribution at times t1, 
t2 and t3. 

M A T E R I A L  P R O P E R T I E S

• Elastic data: Isotropic with E = 100 GPa, ν = 0

• Fatigue data: The fatigue limit is known for two cases with pure axial loading. For 
pure tension it is 560 MPa (σmax = 1120 MPa, σmin = 0 MPa), and for fully 
reversed loading it is 700 MPa (σmax = 700 MPa, σmin = −700 MPa). This gives 

t1 t2 t3

t1 t2 t3
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the Findley parameters f = 440 MPa and k = 0.23 if Equation 14-16 on page 379 in 
the Structural Mechanics Module User’s Guide is applied.

C O N S T R A I N T S

The thick end of the bar is fixed.

L O A D S

• Bending load: The transverse force is evenly distributed as a shear traction over the 
small end.

• Torsional load: A shear stress in the circumferential direction is applied to the bar 
end. It is given as a linear variation with the radius in correspondence with analytical 
solutions for torsion.

Results and Discussion

Figure 9-3 shows the von Mises stresses for the bending load cases. The location for 
the maximum effective stress is at the surface of the fillet, at a radius slightly larger than 
the minimum radius of the shaft. The maximum effective stress can also be found at a 
diametrically opposite location. Here, the bending load gives rise to a compression 
stress of equal magnitude as the tension stress at the other side. Due to numerical 
reasons, the maximum stresses do not occur exactly in the x-z plane.

Figure 9-3: von Mises stress distribution from the bending load case.
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Figure 9-4 shows the effective stress distribution for the torsional load. You can find 
the maximum value along the surface of the fillet, where the shear stress in the 
circumferential direction is at a maximum.

Figure 9-4: von Mises stress distribution for the torsional load case.

In Figure 9-5 you can see that the highest value of the utilization factor, 0.962, is 
found where the positive bending stress is combined with the shear stress from torsion. 
Note that on the diametrically opposite side of the shaft, with the maximum 
compressive stress due to the bending, the utilization factor is only slightly increased 
compared to the surrounding areas.

Figure 9-5: Fatigue utilization factor.
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The history of each of the global stress components in the most critical point is shown 
in Figure 9-6. Because the peak stresses occur at a small distance up along the fillet and 
because, for numerical reasons, they are not found exactly in the plane  y = 0, all stress 
components are nonzero.

Figure 9-6: Histories for global stress components.

For the example in Ref. 1 the computed Findley parameter is 433 MPa, which gives a 
utilization factor of 0.984. This is slightly higher than the utilization factor computed 
by this model, which is 0.962. The difference is mainly due to the simplified approach 
of the referenced example, where only the normal stress component from the bending 
load and the shear stress component from the torsional load are considered. In reality, 
there are additional stress components, especially in the bending case. Also, the peak 
stress concentration does not occur at exactly the same location in the two load cases.

Modeling in COMSOL Multiphysics

Start by using the parametric solver to solve the static problem for the load cases of the 
maximum bending force and the maximum twisting moment, respectively. These are 
the two basic load cases that you can combine and use for the fatigue analysis.

Carry out the fatigue analysis, in either COMSOL Script or MATLAB, by doing the 
following steps:

• Extract the stress distribution (stress tensor) for both basic load cases from the FEM 
structure of the model.
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• Set up the matrix containing the combinations of basic load cases which you can use 
for the fatigue analysis. The rows of this matrix correspond to the time instances you 
are analyzing, and the columns correspond to the basic load cases.

In this case the matrix is a 3x2 matrix. If you look at Figure 9-2 you can see that at 
time t1 both loads are zero, thus the first row has only zeros. At time t2 the bending 
force is at maximum, while the torque at minimum. You obtain the combined 
stresses by subtracting the solution of the twisting moment from that of the bending 
force. The second row of the matrix is thus 1 −1. Both loads are at maximum at the 
third time, t3, which means that you can add the basic load cases and the third row 
of the matrix contains two ones.

• Run the fatigue analysis function hcfmultiax.

Reference

1. D, F. Socie and G.B. Marquis, Multiaxial Fatigue, SAE, 1999.

Model Library path: Structural_Mechanics_Module/Fatigue/
shaft_with_fillet

Note: This model requires COMSOL Script or MATLAB to run the fatigue script 
shaft_with_fillet_fatigue.m

Modeling Using the Graphical User Interface

This section describes how to solve the two basic load cases using COMSOL 
Multiphysics.

M O D E L  N A V I G A T O R

1 On the New page, select 3D from the Space dimension list.

2 From the Application Modes list, select Structural Mechanics Module>Solid, 

Stress-Strain>Static analysis.

3 Click OK.
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O P T I O N S  A N D  S E T T I N G S

1 From the Options menu select Constants and enter the following constants; then 
click OK.

2 Select Model Settings from the Physics menu to open the Model Settings dialog box.

3 Select MPa from the Base unit system list to use mm as length scale and MPa as stress 
unit. Click OK.

G E O M E T R Y  M O D E L I N G

Create the geometry by drawing a 2D plane and rotate it.

1 Select Work Plane Settings from the Draw menu to open the Work Plane Settings 
dialog box.

2 Click OK to create a 2D work plane in the xy-plane which is the default settings.

3 Select Axes/Grid Settings from the Options menu and give axis and grid settings 
according to the following table. On the Grid page, clear the Auto check box to enter 
the grid spacing.

4 Click the Line button on the Draw toolbar. Click the left mouse button at (0, 0), 
then move the mouse to (0, 10) and click the left mouse button again.

5 Move the mouse to (25, 10) and click the left mouse button again.

6 Move the mouse to (25, 8) and click the left mouse button.

7 Click the 2nd Degree Bézier Curve toolbar button.

8 Move the mouse to (25, 5) and click the left mouse button.

NAME EXPRESSION DESCRIPTION

M 30.3[N*m] Torque amplitude

R 5[mm] Radius where torque and force are applied

k M/(R^4*pi/2) Constant used in distributed moment calculation

param 1 Parameter used to control the load cases

F 2.95[kN] Maximum bending force

A pi*R^2 Area of surface where force is applied

AXIS GRID

x min -5 x spacing 1

x max 60 Extra x

y min -15 y spacing 1

y max 15 Extra y
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9 Move the mouse to (28, 5) and click the left mouse button.

10 Click the Line button on the Draw toolbar.

11 Move the mouse to (50, 5) and click the left mouse button.

12 Move the mouse to (50, 0) and click the left mouse button.

13 Click the right mouse button to form a 2D solid.

14 Select Revolve from the Draw menu to open the Revolve dialog box.

15 Select Axis direction through: Second point.

16 Enter x 1 y 0 as the coordinates of the Second point.

17 Click OK to close the Revolve dialog box and create the shaft.

P H Y S I C S  S E T T I N G S

Boundary Conditions
1 Select Boundary Settings from the Physics menu.

2 Specify boundary settings according to the following table:

Subdomain Settings
1 Select Subdomain Settings from the Physics menu.

2 Specify subdomain settings according to the following table:

M E S H  G E N E R A T I O N

1 Select Free Mesh Parameters from the Mesh menu to open the Free Mesh Parameters 
dialog box.

SETTINGS BOUNDARIES 1, 3, 5, 7 BOUNDARIES 21–24

Page Constraint Load

Constraint condition Fixed

Fx 0

Fy -z*k*(param>1.5)

Fz y*k*(param>1.5)-F/A*(param<1.5)

SETTINGS SUBDOMAIN 1

 Page Material

 Material model Isotropic

 E 100[GPa]

 ν 0
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2 On the Subdomain page, type 1.2 in the Element growth rate edit field.

3 On the Boundary page, select Boundaries 11, 12, 14, and 16.

4 Enter 1 in the Maximum element size edit field. Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Select Solver Parameters from the Solve menu to open the Solver Parameters dialog 
box.

2 Select Parametric in the Solver list.

3 Specify param in the Parameter name edit field.

4 Specify 1,2 in the Parameter values edit field.

5 Select Conjugate gradients from the Linear system solver list. Click OK.

6 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Select Plot Parameters from the Postprocessing menu.

2 Select 1 from the Parameter value list on the General page to plot the von Mises stress 
distribution from the bending.

3 Select 2 from the Parameter value list to plot the von Mises stress distribution from 
torsion.

Fatigue Analysis

This section describes how to solve the fatigue problem.

You have already solved the static bending and torsion load cases. 

• Select File>Export>FEM Structure as 'fem' from the File menu to export the FEM 
structure containing the static load cases to the command line.

• Run the script shaft_with_fillet_fatigue.m by typing 
shaft_with_fillet_fatigue and pressing Return.

The script shaft_with_fillet_fatigue.m is shown below.

% Compute all components of the stress tensor
[sxx, syy, szz, sxy, syz, sxz] = posteval(fem,'sx_smsld','sy_smsld',...
                                          'sz_smsld',...
                                          'sxy_smsld','syz_smsld',...
                                          'sxz_smsld',...
                                          'edim',2,'solnum','all','cont','on');
sigma = zeros(6,size(sxx.d,2),size(sxx.d,1));
sigma(1,:,:)=sxx.d';
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sigma(2,:,:)=syy.d';
sigma(3,:,:)=szz.d';
sigma(4,:,:)=sxy.d';
sigma(5,:,:)=syz.d';
sigma(6,:,:)=sxz.d';

% Fatigue data for the material
params.f = 440;
params.k = 0.23;

% Combine the basic load cases to form the fatigue load cycle
lccomb = [0 0; 1 1; 1 -1];

% Resolution when searching for the critical plane
angle_step = 6; % degrees

% Compute the fatigue damage
[resval, sigma_max, delta_tau, worst_ind, s_history]= hcfmultiax(sigma, ...
                   'lccomb', lccomb, 'anglestep', angle_step, 'params', params);

% Copy a postdata struct from the stress evaluation and assign the damage data
% to the value field (d)
findley_res = sxx;
findley_res.d(1,:) = resval;
figure(1);

% Plot the fatigue damage
postdataplot(findley_res,...
             'scenelight','on',...
             'campos',[244,-161,77],...
             'camtarget',[24.5,0,0],...
             'camva',9.5,...
             'title','Fatigue utilization factor');

% Plot the maximum normal stress in the critical plane
sigma_max_res = sxx;
sigma_max_res.d(1,:) = sigma_max;
figure(2);
postdataplot(sigma_max_res,...
             'scenelight','on',...             
             'campos',[244,-161,77],...
             'camtarget',[24.5,0,0],...
             'camva',9.5,...
             'title','Maximum normal stress');

% Plot the shear stress in the critical plane
delta_tau_res = sxx;
delta_tau_res.d(1,:) = delta_tau;
figure(3);
postdataplot(delta_tau_res,...
             'scenelight','on',...
             'campos',[244,-161,77],...
             'camtarget',[24.5,0,0],...
             'camva',9.5,...
             'title','Shear stress amplitude');
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% Plot the stress history for all stress components at the point with
% maximum fatigue damage
x = 1:(size(s_history,2));
figure(4);
if isscript
  plot(x,s_history,'linestyle','cycle');
else
  plot(x,s_history);
end
legend('sxx','syy','szz','sxy','syz','sxz')
title('Stress history in critical point')
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F r ame w i t h  Cu t o u t

Introduction

In a beam of a load-carrying frame, there is a cutout which causes stress concentrations.

Figure 9-7: Geometry of the beam with cutout showing the location of the strain gauges. 
The arrows indicate the measurement direction.

Concern arises that fatigue cracks might occur at the cutout as the service loads are 
increased. Since the loading is random in nature, it needs to be measured before a 
fatigue analysis can be carried out. The measurements are performed during a few 
representative service cycles by three strain gauges attached at locations indicated in 
Figure 9-7.

Based on these measurements, you can perform a fatigue analysis of the beam. First 
build and solve a static model of the beam, to calculate, from the strain measurements, 
the stresses at the critical locations around the cutout. You can then use a built-in 
function to perform a rainflow count on the stress history. By this, load cycles are 
grouped together based on amplitude and mean stress into groups or bins. Finally, you 
calculate the accumulated fatigue damage by considering the contribution from each 
bin.

Note: The fatigue analysis for this model requires COMSOL Script or MATLAB.

strain gauges

1

2
3

x
y

z
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Model Definition

Model the beam using shell elements. Fix one end and apply loads to the other end. 
Assume that the stress distribution in the beam can be obtained by combining together 
three separate load cases, representing torsion and bending around the two main axes. 
Solve the model, using the parametric solver, for these three basic load cases.

Use the FE model to compute a relation between the measured strains and the 
corresponding stresses. The relation between the stress at location i and the strain 
measured by the gauge at location k can be written as

 (9-1)

To find the values of the coefficients, qik, use the results from the three basic load cases, 
solving a linear system of equations based on Equation 9-1.

M A T E R I A L

• Elastic data: Isotropic with E = 200 GPa, ν = 0.3.

• Fatigue data: Iron Alloy 4340 (UNS G43400), three S-N curves for three different 
R values, extracted from the COMSOL Multiphysics Material Library using the 
function matlibfatigue. You can do this by running the script 
extractSNCurvesFromMatlib. If you do not have the Material Library product 
the functions have already been extracted for you, and have the following names:

-  sn_mat1_r_min1 (R = − 1)

-  sn_mat1_r_043 (R = 0.43)

-  sn_mat1_r_0 (R = 0)

C O N S T R A I N T S

Fix the edges at one end of the beam.

L O A D S

• Moment around the x-axis (torsional load): a constant tangential traction of 
100 MPa is applied to each of the four edges.

σi t( ) qik εk t( )⋅

k 1=

3

∑=
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• Moment around the y-axis (bending load): constant normal stress of +100 MPa on 
one “flange” constant normal stress of − 100 MPa on the other, and a normal stress 
along the two “webs” that varies linearly with z.

• Moment around the z-axis (bending load): constant normal stress of +100 MPa on 
one “flange” constant normal stress of − 100 MPa on the other, and a normal stress 
along the two “webs” that varies linearly with y.

T H E  F I N I T E  E L E M E N T  M E S H

Due to the highly nonlinear relation between stress and fatigue life, it is necessary to 
resolve the stress peaks in detail in a fatigue life analysis. Therefore, use a fine mesh 
around the fillets in the cutout to study the local stress concentration in this region. 

Since high-quality results are also required at the locations of the strain gauges, add 
two extra points to the geometry in order to control the mesh there. Two of the strain 
gauges are placed at 45 degrees from the beam axis, see Figure 9-7. For these, you can 
create a correspondingly rotated local coordinate system to measure the strains.
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Results and Discussion

Figure 9-8 shows the von Mises stress for the torsional load case. For this load case, 
the effect of the cutout is dramatic, with a stress concentration factor that exceeds 10 
at the fillets.

Figure 9-8: von Mises stress around the cutout for the torsional load case.

Figure 9-9 shows the accumulated damage for the evaluation points along the four 
fillets. For the upper right and lower left corners the damage is close to 1, which means 
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that the material almost reached the allowable number of load cycles until fatigue 
damage occurs.

Figure 9-9: Accumulated damage along the four fillets around the cutout.

By plotting the damage distribution and cycle count for the stress bins, you can study 
how each stress group contributes to the fatigue damage accumulation. In 
Figure 9-10, you can see that it is almost exclusively certain high loads that contribute 
to the total damage at the most critical point. However, these high loads only occur 
once or twice each in the measured load history, as you can see in the cycle count plot 
for the stress bins, Figure 9-11.

The results illustrate some of the difficulties when performing fatigue analysis. The 
high stress values can be explained by scatter in the measurements, in which case the 
accumulated damage value may be too high. Additional measurements during a longer 
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service period would clarify if this is the case, before taking any type of decision on how 
to modify the load-carrying frame.

Figure 9-10: Damage distribution as a function of stress bins, characterized by an 
amplitude and mean stress, for the critical point, which is at the lower left fillet.
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Figure 9-11: Cycle count for each bin, characterized by a stress amplitude and mean stress, 
for the critical point, which is at the lower left fillet.

Modeling in COMSOL Multiphysics

First, build and solve the model with the three basic load cases of a torsional load and 
bending load in two directions.

For the fatigue analysis, export the FEM structure to COMSOL Script or MATLAB, 
where you can carry out the following steps:

• Based on the stresses and strains obtained from the solution of the static problem, 
compute coefficients, qik, that appear in Equation 9-1.

• Use these coefficients to calculate the stress history for the locations of interest (at 
the fillets of the cutout) from the measured strain history.

• With the rainflow function, identify groups of load cycles with similar amplitude 
and mean stress and group these together into bins (rainflow counting). Use 10 
groups for the mean stress and 20 groups for the stress amplitude, which results in 
200 bins.
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• Calculate the accumulated fatigue damage for the binned stress history by using the 
fatiguedamage function.

Model Library path: Structural_Mechanics_Module/Fatigue/
frame_with_cutout

Modeling Using the Graphical User Interface

This section describes how to solve the three unit load cases using COMSOL 
Multiphysics.

M O D E L  N A V I G A T O R

1 On the New page, select 3D as Space dimension.

2 From the Application Modes list, select 
Structural Mechanics Module>Shell>Parametric analysis.

3 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 Select Model Settings from the Physics menu to open the Model Settings dialog box.

2 Select MPa from the Base unit system list to use mm as length scale and MPa as stress 
unit. Click OK.

G E O M E T R Y  M O D E L I N G

1 Click the Block button on the Draw toolbar to open the Block dialog box.

2 Select Face in the Style area.

3 Enter 1100 as the length in the x direction in the X edit field in the Length area.

4 Enter 154 as the length in the y and z directions in the Y and Z edit fields in the 
Length area. Click OK.

5 Click Zoom Extents on the Main toolbar.

6 Select the block and click the Split Object toolbar button to split the block in faces.

7 Select face F2, F3, and F5 and press the Delete key on your keyboard.

8 Select Work Plane Settings from the Draw menu to open the Work Plane Settings 
dialog box.
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9 Select z-x in the Plane area and click OK to create a 2D work plane in the global 
zx-plane.

10 Select Specify Objects>Rectangle from the Draw menu to open the Rectangle dialog 
box.

11 Enter 154 as Width and 1100 as Height and click OK to create a rectangle.

12 Select Specify Objects>Rectangle from the Draw menu to open the Rectangle dialog 
box.

13 Enter 60 as Width, 100 as Height, 47 as x and 500 as y and click OK to create an 
additional rectangle.

14 Select Specify Objects>Rectangle from the Draw menu to open the Rectangle dialog 
box.

15 Enter 80 as Width, 80 as Height, 37 as x and 510 as y and click OK to create the last 
rectangle.

16 Select Specify Objects>Circle from the Draw menu to open the Circle dialog box.

17 Enter 10 as Radius, 47 as x and 510 as y and click OK to create a circle.

18 Click the Zoom Extents button on the Main toolbar.

19 Click the circle and press Ctrl+C to copy the circle.

20 Click the Array toolbar button to make an array copy of the circle.

21 Enter 60 and 80 as x and y Displacement in the Array dialog box.

22 Enter 2 as the x and y Array size and click OK to create the circles.

23 Select the circles and the small rectangles and click the Union toolbar button.

24 Select both the large rectangle and the rectangle with the rounded corners and click 
the Difference toolbar button to cut out the small rectangle from the large rectangle.

25 Select Embed from the Draw menu to open the Embed dialog box, click OK to close 
the dialog box and embed the rectangle with the cut-out into the 3D geometry.

26 Select Point from the Draw menu to open the Point dialog box. Enter, 850, 77, 0 as 
Coordinates, then click OK to close the Point dialog box and create the new point.

27 Select Point from the Draw menu to open the Point dialog box. Enter, 850, 154, 77 
as Coordinates, then click OK to close the Point dialog box and create the second 
point.

P H Y S I C S  S E T T I N G S

Boundary Conditions
1 Select Boundary Settings from the Physics menu.
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)

2 Specify boundary settings according to the following table:

The coordinate system for postprocessing is specified to coincide with the directions 
of the strain gauges.

Edge Settings
1 Select Edge Settings from the Physics menu.

2 Specify edge settings according to the following tables:

SETTINGS BOUNDARIES 1–4 BOUNDARIES 3, 4 BOUNDARY 2

 Page Material Postprocessing Postprocessing

 E 200[GPa]

 ν 0.33

 thickness 6

 Evaluate at Bottom of shell

 xlocal 1[m] 1[m] t1z[m]

SETTINGS EDGES 1, 2, 4, 6 EDGES 17–20

Page Constraint Load

Constraint condition Fixed

Load definition Load is defined as force/area and 
moment/area using the thickness

SETTINGS EDGE 17

Page Load

Fx 100[MPa]/77[mm]*(z-77)*(para>1.5)*(para<2.5)+(para>2.5)*100[MPa]

Fz -100[MPa]*(para<1.5)

SETTINGS EDGE 18

Page Load

Fx -100[MPa]*(para>1.5)*(para<2.5)-(para>2.5)*100[MPa]/77[mm]*(y-77

Fy 100[MPa]*(para<1.5)

SETTINGS EDGE 19

Page Load

Fx 100[MPa]*(para>1.5)*(para<2.5)-(para>2.5)*100[MPa]/77[mm]*(y-77)

Fy -100[MPa]*(para<1.5)
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M E S H  G E N E R A T I O N

1 From the Mesh menu, choose Free Mesh Parameters to open the Free Mesh Parameters 
dialog box.

2 Click the Global page and select Extra fine from the Predefined mesh sizes list.

3 Click the Custom mesh size radio button.

4 Enter 20 in the Maximum element size edit field.

5 Enter 1.2 in the Element growth rate edit field.

6 Enter 0.2 in the Mesh curvature factor edit field.

7 Click the Edge page and select Edges 10, 11, 14, and 15. 

8 Enter 0.5 in the Maximum element size edit field.

9 Enter 1.1 in the Element growth rate edit field.

10 Click the Point page and select Points 13 and 14. 

11 Enter 1 in the Maximum element size edit field.

12 Enter 1.1 in the Element growth rate edit field.

13 Click the Remesh button and then click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 From the Solve menu, choose Solver Parameters.

2 In the Parameter name edit field, type para.

3 In the Parameter values edit field, type 1:3.

4 Click OK.

5 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 From the Postprocessing menu, choose Plot Parameters.

2 Select 1 from the Parameter value list to plot the von Mises stress distribution from 
the bending. Click Apply.

3 Select 2 from the Parameter value list to plot the von Mises stress distribution from 
torsion. Click OK.

SETTINGS EDGE 20

Page Load

Fx 100[MPa]/77[mm]*(z-77)*(para>1.5)*(para<2.5)-(para>2.5)*100[MPa]

Fz 100[MPa]*(para<1.5)
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Fatigue Analysis

This section describes how to solve the fatigue problem.

You have already solved the three unit load cases. 

• Select File>Export>FEM Structure as 'fem' from the File menu to export the FEM 
structure containing the unit load cases to the command line.

• Run the script extractSNCurvesFromMatlib.m by typing 
extractSNCurvesFromMatlib and pressing Enter. The script extract three S-N 
functions for the Steel Alloy 4340 (UNS G43400) material. The 
extractSNCurvesFromMatlib script requires the Material Library. The S-N 
functions needed in this model example have already been extracted from the 
Material Library, so you do not need to run the script in order to continue with the 
analysis.

The script extractSNCurvesFromMatlib.m is shown below. 

%   Material Steel alloy UNS G43400

%   Uniaxial test at 293K and 2000-2500 cpm,
%   R=-1, un-notched rolled bar, 1.125 diameter, air melted,
%   0.4 inch diameter test sample, hand polished to RMS 5-10,
%   longitudinal direction, UTS=200ksi  

found = matlibfatigue('material', '4340 (UNS G43400)', 'phase',...
                      'UTS 200 Ksi - 293K', 'funcname', 'sn_mat1_r_min1',...
                      'ori', 'R=-1; unnotched', 'rvalue', -1);
    if (~found)
      error(['material 4340 (UNS G43400), UTS 200 Ksi - 293K, R=-1; ',...
             'unnotched: not found in material library']);
    end                  

%   Uniaxial test at 293K and 2000-2500 cpm,
%   R=0.43, un-notched rolled bar, 1.125 diameter, air melted,
%   0.4 inch diameter test sample, hand polished to RMS 5-10,
%   longitudinal direction, UTS=200ksi

found = matlibfatigue('material', '4340 (UNS G43400)', 'phase',...
                      'UTS 200 Ksi - 293K', 'funcname', 'sn_mat1_r_043',...
                      'ori', 'R=0.43; unnotched', 'rvalue', 0.43);
    if (~found)
      error(['material 4340 (UNS G43400), UTS 200 Ksi - 293K, R=0.43; ',...
             'unnotched: not found in material library']);
    end                  

%   Uniaxial test at 293K and 2000-2500 cpm,
%   R=0, un-notched rolled bar, 1.125 diameter, air melted,
%   0.4 inch diameter test sample, hand polished to RMS 5-10,
%   longitudinal direction, UTS=200ksi
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found = matlibfatigue('material', '4340 (UNS G43400)', 'phase',...
                      'UTS 200 Ksi - 293K', 'funcname', 'sn_mat1_r_0',...
                      'ori', 'R=0; unnotched', 'rvalue', 0);
    if (~found)
      error(['material 4340 (UNS G43400), UTS 200 Ksi - 293K, R=0; ',...
             'unnotched: not found in material library']);
    end                  

• Run the script frame_with_cutout_fatigue.m by typing 
frame_with_cutout_fatigue and pressing Enter.

The script frame_with_cutout_fatigue.m is shown below.

eps_pos = [850; 77; 0];  %Location of first strain gauge
ex_gauge_p1 = postinterp(fem,'exl_smsh',eps_pos,'solnum','all','edim',2);
ey_gauge_p1 = postinterp(fem,'eyl_smsh',eps_pos,'solnum','all','edim',2);

eps_pos = [850; 154; 77]; %Location of second strain gauge
ex_gauge_p2 = postinterp(fem,'ex_smsh',eps_pos,'solnum','all','edim',2);

% X and Z coordinates for all four fillet radii centres
x0r = 600-10;
x0l = 500+10;
z0u = 77+40-10;
z0d = 77-40+10;

r = 10.002; %Fillet radius (with a little roundoff tolerance)

nstep = 20; % Number of evaluation steps along each fillet

s1 = zeros(3, nstep*4); % Storage for max principal stress
s3 = zeros(3, nstep*4); % Storage for min principal stress

% For all points along the fillets, get the pricipal stresses
for k = 1:nstep
  phi =pi/2/(nstep-1)* (k-1);
  x = x0l - r*cos(phi);
  z = z0u + r*sin(phi);
  sig_pos = [x; 0; z];
  [s1(:,k), s3(:,k)] = postinterp(fem,'s1_smsh','s3_smsh', ...
    sig_pos,'solnum','all','edim',2);
  x = x0r + r*cos(phi);
  z = z0u + r*sin(phi);
  sig_pos = [x; 0; z];
  [s1(:,k+nstep), s3(:,k+nstep)] = postinterp(fem,'s1_smsh', ...
    's3_smsh',sig_pos,'solnum','all','edim',2);
  x = x0r + r*cos(phi);
  z = z0d - r*sin(phi);
  sig_pos = [x; 0; z];
  [s1(:,k+2*nstep), s3(:,k+2*nstep)] = postinterp(fem,'s1_smsh', ...
    's3_smsh',sig_pos,'solnum','all','edim',2);
  x = x0l - r*cos(phi);
  z = z0d - r*sin(phi);
  sig_pos = [x; 0; z];
  [s1(:,k+3*nstep), s3(:,k+3*nstep)] = postinterp(fem,'s1_smsh', ...
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    's3_smsh',sig_pos,'solnum','all','edim',2);
end

% For the basic load cases, either s1 or s3 will be dominating,
% since the stress state is uniaxial.
% Select the interesting component and store in "stress".
stress = s1.*(abs(s1) > abs(s3)) + s3.*(abs(s1) < abs(s3));

% Compute the "transfer coefficients" q from strain gauges to stress 
locations
A = [ex_gauge_p1 ey_gauge_p1 ex_gauge_p2];
q = (A \ stress)';

% Read the measurements from file
load frame_with_cutout_strain_gauge_values.dat
gauge_val=frame_with_cutout_strain_gauge_values';
hist_len = size(gauge_val,2);

% The strain gauge values
figure(1)
plot(1:hist_len,gauge_val(1,:),1:hist_len,gauge_val(2,:),...
     1:hist_len,gauge_val(3,:))
xlabel('time [s]')
ylabel('strain')
title('Strain gauge measurements')

% Compute corresponding stress point histories, transform to SI units
stress_histories = q * gauge_val*1e6;

na = 20; % Number of amplitude bins
nm = 10; % Number of mean stress bins

worst_damage = 0;
for k = 1:nstep*4 % Loop for all stress points
  [range, meanRange, count] = rainflow(stress_histories(k,:), na, nm);
  ampl = range / 2;
  [total_damage(k), damage_dist] = fatiguedamage('amprange', ...
    ampl,'meanrange', ...
    meanRange, 'count',count,'nrepeat', 10000,...
    'sncurves',{'sn_mat1_r_min1'; 'sn_mat1_r_0'; 'sn_mat1_r_043'}, ...
    'rvalue',[-1 0 0.43], 'fatiguelim',[5.0e8 3.8e8 3.0e8]);
  if total_damage(k) > worst_damage
    worst_damage_ind = k;
    worst_damage = total_damage(k);
  end
end

% Create damage plots of critical point
[range, meanRange, count] = rainflow(...
                              stress_histories(worst_damage_ind,:), na, nm);
ampl = range / 2;
da = (ampl(2) - ampl(1)) / na;
dm = (meanRange(2) - meanRange(1)) / nm;

for i = 1:na
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  x(i) = (ampl(1) + (i-0.5) * da) * 1e-6;
end

for i = 1:nm
  y(i) = (meanRange(1) + (i-0.5) * dm) * 1e-6;
end
[worst_damage, worst_damage_dist] = fatiguedamage('amprange',ampl, ...
  'meanrange', meanRange, 'count',count,'nrepeat', 10000, ...
  'sncurves',{'sn_mat1_r_min1'; 'sn_mat1_r_0'; 'sn_mat1_r_043'}, ...
  'rvalue', [-1 0 0.43], 'fatiguelim',[5.0e8 3.8e8 3.0e8]);

figure(2);
stem3(x,y,worst_damage_dist');
title('Damage distribution');
xlabel('Stress amplitude');
ylabel('Mean stress');
zlabel('Relative damage');

figure(3);
stem3(x,y,count');
title('Count matrix');
xlabel('Stress amplitude');
ylabel('Mean stress');
zlabel('Cycle count');

figure(4)
h = plot(90/(nstep-1)*(0:nstep-1), reshape(total_damage,nstep,4));
title('Damage after 10000 measurement cycles');
xlabel('Angle along fillet [degrees]');
ylabel('Total damage');
legend('Upper left','Upper right','Lower right','Lower left');
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C y l i n d e r  w i t h  Ho l e

Introduction

A load carrying component of a structure is subjected to multi-axial cyclic loading 
during which localized yielding of the material occurs. In this model you perform a 
low cycle fatigue analysis of the part based on the Smith-Watson-Topper (SWT) 
model. Due to localized yielding, you can use two methods to obtain the stress and 
strain distributions for the fatigue law. The first method is an elasto-plastic analysis with 
linear kinematic hardening, while the second is a linear elastic analysis with Neuber 
correction for plasticity, based on the Ramberg-Osgood material model. 

Model Definition

The cylindrical geometry contains a hole, drilled perpendicularly to its axis. As the 
structure and loading contains several symmetries, you may model only 1/8 of the 
cylinder.

Figure 9-12: Model geometry with constrained and loaded faces.

Model the cylinder using the parametric solver to obtain the stress and strain 
distributions during a full load cycle. Assume an elasto-plastic material model with 
linear kinematic hardening. Use the first elastic load step of this model as the basis for 
the second simplified linear elastic analysis. Since you can apply superposition to obtain 
the stress distribution for a linear elastic analysis, you can simply multiply the stresses 
at the first load step with a factor to obtain the stresses at the maximum load.

Symmetry planes

Applied load
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For the linear elastic fatigue analysis, assume that the local stress state does not depend 
on the overall elasto-plastic behavior. Account for local plastic strain development by 
the Neuber correction according to Equation 14-24 to Equation 14-30 in the 
Structural Mechanics Module User’s Guide, based on the Ramberg-Osgood model. 
You can compare this material model with linear kinematic hardening in Figure 9-13.

Figure 9-13: Comparison between Ramberg-Osgood and linear kinematic hardening 
material models.

Note: The fatigue analysis for this model requires COMSOL Script or MATLAB.

M A T E R I A L  P R O P E R T I E S

• Elastic data: Isotropic with E = 210 GPa, ν = 0.3.

• Parameters for the Ramberg-Osgood material model: K' = 1550 MPa, n' = 0.16.

• Kinematic hardening plasticity data: 

- Yield stress 380 MPa

- Tangent modulus 75 GPa

• Fatigue parameters for the SWT equation:

-  σf' = 1323 MPa

-  b = − 0.097

-  εf' = 0.375

-  c = − 0.60
C Y L I N D E R  W I T H  H O L E  |  373



374 |  C H A P T E
C O N S T R A I N T S

Apply symmetry conditions on the three symmetry sections shown in Figure 9-12.

L O A D S

Apply two load cycles of a normal stress with an amplitude of 200 MPa and a sinusoidal 
variation in time (parameter value) to the free bottom face of the cylinder, see 
Figure 9-12.

Results and Discussion

The von Mises stress when the maximum load is reached for the first time (at a 
parametric value of 1) in the elasto-plastic analysis is shown in Figure 9-14. Notice that 
the yield limit is extensively exceeded, and you can therefore expect significant plastic 
strains.

For a point located on the face of the hole, the greatest stresses appear in the 
z-direction. In Figure 9-16, you can follow the development of the normal stress and 
strain in this direction during the two load cycles. As the stress increases, plastic 
deformation occurs when the yield level is reached. On load reversal, there is an initial 
elastic deformation followed by new plastic deformation when the effective stress 
reaches the yield level once more. You can see that after the maximum load is reached 
for the first time, a stable hysteresis loop develops with subsequent cycles following the 
original one exactly. This behavior is characteristic of a kinematic hardening model.

The development of the effective plastic strain for the same point appears in 
Figure 9-15. The regions where effective plastic strain is constant correspond to 
regions of elastic deformation in Figure 9-16.

To perform the fatigue analysis, you can use the stress and strain distributions from a 
fully developed hysteresis loop, starting when the maximum load is reached for the first 
time. The fatigue analysis with the simplified elastic approach is instead based on the 
stress distribution from the initial linear portion of the stress-strain curve in 
Figure 9-16.
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Figure 9-14: von Mises stress level at the first maximum load for the full elasto-plastic 
analysis.
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Figure 9-15: Effective plastic strain versus loading parameter. An increase of the 
parameter value by 4 corresponds to one full load cycle.
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Figure 9-16: σz versus εz for two full load cycles.

Plots of the logarithm of the predicted life in number of cycles for the full elasto-plastic 
and the simplified elastic analyses are shown in Figure 9-17 and Figure 9-18, 
respectively. An interesting result when predicting the service life of the component is 
the minimum number on the color scale. As expected, the region with the shortest life 
is around the hole. The number of load cycles to reach the fatigue limit is predicted to 
be 6600, when using the full elasto-plastic method, and 4700, when using the 
simplified analysis. 
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Figure 9-17: Number of cycles to fatigue (log n) for the full elasto-plastic analysis.

Figure 9-18: Number of cycles to fatigue (log n) for the linear analysis.
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Modeling in COMSOL Multiphysics

Build and solve the model of the cylinder with elasto-plastic analysis. Create a finer 
mesh around the hole to properly resolve the stress distribution in this region. Export 
the FEM structure with the solved model to either COMSOL Script or MATLAB, 
where you can continue the modeling.

To carry out a fatigue analysis using a load cycle from the elasto-plastic analysis, do the 
following:

• Extract stress and strain data from the FEM structure using the posteval function. 
Do this for a fully developed elasto-plastic load cycle, which corresponds to the 
parametric values of 1 to 5.

• Calculate the fatigue life by using the lcfmultiaxpla function.

Next perform the fatigue analysis based on the linear elastic analysis.

• Use the posteval function to compute the principal stresses corresponding to the 
first parametric value.

• From these results, calculate the principal stresses at the maximum load by 
multiplying with the appropriate factor.

• Use the lcfmultiaxlin function to calculate the fatigue life.

Model Library path: Structural_Mechanics_Module/Fatigue/cylinder_hole

Modeling Using the Graphical User Interface

This section describes how to solve the full elasto-plastic analysis using COMSOL 
Multiphysics and the Structural Mechanics Module.

M O D E L  N A V I G A T O R

1 On the New page, select 3D from the Space dimension list and click on Structural 

Mechanics Module>Solid, Stress-Strain>Static analysis elasto-plastic material.

2 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 Select Model Settings from the Physics menu to open the Model Settings dialog box.
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2 Select MPa from the Base unit system list to use mm as length scale and MPa as stress 
unit.

G E O M E T R Y  M O D E L I N G

1 Click the Cylinder button on the Draw toolbar to open the Cylinder dialog box.

2 In the Cylinder parameters area, set both the Radius and the Height to 100.

3 Click OK to close the Cylinder dialog box and create the cylinder.

By repeating Steps 1–3, draw a second cylinder with a radius of 90 and the same 
height as the one you just created.

4 Click the Zoom Extents button on the Main toolbar.

5 Press Ctrl+A to select both cylinders, then click the Difference button on the Draw 
toolbar to cut a hole through the large cylinder using the small cylinder.

Next, draw a small cylinder to cut a hole in the wall of the hollow cylinder.

6 Click the Cylinder button on the Draw toolbar.

7 In the Cylinder parameters area, set the Radius to 10 and the Height to 100.

8 In the Axis base point area, set the x, y, and z components to 0, 0, and 50, 
respectively.

9 In the Axis direction vector area, set the x, y, and z components to 0, 1, and 0, 
respectively.

10 Click OK to create the small cylinder.

11 Select both cylinders and click the Difference button on the Draw toolbar.

12 Click the Zoom Extents button on the Main toolbar.

13 Click the Block button on the Draw toolbar to open the Block dialog box.

14 In the Length area, set X to 100, Y to 100, and Z to 50. Click OK.

15 Press Ctrl+A to select both objects.

16 Click the Intersection button on the Draw toolbar
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P H Y S I C S  S E T T I N G S

Boundary Conditions
1 Select Boundary Settings from the Physics menu.

2 Specify boundary conditions and loads according to the following table:

Subdomain Settings
1 Select Subdomain Settings from the Physics menu.

SETTINGS BOUNDARIES 1, 6, 7 BOUNDARY 3

Page Constraint Load

Constraint condition Symmetry plane

Fx 0

Fy 0

Fz -200*sin(pi*para/2)
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2 Specify material properties according to the following table:

3 Click the Elasto-plastic material data button to open the Elasto-Plastic Material 

Settings dialog box.

4 Specify elasto-plastic material data according to the following table:

M E S H  G E N E R A T I O N

1 Select Free Mesh Parameters from the Mesh menu to open the Free Mesh Parameters 
dialog box.

2 Click the Boundary tab.

3 Select Boundary 4 and enter 1.5 in the Maximum element size edit field.

4 Click the Remesh button and then click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar or select Solver Parameters 
from the Solve menu to open the Solver Parameters dialog box.

2 In the Parameter name edit field, type para.

3 In the Parameter values edit field, type 0.1:0.1:8. Click OK.

4 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Reproduce the plot of the von Mises stress in Figure 9-14 with the following steps:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, clear the Slice check box and select the Subdomain check box 
in the Plot type area to plot the stresses in the entire domain.

SETTINGS SUBDOMAIN 1

 Page Material

 Material model Elasto-plastic

 E 210[GPa]

 ν 0.3

SETTINGS SUBDOMAIN 1

 Hardening model Kinematic

 ETkin 75[GPa]

 σys 380
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3 Select 1 from the Parameter value list to plot the von Mises stress distribution at the 
first occurrence of the maximum axial loading.

4 Click OK to close the Plot Parameters dialog box and generate the plot.

Proceed to generate the plots in Figure 9-15 and Figure 9-16 as follows:

1 From the Postprocessing menu, select Domain Plot Parameters.

2 Click the Point tab and select Point 5 from the Point selection list.

3 In the y-axis data area, type epe_smsld in the Expression edit field.

4 In the x-axis data area, click the option button in front of the Expression button.

5 Click the Expression button and type para in the Expression edit field.

6 Click OK to close the X-Axis Data dialog box.

7 Click Apply to generate the plot in Figure 9-15.

8 In the y-axis data area, type sz_smsld in the Expression edit field.

9 In the x-axis data area, click the Expression button.

10 Type ez_smsld in the Expression edit field, then click OK to close the X-Axis Data 
dialog box.

11 Click OK to close the Domain Plot Parameters dialog box and create the plot in 
Figure 9-16.

Fatigue Analysis

This section describes how to solve the fatigue problem.

F U L L  E L A S T O - P L A S T I C  A N A L Y S I S

1 Select File>Export>FEM Structure as 'fem' from the File menu to export the FEM 
structure containing the full elasto-plastic analysis to the command line.

2 Run the script cylinder_hole_plastic_fatigue.m by typing 
cylinder_hole_plastic_fatigue and pressing Return.

The script cylinder_hole_plastic_fatigue.m is shown below.

% Calculate the stress tensor
[sxx, syy, szz, sxy, syz, sxz] = posteval(fem,'sx_smsld','sy_smsld', ...
  'sz_smsld','sxy_smsld','syz_smsld','sxz_smsld','edim',2, ...
  'solnum',10:50,'cont','on');
sigma = zeros(6,size(sxx.d,2),size(sxx.d,1));
sigma(1,:,:)=sxx.d';
sigma(2,:,:)=syy.d';
sigma(3,:,:)=szz.d';
sigma(4,:,:)=sxy.d';
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sigma(5,:,:)=syz.d';
sigma(6,:,:)=sxz.d';

% Calculate the strain tensor
[exx, eyy, ezz, exy, eyz, exz] = posteval(fem,'ex_smsld','ey_smsld', ...
  'ez_smsld','exy_smsld','eyz_smsld','exz_smsld','edim',2, ...
  'solnum',10:50,'cont','on');
strain = zeros(6,size(exx.d,2),size(exx.d,1));
strain(1,:,:)=exx.d';
strain(2,:,:)=eyy.d';
strain(3,:,:)=ezz.d';
strain(4,:,:)=exy.d';
strain(5,:,:)=eyz.d';
strain(6,:,:)=exz.d';

% Material parameters
para.E = 210000;
para.sigmaf =  1323;
para.b = -0.097;
para.epsf = 0.375;
para.c = -0.60;
angle_step = 15;

% Calculate the fatigue life
[n_cycles_plastic ms mde, swt]= lcfmultiaxpla(sigma, strain, 'anglestep', 
...
                                angle_step, 'params',para);

% Plot the number of cycles
res = sxx;
res.d(1,:) = log10(n_cycles_plastic);
figure(1);
postdataplot(res,...
             'scenelight','on',...
             'title','Number of cycles to fatigue (log(n)) elasto-plastic 
analysis');

% Plot the maximum normal stress at the critical plane
sres = sxx;
sres.d(1,:) = ms;
figure(2);
postdataplot(sres,...
             'scenelight','on',...
             'title','Maximum normal stress at critical plane');

% Plot the strain amplitude at the critical plane
eres = sxx;
eres.d(1,:) = mde;
figure(3);
postdataplot(eres,...
             'scenelight','on',...
             'title','Strain amplitude at critical plane');

% Plot the swt parameter at the critical plane
swtres = sxx;
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swtres.d(1,:) = swt;
figure(4);
postdataplot(swtres,...
             'scenelight','on',...
             'title','SWT parameter at critical plane');

L I N E A R  E L A S T I C  A N A L Y S I S

1 Select File>Export>FEM Structure as 'fem' from the File menu to export the FEM 
structure containing the full elasto-plastic analysis results including the linear elastic 
ones to the command line.

2 Run the script cylinder_hole_linear_fatigue.m by typing 
cylinder_hole_linear_fatigue and pressing Return.

The script cylinder_hole_linear_fatigue.m is shown below.

% Calculate the principal stresses while the material is still
% linear elastic
[s1e, s2e, s3e] = posteval(fem,'s1_smsld','s2_smsld', ...
  's3_smsld','edim',2,'solnum',1,'cont','on');
sig_princ = zeros(3,size(s1e.d,2));
sig_princ(1,:)=s1e.d(1,:);
sig_princ(2,:)=s2e.d(1,:);
sig_princ(3,:)=s3e.d(1,:);

% Divide with the parameter value to get the stresses at the maximum load
% The first step; the load is applied as sin(p*pi/2) with p = 0.1, 0.2 ...
sig_princ = sig_princ * 1 / sin(0.1 * pi / 2);

% Material parameters
para.E = 210000;
para.nu= 0.3;
para.K = 1550;
para.n = 0.16;
para.sigmaf = 1323;
para.b = -0.097;
para.epsf = 0.375;
para.c = -0.60;

% Calculate the number of cycles
n_cycles_linear = lcfmultiaxlin(sig_princ, 'params', para);

% Plot the number of cycles
res = s1e;
res.d(1,:) = log10(n_cycles_linear);
figure(5)
postdataplot(res,...
             'scenelight','on',...
             'title','Number of cycles to fatigue (log(n)) linear analysis');
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F a t i g u e  Ana l y s i s  o f  a n  Au t omob i l e  
Whee l  R im

Introduction

When designing a lightweight rim for a car it is of utmost importance to avoid fatigue 
failure. A number of fatigue tests can be performed in order to ascertain that the rim 
will not fail. Resorting only to tests, however, leads to large costs for prototype tools 
and a long development cycle, which is easy to avoid by simulating the testing 
procedure.

One such test is “rolling fatigue.” The wheel is pressed against a rotating drum with a 
force that is given by the intended capacity of the wheel. During one revolution of the 
wheel, each material point experiences a complex stress history, which adds one cycle 
to the fatigue damage.

Note: This model requires COMSOL Script or MATLAB.

Model Definition

The wheel rim for this analysis is a ten-spoke example where the design elements of the 
geometry cause the finite element mesh to become quite large. To reduce the size of 
the problem, use an iterative solver and make use of symmetry while modeling. The 
loading on the tire is composed of both the tire pressure and a rotating load (drum 
load) transferred from the tire to the rim. In this case, only the geometry is symmetric, 
while the loading (which moves) is not. Because the problem is linear, superposition 
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of load cases is possible. Any load on a symmetric structure can be separated into one 
symmetric and one antisymmetric load, as the following figure illustrates.

Figure 9-19: Superposition of symmetric and antisymmetric load cases to obtain the stress 
distribution for a load applied in two locations.

For an applied load at a certain position you can solve the model using one half of the 
geometry with symmetric and antisymmetric boundary conditions, respectively. 
Adding and subtracting the solution from these load cases results in the stress 
distribution for a load applied in two symmetric positions, as outlined in Figure 9-19.

In the analysis you study the problem in a coordinate system fixed to the wheel rim, 
where the load rotates around the wheel. Assume that the load on the rim extends 30° 
in each direction from the point of contact. It is reasonable to analyze the stress 
distribution with the point of contact evenly spread out at ten locations around the 

Symmetry plane

P/2 P/2 P

-P/2

Symmetric load case Antisymmetric load case Applied load

P/2

P/2 P/2

PP/2 -P/2
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rim. For the modeled half of the geometry this is equivalent to six load positions with 
36° interval between them as shown in the following figure.

You can model the moving load by letting the parametric solver step through the 
parameter values, which you can then use in the load expression to control its location 
and distribution. Use Table 9-1 and Table 9-2 to find each load case by its parameter 
value and load angle. Combine the load cases according to Table 9-3 to calculate the 
stress distribution for load positions around the entire wheel. The designations used in 
the Combination column correspond to load cases listed in Table 9-1 and Table 9-2.

TABLE 9-1:  SYMMETRIC LOAD CASES

PARAMETER 
VALUE

DESCRIPTION DESIGNATION

1 Drum load 0o sd1

2 Drum load 36o sd2

3 Drum load 72o sd3

4 Drum load 108o sd4

5 Drum load 144o sd5

6 Drum load 180o sd6

7 Tire pressure st7

TABLE 9-2:  ANTISYMMETRIC LOAD CASES

PARAMETER 
VALUE

DESCRIPTION DESIGNATION

2 Drum load 36o ad2

3 Drum load 72o ad3

4 Drum load 108o ad4

5 Drum load 144o ad5

180°

144°

108° 72°

36°

0°
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M A T E R I A L

• Elastic data: Isotropic with E = 70 GPa, ν = 0.33.

• Fatigue data: The fatigue limit is known for two cases with pure axial loading. For 
pure tension it is 95 MPa, and for fully reversed loading it is 125 MPa. This gives 
the Findley parameters f = 84 MPa and k = 0.30 if Equation 14-16 in the 
Structural Mechanics Module User’s Guide is applied.

C O N S T R A I N T S

• A region around each bolt hole is fixed.

TABLE 9-3:  COMBINED LOAD CASES

PARAMETER 
VALUE

DESCRIPTION COMBINATION

0 Tire pressure + Drum load 0o st7 + sd1

36 Tire pressure + Drum load 36o st7 + (sd2 + ad2)/2

72 Tire pressure + Drum load 72o st7 + (sd3 + ad3)/2

108 Tire pressure + Drum load 108o st7 + (sd4 + ad4)/2

144 Tire pressure + Drum load 144o st7 + (sd5 + ad5)/2

180 Tire pressure + Drum load 180o st7 + sd6

216 Tire pressure + Drum load 216o st7 + (sd5 - ad5)/2

252 Tire pressure + Drum load 252o st7 + (sd4 - ad4)/2

288 Tire pressure + Drum load 288o st7 + (sd3 - ad3)/2

324 Tire pressure + Drum load 324o st7 + (sd2 - ad2)/2

Symmetric or antisymmetric boundary condition

Fixed boundary condition
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• Symmetric load cases: Symmetry condition (normal displacement fixed) in the 
symmetry plane.

• Antisymmetric load cases: Antisymmetry condition (transverse displacement fixed) 
in the symmetry plane.

L O A D S

• Tire pressure: The overpressure is 2 bar = 200 kPa.

• Rotating drum load: The total load carried by the wheel corresponds to a weight of 
1120 kg. It is applied as a pressure on the rim surfaces where the tire is in contact. 
Assume that the load distribution in the circumferential direction can be 
approximated as p = p0 cos ( 3 ϑ ), where ϑ is the angle from the point of contact 
between the drum and the tire. The loaded area thus extends 30° in each direction. 
The parameter ksolv in the following expression is used to control the location of 
the load:

p p0 ksolv 6<( ) 3 y
x
---⎝ ⎠
⎛ ⎞atan

π 2ksolv 7–( )
10

--------------------------------– ⋅cos–=

y
x
---⎝ ⎠
⎛ ⎞atan

π 3ksolv 13–( )
15

------------------------------------< y
x
---⎝ ⎠
⎛ ⎞atan

π 3ksolv 8–( )
15

-------------------------------->⋅ ⋅

Rotating tire load

Tire pressure
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T H E  F I N I T E  E L E M E N T  M E S H

Mesh the rim surface with a fine mesh to resolve all the details, and to avoid inverted 
and linearized elements, which may influence the fatigue analysis.

The final finite-element mesh consists of approximately 310,000 tetrahedral elements, 
giving a total number of approximately 1,500,000 degrees of freedom.

Results and Discussion

The von Mises stress for one of the combined load cases with the point of contact for 
the drum load located at 144° is shown below, illustrating the region for where the rim 
experiences the maximum stresses.

Figure 9-20: von Mises stress distribution for the combined loading with the rotating drum 
load at 144°.

The computed fatigue utilization factor is shown in Figure 9-21. The maximum value 
is 0.717. As you can see the critical regions are on the inside where the spokes connect 
to the mid part of the rim. When comparing with the stress plot in Figure 9-20, note 
that high stresses will not always lead to a high utilization factor. This is the case for 
the two edges that run around the rim holding the tire in place.
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Figure 9-21: Distribution of the fatigue utilization factor.

By looking at the plot in Figure 9-22 you can understand the nonproportional nature 
of the stress history. Here you can see how the components of the stress tensor change 
at the most critical point as the load rotates around the wheel. For proportional 
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loading there would only be a scale difference between the curves. But in this case 
principal directions of the stress tensor change with each step.

Figure 9-22: Stress history at the location with the highest fatigue utilization factor.

Modeling in COMSOL Multiphysics

Build and solve two models, the first one containing the symmetric load cases with the 
pressure load and the second one containing the antisymmetric load cases.

To superpose the symmetric and antisymmetric load cases, export the FEM structures 
from these two models to COMSOL Script, where you can extract and add the 
solution vectors.

Perform the fatigue analysis using either COMSOL Script or MATLAB, where you can 
run scripts that analyzes the total stress distribution stored in the FEM structures.

Model Library path: Structural_Mechanics_Module/Fatigue/
wheel_rim_fatigue
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Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Click the New button or start COMSOL Multiphysics to open the Model Navigator.

2 Select 3D from the Space dimension list.

3 Open the Structural Mechanics Module folder and then Solid, Stress-Strain. Select 
Parametric analysis.

4 Click OK.

I M P O R T  O F  C A D  G E O M E T R Y

1 On the File menu select Import>CAD Data From File.

2 In the Files of type list select COMSOL Multiphysics file.

3 Browse to the models/Structural_Mechanics_Module/
Automotive_Applications directory located in the COMSOL installation 
directory and select the file wheel_rim.mphbin.

4 Click Import.

O P T I O N S  A N D  S E T T I N G S

Constants
1 Select Options>Constants.

2 Enter the constants from the following table in the Constants dialog box.

3 Click OK.

Visualization Settings
Use a coarse visualization mesh to reduce the time it takes to rendering the geometry 
when switching views in the user interface:

1 From the Options menu, choose Visualization/Selection Settings.

2 From the Visualization mesh list, select Coarse.

3 Click OK.

NAME EXPRESSION

pressure 2e5[Pa]

tire_load 5.194e6[Pa]
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M E S H  G E N E R A T I O N

1 Select Mesh>Free Mesh Parameters.

2 On the Boundary page select boundaries and enter the parameters according to the 
following table.

3 Click OK.

4 Click the Mesh All (Free) button on the Mesh toolbar.

BOUNDARIES MESH CURVATURE 
FACTOR

MESH CURVATURE 
CUTOFF

11, 13, 89, 90 0.5

27, 37, 41, 99, 100, 106, 108, 109, 112, 128, 
129, 130, 144, 147, 154, 169, 171, 180, 181, 
182, 191, 198, 199, 204, 205, 220, 228, 230, 
236, 256, 274, 275, 278, 280, 291, 303, 313, 
333, 343, 345, 349, 350, 352, 353, 357, 358, 
373, 375, 376, 377, 386, 411, 413, 414, 415, 
417, 418, 426, 427, 428, 433, 444

0.4

32, 60, 73, 186, 314, 332, 340, 385, 397, 
406, 412, 441

0.3

44, 46, 51, 52 0.1

3, 5, 6, 7, 92, 94, 95, 96, 107, 196, 229, 317, 
360, 362, 378, 387, 391, 407, 408, 416, 419, 
429, 434

0.4 0.02

2, 4, 16, 17, 84, 85, 97, 98, 197, 371, 401, 
432, 452

0.4 0.015

30, 33, 72, 439 0.3 0.02

28, 29, 54, 74, 75, 103, 104, 115, 116, 126, 
132, 145, 148, 151, 177, 194, 207, 237, 238, 
239, 247, 248, 251, 252, 253, 254, 255, 265, 
270, 279, 281, 285, 288, 290, 292, 298, 309, 
319, 320, 321, 322, 325, 326, 327, 328, 329, 
330, 334, 335, 337, 341, 342, 346, 348, 351

0.3 0.015

35, 43, 57, 70, 102, 114, 121, 136, 137, 138, 
146, 152, 158, 164, 166, 167, 184, 185, 192, 
201, 203, 206, 211, 222, 233, 244, 261, 272, 
286, 295, 299, 300, 302, 304, 379, 398, 409

0.3 0.01
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P H Y S I C S  S E T T I N G S  ( S Y M M E T R I C  L O A D  C A S E S )

Subdomain Settings
1 On the Physics menu select Subdomain Settings.

2 In the Subdomain selection list select Subdomain 1.

3 On the Material page click the Load button to open the Materials/Coefficients Library 
dialog box.

4 In the Materials list expand Basic Material Properties then select Aluminum.

5 Click OK to apply the material and close the dialog box.

6 Click OK to close the Subdomain Settings dialog box.

Boundary Conditions
1 On the Physics menu select Boundary Settings.

2 On the Boundaries page locate the Boundary selection list and select Boundaries 56, 
156, and 232.

3 On the Constraint page select Fixed in the Constraint condition list box.

4 From the Boundary selection list select Boundaries 1, 26, 48, 64, and 76.

5 On the Constraint page select Symmetry Plane in the Constraint condition list box.

6 From the Boundary selection list select Boundaries 10–15, 18, 19, 22, 81-83, 86, 87, 
89-91, and 93.

7 On the Load page make sure that Distributed load is selected from the Type of load 
list box.

8 Select Tangent and normal coord. sys. (t1,t2,n) from the Coordinate system list box.

9 Enter -pressure*(load_param>6) in the Fn edit field.

10 From the Boundary selection list select Boundaries 6, 7, 92 and 94.

11 On the Load page make sure that Distributed load is selected from the Type of load 
list box.

12 Select Tangent and normal coord. sys. (t1,t2,n) from the Coordinate system list box.

13 In the Fn edit field enter 
-tire_load*(load_param<7)*cos(3*(atan2(y,x)-pi/

10*(2*load_param-7)))*(atan2(y,x)>pi/

15*(3*load_param-13))*(atan2(y,x)<pi/15*(3*load_param-8))

14 Click OK to close the Boundary Settings dialog box.
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C O M P U T I N G  T H E  S O L U T I O N  ( S Y M M E T R I C  L O A D  C A S E S )

1 Click the Solver Parameters button.

2 Select Parametric in the Solver list.

3 On the General page, type load_param in the Parameter name edit field and the 
vector 1:7 in the Parameter values edit field.

4 From the Linear system solver list select Conjugate gradients.

5 From the Preconditioner list select Geometric multigrid.

6 Click the Settings button.

7 In the dialog box that opens select Linear system solver>Preconditioner>Coarse 

solver.

8 From the Coarse solver list select SPOOLES.

9 Click OK.

10 Click OK.

11 Click the Solve button on the Main toolbar.

S A V I N G  T H E  S Y M M E T R I C  L O A D  C A S E S

After the problem is solved you can save the model in case you want to open and 
examine the solution to the symmetric load cases. If you do not want to save the model 
continue with the next section, “Exporting the Symmetric Load Cases to COMSOL 
Script.”

1 Select File>Save.

2 Navigate to the directory of your choice.

3 In the File name edit field enter wheel_rim_fatigue_sym.mph.

4 Click Save.

A solved model with the symmetric load cases is available in the COMSOL Model 
Library root directory under Structural_Mechanics_Module/Fatigue/
wheel_rim_fatigue_sym.mph.

E X P O R T I N G  T H E  S Y M M E T R I C  L O A D  C A S E S  T O  C O M S O L  S C R I P T

You can export the model to COMSOL Script as an FEM structure containing the 
geometry, mesh, physics settings, as well as the solution. From the FEM structure you 
can then extract the solution vector, which you can add to the solution vector of the 
antisymmetric load cases.

1 Select File>Export>FEM Structure.
F A T I G U E  A N A L Y S I S  O F  A N  A U T O M O B I L E  W H E E L  R I M  |  397



398 |  C H A P T E
2 In the dialog box that opens enter fem_sym_cases in the Variable name for FEM 

structure edit field.

3 Click OK. COMSOL Script opens automatically.

4 Switch back to COMSOL Multiphysics before continuing with the next step.

P H Y S I C S  S E T T I N G S  ( A N T I S Y M M E T R I C  L O A D  C A S E S )

On the symmetry plane of the geometry you need to change the boundary condition 
to antisymmetry before computing the antisymmetric load cases. Also, you can skip the 
last parameter step, since it corresponds to the pressure load.

Boundary Conditions
1 On the Physics menu select Boundary Settings.

2 In the Boundary selection list select Boundaries 1, 26, 48, 64, and 76.

3 On the Constraint page select Antisymmetry Plane in the Constraint Condition list box.

4 Click OK to close the Boundary Settings dialog box.

C O M P U T I N G  T H E  S O L U T I O N  ( A N T I S Y M M E T R I C  L O A D  C A S E S )

1 Click the Solver Parameters button on the Main toolbar.

2 From the Solver list, select Parametric.

3 On the General page, change the vector in the Parameter values edit field to 2:6.

4 Click OK.

5 Click the Solve button on the Main toolbar.

S A V I N G  T H E  A N T I S Y M M E T R I C  L O A D  C A S E S

Carry out the following steps to save the model at this stage. If you do not want to 
save the model continue with the next section, “Exporting the Antisymmetric Load 
Cases to COMSOL Script.”

1 Select File>Save As.

2 Navigate to the directory of your choice.

3 In the File name edit field enter wheel_rim_fatigue_asym.mph.

4 Click Save.

A solved model with the antisymmetric load cases is available in the COMSOL 
Model Library root directory under Structural_Mechanics_Module/Fatigue/
wheel_rim_fatigue_asym.mph.
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E X P O R T I N G  T H E  A N T I S Y M M E T R I C  L O A D  C A S E S  T O  C O M S O L  S C R I P T

When you have solved the antisymmetric model, export the solution to COMSOL 
Script.

1 Select File>Export>FEM Structure.

2 In the dialog box that opens enter fem_asym_cases in the Variable name for FEM 

structure edit field.

3 Click OK. COMSOL Script opens automatically.

C O M B I N I N G  T H E  L O A D  C A S E S

To obtain the total solution you need to superpose or add the solutions from the 
pressure load with symmetric load cases and the antisymmetric load cases. With the 
two FEM structures exported to COMSOL Script, add the solution vectors according 
to Table 3-3 on page 110 and create a new FEM structure, which you can use for the 
fatigue analysis and import into the graphical user interface to visualize the results. To 
do this, use the script wheel_rim_fatigue_superpose.m, which you find in the 
fatigue directory located in the COMSOL installation directory.

1 With both FEM structures exported to COMSOL Script, run the script 
wheel_rim_fatigue_superpose.m by typing wheel_rim_fatigue_superpose 
at the prompt and pressing Return.

The script wheel_rim_fatigue_superpose.m is shown below.

% Superpose symmetric and antisymmetric results for the 
% wheel rim model

% Export symmetric solution as "fem_sym_cases" and antisymmetric
% solution as "fem_asym_cases"

% Extract solution
us = fem_sym_cases.sol.u;
ua = fem_asym_cases.sol.u;

% Find number of load positions (num_comb)
num_sym_sol = size(us,2);
num_comb = (num_sym_sol - 2) * 2;

% Create the linear combinations
u_tire_pres = us(:,num_sym_sol);
ucomb = zeros(size(us,1), num_comb);
ucomb(:,1) = us(:,1) + u_tire_pres;
ucomb(:,num_sym_sol-1) = us(:,6) + u_tire_pres;
for i = 2:num_sym_sol - 2
  ucomb(:,i) = 0.5 * (us(:,i) + ua(:,i-1)) + u_tire_pres;
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  ucomb(:,num_comb-i+2) = 0.5 * (us(:,i) - ua(:,i-1)) + u_tire_pres;
end

% Create mnemonic parameter values for the combinations
angle_step = 360 / num_comb;
param_list = 0:angle_step:360-angle_step;

% Create new solution object and an fem structure to place it in
sol = femsol(ucomb,'pname','lcmb','plist',param_list);
fem_added = fem_sym_cases;
fem_added.sol = sol;

%fem_added can now be imported into COMSOL Multiphysics

Fatigue Analysis

1 To perform the fatigue analysis run the script wheel_rim_fatigue_analysis.m by 
typing wheel_rim_fatigue_analysis at the prompt and pressing Return.

The script wheel_rim_fatigue_analysis.m is shown below.

% Script for running the wheel rim fatigue analysis
[sxx, syy, szz, sxy, syz, sxz] = 
posteval(fem,'sx_smsld','sy_smsld', 'sz_smsld', ...
  
'sxy_smsld','syz_smsld','sxz_smsld','edim',2,'solnum','all','cont
','on','refine',1);
sigma = zeros(6,size(sxx.d,2),size(sxx.d,1));
sigma(1,:,:)=sxx.d';
sigma(2,:,:)=syy.d';
sigma(3,:,:)=szz.d';
sigma(4,:,:)=sxy.d';
sigma(5,:,:)=syz.d';
sigma(6,:,:)=sxz.d';

k = 0.3;
f = 76E6;
params.f = f;
params.k = k;
angle_step = 9;

[resval sigma_max, delta_tau, worst_ind, s_history] = ...
  hcfmultiax(sigma, 'anglestep', angle_step, 'params', params);

findley_res = sxx;
findley_res.d(1,:) = resval;
figure(1)
postdataplot(findley_res, 'colorbar', 'on', ...
    'campos', [0.342,0.923,-2.87], ...
R  9 :  F A T I G U E  M O D E L S



    'camtarget', [0.0589,0.00860,-0.00152], ...
    'camup', [0.774,0.577,0.260], ...
    'camva', 9.1)

sigma_max_res = sxx;
sigma_max_res.d(1,:) = sigma_max;
figure(2)
postdataplot(sigma_max_res, 'colorbar', 'on')

delta_tau_res = sxx;
delta_tau_res.d(1,:) = delta_tau;
figure(3)
postdataplot(delta_tau_res, 'colorbar', 'on')

x = 1:(size(s_history,2));
figure(4)
plot(x,s_history(1,:),'-',x,s_history(2,:),':',x,s_history(3,:),'
-.',...
  x,s_history(4,:),'--',x,s_history(5,:),'-',x,s_history(6,:),':')
legend('sxx','syy','szz','sxy','syz','sxz')
title('Stress history in critical point')

Postprocessing and Visualization

The fatigue analysis script creates plots showing the results of this analysis. In addition, 
you can plot the stress distribution from the static analysis through the following steps:

1 Switch back to COMSOL Multiphysics and select File>Import>FEM Structure.

2 In the Enter name of FEM structure variable edit field, enter fem_added.

3 Click OK.

4 Click the Plot Parameters button on the Main toolbar.

5 Select the General page.

6 Under the Plot type group label clear the Slice check box.

7 Select the Subdomain check box.

8 In the Parameter value list select 144 to display the von Mises stress for the point of 
contact at 144°.

9 Select the Make rough plots check box.

The above feature generates plots with slightly lower quality than normal for faster 
and more memory-efficient rendering.

10 Click OK.
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F l u i d - S t r u c t u r e  I n t e r a c t i o n
This chapter contains models including the interaction between fluids and 
structures, often named fluid-structure interaction (FSI).
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F r e e z i n g  S o i l

Introduction

When wet soil or clay is subjected to freezing temperatures, water in the interstices 
freezes. Because water expands when it freezes, the surrounding soil deforms. The 
deformation changes the pressure in the interstices. The combined impacts of the 
freezing and the deformation affect the water flow.

This model predicts 3-way interactions between stress and strain, fluid flow, and 
temperature change. This type of analysis is important in assessments related to road 
and building construction, freeze-thaw weathering, fluid flow, and a number of 
environmental applications. The model that follows comes from a COMSOL client 
who used the results to assess thermo-mechanical impacts in a transportation study.

This analysis couples equations that predict what happens when a water-filled soil core 
freezes from the center outwards. Included in the analysis are:

• Effects of a stepwise change in the thermomechanical properties at the phase 
transition temperature

• Porous fluid-flow behavior involving a temperature-driven contribution

• Stress-strain behavior including loads from thermal expansion and fluid flow

• Heat conduction including phase change and the latent heat of freezing

• Coupling effects between the above-mentioned phenomena.

This discussion assumes temperature changes are fully transient with a quasi-static 
interaction with fluid flow and solid deformation. The model uses the Darcy’s Law and 
the Convection and Conduction application modes from the Earth Science Module. 
It also employs a Stress-Strain application mode from the Structural Mechanics 
Module, an application mode that automates temperature-deformation coupling.
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Model Definition1

Figure 10-1: Experimental setup for investigations of freezing soil. A symmetry 
observation permits modeling in axisymmetry 2D.

The model geometry is based on a general test rig often used for investigating the 
properties of soil and clay (see Figure 10-1). A cylindrical container with the sample 
soil has a concentric channel, through which a coolant fluid flows. The initial 
temperature of the wet soil is +3 °C. As the coolant at −15 °C enters the pipe, a 
freezing front travels outward in the soil specimen. Because the soil is homogeneous, 
you can take advantage of the geometric symmetry and model the phenomena in 2D.

S T R E S S - S T R A I N  E Q U A T I O N S

The fundamental Navier’s equation describes a force equilibrium

 (10-1)

where σ is the stress tensor and F is a volume force.

The entries of the stress tensor for axisymmetry are

1. Model definition and material data courtesy of Dr. J.P.B.N. Derks, Ministry of Transport, Public Work &  
Water Management, the Netherlands.

3D to 2D axial symmetry

Coolant flow

0.22 m

ro=0.05 m

ri=0.006 m

Soil or clay fill

∇– σ⋅ F=
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where τ denotes off-diagonal components of strain or shear.

The equations simplify to two force balances in the r and z directions:

 (10-2)

 (10-3)

where τ denotes off-diagonal components of strain or shear.

Flow-to-Structure Coupling
When considering the impacts of fluid flow on structural deformation, the stress tensor 
decompose into two parts

 (10-4)

where σ is the total stress, σ' is the so-called grain stress, and p is the pressure of the 
fluid moving through a porous sand or clay matrix.

In this analysis

.

Temperature-to-Structure Coupling
The thermomechanical relationship is given by the generalized Hooke’s law for an 
elastic nonisothermal material as in

.  (10-5)

Here D is the elasticity matrix, σ' represents the elastic stress, ε gives the total strain, 
and εth is the thermal strain. Further, α (K−1) is the coefficient of thermal expansion, 
T is the temperature, and Tref is the strain reference temperature.
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σyy

σzz

τxy
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τyz
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Model the flow with the modified Darcy’s law

 (10-6)

where u = (u, v, w) denotes the vector of fluid velocities in the x, y, and z directions, 
and  is the suction pressure.

Temperature-to-Flow Coupling, Segregation Potential
The fluid flow and temperature relationships couple through the term 

,

where SP0 is the segregation potential (kg·m/(s2·K)), which is the ratio of the 
moisture migration velocity to the temperature gradient in a freezing soil, and κ is the 
permeability (m2). The segregation potential SP0 is a positive constant below the 
freezing point and 0 above. Experimental observations on specimens frozen under a 
temperature gradient suggest that, even though much of the pore water is frozen, 
water transport still occurs in the frozen soil past the pore freezing front in response 
to temperature-induced unfrozen water content gradients and suction gradients in 
these unfrozen water films. The migratory water freezes at the segregation freezing 
temperature, Ts, which is lower than the pore freezing temperature Tp (Ref. 1). In this 
model example, it is assumed that the segregation freezing temperature is well below 
the temperature range of the study.

Given the definition for , Equation 10-6 states that the fluid velocities depend on 
the pressure gradient and the temperature gradient for conditions below the freezing 
point. 

Structure-to-Flow Coupling
For quasi-steady flow, the following relationship holds:

,  (10-7)

where  and similar terms are the rates of strain (s−1) from the stress-strain 
equations.

Combining Equation 10-6 and Equation 10-7 gives the governing equation

,  (10-8)

u κ
η
---∇ p φs+( )–=

φs

φs SP0 T κ⁄⋅=

φs

∇ u⋅ ε· xx ε· yy ε· zz+ +( )–=

ε· xx

∇ k
η
---∇ p φs+( )–⎝ ⎠

⎛ ⎞⋅ ε· xx ε· yy ε· zz+ +( )–=
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which this example models with the Darcy’s Law application mode.

TE M P E R A T U R E  E Q U A T I O N S

This problem uses the well-known heat equation to model the transfer of heat. As 
described in the Earth Science Module User’s Guide, the heat transfer equation reads

.

Results

Figure 10-2: A snapshot of the von Mises stresses (surface plot) and displacements 
(contours) in a column of freezing soil.

ρcp
∂T
∂t
------- ∇ k∇T–( )⋅+ Q=
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Figure 10-2 shows the displacements in the solid sample and the von Mises stresses 
after 12 hours of freezing operation. It is also easy to monitor how the physical 
properties of the sand change with time and space; see Figure 10-3.

Figure 10-3: Thermal conductivity changes in a step at the freezing point. The lower curve 
corresponds to 24 minutes, and the upper curve to 7 hours and 12 minutes.

Reference

1. Jean-Marie Konrad, “Estimation of the segregation potential of fine-grained soils 
using the frost heave response of two reference soils,” Can. Geotech. J., vol. 42, 
pp. 38–50, 2005.

Modeling in COMSOL Multiphysics

Turning to the COMSOL Multiphysics Structural Mechanics Module, you choose the 
Axial Symmetry, Stress-Strain application mode to solve Equation 10-2 and 
Equation 10-3. To account for the fluid pressure according to Equation 10-4, simply 
add 
F R E E Z I N G  S O I L  |  409



410 |  C H A P T E
to the body load vector F on the Load page in the Subdomain Settings dialog box. To 
have that application mode automatically account for the thermomechanical relations, 
Equation 10-5, select the Include thermal expansion check box on the Load page. To 
get easy access to the rates of strain (time derivatives of the strain), use a time-
dependent stress-strain analysis. This solves Equation 10-1 with an extra term on the 
left-hand side, namely ρ ( ∂2u ) / (∂t2 ), which is the acceleration term in Newton’s 
second law. Here, u is the vector of directional deformations (in m). However, you can 
make the assumption that the time scale in the mechanical problem is much shorter 
than that for the heat transfer problem. Here you skip the time-derivative term in the 
stress/strain equation by setting ρ = 0 and still access the rates of strain as described in 
the next paragraph.

It is easy to implement the modified Darcy’s law (Equation 10-3) with the Earth 
Science Module’s Darcy’s Law application mode, and its predefined equation is

.  (10-9)

Because the vertical change is small, you can ignore gravity impacts on flow. There is, 
however, another contribution to the mass flux, namely that from the segregation 
potential (see Equation 10-8). Include this contribution by setting . 

Next place the rate-of-strain expression in Equation 10-7 in the Qs term. The r, , 
and z components of the rate of strain, , and , are readily available in the 
time-dependent Axial Symmetry, Stress-Strain application mode as the expressions 
diff(er_stress,t), diff(ephi_stress,t), and diff(ez_stress,t). Hence, 
enter -(diff(er_stress,t)+diff(ephi_stress,t)+diff(ez_stress,t)) in the 
Qs edit field of the Darcy’s Law application mode.

The model handles the stepwise-changing material properties at the freezing point as 
well as the latent heat of freezing as described in “Phase Change” on page 303 in the 
Earth Science Module Model Library.

∂p
∂r
------–

∂p
∂z
------–

∇ κ
η
---∇ p ρf gD+( )–⎝ ⎠

⎛ ⎞⋅ Qs=

D φs gρf( )⁄=

φ
ε· rr ε· φφ ε· zz
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Note: This model requires the Earth Science Module and the Structural Mechanics 
Module.

Model Library path: Structural_Mechanics_Module/Fluid-
Structure_Interaction/freezing_soil

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 In the Model Navigator, select Axial symmetry (2D) from the Space dimension list and 
then in the list of application modes select Structural Mechanics Module>Axial 

Symmetry, Stress-Strain>Static analysis. In the Application mode name edit field, type 
stress.

2 Click the Multiphysics button, then click Add.

3 Return to the list of application modes and select COMSOL Multiphysics> 
Heat Transfer>Conduction>Transient Analysis. In the Application mode name edit field 
enter heat, then click Add.
F R E E Z I N G  S O I L  |  411



412 |  C H A P T E
4 In the list of application modes select Earth Science Module>Fluid Flow> 
Darcy’s Law>Pressure analysis. In the Application mode name edit field enter Darcy, 
then click Add.

5 Click OK.

O P T I O N S

1 From the Options menu select Constants and enter the following names, expressions, 
and descriptions (optional); when done, click OK.

G E O M E T R Y  M O D E L I N G

1 Shift-click the Rectangle/Square button at the top of the Draw toolbar.

2 In the Size area, set the Width to 0.044 and the Height to 0.22.

3 In the Position area, select Center from the Base list. Set r to 0.028 and z to 0.11.

4 Click OK, then click the Zoom Extents button on the Main toolbar.

NAME EXPRESSION DESCRIPTION

T_trans 0[degC] Freezing point

scale 0.5 Width of smoothed step function

rho_sa 2000[kg/m^3] Density

nu0 0.3 Poisson’s ratio

alpha_s 0.8e-6[1/K] Coefficient of thermal expansion

T_init 3[degC] Intial temperature

k_sf 4.6[W/(m*K)] Thermal conductivity below freezing point

k_s 2.6[W/(m*K)] Thermal conductivity above freezing point

Cp_sf 1000[J/(kg*K)] Heat capacity below freezing point

Cp_s 1350[J/(kg*K)] Heat capacity above freezing point

kappa_s 7.1e-5[m^2] Permeability, unfrozen sand

eta_s 0.001[Pa*s] Dynamic viscosity

E0_s 65[MPa] Young’s modulus

t_load 300[kN/m^2] Top edge load

e_load 300[kN/m^2] Side edge load

dT 0.5[K] Half width of Gauss bell curve

lam 333[kJ/kg] Latent heat of freezing

p_pore 150[kPa] Pore pressure
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E X P R E S S I O N  D E F I N I T I O N S

From the Options menu select Expressions>Scalar Expressions, then add the following 
names, expressions, and descriptions (optional); when done, click OK.

The unit brackets [1/K] and [1/s] make the function inputs dimensionless.

P H Y S I C S  S E T T I N G S

Application Scalar Variables
To include the segregation potential mass-flux term in the way described below 
Equation 10-9, you need to modify the application scalar variable DDarcy.

1 From the Physics menu, select Scalar Variables.

2 In the Expression column for D_Darcy, type (Sp0*T/kappa_s)/
(g_Darcy*rhof_Darcy).

3 Click OK to close the Application Scalar Variables dialog box.

Subdomain Settings—Axial Symmetry, Stress-Strain
1 From the Multiphysics menu, select Axial Symmetry, Stress-Strain (stress).

2 From the Physics menu, select Subdomain Settings. 

3 Select Subdomain 1, then enter the values in the following table:

4 On the Load page, select the Include thermal expansion check box.

NAME EXPRESSION DESCRIPTION

HS flc1hs((T-T_trans)[1/K],scale) Smoothed Heaviside step

k_g k_sf+(k_s-k_sf)*HS Varying thermal conductivity

D exp(-(T-T_trans)^2/dT^2)/ 
sqrt(pi*dT^2)

Smoothed Dirac delta function

Cp Cp_sf+(Cp_s-Cp_sf)*HS Varying heat capacity

T_b T_init+18[K]*(1- 
2*flc1hs(t[1/s],100))

Varying boundary temperature

Sp0 (1-HS)*1e-12[kg*m/(s^2*K)] Varying segregation potential

QUANTITY VALUE/EXPRESSION DESCRIPTION

 E E0_s Young’s modulus

 ν nu0 Poisson’s ratio

 α alpha_s Thermal expansion coeff.
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5 Specify the loads as in the following table; when done, click OK.

Boundary Conditions—Axial Symmetry, Stress-Strain
1 Select the menu Physics>Boundary Settings.

2 On the Constraint page select Boundaries 1 and 2. From the Constraint condition list 
select Roller.

3 Click the Load tab. Select Boundary 3, and set Fr to 0 and Fz to -t_load.

4 Select Boundary 4. Set Fr to -e_load and Fz to 0.

5 Click OK.

Subdomain Settings—Heat Transfer
1 From the Multiphysics menu select Heat Transfer by Conduction (heat).

2 Choose Physics>Subdomain Settings, then specify these settings:

3 On the Init page, set T(t0) to T_init. Click OK.

Boundary Conditions—Heat Transfer
1 Choose Physics>Boundary Settings and select Boundary 1. From the Boundary 

condition list select Temperature, then in the Temperature edit field type T_b.

2 Select Boundary 4. In the Boundary condition list select Temperature, then in the 
Temperature edit field type T_init. Click OK.

Subdomain Settings—Darcy’s Law
1 Select the menu item Multiphysics>Darcy’s Law (Darcy).

2 From the Physics menu, select Subdomain Settings.

QUANTITY VALUE/EXPRESSION DESCRIPTION

Fr -p2r Body load (force/volume) r dir.

Fz -p2z Body load (force/volume) z dir.

Temp T Strain temperature

Tempref T_init Strain ref. temperature

QUANTITY VALUE/EXPRESSION DESCRIPTION

 k (isotropic) k_g Thermal conductivity

 ρ rho_s Density

 Cp Cp+D*lam Heat capacity
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3 Specify the following settings; when done, click OK.

Because of the setting for D on page 413, the density value has to be nonzero but 
is otherwise irrelevant.

Boundary Conditions—Darcy’s Law
Choose Physics>Boundary Settings, then select Boundary 1. In the Boundary condition 
list select Pressure, then set p0 to p_pore. Similarly select Boundary 4 and set the 
Pressure to 0. Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters.

2 Click the Boundary tab and select Boundary 1. In the Maximum element size edit field 
enter 0.003.

3 Click Remesh. When the mesher has finished, click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 In the Times edit field, type 0:1440:43200. This provides 30 equidistant time steps 
during a total simulation time of 12 hours (43, 200 s).

3 In the Absolute tolerance edit field, type uor 1e-6 w 1e-6 T 0.001 p2 10. This 
sets up absolute tolerances of 10−6 for the displacement variables, 0.001 for the 
temperature, and 10 for the pressure. Click OK.

4 Click the Solve button on the Main toolbar to compute the solution.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To reproduce the plot in Figure 10-2, follow these steps.

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, go to the Plot type area and select the Surface, Contour, 
Deformed shape, and Geometry edges check boxes.

QUANTITY VALUE/EXPRESSION DESCRIPTION

 κs kappa_s Saturated permeability

 ρf 1 Density, liquid

 η eta_s Viscosity, liquid

 Qs -(diff(er_stress,t)+diff(ephi_stress,t) 
+diff(ez_stress,t))

Liquid source
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3 Click the Surface tab, then in the Predefined quantities list on the Surface Data page 
select Axial Symmetry, Stress-Strain (stress)>von Mises Stress.

4 From the Unit list, select kPa.

5 Click the Contour tab, and in the Predefined quantities list on the Contour Data page 
select Axial Symmetry, Stress-Strain (stress)>Total displacement.

6 From the Unit list, select mm.

7 Click OK to close the Plot Parameters dialog box and generate the plot.
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Ob s t a c l e  i n  F l u i d

Introduction

In this model, fluid is flowing through a channel with a flexible obstacle. Due to the 
viscous and pressure forces exerted by the fluid, the obstacle is bending. With the 
obstacle undergoing a large deformation, the fluid flow domain is also changing 
considerably. COMSOL Multiphysics is taking these changes into account by 
computing the flow field on a moving mesh attached to the obstacle.

In this example model, the dimensions are such that the setup mostly resembles a 
MEMS flowmeter, but the modeling principles used are very general and can be 
applied to many situations where there is interaction between a structure and a fluid 
flow domain.

Model Definition

In this example the flow channel is 200 µm long, 150 µm high, and 150 µm wide. A 
flag-shaped obstacle has a slightly off-center position in the channel. The fluid is water 
with a density ρ = 1000 kg/m3 and dynamic viscosity η = 0.001 Pa·s. The obstacle is 
made of a flexible material with a density ρ = 7850 kg/m3 and a Young’s modulus 
E = 8 MPa.

The model consists of a fluid part, solved with the Navier-Stokes equations in the flow 
channel, and a structural mechanics part, which you solve in the obstacle. A Moving 
Mesh application mode makes sure the flow domain is deformed along with the 
obstacle. These application modes and the FSI-specific settings on subdomains and 
boundaries are available directly when using the predefined multiphysics couplings for 
fluid-structure interaction.

F L U I D  F L O W

The fluid flow in the channel is described by the Navier-Stokes equations, solving for 
the velocity field u = (u, v) and the pressure, p:

ρ
t∂

∂u ∇ p– I η ∇u ∇u( )T
+( )+[ ]⋅– ρ u ∇⋅( )u+ F=

∇– u⋅ 0=
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where I is the unit diagonal matrix, and F is the volume force affecting the fluid. We 
assume no gravitation or other volume forces affecting the fluid, so F = 0.

The Navier-Stokes equations are solved in the spatial (deformed) coordinate system. 
At the inlet, the model uses a fully developed laminar flow. Zero pressure is applied at 
the outlet. No-slip boundary conditions, that is u = 0, are used at all other boundaries. 
Note that this is a valid condition only as long as you are solving the stationary 
problem. In a transient version of the same model, with the obstacle starting out from 
an undeformed state, it is necessary to state that the fluid flow velocity be the same as 
the velocity of the deforming obstacle. This is done in “ALE Fluid-Structure 
Interaction” on page 294 in the MEMS Module Model Library, also using the 
predefined FSI interface, where these velocities are available directly.

S T R U C T U R A L  M E C H A N I C S

The structural deformations are solved for using an elastic formulation and a nonlinear 
geometry formulation to allow large deformations.

For boundary conditions, the obstacle is fixed to the bottom of the fluid channel so 
that it cannot move in any direction. All other boundaries experience a load from the 
fluid, given by

 (10-10)

where n is the normal vector to the boundary. This load represents a sum of pressure 
and viscous forces. In addition, the predefined fluid load takes the area effect between 
the reference frame for the solid and the moving ALE frame in the fluid into account.

M O V I N G  M E S H

The motion of the deformed mesh is modeled using Winslow smoothing. For more 
information on this formulation, please refer to “The Moving Mesh Application 
Mode” on page 401 in the COMSOL Multiphysics Modeling Guide. The boundary 
conditions control the displacement of the moving mesh with respect to the initial 
geometry. At the boundaries of the obstacle, this displacement is the same as the 
structural deformation. At the exterior boundaries of the flow domain, it is set to zero 
in all directions. These settings are available as predefined groups.

FT n– p– I η ∇u ∇u( )T
+( )+( )⋅=
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Results

Figure 10-4 shows the velocity field and the deformed obstacle for a maximum inlet 
velocity of 1.5 m/s. With deformations of this magnitude, the changes in the fluid flow 
domain have a visible effect on the flow.

Figure 10-4: Flow velocity (m/s) in two cross sections of the flow channel and the 
deformation (µm) of the obstacle. The color and direction of the streamlines indicate the 
velocity and the direction of the flow.

Modeling Using the Graphical User Interface

Model Library path: Structural_Mechanics_Module/Fluid-
Structure_Interaction/obstacle_in_fluid

M O D E L  N A V I G A T O R

1 In the Model Navigator, select 3D from the Space dimension list and click the 
Multiphysics button.
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2 From the list of application modes, select Structural Mechanics Module> Fluid-

Structure Interaction>Solid, Stress-Strain with Fluid Interaction>Static analysis.

3 Click OK to close the Model Navigator.

G E O M E T R Y  M O D E L I N G

1 Draw a block with Length X: 2e-4, Y: 1.5e-4, Z: 1.5e-4, and the Axis base point in 
the origin.

2 Click the Zoom Extents button to see the block.

3 Go to Draw>Work-Plane Settings. In the dialog box that appears, select a y-z plane 
placed at x = 0.8e-4. Click OK to close the dialog box. This takes you to the work 
plane.

4 To see the block, click on the Projection of 3D Geometries toolbar button on the 
Visualization/Selection toolbar to the left of the drawing area.

5 Click on the Zoom Extents button on the Main toolbar.

6 Go to Options>Axes/Grid Settings. In the dialog box that appears, apply the settings 
in the table below. To set the grid spacing you need to go to the Grid page and clear 
the Auto check box.

SETTING VALUE

Grid x spacing 1e-5

Grid y spacing 1e-5
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7 Click the Line button and click on each coordinate in the table below, working your 
way from Point 1 to Point 8. When done, right-click to complete the curve. Your 
geometry should now look like Figure 10-5.

Figure 10-5: Cross section of the obstacle.

8 Go to Draw>Extrude and extrude your object by the distance 0.15e-4. Leave all 
other settings at their default values and click OK.

X COORD Y COORD

0.4e-4 0

0.4e-4 0.7e-4

0.6e-4 1.0e-4

1.0e-4 1.0e-4

1.0e-4 0.6e-4

0.8e-4 0.6e-4

0.6e-4 0.5e-4

0.6e-4 0
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P H Y S I C S  S E T T I N G S

1 Go to Options>Constants and define the following constants. The descriptions are 
optional.. 

Subdomain Settings
1 From the Multiphysics menu, make sure 3 Geom1: Incompressible Navier-Stokes (ns) 

is selected.

2 In the Subdomain Settings dialog box, select Subdomain 1 and select Fluid domain 
from the Group list beneath the Subdomain list. Then apply the following settings:

3 Click the Artificial Diffusion button.

4 In the Artificial Diffusion dialog box, clear the Streamline diffusion check box and then 
click OK.

5 Select Subdomain 2 and select Solid domain from the Group list beneath the 
Subdomain list.

6 Click OK to close the dialog box.

7 From the Multiphysics menu, select 1 Geom1: Solid, Stress-Strain (smsld).

8 In the Subdomain Settings dialog box, select Subdomain 1 and then select Fluid 

domain from the Group list.

9 Select Subdomain 2 and select Solid domain from the Group list. Then enter 8e6 in 
the E edit field for Young’s modulus. 

10 Click OK to close the dialog box.

11 From the Multiphysics menu, select 2 Geom1: Moving Mesh (ALE) (ale).

12 In the Subdomain Settings dialog box, apply the following settings by selecting from 
the Group list; when done, click OK.

NAME EXPRESSION DESCRIPTION

u_max 1.5[m/s] Maximum inlet velocity

width 150[um] Channel width

height 150[um] Channel height

SUBDOMAIN 1

ρ 1e3

η 1e-3

SETTING SUBDOMAIN 1 SUBDOMAIN 2

Group Fluid domain Solid domain
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Boundary Conditions
1 From the Multiphysics menu, select Incompressible Navier-Stokes.

2 In the Boundary Settings dialog box, apply the following boundary conditions on the 
active boundaries:

3 Click OK.

4 From the Multiphysics menu, select Solid, Stress-Strain.

5 In the Boundary Settings dialog box, apply the following boundary settings on the 
active boundaries:

6 On the boundaries that are not fixed, select Fluid load from the Group list to define 
the fluid load on the solid domain.

7 From the Multiphysics menu, select Moving Mesh (ALE).

8 In the Boundary Settings dialog box, apply the following predefined groups of 
settings on the active boundaries:

M E S H  G E N E R A T I O N

1 Open the Free Mesh Parameters dialog box and set Predefined mesh sizes to Coarse.

SETTINGS BOUNDARY 1 BOUNDARY 16 ALL OTHER 
BOUNDARIES

Boundary type Inlet Outlet Wall

Boundary condition Velocity Pressure, no 
viscous 
stress

No slip

u0 16*u_max*y*(width-y)*z* 
(height-z)/(width^2*height^2)

v0 0

w0 0

p0 0

SETTINGS BOUNDARY 8 ALL OTHER BOUNDARIES

Page Constraints

Constraint condition Fixed Group Fluid load

SETTINGS BOUNDARIES 1–5, 16 ALL OTHER BOUNDARIES

Group Fixed Structural displacement
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2 On the Subdomain page, select Subdomain 2 and enter 0.2e-4 in the Maximum 

element size edit field.

3 Click Remesh, then click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 On the General page of the Plot Parameters dialog box, select the check boxes for 
Slice, Boundary, Streamline, and Geometry edges.

2 On the Boundary page, select Solid, Stress-Strain (smsld)>X-displacement from the 
Predefined quantities list. Select µm from the Unit list. Select hot from the Colormap 
list.

3 On the Streamline page, select Incompressible Navier-Stokes (ns)>Velocity field from 
the Predefined quantities list. Set the Line type to Tube. Click the Tube Radius button 
and set the Radius scale factor to 0.5. On the Line Color page, select Use expression. 
Click the Color Expression button, then select Incompressible Navier-Stokes (ns)> 
Velocity field from the Predefined quantities list. Set the Colormap to cool, then click 
OK.

4 On the Slice page, select Incompressible Navier-Stokes (ns)>Velocity field from the 
Predefined quantities list. Use the Vector with coordinates edit field to put one slice 
at x = 1.85e-4 and another one at y = 1.35e-4.

5 Click OK to generate the plot.
R  1 0 :  F L U I D - S T R U C T U R E  I N T E R A C T I O N



 11
F r a c t u r e  M o d e l s
This section contains examples of fracture models that you can study using the 
Structural Mechanics Module.
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S i n g l e  Edg e  C r a c k

Introduction

This model deals with the stability of a plate with an edge crack that is subjected to a 
tensile load. To analyze the stability of exciting cracks, you can use fracture mechanics. 

A common parameter in fracture mechanics, the so-called stress intensity factor KI, 
provides a means to predict if a specific crack will cause the plate to fracture. When this 
calculated value becomes equal to the critical fracture toughness of the material KIc (a 
material property), then fast, usually catastrophic fracture occurs.

T H E  J - I N T E G R A L

In this model, you determine the stress intensity factor KI using the so-called J-
integral.

The J-integral is a two-dimensional line integral along a counterclockwise contour, Γ, 
surrounding the crack tip. The J-integral is defined as

where W is the strain energy density

and T is the traction vector defined as

.

σij denotes the stress components, εij the strain components, and ni the normal vector 
components.

The J-integral has the following relation to the stress intensity factor for a plane stress 
case and a linear elastic material:

where E is Young’s modulus.

J W yd Ti x∂
∂ui– sd

Γ
∫ Wnx Ti x∂

∂ui–⎝ ⎠
⎛ ⎞ sd

Γ
∫= =
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2
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2

E
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A N A L Y T I C A L  S O L U T I O N

This problem has an analytical solution (see Ref. 1) for the stress intensity factor:

where σ = 20 MPa (tensile load (force /area)), a = 0.6 m (crack length), and ccf = 2.1 
(configuration correction factor). This correction factor is determined for this 
configuration using an polynomial equation from Ref. 1. This gives the following 
analytical stress intensity factor: KIa = 57. 66 MPa·m1/2.

Model Definition

G E O M E T R Y

A plate with a width w of 1.5 m has a single horizontal edge-crack of length a = 0.6 m 
on the left vertical edge (see Figure 11-1). The total height of the plate is 3 m, but due 
to symmetry reasons the model only includes half of the plate. The model geometry 
also includes two smaller domains, thus adding interior boundaries.

Figure 11-1: Plate geometry.

KIa σ π a⋅ ccf⋅ ⋅=
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D O M A I N  E Q U A T I O N S

Due to the interior boundaries the geometry consists of three subdomains. The same 
material properties apply to all three domains:

B O U N D A R Y  C O N D I T I O N S

You apply a tensile load to the upper horizontal edge, while the lower horizontal edge 
is constrained in the y direction from x = 0.6 m to x = 1.5 m.

Modeling in COMSOL Multiphysics

The analysis computes the J-integrals for three different contours traversing three 
different regions around the crack tip. The first contour follows the exterior 
boundaries of the plate. The second contour follows the interior boundaries at 
x = 0.2 m, y = 0.8 m, and x = 1.2 m. The third and last contour follows the interior 
boundaries at x = 0.4 m, y = 0.4 m, and x = 1 m. 

To calculate the J-integral, you define boundary integration variables for each contour. 
This creates two variables for each contour. The first variable, denoted W, contains the 
integrated strain energy density, while the second, denoted Tdudx, contains the 
traction vector times the spatial x-derivative of the deformation components. The sum 
of these two variables then provides the J-integral value as a scalar expression variable. 
Finally, you can compute the stress intensity factor from the J-integral value, also using 
a scalar expression variable.

Note that the boundaries along the crack are not included in the J-integral, because 
they do not give any contribution to the J-integral. This is due to the following facts: 
for an ideal crack dy is zero along the crack faces, and all traction components are also 
zero (Ti = 0) as the crack faces are not loaded.

When calculating the J-integral, the contour normals must point outward of the region 
which the contour encloses. The boundary normals of the plate geometry are all 
pointing outward. However, some of the normals of the interior boundaries that are 
used for the second and third contour do not point outward of the regions that they 
enclose. This means that you need to define additional normals to get the correct 
alignment of the normals. You define these normals as boundary expressions and use 
them in the boundary integration variables.

QUANTITY NAME EXPRESSION

Young's modulus E 206·109

Poisson's ratio ν 0.3
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Results

The following table shows the stress intensity factors for the three different contours:

It is clear from these results that the values for the stress intensity factor in the 
COMSOL Multiphysics model are in good agreement with the reference value for all 
contours.

It is also clear that the accuracy of the calculated stress intensity factors increases for 
the inner contours.

Figure 11-2 shows the stress singularity at the crack tip.

Figure 11-2: Von Mises stresses and the deformed shape of the plate.

CONTOUR STRESS INTENSITY FACTOR

1 57.79 MPa·m1/2

2 57.71 MPa·m1/2

3 57.67 MPa·m1/2
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Reference

1. Abdel-Rahman Ragab and Salah Eldin Bayoumi, Engineering solid mechanics. 
CRC Press, 1998.

Model Library path: Structural_Mechanics_Module/Fracture/
single_edge_crack

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select 2D in the Space dimension list.

2 Select Structural Mechanics Module>Plane Stress in the list of application modes.

3 Click OK.

G E O M E T R Y  M O D E L I N G

First create the upper half of the plate and add two rectangles so that the inner 
boundaries which is created can be used as contours.

1 Choose Draw>Specify Objects>Square.

2 In the Width edit field type 1.5.

3 Click OK.

4 Add a rectangle by choosing Draw>Specify Objects>Rectangle.

5 In the Width edit field type 1 and in the Height edit field type 0.8.

6 In the x edit field type 0.2 and in the y edit field type 0.

7 Click OK.

8 To add a second rectangle, first choose Draw>Specify Objects>Rectangle.

9 In the Width edit field type 0.6 and in the Height edit field type 0.4.

10 In the x edit field type 0.4 and in the y edit field type 0.

11 Click OK.

Next add a point to define the crack tip.

12 Choose Draw>Specify Objects>Point.

13 In the x edit field type 0.6 and in the y edit field type 0.
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14 Click OK.

This completes the geometry. Compare your result with Figure 11-1 on page 427.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Physics menu, choose Subdomain Settings edit field.

2 Select Subdomains 1, 2, and 3.

3 In the Young’s modulus edit field type 2e11.

4 In the Poisson’s ratio edit field type 0.3.

5 Click OK.

Boundary Conditions
1 From the Physics menu choose Boundary Settings.

2 Select Boundaries 10, 12, and 14, then select Symmetry plane from the Constraint 

condition list.

3 Click the Load tab.

4 Select Boundary 3. In the Fy edit field type 20e6.

5 Click the Edge load is defined as force/area using the thickness option button, then 
click OK.

Point Conditions
1 From the Physics menu choose Point Settings.

2 Select Point 7 and select the Rx check box. Leave the displacement at 0.

3 Click OK.

Boundary Expressions
The interior boundaries, which you use for the two inner J-integral contours, need to 
have user-defined normal direction variables.

1 Choose Options>Expressions>Boundary Expressions.
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2 Specify expressions for each of the normal vector components according to the 
following table. When finished, click OK.

Boundary Integration Variables
1 From the Options menu, choose Integration Coupling variables and click on Boundary 

Variables.

2 Select Boundaries 1, 3, and 15.

3 Specify expressions according to the following table:

4 Select Boundaries 4, 6, and 13.

5 Specify additional expressions according to the following table:

6 Select Boundaries 7, 9, and 11.

7 Specify additional expressions according to the following table:

8 Click OK.

Scalar Expressions
Compute the J-integrals for each contour by summing the two integral expressions. In 
addition, define scalar expressions to compute the stress intensity factors.

1 Choose Options>Expressions>Scalar Expressions.

BOUNDARY NAME EXPRESSION

4, 7 Nx 
Ny

-1 
0

6, 9 Nx 
Ny

0 
1

11, 13 Nx 
Ny

1 
0

NAME EXPRESSION

W (sx_smps*ex_smps+sy_smps*ey_smps+2*sxy_smps*exy_smps)*nx/2

Tdudx -((sx_smps*nx+sxy_smps*ny)*ux+(sxy_smps*nx+sy_smps*ny)*vx)

NAME EXPRESSION

W1 (sx_smps*ex_smps+sy_smps*ey_smps+2*sxy_smps*exy_smps)*Nx/2

Tdudx1 -((sx_smps*Nx+sxy_smps*Ny)*ux+(sxy_smps*Nx+sy_smps*Ny)*vx)

NAME EXPRESSION

W2 (sx_smps*ex_smps+sy_smps*ey_smps+2*sxy_smps*exy_smps)*Nx/2

Tdudx2 -((sx_smps*Nx+sxy_smps*Ny)*ux+(sxy_smps*Nx+sy_smps*Ny)*vx)
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2 Specify expressions according to the following table. When finished, click OK.

M E S H  G E N E R A T I O N

1 Choose Mesh>Free Mesh Parameters.

2 On the Global page, click the Custom mesh size option button.

3 In the Maximum element size edit field, type 0.4.

4 Click the Point tab.

5 Select Point 7, then type 0.05 in the Maximum element size edit field.

6 Click OK.

7 Click the Refine Mesh button on the Main toolbar.

This action first generates a mesh according to the specifications you gave in the Free 

NAME EXPRESSION

KI sqrt(E_smps*abs(J))

J 2*(W+Tdudx)

KI1 sqrt(E_smps*abs(J1))

J1 2*(W1+Tdudx1)

KI2 sqrt(E_smps*abs(J2))

J2 2*(W2+Tdudx2)
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Mesh Parameters dialog box and then refines it once.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar to start the analysis.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

First display the stress intensity factor calculated with the outer contour:

1 From the Postprocessing menu, choose Data Display>Global.

2 In the Expression edit field type KI, then click Apply.

The value for the stress intensity parameter KI appears in the message log.

Next display the stress intensity factor values calculated by the two inner contours.

3 In the Expression edit field type KI1, then click Apply.

4 In the Expression edit field type KI2, then click Apply.

The message log displays the stress intensity parameter values for the inner contours.

To plot the von Mises stress field and the deformed shape, follow these steps:

1 From the Postprocessing menu, choose Plot Parameters.

2 Click the General tab and select the Surface, Deformed shape, and Geometry edges 
check boxes only.
R  1 1 :  F R A C T U R E  M O D E L S



3 Click the Surface tab and select von Mises stress from the Predefined quantities list.

4 Click OK.

5 Click the Zoom Extents button on the Main toolbar.

See Figure 11-2 for the von Mises stresses and the deformed shape plot.
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 12
N o n l i n e a r  M a t e r i a l  M o d e l s
This section contains examples of nonlinear material models that you can study 
using the application modes in the Structural Mechanics Module.
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E l a s t o -P l a s t i c  P l a t e

Model Definition

In this example you analyze a plate with a hole when it is loaded above the elastic limit. 
The example is derived from section 7.10 of The Finite Element Method by O.C. 
Zienkiewicz (Ref. 1).

In addition to the original problem formulation, you follow the unloading history.

Because the plate is thin and the loads are in plane, a plane-stress condition can be 
assumed. Double symmetry means only a quarter of the plate needs to be analyzed.

M A T E R I A L

• Elastic properties: E = 70000 MPa and ν = 0.2.

• Plastic properties: Yield stress 243 MPa and a linear isotropic hardening with 
tangent modulus 2171 MPa.

C O N S T R A I N T S  A N D  L O A D S

• Symmetry plane constraints are applied on the left most vertical boundary and the 
lower horizontal boundary.

• The right vertical edge is subjected to a stress, which increases from zero to a 
maximum value of 133.65 MPa and then is released again. The peak value is selected 
so that the mean stress over the section through the hole is 10% above the yield 
stress (=1.1·243·(20−10)/20).

36mm

5mm
20mm
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Results and Discussion

You can study the development of the plastic region in Figure 12-1. The parameter 
values are 0.59, 0.68, 0.78, 0.88, 0.98, and 1.08. These values are proportional to the 
load with parameter value 1.0 corresponding to the yield limit as average stress over 
the cross-section through the hole. For a material without strain hardening, the 
structure would thus have collapsed before reaching the final load level.

Figure 12-1: Development of plastic region (purple) with increased load.

Because an elasto-plastic solution is load-path dependent, it is important not to use too 
large steps in the load parameter when you anticipate a plastic flow. Usually you can 
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take one large step up to the elastic limit, as this example shows. Moreover, reversed 
plastic flow can occur during the unloading. This is why small parameter steps are used 
at the end of the parameter range in this analysis.

Reference

1. O.C. Zienkiewicz and R.L. Taylor, The Finite Element Method, Fourth Edition, 
McGraw-Hill, 1991.

Model Library path: Structural_Mechanics_Module/
Nonlinear_Material_Models/elasto_plastic_plate

Modeling Using the Graphical User Interface

1 Select 2D in the Space dimension list on the New page in the Model Navigator.

2 Select Structural Mechanics Module>Plane Stress>Static analysis elasto-plastic material.

3 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 Select Model Settings from the Physics menu to open the Model Settings dialog box.

2 Select MPa from the Base unit system list to use mm as length scale unit and MPa as 
stress unit. Click OK.

G E O M E T R Y  M O D E L I N G

1 Shift-click the Rectangle/Square button on the Draw toolbar. In the Width edit field 
type 18 and in the Height edit field type 10. Click OK.

2 Shift-click the Ellipse/Circle (Centered) button. In the Radius edit field type 5, then 
click OK.

3 Select both objects by pressing Ctrl+A, then click the Difference button on the Draw 
toolbar to create the composite object CO1.

4 Click the Zoom Extents button on the Main toolbar.

P H Y S I C S  S E T T I N G S

Boundary Settings
1 Select Boundary Settings from the Physics menu.
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2 Specify boundary settings according to the following tables:

Subdomain Settings
1 Select Subdomain Settings from the Physics menu.

2 Select Subdomain 1, then specify data on the Material page according to the 
following table:

3 Click the Elasto-plastic material data button to open the Elasto-Plastic Material 

Settings dialog box.

4 In the σys edit field type 243 and in the ETiso edit field type 2171.

5 Click OK.

The Gauss point order defaults to 2 times the order of the shape function. When 
solving a static problem with second-order triangular elements, you can improve the 
performance by lowering the Gauss point order from 4 to 2. For a linear elastic 
problem this does not make a large difference, but when solving an elasto-plastic 
problem the difference in memory and speed are much larger, because the solver 
computes the plastic strain in the Gauss points of the elements.

6 Type 2 2 2 in the gporder edit field on the Element page.

Note: Lowering the Gauss point order to the same value as the shape function order 
does not work together with quad and hex elements.

BOUNDARIES 1, 3

Page Constraint

Constraint condition Symmetry plane

BOUNDARY 4

Page Load

Fx 243/2*((para<1.1)*para+ 
(para>=1.1)*(2.2-para))

Edge load is defined as force/area 
using the thickness

Selected

SETTINGS VALUE

 E 70000

 ν 0.2
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7 Click OK to close the Subdomain Settings dialog box. 

M E S H  G E N E R A T I O N

1 Click the Initialize Mesh button on the Main toolbar to generate the mesh.

2 Click the Refine Mesh button to refine the mesh.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 Type the name para in the Parameter name edit field.

3 Enter 0 0.44:0.05:0.59 0.63:0.05:1.08 1.1:0.2:1.9 1.95:0.05:2.2 in 
the Parameter values edit field. Click OK.

4 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page select 0.59 from the Parameter value list.

3 Click the Surface tab.

4 Type epe_smps>0 in the Expression edit field to get a flag for plastic deformation.

5 Select cool from the Colormap list.

6 Return to the General page and step through the values in the Parameter value list, 
clicking Apply in between to generate the plots.
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V i s c o e l a s t i c  Ma t e r i a l

Analysis of Viscoelastic Materials

Viscoelastic materials have a time-dependent response, even if the loading is constant. 
Many polymers and biological tissues exhibit such a behavior. Linear viscoelasticity is 
a commonly used approximation where the stress depends linearly on the strain and its 
time derivatives.

Linear viscoelastic material models are expressed in integral-equation (Equation 12-1) 
or differential-equation (Equation 12-2) models.

 (12-1)

 (12-2)

Models of the general type indicated in Equation 12-2 tend to require high-order 
derivatives and are less suitable for a finite element implementation.

The function G(t) in Equation 12-1 is the relaxation modulus function and can be 
measured as the stress when the material is held at a constant strain. This function is 
often approximated in a Prony series as shown in Equation 12-3.

 (12-3)

 (12-4)

Here G0, µm, and λm are material constants.

It is usually assumed that the viscous part of the deformation is incompressible, so that 
the volume change is purely elastic. With this assumption and the relaxation modulus 
represented by Equation 12-3, a differential equation form which is well suited for 
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COMSOL Multiphysics can be developed. It is given in Equation 12-5 through 
Equation 12-10.

 (12-5)

 (12-6)

 (12-7)

 (12-8)

 (12-9)

 (12-10)

The physical interpretation of this model is that the components of the stress and strain 
deviators, s and e, are related through a generalized Maxwell model, as shown in 
Figure 12-2. The instantaneous shear modulus is G0, the long term shear modulus is 
µ0 G0, and the bulk modulus is K. Note that each of the variables qm has as many 
components as the number of strain components of the problem class. The coefficient 
µm can be interpreted as the relative stiffness of the spring in branch m of the 
generalized Maxwell model. Each time constant λm is the time constant of the spring-
dashpot pair in the same branch. Following the analogy, the abstract variable qm is the 
extension of the corresponding spring.
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Figure 12-2: Generalized Maxwell model.

When the viscous strains grow large, the near incompressibility can cause numerical 
problems if only displacements are used in the interpolating functions. In such cases, 
use a so-called mixed formulation. In a mixed formulation, the pressure, p, is 
introduced as an independent variable, while equation Equation 12-9 is only fulfilled 
in a weak sense.

The interpolation functions used for the variables qm and the pressure (if used) should 
be one order lower than what is used for the displacements, because these variables are 
added to the strains and stresses computed from displacement derivatives.

For many materials, the viscoelastic properties have a strong dependence on the 
temperature. A common assumption is that the material is thermorheologically simple 
(TRS). In a material of this class, a change in the temperature can be transformed 
directly into a change in the time scale. The reduced time τ is defined as

 (12-11)

where aT(T) is a shift function. The implication is that the problem can be solved using 
the original material data, provided that the time is transformed into the reduced time. 
One commonly used shift function is defined by the WLF (Williams-Landel-Ferry) 
equation:

 (12-12)

Note that aT(T0)=1, so that T0 is the temperature at which the original material data 
is given. Usually T0 is taken as the glass temperature of the material. If the temperature 
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drops below T0−C2, the WLF equation is no longer valid. The constants C1 and C2 
are material dependent, but with T0 as the glass temperature the values C1 = 17.4 and 
C2 = 51.6 K are reasonable approximations for many polymers if a base-10 logarithm 
is assumed.

If you think of the shift function as a multiplier to the viscosity in each of the dashpots 
in the generalized Maxwell model, Equation 12-7 will for a TRS material be modified 
to 

 (12-13)

Model Definition

The geometry is a long thick-walled cylinder with an inner radius of 5 mm and an outer 
radius of 10 mm. The inner surface is subjected to a prescribed radial displacement of 
0.001 mm. The model shows the decay of the stresses during a period of two hours.

A quarter of the cylinder is modeled. The first versions of the problem are axially 
symmetric, while the subsequent versions are not.

The example is developed in four steps:

1 A pure Maxwell model (only one spring in series with a dashpot) is used.

2 The material model is changed to a four-term generalized Maxwell model.

3 A stationary temperature field is added, causing the problem to lose its axisymmetry.

4 The temperature field is also transient.

When you solve this type of problem, where a load is applied instantaneously at the 
beginning of the analysis, you can choose between two approaches: Either apply the 
load over a short period of time at the beginning of the time stepping, or use a separate 
static analysis to obtain the initial conditions. Here the latter method is used. It will be 
necessary to create correct initial conditions for the qm variables, that is, they must be 
set equal to the corresponding values of the strain deviator components obtained in 
the initial step.

q·m
1

aT T t( )( )λm

-------------------------------qm+ e·=
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Note: The q variables use linear discontinuous shape functions (shdisc), because 
they are only a part of the material model and do not represent a field that must be 
continuos. This increases the number of degrees of freedom, but there is no coupling 
between elements, resulting in low bandwidth of the matrices. The elements are 
linear, because they appear in equations with strains that come from the derivative of 
a second-order displacement field.

M A T E R I A L

• Elastic (instantaneous) data: Isotropic with E = 67 GPa = 67·103 MPa, ν = 0.22.

• Viscoelastic data, first analysis: Shear modulus behaves as a Maxwell material with 
time constant 1 h, giving µ1 = 1 and λ1 = 3600 s.

• Viscoelastic data, following analyses: Four-term Generalized Maxwell material with:

- µ1 = 0.04, λ1 = 20 s

- µ2 = 0.06, λ2 = 300 s

- µ3 = 0.09, λ3 = 3000 s

- µ4 = 0.25, λ4 = 12000 s

• Thermal properties: A WLF model is used with C1=17.44 and C2=51.6. The 
reference temperature is 500 K.

• Heat conduction properties: ρ = 1100 kg/m3 = 1.1·10−9 t/mm3, cp = 2100 J/kg, 
K = 2100·106 Nmm/(t·K), k = 6·10−2 W/(m·K) = 6·10−2 Nmm/(s·mm·K).

C O N S T R A I N T S

• The circumferential displacements are constrained on the radial edges.

• The inner edge of the hole is constrained to a radial displacement of 0.001 mm.

H E A T  TR A N S F E R  B O U N D A R Y  C O N D I T I O N S

• Stationary analysis: The inner and outer circular edge has a temperature distribution 
varying linearly with the y-coordinate from 500 K at the y = 0 symmetry section to 
505 K at the x = 0 symmetry section.

• Transient analysis: The temperature distribution obtained from the stationary 
analysis is used as initial condition, while all edges are insulated.
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Results and Discussion

The first version of the problem can be solved analytically through the correspondence 
principle. Using such a solution, the radial stress at the inner edge has been evaluated. 
It is compared with the COMSOL Multiphysics solution in the table below.

The evolution of the radial stress at r = 5 mm (solid) and r = 7.5 mm (dashed) is shown 
in the figure below.

In this case no problems occurred with incompressibility constraints. You can see from 
the analytical solution that the effective Poisson’s ratio increased from the initial value 
of 0.22 to about 0.45.

When you use a less idealized material model (the one with four time constants), the 
stress decay looks quite different as is shown below. One major difference is that the 

TIME COMSOL MULTIPHYSICS ANALYTICAL

0 -7.22 MPa -7.23 MPa

3600 s -2.96 MPa -2.97 MPa

7200 s -1.24 MPa -1.24 MPa
R  1 2 :  N O N L I N E A R  M A T E R I A L  M O D E L S



coefficient µ0 is no longer zero, because it is in a the pure Maxwell model. As a 
consequence there are substantial stresses even after a long time.
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When the temperature field shown below is introduced, the relaxation will be faster 
where the temperature is higher. 

In the plot below, the radial stresses at radius 7.5 mm display this effect. The solid line 
is taken at y = 0 (cold) and the dashed line at x = 0 (warm).
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In the last analysis, the temperature initially has the skew distribution above, but is 
allowed to redistribute to a final homogeneous value. Again, we compare the radial 
stresses at radius 7.5 mm. The initial behavior is similar to the previous case, but as the 
difference in material properties decreases, the curves approach each other. The strain 
rate in the initially warm point decreases, while it increases in the initially cold point.

Model Library path: Structural_Mechanics_Module/
Nonlinear_Material_Models/viscoelastic_material

Modeling Using the Graphical User Interface

S T E P  1 — A  P U R E  M A X W E L L  M O D E L

Model Navigator
1 Select 2D in the Space dimension list on the New page in the Model Navigator.

2 Select Structural Mechanics Module>Plane Strain>Quasi-static analysis.

3 Click the Multiphysics button, then click the Add button.

4 Select COMSOL Multiphysics>PDE Modes>PDE, General Form>Time-dependent analysis.
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5 In the Dependent variables edit field type qx_1 qy_1 qz_1 qxy_1.

6 In the Application mode name edit field type visc_1.

7 Click the Add button, then click OK to close the Model Navigator.

Options and Settings
1 Select Model Settings from the Physics menu to open the Model Settings dialog box.

2 Select MPa from the Base unit system list to use mm as length scale unit and MPa as 
stress unit. Click OK.

3 Select Axes/Grid Settings from the Options menu and give axis and grid settings 
according to the following table:

4 When finished, click OK.

AXIS GRID

x min -12 x spacing 1

x max 12 Extra x

y min -12 y spacing 1

y max 12 Extra y
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5 Select Constants from the Options menu and enter constant names, expressions, and 
descriptions (optional) according to the following table:

Note that the unit does not appear in the dialog box.

6 Click OK.

7 Select Expressions>Scalar Expressions from the Options menu and enter expression 
names, expressions, and descriptions (optional) according to the following table:

8 Click OK to close the dialog box.

Geometry Modeling
1 Click the Ellipse/Circle (Centered) button on the Draw toolbar. Click the left mouse 

button at (0, 0), then move the mouse to (10, 10) and click the left mouse button 
again to create a circle with radius equal to the cylinder’s outer radius.

2 Click the Ellipse/Circle (Centered) toolbar button. Click the left mouse button at (0, 
0), then move the mouse to (5, 5) and click the left mouse button again to create a 
circle with radius equal to the cylinder’s inner radius.

3 Select both circles, then click the Difference button on the Draw toolbar.

4 Click the Rectangle/Square button on the Draw toolbar. Click the left mouse button 
at (0, 0), then move the mouse to (11, 11) and click the left mouse button again.

5 Select both solid objects and click the Intersection button on the Draw toolbar.

NAME EXPRESSION DESCRIPTION UNIT

mu_1 1 Prony series coefficient

mu_0 1-mu_1 Prony series coefficient

lambda_1 3600 Prony series time constant s

NAME EXPRESSION DESCRIPTION UNIT

kappa E_smpn/(3*(1-2*nu_smpn)) Instantaneous bulk modulus MPa

G E_smpn/(2*(1+nu_smpn)) Instantaneous shear modulus MPa

ekk ex_smpn+ey_smpn Trace of strain tensor

p2 -kappa*ekk Pressure MPa

mu_q_x mu_1*qx_1 Sum of terms in Prony series

mu_q_y mu_1*qy_1 Sum of terms in Prony series

mu_q_z mu_1*qz_1 Sum of terms in Prony series

mu_q_xy mu_1*qxy_1 Sum of terms in Prony series
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Physics Settings

Boundary Settings   

Constrain the displacements of the cuts through the cylinder to have symmetry 
conditions. Specify the radial displacement on the inner surface to be 0.001 mm. The 
viscoelastic variables should not be prescribed on any boundaries as they are by default.

1 Select Plane Strain from the Multiphysics menu.

2 Select Boundary Settings from the Physics menu.

3 On the Constraint page, specify settings according to the following table:

4 Click OK.

5 Select PDE, General Form from the Multiphysics menu.

6 Select Boundary Settings from the Physics menu.

7 On the Type page, specify boundary settings according to the following table:

8 Click OK.

Subdomain Settings   

1 Select Plane Strain from the Multiphysics menu.

2 Select Subdomain Settings from the Physics menu.

3 On the Material page, specify the material properties of the cylinder according to the 
following table:

4 Click OK.

SETTINGS BOUNDARIES 1, 2 BOUNDARY 3

Constraint condition Symmetry plane Prescribed displacement

Coordinate system - Tangent and normal coord. sys. (t,n)

Rn - -0.001

SETTING BOUNDARIES 1–4

Boundary condition type Neumann boundary condition

SETTINGS SUBDOMAIN 1

 Material model Isotropic material

 E 67e3

 ν 0.22
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5 Select PDE, General Form from the Multiphysics menu.

6 Select Subdomain Settings from the Physics menu.

7 Change the shape functions to be discontinuous of order 1, because they do not 
require continuity. Constrain the q variables to the initial strain deviator. The 
changes are summarized in the following table:

8 When finished, click OK.

9 Select Equation System>Subdomain Settings from the Physics menu.

PAGE SETTING SUBDOMAIN 1

 Γ

Flux vector 0 0 
0 0 
0 0 
0 0

F

Source term qx_1-(ex_smpn-ekk/3) 
qy_1-(ey_smpn-ekk/3) 
qz_1-(-ekk/3) 
qxy_1-exy_smpn

Element

shape shdisc(2,1,'qx_1') 
shdisc(2,1,'qy_1') 
shdisc(2,1,'qz_1') 
shdisc(2,1,'qxy_1')

gporder 2 2 2 2
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10 On the Variables page, change the definitions of the stresses according to the 
following table:

11 When finished, click OK to close the dialog box.

Mesh Generation
1 Select Free Mesh Parameters from the Mesh menu.

2 Select Normal in the Predefined mesh sizes list.

3 Click the Boundary tab. Set Maximum element size to 0.4 for Edge 3.

4 Click the Remesh button, then click OK.

5 Click the Zoom Extents button on the Main toolbar to examine the mesh.

Computing the Initial Conditions
1 Select Solver Parameters from the Solve menu.

2 Select Stationary in the Solver list, then click OK to close the dialog box.

3 Click the Solve button on the Main toolbar.

Initial Conditions for the Transient Solution
1 Select Solver Manager from the Solve menu.

2 Select Stored solution as initial value.

SETTINGS SUBDOMAIN 1

sx_smpn 2*G*(mu_0*(ex_smpn-ekk/3)+mu_q_x)-p2

sy_smpn 2*G*(mu_0*(ey_smpn-ekk/3)+mu_q_y)-p2

sz_smpn 2*G*(mu_0*(-ekk/3)+mu_q_z)-p2

sxy_smpn 2*G*(mu_0*exy_smpn+mu_q_xy)
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3 Click the Store Solution button to save the current solution to be used as initial 
condition.

4 Click OK to close the dialog box.

Physics Settings for the Time-Dependent Problem
1 Select PDE, General Form from the Multiphysics menu.

2 Select Subdomain Settings from the Physics menu.

3 On the F page, add the true time-dependent formulation according to the following 
table:

4 When finished, click OK to close the dialog box.

Computing the Solution for the Time-Dependent Problem
1 Select Solver Parameters from the Solve menu.

SETTINGS SUBDOMAIN 1

Source term -qx_1/lambda_1-qy_1/lambda_1 
-qz_1/lambda_1-qxy_1/lambda_1

Weak

dweak -qx_1_test*(ex_smpn_time-ekk_time/3) 
-qy_1_test*(ey_smpn_time-ekk_time/3) 
-qz_1_test*(-ekk_time/3) 
-qxy_1_test*(exy_smpn_time)
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2 Select Time dependent in the Solver list.

3 On the General page, specify the solver parameters according to the following table:

4 Click OK to close the dialog box, then click the Solve button on the Main toolbar.

Postprocessing and Visualization
Produce a graph of the radial stress as function of time at r = 5 mm and r = 7.5 mm.

1 Select Cross-Section Plot Parameters from the Postprocessing menu.

2 On the Point page, enter the following parameters:

3 Click OK to display the graphs.

EDIT FIELD VALUE

Times 0:100:7200

Absolute tolerance 1e-8

EDIT FIELD VALUE

Predefined quantities Plane Strain (smpn)>sx normal stress global sys.

x 5 7.5

y 0 0
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S T E P  2 — A D D I N G  M O R E  T E R M S  I N  T H E  P R O N Y  S E R I E S

The most structured method to enter the input data is to add one new application 
mode for each term in the Prony series. The only connection between the variables are 
supplied through the scalar expressions.

Model Navigator
1 Choose Model Navigator from the Multiphysics menu.

2 Select 2D in the Space dimension list on the New page in the Model Navigator.

3 Select COMSOL Multiphysics>PDE Modes>PDE, General Form>Time-dependent analysis.

4 In the Dependent variables edit field type qx_2 qy_2 qz_2 qxy_2.

5 In the Application mode name edit field type visc_2.

6 Click the Add button.

7 In the Dependent variables edit field type qx_3 qy_3 qz_3 qxy_3.

8 In the Application mode name edit field type visc_3.

9 Click Add.

10 In the Dependent variables edit field type qx_4 qy_4 qz_4 qxy_4.

11 In the Application mode name field type visc_4.

12 Click the Add button, then close the Model Navigator by clicking OK.

Options and Settings
1 Select Constants from the Options menu and edit constant names, expressions, and 

descriptions (optional) according to the following table:

Note that the unit does not appear in the dialog box.

NAME EXPRESSION DESCRIPTION UNIT

mu_1 0.04 Prony series coefficient 1

mu_2 0.08 Prony series coefficient 2

mu_3 0.09 Prony series coefficient 3

mu_4 0.25 Prony series coefficient 4

mu_0 1-mu_1-mu_2-mu_3-mu_4 Prony series coefficient 0

lambda_1 20 Prony series time constant 1 s

lambda_2 300 Prony series time constant 2 s

lambda_3 3000 Prony series time constant 3 s

lambda_4 12000 Prony series time constant 4 s
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2 Select Expressions>Scalar Expressions from the Options menu and modify expressions 
according to the following table:

Physics Settings

Boundary Settings   

The boundary conditions must be removed for the new variables.

1 Select PDE, General Form (visc_2) from the Multiphysics menu

2 Select Boundary Settings from the Physics menu.

3 On the Type page, specify boundary settings according to the following table:

4 Do the same steps for visc_3 and visc_4.

Subdomain Settings   

1 Select PDE, General Form (visc_2) from the Multiphysics menu.

2 Select Subdomain Settings from the Physics menu.

3 Set the values according to the following tables:

NAME EXPRESSION DESCRIPTION

mu_q_x mu_1*qx_1+mu_2*qx_2+mu_3* 
qx_3+mu_4*qx_4

Sum of terms in Prony series

mu_q_y mu_1*qy_1+mu_2*qy_2+mu_3* 
qy_3+mu_4*qy_4

Sum of terms in Prony series

mu_q_z mu_1*qz_1+mu_2*qz_2+mu_3* 
qz_3+mu_4*qz_4

Sum of terms in Prony series

mu_q_xy mu_1*qxy_1+mu_2*qxy_2+mu_3* 
qxy_3+mu_4*qxy_4

Sum of terms in Prony series

SETTING BOUNDARIES 1–4

Boundary condition type Neumann boundary condition

PAGE SETTINGS SUBDOMAIN 1

 Γ

Flux vector 0 0 
0 0 
0 0 
0 0

 F
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4 Do the same steps for visc_3 and visc_4, substituting all _2 with _3 and _4, 
respectively.

5 For visc_1, reset the Source term on the F page because you must generate new 
initial conditions. The other data is already correct.

Computing the Initial Conditions
1 Select Solver Parameters from the Solve menu.

2 Select Stationary in the Solver list, then click OK.

3 Click the Solve toolbar button.

Initial Conditions for the Time-Dependent Problem
1 From the Solve menu select Solver Manager.

2 Click the Store Solution button to save the current solution to be used as initial 
condition. Click OK.

Physics Settings for the Time-Dependent Problem
1 Select PDE, General Form (visc_1) from the Multiphysics menu

Source term qx_2-(ex_smpn-ekk/3) 
qy_2-(ey_smpn-ekk/3) 
qz_2-(-ekk/3) 
qxy_2-exy_smpn

Element 

shape shdisc(2,1,'qx_2') 
shdisc(2,1,'qy_2') 
shdisc(2,1,'qz_2') 
shdisc(2,1,'qxy_2')

gporder 2 2 2 2

 Weak

dweak -qx_2_test*(ex_smpn_time-
ekk_time/3) 
-qy_2_test*(ey_smpn_time-
ekk_time/3) 
-qz_2_test*(-ekk_time/3) 
-qxy_2_test*(exy_smpn_time)

SETTING SUBDOMAIN 1

Source term qx_1-(ex_smpn-ekk/3) 
qy_1-(ey_smpn-ekk/3) 
qz_1-(-ekk/3) 
qxy_1-exy_smpn

PAGE SETTINGS SUBDOMAIN 1
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2 Select Subdomain Settings from the Physics menu.

3 On the F page, add the true time-dependent formulation according to the following 
table:

4 Do the same steps for visc_2, visc_3, and visc_4, substituting all instances of _1 
with _2, _3, and _4, respectively.

Computing the Solution for the Time-Dependent Problem
1 Select Solver Parameters from the Solve menu.

2 Select Time dependent in the Solver list, then click OK.

3 Click the Solve button on the Main toolbar.

Postprocessing and Visualization
Produce a graph of the radial stress as function of time at r = 5 and r = 7.5.

S T E P  3 — A D D  A  T E M P E R A T U R E  D E P E N D E N C E

To solve the thermal problem, you must add a heat equation and modify the time 
constants in the Prony series.

SETTING SUBDOMAIN 1

Source term -qx_1/lambda_1-qy_1/lambda_1-qz_1/lambda_1-qxy_1/lambda_1
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Model Navigator
1 Select Model Navigator from the Multiphysics menu.

2 Select 2D from the Space dimension list on the New page in the Model Navigator.

3 Select COMSOL Multiphysics>Heat Transfer>Conduction>Transient analysis.

4 Click the Add button, then close the Model Navigator by clicking OK.

Options and Settings
1 Select Constants from the Options menu and add constant names, expressions, and 

descriptions (optional) according to the following table:

Note that the unit does not appear in the dialog box.

2 Select Expressions>Scalar Expressions from the Options menu and add the expression 
for the WLF shift factor:

Physics Settings

Boundary Settings   

1 Select Heat Transfer by Conduction from the Multiphysics menu.

2 Select Boundary Settings from the Physics menu.

3 Specify boundary settings according to the following table:

Subdomain Settings   

You must specify the material data for the thermal problem. In addition, the equations 
for the viscoelastic variables must be reset for initial value computation.

1 Select Subdomain Settings from the Physics menu.

NAME EXPRESSION DESCRIPTION UNIT

C1 17.44 WLF constant C1

C2 51.6 WLF constant C2 K

T_ref 500 WLF reference temperature K

NAME EXPRESSION DESCRIPTION UNIT

time_shift 10^(-C1*(T-T_ref)/
(C2+(T-T_ref)))

WLF time shift factor 1

SETTINGS BOUNDARY 3 BOUNDARY 4

Boundary condition Temperature Temperature

T0 500+y/5*6 500+y/10*6
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2 On the Physics page, specify the thermal properties according to the following table:

3 Select PDE, General Form (visc_1) from the Multiphysics menu.

4 Reset all F terms for the viscoelastic variables for initial value generation in the same 
way as in previous steps for visc_1,

5 Repeat the procedure for visc_2, visc_3, and visc_4 with the previously 
described substitutions of _1.

Computing the Initial Conditions
1 Select Solver Parameters from the Solve menu.

2 Select Stationary in the Solver list, then click OK.

3 Click the Solve button on the Main toolbar.

Initial Conditions for the Time-Dependent problem
1 Select Solver Manager from the Solve menu.

2 Click the Store Solution button to save the current solution to be used as initial 
condition, then click OK.

Physics Settings for the Time-Dependent Problem
1 Select PDE, General Form (visc_1) from the Multiphysics menu.

2 Select Subdomain Settings from the Physics menu.

SETTINGS SUBDOMAIN 1

Physics

k (isotropic) 0.06

ρ 1.1e-9

cp 2.1e9

SETTING SUBDOMAIN 1

Source term qx_1-(ex_smpn-ekk/3) 
qy_1-(ey_smpn-ekk/3) 
qz_1-(-ekk/3) 
qxy_1-exy_smpn
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3 On the F page, add the true time-dependent formulation, including temperature-
dependent time shift, according to the following table:

4 Do the same steps for visc_2, visc_3, and visc_4, substituting all _1 with _2, _3, 
and _4, respectively.

Computing the Solution for the Time-Dependent Problem
1 Select Solver Parameters from the Solve menu.

2 Select Time dependent in the Solver list, then click OK.

3 Click the Solve button on the Main toolbar.

Postprocessing and Visualization
Produce a graph of the radial stress as function of time at (7.5, 0) and (0, 7.5).

SETTING SUBDOMAIN 1

Source term -qx_1/lambda_1/time_shift 
-qy_1/lambda_1/time_shift 
-qz_1/lambda_1/time_shift 
-qxy_1/lambda_1/time_shift
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S T E P  4 — S O L U T I O N  W I T H  A  T R A N S I E N T  T E M P E R A T U R E

In the last version of the problem the temperature field is allowed to settle to a steady 
state using insulated conditions. The initial temperature is the same as above. The only 
change needed is thus to set the boundary conditions for the heat transfer problem to 
be thermally insulated also for Boundaries 3 and 4. Solve again and produce a plot of 
the same type as above.
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Hype r e l a s t i c  S e a l

Introduction

In this model you study the force-deflection relation of a car door seal made from a 
soft rubber material. The model uses a hyperelastic material model together with 
formulations that can account for the large deformations.

T H E O R E T I C A L  B A C K G R O U N D

You find the theory for hyperelastic materials in the section “Hyperelastic Materials” 
on page 176 in the Structural Mechanics Module User’s Guide.

Model Definition

The seal is compressed between a stationary plane surface and an indenting cylinder. It 
is of special interest to investigate the effect of air confined within the seal. Figure 12-
3 below shows the geometry of the seal.

Figure 12-3: Model geometry.

The model describes a cross section of the seal with an assumption of plane strain. The 
contacting surfaces are rigid when compared to the seal.

When computing the pressure from the air compressed inside the seal, the current 
cross-section area is required. One useful method for computing an area is by using 
Gauss’ theorem, and converting to a contour integral.

R=4.5

R=2.5

R=12

1.5

8
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 (12-14)

You need to compute the integral in the deformed geometry, which you accomplish 
by selecting the deformed frame when computing the integral. The software adds a 
deformed frame automatically when you add a contact pair.

M A T E R I A L  P R O P E R T I E S

• The rubber is hyperelastic and is modeled as a Mooney-Rivlin material with C10 = 
0.37 MPa and C01 = 0.11 MPa. The material is almost incompressible, so the bulk 
modulus is set to 104 MPa, and the mixed formulation option is used.

• The compression of the confined air is assumed to be adiabatic, giving the pressure-
density relation

 (12-15)

Here the cross-section area is denoted by A, with the undeformed value A0 = 
123.63 mm2. The constant γ has the value 1.4 and p0 = 0.1 MPa is the standard air 
pressure. The load acting on the interior of the seal is then

 (12-16)

C O N S T R A I N T S  A N D  L O A D S

• The lower straight part of the seal is glued to the car body, so all displacements are 
constrained there.

• One contact pair between the cylinder and the seal.

• One contact pair between the stationary plate and the seal.

• The rigid cylinder is lowered using the parameter of the parametric solver as the 
negative y displacement. It starts with a gap of 0 mm and is lowered 4 mm.

A 1 ad∫ x
0

∇•
⎝ ⎠
⎜ ⎟
⎛ ⎞

ad∫ xnx
ˆ dl∫°= = =

p
p0
------ ρ

ρ0
------⎝ ⎠
⎛ ⎞ γ A0

A
-------⎝ ⎠
⎛ ⎞

γ
= =

∆p p p0– p0
A0
A
-------⎝ ⎠
⎛ ⎞

γ
1–⎝ ⎠

⎛ ⎞= =
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Results and Discussion

The deformed shape at the lowest cylinder position—corresponding to an indentation 
of 4 mm—without internal pressure is shown in Figure 12-4. The deformation scale is 
1:1, that is, a true shape.

Figure 12-4: Seal deformation at 4 mm indentation with internal pressure neglected.

In Figure 12-5 you can compare the deformed shapes at 2 mm indentation. In the 
right figure, where the pressure is included, the seal profile appears “inflated.”

Figure 12-5: Seal deformation at 2 mm indentation without internal pressure (left) and 
with internal pressure (right).
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Figure 12-6 contains a plot of the force (per unit length) versus compression 
(displacement of the rigid cylinder) with and without the internal pressure taken into 
account.

Figure 12-6: Force per unit length versus compression with (dashed) and without internal 
pressure.

Notice that the forces needed to compress the seal can be up to one order of 
magnitude larger when the effect of the air is taken into account.

In reality, a car door seal contains small holes through which the air can escape as long 
as the compression is not too fast. Thus the computed values are the limits 
corresponding to very slow and very fast compression, respectively.

Model Library path: Structural_Mechanics_Module/
Nonlinear_Material_Models/hyperelastic_seal
R  1 2 :  N O N L I N E A R  M A T E R I A L  M O D E L S



Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select 2D in the Space dimension list on the New page in the Model Navigator.

2 Select Structural Mechanics Module>Plane Strain>Parametric analysis.

3 Click OK to close the Model Navigator.

O P T I O N S  A N D  S E T T I N G S

1 Select Model Settings from the Physics menu to open the Model Settings dialog box.

2 Select MPa from the Base unit system list to use mm as length scale unit and MPa as 
stress unit. Click OK.

3 Choose Axes/Grid Settings from the Options menu and give axis and grid settings 
according to the following table (first clear the Auto check box). When done, click 
OK.

4 Choose Expressions>Global Expressions from the Options menu and enter expression 
names, expressions, and descriptions (optional) according to the following table. 
When done, click OK.

G E O M E T R Y  M O D E L I N G

1 Click the Ellipse/Circle (Centered) toolbar button and click the left mouse button at 
(0, 6). Move the mouse to (−6, 0) and click the left mouse button again.

2 Click the Ellipse/Circle (Centered) toolbar button and click the left mouse button at 
(8, 4). Move the mouse to (12, 0) and click the left mouse button again.

3 Click the Ellipse/Circle (Centered) toolbar button and click the left mouse button at 
(8, 8). Move the mouse to (12, 12) and click the left mouse button again.

AXIS GRID

x min -7 x spacing 0.5

x max 15 Extra x

y min -3 y spacing 0.5

y max 25 Extra y

NAME EXPRESSION DESCRIPTION UNIT

int_p 0.1[MPa]*((123.63[mm^2]/
int_area[mm^2])^1.4-1)

Internal pressure in cavity MPa
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4 Click the Rectangle/Square toolbar button and click the left mouse button at (0, 0). 
Move the mouse to (8, 12) and click the left mouse button again.

5 Click the Rectangle/Square toolbar button and click the left mouse button at (12, 4). 
Move the mouse to (7, 8) and click the left mouse button again.

6 Select all objects, and click the Union toolbar button.

7 Click the Delete Interior Boundaries toolbar button

8 Click the Ellipse/Circle (Centered) toolbar button and click the left mouse button at 
(0, 6). Move the mouse to (−4.5, 1.5) and click the left mouse button again.

9 Click the Ellipse/Circle (Centered) toolbar button and click the left mouse button at 
(8, 4). Move the mouse to (10.5, 1.5) and click the left mouse button again.

10 Click the Ellipse/Circle (Centered) toolbar button and click the left mouse button at 
(8, 8). Move the mouse to (10.5, 10.5) and click the left mouse button again.

11 Click the Rectangle/Square toolbar button and click the left mouse button at (0, 1.5). 
Move the mouse to (8, 10.5) and click the left mouse button again.

12 Click the Rectangle/Square toolbar button and click the left mouse button at 
(10.5, 4). Move the mouse to (7, 8) and click the left mouse button again.

13 Select all solid objects and click the Difference toolbar button.

14 Click the Rectangle/Square toolbar button and click the left mouse button at 
(−7, −2.5). Move the mouse to (15, 0) and click the left mouse button again.

15 Click the Ellipse/Circle (Centered) toolbar button and click the left mouse button at 
(4, 24). Move the mouse to (16, 24) while pressing the Shift key and click the left 
mouse button again.

16 Click the Rectangle/Square toolbar button and click the left mouse button at 
(−7, 12). Move the mouse to (15, 17.5) and click the left mouse button again.

17 Select the upper circle and rectangle solid objects and click the Intersection toolbar 
button.
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18 Click the Zoom Extents button on the Main toolbar.

19 Select Use Assembly from the Draw menu to leave Draw mode using an assembly 
instead of a composite geometry.

P H Y S I C S  S E T T I N G S

Contact Pairs
To model the contact, use contact pairs. Start by creating two contact pairs, one at the 
top and one at the bottom. Make the weaker boundary the slave and the stiffer one the 
master boundary.

1 Select Physics>Contact Pairs to open the Contact Pairs dialog box.

2 Click the New button to create a contact pair.

3 Select Boundary 6 and 7 in the Master boundaries list.

4 Click the Check Selected button below the Master boundaries list.

5 Select Boundary 11, 15, and 21 in the Slave boundaries list.

6 Click the Check Selected button below the Slave boundaries list.

7 Click the New button to create an additional contact pair.

8 Select Boundary 3 in the Master boundaries list.

9 Click the Check Selected button below the Master boundaries list.
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10 Select Boundary 14 and 18 in the Slave boundaries list.

11 Click the Check Selected button below the Slave boundaries list.

12 Click OK to close the Contact Pairs dialog box.

Boundary Integration Variables
1 Select Integration Coupling Variables>Boundary Variables from the Options menu.

2 Select Boundaries 9, 10, 12, 16, 17, 19, and 20, then enter the data for the contour 
integral giving the internal area according to the following table:

3 Select Boundaries 11, 15, and 21, then enter the data giving the total vertical force 
using the contact pressure from the first contact pair and the deformed frames 
normal direction according to the table below:

Boundary Settings
Constrain the displacements of the glued lower part of the seal in both directions. 
Specify contact forces at the bottom and from the indenting cylinder.

Select Boundary Settings from the Physics menu. Specify boundary and pair settings 
according to the following tables:

NAME EXPRESSION FRAME

int_area -x2*nx2 Frame (deform)

NAME EXPRESSION FRAME

force Tn_cp1_smpn*ny2 Frame (ref)

BOUNDARY 8

Page Constraint

Constraint condition Fixed

PAIRS 1, 2

Page Contact

pn 20[MPa]/0.5[mm]*min(1e-3*5^auglagiter,10)

Page Contact, Initial

Tn 0
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Subdomain Settings
1 Select Subdomain Settings from the Physics menu. Select Subdomain 3 then specify 

material parameters according to the following table:

2 Select Subdomain 1, click the Constraints page, and select Fixed from the Constraint 

condition list.

3 Select Subdomain 2, click the Constraints page, and select Prescribed displacement 
from the Constraint condition list. Click the Rx and Ry check boxes and enter -para 
in the Ry edit field. Click OK.

M E S H  G E N E R A T I O N

1 Select Free Mesh Parameters from the Mesh menu.

2 Click the Subdomain page, select Subdomain 3 in the Subdomain selection list. Enter 
0.5 in the Maximum element size edit field.

3 Click OK to close the dialog box.

4 Click the Initialize Mesh button on the Main toolbar to generate the mesh.

C O M P U T I N G  T H E  S O L U T I O N

1 Select Solver Parameters from the Solve menu.

2 Type the name para in the Parameter name edit field.

3 Type 0:0.5:4 in the Parameter values edit field.

4 Click the Stationary page.

5 Enter 0.01 in the Tolerance edit field in the Augmented Lagrangian solver area.

6 Enter 50 in the Maximum number of iterations edit field in both the Augmented 

Lagrangian solver area and the Nonlinear settings area.

7 Click the Advanced page and select Manual in the Type of scaling list.

SETTING VALUE UNIT

Material model Hyperelastic

Use mixed U-P formulation 
(nearly incompressible material)

 √

Hyperelastic model Mooney-Rivlin

C10 0.37 MPa

C01 0.11 MPa

 κ 1e4 MPa

 ρ 1.1e-9 t/mm3
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8 Enter u 5 v 5 p 0.5 Tn_cp1_smpn 0.2 Tn_cp2_smpn 0.2 in the Manual scaling 
edit field.

Because the initial value of the contact pressure is zero, you need to use manual 
scaling of the variables. Read more about scaling of variables for contact problems 
in “Solver Settings for Contact Modeling” on page 129 of the Structural 
Mechanics Module User’s Guide.

9 Click OK to close the Solver Parameters dialog box.

10 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To reproduce the plot in Figure 12-4 execute the following instructions.

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page keep the default parameter value in the Solution to use area. 
(This corresponds to the last solution that was calculated; to generate the left plot 
in Figure 12-5 instead, choose 2 from the Parameter value list.)

3 Click the Surface tab. From the Predefined quantities list select Total displacement.

4 Click OK to close the dialog box and generate the plot.

Next, turn to the plots of force versus displacement displayed in Figure 12-6. The solid 
line, which corresponds to the case of neglecting any internal pressure inside the seal, 
is obtained as follows:

1 Select Global Variables Plot from the Postprocessing menu.

2 Enter force in the Expression edit field.

3 Click the > button to move force to the Quantities to plot list.

4 Select all parameter values from 0 to 4 in the Solutions to use list.

5 Click OK to plot the compressive force and close the dialog box.

The plot appears in a separate figure window; keep this window to allow for a direct 
comparison with the case of an airtight seal.

A D D I N G  I N T E R N A L  P R E S S U R E

1 Select Boundary Settings from the Physics menu, then click the Load tab.

2 Select Boundaries 9, 10, 12, 16, 17, 19, and 20.

3 Select Follower type from the Type of load list, then set P to int_p.

4 Click OK.
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C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Plot the force versus displacement curve for an airtight seal by following the steps 
below.

1 Select Global Variables Plot from the Postprocessing menu.

2 Click the Title/Axis button. Click the option button next to the Title edit field and 
then type Compressive force as a function of compression.

3 Click the option button next to the First axis label edit field and then type 
compression (para) [mm]. Click the option button next to the Second axis label 
edit field and type force [N/mm]. Click OK.

4 Enter force in the Expression edit field.

5 Click the > button to move force to the Quantities to plot list.

6 Select all parameter values from 0 to 4 in the Solutions to use list.

7 Select the Keep current plot check box.

8 Select Figure 1 in the Plot in list.

9 Click the Line Settings button to open the Line Settings dialog box.

10 Select Dashed line in the Line style list and click OK to close the Line Settings dialog 
box.

11 Click OK to plot the compressive force and close the dialog box.
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The figure window now contains the plots in Figure 12-6 on page 470, which is 
repeated below for convenience.
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Th e rma l l y  I n du c ed C r e e p

Introduction

This model computes the stress history over a long time for a material that exhibits 
creep behavior. The model is taken from NAFEMS Understanding Non-Linear 
Finite Analysis Through Illustrative Benchmarks (Ref. 1). The displacement and 
stress levels are compared with the values given in the reference.

Creep is an inelastic time-dependent deformation that occurs when a material is 
subjected to stress (typically much less than the yield stress) at sufficiently high 
temperature, say 40% of the melting point or more.

The creep strain rate, in a general case, depends on stress, temperature, and time, 
usually in a nonlinear manner:

Fortunately, it is usually possible to separate these effects in the way indicated by the 
following equation:

Experimental creep data (using constant stress and temperature) often display three 
different types of behavior for the creep strain rate as function of time: 

• In the initial primary creep regime the creep strain rate is decreasing with time. 

ε· c ε· c σ T t, ,( )=

ε· c f1 σ( )f2 T( )f3 t( )=
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• In the secondary creep regime the creep strain rate is almost constant.

• In the final tertiary creep regime the creep strain rate is increasing with time until 
a failure occurs.

Most of the time is spent in secondary creep. Tertiary creep is seldom important 
because it only accounts for a small fraction of the total lifetime, just before failure.

The most common model for secondary creep is the Norton equation where the creep 
strain rate is proportional to a power of the stress:

In the multiaxial generalization of Norton’s law, the creep strain rate tensor is 
proportional to the stress deviator, s:

Here σe is the von Mises effective stress, and the time constant, τ, and the creep stress, 
σc, have been introduced to avoid material data with strange units. When a uniaxial 
test is made using the stress σc, the creep strain rate will be τ−1. If, as is common, creep 
data is supplied as “50 MPa will give 1% strain in 10000 h,” it is possible to identify 
σc = 50 MPa and τ = 106 h.

εc

time

tertiary creepsecondary creep

primary creep

σ1>σ2

σ1

σ2

ε· c Aσnf2 T( )=

εc
· 3

2τ
------

σe
σc
------⎝ ⎠
⎛ ⎞

n 1– s
σc
-----f2 T( )=
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The different sets of constants are related through

giving the following expression for σc where τ can be given arbitrarily if A is known.

In primary creep, the relation can be augmented by an explicit dependence on the time 
such as

In this equation, 0 < m < 1 so that the strain rate is decreasing with time. It is infinite 
at time 0, so you must be careful when using this relation in a numerical method.

When the complete process with both primary and secondary creep is simulated, it is 
possible to combine the models as in the equation

A creep model assumes that the total strain is the sum of the elastic strain, the creep 
strain, and possibly a thermal strain. The stresses are computed from the elastic strain 
as for other materials.

In the Structural Mechanics Module you can introduce the creep strains as new 
dependent variables. Because the creep strains are subtracted from the total strains 
during the stress computations, you should select shape functions for the creep strains 
which are one order lower than what is used for the displacements.

Model Definition

The model is called “Thermally Induced Creep Benchmark” and is described in detail 
in section 3.8 of NAFEMS Understanding Non-Linear Finite Analysis Through 
Illustrative Benchmarks (Ref. 1).

The geometry is a hollow sphere with inner radius 200 mm and outer radius 500 mm. 
The problem is axisymmetric. Actually, the solution depends only on the radial 
coordinate, so you could select any section having radial cuts as the computational 
domain. To follow the original example the model uses a 10-degree sector.

A 1

τ σc( )n
----------------=

σc Aτ( )
1
n
---–

=

ε· c Aσnmtm 1– f2 T( )=

ε· c A1σn1 A2σn2mtm 1–
+( )f2 T( )=
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M A T E R I A L  P R O P E R T I E S

• Isotropic with E = 10·103 MPa, ν = 0.25.

• Secondary Creep Data:

 

with A1 = 3.0·10−6 (t in hours, σ in MPa), n1 = 5.5, and f2(T) = e−12500/T (T in K).

• Primary Creep Data (only used in a modified version of the problem):

A2 = 10 (t in hours, σ in MPa), n2 = 3.5, and m = 0.5.

L O A D S

• An internal pressure of 30 MPa. Strictly speaking, the load should be applied in an 
elastic step to provide initial conditions for the creep analysis. It is more practical, 
however, to apply the load fast in the beginning of the creep analysis. The load thus 
grows from zero to full value in the first 0.1 s of this analysis.

• A temperature field with the distribution T = 333 (1 + 100/r), where r and z are 
given in millimeters and T in kelvin. In COMSOL Multiphysics, you enter this as 
333[K]*(1+100[mm]/sqrt(r*r+z*z)).

C O N S T R A I N T S

Symmetry constraint conditions on the radial edges.

εc
· A1σn1f2 T( )=

ε· c A2σn2mtm 1– f2 T( )=
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Results and Discussion

The reference solutions are available only in graphical form, and the corresponding 
COMSOL Multiphysics results appear in the following plots. The correspondence is 
good in all respects.

An interesting feature of this problem is the extreme variation in the time scales over 
which different phenomena occur. The time marching schemes in COMSOL 
Multiphysics handle this automatically.

Figure 12-7 shows the von Mises effective stress at 108 h.

Figure 12-7: Von Mises effective stress at t = 108.

The evolution of displacement with time appears in Figure 12-8. The upper curve 
represents the inner radius, and the lower curve represents the outer radius. In the 
following table you can compare the values at time 1010 h with the reference values. 

LOCATION COMSOL MULTIPHYSICS REFERENCE (REF. 1)

r=200 26.1 mm 25.3 ± 0.7 mm

r=500 4.2 mm 4.0 ± 0.7 mm
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Because the reference values are given as graphs, these values include an estimate of the 
error caused by reading this graph.

Figure 12-8: Radial displacement at r = 200 mm (Point 2) and 500 mm (Point 4) 
against t.

The next graph shows the variation of the von Mises effective stress with time at the 
inner, middle, and outer radii. Notice that significant changes in the stress state occur 
already at the time 104 h, that is, after one millionth of the total analysis time. In the 
final state the stresses are completely redistributed. The creep process is much faster at 
the inside due to the temperature variation, so the stresses tend to relax there. The 
following table shows the final values of the von Mises effective stress at t = 1010 h and 
the reference values for comparison.

LOCATION COMSOL MULTIPHYSICS REFERENCE (REF. 1) 

r=205 11.5 MPa 11.3 ± 0.4 MPa

r=350 17.6 MPa 17.4 ± 0.4 MPa

r=495 21.1 MPa 21.1 ± 0.4 MPa
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Figure 12-9: Von Mises effective stress at r = 205 mm (+), 350 mm (o), and 495 mm (*) 
versus t.

In the last graph, Figure 12-10, the von Mises effective stress distribution through the 
thickness is shown at the times 1, 104, 105, 107, 108, and 1010 (all times in hours). 
The stress at the inner radius decreases monotonically with time, but at other locations 
the state is more complex.
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Figure 12-10: Von Mises effective stress versus r at t = 1, 104, 105, 107, 108, and 1010 
hours. Times increasing with decreasing stress at r = 200 mm.

When you add primary creep the stresses are redistributed during the process, 
especially in the beginning where the contribution from the initial creep is large. The 
final radial displacement at the inner radius increases from 26.1 mm to 29.1 mm. The 
following three graphs show the results with primary creep included.
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Figure 12-11: Radial displacement at r = 200 mm (point 2) and 500 mm (point 4) 
versus t, primary creep included.

Figure 12-12: Von Mises effective stress at r = 205 mm (+), 350 mm (o), and 495 mm (*) 
versus t, primary creep included.
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Figure 12-13: Von Mises effective stress versus r at t=1, 104, 105, 107, 108, and 1010 hours, 
primary creep included. Times increasing with decreasing stress at r = 200 mm.

Reference

1. A.A. Becker, Understanding Non-Linear Finite Analysis Through Illustrative 
Benchmarks, NAFEMS, Glasgow, 2001.

Model Library path: Structural_Mechanics_Module/
Nonlinear_Material_Models/thermally_induced_creep

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select Axial symmetry (2D) from the Space dimension list on the New page in the Model 

Navigator.
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2 Select Structural Mechanics Module>Axial Symmetry, Stress-Strain>Quasi-static 

analysis.

3 Select Lagrange - Cubic from the Element list.

4 Click Multiphysics and then click Add.

5 Select 2D from the Space dimension list.

6 Select COMSOL Multiphysics>PDE Modes>PDE, General Form>Time-dependent analysis.

7 In the Dependent variables edit field type er_c ephi_c ez_c erz_c.

8 In the Application mode name edit field, type creep.

9 Click the Add button, and then click OK.

O P T I O N S  A N D  S E T T I N G S

1 Select Model Settings from the Physics menu to open the Model Settings dialog box.

2 Select MPa from the Base unit system list to use mm as length unit and MPa as stress 
unit.

3 Select Axes/Grid Settings from the Options menu and give axis and grid settings 
according to the following table:

AXIS GRID

r min -600 r spacing 100

r max 600 Extra r
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NIT

Pa

Pa

Pa
4 Select Constants from the Options menu and enter constant names, expressions, and 
descriptions (optional) according to the following table:

5 Select Expressions>Scalar Expressions from the Options menu and enter names, 
expressions, and descriptions (optional) for the scalar expression variables according 
to the following table:

z min -600 z spacing 100

z max 600 Extra z

NAME EXPRESSION DESCRIPTION UNITS

A2 10 Coefficient for primary creep

n2 3.5 Stress exponent for primary creep

m 0.5 Time exponent for primary creep

A1 3e-6 Coefficient for secondary creep

n1 5.5 Stress exponent for secondary creep

tau 1 Creep time constant (arbitrary) h

sig_cp (A2*tau^m)^(-1/n2) Primary creep reference stress MPa

sig_cs (A1*tau)^(-1/n1) Secondary creep reference stress MPa

p_const 3/2/tau/(sig_cp)^n2*m Useful constant, primary creep

s_const 3/2/tau/(sig_cs)^n1 Useful constant, secondary creep

AXIS GRID

NAME EXPRESSION DESCRIPTION U

sd_r (2*sr_smaxi-sphi_smaxi-sz_smaxi)/3 Stress deviator r-component M

sd_phi (2*sphi_smaxi-sr_smaxi-sz_smaxi)/3 Stress deviator phi-component M

sd_z (2*sz_smaxi-sr_smaxi-sphi_smaxi)/3 Stress deviator z-component M

T 333[K]*(1+100[mm]/sqrt(r*r+z*z)) Prescribed temperature field K

f_t exp(-12500[K]/T) Temperature dependence of 
creep rate

rate_p p_const*f_t*mises2^((n2-1)/2)* 
(t)^(m-1)

Primary creep strain rate 
factor. Note small number to 
avoid t=0 problems.

rate_s s_const*f_t*mises2^((n1-1)/2) Secondary creep strain rate 
factor
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Pa2

NIT
G E O M E T R Y  M O D E L I N G

1 Click the Ellipse/Circle (Centered) toolbar button and click the left mouse button at 
(0, 0). Move the mouse to (500, 500) and click the left mouse button again to 
create a circle with the outer radius.

2 Click the Ellipse/Circle (Centered) toolbar button and click the left mouse button at 
(0, 0). Move the mouse to (200, 200) and click the left mouse button again to 
create a circle with the outer radius.

3 Select both circles, and click the Difference toolbar button.

4 Click the Line toolbar button and click the left mouse button at (0, 0). Move the 
mouse to (600, 0), click the left mouse button and click the right mouse button.

5 Make a copy of the line, and click the Rotate toolbar button. Type 10 in the Rotation 

angle edit field and click OK.

6 Click the Line toolbar button and click the left mouse button at (600, 0). Move the 
mouse so that the cursor snaps to the end of line B2, click the left mouse button and 
click the right mouse button.

7 Select the three lines and click the Coerce to Solid toolbar button.

8 Select both solid objects and click the Intersection toolbar button.

rate_fac rate_s Total creep strain rate factor; 
only secondary creep in this 
analysis

mises2 sr_smaxi^2+sphi_smaxi^2+sz_smaxi^2
-sr_smaxi*sphi_smaxi-
sphi_smaxi*sz_smaxi-
sr_smaxi*sz_smaxi+3*srz_smaxi^2

Effective stress squared M

NAME EXPRESSION DESCRIPTION U
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9 Click the Zoom Extents button on the Main toolbar.

P H Y S I C S  S E T T I N G S

Boundary Settings
Constrain the displacements of the cuts through the sphere to have symmetry 
conditions. Specify the pressure on the inner surface as increasing from zero to 
30 MPa, over the time 0.1 s.

1 Select Axial Symmetry, Stress-Strain (smaxi) from the Multiphysics menu.

2 Select Boundary Settings from the Physics menu.

3 Specify boundary settings according to the following tables:

BOUNDARIES 1, 2

Page Constraint

Constraint condition Symmetry plane

BOUNDARY 3

Page Load

Coordinate system Tangent and normal coord. sys. (t, n)
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4 Select PDE, General Form (creep) from the Multiphysics menu.

5 Select Boundary Settings from the Physics menu.

6 Specify boundary settings according to the following table:

Subdomain Settings
1 Select Axial Symmetry, Stress-Strain (smaxi) from the Multiphysics menu.

2 Select Subdomain Settings from the Physics menu.

3 Specify the material properties of the sphere according to the following table:

4 Select PDE, General Form (creep) from the Multiphysics menu.

5 Select Subdomain Settings from the Physics menu.

6 Specify the terms of the PDE according to the following table:

Ft 0

Fn -30[MPa]*((t>0.1[s])+t/(0.1[s])*(t<=0.1[s]))

BOUNDARIES 1–4

Page Type

Boundary condition type Neumann boundary condition

SUBDOMAIN 1

Page Material

Material model Isotropic

E 10e3

ν 0.25

SUBDOMAIN 1

Page Γ

Flux vector 0 0 
0 0 
0 0 
0 0

Page F

Source term rate_fac*sd_r 
rate_fac*sd_phi 
rate_fac*sd_z 
rate_fac*srz_smaxi

BOUNDARY 3
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7 Select Equation System>Subdomain Settings from the Physics menu.

8 Change the definitions of the stresses, so that each occurrence of the total strain is 
replaced by the difference between the total strain and the creep strain. The 
additional terms are in italics in the table below.

M E S H  G E N E R A T I O N

1 Select Free Mesh Parameters from the Mesh menu.

2 Select Finer in the Predefined mesh sizes list and click the Remesh button.

3 Click OK.

4 Click the Zoom Extents button on the Main toolbar to examine the mesh.

Page da

Damping/Mass coefficient 1 0 0 0 
0 1 0 0 
0 0 1 0 
0 0 0 1

SUBDOMAIN 1

Page Variables

sr_smaxi E_smaxi*(1-nu_smaxi)*(er_smaxi-er_c)/
((1+nu_smaxi)*(1-
2*nu_smaxi))+E_smaxi*nu_smaxi*(ephi_smaxi-
ephi_c)/((1+nu_smaxi)*(1-
2*nu_smaxi))+E_smaxi*nu_smaxi*(ez_smaxi-
ez_c)/((1+nu_smaxi)*(1-2*nu_smaxi))

sz_smaxi E_smaxi*nu_smaxi*(er_smaxi-er_c)/
((1+nu_smaxi)*(1-
2*nu_smaxi))+E_smaxi*nu_smaxi*(ephi_smaxi-
ephi_c)/((1+nu_smaxi)*(1-
2*nu_smaxi))+E_smaxi*(1-
nu_smaxi)*(ez_smaxi-ez_c)/
((1+nu_smaxi)*(1-2*nu_smaxi))

sphi_smaxi E_smaxi*nu_smaxi*(er_smaxi-er_c)/
((1+nu_smaxi)*(1-2*nu_smaxi))+E_smaxi*(1-
nu_smaxi)*(ephi_smaxi-ephi_c)/
((1+nu_smaxi)*(1-
2*nu_smaxi))+E_smaxi*nu_smaxi*(ez_smaxi-
ez_c)/((1+nu_smaxi)*(1-2*nu_smaxi))

srz_smaxi E_smaxi*(erz_smaxi-erz_c)/(1+nu_smaxi)

SUBDOMAIN 1
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C O M P U T I N G  T H E  S O L U T I O N

1 Select Solver Parameters from the Solve menu.

2 Specify the solver parameters according to the following table; then click OK:

The tighter absolute tolerance provides increased accuracy during the time stepping.

3 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Plot the von Mises effective stress at 108 h.

1 Select Plot Parameters from the Postprocessing menu.

2 Select 1e8 from the Solution at time list on the General page.

3 Select von Mises stress from the Predefined quantities list on the Surface page (already 
selected as it is the default plot).

4 Click OK to close the Plot Parameters dialog box and plot the von Mises stress.

Plot the radial displacement at the inner and outer radii versus t.

Page General

Times [0 logspace(-2,10,61)]

Absolute tolerance 1e-6
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1 Select Domain Plot Parameters from the Postprocessing menu.

2 Select all times between 1 and 1e10 in the Solutions to use list on the General page.

3 Click the Title/Axis button.

4 Click the Log scale check box for the First axis label.

5 Click OK to close the Title/Axis Settings dialog box.

6 Click the Point tab.

7 From the Predefined quantities list in the y-axis data area select Axial Symmetry, 

Stress-Strain (smaxi)>r-displacement.

8 Select Points 2 and 4 in the Point selection list to get the radial displacement at the 
inner radius and outer radius.

9 Click the Line Settings button.

10 Click the Legend check box in the Line Settings dialog box.

11 Click OK to close the Line Settings dialog box.

12 Click OK to close the Domain Plot Parameters dialog box and plot the radial 
displacement.

Plot the von Mises effective stress versus r for different times.
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1 Select Domain Plot Parameters from the Postprocessing menu.

2 Select 1, 10000, 1e5, 1e7, 1e8, and 1e10 as times to plot in the Solutions to use list 
on the General page.

3 Click the Title/Axis button.

4 Click the Log scale check box for the First axis label to disable the logarithmic scale 
on the x-axis.

5 Click OK to close the Title/Axis Settings dialog box.

6 Click on the Line/Extrusion page.

7 Select Boundary 2 in the Boundary selection list.

8 Enter mises_smaxi in the Expression edit field.

9 Click the upper option button in the x-axis data area, then select r from the 
associated list.

10 Click the Line Settings button.

11 Click the Legend check box in the Line Settings dialog box; then click OK.

12 Click OK to plot the von Mises effective stress against the radius.

E N A B L I N G  P R I M A RY  C R E E P
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Select Expressions>Scalar Expressions from the Options menu and change the expression 
for the creep strain rate factor to include primary creep:

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Plot the radial displacement at the inner and outer radii versus t:

1 Select Domain Plot Parameters from the Postprocessing menu.

2 Select all times between 1 and 1e10 in the Solutions to use list on the General page.

3 Click the Title/Axis button.

4 Click the Log scale check box for the First axis label.

5 Click OK to close the Title/Axis Settings dialog box.

6 Click the Point tab.

7 From the Predefined quantities list in the y-axis data area select Axial Symmetry, 

Stress-Strain (smaxi)>r-displacement.

8 Select Points 2 and 4 in the Point selection list to get the radial displacement at the 
inner radius and outer radius.

9 Click the Line Settings button.

10 Click the Legend check box in the Line Settings dialog box.

11 Click OK to close the Line Settings dialog box.

NAME EXPRESSION DESCRIPTION

rate_fac rate_s+rate_p Total creep strain rate factor
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12 Click OK to close the Domain Plot Parameters dialog box and plot the radial 
displacement.
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S t r e s s e s  i n  t h e  S o i l  S u r r o und i n g  a  
T r a f f i c  T unn e l

Introduction

This model demonstrates the use of elastoplastic analysis in soil mechanics using the 
Mohr-Coulomb material model under plane strain conditions. The analysis studies the 
stresses and deformations in the soil surrounding a traffic tunnel. This model is 
inspired by a model in Ref. 1.

Model Definition

The modeling of the tunnel and the surrounding soil consist of the following stages:

1 Excavation of the soil at the site.

2 Adding the tunnel onto the soil and applying boundary loads on the tunnel.

Due to symmetry reason the model only includes one half of the geometry (see 
Figure 12-14).

A suitable 2D application mode to model geotechnical problems as this is the Plane 
Strain application mode. 
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Figure 12-14: Cross section of the tunnel and the soil layer.

M A T E R I A L

Soil is a material with a highly nonlinear stress-strain behavior. The soil properties can 
be divided into strength and stiffness properties. The strength of soil can be 
characterized by the effective strength parameters c (cohesion) and (friction angle). 
The stiffness parameters E (Young’s modulus) and ν (Poisson’s ratio) describes the 
elastic deformation of the soil.

Problems of material failure in soil mechanics and other frictional materials such as 
concrete are often modeled using the well-known Mohr-Coulomb law. This is an 
elastic perfectly-plastic material model. A smooth approximation of the Mohr-
Coulomb yield surface for a three-dimensional case is the Drucker-Prager model.

The failure criteria, the yield surface, for both material models are based on the two 
strength parameters, cohesion c and friction angle , and two stress quantities, the 
hydrostatic stress and the equivalent deviatoric stress.

The yield surface F for the Drucker-Prager material law is given by:

where

Soil

Excavation

Tunnel

4 m

14 m

6 m

8 m12 m

φ

φ

F 3 α σm⋅ σeqv K–+⋅=
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and

where σm is the hydrostatic stress (or mean stress), and σeqv is the equivalent deviatoric 
stress. 

On the other hand, if two-dimensional plane strain conditions prevails the Drucker-
Prager criterion becomes identical to the Mohr-Coulomb criterion if you write the 
above material parameters as (see Ref. 3):

The hydrostatic stress is defined using the normal stress components σii by (Ref. 2):

whereas the equivalent deviatoric stress is defined using the deviatoric stress 
components sij:

where the deviatoric stress components sij are defined by:

α 2 φsin⋅
3 3 φsin–( )⋅

--------------------------------------=

K 6 c φcos⋅ ⋅
3 3 φsin–( )⋅

--------------------------------------=

α φtan

9 12 φ2tan⋅+( )
---------------------------------------------=

K 3 c⋅

9 12 φ2tan⋅+( )
---------------------------------------------=

σm
σii

3
-------

σx σy σz+ +

3
-------------------------------= =

σeqv
1
2
--- sij sij⋅ ⋅ 1

2
--- sx

2 sy
2 sz

2
+ +( ) sxy

2 syz
2 szx

2
+ + +⋅= =

sij σij

δij σ⋅ kk

3
--------------------–= or

sx σx σm–= sxy τxy=

sy σy σm–= syz τyz=

sz σz σm–= szx τzx=
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The material properties for the soil are tabulated in Table 12-1 below.:

The model assumes that the tunnel behaves completely elastically and uses some typical 
material values for concrete:

C O N S T R A I N T S  A N D  L O A D S

• The lower horizontal boundary is restrained from moving in both the x and 
y directions, thereby simulating a rough and rigid underlying rock layer.

• The model includes only one half of the tunnel due to symmetry. Symmetry plane 
constraints are thus applied on the symmetry-cut boundaries.

• The left vertical boundary is assumed to be perfectly smooth and rigid. This is 
modeled by applying a constraint only in the horizontal direction, while allowing 
movement in the vertical direction, that is, a roller constraint (see also Figure 12-
15).

• The specific weight of the soil is entered as a domain load in the negative y direction. 
The parametric solver ramps up the specific weight and the in-situ stress, which you 
enter an initial stress, during the elastic-perfectly plastic analysis in the first 
excavation stage of the analysis (solver parameter values para from 0 to 1). 
Originally, the soil carries the following in-situ stresses before the excavation: 

TABLE 12-1:  MATERIAL PROPERTIES FOR THE SOIL.

QUANTITY NAME EXPRESSION UNIT

Young’s modulus E 10e6 Pa

Poisson’s ratio ν 0.3 -

Cohesion c 10000 Pa

Friction angle 35 deg

Specific weight γ 18000 N/m3

TABLE 12-2:  MATERIAL PROPERTIES FOR THE TUNNEL.

QUANTITY NAME EXPRESSION UNIT

Young’s modulus E 25e9 Pa

Poisson’s ratio ν 0.33 -

Specific weight γ 25000 N/m3

φ
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where γ denotes the specific weight of the soil, y is the vertical coordinate from the 
ground level, and ν is Poisson’s ratio.

• The specific weight of the tunnel is ramped up and applied as a domain load in the 
negative y direction in the second stage of the model (solver parameter values para 
from 1 to 2).

• Additional pressure loads are also applied in the second stage. The first pressure load 
is ramped up to 5·104 Pa on the upper horizontal boundaries of the tunnel domain 
and a second pressure load is ramped up to 15·104 Pa on the inner lower horizontal 
boundaries.

• The vertical displacement of the lower horizontal edge of the tunnel, which is the 
common boundary with the soil domain, is set to be equal with the vertical 
displacement of the soil. There is however no horizontal displacement constraints 
on this boundary and thereby allowing a relative sliding between the tunnel and the 
soil.

Figure 12-15: Boundary constraints and loads.

σx λ σy⋅=

σy γ– y⋅=

σz λ σy⋅=

λ ν
1 ν–( )

-----------------=
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Modeling in COMSOL Multiphysics

The model includes two Plane Strain application modes. The first application mode is 
active in the soil domain and computes the elastic perfectly-plastic response of this 
domain. The response due to the excavation and the in-situ stress is calculated in the 
first stage of the model, where you ramp up the specific weight of the soil and the in-
situ stresses using the parametric solver for parameter values between 0 and 1. This is 
a suitable method to achieve convergence for problems containing nonlinearities.The 
full specific weight and in-situ stresses are reached at parameter value 1 and kept 
constant at these levels for the following parameter steps. 

The second stage computes the soil response due to the additional weight and stiffness 
from the tunnel and boundary loads on the tunnel. In this analysis the parametric 
solver ramps up the Young’s modulus of the tunnel, the weight of the tunnel, and the 
boundary loads in the same way as in the first stage but with parameter values from 1 
to 2. The ramping up of the Young’s modulus from a nonsignificant value during the 
parameter values between 0 and 1 to full stiffness at parameter value 2 is due to 
convergence reasons. This is also the reason for ramping up the tunnel weight and 
boundary loads.

The second application mode is active in the tunnel domain and models the elastic 
deformations of the tunnel construction. The use of a separate application mode for 
the tunnel domain makes it possible to apply a tangential slip conditions between the 
soil domain and the tunnel domain.

The elastic perfectly-plastic Mohr-Coulomb material model is implemented with a 
user-defined yield function and a perfectly plastic hardening function. The yield 
function contains hydrostatic and equivalent deviatoric stresses as well as the material 
property constants α and K. You define both the stress variables and the material 
properties as scalar expression variables. A second set of scalar expressions of these 
variables use variables evaluated at the Gauss points. The second set of variables is for 
postprocessing purposes.

Convergence problems can occur in elasto-plastic problems like this. A couple of 
remedies to these problems are to use the mixed U-P formulation for nearly 
incompressible materials and to manually tune the parameter step-size settings. In this 
model you specify the initial parameter step and the minimum step size, while keeping 
the default setting for the maximum step size.
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Results and Discussion

You can study the development of the stress levels, plastic regions, and deformations 
in the following figures. Figure 12-16 shows the stress levels and the plastic regions 
after the excavation. The red-colored areas indicate the plastic regions, and a contour 
plot shows the equivalent deviatoric stresses.

Figure 12-16: The equivalent deviatoric stresses and plastic regions due to the excavation.

Figure 12-17shows the equivalent deviatoric stresses in the soil domain as well as the 
maximum and minimum deformations when the surface pressures and the specific 
weight of the tunnel are applied. The stresses has reached the yield surface in the red 
colored areas. 

The figure also shows that the maximum final vertical deformations of the tunnel 
construction are approximately 5 cm.
R  1 2 :  N O N L I N E A R  M A T E R I A L  M O D E L S



Figure 12-17: The equivalent deviatoric stresses and deformations at peak surface 
pressure.
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Model Library path: Structural_Mechanics_Module/
Nonlinear_Material_Models/traffic_tunnel
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Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select 2D from the Space dimension list on the New page in the Model Navigator.

2 Select Structural Mechanics Module>Plane Strain>Static analysis elasto-plastic 

material.

3 Click OK.

G E O M E T R Y  M O D E L I N G

1 Add a rectangle by selecting from the Draw menu, Specify Objects, and then click 
Rectangle.

2 Type 24 in the Width edit field and type 14 in the Height edit field.

3 Click OK.

4 Next specify some lines. On the Draw menu point to Specify Objects, then click Line.

5 Enter the following coordinate pairs in the x and y edit fields for each line; click OK 
between each line.

6 Select all geometry objects by pressing Ctrl+A.

7 Click the Coerce to Solid toolbar button.

8 Click the Split Object button.

9 Select the geometry object CO3 by clicking on it and delete it by pressing Delete.

10 Add a rectangle by selecting Specify Objects from the Draw menu and then clicking 
Rectangle.

11 In the Width edit field type 4 in the Height edit field type 6.

12 In the Position area, in the x edit field type 20 and in the y edit field type 8.

13 Click OK.

14 Add a second rectangle by selecting from the Draw menu, Specify Objects, and then 
click Rectangle.

15 Type 3.5 in the Width edit field and type 5 in the Height edit field.

16 In the Position area, type 20.5 in the x edit field and type 8.5 in the y edit field.

17 Click OK.

LINE X Y

1

2

12 19

19 24

14 8

8 8
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18 Click the Create Composite Object button on the Draw toolbar.

19 Write R1-R2 in the Set Formula edit field.

20 Click OK.

21 Click the Zoom Extents button on the Main toolbar.

O P T I O N S  A N D  S E T T I N G S

Scalar Expressions
1 Choose Options>Expressions>Scalar Expressions.

2 Specify expressions according to the following table:

NAME EXPRESSION

sigma_mean (sx_smpn+sy_smpn+sz_smpn)/3

sigma_meanGp (sxGp_smpn+syGp_smpn+szGp_smpn)/3

sx sx_smpn-sigma_mean

sx_Gp sxGp_smpn-sigma_meanGp

sy sy_smpn-sigma_mean

sy_Gp syGp_smpn-sigma_meanGp

sz sz_smpn-sigma_mean
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Subdomain Expressions
1 From the Options menu, choose Expressions>Subdomain Expressions.

2 Specify expressions according to the following table:

sz_Gp szGp_smpn-sigma_meanGp

sigma_eqv sqrt(0.5*(sx^2+sy^2+sz^2)+sxy_smpn^2)

sigma_eqvGp sqrt(0.5*(sx_Gp^2+sy_Gp^2+sz_Gp^2)+sxyGp_smpn^2)

alpha tan(phi)/sqrt(9+12*(tan(phi))^2)

K (3*c)/sqrt(9+12*(tan(phi))^2)

F 3*alpha*sigma_mean+sigma_eqv

NAME EXPRESSION IN 
SUBDOMAIN 1

EXPRESSION IN 
SUBDOMAIN 2

phi 35[deg]

c 10000[Pa]

gamma 18e3[N/m^3] 25e3[N/m^3]

NAME EXPRESSION
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P H Y S I C S  S E T T I N G S

Boundary Settings
1 Select Boundary Settings from the Physics menu.

2 Specify boundary settings according to the following table:

Subdomain Settings
1 Select Subdomain Settings from the Physics menu.

2 Select Subdomain 2 in the Subdomain selection list.

3 Clear the Active in this domain check box to deactivate this subdomain in this 
application mode.

4 Select Subdomain 1 in the Subdomain selection list.

5 Verify and enter subdomain data according to the following table:

BOUNDARY 1 BOUNDARY 2 BOUNDARY 12

Page Constraint Constraint Constraint

Constraint condition Roller Fixed Symmetry plane

SUBDOMAIN 1

Page Material

Material model Elasto-plastic material

E 10e6

ν 0.3

Page Load

Fy -gamma*para*(para<=1)-gamma*(para>1)

Page Initial Stress and Strain

σxi -gamma*(0.3/(1-0.3))*(14-y)* 
para*(para<=1)-gamma*(0.3/(1-0.3))* 
(14-y)*(para>1)

σyi -gamma*(14-y)*para*(para<=1)-gamma* 
(14-y)*(para>1)

σzi -gamma*(0.3/(1-0.3))* 
(14-y)*para*(para<=1)-gamma* 
(0.3/(1-0.3))*(14-y)*(para>1)

σxyi 0
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6 Select the Use mixed U-P formulation (nearly incompressible material) check box on 
the Material page.

7 Click the Elasto-plastic material data button.

8 Select Perfectly plastic from the Hardening model list in the Elasto-plastic material 

settings dialog box.

9 Select User defined from the Yield function list and type F in the Yield function edit 
field.

10 Type K in the Yield stress level edit field.

11 Click OK to close the Elasto-plastic material settings dialog box.

12 Click OK to close the Subdomain Settings dialog box. 

M E S H  G E N E R A T I O N

1 Click the Initialize Mesh toolbar button to generate the mesh.

2 Click the Refine Mesh toolbar button to refine the mesh.

M O D E L  N A V I G A T O R

Next add a second Plane Strain application mode:

1 Select Model Navigator from the Multiphysics menu.

2 Select 2D in the Space dimension list on the New page in the Model Navigator.

3 Select Structural Mechanics Module>Plane Strain>Static analysis.
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4 Click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 Select Subdomain Settings from the Physics menu.

2 Select Subdomain 1 in the Subdomain selection list.

3 Clear the Active in this domain check box to deactivate this subdomain in this 
application.

4 Enter subdomain data according to the following table.

5 Click OK to close the Subdomain Settings dialog box. 

Boundary Settings
1 Select Boundary Settings from the Physics menu.

2 Specify boundary settings according to the following tables:

SUBDOMAIN 2

Page Material

Material model Isotropic material

E 25e9*(para-1)*(para>1)+100

ν 0.33

Page Load

Fy -gamma*(para-1)*(para>1)

BOUNDARIES 13, 14

Page Constraint

Constraint condition Symmetry plane

BOUNDARY 7

Page Constraint

Constraint condition Prescribed displacement Ry v

BOUNDARY 8

Page Load

Fy -5e4*(para>1)*(para-1)
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C O M P U T I N G  T H E  S O L U T I O N

1 Select Solver Parameters from the Solve menu.

2 Type the name para in the Parameter name edit field.

3 Type 0:0.1:2 in the Parameter values edit field.

4 Click the Parametric tab.

5 Select the Manual tuning of parameter step size check box.

6 Type 0.01 in the Initial step size edit field.

7 Type 0.001 in the Minimum step size edit field.

8 Type 0.05 in the Maximum step size edit field.

9 Click OK to close the Solver Parameters dialog box.

10 Click the Solve toolbar button.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Select Plot Parameters from the Postprocessing menu.

2 Select 1 from the Parameter value list on the General page.

BOUNDARY 10

Page Load

Fy -15e4*(para>1)*(para-1)
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3 Click the Surface tab.

4 Type epeGp_smpn>0 in the Expression edit field to plot the areas where plastic 
deformation has occurred.

5 On the Contour page select the Contour plot check box.

6 In the Expression edit field type sigma_eqvGp to plot the equivalent deviatoric 
stress.

7 Click the Max/Min tab and select the Max/Min marker check box.

8 On the Subdomain Data page clear the Subdomain max/min data check box.

9 On the Boundary Data page select the Boundary max/min data check box.

10 From the Predefined quantities list select Plane Strain (smpn2)>Total displacement.

11 Click OK.
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F l e x i b l e  a nd Smoo t h  S t r i p  Foo t i n g  on 
S t r a t um o f  C l a y

Model Definition

A typical verification model for geotechnical problems is a shallow stratum layer of clay, 
depicted in Figure 12-18 below. A vertical load is applied on the clay stratum and the 
static response and the collapse load are studied.

Figure 12-18: Dimensions, boundary conditions, and pressure load for the stratum of clay.

A N A L Y S I S  T Y P E

Yield Surface
Model the clay as a linear elastic-perfectly plastic material, and assume plane-strain 
conditions in this analysis.

The yield surface, F, for the Drucker-Prager material law is given by

where I1 is the first stress invariant and J2 is the second deviatoric stress invariant.

The first stress invariant is defined using the normal stress components:

7.32 m

3.66 m

1.57 m

p symmetry axis
(centerline)

F α I1⋅ J2+ K= =
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The second stress invariant is defined by

The second deviatoric stress invariant can be expressed using the first and the second 
stress invariants:

If two-dimensional plane-strain conditions prevail the Drucker-Prager criterion 
becomes identical to the Mohr-Coulomb criterion if the material parameters α and K 
are given by (see Ref. 1)

The model employs the Mohr-Coulumb yield condition with an associated flow rule 
and a nonassociated flow rule.

Flow Rule
The flow rule defines the relation between the plastic strain increment in a given 
direction and the current level of stress in the same direction. The relation reads

where dλ is the plastic multiplier and Q is the plastic potential. If the yield surface, F, 
and the plastic potential, Q, are identical, that is, if F = Q, then the rule is called an 
associated flow rule, otherwise a nonassociated flow rule.

The associated flow does unfortunately not always describe the real physical process in 
a sufficiently realistic manner, especially if the material is pressure sensitive like for 
example, soil. Usually, the associated flow rule overestimates the volumetric plastic 
strains.

I1 σx σy σz+ +=

I2 σx σy⋅ σy σz⋅ σz σx⋅+ + τxy
2

–=

J2
1
3
--- I1

2⋅ I2–=

α φtan

9 12 φ2tan⋅+( )
---------------------------------------------=

K 3 c⋅

9 12 φ2tan⋅+( )
---------------------------------------------=

dεij dλ ∂Q
∂σij
----------=
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The nonassociated flow rule case uses a von Mises type of function for the plastic 
potential in this model. This function does not include volumetric plastic strains. The 
plastic potential can thus be written as

M A T E R I A L  P R O P E R T I E S

• Young’s modulus, E = 207 MPa, and Poisson’s ratio ν = 0.3.

• Cohesion c = 69 MPa and angle of internal friction, degrees.

C O N S T R A I N T S  A N D  L O A D S

• The clay layer is supported by a rigid and perfectly rough base. Therefore, fix the 
lower horizontal boundary.

• The left vertical boundary is perfectly smooth and a roller boundary condition is 
suitable to use at this boundary. 

• Model only the left half of the domain due to symmetry reasons. Thus, use 
symmetry boundary condition at the right vertical boundary.

• The stratum is subjected to a footing that you can consider to be flexible and 
smooth. The width of the strip footing is 3.14 m. Gradually increase the footing 
pressure until the clay layer reaches the collapse load.

This example is derived from Nonlinear Analysis in Soil Mechanics by W.F. Chen and 
E. Mizuno (Ref. 1).

Results and Discussion

You can study in Figure 12-19 the load-displacement curves for both the associated 
case and the nonassociated case. The figure shows the applied footing pressure versus 
the centerline displacement (directly beneath the footing’s center) in the y direction. 
The dashed line shows the load-displacement curve for the nonassociated flow rule 
case and the solid line shows the load-displacement curve for associated flow rule case. 

The model uses the SI unit system. The load-displacement curves in Ref. 1 are however 
given in psi (pounds per square inch) and inches. To facilitate comparisons, the load-
displacement plots use these units.

The curves are identical up to 40 psi because the whole domain is still within the elastic 
region. When the pressure increases the behavior diverges. The curve for the associated 
flow rule bends at approximately 150 psi and reaches the collapse load at approximately 

Q J2=

φ 20=
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160 psi. The curve for the nonassociated case deviates gradually from the associated 
case and reaches a collapse load at approximately 146 psi. The collapse load deviates 
only by approximately 3% from the solution given in Ref. 1. 

Figure 12-19: Footing pressure vs. vertical displacement for the nonassociated case (dashed 
line) and the associated case (solid line).

Modeling in COMSOL Multiphysics

Implement the Mohr-Coulomb elastic-perfectly plastic material model with a user-
defined yield function and a perfectly plastic hardening function. The yield function 
contains the first stress invariant, I1, and the second deviatoric stress invariant, J2, as 
well as the material property constants α and K. You define the stress variables and the 
material properties as scalar expression variables and constants.

Model the associated flow rule case in the graphical user interface. For the 
nonassociated flow rule case, on the other hand, you need to model on the command 
line. The workflow for the nonassociated flow rule case:

1 Export the FEM structure for the associated case from the graphical user interface 
to the command line.

2 Edit the plastic potential definition.
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3 Solve and postprocess the model on the command line.

A suitable modeling technique in a case like this, where the relation between the 
applied load and the displacement is highly nonlinear, is to use an algebraic equation 
that controls the applied pressure so that the model reaches the desired displacement 
increments. The ODE functionality in COMSOL Multiphysics provides the means for 
entering the algebraic equation, and the parametric solver steps up the desired vertical 
displacement.

Convergence problems can occur in elasto-plastic problems like this. If this happens, 
try scaling the solution components manually.

Reference

1. W.F. Chen and E. Mizuno, Nonlinear Analysis in Soil Mechanics, Elsevier, 1990.

Model Library path: Structural_Mechanics_Module/
Nonlinear_Material_Models/flexible_footing

Modeling Using the Graphical User Interface

1 In the Model Navigator select 2D from the Space dimension list on the New page.

2 Select Structural Mechanics Module>Plane Strain>Static analysis elasto-plastic 

material.

3 From the Element list select Lagrange - Linear.

4 Click OK.

Options and Settings
1 From the Options menu select Constants. Enter constant names, expressions, units 

and descriptions (optional) according to the following table:

NAME EXPRESSION DESCRIPTION

E 2.07e8[Pa] Young’s modulus

nu 0.3 Poisson’s ratio

phi 20/180*pi Angle of internal friction

c 69e3[Pa] Cohesion
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2 Click OK.

3 From the Options menu select Expressions>Scalar Expressions. Enter expression 
names, expressions, and descriptions (optional) according to the following table:

Note that the unit for the variable Footing_pressure has red colored brackets 
because an ODE variable (Pressure) is used in the expression for this variable. 
Dividing the Pressure variable with 1[psi] converts the value for this variable to psi.

4 Click OK to close the dialog box.

G E O M E T R Y  M O D E L I N G

1 Shift-click the Rectangle/Square button on the Draw toolbar. In the Width edit field 
type 7.32 and in the Height edit field type 3.66 Click OK.

2 Shift-click the Point button. In the x edit field type 5.75 and in the y edit field type 
3.66, then click OK.

3 Click the Zoom Extents button on the Main toolbar.

P H Y S I C S  S E T T I N G S

Boundary Settings
1 From the Physics menu select Boundary Settings.

alpha tan(phi)/sqrt(9+12*(tan(phi))^2) Drucker-Prager material 
constant

K (3*c)/sqrt(9+12*(tan(phi))^2) Drucker-Prager material 
constant

NAME EXPRESSION DESCRIPTION

NAME EXPRESSION DESCRIPTION

I1 sx_smpn+sy_smpn+sz_smpn First stress invariant

I2 sx_smpn*sy_smpn+ 
sy_smpn*sz_smpn+ 
sz_smpn*sx_smpn-sxy_smpn^2

Second stress invariant

J2 1/3*I1^2-I2 Second deviatoric stress 
invariant

F (alpha*I1+sqrt(J2)) Yield surface

Footing_pressure -Pressure/1[psi] Pressure in psi
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2 Specify boundary settings according to the following table:

Subdomain Settings
1 From the Physics menu select Subdomain Settings.

2 Select Subdomain 1, then verify and specify data on the Material page according to 
the following table:

3 Click the Elasto-plastic material data button to open the Elasto-plastic material 

settings dialog box.

4 From the Hardening model list select Perfectly plastic.

5 From the Yield function list select User defined.

6 In the σyfunc edit field type F and in the σys edit field type K.

7 Click OK.

BOUNDARY PAGE CONSTRAINT CONDITION QUANTITY VALUE

1 Constraint Roller

2 Constraint Fixed

5 Constraint Symmetry plane

4 Load Fy Pressure

SETTINGS VALUE

Material model Elasto-plastic material

E E

 ν nu
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8 Click OK to close the Subdomain Settings dialog box.

Integration Coupling Variable
1 From the Options menu select Integration Coupling Variables>Point Variables.

2 Select Point 5. 

3 Type vc in the Name edit field and v in the Expression edit field.

4 Click OK to close the Point Integration Variables dialog box.

By defining the above point integration coupling variable vc the deformation in 
y direction at Point 5 is made available for the next step where an algebraic equation 
is created.

Global Equations
1 Select Global Equations from the Physics menu.

2 Enter Pressure in the Name edit field and vc-para in the Equation edit field.

3 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, choose Free Mesh Parameters.

2 Select Fine from the Predefined mesh sizes list.

3 Click the Remesh button and then click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 In the Parameter name edit field type the name para.

3 In the Parameter values edit field type 0:-0.0005:-0.045. Click OK.

4 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Click the Plot Parameters button on the Main toolbar.

2 Select the Surface and Deformed shape check boxes in the Plot type area on the 
General page.

3 Click the Surface tab.

4 In the Expression edit field type epe_smpn>0.
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5 Click OK.

6 From the Postprocessing menu select Domain Plot Parameters.

7 Click the Point tab.

8 Select Point 5.

9 Into the Expression edit field enter Footing_pressure.

10 In the x-axis data frame select Expression.

11 Click the Expression button and enter -v in the Expression edit field.

12 From the Unit list select in, then click OK.

13 Click OK.
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While the graphical user interface supports the associated flow rule, you need to define, 
solve, and postprocess the nonassociated flow rule model on the command line. You 
need COMSOL Script or MATLAB for this part of the simulation. The following lines 
change the plastic potential to a von Mises function, solve the problem, and plot the 
footing pressure as function of the displacement in the same figure as for the associated 
case (make sure that the figure window for the previous results plot is open):

1 Select Export and FEM Structure as 'fem' from the File menu.

2 Enter the following lines at the command line prompt or run the file 
flexible_footing_nonassoc.m. The M-file is located in the subfolder denoted 
sme in your COMSOL installation directory.

G = fem.elemmph(3);
G{1}.geomdim{1}{3}.G{1}{1} = 'diff(mises_smpn,sx_smpn)';
G{1}.geomdim{1}{3}.G{1}{2} = 'diff(mises_smpn,sy_smpn)';
G{1}.geomdim{1}{3}.G{1}{3} = 'diff(mises_smpn,sz_smpn)';
G{1}.geomdim{1}{3}.G{1}{4} = '0.5*diff(mises_smpn,sxy_smpn)';
fem.elemmph(3)=G;

% Extend mesh
fem.xmesh=meshextend(fem);
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% Solve problem
fem.sol=femnlin(fem, ...
'u',0, ...
'solcomp',{'u','v','Pressure'}, ...
'outcomp',{'epx_smpn','u','epe_smpn','epz_smpn','v',...
'epxy_smpn','epy_smpn','Pressure'}, ...
'pname','para', ...
'pinitstep',1e-4, ...
'pminstep',1e-6, ...
'pmaxstep',0.01,...
'plist',[0:-0.0005:-0.045], ...
'uscale',{'u','0.01','v','0.01'}, ...
'hnlin','on');

% Plot in cross-section or along domain
hold on
postcrossplot(fem,0,[5], ...
'pointdata','Footing_pressure', ...
'pointxdata',{'-v','unit','in'}, ...
'title','Footing_pressure [psi] versus displacement [in]', ...
'axislabel',{'v [in]','Footing_pressure [psi]'}, ...
'refine','auto','linstyle','--');

The following figure shows the finished plot.
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P i e z o e l e c t r i c i t y  M o d e l s
The piezoelectric effect can be seen as a transfer of electric to mechanical energy 
and vice-versa. It is observed in many crystalline materials. Some materials, such as 
quartz, Rochelle salt, and lead titanate zirconate ceramics, display the phenomenon 
strongly enough to use it.

The direct piezoelectric effect consists of an electric polarization in a fixed direction 
when the piezoelectric crystal is deformed. The polarization is proportional to the 
deformation and causes an electric potential difference over the crystal.

The inverse piezoelectric effect, on the other hand, constitutes the opposite of the 
direct effect. This means that an applied electric field induces a deformation of the 
crystal.

This chapter shows the application of the Structural Mechanics Module for 
modeling the piezoelectric effect using a static linear analysis. A 3D example 
describes modeling of the inverse piezoelectric effect.

An introductory piezoelectric model of a piecoceramic tube is also available. You 
find the documentation for this model in the Structural Mechanics Module User’s 
Guide.
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P i e z o c e r am i c  Tub e

Introduction

This example performs a static 2D axisymmetric analysis of a piezoelectric actuator 
using the 2D Piezo Axial Symmetry application mode. It models a radially polarized 
piezoelectric tube as described by S. Peelamedu and others (Ref. 1). One application 
area where radially polarized tubes are employed is in nozzles for fluid control in inkjet 
printers.

Model Definition

G E O M E T RY

The tube has a height of 0.62 mm and an inner and outer radius of 0.38 mm and 
0.62 mm, respectively.

M A T E R I A L

The material properties for the piezoceramic (PZT-5H) are:

c

127 80.2 84.7 0 0 0
127 84.7 0 0 0

117 0 0 0
23.0 0 0

sym 23.0 0
23.5

GPa=

e
0 0 0 0 17.03448 0
0 0 0 17.03448 0 0

6.22812– 6.22812– 23.– 2403 0 0 0

  C/m2
=

ε
1.5 0 0
0 1.5 0
0 0 1.3

10 8–   F/m⋅=
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B O U N D A R Y  C O N D I T I O N S

This model studies two cases, each of which studies different boundary conditions. 
Case 1 represents the inverse piezoelectric effect, and case 2 represents the direct 
piezoelectric effect.

Case 1:

• Structural mechanics boundary condition—constrain the bottom surface from 
moving axially (in the z-direction).

• Electrostatics boundary condition—apply a 1 V potential difference between the 
tube’s inner and outer surfaces.

Case 2:

• Structural mechanics boundary condition—constrain the bottom surface from 
moving axially (in the z direction), but also add an internal fluid pressure of 
0.1 MPa.

• Electrostatics boundary condition—ground the inner and outer surfaces.
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Results and Discussion

The image in Figure 13-1 shows the deformation due to the applied voltage difference 
in Case 1. For the same case, Figure 13-2 shows the radial displacement as a function 
of the tube thickness at the top boundary. 

Figure 13-1: The deformed shape and radial displacement of a piezoceramic-tube 
actuator due to the radial electric field for Case 1.
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Figure 13-2: The radial displacement as a function of the tube thickness due to the radial 
electric field (Case 1).

For the second case, Figure 13-3 shows the deformed shape in Case 2. For that same 
case, Figure 13-4 shows the radial displacement as a function of tube thickness. These 
results show good agreement with those from S. Peelamedu (Ref. 1).
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Figure 13-3: The deformed shape and radial displacement in a piezoceramic-tube 
actuatordue to an internal pressure of 0.1 MPa (Case 2).
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Figure 13-4: The radial displacement as function of the tube thickness due to an internal 
pressure of 0.1 MPa (Case 2).

Modeling in COMSOL Multiphysics

C O N S T I T U T I V E  E Q U A T I O N  A N D  M A T E R I A L  D A T A

You specify the material parameters for the piezoelectric material in the 
Subdomain Settings dialog box in the piezoelectric application mode. Then select the 
stress-charge form for the constitutive equation because this suits the form in which 
you give the material data. Further, enter the elasticity matrix into the ce matrix, enter 
the piezoelectric coupling matrix into the e matrix, and enter the relative permittivities 
into the εrS matrix.

You enter the material properties in this example such that the polarization is in the 
z direction (in a 3D Cartesian coordinate system), which is a common orientation for 
published material data. This orientation means that you must rotate the material so 
that its polarization direction is aligned with the r-direction (radially polarized). To do 
so, use the material-orientation feature in the Piezo Axial Symmetry application mode. 
By selecting the material orientation as the zx-plane, you rotate the material so that its 
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z direction is aligned with the r direction of the model, and the material’s x direction 
is aligned with the model’s z direction.

The piezoceramic material in this example (PZT-5H) is a transversely isotropic 
material, which is a special class of orthotropic materials. Such a material has the same 
properties in one plane (isotropic behavior) and different properties in the direction 
normal to this plane. Thus you can use either the zx-plane material orientation or the 
zy-plane material orientation; both give the same solution.

M E S H I N G

The rectangular geometry is well suited for quadrilaterals, and the model uses a 6-by-
6-element grid.

Reference

1. S. Peelamedu et al., Numerical Approach for Axisymmetric Piezoceramic 
Geometries towards Fluid Control Applications, Univ. Toledo, OH, Mechanical, 
Industrial and Manufacturing Engineering Dept., 2000.

Model Library path: Structural_Mechanics_Module/
Piezoelectric_Effects/piezoceramic_tube

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics. This invokes the Model Navigator, which you can also 
open from an already running COMSOL Multiphysics session by choosing New 

from the File menu.

2 Select Axial Symmetry (2D) from the Space dimension list.

3 Select Structural Mechanics Module>Piezoelectric Effects>Piezo Axial Symmetry>Static 

analysis from the list of application modes.

4 Click OK to close the Model Navigator. Note that this gives you second-order 
elements, Lagrange - Quadratic, by default.

G E O M E T RY  M O D E L I N G

Define the model geometry in Draw mode.
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1 Shift-click the Rectangle/Square button in the Draw toolbar to open the Rectangle 
dialog box.

2 Type 0.24e-3 in the Width edit field and 0.62e-3 in the Height edit field. In the 
Position area, type 0.38e-3 in the r edit field and 0 in the z edit field. This creates a 
rectangle with opposite corners at (0.38e-3, 0) and (0.62e-3, 0.62e-3).

3 Click the Zoom Extents button.

P H Y S I C S  S E T T I N G S  F O R  M O D E L  C A S E  1

Boundary Conditions
1 Open the Boundary Settings dialog box by choosing Boundary Settings from the 

Physics menu.

2 Select Boundary 2 from the Boundary selection list.

3 Select Roller from the Constraint condition list on the Constraint page.

4 Select all boundaries by pressing Ctrl+A.

5 Select Zero charge/Symmetry from the Boundary condition list on the Electric BC page.

6 Select Boundary 1 and then select Ground from the Boundary condition list.

7 Select Boundary 4 and then select Electric potential from the Boundary condition list 
and type 1 in the Electric potential edit field.

8 Click OK to close the dialog box.
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Subdomain Settings
1 Open the Subdomain Settings dialog box by selecting Subdomain Settings from the 

Physics menu.

2 Select Subdomain 1 and click the Structural tab.

3 Select zx plane from the Material orientation list.

4 Click the Edit button associated with cE and enter the following values into the 
Elasticity matrix dialog box; when done, click OK. 

Entries for the elasticity matrix.

1.27e11 8.02e10 8.47e10 0 0 0

1.27e11 8.47e10 0 0 0

1.27e11 0 0 0

2.30e10 0 0

2.30e10 0

2.30e10
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5 Click the Edit button associated with e and enter the following values into the 
Coupling matrix dialog box; when done, click OK. 

Entries for the coupling matrix.

6 Click the Edit button associated with εrS and enter the following values into the 
Relative permittivity matrix dialog box; when done, click OK. 

Entries for the relative permittivity matrix.

7 Click OK again to close the Subdomain Settings dialog box.

M E S H  G E N E R AT I O N

1 From the Mesh menu choose Mapped Mesh Parameters.

2 Click the Boundary tab.

3 Select Boundary 1 and click the Constrained edge element distribution button.

4 Enter 6 in the Number of edge elements edit field.

0 0 0 0 17.03448 0

0 0 0 17.03448 0 0

-6.22812 -6.22812 -23.2403 0 0 0

1694

1694

1468
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5 Repeat this for the remaining three boundaries.

6 Click the Remesh button.

The meshed geometry for the piezoceramic-tube actuator.

7 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.
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PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Choose Plot Parameters from the Postprocessing menu to open the Plot Parameters 
dialog box.

2 On the General page, find the Plot type area, then select the Deformed shape and 
Surface check boxes.

3 Click the Surface tab.

4 Select r-displacement from the Predefined quantities list and click OK (this step 
reproduces Figure 13-1).

5 Choose Cross-Section Plot Parameters from the Postprocessing menu.

6 Click the Line/Extrusion tab.

7 Select r-displacement from the Predefined quantities list.

8 Go to the Cross-section line data area. In the r0 edit field enter 3.8e-4. Similarly set 
r1 to 6.2e-4 and then both z0 and z1 to 3e-4.

9 Click OK (this step reproduces Figure 13-2).

P H Y S I C S  S E T T I N G S  F O R  M O D E L  C A S E  2

Boundary Conditions
1 Open the Boundary Settings dialog box by selecting Boundary Settings from the 

Physics menu. In this dialog box you can select boundaries and enter expressions for 
boundary conditions.

2 Select Boundary 1 from the Boundary selection list.

3 Enter 0.1e6 in the Fr edit field on the Load page.

4 Select Boundaries 1 and 4 and then select Ground from the Boundary condition list 
on the Electric BC page.

5 Select Boundaries 2 and 3 and then select Zero charge/Symmetry from the Boundary 

condition list on the Electric BC page.

6 Click OK to close the dialog box.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Choose Plot Parameters from the Postprocessing menu to open the Plot Parameters 
dialog box.
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2 On the General page select the Deformed shape and Geometry edges check boxes in 
the Plot type area.

3 Click the Surface tab and select r-displacement from the Predefined quantities list and 
click OK (this reproduces Figure 13-3).

4 Choose Cross-Section Plot Parameters from the Postprocessing menu.

5 Click the Line/Extrusion tab.

6 Select r-displacement from the Predefined quantities list.

7 Go to the Cross-section line data area. In the r0 edit field enter 3.8e-4. Similarly set 
r1 to 6.2e-4 and then both z0 and z1 to 3e-4.

8 Click OK (this reproduces Figure 13-4).
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P i e z o e l e c t r i c  S h e a r  A c t u a t e d  Beam

Introduction

This example performs a static analysis on a piezoelectric actuator based on the 
movement of a cantilever beam, using the static 3D Piezo Solid application mode. 
Inspired by work done by V. Piefort (Ref. 1) and A. Benjeddou (Ref. 2), it models a 
sandwich beam using the shear mode of the piezoelectric material to deflect the tip.

Model Definition

G E O M E T R Y

The model consists of a sandwiched cantilever beam 100 mm long; it consists of a rigid 
foam core 2 mm thick sandwiched by two 8-mm thick aluminum layers. Further, the 
device replaces part of the foam core with a 10-mm long piezoceramic actuator that is 
positioned between z = 55 mm and z = 65 mm (Figure 13-5). The cantilever beam is 
orientated along the x-axis.

Figure 13-5: In this geometry for the shear bender note that a piezoceramic material 
replaces part of the foam core.

B O U N D A R Y  C O N D I T I O N S

• The structural mechanics boundary conditions for this model are that the cantilever 
beam is fixed at its surfaces at x = 0 and that all other surfaces are free.

• The electrostatic boundary conditions for this model are that the system applies a 
20 V potential difference between the top and bottom surfaces of the piezoceramic 
subdomain. This gives rise to an electric field perpendicular to the poling direction 
(x-direction) and thus induces a transverse shear strain.

x
y

z
Aluminum

Foam
Piezoceramic

Aluminum

Foam
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M A T E R I A L  P R O P E R T I E S

The following table lists the material properties for the aluminum layers and the foam 
core:

The matrices later in the section contain the material properties for the piezoceramic 
(PZT-5H): cE is the elasticity matrix, e is the piezoelectric coupling matrix, and ε is the 
absolute permittivity matrix.

Note that it is necessary to recalculate the absolute permittivity matrix using the 
permittivity of vacuum ε0 to the relative permittivity matrix.

Note also that the order of the material properties is such that the polarization 
direction is in the z direction. The polarization direction of the piezoceramic material 
in this model is however aligned with the x-axis and thus a local coordinate system 
must be used in the material settings to rotate the piezoceramic material.

PROPERTY ALUMINUM FOAM

E 70 GPa 35.3 MPa

ν 0.345 0.383

ρ 2690 kg/m3 32 kg/m3

cE

126 79.5 84.1 0 0 0
126 84.1 0 0 0

117 0 0 0
23.0 0 0

sym 23.0 0
23.3

 GPa=

e
0 0 0 0 17 0
0 0 0 17 0 0
6.5– 6.5– 23.3 0 0 0

  C/m2
=

ε
1.503 0 0

0 1.503 0
0 0 1.3

10 8–   F/m⋅=
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Results

The shear deformation of the piezoceramic core layer and the flexible foam layer 
induce the bending action. Figure 13-6 shows the resulting tip deflection. The model 
calculates this deflection as 83 nm, which is in good agreement with the work in 
Ref. 1 and Ref. 2.

Figure 13-6: Tip deflection with the piezoceramic positioned at z = 60 mm.

Modeling in COMSOL Multiphysics

C O N S T I T U T I V E  E Q U A T I O N  A N D  M A T E R I A L  D A T A

You specify the material parameters for the piezoelectric material in the Subdomain 

Settings dialog box in the corresponding piezoelectric application mode. You select the 
stress-charge form for the constitutive equation because it suits the form in which you 
give the material data. Enter data for the elasticity matrix into the ce matrix; enter data 
for the piezoelectric coupling matrix into the e matrix; and enter the relative 
permittivities into the εrs matrix.
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You must also define a local coordinate system that is rotated 90 degrees about the y-
axis. Then use this coordinate system n the piezoelectric material settings in order to 
rotate the material so that the poling direction is aligned with the x-axis.

M E S H I N G

The thin central core that holds the piezoelectric actuator and the foam normally 
creates a relatively dense isotropic mesh. You can avoid this situation by scaling the 
mesh in the z direction with a factor of three. Doing so reduces the degrees of freedom 
from approximately 85,000 to 23,000 (by a factor of approximately 3.7) and hence it 
reduces both the solution time and memory requirements.

References

1. V. Piefort, Finite Element Modelling of Piezoelectric Active Structures, Ph.D. 
thesis, Université Libre de Bruxelles, Belgium, Dept. Mechanical Engineering and 
Robotics, 2001.

2. A. Benjeddou and others, A Unified Beam Finite Element Model for Extension 
and Shear Piezoelectric Actuation Mechanisms, CNAM (Paris, France), Structural 
Mechanics and Coupled Systems Laboratory, 1997.

Model Library path: Structural_Mechanics_Module/
Piezoelectric_Effects/shear_bender

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics. This invokes the Model Navigator, which you can also 
open from an already running COMSOL Multiphysics session by choosing New 
from the File menu.

2 On the New page select 3D from the Space dimension list.

3 Click the Multiphysics button, then select Structural Mechanics Module>Piezoelectric 

Effects>Piezo Solid>Static analysis from the list of application modes.

4 Click OK to close the Model Navigator.

Note that this gives you second-order elements, Lagrange - Quadratic, by default.
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G E O M E T R Y  M O D E L I N G

Define the model geometry in draw mode:

1 Draw a block by first clicking the Block button on the Draw toolbar and then 
entering the following parameters in the Block dialog box:

2 Draw a second block by clicking the Block button and entering the following 
parameters:

3 Draw a third block by clicking the Block button and entering the following 
parameters:

4 Click the Zoom Extents button on the Main toolbar.

LENGTH EXPRESSION

X 0.1

Y 0.03

Z 0.018 

LENGTH EXPRESSION

X 0.1

Y 0.03

Z 0.002

AXIS BASE POINT EXPRESSION

x 0

y 0

z 0.008

LENGTH EXPRESSION

X 0.01

Y 0.03

Z 0.002

AXIS BASE POINT EXPRESSION

x 0.055

y 0

z 0.008
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The basic geometry of the shear-actuated beam consisting of three blocks.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu choose Coordinate Systems.

2 In the Coordinate System Settings dialog box click the New button, then click OK in 
the New Coordinate System dialog box to use the default coordinate name.

3 Click the General tab. Click the Define using global coordinates option button, then 
click the Rotation angle method option button.
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4 In the x, y, z rotation angles edit fields type 0, 90, and 0, respectively, then click OK 
to close the dialog box.

Configuring the coordinate system.

The material properties for the foam and the aluminum are specified in the Materials/

Coefficients Library dialog box:

1 From the Options menu choose Materials/Coefficients Library.

2 Click the New button.

3 Change the Name to Aluminum and specify the following set of material parameters:

PARAMETER EXPRESSION/VALUE DESCRIPTION

E 70e9 Young’s modulus 

nu 0.345 Poisson’s ratio

rho 2690 Density
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4 Click Apply.

Material property values for aluminum.

5 Click the New button.
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6 Change the Name to Foam and specify the following set of material parameters:

Material property values for foam.

7 Click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 Open the Subdomain Settings dialog box by choosing Subdomain Settings from the 

Physics menu. Go to the Structural page.

2 Select Subdomains 1 and 3 from the Subdomain selection list.

3 Select Decoupled, isotropic from the Material model list.

4 Select Aluminum from the Library material list; then click Apply.

5 Select Subdomains 2 and 5 from the Subdomain selection list.

PARAMETER EXPRESSION/VALUE DESCRIPTION

E 35.3e6 Young’s modulus

nu 0.383 Poisson’s ratio

rho 32 Density
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6 Select Decoupled, isotropic from the Material model list.

7 Select Foam from the Library material list; then click Apply.

8 Select Subdomain 4.

9 Select Coordinate system 1 from the Coordinate system list.

10 Click the Edit button associated with cE and enter the following values into the 
Elasticity matrix dialog box; when complete, click OK. 

Entries for the elasticity matrix.

11 Click the Edit button associated with e and enter the following values into the 
Coupling matrix, stress-charge form dialog box; when complete, click OK. 

Entries for the coupling matrix.

126e9 79.5e9 84.1e9 0 0 0

126e9 84.1e9 0 0 0

117e9 0 0 0

23e9 0 0

23e9 0

23e9

0 0 0 0 17 0

0 0 0 17 0 0

-6.5 -6.5 23.3 0 0 0
R  1 3 :  P I E Z O E L E C T R I C I T Y  M O D E L S



12 Click the Edit button associated with εrs and enter the following values into the 
Relative permittivity matrix, stress-charge form dialog box; when complete, click OK. 

Entries for the relative permittivity matrix.

13 Click OK.

Boundary Conditions
1 Open the Boundary Settings dialog box by selecting Boundary Settings from the 

Physics menu.

2 Activate the Interior boundaries check box.

3 Fix the beam by selecting the following boundary condition on the Constraint page:.

4 Select Boundaries 14–19 from the Boundary selection list.

5 Go to the Electric BC page and select Zero charge/Symmetry from the Boundary 

condition list on the Electric BC page.

6 Select Boundary 16 and Electric potential from the Boundary condition list and enter 
20 in the Electric potential edit field.

7 Select Boundary 17 and Ground from the Boundary condition list.

8 Click OK to close the dialog box.

M E S H  G E N E R AT I O N

1 From the Mesh menu choose Free Mesh Parameters.

2 Click the Advanced tab.

3 Type 3 in the z-direction scale factor edit field.

4 Click Remesh, then click OK.

1698 0 0

1698

1468

SETTING BOUNDARIES 1, 4, 7

Constraint condition Fixed
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P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Before computing the solution change the default plot to display a boundary plot 
using the deformed shape:

1 From the Postprocessing menu choose Plot Parameters.

2 On the General page clear the Slice check box, then select the Boundary check box 
and the Deformed shape check box.

3 Click the Boundary tab and select Piezo Solid (smpz3d)>z-displacement from the 
Predefined quantities list.

4 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

To start computing the solution, click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N ,  C O N T I N U E D

Figure 13-6 on page 543 shows the resulting plot.
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Compo s i t e  P i e z o e l e c t r i c  T r a n s du c e r

Introduction

This example shows how to set up a piezoelectric transducer problem following the 
work of Y. Kagawa and T. Yamabuchi (Ref. 1). The composite piezoelectric ultrasonic 
transducer has a cylindrical geometry that consists of a piezoceramic (NEPEC 6) layer, 
two aluminum layers, and two adhesive layers. The layers are organized as follows: 
aluminum layer—adhesive layer—piezoceramic layer—adhesive layer—aluminum 
layer.

The system applies an AC potential on the electrode surfaces of both sides of the 
piezoceramic layer. The potential in this example has a peak value of 1V in the 
frequency range 20 kHz to 106 kHz. The goal is to compute the susceptance (the 
imaginary part of the admittance) Y = I/V, where I is the total current and V is the 
potential, for a frequency range around the four lowest eigenfrequencies of the 
structure.

The first step finds the eigenmodes, and the second step runs a frequency sweep across 
an interval that encompasses the first four eigenfrequencies. Both analyses are fully 
coupled, and COMSOL Multiphysics assembles and solves both the electric and 
mechanical parts of the problem simultaneously.

The problem is axially symmetric, and you could analyze it using an axisymmetric 
application mode in 2D. However, in order to illustrate the modeling principles for 
more complicated problems, this example is in 3D.

When creating the model geometry, you make use of the symmetry by first making a 
cut along a midplane perpendicular to the central axis and then cutting out a 10 degree 
wedge. Doing so reduces memory requirements significantly.
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Results

Figure 13-7 shows the input admittance in the transducer as a function of the 
excitation frequency.

Figure 13-7: Input admittance as a function of excitation frequency

The result is in agreement with the work in Ref. 1. A small discrepancy close to the 
eigenfrequencies appears because the simulation uses no damping.

Reference

1. Y. Kagawa and T. Yamabuchi, “Finite Element Simulation of a Composite 
Piezoelectric Ultrasonic Transducer,” IEEE Transactions on Sonics and Ultrasonics, 
vol. SU-26, no. 2, pp. 81–88, 1979.

Model Library path: Structural_Mechanics_Module/
Piezoelectric_Effects/composite_transducer
R  1 3 :  P I E Z O E L E C T R I C I T Y  M O D E L S



Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator and click the New tab. From the Space dimension list select 
3D.

2 In the list of application modes select Structural Mechanics Module>Piezoelectric 

Effects>Piezo Solid>Eigenfrequency analysis.

3 Click OK.

G E O M E T R Y  M O D E L I N G

1 From the Draw menu choose Work Plane Settings.

2 This model uses the default work plane at z = 0, so simply click OK. Doing so creates 
the work plane and opens a 2D drawing area.

3 Click the Ellipse/Circle (Centered) button on the Draw toolbar. Use the right mouse 
button to create a circle centered on the origin and with a radius of approximately 
1 (the exact size is not important).

4 Double-click the circle. In the Radius edit field enter 27.5e-3. Click OK.

5 Click the Zoom Extents button on the Main toolbar.

6 Click the Line button on the Draw toolbar. Draw a line from (0, 0) to (0.03, 0). Use 
the right mouse button to finish drawing lines.

7 Copy and paste the line onto itself with no displacements (either use Ctrl+C and 
Ctrl+V or use the Edit menu items).

8 Select the Rotate toolbar button from the Draw toolbar. In the Rotation angle edit 
field enter 10. Click OK.

9 Select all objects (press Ctrl+A).

10 Click the Coerce to Solid button on the Draw toolbar.

11 Click the Split Object button on the Draw toolbar. 

12 Select the larger object and press the Delete key.
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13 Click the Zoom Extents button on the Main toolbar.

Geometry for the composite piezoelectric transducer.

M E S H  G E N E R AT I O N

This model uses prism elements by extruding a triangular mesh.

1 Click the Initialize Mesh button on the Main toolbar.

2 From the Mesh menu select Extrude Mesh.

3 In the Distance edit field enter 5e-3 5.275e-3 15.275e-3 (being careful to 
separate the entries with a space). Click OK. This step extrudes a mesh with three 
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domains corresponding to the piezoceramic (Subdomain 1), the adhesive layer 
(Subdomain 2), and the aluminum layer (Subdomain 3).

Extruding the mesh to create three subdomains.

The finalized mesh with the three subdomains. 
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O P T I O N S  A N D  S E T T I N G S

1 From the Options menu select Materials/Coefficients Library.

2 Click New.

3 Change the Name to Adhesive.

4 Enter these material properties; when done, click Apply.

5 Click the New button.

6 Change the name to Aluminum2.

7 Enter these material properties; when done, click OK. 

PARAMETER EXPRESSION/VALUE DESCRIPTION

E 1e10 Young’s modulus

nu 0.38 Poisson’s ratio

rho 1700 Density

PARAMETER EXPRESSION/VALUE DESCRIPTION

E 7.03e10 Young’s modulus

nu 0.345 Poisson’s ratio

rho 2690 Density
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Material values to enter for the aluminum.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Multiphysics menu select 1 Geom1: Piezo Solid (smpz3d).

2 From the Physics menu select Subdomain Settings and go to the Structural page.

3 From the Subdomain selection list choose 1. 

4 See that the Material Model list has value Piezoelectric, then in the Density edit field 
enter 7730.
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5 Click the Edit button associated with cE and enter the following values into the 
Elasticity matrix dialog box; when finished, click OK: 

Entries for the elasticity matrix.

6 Click the Edit button associated with e and enter the following values into the 
Coupling matrix, stress-charge form dialog box; when finished, click OK:  

Entries for the coupling matrix.

7 Click the Edit button associated with εrS and enter the following values into the 
Relative permittivity, stress-charge form dialog box; when finished, click OK:   

Entries for the relative permittivity matrix.

8 In the Subdomain selection list choose Subdomains 2 and 3.

9 From the Material Model list select Decoupled, isotropic.

10 In the Subdomain selection list choose 2.

12.8e10 6.8e10 6.6e10 0 0 0

12.8e10 6.6e10 0 0 0

11.0e10 0 0 0

2.1e10 0 0

2.1e10 0

2.1e10

0 0 0 0 0 0

0 0 0 0 0 0

-6.1 -6.1 15.7 0 0 0

993.53 0 0

993.53 0

993.53
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11 Select Adhesive from the Library material list.

12 In the Subdomain selection list choose 3.

13 Select Aluminium2 from the Library material list.

14 Click OK.

Boundary Conditions
The total potential difference between the two electrodes (only one modeled here) is 
1 V, but symmetry dictates that the potential is 0 V on the symmetry plane and 0.5 V 
on the electrode.

1 From the Physics menu choose Boundary Settings.

2 Activate the Interior boundaries check box.

3 In the Boundary selection list select all the boundaries (press Ctrl+A).

4 Go to the Electric BC page, find the Boundary condition list and select Zero charge/

Symmetry.

5 From the Boundary selection list choose Boundary 6.

6 In the Boundary condition list select Electric potential, and in the V0 edit field type 
0.5.

7 Select Boundary 3.

8 Change the boundary condition on the Electric BC page to Ground.

9 From the Boundary selection list choose Boundaries 1, 2, 3, 4, 5, 7, and 8.

10 Go to the Constraint page, and in the Constraint condition list select Symmetry plane.

The outer boundary is free to move, so you do not set any constraints.

11 Click OK.

C O M P U T I N G  T H E  E I G E N F R E Q U E N C Y  S O L U T I O N

Click the Solve button on the Main toolbar. 

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N  O F  T H E  E I G E N F R E Q U E N C I E S

The lowest eigenfrequency is at approximately 43 kHz.

1 To visualize the solution of the lowest eigenfrequency, open the Plot Parameters 

dialog box from the Postprocessing menu.

2 On the General page, clear the Slice check box.

3 On the Boundary page, select the Boundary plot check box and select Piezo Solid 

(smpz3d)>z-displacement (smpz3d) in the Predefined quantities list.
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4 On the Deform page, select the Deformed shape plot check box and see Piezo Solid 

(smpz3d)>Displacement in selected the Predefined quantities list.

5 Click OK to generate the visualization where you can see that the lowest 
eigenfrequency is at approximately 43 kHz.

 

Visualization of the lowest eigenfrequency for the piezoelectric transducer.

C O M P U T I N G  T H E  F R E Q U E N C Y  R E S P O N S E  S O L U T I O N

Next sweep over a frequency range from 20 kHz to 106 kHz in steps of 2 kHz.

1 From the Physics menu select Properties.

2 In the Analysis type list select Frequency response. Click OK.

3 From the Solve menu select Solver Parameters.

4 On the General page see that the Parameter name edit field shows freq_smpz3d.

5 In the Parameter values edit field enter 20e3:2e3:106e3.

6 Click OK.

7 Click the Solve button on the Main toolbar.
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P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N  O F  T H E  F R E Q U E N C Y  R E S P O N S E

To compute the input admittance, use the current-density outflow variable, nJ, on the 
electrode surface. The total input current for the 10-degree wedge is then the surface 
integral of −imag(nJ) over one of the electrode surfaces. To obtain the total current 
for the entire structure, multiply the result by 360/10 = 36.

1 From the Options menu select Integration Coupling Variables>Boundary Variables.

2 In the Boundary selection list choose Boundary 6 (corresponding to the electrode 
surface).

3 In the top row enter I as the name of the integration variable, then in the Expression 
column enter -imag(nJ_smpz3d)*36. Click OK.

4 From the Solve menu select Update Model.

The coupling variable I has global scope, and you can access it anywhere in the 
geometry model (the mesh). Use a domain plot to plot the value of Y versus frequency.

1 From the Postprocessing menu select Domain Plot Parameters.

2 Go to the Point page.

3 In the Point selection area choose a point on the electrode surface (for this exercise, 
select 2).
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4 In the Expression edit field enter I/(2*V). Click OK to close the dialog box and plot 
the susceptance.

Plot of susceptance versus frequency for the piezoelectric transducer.

Recall that this example uses 0.5 V for the electrode potential but the overall potential 
difference is 1 V. Thus, to take symmetry into account, you must multiply the potential 
by 2.
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P i e z o r e s i s t i v e  E l e v a t o r  Bu t t o n

Introduction

This is a simplified model of a design of a piezoresistive in-wall elevator button 
described in a patent application submitted by C.J. Slabinski and R.B. Leach (Ref. 5). 
The elevator button is designed with the following requirements in mind:

• durability with respect to high temperatures

• capability of producing signals that can be easily used in digital signal processing

• reliability, even when subjected to high loads

With respect to each of these requested characteristics, piezoresistive devices are 
superior to piezoelectrical ones. To make the device resistant against fire and heat, the 
button assembly includes parts of materials that are unresponsive to heat, such as clay 
or brick.

Piezoresistive materials change their resisitivity when subjected to mechanical stresses. 
This model concentrates on piezoresistivity in silicon-type materials, which is the most 
important group for practical applications. Although the effect is also observed in 
metals with crystal structures different from silicon, the piezoresistive effect is more 
than an order of magnitude higher in silicon than in metals (Ref. 1).

Note: This Model requires the Structural Mechanics module and the AC/DC 
Module.
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Model Definition

Figure 13-8 shows the simplified elevator-button design that you use in this model.

Figure 13-8: Schematic elevator button design.

The button is embedded in an enclosure formed by the elevator control panel. Its 
operation is modeled by a force, Fz, which acts on the button’s upper boundary. The 
upper part of the button, composed of a conical and a cylindrical part, is made of 
aluminum. The conical shape ensures that the inner button parts are protected if the 
button is subjected to high impacts.

Furthermore, as mentioned in the introduction, it is vital that the button functions 
perfectly even at high ambient temperatures, such as in the event of fire. To shield the 
piezoresitive silicon layer, an adhesive, made of clay or brick, is attached to the resisitive 
layer’s upper and lower sides.

To implement the button in COMSOL Multiphysics, you need two application modes:

• Solid, Stress-Strain, active in the whole geometry of the device

• Electric Currents, which is only active in the sensing resistor domain

To measure the change in the resistivity, a fixed voltage of 1 V is applied across the 
silicon layer. The integral of the current density over one of the resistor’s contacts gives 
the ohmic resistance via Ohm’s law, U = RI.

P I E Z O R E S I S T I V I T Y  F O R  A N  A N I S O T R O P I C  C R Y S T A L

Below follows a short outline of the piezoresistive relations (Ref. 1). For a 3-
dimensional anisotropic crystal, the electric field is related to the current-density field 

Enclosure

aluminum

piezo

brick/clay

Fz

Fixed

+−
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by a 3-by-3 resistivity tensor. In piezo crystals, the nine components always reduce to 
six values arranged in a symmetric tensor:

 (13-1)

For the cubic silicon lattice—with axes aligned with the <100> axes—ρ1, ρ2, and ρ3 
define the dependence of the electric field on the current along the same orthogonal 
directions; the other components are the cross terms.

The six resistivity components depend on the normal and shear stresses in the material 
(Ref. 2). Under stress-free conditions and with Cartesian coordinates aligned with the 
material <100> axes, the normal resistivity components are equal, and the cross terms 
are zero. Thus, under these conditions, the resistivity tensor is isotropic:

 (13-2)

The relative changes in the resistivity can be written as a product of the structural 
stresses, σ, and the piezoresistive stress coefficients, Π . In Voigt notation, this reads:

 (13-3)

The following table lists the correspondences between the element indices or positions 
in Equation 13-3 and the tensor components along the spatial coordinate axes:

  Π MATRIX RESISTIVITY SHEAR STRESS   Π MATRIX

RC  xy  i  xy  i  xy RC

12 xy   ρ6   ρxy  τ3   τxy 66

13 xz   ρ5   ρxz  τ2   τxz 55

23 yz   ρ4   ρyz  τ1   τyz 44

E1

E1

E1

ρ1 ρ6 ρ5

ρ6 ρ2 ρ4

ρ5 ρ4 ρ3

I1

I2

I3

=

ρ3-by-3 ρ0

1 0 0
0 1 0
0 0 1

=

1
ρ0
------

∆ρ1

∆ρ2

∆ρ3

∆ρ4

∆ρ5

∆ρ6

π11 π12 π12 0 0 0

π12 π11 π12 0 0 0

π12 π12 π11 0 0 0

0 0 0 π44 0 0

0 0 0 0 π44 0

0 0 0 0 0 π44

σ1

σ2

σ3

τ1

τ2

τ3

=
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Here, “R” and “C” stand for row and column position, respectively. 

When modeling electric currents in conductive media, conductivity is used instead of 
resistivity. The anisotropic conductivity matrix corresponding to the resistivity matrix 
results from a simple inversion of the resistivity matrix.

Coordinate Transformations
To get a nice representation of the material parameters, it is common in piezoelectricity 
and piezoresistivity to rotate the coordinate system by 45° around the z-axis, so that 
the coordinate system aligns with the <110> directions for the crystal axes. The 
drawback of this representation is that the Cartesian axes (for which the stresses are 
defined) are aligned along the material <100> axes, in contrast to the representation 
used in structural mechanics (standard global coordinate system). Therefore, a local 
coordinate system is introduced for computing the resisitivity coefficients.

When you create and use a local coordinate system in COMSOL Multiphysics, you get 
an orthogonal 3-by-3 transformation matrix T, whose components appear as 
coordn_Tij variables in the equations. This matrix represents a transformation from 
local to global coordinates. The transformation of stresses from global to local 
coordinates is

Use these stress components in the local representation to calculate the resistivity 
matrix, and then transform the resistivity matrix to global coordinates using the inverse 
transformation

Finally, invert this matrix and use the conductivity values in the conductive-media 
equation.

M A T E R I A L  P R O P E R T I E S

Table 13-1 lists the elastic properties for the materials used in the different button 
components. For aluminum and brick, you can use the basic material properties library 
included with COMSOL Multiphysics, whereas you enter the properties for the piezo 

σl TT
σx σxy σxz

σxy σy σyz

σxz σyz σz

T=

ρg T

ρ1 ρ6 ρ5

ρ6 ρ2 ρ4

ρ5 ρ4 ρ3

TT T

ρ11 ρ12 ρ13

ρ21 ρ22 ρ23

ρ31 ρ32 ρ33

TT
= =
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element manually. The thermal expansion coefficients, α, are included in the table to 
simplify generalizing the model to take heat effects into account.

B O U N D A R Y  C O N D I T I O N S

Solid, Stress-Strain—Constraints
Apply roller constraints to the boundaries highlighted in the figure below. Consider all 
other boundaries to be unconstrained.

Boundaries for which roller constraints apply.

Solid, Stress-Strain—Loads
On the top button surface, apply a homogeneous downward pressure of 1 kPa, 
corresponding to a total force of roughly 2.8 N.

Electric Currents
Apply a voltage of 1 V between the electrodes. All other boundaries are electrically 
insulating.

TABLE 13-1:  ELASTIC MATERIAL PROPERTIES

PROPERTY ALUMINUM BRICK PIEZO ELEMENT DESCRIPTION

 E (GPa) 70 17 169 Young’s modulus

 ν 0.33 0.3 0.278 Poisson’s ratio

 ρ (kg/m3) 2700 2000 7850 Density

 α (1/K) 23·10-6 6·10-6 12·10-6 Thermal expansion coefficient
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Results

Figure 13-9 displays the displacement of the boundary when full pressure is applied to 
the top button surface. The very small displacement values show that the button does 
not need to move for a signal to be generated.

Figure 13-9: Total displacement of the button’s boundary surfaces when a uniform 
downward pressure is applied on the top surface. The values of the displacement are so small 
that button movement is imperceptible.
R  1 3 :  P I E Z O E L E C T R I C I T Y  M O D E L S



Figure 13-10 shows the applied force and the current response as functions of time.

Figure 13-10: Applied force (left) and current response (right) as functions of time.

Because of the very small amplitude of the current signal, it is useful to plot I − I0, 
where I0 denotes the current in the absence of a load. Figure 13-11 shows this quantity 
as a function of time.

Figure 13-11: Differential current response.

From Figure 13-11 and the plot in the right panel of Figure 13-10 you can read off a 
signal-to-bias ratio of less than 10−6. To allow the signal to be detected, the noise level 
needs to be even smaller than this. Thus, the simplified model of this example merely 
illustrates a possible application of piezoresistivity. The design must be refined and 
accompanied by the appropriate electronic circuitry to be technically viable.
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Model Library path: Structural_Mechanics_Module/
Piezoelectric_Effects/elevator_button

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 From the Space dimension list, select 3D.

2 Select the application mode Structural Mechanics Module>Solid, Stress-Strain>Quasi-

static analysis.

3 Click Multiphysics, then click Add.

4 Select the AC/DC Module>Quasi-Statics, Electric>Electric Currents>Transient analysis 
application mode

5 Click Add, then click OK.

O P T I O N S  A N D  S E T T I N G S

Constants
1 From the Options menu, choose Constants.

2 On separate rows in the dialog-box table, enter the resistivity and piezoresistive 
stress tensor components listed in the following table. Alternatively, click the Import 

Variables From File button, browse to the folder Structural_Mechanics_Module/
Piezoelectrical_Effects in the Model Library root directory, select the file 
elevator_button_const.txt, and click Open.

NAME EXPRESSION DESCRIPTION

rho0 180e-6[ohm*m] Resistivity of the unstressed material

p11 6.6e-11[1/Pa] Piezoresistive stress coefficient component

p12 -1.1e-11[1/Pa] Piezoresistive stress coefficient component
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Coordinate Systems
Because the piezoresistive coefficients are given in local coordinates, you must 
transform them to the standard global coordinate system used in the Solid, Stress-
Strain application mode. Define the local coordinate system as follows:

1 From the Options menu, choose Coordinate Systems.

2 Click the New button. In the Name edit field, type Silicon orientation, then 
click OK.

3 Back in the Coordinate System Settings dialog box, enter the following settings on 
the General page:

4 Click OK.

p44 138.1e-11[1/Pa] Piezoresistive stress coefficient component

P11, P22, P33 p11 Piezoresistive stress coefficient matrix component

P12, P13, P21, 
P23, P31, P32

p12 Piezoresistive stress coefficient matrix component

P44, P55, P66 p44 Piezoresistive stress coefficient matrix component

SETTINGS X Y Z

x-axis direction vector 1 1 0

xy-plane direction vector 0 0 1

NAME EXPRESSION DESCRIPTION
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Scalar Expressions
Next, add the stress-dependent resistivity and conductivity components in local and 
global coordinates defined in Table 13-2 through Table 13-5. You can either enter 
them manually in the Scalar Expressions dialog box or, more conveniently, load them 
directly from a data file included with the Structural Mechanics Module.

1 From the Options menu, choose Expressions>Scalar Expressions.

2 Enter the stress, resistivity, and conductivity components listed in the following 
tables or (preferably) click the Import Variables From File button, browse to the 
folder Structural_Mechanics_Module/Piezoelectrical_Effects in the 
Model Library root directory, select the file elevator_button_expr.txt, and 
click Open.

3 Click OK to close the Scalar Expressions dialog box.

TABLE 13-2:  MATERIAL STRESS IN LOCAL COORDINATES

NAME EXPRESSION

sxl sxl_smsld

syl syl_smsld

szl szl_smsld

sxzl sxzl_smsld

syzl syzl_smsld

sxyl sxyl_smsld

TABLE 13-3:  RELATIVE RESISTIVITY (RHO/RHO0) IN LOCAL COORDINATES

NAME EXPRESSION

rhol11 1+P11*sxl+P12*syl+P13*szl

rhol22 1+P21*sxl+P22*syl+P23*szl

rhol33 1+P31*sxl+P32*syl+P33*szl

rhol23 P44*syzl

rhol13 P55*sxzl

rhol12 P66*sxyl
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TABLE 13-4:  RELATIVE RESISTIVITY IN GLOBAL COORDINATES

NAME EXPRESSION

rho11 coord1_T11*(rhol11*coord1_T11+rhol12*coord1_T12+ 
rhol13*coord1_T13)+coord1_T12*(rhol12*coord1_T11+ 
rhol22*coord1_T12+rhol23*coord1_T13)+coord1_T13* 
(rhol13*coord1_T11+rhol23*coord1_T12+rhol33*coord1_T13)

rho22 coord1_T21*(rhol11*coord1_T21+rhol12*coord1_T22+ 
rhol13*coord1_T23)+coord1_T22*(rhol12*coord1_T21+ 
rhol22*coord1_T22+rhol23*coord1_T23)+coord1_T23* 
(rhol13*coord1_T21+rhol23*coord1_T22+rhol33*coord1_T23)

rho33 coord1_T31*(rhol11*coord1_T31+rhol12*coord1_T32+ 
rhol13*coord1_T33)+coord1_T32*(rhol12*coord1_T31+ 
rhol22*coord1_T32+rhol23*coord1_T33)+coord1_T33* 
(rhol13*coord1_T31+rhol23*coord1_T32+rhol33*coord1_T33)

rho12 coord1_T11*(rhol11*coord1_T21+rhol12*coord1_T22+ 
rhol13*coord1_T23)+coord1_T12*(rhol12*coord1_T21+ 
rhol22*coord1_T22+rhol23*coord1_T23)+coord1_T13* 
(rhol13*coord1_T21+rhol23*coord1_T22+rhol33*coord1_T23)

rho23 coord1_T21*(rhol11*coord1_T31+rhol12*coord1_T32+ 
rhol13*coord1_T33)+coord1_T22*(rhol12*coord1_T31+ 
rhol22*coord1_T32+rhol23*coord1_T33)+coord1_T23* 
(rhol13*coord1_T31+rhol23*coord1_T32+rhol33*coord1_T33)

rho13 coord1_T11*(rhol11*coord1_T31+rhol12*coord1_T32+ 
rhol13*coord1_T33)+coord1_T12*(rhol12*coord1_T31+ 
rhol22*coord1_T32+rhol23*coord1_T33)+coord1_T13* 
(rhol13*coord1_T31+rhol23*coord1_T32+rhol33*coord1_T33)

TABLE 13-5:  CONDUCTIVITY

NAME EXPRESSION

det_rho rho11*rho22*rho33+2*rho12*rho23*rho13-rho13^2*rho22- 
rho12^2*rho33-rho11*rho23^2

sigma11 (rho22*rho33-rho23^2)/(rho0*det_rho)

sigma22 (rho11*rho33-rho13^2)/(rho0*det_rho)

sigma33 (rho11*rho22-rho12^2)/(rho0*det_rho)

sigma12 (rho13*rho23-rho12*rho33)/(rho0*det_rho)

sigma13 (rho12*rho23-rho13*rho22)/(rho0*det_rho)

sigma23 (rho12*rho13-rho11*rho23)/(rho0*det_rho)
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G E O M E T R Y  M O D E L I N G

1 Click the Cylinder button on the Draw toolbar. Create a cylinder with Radius 0.02, 
Height 0.002, and the Axis base point at (0, 0, 0). Click OK to close the dialog box.

2 Click the Zoom Extents button on the Main toolbar.

3 Repeat this procedure for three more cylinders with the following values:

4 Click the Cone button on the Draw toolbar and specify the following parameters:

5 Click the Block button on the Draw toolbar. In the Base area, click Center. Set the 
Axis base point to (0.02, 0, 0.0035) and the Length to (0.004, 0.04, 0.003). Click 
OK to close the dialog box and create the block BLK1.

NAME RADIUS HEIGHT AXIS BASE POINT

CYL2 2e-2 3e-3 (0,0,2e-3)

CYL3 2e-2 2e-3 (0,0,5e-3)

CYL4 12e-3 15e-3 (0,0,7e-3)

PARAMETER VALUE

Axis base point (0,0,3.2e-2)

Radius 3e-2

Height 1e-2

Semi-angle 45

Axis direction vector (0,0,-1)
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6 Select BLK1 and create a second block, BLK2, by pressing first Ctrl+C and then 
Ctrl+V. In the Paste dialog box, to specify the Displacements (-0.04, 0, 0). Click OK.

The geometry in the drawing area should now look like that in the following figure.

7 From the Draw menu, choose Create Composite Object. In the Set formula edit field, 
enter the expression CYL1+CYL2+CYL3+CYL4+CON1-BLK1-BLK2. Click OK.

The geometry is now complete and should look like that in the figure below.

P H Y S I C S  S E T T I N G S

Subdomain Settings—Solid, Stress-Strain
1 From the Multiphysics menu, select 1 Solid, Stress-Strain (smsld).

2 From the Physics menu, select Subdomain Settings.
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3 Select Subdomains 1 and 5, then click the Load button in the Material settings area.

4 From the Basic Material Properties library, select Aluminum, then click OK.

5 Select Subdomains 2 and 3, then click the Load button.

6 From the Basic Material Properties library, select Brick, then click OK.

7 Select Subdomain 4 and specify settings according to the following table:

8 Click OK.

Boundary Conditions—Solid, Stress-Strain
1 From the Physics menu, select Boundary Settings.

2 On the Constraint page, specify the following constraint condition:

The boundaries not listed above are free, which is the default constraint condition.

3 Go to the Load page and select Boundary 3.

4 In the Fz edit field, type -1[kPa]*flc1hs(t[1/s]-0.2,0.1).

5 Click OK.

Subdomain Settings—Electric Currents
1 From the Multiphysics menu, choose 2 Electric Currents (emqvw).

2 Select Subdomains 1–3 and 5. Clear the Active in this domain check box.

3 Select Subdomain 4. In the σ edit field type sigma11 sigma12 sigma22 sigma13 
sigma23 sigma33. The editable pop-up window displays the components’ 
positions in the anisotropic, symmetric electric conductivity tensor.

4 Click OK.

Boundary Conditions—Electric Currents
1 From the Physics menu, select Boundary Settings.

2 Select the Interior boundaries check box.

PROPERTY VALUE

 Coordinate system Silicon orientation

 E 169e9

 ν 0.278

 α 12e-6

 ρ 7850

SETTINGS BOUNDARIES 4–6, 8, 9, 13, 14, 17, 23–25, 28–30, 32

Constraint condition Roller
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3 Select all boundaries and set the boundary condition to Electric insulation.

4 Select Boundary 13. From the Boundary condition list, choose Electric potential. In 
the V0 edit field, type 1.

5 Select Boundary 32. From the Boundary condition list, choose Ground.

6 Click OK to close the Boundary Settings dialog box.

Integration Coupling Variables
To have a probe plot for the developing of the electric current and the applied load on 
the top surface, define two boundary integration variables.

1 From the Options menu, select Integration Coupling Variables>Boundary Variables.

2 Define the following integration variables by first selecting the boundary, and then 
entering the name and expression on the first available row in the dialog box table.

In the Integration order and Global destination columns, leave the default settings.

3 Click OK to close the dialog box.

M E S H  G E N E R A T I O N

Click the Initialize Mesh button on the Main toolbar to generate a default mesh. 

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

BOUNDARY NAME EXPRESSION

3 force Fzg_smsld

32 current nJ_emqvw
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2 On the General page, type 0:0.1:0.4 in the Times edit field. Also, verify that the 
Linear system solver is set to Direct (SPOOLES).

3 From the Postprocessing menu, choose Probe Plot Parameters.

4 In the Probe Plot Parameters dialog box, click the New button.

5 From the Plot type list, select global. In the Plot name edit field, type force.

6 Click OK.

7 In the Expression to plot area, the integration coupling variable force in the 
Expression edit field.

8 In the same fashion, define a probe plot with the label current for the integration 
coupling variable with the same name.

9 Click OK to close the Probe Plot Parameters dialog box.

10 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To reproduce the plot of the boundary displacement field displayed in Figure 13-9, 
follow these steps:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, clear the Slice check box and select the Boundary check box in 
the Plot type area.
R  1 3 :  P I E Z O E L E C T R I C I T Y  M O D E L S



3 Click the Boundary tab and verify that disp_smsld is selected from the Predefined 

quantities list. From the Unit list, select nm.

4 Click OK to close the dialog box and generate the plot.

5 Click the Scene Light button on the Camera toolbar.

Reproduce the plot in Figure 13-11 with these instructions:

1 From the Postprocessing menu, choose Global Variables Plot.

2 In the Expression edit field, type current-with(1,current).

3 Click the Add Entered Expression button.

4 Click the Axis/Title button.

5 Click the right option buttons for Title and Second axis label.

6 In the Second axis label edit field, type I-I<sub>0</sub> [A].

7 From the Plot in list, select New figure.

8 Click OK.
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S AW Ga s  S e n s o r

Introduction

A surface acoustic wave (SAW) is an acoustic wave propagating along the surface of a 
solid material. Its amplitude decays rapidly, often exponentially, with the depth of the 
material. SAWs are featured in many kinds of electronic components, including filters, 
oscillators, and sensors. SAW devices typically use electrodes on a piezoelectric material 
to convert an electric signal to a SAW, and back again.

In this model, you investigate the resonance frequencies of a SAW gas sensor. The 
sensor consists of an interdigitated transducer (IDT) etched onto a piezoelectric 
LiNbO3 (lithium niobate) substrate and covered with a thin polyisobutylene (PIB) 
film. The mass of the PIB film increases as PIB selectively adsorbs CH2Cl2 
(dichloromethane, DCM) in air. This causes a shift in resonance to a slightly lower 
frequency.

Model Definition

Figure 13-12 shows a conceptual view of the gas sensor in this model. IDTs used in 
SAW devices may have hundreds of identical electrodes, and each electrode can be 
about 100 times longer than it is wide. You can therefore neglect the edge effects and 
reduce the model geometry to the periodic unit cell shown in Figure 13-13. The 
height of this cell does not have to extend all the way to the bottom of the substrate 
but only a few wavelengths down, so that the SAW has almost died out at the lower 
boundary. In the model, this boundary is fixed to a zero displacement.
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Figure 13-12: Conceptual view of the SAW gas sensor, showing the IDT electrodes (in 
black), the thin PIB film (light gray), and the LiNbO3 substrate (dark gray). For the sake 
of clarity, the dimensions are not to scale and the IDT has fewer electrodes than in common 
devices. A slice of the geometry is removed to reveal the modeled unit cell (in white).
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Figure 13-13: The modeled geometry of the model. A 500 nm PIB film covers two 1 µm-
wide electrodes on top of the LiNbO3 substrate. The substrate subdomain continues below 
the lower frame of the picture and has a total height of 22 µm. In the first version of the 
model, the substrate is the only active subdomain.

You set up the model in the Piezo Plane Strain application mode, which requires the 
out-of-plane strain component to be zero. This should be a valid assumption, 
considering that the SAW is generated in the model plane and that the sensor is thick 
in the out-of-plane direction.

The first version of the model deals only with free SAW propagation in the LiNbO3 
substrate, without any applied electric field. In order to find the velocity of the wave, 
we use periodic boundary conditions to dictate that the voltage and the displacements 
be the same along both vertical boundaries of the geometry. This implies that the 
wavelength will be an integer fraction of the width of the geometry. The lowest SAW 
eigenmode has its wavelength equal to the width of the geometry, 4 µm. The 
eigenfrequency of this mode multiplied by 4 µm hence gives the velocity of the wave.

In a second version of the model, the aluminum IDT electrodes and the PIB film are 
added. This causes the lowest SAW mode to split up in two eigensolutions, the lowest 
one representing a series resonance, where propagating waves interfere constructively 
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and the other one a parallel (“anti-”) resonance, where they interfere destructively. 
These two frequencies constitute the edges of the stopband, within which no waves 
can propagate through the IDT.

The adsorption of DCM gas is represented as a slight increase of the density of the PIB 
film. In the third and final version of the model, the sensor is exposed to 100 ppm of 
DCM in air at atmospheric pressure and room temperature. The “partial density” of 
DCM in the PIB film is then calculated as

,

where K = 10l.4821 (Ref. 1) is the air/PIB partition coefficient for DCM, M is its 
molar mass, and

is its concentration in air.

The substrate used in the simulation is YZ-cut LiNbO3 with properties cited in Ref. 2. 
The density of the PIB film is from Ref. 1. The Poisson’s ratio is taken to be 0.48, 
which corresponds to a rather rubbery material. The Young’s modulus is set to 
10 GPa. Even at the comparatively high frequencies considered in this model, this is 
likely an overestimation. However, a much lower value would result in a multitude of 
eigenmodes located inside the film. While those may be important to consider in 
designing a SAW sensor, the focus in this model is on the SAW modes. Also, any effects 
of the DCM adsorption on other material properties than the density are neglected.

ρDCM PIB, KMc=

c 100 10 6– p RT( )⁄⋅ ⋅=
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Results

Figure 13-7 shows the SAW as it propagates along the surface of the piezoelectric 
substrate. The frequency corresponding to a 4 µm wavelength computes to 870 MHz, 
giving a phase velocity of 3479 m/s.

Figure 13-14: Deformed shape plot of a freely propagating SAW in the substrate. The color 
scale shows the magnitude of the displacements.

In the full model with the periodic IDT and the thin film included, the resonance and 
anti-resonance frequencies evaluate to 841 MHz and 850 MHz, respectively. 
Figure 13-15 and Figure 13-16 show the electric potential distribution characteristics 
for these solutions.
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Figure 13-15: Electric potential distribution and deformations at resonance, 841 MHz. 
The potential is symmetric with respect to the center of each electrode.

Exposing the sensor to a 100 ppm concentration of DCM in air leads to a resonance 
frequency shift of 227 Hz downwards. This is computed by evaluating the resonance 
frequency before and after increasing the density of adsorbed DCM to that of the PIB 
domain.

Note that the computational mesh is identical in both these solutions. This implies that 
the relative error of the frequency shift is similar to that of the resonance frequency 
itself. Thus the shift is accurately evaluated despite being a few magnitudes smaller than 
the absolute error of the resonance frequency. 

In a real setup, the drift is often measured by mixing the signal from a sensor exposed 
to a gas with a reference signal from one protected from the gas. The beat frequency 
then gives the shift.
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Figure 13-16: Electric potential distribution and deformations at antiresonance, 
851 MHz. The potential is antisymmetric with respect to the center of the electrodes.
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Model Library path: Structural_Mechanics_Module/
Piezoelectric_Effects/SAW_gas_sensor
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Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator and click the New tab.

2 From the Space dimension list select 2D.

3 In the list of application modes select Structural Mechanics Module>Piezoelectric 

Effects>Piezo Plane Strain>Eigenfrequency analysis.

4 Click OK.

G E O M E T R Y  M O D E L I N G

1 Create the following rectangles by repeatedly using Draw>Specify Objects>Rectangle:

2 Select all objects and choose Draw>Modify>Scale. In the dialog box that appears, 
enter 1e-6 for both scale factors; then click OK.

3 Click the Zoom Extents button on the Main toolbar to zoom in on the now micron-
sized geometry.

O P T I O N S  A N D  S E T T I N G S

1 Choose Options>Constants.

2 Define the following constant names, expressions, and (optionally) descriptions:

WIDTH HEIGHT BASES: CORNER X BASE: CORNER Y

4 22 0 -22

1 0.2 0.5 0

1 0.2 2.5 0

4 0.5 0 0

NAME EXPRESSION DESCRIPTION

p 101.325[kPa] Air pressure

T 25[degC] Air temperature

R 8.3145[Pa*m^3/(K*mol)] Gas constant

c_DCM_air 100e-6*p/(R*T) DCM concentration in air

M_DCM 84.93[g/mol] Molar mass of DCM

K 10^1.4821 PIB/air partition constant for 
DCM

rho_DCM_PIB K*M_DCM*c_DCM_air Mass concentration of DCM in 
PIB
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3 Click OK.

P H Y S I C S  S E T T I N G S

In the first version of the model, you compute the velocity for SAW propagation in a 
homogenous, electrically insulated LiNbO3 substrate. The supplied material data are 
with reference to the xy-plane.

Subdomain Settings
1 From the Physics menu, open the Subdomain Settings dialog box.

2 Select Subdomains 2–4 and clear the Active in this domain check box.

3 Select Subdomain 1 and select Material orientation: xy plane.

4 Click the Edit button associated with cE and enter the following values into the 
Elasticity matrix dialog box; when finished, click OK.

5 Click the Edit button associated with e and enter the following values into the 
Coupling matrix dialog box; when finished, click OK.

6 Click the Edit button associated with εrS and enter the following values into the 
Relative permittivity dialog box; when finished, click OK.

7 Enter 4647 in the Density edit field.

rho_PIB 0.918[g/cm^3] Density of PIB

E_PIB 10[GPa] Young’s modulus of PIB

nu_PIB 0.48 Poisson’s ratio of PIB

eps_PIB 2.2 Relative permittivity of PIB

NAME EXPRESSION DESCRIPTION

2.424e11 0.752e11 0.752e11 0 0 0
2.03e11 0.573e11 0 0.085e11 0

2.03e11 0 0.085e– 11 0
0.752e11 0 0.085e11

0.595e11 0
0.595e11

1.33 0.23 0.23 0 0 0
0 0 0 2.5– 0 3.7
0 2.5– 2.5 0 3.7 0

28.7 0 0
85.2 0

85.2
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8 Click OK to close the Subdomain Settings dialog box.

Boundary Conditions
1 From the Physics menu choose Boundary Settings.

2 Select Boundary 2 and set the Constraint condition to Fixed.

3 Select all exterior boundaries (1, 2, 4, 7, 10, 12, 15, 16).

4 On the Electric BC page, set the Boundary condition to Zero charge/Symmetry.

5 Click OK.

6 Choose Physics>Periodic Conditions>Periodic Boundary Conditions.

7 On the Source tab, select Boundary 1 and enter u in the first Expression edit field.

8 On the Destination page, check Boundary 16 and enter u in the Expression edit field.

9 On the Source Vertices page, select Vertex 1 and click the right double-arrow. Then 
select Vertex 2 and click the right double-arrow.

10 On the Destination Vertices page, select Vertex 12 and click the right double-arrow, 
then Vertex 13 and the right double-arrow.

11 Define the expressions v and V in a similar fashion, starting by entering them in the 
Expression edit field on the Source page, on rows 2 and 3 respectively.

12 Click OK to close the Periodic Boundary Conditions dialog box.

M E S H  G E N E R AT I O N

1 Choose Mesh>Free Mesh Parameters.

2 From the Predefined mesh sizes list, choose Extremely fine.

3 On the Subdomain page, select all subdomains and set the Method to Quad.

4 On the Boundary page, select the upper boundaries of the substrate (4, 7, 10, 12, 
15) and enter 0.05e-6 for the Maximum element size.

5 Click Remesh, then click OK. When done, a zoom-in on the upper part of the 
geometry should look like Figure 13-17.
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Figure 13-17: The meshed geometry.

C O M P U T I N G  T H E  S O L U T I O N

1 From the Solve menu, open the Solver Parameters dialog box.

2 Enter 850e6 in the Search for eigenfrequencies around edit field, then click OK.

3 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The solver returns 6 eigensolutions with eigenfrequencies in the vicinity of 850 MHz. 
At 869.8 MHz, two of them are—within the numerical accuracy—the same. These 
show the shape and the frequency for a SAW with wavelength equal to the width of 
the geometry.

1 Open the Plot Parameters dialog box from the Postprocessing menu.

2 On the General page, select one of the eigenfrequencies equal to 869.8 MHz.

3 On the Deform page, select the Deformed shape plot check box. Clear the Auto check 
box and enter 400 in the Scale factor edit field.
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4 Click OK to close the dialog box and see a plot of the total displacement. If you want 
to, you can repeat the procedure with the other solution to verify that they are the 
same, only shifted by 90 degrees. One of the solutions will look like Figure 13-7.

5 To evaluate the velocity, choose Postprocessing>Data Display>Global.

6 Enter eigfreq_smppn*4e-6[m] in the Expression edit field.

7 In the Eigenfrequency list, select one of the 869.8 MHz eigenfrequencies.

8 Click OK to see the value of the velocity in the message log. It evaluates to 
approximately 3479 m/s.

This concludes the first part of the model. Proceed to find out how the electrodes and 
the PIB film affect the behavior of the SAW.

Sensor without Gas Exposure

Subdomain Settings
1 Open the Subdomain Settings dialog box and select Subdomains 2–4.

2 Select the Active in this domain check box.

3 Select Material model: Decoupled, isotropic.

4 Select only Subdomain 2. 

5 On the Structural page, enter E_PIB for the Young’s modulus, nu_PIB for the 
Poisson’s ratio, and rho_PIB for the Density.

6 On the Electrical page, select the Enable electrical equation check box and enter 
eps_PIB for the relative permittivity.

7 Select Subdomains 3 and 4 and click the Load button.

8 In the Materials/Coefficients Library dialog box, select Basic Material 

Properties>Aluminum and click OK.

9 Click OK to close the Subdomain Settings dialog box.

Boundary Conditions
1 From the Physics menu, choose Boundary Settings.

2 Select the Interior boundaries check box.

3 Select Boundaries 6-9 and 11-14. On the Electric BC page, set the condition to 
Electric potential. Keep the default zero potential.

4 Select Boundaries 3, 5, and 17, and set the condition to Zero charge/symmetry.

5 Click OK to close the dialog box.
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Note: The eigenfrequencies and hence the stopband do not depend on the values of 
the potentials. In fact, for linear eigenfrequency problems, they are automatically set 
to zero at the electrodes, regardless of the applied value. You can solve the 
corresponding driven problem by switching to a frequency response analysis and 
applying different potentials to the electrodes.

6 Choose Physics>Periodic Conditions>Periodic Boundary Conditions.

7 On the Source page, select Boundary 3. Enter u in the first Expression edit field and 
v in the row below, and V in the third row.

8 On the Destination page, select Constraint name: pconstr1, check Boundary 17, and 
enter u in the Expression field.

9 Still on the Destination page, select Constraint name: pconstr2, check Boundary 17, 
and enter v in the Expression field.

10 Finally, select Constraint name: pconstr3, check Boundary 17, and enter V in the 
Expression field.

11 Click OK to close the dialog box. 

You have now established the periodicity in the PIB film.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

If you are still using the manual scaling of the deformations from the previous exercise, 
the plot that appears after solving will look rather distorted. Proceed as follows to find 
the SAW modes and use more suitable plot parameters:

1 Open the Plot Parameters dialog box from the Postprocessing menu.

2 On the General page, select the 850 MHz eigenfrequency.

3 On the Deform page, enter 40 in the Scale factor edit field.

4 Click Apply to view a plot of the total displacement at anti-resonance.

5 On the General page, select the 841 MHz eigenfrequency and click Apply to see the 
deformations at resonance. This plot should look like Figure 13-18.
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Figure 13-18: Deformations at resonance.

A plot of the electric potential shows a qualitative difference between the two 
solutions.

6 On the Surface page, select Piezo Plane Strain (smppn)>Electric potential from the 
Predefined quantities list.

7 Click Apply to see the potential distribution at resonance, as shown in Figure 13-15 
on page 587. Notice that it is symmetric with respect to each individual electrode.

8 On the General page, select the 850 MHz eigenfrequency and click OK to see the 
potential distribution at anti-resonance, as in Figure 13-16 on page 588. This time, 
it is antisymmetric.

Sensor with Gas Exposure

In the final version of this model, you will expose the sensor to DCM gas. The 
eigenfrequencies are expected to shift by a very small amount. In order to see the shift, 
you need to include more digits in the output.

1 Choose Postprocessing>Data Display>Global.
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2 Enter the expression eigfreq_smppn and select the 841 MHz eigenfrequency.

3 Select the Display result in full precision check box, then click OK.

The message log now shows all computed digits of the eigenfrequency.

Subdomain Settings
1 From the Physics menu, select Subdomain Settings.

2 Select Subdomain 2. On the Structural tab, change the Density so that it reads 
rho_PIB+rho_DCM_PIB.

3 Click OK to close the Subdomain Settings dialog box.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Choose Postprocessing>Data Display>Global.

2 Make sure that the expression still says eigfreq_smppn and select the 841 MHz 
eigenfrequency.

3 Click OK.

The first 6 digits of the eigenfrequency are the same as before. Subtracting the new 
value from the previous value (which is most easily done by copying and pasting the 
results from the message log) shows that the eigenfrequency with gas exposure is lower 
by 227 Hz.
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S t r e s s - O p t i c a l  E f f e c t s
This chapter contains models of stress-optical effects.
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S t r e s s -Op t i c a l  E f f e c t s  i n  a  S i l i c a - o n -
S i l i c o n  Wav egu i d e

Introduction

Planar photonic waveguides in silica (SiO2) have great potential for use in wavelength 
routing applications. The major problem with these kinds of waveguides is 
birefringence. Anisotropic refractive indices result in fundamental mode splitting and 
pulse broadening. The goal is to minimize birefringence effects by adapting materials 
and manufacturing processes. One source of birefringence is the use of a silicon (Si) 
wafer on which the waveguide structure is deposited. After annealing at high 
temperature (approximately 1000 °C), mismatch in thermal expansivity between the 
silica and silicon layers results in thermally induced stresses in the structure at the 
operating temperature (typically room temperature, 20 °C).

The Stress-Optical Effect and Plane Strain

The general linear stress-optical relation can be written, using tensor notation, as

where ∆nij = nij − n0 Iij, nij is the refractive index tensor, n0 is the refractive index for 
a stress-free material, Iij is the identity tensor, Bijkl is the stress-optical tensor, and σkl 
is the stress tensor. Due to symmetry the number of independent parameters in the 
stress-optical tensor that characterizes this constitutive relation can be reduced. 
Because nij and σkl are both symmetric, Bijkl = Bjikl and Bijkl = Bijlk. In many cases it 

Air

Cladding (Silica)

Buffer (Silica)

Silicon Wafer Core

Optical Computation Domain Boundary

∆nij B– ijklσkl=
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is possible to further reduce the number of independent parameters, and this model 
includes only two independent parameters, B1 and B2. The stress-optical relation 
simplifies to

where nx = n11, ny = n22, nz = n33, σx = σ11, σy = σ22, and σz = σ33.

This translates to

Using the two parameters B1 and B2, the model assumes that the nondiagonal parts 
of nij and σkl are negligible. This means that the shear stress corresponding to 
σ12 = τxy is neglected. In addition, the shear stresses corresponding to σ13 = τxz and 
σ23 = τyz are neglected by using the plane strain approximation. The plane strain 
approximation holds in a situation where the structure is free in the x and y direction 
but where the z strain is assumed to be zero. Note that this deformation state is not 
correct if the structure is free also in the z direction. In such a case a modified 
deformation state equation, which handles the the x and z directions equivalently, is 
needed.

The first part of this model utilizes the Plane Strain application mode of the Structural 
Mechanics Module. The resulting birefringent refractive index is computed using 
expression variables and can be considered a postprocessing step of the plane strain 
model. The refractive index tensor is used as material data for the second part of the 
model, the mode analysis.

The model “Stress-Optical Effects with Generalized Plane Strain” on page 615 
demonstrates a computation where the structure is free also in the z direction, using a 
formulation called generalized plane strain.

Perpendicular Hybrid-Mode Waves

For a given frequency ν, or equivalently, free-space wavelength λ0 = c0/ν, the RF 
Module’s Perpendicular Hybrid-Mode Waves application mode can be used for the 

∆nx

∆ny

∆nz

B2 B1 B1

B1 B2 B1

B1 B1 B2

σx

σy

σz

–=

nx n0 B2σx– B1 σy σz+( )–=

ny n0 B2σy– B1 σz σx+( )–=

nz n0 B2σz– B1 σx σy+( )–=
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mode analysis. In this model the free-space wavelength is 1.55 µm. The simulation is 
set up with the normalized magnetic field components H=(Hx, Hy, Hz) as dependent 
variables, and the effective mode index neff = β/k0 is obtained from the eigenvalues.

Using this application mode, the wave is assumed to have the form

The computations show a shift in effective mode index due to the stress-induced 
change in refractive index. The birefringence causes the otherwise two-fold degenerate 
fundamental mode to split.

Model Library path: Structural_Mechanics_Module/Stress-
Optical_Effects/stress_optical

Note: This model requires the RF Module and the Structural Mechanics Module.

Plane Strain Analysis

1 In the Model Navigator, select 2D.

2 Select the Structural Mechanics Module>Plane Strain>Static analysis application mode.

3 Click Multiphysics then Add to add this application mode to the model.

4 Next select the RF Module>Perpendicular Waves>Hybrid-Mode Waves>Mode analysis 
application mode. Click Add to add this application mode to the model; then click 
OK.

5 Choose Physics>Properties to open the Application Mode Properties dialog box and 
set Field components to In-plane components. This selects the two-components 
equation formulation for hybrid-mode waves. The default three-component 
equation formulation can also be used for this problem. See “Selecting Equation 
Formulation” on page 146 in the RF Module User’s Guide for general information 
about the different options.

6 For convenience set the property Specify wave using to Free space wavelength. This 
makes the wavelength available in the Application Scalar Variables dialog box instead 
of the frequency. Click OK to close the Application Mode Properties dialog box.

H H x y,( )ej ωt βz–( ) Hx x y,( ) Hy x y,( ) Hz x y,( ), ,( )ej ωt βz–( )
= =
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7 Choose Multiphysics>Model Navigator. Set the Ruling application mode to the 
Perpendicular Hybrid-Mode Waves application mode. This makes this mode specify 
the interpretation of the parameters to the eigenvalue solver given in the Solver 

Parameters dialog box. Click OK.

O P T I O N S  A N D  S E T T I N G S

1 Open the Constants dialog box from the Options menu and enter the following 
names,expressions, and descriptions (optional); when done, click OK.

Notice that the temperatures are given in degrees Celsius. This works well because this 
is a linear model. (Nonlinear models need to have temperatures in kelvin to get the 
correct thermodynamics.)

NAME EXPRESSION DESCRIPTION

nSi 3.5 Refractive index, silicon (Si)

nBuf 1.445 Refractive index, silica (SiO2)

nClad 1.445 Refractive index, silica

deltan 0.0075 Relative index difference: 

nCore nClad/sqrt(1-2*deltan) Refractive index, core

alphaSi 2.5e-6[1/K] Thermal expansion coefficient, silicon

alphaSiO2 0.35e-6[1/K] Thermal expansion coefficient, silica

ESi 110[GPa] Young’s modulus, silicon

ESiO2 78[GPa] Young’s modulus, silica 

nuSi 0.19 Poisson’s ratio, silicon

nuSiO2 0.42 Poisson’s ratio, silica

B1 4.2e-12[m^2/N] First stress optical coefficient

B2 0.65e-12[m^2/N] Second stress optical coefficient 

T1 20[degC] Operating temperature

T0 1000[degC] Reference temperature 

∆
ncore

2 ncladding
2

–( )

2ncore
2

---------------------------------------------=
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2 Give axis and grid settings according to the following table.

G E O M E T R Y  M O D E L I N G

Draw rectangles corresponding to the different regions.

AXIS GRID

x min -0.2e-3 x spacing 1e-5

x max 0.2e-3 Extra x

y min -0.1e-3 y spacing 1e-5

y max 0.03e-3 Extra y

REGION LOWER LEFT CORNER UPPER RIGHT CORNER

Silicon Wafer (-16e-5,-1e-4) (16e-5,-1.7e-5)

Buffer (-16e-5,-1.7e-5) (16e-5,-3e-6)

Cladding (-16e-5,-3e-6) (16e-5,1.3e-5)

Core (-3e-6,-3e-6) (3e-6,3e-6)
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P H Y S I C S  S E T T I N G S

Point Settings and Boundary Conditions
All regions have free boundaries, which also is the default boundary condition. 
However, these conditions will not suffice in creating a unique solution because the 
computational domain is allowed to move and rotate freely; the problem is ill-posed. 
The problem becomes well-posed by adding constraints at points to keep the domain 
fixed.

1 Select the Plane Strain application mode from the Multiphysics menu.

2 Open the Point Settings dialog box, and check the constraints Rx and Ry at Point 1, 
the lower left corner, for both the x and y direction. This will keep the domain from 
moving (translational move).

3 Check the constraint Ry at Point 9, the lower right corner, for the y direction only, 
keeping the domain from rotating but allowing it to slide in the x direction.

Subdomain Settings
The air domain need not be part of the plane strain model.

1 Specify the subdomain settings for the Plane Strain application mode according to 
the following table:

Before entering the temperatures on the Load page, you need to check Include 

thermal expansion. It is not necessary to specify the density ρ, because it does not 
enter the equation for static problems.

SUBDOMAIN 1 SUBDOMAINS 2–4

Page Material Load Material Load

E ESi E ESiO2

ν nuSi Temp T1 ν nuSiO2 Temp T1

α alphaSi Tempref T0 α alphaSiO2 Tempref T0
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E X P R E S S I O N  V A R I A B L E S

In the Subdomain Expressions dialog box in the Options menu, define the following 
variables; when done, click OK.

M E S H  G E N E R A T I O N

Initialize a mesh and refine it twice.

C O M P U T I N G  T H E  S O L U T I O N

1 In the Solver Parameters dialog box select the Stationary solver.

2 On the Solve for tab in the Solver Manager dialog box, select only the Plane Strain 
application mode. This will make sure that only the Plane Strain application mode 
equations are solved in the first run.

3 Click the Solve button.

VARIABLE NAME SUBDOMAIN EXPRESSION

N 1

2

3

4

nSi

nBuf

nClad

nCore

Nx 1

2,3,4

N

N-B1*sx_smpn-B2*(sy_smpn+sz_smpn)

Ny 1

2,3,4

N

N-B1*sy_smpn-B2*(sx_smpn+sz_smpn)

Nz 1

2,3,4

N

N-B1*sz_smpn-B2*(sx_smpn+sy_smpn)
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PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows the von Mises effective stress as a colored surface plot.

1 To view the von Mises stress along a horizontal line through the entire structure, 
use a cross-section plot. In the Cross-Section Plot Parameters dialog box, select von 
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Mises stress as y-axis data on the Line/Extrusion tab. As Cross-section line data set x0 
to -16e-5, y0 to 0, x1 to 16e-5, and y1 to 0. Use x as x-axis data.

Notice that the effective stress is varying slowly on the horizontal cut. This means 
that the significant influence on the stress induced changes in refractive index will 
come from the stress variations in the vertical direction. This is expected since the 
extension of the domains in the x direction is chosen to minimize effects of the 
edges.

Next plot the birefringence:

2 In the Plot Parameters dialog box, click the Surface tab.
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3 To view the stress-induced birefringence nx − ny, type Nx-Ny in the Expression field 
on the Surface Data page.

4 Now create a cross-section plot of the birefringence nx − ny on the vertical line from 
(0, −3·10−6) to (0, 3·10−6). Do this by entering Nx-Ny as y-axis data, and setting x0 
to 0, y0 to -3e-6, x1 to 0, and y1 to 3e-6 in the Cross-Section Plot Parameters dialog 
box. Set the x-axis data to Arc-length. The birefringence varies linearly from about 
2.9·10−4 at the bottom of the core to 2.4·10−4 at the top. Do not close the figure.

5 Now create another cross-section plot of the birefringence on the horizontal line 
from (−3·10−6, 0) to (3·10−6, 0). On the General tab select the Keep current plot 
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check box to make the plot in the same window as the previous one. On the Line/

Extrusion page, set x0 to -3e-6, y0 to 0, x1 to 3e-6, and y1 to 0.

The birefringence is constant on the horizontal line, thus the influence of the edges 
is indeed reduced to a minimum.

Optical Mode Analysis

Select the Perpendicular Hybrid-Mode Waves application mode from the Multiphysics 
menu.

G E O M E T R Y  M O D E L I N G

The computational domain can be reduced significantly for the optical mode analysis, 
because the energy of the fundamental modes is concentrated in the core region, and 
the energy density decays rapidly in the cladding and buffer regions.

Draw a rectangle with corners at (−1e-5, −1e-5) and (1e-5, 1e-5).

The rectangular region containing the active domains can be enlarged later on for 
validating the results. The rectangular region should be chosen large enough so that 
the computed propagation constants do not change significantly if the region is 
enlarged.
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P H Y S I C S  S E T T I N G S

Scalar Variables
1 From the Physics menu, choose Scalar Variables.

2 In the Application Scalar Variables dialog box, set the free-space wavelength to 
1.55e-6; when done, click OK.

Subdomain Settings
1 From the Physics menu, choose Subdomain Settings.

2 Deactivate the Perpendicular Hybrid-Mode Waves application mode in all 
subdomains except 4, 5, and 6. This makes sure the problem is only solved in the 
newly drawn rectangle.

3 For all active domains, select n (anisotropic) and set Nx, Ny, and Nz, respectively, as 
anisotropic refractive indices by changing the entries on the diagonal in the 
refractive index matrix.

4 When done, click OK.

Boundary Conditions
The only available perfect magnetic conductor boundary condition will suffice. Both 
the E and the H fields are assumed to be of negligible size at the boundaries, hence 
any one of them can be set equal to zero at the boundary.

M E S H  G E N E R A T I O N

1 On the Subdomain tab in the Free Mesh Parameters dialog box, set the Maximum 

element size to 2e-6 for Subdomains 4 and 5, and to 1e-6 for Subdomain 6. This 
will make the mesh dense in the activated regions and coarse in the deactivated 
regions. The mesh in the deactivated regions only affects the interpolated values of 
the expression variables and not the mode computation results.

2 Initialize the mesh.

C O M P U T I N G  T H E  S O L U T I O N

1 In the Solver Parameters dialog box, select the Eigenvalue solver.

2 Enter 1.46 in the Search for effective mode indices around edit field. The default 
Desired number of effective mode indices is set to 6, which is fine. These settings will 
make the eigenmode solver search for the 6 eigenmodes with effective mode indices 
closest to the value 1.46. This value is an estimate of the effective mode index for 
the fundamental mode. For propagating modes it must hold that

neff ncore< 1.456=
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3 In the Solver Manager dialog box, select only the Perpendicular Hybrid-Mode Waves 
application mode on the Solve For tab. This ensures that the Plane Strain application 
mode is not part of the eigenmode computation.

4 On the Initial Value tab, set the initial value to Current solution. This will take the 
plane strain solution and use it to evaluate the refractive indices for the mode 
analysis.

5 Click the Solve button.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 On the Surface tab in the Plot Parameters dialog box, select Perpendicular Hybrid-

Mode Waves (rfwv)>Power flow, time average, z component from the Predefined 

quantities list on the Surface Data tab. Then click Apply. This creates a visualization 
of the power flow, also called optical intensity or the Poynting vector, in the z 
direction (out-of-plane direction).

2 The default eigenmode is the one with the highest effective mode index 
corresponding to one of the fundamental modes.

Convergence Analysis

To check the accuracy of the eigenvalues you need to examine the sensitivity of these 
values to changes in the mesh density.
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1 In the Free Mesh Parameters dialog box, lower the value of the maximum element 
size for the core subdomain, number 6, to 5e-7, remesh, and solve again.

2 Repeat this for the maximum element sizes 2.5e-7 and 1.25e-7.

The solver finds the following effective mode:

It is evident from the table that the fundamental modes, corresponding to the two 
lowest eigenmodes with the highest effective mode indices, are nearly degenerate. It is 
also clear that the split of the degenerate fundamental modes that is expected due to 
the stress-induced anisotropic refractive index has been properly resolved with these 

ELEMENT SIZE, 
CORE 
SUBDOMAIN

1E-6 5E-7 2.5E-7 1.25E-7

EFFECTIVE MODE 
INDEX

neff1 1.451149 1.451139 1.451136 1.451136

neff2 1.450883 1.450875 1.450872 1.450871

neff3 1.445409 1.445407 1.445405 1.445405

neff4 1.445144 1.445141 1.445139 1.445139

neff5 1.445139 1.445133 1.445132 1.445131

neff6 1.444873 1.444867 1.444865 1.444865
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mesh sizes. The convergence of the two fundamental modes is shown in the figure 
below.

Now, run the model without the stress-induced birefringence.

1 Change the refractive index of Subdomains 4, 5, and 6 to an isotropic index by 
selecting the n (isotropic) radio button in the Subdomain Settings dialog box, and 
typing N as refractive index.

2 Solve the problem for a maximum element size of 2.5e-7 for Subdomain 6.

Compare these ideal values of the propagation constants with the stress-optical case.

ELEMENT SIZE, 
CORE 
SUBDOMAIN:

2.5E-7 (STRESS) 2.5E-7 (NO STRESS) DIFFERENCE

EFFECTIVE MODE 
INDEX

*1e-4

neff1 1.451136 1.450821 3.15

neff2 1.450872 1.45082 .51

neff3 1.445405 1.445093 57.79

neff4 1.445139 1.445083 .56

neff5 1.445132 1.444832 3.00

neff6 1.444865 1.444799 .66

6 6.1 6.2 6.3 6.4 6.5 6.6 6.7 6.8 6.9 7
1.4509

1.4509

1.451

1.451

1.4511

1.4511

1.4511

1.4512

1.4512
Computed value of effective mode index vs. mesh size h in core subdomain

−log10(h)

ef
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iv
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The difference is significant, which shows that the shift in the effective mode indices 
due to the stress-optical effect is indeed resolved.

Visual inspection of the 4 higher eigenmodes indicates that these are probably 
degenerate in the ideal case of no thermally induced stresses. Moreover, the higher 
eigenmodes have a larger portion of energy leaking into the cladding and buffer, and 
are thus more affected than the fundamental modes of the distance to the air and 
silicon layers. Because of this leakage, the boundary condition will affect the higher 
eigenmodes more than the fundamental mode. Thus a refined analysis of the higher 
modes would make it necessary to enlarge the computation domain. 

The figure below shows the z component of the Poynting vector for the fourth 
eigenmode.

M O D E L I N G  E R R O R S  A N D  S E N S I T I V I T Y  A N A L Y S I S

Although the fundamental modes have converged to 5 decimal places, the known 
modeling errors makes the exactness of the numbers uncertain. One major modeling 
error is due to the fact that the model contains a plane strain assumption in a case 
where the real-world model does not necessarily conform to this deformation state. 
This modeling error is reduced in the refined model “Stress-Optical Effects with 
Generalized Plane Strain” on page 615. Moreover, the material properties are only 
known to a few decimal places and the computed magnitudes of the effective mode 
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indices will correspondingly be uncertain. A standard way of examining the effects of 
uncertainty in material parameters is to perform a sensitivity analysis. That is, you 
perturb one of the material parameters slightly and then examine the resulting 
perturbation in the computed parameter. Another source of uncertainty is whether the 
stress from the thermal expansion is large with respect to the other sources of stress in 
the material originating from the manufacturing process.
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S t r e s s -Op t i c a l  E f f e c t s  w i t h  
Gen e r a l i z e d  P l a n e  S t r a i n

Introduction

The assumptions made for plane strain in the previous analysis of the waveguide 
structure, in the model “Stress-Optical Effects in a Silica-on-Silicon Waveguide” on 
page 598, do not hold in a situation where the silicon-silica laminate is free to expand 
in the z direction. Instead it is necessary to use a generalized plane strain model that 
allows for free expansion in the z direction. The boundary conditions in the xy-plane 
already allow the structure to expand freely in all directions in the plane. When the 
different materials in a laminate expand with different expansion coefficients, the 
laminate bends. In this model, the silica-silicon laminate bends in both the x and 
z directions. The Plane Strain application mode does not cover the bending in the 
z direction, so you must make modifications to the plane strain equations at the 
equation-system level.

Note: This model requires the RF Module and the Structural Mechanics Module.

Generalized Plane Strain

One possible extension of the plane strain formulation is to assume that the strain in 
the z direction has the form

That is, the strain is linearly varying throughout the cross section. This approximation 
is expected to be good when the bending curvature is small with respect to the extents 
of the structure in the xy-plane and corresponds to a small rotation that is 
representative of each cross section of the structure along the z axis. (A more general 
model would include second-degree terms in x and y.)

One way of validating the result of this simulation is to plot the εx and εz strains on a 
cross section on the symmetry line at x = 0. Because you can expect an identical 
bending in the x and z directions, these strains should be identical and vary linearly.

εz e0 e1x e2y+ +=
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E X T E N S I O N  O F  T H E  P L A N E  S T R A I N  E Q U A T I O N S

The objective is to extend the current Plane Strain application mode with additional 
PDE terms that represent the generalized plane strain deformation state. In COMSOL 
Multiphysics, the coefficients e0, e1, and e2 in the expression for the εz strain is 
modeled with coupling variables associated with a point geometry object (zero 
dimensional object). This is a convenient way to include degrees of freedom that are 
constant throughout a subdomain. In order to expand the equations for the Plane 
Strain application mode, the new εz strain contributions need to be added as weak 
terms to the ordinary plane strain equations. The reason for this is that for COMSOL 
Multiphysics to be able to solve the equations as a linear problem, the assembler 
requires that all contributions from coupling variables are entered as weak terms.

Start from the 3D stress-strain relation for linear isotropic conditions including 
thermal effects,

where σx, σy, σz, τxy, τyz, and τxz are the components of the stress tensor, εx, εy, εz, γxy, 
γyz, and γxz are the components of the strain tensor, α is the thermal expansion 
coefficient, T is the operating temperature, and Tref is the reference temperature 
corresponding to the manufacturing temperature. The 6-by-6 matrix D (tensor) has 
entries that contain expressions in Young’s modulus, E, and Poisson’s ratio, ν. The 
matrix D is presented in the Structural Mechanics Module User’s Guide.

For generalized plane strain (and ordinary plane strain), assume that γyz = γxz = 0 and 
two of the equations vanish

The matrix D shrinks accordingly.

σx

σy

σz

τxy

τyz

τxz

D

εx

εy

εz

γxy

γyz

γxz

α

T Tref–

T Tref–

T Tref–

0
0
0

–

⎝ ⎠
⎜ ⎟
⎜ ⎟
⎜ ⎟
⎜ ⎟
⎜ ⎟
⎜ ⎟
⎜ ⎟
⎜ ⎟
⎜ ⎟
⎛ ⎞

=

σx

σy

σz

τxy

D

εx

εy

εz

γxy

α

T Tref–

T Tref–

T Tref–

0

–

⎝ ⎠
⎜ ⎟
⎜ ⎟
⎜ ⎟
⎜ ⎟
⎜ ⎟
⎛ ⎞

=
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The PDE solved is Navier’s equation

where

in the case of generalized plane strain and u = (u, v, w) are the unknown displacement 
variables solved for.

The coefficient c above is a tensor containing the elements of D in a pattern that is 
listed in the Structural Mechanics Module User’s Guide and

contains the contributions from the thermal strains.

In the case of ordinary plane strain the upper left 2-by-2 submatrix of σ, γ, and D is 
used.

It is assumed here that the variables T and Tref are constants. For information on how 
the temperature variables enter Navier’s equation as unknowns in a heat transfer 
problem, see the Structural Mechanics Module User’s Guide. 

To expand the plane strain equation to a generalized plane strain formulation one 
needs to consider the weak form of Navier’s equation. The weak form of a system of 
equations is a scalar equation involving integrals. See “Weak Form Modeling” on page 
293 in the COMSOL Multiphysics Modeling Guide for more information on the 
appearance of the weak form for systems of equations.

To get the weak form of Navier’s equation, multiply by a test function 
v = [utest, vtest, wtest] and integrate

Integration by parts gives

∇– σ⋅ K=

σ
σx τxy 0

τyx σy 0

0 0 σz

c u∇ γ–= =

γ E
1 ν+( ) 1 2ν–( )

---------------------------------------

1 ν+( )α T Tref–( ) 0 0

0 1 ν+( )α T Tref–( ) 0

0 0 1 ν+( )α T Tref–( )

=

v ∇– σ⋅( ) Ωd
Ω
∫ v K Ωd⋅

Ω
∫=
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or in more detail, with K = 0

where uy,test = ∂utest/∂y and similarly for the other test function derivatives. The dot 
product in the domain integral is interpreted as a dot product operating on the rows 
of the matrices so that

where

0 vσn Γ v∇ σ⋅ Ω v K Ωd⋅
Ω
∫+d

Ω
∫–d

Ω∂
∫=

0 utest vtest wtest

σx τxy 0

τyx σy 0

0 0 σz

nx

ny

nz

Γd
Ω∂
∫

ux test, uy test, uz test,

vx test, vy test, vz test,

wx test, wy test, wz test,

σx τxy 0

τyx σy 0

0 0 σz

⋅

⎝ ⎠
⎜ ⎟
⎜ ⎟
⎜ ⎟
⎜ ⎟
⎛ ⎞

Ωd
Ω
∫–

=

ux test, uy test, uz test,

vx test, vy test, vz test,

wx test, wy test, wz test,

σx τxy 0

τyx σy 0

0 0 σz

⋅

⎝ ⎠
⎜ ⎟
⎜ ⎟
⎜ ⎟
⎜ ⎟
⎛ ⎞

Ωd
Ω
∫

ux test, uy test, uz test, σx τxy 0

vx test, vy test, vz test, τyx σy 0 wx test, wy test, wz test, 0 0 σz⋅+⋅

+⋅⎝

⎠

⎛

⎞ Ωd

Ω
∫=
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and

Note that the displacement variable w in the z direction is not available in the Plane 
Strain application mode. However, it is not needed since the generalized formulation 
assumes a certain fix shape of the deformation in the z direction.

The same relations hold for the test functions,

In COMSOL Multiphysics, the test functions utest and vtest are denoted u_test and 
v_test, respectively. Their derivatives ux,test, uy,test, vx,test, and vy,test are denoted 
ux_test, uy_test, vx_test, and vy_test, respectively. Note that the z components 
of the test functions are not available in the Plane Strain application mode.

Using this notation, the weak form of Navier’s equation becomes (with K = 0)

σx
E

1 ν+( ) 1 2ν–( )
--------------------------------------- 1 ν–( )εx νεy νεz 1 ν+( )α T Tref–( )–+ +( )=

σy
E

1 ν+( ) 1 2ν–( )
--------------------------------------- νεx 1 ν–( )εy νεz 1 ν+( )α T Tref–( )–+ +( )=

σz
E

1 ν+( ) 1 2ν–( )
--------------------------------------- νεx νεy 1 ν–( )εz 1 ν+( )α T Tref–( )–+ +( )=

τxy
E

1 ν+( ) 1 2ν–( )
--------------------------------------- 1 2ν–

2
----------------γxy⎝ ⎠
⎛ ⎞=

εx x∂
∂u

=

εy y∂
∂v

=

εz z∂
∂w

=

γxy y∂
∂u

x∂
∂v

+=

εx test, ux test,=

εy test, vy test,=

εz test, wz test,=

γxy test, uy test, vx test,+=

0 vσn Γd
Ω∂
∫ εx test, σx εy test, σy εz test, σz γxy test, τxy+ + +( ) Ωd

Ω
∫–=
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This expression for the weak equation shows which terms you must add as weak terms 
to generalize the plane strain formulation.

To see the difference compared to the ordinary plane strain formulation, the equation 
for σz can be separated out according to

where D has been reduced to 

The ordinary plane strain equation is obtained if εz = 0.

To expand the Plane Strain application mode, you must add weak contributions from 
εz need to the stress components σx and σy according to

In addition, σz needs to be included in the weak equation from being merely a 
postprocessing quantity in the original Plane Strain application mode,

where

and σz was presented earlier.

In COMSOL Multiphysics you model the coefficients e0, e1, and e2 in the expression 
for the εz strain with coupling variables as weak contributions to the ordinary plane 
strain equations. These coefficients represent three additional unknown variables that 
prevail throughout the modeled domain. In practice, these variables need to be 

σx

σy

τxy

D

εx

εy

γxy

1 ν+( )α T Tref–( )

1 ν+( )α T Tref–( )

0

–

νεz

νεz

0

+

⎝ ⎠
⎜ ⎟
⎜ ⎟
⎜ ⎟
⎜ ⎟
⎛ ⎞

=

σz
E

1 ν+( ) 1 2ν–( )
--------------------------------------- νεx νεy 1 ν–( )εz 1 ν+( )α T Tref–( )–+ +( )=

D E
1 ν+( ) 1 2ν–( )

---------------------------------------

1 ν– ν 0
ν 1 ν– 0

0 0 1 2ν–
2

----------------

=

E
1 ν+( ) 1 2ν–( )

--------------------------------------- εx test, νεz εy test, νεz+( )–

εz test, σz–

εz test, e0 test, e1 test, x e2 test, y+ +=
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associated with an arbitrary point of the geometry. Using coupling variables in this way 
specifies a map from this point onto the entire domain on which the generalized plane 
strain equations hold. COMSOL Multiphysics creates the test functions corresponding 
to e0, e1, and e2 automatically.

Model Library path: Structural_Mechanics_Module/Stress-
Optical_Effects/stress_optical_generalized

Plane Strain Analysis

Many of the modeling steps are similar to the model “Stress-Optical Effects in a Silica-
on-Silicon Waveguide” on page 598, but some steps are made in a different order, and 
there are obviously differences when generalizing the plane strain problem.

M U L T I P H Y S I C S  S E T T I N G S

1 In the Model Navigator, select 2D.

2 Select the Structural Mechanics Module>Plane Strain>Static analysis application mode.

3 Click Multiphysics then Add to add this application mode to the model.

4 Next select the RF Module>Perpendicular Waves>Hybrid-Mode Waves> Mode analysis 
application mode. Add this mode to the model.

5 Open the Application Mode Properties dialog box from the Physics menu (Properties) 
and select In-plane components from the Field components list. This selects the two-
components equation formulation for hybrid-mode waves. It is also possible to use 
the default three-component equation formulation for this problem. See “Selecting 
Equation Formulation” on page 146 in the RF Module User’s Guide for general 
information about the different options.

6 For convenience select Free space wavelength from the Specify wave using list. This 
makes the wavelength available in the Application Scalar Variables dialog box instead 
of the frequency.

The unknown parameters e0, e1, and e2 should be constant within the whole modeling 
domain. You can achieve this by adding a new geometry with only a single point to the 
model and define e0, e1, and e2 as the dependent variables at this point. Later on you 
define coupling variables that map these dependent variables from the point to the 
whole model.
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1 From the Multiphysics menu, select the Model Navigator. Click the Add Geometry 

button to add a 2D geometry (2D is the default space dimension).

2 Select the COMSOL Multiphysics>PDE Modes>Weak Form,Point application mode from 
the application mode tree.

3 Type e0 e1 e2 in the Dependent variables text field.

4 Click Add to add the Weak Form, Point application mode to the second geometry. 
This application mode contains the three degrees of freedom for the parameters e0, 
e1, and e2 that describe the z strain.

5 Set the Ruling application mode to the Perpendicular Hybrid-Mode Waves application 
mode. This makes this application mode specify the interpretation of the parameters 
to the eigenvalue solver given in the Solver Parameters dialog box.

6 Click OK to close the Model Navigator.

The Weak Form, Point application mode becomes the active application mode when 
you close the Model Navigator.

G E O M E T R Y  M O D E L I N G

The three degrees of freedom e0, e1, and e2 must be associated with a point. The 
location of this point is insignificant. This means that the added geometry could 
equally well have been a 1D or a 3D geometry. Using the programming language, 
there is also an option of using a 0D geometry.

Add a point at any position, say at the origin (0, 0).

O P T I O N S  A N D  S E T T I N G S

In the Constants dialog box enter the following names, expressions, and descriptions 
(optional); when done, click OK. They are identical to the constants defined on page 
601. 

NAME EXPRESSION DESCRIPTION

nSi 3.5 Refractive index, silicon (Si)

nBuf 1.445 Refractive index, silica (SiO2)

nClad 1.445 Refractive index, silica

deltan 0.0075 Relative index difference:

nCore nClad/sqrt(1-2*deltan) Refractive index, core

∆
ncore

2 ncladding
2

–( )

2ncore
2

---------------------------------------------=
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G E O M E T R Y  M O D E L I N G

1 Switch to Geom1 by clicking its tab.

2 Draw rectangles corresponding to the different regions.

P H Y S I C S  S E T T I N G S

Point Settings and Boundary Conditions
All regions have free boundaries, which also is the default boundary condition. 
However, these conditions do not suffice in creating a unique solution because the 
computational domain can move and rotate freely; the problem is ill-posed. The 
problem becomes well-posed by adding constraints at points to keep the domain fixed.

1 Select the Plane Strain application mode from the Multiphysics menu.

2 Open the Point Settings dialog box, and select the check boxes for the constraints 
Rx and Ry at point 1, the lower left corner, for both the x and y directions. Doing 
so keeps the domain from moving (translational move).

3 Select the check box for the constraint Ry at point 9, the lower-right corner, for the 
y direction only, keeping the domain from rotating but allowing it to slide in the x 
direction. When done, click OK.

alphaSi 2.5e-6[1/K] Thermal expansion coefficient, silicon

alphaSiO2 0.35e-6[1/K] Thermal expansion coefficient, silica

ESi 110[GPa] Young’s modulus, silicon

ESiO2 78[GPa] Young’s modulus, silica

nuSi 0.19 Poisson’s ratio, silicon

nuSiO2 0.42 Poisson’s ratio, silica

B1 4.2e-12[m^2/N] First stress optical coefficient

B2 0.65e-12[m^2/N] Second stress optical coefficient

T1 20[degC] Operating temperature

T0 1000[degC] Reference temperature

REGION LOWER LEFT CORNER UPPER RIGHT CORNER

Silicon Wafer (-16e-5,-1e-4) (16e-5,-1.7e-5)

Buffer (-16e-5,-1.7e-5) (16e-5,-3e-6)

Cladding (-16e-5,-3e-6) (16e-5,1.3e-5)

Core (-3e-6,-3e-6) (3e-6,3e-6)

NAME EXPRESSION DESCRIPTION
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Subdomain Settings
The air domain need not be part of the plane strain model.

1 Specify the subdomain settings for the Plane Strain application mode according to 
the following table.

Before entering the temperatures on the Load page, you must select the Include 

thermal expansion check box. It is not necessary to specify the density ρ, because it 
does not enter the equation for static problems.

SUBDOMAIN 1 SUBDOMAINS 2–4

Page Material Loads Material Loads

E ESi E ESiO2

ν nuSi Temp T1 ν nuSiO2 Temp T1

α alphaSi Tempref T0 α alphaSiO2 Tempref T0
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E X P R E S S I O N  V A R I A B L E S

In the Subdomain Expressions dialog box in the Options menu, define the following 
variables.

The variables ex, ey, and ez are the strains εx, εy, and εz, and the variables sx, sy, 
and sz are the stresses σx, σy, and σz. The definitions of the refractive index variables 
Nx, Ny, and Nz differ slightly compared to the previous model. In this case they are 
expressed in the generalized stress variables sx, sy, and sz. Because of the use of 
integration coupling variables (e00, e11, and e22), COMSOL Multiphysics cannot 
determine the unit for other variables that directly or indirectly depend on these 

VARIABLE NAME SUBDOMAIN EXPRESSION

E 1

2,3,4

ESi

ESiO2

nu 1

2,3,4

nuSi

nuSiO2

alpha 1

2,3,4

alphaSi

alphaSiO2

ex 1,2,3,4 ux

ey 1,2,3,4 vy

ez 1,2,3,4 e00+e11*x+e22*y

sx 1,2,3,4 sx_smpn+E/((1+nu)*(1-2*nu))*nu*ez

sy 1,2,3,4 sy_smpn+E/((1+nu)*(1-2*nu))*nu*ez

sz 1,2,3,4 E/((1+nu)*(1-2*nu))*(nu*ex+nu*ey+(1-nu)*ez-

(1+nu)*alpha*(T1-T0))

N 1

2

3

4

nSi

nBuf

nClad

nCore

Nx 1

2,3,4

N

N-B1*sx-B2*(sy+sz)

Ny 1

2,3,4

N

N-B1*sy-B2*(sx+sz)

Nz 1

2,3,4

N

N-B1*sz-B2*(sx+sy)
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integration coupling variables. This causes the warnings for inconsistent units here 
and in the specification of the refractive index. You can disregard these warnings.

C O U P L I N G  V A R I A B L E S

The unknown parameters e0, e1, and e2 should be constant within the whole modeling 
domain. You can achieve this by defining coupling variables that map these dependent 
variables from the point to the entire model:

1 Switch to Geom2 by clicking its tab.

2 Open the Point Integration Variables dialog box by selecting Integration Coupling 

Variables>Point Variables from the Options menu.

3 Enter the following names and expressions, each on a separate row in the table on 
the Source tab.

The variables e00, e11, and e22 take the values of e0, e1, and e2, respectively, in the 
entire model.

S U B D O M A I N  S E T T I N G S

Finally, enter the additional terms in the generalized plane strain problem.

1 Switch to Geom1 by clicking its tab.

2 Select Equation System>Subdomain Settings from the Physics menu.

3 On the Weak tab in the Subdomain Settings - Equation System dialog box, add 
-E/((1+nu)*(1-2*nu))*(ex_test*nu*ez+ey_test*nu*ez)-ez_test*sz in 
the second row of the weak term for all subdomains. The two first rows correspond 
to the plane strain problem. You can enter this expression in any of these two fields, 
because the software adds them together when assembling the problem.

M E S H  G E N E R A T I O N

1 Initialize the mesh.

2 Refine it twice.

3 Switch to Geom2 by clicking its tab.

4 Initialize the mesh in this geometry too.

NAME EXPRESSION

e00 e0

e11 e1

e22 e2
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C O M P U T I N G  T H E  S O L U T I O N

1 In the Solver Parameters dialog box select the Stationary solver. When done, click OK.

2 On the Solve for tab in the Solver Manager dialog box, select only the Plane Strain and 
the Weak Form, Point application modes. This excludes the hybrid-mode waves 
application mode from the equations to solve. When done, click OK.

3 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Switch to Geom1 by clicking its tab.

2 Click the Surface tab on the Plot Parameters dialog box. Change the string in the 
Expression edit field on the Surface Data page to abs((ex-ez)/ez)<0.05. Clear the 
Smooth check box. Click OK to visualize the area where the relative difference 
between the x and z strain is within 5%. The model is most accurate in the regions 
close to the core, far from the boundaries on the far left and right.

3 For symmetry reasons the strains εx and εz should be equal. To see how well this 
model has achieved this, make a cross-section plot of them. Open the Cross-Section 

Plot Parameters dialog box. Enter the Title ex and ez by using the Title/Axis dialog 
box on the General page. On the Line/Extrusion tab, set x0 to 0, x1 to 0, y0 to -1e-
4, and y1 to 1.3e-5 to make a vertical line across the structure. Enter the y-axis data 
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expression ex, and set the Line resolution to 25. Set the x-axis data to y. Click the Line 

Settings button and select Circle as Line marker. Click Apply to plot ex.

4 On the General tab check Keep current plot to be able to plot ez in the same figure 
window.

5 Then change the Expression to ez in y-axis data. Use Plus sign as Line marker for this 
plot. Click OK to make the plot.

6 To view the stress-induced birefringence nx − ny together with the deformation, 
open the Plot Parameters dialog box and select Surface and Deformation plot. On the 
Surface page, enter the Nx-Ny in the Expression edit field on the Surface Data page, 
and select the Smooth check box again. As Deformation data use Displacement (smpn) 
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from the Predefined quantities list on the Subdomain Data page, which is the default 
selected on the Deform tab. Click OK.

Note: Thid model includes an extension of the plane strain PDE system. This means 
that some of the postprocessing variables in the Plane Strain application mode are no 
longer valid and give wrong results if used. We recommend that you use only the 
variables entered in the Subdomain Expressions dialog box for postprocessing.

Optical Mode Analysis

Now continue with the mode analysis in the same way as was done in the previous 
model on page 608.

G E O M E T R Y  M O D E L I N G

You can reduce the computational domain significantly for the optical mode analysis, 
because the energy of the fundamental modes is concentrated in the core region, and 
the energy density decays exponentially in the cladding and buffer regions.

Draw a rectangle with corners at (-1e-5, -1e-5) and (1e-5, 1e-5).
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P H Y S I C S  S E T T I N G S

Next, set up the parameters for the hybrid-mode wave problem. Select the 
Perpendicular Hybrid-Mode Waves application mode in the Multiphysics menu.

Scalar Variables
1 From the Physics menu, choose Scalar Variables.

2 In the Application Scalar Variables dialog box, set the free space wavelength to 
1.55e-6. Click OK.

Subdomain Settings
1 From the Physics menu, choose Subdomain Settings.

2 Deactivate the Perpendicular Hybrid-Mode Waves application mode in all 
subdomains except 4, 5, and 6 (clear the Active in this domain check box for these 
subdomains). This makes sure that the solution for the electromagnetic waves only 
includes the newly drawn rectangle.

3 For all active domains, select n (anisotropic) and set Nx, Ny, and Nz, respectively, as 
anisotropic refractive indices by changing the entries on the diagonal in the 
refractive index matrix. When done, click OK.

E X P R E S S I O N  V A R I A B L E S

Occasionally the associative geometry algorithm does not update all variables and 
settings exactly as expected when modifying the geometry. In this case the expression 
for N might have got the wrong value in domain 6. In the Subdomain Expressions dialog 
box change the value of N in Subdomain 6 to nCore.

M E S H  G E N E R A T I O N

1 On the Subdomain tab in the Free Mesh Parameters dialog box, set the Maximum 

element size to 2e-6 for Subdomains 4 and 5, and to 2.5e-7 for Subdomain 6.

2 Initialize the mesh.

C O M P U T I N G  T H E  S O L U T I O N

1 In the Solver Parameters dialog box, select the Eigenvalue solver.

2 Enter 1.46 in the text field Search for effective mode indices around. The default 
Desired number of effective mode indices is set to 6, which is fine. These settings make 
the eigenmode solver search for the 6 eigenmodes with effective mode indices 
closest to the value 1.46. This value is an estimate of the effective mode index for 
the fundamental mode. For propagating modes it must hold that

neff ncore< 1.456=
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3 In the Solver Manager dialog box, select only the Perpendicular Hybrid-Mode Waves 
application mode on the Solve For page. This ensures that only this application mode 
is part of the eigenmode computation.

4 On the Initial Value page, set the initial value to Current solution. This takes the plane 
strain solution and use it to evaluate the refractive indices for the mode analysis.

5 Click the Solve button.

The following table contains the effective mode indices together with the effective 
mode indices obtained from the analysis in the previous model without the 
generalization of the plane strain equations.

There is a systematic shift in the propagation constants when the strain in the 
z direction is taken into account.

GENERALIZED 
PLANE STRAIN

PLANE STRAIN DIFFERENCE

EFFECTIVE MODE INDEX *1e-3

neff1 1.450403 1.451136 0.73

neff2 1.450115 1.450872 0.76

neff3 1.444671 1.445405 0.73

neff4 1.444398 1.445139 0.74

neff5 1.444383 1.445132 0.75

neff6 1.444109 1.444865 0.76
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 15
T h e r m a l - S t r u c t u r e  I n t e r a c t i o n
This chapter contains models that include the interaction between heat transfer 
and thermal expansion, often called thermal-structure interaction.
 633
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T h e rma l  S t r e s s e s  i n  a  L a y e r e d  P l a t e

Introduction

This example contains an analysis of the thermal stress in a layered plate. The plate 
consists of three layers: the coating, the substrate, and the carrier. The coating is 
deposited on the substrate at a temperature of 800 °C. At this temperature both the 
coating and the substrate are stress-free. The temperature of the plate is then lowered 
to 150 °C, which induces thermal stresses in the coating/substrate assembly. At this 
temperature the coating/substrate assembly is epoxied to a carrier plate so that the 
coating/substrate has initial stresses when it is bonded to the carrier. Finally, the 
temperature is lowered to 20 °C.

Model Definition

The plate is restrained from moving in the z direction. This makes it possible to use 
the 2D Plane Strain application mode, which assumes that the z-component of the 
strain is zero.

This model contains only thermal loads, and they are introduced into the constitutive 
equations according to the following equations:

and

where σ is the stress vector, D is the elasticity matrix, εx, εy, εz, γxy, γyz, γxz are the strain 
components, αvec is the thermal expansion coefficients, T is the actual temperature, 
and Tref is the reference temperature. For more details concerning the governing and 
constitutive equations see the chapters “Thermal Strain” on page 178 and “Plane 
Strain” on page 112 in the Structural Mechanics Module User’s Guide.

σ Dεel σ0+ D ε εth– ε0–( ) σ0+= =

εth

εx

εy

εz

γxy

γyz

γxz th

αvec T Tref–( )= =
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The geometry of the plate is shown in Figure 15-1. The top layer in the geometry is 
the coating, the middle layer is the substrate, and the bottom layer is the carrier.

Figure 15-1: The plate geometry.

The analysis uses two steps:

S T E P  1

In the first step you lower the temperature from 800 °C to 150 °C, which affects the 
coating layer and the substrate layer. The carrier layer is not active in this step.

The lower-left corner of the substrate is fixed, and the lower-right corner of the 
substrate is constrained in the y direction. This prevents rigid-body movements but 
does not affect the stress distribution.

S T E P  2

In this step all three layers are active and you drop the temperature from 150 °C to 
room temperature, 20 °C. This step includes the initial stresses from Step 1.

In the same manner as in Step 1 the lower-left corner of the carrier is fixed, and the 
lower-right corner of the carrier is constrained in the y direction.
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Results and Discussion

The normal stress in the x direction from the first analysis step is depicted in Figure 15-
2. The substrate material has a higher thermal expansion coefficient than the coating 
material. This means that the substrate shrinks more than the coating, causing tensile 
stresses in the substrate area next to the coating and compressive stresses in the coating.

Figure 15-2: Normal stress in the x direction for the first analysis step.

Figure 15-3 shows the residual thermal x-stress in the final step where the temperature 
is lowered to 20 °C. The tensile stress levels have increased somewhat in the substrate 
area next to the coating, as have the compressive stress in the coating compared to the 
first process step. The main stress contribution is clearly the added initial stress from 
the first process step.
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Figure 15-3: Residual thermal stress at room temperature.

Model Library path: Structural_Mechanics_Module/Thermal-
Structural_Interaction/layered_plate

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 On the New page select 2D from the Space Dimension list and click on Structural 

Mechanics Module.

2 Select Plane Strain>Static analysis.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, choose Axes/Grid Settings.
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2 Specify axis and grid settings according to the following table; when done, click OK.

3 Open the Constants dialog box and enter the following constant names, expressions, 
and descriptions (optional); when done, click OK.

G E O M E T R Y  M O D E L I N G

1 Draw the first rectangle with opposite corners at (−0.01, 0) and (0.01, 0.002).

2 Draw the second rectangle on top of the first rectangle with opposite corners at 
(−0.01, 0.002) and (0.01, 0.012).

3 Draw the third rectangle on top of the second rectangle with opposite corners at 
(−0.01, 0.012) and (0.01, 0.014).

4 See Figure 15-1 for the result.

P H Y S I C S  S E T T I N G S

Point Settings
Enter point settings according to the following table.

Subdomain Settings
The material properties are specified in the Materials/Coefficients dialog box.

1 Select Materials/Coefficients Library from the Options menu.

AXIS GRID

x min -1.5e-2 x spacing 5e-3

x max 1.5e-2 Extra x -

y min -2e-3 y spacing 2e-3

y max 20e-3 Extra y -

NAME EXPRESSION DESCRIPTION

Ttop 800[degC] Coating deposition temperature

Tbot 150[degC] Temperature when the coating/substrate 
is epoxied to the carrier

Troom 20[degC] Room temperature

POINT 2 6

Type Constraint Constraint

Rx

Ry

0

0

Ry 0
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2 Click the New button and specify the following material parameters:

3 Change the Name to Coating.

4 Click Apply.

5 Click the New button specify the following second set of material parameters:

6 Change the Name to Substrate.

7 Click Apply.

8 Click the New button and specify the following third set of material parameters:

9 Change the Name to Carrier.

10 Click OK.

Next, specify the subdomain settings:

1 Choose Physics>Subdomain Settings.

2 To set the first subdomain inactive, select Subdomain 1 from Subdomain selection list 
and then clear the Active in this subdomain check box.

3 Enter the following subdomain settings for the remaining two subdomains:

PARAMETER EXPRESSION/VALUE COMMENT

E 7e10 Young’s modulus, coating

ν (nu) 0.17 Poisson’s ratio, coating

α (alpha) 5e-7 Thermal expansion coefficient, coating

PARAMETER EXPRESSION/VALUE DESCRIPTION

E 1.3e11 Young’s modulus, substrate

ν (nu) 0.28 Poisson’s ratio, substrate

α (alpha) 3e-6 Thermal expansion coefficient, substrate

PARAMETER EXPRESSION/VALUE DESCRIPTION

E 2.15e11 Young’s modulus, carrier

ν (nu) 0.3 Poisson’s ratio, carrier

α (alpha) 6e-6 Thermal expansion coefficient, carrier

SUBDOMAIN 2 2

Page Material Load

Library material Substrate Include thermal expansion √
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M E S H  G E N E R A T I O N

1 Initialize the mesh.

2 Refine the mesh once.

M U L T I P H Y S I C S  S E T T I N G S

1 Open the Model Navigator by selecting Model Navigator from the Multiphysics menu.

2 Choose the Structural Mechanics Module>Plane Strain>Static analysis. Make sure that 
it is the Structural Mechanics Module’s Plane Strain application mode.

3 Add this application mode to the model by clicking the Add button.

4 Click OK to close the Model Navigator.

Check that the second Plane Strain application mode is selected in the Multiphysics 
menu.

Point Settings
Enter point constraints according to the following table.

Subdomain Settings
1 Enter subdomain settings according to the following table.

Temp Tbot

Tempref Ttop

SUBDOMAIN 3 3

Page Material Loads

Library material Coating Include thermal expansion √

Temp Tbot

Tempref Ttop

POINT 1 5

Type Constraint Constraint

Rx 0

Ry 0 Ry 0

SUBDOMAIN 1 1

Page Material Load

Library material Carrier Include thermal expansion √

SUBDOMAIN 2 2
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2 Select Subdomains 2 and 3 from the Subdomain selection list in the Subdomain 

Settings dialog box.

3 Click the Initial Stress and Strain tab. Add the initial stresses from the first application 
mode by entering sx_smpn, sy_smpn, sz_smpn in the Initial normal stress edit fields 
and sxy_smpn in the Initial shear stress edit field.

C O M P U T I N G  T H E  S O L U T I O N

1 Select the Solver Manager from the Solve menu.

2 Select Plane Strain (smpn) from the Solve for variables list on the Solve For page.

3 Click OK to close the dialog box.

4 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Plot the stress in x direction as follows:

1 Select Plane Strain (smpn)>sx normal stress global sys. from the list on the Surface 
page in the Plot Parameters dialog box.

2 Clear the Smooth check box.

Temp Troom

Tempref Tbot

SUBDOMAIN 2 2

Page Material Load

Library material Substrate Include thermal expansion √

Temp Troom

Tempref Tbot

SUBDOMAIN 3 3

Page Material Load

Library material Coating Include thermal expansion √

Temp Troom

Tempref Tbot

SUBDOMAIN 1 1
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3 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Select the Solver Manager from the Solve menu.

2 Select Plane Strain (smpn2) from the Solve for variables list on the Solve For page.

3 Click OK.

4 Click the Restart button.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Plot the stress in x direction for the second plane strain application.

1 Select Plane Strain (smpn2)>sx normal stress global sys. from the Surface page in the 
Plot Parameters dialog box and clear the Smooth check box.
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2 Click OK. 
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S u r f a c e -Moun t  R e s i s t o r

The drive for miniaturizing electronic devices has resulted in today’s extensive use of 
surface-mount electronic components. An important aspect in electronics design and 
the choice of materials is a product’s durability and lifetime. For surface-mount 
resistors and other components producing heat it is a well-known problem that 
temperature cycling can lead to cracks propagating through the solder joints, resulting 
in premature failure (Ref. 1). For electronics in general there is a strong interest in 
changing the soldering material from lead- or tin-based solder alloys to other mixtures.

The following multiphysics example models the heat transport and structural stresses 
and deformations resulting from the temperature distribution using the General Heat 
Transfer application mode and the Solid, Stress-Strain application mode.

Model Definition

Figure 15-4 shows a photograph of a surface-mount resistor together with a diagram 
of it on a printed circuit board (PCB).

Figure 15-4: A photo and diagram of a typical surface-mounted resistor soldered to a 
PCB.
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Table 15-1 shows the dimensions of the resistor and other key components in the 
model including the PCB.

The simulation uses a symmetry cut along the length of the resistor so that it needs to 
include only half of the component (Figure 15-5).

Figure 15-5: The simulation models only half the resistor.

In operation, the resistor dissipates 0.2 W of power as heat. Conduction to the PCB 
and convection to the surrounding air provide cooling. In this model, the heat transfer 
occurs through conduction in the subdomains. The model simplifies the surface 
cooling and describes it using a heat transfer coefficient, h, in this case set to 5 W/
(m2·K); the surrounding air temperature, Tinf, is at 300 K. The resulting heat-transfer 

TABLE 15-1:  COMPONENT DIMENSIONS

COMPONENT LENGTH WIDTH HEIGHT

Resistor (Alumina) 6 mm 3 mm 0.5 mm

PCB (FR4) 16 mm 8 mm 1.6 mm

Cu pad 2 mm 3 mm 35 µm

Ag termination 0.5 mm 3 mm 25 µm

Stand-off (gap to PCB) - - 105 µm
S U R F A C E - M O U N T  R E S I S T O R  |  645



646 |  C H A P T E
equation and boundary condition (included in the model using the General Heat 
Transfer application mode) are

where k is the thermal conductivity, and Q is the heating power per unit volume of the 
resistor (set to 16.7 MW/m3 corresponding to 0.2 W in total).

The model handles thermal expansion using a static structural analysis using the Solid, 
Stress-Strain application mode (a description of the corresponding equations is 
available in the Structural Mechanics Module User’s Guide). The thermal and 
mechanical material properties in this model are:

The model treats properties of air as temperature dependent according to the 
following equations (Ref. 3): 

with p0 = 101.3 kPa, Mw = 0.0288 kg/mol, and R = 8.314 J/(mol·K). Further, 

The stresses are zero at 293 K. The boundary condition for the Solid, Stress-Strain 
application mode is that both ends, in the length direction of the circuit board, are 
fixed with respect to x, y, and z.

TABLE 15-2:  MATERIAL PROPERTIES

MATERIAL E (GPa) n α (ppm) k (W/(m·K)) ρ (kg/m3) Cp (J/(kg·K))

Ag 83 0.37 18.9 420 10500 230

Alumina 300 0.222 8.0 27 3900 900

Cu 110 0.35 17 400 8700 385

Fr4 22 0.28 18 0.3 1900 1369

60Sn-40Pb 10 0.4 21 50 9000 150

∇ k∇T–( )⋅ Q=

n– k∇T–( )⋅ h Tinf T–( )=

ρ p0Mw( ) RT( )⁄=

Cp 1100  J/(kg·K)=

k 10-3.723 + 0.865log T( )  W/(m·K)=
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Note: This model requires the Heat Transfer Module and the Structural Mechanics 
Module.

Results and Discussion

The isosurfaces in Figure 15-6 show the temperature distribution at steady state. The 
highest temperature is approximately 420 K, appearing in the center of the resistor. 
The circuit board also heats up significantly.

Figure 15-6: Temperature distribution in the resistor and the circuit board at steady state.
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Thermal stresses appear as a result of the temperature increase; they arise from the 
materials’ different expansion coefficients. Figure 15-7 plots the effective stress (von 
Mises) together with the resulting deformation of the assembly

Figure 15-7: The thermally induced distribution of von Mises effective stress together with 
the deformation (magnified) and the isotherms.

The highest stresses seem to occur in the termination material. It is interesting to 
compare these effective stresses to the yield stress and thereby investigate whether or 
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not the material is irreversibly deformed. In that case the solder is the weak point. The 
following graph plots the stress in the solder points alone.

Figure 15-8: Close-up of the von Mises effective stresses in the solder joint.

The yield stress for solder is approximately 220 MPa. The highest effective stress seems 
to fall in the range near 220 MPa. This means that the assembly functions without 
failure for the tested power loads. However, if the heating power increases slightly, 
permanent deformation and possibly failure occur.

References

1. H.Lu, C.Bailey, M.Dusek, C.Hunt, and J.Nottay, “Modeling the Fatigue Life of 
Solder Joints of Surface Mount Resistors,” EMAP 2000.

2. Courtesy of Dr. H. Lu, Centre for Numerical Modelling and Process Analysis, 
University of Greenwich, U.K.

3. J.M. Coulson and J.F. Richardson, Chemical Engineering, vol. 1, Pergamon Press, 
1990, appendix.
S U R F A C E - M O U N T  R E S I S T O R  |  649



650 |  C H A P T E
Model Library path: Structural_Mechanics_Module/Thermal-
Structural_Interaction/surface_resistor

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

Open the Model Navigator. Click the New tab. In the Space dimension list select 2D, then 
click OK.

O P T I O N S  A N D  S E T T I N G S

From the Options menu choose Constants, then define the following names and 
expressions. When finished, click OK.

G E O M E T R Y  M O D E L I N G

1 From the Draw menu select Work Plane Settings.

2 On the Quick page go to the Plane area. Click the option button for the y-z plane.

3 Click OK.

4 Create four rectangles. Shift-click the Rectangle/Square button on the Draw toolbar 
for each one and enter the data from this table:

5 Click the Zoom Extents button on the Main menu.

6 Copy rectangle R4 by selecting it and then pressing Ctrl+C.

NAME EXPRESSION

T_air 293

h_air 5

q_source 0.2/(0.5e-3*3e-3*8e-3)

p 1.013e5

RECTANGLE WIDTH HEIGHT X Y

R1 0.002 35e-6 0 0

R2 5.25e-4 4.5e-5 9.75e-4 3.5e-5

R3 5.25e-4 5.5e-4 9.75e-4 8e-5

R4 6e-3 5e-4 1e-3 1.05e-4
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7 Click the Create Composite Object button on the Draw toolbar. (Alternatively, select 
Create Composite Object from the Draw menu.)

8 In the Set formula edit field type R3-R4, then click OK.

9 Paste a copy of R4 with zero displacement. To do so, press Ctrl+V, then click OK in 
the Paste dialog box.

10 Click the 2nd Degree Bezier Curve button on the Draw toolbar.

11 Draw a curve between the upper corner of the termination and the left corner of the 
copper plate as in the figure below. You may want to zoom in the area before you 
start drawing the curve. Draw the line by clicking the coordinates  
(9.75·10−4, 6.3·10−4), (8·10−4, 2·10−4), and (0, 3.5·10−5). The coordinates that 
the mouse is pointing to appears in the lower left corner of the user interface. 

12 After clicking the third coordinate pair click the Line button on the Draw toolbar. 
This allows you to continue the drawing with lines along the copper plate boundary 
and the termination boundary. Click on the coordinates  
(9.75·10−4, 3.5·10−5) and (9.75·10−4, 6.3·10−4). Then complete the drawing by 
right-clicking using the mouse. The drawing should now look like in this figure:

13 Copy the objects R1, R2, CO1, and CO2 by selecting them and pressing Ctrl+C.
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14 Paste the objects by pressing Ctrl+V. Go to the displacement area, and in the x edit 
field type 0.006. Click OK.

15 From the Draw menu select Modify>Scale. Find the Scale factor area, then in the x edit 
field type -1. Go to the Scale base point area and in the x edit field type 0.007. Click 
OK.

16 Click the Zoom Extents button on the Main toolbar.

17 Click the Line button on the Draw toolbar and draw a line between the coordinates 
(0.002, 0) and (0.006, 0).

18 To finalize the geometry select all the objects by pressing Ctrl+A and click the Coerce 

to Solid button on the Draw toolbar.

19 Shift-click the Rectangle/Square button. Specify settings according to the following 
table. When done, click OK. 

20 Open the Extrude dialog box from the Draw menu.

21 From the Objects to extrude list select CO5. In the Distance edit field type 1.5e-3, 
then click OK.

22 Return to the 2D geometry by clicking the Geom1 tag.

23 Open the Extrude dialog box from the Draw menu.

24 Select R1 from the Objects to extrude list and type 4e-3 in the Distance edit field. 
Click OK.

M E S H  G E N E R A T I O N

1 From the Draw menu, select Create Pairs. Select both EXT1 and EXT2. Clear the 
Create imprints check box so that the meshes of the two extruded objects do not 
have to match at their shared boundary. This makes the mesh generation easier and 
reduces the number of elements.

2 Click OK.

3 Open the Mapped Mesh Parameters dialog box from the Mesh menu, then click the 
Edge tab.

4 Select 1 from the Edge selection list. Select the Constrained edge element distribution 

check box and enter 5 in the Number of edge elements edit field.

5 Repeat Step 4 for Edge 2, but leave the number of edge elements at its default value 
10.

WIDTH HEIGHT BASE X Y

16e-3 1.6e-3 Center 4e-3 -8.0e-4
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6 Click the Boundary tab and select 1 from the Boundary selection list.

7 Click Mesh Selected, then click OK.

8 Open the Swept Mesh Parameters dialog box from the Mesh menu.

9 Select Subdomain 1, then press Ctrl+A to select all subdomains.

10 Select the Manual specification of element layers check box and type 10 in the Number 

of element layers check box. Click OK.

11 Click the Subdomain mode button on the Main toolbar.

12 Select only the PCB domain, that is, the largest subdomain.

13 Click Mesh>Interactive Meshing>Mesh Selected (Swept).

14 Click Mesh>Interactive Meshing>Mesh Remaining (Swept).

The meshed geometry in the drawing area should now look like that in the following 
figure:

P H Y S I C S  S E T T I N G S

1 From the Multiphysics menu open the Model Navigator.

2 In the Multiphysics area on the right side of the dialog box select Geom2. In the list 
of application modes on the left select Structural Mechanics Module>Thermal-

Structural Interaction>Solid, Stress-Strain with Thermal Expansion.

3 Click OK.
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Subdomain Settings
1 From the Multiphysics menu, select Geom2: Solid, Stress-Strain.

2 From the Physics menu select Subdomain Settings.

3 Click the Load tab (not the Load button), then select all subdomains. In the Tempref 
edit field type T_air.

4 Click the Material tab.

5 Select Subdomain 1. Click the Load button to open the Materials/Coefficients Library 
dialog box. Select Basic Material Properties>FR4 (Circuit board). Click OK.

6 Repeat the previous step for the other subdomains with materials according to the 
following table:

7 Select Subdomain 7, then clear the Active in this domain check box.

8 Click OK to close the dialog box.

9 Change the active application mode. From the Multiphysics menu select Geom2: 

General Heat Transfer.

10 From the Physics menu select Subdomain Settings. Go to the Conduction page, select 
Subdomain 1, and then select FR4 (Circuit board) from the Library material list.

11 Repeat for the other subdomains according to:

12 Go to the Init page. Select all subdomains and in the Temperature edit field, type 
T_air. Click OK.

Boundary Conditions
1 From the Physics menu open the Boundary Settings dialog box.

2 Select the exterior boundaries in contact with air, that is, Boundaries 3, 4, 8, 12, 19, 
29, 30, 44, 46, and 52–63. In the Boundary condition list select Heat flux.

3 In the Heat transfer coefficient edit field type h_air, and in the External temperature 

edit field type T_air. Click OK.

PROPERTY SUBDOMAINS 2, 8 SUBDOMAINS 3, 4, 9, 11 SUBDOMAINS 5, 10 SUBDOMAIN 6

Material Copper Solder, 60Sn-40Pb Ag Alumina

PROPERTY SUBDOMAINS 
2, 8

SUBDOMAINS 
3, 4, 9, 11

SUBDOMAINS 
5, 10

SUBDOMAIN 6 SUBDOMAIN 7

Material Copper Solder, 
60Sn-40Pb

Ag Alumina Air, 1atm

Q 0 0 0 q_source 0
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4 In the Multiphysics menu change the active application mode to 
Geom2: Solid, Stress-Strain.

5 From the Physics menu open the Boundary Settings dialog box.

6 Select Boundaries 1, 7, 10, 13, 16, 20, 33, 37, 40, and 48. Select Symmetry plane 
from the Constraint condition list.

7 Select Boundaries 2 and 5. Select Fixed from the Constraint condition list. Click OK.

C O M P U T I N G  T H E  S O L U T I O N

The solution procedure runs in two steps: first solving for the temperature field, then 
solving for the stresses. Do so by using solver scripting to record the solver commands 
and then run them.

1 From the Solve menu open the Solver Manager dialog box.

2 On the Solve For page select Geom2>General Heat Transfer (htgh). Click Apply.

3 In the Script page select the Solve using a script check box, then click the Add Current 

Solver Settings button.

4 On the Solve For page select Geom2>Solid, Stress-Strain (smsld).

5 In the Initial Value page go to the Values of variable not solved for and linearization 

point area and select the Current solution button. Click OK.

6 From the Solve menu open the Solver Parameters dialog box.

7 In the Linear system solver list select Direct (SPOOLES) to take advantage of the 
symmetric system matrices. Click OK.

8 From the Solve menu select the Solver Manager. Click the Script tab, then click the 
Add Current Solver Settings button. Click OK.

9 Click the Solve button on the Main toolbar. The second part of the solution script 
is rather memory intensive when using a direct solver. The calculations require 
approximately 500 MB of free memory.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To reproduce the temperature plot in Figure 15-6:

1 From the Postprocessing menu open the Plot Parameters dialog box.

2 Click the General tab.

3 In the Plot type area clear the Slice check box and select the Isosurface check box.

4 Click the Isosurface tab.

5 From the Predefined quantities list select General Heat Transfer (htgh)>Temperature.
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6 In the Isosurface levels area click the Levels button, then type 30 in the Number of 

levels edit field. Click the Color Data tab and select the Color data check box. From 
the Predefined quantities list select General Heat Transfer (htgh)>Temperature.

7 Click Apply.

8 Click the Scenelight button on the Camera toolbar to finish off the plot.

To reproduce Figure 15-7:

1 While still on the Isosurface page in the Plot Parameters dialog box, change the 
Number of levels to 15.

2 In the Fill style list select Wireframe.

3 Click the Subdomain tab and enable this plot type by selecting the Subdomain plot 
check box at the top of the dialog box. From the Predefined quantities list select 
Solid, Stress-Strain (smsld)>von Mises stress.

4 Click the Deform tab and select the Deformed shape plot check box.

5 In Domain types to deform area clear the Boundary and Edge check boxes. 

6 In the Deformation data area click the Subdomain Data tab, then select 
Solid, Stress-Strain (smsld)>Displacement from the Predefined quantities list.

7 Click OK.

To reproduce Figure 15-8: 

1 From the Options menu select Suppress>Suppress Subdomains.

2 Select Subdomains 1, 2, 5, 6, 7, 8, and 10, then click OK.

3 From the Postprocessing menu open the Plot Parameters dialog box.

4 In the General page, go to the Plot type area, clear the Isosurface and Deform check 
boxes. Click OK to generate the plot in Figure 15-8.
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Hea t i n g  C i r c u i t

Introduction

Small heating circuits find use in many applications. For example, in manufacturing 
processes they heat up reactive fluids. Figure 15-9 illustrates a typical heating device 
for this application. The device consists of an electrically resistive layer deposited on a 
glass plate. The layer causes Joule heating when a voltage is applied to the circuit. The 
layer’s properties determine the amount of heat produced.

Figure 15-9: Geometry of a heating device.

In this particular application, you must observe three important design considerations:

• Non-invasive heating

• Minimal deflection of the heating device

• Avoidance of overheating the process fluid

The heater must also work without failure. You achieve the first and second 
requirements by inserting a glass plate between the heating circuit and the fluid; it acts 
as a conducting separator. Glass is an ideal material for both these purposes because it 
is nonreactive and has a low thermal-expansion coefficient.

You must also avoid overheating due to the risk of self-ignition of the reactive fluid 
stream. Ignition is also the main reason for separating the electrical circuit from direct 
contact with the fluid. The heating device is tailored for each application, making 
virtual prototyping very important for manufacturers.

For heating circuits in general, detachment of the resistive layer often determines the 
failure rate. This is caused by excessive thermally induced interfacial stresses. Once the 
layer has detached, it gets locally overheated, which accelerates the detachment. 
Finally, in the worst case, the circuit might overheat and burn. From this perspective, 

Glass plate

Electric heater

Heated fluid
stream

Air
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it is also important to study the interfacial tension due to the different thermal-
expansion coefficients of the resistive layer and the substrate as well as the differences 
in temperature. The geometric shape of the layer is a key parameter to design circuits 
that function properly. You can investigate all of the above-mentioned aspects by 
modeling the circuit.

This multiphysics example simulates the electrical heat generation, the heat transfer, 
and the mechanical stresses and deformations of a heating circuit device. The model 
uses the General Heat Transfer application mode of the Heat Transfer module in 
combination with the Shell, Conductive Media DC application mode from the AC/
DC Module and the Solid, Stress-Strain and Shell application modes from the 
Structural Mechanics Module.

Note: This model requires the AC/DC Module, the Heat Transfer Module, and the 
Structural Mechanics Module.

Model Definition

Figure 15-10 shows a drawing of the modeled heating circuit. 

Figure 15-10: Drawing of the heating circuit deposited on a glass plate.

The device consists of a serpentine-shaped Nichrome resistive layer, 10 µm thick and 
5 mm wide, deposited on a glass plate. At each end, it has a silver contact pad 
measuring 10 mm × 10 mm × 10 µm. When the circuit is in use, the deposited side of 
the glass plate is in contact with surrounding air, and the back side is in contact with 
the heated fluid. Assume that the edges of the glass plate are thermally insulated.

Silver pads

Nichrome circuit
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Table 15-3 gives the resistor’s dimensions.

During operation the resistive layer produces heat. Model the electrically generated 
heat using the Shell, Conductive Media DC application mode from the AC/DC 
Module. The governing equation is

where  d is the thin layer’s thickness (m), σ is the electric conductivity (S/m), V is the 
electric potential (V), and  denotes the gradient operator in the tangential 
directions. An actual applies 12 V to the pads. In the model you achieve this effect by 
setting the potential at one edge of the first pad to 12 V and that of one edge of the 
other pad to 0 V.

To model the heat transfer in the thin conducting layer, use the Highly Conductive 
Layer feature of the General Heat Transfer application mode. It is then not necessary 
to add a separate application mode for it.

The heat power per unit area (measured in W/m2) produced inside the thin layer is 
given by

 (15-1)

where QDC = J · E =  (W/m3) is the power density. The generated heat 
appears as an inward heat flux at the surface of the glass plate. 

At steady state, the resistive layer dissipates the heat it generates in two ways: on its up 
side to the surrounding air (at 293 K), and on its down side to the glass plate. The glass 
plate is similarly cooled in two ways: on its circuit side by air, and on its back side by a 
process fluid (353 K). You model the heat fluxes to the surroundings using heat 
transfer film coefficients, h. For the heat transfer to air, h = 5 W/(m2·K), representing 
natural convection. On the glass plate’s back side, h = 20 W/(m2·K), representing 
convective heat transfer to the fluid. The sides of the glass plate are insulated.

TABLE 15-3:  DIMENSIONS

OBJECT DIMENSION SIZE

glass plate length 130 mm

width 80 mm

thickness 2 mm

pads and circuit thickness 10 µm

∇t dσ∇tV–( )⋅ 0=

∇t

qprod d QDC=

σ ∇tV
2
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The resulting heat transfer equation for the device, together with the boundary 
condition used to describe the heat fluxes at the front and back sides, is

where n is the normal vector of the boundary, k is the thermal conductivity (W/
(m·K)), h is the heat transfer film coefficient (W/(m2·K)), and Tinf is the temperature 
(K) of the surrounding medium. The last term on the right-hand side represents the 
additional flux given by the thin conducting layer, and the constant ks is the thermal 
conductivity in the layer (W/(m·K)). This term is only present on the boundaries 
where the layer is present. Similarly, the inward heat flux, q0, is equal to qprod (see 
Equation 15-1) at the layer but vanishes elsewhere.

The model simulates thermal expansion using static structural-mechanics analyses. It 
uses the Solid, Stress-Strain application mode for the glass plate, and the Shell 
application mode for the circuit layer. The equations of these two application modes 
are described in the Structural Mechanics Module User’s Guide. The stresses are set 
to zero at 293 K. You determine the boundary conditions for the Solid, Stress-Strain 
application mode by fixing one corner with respect to x-, y-, and z-displacements and 
rotation.

Table 15-4 summarizes the material properties used in the model.

TABLE 15-4:  MATERIAL PROPERTIES

MATERIAL E [GPa] ν α [ppm] k [W/(m·K)] ρ [kg/m3] Cp [J/(kg·K)]

Silver 83 0.37 18.9 420 10500 230

Nichrome 213 0.33 10.0 15 9000 20

Glass 73.1 0.17 55 1.38 2203 703

∇ k∇T–( )⋅ 0=

n– k∇T–( )⋅ q0 h Tinf T–( ) ∇t ds ks∇tT–( )⋅–+=
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Results and Discussion

Figure 15-11 shows the heat that the resistive layer generates.

Figure 15-11: Stationary heat generation in the resistive layer when 12 V is applied.

The highest heating power arises in the inner corners of the curves due to the higher 
current density at these spots. The total generated heat, as calculated by integration, is 
approximately 13.8 W.
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Figure 15-12 shows the temperature of the resistive layer and the glass plate at steady 
state.

Figure 15-12: Temperature distribution in the heating device at steady state.

The highest temperature is approximately 430 K, and it appears in the central section 
of the circuit layer. It is interesting to see that the differences in temperature between 
the fluid side and the circuit side of the glass plate are quite small because the plate is 
very thin. Using boundary integration, the integral heat flux on the fluid side evaluates 
to approximately 8.5 W. This means that the device transfers the majority of the heat 
it generates—8.5 W out of 13.8 W—to the fluid, which is good from a design 
perspective, although the thermal resistance of the glass plate results in some losses.

The temperature rise also induces thermal stresses due the materials’ different 
coefficients of thermal expansion. As a result, mechanical stresses and deformations 
arise in the layer and in the glass plate. Figure 15-13 shows the effective stress 
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distribution in the device and the resulting deformations. During operation, the glass 
plate bends towards the air side.

Figure 15-13: The thermally induced von Mises effective stress plotted with the 
deformation.

The highest effective stress, approximately 7 MPa, appears in the corners of the silver 
pads. The yield stress for high quality glass is roughly 250 MPa, and for Nichrome it 
is 360 MPa. This means that the individual objects remain structurally intact for the 
simulated heating power loads.

You must also consider stresses in the interface between the resistive layer and the glass 
plate. Assume that the yield stress of the surface adhesion in the interface is in the 
region of 50 MPa—a value significantly lower than the yield stresses of the other 
materials in the device. If the effective stress increases above this value, the resistive 
layer will locally detach from the glass. Once it has detached, heat transfer is locally 
impeded, which can lead to overheating of the resistive layer and eventually cause the 
device to fail.

Figure 15-14 displays the effective forces acting on the adhesive layer during heater 
operation. As the figure shows, the device experiences a maximum interfacial stress that 
is an order of magnitude smaller than the yield stress. This means that the device will 
be OK in terms of adhesive stress.
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Figure 15-14: The effective forces in the interface between the resistive layer and the glass 
plate.

Finally study the device’s deflections, depicted in Figure 15-15.

Figure 15-15: Total displacement on the fluid side of the glass plate.
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The maximum displacement, located at the center of the plate, is approximately 
30 µm. For high-precision applications, such as semiconductor processing, this might 
be a significant value that limits the device’s operating temperature.

Model Library path: Structural_Mechanics_Module/Thermal-
Structure_Interaction/heating_circuit

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator.

2 In the Space dimension list select 3D. Click the Multiphysics button.

3 From the list of application modes select AC/DC Module>Statics>Shell, Conductive 

Media DC. In the Application mode name edit field type DC, then click Add.

4 From the list of application modes select Heat Transfer Module>General Heat Transfer, 
then click Add.

5 Similarly add two more application modes: Structural Mechanics Module>Solid, 

Stress-Strain and Structural Mechanics Module>Shell. When done, click OK.

O P T I O N S  A N D  S E T T I N G S

From the Options menu select Constants. Define the following names, expressions, and 
descriptions (the descriptions are optional); when done, click OK.

NAME EXPRESSION DESCRIPTION

V_in 12[V] Input voltage

d_layer 10[um] Layer thickness

sigma_Silver 6.3e7[S/m] Electric conductivity of silver

sigma_Nichrome 9.3e5[S/m] Electric conductivity of Nichrome

T_ref 293[K] Reference temperature

T_air T_ref Air temperature

h_air 5[W/(m^2*K)] Heat transfer film coefficient, air

T_fluid 353[K] Fluid temperature

h_fluid 20[W/(m^2*K)] Heat transfer film coefficient, fluid
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G E O M E T R Y  M O D E L I N G

1 Create a 2D work plane at z = 0 by first choosing Draw>Work-Plane Settings and then 
clicking OK in the dialog box that appears to accept the default settings.

2 Create nine rectangles. Open the Draw>Specify Objects>Rectangle dialog box, and 
for each one enter the appropriate data from this table:

3 Click the Zoom Extents button on the Main toolbar.

4 Create a circle with the menu item Draw>Specify Objects>Circle. In the Radius edit 
field type 0.01, then click OK.

5 Create another circle the same way bit with a Radius of 0.005.

6 Click the Create Composite Object button on the Draw toolbar. In the Set formula 
edit field type C1-C2-R2, then click OK. This step generates the composite object 
CO1.

7 Select CO1 by clicking on it, click the Mirror button on the Draw toolbar, then click 
OK. This step creates a mirror copy of CO1 called CO2.

8 Select CO2 and then click the Move button on the Draw toolbar. Go to the 
Displacement area, and in the y edit field type 0.015. Click OK.

9 Select both CO1 and CO2 by pressing Ctrl while clicking on the objects. Copy both 
by pressing Ctrl+C.

10 Paste twice by pressing Ctrl+V, specifying the displacement, and clicking OK. For the 
first copy specify the y-displacement as 0.030, and for the second specify 0.060.

11 Select CO1, copy it, and paste it with zero displacement.

12 Click the Rotate button on the Draw toolbar. In the Rotation angle edit field type 
-90, then click OK.

RECTANGLE WIDTH HEIGHT X-BASE Y-BASE

R1 0.08 0.13 -0.02 -0.035

R2 0.01 0.02 -0.01 -0.01

R3 0.005 0.075 0.015 0

R4 0.01 0.005 0 0.08

R5 0.01 0.01 0 0.075

R6 0.005 0.015 0.045 0.06

R7 0.02 0.005 0.02 -0.025

R8 0.01 0.01 0.01 -0.027

R9 0.01 0.01 -0.013 -0.025
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13 Click the Move button on the Draw toolbar. In the x edit field type 0.025, then click 
OK.

14 Click the Mirror button on the Draw toolbar. In the Normal vector edit field for x 
type 0, and in the y edit field type 1. Click OK. 

15 Click the Move button on the Draw toolbar. In the x edit field type -0.015, and in 
the y edit field type 0.075. Click OK.

16 Click the Create Composite Object button on the Draw toolbar. In the Set formula 
edit field type CO8-R5, then click OK. This step generates composite object CO9.

17 Copy and paste CO9 with x- and y-displacements of -0.02 and -0.08, respectively.

18 Click the Rotate button on the Draw toolbar. In the α edit field in the Rotation angle 
area type 90, and in the y edit field in the Center point area type -0.005. Click OK.

19 Select objects CO7 and R3. Click the Mirror button on the Draw toolbar. In the 
Normal vector edit field for x type 0, and in the y edit field type 1. Click OK. 

20 Click the Move button on the Draw toolbar. Specify the displacement by typing 
0.015 in the x edit field and 0.075 in the y edit field, then click OK. These steps 
generate composite objects CO10 and CO11.

21 Select objects CO9 and R3. Using the Move dialog box, repeat the procedure in the 
previous two steps with values for the x- and y-displacements of 0.03 and 0.06. The 
geometry should now look like that in the following figure.

22 Select all objects except the glass plate (R1) and the silver tabs (R8 and R9). Click 
the Create Composite Object button on the Draw toolbar. Clear the Keep interior 

boundaries check box, then click OK. This step generates composite object CO14.

23 Select CO14, R8, and R9, then click the Coerce to Solid button on the Draw toolbar.
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M E S H  G E N E R A T I O N

1 From the Mesh menu open the Free Mesh Parameters dialog box.

2 On the Global page go to the Predefined mesh sizes list and select Coarse.

3 On the Subdomain page select Subdomain 3, then in the Maximum element size edit 
field type 2e-3.

4 Click the Remesh button, then click OK.

5 From the Mesh menu open the Extrude Mesh dialog box. On the Geometry page find 
the Distance edit field and type 2e-3. From the Extrude to geometry list select Geom1.

6 Click the Mesh tab. In the Number of element layers edit field type 2, then click OK.

7 Double-click the EQUAL button on the status bar at the bottom of the user interface, 
then click the Zoom Extents button on the Main toolbar to expand the geometry’s 
z-axis.

P H Y S I C S  S E T T I N G S

1 From the Options menu open the Materials/Coefficients Library dialog box.

2 Set up the materials silver and NiChrome. To do so, click New, then enter the 
settings from the following table in the corresponding edit fields. When done, click 
OK.

3 Choose Options>Expressions>Scalar Expressions. In the Name edit field type q_prod, 
and in the Expression edit field type d_layer*Q_DC. Enter Heat power per unit 
area inside thin layer in the Description edit field (optional). Click OK.

Boundary Settings—Shell, Conductive Media DC (DC)
1 From the Multiphysics menu select Shell, Conductive Media DC (DC).

2 From the Physics menu select Boundary Settings.

3 Select all the boundaries, then clear the Active in this domain check box.

4 Select Boundary 14, then click the Active in this domain check box. In the Electric 

conductivity edit field for σ (isotropic) type sigma_Nichrome, and in the Layer 
thickness edit field type d_layer.

5 Repeat the previous step for Boundaries 9 and 47 but in the Electric conductivity edit 
field type sigma_Silver. Click OK.

6 From the Physics menu select Edge Settings.

NAME C E alpha k nu rho

Silver 230 83e9 18.9e-6 420 0.37 10500

Nichrome 230 213e9 10e-6 15 0.33 9000
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7 Select Edge 13. In the Boundary condition list select Electric potential, then in the 
Electric potential edit field type V_in.

8 Select Edge 109. In the Boundary condition list select Ground, then click OK.

Subdomain Settings—General Heat Transfer
1 From the Multiphysics menu select General Heat Transfer (htgh).

2 From the Physics menu open the Subdomain Settings dialog box, then select all the 
subdomains.

3 Go to the Conduction page. Click the Load button. From the Materials list select 
Library1>Silica Glass, then click OK.

4 Go to the Init page, and in the T(t0) edit field type T_ref. Click OK.

Boundary Conditions—General Heat Transfer
1 From the Physics menu open the Boundary Settings dialog box. Select Boundaries 9, 

14, and 47.

2 Click the Highly Conductive Layer tab. Select the Enable heat transfer in highly 

conductive layer check box, then in the ds edit field type d_layer.

3 Select Boundary 14. In the Library material list select Nichrome.

4 Similarly, for Boundaries 9 and 47 select Silver.

5 Click the Boundary Condition tab. Select Boundaries 9, 14, and 47. In the Boundary 

condition list select Heat flux. In the q0 edit field type q_prod, in the h edit field type 
h_air, and in the Tinf edit field type T_air.

6 Repeat the settings in the previous step for Boundary 4 but without specifying q0.

7 Select Boundaries 3, 8, 13, and 46. In the Boundary condition list select Heat flux. In 
the h edit field type h_fluid, and in the Tinf edit field type T_fluid. Click OK.

Subdomain Settings—Solid, Stress-Strain
1 From the Multiphysics menu select Solid, Stress-Strain (smsld).

2 From the Physics menu open the Subdomain Settings dialog box, then select all the 
subdomains.

3 Go to the Material page. In Library material list select Silica Glass.

4 Click the Load tab. Select the Include thermal expansion check box. In the Temp edit 
field type T and in the Tempref edit field type T_ref.

5 Go to the Element page. In the Predefined elements list select Lagrange - Linear. Click 
OK.
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Point Settings—Solid, Stress-Strain
1 From the Physics menu open the Point Settings dialog box.

2 Select Point 1. Select the check boxes next to Rx, Ry, and Rz.

3 Select Point 3, then select the Rz check box.

4 Select Point 125, then select the Ry and Rz check boxes. Click OK.

Boundary Settings—Shell
1 From the Multiphysics menu select Shell (smsh).

2 From the Physics menu open the Boundary Settings dialog box.

3 Select all the boundaries, then clear the Active in this domain check box.

4 Select Boundaries 9, 14, and 47. Select the Active in this domain check box.

5 In the thickness edit field type d_layer.

6 Go to the Load page. Select the Include thermal expansion check box. In the Temp 
edit field type T and in the Tempref edit field type T_ref.

7 Click the Material tab. Select Boundaries 9 and 47. In the Library material list select 
Silver.

8 Similarly, for Boundary 14 select Nichrome. Click OK.

C O M P U T I N G  T H E  S O L U T I O N

This model is best solved using a script. Follow these steps to create the script and solve 
the model.

1 From the Solve menu open the Solver Manager.

2 On the Solve For page select Geom1 (3D)>Shell, Conductive Media DC (DC) and 
Geom1 (3D)>General Heat Transfer (htgh), then click Apply.

3 Go to the Script page. Select the Solve using a script check box. Then click the Add 

Current Solver Settings button to generate the first half of the script.

4 From the Solve menu, choose Solver Parameters.

5 In the Linear system solver list select Direct (SPOOLES) to use this solver’s ability to 
utilize the symmetric system matrices. Click OK.

6 Return to the Solver Manager. Go to the Initial Value page, then to the Initial value 
area, and click the Current solution option button.

7 Go to the Solve For page. Select Geom1>Solid, Stress-Strain (smsld) and Geom1>Shell 

(smsh). Click Apply.
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8 On the Script page click the Add Current Solver Settings button to generate the 
second half of the script. Click OK to close the Solver Manager.

9 Finally, click the Solve button on the Main toolbar to compute the solution.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Generate Figure 15-11 as follows:

1 From the Postprocessing menu open the Plot Parameters dialog box.

2 On the General page clear the Slice check box, then select the Boundary check box.

3 Go to the Boundary page. In the Expression edit field type q_prod. Click OK.

4 Click the Zoom Extents button on the Main toolbar.

To calculate the total heat generated in the circuit, follow these steps:

1 From the Postprocessing menu open the Boundary Integration dialog box.

2 Select Boundaries 9, 14, and 47. In the Expression edit field type q_prod. Click OK. 

The calculated value, roughly 13.8 W, appears in the message log at the bottom of 
the graphical user interface.

Generate Figure 15-12 by executing these instructions:

1 From the Postprocessing menu open the Plot Parameters dialog box. On the General 

page go to the Plot type area and select the Slice, Boundary, and Deformed shape check 
boxes.

2 Go to the Slice page, and in the Predefined quantities list select Temperature (htgh). 
In the Slice positioning area find the x levels edit field and type 0, and in the y levels 
edit field type 1.

3 Click the option button for Vector with coordinates associated with z levels, then in 
the corresponding edit field type 0.

4 On the Boundary page find the Expression edit field and type T*q_prod/q_prod.

The use of q_prod/q_prod makes the expression for the temperature valid on the 
resistive layer boundary only, which is the desired effect.

5 On the Deform page, go to the Deformation data area and click the Subdomain Data 
tab. In the Predefined quantities list select Solid, Stress-Strain (smsld)>Displacement.

6 While still in the Deformation data area, click the Boundary Data tab. In the Predefined 

quantities list select Shell (smsh)>Displacement. Click Apply.

Calculate the total heat flux to the fluid in the following way:
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1 From the Postprocessing menu open the Boundary Integration dialog box.

2 Select Boundaries 3, 8, 13, and 46. In the Expression edit field type h_fluid*(T-
T_fluid), then click OK.

A value for the total heat flux of approximately 8.47 W appears in the message log.

To generate Figure 15-13 follow these steps:

1 While still in the Plot Parameters dialog box, go to the Slice page. In the Predefined 

quantities list select Solid, Stress-Strain (smsld)>von Mises stress. 

2 Click the Boundary tab. In the Predefined quantities list select Shell (smsh)>von Mises 

stress. Click Apply.

Figure 15-14 is obtained by executing the following instructions: 

1 From the Postprocessing menu select Domain Plot Parameters.

2 On the Surface page select Boundaries 9, 14, and 47. In the Expression edit field type 
sqrt(Tax_smsld^2+Tay_smsld^2). Click Apply.

This gives a plot of the norm of the surface traction vector (N/m2) in the surface 
plane,

Finally, to obtain Figure 15-15, proceed as follows:

1 Still on the Surface page of the Domain Plot Parameters dialog box, select Boundaries 
3, 8, 13, and 46.

2 In the Predefined quantities list select Solid, Stress-Strain (smsld)>Total displacement, 
then click OK.

Tax

Tay

σx τxy τxz

τyx σy τyz

0
0
1

τxz

τyz

= =
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S imu l a t i o n  o f  a  M i c r o r o bo t  L e g

Introduction

This example describes the modeling of one of the legs of a silicon microrobot. 
Figure 15-16 below shows the microrobot leg.

The microrobot uses a technique based on polyimide V-groove joints to get each of 
the legs to move. The polyimide has a relatively high coefficient of thermal expansion 
α, which causes the leg to bend slightly when the polyimide is heated. Putting several 
V-grooves on each leg provides sufficient deflection (see Figure 15-16).

See Ref. 1 for a more detailed description of the microrobot.

Note: This model requires the Heat Transfer Module and the Structural Mechanics 
Module.

Model Definition

The model is a transient heat transfer analysis combined with a quasi-static thermal 
deformation analysis.

The materials used in the microrobot leg are: Si, SiN, Al, P, SiO, and pSi. They are 
assembled as shown below:

Figure 15-16: Cross-section cut of the microrobot leg.

Heating resistors (pSi)

Silicon leg (Si)Cured polyimide (P)

SiN

Composite layer 
(Al and SiO)
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The geometry of the model comes from an initial 2D geometry using mesh extrusion.

Figure 15-17: 3D extruded mesh of the microbot leg.

The heat is generated by resistive heating. An electric potential of 30 mV is applied in 
each of two heating resistors during the first 10 ms of the 20 ms of the simulation. The 
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resulting heat source generated is about 2·1013 W/m3, corresponding to 100 mW 
(see Figure 15-18).

Figure 15-18: Heat source vs. time in the heating resistors.

An important part of the simulation is the modeling of the cooling effects at the 
boundaries. Experimentally, it has been verified that most of the heat is dissipated in 
the silicon structure, that is, the “body” of the robot. Also, a minor cooling effect at 
the tip of the leg has been observed. Motivated by this, the model uses a heat transfer 
coefficient of 1·106 W/(m2·K) on the part of the leg connected to the rest of the 
robot, and a coefficient of 1·105 W/(m2·K) on the tip of the leg. These values have 
been chosen somewhat arbitrarily, but the results have been calibrated with 
experimental data.

The boundary conditions for the structural mechanics part are simply constrained 
displacement at the left end of the robot leg and zero force on the rest of the structure.

The 3D model does not include the thin layer of Al and SiO. On the resulting 
boundary, a structural shell application mode and two specific thermal boundary 
conditions model the highly conductive and poorly conductive layer.
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The heat propagates by conduction through the leg, and thermal expansion and 
different thermal expansion coefficients of the several materials induce a bending 
action.

Results and Discussions

Figure 15-19 below shows the bending action at t = 0.2 ms. The plot also includes the 
temperature at the boundary.

Figure 15-19: Temperature distribution in the microrobot at 20ms

The plots shows that the leg bends as expected with the increase of temperature and 
moves toward its original position when the heat source is turned off. 

Figure 15-20 below shows the total displacement as a function of time at the tip of the 
leg.
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Figure 15-20: Total displacement at the tip of the leg

To verify the validity of the highly conductive and resistive layer, a cross-section plot 
of the temperature focuses on the middle of the V-groove joints (see Figure 15-21).

Figure 15-21: Position of the cross-section plot.

You can observe the effect of the thin layer at the positions z = −1.1·10−4, −0.6·10−4, 
−0.2·10−4, 0.2·10−4, 0.6·10−4, and 1.1·10−4 m in a cross-section plot of the 
temperature inside the microrobot leg (see Figure 15-22).
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Figure 15-22: A cross-section plot of the temperature distribution inside the microbot leg.

The small dips at z = −0.2·10−4 m and 1.1·10−4 m correspond well with a 2D model 
where the thin composite layers are modeled using solids instead of the highly and 
resistive conductive layers and structural shell elements.

Modeling in COMSOL Multiphysics

The original 2D model consists of thin layers, and it is essential to remove these layer 
in order to reduce the mesh size in the 3D model. Instead, apply the following 
boundary conditions:

• For the thermal part, a highly conductive boundary condition replaces the highly 
conductive layer of aluminum (see Figure 15-16):

 

• Represent the resistive layer (see Figure 15-16) with the stiff spring condition

n k∇T–( )⋅– dρ C∂T
∂t
-------– ∇ dk∇T–( )⋅–=
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where klayer is the thermal conductivity of the material, d the thickness of the layer, 
and T1 and T2 are the temperatures on the each side of the boundary.

Note that because the stiff spring boundary condition models a temperature 
discontinuity on the boundary, you need two General Heat Transfer applications 
modes.

• The structural part includes a shell element with thermal expansion to model the 
two thin layers. The software handles the coupling between the shell and the solid 
elements automatically.

Figure 15-23 shows where the shell application and the thermal boundary conditions 
are active.

Figure 15-23: Location of the shell element and thermal boundary condition.

Because the time scale of the structural mechanics part is much smaller compared with 
the heat transfer part, you can neglect the mass effects in the structural analysis. Instead 
use a parametric analysis to solve the structural mechanics part. This problem only 
couples the solid analysis to the heat transfer analysis, and not the other way around, 
so you can use sequential solution procedure: First solve the heat transfer and 
conductive media DC equations, and then, after storing the solution in a file and 

n k∇T2–( )⋅–
klayer

d
------------------- T1 T2–( )⋅=
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setting the linearization point to the stored solution, solve the structural part using the 
parametric analysis with the time variable t as the parameter.

Reference

1. T. Ebefors, “Polyimide V-groove Joints for Three-Dimensional Silicon 
Transducers,” Ph.D. thesis, May 2000, Dept. of Signal, Sensors and Systems (S3), 
Royal Institute of Technology (KTH), Stockholm, Sweden.

Model Library path: Structural_Mechanics_Module/Thermal-
Structural_Interaction/microrobot_3d

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics or click the New button to open the Model Navigator.

2 Select 3D in the Space dimension list.

3 Click the Multiphysics button.

4 Select Structural Mechanics Module>Thermal-Structural Interaction> Solid, Stress-

Strain with Thermal Expansion and then Quasi-static analysis.

5 Click Add.

6 Open Structural Mechanics Module>Shell and select Quasi-static analysis.

7 Click Add.

8 Open Heat Transfer Module>General Heat Transfer and select Transient Analysis.

9 Click Add.

10 Open COMSOL Multiphysics>Electromagnetics>Conductive Media DC.

11 Click Add.

12 Click OK.

G E O M E T R Y  M O D E L I N G

You obtain the geometry of this model by extruding the mesh of the 2D cross-section 
geometry. The 2D geometry is provided as a DXF file.

1 Go to the Draw menu, and select Work-Plane Settings.
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2 Click the y-z plane button, then click OK.

3 On the File menu point to Import, then click CAD Data From File.

4 Browse to COMSOL_Multiphysics/Multiphysics in the COMSOL models folder.

5 Select microrobot.dxf, then click OK.

6 Click the Zoom Extents button.

7 Click the Coerce to Solid button.

8 On the Draw menu choose Extrude, then define the following extrusion parameters: 
Distance as 4e-5, Scale y as 0.95, and Displacement x as 5e-6.

9 Click OK.

10 Click the Geom2 tab.

11 Select Extrude from the Draw menu and use the same settings except for the Distance. 
In the Distance edit field type -4e-5.

12 Click OK.

13 Select both EXT1 and EXT2, then click the Coerce to Solid button on the Draw 
toolbar.
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P H Y S I C S  S E T T I N G S

Because the microrobot legs consists of several materials with different material 
properties, you have to define subdomain settings for each materials. Using subdomain 
expression variables makes it easier to enter the subdomain properties of the model.

Define the following parameters for the materials:

• The thermal conductivity, k

• The heat capacity, C

• The density, rho

• Young’s modulus, E

• Poisson’s ratio, nu

• The thermal expansion coefficient, alpha

Also define a new variable, Temperature, to visualize the temperature in all domains 
in the postprocessing analysis.

Subdomain Expressions
1 On the Options menu, point to Expressions and then click Subdomain Expressions.

2 In the Subdomain Expressions dialog box, enter the following material properties:

From left to right the material properties represent Si, SiN, P, and pSi, respectively

3 Click OK.

Use shell elements to model the thin layer. This means that you must define the 
material properties as boundary expressions.

4 On the Options menu, point to Expressions and then click Boundary Expressions.

SETTINGS SUBDOMAINS 1, 
4, 7, 10, 12, 15, 18, 
21

SUBDOMAINS 2, 
5, 8, 11, 13, 16, 19, 
22

SUBDOMAINS 3, 
14

SUBDOMAINS 6, 
9, 17, 20

k 140 15 0.16 20

C 707 1000 2000 707

rho 2300 2865 2700 2300

E 130e9 95e9 2e9 160e9

nu 0.3 0.25 0.35 0.3

alpha 2.5e-6 0.8e-6 140e-6 2e-6

Temperature T T T2 T
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5 Enter the following material properties:

Subdomain Settings
1 On the Multiphysics menu, select Solid, Stress-Strain(smsld).

2 Go to Physics>Subdomain Settings and select all subdomains.

3 Enter the following settings for the material properties on the Material page:

4 Click the Load tab, and select the Include thermal expansion check box.

5 Select Subdomains 3 and 14, then type T2 in the Temp edit field.

6 Select all subdomains and type 273.15 in the Tempref edit field.

7 Click OK.

8 In the Multiphysics menu, select General Heat Transfer (htgh).

9 Go to the Subdomain Settings dialog box and select all the subdomains.

10 Enter the following material properties: Thermal conductivity k, Density rho and Heat 

capacity C.

11 Select Subdomains 6, 9, 17, and 20, then type Q_dc in the Heat source edit field.

The coupling between the electric and heat transfer problems is now complete. The 
resistive heating from the Current Media DC application mode is used as the heat 
source in the General Heat Transfer application to evaluate the resulting temperature 
distribution.

1 Select Subdomains 3 and 14, then clear the Active in this domain check box.

SETTINGS BOUNDARIES 8, 11, 14, 26, 27, 
31, 34, 36, 48, 49, 53, 56, 58, 70, 
71, 73, 83, 86, 89, 101, 102, 106, 
109, 111, 123, 124, 128, 131, 133, 
145, 146, 148

BOUNDARIES 15, 17, 20, 37, 
39, 42, 59, 61, 64, 90, 92, 95, 
112, 114, 117, 134, 136, 139

E_layer 70e9 70e9

nu_layer 0.3 0.26

alpha_layer 23e-6 2.35e-5

thickness 2e-6 2e-6

rho_layer 1410 1805

PROPERTY VALUE

E E

ν nu

α alpha

ρ rho
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2 Click OK.

3 Select General Heat Transfer (htgh2) in the Multiphysics menu.

4 In the Subdomain Settings dialog box, select all subdomains except 3 and 14, then 
clear the Active in this domain check box.

5 Select Subdomains 3 and 14, then set the Thermal conductivity to k, the Heat capacity 
to C, and the Density to rho.

6 Click OK.

7 Select Conductive Media DC (dc) in the Multiphysics menu.

8 In the Subdomain Settings dialog box, select Subdomains 6, 9, 17, and 20.

9 Type 1e8 in the Electric conductivity edit field.

10 Select all other subdomains and clear the Active in this domain check box.

11 Click OK.

Boundary Conditions
1 Select the Solid, Stress-strain application mode.

2 Select Physics>Boundary Settings, and select Fixed from the Constraint condition list 
on the Constraint page for Boundaries 74, 75, 149, and 150.

3 Click OK.

4 Select Shell (smsh) in the Multiphysics menu.

5 In the Boundary Settings dialog box, select Boundaries 8, 11, 14, 15, 17, 20, 26, 27, 
31, 34, 36, 37, 39, 42, 48, 49, 53, 56, 58, 59, 61, 64, 70, 71, 73, 83, 86, 89, 90, 
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92, 95, 101 102, 106, 109, 111, 112, 114, 117, 123, 124, 128, 131, 133, 134, 
136, 139, 145, 146, and 148.

6 Set Young’s modulus to E_layer, Poisson’s ratio to nu_layer, and the thickness to 
thickness.

7 Select the other boundaries and clear the Active in this domain check box.

8 Click the Load tab.

9 Select all the active boundaries and then select the Include thermal expansion check 
box.

10 Select Boundaries 11, 14, 15, 20, 26, 27, 31, 34, 36, 37, 42, 48, 49, 53, 56, 58, 
59, 64, 70, 71, 86, 89, 90, 95, 101, 102, 106, 109, 111, 112, 117, 123, 124, 128, 
131, 133, 134, 139, 145, and 146.

11 In the Temp edit field type T2, in the Tempref edit field type 273.15, and in the dT 
edit field type T-T2.

12 Select Boundaries 8, 73, 83, and 148, then enter T as Temp and 273.15 as Tempref.

13 Select Boundaries 17, 39, 61, 92, 114, and 136, then set T2 as Temp and 273.15 as 
Tempref.

14 Click OK.

15 In the Multiphysics menu, select General Heat Transfer (htgh).
S I M U L A T I O N  O F  A  M I C R O R O B O T  L E G  |  685



686 |  C H A P T E
16 In the Physics menu, select Boundary Settings.

17 Select Boundaries 74, 75, 149, and 150, then set a Heat flux boundary condition 
with h as 1e6.

18 Select Boundaries 8, 73, 83, and 148. Click the Highly Conductive Layer tab, and 
select the Enable heat transfer in highly conductive layer check box.

19 Set ks as 238, ρs as 1410, Cp,s as 900, and ds as 2e-6.

20 Select Boundaries 11, 14, 26, 27, 31, 34, 36, 48, 49, 53, 56, 58, 70, 71, 86, 89, 
101, 102, 106, 109, 111, 123, 124, 128, 131, 133, 145, and 146, then set a 
Temperature boundary condition with T0 as T2.

21 Select Boundaries 15, 20, 37, 42, 59, 64, 90, 95, 112, 117, 134, and 139.

22 Set a Heat flux boundary condition with a heat transfer coefficient h as 1.4/1e-6 
and an external temperature Tinf as T2.

23 Select Boundaries 2, 5, 77, and 80.

24 Set a Heat flux boundary condition and enter 1e5 in the h field.

25 Click OK.

26 In the Multiphysics menu, select General Heat Transfer (htgh2).

27 In the Boundary Settings dialog box, select Boundaries 15, 20, 37, 42, 59, 64, 90, 
95, 112, 117, 134, and 139.

28 Set a Heat flux condition with h as 1.4/1e-6 and Tinf as T.

29 Click the Highly Conductive Layer tab and select the Enable heat transfer in highly 

conductive layer check box. In the ks edit field type 238, in the ρs edit field type 
1410, in the Cp,s edit field type 900, and finally in the ds edit field type 1e-6.

30 Select Boundaries 17, 39, 61, 92, 114, and 136.

31 Set the Highly conductive layer condition with ks as 238, ρs as 1410, Cp,s as 900, and 
ds as 2e-6.

32 Click OK.

33 In the Multiphysics menu, select Conductive Media DC (dc).

34 In the Boundary Settings dialog box, select all boundaries and select the Electric 

Insulation boundary condition.

35 Select Boundaries 28 and 50 and set an Electric potential condition, with V0 as 
(flc1hs(t[1/s]-1e-3,5e-4)-flc1hs(t[1/s]-1e-2,5e-4))*3e-2.

The electric potential is set to 30 mV during 9 ms starting at t = 1 ms. The 
smoothed Heaviside function flc1hs ensures continuity in the potential condition.
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36 Select Boundaries 156 and 159, then set a Ground boundary condition.

37 Click OK.

M E S H

1 From the Mesh menu choose Free Mesh Parameters.

2 From the Predefined mesh sizes list select Coarser.

3 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 From the Solve menu choose Solver Manager.

2 Click the Solve For tab.

3 In the Solve for variables list select only the application modes General Heat Transfer 

(htgh), General Heat Transfer (htgh2), and Conductive Media DC (dc) (or, equivalently, 
the variables V, T, and T2).

4 Open the Solver Parameters dialog box by clicking on the corresponding toolbar 
button.

5 On the General page, type 0:0.001:0.02 in the Times edit field. This provides the 
solution at 21 equally-spaced time steps from 0 to 20 ms or every 1 ms. The 
tolerances for the time-dependent solver control the actual time stepping.

6 Click OK.

7 Click the Solve button on the Main toolbar.

8 Go back to the Solver Manager, select the structural mechanics application modes on 
the Solve For page.

9 On the Initial Value page click the Initial value expression option button.

10 Click the Store Solution button, then click OK in the Store Solution dialog box to store 
all solutions.

11 In the Values of variables not solved for and linearization point area click the Stored 

solution option button and select All in the Solution at time list.

12 Click OK.

13 In the Solver Parameters dialog box select the Parametric solver.

14 In the Parameter name edit field type t and in the Parameter values edit field type 
0:0.001:0.02.

15 Click OK.

16 Click the Solve button on the Main toolbar.
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P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 From the Postprocessing menu open the Plot Parameters dialog box.

2 In the Plot type area on the General page clear the Slice check box and select the 
Boundary check box.

3 Go to the Boundary page and type Temperature in the Expression edit field.

4 Select the Deformed Shape check box to plot using a deformed shape.

5 Click the Deform tab.

6 In the Deformation data area, select Solid, Stress-Strain (smsld)>Displacement in the 
Predefined quantities list on the Subdomain Data tab.

7 To get the following plot, clear the Auto check box for automatic scaling of the 
deformed shape. Then type 1 in the Scale factor edit field.

8 Click OK.

9 To get an animation of the results, click the Animate button on the Plot toolbar.
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Th e rma l  E xpan s i o n  i n  a  MEMS Dev i c e  
U s i n g  t h e  Ma t e r i a l  L i b r a r y

The purpose of this model is to exemplify the use of the Material Library in COMSOL 
Multiphysics. This library contains more than 20,000 property functions for 2500 
materials. The larger part of these properties are mechanical and thermal properties for 
solid materials given as functions of temperature. You need the Material Library to 
build the model.

Introduction

Thermal expansion is a common method used in the microscale to displace a part of a 
component, for example in an actuator. In this example model the opposite is required; 
that is, there should be a minimum of thermal expansion. Such a device could be 
included in a microgyroscope or any other sensor for acceleration or positioning.

Model Definition

Figure 15-24 below shows the model geometry:

Figure 15-24: Geometry of the device.

Surfaces attached
to a solid frame
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The model consists of two sets of physics:

• A thermal balance with a heat source in the device, originating from Joule heating 
(ohmic heating). Air cooling is applied on the boundaries except at the position 
where the device is attached to a solid frame, where an insulation condition is set.

• A force balance for the structural analysis with a volume load caused by thermal 
expansions. The device is fixed at the positions where it is attached to a solid frame 
(see Figure 15-24).

The device is made of the copper-beryllium alloy UNS C17500.

The thermal balance consists of a balance of flux at steady state. The heat flux is given 
by conduction only. The heat source is a constant heat source of 1·108 W/m3. The air 
cooling at the boundaries is expressed using a constant heat transfer coefficient of 
10 W/m2 and an ambient temperature of 298 K.

The stress and strains are well within the elastic region for the material. The expression 
for thermal expansion requires a strain reference temperature for the copper-beryllium 
alloy, which in this case is 293 K.

All other thermal and mechanical properties are obtained from the Material Library.

Results and Discussion

The following figure shows the temperature distribution in the device. The heat source 
increases the temperature to 323 K from an ambient temperature of 298 K. The 
temperature varies less than 1/100 of a degree in the device. The displacements vary 
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accordingly, and the model shows that it is possible to study the device using only one 
unit cell, for example, 1/2 of a U-shaped section.

Figure 15-25: Temperature and displacement of the device. The edges of the original 
geometry are shown in black. The deformed shape is exaggerated by a factor of almost 200.

The following figure (Figure 15-26) shows the displacement of a curve that follows 
the top inner edges of the device from left to right. It is clear from Figure 15-26 that 
the displacement follows a repetitive pattern along the length of the device. This also 
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supports the hypothesis that 1/2 of a U-shaped section is enough to represent the 
behavior of the device.

Figure 15-26: The displacement along the inner edge of the device shows a repetitive 
pattern, which means that a model of half of the u-shaped structure is enough to study the 
effects of thermal expansion on the device.

Model Library path: Structural_Mechanics_Module/Thermal-
Structure_Interaction/thermal_expansion

Modeling Using the Graphical User Interface

1 Open the Model Navigator.

2 Select 3D from the Space dimension list.

3 Select Structural Mechanics Module>Thermal-Structural Interactions>Solid, Stress-

Strain with Thermal Expansion>Static analysis.

4 Click OK.

G E O M E T R Y  M O D E L I N G

1 From the Draw menu, select Work Plane Settings.

2 Click the x-y plane option button if it is not already selected.

3 Click OK.

4 From the Options menu, select Axis/Grid Settings.
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5 Enter -1.3e-4 in the x min edit field, 1.3e-4 in the x max edit field, -0.3e-4 in 
the y min edit field, and 1.3e-4 in the y max edit field.

6 Click the Grid tab.

7 Clear the Auto box.

8 Enter 1e-5 in the x spacing and 1e-5 in the y spacing edit fields, respectively.

9 Click OK.

Next, draw a projection of the 3D geometry and then extrude it to create a 3D object:

1 From the Draw menu, select Specify Objects>Rectangle.

2 Type 1e-5 in the Width and 8e-5 in the Height edit fields, respectively.

3 Type -1e-4 in the x edit field in the Position area using the Corner option in the Base 
list.

4 Click OK.

5 Click the 2nd Degree Bezier Curve tool button.

6 Click the coordinates (-9e-5, 8e-5), (-9e-5, 9e-5), and (-8e-5, 9e-5) to create an arc.

7 Click the Line tool button.

8 Click the coordinate (-8e-5, 1e-4).

9 Click the 2nd Degree Bezier Curve tool button.

10 Click the coordinates (-1e-4, 1e-4) and (-1e-4, 8e-5).

11 Click the right mouse button to form a composite object with the shape of an elbow.

12 Press Ctrl+A to select all objects.

13 Click the Mirror tool button.
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14 Enter -8e-5 in the x edit field in the Point on line row in the Paste dialog box. Make 
sure that the normal vector to the line has the default values (1, 0).

15 Click OK.

16 Press Ctrl+A to select and Ctrl+C to copy all objects.

17 Press Ctrl+V to paste all objects.

18 Enter 5e-5 in the x edit field for Displacements in the Paste dialog box.

19 Click OK.

20 Press Ctrl+A to select and Ctrl+C to copy all objects.

21 Press Ctrl+C to paste all objects.

22 Enter 1e-4 in the x edit field for Displacements in the Paste dialog box.

23 Click OK.
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24 Click Zoom Extents.

25 From the Draw menu, select Specify Objects>Rectangle.

26 Enter 3e-5 in the Width, 1e-5 in the Height, and -7e-5 in the x edit fields, 
respectively.

27 Click OK.

28 Press Ctrl+C followed by Ctrl+V to copy and paste the selected rectangle.

29 Type 5e-5 in the x edit field for Displacements.

30 Click OK.

31 Press Ctrl+C followed by Ctrl+V to copy and paste the selected rectangle.

32 Type 5e-5 in the x edit field for Displacements.

33 Click OK.

34 Press Ctrl+A and click the Union button on the Draw toolbar to create one 
composite object.

35 From the Draw menu, select Extrude.

36 Enter 1e-5 in the Distance edit field.

37 Click OK.

38 Click the Headlight button on the Camera toolbar.

The completed geometry in the drawing area should now look like that in the 
following figure.
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P H Y S I C S  S E T T I N G S

Start by setting the properties and boundary conditions for the thermal analysis.

Subdomain Settings—Heat Transfer by Conduction
1 From the Physics menu, select Subdomain Settings.

2 Click the Subdomain selection list and press Ctrl+A to select all subdomains.

3 Click the Load button.

4 Click the Material Library node, which is second in the Materials list.

5 Click the Al & Cu alloys node.

6 Click the Copper alloys node.
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7 Select the copper alloy UNS C17500 from the list.

8 Click OK.

9 Enter 1e8 in the Heat source edit field.

10 Click OK.

Boundary Conditions—Heat Transfer by Conduction
1 From the Physics menu, select Boundary Settings.
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2 Click the Boundary selection list.

3 Press Ctrl+A to select all boundaries.

4 In the Boundary selection list, press Ctrl and click Boundaries 2, 17, 26, 32, 52, 61, 
67, 87, 96, 102, and 122 to clear them from the current selection. Note that you 
can also do this directly in the user interface by selecting all boundaries, clicking the 
right mouse button to keep the selection, and then selecting the boundaries 
corresponding to the attachment to the base one at the time. When you click on a 
boundary, it turns green. If this is the boundary you want to clear from the selection 
list, click the right mouse button. Repeat this procedure until all boundaries listed 
above are cleared from the selection.

5 Select Heat Flux from the Boundary condition list.

6 Enter 10 in the Heat transfer coefficient edit field and 298 in the External temperature 
edit field.

7 Click OK.

Subdomain Settings—Solid, Stress-Strain
1 From the Multiphysics menu, select the Solid, Stress-Strain application mode.

2 From the Physics menu, select Subdomain Settings.

3 Select all the subdomains in the Subdomain selection list, if they are not already 
selected.

4 In the Library material list, select UNS C17500.

5 Click the Load tab. Note that the Include thermal expansion box is selected and that 
the variable for the temperature field, T, already appears in the Strain temperature 
edit field.

6 Type 293 in the Strain ref. temperature edit field. You can get the strain reference 
temperature from the Material Library. In this case, it is included in the notes for 
the thermal expansion coefficient function, alpha, in the Material Library.

7 Click OK.

Boundary Settings—Solid, Stress-Strain
1 From the Physics menu, select the Boundary Settings.

2 Click the Boundary selection list and press Ctrl+D to clear the current selection.

3 Press Ctrl and click Boundaries 2, 17, 26, 32, 52, 61, 67, 87, 96, 102, and 122 to 
select the surfaces attached to the solid frame.

4 Select Fixed from the Constraint condition list.

5 Click OK.
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M E S H  G E N E R A T I O N

1 Click the Interactive Mesh button.

2 Select Boundary 2, which is the left-most boundary attached to the solid frame.

3 Click the Decrease Mesh Size button to decrease the mesh size from normal to fine.

4 Click the Decrease Mesh Size button a second and a third time to decrease the mesh 
size to extra fine.

5 Click the Mesh Selected (Mapped) mesh button.

6 Click the Subdomain Mode button.

7 Select Subdomains 1–5, which are the five first domains from left to right. Note that 
you can do this by clicking the mouse until you get the desired subdomain 
highlighted, then you can right-click to save the selection. Then continue to the 
next subdomain, highlight it by clicking on it, and right-click to save the selection 
and so on until you have selected all five subdomains.

8 Click the Mesh Selected (Swept) button.

The reason for not sweeping the mesh throughout all subdomains is that the 
meshing of the cube sections, which unite the U-shaped sections of the geometry, 
requires that you change the sweep direction in order to create only hexagonal mesh 
elements. If you instead mesh all U-shaped sections first, COMSOL Multiphysics 
detects the sweep dimension automatically by the fact that two opposite faces of the 
cubes are meshed. You can therefore first create a swept mesh for all U-shaped 
sections and then mesh the cubes to create a hexagonal mesh for the whole 
geometry.

9 Click the Boundary Mode button.

10 Select Boundaries 32, 67, and 102 by clicking on them in the user interface. Note 
that you can use the same strategy as outlined above—that is, to click on the desired 
boundary until it gets highlighted—then right-click to save the selection, and so on 
for multiple selections.

11 Click the Mesh Selected (Mapped) button.

12 Click the Subdomain Mode button.

13 Press Ctrl+D to clear the current selection.

14 Select Subdomains 7–12, 14–19, and 21–25 by using the strategy outlined in Point 
7 above.

15 Click the Mesh Selected (Swept) button.

16 Select Subdomains 6, 13, and 20.
T H E R M A L  E X P A N S I O N  I N  A  M E M S  D E V I C E  U S I N G  T H E  M A T E R I A L  L I B R A R Y  |  699



700 |  C H A P T E
17 Click the Mesh Selected (Swept) button.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar. Note that the solution is fully coupled, 
which is not required in this case. You can solve the thermal balance first because it 
does not depend on the structural analysis. The structural analysis does require the 
temperature field in order to calculate the loads due to thermal expansion. If you are 
familiar with the use of the Solver Manager, you can use it to solve the problem 
sequentially.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate the plot in Figure 15-25, visualizing the surface temperature and the 
structural deformation of the device, follow these instructions:

1 Click the Plot Parameters button.

2 Click the General tab.

3 Clear the Slice box.

4 Select the Boundary box.

5 Select the Deformed shape box.

6 Click the Boundary tab.
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7 In the Expression edit field type T.

8 Click the Deform tab.

9 On the Subdomain Data page, select Solid, Stress-Strain (smsld)>Displacement in the 
Predefined quantities list (the default option).

10 Click OK.

Create the deformation plot in Figure 15-26 as follows:

1 Choose Postprocessing>Cross-Section Plot Parameters.

2 Click the Line/Extrusion tab.

3 Select the inner boundary segments marked in the following figure. To add a 
segment that you have highlighted in red by clicking with the mouse to the selection 
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use right-click. The segment should then turn blue in the drawing area. Repeat this 
procedure until you have selected all inner boundary segments.

4 In the Predefined quantities list select Solid, Stress-Strain (smsld)>Total displacement.

5 On the General page, click the Title/Axis button.

6 Click the option button next to the Title edit field. Leave the edit field empty to 
obtain a plot without title.

7 Click the option button next to the First axis label edit field, then enter the label 
Position along the edge [m].

8 Click the option button next to the Second axis label edit field, then enter the label 
Displacement [m].

9 Click OK to close the Title/Axis Settings dialog box.

10 Click OK to close the Cross-Section Plot Parameters dialog box and generate the plot.
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Hea t  Gen e r a t i o n  i n  a  V i b r a t i n g  
S t r u c t u r e

Introduction

When a structure is subjected to vibrations of high frequency, a significant amount of 
heat can be generated within the structure because of mechanical (viscoelastic) losses 
in the material. A second mechanism contributing to the slow temperature rise in a 
vibrating structure is called thermoelastic damping and represents the energy transfer 
between the thermal and mechanical domains.

In this example, you compute a fully coupled thermoelastic response for a vibrating 
beam-like structure by combining the stress-strain analysis with the linearized heat-
transport equation. The analysis is performed in the frequency domain.

You then model the slow rise of the temperature in the beam as a transient heat-transfer 
problem. The corresponding heat-transfer equation contains two source terms 
computed using the results of the frequency response analysis. These terms represent 
the heat generation due to mechanical losses in the material and nonlinear effects 
related to the thermoelastic damping.

Model Definition

The beam consists of two layers of different materials. One end of the beam is fixed, 
and the other one is subjected to periodic loading that is represented in the frequency 
domain as Fz exp ( j ω t), where j is the imaginary unit, and ω is the angular frequency.

The starting point of the thermal analysis is the heat-transfer equation

 (15-2)

where k is the thermal conductivity matrix. For a linear thermo-elastic solid, the 
entropy per unit volume is

 (15-3)

where, in accordance with the Dulong-Petit law, the volumetric heat capacity ρCp is 
independent of the temperature. Furthermore,

T
t∂

∂S ∇ k∇T( )⋅– Q=

S ρCp T T0⁄( )log Selast+=
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 (15-4)

where D is the elasticity matrix, ε is the strain vector, αvec is the thermal expansion 
vector, and T0 is the strain reference temperature.

The initial state at time t = 0 is stress-free, and the initial temperature is T0 across the 
beam.

The temperature field is decomposed into small-amplitude periodic oscillations and 
slow temperature rise. The total (viscoelastic) stress that appears in the frequency 
response analysis is given by

 (15-5)

where η is the loss factor and T1 presents the linear temperature response in the 
frequency domain. The corresponding temperature oscillations in the physical domain 
are

.  (15-6)

The elastic part of the entropy in the frequency domain is

 (15-7)

Linearizing Equation 15-2 and applying the frequency decomposition gives

 (15-8)

where

 (15-9)

Use Equation 15-8 to compute the temperature response. In the frequency response 
analysis, use the temperature T1 as the strain temperature and set the strain reference 
temperature to zero. This is because the solution physically corresponds to 
thermoelastic oscillations of small amplitude, which initially are zero. However, T0 in 
Equation 15-9 is the actual temperature of the beam at rest.

Using the results of the frequency response analysis, model the slow temperature rise 
with the following equation:

 (15-10)

Selast αvec D ε αvec T T0–( )–[ ]⋅=

σ D 1 jη+( )ε αvecT1–[ ]=

Real T1 xi( ) jωt( )exp[ ]

Selast αvec σ jηDε–( )⋅=

∇– k T1∇( )⋅ Q1=

Q1 j– ω ρCpT1 T0Selast+( )=

ρCp t∂
∂T ∇ k T∇( )⋅– Q2 Qd+=
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Here T represents the temperature averaged over the time period 2π/ω, and the heat 
sources are

 (15-11)

and

 (15-12)

The term Qd presents the internal work of the nonelastic (viscous) forces over the 
period; Qd is related to the energy transfer between the mechanical and thermal 
domains due to the nonlinear nature of thermo-elastic coupling. For Selast and Qd use 
the predefined variables Ent and Qdamp, respectively.

The initial condition for Equation 15-10 is

 (15-13)

For this model, assume that T0 = 300 K.

Use the following boundary conditions:

• At the fixed end, use the temperature condition T = T0.

• At the end subjected to forcing, use the thermal insulation condition.

• The boundary between the layers of different material is an internal boundary.

• At all other boundaries, use the heat-flux condition

 (15-14)

where h is the heat transfer coefficient and Te is the external temperature.

For the temperature response, the condition at the fixed end is

 (15-15)

Use the following condition instead of Equation 15-14 where applicable:

 (15-16)

The beam consists of two layers made of aluminum and titanium, respectively, with the 
corresponding loss factors 0.001 and 0.005.

Q2
1
2
---– Real T1Conj jωSelast( )[ ]=

Qd
1
2
---ωηReal ε Conj Dε( )⋅[ ]=

T T0=

n k∇T–( )⋅ h T Te–( )=

T1 0=

n k∇T1–( )⋅ hT1=
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For the simulation, apply a periodic loading in the z direction of magnitude 1.7 MPa 
and frequency 7767 Hz at the free end of the beam for 2 seconds, keeping the fixed 
end and the structure environment at a constant temperature of 300 K during the 
process.

Results and Discussion

Figure 15-27 displays the temperature distribution at the end of the simulated 2-
second process. As the figure shows, the maximum temperature rise in the beam is 
0.19 °C.

Figure 15-27: Temperature increase in the beam after 2 seconds of forced vibrations.
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Model Library path: Structural_Mechanics_Module/ 

Thermal-Structure_Interaction/vibrating_beam

Modeling Using the Graphical User Interface

1 Start COMSOL Multiphysics.

2 In the Model Navigator, select 3D from the Space dimension list, then click the 
Multiphysics button.

3 From the Application Modes list, select Structural Mechanics Module>Solid, Stress-

Strain>Frequency response analysis. Click Add.

4 From the Application Modes list, select 
COMSOL Multiphysics>Heat Transfer>Conduction>Transient analysis. Click Add.

5 Select a second Conduction application mode from the same folder, but this time 
with Steady-state analysis. Change the entry in the Dependent variables to T1, and 
the Application mode name to ht1.

6 Click Add, then click OK.

G E O M E T R Y  M O D E L I N G

1 Click the Block button on the Draw toolbar.

2 Enter the following values in the corresponding edit fields:

3 Click OK to create block BLK1

4 Repeat Steps 1–3 to create block BLK2 using the following inputs:

LENGTH AXIS BASE 
POINT

AXIS DIRECTION 
VECTOR

x 0.01 0 0

y 0.001 0 0

z 0.001 0 1

LENGTH AXIS BASE 
POINT

AXIS DIRECTION 
VECTOR

x 0.01 0 0

y 0.001 0 0

z 0.001 0.001 1
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M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters.

2 On the Subdomain page, select both subdomains and enter 4.5e-4 in the Maximum 

element size edit field.

3 Click Remesh to generate the mesh.

4 Click OK.

O P T I O N S  A N D  S E T T I N G S

Constants
1 From the Options menu, open the Constants dialog box.

2 Enter the following constants (the descriptions are optional):

3 Click OK.

Scalar Expressions
1 From the Options menu, choose Expressions>Scalar Expressions.

2 Enter the following expressions (the descriptions are optional);

3 Click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings—Solid, Stress-Strain
1 From the Multiphysics menu, select 1 Solid, Stress-Strain (smsld).

2 From the Physics menu, select Subdomain Settings.

NAME EXPRESSION DESCRIPTION

eta1 0.001 Loss factor in Subdomain 1

eta2 0.005 Loss factor in Subdomain 2

T0 300[K] Initial temperature

Te 300[K] External temperature

he 5[W/(m^2*K)] Heat-transfer coefficient

Fz 1.7[MPa] Load amplitude

NAME EXPRESSION DESCRIPTION

Q1 -j*omega_smsld*(rho_ht*C_ht*T1+ 
T0*Ent_smsld)

Heat source for linear 
temperature response

Q2 -real(0.5/T0*conj(T1)*k_ht1*(T1xx+ 
T1yy+T1zz))

Heat source due to 
nonlinearity
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3 Click the Load tab.

4 Select both subdomains and select the Include thermal expansion check box.

5 Enter T1 in the Strain temperature edit field and 0 in the Strain ref. temperature edit 
field.

6 Click the Material tab.

7 Select Subdomain 1, then click the Load button.

8 From the Basic Material Properties library, select Aluminum and click OK.

9 Select Subdomain 2, then click the Load button. 

10 From the Basic Material Properties library, select Titanium beta-21S and click OK.

11 Click the Damping tab.

12 From the Damping model list, select Loss factor. Type eta2 in the Loss factor edit 
field.

13 Select Subdomain 1.

14 From the Damping model list, select Loss factor. Type eta1 in the Loss factor edit 
field.

15 Click OK.

Subdomain Settings—Heat Transfer by Conduction
1 From the Multiphysics menu, select 2 Heat Transfer by Conduction (ht).

2 From the Physics menu, select Subdomain Settings.

3 Select both Subdomains 1 and 2.

4 On the Init page, type T0 in the Temperature edit field.

5 On the Physics page, type Q2+Qdamp_smsld in the Heat source edit field.

6 Select Subdomain 1, then select Aluminum from the Library material list.

7 Select Subdomain 2, then select Titanium beta-21S from the Library material list.

8 Click OK.

Subdomain Settings—Heat Transfer by Conduction 1
1 From the Multiphysics menu, select 3 Heat Transfer by Conduction (ht1).

2 From the Physics menu, select Subdomain Settings.

3 Select both Subdomains 1 and 2.

4 In the Heat source edit field, type Q1.

5 Select Subdomain 1, then select Aluminum from the Library material list.

6 Select Subdomain 2, then select Titanium beta-21S from the Library material list.
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7 Click OK.

Boundary Conditions—Solid, Stress-Strain
1 From the Multiphysics menu select 1 Solid, Stress-Strain (smsld).

2 From the Physics menu, select Boundary Settings. 

3 Select Boundaries 1 and 4.

4 On the Constraint page, set the Constraint condition to Fixed.

5 Click the Load tab. Select Boundaries 10 and 11.

6 In the first part of the Face load (force/area) z-dir. edit field, type Fz.

7 Click OK.

Boundary Conditions—Heat Transfer by Conduction
1 From the Multiphysics menu, select 2 Heat Transfer by Conduction (ht).

2 From the Physics menu, select Boundary Settings. 

3 Select Boundaries 1 and 4. 

4 Set the Boundary condition to Temperature.

5 Enter T0 in the Temperature edit field.

6 Select Boundaries 2, 3, 5, 7, 8, and 9.

7 Set the Boundary condition to Heat flux.

8 Enter Te in the External temperature edit field and he in the Heat transfer coefficient 
edit field.

For the remaining external boundaries (number 10 and 11) keep the default setting, 
which is thermal insulation.

9 Click OK.

Boundary Conditions—Heat Transfer by Conduction 1
1 From the Multiphysics menu select 3 Heat Transfer by Conduction (ht1).

2 Select Boundary Settings from the Physics menu. 

3 Select Boundaries 1 and 4. 

4 Set the Boundary condition to Temperature.

5 Enter 0 in the Temperature edit field.

6 Select Boundaries 2, 3, 5, 7, 8, and 9.

7 Set the Boundary condition to Heat flux.
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8 Enter 0 in the External temperature edit field and he in the Heat transfer coefficient 
edit field.

For the remaining external boundaries (number 10 and 11) keep the default setting, 
which is thermal insulation.

9 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

First, compute the coupled linear response. Then perform the transient solution for 
the slow evolution of the beam temperature. Record the entire procedure in a solver 
script.

1 Choose Solve>Solver Parameters and change Solver to Stationary. 

2 Set the Linear system solver to Direct (PARDISO).

3 Click OK.

4 Go to Solve>Solver Manager and select Initial value expression from the Initial value 
area and Use setting from Initial value frame in the Values of variables not solved for 

and linearization point area.

5 On the Solve For page, select Solid, Stress-Strain (smsld) and Heat Transfer by 

Conduction (ht1).

6 Click Apply.

7 On the Script page, click Add Current Solver Settings.

8 Click OK.

Continue with the transient solution set-up.

1 Go to Solve>Solver Parameters and change the Solver to Time dependent.

2 Select the Allow complex numbers check box because the source term involves 
complex valued variables from the frequency response analysis.

3 Enter 0:0.05:2 in the Times edit field.

4 Click OK.

5 Go to Solve>Solver Manager.

6 On the Initial Value page, select Current solution in both areas.

7 Go to the Solve For page and select Heat Transfer by Conduction (ht).

8 Click Apply.

9 On the Script page, click Add Current Solver Settings.

10 Select the Solve using a script check box.
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11 Click OK.

The solver script is ready. Before running it, set the excitation frequency. 

1 From the Physics menu, choose Scalar Variables. 

2 In the Excitation frequency edit field, type 7767.

3 Click OK to close the Application Scalar Variables dialog box.

4 Click the Solve button on the Main toolbar to perform the computations.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To plot the temperature increase shown in Figure 15-27, follow these steps:

1 Click the Plot Parameters button on the Main toolbar.

2 In the Plot type area on the General page, select the Subdomain, Deformed shape, and 
Geometry edges check boxes, and clear all the others.

3 Click the Subdomain page. In the Expression edit field, enter T-T0.

4 Click Apply to plot the temperature increase at the end of the process, as shown in 
Figure 15-27 on page 706.

To visualize the temperature evolution in time, do as follows:

1 In the Plot Parameters dialog box, click the Animate tab.

2 Click the Start Animation button.
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