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 1
I n t r o d u c t i o n
The RF Module Model Library consists of a set of models from various areas of 
electromagnetic wave simulations. Their purpose is to assist you in learning, by 
example, how to model sophisticated electromagnetic components, systems, and 
effects. Through them, you can tap the expertise of the top researchers in the field, 
examining how they approach some of the most difficult modeling problems you 
might encounter. You can thus get a feel for the power that COMSOL Multiphysics 
offers as a modeling tool. In addition to serving as a reference, the models can also 
give you a big head start if you are developing a model of a similar nature. 

We have divided these models into three groups: optics and photonics, RF and 
microwave engineering, and tutorial models. The models also illustrate the use of 
the various electromagnetics-specific application modes from which we built them. 
These specialized modes are unavailable in the base COMSOL Multiphysics 
package, and they come with their own graphical-user interfaces that make it quick 
and easy to access their power. You can even modify them for custom requirements. 
COMSOL Multiphysics itself is very powerful and, with sufficient expertise in a 
given field, you certainly could develop these modes by yourself—but why spend 
the hundreds or thousands of hours that would be necessary when our team of 
experts has already done the work for you?
 1



2 |  C H A P T E R  1
Note that the model descriptions in this book do not contain every detail on how to 
carry out every step in the modeling process. Before tackling these in-depth models, 
we urge you to first read the second book in the RF Module documentation set. Titled 
the RF Module User’s Guide, it introduces you to the basic functionality in the 
module, reviews new features in the version 3.4 release, covers basic modeling 
techniques and includes reference material of interest to those working with 
electromagnetic field simulations. For more information on how to work with the 
COMSOL Multiphysics graphical user interface, please refer to the COMSOL 
Multiphysics User’s Guide or the COMSOL Multiphysics Quick Start manual. An 
explanation on how to model with a programming language is available in yet another 
book, the COMSOL Multiphysics Scripting Guide. 

The book in your hands, the RF Module Model Library, provides details about a large 
number of ready-to-run models that illustrate real-world uses of the module. Each 
entry comes with theoretical background as well as instructions that illustrate how to 
set it up. They were written by our staff engineers who have years of experience in 
electromagnetics; they are your peers, using the language and terminology needed to 
get across the sophisticated concepts in these advanced topics.

Finally note that we supply these models as COMSOL Multiphysics Model MPH-files 
so you can import them into COMSOL Multiphysics for immediate execution, 
allowing you to follow along with these examples every step along the way.

Model Library Guide

The table below summarizes key information about the entries in the RF Module 
Model Library. A series of columns states the application mode (such as Perpendicular 
Currents) used to solve the corresponding model. The solution time is the elapsed 
time measured on a machine running Windows Vista with a 2.6 GHz AMD Athlon X2 
Dual Core 500 CPU and 2 GB of RAM. For models with a sequential solution 
strategy, the Solution Time column shows the elapsed time for the longest solution 
step. Additional columns point out the solution properties a given example highlights. 
:  I N T R O D U C T I O N
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The choices here include the type of analysis (such as time dependent) and whether 
multiphysics or parametric studies are included.
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TUTORIAL MODELS

Periodic Boundary 
Conditions

37* 3D Electromagnetic 
Waves

11 s √

Dielectric Scattering PML 48* In-Plane TE Waves 2 s √

Far-Field Postprocessing 50* Axisymmetric TE 
Waves

1 s √

Microstrip on a Printed 
Circuit Board

68* 3D Electromagnetic 
Waves; Boundary 
Mode Analysis, 
Hybrid-Mode Waves

2 min √ √

Lossy Circular Waveguide 81* Perpendicular 
Hybrid-Mode Waves

3 s √

Magnetic Frill 14 3D Electromagnetic 
Waves

34 s √

RF AND MICROWAVE MODELS

Waveguide H-Bend 21* 3D Electromagnetic 
Waves, In-Plane TE 
Waves

8 s √

2D In-Plane TE 
Waves

1 s √

Three-Port Ferrite 
Circulator

32 In-Plane TE Waves 18 s √

Monoconical RF Antenna 45 Axisymmetric TM 
Waves

57 s √

Magnetic Dipole Antenna 57 Axisymmetric TE 
Waves

1 s √
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√
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√

√
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E

T
R
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T
U

D
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Thermal Drift in a 
Microwave Filter

64 3D Electromagnetic 
Waves, Moving 
Mesh, Shell

48 s √ √ √

Waveguide H-Bend with 
S-parameters

80 In-Plane TE Waves 24 s √

Waveguide Adapter 85 Boundary Mode 
Analysis, 3D 
Electromagnetic 
Waves

4 min √ √ √

Microwave Cancer 
Therapy

98 Axisymmetric TM 
Waves, Bioheat 
Equation

52 s √ √

Absorbed Radiation (SAR) 
in the Human Brain

110 3D Electromagnetic 
Waves, Bioheat 
Equation

52 min √ √

Microwave Oven 124 3D Electromagnetic 
Waves, General 
Heat Transfer

19 min √ √ √

Balanced Patch Antenna 
for 6 GHz

136 3D Electromagnetic 
Waves

¤7 h √

Coaxial to Waveguide 
Coupling

157 3D Electromagnetic 
Waves

9 min √

Sea Bed Logging 164 3D Electromagnetic 
Waves

2 min √

OPTICS AND PHOTONICS 
MODELS

Photonic Microprism 174 In-Plane TE Waves 2 s √

Photonic Crystal 182 In-Plane TE Waves 2 s √

Bandgap Analysis of a 
Photonic Crystal

192 In-Plane TE Waves 3 min √

TABLE 1-1:  RF MODULE MODEL LIBRARY
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* this page number refers to the RF Module User’s Guide. 
¤ this model requires a 64-bit platform.

Typographical Conventions

All COMSOL manuals use a set of consistent typographical conventions that should 
make it easy for you to follow the discussion, realize what you can expect to see on the 
screen, and know which data you must enter into various data-entry fields. In 
particular, you should be aware of these conventions:

• A boldface font of the shown size and style indicates that the given word(s) appear 
exactly that way on the COMSOL graphical user interface (for toolbar buttons in 
the corresponding tooltip). For instance, we often refer to the Model Navigator, 
which is the window that appears when you start a new modeling session in 

Step-Index Fiber 208 Perpendicular 
Hybrid-Mode Waves

7 s √

Stress-Optical Effects in a 
Silica-on-Silicon 
Waveguide

215 Plane Strain, 
Perpendicular 
Hybrid-Mode Waves

2 s √ √ √

Stress-Optical Effects with 
Generalized Plane Strain

232 Plane Strain, 
Perpendicular 
Hybrid-Mode 
Waves, Weak Form, 
Point

7 s √ √ √

Second Harmonic 
Generation of a Gaussian 
Beam

249 In-Plane TE Waves, 
ODE

4 min √ √

Propagation of a 3D 
Gaussian Beam Laser 
Pulse

261 3D Electromagnetic 
Waves

128 min √

TABLE 1-1:  RF MODULE MODEL LIBRARY
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6 |  C H A P T E R  1
COMSOL; the corresponding window on the screen has the title Model Navigator. 
As another example, the instructions might say to click the Multiphysics button, and 
the boldface font indicates that you can expect to see a button with that exact label 
on the COMSOL user interface.

• The names of other items on the graphical user interface that do not have direct 
labels contain a leading uppercase letter. For instance, we often refer to the Draw 
toolbar; this vertical bar containing many icons appears on the left side of the user 
interface during geometry modeling. However, nowhere on the screen will you see 
the term “Draw” referring to this toolbar (if it were on the screen, we would print 
it in this manual as the Draw menu).

• The symbol > indicates a menu item or an item in a folder in the Model Navigator. 
For example, Physics>Equation System>Subdomain Settings is equivalent to: On the 
Physics menu, point to Equation System and then click Subdomain Settings. 
COMSOL Multiphysics>Heat Transfer>Conduction means: Open the COMSOL 

Multiphysics folder, open the Heat Transfer folder, and select Conduction.

• A Code (monospace) font indicates keyboard entries in the user interface. You might 
see an instruction such as “Type 1.25 in the Current density edit field.” The 
monospace font also indicates COMSOL Script codes.

• An italic font indicates the introduction of important terminology. Expect to find 
an explanation in the same paragraph or in the Glossary. The names of books in the 
COMSOL documentation set also appear using an italic font.
:  I N T R O D U C T I O N



 2
T u t o r i a l  M o d e l s
This chapter contains a selection of models that demonstrate important features 
and modeling techniques. Therefore, this chapter contains models from many 
different application areas. For pedagogical reasons, these models are kept as simple 
as possible with the main focus on the feature that they demonstrate. See also the 
chapter “RF Modeling” on page 11 in the RF Module User’s Guide for additional 
tutorial models.
 7
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D i e l e c t r i c  S c a t t e r i n g  PML

This is a tutorial example to show how to add PMLs and how to use the scattered field 
formulation. In the RF Module you can define perfectly matched layers by adding 
additional subdomains outside the boundaries that you would like to be absorbing. 
Because this model is in 2D, the PML regions are from the 2D cross section of the 
PML configuration in Figure 2-4 on page 44 in the RF Module User’s Guide.

Model Definition

The model shows a wave propagating from left to right through air. A dielectric object 
scatters the wave in different directions.

D O M A I N  E Q U A T I O N S

The model solves the following equation for the z component of the scattered E field:

To define the PMLs you introduce new subdomains around the air domain 
representing absorbing layers.

• In the corners the PMLs absorb the waves in both the x and y directions.

• On the sides only the waves propagating in x direction are absorbed.

• On the top and bottom the waves propagating in the y direction are absorbed.

B O U N D A R Y  C O N D I T I O N S

Using an absorbing boundary condition at the outer boundaries of the PML regions 
improves the efficiency of the PMLs. As a result, use the scattering boundary condition 
on all outer boundaries.

∇ µr
1– ∇ Ez×( )× εr j σ

ωε0
---------–⎝ ⎠

⎛ ⎞k0
2Ez– 0=
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Results and Discussion

Figure 2-1 shows the scattered field without the plane wave.

Figure 2-1: The figure shows the scattered field from the dielectric object.

The PMLs absorb the scattered energy with a minimum of reflections. If there was no 
dielectric object inside the domain, the low-reflecting and PMC boundary conditions 
would be enough. In that case the waves would propagate only in the x direction and 
the low-reflecting boundary condition would absorb the plane wave perfectly. With a 
scatterer present, the PMLs are necessary to absorb the scattered wave that you can see 
in Figure 2-1.

Model Library path: RF_Module/Tutorial_Models/
dielectric_scattering_PML
D I E L E C T R I C  S C A T T E R I N G  P M L  |  9
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Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 In the Model Navigator open the RF Module folder, then select 
In-Plane Waves>TE Waves>Scattered Harmonic Propagation.

2 Click OK.

G E O M E T R Y  M O D E L I N G

1 Draw four rectangles by Shift-clicking the Rectangle/Square button on the Draw 
toolbar. The rectangles have the following dimensions.

2 Draw two ellipses centered at the origin with the following semi-axis lengths by 
Shift-clicking the Ellipse/Circle button on the Draw toolbar.

3 Select both ellipses and click the Union button and then the Delete Interior Boundaries 
button on the Draw toolbar.

PROPERTY R1 R2 R3 R4

Width 2.4 2.4 0.2 0.2

Height 0.2 0.2 2.4 2.4

Position corner x -1.2 -1.2 -1.2 1

Position corner y 1 -1.2 -1.2 -1.2

PROPERTY E1 E2

A-semiaxis 0.1 0.3

B-semiaxis 0.3 0.1
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4 Draw a square with corners at (−1, −1) and (1, 1).

P H Y S I C S  S E T T I N G S

Application Mode Properties
1 Choose Properties from the Physics menu.

2 In the Application Mode Properties dialog box, select Free space wavelength from the 
Specify wave using list.

3 Click OK.

Application Scalar Variables
1 Open the Application Scalar Variables dialog box.

2 Type 0.5 in the edit field corresponding to the variable lambda0_rfwe.

3 Click OK.

Subdomain Settings
1 Open the Subdomain Settings dialog box.

2 Click the PML tab, and select Subdomains 1–4 and 6–9.

3 Choose Cartesian from the Type of PML list

4 Select Subdomains 1–3 and 7–9.
D I E L E C T R I C  S C A T T E R I N G  P M L  |  11
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5 Select the Absorbing in x direction check box.

6 Select Subdomains 1, 3, 4, 6, 7, and 9.

7 Select the Absorbing in y direction check box.

8 Select Subdomain 10, click the Physics tab, and set the Relative permittivity to 3. Let 
the Relative permeability have the default value 1.

9 In Subdomain 5, use the default values.

10 Click OK.

Boundary Conditions
1 From the Physics menu, choose Boundary Settings.

2 Select Boundary 1 and then select the Select by group check box to select all outer 
boundaries.

3 Select Scattering boundary condition from the Boundary condition list.

4 Click OK.

M E S H  G E N E R A T I O N

To resolve the waves, you need to use a finer mesh than the default.

1 Open the Free Mesh Parameters dialog box, click the Custom mesh size button, and 
set the Maximum element size to 0.05.

2 Click OK.

3 Initialize the mesh by clicking the Initialize Mesh button on the Main toolbar.
 2 :  TU T O R I A L  M O D E L S



C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar to compute the solution.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Follow these steps to visualize the scattered field without the incident plane wave as in 
Figure 2-1. To plot the solution in the physical domains only, you suppress the PML 
subdomains.

1 Choose Suppress>Suppress Subdomains from the Options menu.

2 Select Subdomains 1–4 and 6–9. Click OK.

3 Open Plot Parameters.

4 On the Surface tab, select Scattered electric field, z component from the Predefined 

quantities list.

5 Click OK. This creates the plot in Figure 2-1 on page 9.
D I E L E C T R I C  S C A T T E R I N G  P M L  |  13
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Magne t i c  F r i l l

Introduction

Feeding antennas with proper signals can be difficult. The signal is often described as 
a voltage, and voltages are not well defined in electromagnetic wave formulations. 
There are several tricks to model voltage generators in such situations, and one is the 
magnetic frill. This model shows the basic steps how to define a magnetic frill voltage 
generator for a dipole antenna, and it also compares the resulting antenna impedance 
with known results.

Model Definition

Magnetic frills can only be defined for the wave formulation using the H-field, which 
is based on the time-harmonic Faraday’s law.

Although there are no magnetic charges, it is possible to mathematically define a 
current of magnetic charges, called a magnetic current. This current enters the 
right-hand side of Faraday’s law in the same manner as the ordinary current enters the 
right-hand side of Ampère’s law. Similar to the ordinary current density that has the 
unit A/m2, the magnetic current density has the unit V/m2.

A closed loop of magnetic current therefore has the unit V, and represents a voltage 
generator for the surface closed by the loop. In this model, the loop is located around 
a thin straight wire and acts as a voltage source at the center of the wire. This is actually 
a dipole antenna fed by a voltage signal in the center.

The current through the wire is measured with another loop, along which a line 
integral of the H-field is specified.

Note that this loop and the magnetic current loop must be two different loops.

Results and Discussion

The dipole antenna is fed with a voltage signal of 1 V, and from the measured current 
it is possible to extract the impedance. Taken from Ref. 1, the impedance and 

∇ E× jωB–=

H ld⋅∫ I=
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dimensions of a typical dipole antenna are shown in the table below. The dimensions 
are given in terms of the wavelength, λ.

The impedance from the COMSOL Multiphysics model is 78.08+11.88i, which 
agrees well with the results from Ref. 1.

Reference

1. Constantine A. Balanis, Advanced Engineering Electromagnetics, John Wiley and 
Sons, 1989.

Model Library path: RF_Module/Tutorial_Models/magnetic_frill

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select 3D from the Space dimension list.

2 Select the RF Module>Electromagnetic Waves>Harmonic propagation application 
mode.

3 From the Element list choose Vector - Quadratic.

4 Click the Multiphysics button followed by the Add button.

5 Click the Application Mode Properties button to open the dialog box with the same 
name.

6 In the dialog box, choose Magnetic Field from the Solve for list, then click OK.

7 Click OK.

O P T I O N S  A N D  S E T T I N G S

Open the Global Expressions dialog box from the Options menu, and define the variable.

WAVELENGTH LENGTH RADIUS IMPEDANCE

0.3 0.47λ 0.005λ

NAME EXPRESSION DESCRIPTION

Z 1/I Impedance of antenna
M A G N E T I C  F R I L L  |  15
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G E O M E T R Y  M O D E L I N G

You can use symmetries to reduce the size of the model. Only one quarter of the 
antenna with surroundings is modeled.

1 Create a work plane by opening the Work-Plane Settings dialog box from the Draw 
menu, click the yz button.

2 Click OK to obtain a work plane in the yz-plane.

3 Choose Draw>Specify Objects>Rectangle and define the following rectangles.

4 Select both rectangles and click the Difference toolbar button.

5 From the Draw menu, use Specify Objects>Point to specify two points with the 
following coordinates.

6 Select all objects and choose Revolve from the Draw menu.

7 Enter -90 in the α2 edit field and click OK.

The geometry is now finished, and the two loops where created by revolving the two 
points in the work plane. If you zoom in closer to the origin, you see two quarter loops.

P H Y S I C S  S E T T I N G S

Variables
1 Choose Options>Integration Coupling Variables>Edge Variables.

2 Select edge 14 and define the line integration for the current in the dipole according 
to the table below.

3 Click OK.

NAME WIDTH HEIGHT BASE CORNER

R1 0.5 0.6 Corner (0,-0.3)

R2 0.005*0.3 0.47*0.3 Center (0,-0.47*0.15)

NAME X Y

PT1 0.005*0.3 0

PT2 0.01 0

NAME EXPRESSION INTEGRATION ORDER GLOBAL DESTINATION

I 4*(tHx*t1x+tHy*t1y) 4 Selected
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Boundary Conditions
From the Physics menu, open the Boundary Settings dialog box. Then enter the 
boundary conditions according to the following table.

Subdomain Settings
Leave the subdomain settings at their defaults.

Edge Settings
1 From the Physics menu, open the Edge Settings dialog box. Select Edge 16 and 

type 1 in the Magnetic current in edge segment direction edit field.

2 Click OK.

The last step defines the magnetic current in the outer loop. The current flows in the 
direction of the edge segment, so it is important to know the direction to determine 
the sign of the magnetic current value.

M E S H  G E N E R A T I O N

The boundary mesh settings below are made to handle the small dimensions of the 
antenna compared to the rest of the geometry. The global maximum mesh element 
size is set to resolve the wavelength properly.

1 Open the Free Mesh Parameters dialog box from the Mesh menu, and select Coarser 
from the Predefined mesh sizes list.

2 Click the Custom mesh size option button and type 0.07 in the Maximum element 

size edit field.

3 Click the Boundary tab, and select Boundaries 4, 5, 7, and 8. Type 0.2 in the Mesh 

curvature factor edit field, and type 0.01 in the Mesh curvature cutoff edit field.

4 Click the Advanced tab and enter 0.75 in the z-direction scale factor edit field. This 
ensures that the small elements around the antenna become stretched a bit along 
the antenna, reducing the total number of mesh elements efficiently.

5 Click the Remesh button and then click OK.

SETTINGS BOUNDARIES 1, 2 BOUNDARIES 3, 6, 9 ALL OTHERS

Boundary condition Perfect magnetic 
conductor

Scattering 
boundary condition

Perfect electric 
conductor

Wave type Cylindrical wave

r0 0 0 0.3
M A G N E T I C  F R I L L  |  17
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C O M P U T I N G  T H E  S O L U T I O N

1 Open the Solver Parameters dialog box from the Solve menu.

2 Select Geometric multigrid from the Linear system solver list.

3 Click the Settings button. In the dialog box that appears, make sure that Linear 

system solver is selected in the field to the left, and choose Lower element order first 
from the Hierarchy generation method list.

4 All other settings can be left at their default values. For details on the default 
settings, see “Solving Large 3D Problems” on page 69 of the RF Module User’s 
Guide.

5 Click OK to close the Linear System Solver Settings dialog.

6 Click the Stationary tab, and then select Linear in the Linearity list. This model is 
linear, but the solver interprets the model as nonlinear, because of the use of 
integration coupling variables.

7 Click OK.

8 Click the Solve button on the Main toolbar.

The solver takes a few minutes to complete the analysis.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Open the Plot Parameters dialog box from the Postprocessing menu.

2 On the Slice tab, choose Electric field, norm form the list of Predefined quantities.

3 Set the z levels to 1 in the Slice positioning area. For the x levels select Vector with 

coordinates and type 0 in the corresponding edit field.

4 Click the Range button, clear the Auto check box, and type 0 and 20 in the Min and 
Max edit fields, respectively. Click OK.
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5 Click OK to close the dialog box and make the following plot.

6 To calculate the impedance, choose Postprocessing>Data Display>Global. In the 
dialog box, enter Z in the Expression edit field. The impedance is close to 78 +12 i.
M A G N E T I C  F R I L L  |  19
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M i c r o s t r i p  on a P r i n t e d  C i r c u i t  Boa r d

This example calculates the impedance of a microstrip line on a printed circuit board. 
It compares the impedance with that obtained from an analytical formula given the 
dimensions of the micro strip and permittivity of the circuit board. This formula is 
available as a script with the following arguments: width, height, height of conductor, 
and permittivity of circuit board. The following command gives the analytical 
characteristic impedance of the microstrip:

zmustrip(2e-2,5e-3,5e-4,3)

35.4780

The analysis tests two terminations: lumped port termination and numerical port 
termination. Both versions use a lumped port with 50 Ω cable impedance to excite the 
signal into the microstrip. The numerical port version does a boundary mode analysis 
on the terminating end, which results in almost no reflection from the termination of 
the microstrip. The lumped port termination uses the calculated impedance as cable 
impedance. This matching is less accurate and give reflections, which interfere with the 
impedance calculation and therefore deviates from the analytical result. Table 2-1 
below summarizes the result.

Note that the analytical result does not represent the most accurate value because it 
assumes infinite extension of the surroundings. This model is terminated by perfect 
magnetic conductors, which influence the impedance of the microstrip. It is clear that 
the numerical port has much less reflection compared to the lumped port. This is 
important to consider when lumped ports are used as terminations.

Model Library path: RF_Module/Tutorial_Models/microstrip_on_pcb

TABLE 2-1:  RESULT OF THE IMPEDANCE COMPARISON

ANALYSIS MICROSTRIP IMPEDANCE

Analytical 35.48 Ω

Numerical port termination 36.39 Ω

Lumped port termination 39.83 Ω
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M O D E L  N A V I G A T O R

1 In the Model Navigator, choose 3D from the Space dimension list, and select RF 

Module>Electromagnetic Waves.

2 Click OK.

3 From the Multiphysics menu, choose Model Navigator to open the same dialog box 
again.

4 Select RF Module>Boundary Mode Analysis>Hybrid-Mode Waves, and click the Add 
button.

5 Choose Boundary Mode Analysis, Hybrid-Mode Waves (rfwb) from the Ruling 

application mode list.

6 Click OK.

The ruling application mode determines the default settings for the solver and how 
you can specify the eigenvalues in the Solver Parameters dialog box. By reopening 
the Model Navigator dialog box, you can get the default settings for the iterative 
solvers used by the electromagnetic waves application mode and the more 
user-friendly eigenvalue specifications of the boundary mode analysis application 
mode.

G E O M E T R Y  M O D E L I N G

1 Draw four blocks by clicking the Block button on the Draw toolbar. Specify the 
following dimensions for the blocks. For each block, click OK when done.

2 Select BLK1 and BLK4 and click the Difference toolbar button on the Draw toolbar.

P H Y S I C S  S E T T I N G S  ( B O U N D A R Y  M O D E  A N A L Y S I S )

Boundary Conditions
1 From the Physics menu, choose Boundary Settings.

PROPERTY BLK1 BLK2 BLK3 BLK4

X length 0.3 0.2 0.2 0.2

Y length 0.3 0.3 2E-2 2E-2

Z length 0.15 5E-3 5E-3 5E-4

X base 0 0.1 0.1 0.1

Y base 0 0 0.14 0.14

Z base 0 0 0 5E-3
M I C R O S T R I P  O N  A  P R I N T E D  C I R C U I T  B O A R D  |  21
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2 Select Boundaries 23, 25, and 26, select the Specify material parameters in terms of 

εr, µr, and σ option button, and then enter 3 in the εr edit field.

3 Select Boundaries 1–22, and clear the Active in this domain check box.

4 Click OK.

Edge Settings
1 From the Physics menu, choose Edge Settings.

2 Select Edges 32, 34, 36, 46, and 47, then click the Perfect magnetic conductor 
button.

3 Select Edges 33, 38, 39, 40, 41, 43, and 44, and click the Perfect electric conductor 
button.

4 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, open the Free Mesh Parameters dialog box.

2 From the Predefined mesh sizes list, choose Coarser.

3 Click OK.

4 Click the Initialize Mesh button on the Main toolbar.

C O M P U T I N G  T H E  S O L U T I O N

It is important that you solve the boundary mode analysis first because it gives the 
mode and propagation constant for the numerical port. The boundary mode analysis 
is an eigenvalue simulation where the propagation constant is an eigenvalue. The 
second step solves a stationary problem for the wave propagation, so you must switch 
analysis type between the solver steps. It is also important to store the eigenvalue 
before you start the second step, especially if the boundary mode analysis gives several 
possible propagation constants (eigenvalues).

1 From the Solve menu, open the Solver Manager dialog box.

2 Click the Solve For tab, and select Boundary Mode Analysis, Hybrid-Mode Waves (rfwb) 
from the Solve for variables list.

3 Click OK.

4 From the Solve menu, open the Solver Parameters dialog box.

5 From the Solver list, choose Eigenvalue.

6 Enter 0.9 in the Search for effective mode indices around edit field.

7 Enter 2 in the Desired number of effective mode indices edit field.
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8 From the Linear system solver list, choose Direct (UMFPACK), then click OK.

9 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 From the Postprocessing menu, open the Plot Parameters dialog box.

2 Click the Boundary tab and select the Boundary plot check box. From the Predefined 

quantities list, select Boundary Mode Analysis, Hybrid-Mode Waves (rfwb)>Tangential 

electric field, z component.

3 Clear the Color scale check box.

4 Click the Slice tab, then choose Electromagnetic Waves (rfw)>Electric field, norm from 
the Predefined quantities list, enter 0 in the x levels edit field and 1 in the y levels edit 
field.

5 Click the General tab, and select the solution with an effective mode index of 0.88 
from the Effective mode index list.

6 Click OK to see the following plot. You have not solved for the electric field on the 
slice yet, so it just shows up as a zero solution. In the subsequent wave propagation 
simulation you use the plotted boundary mode analysis solution for the numerical 
port.
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F R E E Z I N G  T H E  B O U N D A R Y  M O D E  A N A L Y S I S  A P P L I C A T I O N  M O D E

1 In the Physics menu, select Properties to open the Application Mode Properties dialog 
box.

2 From the Specify eigenvalues using list, choose Manual eigenvalue.

3 Click OK.

When you perform this operation, you copy the propagation constant for the 
current plot to an application scalar variable for the propagation constant. All the 
postprocessing variables now use this propagation constant instead of calculating 
them from the eigenvalues. The application mode is in a state where it makes no 
sense to solve for eigenvalues. So before re-solving this application mode again, 
switch back to the original setting in the Application Mode Properties dialog box.

4 From the Solve menu, open the Solver Manager dialog box.

5 Click the Solve For tab, and choose only the Electromagnetic Waves (rfw) application 
mode.

6 Click the Initial Value tab, and in the Values of variables not solved for and linearization 

point area, click the Current solution option button.
 2 :  TU T O R I A L  M O D E L S



7 From the Effective mode index list, choose same effective mode index as you plotted, 
0.88. It is important that this mode index matches the propagation constant stored 
in the scalar variables.

8 Click OK. You are now ready to continue with the setup of the electromagnetic 
waves application mode.

P H Y S I C S  S E T T I N G S  ( E L E C T R O M A G N E T I C  WAV E S )

From the Multiphysics menu, choose Electromagnetic Waves (rfw).

Subdomain Settings
1 Open the Subdomain Settings dialog box.

2 Select Subdomains 2, 3, and 4, then enter 3 in the εr edit field.

3 Click OK.

Boundary Conditions
1 From the Physics menu, choose Boundary Settings.

2 Select the Interior boundaries check box.
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3 On the Conditions page, set the values according to the following table. Leave all 
values not shown at their defaults. Note that the controls do not show up until you 
choose the boundary condition.

4 Select Boundary 1 and choose Scattering boundary condition from the Boundary 

condition list.

SETTINGS BOUNDARY 10 BOUNDARIES 23–26 BOUNDARIES 2, 4, 5, 7, 22

Boundary condition Lumped port Port Perfect magnetic 
conductor

Port number 1 2

Voltage generator at 
this port

Selected

Wave excitation at this 
port

Cleared
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5 On the Port page, set the values according to the table below:

6 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 From the Solve menu, open the Solver Parameters dialog box.

2 Switch to the Stationary solver and choose GMRES from the Linear system solver list. 
All the other settings for this iterative solver are properly setup for an 
electromagnetic wave calculation because of what you did under the section “Model 
Navigator” on page 21.

3 Click OK, and then click the Solve button on the Main toolbar to solve the problem.

SETTINGS BOUNDARIES 23–26

Mode specification Numeric

Mode type Transverse electromagnetic (TEM)

Use numeric data from Boundary Mode Analysis, Hybrid-Mode Waves (rfwb)
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When the solver finishes, the result looks like the following figure.

Extracting the Microstrip Impedance
1 From the Postprocessing menu, choose Data Display>Global.

2 In the dialog box that appears, choose Port impedance, port 1 from the Predefined 

quantities list.

3 Click OK. The result shows up in the message log and is close to 36.39 Ω.

Solving with Lumped Port Termination

P H Y S I C S  S E T T I N G S  ( E L E C T R O M A G N E T I C  WA V E S )

1 From the Physics menu, open the Boundary Settings dialog box.

2 Click the Conditions tab, select boundaries 23, 24, and 26, and choose Perfect 

magnetic conductor from the Boundary condition list.

3 Select Boundary 25, and choose the Lumped port boundary condition.

4 Enter 2 in the Port number edit field.
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5 On the Port page, enter 36.4 in the Zref edit field. This is the value you extracted in 
the previous section.

6 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar to solve the model again.

Extracting the Microstrip Impedance
1 From the Postprocessing menu, choose Data Display>Global.

2 In the dialog box that appears, pull down the Predefined quantities list and choose 
Port impedance, port 1.

3 Click OK.
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The result shows up in the message log and is roughly 39.83 Ω. This is a little bit 
different from the previous result, and it is also possible to see the small standing wave 
shape in the slice plot.
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 3
R F  a n d  M i c r o w a v e  M o d e l s
In this chapter, you find models within RF and microwave engineering. From the 
mathematical viewpoint, the same physics formulations are used in the chapter on 
optics and photonics. The terminology and the way numerical results are presented 
differ slightly, but anyone interested in RF and microwave engineering may benefit 
from also reading that chapter.
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Th r e e - Po r t  F e r r i t e  C i r c u l a t o r

Introduction

A microwave circulator is a multiport device that has the property that a wave incident 
in port 1 is coupled into port 2 only, a wave incident in port 2 is coupled into port 3 
only, and so on. Circulators are used to isolate microwave components to couple a 
transmitter and a receiver to a common antenna, for example. They typically rely on 
the use of anisotropic materials, most commonly ferrites. In this example, a three-port 
circulator is constructed from three rectangular waveguide sections joining at 120° 
where a ferrite post is inserted at the center of the joint. Figure 3-1 shows the 
geometry of the circulator.

Figure 3-1: Geometry of the three-port microwave circulator.

To match the junction, identical dielectric tuning elements are inserted into each 
branch (not shown above). The ferrite post is magnetized by a static H0 bias field along 
the axis. The bias field is usually supplied by external permanent magnets. Here, the 
focus is on the modeling of the ferrite and how to minimize reflections at the inport 
by matching the junction by the proper choice of tuning elements. For a general 
introduction to the modeling of rectangular waveguide structures, see the Waveguide 
H-bend model on page 21 in the RF Module User’s Guide and the corresponding 2D 
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model found on page 80 in this document. Matching the circulator junction involves 
calculating how well a TE10 wave propagates between ports in the circulator for 
different materials in the tuning element. This is done by calculating the scattering 
parameters, or S-parameters, of the structure as a function of the permittivity of the 
tuning elements for the fundamental TE10 mode. The S-parameters are a measure of 
the transmittance and reflectance of the circulator. For a theoretical background on 
S-parameters, see the section “S-Parameters and Ports” on page 56 in the RF Module 
User’s Guide.

This model only includes the TE10 mode of the waveguide. Thus the model can be 
made in 2D as the fields of the TE10 mode have no variation in the transverse direction. 
Figure 3-2 shows the 2D geometry including the dielectric tuning elements.

Figure 3-2: 2D geometry with dielectric tuning elements.

Model Definition

The dependent variable in this application mode is the z-component of the electric 
field E. It obeys the following relation:

∇ µr
1– ∇ Ez×( )× εr

jσ
ωε0
---------–⎝ ⎠

⎛ ⎞k0
2Ez– 0=
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where µr denotes the relative permeability, ω the angular frequency, σ the conductivity,  
ε0 the permittivity of vacuum, εr the relative permittivity, and k0 is the free space wave 
number. Losses are neglected so the conductivity is zero everywhere. The magnetic 
permeability is of key importance in this model as it is the anisotropy of this parameter 
that is responsible for the nonreciprocal behavior of the circulator. For the theory of 
the magnetic properties of ferrites, see Ref. 1 and Ref. 2. The model assumes that the 
static magnetic bias field, H0, is much stronger than the alternating magnetic field of 
the microwaves, so the quoted results are a linearization for a small-signal analysis 
around this operating point. Further assume that the applied magnetic bias field is 
strong enough for the ferrite to be in magnetic saturation. Under these assumptions 
and neglecting losses, the anisotropic permeability of a ferrite magnetized in the 
positive z direction is given by:

where

and

Here µ0 denotes the permeability of free space; ω is the angular frequency of the 
microwave field; ω0 is the precession frequency or Larmor frequency of a spinning 
electron in the applied magnetic bias field, H0; ωm is the electron Larmor frequency at 
the saturation magnetization of the ferrite, Ms; and γ is the gyromagnetic ratio of the 
electron. For a lossless ferrite, the permeability clearly becomes unbounded at ω = ω0. 
In a real ferrite, this resonance becomes finite and is broadened due to losses. For 
complete expressions including losses, see Ref. 1 and Ref. 2. In this analysis the 
operating frequency is chosen sufficiently off from the Larmor frequency to avoid the 

µ[ ]
µ jκ 0
jκ– µ 0
0 0 µ0

=

κ µ0
ωωm

ω0
2 ω2–

----------------------
⎝ ⎠
⎜ ⎟
⎛ ⎞

=

µ µ0 1
ω0ωm

ω0
2 ω2–

----------------------+
⎝ ⎠
⎜ ⎟
⎛ ⎞

=

ω0 µ0γH0=

ωm µ0γMs=
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singularity. The material data, Ms = 2.39·105 A/m and εr = 12.9, are taken for 
magnesium ferrite from Ref. 2. The applied bias field is set to H0 = 2.72·105 A/m, 
which is well above saturation. The electron gyromagnetic ratio is set to 
1.759·1011 C/kg. Finally, the model uses an operating frequency of 10 GHz. This is 
well above the cutoff for the TE10 mode, which for a waveguide cross section of 2 cm 
by 1 cm is at about 7.5 GHz. At the ports, matched port boundary conditions make 
the boundaries transparent to the wave.

Results and Discussion

The S11 parameter as a function of the relative permittivity of the matching elements, 
eps_r, is shown in Figure 3-3. The S11 parameter corresponds to the reflection 
coefficient at port 1. Thus matching the junction is equivalent to minimizing the 
magnitude of S11.

Figure 3-3: S11 parameter as a function of the relative permittivity.

By choosing eps_r to about 1.28, you obtain a reflection coefficient of about −35 dB, 
which is a good value for a circulator design. Judging from the absence of standing 
wave patterns in the magnitude plot of the electric field and by looking at the direction 
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of the microwave energy flow in the result plot below, it is clear that the circulator 
behaves as desired.
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By feeding the circulator at a different port, the nonreciprocal behavior of the device 
becomes quite apparent.

As a final study, extract the full S-parameter matrix at the optimum value of eps_r for 
a range of frequencies. The script sparametermatrix.m automatically uses all ports, 
one at a time, as inputs and extracts the matrix. The matrix contains all the information 
about the relation between the ports.

If you feed the signal through, say, Port 2, check column 2, and you see that it is passed 
on to Port 1 where you find the highest value. The calculated S-parameter data are also 
exported to a Touchstone file using the command touchwrite.
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Model Library path: RF_Module/RF_and_Microwave_Engineering/circulator

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 From the Space dimension list, select 2D.

2 From the Application Modes folder, select 
RF Module>In-Plane Waves>TE Waves>Harmonic propagation.

3 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 Define the following constants in the Constants dialog box. The description field is 
optional and can be omitted.

2 Define the following scalar variables in the Scalar Expressions dialog box.

G E O M E T R Y  M O D E L I N G

The geometry modeling of this model is rather extensive, so it is possible to import the 
circulator geometry from a binary file. Select the section that you prefer.

NAME EXPRESSION DESCRIPTION

freq 300[MHz]/0.03 Frequency

eps_r 1 Relative permittivity in matching layer

NAME EXPRESSION DESCRIPTION

gamma 1.759e11[C/kg] Gyromagnetic ratio

H0 omega_rfwe/(gamma* 
mu0_rfwe+1e4[m/C])

Applied magnetic bias field

w0 mu0_rfwe*gamma*H0 Larmor frequency

Ms 0.3[Wb/m^2]/mu0_rfwe Saturation magnetization

wm mu0_rfwe*gamma*Ms Larmor frequency at saturation limit

mur 1+w0*wm/(w0^2- 
omega_rfwe^2)

Relative permeability tensor element

kr omega_rfwe*wm/ 
(w0^2-omega_rfwe^2)

Relative permeability tensor element
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Importing the Geometry from a Binary File
1 From the File menu, select Import>CAD Data From File.

2 In the Import CAD Data From File dialog box, make sure that the COMSOL Multiphysics 

file or All 2D CAD files is selected in the Files of type list.

3 From the models directory under the COMSOL Multiphysics installation directory, 
go to the model library path given on page 38. Select the circulator.mphbin file, 
and click Import.

4 Skip section “Creating the Geometry from Scratch” and begin at section “Scalar 
Variables”.

Creating the Geometry from Scratch
Use the buttons on the Draw toolbar and the Draw and Edit menus.

1 Draw a Rectangle with the lower left corner in (-0.06,-0.01) and the width 0.06 and 
height 0.02.

2 Copy the rectangle and paste it without any displacement.

3 Rotate the pasted rectangle 120° around (0,0).

4 Paste a new copy of the original rectangle without any displacement.

5 Rotate the pasted rectangle −120° around (0, 0).

6 Select all objects and click the Union button in the toolbar.

7 Click the Delete Interior Boundaries button in the toolbar.

8 Draw another Rectangle with the lower left corner in (−0.02, −0.01) and the width 
0.0142264973081037 and height 0.02. You must enter the width to all decimal 
places, otherwise the two right corners of the rectangle do not connect to the 
corners in the previously created object. An alternative way to define this rectangle 
is: Go to the Draw menu and select Draw Objects>Rectangle/Square. Point the mouse 
to (−0.02, −0.01). Click the left mouse button and keep pressing it down while you 
move the pointer diagonally up and to the right. When it eventually snaps to the 
wanted corner in the existing object, release the mouse button.

9 Repeat Steps 2–5 above for the latest rectangle.

10 Draw a Circle with a radius of 0.0023 centered at the origin.

S C A L A R  V A R I A B L E S

1 From the Physics menu, select Scalar Variables.

2 In the Application Scalar Variables dialog box, set the Frequency to freq.

3 Click OK.
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P H Y S I C S  S E T T I N G S

Boundary Conditions
The default boundary condition is perfect electric conductor which is fine for all 
exterior boundaries except at the ports. Interior boundaries are by default not active 
meaning that continuity is imposed.

At boundaries number 1, 20, and 21, specify the Port boundary condition. On the Port 
tab set the values according to the table below:

Subdomain Settings
1 Click the Groups tab in the Subdomain Settings dialog box and create three groups 

called air, dielectric, and ferrite, respectively.

2 Keep the default subdomain settings for the air group. For the dielectric group, 
change the Relative permittivity to eps_r. For the ferrite group, set the Relative 

permittivity to 12.9, and enter the Relative permeability, as four space-separated 
entries in this edit field: mur -i*kr i*kr mur.

3 On the Subdomains page, assign Subdomains 1, 3, 6, and 7 to the air group; 
Subdomains 2, 4, and 5 to the dielectric group; and Subdomain 8 to the ferrite 
group.

4 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, open the Free Mesh Parameters dialog box.

2 On the Subdomain page, set the Maximum element size to 0.003 for Subdomains 1–
7 and to 0.0005 for Subdomain 8. This will ensure that the waves are properly 
resolved everywhere. Especially in the ferrite, the wavelength will be much shorter 
than in free space, calling for a much denser mesh here. 

3 Click OK to close Free Mesh Parameters dialog box.

4 Click the Initialize Mesh button on the Main toolbar.

SETTINGS BOUNDARY 1 BOUNDARY 20 BOUNDARY 21

Port number 1 3 2

Wave excitation at this port Selected Cleared Cleared

Mode specification Analytic Analytic Analytic

Mode number 1 1 1
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C O M P U T I N G  T H E  S O L U T I O N

Use the parametric solver in order to study the S-parameters as a function of the 
relative permittivity in the matching elements.

1 Click the Solver Parameters button on the Main toolbar.

2 From the Solver list, select Parametric.

3 Enter eps_r as Parameter name and linspace(1,1.5,51) as Parameter values. The 
solver will calculate the solution using 51 equidistant permittivity values in the range 
1 to 1.5. Click OK.

4 Click the Solve button on the Main toolbar.

The solution time is about 30 s on a PC with a 2.2 GHz P4 processor running 
Windows XP.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows the instantaneous electric field at the final solution step; see the 
following figure.

It is more instructive to look at the magnitude of the electric field and to set the color 
range manually as the plot otherwise will be dominated by the strong electric field in 
the ferrite post:
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1 Click the Plot Parameters button on the Main toolbar.

2 On the Surface page, select Electric field, norm from the list of Predefined quantities.

3 Click the Range button. Specify a range from 0 to 350, then click OK. 

4 On the Arrow page, select the Arrow plot check box.

5 From the list of Predefined quantities, select Power flow, time average.

6 Set the arrow Color to black, then click OK.

The presence of standing waves at the input is clearly visible for this value (1.5) of the 
relative permittivity in the matching elements. The next step is to plot the reflection 
coefficient S11 as a function of eps_r. You can do this using a domain plot.

1 From the Postprocessing menu, select Domain Plot Parameters.

2 On the General page, select all solutions in the Solutions to use list.

3 On the Point page, select S_parameter dB(S11) from the list of Predefined quantities.

S11 is defined everywhere, but you only need to evaluate it at a single point to make 
a plot as a function of eps_r.

4 Select Point 1, then click Apply to plot S11.
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Note: When displaying S-Parameter variables, the phase of the solution must be set 
to zero. Otherwise, incorrect values will be displayed. In the various dialogs for 
displaying and plotting data that are available from the Postprocessing menu, the 
phase of the solution can be set via the Solution at angle (phase) field. If the dialog box 
contains several tabs, it usually appears on the General tab.

The plot shows that S11 is minimized by setting eps_r to 1.28. Make this change in 
the Constants dialog box, open the Solver Parameters dialog, select the Stationary solver, 
and solve again. Any standing wave pattern should barely be visible now. Change the 
inport from Port 1 to Port 2 by editing the boundary settings for these boundaries and 
solve again to see the nonreciprocal behavior of the device.

Extracting the S-Parameter Matrix

This section requires that you have access to COMSOL Script or MATLAB.

1 From the File menu, choose Export>FEM Structure as 'fem'. Switch to the COMSOL 

Script command window.
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2 Enter the following command at the prompt.

S = sparametermatrix(fem,'scale','db')

S = 

   -34.7786    -0.0028   -34.9297
   -34.9500   -34.7802    -0.0028
    -0.0028   -34.9280   -34.7998

The command gives the S-parameters in dB scale.

Exporting S-Parameters versus Frequency to Touchstone

This section requires that you have access to COMSOL Script or MATLAB.

1 If you continue from the previous section it is not necessary to export the fem 
structure. Otherwise, do step 1 from that section.

2 Enter the following commands at the prompt:

freq = linspace(1e10,1.5e10,25);
S = sparametermatrix(fem,'pname','freq','plist',freq);
touchwrite('circulator',freq,S,'frequnit','MHz');

The first command creates a list of frequencies to export, the second command 
calculates the S-parameter matrix for all those frequencies, and the final command 
exports the data to a file named circulator.s3p. If you do not provide a path for 
the file, the touchwrite command saves the file in the current directory. It is 
Touchstone convention to put the number 3 in the filename extension because the 
model has three ports. The frequnit option specifies that the frequency is given in 
MHz in the exported file. The format for the S-parameters in the file is magnitude 
and angle, but you can change to another format by using the options specified in 
Chapter 4, “Function Reference,” in the RF Module Reference Guide.
 3 :  R F  A N D  M I C R O W A V E  M O D E L S



Mono c on i c a l  R F  An t e nna

Introduction

Conical antennas are useful for many applications due to their broadband 
characteristics and relative simplicity. This example includes an analysis of the antenna 
impedance and the radiation pattern as functions of the frequency for a monoconical 
antenna with a finite ground plane and a 50 Ω coaxial feed. The rotational symmetry 
makes it possible to model this in 2D using one of the axisymmetric electromagnetic 
wave propagation application modes. When modeling in 2D, you can use a dense 
mesh, giving an excellent accuracy for a wide range of frequencies.

Model Definition

The antenna geometry consists of a 0.2 m tall metallic cone with a top angle of 
90 degrees on a finite ground plane of a 0.282 m radius. The coaxial feed has a central 
conductor of 1.5 mm radius and an outer conductor (screen) of 4.916 mm radius 
separated by a teflon dielectric of relative permittivity of 2.07. The central conductor 
of the coaxial cable is connected to the cone, and the screen is connected to the ground 
plane.

Figure 3-4: The geometry of the antenna. The central conductor of the coaxial cable is 
connected to the metallic cone, and the cable screen is connected to the finite ground plane.

The model takes advantage of the rotational symmetry of the problem, which allows 
modeling in 2D using cylindrical coordinates. You can then use a very fine mesh to 
achieve an excellent accuracy.
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D O M A I N  E Q U A T I O N S

An electromagnetic wave propagating in a coaxial cable is characterized by transverse 
electromagnetic fields (TEM). Assuming time-harmonic fields with complex 
amplitudes containing the phase information, you have:

where z is the direction of propagation and r, , and z are cylindrical coordinates 
centered on axis of the coaxial cable. Z is the wave impedance in the dielectric of the 
cable, and C is an arbitrary constant. The angular frequency is denoted by ω. The 
propagation constant, k, relates to the wavelength in the medium λ as

In the air, the electric field also has a finite axial component whereas the magnetic field 
is purely azimuthal. Thus it is possible to model the antenna using an axisymmetric 
transverse magnetic (TM) formulation, and the wave equation becomes scalar in : 

B O U N D A R Y  C O N D I T I O N S

The boundary conditions for the metallic surfaces are:

At the feed point, a matched coaxial port boundary condition is used to make the 
boundary transparent to the wave. The antenna is radiating into free space, but you 
can only discretize a finite region. Therefore, truncate the geometry some distance 
from the antenna using a scattering boundary condition allowing for outgoing 
spherical waves to pass without being reflected. Finally, apply a symmetry boundary 
condition for boundaries at r = 0.

Results and Discussion

Figure 3-5 shows the antenna impedance as a function of frequency. Ideally, the 
antenna impedance should be matched to the characteristic impedance of the feed, 
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50 Ω, to obtain maximum transmission into free space. This is quite well fulfilled in the 
high frequency range.

Figure 3-5: The antenna impedance as a function of frequency from 200 MHz to 
1.5 GHz. The solid line shows the radiation resistance and the dashed line represents the 
reactance.

Figure 3-6 shows the antenna radiation pattern in the near-field for three different 
frequencies. The effect of the finite diameter of the ground plane is to lift the main lobe 
from the horizontal plane. For an infinite ground plane or in the high frequency limit, 
the radiation pattern is symmetric around zero elevation. This is easy to understand, as 
an infinite ground plane can be replaced by a mirror image of the monocone below the 
plane. Such a biconical antenna is symmetric around zero elevation and has its main 
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lobe in the horizontal direction. The decreased lobe lifting at higher frequencies is just 
about visible in Figure 3-6.

Figure 3-6: The antenna radiation pattern in the near-field as a function of the elevation 
angle for 200 MHz (solid line), 863 MHz (dotted line) and 1.5 GHz (dashed line).
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Figure 3-7 shows the antenna radiation pattern in the far-field for the same frequencies 
as the radiation pattern at the boundary in Figure 3-6.

Figure 3-7: The antenna radiation pattern for the far-field as function of elevation angle 
for 200 MHz (solid line), 863 MHz (dotted line) and 1.5 GHz (dashed line).

Model Library path: RF_Module/RF_and_Microwave_Engineering/
conical_antenna

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select Axial symmetry (2D) in the Space dimension list.

2 Select the RF Module>Electromagnetic Waves>TM Waves>Harmonic propagation 
application mode and then click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, choose Constants.
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2 Enter the following variable name, expression, and (optionally) description; when 
done, click OK.

3 From the Options menu, choose Axes/Grid Settings.

4 On the Grid page, clear the Auto check box.

5 Enter grid settings according to the following table; when done, click OK.

G E O M E T R Y  M O D E L I N G

To create the model geometry, draw the right half of the cross section of the antenna 
and the coaxial feed in a truncated half space.

1 Open the Rectangle dialog box by shift-clicking the Rectangle/Square button on the 
Draw toolbar. Set the Width to 0.282, Height to 0.301, Base to Corner, r to 0, and 
z to -0.101. Click OK.

2 Using the same approach, draw a second rectangle and set the Width to 0.003416, 
Height to 0.1, r to 0.0015, and z to -0.1.

3 Draw a third rectangle and set the Width to 0.276, Height to 0.091, r to 0.006, and 
z to -0.101.

4 Click the Zoom Extents button on the Main toolbar.

5 Click the Line button on the Draw toolbar.

NAME EXPRESSION DESCRIPTION

f 500[MHz] Frequency

GRID

r spacing 0.05

Extra r 0.0015 0.004916

z spacing 0.05

Extra z
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6 Draw a polygon with corners at (0.3, 0), (0.3, 0.2), (0.2, 0.2), and (0.0015, 0). 
Finally right-click to create a solid object CO1.

7 From the Draw menu, open the Create Composite Object dialog box.

8 In the Set formula edit field, type R1-(R2+R3+CO1).

9 Click OK to create the composite object.

10 Zoom out and draw a circle with radius 0.6 centered at (0, 0).

11 Draw a rectangle with opposite corners at (−0.6, −0.6) and (0, 0.6).

12 Select the three objects R1, C1, and CO2, then click the Difference button on the 
Draw toolbar.
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13 Zoom in around (0, 0) using the Zoom Window tool, and draw a line from (0.0015, 
0) to (0.004916, 0).

P H Y S I C S  S E T T I N G S

Scalar Variables
1 From the Physics menu, choose Scalar Variables.

2 In the Application Scalar Variables dialog box, set the Frequency to f to obtain a 
500 MHz wave.

3 Click OK.

Boundary Conditions
1 From the Physics menu, choose Boundary Settings.

2 Enter boundary conditions according to the following table:

3 Select Boundary 6 and click the Port tab.

SETTINGS BOUNDARIES 1, 3 BOUNDARY 6 BOUNDARIES 14, 15 ALL OTHERS

Boundary 
condition

Axial symmetry Port Scattering 
boundary 
condition

Perfect electric 
conductor

Wave type Spherical wave
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4 Select the Wave excitation at this port check box.

5 Set Mode specification to Coaxial.

6 Click OK.

Subdomain Settings
The inner of the coaxial line is made of teflon. The subdomain parameters need to be 
specified accordingly.

1 From the Physics menu, choose Subdomain Settings.

2 Specify settings according to the following table; when done, click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, open the Free Mesh Parameters dialog box.

2 Click the Custom mesh size button and set the Maximum element size to 2.5e-2.

3 To make the mesh finer inside the coaxial line, where the wavelength is shorter due 
to higher permittivity, click the Subdomain tab, select Subdomain 2, and set the 
Maximum element size to 5e-4.

4 To make the mesh finer near the antenna, click the Boundary tab, select Boundaries 
4 and 8, and set the Maximum element size to 2.5e-3.

5 Click the Remesh button. When the mesher has finished, click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows the azimuthal magnetic field component of the transmitted 
wave. Due to the strong field in the coaxial line, you need to manually adjust the plot 
parameters.

1 Click the Plot Parameters button on the Main toolbar.

2 On the Surface page, click the Range button, clear the Auto check box and set Min 
and Max to -0.5 and 0.5 respectively. Click OK.

3 On the Contour page, select the Contour plot check box. On the Contour Data page, 
choose Magnetic field, phi component from the Predefined quantities list.

SETTINGS SUBDOMAIN 1 SUBDOMAIN 2

 εr 1 2.07

 µr 1 1
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4 In the Contour levels area, click the Vector with isolevels option button, then type 
-0.5:0.01:0.1 in the associated edit field.

5 In the Contour color area, click first the Uniform color option button and then the 
Color button. Set the color to white, then click OK.

6 Clear the Color scale check box, then click OK to generate the following plot:

Antenna Impedance and Radiation Pattern

A frequency sweep for the radiation pattern and the antenna impedance can be made 
from the graphical user interface or using a script file. The S11 scattering parameter is 
automatically computed when using the port boundary condition at the feed 
boundary. From S11, the antenna impedance is deduced using the relation

where Ztl = 50 Ω is the characteristic impedance of the coaxial line.

O P T I O N S  A N D  S E T T I N G S

1 In the Constants dialog box, enter the following variable name and expression.

NAME EXPRESSION DESCRIPTION

Z_tl 50[ohm] Characteristic transmission-line impedance

Z Ztl
1 S11+

1 S11–
-------------------=
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2 In the Scalar Expressions dialog box, define the following variables.

S O L V I N G  T H E  M O D E L

1 Open the Solver Parameters dialog box and select the Parametric solver.

2 Set the Parameter name to f and the Parameter values to 
linspace(200e6,1.5e9,50), then click OK.

3 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To plot the antenna impedance as a function of frequency, do the following steps:

1 Open the Domain Plot Parameters dialog box.

2 On the General page, select all frequencies in the Solutions to use list.

3 Go to the Point page and select Point 1. Then enter real(Z) as Expression to plot 
the radiation resistance.

4 Click the Line Settings button. From the Line style list, select Solid line. Click OK.

5 Click Apply to generate the resistance plot.

6 To generate a second plot in the same figure window, go to the General page and 
select the Keep current plot check box.

7 Go to the Point page and enter imag(Z) as Expression to plot the reactance.

8 Click the Line Settings button. From the Line color list, select Color, then click the 
Color button. Select a green color, then click OK. From the Line style list, select 
Dashed line, then click OK to close the Line Settings dialog box.

9 On the General page, click the Title/Axis button. Enter Antenna impedance as Title 
and Solid line: Real(Z);  dashed line: Imag (Z) [\OMEGA] as Second axis 

label. Click OK.

10 Click Apply to reproduce the plot in Figure 3-5.

To plot the radiation pattern as a function of frequency, follow these steps:

1 On the General page, select a few frequencies in the Solutions to use list, for example, 
2e8, 8.632653e8, and 1.5e9.

2 Clear the Keep current plot check box. Click the Title/Axis button and enter 
Radiation pattern (dB) as Title. Click the Auto option button for Second axis 

label, then click OK.

VARIABLE NAME EXPRESSION

Z Z_tl*(1+S11_rfwh)/(1-S11_rfwh)
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3 Click the Line/Extrusion tab. Select Boundaries 14 and 15, then enter the Expression 
10*log10(nPoav_rfwh). Clear the Smooth check box.

4 In the x-axis data area, click first the lower radio button and then the Expression 

button. In the X-Axis Data dialog box, enter the Expression atan2(z,r), select 
° (degrees) from the Unit list, and then click OK.

5 Click the Line Settings button. Select cycle from both the Line color list and the Line 

style list, then click OK.

6 Click OK to generate the plot in Figure 3-6.

Far-Field Computation

You can easily add far-field calculation to the model, and then plot the radiation pattern 
in the far field as shown in Figure 3-7.

P H Y S I C S  S E T T I N G S

1 Select Boundary settings from the Physics menu.

2 Select Boundaries 14 and 15 in the Boundary selection.

3 Click the Far-Field tab.

4 Enter a far-field variable with name E_far and make sure the tangential electric field 
and the curl of the electric field are entered automatically in the next two columns.

5 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

To evaluate the far-field variables, select Update Model from the Solver menu.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To plot the radiation pattern of the far field, do the following steps:

1 Open the Domain Plot Parameters dialog box from the Postprocessing menu.

2 Select a few frequencies in the Solution to use list, for example 2e8, 8.632653e8, and 
1.5e9.

3 Click the Line/Extrusion tab and select Boundaries 14 and 15.

4 In the Expression edit field, type normE_fardB.

5 Click the Line Settings button. Make sure that Line color and Line style are set to cycle, 
then click OK to close the Line Settings dialog box.

6 Click OK to generate the plot in Figure 3-7.
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Magne t i c  D i p o l e  An t e nna

Introduction

A magnetic dipole consists in its simplest form of a current carrying coil. Three such 
coils coupled together in an AC power circuit constitute a radiating system. Changing 
the phases of the coils alters the transmission angle of the waves.

Model Definition

An array of three magnetic dipoles with a radius of 5 cm will be modeled. The dipoles 
are placed 0.1 m apart. The cylindrical symmetry of the problem allows us to set up a 
2D axisymmetric model. The dipoles then appear as points in the rz-modeling plane.

The emitted waves from the dipoles are axisymmetric TE waves. The governing 
equation for the waves is

where µr is the relative permeability, εr the relative permittivity, and k0 the free space 
wave number. In the axisymmetric case this equation can be reduced to a scalar 
equation for the azimuthal component of the electric field . 

∇ µr
1– ∇ E×( )× k0

2εrE– 0=

Eϕ
M A G N E T I C  D I P O L E  A N T E N N A  |  57



58 |  C H A P T E R
Results and Discussion

The figure below shows the radiation pattern from an array of three coils, each carrying 
a current of 1 A. The relative phases of the currents are , , and 

.

Model Library path: RF_Module/RF_and_Microwave_Engineering/
dipole_array

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select Axial symmetry (2D) from the Space dimension list.

2 Select the RF Module>Electromagnetic Waves>TE waves, harmonic propagation 
application mode.

3 Click OK.

ϕ1 0= ϕ2 0.7 rad=

ϕ3 1.4 rad=
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O P T I O N S  A N D  S E T T I N G S

1 In the Constants dialog box, enter the following variable names and expressions.

2 Use the default frequency of 1 GHz, which you find in the Application Scalar 

Variables dialog box.

G E O M E T R Y  M O D E L I N G

1 Draw a circle with the radius 1 centered at (0,0).

2 Draw a rectangle with opposite corners at (0,-1) and (1,1).

3 Select both the circle and rectangle and click the Intersection button.

4 Draw three points at the coordinates (0.05, -0.1), (0.05, 0), and (0.05, 0.1).

NAME EXPRESSION

I0 1

th1 -0.7

th2 2*th1
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P H Y S I C S  S E T T I N G S

Point Settings
Define the three dipoles by entering a current at the points according to the following 
table:

Boundary Conditions
Enter boundary conditions according to the following table:

Subdomain Settings
Use the default values applicable for air.

M E S H  G E N E R A T I O N

1 To obtain a uniform mesh, click the Custom mesh size button and set Maximum 

element size to 0.03 in the Free Mesh Parameters dialog box. 

2 Generate the mesh.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

SETTING POINT 3 POINT 4 POINT 5

I0 I0 I0*exp(j*th1) I0*exp(j*th2)

SETTING BOUNDARY 1 BOUNDARIES 2, 3

Boundary condition Axial symmetry Scattering boundary condition
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PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows the electric field component of the transmitted wave.

To show the radiation pattern from the antenna array, make a plot along the half-circle 
boundary.

1 In the Domain Plot Parameters dialog box select Line plot. Set the y-axis data to 
10*log10(nPoav_rfwe+1e-3) and select Boundaries 2 and 3. The term 1e-3 is to 
avoid singularities at the end points.
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2 In the x-axis area, select the Expression radio button. Then click the Expression 
button and enter atan2(r,z) in the Expression edit field.

Modeling Using the Programming Language

% When programming the same model you start by defining the 
% constants. Use a constant named I1 rather than I0 to avoid
% conflict with the point variable I0 generated by the 
% application mode.
clear fem
fem.const={...
  'I1',1,...
  'th1',-0.7,...
  'th2',-1.4};

% You can now define the coordinates and the geometry.
fem.sdim={'r' 'z'};
clear draw
draw.s.objs={circ2(0,0,1)*rect2(0,1,-1,1)};
draw.s.name={'C01'};
draw.p.objs={point2(0.05,-0.1),point2(0.05,0),point2(0.05,0.1)};
draw.p.name={'PT1','PT2','PT3'};
fem.draw=draw;
fem.geom=geomcsg(fem);
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% Create the application structure and compute the corresponding 
% FEM coefficients.
clear appl
appl.mode.class='AxisymmetricWaves';
appl.mode.type='axi';
appl.bnd.type={'ax' 'SC'};
appl.bnd.ind=[1 2 2];
appl.pnt.I0={'0' 'I1' 'I1*exp(j*th1)' 'I1*exp(j*th2)'};
appl.pnt.ind=[1 1 2 3 4 1];
fem.appl=appl;
fem=multiphysics(fem);

% You can now mesh the problem using the proper parameters, and 
% then solve it.
fem.mesh=meshinit(fem,'hmax',...
  {0.03 [] [] []});
fem.xmesh=meshextend(fem);
fem.sol=femlin(fem);

% Make a visualization of the field by the following command.
postplot(fem,'tridata','Ephi')

% The radiation pattern is visualized using a cross-section plot.
postcrossplot(fem,1,[2 3],'lindata','10*log10(nPoav)');
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Th e rma l  D r i f t  i n  a  M i c r owa v e  F i l t e r

Introduction

Microwave filters serve to suppress unwanted frequencies in the output of microwave 
transmitters. Amplifiers are in general nonlinear and produce harmonics that must be 
suppressed using one or several narrow passband filters on the output. High frequency 
stability of such filters can be hard to achieve as microwave systems may be subject to 
thermal drift caused by high power loads or harsh environmental conditions like 
exposure to direct sunlight in the desert. Thus, system engineers need to estimate the 
drift of the passband frequency that arises due to thermal expansion of a filter.

Model Definition

Figure 3-8 shows the filter geometry. It consists of a box with a cylindrical post 
centered on one face. It is typically made of brass covered with a thin layer of silver to 
minimize losses. The silver layer is sufficiently thin to have a negligible influence on the 
device’s thermal and mechanical properties.

Figure 3-8: A microwave filter consists of a box-shaped thin metallic shell, typically made 
of brass, that contains a cylindrical post. This configuration forms a closed air-filled 
electromagnetic cavity between the box walls and the post.

The thermal expansion and the associated drift in eigenfrequency are caused by a 
uniform increase of the temperature of the cavity walls. The thermal expansion is 
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readily computed using the Shell application mode from the Structural Mechanics 
Module. The electromagnetic cavity mode analysis is easily performed using the 3D 
Electromagnetic Waves application mode in the RF Module. In principle, it is possible 
to determine the thermal drift in the passband frequency by repeated calculation of the 
thermal expansion followed by an electromagnetic mode analysis of the deformed 
geometry. A complication arises, however, because it is not wise to regenerate the 
mesh—doing so would introduce too much numerical noise.

A better approach is to use a special set of equations to smoothly deform the original 
mesh according to the thermal expansion. Thus, the Moving Mesh (ALE) application 
mode for deformed geometry in COMSOL Multiphysics is used to map the thermal 
expansion to the geometry used for the electromagnetic analysis.

Results and Discussion

M O D E L I N G  T H E  T H E R M A L  E X P A N S I O N

The filter’s temperature can rise due to power dissipation in the filter itself, in the 
surrounding electronics, or due to external heating. Figure 3-9 shows the thermal 
expansion results for a filter entirely made of brass. 

Figure 3-9: Thermal expansion at 100 °C above the reference temperature.
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E L E C T R O M A G N E T I C  M O D E  A N A L Y S I S

An actual filter usually consists of multiple cavities cascaded, but this discussion limits 
the analysis to one cell. Figure 3-10 shows the filter’s lowest eigenmode. The typical 
quarter-wave resonance of the cylindrical post is clearly visible. A strong capacitive 
coupling between the top of the post and the nearby face of the box is also obvious.

Figure 3-10: Results from the electromagnetic mode analysis. The plot shows the electric 
and surface current patterns of the fundamental mode.
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E I G E N F R E Q U E N C Y  V S .  T E M P E R A T U R E

By repeating the structural and electromagnetic analyses for a number of operating 
temperatures, an eigenfrequency-versus-temperature curve is obtained. The results for 
two different designs appear in Figure 3-11.

Figure 3-11: Eigenfrequency (Hz) versus temperature (K) for two different designs.

For the first design, the entire filter is made of brass whereas for the second design the 
post is made of steel. It is obvious that the combination of steel and brass is superior 
to a design using brass alone. The reason is the reduced capacitive coupling between 
the top of the post and the nearby face of the box, which results from the different 
coefficients of thermal expansion for the two materials. This coupling has a strong 
influence on the resonant frequency and, when reduced, it counteracts the effect of an 
overall increase in cavity size.

Model Library path: RF_Module/RF_and_Microwave_Engineering/mw_filter
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Note: This model requires the RF Module and the Structural Mechanics Module.

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

The model uses linear elements to reduce the memory requirements.

1 Click the Multiphysics button.

2 Select 3D from the Space dimension list.

3 In the Structural Mechanics Module folder, select Shell>Static analysis.

4 Click Add to add a copy of this application mode.

5 In the COMSOL Multiphysics folder, select Deformed Mesh>Moving Mesh (ALE)>Static 

analysis. Select Lagrange - Linear from the Element list.

6 Click Add.

7 In the RF Module folder, select Electromagnetic Waves>Eigenfrequency analysis. Select 
Vector - Linear from the Element list.

8 Click Add.

9 The Electromagnetic Waves>Eigenfrequency analysis application mode now appears 
under Frame (ale) in the displayed tree structure.

10 Change Ruling application mode to Electromagnetic Waves (rfw).

11 Click OK to close the Model Navigator.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, choose Constants.

2 In the Constants dialog box, define the following constants. The description field is 
optional. When done, click OK.

For the parametric analysis, you replace the constant T1 for the operating temperature, 
T1, with a parameter T1 in the Solver Parameter dialog box.

NAME EXPRESSION DESCRIPTION

T0 0[degC] Reference temperature

T1 0[degC] Operating temperature
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G E O M E T R Y  M O D E L I N G

1 Go to the Draw menu and click the block symbol and define a block with Length X: 
0.02, Length Y: 0.02, Length Z: 0.07. Leave the other parameters at their defaults.

2 Click OK.

3 Click the Zoom Extents button to get a better view of the geometry.

4 Select Work-Plane Settings from the Draw menu.

5 Click OK to create a default xy work plane at z = 0.

6 Click the Zoom Extents button.

7 In the 2D work plane (Geom 2), go to Draw>Specify Objects>Circle to create a circle 
C1 with radius 0.004 and center at (0.01, 0.01).

8 Go to Draw>Extrude and extrude C1 a Distance of 0.067.

9 Press Ctrl+A to select all objects in the 3D geometry.

10 Click the Difference button on the Draw toolbar.

11 Click the Zoom Extents button on the Main toolbar.

B O U N D A R Y  C O N D I T I O N S  ( S H E L L )

1 From the Multiphysics menu, select Geom1: Shell (smsh).

2 In the Boundary settings dialog box, click the Groups tab.
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3 Select the unnamed1 group and change the Name to Brass.

4 Change the Young’s modulus to 1.05e11 (Pa).

5 Change the Poisson’s ratio to 0.35.

6 Change the Density to 8400 (kg/m3).

7 Change the Thermal expansion coeff. to 2.1e-5 (K−1).

8 Change the Thickness to 0.002 (m).

9 Click the Load tab and click Include thermal expansion.

10 Set Strain temperature to T1 and Strain ref. temperature to T0.

11 Click New to create a new group that inherits the settings for “Brass” and name it 
“Steel.”

12 Click the Material tab.

13 Change the Young’s modulus to 2e11 (Pa).

14 Change the Density to 7800 (kg/m3).

15 Change the Thermal expansion coeff. to 1.15e-5 (K−1). 

16 Click the Boundaries tab. By now, all boundaries, should belong to the “Brass” 
group and “Steel” is only there for future use.

17 Click OK.

P O I N T  S E T T I N G S

Appropriate point settings must be applied to eliminate any translation or rotation of 
the structure.

1 In the Point settings dialog box, select Point 1.

2 Constrain Rx, Ry, and Rz to 0.

3 Select Point 3 and constrain Rx and Rz to 0.

4 Select Point 13 and constrain Ry and Rz to 0.

5 Click OK.

B O U N D A R Y  C O N D I T I O N S  ( A L E )

The default subdomain settings in ALE is “free displacement,” which is right for this 
model so you only need to set the ALE boundary displacements to the displacements 
from the shell application mode.

1 From the Multiphysics menu, select Geom1: Moving Mesh ALE (ale).

2 In the Boundary settings dialog box, select all boundaries.
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3 Set dx, dy, and dz to u, v, and w, respectively. 

4 Click OK.

B O U N D A R Y  C O N D I T I O N S  ( E M  W AV E S )

The default boundary and subdomain settings in the Electromagnetic Wave 
application mode are “perfect electric conductor” and “air,” which is fine for this 
analysis.

M E S H  G E N E R A T I O N

1 Open the Free Mesh Parameters dialog and select Finer from the Predefined mesh sizes 
list and close the dialog by clicking OK.

2 Click the Initialize Mesh button in the toolbar to generate the mesh.

3 To see the mesh and later the solution better, go to the Options menu and select 
Suppress>Suppress Boundaries and select Boundaries 1, 2, and 4. Click OK and go to 
mesh mode by clicking the Mesh Mode button on the Main toolbar.

C O M P U T I N G  T H E  S O L U T I O N  ( S H E L L )

Use the parametric solver to study thermal expansion as a function of temperature. The 
solver settings are adapted for the ruling application mode, which is the 
electromagnetic problem. You need to change these settings to fit also the structural 
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problem. Also make use of the option to record the solver calls in a log that you can 
replay later.

1 In the Solver Parameters dialog box select the Parametric solver.

2 Enter T1 as Parameter name and linspace(273.15,373.15,11) as 
Parameter values. The solver then calculates the solution using 11 equidistant 
temperature values in the range 273.15 K to 373.15 K.

3 Click OK.

4 Open the Solver Manager from the Solve menu.

5 Click the Initial value expression button in the Initial value area.

6 Click the Solve For tab and select only the Shell (smsh) variables.

7 Click the Script tab and select the Automatically add commands when solving check 
box.

8 Click OK.

9 Solve by clicking the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Open the Plot Parameters dialog box and clear the Slice check box in the Plot type 
area on the General tab. Instead, select the Boundary and Deformed shape plots.

2 Click the Boundary tab and select Shell (smsh)>Total displacement from the list of 
Predefined quantities.

3 Click the Deform tab and clear the Subdomain check box in the Domain types to 

deform area.
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4 Click OK.

C O M P U T I N G  T H E  S O L U T I O N  ( A L E )

To map the shell deformations smoothly to the volume mesh, you must solve the ALE 
problem. Use the parametric solver again, now starting from the previous solutions:

1 Open the Solver Manager.

2 Click the Initial value tab.

3 In the Values of variables not solved for and linearization point area, click the 
Stored solution option button.

4 Click Store Solution and then click OK in the dialog that opens (store all solutions).

5 Select All from the Parameter value list.

6 Click the Solve For tab and select only the Moving Mesh (ALE) (ale) variables.

7 Click OK to close the Solver Manager.

8 Solve by clicking the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Open the Plot Parameters dialog box and select the Slice check box in the Plot type 
area on the General tab. 
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2 Click the Slice tab and change Number of levels to 1 X level and type 
sqrt(dx_ale^2+dy_ale^2+dz_ale^2) in the Expression field.

3 Click OK.

E X P O R T I N G  D A T A  T O  C O M S O L  S C R I P T

1 Go to the File menu and select Export>FEM Structure.

2 Type fem_brass in the dialog that appears.

3 Click OK and close the COMSOL Script window that appears.

B O U N D A R Y  C O N D I T I O N S  ( S H E L L )

Change the material in the post from brass to steel.

1 From the Multiphysics menu, select Geom1: Shell (smsh).

2 In the Boundary settings dialog box, change Group from Brass to Steel for Boundaries 
6–10.

3 Click OK.

C O M P U T I N G  T H E  S O L U T I O N  U S I N G  A  S O L V E R  S C R I P T

Now, you must repeat the solution steps above. To automate this, use the solver script 
that has been recorded.
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1 Open the Solver Manager.

2 Click the Script tab.

3 Select the Solve using a script check box.

4 Click OK.

5 Solve by clicking the Solve button.

E X P O R T I N G  D A T A  T O  C O M S O L  S C R I P T

1 Go to the File menu and select Export>FEM Structure.

2 Type fem_steel in the dialog that appears.

3 Click OK and close the COMSOL Script window that appears.

C O M P U T I N G  T H E  S O L U T I O N  ( E M  WA V E S )

From the graphical user interface, the electromagnetic problem can only be solved for 
one temperature at a time. Perform this for one temperature. Then go to the 
COMSOL Script command window for the rest of the analysis.

1 Open the Solver Manager.

2 Click the Script tab.

3 Clear the Solve using a script check box.
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4 Click the Solve For tab and select only the Electromagnetic Waves (rfw) variables.

5 Click the Initial Value tab.

6 Change Parameter value to 373.15.

7 Click the Store Solution button and then click OK in the dialog that opens (store all 
solutions).

8 Click OK to close the Solver Manager.

9 Open the Solver Parameters dialog.

10 Change Solver to Eigenfrequency.

11 Set Desired number of eigenfrequencies to 1 and Search for eigenfrequencies around to 
1e9.

12 Click OK to close the Solver Parameters dialog box.

13 Solve by clicking the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Open the Plot Parameters dialog box and clear the Deformed shape check box under 
Plot type on the General tab. Keep the Boundary and Slice plots. 

2 Click the Boundary tab and select Electromagnetic Waves (rfw)>Surface current 

density, norm from the Predefined quantities list.

3 Click the Slice tab and select Electromagnetic Waves (rfw)>Electric field, norm from 
the Predefined quantities list.
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4 Click OK. Note that the results might differ slightly from the plot below because the 
mesh on your computer can be different and the plotted quantities are rather mesh 
sensitive.

C O M P U T I N G  T H E  S O L U T I O N  I N  C O M S O L  S C R I P T

Open the COMSOL Script command window from the File menu. Then issue the 
following commands to solve the electromagnetic problem for all temperature values 
for the two filter designs. The solver calls can essentially be copied from the Script page 
in the Solver Manager. COMSOL Script can open and run M-files, so the most 
convenient procedure is to save the commands in a text file and save it with the file 
extension .m, for example, eigloop.m.

fem = fem_brass;
fem1 = fem;
T = fem.sol.plist;
freq = zeros(size(T));
for k=1:length(T)
  u = asseminit(fem1,'init',fem.sol,'solnum',k);
  fem1.sol=femeig(fem1,'u',u, ...
                  'solcomp',{'tExEyEz10'}, ...
                  'outcomp',{'z','thz','w','lm9','lm8', ...
                  'v','tExEyEz10','thx','lm7','u','y', ...
                  'thy','x'},'neigs',1, ...
                  'shift',-6.283185e9*i);
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  freq(k) = 
postinterp(fem1,'nu_rfw',zeros(0,1),'dom',1,'solnum',1);
end;
plot(T,freq,'+-');
grid on;
hold on;

fem = fem_steel;
fem1 = fem;
T = fem.sol.plist;
freq = zeros(size(T));
for k=1:length(T)
  u = asseminit(fem1,'init',fem.sol,'solnum',k);
  fem1.sol=femeig(fem1,'u',u, ...
                  'solcomp',{'tExEyEz10'}, ...
                  'outcomp',{'z','thz','w','lm9','lm8', ...
                  'v','tExEyEz10','thx','lm7','u','y', ...
                  'thy','x'},'neigs',1, ...
                  'shift',-6.283185e9*i);
  freq(k) = 
postinterp(fem1,'nu_rfw',zeros(0,1),'dom',1,'solnum',1);
end;
plot(T,freq,'o-');
grid on;
hold on;
legend('Brass','Steel');
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Wavegu i d e  H -B end w i t h  S - p a r ame t e r s

Introduction

This example is an extension of the waveguide H-bend model found on page 21 in the 
RF Module User’s Guide. For a general introduction to the model, see the RF Module 
User’s Guide.

The purpose of the model is to calculate how well a TE10 wave propagates through a 
bend in a waveguide filled with a dielectric medium. This is done by calculating the 
scattering parameters, or S-parameters, of the waveguide bend as a function of the 
frequency, for the fundamental TE10 mode. The S-parameters are a measure of the 
transmittance and reflectance of the waveguide bend. For a theoretical background on 
S-parameters, see the section “S-Parameters and Ports” on page 56 in the RF Module 
User’s Guide.

This model only includes the TE10 mode of the waveguide, and you can therefore 
make the model in 2D, because the fields of the TE10 mode have no variation in the 
transverse direction. The figure below shows the modeling geometry.

The bend of the waveguide is made of a dielectric medium with the refractive index 
n = 1.45.
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Model Definition

The governing equation for transverse electric (TE) waves with the transversal 
component Ez is given by

where n is the refractive index, and k0 is the free space wave number.

The entrance and exit ports do not represent physical boundaries in the geometry. To 
avoid reflection at these boundaries, matched boundary conditions make the 
boundaries transparent to the wave.

Results and Discussion

The following figure shows the S-parameters as a function of frequency. The S11 
parameter corresponding to the reflectance is given by the curve with plus sign 
markers. The S21 parameter corresponding to the transmittance is given by the curve 
with circle markers.

The resonances at 4.6 GHz, 5.3 GHz, and 6.0 GHz are the cavity resonances of the 
dielectric region in the bend.

∇– ∇Ez n2k0
2Ez–⋅ 0=
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Model Library path: RF_Module/RF_and_Microwave_Engineering/
hbend_S_parameters

Modeling Using the Graphical User Interface

Begin by following the steps in the section “2D Modeling Using the Graphical User 
Interface” on page 33 in the RF Module User’s Guide. Then continue as follows.

G E O M E T R Y  M O D E L I N G

1 Click the Line button, and click at (0, 0.0174) and at (0, -0.0174) with the left 
mouse button. Then click with the right mouse button to add the line to the 
geometry.

2 Draw another line from (0.0575, 0.075) to (0.0924, 0.075).

S C A L A R  V A R I A B L E S

In the Application Scalar Variables dialog box, set the frequency nu_rfwe to fq1.

B O U N D A R Y  C O N D I T I O N S

The default boundary condition is perfect electric conductor which is fine for all 
exterior boundaries except at the ports. Interior boundaries are by default not active 
meaning that the software imposes continuity.

For Boundaries 1 and 7, specify the Port boundary condition with the following 
settings (to set the mode specification and the mode number, go to the Port page):

S U B D O M A I N  S E T T I N G S

In the Subdomain Settings dialog box, select Specify material parameters in terms of 

refractive index in Subdomain 2. Then set the refractive index to 1.45.

SETTINGS BOUNDARY 1 BOUNDARY 7

Port number 1 2

Wave excitation at this port Selected Cleared

Mode specification Analytic Analytic

Mode number 1 1
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M E S H  G E N E R A T I O N

Initialize a mesh and refine it twice.

C O M P U T I N G  T H E  S O L U T I O N

Use the parametric solver to study the S-parameters as functions of the frequency.

1 In the Solver Parameters dialog box select the Parametric solver.

2 Enter fq1 as Parameter name and linspace(4.31e9,6e9,50) as Parameter values. 
The solver will calculate the solution using 50 equidistant frequency values in the 
range 4.31 GHz to 6 GHz. The frequency 4.31 GHz is just above the cutoff 
frequency.

3 Solve by clicking the Solve button.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

You can plot the S-parameters using a domain plot.

1 In the Domain Plot Parameters dialog box select all solutions in the Solutions to use 
list.

2 Select the Point tab and select S_parameter dB(S11) from the list of Predefined 

quantities.
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3 S11 is defined everywhere, but you only need to evaluate it at a single point to make 
a plot as a function of frequency. Select point 1 and click Apply to plot S11.

4 On the General tab select Keep current plot.

5 Select the Point tab and select S_parameter dB(S21) from the list of Predefined 

quantities and click Apply.

Note: When displaying S-Parameter variables, the phase of the solution must be set 
to zero. Otherwise, incorrect values will be displayed. In the various dialogs for 
displaying and plotting data that are available from the Postprocessing menu, the 
phase of the solution can be set via the Solution at angle (phase) field. If the dialog box 
contains several tabs, it usually appears on the General tab.
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Wavegu i d e  Adap t e r

Introduction

This is a model of an adapter for microwave propagation in the transition between a 
rectangular and an elliptical waveguide. Such waveguide adapters are designed to keep 
energy losses due to reflections at a minimum for the operating frequencies. To 
investigate the characteristics of the adapter, the simulation includes a wave traveling 
from a rectangular waveguide through the adapter and into an elliptical waveguide. 
The S-parameters are calculated as functions of the frequency. The involved 
frequencies are all in the single-mode range of the waveguide, that is, the frequency 
range where only one mode is propagating in the waveguide.

Model Definition

The waveguide adapter consists of a rectangular part smoothly transcending into an 
elliptical part as seen in Figure 3-12.

Figure 3-12: The geometry of the waveguide adapter.

The walls of manufactured waveguides are typically plated with a good conductor such 
as silver. The model approximates the walls by perfect conductors. This is represented 
by the boundary condition n × E = 0.
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The rectangular port is excited by a transverse electric (TE) wave, which is a wave that 
has no electric field component in the direction of propagation. This is what an 
incoming wave would look like after traveling through a straight rectangular 
waveguide with the same cross section as the rectangular part of the adapter. The 
excitation frequencies are selected so that the TE10 mode is the only propagating mode 
through the rectangular waveguide. The cutoff frequencies for the different modes are 
given analytically from the relation

where m and n are the mode numbers, and c is the speed of light. For the TE10 mode, 
m = 1 and n = 0. With the dimensions of the rectangular cross section (a = 2.286 cm 
and b = 1.016 cm), the TE10 mode is the only propagating mode for frequencies 
between 6.6 GHz and 14.7 GHz. 

At the elliptical port of the waveguide, the solution of an eigenmode problem on the 
port boundary gives the propagating mode. The elliptical port is passive, but the 
eigenmode is still used in the boundary condition of the 3D propagating wave 
simulation. Using the RF Module’s Boundary Mode Analysis application mode, the 
eigenmode equation is

Here Hn is the component of the magnetic field perpendicular to the boundary, n the 
refractive index, β the propagation constant in the direction perpendicular to the 
boundary, and k0 the free space wave number. The eigenvalues are λ = −jβ. The 
dimensions of the elliptical end of the waveguide are such that the frequency range for 
the lowest propagating mode overlaps that of the rectangular port.

With the stipulated excitation at the rectangular port and the numerically established 
mode shape at the elliptical port as boundary conditions, the following equation is 
solved for the electric field vector E inside the waveguide adapter:

where µr denotes the relative permeability, j the imaginary unit, σ the conductivity, ω 
the angular frequency, εr the relative permittivity, and ε0 the permittivity of free space. 
The model uses the following material properties for free space: σ = 0 and µr = εr = 1.
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Results

The first eigenmode of the elliptical port is displayed in Figure 3-13. The effective 
mode index is β/k0 = 0.535.

Figure 3-13: The x component of the electric field for the first eigenmode of the elliptical 
port.
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Figure 3-14 shows a single-mode wave propagating through the waveguide.

Figure 3-14: The x component of the propagating wave inside the waveguide adapter at 
the frequency 10 GHz.

Naming the rectangular Port 1 and the elliptical Port 2, the S-parameters describing 
the reflection and transmission of the wave are defined as follows:

Here Ec is the calculated total field. E1 is the analytical field for the port excitation, 
and E2 is the eigenmode calculated from the boundary mode analysis and normalized 

S11

Ec E1–( ) E1
*⋅( ) A1d

Port 1
∫

E1 E1∗⋅( ) A1d
Port 1
∫

-----------------------------------------------------------------=

S21

Ec E2
*⋅( ) A2d

Port 2
∫

E2 E2
*⋅( ) A2d

Port 2
∫

-----------------------------------------------=
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with respect to the outgoing power flow. Figure 3-15 and Figure 3-16 show the S11 
and S21 parameters as functions of the frequency. 

Figure 3-15: The S11 parameter (in dB) as a function of the frequency. This parameter 
describes the reflections when the waveguide adapter is excited at the rectangular port.
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Figure 3-16: The S21 parameter (in dB) as a function of the frequency. This parameter is 
a measure of the part of the wave that is transmitted through the elliptical port when the 
waveguide adapter is excited at the rectangular port.

Modeling in COMSOL Multiphysics

This model uses the RF Module’s Port boundary condition for the wave propagation 
problem. With this boundary condition the software computes the S-parameters 
automatically. The mode of the incoming wave is specified. The mode of the outgoing 
wave is given from an eigenmode analysis on the cross section of the elliptical part of 
the waveguide adapter.

To create the geometry of the waveguide adapter from the command line, use the loft 
command, which provides a smooth connection between the box and the ellipse. The 
resulting geometry is available in a COMSOL binary file, 
waveguide_adapter_geometry.mphbin. The script for creating the geometry is 
available at the end of the model description.
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Model Library path: RF_Module/RF_and_Microwave_Engineering/
waveguide_adapter

Modeling Using the Graphical User Interface

To set up the waveguide adapter model, the analysis contains two steps: First perform 
the boundary mode analysis on the elliptical port of the adapter, then solve the wave 
propagation problem using the mode shape as a boundary condition.

Mode Analysis

M O D E L  N A V I G A T O R

1 Select 3D in the Space dimension list.

2 Select the RF Module>Boundary Mode Analysis>TE Waves application mode, click the 
Multiphysics button, and click the Add button to add the application mode to the 
model.

3 Then select the RF Module>Electromagnetic Waves>Harmonic propagation application 
mode from the tree view.

4 From the Element list, select Vector - Quadratic, and click the Add button.

5 Click OK to close the Model Navigator.

G E O M E T R Y  M O D E L I N G

1 From the File menu, choose Import>CAD Data From File.

2 In the Import CAD Data From File dialog box, make sure that the COMSOL Multiphysics 

file or All 3D CAD files is selected in the Files of type list.

3 From the models directory under the COMSOL Multiphysics installation folder, 
locate the waveguide_adapter_geometry.mphbin file in the model path specified 
on page 91, and click Import.

First use the Boundary Mode Analysis application mode to compute the eigenmode of 
the elliptical end. This eigenmode is then part of the boundary condition for the 
electromagnetic wave propagation simulation.
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P H Y S I C S  S E T T I N G S

First set up the boundary mode analysis problem. Select Boundary Mode Analysis from 
the Multiphysics menu.

Scalar Variables
In the Application Scalar Variables dialog box, set the frequency nu_rfwb to 7e9. This 
is a frequency above the cutoff frequency, which ensures that you find a propagating 
wave mode when doing the mode analysis.

Boundary Settings
In the Boundary Settings dialog box, select all boundaries with Ctrl+A and clear the 
Active in this domain check box. Then select Boundary 6 and select the same check box 
again, so this is the only active boundary. This boundary is the elliptical end of the 
waveguide, where you perform the mode analysis.

Edge Settings
In the Edge Settings dialog box select the Perfect electric conductor boundary condition 
at Edges 5, 6, 10, 14, 29, 39, 52, and 55. These are the exterior edges of the ellipse.

M E S H  G E N E R A T I O N

1 Open the Free Mesh Parameters dialog box from the Mesh menu.

2 Click the Custom mesh size button, and enter 0.006 in the Maximum element size 
edit field.

3 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Open the Solver Manager dialog box from the Solve menu and select only the 
Boundary Mode Analysis application mode on the Solve For tab. Click OK.

2 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Visualize the eigenmodes as a boundary plot:

1 In the Plot Parameters dialog box, clear the Slice check box and select the Boundary 
check box in the Plot type area on the General page.

2 Select 0.535 from the Effective mode index list.

3 On the Boundary tab, select the Tangential electric field, x component. There are two 
field variables one for each of the two application modes. Pick the tEx_rfwb 
variable.
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4 Click OK to plot the field and click the Go to XY View button to better see the field 
(see Figure 3-13 on page 87)

5 Make the same type of plot of the y component of the electric field, tEy_rfwb.

Figure 3-17: The y-component of the electric field for the first eigenmode of the elliptical 
port.

6 To see the normal component of the magnetic field, start by selecting Normal 

magnetic field from the Predefined quantities list.

7 On the General tab, enter 90 in the Solution at angle (phase) edit field. This 
compensates for the phase shift of 90° between the electric and the magnetic field.

8 Click OK to see the plot.
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F R E E Z I N G  T H E  B O U N D A R Y  M O D E  A N A L Y S I S  A P P L I C A T I O N  M O D E

1 From the Physics menu, choose Properties to open the Application Mode Properties 
dialog box. From the Specify eigenvalues using list, choose Manual eigenvalue.

2 Click OK.

When you perform this operation, you copy the propagation constant for the 
current plot to an application mode scalar variable for the propagation constant. All 
postprocessing variables now use this propagation constant instead of computing it 
from the eigenvalues. The application mode is in a state where it makes no sense to 
solve for eigenvalues. So before re-solving this application mode again, switch back 
to the original setting in the Application Mode Properties dialog box.

S-Parameter Analysis

Now continue to set up the 3D problem to do the S-parameter analysis. Start by 
clicking the Go to Default 3D View button in order to see the full geometry.

B O U N D A R Y  S E T T I N G S

1 Choose Electromagnetic Waves (rfw) from the Multiphysics menu.

2 Open the Boundary Settings dialog box.

3 At the rectangular end, Boundary 13, select the Port boundary condition and enter 
the port number (1). Then click the Port tab to specify the mode at this port 
according to the following table:

DESCRIPTION VALUE

Port number 1

Wave excitation at this port selected

Mode specification Rectangular

Mode type Transverse electric (TE)

Mode number 10
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4 At the elliptical end (Boundary 6) also select the Port boundary condition and enter 
the port number (2) on the Conditions page. Then click the Port tab to specify the 
mode at this port according to the following table:

5 Use the default Perfect electric conductor boundary condition at all other 
boundaries.

C O M P U T I N G  T H E  S O L U T I O N

1 Open the Solver Manager dialog box. On the Initial Value tab, click the Store Solution 
button. In the dialog box that appears, select the solution with the effective mode 
index close to 0.535 and click OK.

2 In the Initial value area, click the Stored solution option button.

3 On the Solve For tab select only the Electromagnetic Waves application mode.

4 Click OK to close the Solver Manager.

5 In the Solver Parameters dialog box, select the Parametric solver. 

6 Set Parameter name to freq and Parameter values to linspace(6.6e9,1e10,50).

7 Click OK to close the Solver Parameters dialog box.

8 Open the Application Scalar Variables dialog box from the Physics menu and clear the 
Synchronize equivalent variables check box. This allows you to set different values for 
the two frequency variables nu_rfwb and nu_rfw. nu_rfwb is the frequency variable 
for the Boundary Mode Analysis application mode. It is important that it retains its 
value of 7·109 for the data from the mode analysis solution to be evaluated correctly.

9 Set the frequency variable nu_rfw to freq. This is the frequency variable of the 3D 
Electromagnetic Waves application mode. Click OK.

10 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 To visualize the x component of the electric field in the waveguide, start by opening 
the Plot Parameters dialog box.

DESCRIPTION VALUE

Port number 2

Wave excitation at this port cleared

Mode specification Numeric

Mode type Automatic

Use numeric data from Boundary Mode Analysis, TE Waves (rfwb)
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2 On the General tab, make sure that the Solution at angle (phase) text field reads 0.

3 Clear the Boundary check box, and select the Slice check box.

4 Click the Slice tab and select Electromagnetic Waves (rfw)>Electric field, x component 
from the Predefined quantities list.

5 In the Slice positioning area, set the number of x levels, y levels, and z levels to 1, 1, 
and 0 respectively.

6 Choose wave from the Colormap list.

7 Click OK to see the plot in Figure 3-14 on page 88.

The Port boundary conditions generate two S-parameter variables, S11_rfw and 
S21_rfw as well as two variables S11dB_rfw and S21dB_rfw, which are the 
S-parameters on a dB scale. The names of the variables reflect the port numbers that 
you entered in the Boundary Settings dialog box. Make a domain plot in a point to plot 
the S-parameters as functions of frequency:

1 On the Point tab in Domain Plot Parameters dialog box select Point 1 and select 
Electromagnetic Waves (rfw)>S-parameter dB (S11). Click Apply to plot S11 on a dB 
scale.

2 When plotting S21 first deselect the first two data points on the General tab to better 
see the variation. Select the variable Electromagnetic Waves (rfw)>S-parameter dB 

(S21) and click OK to make the plot on page 90.

Note: When displaying S-parameter variables, you must set the phase of the solution 
to zero. Otherwise, the result displays show incorrect values. In most dialog boxes 
that are available on the Postprocessing menu, you can set the phase of the solution via 
the Solution at angle (phase) edit field. If the dialog box contains several tabs, it usually 
appears on the General tab.

Creating the Geometry in COMSOL Script or MATLAB

To create the geometry, run COMSOL Script from within COMSOL Multiphysics or 
start COMSOL Multiphysics with MATLAB. Open a new 3D model by selecting 3D 
from the Space dimension list in the Model Navigator and clicking OK. After running 
the script below from the command line, choose File>Import>Geometry Objects. In the 
dialog box that appears, enter the geometry object g7.

lx = 1.827/2; ly = 3.015/2; e1 = ellip2(lx,ly);
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y0 = 1.142999999817202; x0 = sqrt((1-y0^2/ly^2)*lx^2);
p1 = point2(x0, y0); p2 = scale(p1,1,-1);
p3 = rotate(p1,pi); p4 = scale(p3,1,-1);
g1 = solid2(geomcsg({e1},{},{p1},{p2},{p3},{p4}));
lx2 = 1.016; ly2 = 2.286;
r1 = solid2(geomcsg({rect2(lx2,ly2,'Base','center')},...
{point2(0,-2.286/2)},{point2(1.016/2,0)},...
{point2(0,2.286/2)},{point2(-1.016/2,0)}));
z0 = 3.0; z1 = 11.0;
wrk0 = geomgetwrkpln('quick',{'xy',z0});
wrk1 = geomgetwrkpln('quick',{'xy',z1});
t = cell(1,8);
t{1} = 3; t{2} = 2; t{3} = 4; t{4} = 5;
t{5} = 6; t{6} = 7; t{7} = 8; t{8} = 1;
g2 = loft({r1 g1},'LoftEdge',t,...
'wrkpln',{wrk0 wrk1},'loftmethod','linear');
g3 = extrude(r1,'distance',3);
g4 = extrude (g1,'distance',3,'wrkpln',wrk1);
g5 = geomcomp({g2,g3,g4},'repairtol',1e-8);
g6 = geomdel(g5);
g7 = scale(g5,0.01,0.01,0.01);
geomplot(g7);
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M i c r owa v e  Can c e r  Th e r ap y

Introduction

Electromagnetic heating appears in a wide range of engineering problems and is ideally 
suited for modeling in COMSOL Multiphysics because of its multiphysics capabilities. 
This example comes from the area of hyperthermic oncology and it models the 
electromagnetic field coupled to the bioheat equation. The modeling issues and 
techniques are generally applicable to any problem involving electromagnetic heating.

In hyperthermic oncology, cancer is treated by applying localized heating to the tumor 
tissue, often in combination with chemotherapy or radiotherapy. Some of the 
challenges associated with the selective heating of deep-seated tumors without 
damaging surrounding tissue are:

• Control of heating power and spatial distribution

• Design and placement of temperature sensors

Among possible heating techniques, RF and microwave heating have attracted much 
attention from clinical researchers. Microwave coagulation therapy is one such 
technique where a thin microwave antenna is inserted into the tumor. The microwaves 
heat up the tumor, producing a coagulated region where the cancer cells are killed.

This model computes the temperature field, the radiation field, and the specific 
absorption rate (SAR)—defined as the ratio of absorbed heat power and tissue 
density—in liver tissue when using a thin coaxial slot antenna for microwave 
coagulation therapy. It closely follows the analysis found in Ref. 1. It computes the 
temperature distribution in the tissue using the bioheat equation.

Model Definition

Figure 3-18 shows the antenna geometry. It consists of a thin coaxial cable with a 
ring-shaped slot measuring 1 mm cut on the outer conductor 5 mm from the 
short-circuited tip. For hygienic purposes, the antenna is enclosed in a sleeve (catheter) 
made of PTFE (polytetrafluoroethylene). The following tables give the relevant 
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geometrical dimensions and material data. The antenna operates at 2.45 GHz, a 
frequency widely used in microwave coagulation therapy.

Figure 3-18: Antenna geometry for microwave coagulation therapy. A coaxial cable with 
a ring-shaped slot cut on the outer conductor is short-circuited at the tip. A plastic catheter 
surrounds the antenna.

The model takes advantage of the problem’s rotational symmetry, which allows 
modeling in 2D using cylindrical coordinates as indicated in Figure 3-19. When 

TABLE 3-1:  DIMENSIONS OF THE COAXIAL SLOT ANTENNA.

PROPERTY VALUE

Diameter of the central conductor 0.29 mm

Inner diameter of the outer conductor 0.94 mm

Outer diameter of the outer conductor 1.19 mm

Diameter of catheter 1.79 mm

TABLE 3-2:  MATERIAL PROPERTIES.

PROPERTY INNER DIELECTRIC OF 
COAXIAL CABLE

CATHETER LIVER TISSUE

Relative permittivity 2.03 2.60 43.03

Conductivity 1.69 S/m
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modeling in 2D, you can select a fine mesh and achieve excellent accuracy. The model 
uses a frequency-domain problem formulation with the complex-valued azimuthal 
component of the magnetic field as the unknown.

Figure 3-19: The computational domain appears as a rectangle in the rz-plane.

The radial and axial extent of the computational domain is in reality larger than 
indicated in Figure 3-19. This problem does not model the interior of the metallic 
conductors, and it models metallic parts using boundary conditions, setting the 
tangential component of the electric field to zero.

D O M A I N  A N D  B O U N D A R Y  E Q U A T I O N S — E L E C T R O M A G N E T I C S

An electromagnetic wave propagating in a coaxial cable is characterized by transverse 
electromagnetic fields (TEM). Assuming time-harmonic fields with complex 
amplitudes containing the phase information, the appropriate equations are

where z is the direction of propagation, and r, , and z are cylindrical coordinates 
centered on the axis of the coaxial cable. Pav is the time-averaged power flow in the 
cable, Z is the wave impedance in the dielectric of the cable, while rinner and router are 
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the dielectric’s inner and outer radii, respectively. Further, ω denotes the angular 
frequency. The propagation constant, k, relates to the wavelength in the medium, λ, as

.

In the tissue, the electric field also has a finite axial component whereas the magnetic 
field is purely in the azimuthal direction. Thus, you can model the antenna using an 
axisymmetric transverse magnetic (TM) formulation. The wave equation then 
becomes scalar in : 

.

The boundary conditions for the metallic surfaces are

.

The feed point is modeled using a port boundary condition with a power level set to 
10 W. This is essentially a first-order low-reflecting boundary condition with an input 
field : 

where

for an input power of Pav deduced from the time-average power flow.

The antenna radiates into the tissue where a damped wave propagates. Because you can 
discretize only a finite region, you must truncate the geometry some distance from the 
antenna using a similar absorbing boundary condition without excitation. Apply this 
boundary condition to all exterior boundaries. Finally, apply a symmetry boundary 
condition for boundaries at r = 0:
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D O M A I N  A N D  B O U N D A R Y  E Q U A T I O N S — H E A T  TR A N S F E R

The bioheat equation describes the stationary heat transfer problem as

where k is the liver’s thermal conductivity (W/(m·K)), ρb represents the blood density 
(kg/m3), Cb is the blood’s specific heat capacity (J/(kg·K)), and ωb denotes the blood 
perfusion rate (1/s). Further, Qmet is the heat source from metabolism, and Qext is an 
external heat source, both measured in W/m3.

This model neglects the heat source from metabolism. The external heat source is 
equal to the resistive heat generated by the electromagnetic field:

.

The model assumes that the blood perfusion rate is ωb = 0.0036 s−1, and that the 
blood enters the liver at the body temperature Tb = 37 °C and is heated to a 
temperature, T. The blood’s specific heat capacity is Cb = 3639 J/(kg·K).

For a more realistic model, you might consider letting ωb be a function of the 
temperature. At least for external body parts such as hands and feet, it is evident that 
a temperature increase results in an increased blood flow.

This example models the heat-transfer problem only in the liver domain. Where this 
domain is truncated, it uses insulation, that is

.

Results and Discussion

Figure 3-20 shows the resulting steady-state temperature distribution in the liver tissue 
for an input microwave power of 10 W. The temperature is highest near the antenna. 
It then decreases with distance from the antenna and reaches 37 °C closer to the outer 
boundaries of the computational domain. The perfusion of relatively cold blood seems 
to limit the extent of the area that is heated.

∇ k T∇–( )⋅ ρbCbωb Tb T–( ) Qmet Qext+ +=

Qext
1
2
---Re σ jωε–( )E E*⋅[ ]=

n T∇⋅ 0=
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Figure 3-20: Temperature in the liver tissue.

Figure 3-21 shows the distribution of the microwave heat source. Clearly the 
temperature field follows the heat-source distribution quite well. That is, near the 
antenna the heat source is strong, which leads to high temperatures, while far from the 
antenna, the heat source is weaker and the blood manages to keep the tissue at normal 
body temperature.

Figure 3-21: The computed microwave heat-source density takes on its highest values near 
the tip and the slot. The scale is cut off at 1 W/cm3.
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Figure 3-22 plots the specific absorption rate (SAR) along a line parallel to the antenna 
and at a distance of 2.5 mm from the antenna axis normalized by its maximal value 
along the line. The results are in good agreement with those found in Ref. 1.

Figure 3-22: Normalized SAR value along a line parallel to the antenna and at a 
distance 2.5 mm from the antenna axis. The tip of the antenna is located at 70 mm, and 
the slot is at 65 mm.

Reference

1. K. Saito, T. Taniguchi, H. Yoshimura, and K. Ito, “Estimation of SAR Distribution 
of a Tip-Split Array Applicator for Microwave Coagulation Therapy Using the Finite 
Element Method,” IEICE Trans. Electronics, vol. E84-C, 7, pp. 948–954, July 2001.

Modeling in COMSOL Multiphysics

The COMSOL Multiphysics implementation is straightforward. Drawing the 
geometry is best done creating rectangles and setting their dimensions directly from 
the Draw menu. The scale differences together with the strong radial dependence of 
the electromagnetic fields make some manual adjustment of the mesh parameters 
necessary. In addition, 4th-order elements for the electromagnetic problem and a 
dense mesh in the dielectric result in well-resolved fields. The model computes the 
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solutions for both the electromagnetic problem and the heat transfer problem in 
parallel. This takes into account the coupling of the resistive heating from the 
electromagnetic solution into the bioheat equation. In principle, however, you could 
solve the two problems in sequence because there is only a 1-way coupling from the 
electromagnetic problem to the bioheat problem.

Model Library path: RF_Module/RF_and_Microwave_Engineering/
microwave_cancer_therapy

Note: This model requires the RF Module and the Heat Transfer Module.

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator. In the Space dimension list select Axial symmetry 2D.

2 In the list of application modes select  
Heat Transfer Module>Bioheat Equation>Steady-state analysis.

3 Click the Multiphysics button, then click the Add button.

4 In the list of application modes select 
RF Module>Electromagnetic Waves>TM Waves>Harmonic propagation.

5 In the Element list select Lagrange - Quartic.

6 Click Add, then click OK.

O P T I O N S  A N D  S E T T I N G S

From the Options menu select Constants. Enter the following names and expressions; 
when done, click OK.

NAME EXPRESSION EXPRESSION

k_liver 0.56[W/(kg*K)] Thermal conductivity, liver

rho_blood 1000[kg/m^3] Density, blood

C_blood 3639[J/(kg*K)] Specific heat, blood

omega_blood 3.6e-3[1/s] Blood perfusion rate
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G E O M E T R Y  M O D E L I N G

1 Create two rectangles. Select the menu item Draw>Specify Objects>Rectangle, then 
enter the following settings; when done with each one, click OK.

2 From the Draw menu open the Create Composite Object dialog box. Clear the Keep 

interior boundaries check box. In the Object selection box select both rectangles, then 
click the Union button. Click OK.

3 Following the procedure in Step 1, specify two more rectangles with the following 
properties:

4 Add a line to the geometry. Select the menu item Draw>Specify Objects>Line. In the 
r edit field enter the coordinates 0 8.95e-4 8.95e-4, and in the z edit field enter 
the coordinates 9.5e-3 0.01 0.08. Click OK.

5 Finally specify another rectangle with these parameters:

P H Y S I C S  S E T T I N G S

Subdomain Settings—Bioheat Equation
1 From the Multiphysics menu select 1 Bioheat Equation (htbh).

T_blood 37[degC] Blood temperature

P_in 10[W] Input microwave power

nu 2.45[GHz] Microwave frequency

eps_diel 2.03 Relative permittivity, dielectric

eps_cat 2.6 Relative permittivity, catheter

eps_liver 43.03 Relative permittivity, liver

sig_liver 1.69[S/m] Electric conductivity

WIDTH HEIGHT BASE CORNER R BASE CORNER Z

0.595e-3 0.01 0 0

29.405e-3 0.08 0.595e-3 0

WIDTH HEIGHT BASE CORNER R BASE CORNER Z

0.125e-3 1e-3 0.47e-3 0.0155

3.35e-4 0.0699 0.135e-3 0.0101

WIDTH HEIGHT BASE CORNER R BASE CORNER Z

1.25e-4 1e-3 4.7e-4 0.0155

NAME EXPRESSION EXPRESSION
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2 From the Physics menu select Subdomain Settings.

3 Select Subdomains 2, 3, and 4, then clear the Active in this domain check box.

4 Select Subdomain 1, then enter the following settings; when done, click OK.

Boundary Conditions—Bioheat Equation
1 From the Physics menu select Boundary Settings.

2 Select all the exterior boundaries (get them by pressing Ctrl+A, and note that the 
following step ignores the interior boundaries). 

3 In the Boundary condition list select Thermal insulation, then click OK.

Note: Because the model neglects metabolic heat generation you set Qmet to 0. The 
variable Qav_rfwh is a subdomain expression for the resistive heating provided by the 
TM Waves application mode.

Scalar Variables—TM Waves
1 From the Multiphysics menu select 2 TM Waves (rfwh).

2 From the Physics menu select Scalar Variables to open the Application Scalar Variables 
dialog box.

3 Find the variable nu_rfwh and set its value to nu, then click OK.

Boundary Conditions—TM Waves
1 From the Physics menu select Boundary Settings. 

PROPERTY VALUE

 k (isotropic) k_liver

 ρb rho_blood

 Cb C_blood

 ωb omega_blood

 Tb T_blood

 Qmet 0

 Qext Qav_rfwh
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2 Specify boundary settings according to the following table (to enter the port 
settings for Subdomain 8 go to the Port page); when finished, click OK.

For the (exterior) boundaries not mentioned in the table, the default condition 
(perfect electric conductor) applies.

Subdomain Settings—TM Waves
1 From the Physics menu select Subdomain Settings.

2 Enter the following settings; when finished, click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu open the Free Mesh Parameters dialog box. 

2 Go to the Global page, click the Custom mesh size button and in the Maximum 

element size edit field type 3e-3.

3 Go to the Subdomain page and select Subdomain 3. In the Maximum element size edit 
field type 1.5e-4.

4 Click Remesh, then click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows the temperature field. To change the unit to degrees Celsius, 
reproducing the plot in Figure 3-20, do as follows:

SETTINGS SUBDOMAINS 1, 3 SUBDOMAINS 2, 14, 18, 20, 21 SUBDOMAIN 8

Boundary condition Axial symmetry Scattering boundary 
condition

Port

Wave excitation at 
this port

selected

Pin P_in

Mode specification Coaxial

Wave type Spherical wave

SETTINGS SUBDOMAIN 1 SUBDOMAIN 2 SUBDOMAIN 3 SUBDOMAIN 4

 εr (isotropic) eps_liver eps_cat eps_diel 1

 σ (isotropic) sig_liver 0 0 0

 µr 1 1 1 1
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1 Click the Plot Parameters button on the Main toolbar.

2 Click the Surface tab. From the Unit list select oC, then click Apply.

The following steps describe how to visualize the resistive heating of the tissue:

1 In the Predefined quantities list select TM Waves (rfwh)>Resistive heating, time 

average. In the Unit edit field type W/cm^3, then click Apply.

Heating decreases rapidly in the liver tissue, resulting in an almost uniformly blue 
plot. To get a better feeling for the heating at a distance from the antenna, do as 
follows:

2 In the Expression edit field type min(Qav_rfwh,1[W/cm^3]), then click OK.

In the resulting plot, which reproduces that in Figure 3-21, the region around the 
antenna in which the time-averaged resistive heating exceeds 1 W/cm3 has a 
uniform, deep red color. Outside this region, you can read off the heating 
distribution from the color scale on the right.

To compute the total heating power deposited in the liver, follow these steps:

1 From the Postprocessing menu open the Subdomain Integration dialog box.

2 Select Subdomain 1. From the Predefined quantities list select 
TM Waves (rfwh)>Resistive heating, time average.

3 Select the Compute volume integral (for axisymmetric modes) check box. Click OK.

The result appears in the message log at the bottom of the user interface. The value 
of approximately 9.37 W indicates that the tissue absorbs most of the 10 W input 
power at stationary conditions.

These steps reproduce the plot in Figure 3-22, displaying the normalized SAR value:

1 From the Postprocessing menu open the Cross-Section Plot Parameters dialog box.

2 On the Line/Extrusion page, type Qav_rfwh/3.01[W/cm^3] in the Expression edit 
field. In both the r0 and r1 edit fields type 2.5e-3; in the z0 edit field type 0.08; 
and in the z1 edit field type 0.

3 Click the General tab, then click the Title/Axis button. In the Title/Axis Settings dialog 
box, select the option button next to the Title edit field, then enter the title 
Off-axis SAR values (distance = 2.5 mm).

4 In a similar way, enter the first axis label Insertion depth [m] and the second axis 
label SAR (normalized), then click OK to close the Title/Axis Settings dialog box.

5 Click OK to generate the plot.
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Ab s o r b ed Rad i a t i o n  ( S AR )  i n  t h e  
Human B r a i n

Scientists use the SAR (specific absorption rate) to determine the amount of radiation 
that human tissue absorbs. This measurement is especially important for mobile 
telephones, which radiate close to the brain. The model studies how a human head 
absorbs a radiated wave from an antenna, and the temperature increase that the 
absorbed radiation causes.

Introduction

The increasing use of wireless equipment has also increased the amount of radiation 
energy to which human bodies are exposed, and it is particularly important to avoid 
radiation into the brain. Experts continue to debate how dangerous this radiation 
might be. Almost everyone agrees, however, that it is important to minimize exposure 
to radiation. A common property that measures absorbed energy is the SAR value, 
calculated as

where σ is the conductivity of human brain tissue, ρ is the density, and |E| is the norm 
of the electric field. The SAR value is an average over a region of either 10 g or 1 g of 
brain tissue, depending on national rules. This model does not calculate the average 
value and so it refers to the local SAR value. The maximum local SAR value is always 
higher than the maximum SAR value.

Model Definition

The human head geometry is the same geometry (SAM Phantom) provided by IEEE, 
IEC and CENELEC from their standard specification of SAR value measurements. 
The original geometry was imported into COMSOL Multiphysics after minor 
adjustments of the original geometry.

In addition, the model samples some material parameters with a volumetric 
interpolation function that estimates the variation of tissue type inside the head. The 
source data for this function comes directly from a file named 

ESAR σ E 2

ρ
----------=
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sar_in_human_head_interp.txt. That data file was created from a 
magnetic-resonance image (MRI) of a human head; these images contain 109 slices, 
each with 256 × 256 voxels (Ref. 2). The use of the variation of the data in this file on 
the tissue material parameters has no scientific background, and this model simply 
implements it to illustrate a variation in conductivity, permittivity and perfusion rate as 
a function of the position inside the head. The model reduces the resolution of the 
volumetric data to 55 × 50 × 50 interpolation points, which matches the mesh-element 
density inside the head. Prior to generating the data file, the modeler in this case scaled, 
translated and rotated the 3D MRI data to match the form of the imported head 
geometry in COMSOL Multiphysics.

WAV E  P R O P A G A T I O N

The radiation comes from a patch antenna placed on the left side of the head. A line 
current on an edge act as an equivalent current source feeding the two patches of the 
antenna. To avoid reflections, the model makes use of PMLs; see “Perfectly Matched 
Layers (PMLs)” on page 43 in the RF Module User’s Guide. The model solves the 
Vector-Helmholtz equation everywhere in the domain for a certain frequency

where µr is the relative permeability, k0 is the free-space wave vector, and εr is the 
permittivity for a vacuum.

For wave-propagation problems such as this one, you must limit the mesh size 
according to the problem’s minimum wavelength. Typically you need about five 
elements per wavelength to properly resolve the wave.

This example takes material properties for the human brain from a presentation by 
G. Schmid (Ref. 1). The following table reviews some important frequency-dependent 
properties in this publication. The interpolation function samples these values to create 
a realistic variation.

H E A T I N G  O F  T H E  H E A D

The bioheat equation models the heating of the head with a heating loss due to the 
blood flow. This heat loss depends on the heat capacity and density of the blood, and 

PARAMETER FREQUENCY VALUE DESCRIPTION

 σ 835 MHz 1.35 S/m Conductivity

 εr 835 MHz 56 Relative permeability

∇ 1
µr
-----∇× E k0

2εrE–× 0=
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on the blood perfusion rate. The perfusion rate varies significantly in different parts of 
the human body, and the table below presents the values used here.

The same interpolation function used for the electric parameters also models the 
difference in perfusion rate between the brain tissue inside the head and the outer parts 
of skin and bone. Note again that the use of the interpolation function does not have 
any physical relevance, it is just to show a realistic effect of a varying material parameter.

Results and Discussion

The model studies the local SAR value in the head using the formula described earlier 
for the frequency 835 MHz. The SAR value is highest close to the surface of the head 
facing the incident wave. The differences in electrical properties become visible if you 
plot the local SAR value on a log scale.

Figure 3-23: Log-scale slice plot of the local SAR value.

PART PERFUSION RATE

Brain 2·10-3 (ml/s)/ml

Bone 3·10-4 (ml/s)/ml

Skin 3·10-4 (ml/s)/ml
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The bioheat equation produces a similar plot for the heating of the head, which is 
highest closest to the antenna. The maximum temperature increase (from 37 °C) is less 
than 0.2 °C, and drops rapidly inside the head.

Figure 3-24: The local increase in temperature at the surface has a maximum of 0.2 °C 
right beneath the antenna.

References

1. G. Schmid, G. Neubauer, P.R. Mazal, and F. Alesch, Dielectric properties of brain 
tissue: measurements on humans, http://www.cost281.org/download.php?fid=531.

2. M. Levoy, MRI data originally from Univ. of North Carolina (downloaded from the 
Stanford volume data archive at http://graphics.stanford.edu/data/voldata/).

Model Library path: RF_Module/RF_and_Microwave_Engineering/
sar_in_human_head
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Modeling Using the Graphical User Interface

Note: This model requires both the RF Module and the Heat Transfer Module.

M O D E L  N A V I G A T O R

1 In the Model Navigator, select 3D in the Space dimension list.

2 In the RF Module folder, select Electromagnetic Waves>Harmonic propagation.

3 Click the Multiphysics button.

4 Click the Add button.

5 In the Heat Transfer Module folder, select Bioheat Equation>Steady-state analysis.

6 In the Dependent variables edit field, type dT. Click Add.

7 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, choose Constants.

2 In the Constants dialog box, define the following constants with names, expressions, 
and descriptions (optional):

NAME EXPRESSION DESCRIPTION

epsilonr_pcb 5.23 Permittivity for the patch 
antenna board

epsilonr0_brain 56 Permittivity for the brain 
tissue

sigma0_brain 1.35[S/m] Conductivity for the brain 
tissue

rho_brain 1.03e3[kg/m^3] Density of brain tissue

sdamping 2e-4 Sampling parameter

edamping 4e-4 Sampling parameter

soffset -1.0[S/m] Sampling parameter

eoffset -50 Sampling parameter

rho_blood 1000[kg/m^3] Density of blood

c_blood 3639[J/(kg*K)] Heat capacity of blood

odamping 1.08e-6[1/s] Sampling parameter

ooffset -7.8e-4[1/s] Sampling parameter
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3 Click OK.

4 From the Options menu, choose Functions.

5 In the Functions dialog box, click the New button.

6 In the New Function dialog box, type fbrain in the Function name edit field, select 
the Interpolation radio button, and select File from the Use data from drop-down 
menu.

7 Click the Browse button and locate the file named 
sar_in_human_head_interp.txt. Select the file and click Open to use it. Click OK 
to create the interpolation function.

8 From the Extrapolation method list, select Constant.

9 Click OK.

G E O M E T R Y  M O D E L I N G

The head geometry has been created outside COMSOL Multiphysics, so you import 
it from an mphbin file (COMSOL’s native geometry format). Then create the 
surrounding domains of PMLs, air, and antenna manually.

1 From the File menu, choose Import>CAD Data From File.

2 In the Import CAD Data From File dialog box, make sure that COMSOL Multiphysics file 
or All 3D CAD files is selected in the Files of type list.

3 Locate the file sar_in_human_head.mphbin, then click Import.

4 From the Draw menu, choose Work-Plane Settings.
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5 In the Work-Plane Settings dialog box, type -0.3 in the z edit field, and click OK.

6 From the Draw menu, choose Specify Objects>Rectangle.

7 In the Rectangle dialog box, specify a rectangle with the following settings and click 
OK when done.

8 Specify two more rectangles with the following settings:

9 Select the smaller rectangle with label R2.

10 Click the Array button on the Draw toolbar. In the dialog box that appears, fill in 
the following fields. Click OK when done.

11 Select all objects and click the Union button on the Draw toolbar.

12 From the Draw menu, choose Extrude.

13 Enter 0.1 0.5 0.6 in the Distance edit field and click OK.

You have now created the surrounding air and the PML regions. Continue with the 
patch antenna close to the head.

14 Click the Block toolbar button.

15 In the Block dialog box, click the Center option button and fill in the following fields. 
Click OK when done.

16 From the Draw menu, choose Work-Plane Settings.

17 In the Work-Plane Settings dialog box, click the Face Parallel tab. Expand the BLK1 
object, and choose face number 2.

18 Click OK. You now see a work plane parallel to the face of the block facing the head.

WIDTH HEIGHT X Y

0.4 0.4 -0.2 -0.2-0.03

WIDTH HEIGHT X Y

0.1 0.1 -0.3 -0.3-0.03

0.6 0.6 -0.3 -0.3-0.03

X (DISPLACEMENT) Y (DISPLACEMENT) X (ARRAY SIZE) Y (ARRAY SIZE)

0.5 0.5 2 2

X (LENGTH) Y (LENGTH) Z (LENGTH) AXIS BASE POINT (X, Y, Z)

0.004 0.08 0.08 (0.1, 0, 0.05)
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19 Specify two rectangles with the following settings.

20 Select both rectangles and click the Union button on the Draw toolbar.

21 Click the Delete Interior Boundaries toolbar button to delete the internal boundary 
between the rectangles.

22 From the Draw menu, choose Embed, and click OK in the dialog box that appears. 
This places the drawn object onto the face of the block in the 3D geometry.

23 From the Draw menu, choose Work-Plane Settings.

24 In the Work-Plane Settings dialog box, click the Face Parallel tab. Expand the BLK1 
object, and choose face 1. Click OK.

25 Specify one rectangle with the following settings.

26 From the Draw menu, choose Embed. Click OK.

WIDTH HEIGHT X Y

0.06 0.06 0.01 0.01

0.005 0.01 0.04-0.0025 0

WIDTH HEIGHT X Y

0.004 0.005 0 0.04-0.0025
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27 Click the Zoom Extents button on the Main toolbar and the Headlight toolbar button 
on the Camera toolbar. Select the head geometry objects to see the geometry 
plotted below.

P H Y S I C S  S E T T I N G S  ( E L E C T R O M A G N E T I C  W AV E S )

1 From the Multiphysics menu, choose Electromagnetic Waves (rfw).

2 From the Physics menu, choose Application Scalar Variables.

3 In the Scalar Variables dialog box, change the value of the frequency, nu_rfw, to 
835[MHz].

4 Click OK.

5 From the Options menu, select Expressions>Subdomain Expressions.

6 In the Subdomain Expressions dialog box, define variables according to the following 
table:

SETTINGS SUBDOMAIN 19

dSAR Qav_rfw/rho_brain

sigma_brain sigma0_brain*(1+fbrain(x[1/m],y[1/m],z[1/m])*sdamping) 
+soffset
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7 Click OK.

Boundary Conditions
1 From the Physics menu, open the Boundary Settings dialog box.

2 Select all exterior boundaries (use the Select by group check box) and choose the 
Scattering boundary condition from the Boundary condition list.

3 Select the Interior boundaries check box to allow settings on interior boundaries. 
Make sure that the Select by group check box is cleared.

4 Select Boundaries 92 and 96 (patches on the antenna) and choose Perfect electric 

conductor from the Boundary condition list.

5 Select Boundary 93 (boundary between patches) and choose Lumped port from the 
Boundary condition list.

6 Select the Voltage generator at this port check box.

7 Enter 45.5 in the Vin edit field.

8 Click the Port tab and type 75 in the Zref edit field.

9 Click OK. The voltage applied to the lumped port is quite high due to the impedance 
mismatch between the antenna and the external cable impedance, which is set to 
75 Ω.

Subdomain Settings
1 From the Physics menu, open the Subdomain Settings dialog box.

2 Define the subdomain settings according to the following table:

3 Click the PML tab and define the PML regions according to the table below. Note 
that the subdomain selections are overlapping. Make sure that all selections, except 
those specified as “As is,” are white and not yellow. A yellow color means that the 

epsilonr_brain epsilonr0_brain*(1+fbrain(x[1/m],y[1/m],z[1/m])*edamping)
+eoffset

omega_head fbrain(x[1/m],y[1/m],z[1/m])*odamping+ooffset

SETTINGS SUBDOMAIN 19

SETTINGS SUBDOMAIN 19 SUBDOMAIN 20

 εr epsilonr_brain epsilonr_pcb

 σ sigma_brain 0
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property has different values among the selected subdomains. You fix this by 
reselecting the property to the specified value.

4 Click OK.

P H Y S I C S  S E T T I N G S  ( B I O H E A T  E Q U A T I O N )

From the Multiphysics menu, choose Bioheat Equation (htbh).

Boundary Conditions
The default boundary condition, thermal insulation, applies everywhere.

Subdomain Settings
1 From the Physics menu, open the Subdomain Settings dialog box.

2 Select all subdomains except Subdomain 19, and clear the Active in this domain 
check box.

3 Then select Subdomain 19, and enter the following expressions.

SETTINGS SUBDOMAINS 1–9, 21–
29

SUBDOMAINS 1–3, 7–12, 
16–18, 21–23, 27–29

SUBDOMAINS 1, 3, 4, 6, 
7, 9, 10, 12, 13, 15, 16, 18, 
21, 23, 24, 26, 27, 29

Type of PML Cartesian Cartesian Cartesian

Absorbing in 
x direction

Selected As is As is

Width in 
x direction

2*Sdx_guess_rfw As is As is

Absorbing in 
y direction

As is Selected As is

Width in 
y direction

As is 2*Sdy_guess_rfw As is

Absorbing in 
z direction

As is As is Selected

Width in 
z direction

As is As is 2*Sdz_guess_rfw

PARAMETER EXPRESSION

 ρb rho_blood

 Cb c_blood

 ωb omega_head

 Tb 0

 Qext Qav_rfw
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4 Click the Init tab and type 0 in the dT(t0) edit field.

5 Click OK.

M E S H  G E N E R A T I O N

The steps to generate the mesh involve interactive meshing, where you use the 
standard free meshing for the head, patch, and surrounding air. For the PML regions, 
use swept meshing. This gives more control of the mesh resolution in the absorbing 
direction, which is crucial to get convergence with iterative solvers.

1 From the Mesh menu, choose Free Mesh Parameters.

2 Select Coarser from the Predefined mesh sizes list.

3 Click the Edge tab, select all edges of the patch facing the head (Edges 132–135, 
137–138, 140–142, and 149). Enter 2e-3 in the Maximum element size edit field.

4 Click the Boundary tab, select Boundaries 73 and 78, enter 0.4 in the Mesh curvature 

factor edit field, and enter 0.01 in the Mesh curvature cutoff edit field.

5 Click the Subdomain tab, select Subdomain 19 and enter 0.015 in the Maximum 

element size edit field.

6 Select Subdomains 14, 19, and 20, and click the Mesh Selected button.

7 Click OK to close the Free Mesh Parameters dialog box.

8 Open the Swept Mesh Parameters dialog box from the Mesh menu.

9 Select the Subdomains 5, 11, 13, 15, 17, and 25. These are the PML regions with 
absorption in a single direction.

10 Select the Manual specification of element layers check box, and enter 4 in the Number 

of element layers edit field.

11 Click the Mesh Selected button.

12 Select the Subdomains 2, 4, 6, 8, 10, 12, 16, 18, 22, 24, 26, and 28. These are the 
PML regions with absorption in two directions.

13 Click the Mesh Selected button. This creates hex elements in the selected regions.

14 Click the Select Remaining button and then click the Mesh Selected button. This 
creates hex elements in the remaining PML regions.
A B S O R B E D  R A D I A T I O N  ( S A R )  I N  T H E  H U M A N  B R A I N  |  121



122 |  C H A P T E R
15 Click OK to close the dialog box. The final mesh is a mix between tetrahedron 
elements and prism elements.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

The model solves with the default solver settings, which is the GMRES solver with the 
GMG preconditioner. It solves the nonlinear problem including both electromagnetic 
waves and the bioheat equation, which requires a little bit more than 2 GB of memory 
to solve. It is possible to save some memory and solution time by first solving for the 
electromagnetic waves and then for the temperature because the system is only 
one-way coupled. Specify the variables to solve for from the Solver Manager dialog box.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Select Plot Parameters from the Postprocessing menu.

2 On the General page, make sure that the Slice check box is selected, and that the 
Geometry edges check box is cleared.

3 Click the Slice tab, and type log10(dSAR) in the Expression edit field.

4 Enter 0 in the x-levels edit field, and 10 in the z-levels edit field.

5 Click Apply. You should now see the plot in Figure 3-23 on page 112.

6 Under the Slice tab, clear the Slice plot check box.
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7 Click the Boundary tab, and enter dT in the Expression edit field.

8 Click OK to see the plot in Figure 3-24 on page 113.
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M i c r owa v e  Ov en

Introduction

This is a model of the heating process in a microwave oven. The distributed heat source 
is computed in a stationary, frequency domain electromagnetic analysis followed by a 
transient heat transfer simulation showing how the heat redistributes in the food.

Model Definition

The microwave oven is a metallic box connected to a 1 kW, 2.45 GHz microwave 
source via a rectangular waveguide operating in the TE10 mode. Near the bottom of 
the oven there is a cylindrical glass plate with a spherical potato placed on top of  it. A 
part of the potato is cut away for mechanical stability which also facilitates the creation 
of a finite element mesh in the region where it is in contact with the plate. Symmetry 
is utilized by simulating only half of the problem. The symmetry cut is applied 
vertically through oven, waveguide, potato and plate. The reduced geometry is shown 
in Figure 3-12.

Figure 3-25: Geometry of microwave oven, potato, and waveguide feed.
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The walls of the oven and the waveguide are good conductors. The model 
approximates these walls as perfect conductors, represented by the boundary condition 

. The symmetry cut has mirror symmetry for the electric field and is 
represented by the boundary condition . 

The rectangular port is excited by a transverse electric (TE) wave, which is a wave that 
has no electric field component in the direction of propagation. At an excitation 
frequency of 2.45 GHz, the TE10 mode is the only propagating mode through the 
rectangular waveguide. The cutoff frequencies for the different modes are given 
analytically from the relation

where m and n are the mode numbers and c denotes the speed of light. For the TE10 
mode, m = 1 and n = 0. With the dimensions of the rectangular cross section (a = 
7.8 cm and b = 1.8 cm), the TE10 mode is the only propagating mode for frequencies 
between 1.92 GHz and 3.84 GHz.

With the stipulated excitation at the rectangular port, the following equation is solved 
for the electric field vector E inside the waveguide and oven:

where µr denotes the relative permeability, j the imaginary unit, σ the conductivity, ω 
the angular frequency, εr the relative permittivity, and ε0 the permittivity of free space. 
The model uses material parameters for air: σ = 0 and µr = εr = 1. In the potato the 
same parameters are used except for the permittivity which is set to εr = 65 − 20j where 
the imaginary part accounts for dielectric losses. The glass plate has σ = 0, µr = 1 and 
εr = 2.55.

Results

The first figure below shows the distributed microwave heat source as a slice plot 
through the center of the potato. From the rather complicated oscillating pattern that 
has a strong peak in the center, it is obvious that the potato acts as a resonant cavity for 
the microwave field. The voltage reflection coefficient at the waveguide port, S11, 
evaluates to about −4dB, meaning that the potato absorbs about 60% of the input 
microwave power. The second figure shows the temperature in the center of the potato 
as a function of time for the first 5 seconds. Due to the low thermal conductivity of the 
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potato, the heat distributes rather slowly and the temperature profile after 5 seconds 
has a strong peak in the center, see the third figure. When heating the potato further, 
the temperature in the center eventually reaches 100 °C and the water contents start 
boiling, drying out the center and transporting heat as steam to outer layers. This also 
affects the electromagnetic properties of the potato. The simple microwave absorption 
and heat conduction model used here does not capture these nonlinear effects. 
However, the model can serve as a starting point for a more advanced analysis. 

Figure 3-26: Dissipated microwave power distribution.
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Figure 3-27: Temperature in the center of the potato during the first 5 seconds of heating.
M I C R O W A V E  O V E N  |  127



128 |  C H A P T E R
Figure 3-28: Temperature distribution after 5 seconds of heating.

Modeling in COMSOL Multiphysics

This model uses the RF Module’s Port boundary condition for the wave propagation 
problem. With this boundary condition, the S-parameters are calculated automatically. 
The mode of the incoming wave is specified.

Model Library path: RF_Module/RF_and_Microwave_Engineering/
microwave_oven

Modeling Using the Graphical User Interface

The model is set up in two steps: first the wave propagation problem is solved, then 
the heat transfer problem is solved.
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Electromagnetic Analysis

M O D E L  N A V I G A T O R

1 Select 3D in the Space dimension list.

2 Select the RF Module>Electro-Thermal Interaction>Microwave Heating>Transient 

analysis application mode from the tree view.

3 Click OK to close the Model Navigator dialog box.

O P T I O N S  A N D  S E T T I N G S

Define the following expression in the Scalar Expressions dialog box. The description 
field is optional and can be omitted.

G E O M E T R Y  M O D E L I N G

1 Go to the Draw menu and click the block symbol and define a block with Length x: 
0.267, Length y: 0.270, Length z: 0.188. Leave the other parameters at their 
defaults.

2 Click OK.

3 Click the block symbol again and define a block with Length X: 0.050, Length Y: 
0.078, Length Z: 0.018, Axis base point x: 0.267, Axis base point y: (0.270-0.078)/
2, Axis base point z: 0.188-0.018. Leave the other parameters at their defaults.

4 Click OK.

5 Click the Zoom Extents button to get a better view of the geometry.

6 In the Draw menu choose Cylinder, then define a cylinder with Radius: 0.227/2, 
Height: 0.006, Axis base point x: 0.267/2, Axis base point y: 0.270/2, Axis base point 

z: 0.021-0.006. Leave the other parameters at their default values.

7 Click OK.

8 While the cylinder is selected, copy it by pressing Ctrl+C and paste the copy, which 
you will need later, by pressing Ctrl+V. Use the default displacements of  (0, 0, 0).

9 In the Draw menu choose Sphere, then define a sphere with Radius: 0.063/2, Axis 

base point x: 0.267/2, Axis base point y: 0.270/2, Axis base point z: 
0.021-0.006+0.063/2. Leave the other parameters at their default values.

10 Click OK.

NAME EXPRESSION DESCRIPTION

nu_co c0_rfw/(2*7.8[cm]) Cutoff frequency
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11 In the Draw menu choose Create Composite Object. In the Set formula edit field type 
SPH1-CYL2.

12 Click OK.

13 In the Draw menu choose Block, then define a block with Length X: 0.267+0.050, 
Length Y: 0.270/2, Length Z: 0.188. Leave the other parameters at their default 
values.

14 Click OK.

15 In the Draw menu choose Create Composite Object. In the Set formula edit field, type 
(BLK1+BLK2+CYL1+CO1)-BLK3.

16 Click OK.

17 Click the Zoom Extents button on the Main toolbar.

P H Y S I C S  S E T T I N G S

First set up the electromagnetic problem. Select Electromagnetic Waves (rfw) from the 
Multiphysics menu.

Scalar Variables
In the Scalar Variables dialog box, set the frequency nu_rfw to 2.45e9.
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Subdomain Settings
1 Open the Subdomain Settings dialog box.

2 Keep all the subdomains at the default settings (air) except for Subdomain 2 (glass 
plate) which has a relative permittivity of 2.55 and Subdomain 3 (potato) which has 
a relative permittivity of 65-i*20.

3 Click OK.

Boundary Conditions
1 Open the Boundary Settings dialog box.

2 At the waveguide end, Boundary 23, select the Port boundary condition. On the 
Port tab set the values according to the table below:

3 Use the default Perfect electric conductor boundary condition at all other boundaries 
except at the symmetry boundaries 2, 7, 10, and 19 where the Perfect magnetic 

conductor boundary condition is applied.

4 Click OK.

M E S H  G E N E R A T I O N

1 Select Mesh Cases from the Mesh menu and create two new mesh cases by clicking 
the New button twice in the dialog box that opens.

2 Select Mesh case 1 in the list and select Use the same mesh as mesh case 0. Repeat the 
procedure for mesh case 2. 

3 Click OK.

4 Select Mesh case 0 from the Mesh menu.

5 Open the Subdomain Settings dialog box.

DESCRIPTION VALUE

Port number 1

Wave excitation at this port selected

Pin 500

Mode specification User defined

Mode type Transverse electric (TE)

E0 0 0 cos(pi*(y-13.5[cm])/7.8[cm])

Specify cutoff frequency selected

νcutoff nu_co
M I C R O W A V E  O V E N  |  131



132 |  C H A P T E R
6 Click the Element tab and select Vector - Cubic from the list of Predefined elements. 
Do this for all subdomains.

7 Click OK.

8 Select Mesh case 1 from the Mesh menu.

9 Open the Subdomain Settings dialog box.

10 Click the Element tab and select Vector - Quadratic from the list of Predefined 

elements. Do this for all subdomains.

11 Click OK.

12 Open the Free Mesh Parameters dialog box and click the Subdomain tab and set the 
Maximum element size to 0.049 for Subdomains 1 and 4 and to 0.049/sqrt(2.55) 
for Subdomain 2 (plate) and to 0.049/sqrt(65) for Subdomain 3 (potato). This 
will make sure that the waves are properly resolved everywhere. Especially in the 
potato, the wavelength will be much shorter than in free space, calling for a much 
denser mesh here. 

13 Click OK.

14 Click the Initialize Mesh button in the toolbar.

C O M P U T I N G  T H E  S O L U T I O N

1 Open the Solver Manager dialog box and on the Solve For tab select only the 
Electromagnetic Waves application mode.

2 Click OK to close the Solver Manager.

3 In the Solver Parameters dialog box, with the Auto select solver check box selected, 
set the Analysis type to Stationary.

4 Set Matrix symmetry to Symmetric.

5 Set Linear system solver to GMRES and Preconditioner to Geometric Multigrid.

6 Click the Settings button.

7 Select the Preconditioner in the tree on the left of the Linear System Solver Settings 
dialog.

8 Set the Hierarchy generation method to Manual.

9 Click OK to close the Linear System Solver Settings dialog.

10 Click the Stationary tab and set Linearity to Linear.

11 Click the Advanced tab and set the Assembly block size to 2000.

12 Click OK to close the Solver Parameters dialog box.

13 Click the Solve button.
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PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows the temperature which so far is zero as we have not solved for 
it yet.

1 To visualize the dissipated heat in the potato, start by opening the Plot Parameters 

dialog box.

2 Click the Slice tab and select Electromagnetic Waves>Resistive heating, time average 

in the Predefined quantities list.

3 Under Slice Positioning, set the number of x levels to 0 and for y levels check Vector 

with coordinates and enter 0.135+1e-5 in that field. 

4 Click OK to generate the plot below.

The port boundary condition generates two S-parameter variables, S11_rfw and 
S11dB_rf which is the S-parameters on a dB scale. To evaluate S11dB_rf, proceed as 
follows.

1 Open the Point Evaluation dialog box from the Postprocessing menu.

2 Select Point 1 from the Point selection list and S Parameter dB (S11) from the list of 
Predefined quantities.

3 Click OK to display the value of S11dB_rf in log bar at the bottom of the graphical 
user interface. The value should be about −4 dB.
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P H Y S I C S  S E T T I N G S

Now it is time to set up and solve the transient heat transfer problem. Select General 

Heat Transfer (htgh) or Heat Transfer (ht) from the Multiphysics menu. What you select 
here depends if you have the Heat-Transfer Module or not. The multiphysics group 
Microwave heating uses the module version (htgh) if you have access to it. However, 
this model does not require that you have it.

Subdomain Settings
1 Open the Subdomain Settings dialog box.

2 Select Subdomains 1, 2, and 4 and clear the Active in this domain check box.

3 Select Subdomain 3 and set the Thermal conductivity to 0.55 W/(m·K), the Density 
to 1050 kg/m3, the Heat capacity to 3.64e3 J/(kg·K), and the Heat source to 
Qav_rfw.

4 Click the Init tab and set the Initial value to 273.15+8 K.

5 Click OK.

Boundary Conditions
The default boundary condition, Thermal insulation, is used here so no changes are 
necessary.

M E S H

Select Mesh case 0 from the Mesh menu.

C O M P U T I N G  T H E  S O L U T I O N

1 Open the Solver Manager dialog box and on the Solve For page select only the General 

Heat Transfer application mode.

2 On the Initial Value page set the Variables not solved for and linearization point to 
Current solution.

3 Click OK to close the Solver Manager.

4 In the Solver Parameters dialog box, with the Auto select solver check box selected, 
select Transient from the Analysis list. 

5 Set Linear system solver to Direct (SPOOLES).

6 Under Time stepping set Times to linspace(0,5,6) and Absolute tolerance to 1.

7 Click OK to close the Solver Parameters dialog box.

8 Click the Solve button.
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PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 To visualize the temperature in the potato, start by opening the Plot Parameters 

dialog box.

2 Click the Slice tab and select General Heat Transfer>Temperature in the 
Predefined quantities list.

3 Click OK to generate the plot below.

1 To visualize the temperature as a function of time in the center of the potato, start 
by opening the Cross-section Plot Parameters dialog box from the Postprocessing 
menu.

2 Click the Point tab and select General Heat Transfer>Temperature in the Predefined 

quantities list.

3 Set the Coordinates to (0.267/2,0.270/2,0.015+0.063/2).

4 Click OK to generate the plot in Figure 3-27 on page 127.
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Ba l a n c e d  Pa t c h  An t e nna f o r  6 GHz

Introduction

Patch antennas are becoming more common in wireless equipment, like wireless LAN 
access points, cellular phones, and GPS handheld devices. The antennas are small in 
size and can be manufactured with simple and cost-effective techniques. Due to the 
complicated relationship between the geometry of the antenna and the 
electromagnetic fields, it is difficult to estimate the properties of a certain antenna 
shape. At the early stages of antenna design the engineer can benefit a lot from using 
computer simulations. The changes in the shape of the patch are directly related to the 
changes in radiation pattern, antenna efficiency, and antenna impedance.

Balanced antennas are fed using two inputs, resulting in less disturbances on the total 
system through the ground. Balanced systems also provide a degree of freedom to alter 
antenna properties, by adjusting the phase and magnitude of the two input signals. 
Figure 3-29 shows the antenna that this model simulates.

Figure 3-29: A photo of the real antenna that the model extracts the properties for.
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Model Definition

The patch antenna is fabricated on a printed circuit board (PCB) with a relative 
dielectric constant of 5.23 (Ref. 1). The entire backside is covered with copper, and 
the front side has the pattern of the drawing shown in Figure 3-30 below.

Figure 3-30: The printed pattern of the patch antenna shown as a top view. The large 
square is 10×10 mm, the smaller rectangles are 5.2×3.8 mm, the thicker lines are 0.6 mm 
wide, and the thinner lines are 0.2 mm wide and 5.2 mm long. The entire pcb is 
50×50 mm and 0.7 mm thick.

The coaxial cables have an outer conductor with an inner diameter of 4 mm and a 
center conductor with a diameter of 1 mm. The gap between the conductors is filled 
with a material with a dielectric constant of 2.07 (teflon). This gives an impedance of 
the cables close to 58 Ω. There are two coaxial cables feeding the patch antenna from 
two sides, resulting in a balanced feed. The shape of the field at the outer boundary of 
the cables are known TEM modes, which can be specified with analytical formulas 
expressed in the local cylindrical coordinate system of each cable. With the port 
boundary condition you can automatically calculate the coaxial TEM mode, and 
specify a power level and a phase shift for each defined port. In this model, the signals 
in the cables have the same magnitude but are shifted 180 degrees in phase.

The entire antenna is modeled in 3D, using the electric field as solution variable. The 
time-harmonic nature of the signals makes it possible to solve the Vector-Helmholtz 
equation for the electric field everywhere in the geometry,
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where k0 is the wave number for free space and is defined as

All metallic objects are defined as perfect electric conductors (PEC), and the input to 
the coaxial cables uses the low-reflecting scattering boundary condition. The latter is 
a first-order approximation of an absorbing boundary, which lets all scattered waves 
pass the boundary without reflections. In addition, you can supply an incident wave, 
which in this case is the TEM mode of a coaxial cable described earlier in the text. The 
scattering boundary condition usually works well for waves propagating in cables, but 
for radiating waves from an antenna they are not very accurate and create reflections. 
Perfectly matched layers (PMLs) are more suitable in such cases, and for this antenna 
the model includes a spherical PML. You can find detailed information about PMLs in 
“Perfectly Matched Layers (PMLs)” on page 43 of the RF Module User’s Guide. This 
description covers the damping of the PML, because it is important when designing 
the length of the PML. A wave entering the PML is damped without reflections as it 
travels through the layer. When the wave reaches the outer boundary, the entire wave 
can be reflected back in the worst-case scenario. During the propagation back to the 
simulation volume the wave continues to get damped, so it always has to travel twice 
the distance of the PML layer. The damping is determined by the wave number, k0, 
the PML constant, bPML, and the length of the PML layer, dPML, using the following 
formula:

For frequencies around 6 GHz the damping parameter α is 0.007, so less than 1% of 
the radiated signal is reflected back. In addition, a scattering boundary condition is 
added outside the PML to further reduce the reflection.

∇ µ 1– ∇ E×( )× k0
2εrE– 0=

k0 ω ε0µ0=

α 2bPMLdPMLk0–( )exp=
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Results and Discussion

Figure 3-31: The final geometry of the patch antenna plotted together with a slice plot of 
the electric field in the surrounding air. The spherical PML is located outside the air 
domain and outside all cable regions.

Typical parameters important for an antenna are optimum radiation frequency, 
antenna impedance, and radiation pattern. First, use the parametric solver to find the 
optimal radiation frequency by sweeping over frequency. It is most efficient to first do 
a coarse sweep and then continue with a successively more resolved sweep in order to 
find the peak in the antenna efficiency. The antenna efficiency is the radiated power 
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divided by the input power. In Figure 3-32 this efficiency is plotted against the 
frequency, showing that the optimum frequency is located at 6.3 GHz.

Figure 3-32: A resolved sweep in the range around 6 GHz, where the region between 
6.2 GHz and 6.4 GHz was resolved in detail to locate the peak.

The radiation pattern is usually plotted in a lobe pattern, which is a surface 
representing the directional strength in all directions of the antenna. This plot is 
interpreted as follows: The vector between the origin and a point on the surface has a 
magnitude that represents the radiated energy in the direction parallel to the vector. 
The energy is given in dB, and the 0 dB level is the maximum radiated energy (a point 
on the unit sphere). The lobe pattern can be created with a deformation plot, where 
0 dB is no deformation and −40 dB is the maximum deformation to origin. The 
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radiation pattern for the modeled patch antenna is shown in Figure 3-33 for the 
optimum frequency, 6.3 GHz.

Figure 3-33: The radiation pattern plotted as a lobe pattern, using the deformed plot 
feature. It is clear that the wave mainly propagates in two lobes, with minimal radiation 
out of the backside of the PCB.

Model Library path: RF_Module/RF_and_Microwave_Engineering/
patch_antenna_balanced

Modeling in COMSOL Multiphysics

Antenna simulations in 3D often get very large, so this model should be solved on a 
64-bit platform. The final mesh results in about 550,000 complex degrees of freedom, 
and it is seldom possible to solve problems of such large size without iterative solvers. 
This model solves with an efficient iterative multigrid solver, consuming around 
2.5 GB of memory.
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Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 In the Model Navigator, select 3D in the Space dimension list.

2 In the RF Module folder, select Electromagnetic Waves and Harmonic propagation.

3 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, choose Constants.

2 In the Constants dialog box, define the following constants with names and 
expressions:

3 Click OK.

G E O M E T R Y  M O D E L I N G

The geometry modeling of this model is rather extensive, so it is possible to import the 
patch antenna geometry from a binary file. Select the section that you prefer.

Importing the Geometry from a Binary File
1 From the File menu, select Import>CAD Data From File.

2 In the Import CAD Data From File dialog box, make sure that the COMSOL Multiphysics 

file or All 3D CAD files is selected in the Files of type list.

NAME VALUE DESCRIPTION

a_coax 0.5[mm] Radius for the inner conductor of the coaxial cable

b_coax 2[mm] Inner radius for the outer conductor

epsilonr_coax 2.07 Rel. permittivity of the insulator in the cable

epsilonr_pcb 5.23 Rel. permittivity of the printed circuit board for the 
patch antenna

Pport 16.636[mW] Input power for the ports

freq 6.3[GHz] Default frequency
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3 From the models directory under the COMSOL Multiphysics installation directory, 
go to the model library path given on page 141. Select the file 
patch_antenna_balanced.mphbin, then click Import.

4 Skip section “Creating the Geometry from Scratch” and begin at “Physics Settings” 
on page 147.

Creating the Geometry from Scratch
The geometry will be drawn using the unit mm in a separate geometry. As a final step 
the entire drawn geometry will be converted to meters by copying it to the first 
geometry followed by a scale operation. All the dialog boxes for specifying the 
primitive objects are accessed from the Draw menu and Specify Object. The software 
generates the Name column in the tables below, so you do not have to enter them. Just 
check that you get the correct name for the objects that you create.

Begin by creating a work plane for the patch antenna cross section:

1 From the Draw menu, select Work-Plane Settings.

2 In the Work-Plane Settings dialog box, select the x-y plane at z equal to 0. Click OK.

3 Draw squares with the properties according to the table below.

4 Draw rectangles with the properties according to the following table.

5 Click the Zoom Extents toolbar button.

6 Select all the rectangles, R1, R2, and R3, and click the Union toolbar button.

7 Click the Delete Interior Boundaries toolbar button.

8 Copy the selected object by pressing Ctrl+C, and then paste it by pressing Ctrl+V. 
In the dialog box that appears, just click OK to create the copy in the same location 
as the original.

9 Click the Rotate toolbar button. In the Rotate dialog box, type -90 in the Rotation 

angle edit field.

NAME WIDTH BASE (X, Y) DESCRIPTION

SQ1 50 Center (0,0) PCB

SQ2 10 Center (0,0) Patch

NAME WIDTH HEIGHT BASE (X, Y) DESCRIPTION

R1 0.4 5.2 Corner (-0.2,-5-5.2) Conductor

R2 5.2 3.8 Center (0,-5-5.2-3.8/2) Conductor

R3 0.8 25-5-5.2-3.8 Corner (-0.4,-25) Conductor
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10 Select the objects SQ2, CO1, and CO2. Click first the Union button and then the 
Delete Interior Boundaries button, both located on the Draw toolbar.

Now it is time to draw the patch antenna in a new 3D geometry called 
patch_antenna.

11 Open the Model Navigator from the Multiphysics menu.

12 Click the Add Geometry button. In the Add Geometry dialog box, enter 
patch_antenna in the Geometry Name edit field, and select 3D from the Space 

dimension list. Click OK.

13 Click OK to close the Model Navigator window.

14 Click the Geom2 tab in the main window.

15 Select the large square, SQ1, and select Extrude from the Draw menu.

16 In the Extrude dialog box, enter -0.8 in the Distance edit field, and select 
patch_antenna from the Extrude to geometry list. Click OK.

17 Go back to Geom2 to do an embedding.

18 Select the patch object C01, and select Embed from the Draw menu. Select 
patch_antenna in the Embed to geom list. Click OK.

The following steps create the coaxial cables that feed the antenna. The connectors 
are also drawn to resemble the real device as closely as possible:

19 From the Draw menu, select Work-Plane Settings.

20 In the Work-Plane Settings dialog box, click Add to create a new work plane 
geometry.

21 Select the z-x plane and set y equal to -25. Click OK.

22 Draw circles with the properties according to the table below.

23 Select the circles C1 and C2, then click the Difference button on the Draw toolbar.

24 Press Ctrl+C to copy the resulting object. This saves the object for later use.

NAME RADIUS BASE (X, Y) DESCRIPTION

C1 0.5 Center (0,0) Inner conductor

C2 2 Center (0,0) Outer conductor 
inner border

C3 2.5 Center (0,0) Outer conductor  
outer border
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25 Create a rectangle with the following properties:

26 Select the objects R1 and CO1, and click the Intersection toolbar button.

27 Paste the copied object with Ctrl+V. Leave all the displacements at zero and click OK.

28 Select the objects CO1 and CO2, and click the Union button.

29 Extrude the resulting object, CO3, to the patch_antenna geometry. Enter the 
expression -45+25 in the Distance edit field and click OK.

30 Go back to the work plane geometry by clicking the Geom3 tab.

31 Specify a rectangle with the following properties:

32 From the Draw menu, select Fillet/Chamfer. In the Fillet/Chamfer dialog box, select all 
the points of object R1, make sure that the Fillet radio button is selected, and enter 
1.75 in the Radius edit field. Click OK.

33 Create a circle with the following properties:

34 Select the circle C1 and click the Array toolbar button. In the Array dialog box, enter 
the expression -12.5+3.5 in both the Displacement x and y edit fields, and enter 2 
in both the x and y Array size edit fields. Click OK.

35 Select the circles C1, C2, C4, and C5. Click the Union button.

36 Select the objects CO1 and CO2. Click the Difference button.

37 Extrude the resulting object to the patch_antenna geometry, using -1.5 in the 
Distance edit field.

38 Open the Work-Plane Settings from the Draw menu. Enter -25-1.5 in the y edit 
field. This changes the y-location of the work plane in the 3D geometry.

39 Extrude the circle C3 to the patch_antenna geometry, using a distance of -50.

40 Select the extruded objects, EXT2, EXT3, and EXT4. Copy them by pressing 
Ctrl+C.

NAME WIDTH HEIGHT BASE (X, Y)

R1 0.8 10 Corner (-0.8,-5)

NAME WIDTH HEIGHT BASE (X, Y) DESCRIPTION

R1 12.5 12.5 Center (0,0) Connector

NAME RADIUS BASE (X, Y) DESCRIPTION

C1 1.25 Center (12.5/2-1.75,12.5/2-1.75) One of the holes of  
the connector
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41 Paste them with Ctrl+V and leave the displacements at zero.

42 Click the Rotate toolbar button. In the Rotate dialog box, enter -90 in the Rotation 

angle edit field. Click OK.

The final step is to create the surrounding air volume, and the PML region. This is 
done with two spheres.

43 Specify two spheres with the following properties:

The entire geometry in now completed in the patch_antenna geometry. To help the 
software coerce the geometry to its minimal regions (subdomains) you can do 
step-by-step union and difference operations until there is only two solid objects (and 
one face object). Do all the operations below in the specified order, otherwise the 
names of the geometry objects do not match.

1 Select all objects in the patch_antenna geometry by pressing Ctrl+A.

2 Press Ctrl+C to copy, then go to the first geometry by clicking the Geom1 tab, and 
paste the objects with Ctrl+V (and zero displacements).

3 Do all the geometry operations according to the table below, starting from the first 
row:

4 Press Ctrl+A to select all objects.

5 Click the Scale button on the Draw toolbar. Type 1e-3 in all the Scale factor edit 
fields, then click OK.

NAME RADIUS BASE CORNER DESCRIPTION

SPH1 60 Center (0,0) PML+Air

SPH2 40 Center (0,0) Air

STEP OBJECTS OPERATION

1 SPH1, SPH2 Union

2 CO1, EXT4 Difference

3 CO2, EXT7 Difference

4 CO1, EXT3 Difference

5 CO2, EXT6 Difference

6 EXT1, CO1 Union

7 EXT2, EXT5 Union
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6 Click the Zoom Extents button on the Main toolbar. Using the tools on the Camera 
toolbar, turn on the headlight and increase the transparency slightly to get the 
following image of the final geometry.

P H Y S I C S  S E T T I N G S

1 Go to the first geometry by clicking the Geom1 tab.

2 From the Options menu, choose Expressions>Scalar Expressions.

3 In the Scalar Expressions dialog box, define the following variables with names and 
expressions (the descriptions are optional):

The variable P1 is the power flow into Port 1, which is defined as a integration 
coupling variable later. The impedance variable Z0 is not correct to use when both 

NAME EXPRESSION DESCRIPTION

S11 sqrt(1-P1/Pport) S11 parameter for first 
input

Z_coax sqrt(mu0_rfw/(epsilon0_rfw* 
epsilonr_coax))/(2*pi)* 
log(b_coax/a_coax)

Impedance for the coaxial 
cables

Z0 Z_coax*(1+S11)/(1-S11) Input impedance for the 
system on the first cable
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inputs are feeding the antenna, like it is done below. To perform a calculation for 
the antenna impedance, you must turn off one input. The variable is declared here 
to prepare for such an analysis.

4 Click OK.

5 From the Options menu, select Expressions>Subdomain Expressions.

6 In the Subdomain Expressions dialog box, define the following variables:

7 Click OK.

8 From the Options menu, choose Integration Coupling Variables>Boundary Variables.

9 In the Boundary Integration Variables dialog box, define the following variables with 
names and expressions. Use the default Global destination and Integration order 4 for 
all variables.

10 Click OK.

11 From the Physics menu, select Scalar Variables.

12 In the Scalar Variables dialog box, type freq in the expression column for variable 
nu_rfw. Click OK.

Boundary Conditions
1 From the Physics menu, open the Boundary Settings dialog box, select the Interior 

boundaries check box, and enter the settings according the following two tables 
(leave all fields not specified at their default values):

SETTING SUBDOMAIN 5 ALL OTHERS

normE_air normE_rfw

VARIABLE BOUNDARIES 9, 11, 14 BOUNDARIES 99, 100, 105 ALL OTHERS

P1 -nPoav_rfw

P2 -nPoav_rfw

SETTINGS BOUNDARIES 9, 11, 
14

BOUNDARIES 99, 
100, 105

BOUNDARIES 2, 4, 6, 8, 
112, 114, 123, 126

Boundary condition Port Port Scattering boundary

Wave type Plane wave Plane wave Spherical wave

Port number 1 2

Wave excitation 
at this port

Selected Selected

Port power Pport Pport
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2 Select Boundaries 26, 28, 30, 32, 120, 122, 124, and 125. On the Far-Field page 
type Efar in the first row of the Name column and let the other columns have the 
default values.

3 Click Apply and leave the Boundary Settings dialog box open. A special variable is 
needed later to plot all the metal objects in the geometry. Use the boundary settings 
to select all boundaries with the Perfect electric conductor condition. Mark boundary 
60 and then select the Select by group check box. All metal boundaries should now 
be selected. Click OK.

4 Go to the Options menu and select Expressions>Boundary Expressions.

5 In the Boundary Expressions dialog box, add the variable boundary_plot and type 
1 in the Expression column.

6 Select Boundaries 58, 59, 61, 65, 71, 73, 74, 101, 141, and 142. Type 2 in the 
Expression column for the boundary_plot variable.

7 Select Boundaries 1, 3, 5, 7, 92, 93, 111, and 113. Clear the Expression column for 
the boundary_plot variable.

8 Click OK.

Subdomain Settings
1 From the Physics menu, open the Subdomain Settings dialog box and enter the 

following settings:

2 Select Subdomain 1, click the PML tab, and select Spherical from the PML type list.

3 Enter lambda0_rfw in the Width in r direction edit field.

The default value that you removed is equal to the actual width of the PML. Using 
that value adjusts the PML design so one wavelength fits into the width of the PML. 
Using the free-space wavelength, λ0, instead makes the program assume that the 

Port phase 0 pi

Mode specification Coaxial Coaxial 0

SETTINGS BOUNDARIES 60, 70

Boundary condition Perfect electric conductor

SETTINGS SUBDOMAINS 2–4, 7–9 SUBDOMAIN 6 ALL OTHERS

εr (isotropic) epsilonr_coax epsilonr_pcb 1

µr (isotropic) 1 1 1

SETTINGS BOUNDARIES 9, 11, 
14

BOUNDARIES 99, 
100, 105

BOUNDARIES 2, 4, 6, 8, 
112, 114, 123, 126
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width of the PML is equal to λ0, even though it is not. This means that the width 
of the PML is shorter than one wavelength, and thereby reduces the required 
number of mesh elements here. The drawback is that the reflection increases. 
However, the combination of the PML and the scattering boundary condition for 
spherical waves is efficient, and one-wavelength PMLs are often not necessary.

4 Click OK to close the Subdomain Settings dialog box.

M E S H  G E N E R A T I O N

The structure of the patch antenna benefits significantly by optimizing the mesh with 
interactive meshing. This feature makes it possible to use individual mesh parameters 
for subdomains and boundaries.

1 Click the Geom1 tab.

2 From the Mesh menu, choose Free Mesh Parameters.

3 Select Finer from the Predefined mesh sizes list.

4 Click the Boundary tab.

5 Select boundaries representing the faces of the coaxial cable facing the patch 
antenna. Either use the technique described for the edges below or select them by 
number. The boundary numbers are: 9, 11, 14, 99, 100, and 105.

6 Click the Mesh Selected button. Leave this dialog box open.

Due to the structure of the coaxial cable subdomains it is more efficient to mesh 
them with prism elements. With mesh sweeping, it is possible to create such meshes 
in extruded-like geometries from a triangular mesh on one of the faces.

7 From the Mesh menu, choose Swept Mesh Parameters.
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8 In the Swept Mesh Parameter dialog box, select Subdomains 2, 3, 4, 7, 8, and 9. 
Under the Element layers tab, select the Manual selection of element layers check box, 
and type 8 in the Number of element layers edit field.

9 Click the Mesh Selected button.

10 Click OK to close the Swept Mesh Parameters dialog box.

11 In the Free Mesh Parameters dialog box, click the Global tab, select Normal from the 
Predefined mesh sizes list, and click Apply.

12 Click the Custom mesh size option button, then type 0.01 in the Mesh curvature 

cutoff edit field.

13 Click the Boundary tab.

14 Select boundaries representing the drill holes and fillets of the connectors. Either 
use the technique described for the edges below or select them by number. The 
boundary numbers are: 35–40, 42–45, 47–56, 82–85, 87–90, and 130–139.

15 Click the Mesh Selected button.

16 Click the Global tab, then type 2 in the Resolution of narrow regions edit field.

17 Click the Edge tab.

18 Select Edges 190–193, 284, and 330, then type 8e-4 in the Maximum element size 
edit field.

The edges listed above are all edges of the square patch in the middle of the 
substrate, and there is a technique to select all of them with the mouse. Click the 
Go to XY View button on the Camera toolbar. You now see a top view of the patch 
antenna. Then click the Orbit/Pan/Zoom button, also on the Camera toolbar. This is 
a toggle button that shifts between rotating the view (button pressed down) and 
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selecting objects. The button must now be in the selecting objects state (button not 
pressed). With the mouse, select all edges belonging to the rectangular patch in the 
middle (mouse click and drag around these edges). Right-click on one of the 
selected edges to lock the selection (colored blue). The figure below shows what the 
selection should look like. This is often the most efficient technique to select 
multiple edges and boundaries in a 3D geometry. It is also possible to change view 
and select a new set of domains, adding them to the previous selection.

19 Click the Boundary tab, select Boundary 70 and click the Mesh Selected button.

20 Click the Global tab and type 0.5 in the Resolution of narrow regions edit field.

21 Click the Advanced tab and type 2 in the z-direction scale factor edit field.

22 Click the Subdomain tab, select Subdomain 6, and click the Mesh Selected button.

23 Click the Advanced tab again and restore the value in the z-direction scale factor edit 
field to 1.

24 Click the Subdomain tab, select Subdomains 1 and 5, and click the Mesh selected 
button.

25 Click OK to close the Free Mesh Parameters dialog box.

26 Click OK to close the dialog box.
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Hiding Boundaries
To better see the mesh inside the geometry it is necessary to hide (suppress) some 
boundaries.

1 Choose Suppress>Boundaries from the Options menu.

2 Select Boundaries 3, 4, 27, 28, 93, and 95. Click OK.

3 Zoom in to get a better view of the mesh inside. You should see something like the 
figure below. Notice the prism elements inside the coaxial cable.

C O M P U T I N G  T H E  S O L U T I O N

The program can use the linear order element combination for a coarse solution and 
solve for the quadratic elements using the Geometric multigrid preconditioner. The 
linear solution is then used in the preconditioning step. COMSOL Multiphysics does 
this automatically with the setting you select in Step 6.

1 Open the Solver Parameters dialog box from the Solve menu.

2 Select Parametric from the Solver list.

3 In the Parameter name edit field type freq, and in the Parameter values edit field 
type 6.2e9:0.02e9:6.4e9.

4 Click the Settings button.
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5 Select Coarse solver from the tree view. Choose PARDISO from the Coarse solver list.

All other settings can be left at their default values. For details on the default 
settings, see “Solving Large 3D Problems” in the RF Module User’s Guide.

6 Click OK to close the Linear System Solver Settings dialog box.

7 Click OK.

8 Click the Solve button on the Main toolbar.

The solving process takes some time, because this is a large problem, and the analysis 
includes a parameter sweep of eleven steps.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Select Plot Parameters from the Postprocessing menu.

2 Make sure that the Boundary, Slice, and Geometry edges check boxes are selected on 
the General tab.

3 Choose the solution 6.3e9 from the Parameter value list.

4 Click the Slice tab, and enter normE_air in the Expression edit field.

5 Click the Range button, clear the Auto check box, and type 500 in the Max edit field 
and 0 in the Min edit field. Click OK.

6 Click the Boundary tab, and enter boundary_plot in the Expression edit field. Select 
the Hot colormap from the Colormap list.
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7 Click the Range button, clear the Auto check box, and type 2 in the Max edit field and 
0 in the Min edit field. Click OK.

8 Click OK. You should now see the plot in Figure 3-31 on page 139.

To plot the antenna efficiency, perform the following steps:

1 From the Postprocessing menu, select Domain Plot Parameters.

2 Choose the Point plot type and check that all parameters are selected in the 
Parameter value list.

3 On the Point tab, type (P1+P2)/(2*Pport) in the Expression edit field.

4 Select Point 1, then click OK. In a separate window you should see the plot in 
Figure 3-32 on page 140.

R A D I A T I O N  P A T T E R N  P L O T  I N  C O M S O L  S C R I P T

The final step is to plot the radiation pattern shown in Figure 3-33 on page 141. These 
steps require COMSOL Script or MATLAB.

1 Press CTRL+F to export the entire model to the COMSOL Script workspace.

2 Go to the COMSOL Script window and enter the following commands to define 
some useful variables.

res = 50;
theta = linspace(0,pi,res);
phi = linspace(0,2*pi,res);
[THETA,PHI] = meshgrid(theta,phi);

The variable res sets the resolution of the radiation plot, the theta and phi 
variables defines the ranges of the angular direction to span all directions, and finally 
the variables THETA and PHI holds the grid points used for plotting the final surface.

3 Then convert the angular direction to the corresponding vector components. Scale 
the length of the vector so it does not point to a coordinate outside the model 
geometry.

X = 1e-3*sin(THETA).*cos(PHI);
Y = 1e-3*sin(THETA).*sin(PHI);
Z = 1e-3*cos(THETA);

4 Now use the postinterp function to extract the norm of the far field for all 
directions. It is first necessary to reorganize the coordinates to a 3-by-N matrix.

xx = [X(:) Y(:) Z(:)]';
EdB = postinterp(fem,'normEfardB',xx,'solnum',6);

5 You need the maximum and minimum values before you calculate the coordinates 
for the radiation pattern surface.
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maxE = max(EdB);
minE = min(EdB);
EdB = reshape(EdB,size(THETA));
Xr = X.*(EdB-minE)./(maxE-minE);
Yr = Y.*(EdB-minE)./(maxE-minE);
Zr = Z.*(EdB-minE)./(maxE-minE);

6 Use the surf function to plot the radiation pattern, and also specify a few option to 
make a nicer plot. The plot should look like Figure 3-33 on page 141.

h = surf(Xr,Yr,Zr,EdB);
set(h,'edgecolor','black');
title('Radiation pattern (dB-scale)');

It may take a minute or so before the plot appears, because of the far-field evaluation 
in all directions.
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Coa x i a l  t o  Wav egu i d e  Coup l i n g

This model shows how to use assembly pairs and the Port boundary conditions to feed 
a rectangular waveguide.

Introduction

Feeding a waveguide from a coaxial cable is a straightforward way to get 
electromagnetic waves inside the waveguide. The coaxial feed must be modeled with 
enough length, so reflected waves either are damped out in the cable (evanescent 
modes) or turn into propagating modes. Propagating modes are efficiently terminated 
with a matched absorbing boundary condition, called the Port boundary condition in 
the RF Module. Due to its small size and circular shape, the cable contributes 
significantly to the overall size of the problem. It is therefore necessary to keep the 
cable as short as possible. One approach is to add the cable part as a separate assembly, 
connecting it to the waveguide using the port condition for pairs. This port condition 
can excite a wave into the master side of the pair while only the reflected waves exiting 
the master side enters the slave side. The port condition can be placed directly at the 
surface where the cable enters the waveguide, and only a short cable part, modeled as 
a perfectly matched layer (PML), is necessary.

In 3D, the electromagnetic waves application mode uses vector elements, and these 
elements are very sensitive to incompatible meshes. The master and slave side of an 
assembly pair usually get incompatible meshes in 3D, so the identity coupling must be 
stabilized with the divergence condition. The divergence condition adds an extra 
equation that complicates the use of iterative solvers, so if it is possible to create 
compatible (or identical) meshes it is definitely worth the effort. It is possible to copy 
a mesh from one boundary in an identity pair to the other side using interactive 
meshing and script programming. This approach is used in this model to avoid having 
to turn on the divergence condition.

Results and Discussion

For cable feeds it is interesting to compare the reflected wave going back into the 
coaxial cable with the wave propagating in the rectangular waveguide. You can make 
such a comparison by evaluating the S-parameter on the coaxial port and compare it 
with the S-parameter on the rectangular port. There is also a coaxial port on the 
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exterior of the PML that shows a very low value. The following table shows the result 
for a frequency of 6 GHz in dB scale:

The following plot shows the z-component of the electric field. It shows how the 
rectangular waveguide mode is created directly after the cable feed.

The z-component is the only component present for the propagating mode in the 
rectangular waveguide, and it is completely absent from the propagating mode of the 
coaxial cable.

Model Library path: RF_Module/RF_and_Microwave_Engineering/
coaxial_to_waveguide_coupling

PARAMETER VALUE DESCRIPTION

S11 -8.6 dB Reflected wave into the coaxial cable

S21 -0.65 dB Wave exiting the rectangular waveguide

S31 -19 dB Wave exiting the PML
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Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select 3D from the Space dimension list.

2 Select the RF Module>Electromagnetic Waves>Harmonic propagation application 
mode.

3 Click OK.

G E O M E T R Y  M O D E L I N G

Use the toolbar buttons and the Draw and Edit menus.

1 Click the Block toolbar button. In the Block dialog box enter the following 
properties.

2 Click OK.

3 From the Draw menu, choose Work-Plane Settings.

4 In the Work-Plane Settings dialog box, click the Face parallel tab, and select face 
number 1 of the object BLK1. Click OK to create the work plane.

5 In the new work plane, draw two circles according to the table below.

6 Select the circle labeled C2 and press Ctrl+C to copy it.

7 Select all objects by pressing Ctrl+A, and then click the Difference toolbar button.

8 Press Ctrl+V to paste the circle back to the work plane. In the dialog that appears, 
just click OK.

9 Select the pasted circle and choose Extrude from the Draw menu.

10 In the Distance edit field, type 0.0175/2. Click OK.

11 In the 3D geometry, select all objects and click the Difference toolbar button.

12 Go back to the work plane again and select the ring labeled CO1.

PROPERTY VALUE

x 0.1

y 0.0175*2

z 0.0175

LABEL RADIUS CENTER (X, Y)

C1 0.005 (0.0175, 0.0175)

C2 0.001 (0.0175, 0.0175)
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13 Choose Extrude from the Draw menu, and type -0.01 in the Distance edit field.

14 Select all objects and click the Create Pairs and Imprints toolbar button.

S C A L A R  V A R I A B L E S

In the Application Scalar Variables dialog box (available by choosing Scalar Variables 
from the Physics menu), set the Frequency to 6e9.

B O U N D A R Y  C O N D I T I O N S

The default boundary condition is a perfect electric conductor, which is fine for all 
exterior boundaries except at the ports. The pair condition between the waveguide and 
the coaxial cable is also a port with wave excitation. The excitation enters the 
waveguide side because it is the master side of the pair. Only waves reflected back to 
the cable enter the slave side.

1 Open the Boundary Settings dialog box from the Physics menu.

2 Click the Pair tab and select the pair in the list.

3 From the Boundary condition list, select the Port boundary condition.

4 Click the Port tab, then select the Wave excitation at this port check box.

5 From the Mode specification list, select Coaxial.

6 Click the Boundaries tab, and select Boundary 15. Select the Port boundary 
condition.

7 Click the Port tab and type 3 in the Port number edit field. Then select the coaxial 
mode specification also for this port.

8 Click the Conditions tab, select Boundary 12, choose the port boundary condition 
again, and then click the Port tab.

9 Type 2 in the Port number edit field, and choose Rectangular from the Mode 

specification list.

10 Click OK to close the Boundary Settings dialog box.

S U B D O M A I N  S E T T I N G S

All subdomains keep the defaults value that represents air. The subdomain for the 
coaxial cable damps all reflected waves using perfectly matched layers.

1 Open the Subdomain Settings dialog box from the Physics menu.

2 Select Subdomain 2 and click the PML tab.

3 Choose Cartesian from the Type of PML list.
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4 Select the Absorbing in z direction check box, and enter 4*Sdz_guess_rfw in the 
Width in z direction edit field. This setting ensures that a quarter wavelength fits 
inside the PML. The damping is not as good as the default setting but should be 
enough because a Port boundary condition terminates the PML.

5 Click OK to close the dialog box.

M E S H  G E N E R A T I O N

The mesh generation for this model needs interactive meshing, because it is necessary 
to have identical meshes on the master and slave side of the assembly pair (Boundaries 
6 and 16). If the meshes are incompatible (not identical) it is necessary to use the 
divergence condition, which increases the solution time and memory requirement 
drastically.

1 Open the Free Mesh Parameters dialog box from the Mesh menu.

2 Click the Boundary tab, select Boundary 6, and set the Maximum element size to 
0.002, the Mesh curvature factor to 0.4, and the Mesh curvature cutoff to 0.01.

3 Click the Mesh Selected button. The mesh now only contains the boundary mesh of 
the master side of the pair.

4 Select both boundaries 6 and 16, and click the Copy Mesh toolbar button. The same 
mesh now exists on boundary 16.

5 Click OK to close the Free Mesh Parameters dialog box.

6 Choose Swept Mesh Parameters from the Mesh menu.

7 Select subdomain 2 and select the Manual specification of element layers check box. 
Enter 5 in the Number of element layers edit field.

8 Click the Mesh Selected button.

9 Click OK.

10 Continue with the rest of the mesh. Open the Free Mesh Parameters dialog box 
again. Click the Custom mesh size radio button, enter 0.008 in the Maximum element 

size edit field, 0.5 in the Mesh curvature factor edit field, and 0.012 in the Mesh 

curvature cutoff edit field.

11 Click OK.

12 Click the Mesh Mode button on the Main toolbar, then click the Mesh Remaining 

(Free) button on the Mesh toolbar.

C O M P U T I N G  T H E  S O L U T I O N

1 Open the Solver Parameters dialog box from the Solve menu.
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2 Click the Settings button.

3 In the dialog box that appears, type 40 in the Factor in error estimate edit field and 
100 in the Number of iterations before restart edit field.

4 Click OK twice to close both dialog boxes.

5 Click the Solve button on the Main toolbar to solve the problem. The convergence 
is rather slow so the solution process might take some time.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Open the Plot Parameters dialog box from the Postprocessing menu.

2 Under the Slice tab, choose Electric field, z component from the Predefined quantities 
list.

3 Click the option button Vector with coordinates for the x levels, and type 0.0175 in 
the corresponding edit field. Also type 1 in the Number of levels edit field for the 
z levels.

4 Click the Range button, and in the dialog box that appears, enter -2000 and 2000 
in the Min and Max edit fields, respectively.

5 Click OK.

6 Choose the wave colormap and click OK to get the plot below.
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7 The S-parameters S11 and S21 are easiest to get from the menu option 
Postprocessing>Data Display>Global. In the Global Data Display dialog box, choose 
Electromagnetic Waves (rfw)>S-parameter dB (S11) and Electromagnetic Waves 

(rfw)>S-parameter dB (S21) from the Predefined quantities list and then click Apply to 
see their values in the message log at the bottom of the COMSOL Multiphysics user 
interface. The S-parameters have the following approximate values:

S11 = -8.59 dB
S21 = -.64 dB
S31 = -22.23 dB
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S e a  B ed L og g i n g

Introduction

The Sea Bed Logging method for oil prospecting has emerged as a promising 
technique during recent years. This model demonstrates one variant of it. It uses a 
mobile horizontal 1 Hz electric dipole antenna that is towed 150 m above the sea floor. 
An array of sea floor receivers measure the electric field at various distances away from 
the antenna. When measuring at sufficiently large distance, some of the transmitted 
energy is reflected/guided by the resistive reservoir and results in a higher received 
signal than if no reservoir were present. 

Model Definition

The computational domain is a sphere of 5 km radius. The top region of this sphere 
represents air. At such a low frequency as 1Hz, some numerical stabilization is required 
in this domain so an artificial conductivity of 0.001 S/m is specified. A 100 m deep 
ocean water domain with a conductivity of 3 S/m and a relative permittivity of 80 is 
specified above the mid plane of the sphere. Below the midplane, a conductivity of 1.5 
S/m and a relative permittivity of 30 is specified for the rock. Embedded in the rock 
at an average depth of 250 m, there is a block-shaped, 100 m deep and 4 km-by-1 km 
wide hydrocarbon reservoir. The conductivity of the hydrocarbon layer is 0.01 S/m 
and the permittivity is 4. The transmitter is modeled as a short 10 kA amplitude AC 
line current segment 150 m above the midplane. At the external spherical boundaries, 
a scattering type boundary condition absorbs outgoing spherical waves. The following 
equation is solved for the electric field vector E inside the computational domain:

where µr denotes the relative permeability, j the imaginary unit, σ the conductivity, ω 
the angular frequency, εr the relative permittivity, and ε0 the permittivity of free space. 

Results

The first figure below shows a slice plot of the electric field magnitude on a dB scale 

µr
1– E∇×( )∇× k0

2 εr
jσ

ωε0
---------–⎝ ⎠

⎛ ⎞E– 0=
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where the guiding effect of the hydrocarbon layer is clearly visible. 

Figure 3-34: The electric field magnitude is plotted in a slice containing the antenna (red 
spot). The guiding effect of the hydrocarbon layer is clearly visible.

The effect is shown quantitatively in the next plot, where a comparison of the electric 
field magnitude on the sea floor is plotted as a function of distance for simulations with 
and without a hydrocarbon layer. The maximum is obtained right under the antenna 
where there is little difference between the two cases. When you move away from the 
antenna, there is a notably higher signal strength when the hydrocarbon layer is 
present.
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Figure 3-35: Electric field magnitude on the sea floor as a function of distance. The dashed 
line represents the case without a hydrocarbon layer.

Modeling in COMSOL Multiphysics

This model uses the 3D Electromagnetic Waves formulation available in the RF 
Module although the wavelength is much larger than the computational domain. In 
principle, you could also create this model using a quasi-static formulation in the 
AC/DC Module.

Model Library path: RF_Module/RF_and_Microwave_Engineering/
sea_bed_logging
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Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select 3D from the Space dimension list.

2 Select the RF Module>Electromagnetic Waves>Harmonic propagation application 
mode from the list of application modes.

3 Click OK to close the Model Navigator dialog box.

G E O M E T R Y  M O D E L I N G

1 Use the Sphere tool to create a sphere with a Radius of 5e3 and other parameters at 
their defaults.

2 Click the Zoom Extents button on the Main toolbar.

3 Use the Cylinder tool to create a cylinder with Radius 6e3 and Height 1e3. Leave all 
other parameters at their default values.

4 Select all object by pressing Ctrl+A.

5 Click the Intersection button on the Draw toolbar.

6 Use the Sphere tool to create a new sphere with a Radius of 5e3 and other parameters 
at their defaults.

7 Go to the Draw menu and click the block symbol and define a block with Base: 
Center, Length x: 4e3, Length y: 1e3 Length z: 100, and Axis base point z: -250. Leave 
the other parameters at their default values.

8 Go to the Draw menu and click the line symbol and define a Polyline with Coordinates 

x: -10 10, Coordinates y: 0 0 and Coordinates z: 150 150.

9 Go to the Draw menu and click the line symbol and define a Polyline with Coordinates 

x: -5e3 5e3, Coordinates y: 0 0 and Coordinates z: 0 0.
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P H Y S I C S  S E T T I N G S

Scalar Variables
1 From the Physics menu, choose Scalar Variables.

2 In the Application Scalar Variables dialog box, set the frequency nu_rfw to 1.

3 Click OK.

Subdomain Settings
1 Open the Subdomain Settings dialog box.

2 Specify subdomain settings according to the following table.

3 Click OK.

Boundary Conditions
1 Open the Boundary Settings dialog box.

SETTINGS SUBDOMAIN 1 SUBDOMAIN 2 SUBDOMAIN 3 SUBDOMAIN 4

Relative permittivity 80 30 1 4

Electric conductivity 3 1.5 0.001 0.01
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2 Select all exterior boundaries, that is, the boundaries that are not grayed out in the 
Boundary selection list. Select the Scattering boundary condition and the Spherical 

wave type.

3 Click OK.

Edge Settings
1 Open the Edge Settings dialog box.

2 Select Edge 17. In the Current in edge segment direction edit field, type 1e4.

3 Click OK.

M E S H  G E N E R A T I O N

1 Open the Free Mesh Parameters dialog box.

2 Click the Custom mesh size button and set the Maximum element size to 1e3.

3 Click OK.

4 Click the Initialize Mesh button on the Main toolbar.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows the total energy density on a linear scale. Follow the 
instructions below to visualize the electric field magnitude on a dB scale.

1 Open the Plot Parameters dialog box.

2 Click the Slice tab and type 20*log10(normE_rfw) in the Expression edit field.

3 In the Slice positioning area, set the number of x levels and z levels to 0 and number 
of y levels to 1. 
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4 Click OK to generate the plot below.

5 Open the Domain Plot Parameters dialog box from the Postprocessing menu.

6 Click the Line/Extrusion plot tab and type 20*log10(normE_rfw) in the Expression 
edit field. 

7 Set the x-axis data to x.

8 Select Edge 5 in the Edge selection list.
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9 Click OK to generate the following plot.

Keep this figure window open in the background for later use.

P H Y S I C S  S E T T I N G S

Now it is time to simulate the model without the hydrocarbon reservoir.

Subdomain Settings
1 Open the Subdomain Settings dialog box.

2 Select Subdomain 4 and type in the subdomain settings from Subdomain 2.

3 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Open the Domain Plot Parameters dialog box from the Postprocessing menu.

2 On the Line/Extrusion page, click the Line Settings button.

3 In the dialog box that opens, select Dashed line from the Line type list.

4 Click OK to close the Line Settings dialog.
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5 Click the General tab. From the Plot in list, select Figure 1. Select the Keep current 

plot check box.

6 Select Edge 5 from the Edge selection list.

7 Click OK to generate the plot below.
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 4
O p t i c s  a n d  P h o t o n i c s  M o d e l s
In this chapter you find models within Optics and Photonics. From the 
mathematical viewpoint, these models use the same physics formulations as in the 
previous chapter on RF and Microwave Engineering. The terminology and the way 
numerical results are presented differ slightly though. Anyone interested in RF and 
Microwave Engineering may benefit from also reading this chapter.
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Pho t on i c  M i c r o p r i sm

Introduction

A microprism is used for reducing radiative losses in photonic waveguide bends. If you 
place a microprism between two waveguides forming a sharp bend, light will be guided 
between the waveguides through the prism.

For a certain refractive index of the prism, the light propagating through the prism 
couples to the respective mode under just the appropriate resonance angle (see Ref. 1). 
If the initial field distribution does not diffract while propagating through the prism, 
the coupling from the prism to the guide is the inverse to the light transfer from the 
guide to the prism. Therefore, the efficiency of the process is very high.

The interface between the guide and the prism must be sufficiently long to allow 
almost all the power to exit from the guide into the prism and vice versa. On the other 
hand, to avoid diffraction, the size of the prism should be kept as small as possible.

This model also makes use of perfectly matched layers, PMLs. These are domains with 
artificial absorption that reduce nonphysical reflections. For more information on 
PMLs, see Ref. 2 and the section “Perfectly Matched Layers (PMLs)” on page 43 in 
the RF Module User’s Guide.

Microprism
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Model Definition

The model is built using the 2D In-Plane TE Waves application mode. The modeling 
takes place in the xy-plane.

D O M A I N  E Q U A T I O N S

The dependent variable in this application mode is the z component of the electric field 
E. It obeys the following relation:

where µr denotes the relative permeability, ω the angular frequency, σ the conductivity,  
ε0 the permittivity of vacuum, εr the relative permittivity, and k0 the wave number. 
Different refractive indices are used for the prism and the guides. The wave is 
dampened by PMLs where the wave enters and exits the setup. The whole geometry 
is surrounded by another PML, which decreases reflections from the nonphysical 
exterior boundary. The solution is calculated for IR light with a wavelength in vacuum 
of 870 nm.

B O U N D A R Y  C O N D I T I O N S

The exterior boundaries in this model use a scattering boundary condition to 
terminate the PML. Inside the geometry, continuity is applied everywhere except for 
at the boundary where the wave is entering the structure. This boundary is excited 
with a cosine function fitted to match the width of the waveguide.

∇ µr
1– ∇ Ez×( )× εr

jσ
ωε0
---------–⎝ ⎠

⎛ ⎞k0
2Ez– 0=
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Results and Discussion

Figure 4-1 shows the geometry and the solution of the model. The wave enters the 
horizontal guide from the right and exits at the top of the vertical guide. The circles 
surrounding the entry and the exit are PMLs. 

Figure 4-1: The z component of the electric field.

Several variables govern the transmission of the wave through the bend: for example, 
the relation between the refractive indices of the guide and the prism, the size of the 
prism, and the gap between the guides and the prism. The optimal values of the 
parameters also depend on the angle of the bend.
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Model Library path: RF_Module/Optics_and_Photonics/
photonic_micro_prism

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select 2D from the Space dimension list.

2 In the list of application modes, select RF Module>In-Plane Waves> 
TE Waves>Harmonic propagation.

3 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 In the Axes/Grid Settings dialog box, set axis and grid settings according to the 
following table; when done, click OK.

2 In the Constants dialog box, enter the following variable names, expressions, and 
descriptions (optional); when done, click OK.

G E O M E T R Y  M O D E L I N G

Start by defining the solid objects for the two guides and the prism.

1 Select Draw Line and click at (0.3, −0.1), (4.5, −0.1), (4.5, 0.1), and (0.1, 0.1). 
Create a solid object CO1 by clicking the right mouse button.

2 Select Draw Line and click at (0.1, 0.1), (0.1, 4.5), (−0.1, 4.5), and (−0.1, 0.3). 
Create a solid object CO2 by clicking the right mouse button.

AXIS GRID

x min -6 x spacing 0.5

x max 6 Extra x -0.1 0.1 0.18 0.3 3.18

y min -6 y spacing 0.5

y max 6 Extra y -0.1 0.1 0.18 0.3 3.18

NAME EXPRESSION DESCRIPTION

n_Guide 1.5 Refractive index, waveguide

n_Prism 2.5 Refractive index, microprism
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3 Select Draw Line and click at (0.18, 3.18), (0.18, 0.18), and (3.18, 0.18). Create a 
solid object CO3 by clicking the right mouse button.

Then, define circular domains for the absorbing layers.

1 Draw a circle C1 with radius 5 and a circle C2 with radius 5.5, both centered at 
(0,0).

2 Draw a circle C3 centered at (4.5, 0) and a circle C4 centered at (0, 4.5), both with 
radius 0.5.

3 Unite all objects into one solid object by selecting all objects and clicking the Union 
toolbar button.

The model geometry is now ready, except for the size. The dimensions should be given 
in µm.

1 Click the Scale button on the Draw toolbar, and give the value 1e-6 for both scaling 
factors.

2 Click the Zoom Extents button on the Main toolbar to see the resulting object.

Figure 4-2: Model geometry.

P H Y S I C S  S E T T I N G S

Scalar Variables
Set the frequency to 3e8/870e-9 in the Scalar Variables dialog box.
 4 :  O P T I C S  A N D  P H O T O N I C S  M O D E L S



Boundary Conditions
Enter the boundary conditions according to the following table. To apply boundary 
conditions to interior boundaries, it is necessary to select the Interior boundaries check 
box.

Subdomain Settings
1 Subdomains 1 and 5 represent air or vacuum. This is the default setting.

2 Subdomain 7 is the prism. Choose to represent the material properties in terms of 
the refractive index, and enter n_Prism in the text field. 

3 Subdomains 2, 4, and 6 are the free part of the waveguide. Use n_Guide as the 
refractive index here.

4 Subdomains 3, 8, and 9 are used for damping the wave. Choose to represent the 
material properties in terms of εr, µr, and σ. Enter n_Guide^2*Izz for the Relative 

permittivity and Ixx 0 0 Iyy for the Relative permeability, which is anisotropic.

5 Subdomain 10 also damps the wave to reduce the effect of the exterior boundary. 
Enter Izz for the Relative permittivity and Ixx 0 0 Iyy for the Relative permeability.

Expression Variables
1 Open the Subdomain Expressions dialog box from the Options menu. Mark all 

subdomains and specify the expressions for diagonal indices of the PML tensor.

2 For best results, the wave is damped along the expected direction of propagation, 
except for in the beginning of the waveguide, where it is damped in the 
perpendicular direction. To achieve this effect, use the following expressions.

SETTINGS BOUNDARY 15 BOUNDARIES 16, 17, 23, 28 ALL OTHER

Boundary condition Electric field Scattering boundary condition Continuity

E0z cos(y*pi/0.4[um]) 0

Wave type Cylindrical wave

NAME EXPRESSION

Ixx sy*sz/sx

Iyy

Izz

sx*sz/sy

sx*sy/sz

SUBDOMAIN 3 4 8 9 10 ALL OTHER

sx 1 1-i 1

sy 1-i 1-i 1

sz 1 1 1
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M E S H  G E N E R A T I O N

1 Change the default mesh parameters to get an applicable mesh. Open the Free Mesh 

Parameters dialog box. On the Global tab, click the Custom mesh size button and set 
Maximum element size to 250e-9. On the Subdomain tab, select the subdomains 2, 
4, 6, 7, and 8, and set Maximum element size to 120e-9.

2 Initialize the mesh.

Figure 4-3: Mesh

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solve button on the Main toolbar to compute the solution.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

By default, the z component of the electric field is visualized. It shows clearly that the 
wave propagates between the two guides, through the prism; see Figure 4-1. Another 
interesting entity for visualization is the electric energy density. Select Electric energy 

density, time average on the Surface tab of the Plot Parameters dialog box, and use the 
cool colormap. The resulting plot (Figure 4-4) shows that the energy density is mainly 
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localized to the waveguide and the prism, and that there are signs of resonances in the 
prism. 

Figure 4-4: Electric energy density.
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Pho t on i c  C r y s t a l

Photonic crystal devices are periodic structures of alternating layers of materials with 
different refractive indices. Waveguides that are confined inside of a photonic crystal 
can have very sharp low-loss bends, which may enable an increase in integration density 
of several orders of magnitude.

Introduction

This model describes the wave propagation in a photonic crystal that consists of GaAs 
pillars placed equidistant from each other. The distance between the pillars prevents 
light of certain wavelengths to propagate into the crystal structure. Depending on the 
distance between the pillars, waves within a specific frequency range are reflected 
instead of propagating through the crystal. This frequency range is called the photonic 
bandgap (Ref. 1). By removing some of the GaAs pillars in the crystal structure you 
can create a guide for the frequencies within the bandgap. Light can then propagate 
along the outlined guide geometry.

Pillar (GaAs)

Air

Incoming 
wave

Outgoing wave
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Model Definition

The geometry is a square of air with an array of circular pillars of GaAs as described 
above. Some pillars are removed to make a waveguide with a 90° bend. 

The objective of the model is to study TE waves propagating through the crystal. To 
model these, use a scalar equation for the transverse electric field component Ez,

where n is the refractive index and k0 is the free-space wave number.

Because there are no physical boundaries, you can use the scattering boundary 
condition at all boundaries. Set the amplitude Ez to 1 on the boundary of the 
incoming wave.

Results and Discussion

Figure 4-5 contains a plot of the z component of the electric field. It clearly shows the 
propagation of the wave through the guide.

Figure 4-5: The z component of the electric field showing how the wave propagates along 
the path defined by the pillars.

∇ ∇Ez n2k0
2Ez–⋅– 0=
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If the angular frequency of the incoming wave is less than the cutoff frequency of the 
waveguide, the wave does not propagate through the outlined guide geometry. In 
Figure 4-6 the wavelength has been increased by a factor of 1.17.

Figure 4-6: A longer wavelength will not propagate through the guide.
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Model Library path: RF_Module/Optics_and_Photonics/photonic_crystal

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select 2D from the Space dimension list.
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2 In the list of application modes, select RF Module>In-Plane Waves> 
TE Waves>Harmonic propagation.

3 Click OK.

A P P L I C A T I O N  M O D E  P R O P E R T I E S

For convenience, specify that the wavelength rather than the frequency should be used 
as input. In the Application Mode Properties dialog box set the property Specify wave 

using to Free space wavelength.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, choose Axes/Grid Settings.

2 Set axis and grid settings according to the following table (clear the Auto check box 
to enter the grid settings).

3 Click OK.

G E O M E T R Y  M O D E L I N G

The easiest way to create the crystal geometry is using a array of geometry objects.

1 Start by drawing a circle with the radius 7e-8 and the center at x = 0, y = 0. 

2 Select the circle and click the Array button. In the Displacement edit fields, type 
3.75e-7 for the displacements in both directions and in the Array size edit fields, 
type 10 in both the x and y directions

3 Create the guide as a 90° bend by removing some pillars from the array. Remove the 
circles C3, C13, C23, C33, C43, C53, C63, C64, and C74 to C80.

4 Use the Rectangle dialog box to create a rectangle intersecting with all pillars. Set 
both the Width and Height to 9*3.75e-7.

5 Select all objects and open the Create Composite Object dialog box. Type 
R1*(C1+C2+...+C99+C100+R1) in the Set formula edit field and click OK to create 
an object with the regions outside the rectangle removed. The sum within 

AXIS GRID

x min 0 x spacing 5e-7

x max 5e-6 Extra x 7e-8

y min -1e-6 y spacing 5e-7

y max 4e-6 Extra y
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parentheses in the set formula creates a union of all objects. The * operator then 
takes the intersection of this union and the rectangle.

P H Y S I C S  S E T T I N G S

Scalar Variables
In the Application Scalar Variables dialog box, set the wavelength to 1e-6.

Boundary Conditions
Use low-reflecting boundary conditions on all exterior boundaries. Apply a source at 
the input port. These settings are summarized in the following table.

Subdomain Settings
Enter subdomain settings according to the following table.

SETTINGS BOUNDARY 5 ALL OTHERS

Boundary condition Scattering boundary condition Scattering boundary condition

 E0z 1 0

Wave type Plane wave Plane wave

SETTINGS SUBDOMAINS 1, 3–86 SUBDOMAIN2

 n n_GaAs n_Air
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Because the refractive index of GaAs is frequency dependent, define the refractive 
indices in the model using expression variables. The expression defines a linearized 
frequency dependency of the refractive index of GaAs between the refractive index 
values corresponding to the wavelengths 1.0332 µm and 1.2339 µm according to Ref. 
2. In the Options>Expressions>Scalar Expressions dialog box, define the variables n_Air 
and n_GaAs. The descriptions are optional. When done, click OK.

M E S H  G E N E R A T I O N

1 Change the default mesh parameters to get an applicable mesh. Open the Free Mesh 

Parameters dialog box, click the Custom mesh size button, and set Element growth 

rate to 1.55 and Mesh curvature factor to 0.65.

2 Initialize the mesh.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar to solve the problem with the default solver.

NAME EXPRESSION DESCRIPTION

n_Air 1 Refractive index, air

n_GaAs -3.3285e5*lambda0_rfwe[1/m]+3.5031 Refractive index, GaAs
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P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

By default, the z component of the electric field is visualized. This clearly shows the 
propagation of the wave through the guide. Change the colormap to wave under the 
Surface tab in the Postprocessing dialog box. This makes it easier to identify the wave.

If the angular frequency of the incoming wave is less than the cutoff frequency of the 
waveguide, the wave will not propagate through the outlined guide geometry. 

1 Open the Application Scalar Variables dialog box and multiply the wavelength by 
1.17.

2 Click the Solve button.

3 Open the Plot Parameters dialog box to change the range of the plot. The wave 
colormap looks best if the range is symmetric around zero.

4 Click the Range button, then enter -1.9 and 1.9 in the Min and Max edit fields.
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5 Click OK twice to see the following plot.

Use a cross-section line plot to visualize the evanescent electric field. Position the plot 
along the outlined guide between the inlet and the bend.

1 Open the Cross-Section Plot Parameters dialog box and select Line plot.
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2 As Cross-section line data set x0 to 0, x1 to 2.5e-6, y0 to 0.75e-6, and y1 to 
0.75e-6. Set the x-axis data to x.

The resulting plot shows that the z component of the electric field declines 
exponentially along the plot line.

Modeling Using the Programming Language

% Start by defining the variables.
clear fem appl
fem.expr.n_GaAs = '-3.3285e5*lambda0+3.5031';
fem.expr.n_Air = '1';

% Define the geometry.
latt_const = 3.75e-7;     
oPillar = circ2(0,0,7e-8);
N = 10;                 
cPillars = geomarrayr(oPillar,latt_const,latt_const,N,N);
aRm_Pillars = [3 13 23 33 43 53 63 64 74:80];
bKeep_Pillars = logical(ones(1,N^2));
bKeep_Pillars(aRm_Pillars) = logical(0);
oPillars = geomcomp(cPillars(bKeep_Pillars));
oBox = rect2(0,(N-1)*latt_const,0,(N-1)*latt_const);
fem.geom = (oBox+oPillars)*oBox;
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% Create the application structure and compute the corresponding 
% FEM coefficients.
appl.mode = 'InPlaneWaves';
appl.prop.inputvar = 'lambda';
appl.var.lambda0 = 1e-6;
appl.bnd.type = {'cont' 'SC' 'SC'};
appl.bnd.ind = ones(1,340);
appl.bnd.ind(1:72) = 2;
appl.bnd.ind(5) = 3;
appl.bnd.E0 = {{'0' '0' '0'} {'0' '0' '0'} {'0' '0' '1'}};
appl.equ.matparams = 'n';
appl.equ.n = {'n_GaAs','n_Air'};
appl.equ.ind = ones(1,86);
appl.equ.ind(2) = 2;
fem.appl = appl;
fem = multiphysics(fem);

% Mesh and solve the problem using the proper parameters.
fem.mesh = meshinit(fem,'hgrad',1.55,'hcurve',0.65);
fem.xmesh = meshextend(fem);
fem.sol = femlin(fem);

% Visualize the resulting electric field.
postplot(fem,'tridata','Ez','geom','on','tribar','on');

% Modify the angular frequency and re-solve the problem.
fem.appl.var.lambda0 = 1e-6*1.17;
fem = multiphysics(fem);
fem.xmesh = meshextend(fem);
fem.sol = femlin(fem);

% Visualize the new solution.
postplot(fem,'tridata','Ez','geom','on','tribar','on');

% Make the cross section line plot.
postcrossplot(fem,1,[0 2.5e-6;...
  0.75e-6 0.75e-6],'lindata','Ez','title','',...
  'axislabel',{'width [m]' 'electric field [V/m]' ''});
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Bandgap Ana l y s i s  o f  a  Pho t on i c  
C r y s t a l

This model performs a bandgap analysis of a photonic crystal similar to the one used 
in the model “Photonic Crystal” on page 182.

Introduction

The model investigates the wave propagation in a photonic crystal that consists of 
GaAs pillars placed equidistant from each other. The distance between the pillars 
determines a relationship between the wave number and the frequency of the light that 
prevents light of certain wavelengths to propagate inside the crystal structure. This 
frequency range is called the photonic bandgap (Ref. 2). There are several bandgaps 
for a certain structure, and this model extracts the bandgaps for the lowest bands of 
the crystal.

Model Definition

This model is similar to the Photonic Crystal waveguide model. The difference is that 
in this model the crystal itself is analyzed instead of a waveguide. Because it has a 
repeated pattern it is possible to use periodic boundary conditions. As a result, only 
one pillar is needed for this simulation. The model contains a small asymmetry, which 
is not present in the photonic crystal waveguide model, to remove difficulties of 
eigenfunctions with identical eigenvalues.

There are two main complications with this bandgap analysis. Firstly, the refractive 
index of GaAs is frequency dependent. Secondly, the wave vector must be ramped for 
the band diagram. Although you can solve each of these complications with the 
eigenvalue solver separately, the two combined make it difficult without a script. 
However, it is possible to solve a nonlinear problem with the stationary solver, using 
the eigenvalue as an unknown (see “Example: Eigenmode Analysis of an L-Shaped 
Membrane with Rounded Corner” on page 425 in the COMSOL Multiphysics 
Modeling Guide for more details on such approaches). The equation for the 
eigenvalue is a normalization of the electric field, so the average field is unity over the 
domain. The nonlinear solver finds the correct eigenvalue with an updated refractive 
index to the found eigenvalue. Furthermore, the parametric solver can sweep the wave 
vector, k. The eigenvalue is equal to the squared wave vector in free space,
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.

The eigenvalue is denoted Λ to avoid confusion with the free-space wavelength, which 
is denoted with λ0. The relation between Λ and λ0 is

.

The wave vector for the propagating wave, k, enters the simulation as Floquet 
periodicity boundary conditions (Ref. 1),

,

where β is a phase factor determined by the wave vector and the distance, d, between 
the periodic boundaries:

.

The range for the swept k is determined by the reciprocal lattice vectors of the 
photonic crystal, and these are determined from the primitive lattice vectors. For a 2D 
crystal there are two lattice vectors, a1 and a2, defined in the following figure.

The reciprocal lattice vectors are calculated from a1 and a2 using the relations

k0
2 Λ=

λ0
2π

Λ
--------=

Ez 2( ) Ez 1( )e i– β
=

β kd=

a1

a2
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,

where a3 is assumed to be the unit vector ez. When a1 and a2 are perpendicular to 
each other and to a3, b1 and b2 become

.

The solution process is rather complicated, and you have to find proper initial 
conditions for the nonlinear parameter ramp. This is crucial because the system has 
several solutions, one for each eigenvalue. In COMSOL Multiphysics you can first use 
the eigenvalue solver to locate an approximate solution at any k-vector. The solution 
is not exact due to the frequency-dependent refractive index of GaAs. It is possible to 
repeat the eigenvalue calculation to get closer to the final solution. You can often 
switch directly to the time-harmonic analysis type after the first iteration of the 
eigenvalue problem, using that solution as initial guess for the nonlinear solver. With 
the nonlinear solver you can now perform a nonlinear ramp from k = 0 to k = 0.5, 
which represents half the reciprocal vector given by a linear combination of b1 and b2 
in some predefined direction, for example (1, 1).

The solution steps described above can be automated with a script in COMSOL Script 
or MATLAB. Note that it is not possible to automate it with solver scripting because 
you have to change the analysis type before switching to the nonlinear solver. The 
automation is recommended if you are interested in doing several sweeps for different 
bands and for different k directions. 

b1 2π
a2 a3×

a1 a2 a3×( )⋅
-----------------------------------=

b2 2π
a3 a1×

a1 a2 a3×( )⋅
-----------------------------------=

b1
2π
a1

---------
a1
a1
---------=

b2
2π
a2

---------
a2
a2
---------=
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Results and Discussion

Figure 4-7 contains the field profile for k = 0.5 in the (1, 1) direction. The frequency 
for this band and k-vector is 395 THz, and the k = 0 eigenvalue for this band 
corresponds to a frequency of 423 THz.

Figure 4-7: Field profile, Ez, at k = 0.5 for the first band in the (1, 1) direction.
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The five lowest bands for the (1, 1) direction appear in Figure 4-8 below. The three 
lowest bands lie close and do not really show any true bandgap. A bandgap appears 
between the third and fourth band.

Figure 4-8: Band diagram of the bands in the (1, 1) direction.

Using a script, it is also possible to perform a sweep in different directions and for 
several bands, together with the sweep of the k-vector magnitude. Such an analysis 
results in several band surfaces in k-space. Figure 4-9 on page 197 shows the five 
lowest band surfaces obtained using the script created under the section “Modeling 
Larger Sweeps With COMSOL Script” on page 204. There is a large bandgap between 
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the third and fourth band surface, and no waves in this frequency range can propagate 
in the crystal.

Figure 4-9: Band surfaces for the five lowest bands for one quadrant in k-space.
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B A N D G A P  A N A L Y S I S  O F  A  P H O T O N I C  C R Y S T A L  |  197



198 |  C H A P T E R
Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select 2D from the Space dimension list.

2 In the list of application modes, select 
RF Module>In-Plane Waves>TE Waves>Eigenfrequency analysis.

3 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, choose Constants.

2 In the Constants dialog box, define the following constants with names, expressions, 
and (optional) descriptions:

Scalar Expressions
1 From the Options menu, choose Expressions>Scalar Expressions.

2 In the Scalar Expressions dialog box, define the following variables with names, 
expressions, and (optional) descriptions:

NAME VALUE DESCRIPTION

k 0 Fraction of wave vector magnitude

k1 1 1st component of wave direction vector

k2 1 2nd component of wave direction vector

a1x 375[nm] x-component of 1st lattice vector

a1y 0[nm] y-component of 1st lattice vector

a2x 0[nm] x-component of 2nd lattice vector

a2y 375[nm] y-component of 2nd lattice vector

NAME EXPRESSION DESCRIPTION

kx k*(k1*b1x+k2*b2x) 1st k-component for periodic 
condition

ky k*(k1*b1y+k2*b2y) 2nd k-component for periodic 
condition

b1x 2*pi*a2y/(a1x*a2y-a1y*a2x) x-component of 1st 
reciprocal lattice vector

b1y -2*pi*a2x/(a1x*a2y-a1y*a2x) y-component of 1st 
reciprocal lattice vector

b2x -2*pi*a1y/(a1x*a2y-a1y*a2x) x-component of 2nd 
reciprocal lattice vector
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G E O M E T R Y  M O D E L I N G

1 From the Draw menu, choose Specify Objects>Rectangle.

2 In the dialog box that appears, define the rectangle properties according to the table 
below.

3 From the Draw menu, choose Specify Objects>Circle.

4 In the dialog box that appears, define the circle properties according to the table 
below.

5 Finally, click the Zoom Extents button on the Main toolbar to simplify the boundary 
and subdomain selection.

P H Y S I C S  S E T T I N G S

Boundary Conditions
1 Open the Boundary Settings dialog box from the Physics menu.

2 Select all boundaries and select the Periodic condition from the Boundary condition 
list.

3 From the Type of periodicity list, choose Floquet periodicity.

4 Enter kx and ky in the edit fields for the k-vector.

5 The selected boundaries represents two groups of periodic conditions, one between 
Boundaries 1 and 4, and the other between Boundaries 2 and 3. You must specify a 
different periodic pair index to separate them. Select Boundaries 2 and 3 and enter 
2 in the Periodic pair index edit field.

6 Click OK.

b2y 2*pi*a1x/(a1x*a2y-a1y*a2x) y-component of 2nd 
reciprocal lattice vector

n_Air 1 Refractive index of air

n_GaAs 3.3285e5[1/m]*lambda0_rfwe+ 
3.5031

Dispersive refractive index 
of GaAs

WIDTH HEIGHT BASE (X, Y)

3.75e-7 3.75e-7 Center (0,0)

RADIUS BASE (X, Y)

7e-8 Center (0,0)

NAME EXPRESSION DESCRIPTION
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Subdomain Settings
1 Open the Subdomain Settings dialog box from the Physics menu and specify the 

subdomain settings according to the following table. Prior to specifying the 
refractive index, n, it is necessary to click the Specify material properties in terms of 

refractive index radio button.

2 Click the Init tab and enter Ez in the Ez(t0) edit field for both subdomains.

3 Click OK.

Integration Coupling Variables
When the nonlinear solver calculates the eigenvalue it is necessary to provide a second 
equation to the system. This model uses a normalization taking the average value of 
the squared magnitude of the electric field over the entire domain. The average value 
is calculated using an integration coupling variable, and an ODE forces that variable 
equal to 1.

1 From the Options menu choose Integration Coupling Variables>Subdomain Variables.

2 In the dialog box that appears, define two variables according to the table below. 
Make sure that the Global destination check box is selected for both variables.

3 Click OK.

PROPERTY SUBDOMAIN 1 SUBDOMAIN 2

n n_Air n_GaAs

NAME SUBDOMAIN EXPRESSION

A 1,2 1

nEz 1,2 Ez*conj(Ez)/A
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M E S H  G E N E R A T I O N

1 Open the Free Mesh Parameters dialog box from the Mesh menu.

2 Select the Finer mesh size from the Predefined mesh sizes list.

3 Click Remesh and then click OK.

C O M P U T I N G  T H E  E I G E N V A L U E  S O L U T I O N

As a first step, calculate a good initial guess for the freq ODE variable and the electric 
field, using the eigenvalue analysis of the photonic crystal. Because the refractive index 
depends on the wavelength, it is necessary to provide a linearization point for the 
eigenvalue.

1 Open the Solver Parameters dialog box from the Solve menu. Make sure that 
Eigenfrequency is chosen in the Analysis list.

2 Type 1 in the Desired number of eigenfrequencies edit field, and type 4e14 in the 
Search for eigenfrequencies around edit field.

3 Click the Eigenfrequency tab, and enter -i*2*pi*4e14 in the Eigenvalue linearization 

point edit field. This is the eigenvalue that corresponds to the eigenfrequency 
4e14 Hz.

4 Click the Advanced tab. Select the Use Hermitian transpose of constraint matrix and 

in symmetry detection check box. Click OK.

5 Click the Solve button on the Main toolbar. The calculated solution has not reached 
the correct eigenvalue, because the frequency 4·1014 Hz was used for the refractive 
index calculation of GaAs and the returned eigenvalue is close to 4.2·1014 Hz. It is 
possible to update the linearization point and solve again, but for the parametric 
sweep defined later it is more efficient to solve a nonlinear problem. The current 
eigenvalue solution is good enough as an initial guess for that nonlinear parametric 
sweep.

C O M P U T I N G  T H E  N O N L I N E A R  S O L U T I O N

Now you use the eigenvalue solution as initial guess for the nonlinear problem. The 
use of the nonlinear solver enables sweeping of variables with the parametric solver. 
Here you ramp the magnitude of the k-vector from 0 to 0.5, which is in units of the 
reciprocal lattice vectors, b1, b2, b3.

1 Open the Solver Parameters dialog box from the Solve menu. Choose Harmonic 

propagation from the Analysis list.

2 Select the Parametric solver from the Solver list. Type k in the Parameter name edit 
field and 0:0.02:0.5 in the Parameter values edit field.
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3 Click the Parametric tab. Select the Manual tuning of parameter step size check box, 
and type 1 in the Minimum step size and Maximum step size edit fields. Click OK.

Space-Independent Equations
1 From the Physics menu, choose Space-Independent Equations.

2 In the Space-Independent Equations dialog box, define the following variable and 
equation:

3 Click OK.

Scalar Variables
1 Choose Scalar Variables from the Physics menu.

2 In the dialog box that appears, enter the value freq for the nu_rfwe variable. Click 
OK.

3 Click the Solve button on the Main toolbar. COMSOL Multiphysics uses the latest 
eigenvalue to calculate the initial guess for the ODE variable freq.

During the sweep, the solver uses the latest solution for both freq and Ez, tracing the 
band starting at k = 0 when k increases. You need to choose the step size of k carefully, 
because a too large step may cause the solution to “jump” to a different band if the 
bands lie close and have similar field profiles. This is hard to avoid in some situations, 
because the bands can meet in some points.

NAME (U) EQUATION INIT (U) DESCRIPTION

freq 1-nEz -imag(lambda)/(2*pi) Frequency
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PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

By default you see the field profile for the current solution in the main window. This 
profile can be used to check that the k-vector sweep stays on the same band. The field 
profile changes only slightly when the magnitude of the k-vector increases, and a 
sudden change in field profile between two k-vector steps can indicate that the solution 
has jumped to a different band.

Click the 3D Surface Plot toolbar button to get a height scale on the default surface plot.

The most interesting plot is the band diagram of the photonic crystal. Follow the steps 
below to generate the band diagram for one band.

1 Choose Global Variables Plot from the Postprocessing menu.

2 In the Global Variables Plot dialog box, select the variable Frequency from the 
Predefined quantities list and press the > button. This is the ODE variable freq.
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3 Click OK to see the following plot.

If you plan to do another sweep for a different band, just repeat the steps starting from 
“Computing the Eigenvalue Solution” on page 201. You have to change the 
eigenvalue shift and linearization point to match the new band for k = 0. If you want 
to plot the new band in the same figure window, make sure that the Keep current plot 
check box is selected in the Global Variables Plot dialog box.

Modeling Larger Sweeps With COMSOL Script

More than three sweeps are best performed using a script or function. The following 
script takes the fem structure, k magnitudes, directions, and eigenfrequency shifts, and 
it then performs several sweeps over all the possible variations. If the direction spans 
several directions in k-space, you can plot the results as a surface for each band.

1 In COMSOL Multiphysics, press Ctrl+F. This exports the current model to the 
COMSOL Script command line. The model is now available at the command 
prompt through the structure named fem.

2 Open the COMSOL Script text editor by typing edit at the command prompt. It 
is also possible to use a different text editor; just make sure to save the script in a the 
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current path used in COMSOL Script or in its search path. You can view the current 
path with the command pwd, and the search path with the command path.

3 In the text editor, enter the following sequence of commands, which controls a 
sweep over five bands and one quadrant in k-space. Save the file with an appropriate 
name.

% k-vector factor to sweep
k = 0.02:0.02:0.5;
% Directions to create band surfaces
dir0 = [ones(1,5) 0.75:-0.25:0 ; 0:0.25:1 ones(1,4)];
% Number of bands
nbands = 5;
% Frequency linearization point
freq0 = 4e14;

% Update magnitude
fem.const{2*strmatch('k',fem.const(1:2:end),'exact')} = k(1);

% Clear frequency variable
nu = [];
% Loop over all directions
for dir=dir0
    % Update direction
    fem.const{2*strmatch('k1',fem.const(1:2:end), ...
                         'exact')} = dir(1);
    fem.const{2*strmatch('k2',fem.const(1:2:end), ...
                         'exact')} = dir(2);
    % Switch to eigenvalue analysis
    fem.appl{1}.prop.analysis = 'eigen';
    fem = multiphysics(fem);
    fem.xmesh = meshextend(fem);
    % Solve eigenvalue problem
    init = asseminit(fem,'init','0');
    fem.sol=femeig(fem, ...
                   'init',init, ...
                   'conjugate','on', ...
                   'solcomp',{'Ez'}, ...
                   'neigs',nbands, ...
                   'shift',-i*2*pi*freq0, ...
                   'eigref',sprintf('-i*2*pi*%g',freq0));
    % Store solution guess for all bands
    sole = fem.sol;
    % Switch to harmonic analysis
    fem.appl{1}.prop.analysis = 'harmonic';
    fem = multiphysics(fem);
    fem.xmesh = meshextend(fem);
    % Loop over all bands
    for ind=1:length(sole.lambda)
        % Print some progress information
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        disp(sprintf(['Direction = (%g,%g), ' ...
                     'Band number %i'],dir,ind));
        init = asseminit(fem,'u',sole,'solnum',ind);
        % Sweep in direction using eigenvalue solution guess
        fem.sol=femnlin(fem, ...
                        'init',init, ...
                        'conjugate','on', ...
                        'pname','k', ...
                        'plist',k, ...
                        'porder',0, ...
                        'pminstep',0.01, ...
                        'pmaxstep',0.01);
        nu = cat(1,nu,postint(fem,'nu_rfwe','edim',0,'dl',1,...
                              'solnum','all'));
    end
end
% Reshape the nu data to have bands in the 3:rd dimension
nu = reshape(nu,[nbands size(dir0,2) length(k)]);
nu = permute(nu,[2 3 1]);
% Save data for later use
save band_diagram_data k dir0 nu

% Create a grid for plotting
[K,DIRx] = meshgrid(k,dir0(1,:));
[K,DIRy] = meshgrid(k,dir0(2,:));
X = DIRx.*K;
Y = DIRy.*K;
% Plot one surface for each band
figure(2);
hold on;
for ind=1:size(nu,3)
    h = mesh(X,Y,real(nu(:,:,ind)));
    % Set transperency and colors
    set(h,'EdgeColor',[1 1 0.3],'FaceColor','interp',...
          'ColorMap','cool(1024)','FaceAlpha',0.6);
end
% Band diagram in (1,1) direction
figure(3);
plot(k,permute(real(nu(5,:,:)),[3 2 1]));
xlabel('<b>k</b>, (1,1) direction');
ylabel('Frequency [Hz]');

You can find more information on the script commands in the COMSOL Script 
User’s Guide and the COMSOL Multiphysics Reference Guide.

4 Once you saved the script, you can execute it from the command prompt by typing 
it name without the extension. If you, for example, named the file 
band_diagram_sweep.m, type the following at the command line:
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band_diagram_sweep

The script takes a long time to solve because it calculates so many data points.
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S t e p - I n d e x  F i b e r

Introduction

The transmission speed of optical waveguides is superior to microwave waveguides 
because optical devices have a much higher operating frequency than microwaves, 
enabling a far higher bandwidth.

Today the silica glass (SiO2) fiber is forming the backbone of modern communication 
systems. Before 1970, optical fibers suffered from large transmission losses, making 
optical communication technology merely an academic issue. In 1970, researchers 
showed, for the first time, that low-loss optical fibers really could be manufactured. 
Earlier losses of 2000 dB/km now went down to 20 dB/km. Today’s fibers have losses 
near the theoretical limit of 0.16 dB/km at 1.55 µm (infrared light). 

One of the winning devices has been the single-mode fiber, having a step-index profile 
with a higher refractive index in the centre core and a lower index in the outer 
cladding. Numerical software plays an important role in the design of single-mode 
waveguides and fibers. For a fiber cross section, even the most simple shape is difficult 
and cumbersome to deal with analytically. A circular step-index waveguide is a basic 
shape where benchmark results are available (see Ref. 1).

This example is a model of a single step-index waveguide made of silica glass. The inner 
core is made of pure silica glass with refractive index n1 = 1.4457 and the cladding is 
doped, with a refractive index of n2 = 1.4378. These values are valid for free-space 
wavelengths of 1.55 µm. The radius of the cladding is chosen to be large enough so 
that the field of confined modes is zero at the exterior boundaries.

For a confined mode there is no energy flow in the radial direction, thus the wave must 
be evanescent in the radial direction in the cladding. This is true only if

On the other hand, the wave cannot be radially evanescent in the core region. Thus 

The waves are more confined when neff is close to the upper limit in this interval.

neff n2>

n2 neff n1< <
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Model Definition

The mode analysis is made on a cross-section in the x-y plane of the fiber. The wave 
propagates in the z direction and has the form

where ω is the angular frequency and β the propagation constant. An eigenvalue 
equation for the magnetic field H is derived from Helmholtz equation

which is solved for the eigenvalue λ = −jβ.

As boundary condition along the outside of the cladding the magnetic field is set to 
zero. Because the amplitude of the field decays rapidly as a function of the radius of the 
cladding this is a valid boundary condition.

Results and Discussion

When studying the characteristics of optical waveguides, the effective mode index of a 
confined mode, 

as a function of the frequency is an important characteristic. A common notion is the 
normalized frequency for a fiber. This is defined as

H x y z t, , ,( ) H x y,( )ej ωt βz–( )
=

∇ n 2– ∇ H×( )× k0
2H– 0=

neff
β
k0
------=

V 2πa
λ0

---------- n1
2 n2

2
– k0a n1

2 n2
2

–= =
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where a is the radius of the core of the fiber. For this simulation, the effective mode 
index for the fundamental mode, 1.4444 corresponds to a normalized frequency of 
4.895. The electric and magnetic fields for this mode is shown in Figure 4-10 below.

Figure 4-10: The color scale is the z component of the electric field and the contour lines is 
the z component of the magnetic field. This plot is for the effective mode index 1.4444.

Reference

1. Amnon Yariv, Optical Electronics in Modern Communications, 5th edition, 
Oxford University Press, 1997.

Model Library path: RF_Module/Optics_and_Photonics/step_index_fiber

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 In the Model Navigator, select 2D in the Space dimension list.
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2 Select the RF Module>Perpendicular Waves>Hybrid-Mode Waves>Mode analysis 
application mode.

3 Click OK.

A P P L I C A T I O N  M O D E  P R O P E R T I E S

1 Select Properties in the Physics menu to open the Application Mode Properties dialog 
box.

2 For convenience set the property Specify wave using to Free space wavelength. This 
makes the wavelength available in the Application Scalar Variables dialog box instead 
of the frequency.

O P T I O N S  A N D  S E T T I N G S

1 In the Constants dialog box, enter the following names and expressions for the 
refractive indices.

G E O M E T R Y  M O D E L I N G

1 Draw a circle C1 centered at (0,0) with radius 8e-6.

2 Draw a second circle C2 centered at (0,0). This time with the radius 40e-6.

3 Click the Zoom Extents button for a full visualization of the two circles.

P H Y S I C S  S E T T I N G S

Scalar Variables
In the Application Scalar Variables dialog box, set the free space wavelength 
lambda0_rfwv to 1.55e-6.

Boundary Conditions
Use the default boundary conditions on all exterior boundaries.

Subdomain Settings
In the Subdomain Settings dialog box enter the refractive index in the two domains 
according to the following table.

NAME EXPRESSION

nSilicaGlass 1.4457

nSilicaGlassDoped 1.4378

SETTING SUBDOMAIN 1 SUBDOMAIN 2

n nSilicaGlassDoped nSilicaGlass
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M E S H  G E N E R A T I O N

1 Initialize the mesh.

2 Refine the mesh once.

C O M P U T I N G  T H E  S O L U T I O N

The modes of interest have an effective mode index somewhere between the refractive 
indices of the two materials, that is,

1 In the Solver Parameters dialog box set the parameter Search for effective mode 

indices around to 1.446. This guarantees that the solver will find the fundamental 
mode, which has the largest effective mode index.

2 Solve the problem.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows the power flow in the z direction for the fundamental mode. 
This is the HE11 mode, which is verified by visualizing the transversal components of 
both the magnetic and the electric field.

1 In the Plot Parameters dialog box, select surface and contour plots.

2 Set Solution at angle (phase) to 45.

3 On the Surface tab, set the Surface data to Electric field, z component.

1.4378 neff 1.4457< <
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4 On the Contour tab, give Magnetic field, z component as Contour data.

Modeling Using the Programming Language

The following command lines preforms the calculation in COMSOL Script. The code 
is also available in the script file step_index_fiber_cmd.m in the model library path.

% The model can also be simulated by programming. First set up the 
% structure with the geometry and the refractive indices as 
% constants.
clear fem
fem.sdim={‘x’ ‘y’};
fem.geom=circ2(0,0,8e-6)+circ2(0,0,40e-6);
fem.const={...
  ‘nSilicaGlassDoped’,1.4378,...
  ‘nSilicaGlass’,1.4457};

% Then define the application mode structure and generate the FEM 
% structure from it.
clear appl
appl.mode=’PerpendicularWaves’;
appl.prop.inputvar=’lambda’;
appl.var.lambda0=1.55e-6;
appl.equ.n={‘nSilicaGlassDoped’ ‘nSilicaGlass’};
fem.appl=appl;
fem=multiphysics(fem);
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% Now generate the mesh, and the extended mesh structure.
fem.mesh=meshinit(fem);
fem.mesh=meshrefine(fem);
fem.xmesh=meshextend(fem);

% Solve the problem and visualize the solution.
% Note that the ‘shift’ parameter to the solver
% must be expressed as the eigenvalue lambda = -j*beta.
fem.sol=femeig(fem,’shift’,-5.861604e6*i);
postplot(fem,’tridata’,’Ez’,’contdata’,’Hz’,’phase’,45);
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S i l i c a - o n - S i l i c o n  Wavegu i d e

Introduction

Planar photonic waveguides in silica (SiO2) have great potential for use in wavelength 
routing applications. The major problem with these kinds of waveguides is 
birefringence. Anisotropic refractive indices result in fundamental mode splitting and 
pulse broadening. The goal is to minimize birefringence effects by adapting materials 
and manufacturing processes. One source of birefringence is the use of a silicon (Si) 
wafer on which the waveguide structure is deposited. After annealing at high 
temperature (approximately 1000 °C), mismatch in thermal expansivity between the 
silica and silicon layers results in thermally induced stresses in the structure at the 
operating temperature (typically room temperature, 20 °C).

The Stress-Optical Effect and Plane Strain

The general linear stress-optical relation can be written, using tensor notation, as

where ∆nij = nij − n0 Iij, nij is the refractive index tensor, n0 is the refractive index for 
a stress-free material, Iij is the identity tensor, Bijkl is the stress-optical tensor, and σkl 
is the stress tensor. Due to symmetry the number of independent parameters in the 
stress-optical tensor that characterizes this constitutive relation can be reduced. 
Because nij and σkl are both symmetric, Bijkl = Bjikl and Bijkl = Bijlk. In many cases it 

Air

Cladding (Silica)

Buffer (Silica)

Silicon Wafer Core

Optical Computation Domain Boundary

∆nij B– ijklσkl=
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is possible to further reduce the number of independent parameters, and this model 
includes only two independent parameters, B1 and B2. The stress-optical relation 
simplifies to

where nx = n11, ny = n22, nz = n33, σx = σ11, σy = σ22, and σz = σ33.

This translates to

Using the two parameters B1 and B2, the model assumes that the nondiagonal parts 
of nij and σkl are negligible. This means that the shear stress corresponding to 
σ12 = τxy is neglected. In addition, the shear stresses corresponding to σ13 = τxz and 
σ23 = τyz are neglected by using the plane strain approximation. The plane strain 
approximation holds in a situation where the structure is free in the x and y direction 
but where the z strain is assumed to be zero. Note that this deformation state is not 
correct if the structure is free also in the z direction. In such a case a modified 
deformation state equation, which handles the the x and z directions equivalently, is 
needed.

The first part of this model utilizes the Plane Strain application mode of the Structural 
Mechanics Module. The resulting birefringent refractive index is computed using 
expression variables and can be considered a postprocessing step of the plane strain 
model. The refractive index tensor is used as material data for the second part of the 
model, the mode analysis.

The model “Stress-Optical Effects with Generalized Plane Strain” on page 232 
demonstrates a computation where the structure is free also in the z direction, using a 
formulation called generalized plane strain.

Perpendicular Hybrid-Mode Waves

For a given frequency ν, or equivalently, free-space wavelength λ0 = c0/ν, the RF 
Module’s Perpendicular Hybrid-Mode Waves application mode can be used for the 

∆nx

∆ny

∆nz

B2 B1 B1

B1 B2 B1

B1 B1 B2

σx

σy

σz

–=

nx n0 B2σx– B1 σy σz+( )–=

ny n0 B2σy– B1 σz σx+( )–=

nz n0 B2σz– B1 σx σy+( )–=
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mode analysis. In this model the free-space wavelength is 1.55 µm. The simulation is 
set up with the normalized magnetic field components H=(Hx, Hy, Hz) as dependent 
variables, and the effective mode index neff = β/k0 is obtained from the eigenvalues.

Using this application mode, the wave is assumed to have the form

The computations show a shift in effective mode index due to the stress-induced 
change in refractive index. The birefringence causes the otherwise two-fold degenerate 
fundamental mode to split.

Model Library path: RF_Module/
Optics_and_PhotonicsStructural_Mechanics_Module/

Stress-Optical_Effects/stress_optical

Note: This model requires the RF Module and the Structural Mechanics Module.

Plane Strain Analysis

1 In the Model Navigator, select 2D.

2 Select the Structural Mechanics Module>Plane Strain>Static analysis application mode.

3 Click Multiphysics then Add to add this application mode to the model.

4 Next select the RF Module>Perpendicular Waves>Hybrid-Mode Waves>Mode analysis 
application mode. Click Add to add this application mode to the model; then click 
OK.

5 Choose Physics>Properties to open the Application Mode Properties dialog box and 
set Field components to In-plane components. This selects the two-components 
equation formulation for hybrid-mode waves. The default three-component 
equation formulation can also be used for this problem. See “Selecting Equation 
Formulation” on page 146 in the RF Module User’s Guide for general information 
about the different options.

H H x y,( )ej ωt βz–( ) Hx x y,( ) Hy x y,( ) Hz x y,( ), ,( )ej ωt βz–( )
= =
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6 For convenience set the property Specify wave using to Free space wavelength. This 
makes the wavelength available in the Application Scalar Variables dialog box instead 
of the frequency. Click OK to close the Application Mode Properties dialog box.

7 Choose Multiphysics>Model Navigator. Set the Ruling application mode to the 
Perpendicular Hybrid-Mode Waves application mode. This makes this mode specify 
the interpretation of the parameters to the eigenvalue solver given in the Solver 

Parameters dialog box. Click OK.

O P T I O N S  A N D  S E T T I N G S

1 Open the Constants dialog box from the Options menu and enter the following 
names,expressions, and descriptions (optional); when done, click OK.

Notice that the temperatures are given in degrees Celsius. This works well because this 
is a linear model. (Nonlinear models need to have temperatures in kelvin to get the 
correct thermodynamics.)

NAME EXPRESSION DESCRIPTION

nSi 3.5 Refractive index, silicon (Si)

nBuf 1.445 Refractive index, silica (SiO2)

nClad 1.445 Refractive index, silica

deltan 0.0075 Relative index difference: 

nCore nClad/sqrt(1-2*deltan) Refractive index, core

alphaSi 2.5e-6[1/K] Thermal expansion coefficient, silicon

alphaSiO2 0.35e-6[1/K] Thermal expansion coefficient, silica

ESi 110[GPa] Young’s modulus, silicon

ESiO2 78[GPa] Young’s modulus, silica 

nuSi 0.19 Poisson’s ratio, silicon

nuSiO2 0.42 Poisson’s ratio, silica

B1 4.2e-12[m^2/N] First stress optical coefficient

B2 0.65e-12[m^2/N] Second stress optical coefficient 

T1 20[degC] Operating temperature

T0 1000[degC] Reference temperature 

∆
ncore

2 ncladding
2

–( )

2ncore
2

---------------------------------------------=
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2 Give axis and grid settings according to the following table.

G E O M E T R Y  M O D E L I N G

Draw rectangles corresponding to the different regions.

AXIS GRID

x min -0.2e-3 x spacing 1e-5

x max 0.2e-3 Extra x

y min -0.1e-3 y spacing 1e-5

y max 0.03e-3 Extra y

REGION LOWER LEFT CORNER UPPER RIGHT CORNER

Silicon Wafer (-16e-5,-1e-4) (16e-5,-1.7e-5)

Buffer (-16e-5,-1.7e-5) (16e-5,-3e-6)

Cladding (-16e-5,-3e-6) (16e-5,1.3e-5)

Core (-3e-6,-3e-6) (3e-6,3e-6)
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P H Y S I C S  S E T T I N G S

Point Settings and Boundary Conditions
All regions have free boundaries, which also is the default boundary condition. 
However, these conditions will not suffice in creating a unique solution because the 
computational domain is allowed to move and rotate freely; the problem is ill-posed. 
The problem becomes well-posed by adding constraints at points to keep the domain 
fixed.

1 Select the Plane Strain application mode from the Multiphysics menu.

2 Open the Point Settings dialog box, and check the constraints Rx and Ry at Point 1, 
the lower left corner, for both the x and y direction. This will keep the domain from 
moving (translational move).

3 Check the constraint Ry at Point 9, the lower right corner, for the y direction only, 
keeping the domain from rotating but allowing it to slide in the x direction.

Subdomain Settings
The air domain need not be part of the plane strain model.

1 Specify the subdomain settings for the Plane Strain application mode according to 
the following table:

Before entering the temperatures on the Load page, you need to check Include 

thermal expansion. It is not necessary to specify the density ρ, because it does not 
enter the equation for static problems.

SUBDOMAIN 1 SUBDOMAINS 2–4

Page Material Load Material Load

E ESi E ESiO2

ν nuSi Temp T1 ν nuSiO2 Temp T1

α alphaSi Tempref T0 α alphaSiO2 Tempref T0
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E X P R E S S I O N  V A R I A B L E S

In the Subdomain Expressions dialog box in the Options menu, define the following 
variables; when done, click OK.

M E S H  G E N E R A T I O N

Initialize a mesh and refine it twice.

C O M P U T I N G  T H E  S O L U T I O N

1 In the Solver Parameters dialog box select the Stationary solver.

2 On the Solve for tab in the Solver Manager dialog box, select only the Plane Strain 
application mode. This will make sure that only the Plane Strain application mode 
equations are solved in the first run.

3 Click the Solve button.

VARIABLE NAME SUBDOMAIN EXPRESSION

N 1

2

3

4

nSi

nBuf

nClad

nCore

Nx 1

2,3,4

N

N-B1*sx_smpn-B2*(sy_smpn+sz_smpn)

Ny 1

2,3,4

N

N-B1*sy_smpn-B2*(sx_smpn+sz_smpn)

Nz 1

2,3,4

N

N-B1*sz_smpn-B2*(sx_smpn+sy_smpn)
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P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows the von Mises effective stress as a colored surface plot.

1 To view the von Mises stress along a horizontal line through the entire structure, 
use a cross-section plot. In the Cross-Section Plot Parameters dialog box, select von 
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Mises stress as y-axis data on the Line/Extrusion tab. As Cross-section line data set x0 
to -16e-5, y0 to 0, x1 to 16e-5, and y1 to 0. Use x as x-axis data.

Notice that the effective stress is varying slowly on the horizontal cut. This means 
that the significant influence on the stress induced changes in refractive index will 
come from the stress variations in the vertical direction. This is expected since the 
extension of the domains in the x direction is chosen to minimize effects of the 
edges.

Next plot the birefringence:

2 In the Plot Parameters dialog box, click the Surface tab.
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3 To view the stress-induced birefringence nx − ny, type Nx-Ny in the Expression field 
on the Surface Data page.

4 Now create a cross-section plot of the birefringence nx − ny on the vertical line from 
(0, −3·10−6) to (0, 3·10−6). Do this by entering Nx-Ny as y-axis data, and setting x0 
to 0, y0 to -3e-6, x1 to 0, and y1 to 3e-6 in the Cross-Section Plot Parameters dialog 
box. Set the x-axis data to Arc-length. The birefringence varies linearly from about 
2.9·10−4 at the bottom of the core to 2.4·10−4 at the top. Do not close the figure.

5 Now create another cross-section plot of the birefringence on the horizontal line 
from (−3·10−6, 0) to (3·10−6, 0). On the General tab select the Keep current plot 
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check box to make the plot in the same window as the previous one. On the Line/

Extrusion page, set x0 to -3e-6, y0 to 0, x1 to 3e-6, and y1 to 0.

The birefringence is constant on the horizontal line, thus the influence of the edges 
is indeed reduced to a minimum.

Optical Mode Analysis

Select the Perpendicular Hybrid-Mode Waves application mode from the Multiphysics 
menu.

G E O M E T R Y  M O D E L I N G

The computational domain can be reduced significantly for the optical mode analysis, 
because the energy of the fundamental modes is concentrated in the core region, and 
the energy density decays rapidly in the cladding and buffer regions.

Draw a rectangle with corners at (−1e-5, −1e-5) and (1e-5, 1e-5).

The rectangular region containing the active domains can be enlarged later on for 
validating the results. The rectangular region should be chosen large enough so that 
the computed propagation constants do not change significantly if the region is 
enlarged.
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P H Y S I C S  S E T T I N G S

Scalar Variables
1 From the Physics menu, choose Scalar Variables.

2 In the Application Scalar Variables dialog box, set the free-space wavelength to 
1.55e-6; when done, click OK.

Subdomain Settings
1 From the Physics menu, choose Subdomain Settings.

2 Deactivate the Perpendicular Hybrid-Mode Waves application mode in all 
subdomains except 4, 5, and 6. This makes sure the problem is only solved in the 
newly drawn rectangle.

3 For all active domains, select n (anisotropic) and set Nx, Ny, and Nz, respectively, as 
anisotropic refractive indices by changing the entries on the diagonal in the 
refractive index matrix.

4 When done, click OK.

Boundary Conditions
The only available perfect magnetic conductor boundary condition will suffice. Both 
the E and the H fields are assumed to be of negligible size at the boundaries, hence 
any one of them can be set equal to zero at the boundary.

M E S H  G E N E R A T I O N

1 On the Subdomain tab in the Free Mesh Parameters dialog box, set the Maximum 

element size to 2e-6 for Subdomains 4 and 5, and to 1e-6 for Subdomain 6. This 
will make the mesh dense in the activated regions and coarse in the deactivated 
regions. The mesh in the deactivated regions only affects the interpolated values of 
the expression variables and not the mode computation results.

2 Initialize the mesh.

C O M P U T I N G  T H E  S O L U T I O N

1 In the Solver Parameters dialog box, select the Eigenvalue solver.

2 Enter 1.46 in the Search for effective mode indices around edit field. The default 
Desired number of effective mode indices is set to 6, which is fine. These settings will 
make the eigenmode solver search for the 6 eigenmodes with effective mode indices 
closest to the value 1.46. This value is an estimate of the effective mode index for 
the fundamental mode. For propagating modes it must hold that

neff ncore< 1.456=
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3 In the Solver Manager dialog box, select only the Perpendicular Hybrid-Mode Waves 
application mode on the Solve For tab. This ensures that the Plane Strain application 
mode is not part of the eigenmode computation.

4 On the Initial Value tab, set the initial value to Current solution. This will take the 
plane strain solution and use it to evaluate the refractive indices for the mode 
analysis.

5 Click the Solve button.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 On the Surface tab in the Plot Parameters dialog box, select Perpendicular 

Hybrid-Mode Waves (rfwv)>Power flow, time average, z component from the 
Predefined quantities list on the Surface Data tab. Then click Apply. This creates a 
visualization of the power flow, also called optical intensity or the Poynting vector, 
in the z direction (out-of-plane direction).

2 The default eigenmode is the one with the highest effective mode index 
corresponding to one of the fundamental modes.

Convergence Analysis

To check the accuracy of the eigenvalues you need to examine the sensitivity of these 
values to changes in the mesh density.
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1 In the Free Mesh Parameters dialog box, lower the value of the maximum element 
size for the core subdomain, number 6, to 5e-7, remesh, and solve again.

2 Repeat this for the maximum element sizes 2.5e-7 and 1.25e-7.

The solver finds the following effective mode:

It is evident from the table that the fundamental modes, corresponding to the two 
lowest eigenmodes with the highest effective mode indices, are nearly degenerate. It is 
also clear that the split of the degenerate fundamental modes that is expected due to 
the stress-induced anisotropic refractive index has been properly resolved with these 

ELEMENT SIZE, 
CORE 
SUBDOMAIN

1E-6 5E-7 2.5E-7 1.25E-7

EFFECTIVE MODE 
INDEX

neff1 1.451149 1.451139 1.451136 1.451136

neff2 1.450883 1.450875 1.450872 1.450871

neff3 1.445409 1.445407 1.445405 1.445405

neff4 1.445144 1.445141 1.445139 1.445139

neff5 1.445139 1.445133 1.445132 1.445131

neff6 1.444873 1.444867 1.444865 1.444865
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mesh sizes. The convergence of the two fundamental modes is shown in the figure 
below.

Now, run the model without the stress-induced birefringence.

1 Change the refractive index of Subdomains 4, 5, and 6 to an isotropic index by 
selecting the n (isotropic) radio button in the Subdomain Settings dialog box, and 
typing N as refractive index.

2 Solve the problem for a maximum element size of 2.5e-7 for Subdomain 6.

Compare these ideal values of the propagation constants with the stress-optical case.

ELEMENT SIZE, 
CORE 
SUBDOMAIN:

2.5E-7 (STRESS) 2.5E-7 (NO STRESS) DIFFERENCE

EFFECTIVE MODE 
INDEX

*1e-4

neff1 1.451136 1.450821 3.15

neff2 1.450872 1.45082 .51

neff3 1.445405 1.445093 57.79

neff4 1.445139 1.445083 .56

neff5 1.445132 1.444832 3.00

neff6 1.444865 1.444799 .66

6 6.1 6.2 6.3 6.4 6.5 6.6 6.7 6.8 6.9 7
1.4509

1.4509

1.451

1.451

1.4511

1.4511
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1.4512

1.4512
Computed value of effective mode index vs. mesh size h in core subdomain
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The difference is significant, which shows that the shift in the effective mode indices 
due to the stress-optical effect is indeed resolved.

Visual inspection of the 4 higher eigenmodes indicates that these are probably 
degenerate in the ideal case of no thermally induced stresses. Moreover, the higher 
eigenmodes have a larger portion of energy leaking into the cladding and buffer, and 
are thus more affected than the fundamental modes of the distance to the air and 
silicon layers. Because of this leakage, the boundary condition will affect the higher 
eigenmodes more than the fundamental mode. Thus a refined analysis of the higher 
modes would make it necessary to enlarge the computation domain. 

The figure below shows the z component of the Poynting vector for the fourth 
eigenmode.

M O D E L I N G  E R R O R S  A N D  S E N S I T I V I T Y  A N A L Y S I S

Although the fundamental modes have converged to 5 decimal places, the known 
modeling errors makes the exactness of the numbers uncertain. One major modeling 
error is due to the fact that the model contains a plane strain assumption in a case 
where the real-world model does not necessarily conform to this deformation state. 
This modeling error is reduced in the refined model “Stress-Optical Effects with 
Generalized Plane Strain” on page 232. Moreover, the material properties are only 
known to a few decimal places and the computed magnitudes of the effective mode 
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indices will correspondingly be uncertain. A standard way of examining the effects of 
uncertainty in material parameters is to perform a sensitivity analysis. That is, you 
perturb one of the material parameters slightly and then examine the resulting 
perturbation in the computed parameter. Another source of uncertainty is whether the 
stress from the thermal expansion is large with respect to the other sources of stress in 
the material originating from the manufacturing process.
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S t r e s s -Op t i c a l  E f f e c t s  w i t h  
Gen e r a l i z e d  P l a n e  S t r a i n

Introduction

The assumptions made for plane strain in the previous analysis of the waveguide 
structure, in the model “Stress-Optical Effects in a Silica-on-Silicon Waveguide” on 
page 215, do not hold in a situation where the silicon-silica laminate is free to expand 
in the z direction. Instead it is necessary to use a generalized plane strain model that 
allows for free expansion in the z direction. The boundary conditions in the xy-plane 
already allow the structure to expand freely in all directions in the plane. When the 
different materials in a laminate expand with different expansion coefficients, the 
laminate bends. In this model, the silica-silicon laminate bends in both the x and 
z directions. The Plane Strain application mode does not cover the bending in the 
z direction, so you must make modifications to the plane strain equations at the 
equation-system level.

Note: This model requires the RF Module and the Structural Mechanics Module.

Generalized Plane Strain

One possible extension of the plane strain formulation is to assume that the strain in 
the z direction has the form

That is, the strain is linearly varying throughout the cross section. This approximation 
is expected to be good when the bending curvature is small with respect to the extents 
of the structure in the xy-plane and corresponds to a small rotation that is 
representative of each cross section of the structure along the z axis. (A more general 
model would include second-degree terms in x and y.)

One way of validating the result of this simulation is to plot the εx and εz strains on a 
cross section on the symmetry line at x = 0. Because you can expect an identical 
bending in the x and z directions, these strains should be identical and vary linearly.

εz e0 e1x e2y+ +=
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E X T E N S I O N  O F  T H E  P L A N E  S T R A I N  E Q U A T I O N S

The objective is to extend the current Plane Strain application mode with additional 
PDE terms that represent the generalized plane strain deformation state. In COMSOL 
Multiphysics, the coefficients e0, e1, and e2 in the expression for the εz strain is 
modeled with coupling variables associated with a point geometry object (zero 
dimensional object). This is a convenient way to include degrees of freedom that are 
constant throughout a subdomain. In order to expand the equations for the Plane 
Strain application mode, the new εz strain contributions need to be added as weak 
terms to the ordinary plane strain equations. The reason for this is that for COMSOL 
Multiphysics to be able to solve the equations as a linear problem, the assembler 
requires that all contributions from coupling variables are entered as weak terms.

Start from the 3D stress-strain relation for linear isotropic conditions including 
thermal effects,

where σx, σy, σz, τxy, τyz, and τxz are the components of the stress tensor, εx, εy, εz, γxy, 
γyz, and γxz are the components of the strain tensor, α is the thermal expansion 
coefficient, T is the operating temperature, and Tref is the reference temperature 
corresponding to the manufacturing temperature. The 6-by-6 matrix D (tensor) has 
entries that contain expressions in Young’s modulus, E, and Poisson’s ratio, ν. The 
matrix D is presented in the Structural Mechanics Module User’s Guide.

For generalized plane strain (and ordinary plane strain), assume that γyz = γxz = 0 and 
two of the equations vanish

The matrix D shrinks accordingly.

σx

σy

σz

τxy

τyz

τxz

D

εx

εy

εz

γxy

γyz

γxz

α

T Tref–

T Tref–

T Tref–

0
0
0

–

⎝ ⎠
⎜ ⎟
⎜ ⎟
⎜ ⎟
⎜ ⎟
⎜ ⎟
⎜ ⎟
⎜ ⎟
⎜ ⎟
⎜ ⎟
⎛ ⎞

=

σx

σy

σz

τxy

D

εx

εy

εz

γxy

α

T Tref–

T Tref–

T Tref–

0

–

⎝ ⎠
⎜ ⎟
⎜ ⎟
⎜ ⎟
⎜ ⎟
⎜ ⎟
⎛ ⎞

=
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The PDE solved is Navier’s equation

where

in the case of generalized plane strain and u = (u, v, w) are the unknown displacement 
variables solved for.

The coefficient c above is a tensor containing the elements of D in a pattern that is 
listed in the Structural Mechanics Module User’s Guide and

contains the contributions from the thermal strains.

In the case of ordinary plane strain the upper left 2-by-2 submatrix of σ, γ, and D is 
used.

It is assumed here that the variables T and Tref are constants. For information on how 
the temperature variables enter Navier’s equation as unknowns in a heat transfer 
problem, see the Structural Mechanics Module User’s Guide. 

To expand the plane strain equation to a generalized plane strain formulation one 
needs to consider the weak form of Navier’s equation. The weak form of a system of 
equations is a scalar equation involving integrals. See “Weak Form Modeling” on page 
293 in the COMSOL Multiphysics Modeling Guide for more information on the 
appearance of the weak form for systems of equations.

To get the weak form of Navier’s equation, multiply by a test function 
v = [utest, vtest, wtest] and integrate

Integration by parts gives

∇– σ⋅ K=

σ
σx τxy 0

τyx σy 0

0 0 σz

c u∇ γ–= =

γ E
1 ν+( ) 1 2ν–( )

---------------------------------------

1 ν+( )α T Tref–( ) 0 0

0 1 ν+( )α T Tref–( ) 0

0 0 1 ν+( )α T Tref–( )

=

v ∇– σ⋅( ) Ωd
Ω
∫ v K Ωd⋅

Ω
∫=
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or in more detail, with K = 0

where uy,test = ∂utest/∂y and similarly for the other test function derivatives. The dot 
product in the domain integral is interpreted as a dot product operating on the rows 
of the matrices so that

where

0 vσn Γ v∇ σ⋅ Ω v K Ωd⋅
Ω
∫+d

Ω
∫–d

Ω∂
∫=

0 utest vtest wtest

σx τxy 0

τyx σy 0

0 0 σz

nx

ny

nz

Γd
Ω∂
∫

ux test, uy test, uz test,

vx test, vy test, vz test,

wx test, wy test, wz test,

σx τxy 0

τyx σy 0

0 0 σz

⋅

⎝ ⎠
⎜ ⎟
⎜ ⎟
⎜ ⎟
⎜ ⎟
⎛ ⎞

Ωd
Ω
∫–

=

ux test, uy test, uz test,

vx test, vy test, vz test,

wx test, wy test, wz test,

σx τxy 0

τyx σy 0

0 0 σz

⋅

⎝ ⎠
⎜ ⎟
⎜ ⎟
⎜ ⎟
⎜ ⎟
⎛ ⎞

Ωd
Ω
∫

ux test, uy test, uz test, σx τxy 0

vx test, vy test, vz test, τyx σy 0 wx test, wy test, wz test, 0 0 σz⋅+⋅

+⋅⎝

⎠

⎛

⎞ Ωd

Ω
∫=
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and

Note that the displacement variable w in the z direction is not available in the Plane 
Strain application mode. However, it is not needed since the generalized formulation 
assumes a certain fix shape of the deformation in the z direction.

The same relations hold for the test functions,

In COMSOL Multiphysics, the test functions utest and vtest are denoted u_test and 
v_test, respectively. Their derivatives ux,test, uy,test, vx,test, and vy,test are denoted 
ux_test, uy_test, vx_test, and vy_test, respectively. Note that the z components 
of the test functions are not available in the Plane Strain application mode.

Using this notation, the weak form of Navier’s equation becomes (with K = 0)

σx
E

1 ν+( ) 1 2ν–( )
--------------------------------------- 1 ν–( )εx νεy νεz 1 ν+( )α T Tref–( )–+ +( )=

σy
E

1 ν+( ) 1 2ν–( )
--------------------------------------- νεx 1 ν–( )εy νεz 1 ν+( )α T Tref–( )–+ +( )=

σz
E

1 ν+( ) 1 2ν–( )
--------------------------------------- νεx νεy 1 ν–( )εz 1 ν+( )α T Tref–( )–+ +( )=

τxy
E

1 ν+( ) 1 2ν–( )
--------------------------------------- 1 2ν–

2
----------------γxy⎝ ⎠
⎛ ⎞=

εx x∂
∂u

=

εy y∂
∂v

=

εz z∂
∂w

=

γxy y∂
∂u

x∂
∂v

+=

εx test, ux test,=

εy test, vy test,=

εz test, wz test,=

γxy test, uy test, vx test,+=

0 vσn Γd
Ω∂
∫ εx test, σx εy test, σy εz test, σz γxy test, τxy+ + +( ) Ωd

Ω
∫–=
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This expression for the weak equation shows which terms you must add as weak terms 
to generalize the plane strain formulation.

To see the difference compared to the ordinary plane strain formulation, the equation 
for σz can be separated out according to

where D has been reduced to 

The ordinary plane strain equation is obtained if εz = 0.

To expand the Plane Strain application mode, you must add weak contributions from 
εz need to the stress components σx and σy according to

In addition, σz needs to be included in the weak equation from being merely a 
postprocessing quantity in the original Plane Strain application mode,

where

and σz was presented earlier.

In COMSOL Multiphysics you model the coefficients e0, e1, and e2 in the expression 
for the εz strain with coupling variables as weak contributions to the ordinary plane 
strain equations. These coefficients represent three additional unknown variables that 
prevail throughout the modeled domain. In practice, these variables need to be 

σx

σy

τxy

D

εx

εy

γxy

1 ν+( )α T Tref–( )

1 ν+( )α T Tref–( )

0

–

νεz

νεz

0

+

⎝ ⎠
⎜ ⎟
⎜ ⎟
⎜ ⎟
⎜ ⎟
⎛ ⎞

=

σz
E

1 ν+( ) 1 2ν–( )
--------------------------------------- νεx νεy 1 ν–( )εz 1 ν+( )α T Tref–( )–+ +( )=

D E
1 ν+( ) 1 2ν–( )

---------------------------------------

1 ν– ν 0
ν 1 ν– 0

0 0 1 2ν–
2

----------------

=

E
1 ν+( ) 1 2ν–( )

--------------------------------------- εx test, νεz εy test, νεz+( )–

εz test, σz–

εz test, e0 test, e1 test, x e2 test, y+ +=
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associated with an arbitrary point of the geometry. Using coupling variables in this way 
specifies a map from this point onto the entire domain on which the generalized plane 
strain equations hold. COMSOL Multiphysics creates the test functions corresponding 
to e0, e1, and e2 automatically.

Model Library path: RF_Module/
Optics_and_PhotonicsStructural_Mechanics_Module/

Stress-Optical_Effects/stress_optical_generalized

Plane Strain Analysis

Many of the modeling steps are similar to the model “Stress-Optical Effects in a 
Silica-on-Silicon Waveguide” on page 215, but some steps are made in a different 
order, and there are obviously differences when generalizing the plane strain problem.

M U L T I P H Y S I C S  S E T T I N G S

1 In the Model Navigator, select 2D.

2 Select the Structural Mechanics Module>Plane Strain>Static analysis application mode.

3 Click Multiphysics then Add to add this application mode to the model.

4 Next select the RF Module>Perpendicular Waves>Hybrid-Mode Waves> Mode analysis 
application mode. Add this mode to the model.

5 Open the Application Mode Properties dialog box from the Physics menu (Properties) 
and select In-plane components from the Field components list. This selects the 
two-components equation formulation for hybrid-mode waves. It is also possible to 
use the default three-component equation formulation for this problem. See 
“Selecting Equation Formulation” on page 146 in the RF Module User’s Guide for 
general information about the different options.

6 For convenience select Free space wavelength from the Specify wave using list. This 
makes the wavelength available in the Application Scalar Variables dialog box instead 
of the frequency.

The unknown parameters e0, e1, and e2 should be constant within the whole modeling 
domain. You can achieve this by adding a new geometry with only a single point to the 
model and define e0, e1, and e2 as the dependent variables at this point. Later on you 
define coupling variables that map these dependent variables from the point to the 
whole model.
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1 From the Multiphysics menu, select the Model Navigator. Click the Add Geometry 

button to add a 2D geometry (2D is the default space dimension).

2 Select the COMSOL Multiphysics>PDE Modes>Weak Form,Point application mode from 
the application mode tree.

3 Type e0 e1 e2 in the Dependent variables text field.

4 Click Add to add the Weak Form, Point application mode to the second geometry. 
This application mode contains the three degrees of freedom for the parameters e0, 
e1, and e2 that describe the z strain.

5 Set the Ruling application mode to the Perpendicular Hybrid-Mode Waves application 
mode. This makes this application mode specify the interpretation of the parameters 
to the eigenvalue solver given in the Solver Parameters dialog box.

6 Click OK to close the Model Navigator.

The Weak Form, Point application mode becomes the active application mode when 
you close the Model Navigator.

G E O M E T R Y  M O D E L I N G

The three degrees of freedom e0, e1, and e2 must be associated with a point. The 
location of this point is insignificant. This means that the added geometry could 
equally well have been a 1D or a 3D geometry. Using the programming language, 
there is also an option of using a 0D geometry.

Add a point at any position, say at the origin (0, 0).

O P T I O N S  A N D  S E T T I N G S

In the Constants dialog box enter the following names, expressions, and descriptions 
(optional); when done, click OK. They are identical to the constants defined on page 
218. 

NAME EXPRESSION DESCRIPTION

nSi 3.5 Refractive index, silicon (Si)

nBuf 1.445 Refractive index, silica (SiO2)

nClad 1.445 Refractive index, silica

deltan 0.0075 Relative index difference:

nCore nClad/sqrt(1-2*deltan) Refractive index, core

∆
ncore

2 ncladding
2

–( )

2ncore
2

---------------------------------------------=
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G E O M E T R Y  M O D E L I N G

1 Switch to Geom1 by clicking its tab.

2 Draw rectangles corresponding to the different regions.

P H Y S I C S  S E T T I N G S

Point Settings and Boundary Conditions
All regions have free boundaries, which also is the default boundary condition. 
However, these conditions do not suffice in creating a unique solution because the 
computational domain can move and rotate freely; the problem is ill-posed. The 
problem becomes well-posed by adding constraints at points to keep the domain fixed.

1 Select the Plane Strain application mode from the Multiphysics menu.

2 Open the Point Settings dialog box, and select the check boxes for the constraints 
Rx and Ry at point 1, the lower left corner, for both the x and y directions. Doing 
so keeps the domain from moving (translational move).

3 Select the check box for the constraint Ry at point 9, the lower-right corner, for the 
y direction only, keeping the domain from rotating but allowing it to slide in the x 
direction. When done, click OK.

alphaSi 2.5e-6[1/K] Thermal expansion coefficient, silicon

alphaSiO2 0.35e-6[1/K] Thermal expansion coefficient, silica

ESi 110[GPa] Young’s modulus, silicon

ESiO2 78[GPa] Young’s modulus, silica

nuSi 0.19 Poisson’s ratio, silicon

nuSiO2 0.42 Poisson’s ratio, silica

B1 4.2e-12[m^2/N] First stress optical coefficient

B2 0.65e-12[m^2/N] Second stress optical coefficient

T1 20[degC] Operating temperature

T0 1000[degC] Reference temperature

REGION LOWER LEFT CORNER UPPER RIGHT CORNER

Silicon Wafer (-16e-5,-1e-4) (16e-5,-1.7e-5)

Buffer (-16e-5,-1.7e-5) (16e-5,-3e-6)

Cladding (-16e-5,-3e-6) (16e-5,1.3e-5)

Core (-3e-6,-3e-6) (3e-6,3e-6)

NAME EXPRESSION DESCRIPTION
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Subdomain Settings
The air domain need not be part of the plane strain model.

1 Specify the subdomain settings for the Plane Strain application mode according to 
the following table.

Before entering the temperatures on the Load page, you must select the Include 

thermal expansion check box. It is not necessary to specify the density ρ, because it 
does not enter the equation for static problems.

SUBDOMAIN 1 SUBDOMAINS 2–4

Page Material Loads Material Loads

E ESi E ESiO2

ν nuSi Temp T1 ν nuSiO2 Temp T1

α alphaSi Tempref T0 α alphaSiO2 Tempref T0
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E X P R E S S I O N  V A R I A B L E S

In the Subdomain Expressions dialog box in the Options menu, define the following 
variables.

The variables ex, ey, and ez are the strains εx, εy, and εz, and the variables sx, sy, 
and sz are the stresses σx, σy, and σz. The definitions of the refractive index variables 
Nx, Ny, and Nz differ slightly compared to the previous model. In this case they are 
expressed in the generalized stress variables sx, sy, and sz. Because of the use of 
integration coupling variables (e00, e11, and e22), COMSOL Multiphysics cannot 
determine the unit for other variables that directly or indirectly depend on these 

VARIABLE NAME SUBDOMAIN EXPRESSION

E 1

2,3,4

ESi

ESiO2

nu 1

2,3,4

nuSi

nuSiO2

alpha 1

2,3,4

alphaSi

alphaSiO2

ex 1,2,3,4 ux

ey 1,2,3,4 vy

ez 1,2,3,4 e00+e11*x+e22*y

sx 1,2,3,4 sx_smpn+E/((1+nu)*(1-2*nu))*nu*ez

sy 1,2,3,4 sy_smpn+E/((1+nu)*(1-2*nu))*nu*ez

sz 1,2,3,4 E/((1+nu)*(1-2*nu))*(nu*ex+nu*ey+(1-nu)*ez-

(1+nu)*alpha*(T1-T0))

N 1

2

3

4

nSi

nBuf

nClad

nCore

Nx 1

2,3,4

N

N-B1*sx-B2*(sy+sz)

Ny 1

2,3,4

N

N-B1*sy-B2*(sx+sz)

Nz 1

2,3,4

N

N-B1*sz-B2*(sx+sy)
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integration coupling variables. This causes the warnings for inconsistent units here 
and in the specification of the refractive index. You can disregard these warnings.

C O U P L I N G  V A R I A B L E S

The unknown parameters e0, e1, and e2 should be constant within the whole modeling 
domain. You can achieve this by defining coupling variables that map these dependent 
variables from the point to the entire model:

1 Switch to Geom2 by clicking its tab.

2 Open the Point Integration Variables dialog box by selecting Integration Coupling 

Variables>Point Variables from the Options menu.

3 Enter the following names and expressions, each on a separate row in the table on 
the Source tab.

The variables e00, e11, and e22 take the values of e0, e1, and e2, respectively, in the 
entire model.

S U B D O M A I N  S E T T I N G S

Finally, enter the additional terms in the generalized plane strain problem.

1 Switch to Geom1 by clicking its tab.

2 Select Equation System>Subdomain Settings from the Physics menu.

3 On the Weak tab in the Subdomain Settings - Equation System dialog box, add 
-E/((1+nu)*(1-2*nu))*(ex_test*nu*ez+ey_test*nu*ez)-ez_test*sz in 
the second row of the weak term for all subdomains. The two first rows correspond 
to the plane strain problem. You can enter this expression in any of these two fields, 
because the software adds them together when assembling the problem.

M E S H  G E N E R A T I O N

1 Initialize the mesh.

2 Refine it twice.

3 Switch to Geom2 by clicking its tab.

4 Initialize the mesh in this geometry too.

NAME EXPRESSION

e00 e0

e11 e1

e22 e2
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C O M P U T I N G  T H E  S O L U T I O N

1 In the Solver Parameters dialog box select the Stationary solver. When done, click OK.

2 On the Solve for tab in the Solver Manager dialog box, select only the Plane Strain and 
the Weak Form, Point application modes. This excludes the hybrid-mode waves 
application mode from the equations to solve. When done, click OK.

3 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Switch to Geom1 by clicking its tab.

2 Click the Surface tab on the Plot Parameters dialog box. Change the string in the 
Expression edit field on the Surface Data page to abs((ex-ez)/ez)<0.05. Clear the 
Smooth check box. Click OK to visualize the area where the relative difference 
between the x and z strain is within 5%. The model is most accurate in the regions 
close to the core, far from the boundaries on the far left and right.

3 For symmetry reasons the strains εx and εz should be equal. To see how well this 
model has achieved this, make a cross-section plot of them. Open the Cross-Section 

Plot Parameters dialog box. Enter the Title ex and ez by using the Title/Axis dialog 
box on the General page. On the Line/Extrusion tab, set x0 to 0, x1 to 0, y0 to -1e-4, 
and y1 to 1.3e-5 to make a vertical line across the structure. Enter the y-axis data 
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expression ex, and set the Line resolution to 25. Set the x-axis data to y. Click the Line 

Settings button and select Circle as Line marker. Click Apply to plot ex.

4 On the General tab check Keep current plot to be able to plot ez in the same figure 
window.

5 Then change the Expression to ez in y-axis data. Use Plus sign as Line marker for this 
plot. Click OK to make the plot.

6 To view the stress-induced birefringence nx − ny together with the deformation, 
open the Plot Parameters dialog box and select Surface and Deformation plot. On the 
Surface page, enter the Nx-Ny in the Expression edit field on the Surface Data page, 
and select the Smooth check box again. As Deformation data use Displacement (smpn) 
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from the Predefined quantities list on the Subdomain Data page, which is the default 
selected on the Deform tab. Click OK.

Note: Thid model includes an extension of the plane strain PDE system. This means 
that some of the postprocessing variables in the Plane Strain application mode are no 
longer valid and give wrong results if used. We recommend that you use only the 
variables entered in the Subdomain Expressions dialog box for postprocessing.

Optical Mode Analysis

Now continue with the mode analysis in the same way as was done in the previous 
model on page 225.

G E O M E T R Y  M O D E L I N G

You can reduce the computational domain significantly for the optical mode analysis, 
because the energy of the fundamental modes is concentrated in the core region, and 
the energy density decays exponentially in the cladding and buffer regions.

Draw a rectangle with corners at (-1e-5, -1e-5) and (1e-5, 1e-5).
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P H Y S I C S  S E T T I N G S

Next, set up the parameters for the hybrid-mode wave problem. Select the 
Perpendicular Hybrid-Mode Waves application mode in the Multiphysics menu.

Scalar Variables
1 From the Physics menu, choose Scalar Variables.

2 In the Application Scalar Variables dialog box, set the free space wavelength to 
1.55e-6. Click OK.

Subdomain Settings
1 From the Physics menu, choose Subdomain Settings.

2 Deactivate the Perpendicular Hybrid-Mode Waves application mode in all 
subdomains except 4, 5, and 6 (clear the Active in this domain check box for these 
subdomains). This makes sure that the solution for the electromagnetic waves only 
includes the newly drawn rectangle.

3 For all active domains, select n (anisotropic) and set Nx, Ny, and Nz, respectively, as 
anisotropic refractive indices by changing the entries on the diagonal in the 
refractive index matrix. When done, click OK.

E X P R E S S I O N  V A R I A B L E S

Occasionally the associative geometry algorithm does not update all variables and 
settings exactly as expected when modifying the geometry. In this case the expression 
for N might have got the wrong value in domain 6. In the Subdomain Expressions dialog 
box change the value of N in Subdomain 6 to nCore.

M E S H  G E N E R A T I O N

1 On the Subdomain tab in the Free Mesh Parameters dialog box, set the Maximum 

element size to 2e-6 for Subdomains 4 and 5, and to 2.5e-7 for Subdomain 6.

2 Initialize the mesh.

C O M P U T I N G  T H E  S O L U T I O N

1 In the Solver Parameters dialog box, select the Eigenvalue solver.

2 Enter 1.46 in the text field Search for effective mode indices around. The default 
Desired number of effective mode indices is set to 6, which is fine. These settings make 
the eigenmode solver search for the 6 eigenmodes with effective mode indices 
closest to the value 1.46. This value is an estimate of the effective mode index for 
the fundamental mode. For propagating modes it must hold that

neff ncore< 1.456=
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3 In the Solver Manager dialog box, select only the Perpendicular Hybrid-Mode Waves 
application mode on the Solve For page. This ensures that only this application mode 
is part of the eigenmode computation.

4 On the Initial Value page, set the initial value to Current solution. This takes the plane 
strain solution and use it to evaluate the refractive indices for the mode analysis.

5 Click the Solve button.

The following table contains the effective mode indices together with the effective 
mode indices obtained from the analysis in the previous model without the 
generalization of the plane strain equations.

There is a systematic shift in the propagation constants when the strain in the 
z direction is taken into account.

GENERALIZED 
PLANE STRAIN

PLANE STRAIN DIFFERENCE

EFFECTIVE MODE INDEX *1e-3

neff1 1.450403 1.451136 0.73

neff2 1.450115 1.450872 0.76

neff3 1.444671 1.445405 0.73

neff4 1.444398 1.445139 0.74

neff5 1.444383 1.445132 0.75

neff6 1.444109 1.444865 0.76
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S e c ond Ha rmon i c  Gen e r a t i o n  o f  a  
Gau s s i a n  Beam

Introduction

Laser systems are an important application area in modern electronics. There are 
several ways to generate a laser beam, but they all have one thing in common: The 
wavelength is determined by the stimulated emission, which depends on material 
parameters. It is especially difficult to find lasers that generate short wavelengths (for 
example, ultraviolet light). With nonlinear materials it is possible to generate 
harmonics that are an even multiple of the frequency of the laser light. With such 
materials it is straightforward to generate a laser beam with half the wavelength of the 
original beam. This model shows how to set up a second harmonic generation as a 
transient wave simulation using nonlinear material properties. A YAG (λ=1.06 µm) 
laser beam is focused on a nonlinear crystal, so that the waist of the beam is inside the 
crystal.

Model Definition

When a laser beam propagates it travels as an approximate plane wave with a 
cross-section intensity of Gaussian shape. The waist of the beam is defined as the 
Gaussian function’s characteristic length. A focused laser beam has a minimum waist, 
w0, at a certain point along the direction of propagation. The solution of the 
time-dependent Maxwell’s equations gives the following electric field (x-component):

,

where

.
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In these expressions, w0 is the minimum waist, ω is the angular frequency, r is the radial 
cylindrical coordinate, and k is the wave number. The wave fronts of the beam is not 
exactly planar, it propagates like a spherical wave with radius R(z). Close to the point 
of the minimum waist the wave is almost plane. These expressions are used to excite a 
plane wave at one end of a cylinder.

In this example the problem is solved as a 2D cross section that resembles the axial 
symmetry of the problem. However, due to the x-polarization of the E-field, true axial 
symmetry cannot be used (available as an application mode in COMSOL 
Multiphysics). Here the direction is approximates with a standard 2D cross section, 
neglecting the revolution around the z-axis. So this actually models an infinitely long 
Gaussian beam plane. The second harmonics generation is probably not affected 
significantly by this approximation. In the model “Propagation of a 3D Gaussian Beam 
Laser Pulse” on page 261, propagation of a true 3D Gaussian beam is calculated 
without any nonlinear effects.

The nonlinear properties for 2nd harmonic generation in a material can be defined with 
the following matrix,

,

where P is the polarization. The model only uses the d11 parameter for simplicity. To 
keep the problem size small the nonlinear parameter is magnified by some orders of 
magnitude. The crystal here has a value of 10−17 F/V, when the values for most 

w0
z

ϕ

P

d11 d12 d13 d14 d15 d16

d21 d22 d23 d24 d25 d26

d31 d32 d33 d34 d35 d36

Ex
2

Ey
2

Ez
2

2EzEy

2EzEx

2ExEy

⋅=
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materials usually are in the 10−22 F/V range. Without this magnification, a detectable 
2nd harmonics requires the z direction of the geometry to be much longer, resulting 
in a large problem.

The Gaussian beam is also excited as a pulse in time, using a Gaussian envelope 
function. This produces a wave package with a Gaussian frequency spectrum. The 
frequency spectrum from a series of time samples can be calculated using the fast 
Fourier transform (FFT), which you can do from the COMSOL Script command line 
using the function fft.

Results and Discussion

The main purpose of this simulation is to calculate the second harmonic generation 
when the pulse travels along the 20 µm geometry. So you have to solve for the time it 
takes for the pulse to enter, pass, and disappear from the volume. The pulse has a 
characteristic time of 10 fs, and below you can see the pulse after it has traveled 61 fs.

Figure 4-11: The pulse after 61 fs.
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After 90 fs the pulse has reached the output boundary (see Figure 4-12). The 
simulation has to continue for another 30 fs so the pulse completely disappears.

Figure 4-12: The pulse after 90 fs. It has now reached the output boundary.

The simulation stores the times between 60 fs and 120 fs, which is when the pulse 
passes the output boundary. The electric field at this boundary has a second harmonic 
component that is extracted using FFT. The extraction and transformation is 
performed at the COMSOL Script command line. The result appears in Figure 4-13 
on page 253. There are two groups of peaks in the figure, where the peaks on the right 
are mirrors of the ones to the left. This mirror effect is due to the sampling of the 
harmonic signals, which always creates a mirror spectrum around the sampling 
frequency.
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Figure 4-13: The result from the FFT on the beam at the output boundary. The two small 
peaks between the large peaks are the second harmonic generation.

Reference

1. A. Yariv, Quantum Electronics, 3rd Edition, John Wiley & Sons, 1988.

Model Library path: RF_Module/Optics_and_Photonics/
second_harmonic_generation

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 In the Model Navigator, select 2D in the Space dimension list.

2 Click the Multiphysics button, and then Click the Add Geometry button.
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3 In the Add Geometry dialog box, type z r phi in the Independent variables edit field. 
Click OK.

4 Select the RF Module>In-Plane Waves>TE Waves>Transient propagation application 
mode.

5 Type Aphi in the Dependent variables edit field, and click Add.

6 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, choose Constants.

2 In the Constants dialog box, define the following constants with names, expressions, 
and descriptions (optional):

3 Click OK.

G E O M E T R Y  M O D E L I N G

All the dialog boxes for specifying the primitive objects are accessed from the Draw 
menu and Specify Objects. The first column in the table below contains the labels of the 
geometric objects. These are automatically generated by COMSOL Multiphysics, and 
you do not have to enter them. Just check that you get the correct label for the objects 
that you create.

1 Draw a rectangle with the properties according to the table below.

2 Click the Zoom Extents toolbar button.

NAME EXPRESSION DESCRIPTION

w0 2[um] Minimum waist of laser beam

lambda0 1.06[um] Wavelength of laser beam

E0 3e4[V/m] Peak electric field

z0 pi*w0^2/lambda0 Peak electric field z position

k0 2*pi/lambda0 Wave number

t0 25[fs] Pulse time delay

dt 10[fs] Pulse width

d11 1e-17[F/V] Matrix element for 2nd generation

LABEL WIDTH HEIGHT BASE CORNER

R1 20e-6 6e-6 Corner (-1e-5,-6e-6)
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P H Y S I C S  S E T T I N G S

1 From the Options menu, choose Expressions>Scalar Expressions.

2 In the Scalar Expressions dialog box, define the following variables with names, 
expressions, and descriptions (optional):

3 Click OK.

4 From the Options menu, choose Expressions>Boundary Expressions.

5 In the Boundary Expressions dialog box, define the following variables with names 
and expressions:

Because of the use of an integration coupling variable (w_bnd), COMSOL 
Multiphysics cannot determine the unit for E_bnd and warns for an inconsistent unit 
here and in the specification of the scattering boundary condition. You can disregard 
these warnings.

6 Click OK.

7 From the Options menu, point to Integration Coupling Variable and then click Point 

Variables.

8 In the Point Integration Variables dialog box, define the following variables with 
names and expressions. Use Global destination for all variables.

NAME VALUE DESCRIPTION UNIT

w w0*sqrt(1+(z/z0)^2) Analytical waist function along z m

eta atan(z/z0) Analytical angle along z m

R z*(1+(z0/z)^2) Analytical radius along z m

c0 1/sqrt(epsilon0_rfwe*mu0_rfwe) Speed of light m/s

omega0 2*pi*c0/lambda0 Angular frequency rad/s

SETTINGS BOUNDARY 1 BOUNDARY 2 BOUNDARY 3

E_bnd w0/w*exp(-r^2/w_bnd^2)* 
cos(omega0*t-k0*z+eta_bnd- 
r^2*k0/(2*R_bnd))

E_pulse exp(-(t-t0)^2/dt^2)

E_lim E0*1.2 -E0*1.2

NAME POINT 2 ALL OTHERS

w_bnd w

eta_bnd eta

R_bnd R
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Boundary Conditions
1 From the Physics menu, open the Boundary Settings dialog box and enter the settings 

according the following two tables (leave all fields not specified at their default 
values):

2 Click OK.

Subdomain Settings
1 From the Physics menu, open the Subdomain Settings dialog box, select Subdomain 

1, and click the D=ε0εrE+Dr button for the constitutive relation.

2 Define the subdomain settings according to the following table:

3 Click OK.

SETTINGS BOUNDARY 1 BOUNDARY 4

Boundary condition Scattering boundary Scattering boundary

E0*E_pulse*E_bnd 0

SETTINGS BOUNDARY 2 BOUNDARY 3

Boundary condition Perfect electric conductor Perfect magnetic conductor

SETTINGS SUBDOMAIN 1

εr 1

Dr d11*Ephi_rfwe^2

E0 ϕ,
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M E S H  G E N E R A T I O N

1 From the Mesh menu, choose Mapped Mesh Parameters.

2 Click on the Boundary tab, and select Boundary 1.

3 Select the Constrained edge element distribution check box.

4 Click the Edge vertex distribution button. In the edit field below, type 
sin(linspace(0,pi/2,21)). This creates a denser mesh closer to the upper 
boundary.
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5 Select Boundary 4 and do the same operations there.

6 Select Boundary 2, click the Edge vertex distribution button, and type 
0:5e-8:20e-6 in the edit field.

7 Click the Remesh button and then click OK.

P R O B E  P L O T  F O R  F F T  A N A L Y S I S

The amount of time steps that has to be saved for the FFT analysis is very large, and to 
store all solutions of the A-field results in a huge model file. For the FFT, it is only 
interesting to look at the field at the output boundary. If you make a probe plot of this 
quantity, the resulting plot contains all steps taken by the solver. You can later use the 
data points stored in the figure window to make the FFT analysis. As a result, you can 
reduce the number of output times to include only those values intended for field 
plots.

1 From the Postprocessing menu, choose Probe Plot Parameters.

2 In the Probe Plot Parameters dialog box, click the New button.

3 In the dialog box that appears, choose Point probe from the Plot type list, and enter 
Eout in the Plot name edit field. Click OK.

4 Select boundary 4, and choose Electric field, phi component from the Predefined 

quantities list.
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5 Click the New button again and repeat the steps above to define a point probe plot 
named Ein for boundary 2.

6 Select the Plot all plots in the same axis check box. Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 From the Solve menu, choose Solver Parameters.

2 In the Times edit field type 0 6.1e-14 9e-14 1.2e-13.

3 Click on the Time Stepping tab, and select the Manual tuning of step size check box. 
Enter 1e-16 in the Initial time step and Maximum time step edit fields.

4 Click OK.

5 Click the Solve toolbar button.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Select Plot Parameters from the Postprocessing menu.

2 Make sure that the Surface, Boundary, and Geometry edges check boxes are selected 
under the General tab.

3 Select time 6.1e-14 from the Solution at time list.

4 Click the Surface tab, and enter Ephi_rfwe in the Expression edit field.

5 Click the Height Data tab, select the Height data check box, and enter Ephi_rfwe in 
the Expression edit field.

6 Click the Boundary tab, type E_lim in the Expression edit field.

7 Click the Height Data tab, select the Height data check box, and enter E_lim in the 
Expression edit field.

8 Click the Uniform color option button.

9 Click the Color button and select white from the palette in the dialog box that 
appears. Click OK to close the dialog box.

10 Click Apply to get the plot in Figure 4-11.

11 Click on the General tab, and select time 9e-14. Click OK. You should now see the 
plot in Figure 4-12.

F F T  A N A L Y S I S  U S I N G  C O M S O L  S C R I P T

To get the Fourier transform of the output, run some commands in COMSOL Script 
(or MATLAB):

1 From the File menu, choose COMSOL Script. The COMSOL Script window opens 
automatically.
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2 In the COMSOL Script window, enter the following commands:

c = get(gca,'children');
xdata = get(c(1),'xdata');
ydata = get(c(1),'ydata');
ydata = ydata(diff([xdata inf])>0);
xdata = xdata(diff([xdata inf])>0);

These statements first fetch the output field data from the current figure. This data 
contains a lot of duplicate points that you remove with the last two statements.

3 Now you can continue to preform the FFT analysis on a selected time interval of the 
output field.

T = xdata(601:end);
Eout = ydata(601:end);
freq = ((1:length(T))-1)/(length(T)*mean(diff(T)));
xEout = fft(Eout);
plot(freq,abs(xEout));

This produces the plot in Figure 4-13 on page 253.
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P ropag a t i o n  o f  a  3D Gau s s i a n  Beam 
La s e r  Pu l s e

Introduction

This is a 3D version of the model “Second Harmonic Generation of a Gaussian Beam” 
on page 249. The differences are that the nonlinear material parameters have been 
removed, the geometry is smaller, and the laser pulse is shorter. This is necessary to 
reduce the execution time and the model file size shipped with the product.

Model Definition

All the details about Gaussian laser beams are covered in the model “Second Harmonic 
Generation of a Gaussian Beam” on page 249. This model uses the same YAG laser 
pulse, but with a characteristic time of 40 fs. Because the Gaussian pulse has spherical 
wave fronts when it approaches and leaves the minimum waist, the input and output 
boundaries are made spherical.

The model also use the symmetry of the cylindrical shape so that it is only necessary to 
simulate one quarter of the full volume. The perfect electric and perfect magnetic 
boundary conditions are used as symmetry conditions one these boundaries. It is not 
straightforward to use axial symmetry, because the polarization of the beam is in the 
x direction.
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Results and Discussion

Notice the spherical fronts in the following figures. These figures show the pulse that 
propagates at two different times: at the entry and just after passing the minimum 
waist.

Figure 4-14: The pulse entering the domain at t=10 fs. The spot size is shown on the input 
boundary to the left.
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Figure 4-15: After 20 fs the pulse has passed the minimum waist and soon reaches the 
output boundary.

Model Library path: RF_Module/Optics_and_Photonics/gaussian_beam_3d

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 In the Model Navigator, select 3D in the Space dimension list.

2 Select the RF Module>Electromagnetic Waves>Transient propagation application 
mode. Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, choose Constants.
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2 In the Constants dialog box, define the following constants with names, expressions, 
and descriptions (optional):

3 Click OK.

G E O M E T R Y  M O D E L I N G

All the dialog boxes for specifying the primitive objects are accessed from the Draw 
menu and Specify Objects. The first column in the tables below contains the labels of 
the geometric objects. These are automatically generated by COMSOL Multiphysics, 
and you do not have to enter them. Just check that you get the correct label for the 
objects that you create.

Begin by drawing the cross section of the simulation domain followed by an extrusion 
to 3D. The input and output boundaries are then adjusted so they get a slight spherical 
shape, consistent with the spherical wave fronts of the Gaussian pulse.

1 From the Draw menu, select Work-Plane Settings.

2 In the Work-Plane Settings dialog box, select the x-y plane and enter -2e-6 in the z 
edit field. Click OK.

Draw a circle with the properties according to the table below.

3 Draw rectangles with the properties according to the following table.

4 Click the Zoom Extents toolbar button.

NAME EXPRESSION DESCRIPTION

w0 2[um] Minimum waist of laser beam 

lambda0 1.06[um] Wavelength of laser beam

E0 30[kV/m] Peak electric field

z0 pi*w0^2/lambda0 Peak electric field z position

k0 2*pi/lambda0 Wave number

t0 10[fs] Pulse time delay

dt 40[fs] Pulse width

NAME RADIUS BASE (X, Y)

C1 6e-6 Center (0,0)

NAME WIDTH HEIGHT BASE CORNER

R1 6e-6 1.2e-5 Corner (-6e-6,-6e-6)

R2 6e-6 6e-6 Corner (0,-6e-6)
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5 Select all the rectangles, R1 and R2, and click the Union toolbar button.

6 Click the Delete Interior Boundaries toolbar button.

7 Select all objects by pressing Ctrl+A, and click the Create Composite Object toolbar 
button.

8 In the dialog box that appears, enter C1-CO1 in the Set formula edit field. Click OK.

9 Select Extrude from the Draw menu.

10 In the Extrude dialog box, enter 4e-6 in the Distance edit field, and click OK.

11 It is desired to have the spherical wave fronts of the beam coincide with the input 
and output boundaries. Do this with two spheres with a radius from the value of the 
R expression evaluated at one of the boundaries. Specify the two spheres using the 
following properties:

12 Select all objects by pressing Ctrl+A, and click the Intersection toolbar button.

13 Click the Headlight toolbar button. You should now see the geometry shown in the 
figure below.

NAME RADIUS BASE CORNER

SPH1 7.22713e-5 Center (7.22713e-5-2e-6,0)

SPH2 7.22713e-5 Center (-7.22713e-5+2e-6,0)
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P H Y S I C S  S E T T I N G S

1 Go to geometry Geom1 by clicking the Geom1 tab.

2 From the Options menu, choose Expressions>Scalar Expressions.

3 In the Scalar Expressions dialog box, define the following variables with names, 
expressions, and descriptions (optional):

4 Click OK.

5 From the Options menu, choose Expressions>Boundary Expressions.

6 In the Boundary Expressions dialog box, define the following variables with names 
and expressions:

Because of the use of an integration coupling variable (w_bnd), COMSOL 
Multiphysics cannot determine the unit for E_bnd and warns for an inconsistent unit 
here and in the specification of the scattering boundary condition. You can disregard 
these warnings.

7 Click OK.

8 From the Options menu, select Integration Coupling Variable>Point Variables.

9 In the Point Integration Variables dialog box, define the following variables with 
names and expressions. Use Global destination for all variables.

NAME VALUE DESCRIPTION

w w0*sqrt(1+(z/z0)^2) Analytical waist function along z

eta atan(z/z0) Analytical angle along z

R z*(1+(z0/z)^2) Analytical radius along z

r sqrt(x^2+y^2) Radial coordinate

c0 1/sqrt(epsilon0_rfw*mu0_rfw) Speed of light

omega0 2*pi*c0/lambda0 Angular frequency

SETTING BOUNDARY 3 ALL OTHER

E_bnd w0/w*exp(-r^2/w_bnd^2)* 
cos(omega0*t-k0*z+eta_bnd-r^2*k0/(2*R_bnd))

E_pulse exp(-(t-t0)^2/dt^2)

NAME POINT 1 ALL OTHERS

w_bnd w

eta_bnd eta

R_bnd R
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Boundary Conditions
1 From the Physics menu, open the Boundary Settings dialog box and enter the settings 

according the following two tables (leave all fields not specified at their default 
values):

2 Click OK.

Subdomain Settings
Use the default values for the subdomain settings.

M E S H  G E N E R A T I O N

1 From the Mesh menu, choose Free Mesh Parameters.

2 Click the Custom mesh size button and enter 1e-7 in the Maximum element size edit 
field.

3 Click the Advanced tab.

4 Enter 0.12 in the x-direction scale factor and y-direction scale factor edit fields. This 
keeps the small mesh size in the z direction but stretches the elements in the x and 
y directions.

5 Click the Remesh button, then click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 From the Solve menu, choose Solver Parameters.

2 In the Times edit field type 0:1e-14:3e-14.

3 Select the GMRES from the Linear system solver list.

4 Select Algebraic multigrid from the Preconditioner list.

5 Make sure that the Symmetric option is selected from the Matrix symmetry list.

6 Click the Time Stepping tab and select the Manual tuning of step size check box. Enter 
1e-16 in the Initial time step and Maximum time step edit fields.

SETTINGS BOUNDARY 3 BOUNDARY 4

Boundary condition Scattering boundary Scattering boundary

E0,x E0*E_pulse*E_bnd 0

E0,y 0 0

E0,z 0 0

SETTING BOUNDARY 2 BOUNDARIES 1, 5

Boundary condition Perfect magnetic conductor Perfect electric conductor
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7 Click OK.

8 From the Solve menu, choose Solver Manager. Click the Output tab and select the 
Include time derivatives check box. This ensures that the time derivatives of the 
A-field, which is the E-field, is calculated more accurately.

9 Click OK.

10 Click the Solve button on the Main toolbar.

The solving process takes some time because this is a large problem that takes about 
300 time steps.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Plot the x-component of the E-field on the boundaries. Some boundaries are 
suppressed so it is possible to get a view into the simulation volume.

1 Select Plot Parameters from the Postprocessing menu.

2 Make sure that the Boundary and Geometry edges check boxes are selected under the 
General tab.

3 Click the Boundary tab and enter Ex in the Expression edit field.
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4 Click OK.

5 From the Options menu, select Suppress>Suppress Boundaries. In the Suppress 

Boundaries dialog box, select boundaries 4 and 5. Click OK.

6 Compare the results at times 1e-14 and 2e-14 to see how the pulse propagates. 
These results are plotted in Figure 4-14 on page 262 and in Figure 4-15 on page 
263.
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3D electromagnetic waves model 85, 124

3D waveguide 85

A absorbing layers 174

anisotropic permeability 34

antenna impedance 46, 54

antennas 136

conical 45

magnetic dipole 57

RF 45

application mode

Axisymmetric TE waves 58

Axisymmetric TM waves 49

Bioheat equation 105

Boundary mode analysis 91

Electromagnetic waves 91

In-plane TE waves 177, 185, 198

Perpendicular Hybrid-Mode Waves 

216

Perpendicular hybrid-mode waves 211

Plane Strain 216

TM waves 105

axisymmetric TE waves model 57

axisymmetric TM waves model 45

azimuthal magnetic field 46

B balanced antennas 136

bandgap analysis 192

bioheat equation model 98

birefringence 215

stress-induced 224

boundary mode analysis 91

boundary mode analysis model 85, 124

C capacitive coupling 67

cavity resonances 81

characteristic impedance 54

circulator 32

cladding 208

coaxial cable, feeding a waveguide 157

COMSOL Script 77

confined mode 208

conical antennas 45

convergence analysis 227

coupling variable

scalar 54

cross-section plot 155

cutoff frequency 86, 125, 184, 188

D dipole, magnetic 57

drift, in eigenfrequency 64

E effective mode index 209

eigenfrequency drift 64

electromagnetic wave model 3D 85, 124

errors in modeling 230

expansion coefficient 232

F far-field

computation 56

radiation patterns 49

ferrite circulator 32

FFT 251, 258

fiber

optical 208

silica glass 208

single-mode 208

Floquet periodicity boundary conditions 

193

frequency

normalized 209

G Gaussian beam 249, 261

generalized plane strain 232

gyromagnetic ratio 34

H H bend 32, 80
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harmonic generation 250

I impedance

of antenna 46, 54

impedance, of microstrip line 20

in-plane TE waves model 32, 80, 174, 182

intensity, optical 227

L Larmor frequency 34

lobe pattern 141

low-reflecting boundary conditions 138

M magnetic dipole 57

magnetic frill 14

matched boundary conditions 46, 81

matched port boundary conditions 35

microprism 174

microstrip line, impedance of 20

microwave circulator 32

microwave filters 64

microwave waveguide 85

mode analysis 225

model

stress-optical effects 215

stress-optical effects, generalized 232

modeling errors 230

models, overview of 2

monoconical antennas 45

moving mesh 65

N Navier’s equation 234

weak form 234

near-field radiation patterns 47

normalized frequency 209

O optical fiber 208

optical intensity 227

optical waveguide 174, 208

optics 208

optimum radiation frequency 139

optoelectronics 208

P parametric solver 55

patch antennas 136

perfect electric conductors 138

perfectly matched layers 138, 174

Perpendicular Hybrid-Mode Waves 216

perpendicular hybrid-mode waves model 

208

perturbation

of material parameters 231

photonic bandgap 182, 192

photonic crystal 192

photonic microprism 174

photonic waveguide 215

Plane Strain 232

application mode 216

generalized 232

plane strain, generalized 232

PML constant 138

PML layer 138

PMLs. see perfectly matched layers

Point Settings dialog box 220, 240

Port boundary condition 157

power flow 227

Poynting vector 227

Q quarter-wave resonance 66

R radiation patterns 54, 140

far-field 49

near-field 47

reactance 55

rectangular waveguides 157

refractive index 174, 208

resistance 55

resonance 66, 81

S SAR 110

scattering boundary conditions 46

scattering parameter 33, 54, 80

sea bed logging 164



second harmonic generation 250

sensitivity analysis 231

silica glass fiber 208

single-mode fiber 208

single-mode range 85

solver

parametric 55

S-parameter 33, 54, 80, 85

S-parameters 163

specific absorption rate 110

Specific absorption rate (SAR) 98

spherical waves 46

stress-induced birefringence 224

stress-optical effect 215

stress-optical effects 215

stress-optical effects, generalized 232

stress-optical tensor 215

symmetry boundary conditions 46

T thermal expansion 64

TM waves model 98

Touchstone file, exporting to 44

transverse electric waves 81, 86, 125

transverse electromagnetic fields 46

typographical conventions 5

W waveguide

3D 85

H bend 32, 80

microwave 85

optical 174, 208

photonic 215

weak form 234

Y YAG laser 249, 261
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