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 1
I n t r o d u c t i o n
The COMSOL Reaction Engineering Lab® is a tool that uses reaction formulas 
to create models of reacting systems. In this context, a model means the material, 
energy, and momentum balances for a system. The Reaction Engineering Lab not 
only defines these balances, it can also solve the material and energy balances for 
space-independent models, that is, for models where the composition and 
temperature in the reacting system vary only in time. For space-dependent models, 
the Reaction Engineering Lab offers a direct coupling to the Chemical Engineering 
Module, the MEMS Module, and the Earth Science Module. This direct link 
enables you to create models involving material, energy, and momentum balances 
in COMSOL Multiphysics® directly from a set of reaction formulas.

Included in these models are the kinetic expressions for the reacting system, which 
are automatically or manually defined in the Reaction Engineering Lab. You also 
have access to a variety of ready-made expressions in order to calculate a system’s 
thermodynamic and transport properties.

In addition to the formulation and solution of models from reaction formulas, the 
Reaction Engineering Lab also lets you perform parameter estimation calculations. 
Using this feature you can readily extract kinetic parameters from experimental 
data. Furthermore, in combination with COMSOL Script, the Reaction 
Engineering Lab can implement parametric studies and custom post processing.
 1



2 |  C H A P T E R  
We are convinced that the combination of  the COMSOL Reaction Engineering Lab, 
COMSOL Script, and the COMSOL Multiphysics represents the most advanced 
software for the modeling of reacting systems. Regardless of the system—whether a 
biological system or a CVD reactor in the semiconductor industry—this suite of 
products gives you unparalleled power in formulating and solving models.
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• Interpretation of reaction formulas entered in the graphical user interface to create 
the reaction kinetic expressions for a reacting system.

• Formulation of a species list based on entered reaction formulas.

• Formulation and solution of material and energy balances for as set of predefined 
reactor types; the Batch reactor, the Semibatch reactor, the Continuous stirred tank 
reactor (CSTR), and the Plug-flow reactor.

• Compilation of thermodynamic and transport properties based on a minimum set 
of input data.

• Parameter estimation calculations, directly integrated into the graphical user 
interface.

• Export of simulation data to COMSOL Script for further postprocessing and 
evaluation.

• Automatic detection of steady state when simulating material and energy balances.

• Export of Reaction Engineering Lab models to COMSOL Multiphysics’ Chemical 
Engineering Module, MEMS Module, and Earth Science Module.

• Import of CHEMKIN® files to simulate complex chemical reactions in the gas 
phase.

• Model Library with 34 entries from various fields that involve chemical reactions.

Typographical Conventions

All COMSOL manuals use a set of consistent typographical conventions that should 
make it easy for you to follow the discussion, realize what you can expect to see on the 
screen, and know which data you must enter into various data-entry fields. In 
particular, you should be aware of these conventions:

• A boldface font of the shown size and style indicates that the given word(s) appear 
exactly that way on the COMSOL graphical user interface (for toolbar buttons in 
the corresponding tooltip). For instance, we often refer to the Model Navigator, 
which is the window that appears when you start a new modeling session in 
COMSOL; the corresponding window on the screen has the title Model Navigator. 
As another example, the instructions might say to click the Multiphysics button, and 
the boldface font indicates that you can expect to see a button with that exact label 
on the COMSOL user interface.
K E Y  F E A T U R E S  I N  VE R S I O N  1 . 4  |  3
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• The names of other items on the graphical user interface that do not have direct 
labels contain a leading uppercase letter. For instance, we often refer to the Draw 
toolbar; this vertical bar containing many icons appears on the left side of the user 
interface during geometry modeling. However, nowhere on the screen will you see 
the term “Draw” referring to this toolbar (if it were on the screen, we would print 
it in this manual as the Draw menu).

• The symbol > indicates a menu item or an item in a folder in the Model Navigator. 
For example, Physics>Equation System>Subdomain Settings is equivalent to: On the 
Physics menu, point to Equation System and then click Subdomain Settings. 
COMSOL Multiphysics>Heat Transfer>Conduction means: Open the COMSOL 

Multiphysics folder, open the Heat Transfer folder, and select Conduction.

• A Code (monospace) font indicates keyboard entries in the user interface. You might 
see an instruction such as “Type 1.25 in the Current density edit field.” The 
monospace font also indicates COMSOL Script codes.

• An italic font indicates the introduction of important terminology. Expect to find 
an explanation in the same paragraph or in the Glossary. The names of books in the 
COMSOL documentation set also appear using an italic font.
1 :  I N T R O D U C T I O N



 2
M o d e l i n g  S t r a t e g y
 5



6 |  C H A P T E R  
Mode l i n g  S t r a t e g y

This section describes three primary approaches for using the COMSOL Reaction 
Engineering Lab in the analysis of a reacting system:

• Reaction Kinetic Modeling—During this stage you assume a set of possible 
variations around a reaction mechanism and then enter them into the Reaction 
Engineering Lab. You model the mechanism assuming highly controlled conditions 
in order to compare the simulation to experimental data. These conditions describe 
the model using one independent variable—generally either time (t) or one space 
variable (x). You can then perform virtual experiments in the Reaction Engineering 
Lab to study the influence of various assumptions and conditions on the outcome 
of the set of reactions. This stage usually involves model calibration, where you tune 
the model parameters to experimental data. You can find a wide range of 
functionality for parameter estimation and model calibration in COMSOL Script, 
which is linked to the Reaction Engineering Lab.

• Process Modeling—Here you implement a known or postulated mechanism for a 
reacting system, defining and modeling it in the Reaction Engineering Lab. You can 
then design and scale a process, or study the influence of various operating 
conditions on the process—always assuming that variations in composition and 
temperature are present only as functions of one independent variable (again, either 
time or one space variable). Such a process can be any one that involves a reacting 
system, from the modeling of drug delivery in living tissue to the removal of 
chlorine in a scrubber tower.

• Detailed Process Modeling—During this stage you implement a known mechanism 
for a reacting system, but here the operating conditions allow for variations in 
composition and temperature in more than one independent variable, that is, in 
time and space, or in several space variables (x, y, z). It is therefore interesting to 
study the influence of these variations on the system’s design, for example, different 
ways to perform mixing in a reactor or the influence of diffusion and convection in 
drug delivery. In this scenario, you can first set up the system in the Reaction 
Engineering Lab, which then calculates both the kinetics and the transport 
properties under ideal conditions. Once the system is properly described under ideal 
conditions, export your model to the Chemical Engineering Module, MEMS 
Module, or Earth Science Module of COMSOL Multiphysics, where it is possible 
to resolve the process given variations in geometry and time.
2 :  M O D E L I N G  S T R A T E G Y



The modeling strategy in the Reaction Engineering Lab depends on the issues you 
want to address, as outlined in the three points above. The following discussion 
provides an introduction to the basic modeling strategy. Later on, this chapter includes 
a few examples that show the application of the suggested modeling strategies. The 
three implementation strategies discussed in the following paragraphs correspond to 
the three approaches just discussed.

• The first and most straightforward modeling scenario deals with perfectly mixed 
isothermal systems, that is, those with constant temperature in space and time. Here 
there is no need to compute transport and thermodynamic properties. Under these 
conditions, the Reaction Engineering Lab does not need information about the 
system’s phase because it treats the system identically for gases and liquids. These 
conditions are typical for kinetic studies. In such cases, it is desirable to keep 
temperature strictly controlled, and you can apply mixing to avoid compositional 
variations, which slow down the interpretation of the experiments.

• In the second scenario, the reacting system is perfectly mixed, but the temperature 
is not constant over time. Here the Reaction Engineering Lab needs information 
about the fluid properties. Therefore, the first step in the modeling process is to 
determine the type of fluid in the reacting system. The second step is to check 
whether the expressions for energy transport and thermodynamic properties in the 
Reaction Engineering Lab are appropriate for the system being modeled. For 
example, the Reaction Engineering Lab contains relevant and accurate functions for 
properties of gases at low or moderate pressures, and it also provides data for 
reacting systems that use water as a solvent.

• The third scenario involves the modeling of reacting systems that have substantial 
variations in composition or temperature as a function of position in the system—
an analysis that requires the calculation of energy-transport and material-transport 
properties. If the variations take place in one space variable at steady state, it might 
be possible to use the time variable to model the space coordinate. In that case, you 
can set up and solve the model within the Reaction Engineering Lab. In all other 
cases, first set up the model and evaluate all transport and thermodynamic properties 
in the Reaction Engineering Lab; then, after investigating the model’s behavior for 
perfectly mixed conditions, export it to a more extensive model—one that includes 
the system’s geometrical description—for analysis in COMSOL Multiphysics. With 
this combination of products, the Reaction Engineering Lab can automatically set 
up the domain equations and the properties of the reacting system in the Chemical 
Engineering Module, MEMS Module, or Earth Science Module.’
M O D E L I N G  S T R A T E G Y  |  7
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Figure 2-1 provides an overview of the modeling strategy. Without going into great 
detail, it nonetheless explains the main steps required in setting up a model in the 
Reaction Engineering Lab.

Figure 2-1: Diagram of the strategy for modeling reacting systems in the Reaction 
Engineering Lab.

The following examples provide details about the implementation of the steps in this 
figure.
2 :  M O D E L I N G  S T R A T E G Y



Perfectly Mixed Reacting Systems: Constant Temperature in Time 
and Space

For a perfectly mixed reactor with a predefined constant temperature, you do not need 
the reacting system’s energy balance in order to describe the system behavior. The 
behavior is defined as the composition and the production or consumption of species 
over time. Furthermore, because the reactor is perfectly mixed, the Reaction 
Engineering Lab can also set up a model even though it has no information about 
material-transport or energy-transport properties. In this example you make use of 
Reaction Engineering Labs default reactor type, namely a Batch reactor with constant 
volume. Other predefined reactor types available are the Semibatch reactor, the 
Continuous stirred tank reactor (CSTR), and the Plug-flow reactor.

Consider a classical example from the literature on reaction kinetics involving the 
hydrogen-iodine reaction (Ref. 1). Assume that the bimolecular reaction properly 
describes the kinetics through the relationship

In a second step, you could also treat the mechanism as suggested by Sullivan (Ref. 1), 
which involves the equilibrium of the iodine molecule with elementary iodine where 
both can react with hydrogen to form HI.

For this exercise, simulate an experiment where an equimolar mixture of hydrogen and 
iodine gas is allowed to react and form HI. The reaction runs under isothermal 
conditions, and the temperature is kept at 700 K throughout. The experiment takes 
place in a perfectly mixed batch reactor.

The purpose of the experiment is to study the composition in the reactor over time and 
determine how long it takes the system to reach steady state, where it is possible to 
determine the reaction’s equilibrium constant.

Under these conditions, the modeling procedure in the Reaction Engineering Lab is:

1 Start the Reaction Engineering Lab.

2 Set the system temperature.

3 Set a new reaction and enter the expression for the reaction as just given.

4 Set the initial concentrations of H2, I2, and HI.

5 Set the time interval for the reactor simulation.

6 Compute the solution.

H2 g( ) I2 g( )+ 2HI g( )=
M O D E L I N G  S T R A T E G Y  |  9
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7 Plot the solution.

The input data consists of the following:

• Frequency factor for the forward reaction Af = 8.87·107 m3/(mol·s).

• Frequency factor for the reverse reaction Ar = 3.00·107 m3/(mol·s).

• Activation energy for the forward reaction Ef = 167·103 J/mol.

• Activation energy for the reverse reaction Er = 184·103 J/mol.

• Initial concentration for both H2 and I2 = 8.71 mol/m3.

• System temperature = 700 K.

Model Library path: Education/isothermal_hi_reactor

The following instructions show the detailed implementation of the model as just 
sketched.

M O D E L I N G  I N  T H E  R E A C T I O N  E N G I N E E R I N G  L A B

Defining the Reactions
1 Double-click the Reaction Engineering Lab icon on the desktop to open the Model 

Navigator.

2 Click the New button. The main user interface window should now be active.

3 Go to the Model menu and select Model Settings. In the Temperature edit field, type 
700. Click Close.

4 From the Model menu, select Reaction settings. Click the New button.

5 Find the Formula edit field and type H2+I2<=>2HI. Press the Enter key.
 2 :  M O D E L I N G  S T R A T E G Y



6 Select the Use Arrhenius expressions check box. The Reaction settings dialog box 
should now look like this:

Note that the delimiter <=> defines a reversible reaction. In contrast, the delimiter 
for an irreversible reaction is either => or <=, and an equilibrium reaction is 
specified with the = symbol. Note also that the Reaction Engineering Lab 
automatically sets the reaction rate expression using the mass action law and puts the 
result in the corresponding Reaction rate edit field.

7 Go to the Arrhenius parameters area. Find the column for the forward reaction. Go 
to the A edit field for the Frequency factor and type 8.87e7, then in the E edit field 
for the Activation energy type 167e3.

8 Find the column for the reverse reaction. Go to the A edit field for the Frequency 

factor and type 3.00e7, then in the E edit field for the Activation energy type 184e3.

The Species Selection List
1 Click the Species tab to examine the Species selection list and the corresponding 

material balances for each species.The Reaction Engineering Lab creates the Species 

selection list automatically as you type in the reaction.
M O D E L I N G  S T R A T E G Y  |  11
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2 Click on species H2 in the Species selection list. The user interface should look like 
this:

3 Locate the c0 edit field for the initial concentration of species H2 and type 8.71. 
Doing so sets the initial concentration in mol/m3.

4 Click I2 in the Species selection list and set the Initial concentration to 8.71 mol/m3.

5 Check that the initial concentration of HI is set to 0. Click Close.

Computing the Solution
Click the Solve Problem button (=) on the Main toolbar.

Reaction Engineering Lab uses an internal stop condition for the simulation time. The 
time stepping stops when the material balances have reached steady state according to 
the tolerance that you can specify in the Solver Parameters dialog box. In this case, the 
default settings cause the solver to stop at 3.4·105 seconds. The resulting plot shows 
that the transients are captured using the default settings.
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Plotting the Solution
The Reaction Engineering Lab automatically displays the concentration of reactants 
and products as shown in the following figure: 

This plot shows that the reactor is close to steady state after roughly 36,000 s  
(10 hours). It is therefore interesting to check the value of the relationship

which at steady state, in this case, should yield the equilibrium constant. The following 
steps show how to define and plot the equilibrium expression:

1 From the Postprocessing menu, select Plot Parameters.

2 In the Expression edit field, type c_HI^2/c_H2/c_I2, which is the equilibrium 
expression.

3 Click the Add Entered Expression button (>).

K HI[ ]2

H2[ ] I2[ ]
-----------------------=
M O D E L I N G  S T R A T E G Y  |  13
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4 Type 57600 in the End time edit field in the Time values area. 

5 Click OK.

The resulting plot shows that the equilibrium expression asymptotically reaches the 
value of roughly 54.9 (dimensionless), which is also the relationship between kf  and 
kr in the model.
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Perfectly Mixed Reacting Systems: Varying Temperature in Time 

In the case of a perfectly mixed nonisothermal system, you have to set up both the 
time-dependent material and energy balances. There are no spatial concentration 
gradients because the system is perfectly mixed, so the Reaction Engineering Lab can 
create a model without evaluating the material-transport properties.

Returning to the previous example, continue with the formation of HI described by 
the reaction

The energy balance for the Batch reactor is by default defined according to the 
equation

In the above equation Vr denotes the system volume (m3), ci is the species 
concentration (mol/m3), Cp,i is the species molar heat capacity (J/(mol·K)), T is the 
temperature (K), and p the pressure (Pa). On the right hand side, ws represents the 
shaft work (J/s), Q is the heat due to chemical reaction (J/s), and Qext denotes heat 
added to the system (J/s). The heat of reaction is given as:

For this scenario, the modeling procedure in the Reaction Engineering Lab is:

1 Start the Reaction Engineering Lab.

2 Select the type of fluid (gas) and activate the energy balance.

3 Set a new reaction and type in the expression for the reaction just described.

4 Set the initial concentrations for H2, I2, and HI.

5 Set the thermodynamic properties of H2, I2, and HI.

6 Set the time interval for the reactor simulation.

7 Compute the solution.

8 Plot the solution.

At this stage, include the polynomials that describe the heat capacity, Cp,i, for each 
species  i as input data to the model. In addition you need the enthalpy of formation 

H2 g( ) I2 g( )+ 2HI g( )=

Vr ciCp i,
dT
dt
--------

i
∑ ws Q Q+ ext Vr

dp
dt
-------+ +=

Q Vr Hjrj

j
∑–=
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and the entropy of formation at 0 K for each of the three species. These are usually 
tabulated in NASA polynomial files for thermodynamic properties of pure gases.

The following list summarizes the input data for the model:

• Frequency factor for the forward reaction Af = 8.87·107 m3/(mol · s)

• Frequency factor for the reverse reaction Ar = 3.00·107 m3/(mol · s)

• Activation energy for the forward reaction Ef = 167·103 J/mol

• Activation energy for the reverse reaction Er = 184·103 J/mol

• Initial concentration for both H2 and I2 = 8.71 mol/m3

• Initial system temperature = 700 K

The polynomials for Cp (J/(mol · K)) are arranged according to the expression

and their coefficients take on the following values:

Note that h0,0K and s0,0K are fictitious enthalpies and entropies calculated as

The equation uses the Cp polynomials in the integral expression despite the fact that 
these might not be valid all the way down to 0 K. This inclusion does not introduce an 
error, because contributions outside the interval are cancelled out in every integration 
in the non-isothermal system (when going from T1 to T2) as long as the system 
temperature is within the correct interval. To calculate the entropy, follow the a 
procedure for s0,0K  analogous to the one described earlier for h0,0K. This is also a 
standard way of calculating s0,0K  and h0,0K  in NASA polynomials for thermodynamic 
data.

Cp
Rg
------- a1 a2T a3T2 a4T3 a5T4

+ + + +=

TABLE 2-1:  COEFFICIENT VALUES FOR VARYING TEMPERATURE

 a1  a2  a3  a4  a5  h0,0K/Rg  s0,0K/Rg

H2 2.883 3.681·10-3 -7.720·10-6 6.920·10-9 -2.130·10-12 -9.671·102 -1.034

I2 3.508 6.303·10-3 -1.461·10-5 1.470·10-8 -5.310·10-12 6.287·103 1.002·101

HI 3.648 -1.392·10-3 3.890·10-6 -3.260·10-9 1.100·10-12 2.131·103 4.334

h0 0K, h0 298K, Cp Td

298

0

∫+=
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Model Library path: Education/nonisothermal_hi_reactor

M O D E L I N G  I N  T H E  R E A C T I O N  E N G I N E E R I N G  L A B

Defining the Reactions
1 Start the Reaction Engineering Lab to open the Model Navigator.

2 Click the New button.

3 Go to the Model menu and select Model Settings.

4 Select the Calculate thermodynamic properties and Include energy balance check 
boxes.

5 The dialog box should look like this:

6 Click Close.

7 Click the Reaction settings button on the Main toolbar.

8 Click the New button in the lower-left corner in the Reactions page.

9 Go to the Formula edit field and type H2+I2<=>2HI, then press the Enter key.

10 Select the Use Arrhenius expressions check box.
M O D E L I N G  S T R A T E G Y  |  17
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11 Go to the Arrhenius parameters area. Find the column for the forward reaction. In 
the A edit field for the Frequency factor type 8.87e7, then in the E edit field for the 
Activation energy type 167e3.

12 Locate the column for the reverse reaction. In the A edit field for the Frequency factor 
type 3.00e7, then in the E edit field for Activation energy type 184e3.

The Species Selection List
1 Click the Species tab to review the Species selection list and the corresponding 

material balances for each species. Click on species H2, then in the c0 edit field for 
the Initial concentration type 8.71.

2 Click the Thermo tab. Enter the appropriate numbers in the first row (corresponding 
to H2 in Table 2-1) in the edit fields labeled alow,k. To use the same polynomials for 
the entire temperature interval, type 50 in the lower edit field for the Temperature 

interval limits, then type 3000 in the midpoint and upper edit fields. When you click 
on either of the Polynomial coefficients edit fields a table appears, and its rows are 
ordered identically to the input data listed in Table 2-1: a1, a2, a3, a4, a5, h0,0K/
Rg, and s0,0K/Rg. The user interface should look like this when you click on the 
Polynomial coefficients edit field:

3 Click the General tab.
 2 :  M O D E L I N G  S T R A T E G Y



4 In the Species selection list click I2, then in the c0 edit field for the initial 
concentration type 8.71.

5 Click the Thermo tab and set the Temperature interval limits: type 50 in the lower edit 
field, 3000 in the midpoint edit field, and 3000 in the upper edit field.

6 Enter values in the alow,k Polynomial coefficients edit fields, which corresponds to I2 
in Table 2-1:

7 Click the General tab.

8 In the Species selection list click on HI, then in the c0 edit field for the initial 
concentration, make sure that the value is set to 0 (this is the default value).
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9 Click the Thermo tab and specify the Temperature interval limits according to those 
already mentioned. Enter values in the lower Polynomial coefficient, alow,k, edit field 
corresponding to HI in Table 2-1. Click Close.

Setting the Simulation Parameters and Computing the Solution
1 From the Model menu, select Model Settings.

2 Select the Init page.

3 In the T(t0) edit field for Initial temperature, type 700. Click Close.

4 Click the Solve Problem button (=) on the Main menu.

Reaction Engineering Lab stops the simulation at approximately 950 seconds, where 
the system reaches steady state.
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Plotting the Solution
1 The default plot shows the concentrations of the reactants and products as functions 

of time. You can see from the plot that the reaction is considerably faster in this case 
compared to the isothermal case discussed previously.

2 Click the Plot Parameters button on the Main toolbar.

3 Remove all items from the Quantities to plot list by clicking the << button. 

Next look at the equilibrium expression during the experiment and compare it to 
the relationship between the concentrations in the mixture. Also compare it to the 
temperature deviation from the initial concentration of 700 K.

4 While still in the Plot Parameters dialog box, go to the Expression edit field, type 
kf_1/kr_1, and then click the corresponding > button to plot the equilibrium 
expression throughout the entire experiment.
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5 Click OK. The equilibrium expression varies with the temperature.

Finally, compare these results with the actual relationship between the 
concentrations.

6 Click the Plot Parameters button.

7 In the Expression edit field, type c_HI^2/c_I2/c_H2, then click the corresponding 
> button.

8 In the Expression edit field, type (T-700)/10, then click the corresponding > 
button.
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9 Click OK to create this plot:

This figure shows several things:

• The system reaches steady state after approximately 600 s.

• The temperature ceases to increase at roughly 890 K.

• The relationship between the concentrations coincides with the corresponding 
equilibrium expression.

Space-Dependent Reacting Systems: Varying Temperature in Time

For the third case in this suite of models treating the HI reactor, introduce space 
dependency into the model. This means that you need to export the model from the 
Reaction Engineering Lab into the Chemical Engineering Module in COMSOL 
Multiphysics. For this scenario, the modeling procedure in the Reaction Engineering 
Lab is as follows:

1 Start COMSOL Reaction Engineering Lab.

2 Select the type of fluid (gas) and activate the energy balance.

3 Set up a new reaction and enter the expression for the HI reaction described above.

4 Set the initial concentrations for H2, I2, and HI.
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5 Set the thermodynamic properties of H2, I2, and HI.

6 Set the transport properties of H2, I2, and HI.

7 Export to the Chemical Engineering Module.

8 Set the boundary conditions and compute the solution in COMSOL Multiphysics.

In order to perform the export step in the modeling procedure, you need some data 
to calculate the system’s transport properties:

• The molar weight of H2, I2, and HI

• The characteristic length of the Lennard-Jones potential for H2, I2, and HI

• The energy minimum of the Lennard-Jones potential for H2, I2, and HI

• The dipole moment for H2, I2, and HI

You can find this data in Ref. 2.

The model studies the time it takes for the reacting system to reach uniform conditions 
in a small measuring cell. The external temperature is 710 K, while the initial system 
temperature is 700 K.

You can now examine the detailed instructions that reproduce the model. The 
procedure is identical to the previous model until the point where you set the 
thermodynamic properties. After that point you have to provide the transport 
properties and export the reaction model to the Chemical Engineering Module.

Model Library path: Education/spacedependent_hi_reactor

Model Library path: Reaction_Engineering_Lab/Education/
spacedependent_hi_reactor

M O D E L I N G  I N  T H E  R E A C T I O N  E N G I N E E R I N G  L A B

Defining the Reactions
1 Double-click the Reaction Engineering Lab icon on the desktop to open the Model 

Navigator.

2 Click the New button.

3 Go to the Model menu and select Model Settings.
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4 Select the Calculate thermodynamic properties, the Calculate species transport 

properties, and the Include energy balance check boxes.

5 Click Close.

6 Click the Reaction Settings button on the Main toolbar.

7 Click the New button in the lower-left corner of the Reactions page.

8 Go to the Formula edit field and type H2+I2<=>2HI, then press the Enter key.

9 Select the Use Arrhenius expressions check box.

10 Go to the Arrhenius parameters area. Find the column for the forward reaction. In 
the A edit field for the Frequency factor type 8.87e7, then in the E edit field for the 
Activation energy type 167e3.

11 Locate the column for the reverse reaction. In the A edit field for the Frequency factor 
type 3.00e7, then in the E edit field for Activation energy type 184e3.

The Species Selection List
1 Click the Species tab to review the Species selection list and the corresponding 

material balances for each species. Click on species H2, then in the c0 edit field for 
the Initial concentration type 8.71.

2 Click the Thermo tab. Enter the appropriate numbers in the first row (corresponding 
to H2 in Table 2-1 in the edit fields labeled alow,k. To use the same polynomials for 
the entire temperature interval, type 50 in the lower edit field for the Temperature 

interval limits, then type 3000 in the midpoint and upper edit fields. When you click 
on either of the Polynomial coefficients edit fields a table appears, and its rows are 
ordered identical to the input data listed in Table 2-1: a1, a2, a3, a4, a5, h0,0K/Rg, 
and s0,0K/Rg.

3 Click the General tab.

4 In the Species selection list click I2, then in the c0 edit field for the initial 
concentration type 8.71.

5 Click the Thermo tab and set the Temperature interval limits: type 50 in the lower edit 
field, 3000 in the midpoint edit field, and 3000 in the upper edit field.

6 Enter values in the alow,k Polynomial coefficients edit fields, which correspond to I2 
in Table 2-1.

7 Click the General tab.

8 In the Species selection list click HI, then in the c0 edit field, make sure that the initial 
concentration is set to 0 (the default value).
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9 Click the Thermo tab and specify the Temperature interval limits: type 50 in the lower 
edit field, 3000 in the midpoint edit field, and 3000 in the upper edit field.

10 Enter values in the lower Polynomial coefficient, alow,k edit field corresponding to HI 
in Table 2-1.

11 In the Species selection list, click H2.

12 In the General tab, type 2e-3 in the Molecular weight edit field.

13 Click the Transport tab and type 2.827 in the Potential characteristic length edit field, 
type 59.7 in the Potential Energy minimum edit field, and make sure that the value 
is 0 in the Dipole moment edit field (the default value).

14 In the Species selection list, click I2.

15 Click the General tab and type 254e-3 in the Molecular weight edit field.

16 Click the Transport tab and type 5.16 in the Potential characteristic length edit field, 
474.2 in the Potential energy minimum edit field, and 1.3 in the Dipole moment edit 
field.

17 In the Species selection list, click HI.

18 Click the General tab and type 127e-3 in the Molecular weight edit field.

19 Click the Transport tab and type 4.211 in the Potential characteristic length edit field, 
288.7 in the Potential energy minimum edit field, and 0.5 in the Dipole moment edit 
field. Click Close.

Exporting the Model to COMSOL Multiphysics
1 Choose File>Export>Model to COMSOL Multiphysics.

2 Select 1D in the Space dimension list in the Start COMSOL Multiphysics dialog box. If 
COMSOL Multiphysics is already open, this dialog box does not appear; instead 
create a 1D geometry before starting the export from the Reaction Engineering 
Lab.

3 Click OK.

4 Go to the Export mass balance area. In the Application mode list select Maxwell-Stefan 

Diffusion and Convection: New.

5 Type mass in the Group name edit field.

6 In the Export energy balance area, select Heat Transfer by Conduction: New in the 
Application mode list.

7 Type energy in the Group name edit field.
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8 The Export to COMSOL Multiphysics dialog box should now look like this:

9 Click Export.

Modeling in COMSOL Multiphysics
1 Choose Draw>Specify Objects>Line.

2 Enter 0 5e-3 in the x edit field, and click OK.

3 Click the Zoom Extents toolbar button (or choose Options>Zoom>Zoom Extents).

4 Choose Multiphysics>Maxwell-Stefan Diffusion and Convection (chms).

5 Choose Physics>Subdoman Settings.

6 Select subdomain 1 from the Subdomain selection list.

7 Select mass from the Group list below the list on the Subdomains tab.

8 Click OK.

You have now applied the settings exported from Reaction Engineering Lab for the 
mass balance.

9 Choose Physics>Boundary Settings.
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10 In the Boundaries list, select 1 and 2. Verify that the default boundary condition, 
Insulation/symmetry, is selected for both w_H2 and w_I2. Click OK.

Note that you do not need to set any conditions for w_HI; it depends on the fluxes 
of the two other species. COMSOL Multiphysics obtains the flux of w_HI from the 
flow velocity (0 in this case) and the fact that the sum of all mass fluxes should give 
the total mass flux (0 in this case because the flow velocity is 0).

11 Choose Multiphysics>Heat Transfer by Conduction (ht).

12 Choose Physics>Subdoman Settings.

13 Select energy in the Group list below the list in the Subdomains tab.

14 Click OK.

This applies the exported settings from Reaction Engineering Lab to describe the 
energy balance equation.

15 Choose Physics>Boundary Settings.

16 In the Boundaries list select 2, and in the Boundary condition list select Temperature.

17 Type 710 in the Temperature edit field.

18 Click OK.

19 Click the Refine Mesh button on the Main toolbar twice (or choose Mesh>Refine Mesh 
twice).

20 Click the Solve button on the Main toolbar (or choose Solve>Solve Problem). This 
solves the model.

To study how the reaction rate varies in space and time, set up a new plot as follows:

1 Choose Postprocessing>Domain Plot Parameters.

2 Click the Line/Extrusion tab and type r_1_rxn_chms in the Expression edit field. This 
corresponds to the reaction rate as defined in the Reaction Engineering Lab.

3 Click the General tab and select all time steps from 0.1 to 1 s from the Solutions to 

use list (first select 0.1, then press Shift and select the last time to get the whole 
selection).
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4 Click OK.

The plot shows that the reaction distribution in the reactor quickly becomes uniform, 
due to the small size of the reactor and the fast transport in the gas phase at 700 K.

Model Validation and Calibration

The following section gives an overview of the Parameter Estimation functionality of 
the Reaction Engineering Lab, allowing you to validate and calibrate your model to 
experimental data. A number of basic examples are outlined, treating typical 
applications of parameter estimation:

• Finding rate constants for isothermal systems.

• Evaluating Arrhenius parameters for non-isothermal systems.

• Determining reaction order.

• Estimating non-kinetic parameters.

Working with parameter estimation problems typically involves the following steps:

• Formulating a reaction model by entering the chemical reactions and selecting a 
reactor type.

• Reading experimental data into the graphical user interface.

• Associating measured variables with the variables of the reaction model.
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• Selecting parameters and performing estimation by minimizing the objective 
least-squares function.

• Evaluating the ability of the model to represent the experimental data.

Apart from the examples below you can also find a number of more advanced models 
in the model library.

D E T E R M I N I N G  R A T E  C O N S T A N T S

Determining rate constants for chemical reactions occurring at constant temperature 
is perhaps the most common application of parameter estimation in chemistry and 
chemical engineering.

Consider the irreversible reaction:

 (2-1)

If the chemistry occurs in a closed and perfectly mixed system, then the mathematical 
model is given by:

 (2-2)

 (2-3)

The model described by Equation 2-2 and Equation 2-3 is automatically set up in the 
Reaction Engineering Lab as you select the Batch reactor type and enter the reaction 
formula into the graphical user interface.

BkA

dcA

dt
---------- kcA–=

dcB
dt

---------- kcA=
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Figure 2-2: You define the kinetics of the reaction model by typing in reaction formulas in 
the Reaction Settings dialog box.

In order to estimate the reaction rate constant (k) the mathematical model has to be 
correlated with experimental data. Start by loading the experimental data into the 
software and then continue with the parameter estimation procedure within the 
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Reaction Engineering Lab GUI. In the present example you import data points 
describing the concentration of species A as a function of time.

Figure 2-3: Import the experimental data directly into the graphical user interface.

The next step requires association of the measured variables with the variables of the 
reaction model. In this case, the measured variable is the concentration of species A, 
corresponding to a state variable of the model, cA. Once the parameters you want to 
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estimate have been specified, the software is set up to solve the parameter estimation 
problem.

Figure 2-4: Once the rate constant has been estimated the simulated and experimental 
results can be plotted simultaneously.

The following steps show you how to set up and solve the parameter estimation 
problem outlined above.

Model Library path: Education/parameter_estimation_isothermal

1 Start the Reaction Engineering Lab. In the Model Navigator, click the New button.

2 Select the menu item Model>Reaction Settings.

3 On the Reactions page, create a new entry in the Reaction selection list by clicking 
the New button.

4 Type A=>B in the Formula edit field.

5 Click the Species tab.

6 Select A from the Species selection list and type 1 in the c0 edit field.

7 Click Close.
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This concludes the definition of the reaction model where the mass balance equations, 
Equation 2-2 and Equation 2-3, describing an isothermal batch reactor system are set 
up. Note that the isothermal batch reactor is the default reactor system in Reaction 
Engineering Lab. Employing other reactor types requires that the appropriate 
selections are made in the Model Settings dialog box.

Now, move on to import the experimental results and associate the variables of the 
measured data with the variables of the reaction model:

1 Select the menu item Estimation>Parameter Estimation Settings.

2 Click the Import From File button, browse to the text file 
parameter_estimation_isothermal_data.txt. Select the file and click Import.

3 As the name of the text file appears in the Data set selection list, select it.

4 On the Variable Mapping page, note that the measured variable name, c_A 273K, is 
mapped to the model variable c_A, by default.

The independent variable of the measured data is assumed to be represented in the 
first column in the imported data file. In the present example the data has been 
collected at a number of different times (seconds). This corresponds to the default 
selections in the Independent data properties area, set to Time (Seconds).

In the next step, select the parameters you want to estimate.

1 In the Parameter Estimation Settings dialog box, go to the Parameters page.
 2 :  M O D E L I N G  S T R A T E G Y



2 Select kf_1 (Forward rate constant 1) from the Predefined parameters list and click Add 
(>).

Note that the initial guess of the parameter is taken from the value specified in the 
reaction model. In this case the value of the parameter kf_1 is found in the Forward 

rate constant edit field, in the Reaction Settings dialog box. The default value is 1.

3 Click OK to close the Parameter Estimation Settings dialog box.

Finally, solve the parameter estimation problem.

1 Click the Estimate Parameters button on the Main toolbar.

You find the estimated value of the rate constant kf_1 and its confidence limits 
displayed in the Log - Progress window. If the Log - Progress window is not open, access 
it by following the steps below:

1 Select the menu item Estimation>View Log.

2 Click the Log page.

Note that you may have to scroll in the log to locate the summary report of the 
parameter estimation calculations. Selecting the Close automatically check box closes 
the Log - Progress window after each simulation.

You can have the software automatically update the reaction model with the new 
parameter value. In this example, you then find the updated value (7.411) in the 
Forward rate constant edit field, in the Reaction Settings dialog box. It is also your 
option to have the software automatically run the model simulation with the updated 
parameters. To set these options, follow these steps.

1 Select the menu item Estimation>Parameter Estimation Settings.

2 Go to the Advanced page.

3 Make sure that the check box Copy parameter values to model after parameter 

estimation is selected.

4 Make sure that the check box Solve model after estimating parameters is selected.

5 Click OK.

D E T E R M I N I N G  A R R H E N I U S  P A R A M E T E R S

In the previous example you evaluated the rate constant, k, under isothermal 
conditions. Under non-isothermal conditions, Reaction Engineering Lab allows you 
to express the rate constants according to the Arrhenius law:
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 (2-4)

In Equation 2-4, A represents the frequency factor, E the activation energy (J/mol), 
Rg the ideal gas constant (J/(mol·K)), and T the temperature (K). Making use of a 
series of estimates for k, evaluated from experiments run at different temperatures, the 
software can calculate the Arrhenius parameters A and E.

The way to set up and solve this type of estimation problem is very similar to the 
isothermal case. The difference is that the software takes multiple data sets as input for 
the calculations. In the present example, concentration transients of species A are 
available at three different temperatures; 400 K, 500 K, and 600 K.

Figure 2-5: Three data sets are read into the software, representing concentration 
transients of species A at 400 K, 500 K, and 600 K.

When working with multiple data sets, each set is associated with a parameter that is 
known exactly, in this case the temperature. The known temperature affects the 
reaction model and is specified when setting up the parameter estimation problem. 

k A E–
RgT
-----------⎝ ⎠
⎛ ⎞exp=
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When the software calculates the Arrhenius parameters, all experimental data sets are 
taken into account simultaneously.

Figure 2-6: When the Arrhenius parameters have been estimated, the simulated and 
experimental results are plotted in the same graph.

The following steps illustrate how to evaluate the Arrhenius parameters appearing in 
Equation 2-4.

Model Library path: Education/parameter_estimation_nonisothermal

1 Start the Reaction Engineering Lab. In the Model Navigator, click the New button.

2 Select the menu item Model>Model Settings.

3 Type Temp in the Temperature edit field.

This is the parameter name you will use when accounting for the fact that data sets 
refer to experiments performed at different temperatures.

4 Click Close.

5 Select the menu item Model>Constants.

6 Type Temp in the Name column and 400 in the Expression column.

7 Click OK.

8 Select the menu item Model>Reaction Settings.

9 On the Reactions page, create a new entry in the Reaction selection list by clicking 
the New button.
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10 Type A=>B in the Formula edit field.

11 Click the Use Arrhenius expressions check box.

12 Click the Species tab.

13 Select A from the Species selection list and type 1 in the c0 edit field.

14 Click Close.

Now, move on to import experimental data sampled at 400 K, 500 K, and 600 K.

1 Select the menu item Estimation>Parameter Estimation Settings.

2 Go to the Data page.

3 Click the Import From File button, browse to the text file 
parameter_estimation_data_400K.txt. Select the file and click Import.

4 In the same way, import the files parameter_estimation_data_500K.txt and 
parameter_estimation_data_600K.txt.

5 Select the parameter_estimation_data_400K.txt entry from the Data set 

selection list.

6 Click the Inputs page.

7 Type Temp in the Name column and 400 in the Expression column.

8 Repeat the process according to the table below:

DATA SET TEMP

parameter_estimation_data_500K.txt 500

parameter_estimation_data_600K.txtt 600
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In the next step, select the parameters you want to estimate.

1 In the Parameter Estimation Settings dialog box, go to the Parameters page.

2 Select Af_1 (Forward frequency factor 1) and Ef_1 (Forward activation energy 1) from 
the Predefined parameters list and click Add (>).
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3 Provide initial guesses for the parameters by selecting the appropriate entry in the 
Parameters to estimate list and typing the value into the Specify value edit field:

Here you specify the parameters initial values in the Parameter Estimation Settings 
dialog box. You can of course also choose the current values provided in the reaction 
model. To provide initial guesses within the model, go to the Reaction Settings 
dialog box and type the values in the Frequency factor and Activation energy edit 
fields.

4 Click OK to close the Parameter Estimation Settings dialog box.

Finally, solve the parameter estimation problem:

1 Click the Estimate Parameters button on the Main toolbar.

By default the calculated parameters are updated to the reaction model. In the 
present model you find the values of Af_1 and Ef_1 in the Frequency factor and 
Activation energy edit fields, as you open the Reaction Settings dialog.

You can also find the estimated values of Af_1 and Ef_1and the associated 
confidence limits in the Log - Progress window. If the Log - Progress window is not 
open, access it using the following steps:

2 Select the menu item Estimation>View Log.

PARAMETER INITIAL GUESS

Af_1 1e5

Ef_1 5e4
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3 Click the Log page.

Note that you may have to scroll in the log to locate the summary report of the 
parameter estimation calculations. Selecting the Close automatically check box closes 
the Log - Progress window after each simulation.

D E T E R M I N I N G  R E A C T I O N  O R D E R

The path of a chemical reaction can consist of a large number of steps with 
intermediate species that do not appear in the net reaction. In many cases, you want 
to estimate the influence of the reactant and product concentrations on the reaction 
rate without modeling the intermediate concentrations. Within a certain range of 
composition, such an approximation can be satisfactory for setting up materials and 
energy balances of a system. These types of simplified kinetic models therefore require 
that you fit the reaction order of the reactant and product concentrations in the net 
reaction to experimental measurements of concentration as a function of time. 

Suppose that molecularity of the overall reaction is unknown:

 (2-5)

If the chemistry occurs in a perfectly mixed system, then the mathematical model is 
given by:

 (2-6)

 (2-7)

In this case, you can have the software estimate both the rate constant (k) and the 
reaction (n) order simultaneously. In more complicated reaction networks, where 
multiple reaction orders and rate constants are to be evaluated, it is often a good 
approach to start by setting reaction orders as constant integers and then evaluate the 
rate constants. Investigating the model fit to data for a number of different reaction 
order combinations then allows you to choose the appropriate model. Such an 
approach is exemplified in the model Kinetic Modeling of Cinnamaldehyde 
Hydrogenation, found in the Model Library.

Follow the steps below to estimate the reaction order n and rate constant k for the 
system just described.

BknA

dcA

dt
---------- kcA

n
–=

dcB

dt
---------- kcA

n
=
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Model Library path: Education/parameter_estimation_rxnorder

1 Start the Reaction Engineering Lab. In the Model Navigator, click the New button.

If you already have Reaction Engineering Lab open, select the menu item File>New.

2 Select the menu item Model>Reaction Settings.

3 On the Reactions page, create a new entry in the Reaction selection list by clicking 
the New button.

4 Type A=>B in the Formula edit field.

5 Modify the automatically generated reaction rate expression by typing kf_1*c_A^n 
in the r edit field.

6 Click the Species tab.

7 Select A from the Species selection list and type 1 in the c0 edit field.

8 Click Close.

9 Choose Model>Constants.

10 Type n in the Name column and 1 in the Expression column.

11 Click OK.

This concludes the definition of the reaction model where the mass balance equations, 
Equation 2-6 and Equation 2-7. Note that you modified the reaction rate expression 
by raising the concentration c_A to the power n. The user-defined parameter n 
corresponds to the reaction order and was defined in the Constants dialog, with an 
initial guess n = 1.

Now, move on import the experimental data and associate the variables of the 
experimental data with the variables of the reaction model:

1 Select the menu item Estimation>Parameter Estimation Settings.

2 Click the Import From File button, browse to the text file 
parameter_estimation_rxnorder_data.txt. Select the file and click Import.

3 As the name of the text file appears in the Data set selection list, select it.
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4 On the Variable Mapping page, note that the measured variable name, c_A data, is 
mapped to the model variable c_A, by default.

Note that the independent variable of the measure data is time (seconds). This 
corresponds to the default selections in the Independent data properties area, set to 
Time (Seconds).

In the next step, select the parameters you want to estimate:

1 In the Parameter Estimation Settings dialog box, go to the Parameters page.

2 Select kf_1 (Forward rate constant 1) from the Predefined parameters list and click Add 
(>).

3 Select n from the Predefined parameters list and click Add (>).

Note that the initial guess of the parameter value is take from the value specified in 
the reaction model. The value of the parameter kf_1 is found in the Forward rate 

constant edit field, in the Reaction Settings dialog box. The value of the reaction 
order was set in the Constants dialog.

4 Click OK to close the Parameter Estimation Settings dialog box.

Finally, solve the parameter estimation problem.

1 Click the Estimate Parameters button on the Main toolbar.

You find the estimated value of the rate constant kf_1, the reaction order n, and their 
confidence limits displayed in the Log - Progress window.

If the Log - Progress window is not open, access it by following the steps below:
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1 Select the menu item Estimation>View Log.

2 Click the Log page.

You can have the software automatically update the reaction model with the new 
parameter values. You find the proper selections on the Advanced page in the Parameter 

Estimation Settings dialog box. In this example, you find the updated value of kf_1 in 
the Forward rate constant edit field, and the estimated value of n in the Constants dialog 
box.

D E T E R M I N I N G  N O N - K I N E T I C  P A R A M E T E R S

Nearly any parameter of a model set up in Reaction Engineering Lab can be calibrated 
with respect to experimental data, no matter what combination of kinetics and reactor 
type that you choose to simulate.

Consider the dissolution of CO in liquid, vigorously stirred in a closed vessel. The 
liquid phase concentration of CO can be described by the following equation:

 (2-8)

where kg is the mass transfer coefficient and csat is the saturation concentration of CO 
in the liquid. Although the saturation concentration is a function of the gas pressure 
and the nature of the solvent, csat will be evaluated directly from experimental data 
together with kg.

The reaction model is set up by selecting the Batch reactor type, defining mass a 
balance by creating a new species, and typing the right-hand side of Equation 2-6 into 
the R edit field.

dcCO
dt

-------------- kg csat cCO–( )=
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Figure 2-7: The reaction model is defined in the Reaction Settings dialog box.

You then set up and solve the parameter estimation problem by associating the 
experimental variables with the model variables, and selecting the parameters to 
estimate. Follow the steps below to estimate the mass transfer coefficient kg and 
saturation concentration csat.

Model Library path: Education/parameter_estimation_CO_absorption

1 Start the Reaction Engineering Lab. In the Model Navigator, click the New button.

If you already have Reaction Engineering Lab open, select the menu item File>New.

2 Select the menu item Model>Reaction Settings.

3 On the Species page, create a new entry in the Species selection list by clicking the 
New button.

4 Type CO in the Formula edit field.

5 Type kg*(c_sat-c_CO) in the Rate expression edit field.
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6 Select the menu item Model>Constants.

7 Type in the following entries in the Name column and Expression columns:

8 Click OK.

This concludes the definition of the reaction model where the mass balance 
Equation 2-8. The user-defined parameters kg and c_sat were defined in the 
Constants dialog, with the initial guesses kg = 0.1, and c_sat = 1.

Next import the experimental data and select the parameters you want to estimate.

1 Select the menu item Estimation>Parameter Estimation Settings.

2 Click the Import From File button, browse to the text file 
parameter_estimation_CO_absorption_data.txt. Select the file and click 
Import.

3 Go to the Parameters page.

4 Select kg and c_sat from the Predefined parameters list and click Add (>).

Note that the initial guess of the parameter value is taken from the value specified in 
the reaction model. The value of kg and c_sat were specified in the Constants 
dialog.

5 Click OK to close the Parameter Estimation Settings dialog box.

NAME EXPRESSION 

kg 0.1

c_sat 1
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Finally, solve the parameter estimation problem.

Click the Estimate Parameters button on the Main toolbar.

By default the software automatically updates the reaction model with the calculated 
parameter values. In this example, the estimated values are retuned to the Constants 
window, updating the reaction model.

You can also find the estimated value of kg and c_sat, as well as their confidence limits 
displayed in the Log - Progress window. If the Log - Progress window is not open, access 
it by following the steps below:

1 Select the menu item Estimation>View Log.

2 Click the Log page.
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I n t r o du c t i o n

To launch the Reaction Engineering Lab’s graphical user interface (GUI), click the 
Reaction Engineering Lab desktop icon.

The GUI contains seven central components, listed here in the order you encounter 
them during normal work flow:

• The Model Settings dialog box

• The Constants and Expressions dialog boxes

• The Reaction Settings dialog box

• The Solver Parameters dialog box

• The Parameter Estimation Parameters dialog box

• The Plot Parameters dialog box

• Export to the COMSOL Script workspace and to COMSOL Multiphysics.

Figure 3-1: The Reaction Engineering Lab GUI and the Reaction Settings dialog box.

Models you create in the Reaction Engineering Lab are referred to as reaction models 
and are stored in files with the .rxn extension. A reaction model contains information 
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about the reaction kinetics and thermodynamics of the chemical system under study. 
It also contains details regarding the reacting fluid such as the fluid phase and the 
mixture transport properties. Furthermore, if you have run any simulations, it also 
stores the results.

The following paragraphs give an overview of the user-interface components; a 
detailed description of all user-interface features follows in later sections.

To access the Model Settings dialog box, select Model>Model Settings on the menu bar 
or click the corresponding quick button on the Main toolbar. Options in this dialog 
box determine which balance equations (material and energy) and transport properties 
that are included in the model and also the phase of the fluid (gas or liquid) in which 
the chemistry takes place. Specifying these system characteristics constitutes the natural 
starting point when creating a reaction model.

You access the Reaction Settings dialog box by selecting Model>Reaction Settings on the 
menu bar or by clicking the corresponding quick button on the Main toolbar. This 
dialog box presents two main interfaces:

• In the Reactions interface you set up the kinetics of the chemical reaction networks. 
When you type in the chemical-reaction formulas, the Reaction Engineering Lab 
automatically generates the corresponding reaction rate expressions. Apart from 
reversible and irreversible reactions, the Reaction Engineering Lab also handles 
reactions at chemical equilibrium. For a given reaction you specify rate constants or 
equilibrium constants.

• The Species interface deals with information concerning the reactants, 
intermediates, and products participating in a given chemistry. The information you 
enter and that the Reaction Engineering Lab generates in the Species interface 
forms natural building blocks for expressing composite properties related to 
chemical reactions and fluid transport. For instance, the Reaction Engineering Lab 
uses species-specific thermodynamic properties to calculate a reaction’s 
thermodynamic properties; transport properties of a fluid mixture depend on the 
properties of its pure components. The main functionality of the Species interface is 
to organize and describe thermodynamic and transport data in this regard. The 
Reaction Engineering Lab uses predefined expression in order to calculate transport 
properties for gases at moderate pressure and for a limited set of liquids, for 
example, aqueous solutions.

From the Parameter Estimation Settings dialog box you set up parameter estimation 
problems. Access this window by selecting the menu item Estimation>Parameter 

Estimation Settings.Using the dialog box you typically import experimental data into 
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the software and associate the measured variables with the variables of you reaction 
model. When you click the Estimate Parameters button, Reaction Engineering Lab will 
start searching for values of selected model parameters that calibrate your theoretical 
model to the experimental data.

Access the Solver Parameters dialog box by selecting Simulation>Solver Parameters or 
by selecting the corresponding icon from the Main toolbar. In this dialog box you 
enter the simulation’s time scale as well as solver specifications.

To configure plot parameters you likewise work with a dialog box accessible either by 
making a selection from the Postprocessing menu or by clicking the corresponding 
quick button on the Main toolbar. Here you decide which model results to display and 
how they appear. You can plot any solution variable, predefined expression, or 
user-defined expression in either the main user interface or in separate plot windows.

The Reaction Engineering Lab is fully integrated in the COMSOL product family. For 
further analysis in other COMSOL software products, you can link reaction models 
from the Reaction Engineering Lab environment. Export model data to the 
COMSOL Script workspace to run reaction models from the command line, perform 
parametric studies and advanced postprocessing. Use the Export to COMSOL 

Multiphysics to transfer the chemistry and physics of reactions models to COMSOL 
Multiphysics, extending you analysis to time and space-dependent models. Reaction 
Engineering Lab can export to application modes of the Chemical Engineering 
Module, the MEMS Module, as well as the Earth Science Module.
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Th e  Mode l  Na v i g a t o r

When starting the Reaction Engineering Lab, you are greeted by the Model Navigator.

Figure 3-2: The Reaction Engineering Lab Model Navigator.

The Model Navigator allows you to browse and select from reaction models and also 
to view associated documentation. You find a collection of solved reaction models on 
the Model Library page, where different folders group the models into different 
application areas. You can load the models for inspection or modification, either in the 
Reaction Engineering Lab (Model RXN-file) or in COMSOL Multiphysics (Model 
MPH-file, which requires COMSOL Multiphysics). Selecting a model in the list to the 
left produces a model image and a short model summary in the Description area to the 
right. To access documentation about the model, click the Documentation button.

Clicking the Library Root button allows you to specify the path to your model 
directories in order to access models from the User Models tab in later modeling 
sessions.

To browse for and open a model, click the Open tab and use the Look in list to find the 
file that you want to open. Click OK to open the file.

To build a new model from scratch, click the New button in the Model Navigator.
T H E  M O D E L  N A V I G A T O R  |  53



54 |  C H A P T E R
Select File>Reaction Model Properties to open the dialog box in Figure 3-3. Here you 
can enter basic information about a model, information that you can display in the 
Model Navigator when single-clicking a model name on the User Models tab. Select 
File>Save Model Image to associate an image to the model description. The Model 

Navigator displays both the model image and the model description.

Figure 3-3: The Reaction Model Properties dialog box.
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Mode l  S e t t i n g s

The Model Settings dialog box (Figure 3-4) is the natural starting point when building 
a new model. You can access it by selecting Model>Model Settings or by clicking the 
corresponding quick button on the Main toolbar.

Figure 3-4: The Model Settings dialog box.

In the Reactor type list you can choose from a set of predefined chemical reactors:

• Batch reactor

• Batch reactor with constant volume

• Semibatch reactor

• Continuous stirred tank reactor (CSTR) with constant volume

• Continuous stirred tank reactor (CSTR) with constant mass

• Plug-flow reactor

The default reactor selection in the Reaction Engineering Lab is the Batch (constant 

volume) reactor, running under isothermal conditions. Common for all reactor models 
is that reacting fluids in the gas phase are assumed to behave as ideal gases. Liquid 
mixtures are assumed to be ideal and incompressible.
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The Batch Reactor

In the batch reactor, no mass enters or leaves the system.

The species mass balances are given by:

 (3-1)

which takes into account the effect of changing volume. In Equation 3-1, ci is the 
species molar concentration (mol/m3), Vr denotes the reactor volume (m3), and Ri is 
the species rate expression (mol/(m3·s)).

For an ideal reacting gas, the energy balance is:

 (3-2)

In Equation 3-2 Cp,i is the species molar heat capacity (J/(mol·K)), T is the 
temperature (K), and p the pressure (Pa). On the right hand side, ws represents 
additional work, for instance the shaft work (J/s). Q is the heat due to chemical 
reaction (J/s), and Qext denotes heat added to the system (J/s). The heat of reaction 
is:

 (3-3)

where Hj is the enthalpy of reaction (J/(mol K)), and rj the reaction rate (mol/
(m3·s)).

For an incompressible and ideally mixed reacting liquid, the energy balance is:

d ciVr( )
dt

-------------------- VrRi=

Vr ciCp i,
dT
dt
--------

i
∑ ws Q Q+ ext Vr

dp
dt
-------+ +=

Q Vr Hjrj

j
∑–=
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 (3-4)

You find Equation 3-1displayed in the Equations area of the Model Settings dialog box. 
If an energy balance is included in your model, you find Equation 3-2 or Equation 3-4 
displayed in the Equations area when the Energy Balance page is selected.

The Batch Reactor with Constant Volume

The constant volume batch reactor is the default selection in the Reaction Engineering 
Lab. It assumes a closed, perfectly mixed system of constant volume. The species mass 
balances are:

 (3-5)

For an ideal reacting gas, the energy balance is given by Equation 3-2. For an 
incompressible and ideally mixed reacting liquid, the energy balance is given by 
Equation 3-4.

The Semibatch Reactor

In the semibatch reactor, reactants enter the reactor by means of one or several feed 
streams.

The species mass balances are given by:

 (3-6)

Vr ciCp i,
dT
dt
--------

i
∑ ws Q Q+ ext+=

dci
dt
-------- Ri=

d ciVr( )
dt

-------------------- vf i,  cf i, R+ iVr=
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In Equation 3-6, cf,i is the species molar concentration (mol/m3) of the associated 
feed stream vf,i (m

3/s). Vr denotes the reactor volume (m3) and is a function of time. 
For ideal mixtures:

 (3-7)

The term vp denotes the volumetric production rate due to reaction (m3/s):

 (3-8)

where νij is the stoichiometric coefficient of species i in reaction j, Mi denotes the 
species molecular weight (kg/mol), ρi the species density (kg/m3), and rj is the 
reaction rate (mol/(m3·s)) of reaction j.

For an ideal gas, the species molar volume (m3/mol) is the same for all species:

 (3-9)

so that:

.  (3-10)

The energy balance for an ideal reacting gas is:

 (3-11)

For an incompressible and ideally mixed reacting liquid, the energy balance is:

 (3-12)

Find the balance equations displayed the Equations area, when selecting the Mass 

Balance or Energy Balance page, respectively.

dVr

dt
---------- vf i,∑ vp+=

vp νij
Mi

ρi
-------rjVr

i
∑

j
∑=

Mi
ρi
-------

RgT

p
------------=

vp

RgT

p
------------ νijrjVr

i
∑

j
∑=

Vr ciCp i,
dT
dt
--------

i
∑ ws Q Q+ ext Vr

dp
dt
------- vf i,  cf i, hf i, hi–( )

i
∑+ + +=

Vr ciCp i,
dT
dt
--------

i
∑ ws Q Q+ ext vf i,  cf i, hf i, hi–( )

i
∑+ +=
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The CSTR with Constant Volume

The continuous stirred tank reactor (CSTR) has reacting species entering and leaving 
the reactor by means of feed and outlet streams. The reactor is once again assumed to 
be perfectly mixed, so that the species concentrations of the exit stream are the same 
as the concentrations in the reactor volume.

The species mass balances are given by:

 (3-13)

where v is the volumetric flow rate (m3/s) of the outlet stream. Assuming constant 
reactor volume:

 (3-14)

and setting the volumetric flow rate to:

 (3-15)

Equation 3-13 can be rewritten as:

 (3-16)

The volumetric production rate is labeled vp (m3/s), and is expressed by Equation 3-8 
for ideally mixed liquids and by Equation 3-10 for ideal gases.

The energy balance for an ideal reacting gas is:

d ciVr( )
dt

-------------------- vf i,  cf i, vci RiVr+–=

dVr
dt

---------- 0=

v vf i,∑ vp+=

Vr
dci

dt
-------- vf i,  cf i, vf i,∑ vp+⎝ ⎠

⎛ ⎞ ci RiVr+–=
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 (3-17)

For an incompressible and ideally mixed reacting liquid, the energy balance is:

 (3-18)

You find the mass balance given by Equation 3-16 displayed in the Equations area, 
when the Mass Balance page is active. The energy balance given by Equation 3-17 or 
Equation 3-18 is displayed when the Energy Balance page is active.

The CSTR with Constant Mass

This reactor model assumes that the outlet feed is adjusted in such a way that the total 
mass of the reactor is held constant.

As before, the species mass balances for the CSTR are given by:

 (3-19)

The reactor volume as a function of time is given by:

 (3-20)

The volumetric flow rate of the outlet stream, v (m3/s), is set to:

 (3-21)

The energy balance for an ideal reacting gas is:

 (3-22)

For an incompressible and ideally mixed reacting liquid, the energy balance is:

 (3-23)

Vr ciCp i,
dT
dt
--------

i
∑ ws Q Q+ ext Vr

dp
dt
------- vf i,  cf i, hf i, hi–( )

i
∑+ + +=

Vr ciCp i,
dT
dt
--------

i
∑ ws Q Q+ ext vf i,  cf i, hf i, hi–( )

i
∑+ +=

d ciVr( )
dt

-------------------- vf i,  cf i, vci RiVr+–=

dVr

dt
---------- vf i,∑ v vp+–=

v
vf i,∑
ρ

----------------ρf=

Vr ciCp i,
dT
dt
--------

i
∑ ws Q Q+ ext Vr

dp
dt
------- vf i,  cf i, hf i, hi–( )

i
∑+ + +=

Vr ciCp i,
dT
dt
--------

i
∑ ws Q Q+ ext vf i,  cf i, hf i, hi–( )

i
∑+ +=
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You find the balance equations displayed in the Equations area, when selecting the Mass 

Balance or Energy Balance page, respectively.

The Plug-Flow Reactor

In the plug-flow reactor, the species concentrations and the temperature vary with 
position. For a tubular reactor configuration, concentration and temperature gradients 
are allowed to develop in the axial direction, but not in the radial direction,

The species mass balances are given by:

 (3-24)

where Fi is the species molar flow (mol/s), V is the reactor volume (m3) and Ri 
denotes the species rate expression (mol/(m3·s)).

In order to evaluate the rate expressions Ri, which are functions of the species 
concentrations, Reaction Engineering Lab calculates:

 (3-25)

where v is the volumetric flow rate (m3/s). 

For ideal gases:

 (3-26)

so that

dFi

dV
--------- Ri=

ci
Fi

v
-----=

v
RgT

p
----------- Fi

i
∑=
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.  (3-27)

For liquids, the volumetric flow rate is given by:

 (3-28)

Neglecting pressure drop, the energy balance for an ideal reacting gas, as well as an 
incompressible and ideally mixed reacting liquid is:

 (3-29)

where Cp,i is the species molar heat capacity (J/(mol·K)), and ws represents an 
additional work term, for instance the shaft work per volume (J/(m3·s)). Qext is the 
heat added to the system per unit volume (J/(m3·s)), and Q denotes the heat due to 
chemical reaction (J/(m3·s)).

 (3-30)

where Hj the heat of reaction (J/mol), and rj the reaction rate (mol/(m3·s)).

You find the mass balance given by Equation 3-24 displayed in the Equations area, 
when the Mass Balance page is active. The energy balance given by Equation 3-29 is 
displayed when the Energy Balance page is active.

Below the reactor type list, you find the following selections:

• Reacting fluid

• Calculate thermodynamic properties

• Calculate species transport properties

• Include energy balance

In the Reacting fluid list you specify the phase of the reaction fluid as a gas or liquid. 
Reacting fluids in the gas phase are treated as ideal gases while liquids are considered 
incompressible ideal mixtures. The choice of fluid phase affects the set of predefined 
expressions made available in edit fields, defining thermodynamic as well as transport 
properties. Note that you can, for example, include a solid catalyst phase in the model 

ci
p

RgT
-----------

Fi

Fi

i
∑
-------------=

v
ρ0v0

ρ
------------=

FiCp i,
dT
dV
--------

i
∑ ws Q Qext+ +=

Q Hjrj

j
∑–=
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using the free catalyst site concentration as a variable. However, in such a case you have 
to exclude variables describing the solid phase from the calculation of the fluid 
properties. It is also possible to mix liquids and gases in the Reaction Engineering Lab, 
but you have to specify the mixture properties by changing the predefined expressions 
for density and heat capacity.

To add an energy balance to the model, select the Calculate thermodynamic properties 

check box and then the Include energy balance check box. In the cases when you want 
to calculate transport properties, select the Calculate species transport properties check 
box.

The right hand side of the Model Settings dialog box displays the following six pages:

• General

• Mass Balance

• Energy Balance

• Feed Streams

• Stoichiometry

• Init

On these pages you enter reactor specific settings, for instance the temperature and 
pressure conditions, and the number of feed streams. To fully characterize a reactor 
model you also need to provide species specific information, such as starting 
concentrations and thermodynamic properties. Such setting are entered in the Species 
interface in the Reaction Settings dialog, as described under Reaction Settings—Species 
Interface on page 82.
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The General Page

Figure 3-5: The General page displayed in the Model Settings dialog box.

The four edit fields on the General page contain parameters used in predefined 
expressions defined in the Reaction Engineering Lab. If your system is isothermal, or 
if you use a predefined temperature as a function of time, you do not need to set up 
an energy balance. In such cases, the value of the temperature T is used by the Reaction 
Engineering Lab to evaluate all temperature-dependent expressions in the material 
balances (when an energy balance is not included in the simulation). In the T edit field 
you can enter a number (298.15), variable name (T_0), or an expression of time, t (for 
example, 298.15+5*sin(2*pi*t/(3600*24))). If you are also setting up an energy 
balance for the system, temperature is a dependent variable along with the 
concentrations in the system of equations, and the T edit field is made unavailable by 
the Reaction Engineering Lab.

In the cases when the kinetic model does not require an energy balance, the Reaction 
Engineering Lab only uses the pressure value p for calculating transport properties. 
These properties are used in the export to space-dependent models in COMSOL 
Multiphysics. The default value in the p edit field is 

 (3-31)p RgT ci∑=
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for gas phase systems, and 101,325 Pa for liquid phase systems.

Finally, the ideal gas constant Rg and Boltzmann’s constant, kb, are provided for 
reference, as these are used in certain predefined expressions.

The Mass Balance Page

Figure 3-6: The Mass Balance page displayed in the Model Settings dialog box.

The Mass Balance page supplies parameters and expressions for the species mass balance 
equations displayed in the Equations area, at the top of the Model Settings dialog box. 
The edit fields for the system volume (Vr), the volumetric production rate (vp) and the 
volumetric flow rate (v) are available depending on the selection of reactor type. You 
can edit the Vr edit field when modeling the Batch, Batch (constant volume) and CSTR 

(constant volume) types. As the balance equations of the Batch reactor type accounts for 
changing volume, you may enter time dependent volume expressions in the Vr field. 
The vp edit field is available when modeling Semibatch or CSTR reactors. For liquid 
phase reactions, the edit field contains the predefined expression:

 (3-32)vp νij
Mi
ρi
-------rjVr

i
∑

j
∑=
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Reaction Engineering Lab automatically inserts the stoichiometric coefficient (νij) and 
expressions for the reaction rates (rj), as defined in the Reaction interface of the 
Reaction Settings dialog. Furthermore, the values of the molecular weight (Mi) and the 
species density (ρi) are automatically taken from Species interface of the Reaction 

Settings dialog. It follows that the vp edit field may be empty if, for instance, no 
reaction has been specified in the Reaction Settings dialog. Set the vp edit field to zero 
is you want to ignore volume changes due to reaction.

For gas phase reactions, the vp edit field contains the predefined expression:

.  (3-33)

You can edit the v edit field when modeling with the CSTR (constant mass) or Plug-flow 
reactor types. For gas phase reactions, modeled with the Plug-flow reactor, the v edit 
field contains the following predefined expression:

 (3-34)

For liquid phase reactions, default settings assume constant fluid density, and 
consequently a constant volumetric flow throughout the reactor:

 (3-35)

The default value in the v edit field is one. 

You are free to enter an expression on the form of Equation 3-35 in order to account 
for varying density.

Note that all predefined constants and expressions provided in edit fields may be 
overwritten by user-defined expressions. This allows you to go beyond the modeling 
assumptions that are default in Reaction Engineering Lab. For further reading on the 
specific mass balances and volumetric rates, see the beginning of the section Model 
Settings on page 55.

vp

RgT

p
------------ νijrjVr

i
∑

j
∑=

v
RgT

p
----------- Fi

i
∑=

v
ρ0v0

ρ
------------=
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The Energy Balance Page

Figure 3-7: The Energy Balance page displayed in the Model Settings dialog box.

To access the Energy Balance page you first need to select the Calculate thermodynamic 

properties check box and the Include energy balance check box. The Energy Balance page 
supplies parameters and expressions for the energy balance equations displayed in the 
Equations area, at the top of the Model Settings dialog box.

The edit fields for the shaft work (ws), heat source of reaction (Q), and external heat 
source (Qext), are all available for any given reactor type. The default value for ws and 
Qext is zero. The Q edit field holds the following predefined expression for the Batch, 
Semibatch and CSTR reactor types:

 (3-36)

Reaction Engineering Lab automatically inserts expressions for the enthalpy of 
reaction (Hj) and the reaction rate (rj), as defined in the Reaction Settings dialog.

For the Plug-flow reactor the heat source of reactions given as:

Q Vr Hjrj

j
∑–=
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 (3-37)

For further reading on the specific energy balances corresponding source terms, see the 
beginning of the section Model Settings on page 55.

The Feed Streams Page

Figure 3-8: The Feed Streams page displayed in the Model Settings dialog box.

The Feed Streams page is available for the Semibatch and CSTR reactor types. On this 
page you define the number and properties of the feed streams supplying the reactor 
with chemicals. Create one or more feed streams by clicking the New button. Editing 
the Name edit field allows you to label each stream as desired. To specify the volumetric 
feed rate (vf) and feed stream temperature (Tf), first select an entry in the feed streams 
list and then enter the corresponding values in the vf and Tf edit fields. The individual 
species are assigned to the inlet streams in the Species interface in the Reaction Settings 
dialog (see “Reaction Settings—Species Interface” on page 82).

Q Hjrj

j
∑–=
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The Stoichiometry Page

Figure 3-9: The Stoichiometry page displayed in the Model Settings dialog box.

The Stoichiometry and selection of slave species area displays a stoichiometric matrix 
that lists chemical reactions as columns and the involved species as rows. 
Stoichiometric coefficients in the matrix elements are defined as being negative for 
reactants and positive for products. The column labeled Slave holds check boxes that 
are used only for equilibrium reactions. In most cases, there is no need to modify the 
setting of the Stoichiometry page.

To illustrate the Slave species concept, consider the following example. Two 
nonequilibrium reaction are taking place in a perfectly mixed isothermal batch reactor 
of constant volume:

 (3-38)

 (3-39)

The corresponding mass balances are:

k1
A B

f

B 2C
k2

k2

f

r
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 (3-40)

 (3-41)

 (3-42)

Figure 3-9 shows the corresponding stoichiometric matrix displayed on the 
Stoichiometry page.

Now compare Equation 3-40 through Equation 3-42 with the balance equations that 
Reaction Engineering Lab sets up for the related chemistry, where the second reaction 
is now at equilibrium:

 (3-43)

 (3-44)

In contrast to the reversible reaction given by Equation 3-39, the explicit forward and 
reverse reaction rates of the equilibrium reaction (Equation 3-44) are not known. To 
make use of the information contained in the equilibrium relation, the mass balances 
must be reformulated. Linear combinations of rate expressions remove the unknown 
forward and reverse reaction rates of Equation 3-44. Furthermore, the equilibrium 
expression is added to the new set of material balances. Mass balances set up for the 
reactions given by Equation 3-43 and Equation 3-44 are then:

 (3-45)

 (3-46)

.  (3-47)

The equilibrium expression (Equation 3-47) introduces an algebraic relationship 
between the species’ concentrations. In order to satisfy this relationship, one species’ 
concentration must be directly linked to the other’s. The dependent species is known 

d
dt
------cA r1–=

d
dt
------cB r1 r2–=

d
dt
------cC 2r2=

k1
A B

f

B 2C

eqK2

d
dt
------cA r– 1=

d
dt
------ 2cB cC+( ) 2r1=

K2
eq cC

2

cB
------=
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as the slave species, and the Reaction Engineering Lab highlights it by selecting its 
check box in the Slave column of the stoichiometric matrix (see Figure 3-10).

Figure 3-10: The Stoichiometry page displayed for a reaction set containing an 
equilibrium reaction, where a slave species (B) has been selected automatically.

The default solver settings automatically computes the initial concentration of the slave 
species from the initial concentrations of the other (non-slave) species and the 
equilibrium expression.

The Reaction Engineering Lab automatically performs the procedure of eliminating 
equilibrium reaction rates from material balances, and it does so for any number of 
equilibrium reactions in a reaction set. Furthermore, the selection of slave species is 
automatic. It is possible to change the default selection of slave species by clearing and 
selecting the check boxes in the stoichiometric matrix.

When you export a reaction model from the Reaction Engineering Lab to the 
Chemical Engineering Module, the corresponding mass balances—now partial 
differential equations—undergo the same automatic elimination process. In the 
Chemical Engineering Module application modes generated in the export process, the 
stoichiometric matrix and the selection of slave species appear in a noneditable form. 
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If you want to change the selection of slave species for the application modes, you must 
make these changes in the Reaction Engineering Lab and then re-export the model.

For more reading on how Reaction Engineering Lab treats reaction kinetics and 
chemical equilibrium, see “The Kinetics Page” on page 75.

The Initial Values Page

Figure 3-11: The Init page displayed in the Model Settings dialog box.

The Init page supplies initial values for the balance equations solved by Reaction 
Engineering Lab. If an energy balance is included in the model you supply the initial 
reactor temperature in the T(t0) edit field. For the Plug-flow reactor type, enter the inlet 
temperature in the T(V0) edit field. The edit field for the initial system volume (V(t0)) 
is available for the Semibatch and CSTR (constant mass) reactor models.
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Rea c t i o n  S e t t i n g s—Rea c t i o n s  
I n t e r f a c e

Choose Model>Reaction Settings and click the Reactions tab to bring up the Reactions 
interface (Figure 3-12). Its main components are the Reaction selection list, the Kinetics 
page, and the Thermo page.

Figure 3-12: The Reactions interface, featuring the Reaction selection list (left) the 
Formula edit field (top), and the Kinetics page (right).

The Reactions interface contains the Reaction selection list, where reactions appear 
when you enter chemical reaction formulas in the Formula edit field. To create new 
entries, click the New button and then enter a chemical reaction formula in the Formula 
edit field; remove unwanted entries with the Delete button. To edit a reaction formula, 
select the appropriate entry in the Reaction selection list and change the expression in 
the Formula edit field. The Reaction Engineering Lab examines the species taking part 
in the model’s reactions and automatically arranges them in a corresponding Species 

selection list (see the description that follows shortly).
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Valid species names consist of a case-sensitive combination of letters, numbers, and “+” 
or “−” signs. With the exception of the “+” and “−” signs, which are used for ions, 
special characters are not allowed as species names or part of species names (for 
example, (), [], *, #, and _ ). In addition, the first character in a species name has to be 
a letter to avoid confusion with the stoichiometric coefficients in the reaction formula. 
Ions are labeled with one plus or minus sign per species charge added directly after the 
species name. For example, A++ represents a cationic monomer with a twofold positive 
charge; A2+ represents a cationic dimer of species  A with a single positive charge; and 
2A+ represents two cationic monomers, each with a single positive charge. This 
automatically fills in the charge of the species ion the Charge edit field in the Species 
interface.

For each reaction formula you enter, specify the reaction type with a delimiter 
separating the two sides of the equation: <=> denotes a reversible reaction; => denotes 
an irreversible reaction; and = denotes a reaction at chemical equilibrium.

It is possible to change the reaction type either by editing the expression in the Formula 
edit field or by selecting an entry in the Reaction selection list and then changing the 
selection in the Type list. The Type list also displays the current setting for the selected 
reaction (reversible, irreversible, or equilibrium).

The check boxes at the left of the reactions in the Reaction selection list allow for easy 
activation/deactivation of selected reactions. Creating reaction subsets in this manner 
provides a straightforward approach to investigating the influence of individual 
reactions on the overall reaction system. Species that take part only in deactivated 
reactions are automatically deactivated in the Species selection list. Furthermore, if you 
delete reactions from the Reaction selection list, the Reaction Engineering Lab 
automatically deletes from the Species selection list those species that take part only in 
the deleted reactions.

When you enter chemical formulas, each reaction is associated with a unique 
identification number. Note that this is not a row number but rather an absolute 
reference number to a given reaction. This means that a reaction keeps its identification 
number, even if you delete reactions with a lower number. Furthermore, constants and 
expressions within edit fields associated with a given reaction are also indexed with the 
reaction number (see the labeling rules in the following section).

As a general labeling rule, the variable name referring to the contents of an edit field 
associated with an entry in the Reaction selection list is given by the edit field’s name 
indexed by the reaction number. For example, if you select the entry for Reaction 1 
from the Reaction selection list, then the contents of the rate constant edit fields kf and 
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kr are labeled kf
1 and kr

1, respectively. You can use these variables—typed as kf_1 and 
kr_1, respectively—in the expressions of other edit fields. Continuing the example, the 
predefined reaction rate expression in the r edit field, labeled r1, is a function of the 
rate constants kf

1 and kr
1. Assume that you overwrite the expression in the r edit field 

with the expression r_4; then the Reaction Engineering Lab interprets this as  r1 being 
equal to r4, the expression appearing in the r edit field when Reaction 4 is selected.

The purpose of the identification number for each reaction and the labeling rules is to 
allow you to create arbitrary relations for the reaction rates and rate constants in 
different reactions. For example, if you would like to keep a constant relation between 
the rates of different reactions, you can use the above labeling and indexing to express 
this directly in the edit fields.

The variable names of all edit fields in the Reactions interface appear in the Chapter 5, 
“Reference Section,”. Furthermore, the variable names associated with a particular 
edit field appear when you place the mouse cursor on top of the edit field’s name. This 
is exemplified in Figure 3-12. When the second entry is selected in the Reaction 

selection list, and the cursor is placed over the r symbol, the tooltip r_2 appears.

The Kinetics Page

The layout of the Kinetics page appears in Figure 3-12; this page contains information 
about the kinetics of a selected reaction. You can select to specify the kinetic input data 
by entering the rate constants directly, for isothermal reactions, or you can specify the 
activation energy and the frequency factor in the Arrhenius expressions to account for 
temperature variations. Select the Use Arrhenius expressions check box to access the 
appropriate edit fields.

Consider a general reaction belonging to a set of j reactions and involving i species:

 (3-48)

For such a reaction set, the reaction rates rj (mol/(m3·s)), can be described by the mass 
action law:

.  (3-49)

+
kj

bBaA

f

kj
r

... + yYxX + ...+

rj kj
f ci

ν– ij  k– j
r ci

νij

i prod∈
∏

i react∈
∏=
R E A C T I O N  S E T T I N G S — R E A C T I O N S  I N T E R F A C E  |  75



76 |  C H A P T E R
Here, and denote the forward and reverse rate constants, respectively. The 
concentration of species i is denoted as ci (mol/m3). The stoichiometric coefficients 
are denoted νij, and are defined as being negative for reactants and positive for 
products. In practice, a reaction seldom involves more than two species colliding in a 
reacting step, which means that a kinetic expression is usually of order 2 or less (with 
respect to the involved concentrations).

In addition to the concentration dependence, you can include the temperature 
dependence of reaction rates by using the predefined Arrhenius expressions for the rate 
constants: 

.  (3-50)

To activate the Arrhenius parameters area and make the kinetic expressions use these 
parameters, select the Use Arrhenius expressions check box. In the Arrhenius parameters 
area, A denotes the frequency factor, n the temperature exponent, E the activation 
energy (J/mol) and Rg the gas constant, 8.314 J/(mol·K). The pre-exponential factor, 
including the frequency factor A and the temperature factor Tn, is given the units 
(m3 /mol)α−1/s, where α is the order of the reaction (with respect to the 
concentrations). Edit fields are available for each of the Arrhenius parameters in the 
equation above.

For an Irreversible reaction, predefined expressions appear in the edit fields for the 
Forward rate constant, kf, and the Reaction rate, r. In the Arrhenius parameters area, the 
Reaction Engineering Lab fills in the edit fields A, n, and E, all pertaining to the forward 
rate constant, with default values and makes the remaining fields unavailable.

The reaction rate edit field r displays the reaction rate expression for the selected 
reaction according to the mass action law. You can overwrite any of the predefined 
expressions with your own expressions or constants. For example, the concentrations 
of species A and B are labeled cA and cB by the Reaction Engineering Lab. You can 
type any expression of these variables—entered as c_A and c_B, respectively—in the r 
edit field to overwrite the default mass action law expression (it does not have to be a 
power-law expression, but can be any analytical expression). Should you want to revert 
to the predefined expressions given for a specific reaction, select the reaction entry in 
the Reaction selection list and click the Reset button.

For a Reversible reaction, predefined expressions appear in the edit fields for the 
Forward rate constant, kf, the Reverse rate constant, kr, and the Reaction rate, r. In the 
Arrhenius parameters area, the Reaction Engineering Lab fills in the edit fields A, n, and 
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E, all pertaining to the forward and reverse rate constants, with default values. As 
mentioned in the above paragraph, you can overwrite any of the predefined 
expressions with custom expressions of the modeled concentrations, temperature, and 
model constants. 

The edit field for the equilibrium constant, Keq
0, is also available, filled in with the 

predefined expression

.  (3-51)

The exponential term in Equation 3-51 as being related to the Gibbs free energy of 
reaction, Gj (J/mol):

.  (3-52)

The thermodynamic expressions for Hj and Sj are described in detail shortly. In the 
case of reversible reactions, it is also possible to make use of equilibrium relationships 
in order to indirectly calculate reaction constants. For instance, you can calculate the 
reverse rate constant from the equilibrium condition in this way:

 (3-53)

Consider an example implementing the form of Equation 3-53 for the reverse rate 
constant: For a hypothetical Entry 1 in the Reaction selection list, the Arrhenius 
expression in the reverse rate constant edit field, kr, would simply be overwritten by 
the expression kf_1/Keq0_1.

When using Equation 3-53, take care to ensure that the equilibrium constant has the 
proper units. If Keq

0 is derived from gas-phase data, thus being expressed in pressure 
units, you must provide the proper conversion with the relationship

 (3-54)

where Keq
c,j is the equilibrium constant expressed in concentration units, Keq

p,j is the 
equilibrium constant expressed in pressure units, and vij are the stoichiometric 
coefficients defined as being positive for reactants and negative for products.
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For an Equilibrium reaction, only the equilibrium constant edit field, Keq
0, and the 

equilibrium expression field, Keq, are available. In the Keq field, you can overwrite the 
predefined expression corresponding to Equation 3-51 with an arbitrary expression of 
the concentrations and temperature. The default settings for the reaction given by 
Equation 3-48 and assuming equilibrium, yields the expression for the equilibrium 
expression in Equation 3-55:

.  (3-55)

The following short example illustrates how the Reaction Engineering Lab handles 
equilibrium reactions in the formulation of the material balance equations. Consider 
the reaction

.  (3-56)

According to Equation 3-49 the reaction rate (mol/(m3· s)) is formulated as

 (3-57)

where cA and cB are the concentrations (mol/m3) of A and B, and kf and kr are the 
forward and reverse rate constants (1/s), respectively. The net rate expressions with 
respect to species A and B are then

 (3-58)

 (3-59)

Writing down the material balances for species A and B, respectively, yields:

 (3-60)

 (3-61)

where NA and NB are the molar flux vectors (mol/(m2· s)) for species A and B, 
respectively. The rate of consumption of species A equals the production rate of species 
B, as shown in Equation 3-60 and Equation 3-61. Assuming the reaction in 
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Equation 3-56 is at equilibrium, a dilemma arises because r is not known explicitly. 
However, the relationship between the forward and reverse reaction rates in 
Equation 3-56 is given by the following ratio:

 (3-62)

With the combined information in Equation 3-60 through Equation 3-62, the 
Reaction Engineering Lab is able to define the mass balances for the equilibrium 
system without explicitly knowing the reaction rate expressions. The Reaction 
Engineering Lab eliminates the reaction rate terms by linearly combining the mass 
balances so that the equation system becomes

 (3-63)

.  (3-64)

The Reaction Engineering Lab solves these equations directly. In general, for a system 
of reactions contributing to n mass balances and with m reactions being at equilibrium, 
the reduced system of equations to be solved would be composed of n–m mass 
balances and m equilibrium expressions. The elimination process producing the above 
system of equations is automated in the Reaction Engineering Lab, allowing you to 
effortlessly include chemical equilibrium conditions, even for very complicated 
reaction models.

The system of equations given by Equation 3-63 and Equation 3-64, includes the flux 
vectors of the respective species, NA and NB, with the corresponding transport 
properties. The Reaction Engineering Lab formulates such a system only for 
space-dependent problems, which you can solve through the export to COMSOL 
Multiphysics.

The Thermo Page

The Thermo tab is only available when you have selected the Calculate thermodynamic 

properties check box in the Model Settings dialog box (see Figure 3-4). The 
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Reactions>Thermo page (Figure 3-13) contains information about thermodynamic 
properties related to a selected reaction.

Figure 3-13: The Thermo page as shown in the Reactions interface.

The enthalpy of reaction (J/mol) is calculated by the Reaction Engineering Lab from 
species properties and the related stoichiometric coefficients in this way:

.  (3-65)

Similarly, the entropy of reaction (J/(mol·K)) comes from the relationship

.  (3-66)

In these equations, hi and si are the species’ molar enthalpy (J/mol) and entropy (J/
(mol·K)), respectively. You enter these quantities on the Species>Thermo page either by 
using the predefined polynomial or by providing a custom expression or constants. 
The stoichiometric coefficients, vij, are defined as being negative for reactants and 
positive for products. As noted earlier, using Equation 3-65 and Equation 3-66 to 
equate the Gibbs free energy of reaction enables you to express the equilibrium 
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constant according to Equation 3-51. The expression for the equilibrium constant 
goes into the edit field Keq

0 of the Kinetics page (described earlier).

The heat source of reaction (J/(m3· s)) is given as:

.  (3-67)

The sum of Qj over all reactions is the total heat source due to chemical reaction:

.  (3-68)

This term appears in the Model Settings>Energy Balance dialog box.

Qj H– jrj=

Q Qj
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Rea c t i o n  S e t t i n g s—Spe c i e s  I n t e r f a c e

Clicking the Species tab in the Reaction Settings dialog brings up the Species interface 
(Figure 3-14). The main components of the Species interface are the Species selection 
list, the General page, the Feed Stream page, the Thermo page, and the Transport page. 
The Feed Stream tab is only available when you have selected one of the Reactor types; 
Semibatch, CSTR or Plug-flow. The Thermo tab is only available when you have selected 
the Calculate thermodynamic properties check box while the Transport tab is available 
when you select the Calculate species transport properties check box. All the above 
selection are made in the Model Settings dialog box (Figure 3-4). 

Figure 3-14: The default Species interface in the Reaction Engineering Lab featuring the 
Species selection list (left) and the General page (right).

The Reaction Engineering Lab generates the Species selection list based on the 
chemical reaction formulas entered into the Reaction selection list.

A general rule applies to the labeling of variables referring to the contents of edit fields: 
variables names consist of the edit field’s name indexed by the species name. For 
instance, the species rate expression, which appears in the R edit field, is labeled R_h2o 
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for the species named h2o. Moreover, Cp_h2o is the heat capacity, eta_h2o is the 
viscosity, and so on.

Chapter 5, “Reference Section,” lists the variable names of all edit fields. In addition, 
the variables associated with a particular edit field appear when you hold the mouse 
cursor on top of the edit field’s name.This system of reference, which is parallel for 
both the Reactions and Species interfaces, makes it straightforward to interpret the 
contents of edit fields and also to see how the fields interrelate. 

Just as with entries in the Reaction selection list, you can add, remove, or deactivate 
entries in the Species selection list. Deactivation of a species automatically deactivates 
any reactions in which the species participates. Before you can delete a species, a 
warning prompts you that reactions including the species will also be removed.

For each species you enter, it is possible to change its characteristics by making a 
selection in the Type list. You can here specify the special cases when a species serves as 
the solvent in a solution or when a species is at steady state. The selection of a species 
as solvent has implications in the calculation of thermodynamic and transport 
properties. These properties are also used in the export to the Chemical Engineering 
Module, and you have to select different application modes if you intend to apply a 
solvent-solute approximation or if you want to apply a full multicomponent 
description for the reacting fluid.

The default settings in the Reaction Engineering Lab implement the description for 
multicomponent fluids. This means that it generates the mixture’s physical properties 
dependent upon its composition. This default choice is a prerequisite for the use of the 
multicomponent mass balance formulations in the Chemical Engineering Module 
(Maxwell-Stefan Diffusion and Convection) of COMSOL Multiphysics.

Configuring a species as a solvent sets the physical properties of the reacting fluid equal 
to those of the solvent species; specifically, its density, heat capacity, viscosity, and 
thermal conductivity. Furthermore, the Reaction Engineering Lab implements a 
solute-solvent approximation for the interaction of species in the fluid and describes 
their transport properties accordingly. In material balances this means that the 
diffusion coefficient is independent of any of the solute’s concentrations, because every 
solute only interacts with solvent molecules, regardless of their concentration. In 
addition, the convective term in the flux of species is directly given by the velocity field 
of the solvent multiplied by the solute concentration. Select a Solvent species when 
making use of the mass balance formulations in the Diffusion and the Convection and 
Diffusion application modes in the Chemical Engineering Module of COMSOL 
Multiphysics.
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A solvent can furthermore affect the reaction kinetics. Select Solvent in the Type list to 
set the species’ concentration to a constant value (the value in the c0 edit field). The 
Reaction Engineering Lab does not formulate a mass balance for the solvent species. 
The Lock concentration/activity check box is selected to underline that assumption. This 
setting corresponds to the situation where the solvent does not take part in chemical 
reactions at all, or where it reacts but is present in large excess. If you clear the Lock 

concentration/activity check box, the Reaction Engineering Lab sets up a material 
balance for the solvent species; the concentration takes on the initial value in the c0 edit 
and is allowed to change with time.

Selecting a species to be at Steady state imposes the following condition on its material 
balance:

.  (3-69)

This can be a useful assumption and simplification when reaction kinetic rates differ 
greatly, particularly in reactions that follow each other.

The General Page

Figure 3-14 shows the layout of the General page in the Species interface. The 
Molecular weight edit field, the Thermo tab, and the Transport tab are only available 
when you have selected the Calculate thermodynamic properties and the Calculate 

species transport properties check boxes. The Feed Stream tab is only available when 
you have selected one of the Reactor types; Semibatch, CSTR or Plug-flow. The above 
selections are made in the Model Settings dialog box (see Figure 3-4).

The Parameters area deals with species parameters. The first two edit fields are the 
species molecular weight, M (kg/mol) and the ionic charge, z. Values you enter for the 
molecular weight appear in the predefined expressions displayed in other edit fields. 
The following three edit fields include the critical temperature, Tc (K), the critical 
molar volume, Vc (m

3/mol) and the critical compressibility factor, Zc. 

The Density edit field is active when you select a species as a solvent and when the 
Calculate species transport properties check box is selected in the Model Settings dialog 
box. The fluids density is compiled for both multicomponent and solute-solvent 
solutions. However, the Density edit field only displays the density of the solution for 
solvent-solute descriptions, when you select the solvent species in the Species selection 
list.

t∂
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The ideal gas law is used to calculate the density of gases. The critical temperature, 
molar volume and compressibility factor are used to compute the density of liquid 
solvents. You can select Gas or Liquid as Reacting fluid in the Model Settings dialog box, 
see Figure 3-4.

For gas solvents, density, ρ, is expressed using the ideal gas law

 (3-70)

where ρsolvent denotes the solvent’s density (kg/m3), p the pressure (Pa), M the 
solvent’s molecular weight (kg/mol), T the temperature (K), and Rg the ideal gas 
constant (8.314 J/(mol·K)). Equation 3-70 uses the molar mass, M, for the solvent 
species, which you specify in the Parameters area of the General page.

For liquid solvents, the temperature-dependent density is given by the Rackett 
equation (Ref. 1)

 (3-71)

where Vc denotes the critical molar volume (mol/m3), Zc the critical compressibility 
factor, and Tc the critical temperature (K) of the solvent species. Equation 3-71 uses 
the values you enter into the corresponding edit fields. Critical volumes, temperatures, 
and compressibility factors for a large number of species are readily available in 
engineering handbooks such as Ref. 2 and Ref. 3. Note that, if you do not intend to 
use the predefined expression from Equation 3-71 in your model, you do not need to 
supply the values for the critical constants.

The Lock concentration/activity check box removes the selected species’ material 
balance, and the Reaction Engineering Lab also sets its concentration to the constant 
value in the c0 edit field. A locked species still affects the kinetics of appropriate 
reactions by appearing in the rate expressions as a constant. Note that you can use the 
Lock activity/concentration feature without having the species selected as solvent.

The solution of the material and energy balances require initial conditions for the 
reacting systems. Specify the initial concentrations in the c0 edit field. Note that these 
initial concentrations refer to species in the reactor volume of the Batch, Semibatch 
and CSTR reactors. For reactors with an inlet, that is the Semibatch and CSTR models, 
you also need to specify the species concentrations in the feed streams, cf. When using 
the predefined Plug-flow reactor type, inlet molar flows, F0, rather than initial 
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concentrations need to be supplied. Read more about specifying feed and inlet 
condition under the heading The Feed Streams Page on page 68.

Take special care when some species are involved in a reaction that is at chemical 
equilibrium. Under such conditions the equilibrium expression (Equation 3-55) 
introduces an algebraic relationship between the species’ concentrations. In order to 
satisfy this relationship, one species’ concentration must be directly linked to the 
concentration of the other. Dependent species are referred to as slave species. The 
Reaction Engineering Lab automatically selects the slave species, and the results appear 
in the Mass Balance Parameters dialog box. The number of slave species must be equal 
to the number of equilibrium reactions. Normally you do not need to change these 
settings.

Note: It is only possible to select slave species from the species that occur in 
equilibrium reactions.

You do not need to supply the initial concentrations for the slave species, because the 
Reaction Engineering Lab calculates their concentrations to satisfy the equilibrium 
expression (see section “Solver Parameters” on page 102). However, it is good practice 
to enter values into the c0 edit fields of slave species as well, as these values will be used 
as initial guesses to find slave species concentrations that are consistent with the 
equilibrium expressions.

The rate expression for a given species contains a contribution from each reaction in 
which the species participates so that

.  (3-72)

In Equation 3-72, rj denotes the reaction rate (mol/(m3·s)) for reaction j, which is in 
turn given by Equation 3-49. νij denotes the stoichiometric coefficient for species i in 
reaction j, defined as being negative for reactants and positive for products.

Note that you can modify or overwrite predefined expressions with arbitrary 
expressions of the modeled variables and the entities in other edit fields. Should you 
want to revert to the predefined expressions given for a specific species, select the 
species entry in the Species selection list and click the Reset button.

Ri νijrj

j
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The Feed Stream Page

Figure 3-15 shows the layout of the Feed Streams page in the Species interface.The 
Feed Stream tab is only available when you have selected one of the Reactor types; 
Semibatch, CSTR or Plug-flow. The above selections are made in the Model Settings dialog 
box.

Figure 3-15: The Feed Stream page of the Species interface.

In the Reactor feed stream parameters area, you associate the species of the reacting 
fluid with the feed streams that supply them to the reactor volume. The Name list 
contains all feed streams defined in the Model Settings>Feed Streams dialog. To 
associate a species with a particular feed stream, first select the appropriate entry from 
the Species selection list and then select the feed stream from the Name list. Also, supply 
the concentration of the species in the feed stream by editing in the cf field. The edit 
field F0 corresponds to the species molar flow at the inlet of a plug-flow reactor. The 
edit field is available if the reactor type Plug-flow has been selected from the Model 

Settings dialog box.
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The Reactor feed stream expressions area contains the hf edit field. In this edit field you 
specify the species contribution to the molar enthalpy of the feed. For gases, the 
predefined expression in the hf field is:

 (3-73)

Note that Equation 3-73 is equivalent to thermodynamic polynomial expressed in 
Equation 3-75, evaluated at the feed stream temperature, Tf,i. The temperature of 
each feed stream is a reactor specific rather than a species-specific property, and you 
specify them in the Tf edit field found in the Model Setting dialog box. For liquids, no 
predefined expression is supplied in hf edit field, and the default value is set to zero.

Read more of how Reaction Engineering Lab sets up and uses thermodynamic 
properties in the following section.

hf i, Rg a1Tf i,
a2
2
------Tf i,

2 a3
3
------Tf i,

3 a4
4
------Tf i,

4 a5
5

------Tf i,
5 a6+ + + + +⎝ ⎠

⎛ ⎞=
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The Thermo Page

Figure 3-16 shows the layout of the Thermo page in the Species interface. The Thermo 
page is only available when you have selected the Calculate thermodynamic properties 
check box in the Model Settings dialog box.

Figure 3-16: The Thermo page of the Species interface.

The top area of the Thermo page deals with Thermodynamic parameters and supplies 
inputs to fields in the Thermodynamic expressions area. Any coefficients for the 
thermodynamic polynomials (see below) you enter into the ak,low edit fields apply to 
the temperatures in the range Tint/lower to Tint/midpoint; coefficients you enter into the 
ak,high edit fields apply to temperatures in the range Tint/midpoint to Tint/upper range.

At the bottom of the Thermo page you can see the Thermodynamic expressions area, 
which contains the edit field for the species’ heat capacity, Cp, the molar enthalpy, h, 
and the molar entropy, s, using the polynomial format of Gordon and McBride (Ref. 
5). This manual also refers to these expressions as NASA polynomials:

 (3-74)Cp i, Rg a1 a2T a3T2 a4T3 a5T4
+ + + +( )=
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 (3-75)

 (3-76)

Here, Cp,i denotes the species’ heat capacity (J/(mol·K)), T the temperature (K), and 
Rg the ideal gas constant, 8.314 (J/(mol·K)). Further, hi is the species’ molar enthalpy 
(J/mol), and si represents its molar entropy (J/(mol·K)), at standard state.

When you use the NASA polynomials as inputs to the Reaction Engineering Lab, enter 
the coefficients a1 to a7 directly into the corresponding edit fields. Then the 
predefined expressions given by Equation 3-74, Equation 3-75, and Equation 3-76 
are ready to use. You can also import data files with the coefficients, as outlined in 
Importing Thermodynamics Files on page 129. Polynomial coefficients for NASA 
polynomials are available as public resources (Ref. 14).

WO R K I N G  W I T H  P R E D E F I N E D  E X P R E S S I O N S

The open and editable format of the Reaction Engineering Lab lets you choose 
whether to use the predefined expressions as given, use parts of a predefined format, 
or replace expressions entirely. A few short examples highlight the use of the 
predefined expressions used in the Thermo page to enter the thermodynamic properties 
of carbon monoxide. They also illustrate the possibilities to adapt to different 
modeling situations.

• Case 1—Carbon monoxide is part of a reacting mixture. You want to do several 
things: make use of the predefined expressions of species Cp as an input to the heat 
capacity of the reacting mixture (Equation 3-138); use the predefined expression h 
for each species to calculate the heat of reaction (Equation 3-65); and use the 
predefined expression s for each species to calculate the entropy of reaction 

hi Rg a1T
a2
2
------T2 a3

3
------T3 a4

4
------T4 a5

5
------T5 a6+ + + + +⎝ ⎠

⎛ ⎞=

si Rg a1 Tln a2T
a3
2
------T2 a4

3
------T3 a5

4
------T4 a7+ + + + +⎝ ⎠

⎛ ⎞=
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(Equation 3-66) and subsequently the equilibrium constant of reaction 
(Equation 3-51).

To accomplish this, enter the seven coefficients of the NASA format, a1 to a7, into 
the appropriate edit fields, or import a CHEMKIN thermo input file (see Importing 
Thermodynamics Files on page 129).

Figure 3-17: Enter the polynomial coefficients of the NASA format into the corresponding 
edit fields or import the data from file.

• Case 2—Carbon monoxide is part of a reacting mixture. You want to make use of 
the predefined expressions of species Cp to calculate the heat capacity of the reacting 
mixture (Equation 3-138).

Polynomials for Cp are available in the literature (Ref. 2, Ref. 3, and Ref. 4) in the 
frequently used form
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 (3-77)

You can directly use the predefined expression for the species’ heat capacity, 
Equation 3-74, also given in the Cp edit field, by supplying coefficients in the a1 to 
a5 edit fields. Note that you can enter fewer than five coefficients.

You also want to use the predefined expressions h for each species to calculate the 
heat of reaction (Equation 3-65). An option is to make use of the heat of formation 
at standard state (298.15 K) to calculate the coefficient a6. Identifying the 
coefficient a6 of Equation 3-75 is straightforward. In the NASA polynomial format, 
the species molar enthalpy is related to its heat capacity according to

 (3-78)

Inserting Equation 3-74 into Equation 3-78 and comparing the result with 
Equation 3-75 shows that the term a6 Rg is identified as the species enthalpy of 
formation at 0 K, that is, h(0). Evaluate h(0) from the species enthalpy of formation 
at standard state temperature, Tstd = 298.15 K, which is given by

 (3-79)

Cp Rg anTn 1–

n
∑= n = 1,…,5

h Cp T h 0( )+d
0

T

∫=

a6
h Tstd( )

Rg
-------------------- a1Tstd

a2
2

------Tstd
2 a3

3
------Tstd

3 a4
4

------Tstd
4 a5

5
------Tstd

5
+ + + +⎝ ⎠

⎛ ⎞ .–=
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Figure 3-18: Enter the polynomial coefficients for Cp (a1 to a5) and coefficient a6, 
evaluated from the enthalpy of formation at standard state.

• Case 3—Carbon monoxide is again part of a reacting mixture. It is satisfactory to 
approximate Cp as being constant. Specify the species enthalpy by making use of the 
heat of formation at 298 K, h(298), according to the well-known expression
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 (3-80)

Figure 3-19: The predefined expression for Cp overwritten by a constant value, and the 
predefined expression for h overwritten by a user-defined expression.

h Cp T 298–( ) h 298( )+=
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The Transport Page

Figure 3-20 shows the layout of the Transport page in the Species interface. The 
Transport page is only available when you have selected the Calculate species transport 

properties check box in the Model Settings dialog box.

Figure 3-20: The Transport page in the Species interface.

At the top of the Transport page is the Transport parameters area, which supplies inputs 
to the expressions in the Transport expressions area. The first three parameters apply to 
gases: σ, the characteristic length (Å) of the Lennard-Jones/Stockmayer potential; ε/
kb, the energy minimum (K) of the Lennard-Jones/Stockmayer potential; and µ, the 
dipole moment (Debye). The three parameters at the bottom of the area apply to 
liquids: ηref is the liquid viscosity (Ns/m2) of a species given at the temperature Tref (K), 
while Vb is the molar volume at the boiling point (m3/mol). 

The bottom area of the Transport page, labeled Expressions, contains the edit field for 
the diffusivity, D0, the dynamic viscosity, η, and the thermal conductivity, k.

The Reaction Engineering Lab sets up different expressions for diffusivities depending 
on whether species are diffusing in a solvent or in a multicomponent mixture.
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The most general description of a solution is the one that describes the solution as a 
multicomponent solution, where all species in a solution interact with each other. A 
simplified description, but still a common one, assumes that the solution consists of a 
solvent that dominates the properties of the solution. The solutes in such a solution 
interact only with solvent molecules.

For gases, the Reaction Engineering Lab calculates diffusion coefficients from the 
following expression based on kinetic gas theory:

 (3-81)

Here, DAB is the binary diffusion coefficient (m2/s), M equals the molecular weight 
(kg/mol), T represents the temperature (K), p is the pressure (Pa), and σ equals the 
characteristic length (Å) of the Lennard-Jones/Stockmayer potential. In addition, ΩD 
is the collision integral, given by the following equation (Ref. 7 and Ref. 8):

 (3-82)

where

 (3-83)

 (3-84)

 (3-85)

 (3-86)

 (3-87)

In Equation 3-87, µ is the species dipole moment (Debye). For gases at moderate 
pressure, the binary diffusivity can be used for the multicomponent Maxwell-Stefan 
diffusivities.

DAB 2.695 10 3– T3 MA MB+( ) 2 103MAMB⋅( )⁄
pσAσBΩD

--------------------------------------------------------------------------------------⋅ ⋅=

ΩD A T∗( ) B–
C DT∗–( )exp[ ] E FT∗–( )exp[ ]+ +=

G+ HT∗–( )exp[ ]
0.19δAB

2

T∗
----------------------+

T∗ k T
εAB
---------=

εAB εAεB( )1 2⁄
=

δAB δAδB( )1 2⁄
=

σAB σAσB( )1 2⁄
=

δ 1
2
--- µ2

εσ3
---------=
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To export the Maxwell-Stefan diffusivities from the Reaction Engineering Lab to 
COMSOL Multiphysics, selecting the export to the Maxwell-Stefan Diffusion and 
Convection Application mode. The Reaction Engineering Lab creates one diffusivity 
expression for each pair of species in the solution, so for multicomponent solutions the 
Diffusivity edit field is unavailable (there is generally not a single value). You find the 
expressions for the diffusivities in the Export to COMSOL Multiphysics dialog box and in 
the Maxwell-Stefan diffusivity matrix in the Maxwell-Stefan Diffusion and Convection 
application mode in the Chemical Engineering Module.

If a solvent approximation is used for gases, the binary diffusivities are used to calculate 
the diffusivity of species A in a solvent B. The expression of each species diffusivity in 
the solvent is then displayed in the Diffusivity edit field in the Reaction Engineering 
Lab.

For liquids, the diffusivity of a species A in a solvent B is calculated by the Reaction 
Engineering Lab using the Wilke-Chang equation (Ref. 9):

 (3-88)

where ηB denotes the solvent’s dynamic viscosity (Ns/m2), and Vb, A equals the molar 
volume at the normal boiling point of the solute species (m3/mol). is the 
dimensionless association factor of the solvent, by default set to 1. The expression of 
each species diffusivity in the solvent is then displayed in the Diffusivity edit field in the 
Reaction Engineering Lab. Note that this requires that you select one of the species in 
the Species selection list as Solvent. The Molar volume at boiling point edit field is then 
only available for the solute species while the Dynamic viscosity and the Reference 

temperature edit fields are only available for the solvent species.

As mentioned already in the General page section above, the default settings 
implements a multicomponent solution consisting of all species in the Species selection 
list. This choice is appropriate when exporting to the Maxwell-Stefan Convection and 
Diffusion application mode in the Chemical Engineering Module. The solvent-solute 
approximation is appropriate for export to the Diffusion and Convection and 
Diffusion application modes in the Chemical Engineering Module.

Referring again to the Transport page on the Species interface of the Reaction Settings 
dialog box, the Transport expressions area displays expressions for the dynamic viscosity 
of the species. For gases, the predefined expression for the dynamic viscosity is given 
by the kinetic gas theory (Ref. 7 and Ref. 8) as

DAB 3.7·10 15– φBMB( )1 2⁄ T

ηBVb A,
0.6

----------------------------------=

φB
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.  (3-89)

Here η represents the dynamic viscosity (Ns/m2), and Ωv is the collision integral, 
given by

 (3-90)

with

 (3-91)

 (3-92)

In Equation 3-92, µ is the species dipole moment (Debye).

For liquids, an approximate expression for the temperature dependence of the dynamic 
viscosity is given by this equation (Ref. 10):

 (3-93)

where the dynamic viscosity η is given in Ns/m2. As inputs for Equation 3-93, the 
Reaction Engineering Lab takes the reference viscosity, ηref (N·s/m2) at the reference 
temperature Tref (K), found in the Transport parameters area.

Finally, the Transport expressions area displays expressions for the species’ thermal 
conductivity.

For gases, the predefined expression for thermal conductivity comes from the 
Stiel-Thodos equation (Ref. 11)

 (3-94)

where the thermal conductivity k is in (W/(m·K)). Here Cp denotes the heat capacity 
(J/(mol·K)). Note that Equation 3-94 is a function of viscosity as given by 
Equation 3-89 and of the specific heat as given by Equation 3-74.
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The Reaction Engineering Lab does not provide predefined expressions for the 
thermal conductivity of liquids. For liquids, you can type an arbitrary expression of 
composition, temperature or any other modeled entity, in the k edit field to calculate 
the thermal conductivity of liquid mixtures in order to use such an expression in the 
export to the Chemical Engineering Module.
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Con s t a n t s  and Exp r e s s i o n s

Choose Model>Constants to open the dialog box in Figure 3-21.

Figure 3-21: The Constants dialog box.

The Reaction Engineering Lab evaluates constants when you click Apply or OK in the 
Constants dialog box. Constants can depend on other constants and can contain any 
mathematical functions except dependent variables and the time variable from the 
model. You can use the Constants box to create your own temporary constants 
database. You can use constants in any expressions or edit field in the Reaction 
Engineering Lab.

To add a constant, type its designation in the Name edit field, then enter the expression 
that defines its value in the Expression edit field. This expression can use any constants 
already defined. Click Apply or click in another edit field to evaluate the constant. You 
can add optional text in the Description edit field.

It is possible to save constant lists to a text file as well as load constants from a text file 
into the Constants dialog box. To save your constants to a file, click the Export Variables 

to File button in the lower-left corner of the dialog box. The Reaction Engineering Lab 
saves the information in three tab-separated columns you define in the Export Variables 
dialog box. In each row, the first column contains the constant’s name; the second 
column contains the expression that defines its value; and the third column contains 
an optional description.

You can also load constants from a text file where each row contains a constant’s name, 
expression, and description separated by tabs or colons. To load such a file, click the 
Import Variables from File button in the lower-left corner of the Constants dialog box. 
This opens the Import Variables dialog box, where you can browse for text files. The 
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Reaction Engineering Lab adds the constants to the end of the current list in the dialog 
box.

Now move on to the Model>Expressions dialog box in Figure 3-22.

Figure 3-22: The Expressions dialog box.

Expression variables can make a model easier to understand by introducing short 
names for complicated expressions. Another use for expression variables is during 
postprocessing.

To add an expression, type an appropriate entry in the Name edit field, then in the 
Expression field enter the relationship that defines the variable. These expressions can 
include arbitrary functions of the dependent variables (concentrations and 
temperature) and the time variable in your model as well as the constants defined in 
the Constants dialog box. You can also add optional text to identify the variable in the 
Description edit field. You can save expressions to text files and also load such 
expressions from text files into the Expressions dialog box.
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S o l v e r  Pa r ame t e r s

Figure 3-23 shows the contents of the Simulation>Solver Parameters dialog box.

Figure 3-23: The Solver Parameters dialog box.

The default setting for the Reaction Engineering Lab solver is to run the simulation 
until the system reaches steady state, within the specified time frame in the Times edit 
field. This is done by calculating a norm for the time derivatives of the species 
concentrations and once this norm is small enough, compared to the tolerance that 
you set in the Steady-state relative tolerance edit field, the solution process stops. If 
steady state is not reached within the specified time frame, the solver stops at the 
maximum time. The default relative tolerance for the steady-state condition is 10−9. 
The solver stops when the following expression becomes negative:

You can also actively enter a solution time in the Time stepping area if you know the 
time span of the process. The Times edit field contains a vector of times in seconds for 
which the Reaction Engineering Lab calculates the solution. The default vector is 
0 1e6, which represents times from 0 to 106 s. If you want to make sure that the solver 
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computes the solution for the entire time span, clear the Stop if steady state is reached 

first check box. Note also that you need to clear the Stop if steady state is reached first 
when solving models using the Semibatch and CSTR reactor types, where the initial 
concentration of reactants is zero.

The absolute and relative tolerances control the error in each integration step during 
the time-stepping process. For one dependent variable (solution component), the 
relative error is, roughly stated, less than the relative tolerance if the value of the 
dependent variable is large, and the absolute error is less than the absolute tolerance if 
the value of the dependent variable is small. The Relative tolerance edit field only 
accepts a positive number as input (default = 1e-6). The Absolute tolerance edit field 
accepts two different entries. You can set the Absolute tolerance to a positive number 
(default = 1e-7) or you can specify it as a space-separated list whose entries alternate 
between the name of a dependent variable and a positive scalar. For example, entering 
a sequence like c_a 1e-7 c_b 1e-5 makes it possible to set different absolute 
tolerances for different species, in this case for species a and b.

The Reaction Engineering Lab uses the solver’s internal steps as default for 
postprocessing results, so these time steps are normally independent of the 
intermediate times you specify in the Times edit field. To obtain solution results at the 
times in the Times edit field rather than the solution at the times chosen by the solver, 
go to the Times to store output list and select Specified times.

To control how the solver takes its internal time steps, select the appropriate options 
in the Time steps taken by solver list. For the Free selection, the solver steps are 
controlled by the step length controller, in order to satisfy the tolerance for the 
simulation. If you select Strict, the solver must take a time step at each of the values in 
the Times edit field, and it also adds times in between as necessary. The Strict selection 
is useful when an equation involves transient steps or irregularities that the time 
stepping must not skip. Adding times around each such event ensures that the solver 
resolves them. For the Intermediate selection, the solver must take at least one time step 
in the intervals defined with the list in the Times edit field. 

Selecting the Manual tuning of step size check box just below the Time stepping area 
makes it possible to set the initial internal time step and the upper limit of the internal 
time steps.

In the Advanced area you control additional settings of the time-stepping algorithm. 
The Maximum BDF order edit field (BDF = backward differentiation formula) accepts 
an integer between 1 and 5 that sets the degree of the interpolating polynomial used 
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in the time-stepping method. A smaller value results in a more stable numerical scheme 
at the expense of an increased number of time steps.

Models set up in the Reaction Engineering Lab are often differential-algebraic 
problems. A system of differential-algebraic equations (DAEs) has constraints imposed 
on the initial values, for instance, that an algebraic equation must be satisfied (such as 
the equilibrium relation).

By default the Reaction Engineering Lab makes an initialization of slave species 
concentrations for models that contain equilibrium reactions. For these models, the 
initial concentrations of slave species are computed from the initial concentrations of 
the other (non-slave) species and the equilibrium relations before solving the 
time-dependent problem. The initial concentrations entered for each slave species are 
used as a starting guess when finding the consistent initial concentrations. It may 
sometimes be necessary to change the initial guesses in order to find valid initial 
concentrations. After computing the initial concentrations, the Reaction Engineering 
Lab solves the DAE system over time. Use the Compute initial concentrations for slave 

species check box to manually disable the slave species initialization procedure.

The above procedure ensures that the initial values are consistent for DAE systems 
formed by equilibrium reactions. Other model properties can also result in a DAE 
system, for example, if some species are set to steady state. For such systems the DAE 
solver can perturb the initial values so that they become consistent with the imposed 
constraints. The selection in the Consistent initialization of DAE systems list controls how 
the solver perturbs initial values. Select Backward Euler for index-1 and index-2 DAEs. 
The solver then perturbs the initial values of all degrees of freedom (DOFs) by taking 
a backward Euler step, giving a small perturbation to the differential DOFs. Select On 
for index-1 DAEs. The solver then fixes the values of the differential DOFs (to those 
given by the initial value) and then solves for the initial values of the algebraic DOFs 
and the time derivative of the differential DOFs. When applicable, this selection is 
preferable to Backward Euler because it does not perturb the values of the differential 
DOFs. The default setting is Off, which indicates that the initial values are already 
consistent and that the solver does not need to modify them. This setting is 
recommended for pure ODE systems and DAE systems initialized by computing the 
consistent slave species initial concentrations.

For DAE systems, the selection Exclude algebraic in the Error estimation strategy list 
excludes the algebraic DOFs from the error norm.

By default, the solver stops with an error message when it encounters an undefined 
mathematical operation in an expression that appears in the model settings, for 
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instance, division by zero or square root of a negative number. To change this 
behavior, clear the Stop if error due to undefined operation check box. Then the solver 
treats the result of the operation as Inf (infinity) or NaN (not a number). This feature 
can be useful in a nonlinear problem where the steps in the iterative solution process 
lead to variable values for which an expression is undefined. The solver then reduces 
the step size in the Newton iteration when it encounters Inf or NaN so that it can find 
a solution.

The Reaction Engineering Lab uses a dedicated version of the DAE solver DASPK, 
developed by Dr. Linda Petzold of the University of California, Santa Barbara (Ref. 
12).
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Pa r ame t e r  E s t ima t i o n  S e t t i n g s

In order to use a reaction model to perform system analysis and design, you need to 
know the relevant kinetic parameters. When not available, the parameters can be found 
by properly adjusting the theoretical model so that simulated results match 
experimental data. This process is referred to as parameter estimation.

Typical applications of parameter estimation involves evaluating:

• Rate constants for isothermal systems

• Arrhenius parameters for non-isothermal systems

• Reaction order

• Estimating non-kinetic parameters

You can readily solve such problems within the graphical user interface of the Reaction 
Engineering Lab. When doing so, the work flow often involves the following steps:

• Formulating a reaction model by entering the chemical reactions and selecting a 
reactor type

• Reading experimental data into the graphical user interface

• Associating measured variables with the variables of the reaction model

• Selecting parameters and performing estimation by minimizing the objective 
least-squares function

• Evaluating the ability of the model to represent the experimental data

You find hands-on examples illustrating how to solve parameter estimation problems 
in the section “Model Validation and Calibration” on page 29, as well as more 
extensive examples the Model library.

To set up a parameter estimation problem, select the menu item Estimation>Parameter 

Estimation Settings or click the Parameter Estimation Settings button on the Main 
toolbar.

The Data Page

The Data page provides an overview of the experimental data that has been loaded into 
Reaction Engineering Lab. To import data in the form of text files, click the Import 

From File button. You can also import data structures set up in COMSOL Script by 
clicking the Import From Workspace button. Equivalently, you can load data into the 
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user interface by choosing File>Import>Experimental Data From File or 
File>Import>Experimental Data From Workspace. These two options are described in 
detail in “Importing Experimental Data” on page 135.

You are free to load multiple data into the software. You may further choose to include 
one or more data sets into the parameter estimation calculations.

Figure 3-24: The Parameter Estimation Settings dialog box displaying the Data page.

The names of loaded data sets appear in the Data set selection list. Click the Delete 
button to remove selected data sets from the list. You can also deactivate a data set by 
clearing the associated check box.

The Data page contains the following subpages:

• Variable Mapping

• Init

• Inputs

T H E  V A R I A B L E  M A P P I N G  P A G E

On the Variable Mapping page, the Data selection list displays the names of the columns 
containing the dependent variables of the measured data. Columns of data can be 
deactivated by clearing the check box to the left of the list entry. You can associate the 
measured variables with the reaction model variables by choosing the appropriate entry 
in the Data selection list and then selecting corresponding variable name from the 
Predefined quantities list, as illustrated in Figure 3-24. If a batch reactor type is being 
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modeled, the list contains the concentration variables defined in the Reaction Settings 

dialog. If you are using a plug-flow reactor type, the Predefined quantities list contains 
the species molar flow variables. You can also associate measured and model variables 
by entering a user-defined expression in the Expression edit field.

At the bottom of the Variable Mapping page, you find the Independent data properties 
area. The independent variable of the experimental data set is assumed to be in the first 
column of the data file. For instance, this could be a list of times at which 
measurements have been performed. From the Quantity list you can select Time, 
Residence time or Volume, whichever is appropriate to represent the independent 
variable of the measured data. The appropriate unit of the data is selected from the Unit 
list. Time given in Seconds is the default selection for the batch reactor types and 
reactor Volume in Cubic meters is default for the plug-flow reactor type.

T H E  I N I T  P A G E

You use the Init page when you want the software to account for multiple data sets in 
the parameter estimation calculations, where the initial concentrations of reacting 
species vary among the sets. When parameters other than initial concentrations change 
with data set, then use the Inputs page, as outlined in the following section.

The Init page is deactivated by default. You activate the page by selecting the Advanced 
setting Specify initial state values for data sets.

Note that if you perform parameter estimation using data sets that specify varying 
initial species concentrations, then initial concentrations are assumed to be known 
quantities and cannot be selected as parameters to be estimated.

T H E  I N P U T S  P A G E

You use the Inputs page when parameters other than initial concentrations have 
different values for different data sets. The page contains a list where you can specify 
parameters that vary from set to set. The values of these parameters are known, and 
come to affect the evaluation of the reaction model. Examples of input parameters are 
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the temperature, amount of catalyst, and so on. The parameter names in the list are 
identical to the names of constants or expressions defined in the reaction model.

Figure 3-25: Working with multiple data sets you specify known parameters that vary from 
set to set on the Inputs page.

The Parameters Page

On the Parameters page you select the parameters that you want to estimate. 
Depending on reaction model selections, the Predefined parameters list displays a 
number of default parameters, such as rate constants, Arrhenius parameters, and initial 
concentrations. You can move over to the Parameters to estimate list by selecting 
entries from the Predefined parameters and then clicking the Add button (>) or the Add 

all button (>>). You can also specify user-defined parameter names in the Expression 
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edit field, and add them (>). Remove entries from the Parameters to estimate list by 
clicking the Remove (<) or Remove all (<<) buttons.

Figure 3-26: Specify the parameters to be included in the parameter estimation 
calculation.

In the Initial guess area, you specify an initial guess for each of the parameter values that 
you are about to estimate. By default, the Use value from model radio button is selected. 
This causes the software to use the current value of the parameter specified in the 
reaction model. For example, if you want to evaluate the frequency factor and 
activation energy of an irreversible reaction, the values in the Frequency factor and 
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Activation energy found in the Reaction Settings dialog box will be used as initial 
guesses.

Figure 3-27: Initial guesses for parameter estimation calculations can be taken directly 
from the reaction model.

As an alternative you can select the Specify value and type the initial guess into the 
associated edit field.

The Advanced Page

Advanced page contains settings for the non-linear least squares (NLS) algorithm, used 
for parameter estimation. The settings and default values are:

• Maximum number of iterations in search direction; 50

• Maximum number of iterations in the line search; 50

• Tolerance for the gradient; 1e-6

• Minimum relative decrease in the cost function; 1e-6

• Lower bound for the singular values of the Jacobian; 1e-6

• Confidence level; 0.95
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The value set in the Confidence level edit field determines the confidence interval 
calculated by the software. The default value is 0.95, which indicates that a 95% 
confidence interval is evaluated using the standard normal distribution. Once a 
parameter estimation calculation has been performed, the upper and lower limits of the 
confidence interval are displayed in the Log - Progress window.

Additional settings control how the software handles initial data sets. By default, the 
Specify initial state values for data sets check box is cleared. When this setting is cleared 
and multiple data sets are included in a parameter estimation calculation, it is assumed 
that parameters varying from set to set do not include initial concentrations. Known 
parameters changing with data set are provide on the Inputs page. When Specify initial 

state values for data sets check box is selected, you can use multiple data sets where 
initial concentrations change from set to set. The values are entered on the Init page.

Selecting Copy parameter values to model after parameter estimation automatically 
updates the reaction model with the estimated parameters values. You find the 
calibrated values where the parameters were originally defined. Typically this would be 
in the Reaction Settings dialog box or in the Constants dialog box.

The Solve model after estimating parameters check box is selected by default, and is only 
available if the Copy parameter values to model after parameter estimation is also 
selected. As indicated, the selection automatically solves the reaction model 
immediately after the parameter estimation calculation is completed.

The Log Page

Solving a reaction model or performing a parameter estimation calculation opens the 
Progress window. You can also access this window by selecting either of the menu items 
Simulation>View Log or Estimation>View Log. On the Log page you can see the progress 
of simulation as well as parameter estimation.

The parameter estimation log summarizes the steps of the NLS algorithm, listing the 
loss function and stop conditions. Furthermore, a summary report is generated listing 
the calculated values of estimated parameters, the standard error and the upper and 
lower limits of the confidence interval.

Algorithm for Parameter Estimation

For parameter estimation calculations, Reaction Engineering Lab uses a non-linear 
least squares (NLS) algorithm implementing the Gauss-Newton method.
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P R O B L E M  D E F I N I T I O N  A N D  N O T A T I O N

A general problem formulation is to estimate the parameter in the model:

 (3-95)

In Equation 3-95, x0 denotes the known or unknown initial state vector. θ contains 
the unknown parameters in the model, u is a known input signal, e is a stochastic 
measurement noise, and v is an unknown stochastic input signal.

The general solution can be stated as minimizing the sum of least squares

 (3-96)

The parameter vector η does not have to include all parameters and initial states, but 
rather a subset of them.

 (3-97)

The residual ε is defined component-wise as

 (3-98)

Equation 3-96 is also known as the loss function.

A L G O R I T H M

The Newton-Raphson method for NLS can be stated as iterating

 (3-99)

until convergence. The Jacobian and Hessian in Equation 3-99 are given by

 (3-100)
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 (3-101)

The Gauss-Newton method approximates the Newton-Raphson method with the 
assumption that the second term of the Hessian is an order of magnitude smaller than 
the first term, so that

 (3-102)

The Gauss-Newton method for NLS can thus be stated as iterating

 (3-103)

where µ is the step size. The gradient J is evaluated numerically.

P A R A M E T E R  E S T I M A T I O N  F U N C T I O N S

The parameter estimation functionality available through the Reaction Engineering 
Lab graphical user interface is also available in COMSOL Script. Type help reaction 
at the Script prompt to learn more about structure and functionality of the parameter 
estimation function and objects.

V2 η( )∂
∂η ηT∂
------------------ J η( )JT η( )

η∂
∂ J η( )ε η( )–=

V2 η( )∂
∂η ηT∂
------------------ J η( )JT η( )≈

ηi 1+ ηi µj J ηi( )JT ηi( )( )
1–
J ηi( )ε ηi( )–=
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P l o t  Pa r ame t e r s

Select the menu item Postprocessing>Plot Parameters or the Plot Parameters button to 
bring up the dialog box in Figure 3-28.

Figure 3-28: The Plot Parameters dialog box.

The Solution page

The Predefined quantities list shows variables set up after the solution of a given 
reaction model. By default, it lists the variables for all species’ concentrations, the 
temperature, the reaction rates, the rate expressions per species, and any variable name 
you have entered in the Expressions list. 

The Quantities to plot list shows the variables designated for plotting. When the 
Reaction Engineering Lab solves a reaction model for the first time, it plots all species’ 
concentrations in the main user-interface window. To add variables from the Predefined 

quantities list to the Quantities to plot list, click the Add button, >, or the Add All 
button, >>. Remove variables from the Quantities to plot list by clicking the Remove 
button, <, or the Remove All button, <<. To add more expressions to the Quantities 

to plot list, type them into the Expression edit field just below the Predefined quantities 
list and then click the Add button >. Entries can be arbitrary constants or expressions 
as well as predefined variables in the Reaction Engineering Lab.
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The Start time and End time edit fields let you select a specific time interval in which 
to plot entries in the Quantities to plot list. The zoom tools update this time interval 
when you use them to change the plot.

Click the Line Settings button to bring up the corresponding dialog box. Select the 
desired line color, line style, or line marker settings for the respective plot variables. 
The default settings create solid lines with colors that cycle. Select the Legend check 
box to include a legend of the traces in the plot window. Select the Show labels on lines 
check box to add labels with the names of the plotted quantities on the respective lines.

Back in the Plot Parameters dialog box, click the Title/Axis button to bring up the Title/

Axis Settings dialog box. To overwrite the default axis titles, clear the Auto check box 
and type the desired text into the x label and y label edit fields. Select the Log scale check 
box to change an axis scale from linear to logarithmic.

Selections in the Plot in list let you plot the simulation results in the Main axes of the 
primary user-interface window, in a New figure window, or in an existing figure window 
when applicable. To plot different groups from the Quantities to plot list on top of one 
another, select the Keep current plot check box. To plot experimental data points on 
top of an existing plot, select the Plot experimental data check box. This last check box 
is available only if you have already read external data into the user interface with the 
menu selection File>Import>Experimental Data. Further information on how to import 
data into the Reaction Engineering Lab appears in the following section.
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The Experimental Data Page

The Data sets to plot list shows the file names of all data sets currently loaded into the 
software. The check box immediately to the left of the data set name allows you to 
activate the or deactivate the plotting of the indicated data set.

Figure 3-29: Control the plotting of data sets from the Experimental Data page.

The Marker settings of each data set can be changed with respect to Marker color and 
Marker type. You can also select to show the Legend associated with each set.

Zooming Into the Plots

To zoom into an interesting section of the plot, use the Zoom Horizontal toolbar 
button. It provides an easy way to select a start time and end time for the plot. Until 
you start a new model, the Reaction Engineering Lab keeps the selected time span 
unless you click the Zoom Extents button to get the full time span (or use any of the 
other zoom tools).
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Impo r t i n g  CHEMK IN F i l e s

The Reaction Engineering Lab can import CHEMKIN files to simulate complex 
chemical reactions in the gas phase (Ref. 13). These input files contain three basic sets 
of information:

• Chemical kinetics

• Species thermodynamic properties

• Species transport properties

The Reaction Engineering Lab can use the imported data to:

• Set up and solve mass and energy balances for ideal reactor systems (batch reactors, 
semi-batch reactors, CSTRs, and plug-flow reactors)

• Set up and evaluate species transport properties as a function of reactor conditions

• Set up and mass, energy, and momentum balances for space-dependent models, and 
export them to COMSOL Multiphysics

It is possible to read the input files for kinetics, thermodynamic, and transport 
properties independently and use them as separate data resources. For instance, if you 
have entered a set of reactions into the Reaction Engineering Lab’s graphical user 
interface, you can supply species thermodynamic and transport data by reading the 
appropriate input files. The full functionality of the Reaction Engineering Lab is 
retained even after the import procedure. This means that all expressions and all data 
imported into the software are available for reference and for editing in the GUI.

Data files describing reaction kinetics, species thermodynamics, and species transport 
properties are published on the World Wide Web and are readily available (Ref. 14).
R  3 :  T H E  M O D E L I N G  E N V I R O N M E N T



Impo r t i n g  K i n e t i c s  F i l e s

The Reaction Engineering Lab can import and interpret the data contained in 
CHEMKIN input files describing gas-phase kinetics.

To import a kinetics file, select the menu item File>Import>CHEMKIN Kinetics Input File. 
Reading a kinetics file is equivalent to creating a new reaction model, and you are 
therefore prompted to save the model to the file you are currently working with. When 
the Import CHEMKIN Kinetics Input File dialog box opens up, browse to the desired file 
and click the Import button. To view the imported set of reactions, click the Reaction 

Settings button on the Main toolbar.

U N I T S

The Reaction Engineering Lab interprets unit keywords contained in kinetics input 
files and automatically performs a conversion to SI units upon import.

S Y M B O L S  A N D  S P E C I E S  L A B E L I N G

The notation used for different reaction types in both the Reaction Engineering Lab 
and CHEMKIN input overlap to a large degree:

Note, though, that the Reaction Engineering Lab interprets the = delimiter in a 
CHEMKIN input file as a marker for a reversible reaction, replacing the delimiter with 
<=> in the graphical user interface. In the Reaction Engineering Lab, the = delimiter 
is reserved for reactions of the equilibrium type (see the section The Kinetics Page on 
page 75).

The Reaction Engineering Lab can read any species labels used in a kinetics input file. 
Once the file has been imported, the chemical species, as indicated by their respective 
label, are displayed in the Reaction Settings dialog box in the Reaction selection and 
Species selection lists.

To make the representation of expressions and variable names as compact as possible, 
the Reaction Engineering Lab automatically assigns associated species labels based on 
their position in the Species selection list. For the position i in the Species selection list, 

SYMBOL REACTION ENGINEERING LAB CHEMKIN INPUT

=> irreversible irreversible

<=> reversible reversible

= equilibrium reversible
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the assigned name is simply si (species i). The species variable and parameter names 
are in turn indexed with this label.

Figure 3-30 illustrates automatic species and parameter naming. Here H2O2 is the 
species name imported from the CHEMKIN input file. When the reactions are 
imported, the Reaction Engineering Lab automatically creates the Species selection list, 
in this case with H2O2 placed in position 7. The associated species name is 
subsequently set to s7, with parameters and variables using this label as an index. When 
you position the cursor over an edit field’s name, the corresponding variable name is 
displayed as a tooltip. In the figure, the H2O2 has the variable name M_s7 assigned to 
the molecular weight.

Figure 3-30: The position in the Species selection list is used to create a species label that 
appears in parameters and variable names.

The species labels M and (+M) that occur in kinetics files have special significance. M 
refers to a third body species that takes part in a reaction without being consumed:

 (3-104)

The presence of (+M) in a reaction indicates that the effect of the third body is pressure 
dependent:

O OHM+ M+H+
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 (3-105)

As an example, the reaction between oxygen and carbon monoxide occurs in the 
absence of a third body at high pressures, while at low pressures a third body is 
required for the reaction to proceed. 

The third body represents all species in the reaction mixture. As a consequence, there 
is no separate M species generated in the Species selection list. The effect of the third 
body is rather seen on rates of the reactions where M is present (see Kinetics 
Expressions in the following section).

Kinetic Expressions

Both the Reaction Engineering Lab and a CHEMKIN kinetics input make use of the 
mass-action law to specify the rate of a generic chemical reaction (mol/(m3·s)):

.  (3-106)

Here, and denote the forward and reverse rate constants, respectively, ci is the 
concentration of species i (mol/m3), and νij are stoichiometric coefficients. νij are 
defined as being negative for reactants and positive for products.

By default, a CHEMKIN input specifies the forward rate constant by supplying the 
corresponding Arrhenius parameters , , and  to the equation

.  (3-107)

The standard way to calculate the reverse rate constant is using the relationship

.  (3-108)

In this equation,  is the equilibrium constant expressed in concentration units 
(mol/m3). The equilibrium constant given in pressure units (atm) can be evaluated 
from the NASA thermodynamic polynomials (Ref. X):

 (3-109)
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.  (3-110)

The thermodynamic polynomials required to evaluate Equation 3-107 are predefined 
in the Reaction Engineering Lab, and the requisite coefficients are imported from a 
thermodynamics file (see the section Importing Thermodynamics Files on page 129). 

The kinetics expressions just given can be identified directly in the Reaction 
Engineering Lab user interface. As illustrated in Figure 3-31, you find Equation 3-106 
represented in the Reaction rate edit field, Equation 3-107 in the Forward rate constant 
edit field, Equation 3-108 in the Reverse rate constant edit field, and Equation 3-110 
in the Equilibrium constant edit field.

Figure 3-31: All kinetics parameters and rate expressions are presented in the Reactions 
interface of the Reaction Settings dialog box.

T H I R D  B O D Y  R E A C T I O N S

A reaction containing the species M indicates that a third body takes part in the 
reaction without being consumed in the process (see, for example, Equation 3-104). 
The third body species represents all species present in the reacting mixture, leading to 
the following expression for the reaction rate:

K0 j,
eq Kp j,

eq p0
RgT
-----------⎝ ⎠
⎛ ⎞

νij

i

∑
=

R  3 :  T H E  M O D E L I N G  E N V I R O N M E N T



 (3-111)

where

 (3-112)

The second factor on the right-hand side of Equation 3-111 is the default reaction rate 
(Equation 3-106). The factor ceff corresponds to the total concentration of the 
reacting gas. The parameter bij is the species efficiency factor, taking into account that 
certain species act more efficiently as third bodies. Expressions taking the form of 
Equation 3-112 are automatically set up in the Reaction rate edit field if a third body 
reaction is imported from a file.

P R E S S U R E - D E P E N D E N T  T H I R D  B O D Y  R E A C T I O N S

A reaction containing the species (+M) indicates a pressure-dependent third body 
reaction.

In a first class of pressure-dependent kinetics, a reaction occurs in the absence of a third 
body at high pressures, while a third body is required for the reaction to proceed at 
low pressures (unimolecular/recombination fall-off reactions). A reaction of this class 
is indicated by the LOW keyword in a CHEMKIN kinetics file (see the section 
Supported Keywords on page 126). 

Consider an example:

At high pressure, oxygen and carbon monoxide react directly:

At low pressure, a third species promotes the reaction:

In the Reaction Engineering Lab and in the kinetics input files, the two reactions are 
summarized using the symbol (+M):

Separate Arrhenius parameters are required for both the high-pressure region,

rj ceff kj
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 (3-113)

and the low-pressure region,

.  (3-114)

The rate constant at any pressure is given by

 (3-115)

where the reduced pressure is expressed as

.  (3-116)

The Arrhenius parameters for the high-pressure region are imported into the 
Reactions/Kinetics page in the Frequency factor, Temperature exponent, and Activation 

energy edit fields. The Arrhenius parameters for the low-pressure region are directly 
used to set up an expression equivalent to Equation 3-114. The complete expression 
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for the rate constant (Equation 3-115) is presented in the Forward rate constant edit 
field.

Figure 3-32: The full expression for a pressure-dependent rate constant is presented in the 
Forward rate constant edit field.

The expression for F in Equation 3-115 can have three different forms describing the 
blending of and k0. The selection of the blending function, F, is indicated in 
kinetics files by the appropriate keyword along with the requisite set of function 
parameters. The Reaction Engineering Lab supports the following descriptions of F:

• Lindemann (Ref. 15):

 (3-117)

• Troe (Ref. 16):

 (3-118)

where

 (3-119)

 (3-120)
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 (3-121)

 (3-122)

• SRI (Ref. 17):

 (3-123)

.  (3-124)

In a second class of pressure-dependent kinetics, a reaction occurs in the absence of a 
third body at low pressures, while a third body is required for the reaction to proceed 
at high pressures (chemically activated bimolecular reactions). A reaction of this class 
is indicated with the HIGH keyword in a kinetics file (see the section Supported 
Keywords on page 126).

Pressure-dependent rate constants are set up in a similar fashion as just explained. 
Separate Arrhenius coefficients are provided for the high- and low-pressure limits with 
the transition between the two regimes being described by the same blending 
functions F. The Arrhenius parameters for the low-pressure region are imported into 
on the Reactions/Kinetics page in the Frequency factor, Temperature exponent, and 
Activation energy edit fields, and the complete expression for the rate constant appears 
in the Forward rate constant edit field.

Supported Keywords

CHEMKIN kinetics files can include auxiliary reaction data that serve to modify the 
the standard format of kinetic expressions. Auxiliary reaction data is indicated in the 
input file with specific keywords. The Reaction Engineering Lab supports the 
following keywords:

•  REV

•  FORD

•  RORD

•  DUPLICATE

•  LOW
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•  HIGH

•  TROE

•  SRI

S P E C I F I E D  R E V E R S E  R E A C T I O N S

The REV keyword in a kinetics input file signals that the Arrhenius parameters are 
specified for the reverse rate constant in addition to the parameters for the forward 
reaction. In such a case, the Reaction Engineering Lab imports these parameters into 
the corresponding edit field (Aj

r, nj
r, and Ej

r) and provides an expression in the 
Arrhenius form in the Reverse rate constant edit field:

 (3-125)

Figure 3-33: When importing a kinetics file containing the REV keyword, the Reaction 
Engineering Lab describes the reverse rate constant using an Arrhenius expression.

S P E C I F I E D  R E A C T I O N  O R D E R

The FORD and RORD keywords indicate that the reaction rate does not follow the 
mass-action law, that is, the reaction order with respect to a species is different than the 
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absolute value of the stoichiometric coefficient of that species in the specified reaction. 
In the kinetics input file, each occurrence of the FORD or FORD keyword is followed by 
a species name and a number that indicates the new reaction order. The Reaction 
Engineering Lab adjusts for the new reaction order directly in the reaction rate 
expression, which it displays in the r edit field.

D U P L I C A T E  R E A C T I O N S

The keyword DUPLICATE (DUP) is used in kinetics files for each identical occurrence of 
a reaction formula. This feature accounts for the fact that two or more reactions have 
the same reaction mechanism but different rate parameters. The Reaction Engineering 
Lab can import any number of identical reaction formulas.

P R E S S U R E  D E P E N D E N T  R E A C T I O N S

In a kinetics input file, the LOW keyword signals a reaction that is pressure dependent 
at low pressures (unimolecular/recombination fall-off reactions). The Arrhenius 
coefficients on the reaction line are for the high-pressure limit, while the Arrhenius 
parameters on the auxiliary information line are for the low-pressure limit. 

In contrast, the HIGH keyword indicates a reaction that is pressure dependent at high 
pressures (bimolecular/recombination reactions). The Arrhenius coefficients on the 
reaction line are for the low-pressure limit, while the Arrhenius parameters on the 
auxiliary information line are for the high-pressure limit.

Additional keywords specify the form of the blending function, F. A Troe pressure 
dependence is set up if the LOW or HIGH keyword is followed by the TROE keyword 
along with three or four parameters (a, T***, T*, and T**). A SRI pressure 
dependence is set up if the LOW or HIGH keyword is followed by the SRI keyword 
together with three or five parameters (a, b, c, d, and e). If no additional keyword 
follows LOW or HIGH, then a Lindemann pressure dependence is assumed. For further 
reading on the blending function F, see the section Kinetic Expressions on page 121.
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Impo r t i n g  Th e rmodynam i c s  F i l e s

The Reaction Engineering Lab can import and properly interpret the data contained 
in CHEMKIN input files describing the thermodynamic properties of gas-phase 
species.

To import a kinetics file, select the menu item File>Import>CHEMKIN Thermo Input File. 
When the Import CHEMKIN Thermo Input File dialog box opens up, browse to the 
desired file and click the Import button.

The amount of data that the Reaction Engineering Lab imports from a 
thermodynamics file depends on the number of entries in the Species selection list. If 
the list is empty, it imports all the data from the thermo file and creates the 
corresponding new species entries. If the Species selection list already has entries, the 
Reaction Engineering Lab uses the species labels to identify entries in the 
thermodynamics file, and it then imports only the corresponding species data.

Because the Reaction Engineering Lab can read thermodynamics files separately 
without the prior import of a kinetics file, the files can be used as data resources for 
user-defined chemistries.

A CHEMKIN thermodynamic input file contains mainly sets of coefficients used to set 
up thermodynamic polynomials in the format of Gordon and McBride (Ref. 5). These 
polynomials describe the species heat capacity (J/(mol·K)), enthalpy (J/mol), and 
entropy (J/(mol·K)), at standard state:

 (3-126)

 (3-127)

 (3-128)

Each species in the thermo file is associated with seven polynomial coefficients (a1 – 
a7) for two temperature intervals. Once you have imported the file into the Reaction 
Engineering Lab, the thermodynamic coefficients for the respective temperature 
interval appear on the Thermo page that appears on the Species interface. Furthermore, 
Equation 3-126 appears in the Heat capacity edit field, Equation 3-127 in the Molar 

enthalpy edit field, and Equation 3-128 in the Molar entropy edit field.
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Figure 3-34: The NASA thermodynamic polynomials and the associated coefficients 
appear on the Thermo page in the Species interface.

From the species thermodynamic data and the stoichiometry, the Reaction 
Engineering Lab automatically sets up the related thermodynamics for chemical 
reactions, that is, the enthalpy of reaction (J/mol)

 (3-129)

the entropy of reaction (J/(mol·K))

 (3-130)

and the heat source of reaction (J/(m3·s))

 (3-131)

It presents these expressions on the Thermo page of the Reactions interface.

Hj νijhi

i
∑=

Sj νijsi

i
∑=

Qj H– jrj=
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Figure 3-35: The reaction thermodynamic expressions appear on the Thermo page in the 
Reactions interface.

As noted previously, the reaction thermodynamic expressions can, in turn, be used to 
describe the equilibrium constant. The Gibbs free energy of reaction is

 (3-132)

and hence

 (3-133)

A thermodynamics input file also contains information about the atomic composition 
associated with a given species label. Upon importing a file, the Reaction Engineering 
Lab uses this information to calculate the species molecular weight (kg/mol), which 
appears in the Molecular weight edit field on the Species/General page.

Some kinetics input files might be appended with the species thermodynamic data. In 
these instances, reading the kinetics files imports both kinetics and thermodynamic 
data into the Reaction Engineering Lab.
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You can read more about the thermodynamic expressions defined in the Reaction 
Engineering Lab in the section The Thermo Page on page 89.
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Impo r t i n g  T r a n s po r t  F i l e s

The Reaction Engineering Lab can import and properly interpret the data contained 
in CHEMKIN input files describing the transport properties of gas-phase species.

To import a kinetics file, select the menu item File>Import>CHEMKIN Transport Input 

File. When the Import CHEMKIN Transport Input File dialog box opens up, browse to the 
desired file and click the Import button. 

The amount of data that the Reaction Engineering Lab imports from the transport file 
depends on the number of entries in the Species selection list. If the list is empty, all 
data from the transport file is imported and the software creates the corresponding 
new species entries. If the Species selection list already has entries, the Reaction 
Engineering Lab uses the species labels to identify entries in the transport file, and it 
imports only the corresponding species data.

Because the Reaction Engineering Lab can read transport files separately without the 
prior import of a kinetics file, you can use these files as data resources for user-defined 
chemistries.

Figure 3-36: Species transport expressions along with the associated interaction potential 
parameters are given on the Transport page in the Species interface.
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Each species in a transport file is associated with a data set of six parameters. From this 
file the Reaction Engineering Lab extracts the energy minimum of the Lennard-Jones 
potential well, ε/kb (K), the Lennard-Jones characteristic collision length, σ (10−10 m), 
and the dipole moment of each species, µ (Debye). As illustrated in Figure 3-36, you 
find the imported values on the Transport page in the Species interface.

The Reaction Engineering Lab makes use of the imported parameters to set up 
expressions for a set of transport properties. Binary diffusion coefficients (m2/s) are 
calculated according to

 (3-134)

The dynamic viscosity (Ns/m2) is given by

 (3-135)

and the thermal conductivity (W/(m·K)) is expressed as

.  (3-136)

Predefined expressions corresponding to Equation 3-134, Equation 3-135, and 
Equation 3-136 are provided in the Transport expressions area of the Transport page.

You can read more about the thermodynamic expressions defined in the Reaction 
Engineering Lab in the section “The Transport Page” on page 95.
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Impo r t i n g  Exp e r imen t a l  Da t a

You can load experimental data to the Reaction Engineering Lab workspace in two 
different ways. The simplest way is to import data from a file, which you do by 
choosing File>Import>Experimental Data From File. The data file has to be organized in 
columns. The first column represents the sample time and the subsequent columns 
represent the samples concentrations or temperature. Elements in different columns 
can be separated by tabs or spaces. The first row in every column has to contain a string 
with the label of the corresponding measured entity. The contents of the string is used 
in the legend when plotting in the Reaction Engineering Lab. The following table 
shows an example of a data file on the required format for a system with species A and 
B measured at different times t:

Once you have loaded the data into the Reaction Engineering Lab workspace, you can 
plot it by choosing Postprocessing>Plot Parameters and then selecting the Plot 

experimental data check box in the Plot Parameters dialog box.

The second way of loading experimental data to Reaction Engineering Lab is to import 
the data from the COMSOL Script workspace as a structure. You can do this by 
selecting File>Import>Experimental Data from Workspace. With this feature, you can use 
COMSOL Script to organize sets of external data points in a structure variable that the 
Reaction Engineering Lab can read. The data structure has a similar format as the data 
files: The first field is the vector x, typically containing times at which measurements 
have been performed. The second field is a matrix y, whose columns typically contain 
concentrations of a species measured at the times specified in x. The third field, 
legend, contains a cell array of strings of the same size as the number of columns in y; 
the string contents are displayed as trace legends when the Reaction Engineering Lab 
plots the data. Using the previous example, you then organize the structure as follows:

't' 'c_A' 'c_B'

60 5.0 4.1

120 3.5 6.5

180 1.1 7.0

240 0 7.1

300 0 5.0
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1 Create a column vector of the experimental time data:

t=[60 120 180 240 300]'

2 Create a matrix of the experimental concentration data, with each column vector 
corresponding to the concentrations of a given species:

c=[[5 3.5 1.1 0 0]' [4.1 6.5 7 7.1 5]']

3 Create a structure variable expdata and defined the x and y fields:

expdata.x=t;
expdata.y=c;

4 Add trace labels with the legend field:

expdata.legend={'cA data','cB data'};

5 In the Reaction Engineering Lab, select the menu item File>Import>Experimental 

Data from Workspace, then in the Experimental data dialog box enter expdata.

6 To plot the data, open the Postprocessing>Plot Parameters dialog box and select the 
Plot experimental data check box.
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Expo r t i n g  R e a c t i o n  Mode l s

The Reaction Engineering Lab sets up models for species that are reacting in ideal 
reactor systems. It describes material and energy balances with a system of ordinary 
differential equations (ODEs) that, when solved, shows the evolution of species 
concentrations and system temperatures over time or as a function of one space 
variable.

At times, you may want to perform an extended analysis of the reaction model, going 
beyond the functionality of the Reaction Engineering Lab. For instance, to study how 
a reacting system’s detailed geometry impacts the concentration and temperature 
distributions, you can export a reaction model to COMSOL Multiphysics, where the 
space- and time-dependent model can be set up and solved. As another option, you 
export a reaction model to the COMSOL Script environment. In Script, you can for 
instance run parametric studies or perform advanced postprocessing. The following 
sections describe both of these options.

Export to Application Modes in the Chemical Engineering Module

An application mode in COMSOL Multiphysics is a predefined modeling interface 
describing a specific type of phenomenon. For instance, chemical engineering type 
problems typically involve mass, energy, and momentum transport, and you find the 
corresponding classes of application modes in COMSOL Multiphysics. You can export 
reaction models set up in the Reaction Engineering Lab to application modes of the 
Chemical Engineering Module, the MEMS Module, and the Earth Science Module. 
Expressions generated in the Reaction Engineering Lab, describing reaction kinetics, 
thermodynamics and transport properties, are inserted automatically into relevant edit 
fields of the application modes, thus greatly simplifying the modeling of reacting 
systems. 

You can export your reaction models to one or more of the following application 
modes:

• Diffusion

• Convection and Diffusion

• Maxwell-Stefan Diffusion and Convection

• Nernst-Planck

• Electrokinetic Flow
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• Solute Transport

• Conduction

• Convection and Conduction

• Conduction in Porous Media

• Convection and Conduction in Porous Media

• Incompressible Navier-Stokes

• Weakly Compressible Navier-Stokes

• General Laminar Flow

Once you have exported to COMSOL Multiphysics you can add any other application 
mode in to include effects of, for example, electric fields for electrochemical systems. 
You can do this for any model geometry in 1D, 1D axial symmetry, 2D, 2D axial 
symmetry, or 3D.

To export a reaction model to COMSOL Multiphysics, first go to the Main menu and 
select File>Export>Model to COMSOL Multiphysics or click the corresponding quick 
button on the Main toolbar. This will launch COMSOL Multiphysics if it is not already 
running. A dialog box prompts you for the space dimension of the transport model: 
1D, 1D axial symmetry, 2D, 2D axial symmetry, or 3D (Figure 3-37).

Figure 3-37: To export reaction models to COMSOL Multiphysics, that program must be 
running. It first prompts you for the space dimension of the multiphysics model.
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After selecting a space dimension, the Export to COMSOL Multiphysics dialog box appears 
(Figure 3-38).

Figure 3-38: The Export to COMSOL Multiphysics dialog box contains selections for the 
export of reaction models to applicable application modes of the Chemical Engineering 
Module.

At the top of this dialog box, the Geometry list shows the geometries available in the 
current multiphysics model. Note that if you are creating a new multiphysics model, 
only one geometry, with the dimensions that you selected in the Start COMSOL 

Multiphysics dialog box, is available in the Geometry list.

You can include several geometries in a model if you want to model several coupled 
reacting systems to model, for example, cascade coupled reactors. The export of a 
given reaction model is always associated with a specific geometry, but you can run 
multiple exports from the Reaction Engineering Lab to set up a model with several 
geometries. This also allows you to define different reaction settings in different 
geometries in a model.
E X P O R T I N G  R E A C T I O N  M O D E L S  |  139



140 |  C H A P T E
The Domain level list contains the choices Subdomain, Boundary, and Interior Boundary. 
Your selection determines if the application mode is exported to a subdomain group 
or a boundary group. The boundary conditions are different on interior boundaries 
than on the exterior boundaries. They therefore require a separate boundary group. 
For the exterior boundaries, select Boundary in the Domain level list. You can run 
multiple exports if you want to use different reaction sets in different subdomains or 
at different boundaries.

The Export mass balance area consists of the Settings, the Species Mapping, and the 
Variables pages. The Settings page contains the Application mode list with these choices:

• Diffusion

• Convection and Diffusion

• Nernst-Planck

• Electrokinetic Flow

• Maxwell-Stefan Diffusion and Convection

• Solute Transport

Selecting a new application mode, for example, Diffusion:New in the Application mode 
list, creates an application mode with the name you provide in the 
Application mode name edit field, and it associates exported groups with that mode. 
You can also select an already existing application mode from the Application mode list. 
Regardless of if you are selecting a new or existing application mode, you can enter any 
name in the Group name edit field. You can use different groups to simulate different 
kinetics models using the same application mode.

Click the Species Mapping tab to display the names of the species in the Reaction 
Engineering Model and the corresponding names of the dependent variables in the 
COMSOL Multiphysics application mode. To export a group to an existing 
application mode you can map the species concentration in the Reaction Engineering 
Lab model on the existing names for the species concentration in the active application 
mode running in COMSOL Multiphysics. For reaction models containing equilibrium 
reactions, the slave species selection must also be the mapped to the corresponding 
slave concentration in the COMSOL Multiphysics application mode.

All mass balance application modes except Maxwell-Stefan Diffusion and Convection 
use the default variable names according to the syntax c_speciesname, referring to 
species concentrations in mole per volume. When exporting to the Maxwell-Stefan 
application mode, the default variable name follows the syntax w_speciesname, 
referring to the species weight fraction. The Reaction Engineering Lab automatically 
R  3 :  T H E  M O D E L I N G  E N V I R O N M E N T



calculates initial weight fractions of the reaction model from the initial concentrations 
and molecular weights you enter on the Species>General page. 

An additional consideration of the Maxwell-Stefan Diffusion and Convection 
application mode is the order of the species in the Species Mapping page. For this 
application mode, the Reaction Engineering Lab eliminates the mass balance of the last 
species variable in the setup of the mass balance equations. You can rearrange the order 
of entries in the Species Mapping page by right-clicking on the name of the species in 
the Species selection list and then selecting Move Up or Move Down.

Click the Variables tab (the third tab in the Export mass balance area) to view a list of 
variables for export, which are not available elsewhere in the user interface. In general, 
these variables are not used for modeling in the Reaction Engineering Lab but are 
necessary for modeling in the Chemical Engineering Module. The listed expressions 
depend on the selection in the Application mode list. For instance, expressions for 
binary diffusion coefficients (Equation 3-81) appear when you choose the 
Maxwell-Stefan Diffusion and Convection application mode.

Now move on to the Export energy balance area, which consists of the Settings page and 
the Variables page. The Settings page contains the Application mode list, which contains 
the application modes:

• Conduction

• Convection and Conduction

• Conduction in Porous Media

• Convection and Conduction in Porous Media

The list of dependent variables is here seen in the Settings page, but otherwise the 
structure of the Export energy balance area is analogous to that of the Export mass 

balance area above. Expressions listed on the Variables page depend on your choice in 
the Application mode list. For reacting multicomponent mixtures, the following 
mixture properties are defined:

• density (kg/m3)

 (3-137)

• heat capacity (J/(kg·K))

ρfluid
p

RgT
-----------  

i
∑ xiMi=
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 (3-138)

• thermal conductivity (W/(m·K)) as described in Ref. 18

 (3-139)

In these equations, ρ denotes density (kg/m3), p pressure (Pa), T temperature (K), x 
mole fraction, M molecular weight (kg/mol), cp heat capacity per unit mass (J/
(kg·K)), Cp represents the heat capacity per mole (J/(mol·K)), and k the thermal 
conductivity (W/(m·K)).

The third and final area in the Export to COMSOL Multiphysics dialog box is the Export 

momentum balance area, which again consists of the Settings and the Variables pages.

Note: The export of momentum balances is available for 2D and 3D geometries.

This area’s functionality is the same as for the Export energy balance area described 
earlier. The expressions listed on the Variables page depend on your selection in the 
Application mode list. You can set up the following application modes:

• Incompressible Navier-Stokes

• Weakly compressible Navier-Stokes

• General Laminar Flow

Once the Incompressible Navier-Stokes application mode is exported to COMSOL 
Multiphysics, you can convert this application mode into any of the Brinkman 
Equations, k-ε Turbulence Model, or k-ω Turbulence Model application modes. 
Choose the proper settings in the Application Mode Properties dialog, found by 
selecting Properties under the Physics menu in COMSOL Multiphysics.

If you are modeling solutions with nonconstant density, you should select the Weakly 
compressible Navier-Stokes application mode, even when your system is isothermal. 
For reacting multicomponent mixtures, the following mixture properties are defined:

• density (kg/m3)
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• viscosity (Ns/m2); from Ref. 19

 (3-141)

where

 (3-142)

In these equations η denotes the dynamic viscosity (Ns/m2).

If you only want to export mass balances with one or none of the energy and 
momentum balances, clear one or both of the check boxes in the upper corners of the 
Export energy balance and Export momentum balance areas to obtain the desired export 
combination.

Export to the COMSOL Script Workspace

You can export a model to the COMSOL Script workspace to run models from the 
command line, perform parametric studies and advanced postprocessing, or to 
calibrate and validate a model using experimental data.

Reaction models are exported to the COMSOL Script workspace in the form of a data 
structures, denoted REL structures. A data structure is an array of containers for a set 
of fields, which you can access with a dot notation. Choose File>Export>REL Structure 

as ‘rel’ to export the current reaction model as a REL structure called rel. If you want 
to specify the name of the exported REL structure, choose File>Export>REL Structure.

Select Export>Simulation data to export the output from a simulation in the Reaction 
Engineering Lab to the COMSOL Script workspace. The simulation results are stored 
in a data structure with three fields, on the following predefined format: The first field 
is the vector x, typically containing simulation times at which results were stored. The 
second field is a matrix y, whose columns typically contain simulation results evaluated 
at the times specified in x. The third field, legend, contains a cell array of strings of 
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the same size as the number of columns in y. Note that the data structure for export 
of simulation data has the same format as the structure for loading experimental data.

Exporting Images

To export the current plot as an image select the menu item File>Export>Image. Using 
the Export Image dialog box, you can control font sizes, line widths, and what to 
include in the image you export. To speed up the image-generation process, a preview 
feature and image rendering information are available.

Figure 3-39: The Export Image dialog box.

In the Output format area, click the Bitmap graphics button to export an image using a 
bitmap-based formats such as TIFF and JPEG. You select the format after clicking the 
Export button. Click the Vector graphics button to save the image as an EPS file 
(Encapsulated PostScript).

In the Image size area, you can specify the size of the image. Select the unit from the 
Units list: inches, centimeters, or pixels (pixels are available for bitmap graphics only).

When using inches or centimeters, you can set the size using the Width, Height, and 
Resolution (dpi) edit fields. When you use pixels as the unit, the Resolution (dpi) edit 
field is not available
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The settings in the Font scale and Line scale areas affect the scaling between the plot’s 
size on the screen and the size in the image (size = number of pixels):

• Click Auto to use the global scale (you see its value in the Image rendering information 
area, it is the scale between the size of the plot on screen and the size of the image) 
if you specify the size in pixels (the software scales text, lines, and other graphics 
equally). If you specify the size in centimeters or inches, the automatic scale is based 
on the resolution that you. The font size and line width that you specify when 
creating the plot should be preserved if you export an image using a certain 
resolution in dpi (dots per inch) and import it to a document as an image using the 
same dpi number (a text with a certain size in the plot will look like a text with the 
same size in the document).

• Click Relative scale to use a total font scale that is the automatic scale times the 
relative scale that you specify.

• Click Absolute scale to use a total font scale that is equal to the absolute scale that 
you specify.

The following settings are available in the Rendering options area:

• Select the Antialiasing check box to reduces stairstep-like lines (jaggies) and makes 
lines and edges look smooth

• Select the Include Only Plot check box to include only the graphics objects in the 
drawing area, excluding colorbars, axes, tick marks, titles, and labels.

• Select the Include Colorbars and Legends check box to include colorbars and legends, 
if present.

• Select the Automatic axis tick marks check box to take advantage of a new feature 
that can hide axis tick marks if they overlap. Clear this check box if you want make 
sure that the image has the same axis tick marks as you see on the screen.

• Select the Thin grid lines check box to render thin grid lines compared to other lines 
in the image. Use this option if you think that the grid is too dominating in the 
image.
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I n t r o du c t i o n

Model Library Guide

The table below summarizes key information about the models in the Model Library 
chapter and Modeling Strategy chapters of this manual.

TABLE 4-1:  COMSOL REACTION ENGINEERING LAB MODEL LIBRARY

MODEL PAGE COMSOL SOFTWARE 
COMBINATION

M
A

S
S

 B
A

L
A

N
C

E

E
N

E
R

G
Y

 B
A

L
A

N
C

E

M
O

M
E

N
T

U
M
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A
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A

N
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H

E
M

K
IN

 I
M

P
O

R
T

E
X
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O

R
T

 T
O

 S
C

R
IP

T

E
X

P
O

R
T

 T
O

 M
U

L
T

IP
H

Y
S

IC
S

MODEL NAME

Isothermal HI 
Reactor

9 Reaction 
Engineering Lab

 √ 

Nonisothermal HI 
Reactor

15 Reaction 
Engineering Lab

 √  √ 

Space-dependent HI 
Reactor

23 Reaction 
Engineering Lab

Chemical 
Engineering Module

 √  √  √ 

Parameter Estimation 
Isothermal

30 Reaction 
Engineering Lab

 √   

Parameter Estimation 
Nonisothermal

35 Reaction 
Engineering Lab

 √   

Parameter Estimation 
Reaction Order

41 Reaction 
Engineering Lab

 √   

Parameter Estimation 
CO Adsorption

44 Reaction 
Engineering Lab

 √    

DNA Degradation 154 Reaction 
Engineering Lab

Script

 √  
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Drug Release 163 Reaction 
Engineering Lab

Chemical 
Engineering Module

 √  √ 

Enzyme Inhibition 180 Reaction 
Engineering Lab

√ 

Ozone Combustion 187 Reaction 
Engineering Lab

Chemical 
Engineering Module

 √  √  √  √ 

Diesel Filter 205 Reaction 
Engineering Lab

Chemical 
Engineering Module

 √  √  √   √ 

NOx Reduction 234 Reaction 
Engineering Lab

Chemical 
Engineering Module

 √  √ √  √ 

Compression Ignition 258 Reaction 
Engineering Lab

 √  √  √ 

Pesticide Transport 271 Reaction 
Engineering Lab

Earth Science 
Module

√ √ √ 

Oscillating Reactions 289 Reaction 
Engineering Lab

Script

 √   √ 

Pressure-Time Data 
in Parameter 
Estimation

305 Reaction 
Engineering Lab

√ 
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Microbial Growth 312 Reaction 
Engineering Lab

Script

 √   √ 

Tortuous Reactor 320 Reaction 
Engineering Lab

MEMS Module

√ √ √ 

Ibuprofen Synthesis 336 Reaction 
Engineering Lab

 √  

Protein Adsorption 347 Reaction 
Engineering Lab

Chemical 
Engineering Module

 √  √ 

Chlorine Scrubber 359 Reaction 
Engineering Lab

 √ 

Non-Isothermal 
Plug-Flow

367 Reaction 
Engineering Lab

 √  √  √ 

Semibatch 
Polymerization

380 Reaction 
Engineering Lab

 √   

CSTR Startup 388 Reaction 
Engineering Lab

 √  √   

Fluid Catalytic 
Cracking

399 Reaction 
Engineering Lab

√ 

Carbon Deposition 408 Reaction 
Engineering Lab

Chemical 
Engineering Module

√ √ √ 

Pentaerythritol 
Kinetics

430 Reaction 
Engineering Lab

 √   
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Cinnamaldehyde 
Hydrogenation

442 Reaction 
Engineering Lab

√ 

GaAs CVD 453 Reaction 
Engineering Lab

Chemical 
Engineering Module

 √  √  √    √ 

TABLE 4-1:  COMSOL REACTION ENGINEERING LAB MODEL LIBRARY
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Deg r ad a t i o n o f  DNA i n  P l a sma

Introduction

Biotechnology is a rapidly growing area in the pharmaceutical sciences. One example 
of a clinical application is gene therapy, where it is possible to produce proteins in vivo, 
using the body’s own mechanisms for protein production. Major issues in gene 
delivery involve the transport of plasmid DNA (pDNA) to target sites and the 
conversion between different forms of pDNA.

The following example illustrates the kinetic analysis of pDNA degradation. Relying 
on a proposed first-order reaction mechanism, you first evaluate experimental data to 
find the rate constants. Making use of these constants, you then set up the kinetic 
model in the Reaction Engineering Lab, which solves the corresponding material 
balance equations. As a final verification, you can compare the modeling results with 
experimental data you load into the Reaction Engineering Lab.

Introduction

pDNA can be used to express proteins in the human body, proteins that can have 
therapeutic effects. It exists in three forms with varying protein-expression rates. These 
different pDNA-forms interconvert and degrade with time. As a consequence, an 
overall therapy benefits from knowledge about the distribution of pDNA-forms over 
time. The following example investigates a mechanism for pDNA degradation and 
compares the modeling results with experimental data (Ref. 1).

Model Description

pDNA exists in three forms: a supercoiled form (SC), an open-circular form (OC), and 
a linear form (L). The protein expression rate for the SC form is greater than the one 
for the OC form, which in turn is significantly greater than that for the L form. The 
kinetic model in this study assumes that the pDNA-forms interconvert and decompose 
according to the mechanism in Figure 4-1.

Figure 4-1: Kinetic model of plasmid DNA interconversion and decomposition. 
Supercoiled pDNA (SC) converts to an open-circular form (OC), which in turn converts 
to a linear form (L). The linear pDNA decomposes to form linear fragments (F).

LSC FOC
k1 k3k2
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This model proposes a set of irreversible reactions in which SC-form pDNA converts 
to the OC form and subsequently to the L form. Then the L-form decomposes into a 
number of linear fragments, collectively denoted as F.

The three irreversible reactions in Figure 4-1 translate into the following reaction rate 
expressions:

 (4-1)

 (4-2)

 (4-3)

Making use of the reaction rates (Equation 4-1 to Equation 4-3) and the reaction 
stoichiometry, the material balances for the model become:

 (4-4)

 (4-5)

 (4-6)

.  (4-7)

The Reaction Engineering Lab automatically generates these reaction-rate expressions 
and balance equations; all you need to do is to type the corresponding chemical 
reaction formulas into the user interface. This specific system is assumed to be 
isothermal, which is often the case for biological systems. To solve the model, the 
Reaction Engineering Lab needs the rate constants and initial species concentrations 
(10 ng/µL for the SC form) as input.

The rate constants k1 through k3 have to be evaluated from experimental data, 
summarized below:

TIME (s) cSC (ng/µL) cOC (ng/µL) cL (ng/µL)

0 10 0 0

60 5.0 4.1 0.1

r1 k1cSC=

r2 k2cOC=

r3 k3cL=

td

dcSC k– 1cSC=

td

dcOC k1cSC k2cOC–=

td

dcL k2cOC k3cL–=

td

dcF k3cL=
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In this example you will use an integral approach to calculate the rate constants from 
the experimental data. This involves reformulating the reaction rate equations by 
means of integration. Equation 4-4 through Equation 4-6 become:

 (4-8)

 (4-9)

 (4-10)

For each time interval, , evaluate the concentration differences and integrals 
numerically in COMSOL Script and solve the system of equations

 (4-11)

where for each species (i)

120 3.5 6.5 0.3

180 1.1 7.0 0.5

300 0.5 8.1 0.8

420 0.1 8.0 1.2

600 0 7.8 1.7

900 0 7.1 2.4

1200 0 6.3 2.5

1800 0 4.5 2.6

2400 0 3.0 2.0

3000 0 2.1 1.8

3600 0 1.5 1.2

TIME (s) cSC (ng/µL) cOC (ng/µL) cL (ng/µL)

cSC tm( ) cSC t0( )– k– 1 cSC td

t0

tm

∫=

cOC tm( ) cOC t0( )– k1 cSC td

t0

tm

∫ k2 cOC td

t0

tm

∫–=

cL tm( ) cL t0( )– k2 cOC td

t0

tm

∫ k3 cL td

t0

tm

∫–=

t0 t tm≤ ≤

DSC

DOC

DL

SSC– 0 0

SSC SOC– 0

0 SOC SL–

k1

k2

k3

=
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 (4-12)

 (4-13)

Because the system given by Equation 4-11 is overdetermined, k is the least-squares 
solution.

Results

The following rate constants were calculated from the experimental data and reaction 
mechanism: 

Figure 4-2 shows the simulation results for the development of pDNA forms as 
functions of time; it does not display the fragmental products, F.

Figure 4-2: pDNA species concentrations given in ng/µL as functions of time (s).

k1 (s−1) k2 (s
−1) k3 (s

−1)

1.0·10-2 5.0·10-4 1.0·10-3

Di ci tm( ) ci t0( )–=

Si ci td

t0

tm

∫=
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Figure 4-3 shows the experimental values in the same plot as the simulation results. 
Clearly, the assumptions of the kinetic model are in agreement with the experimental 
findings.

Figure 4-3: A plot resulting from reading in experimental data and comparing it to 
simulation results.

The estimated rate constants show that the supercoiled pDNA rapidly transforms into 
the open-circular form with a half-life of approximately 1.2 minutes:

The open-circular and linear pDNA decay with half-lives of 23.1 and 11.5 minutes, 
respectively. As previously mentioned, the supercoiled pDNA has the highest 
protein-expression rate of the three forms. However, because the SC form has a 
half-life of only 1.2 minutes, it is likely that it decomposes during transport to the 
therapeutic target sites. These findings imply that you have to find ways to hinder the 
relatively fast decay of SC.

In conclusion, this example sets up a kinetic model for the transformation and 
degradation of pDNA in the Reaction Engineering Lab. It uses COMSOL Script and 
the Reaction Engineering Lab to validate a kinetic model and estimate the rate 
constants in the proposed kinetic mechanism.

Reference

1. B.E. Houk, G. Hochhaus, and J.A. Hughes, AAPS Pharmsci, vol. 1, p. 1, 1999.

t1 2⁄
2ln

k
---------=
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Model Library path: Biochemistry/dna_degradation

Modeling Using COMSOL Script

M O D E L  N A V I G A T O R

1 Start COMSOL Script.

2 In the COMSOL Script window, create a time vector by typing the following line at the 
prompt, then press Enter.

t = [0 60 120 180 300 420 600 900 1200 1800 2400 3000 3600];

3 Use the following lines of code to create vectors with the concentration data:

c_sc = [10 5 3.5 1.1 0.5 0.1 0 0 0 0 0 0 0]';
c_oc = [0 4.1 6.5 7.0 8.1 8.0 7.8 7.1 6.3 4.5 3.2 2.0 1.5]';
c_l = [0 0.1 0.3 0.5 0.8 1.2 1.7 2.4 2.5 2.6 2.0 1.8 1.2]';

4 With reference to Equation 4-12, create the concentration difference vectors:

d_sc = c_sc-c_sc(1);
d_oc = c_oc-c_oc(1);
d_l = c_l-c_l(1);

5 With reference to Equation 4-13, evaluate the integrals using the trapezoidal rule:

s_sc = cumtrapz(t,c_sc);
s_oc = cumtrapz(t,c_oc);
s_l = cumtrapz(t,c_l);

6 Create a vector of zeros with the same number of elements as the data vectors:

z = zeros(1,length(t))';

7 With reference to Equation 4-11, create the vector D:

D = [d_sc;d_oc;d_l];

8 With reference to Equation 4-11, create the matrix S:

S = [[-s_sc z z]; [s_sc -s_oc z]; [z s_oc -s_l]];

9 Solve for the vector k of Equation 4-11,

k = S\D

to obtain the following rate constants:

k = 

     0.0100
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   5.0e-004
   1.0e-003

With the subsequent three steps you create a data structure called dna and fill it with 
the experimental values. You will later import the data into the Reaction 
Engineering Lab.

10 Store the time data in the x vector of the dna data structure:

dna.x=t;

11 Store the concentration data as columns in the y matrix of the dna data structure:

dna.y=[c_sc c_oc c_l];

12 Enter labels for the various columns of data with the following line, which defines 
entries in the cell array legend for the dna structure data; then press Enter.

dna.legend={'SC data','OC data','L data'};

13 Start the Reaction Engineering Lab by choosing File>Reaction Engineering Lab.

14 Keep the COMSOL Script window open and click on the Reaction Engineering Lab 
user interface.

Modeling Using COMSOL Reaction Engineering Lab

R E A C T I O N S  I N T E R F A C E

1 From the Model menu, select Reaction Settings.

2 Create three entries in the Reaction selection list by clicking the New button three 
times.

3 Enter the reaction formulas in the table below by first selecting the appropriate row 
in the Reaction selection list and then typing the text in the Formula edit field. Note 
how the Reaction Engineering Lab automatically generates expressions for the 
reaction rates and presents them in the r edit field.

When you type the reaction formulas, the reactions are automatically activated and 
the corresponding check boxes become selected; no separate action is required to 
activate the reactions.

REACTION ID # REACTION FORMULA

1 SC=>OC

2 OC=>L

3 L=>F
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4 Enter the following values for the Forward rate constant by first selecting the 
appropriate row in the Reaction selection list and then typing the corresponding 
number in the kf edit field:

S P E C I E S  I N T E R F A C E

1 While still in the Reaction Settings dialog box, click the Species tab.

2 Verify that the Species selection list has the four species (SC, OC, L, and F).

3 On the General page, enter the following initial concentrations, one by one, in the 
c0 edit field after first having selected the appropriate entry in the Species selection 
list:

4 Click Close.

C O M P U T I N G  T H E  S O L U T I O N

1 Open the Simulation>Solver Parameters dialog box.

2 Type 3600 in the Times edit field.

3 Click OK.

4 Click the Solve Problem button (=) on the Main toolbar.

REACTION ID #  kf

1 1e-2

2 5e-4

3 1e-3

SPECIES NAME  c0

SC 10

OC 0

L 0

F 0
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P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows the time variations of the concentrations of all four species, as 
displayed in the figure below:

To create Figure 4-2 on page 157 follow these steps:

1 Choose Postprocessing>Plot Parameters (or click the corresponding button on the 
Main toolbar).

2 Select F in the Quantities to plot list and click the < button to remove it from the 
plot.

3 Click OK.

Now, read the experimental data into the Reaction Engineering Lab and compare with 
the simulation results.

1 Choose File>Import>Experimental Data From Workspace to bring up the dialog box.

2 Type dna in the Variable name for structure with experimental data edit field.

3 Click OK.

4 Choose Postprocessing>Plot Parameters.

5 Select the Plot experimental data check box at the right bottom corner.

6 Click OK to create Figure 4-3.
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Drug R e l e a s e  f r om a B i oma t e r i a l

Introduction

Biomaterial matrices for drug release are useful for in vivo tissue regeneration. The 
following example describes the release of a drug from a biomaterial matrix to 
damaged cell tissue. Specifically, a nerve guide delivers a regenerating drug to damaged 
nerve ends. The model examines detailed drug-release kinetics with rate expressions 
handling drug dissociation/association reactions as well as matrix degradation by 
enzyme catalysis. The enzyme reaction is described by Michaelis-Menten kinetics. 
With this simulation it is easy to investigate design parameters governing the rate of 
drug release such as drug-to-biomaterial affinity, biomaterial degradation, drug 
loading, and of course the influence of geometry and composition of the biomaterial 
matrix. The model illustrates the use of the Reaction Engineering Lab and the 
Chemical Engineering Module as powerful modeling tools for bioengineering 
applications.

Model Definition

In this model a drug is released into a region containing damaged nerve ends. The 
biomaterial holding the drug has a cylindrical shape and serves a dual purpose: It acts 
as a guide to help regenerating nerve cells connect, and it also stimulates the healing 
process through targeted drug release.

The model simulates transient chemical reactions and species transport in a 2D 
geometry with axial symmetry.

Figure 4-4 shows the full 3D geometry as well as the 2D modeling domain, reduced 
by axial symmetry and a mirror plane. The subdomains are:

• The nerve-cell tissue (Ω1) 
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• The biomaterial matrix (Ω2)

• The surrounding medium (Ω3)

Figure 4-4: The full 3D geometry (left) and the equivalent modeling domain reduced to 
2D by axial symmetry (right). The subdomains are: the nerve-cell tissue (Ω1), the 
biomaterial matrix (Ω2), and the surrounding medium (Ω3).

In the biomaterial matrix, a drug molecule, d, binds to a peptide, p, which in turn is 
anchored to the matrix, m. Matrix-bound species are labeled mpd and mp, respectively, 
the latter referring to a species where no drug is bound to the peptide. Species mpd 
and mp are active only in subdomain Ω2.

Two mechanisms release the drug from the matrix. First, the drug can simply dissociate 
from the matrix site mp. Second, matrix degradation by an enzyme, e, originating from 
the cell-tissue domain, leads to release of the drug-peptide species, pd, from which the 
drug subsequently dissociates. The unbound species p, d, pd, and e are active in the 
entire model domain. Figure 4-5 illustrates the complete reaction scheme.

Ω2

Ω1

Ω3
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Figure 4-5: Reaction scheme describing drug dissociation/association reactions 
(horizontal) and matrix-degradation reactions (vertical).

The simulation makes use of two diffusion application modes in the Chemical 
Engineering Module. The time-dependent mass balance per species is described by

  (4-14)

where Dik (m2/s) is the diffusion coefficient for species i   in the medium of subdomain 
Ωk. Further, Rik (mol/(m3· s)) is the rate expression for species i   in the medium of 
subdomain Ωk. In the matrix subdomain, all the reactions described in Figure 4-5 are 
possible, leading to the following rate expressions:

 (4-15)

m

p

m

pd +

m

p

m

m

pE

m

pEE

k1
r

k1
f

k2
r k2

f

k3
f

E

d

d

p

d

d +

k2
r k2

f

k1
r

k1
f

k3
f

Dissociation

D
egradation

ci∂
t∂

------- ∇+ D– ik∇ci( )⋅ Rik in Ωk=

Rd2 k– 1
f cd cmp cp+( ) k1

r cmpd cpd+( )+=
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 (4-16)

 (4-17)

 (4-18)

 (4-19)

The rate terms RMMmp and RMMmpd  refer to the Michaelis-Menten kinetics describing 
the enzyme catalyzed degradation of the matrix:

with

RMMmp  describes the disappearance of mp sites and the production of p species. 
RMMmpd  describes the disappearance of mpd sites and the production of pd species. In 
the cell region (Ω1) and in the surrounding medium (Ω3) only dissociation/
association reactions occur, leading to the rate expressions

The boundary condition is axial symmetry along the rotational axis and insulation/
symmetry elsewhere. Values for diffusion coefficients and rate constants come from the 
literature (Ref. 1).

Rp2 k– 1
f cd cp k1

r cpd RMMmp+ +=

Rpd2 k1
f cd cp k1

r cpd– RMMmpd+=

Rmp2 k– 1
f cd cmp k1

r cmpd RMMmp–+=

Rmpd2 k1
f cd cmp k1

r cmpd– RMMmpd–=

RMMmp
Vmax cmp
KM cmp+
------------------------=

RMMmpd
Vmax cmpd
KM cmpd+
---------------------------=

Vmax k3
f ce=

KM
k3

f k+ 2
r

k2
f

------------------=

Rd1 Rd3= Rp1 Rp3 k– 1
f cd cp k1

r cpd+= = =

Rpd1 Rpd3= k1
f cd cp k1

r cpd–=
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Results and Discussion

Figure 4-6 shows the concentration transients of the reacting species in a perfectly 
mixed (space-independent) system.

Figure 4-6: Concentrations of all reacting species (mol/ m3) as functions of time (s).

The effect of enzyme degradation is clearly visible, with matrix-bound peptide species 
(mp and mpd) decreasing and free peptide species (p and pd) increasing with time. The 
matrix is completely degraded after approximately 5000 seconds. As the drug and 
peptide species have the same association/dissociation kinetics, no matter whether the 
peptide is free or matrix-bound, the steady-state concentration of drug is constant 
during the degradation process.

Solving the space-dependent mass balances of Equation 4-14 results in concentration 
distributions of all participating species as functions of time. Figure 4-7 shows the 
concentration of drug across the modeling domain.

Figure 4-7: Drug concentration at the end of the simulation (7200 s).
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You can visualize the effect of matrix degradation on the release of the drug by plotting 
the total drug concentration over a cross section of the matrix as a function of time.

Figure 4-8: Concentration profiles describing the total drug concentration (cd + cpd) 
across the modeling domain. Profiles were collected at times up to 3600 s.

As noted earlier, the enzyme originates from the nerve-cell subdomain. From 
Figure 4-8 it is clear that matrix degradation has a directing effect on the drug release 
toward the damaged cell region.

To visualize the degradation front passing through the biomaterial geometry, plot the 
total matrix site concentration (cmp + cmpd) across the matrix subdomain (Figure 4-9).

Figure 4-9: Concentration profiles describing the total matrix site concentration (cmp + 
cmpd) with profiles collected at times up to 7200 s.
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The detailed reaction/transport description in this model allows for the investigation 
of many design parameters relevant to bioengineering. This case presents the effect of 
matrix degradation on drug release as a function of time and geometry. Furthermore, 
it is straightforward to study the influence of the drug/peptide affinity by varying the 
rate constants kf

1 and kr
1, or the influence of drug loading by varying the cmp : cmpd 

ratio. Of course, the ability to examine alternative geometries and mixed biomaterial 
domains gives even more design flexibility.

Reference

1. D.J. Maxwell, B.C. Hicks, S. Parsons, and S.E. Sakiyama-Elbert, Acta Biomat., 
vol. 1, p. 101, 2005.

Note: The complete model requires the Chemical Engineering Module and 
COMSOL Multiphysics.

Model Library path: Biochemistry/drug_release1

Model Library path: Biochemistry/drug_release2

The following path shows the location of the COMSOL Multiphysics model:

Model Library path:  

Reaction_Engineering_Lab/Biochemistry/drug_release2

Modeling Using COMSOL Reaction Engineering Lab

To set up this model, enter the chemistry described in Figure 4-5 into the Reaction 
Engineering Lab in two steps. First describe the association/dissociation chemistry by 
entering the corresponding chemical reaction formulas. Second, for the degradation 
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of the biomaterial matrix due to enzyme catalysis, directly enter the well-known 
expressions for the Michaelis-Menten rates.

M O D E L  N A V I G A T O R

Start the Reaction Engineering Lab. In the Model Navigator, click the New button.

O P T I O N S  A N D  S E T T I N G S

1 Click the Model Settings button on the Main toolbar.

2 In the Reacting fluid list, select Liquid.

3 Select the Calculate thermodynamic properties check box.

4 Select the Calculate species transport properties check box.

5 In the T edit field, type 310.

6 Click Close.

7 Choose Model>Constants, then define the following names and expressions. Note 
that Km is the Michaelis-Menten constant.

8 Click OK.

9 Choose Model>Expressions, then define the Michaelis-Menten expressions by 
entering the following settings:

10 Click OK.

R E A C T I O N S  I N T E R F A C E

1 Choose Model>Reaction Settings.

2 On the Reactions page, create two entries in the Reaction selection list by clicking the 
New button twice.

NAME EXPRESSION

kf_mm3 7.336e-3

Km 0.01

NAME EXPRESSION

Vmax kf_mm3*c_e

R_mm_mp Vmax*c_mp/(Km+c_mp)

R_mm_mpd Vmax*c_mpd/(Km+c_mpd)
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3 Enter the following reaction formulas by first selecting the appropriate row in the 
Reaction selection list and then typing the text in the Formula edit field:

4 On the Kinetics page, enter the following forward and reverse rate constants. To do 
so, first select the appropriate row in the Reaction selection list, and then enter the 
numbers in the appropriate edit fields. Note how you set the rate constants of 
Reaction 2 equal to those of Reaction 1 by invoking the variable names 
corresponding to the Rate constant edit fields, kf_1 and kr_1.

S P E C I E S  I N T E R F A C E

1 Click the Species tab.

2 Look at the Species selection list and note the five species that result automatically 
when you enter the reaction formulas as described earlier.

3 Create a new species entry by clicking New, then in the Formula edit field enter e. 
This entry corresponds to the enzyme.

4 Go to the General tab. For each entry in the Species selection list, type the following 
initial concentrations in the c0 edit field:

To include the effects of the enzyme degradation into the kinetic description, you must 
modify the predefined reaction expressions with the Michaelis-Menten rates, which 
you defined earlier in the scalar expressions. 

REACTION ID # REACTION FORMULA

1 d+mp<=>mpd

2 d+p<=>pd

REACTION ID # kf kr

1 1.5e4 13.5

2 kf_1 kr_1

SPECIES NAME  c0
d 0

mp 1e-2

mpd 1e-2

p 0

pd 0

e 2e-3
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5 While still on the General page, select the appropriate entry in the Species selection 

list and modify the rate expressions in the corresponding R edit field.

6 Click the Transport tab.

7 For each species in the list below, select the corresponding entry in the Species 

selection list. Then select the Specify diffusivity check box and type the appropriate 
diffusivity value in the D0 edit field.

8 Click Close.

Start by investigating the kinetics in a perfectly mixed system in the Reaction 
Engineering Lab. 

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve Problem button (=) on the Main toolbar.

P O S T P R O C E S S I N G

To reproduce results of Figure 4-6, click the x log button on the Main toolbar.

To reproduce results of Figure 4-7, follow the steps listed below.

S P E C I E S  I N T E R F A C E

1 Choose Model>Reaction Settings.

2 Click the Species tab.

3 Go to the General tab.

SPECIES NAME  R

mp -r_1-R_mm_mp

mpd r_1-R_mm_mpd

p -r_2+R_mm_mp

pd r_2+R_mm_mpd

SPECIES NAME D 
0

d 8.93e-11

mp 0

mpd 0

p 1.58e-10

pd 8.3e-11

e 5e-11
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4 Choose the species e from the Species selection list and type 0 in the c0 edit field.

You change the value of the initial concentration because the first export of the 
reaction model is to a geometry domain where the enzyme concentration is zero.

5 Click Close.

E X P O R T I N G  T H E  M A S S  B A L A N C E

1 Choose File>Export>Model to COMSOL Multiphysics.

2 Choose 2D in the Space dimension list, then click OK.

This step launches COMSOL Multiphysics and opens the 
Export to COMSOL Multiphysics dialog box, to which the next five steps refer:

3 On the Settings page in the Export mass balance area, select Diffusion: New from the 
Application mode list.

4 In the Group name edit field on the same page, type biomaterial.

5 Clear the check box at the top of the Export energy balance area.

6 Clear the check box at the top of the Export momentum balance area.

7 Click Export to close the Export to COMSOL Multiphysics dialog box.

8 In the Reaction Engineering Lab, choose File>Save As and save the current reaction 
model as drug_release1.rxn.

Now create a new reaction model that describes the reaction occurring outside the 
biomaterial matrix. The reaction to include is the association/dissociation reaction of 
the unbound peptide with the drug. When entering the reaction formulas, use new 
species names. You later couple the concentration variables for peptide, drug, 
peptide-drug complex, and enzyme into COMSOL Multiphysics.

M O D E L  N A V I G A T O R

Create a new reaction model by choosing File>New.

O P T I O N S  A N D  S E T T I N G S

1 Click the Model Settings button on the Main toolbar.

2 In the Reacting fluid list, select Liquid.

3 Select the Calculate thermodynamic properties check box.

4 Select the Calculate species transport properties check box.

5 In the T edit field, type 310.

6 Click Close.
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R E A C T I O N S  I N T E R F A C E

1 Click the Reaction Settings button on the Main toolbar.

2 On the Reactions page, create an entry in the Reaction selection list by clicking the 
New button.

3 Type the following data in the Formula edit field:

4 Go to the Kinetics page and enter the following forward and reverse rate constants:

S P E C I E S  I N T E R F A C E

1 Click the Species tab.

In the Species selection list, notice the three species that resulted automatically when 
you entered the reaction formula. 

2 Create a new species entry by clicking New, then type E in the Formula edit field. This 
entry corresponds to the enzyme.

3 Click the Transport tab.

4 Select the appropriate entry in the Species selection list, select the Specify diffusivity 
check box, and enter the following diffusivities in the D0 edit field:

5 Click Close.

Now export these settings to a second application mode in COMSOL Multiphysics. 
You want to create two separate groups: one corresponding to the conditions in the 
fluid surrounding the biomaterial and nerve, and another corresponding to the 
nerve-cell domain.

E X P O R T I N G  T H E  M A S S  B A L A N C E

1 Choose File>Export>Model to COMSOL Multiphysics.

REACTION ID # REACTION FORMULA

1 D+P<=>PD

REACTION ID #  kf
 kr

1 1.5e4 13.5

SPECIES NAME  D0

D 8.3e-11

P 1.68e-10

PD 9.31e-11

E 5.5e-11
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2 On the Settings page in the Export mass balance area, select Diffusion: New from the 
Application mode list.

3 In the Group name edit field on the same page, type fluid.

4 Clear the check box at the top of the Export energy balance area.

5 Clear the check box at the top of the Export momentum balance area.

6 Click Export to close the Export to COMSOL Multiphysics dialog box.

Now modify the settings of the reaction model to reflect the situation in the nerve-cell 
region.

S P E C I E S  I N T E R F A C E

1 Click the Reaction Settings button on the Main toolbar.

2 Click the Species tab.

3 Click the General tab, then enter the following initial concentrations, one by one, in 
the c0 edit field after first having selecting the appropriate entry in the Species 

selection list:

4 Click the Transport tab.

5 For each species in the table below, select the entry in the Species selection list and 
type the corresponding diffusivity value in the D0 edit field:

6 Click Close.

E X P O R T  S E T T I N G S

From the File menu, choose Export>Model to COMSOL Multiphysics.

SPECIES NAME  c0
D 0

P 0

PD 0

E 2e-3

SPECIES NAME  D0

D 8.93e-11

P 1.58e-10

PD 8.3e-11

E 5e-11
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Export the Mass Balance
1 In the Export mass balance area, select Diffusion (chdi2) from the Application mode list.

2 In the Group name edit field, type nerve.

3 Go to the Export energy balance area and clear the check box at the top.

4 Go to the Export momentum balance area and clear the check box.

5 Click Export.

6 Choose File>Save as and save the current reaction model as drug_release2.rxn.

Modeling Using COMSOL Multiphysics

1 Switch to COMSOL Multiphysics.

2 Choose Multiphysics>Model Navigator.

3 Verify that the model contains two Diffusion application modes as a result of the 
exports from the Reaction Engineering Lab.

4 Click OK.

G E O M E T R Y  M O D E L I N G

1 While holding down the Shift key, click the Rectangle/Square button on the Draw 
toolbar. Enter the values for the rectangle R1 from the following table, then repeat 
the procedure for the rectangles R2 and R3.

2 Click the Zoom Extents button on the Main toolbar.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 Choose Multiphysics>1 Diffusion (chdi).

2 Choose Physics>Subdomain Settings.

3 From the Subdomain selection list, select 1, then clear the Active in this domain check 
box. Repeat this procedure for Subdomain 3.

EDIT FIELD R1 R2 R3

Width 6e-3 1e-3 2e-3

Height 9e-3 9e-3 6e-3

Base Corner Corner Corner

x 0 0 1e-3

y 0 0 0
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4 From the Subdomain selection list, select 2.

5 From the Group list, select biomaterial. COMSOL Multiphysics created this group 
when you performed the export from the Reaction Engineering Lab. Note how all 
the relevant edit fields of the subdomain setting are automatically filled in.

6 Click OK.

7 Choose Multiphysics>2 Diffusion (chdi2).

8 Choose Physics>Subdomain Settings.

9 From the Subdomain selection list, select 2, and then clear the Active in this domain 
check box.

10 From the Subdomain selection list, select 1.

11 From the Group list, select nerve.

12 From the Subdomain selection list, select 3.

13 From the Group list, select fluid.

14 Click OK.

Boundary Conditions
1 Choose Multiphysics>1 Diffusion (chdi).

2 Choose Physics>Boundary Settings.

3 Go to the Boundary Selection list and select 4, 7, and 9 by Ctrl-clicking the entries.

4 Couple the species concentration variables of the biomaterial to the surroundings. 
For each species in the table, find the Boundary condition list and select 
Concentration. Then type the entries from the following table:

5 Leave the remaining boundary conditions at their default setting Insulation/

Symmetry.

6 Click OK.

7 Choose Multiphysics>2 Diffusion (chdi2).

8 Choose Physics>Boundary Settings.

BOUNDARY  c_d  c_p  c_pd  c_e

4, 7, 9 c_D c_P c_PD c_E
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9 Couple the species-concentration variables of the surroundings to the biomaterial. 
For each species in the table, find the Boundary condition list and select 
Concentration. Then type the entries from the following table:

10 Leave all the other boundary conditions at their default setting Insulation/symmetry.

11 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 Define the following expressions by choosing Options>Expressions>Subdomain 

Expressions and entering the settings in the table:

2 Click OK.

M E S H  G E N E R A T I O N

1 Choose Mesh>Free Mesh Parameters.

2 Click the Boundary tab, go to the Boundary selection list, and select 4, 6, 7, and 9. 
Type 1e-4 in the Maximum element size edit field.

3 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 In the Times edit field, type 0:600:7200.

3 In the Relative tolerance edit field, type 1e-5.

4 In the Absolute tolerance edit field, type 1e-6.

5 Click OK.

6 Click the Solve button.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 From the Postprocessing menu open the Plot Parameters dialog box.

BOUNDARY  c_D  c_P  c_PD  c_E

4, 7, 9 c_d c_p c_pd c_e

NAME  SUBDOMAINS 1, 3 SUBDOMAIN 2

c_peptide c_P c_p

c_drug c_D c_d

c_peptidedrug c_PD c_pd

c_enzyme c_E c_e
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2 On the Surface Data page, find the Expression edit field and type c_drug.

3 Click OK.

4 To create Figure 4-8, first go to the Postprocessing menu and open the 
Cross-Section Plot Parameters dialog box.

5 Go to the General page. In the Solutions to use area, select output times between 0 
and 3600 by clicking 0 and then Shift-clicking 3600.

6 Click the Line/Extrusion tab.

7 In the y-axis data area, find the Expression edit field and type 
c_drug+c_peptidedrug.

8 Go to the Cross-section line data area and enter the following values:

9 Click Apply.

10 To create Figure 4-9, return to the Cross-section Plot Parameters dialog box.

11 On the General page, go to the Solutions to use area and select all the entries by 
pressing Ctrl+A and clicking the output list.

12 In the Expression edit field, on the Line/Extrusion page, type c_mp+c_mpd.

13 Click OK.

EDIT FIELD  ENTRY

x0 0

y0 3e-3

x1 5e-3

y1 3e-3
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En z yme I nh i b i t i o n  K i n e t i c s

Introduction

Enzymatic reactions often involve multiple coupled reaction steps in which many 
intermediary species take part. The concentrations of the intermediates may be very 
low, making them hard to isolate and quantify. It is often more practical to investigate 
the depletion of substrate or the accumulation of product under a series of different 
reaction conditions.

This example illustrates how you can perform parameter estimation making use of data 
from multiple experimental runs. In this case, the data consists of concentration 
transients of the reaction product, measured at different initial concentrations of 
reactant.

Model Description

Enzymes act as biological catalysts, efficiently and selectively transforming substrate 
into product. Factors like temperature and pH typically affect the enzyme reaction 
rates. Furthermore, the overall efficiency of enzymatic systems may also be affected by 
undesired side reactions where the enzymes form inactive complexes with molecules 
other than the substrate. Inhibition effects can be both beneficial and detrimental, 
which makes it relevant to study the mechanisms of enzyme reactions in detail.

In competitive inhibition, the substrate and inhibitor compete for the same active site 
on the enzyme. The corresponding kinetics can be described by the following reaction 
set:

 (4-20)

In the main reaction sequence, the enzyme (E) and substrate (S) first form a complex 
(ES), which then produces the product (P). As a side reaction, the enzyme can also 
react with an inhibitor (I) forming the inactive complex (EI).

k1

E ESS+
r

k1
f

k3

E EII+
r

k3
f

ES
k2

f

E P+
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In an effort to evaluate kinetic parameters in the reaction network, experiments were 
set up to monitor concentration changes as functions of time. Rather than monitoring 
all species during a single experiment, the concentration transients of P were measured 
while varying the amount of inhibitor present in each run. The initial conditions of the 
experiments are summarized in the table below:

The corresponding experimental results are illustrated in Figure 4-10, where the data 
sets have been read into the Reaction Engineering Lab.

Figure 4-10: Four sets of data points representing the concentration of P (µmol/L) as 
function of time (s).

In this example it is assumed that the rate constants for the formation and 
decomposition of the ES complex are known from previous experiments;  = 100 
µmol/(L s) and  = 180 1/s. Furthermore, it is reasonable to assume that the rate 
constant describing the ES formation is similar to that of EI formation.

The parameter estimation will thus evaluate the rate constant of the product forming 
step, , and the rate constant for the decomposition of EI, . 

EXPERIMENT #  c0S (µmol/L)  c0E (µmol/L)  c0I (µmol/L)

1 25 0.004 0

2 25 0.004 0.005

3 25 0.004 0.01

4 25 0.004 0.02

k1
f

k1
r

k2
f k3

r
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Results

The parameter estimation produces the following results for the rate constants:

Figure 4-11 shows the experimental data along with the simulated results, using the 
rate constants found from parameter estimation.

Figure 4-11: Four sets of data points representing the concentration of P (µmol/L) as 
function of time (s), and the corresponding simulation results.

Clearly, there is good agreement between theory and experiments. This indicates that 
the reaction mechanism describing the competitive inhibition (Equation 4-20) is 
indeed a good representation of what occurs in reality. Furthermore, the assumption 
that rate constant describing the formation of ES is equal to that of EI formation also 
appears valid.

RATE 
CONSTANT

VALUE LOWER 
LIMIT

UPPER LIMIT

kf_2 10.16 10.11 10.22

kr_3 9.80e-2 9.69e-2 9.90e-2
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Model Library path: Biochemistry/enzyme_inhibition

Modeling Using the COMSOL Reaction Engineering Lab

M O D E L  N A V I G A T O R

1 Start the COMSOL Reaction Engineering Lab by double-clicking its desktop icon.

2 In the Model Navigator click the New button.

R E A C T I O N S  I N T E R F A C E

1 From the Model menu, select Reaction Settings.

2 Create three entries in the Reaction selection list by clicking the New button three 
times.

3 Enter the reaction formulas in the table below by first selecting the appropriate row 
in the Reaction selection list and then typing the text in the Formula edit field.

Note how Reaction Engineering Lab automatically generates the corresponding 
kinetic expressions and displays them in the Reaction rate edit field.

4 Enter the following values for the Forward rate constant and the Reverse rate 

constant by first selecting the appropriate row in the Reaction selection list and then 
typing the corresponding numbers in the kf and kr edit fields:

The values just entered for the rate constants serve as starting guesses for the 
parameter estimation. You can also supply starting guesses in the Parameter 

Estimation Settings dialog box.

REACTION ID # REACTION FORMULA

1 E+S<=>ES

2 ES=>P+E

3 E+I<=>EI

REACTION ID # kf kr

1 100 180

2 1

3 100 1e-2
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S P E C I E S  I N T E R F A C E

1 While still in the Reaction Settings dialog box, click the Species tab.

2 On the General page, enter the following initial concentrations, one by one, in the 
c0 edit field after first having selected the appropriate entry in the Species selection 
list:

3 Click Close.

Move on to load experimental data into the software and set up the parameter 
estimation problem.

1 Choose Estimation>Parameter Estimation Settings.

2 Go to the Advanced page and select the Specify initial state values for data sets check 
box.

With this setting you activate the Data/Init page, where you specify which initial 
concentrations that apply to each individual data set.

3 Return to the Data page and click the Import From File button.

4 Browse to the text file enzyme_inhibition_p_set1.txt and click Import.

5 Similarly import the files enzyme_inhibition_p_set2.txt, 
enzyme_inhibition_p_set3.txt, and enzyme_inhibition_p_set4.txt.

6 Select enzyme_inhibition_p_set1.txt from the Data set selection list, and then 
P set 1 from the Data selection list.

7 Select P from the Predefined quantities list.

With this procedure you have selected a particular data set and associated the data 
found in the column “P set 1” of the file with the corresponding variable name of 
the model, P.

8 Go to the Init page and select Initial concentration I in the Variable selection list.

SPECIES NAME c0
E 0.004

S 25

ES 0

P 0

I 0

EI 0
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9 Click the Specify value option button and type 0 in the corresponding edit field.

With these steps you tell the software that the initial concentration of the inhibitor 
(I) is 0 for this particular data set.

10 Proceed in the same manner to associate measured variables with model variables, 
and specifying the initial inhibitor concentration relevant for data set:

11 Click the Parameters page.

12 From the Predefined parameters list, select kf_2 (Forward rate constant 2) and then 
click the Add button (>).

13 Repeat the above step for the parameter kr_3 (Reverse rate constant 3).

Select kf_2 and then kr_3 from the Parameters to estimate list. Note that the Use 

value from model is selected by default. This indicates that the initial guesses of the 
parameters are the values entered in rate constant edit fields in the Reaction Settings 
dialog box.

14 Click OK to close the Parameter Estimation Settings dialog box.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Estimate Parameters button on the Main toolbar.

You find the estimated values of the rate constants kf_2 and kr_3 and their 
confidence limits displayed in the Progress - Log window. If the Progress - Log 
window is not open, access it by following the steps below:

2 Select the menu item Estimation>View Log.

3 Click the Log page.

You may have to scroll in the log to locate the summary report of the parameter 
estimation calculations. Selecting the Close automatically check box closes the 
Progress - Log window after each simulation.

Note that once the parameter estimation is finished, the reaction model is simulated 
automatically, using the rate constants just evaluated. You can turn off the automatic 
simulation feature on the Advanced page in the Parameter Estimation Settings dialog 

DATA SET PREDEFINED 
QUANTITY

INITIAL 
CONCENTRATION I

enzyme_inhibition_p_set1.txt P 0

enzyme_inhibition_p_set2.txt P 5e-3

enzyme_inhibition_p_set3.txt P 10e-3

enzyme_inhibition_p_set4.txt P 20e-3
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box. Here, you can also select if you want automatic update of the evaluated 
parameters to the reaction model or not.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Choose Postprocessing>Plot Parameters.

2 Click the << button.

3 Go to the Predefined quantities list and select P.

4 Click the > button to add the entry to the Quantities to plot list.

5 Click OK.

The model results show the concentration of the product P evaluated when the initial 
concentration of the inhibitor is 0. To check that simulated results also align with the 
remaining data sets, follow the steps below.

S P E C I E S  I N T E R F A C E

1 From the Model menu, select Reaction Settings.

2 Click the Species tab.

3 On the General page select I from the Species selection list, and type 5e-3 in the c0 
edit field.

4 Click Close.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solve button on the Main Toolbar.

Repeat the above steps to check the simulations for initial concentrations 0.01 and 
0.02.
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Ozon e  Combu s t i o n

Introduction

This 1D example illustrates the detailed modeling of a premixed, laminar, steady-state 
flame where ozone undergoes combustion to form oxygen. Here seven reversible, 
elementary reactions describe the chemical degradation of ozone. The limited size of 
the reaction set makes this a good test case for combustion modeling (Ref. 1). The 
model couples mass, energy, and continuity equations describing the flame through 
dependencies on the temperature, pressure, and composition of the reacting flow. 
These relationships are given by expressions for thermodynamic and transport 
properties, which are provided at the level of detail commonly used by the combustion 
community.

It is well known that a flame has a limited range of operating conditions. If these 
conditions are not maintained, the flame does not remain stationary but instead can 
oscillate or fade. The technical question this model seeks to answer is this: How does 
the velocity of the inlet gas affect the flame in general and the chemistry in particular?

Model Definition

The modeling domain is in one dimension, 0.5 mm in length.

Assume pressure is constant at 101.3 kPa. At the inlet, a reacting gas mixture of 50% 
ozone and 50% oxygen (by weight) is held at 1000 K.

This example solves the stationary problem using three application modes:

• Maxwell-Stefan Diffusion and Convection to describe the mass balances

• Convection and Conduction to describe the overall energy balance

• PDE, General Form to describe the continuity equation

The mass balance per species i is described in the Maxwell-Stefan Diffusion and 
Convection application mode by

 (4-21)

where ρ is the density (kg/m3), wi denotes the species mass fraction, u equals the 
velocity vector (m /s), and Ri is the source term per species due to the chemical 
reaction (kg/(m3·s)). The ji diffusive mass flux of species i, is given by

∇ ji ρ+ ωiu( )⋅ Ri=
O Z O N E  C O M B U S T I O N  |  187



188 |  C H A P T E
 (4-22)

In this equation, the first term refers to the thermal diffusivity, which this example 
ignores. The components of the Fickian diffusivity matrix,  (m2/s), are calculated 
from the corresponding set of binary diffusion coefficients, which are calculated from 
kinetic gas theory in this way:

 (4-23)

Here DAB is the binary diffusion coefficient (m2/s), M denotes the molecular weight 
(kg/mol), T represents the temperature (K), p gives the pressure (Pa), σ is the 
characteristic length (Å) of the Lennard-Jones/Stockmayer potential, and ΩD is the 
collision integral.

The Convection and Conduction application mode describes the energy balance 
according to the equation

 (4-24)

where Cp is the fluid’s heat capacity (J/(kg·K)) evaluated as the weight fraction average 
of the fluid components:

 (4-25)

The model then calculates the heat capacity of the individual components from 
thermodynamic polynomials in the NASA format:

 (4-26)

where Rg is the ideal gas constant (J/(mol·K)), Mi equals the molar mass (kg/mol) of 
component i, and a1 to a5 are constants. Similarly, the fluid thermal conductivity, k 
(W/(m·K)), depends on temperature and fluid composition as

 (4-27)
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where xi is the mole fraction of species i. The thermal conductivity of the individual 
species is given by the Stiel-Thodos equation:

 (4-28)

In Equation 4-28, the heat capacity Cp  comes from Equation 4-26, and you evaluate 
the dynamic viscosity η (Ns/m2) using the following expression from kinetic gas 
theory:

 (4-29)

Here, Ωv denotes the collision integral.

In Equation 4-24, Q is the heat source (J/(m3·s)) due to a chemical reaction and is 
defined as

 (4-30)

where the reaction rates, rj, come from Equation 4-47 discussed later. The heats of 
reaction, Hj (J/kg), are calculated as

 (4-31)

where νij is the stoichiometric coefficient of species i in reaction j, defined as being 
positive for reactants and negative for products. The enthalpy of each species is related 
to temperature by

 (4-32)

This example models the overall mass conservation (continuity equation) using a PDE, 

General Form application mode

 (4-33)

where ρ is the fluid density (kg/m3) expressed using the ideal gas law:
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 (4-34)

The boundary conditions imposed for the Maxwell-Stefan diffusion and convection 
are

 (4-35)

 (4-36)

where j is the diffusive mass flux. The boundary conditions for the convection/
conduction application mode are

 (4-37)

 (4-38)

For the continuity equation, the gas velocity is specified at the inlet as

 (4-39)

The following set of elementary reactions describe the chemistry of ozone 
combustion:

 (4-40)

 (4-41)

 (4-42)

 (4-43)

 (4-44)
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 (4-45)

 (4-46)

The rate (mol/(m3·s)) of reaction j  is given by

 (4-47)

Here, and denote the forward and reverse rate constants, respectively. The 
concentration of species i is denoted ci (mol/m3). The stoichiometric coefficients are 
denoted νij. The temperature dependence of the rate constants is given by the 
Arrhenius expression

 (4-48)

where A is the frequency factor, n represents the temperature exponent, and E equals 
the activation energy (J/mol).

This example first solves the model for fixed inlet conditions with a velocity of 1 m/s, 
a temperature of 500 K, and a gas mixture of 50% ozone and 50% oxygen using the 
Stationary Nonlinear solver. Then it solves the model for a sweep of values of the inlet 
velocity using the Parametric solver.
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Results

Figure 4-12 shows the evolution of the gas composition along the length of the flame. 
The reaction paths described by Equation 4-40 to Equation 4-46 lead to ozone 
decomposition into oxygen. 

Figure 4-12: Species distribution (weight fraction) in the reacting flow. 

The results indicate that the reaction takes place in the first 100 µm of the flame. The 
figure also illustrates that the weight fraction of oxygen radicals is relatively small. The 
results show values in the range of weight fraction near 0.5%. Furthermore, the radical 
concentration seems to remain at that level even at the outlet, suggesting a slow radical 
termination reaction.

Figure 4-13 shows the thermal effects at an inlet velocity of 1 m/s.

Figure 4-13: Thermal effects in terms of temperature and velocity profile.
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In total, the combustion reactions are exothermic, resulting in a rapid release of energy 
and increase of temperature at the reaction zone. This increase in temperature leads to 
a higher gas velocity due to a rapid density decrease.

The model explores the influence of the inlet velocity on the results. This case varies 
the inlet velocity from 3.0 to 0.01 m/s. Figure 4-14 shows how this velocity variation 
affects the concentration profile of ozone, and it indicates that the reaction zone 
becomes very narrow as the velocity increases. Furthermore, the geometrical offset 
from the inlet to where the reaction starts increases slightly at the highest velocities. 

Figure 4-14: Ozone weight fraction profiles for various inlet velocities.

The inlet velocity also strongly affects the flame’s temperature as seen in Figure 4-15.

Figure 4-15: Temperature profiles for various inlet velocities.
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As a consequence of the increasing temperature, the velocity is also affected. 
Figure 4-16 shows the gas velocity in the flame in relation to the inlet velocity, that is, 
the relative velocity.

Figure 4-16: Relative velocity profiles at various inlet velocities.

In conclusion, this example shows the setup and solution of a combustion problem 
making use of the Reaction Engineering Lab together with the Chemical Engineering 
Module. The Reaction Engineering Lab automatically formulates a kinetic scheme 
involving seven reversible ozone reactions when you enter the corresponding reaction 
formulas into the user interface. The accurate modeling of the decomposition process 
furthermore made use of the predefined expression for thermodynamics and transport 
properties available in the Reaction Engineering Lab.

Reference

1. J.M. Heimerl and T.P. Coffee, Combustion and Flame, vol. 39, p. 301, 1980.

Model Library path: Combustion/ozone_combustion

The following path shows the location of the COMSOL Multiphysics model:

Model Library path:  
Reaction_Engineering_Lab/Combustion/ozone_combustion
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Modeling Using COMSOL Reaction Engineering Lab

M O D E L  N A V I G A T O R

1 Start the Reaction Engineering Lab.

2 Click New in the Model Navigator.

S E T T I N G S  A N D  P A R A M E T E R S

1 Choose Model>Model Settings.

2 Select the Calculate thermodynamic properties check box.

3 Select the Calculate species transport properties check box.

4 Type 900 in the T edit field, then click Close.

R E A C T I O N S  I N T E R F A C E

1 Choose Model>Reaction Settings.

2 Create seven entries in the Reaction selection list by clicking the New button seven 
times.

3 Enter the following reaction formulas by first selecting the appropriate row in the 
Reaction selection list and then typing the text in the Formula edit field. Note how 
the Reaction Engineering Lab automatically generates reaction rate expressions and 
presents them in the r edit field.

4 On the Kinetics page, specify the Arrhenius parameters for the forward and reverse 
rate constants according to the table below. To do so, first select the appropriate row 

REACTION ID # REACTION FORMULA

1 2o3<=>o3+o2+o

2 o+o3<=>2o2

3 2o+o2<=>2o2

4 o3+o2<=>o+2o2

5 3o<=>o+o2

6 o3+o<=>2o+o2

7 2o+o3<=>o2+o3
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in the Reaction selection list, then select the Use Arrhenius expressions check box, and 
finally type the numbers in the corresponding edit field in the Arrhenius area:

5 The rate constants of reactions 4 through 7 are related to rate constants of reactions 
1 through 3. In the kf and kr edit fields, replace the predefined expressions with the 
following relations:

S P E C I E S  I N T E R F A C E

1 Click the Species tab.

2 Check that the Species selection list has the following three entries: o3, o2, and o.

3 On the General page enter the following values for the Molecular weight in the M edit 
field and also enter values for the Initial concentration in the c0 edit field after 
selecting the appropriate entry in the Species selection list:

4 Click the Thermo tab.

5 Select all the species in the Species selection list by pressing Ctrl+A and clicking 
anywhere in the list. Enter the numbers 3e2, 1e3, and 6e3 in the edit fields for the 
lower, midpoint, and upper temperature interval, Tint.

6 Select one entry at a time from the Species selection list and type the following 
vectors of polynomial coefficients in the edit fields for alow,k and ahigh,k:

REACTION ID # A
forward reverse

n
forward reverse

E
forward reverse

1 4.31e8 1.2e1 0 0 92.8e3 -8.11e3

2 1.14e7 1.19e7 0 0 19.1e3 420.7e3

3 1.38e6 2.75e13 -1 -1 1.42e3 496.6e3

REACTION ID #  kf
 kr

4 0.44*kf_1 0.44*kr_1

5 3.6*kf_3 3.6*kr_3

6 0.44*kf_1 0.44*kr_1

7 kf_3 kr_3

SPECIES NAME  M  c0
o3 48e-3 16.25

o2 32e-3 24.37

o 16e-3 0
R  4 :  M O D E L  L I B R A R Y



Note that only six out of seven edit fields are used. This is fine because the NASA 
polynomial format uses the seventh edit field only to calculate the species entropy, 
an expression this model does not use.

COEFFICIENT O3 O2 O

alow,1 0.2466e1 0.3625e1 0.2955e1

alow,2 0.9170e-2 -0.1878e-2 -0.1706e-2

alow,3 -0.4969e-5 0.7055e-5 0.2592e-5

alow,4 -0.2063e-8 -0.6763e-8 -0.1783e-8

alow,5 0.2001e-11 0.2155e-11 0.4570e-12

alow,6 0.1605e5 -0.1047e4 0.2914e5

ahigh,1 0.5466e1 0.3621e1 0.2535e1

ahigh,2 0.1732e-2 0.7361e-3 -0.1437e-4

ahigh,3 -0.7220e-6 -0.1965e-6 -0.1136e-7

ahigh,4 0.1372e-9 0.3620e-10 0.6600e-11

ahigh,5 -0.9623e-14 -0.2894e-14 -0.6118e-15

ahigh,6 0.1521e5 -0.1201e4 0.2923e5
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7 Click the Transport tab.

8 Enter the following interaction potential parameters into the ε/kb and σ edit fields 
after selecting the appropriate entry in the Species selection list:

9 Click Close.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 In the Times edit field, type 10. Click OK.

3 Click the Solve Problem button (=).

4 To get a good overview of the results, click both the X log and the Y log buttons on 
the Main toolbar to switch to a log-log plot.

5 Go to the figure window and click the Edit Plot button to open the Edit Plot dialog 
box. Open the Grid page and clear the Show grid check box. You should now get the 
following plot:

E X P O R T  S E T T I N G S

1 From the File menu, select Export>Model to COMSOL Multiphysics.

SPECIES NAME  σ  ε/kb

o3 4.69 39.4

o2 3.372 128.7

o 2.947 127.2
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2 Select 1D from the Space dimension list, then click OK.

This step launches COMSOL Multiphysics and opens the 
Export to COMSOL Multiphysics dialog box.

3 In the Export mass balance area, select Maxwell-Stefan Diffusion and Convection: New 

from the Application mode list.

4 In the Group name edit field, type mass.

5 In the Export energy balance area, select Convection and Conduction: New from the 
Application mode list.

6 In the Group name edit field, type energy.

7 Click Export.

Modeling Using COMSOL Multiphysics

M O D E L  N A V I G A T O R

1 From the Multiphysics menu, select Model Navigator.

2 Verify that the model contains the Maxwell-Stefan Diffusion and Convection (chms) and 
the Convection and Conduction (chcc) application modes as a result of the export from 
the Reaction Engineering Lab.

3 From the list of application modes, select 
COMSOL Multiphysics>PDE Modes>PDE, General Form.

4 Click Add.

5 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 Define the following constants by choosing Options>Constants and typing them in:

2 Click OK.

G E O M E T R Y  M O D E L I N G

1 Choose Draw>Specify Objects>Line.

NAME EXPRESSION DESCRIPTION

w_o3_in 0.5 Inlet weight fraction o3

w_o2_in 0.5 Inlet weight fraction o2

T_in 500 Inlet temperature

u_in 1 Inlet gas velocity
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2 In the x edit field, type 0 5e-4, and then click OK.

3 Click the Zoom Extents button on the Main toolbar.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 Choose Multiphysics>Maxwell-Stefan Conduction and Convection (chms).

2 Choose Physics>Subdomain Settings.

3 In the Subdomain selection list on the Subdomains page, select 1.

4 Still on the Subdomains page, select mass from the Group list.

Note how all the relevant edit fields are filled in with the values exported from the 
Reaction Engineering Lab.

5 On the General page, type u in the x-velocity edit field.

6 On the Init page, type 0.05 in the w_o3(t0) edit field and type 0.92 in the w_o2(t0) 
edit field.

7 Click OK.

8 Choose Multiphysics>Convection and Conduction (chcc).

9 Choose Physics>Subdomain Settings.

10 On the Subdomains page, select energy from the Group list.

This group setting was also created during the export from the Reaction 
Engineering Lab to COMSOL Multiphysics.

11 On the Physics page, type u in the x-velocity edit field.

12 On the Init page, type T_in in the T(t0) edit field.

13 Click OK.

14 Choose Multiphysics>PDE, General Form (g).

15 Choose Physics>Subdomain Settings.

16 On the Coefficients page, type the following data into the indicated edit fields:

17 On the Init page, type u_in in the u(t0) edit field.

PROPERTY VALUE

 Γ 0

 F -(rho_rxn_chcc*ux+diff(rho_rxn_chcc,x)*u)

 ea 0

 da 0
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18 Click OK.

Boundary Conditions
1 With the application mode PDE, General Form (g) still active, choose 

Physics>Boundary Settings.

2 Enter the boundary conditions according to the following table:

3 Click OK.

4 Choose Multiphysics>Maxwell-Stefan Diffusion and Convection (chms).

5 Choose Physics>Boundary Settings.

6 Enter the boundary conditions according to the following table:

7 Click OK.

8 Choose Multiphysics>Convection and Conduction (chcc).

9 Choose Physics>Boundary Settings.

10 Enter the boundary conditions according to the following table:

11 Click OK.

M E S H  G E N E R A T I O N

1 Choose Mesh>Free Mesh Parameters.

2 On the Global page, type 0.5e-5 in the Maximum element size edit field.

3 In the Element growth rate edit field, type 1.1.

SETTINGS BOUNDARY 1 BOUNDARY 2

Type Dirichlet Neumann

 G 0 0

 R u_in-u

SETTINGS BOUNDARY 1 BOUNDARY 2

w_o3 Mass fraction, 
w_o30=w_o3_in

Convective Flux

w_o2 Mass fraction, 
w_o20=w_o2_in

Convective Flux

SETTINGS BOUNDARY 1 BOUNDARY 2

Type Temperature Convective Flux

Value T_in
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4 Click the Boundary tab, select Boundary 1, and type 1e-10 in the 
Maximum element size edit field.

5 Click Remesh and then click OK.

C O M P U T I N G  T H E  F I R S T  S O L U T I O N

1 Choose Solve>Solver Parameters.

2 Select Stationary in the Solver list.

3 Click OK.

4 Solve the problem by clicking the Solve button (=) on the Main toolbar.

P O S T P R O C E S S I N G  T H E  F I R S T  S O L U T I O N

The following steps reproduce Figure 4-12:

1 Choose Postprocessing>Domain Plot Parameters.

2 On the General page, select the Keep current plot check box.

3 On the Line/Extrusion page, select Subdomain 1.

4 From the Predefined quantities list, select Mass Fraction, w_o3 (chms).

5 Plot the first line by clicking Apply.

6 In the Line/Extrusion page, select Mass Fraction, w_o2 (chms) in the 
Predefined quantities list.

7 Click the Line Settings button. From the Line color list select Color, then click OK.

8 Plot the second line by clicking Apply.

9 On the Line/Extrusion page, type w_o*10 in the Expression edit field.

10 Click the Line Settings button. From the Line color list, select Color. Click the Color 
button, select green from the palette, and click OK.

11 Click OK.

12 Go to the figure window and click the Edit Plot button to open the Edit Plot dialog 
box.

13 Click on Axes in the list, then type Species distribution in the Title edit field. 
Also, type Mass fractions in the y label edit field.

14 Click the top line(0) object in the list. This corresponds to the line first plotted.

15 Select the Show legend check box and type Ozone in the Legends edit field.

16 Repeat the last two steps for the two remaining line(0) objects using the legend 
names Oxygen and O-radicals*10, respectively.
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17 Click OK to finalize the plot.

Create Figure 4-13 with the following steps:

1 Choose Postprocessing>Domain Plot Parameters.

2 On the General page, select New figure from the Plot in list.

3 On the Line/Extrusion page, type T/1000 in the Expression edit field, then click Apply.

4 Still on the Line/Extrusion page, type u/u_in in the Expression edit field.

5 Click the Line Settings button. From the Line color list, select Cycle, then click OK.

6 Click OK.

7 In the figure window, click the Edit Plot toolbar button.

8 Click on Axes in the list and type Thermal result in the Title edit field. Also type 
u/u_in; T/1000 in the y label edit field.

9 Click the top line(0) object in the list, click to select the Show legend check box, and 
type T/1000 in the Legends edit field.

10 Repeat the last step for the other line(0) object using the legend name u/u_in.

11 Click OK to finalize the plot.

C O M P U T I N G  T H E  P A R A M E T R I C  S O L U T I O N S

1 Choose Solve>Solver Parameters, then select Parametric in the Solver list.

2 Type u_in in the Parameter name edit field and 3 1 0.3 0.1 0.03 in the 
Parameter values edit field. 

3 On the Advanced page, click to clear the Stop if error due to undefined operation 

check box. Click OK.

4 Choose Solve>Solver Manager. In the Initial value area of the Initial Value page, select 
Current solution. Click OK.

5 Click the Solve button on the Main toolbar. The solution process takes a few minutes 
on a standard PC.

PO S T P R O C E S S I N G  T H E  P A R A M E T R I C  S O L U T I O N

The following steps reproduce Figure 4-14:

1 Choose Postprocessing>Domain Plot Parameters.

2 On the General page, select New figure from the Plot in list.

3 On the Line/Extrusion page, select Mass Fraction, w_o3 from the Predefined quantities 
list.
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4 Click the Line Settings button, then select the Legends check box and click OK.

5 Generate the plot by clicking OK.

To reproduce Figure 4-15, repeat the steps above except this time select 
Temperature (chcc) from the Predefined quantities list.

Finally, to create Figure 4-16, repeat the steps above, but this time type u/u_in in the 
Expression edit field instead of selecting a variable from the list.
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D i e s e l  F i l t e r

This example deals with a model of a filter system for a diesel engine. A porous 
membrane separates soot particles from exhaust gases passing through it, leading to 
the formation of a soot layer. Both catalytic and noncatalytic reactions retard the layer’s 
build-up; carbon is oxidized to carbon monoxide and carbon dioxide, which both pass 
through the membrane.

Introduction

Diesel filters are used to remove particulate matter in diesel-engine exhaust gases. A 
filter system’s efficiency and durability are closely related to the manner in which it 
removes soot deposits from the porous filter walls. For instance, one method is to 
remove the soot layer by means of noncatalytic reactions with oxygen. However, this 
scheme requires that the exhaust temperature increase above normal operating 
conditions. Another approach involves introducing cerium additives to the fuel. 
Cerium oxide species are subsequently present in the soot layer, acting as a catalyst in 
carbon-oxidation reactions. Under these conditions, it is possible to remove carbon 
deposits in the filter without increasing the exhaust temperature. The following model 
illustrates both of these working conditions.

Diesel filters are typically of a monolithic type with narrow channels running through 
a cylindrical structure. The silicon carbide filter under study is 15 cm long with a total 
of 2000 channels. Filter channels are open only at one end and are arranged in an 
alternating fashion in the monolith. The channels are separated by porous walls, as 
illustrated in Figure 4-17.

Figure 4-17: Front view of a channel section in a diesel filter. The A-channels are open 
while the B-channels are closed. Channels are separated by porous walls. A back view would 
show the opposite configuration. Gas therefore enters the filter through the A-channels and 
exits through the B-channels.

Inlet
Outlet

A

B
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Model Definition

T H E  C H E M I C A L  R E A C T I O N S  A N D  T H E  1 D  M O D E L S

Begin this example with an overview of the system chemistry.

The soot layer must be removed continuously or at intervals to keep the filter in 
working condition. Oxygen can react with carbon to form carbon monoxide and 
carbon dioxide. Further reaction pathways open when the diesel fuel is treated with 
additives containing cerium. The soot layer then contains cerium-oxide species that act 
as catalysts to oxidize the carbon, and oxygen regenerates the catalyst. 

This model considers the following reactions taking place in the soot layer:

The reactions occur in the soot layer. The reaction rates (mol/(m3·s)) are given by

where cO2 is the molar concentration of oxygen (mol/m3), while xCeO2 and xCe2O3 
are the molar fractions of the different cerium species. 

+ O2

k1
C CO2

+ 0.5O2

k2
C CO

+ 4CeO2

k3
C CO22Ce2O3 +

+ 2CeO2

k4
C COCe2O3 +

0.5O2

k5
Ce2O3 2CeO2+ .

r1 k1cO2=

r2 k2cO2=

r3 k3xCeO2=

r4 k4xCeO2=

r5 k5xCe2O3cO2=
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The Reaction Engineering Lab automatically defines the material and energy balances 
for a perfectly mixed batch reactor.

An alternative way to define a steady-state model for a tubular reactor in the Reaction 
Engineering Lab is to use time, t, as the dependent variable. At steady state and at a 
given constant velocity, you can use the time variable to step in space.

For example, consider the material balance for an isothermal tubular reactor where you 
neglect transport by diffusion in the direction of the flow. You can then define a 
material balance according to

where u is the velocity and Ri  includes all the reactions in which species i is involved. 
You can directly use the time t as the x coordinate, remembering that the time interval 
now represents the reactor length. Alternatively, substitute the relation u = dx/dt in 
the previous equation to get an equation that truly depends on time. The second 
option implies that you travel with the flow along the length of the reactor during time 
stepping. Both cases only require an initial or inlet condition for the concentration.

It is advisable to follow a two-step strategy in the Reaction Engineering Lab to get a 
feeling for this system (the modeling steps are independent of each other):

1 Model a perfectly stirred tank reactor including the system kinetics; then export that 
Reaction Engineering Lab model to the Chemical Engineering Module in 
COMSOL Multiphysics to set up a time-dependent 2D model. In both the 
Reaction Engineering Lab and COMSOL Multiphysics, the model includes an 
energy balance but still assumes that nitrogen acts as a solvent.

2 The second model is only done in the Reaction Engineering Lab and involves the 
definition of a 1D tubular reactor for the system. This model can be isothermal 
assuming that nitrogen acts as a solvent.

The assumption that nitrogen is present in a dominating concentration is not 
completely acceptable for a high-fidelity model. However, as a first step you can be 
satisfied with a description that has the correct order of magnitude.

Now look at a material balance at a constant pressure and a constant temperature in 
one cell in the monolithic filter (here neglecting any pressure losses in the system). 
Assume you can put part of the filter into an experimental setup as shown in 
Figure 4-18 so that you can study one single cell and one single filter-unit. The exhaust 
gas enters Channel A and passes through a single filter wall to Channel B (note that a 

xd
d ciu( ) Ri– 0=
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repetitive cell would have a filter wall on all sides). Because not much happens in 
Channel B, you can restrict the 1D model system to treat just Channel A, the deposited 
particles, and the catalyst. Along the system boundaries, the filter is a distributed outlet 
(again see Figure 4-18). Because the pressure loss over the filter wall is comparably 
large, you can, furthermore, assume that the velocity across the wall along the length 
of the channel is constant. This implies that the velocity component along the channel 
decreases linearly from the inlet to the outlet.

Figure 4-18: Cross section of the modeled system. The exhaust enters Channel A, goes 
through the filter wall, and exits through Channel B. Assume the velocity across the filter 
wall is constant along the x direction in the 1D model, while the velocity component along 
the length of the channel decreases linearly with the distance from the inlet.

A general material balance for a small section of Channel A of length ∆x resembles the 
following equation for any species i:

 (4-49)

Here Ni denotes the flux vector (mol/(m2· s)), Acs equals the channel’s cross-sectional 
surface (m2), vf represents the flow velocity across the filter (m/s), and Ri (mol/
(m3·s)) is the reaction rate per unit volume of the channel, which includes all the 
reactions in which i takes part. The reaction is limited to the soot layer on the filter 
surface. Because the kinetic data is given per unit volume of soot, you must estimate 
the volume of soot per unit volume of the channel. Do so by assuming a given soot 
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layer thickness; the relationship between the soot-layer thickness and channel height 
then gives the volume of soot per unit volume of channel (δsoot/δchannel).

Dividing Equation 4-49 by the cross-sectional area Acs and ∆x as you let ∆x approach 
zero results in the equation

.

Assuming that the transport of species in the x direction is dominated by convection 
gives

 (4-50)

where u is the flow velocity in the x direction (m/s). However, according to the 
assumption of a linearly decreasing flow along the channel, you can express u as

 (4-51)

where ku (1/s) denotes the proportionality constant (−1 times the inlet velocity 
divided by the channel length), and u0 equals the inlet velocity. Equation 4-51 inserted 
into Equation 4-50 results in the following expression (after making use of the 
differentiation rule for products):

 (4-52)

The Reaction Engineering Lab automatically calculates the Ri term from the reaction 
formulas. You can add the second and third terms manually as sources or sinks directly 
in the user interface. 

T H E  2 D  M O D E L

This example removes a channel section from the monolith and places it into an 
experimental setup to study only a single filter unit with a single filter wall. Assuming 
that you use only a single filter wall and by thermally and mechanically insulating the 

dNi

dx
---------- ci

vf
Acs
--------- Ri–+ 0=

d ciu( )
dx

----------------- ci
vf

Acs
--------- Ri–+ 0=

u kux u0+=

u
dci

dx
-------- kuci ci

vf

Acs
--------- Ri–+ + 0=
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upper and vertical channel walls, you can treat the system with a 2D model as in the 
following figure:

Figure 4-19: Modeled domain including four subdomains: the inlet Channel A, soot layer, 
filter wall, and outlet Channel B.

The model includes four distinct subdomains: the inlet Channel A, the soot layer on 
the surface of the filter wall, the filter wall, and the outlet Channel B.

The filter is 15 cm long, and the height of a single channel is 1.27 mm. The filter wall 
is 0.40 mm thick. Diesel exhaust gas enters the inlet channel, and the gas containing 
soot particles filters off through the porous SiC filter wall, thereby leaving a soot layer 
on top of this wall. The exhaust exits the filter through the outlet channel. This 
example model adds a short inlet-adapter zone and a corresponding outlet-adapter 
zone to make it easier to define stable boundary conditions. You must treat the top 
surface of the soot layer as a moving sub-boundary that grows and shrinks according 
to the amount of soot.

To solve this model, use four application modes in the Chemical Engineering Module:

• Weakly Compressible Navier-Stokes

• Darcy’s Law

• Convection and Diffusion (material balance)

• Convection and Conduction (energy balance)

In addition, a Moving Mesh (ALE) application mode from COMSOL Multiphysics 
handles the moving top boundary of the soot layer.

Soot layer

Top surface of soot layer

Inlet Channel, A

Outlet Channel, B

Filter wall
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The Weakly Compressible Navier-Stokes application mode is defined in both the inlet 
and outlet channels. The Darcy’s Law application mode is defined in the soot layer and 
the filter wall. The Convection and Diffusion application mode is defined in all four 
subdomains as are the Convection and Conduction and the Moving Mesh ALE 
application modes.

There are three issues worth mentioning regarding the domain equations and 
boundary conditions used in the model implementation:

• The top surface of the soot layer represents an outer boundary for the Weakly 
Compressible Navier-Stokes application mode. At this boundary the velocity 
components (x and y) of this application mode are set equal to those of the Darcy’s 
Law application mode. The same procedure is followed at the lower filter wall 
surface (the one facing the outlet channel). At the same boundaries, the Darcy’s Law 
application mode boundary conditions state that the pressure should be equal to 
that of the Weakly Compressible Navier-Stokes Flow application mode.

• The Moving Mesh ALE application mode needs an expression for the mesh velocity 
at the top surface of the soot layer. This expression comes from the equation

where vy is the mesh velocity, v is the y-component of the flow velocity at the top 
surface of the soot layer, Mc equals the molar weight of carbon, Rc denotes the sum 
of all carbon-consuming reaction rates (averaged across the layer thickness), and δsl 
equals the soot layer’s thickness.

• Note that the properties of the porous filter wall and soot layer are a combination 
of those of solids and fluids. For example, in the energy balance, the conduction 
term should include the conductivities of the solid and the fluid, while the 
convection term should contain only the properties of the fluid because the solid 
does not move. The accumulation (time-dependent) term should include a mixture 
of both properties in this way:

vy
ρpart
ρsoot
-------------–⎝ ⎠

⎛ ⎞v
Mcδsl
ρsoot
---------------RC–=

ρmix ρsolid 1 εsolid–( ) ρgasεsolid+=

Cpmix Cpsolid 1 εsolid–( ) Cpgasεsolid+=
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where ρmix is the mixture’s density (kg/m3), Cp,mix is its heat capacity (J/(kg·K)), 
kmix equals its thermal conductivity (W/(m·K)), and εsolid the void fraction 
(porosity).

Results

T H E  C H E M I C A L  R E A C T I O N S  A N D  1 D  M O D E L S

Start by looking at a 1D-model isothermal model, solved for in the Reaction 
Engineering Lab, describing a simplified tubular reactor model for Channel A, 
according to Equation 4-52. The following figures depict the species’ concentration 
along the channel length at two different temperatures, one below “catalyzer ignition” 
temperature, and one above.

Figure 4-20: Composition along the length of the reactor for two operation temperatures, 
653 K and 703 K.

An interesting effect arises at 703 K when the oxygen is depleted. As the temperature 
increases, the rate of oxidation increases until depletion of oxygen take place in the 
reactor. The rate of CeO2 regeneration then decreases substantially and Ce2O3 
becomes the dominating cerium species.

It is interesting to study the ratio of the non-catalyzed to the catalyzed reaction rates 
for the carbon monoxide and carbon dioxide producing reactions. In the following 

kmix ksolid 1 εsolid–( ) kgasεsolid+=

T = 653 K T = 703 K
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figures the reaction rate ratios r1/r3, carbon dioxide production, and r2/r4, carbon 
monoxide production rates are depicted for the two different temperatures.

Figure 4-21: Relationship between the non-catalytic and catalytic carbon-oxidation 
reactions.

Figure 4-21 shows that the catalytic reactions by far dominate the oxidation of carbon. 
This is expected at these relatively moderate temperatures. The oxidation of carbon to 
carbon dioxide has a higher fraction of non-catalyzed oxidation than that of carbon to 
carbon monoxide. The dominance of the catalytic reactions decreases with 
temperature.

T H E  2 D  M O D E L

Figure 4-22 shows the initial velocity distribution in a channel unit cell. The flow 
regime is laminar.

Figure 4-22: Velocity magnitude in a filter unit cell.

T = 653 K T = 703 K
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Figure 4-23 shows the pressure distribution across the channel pair. The the main 
pressure drop is observed across the thin but dense soot layer deposited on top of the 
porous membrane.

Figure 4-23: Pressure distribution in a filter unit cell.

The oxidation of carbon is overall an exothermic reaction, although the catalytic steps 
are endothermic. The regeneration of the catalyst is heavily exothermic and makes up 
for the endothermic properties of the catalytic oxidation reaction. The next figure 
shows the temperature distribution in the system after 300 s for an inlet temperature 
of 550 K. The exhaust gases leaves the filter at somewhat elevated temperatures due to 
the net exothermicity of the reactions.

Figure 4-24: Temperature distribution in the filter for an inlet temperature of 550 K.
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The following illustration (Figure 4-25) shows the soot layer along the length of the 
reactor at an inlet temperature of 550 K. The base-line corresponds to the initial soot 
layer thickness of 50 µm. The artifact at x = 0 appears because you do not allow the 
soot layer to grow or decrease at this position. Under the present conditions, carbon 
oxidation is not sufficient to keep the soot layer from growing.

Figure 4-25: The soot layer’s thickness at 0 to 300 s for 50 s intervals at an inlet 
temperature of 550 K. Time increases upwards in the plot.

Reference

1. G. Konstantas and A.M. Stamatelos, Joint Meeting of the Greek and Italian 
Sections of the Combustion Institute, 
http://www.mie.uth.gr/labs/ltte/pubs/Combust_Inst_Corfou_013.pdf.

Model Library path: Combustion/diesel_filter1

Model Library path: Combustion/diesel_filter2

The following path shows the location of the COMSOL Multiphysics model:
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Model Library path:  
Reaction_Engineering_Lab/Combustion/diesel_filter1

Modeling Using COMSOL Reaction Engineering Lab

You create a first model solely to export it to the Chemical Engineering Module and 
run it as a time-dependent 2D problem. However, prior to solving the 
space-dependent model in COMSOL Multiphysics you modify the reaction model so 
that it models a tube reactor and solve it in Reaction Engineering Lab.

M O D E L  N A V I G A T O R

1 Start the Reaction Engineering Lab.

2 In the Model Navigator, click New.

M O D E L  S E T T I N G S

1 From the Model menu, select Model Settings.

2 Select the Calculate thermodynamic properties check box.

3 Select the Calculate species transport properties check box.

4 Select the Include energy balance check box.

5 Click Close.

R E A C T I O N S  S E T T I N G S — R E A C T I O N  I N T E R F A C E

1 From the Model menu, select Reaction Settings.

2 Create five entries in the Reaction selection list by clicking the New button repeatedly.

3 Enter the following reaction formulas by first selecting the appropriate row in the 
Reaction selection list and then typing the text in the Formula edit field.

REACTION ID # REACTION FORMULA

1 c+o2=>co2

2 c+0.5o2=>co

3 c+4ceo2=>2ce2o3+co2

4 c+2ceo2=>ce2o3+co

5 ce2o3+0.5o2=>2ceo2
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4 On the Kinetics page, specify the following Arrhenius parameters by first selecting 
the appropriate row in the Reaction selection list, then selecting the Use Arrhenius 

expressions check box, and finally typing the corresponding numbers in the edit 
fields.

In this model you cannot evaluate the kinetics by applying the mass action law to 
the set of chemical reaction formulas you entered. Instead, alternative reaction rate 
expressions are used.

5 Select, one by one, the appropriate entry in the Reaction selection list, and replace 
the predefined reaction rates in the r edit field with the following reaction rate 
expressions:

6 Click the Thermo tab.

7 Type the following enthalpies of reaction in the H edit field after selecting the 
appropriate entry in the Reaction selection list:

REACTION ID #  A (forward)  n (forward)  E (forward) 

1 1e13 0 165e3

2 5.5e10 0 150e3

3 4.5e11 0 120e3

4 4e8 0 80e3

5 1e12 0 80e3

REACTION ID #  r

1 kf_1*c0_c*c_o2

2 kf_2*c0_c*c_o2

3 kf_3*c0_c*c_ceo2

4 kf_4*c0_c*c_ceo2

5 kf_5*c_o2*c_ce2o3

REACTION ID #  H

1 -3.96e5

2 -1.1e5

3 6.72e4

4 1.21e5

5 -2.24e5
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R E A C T I O N  S E T T I N G S — S P E C I E S  I N T E R F A C E

1 Click the Species tab.

2 In the Species selection list, verify that six species were automatically generated from 
your reaction formulas: c, o2, co2, co, ceo2, and ce2o3.

3 On the General page, enter the following values for the initial concentrations in the 
c0 edit field after selecting the appropriate entry in the Species selection list.

4 To remove the material balance of carbon, select the Lock concentration/activity 

check box after selecting c in the Species selection list. Specify c0 to 1.

Doing so not only removes the material balance, but also removes the species from 
expressions calculating properties of the reacting mixture.

Nitrogen is also present in the gas but does not take part in the reactions, so the next 
step is to add it as a species.

5 Create a new species entry by clicking New and then typing n2 in the Formula edit 
field.

In this model you also assume that nitrogen is the dominant species in the gas 
mixture and thus serves as a solvent in which the other species are diluted.

6 To define n2 as solvent, select it in the Species selection list and select Solvent from 
the Type list at the upper-right corner of the Reaction Settings dialog box.

7 Type 27.41 in the c0 edit field.

When a species has been selected as solvent, the physical properties of the gas phase 
mixture will be take to be those of the solvent species.

8 Enter the following values for the molecular weight in the M edit field after selecting 
the appropriate entry in the Species selection list. Note that you do not need to 
specify the molecular weights of the cerium species because they are solid and 

SPECIES NAME  c0

o2 3.05

co2 1.525

co 1.525

ceo2 1

ce2o3 0
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therefore not transported. Due to their small concentration they also do not affect 
the fluid density.

9 Click the Thermo tab.

10 From the Species selection list, select n2. Then type the following components in the 
alow,k edit field for Polynomial coefficients:

11 Locate the Tint edit fields for the Temperature interval limits. In the lower edit field 
type 300; in the midpoint edit field type 3000; and in the upper edit field type 3000. 
With this setup you use a single temperature interval to describe nitrogen’s 
thermodynamic properties.

12 Click the Transport tab.

SPECIES NAME  M

o2 32e-3

co2 44e-3

co 28e-3

ceo2 172e-3

ce2o3 328e-3

n2 28e-3

COMPONENT #  n2

1 3.298677

2 0.14082404e-2

3 -0.03963222e-4

4 0.05641515e-7

5 -0.02444854e-10

6 -0.10208999e4

7 3.950372
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13 Type the following interaction potential parameters in the ε/kb and σ edit fields after 
selecting, one by one, the appropriate entries in the Species selection list:

Note that you do not need any transport properties for the cerium species, since 
they will not be mobile. However, you must use some arbitrary numbers in this list 
for the export mechanism to work properly, since the Reaction Engineering Lab will 
try to calculate the diffusion coefficients anyway.

14 Click Close.

C O M P U T I N G  T H E  S O L U T I O N

The reaction model now describes a perfectly mixed tank reactor, with both mass and 
energy balances. This is what you will export to COMSOL Multiphysics in order to 
model the system as space dependent. However, prior to exporting, it is generally a 
good idea to solve the model in order to verify that there are no problems.

1 Click the Model Settings button on the Main toolbar, and then select the Energy 

Balance page.

2 In the Qext edit field for the External heat source, type -15/1.25e-3*(T-473.15).

3 Select the Init page and type 473.15 in the T(t0) edit field for the Initial temperature.

4 Click Close.

5 Click the Solve Problem button (=) on the Main toolbar.

The default plot, shows the concentration of all species. To produce the plot below 
remove the concentration for n2.

6 Click the Plot Parameters button and use the < button to remove n2 from the 
Quantities to plot list on the right.

SPECIES NAME  σ  ε/kb

o2 3.467 106.7

co2 3.941 195.2

co 3.69 91.7

ceo2 1 50

ce2o3 1 50

n2 3.798 71.4
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7 Click OK, and you should get the following figure.

8 Using the menu item File>Save As, you can now save the model for later use (name 
the model diesel_filter1.rxn).

1D Tubular Reactor

The situation in the filter system can be described as a 1D tubular reactor. You then 
use Reaction Engineering Lab to solve for the profiles with respect to position in the 
reactor. In order to do so, the differential equations produced by Reaction 
Engineering Lab for the filter are altered according to Equation 4-52. In addition, the 
model is solved for as being isothermal. Thus, the energy balance is omitted and a 
constant temperature is prescribed.

M O D E L  S E T T I N G S

1 From the Model menu, select Model Settings.

2 Clear the Include energy balance check box.

3 Type 653 in the Temperature edit field.

4 Click Close.
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C O N S T A N T S  A N D  E X P R E S S I O N S

1 From the Model menu select Constants.

2 Specify the following entries by typing in Name, Expression, and Description, at 
completion click OK.

3 From the Model menu select Expressions.

4 Specify the following entries by typing in Name, Expression, and Description, at 
completion click OK.

R E A C T I O N S  S E T T I N G S — R E A C T I O N  I N T E R F A C E

Modify the reaction rates in order to take the difference in domain thickness between 
the catalyzing layer (0.05 mm thick) and the channel (1.27 mm). This is achieved by 
multiplying all reaction rates with the constant Sa.

1 From the Model menu, select Reaction Settings.

2 Edit the Arrhenius parameter for the Frequency factor by multiplying the present 
value with the constant Sa. This is done for each one of the five reactions. Thus type 
in *Sa after the numeral value for each reaction.

R E A C T I O N  S E T T I N G S — S P E C I E S  I N T E R F A C E

Now modify the mass balances according to Equation 4-52.

1 Click the Species tab.

NAME EXPRESSION DESCRIPTION

L 0.15 Reactor Length (m)

u0 2.5 Inlet velocity (m/s)

ku -u0/L Proportionality constant

H 1.27e-3 Channel height (m)

vf u0*H/L Filter gas velocity (m/s)

Sa 5e-5/H Surface area factor

NAME EXPRESSION DESCRIPTION

u u0+ku*t Local channel velocity (m/s)
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2 For each species listed in the table below, replace the Rate expression by typing in 
the indicated expression in the R edit field.

3 Select species n2 and clear the Lock concentration/activity check box.

4 Click Close.

C O M P U T I N G  T H E  S O L U T I O N

Now the model describes the position in the reactor with the independent variable t. 
This means that you have to specify the integration limit to be equal to the reactor 
length.

1 From the Simulation menu, select Solver Parameters.

2 Type 0.149 in the Times edit field. You use 0.149 to avoid describing the stagnant 
zone close to the dead-end of the tubular reactor.

3 Click OK, and then click the Solve Problem button on the Main toolbar.

PO S T P R O C E S S I N G

The produced plot should resemble the left panel of Figure 4-20. To produce the left 
panel of Figure 4-21 follow these steps:

1 Click the Plot Parameters button. Click << to clear the Quantities to plot list.

2 Type r_1/r_3 in the Expression edit field and click > to add it to the Quantities to 

plot list.

3 Type r_2/r_4 in the Expression edit field and click > to add it to the Quantities to 

plot list.

4 Click OK.

In order to calculate the results for the higher temperature use Model>Model Settings 

to change the Temperature to 703, then click the Solve Problem button. Generate the 
right panel of Figure 4-20 and Figure 4-21 by repeating steps 1 to 3 above.

SPECIES NAME Rate expression

o2 ((-r_1-0.5*r_2-0.5*r_5)-ku*c_o2-vf/H*c_o2)/u

co2 ((r_1+r_3)-ku*c_co2-vf/H*c_co2)/u

co ((r_2+r_4)-ku*c_co-vf/H*c_co)/u

ceo2 ((-4*r_3-2*r_4+2*r_5)-ku*c_ceo2-vf/H*c_ceo2)/u

ce2o3 ((2*r_3+r_4-r_5)-ku*c_ce2o3-vf/H*c_ce2o3)/u

n2 -(ku*c0_n2+vf/H*c0_n2)/u
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5 Use the menu item File>Save As to save the model for later use (name the model 
diesel_filter2.rxn).

Modeling Using COMSOL Multiphysics

You first generate a moving-mesh model of the filtration process before actually 
exporting the kinetic model from the Reaction Engineering Lab into the Chemical 
Engineering Module.

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics.

2 From the list of application modes, select  
COMSOL Multiphysics>Deformed Mesh>Moving Mesh (ALE)>Transient analysis.

3 Click the Multiphysics button, then click Add.

4 From the list of application modes, select  
Chemical Engineering Module>Flow with Variable Density>Weakly Compressible 

Navier-Stokes>Transient analysis

5 Click Add.

6 From the list of application modes, select  
Chemical Engineering Module>Momentum Transport>Porous Media Flow>Darcy’s 

Law>Transient analysis.

7 Click Add.

8 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 Choose Options>Constants.

2 Enter constants according to the table below in the Constants dialog box.

NAME EXPRESSION

visc 3e-5

kappa 1e-11

kappa1 1e-13

Tin 550

cpn2 1532

kn2 0.06

densn2 0.525
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3 Click OK.

4 From the Options>Expressions menu, select Scalar Expressions and enter expressions 
according to the table below.

5 Click OK.

G E O M E T R Y  M O D E L I N G

1 Hold the Shift key and click the Rectangle/Square button on the Draw toolbar. Enter 
the values for rectangle R1 from the following table. Repeat the procedure for 
rectangles R2 through R6.

2 Click OK.

3 Double-click EQUAL on the status bar at the bottom of the user interface and then 
click the Zoom Extents button on the Main toolbar.

4 With the mouse, select rectangles R1 and R2 (Ctrl-click), then click the Create 

Composite Object button on the Draw toolbar.

5 Clear the Keep interior boundaries check box, then click OK.

kmix 30

Pat 1.013e5

poro 0.5

paco 5e-4

pade 1920

Mc 12e-3

des 5e-5

NAME EXPRESSION

dx dx_ale

dy dy_ale

PROPERTY R1 R2 R3 R4 R5 R6

Width 1e-2 0.15 0.15 0.15 0.15 1e-2

Height 1.27e-3 1.27e-3 5e-5 4e-4 1.27e-3 1.27e-3

Base Corner Corner Corner Corner Corner Corner

x -1e-2 0 0 0 0 0.15

y 0 0 -5e-5 -4.5e-4 -1.72e-3 -1.72e-3

NAME EXPRESSION
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6 With the mouse, select rectangles R5 and R6, then click the Create Composite Object 
button on the Draw toolbar.

7 Make sure that the Keep interior boundaries check box is cleared.

8 Click OK.

9 From the Options>Expressions menu, select Subdomain Expressions and define 
expressions according to the table below.

10 Click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings—Weakly Compressible Navier-Stokes
1 Choose Multiphysics>Weakly Compressible Navier-Stokes (chns).

2 Choose Physics>Subdomain Settings.

3 From the Subdomain selection list, select 1 and 2.

4 In the Dynamic viscosity edit field, type visc.

5 Go to the Density page and type densn2 in the ρ edit field.

6 Click the Init tab, and type Pat in the Pressure edit field.

7 From the Subdomain selection list, first click to select 3 and then Ctrl-click 4.

8 Clear the Active in this subdomain check box.

9 Click OK.

10 Choose Physics>Properties.

11 From the Weak constraints list, select On.

12 From the Constraint type list, select Non-ideal.

13 Click OK.

Subdomain Settings—Darcy’s Law
1 Choose Multiphysics>Darcy’s Law (chdl).

2 Choose Physics>Subdomain Settings.

NAME EXPRESSION IN 
SUBDOMAINS 1 & 2

EXPRESSION IN 
SUBDOMAIN 3 & 4

uall u u_chdl

vall v v_chdl

Uall sqrt(uall^2+vall^2) sqrt(uall^2+vall^2)

Pall p p2
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3 In the Subdomain selection list, Ctrl-click to select 1 and 2.

4 Clear the Active in this subdomain check box.

5 From the Subdomain selection list, select 3.

6 In the Porosity edit field, type poro.

7 In the Density edit field, type densn2.

8 In the Permeability edit field, type kappa.

9 In the Dynamic viscosity edit field, type visc.

10 Click the Init tab and in the Pressure edit field, type Pat.

11 Click the Physics tab.

12 In the Subdomain selection list, select 4.

13 In the Porosity edit field, type poro.

14 In the Permeability edit field, type kappa1.

15 In the Density edit field type densn2.

16 In the Dynamic viscosity edit field, type visc.

17 Click the Init tab, and in the Pressure edit field, type Pat.

18 Click OK.

19 Choose Physics>Properties.

20 From the Weak constraints list, select On.

21 From the Constraint type list, select Non-ideal.

22 Click OK.

Subdomain Settings—Moving Mesh (ALE)
1 From the Multiphysics menu, select Moving Mesh (ALE) (ale).

2 Choose Physics>Subdomain Settings.

3 From the Subdomain selection, list select 2 and 3.

4 Click to select the no displacement button.

5 Click OK.

Boundary Conditions—Weakly Compressible Navier-Stokes
1 Choose Multiphysics>Weakly Compressible Navier-Stokes (chns).

2 Choose Physics>Boundary Settings.
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3 Make selections from the Boundary selection list and enter the corresponding 
settings:

4 Click OK.

Boundary Conditions—Darcy’s Law
1 Choose Multiphysics>Darcy’s Law (chdl).

2 Choose Physics>Boundary Settings.

3 Make selections from the Boundary selection list and enter the following settings:

For all other active boundaries, keep the default Insulation/Symmetry condition.

4 Click OK.

Boundary Conditions—Moving Mesh (ALE)
1 Choose Multiphysics>Moving Mesh (ALE) (ale).

2 Choose Physics>Boundary Settings.

3 Select all boundaries, then select the dx and dy check boxes to prevent any 
displacements.

4 Select Boundaries 8, 15, and 16, then clear the dy check box.

5 Select the Interior boundaries check box.

6 Select Boundary 10.

7 Select the Mesh velocity option button.

SETTINGS BOUNDARY 1 BOUNDARY 7 BOUNDARY 10 BOUNDARY 17 ALL OTHERS

Boundary 
type

Inlet Inlet Outlet Outlet Wall

Boundary 
condition

Velocity Velocity Velocity Pressure, no 
viscous 
stress

No slip

u0 15*s*(1-s) -kappa/
visc*p2x

-kappa1/
visc*p2x

v0 -kappa/
visc*p2y

-kappa1/
visc*p2y

SETTINGS BOUNDARIES 7, 10

Boundary condition Pressure condition

p0 p
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8 Select the vy check box and type -paco/pade*v in the corresponding edit field. 
Doing so displaces the boundary in proportion to the flow velocity across it and the 
particle density in the incoming flow.

9 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Mapped Mesh Parameters.

2 Click the Boundary tab, select all boundaries, and check the Constrained edge element 

distribution check box. Then define the Number of edge elements as in this table:

3 Click Remesh.

4 Click OK.

E X P O R T I N G  F R O M  T H E  R E A C T I O N  E N G I N E E R I N G  L A B

1 In COMSOL Multiphysics choose File>Reaction Engineering Lab. This selection 
opens the Reaction Engineering Lab.

2 Choose File>Open. In the Open Model dialog box, browse to the model 
diesel_filter1.rxn that you created earlier in this exercise.

3 Click Open.

4 Click the Export to COMSOL Multiphysics button.

5 A new dialog box appears. In the Export mass balance area, go to the 
Application mode list and select Convection and Diffusion: New.

6 In the corresponding Group name edit field, type mat_bal.

7 In the Export energy balance area, go to the Application mode list and select 
Convection and Conduction: New.

8 In the corresponding Group name edit field, type en_bal.

9 Clear the Export momentum balance check box.

10 Click Export.

11 Exit the Reaction Engineering Lab.

You can now continue the modeling procedure in COMSOL Multiphysics.

SETTING BOUNDARIES 5, 7, 9–11 BOUNDARIES 8, 15 ALL OTHERS

Number of edge elements 40 1 5
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P H Y S I C S  S E T T I N G S

Subdomain Settings—Convection and Diffusion
1 Choose Multiphysics>Convection and Diffusion (chcd).

2 Choose Physics>Subdomain Settings.

3 Go to the Subdomain selection list and select all the entries.

4 From the Group list (just below the Subdomain selection list), select mat_bal.

5 For c_o2, c_co2, and c_co, find the x-velocity edit field and type uall, then find the 
y-velocity edit field and type vall.

6 Click the c_ceo2 tab. In the Diffusion coefficient edit field, type 1e-10. (Note that you 
delete the unwieldy expression created by the Reaction Engineering Lab.)

7 Click the c_ce2o3 tab. In the Diffusion coefficient edit field, type 1e-10.

8 Click Apply.

9 From the Subdomain selection list, select 1, 2, and 3.

10 Replace the expression in the Reaction rate edit field with 0 for all species. Do so in 
order to neglect the reaction in the bulk of the fluid.

11 Click OK.

Subdomain Settings—Convection and Conduction
1 Choose Multiphysics>Convection and Conduction (chcc).

2 Choose Physics>Subdomain Settings.

3 Go to the Subdomain list and select all the entries.

4 From the Group list, select en_bal.

5 In the x-velocity edit field, type uall, and in the y-velocity edit field, type vall.

6 Click the Init tab, find the Temperature field, and type Tin.

7 Click Apply.

8 Click the Physics tab.

9 From the Subdomain list, select 1, 2, and 3.

10 Replace the expression in the Heat source edit field with 0.

11 Click Apply.

12 From the Subdomain list, select 3 and 4.

13 Replace the expression in the Thermal conductivity edit field with kmix.

14 Click OK.
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Boundary Settings
1 Choose Multiphysics>Convection and Diffusion (chcd).

2 Choose Physics>Boundary Settings.

3 Apply the boundary conditions from the following table for all species, then click 
OK.

4 Choose Multiphysics>Convection and Conduction (chcc).

5 Choose Physics>Boundary Settings.

6 Set the boundary conditions as in the table below, then click OK.

For all other active boundaries, keep the default Thermal insulation condition.

7 Choose Multiphysics>Moving Mesh (ALE) (ale).

8 Choose Physics>Boundary Settings.

9 From the Boundary list, select 10.

10 Select the Mesh velocity option button.

11 Select the vy check box and replace the expression in the associated edit field with 
-paco/pade*v+Mc/pade*(dy+des)* 

(r_1_rxn_chcd+r_2_rxn_chcd+r_3_rxn_chcd+r_4_rxn_chcd). This 
expression includes the reactions that consume the soot particles.

12 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

In a model described by a strongly coupled system of equations, it is often a good 
practice to solve the problem sequentially to avoid convergence issues. Here you start 
by solving for the stationary flow. After that, you couple the mass and energy balances 

BOUNDARY c_o2 c_co2 c_co c_ceo2 c_ce2o3

1 Conc. Conc. Conc. Conc. Conc.

3.05 1.525 1.525 1 0

17 Convect. 
flux

Convect. 
flux

Convect. 
flux

Convect. 
flux

Convect. 
flux

All others Insulation Insulation Insulation Insulation Insulation

SETTINGS BOUNDARY 1 BOUNDARY 17

Boundary condition Temperature Convective flux

T0 Tin
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to the flow. Finally, you solve the full time-dependent system, with the dynamic nature 
of the soot layer handled by the Moving Mesh (ALE) application mode.

1 Click the Solver Parameters button on the Main toolbar.

2 From the Solver list, select Stationary.

3 Click OK.

4 Click the Solver Manager button on the Main toolbar.

5 Click the Solve For tab.

6 From the list of application modes, select Weakly Compressible Navier-Stokes and 
Darcy’s Law.

7 Click the Solve button on the Main toolbar.

8 In the list of application modes, select all application modes except Moving Mesh 

(ALE).

9 Click OK.

10 Click the Restart button on the Main toolbar.

11 Click the Solver Parameters button on the Main toolbar.

12 From the Solver list, select Time dependent.

13 In the Times edit field, type 0:10:300.

14 Click OK.

15 Click the Solver Manager button on the Main toolbar.

16 Click the Solve For tab. Press Ctrl+A to select all variables.

17 Click OK.

18 Click the Restart button on the Main toolbar.

P O S T P R O C E S S I N G

To reproduce the plot in Figure 4-22 do the following steps.

1 Open the Plot Parameters dialog box.

2 On the General page set Solution at time to 0.

3 Go to the Surface page and type Uall in the Expression edit field.

4 Go to the Streamline page, select Streamline plot and type uall and vall as X and 
Y component respectively.

5 Set Streamline plot type to Magnitude controlled.

6 On the Line Color page set the Uniform color to white.
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7 Click OK.

Create the plot in Figure 4-23 with the following steps.

1 Open the Plot Parameters dialog box and clear the Streamline plot check box

2 Go to the Surface page and type Pall in the Expression edit field.

3 Click OK.

The following steps reproduces Figure 4-24.

1 Open the Plot Parameters dialog box.

2 On the Surface page type T in the Expression edit field.

3 Go to the General page and set Solution at time to 300.

4 Click OK.

To create the plot in Figure 4-25 do the following steps.

1 Open the Domain Plot Parameters dialog box from the Postprocessing menu.

2 Select 0, 50, 100, 150, 200, 250 and 300 from the Solutions to use list.

3 On the Line/Extrusion page select Boundary 9 and select y-displacement in the 
Predefined quantities list.

4 Click OK.
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S e l e c t i v e  C a t a l y t i c  R edu c t i o n  o f  NOx

Introduction

The removal of pollutants from high-temperature gases is often required in 
combustion processes. In this example, the selective reduction of NOx by ammonia 
occurs as flue gas passes through a honeycomb reactor. The chemical reactions take 
place on the surface of a V2O5/TiO2 catalyst that is supported on a ceramic structure.

This example shows how to use the COMSOL Reaction Engineering Lab in concert 
with the Chemical Engineering Module to readily solve advanced engineering 
problems. You can start by setting up the reaction kinetics in the Reaction Engineering 
Lab and then model the chemistry assuming that each of the channels in the monolith 
behaves as a plug-flow reactor. This gives you a notion about the magnitude of 
important design parameters such as the residence time and selectivity as a function of 
temperature. In a second part of the example, you set up a reactor model taking the 
actual geometry of a monolith channel into account by exporting the reaction model 
from Reaction Engineering Lab to the Chemical Engineering Module. In the 
space-dependent model you can solve the mass-balance equations coupled to the 
momentum balances for free flow and porous media flow.

Note: Solving the second part of this model requires the Chemical Engineering 
Module.

Model Definition

NO reduction by ammonia can be summarized by the following reaction:

 (4-53)

However, ammonia can at the same time undergo oxidation:

 (4-54)

When optimizing the conversion of NO, you consequently seek to minimize the 
oxidation reaction while maintaining a reasonable reaction rate for the reduction.

4NO 4N2O2+ 6H2O+4NH3+

4NO 4N2O2+ 6H2O+4NH3+
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The heterogeneous catalytic conversion of NO to N2 is described by an Eley-Rideal 
mechanism. A key reaction step involves the reaction of gas-phase NO with 
surface-adsorbed NH3. The following rate equation (mol/(m3·s)) has been suggested 
in Ref. 1 for Equation 4-53:

 (4-55)

where

 (4-56)

and

 (4-57)

For Equation 4-54, the reaction rate (mol/(m3·s)) is given by

 (4-58)

where

 (4-59)

This example investigates the conversion of NOx through two reactor models. You 
first set up and solve a plug-flow reactor in the COMSOL Reaction Engineering Lab, 
and then you solve a space-dependent reactor model using COMSOL Multiphysics.

Assuming steady, the design equation for a plug-flow reactor is given by:

 (4-60)

where Fi is the species molar flow rate (mol/s), V represents the reactor volume (m3), 
and is Ri the species net reaction rate (mol/(m3·s)). The molar flow rate is related to 
the species concentrations, ci (mol/m3), through the volumetric flow rate, v (m3/s):

 (4-61)

r1 k1cNO
acNH3

1 acNH3+
---------------------------=

k1 A1
E1

RgT
-----------–⎝ ⎠

⎛ ⎞exp=

a A0
E0

RgT
-----------–⎝ ⎠

⎛ ⎞exp=

r2 k2cNH3=

k2 A2
E2

RgT
-----------–⎝ ⎠

⎛ ⎞exp=

Fd i

Vd
--------- Ri=

Fi vci=
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where the volumetric flow rate is given by the average flow velocity, u (m/s), 
multiplied by the reactor cross-section  A (m2):

 (4-62)

The mass balances given by Equation 4-60 are set up and solved in the Reaction 
Engineering Lab.

The plug-flow model considerably simplifies the reaction conditions compared to 
actual reactors used in industry. In the extended example, the conversion of NOx 
occurs in a honeycomb reactor, which consists of packets of thin parallel channels 
through which the flue gas flows. The ceramic channel walls are coated with a porous 
catalytic layer, in this case V2O5/TiO2.

The transport and reaction of chemical species can be divided into several steps: First 
the reactants are transported in the direction of the flow, mainly by convection in the 
open channels. The reactants diffuse towards the walls and into the porous catalyst 
where they react on the catalyst surface. Formed products subsequently diffuse out of 
the porous structure and are transported out of the reactor through the open channels.

The model setup in COMSOL Multiphysics corresponds to a single channel of the 
honeycomb structure. The model assumes the channel is cylindrical, making it possible 
to reduce the modeling domain to a 2D geometry with rotational symmetry. The 
model geometry appears in Figure 4-26.

Figure 4-26: Geometry of a reactor-channel model taking axial symmetry into account. 
Dimensions are in meters (m).
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M O M E N T U M  TR A N S P O R T

The flow in the free channel is described by the Navier-Stokes equations:

 (4-63)

where ρ denotes density (kg/m3), u represents the velocity (m/s), η denotes viscosity 
(kg/(m· s)), and p equals pressure (Pa). In the porous domain, the Brinkman 
equations describe the flow:

 (4-64)

Here εp denotes the porosity (dimensionless) and  k refers to the permeability (m2) of 
the porous medium. As you can see in Equation 4-63 and Equation 4-64, the 
momentum-balance equations are closely related. The term on the right-hand side of 
the Navier-Stokes formulation corresponds to momentum transported by convection 
in free flow. In the Brinkman formulation, this term is replaced by a contribution 
associated with the drag force experienced by the fluid as it flows through a porous 
medium. COMSOL Multiphysics effortlessly combines free flow and porous-media 
flow.

The boundary conditions are

 (4-65)

At the outlet viscous stresses are ignored and the pressure is set to 1 atmosphere.

M A S S  T R A N S P O R T

The mass-balance equations for the model are the diffusion-convection equations at 
steady state:

 (4-66)

Here Di denotes the diffusion coefficient (m2/s), ci is the species concentration, and 
u equals the velocity vector (m/s). The term  Ri corresponds to the species’ net 
reaction rate, which is a function of the reaction rates, Equation 4-55 and 
Equation 4-58, and the reaction stoichiometry.

∇ η– ∇u ∇u( )T
+( ) pI+[ ]⋅ ρ u ∇⋅( )u–=

∇ u⋅ 0=

∇ η
εp
-----– ∇u ∇u( )T

+( ) pI+⋅ η
k
---u–=

∇ u⋅ 0=

u n⋅ v0=

u 0      =

p pref  =

inlet
walls

  outlet

∇ Di∇– ci ciu+( )⋅– Ri=
S E L E C T I V E  C A T A L Y T I C  R E D U C T I O N  O F  N O X  |  237



238 |  C H A P T E
In the free channel, the inlet conditions are equal to the inlet concentrations:

 (4-67)

At the outlet, use the convective flux condition

 (4-68)

All other boundaries use the insulating or symmetry condition

 (4-69)

TR A N S P O R T  P R O P E R T I E S

Setting up momentum and mass balances requires that certain physical properties 
characteristic of the reacting fluid are determined. For instance, the Navier-Stokes 
equation (Equation 4-63) and the Brinkman equation (Equation 4-64) both require 
the fluid viscosity. Furthermore, the mass balances need species specific diffusion 
coefficients as input.

For reacting gas mixtures, the Reaction Engineering Lab makes use of kinetic gas 
theory to set up expressions for transport properties such as binary diffusivities, 
viscosity, and thermal conductivity as functions of temperature, pressure, and 
composition. In this example, the diffusivities (m2/s) are calculated using the formula:

 (4-70)

where ΩD is a collision integral

.  (4-71)

Furthermore gas viscosity (Ns/m2) is given by the expression:

 (4-72)

where Ωv is a collision integral

.  (4-73)

c cin=

n D∇– c( )⋅ 0=

n D∇– c cu+( )⋅ 0=

D 2.695 10 3– T3 MA MB+( ) 2 103M⋅ AMB( )⁄( )
pσAσBΩD

-------------------------------------------------------------------------------------------⋅ ⋅=

ΩD f T σ ε
k
--- µ, , ,⎝ ⎠

⎛ ⎞=

η 2.699 10 6– T 1 103M⋅( )
σ2Ωv

------------------------------------⋅ ⋅=

Ωv f T σ ε
k
--- µ, , ,⎝ ⎠

⎛ ⎞=
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To evaluate Equation 4-70 and Equation 4-72, you need to specify the characteristic 
length and energy minimum of the Lennard-Jones interaction potential, that is σ 
(10-10 m) and the ε/k (K), respectively. The species dipole moment, µ (Debye), can 
also be provided. Each species in the reacting gas has a characteristic set of these 
constants, and you find their values in the literature, in databases, or from experiments. 
The parameters σ, ε/k, and µ can either be entered manually in the Reaction 
Engineering Lab GUI, or you can import text files containing the data. In this model 
you import transport data using the Import CHEMKIN File feature.

The structure of a CHEMKIN transport data file is illustrated below:

The first column indicates the species name; the second column contains an index 
describing the geometrical configuration of the molecule; the third column provides 
the value for ε/k; the fourth column lists the value for σ; the fifth column gives the 
value of µ; the sixth column indicates polarizability; and the seventh column lists 
rotational relaxation collision number.

The entries given in columns 1, 3, 4, and 5 are read into the Reaction Engineering Lab 
when selecting the menu item File>Import>CHEMKIN Transport Input File.

Resources for kinetic, thermodynamic, and transport data on the CHEMKIN format 
are available on the web (see, for instance, www.comsol.com/reaction).

Results

First review the results of the plug-flow model, which you set up and solve in the 
Reaction Engineering Lab.

Figure 4-27 shows the concentrations of NO and NH3 as functions of the reactor 
volume. Reactions take place at 523 K and that the gas enters the reactor with a 
velocity of 0.3 m/s. The reactor is assumed to be a channel with a length of 0.36 m 

NO 0 97.500 3.620 0.000 0.000 0.000

NH3 0 558.300 2.900 1.470 0.000 0.000

O2 0 106.700 3.470 0.000 0.000 0.000

N2 0 71.400 3.800 0.000 0.000 0.000

H2O 0 809.100 2.640 1.880 0.000 0.000
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and a radius of 2 mm. Under these conditions, the simulations show that most of the 
NO has been converted as the gas leaves the reactor (NO converted > 99%).

Figure 4-27: Concentrations of NO and NH3 as functions of axial distance from the 
reactor inlet. S is the selectivity parameter.

The plot also shows the selectivity parameter, S, giving the ratio of reaction rates 
according to

 (4-74)

S varies between 3.6 and 2.7 along the reactor length, indicating that the reduction of 
NO is the dominating reaction pathway.

Figure 4-28 shows the initial reaction rate of NO reduction (r1) and NH3 oxidation 
(r2) in the temperature interval 450–750 K. Up to approximately 655 K, NH3 is 
mainly consumed by the desired reduction reaction, Equation 4-53. At about 670 K 
the rate of NO reduction reaches a maximum. Above this temperature the desorption 

S
r1
r2
-----=
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of NH3 from the catalyst surface becomes faster than the reaction of adsorbed NH3 
with gas-phase NO.

Figure 4-28: Initial rates of NO reduction (Reaction rate 1) and NH3 oxidation 
(Reaction rate 2) as functions of temperature for the plug-flow reactor model.

The following results come from the space-dependent reactor model, which you set up 
and solve in COMSOL Multiphysics. In this case, the chemistry takes place in a 
channel of a honeycomb reactor.

Figure 4-29 shows the fluid velocity profile, given as a function of radial position at the 
channel midpoint.

Figure 4-29: Flow velocity as a function of radial position.
S E L E C T I V E  C A T A L Y T I C  R E D U C T I O N  O F  N O X  |  241



242 |  C H A P T E
Figure 4-30 displays the concentration of NO across the reactor channel. Integrating 
the boundary flux of NO across the inlet and outlet allows you to calculate the 
conversion of NO as being 89%.

Figure 4-30: Concentration of NO across the space-dependent model domain.

It is easy to extend the model to study the effects of different design parameters such 
as reaction temperature, inlet velocity, and geometry. It can also easily take into 
account the effect of material properties such as the permeability of the porous region.

Figure 4-31 compares the results of the plug-flow model and the reactor model 
including the actual channel geometry. For the channel model, the NO concentration 
shown is the average concentration evaluated along the section of channel length 
affected by the catalytic washcoat (0.36 m). The average inlet velocity in the channel 
model is 0.3 m/s.
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Figure 4-31: Concentration of NO (mol/m3) along the reactor channel. The solid line 
represents data from the plug-flow model and the dashed line represents the mean 
concentration evaluated from the channel model.

The assumptions underlying the plug-flow model readily explain the differences in 
results. In the plug-flow model, reactions are assumed to occur homogeneously 
throughout the reactor volume. Because the species need not be transported to and 
from the bulk flow to the reactive washcoat, as is the case in the channel model, the 
conversion of reactants is, of course, faster.

In summary: This example illustrates the modeling of a heterogeneous catalytic process 
using the COMSOL Reaction Engineering Lab and the Chemical Engineering 
Module. The Reaction Engineering Lab helps you set up the chemical kinetics and 
expressions describing the transport properties of the reacting mixture. In COMSOL 
Multiphysics you study the reacting flow in a specific reactor geometry.

Reference

1. G. Shaub, D. Unruh, J. Wang, and T. Turek, Chemical Engineering and 
Processing, vol. 42, p. 365, 2003.

The following path gives the location of the Reaction Engineering Lab model:

Model Library path: Combustion/nox_reduction
S E L E C T I V E  C A T A L Y T I C  R E D U C T I O N  O F  N O X  |  243



244 |  C H A P T E
The following path shows the location of the COMSOL Multiphysics model:

Model Library path:  
Chemical_Engineering_Module/Transport_and_Reactions/nox_reduction

Modeling Using the COMSOL Reaction Engineering Lab

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics.

2 In the Model Navigator, go to the Space dimension list and select Axial symmetry (2D).

3 Click OK.

The main user interface of COMSOL Multiphysics opens up.

4 From the File menu, select Reaction Engineering Lab.

The main user interface of COMSOL Reaction Engineering Lab opens up.

5 Click the COMSOL Reaction Engineering Lab window.

O P T I O N S  A N D  S E T T I N G S

1 Click the Model Settings button on the Main toolbar.

2 From the Reactor type list, select Plug-flow.

3 Select the Calculate thermodynamic properties check box.

4 Select the Calculate species transport properties check box.

5 On the General page, type 523 in the Temperature edit field.

6 On the Mass Balance page, type v_av*A in the Volumetric flow rate edit field.

7 Click Close.

R E A C T I O N S  I N T E R F A C E

1 Click the Reaction Settings button on the Main toolbar.

2 Make sure the Reactions page is active. Create two entries in the Reaction selection 

list by clicking the New button twice.
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3 Enter the following reaction formulas by first selecting the appropriate row in the 
Reaction selection list and then entering the corresponding text in the Formula edit 
field:

4 Select the first row in the Reaction selection list.

5 Select the Use Arrhenius expressions check box.

6 Type 1e6 in the A edit field and 60e3 in the E edit field.

7 Modify the predefined reaction rate according to Equation 4-55 on page 235 by 
typing kf_1*c_NO*a*c_NH3/(1+a*c_NH3) in the r edit field.

You define the expression for a later on.

8 Select the second row in the Reaction selection list.

9 Select the Use Arrhenius expressions check box.

10 Type 6.8e7 in the A edit field and 85e3 in the E edit field.

11 Modify the predefined reaction rate according to Equation 4-58 on page 235 by 
typing kf_2*c_NH3 in the r edit field.

S P E C I E S  I N T E R F A C E

1 Click the Species tab.

2 Check that the Species selection list has the five entries expected from entering the 
reaction formulas just given.

3 Click the General tab. Select the appropriate entry in the Species selection list and 
then enter the corresponding value for the Molecular weight:

REACTION ID # REACTION FORMULA

1 4NO+4NH3+O2=>4N2+6H2O

2 4NH3+3O2=>2N2+6H2O

SPECIES NAME  M [kg/mol]

NO 30e-3

NH3 17e-3

O2 32e-3

N2 28e-3

H2O 18e-3
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4 Select N2 from the Species selection list and choose Solvent from the Type list.

This selection is appropriate when a species is the main component of a reaction 
mixture. Setting a species as a Solvent removes its mass balance (the concentration is 
assumed to be constant). Furthermore, the thermodynamic and transport 
properties of the reacting mixture are based on the properties of the solvent species.

5 Click the Feed Stream tab. Select the appropriate entry in the Species selection list 
and then enter the corresponding value for the Inlet molar flow:

6 Select File>Import>CHEMKIN Transport Input File and browse to the file 
nox_reduction_transport.txt then click Import.

This imports the Lennard-Jones parameters required to set up expressions for the 
fluid viscosity and species diffusivities.

7 Click the Transport page and verify that the σ, ε/kB, and µ edit fields have been 
updated with the appropriate parameter values.

As an alternative to reading in the values from file, you can type in the appropriate 
values in the σ, ε/kB, and µ edit fields:

8 Click Close.

SPECIES NAME  F0 [mol/s]

NO 3.07e-8

NH3 3.96e-8

O2 6.67e-6

N2 7.23e-5

H2O 8.78e-6

SPECIES NAME  σ [m]  ε/kB [K]   µ [D]

NO 3.62 97.5 0

NH3 2.90 558.3 1.47

O2 3.47 106.7 0

N2 3.80 71.4 0

H2O 2.64 809.1 1.88
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O P T I O N S  A N D  S E T T I N G S

1 Choose Model>Constants and type in the following entries:

2 Click OK.

3 Choose Model>Expressions and type in the following entries:

4 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 In the Reactor volumes edit field, type pi*0.002^2*0.36, that is, the volume of the 
monolith channel.

3 Set the Relative tolerance to 1e-9 and the Absolute tolerance to 1e-10.

4 Set the Steady-state relative tolerance to 1e-12.

5 Click OK.

6 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The concentration transients of all species are plotted by default. Reproduce 
Figure 4-27 on page 240 and the plug-flow graph of Figure 4-31 on page 243 with 
the following steps:

1 Click the Plot Parameters button on the Main toolbar.

2 Remove all entries from the Quantities to plot list by clicking the << button.

3 In the Expression edit field type c_NO, then click the > button.

NAME EXPRESSION DESCRIPTION

A0 2.68e-17 Frequency factor (1/s)

E0 -243e3 Activation energy (J/mol)

rad 2e-3 Channel radius (m)

A pi*rad^2 Channel cross section

v_av 0.3 Average gas velocity (m/s)

NAME EXPRESSION DESCRIPTION

a A0*exp(-E0/(Rg*T)) Arrhenius expression

S r_1/r_2 Selectivity parameter

z t/A Axial distance from inlet
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4 In the x-axis data area, click first the lower option button and then the Expression 
button. In the Expression edit field, type z, then click OK.

5 From the Plot in list, select New figure. Click Apply to generate the first part of 
Figure 4-31 in a separate figure window; leave this window open.

6 In the Expression edit field type c_NH3, then click the > button.

7 In the Expression edit field type S/1000, then click the > button.

8 From the Plot in list, select Main axes, then click OK to generate the plot in 
Figure 4-27.

Now move on to see how temperature affects the initial reaction rates.

O P T I O N S  A N D  S E T T I N G S

1 Click the Model Settings button on the Main toolbar.

2 On the General page, type 450+300*t in the Temperature edit field.

As you later set the simulation time to 1 second, this imposes a temperature profile 
increasing linearly from 450 K at t = 0 to 750 K at t = 1 s.

3 Click Close.

S P E C I E S  I N T E R F A C E

1 Click the Reaction Settings button on the Main toolbar.

2 Click the Species tab.

3 Click the General tab.

4 Select NO from the Species selection list, then select the Lock concentration/activity 
check box.

5 Type F0_NO/(v_av*A) in the Initial concentration edit field.

Note how you can use the default variable name for the inlet molar flow and divide 
it by the volumetric flow to create an expression for the initial concentration.

6 Select NH3 from the Species selection list and select the Lock concentration/activity 
check box.

7 Type F0_NH3/(v_av*A) in the Initial concentration edit field.

8 Click Close.

By locking the concentrations of the species affecting the reaction rates r1 and r2 
you can evaluate the initial rates as functions of temperature.
R  4 :  M O D E L  L I B R A R Y



C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 In the Reactor volumes edit field type 1.

3 Click OK.

4 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Reproduce Figure 4-28 on page 241 with the following steps:

1 Click the Plot Parameters button on the Main toolbar.

2 Remove all entries from the Quantities to plot list by clicking the << button.

3 In the Predefined quantities list, select Reaction rate 1, then click the > button.

4 In the Predefined quantities list, select Reaction rate 2, then click the > button.

5 Click the Expression option button in the x-axis data area.

6 Click the Expression button and type T in the edit field. Click OK.

7 Click OK to close the Plot Parameters dialog box and generate the plot.

Now restore some of the settings in the Reaction Engineering Lab before moving on 
to export the reaction model to COMSOL Multiphysics.

O P T I O N S  A N D  S E T T I N G S

1 Click the Model Settings button on the Main toolbar.

2 Type 523 in the Temperature edit field.

3 Click Close.

S P E C I E S  I N T E R F A C E

1 Click the Reaction Settings button on the Main toolbar.

2 Click the Species tab.

3 Select NO from the Species selection list. Clear the Lock concentration/activity check 
box and type 0 in the Initial concentration edit field.

4 Select NH3 from the Species selection list. Clear the Lock concentration/activity check 
box and type 0 in the Initial concentration edit field.

5 Click Close.

E X P O R T  S E T T I N G S

1 Click the Export to COMSOL Multiphysics button on the Main toolbar.
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2 The Export to COMSOL Multiphysics dialog box appears.

3 Go to the Export mass balance area, and in the Application mode list select Convection 

and Diffusion: New.

4 In the Group name edit field type mass.

5 Move to the Export energy balance area and clear the check box in the upper left 
corner.

6 Go to the Export momentum balance area, and in the Application mode list select 
Incompressible Navier-Stokes: New.

7 In the Group name edit field type momentum.

8 Click the Export button at the bottom of the dialog box.

Modeling Using COMSOL Multiphysics

It is now time to investigate the chemistry taking place in a space-dependent model, in 
this case in a channel of a honeycomb reactor. After drawing the model geometry you 
use the application modes (predefined balance equations) of the Chemical Engineering 
Module to set up and solve mass and momentum balances.

Click the COMSOL Multiphysics window.

G E O M E T R Y  M O D E L I N G

Remember that in the axisymmetry modes, the symmetry axis is at  r (or x) = 0, and 
that the geometry is built to the right of the axis.

1 Press the Shift key and click the Rectangle/Square button.

2 Type the following values in the corresponding edit fields for the rectangle 
dimensions:

3 Click OK.

4 Press the Shift key again and click the Rectangle/Square button.

SIZE POSITION

Width 2e-3 r 0

Height 400e-3 z 0
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5 Type the following values in the corresponding edit fields for the rectangle 
dimensions:

6 Click OK.

Now zoom in on this very narrow geometry.

7 Choose Option>Axes/Grid Settings.

8 Clear the Axis equal check box. In the r-z limits area, enter the following settings:

9 Click OK.

O P T I O N S  A N D  S E T T I N G S

Constants
1 From the Options menu, select Constants.

2 Enter the following parameter names and values in the Constants dialog box:

3 Click OK.

SIZE POSITION

Width 1e-3 r 2e-3

Height 360e-3 z 20e-3

PROPERTY VALUE

r min -0.003

r max 0.005

z min -0.01

z max 0.41

NAME EXPRESSION DESCRIPTION

v_av 0.3[m/s] Average inlet velocity

p_ref 101325[Pa] Pressure

eps_p 0.4 Porosity

k 1e-8[m^2] Permeability

k_eff 0.25 Effectiveness factor

c_NO_in 8.16e-3[mol/m^3] Inlet concentration

c_NH3_in 1.05e-2[mol/m^3] Inlet concentration

c_O2_in 1.77[mol/m^3] Inlet concentration

c_H2O_in 2.33[mol/m^3] Inlet concentration
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Projection Coupling Variables
To enable a comparison between the plug-flow and channel models, it is of interest to 
calculate the NO concentration averaged over the channel cross section as a function 
of the axial coordinate along the reactor channel. This quantity is given by the integral

To make it available for postprocessing, define a projection coupling variable, 
co_NO_mean, according to the following instructions (for a description of projection 
coupling variables, see the section “Projection Coupling Variables” on page 270 of the 
COMSOL Multiphysics User’s Guide).

1 From the Options menu, select Projection Coupling Variables>Subdomain Variables.

2 On the Source page, select Subdomain 1, then enter the following data on the first 
row of the table:

3 Click the General transformation option button. In the Source transformation area, 
set x to z and y to r.

4 Click the Destination tab. From the Level list, select Boundary.

5 Select Boundary 5, then select the Use selected boundaries as destination check box.

6 In the Destination transformation area, set x to z, then click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings—Navier-Stokes Application Mode
1 From the Multiphysics menu, select Incompressible Navier-Stokes (chns).

2 From the Physics menu, select Properties. From the Analysis type list, select 
Stationary. Click OK.

3 From the Physics menu, select Subdomain Settings.

4 Select Subdomains 1 and 2 from the Subdomain selection list by pressing Ctrl+A and 
and clicking in the list.

5 From the Group list, select momentum.

Note how the Density and Dynamic viscosity edit fields are automatically filled in as 
a result of exporting the group momentum from the Reaction Engineering Lab.

NAME EXPRESSION INTEGRATION ORDER

c_NO_mean 2/(0.002^2)*r*c_NO 4

cNO,mean z( ) 1
A
---- c x( ) Ad

Ω
∫ 2

R2
------- cNO r z,( )r rd

0

R

∫= =
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6 Click the Init tab.

7 Type p_ref in the Pressure edit field.

8 Go back to the Physics tab.

9 Select Subdomain 2 (the porous-medium subdomain) from the Subdomain selection 
list.

10 Select the Flow in porous media check box.

11 Type eps_p in the Porosity edit field and k in the Permeability edit field.

12 Click OK.

Boundary Conditions—Navier-Stokes Application Mode
1 From the Physics menu, select Boundary Settings.

2 Enter the boundary conditions according to the following table:

Here you set up a parabolic inlet-velocity profile at the channel inlet. The velocity 
expression uses the built-in parameterization variable s that is available on 
boundaries in 2D. The value of s runs from 0 to 1 along any given boundary.

3 Click OK.

Subdomain Settings—Convection and Diffusion
1 From the Multiphysics menu, select Convection and Diffusion (chcd).

2 From the Physics menu, select Properties. From the Analysis type list, select 
Stationary. Click OK.

3 From the Physics menu, select Subdomain Settings.

4 Select Subdomains 1 and 2 from the Subdomain selection list by pressing Ctrl+A and 
and clicking in the list.

5 Select mass from the Group list.

Note how the Diffusion coefficient and Reaction rate edit fields are automatically filled 
in as a result of exporting the group mass from the Reaction Engineering Lab.

SETTINGS BOUNDARY 1 BOUNDARY 2 BOUNDARY 3 ALL OTHERS

Boundary 
type

Symmetry 
boundary

Inlet Outlet Wall

Boundary 
condition

Axial symmetry Velocity Pressure, no 
viscous stress

No slip

u0 0

v0 v_av*2*(1-s^2)

p0 p_ref
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6 Click the c_NO tab.

7 Type u in the r-velocity edit field and v in the z-velocity edit field.

8 Repeat Steps 6 and 7 for the remaining species (c_NH3, c_O2, and c_H2O) by clicking 
their respective tabs.

9 Select Subdomain 1 from the Subdomain selection list.

10 Click the c_NO tab.

11 As no reaction takes place in the gas phase, type 0 in the Reaction rate edit field.

12 Repeat Step 11 for the remaining species (c_NH3, c_O2, and c_H2O) by clicking their 
respective tabs.

13 Select Subdomain 2 from the Subdomain selection list.

You must somewhat modify the gas-phase diffusivities exported from the Reaction 
Engineering Lab to represent the corresponding diffusivities in the porous domain. 
The effective diffusivity (Di,eff) in a porous material is related to the gas-phase 
diffusivity (Di) by

where,  is the porosity, σ gives the constriction factor, and τ equals the tortuosity. 
Here, the material properties are grouped into the factor 

14 Click the c_NO tab.

15 In the Diffusion coefficient edit field, modify the existing expression by typing k_eff* 
at the beginning of the expression, then click Apply.

16 Repeat Step 15 for the remaining species (c_NH3, c_O2, and c_H2O) by clicking their 
respective tabs.

17 Click OK.

Boundary Conditions—Convection and Diffusion
1 From the Physics menu, select Boundary Settings.

2 Enter the boundary conditions for each of the species c_NO, c_NH3, c_O2, and c_H2O 

according to the following table:

SETTINGS BOUNDARY 1 BOUNDARY 2 BOUNDARY 3 ALL OTHERS

Type Axial 
symmetry

Concentration Convective 
flux

Insulation/
Symmetry

c_NO0 c_NO_in

c_NH30 c_NH3_in

Di eff,
φσDi

τ
-------------=

φ
keff φσ τ⁄ .=
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3 Click OK.

M E S H  G E N E R A T I O N

Because projection coupling variables require simplex mesh elements, you must use a 
triangular mesh.

1 From the Mesh menu, choose Free Mesh Parameters.

2 On the Global page, select Extremely fine from the Predefined mesh sizes list.

To fully resolve this model requires a very dense mesh; the above setting results in 
a model size of roughly 386,000 degrees of freedom. If you want to reduce memory 
consumption and solution time at the cost of obtaining a solution which is 
numerically slightly inaccurate, you can select the mesh size Extra fine instead.

3 Click the Advanced tab. Set the r-direction scale factor to 100. This setting is 
necessary to obtain a sufficient mesh resolution in the radial direction.

4 Click the Remesh button, then click OK.

C O M P U T I N G  T H E  S O L U T I O N

It is not necessary to solve both the momentum and mass balances simultaneously 
because the fluid flow is independent of the concentration. Therefore, to save time and 
computer memory, first solve the momentum balances and then solve the mass 
balances on the existing flow profile.

1 From the Solve menu, select Solver Parameters.

2 From the Solver list, select Stationary.

3 Go to the Advanced page.

4 In the Type of scaling list, select None.

5 Click OK.

6 From the Solve menu, select Solver Manager.

7 On the Solve For page, select Incompressible Navier-Stokes in the Solve for variables 
tree.

8 Click the Solve button. The solution time is around 2 minutes.

9 On the Initial Value page click the Store Solution button.

10 Click the Stored solution option button in the Initial value area.

c_O20 c_O2_in

c_H2O0 c_H2O_in

SETTINGS BOUNDARY 1 BOUNDARY 2 BOUNDARY 3 ALL OTHERS
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11 Return to the Solve For page and select Convection and Diffusion.

12 Click OK.

13 Click the Solve button on the Main toolbar. The solution time is roughly 4 minutes.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows the concentration of NO across the modeling domain, as seen 
in Figure 4-30 on page 242.

The following steps reproduce Figure 4-29 on page 241:

1 From the Postprocessing menu, open the Cross-Section Plot Parameters dialog box.

2 On the General page, clear the Display cross-section in main axes check box.

3 On the Line/Extrusion page, select Incompressible Navier-Stokes (chns)>z-velocity 
from the Predefined quantities list.

4 In the x-axis data area, click first the lower option button and then the Expression 
button to open the X-Axis Data dialog box. Type r in the Expression edit field, then 
select mm from the Unit list. Click OK to close the dialog box.

5 In the Cross-Section Plot Parameters dialog box, go to the Cross-section line data area.

6 Type 0 in the r0 edit field and 0.003 in the r1 edit field.

7 Type 0.2 in both the z0 and z1 edit fields.

8 Click OK to close the dialog box and generate the plot.

To finish the plot in Figure 4-31 on page 243, follow these instructions.

1 From the Postprocessing menu, open the Domain Plot Parameters dialog box.

2 On the General page, select the Keep current plot check box. From the Plot in list, 
select the figure window in which you plotted the first graph (Figure 1, unless you 
had any open figure windows from previous modeling sessions).

3 Go to the Line/Extrusion page and select Boundary 5. In the y-axis data area, type 
c_NO_mean in the Expression edit field.

4 Click the Line Settings button. From the Line color list, select Color, then click the 
Color button. In the Line Color dialog box, select a green color, then click OK. From 
the Line style list, select Dashed line, then click OK to close the Line Settings dialog 
box.

5 Click OK to close the Domain Plot Parameters dialog box and generate the plot.

6 Click the Edit Plot toolbar button in the figure window, then use the Edit Plot dialog 
box to edit plot title, axis labels, and legends.
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To calculate the conversion of NO to N2, perform an integration of the mass flux over 
the inlet and outlet:

1 From the Postprocessing menu, select Boundary Integration.

2 Select Boundary 2 (the inlet), and then in the Predefined quantities list select 
Convection and Diffusion>Normal total flux, c_NO.

3 Select the check box beside Compute surface integral (for axisymmetric modes).

4 Click Apply.

5 Select Boundary 3 (the outlet).

6 Click OK.

The values from the flux integrations appear in the message log at the bottom of the 
user interface. The inlet integration yields −3.08·10−8 mol/s, while outlet 
integration yields 3.5·10−9 mol/s. The flux is defined as leaving the geometry 
domain, hence the minus sign at the inlet. The conversion of NO becomes

3.08 0.35–
3.08

----------------------------- 0.89=
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Homogen eou s  Cha r g e  Comp r e s s i o n  
I g n i t i o n  o f  Me t h an e

Introduction

Homogeneous Charge Compression Ignition (HCCI) engines are being considered as 
an alternative to traditional spark- and compression-ignition engines. As the name 
implies, a homogeneous fuel/oxidant mixture is autoignited by compression with 
simultaneous combustion occurring throughout the cylinder volume. Combustion 
temperatures under lean burn operation are relatively low, resulting in low levels of 
NOx emission. Furthermore, the fuel’s homogeneous nature as well as the combustion 
process itself lead to low levels of particulate matter being produced. 

Although HCCI combustion shows much promise, the method also suffers from a 
number of recurring problems, one of the more important being ignition timing. The 
following model examines the HCCI of methane, investigating ignition trends as a 
function of initial temperature, initial pressure, and fuel additives.

This model solves the mass and energy balances describing the detailed combustion of 
methane in a variable-volume system. The large amount of kinetic and thermodynamic 
data required to set up the problem is readily made available by importing relevant files 
into the Reaction Engineering Lab.

Model Definition

It is difficult to form the uniform mixtures required for HCCI with conventional diesel 
fuel. Natural-gas fuels, on the other hand, readily produce homogeneous mixtures and 
have the potential to serve as HCCI fuels. This example considers the combustion of 
methane, as described by the GRI-3.0 mechanism, incorporating a detailed reaction 
mechanism of 53 species taking part in 325 reactions. The files describing the reaction 
kinetics and thermodynamics of the GRI-3.0 mechanism are available on the Internet 
(Ref. 1), and you can import these files directly into the Reaction Engineering Lab.

V A R I A B L E  VO L U M E  R E A C T O R

This model represents the combustion cylinder with a perfectly mixed batch system of 
variable volume, a reactor type that is predefined in the Reaction Engineering Lab. 
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Figure 4-32 shows a drawing of an engine cylinder, and it points out parameters 
relevant for calculating the instantaneous cylinder volume.

Figure 4-32: The volume of a combustion cylinder can be expressed as a function of time 
with the slider-crank relationship. This diagram shows the key geometric parameters. La is 
the length of the crank arm, Lc gives the length of the connecting rod, D equals the cylinder 
diameter, and α is the crank angle.

The volume change as a function of time is described by the slider-crank equation:

 (4-75)

where, V is the cylinder volume (m3), Vc gives the clearance volume (m3), CR equals 
the compression ratio, and R denotes the ratio of the connecting rod to the crank arm 
(Lc/La). Further, α is the crank angle (rad), which is also a function of time

 (4-76)

where N is the engine speed in rpm, and t is the time (s).

The engine specifications used in the model are:

ENGINE SPECIFICATION VARIABLE NAME VALUE

Bore D 13 cm

Stroke S 16 cm

Connecting rod Lc 26.93 cm

Crank arm La 8 cm

Engine speed N 1500 rpm

Compression ratio CR 15

α

La

Lc

D

V
Vc
------ 1 CR 1–( )

2
----------------------- R 1 α R2 αsin( )2

––cos–+[ ]+=

α 2πN
60

------------t=
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Equation 4-77 includes the clearance volume, Vc, which is calculated from

 (4-77)

Vs is the volume swept by the piston during a cycle from the equation

 (4-78)

Figure 4-33 shows the calculated cylinder volume as a function of the crank angle. The 
piston is initially at bottom dead center (BDC), corresponding to a crank angle of -180 
degrees.

Figure 4-33: Cylinder volume as function of crank angle. The crank angle is defined as 
being zero at top dead center (TDC).

M A S S  A N D  E N E R G Y  B A L A N C E S

The mass balances describing a perfectly mixed reactor with variable volume are 
summarized by

 (4-79)

where ci represents the species concentration (mol/m3), and Ri denotes the species 
rate expression (mol/(m3·s)).

For an ideal gas mixture, the reactor energy balance is

Vc
Vs

CR 1–( )
-----------------------=

Vs
πD2

4
-----------S=

d Vci( )
dt

----------------- VRi=
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 (4-80)

where Cp,i is the species molar heat capacity (J/(mol·K)), T is the temperature (K), 
and p gives the pressure (Pa). In this equation, Q is the heat due to chemical reaction 
(J/s)

 (4-81)

where Hj is the enthalpy of reaction (J/(mol·K)), and rj equals the reaction rate (mol/
(m3·s)). Qext denotes heat added to the system (J/s). The model being described 
assumes adiabatic conditions, that is, Qext = 0.

The kinetic and thermodynamic data for methane combustion is available in the form 
of data input files. Once you have imported them into the Reaction Engineering Lab, 
the software automatically sets up the mass and energy balances detailed in 
Equation 4-79 and Equation 4-80.

To complete the model setup, all that remains is to define the initial conditions. In this 
model, methane is combusted under lean conditions, that is, supplying more than the 
stoichiometric amount of oxidizer. The stoichiometric requirement of the oxidizer 
(air) to combust methane is found from the overall reaction:

 (4-82)

Assuming that the composition of air is 21% oxygen and 79% nitrogen, the 
stoichiometric air-fuel ratio is

 (4-83)

The equivalence ratio relates the actual air-fuel ratio to the stoichiometric requirements

 (4-84)

This model sets the equivalence ratio to Φ = 0.5.

FromEquation 4-83 and Equation 4-84 you can calculate the molar fraction of fuel in 
the reacting mixture as

Vr ciCp i,
dT
dt
--------

i
∑ Q Q+ ext Vr

dp
dt
-------+=

Q Vr Hjrj

j
∑–=

CH4 + O2 N2 CO2 H2O N2+( )2 2 7.523.76 + +

A F⁄( )stoic
mair
mfuel
--------------⎝ ⎠
⎛ ⎞

stoic

4.76 2 Mair⋅⋅
1 Mfuel⋅

------------------------------------= =

Φ
A F⁄( )stoic

A F⁄( )
----------------------------=
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 (4-85)

and subsequently the initial concentration is

 (4-86)

The initial pressure and the initial temperature are variable model parameters.

Results 

Figure 4-34 shows the cylinder pressure as a function of time when a methane-air 
mixture is compressed and ignites. The piston starts at bottom dead center (BDC) and 
reaches top dead center (TDC) after 0.02 s. At BDC the pressure is set to 1.5·105 Pa, 
Φ is 0.5, and the compression ration is CR = 15. The initial temperature is varied from 
400 K to 800 K.

Figure 4-34: Pressure traces illustrating the compression and ignition of fuel in an engine 
cylinder. The initial temperature varies between 400 K and 800 K.

Consistent with literature results, methane does not ignite at an initial temperature of 
400K (Ref. 2). Furthermore, the induction delay decreases with increasing initial 
temperature. The induction delay time can be evaluated from the pressure gradient. 
For instance, the induction delay is 0.0193 s when Tinit = 500 K.

Figure 4-35 illustrates the pressure traces as the initial pressure varies from 1·105 Pa to 
3·105 Pa. The initial temperature is 500 K. An increase in pressure means an increase 

xfuel
1

4.76 2⋅ Φ 1+⁄
-------------------------------------=

cfuel
xfuelpinit
RgTinit

-------------------------=
R  4 :  M O D E L  L I B R A R Y



in the species concentrations in the fuel-air mixture, resulting in the expected advance 
in ignition times.

Figure 4-35: Increased initial gas pressure advances ignition times.

As mentioned previously, a significant challenge to the realization of HCCI engines is 
ignition control. In this regard, combustion at TDC has been suggested as the 
optimum timing (Ref. 3). The results just discussed show that the inlet temperature of 
the fuel-air mixture is a potential tuning parameter for ignition. However, relatively 
high inlet temperatures are often required for proper timing. This adversely affects 
engine performance because the trapped mass as well as the volumetric efficiency 
decreases. An alternative that facilitates ignition is to mix small amounts of additives 
into the fuel-air mixture (Ref. 4). These additives chemically activate the reaction 
mixture even at relatively low temperatures. This approach alleviates the requirements 
of high intake temperatures. Figure 4-36 shows how small amounts of formaldehyde 
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(CH2O) cause ignition at an initial temperature of 400 K, a temperature insufficient 
to induce combustion with a pure methane fuel.

Figure 4-36: Small amounts of formaldehyde stimulate ignition of the fuel-air mixture.

The increased reactivity observed in the presence of CH2O is explained by the opening 
of a new chemical pathway leading to the formation of hydroxyl radicals. Specifically, 

CH2O reacts with O2 to produce H2O2:

H2O2, in turn, decomposes to reactive OH radicals, which subsequently react violently 
with the fuel molecules to cause ignition:

The results in the following graphs show the species molar fractions of CH2O, HO2, 
H2O2, and OH during the combustion of methane. Figure 4-37 shows molar fraction 
plots for the case when 0.13% CH2O is added to the fuel; Figure 4-38 is the equivalent 
species plots for the case when pure methane is combusted. In each case conditions 

O2+CH2O HO2 CHO+

+ CH2O H2O2 CHO+HO2

+ M OH M+H2O2 2
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have been tuned to produce ignition near TDC so as to provide a reference point for 
comparing the species concentrations.

Figure 4-37: Selected species molar fractions as a function of crank angle. 0.26 molar 
percent CH2O is added to the reacting mixture, which is initially at 400 K and 1.5 bar.

Figure 4-38: Selected species molar fraction as a function of crank angle. Only methane is 
combusted. The initial temperature is 469 K and the initial pressure 1.5 bar.

The implications of the CH2O reaction path just outlined are directly visible by 
comparing Figure 4-37 and Figure 4-38; CH2O stimulates the production of HO2 
and H2O2 that in turn produce OH radicals in amounts critical to fuel ignition.
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Model Library path: Combustion/compression_ignition

Modeling Using the COMSOL Reaction Engineering Lab

The kinetic and thermodynamic data required for this model are available on the 
Internet. Find the GRI-Mech 3.0 input files at (Ref. 1):

http://www.me.berkeley.edu/gri_mech/version30/text30.html.

Download the reaction mechanism and rate coefficient file (grimech30.dat), as well 
as thermodynamic data file (thermo30.dat) and store them on your computer.

M O D E L  N A V I G A T O R

1 Start the COMSOL Reaction Engineering Lab.

2 In the Model Navigator click the New button.

Proceed to import the chemical kinetics and thermodynamics data files.

1 Select File>Import>CHEMKIN Kinetics Input File.

Importing a kinetics file is equivalent to setting up a new reaction model. The 
software therefore asks you to save any current model you are working with.

2 Browse to the folder containing the appropriate file (grimech30.dat) and click the 
Import button.

3 Select File>Import>CHEMKIN Thermo Input File.

4 Browse to the folder containing the appropriate file (thermo30.dat) and click the 
Import button.
R  4 :  M O D E L  L I B R A R Y



O P T I O N S  A N D  S E T T I N G S

Start by setting up constants and expressions used in the model.

1 Select the menu item Model>Constants.

2 Type in the entries in the table below.

Alternatively, click the Import Variables From File button in the Constants dialog box, 
browse to the file compression_ignition_const.txt on your computer and click 
Open.

3 Click OK.

4 Select Model>Expressions.

5 Type in the entries in the table below.

Alternatively, click the Import Variables From File button in the Expressions dialog 
box, browse to the file compression_ignition_expr.txt on your computer and 
click Open.

NAME EXPRESSION DESCRIPTION

T_init 400 Initial temperature at BDC

p_init 1.5e5 Initial pressure at BDC

La 0.08 Crank arm length

Lc 0.2693 Connecting rod length

S 0.16 Stroke

D 0.13 Bore diameter

CR 15 Compression ratio

N 1500 Engine rpm

ER 0.5 Equivalence ratio

NAME EXPRESSION DESCRIPTION

Vol V_c*(1+(CR-1)/
2*(R+1-cos(alpha)-sqrt(R^2-
sin(alpha)^2)))

Cylinder volume

V_s pi*D^2/4*S Swept volume

V_c V_s/(CR-1) Clearance volume

alpha t*2*pi*N/60-pi Crank angle (rad)

crank_angle alpha*180/pi Crank angle (deg)

R Lc/La Length ratio

x_CH4 1/(4.76*2/ER+1) Initial CH4 mole fraction

x_O2 0.21*(1-x_CH4) Initial O2 mole fraction
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6 Click OK.

Continue with global model settings.

7 Click the Model Settings button on the Main toolbar.

8 Select Batch from the Reactor type list.

9 Select the Include energy balance check box.

10 Go to the Mass Balance page and type Vol in the Reactor volume edit field.

11 Go to the Init page and type T_init in the Initial temperature edit field.

12 Click Close.

S P E C I E S  I N T E R F A C E

1 Click the Reaction Settings button on the Main toolbar.

2 Click the Species tab.

3 On the General page select the appropriate entry in the Species selection list, then 
enter the corresponding value for the Initial concentration in the c0 edit field:

4 Click Close.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 Go to the Times edit field and enter 0.04. This is the time required for one piston 
cycle.

3 Type 1e-8 in the Relative tolerance edit field.

x_N2 1-x_CH4-x_O2-x_CH2O Initial N2 mole fraction

x_CH2O 0 Initial CH2O mole fraction

c_CH4_0 x_CH4*p_init/(Rg*T_init) Initial CH4 concentration

c_O2_0 x_O2*p_init/(Rg*T_init) Initial O2 concentration

c_N2_0 x_N2*p_init/(Rg*T_init) Initial N2 concentration

c_CH2O_0 x_CH2O*p_init/(Rg*T_init) Initial CH2O concentration

SPECIES NAME  c0 

O2 c_O2_0

CH2O c_CH2O_0

CH4 c_CH4_0

N2 c_N2_0

NAME EXPRESSION DESCRIPTION
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4 Type 1e-9 in the Absolute tolerance edit field.

5 Click OK.

6 Solve the problem by clicking the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

By default, the model plots the concentration transients of species with a nonzero 
initial concentration. Reproduce Figure 4-34 with the following steps:

1 Click the Plot Parameters button on the Main toolbar.

2 Remove all entries from the Quantities to plot list by clicking the << button.

3 In the Expression edit field type p, then click the Add Entered Expression (>) button.

4 Click Apply.

5 Select the Keep current plot check box.

6 Click OK.

7 Select the menu item Model>Constants.

8 Set the initial temperature T_init to 450 and click OK.

9 Solve the problem again with the new initial temperature by pressing the = button. 

10 Continue in the same manner to produce results for the initial temperatures 500 K, 
600 K, and 800 K.

11 Click the Edit Plot button.

12 On the Axis page, clear the x limits Auto check box and type 0.012 and 0.026 in the 
left and right edit fields, respectively.

13 Type Pressure in the y label edit field.

14 Select the first Line (p) entry, type p (400K) in the Legends edit field, and select the 
Show legend check box.

15 Select the second Line (p) entry, type p (450K) in the Legends edit field, select the 
Show legend check box, and select Point from the Line marker list.

16 Repeat the above steps for the pressure plots corresponding to the initial 
temperatures 500 K, 600 K, and 800 K, using a different line marker for each line.

17 Click OK to close the Edit Plot window.

Reproduce Figure 4-36 with the following steps:
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1 Select Model>Constants and type in the following; when done, click OK.

2 Select Model>Expressions and type in the following; when done, click OK.

3 Click the Plot Parameters button on the Main toolbar.

4 Clear the Keep current plot check box.

5 Select the Expression option button in the x-axis data area.

6 Click the Expression button. 

7 Type crank_angle in the Expression edit field, then click OK.

8 Click Apply in the Plot Parameters window.

9 Click the Solve button on the Main toolbar.

10 Go to the Plot Parameters window.

11 Select the Keep current plot check box.

12 Click OK to close the Plot Parameters window.

13 Select the menu item Model>Expressions and set the initial mole fraction of 
formaldehyde by setting x_CH2O to 0.01.

14 Once again solve the problem with the new initial mole fraction by pressing the = 
button.

15 Continue in the same manner to produce results for the initial mole fraction 0.001 
and 0.

16 Click the Edit Plot button.

17 On the Axis page, clear the x limits check box and type -50 and 50 in the left and 
right edit fields, respectively.

18 Type Pressure in the y label edit field.

19 Select the first Line (p) entry, type p (5% CH2O) in the Legends edit field, and select 
Point from the Line marker list.

20 Repeat steps the above steps for the pressure plots corresponding to the initial 
formaldehyde mole fractions of 0.01, 0.001, and 0.

NAME EXPRESSION DESCRIPTION

T_init 400 Initial temperature

NAME EXPRESSION DESCRIPTION

x_CH2O 0.05 Initial CH2O mole fraction
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Pe s t i c i d e  T r a n s po r t  and Rea c t i o n  i n  
S o i l

Introduction

Aldicarb is a commercial pesticide, used on a variety of crops, including cotton, sugar 
beet, citrus fruits, potatoes, and beans. The general population may be exposed to 
aldicarb primarily through the ingestion of contaminated water and foods.

This example looks at the degradation kinetics of aldicarb and its toxic by-products, 
investigating both the degradation time-scale as well as the spatial concentration 
distribution of toxic components. In the first model the chemicals are contained in a 
water pond, treated as a perfectly mixed system. The second model tracks the detailed 
distribution of chemicals in soil as the pesticide leaches out of the pond and is 
transported in water through the ground.

The reaction kinetics describing the degradation pathways of aldicarb is exported to 
the Solute Transport application mode of the Earth Science Module. In COMSOL 
Multiphysics the solute transport is coupled to fluid flow as described by Richards’ 
equation.

Note: This model requires the COMSOL Reaction Engineering Lab and the Earth 
Science Module.

Model Definition

Aldicarb degrades by transformation to the corresponding sulfoxide and the sulfone 
(both of which are toxic), and is detoxified by hydrolysis to oximes and nitriles. The 
chain of reactions is illustrated in Figure 4-39. The toxicity of a chemical species is 
indicated by its LD50 value, signifying the dose (mg/kg) lethal to half of a test 
population of rats. As indicated, both the sulfoxide and solfone analogues of aldicarb 
are also relatively toxic.
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Figure 4-39: Reaction pathways of aldicarb degradation.

Each of the j unimolecular reactions outlined above have rate expressions of the form:

Note that in this example the concentration unit is kg/m3 and the rate constants are 
expressed in 1/day.

P E R F E C T L Y  M I X E D  S Y S T E M

The first model solves for the decomposition kinetics of aldicarb occurring in a water 
pond. The pond is treated as a closed and perfectly mixed system. The reaction 
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mechanism illustrated in Figure 4-39 translates into the following mass balance 
equations:

• For aldicarb (a)

• For aldicarb sulfoxide (asx)

• For aldicarb sulfone (asn)

• For aldicarb oxime (ao)

• For aldicarb sulfoxide oxime (asxo)

• For aldicarb sulfone oxime (asno)

Solving this set of coupled ODEs outlined above provides information on the time 
scale of the degradation processes.

S P A C E -  A N D  T I M E - D E P E N D E N T  S Y S T E M

In a more detailed model, you assume that aldicarb moves from the pond into 
relatively dry soil. In the soil, the aldicarb decomposes according to the mechanism 
illustrated in Figure 4-39. In addition, the pesticide and its decay products are 
transported by advection, dispersion, sorption, and volatilization.

td

dca r1– r3–=

td

dcasx r1 r2– r4–=

td

dcasn r2 r5–=

td

dcao r3=

td

dcasxo r4=

td

dcasno r5=
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Geometry
Water is ponded by a ring sitting on the ground. The soil is layered and rests on rocks. 
Water moves through the bottom of the ring into the soil. The water level in the ring 
is known. There is no flow through the vertical walls or the surface outside of the ring.

Figure 4-40: Geometry of the infiltration ring and soil column.

Aldicarb moves with water from the pond into the soil at a constant concentration. In 
the soil, the chemicals react and also sorb onto soil particles. Aldicarb and the aldicarb 
sulfone volatilize to the atmosphere. The sorption, biodegradation, and volatilization 
proceed in linear proportion to the aqueous concentrations. The soil is initially pristine 
with zero concentration of the involved chemicals. At the ground surface outside the 
ring, there is volatilization to the atmosphere for ca and casn. The vertical axis is a line 
of symmetry. The other boundaries are posed such that the solutes can freely leave the 
soil column with the fluid flow. You can model the problem with 2D axisymmetry and 
track the solute transport for 10 days.

Fluid Flow
Richards’ equation governs the saturated-unsaturated flow of water in soil (Ref. 1) and 
is implemented in the Richards’ equation application mode:
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Here, C denotes specific moisture capacity (m−1), Se is the effective saturation of the 
soil, S is a storage coefficient (m−1), Hp represents the dependent variable pressure 
head (m), t is time (d), K equals the hydraulic conductivity function (m/d), D is the 
coordinate representing vertical elevation (for example, x, y, or z), and Qs is a fluid 
source defined by volumetric flow rate per unit volume of soil (d−1). In this problem, 
S = θs − θr, where θs and θr denote the volume fraction of fluid at saturation and after 
drainage, respectively. 

You can find more detail on the Richards’ Equation application mode in the Earth 
Science Module User’s Guide.

Mass Transport
The governing equation for solute transport describes advection and dispersion of a 
sorbing, volatilizing, and decaying solute in variably saturated soil.

 (4-87)

Equation 4-87 is implemented in the Solute Transport application mode. The first 
bracketed term explains the change in solute mass per volume per time for the liquid-, 
solid-, and air-phase concentrations. The second term explains the changes in storage 
because the water content in the soil varies in time. The third bracketed expression 
represents the overall solute flux due to liquid dispersion, diffusion (liquid and air), and 
advection with moving water. The right side explains reactions and generalized 
sources.

Solute spreading now includes mechanical dispersion in water plus molecular diffusion 
for water and air. These three processes appear in the liquid-gas dispersion tensor, 
whose entries are

 (4-88)

 (4-89)
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In this equation, DLGii are the principal components of the liquid-gas dispersion 
tensor; DLGij and DLGji are the cross terms; α is the dispersivity (m) where the 
subscripts 1 and 2 denote longitudinal and transverse flow, respectively. Dm and DG 
(m2/d) are molecular diffusion, while τL and τG give the tortuosity factors for liquid 
(water) and gas (air), respectively. 

The three solutes—aldicarb, aldicarb sulfoxide, and aldicarb sulfone—have different 
decay terms, RLi, partition coefficients, kPi, and volatilization constants, kGi. All of the 
solutes attach to soil particles. Two of the solutes volatilize; sulfoxide does not.

Results

First, review the results of the perfectly mixed reactor model, solved in the Reaction 
Engineering Lab.

Figure 4-41 shows the concentration profile of aldicarb and all of its decay products. 
Only small amounts of aldicarb remain after 10 days. Figure 4-42 shows concentration 
transients of the most toxic species aldicarb, aldicarb sulfoxide, and aldicarb sulfone, as 
well as the sum of these three components (see Figure 4-39 for LD50 values). 
Considering the summed contributions, contamination levels clearly remain high even 
after several months.

Figure 4-41: Concentration profiles (kg/m3) as reactions occur during a 100 day time 
period.
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Figure 4-42: Concentration transients of the most toxic species, aldicarb (c_a), aldicarb 
sulfoxide (c_asx), and aldicarb sulfone (c_asn).

Results shown below come from the space and time-dependent model set up and 
solved in COMSOL Multiphysics.

Figure 4-43 shows the fluid flow in soil after 0.3 days (left) and 1.0 days (right). The 
plots illustrate the wetting of the soil with time. As indicated by the arrows, the fluid 
velocities are relatively high beneath the ponded water.

Figure 4-43: The effective saturation (surface plot), pressure head (contours), and flow 
velocity (arrows) in a variably saturated soil after 0.3 days (left) and 1 day (right).
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Figure 4-44 through Figure 4-46 show the concentration distribution of aldicarb and 
the equally toxic aldicarb sulfoxide, after 1, 5, and 10 days of infiltration. Consistent 
with the evolving flow field, the main direction of transport is in the vertical direction.

Figure 4-44: Concentration of aldicarb (left) and aldicarb sulfoxide (right) after 1 day.

Figure 4-45: Concentration of aldicarb (left) and aldicarb sulfoxide (right) after 5 days.

Figure 4-46: Concentration of aldicarb (left) and aldicarb sulfoxide (right) after 10 
days.
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The distribution of aldicarb has clearly reached steady-state conditions after 10 days. 
This time frame was also predicted by the ideal reactor model. Results also show that 
the soil contamination is rather local with respect to the aldicarb source. The aldicarb 
sulfoxide, on the other hand, can be expected to affect a considerably larger soil 
volume for a significantly longer time.
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Model Library path: Reaction_Engineering_Lab/Earth_Science/
pesticide_transport

Modeling Using the COMSOL Reaction Engineering Lab

M O D E L  N A V I G A T O R

1 Start COMSOL Reaction Engineering Lab.

2 Click New in the Model Navigator.

O P T I O N S  A N D  S E T T I N G S

1 Click the Model Settings button on the Main toolbar.

2 Select the Liquid from the Reacting fluid list.

3 Select the Calculate thermodynamic properties check box.

4 Select the Calculate species transport properties check box.

5 Click Close.

R E A C T I O N S  I N T E R F A C E

1 Click the Reaction Settings button on the Main toolbar.

2 Make sure the Reactions page is active. Create five entries in the Reaction selection 

list by clicking the New button
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3 Enter the following reaction formulas by first selecting the appropriate row in the 
Reaction selection list and then entering the corresponding text in the Formula edit 
field.

4 Type in the following rate constants by first selecting the appropriate row in the 
Reaction selection list and then entering the corresponding value in the kf edit field.

S P E C I E S  I N T E R F A C E

1 Click the Species tab.

2 Select the entry a from the Species selection list and type 1 in the c0 edit field.

3 Go to the Transport page.

4 Select all entries in the Species selection list by pressing Ctrl+A and clicking the list.

5 Click the Specify diffusivity check box and type 0.00374 in the Diffusivity edit field.

6 Click Close.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 Go to the Times edit field and enter 100. Note that the time unit in this example is 
days.

3 Click OK.

4 Compute the solution by clicking the Solve button on the Main toolbar.

REACTION ID # REACTION FORMULA

1 a=>asx

2 asx=>asn

3 a=>ao

4 asx=>asxo

5 asn=>asno

REACTION ID # FORWARD RATE CONSTANT

1 0.36

2 0.024

3 0.2

4 0.01

5 0.0524
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PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The concentration transients of all species are plotted by default as shown in 
Figure 4-41. Reproduce Figure 4-42 with the following steps:

1 Click the Plot Parameters button on the Main toolbar.

2 Remove the entries ao, asxo, asno from the Quantities to plot list by selecting them 
and clicking the < button.

3 Type c_a+c_asx+c_asn in the Expression edit field and click the associated > 
button.

4 Click OK.

Now, move on to export the reaction model to COMSOL Multiphysics and solve the 
time and space-dependent transport and reaction problem.

S P E C I E S  I N T E R F A C E

This model focuses on the concentration of the highly toxic species aldicarb (a), 
aldicarb sulfoxide (asx), and aldicarb sulfone (asn). Therefore, you can disregard the 
mass balances for the hydrogenolysis products (ao, asxo, and asno). Before exporting 
the reaction model you therefore deactivate these species.

1 Click the Reaction Settings button on the Main toolbar.

2 Click the Species page.

3 Select ao from the Species selection list and deactivate the species by clearing the 
check box immediately to the left of the species name.

4 In the same way, deactivate the species asxo and asno.

5 Click Close.

E X P O R T  S E T T I N G S

1 Click the Export to COMSOL Multiphysics button on the Main toolbar.

2 Select Axial symmetry (2D) from the Space dimension list, then click OK.

3 The Export to COMSOL Multiphysics dialog box appears.

4 Go to the Export mass balance area, and in the Application mode list select Solute 

Transport: New.

5 In the Group name edit field type reactions.

6 Move to the Export energy balance area and clear the check box in the upper left 
corner.
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7 Go to the Export momentum balance area and clear the check box in the upper left 
corner.

8 Click the Export button at the bottom of the dialog box.

Modeling Using COMSOL Multiphysics

Click the COMSOL Multiphysics window.

1 Select the menu item Multiphysics>Model Navigator.

Note how the model already contains the application mode Solute Transport, created 
by the export from Reaction Engineering Lab.

2 In the list of application modes select Earth Science Module>Fluid Flow>Richards’ 

Equation>Pressure head analysis>Transient analysis.

3 Click the Add button.

4 Click OK.

A P P L I C A T I O N  S C A L A R  V A R I A B L E S

To set the vertical direction and gravitational constant in the model, go to the Physics 
menu and choose Scalar Variables. Make the following modifications to the defaults. 
Here you convert from seconds to days and square the quantity because you are 
dealing with acceleration. When done, click OK.

G E O M E T R Y  M O D E L I N G

You create the geometry by drawing two rectangles and adding one line.

1 Select the menu item Draw>Specify Objects>Rectangle. Specify the following settings, 
then click OK.

2 Go to the Main toolbar and click the Zoom Extents button. 

NAME EXPRESSION

g_esvr 9.82*86400*86400

D_esvr z

PARAMETER EXPRESSION

Width 1.25

Height 1.3

r 0

z -1.3
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3 Again select Draw>Specify Objects>Rectangle. Specify the following settings, then 
click OK.

4 Select the menu item Draw>Specify Objects>Line. In the r edit field enter 0 0.25, 
and in the z edit field enter 0 0. Click OK.

P H Y S I C S — S O L U T E  TR A N S P O R T

1 Choose Multiphysics>Solute Transport (esst).

2 Select the menu item Physics>Properties.

3 Select Liquid/Solid/Gas from the Material drop down list, then click OK. You change 
the default settings as a three phase system is being modeled.

4 Select the menu item Physics>Subdomain Settings. In the Subdomain selection list 
simultaneously select Subdomains 1 and 2 by pressing the Ctrl key.

5 From the Group list, select reactions.

6 Go to the Flow and Media page, enter the following settings.

This couples the solute transport to the flow calculated by the Richards’ Equation 
(esvr) application mode.

7 Set the Time change in liquid volume fraction to Time change in pressure head and 
enter the following.

PARAMETER EXPRESSION

Width 1.25

Height 0.4

r 0

z -0.4

PROPERTY VALUE

 θ theta_esvr

 θs thetas_esvr

 u u_esvr

 v v_esvr

PROPERTY VALUE

 C C_esvr

 ∂Hp / ∂t pt
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8 Click the Liquid page. In the list of subdomains, simultaneously select 1 and 2 by 
pressing Ctrl. Make the changes in the following table, and note that you can copy 
and paste in the edit fields.

Note also that the DmL and RL edit fields have been filled out automatically as a result 
of the export from COMSOL Reaction Engineering Lab.

9 Click the Solid page. Select both Subdomain 1 and 2, then make the following 
changes:

10 Click the Gas page, select Subdomains 1 and 2, then make the following changes:

11 Go to the Init page and type 0 in the c_a(t0) edit field.

12 Click OK.

Boundary Conditions—Solute Transport
1 From the Physics menu choose Boundary Settings.

2 Verify that you are on the c_a page, then enter the following settings:

TERM C_A C_ASX C_ASN

α1 0.005 0.005 0.005

α2 0.0001 0.0001 0.0001

TERM C_A C_ASX C_ASN

 ρb 1300 1300 1300

 KP 0.0001 0.00005 0.0002

TERM C_A C_ASX C_ASN

kG 1.33e-7 0 1.33e-3

DmG 0.432 0.432 0.432

BOUNDARY CONDITION VARIABLE VALUE

1, 3 Axial symmetry

2, 7, 8 Advective flux

5 Flux N0 1e6*(1-c_a)*(t>=0)

6 No flow boundary volatilization d 0.005
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3 Click the c_asx page, then enter the following settings:

4 Click the c_asn page, then enter the following settings:

5 Click OK.

P H Y S I C S — R I C H A R D S ’  E Q U A T I O N

Subdomain Settings—Richards’ Equation
1 Go to the Multiphysics menu and choose Richards’ Equation (esvr).

2 Select the menu item Physics>Subdomain Settings and click the Coefficients page. 
Enter the following settings, then click Apply.

3 Click the van Genuchten page and make the following changes:

BOUNDARY CONDITION VARIABLE VALUE

1, 3, Axial symmetry

6 No flux/Symmetry

2, 7, 8 Advective flux

5 Concentration c_asx0 0

BOUNDARY CONDITION VARIABLE VALUE

1, 3 Axial symmetry

2, 7, 8 Advective flux

5 Concentration c_asn0 0

6 No flow boundary volatilization d 0.005

SETTINGS SUBDOMAIN 1 SUBDOMAIN 2

 Constitutive relation van Genuchten van Genuchten

 θs 0.339 0.399

 θr 0 0.0001

 Storage term User defined User defined

 S 0.339 0.399

 KS 0.454 0.298

 ρf 1000 1000

SETTINGS SUBDOMAIN 1 SUBDOMAIN 2

 α 1.39 1.74
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4 Click the Init page. Select both subdomains simultaneously using the Ctrl key, then 
in the edit field enter this expression:

5 Click OK.

Boundary Conditions—Richards’ Equation
1 From the Physics menu choose Boundary Settings and make these settings:

2 Click OK.

M E S H  G E N E R A T I O N

1 Go to the menu item Mesh>Free Mesh Parameters.

2 Click the Boundary page. Select the upper surface and the break between the two 
soil layers (Boundaries 4, 5, and 6). In the Maximum element size edit field enter 
0.02. 

3 Click OK.

4 Click the Initialize Mesh button on the Main toolbar. 

C O M P U T I N G  T H E  S O L U T I O N

This model has many degrees of freedom and is also nonlinear. It requires roughly an 
hour to solve on a fast computer.

1 Choose Solve>Solver Parameters.

2 In the Solver list choose Time dependent if it is not already selected.

 n 1.6 1.38

 l 0.5 0.5

SETTING SUBDOMAINS 1 AND 2

HP(t0) -(z+1.2)*(z<-0.4)+(-(z+1.2)-0.2*(z+0.4))*(-0.4<=z)

BOUNDARY BOUNDARY CONDITION VARIABLE EXPRESSION

1, 3 Axial symmetry

6–8 Zero flux/Symmetry

2 Inward flux N0 -0.454/100

5 Mixed Rb 1*(t>=0)

5 Hpb 0.01*(t>=0)

5 Db D_esvr*(t>=0)

SETTINGS SUBDOMAIN 1 SUBDOMAIN 2
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3 In the Times edit field enter -0.1,0,logspace(-3,-1,21),0.1:0.1:1,2:1:10. 
It gives you 31 logarithmically spaced inputs from 0.001 to 0.1 day; 0.1-day 
increments through Day 1; and 1-day increments until Day 10. 

4 Click the Advanced page.

5 Change the Type of scaling to Manual.

6 Type p 1e10 c_a 1 c_asx 1 c_asn 1 in the Manual scaling edit field.

7 Click OK.

8 Click the Solve button on the Main toolbar. 

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To plot the flow solution in Figure 4-43, follow these steps.

1 Select the menu item Postprocessing>Plot Parameters. 

2 On the General page go to the Plot type area and select the Surface, Contour, and 
Arrow check boxes.

3 From the Solution at time list choose 0.3.

4 Click the Surface page, and in the Expression edit field enter Se_esvr.

5 Click the Contour page, and in the Predefined quantities list choose 
Richards’ Equation (esvr)>Pressure head.

6 In the Contour color area, click the Uniform color option button. Click the Color 
button, change the color to white, and click OK.

7 Click Apply.

8 Click the Arrow page.

9 From the list of Predefined quantities select Richards’ Equation (esvr)>Velocity field.

10 Click the Color button, choose white as the desired color, then click OK.

11 Clear the Auto check box, and in the Scale factor edit field enter 0.5.

12 Click Apply.

13 To generate the solution after 1 day, go to the General page and select 1 from the 
Solution at time list, and then click OK.

To generate the plots in Figure 4-44 through Figure 4-46, continue with these steps:

1 Select the menu item Postprocessing>Plot Parameters. 

2 On the General page, clear the Arrow and Contour check boxes.

3 Click the Surface page, then type c_a in the Expression edit field.
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4 Click Apply.

5 To generate the solution after 5 days and 10 days, go to the General page and select 
the corresponding entries from the Solution at time list, and click Apply.

6 To generate plots for the aldicarb sulfoxide concentrations, click the Surface page, 
type c_asx in the Expression edit field, then click Apply.
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Os c i l l a t i n g  R e a c t i o n s

Most reactions proceed smoothly, at varying rates, to a final state of equilibrium. Some, 
however, do not. They oscillate with reactant, product, or intermediate species 
concentrations fluctuating wildly. Such instances of nonlinear chemical dynamics are 
commonplace in biochemical systems.

This example looks closely at three well-known examples of reaction systems with 
oscillating kinetics: the Lotka reaction, the Lotka-Volterra reaction, and a version of 
the Belousov-Zhabotinsky reaction. To model them, you first enter the chemical 
reaction formulas for the mechanisms into the Reaction Engineering Lab and have it 
set up and solve the corresponding material balances. Then you can easily modify the 
reaction conditions and focus on how these choices affect the results. After these initial 
studies, you export the reaction models to COMSOL Script to perform additional 
calculations and postprocessing.

Introduction

Autocatalysis is the acceleration of a reaction by the products. A consequence of 
autocatalysis is the possibility that the reacting species will vary periodically. Such 
reaction systems are of great interest, and many natural phenomena—from firefly 
flashes to the human heartbeat—are oscillatory chemical systems. Although the actual 
reaction mechanisms responsible for oscillations in biochemistry often are exceedingly 
complicated, surprisingly simple reaction models have successfully captured key 
features of these cyclic events.

The following discussion investigates three oscillating reaction models (Ref. 1 and Ref. 
2).

Model Descriptions

C A S E  1 — T H E  L O T K A  R E A C T I O N

Lotka originally created this simple example chemistry to illustrate a temporal behavior 
characterized by damped oscillations. Lotka’s mechanism is given by the following set 
of reaction steps:

k1
A X
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The second reaction is autocatalytic, that is, the first reaction produces X, which is 
consumed in the following step. In these reactions, the species P symbolizes reaction 
products that do not affect the oscillations.

The mass action law suggests the following reaction rates (mol/(m3· s)) for the 
previously described system:

Making use of the reaction rates and the stoichiometry of the reaction formulas, the 
material balances for the species become

The Reaction Engineering Lab automatically generates these reaction rate expressions 
and material balances. You simply enter the chemical reaction formulas into the user 
interface.

C A S E  2 — T H E  L O T K A - VO L T E R R A  R E A C T I O N

Volterra proposed a mechanism for interacting organisms related to the Lotka 
mechanism. The Lotka-Volterra kinetic scheme differs from the Lotka scheme only by 
the fact that the first reaction step is also autocatalytic: 

+ Y
k2

X 2Y

k3
Y P

r1 k1cA=

r2 k2cXcY=

r3 k3cY=

td

dcA r– 1=

td

dcX r1 r2–=

dcY

dt
--------- r2 r3–=

td

dcP r3=
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This mechanism is also known as the prey-predator scheme, displaying steady species 
that oscillate without damping.

The mass action law suggests the following reaction rates (mol/(m3· s)) for the system 
just described:

The material balance equations for a perfectly mixed isothermal system become

C A S E  3 — T H E  B E L O U S O V - Z H A B O T I N S K Y  R E A C T I O N

Originally, Belousov wanted to reproduce the chemistry of the citric acid cycle—work 
later carried on by Zhabotinsky. The full mechanism of the Belousov-Zhabotinsky 
reaction involves more than 40 reaction steps. However, a smaller mechanism 
consisting of four reactions captures the reaction’s oscillating behavior. Consider this 
example:

+ X
k1

A 2X

+ Y
k2

X 2Y

k3
Y P

r1 k1cAcX=

r2 k2cXcY=

r3 k3cY=

td

dcA r1–=

td

dcX r1 r2–=

td

dcY r2 r3–=

td

dcP r3=
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In these reactions, the species P1 and P2 symbolize reaction products that do not affect 
the oscillations. The reaction rates for the system become

Not considering the product species P1 and P2, the material balance equations 
become

k1
NaIO3

+ IO3Na
+ -

k2
IO3

-
I

- + P1

k3
IO3

-
2I

- + P2+ 3I
-

k4
I

-
0.5I2

r1 k1cNaIO3=

r2 k2cIO3=

r3 k3cIO3cI
2

=

r4 k4cI=

td

dcNaIO3 r– 1=

td

dcNa r1=

td

dcIO3 r1 r2– r3–=

td

dcI r2 r3 r4–+=

td

dcI2 0.5r4=
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Note again that all of these equations are automatically defined in the Reaction 
Engineering Lab.

Results

Compare the time evolution of the three reacting systems by solving the material 
balances and plotting the species concentrations as functions of time. To increase the 
understanding of the dynamic chemistries, also create plots for the trajectories of the 
oscillating species, (cX(t), cY(t)). 

C A S E 1 — T H E  L O T K A  R E A C T I O N

As shown in Figure 4-47, the Lotka scheme corresponds to damped oscillating 
reactions, in this case reaching equilibrium after approximately 4000 s.

Figure 4-47: Species concentrations (mol/m3) as functions of time (s). The system reaches 
equilibrium after approximately 4000 s.
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Figure 4-48 shows two phase plots—that is, trajectories in the (cX, cY) plane, here 
parameterized by the time, t. The two trajectories start at the initial points (cX, cY) = 
(0.2,0.1) and (cX, cY) = (0.5,0.8), respectively. 

Figure 4-48: Trajectories {(cX(t), cY(t))} given in molar concentrations (mol/m3). The 
system reaches the same stationary state irrespective of the starting conditions.

It is clear from the graphs that the same stationary state is reached irrespective of initial 
concentrations.

C A S E 2 — T H E  L O T K A - VO L T E R R A  R E A C T I O N

The Lotka-Volterra kinetics illustrates chemical oscillations without damping 
(Figure 4-49).

Figure 4-49: Species concentrations (mol/m3) of oscillating species as functions of time (s).
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Figure 4-50 provides phase plots, {(cX(t), cY(t))}, of the system. The two trajectories 
start at the points (cX, cY) = (2, 0.1) and (cX, cY) = (1.5, 1), respectively.

Figure 4-50: Trajectories {(cX(t), cY(t))} given in molar concentrations (mol/m3). The 
closed orbits illustrate the undamped nature of the system.

The plots indicate that every set of initial conditions produces a different orbit. In 
biological systems, however, it is common that a number of initial conditions lead to 
the same oscillatory pattern. These stable patterns are referred to as attractor orbits.

C A S E  3 — T H E  B E L O U S O V - Z H A B O T I N S K Y  R E A C T I O N

From Figure 4-51 it appears as if the Belousov-Zhabotinsky reaction has the same 
oscillatory behavior as the Lotka-Volterra reaction.

Figure 4-51: Species concentrations (mol/m3) as functions of time (s).
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However, the phase plots in Figure 4-52 illustrate a fundamental difference between 
the two situations. 

Figure 4-52: Trajectories {(cI(t), cIO3(t))} given in molar concentrations (mol/m3). 
Initial concentrations are (cI , cIO3) = (0.04, 0.04) and (cI , cIO3)= (0.01, 0.08) (mol/
m3). The system reaches the same limit cycle irrespective of the starting conditions.

Irrespective of the initial concentrations of the species I and IO3, the 
Belousov-Zhabotinsky mechanism settles into the same periodic variations of 
concentration. As mentioned previously, this is a common feature observed in 
oscillating biological systems, and indeed the Belousov-Zhabotinsky mechanism has 
been used extensively to model nonlinear dynamics in biology.

To conclude, the Reaction Engineering Lab here examines oscillating reactions. The 
software’s ease of use enables you to focus on modeling results rather than the model 
setup and methods of solution. This example studies three reaction mechanisms with 
different sets of initial conditions, and it provides several important insights into the 
field of nonlinear chemical dynamics.
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Model Library path: Education/oscillating_reactions_lotka
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Model Library path: Education/oscillating_reactions_lv

Model Library path: Education/oscillating_reactions_bz

Modeling Using COMSOL Reaction Engineering Lab

M O D E L  N A V I G A T O R

1 Start the Reaction Engineering Lab.

2 Click New in the Model Navigator.

R E A C T I O N S  I N T E R F A C E — C A S E  1

1 Choose Model>Reaction Settings.

2 Create three entries in the Reaction selection list by clicking the New button three 
times.

3 Enter the following reaction formulas by first selecting the appropriate row in the 
Reaction selection list and then typing the text in the Formula edit field. Note how 
the reaction rate expressions are automatically generated and presented in the r edit 
field.

4 Enter the following forward rate constants by first selecting the appropriate row in 
the Reaction selection list and then typing the numbers in the kf edit field:

REACTION ID # REACTION FORMULA

1 A=>X

2 X+Y=>2Y

3 Y=>P

REACTION ID # kf 

1 6e-3

2 1.2e-2

3 1.6e-2
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S P E C I E S  I N T E R F A C E — C A S E  1

1 Click the Species tab.

2 Verify that the Species selection list contains the four species A, X, Y, and P.

3 On the General page, enter the following initial concentrations, one by one, in the 
c0 edit field after first having selected the appropriate entry in the Species selection 

list:

4 Select the reactant species A in the Species selection list and select the Lock 

concentration/activity check box. This removes the material balance for species A. 
The concentration of this species is assumed to have the constant value entered in 
the c0 edit field.

5 Click Close.

C O M P U T I N G  T H E  S O L U T I O N — C A S E  1

1 Choose Simulation>Solver Parameters.

2 In the Times edit field, type 0 4000.

3 In the Relative tolerance edit field, type 1e-4.

4 In the Absolute tolerance edit field, type 1e-5.

5 Clear the Stop if steady state is reached first check box.

6 Click OK.

7 Click the Solve Problem button (=) on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N — C A S E  1

The default plot shows all concentrations versus time. To create Figure 4-47, proceed 
with the following steps:

1 Choose Postprocessing>Plot Parameters.

2 From the Quantities to plot list, select the entries A and P.

3 Remove the entries from the list by clicking the < button.

4 Click OK.

SPECIES NAME c0
A 1

X 0.2

Y 0.1

P 0
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5 Choose File>Save As and save the reaction model as 
oscillating_reactions_lotka.rxn.

Next, modify the first model.

R E A C T I O N S  I N T E R F A C E — C A S E  2

1 Choose Model>Reaction Settings.

2 Click the Reactions tab and select the first reaction.

3 Edit the reaction to read A+X=>2X by typing this expression in the Formula edit field.

4 Select the last reaction in the Reaction selection list and type 8e-3 in the kf edit field.

S P E C I E S  I N T E R F A C E — C A S E  2

1 Click the Species tab.

2 Select species X in the Species selection list and type 2 in the c0 edit field.

3 Click Close.

C O M P U T I N G  T H E  S O L U T I O N — C A S E  2

Click the Solve Problem button on the Main toolbar to solve the problem with the new 
settings.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N — C A S E  2

1 The initial plot will now resemble Figure 4-49.

2 Choose File>Save as and save the reaction model as 
oscillating_reactions_lv.rxn.

R E A C T I O N S  I N T E R F A C E — C A S E  3

1 Select File>New to create a new reaction model.

2 Choose Model>Reaction Settings.

3 Create four entries in the Reaction selection list by clicking the New button four 
times.

4 Enter the following reaction formulas by first selecting the appropriate row in the 
Reaction selection list and then typing the text in the Formula edit field:

REACTION ID # REACTION FORMULA

1 NaIO3=>Na+IO3

2 IO3=>I+P1
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5 Enter the following forward rate constants by first selecting the appropriate row in 
the Reaction selection list and then typing the numbers in the kf edit field:

S P E C I E S  I N T E R F A C E — C A S E  3

1 Click the Species tab.

2 Verify that the Species selection list contains the seven species expected from entering 
the reaction formulas above.

3 On the General page, enter the following initial concentrations, one by one, in the 
c0 edit field after first having selecting the appropriate entry in the Species selection 
list:

4 Click Close.

C O M P U T I N G  T H E  S O L U T I O N — C A S E  3

1 Choose Simulation>Solver Parameters.

2 In the Times edit field, type 0 4000.

3 In the Relative tolerance edit field, type 1e-7.

4 In the Absolute tolerance edit field, type 1e-8.

3 IO3+2I=>3I+P2

4 I=>0.5I2

REACTION ID # kf

1 1.67e-5

2 1.67e-4

3 41.7

4 1.67e-2

SPECIES NAME c0
NaIO3 10

Na 0

IO3 4e-2

I 4e-2

P1 0

P2 0

I2 0

REACTION ID # REACTION FORMULA
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5 Clear the Stop if steady state is reached first check box.

6 Click OK.

7 Click the Solve Problem button on the Main toolbar to solve the model.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N — C A S E  3

To create Figure 4-51, follow these steps:

1 Choose Postprocessing>Plot Parameters.

2 Click the << button to clear the default selection in the Quantities to plot list.

3 From the Predefined quantities list, select the entries I and IO3.

4 Click the > button to add the selection to the Quantities to plot list.

5 Click OK.

6 Choose File>Save As and save the reaction model as 
oscillating_reactions_bz.rxn.

Modeling Using COMSOL Script

Now solve the reaction models for different sets of initial concentrations and then plot 
the solutions obtained in the phase plane, (cX, cY). This is straightforward to 
implement in COMSOL Script.

E X P O R T — C A S E  1

1 In the Reaction Engineering Lab, load the Lotka reaction model by choosing 
File>Open and typing oscillating_reactions_lotka.rxn in the File name edit 
field.

2 Choose File>Export>REL Structure to Workspace as 'rel'. COMSOL Script will 
launch, if not already open.

S C R I P T I N G — C A S E  1

1 Click the COMSOL Script window.

You can choose between using the ready-made script that comes with the model or 
typing it in yourself. If you choose to run the ready-made script, you can skip the next 
step where the script is created and saved and continue with Step 7.

2 If you choose to type it in yourself, type edit at the prompt to bring up a 
COMSOL Script Editor window.

3 Type the following script into the COMSOL Script Editor:
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% Create vectors containing initial concentrations
cX = [0.2 0.5];
cY = [0.1 0.8];

%create a loop
for i = 1:2
% solve the reaction model
rel.sol=femtime(rel, ‘report’,’off’, ...
‘solcomp’,{‘c_X’,’c_Y’,’c_P’}, ...  
‘outcomp’,{‘c_X’,’c_Y’,’c_P’}, ...
‘const’,{‘c0_X’,cX(i),’c0_Y’,cY(i)}, ...
‘atol’,1e-4, ...
‘rtol’,1e-5, ...
‘tlist’,0:1:4000);

%Plot the results for each simulation
postglobalplot(rel,’c_Y’,’linxdata’,’c_X’, ...
‘axislabel’,{‘concentration c_X [mol m^-3]’,’concentration c_Y 
[mol m^-3]’});
hold on

%end loop
end

hold off

4 Choose File>Save to save the file and specify the name as 
oscillating_reactions_lotka.m.

5 Return to the COMSOL Script window.

6 Run the script by choosing File>Run M-file. Browse to where you saved the file, select 
it, and click Open to generate Figure 4-48.

7 To run the ready-made script, simply choose File>Run M-file and browse to models/
Reaction_Engineering_Lab/Education/ 

oscillating_reactions_lotka.m in the COMSOL installation directory.

8 Click OK to generate Figure 4-48.

E X P O R T — C A S E  2

1 In the Reaction Engineering Lab, load the Lotka-Volterra reaction model by 
selecting File>Open and browse to oscillating_reactions_lv.rxn.

2 Choose File>Export>REL Structure to Workspace as 'rel'.
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S C R I P T I N G — C A S E  2

1 Click the COMSOL Script window.

If, in Case 1 above, you chose to run the ready-made script, skip the first few steps 
below and start directly with Step 7; otherwise, follow Steps 2–6.

2 Type edit oscillating_reactions_lotka.m to open the text editor.

3 In the Script Editor, choose File>Save as and save the file as 
oscillating_reactions_lv.m.

4 Modify the initial concentration vectors as follows:

cX = [2 1.5];
cY = [0.1 1];

5 Choose File>Save.

6 Run the script by choosing File>Run M-file. Browse to where you saved the file, select 
it, and click Open to generate Figure 4-50.

7 To run the ready-made script, choose File>Run M-file and browse to models/
Reaction_Engineering_Lab/Education/oscillating_reactions_lv.m in 
the COMSOL installation directory.

8 Click OK to generate Figure 4-50.

E X P O R T — C A S E  3

1 In the Reaction Engineering Lab, load the Belousov-Zhabotinsky reaction model 
by choosing File>Open and specifying the file name 
oscillating_reactions_bz.rxn.

2 Choose File>Export>REL Structure to Workspace as 'rel'.

S C R I P T I N G — C A S E  3

1 Click the COMSOL Script window.

Again, you can choose between using the ready-made script that comes with the model 
or typing it in yourself. If you choose to run the ready-made script, you can skip the 
next few steps where the script is created and saved, and continue with Step 7.

2 If you choose to type it in yourself, type edit at the prompt to bring up a 
COMSOL Script Editor window.

3 Type the following script into the COMSOL Script Editor:

close all;
% Create vectors containing initial concentrations
cI = [0.04 0.08];
cIO3 = [0.04 0.1];
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%create a loop
for i = 1:2
% solve the reaction model
rel.sol=femtime(rel, 'report','off', ...
'solcomp',{'c_NaIO3','c_Na','c_IO3','c_I','c_I2'}, ...  
'outcomp',{'c_NaIO3','c_Na','c_IO3','c_I','c_I2'}, ...
'const',{'c0_I',cI(i),'c0_IO3',cIO3(i)}, ...
'atol',1e-7, ...
'rtol',1e-8, ...
'tlist',0:1:4000);

%Create the phase plots for each simulation
postglobalplot(rel,'c_IO3','linxdata','c_I', ...
'axislabel',{'concentration c_I [mol m^-3]','concentration c_IO3 
[mol m^-3]'});
hold on

%end loop
end

hold off

4 Choose File>Save to save the file and specify the name as 
oscillating_reactions_bz.m.

5 Return to the COMSOL Script command window.

6 Run the script by choosing File>Run M-file. Browse to where you saved the file, select 
it, and click Open to generate Figure 4-52.

7 To run the ready-made script, simply choose File>Run M-file and browse to models/
Reaction_Engineering_Lab/Education/oscillating_reactions_bz.m in 
the COMSOL installation directory.

8 Click OK to generate Figure 4-52.
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Ana l y z i n g  P r e s s u r e - T ime Da t a  i n  
Pa r ame t e r  E s t ima t i o n

Introduction

This example illustrates the estimation of the reaction order and rate constant for the 
gas phase decomposition of ditertbutyl peroxide. The reaction takes place in a closed 
vessel of constant volume where the total pressure is measured as a function of reaction 
time.

The parameter estimation functionality of the Reaction Engineering Lab is directly 
integrated into the software’s graphical user interface. As such, it allows for seamless 
calibration and validation of your model with respect to experimental results, before 
advancing to reactor analysis and design. Once experimental data has been imported, 
you can make use of predefined reactor types and automatically generated kinetics to 
evaluate the kinetic parameters of the model.

Model Definition

This example reproduces results found in Ref. 1.

Gas phase ditertbutyl peroxide decomposes into ethane and dimethyl ketone in a batch 
reactor of fixed volume.

 (4-90)

The reactor contains pure peroxide initially and is held at a constant temperature of 
170 °C. In order to evaluate the reaction order as well as the rate constant, experiments 
are performed where the total pressure (Pa) in the reactor is measured as a function of 
time (s).

TIME PRESSURE

60 1.15E+03

120 1.31E+03

180 1.43E+03

240 1.56E+03

C2H6
k +H3C C

CH3
O

CH3

O C
CH3

CH3

CH3 H3C CH3

O

2
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M A S S  B A L A N C E S

The mass balances describing a perfectly mixed reactor with constant volume are 
summarized by

 (4-91)

where ci represents the species concentration (mol/m3), and Ri denotes the species 
rate expression (mol/(m3·s)). The reaction rate is given by:

 (4-92)

where, α indicates the reaction order. Taking the reaction stoichiometry into account 
the species mass balances are:

 (4-93)

 (4-94)

300 1.66E+03

360 1.75E+03

420 1.86E+03

480 1.95E+03

540 2.04E+03

600 2.09E+03

660 2.17E+03

720 2.23E+03

780 2.29E+03

840 2.36E+03

900 2.40E+03

960 2.43E+03

1020 2.49E+03

1080 2.53E+03

1140 2.56E+03

1200 2.60E+03

TIME PRESSURE

dci
dt
-------- Ri=

r kcDTP
α

=

dcDTP
dt

----------------- r–=

dcEt

dt
------------ r=
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 (4-95)

Solving the mass balances provides the evolution of the species concentrations with 
time. Correlating the simulated results with the experimental data requires a relation 
between the total concentration and the total pressure. This relation is given by the 
ideal gas law:

 (4-96)

where Rg is the ideal gas constant (J/(mol·K)), and T the temperature (K).

The total pressure is calculated automatically in the Reaction Engineering Lab, and 
you find the expression in the Model Settings dialog box.

Results 

The plots below show the simulation results along with the experimental data points. 
In each instance, the reaction order has been held constant (α = 0, 1, and 2) while the 
rate constant has been estimated.

Figure 4-53: Simulated results and experimental data showing the total pressure in the 
reactor as a function of time. The reaction order α is 0.

dcDMK
dt

------------------- 2r=

p ciRgT∑=
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Figure 4-54: Simulated results and experimental data showing the total pressure in the 
reactor as a function of time. The reaction order α is 1.

Figure 4-55: Simulated results and experimental data showing the total pressure in the 
reactor as a function of time. The reaction order α is 2.

Clearly, a first order reaction gives the best fit to data. If α = 1 the corresponding rate 
constant is estimated to be 1.33·10−3 (1/s).

References

1. H. S. Fogler, Elements of Chemical Reaction Engineering 3rd Ed. Prentice Hall PTR, 
1999, pp. 229–239.
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Model Library path: Education/pressure_time

Modeling Using the COMSOL Reaction Engineering Lab

M O D E L  N A V I G A T O R

1 Start the COMSOL Reaction Engineering Lab.

2 In the Model Navigator click the New button.

O P T I O N S  A N D  S E T T I N G S

Start by setting up constants and expressions used in the model.

1 Select the menu item Model>Constants and type in the following entries:

2 Click OK.

3 Select Model>Expressions and type in the following entries:

4 Click OK.

Continue with global model settings.

5 Click the Model Settings button on the Main toolbar.

6 On the General page type 273.15+170 in the Temperature edit field.

7 Click Close.

R E A C T I O N S  I N T E R F A C E

1 Click the Reaction Settings button on the Main toolbar.

2 Create a new entry in the Reaction selection list by clicking the New button.

3 Type DTP=>ET+2DMK in the Formula edit field.

4 Edit the predefined reaction rate expression to include the reaction order. Type 
kf_1*c_DTP^alfa in the r edit field.

NAME EXPRESSION DESCRIPTION

alfa 0 reaction order

p0 1000 initial pressure

NAME EXPRESSION DESCRIPTION

c0 p0/Rg/T DTP initial concentration (mol/m^3)
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S P E C I E S  I N T E R F A C E

1 Click the Species page.

2 Select DTP in the Species selection list, then type c0 in the c0 edit field.

3 Click Close.

P A R A M E T E R  E S T I M A T I O N

1 Click the Parameter Estimation Settings button on the Main toolbar.

2 In the Data set selection area, click the Import From File button.

3 Browse to the file pressure_time_data.txt, select it and click Import.

4 Select the pressure_time_data.txt entry in the Data set selection list.

5 Go to the Variable Mapping page and select the Pressure data entry in the Data 

selection list.

6 Type Rg*T*(c_DTP+c_ET+c_DMK) in the Expression edit field. 

This associates the measured pressure with an expression for the pressure defined in 
the model. Equivalently you could type p in the Expression edit field, as Reaction 
Engineering Lab automatically calculates the pressure according to Equation 4-96. 
You find this relation defined in the Model Settings dialog box, in the Pressure edit 
field.

7 Click the Parameters page.

8 Select kf_1 (Forward rate constant 1) from the list of Predefined parameters, then click 
the > button.

9 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Estimate Parameters button on the Main toolbar to find kf_1 for alfa = 0.

Note that the software automatically updates the reaction model with the new 
parameter value. In this example, you find the updated value in the Forward rate 

constant edit field, in the Reaction Settings dialog box. Also, the software automatically 
runs the model simulation with the updated parameters. You can change these settings 
on the Advanced page in the Parameter Estimation Settings dialog box.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

By default, the model plots the concentration transients of species with a nonzero 
initial concentration. Reproduce Figure 4-53 with the following steps:

1 Click the Plot Parameters button on the Main toolbar.
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2 Remove all entries from the Quantities to plot list by clicking the << button.

3 In the Expression edit field type p, then click the > button.

4 Click OK.

5 Select the menu item Model>Constants and set the reaction order alfa to 1.

6 Solve the problem again with the new reaction order by clicking the Estimate 

Parameters button.

7 Continue in the same manner to produce results for alfa = 2.
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M i c r o b i a l  G r ow t h  i n  Food

Introduction

Predicting levels of disease-producing microorganisms has enormous cost-saving 
potential in food product development. Accurate models reduce the need for extensive 
and time-consuming microbiological testing. Furthermore, food processing methods 
may be re-evaluated, possibly leading to milder treatments of fresh foods while 
maintaining microbial safety.

In this example, you first set up a kinetic model of the microbial growth in the Reaction 
Engineering Lab and solve the corresponding material balance equations under 
isothermal conditions. Subsequently, you export the reaction model to COMSOL 
Script, where you perform a parametric study, observing bacterial growth as a function 
of temperature.

The model uses a chemical kinetics approach to describe the four phases of the 
microbial life cycle. The study specifically concerns the growth and death of 
Staphylococcus aureus  in bread (Ref. 1). S. aureus  is a dangerous pathogen that grows 
anaerobically and produces a heat-resistant and persistent toxin, causing cramps, 
diarrhoea, and nausea.

Model Description

Models of bacterial life cycles can be set up in a manner analogous to chemical reaction 
mechanisms. The four steps involved are represented in Figure 4-56.

Figure 4-56: The life and death of Staphylococcus aureus.

The first step corresponds to the activation of cells from the lag phase (M) to the 
growth phase (Ms). The second step represents the multiplication of cells via binary 
division. This step also produces an antagonistic metabolite (A), which interacts with 
the active species (Ms) to cause cell death (D). The natural death of cells also occurs.

A+

M

Ms

Ms

D

D

Msk1 k2

k3

k4
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The four irreversible reactions illustrated in Figure 4-56 translate into the following 
reaction rate expressions:

 (4-97)

 (4-98)

 (4-99)

 (4-100)

Making the use of these reaction rates and the reaction stoichiometry, the material 
balances for the model become:

 (4-101)

 (4-102)

 (4-103)

 (4-104)

The above reaction rate expressions and balance equations are automatically generated 
in the Reaction Engineering Lab; just type the corresponding chemical reaction 
formulas into the user interface. Material balances are solved at constant system 
temperature.

Experiments provide the following rate constants for a set of relevant temperatures:

The temperature is given in degrees Celsius and the cell concentration in cell count per 
µL.

 T (oC)  k1 (s
-1)  k2 (s

-1)  k3 (conc-1s-1)  k4 (s
-1) 

10 5.67·10-6 1.16·10-5 2.06·10-15 1.22·10-5

20 1.36·10-6 1.37·10-5 1.92·10-15 1.16·10-5

30 1.08·10-5 3.53·10-5 3.66·10-14 6.60·10-6

40 2.91·10-5 5.43·10-5 2.65·10-13 1.47·10-5

r1 k1cM=

r2 k2cMs=

r3 k3cMscA=

r4 k4cMs=

td

dcM r1–=

td

dcMs r1 r2 r3– r4–+=

td

dcA r2 r3–=

td

dcD r3 r4+=
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Results

Figure 4-57 shows the development of all species as a function of time at a system 
temperature of 40 °C. As experimental techniques of measuring S. aureus  cells do not 
distinguish between cells in the lag phase (M) and the multiplying phase (Ms), the plot 
also shows the total cell count, U = M + Ms.

Figure 4-57: Growth and death of  S. aureus in bread, at 40 oC, during a 7 day time span. 
Cell species concentrations given in (cell count µ/L) as functions of time (s).

Lag phase cells (M) undergo a first-order decline toward limiting values, while the 
antagonist (A) and the dead cells (D) show a first-order increase. The concentration of 
actively multiplying species (Ms) increases to a maximum and then declines. Excluding 
the initial stages of the simulation, the total number of living cells (U) is close to the 
amount of multiplying cells (Ms). This means that Ms plays the predominant role in 
determining the value of U throughout most of the kinetics process.
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Figure 4-58 shows the multiplying cell concentration as a function of time for system 
temperatures of 10, 20, 30, and 40 °C.

Figure 4-58: The concentration of multiplying S. aureus in bread, during a time span of 
100 days, evaluated at temperatures of 10, 20, 30, and 40 oC. Cell species concentrations 
given in (cell count µ/L) as functions of time (s).

At 10 °C, there is a moderate increase of multiplying S. aureus. With increasing 
temperature, a distinct peak in cell concentration is established, occurring earlier in 
time, with increasing temperature. The maximum cell concentration is lower when the 
system temperature is 40 °C, compared to 30 °C. This is consistent with the optimal 
growth temperature for S. aureus being 37.5 °C.

Reference

1. i.A. Taub, F.E. Feeherry, E.W. Ross, K. Kustin, and C.J. Doona, Journal of Food 
Science, vol. 68, p. 2530, 2003.

Model Library path: Food_Processing/microbial_growth

Modeling Using COMSOL Reaction Engineering Lab

1 Start the Reaction Engineering Lab.

2 In the Model Navigator, click the New button.
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O P T I O N S  A N D  S E T T I N G S

1 Choose Model>Expressions, then enter the following data:

2 Click OK.

R E A C T I O N S  I N T E R F A C E

1 Choose Model>Reaction Settings (or use the Main toolbar button).

2 Create four entries in the Reaction selection list by clicking the New button four 
times.

3 Enter the following reaction formulas by first selecting the appropriate row in the 
Reaction selection list and then typing the corresponding expression in the Formula 
edit field. Note how expressions for the reaction rates are automatically generated 
and presented in the r edit field.

4 In the Reaction Settings dialog box (the same as above), enter the forward rate 
constants by first selecting the appropriate row in the Reaction selection list, then 
deleting the default expression in the kf edit field, and finally typing the following 
numbers for the different reactions:

S P E C I E S  I N T E R F A C E

1 Click the Species tab.

2 Check that the Species selection list has the four species (M, Ms, A, and D), given in 
the reaction formulas above.

NAME EXPRESSION DESCRIPTION

U c_M+c_Ms Total living cell concentration

REACTION ID # REACTION FORMULA

1 M=>Ms

2 Ms=>2Ms+A

3 A+Ms=>D

4 Ms=>D

REACTION ID #  kf
 

1 2.91e-5

2 5.43e-5

3 2.65e-13

4 1.47e-5
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3 On the General page, enter the following initial concentrations by selecting the 
species name in the Species selection list and typing in the corresponding value in the 
c0 edit field:

Notice that the default value is zero, so you only have to specify those initial values that 
deviate from zero, in this case the value for M.

4 Click Close when you are finished.

C O M P U T I N G  T H E  S O L U T I O N

1 Choose Simulation>Solver Parameters.

2 Clear the Stop if steady state is reached first check box.

3 In the Time stepping area, type 0:1e4:7*24*3600 in the Times edit field. This results 
in a simulation from time zero to seven days of reaction.

4 Click OK.

5 Click the Solve Problem button (=) on the Main toolbar to compute the solution.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot is a linear plot of all species concentrations as functions of time. To 
generate Figure 4-57, follow these steps:

1 Choose Postprocessing>Plot Parameters (or use the corresponding button on the 
Main toolbar).

2 From the Predefined quantities list, select Total living cell concentration.

3 Click the Add Entered Expression button (>) next to the Expression edit field below 
the Predefined quantities list to add U to the Quantities to plot list.

4 Click OK.

5 Click the Y log button on the Main toolbar.

6 Click the Edit Plot button on the Main toolbar to open the plot editor.

7 In the Axis tab, clear the y limits: Auto check box, and type 1e-4 and 1e10 in the 
corresponding edit fields.

SPECIES  c0 

M 1e4

Ms 0

A 0

D 0
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8 Click OK.

Modeling Using COMSOL Script

The goal is to solve the reaction model for four different reaction conditions and then 
plot the solution for the active species, Ms, for all four cases.

E X P O R T

In the Reaction Engineering Lab, choose 
File>Export>REL Structure to Workspace as 'rel'.

COMSOL Script launches, if not already open.

S C R I P T I N G

1 Click the COMSOL Script window.

You can choose between using the ready-made script that comes with the model or 
typing it in yourself. If you choose to run the ready-made script, you can skip the 
next step, where the script is created and saved, and continue with Step 7.

2 Type edit at the prompt to bring up a COMSOL Script Editor window.

3 If you choose to type it in yourself, type the following script into the text editor:

% Create vectors for containing the forward rate constants
% for the different temperatures
k1 = [5.67e-6 1.36e-6 1.08e-5 2.91e-5];
k2 = [1.16e-5 1.37e-5 3.53e-5 5.43e-5];
k3 = [2.06e-15 1.92e-15 3.66e-14 2.65e-13];
k4 = [1.22e-5 1.16e-5 6.6e-6 1.47e-5];

linecolors = {'b','r','g','m'};

%create a loop
for i = 1:4
  % solve the reaction model
  rel.sol=femtime(rel, 'report','off', ...
  'solcomp',{'c_M','c_Ms','c_A','c_D'}, ...
  'outcomp',{'c_M','c_Ms','c_A','c_D'}, ...
  'const',{'kf_1',k1(i),'kf_2',k2(i),'kf_3',k3(i),'kf_4',k4(i)}, 
...
  'tlist',0:1e4:100*24*3600);

  %Plot the results for each simulation
  postglobalplot(rel,'c_Ms','axistype',{'log','log'}, ...
  'axis',[4 7 -2 10],'grid','off','linlegend','on', ...
  'axislabel',{'time','concentration'}, ...
  'lincolor',linecolors{i});
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  hold on;
  
end;

4 Choose File>Save to save the file and specify the name as: microbial_growth.m.

5 Go back to the COMSOL Script command window by clicking in it.

6 Run the script by choosing File>Run M-file. Browse to where you saved the file, select 
it, and click Open.

7 To run the ready-made script, choose File>Run M-file, browse to models/
Reaction_Engineering_Lab/Food Processing/microbial_growth.m in the 
COMSOL installation directory, and click Open.

8 Click the Edit Plot button in the Figure 1 window.

9 Select the first Axes>Line(c_Ms).

10 In the Legends edit field, type c_Ms 10 C.

11 Select the second Axes>Line(c_Ms).

12 In the Legends edit field, type c_Ms 20 C.

13 Select the third Axes>Line(c_Ms).

14 In the Legends edit field, type c_Ms 30 C.

15 Select the fourth Axes>Line(c_Ms).

16 In the Legends edit field, type c_Ms 40 C.

17 Click OK.

You should now get Figure 4-58.
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Hyd r o c a r b on Deha l o g e n a t i o n  i n  a  
T o r t u ou s  M i c r o r e a c t o r

Introduction

Removing halogen groups from hydrocarbons is an important reaction step in several 
chemical processes. One application is water purification. Other examples involve 
organic synthesis, where the removal of halogen groups serves as a starting point for 
carbon-carbon coupling reactions. Typically, the carbon-halogen bond scission is 
activated by precious metal catalysts based on platinum or palladium.

The model presented here shows hydrocarbon dehalogenation as it occurs in a 
microreactor. The reactants are transported from the fluid bulk to the catalytic surfaces 
at the reactor walls, where they react. A first model is set up in Reaction Engineering 
Lab, where two competing reactions are analyzed. Subsequently, the reaction kinetics 
are exported to the MEMS Module, where a space-dependent model of the 
microreactor is set up and solved.

Note: This model requires the COMSOL Reaction Engineering Lab and the MEMS 
Module.

Model Definition

The adsorption of halogenated hydrocarbons onto the surface of a platinum catalyst 
leads to cleavage of the carbon halogen bond. The hydrocarbon fragments then 
undergo either hydrogenation or coupling reactions. Figure 4-59 illustrates the overall 
reactions for a brominated hydrocarbon species.

 (4-105)

Figure 4-59: The dehalogenation of RBr can result either in hydrogenation or coupling of 
the hydrocarbon fragments.

R-H
k1R-Br

[Pt]

R-R2R-Br
k2

[Pt]
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The reaction rates are:

 (4-106)

and

 (4-107)

where the rate constants are given by the Arrhenius expression:

 (4-108)

In Equation 4-108, A is the frequency factor, and E the activation energy (J/mol). 
The table below lists the values of the Arrhenius parameters for the two reactions.

I D E A L  R E A C T O R  M O D E L

The mass balance equation for a flow-through reactor is given by

 (4-109)

where F is the molar flow rate (mol/s), V the reactor volume (m3), and Ri the net 
reaction term (mol/(m3· s)). If the reactor has constant cross-section and constant 
flow velocity, the left hand side of Equation 4-109 can be rewritten as

 (4-110)

The reactor mass balance thus becomes

 (4-111)

where τ represents the residence time (s). The assumption of constant flow velocity is 
valid for incompressible liquids or liquids where the effect of temperature on the 
density is small. Equation 4-111 is identical to the balance equation of the batch 

TABLE 4-2:  ARRHENIUS PARAMETERS

FREQUENCY 
FACTOR

ACTIVATION 
ENERGY

Reaction 1 2e-3 10e3

Reaction 2 1e-3 30e3

r1 k1cRBr=

r2 k2cRBr
2

=

kj Aj
Ej

RgT
------------–

⎝ ⎠
⎜ ⎟
⎛ ⎞

exp=

dFi

dV
--------- Ri=

dFi

dV
--------- u

dci

dx
--------

dci

dτ
--------= =

dci

dτ
-------- Ri=
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reactor, except that residence time replaces the reaction time. You can therefore make 
use of the Batch reactor type when solving the model in the Reaction Engineering Lab.

The ideal reactor model assumes by default that reactions take place in the entire 
reactor volume. In the 3D microreactor model, reactions occur at catalytic surfaces 
located at the reactor walls. In order to make the ideal model represent a reactor with 
surface reactions, Equation 4-111 has to be scaled by the reactive area per reactor 
volume. Scaling the ideal reactor equations by the dimensions of the microreactor 
makes the 1D and 3D models comparable. The area to volume ratio is

 (4-112)

where W is the width of the channel (m), H the channel height (m), and L the length 
of a reactive section (m). The scaled ideal reactor equation is then

 (4-113)

Note that the net reaction term (Ri) in this case represents surface reactions 
(mol/(m2· s)).

S P A C E - D E P E N D E N T  M O D E L

The microreactor considered in this example consists of a tortuous channel, fitted with 
inlet and outlet adapter sections, as illustrated in Figure 4-60. 

Figure 4-60: Microreactor geometry.

WL
WLH
--------------- 1

H
-----=

dci

dτ
--------

Ri

H
------=

Inlet

Outlet

Catalytic surface
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In the straight sections of the reactor, the channel walls are in part coated with 
platinum catalyst. As water with small amounts of a brominated hydrocarbon flows 
through the reactor, dehalogenation reactions occur at the catalytic surfaces. 

M O M E N T U M  B A L A N C E S

The flow in the channel is described by the Navier-Stokes equations:

 (4-114)

where ρ denotes density (kg/m3), u represents the velocity (m/s), η denotes viscosity 
(kg/(m· s)), and p equals pressure (Pa).

A pressure difference drives the flow through the reactor, as indicated by the boundary 
conditions

 (4-115)

Each pressure condition is specified along with a vanishing viscous stress condition at 
the boundary

At the wall the velocity is zero

 (4-116)

M A S S  B A L A N C E S

The mass balances set up and solved are the diffusion-convection equations at steady 
state:

 (4-117)

where Di denotes the diffusion coefficient (m2/s), ci is the species concentration 
(mol/m3), and u equals the velocity vector (m/s).

No reactions take place in the fluid bulk. Rather, the reactions take place on the 
catalytic surfaces. The boundary fluxes at the catalytic surfaces thus become

 (4-118)

∇ η– ∇u ∇u( )T
+( ) pI+[ ]⋅ ρ u ∇⋅( )u–=

∇ u⋅ 0=

p pinlet= inlet

p 0= outlet

η ∇u ∇u( )T
+( )n 0=

u 0= walls

∇ Di∇– ci ciu+( )⋅ 0=

n Di∇– ci ciu+( )⋅ Ri=
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where Ri represents the reaction term. Note that these boundary conditions are set up 
automatically as you export the reaction kinetics from the Reaction Engineering Lab 
to COMSOL Multiphysics.

Inlet conditions are equal to the inlet concentrations

 (4-119)

At the outlet, you can set the convective flux condition, assuming that the transport of 
mass across the boundary is dominated by convection

 (4-120)

All other boundaries use the insulating condition

 (4-121)

Results

First review the results of the ideal reactor model, which you set up and solve in the 
Reaction Engineering Lab.

Figure 4-61 through Figure 4-63 show concentration profiles of reactant and 
products as function of residence time, evaluated at 288 K, 343 K, and 363 K.

Figure 4-61: Concentration of the RBr, RH, and RR species as function of residence time. 
Reactions occur at 288 K.

c cin=

n D∇– c( )⋅ 0=

n D∇– c cu+( )⋅ 0=
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Figure 4-62: Concentration of the RBr, RH, and RR species as function of residence time. 
Reactions occur at 343 K.

Figure 4-63: Concentration of the RBr, RH, and RR species as function of residence time. 
Reactions occur at 363 K.

The hydrocarbon coupling reaction has the higher activation energy and is hence more 
temperature sensitive than the hydrogenation reaction (see Table 4-2). The 
concentration plots of the ideal reactors outline the effect quite clearly. At 288 K, the 
hydrogenation product RH is dominant, while at 363 K the coupling product is the 
more prominent. Notably, at 343 K, the concentration dependency on the reaction 
rates becomes accentuated, so that RBr dominates only at shorter τ and RH at longer 
τ.
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Although the primary goal may be to remove the halogenated reactant, RBr, it may 
also be important to set reaction conditions in such a way that the most favorable 
by-product is formed. The present model shows how such design aspects can readily 
be investigated in the Reaction Engineering Lab.

The next set of results refer to the space-dependent model of a tortuous microreactor, 
set up and solved in COMSOL Multiphysics.

Figure 4-64 shows the velocity of the laminar flow field in the reactor. The flow is 
driven by a pressure difference of 1500 Pa between inlet and outlet. The resulting 
maximum velocity is close to 5 mm/s.

Figure 4-64: Velocity field in the reactor where the pressure difference between inlet and 
outlet is 1500 Pa.
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Figure 4-65 shows the concentration distribution of the reactant RBr in the reactor. 
At relatively low temperature, 288 K, the outlet concentration is 10.6 mol/m3.

Figure 4-65: Concentration distribution of the halogenated reactant RBr. Fluid 
properties and reaction rates are evaluated at 288 K.

Running the reactor at 363 K, the outlet concentration of RBr is still 6.7 mol/m3.

Figure 4-66: Concentration distribution of the halogenated reactant RBr. Fluid 
properties and reaction rates are evaluated at 363 K.

Judging from the results of the ideal reactor models, a more pronounced temperature 
effect would be expected. The reason for this apparently moderate influence on 
conversion is that the increased temperature also affects the flow.
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Raising the temperature from 282 K to 363 K decreases the viscosity of water from 
1.36·10−3 to 3.17·10−4. This is automatically taken into account by the temperature 
dependent fluid properties. As the flow through the reactor is driven by a constant 
pressure difference, the velocity will increase as viscosity decreases. Results show that 
the maximum fluid velocity at 363 K is ~3.6 times greater than at 282 K, resulting in 
a shorter residence time.

Model Library path: Microfluidics/tortuous_reactor

The following path shows the location of the COMSOL Multiphysics model:

Model Library path: Reaction_Engineering_Lab/Microfluidics/
tortuous_reactor

Modeling Using COMSOL Multiphysics

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics by clicking the desktop icon.

2 Select 3D from the Space dimension list.

3 In the list of application modes select MEMS Module>Microfluidics>Incompressible 

Navier-Stokes.

4 Click OK.

G E O M E T R Y  M O D E L I N G

Select the menu item File>Import CAD Data From File. Browse to the file 
tortuous_reactor.mphbin and click Import.

P H Y S I C S  S E T T I N G S

Subdomain Settings—Incompressible Navier-Stokes
1 Choose Physics>Subdomain Settings.

2 In the Subdomain selection list, select all subdomains by pressing Ctrl+A and clicking 
the list.

3 Go to the Material/Coefficients Library by clicking the Load button.
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4 Browse to Liquids and Gases>Liquids>Water, liquid and click OK to load the 
properties.

5 Click OK.

Boundary Conditions—Incompressible Navier-Stokes
1 Choose Physics>Boundary Settings.

2 Enter the following boundary conditions:

Leave all other boundaries at their default setting (Wall, No slip).

3 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 Choose Options>Constants then enter the following data:

2 Click OK.

M E S H  G E N E R A T I O N

1 Select the menu item Mesh>Free Mesh Parameters.

2 On the Global page select Finer from the Predefined mesh sizes list.

3 Click the Boundary page, select Boundary 8, and click the Mesh Selected button.

4 Choose Mesh>Swept Mesh Parameters.

5 Select Subdomains 2–19 and 21 from the Subdomain selection list by pressing Ctrl 
and clicking the list.

6 Click the Mesh Selected button.

7 Click OK to close the Swept Mesh Parameters dialog.

8 Go to the Free Mesh Parameters dialog, and click the Subdomain page.

9 Select Subdomains 1 and 20 from the Subdomain selection list by pressing Ctrl and 
clicking the list.

SETTINGS BOUNDARY 6 BOUNDARY 104

Boundary type Inlet Outlet

Boundary condition Pressure, no 
viscous stress

Pressure, no 
viscous stress

p0 delta_p 0

NAME EXPRESSION DESCRIPTION

delta_p 1.5[kPa] Inlet overpressure

T 288[K] Temperature
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10 Click the Mesh Selected button.

11 Click OK to close the Free Mesh Parameters dialog box.

C O M P U T I N G  T H E  S O L U T I O N

1 Solve the problem by clicking the Solve button (=) on the Main toolbar.

2 Select the menu item Solve>Solver Manager.

3 Press the Store Solution button and the click OK.

P O S T P R O C E S S I N G  T H E  S O L U T I O N

The following steps reproduce Figure 4-64:

1 Choose Postprocessing>Plot Parameters.

2 On the Slice page, select the Slice plot check box.

3 Type 0 in the x-levels edit field and 1 in the z-levels edit field.

4 Click OK.

Modeling Using the COMSOL Reaction Engineering Lab

1 In the main user interface of COMSOL Multiphysics, choose 
File>Reaction Engineering Lab.

The main user interface of COMSOL Reaction Engineering Lab opens up.

2 Click the COMSOL Reaction Engineering Lab window.

O P T I O N S  A N D  S E T T I N G S

1 Click the Model Settings button on the Main toolbar.

2 On the General page type 288 in the Temperature edit field.
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3 Click Close.

4 Choose Model>Constants then enter the following data:

5 Click OK.

R E A C T I O N S  I N T E R F A C E

1 Click the Reaction Settings button on the Main toolbar.

2 Make sure the Reactions page is active. Create two entries in the Reaction selection 

list by clicking the New button twice.

3 Enter the following reaction formulas by first selecting the appropriate row in the 
Reaction selection list and then entering the corresponding text in the Formula edit 
field.

4 Select row 1 from the Reaction selection list.

5 Select the Use Arrhenius expression check box.

6 Enter 2e-3 in the A edit field and 10e3 in the E edit field.

7 Select row 2 from the Reaction Selection list.

8 Select the Use Arrhenius expression check box.

9 Enter 1e-1 in the A edit field and 30e3 in the E edit field.

10 Select Reaction 1 from the Reaction selection list and type kf_1*c_RBr/H in the r 
edit field. 

11 Select Reaction 2 from the Reaction selection list and type kf_2*c_RBr^2/H in the 
r edit field.

You have now modified the automatically generated reaction rates by dividing with 
the scale factor H, according to Equation 4-113.

S P E C I E S  I N T E R F A C E

1 Click the Species tab.

2 Select RBr from the Species selection list and type 50 in the c0 edit field.

3 Click Close.

NAME EXPRESSION DESCRIPTION

H 5e-6 Reactor channel height (m)

REACTION ID # REACTION FORMULA

1 RBr=>RH

2 2RBr=>RR
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C O M P U T I N G  T H E  S O L U T I O N

1 Open the Simulation>Solver Parameters dialog box.

2 Type 1 in the Times edit field.

3 Click OK.

4 Click the Solve Problem button (=) on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The results of Figure 4-61 are shown in the default plot. To generate the results shown 
in Figure 4-62 follow these steps.

1 Click the Model Settings button on the Main toolbar.

2 On the General page type 343 in the Temperature edit field.

3 Click Close.

4 Click the Solve Problem button.

To generate the results shown in Figure 4-63:

1 Click the Model Settings button on the Main toolbar.

2 On the General page type 363 in the Temperature edit field.

3 Click Close.

4 Click the Solve Problem button.

E X P O R T  S E T T I N G S

You will now proceed to export the reaction kinetics to the reacting boundaries in the 
Multiphysics model. Recall that the rate constants are temperature dependent. To 
export a temperature variable while only exporting mass balances, follow these steps:

1 Click the Model Settings button on the Main toolbar.

2 On the General page type Temp in the Temperature edit field.

3 Click Close.

This will export a variable name Temp rather than a constant temperature, which would 
otherwise be the case.

Recall also that the reaction rates were scaled in order to make the 1D ideal reactor 
comparable to the 3D microreactor. As you are about to export the reaction kinetics 
to the 3D model, the effect of the scaling should first be removed.
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1 Choose Model>Constants then set the scaling factor H to 1:

2 Click OK.

Now, move on to export the reaction model.

1 Click the Export to COMSOL Multiphysics button on the Main toolbar.

2 The Export to COMSOL Multiphysics dialog box appears.

3 Select Boundary in the Domain level drop down list.

4 Go to the Export mass balance area, and in the Application mode list select Convection 

and Diffusion: New.

5 In the Group name edit field type reactions.

6 Move to the Export energy balance area and clear the check box in the upper left 
corner.

7 Click the Export button at the bottom of the dialog box.

Modeling Using COMSOL Multiphysics

It is now time to investigate the chemistry taking place in a space-dependent model.

Click the COMSOL Multiphysics window.

Subdomain Settings—Convection and Diffusion
1 From the Multiphysics menu select Convection and Diffusion (chcd).

2 From the Physics menu select Subdomain Settings.

3 In the Subdomain selection list, select all subdomains by pressing Ctrl+A and clicking 
the list.

4 On the c_RBr page type the following:

5 Type in the same entries on the c_RH page and the c_RR page.

NAME EXPRESSION DESCRIPTION

H 1 reactor channel height (m)

EDIT FIELD VALUE

Diffusion coefficient D

x-velocity u

y-velocity v

z-velocity w
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6 Click OK.

Boundary Conditions—Convection and Diffusion
1 From the Physics menu select Boundary Settings.

2 In the Boundary selection list, select 27, 41, 57, 71, and 87 by pressing Ctrl and 
clicking the entries. These boundaries represent the reactive surfaces.

3 Select reactions from the Group list.

This associates the exported kinetics from Reaction Engineering Lab with the 
catalytic surfaces. The Flux boundary condition is automatically set on all mass 
balance pages, and the appropriate reaction terms appear in the Inward flux edit 
fields.

4 Enter the remaining boundary conditions for each of the species c_RBr, c_RH, and 
c_RR according to the following table:

5 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu select Constants.

2 Add entries to complete the list of constants as follows:

3 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Select the menu item Solve>Solver Manager.

SETTINGS BOUNDARY 6 BOUNDARY 104 ALL OTHERS

Boundary 
condition

Concentration Convective flux Insulation/Symmetry

c_RBr0 50

c_RH0 0

c_RR0 0

NAME EXPRESSION DESCRIPTION

delta_p 1.5[kPa] Inlet overpressure

T 288[K] Temperature

D 1e-6[m^2/s]*exp(-2000[K]/T) Diffusivity

Temp T Temperature
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2 In the Values of variables not solved for and linearization point, click the Stored 
solution option button.

3 Click the Solve For tab.

4 Select only the Convection and Diffusion (chcd) folder in the Solve for variables tree.

5 Click OK.

6 Solve the problem by clicking the Solve button (=) on the Main toolbar.

PO S T P R O C E S S I N G  T H E  S O L U T I O N

The following steps reproduce Figure 4-65:

1 Choose Postprocessing>Plot Parameters.

2 On the Boundary page, select the Boundary plot check box.

3 Type c_RBr in the Expression edit field.

4 Click OK.

To reproduce the results in Figure 4-66, change the variable T in the Constants dialog 
box to 363[K], and solve for the flow and mass balances as outlined above.
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I b up r o f e n  S y n t h e s i s

Introduction

Kinetic analysis of catalytic reactions is essential for understanding rate behavior as well 
as the reaction mechanism. Developing knowledge of intrinsic reaction kinetics and of 
rate equations is central to reaction engineering studies aimed at improving reactor 
design.

This example illustrates the reaction kinetics of a complex chemistry occurring in a 
perfectly stirred tank reactor. The homogeneous catalysis of 1-(4-isobutylphenyl) 
ethanol into the anti-inflammatory drug ibuprofen serves as the example chemistry. 
The model determines concentrations of reactants, intermediates, and products as 
functions of time for the network of chemical reactions.

The chemistry in this example involves homogeneous catalysis. As this terminology 
suggests, the catalyst and the reacting species are in the same phase. Most commonly, 
a liquid reaction mixture contains a soluble metalorganic complex that affects the 
catalysis. Organometallic catalysts can often be fine-tuned with respect to reaction 
activity and selectivity. Because these relatively expensive catalysts produce 
highly-refined reaction products, they commonly find application in fine chemicals or 
pharmaceutics.

The model focuses on the use of the Reaction Engineering Lab for a kinetics 
investigation. You easily enter chemical reaction formulas from the keyboard, then the 
Reaction Engineering Lab automatically generates rate expressions and material 
balances. It solves the equations, and you postprocess results directly in the graphical 
user interface.

Model Description

Analyzing chemical kinetics involves solving the set of ordinary differential equations 
corresponding to individual steps in a network of reactions. This example illustrates the 
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kinetics of ibuprofen synthesis. Figure 4-67 shows the reaction steps displayed in a 
catalytic cycle (Ref. 1).

Figure 4-67: Catalytic cycle of ibuprofen synthesis.

Prior to entering the cycle, the starting material, 1-(4-isobutylphenyl)ethanol, is first 
dehydrated to form 4-isobutylstyrene. This species subsequently undergoes the 
addition of HCl to produce the active substrate 1-(4-isobutylphenyl)ethyl chloride. 
The palladium catalyst must also go through an initial transformation, from L2PdCl2 
(L=triphenylphosphine) to anionic L2PdCl, before becoming active. The activated 
catalyst then assists in the carbonylation and hydrolysis of 1-(4-isobutylphenyl)ethyl 
chloride, producing ibuprofen.

The following reactions represent the catalytic cycle:

L2PdCl

CO

H2O

OH

L2PdCl2

Cl

L2PdCl2COClPdL2

COOH

H+

H+

HCl

-

-

Cl-
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 (4-122)

 (4-123)

 (4-124)

 (4-125)

 (4-126)

 (4-127)

 (4-128)

Reaction 4-122 involves the dehydration of the reactant alcohol to form the 
corresponding alkene. Reaction 4-123 describes the hydrohalogenation of alkene, 
resulting in the active substrate 1-(4-isobutylphenyl)ethyl chloride. Reaction 4-124 
shows the dehydrohalogenation of the active substrate, assisted by a base, B. 
Reaction 4-125 describes the transformation of the pre-catalytic species L2PdCl2 into 
the active anionic catalyst L2PdCl. In Reaction 4-126 the active substrate undergoes 
oxidative addition to the L2PdCl catalyst. Reaction 4-127 summarizes the 
carbonylation, and Reaction 4-128 describes the hydrolysis of the metalorganic 
species, leading to the formation of ibuprofen and regeneration of the catalyst.

In order to make species notation more manageable, this example uses the following 
labels:

OH
+ H+

k1 + H2O+ H+

++ H+ Cl-
Clk2

++ H+ Cl- + B+ B
Cl k3

+ CO + H2OL2PdCl2
k4

L2PdCl + +Cl- + CO2

-
2H+

L2PdCl +
k5

L2PdCl2

Cl-
-

CO
k6 + Cl-L2PdCl2 + L2PdClCO

-

H2O
k7 + H+ + L2PdCl+L2PdClCO

COOH -
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Making use of this notation, the reaction rates corresponding to Reaction 4-122 
through Reaction 4-128 are:

 (4-129)

 (4-130)

 (4-131)

 (4-132)

 (4-133)

 (4-134)

 (4-135)

The Reaction Engineering Lab automatically generates these expressions and displays 
them immediately when you enter the chemical reaction formulas. By default, the 

OH

L2PdCl2

L2PdCl

L2PdCl2

Cl

L2PdClCO

-

-

roh

ren

rhcl

pd1

pd2

pd3

pd4
COOH

ibu

species abbreviation species abbreviation

r1 k1crohch=

r2 k2crenchccl=

r3 k3crhclcb=

r4 k4cpd1ccoch2o=

r5 k5cpd2crhcl=

r6 k6cpd3cco=

r7 k7cpd4ch2o=
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software assumes that the chemistry takes place isothermally in a perfectly stirred batch 
reactor.

Figure 4-68: A perfectly stirred batch reactor where the reactant alcohol is carbonylated to 
form ibuprofen by means of palladium catalysis.

With no inflow or outflow from the reactor, the change of species concentrations with 
time is a function only of the reaction rates. The following set of ODEs result from the 
reaction rates (Equation 4-129 to Equation 4-135) and stoichiometry of the reaction 
formulas (Equation 4-122 to Equation 4-128):

 (4-136)

 (4-137)

 (4-138)

 (4-139)

 (4-140)

 (4-141)

 (4-142)

CO(l) Pd

R-OH

td

dcroh r1=

td

dcren r1 r2– r3+=

td

dcrhcl r2 r3– r5–=

td

dcibu r7=

td

dcpd1 r– 4=

td

dcpd2 r4 r5– r7+=

td

dcpd3 r5 r6–=
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 (4-143)

 (4-144)

 (4-145)

 (4-146)

The Reaction Engineering Lab automatically generates and solves these equations.

The model investigates two reaction conditions. The first simulation (Case 1) solves 
Equation 4-136 to Equation 4-146. In Case 2 you subsequently modify the reaction 
network with an additional reaction, altering the simulation results. Assume that the 
reactant alcohol and product ibuprofen (a carboxylic acid) react reversibly, forming an 
ester:

The results of the two simulations are compared to gain insight in the process 
implications.

td

dcpd4 r6 r7–=

td

dch r– 2 r3 2r4 r7+ + +=

td

dccl r– 2 r3 r4 r6+ + +=

td

dch2o r1 r4– r7–=

OH
+ H+

k8 + H2OH+
COOH

+
k8 O

O
+

r

f
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Results

C A S E  1

Figure 4-69 shows the concentration profiles for selected reactants and products over 
time.

Figure 4-69: Selected species concentrations (mol/m3) as a function of time (s).

Clearly, after approximately 2 hours the process has run to completion.
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C A S E  2

This expansion of the original case adds a reversible reaction between the reactant 
alcohol and the product ibuprofen to form an ester. Figure 4-70 shows the 
concentration of ibuprofen and ester over time.

Figure 4-70: Selected species concentrations (mol/m3) as a function of time (s).

In the course of the reaction, ester forms as an intermediary product. In order to 
achieve the same final concentration of ibuprofen for Case 2 as in Case 1, the process 
must run for at least 12 hours.

In conclusion, this example illustrates the use of the COMSOL Reaction Engineering 
Lab for analyzing the kinetics of a complex reaction network. When you enter the 
chemical-reaction formulas into the user interface, the Reaction Engineering Lab 
automatically sets up the corresponding rate expressions and material balances. You 
can modify simulation conditions effortlessly, for instance by activating/deactivating 
individual reactions or by changing initial conditions.

Reference

1. R.V. Chaudhari, A. Seayad, and S. Jayasree, Catalysis Today, vol. 66, p. 371, 2001.

Model Library path: Pharmaceuticals/ibuprofen_synthesis
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Modeling Using COMSOL Reaction Engineering Lab

M O D E L  N A V I G A T O R — C A S E  1

1 Start the Reaction Engineering Lab.

2 In the Model Navigator, click the New button.

R E A C T I O N S  I N T E R F A C E — C A S E  1

1 Click the Reaction Settings button on the Main toolbar.

2 Create seven entries in the Reaction Selection list by clicking the New button 
repeatedly.

3 Enter the following reaction formulas by first selecting the appropriate row in the 
Reaction Selection list and then typing the text in the Formula edit field. Note how 
the Reaction Engineering Lab automatically generates reaction rate expressions and 
presents them in the r edit field.

4 Specify the forward rate constants, one by one, according to the table below by first 
selecting the appropriate row in the Reaction selection list and then typing the 
corresponding value in the kf edit field.

REACTION ID # REACTION FORMULA

1 roh+h=>ren+h2o+h

2 ren+h+cl=>rhcl

3 rhcl+b=>ren+h+cl+b

4 pd1+co+h2o=>pd2+cl+2h+co2

5 pd2+rhcl=>pd3

6 pd3+co=>pd4+cl

7 pd4+h2o=>pd2+h+ibu

REACTION ID #  kf
 

1 7.45e-3

2 1.25e-2

3 1.60e-3

4 1.50e-1

5 1.59

6 2.14e-1

7 9.52e-1
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S P E C I E S  I N T E R F A C E — C A S E  1

1 Click the Species tab.

2 Check that the Species selection list has 14 entries when you have entered the 
reaction formulas just given.

3 On the General page, specify initial concentrations according to the table below by 
first selecting the appropriate entry in the Species selection list and then typing the 
corresponding value in the c0 edit field. (For species not in the table, keep the 
default value of 0 for c0.)

4 Click Close.

C O M P U T I N G  T H E  S O L U T I O N — C A S E  1

1 Choose Simulation>Solver Parameters.

2 In the Time stepping area, find the Times edit field and type 0 3600*3.

3 Click OK.

4 Click the Solve Problem button (=) on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N — C A S E  1

1 Choose Postprocessing>Plot Parameters.

2 Click the << button.

3 Go to the Predefined quantities list and Ctrl-click to select the entries roh, ren, rhcl, 
and ibu.

4 Click the > button to add the selected entries to the Quantities to plot list.

5 Click the Line Settings button, select the Legend check box, and click OK.

6 From the Plot in list, select New figure.

7 Click OK to generate Figure 4-69.

SPECIES NAME  c0 

roh 1.23

h 0.2

h2o 3

cl 0.2

b 0.1

pd1 1.21e-2

co 1.1
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R E A C T I O N S  I N T E R F A C E — C A S E  2

1 From the Model menu, select Reaction Settings.

2 Click the Reactions tab.

3 Create a new entry in the Reaction selection list by clicking the New button.

4 Enter the following reaction formula by first selecting the appropriate row in the 
Reaction selection list and then typing the text in the Formula edit field:

5 Enter the corresponding forward and reverse rate constants by first selecting the 
appropriate row in the Reaction selection list and then entering the numbers in the 
kf and kr edit fields:

S P E C I E S  I N T E R F A C E — C A S E  2

1 Click the Species tab.

2 Notice that the Species selection list is updated with the new ester species. Its initial 
concentration is 0, the default value in the c0 edit field.

3 Click Close.

C O M P U T I N G  T H E  S O L U T I O N — C A S E  2

1 Choose Simulation>Solver Parameters.

2 In the Time stepping area, find the Times edit field and type 0 3600*12. Click OK.

3 Click the Solve Problem button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N — C A S E  2

1 Choose Postprocessing>Plot Parameters.

2 Remove the intermediate species ren and rhcl from the Quantities to plot list by 
Ctrl-clicking those entries and then clicking the < button.

3 From the Predefined quantities list, select the ester species. Add it to the Quantities 

to plot list by clicking the > button.

4 Select Plot in list and select New figure.

5 Click OK create Figure 4-70.

REACTION ID # REACTION FORMULA

8 ibu+roh+h<=>ester+h2o+h

REACTION ID #  kf
  kr

 

8 0.5 1e-2
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P ro t e i n  Ad s o r p t i o n

This example uses algebraic equilibrium relations to model the time-dependent 
adsorption of proteins to an ion-exchanger medium. The fluid phase contains three 
components: two proteins and one salt. The adsorption/desorption kinetics are 
described by a set of equilibrium reactions where proteins displace ions adsorbed at the 
surface and vice versa.

The model highlights the implementation of reactions at chemical equilibrium in 
mass-transport modeling. Setting up the balance equations describing the present 
diffusion/reaction system results in a system of six partial differential equations. To 
include the algebraic equations describing reactions at chemical equilibrium, you must 
reformulate the system of balance equations. As this discussion illustrates, this 
reformulation process is normally quite involved—but it is important to note that the 
Reaction Engineering Lab automates this process. To include equilibrium reactions in 
your kinetics, simply enter the chemical reaction formulas and the corresponding 
equilibrium constants.

Introduction

The binding of proteins to ion exchangers can be described within the steric mass 
action approximation (SMA). This approach assumes that the adsorption of a protein 
can be considered as an exchange reaction of the protein with a given number of 
adsorbed ions.

Figure 4-71: Proteins A and B displacing salt ions S at an ion-exchanger surface.
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The equilibria describing the adsorption/desorption reactions are

Here, S denotes the salt ions, z represents the binding charge, P stands for the protein, 
and a indicates species being adsorbed to the surface. Once adsorbed, proteins can 
make neighboring salt ions unavailable for displacement, reducing the effective 
concentration of adsorbed salt ions, Sa. This fact is taken into account by a steric factor, 
σ, associated with each protein. 

Assuming monovalent salt ions, the equilibrium expression for this reaction is

 (4-147)

Model Definition

Two modeling assumptions are treated when studying the protein adsorption/
desorption kinetics. 

In the first instance, a perfectly mixed (space-independent) system is assumed. Initially, 
only free (S) and adsorbed (Sa) salt species are present. Equal concentrations of 
proteins A and B subsequently enter the system, as described by a Gaussian pulse:

 (4-148)

In the second instance, the influence of geometry is included. The modeling domain 
is a 1D representation of a section of a pore channel, 10 µm in length, in a particle of 
an ion exchanger gel. The channel is initially filled only with a salt solution, S. Proteins 
A and B subsequently enter the channel, diffuse along its length, and adsorb at the 
walls.

The following adsorption/desorption reactions occur:

+zSa P +zS Pa
eq

K

Keq cPa

cP
---------

cS

cSa σPcPa–
-------------------------------⎝ ⎠
⎛ ⎞

z
=

ci t( ) ci0 t t0–( )2
–( )exp=

+Sa A +S Aa
k1

k1
r

f

+Sa B +S Ba
k2

k2
r

f
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In total, six species are involved: three in the liquid phase (cS, cA, and cB) and three in 
the adsorbed phase (cSa, cAa, and cBa), all given in molar concentrations (mol/m3). 
The mass action law gives the reaction rates for reversible reactions as

The mass balances for the species in a time-dependent diffusion/reaction system are:

 (4-149)

 (4-150)

 (4-151)

 (4-152)

 (4-153)

 (4-154)

where Di (m
2/s) is the diffusion coefficient for species i  in the liquid and adsorbed 

phase. In this system of mass balance equations, the actual forward and reverse reaction 
rates are not known. However, the relationship between the rates comes from the 
equilibrium relationship, Equation 4-147. Assuming that z = 1 and σA = σB = 0, the 
relationships are

r1 k1
f cSacA k1

r cScAa–=

r2 k2
f cSacB k2

r cScBa–=

cA∂
t∂

--------- ∇+ D– A∇cA( )⋅ r– 1=

cB∂
t∂

--------- ∇+ D– B∇cB( )⋅ r– 2=

cS∂
t∂

-------- ∇+ D– S∇cS( )⋅ r1 r2+=

qA∂
t∂

--------- ∇+ D– Aa∇cAa( )⋅ r1=

qB∂
t∂

--------- ∇+ D– Ba∇cBa( )⋅ r2=

qS∂
t∂

--------- ∇+ D– Sa∇cSa( )⋅ r– 1 r2–=

K1
eq cAa

cA
---------

cS
cSa
---------⋅=

K2
eq cBa

cB
---------

cS

cSa
---------⋅=
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In order to combine the information in the mass balances and the equilibrium 
expressions, you must form linear combinations of the former (Equation 4-149 to 
Equation 4-154), thereby removing reaction rates r1 and r2 from the equation system. 
An exemplary set of linear combinations produces the following system of equations 
to solve:

.

The Reaction Engineering Lab automates this elimination procedure for reactions at 
equilibrium; it requires only the chemical reaction formula and the equilibrium 
constant. In this example K1

eq = 2 and K2
eq = 5.

t∂
∂ cS cAa– cBa–( ) ∇+ D– S∇cS DAa∇cAa DBa∇cBa+ +( )⋅ 0=

t∂
∂ cA cAa+( ) ∇+ D– A∇cA DAa– ∇cAa( )⋅ 0=

t∂
∂ cB cBa+( ) ∇+ D– B∇cB DBa– ∇cBa( )⋅ 0=

t∂
∂ cSa cAa cBa+ +( ) ∇+ D– Sa∇cSa D– Aa∇cAa DBa– ∇cBa( )⋅ 0=

K1
eqcAcSa cAacS– 0=

K2
eqcBcSa cBacS– 0=
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Results 

Figure 4-72 shows the concentrations of reacting species as function of time, assuming 
a perfectly mixed system.

Figure 4-72: Concentrations (mol/m3) of the reacting species as functions of time (s).

Initially, only salt species S and Sa are present, as is reasonable for a fresh ion exchanger 
medium. Proteins A and B enter the system in gaussian pulses centered around 5 
seconds (the two concentration profiles overlap). The stronger adsorption affinity of 
protein B compared to protein A is readily observed. Note also how the concentration 
of free salt species S increases as the proteins adsorb at the surface. Towards the end of 
the time interval, all protein has been removed by eluent and the exchanger medium 
has been restored. 
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Figure 4-73 shows the results of the space-dependent model. Plotted are the 
concentrations of surface species as a function of time at a point located at the center 
of the geometry.

Figure 4-73: Adsorbed species concentrations of Aa, Ba, and Sa over time.

As the front of diffusing proteins moves through the pore section, proteins clearly 
displace salt as adsorbed species. The results once again reproduce the fact that protein 
B has a higher adsorption affinity compared to A as expected through the input 
specification of K2

eq > K1
eq.

In summary, the model shows how to quickly set up and solve an applied problem 
involving mass transport and reactions at chemical equilibrium. It is very easy to set up 
the equilibrium kinetics in the Reaction Engineering Lab by supplying the chemical 
reaction formulas and the equilibrium constants. Exporting the model to COMSOL 
Multiphysics allows you to study how a geometry affects the reacting system.

Model Library path: Pharmaceuticals/protein_adsorption1

Model Library path: Pharmaceuticals/protein_adsorption2

The following path shows the location of the COMSOL Multiphysics model:
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Model Library path:  

Reaction_Engineering_Lab/Pharmaceuticals/protein_adsorption2

Modeling Using COMSOL Reaction Engineering Lab

M O D E L  N A V I G A T O R

1 Start the Reaction Engineering Lab.

2 In the Model Navigator, click the New button to launch the main user interface.

3 Click the Reaction Settings button on the Main toolbar.

O P T I O N S  A N D  S E T T I N G S

1 Click the Model Settings button on the Main toolbar.

2 Select the Calculate thermodynamic properties check box.

3 Select the Calculate species transport properties check box.

4 Click Close.

R E A C T I O N S  I N T E R F A C E

1 Make sure that the Reactions page is active. Create two entries in the Reaction 

selection list by clicking the New button twice.

2 Enter the following reaction formulas by first selecting the appropriate row in the 
Reaction selection list and then typing the corresponding text in the Formula edit 
field:

3 Enter the following equilibrium constants by first selecting the appropriate row in 
the Reaction selection list and then typing the corresponding number in the Keq

0 edit 
field:

REACTION ID # REACTION FORMULA

1 A+Sa=Aa+S

2 B+Sa=Ba+S

REACTION ID #  Keq
0 

1 2

2 5
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S P E C I E S  I N T E R F A C E

1 Click the Species tab.

2 Check that the Species selection list has the six entries expected from entering the 
reaction formulas just given.

3 On the General page, for each species in the table below, select the entry in the 
Species selection list and then enter the corresponding value for the Initial 

concentration in the c0 edit field.

4 Select species A in the Species selection list and select the Lock concentration/activity 
check box.

5 Select species B in the Species selection list and select the Lock concentration/activity 
check box.

6 Go to the Transport page. For each species in the table below, select the entry in the 
Species selection list, select the Specify diffusivity check box, and enter the 
corresponding value for the Diffusivity in the D0 edit field.

7 Click Close.

M O D E L  S E T T I N G S

1 Click the Model Settings button on the Main toolbar, then select the Stoichiometry 
page.

SPECIES NAME  c0 

A exp(-(t-5)^2)

Sa 0.5

Aa 0

S 1

B exp(-(t-5)^2)

Ba 0

SPECIES NAME  D0
 

A 5e-11

Sa 2e-9

Aa 1e-11

S 1e-8

B 7e-11

Ba 1.4e-11
R  4 :  M O D E L  L I B R A R Y



2 Set species Aa and Ba as the slave species by selecting the corresponding check boxes 
in the Slave column. Clear the other species’ check boxes.

3 Click Close.

The selection of slave species is automatic in Reaction Engineering Lab. In the 
present model you modify this choice and set the concentrations of adsorbed 
proteins as slave species. This is appropriate, as surface concentrations are difficult 
to evaluate experimentally. In general, it is good practice to review the default slave 
species selections in models containing equilibrium reactions.

C O M P U T I N G  T H E  S O L U T I O N

Start by investigating the kinetics in a perfectly mixed system in the Reaction 
Engineering Lab. To reproduce results of Figure 4-72, follow the steps listed below.

1 Choose Simulation>Solver Parameters.

2 In the Times edit field, type 10.

3 Click OK.

4 Click the Solve Problem button (=) on the Main toolbar.

You should now see the plot reproduced in Figure 4-72 on your screen.

S P E C I E S  I N T E R F A C E

Continue by modifying the model for export to COMSOL Multiphysics.

1 Choose Model>Reaction Settings.

2 With the Species tab active, go to the General page.

3 Select species A from the Species selection list, type 0 in the c0 edit field, and clear the 
Lock concentration/activity check box.

4 Select species B from the Species selection list, type 0 in the c0 edit field, and clear the 
Lock concentration/activity check box.

In the geometric subdomain, the initial concentrations of the protein species are 
zero.

5 Click Close.

E X P O R T  S E T T I N G S

1 From the File menu, select Export>Model to COMSOL Multiphysics.

The Start COMSOL Multiphysics dialog box appears.

2 From the Space dimension list, select 1D. Click OK.
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3 In the dialog box that launches, go to the Export mass balance area and select 
Diffusion: New from the Application mode list.

4 In the Group name edit field, type protein.

5 Move to the Export energy balance area and clear the check box in the upper left 
corner.

6 Click the Export button at the bottom of the dialog box.

Modeling Using COMSOL Multiphysics

G E O M E T R Y  M O D E L I N G

1 Hold down the Shift key and click the Line button on the Draw toolbar to launch 
the Line dialog box.

2 In the x edit field, type 0 1e-5, then click OK.

3 Click the Zoom Extents button.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 Choose Physics>Subdomain Settings.

2 From the Subdomain selection list, select 1.

3 From the Group list, select protein. 

The Reaction Engineering Lab created this group during the export process from 
the Reaction Engineering Lab to COMSOL Multiphysics. Note how all the relevant 
edit fields are automatically filled in. On the Stoichiometry page you can review the 
selection of slave species. If you want to make any changes to this selection, go back 
to the Reaction Engineering Lab, make the necessary changes, and then perform a 
new export.

4 Click OK.

Boundary Conditions
1 Choose Physics>Boundary Settings.

2 For all four species, enter the following boundary conditions:

3 From the Boundary selection list, select 1.

SETTINGS BOUNDARY 1 BOUNDARY 2

Type Concentration Insulation/Symmetry
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4 Select the tab for each of the four species, in turn, and type the corresponding value 
from the table below in the Concentration edit field:

5 Click OK.

G E O M E T R Y  M O D E L I N G

1 Click the Draw Mode button on the Main toolbar.

2 Shift-click the Point button, then in the x edit field type 0.5e-5.

This step places a point in the middle of the modeling domain. This point is where 
the model evaluates the change in species concentrations over time.

3 Click OK.

M E S H  G E N E R A T I O N

1 Choose Mesh>Free Mesh Parameters.

2 Click the Boundary tab, select Boundary 1, and type 1e-8 in the Maximum element 

size edit field.

3 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar. Check in the Solver list that 
Time dependent is selected.

2 Go to the Times edit field and enter the vector 0:0.01:4. Click OK.

3 Solve the problem by clicking the Solve button (=) on the Main toolbar.

PO S T P R O C E S S I N G  T H E  S O L U T I O N

The following steps reproduce Figure 4-73:

1 Choose Postprocessing>Domain Plot Parameters.

2 On the General page, select the Keep current plot check box.

3 On the Point page, locate the Boundary selection list and choose 2.

4 From the Predefined quantities list, select Concentration, c_Aa.

SPECIES CONCENTRATION

c_A 1

c_Sa 0.1

c_S 1

c_B 1
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5 Click the Line Settings button. Select the Legend check box. From the Line marker 
list, select Triangle. Click OK.

6 Click Apply to plot the first graph.

7 Still on the Point page, from the Predefined quantities list, select Concentration, c_Ba.

8 Click the Line Settings button. From the Line color list, select Color, and from the Line 

marker list, select Square. Click OK.

9 Click Apply to generate the second graph.

10 On the Point page, go to the Predefined quantities list and select Concentration, c_Sa.

11 Click the Line Settings button. From the Line color list select Color. Click the Color 
button, select green from the palette, and click OK.

12 From the Line marker list, select Circle, then click OK.

13 Click OK to add the third graph to the plot.

14 Click the Edit Plot button in the Figure window.

15 Locate the list on the left of the Edit Plot dialog box, then select Axes.

16 Go to the Title edit field and type Adsorbed species.

17 Go to the y label edit field and enter Concentration.

18 Return to the list on the left of the Edit Plot dialog box, and this time select the first 
Line entry.

19 Go to the Legends edit field, enter c_Aa, then select the Show legend check box.

20 In the list to the left in the Edit Plot dialog box select the second Line entry.

21 Go to the Legends edit field, enter c_Ba, then select the Show legend check box.

22 Return once more to the list in the left in the Edit Plot dialog box, then select the 
third Line entry.

23 In the Legends edit field enter c_Sa, then select the Show legend check box.

24 Click OK.
R  4 :  M O D E L  L I B R A R Y



Neu t r a l i z a t i o n  o f  Ch l o r i n e  i n  a  
S c r ubb e r

Introduction

This example studies the kinetics of the neutralization of chlorine gas in water solution. 
It is of particular interest to investigate whether a simple two-reaction mechanism 
adequately describes the system, or whether a further two reactions are also required.

Such a study could well be useful for sizing a chlorine scrubber. This includes choosing 
the size and shape of the packing within the scrubber as well as the flow rates for the 
species to be cleaned and the scrubber fluid. 

In this first study, assume that the fluid volume is perfectly mixed. This means that the 
chlorine has dissolved to an almost saturated state (1·10−2 mol/m3) and that the 
hydroxide has also mixed well throughout, as would be the case for a very small 
amount of fluid in a scrubber. Starting from this assumption, you can investigate the 
time-scale of the reactions, the amount of hydroxide required to neutralize the 
chlorine, and the likely concentrations of the resulting products. A further criterion is 
that the final solution is slightly alkaline.

Model Definition

The model includes two different reaction schemes, and its solution provides an 
estimate of how much hydroxide should be used to neutralize the chlorine in a 
perfectly-mixed solution. This first instance only considers the reaction where the 
hydroxide ion neutralizes the chlorine:

 (4-155)

In this case, also consider the equilibrium reaction of the hydroxide ion with the 
hydrogen ion and water:

 (4-156)

Cl2 OH-+ HClO Cl-+k
f

kr

H2O H+ + OH-
Keq
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In a second case, you investigate the situation where the produced hypochlorous acid 
species can dissociate by reacting with the hydroxide ion:

 (4-157)

Chlorine can also react directly with water to produce a hypochlorous acid and chloric 
acid:

 (4-158)

Traditionally, when setting up the reaction terms and mass balances of a reaction 
scheme, you use a full description of the mass action law. This includes reaction rate 
constants for both the forward and reverse reactions in the reaction term and 
subsequent mass balances. In the present example, you can assume that the forward 
and reverse reaction rate constants for Equation 4-156 and Equation 4-157 are not 
available, and that you have to use equilibrium constants instead. This is easily achieved 
using the Reaction Engineering Lab.

You find the thermodynamic and kinetic data for the system in Ref. 1 and Ref. 2. For 
convenience, they are reproduced in Table 4-3 below.

Eight species result from the reactions in Equation 4-155 through Equation 4-158, of 
which two—H2O and HCl—are assumed to have initial concentrations equal to unity. 
These conditions can easily be set in the Reaction Engineering Lab. The only other 
non-vanishing initial concentration is that for chlorine in water, which is set to the 
value of 1·10−2 mol/m3. Yet, it is always useful to avoid zero concentrations 
throughout a specified reaction model, because they often show up in the participating 
equations, such as in those describing equilibrium. Therefore, some arbitrary trace 
concentrations are entered for the other species.

TABLE 4-3:  KINETIC PARAMETERS FOR THE NEUTRALIZATION REACTIONS

REACTION  kf
  kr

  Keq
 

Equation 4-155 1.565·106 3.485·10-5

Equation 4-156 1·108

Equation 4-157 2.79·103

Equation 4-158 16.48 3.7·10-10

ClO-HClO + OH- H2O+
Keq

Cl2 H2O+ ClO- Cl-+ 2H++
k

f

k
r
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Results

C A S E  1

Figure 4-74 shows the concentration profile after 30 ms where only chlorine’s reaction 
with hydroxide and the water dissociation reaction are considered.

Figure 4-74: Dissolved chlorine (aq), hydrogen ion, and hydroxide ion concentration in a 
log scale versus logarithmic time graph. Only chlorine’s reaction with hydroxide and the 
water dissociation reaction are considered.

Initially, the chlorine quickly decays through the ready abundance of hydroxide ions. 
It continues to be reduced at a slower pace through the reaction with hydroxide ions 
that are, in turn, being produced through the water dissociation reaction. The initial 
concentration of the hydroxide ions is sufficiently large to guarantee an alkaline final 
solution.

A basic conclusion that can be drawn from this figure, is that a contact time of at least 
30 ms is required to reduce the chlorine concentration to levels below 10−6 mol/m3. 
This is quite a short time in comparison with the kinetics associated with the 
absorption and transport of chlorine into water.
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C A S E  2

Figure 4-75 shows the case where all four reactions are considered. It is apparent that 
the final solution is acidic, and that not enough of the chlorine is reduced.

Figure 4-75: Dissolved chlorine (aq), hydrogen ion, and hydroxide ion concentration in a 
log scale versus logarithmic time graph. All reaction mechanism steps are considered.

Figure 4-76 shows the case where all four reactions are considered and the hydroxide 
concentration has been adjusted.

Figure 4-76: Dissolved chlorine (aq), hydrogen ion, and hydroxide ion concentration in a 
log scale versus time graph. All reaction mechanism steps are considered and the hydroxide 
concentration has been adjusted.

An interesting result from Figure 4-76 is that the chlorine concentration is an order of 
magnitude greater than in Figure 4-74. In this case, a contact time larger than 30 ms 
may be required to reduce the concentration to 10−6 mol/m3.
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An overall conclusion is that the consideration of the two extra reactions in the 
mechanism is important, because these reactions decelerate the overall kinetics. This 
holds irrespective of the fact that one of the extra reactions, the one displayed in 
Equation 4-158, also leads to the decay of chlorine.
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Model Library path: Process_Chemistry/chlorine_scrubber

Modeling Using COMSOL Reaction Engineering Lab

1 Start the Reaction Engineering Lab.

2 Click New in the Model Navigator.

3 In the main user interface window, click the Reaction Settings button.

R E A C T I O N S  I N T E R F A C E

1 Create four entries in the Reaction selection list by clicking the New button four 
times.

2 Enter the following reaction formulas by first selecting the appropriate row in the 
Reaction selection list and then typing the corresponding text in the Formula edit 
field.

REACTION ID # REACTION FORMULA

1 Cl2+OH<=>HClO+Cl

2 H+OH=H2O

3 HClO+OH=ClO+H2O

4 Cl2+H2O<=>ClO+HCl
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3 Enter the following forward rate constants, reverse rate constants, and equilibrium 
constants by first selecting the appropriate row in the Reaction selection list and then 
typing the data in the appropriate edit field.

S P E C I E S  I N T E R F A C E

1 Click the Species tab.

2 Verify that the Species selection list has the eight species expected from entering the 
reaction formulas above.

3 On the General page, enter the following initial concentrations in the c0 edit field by 
selecting, one by one, the appropriate entries in the Species selection list.

4 The concentrations of the species H2O and HCl affect the reaction kinetics but are 
constant during the reaction. Impose these conditions by selecting the respective 
species in the Species selection list and then selecting the Lock concentration/activity 
check box.

5 Click Close.

R E A C T I O N S  I N T E R F A C E — C A S E  1

1 From the Model menu, select Reaction Settings.

2 Click the Reactions tab.

REACTION ID #  kf
  kr

  Keq
0 

1 1.565e6 3.485e-5

2 1e8

3 2.79e3

4 16.48 3.7e-10

SPECIES NAME  c0 

Cl2 1e-2

OH 1e-2

HClO 1e-11

Cl 1e-11

H 1e-6

H2O 1

ClO 1e-11

HCl 1
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3 Deactivate the third and fourth reactions—the hypochlorous acid dissociation and 
chlorine reaction with water, respectively—by clearing the check boxes next to these 
reactions.

4 Click Close.

O P T I O N S  A N D  S E T T I N G S

The following steps describe how to change the default slave species selection from 
OH to H.

1 From the Model menu, select Model Settings.

2 On the Stoichiometry page, clear the check box for OH and select the check box for H.

3 Click Close.

C O M P U T I N G  T H E  S O L U T I O N — C A S E  1

1 Choose Simulation>Solver Parameters.

2 In the Time stepping area, find the Times edit field and type 1.

3 In the Relative tolerance edit field, type 1e-9.

4 In the Absolute tolerance edit field, type 1e-10.

5 Click OK.

6 Click the Solve Problem button (=) on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N — C A S E  1

1 Choose Postprocessing>Plot Parameters.

2 Click the << button to clear the Quantities to plot list.

3 Go to the Predefined quantities list and Ctrl-click to select the entries Cl2, OH, and H.

4 Click the > button to add the selected entries to the Quantities to plot list.

5 Click the Line Settings button.

6 From the Line color list, select Cycle.

7 From the Line marker list, select Cycle and then click OK.

8 Click OK.

9 Select the X log and Y log buttons on the Main toolbar to generate Figure 4-74.

R E A C T I O N S  I N T E R F A C E — C A S E  2

1 Choose Model>Reaction Settings.

2 Click the Reactions tab.
N E U T R A L I Z A T I O N  O F  C H L O R I N E  I N  A  S C R U B B E R  |  365



366 |  C H A P T E
3 Reactivate the third and fourth reactions by selecting the check boxes beside these 
reactions.

O P T I O N S  A N D  S E T T I N G S

When activating or deactivating reactions, the selection of slave species is automatically 
changed. Therefore we need to manually alter the selection such that H and HClO 
become slave species.

1 From the Model menu, select Model Settings.

2 On the Stoichiometry page, select the check boxes for HClO and H and ensure that 
the check boxes for all other species are cleared.

3 Click Close.

S P E C I E S  I N T E R F A C E — C A S E  2

1 Click the Species tab.

2 Select OH and type 1.2e-2 in the c0 edit field to change the initial concentration.

3 Click Close.

C O M P U T I N G  T H E  S O L U T I O N — C A S E  2

Click the Solve Problem button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N — C A S E  2

Click the X log and Y log buttons on the Main toolbar to create Figure 4-76.

To create Figure 4-75, simply change the hydroxide ion (OH) concentration back to its 
original value of 1e-2 and re-solve the model.
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Non - I s o t h e rma l  P l u g - F l ow Rea c t o r

Introduction

This model considers the thermal cracking of acetone, which is a key step in the 
production of acetic anhydride. The gas phase reaction takes place under 
non-isothermal conditions in a plug-flow reactor. As the cracking chemistry is 
endothermic, control over the temperature in the reactor is essential in order to achieve 
reasonable conversion. When the reactor is run under adiabatic conditions, the model 
shows how the conversion of acetone can be affected by mixing the reactant with inert. 
Furthermore, it is illustrated how to affect the conversion of acetone by means of a heat 
exchanger supplying energy to the system.

The example details the use of the predefined Plug-flow reactor type in the Reaction 
Engineering Lab and how to set up and solve models describing non-isothermal 
reactor conditions. You will learn how to model adiabatic reactor conditions as well as 
how to introduce heat exchange.

Model Definition

This model is related to an example found in Ref. 1. An essential step of in the 
gas-phase production of acetic anhydride is the cracking of acetone (A) into ketene (K) 
and methane (M):

 (4-159)

The rate of reaction is

 (4-160)

where the rate constant is given by the Arrhenius expression

 (4-161)

For the decomposition of acetone described above, the frequency factor is 
A1 = 8.2·1014 (1/s), and the activation energy is E1 = 284.5 (kJ/mol).

CH3COCH3 CH2CO CH4+

(A) (K) (M)

r1 k1cA=

k1 A1
E1

RgT
-----------–⎝ ⎠

⎛ ⎞exp=
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Chemical reaction takes place under non-isothermal conditions in a plug-flow reactor, 
illustrated schematically in Figure 4-77.

Figure 4-77: The Plug-flow reactor is a predefined reactor type in the Reaction 
Engineering Lab.

Species mass balances are described by:

 (4-162)

where Fi is the species molar flow rate (mol/s), V is the reactor volume (m3), and Ri 
is the species rate expression (mol/(m3·s)). Concentrations needed to evaluate rate 
expressions are found from:

 (4-163)

where v is the volumetric flow rate (m3/s). By default, the Reaction Engineering Lab 
treats gas phase reacting mixtures as being ideal. Under this assumption the volumetric 
flow rate is given by:

 (4-164)

where p is the pressure (Pa), Rg denotes the ideal gas constant (8.314 J/(mol·K)), and 
T is the temperature (K).

The reactor energy balance is given by:

 (4-165)

In Equation 4-165, Cp,i represents the species molar heat capacity (J/(mol·K)), ws is 
the shaft work per volume (J/(m3·s)). Q denotes the heat due to chemical reaction (J/
(m3·s)):

dFi

dV
--------- Ri=

ci
Fi

v
-----=

v p
RgT
-----------

Fi

Fi

i
∑
-------------=

Fi

i
∑ Cp i,

dT
dV
-------- ws Q Qext+ +=
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 (4-166)

where Hj is the heat produced by reaction j. The term Qext represents external heat 
added or removed from the reactor. The present model treats both adiabatic reactor 
conditions:

and the situation where the reactor is equipped with a heat exchanger jacket. In the 
latter case Qext is given by:

 (4-167)

where U is the overall heat transfer coefficient (J/(m2·s·K)), a is the effective heat 
transfer area per unit of reactor volume (1/m), and Tamb is the temperature of the heat 
exchanger medium (K). The Reaction Engineering Lab automatically sets up and 
solves Equation 4-162 and Equation 4-165 as the predefined Plug-flow reactor type is 
selected. As input to the balance equations you need to supply the chemical reaction 
formula, the Arrhenius parameters, the species thermodynamic properties, as well as 
the inlet molar feed of reactants.

Following the step-by-step instructions below, you will first model the cracking of 
acetone in an adiabatic plug-flow reactor. See how the acetone conversion varies with 
the ratio of reactant to inert in the inlet stream. In second model, add the effects of a 
heat exchanger jacket and observe how the added energy drives the reaction to 
completion.

Working with Thermodynamic Polynomials

Reaction Engineering Lab uses the following set of polynomials as default expressions 
describing species thermodynamic properties:

 (4-168)

 (4-169)

 (4-170)

Q Hjrj

j
∑–=

Qext 0=

Qext Ua Tamb T–( )=

Cp i, Rg a1 a2T a3T2 a4T3 a5T4
+ + + +( )=

hi Rg a1T
a2
2
------T2 a3

3
------T3 a4

4
------T4 a5

5
------T5 a6+ + + + +⎝ ⎠

⎛ ⎞=

si Rg a1 Tln a2T
a3
2
------T2 a4

3
------T3 a5

4
------T4 a7+ + + + +⎝ ⎠

⎛ ⎞=
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Here, Cp,i denotes the species’ heat capacity (J/(mol·K)), T the temperature (K), and 
Rg the ideal gas constant, 8.314 (J/(mol·K)). Further, hi is the species’ molar enthalpy 
(J/mol), and si represents its molar entropy (J/(mol·K)). A set of seven coefficients 
per species are taken as input for the polynomials above. The coefficients a1 through 
a5 relate to the species heat capacity, the coefficient a6 is associated with the species 
enthalpy of formation (at 0 K), and the coefficient a7 comes from the species entropy 
of formation (at 0 K).

The format outlined by Equation 4-168 through Equation 4-170 is referred to as 
CHEMKIN or NASA format (Ref. 2). This is a well established format, and database 
resources list the needed coefficients for different temperature intervals. Many web 
based data resources exist for CHEMKIN thermodynamic data and otherwise (Ref. 3). 
It is therefore often a straight forward task to assemble the thermodynamic data 
required and then import it into your reaction model.

C R E A T I N G  A  T H E R M O D Y N A M I C  D A T A  F I L E

CHEMKIN thermodynamic files typically contains blocks of data, one block for each 
species. Such a data block is illustrated in Figure 4-78 for gas phase acetone.

Figure 4-78: Thermodynamic data block on the CHEMKIN format.

The first line starts with the species label, given with a maximum of 18 characters, 
followed by a 6 character comment space. Then follows a listing of the type and 
number of atoms that constitute the species. The G comments that this is gas phase 
data. The line ends with listing of three temperatures, defining two temperature 
intervals. Lines 2 through 4 contain two sets of the polynomial coefficients, a1 
through a7. The first set of coefficients is valid for the upper temperature interval, and 
the second for the lower interval.
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A complete CHEMKIN thermodynamics file has the structure illustrated in 
Figure 4-79.

Figure 4-79: Thermodynamic data file on the CHEMKIN format.

The keyword thermo always starts the text file. The subsequent line lists three 
temperatures, defining two temperature intervals. These intervals are used if no 
intervals are provided in the species specific data. Then follows the species data blocks, 
in any order. The keyword end is the last entry in the file.

The data file reproduced in Figure 4-79 is used in the present model. It was 
constructed by creating a text-file with species data blocks from the Sandia National 
Labs Thermodynamics resource (Ref. 4).

U S I N G  S U B S E T S  O F  T H E R M O D Y N A M I C  C O E F F I C I E N T S

In some instances, not all coefficients a1 through a7 are available. Coefficients may also 
be on a format differing from the NASA or CHEMKIN style. Input parameters can 
still be put on the form of Equation 4-168 to Equation 4-170, as illustrated below.

For species A, K, M, and N2, Ref. 1 lists polynomials for the heat capacity on the form:

 (4-171)

Furthermore, the species enthalpies of formation at Tref = 298 K are provided:

SPECIES  a1'  a2'  a3'  h(298) 

A 26.63 0.183 -45.86e-6 -216.67e3

K 20.04 0.0945 -30.95e-6 -61.09e3

Cp i, a1' a2'T a3'T2
+ +=
N O N - I S O T H E R M A L  P L U G - F L O W  R E A C T O R  |  371



372 |  C H A P T E
The data in the table above can be correlated with the polynomials given by 
Equation 4-168 and Equation 4-169 by noting the relations:

 (4-172)

 (4-173)

Using Equation 4-172 and Equation 4-173, you find the coefficients to enter in the 
Reaction Engineering Lab GUI.

Read more about how to work with thermodynamic data in the section “Working with 
Predefined Expressions” on page 90.

Results

In a first model, the plug-flow reactor is run under adiabatic conditions. The reactor 
is fed with a total molar flow of 38.3 mol/s. The inlet stream consists of a mixture of 
reactant acetone and inert nitrogen, as specified by:

Figure 4-80 shows the reactor temperature as a function of the reactor volume for the 
mixing conditions, Afrac = 1, 0.5, 0.1, and 0.01. As the cracking of acetone is 

M 13.39 0.077 -18.71e-6 -71.84e3

N2 6.25 8.78e-3 -2.1e-8 0

SPECIES  a1  a2  a3  a6 

A 3.20 2.20e-2 -5.52e-6 -2.79e4

K 2.41 1.14e-2 -3.72e-6 -8.54e3

M 1.61 9.26e-3 -2.25e-6 -9.87e3

N2 0.752 1.06e-3 -2.53e-9 -2.71e2

SPECIES  a1'  a2'  a3'  h(298) 

an
an'

Rg
--------       = n 1 … 5, ,=

a6
h Tref( )

Rg
------------------- a1Tref

a2
2
------Tref

2 a3
3
------Tref

3
+ +⎝ ⎠

⎛ ⎞–=

FA 38.3Afrac=

FN2 38.3 1 Afrac–( )=
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endothermic, the reactor temperature decreases along the reactor length; the effect 
being more pronounced as the fraction acetone increases.

Figure 4-80: The reactor temperature (K) as a function of reactor volume (m3), plotted 
for a number of feed conditions.

Figure 4-81 shows the conversion of acetone for the different mixing conditions. 
Conversion increases although the concentration of acetone decreases, due to the 
temperature effects. When pure acetone (Afrac = 1) enters the reactor conversion is no 
more than 24% at the reactor oulet.

Figure 4-81: The conversion of acetone (%) as a function of reactor volume (m3), plotted 
for a number of feed conditions.
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Figure 4-82 shows the reaction rates as a function of reactor volume. Note that under 
the simulated conditions reaction rates decrease as conversion increases, thereby 
affecting the net production rate of ketene and methane.

Figure 4-82: The rate of the acetone cracking reaction (mol/(m3·s)) as a function of 
reactor volume (m3), plotted for a number of feed conditions.

Figure 4-83 shows the temperature profile of the plug-flow reactor (Afrac = 1) as a heat 
exchanger supplies energy to the reacting system. Initially the energy consumption of 
the cracking reaction is dominant, and the temperature in the system drops. As the 
reaction rate drops off, the heat exchanger starts to heat up the system. The heating 
rate decreases with the temperature difference between the heat exchanger medium 
and reacting fluid.

Figure 4-83: Temperature (K) as a function of volume (m3), for a reactor equipped with 
a heat exchanger jacket.
R  4 :  M O D E L  L I B R A R Y



Figure 4-84 shows the conversion of acetone along with the reaction rate (Afrac = 1). 
Comparing with Figure 4-81 and Figure 4-82, note how the heat exchanger allows for 
relatively high reaction rates while maintaining high conversion.

Figure 4-84: The conversion of acetone (%) and reaction rate (mol/(m3·s)) as a function 
of reactor volume (m3).
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Model Library path: Process_Chemistry/nonisothermal_plugflow

Modeling Using COMSOL Reaction Engineering Lab

M O D E L  N A V I G A T O R

1 Start the Reaction Engineering Lab.
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2 In the Model Navigator, click the New button to launch the main user interface.

O P T I O N S  A N D  S E T T I N G S

1 Click the Model Settings button on the Main toolbar.

2 Select Plug-flow from the Reactor type list.

3 Select the Calculate thermodynamic properties check box.

4 Select the Include energy balance check box.

5 On the General page, type 162e3 in the p edit field.

6 Click the Init page, and type 1035 in the T(V0) edit field.

7 Click Close.

Now, define a number of constants that will be used later.

1 Select the menu item Model>Constants, then enter the following data:

2 Click OK.

3 Select the menu item Model>Expressions, then enter the following data:

4 Click OK.

R E A C T I O N S  I N T E R F A C E

1 From the Model menu, select Reaction Settings.

2 Create a new entry in the Reaction selection list by clicking the New button.

3 Type A=>K+M in the Formula edit field.

4 Select the Use Arrhenius expressions check box.

5 Type 8.2e14 in the A edit field.

6 Type 284.5e3 in the E edit field. 

S P E C I E S  I N T E R F A C E

1 While still in the Reaction Settings dialog box, click the Species tab.

NAME EXPRESSION

Ua 16500

T_amb 1150

A_frac 1

NAME EXPRESSION

X_A (F0_A-F_A)/F0_A*100
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2 Verify that the Species selection list has the three species (A, K, and M).

3 Click the New button and type N2 in the Formula edit field. This adds the inert 
species N2 to the reacting flow.

4 Click the Feed Stream page.

Note that for a plug-flow reactor you need to specify the inlet molar flows (F0), in 
contrast to the batch reactor types, where you need to provide the initial species 
concentrations (c0).

5 Select species A from the Species selection list and enter 38.3*A_frac in the F0 edit 
field.

6 Select species N2 from the Species selection list and enter 38.3*(1-A_frac) in the 
F0 edit field. You will use the parameter A_frac to vary the mix of reactant and inert, 
for a constant molar flow at the inlet

7 Click Close.

I M P O R T  T H E R M O D Y N A M I C  D A T A

Proceed to import the thermodynamics data file.

1 Select File>Import>CHEMKIN Thermo Input File.

2 Browse to the file nonisothermal_plugflow_thermo.txt and click the Import 
button.

You can inspect the loaded data in the Reaction Settings dialog box. Go to the 
Species>Thermo page and click the Polynomial coefficients edit field. Here you will 
find the thermodynamic coefficients a1 through a7 for each species.

C O M P U T I N G  T H E  S O L U T I O N

1 Open the Simulation>Solver Parameters dialog box.

2 Type 3 in the Reactor volumes edit field.

3 Clear the Stop If Steady State is reached first check box.

4 Click OK.

5 Click the Solve Problem button (=) on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows the molar flows of the participating species as a function of the 
reactor volume. To create Figure 4-80, follow these steps:

1 Choose Postprocessing>Plot Parameters (or click the corresponding button on the 
Main toolbar).
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2 Click the << button to remove all entries from the Quantities to plot list.

3 Select Temperature from the Predefined quantities list and click the Add button, >.

4 Select New Figure in the Plot in list.

5 Select the Keep current plot check box.

6 Click Apply.

7 Select Model>Constants.

8 Change the A_frac entry to 0.5, then click Apply.

9 Click the = button on the Main toolbar.

10 Repeat Steps 8 and 9 for the A_frac values 0.1 and 0.01.

11 Click the Figure 1 window.

12 Click the Edit Plot button.

13 Select the first Line entry, type A_frac = 1 in the Legends edit field.

14 Select the second Line entry, type A_frac = 0.5 in the Legends edit field, and 
choose Triangle from the Line marker list.

15 Select the third Line entry, type A_frac = 0.1 in the Legends edit field, and choose 
Square from the Line marker list.

16 Select the fourth Line entry, type A_frac = 0.01 in the Legends edit field, and 
choose Plus sign from the Line marker list.

17 Click OK to close the Edit Plot dialog.

18 Click OK to close the Constants dialog.

Create Figure 4-81 and Figure 4-82 in the same fashion as just described, adding X_A 
and then Reaction rate 1 to the Quantities to plot list, found in the Plot Parameters 
dialog.

1 In the Plot Parameters dialog box, clear the Keep current plot check box.

2 Select Main axes from the Plot in list.

3 Click OK.

Move on to see how conversion is affected as a heat exchanger jacket supplies heat to 
the reacting mixture.

O P T I O N S  A N D  S E T T I N G S

1 Select the menu item Model>Model Settings.

2 Click the Energy Balance tab.
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3 Type Ua*(T_amb-T) in the Qext edit field.

4 Click Close.

5 Select the menu item Model>Constants.

6 Change the value A_frac entry to 1, then click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve Problem button (=) on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To create Figure 4-83, follow these steps:

1 Choose Postprocessing>Plot Parameters (or click the corresponding button on the 
Main toolbar).

2 Click the << button to remove all entries from the Quantities to plot list.

3 Select Temperature from the Predefined quantities list and click the Add button, >.

4 Click Apply.

To create Figure 4-84, follow steps below:

1 Click the << button to remove all entries from the Quantities to plot list.

2 Select X_A from the Predefined quantities list and click the Add button, >.

3 Select Reaction rate 1 from the Predefined quantities list and click the Add button, >.

4 Click OK.
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Po l yme r i z a t i o n  i n  a  S em i b a t c h  
R e a c t o r

Introduction

As reactant monomer converts into polymer chains, the density of the reacting mixture 
often changes notably. In this example you will look at how this effect impacts the total 
production of polymer in a process. The liquid phase polymerization takes place in a 
semibatch reactor, where two operating conditions are compared. In the first scenario, 
the feed of monomer to the reactor is turned off once the maximum volume capacity 
is reached. In a second scenario, the feed of monomer is allowed to continuously 
compensate for the volume change due to chemical reaction.

The model illustrates the use of the Semibatch reactor type, that is predefined in the 
Reaction Engineering Lab. It is also shown how to set timed events, in this case, 
controlling the reactant feed to the reactor.

Model Definition

This model reproduces results found in Ref. 1. A liquid phase polymerization can be 
modeled as a first order irreversible reaction:

 (4-174)

 (4-175)

In the above equations, M denotes the monomer, P the polymer, r is the reaction rate 
(mol/(m3 s)), k is the rate constant (1/s), and cM is the concentration of monomer 
(mol/m3).

The polymerization takes place in a semibatch reactor with a volume capacity of 20 m3. 
Initially the reactor is charged with 10 m3 of solvent. Pure monomer enters the reactor 
with a volumetric flow rate of vf = 1 m3/min.

k1
M P

r1 k1cM=
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Figure 4-85 shows a schematic representation of the semibatch reactor.

Figure 4-85: The Semibatch reactor is a predefined reactor type in the Reaction 
Engineering Lab.

The following mass balance describes the semibatch reactor:

 (4-176)

In Equation 4-176, ci is species molar concentration (mol/m3), cf,i is the species 
concentration (mol/m3) of the associated feed stream vf,i (m

3/s), and Ri denotes the 
species rate expression (mol/(m3·s)). Vr labels the reactor volume (m3) and is a 
function of time. For ideal mixtures:

 (4-177)

where vp is the volumetric production rate due to chemical reaction:

 (4-178)

In Equation 4-178, νij is the stoichiometric coefficient of species i in reaction j, Mi 
denotes the species molecular weight (kg/mol), ρi is the species density (kg/m3), and 
rj is the reaction rate (mol/(m3·s)) of reaction j.

Note that Reaction Engineering Lab automatically sets up and solves Equation 4-176 
and Equation 4-177 once the Semibatch reactor type has been selected.

In the present example, the density of the monomer is 800 kg/m3 and the density of 
the polymer 1100 kg/m3. Hence, as polymer is being formed, the volume of the 

d ciVr( )
dt

-------------------- vf i,  cf i, R+ iVr=

dVr
dt

---------- vf i,∑ vp+=

vp νij
Mi

ρi
-------rjVr

i
∑

j
∑=
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reacting mixture will decrease (vp is negative). The model investigates two operating 
conditions:

•  Operating Condition 1—The monomer feed (1 m3/min) is shut off once the 
reactor volume reaches 20 m3, which occurs after 11.2 minutes. The reaction is 
then allowed to go to completion.

•  Operating Condition 2—The monomer feed is adjusted to keep the reactor filled 
while the reaction goes to completion. This is accomplished by setting the 
volumetric feed equal to −vp, for t > 11.2 minutes.

Results

Figure 4-86 shows the reactor volume as function of the run time, illustrating the two 
operating conditions listed above.

Figure 4-86: The reactor volume (m3) as function of time (minutes) for operating 
condition 1 (solid line) and 2 (dash-dotted line).
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Figure 4-87 illustrates the volumetric flow rate of the feed stream, vf.

Figure 4-87: The volumetric flow rate of the feed stream (m3/s) as function of time 
(minutes) for operating condition 1 (solid line) and 2 (dash-dotted line).

Figure 4-88 shows the total mass of monomer in the reactor, mM (kg), as evaluated by 
the expression:

.

Figure 4-88: The total monomer mass in the reactor volume (kg) as function of time 
(minutes) for operating condition 1 (solid line) and 2 (dash-dotted line).

It is straight forward to compare the amount of produced polymer as a result of the 
different operating conditions. For both cases the reaction has run to completion after 

mM cMVrMM=
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approximately 3 hours. At this time, the total volume of the reacting mixture is 
18.1 m3 for operating condition 1 and 20 m3 for operating condition 2. The reactor 
was initially charged with 10 m3 of solvent. Hence, the total mass of polymer produced 
is:

The relative increase in polymer production using operating condition 2 compared to 
condition 1 is then:

Reference

1. J.B. Rawlings and J.G. Ekerdt, Chemical Reactor Analysis and Design 
Fundamentals, Nob Hill Publishing, 2004, example 4.3, pp. 139–144.

Model Library path: Process_Chemistry/semibatch_polymerization

Modeling Using COMSOL Reaction Engineering Lab

M O D E L  N A V I G A T O R

1 Start the Reaction Engineering Lab.

2 In the Model Navigator, click the New button to launch the main user interface.

O P T I O N S  A N D  S E T T I N G S

1 Click the Model Settings button on the Main toolbar.

2 Select Semibatch from the Reactor type list.

3 Select Liquid from the Reacting fluid list.

4 Click the Feed Streams tab.

5 Click the New button to create Inlet1.

6 Select Inlet1 from the Feed stream list, and type 1/60*(t<672) in the vf edit field.

In this first model, the feed stream is turned off after 672 seconds (11.2 minutes).

7 Go to the Init page, and type 10 in the Vr(t0) edit field.

mP Vr0 Vr–( )ρM=

mP 2, mP 1,–

mP 1,
--------------------------------- 10 8.1–

8.1
--------------------- 23%= =
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8 Click Close.

R E A C T I O N S  I N T E R F A C E

1 From the Model menu, select Reaction Settings.

2 Create a new entry in the Reaction selection list by clicking the New button.

3 Type M=>P in the Formula edit field.

4 Type 1/600 in the kf edit field.

S P E C I E S  I N T E R F A C E

1 While still in the Reaction Settings dialog box, click the Species tab.

2 Select the indicated entry in the Species selection list and enter the following 
properties:

There is no initial concentration of neither M nor P in the reactor volume, so the c0 
edit field retains its default value of zero for both species.

3 Click the Feed Stream page.

4 Select species M from the Species selection list select Inlet1 from the Name list.

5 Type rho_M/M_M in the cf edit field.

As P does not enter the reactor through an inlet, there is no need to associate a feed 
stream with this species.

6 Click Close.

C O M P U T I N G  T H E  S O L U T I O N

1 Open the Simulation>Solver Parameters dialog box.

2 Type 3000 in the Times edit field.

3 Clear the Stop if steady-state is reached first check box.

4 Click OK.

5 Click the Solve Problem button (=) on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows the molar concentrations of the participating species as a 
function of time (s). To create Figure 4-86, follow these steps:

SPECIES NAME  M  ρ 

M 0.1 800

P 0.1 1100
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1 Choose Postprocessing>Plot Parameters (or click the corresponding button on the 
Main toolbar).

2 Click the << button to remove all entries from the Quantities to plot list.

3 Type Vr in the Expression edit field and click the Add button >, to move the 
expression to the Quantities to plot list.

4 Go to the x-axis data area, select the Expression radio button, and click the Expression 
button.

5 Type t/60 in the Expression edit field and then click OK. This way you scale the time 
axis to show minutes rather than seconds.

6 Select New Figure in the Plot in list.

7 Select the Keep current plot check box.

8 Click Apply.

Now, run the model once again, with the volumetric flow of the feed stream adjusted 
so that the entire reactor volume is put to use. To accomplish this, compensate for the 
volume loss due to chemical reaction, as illustrated below.

9 Click the Model Settings button on the Main toolbar.

10 Go to the Feed Streams page.

11 Select Inlet1 from the Feed stream list, and type 1/60*(t<672)-vp*(t>=672) in the 
vf edit field.

Now the feed stream continuously fills the reactor. Up to 672 s (11.2 min) the 
reactor is filled with the volumetric feed rate of 1/60 (m3/s), where after the feed 
is adjusted to exactly compensate for the volume loss due to chemical reaction, that 
is vp (m3/s). As the volume decreases with reaction, vp is negative.

12 Click Close.

13 Press the = button on the Main toolbar.

14 Click the Figure 1 window.

15 Click the Edit Plot button.

16 Select the first Line entry, type case 1 in the Legends edit field.

17 Select the second Line entry, type case 2 in the Legends edit field, and choose 
Dash-dot line from the Line style list.

18 Select Axes in the list to the left.

19 Clear the y limits Auto check box and type 0 and 22 in the first and second edit field.

20 Type time (min) in the x label edit field.
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21 Type volume (m^3) in the y label edit field.

22 Click OK to close the Edit Plot dialog.

23 Click OK to close the Constants dialog.

Create Figure 4-87 and Figure 4-88 in the same fashion as just described, adding 
vf_Inlet1*60 and then the expression c_M*M_M*Vr to the Quantities to plot list, 
found in the Plot Parameters dialog.
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S t a r t up  o f  a  C S TR

Introduction

The hydrolysis of propylene oxide into propylene glycol is an important chemical 
process with 400,000 metric tons produced worldwide each year. Propylene glycol 
finds wide application as a moisturizer in foods, pharmaceuticals, and cosmetics.

In this example you model the startup phase of a continuous stirred tank reactor 
(CSTR) used to produce propylene glycol. The non-isothermal process is described by 
a set of coupled mass and energy balances that you easily set up and solve in the 
Reaction Engineering Lab. The model highlights the use of the predefined CSTR 
reactor type and also shows how to enter the thermodynamic data needed for energy 
balances.

Model Description

This model reproduces the results found in Ref. 1. Propylene glycol (PrOH) is 
produced from the reaction of propylene oxide (PrO) with water (W) in the presence 
of an acid catalyst:

 (4-179)

The reaction rate (mol/(m3·s)) is first order with respect to propylene oxide:

 (4-180)

where the rate constant is temperature dependent according to the expression

 (4-181)

The Arrhenius parameters in Equation 4-181 are A1 = 4.71·109 (1/s) and E1 = 75358  
(J/mol).

H2O+O H2SO4 OHHO

r1 k1cPrO–=

k1 A1
E1

RgT
------------–⎝ ⎠

⎛ ⎞exp=
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The liquid phase reaction takes place in a continuous stirred tank reactor (CSTR) 
equipped with a heat-exchanger. Methanol (MeOH) is added to the mixture but does 
not react. It is further assumed that the mixture density is constant over time.

Figure 4-89: A perfectly mixed CSTR for the production of propylene glycol. The CSTR is 
a predefined reactor type in the Reaction Engineering Lab.

The time evolution of the non-isothermal reacting system is given by several coupled 
balance equations.

The species mass balances are

 (4-182)

In Equation 4-182, ci is the species molar concentration (mol/m3), Vr denotes the 
reactor volume (m3), Ri is the species rate expression (mol/(m3·s)), and v is the 
volumetric flow rate (m3/s).

For an incompressible and ideally mixed reacting liquid, the energy balance is

 (4-183)

where Cp,i is the species molar heat capacity (J/(mol·K)), and T is the temperature 
(K). On the right-hand side, Q represents the heat due to chemical reaction (J/s), and 
Qext denotes heat added to the system (J/s), for instance by a heat exchanger. The last 
term signifies heat added as species flow through the reactor. In this term, hi is the 
species molar enthalpy (J/mol).

This example assumes that the species heat capacities, Cp,i, represent an average over 
the temperature interval. The associated species’ enthalpies are then given by

 (4-184)

where hi(Tref) is the standard heat of formation at the reference temperature Tref.

d ciVr( )
dt

-------------------- vf i,  cf i, vci RiVr+–=

Vr ciCp i,
dT
dt
--------

i
∑ Q Q+ ext vf i,  cf i, hf i, hi–( )

i
∑+=

hi Cp i, T Tref–( ) hi Tref( )+=
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The heat of reaction is given by

 (4-185)

where Hj is the enthalpy of reaction (J/mol), and rj denotes the reaction rate  
(mol/(m3·s)).

The heat added by the heat exchanger is given by

 (4-186)

where F is the molar flow rate (mol/s), U is the overall heat transfer coefficient  
(J/(K·m2·s)), and A represents the heat exchange area (m2). The subscript x refers to 
the heat exchanger medium, which in this case is water. Tx is the inlet temperature of 
the heat exchanger medium.

The following table summarizes additional parameters describing the reactor setup and 
process conditions:

PARAMETER VALUE DESCRIPTION

Vr 1.89 m3 Reactor volume

vf 3.47·10-3 m3/s Volumetric flow rate

cf,PrO 2903 mol/m3 Concentration of PrO in feed stream

cf,W 36291 mol/m3 Concentration of W in feed stream

cf,MeOH 3629 mol/m3 Concentration of MeOH in feed stream

c0,W 55273 mol/m3 Initial concentration of W in the reactor

Cp,PrO 146.5 J/(mol·K) Heat capacity of PrO

Cp,W 75.4 J/(mol·K) Heat capacity of W

Cp,PrOH 192.6 J/(mol·K) Heat capacity of PrOH

Cp,MeOH 81.6 J/(mol·K) Heat capacity of MeOH

Cpx 75.4 J/(mol·K) Heat capacity of heat exchanger medium

href,PrO -153.5·103 J/mol Enthalpy of formation of PrO at Tref

href,W -286.1·103 J/mol Enthalpy of formation of W at Tref

href,PrOH -525.6·103 J/mol Enthalpy of formation of PrOH at Tref

href,MeOH -238.6 J/mol Enthalpy of formation of MeOH at Tref

Tf 297 K Feed stream temperature

Q Vr Hjrj

j
∑–=

Qext FxCp x, Tx T–( ) 1 UA
FxCp x,
------------------⎝ ⎠
⎛ ⎞exp–⋅=
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The model described here is readily set up and solved using the predefined CSTR 
reactor type in the Reaction Engineering Lab.

Results

Figure 4-90 shows the concentration of PrO (mol/m3) and the reactor temperature 
(K) as a function of reaction time.

Figure 4-90: Concentrations of reactant PrO (mol/m3) after 4 hours of operation (left) 
and reactor temperature (K) after 4 hours of operation (right).

Initially both the reactant concentration and the temperature oscillate around their 
respective steady-state values (491 mol/m3 and 336 K, respectively). The same result 

T0 297 K Initial reactor temperature

Tref 293 K Reference temperature

Tx 289 K Temperature of heat exchanger medium at inlet

Fx 126 mol/s Heat exchanger medium molar flow

UA 8441 J/(s·K) Heat exchange parameter

PARAMETER VALUE DESCRIPTION
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can be illustrated by a trajectory in the concentration-temperature phase plane as 
presented in Figure 4-91.

Figure 4-91: Trajectory in the concentration-temperature phase plane.

The model predicts that the reactor temperature passes a maximum value higher than 
the steady-state temperature. From a safety perspective it is therefore relevant to look 
closer at possible sets of initial conditions to see if process operation limits are violated. 
In the process modeled here, it is undesirable to exceed a reactor temperature of 355 K 
so as to avoid undesirable side reactions and not damage reactor equipment. 
Figure 4-92 shows the concentration-temperature phase plane for three initial 
conditions; (cPrO = 0, T0 = 297), (cPrO = 0, T0 = 340), and (cPrO = 1400, T0 = 340).

Figure 4-92: Trajectories in the concentration-temperature phase plane for three initial 
conditions.

Safety limit
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The plot shows that all investigated initial conditions converge to the same steady state. 
However, starting with cPrO = 1400 (mol/m3) and T0 = 340 K leads to violation of 
the temperature safety limits.

Reference

1. H. S. Fogler, Elements of Chemical Reaction Engineering 3rd Ed., Prentice Hall 
PTR, 1999, Example 9-4, pp. 553–559.

Model Library path: Process_Chemistry/cstr_startup

Modeling Using the COMSOL Reaction Engineering Lab

M O D E L  N A V I G A T O R

1 Start the COMSOL Reaction Engineering Lab by double-clicking its desktop icon.

2 In the Model Navigator click the New button.

O P T I O N S  A N D  S E T T I N G S

1 Click the Model Settings button on the Main toolbar.

2 Select CSTR (constant volume) from the Reactor type list.

3 Select Liquid from the Reacting Fluid list.

4 Select the Calculate thermodynamic properties check box.

5 Select the Include energy balance check box.

6 Go to the Feed Streams page.

7 Click the New button to create a reactor inlet.

8 Click Close.

Next define the constants and expressions needed later:

1 From the Model menu select Constants.
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2 Type in the entries in the table below.

Alternatively, click the Import Variables From File button in the Constants dialog box, 
browse to the file cstr_startup_const.txt on your computer and click Open.

3 Click OK.

4 From the Model menu select Expressions.

5 Type in the entries in the table below.

Alternatively, click the Import Variables From File button in the Expressions dialog 
box, browse to the file cstr_startup_expr.txt on your computer and click Open.

6 Click OK.

PARAMETER VALUE DESCRIPTION

cp_pro 146.5 Heat capacity [J/(mol*K)]

cp_w 75.4 Heat capacity [J/(mol*K)]

cp_proh 192.6 Heat capacity [J/(mol*K)]

cp_meoh 81.6 Heat capacity [J/(mol*K)]

cp_x 75.4 Heat capacity [J/(mol*K)]

href_pro -153.5e3 Enthalphy of formation [J/mol]

href_w -286.1e3 Enthalphy of formation [J/mol]

href_proh -525.6e3 Enthalphy of formation [J/mol]

href_meoh -238.6 Enthalphy of formation [J/mol]

Tref 293 Reference temperature [K]

Tf 297 Temperature of feed stream [K]

Tx 289 Temperature of heat exchanger medium [K]

Fx 126 Heat exchanger medium molar flow [mol/s]

UA 8441 Heat exchange parameter [J/(s*K)]

PARAMETER VALUE DESCRIPTION

h_pro cp_pro*(T-Tref)+href_pro Enthalpy [J/mol]

h_w cp_w*(T-Tref)+href_w Enthalpy [J/mol]

h_proh cp_proh*(T-Tref)+href_proh Enthalpy [J/mol]

h_meoh cp_meoh*(T-Tref)+href_meoh Enthalpy [J/mol]

hf_pro cp_pro*(Tf-Tref)+href_pro Feed enthalpy [J/mol]

hf_w cp_w*(Tf-Tref)+href_w Feed enthalpy [J/mol]

hf_meoh cp_meoh*(Tf-Tref)+href_meoh Feed enthalpy [J/mol]

Q_xch Fx*cp_x*(Tx-T)*(1-exp(-UA/
(Fx*cp_x)))

Heat exchange [J/s]
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R E A C T I O N S  I N T E R F A C E

1 Click the Reaction Settings button on the Main toolbar.

2 Create a new entry in the Reaction selection list by clicking the New button.

3 Type PrO+W=>PrOH in the Formula edit field.

4 Select the Use Arrhenius expressions check box.

5 Type 4.71e9 in the A edit field.

6 Type 75358 in the E edit field.

7 Type kf_1*c_PrO in the r edit field.

S P E C I E S  I N T E R F A C E

1 While still in the Reaction Settings dialog box click the Species tab.

2 Verify that the Species selection list has the three species (PrO, W, and PrOH).

3 Click the New button and type MeOH in the Formula edit field. This adds the 
unreactive methanol species to the reacting mixture.

4 Select species W from the Species selection list and enter 55273 in the c0 edit field.

(Initially water is the only species present in the reactor).

At this point you associate each species with a feed stream. You also specify the 
associated molar concentrations and enthalpies.

5 Click the Feed Stream tab.

6 Select species PrO from the Species selection list, then select Inlet1 from the Name list. 
Type 2903 in the cf edit field and type hf_pro in the hf edit field.

7 Select species W from the Species selection list, then select Inlet1 from the Name list. 
Type 36291 in the cf edit field and type hf_w in the hf edit field.

8 Select species MeOH from the Species selection list, then select Inlet1 from the Name 
list. Type 3629 in the cf edit field and type hf_meoh in the hf edit field.

Now enter thermodynamic properties for species in the reactor.

9 Click the Thermo page.

10 Select species PrO from the Species selection list. Type cp_pro in the Cp edit field and 
type h_pro in the h edit field.

11 Select species W from the Species selection list. Type cp_w in the Cp edit field and type 
h_w in the h edit field.

12 Select species PrOH from the Species selection list. Type cp_proh in the Cp edit field 
and type h_proh in the h edit field.
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13 Select species MeOH from the Species selection list. Type cp_meoh in the Cp edit field 
and type h_meoh in the h edit field.

Note that you are making use of the variables you loaded previously into the 
Constants and Expression dialog boxes.

14 Click Close.

M O D E L  S E T T I N G S

Now return to the Model Settings dialog box and specify a few reactor-specific 
parameters.

1 Click the Model Settings button on the Main toolbar.

2 Go to the Mass Balance page.

3 Type 1.89 in the Vr edit field and type 0 in the vp edit field.

The Volumetric production rate edit field contains a predefined expression that 
accounts for any volume change due to chemical reaction. In this example you 
assume that the density of the reacting mixture is constant and thus set the value to 
zero.

4 Go to the Energy Balance page.

5 Type Q_xch in the Qext edit field.

This sets the external heat source term equal to the expression in the Expressions 
dialog box.

6 Go to the Feed Streams page.

7 Select Inlet1 from the list to the left.

8 Type 3.47e-3 in the vf edit field and type Tf in the Tf edit field.

9 Go to the Init page.

10 Type 297 in the T(t0) edit field.

11 Click Close.

C O M P U T I N G  T H E  S O L U T I O N

1 Open the Simulation>Solver Parameters dialog box.

2 Type 4*3600 in the Times edit field.

3 Clear the Stop if steady state is reached first check box.

4 Click OK.

5 Click the Solve Problem button (=) on the Main toolbar.
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PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows the concentrations of all participating species as a function of 
time. To create the figures that appeared in the Results section follow these steps:

1 Choose Postprocessing>Plot Parameters (or click the corresponding button on the 
Main toolbar).

2 Click the << button to remove all entries from the Quantities to plot list.

3 Select PrO from the Predefined quantities list and click the Add Selected Predefined 

Quantities button, >.

4 Select New Figure from the Plot in list.

5 Click Apply to create the left panel of Figure 4-90.

6 Click the << button to remove all entries from the Quantities to plot list.

7 Select Temperature from the Predefined quantities list and click the Add Selected 

Predefined Quantities button, >.

8 Select New Figure from the Plot in list.

9 Click Apply to create the right panel of Figure 4-90.

10 Click the << button to remove all entries from the Quantities to plot list.

11 Select PrO from the Predefined quantities list and click the Add Selected Predefined 

Quantities button, >.

12 Select the Expression option button in the x-axis data area and click the Expression 
button.

13 Select Temperature from the Predefined quantities list and click OK.

14 Select New Figure from the Plot in list.

15 Select Keep current plot and click OK to create Figure 4-91.

Now change the initial conditions, re-solve the model, and plot the results.

1 Click the Model Settings button on the Main toolbar.

2 Go to the Init page.

3 Type 340 in the T(t0) edit field.

4 Click Close.

5 Click the Solve Problem button on the Main toolbar.

Note how the new results are plotted in the Figure 3 window on top of the previous 
results.

6 Click the Reaction Settings button on the Main toolbar.
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7 Go to the Species>General page.

8 Select species PrO from the Species selection list and enter 1400 in the c0 edit field.

9 Click Close.

10 Click the Solve Problem button on the Main toolbar.

The plot in the Figure 3 window now represents Figure 4-92 in the Results section of 
this model.
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F l u i d  C a t a l y t i c  C r a c k i n g

Introduction

This example illustrates the fluid catalytic cracking (FCC) of a flashed distillate 
feedstock occurring in plug-flow reactor. The simulations consider how coking affects 
the catalytic activity and selectivity in the process.

The model shows you how to set up a reaction kinetic network in the Reaction 
Engineering Lab. As you type in the chemical reaction formulas in the graphical user 
interface, the software automatically generates the corresponding rate expressions. In 
a first simulation you can directly make use of the automatically generated kinetics to 
model the FCC process in an ideal reactor system. In a second simulation, you can 
extend the kinetic model to include the effects of catalyst coking.

Model Description

The complex chemistry involved in FCC is often reduced to kinetic models where 
reactants and products are lumped together in different hydrocarbon groups. A 
five-lump model for the catalytic cracking of a hydrotreated flash distillate has been 
proposed in the literature (Ref. 1):

All 8 reactions follow first order kinetics:

 (4-187)

k3
k4

k5

k1

k2

HCO
heavy crude oil

Gas

LCO
light cycle oil

Coke

Gasoline
k6

k7 k8

rj kjci= j 1 … 8, ,=
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A first model looks at the cracking reactions, neglecting coking (reactions 7 and 8). 
The reactor model is an ideal plug-flow reactor running at constant temperature 
(798 K), described by the following mass balance:

 (4-188)

where Fi is the species molar flow rate, V the reactor volume, νij is the stoichiometric 
coefficient, and rj the reaction rate.

Assuming constant reactor cross section and flow velocity, the species concentration 
gradient as function of residence time (τ) is given by:

 (4-189)

K I N E T I C S  D I S R E G A R D I N G  C O K I N G

Neglecting the coke producing reactions 7 and 8, the detailed mass balances with 
respect to the lumped species become:

 (4-190)

 (4-191)

 (4-192)

 (4-193)

The Reaction Engineering Lab automatically sets up Equation 4-190 through 
Equation 4-193 as you type in the chemical reaction formulas into the graphical user 
interface.

K I N E T I C S  I N C L U D I N G  C O K I N G

In a second simulation you will include coking reactions into the kinetic model, which 
affect both selectivity as well as activity. The overall activity of the system is dominated 
by two different time scales. Coke formation occurs on the millisecond scale, while the 

dFi

dV
--------- νijrj

j
∑ Ri= =

dFi

dV
---------

d vci( )
dV

----------------
dci

dτ
-------- Ri= = =

dchco
dτ

-------------- r1– r2– r3–=

dclco
dτ

------------ r1 r4– r5–=

dcgasoline
dτ

---------------------- r2 r5 r6–+=

dcgas
dτ

------------- r3 r4 r6+ +=
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formation of other products takes place in seconds. To account for these different time 
scales, two different activity functions are used.

For the non-coking reactions (reactions 1 through 6) the activity function is given by:

 (4-194)

where kd is a deactivation constant and CC the coke content of the catalyst. The 
reaction rates are modified by the activity according to:

 (4-195)

For the coking reactions (reactions 7 and 8), the activity function is:

 (4-196)

where α is a deactivation constant depending on the residence time. The reaction rates 
become:

 (4-197)

The reactor mass balances are:

 (4-198)

 (4-199)

 (4-200)

 (4-201)

 (4-202)

You can readily include the effect of catalyst deactivation by modifying the 
automatically generated kinetics in the Reaction Engineering Lab.

a e kdcC–
=

rj akjci= j 1 … 6, ,=

b e ατ–
=

rj bkjci= j 7 8,=

dchco
dτ

-------------- r1– r2– r3– r7–=

dclco
dτ

------------ r1 r4– r5– r8–=

dcgasoline
dτ

---------------------- r2 r5 r6–+=

dcgas
dτ

------------- r3 r4 r6+ +=

dccoke
dτ

---------------- r7 r8+=
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Results

Figure 4-93 shows the concentrations of the lumped components as functions of the 
residence time. The upper graph illustrates the results when the coking reactions are 
ignored, while the lower results include the effect of coking.

Figure 4-93: Concentrations of lumped species as function of the reactor residence time. 
Results are displayed for models where coking is ignored (solid lines), and where coking is 
taken into account (dashed lines).

The results show a clear influence of coking on the product distribution, in this case 
favoring gasoline production relative to the fraction of gas.
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Figure 4-94 shows the concentration of coke along with the activity functions for 
non-coking reactions (Equation 4-194), and coking reactions (Equation 4-196).

Figure 4-94: Concentration profile of coke, as well as activity functions for non-coking 
reactions (a), and coking reactions (b).

The activity function, b, limits the effect of the coking reactions to relatively short 
residence times. Once the deposition of carbon has stopped, the activity for the 
non-coking reactions remains constant at ~0.85.

Reference

1. M. A. den Hollander, M. Wissink, M. Makkee, J. A. Moulijn, J. Appl. Catal. A, 
vol. 223, p. 103, 2003.

Model Library path: Process_Chemistry/catalytic_cracking

Modeling Using the COMSOL Reaction Engineering Lab

M O D E L  N A V I G A T O R

1 Start the COMSOL Reaction Engineering Lab by double-clicking its desktop icon.

2 In the Model Navigator click the New button.
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R E A C T I O N S  I N T E R F A C E

1 From the Model menu select Reaction Settings.

2 Create six entries in the Reaction selection list by clicking the New button.

3 Enter the reaction formulas as shown in the following table by first selecting the 
appropriate row in the Reaction selection list and then entering the text in the 
corresponding Formula edit field.

4 Enter the following values for the Forward rate constant by first selecting the 
appropriate row in the Reaction selection list and then entering the corresponding 
number in the kf edit field:

S P E C I E S  I N T E R F A C E

1 While still in the Reaction Settings dialog box, click the Species tab.

2 Verify that the Species selection list contains four species (hco, lco, gasoline, and gas).

3 On the General page, enter the following initial concentrations in the c0 edit field 
after selecting the appropriate entry in the Species selection list:

REACTION ID # REACTION FORMULA

1 hco=>lco

2 hco=>gasoline

3 hco=>gas

4 lco=>gas

5 lco=>gasoline

6 gasoline=>gas

REACTION ID # kf 

1 1.9

2 7.5

3 1.5

4 0

5 1

6 0.3

SPECIES NAME c0 

hco 0.81

lco 0.19
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4 Click Close.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 Enter 5 in the Times edit field. The units here are in seconds.

3 Click OK.

4 Click the Solve Problem button (=) on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows the time variation of the concentration of all species. Now, 
include the coking reactions in the existing kinetics.

R E A C T I O N S  I N T E R F A C E

1 Click the Reaction Settings button on the Main toolbar.

2 Go to the Reactions page.

3 Create two new entries in the Reaction selection list by clicking the New button twice.

4 Enter the reaction formulas as shown in the following table:

5 Enter the following values for the Forward rate constant by first selecting the 
appropriate row in the Reaction selection list and then entering the corresponding 
number in the kf edit field:

Up until this point, all kinetic expressions for the reaction rates have been 
automatically generated by the software. Now, you will modify the existing 
expressions to include the activity functions, Equation 4-194 and Equation 4-196.

gasoline 0

gas 0

REACTION ID # REACTION FORMULA

7 hco=>coke

8 lco=>coke

REACTION ID # kf 

7 0.21

8 0.5

SPECIES NAME c0 
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6 Modify the existing reaction rate expressions according to the following table by first 
selecting the appropriate row in the Reaction selection list and then entering the text 
in the corresponding Reaction rate edit field.

In practice you are multiplying the first six reactions with the variable a, and the last 
two reactions by the variable b.

7 Click Close.

O P T I O N S  A N D  S E T T I N G S

Now, define the activity functions corresponding to the variables a (Equation 4-194), 
and b (Equation 4-196).

1 From the Model menu select Expressions.

2 Enter the following parameter names and values in the Expressions dialog box:

3 Click OK.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Click the Plot Parameters button on the Main toolbar.

2 From the Plot in list, select New Figure.

3 Select the Keep current plot check box

REACTION ID # REACTION RATE

1 kf_1*c_hco*a

2 kf_2*c_hco*a

3 kf_3*c_hco*a

4 kf_4*c_lco*a

5 kf_5*c_lco*a

6 kf_6*c_gasoline*a

7 kf_7*c_hco*b

8 kf_8*c_lco*b

NAME EXPRESSION DESCRIPTION

a exp(-kd*c_coke) activity function for 
non-coking reactions

b exp(-alfa*t) activity function for 
coking reactions

kd 8.2 deactivation constant

alfa 10 deactivation constant
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4 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solve Problem button (=) on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Return to plotting in the main user interface and visualize the results of the coking and 
its effect on catalytic activity.

1 Select the menu item Postprocessing>Plot Parameters.

2 From the Plot in list, select Main axes.

3 Clear the Keep current plot check box.

4 Remove all entries in the Quantities to plot list by pressing the << button.

5 Select coke in the Predefined quantities list and press the > button.

6 Type a in the Expressions edit field and press the > button.

7 Type b in the Expressions edit field and press the > button.

8 Click OK.
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C a r b on Depo s i t i o n  i n  He t e r o g en eou s  
C a t a l y s i s

Introduction

Carbon deposition onto the surface of solid catalysts is commonly observed in 
hydrocarbon processing. Carbon deposits can affect both the activity of catalysts as 
well as the flow of gas through a catalyst bed.

This example investigates the thermal decomposition of methane into hydrogen and 
solid carbon. In the first model you look at the isothermal process occurring in an ideal 
reactor, simulated in the Reaction Engineering Lab. The influence of carbon 
deposition on catalyst activity is also considered. In the second model, you study the 
effect that the carbon deposits have on the fluid flow. The second simulation takes 
place in COMSOL Multiphysics taking both time and space dependencies into 
account.

Model Definition

C H E M I S T R Y

Methane decomposes over a Ni/Al2O3 catalyst according to the overall chemical 
reaction:

 (4-203)

The following reaction rate expression has been reported in the literature (Ref. 1).

 (4-204)

where

 (4-205)

C +CH4 2H2

r k
pCH4

pH2
2

Kp
----------–

1 kH pH2+( )
2

----------------------------------------⋅=

k 20.492 104200
RgT

--------------------–⎝ ⎠
⎛ ⎞exp=
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 (4-206)

and

 (4-207)

I D E A L  R E A C T O R  M O D E L

The first model is set up in Reaction Engineering Lab. This treats the isothermal 
decomposition of methane (Equation 4-203) in a perfectly mixed reactor with 
constant volume. The species mass balances are summarized by:

 (4-208)

The rate term, Ri, takes into account the reaction stoichiometry, νi, the reaction rate, 
r, and the catalyst activity, a:

 (4-209)

The mass balances of the reacting species are then:

 (4-210)

 (4-211)

 (4-212)

The time dependency of the catalytic activity is expressed by the ODE:

 (4-213)

where

 (4-214)

kH
163200

RgT
-------------------- 22.426–⎝ ⎠
⎛ ⎞exp=

Kp 5.088 105 91200
RgT

----------------–⎝ ⎠
⎛ ⎞exp⋅ ⋅=

dci

dt
-------- Ri=

Ri νira=

dcCH4
dt

----------------- ra–=

dcC
dt

---------- ra=

dcH2
dt

------------- 2ra=

da
dt
------- kar2cCa–=

ka
135600

RgT
-------------------- 32.007–⎝ ⎠
⎛ ⎞exp=
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Solving the mass balances provides the evolution of the species concentrations over 
time. The fact that carbon is in the solid phase is taken into account by removing its 
effect on gas phase physical properties. The pressure in the reactor is a function of only 
the methane and hydrogen concentrations:

 (4-215)

S P A C E -  A N D  T I M E - D E P E N D E N T  M O D E L

The second model is solved in COMSOL Multiphysics and takes both fluid flow and 
the chemical reaction into account.

The flow reactor is set up in 2D, as illustrated below:

Figure 4-95: A flow reactor is set up in 2D. Methane enters from the left and reacts in the 
porous catalytic bed in the mid-section of the geometry.

Methane first flows through a free section of the reactor, and then encounters a porous 
catalytic bed where the decomposition reaction takes place.

Momentum Balances
The flow in the free channel section is described by the Navier-Stokes equations:

 (4-216)

p RgT cCH4 cH2+( )=

Inlet outlet

wall

wall

porous catalytic bed

ρ∂u
∂t
------- ∇+ η– ∇u ∇u( )T

+( ) pI+[ ]⋅ ρ u ∇⋅( )u–=

∇ u⋅ 0=
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where ρ denotes density (kg/m3), u represents the velocity (m/s), η denotes viscosity 
(kg/(m· s)), and p equals pressure (Pa). In the porous domain, the Brinkman 
equations govern the flow:

 (4-217)

where εp is the porosity and k denotes permeability (m2) of the porous media. As you 
can see in Equation 4-216 and Equation 4-217, the momentum-balance equations are 
closely related. The term on the right-hand side of the Navier-Stokes formulation 
corresponds to momentum transported by convection in free flow. In the Brinkman 
formulation, this term is replaced by a contribution associated with the drag force 
experienced by the fluid as it flows through a porous medium. COMSOL Multiphysics 
automatically combines free and porous-media flow to solve the equations 
simultaneously.

The boundary conditions for the flow are:

 (4-218)

Mass transport in the reactor is described by the diffusion-convection equations:

 (4-219)

where Di denotes the diffusion coefficient (m2/s) and ci is the species concentration. 
The term Ri corresponds to the species’ net reaction rates.

In the free channel, the inlet conditions are equal to the inlet concentrations

 (4-220)

At the outlet, you use the convective flux condition

 (4-221)

All other boundaries use the insulating or symmetry condition

 (4-222)

ρ
εp
-----∂u

∂t
------- ∇+

η
εp
-----– ∇u ∇u( )T

+( ) pI+⋅ η
k
---u–=

∇ u⋅ 0=

u n⋅ u0=

u 0      =

p 0      =

inlet
walls

 outlet

∂ci

∂t
------- ∇ Di∇– ci ciu+( )⋅+ Ri=

c cin=

n D∇– c( )⋅ 0=

n D∇– c cu+( )⋅ 0=
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Balance for Void Fraction
The void fraction of the catalytic bed decreases as carbon is deposited. This in turn 
affects the flow through the reactor. A balance for the void fraction, or porosity, of the 
bed is given by:

 (4-223)

This equation can be implemented in the PDE, General Form application mode of 
COMSOL Multiphysics, resulting in porosity distribution across the catalytic bed as a 
function of time. The initial porosity of the bed is assumed to be ε = 0.4.

The porosity is related to the permeability of the porous domain by the expression 
(Ref. 2):

 (4-224)

In this way, the porosity balance couples the mass and momentum balances describing 
the reacting system.

Results 

I D E A L  R E A C T O R  M O D E L

The upper graph of Figure 4-96 shows the concentration transients of methane, 
hydrogen and deposited carbon, as methane decomposes over a Ni/Al2O3 catalyst.

dε
dt
------ εr

Mcρsoot
---------------------–=

k k0
ε
ε0
-----⎝ ⎠
⎛ ⎞ 3.55

=
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The lower graph is a plot of the reactor pressure. Deactivation of the catalyst is not 
taken into account at this point.

Figure 4-96: Upper graph: concentration transients of methane decomposition over a Ni/
Al2O3 catalyst. Lower graph: reactor pressure. Deactivation of the catalyst is not 
considered.

Taking catalyst deactivation into account (Equation 4-213) produces the results 
shown in Figure 4-97. Under the simulated conditions a moderate drop in activity is 
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noted (upper graph), leading to a largely unaffected overall process, as can be seen by 
comparing with the concentration transients of the previous model (lower graph).

Figure 4-97: Upper graph: catalyst activity drops off as carbon deposits at the catalyst 
surface. Lower graph: concentration transients of methane, hydrogen and deposited 
carbon with no deactivation present (solid lines) and with deactivation taken into 
account (dashed lines).

S P A C E -  A N D  T I M E - D E P E N D E N T  M O D E L

The following results concern a space- and time-dependent model simulated in 
COMSOL Multiphysics. Methane decomposition occurs in a porous region where 
solid catalyst particles are packed. Figure 4-98 shows the velocity field across the 
reactor prior to carbon deposition. The 2D plot shows that the velocity profile is 
parabolic in the free channel sections and close to constant in the porous domain. The 
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line plot in the bottom graph in Figure 4-98 shows the velocity along the reactor 
centerline.

Figure 4-98: Upper graph: velocity flow field in the 2D reactor domain. Lower graph: the 
gas velocity plotted along the reactor centerline.
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Reactions take place in the packed catalytic bed located in the mid section of the 
reactor. Figure 4-99 shows the concentration profiles along the centerline of the bed.

Figure 4-99: Methane and hydrogen concentrations as a function of the bed position.

The methane and hydrogen concentrations are equal after passing approximately 
0.18 m into the bed. Figure 4-98 shows that the velocity in the bed is near 
0.67·10−3 m/s, equaling a residence time of 270 s. This result agrees with the findings 
from the ideal reactor simulation, shown in Figure 4-96. 

Now, consider the effects as methane is constantly supplied to the reactor for 
1000 seconds. The initial permeability is a constant 1·10−9 m2 across the bed. Note 
how the permeability at the front end of the bed changes by four orders of magnitude 
during the first 1000 s of carbon deposition.

Figure 4-100: Permeability of the packed catalytic bed as the decomposition of methane 
proceeds for 1000 s. The time interval between each line is 100 s.
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As carbon deposits in the reacting bed, the pressure distribution across the reactor is 
affected. Figure 4-101 shows a small, linear pressure drop as unreacting gas passes 
through a clean catalyst bed.

Figure 4-101: Distribution of pressure as an unreacting gas passes a clean catalyst 
bed.Upper graph: pressure distribution across the 2D reactor domain. Lower graph: 
pressure drop along the packed catalyst bed.
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Figure 4-102 shows the pressure distribution across the reactor after methane 
decomposition has occurred for 1000 s. The pressure drop is notably greater and 
occurs across the first 10 cm of the bed.

Figure 4-102: Distribution of pressure when methane decomposition has been allowed to 
occur for 1000 s. Upper graph: pressure distribution across the 2D reactor domain. Lower 
graph: pressure drop along the packed catalyst bed.
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The following path shows the location of the Reaction Engineering Lab model:

Model Library path: Process_Chemistry/carbon_deposition

The following path shows the location of the COMSOL Multiphysics model:

Model Library path: Reaction_Engineering_Lab/Process_Chemistry/
carbon_deposition

Modeling Using the COMSOL Reaction Engineering Lab

M O D E L  N A V I G A T O R

1 Start COMSOL Reaction Engineering Lab.

2 Click New in the Model Navigator window.

R E A C T I O N S  I N T E R F A C E

1 Click the Reaction Settings button on the Main toolbar.

2 Make sure the Reactions page is active. Create a new entry in the Reaction selection 
list by clicking the New button.

3 Type CH4=>C+2H2 in the Formula edit field.

4 Modify the predefined reaction rate according to Equation 4-204 by typing the 
following in the r edit field: c_a*k*(p_CH4-p_H2^2/Kp)/(1+kh*sqrt(p_H2))^2.

You will define the parameters and constants for the rate expression later on.

S P E C I E S  I N T E R F A C E

1 Click the Species tab.

2 Create a new entry in the Species selection list by clicking the New button.
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3 Type a in the Formula edit field.

When a new species is created a mass balance equation is set up along with it, in this 
case:

The left hand side is defined internally in the software and the right hand side 
corresponds to the expression given in the R edit field.

Note also that you can remove the effect of catalyst activity from your model by 
selecting the Lock concentration/activity check box. This removes the species mass 
balance and sets the concentration of the species to the value entered in the Initial 

concentration edit field.

4 Proceed to define the equation for the catalyst activity (Equation 4-213) by 
selecting species a from the Species selection list and typing -ka*r_1^2*c_C*c_a in 
the R edit field.

5 Select the appropriate entry from the Species selection list and then enter the 
corresponding value for the Initial concentration:

6 Click Close.

O P T I O N S  A N D  S E T T I N G S

1 Click the Model Settings button on the Main toolbar.

2 On the General page type 950 in the Temperature edit field.

3 In the p edit field, modify the predefined expression for the pressure to: 
Rg*T*(c_CH4+c_H2).

The predefined expression for the pressure in the reactor is:

You remove the contributions from the carbon species and the activity parameter, as 
they do not contribute to the gas phase pressure.

4 Click Close.

5 Select the menu item Model>Expressions.

SPECIES NAME c0

CH4 50

a 1

dca

dt
--------- Ra=

p RgT ci∑=
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6 Enter the following expressions by typing them in. Alternatively, click the Import 

Variables From File button and browse to the file: 
carbon_deposition_expressions.txt:

7 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 Type 1000 in the Times edit field.

3 Click OK.

4 Compute the solution by clicking the Solve Problem button on the Main toolbar.

E X P O R T  S E T T I N G S

You will now export the reaction model from Reaction Engineering Lab to COMSOL 
Multiphysics, and see how the chemistry of methane decomposition behaves in a time 
and space dependent system. The COMSOL Multiphysics model assumes that the 
catalyst activity is constant. The deposition of carbon, however, affects reactor 
performance because the deposits affect the permeability of the porous section of the 
reactor.

1 Click the Reaction Settings button on the Main toolbar.

2 Go to the Species page.

3 Select the a from the Species selection list and select the Lock concentration/activity 
check box.

The activity is assumed to be constant and equal to one. 

NAME EXPRESSION DESCRIPTION

k 2.31e-5*exp(20.492-104200/
Rg/T)

Arrhenius expression

Kp 5.088e5*exp(-91200/Rg/T) Arrhenius expression

kh exp(163200/Rg/T-22.426) Arrhenius expression

ka 43240*exp(135600/Rg/
T-32.077)

Arrhenius expression

p_CH4 c_CH4*Rg*T/100000 CH4 pressure (bar)

p_H2 c_H2*Rg*T/100000+eps H2 pressure (bar)
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4 Select the species C from the Species selection list and then select the Lock 

concentration/activity check box.

The purpose of this setting is to avoid the automatic set up of a mass balance 
equation for the species C in COMSOL Multiphysics. The effect of the carbon 
deposition rate will be taken into account by a balance equation for the reactor bed 
void fraction (Equation 4-223), that will be set up after the export.

5 Click Close.

6 Click the Export to COMSOL Multiphysics button on the Main toolbar.

7 Select 2D from the Space dimension list and click OK.

8 The Export to COMSOL Multiphysics dialog box appears.

9 Go to the Export mass balance area, and in the Application mode list select Convection 

and Diffusion: New.

10 In the Group name edit field type reactions.

11 Move to the Export energy balance area and clear the check box in the upper left 
corner.

12 Move to the Export momentum balance area and clear the check box in the upper left 
corner.

13 Click the Export button at the bottom of the dialog box.

Modeling Using COMSOL Multiphysics

Click the COMSOL Multiphysics window.

M O D E L  N A V I G A T O R

1 Select the menu item Multiphyiscs>Model Navigator.

2 In the Application Modes tree, select Chemical Engineering Module>Momentum 

Transport>Laminar Flow>Incompressible Navier-Stokes.

3 Click the Add button.

4 In the Application Modes tree, select COMSOL Multiphysics>PDE Modes>PDE, General 

Form.

5 Type por in the Dependent variables edit field, then click the Add button.

6 Click the OK button.

G E O M E T R Y  M O D E L I N G

1 Press the Shift key and click the Rectangle/Square button.
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2 Type the following values in the corresponding edit fields for the rectangle 
dimensions.

3 Click OK.

4 Press the Shift key again and click the Rectangle/Square button.

5 Type the following values in the corresponding edit fields for the rectangle 
dimensions

6 Click OK.

7 Click the Zoom Extents button on the Main toolbar.

P H Y S I C S  S E T T I N G S

Subdomain Settings—Navier-Stokes Application Mode
1 Select Incompressible Navier-Stokes (chns) from the Multiphysics menu.

2 Select Subdomain Settings from the Physics menu.

3 Select all subdomains by pressing Ctrl+A and clicking the Subdomain selection list.

4 Type 1 in the Density edit field.

5 Type 1e-5 in the Dynamic viscosity edit field.

6 Select Subdomain 2 (the porous media subdomain) from the Subdomain selection 
list.

7 Select the Flow in porous media (Brinkman equations) check box.

8 Type por in the Porosity edit field.

9 Type kappa in the Permeability edit field.

10 Click OK.

Boundary Conditions—Navier-Stokes Application Mode
1 Select Boundary Settings from the Physics menu.

SIZE POSITION

Width 1 x 0

Height 0.1 y 0

SIZE POSITION

Width 0.4 x 0.4

Height 0.1 y 0
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2 Enter the boundary settings according to the following table:

3 Click OK.

Subdomain Settings—Convection and Diffusion
1 From the Multiphysics menu select Convection and Diffusion (chcd).

2 From the Physics menu select Subdomain Settings.

3 From the Subdomain selection list, select Subdomain 2.

4 Select reactions from the Group list.

Note how the Reaction rate edit fields are automatically filled in as a result of 
exporting the group reactions from the Reaction Engineering Lab.

5 Select all subdomains by pressing Ctrl+A and clicking the Subdomain selection list.

6 On page c_CH4 type u in the x-velocity edit field and v in the y-velocity edit field.

7 Go to page c_H2 and type u in the x-velocity edit field and v in the y-velocity edit 
field.

8 Click Apply.

9 Click the Init page and type 50 in the c_CH4(t0) edit field.

10 Click Apply.

11 Type expressions into the Diffusion coefficient edit field according to the following 
table:

12 Click OK.

Boundary Conditions—Convection and Diffusion
1 From the Physics menu select Boundary Settings.

SETTINGS BOUNDARY 1 BOUNDARY 5,6 BOUNDARY 10 ALL OTHERS

Boundary 
type

Inlet Wall Outlet Wall

Boundary 
condition

Laminar inflow Slip Pressure No slip

U0 u_in

p0 0

SUBDOMAIN PAGE / C_CH4 PAGE / C_H2

1 D_CH4 D_H2

2 k_eff*D_CH4 k_eff*D_H2

3 D_CH4 D_H2
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2 Enter the boundary conditions for the species c_CH4 and c_H2 according to the 
following table:

3 Click OK.

Subdomain Settings—PDE, General Form
1 From the Multiphysics menu select PDE, General Form (g).

2 From the Physics menu select Subdomain Settings.

3 Select 1 and 3 in the Subdomain selection list and clear the Active in this domain check 
box.

4 Select 2 in the Subdomain selection list.

5 Type 0 in the two Flux vector edit fields.

6 Type -por*r_1_rxn_chcd/M_C/rho_soot in the Source term edit field.

The above settings have reduced the general form PDE

to the form of the void fraction balance (Equation 4-223)

7 Go to the Init page.

8 Type por0 in the por(t0) edit field.

9 Click OK.

Boundary Conditions—PDE, General Form
1 From the Physics menu select Boundary Settings.

2 Select Boundaries 4, 5, 6 and 7 and select the Neumann boundary condition option 
button.

3 Click OK.

SETTINGS BOUNDARY 1 BOUNDARY 10 ALL OTHER

Boundary condition Concentration Convective flux Insulation/Symmetry

c_CH40 cCH4_in

c_H20 cH2_in

ea
∂2ϕ

∂t2
--------- da

∂ϕ
∂t
------ ∇ Γ⋅+ + F=

da
∂ϕ
∂t
------ F εr

Mcρsoot
---------------------–= =
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O P T I O N S  A N D  S E T T I N G S

1 From the Options menu select Constants.

2 Enter the following parameter names and values in the Constants dialog box, either 
by typing them in, or by clicking the Import Variables From File button and browsing 
to the file: carbon_deposition_constants.txt, followed by clicking Open.

3 Click OK.

4 From the Options menu select Expressions>Scalar Expressions.

5 Enter the following parameter names and expressions, then click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu choose Free Mesh Parameters.

2 Click the Boundary tab.

3 Select the appropriate entries in the Boundary selection list and enter the following 
mesh settings:

4 Click the Remesh button and then the OK button.

NAME EXPRESSION DESCRIPTION

u_in 0.667e-3 average inlet velocity

cCH4_in 50 inlet concentration

cH2_in 0 inlet concentration

kappa0 1e-9 permeability of clean 
catalyst

por0 0.4 porosity of clean 
catalyst bed

rho_soot 4e3 density of soot deposits

M_C 12.011e-3 molar weight of carbon

D_CH4 1e-6 diffusion coefficient

D_H2 4e-6 diffusion coefficient

k_eff 0.1 effectiveness factor

NAME EXPRESSION DESCRIPTION

kappa kappa0*(por/por0)^3.55 permeability

BOUNDARY MAXIMUM ELEMENT SIZE

2-9 5e-3
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C O M P U T I N G  T H E  S O L U T I O N

Start by computing a flow field where chemical reactions are disregarded. This is to 
have a good starting guess for the flow when solving the coupled problem.

1 From the Solve menu select Solver Parameters.

2 Select Stationary from the Solver list.

3 Click OK.

4 From the Solve menu select Solver Manager.

5 On the Solve For page, select Incompressible Navier-Stokes (chns) in the Solve for 

variables tree.

6 Click the OK button.

7 Click the Solve button on the Main toolbar.

The following steps produce a plot of the flow field:

1 From the Postprocessing menu open the Plot Parameters dialog box.

2 Go to the Surface page.

3 Select Incompressible Navier-Stokes (chns)>Velocity field from the Predefined 

quantities list.

4 Go to the Arrow page and select the Arrow plot check box.

5 Select Incompressible Navier-Stokes (chns)>Velocity field from the Predefined 

quantities list.

6 Click OK.

Proceed to solve the time-dependent problem, which takes the chemical reactions and 
carbon deposition into account.

1 From the Solve menu select Solver Parameters.

2 Select Time dependent from the Solver list.

3 Type 0:100:1000 in the Times edit field.

4 Click OK.

5 From the Solve menu select Solver Manager.

6 On the Initial Value page click the Store Solution button.

7 Click the Stored solution option button in the Values of variables not solved for and 

linearization point area.
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8 Return to the Solve For page and select Convection and Diffusion (chcd) and PDE, 

General Form (g) from the Solve for variables tree, by pressing Ctrl and clicking the 
entries.

9 Click OK.

10 Click the Solve button on the Main toolbar.

Plot gas phase concentrations of methane and hydrogen in the reactive bed:

1 From the Postprocessing menu open the Cross-Section Plot Parameters dialog box.

2 On the General page, select 1000 from the Solutions to use list.

3 Select the Keep current plot check box.

4 Go to the Line/Extrusion page.

5 Select Convection and Diffusion (chcd)>Concentration, c_CH4 from the Predefined 

quantities list.

6 Enter the following parameters in the Cross-section line data area:

7 Click Apply.

8 Select Convection and Diffusion (chcd)>Concentration, c_H2 from the Predefined 

quantities list.

9 Click OK.

In the last simulation of this example, look at how the flow is affected by the deposition 
of soot in the porous bed.

1 From the Solve menu select Solver Manager.

2 On the Initial Value page click the Store Solution button.

3 In the Store Solution window, click OK to store all solutions.

4 Click the Stored solution option button in the Values of variables not solved for and 

linearization point area.

5 Select All from the Solution at time list.

EDIT FIELD VALUE

x0 0.4

y0 0.05

x1 0.8

y1 0.05
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6 On to the Solve For page, select Incompressible Navier-Stokes (chns) in the Solve for 

variables tree.

7 Click OK.

8 Click the Solve button on the Main toolbar.

To plot the permeability in the porous bed as a function of time follow these steps:

1 From the Postprocessing menu open the Cross-Section Plot Parameters dialog box.

2 On the General page, press Ctrl+A and click the Solutions to use list.

3 Select New figure from the Plot in list.

4 Go to the Line/Extrusion page.

5 Type kappa in the Expression edit field.

6 Click OK.

7 In the Figure window, click the y log button.

Finally, plot the reactor pressure after 1000 seconds.

1 From the Postprocessing menu open the Plot Parameters dialog box.

2 Go to the General page and select 1000 from the Solutions at time list.

3 Clear the Arrow check box.

4 Go to the Surface page.

5 Select Incompressible Navier-Stokes (chns)>Pressure from the Predefined quantities 

list.

6 Click OK.
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K i n e t i c s  o f  Pe n t a e r y t h r i t o l  
P r odu c t i o n

Introduction

Pentaerythritol is an important intermediate for the production of plastics, surface 
coatings, paints, dyes, and explosives. In the commercial process, pentaerythritol is 
produced in an aqueous alkaline medium of formaldehyde and acetaldehyde. 
Methanol is formed as a byproduct.

A kinetic model of a reacting system, made up of ordinary differential equations, is 
calibrated by finding the unknown reaction rate constants. In the present example, you 
fit concentration vs. time data of reacting species to a kinetic model in order to estimate 
the kinetic parameters.

Begin by reading the data from a text file into COMSOL Script. Based on a suggested 
kinetic model, evaluate rate constants and Arrhenius parameters. Then go on to 
simulate the kinetic model in the Reaction Engineering Lab, using the rate parameters 
as input. Finally, verify the kinetic model by comparing the simulation results with the 
experimental data, that you read into the Reaction Engineering Lab.

Reaction Kinetics

Pentaerythritol is produced through the reaction of formaldehyde and acetaldehyde 
with sodium hydroxide. In the batch process, the reaction temperature is typically 300 
to 330 K. The product is recovered from the reaction mixture by crystallization.

Initial reactions involve rapid aldol condensations, where formaldehyde and 
acetaldehyde react in the presence of base, forming pentaerythritol:

 (4-225)

Subsequent reactions are of the Cannizarro type, in which two aldehyde molecules 
yield an organic acid and alcohol molecules. In the product forming step, 
pentaerythrose reacts with formaldehyde and base, giving pentaerythritol:

HCHO 3CH3CHO+
[OH-]

(HOCH2)3CCHO .
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 (4-226)

Two aldehyde molecules can also react with the base and form methanol as a 
byproduct.

 (4-227)

As mentioned, the condensation reactions summarized by Equation 4-225 are 
comparatively fast. Consequently, by carrying out the condensation steps at low 
temperature, it is possible to convert acetaldehyde to pentaerythrose before any 
significant amount of pentaerythritol is formed. When the temperature in the reactor 
is raised, only the Cannizarro reactions occur. Running a batch process in this two-step 
fashion makes it possible to conveniently evaluate the kinetic parameters in 
Equation 4-226 and Equation 4-124 (Ref. 1).

Mass Balances

Assume the Cannizarro reactions to be of third order. Labeling HCHO as A, OH- as 
B, and (HOCH2)3CCHO as C, results in the following material balances for a 
perfectly mixed batch reactor:

 (4-228)

 (4-229)

.  (4-230)

Written in matrix form, these equations become

(HOCH2)3CCHOHCHO + OH- +
k1 (HOCH2)4C HCOO-+ .

2HCHO + OH- k2 CH3OH HCOO-+ .

td

dcA k1cAcBcC– 2k2cA
2 cB–=

td

dcB k1cAcBcC– k2cA
2 cB–=

td

dcC k1cAcBcC–=
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 (4-231)

or, equivalently,

.  (4-232)

Evaluating Reaction Rate Parameters From Experimental Data

The following data have been measured for this reaction system at 304 K:

TABLE 4-4:  EXPERIMENTAL DATA AT 304 K

TIME (S) cA (mol/m3) cB (mol/m3) cC (mol/m3)

0 1540.20 932.00 301.80

50 1500.52 885.90 262.56

100 1454.46 856.11 232.28

150 1435.87 823.53 189.67

200 1402.37 807.21 177.64

250 1388.56 780.11 163.72

300 1368.05 771.26 152.73

350 1351.39 755.53 131.69

400 1340.76 729.96 115.52

450 1329.92 725.18 107.12

500 1314.32 711.83 112.64

550 1307.30 699.81 85.03

600 1287.82 697.17 73.89

650 1281.29 688.55 52.76

700 1282.37 678.31 60.78

750 1268.57 683.52 60.67

800 1263.14 672.27 65.68

850 1244.59 661.77 44.20

900 1245.99 661.19 44.68

td

dcA

td

dcB

td

dcC

cAcBcC– 2cA
2 cB–

cAcBcC– cA
2 cB–

cAcBcC– 0

k1

k2

=

D Mk=
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In this model you use a derivative approach to solve numerically for the rate constants 
(solve Equation 4-232). In brief, the time derivatives, D, of the concentrations are 
determined with finite difference approximations from the experimental data in the 
table above. Then k is solved for with a least-squares fitting procedure.

To evaluate the elements of D, the three-point differentiation formulas given by 
Equation 4-233 to Equation 4-235 are used. In this example, ∆t is constant and equal 
to 50 s. For each collected data-point, the formulas provide a numerical approximation 
to the derivatives of concentration with respect to time. For instance, for species A with 
concentration data recorded at constant intervals ∆t from t = 0 to t = m, the derivative 
at the initial time is

 (4-233)

and at interior times

 (4-234)

and at the end time

.  (4-235)

The matrix elements of M are also calculated from the experimental data. Finally, the 
rate constant vector, k, is solved for using the COMSOL Script function \ 
(mldivide):

.  (4-236)

The mldivide command performs the matrix operation M−1 M k = M−1 D. The rate 
constants k1 and k2 are the least-square solution to the overdetermined equation 
system.

950 1243.86 657.30 36.69

1000 1247.35 650.46 29.81

TABLE 4-4:  EXPERIMENTAL DATA AT 304 K

TIME (S) cA (mol/m3) cB (mol/m3) cC (mol/m3)

td

dcA
⎝ ⎠
⎛ ⎞

t 0=

3cA 0( )– 4cA 1( ) cA 2( )–+

2∆t
---------------------------------------------------------------=

td

dcA
⎝ ⎠
⎛ ⎞

t j=

cA j 1+( ) cA j 1–( )–

2∆t
--------------------------------------------=

td

dcA
⎝ ⎠
⎛ ⎞

t m=

3cA m 2–( ) 4cA m 1–( )– cA m( )+

2∆t
-----------------------------------------------------------------------------=

k M\D=
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Determining Arrhenius Parameters

Using the procedure described above, you estimate the rate constants k1 and k2 at a 
given constant temperature. However, the values of the rate constants are dependent 
on the temperature, according to the Arrhenius law:

.  (4-237)

In Equation 4-237, A represents the frequency factor, E the activation energy (J/
mol), Rg the ideal gas constant (J/(mol K)), and T the temperature (K). With access 
to experimental data at several temperatures the Arrhenius parameters, A and E can be 
determined. 

First, for each temperature the previous procedure is applied and the rate constants are 
determined. Secondly, a plot of ln  k vs. 1/T should yield a straight line, given by

 (4-238)

where the slope of the plotted line equals −E/Rg and the intercept equals ln A. Thus, 
the wanted parameters are determined by line fitting.

Experiments conducted at four different temperatures have been evaluated producing 
the following results for the rate constants k1 and k2:

TABLE 4-5:  DETERMINED VALUES FOR RATE CONSTANTS

 T (K)  k1 (m
6/(mol2 ·s))  k2 (m

6/(mol2 ·s)) 

273 2.7·10-11 7.5·10-14

297 7.8·10-10 2.2·10-12

304 2.1·10-9 5.7·10-12

314 6.5·10-9 1.8·10-11

ki Ai
Ei–

RgT
-----------⎝ ⎠
⎛ ⎞exp=

kln Aln E
RgT
-----------–=
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Results

Figure 4-103 and Figure 4-104 show the concentrations of the reactants A and B as 
function of time. Solid lines represent the simulated results, and symbols represent the 
experimental data.

Figure 4-103: Concentration (mol/m3) as a function of time (s) of the reactant A. The 
solid line represents simulated results while symbols represent experimental data.

Figure 4-104: Concentration (mol/m3) as a function of time (s) of the reactant B. The 
solid line represents simulated results while symbols represent experimental data.
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Figure 4-105 shows the concentration profiles of the reactant C and also of the main 
product P (pentaerythritol) and byproduct Q (methanol).

Figure 4-105: Concentration profiles (mol/m3) as functions of time (s) of the reactant C 
and the products P and Q. Solid lines represent simulated results while symbols represent 
experimental data.

The good agreement between simulated and experimental results allows you to 
confirm the proposed third order kinetics of the reactions, and to determine the rate 
constants k1 to 2.1·10−9 (m6/(mol2·s)) and k2 to 5.7·10−12 (m6/(mol2·s)), at 304 K.
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Figure 4-106 shows linear fits to experimental data, relating the rate constants k1 
(squares) and k2 (circles) to temperature.

Figure 4-106: Arrhenius plots (ln k vs. 1/T) to determine the temperature dependence of 
the rate constants. Solid lines represent fits to the data given by the symbols—squares for k1 
and circles for k2.

With reference to Equation 4-238, you readily evaluate the activation energies; 
E1 = 95.6 (kJ/mol) and E2 = 97.4 (kJ/mol), as well as frequency factors 
A1 = 5.364·107 (m6/(mol2·s)) and A2 = 7.133·105 (m6/(mol2·s)).

Reference

1. M.S. Peters and C.R. Cupit, Chemical Engineering Science., vol. 10, p. 57, 1959.

Model Library path: Process_Chemistry/erythritol_kinetics

Modeling Using COMSOL Script

In COMSOL Script, you can estimate kinetic parameters from experimental data. You 
first evaluate the rate constants k1 and k2 by solving Equation 4-231, using data 
collected at 304 K. In a second step, you determine the temperature dependence of  k1 
and k2 by calculating the corresponding Arrhenius parameters.

1 Start COMSOL Script.

2 Move to the directory containing the text file with the experimental data:
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cd models/Reaction_Engineering_Lab/Process_Chemistry

The data file erythritol_experiments.txt lists the experimental data of 
 Table 4-4 in columns: the first column is the time, the following are data of 
concentration of the three species cA, cB, and cC. The first line in the file contains 
the headings.

Next, you can choose between either running a ready-made script called 
erythritol_kinetics_fit1.m, which you find in the current directory, or 
following Instructions 3–9 below.

3 Create four vectors into which you read the data of the text file, skipping each 
column header:

[t Ca Cb Cc] = textread('erythritol_experiments.txt', ...
    '%f %f %f %f', 'headerlines', 1);

4 Create a matrix of the concentration data and calculate its size:

C = [Ca Cb Cc];
[m n] = size(C);

5 Define the time difference between sampling points:

dt = 50;

6 Make use of the three-point differentiation formulas (Equation 4-233 to 
Equation 4-235) and calculate the approximative time derivatives:

dC(1,:) = -3*C(1,:)+4*C(2,:)-C(3,:);
dC(m,:) = 3*C(m-2,:)-4*C(m-1,:)+C(m,:);
dC((2:(m-1)),:) = C((3:m),:)-C((1:m-2),:);

7 Set up the vector D of Equation 4-232:

D = [dC(:,1)./(2*dt);dC(:,2)./(2*dt);dC(:,3)./(2*dt)];

8 Create the matrix M of Equation 4-232:

M1 = Ca.*Cb.*Cc;
M2 = Ca.^2.*Cb;
z = zeros(m,1);
M = [-M1 -2*M2;-M1 -M2;-M1 z];

9 Solve for the rate-constant vector, k:

k = M\D

k = 

   2.1e-009
   5.7e-012
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You have now completed the parameter estimation of the rate constants k1 and k2 at 
304 K. Now, move on to estimate the Arrhenius parameters for the rate constants 
using the data supplied in Table 4-4 and Table 4-5.

Next, you can once again choose between running a ready-made script, this time called 
erythritol_kinetics_fit2.m, or following the instructions below.

1 Create the following vectors with experimental values taken from Table 4-5:

T = [273 297 304 314];
k1 = [2.7e-11 7.8e-10 2.1e-9 6.5e-9];
k2 = [7.5e-14 2.2e-12 5.7e-12 1.8e-11];

2 Transform the data as suggested by Equation 4-238:

x = 1./T;
y1 = log(k1);
y2 = log(k2);

3 Fit a first-order polynomial to the transformed data:

p1 = polyfit(x,y1,1);
p2 = polyfit(x,y2,1);

4 Evaluate the first-order polynomials p1 and p2 at the points given by the vector x:

x_fit = 3.1e-3:1e-4:3.8e-3;
y1_fit = polyval(p1,x_fit);
y2_fit = polyval(p2,x_fit);

5 Plot the polynomials and the experimental data in the same graph and label the axes:

plot(x,y1,'bs',x,y2,'ro',x_fit,y1_fit,'b',x_fit,y2_fit,'r');
xlabel('1/T');ylabel('ln(k)');

6 Evaluate the Arrhenius parameters A1, E1, A2, and E2:

A1 = exp(p1(2))
A1 = 
5.5e+007

E1 = -8.314*p1(1)
E1 = 
9.6e+004

A2 = exp(p2(2))
A2 = 
1.4e+005

E2 = -8.314*p2(1)
E2 = 
9.6e+004
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Modeling Using COMSOL Reaction Engineering Lab

In the Reaction Engineering Lab, set up the kinetic model of pentaerythritol 
production by typing the chemical reactions and rate constants into the user interface. 
Run the simulation and then compare the model results with experimental data 
directly.

In the COMSOL Script window, select File>Reaction Engineering Lab.

R E A C T I O N S  I N T E R F A C E

1 From the Model menu, select Reaction Settings.

2 Create two entries in the Reaction selection list by clicking the New button twice.

3 Enter the following reaction formulas by first selecting the appropriate row in the 
Reaction selection list and then typing the text in the Formula edit field. Note how 
the Reaction Engineering Lab automatically generates reaction rate expressions and 
presents them in the r edit field.

4 Enter the values for k1 and k2 that you calculated previously by first selecting the 
appropriate row in the Reaction selection list and then typing the corresponding 
number in the kf edit field:

S P E C I E S  I N T E R F A C E

1 While still in the Reaction Settings dialog box, click the Species tab.

2 Verify that the Species selection list contains four species (A, B, C, P, and Q).

3 On the General page, enter the following initial concentrations in the c0 edit field 
after first having selecting the appropriate entry in the Species selection list:

REACTION ID # REACTION FORMULA

1 A+B+C=>P

2 2A+B=>Q

REACTION ID #  kf
 

1 2.1e-9

2 5.7e-12

SPECIES NAME  c0 

A 1540

B 932

C 301.8
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4 Click Close.

C O M P U T I N G  T H E  S O L U T I O N

1 Choose Simulation>Solver Parameters.

2 Clear the Stop if steady state is reached first check box.

3 In the Times edit field, type 1000.

4 Click OK.

5 Click the Solve Problem button (=) on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows the time variation of the concentration of all species. For a 
direct comparison between the simulation results and the experiments, read the text 
file with experimental data into the Reaction Engineering Lab and plot it in same the 
graph showing the simulation results.

1 Choose File>Import Experimental Data From File to bring up the dialog for importing 
data from a text file.

2 Browse in the COMSOL installation folder to models/
Reaction_Engineering_Lab/Process_Chemistry/

erythritol_experiments.txt, and click Import.

3 Choose Postprocessing>Plot Parameters.

4 Select the Plot experimental data check box at the right bottom corner and click OK 
to get the following plot:

5 Use the zoom tools (or the Plot Edit dialog box) to zoom on each line in order to 
reproduce the figures displayed previously in the result section.
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K i n e t i c  Mode l i n g  o f  C i n n ama l d eh yd e  
Hyd r o g ena t i o n

Introduction

The hydrogenation of α,β-unsaturated aldehydes commonly produces a mixture of 
two products, namely the corresponding unsaturated alcohol as well as the saturated 
aldehyde. Various multi-metallic catalysts have shown promise with respect to 
increasing selectivity towards the desired alcohol product. In this example, the rate 
constants of a network of hydrogenation reactions are determined by fitting of the 
model parameters to experimental data. The first system under study is a binary Cu-Al 
catalyst and a second investigation concerns the quaternary Cu-Co-Zn-Al system.

The model illustrates the built-in parameter estimation functionality of the Reaction 
Engineering Lab. The reaction model is set up in the usual way, by typing chemical 
reaction formulas into the graphical user interface. After reading the experimental data 
into the software, model parameters are then estimated by means of the Gauss- 
Newton method.

Model Description

Exposing α,β-unsaturated cinnamaldehyde (cal) to hydrogen leads to either 
hydrogenation of the carbonyl to produce cinnamyl alcohol (col), or to hydrogenation 
of the alkene functionality to produce hydrocinnamaldehyde (sal). Further 
hydrogenation of both of these reaction products yields hydrocinnamyl alcohol (sol).

The corresponding reaction network is illustrated below.
R  4 :  M O D E L  L I B R A R Y



 (4-239)

Apart from the hydrogenation pathway just described, additional reactions are 
indicated by the dashed arrows. Cinnamaldehyde (cal) can decompose though 
decarbonylation and also undergo direct hydrogenation into hydrocinnamyl alcohol 
(sol). Cinnamyl alcohol (col) can decompose through hydrogenolysis as well as 
undergo isomerization to hydrocinnamaldehyde (sal). However, experiments have 
determined these reaction pathways to be negligible (Ref. 1), and the corresponding 
rate constants are not evaluated.

Experiments to evaluate catalyst performance are performed in a batch reactor 
autoclave, where 10 ml of cinnamaldehyde is diluted in isopropanol. 1 g of catalyst is 
added to the perfectly mixed system. In addition, a constant hydrogen pressure of 
10 bar is applied, and the system temperature is 393 K.

Assuming that hydrogen is present in excess, the following mass balances are proposed:

 (4-240)

 (4-241)

 (4-242)

k1

C
H

O
H

H

C
H

OH
H

H
H

C
H

O
H

H

H

H

H

H

H

H
C
H

OH

H

k3

k2 k4

(cal)

(col)

(sal)

(sol)

dccal
dt

------------- k1ccal
m

– k2ccal
n

–=

dccol
dt

------------- k1ccal
m k3ccol–=

dcsal
dt

------------- k2ccal
n k4csal–=
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 (4-243)

The reaction rate constants, k1 through k4, as well as the reaction orders, m and n, are 
to be evaluated from two sets of experiments. A first set involves a bimetallic Cu-Al 
catalyst while the second experiment employs a quaternary Cu-Co-Zn-Al catalyst. The 
concentrations of the involved species, cal, col, sal and sol are measured as a function 
of time, and the results are shown in Table 4-6 and Table 4-7, below.

TABLE 4-6:  EXPERIMENTAL DATA FOR CU-AL CATALYST

TIME (MIN) ccal (mol/dm3) ccol (mol/dm3) csal (mol/dm3) csol (mol/dm3)

0 0.491 0.000 0.000 0.000

15 0.486 0.006 0.008 0.000

30 0.476 0.006 0.016 0.001

45 0.460 0.018 0.024 0.001

60 0.437 0.024 0.034 0.002

90 0.407 0.034 0.049 0.005

120 0.376 0.044 0.067 0.009

150 0.347 0.051 0.083 0.013

180 0.323 0.061 0.102 0.019

210 0.294 0.068 0.119 0.025

240 0.265 0.074 0.135 0.032

270 0.233 0.078 0.149 0.039

300 0.199 0.088 0.174 0.049

330 0.171 0.088 0.180 0.054

360 0.138 0.091 0.196 0.063

390 0.108 0.099 0.220 0.074

420 0.080 0.101 0.234 0.083

TABLE 4-7:  EXPERIMENTAL DATA FOR CU-CO-ZN-AL CATALYST

TIME (MIN) ccal (mol/dm3) ccol (mol/dm3) csal (mol/dm3) csol (mol/dm3)

0 0.506 0.000 0.000 0.000

15 0.438 0.039 0.022 0.002

30 0.389 0.039 0.041 0.007

45 0.349 0.081 0.057 0.014

dcsol
dt

------------- k3ccol k4csal+=
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Results

The first model concerns hydrogenation of cinnamaldehyde over a solid Cu-Al catalyst. 
Figure 4-107 shows the concentration transients of cal, col, sal, and sol (mol/dm3) 
evaluated from both experiments and simulation.

Figure 4-107: Concentration of cal, col, sal, and sol (mol/dm3) as function of time (min). 
Solid lines indicate simulated results while markers show experimental data. Reaction 
orders are m=n=0.

Experimental data points for the reactant aldehyde (cal) show that the concentration 
falls off linearly with time. This implies that the reactions depleting cal are of order 
zero, that is, m = 0 and n = 0. The reaction orders are held constant during the 
estimation of the rate constants, k1 through k4. Performing parameter estimation for 

60 0.316 0.093 0.072 0.022

90 0.258 0.101 0.095 0.040

120 0.214 0.107 0.120 0.062

150 0.179 0.104 0.139 0.084

180 0.159 0.090 0.143 0.097

210 0.135 0.084 0.158 0.118

240 0.120 0.077 0.172 0.137

TABLE 4-7:  EXPERIMENTAL DATA FOR CU-CO-ZN-AL CATALYST

TIME (MIN) ccal (mol/dm3) ccol (mol/dm3) csal (mol/dm3) csol (mol/dm3)
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different combinations of m and n, confirms that m = 0 and n = 0 gives the best model 
fit. Table 4-8 lists the values of rate constants and the confidence interval (95%).

Figure 4-108 shows the concentration transients of cal, col, sal, and sol (mol/dm3) 
evaluated for the Cu-Co-Zn-Al system.

Figure 4-108: Concentration of cal, col, sal, and sol (mol/dm3) as function of time (min). 
Solid lines indicate simulated results while markers show experimental data. Reaction 
orders are m=2 and n=1.

For the quaternary catalyst system, the aldehyde (cal) concentration falls off 
exponentially with time. To evaluate the proper reaction order in this case, a number 
of model fits are performed with m and n ranging from 1 to 2. Reaction orders m=2 
and n=1 provide the best fit to data.

Table 4-9 lists the values of rate constants and the confidence interval (95%).

TABLE 4-8:  RATE CONSTANTS WHEN M=0,N=0

VALUE LOWER LIMIT UPPER LIMIT

kf_1 4.37e-4 4.34e-4 4.40e-4

kf_2 5.61e-4 5.58e-4 5.65e-4

kf_3 3.17e-3 3.12e-3 3.21e-3

kf_4 3.00e-5 0.71e-5 5.30e-5

TABLE 4-9:  RATE CONSTANTS WHEN M=2,N=1

VALUE LOWER LIMIT UPPER LIMIT

kf_1 1.18e-2 1.16e-2 1.20e-2

kf_2 3.08e-3 3.04e-3 3.12e-3
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The ratio k1/k2 provides a measure of the selectivity of the first hydrogenation step. 
For the Cu-Al system, k1/k2 = 0.78, meaning that there is a preference to hydrogenate 
the C=C bond in cinnamaldehyde. In the case of the Cu-Co-Zn-Al system, k1/
k2 = 3.9. Here, the desired hydrogenation of C=O bond is favored. The proposed 
explanation to this behavior is that Cu preferentially activates the alkene bond while 
cationic Co and Zn species activate the carbonyl (Ref. 1).

Although Cu has adverse effects with respect to selectivity, the metal is essential when 
it comes to producing the surface bound hydrogen needed for the hydrogenation 
reactions.

As can be seen from Table 4-8 and Table 4-9, the Cu-Co-Zn-Al system is considerably 
more active towards hydrogenation as compared to the Cu-Al catalyst. This has been 
correlated to the dispersion of Cu particles, which is greater in the Cu-Co-Zn-Al 
system. A greater dispersion means that more Cu sites are available at the catalytic 
surface. 

Reference

1. A.J. Marchi, D.A. Gordo, A.F. Trasarti and C.R. Apesteguia, Applied Catalysis A, 
vol. 249, p. 53, 2003.

Model Library path: Process_Chemistry/cinnamaldehyde_hydrogenation

kf_3 6.04e-3 5.97e-3 6.11e-3

kf_4 4.33e-4 3.92e-4 4.73e-4

TABLE 4-9:  RATE CONSTANTS WHEN M=2,N=1

VALUE LOWER LIMIT UPPER LIMIT

R C
H

O

H H

Cu Zn
2+

RC
H

O

HH

HH

Cu Cu
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Modeling Using the COMSOL Reaction Engineering Lab

M O D E L  N A V I G A T O R

1 Start the COMSOL Reaction Engineering Lab by double-clicking its desktop icon.

2 In the Model Navigator click the New button.

Start by evaluating the kinetic parameters of the Cu-Al system.

R E A C T I O N S  I N T E R F A C E

1 From the Model menu, select Reaction Settings.

2 Create four entries in the Reaction selection list by clicking the New button four 
times.

3 Enter the reaction formulas in the table below by first selecting the appropriate row 
in the Reaction selection list and then typing the text in the corresponding Formula 
edit field.

4 Modify the automatically generated expressions for the reaction rates by entering 
the following text into the Reaction rate edit field.

You modify the predefined expressions by adding parameters for the reaction order. 
The parameters m and n will be defined later on.

REACTION ID # REACTION FORMULA

1 cal=>col

2 cal=>sal

3 col=>sol

4 sal=>sol

REACTION ID # REACTION RATE

1 kf_1*c_cal^m

2 kf_2*c_cal^n
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5 Enter the following values for the Forward rate constant by first selecting the 
appropriate row in the Reaction selection list and then typing the corresponding 
number in the kf edit field:

The values just entered for the rate constants serve as starting guesses for the 
parameter estimation.

S P E C I E S  I N T E R F A C E

1 While still in the Reaction Settings dialog box, click the Species tab.

2 Verify that the Species selection list contains four species (cal, col, sal, and sol).

3 On the General page, enter the following initial concentrations, one by one, in the 
c0 edit field after first having selected the appropriate entry in the Species selection 
list:

4 Click Close.

O P T I O N S  A N D  S E T T I N G S

1 Select the menu item Model>Constants.

2 Type in the entries in the table below.

3 Click OK.

Move on to load experimental data into the software and set up the parameter 
estimation problem.

REACTION ID # kf

1 1e-3

2 1e-3

3 1e-3

4 1e-3

SPECIES NAME c0

cal 0.5

col 0

sal 0

sol 0

NAME EXPRESSION DESCRIPTION

m 0 reaction order

n 0 reaction order
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1 Select the menu item Estimation>Parameter Estimation Settings.

2 On the Data page click the Import From File button.

3 Browse to the text file cinnamaldehyde_hydrogenation_CuAl_data.txt and 
click Import.

4 Select the entry under Data set selection.

5 Go to the Variable Mapping page and click through the Data selection list, making 
sure that the default association of model variables with measured variables is 
correct.

6 Click the Parameters page.

7 In the Predefined parameters list, select kf_1 (Forward rate constant 1) and then click 
the > button.

8 Repeat the above step for the parameters kf_2 (Forward rate constant 2), kf_3 

(Forward rate constant 3), and kf_4 (Forward rate constant 4).

9 Click OK to close the Parameter Estimation Settings dialog box.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Estimate Parameters button on the Main toolbar.

You find the estimated values of the rate constants and their confidence limits displayed 
in the Progress - Log window. If the Progress - Log window is not open, access it by 
following the steps below:

1 Select the menu item Estimation>View Log.

2 Click the Log page.

Note that you may have to scroll in the log to locate the summary report of the 
parameter estimation calculations. Selecting the Close automatically check box closes 
the Progress - Log window after each simulation.

You can have the software automatically update the reaction model with the new 
parameter values. In this example, you then find the updated values in the Forward rate 

constant edit fields, in the Reaction Settings dialog box. It is also your option to have 
the software automatically run the model simulation with the updated parameters. To 
set these options, follow these steps.

1 Select the menu item Estimation>Parameter Estimation Settings.

2 Go to the Advanced page.

3 Make sure that the check box Copy parameter values to model after parameter 

estimation is selected.
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4 Make sure that the check box Solve model after estimating parameters is selected.

5 Click OK.

Now, load the data for the Cu-Co-Zn-Al system and evaluate the kinetic constants.

R E A C T I O N S  I N T E R F A C E

1 Click the Reaction Settings button on the Main toolbar.

2 Make sure that the Reactions page is active.

3 Enter the following values for the Forward rate constant by first selecting the 
appropriate row in the Reaction selection list and then typing the corresponding 
number in the kf edit field:

O P T I O N S  A N D  S E T T I N G S

1 Select the menu item Model>Constants.

2 Type in the entries in the table below; when done, click OK.

Move on to load experimental data into the software and set up the parameter 
estimation problem.

1 Select the menu item Estimation>Parameter Estimation Settings.

2 Go to the Data page and click the Import From File button.

3 Browse to the text file cinnamaldehyde_hydrogenation_CuCoZnAl_data.txt and 
click Import.

4 Select cinnamaldehyde_hydrogenation_CuAl_data.txt from the Data set selection list, 
and deactivate the set by clearing the check box to the left of the list entry.

5 Select cinnamaldehyde_hydrogenation_CuCoZnAl_data.txt in the Data set selection list.

REACTION ID # kf

1 1e-3

2 1e-3

3 1e-3

4 1e-3

NAME EXPRESSION DESCRIPTION

m 2 reaction order

n 1 reaction order
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6 Go to the Variable Mapping page and click through the Data selection list, making 
sure that the default association of model variables with measured variables is 
correct.

7 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Estimate Parameters button on the Main toolbar.
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Ch em i c a l  V apo r  Depo s i t i o n  o f  GaA s

Introduction

This example illustrates the modeling of a reactor for chemical vapor deposition 
(CVD). In the CVD process described here, triethyl-gallium (Ga(C2H5)3) first 
decomposes into a gas phase. The reaction products, along with arsine (AsH3), then 
adsorb and react on a substrate to form GaAs layers. The CVD system is modeled using 
momentum, energy, and mass balances including a detailed description of the gas 
phase and adsorption kinetics (Ref. 1).

The model highlights the usability of the Reaction Engineering Lab together with the 
Chemical Engineering Module in COMSOL Multiphysics for simulation of complex 
reaction/transport systems. In the Reaction Engineering Lab you can easily study the 
transient behavior of different sets of reactions in a perfectly mixed system. On the 
basis of this analysis, you can then choose a reaction set, export it seamlessly to the 
Chemical Engineering Module, and investigate how the chemistry behaves in a 
detailed reactor geometry with surface reactions present.

Introduction

Chemical vapor deposition is an important process for the electronics industry. A thin 
film is grown on a substrate by allowing molecules and molecular fragments to adsorb 
and react on a surface. Combining detailed chemical reaction kinetics with transport 
models of a CVD reactor allows for realistic modeling of the deposition process. Such 
simulations in turn minimize the large number of expensive and time-consuming trial 
runs typically required for a reactor design.

Model Definition

You can describe the gas phase decomposition of Ga(C2H5)3 with three irreversible 
reactions:

 (4-244)

 (4-245)

Ga(C2H5)3 C2H5+k1 Ga(C2H5)2

Ga(C2H5)2 Ga(C2H5)H C2H4
+k2
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 (4-246)

A number of radical reactions also take place in the gas phase:

 (4-247)

 (4-248)

 (4-249)

 (4-250)

 (4-251)

 (4-252)

The growth of GaAs at the surface is governed by the adsorption of gas phase species 
and the subsequent reaction of the surface-bonded molecular fragments. 
Equation 4-253 to Equation 4-257 give the surface reactions involving the Ga and As 
species. SA and SG represent surface sites, corresponding to dangling bonds of As or 
Ga atoms, respectively.

 (4-253)

 (4-254)

 (4-255)

 (4-256)

 (4-257)

The surface reactions of carbon and hydrogen fragments are given by:

Ga(C2H5)H GaH2 C2H4
+k3

+ H2 C2H6 H+
f

rC2H5

k4

k4

+ 2CH3C2H5 H
k5

+ H2 CH4 +CH3 H
k6

C2H62CH3
k7

C2H4 + H2 C2H5
k8

2H2+ H22H
k9

Ga(C2H5)3
k10 + 2C2H5+ SA GaC2H5*

Ga(C2H5)H + SA Ga(C2H5)H*
f

r

k11

k11

GaH2
k12

Ga* + 2H+ SA

Ga*Ga(C2H5)H*
k13 + HC2H5+

AsH3
k14 As* + 3H+ SG
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 (4-258)

 (4-259)

 (4-260)

 (4-261)

 (4-262)

 (4-263)

Finally, surface reactions leading to GaAs growth are given by:

 (4-264)

 (4-265)

The reaction rates (mol/(m3· s)) corresponding to the chemistry just described involve 
the mass action law

.  (4-266)

Here, and denote the forward and reverse rate constants, respectively. The 
concentration of species i  is denoted ci (mol/m3). The stoichiometric coefficients are 
denoted νij, and are defined as negative for reactants and positive for products. The 
temperature dependence of the reaction rates is included through Arrhenius 
expressions for the rate constants:

.  (4-267)

In this equation, A denotes the frequency factor, T the temperature (K), n the 
temperature exponent, E the activation energy (J/mol), and Rg the ideal gas constant, 

+ SAC2H5 C2H5A*

f

r

k15

k15

+ SGC2H5 C2H5G*

f

r

k16

k16

k17 +C2H5A* C2H4HA*

k18 +C2H5G* C2H4HG*

k19 +SAHA* H

k20 +SGHG* H

k21 GaAs + C2H5GaC2H5* As*+ + SA + SG

k22 GaAsGa* As*+ + SA + SG

rj kj
f ci

ν– ij kj
r ci

νij

i prod∈
∏–

i react∈
∏=

kj
f kj

r

k ATn E
RgT
-----------–⎝ ⎠

⎛ ⎞exp=
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8.314 J/(mol·K). The frequency factor is expressed in the units , 
where α is the order of the reaction.

Adsorption kinetics can also affect the overall rates. The rate of adsorption of species i 
at the substrate surface is

 (4-268)

where ci is the species concentration (mol/m3), Mi denotes the molecular weight (kg/
m3), xs is the fraction of available surface sites, and E gives the activation energy (J/
mol).

In this model, the chemical species occurring in the reactions just outlined have the 
following labels: any label starting with SA indicates a surface species adsorbed at an 
arsenic site, while SG denotes a surface species adsorbed at a gallium site.

Figure 4-109: Species labels used in the model.

The analysis process follows these steps: First, take the chemistry just outlined and 
enter it into the Reaction Engineering Lab. Next study the material balances of 
different reaction networks—while assuming they are working in a perfectly mixed 

(m3/mol)
α 1–

/s

ri ci
RgT
2πMi
--------------xs

E
RgT
-----------–⎝ ⎠

⎛ ⎞exp=

Ga(C2H5)3

GaC2H5*

Ga(C2H5)H

Ga(C2H5)H*

GaH2

Ga*

AsH3

As*

H2

C2H6

H

C2H5Ga(C2H5)2

C2H4

CH3

CH4

H*

C2H5*

GaAs

gaet3

gaet2

gahet

gah2

SAgahet

SAgaet

SAga

ash3

SGas

gaas

ethane

et

ethene

methane

met

h2

h

SAet, SGet

SAh, SGh
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batch reactor—to quickly get an overview of the reaction kinetics. Then use the 
Reaction Engineering Lab’s library of predefined expressions for species transport 
properties. With this preprocessing completed, export the reaction model to the 
Chemical Engineering Module to investigate the effects of the CVD reactor geometry 
on the reacting system. You can also study the effects of the adsorption and surface 
reactions.

Figure 4-110 shows the CVD reactor as drawn in COMSOL Multiphysics. The reactor 
is 40 cm long and 10 cm high. Located in the center is the substrate, 5 cm across and 
tilted 10° with respect to the vertical position. Gas enters the reactor at the inlet with 
a velocity of 0.4 m/s and at a pressure of 4000 Pa.

Figure 4-110: The modeling domain consists of the CVD reactor and the substrate surface.

You solve the problem in the Chemical Engineering Module using three application 
modes:

• Weakly Compressible Navier-Stokes

• Convection and Conduction

• Convection and Diffusion

The gas in the reactor domain is described by momentum, heat, and mass-balance 
equations. 

The momentum balance is

wall

wall

inlet outlet
substrate
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 (4-269)

.  (4-270)

The energy balance is

.  (4-271)

The mass balance is

.  (4-272)

The boundary conditions imposed on the momentum balance are no-slip at the 
reactor walls and at the substrate surface, the substrate being treated as an interior 
boundary. Furthermore,

 (4-273)

 (4-274)

.  (4-275)

The boundary conditions for the energy balance are

 (4-276)

 (4-277)

.  (4-278)

During the CVD process the substrate is heated. To model this process, impose a 
temperature profile at the substrate boundary:

 (4-279)

The boundary conditions for the mass balance are insulating at the reactor walls. 
Furthermore,

 (4-280)

ρ
t∂

∂u ∇ η ∇u ∇u( )T
+( )⋅– ρ u ∇⋅( )u ∇p+ + F=

ρ∂
t∂

------ ∇+ ρu( )⋅ 0=

ρ Cp
T∂
t∂

------- ∇+ k– ∇T ρ CpT u+( )⋅ Q=

ci∂
t∂

------- ∇+ D– i∇ci ci u+( )⋅ Ri=

u u0 inlet=

p p0  outlet=

η ∇u ∇u( )T
+( ) 2η

3
------- ∇ u⋅( )I– n 0= outlet

T T0  inlet=

T T0  walls=

n k T∇–( )⋅ 0  outlet=

T Tsurf  substrate.=

ci c0 i,  inlet=
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.  (4-281)

Adsorption and reaction at the substrate surface lead to a flux discontinuity given by

 (4-282)

.  (4-283)

Results

As noted, the first step in the modeling process is to enter the complete set of gas phase 
reactions, Equation 4-244 to Equation 4-252, into the Reaction Engineering Lab for 
analysis. Figure 4-111 shows the species concentrations as functions of time in a 
perfectly mixed batch reactor kept at 900 K.

Figure 4-111: The complete set of gas phase reactions including decomposition reactions of 
gallium species as well as radical reactions. The chemistry occurs in a perfectly mixed batch 
reactor held at 900K. Radical species are not shown in the graph.

As a test, omit the radical reactions given by Equation 4-247 to Equation 4-252 from 
the set of gas phase reactions. Once again analyze the kinetics of the reactions 
describing gallium species decomposition, Equation 4-244 to Equation 4-246, at 

n Di ci∇–( )⋅ 0  outlet=

n– N1 N2–( )⋅ Ni  substrate=

Nj D– i∇ci ciu+ substrate=
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900 K. The results appear in Figure 4-112.

Figure 4-112: A reduced set of gas phase reactions including only the decomposition 
reactions of gallium species. Reactions occur in a perfectly mixed system held at 900 K.

Reducing the gas phase reaction set does not affect the reactions of the gallium species. 
However, excluding the radical reactions has a considerable influence on the 
carbon-species distribution. For the reduced reaction set, ethene and ethyl radicals are 
the main carbon products; for the full reaction set the main products are ethene and 
methane. The various species have different characteristics with respect to surface 
adsorption and reaction. Furthermore, the net concentration of carbon species is 
higher for the full reaction set. Both these factors can significantly influence the growth 
of surface layers. For a first study of geometrical effects on the reacting system, you can 
bring the reduced reaction model into the actual geometry of the CVD reactor and 
then solve the problem in the Chemical Engineering Module.

Figure 4-113: The gas phase velocity (left) and the temperature distribution (right) in the 
reactor domain.

Figure 4-113 shows the fluid velocity (left panel) and the temperature distribution 
(right panel) in the reactor domain. The gas mixture enters the reactor with a velocity 
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of 0.4 m/s and a temperature of 300 K with the substrate held at a constant 
temperature of 900 K. Notice the large effect that the heating plate has on the 
temperature and the expansion this causes in the fluid. This effect is seen in the average 
velocity, which increases downstream after the position of the substrate.

Figure 4-114: Left panel: concentration distribution of triethyl-gallium in the reactor 
domain. Right panel: concentration profiles of triethyl-gallium (blue line) and gallium 
hydride (red line) along the reactor centerline.

In Figure 4-114, the left panel shows the concentration distribution of the 
triethyl-gallium species in the reactor domain, while the right panel displays the 
concentration profile along the reactor centerline for triethyl-gallium together with 
that of the final product gallium hydride. Triethyl-gallium is stable at the inlet 
temperature (300 K) and then rapidly decomposes near the hot substrate.

Figure 4-115 shows the concentration profile of arsine along the reactor centerline. 
This species does not decompose in the gas phase. The decrease in concentration at the 
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substrate surface (at the 0 length coordinate) is due to the adsorption of arsine at the 
surface.

Figure 4-115: Concentration profile of arsine along the reactor centerline. Arsine is 
adsorbed at the substrate surface, which is located at the center of the length scale.

Figure 4-116 depicts a few of the transport properties set up in the Reaction 
Engineering Lab and exported to the applications modes of the COMSOL 
Multiphysics model. The left panel shows the diffusivities of triethyl-gallium (bottom) 
and arsine (top). The right panel shows the thermal conductivity of the hydrogen 
carrier gas. All variables are plotted as functions of temperature.

Figure 4-116: The diffusivities of triethyl-gallium (bottom) and arsine (top) as functions 
of temperature (left), and the thermal conductivity of the hydrogen carrier gas (right).

In summary, this model illustrates how to work with the Reaction Engineering Lab 
and COMSOL Multiphysics to solve an applied multiphysics problem. You set up the 
chemical kinetics in the Reaction Engineering Lab by entering the chemical reaction 
formulas. It is then easy to study different models by effortlessly activating/ 
deactivating reactions. Then you make use of a predefined library of expressions to set 
up the transport properties of the reacting system before exporting the reaction model 
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to the Chemical Engineering Module. There you add the effect of the CVD reactor’s 
geometry and of surface reactions to the model.

Reference

1. N.K. Ingle, C. Theodoropoulos, T.J. Mountziaris, R.M. Wexler, and F.T.J. Smith, 
J. Crystal Growth, vol. 167, p. 543, 1996.

Model Library path: Semiconductors/gaas_cvd1

Model Library path: Semiconductors/gaas_cvd2

The following path shows the location of the COMSOL Multiphysics model:

Model Library path: Reaction_Engineering_Lab/Semiconductors/gaas_cvd2

Modeling Using COMSOL Multiphysics

In this example, you first create the CVD reactor geometry in COMSOL Multiphysics 
and then proceed to create the reaction model in the Reaction Engineering Lab.

G E O M E T R Y  M O D E L I N G

1 Open COMSOL Multiphysics and click OK in the Model Navigator.

2 Hold down the Shift key and click the Rectangle/Square button on the Draw toolbar 
(or choose Draw>Specify Objects>Rectangle from the top menu). Enter the values for 
the rectangle R1 given below.

EDIT FIELD R1

width 0.4

height 0.1

position Center
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3 Click OK, then click the Zoom Extents button on the Main toolbar.

4 Hold down the Shift key and click the Line button on the Draw toolbar. Enter the 
following values for the line B1:

5 Click OK.

6 Click the Rotate button on the Draw toolbar.

7 In the a edit field, type -10. Click OK.

The geometry should now look like the one in the picture below.

8 Start the Reaction Engineering Lab by choosing File>Reaction Engineering Lab.

x 0

y 0

EDIT FIELD B1

x 0 0

y -0.025 0.025

EDIT FIELD R1
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Modeling Using COMSOL Reaction Engineering Lab

The model setup in the Reaction Engineering Lab consists of two parts: gas phase 
reactions and adsorption/desorption.

First you solve a “full” reaction model. Then you work with a reduced set of reactions, 
solve the model again, and compare the results. This work all takes place in the 
Reaction Engineering Lab. At the end of this first stage of work (outlined in the section 
“Gas Phase Reactions” below) you export the reaction model to COMSOL 
Multiphysics to the gas subdomain.

Second you set up a reaction model describing the adsorption and desorption from the 
surface of the substrate and export it to the substrate boundary in COMSOL 
Multiphysics. This takes place in the section titled “Adsorption/Desorption” on page 
472.

Gas Phase Reactions

O P T I O N S  A N D  S E T T I N G S

1 Choose Model>Model Settings (or use the corresponding button on the Main 
toolbar).

2 Select the Calculate thermodynamic properties check box.

3 Select the Calculate species transport properties check box.

4 Type 900 in the T edit field.

5 Click Close.

R E A C T I O N S  I N T E R F A C E

Start by investigating the gas phase reactions of the CVD process in the Reaction 
Engineering Lab modeling environment.

1 Choose Model>Reaction Settings (or click the corresponding button on the Main 
toolbar).

2 Create nine entries in the Reaction selection list by clicking the New button nine 
times.
C H E M I C A L  V A P O R  D E P O S I T I O N  O F  G A A S  |  465



466 |  C H A P T E
3 Enter the following reaction formulas by first selecting the appropriate row in the 
Reaction selection list and then entering the corresponding text in the Formula edit 
field.

4 On the Kinetics page, specify the following Arrhenius parameters for the forward 
rate and reverse rate constants by first selecting the corresponding reaction number 
in the Reaction selection list, then selecting the Use Arrhenius expressions check box, 
and finally typing the corresponding numbers in the A, n, and E edit fields:

S P E C I E S  I N T E R F A C E

1 Click the Species tab.

2 Verify that the Species selection list has 11 entries.

3 From the Species selection list, select h2.

REACTION ID # REACTION FORMULA

1 gaet3=>gaet2+et

2 gaet2=>gahet+ethene

3 gahet=>gah2+ethene

4 et+h2<=>ethane+h

5 et+h=>2met

6 met+h2=>methane+h

7 2met=>ethane

8 ethene+h=>et

9 2h+h2=>2h2

REACTION ID #  A 
 forward 

  
reverse 

 n 
 forward

  
 reverse 

 E 
 forward 

  
 reverse 

1 1e15 0 195e3 

2 1e18 0 195e3

3 1e18 0 195e3

4 3.1e-6 5.5e-4 3.6 3.5 35.6e3 21.8e3

5 3.6e7 0 0

6 2.9e-4 3.12 36.4e3

7 2e6 0 0

8 1.5e2 1.49 41.8e3

9 1e6 0 0
R  4 :  M O D E L  L I B R A R Y



4 From the Type list (at the top right corner in the Formula area), select Solvent.

Note that this step automatically selects the Lock concentration/activity check box. 
This includes the influence of hydrogen concentration as a constant in the rate 
expressions.

5 For each species, specify the molecular weight and the initial concentration by first 
selecting the corresponding entry in the Species selection list and then typing the 
values listed in the table below in the M and c0 edit fields, respectively, both on the 
General page.

Molecular hydrogen is the carrier gas in the CVD process, and it is present in excess. 
You set hydrogen as the solvent species and assume that the hydrogen concentration 
is constant.

6 Click Close.

C O M P U T I N G  T H E  S O L U T I O N

1 Choose Simulation>Solver Parameters.

2 In the Times edit field, type 1.

3 Click OK.

4 Click the Solve Problem button (=) on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To produce Figure 4-111 follow these steps:

1 Choose Postprocessing>Plot Parameters.

SPECIES NAME  M  c0 

gaet3 156.7e-3 6.415e-3

gaet2 127.7e-3 0

et 29e-3 0

gahet 99.7e-3 0

ethene 28e-3 0

gah2 71.7e-3 0

h2 2e-3 1.44

ethane 30e-3 0

h 1e-3 0

met 15e-3 0

methane 16e-3 0
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2 Click the << button to clear the Quantities to plot list.

3 With the help of the Ctrl key, select the species gaet3, gah2, ethane, ethene, and 
methane from the Predefined quantities list.

4 Click the > button to add the selected species to the Quantities to plot list.

5 Click the Line Settings button.

6 From the Line color list, select Cycle.

7 From the Line marker list, select Cycle and then click OK.

8 From the Plot in list, select New figure.

9 Click OK.

10 Click the Edit Plot button in the toolbar of the plot window, then select the Log scale 
check box for both the x axis and the y axis.

11 Clear the y-limits: Auto check box and type 1e-5 and 1e-1 in the corresponding edit 
fields to specify the vertical plot range.

12 Go to the Grid page and clear the Show grid check box. 

13 Click OK.

To reduce the model before simulating the process in a dimensional model, study 
whether it is possible to remove the non-gallium species and reactions and yet obtain 
approximately the same results. To do so, modify the existing reaction model by first 
deactivating reactions of non-gallium species. Then re-solve the material balances and 
compare the results with the full reaction model.

R E A C T I O N S  I N T E R F A C E — R E D U C E D  M O D E L

1 Choose Model>Reaction Settings.

2 Click the Reactions tab.

3 Deactivate reactions 4 to 9 (the non-gallium reactions) by clearing the 
corresponding check boxes in the Reaction selection list.

4 Click Close.

P R E P A R I N G  P O S T P R O C E S S I N G — R E D U C E D  M O D E L

In order not to lose the previous plot, which is to be used for comparison, specify the 
location of the next plot to be a separate figure window:

1 Choose Postprocessing>Plot Parameters.

2 Select New figure in the Plot in list.
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3 Click OK.

C O M P U T I N G  T H E  S O L U T I O N — R E D U C E D  M O D E L

Click the Solve Problem button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N — R E D U C E D  M O D E L

1 Click the Edit Plot button in the toolbar of the new figure window, then select the 
Log scale check box for both the x axis and the y axis.

2 Clear the y-limits: Auto check box and type 1e-5 and 1e-1 in the corresponding edit 
fields to specify the vertical plot range.

3 Go to the Grid page and clear the Show grid check box. 

4 Click OK to create Figure 4-112.

A comparison of Figure 4-111 and Figure 4-112 reveals that the gallium-related 
reactions remain approximately the same (see the Results section for a deeper analysis 
and discussion). This means that you can go on to set up a dimensional CVD model 
based on the reduced model instead of the one comprising all species. 

In this CVD model, you add the surface adsorption/desorption kinetics to the 
reactions of the gas phase. Furthermore, before exporting the reduced model to the 
reactor geometry created in COMSOL Multiphysics, the exercise makes use of 
predefined expressions for species transport properties in the Reaction Engineering 
Lab.

Briefly summarized, the step-by-step instructions below implement the following 
procedure: First remove the non-gallium reactions from the reaction model. Then add 
the necessary data for describing the thermodynamics and transport parameters 
necessary for the dimensional model. Finally export the model to the reactor 
subdomain in COMSOL Multiphysics.

Exporting the Model to COMSOL Multiphysics

R E A C T I O N S  I N T E R F A C E

1 From the Model menu, select Reaction Settings.

2 Click the Reaction tab.
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3 Remove the non-gallium reactions by selecting each reaction in the Reaction 

selection list and clicking the Delete button. You end up with the following three 
remaining reactions:

S P E C I E S  I N T E R F A C E

1 Click the Species tab. You now have the following six species: gaet3, gaet2, et, gahet, 
ethene, and gah2; deletions from the Reaction selection list automatically remove the 
other entries from the Species selection list.

2 Add the solvent species H2 by clicking the New button and entering h2 in the 
Formula edit field.

3 Select Solvent from the Type list next to the Formula edit field.

4 Atomic hydrogen occurs in the gas phase, and it is produced by surface reactions. 
Add this species by clicking the New button and entering h in the Formula edit field.

5 Arsine occurs in the gas phase but does not react until it adsorbs at the surface. Add 
this species by clicking the New button and entering ash3 in the Formula edit field.

6 On the General page—by selecting, in turn, gaet3, gaet2, et, gahet, ethene, and gah2, 
from the Species selection list—verify that the following values appear in the 
Molecular weight edit field, M, and the Initial concentration edit field, c0. For the 
species you just added—h2, h, and ash3—type the values in the appropriate edit 
fields. Take care, in particular to select the Lock concentration/activity check box for 
the solvent species h2.

REACTION ID # REACTION FORMULA

1 gaet3=>gaet2+et

2 gaet2=>gahet+ethene

3 gahet=>gah2+ethene

SPECIES NAME M c0 LOCK CONCENTRATION/ACTIVITY

gaet3 156.7e-3 6.415e-3 no

gaet2 127.7e-3 0 no

et 29e-3 0 no

gahet 99.7e-3 0 no

ethene 28e-3 0 no

gah2 71.7e-3 0 no

h2 2e-3 1.44 yes
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7 Click the Thermo tab.

8 Select the solvent species h2.

9 Type 200, 1000, and 3000 into the Tlower, Tmidpoint, and Tupper edit fields, 
respectively.

10 Enter the following polynomial coefficients:

11 Click the Transport tab.

12 Select the appropriate entry in the Species selection list and enter the following 
Lennard-Jones parameters (which are specific for the species and independent of the 
conditions) in the σ and ε/k edit fields:

13 Click Close.

h 1e-3 0 no

ash3 77.9e-3 0.16 no

COMPONENT #  alow,k  ahi,k 

1 2.3433 3.3373

2 7.9805e-3 -4.9402e-5 

3 -1.9481e-5 4.9946e-7

4 2.0172e-8 -1.7957e-10

5 -7.3761e-12 2.0026e-14

6 -9.1793e2 -9.5016e2

7 6.8301e-1 -3.2050

SPECIES NAME  σ  ε/k 

gaet3 6.245 478.6

gaet2 5.487 516.7

et 4.291 184.5

gahet 4.720 554.8

ethene 4.163 224.7

gah2 3.664 345.3

h2 2.827 59.7

h 1.825 2.31

ash3 4.145 259.8

SPECIES NAME M c0 LOCK CONCENTRATION/ACTIVITY
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E X P O R T  S E T T I N G S

1 Choose File>Export>Model to COMSOL Multiphysics.

2 The default choice of Geometry is Geom1 (2D), which is where you want to export to 
first. It is the gas geometry. This requires no change.

3 In the Export mass balance area, find the Application mode list and select 
Convection and Diffusion: New.

4 Type gas_mass in the Group name edit field.

5 In the Export energy balance area, find the Application mode list and select 
Convection and Conduction: New.

6 In the Group name edit field, type gas_energy.

7 In the Export momentum balance area, go to the Application mode list and select 
Incompressible Navier-Stokes: New.

8 In the Group name edit field, type gas_momentum.

9 Click Export.

Adsorption/Desorption
Now proceed to create the surface reactions that occur at the substrate. You first 
modify the reaction model and then export it to the substrate boundary of the 2D 
model. The exported reaction model describes the source terms necessary for defining 
the mass balance boundary conditions on the substrate surface. In this case you must 
first set up the surface temperature, Tsurf, as a model parameter.

O P T I O N S  A N D  S E T T I N G S

1 Choose Model>Model Settings.

2 In the T edit field, type T_surf.

3 In the p edit field, type p_0.

The parameters p_0 and T_surf are now defined in COMSOL Multiphysics, and 
these variables replace the pressure, p, and the temperature, T, respectively, in all 
expressions and functions.

4 Click Close.

R E A C T I O N S  I N T E R F A C E

1 Click the Reaction Settings button.

2 Click the Reactions tab.
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3 Deactivate the gas phase reactions by clearing all the check boxes for the reactions 
in the Reaction selection list.

4 Create 16 new entries in the Reaction selection list by clicking the New button 
repeatedly.

5 Type the following entries into the Formula edit field:

Names starting with SA refer to surface adsorbed species at arsenic sites; names 
starting with SG refer to surface adsorbed species at gallium sites. The notation 
separates the adsorption and desorption processes.

6 On the Kinetics page, enter the following Arrhenius parameters for the forward rate 
constants by first selecting the appropriate row in the Reaction selection list and then 

REACTION ID # REACTION FORMULA

10 gaet3=>SAgaet+2et

11 gahet=>SAgahet

12 SAgahet=>gahet

13 gah2=>SAga+2h

14 SAgahet=>SAga+et+h

15 ash3=>SGas+3h

16 et=>SAet

17 SAet=>et

18 et=>SGet

19 SGet=>et

20 SAet=>ethene+SAh

21 SGet=>ethene+SGh

22 SAh=>h

23 SGh=>h

24 SAgaet+SGas=>gaas+et

25 SAga+SGas=>gaas
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selecting the Use Arrhenius expressions check box and finally entering the numbers 
in the A, n, and E edit fields:

For some of the adsorption reactions, the reaction rate expressions do not follow the 
traditional mass action law and therefore need to be modified; you set them in the 
form of Equation 4-268.

REACTION ID #  A (forward)  n (forward)  E (forward) 

10 1 0 20.9e3

11 1 0 0

12 5e8 0 146e3

13 1 0 0

14 5e11 0 134e3

15 1 0 20.9e3

16 1 0 0

17 7.9e11 0 151e3

18 1 0 0

19 7.9e11 0 151e3

20 2.5e10 0 134e3

21 2.5e10 0 134e3

22 7.2e5 0 67.4e3

23 7.2e5 0 67.4e3

24 1.1e6 0 4.18e3

25 1.1e6 0 4.18e3
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7 For each reaction in the following table, select the corresponding row in the 
Reaction selection list and replace the existing entry in the r edit field with the 
expression in the table:

These expressions contain the variables x_A_surf and x_G_surf, corresponding to 
the mole fractions of free arsenic and gallium sites, respectively. You define these 
variables later in COMSOL Multiphysics.

S P E C I E S  I N T E R F A C E

1 Click the Species tab.

2 Select gaet2 from the Species selection list and click the check box to activate it. All 
18 species present should now be active (checked) in the Species selection list.

3 Select the Lock concentration/activity check box for all the species below ash3 in the 
Species selection list (that is, SAgaet, SAgahet, SAga, SGas, SAet, SGet, SAh, SGh, and 
gaas). You can do this for one species at a time or select all the species and then apply 
the setting.

The effect of this setting is that these species are considered to have a constant 
concentration in the final model, and the Reaction Engineering Lab does not create 
mass balance equations for them.

4 On the General page, type the following values for molecular weight and initial 
concentration into the M and c0 edit fields, respectively:

REACTION ID #  r 

10 kf_10*c_gaet3*(Rg*T)^0.5/(2*pi*M_gaet3)^0.5*x_A_surf

11 kf_11*c_gahet*(Rg*T)^0.5/(2*pi*M_gahet)^0.5*x_A_surf

13 kf_13*c_gah2*(Rg*T)^0.5/(2*pi*M_gah2)^0.5*x_A_surf

15 kf_15*c_ash3*(Rg*T)^0.5/(2*pi*M_ash3)^0.5*x_G_surf

16 kf_16*c_et*(Rg*T)^0.5/(2*pi*M_et)^0.5*x_A_surf

18 kf_18*c_et*(Rg*T)^0.5/(2*pi*M_et)^0.5*x_G_surf

SPECIES NAME  M  c0 

SAgaet 98.7e-3 1.4e-9

SAgahet 99.7e-3 0

SAga 69.7e-3 7.2e-6

SGas 74.9e-3 7.3e-6

SAet 29e-3 2.9e-8

SGet 29e-3 1.7e-8
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5 Click Close.

E X P O R T  S E T T I N G S

1 Select File>Export>Model to COMSOL Multiphysics.

2 From the Domain level list, choose Interior boundary.

3 Clear the Export energy balance check box; the reaction model needs only a mass 
balance in COMSOL Multiphysics.

4 In the Export mass balance area, go to the Application mode list and select 
Convection and Diffusion (chcd).

5 In the Group name edit field, type boundary_mass.

6 Click Export.

Modeling Using COMSOL Multiphysics

1 Choose Multiphysics>Model Navigator.

2 Verify that the model contains the Convection and Diffusion (chcd),  
Convection and Conduction (chcc), and Incompressible Navier-Stokes (chns) application 
modes.

3 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 Choose Options>Constants and define the following constants:

SAh 1e-3 6.8e-8

SGh 1e-3 4e-8

gaas 144.6e-3 0

NAME EXPRESSION DESCRIPTION

u_in 0.4 Inlet velocity

T_in 300 Inlet temperature

T_surf 900 Surface temperature

p_0 4000 Outlet pressure

c_ash3_in 0.16 Inlet concentration AsH3

c_gaet3_in 6.415e-3 Inlet concentration GaEt3

x_A_surf 5e-5 Mole fraction empty A-sites

x_G_surf 2.75e-5 Mole fraction empty G-sites

SPECIES NAME  M  c0 
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2 Click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 Choose Multiphysics>Convection and Diffusion (chcd).

2 Choose Physics>Properties.

3 In the dialog that appears, set Analysis type to Stationary and click OK.

4 Choose Physics>Subdomain Settings.

5 From the Subdomain selection list, choose 1.

6 To check that the model is set up properly, verify that there are tabs with the 
following species names: c_gaet3, c_gaet2, c_et, c_gahet, c_ethene, c_gah2, c_h, and 
c_ash3.

7 In the Group list select gas_mass. This group was created by the export from the 
Reaction Engineering Lab to COMSOL Multiphysics. Note how the Reaction 
Engineering Lab has filled in the D isotropic and R edit fields.

8 For each species, type u in the u edit field and v in the v edit field. You must click 
on the tab for each species and repeat the setting.

9 Click OK.

10 Choose Multiphysics>Convection and Conduction (chcc).

11 Choose Physics>Properties.

12 In the dialog that appears, set Analysis type to Stationary and click OK.

13 Choose Physics>Subdomain Settings.

14 In the Group list, select gas_energy. This group was created by the export from the 
Reaction Engineering Lab to COMSOL Multiphysics.

15 Type u in the u edit field and v in the v edit field.

16 In the Init tab, type T_in in the T(t0) edit field. This sets the initial value for the 
temperature.

17 Click OK.

18 Choose Multiphysics>Incompressible Navier-Stokes (chns).

19 Choose Physics>Properties.

20 In the dialog that appears, set Analysis type to Stationary.

21 Set Weakly compressible flow to On to take density variations into account properly.
C H E M I C A L  V A P O R  D E P O S I T I O N  O F  G A A S  |  477



478 |  C H A P T E
22 Click OK.

This setting changes the name of the application to Weakly Compressible 

Navier-Stokes (chns).

23 Choose Physics>Subdomain Settings.

24 In the Subdomain selection list, select 1.

25 In the Group list, select gas_momentum. This group was created by the export from 
the Reaction Engineering Lab to COMSOL Multiphysics.

26 On the Init page, type p_0 in the p(t0) edit field. This sets the initial value for the 
pressure.

27 Click OK.

Boundary Conditions
1 Choose Multiphysics>Convection and Diffusion (chcd).

2 Choose Physics>Boundary Settings.

3 From the Boundary selection list, choose 1 (the inlet).

4 Specify the Concentration for each species by selecting this entry from the 
Boundary condition list. Do so by going through all the species tabs and setting this 
condition.

5 On the c_gaet3 page, type c_gaet3_in in the Concentration edit field.

6 On the c_ash3 page, type c_ash3_in in the Concentration edit field.

7 Select the Interior boundaries check box to enable interior boundary conditions.

8 Select Boundary 4 (the substrate).

9 In the Group list, select boundary_mass. This group was created by the export from 
the Reaction Engineering Lab to COMSOL Multiphysics. It sets the appropriate 
conditions for all species.

10 Select Boundary 5 (the outlet) and set Convective flux as the boundary condition for 
all species. Do so by going through all the species tabs and selecting that condition 
from the Boundary conditions list.

11 Click OK.

12 Choose Multiphysics>Convection and Conduction (chcc).

13 Choose Physics>Boundary Settings.

14 Select the Interior boundaries check box.
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15 Enter the boundary conditions in the following table:

16 Click OK.

17 Choose Multiphysics>Weakly Compressible Navier-Stokes (chns).

18 Choose Physics>Boundary Settings.

19 Select the Interior boundaries check box.

20 Enter the boundary conditions in the following table:

21 Click OK.

M E S H  G E N E R A T I O N

1 Choose Mesh>Free Mesh Parameters.

2 On the Global page, select Fine from the Predefined mesh sizes list.

3 On the Boundary page, select Boundary 4, then type 2e-3 in the 
Maximum element size edit field.

4 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

Now compute the solution at a substrate temperature of 900 K (which you already set 
in the Constants dialog box).

1 Click the Solver Parameters button.

2 Click the Advanced tab and clear the Stop if error due to undefined operation check 
box.

3 Click OK.

SETTINGS BOUNDARIES 1–3 BOUNDARY 4 BOUNDARY 5

Type Temperature Temperature Convective flux

Value T_in T_surf

SETTINGS BOUNDARY 1 BOUNDARIES 2–4 BOUNDARY 5

Boundary type Inlet Wall Outlet

Boundary condition Velocity No slip Pressure, no 
viscous stress

u0 u_in

v0 0

p0 p_0
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4 Choose Solve>Solver Manager.

5 On the Solve For page, select both Convection and Conduction and 
Weakly Compressible Navier-Stokes.

6 On the Script page, select the Automatically add commands when solving check box.

7 Click Apply, then click Solve. This step solves the momentum and energy balances to 
get a good initial value.

8 On the Initial Value page, select Current solution in the Initial value area.

9 On the Solve For page, select only Convection and Diffusion.

10 Click Apply and then click Solve to find the mass balance.

11 Finally, select all the application modes by clicking the Solve For tab and selecting the 
Geom1 folder.

12 Click Apply and then click Solve.

13 Now you have the final solution. Go to the Script page and clear the 
Automatically add commands when solving check box. Also select the 
Solve using a script check box. These settings allow you to use the same solution 
technique if you wish to alter parameters in the model and solve again.

14 Choose File>Save As and type cvd900.mph in the edit field.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To create the left panel of Figure 4-113, follow these steps:

1 Choose Postprocessing>Plot Parameters (or use the toolbar button).

2 On the Surface page, select Predefined quantities> Velocity field (chns).

3 Click Apply.

4 To reproduce the right panel of Figure 4-113, go to the Surface page. From the 
Predefined quantities list, select Temperature (chcc) and then click Apply.

5 To reproduce the left panel of Figure 4-114, go to the Surface page. From the 
Predefined quantities list, select Concentration, c_gaet3 (chcd), and then click Apply to 
generate the plot.

In order to produce the remaining figures, illustrating various results along the reactor 
centerline, use the Cross-Section Plot Parameters dialog box.

6 Choose Postprocessing>Cross-Section Plot Parameters.

7 On the General page, click the Title/Axis button.
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8 Select the option button next to the Title edit field, and type 
Centerline concentrations.

9 Select the option button next to the Second axis label edit field and type c_i (mol/
m^3).

10 Click OK to close the Title/Axis Settings dialog box.

11 On the Line/Extrusion page, type -0.2 and 0.2 in the x0 and x1 edit fields, 
respectively.

12 Select x in the x-axis data list, then click Apply.

13 From the Predefined quantities list, select Concentration, c_gah2 (chcd).

14 Click the Line Settings button, select Color from the Color list, and click OK.

15 On the General page, select the Keep current plot check box and then click Apply to 
generate the right panel of Figure 4-114.

16 To generate Figure 4-115, go to the General page and select Plot in: New Figure.

17 Click the Title/Axis button, select the Auto buttons next to both Title and 
Second axis label, and click OK.

18 On the Line/Extrusion page, select Concentration, c_ash3 (chcd).

19 Click the Line Settings button, select Cycle from the Color list, and click OK.

20 Generate the plot by clicking Apply.

The Reaction Engineering Lab calculates the diffusivities, the thermal conductivity, 
and other fluid properties, including their temperature dependence. Next, plot the 
diffusivities along the reactor centerline for two of the species as functions of the 
temperature.Again use the Cross-Section Plot Parameters dialog box.

1 On the General tab of the Cross-Section Plot Parameters dialog box, select New figure 
from the Plot in list.

2 Click the Title/Axis button, select the option button next to the Title edit field, and 
type Diffusion coefficients.

3 Select the option button next to the Second axis label edit field and type D_i (m^2/
s).

4 Click OK to close the Title/Axis Settings dialog box.

5 Click the Line/Extrusion tab and type D_c_gaet3_chcd in the Expression edit field.

6 Click the bottom option button in the x-axis data area and then click the Expression 
button.

7 Type T in the Expression edit field and click OK.
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8 Click Apply to generate the first plot.

9 Type D_c_ash3_chcd in the Expression edit field.

10 Click the Line Settings button, then select Color in the Color list and click OK.

11 Create the left panel of Figure 4-116 by clicking Apply.

Finally, plot the thermal conductivity of the hydrogen carrier gas, displayed in the 
right panel of Figure 4-116:

12 Type k_chcc in the Expression edit field.

13 Click the Line Settings button, select Cycle from the Color list, and click OK.

14 Click the General tab and select New figure from the Plot in list.

15 Click the Title/Axis button, select the Auto buttons next to both Title and 
Second axis label, and click OK.

16 Click OK.
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V a r i a b l e s  and Pa r ame t e r s  i n  COMSOL 
R e a c t i o n  Eng i n e e r i n g  L ab

Introduction

This section describes variables and parameters defined in COMSOL Reaction 
Engineering Lab. The following tables are ordered with respect to the components in 
the Reaction Settings dialog box and the Export to COMSOL Multiphysics dialog box.

T H E  R E A C T I O N  K I N E T I C S  P A G E

TABLE 5-1:  VARIABLES AND PARAMETERS ON THE REACTION KINETICS PAGE

PROPERTY LABEL EXPRESSION NAME SI UNIT NOTE

kf_ forward rate 
constant

kr_ reverse rate 
constant

Keq0_ equilibrium 
constant

Keq_ equilibrium 
expression

Af_, Ar_ N/A frequency 
factor

nf_, nr_ N/A temperature 
exponent

Ef_, Er_ N/A activation 
energy

J/(mol·K)

rj r_ reaction rate mol/(m3·s)

kj
f

AfTnf Ef

RgT
-----------–

⎝ ⎠
⎜ ⎟
⎛ ⎞

exp

kj
r

ArTnr Er

RgT
-----------–

⎝ ⎠
⎜ ⎟
⎛ ⎞

exp

Kj0
eq

e
S Rg H RgT⁄–⁄( )

Kj
eq cmcn...

cacb...
----------------- 

Af
j Ar

j,

nf
j nr

j,

Ef
j Er

j,

rj kj
f ci

ν– ij kj
r ci

νij∏–∏=
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T H E  R E A C T I O N  T H E R M O  P A G E

T H E  S P E C I E S  G E N E R A L  P A G E

T H E  S P E C I E S  T H E R M O  P A G E

TABLE 5-2:  VARIABLES AND PARAMETERS ON THE REACTION THERMO PAGE

PROPERTY LABEL EXPRESSION NAME SI UNIT NOTE

Hj H_ enthalpy of 
reaction

J/mol

Sj S_ entropy of 
reaction

J/(mol·K)

Qj Q_ heat source of 
reaction

J/(m3·s)

TABLE 5-3:  VARIABLES AND PARAMETERS ON THE SPECIES GENERAL PAGE

PROPERTY LABEL EXPRESSION NAME SI UNIT NOTE

Mi M_ N/A molecular 
weight

kg/mol

ρi rho_ ideal gas density kg/m3

ρi rho_ liquid density kg/m3 Ref. 1

zi z_ N/A charge

Tc, i Tc_ N/A critical 
temperature

K

Vc, i Vc_ N/A critical molar 
volume

m3/mol

Zi Z_ N/A compressibility 
factor

mol

c0, i c0_ N/A initial 
concentration

mol/m3

Ri R_ rate expression mol/(m3·s)

Hj νijhi

i
∑=

Sj νijsi

i
∑=

Qj H– jrj=

ρi
p

RgT
-----------Mi=

ρi
Mi

Vc i, Zi

1 T
Tc i,
--------–⎝ ⎠

⎛ ⎞
2
7
---

-----------------------------------=

Ri νijrj

j
∑=
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OTE

s 
ef. 2

s 
ef. 2

s 
ef. 2

 
ef. 

s 
ef. 2

 
ef. 

s 
ef. 2
TABLE 5-4:  VARIABLES AND PARAMETERS ON THE SPECIES THERMO PAGE

PROPERTY LABEL EXPRESSION NAME SI UNIT N

hi h_ molar enthalpy J/mol ga
R

si s_ molar entropy J/(mol·K) ga
R

Cp, i Cp_ heat capacity J/(mol·K) ga
R

Cp_ heat capacity J/(mol·K) liq
R
10

ak, 1 – ak, 7 aLok_

aHik_

N/A polynomial 
coefficients

ga
R

ak,1 – ak, 7 aLok_

aHik_

N/A polynomial 
coefficients

liq
R
10

Tint Tlo_

Tmid_

Thi_

N/A temperature 
interval limits

K ga
R

Tint Tlo_

Tmid_

Thi_

N/A temperature 
interval limits

K liq

hi Rg(a1T
a2
2
------T+ +=

a3
3
------T3 a4

4
------T4 a5

5
------T5 a6)+ + +

si Rg(a1 Tln a2T+ +=

a3
2
------T2 a4

3
------T3 a5

4
------T4 a7)+ + +

Cp i, Rg(a1 a2T+ +=

a3T2 a4T3 a5T4)+ +

Cp i, Rg(a1 a2T+ +=

a3T2 a4T3 a5T4)+ +
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TABLE 5-

PROPER TE
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f. 5
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Di
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T H E  S P E C I E S  T R A N S P O R T  P A G E

5:  VARIABLES AND PARAMETERS ON THE SPECIES TRANSPORT PAGE

TY LABEL EXPRESSION NAME UNITS NO

D_ diffusivity m2/s gas
Re
Re

D_ diffusivity m2/s liqu
Re

Di
0 2.695 10 3–⋅=

T3 Mi M0+( ) 2 103MiM0⋅( )⁄
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εi

kB
------

ε0
kB
------⋅ σi

3σ0
3

------------------------------------------------+

⎠
⎟
⎟
⎟
⎟
⎞ 1–

Di
0 3.7 10 15–⋅ T M0

η0Vb i,
0.6

--------------------------------------------=
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ηi  
f. 4 
f. 5

ηi uid 
f. 7

ki  
f. 8

ηi, ref

Ti, ref

Vb, i

σi

TABLE 5-

PROPER TE
eta_ dynamic 
viscosity

Ns/m2 gas
Re
Re

eta_ dynamic 
viscosity

Ns/m2 liq
Re

k_ thermal 
conductivity

W/(m·K) gas
Re

etaRef_ N/A dynamic 
viscosity at 
Tref

Ns/m2

Tref_ N/A reference 
temperature

K

Vb_ N/A molar volume 
at boiling 
point

m3/mol

sigma_ N/A characteristic 
length

Å

5:  VARIABLES AND PARAMETERS ON THE SPECIES TRANSPORT PAGE

TY LABEL EXPRESSION NAME UNITS NO

ηi 2.669 10 6– T Mi 103⋅( )

σi
2

----------------------------------⋅=

b1

T
εi
kB
------⁄⎝ ⎠

⎛ ⎞
b2

-------------------------
b3

b4T
εi
kB
------⁄⎝ ⎠

⎛ ⎞exp

-------------------------------------+ +

⎝
⎜
⎜
⎜
⎛

b5

b6T
εi

kB
------⁄⎝ ⎠

⎛ ⎞exp

------------------------------------- 4.998 10⋅ 40– µ4

kB
2 T

εi
kB
------σi

6
----------------------------------------

⎠
⎟
⎟
⎟
⎞ 1–

+

ηi 10 3– ( ηref103( )
0.2661–

=

T Tref–

223
---------------------) 3– .758+

k η
M
----- 1.15Cp 0.88Rg+( )=
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εi/kb

µi

TABLE 5-

PROPER TE
epsilonkb_ N/A potential 
energy 
minimum

K

mu_ N/A dipole 
moment

D

5:  VARIABLES AND PARAMETERS ON THE SPECIES TRANSPORT PAGE

TY LABEL EXPRESSION NAME UNITS NO

TABLE 5-6:  VARIABLES AND PARAMETERS SET UP FOR EXPORT TO THE DIFFUSION APPLICATION MODE (CHDI)

PROPERTY EXPRESSION NAME SI UNIT NOTE

 Ri rate 
expression

mol/(m3·s)

diffusivity m2/s gas 
Ref. 4 
Ref. 5

diffusivity m2/s liquid 
Ref. 6

 c0,  i N/A initial 
concentration

mol/m3

Ri νijrj

j
∑=

Di
0

Di
0 2.695 10 3–⋅=

T3 Mi M0+( ) 2 103MiM0⋅( )⁄
pσiσ0

---------------------------------------------------------------------------------⋅

c1

T
εi

kB
------

ε0
kB
------⁄

⎝ ⎠
⎜ ⎟
⎛ ⎞

c2

------------------------------------
c3

e
c4T

εi

kB

------
ε0

kB

------⁄⎝ ⎠
⎛ ⎞

------------------------------+

⎝
⎜
⎜
⎜
⎜
⎜
⎛

c5

e
c6T

εi

kB

------
ε0

kB

------⁄⎝ ⎠
⎛ ⎞

------------------------------
c7

e
c8T

εi

kB

------
ε0

kB

------⁄⎝ ⎠
⎛ ⎞

------------------------------+ +

4.748 10 40–⋅ µi
2µ0

2

kB
2 T

εi

kB
------

ε0
kB
------⋅ σi

3σ0
3

------------------------------------------------+

⎠
⎟
⎟
⎟
⎟
⎞ 1–

Di
0

Di
0 3.7 10 15–⋅ T M0

η0Vb i,
0.6

--------------------------------------------=
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TABLE 5-7:  VARIABLES AND PARAMETERS SET UP FOR EXPORT TO THE CONVECTION AND DIFFUSION 
APPLICATION MODE (CHCD)

PROPERTY EXPRESSION NAME SI UNIT NOTE

Ri rate 
expression

mol/(m3·s)

diffusivity m2/s gas 
Ref. 4 
Ref. 5

diffusivity m2/s liquid 
Ref. 6

 c0, i N/A initial 
concentration

mol/m3

Ri νijrj

j
∑=

Di
0

Di
0 2.695 10 3–⋅=

T3 Mi M0+( ) 2 103MiM0⋅( )⁄
pσiσ0

---------------------------------------------------------------------------------⋅

c1

T
εi

kB
------

ε0
kB
------⁄

⎝ ⎠
⎜ ⎟
⎛ ⎞

c2

------------------------------------
c3

e
c4T

εi

kB

------
ε0

kB

------⁄⎝ ⎠
⎛ ⎞

------------------------------+

⎝
⎜
⎜
⎜
⎜
⎜
⎛

c5

e
c6T

εi

kB

------ ε0

kB

------⁄⎝ ⎠
⎛ ⎞

------------------------------
c7

e
c8T

εi

kB

------ ε0

kB

------⁄⎝ ⎠
⎛ ⎞

------------------------------+ +

4.748 10 40–⋅ µi
2µ0

2

kB
2 T

εi

kB
------

ε0
kB
------⋅ σi

3σ0
3

------------------------------------------------+

⎠
⎟
⎟
⎟
⎟
⎞ 1–

Di
0

Di
0 3.7 10 15–⋅ T M0

η0Vb i,
0.6

--------------------------------------------=
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TABLE 5-8:  VARIABLES AND PARAMETERS SET UP FOR EXPORT TO THE MAXWELL-STEFAN DIFFUSION AND 
CONVECTION APPLICATION MODE (CHMS)

PROPERTY EXPRESSION NAME SI UNIT NOTE

Ri rate 
expression

kg/(m3·s)

DAB binary 
diffusion 
coefficients

m2/s gas 
Ref. 4 
Ref. 5

ρfluid fluid density kg/m3

 p N/A pressure Pa

 T N/A temperature T

 M N/A molecular 
weight

kg/mol

w0, i initial weight 
fraction

Ri Mi νijrj

j
∑=

DAB 2.695 10 3–⋅=

T3 Mi M0+( ) 2 103MiM0⋅( )⁄
pσiσ0

---------------------------------------------------------------------------------⋅

c1

T
εi
kB
------

ε0
kB
------⁄

⎝ ⎠
⎜ ⎟
⎛ ⎞

c2

------------------------------------
c3

e
c4T

εi

kB

------ ε0

kB

------⁄⎝ ⎠
⎛ ⎞

------------------------------+

⎝
⎜
⎜
⎜
⎜
⎜
⎛

c5

e
c6T

εi

kB

------ ε0

kB

------⁄⎝ ⎠
⎛ ⎞

------------------------------
c7

e
c8T

εi

kB

------ ε0

kB

------⁄⎝ ⎠
⎛ ⎞

------------------------------+ +

4.748 10 40–⋅ µi
2µ0

2

kB
2 T

εi
kB
------

ε0
kB
------⋅ σi

3σ0
3

------------------------------------------------+

⎠
⎟
⎟
⎟
⎟
⎞ 1–

ρfluid
p

RgT
-----------  

i
∑ xi ms, Mi=

w0 i,
c0 i, Mi

c0 i, Mi

i
∑
------------------------=
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TABLE 5-9:  VARIABLES AND PARAMETERS SET UP FOR EXPORT TO THE CONDUCTION APPLICATION MODE 
(HT)

PROPERTY EXPRESSION NAME SI UNIT NOTE

Q heat source J/(m3·s)

cp, solv solvent heat 
capacity

J/(kg·K) export 
to ht 
with 
chdi, 
chcd

cp, fluid fluid heat 
capacity

J/(kg·K) export 
to ht 
with 
chms

ρsolv solvent 
density

kg/m3 gas 
export 
to ht 
with 
chdi, 
chcd

ρsolv solvent 
density

kg/m3 liquid 
Ref. 1 
export 
to ht 
with 
chdi, 
chcd

ρfluid fluid density kg/m3 export 
to ht 
with 
chms

ksolv solvent 
thermal 
conductivity

W/(m·K) gas 
Ref. 
11 
export 
to ht 
with 
chdi, 
chcd

Q Qj

j
∑=

cp solv,
Cp

M
-------=

cp fluid,  
i
∑ wi ms,

Cp i,
Mi

-----------=

ρsolv
pM
RgT
-----------=

ρsolv
M

VcZ
1 T

Tc

-----–⎝ ⎠
⎛ ⎞

2
7
---

-----------------------------=

ρfluid
p

RgT
-----------  

i
∑ xi ms, Mi=

ksolv
η
M
----- 1.15Cp 0.88Rg+( )=
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ksolv ki solvent 
thermal 
conductivity

W/(m·K)

kfluid fluid thermal 
conductivity

W/(m·K) export 
to ht 
with 
chms 
Ref. 
12

TABLE 5-10:  VARIABLES AND PARAMETERS SET UP FOR EXPORT TO THE CONVECTION AND CONDUCTION 
APPLICATION MODE (CHCC)

PROPERTY EXPRESSION NAME SI UNIT NOTE

Q heat source J/(m3·s)

cp, solv solvent heat 
capacity

J/(kg·K) export 
to chcc 
with 
chdi, 
chcd

cp, fluid fluid heat 
capacity

J/(kg·K) export 
to chcc 
with 
chms

ρsolv solvent 
density

kg/m3 gas 
export 
to chcc 
with 
chdi, 
chcd

ρsolv solvent 
density

kg/m3 liquid 
Ref. 1 
export 
to chcc 
with 
chdi, 
chcd

TABLE 5-9:  VARIABLES AND PARAMETERS SET UP FOR EXPORT TO THE CONDUCTION APPLICATION MODE 
(HT)

PROPERTY EXPRESSION NAME SI UNIT NOTE

kfluid
1
2
--- xi ms, ki +

i 1=
∑⎝⎜

⎛
=

xi ms,
ki

-------------

i 1=
∑⎝ ⎠

⎜ ⎟
⎛ ⎞ 1–

⎠
⎟
⎞

Q Qj

j
∑=

cp solv,
Cp
M
-------=

cp fluid,  
i
∑ wi ms,

Cp i,
Mi

-----------=

ρsolv
pM
RgT
-----------=

ρsolv
M

VcZ
1 T

Tc

-----–⎝ ⎠
⎛ ⎞

2
7
---

-----------------------------=
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CHEMKIN files 118

comparison data 136
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irreversible reactions 74, 76
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kinetic modeling 6

kinetics files
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rate expressions 121
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