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 1
I n t r o d u c t i o n
The MEMS Module Model Library consists of a set of models that demonstrate 
the use of this module for modeling of various types of MEMS devices. The 
purpose of these models is to assist you in learning, by example, how to create 
sophisticated multiphysics models for design and analysis of 
microelectromechanical systems. In addition to serving as a reference, the model 
library can also give you a big head start if you are developing a model of a similar 
nature. 

We have divided these models into four different groups:

• Actuator models

• Sensor models

• Microfluidics models

• Piezoelectric models

The models also illustrate the use of the various application modes in the MEMS 
Module that we used to build these models. Some models also make use of the 
PDE modes in COMSOL Multiphysics for equation-based modeling.

The book in your hands, the MEMS Module Model Library, provides details about 
a large number of ready-to-run models that illustrate real-world uses of the module. 
 1
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Each model start with a model definition and results presentation. This part also 
includes information about how to implement the analysis using the MEMS Module. 
The last part of the model contains step-by-step instructions on how to build the 
model, perform the analysis, and finally visualize and postprocess the solution. For an 
overview of the functionality in the MEMS Module and a detailed introductory 
example, see the MEMS Module User’s Guide and the MEMS Module Reference 
Guide. For more information on how to work with the COMSOL Multiphysics user 
interface, please refer to the COMSOL Multiphysics User’s Guide or the COMSOL 
Multiphysics Quick Start & Quick Reference manual. An explanation on how to 
model using a programming language is available in yet another book, the COMSOL 
Multiphysics Scripting Guide. 

Finally note that we supply these models as COMSOL Multiphysics Model MPH-files, 
available in the MEMS Module section on the Model Library page in the Model 
Navigator. You can open these models in COMSOL Multiphysics for immediate access 
making it possible to follow these examples every step along the way.

Model Library Guide

The table below summarizes key information about the entries in this model library. 
One column indicates which application modes (such as Plane Stress) the model 
includes. The solution time is the elapsed time measured on a machine running 
Windows Vista with a 2.6 GHz AMD Athlon X2 Dual Core 500 CPU and 2 GB of 
RAM. For models with a sequential solution strategy, the Solution Time column shows 
the elapsed time for the longest solution step. The following columns indicate the 
analysis type (such as eigenfrequency), and if multiphysics modeling or parametric 
studies are part of the model.
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ntilever beam models 8

ntilever beam 2D 15 Plane Stress; Moving 
Mesh; Electrostatics

35 s  √  √
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ntilever beam 3D 21 Solid, Stress-Strain; 
Moving Mesh; 
Electrostatic

3 min  √ √

mb drive 28 Plane Stress; Moving 
Mesh; Electrostatics

3 min  √  √  √

pacitive 3D comb drive 44 Electrostatics 1 s  √ 

cko foot 54 Solid, Stress Strain 20 s  √ 

roresistor beam 30* Solid, Stress-Strain; Heat 
Transfer; Conductive 
Media DC

5 s  √  √

romirror 61 Solid, Stress-Strain 10 min  √  √ 

sonator models 73

sonator straight 2D 78 Plane Stress 2 s  √  √ 

sonator folded 2D 84 Plane Stress 4 s  √  √ 

sonator straight 3D 91 Solid, Stress-Strain 24 s  √  √ 

sonator folded 3D 99 Solid, Stress-Strain 29 s  √  √ 

ermoelastic damping models 106

ermoelastic damping 3D 115 Solid, Stress-Strain; Heat 
Transfer by Conduction

2 min

ermoelastic damping 2D 118 Plane Stress; Heat 
Transfer by Conduction

1 s

ermomechanical valve models 122

ermomechanical valve 2D 128 Plane Stress; Heat 
Transfer by Conduction; 
Conductive Media DC

27 s  √  √  √

ermomechanical valve 3D 134 Solid, Stress-Strain; Heat 
Transfer by Conduction; 
Conductive Media DC

2 min  √  √  √

SOR MODELS 145

celerometer models 146
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celerometer 2D 151 Plane Stress; Weak Form 
PDE

18 s  √  √

celerometer 3D 155 Solid, Stress-Strain; Weak 
Form PDE

2 min  √  √

MS gyroscope 161 Solid, Stress-Strain; Film 
Damping

11 min

zoresistive elevator button 177 Solid, Stress-Strain; 
Electric Currents**

11 min  √  √

ssure sensor 2D 194 Plane Stress; Weak Form 
PDE; Electrostatics

36 s  √  √

W gas sensor 212 Piezo Plane Strain 11 s √ √

ermal expansion in a MEMS 
ice using the Material Library

227 Solid, Stress-Strain; Heat 
Transfer by Conduction

19 s √ √

ROFLUIDICS MODELS 241

 electrokinetic 2D 242 Electrostatics; 
Convection and 
Conduction; 
Incompressible 
Navier-Stokes; Diffusion 
and Convection; 
Diffusion

33 s  √  √

ctrokinetic valve 3D 294 Electrokinetic Flow; 
Incompressible 
Navier-Stokes; 
Conductive Media DC; 
Poisson’s Equation

9 s  √  √

id-structure interaction 294 Plane Strain with Fluid 
Interaction

2 min  √  √

ella mixer 307 Incompressible 
Navier-Stokes; 
Diffusion and Convection

53 s  √  √  √

ctroosmotic flow in a biochip 322 Electroosmotic Flow 1 s
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*In the MEMS Module User’s Guide.

**This model requires the AC/DC Module.

***This model requires the COMSOL Reaction Engineering Lab.

We welcome any questions, comments, or suggestions you might have concerning 
these models. Contact us at info@comsol.com or call your local COMSOL 
representative.

-voltage electroosmotic 
ropump

335 Electroosmotic Flow 17 s

ctroosmotic mixer 349 Incompressible 
Navier-Stokes; 
Conductive Media DC

4 min  √  √

r-shaped microchannel chip 364 Incompressible 
Navier-Stokes

33 s  √ 

rochannel H-cell 376 Flow with Species 
Transport

2 min  √  √

jet model 390 Level Set and Laminar 
Flow

4 h  √  √

ing of a capillary channel 404 Level Set and Laminar 
Flow

149 min  √  √

drocarbon dehalogenation in 
rtuous microreactor***

418 Incompressible 
Navier-Stokes

14 s √ √

ZOELECTRICITY MODELS 435

zoceramic tube 436 Piezo Axial Symmetry; 
Axial Symmetry 
Stress-Strain,

1 s  √  √

zoelectric shear actuated 
m

449 Piezo Solid 7 s  √  √

mposite piezoelectric 
nsducer

461 Piezo Solid; Solid, 
Stress-Strain

6 min √ √ √
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Typographical Conventions

All COMSOL manuals use a set of consistent typographical conventions that should 
make it easy for you to follow the discussion, realize what you can expect to see on the 
screen, and know which data you must enter into various data-entry fields. In 
particular, you should be aware of these conventions:

• A boldface font of the shown size and style indicates that the given word(s) appear 
exactly that way on the COMSOL graphical user interface (for toolbar buttons in 
the corresponding tooltip). For instance, we often refer to the Model Navigator, 
which is the window that appears when you start a new modeling session in 
COMSOL; the corresponding window on the screen has the title Model Navigator. 
As another example, the instructions might say to click the Multiphysics button, and 
the boldface font indicates that you can expect to see a button with that exact label 
on the COMSOL user interface.

• The names of other items on the graphical user interface that do not have direct 
labels contain a leading uppercase letter. For instance, we often refer to the Draw 
toolbar; this vertical bar containing many icons appears on the left side of the user 
interface during geometry modeling. However, nowhere on the screen will you see 
the term “Draw” referring to this toolbar (if it were on the screen, we would print 
it in this manual as the Draw menu).

• The symbol > indicates a menu item or an item in a folder in the Model Navigator. 
For example, Physics>Equation System>Subdomain Settings is equivalent to: On the 
Physics menu, point to Equation System and then click Subdomain Settings. 
COMSOL Multiphysics>Heat Transfer>Conduction means: Open the COMSOL 

Multiphysics folder, open the Heat Transfer folder, and select Conduction.

• A Code (monospace) font indicates keyboard entries in the user interface. You might 
see an instruction such as “Type 1.25 in the Current density edit field.” The 
monospace font also indicates COMSOL Script codes.

• An italic font indicates the introduction of important terminology. Expect to find 
an explanation in the same paragraph or in the Glossary. The names of books in the 
COMSOL documentation set also appear using an italic font.
1 :  I N T R O D U C T I O N
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M E M S  A c t u a t o r  M o d e l s
This chapter contains example models of MEMS actuators such as cantilever 
beams, comb drives, gecko feet, micromirrors, resonators, and thermomechanical 
microvalves. These models often include movements and geometry changes. Using 
the Moving Mesh (ALE) application mode you can include these effects in your 
own models, and the cantilever beam and comb drive models show how to do so. 
The Capacitive 3D Comb Drive model is an example of how to make a quick 3D 
analysis of the electrostatic field and calculate a base capacitance value based on 
that. Prestressed Micromirror and Thin-Film Resonator are pure continuum 
mechanics models. They demonstrate how you can model residual stresses using 
initial stress option. Two models, Microresistor Beam and Thermomechanical 
Microvalve, are examples of electro-thermal-structural couplings. In both models, 
the application is to move the structure by conducting a current through 
conductive layers and generate a temperature increase that leads to a displacement 
through thermal expansion. The Gecko Foot model uses assembly features and 
interactive meshing to model both the nanohair and microhair of a synthetic gecko 
foot.
 7
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C an t i l e v e r  B eam

Introduction

The elastic cantilever beam is an elementary structure in MEMS design. This example 
shows the bending of a beam due to electrostatic forces. The primary problem the 
model addresses is the 2-way coupling between the deformations and the electric field. 
It solves the electrostatic equation in the air domain surrounding the beam using the 
arbitrary Lagrangian-Eulerian (ALE) method to account for geometry changes 
associated with the deformation. There are two versions: a 2D model and a 3D model. 
The 2D model uses the Plane Strain and the Electrostatics application modes from the 
MEMS Module and then the Moving Mesh (ALE) application mode from COMSOL 
Multiphysics. The 3D model uses the Solid, Stress-Strain application mode for the 
structural part.

Model Definition

Figure 2-1 and Figure 2-2 show the model geometry both in 2D and 3D. The 
cantilever beam, made of polysilicon (Young’s modulus, E, for the material is 153 GPa, 
and its Poisson’s ratio, ν, is 0.23), is fixed at one end but is otherwise free to move. It 
is coated with a thin conductive layer from the lower side. The beam resides in an 
air-filled chamber that is electrically insulated. However, the lower side of the chamber 
has an electrode that is grounded.

An electrostatic force caused by an applied potential difference between the two 
electrodes make the beam bend towards the grounded layer below it. To compute the 
electrostatic force, this example calculates the electric field in the surrounding air. The 
model considers a layer of air 20 µm thick both above and to the sides of the beam, 
and the air gap between the bottom of the beam and the grounded layer is initially 2 
µm. As the beam bends, the geometry of the air changes continuously. Using the ALE 
method, the model takes this displacement into account when computing the potential 
field. Thus, the geometry deforms, and the electric field between the electrodes 
continuously changes as a result of the bending.
2 :  M E M S  A C T U A T O R  M O D E L S



Figure 2-1: The cantilever-beam model’s initial geometry. In 2D the beam has a length of 
300 µm and a height of 2 µm, and it is fixed at the left boundary. The lower boundary of 
the surrounding air domain represents the grounded substrate.

Figure 2-2: The cantilever beam’s initial geometry in 3D. The beam is 100 µm long and 
2 µm thick, and it is fixed at x = 0. The model uses symmetry on the zx-plane at y = 0, and 
thus it examines only a 20-µm wide section of the 40-µm wide beam. The lower boundary 
of the surrounding air domain represents the grounded substrate. The model has 20 µm of 
free air above and to the sides of the beam, while the gap below the beam is 2 µm.

This model solves the electric field within the air and the beam using the electrostatic 
equation

.

The model places the lower-boundary cantilever beam at a positive potential. The 
electric field is continuous from the polysilicon to air on the other boundaries. The 
lower boundary of the chamber is grounded, and all other boundaries are electrically 
insulated. The model solves the electrostatic equation on the deformed mesh that the 
Moving Mesh (ALE) application mode introduces.

The force density that acts on the electrode of the beam results from the Maxwell’s 
stress tensor:

,

∇ ε V∇( )⋅– 0=

Fes
1
2
--- E D⋅( )n– n E⋅( )DT

+=
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where E and D are the electric field and electric displacement vectors, respectively, and 
n is the outward normal vector of the boundary. This force is always oriented along 
the normal of the boundary.

In 2D this model solves the structural deformation of the beam using the plane strain 
approximation.

Results

A positive feedback exists between the electrostatic forces and the deformation of the 
cantilever beam. The forces bend the beam and thereby reduce the gap to the 
grounded substrate. This action, in turn, increases the forces. At a certain voltage the 
electrostatic forces overcome the stress forces, the system becomes unstable, and the 
gap collapses. This critical voltage is called the pull-in voltage.

At applied voltages lower than the pull-in voltage, the beam stays in an equilibrium 
position where the stress forces balance the electrostatic forces. Figure 2-3 shows the 
potential field and the deformations for a 300 µm long 2D case. Similarly, Figure 2-4 
shows the steady-state solution in a 100-µm long 3D case with 58 V applied. Because 
the cantilever’s length in the 3D model is shorter (100 µm), the structure’s stiffness is 
higher and a much higher applied voltage is required to achieve similar deformations 
as in the 2D model. Figure 2-5 shows the shape of the cantilever’s deformation 
extracted from 3D results along the long edge.

When solving for a level higher than the pull-in voltage, the solution ceases to converge 
before the beam touches the substrate. This is an effect of the ALE method not being 
able to handle topology changes. By scanning over different applied voltages and using 
the parametric solver, you can study the beam’s behavior and estimate the pull-in 
voltage. Figure 2-6 shows the deflection of the beam’s end in a 2D model for different 
applied voltages.
 2 :  M E M S  A C T U A T O R  M O D E L S



Figure 2-3: (2D model) The potential field and deformations at the cantilever beam’s 
equilibrium position for an applied voltage of 6.3 V.

Figure 2-4: (3D model) Steady-state solution for the 3D cantilever-beam model with an 
applied voltage of 58 V. The boundaries display the electric potential; the arrows show the 
electric field; the black edges indicate the non-deformed beam geometry; and the white 
edges delineate the deformed geometry.
C A N T I L E V E R  B E A M  |  11
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Figure 2-5: (3D model) The deformed shape of the cantilever along the long edge. This 
result is obtained from the 3D model.

Figure 2-6: (2D model) Vertical displacement at the beam tip as a function of the applied 
voltage. The solution ceases to converge just before the beam touches the substrate.
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The Figure 2-6 indicates that the pull-in voltage of the 300 µm long cantilever beam 
is somewhere between 6.3 V and 6.4 V. Using a finer mesh and computing the 
solution for a number of voltages in this range should reduce the size of this interval. 
For comparison, computations in Ref. 1 lead to the pull-in voltage of 

where c1 = 0.07, c2 = 1.00, and c3 = 0.42; g0 is the initial gap between the beam and 
the ground plane; and 

.

If the beam has a narrow width (W) relative to its thickness (H) and length (L), Ê is 
Young’s modulus, E. Otherwise, Ê is the plate modulus, E/(1 − η2), where η is 
Poisson’s ratio. Because the calculation in Ref. 1 uses a parallel-plate approximation for 
calculating the electrostatic force and because it corrects for fringing fields, these 
results are not directly comparable with those from the simulation. Inserting the data 
from the model in the formula and using an infinite width, W, to disable the 
fringing-field correction gives VPI = 6.35 V. Setting W = 40 µm results in VPI = 6.28 V. 
Here is some COMSOL Script code that calculates the analytical pull-in voltages:

% pull-in.m - calculates the analytical value for the pull-in
%   voltage
W = 40e-6; H = 2e-6; L = 300e-6;
gap = 2e-6;
c1 = 0.07; c2 = 1.00; c3 = 0.42;
E = 153e9;
nu = 0.23;
eps0 = 8.854e-12;
Ehat = E; % or = E/(1-nu^2);
B = Ehat*H^3*gap^3;
Vpi = sqrt((4*c1*B)/(eps0*L^4*c2^2*(1+c3*gap/W))); % or W -> inf
fprintf(1,'Pull in voltage is %f V \n', Vpi);

Modeling in COMSOL Multiphysics

COMSOL Multiphysics translates the application-mode equations between the fixed 
and moving frames. The program keeps track of the movements using the Moving 
Mesh (ALE) application mode and a transformation matrix, which you compute from 
the material displacements at the beam’s boundaries. In this model the displacements 
are such that the forces’ change of direction is almost negligible, but the 

VPI
4c1B

ε0L4c2
2 1 c3

g0
W
------+⎝ ⎠

⎛ ⎞
----------------------------------------------=
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ˆ
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3
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transformation might be needed if this serves as a template for a simulation that deals 
with larger deformations. Using the force transformation and support for large 
deformations in the Plane Strain application mode makes bending through large angles 
possible. Because the cantilever beam has a constant potential, the electrostatic forces 
are always perpendicular to its surface. To ensure that these forces have this 
orientation, the model uses the Electrostatics application mode’s ability to calculate 
Maxwell’s surface stress tensors on boundaries to define the electrostatic force.

In the 3D case, the large-deformation option doesn’t dramatically affect the results. 
The difference in the z-displacement of the cantilever’s tip between the large 
deformation being on and off is less than 1%. However, the solution time more than 
doubles when the large deformation is activated. Thus in the 3D case this exercise uses 
only the linear stress-strain relationship (where the large deformation is off).

Here the 2D case examines a parametric study in which the applied voltage varies. 
However, because the solution time for the parametric solution in the 3D case might 
expand to several hours, for 3D this example solves only the static solution. If more 
detailed studies are required, you should then also conduct a parametric or 
time-dependent analysis.

Reference

1. R.K. Gupta, Electrostatic Pull-In Structure Design for In-Situ Mechanical Property 
Measurements of Microelectromechanical Systems (MEMS), Ph.D. thesis, MIT, 1997.

Model Library path: MEMS_Module/Actuator_Models/
ale_cantilever_beam_2d

Model Library path: MEMS_Module/Actuator_Models/
ale_cantilever_beam_3d
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Modeling Using the Graphical User Interface—2D Version

M O D E L  N A V I G A T O R

1 In the Model Navigator select 2D from the Space dimension list and then click 
Multiphysics.

2 From the list of application modes on the left side of the dialog box select  
MEMS Module>Structural Mechanics>Plane Strain and then click Add.

3 From the list of application modes select COMSOL Multiphysics>Deformed 

Mesh>Moving Mesh (ALE) and then click Add.

4 In the Multiphysics list on the right side of the dialog box select Frame (ale) then add 
MEMS Module>Electrostatics>Electrostatics to that list. As a result, the selected 
application modes in Model Navigator window look like this:

5 Click OK to close the Model Navigator.

G E O M E T R Y  M O D E L I N G

1 From the Options menu, choose Axes/Grid Settings.

2 Clear the Axis equal check box, then click OK.
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3 While holding down the Shift key, click the Rectangle/Square button on the Draw 
toolbar on the far left side of the graphical user interface; this action opens the 
Rectangle dialog box. Enter dimensions as in the following table, then click OK. 

4 Repeat the procedure to make another rectangle but with these dimensions:

5 Click the Zoom Extents button on the Main toolbar at the top of the graphical user 
interface.

The inner rectangle represents the cantilever beam and the outer rectangle the 
surrounding air. These two objects would be enough to model the geometry with 
an unstructured mesh. However, in this model you use a mapped mesh, and for that 
purpose you add a rectangle that divides the air into three subdomains. This helps 
you create a rectangular mesh later on.

6 Repeat the procedure to create a third rectangle with these dimensions:

PROPERTY VALUE

Width 300e-6

Height 2e-6

X 0

Y 2e-6

PROPERTY VALUE

Width 320e-6

Height 10e-6

X 0

Y 0

PROPERTY VALUE

Width 20e-6

Height 2e-6

X 300e-6

Y 2e-6
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The resulting geometry should look like that in the figure below.

Completed 2D model geometry.

P H Y S I C S  S E T T I N G S

Subdomain Settings—Electrostatics
1 Go to the Multiphysics menu and make sure that Electrostatics (emes) is selected.

2 Open the Physics>Subdomain Settings dialog box and select Subdomains 1, 3, and 4. 
The default settings (εr = 1) corresponds to air, so keep them.

3 While still in that dialog box, select Subdomain 2. For the relative permittivity, εr, 
enter the value 4.5 (for polysilicon). Click the Force tab. In the first row enter Fes. 
The software automatically generates the variables Fes_nTx_emes and 
Fes_nTy_emes for the electrostatic force components. Later on you use these 
variables to define the boundary load in the Plane Strain application mode.

4 Click OK.

Boundary Conditions—Electrostatics
1 From the Physics menu, open the Boundary Settings dialog box.

2 Select the Interior boundaries check box, then specify conditions as follows:

3 Click OK.

SETTINGS BOUNDARIES 
1, 3, 5, 7, 11–13

BOUNDARY 4 BOUNDARY 2 BOUNDARIES 6, 
8, 9, 10

Boundary condition Zero charge/
Symmetry

Electric 
potential

Ground Continuity

V0 V_in
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Subdomain Settings—Moving Mesh
1 From the Multiphysics menu, select Moving Mesh (ale).

2 In the Subdomain Settings dialog box select the those for air (Subdomains 1, 3, and 
4). Keep the default Free displacement setting.

3 While still in that dialog box select Subdomain 2. Inside the cantilever beam use 
Physics induced displacement. For the displacement variables, dx and dy, enter u and 
v, respectively. These are the displacements from the Plane Strain application mode.

4 Click OK.

Boundary Conditions—Moving Mesh
1 In the Boundary Settings dialog box, for the mesh displacements, dx and dy, enter 

the following values for outer settings (do not assign any settings for interior 
boundaries, which appear dimmed):

2 Click OK.

Application Mode Properties—Plane Strain
1 From the Multiphysics menu, choose Plane Strain (smpn).

2 From the Physics menu, open the Properties dialog box.

3 Click the Application Mode Properties button. From the Large deformation list, select 
On, then click OK.

4 Click OK to close the dialog box.

The large-deformation option ensures that the solver uses a nonlinear stress-strain 
relationship to calculate the results in the Plane Strain application mode.

Subdomain Settings—Plane Strain
1 In the Subdomain Settings dialog box select Subdomain 2 and enter the following 

settings. Later on you use the parametric solver to find an estimate for the pull-in 
voltage, thus you only need to specify Young’s modulus, E, Poisson’s ratio, ν, and 
the thickness.

SETTINGS BOUNDARIES 4, 6, 8 ALL OTHERS

dx u 0

dy v 0

SETTINGS SUBDOMAIN 2

 E 153e9

 ν 0.23
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2 While still in the dialog box select Subdomains 1, 3, and 4. To make this application 
mode inactive outside the cantilever, clear the Active in this domain check box.

3 Click OK.

Boundary Conditions—Plane Strain
1 From the Physics menu, select Boundary Settings. In the resulting dialog box verify 

that the Interior boundaries check box is cleared.

2 Click the Constraint tab. Select Boundary 3. From the Constraint condition list select 
Fixed.

3 Click the Load tab. Enter boundary loads according to the following table; when 
finished, click OK.

Fes_nTx_emes and Fes_nTy_emes are automatically generated variables from the 
Electrostatics application mode (_emes) that define the x- and y-components of the 
electrostatic force, respectively.

4 Click OK to accept the boundary conditions.

M E S H  G E N E R A T I O N

1 From the Mesh menu, open the Mapped Mesh Parameters dialog box.

2 Click the Boundary tab. Select Boundaries 1, 3, and 5.

3 Check the Constrained edge element distribution check box and type 5 in the 
Number of edge elements edit field.

4 Repeat the previous step for Boundaries 6 and 10, in turn, using the values 60 and 
4, respectively, for the Number of edge elements.

5 Click Remesh. 

6 When the mesher has finished, click OK.

The completed mesh should look like that in the following figure.

 α 4.15e-6

 ρ 2330

 thickness 20e-6

SETTINGS BOUNDARIES 3, 6, 8 BOUNDARY 4

Fx 0 Fes_nTx_emes

Fy 0 Fes_nTy_emes

SETTINGS SUBDOMAIN 2
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Mesh for the 2D model.

C O M P U T I N G  T H E  S O L U T I O N

1 From the Solver menu, open the Solver Parameters dialog box.

2 Go to the Solver list and select Parametric.

3 In the Parameter name edit field, type V_in.

4 In the Parameter values edit field type 1:6, 6.1:0.1:6.3. Because the cantilever 
deforms less at lower voltages, start with a long step (1.0 V) and then, when the 
solution gets closer to the pull-in value, use a shorter step (0.1 V).

5 Click OK.

6 Click the Solve button on the Main toolbar. 

Note: If you try to solve the model for higher values of the applied voltage (for 
example, 6.4) the solver ceases to find a proper solution and you receive an error 
message (“Failed to find a solution for all parameters, even when using the minimum 
parameter step.”). This indicates that you have exceeded the pull-in voltage. In that 
case, you can scroll up the log area of the solver’s Progress window to find out the 
latest parameter values that the solver tried to use. That way you can get a more 
accurate estimate for the pull-in voltage.
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PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows the von Mises stress at the last successful parameter value 
Vin(9) = 6.3 V. To see deformations inside the cantilever beam, follow these 
instructions:

1 From the Postprocessing menu, open the Plot Parameters dialog box.

2 On the General page select the Surface check box. Make sure the check boxes for all 
other plot types are cleared.

3 Click the Surface tab. Go to the Predefined quantities list and select Plane Strain 

(smps)>Total displacement.

4 Click Apply.

To visualize the deformed mesh in the air domain, do as follows:

1 Click the General tab. 

2 Clear the Element refinement: Auto check box and type 1 in the associated edit field. 
This makes a wireframe plot that represents the computational mesh.

3 Make sure that only the Surface and Geometry edges check boxes are selected.

4 Make sure that Frame (ale) is selected from the Frame list.

5 Click the Surface tab. From the Predefined quantities list on the Subdomain Data 
page, select Electrostatics (emes)>Electric potential. From the Fill style list in the 
Coloring and fill area, select Wireframe.

6 Click OK. This generates the plot in Figure 2-3 on page 11.

Next, plot the displacement of the cantilever beam’s tip as a function of the voltage:

1 From the Postprocessing menu, select Domain Plot Parameters.

2 Click the Title/Axis button. Click the option button next to the First axis label edit 
field and enter the label Applied voltage [V]. Click OK.

3 Click the Point tab. From the Point selection list, select Point 5. From the 
Predefined quantities list, select Plane Strain (smpn)>Y-displacement. From the Unit 
list, select um to get the plot unit micrometer.

4 Click OK to close the dialog box and generate the plot in Figure 2-6.

Modeling Using the Graphical User Interface—3D Version

M O D E L  N A V I G A T O R

1 In the Model Navigator select 3D in the Space dimension list, then click Multiphysics.
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2 From the list of application modes on the left side of the dialog box, select  
MEMS Module>Structural Mechanics>Solid, Stress-Strain. Click Add.

3 From the list of application modes, select COMSOL Multiphysics>Deformed 

Mesh>Moving Mesh (ALE) and then click Add.

4 In the Multiphysics list on the right side of the dialog box, select Frame (ale) then add 
MEMS Module>Electrostatics>Electrostatics to that list.

5 Click OK to close the Model Navigator.

G E O M E T R Y  M O D E L I N G

1 Click the Block button on the Draw toolbar.

2 In the Length area, set X to 100e-6, Y to 20e-6, and Z to 2e-6. In the Axis base point 
area, set Z to 2e-6.

3 Click OK.

4 Repeat that procedure to make another block but this time set X to 120e-6, Y to 
40e-6, and Z to 24e-6.

5 Click OK.

6 Click the Zoom Extents button on the Main toolbar.

Figure 2-7: The geometry for 3D cantilever beam model. The inner block represents the 
cantilever beam and the outer rectangle the surrounding air. Symmetry is defined along 
the plane y = 0.

O P T I O N S

Constants
1 From the Options menu, choose Constants.
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2 Define a constant named V0 by the expression 56[V] and give it the description 
Applied voltage.

3 Click OK.

P H Y S I C S  S E T T I N G S

Application Mode Properties—Solid, Stress-Strain
If you need more-precise results, try using the nonlinear stress-strain relationship. To 
do so select Properties from the Physics menu and set the Large Deformation property 
option to On. In this example, however, the final result differs less than 1% when the 
large deformation is not in use, so you can skip that step and continue directly from 
the subdomain settings.

Subdomain Settings—Solid, Stress-Strain
1 Go to the Multiphysics menu and make sure that the Solid, Stress-Strain (smsld) 

application mode is selected.

2 Open the Physics>Subdomain Settings dialog box and select Subdomain 1. To 
deactivate this application mode outside the cantilever, clear the 
Active in this subdomain check box.

3 While still in the dialog box, select Subdomain 2 and enter the following settings. 
Later on you use a static solver to find the cantilever’s displacement. Thus, you only 
need to specify Young’s modulus, E, and Poisson’s ratio, ν.

4 Click OK.

Boundary Conditions—Solid, Stress-Strain
1 From the Physics menu, select Boundary Settings.

2 Click the Constraint tab, then select Boundary 4. From the Constraint condition list 
select Fixed.

3 Select Boundary 5. From the Constraint condition list, select Symmetry plane.

PROPERTY VALUE

 E 153e9

 ν 0.23

 α 4.15e-6

 ρ 2330
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4 Click the Load tab. Select Boundary 6, then enter the following settings:

Here, dn_Tx_emes, dnTy_emes, and dnTz_emes are automatically generated 
variables from the Electrostatics application mode that define the x-, y-, and 
z-components of the electrostatic force towards the air.

5 Click OK to accept the boundary conditions.

Subdomain Settings—Moving Mesh
1 From the Multiphysics menu, select Moving Mesh (ALE).

2 In the Subdomain Settings dialog box select the air (Subdomain 1). Keep the default 
Free displacement settings.

3 While still in the dialog box, select Subdomain 2. Inside the cantilever beam use 
Physics induced displacement. For the displacement variables, dx, dy, and dz, enter u, 
v, and w, respectively. These are the displacements from the Solid, Stress-Strain 
application mode.

4 Click OK.

Boundary Conditions—Moving Mesh
1 In the Boundary Settings dialog box for the mesh displacements, enter these settings:

2 Click OK.

Subdomain Settings—Electrostatics
1 From the Multiphysics menu, select Electrostatics (emes).

2 From the Physics menu, open the Subdomain Settings dialog box.

3 For Subdomain 1, the default settings (εr = 1) corresponds to air, so keep them.

4 While still in the dialog box, select Subdomain 2. Clear the Active in this domain 
check box.

PROPERTY VALUE

Fx dnTx_emes

Fy dnTy_emes

Fz dnTz_emes

SETTINGS BOUNDARIES 
6, 7, 9, 11

BOUNDARIES 
1, 3, 8, 10, 12

BOUNDARY 2

dx u 0 not selected

dy v 0 0

dz w 0 not selected
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5 Click OK.

Boundary Conditions—Electrostatics
1 From the Physics menu, open the Boundary Settings dialog box.

2 First select all the boundaries and change the Boundary condition to Zero charge/

Symmetry.

3 Next select only Boundary 3, and for the Boundary condition select Ground.

4 Finally select Boundary 6. Change the Boundary condition to Electric potential, and 
in the V0 edit field type V0.

5 Click OK.

M E S H  G E N E R A T I O N

Click the Initialize Mesh button on the Main toolbar. The mesh consists of roughly 
3700 elements.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button from the Main toolbar; the Solver Parameters 
dialog box then opens.

2 In the General page change Linear system solver to FGMRES. Keep the default 
Preconditioner: Geometric multigrid.

3 Click the Settings button; the Linear System Solver Settings dialog box then opens.

4 Select Presmoother from the tree on the left.

5 Change Presmoother to Vanka.

6 Type 1 into the Number of iterations field; The default 2 operates equally well, but 
additional time will be spend for extra iterations.

7 In the Vanka update area type lm4 lm5 lm6 into the Variables field.

This defines the variables that produce zeros in the diagonal of the equation system 
matrix. lm4, lm5, and lm6 are the variables used on the boundaries of the Moving 
Mesh (ALE) application mode.

8 Select Postsmoother from the tree on the left.

9 Define same settings as for the presmoother (repeat steps 8–11).

10 Select Coarse solver from the tree on the left.
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11 Change Coarse solver to PARDISO.

For some difficult problems the default UMFPACK solver can be a more stable 
choice. But in general the PARDISO solver is more memory efficient and with 
multiprocessor computers you benefit from the parallel operation of the solver.

12 Click OK to close the Linear System Solver Settings dialog box.

13 Click OK to close the Solver Settings dialog box.

14 Click the Solve button on the Main toolbar. It takes a few minutes to compute the 
solution.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot show the von Mises stress slice plot. To see the deformed structure 
and the electrostatic fields inside the air, follow these instructions:

1 From the Options menu, select Suppress>Suppress Boundaries. Select Boundaries 8, 
10, and 12. Click OK.

2 Click the Camera Parameters button on the Camera toolbar. Change the 
Camera constraint to Z and the Mouse constraint to Horizontal, then click Close. Using 
the mouse, rotate the graphics 180 degrees so that the tip of the cantilever points 
toward you.

3 From the Postprocessing menu, open the Plot Parameters dialog box. In the Plot type 
area on the General page, clear the Slice check box and select the Boundary, Edge, and 
Arrow check boxes.

4 Click the Boundary tab. From the Predefined quantities list on the Boundary Data 
page, select Electrostatics (emes)>Electric potential.

5 Click the Edge tab. In the Edge color area, click first the Uniform color option and then 
the Color button. From the palette on the Edge Color dialog box, select white. Click 
OK.

6 Click the Arrow tab and go to the Subdomain Data page. From the 
Predefined quantities list, select Electrostatics (emes)>Electric field. In the Arrow 

positioning area go to the Number of points edit fields and enter 4 for x points, 7 for 
y points, and 5 for z points. Go to the Arrow parameters area. Change the Arrow type 
to Cone and the Arrow length to Normalized. Clear the Auto check box for the 
Scale factor and enter a value of 0.5.

7 Click OK.

8 On the Camera toolbar, click the Scene Light and Headlight buttons to turn them on.

To visualize the shape of the deformed cantilever, generate a domain plot:
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1 From the Postprocessing menu, select Domain Plot Parameters and then click the Line/

Extrusion tab.

2 From the Edge selection list, select 13.

3 From the Predefined quantities list in the y-axis data area, select  
Solid, Stress-Strain (smsld)>Z-displacement.

4 From the Unit list, select um to see the results in micrometers.

5 In the x-axis data area, select X from the drop-down list.

6 Click OK.
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Comb D r i v e

Introduction

Rectangular comb drives find use in a variety of MEMS applications. The following 
model of an electrostatically actuated comb drive opens and closes a pair of 
microtweezers. To facilitate controlled partial engagement, this design gives the comb 
fingers jagged edges. This model comes from Isabelle P. F. Harouche and Dr. Cyrus 
Shafai of the Department of Electrical and Computer Engineering, University of 
Manitoba, Canada (Ref. 1).

Model Definition

Figure 2-8 shows the microtweezers (top) and a close-up of part of the comb drive 
(bottom). Applying a voltage across the gaps between the combs actuates the tweezers. 
The structure is made of polysilicon and has a thickness of a few micrometers.

Figure 2-8: The microtweezers (top) and the comb-drive mechanism (bottom).
 2 :  M E M S  A C T U A T O R  M O D E L S



The model includes just a few of the teeth. It simulates only the comb drive and its 
attachment using double-folded beam springs. Taking advantage of symmetries means 
that you only have to set up a quarter of the geometry, see Figure 2-9.

Figure 2-9: Initial (undeformed) model geometry.

The upper half of the comb is fixed, as is the end of the beam spring. The system applies 
an electric potential to the beam spring and the lower comb; the upper comb is 
grounded. In the air surrounding the comb drive, the model solves the electrostatic 
equation

.

The electrostatic force density is

,

and the simulation applies it to each comb as a perpendicular boundary load.

Modeling in COMSOL Multiphysics

Because electrostatic forces attract the combs to each other, any geometric change has 
an impact on the electric field between them. To account for this effect, the model uses 
an arbitrary Lagrangian-Eulerian (ALE) method implemented in COMSOL 
Multiphysics’ Moving Mesh application mode. This application mode automatically 
keeps track of the movements and translate application mode equations between the 
fixed (reference) and moving frames.

∇ ε V∇( )⋅– 0=

Fes
εE2

2
----------=
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In this model the displacements are relatively large. Therefore, you use the Plane Stress 
application mode’s support for large deformations.

To define the electrostatic force, you use the Electrostatics application mode’s Maxwell 
surface stress tensor boundary variables.

The geometry of this model is rather complex and thus the boundary conditions are 
laborious to enter. For an example that is faster and easier to set up, see the Cantilever 
beam model, which is a good introduction to using the Moving Mesh application 
mode.

Results and Discussion

The following two figures show the comb drive and the electric field at equilibrium for 
an actuation voltage of 600 V.

Figure 2-10: The electric-potential field for an actuation voltage of 600 V.
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Figure 2-11: Displacements inside the comb drive at 600 V. The color scale that appears on 
the screen indicates displacements in the y direction.

The next figure plots the displacement at the tip of one of the fingers of the lower 
comb as a function of the actuation voltage. The teeth have some effect on the 
displacements, but in order to make step-by-step actuation possible (like a switch 
gear), they would need to be wider, almost touching each other.

To reduce actuation voltages it is common to construct comb drives with many more 
teeth than in this model. Preferably, you would model such comb drives using a 
periodic approximation, thereby allowing the simulation of only one pair of fingers. 
The model could handle plane stress analysis in a separate geometry using the 
parametric solver to find the displacement of the comb base as a function of the applied 
force. Then a boundary integration variable could integrate the force density and 
dictate the displacements.

Another extension of the model would include fringing-field effects. A full 3D model 
might not be realistic, but you could estimate the size of the fringing fields by 
modeling two fingers in both 2D and 3D. You could then include the result of this 
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simulation in the full 2D model as, for instance, an approximate correction factor 
applied directly to the actuation voltage.

Figure 2-12: The displacement of the innermost comb finger as a function of the actuation 
voltage. For mid-range voltages the teeth suppress the displacement so that it is almost 
linear with voltage. Without teeth in the comb you could expect that the displacement 
would resemble a quadratic function of the voltage.

Reference

1. Isabelle P. F. Harouche and C. Shafai, “Simulation of shaped comb drive as a 
stepped actuator for microtweezers application,” Sensors and Actuators A: Physical, 
2005.

Model Library path: MEMS_Module/Actuator_Models/comb_drive_2d
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Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 In the Model Navigator, select 2D in the Space dimension list.

2 Click Multiphysics.

3 From the Application Modes list select  
MEMS Module>Structural Mechanics>Plane Stress>Static analysis.

4 Click Add.

5 Click the Application Mode Properties button. From the Large deformation list, select 
On, then click OK.

6 From the Application Modes list, select 
COMSOL Multiphysics>Deformed mesh>Moving Mesh (ALE). Click Add.

7 Click the Appliction Mode Properties button and select Winslow in the 
Smoothing method list. Winslow smoothing works better for this model. 

8 Click OK to close the Appliction Mode Properties dialog box.

9 In the Multiphysics list on the right side of the Model Navigator, select Frame (ale).

10 From the Application Modes list, select MEMS Module>Electrostatics>Electrostatics.

11 Click Add.

12 Click OK to close the Model Navigator.

G E O M E T R Y  M O D E L I N G

Please follow these geometry-modeling steps carefully; the following discussion 
assumes that the boundary numbering is that resulting from these steps. After you 
complete the geometry it should have a total of 337 boundaries.

Notice also that you first enter the geometric objects as if they would be measured in 
micrometers (in other words, without the e-6 after all numbers) and then, scale the 
entire geometry by 10−6 to have it in SI units. This approach reduces the amount of 
typing and avoids the likely error of forgetting to include e-6 on one of the 
dimensions.

1 From the Draw menu, select Specify Objects>Rectangle to create rectangles 
(alternately, hold the Shift key and click on the Rectangle/Square button on the Draw 
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toolbar on the far left of the user interface). In the dialog box that opens, create four 
rectangles with these properties:

2 Select all the rectangles (use Ctrl+A) and click the Array button on the Draw toolbar.

3 Enter the data from this table:

4 Click OK.

5 Select all the rectangles and click the Union button on the Draw toolbar.

6 Create another rectangle with these properties:

7 Select both objects and click the Intersection button on the Draw toolbar.

8 Create seven new rectangles with these properties:

9 From the Draw menu select Create Composite Object.

NAME WIDTH HEIGHT X Y

R1 7 5 -3.5 81

R2 3 5 -1.5 86

R3 7 5 6.5 106

R4 3 5 8.5 101

DATA EXPRESSION

X displacement 20

Y displacement 10

X size 5

Y size 4

NAME WIDTH HEIGHT X Y

R1 91.5 60 0 81

NAME WIDTH HEIGHT X Y

R1 91.5 12 0 141

R2 86.5 12 0 69

R3 45 17 0 52

R4 150 2 45 54

R5 150 2 45 34

R6 25 15 20 25

R7 15 40 195 25
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10 In the dialog box that opens click Select All, then clear the Keep interior boundaries 

check box.

11 Click OK.

12 Create yet another rectangle:

13 Select all the objects and click the Scale button. Enter 1e-6 for both the X and Y 
scale factors.

14 Click OK.

15 Click the Zoom Extents button.

The completed comb-drive geometry.

P H Y S I C S  S E T T I N G S

Subdomain Settings—Electrostatics
1 From the Multiphysics menu, choose Electrostatics (emes).

2 Open the Subdomain Settings dialog box, choose Subdomain 1, and verify that the 
relative permittivity, εr = 1.

3 Select Subdomains 2 and 3.

4 For the relative permittivity, εr, enter the value 4.5 (polysilicon). 

5 Click the Force tab. On the first row enter Fes. COMSOL Multiphysics then 
automatically generates the variables Fes_nTx_emes and Fes_nTy_emes for the 

NAME WIDTH HEIGHT X Y

R1 235 178 0 0
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electrostatic force components. Later on you will use these variables to define the 
boundary load in the Plane Stress application mode.

6 Click OK.

Boundary Conditions—Electrostatics
1 From the Physics menu, select Boundary Settings.

2 In the dialog box that opens, make sure that the Interior boundaries check box is 
selected. 

3 Enter the settings in the following table. Note that the physical boundaries of the 
upper comb are all grounded, while those of the lower comb have an electric 
potential of Vin. The arms and the contact pads of the lower comb are electrically 
inactive. When you have entered all boundary conditions click the Groups tab and 
enter the group names. This helps you identify the boundaries if you want to make 
changes to the model. 

4 Click OK.

SETTINGS BOUNDARIES 1-3, 
5-14, 16, 18, 20, 337

BOUNDARIES 85-87, 
168-171, 173, 175, 
331-336

BOUNDARIES 4, 15, 
21-36, 69-84, 88-103, 
136-167, 172, 174, 176, 
209-240, 273-305

BOUNDARIES 17, 
19, 37–68, 104–135, 
177–208, 241–272, 
306–330

Boundary 
condition

Zero charge/
symmetry

Continuity Electric potential Ground

V0 V_in

Group 
name

Zero charge/
symmetry

Continuity V_in Ground
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Boundary conditions for the Electrostatics application mode. Grounded boundaries: cyan; 
electric potential (Vin): green; Zero charge/Symmetry boundaries: black; Continuity 
boundaries: blue.

Subdomain Settings—Moving Mesh
1 From the Multiphysics menu, select Moving Mesh (ALE) (ale).

2 From the Physics menu, open the Subdomain Settings dialog box.

3 Select Subdomain 1 (air) and make sure that the Free displacement option is selected.

4 Select Subdomains 2 and 3 (comb drives).

5 Select the Physics included displacement check box. For the displacement variables dx 
and dy, enter the values u and v, respectively. These variables represent the 
displacements calculated in the Plane Stress application mode.

6 Click OK.

Boundary Conditions—Moving Mesh
1 From the Physics menu, select Boundary Settings. In the dialog box that opens, make 

sure that the Interior boundaries check box is not selected. 
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2 Enter the settings in the following table:

3 Click OK. 

Boundary settings for Moving Mesh (ALE) application mode. Inactive boundaries: black; 
symmetry boundaries: blue; moving comb drive: cyan; the fixed outer boundaries: green.

Subdomain Settings—Plane Stress
1 From the Multiphysics menu, choose Plane Stress (smps).

2 Open the Subdomain Settings dialog box.

SETTINGS BOUNDARIES 
1,14, 18

BOUNDARIES 2, 
20, 337

BOUNDARIES 4, 
15, 17, 19, 21–336

dx 0 0 u

dy 0 v

Group name Symmetry Fixed Comb drive
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3 Choose Subdomains 2 and 3, then enter these settings:

The thermal expansion coefficient (α) is needed only if you have included thermal 
expansion in the load settings. Similarly, the density (ρ) is used only in 
time-dependent, eigenfrequency, and frequency-response analyses. In this case you 
use a nonlinear parametric analysis, and it is therefore not necessary to enter these 
values.

4 While still in the dialog box, select Subdomain 1. To make sure that the application 
mode is inactive outside the comb drive, clear the Active in this domain check box.

5 Click OK.

Boundary Conditions—Plane Stress
1 Open the Boundary Settings dialog box and make sure that the Interior boundaries 

check box is not selected.

2 On the Constraint and Load pages, define boundary conditions according to the 
following table. On the Load page, click the  
Edge load is defined as load/area using the thickness option button. This makes the 
loads from the Electrostatics application mode match the structural loads.

PROPERTY VALUE

 E 158e9

 ν 0.22

 thickness 2e-6

SETTINGS BOUNDARIES 
3, 5–13,16

BOUNDARIES 
19, 85–87, 168, 
170

BOUNDARIES 
169, 171, 173, 
175, 331–336

BOUNDARIES 4, 15, 17, 
21–84, 88–167, 172, 174, 
176–330

Constraint condition Symmetry Fixed Free

Edge load X dir. 0 0 0 Fes_nTx_emes

Edge load Y dir. 0 0 0 Fes_nTy_emes

Group name Symmetry Fixed Free Es force
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3 Click OK. 

Boundary settings for the Plane Stress application mode. Electrostatically actuated 
boundaries: cyan; symmetry boundaries: blue; fixed boundaries: green; free boundaries 
(and inactive boundaries): black.

M E S H  G E N E R A T I O N

1 From the Mesh menu, choose Free Mesh Parameters.

2 On the General page, select Fine from the Predefined mesh sizes list.

3 Click the Remesh button and then click OK.
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The mesh generated using the predefined settings for a fine mesh.

C O M P U T I N G  T H E  S O L U T I O N

1 From the Solve menu, choose Solver Parameters.

2 On the General page, select Parametric from the Analysis list.

3 In the Parameter name edit field type V_in, and in the Parameter values edit field 
type 0:50:600.

4 Click the Advanced tab.

5 In the Scaling of variables area, select Manual from the Type of scaling list.

6 Type V 100 u 1e-4 v 1e-4 x 1e-4 y 1e-4 in the Manual scaling edit field.

This scales the variables using the magnitudes of the dependent variables (about 100 
for the potential V and about 10−4 for the displacement (u, v, and w). The Lagrange 
multipliers have a magnitude of roughly 1 and do not need any scaling.

7 Click OK.

8 Click the Solve button on the Main toolbar.
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P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default results show von Mises stresses with colors on the deformed shape for the 
last parametric value, Vin(12) = 600 V. To study the electric potential in the moving 
frame do the following:

1 From the Postprocessing menu, select Plot Parameters to open the like-named dialog 
box.

2 On the General page, verify that only Surface plot type is selected and that the 
selection in the Frame list is Frame (ale).

3 On the Surface page, select Electrostatics (emes)>Electric potential from the 
Predefined quantities list.

4 Click Apply to generate the plot displayed in Figure 2-10 on page 30.

To see the deformation inside the comb drive do as follows:

5 On the Surface page, select Plane Stress (smps)>Total displacement from the 
Predefined quantities list.

6 Click Apply to generate the plot in Figure 2-11.

It is also possible to visualize the deformed mesh in the air domain:

7 On the General page clear the Auto Element refinement check box, then type 1 in the 
associated edit field.

8 Click the Surface tab.

9 From the Predefined quantities list, select 
Moving Mesh (ALE) (ale)>y-displacement (ale).

10 From the Fill style list, select Wireframe.

11 Click OK.

The resulting plot is reproduced in Figure 2-13.
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Figure 2-13: The deformed mesh at an actuation voltage of 600 V. The color scale that 
appears on the screen represents displacements in the y direction.

Next, plot the displacement of the central tooth as a function of the applied voltage:

12 From the Postprocessing menu, choose Domain Plot Parameters.

13 On the General page, click the Title/Axis button. Select the option button next to the 
First axis label edit field, then enter the label Actuation voltage [V]. Click OK.

14 Click the Point tab. Select Point 12. From the Predefined quantities list, select Plane 

Stress (smps)>Y-displacement. From the Unit list, select um (for micrometers).

15 Click OK. The plot given in Figure 2-12 on page 32 appears in a new window.

Finally, to reproduce the plot that appears in the Model Navigator when you open 
the preconfigured model, do the following:

16 Go to the Postprocessing menu and select Plot Parameters.

17 On the General page select the Element refinement Auto check box.

18 Make sure that only the Surface check box is selected in the Plot type area.

19 On the Surface page, select Electrostatics (emes)>Electric potential from the 
Predefined quantities list.

20 From the Fill style list, select Filled, then click OK.

21 Click the Zoom Extents button on the Main toolbar.
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C apa c i t i v e  3D Comb D r i v e

This model illustrates how to approach a 3D electrostatics problem, create a geometry 
using the array and extrusion tools, and compute capacitances using the Electrostatics 
application mode’s port boundary condition.

Introduction

Capacitive comb drives are commonly used both as actuators and position sensors. For 
actuators, electrostatic forces typically pull on a MEMS flexure to provide highly 
accurate position control. The following model focuses on the other common usage 
of comb drives: position measurement. Many approaches exist for positional 
measurements with MEMS devices including changes in capacitance or inductance, 
optical schemes, and others. Of these, capacitance measurement is the most widely 
used, particularly in microaccelerometers. 

A pair of interdigitated combs for capacitance-based position measurement. Note that the 
fingers of one comb do not touch those of the other.

Comb drives and capacitive sensors based on them consist of a series of interdigitated 
tines or fingers. In a pair of interdigitated combs (see the previous figure) the fingers 
of one comb do not touch those of the other comb, but they do slide in and out 
relative to each other with a variable overlap. The fingers in MEMS combs are typically 
a few microns wide and 40 to 100 microns long. The gap between the interdigitated 
tines is normally 0.5 to 2 microns.
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You typically can get a rough idea of a drive’s capacitance by approximating the 3D 
structure as multiple parallel-plate capacitors. This sizing approach is reasonable if the 
structures are tall compared to the gap and if fringing of the electrostatic field is 
negligible—which is not the case in most plated MEMS structures. In many cases the 
tine height is on the same order as its width as well as the gap between the tines; in 
fact, it can sometimes even be smaller. In these configurations electrostatic fringing 
dominates the field, and the parallel-plate approximation can be quite inaccurate, even 
for sizing. Here a quick 3D analysis of the electrostatic field gives a capacitance value 
that you can combine with the parallel-plate theory to provide considerable design 
information. Additionally, you can use the capacitance in reduced-order electrical 
circuit models to simulate the electrical system as a whole.

Theoretical Background

The energy required to charge a capacitor should equal that of the electrostatic field, 
which is

.

We is readily available in the Electrostatics application mode; the software calculates it 
by integrating across the domain

where D is the electric displacement, and E is the electric field. The capacitance, C, is 
related to the charge on the two conductive plates, Q, and the voltage difference across 
those plates, ∆V, by

.

Now calculate C from the stored electric energy in the capacitor, We, and the voltage 
across the capacitor:

.  (2-1)

We
Q2

2C
--------=

We D E⋅( ) Ωd
Ω
∫=

C Q
∆V
--------=

C Q2

2We
----------- C2∆V2

2We
------------------ C⇒

2We

∆V2
-----------= = =
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Results and Discussion

The next figure shows the electric potential on the comb drive’s surfaces, the silicon 
substrate, and the bounding box. Calculating capacitance using the energy-storage 
distribution in the electric field and integrating over the volumetric domain leads to a 
value of 0.021 pF. Changing the geometry—for example, by shifting the fingers on the 
right side closer to those on the left—likewise changes the value of the stored energy 
and thus the capacitance.

Figure 2-14: Electric potential on the surfaces of a comb drive.

Modeling in COMSOL Multiphysics

Static comb drives are relatively easy to set up in COMSOL Multiphysics. They 
typically consist of a series of interdigitated rectangles of the same size. Thus you can 
create one rectangle and reproduce it in a regular pattern it to create the fingers of a 
comb. Then simply copy, paste, and move the entire geometry to create a second 
comb. Finally recall that electrostatic fields have only one degree of freedom per node: 
the voltage. Therefore these types of models do not tend to lead to huge system 
matrices and memory requirements. True, you can make problems quite large, but you 
can generally expect quick solutions to reasonably complex 3D electrostatics problems.
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To solve electrostatics problems in the MEMS Module, use the Electrostatics 
application mode, which solves for the electric potential.

Model Library path: MEMS_Module/Actuator_Models/comb_drive_3d

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator to the New tab and select 3D in the Space dimension list.

2 Select Application modes>MEMS Module>Electrostatics>Electrostatics.

3 Click OK.

G E O M E T R Y  M O D E L I N G

Work-Plane Settings
1 From the Draw menu choose Work-Plane Settings.

2 Click the Quick tab, and on that page click the x-y button.

3 For the z-value use 0 (the default) and click OK.

Drawing the 2D Work Geometry
1 Shift-click the Rectangle/Square icon on the Draw toolbar and create a rectangle:

2 Click the Zoom Extents button on the Main toolbar.

3 From the Draw select first Modify and then Array.

4 In the Array dialog box enter these values:

5 Click OK.

6 Click the Zoom Extents button on the Main toolbar.

7 Press Ctrl+A to select all the geometry objects.

NAME WIDTH HEIGHT BASE X Y

R1 40e-6 2e-6 Corner 0 0

DISPLACEMENT ARRAY SIZE

X Y X Y

0 8e-6 1 5
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8 Press Ctrl+C and then Ctrl+V to copy and paste the selected objects.

9 In the Paste dialog box that appears, enter these values:

10 Click OK.

11 Click the Zoom Extents button on the Main toolbar. 

Creating the comb-drive geometry using a 2D work plane.

12 Select rectangle R10 and delete it.

13 Add two more rectangles:

14 Select the rectangles forming the left comb (R1, R2, R3, R4, R5, and R11).

15 To create a composite object, click the Union button on the Draw toolbar.

16 Click the Delete Interior Boundaries button near the bottom of the Draw toolbar.

17 Select the rectangles that form the right comb (R6, R7, R8, R9, and R10).

18 Click the Union button.

DISPLACEMENT

X Y

14e-6 4e-6

SIZE POSITION

NAME WIDTH HEIGHT BASE X Y

R10 10e-6 26e-6 Corner 54e-6 4e-6

R11 10e-6 34e-6 Corner -10e-6 0
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19 Click the Delete Interior Boundaries button.

Two composite objects, one for each side of the comb.

Next draw the outline of the substrate and bounding air space for the analysis. In this 
case, extend the space 10 microns on either side of the comb teeth.

20 Create another rectangle:

21 Click Zoom Extents.

The comb with the substrate and bounding air space.

SIZE POSITION

NAME WIDTH HEIGHT BASE X Y

R1 74e-6 54e-6 Corner -10e-6 -10e-6
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Extruding the Geometry
First extrude the two comb drives into a 3D geometry:

1 From the Draw menu, choose Extrude.

2 From the Objects to extrude list, select CO2 and CO3.

3 In the Distance edit field, type 2e-6.

4 Click OK.

5 Click then Zoom Extents button on the Main toolbar.

The extruded comb drive alone.

Now continue extruding, this time with the air surrounding the combs.

6 Switch back to the 2D window; to do so, go to the top of the work area and select 
the tab for Geom2.

7 From the Draw menu, choose Extrude.

8 In the Objects to extrude list, select R1.

9 In the Distance edit field, type 12e-6.

10 Click OK.

Because it is not necessary to model the electrostatic field inside the combs, subtract 
the comb geometries from the air; later you model the electrostatic field only in the 
air and substrate.

11 On the Draw toolbar, click the Create Composite Object button.

12 In the Set formula edit field, type EXT3-EXT1-EXT2.

13 Clear the Keep interior boundaries check box.
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14 Click OK.

To complete the 3D geometry, extrude the silicon substrate under the two combs.

15 Click the Geom2 tab to switch back to the 2D geometry.

16 From the Draw menu, choose Extrude.

17 From the Objects to extrude list, select R1.

18 In the Distance edit field, type -10e-6.

19 Click OK.

Extruding the geometry to create the silicon substrate below the combs.

P H Y S I C S  S E T T I N G S

Subdomain Settings
The model consists of two subdomains: the first is the silicon substrate under the comb 
drives; the second is the surrounding air. Set a value of 11.9 for the substrate’s relative 
permittivity and use the default value of  1.0 for the air.

1 From the Physics menu, choose Subdomain Settings.

2 Enter the following values for the subdomains; when finished, click OK.

SETTINGS SUBDOMAIN 1 SUBDOMAIN 2

εr (isotropic) 11.9 1.0

ρ 0 0
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Boundary Conditions
Continue the physics settings by specifying the boundary conditions. The first comb is 
tied to the ground, and the second is defined as a port. You model the surrounding 
boundaries with the symmetry condition.

1 From the Physics menu, choose Boundary Settings.

2 On the Conditions page specify the following settings:

3 While still in the Boundary Settings dialog box select one of the port boundaries and 
select the Select by group check box. Doing so selects all port boundaries. Then click 
the Port tab.

4 On the Port page, verify that the port number is 1. Then select the Use port as input 
check box, and from the Input property list select Energy method. Using these 
settings ensure that a unit voltage is forced on the boundaries of the second comb 
drive, and the capacitance value is integrated from electric energy density.

Boundary conditions for the two combs: The one on the left is grounded, and the one on the 
right is defined as a port. All other boundaries have symmetry conditions.

M E S H  G E N E R A T I O N

Click the Initialize Mesh button on the Main toolbar. The resulting mesh consists of 
roughly 7800 elements.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar. The model contains about 12,400 degrees 
of freedom and COMSOL Multiphysics solves it in just a few seconds.

SETTINGS BOUNDARIES 1–5, 7, 
12, 13, 52, 53

BOUNDARIES 8–11, 
14–27, 42–46

BOUNDARIES 28–41, 
47–51

Boundary 
condition

Zero charge/
Symmetry

Ground Port
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PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To see the voltage distribution on the surface of the comb drive (Figure 2-14), 
suppress some of the outer boundaries. The suppression visualization settings are 
available from the Options menu.

1 From the Postprocessing menu, select Plot Parameters.

2 In the dialog box that opens, click the General tab.

3 Clear the Slice check box and select the Boundary check box.

4 Click OK.

5 From the Options menu, choose Suppress>Suppress Boundaries.

6 Select Boundaries 1, 2, 4, 5, and 7.

7 Click OK.

8 On the Main toolbar, click the Postprocessing Mode button to return to the 
postprocessing plot.

Computing the Capacitance
As a final step, display the capacitance value computed by integrating the electric 
energy density over the geometry.

1 From the Postprocessing menu, choose Data Display>Global.

2 In the Expression edit field, type C11_emes.

3 Click OK.

The value of the integral, 2.1·10−14—corresponding to 0.021 pF—appears in the 
message log at the bottom of the screen.
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Ge c ko Foo t

Introduction

In nature, various species apply advanced techniques for specialized tasks. For instance, 
gecko lizards use dry adhesion forces such as Van der Waals forces to climb walls. Dry 
adhesion is an interesting phenomena for sticking because it requires no energy to hold 
on, and no residue is left on the surface. Gecko lizards have inspired researchers to 
develop synthetic gecko foot hairs to be used in, for example, robot application for 
purposes where humans cannot go.

Model Definition

Hair on a gecko foot is a very complex biological structure with hierarchical nano and 
micro sections. On its feet, a gecko has billions of nanoscale hairs that are in contact 
with surfaces while it climbs. These nanohairs are attached to microscale hairs, which 
are on the tip of a gecko’s toes.

Critical design parameters for nanohairs to achieve the optimal sticking are hair length, 
detach angle, distance between nanohairs, and the cross section area of one hair. By 
varying these parameters, the hairs can stick onto very rough surfaces, but on the other 
hand they must be stiff enough to avoid sticking to each others. Proper material 
choices help achieving the design goals while providing the required adhesion force. 
Typically the Young’s modulus for materials used in synthetic nanohair vary in between 
1 GPa and 15 GPa.

This model contains the hierarchy of synthetic gecko foot hair where cantilever beams 
both in nano and micro scales describe the seta and spatula parts of one spatular stalk 
attached to a gecko foot. The basis of the analyzed structure is the micro stalk with 
these dimensions: width, 4.53 µm; height, 4.33 µm; and length, 75 µm. At the end of 
the micro hair, 169 nanohairs are attached and they have dimensions of 0.18 µm, 
0.17 µm, and 3 µm, respectively. The micro hair is fixed at the far end, while the 
contact and friction forces appear as surface loads at the end of each nanohair. The 
free-body diagram of one micro/nanohair (see nearby figure) illustrates the applied 
forces, which are set to 0.4 µN for the contact force and 0.2 µN for the friction force 
with 60° contact angle to target surface. The structure is made of β-keratin with a 
Young’s modulus of 2 GPa and a Poisson’s ratio of 0.4. The model was inspired by Ref. 
1.
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Results and Discussion

The following plot shows the von Mises effective stress in the model, stress that reaches 
a maximum at 97.73 MPa. The total displacement is 13.01 µm. This information helps 
in selecting the material and certain criteria for polymers to be used in synthetic gecko 
foot design as well as in setting design parameters for the geometrical dimensions. 

The maximum von Mises stress in the analyzed model is almost twice the value of the 
material’s yield stress. Further analysis requires either a stronger material or some 
geometrical changes. An optimal solution likely depends on a combination of both 
these design parameters.
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Figure 2-15: Von Mises stress in a synthetic Gecko foot with a length of the microbeam of 
75 µm and nanohairs with a length of 3 µm. This plot shows only the end with the 
nanohairs.
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Model Library path: MEMS_Module/Actuator_Models/gecko_foot
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Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator to create a new model.

2 Select 3D from the Space dimension list.

3 Select the MEMS Module>Structural Mechanics>Solid, Stress-Strain application mode.

4 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 Choose Options>Constants to open the Constants dialog box.

2 Defined the following constants by typing the name, expression, and description 
into the table using a new row for each constant (the Description field is optional):

3 Click OK.

G E O M E T R Y  M O D E L I N G

To be able to mesh the microscale and nanoscale sections independently, use the 
assembly feature, which keeps each geometry object as a separate part. First create the 
microscale part as a block. Then create one of the nanohairs and use the array feature 
to create an array of identical nanohairs.

1 From the Draw menu, choose Use Assembly.

2 Click the Block button on the Draw toolbar. Enter the following dimensions in the 
Length area: X: 4.53e-6, Y: 75e-6; Z: 4.33e-6.

Use the default values for all other properties, then click OK to create the block.

NAME EXPRESSION DESCRIPTION

Fc 0.4[uN] Contact force

Ff 0.2[uN] Friction force

Fcy Fc*sin(pi/3) Contact force, y component

Fcz Fc*cos(pi/3) Contact force, z component

Ffy Ff*cos(pi/3) Friction force, y component

Ffz Ff*sin(pi/3) Friction force, z component

Area 0.17[um]*0.18[um] Cross-sectional area of the spatulae
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3 Click the Block button on the Draw toolbar to create another block. Enter the 
following dimensions in the Length area: X: 0.18e-6, Y: 3e-6; Z: 0.17e-6. Enter the 
following base point in the Axis base point area: x: 0, y: -3e-6; z: 0.

Use the default values for all other properties, then click OK to create the block.

4 Make sure that the second block (BLK2) is selected.

5 Click the Array button on the Draw toolbar to make an array of blocks similar to 
BLK2. Together they form a group of 13 ×13 nanohairs. Enter the following values 
in the Displacement area: x: (4.53e-6-0.18e-6)/12, y: 0; z: (4.33e-6-0.17e-6)/
12. Enter the following values in the Array size area: x: 13, y: 1; z: 13.

6 Click OK.

7 Press Ctrl+A to select all the objects.

8 Choose Mate Objects from the Draw menu. In the Mate Objects dialog box, clear the 
Create imprints check box, then click OK.

This final step creates the identity pairs that connect the parts to form a continuous 
field problem in the entire assembly. There are a total of 169 pairs, one for each 
nanohair. There is no need to create imprints of the nanohairs because the 
displacement field is continuous across the entire assembly, and there are no loads 
or constraints where the nanohairs meet the microsection.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Physics menu choose Subdomain Settings.

2 Select all the subdomains and then enter the following material properties on the 
Material page: E: 2e9 (Young’s modulus), ν: 0.4 (Poisson’s ratio).

3 Click OK.

Boundary Conditions
Specify the loads and constraints.

1 From the Physics menu, choose Boundary Settings.

2 Select Boundary 83.

3 Select Fixed from the Constraint condition list.

4 Use the zoom tools and rotate the geometry so that you can reach the ends of all 
nanohairs. Then disable the zoom and rotate operations by clicking the Orbit/Pan/

Zoom button on the Camera toolbar so that you can use the mouse to select 
boundaries.
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5 Using the mouse, select the ends of all the nanohairs. The following table contains 
the numbers for all these boundaries:

6 Click the Load tab.

7 Enter the following loads: Fx: O, Fy: (-Fcy+Ffy)/Area, Fz: (Fcz-Ffz)/Area.

8 Click OK.

M E S H  G E N E R A T I O N

Create swept meshes for each subdomain, which is possible due to the assembly 
geometry where each block is an individual part.

1 Choose Mesh>Interactive Meshing>Mesh Selected (Mapped). This creates a mapped 
2D mesh on all nanohair ends.

2 Choose Mesh>Swept Mesh Parameters.

3 Select all subdomains except Subdomain 14 (the microsection).

4 On the Element Layers page select the Manual specification of element layers check 
box, then type 8 in the Number of element layers edit field.

5 Click the Mesh Selected button, then click OK.

This creates hexahedral mesh elements for all the nanohairs. Next create another swept 
hexahedral mesh for the microsection.

1 Choose Mesh>Mapped Mesh Parameters.

2 8 14 20 26 32 38 44 50 56 62 68 74

86 92 98 104 110 116 122 128 134 140 146 152 158

164 170 176 182 188 194 200 206 212 218 224 230 236

242 248 254 260 266 272 278 284 290 296 302 308 314 

320 326 332 338 344 350 356 362 368 374 380 386 392 

398 404 410 416 422 428 434 440 446 452 458 464 470

476 482 488 494 500 506 512 518 524 530 536 542 548 

554 560 566 572 578 584 590 596 602 608 614 620 626

632 638 644 650 656 662 668 674 680 686 692 698 704

710 716 722 728 734 740 746 752 758 764 770 776 782

788 794 800 806 812 818 824 830 836 842 848 854 860

866 872 878 884 890 896 902 908 914 920 926 932 938 

944 950 956 962 968 974 980 986 992 998 1004 1010 1016
G E C K O  F O O T  |  59



60 |  C H A P T E R
2 Select Boundary 83 (the back end of the microsection).

3 Click the Edge tab, then select Edges 162, 163, 164, and 168.

4 Select the Constrained edge element distribution check box and type 5 in the 
Number of edge elements edit field.

5 Click the Boundary tab, then click the Mesh Selected button. Click OK.

6 Choose Mesh>Swept Mesh Parameters.

7 Select Subdomain 14 (the microsection).

8 On the Element Layers page select the Manual specification of element layers check 
box, then type 10 in the Number of element layers edit field.

9 Click the Mesh Selected button, then click OK.

The total number of mesh elements should be approximately 1600.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar to start the analysis.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Choose Postprocessing>Plot Parameters.

2 On the General page clear the Slice check box. Select the Subdomain and Deformed 

shape check boxes in the Plot type area.

3 Click the Subdomain tab.

4 Select MPa from the Unit list to display the von Mises stress in MPa instead of Pa.

5 Click OK.
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P r e s t r e s s e d  M i c r om i r r o r

Introduction

One method of creating spring-like structures or inducing curvature in plated 
structures is to plate materials onto a substrate such that the layer has a residual stress 
after the plating process. The plating process can control this stress, which can be either 
compressive or tensile, even for similar materials. The automotive industry has studied 
this phenomenon at length because highly stressed chrome is appreciably shinier than 
nonstressed chrome. MEMS device manufacturers sometimes use this effect to create 
curved cantilevers or spring-loaded micromechanical structures that lift off the 
substrate when deliberately undercut by an etchant.

One such device is the electrostatically controlled micromirror. It is typically quite 
small, and arrays of such devices can implement a projection system. They serve as 
optical redirectors and similar reflection devices. This section shows the fundamentals 
of how to set up and solve lift-off of a prestressed plated device. 

Model Definition

This single-physics model uses 3D structural analysis. The micromirror has a stiff, flat, 
reflective center portion, which is supported by four prestressed plated cantilever 
springs. To keep the mesh size small and the solution time reasonable, this exercise 
studies the plated structure with two layers. It also assumes that the plating process 
creates equal and opposite (compressive and tensile) initial stresses in the top and 
bottom layers. This convenience makes the model straightforward to set up. You can 
make the initial-stress distribution as complex as desired and set it up as shown in this 
example. Depending on the magnitude of the deformations, you are likely best advised 
to solve such simulations with a large-deformation analysis using a nonlinear or 
parametric nonlinear solver, noting that the latter is more likely to converge. Thus this 
illustrative model uses the large-deformation analysis type with both the linear and 
parametric linear solvers.

Note in particular that a 3D structure with thin layers such as the one in this model 
leads to a very large unstructured tetrahedral mesh. To avoid this case, this example 
first generates a 2D quadrilateral mesh by mesh mapping and then extrudes it into 3D 
to produce a mesh with hexahedral (brick) elements. This way you can have the mesh 
generator create structured elements with a high aspect ratio.
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One of the key process parameters you wish to determine in this class of problem is 
generally what prestress level is necessary to result in a desired lift-off. Another 
common concern is how much effect variations in the prestress might have on 
displacement. A parametric study answers this question.

Results and Discussion

The following two images compare lift-off for aluminum and steel plates. The steel, 
being harder than aluminum, deforms less.

Figure 2-16: Lift-off for aluminum (top) and steel (bottom).

The following two figures show the mirror response to the different levels of applied 
prestress. According to Figure 2-17, the center point deflection is almost linearly 
dependent of the prestress. Figure 2-18 shows the mirror’s curvature along its 
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centerline for different values of prestress. In line with expectations, increasing the 
stress bends the mirror more. 

Figure 2-17: Vertical deflection of the center of the mirror for different prestress levels.

Figure 2-18: Mirror curvature along the centerline for different prestress levels.
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Because of bonding the structure cannot move freely when it cools down, which causes 
residual stresses. The following plot shows this released stress state using the first 
principal stress after deformation.

Figure 2-19: Plot of the first principal stress after deformation.

Reference

1. G. Kovacs, Micromachined Transducers Sourcebook, WCM McGraw-Hill, 1998.

Model Library path: MEMS_Module/Actuator_Models/micromirror

Modeling Using the Graphical User Interface 

M O D E L  N A V I G A T O R

1 In the Model Navigator click the New tab. From the Space dimension list, select 3D.

2 In the list of application modes select 
MEMS Module>Structural Mechanics>Solid, Stress-Strain>Static analysis.
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3 Click OK.

O P T I O N S  A N D  S E T T I N G S

Constants
1 From the Options menu, choose Constants.

2 Enter a variable with the Name Stress, the Expression 8[GPa], and the description 
Initial normal stress.

3 Click OK.

Work Plane
1 From the Draw menu, select Work-Plane Settings.

2 Click the Quick tab.

3 Choose the x-y plane, and for z use a value of 0.

4 Click OK.

Axes and Grid Settings
1 From the Options menu, choose Axes/Grid Settings.

2 Click the Grid tab.

3 Clear the Auto check box.

4 In both the x spacing and y spacing edit fields type 0.1.

5 Click OK.

G E O M E T R Y  M O D E L I N G

1 Shift-click the Rectangle/Square button on the Draw toolbar and create five 
rectangles:

NAME SIZE POSITION

WIDTH HEIGHT BASE X Y

R1 1 1 Corner 0 0

R2 0.2 0.2 Corner 0 1

R3 0.2 0.2 Corner 1 0.8

R4 0.2 0.2 Corner 0.8 -0.2

R5 0.2 0.2 Corner -0.2 0
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2 Click the Zoom Extents button. 

The initial geometry after drawing five rectangles.

These steps create the mirror along with support structure for the cantilevers. This 
assembly is made of a metal stiffer than the prestressed cantilever springs. Next 
chamfer the corners.

3 From the Draw menu, select Fillet/Chamfer.

4 Click the Chamfer option button.

5 In the Distance edit field, type 0.1.

6 In the Vertex selection list, choose the four vertices R2>4, R3>3, R4>2, and R5>1.

7 Click OK. 

The mirror geometry after chamfering.
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8 Use the Rectangle/Square tool and data from the following table to create the spring:

The geometry with the springs added.

Rescaling the Geometry
1 From the Edit menu, choose Select All.

2 From the Draw menu, select Modify and then Scale.

3 In the Scale factor edit fields for x and y, type 1e-3.

4 Click OK.

5 Click the Zoom Extents button.

6 From the Options menu, choose Axes/Grid Settings.

7 Click the Grid tab.

8 Select the Auto check box.

9 Click OK.

NAME SIZE POSITION

WIDTH HEIGHT BASE X Y

R1 0.9 0.1 Corner 0.2 1.1

R2 0.1 0.9 Corner 1.1 -0.1

R3 0.9 0.1 Corner -0.1 -0.2

R4 0.1 0.9 Corner -0.2 0.2
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C R E A T I N G  A  M A P P E D  M E S H

1 From the Mesh menu, choose Mapped Mesh Parameters.

2 Click the Boundary tab.

3 Select Boundaries 12, 16, 27, and 31.

4 Select the Constrained edge element distribution check box.

5 In the Number of edge elements edit field, type 6.

6 Select Boundaries 3, 7, 13, 14, 20, 23, 30, and 39.

7 Select the Constrained edge element distribution check box.

8 In the Number of edge elements edit field, type 12.

9 Next select Boundaries 4, 11, 19, 21, 24, 26, 32, and 36.

10 Select the Constrained edge element distribution check box.

11 In the Number of edge elements edit field, type 3.

12 Click the Remesh button.

13 Click OK.

The geometry with the 2D mapped mesh.

E X T R U D I N G  M E S H  I N T O  3 D

1 From the Mesh menu, select Extrude Mesh.

2 On the Geometry page, type 20e-6 40e-6 in the Distance edit field. 

This specifies a 3D geometry meshed in two sections: a first section between the 
planes z = 0 and z = 20 µm, and a second section between z = 20 µm and 
z = 40 µm. On the Mesh page, you can specify the number of element layers for each 
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section. The default is in this case a single element layer per section. In general, the 
default number of element layers is a function of the 2D mesh-element size to give 
3D prism elements of roughly the same size in all directions.

3 Click OK. 

The geometry after extruding the mesh into 3D.

P H Y S I C S  S E T T I N G S

Application Mode Properties
1 From the Physics menu, select Properties.

2 In the Application Mode Properties dialog box, change the value in the Large 
deformation list to On.

3 Click OK.

Subdomain Settings
1 From the Physics menu, choose Subdomain Settings.

2 In the Subdomain Selection list, select all subdomains (1–18).

3 Click the Material tab, then click the Load button.

4 From the Basic Material Properties list, choose Aluminum 3003-H18.

5 Click OK.

6 Click the Initial Stress and Strain tab.

7 From the Subdomain selection list, choose Subdomains 3, 5, 11, and 17.

8 Select the Include initial stress check box.

9 For both σxi and σyi enter the value -Stress.
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10 From the Subdomain selection list, choose Subdomains 4, 6, 12, and 18.

11 Select the Include initial stress check box.

12 For both σxi and σyi enter the value +Stress.

13 Click OK.

Boundary Conditions
1 From the Physics menu, choose Boundary Settings.

2 In the Boundary selection list, select Boundaries 15, 16, 17, 20, 92, 95, 102, and 103 
(see the image below).

3 On the Constraint page select, set the check boxes for Constraint condition list to 
Fixed.

4 Click OK.

Geometry with the fixed boundaries highlighted.

C O M P U T I N G  T H E  S O L U T I O N

For large stress values this model is very nonlinear and needs a lot of solver steps to 
converge. Thus you need to increase the default number of allowed steps before 
solving the model.

1 From the Solve menu, select Solver Parameters.

2 Verify that the Analysis list has selection Static and that the Auto select solver is 
selected.

3 Go to the Stationary page.

4 In the Maximum number of iterations field, type 50.
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5 Click OK.

6 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Generate Figure 2-16 on page 62 with the following steps.

1 From the Postprocessing menu, choose Plot Parameters.

2 On the General page, clear the Slice check box in the Plot type area.

3 Select both the Boundary and Deformed shape check boxes.

4 Click the Deform tab.

5 Clear the Auto check box, and in the Scale factor edit field type 1.0.

6 Click OK.

7 Click the Zoom Extents button.

8 Click the Headlight button on the Camera toolbar on the left side of the user 
interface.

S T I F F E N I N G  T H E  C E N T E R  S E C T I O N

1 From the Physics menu, choose Subdomain Settings.

2 In the Subdomain selection list, choose 1, 2, 7–10, and 13–16.

3 On the Material page, click the Load button.

4 From the Basic Material Properties list, choose Steel AISI 4340.

5 Click OK twice.

6 Click the Solve button.

The resulting plot is shown in Figure 2-16 on page 62.

D I S P L A C E M E N T  V S .  P R E S T R E S S

1 From the Solve menu, choose Solver Parameters.

2 From the Analysis list, choose Parametric.

3 Click the General tab. In the Parameter name edit field, type Stress.

4 In the Parameter values edit field, type 0:1e9:10e9. Click OK.

5 Click the Solve button. The analysis can require several minutes to complete.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 From the Postprocessing menu, choose Cross-Section Plot Parameters.
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2 In the Solutions to use list, verify that all solutions are selected. If not, click in the list 
and press Ctrl+A.

3 Click the Title/Axis button. Select the option button next to the First axis label edit 
field, then enter the label Prestress [N/m<sup>2</sup>]. Click OK.

4 Click the Point tab. In the y-axis data area, select Solid, Stress-Strain (smsld)>Total 

displacement from the Predefined quantities list and um from the Unit list.

5 In the Coordinates area, change the x, y, and z values to 0.5e-3, 0.5e-3, and 40e-6, 
respectively.

6 Click Apply.

The resulting plot appears in Figure 2-17 on page 63.

7 On the General page, click the Title/Axis button. Click the Auto option button for the 
First axis label, then click OK.

8 On the Line/Extrusion page, click the Line plot option button.

9 In the y-axis data area, select Solid, Stress-Strain (smsld)>Total displacement from the 
Predefined quantities list and um from the Unit list.

10 In the x-axis data area, click the lower option button, then click Expression. From 
the Predefined quantities list, select Geometry and Mesh>x-coordinate. From the Unit 
list, select mm, then click OK.

11 Change the values in the Cross-section line data area as follows:

12 Click the Line Settings button. From the Line marker list, select Cycle. Select the 
Legend check box, then click OK to close the Line Settings dialog box.

13 Click OK. 

The results appear in Figure 2-18 on page 63.

Visualizing the Released Stress State
Follow the steps below to create Figure 2-19 on page 64.

1 From the Postprocessing menu, choose Plot Parameters.

2 Click the Boundary tab. 

3 Find the Boundary data area, and in the Expression edit field type s1_smsld.

4 Click OK. 

NAME VALUE NAME VALUE NAME VALUE

x0 0 y0 0.5e-3 z0 40e-6

x1 1e-3 y1 0.5e-3 z1 40e-6
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Re s i d u a l  S t r e s s  i n  a  Th i n - F i lm 
Re s ona t o r

Introduction

Almost all surface-micromachined thin films are subject to residual stress. The most 
common is likely thermal stress, which accompanies a change in temperature and is due 
to the difference in the coefficient of thermal expansion between the film and the 
substrate. The examples in this section show how to add thermal residual stress to a 
structural-mechanical model and observe how it changes the structure’s resonant 
frequency. 

A thin-film resonator with four cantilever beam springs.

For a lateral resonator with four cantilever-beam springs, the resonant frequency is

where m is the mass of the resonator plate, E is Young’s modulus, t is the thickness, L 
is the length, b is the width, and σr is the residual stress in the cantilevers. The stress 
is typically a sum of external stresses, the thermal stress, and intrinsic components. 
Assuming the material is isotropic, the stress is constant through the film thickness, and 
the stress component in the direction normal to the substrate is zero. The stress-strain 
relationship is then

f0
1

2π
------ 4Etb3

mL3
-----------------

24σrtb
5mL

-------------------+≈
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where ν is Poisson’s ratio.

A process deposits a thin film onto a thick substrate at a high temperature. When the 
assembly cools to room temperature, the film and the substrate shrink differently and 
cause strain in the film. The strain comes from ε = ∆α∆T where ∆α is the difference 
between the thermal-expansion coefficients, and ∆T is the difference between the 
deposition temperature and the normal operating temperature.

You can relieve thermal residual stress in thin-film spring structures by folding the 
flexures as shown in the next figure. The flexures relieve axial stress because each is free 
to expand or contract in the axial direction. 

The film resonator with folded cantilever beam strings.

The basic folded structure is a U-shaped spring. For springs in series, the equivalent 
spring constant is

The first and last springs are cantilever beams. You obtain the spring constant for them 
from k = 3EI/L3, where I is the moment of inertia. For a rectangular beam with a 
rotation about the y-axis, the moment of inertia is I = wt3/12, where w is the width 
and t is the structure’s thickness. You can treat the second spring as a column with a 
spring constant of k = AE/L, where A is the cross-sectional area A = wt. Assuming the 
spring thickness and width are the same everywhere, the equation comes to 

σr
E

1 ν–
------------⎝ ⎠
⎛ ⎞ ε=

1
keq
-------- 1

k1
------ 1

k2
------ 1

k3
------+ +=
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,

which can help estimate the lengths of the folded springs.

Model Definition

This example took the dimensions and the material properties presented in the 
following tables from the example in Chapter 27.2.5 in Ref. 1. It calculates the lengths 
of the folded cantilever using the equivalent spring-constant relationship.

This simulation models thermal residual stress using the thermal expansion option in 
the Structural Mechanics application mode. It calculates the coefficient of thermal 
expansion using the stress-strain relationship. It sets the deposition temperature to 
605 °C (see Chapter 16.13.2.3 in reference Ref. 1)..

In order to determine the eigenfrequencies for the case with residual stress, you must 
use the large-deformation analysis available in the structural mechanics application 
modes. First solve for the residual stress using a nonlinear solver. Then store the linear 
solution and solve for the eigenfrequencies using that stored solution. To obtain the 
eigenfrequency without the stress, solve the problem using the initial settings.

TABLE 2-1:  DIMENSIONS OF THE STRUCTURE.

PARAMETER STRAIGHT 
CANTILEVERS

FOLDED CANTILEVERS SHUTTLE 
MASS

L1 L2 L3

Length 200 µm 170 µm 10 µm 146 µm 250 µm

Width 2 µm 120 µm

Thickness 2.25 µm 2.25 µm

TABLE 2-2:  MATERIAL PROPERTIES OF THE STRUCTURE.

PROPERTY VALUE

Material polysilicon

Young’s modulus 155 GPa

Poisson’s ratio 0.23

Density 2330 kg/m3

T0 605 oC

T1 25 oC

Leq
3 L1

3 wt2L2
4

----------------- L3
3+ +=
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Results and Discussion

Table  summarizes the resonant frequencies for the first horizontal eigenmode. For the 
2D models this is the lowest found eigenmode, but for the 3D models this is the 
second mode. In 3D modes, the lowest resonance corresponds to eigenmode with 
rotational movement. You can see these modes for the resonator with straight 
cantilevers in the pictures below the table.

The von Mises stress is close to 50 MPa in the legs of the resonators with straight 
cantilevers. But for folded cantilevers, the stress is much less, about 140 kPa (See 
pictures in the step-by-step instructions). The analytical reference value for straight 
cantilevers was calculated using 50 MPa stress.

As the table shows, the resonant frequency for the straight cantilevers increases 
significantly when the model includes residual stress. Moreover, the model results 
agree closely with the analytical estimates. By folding the springs you can decrease the 
sensitivity to stress.

The first and rotational eigenmode of the resonator with straight cantilevers.

TABLE 2-3:  RESONANT FREQUENCIES WITH AND WITHOUT RESIDUAL STRESS.

 STRAIGHT CANTILEVERS  FOLDED CANTILEVERS

ANALYTICAL 2D MODEL 3D MODEL  2D MODEL 3D MODEL

Without stress 15.0 kHz 14.8 kHz 14.8 kHz 14.0 kHz 14.1 kHz

With residual stress 33.1 kHz 31.9 kHz 32.0 kHz 14.0 kHz 14.1 kHz
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The second and horizontal eigenmode of the resonator with straight cantilevers.

Reference

1. M. Gad-el-Hak, ed., The MEMS Handbook, CRC Press, London, 2002, ch. 16.12 
and 27.2.5.

Model Library path: MEMS_Module/Actuator_Models/resonator_straight_2d

Model Library path: MEMS_Module/Actuator_Models/resonator_folded_2d

Model Library path: MEMS_Module/Actuator_Models/resonator_straight_3d

Model Library path: MEMS_Module/Actuator_Models/resonator_folded_3d
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Modeling Using the Graphical User Interface—2D, Straight 
Cantilevers

M O D E L  N A V I G A T O R

1 Open the Model Navigator, click the New tab, and in the Space dimension list select 2D.

2 In the list of application modes, select  
MEMS Module>Structural Mechanics>Plane Stress>Static analysis.

3 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu choose Constants.

2 In the Constants dialog box enter the following names and expressions; the 
descriptions are optional. When finished, click OK.

G E O M E T R Y  M O D E L I N G

1 Shift-click the Rectangle/Square button on the Draw toolbar to create these five 
rectangles:

NAME EXPRESSION DESCRIPTION

E 155[GPa] Young’s modulus

nu 0.23 Poisson’s ratio

rho 2330[kg/m^3] Density

sigma 50[MPa] Residual stress

epsilon sigma*(1-nu)/E Residual strain

T1 605[degC] Deposition temperature

T0 25[degC] Room temperature

daT epsilon/(T1-T0) Coefficient of thermal expansion (1/K)

NAME SIZE POSITION

WIDTH HEIGHT BASE X Y

R1 250e-6 120e-6 Corner 0 0

R2 2e-6 200e-6 Corner 100e-6 120e-6

R3 2e-6 200e-6 Corner 148e-6 120e-6

R4 2e-6 200e-6 Corner 100e-6 -200e-6

R5 2e-6 200e-6 Corner 148e-6 -200e-6
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2 Click the Zoom Extents button on the Main toolbar. 

Initial geometry for the thin-film resonator in 2D with straight cantilevers.

P H Y S I C S  S E T T I N G S

Application Mode Properties
1 From the Physics menu, choose Properties.

2 In the Application Mode Properties dialog box, go to the Large deformations list and 
select On. Click OK.

Subdomain Settings
1 From the Physics menu, choose Subdomain Settings.

2 Select all subdomains by first clicking in the Subdomain selection list or the drawing 
area and then pressing Ctrl+A.

3 Enter the following values on the Material page of the Subdomain Settings dialog box; 
when finished, click OK.

Boundary Conditions
1 From the Physics menu, choose Boundary Settings.

QUANTITY VALUE DESCRIPTION

E E Young’s modulus

 ν nu Poisson’s ratio

 α daT Thermal expansion coefficient

 ρ rho Density

 thickness 2.25e-6 Thickness
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2 In the Boundary selection list, select Boundaries 5, 9, 15, and 19.

3 On the Constraint page, set the Constraint condition list to Fixed.

4 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, choose Free Mesh Parameters. 

2 Verify that Normal is selected from the Predefined mesh sizes list.

3 Click Custom mesh size.

4 In the Resolution of narrow regions field type 2.

5 Click Remesh, then click OK.

C O M P U T I N G  T H E  S O L U T I O N — E I G E N M O D E S  W I T H O U T  S T R E S S E S

Follow the steps below to compute the eigenmodes with the applied stress stiffening:

1 From the Solve menu, choose Solver Parameters.

2 From the Analysis list, select Eigenfrequency.

3 Click OK.

4 Click the Solve button.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 From the Postprocessing menu, choose Plot Parameters.

2 On the General page, choose from the Eigenfrequency list the mode you want to plot. 
The first eigenfrequency is approximately 14 kHz

3 Click the Surface tab.

The default plot in this page is the von Mises stress. Because the solution from the 
Eigenfrequency analysis is scaled, the stress levels is arbitrarily scaled also. Thus, it is 
more informative to plot, for example, the Total displacement.

4 Select Plane Stress (smps)>Total displacement from the Predefined quantities list.

5 Click the Deform tab.

6 Select the Deformed shape plot check box.

7 Click OK.

P H Y S I C S  S E T T I N G S — T H E R M A L  S T R A I N S

Subdomain Settings
1 From the Physics menu, choose Subdomain Settings.
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2 Select all subdomains.

3 On the Load page, enter the values in the following table; when done, click OK.

C O M P U T I N G  T H E  S O L U T I O N — S T A T I C  R E S I D U A L  S T R E S S

Using the steps below, solve the model and store the solution for later use.

1 From the Solve menu, choose Solver Parameters.

2 From the Analysis list, select Static, then click OK.

3 Click the Solve button on the Main toolbar. 

4 From the Solve menu, choose Solver Manager.

5 Click the Initial Value tab.

6 Click the Store Solution button at the bottom of the dialog box.

7 In the Values of variables not solved for and linearization point area, select 
Stored solution.

It is important to define the linearization point correctly. Using this information, 
the stress stiffening effect enters into the following eigenfrequency solution 
computed below.

8 Click OK.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N — S T A T I C  R E S I D U A L  S T R E S S

To gain information about the thermally generated stresses change the surface plot 
back to von Mises stress:

1 From the Postprocessing menu, choose Plot Parameters.

2 Click the Surface tab. 

3 Select Plane Stress (smps)>von Mises stress from the Predefined quantities list.

4 Click OK. 

PROPERTY SETTING/VALUE DESCRIPTION

Include thermal expansion Selected

Temp T0 Strain temperature

Tempref T1 Strain ref. temperature
R E S I D U A L  S T R E S S  I N  A  T H I N - F I L M  R E S O N A T O R  |  81



82 |  C H A P T E R
.

Deformed shape of the geometry for the thin-film resonator in 2D with straight cantilevers.

Next create a cross-section plot to inspect the stress distribution in more detail.

1 From the Postprocessing menu choose Cross-Section Plot Parameters.

2 Click the Line/Extrusion tab.

3 Enter the following values:

PARAMETER VALUE

Plot type Line plot

Predefined quantities von Mises stress

x-axis data y

CROSS-SECTION LINE DATA

x0 101e-6

x1 101e-6

y0 0

y1 320e-6

Line resolution 321
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4 Click OK.

Line plot of von Mises stress going first through the resonator body and then through one of 
the legs.

C O M P U T I N G  T H E  S O L U T I O N — E I G E N M O D E S  W I T H  T H E R M A L  S T R E S S E S

Follow the steps below to compute the eigenmodes with the applied stress stiffening:

1 From the Solve menu choose Solver Parameters.

2 From the Analysis list select Eigenfrequency.

3 Click OK.

4 Click the Solve button on the Main toolbar. The value of the eigenfrequency appears 
in the message log. Notice that the first eigenfrequency has changed to 
approximately 31,950 Hz.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 From the Postprocessing menu, choose Plot Parameters.

2 Click the Surface tab. 

3 Select Plane Stress (smps)>Total displacement from the Predefined quantities list.
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4 Click OK. 

Deformation associated with the first eigenfrequency for the thin-film resonator in 2D 
with straight cantilevers.

Modeling Using the Graphical User Interface—2D, Folded 
Cantilevers

M O D E L  N A V I G A T O R

1 Open the Model Navigator, click the New tab, and in the Space dimension list select 2D.

2 Click the New tab, and in the list of application modes select  
MEMS Module>Structural Mechanics>Plane Stress>Static analysis.

3 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu choose Constants.
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2 In the Constants dialog box enter the following names and expressions; the 
descriptions are optional. When finished, click OK.

G E O M E T R Y  M O D E L I N G

1 Shift-click the Rectangle/Square button on the Draw toolbar to create these 13 
rectangles:

NAME EXPRESSION DESCRIPTION

E 155[GPa] Young’s modulus

nu 0.23 Poisson’s ratio

rho 2330[kg/m^3] Density

sigma 50[MPa] Residual stress

epsilon sigma*(1-nu)/E Residual strain

T1 605[degC] Deposition temperature

T0 25[degC] Room temperature

daT epsilon/(T1-T0) Coefficient of thermal expansion

NAME SIZE POSITION

WIDTH HEIGHT BASE X Y

R1 250e-6 120e-6 Corner 0 0

CANTILEVER 1

R2 2e-6 170e-6 100e-6 120e-6

R3 12e-6 2e-6 100e-6 290e-6

R4 2e-6 146e-6 110e-6 144e-6

CANTILEVER 2

R5 2e-6 170e-6 148e-6 120e-6

R6 12e-6 2e-6 138e-6 290e-6

R7 2e-6 146e-6 138e-6 144e-6

CANTILEVER 3

R8 2e-6 170e-6 100e-6 -170e-6

R9 12e-6 2e-6 100e-6 -172e-6

R10 2e-6 146e-6 110e-6 -170e-6

CANTILEVER 4

R11 2e-6 170e-6 148e-6 -170e-6

R12 12e-6 2e-6 138e-6 -172e-6

R13 2e-6 146e-6 138e-6 -170e-6
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2 Click the Zoom Extents button on the Main toolbar. 

Initial geometry for the thin-film resonator in 2D with folded cantilevers.

P H Y S I C S  S E T T I N G S

Application Mode Properties
1 From the Physics menu, choose Properties.

2 In the Application Mode Properties dialog, go to the Large deformations list and select 
On.

Subdomain Settings
1 From the Physics menu, choose Subdomain Settings.

2 Select all subdomains.

3 On the indicated pages, specify the following settings; when finished, click OK.

SETTINGS VALUE DESCRIPTION

MATERIAL PAGE

 E E Young’s modulus

 ν nu Poisson’s ratio

 α daT Thermal expansion coefficient

 ρ rho Density

 thickness 2.25e-6 Thickness

LOAD PAGE

Include thermal expansion selected
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Boundary Conditions
1 From the Physics menu, choose Boundary Settings.

2 In the Boundary selection list, select Boundaries 22, 24, 34, and 36.

3 On the Constraint page, set the Constraint condition list to Fixed.

4 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, choose Free Mesh Parameters.

2 Verify that Normal is selected from the Predefined mesh sizes list.

3 Click Custom mesh size.

4 In the Resolution of narrow regions edit field type 2.

5 Click Remesh, then click OK.

C O M P U T I N G  T H E  S O L U T I O N — E I G E N M O D E S  W I T H O U T  S T R E S S E S

Follow the steps below to compute the eigenmodes with the applied stress stiffening:

1 From the Solve menu, choose Solver Parameters.

2 From the Analysis list, select Eigenfrequency.

3 Click OK.

4 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 From the Postprocessing menu, choose Plot Parameters.

2 On the General page, choose the mode you want to plot from the Eigenfrequency list; 
the first eigenfrequency is approximately 14 kHz.

3 Click the Surface tab. 

The default plot in this page is the von Mises stress. Because the solution from the 
Eigenfrequency analysis is scaled, the stress levels will be arbitrarily scaled also. Thus, 
it is more informative to plot for example the Total displacement.

4 Select Plane Stress (smps)>Total displacement from the Predefined quantities list.

5 Click the Deform tab.

6 Select the Deformed shape plot check box.

Temp T0 Strain temperature

Tempref T1 Strain ref. temperature

SETTINGS VALUE DESCRIPTION
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7 Click OK.

P H Y S I C S  S E T T I N G S — T H E R M A L  S T R A I N S

1 From the Physics menu, choose Subdomain Settings.

2 Select all subdomains.

3 On the Load page, enter the values in the following table; when finished, click OK.

C O M P U T I N G  T H E  S O L U T I O N — S T A T I C  R E S I D U A L  S T R E S S

Using the steps below, solve the model and store the solution for later use.

1 From the Solve menu, choose Solver Parameters.

2 From the Analysis list, select Static, then click OK.

3 Click the Solve button on the Main toolbar.

4 From the Solve menu, choose Solver Manager.

5 Click the Initial Value tab.

6 Click the Store Solution button at the bottom of the dialog box.

7 In the Values of variables not solved for and linearization point area select 
Stored solution.

It is important to define the linearization point correctly. Using this information, 
the stress stiffening effect enters into the following eigenfrequency solution 
computed below.

8 Click OK.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N — S T A T I C  R E S I D U A L  S T R E S S

To gain information about the thermally generated stresses change the surface plot 
back to von Mises stress:

1 From the Postprocessing menu, choose Plot Parameters.

2 Click the Surface tab. 

3 Select Plane Stress (smps)>von Mises stress from the Predefined quantities list.

4 Click OK. 

SETTINGS VALUE DESCRIPTION

Include thermal expansion selected

Temp T0 Strain temperature

Tempref T1 Strain ref. temperature
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Deformed shape of the geometry for the thin-film resonator in 2D with folded cantilevers.

Next create a cross-section plot to inspect the stress distribution in more detail:

1 From the Postprocessing menu, choose Cross-Section Plot Parameters.

2 Click the Line/Extrusion tab.

3 Enter these values; when done, click OK.

PARAMETER VALUE

Plot type Line plot

Predefined quantities von Mises stress

Expression mises_smps

x-axis data y

CROSS-SECTION LINE DATA

x0 101e-6

x1 101e-6

y0 0
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Line plot of von Mises stress going first through the resonator body and then through one of 
the legs.

C O M P U T I N G  T H E  S O L U T I O N — E I G E N M O D E S  W I T H  S T R E S S E S

Follow the steps below to compute the eigenmodes with the applied stress stiffening:

1 From the Solve menu, choose Solver Parameters.

2 From the Analysis list, select Eigenfrequency.

3 Click OK.

4 Click the Solve button on the Main toolbar. Notice that the first eigenfrequency is 
almost the same as without thermal stresses.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 From the Postprocessing menu, choose Plot Parameters.

2 Click the Surface tab. 

y1 290e-6

Line resolution 291

PARAMETER VALUE
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3 Select Plane Stress (smps)>Total displacement from the Predefined quantities list.

4 Click OK. 

 

Deformation associated with the first eigenfrequency for the thin-film resonator in 2D 
with folded cantilevers.

Modeling Using the Graphical User Interface—3D, Straight 
Cantilevers

M O D E L  N A V I G A T O R

1 In the Model Navigator, click the New tab. In the Space dimension list, select 3D.

2 In the list of application modes, select 
MEMS Module>Structural Mechanics>Solid, Stress-Strain.

3 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, choose Constants.
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2 In the Constants dialog box, enter these variable names, expressions, and 
(optionally) descriptions; when done, click OK.

G E O M E T R Y  M O D E L I N G

1 Shift-click the Block button on the Draw toolbar to create these five solid blocks; 
when complete, click OK.

NAME EXPRESSION DESCRIPTION

E 155[GPa] Young’s modulus

nu 0.23 Poisson’s ratio

rho 2330[kg/m^3] Density

sigma 50[MPa] Residual stress

epsilon sigma*(1-nu)/E Residual strain

T1 605[degC] Deposition temperature

T0 25[degC] Room temperature

daT epsilon/(T1-T0) Coefficient of thermal expansion

NAME LENGTH AXIS BASE POINT

X Y Z X Y Z

BLK1 250e-6 120e-6 2.25e-6 0 0 0

BLK2 2e-6 200e-6 2.25e-6 100e-6 120e-6 0

BLK3 2e-6 200e-6 2.25e-6 148e-6 120e-6 0

BLK4 2e-6 200e-6 2.25e-6 100e-6 -200e-6 0

BLK5 2e-6 200e-6 2.25e-6 148e-6 -200e-6 0
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2 Click the Zoom Extents button on the Main toolbar. 

Initial geometry for the thin-film resonator in 3D with straight cantilevers.

P H Y S I C S  S E T T I N G S

Application Mode Properties
1 From the Physics menu, choose Properties.

2 In the Application Mode Properties dialog box, go to the Large deformations list and 
select On.

Subdomain Settings
1 From the Physics menu, choose Subdomain Settings.

2 Select all subdomains.

3 Enter the following values on the Material page of the Subdomain Settings dialog box; 
when finished, click OK.

Boundary Conditions
1 From the Physics menu, select Boundary Settings.

2 In the Boundary selection list, select Boundaries 7, 15, 21, and 29.

PROPERTY VALUE DESCRIPTION

 E E Young’s modulus

 ν nu Poisson’s ratio

 α daT Thermal expansion coeff.

 ρ rho Density
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3 On the Constraint page, set the Constraint condition list to Fixed.

4 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, choose Free Mesh Parameters.

2 Click the Global tab.

3 Verify that the selection from the Predefined mesh sizes list is Normal.

4 Click the Advanced tab.

5 For the z-direction scale factor enter 2.0.

6 Click Remesh.

7 Click OK.

C O M P U T I N G  T H E  S O L U T I O N — E I G E N M O D E S  W I T H O U T  S T R E S S E S

Follow the steps below to compute the eigenmodes with the applied stress stiffening:

1 From the Solve menu, choose Solver Parameters.

2 From the Analysis list, select Eigenfrequency.

3 Click OK.

4 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N — S T A T I C  R E S I D U A L  S T R E S S

1 From the Postprocessing menu, choose Plot Parameters.

2 Click the General tab.

3 from the Eigenfrequency list, choose the mode you want to plot; the eigenmode for 
the horizontal movement has an eigenfrequency of approximately 14.8 kHz

4 Clear the Slice check box.

5 Select the Boundary and Deformed shape check boxes.

6 Click OK.

P H Y S I C S  S E T T I N G S — T H E R M A L  S T R A I N S

Subdomain Settings
1 From the Physics menu, choose Subdomain Settings.

2 Select all subdomains.
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3 Go to the Load page and enter the values in the following table; when done, click OK.

C O M P U T I N G  T H E  S O L U T I O N — S T A T I C  R E S I D U A L  S T R E S S

Using the steps below, solve the model and store the static solution for later use.

1 From the Solve menu, choose Solver Parameters.

2 From the Analysis list, select Static, then click OK.

3 Click the Solve button on the Main toolbar.

4 From the Solve menu, choose Solver Manager.

5 Click the Initial Value tab.

6 Click the Store Solution button at the bottom of the dialog box.

7 In the Values of variables not solved for and linearization point area select 
Stored solution.

8 Click OK.

SETTINGS VALUE DESCRIPTION

Include thermal expansion yes

Temp T0 Strain temperature

Tempref T1 Strain ref. temperature
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P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N — S T A T I C  R E S I D U A L  S T R E S S

According to the plot settings you defined before, the deformed plot with total 
displacement appears in the user interface:

Deformed shape of the geometry for the thin-film resonator in 3D with straight cantilevers.

Next create a cross-section plot to inspect the stress distribution in more detail.

1 From the Postprocessing menu, choose Cross-Section Plot Parameters.

2 Click the Line/Extrusion tab.

3 Enter the following values; when finished, click OK.

PARAMETER VALUE

Plot type Line plot

Predefined quantities von Mises stress

Expression mises_smsld

x-axis data y

CROSS-SECTION LINE DATA

x0 101e-6

x1 101e-6
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Line plot of von Mises stress going first through the resonator body and then through one of 
the legs.

C O M P U T I N G  T H E  S O L U T I O N — E I G E N M O D E S  W I T H  S T R E S S E S

1 From the Solve menu, choose Solver Parameters.

2 From the Analysis list, select Eigenfrequency.

3 Click OK.

4 From the Solve menu, choose Solver Manager.

y0 0

y1 320-6

z0 1.125e-6

z1 1.125e-6

Line resolution 321

PARAMETER VALUE
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5 Click the Solve button. Observe the eigenfrequency from the plot title; the first 
found eigenmode corresponds to rotational movement.

Deformation associated with the first eigenfrequency for the thin-film resonator in 3D 
with straight cantilevers.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N — E I G E N F R E Q U E N C Y

1 From the Postprocessing menu, choose Plot Parameters.

2 Click the General tab.

3 Go to the Solution to use area, and in the Eigenfrequency list select the second value, 
which should be near 32 kHz.

4 Click OK.

Deformation associated with the second eigenfrequency for the thin-film resonator in 3D 
with straight cantilevers.
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Modeling Using the Graphical User Interface—3D, Folded 
Cantilevers

M O D E L  N A V I G A T O R

1 In the Model Navigator click the New tab, and in the Space dimension list select 3D.

2 In the list of application modes select  
MEMS Module>Structural Mechanics>Solid, Stress-Strain.

3 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, choose Constants.

2 In the Constants dialog box, enter these variable names, expressions, and 
(optionally) descriptions; when finished, click OK.

G E O M E T R Y  M O D E L I N G

1 Shift-click the Block button on the Draw toolbar to create these 13 solid blocks; 
when finished, click OK.

NAME EXPRESSION DESCRIPTION

E 155[GPa] Young’s modulus

nu 0.23 Poisson’s ratio

rho 2330[kg/m^3] Density

sigma 50[MPa] Residual stress

epsilon sigma*(1-nu)/E Residual strain

T1 605[degC] Deposition temperature

T0 25[degC] Room temperature

daT epsilon/(T1-T0) Coefficient of thermal expansion

NAME LENGTH AXIS BASE POINT

X Y Z X Y Z

BLK1 250e-6 120e-6 2.25e-6 0 0 0

CANTILEVER 1

BLK2 2e-6 170e-6 2.25e-6 100e-6 120e-6 0

BLK3 12e-6 2e-6 2.25e-6 100e-6 290e-6 0

BLK4 2e-6 146e-6 2.25e-6 110e-6 144e-6 0

CANTILEVER 2

BLK5 2e-6 170e-6 2.25e-6 148e-6 120e-6 0
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2 Click the Zoom Extents button on the Main toolbar. 

Initial geometry for the thin-film resonator in 3D with folded cantilevers.

P H Y S I C S  S E T T I N G S

Application Mode Properties
1 From the Physics menu, choose Properties.

2 In the Application Mode Properties dialog box, go to the Large deformations list and 
select On.

3 Click OK.

BLK6 12e-6 2e-6 2.25e-6 138e-6 290e-6 0

BLK7 2e-6 146e-6 2.25e-6 138e-6 144e-6 0

CANTILEVER 3

BLK8 2e-6 170e-6 2.25e-6 100e-6 -170e-6 0

BLK9 12e-6 2e-6 2.25e-6 100e-6 -172e-6 0

BLK10 2e-6 146e-6 2.25e-6 110e-6 -170e-6 0

CANTILEVER 4

BLK11 2e-6 170e-6 2.25e-6 148e-6 -170e-6 0

BLK12 12e-6 2e-6 2.25e-6 138e-6 -172e-6 0

BLK13 2e-6 146e-6 2.25e-6 138e-6 -170e-6 0

NAME LENGTH AXIS BASE POINT

X Y Z X Y Z
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Subdomain Settings
1 From the Physics menu, choose Subdomain Settings.

2 Select all subdomains.

3 On the Material page of the Subdomain Settings dialog box, enter the following 
values; when finished, click OK.

Boundary Conditions
1 From the Physics menu, select Boundary Settings.

2 In the Boundary selection list, select 34, 36, 52, and 54.

3 On the Constraint page, set the Constraint condition list to Fixed.

4 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, choose Free Mesh Parameters.

2 Click the Global tab.

3 Verify that the selection from the Predefined mesh sizes list is Normal.

4 Click the Advanced tab.

5 For the z-direction scale factor enter 2.0.

6 Click Remesh.

7 Click OK.

C O M P U T I N G  T H E  S O L U T I O N — E I G E N M O D E S  W I T H O U T  S T R E S S E S

Follow the steps below to compute the eigenmodes with the applied stress stiffening:

1 From the Solve menu, choose Solver Parameters.

2 From the Analysis list, select Eigenfrequency.

3 Click OK.

4 Click the Solve button.

SETTINGS VALUE DESCRIPTION

MATERIAL PAGE

 E E Young’s modulus

 ν nu Poisson’s ratio

 α daT Thermal expansion coefficient

 ρ rho Density
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P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 From the Postprocessing menu, choose Plot Parameters.

2 Go to the General page.

3 From the Eigenfrequency list, choose the mode you want to plot; The eigenmode for 
the horizontal movement has an eigenfrequency of approximately 14 kHz

4 Click the Deform tab.

5 Select the Deformed shape plot check box.

6 Click OK.

P H Y S I C S  S E T T I N G S — T H E R M A L  S T R A I N S

Subdomain Settings
1 From the Physics menu, choose Subdomain Settings.

2 Select all subdomains.

3 On the Load page, enter the values in the following table; when finished, click OK.

C O M P U T I N G  T H E  S O L U T I O N — S T A T I C  R E S I D U A L  S T R E S S

Using the steps below, solve the model and store the static solution for later use.

1 From the Solve menu, choose Solver Parameters.

2 From the Analysis list, select Static, then click OK.

3 Click the Solve button on the Main toolbar.

4 From the Solve menu, choose Solver Manager.

5 Click the Initial Value tab.

6 Click the Store Solution button at the bottom of the dialog box.

7 In the Values of variables not solved for and linearization point area select 
Stored solution.

8 Click OK.

QUANTITY VALUE DESCRIPTION

Temp T0 Strain temperature

Tempref T1 Strain ref. temperature
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PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N — S T A T I C  R E S I D U A L  S T R E S S

According to the plot settings you defined before, the deformed plot with total 
displacement appears in the user interface:

Deformed shape of the geometry for the thin-film resonator in 3D with folded cantilevers.

Next create a cross-section plot to inspect the stress distribution in more detail.

1 From the Postprocessing menu, choose Cross-Section Plot Parameters.

2 Click the Line/Extrusion tab.

3 Enter the following values; when finished click OK.

PARAMETER VALUE

Plot type Line plot

Predefined quantities von Mises stress

Expression mises_smsld

x-axis data y

CROSS-SECTION LINE DATA

x0 101e-6

x1 101e-6
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Line plot of von Mises stress going first through the resonator body and then through one of 
the legs.

C O M P U T I N G  T H E  S O L U T I O N — E I G E N M O D E S  W I T H  S T R E S S E S

1 From the Solve menu, choose Solver Parameters.

2 From the Analysis list, select Eigenfrequency.

3 Click OK.

y0 0

y1 290e-6

z0 1.125e-6

z1 1.125e-6

Line resolution 291

PARAMETER VALUE
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4 Click the Solve button. Observe the eigenfrequency from the plot title; the first 
found eigenmode corresponds to rotational movement.

Deformation associated with the first eigenfrequency for the thin-film resonator in 3D 
with folded cantilevers.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N — E I G E N F R E Q U E N C Y

1 From the Postprocessing menu, choose Plot Parameters.

2 Click the General tab.

3 From the Eigenfrequency list, select the second value, which should be near 14 kHz.

4 Click OK.

Deformation associated with the second eigenfrequency for the thin-film resonator in 3D 
with folded cantilevers.
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T h e rmoe l a s t i c  Damp i ng  i n  a  MEMS 
Re s ona t o r

Introduction

A high Q value is a key factor of a MEMS resonator. It it essential that the resonator 
vibrates consistently at the desired frequency and that it requires as little energy as 
possible to maintain its vibration. These features can be characterized by the 
resonator’s Q value, which is a measure of the sharpness of its spectrum’s peak. There 
are several ways to define the Q value, for example:

 (2-2)

where W0 is the total stored vibrational energy, ∆W is the energy lost per cycle, ω0 is 
the natural angular frequency, δ is the damping factor (vibration decays exponentially 
with δt), and ∆ω is the half power width of the spectrum.

In order to improve the resonator, the designer needs to consider all aspect that 
produce damping and noise to the system. For example, resonators are usually run in 
vacuum to minimize effects of air and squeeze-film damping.

Thermoelastic damping (Ref. 1, Ref. 2, and Ref. 3) is an important factor that the 
resonator designer needs to address. It is a result of a phenomenon called thermoelastic 
friction, which takes place when you subject any material to cyclic stress. The stress 
results in deformation, and the required energy is mostly stored as internal potential 
energy. However, materials heat under compressive stress and cool under tensile stress. 
Thus, due to the heat flow from warmer to cooler regions energy is also lost as 
nonrecoverable thermal energy. The amount of thermoelastic friction and damping 
depends on the rate of this energy loss. The magnitude of the energy loss depends on 
the vibrational frequency and on the structure’s thermal relaxation time constant, 
which is the effective time the material requires to relax after an applied constant stress 
or strain. Therefore, the effect of thermoelastic dissipation, and consequently the 
damping, is most pronounced when the vibration frequency is close to the thermal 
relaxation frequency.

Q
2πW0

∆W
---------------

ω0
2δ
------

ω0
∆ω
--------= = =
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For simple structures, researchers have developed analytical expressions to estimate 
thermoelastic damping. According to Zener (Ref. 1 and Ref. 2), you can calculate the 
Q value for a resonator with a single thermal mode by: 

 (2-3)

where E is the Young’s modulus, α is the thermal expansion coefficient, T0 is the 
resonator temperature at rest, ρ is the density, Cp is the heat capacity of the material, 
ω is the vibration angular frequency, and τ is the thermal relaxation time of the system. 
Thus it is easy to see that in order to have good Q value, the system needs to be 
designed so that ω is as far from 1/τ as possible.

The natural frequency of a beam clamped at both ends can be calculated as (Ref. 4) 

 (2-4)

where a0 equals 4.730; h and L are the thickness and length of the beam, respectively; 
and E and ρ are material parameters as above.

The thermal relaxation time of the beam is given by

 (2-5)

where κ is the thermal conductivity and other parameters are as above.

The problem is that Equations 2-3 through 2-5 are valid only for very simple 
structures. Therefore more advanced methods, such as FEA, are preferable.

This example shows how to model thermoelastic damping with COMSOL 
Multiphysics. To be able to compare with measurements and analytical expressions, 
this example illustrates a simple beam resonator in 2D and 3D. The Q value and 
natural frequency is solved with an eigenfrequency analysis that combines heat transfer 
and structural mechanics in one equation system. Thus the eigenmodes are 
thermoelastic.

This example was inspired by the work of Amy Duwel and others (Ref. 1).
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Model Definition

Figure 2-20 shows the geometry. The resonator is a beam of silicon with length 
400 µm, height 12 µm, and width 20 µm. The beam is fixed at both ends, and it 
vibrates in a flexural mode in the z direction (that is, along the smallest dimension). 
The model assume that the vibration takes place in vacuum. Thus there is no transfer 
of heat from the free boundaries. The model also assumes that the contact boundaries 
are thermally insulated.

Figure 2-20: Geometry of the modeled beam. The beam is fixed at both ends.

Table 2-4 lists the physical properties of the beam material and the surroundings: 

TABLE 2-4:  MATERIAL PROPERTIES (POLYSILICON)

PROPERTY VALUE

Young’s modulus, E 157 GPa

Density, ρ 2330 kg/m3

Poisson’s ratio, ν 0.3

Thermal expansion coefficient, α 2.6·10-6 K-1

Specific heat, Cp 700 J/(kg·K)

Thermal conductivity, k 90 W/(m·K)

Ambient and initial beam temperature, Tinit 300 K
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To gain information about the quality of the resonator, it is of interest to know its 
natural frequency and Q value. To do this, you run an eigenfrequency analysis to find 
the eigenvalues for this system. For a system with damping, the eigenvalue λ contains 
information about the natural frequency and Q value according to: 

 (2-6)

The eigenvalues appear as complex conjugates, and ω0 and Q are therefore given as 
absolute values.

At this point, to avoid any confusion it is good to note that here Q refers to the 
resonator’s quality, whereas later in this text Qheat refers to the heat source term in the 
heat equation.

To model thermoelastic damping, you must consider both the thermal problem and 
the structural problem. Furthermore, there is a 2-way coupling between them: the 
strain rate heats or cools the material locally, which produces thermal strains.

The relation between the material stress σ and strain ε is given by 

 (2-7)

where εel and εth are the elastic and thermal strains, respectively, D is the 6 × 6 elasticity 
matrix, and all stresses and strains are denoted with 6-component vectors consisting of 
x, y, and z normal components followed by the xy, yx, and xz shear components.

It is possible to expand this for an isotropic material:

 (2-8)

w0 Im λ( )=

Q Im λ( )
2Re λ( )
-------------------=
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where T is the strain temperature, Tref is the stress-free reference temperature, and α 
is the thermal expansion coefficient.

The heat balance equation is

 (2-9)

where k is the thermal conductivity. For a linear thermoelastic solid, the entropy per 
unit volume is:

 (2-10)

where T0 is the reference temperature, the volumetric heat capacity ρCP is assumed 
independent of the temperature, and

 (2-11)

where σ is the stress vector, and αvec is the thermal expansion vector. For an isotropic 
material, Equation 2-11 simplifies into

 (2-12)

For small deformations and small variation of the temperature, Equation 2-9 is 
linearized as:

 (2-13)

Finally, the frequency decomposition for the temperature is performed

 (2-14)

where  is the complex angular frequency. Equation 2-13 gives

 (2-15)

where the heat source term is

 (2-16)

You model the problem with the damped eigenfrequency analysis for the beam, which 
is coupled with the thermal problem Equation 2-15.

T
t∂

∂S ∇ k∇T( )⋅– 0=

S ρCP T T0⁄( )log Selast+=

Selast αvec σ⋅=
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When modeling in 2D, you use the plane stress approximation. Because the third stress 
component vanishes, you can replace Equation 2-16 by

 (2-17)

In the eigenfrequency analysis, you use the temperature computer from Equation 2-15 
as the strain temperature and set the strain reference temperature to zero, Tref = 0. This 
is because the solution physically corresponds to thermoelastic oscillations of small 
amplitude—it is initialized to zero. However, T0 in Equation 2-16 and Equation 2-17 
is the actual temperature of the beam at rest.

Results and Discussion

Figure 2-21 and Figure 2-22 show the eigenmodes and temperature distribution 
corresponding to the found eigenvalue. Solved natural frequencies and Q values are 
given in Table 2-5. Reference data, one calculated with Equation 2-3 to Equation 2-5 
and the others from measurements (see Ref. 1), are also given.

The Q value given by the 3D model appear to be roughly 10% smaller than the other 
estimates. One reason for this difference comes from the simplifying assumption that 
concerns both the Zener’s equation (Equation 2-3) and the plane stress method. For 
example, the plane stress method assumes that the structure is very thin and that there 
are no stresses perpendicular to the plane. However, looking at the 3D model in more 
detail, you find that stresses and their spatial derivatives have components of equal 
magnitude in all three dimensions. The model also assumes that the beam was perfectly 
fixed at its ends. Physically, this cannot happen, and allowing more loose contact 
lowers the natural frequency and improves the Q value.

One factor that also affects the simulated Q values is the boundary condition for the 
thermal equation. This example uses thermal insulation on all boundaries, but you can 
assume that there is a flux of heat at least from both ends of the beam. If you simply 
assign a constant temperature (T = 0) to the beam ends, the Q value improves 

TABLE 2-5:  COMPARISON OF NATURAL FREQUENCY AND Q VALUE.

SOURCE F0 (MHZ) Q

3D model 0.63 MHz 9151

2D model 0.63 MHz 10,170

Equation 0.63 MHz 10,260

Measurements (Ref. 1) 0.57 MHz 10,281

Qheat jω ρCPT
˜

T0α σx σy+( )+( )–=
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considerably. The physically correct result should be somewhere between these two 
estimates.

A look at Figure 2-21 and Figure 2-22 shows a temperature distribution that appears 
to agree with the theory: the temperature is higher near the compressive strain and 
lower near the tensile strain. 

Note, however, that you should not take the displayed temperature range (−4 K to 
4 K) literally because the software normalizes the solution from the eigenfrequency 
solver.

Figure 2-21: First eigenmode and temperature distribution of the 3D model.
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Figure 2-22: First eigenmode and temperature distribution of the 2D model.

Modeling in COMSOL Multiphysics

To create a model of thermoelastic damping with COMSOL Multiphysics requires two 
application modes. For the 3D model, use the Solid, Stress-Strain application mode 
from the MEMS Module and the steady-state Conduction application mode from the 
base package. In 2D, use the Plane Stress application mode from the MEMS Module 
with the same Conduction application mode as in 3D.

In this example you guide the eigenfrequency solver to find the eigenfrequency near 
the expected natural frequency (Equation 2-4). Alternatively, you can first solve the 
undamped eigenfrequency f0 (select Eigenfrequency analysis in the Solver Parameters 
dialog box and solve only for the structural application mode). This approach is also 
valid for more complex geometries where you do not have an analytical expression for 
the estimated natural frequency.

This model, which consists of 2nd-order (structural) and 1st-order (thermal) 
eigenvalue problems, is numerically quite challenging. You can improve the results’ 
accuracy by manually scaling the dependent variables. This is an approach that you can 
use more generally. Once you know the magnitudes of the dependent variables, go to 
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the Advanced page in the Solver Parameters dialog box and define manual scaling of the 
dependent variables.

For the 3D problem you can utilize its symmetry. The beam is truncated to 10 um in 
the width direction. Thus you get a smaller mesh size, but it also makes the problem 
easier to solve because the symmetry condition also prevents any flexural vibrations in 
this direction.

This example uses both rectangular and brick meshes. In 2D, first draw the geometry 
and use a mapped mesh to mesh it. In 3D, you utilize work planes by drawing a 2D 
view of the beam into the work plane. Then mesh it using the mapped mesh, and 
finally, a mesh extrusion creates the true 3D geometry.

In the damped eigenfrequency analysis, the resonator’s quality factor Q is available as 
a predefined variable Qfastor. In the 3D analysis, you can use a predefined variable 
Ent for the elastic part of the entropy Selast. Use the explicit expression given in 
Equation 2-17 for 2D problem.
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Modeling Using the Graphical User Interface—3D Example

M O D E L  N A V I G A T O R

1 In the Model Navigator select 3D in the Space dimension list.

2 Click Multiphysics.

3 From the list of application modes, select MEMS Module>Structural Mechanics> 
Solid, Stress-Strain>Damped eigenfrequency analysis.

4 Click Add.

5 From the list of application modes select  
COMSOL Multiphysics>Heat Transfer>Conduction>Steady-state analysis.

6 Click Add.

7 Click OK.

O P T I O N S  A N D  S E T T I N G S

Select Options>Constants and enter constants from the following table; when finished, 
click OK.

The constant f0 serves as an initial guess for the eigenfrequency solver.

G E O M E T R Y  M O D E L I N G

1 Select Draw>Work-Plane Settings.

2 On the Quick page select the z-x check box.

3 Click OK. The 2D work plane becomes active.

4 Shift-click the Rectangle/Square button on the Draw toolbar.

NAME EXPRESSION DESCRIPTION

E 157[GPa] Young’s modulus

rho 2330[kg/m^3] Density

nu 0.3 Poisson’s ratio

alpha 2.6e-6[1/K] Thermal expansion coefficient

Cp 700[J/(kg*K)] Specific heat capacity

k 90[W/(m*K)] Thermal conductivity

T0 300[K] Ambient and initial beam 
temperature

f0 4.730^2*sqrt(E/(rho*12))* 
12[um]/(2*pi*(400[um])^2)

Theoretical estimate for the 
natural frequency
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5 In the Width edit field type 12e-6, and in the Height edit field type 400e-6.

6 Click OK, then click the Zoom Extents button on the Main toolbar.

M E S H  G E N E R A T I O N

1 In the work plane select Mesh>Mapped Mesh Parameters.

2 In the Subdomain page select the first subdomain and click the Boundary tab.

3 Select Boundary 1.

4 Select the Constrained edge element distribution check box, then enter 25 in the 
Number of edge elements edit field.

5 Select Boundary 2.

6 Select the Constrained edge element distribution check box, then enter 4 in the 
Number of edge elements edit field.

7 Click Remesh, then click OK.

8 Select Mesh>Extrude Mesh.

9 In the Distance edit field type 10e-6.

10 Change to the Mesh page

11 In the Number of element layers edit field type 2.

12 Click OK.

The 3D geometry should open automatically.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Multiphysics menu select 1 Geom1: Solid, Stress-Strain (smsld).

2 Select Physics>Subdomain Settings.

3 Select Subdomain 1, and in the Material page enter settings according to the 
following table: 

4 Click the Load tab.

PROPERTY VALUE

 E E

 ν nu

 α alpha

 ρ rho
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5 Select Include thermal expansion and type T for Temp and 0 for Tempref.

6 Change to the Damping page.

7 From the Damping model list select No damping.

8 Click OK.

9 From the Multiphysics menu select 2 Geom1: Heat Transfer by Conduction (ht).

10 Select Physics>Subdomain Settings.

11 See that Subdomain 1 is selected and in the Material page enter settings from the 
following table:

12 Click OK.

Boundary Conditions
1 From the Multiphysics menu, select 1 Geom1: Solid, Stress-Strain (smsld).

2 Select Physics>Boundary Settings.

3 Select Boundaries 1 and 6.

4 On the Constraint page, set Constraint condition to Fixed.

5 Select Boundary 2.

6 Set Constraint condition list to Symmetry plane.

7 Click OK.

8 From the Multiphysics menu, select 2 Geom1: Heat Transfer by Conduction (ht).

9 Select Physics>Boundary Settings.

10 Verify that Thermal insulation is the default value.

11 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Choose Solve>Solver Parameters.

2 Go to the General page.

3 Type 1 for Desired number of eigenfrequencies.

4 Type f0 for Search for eigenfrequencies around.

5 Go to the Advanced page.

6 Locate the Scaling of variables area and choose Manual for Type of scaling.

PROPERTY VALUE

 k (isotropic) k

 Q -jomega_smsld*(rho*Cp*T+T0*Ent_smsld)
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7 In the Manual scaling edit field, type u 1e-4 v 1e-4 w 1e-4 T 1. Click OK.

8 Click the Solve button on the Main toolbar.

The solver finds a solution with an eigenfrequency of approximately 63,394 Hz.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate the plot in Figure 2-21 follow these steps:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General Page verify that the Boundary, Deformed shape, and Geometry edges 
check boxes are selected and that all others are cleared.

3 Go to the Boundary page and select Heat Transfer by Conduction (ht)>Temperature 
from the Predefined quantities list.

4 Click OK.

You can see the eigenfrequency in the postprocessing plot. Use the Global Data Display 
dialog box to calculate the Q value: 

1 Choose Postprocessing>Data Display>Global.

2 In the Expression edit field, type Qfactor_smsld.

3 Click Apply. You find the Q value in the message log.

Modeling Using the Graphical User Interface—2D Example

Start the model in the Model Navigator. 

1 In the Model Navigator select 2D.

2 Click Multiphysics.

3 From the list of application modes select  
MEMS Module>Structural Mechanics>Plane Stress>Damped eigenfrequency analysis.

4 Click Add.

5 From the list of application modes select  
COMSOL Multiphysics>Heat Transfer>Conduction>Steady-state analysis.

6 Click Add, then click OK.
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O P T I O N S  A N D  S E T T I N G S

Choose Options>Constants and enter constants from the following table:

The constant f0 serves as an initial guess for the eigenfrequency solver.

G E O M E T R Y  M O D E L I N G

1 Shift-click the Rectangle/Square button on the Draw toolbar.

2 In the Width edit field type 400e-6, and in the Height edit field type 12e-6.

3 Click OK, then click the Zoom Extents button on the Main toolbar.

M E S H  G E N E R A T I O N

1 In the work plane select Mesh>Mapped Mesh Parameters.

2 On the Subdomain page, select Subdomain 1.

3 Click the Boundary tab. Select Boundary 1.

4 Select the Constrained edge element distribution check box, then type 5 in the 
Number of edge elements edit field.

5 Select Boundary 2.

6 Select the Constrained edge element distribution check box, then type 25 in the 
Number of edge elements edit field.

7 Click Remesh, then click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings—Plane Stress
1 From the Multiphysics menu, select 1 Plane Stress (smps).

2 Choose Physics>Subdomain Settings.

NAME EXPRESSION DESCRIPTION

E 157[GPa] Young’s modulus

rho 2330[kg/m^3] Density

nu 0.3 Poisson’s ratio

alpha 2.6e-6[1/K] Thermal expansion coefficient

Cp 700[J/(kg*K)] Specific heat capacity

k 90[W/(m*K)] Thermal conductivity

T0 300[K] Ambient and initial beam 
temperature

f0 4.730^2*sqrt(E/(rho*12))* 
12[um]/(2*pi*(400[um])^2)

Theoretical estimate for the 
natural frequency
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3 Select Subdomain 1. On the Material page, enter the following settings:

4 Click the Load tab.

5 Select the Include thermal expansion check box. Enter T for Temp and 0 for Tempref.

6 Change to the Damping page.

7 From the Damping model list, select No damping, then click OK.

Subdomain Settings—Heat Transfer by Conduction
1 From the Multiphysics menu, select 2 Heat Transfer by Conduction (ht).

2 Choose Physics>Subdomain Settings.

3 Verify that Subdomain 1 is selected, then on the Physics page enter settings 
according to the following table; when finished, click OK.

Boundary Conditions—Plane Stress
1 From the Multiphysics menu, select 1 Plane Stress (smps).

2 Choose Physics>Boundary Settings. Select Boundaries 1 and 4.

3 On the Constraint page, set Constraint condition to Fixed, then click OK.

Boundary Conditions—Heat Transfer by Conduction
1 From the Multiphysics menu, select 2 Heat Transfer by Conduction (ht).

2 Choose Physics>Boundary Settings.

3 Verify that Thermal insulation is the default value, then click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Choose Solve>Solver Parameters.

2 On the General page, enter 1 for Desired number of eigenfrequencies.

PROPERTY VALUE

 E E

 ν nu

 α alpha

 ρ rho

 thickness 20e-6

PROPERTY VALUE

 k (isotropic) k

 Q -jomega_smps*(rho*Cp*T+T0*alpha*(sx_smps+sy_smps))
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3 Enter f0 for Search for eigenfrequencies around.

4 Go to the Advanced page.

5 Locate the Scaling of variables area and choose Manual for Type of scaling.

6 In the Manual scaling edit field, type u 1e-4 v 1e-4 T 1. Click OK.

7 Click the Solve button on the Main toolbar.

The solver finds a solution with an eigenfrequency of approximately 63,045 Hz.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate the plot in Figure 2-22 follow the steps below:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, verify that the Boundary, Deformed shape, and Geometry edges 

check boxes are selected, and that all others are cleared.

3 On the Surface page, select Heat Transfer by Conduction (ht)>Temperature from the 
Predefined quantities list. Click OK.

You can see the eigenfrequency in the postprocessing plot. Use the Global Data Display 

dialog box to calculate the Q value: 

1 Select Postprocessing>Data Display>Global.

2 In the Expression edit field type Qfactor_smps.

3 Click Apply. The Q value appears in the message log below the drawing area.
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T h e rmome chan i c a l  M i c r o v a l v e

Introduction

Active microvalves are common components in microfluidic systems (Ref. 1). In a 
thermomechanically actuated microvalve, an electric current generates the movement 
by resistively heating the actuator structure, thereby causing mechanical stress and 
deformation. This example shows how you can couple resistive heating to the 
temperature field and how an increase in temperature expands the solid structure and 
creates the necessary valve movement.

Model Definition

Consider a microvalve consisting of two silicon chips and a substrate as shown in 
Figure 2-23. The lower chip contains a cross-shaped actuator. Doped polysilicon 
heaters reside on the surfaces of the arms. The upper passive chip contains a valve seat 
with an orifice. The heated actuator structure expands, while the colder passive frame 
remains fixed. When the compressive stress accumulates to a critical value, the actuator 
buckles and the valve opens.

Figure 2-23: 2D cross-sectional view of a microvalve structure (left) and a top view of the 
arms (right).

At rest the valve is closed. When a voltage difference is applied across the ends of the 
heater elements, the resulting current resistively heats the doped polysilicon area. The 
heat conducts to the membrane, where it introduces stress and strain and finally causes 
the membrane to buckle, thereby opening the valve.

For analytical purposes, you can study an even more simplified structure. Consider a 
cantilever beam clamped rigidly at both ends as shown in Figure 2-24.
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Figure 2-24: A simple cantilever-beam model. Both ends of the beam are tightly clamped 
into supporting frames.

In such a configuration, the central deflection, δc, of the silicon bridge is approximately 
given by

where L is the beam length, α is the thermal expansion coefficient, and ∆T is the 
temperature difference between the membrane and the surrounding silicon frame 
(Ref. 2). You determine the critical buckling temperature difference, ∆Tcrit, by 
substituting the strain generated by this temperature difference, ε = α∆Tcrit, into the 
equation of the critical-buckling strain εcrit = π2t2/(3L2), where t is the beam’s 
thickness. The result reads

.

For example, if a silicon bridge is 12 µm thick and 2600 µm long, and the thermal 
expansion coefficient is 2.6·10−6/K, the critical temperature difference is 27 °C. A 
temperature difference of 200 °C then creates a deflection of 35 µm.

Modeling in COMSOL Multiphysics

This example models only the active cross-shaped actuator portion of the structure. It 
applies a potential difference to the ends of the heaters. Assuming that there are no 
external current sources and that the electric field is static, you can use the following 
equation to model the conductive surface:

Here σs is the surface conductivity and V is the electric potential. The surface 
conductivity is the reciprocal of the surface resistivity, σs = 1/ρs. You can also obtain 
it by multiplying the conductivity, σ, with the layer thickness, tl, that is, σs = tl σ. The 

δc
2
π
---L α ∆T ∆Tcrit–( )=

∆Tcrit
π2t

2

3α L2
---------------=

∇– σ( s V )∇⋅ 0=
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model uses the Conductive Media DC application mode’s electric-shielding boundary 
condition to model the conductive layer.

Next calculate the resistive heat power generated in the layer per unit surface area, q, 
from the equation

where  denotes the gradient in the directions tangential to the surface. The resistive 
heating couples to the Heat Transfer by Conduction application mode as an inward 
heat-flux term on the relevant boundaries. In the absence of internal heat sources, the 
equation for the temperature field, T, is analogous to the conductive media equation:

Here k denotes the thermal conductivity. The model couples the temperature to the 
Plane Stress (in 2D) or Solid, Stress-Strain (in 3D) application mode’s subdomain 
stress-load thermal expansion. Because the ends of the actuator arms are rigidly 
connected to the surrounding frame, the cross-shaped structure starts to deform.

Although the model geometry and the couplings of the application modes are rather 
simple, the meshing and solution require special techniques. The 2D model uses a 
mesh-mapping technique to generate a regular rectangular mesh. The 3D model 
increases the setting for the mesh scaling in the z direction from 1 to 10 to decrease 
the mesh size and the number of degrees of freedom. Depending on the amount of 
available memory on your computer, you can tune this value to increase or decrease 
the mesh size and thus change the solution accuracy.

Due to the problem’s high degree of nonlinearity, this example solves the model using 
the parametric nonlinear solver; direct use of the nonlinear static solver can lead to 
solution errors.

The following tables show the dimensions and material parameters for the model:

STRUCTURE DIMENSION MEASURE

Arm length 1000 µm

Arm width 600 µm

Structure height 12 µm

Cross-section area 600 µm  x 600 µm

q tlσ Et Et⋅ σs Vt∇ 2
= =

∇t

∇– k T∇( )⋅ 0=
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Note: The heat capacity drops out of the heat equation for stationary analyses and is 
given here for the sake of completeness only.

Results and Discussion

The following figures show the deformed shape and the deformation versus voltage 
both in 2D and 3D.

The 2D model gives values that agree well with the analytical result for a rigidly 
clamped cantilever beam: when the maximum deflection in the 2D model is 35 µm, 
the average temperature difference is 195 K compared to the analytical prediction of 
200 K—a difference of only roughly 2.5%.

The 3D model, on the other hand, differs substantially from these results. Here, the 
maximum deformation 35 µm is reached for a voltage of 9.75 V with a corresponding 
average temperature difference of 364 K.

MATERIAL PROPERTY VALUE

Material Polysilicon

Young’s modulus 160 GPa

Poisson’s ratio 0.22

Coefficient of thermal expansion 2.6·10-6 1/K

Density 2320 kg/m3

Thermal conductivity 34 W/(m·K)

Heat capacity 678 J/(kg·K)

Sheet resistivity, heater layer 20 Ω

Doping-layer thickness 600 nm

Electric conductivity, membrane bulk 10-10 S/m
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.

Figure 2-25: Deformed shape and temperature in 2D.

Figure 2-26: Deformed shape and temperature in 3D.
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Figure 2-27: Deformation (y-displacement) versus voltage in 2D.

Figure 2-28: Deformation (z-displacement) versus voltage in 3D.
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Modeling Using the Graphical User Interface (2D)

Model Library path: MEMS_Module/Actuator_Models/
thermomechanical_valve_2d

M O D E L  N A V I G A T O R

1 In the Model Navigator, click the New tab. From the Space dimension list, select 2D.

2 Click the Multiphysics button.

3 From the list of application modes, select  
MEMS Module>Structural Mechanics>Plane Stress>Parametric analysis, then click Add.

4 From the list of application modes, select  
COMSOL Multiphysics>Heat Transfer>Conduction>Steady-state analysis, then click Add.

5 From the list of application modes, select  
MEMS Module>Electrostatics>Conductive Media DC, then click Add.

6 Click OK.

O P T I O N S  A N D  S E T T I N G S

Constants
1 From the Options menu, choose Constants.

2 Add the following constants (note that COMSOL Multiphysics automatically fills 
in the Value column); when finished, click OK.

NAME EXPRESSION DESCRIPTION

d 0.6[mm] Bridge width

T_ref 25[degC] Reference temperature

sigma_b 1e-10[S/m] Electric conductivity, membrane bulk
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It is not strictly necessary to define V_in at this stage because you specify it later as the 
solver parameter. However, by defining V_in as a constant you avoid inconsistent-unit 
warnings, which occur when you enter an undefined constant in an edit field that 
expects input with a specific unit. It also allows you to try solving the problem directly 
using the stationary solver.

G E O M E T R Y  M O D E L I N G

1 Shift-click the Rectangle/Square button on the Draw toolbar and create the following 
rectangle; when done, click OK.

2 Shift-click the Point button on the Draw toolbar and add these two points; when 
done, click OK.

3 Click the Zoom Extents button.

Initial geometry of the simplified thermomechanical microvalve’s active element in 2D.

P H Y S I C S  S E T T I N G S

Application Mode Properties—Plane Stress
1 From the Multiphysics menu, select Plane stress (smps).

2 From the Physics menu, select Properties.

rho_s 20[ohm] Surface resistivity

t_l 600[nm] Heater-layer thickness

sigma_s 1/rho_s Surface conductivity

sigma sigma_s/t_l Electric conductivity, heater layer

V_in 2[V] Voltage

NAME SIZE POSITION

WIDTH HEIGHT BASE X Y

R1 2600e-6 12e-6 Corner 0 0

NAME X Y

PT1 800e-6 12e-6

PT2 1800e-6 12e-6

NAME EXPRESSION DESCRIPTION
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3 In the Application Mode Properties dialog box, set Large deformation to On.

4 Click OK.

Subdomain Settings—Plane Stress
1 From the Physics menu, choose Subdomain Settings.

2 In the Subdomain selection list, select 1.

3 Click the Load button to open the Materials/Coefficients Library dialog box.

4 From the Materials tree, select MEMS Material Properties>Semiconductors>Poly-Si, 
then click OK.

5 In the thickness edit field, type d.

6 Click the Load tab. Select the Include thermal expansion check box, then specify 
settings according to the following table; when done, click OK.

Boundary Conditions—Plane Stress
1 From the Physics menu, choose Boundary Settings.

2 On the indicated pages, specify these boundary conditions; when done, click OK.

Apply a downward load of 0.01 N/m along Boundary 2 to initiate buckling of the 
structure. You can easily verify that a value in the range of 0.001 N/m to 0.1 N/m has 
a negligible effect on the solution.

Subdomain Settings—Heat Transfer by Conduction
1 From the Multiphysics menu, select Heat Transfer by Conduction (ht).

2 From the Physics menu, choose Subdomain Settings.

3 In the Subdomain selection list, select 1.

4 From the Library material list, select Poly-Si, then click OK.

PROPERTY VALUE DESCRIPTION

Temp T Strain temperature

Tempref T_ref Strain ref. temperature

SETTINGS VALUE ON BOUNDARY DESCRIPTION

1, 6 2 OTHERS

CONSTRAINT PAGE

Constraint condition Fixed Free Free
LOAD PAGE

Fy -0.01 Edge load y dir.
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Boundary Conditions—Heat Transfer by Conduction
1 From the Physics menu, choose Boundary Settings.

2 Enter the following values in the Boundary Settings dialog box; when done, click OK.

For Boundaries 2 and 4, leave the default thermal-insulation boundary condition.

Subdomain Settings—Conductive Media DC
1 From the Multiphysics menu, select Conductive Media DC (emdc).

2 From the Physics menu choose Subdomain Settings.

3 From the Subdomain selection list or in the drawing area, select Subdomain 1.

4 In the σ (isotropic) edit field type sigma_b. (The solution is rather insensitive to this 
parameter value, as long as it is small but nonzero.)

5 Click OK.

Boundary Conditions—Conductive Media DC
1 From the Physics menu, choose Boundary Settings.

2 In the Boundary Settings dialog box, enter these boundary conditions and values; 
when done, click OK.

Point Settings—Conductive Media DC
1 From the Physics menu, choose Point Settings.

2 In the Point Settings dialog box, enter the following values; when done, click OK.

SETTINGS BOUNDARIES 1, 6 BOUNDARIES 3, 5 DESCRIPTION

Boundary 
condition

Temperature Heat flux

q0 q Inward heat flux

T0 T_ref Temperature

SETTINGS  BOUNDARIES 1, 2, 4, 6 BOUNDARIES 3, 5

Boundary condition Electric insulation Electric shielding

Conductivity sigma

Thickness t_l

SETTINGS POINTS 1, 5 POINTS 2, 6 POINTS 3, 4 DESCRIPTION

Qj0 0 Point current source

V0 0 V_in Electric potential
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Boundary Expressions—Conductive Media DC
1 From the Options menu, choose Expressions>Boundary Expressions.

2 Select Boundaries 3 and 5. Enter the following properties in the table’s first row:

3 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, choose Mapped Mesh Parameters.

2 Click the Boundary tab.

3 Enter these values for the boundaries:

4 Click the Remesh button.

5 Click OK.

S O L V I N G  T H E  M O D E L

1 From the Solve menu, choose Solver Parameters.

2 On the General page, select Parametric from the Analysis list.

3 Set the Parameter name to V_in and the Parameter values to 0:0.1:2.

4 Click the Parametric tab. From the Predictor list, select Constant. This change from 
the default linear prediction method is necessary to remain on the first deformation 
mode (with a single node) as the voltage is turned up.

5 Click OK.

6 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Temperature Distribution and Deformed Shape
Follow the steps below to reproduce Figure 2-25 on page 126.

1 From the Postprocessing menu, choose Plot Parameters.

2 Click the General tab.

NAME EXPRESSION

q sigma_s*(VTx^2+VTy^2)

SETTINGS VALUE ON BOUNDARY

1 2 3 4

Constrained edge element distribution         Selected

Number of edge elements 4 65 20 25
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3 In the Plot type area, select the check boxes Surface, Max/min marker, Deformed shape, 
and Geometry edges.

4 Click the Surface tab.

5 On the Surface Data page, select Heat-Transfer by Conduction (ht)>Temperature from 
the Predefined quantities list. From the Unit list, select oC (or type degC in the edit 
field).

6 Click the Max/Min tab.

7 On the Subdomain Data page, select Plane Stress (smps)>Total displacement from the 
Predefined quantities list. From the Unit list, select µm (or type um in the edit field).

8 Click OK.

9 Click the Zoom Extents button on the Main toolbar.

For comparison with theoretical values, calculate the difference between the average 
temperature in the active element and the surroundings.

1 From the Postprocessing menu, select Subdomain Integration.

2 Select Subdomain 1 and enter the Expression (T-T_ref)/(2.6[mm]*12[um]).

3 Click OK.

The average temperature difference value (roughly 194.8 K) appears in the message 
log at the bottom of the user interface.

Centerpoint Analysis
Follow the steps below to reproduce the plot in Figure 2-27 on page 127.

1 From the Postprocessing menu, choose Cross-Section Plot Parameters.

2 Click the Point tab.

3 From the Predefined quantities list inside the y-axis data area, select Plane Stress 

(smps)>y-displacement. From the Unit list, select µm.

4 In the edit fields for x and y inside the Coordinates area, type 1300e-6 and 12e-6, 
respectively.

5 Click OK.
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Modeling Using the Graphical User Interface (3D)

Model Library path: MEMS_Module/Actuator_Models/
thermomechanical_valve_3d

M O D E L  N A V I G A T O R

1 In the Model Navigator click the New tab, go to the Space dimension list, and select 3D.

2 Click the Multiphysics button.

3 From the list of application modes select  
MEMS Module>Structural Mechanics>Solid, Stress-Strain>Parametric analysis, then 
click Add.

4 From the list of application modes select  
COMSOL Multiphysics>Heat  Transfer>Conduction>Steady-state analysis, then click 
Add.

5 From the list of application modes select MEMS Module>Conductive Media DC, then 
click Add.

6 Click OK.

O P T I O N S  A N D  S E T T I N G S

Constants
1 From the Options menu, choose Constants.

2 Add the following constants, (note that COMSOL Multiphysics automatically fills 
in the Value column); when finished, click OK.

NAME EXPRESSION DESCRIPTION

E 161[GPa] Young’s modulus

nu 0.33 Poisson’s ratio

alpha 2.3e-6[1/K] Thermal expansion coefficient

rho 2320[kg/m^3] Density

d 0.6[mm] Bridge width

T_ref 25[degC] Reference temperature

k 34[W/(m*K)] Thermal conductivity

sigma_b 1e-10[S/m] Electric conductivity, membrane bulk

rho_s 20[ohm] Surface resistivity
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G E O M E T R Y  M O D E L I N G

Work-Plane Settings
1 From the Draw menu, choose Work-Plane Settings.

2 Accept the default settings (an xy-plane at z = 0) by clicking OK.

Creating Objects
1 Shift-click the Rectangle/Square tool on the Draw toolbar and create ten rectangles; 

when done, click OK.

t_l 600[nm] Heater-layer thickness

sigma_s 1/rho_s Surface conductivity

sigma sigma_s/t_l Conductivity

V_in 2[V] Voltage

NAME SIZE POSITION

WIDTH HEIGHT BASE X Y

R1 2600e-6 600e-6 Corner -1300e-6 -300e-6

R2 600e-6 2600e-6 Corner -300e-6 -1300e-6

R3 800e-6 400e-6 Corner -1300e-6 -200e-6

R4 700e-6 200e-6 Corner -1300e-6 -100e-6

R5 800e-6 400e-6 Corner 500e-6 -200e-6

R6 700e-6 200e-6 Corner 600e-6 -100e-6

R7 400e-6 800e-6 Corner -200e-6 500e-6

R8 200e-6 700e-6 Corner -100e-6 600e-6

R9 400e-6 800e-6 Corner -200e-6 -1300e-6

R10 200e-6 700e-6 Corner -100e-6 -1300e-6

NAME EXPRESSION DESCRIPTION
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The rectangles that make up the geometry of the thermomechanical microvalve’s active 
element in 3D.

2 From the Draw menu, choose Create Composite Object.

3 Clear the Keep interior boundaries check box.

4 In the Set formula edit field, enter these formulas to create composite objects; when 
done, click OK.

NAME SET FORMULA

CO1 R1+R2

CO2 R3-R4

CO3 R5-R6

CO4 R7-R8

CO5 R9-R10
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The composite objects that make up the geometry of the thermomechanical microvalve’s 
active element in 3D.

Extruding and Embedding into 3D
1 From the Draw menu, choose Extrude.

2 From the Objects to extrude list, select CO1.

3 Enter the following values in the Extrude parameters dialog box; when done, click 
OK.

NAME VALUE

Distance -12e-6

Scale x 1

Scale y 1

Displacement x 0

Displacement y 0

Twist (degrees) 0
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The extruded geometry of the thermomechanical microvalve’s active element in 3D.

4 Click the Geom2 tab at the top of the drawing area.

5 From the Draw menu, choose Embed.

6 In the Objects to embed list select CO2, CO3, CO4, and CO5; when done, click OK.

The actuator arms embedded in the overall geometry.

P H Y S I C S  S E T T I N G S

Application Mode Properties—Plane Stress
1 From the Multiphysics menu, choose Solid, Stress-Strain (smsld).

2 From the Physics menu, select Properties.
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3 In the Application Mode Properties dialog box, change Large deformation to On.

4 Click OK.

Subdomain Settings—Plane Stress
1 From the Physics menu, choose Subdomain Settings.

2 In the Subdomain selection list, select 1.

3 Enter settings according to the following table:

4 Click the Load tab. Select the Include thermal expansion check box, then specify 
settings according to the following table; when done, click OK.

Boundary Conditions—Plane Stress
1 From the Physics menu, choose Boundary Settings.

2 Select Boundaries 1, 9, 11, and 22. On the Constraint page, select Fixed from the 
Constraint condition list.

3 Click the Load tab. Select Boundary 3. In the Fz edit field, type -1.

As in the 2D case, you apply a small transverse load to simulate a perturbation that 
triggers buckling of the valve.

4 Click OK.

Subdomain Settings—Heat Transfer by Conduction
1 From the Multiphysics menu, choose Heat Transfer by Conduction (ht).

2 From the Physics menu, choose Subdomain Settings.

3 In the Subdomain selection list, select 1.

4 From the Library material list, select Poly-Si, then click OK.

Boundary Conditions—Heat Transfer by Conduction
1 From the Physics menu, choose Boundary Settings.

PROPERTY VALUE DESCRIPTION

 E E Young’s modulus

 ν nu Poisson’s ratio

 α alpha Thermal expansion coeff.

 ρ rho Density

PROPERTY VALUE DESCRIPTION

Temp T Strain temperature

Tempref T_ref Strain ref. temperature
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2 Enter the following values in the Boundary Settings dialog box; when done, click OK.

At boundaries not mentioned in the table, the default thermal-insulation condition 
applies.

Subdomain Settings—Conductive Media DC
1 From the Multiphysics menu, choose Conductive Media DC (emdc).

2 From the Physics menu, choose Subdomain Settings.

3 From the Subdomain selection list, select 1.

4 In the σ (isotropic) edit field, type sigma_b.

5 Click OK.

Boundary Conditions—Conductive Media DC
1 From the Physics menu, choose Boundary Settings.

2 Enter the following boundary values; when done, click OK.

Edge Settings—Conductive Media DC
1 From the Physics menu, choose Equation System>Edge Settings.

2 Enter the following values in the dialog box; when done, click OK.

Boundary Expressions
1 From the Options menu, choose Expressions>Boundary Expressions.

SETTINGS BOUNDARIES 1, 9, 11, 22 BOUNDARIES 5, 12, 13, 20 DESCRIPTION

Boundary condition Temperature Heat flux

q0 q Inward heat flux

T0 T_ref Temperature

SETTINGS BOUNDARIES 1–4, 6–11, 14–19, 21, 22 BOUNDARIES 5, 12, 13, 20

Boundary condition Electric insulation Electric shielding

 σ sigma

 d t_l

SETTINGS EDGES 10, 32, 46, 72 EDGES 6, 36, 44, 74 ALL OTHERS DESCRIPTION

Qlj 0 Line current source

V0 0 V_in Electric potential
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2 Add the following boundary expression; when done, click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, choose Free Mesh Parameters.

2 Click the Advanced tab.

3 In the z-direction scale factor edit field, type 10.

4 Click the Remesh button.

5 Click OK. The initialized mesh consists of roughly 2150 elements.

S O L V I N G  T H E  M O D E L

Solver Parameters
1 From the Solve menu, choose Solver Parameters.

2 From the Analysis list, select Parametric.

3 In the Parameter name edit field, type V_in.

4 In the Parameter values edit field, type 0:0.25:10.

5 Click OK.

Solving the Electric Potential
1 From the Solve menu, choose Solver Manager.

2 Click the Initial Value tab.

3 In the Initial value area, click the Initial value expression button.

4 In the Values of variables not solved for and linearization point area, click the Zero 
button.

5 Click the Solve For tab.

6 From the Solve for variables list, select Conductive Media DC (emdc).

7 Click the Solve button.

Solving the Heat Transfer Problem
1 Click the Initial Value tab.

2 Click the Store Solution button.

3 Make sure that all the solutions are selected, then click OK.

SETTINGS BOUNDARIES 5, 12, 13, 20

q sigma*t_l*(VTx^2+VTy^2+VTz^2)
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4 In the Values of variables not solved for and linearization point area, click the 
Stored solution button.

5 From the Parameter value list, select All.

6 Click the Solve For tab.

7 From the Solve for variables list, select Heat Transfer by Conduction (ht).

8 Click the Solve button.

Solving the Plane Stress Problem
1 Click the Initial Value tab.

2 Click the Store Solution button.

3 In the Store Solution dialog box, click OK.

4 Click the Solve For tab.

5 From the Solve for variables list, select Solid, Stress-Strain (smsld).

6 Click the Solve button; the solution could take several minutes to compute.

7 Click OK.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Temperature Distribution and Deformed Shape
Follow the steps below to create Figure 2-26 on page 126.

1 From the Postprocessing menu, choose Plot Parameters.

2 Click the General tab.

3 In the Plot type area, select the check boxes Boundary, Max/min marker, Deformed 

shape, and Geometry edges. Clear all other check boxes.

4 Click the Boundary tab.

5 In the Predefined quantities list, select Heat Transfer by Conduction (ht)>Temperature.

6 In the Unit list, select oC.

7 Click the Max/Min tab.

8 From the Predefined quantities list on the Subdomain Data page, select 
Solid, Stress-Strain (smsld)>Total displacement. From the Unit list, select µm.

9 Click OK.

10 Click the Zoom Extents button on the Main toolbar.

Next, calculate the difference between the average temperature in the active element 
and the surroundings.
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1 From the Postprocessing menu, select Subdomain Integration.

2 Select Subdomain 1 and enter the Expression (T-T_ref)/3.312e-11[m^3]. The 
denominator is the actuator’s volume. This value is available on the Subdomain page 
of the Geometric Properties dialog box that you open from the Postprocessing menu.

3 In the Solution to use area, select 9.75 from the Parameter value list.

4 Click OK.

The average temperature difference value (roughly 364 K) appears in the message 
log at the bottom of the user interface.

Cross-Section Analysis
Follow the steps below to create Figure 2-28 on page 127.

1 From the Postprocessing menu, choose Cross-Section Plot Parameters.

2 Click the Point tab.

3 From the Predefined quantities list inside the y-axis data area, select 
Solid, Stress-Strain (smsld)>z-displacement. From the Unit list, select µm.

4 Click OK.
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 3
M E M S  S e n s o r  M o d e l s
This chapter highlights models that describe different types of sensors in MEMS 
devices. The accelerometer example shows modeling in both 2D and 3D. An 
example of a pressure sensor describes a device that measures static pressures in the 
range from zero up to atmospheric pressure. Another model uses the Material 
Library to simulate thermal expansion in a MEMS device that could be part of a 
microgyroscope.
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S qu e e z e d - F i lm Ga s  Damp i n g  i n  an 
A c c e l e r ome t e r

Micromechanical structures that use capacitance to measure another parameter such as 
acceleration typically have a very narrow gap between their electrodes. The gap usually 
contains gas, which damps the movements of the mechanical parts. This model of a 
microsystem accelerometer shows how to couple squeezed-film gas damping, which 
you model with the linearized Reynolds equation, to displacements in the sensor.

Introduction

Squeezed-film gas damping is a critical aspect of many MEMS transducers and 
actuators. An example of a typical microsystem component where gas-damping 
properties are important is the accelerometer common in vehicle motion-control and 
safety systems.

In accelerometers, inertia produces a motion that the device detects. A typical 
structure connects a large proof mass, with dimensions typically in millimeters, to 
surrounding structures with elastic beams. This combination forms a mechanical 
oscillator with a specific resonance frequency. However, in accurate motion-detection 
applications these resonances are unwanted, and the device damps the movements to 
produce smooth time-step and frequency responses. Such a device can usually achieve 
suitable damping with a low gas pressure (100 Pa–1000 Pa) which, considering the 
dimensions of the device, lead to rarefied gas effect in the system. 

A narrow gap formed by two solid horizontal plates restricts the displacement of the 
gas perpendicular to the surfaces. When the sensor squeezes the gap, the gas flows out 
from its edges. The narrow pathway restricts the flow, which causes gas pressure to 
increase, which decelerates the plates’ movement. 

You can model the pressure distribution in the narrow gap with the modified 
Reynold’s equation

where pF denotes the gas film pressure variation, p = pA + pF is the total fluid pressure 
consisting of the initial/ambient pressure and the variation, h = h0 + ∆h is the gap 

∇ h3Qch p∇pF( )⋅ 12η
td

dpFh p
td

dh
+⎝ ⎠

⎛ ⎞=
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height consisting of the initial gap and the deformation in the normal direction of the 
boundary, and η is the fluid viscosity at normal conditions. The term Qch denotes the 
relative flow rate function that accounts for the rarefied gas effects. Veijola and others 
(Ref. 2) have used a simple equation for the relative flow coefficient

which is valid for . The Knudsen number is the ratio between the gas’ 
mean free path, λ, and the gap height, h:

and the coefficient σP is calculated from the tangential momentum accommodation 
coefficient, αv:

.

The mean free path at a pressure p comes from

where λ0 is the mean free path at the reference pressure p0.

Another way to tune the damping is to perforate the structure with holes. By adding 
a term related to the gas flow through the holes, it is also possible to use the Reynolds 
equation for perforated plates. For more information about this approach see Ref. 3.

Model Definition

This example models the solid moving parts in the accelerometer using the Solid, 
Stress-Strain application mode in 3D and using the Plane Strain application mode in 
2D. This model solves the squeezed-film air damping on the lower and upper surfaces 
using the Film Damping application mode. The model constrains the film pressure, pF, 
to 0 at the edges of the boundary.

The following two figures show the accelerometer geometry in 3D and in 2D. The 
model consists of two thin silicon cantilever beams and a silicon proof mass. The 
cantilever beams are fixed to the surrounding structures at one end. The proof mass 
reacts to inertial forces and bends the cantilevers. The external acceleration, a, acts in 
the z direction and causes a body volume force Fz = ρsolid a.

Qch 1 9.638 σP Kn( )1.159
+=

0 Kn 880≤ ≤

Kn λ h⁄=

σP
2 αv–

αv
--------------- 1.016 0.1211 1 αv–( )–( )=

λ p0λ0( ) p⁄=
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In 2D the two cantilevers are lumped as one structure whose thickness equals the sum 
of the two cantilevers. Consequently, the model has two domains with different 
thicknesses at the connecting boundary. Thus you should be prudent when inspecting 
stress levels near this area.

Model geometry in 3D.

Model geometry in 2D.
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The following tables list the structures’ dimensions as well as pertinent material and 
gas properties used to calculate the effective viscosity:

Results and Discussion

Figure 3-1 shows the pressure distribution on the surface of the proof mass after 4 ms 
of simulation. The ambient pressure, pA, in this case is 300 Pa, and the acceleration 
switches on at the beginning of the simulation. The acceleration’s magnitude is half 
that due to gravity, g. In this figure, the maximum displacement at the tip of the proof 
mass is roughly 0.4 µm, or 0.1% of its thickness.

Figure 3-2 shows the total displacement of the proof mass tip as a function of time for 
ambient pressures of 3 Pa, 30 Pa, and 300 Pa. As ambient pressure increases, the film 
damping at the upper and lower surfaces increases through the increase in the gas’ 
effective viscosity and density. This increased damping results in a substantial decrease 
in oscillation with increasing pressure. At 300 Pa, there is no apparent oscillations, and 
the proof mass seems asymptotically to reach the value of 0.2 µm in total displacement.

PARAMETER CANTILEVERS PROOF MASS GAP

Length 520 µm 1780 µm 1780 µm

Height 40 µm 400 µm 3.95 µm

Width 100 µm 2960 µm 2960 µm

PARAMETER VALUE

Structure material Silicon

Young’s modulus 131 GPa

Poisson’s ratio 0.27

Density 2330 kg/m3

Viscosity of the gas 22.6·10-6 Ns/m2

λ0 70 nm

p0 101.325 kPa
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Figure 3-1: A load on the face of the proof mass in the z direction leads to a deformation.

Figure 3-2: Plot of the displacement of the proof mass tip at ambient pressures of 3 Pa 
(dashed line), 30 Pa (dashed-dotted line), and 300 Pa (solid line).
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Modeling Using the Graphical User Interface (2D)

Model Library path: MEMS_Module/Sensor_Models/accelerometer_2d

Use the following instructions to create the 2D version of the accelerometer model.

M O D E L  N A V I G A T O R

1 Open the Model Navigator, from the Space dimension list select 2D.

2 In the list of application modes select MEMS Module>Structural Mechanics> 
Plane Strain with Film Damping>Transient analysis.

3 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu choose Constants.

2 In the Constants dialog box enter names, expressions, and descriptions (optional) for 
the following constants; when done click OK.

NAME EXPRESSION DESCRIPTION

accel 9.81[m/s^2]/2 Applied acceleration 

P_A 300[Pa] Ambient gas pressure
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G E O M E T R Y  M O D E L I N G

1 Open the Rectangle dialog box either by Shift-clicking the Rectangle/Square button 
on the Draw toolbar or by going to the Draw menu and choosing Specify 

Objects>Rectangle. Create these two rectangles:

2 Click the Zoom Extents button on the Main toolbar.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Multiphysics menu choose the Plane Strain (smpn) application mode.

2 From the Physics menu choose Subdomain Settings.

3  Enter the following values in the Subdomain Settings dialog box:

4 While still on the Load page, click the Body load is defined as force/volume using the 

thickness option button for both subdomains.

NAME SIZE POSITION

WIDTH HEIGHT BASE X Y

R1 1780e-6 400e-6 Corner 0 0

R2 520e-6 40e-6 Corner -520e-6 180e-6

QUANTITY VALUE IN SUBDOMAIN DESCRIPTION

1 2

MATERIAL PAGE

 Library material Silicon Click the Load button, go to 
Materials>Basic Material Properties 
and select Silicon

  E 131e9[Pa] Young’s modulus

  ν 0.27 Poisson’s ratio

  α 4.15e-6[1/K] Coefficient of thermal expansion

 ρ 2330[kg/m^3] Density

 thickness 200e-6 2960e-6 Thickness

LOAD PAGE

Fx 0 Body load (force/volume), x dir.

Fy -rho_smpn*accel Body load (force/volume), y dir.

DAMPING PAGE

Damping model No damping
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5 Click OK.

Boundary Conditions
1 From the Multiphysics menu verify that you the Plane Strain (smpn) application mode 

is still selected.

2 From the Physics menu choose Boundary Settings.

3 Select Boundary 1, and on the Constraint page select Fixed from the Constraint 

condition list.

4 Click the Groups tab, and in the Name edit field (under the Group selection list) type 
Fixed; then press Enter.

5 Click the Boundaries tab.

6 Select Boundaries 5 and 8. From the Group list select Film damping (click the Load 
tab to see the predefined loads)

7 Click OK.

8 From the Multiphysics menu choose the Film Damping (mmfd) application mode.

9 From the Physics menu choose Boundary Settings.

10 From the Boundaries list select 5 and 8, and from the Group list select Film damping.

11 In the Settings page enter the following boundary settings (some of them are correct 
initially); when done, click OK.

Point Settings
The default point setting, which sets the film pressure to zero, is sufficient for this 
model.

QUANTITY VALUE ON BOUNDARY

5, 8

dx,dy u v

h0 3.95e-6

pA P_A

λ0 70e-9

101325

η 22.6e-6

αv 1

Qch Model 1.

Use perforation effects No

pλ 0,
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C O U P L I N G  V A R I A B L E S

To observe the total damping force, create two integration coupling variables with 
these steps:

1 From the Options menu select Integration Coupling Varaibles>Boundary Variables.

2 In the dialog that opens define coupling variables (each variable on a separate row) 
according to the following table; when done, click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu select Free Mesh Parameters.

2 Keep the Predefined mesh sizes selection Normal, then click the Custom mesh size 
button.

3 Set Resolution of narrow regions to 2.

4 Click Remesh, then click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 From the Solve menu choose Solver Parameters.

2 Keep the time-dependent analysis and solver, and make the following changes in the 
Solver Parameters dialog box; when done, click OK:

3 Click the Solve button on the Main toolbar to start the analysis.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 From the Postprocessing menu choose Plot Parameters.

2 Click the Surface tab.

BOUNDARY NAME EXPRESSION INTEGRATION 
ORDER

GLOBAL 
DESTINATION

5 force_bot -ny*pf*thickness_smpn 4 yes

8 force_top -ny*pf*thickness_smpn 4 yes

PARAMETER VALUE

Analysis Transient

Auto select solver yes

GENERAL PAGE

Times 0:1e-5:4e-3

TIME STEPPING PAGE

Time steps taken by the solver Intermediate
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3 In the Surface data area choose Plane Strain>Total displacement from the Predefined 

quantities list.

4 Click the Arrow tab and select the Arrow plot check box.

5 In the Plot arrows on list select Boundaries. Click the Boundary Data tab and select 
Film Damping>Pressure load from the Predefined quantities list.

6 Click the Deform tab and select the Deformed shape plot check box.

7 Click OK.

8 From the Postprocessing menu choose Domain Plot Parameters.

9 Select the Point page and from the Point selection list select Point 7.

10 Select Plane Strain>y-displacement from the Predefined quantities list.

11 Click Apply.

12 Type force_bot in the Expression edit field.

13 Click OK.

If you want to compare the step responses in the same figure window for different 
pressures, open the Constants dialog box and change the value for pA to 3[Pa] or 
300[Pa]. Then click the Solve button again, and when the solution is ready, open the 
Domain Plot Parameters dialog box. Go to the General page and select the Keep current 

plot check box. Following this procedure plots both step responses in the same graph 
when you click OK or Apply.

You might also want to animate the step response. To do so:

1 Open the Plot Parameters dialog box and click the Animate tab.

2 Select AVI or QuickTime from the File type list.

3 Click the Start Animation button.

Modeling Using the Graphical User Interface (3D)

Model Library path: MEMS_Module/Sensor_Models/accelerometer_3d

Use the following instructions to create the 3D version of the accelerometer model.

M O D E L  N A V I G A T O R

1 Open the Model Navigator and select 3D from the Space dimension list.
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2 Select the application mode MEMS Module>Structural Mechanics>Solid, Stress-Strain 

with Film Damping>Transient analysis.

3 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu select Constants.

2 In the Constants dialog box enter these variable names, expressions, and descriptions 
(optional); when done, click OK.

G E O M E T R Y  M O D E L I N G

1 Open the Block dialog box; to do so either go to the Draw menu and choose Block, 
or Shift-click the Block button on the Draw toolbar on the left side of the user 
interface.

2 Create these three solid blocks:

3 Click the Zoom Extents button.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Multiphysics menu select the Solid, Stress-Strain (smsld) application mode.

2 From the Physics menu select Subdomain Settings.

3 Enter the following subdomain settings values; when done, click OK.

NAME EXPRESSION DESCRIPTION

accel 9.81[m/s^2]/2 Applied acceleration

P_A 300[Pa] Ambient gas pressure

NAME LENGTH AXIS BASE POINT

X Y Z X Y Z

BLK1 1780e-6 2960e-6 400e-6 0 0 0

BLK2 520e-6 100e-6 40e-6 -520e-6 200e-6 180e-6

BLK3 520e-6 100e-6 40e-6 -520e-6 2660e-6 180e-6

QUANTITY VALUE IN SUBDOMAIN DESCRIPTION

1–3

MATERIAL PAGE

Library material Silicon Click the Load button, go to Materials>Basic 
Material Properties and select Silicon
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Boundary Conditions
1 Verify on the Multiphysics menu that the Solid, Stress-Strain (smsld) application mode 

is still selected.

2 From the Physics menu select Boundary Settings.

3 Select Boundaries 1 and 6.

4 On the Constraint page select Fixed from the Constraint condition list. 

5 Click the Group tab and type Fixed in the Name edit field, then press Enter.

6 Click the Boundaries tab. 

7 Select Boundaries 13 and 14, and from the Group list select Film damping; notice the 
predefined load on the Load page. Click OK.

8 From the Multiphysics menu select the Film Damping (mmfd) application mode.

9 From the Physics menu select Boundary Settings.

10 Select Boundaries 13 and 14.

11 In the Group list select Film damping, then enter the settings from the following table 
(some are correct by default); when done, click OK.

 E 131e9[N/m^2] Young’s modulus

 ν 0.27 Poisson’s ratio

 α 4.15e-6[1/K] Coefficient of thermal expansion

 ρ 2330[kg/m^3] Density
LOAD PAGE

Coordinate system Global coordinate system

Fx 0 Body load (force/volume) x dir.

Fy 0 Body load (force/volume) y dir.

Fz -rho_smsld*accel Body load (force/volume) z dir.
DAMPING PAGE

Damping model No damping

QUANTITY VALUE IN SUBDOMAIN DESCRIPTION

1–3

QUANTITY VALUE ON BOUNDARY

13, 14

 dx,dy,dz u v w

 h0 3.95e-6
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Edge Settings
The default edge setting, which sets the film pressure to zero, applies to this model.

C O U P L I N G  V A R I A B L E S

To observe the total damping force, create two integration coupling variables 
according to the following steps.

1 From the Options menu select Integration Coupling Varaibles>Boundary Variables.

2 In the dialog box that opens, define coupling variables according to the following 
tables (one coupling variable per row); when done, click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu select Free Mesh Parameters.

2 In the Predefined mesh sizes list choose Coarse.

3 Click Remesh.

4 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 From the Solve menu select Solver Parameters.

 pA P_A

 λ0 70e-9

101325

 η 22.6e-6

 αv 1

 Qch Model 1.

 Use perforation effects No

BOUNDARY NAME EXPRESSION INTEGRATION 
ORDER

GLOBAL 
DESTINATION

13 force_bot -nz*pf 4 yes

14 force_top -nz*pf 4 yes

QUANTITY VALUE ON BOUNDARY

13, 14

pλ 0,
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2 Keep the time dependent analysis and solver, but otherwise make the following 
changes in the Solver Parameters dialog box; when done, click OK:

3 Click the Solve button on the Main toolbar to start the simulation.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 From the Postprocessing menu select Plot Parameters.

2 In the Plot type area clear the Slice check box.

3 Click the Boundary tab.

4 Select the Boundary plot check box.

5 In the Boundary data area go to the Predefined quantities list and choose Face load in 

global z dir.

6 Click the Edge tab.

7 Select the Edge plot check box.

8 Click the Uniform color option button.

9 Click the Color button and select black from the color palette. Click OK.

10 Click the Deform tab.

11 Select the Deformed shape check box.

12 Click OK.

Also plot the z-displacement at the bottom corner and the damping force at the 
bottom versus time:

1 From the Postprocessing menu select Domain Plot Parameters.

2 Select the Point page.

3 From the Point selection list choose Point 21.

4 Select Solid, Stress-Strain>z-displacement from the Predefined quantities list.

PARAMETER VALUE

Analysis Transient

Auto select solver yes

GENERAL PAGE

Times 0:1e-5:4e-3

TIME STEPPING PAGE

Times to store in output Specified times

Time steps taken by the solver Intermediate
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5 Click Apply.

6 Type force_bot in the Expression edit field.

7 Click OK.

If you want to compare the step responses in same figure for different pressures, go to 
the Constant dialog box and change the value for pa to 3[Pa] or 300[Pa]; then click 
the Solve button again. When the solution is ready and you want to plot both step 
responses in the same graph, open the Domain Plot Parameters dialog box, click the 
General tab, and select the Keep current plot check box.

You might also want to animate the step response. To do so:

1 Open the Plot Parameters dialog box and click the Animate tab.

2 In the File type list select your preference of AVI or QuickTime.

3 Click the Start Animation button.
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E s t ima t i n g  t h e  Q Fa c t o r  o f  a  MEMS 
Gy r o s c op e

A particularly simple type of MEMS gyroscope is a 2-DOF vibrational system with a 
single proof mass. The complete system with proof mass, support structure, drive and 
sense units can be fabricated in one piece out of polysilicon. High sensitivity and low 
power consumption are important design goals. Both are affected by a number of 
possible dissipative processes where vibrational energy is turned into heat inside the 
structure or in interaction with its surroundings.

This model focuses on the slide film damping due to air viscosity in the thin air layer 
between the gyroscope’s proof mass and the substrate. The Q factor obtained from this 
analysis is therefore an upper bound for the considered design. All other processes 
contribute to the damping work to further decrease the Q factor. Therefore, if the slide 
film damping can be assumed to be the dominating dissipative process in the system, 
optimizing the Q value obtained from this simplified model will be a good starting 
point for improving the design.

The model is inspired by Ref. 1.

Introduction

The working principle of a vibrational gyroscope is surprisingly simple. A proof mass 
is suspended above a surface in such a way that its first two vibrational modes are 
orthogonal and tangential to the surface. If one of the modes, from now on referred 
to as the drive mode, is excited using for example a comb drive unit, any rotation about 
an out-of-plane axis will induce Coriolis forces, which transfer energy to the other, 
orthogonal, mode. This induced excitation of the sense mode can be detected by 
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measuring capacitance between the proof mass and a pair of sense electrodes. See 
Figure 3-3.

Figure 3-3: Schematic drawing of one half of a generic 2-DOF gyroscope.

Model Definition

To model the vibration in the drive direction, you only need to include one half of the 
real structure in the geometry. The symmetry boundary condition on the mirror plane 
saves computation time and memory but also removes any modes oscillating in the 
sense direction. Therefore, the coupling between the modes cannot be studied and the 
sense electrodes are excluded from the model.

To simplify further, the model does not include the details of the comb drive. It is 
assumed that the drive is working in its region of linear response so that the unit can 
be replaced by a corresponding driving force. Considering the comb drive to act like a 
stack of idealized plate capacitors leads to the following expression for the total force 
acting on the drive assembly (Ref. 1):

 (3-1)

Symmetry plane Sense electrode

Comb drive

Anchor points

Proof mass

Fcd 4
ε0z0N

y0
----------------VDCVAC=
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Here ε0 = 8.854 pF/m is the permittivity of free space, z0 = 10 µm the height of the 
fingers, y0 = 4 µm the distance between neighboring fingers, N = 10 the number of 
fingers, VDC = 30 V the bias voltage, and finally VAC = 2 V the applied driving voltage.

As mentioned above, all damping processes except slide-film damping between the 
proof mass and the substrate are excluded from the model. Internal viscous damping 
in the polysilicon structure can be assumed to be small, as well as thermo-elastic 
damping in the supporting beams. The slide-film and squeeze-film damping in the 
comb drives may be considered in a refined model.

This particular gyroscope is intended for use under atmospheric conditions. The 2 µm 
thick gas film between the proof mass and the substrate is therefore assumed to contain 
air at atmospheric pressure. The following parameters are relevant for describing the 
film behavior under these conditions:

The Q factor is a measure of the ratio between stored energy and energy lost per cycle 
in a free oscillation. Two possible definitions are

where W0 is the stored vibrational energy, ∆W is the energy lost per cycle, ω0 is the 
natural angular frequency, and δ is the damping factor (vibrations decay exponentially 
with δt). When considering steady-state driven oscillations, the Q factor is commonly 
defined as the resonance frequency divided by the bandwidth

where the bandwidth ∆ω is in turn defined as the half-power width of the spectrum.

To evaluate the Q factor as the ratio between frequency and bandwidth you can, for 
example, run a frequency sweep with high resolution close to the resonant frequency. 
Then a standard eigenvalue analysis is a natural starting point. Once you know the 
eigenfrequency, you can add the slide-film damping and switch to a frequency response 
analysis for frequencies in the immediate vicinity of the resonance.

SYMBOL VALUE DESCRIPTION

h0 2 µm Film thickness

pA 1 atm Ambient pressure

λ0 70 nm Mean free path at 1 atm

η 18·10-6 Pa·s Dynamic viscosity

Q
2πW0

W∆
---------------

ω0
2δ
------= =

Q
ω0

ω∆
-------=
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It is, however, more efficient and accurate to extract the Q factor using the equivalent 
definition 

where λ is a complex eigenvalue. The last part of this example illustrates how 
COMSOL Multiphysics’ eigenvalue solver can be applied directly on a model set up 
for frequency response analysis. 

The relation between eigenvalue λ and a complex frequency f is 

where ω is the angular frequency. This expression for the frequency can be inserted 
directly into the frequency response equations. The eigenvalue solver provides the 
damped eigenvalue in one step when the system of equations is a quadratic polynomial 
in the angular frequency, otherwise a few steps of fix-point iteration is usually enough 
to reach convergence.

Results and Discussion

The drive direction resonance is found to be close to 433 kHz. Since the mesh 
resolution is rather low, the eigenfrequency may depend somewhat on the details of 
the mesh. Running a frequency sweep of a ±1 kHz interval around the obtained 
resonance frequency and plotting the square of the proof mass velocity gives you 

Q
ω0
2δ
------ λ( )imag

2 λ( )real
-----------------------= =

λ iω 2πif f⇔ λ
2πi
---------= = =
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Figure 3-4. Carefully measuring the half-height width of the peak leads to an estimated 
Q ≈ 8000.

Figure 3-4: The drive mode resonance peak is very sharp despite the added slide-film 
damping. The Q value obtained from measuring the width at half power is therefore not 
very accurate.

The Q value obtained from measuring the bandwidth agrees well with the value given 
by the simple formula (Ref. 2)

 (3-2)

Inserting the angular frequency at resonance ω = 2.73·106 rad/s, proof mass 
m = 3.9·10−11 kg, gap height h0 = 2 µm, dynamic viscosity η = 18·10−6 Pa·s, and 
slide film area A = 1.68·10−9 m2, gives an estimated Q = 7030. This formula does not 
account for the breakdown of the continuum assumption at small scales, and will 
therefore underestimate the Q value.

Using the eigenvalue solver to extract the desired value instead gives Q = 7524, which 
is also well in agreement with both the previous estimates. In fact, considering the 
many simplifications in the present model, the value obtained from Equation 3-2 is for 
most practical purposes good enough. When other dissipative processes are added, or 

Q
ωmh0

ηA
----------------=
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the geometry is made more complex, the numerical modeling technique illustrated 
here will be justified, though.
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Modeling in COMSOL Multiphysics

The Solid, Stress-Strain with Film Damping predefined Multiphysics coupling by 
default solves for both the structural displacements and the pressure in the air film 
between the proof mass and the substrate. The tangential velocity uT given by Navier’s 
equation in the solid are inserted into the modified Reynolds equation describing the 
film pressure, pF, on the slide-film boundary:

Here, the gap width h0, relative flow rate function Qch, and viscosity η are taken to be 
constant, and  represents differentiation in the tangential direction. The slide film 
in return applies a stress

on the structure, where Ks is the scaled Knudsen number. In the present situation, 
where the sliding surfaces are parallel, the contribution from the pressure in the second 
term is very small. Therefore, you can actually save some computation time without 
sacrificing much accuracy by simply switching off the film pressure variable during 
solving.

As a first step, the undamped vibrational modes of the gyroscope are found with only 
the Solid, Stress-Strain application mode active. Adding slide-film damping does not 
change the natural frequency perceptibly, so when measuring the half-power width of 
the resonance peak, you can safely restrict the frequency sweep to a very narrow band 
around the first pure structural eigenfrequency. Finally, the eigenvalue solver lets you 
find the same result in a more convenient way.

∇T h0
3Qch p∇TpF 6ηh0uT–( )⋅ 12jωηh0 pF=

∇T

F η
uT

h0 1 2Ks+( )
-------------------------------–

h0 pT F∇
2

--------------------–=
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Model Library path: MEMS_Module/Sensor_Models/mems_gyroscope

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select 3D from the Space dimension list.

2 Expand the predefined Multiphysics node 
MEMS Module>Structural Mechanics>Solid, Stress-Strain with Film Damping and select 
Frequency response analysis.

3 Click OK to close the Model Navigator.

O P T I O N S  A N D  S E T T I N G S

1 Open the Constants dialog box from the Options menu, and enter the following 
constants.

2 Click OK to close the dialog box.

NAME EXPRESSION DESCRIPTION

e0 8.854e-12[F/m] permittivity of free space

z0 10e-6[m] structure thickness

y0 4e-6[m] distance between fingers

N 10 number of comb fingers

V_dc 30[V] bias voltage

V_ac 2[V] drive voltage

F_cd 4*e0*z0*N*V_dc*V_ac/y0 comb drive force

A_cd 40e-6*10e-6[m^2] comb drive area
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G E O M E T R Y  M O D E L I N G

1 The somewhat idealized geometry is built entirely from blocks. First, use the Block 
button on the Draw toolbar repeatedly to create four blocks with the following 
dimensions and positions:

2 Press Ctrl+A to select all objects and click the Difference button on the Main toolbar. 

3 Add two more blocks to represent the simplified comb drives: 

4 Click the Zoom Extents button on the main toolbar to fit the geometry to your 
screen. 

P H Y S I C S  S E T T I N G S

Subdomain Settings
The gyroscope structure is made entirely of polycrystalline silicon, which shows 
negligible internal viscous damping at these scales. Poly-Si is a standard material that 
can be found in the MEMS Material Library.

1 Select the Solid, Stress-Strain application mode from the Model Tree.

2 Open the Subdomain Settings dialog box by clicking in the Model Tree or choosing 
Subdomain Settings from the Physics menu.

3 Select all three subdomains in the list and click the Load button.

LENGTH AXIS BASE POINT

X Y Z X Y Z

100e-6 50e-6 10e-6 0 0 0

20e-6 49e-6 10e-6 0 1e-6 0

20e-6 49e-6 10e-6 80e-6 1e-6 0

58e-6 20e-6 10e-6 21e-6 2e-6 0

LENGTH AXIS BASE POINT

X Y Z X Y Z

2e-6 20e-6 10e-6 18e-6 30e-6 0

2e-6 20e-6 10e-6 80e-6 30e-6 0
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4 In the Materials/Coefficients Library, select  
MEMS Material Properties>Semiconductors>Poly-Si.

5 Click OK to close the dialog box and return to Subdomain Settings.

6 Click the Damping tab and disable structural damping by selecting No damping from 
the Damping model drop-down list.

Cubic Lagrange elements can be used to somewhat compensate for the fact that it 
is difficult to create a mesh with more than one element across the thickness of the 
thin support beams. In fact, third-order elements in general give considerably better 
accuracy in relation to the number of degrees of freedom when applied to bending 
of thin structures compared to the default second-order elements.

7 Click the Element tab, then choose Lagrange - Cubic from the Predefined elements list.

8 Click OK to close the dialog box.

Boundary Conditions—Solid, Stress-Strain
The first step in the analysis is to find the frequency of the drive-direction resonance. 
For that purpose, it is enough to solve the pure, undamped structural eigenvalue 
problem. The Film Damping application mode is by default disabled on all boundaries. 
Therefore, it is enough, for now, to set appropriate constraints on the structure.

1 Open the Boundary Settings dialog box for the Solid, Stress-Strain application mode.
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2 Select Boundaries 1 and 26, which represent anchor points, and select Fixed from 
the Constraint condition list.

3 Select Boundaries 10, 13, and 24 (the mirror plane boundaries) and set the 
Constraint condition to Symmetry plane.

4 Click OK to close the dialog box.

M E S H  G E N E R A T I O N

1 While still in Boundary mode, select the top surface Boundaries 4, 9, and 23 and 
click the Interactive Meshing button on the Mesh toolbar.

2 Then click the Decrease Mesh Size button once to decrease the mesh size from 
Normal to Fine.

3 Mesh the selected surfaces by clicking the Mesh Selected (Free) button.

4 Choose Swept Mesh Parameters from the Mesh menu.

5 Select all subdomains in the Subdomain selection list and select the Manual 

specification of element layers check box.

6 Enter 1 in the Number of element layers edit field.

7 Click OK to close the dialog box.
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8 To create the final mesh, click the Mesh Remaining (Swept) button on the Mesh 
toolbar.

Figure 3-5: The swept mesh is rather coarse, but the use of cubic shape functions ensures that 
the accuracy is sufficient.

C O M P U T I N G  T H E  S O L U T I O N

As a preliminary step, before evaluating the Q factor, use the eigenvalue solver to find 
the first few resonance frequencies of the structure.

1 Open the Solver Parameters dialog box.

2 Select Eigenfrequency from the Analysis list, then click OK.

3 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows the von Mises stress on a number of cross sections. A deform 
plot makes it easier to classify the different eigenmodes.

1 Open the Plot Parameters dialog box.

2 In the Plot type frame, clear the Slice check box and select the Boundary and 
Deformed shape check boxes.
E S T I M A T I N G  T H E  Q  F A C T O R  O F  A  M E M S  G Y R O S C O P E  |  171



172 |  C H A P T E
3 Click OK to display the shape of the first eigenmode.

Figure 3-6: The first eigenmode shows the proof mass oscillating in the drive direction with 
a frequency of about 433 kHz.Due to the limited mesh resolution, the exact frequency 
obtained might vary slightly.

P H Y S I C S  S E T T I N G S

Now, knowing the resonance frequency of the drive mode, it is time to apply the comb 
drive forcing according to Equation 3-1 and activate the slide-film damping.

Boundary Conditions—Solid, Stress-Strain
1 Open the Boundary Settings dialog box for the Solid, Stress-Strain application mode 

again.

2 On the Load page, select Boundaries 6 and 25. Apply the driving force on these 
boundaries by entering the distributed load F_cd/A_cd in the Fx edit field.

3 Select the lower surface of the model, consisting of Boundaries 3, 8, and 22, and 
choose Film damping from the Group list.

4 Click OK to close the dialog box.

Boundary Conditions—Film Damping
1 Locate Geom1>Film Damping>Boundary Settings in the Model Tree and double-click 

the node.
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2 Make sure the slide-film boundaries (Boundaries 3, 8, and 22) are still selected and 
choose Film damping from the Group list.

3 Change the Gas film settings according to the following table:

4 Click OK to close the dialog box.

Edge Settings—Film Damping
1 Open the Edge Settings dialog box, either from the Physics menu or by clicking in 

the Model Tree.

2 Select Edges 15, 24, and 49, which are part of the symmetry plane, and choose 
Closed/Symmetry as End condition.

3 Click OK to close the dialog box.

C O M P U T I N G  T H E  S O L U T I O N

Above, the eigenvalue solver was used to calculate the resonance frequency of the drive 
mode. Next, apply the parametric solver to obtain the frequency response of the 
damped model for frequencies in the immediate neighborhood of the known 
resonance. With a clever choice of frequency steps, you can resolve the resonance peak 
accurately without having to use a short sampling interval everywhere. For example 
using

sort([433775 433775-logspace(1,3,15) 433775+logspace(1,3,15)])

gives you a sorted frequency list, as expected by the solver, which resolves the 
neighborhood of 433775 Hz.

The damping in the model is rather weak, with an estimated Q factor close to 8000. 
The expected band width of the resonance peak is then less than 100 Hz, which is less 
than the errors caused by the rather coarse mesh. Small differences between meshes 
created on different hardware platforms can potentially move the peak more than its 

PROPERTY VALUE

 Damping type Slide film

 h0 2e-6[m]

 pA 1[atm]

 λ0 70[nm]

1[atm]

 η 18e-6[Pa*s]

 Qch Slip

pλ 0,
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bandwidth. Therefore it may be necessary to modify the suggested parameter list to 
reflect the actual resonance frequency found in the first solution step.

Solver Settings
1 Open the Solver Parameters dialog box.

2 Select Frequency response from the Analysis type list, which both modifies the 
implementation of the structural equations and switches to the Parametric solver.

Note that the Film Damping application mode is already set to the Frequency 
response analysis type because it was started in that mode. The Analysis type list in 
the Solver Parameters dialog box only affects the ruling application mode, which in 
this case is the Solid, Stress-Strain application mode.

3 Enter freq as Parameter name. This defines the variable freq, which will be used 
below.

4 In the Parameter values edit field, enter

sort([433775 433775-logspace(1,3,15) 433775+logspace(1,3,15)]).

5 Click OK to close the Solver Parameters dialog box.

Scalar Variables
Both application modes are now set to the Frequency response analysis type, which 
means that they describe harmonic motion at a fixed frequency. You must specify this 
frequency for both modes:

1 Choose Scalar Variables from the Physics menu.

2 In the Application Scalar Variables dialog box, set both variables described as 
Excitation frequency to freq[Hz].

3 Click OK to accept the changes and close the dialog box.

Probe Plot
When working with the parametric solver, it is often convenient to set up a probe plot 
that lets you check your results as they are produced. In this model, the quantity of 
interest is the vibrational energy at steady state for each frequency. Looking at the 
shape of the drive mode, it is obvious that the vibrational energy will be very nearly 
proportional to the square of the proof mass’s peak velocity, which is constant 
throughout the proof mass.

1 Choose Probe Plot Parameters from the Postprocessing menu.

2 In the dialog box, click New.

3 Select Point probe from the Plot type list, then click OK to create the new probe plot.
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4 Select Point 32 and change the Expression field to abs(u_t_smsld)^2.

5 Click OK to close the dialog box.

Solving the Model
Click the Solve button on the Main toolbar to compute the frequency sweep.

As the sweep progresses, the probe plot appears in the Progress window, showing a 
distinct peak in the vibrational energy curve. When the solving stage finishes, the 
resulting plot is automatically copied to a separate figure window. The curve should be 
similar to that in Figure 3-4 on page 165.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The Q factor can be estimated directly from the probe plot by measuring the width of 
the resonance peak at half its maximum value and dividing the resonance frequency by 
the measured bandwidth. This, however, gives you a very rough estimate.

It is possible to use the Point Evaluation dialog box to manually look for the frequencies 
that give values for the squared velocity at Point 32 close to half the peak value. Using 
some back-of-the-envelope interpolation you can conclude that the Q factor must lie 
somewhere close to 8000, not far from what is predicted by Equation 3-2. This result 
serves to verify that the frequency response model is likely to be correct. With a 
working frequency response model and knowledge about what the drive mode looks 
like, you can proceed to the final step.

C O M P U T I N G  T H E  S O L U T I O N

The slide-film damping application mode does not explicitly support the eigenvalue 
analysis type to calculate damped eigenvalue solutions. Instead, you can do an 
eigenvalue analysis of the equations solved above for frequency response just by 
switching solver and rewriting the frequency in terms of the eigenvalue variable 
lambda.

1 Open the Solver Parameters dialog box.

2 Select Eigenvalue from the Solver list, then click OK.

3 Choose Scalar Variables from the Physics menu.

4 In the Application Scalar Variables dialog box, set the Excitation frequency for both 
application modes to lambda/(2*pi*i).

5 Click OK to close the dialog box.

6 Click the Solve button on the Main toolbar.
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P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Solving a damped eigenvalue problem like this gives you a number of complex 
eigenvalues which do not necessarily show up in the same order as for the lossless 
model. Your first task is therefore to locate the drive mode. If the displayed plot does 
not already look like Figure 3-6 on page 172, do the following:

1 Open the Plot Parameters dialog box, by choosing it from the Postprocessing menu 
or clicking the corresponding button on the Main toolbar.

2 Because λ = 2πif, search the Eigenvalue list on the General page for an eigenvalue with 
imaginary part close to 2.7·106. There should be two, one with positive and one 
with negative imaginary part.

3 Click Apply and check the plot to verify that you have indeed found the drive mode.

4 Click OK or Cancel to close the dialog box.

Finally, proceed to evaluate the Q factor as half the ratio between imaginary and real 
part of the eigenvalue:

5 Choose Data Display>Global from the Post menu.

6 Enter abs(imag(lambda)/real(lambda)/2) in the Expression field and select the 
drive mode from the Eigenvalue list.

7 Click OK to close the dialog box and display the final result in the message log.
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P i e z o r e s i s t i v e  E l e v a t o r  Bu t t o n

Introduction

This is a simplified model of a design of a piezoresistive in-wall elevator button 
described in a patent application submitted by C.J. Slabinski and R.B. Leach (Ref. 5). 
The elevator button is designed with the following requirements in mind:

• durability with respect to high temperatures

• capability of producing signals that can be easily used in digital signal processing

• reliability, even when subjected to high loads

With respect to each of these requested characteristics, piezoresistive devices are 
superior to piezoelectrical ones. To make the device resistant against fire and heat, the 
button assembly includes parts of materials that are unresponsive to heat, such as clay 
or brick.

Piezoresistive materials change their resisitivity when subjected to mechanical stresses. 
This model concentrates on piezoresistivity in silicon-type materials, which is the most 
important group for practical applications. Although the effect is also observed in 
metals with crystal structures different from silicon, the piezoresistive effect is more 
than an order of magnitude higher in silicon than in metals (Ref. 1).

Note: This Model requires the MEMS module and the AC/DC Module.
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Model Definition

Figure 3-7 shows the simplified elevator-button design that you use in this model.

Figure 3-7: Schematic elevator button design.

The button is embedded in an enclosure formed by the elevator control panel. Its 
operation is modeled by a force, Fz, which acts on the button’s upper boundary. The 
upper part of the button, composed of a conical and a cylindrical part, is made of 
aluminum. The conical shape ensures that the inner button parts are protected if the 
button is subjected to high impacts.

Furthermore, as mentioned in the introduction, it is vital that the button functions 
perfectly even at high ambient temperatures, such as in the event of fire. To shield the 
piezoresitive silicon layer, an adhesive, made of clay or brick, is attached to the resisitive 
layer’s upper and lower sides.

To implement the button in COMSOL Multiphysics, you need two application modes:

• Solid, Stress-Strain, active in the whole geometry of the device

• Electric Currents, which is only active in the sensing resistor domain

To measure the change in the resistivity, a fixed voltage of 1 V is applied across the 
silicon layer. The integral of the current density over one of the resistor’s contacts gives 
the ohmic resistance via Ohm’s law, U = RI.

P I E Z O R E S I S T I V I T Y  F O R  A N  A N I S O T R O P I C  C R Y S T A L

Below follows a short outline of the piezoresistive relations (Ref. 1). For a 
3-dimensional anisotropic crystal, the electric field is related to the current-density 

Enclosure

aluminum

piezo

brick/clay

Fz

Fixed

+−
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field by a 3-by-3 resistivity tensor. In piezo crystals, the nine components always reduce 
to six values arranged in a symmetric tensor:

 (3-3)

For the cubic silicon lattice—with axes aligned with the <100> axes—ρ1, ρ2, and ρ3 
define the dependence of the electric field on the current along the same orthogonal 
directions; the other components are the cross terms.

The six resistivity components depend on the normal and shear stresses in the material 
(Ref. 2). Under stress-free conditions and with Cartesian coordinates aligned with the 
material <100> axes, the normal resistivity components are equal, and the cross terms 
are zero. Thus, under these conditions, the resistivity tensor is isotropic:

 (3-4)

The relative changes in the resistivity can be written as a product of the structural 
stresses, σ, and the piezoresistive stress coefficients, Π . In Voigt notation, this reads:

 (3-5)

The following table lists the correspondences between the element indices or positions 
in Equation 3-5 and the tensor components along the spatial coordinate axes:

  Π MATRIX RESISTIVITY SHEAR STRESS   Π MATRIX

RC  xy  i  xy  i  xy RC

12 xy   ρ6   ρxy  τ3   τxy 66

13 xz   ρ5   ρxz  τ2   τxz 55

23 yz   ρ4   ρyz  τ1   τyz 44

E1

E1

E1

ρ1 ρ6 ρ5

ρ6 ρ2 ρ4

ρ5 ρ4 ρ3

I1

I2

I3

=

ρ3-by-3 ρ0

1 0 0
0 1 0
0 0 1

=

1
ρ0
------

∆ρ1

∆ρ2

∆ρ3

∆ρ4

∆ρ5

∆ρ6

π11 π12 π12 0 0 0

π12 π11 π12 0 0 0

π12 π12 π11 0 0 0

0 0 0 π44 0 0

0 0 0 0 π44 0

0 0 0 0 0 π44

σ1

σ2

σ3

τ1

τ2

τ3

=
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Here, “R” and “C” stand for row and column position, respectively. 

When modeling electric currents in conductive media, conductivity is used instead of 
resistivity. The anisotropic conductivity matrix corresponding to the resistivity matrix 
results from a simple inversion of the resistivity matrix.

Coordinate Transformations
To get a nice representation of the material parameters, it is common in piezoelectricity 
and piezoresistivity to rotate the coordinate system by 45° around the z-axis, so that 
the coordinate system aligns with the <110> directions for the crystal axes. The 
drawback of this representation is that the Cartesian axes (for which the stresses are 
defined) are aligned along the material <100> axes, in contrast to the representation 
used in structural mechanics (standard global coordinate system). Therefore, a local 
coordinate system is introduced for computing the resisitivity coefficients.

When you create and use a local coordinate system in COMSOL Multiphysics, you get 
an orthogonal 3-by-3 transformation matrix T, whose components appear as 
coordn_Tij variables in the equations. This matrix represents a transformation from 
local to global coordinates. The transformation of stresses from global to local 
coordinates is

Use these stress components in the local representation to calculate the resistivity 
matrix, and then transform the resistivity matrix to global coordinates using the inverse 
transformation

Finally, invert this matrix and use the conductivity values in the conductive-media 
equation.

M A T E R I A L  P R O P E R T I E S

Table 3-1 lists the elastic properties for the materials used in the different button 
components. For aluminum and brick, you can use the basic material properties library 
included with COMSOL Multiphysics, whereas you enter the properties for the piezo 

σl TT
σx σxy σxz

σxy σy σyz

σxz σyz σz

T=

ρg T

ρ1 ρ6 ρ5

ρ6 ρ2 ρ4

ρ5 ρ4 ρ3

TT T

ρ11 ρ12 ρ13

ρ21 ρ22 ρ23

ρ31 ρ32 ρ33

TT
= =
R  3 :  M E M S  S E N S O R  M O D E L S



element manually. The thermal expansion coefficients, α, are included in the table to 
simplify generalizing the model to take heat effects into account.

B O U N D A R Y  C O N D I T I O N S

Solid, Stress-Strain—Constraints
Apply roller constraints to the boundaries highlighted in the figure below. Consider all 
other boundaries to be unconstrained.

Boundaries for which roller constraints apply.

Solid, Stress-Strain—Loads
On the top button surface, apply a homogeneous downward pressure of 1 kPa, 
corresponding to a total force of roughly 2.8 N.

Electric Currents
Apply a voltage of 1 V between the electrodes. All other boundaries are electrically 
insulating.

TABLE 3-1:  ELASTIC MATERIAL PROPERTIES

PROPERTY ALUMINUM BRICK PIEZO ELEMENT DESCRIPTION

 E (GPa) 70 17 169 Young’s modulus

 ν 0.33 0.3 0.278 Poisson’s ratio

 ρ (kg/m3) 2700 2000 7850 Density

 α (1/K) 23·10-6 6·10-6 12·10-6 Thermal expansion coefficient
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Results

Figure 3-8 displays the displacement of the boundary when full pressure is applied to 
the top button surface. The very small displacement values show that the button does 
not need to move for a signal to be generated.

Figure 3-8: Total displacement of the button’s boundary surfaces when a uniform 
downward pressure is applied on the top surface. The values of the displacement are so small 
that button movement is imperceptible.
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Figure 3-9 shows the applied force and the current response as functions of time.

Figure 3-9: Applied force (left) and current response (right) as functions of time.

Because of the very small amplitude of the current signal, it is useful to plot I − I0, 
where I0 denotes the current in the absence of a load. Figure 3-10 shows this quantity 
as a function of time.

Figure 3-10: Differential current response.

From Figure 3-10 and the plot in the right panel of Figure 3-9 you can read off a 
signal-to-bias ratio of less than 10−6. To allow the signal to be detected, the noise level 
needs to be even smaller than this. Thus, the simplified model of this example merely 
illustrates a possible application of piezoresistivity. The design must be refined and 
accompanied by the appropriate electronic circuitry to be technically viable.
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Model Library path: MEMS_Module/Sensor_Models/elevator_button

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 From the Space dimension list, select 3D.

2 Select the application mode MEMS Module>Solid, Stress-Strain>Quasi-static analysis.

3 Click Multiphysics, then click Add.

4 Select the AC/DC Module>Quasi-Statics, Electric>Electric Currents>Transient analysis 
application mode

5 Click Add, then click OK.

O P T I O N S  A N D  S E T T I N G S

Constants
1 From the Options menu, choose Constants.

2 On separate rows in the dialog-box table, enter the resistivity and piezoresistive 
stress tensor components listed in the following table. Alternatively, click the Import 

Variables From File button, browse to the folder MEMS_Module/Sensor_Models in 
the Model Library root directory, select the file elevator_button_const.txt, 
and click Open.

NAME EXPRESSION DESCRIPTION

rho0 180e-6[ohm*m] Resistivity of the unstressed material

p11 6.6e-11[1/Pa] Piezoresistive stress coefficient component

p12 -1.1e-11[1/Pa] Piezoresistive stress coefficient component

p44 138.1e-11[1/Pa] Piezoresistive stress coefficient component

P11, P22, P33 p11 Piezoresistive stress coefficient matrix component
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Coordinate Systems
Because the piezoresistive coefficients are given in local coordinates, you must 
transform them to the standard global coordinate system used in the Solid, 
Stress-Strain application mode. Define the local coordinate system as follows:

1 From the Options menu, choose Coordinate Systems.

2 Click the New button. In the Name edit field, type Silicon orientation, then 
click OK.

3 Back in the Coordinate System Settings dialog box, enter the following settings on 
the General page:

4 Click OK.

Scalar Expressions
Next, add the stress-dependent resistivity and conductivity components in local and 
global coordinates defined in Table 3-2 through Table 3-5. You can either enter them 

P12, P13, P21, 
P23, P31, P32

p12 Piezoresistive stress coefficient matrix component

P44, P55, P66 p44 Piezoresistive stress coefficient matrix component

SETTINGS X Y Z

x-axis direction vector 1 1 0

xy-plane direction vector 0 0 1

NAME EXPRESSION DESCRIPTION
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manually in the Scalar Expressions dialog box or, more conveniently, load them directly 
from a data file included with the MEMS Module.

1 From the Options menu, choose Expressions>Scalar Expressions.

2 Enter the stress, resistivity, and conductivity components listed in the following 
tables or (preferably) click the Import Variables From File button, browse to the 
folder MEMS_Module/Sensor_Models in the Model Library root directory, select 
the file elevator_button_expr.txt, and click Open.

3 Click OK to close the Scalar Expressions dialog box.

TABLE 3-2:  MATERIAL STRESS IN LOCAL COORDINATES

NAME EXPRESSION

sxl sxl_smsld

syl syl_smsld

szl szl_smsld

sxzl sxzl_smsld

syzl syzl_smsld

sxyl sxyl_smsld

TABLE 3-3:  RELATIVE RESISTIVITY (RHO/RHO0) IN LOCAL COORDINATES

NAME EXPRESSION

rhol11 1+P11*sxl+P12*syl+P13*szl

rhol22 1+P21*sxl+P22*syl+P23*szl

rhol33 1+P31*sxl+P32*syl+P33*szl

rhol23 P44*syzl

rhol13 P55*sxzl

rhol12 P66*sxyl

TABLE 3-4:  RELATIVE RESISTIVITY IN GLOBAL COORDINATES

NAME EXPRESSION

rho11 coord1_T11*(rhol11*coord1_T11+rhol12*coord1_T12+ 
rhol13*coord1_T13)+coord1_T12*(rhol12*coord1_T11+ 
rhol22*coord1_T12+rhol23*coord1_T13)+coord1_T13* 
(rhol13*coord1_T11+rhol23*coord1_T12+rhol33*coord1_T13)

rho22 coord1_T21*(rhol11*coord1_T21+rhol12*coord1_T22+ 
rhol13*coord1_T23)+coord1_T22*(rhol12*coord1_T21+ 
rhol22*coord1_T22+rhol23*coord1_T23)+coord1_T23* 
(rhol13*coord1_T21+rhol23*coord1_T22+rhol33*coord1_T23)
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G E O M E T R Y  M O D E L I N G

1 Click the Cylinder button on the Draw toolbar. Create a cylinder with Radius 0.02, 
Height 0.002, and the Axis base point at (0, 0, 0). Click OK to close the dialog box.

2 Click the Zoom Extents button on the Main toolbar.

3 Repeat this procedure for three more cylinders with the following values:

rho33 coord1_T31*(rhol11*coord1_T31+rhol12*coord1_T32+ 
rhol13*coord1_T33)+coord1_T32*(rhol12*coord1_T31+ 
rhol22*coord1_T32+rhol23*coord1_T33)+coord1_T33* 
(rhol13*coord1_T31+rhol23*coord1_T32+rhol33*coord1_T33)

rho12 coord1_T11*(rhol11*coord1_T21+rhol12*coord1_T22+ 
rhol13*coord1_T23)+coord1_T12*(rhol12*coord1_T21+ 
rhol22*coord1_T22+rhol23*coord1_T23)+coord1_T13* 
(rhol13*coord1_T21+rhol23*coord1_T22+rhol33*coord1_T23)

rho23 coord1_T21*(rhol11*coord1_T31+rhol12*coord1_T32+ 
rhol13*coord1_T33)+coord1_T22*(rhol12*coord1_T31+ 
rhol22*coord1_T32+rhol23*coord1_T33)+coord1_T23* 
(rhol13*coord1_T31+rhol23*coord1_T32+rhol33*coord1_T33)

rho13 coord1_T11*(rhol11*coord1_T31+rhol12*coord1_T32+ 
rhol13*coord1_T33)+coord1_T12*(rhol12*coord1_T31+ 
rhol22*coord1_T32+rhol23*coord1_T33)+coord1_T13* 
(rhol13*coord1_T31+rhol23*coord1_T32+rhol33*coord1_T33)

TABLE 3-5:  CONDUCTIVITY

NAME EXPRESSION

det_rho rho11*rho22*rho33+2*rho12*rho23*rho13-rho13^2*rho22- 
rho12^2*rho33-rho11*rho23^2

sigma11 (rho22*rho33-rho23^2)/(rho0*det_rho)

sigma22 (rho11*rho33-rho13^2)/(rho0*det_rho)

sigma33 (rho11*rho22-rho12^2)/(rho0*det_rho)

sigma12 (rho13*rho23-rho12*rho33)/(rho0*det_rho)

sigma13 (rho12*rho23-rho13*rho22)/(rho0*det_rho)

sigma23 (rho12*rho13-rho11*rho23)/(rho0*det_rho)

NAME RADIUS HEIGHT AXIS BASE POINT

CYL2 2e-2 3e-3 (0,0,2e-3)

TABLE 3-4:  RELATIVE RESISTIVITY IN GLOBAL COORDINATES

NAME EXPRESSION
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4 Click the Cone button on the Draw toolbar and specify the following parameters:

5 Click the Block button on the Draw toolbar. In the Base area, click Center. Set the 
Axis base point to (0.02, 0, 0.0035) and the Length to (0.004, 0.04, 0.003). Click 
OK to close the dialog box and create the block BLK1.

6 Select BLK1 and create a second block, BLK2, by pressing first Ctrl+C and then 
Ctrl+V. In the Paste dialog box, to specify the Displacements (-0.04, 0, 0). Click OK.

The geometry in the drawing area should now look like that in the following figure.

7 From the Draw menu, choose Create Composite Object. In the Set formula edit field, 
enter the expression CYL1+CYL2+CYL3+CYL4+CON1-BLK1-BLK2. Click OK.

CYL3 2e-2 2e-3 (0,0,5e-3)

CYL4 12e-3 15e-3 (0,0,7e-3)

PARAMETER VALUE

Axis base point (0,0,3.2e-2)

Radius 3e-2

Height 1e-2

Semi-angle 45

Axis direction vector (0,0,-1)

NAME RADIUS HEIGHT AXIS BASE POINT
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The geometry is now complete and should look like that in the figure below.

P H Y S I C S  S E T T I N G S

Subdomain Settings—Solid, Stress-Strain
1 From the Multiphysics menu, select 1 Solid, Stress-Strain (smsld).

2 From the Physics menu, select Subdomain Settings.

3 Select Subdomains 1 and 5, then click the Load button in the Material settings area.

4 From the Basic Material Properties library, select Aluminum, then click OK.

5 Select Subdomains 2 and 3, then click the Load button.

6 From the Basic Material Properties library, select Brick, then click OK.

7 Select Subdomain 4 and specify settings according to the following table:

8 Click OK.

Boundary Conditions—Solid, Stress-Strain
1 From the Physics menu, select Boundary Settings.

PROPERTY VALUE

 Coordinate system Silicon orientation

 E 169e9

 ν 0.278

 α 12e-6

 ρ 7850
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2 On the Constraint page, specify the following constraint condition:

The boundaries not listed above are free, which is the default constraint condition.

3 Go to the Load page and select Boundary 3.

4 In the Fz edit field, type -1[kPa]*flc1hs(t[1/s]-0.2,0.1).

5 Click OK.

Subdomain Settings—Electric Currents
1 From the Multiphysics menu, choose 2 Electric Currents (emqvw).

2 Select Subdomains 1–3 and 5. Clear the Active in this domain check box.

3 Select Subdomain 4. In the σ edit field type sigma11 sigma12 sigma22 sigma13 
sigma23 sigma33. The editable pop-up window displays the components’ 
positions in the anisotropic, symmetric electric conductivity tensor.

4 Click OK.

Boundary Conditions—Electric Currents
1 From the Physics menu, select Boundary Settings.

2 Select the Interior boundaries check box.

3 Select all boundaries and set the boundary condition to Electric insulation.

4 Select Boundary 13. From the Boundary condition list, choose Electric potential. In 
the V0 edit field, type 1.

5 Select Boundary 32. From the Boundary condition list, choose Ground.

6 Click OK to close the Boundary Settings dialog box.

Integration Coupling Variables
To have a probe plot for the developing of the electric current and the applied load on 
the top surface, define two boundary integration variables.

1 From the Options menu, select Integration Coupling Variables>Boundary Variables.

SETTINGS BOUNDARIES 4–6, 8, 9, 13, 14, 17, 23–25, 28–30, 32

Constraint condition Roller
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2 Define the following integration variables by first selecting the boundary, and then 
entering the name and expression on the first available row in the dialog box table.

In the Integration order and Global destination columns, leave the default settings.

3 Click OK to close the dialog box.

M E S H  G E N E R A T I O N

Click the Initialize Mesh button on the Main toolbar to generate a default mesh. 

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

BOUNDARY NAME EXPRESSION

3 force Fzg_smsld

32 current nJ_emqvw
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2 On the General page, type 0:0.1:0.4 in the Times edit field. Also, verify that the 
Linear system solver is set to Direct (SPOOLES).

3 From the Postprocessing menu, choose Probe Plot Parameters.

4 In the Probe Plot Parameters dialog box, click the New button.

5 From the Plot type list, select global. In the Plot name edit field, type force.

6 Click OK.

7 In the Expression to plot area, the integration coupling variable force in the 
Expression edit field.

8 In the same fashion, define a probe plot with the label current for the integration 
coupling variable with the same name.

9 Click OK to close the Probe Plot Parameters dialog box.

10 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To reproduce the plot of the boundary displacement field displayed in Figure 3-8, 
follow these steps:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, clear the Slice check box and select the Boundary check box in 
the Plot type area.
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3 Click the Boundary tab and verify that disp_smsld is selected from the Predefined 

quantities list. From the Unit list, select nm.

4 Click OK to close the dialog box and generate the plot.

5 Click the Scene Light button on the Camera toolbar.

Reproduce the plot in Figure 3-10 with these instructions:

1 From the Postprocessing menu, choose Global Variables Plot.

2 In the Expression edit field, type current-with(1,current).

3 Click the Add Entered Expression button.

4 Click the Axis/Title button.

5 Click the right option buttons for Title and Second axis label.

6 In the Second axis label edit field, type I-I<sub>0</sub> [A].

7 From the Plot in list, select New figure.

8 Click OK.
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C apa c i t i v e  P r e s s u r e  S e n s o r

Introduction

The basic structure of a pressure sensor consists of two cavities separated by a thin 
membrane. One cavity contains the reference pressure (possibly a vacuum), and the 
other connects to the measurable pressure. When that pressure changes, the membrane 
deforms by a magnitude that depends on several things: the amount of pressure, the 
material’s mechanical properties, and the structure’s shape.

Any initial stresses in the material also affect the deformation. Therefore, the 
manufacturing process and the selected materials directly affect sensor operation. In 
some structures the membrane and cavities are engraved onto silicon and sealed with 
layers of glass. Because the materials are bonded together at a high temperature, 
cooling them down to the sensor’s normal operating temperature produces 
undesirable stresses in the material that affect device performance.

A common way to detect membrane deformation is by measuring capacitance. The 
surface of the deforming membrane and the opposite side of one of the cavities are 
coated with metal. Thus they form a capacitor whose value depends on the distance of 
the plates and on the system’s geometry. 

The sensor in this example measures static pressures of a magnitude from zero to 
atmospheric pressure. The model first computes the initial stresses from device 
construction; then it accounts for the structure’s mechanical deformation resulting 
from an applied pressure. It finally calculates the sensor’s capacitance for the deformed 
shape from the electric field.

Being in 2D, this model describes a different geometry from a true 3D sensor. Often 
the deforming membrane is a circular or rectangular diaphragm fixed at all boundaries. 
But when you view this structure in 2D, a bridge type structure results, which is fixed 
only at the two edges. The following figure illustrates the model’s deformed geometry.
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2D view of a pressure sensor. 

Model Definition

M O D E L  G E O M E T R Y

From that diagram you can see that the model consists of three layers. The active 
silicon structure sits between two blocks of glass. The following list provides 
descriptions of the different structures in the sensor:

• Top and bottom layers

- Rectangular

- Material: Glass, HOYA, SD-2

- Width: 2.5 mm

- Height: 0.5 mm
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• Middle layer

- Complex structure: a rectangle in which cavities needed for sensor operation are 
engraved

- Material: Silicon

- Width: 2.5 mm

- Height: 0.5 mm

- Membrane width: 1.5 mm

- Membrane height: 20 µm

• Cavity with a vacuum

- Symmetric trapezoid at the upper boundary of the middle layer

- Material: Vacuum

- Width at the top: 1.9 mm

- Width at the bottom: 1.5 mm

- Height: 0.475 mm

• Cavity with ambient pressure

- Rectangular

- Material: Air

- Width: 1.5 mm

- Height: 5 µm

• Capacitance measurement

- Done with two metal plates at the top and bottom of the cavity with ambient 
pressure

- Top plate potential: 1 V

- Bottom plate potential: Ground

- Plate width: 1.0 mm

The thickness of all parts is 2.5 mm.

The structure is fixed at two points but is otherwise allowed to deform freely. The 
lower left corner is fixed in the x and y directions but can rotate. The lower right corner 
is fixed in the y direction but can rotate and move in the x direction.
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S T R E S S  A N D  D E F O R M A T I O N

During manufacturing, the sensor is bonded together in a vacuum and at a high 
temperature and is then cooled down. Therefore, during this process no external forces 
act on the sensor’s boundaries, but internal stresses appear because the two materials 
have different coefficients of thermal expansion. This process also produces a vacuum 
in the upper cavity, and it serves as the reference pressure.

During normal operation, the sensor is fixed on a solid surface, and ambient pressure 
pushes on all outer boundaries. The temperature also changes, which produces extra 
stresses due to thermal expansion. 

For a linear elastic material, the stress-strain relationship including the initial stress 
(σ0), initial strain (ε0), and thermal effects (εth), is 

where D is the elasticity matrix, and vectors give the normal and shear values of the 
stresses and strains.

Initially only thermal expansion is active, and it comes from the relationship

,

where αvec are the coefficients of thermal expansion, T is the ambient temperature, 
and Tref is the reference temperature. The manufacturing stage produces the initial 
stress for normal operation, where further thermal expansion takes place. This model 
assumes that after manufacturing the sensor is close to its initial geometry and thus the 
initial strain is zero.

For calculating large deformations, strain values come from the Green strains as

.
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For the case of large deformations, the model solves the problem using the principle 
of virtual work, which states that the sum of virtual work from internal strain is equal 
to work from external loads.

C A P A C I T A N C E

For computing sensor capacitance, the model solves for the electric field in the 
deformed geometry or frame, which is defined by the Moving Mesh (ALE) application 
mode. 

To calculate the capacitance, a port boundary condition is used. It calculates the 
capacitance from the energy of the electric field with the equation

where U is the potential difference between the plates (U = 1 for the port boundary 
condition) and We is the electric energy density. The area Ωd corresponds to the 
narrow air gap in the sensor.

Results and Discussion

Figure 3-11 shows the results after the bonding phase, where bonding took place at 
400 °C and the sensor is then cooled down to 22 °C. In the image the x- and y-axes 
have different scales, and the structural deformation is scaled by 20.

It appears that the membrane slightly pulls towards the larger cavity even though there 
are no applied loads. Stresses appear near the boundaries of the different materials and 
in the silicon membrane, which is narrower than other parts of the sensor. The 
maximum appears at the lower left corner of the smaller cavity.

C 2

U2
------- We Ωdd

Ωd

∫=
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Figure 3-11: Initial stresses of the materials in the pressure sensor.

Figure 3-12 shows the results when the sensor is in operation: it is exposed to a 
pressure of one atmosphere at 15 °C. The figure is arbitrarily scaled and is focused on 
the left half of the lower cavity. The membrane deforms toward the vacuum with 
maximum deformation at the middle. Maximum stresses appear at the upper corners 
of the lower cavity where the membrane attaches to the silicon boundaries.

The streamlines show the electric field in the lower cavity. The lines are vertical 
between the two electrodes. Some field lines appear outside of the electrode region, 
C A P A C I T I V E  P R E S S U R E  S E N S O R  |  199



200 |  C H A P T E
but the field strength is very small there (dark blue color).

Figure 3-12: Sensor deformation, stresses (left color bar: von Mises Stress) and electric field 
(right colorbar: Electric field strength) when exposed to ambient pressure.

Figure 3-13 show the capacitance values computed from the electric field for four 
conditions as described in Table . Conditions A and B have the same ambient 
temperature but a higher bonding temperature. In Condition C all temperature values 
are the same so no stresses or deformations arise from thermal effects. For Condition 
D, thermal deformation does result from the ambient temperature. 

You can also compare the computed capacitance values to those for a plate capacitor 
with a plate size of 1 mm times unity and a gap of 5 µm when not deformed. The 
capacitance for this plate capacitor is C = ε0 A/d = 1.771·10−9 F; the corresponding 
value from the COMSOL Multiphysics model is 1.7760763·10−9 F computed with 
settings for Condition C and zero pressure.

TABLE 3-6:  TEMPERATURE CONDITIONS FOR COMPUTING THE CAPACITANCE VALUES

TEMPERATURE A B C D

High bonding (°C) 400 200 22 22

Low bonding (°C) 22 22 22 22

Ambient (°C) 15 15 22 -18
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Figure 3-13: Computed capacitance vs. ambient pressure for different temperature 
conditions: Condition A, triangles; Condition B, squares; Condition C, +; 
Condition D, *.

Modeling in COMSOL Multiphysics

In COMSOL Multiphysics you solve this problem using four application modes: two 
Plane Stress application modes, one Moving Mesh (ALE) application mode, and one 
Electrostatics application mode. The latter two are defined in a frame to allow the mesh 
to move.

Because the structure’s deformation can be large, you must use a large deformation 
analysis for both Plane Stress application modes.

You solve for the mesh movement and the electric field only in the small air gap where 
the ambient pressure is applied to the sensor. The mesh movement follows the 
structural deformation on the model’s parts. 

The solution process takes place in four steps:
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1 The first Plane Stress application mode represents the sensor’s fabrication, and it 
computes the initial stresses that result from thermal expansion. This is solved with 
the static solver.

2 The second Plane Stress application mode solves the deformation and stresses that 
result when the sensor is exposed to ambient temperature and pressure. It uses the 
initial stresses and deformation from the first plane stress application mode. This is 
solved with a parametric solver for different values of ambient pressure.

3 Using a parametric solver you solve the ALE mesh for each ambient pressure.

4 Finally, using a parametric solver you solve the electric field for each ambient 
pressure.

Several constants define the different manufacturing and ambient conditions. The 
following table contain descriptions and default values for them. For temperature 
values the model uses the normal temperature T0 = 273.15 K. If you want to use static 
analysis to solve for single solutions, you can define a constant P_ambient. It is not 
needed for the parametric analysis.

Model Library path: MEMS_Module/Sensor_Models/pressure_sensor_2d

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator, go to the New page, and select 2D from the Space 

dimension list.

2 Click the Multiphysics button.

3 From the list of application modes select MEMS Module>Structural Mechanics>Plane 

Stress>Static analysis. Add it to the model two times by clicking the Add button 
twice. Note that COMSOL Multiphysics adds both to a 2D geometry it labels 
Geom1 (2D).

CONSTANT VALUE UNIT DESCRIPTION

T_bondingH 400+T0 K High bonding temperature

T_bondingL 22+T0 K Low bonding temperature

T_ambient 15+T0 K Ambient temperature

P_ambient 101e3 Pa Ambient pressure
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4 In the Multiphysics area on the right select Plane Stress (smps).

5 Click the Application Mode Properties button, find the Large deformation list, and 
select On. Click OK.

6 In the Multiphysics area select Plane Stress (smps2).

7 Click the Application Mode Properties button, find the Large deformation list, and 
select On. Click OK.

8 In the Multiphysics area select COMSOL Multiphysics>Deformed Mesh>Moving Mesh 

(ALE)>Static analysis. Click Add.

9 From the list of application modes select MEMS Module>Electrostatics>Electrostatics. 
Click Add. Note that this application mode appears under Frame (ale).

10 In the Multiphysics area select Electrostatics (emes) and click the Application Mode 

Properties button. In the Weak Constraints list select On and in the Constraint type 
list choose Non-ideal.

11 Find the Ruling application mode list at the bottom of the dialog box and select 
Moving Mesh (ALE) (ale).

12 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu select Axes/Grid Settings.

2 In the dialog box that opens, go to the Axis page and clear the Axis equal check box. 
Then define axis settings according to the following table:

3 Go to the Grid page and clear the Auto check box. Then define axis settings 
according to the following table. When complete, click OK.

x min -1e-3

x max 3e-3

y min -1e-3

y max 2e-3

x spacing 0.5e-3

Extra x 0.3e-3 0.75e-3 1.75e-3 2.2e-3

y spacing 0.5e-3

Extra y 5e-6 25e-6
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4 From the Options menu select Constants. In the resulting dialog box enter the 
following names and expressions (you can change these values to model different 
bonding and ambient conditions). When done, click OK.

5 From the Options menu select Materials/Coefficients Library. In the resulting dialog 
box select Model and then click New. 

6 Go to the Name edit field and enter Glass HOYA, then in the Material properties area 
set these parameter values; when done, click OK.

G E O M E T R Y  M O D E L I N G

1 Draw four rectangles as given in the following table. To do so, go to the Draw 
toolbar and Shift-click the Rectangle/Square button; alternatively, from the Main 
menu choose Draw>Specify Objects>Rectangle.

2 Create the composite object CO1, which consists of the points in the following 
table. To do so, go to the Draw toolbar, click the Line button, and left-click through 
the points in sequence. Finish the geometry by right-clicking on the drawing area.

Alternatively, go to the Draw toolbar and Shift-click the Line button. In the resulting 
dialog box go to the Style list and select Closed polyline (solid). In the Name edit field, 
verify that the name is CO1; if not, enter it. Then enter the coordinates (all four x 

NAME EXPRESSION DESCRIPTION

T0 273.15[K] Normal temperature

T_bondingH T0 + 400[K] High bonding temperature

T_bondingL T0 + 22[K] Low bonding temperature

T_ambient T0 + 15[K] Ambient temperature

QUANTITY VALUE/EXPRESSION DESCRIPTION

E 86.667e9 Young’s modulus

nu 0.244 Poisson ratio

rho 2600 Density

alpha 3.41e-6 Thermal expansion

NAME SIZE POSITION

WIDTH HEIGHT BASE X Y

R1 2.5e-3 0.5e-3 Corner 0 -0.5e-3

R2 2.5e-3 0.5e-3 Corner 0 0

R3 2.5e-3 0.5e-3 Corner 0 0.5e-3

R4 1.5e-3 5e-6 Corner 0.5e-3 0
R  3 :  M E M S  S E N S O R  M O D E L S



values go on one line separated by spaces; the same holds for the y values). When 
finished, click OK. 

3 Create a composite object of objects R2 and CO1. On the Draw toolbar select the 
Create Composite Object button, go to the Set formula edit field and enter R2-CO1, 
then click OK.

4 Draw four points on the coordinates given on the following table. To do so, 
successively select the Point button from the Draw toolbar and click the grid points. 
Alternatively, from the Draw toolbar shift-click the Point button four times, each 
time entering a coordinate pair. 

P H Y S I C S  S E T T I N G S

Subdomain Settings
You supply material parameters separately for each application mode. Furthermore, 
here you define in which subdomain the model solves each application mode.

Specify the subdomain settings for the Plane Stress (smps) application mode as follows:

1 From the Main menu choose Multiphysics>Plane Stress (smps).

2 Choose the menu item Physics>Subdomain Settings. 

3 Go to the Material page.

4 Select Subdomain 4 and clear the Active in this domain check box.

5 Select Subdomains 1 and 3. 

6 Click Load, then from the Materials list select Geom1>Glass HOYA (mat1). Click OK. 

COORDINATE

X Y

0.3e-3 0.5e-3

0.5e-3 25e-6

2.0e-3 25e-6

2.2e-3 0.5e-3

NAME COORDINATES

X Y

PT1 7.5e-4 5e-6

PT2 1.75e-3 5e-6

PT3 7.5e-4 0

PT4 1.75e-3 0
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7 Go to the thickness edit field and enter 2.5[mm]. 

8 Select Subdomain 2. 

9 Click Load. From the Materials list select Basic Material Properties>Silicon, then click 
OK.

10 Go to the thickness edit field and enter 2.5[mm]. 

11 To enable thermal stresses first select Subdomains 1, 2, and 3. 

12 Click the Load tab. Select the Include thermal expansion check box. Go to the Temp 
edit field and enter T_bondingL, then go to the Tempref edit field and enter 
T_bondingH.

13 Click OK.

Specify the subdomain settings for the Plane Stress (smps2) application mode as 
follows:

1 From the Main menu select Multiphysics>Plane Stress (smps2).

2 Choose the menu item Physics>Subdomain Settings.

3 Set the material parameters for Subdomains 1, 2, and 3, and deactivate subdomain 
4 following the same procedures as for the first Plane Stress application mode in the 
previous list (Steps 3 to 10). Note, though, that you can select materials directly 
from the Library material list on the Material page.

4 To include initial stresses and further thermal stresses first select Subdomains 1, 2, 
and 3.

5 Click the Load tab. Select the Include thermal expansion check box. Go to the Temp 
edit field and enter T_ambient, then go to the Tempref edit field and enter 
T_bondingL.

6 Click the Initial Stress and Strain tab. Select the Include initial stress check box. Enter 
values for σxi (sX_smps), for σyi (sY_smps), for σzi (sZ_smps), and for σxyi 
(sXY_smps). 

7 Click OK.

Specify the subdomain settings for the Moving Mesh (ALE) (ale) application mode as 
follows:

1 From the Main menu select Multiphysics>Moving Mesh (ALE) (ale).

2 Choose the menu item Physics>Subdomain Settings.

3 Select Subdomains 1, 2, and 3 and select the Physics induced displacement check box.

4 Enter u2 and v2 in the dx and dy edit fields, respectively.
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5 Select Subdomain 4.

6 See that the Free displacement option button is selected.

7 Click OK.

When configuring the Electrostatics application mode, use material parameters 
corresponding to air.

1 From the Main menu select Multiphysics>Electrostatics (emes).

2 Choose the menu item Physics>Subdomain Settings.

3 Select Subdomains 1, 2, and 3 and clear the Active in this domain check box.

4 Leave parameter values for Subdomain 4 at their initial values (that is, the 
constitutive relationship is D = ε0εr  E with εr = 1 and ρ is 0). Check the Init page to 
verify that the setup has initialized V to zero.

5 Click OK.

Boundary Conditions
The manufacturing process applies no loads or constraints on the boundaries. Thus 
you do not need to set any boundary conditions for Plane Stress (smps) because, by 
default, there are not any loads or constraints. Define boundary conditions for the 
other application modes according to the following steps: 

1 Select Multiphysics>Plane Stress (smps2) and open the Physics>Boundary Settings 
dialog box. 

2 Select Boundary 2, and on the Constraint page set Constraint condition to Fixed.

3 Go to the Load page and select all boundaries 

4 Click the Edge load is defined as force/area using the thickness button.

5 Select Tangent and normal coord. sys. (t,n) from the Coordinate system list.

6 See that Ft is zero for all boundaries.

7 Set the Fn values as follows:

8 Click OK, then click Update symbols on the Visualization/Selection toolbar to see 
that all boundary forces point towards the sensor.

9 Select Multiphysics>Moving Mesh (ALE) (ale) and then Physics>Boundary Settings.

10 Select all active boundaries, that is, Boundaries 10–12 and 14–18. 

SETTINGS BOUNDARIES 10, 12, 
15, 17

BOUNDARIES 1, 3, 5, 7, 11, 14, 16, 
18, 22–24

BOUNDARIES 8, 9, 13, 
20

Fn P_ambient -P_ambient 0
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11 Select the dx and dy check boxes and type u2 and v, respectively, in the 
corresponding edit fields.

12 Click OK.

13 Select Multiphysics>Electrostatics (emes) and then Physics>Boundary Settings.

14 Define boundary settings for the active boundaries as in the following table. Note 
that you define the port settings on the separate Port page; when done click OK. 

Point Settings
1 Select Multiphysics>Plane Stress (smps) and then Physics>Point Settings.

2 Make sure the Standard notation button is selected. Then define point constraints 
according to the following table. Check also that Global coordinate system is selected 
in the Coordinate system list; when done, click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu choose Mesh Parameters.

2 On the Global page find the Maximum element size edit field and enter 0.5e-4.

3 Select the Subdomain page.

4 Select Subdomain 4, then go to the Maximum element size edit field and enter 1e-6.

5 Select the Advanced page.

6 In the x-direction scale factor edit field enter 0.2.

7 Click Remesh to initialize the mesh.

8 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

The following steps use a static solver to first solve the bonding phase and the 
parametric solver to solve the sensor operation for different pressures. 

SETTINGS BOUNDARIES 10–12, 16–18 BOUNDARY 14 BOUNDARY 15

Boundary condition Zero charge/Symmetry Ground Port

Port number 1

Use port as input Selected

Input property Forced voltage

SETTINGS POINT 1 POINT 17

Rx 0 (not selected)

Ry 0 0
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To make it easier to test the model with different temperature settings, use solver 
scripting. Before proceeding with the steps below, go to the Solver Manager dialog box, 
click the Script tab, select Automatically add commands when solving, and then close the 
Solver Manager dialog box. Next perform the steps below, and finally clear the 
Automatically add commands when solving check box. Later on you can return to the 
Script page of the Solver Manager, select the Solve using a script check box, and click the 
Solve button. The script automatically performs all the steps needed for the solution.

1 From the Solve menu select Solver Parameters.

2 On the General page verify that the Analysis list has the selection Static and that the 
Solver list has the selection Stationary. Click OK.

3 From the Solve menu choose the Solver Manager; alternately, click the Solver Manager 
button on the Main toolbar.

4 On the Initial Value page the default values are correct (Initial value: Initial value 

expression evaluated using current solution; Value of variables not solved for and 

linearization point: Use setting from Initial value frame).

5 Click the Solve For tab. Select Plane Stress (smps) and then click Solve.

6 Keeping the Solver Manager open, select Solver Parameters from the Solve menu.

7 On the General page select Parametric from the Solver list.

8 In the Parameter name field type P_ambient. 

9 In the Parameter values list type 0 1e4:1e4:1e5. Click OK.

10 Go back to the Solver Manager.

11 Click the Initial Value tab. In the Value of variables not solved for and linearization 

point area click the Current solution button.

12 Click the Solve For tab. Select Plane Stress (smps2) and then click Solve.

13 On the Initial Value page find the Value of variables not solved for and linearization 

point area. Verify that the Parameter value list is active and has the selection All. 

14 On the Solve For page select the Moving Mesh (ALE) (ale) application mode. Click 
Solve.

15 Select the Electrostatics (emes) application mode. Click Solve.

16 Click OK to close the Solver Manager.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Bonding Phase
Use following steps to create Figure 3-11 on page 199:
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1 From the Postprocessing menu choose Plot Parameters.

2 Go to the General page.

3 On the Plot type area verify that only the Surface, Boundary and Deformed shape 

check boxes are selected. See that the Frame list shows Frame (ref).

4 Examine the Parameter value list. Any solution is fine because there is only one 
solution, that for the first step.

5 Click the Surface tab. From the Predefined quantities list select von Mises stress 

(smps).

6 Go to the Surface color area, and in the Colormap list select Cool.

7 Go to the Boundary page. Any selection in the Predefined quantities list is fine.

8 In the Boundary color area select Uniform color; then click the Color button, select 
red, and click OK.

9 Click OK to close the Plot Parameters dialog box.

Response to Ambient Pressure
Use following steps to create Figure 3-12 on page 200:

1 From the Postprocessing menu choose Plot Parameters.

2 On the General page go to the Plot type area and make sure that only the Surface, 
Boundary, and Streamline check boxes are selected. 

3 Verify that the Frame list shows Frame (ale).

4 From the Parameter value list select the solution you want to plot

5 Move to the Surface page, go to the Predefined quantities list and select Plane Stress 

(smps2)>von Mises stress. In the Colormap list select cool.

6 On the Boundary page use the same settings given in Steps 7 and 8 in the previous 
postprocessing section.

7 Go to the Streamline page. Under Streamline Data set the Predefined quantities list to 
Electric field (emes).

8 On the Start Points tab, set the Number of start points to 100.

9 Click the Line Color tab, then click the Use expression button, and click the Color 

Expression button.

10 In the dialog box that opens, set the Predefined quantities list to Electrostatics 

(emes)>Electric field, norm, then click OK.

11 Click the Advanced button and select Normalize vector field, then click OK.

12 Click OK.
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Capacitance
To compute the capacitance, perform the following steps:

1 From the Postprocessing menu choose Data Display>Global.

2 From the Predefined quantities list, select Electrostatics (emes)>Capacitance matrix, 

element 11.

3 From the Parameter value list select the solution you want to plot.

4 Click OK. 

You find the result in the message log at the bottom of the main window. The model 
calculates a capacitance of approximately 1.77 nF for zero pressure.

You can also plot the capacitance:

1 From the Postprocessing menu choose Domain Plot Parameters.

2 Click the Point tab.

3 In the Expression to evaluate edit field type C11_emes.

4 Select any point.

5 Click OK.
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S AW Ga s  S e n s o r

Introduction

A surface acoustic wave (SAW) is an acoustic wave propagating along the surface of a 
solid material. Its amplitude decays rapidly, often exponentially, with the depth of the 
material. SAWs are featured in many kinds of electronic components, including filters, 
oscillators, and sensors. SAW devices typically use electrodes on a piezoelectric material 
to convert an electric signal to a SAW, and back again.

In this model, you investigate the resonance frequencies of a SAW gas sensor. The 
sensor consists of an interdigitated transducer (IDT) etched onto a piezoelectric 
LiNbO3 (lithium niobate) substrate and covered with a thin polyisobutylene (PIB) 
film. The mass of the PIB film increases as PIB selectively adsorbs CH2Cl2 
(dichloromethane, DCM) in air. This causes a shift in resonance to a slightly lower 
frequency.

Model Definition

Figure 3-14 shows a conceptual view of the gas sensor in this model. IDTs used in 
SAW devices may have hundreds of identical electrodes, and each electrode can be 
about 100 times longer than it is wide. You can therefore neglect the edge effects and 
reduce the model geometry to the periodic unit cell shown in Figure 3-15. The height 
of this cell does not have to extend all the way to the bottom of the substrate but only 
a few wavelengths down, so that the SAW has almost died out at the lower boundary. 
In the model, this boundary is fixed to a zero displacement.
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Figure 3-14: Conceptual view of the SAW gas sensor, showing the IDT electrodes (in black), 
the thin PIB film (light gray), and the LiNbO3 substrate (dark gray). For the sake of 
clarity, the dimensions are not to scale and the IDT has fewer electrodes than in common 
devices. A slice of the geometry is removed to reveal the modeled unit cell (in white).
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Figure 3-15: The modeled geometry of the model. A 500 nm PIB film covers two 1 µm-wide 
electrodes on top of the LiNbO3 substrate. The substrate subdomain continues below the 
lower frame of the picture and has a total height of 22 µm. In the first version of the model, 
the substrate is the only active subdomain.

You set up the model in the Piezo Plane Strain application mode, which requires the 
out-of-plane strain component to be zero. This should be a valid assumption, 
considering that the SAW is generated in the model plane and that the sensor is thick 
in the out-of-plane direction.

The first version of the model deals only with free SAW propagation in the LiNbO3 
substrate, without any applied electric field. In order to find the velocity of the wave, 
we use periodic boundary conditions to dictate that the voltage and the displacements 
be the same along both vertical boundaries of the geometry. This implies that the 
wavelength will be an integer fraction of the width of the geometry. The lowest SAW 
eigenmode has its wavelength equal to the width of the geometry, 4 µm. The 
eigenfrequency of this mode multiplied by 4 µm hence gives the velocity of the wave.

In a second version of the model, the aluminum IDT electrodes and the PIB film are 
added. This causes the lowest SAW mode to split up in two eigensolutions, the lowest 
one representing a series resonance, where propagating waves interfere constructively 
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and the other one a parallel (“anti-”) resonance, where they interfere destructively. 
These two frequencies constitute the edges of the stopband, within which no waves 
can propagate through the IDT.

The adsorption of DCM gas is represented as a slight increase of the density of the PIB 
film. In the third and final version of the model, the sensor is exposed to 100 ppm of 
DCM in air at atmospheric pressure and room temperature. The “partial density” of 
DCM in the PIB film is then calculated as

,

where K = 10l.4821 (Ref. 1) is the air/PIB partition coefficient for DCM, M is its 
molar mass, and

is its concentration in air.

The substrate used in the simulation is YZ-cut LiNbO3 with properties cited in Ref. 2. 
The density of the PIB film is from Ref. 1. The Poisson’s ratio is taken to be 0.48, 
which corresponds to a rather rubbery material. The Young’s modulus is set to 
10 GPa. Even at the comparatively high frequencies considered in this model, this is 
likely an overestimation. However, a much lower value would result in a multitude of 
eigenmodes located inside the film. While those may be important to consider in 
designing a SAW sensor, the focus in this model is on the SAW modes. Also, any effects 
of the DCM adsorption on other material properties than the density are neglected.

ρDCM PIB, KMc=

c 100 10 6– p RT( )⁄⋅ ⋅=
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Results

Figure 3-16 shows the SAW as it propagates along the surface of the piezoelectric 
substrate. The frequency corresponding to a 4 µm wavelength computes to 870 MHz, 
giving a phase velocity of 3479 m/s.

Figure 3-16: Deformed shape plot of a freely propagating SAW in the substrate. The color 
scale shows the magnitude of the displacements.

In the full model with the periodic IDT and the thin film included, the resonance and 
anti-resonance frequencies evaluate to 841 MHz and 850 MHz, respectively. 
Figure 3-17 and Figure 3-18 show the electric potential distribution characteristics for 
these solutions.
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Figure 3-17: Electric potential distribution and deformations at resonance, 841 MHz. 
The potential is symmetric with respect to the center of each electrode.

Exposing the sensor to a 100 ppm concentration of DCM in air leads to a resonance 
frequency shift of 227 Hz downwards. This is computed by evaluating the resonance 
frequency before and after increasing the density of adsorbed DCM to that of the PIB 
domain.

Note that the computational mesh is identical in both these solutions. This implies that 
the relative error of the frequency shift is similar to that of the resonance frequency 
itself. Thus the shift is accurately evaluated despite being a few magnitudes smaller than 
the absolute error of the resonance frequency. 

In a real setup, the drift is often measured by mixing the signal from a sensor exposed 
to a gas with a reference signal from one protected from the gas. The beat frequency 
then gives the shift.
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Figure 3-18: Electric potential distribution and deformations at antiresonance, 
851 MHz. The potential is antisymmetric with respect to the center of the electrodes.
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Model Library path: MEMS_Module/Sensor_Models/SAW_gas_sensor

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator and click the New tab.
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2 From the Space dimension list select 2D.

3 In the list of application modes select MEMS Module>Structural Mechanics>Piezo Plane 

Strain>Eigenfrequency analysis.

4 Click OK.

G E O M E T R Y  M O D E L I N G

1 Create the following rectangles by repeatedly using Draw>Specify Objects>Rectangle:

2 Select all objects and choose Draw>Modify>Scale. In the dialog box that appears, 
enter 1e-6 for both scale factors; then click OK.

3 Click the Zoom Extents button on the Main toolbar to zoom in on the now 
micron-sized geometry.

O P T I O N S  A N D  S E T T I N G S

1 Choose Options>Constants.

2 Define the following constant names, expressions, and (optionally) descriptions:

WIDTH HEIGHT BASES: CORNER X BASE: CORNER Y

4 22 0 -22

1 0.2 0.5 0

1 0.2 2.5 0

4 0.5 0 0

NAME EXPRESSION DESCRIPTION

p 101.325[kPa] Air pressure

T 25[degC] Air temperature

R 8.3145[Pa*m^3/(K*mol)] Gas constant

c_DCM_air 100e-6*p/(R*T) DCM concentration in air

M_DCM 84.93[g/mol] Molar mass of DCM

K 10^1.4821 PIB/air partition constant for 
DCM

rho_DCM_PIB K*M_DCM*c_DCM_air Mass concentration of DCM in 
PIB

rho_PIB 0.918[g/cm^3] Density of PIB

E_PIB 10[GPa] Young’s modulus of PIB

nu_PIB 0.48 Poisson’s ratio of PIB

eps_PIB 2.2 Relative permittivity of PIB
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3 Click OK.

P H Y S I C S  S E T T I N G S

In the first version of the model, you compute the velocity for SAW propagation in a 
homogenous, electrically insulated LiNbO3 substrate. The supplied material data are 
with reference to the xy-plane.

Subdomain Settings
1 From the Physics menu, open the Subdomain Settings dialog box.

2 Select Subdomains 2–4 and clear the Active in this domain check box.

3 Select Subdomain 1 and select Material orientation: xy plane.

4 Click the Edit button associated with cE and enter the following values into the 
Elasticity matrix dialog box; when finished, click OK.

5 Click the Edit button associated with e and enter the following values into the 
Coupling matrix dialog box; when finished, click OK.

6 Click the Edit button associated with εrS and enter the following values into the 
Relative permittivity dialog box; when finished, click OK.

7 Enter 4647 in the Density edit field.

8 Click OK to close the Subdomain Settings dialog box.

Boundary Conditions
1 From the Physics menu choose Boundary Settings.

2 Select Boundary 2 and set the Constraint condition to Fixed.

3 Select all exterior boundaries (1, 2, 4, 7, 10, 12, 15, 16).

2.424e11 0.752e11 0.752e11 0 0 0
2.03e11 0.573e11 0 0.085e11 0

2.03e11 0 0.085e– 11 0
0.752e11 0 0.085e11

0.595e11 0
0.595e11

1.33 0.23 0.23 0 0 0
0 0 0 2.5– 0 3.7
0 2.5– 2.5 0 3.7 0

28.7 0 0
85.2 0

85.2
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4 On the Electric BC page, set the Boundary condition to Zero charge/Symmetry.

5 Click OK.

6 Choose Physics>Periodic Conditions>Periodic Boundary Conditions.

7 On the Source tab, select Boundary 1 and enter u in the first Expression edit field.

8 On the Destination page, check Boundary 16 and enter u in the Expression edit field.

9 On the Source Vertices page, select Vertex 1 and click the right double-arrow. Then 
select Vertex 2 and click the right double-arrow.

10 On the Destination Vertices page, select Vertex 12 and click the right double-arrow, 
then Vertex 13 and the right double-arrow.

11 Define the expressions v and V in a similar fashion, starting by entering them in the 
Expression edit field on the Source page, on rows 2 and 3 respectively.

12 Click OK to close the Periodic Boundary Conditions dialog box.

M E S H  G E N E R AT I O N

1 Choose Mesh>Free Mesh Parameters.

2 From the Predefined mesh sizes list, choose Extremely fine.

3 On the Subdomain page, select all subdomains and set the Method to Quad.

4 On the Boundary page, select the upper boundaries of the substrate (4, 7, 10, 12, 
15) and enter 0.05e-6 for the Maximum element size.

5 Click Remesh, then click OK. When done, a zoom-in on the upper part of the 
geometry should look like Figure 3-19.
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Figure 3-19: The meshed geometry.

C O M P U T I N G  T H E  S O L U T I O N

1 From the Solve menu, open the Solver Parameters dialog box.

2 Enter 850e6 in the Search for eigenfrequencies around edit field, then click OK.

3 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The solver returns 6 eigensolutions with eigenfrequencies in the vicinity of 850 MHz. 
At 869.8 MHz, two of them are—within the numerical accuracy—the same. These 
show the shape and the frequency for a SAW with wavelength equal to the width of 
the geometry.

1 Open the Plot Parameters dialog box from the Postprocessing menu.

2 On the General page, select one of the eigenfrequencies equal to 869.8 MHz.

3 On the Deform page, select the Deformed shape plot check box. Clear the Auto check 
box and enter 400 in the Scale factor edit field.
R  3 :  M E M S  S E N S O R  M O D E L S



4 Click OK to close the dialog box and see a plot of the total displacement. If you want 
to, you can repeat the procedure with the other solution to verify that they are the 
same, only shifted by 90 degrees. One of the solutions will look like Figure 3-16.

5 To evaluate the velocity, choose Postprocessing>Data Display>Global.

6 Enter eigfreq_smppn*4e-6[m] in the Expression edit field.

7 In the Eigenfrequency list, select one of the 869.8 MHz eigenfrequencies.

8 Click OK to see the value of the velocity in the message log. It evaluates to 
approximately 3479 m/s.

This concludes the first part of the model. Proceed to find out how the electrodes and 
the PIB film affect the behavior of the SAW.

Sensor without Gas Exposure

Subdomain Settings
1 Open the Subdomain Settings dialog box and select Subdomains 2–4.

2 Select the Active in this domain check box.

3 Select Material model: Decoupled, isotropic.

4 Select only Subdomain 2. 

5 On the Structural page, enter E_PIB for the Young’s modulus, nu_PIB for the 
Poisson’s ratio, and rho_PIB for the Density.

6 On the Electrical page, select the Enable electrical equation check box and enter 
eps_PIB for the relative permittivity.

7 Select Subdomains 3 and 4 and click the Load button.

8 In the Materials/Coefficients Library dialog box, select Basic Material 

Properties>Aluminum and click OK.

9 Click OK to close the Subdomain Settings dialog box.

Boundary Conditions
1 From the Physics menu, choose Boundary Settings.

2 Select the Interior boundaries check box.

3 Select Boundaries 6-9 and 11-14. On the Electric BC page, set the condition to 
Electric potential. Keep the default zero potential.

4 Select Boundaries 3, 5, and 17, and set the condition to Zero charge/symmetry.

5 Click OK to close the dialog box.
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Note: The eigenfrequencies and hence the stopband do not depend on the values of 
the potentials. In fact, for linear eigenfrequency problems, they are automatically set 
to zero at the electrodes, regardless of the applied value. You can solve the 
corresponding driven problem by switching to a frequency response analysis and 
applying different potentials to the electrodes.

6 Choose Physics>Periodic Conditions>Periodic Boundary Conditions.

7 On the Source page, select Boundary 3. Enter u in the first Expression edit field and 
v in the row below, and V in the third row.

8 On the Destination page, select Constraint name: pconstr1, check Boundary 17, and 
enter u in the Expression field.

9 Still on the Destination page, select Constraint name: pconstr2, check Boundary 17, 
and enter v in the Expression field.

10 Finally, select Constraint name: pconstr3, check Boundary 17, and enter V in the 
Expression field.

11 Click OK to close the dialog box. 

You have now established the periodicity in the PIB film.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

If you are still using the manual scaling of the deformations from the previous exercise, 
the plot that appears after solving will look rather distorted. Proceed as follows to find 
the SAW modes and use more suitable plot parameters:

1 Open the Plot Parameters dialog box from the Postprocessing menu.

2 On the General page, select the 850 MHz eigenfrequency.

3 On the Deform page, enter 40 in the Scale factor edit field.

4 Click Apply to view a plot of the total displacement at anti-resonance.

5 On the General page, select the 841 MHz eigenfrequency and click Apply to see the 
deformations at resonance. This plot should look like Figure 3-20.
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Figure 3-20: Deformations at resonance.

A plot of the electric potential shows a qualitative difference between the two 
solutions.

6 On the Surface page, select Piezo Plane Strain (smppn)>Electric potential from the 
Predefined quantities list.

7 Click Apply to see the potential distribution at resonance, as shown in Figure 3-17 
on page 217. Notice that it is symmetric with respect to each individual electrode.

8 On the General page, select the 850 MHz eigenfrequency and click OK to see the 
potential distribution at anti-resonance, as in Figure 3-18 on page 218. This time, 
it is antisymmetric.

Sensor with Gas Exposure

In the final version of this model, you will expose the sensor to DCM gas. The 
eigenfrequencies are expected to shift by a very small amount. In order to see the shift, 
you need to include more digits in the output.

1 Choose Postprocessing>Data Display>Global.
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2 Enter the expression eigfreq_smppn and select the 841 MHz eigenfrequency.

3 Select the Display result in full precision check box, then click OK.

The message log now shows all computed digits of the eigenfrequency.

Subdomain Settings
1 From the Physics menu, select Subdomain Settings.

2 Select Subdomain 2. On the Structural tab, change the Density so that it reads 
rho_PIB+rho_DCM_PIB.

3 Click OK to close the Subdomain Settings dialog box.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Choose Postprocessing>Data Display>Global.

2 Make sure that the expression still says eigfreq_smppn and select the 841 MHz 
eigenfrequency.

3 Click OK.

The first 6 digits of the eigenfrequency are the same as before. Subtracting the new 
value from the previous value (which is most easily done by copying and pasting the 
results from the message log) shows that the eigenfrequency with gas exposure is lower 
by 227 Hz.
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Th e rma l  E xpan s i o n  i n  a  MEMS Dev i c e  
U s i n g  t h e  Ma t e r i a l  L i b r a r y

The purpose of this model is to exemplify the use of the Material Library in COMSOL 
Multiphysics. This library contains more than 20,000 property functions for 2500 
materials. The larger part of these properties are mechanical and thermal properties for 
solid materials given as functions of temperature. You need the Material Library to 
build the model.

Introduction

Thermal expansion is a common method used in the microscale to displace a part of a 
component, for example in an actuator. In this example model the opposite is required; 
that is, there should be a minimum of thermal expansion. Such a device could be 
included in a microgyroscope or any other sensor for acceleration or positioning.

Model Definition

Figure 3-21 below shows the model geometry:

Figure 3-21: Geometry of the device.

Surfaces attached
to a solid frame
T H E R M A L  E X P A N S I O N  I N  A  M E M S  D E V I C E  U S I N G  T H E  M A T E R I A L  L I B R A R Y  |  227



228 |  C H A P T E
The model consists of two sets of physics:

• A thermal balance with a heat source in the device, originating from Joule heating 
(ohmic heating). Air cooling is applied on the boundaries except at the position 
where the device is attached to a solid frame, where an insulation condition is set.

• A force balance for the structural analysis with a volume load caused by thermal 
expansions. The device is fixed at the positions where it is attached to a solid frame 
(see Figure 3-21).

The device is made of the copper-beryllium alloy UNS C17500.

The thermal balance consists of a balance of flux at steady state. The heat flux is given 
by conduction only. The heat source is a constant heat source of 1·108 W/m3. The air 
cooling at the boundaries is expressed using a constant heat transfer coefficient of 
10 W/m2 and an ambient temperature of 298 K.

The stress and strains are well within the elastic region for the material. The expression 
for thermal expansion requires a strain reference temperature for the copper-beryllium 
alloy, which in this case is 293 K.

All other thermal and mechanical properties are obtained from the Material Library.

Results and Discussion

The following figure shows the temperature distribution in the device. The heat source 
increases the temperature to 323 K from an ambient temperature of 298 K. The 
temperature varies less than 1/100 of a degree in the device. The displacements vary 
R  3 :  M E M S  S E N S O R  M O D E L S



accordingly, and the model shows that it is possible to study the device using only one 
unit cell, for example, 1/2 of a U-shaped section.

Figure 3-22: Temperature and displacement of the device. The edges of the original 
geometry are shown in black. The deformed shape is exaggerated by a factor of almost 200.

The following figure (Figure 3-23) shows the displacement of a curve that follows the 
top inner edges of the device from left to right. It is clear from Figure 3-23 that the 
displacement follows a repetitive pattern along the length of the device. This also 
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supports the hypothesis that 1/2 of a U-shaped section is enough to represent the 
behavior of the device.

Figure 3-23: The displacement along the inner edge of the device shows a repetitive pattern, 
which means that a model of half of the u-shaped structure is enough to study the effects of 
thermal expansion on the device.

Model Library path: MEMS_Module/Sensor_Models/thermal_expansion

Modeling Using the Graphical User Interface

1 Open the Model Navigator.

2 Select 3D from the Space dimension list.

3 Select MEMS Module>Thermal-Structural Interactions>Solid, Stress-Strain with Thermal 

Expansion>Static analysis.

4 Click OK.

G E O M E T R Y  M O D E L I N G

1 From the Draw menu, select Work Plane Settings.

2 Click the x-y plane option button if it is not already selected.

3 Click OK.

4 From the Options menu, select Axis/Grid Settings.

5 Enter -1.3e-4 in the x min edit field, 1.3e-4 in the x max edit field, -0.3e-4 in 
the y min edit field, and 1.3e-4 in the y max edit field.
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6 Click the Grid tab.

7 Clear the Auto box.

8 Enter 1e-5 in the x spacing and 1e-5 in the y spacing edit fields, respectively.

9 Click OK.

Next, draw a projection of the 3D geometry and then extrude it to create a 3D object:

1 From the Draw menu, select Specify Objects>Rectangle.

2 Type 1e-5 in the Width and 8e-5 in the Height edit fields, respectively.

3 Type -1e-4 in the x edit field in the Position area using the Corner option in the Base 
list.

4 Click OK.

5 Click the 2nd Degree Bezier Curve tool button.

6 Click the coordinates (-9e-5, 8e-5), (-9e-5, 9e-5), and (-8e-5, 9e-5) to create an arc.

7 Click the Line tool button.

8 Click the coordinate (-8e-5, 1e-4).

9 Click the 2nd Degree Bezier Curve tool button.

10 Click the coordinates (-1e-4, 1e-4) and (-1e-4, 8e-5).

11 Click the right mouse button to form a composite object with the shape of an elbow.

12 Press Ctrl+A to select all objects.

13 Click the Mirror tool button.

14 Enter -8e-5 in the x edit field in the Point on line row in the Paste dialog box. Make 
sure that the normal vector to the line has the default values (1, 0).
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15 Click OK.

16 Press Ctrl+A to select and Ctrl+C to copy all objects.

17 Press Ctrl+V to paste all objects.

18 Enter 5e-5 in the x edit field for Displacements in the Paste dialog box.

19 Click OK.

20 Press Ctrl+A to select and Ctrl+C to copy all objects.

21 Press Ctrl+C to paste all objects.

22 Enter 1e-4 in the x edit field for Displacements in the Paste dialog box.

23 Click OK.

24 Click Zoom Extents.

25 From the Draw menu, select Specify Objects>Rectangle.
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26 Enter 3e-5 in the Width, 1e-5 in the Height, and -7e-5 in the x edit fields, 
respectively.

27 Click OK.

28 Press Ctrl+C followed by Ctrl+V to copy and paste the selected rectangle.

29 Type 5e-5 in the x edit field for Displacements.

30 Click OK.

31 Press Ctrl+C followed by Ctrl+V to copy and paste the selected rectangle.

32 Type 5e-5 in the x edit field for Displacements.

33 Click OK.

34 Press Ctrl+A and click the Union button on the Draw toolbar to create one 
composite object.

35 From the Draw menu, select Extrude.

36 Enter 1e-5 in the Distance edit field.

37 Click OK.

38 Click the Headlight button on the Camera toolbar.

The completed geometry in the drawing area should now look like that in the 
following figure.
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P H Y S I C S  S E T T I N G S

Start by setting the properties and boundary conditions for the thermal analysis.

Subdomain Settings—Heat Transfer by Conduction
1 From the Physics menu, select Subdomain Settings.

2 Click the Subdomain selection list and press Ctrl+A to select all subdomains.

3 Click the Load button.

4 Click the Material Library node, which is second in the Materials list.

5 Click the Al & Cu alloys node.

6 Click the Copper alloys node.
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7 Select the copper alloy UNS C17500 from the list.

8 Click OK.

9 Enter 1e8 in the Heat source edit field.

10 Click OK.

Boundary Conditions—Heat Transfer by Conduction
1 From the Physics menu, select Boundary Settings.
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2 Click the Boundary selection list.

3 Press Ctrl+A to select all boundaries.

4 In the Boundary selection list, press Ctrl and click Boundaries 2, 17, 26, 32, 52, 61, 
67, 87, 96, 102, and 122 to clear them from the current selection. Note that you 
can also do this directly in the user interface by selecting all boundaries, clicking the 
right mouse button to keep the selection, and then selecting the boundaries 
corresponding to the attachment to the base one at the time. When you click on a 
boundary, it turns green. If this is the boundary you want to clear from the selection 
list, click the right mouse button. Repeat this procedure until all boundaries listed 
above are cleared from the selection.

5 Select Heat Flux from the Boundary condition list.

6 Enter 10 in the Heat transfer coefficient edit field and 298 in the External temperature 
edit field.

7 Click OK.

Subdomain Settings—Solid, Stress-Strain
1 From the Multiphysics menu, select the Solid, Stress-Strain application mode.

2 From the Physics menu, select Subdomain Settings.

3 Select all the subdomains in the Subdomain selection list, if they are not already 
selected.

4 In the Library material list, select UNS C17500.

5 Click the Load tab. Note that the Include thermal expansion box is selected and that 
the variable for the temperature field, T, already appears in the Strain temperature 
edit field.

6 Type 293 in the Strain ref. temperature edit field. You can get the strain reference 
temperature from the Material Library. In this case, it is included in the notes for 
the thermal expansion coefficient function, alpha, in the Material Library.

7 Click OK.

Boundary Settings—Solid, Stress-Strain
1 From the Physics menu, select the Boundary Settings.

2 Click the Boundary selection list and press Ctrl+D to clear the current selection.

3 Press Ctrl and click Boundaries 2, 17, 26, 32, 52, 61, 67, 87, 96, 102, and 122 to 
select the surfaces attached to the solid frame.

4 Select Fixed from the Constraint condition list.

5 Click OK.
R  3 :  M E M S  S E N S O R  M O D E L S



M E S H  G E N E R A T I O N

1 Click the Interactive Mesh button.

2 Select Boundary 2, which is the left-most boundary attached to the solid frame.

3 Click the Decrease Mesh Size button to decrease the mesh size from normal to fine.

4 Click the Decrease Mesh Size button a second and a third time to decrease the mesh 
size to extra fine.

5 Click the Mesh Selected (Mapped) mesh button.

6 Click the Subdomain Mode button.

7 Select Subdomains 1–5, which are the five first domains from left to right. Note that 
you can do this by clicking the mouse until you get the desired subdomain 
highlighted, then you can right-click to save the selection. Then continue to the 
next subdomain, highlight it by clicking on it, and right-click to save the selection 
and so on until you have selected all five subdomains.

8 Click the Mesh Selected (Swept) button.

The reason for not sweeping the mesh throughout all subdomains is that the 
meshing of the cube sections, which unite the U-shaped sections of the geometry, 
requires that you change the sweep direction in order to create only hexagonal mesh 
elements. If you instead mesh all U-shaped sections first, COMSOL Multiphysics 
detects the sweep dimension automatically by the fact that two opposite faces of the 
cubes are meshed. You can therefore first create a swept mesh for all U-shaped 
sections and then mesh the cubes to create a hexagonal mesh for the whole 
geometry.

9 Click the Boundary Mode button.

10 Select Boundaries 32, 67, and 102 by clicking on them in the user interface. Note 
that you can use the same strategy as outlined above—that is, to click on the desired 
boundary until it gets highlighted—then right-click to save the selection, and so on 
for multiple selections.

11 Click the Mesh Selected (Mapped) button.

12 Click the Subdomain Mode button.

13 Press Ctrl+D to clear the current selection.

14 Select Subdomains 7–12, 14–19, and 21–25 by using the strategy outlined in Point 
7 above.

15 Click the Mesh Selected (Swept) button.

16 Select Subdomains 6, 13, and 20.
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17 Click the Mesh Selected (Swept) button.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar. Note that the solution is fully coupled, 
which is not required in this case. You can solve the thermal balance first because it 
does not depend on the structural analysis. The structural analysis does require the 
temperature field in order to calculate the loads due to thermal expansion. If you are 
familiar with the use of the Solver Manager, you can use it to solve the problem 
sequentially.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate the plot in Figure 3-22, visualizing the surface temperature and the 
structural deformation of the device, follow these instructions:

1 Click the Plot Parameters button.

2 Click the General tab.

3 Clear the Slice box.

4 Select the Boundary box.

5 Select the Deformed shape box.

6 Click the Boundary tab.
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7 In the Expression edit field type T.

8 Click the Deform tab.

9 On the Subdomain Data page, select Solid, Stress-Strain (smsld)>Displacement in the 
Predefined quantities list (the default option).

10 Click OK.

Create the deformation plot in Figure 3-23 as follows:

1 Choose Postprocessing>Cross-Section Plot Parameters.

2 Click the Line/Extrusion tab.

3 Select the inner boundary segments marked in the following figure. To add a 
segment that you have highlighted in red by clicking with the mouse to the selection 
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use right-click. The segment should then turn blue in the drawing area. Repeat this 
procedure until you have selected all inner boundary segments.

4 In the Predefined quantities list select Solid, Stress-Strain (smsld)>Total displacement.

5 On the General page, click the Title/Axis button.

6 Click the option button next to the Title edit field. Leave the edit field empty to 
obtain a plot without title.

7 Click the option button next to the First axis label edit field, then enter the label 
Position along the edge [m].

8 Click the option button next to the Second axis label edit field, then enter the label 
Displacement [m].

9 Click OK to close the Title/Axis Settings dialog box.

10 Click OK to close the Cross-Section Plot Parameters dialog box and generate the plot.
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M i c r o f l u i d i c s  M o d e l s
This chapter presents several microfluidics models including those that describe 
AC electrokinetically adjusted fluid flow in a microchannel, pressure-driven flow 
and electrophoresis in a microchannel system, fluid-structure interaction, fluid flow 
in a star-shaped microchannel, capillary filling, and electroosmotic flow and lamella 
micromixer models.
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AC E l e c t r o k i n e t i c a l l y  Enhan c ed 
S u r f a c e  R e a c t i o n s

Introduction

This model studies the use of AC electrokinetic forces to enhance the rate of transport 
of reactants to a reaction surface on the wall of a microchannel. It was developed for 
the MEMS Module by Gaurav Soni, Marin Sigurdson, and Carl Meinhart of the 
Department of Mechanical and Environmental Engineering, University of California, 
Santa Barbara.

The modeled system mixes a small concentration of a biological analyte with the fluid 
in a microchannel where a reaction surface is located on the channel walls. The flow 
velocity perpendicular to the surface is so small that the analyte, which is supposed to 
bind to an antibody ligand on this surface, is transported mainly by diffusion. The rate 
of the binding reaction on the surface is usually large enough to bind practically all 
analyte molecules appearing there. Thus, the process is said to be transport limited and, 
in order to increase the reaction rate, the system must increase the transport of 
molecules to the reaction surface.

AC electrokinetic forces can generate swirling patterns in the fluid and thereby 
enhance the transport of the analyte to the reaction surface (Ref. 1). Biological 
immunoassays, which detect an analyte through their binding response to an antibody 
ligand, can use these flow patterns to great advantage.

The AC electrokinetic forces arise when the fluid absorbs energy from an applied 
nonuniform AC electric field by means of Joule heating. The temperature increase 
changes the fluid’s conductivity and permittivity. Consequently the fluid experiences 
an effective or time-averaged volume force, which depends on the conductivity and 
permittivity gradients and on the field intensity. By changing the shape of the electric 
field it is possible to alter the fluid-flow pattern so that required amounts of analyte 
molecules reach the reaction surface.

Model Definition

Figure 4-1 shows the model geometry, which consists of a section of the channel 
40 µm high and 250 µm long. Two electrodes, each 60 µm wide, are located on the 
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lower boundary at distances of 50 µm and 130 µm from the inlet. The reaction 
surface, 20 µm wide, is located on the top wall, 90 µm from the inlet.

The fluid flows from left to right. The incoming flow profile is characteristic for fully 
developed laminar flow, that is, it is parabolic with zero velocity at the channel walls. 
An applied electrothermal force creates swirling patterns in the flow at the channel’s 
center.

The two electrodes produce an AC electric field that heats the fluid and creates the 
electrothermal force. The model assumes that the electrodes are perfect heat 
conductors and remain at a constant ambient temperature. At the inlet and the outlet, 
the temperature gradually approaches the ambient. At all other boundaries the model 
assumes that the channel is thermally and electrically insulated.

The incoming flow has a small concentration of a biological analyte, which the reaction 
surface on the upper boundary transports and adsorbs. Any remaining concentration 
exits the channel with the fluid at the right boundary.

Having solved for the steady-state flow for a given electric field and the resulting 
electrothermal force, this example reviews a transient simulation of the material 
balance of the analyte, assuming that the initial concentration in the channel is zero 
and that a given concentration of the analyte is injected at the inlet at time zero.

Figure 4-1: Model geometry for the microchannel with electrodes and a reaction surface.

F L U I D  F L O W

Fluid flow in the channel follows the Navier-Stokes equations

ρ u∂
t∂

------- η∇2u ρu ∇⋅ u p∇+ +– F=

∇ u⋅ 0=
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where u denotes the velocity, ρ is the density, η is the dynamic viscosity, and p refers 
to the pressure. At steady state, the first time-dependent term disappears. The volume 
force F appearing in the equation is the electrothermal force fE given by

 (4-1)

where σ is the conductivity, ε = εrε0 equals the fluid’s permittivity, ω represents the 
electric field’s angular frequency, and τ = ε/σ gives the fluid’s charge-relaxation time. 
The field vector E contains the amplitude and orientation of the AC electric field but 
not its instantaneous value.

The following table gives the input data for the model:

As a result of Joule heating, ε and σ are temperature dependent. You can rewrite the 
gradients of theses entities using chain differentiation, which yields

 

and

where T is the fluid’s temperature. For water,

and 

Thus you can rewrite the electrothermal force (Equation 4-1) as

NAME VALUE DESCRIPTION

 ρ 1000 kg/m3 Density of water

 η 1.08·10-3 kg/(m·s) Dynamic viscosity of water

 σ 5.75·10-2 S/m Conductivity of water

 εr 80.2 Relative permittivity of water

 ω 2π·15·103 rad/s Angular frequency of the AC electric field

F fE=

fE 0.5 ∇σ
σ

-------- ∇ε
ε

-------+⎝ ⎠
⎛ ⎞ E εE

1 ωτ( )2
+

------------------------ 0.5 E 2∇ε+⋅–=

ε∇ ε T∂⁄∂( ) T∇=

σ∇ σ T∂⁄∂( ) T∇=

1 ε⁄( ) ε T∂⁄∂( ) 0.004 K 1–
–=

1 σ⁄( ) σ T∂⁄∂( ) 0.02 K 1–
=
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The following table contains the boundary conditions for the incompressible 
Navier-Stokes equations:

E L E C T R O S T A T I C S

Because the electrothermal force is a time-averaged entity, it is sufficient to solve the 
static electric field that corresponds to the root mean square (rms) value of the AC 
field. The rms value of the AC voltage is Vrms = 10 V.

To solve the electrostatics problem, turn to Laplace’s equation

 

with

 

and the constitutive equation

The boundary conditions for the electrostatic problem are as follows:

H E A T  TR A N S F E R

The power that a unit volume of fluid absorbs through Joule heating is

BOUNDARY CONDITION

Left Parabolic inflow with average velocity 0.1 mm/s and 
zero velocity at the upper and lower boundaries

Upper No slip condition

Lower No slip condition

Right Outflow with pressure p = 0

BOUNDARY CONDITION

Left electrode Electric potential, V = Vrms/2 = 5V

Right electrode Electric potential, V = -Vrms/2 = -5V

Other boundaries Electric insulation

fE 0.5ε 0.016 K 1–( ) T∇ E E

1 ωτ( )2
+

------------------------ 0.5 E 2 0.004 K 1–
–( )∇T+⋅⎝ ⎠

⎛ ⎞–=

∇– ε∇V( )⋅ 0=

E V∇–=

D ε0εrE=

Q σ E 2
=
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where E is the rms value of the electric field and σ is the fluid’s conductivity. The heat 
source, Q, appears in the stationary heat balance equation

where Cp denotes the heat capacity and k is the fluid’s thermal conductivity. This is the 
nonconservative formulation of the heat balance, which is consistent with the 
assumption of a divergence-free flow field.

The following table gives the relevant input data for the heat-transfer problem:

In general, the Navier-Stokes equations along with the convection and conduction 
equation form a coupled system that you should solve simultaneously.

This example assumes an ambient temperature T = 0 °C, and the electrodes are held 
steady at this temperature. The flow rate is small, and you can therefore assume that 
the temperature decreases symmetrically at the inlet and the outlet. The magnitude of 
the temperature gradient at both boundaries is such that the fluid reaches the ambient 
temperature at a distance of  1 mm from the boundary. At all other boundaries the 
model assumes that the channel is insulated.

C O N V E C T I O N  A N D  D I F F U S I O N  O F  T H E  A N A L Y T E

The material balance of the analyte comes from the equation

.

This equation gives the material balance in a nonconservative form because the flow 
field is divergence free. In this equation D denotes the diffusion coefficient and R 
represents the reaction rate. Here R equals zero because no reactions take place in the 
bulk of the fluid, only on the reaction surface.

The boundary conditions are as follows:

NAME VALUE DESCRIPTION

 ρ 1000 kg/m3 Density of water

 Cp 4.184·103 J/(kg·K) Heat capacity of water

 k 0.598 W/(m·K) Thermal conductivity of water

BOUNDARY CONDITION

Left The incoming flow has constant analyte concentration

Right Remaining concentration leaves the system through convection

∇ k∇T–( )⋅ Q ρCpu ∇T⋅–=

δts
c∂
t∂

----- ∇ D∇c–( )⋅+ R u ∇c⋅–=
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The following table gives the input data for the material balance:

B I N D I N G  R E A C T I O N

The reaction surface contains a total concentration Rt of antibody ligands. The portion 
of the bonded molecules is the concentration B. The binding rate depends on the 
analyte concentration on the surface, c, on the concentration of free antibodies, and 
on the association rate constant, kon. Similarly, bonded antibodies dissociate with a rate 
that depends on the concentration of the bonded ligands and on the dissociation rate 
constant, koff. Therefore, the equation that describes the material balance of adsorbed 
species (see Ref. 2) is:

 (4-2)

The reaction rate of the analyte on the surface equals the negative of the binding rate 
on the surface.

The table below gives the input data for the material balance of the adsorbed species:

The model assumes that the antibodies do not diffuse on the surface and that there is 
no leakage of the molecules at the edges of the surface.

Reaction surface Concentration consumed in the binding reaction as defined by 
Equation 4-2 (see next chapter)

Other boundaries Boundaries are insulated and the concentration gradients normal 
to these boundaries equal zero

NAME VALUE DESCRIPTION

 δts 1 Time-scaling coefficient

 D 1·10-11 m2/s Diffusivity of the analyte in the fluid

 R 0 M/s No reaction takes place within the fluid

 c0 1 nM = 1µmol/m3 Inlet analyte concentration

NAME VALUE DESCRIPTION

 kon 108 (M·s)-1 = 105 m3/(mol·s) Association rate constant

 koff 0.02 s-1 Dissociation rate constant

 Rt 1.67·10-11 M·m = 1.67·10-8 mol/m2 Total surface concentration 
of the antibody ligand

BOUNDARY CONDITION

B∂
t∂

------- konc Rt B–( ) koff B–=
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To study the effect of the applied electric field, you first run the model with Vrms = 0 V 
and then repeat the simulation for Vrms = 10 V.

S T E P - R E S P O N S E  A N A L Y S I S

Another interesting aspect to analyze is the system’s behavior when injecting a fixed 
amount of analyte over a limited time with a sudden cutoff in the analyte supply. To 
simulate such an experiment, use the analyte inlet concentration expression

 (4-3)

with t1 = 1000 s and c0 = 75 nM = 75 µmol/m3 (1 M ≡ 1 mol/l = 103 mol/m3). For 
this analysis, modify the material balance input data according to the following table 
to obtain a reaction-rate limited process.

Results and Discussion

Figure 4-2 shows the flow profile and concentration distribution without any applied 
electric field. In this case, the flow is laminar and has a parabolic profile. The effect of 
the reaction surface on the analyte concentration is visible only in the narrow region 
near the surface. Compare it to the flow and concentration with an applied electric field 
(Figure 4-3). Now the flow profile is far from parabolic: it has two distinct swirls and 
a narrow region with high flow velocity between the electrodes. Both of these figures 
represent the situation 5 s after the system introduces analyte at the left boundary.

Figure 4-4 depicts the flow and concentration just 1 s after introducing the analyte. It 
shows more clearly how the swirling patterns in the flow focus the analyte on a 
narrower path near the reaction surface. This flow results in a difference in the 
adsorption rate of the molecules with and without the electric field, (Figure 4-5). The 
average number of adsorbed molecules—the ratio between the total amount and the 
surface width—on the surface increases more rapidly with the electric field (the curve 
with squares) than without the electric field (the curve with triangles).

NAME VALUE DESCRIPTION

 kon 100 m3/(mol·s) Association rate constant

 koff 5·10-3 s-1 Dissociation rate constant

 Rt 1.67·10-11 mol/
m2

Total surface concentration of the antibody ligand

c t( )
c0

0⎩
⎨
⎧

=
t t1<

t t1>
R  4 :  M I C R O F L U I D I C S  M O D E L S



Figure 4-2: Microchannel flow and concentration at 5 s without any applied electric field.

Figure 4-3: Microchannel flow and concentration at 5 s with an applied electric field.
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Figure 4-4: Microchannel flow and concentration at 1 s with an applied electric field.

Figure 4-5: Binding of molecules on the reaction surface in the microchannel with 
(squares) and without (triangles) an applied electric field.
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Figure 4-6 shows the result for the average concentration of bonded molecules of the 
third and final simulation, in which you cut off the analyte supply at t = 1000 s. During 
the phase when the analyte supply is kept constant, the concentration of molecules on 
the binding surface approaches a constant maximum value near 10−11 mol/m2. When 
the supply at the inlet then stops, the concentration starts to decay. By varying the 
antibody ligand concentration and the association and dissociation rate constants, you 
can study the effects on the maximum concentration and the decay rate. Simulations 
of this kind can thus be useful for fitting a model to experimental data.

Figure 4-6: System response when the analyte supply at the inlet is cut off at t = 1000 s.

Modeling in COMSOL Multiphysics

This model solves the problem with two geometries and five application modes. 
Table 4-1 lists the geometries and their application modes.

The first geometry, named channel, is in 2D and represents the channel. Within this 
geometry the model uses four application modes: Electrostatics, Convection and 
Conduction, Incompressible Navier-Stokes, and Convection and Diffusion. The 
second geometry, named surface, is in 1D and simulates the reaction surface with the 
Diffusion application mode. The overall model couples this solution with the reaction 
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surface boundary condition of the Convection and Diffusion application mode on the 
first geometry. For this purpose you must define two extrusion-coupling variables.

You solve the model in three steps with different solvers in a progression using results 
from the previous step:

• First, solve the Electrostatics application mode with a stationary linear solver.

• Next, solve the Convection and Conduction and the Incompressible Navier-Stokes 
application modes together using a stationary nonlinear solver, because they form a 
coupled system through their subdomain settings.

• In the third step you use the time-dependent solver to solve the transport of the 
analyte. At this point the software solves two application modes simultaneously: 
Convection and Diffusion, and Diffusion.

COMSOL Multiphysics’ solver scripting capabilities allow you to record these solving 
stages, a feature which greatly facilitates repeated simulations.
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TABLE 4-1:  GEOMETRY AND APPLICATION MODE DESCRIPTION

GEOMETRY APPLICATION 
MODE

VARIABLES DESCRIPTION

channel Electrostatics V Solves the static electric potential in 
the channel

channel Convection and 
Conduction

T Solves the temperature distribution 
in the channel

channel Incompressible 
Navier-Stokes

u, v, p Solves the velocities in the x and y 
directions and the pressure 
distribution in the channel

channel Convection and 
Diffusion

c Solves the concentration of the 
analyte in the channel

surface Diffusion B Solves the concentration of the 
binded antibodies on the reaction 
surface
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Model Library path:  

MEMS_Module/Microfluidics_Models/ac_electrokinetic_2d

Modeling Using the Graphical User Interface

M O D E L  L I B R A R Y

1 In the Model Navigator, click the New tab, then click the Multiphysics button.

2 Click the Add Geometry button.

3 Enter these settings in the dialog box:

4 Click OK.

5 Click the Add Geometry button once again and enter these settings:

Because the available unit systems give the wrong reference dimension for the 1D 
geometry, use the last setting to disable units for this geometry.

6 Click OK.

7 In the Multiphysics area, select the geometry channel (2D).

8 In the list of application modes, select MEMS Module>Electrostatics>Electrostatics, 
then click the Add button in the Multiphysics area.

9 Select the application mode COMSOL Multiphysics>Heat Transfer>Convection and 

Conduction, then click the Add button.

10 Select MEMS Module>Microfluidics>Incompressible Navier-Stokes, then click Add.

FIELD VALUE

Geometry name channel

Space dimension 2D

Independent variables x y z

FIELD VALUE

Geometry name surface

Space dimension 1D

Independent variables x y z

Unit system None
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11 Select MEMS Module>Microfluidics>Convection and Diffusion>Transient analysis, then 
click Add.

12 In the Multiphysics area, select the geometry surface (1D).

13 Select COMSOL Multiphysics>Convection and Diffusion>Diffusion>Transient analysis. In 
the Dependent variables edit field type B, then click Add.

14 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, choose Constants.

2 Define the following names, expressions, and (optionally) descriptions; when 
finished, click OK.

Later, you change the value of   the electric potential to 10 V and re-solve the model.

G E O M E T R Y  M O D E L I N G

First create the 2D geometry for the channel.

NAME EXPRESSION DESCRIPTION

epsilon0 8.854188e-12[F/m] Permittivity of free space

epsilonr_f 80.2 Relative permittivity, fluid

epsilon_f epsilonr_f*epsilon0 Permittivity, fluid

k_f 0.598[W/(m*K)] Thermal conductivity, fluid

rho_f 1000[kg/m^3] Density, fluid

Cp_f 4.184[kJ/(kg*K)] Heat capacity, fluid

eta_f 1.08e-3[Pa*s] Dynamic viscosity, fluid

sigma_f 5.75e-2[S/m] Electric conductivity, fluid

tau epsilon_f/sigma_f Charge relaxation time, fluid

D_a 1e-11[m^2/s] Diffusion coefficient, analyte

omega 2*pi[rad]*15[kHz] Angular frequency, AC electric field

V_rms 0[V] Electric potential, RMS value

T_amb 0[degC] Ambient temperature

u_av 0.1[mm/s] Average flow velocity at the inlet

c0 1[umol/m^3] Analyte concentration at the inlet

k_on 1e5[m^3/(mol*s)] Association rate constant

k_off 0.02[1/s] Dissociation constant

R_t 1.67e-8[mol/m^2] Total surface concentration, antibody 
ligand
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1 Click the channel tab in the drawing area.

2 From the Options menu, choose Axes/Grid Settings.

3 In the dialog box, click the Axis tab, select the Axes equal check box, and enter these 
settings:

4 Click the Grid tab.

5 Clear the Auto check box and make these settings:

6 Click OK.

7 Click the Rectangle/Square button on the Draw toolbar and draw a rectangle with 
diagonally opposite corners at (0, 0) and (2.5·10−4, 4·10−5).

8 Draw the following points by successively using the Point tool in the Draw toolbar.

SETTING VALUE

x min -5e-5

x max 30e-5

y min -5e-5

y max 10e-5

SETTING VALUE

x spacing 1e-5

y spacing 1e-5

NAME  x  y  

PT1 0.5e-4 0

PT2 1.1e-4 0

PT3 1.3e-4 0

PT4 1.9e-4 0

PT5 0.9e-4 0.4e-4

PT6 1.1e-4 0.4e-4
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The completed 2D geometry should look like that in the following picture:

The completed 2D geometry for a microchannel detector.

Next create the 1D geometry for the reaction surface.

1 Click the surface tab.

2 From the Options menu, choose Axes/Grid Settings.

3 In the dialog box, click the Axis tab, then enter these settings:

4 Click the Grid tab. Clear the Auto check box. In the x spacing edit field type 1e-5, 
then click OK.

5 On the Draw toolbar select the Line tool and draw a line from 0.9·10−4 to 1.1·10−4.

The geometry is now complete. 

SETTING VALUE

x min -5e-5

x max 30e-5
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P H Y S I C S  S E T T I N G S

Expressions and Coupling Variables
Follow these steps to create the expressions for computing the electrothermal force, to 
define the expressions and coupling variables needed to solve the binding reaction, and 
provide the integration-coupling variables needed for postprocessing.

Note: You create expressions separately for the two geometries.

Start by defining scalar expressions for the electrothermal force components.

1 Click the channel tab to select that geometry.

2 From the Options menu, choose Expressions>Scalar Expressions.

3 In the dialog box, enter the expressions in the following table for the x- and y- 
components of the electrothermal force. Note that this example uses the expressions 
tmp1 and tmp2 only to simplify the writing of Fx_et and Fy_et.

4 Click OK.

Next set the expressions and extrusion-coupling variables you need to solve the surface 
reaction.

1 From the Options menu, choose Expressions>Boundary Expressions.

2 In the Boundary selection list, select Boundary 5.

3 Create the following boundary expression (c_surf is an extrusion coupling variable 
that you define later):

COMSOL Multiphysics marks the unit of react_bulk as inconsistent because of 
the coupling variable. You can disregard this warning.

4 Click OK. 

NAME EXPRESSION

tmp1 (Tx*Ex_emes+Ty*Ey_emes)/(1+(omega*tau)^2)

tmp2 normE_emes^2

Fx_et -0.5*epsilon_f*(0.016[1/K]*tmp1*Ex_emes-0.5*0.004[1/K]*tmp2*Tx)

Fy_et -0.5*epsilon_f*(0.016[1/K]*tmp1*Ey_emes-0.5*0.004[1/K]*tmp2*Ty)

NAME EXPRESSION

react_bulk k_off*c_surf-k_on*c*(R_t-c_surf)
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5 Click the surface tab to select that geometry.

6 From the Options menu, choose Expressions>Subdomain Expressions.

7 In the Subdomain selection list, select Subdomain 1. 

8 Define the following subdomain expression (the term c_bulk is an 
extrusion-coupling variable that you define next); when done, click OK.

9 Click the channel tab to select that geometry.

10 From the Options menu, choose Extrusion Coupling Variables>Boundary Variables.

11 Select Boundary 5. In the first row of the Name column type c_bulk, then type c in 
the corresponding Expression column.

12 Click the General transformation option button.

Configuring the source of the extrusion coupling variable for the channel geometry.

13 Click the Destination tab.

14 From the Geometry list select surface, and from the Level list select Subdomain.

NAME EXPRESSION

react_surf k_on*c_bulk*(R_t-B)-k_off*B
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15 In the Subdomain selection list, click the check box to select Subdomain 1. Make sure 
the Use selected subdomains as destination check box is selected.

Configuring the destination of the extrusion coupling variable for the channel geometry.

16 Click OK.

17 Verify that you still have the surface tab selected; if it is not selected, click it.

18 From the Options menu, choose Extrusion Coupling Variables>Subdomain Variables.

19 From the Subdomain selection list select 1, go to the first row in the Name column 
and enter c_surf, then type B in the corresponding Expression column.

20 Click the General transformation option button.

Configuring the source of the extrusion coupling variable for the surface geometry.

21 Click the Destination tab.
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22 From the Geometry list select channel, and from the Level list select Boundary.

23 In the Boundary selection list, click the check box to select Boundary 5. Make sure 
the Use selected boundaries as destination check box is selected.

Configuring the destination of the extrusion coupling variable for the surface geometry.

24 Click OK.

Finally set the integration-coupling variables needed for postprocessing. They 
represent the total amount of bonded molecules on the reaction surface and its length, 
respectively. Their ratio thus gives the average concentration of bonded molecules at 
the surface.

1 Select the surface geometry.

2 From the Options menu, select Integration Coupling Variables>Subdomain Variables.

3 Select Subdomain 1 and enter these settings:

4 Click OK.

Subdomain Settings
1 From the Multiphysics menu, select 1 channel: Electrostatics (emes).

2 From the Physics menu, select Subdomain Settings.

3 Select Subdomain 1.

NAME EXPRESSION INTEGRATION 
ORDER

GLOBAL 
DESTINATION

B_total B 4 Selected

x_length 1 4 Selected
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4 Under the options for the Constitutive relation click the option button 
corresponding to D = ε0εrE.

5 In the Relative permittivity edit field type epsilonr_f, then click OK.

6 From the Multiphysics menu, select 2 channel: Convection and Conduction (cc).

7 From the Physics menu, select Subdomain Settings.

8 Select Subdomain 1, then enter settings as in this table; when finished, click OK.

9 From the Multiphysics menu, select 3 channel: Incompressible Navier-Stokes (mmglf).

10 From the Physics menu, select Subdomain Settings.

11 In the dialog box select Subdomain 1, then enter these settings:

12 Click the Init tab. In the x-velocity edit field, type u_av. Click OK.

13 From the Multiphysics menu, select 4 channel: Convection and Diffusion (chcd).

14 From the Physics menu, select Subdomain Settings.

15 Select Subdomain 1, then enter settings as in the following table; for the Time-scaling 

coefficient and the Reaction rate, leave the default settings. When finished, click OK.

QUANTITY VALUE/EXPRESSION DESCRIPTION

 k (isotropic) k_f Thermal conductivity

 ρ rho_f Density

 Cp Cp_f Heat capacity at constant 
pressure

 Q sigma_f*normE_emes^2 Heat source

 u u x-velocity

 v v y-velocity

QUANTITY VALUE/EXPRESSION DESCRIPTION

 ρ rho_f Density

 η eta_f Dynamic viscosity

 Fx Fx_et Volume force, x dir.

 Fy Fy_et Volume force, x dir.

QUANTITY VALUE/EXPRESSION DESCRIPTION

 D (isotropic) D_a Diffusion coefficient

 u u x-velocity

 v v y-velocity
A C  E L E C T R O K I N E T I C A L L Y  E N H A N C E D  S U R F A C E  R E A C T I O N S  |  261



262 |  C H A P T E
16 From the Multiphysics menu, choose 5 surface: Diffusion (di).

17 From the Physics menu, select Subdomain Settings.

18 Select Subdomain 1, then enter these settings; when finished, click OK.

Boundary Conditions
1 From the Multiphysics menu, choose 1 channel: Electrostatics (emes).

2 From the Physics menu, select Boundary Settings.

3 Enter boundary settings from the following table; when finished, click OK.

4 From the Multiphysics menu, choose 2 channel: Convection and Conduction (cc).

5 From the Physics menu, select Boundary Settings.

6 Enter boundary settings from the following table; when finished, click OK.

The default boundary condition (thermal insulation) applies to the boundaries not 
listed in the table.

7 From the Multiphysics menu, select 3 channel: Incompressible Navier-Stokes (mmglf).

8 From the Physics menu, select Boundary Settings.

9 Enter boundary settings from the following table; when finished, click OK.

QUANTITY VALUE/EXPRESSION DESCRIPTION

 D 0 Diffusion coefficient

 R react_surf Reaction rate

SETTINGS BOUNDARY 4 BOUNDARY 8 BOUNDARIES 1–3, 
5–7, 9, 10

Boundary 
condition

Electric potential Electric potential Zero charge/
Symmetry

V0 V_rms/2 -V_rms/2

SETTINGS BOUNDARIES 1, 10 BOUNDARIES 4, 8

Boundary condition Heat flux Temperature

q0 -k_f*(T-T_amb)/1[mm]- 
nx*u*rho_f*Cp_f*T

T0 T_amb

SETTINGS BOUNDARY 1 BOUNDARY 10 BOUNDARIES 2–9

Boundary type Inlet Outlet Wall

Boundary condition Laminar inflow Pressure, no 
viscous stress

No slip
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10 From the Multiphysics menu, select 4 channel: Convection and Diffusion (chcd).

11 From the Physics menu, select Boundary Settings.

12 Enter boundary settings from the following table; when finished, click OK.

13 From the Multiphysics menu, select 5 surface: Diffusion (di).

14 From the Physics menu, select Boundary Settings.

15 Verify that the Boundary condition is set to Insulation/Symmetry on both boundaries.

16 Click OK.

M E S H  G E N E R A T I O N

1 Select the channel geometry.

2 From the Mesh menu, select Free Mesh Parameters.

3 Click the Boundary tab.

4 Select Boundaries 4, 5, and 8.

5 In the Maximum element size edit field type 0.2e-6.

6 Click the Remesh button to initialize the mesh for the channel geometry. Click OK.

7 Select the surface geometry.

8 Click the Initialize Mesh button on the Main toolbar to initialize the mesh for the 
surface geometry.

C O M P U T I N G  T H E  S O L U T I O N

You solve the model in three steps using three different solvers.

1 Click the Solver Manager button on the Main toolbar to launch the Solver Manager.

U0 u_av

Lentr 1e-4

Constrain end points to zero Yes

p0 0

SETTINGS BOUNDARY 1 BOUNDARY 5 BOUNDARY 10 BOUNDARIES 2–4, 6–9

Boundary 
condition

Concentration Flux Convective 
flux

Insulation/ 
Symmetry

c0 c0

N0 react_bulk

SETTINGS BOUNDARY 1 BOUNDARY 10 BOUNDARIES 2–9
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2 On the Script page, select the Automatically add commands when solving check box. 
With this setting, COMSOL Multiphysics records the subsequent solver commands 
so that you can reuse them when you later solve the model for Vrms = 10 V.

3 On the Solve For page, select channel (2D)>Electrostatics (emes).

4 Click Solve.

5 Click the Initial Value tab. In the Values of variables not solved for and linearization 

point area, select the Current solution option button.

6 Return to the Solve For page. Select the application modes channel (2D)>Convection 

and Conduction (cc) and channel (2D)>Incompressible Navier-Stokes (mmglf).

7 Click Solve.

8 Click the Solver Parameters button on the Main toolbar to launch the Solver 

Parameters dialog box.

9 From the Solver list, select Time dependent.

10 On the General page, type 0:0.1:5 in the Times edit field in the Time stepping area.

11 Click OK to close the Solver Parameters dialog box.

12 Return to the Solver Manager.

13 On the Solve For page, select the application modes 
channel (2D)>Convection and Diffusion (chcd) and surface (1D)>Diffusion (di).

14 Click OK to close the Solver Manager dialog box.

15 Click Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Begin by visualizing the fluid flow and the analyte concentration in the flow channel 
after 5 s.

1 In the drawing area, select the channel geometry.

2 Click the Plot Parameters button on the Main toolbar.

3 On the General page of the Plot Parameters dialog box, select the check boxes for 
Surface, Arrow, Streamline, and Geometry edges. Make sure the Solution at time list is 
initialized to 5.

4 Click the Surface tab. From the Predefined quantities list, select Convection and 

Diffusion (chcd)>Concentration, c. In the Unit edit field, type umol/m^3.

5 Click the Arrow tab. In the Plot arrows on list select Subdomains. 

6 Click the Subdomain Data tab. From the Predefined quantities list, select 
Incompressible Navier-Stokes (mmglf)>Velocity field.
R  4 :  M I C R O F L U I D I C S  M O D E L S



7 In the Arrow parameters area, find the Arrow length list and select Proportional.

8 Click the Color button. Select black, then click OK to close the Arrow Color dialog 
box.

9 Go to the Streamline page. Click the Streamline Data tab, then in the Predefined 

quantities list select Incompressible Navier-Stokes (mmglf)>Velocity field.

10 From the Streamline plot type list, select Magnitude controlled.

11 Click the Line Color tab. Select the Uniform color option button. Click the Color 
button, then select the orange color corresponding to the RGB values (255, 102, 
0). To do so, click the RGB tab and enter the values directly. Click OK to close the 
Streamline Color dialog box.

12 Return to the General page. From the Plot in list, select New figure.

13 Click OK to generate the plot in Figure 4-2 on page 249.

Next, generate the first graph in Figure 4-5 on page 250 with the following steps:

1 Select the surface geometry.

2 From the Postprocessing menu, select Cross-Section Plot Parameters.

3 On the General page, verify that all solutions in the Solutions to use list are selected. 
From the Plot in list, select New figure.

4 Click the Point tab. In the y-axis data area, type B_total/x_length in the 
Expression edit field. In the Coordinates area, type 1e-4 in the x edit field.

5 Click the Line Settings button. From the Line marker list select Triangle, then click OK 
to close the Line Settings dialog box.

6 Click OK.

Leave the figure windows open to enable comparison with the solutions for the case 
where an electric field has been applied.

Re-Solve the Model with an Applied Electric Field

In this second part of the modeling session, you apply an external electric field.

O P T I O N S  A N D  S E T T I N G S

Choose Options>Constants. Change the Expression for V_rms to 10[V], then click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Manager button on the Main toolbar.
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2 On the Script page, select Solve using a script check box. The following solver script 
appears in the script area (the orders between the entries in the solcomp and 
outcomp lists can vary):

3 Click OK to close the Solver Manager.

4 Click the Solve button on the Main toolbar. The software automatically repeats all 
the solving stages you recorded in the first part of this model to compute the 
solution for Vrms = 10 V.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 In the drawing area, select the channel geometry.

2 Click the Plot Parameters button on the Main toolbar.

3 On the General page, select New figure from the Plot in list. Click Apply.

The plot displayed in Figure 4-3 on page 249—visualizing the fluid flow and the 
analyte concentration in the flow channel after 5 s in the presence of an electric field 
—should now appear in the Figure 3 window. To plot the same quantities at  t = 1 s, 
proceed with the following steps:

4 Still on the General page, from the Solution at time list select 1.

5 From the Plot in list select New figure, then click OK.
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The new figure window now contains a plot resembling that in Figure 4-4. This is the 
plot you see in the Model Navigator if you open the model from the Model Library.

Finally, finish reproducing Figure 4-5, which illustrates the binding rate of the analyte, 
by executing the following instructions:

1 Select the surface geometry.

2 From the Postprocessing menu, select Cross-Section Plot Parameters.

3 On the Point page, click the Line Settings button. From the Line marker list select 
Square, then click OK to close the Line Settings dialog box.

4 Click the General tab.

5 Select the Keep current plot check box.

6 Click the Title/Axis button.

7 Activate the Title edit field, then enter the title Average concentration of 
bonded molecules [mol/m<sup>2</sup>].

The HTML tags produce a superscript figure “2” for the exponent.

8 Click OK to close the Title/Axis Settings dialog box.

9 Click OK to generate the plot.

The two graphs in the Figure 2 window should now look like those in Figure 4-5.

To study an animation of the solution, click the Animate button on the Plot toolbar.

Step-Response Simulation

O P T I O N S  A N D  S E T T I N G S

From the Physics menu, select Constants. Edit the expressions for the four last constants 
according to the following table; when done, click OK.

P H Y S I C S  S E T T I N G S

1 From the Multiphysics menu, select 4 channel: Convection and Diffusion (chcd).

2 From the Physics menu, select Boundary Settings. Select Boundary 1.

NAME EXPRESSION

c0 75[umol/m^3]

k_on 100[m^3/(mol*s)]

k_off 5e-3[1/s]

R_t 1.67e-11[mol/m^2]
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3 Change the entry in the c0 edit field to c0*(t<1000[s]), then click OK.

The logical expression implements the step function in Equation 4-3.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 Change the entry in the Times edit field to 0:25:950 975:1025 1050:50:2000.

3 Set the Relative tolerance to 1e-4 and the Absolute tolerance to 1e-3.

4 Click the Time Stepping tab.

5 From the Time steps taken by solver list, select Intermediate.

6 Click OK to close the Solver Parameters dialog box.

7 Click the Solver Manager button on the Main toolbar.

8 On the Script page, click the Add Current Solver Settings button.

A femtime command with the current solver settings appears in the script area.

9 Because this command should replace the previous one, cut out the complete upper 
femtime command together with the asseminit command line immediately 
before it as well as the fem0=xfem; line immediately after it. When you are done, 
the contents of the script area should be as in the following figure (again, the entries 
in the solcomp and outcomp lists can be ordered differently).
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10 Click OK to close the Solver Manager.

11 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To reproduce the plot in Figure 4-6, follow these steps:

1 Select the surface geometry.

2 From the Postprocessing menu, select Cross-Section Plot Parameters.

3 On the General page, select New figure from the Plot in list.

4 On the Point page, click the Line Settings button. From the Line marker list select 
None, then click OK to close the Line Settings dialog box.

5 Click OK to close the Cross-Section Plot Parameters dialog box and generate the plot.
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T r a n s po r t  i n  an E l e c t r o k i n e t i c  V a l v e

Introduction

This model presents an example of pressure-driven flow and electrophoresis in a 
microchannel system.

Researchers often use a device similar to the one in this model as an electrokinetic 
sample injector in biochips to obtain well-defined sample volumes of dissociated acids 
and salts and to transport these volumes. The model presents a study of a pinched 
injection cross valve during the focusing, injection, and separation stages. Inspiration 
for the model comes from a study by Ermakov and others (Ref. 1). Focusing is 
obtained through pressure-driven flow of the sample and buffer solution, which 
confines the sample in the focusing channel. When the system reaches steady state, the 
pressure-driven flow is turned off and an electric field is applied along the channels. 
This field drives the dissociated sample ions in the focusing zone at right angles to the 
focusing channel and through the injection channel. A clean separation of the sample 
ions is important, so the model examines the effect on ion separation of different 
configurations of the electric field.

This specific case does not account for electroosmosis because the channel surfaces are 
subjected to a treatment that minimizes the extension of the electric double layer.

Model Definition

Figure 4-7 shows a 2D cross section of the geometry in the xz-plane and points out 
the different channels and boundaries. The horizontal channel serves as the focusing 
channel, while the vertical channel is the injection channel. The actual model is in 3D 
with rectangular pipes whose corners are rounded. For geometry dimensions refer to 
Table 4-3 on page 279.
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Figure 4-7: The focusing stage involves pressure-driven flow of both the sample and the 
buffering solution. The device applies an electric field over the focusing channel.

The device operation and hence the modeling procedure takes place in two stages: 
focusing and injection.

In the focusing stage, the device injects a buffering solution through pressure-driven 
convection into the vertical channels from the top and bottom. At the same time, it 
forces the sample solution through the horizontal focusing channel (see Figure 4-7). 
The buffering solution neutralizes the acids contained in the sample except for a very 
thin region confined to the crossing between the horizontal and vertical channels. This 
means that the dissociated ions are only in a needle-shaped region in the focusing zone.

Next, in the injection stage the device turns off the convective flow and then applies a 
vertical field to migrate the sample from the focusing channel to the injection point at 
the lower end of the vertical channel. The sample ions are negatively charged and 
migrate in opposite direction to the electric field. This model studies two different 
configurations (See Table 4-2) for the applied electric field. In the first configuration 
(Injection stage, Mode A) electric field is only applied in the vertical direction. In the 
second configuration (Injection stage, Mode B) the electric field is applied in both the 

Focusing zone

Injection channel

Focusing channel

OutletSample
inlet

Buffer inlet

Buffer inlet
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horizontal and vertical directions (Figure 4-8).The horizontal field focuses the sample 
during the initial part of the injection stage in order to obtain a well-separated sample. 

Figure 4-8: During the injection stage, the device turns off convective flow and applies an 
electric field. The horizontal field avoids the broadening of the sample, while the vertical 
field injects the sample into the vertical channel in the direction opposite to the electric 
field.

The model assumes that the charged sample concentration is very low compared to 
other ions dissolved in the solution. This implies that the sample concentration does 
not influence the solution’s conductivity and that you can neglect the concentration 
gradients of the charge-carrying species, which are present in a much higher 
concentration than the sample ions. Such an electrolyte is known as a supporting 
electrolyte.

TABLE 4-2:  APPLIED ELECTRIC FIELD CONFIGURATION

INLET MODE A MODE B

Sample inlet Electric insulation Electric potential, V = -1V

Outlet Electric insulation Electric potential, V = 0V

Upper buffer inlet Electric potential, V = -3.2V Electric potential, V = -3.2V

Lower buffer inlet Electric potential, V = 0V Electric potential, V = 0V

Migration of the sample

Electric field
vectors

opposite to the field
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Several equations describe the model: the Stokes flow equations, the equation for 
current balance, and a mass balance using the Nernst-Planck equation. This model uses 
the steady-state solution for the focusing stage as the initial condition for the injection 
stages.

Now consider the formulation of the model equations.

T H E  F O C U S I N G  S T A G E

The Stokes flow equations give the global mass a momentum balance in the focusing 
stage:

In these equations, η denotes the dynamic viscosity (kg/(m·s)), u is the velocity (m/
s), p is the pressure (Pa).

The total balance of charges for a supporting electrolyte comes from the divergence of 
the current-density vector, which in a supporting electrolyte is given by Ohm’s law:

Here κ is the electrolyte’s conductivity (S/m) and V is the potential (V). The balance 
of current at steady state then becomes

which gives

The flux vector for the sample ions comes from the Nernst-Planck equation

which leads to the following mass balance equation at steady state for species i:

Here ci is the concentration (mol/m3), Di represents the diffusivity (m2/s), zi equals 
the charge number (which equals 1 for this model), umi is the mobility (s·mol/kg), 
and F is Faraday’s constant (C/mol).

∇– η ∇u ∇u( )T
+( )⋅ ∇p+ 0=

∇ u⋅ 0.=

i κ V∇–=

∇ i⋅ 0=

∇ κ V∇–( )⋅ 0=

Ni Di∇ci– ziumiFci V∇– ciu+=

∇ Di∇ci– ziumiFci V∇– ciu+( )⋅ 0=
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For the pressure-driven flow, assume that the flow has fully developed laminar form in 
all inlets, that all sides have no-slip conditions, and that the fluid flows freely out from 
the end of the focusing channel.

The boundary conditions for the charge balance determine the potential at the 
respective inlet and outlet boundary

where  i denotes the index for each boundary. This model also assumes that all wall 
boundaries are insulating:

The boundary conditions for the mass balance of the sample during the focusing stage 
appear below. The equation

gives the concentration at the inlet of the sample, while the equation

gives the concentration of the buffer at the inlet of the two vertical channels, and the 
buffer inlets are at both boundaries in the vertical channel. At the outlet boundary, 
convection and migration are the dominating transport mechanisms (that is, diffusion 
is negligible), so that 

T H E  I N J E C T I O N  S T A G E

In the injection and separation stages, the device turns the flow off and changes the 
configuration of the electric field. You again solve the charge-balance equations but 
with new boundary conditions:

The mass balance for the dilute species comes from a time-dependent mass balance:

The model assumes that the convective contribution is zero.

V V0 i,=

V∇ n⋅ 0=

c cin=

c cbuffer=

Ni n⋅ ziumiFci V∇– ciu+( ) n⋅=

∇ κ V∇–( )⋅ 0=

t∂
∂c ∇+ Di∇ci– ziumiFci V∇–( )⋅ 0=
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The boundary conditions for the current-balance equation imply that the potential is 
locked at all boundaries except for the walls,

Further assume the walls are electrically insulated, which yields

As opposed to the focusing state, the boundary conditions for the mass balance are 
changed. In the injection stage, set the concentration at the inlet boundary:

For all other boundaries, assume that migration is the dominating transport 
mechanism, so that

 (4-4)

The time-dependent solution requires an initial condition for the mass balance, which 
you obtain from the steady-state solution of the focusing stage:

Results and Discussion

This example analyzes the focusing stage and two configurations for the injection 
stages. Recall that the first injection-stage configuration (Mode A) applies the electric 
field only over the injection channel while the inlet and outlet boundaries of the 
focusing channel are insulated; the second injection-stage configuration (Mode B) 
applies the electric field over both channels.

Figure 4-9 shows the steady-state concentration distribution during the focusing stage 
along with the distribution at the beginning of the injection stage. Note that the 
vertical flows from the upper and lower injection channels focus the concentration on 

V V0 i,=

V∇ n⋅ 0=

c cin=

Ni n⋅ ziumiFci V∇–( ) n⋅=

c t 0=( ) cfocus=
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a very narrow region near the crossing area of the channels. Further away from the 
crossing area, however, the concentration spreads again more equally over the channel. 

Figure 4-9: The steady-state concentration distribution during the focusing stage and 
prior to the injection stage.

Figure 4-10 and Figure 4-11 compare the concentration distribution for the two 
configurations at two times, specifically 0.06 s and 0.12 s after the beginning of the 
injection stage. The figures on the left show that for Mode A the concentration 
boundary is practically stationary in the horizontal direction. Consequently, the 
vertical electric field can continuously draw ions from the focusing channel, which 
results in poor separation and a poorly defined sample volume of the substance. For 
Mode B the situation is very different. The horizontal electric field draws the 
concentration boundary to the left, and the channels separate rapidly. Consequently, 
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this scheme draws a well-defined sample volume of the substance into the injection 
channel.

Figure 4-10: The concentration distribution at a time 0.06 s after starting the injection 
stage for the Mode A configuration (left) and Mode B configuration (right).

Figure 4-11: The concentration distribution at a time 0.12 s after starting the injection 
stage for the Mode A configuration (left) and Mode B configuration (right).

It is also possible to observe the difference between the two configurations if you look 
at the concentration along a line through the middle of the injection channel, 
examining it at several times after the start of the injection stage (Figure 4-12). The 
maximum concentration moves down the injection channel with time. The peaks are 
higher in the upper axis corresponding to Mode A, but they are much wider than for 
Mode B. A considerable amount of concentration appears at the left of the peak, and 
the sample remains attached to the focusing area—resulting in an unwanted distortion 
of the sample package. The narrow peaks of Mode B, on the other hand, form nice bell 
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curves throughout the downward transport in the injection channel, resulting in a 
well-defined sample package.

Figure 4-12: Concentration profile for Mode A (top) and Mode B (bottom) along the 
injection channel at various time steps: 0 s, 0.06 s, 0.12 s, 0.18 s, 0.24 s, 0.30 s, 0.36 s, 
0.42 s, 0.48 s, 0.54 s, and 0.6 s after initialization of the injection stage. The origin of the 
x-axis marks the centerline of the focusing channel.
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This study illustrates that modeling is extremely valuable in the investigation of 
electrophoretic transport. You can vary the configuration of the potential to obtain 
even better focusing and injection stages for the valve under study.

Modeling in COMSOL Multiphysics

A P P L I C A T I O N  M O D E S

In COMSOL Multiphysics you define the model with three application modes:

• The Stokes Flow application mode solves the fluid flow in the channels with Stokes 
equations.

• The Conductive Media DC application mode solves the equation for current 
balance.

• The Electrokinetic Flow application mode solves the Nernst-Planck equation.

G E O M E T R Y  M O D E L I N G

Table 4-3 gives the dimensions of the model geometry. To draw it, proceed in four 
steps:

1 Initialize the geometry with simple blocks that represent the crossing of the 
channels.

2 Create a 2D work plane geometry in which you draw the cross section of the 
channel and a few assisting objects.

3 To finalize to channel crossing, apply the revolve operator to the 2D objects and 
subtract the resulting 3D objects from the original 3D blocks.

4 Finally apply the extrude operator to the 2D channel cross section to create the 
channels.

TABLE 4-3:  MODEL DIMENSIONS

HORIZONTAL CHANNEL VERTICAL CHANNEL CROSSING AREA

Dimensions (µm)

- x 340 20 28

- y 20 20 20

- z 20 340 28

Position (µm)

- x -100 0 -4

- y 0 0 0
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C O M P U T I N G  T H E  S O L U T I O N

The operation of the actual device proceeds in two stages, the focusing stage and the 
injection stage. This model simulates two settings of the injection stage so in total it 
works in three phases.

The first phase defines the subdomain settings and boundary conditions for the 
focusing phase. Then the model solves the application modes sequentially with a 
nonlinear solver in the following sequence:

1 Stokes Flow application mode

2 Conductive Media DC application mode

3 Electrokinetic Flow application mode 

Each step uses the solution from the previous one. The model stores the last solution 
for use as the initial value for the consequent modeling.

In the second phase you change the subdomain settings and boundary conditions to 
handle the injection stage Mode A. In a real device you would turn off the convective 
flow; in the model you simulate this by setting the velocity parameters of the 
Electrokinetic Flow application mode to zero. Thus it uses no information from the 
Stokes Flow application mode.

Solving the second phase starts from the stored solution of the first phase, and the 
model solves the Conductive Media DC application mode with a nonlinear solver. 
Then you select a time-dependent solver and solve the Electrokinetic Flow application 
mode. This solution is the result for the injection stage Mode A.

In the third phase you again change subdomain settings and boundary conditions but 
this time for the injection stage Mode B; you then solve for the final solution the same 
way as in the second phase.

- z 0 -200 -4

Rounding (µm)

- radius 4 4 4

- direction in in out

TABLE 4-3:  MODEL DIMENSIONS

HORIZONTAL CHANNEL VERTICAL CHANNEL CROSSING AREA
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Reference

1. S.V. Ermakov, S.C. Jacobson, and J.M. Ramsey, Technical Proc 1999 Int’l Conf. 
on Modeling and Simulation of Microsystems, Computational Publications, 1999.

Model Library path:  

MEMS_Module/Microfluidics_Models/electrokinetic_valve_3d

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator, select the New page, and from the Space dimension list 
select 3D.

2 Click the Multiphysics button.

3 In the Application Modes tree, select MEMS Module>Microfluidics>Stokes Flow. Click 
Add.

4 In the Application Modes tree, select MEMS Module>Electrostatics>Conductive Media 

DC. Click Add.

5 In the Application Modes tree, select MEMS Module>Microfluidics>Electrokinetic 

Flow>Transient analysis. Click Add.

6 Click OK.

O P T I O N S  A N D  S E T T I N G S

Next define some constants for the model.

1 From the Options menu, choose Constants.

2 In the dialog box that opens, specify names, expressions, and (optionally) 
descriptions for the following constants; when done, click OK.

NAME EXPRESSION DESCRIPTION

u_a 0.2[mm/s] Average velocity, sample inlet

w_a 0.67[mm/s] Average velocity, buffer inlets

rho 1e3[kg/m^3] Fluid density

eta 1e-3[Pa*s] Fluid viscosity

D 1e-9[m^2/s] Sample ion diffusivity
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G E O M E T R Y  M O D E L I N G

3D Geometry—Step 1
Start the geometry by creating a simple set of rectangular blocks. 

1 Click the Block tool on the 3D Draw toolbar and create two rectangular blocks using 
the settings from the following table; keep all other settings at their default values.

2 Click the Zoom Extents button on the Main toolbar.

Work Plane Geometry
Next create a 2D geometry on a work plane. After you extrude and revolve the objects, 
they shape the 3D geometry. 

1 From the Draw menu, choose Work Plane Settings.

2 On the Quick page, click the y-z option button. Type -4e-6 in the associated x edit 
field. Click OK.

3 Click the Geom2 tab to activate the 2D work plane geometry.

4 Shift-click the Rectangle/Square button on the Draw toolbar. 

5 Create a rectangle as in the following table; when done, click OK.

6 Click the Zoom Extents button on the Main toolbar.

7 Click the Fillet/Chamfer button on the Draw toolbar.

Rg 8.314[J/(mol*K)] Gas constant

T 298[K] Fluid temperature

nu D/(Rg*T) Sample ion mobility

sigma 1[S/m] Electric conductivity, electrolyte

c_in 0.05*3.5[g/l]/ 
(22+35)[g/mol]

Sample ion concentration, inlet

BLOCK AXIS BASE POINT LENGTH

X Y Z X Y Z

BLK1 -4e-6 0 -4e-6 28e-6 20e-6 28e-6

BLK2 -20e-6 0 -20e-6 60e-6 20e-6 60e-6

SIZE POSITION

WIDTH HEIGHT BASE X Y

20e-6 20e-6 Corner 0 0

NAME EXPRESSION DESCRIPTION
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8 In the dialog box go to the Vertex selection area, open the menu tree under R1, then 
select the four corners. Click the Fillet option button, and in the Radius edit field 
type 4e-6. Click OK.

9 Shift-click the Rectangle/Square button on the Draw toolbar. Create a rectangle as in 
the following table; when done, click OK.

10 Click the Create Composite Object button on the Draw toolbar.

11 Verify that the Keep interior boundaries check box is selected.

12 In the Set formula edit field, type CO1+R1. Click OK.

13 Click the Split Object button on the Draw toolbar.

Zoom-in view of the completed 2D geometry.

3D Geometry—Step 2
After creating the work plane geometry, keep Geom2 activated and use it to shape the 
3D geometry.

1 From the Draw menu, choose Revolve.

OBJECT SIZE POSITION 

WIDTH HEIGHT BASE X Y

R1 20e-6 28e-6 Corner 0 -4e-6
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2 In the resulting dialog box, enter settings as in the following figure.

Settings for the Revolve operation.

3 Click OK. The revolved object automatically becomes activated in Geom1.

4 Click the Array button on the Draw toolbar.

5 In the dialog box that appears, specify the following settings, then click OK.

6 Click the Create Composite Object button on the Draw toolbar.

7 In the Set formula edit field, type BLK2-REV1-REV2-REV3-REV4. Click Apply.

8 In the Set formula edit field, type BLK1*CO1. Click OK.

9 Click the Geom2 tab.

10 From the Draw menu, choose Extrude.

11 From the Objects to extrude list, select CO3. In the Distance edit field, type-96e-6. 
Click OK.

12 Click the Geom2 tab.

13 From the Draw menu, choose Work Plane Settings.

14 On the Quick page, click the y-z button, and in the corresponding x edit field type 
24e-6. Click OK.

15 From the Draw menu, choose Extrude.

DISPLACEMENT ARRAY SIZE

X Y Z X Y Z

28e-6 0 -28e-6 2 1 2
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16 In the dialog box that appears, set the Distance to 216e-6. Click OK.

The following figure shows the 3D geometry when you have executed this step.

3D geometry after an extrusion operation on one of the arms.

17 Click the Geom2 tab.

18 From the Draw menu, choose Work Plane Settings.

19 On the Quick page, click the x-y button. In the associated z edit field, type -4e-6. 
Click OK.

20 From the Draw menu choose Extrude. Set the Distance to -196e-6, then click OK.

21 Click the Geom2 tab.

22 From the Draw menu, choose Work Plane Settings.

23 On the Quick page, click the x-y button. In the associated z edit field type 24e-6. 
Click OK.

24 From the Draw menu, choose Extrude. Set the Distance to 96e-6, then click OK.

The completed geometry should look like that in the following figure.
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The completed 3D geometry after extrusion of all four arms. 

P H Y S I C S  S E T T I N G S — T H E  F O C U S I N G  S T A G E

Subdomain Settings
1 From the Multiphysics menu, choose 1 Geom1: Stokes (mmglf).

2 From the Physics menu, choose Subdomain Settings. 

3 In the Subdomain selection list, select all the subdomains. 

4 Enter the settings from the following table. When done, click OK.

5 From the Multiphysics menu, choose 2 Geom1: Conductive Media DC (emdc).

6 From the Physics menu, choose Subdomain Settings. 

7 For all subdomains, set σ to sigma. Click OK.

8 From the Multiphysics menu, choose 3 Geom1: Electrokinetic Flow (chekf).

9 From the Physics menu, choose Subdomain Settings.

PROPERTY VALUE

 ρ rho

 η eta
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10 With all subdomains still selected, enter the settings in the following table; when 
done, click OK.

Boundary Conditions
1 From the Multiphysics menu, choose 1 Geom1:Stokes (mmglf).

2 From the Physics menu, choose Boundary Settings.

3 Specify the following boundary conditions (for boundaries not listed in the table, 
the default No slip condition applies); when done, click OK.

4 From the Multiphysics menu, choose 2 Geom1: Conductive Media DC (emdc).

5 From the Physics menu, choose Boundary Settings.

6 Click in the Boundary selection list and press Ctrl+A to select all boundaries. From 
the Boundary condition list, select Electric insulation.

PROPERTY VALUE

D (isotropic) D

R 0

um nu

z -1

u u

v v

w w

V V

SETTINGS BOUNDARY 1 BOUNDARIES 21, 26 BOUNDARY 54

Boundary type Inlet Inlet Outlet

Boundary condition Laminar inflow Laminar inflow Pressure, no 
viscous stress

U0 u_a w_a

Lentr 1e-4 1e-4

Constrain outer edges 
to zero

Yes Yes

p0 0
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7 Edit the boundary conditions according to the following table; when done, click OK.

8 From the Multiphysics menu, choose 3 Geom1: Electrokinetic Flow (chekf).

9 From the Physics menu, choose Boundary Settings.

10 Specify boundary settings as in the following table (for boundaries not listed, the 
default Insulation/Symmetry condition applies); when done, click OK.

M E S H  G E N E R A T I O N

1 Click Geom1 to activate the 3D geometry.

2 Click the Initialize Mesh button on the Main toolbar.

C O M P U T I N G  T H E  S O L U T I O N — T H E  F O C U S I N G  S T A G E

First, compute the solution for the velocity field, and then use that solution when 
solving the mass-transport problem.

1 Click the Solver Manager button on the Main toolbar.

2 Click the Solve For tab.

3 From the Solve for variables tree, select Geom1 (3D)>Stokes (mmglf).

4 Click the Solve button.

5 When the solver has finished, click the Initial Value tab.

6 Click the Current solution option button in the Initial value area, then return to the 
Solve For page.

7 From the Solve for variables tree, select Geom1 (3D)>Conductive Media DC (emdc).

8 Click Solve 

9 From the Solve for variables tree, select Geom1 (3D)>Electrokinetic Flow (chekf).

10 Click Solve.

11 On the Initial Value page, click the Store Solution button.

12 Click OK to close the Solver Manager.

SETTINGS BOUNDARY 1 BOUNDARY 54

Boundary condition Electric potential Ground

V0 -1 -

SETTINGS BOUNDARY 1 BOUNDARIES 21, 26 BOUNDARY 54

Boundary condition Concentration Concentration Convective flux

c0 c_in 0 -
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P H Y S I C S  S E T T I N G S — I N J E C T I O N  S T A G E ,  M O D E  A

Subdomain Settings
1 From the Multiphysics menu, choose 3 Geom1: Electrokinetic Flow (chekf).

2 From the Physics menu, choose Subdomain Settings.

3 In the Subdomain selection list, select all the subdomains, then change the settings 
for velocity parameters as in the following table; when done, click OK.

Boundary Conditions
1 From the Physics menu, choose Boundary Settings.

2 Select Boundaries 1, 21, 26, and 54 (the inlets and outlets).

3 From the Boundary condition list, select Flux.

4 In the N0 edit field, type -nmflux_c_chekf.

The predefined boundary variable nmflux_c_chekf gives the outward normal 
electrophoretic flux, Ni · n.

5 Click OK.

6 From the Multiphysics menu, choose 2 Geom1: Conductive Media DC (emdc).

7 From the Physics menu, choose Boundary Settings.

8 Change the boundary settings as in the following table; when done, click OK.

C O M P U T I N G  T H E  S O L U T I O N — I N J E C T I O N  S T A G E ,  M O D E  A

1 Click the Solver Manager button on the Main toolbar.

2 Click the Script tab. Select the Automatically add commands when solving check box.

This setting instructs the software to record the subsequent solver settings and 
commands, which you can then reuse when solving Mode B.

PROPERTY VALUE

u 0

v 0

w 0

SETTINGS BOUNDARIES 1, 54 BOUNDARY 21 BOUNDARY 26

Boundary condition Electric insulation Electric potential Electric potential

V0 - 0 -3.2
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3 Click the Initial Value tab. In the Initial value area, click the Stored solution option 
button. This makes the steady-state solution from the focusing stage the initial 
solution.

4 Click the Solve For tab.

5 In the Solve for variables tree, select Geom1 (3D)>Conductive Media DC (emdc).

6 Click Solve.

7 Click the Solver Parameters button on the Main toolbar.

8 From the Analysis list, select Transient.

9 In the Time stepping area go to the Times edit field and enter 0:0.03:0.6.

10 Click OK.

11 Activate the Solver Manager window.

12 Click the Initial Value tab.

13 In the Initial value area, click the Current solution option button.

14 Click the Solve For tab.

15 In the Solve for variables tree, select Geom1 (3D)>Electrokinetic Flow (chekf).

16 Click Solve.

17 Click OK.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N — I N J E C T I O N  S T A G E ,  M O D E  A

Reproduce the plot in Figure 4-9 on page 276 with the following steps:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, select the Subdomain and Geometry edges check boxes in the 
Plot type area and clear all the others.

3 From the Solution at time list, select 0.

4 Click the Subdomain tab. From the Predefined quantities list on the Color Data page, 
select Electrokinetic Flow (chekf)>Concentration, c. Click Apply.

5 Click the Go to Default 3D View button on the Camera toolbar, then click the Zoom 

Extents button on the Main toolbar.

To visualize the solution at two later times, as in the left panels of Figure 4-10 and 
Figure 4-11 on page 277, do as follows:

6 Return to the Subdomain page of the Plot Parameters dialog box.

7 Clear the Color scale check box in the Element color area.
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8 Click the General tab. From the Solution at time list, select 0.06. Click Apply to 
generate the plot in the left panel.

9 From the Solution at time list, select 0.12. Click OK to generate the plot in the left 
panel.

To make an animation of the solution, click the Animate button on the Plot toolbar. 
On the Animate page of the Plot Parameters dialog box, you can customize the 
movie settings.

Generate the upper plot of Figure 4-12, by executing the following instructions:

1 From the Postprocessing menu, choose Cross-Section Plot Parameters.

2 On the General page, select Interpolated times from the Select via list.

3 In the Times edit field, type 0:0.06:0.6.

4 Click the Line/Extrusion tab.

5 In the Predefined quantities list, select Electrokinetic Flow (chekf)>Concentration, c.

6 In the x-axis data area, click the option button next to the Expression button and 
then click Expression.

7 In the Expression edit field, type 10[um]-z. Click OK.

8 In the Cross-section line data area, enter the settings listed in the following table; 
when done, click OK.

P H Y S I C S  S E T T I N G S — I N J E C T I O N  S T A G E ,  M O D E  B

Boundary Conditions
1 From the Physics menu, choose Boundary Settings.

2 Change the boundary settings for the Conductive Media DC application mode to 
those in the following table:

CROSS-SECTION LINE DATA

x0 1e-5 x1 1e-5

y0 1e-5 y1 1e-5

z0 2e-5 z1 -2e-4

Line resolution 200

SETTINGS BOUNDARY 1 BOUNDARIES 21, 54 BOUNDARY 26

Boundary condition Electric potential Electric potential Electric potential

V0 -1 0 -3.2
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3 Click OK.

C O M P U T I N G  T H E  S O L U T I O N — I N J E C T I O N  S T A G E ,  M O D E  B

1 Click the Solver Manager button on the Main toolbar.

2 On the Script page, select the Solve using a script check box.

3 Click Solve to execute the script you see in the edit window.

4 Click OK to close the Solver Manager.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N — I N J E C T I O N  S T A G E ,  M O D E  B

Generate the plots in the right panels of Figure 4-10 and Figure 4-11 on page 277 as 
follows:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, select 0.06 from the Solution at time list. Click Apply.

This generates the right plot in Figure 4-10.

3 Repeat Step 2 but select 0.12 from the Solution at time list to generate the right plot 
in Figure 4-11.

4 From the Solution at time list, select 0.
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5 Click OK to close the dialog box and generate the plot you see when you open the 
model from the Model Library.

Finally, generate the lower plot in Figure 4-12 with the following steps:

1 From the Postprocessing menu, select Cross-Section Plot Parameters.

2 Accept the settings from Mode A by clicking OK.
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ALE F l u i d - S t r u c t u r e  I n t e r a c t i o n

Introduction

The following example demonstrates techniques for modeling fluid-structure 
interactions in COMSOL Multiphysics. It illustrates how fluid flow can deform 
surrounding structures and how to solve for the flow in a continuously deforming 
geometry using the arbitrary Lagrangian-Eulerian (ALE) technique.

The model geometry consists of a horizontal flow channel in the middle of which is an 
obstacle, a narrow vertical structure (Figure 4-13). The fluid flows from left to right, 
except the obstacle forces it into a narrower path in the upper part of the channel, and 
it imposes a force on the structure’s walls resulting from the viscous drag and fluid 
pressure. The structure, being made of a deformable material, bends under the applied 
load. Consequently, the fluid flow also follows a new path, so solving the flow in the 
original geometry would generate incorrect results.

The ALE method handles the dynamics of the deforming geometry and the moving 
boundaries with a moving grid. COMSOL Multiphysics computes new mesh 
coordinates on the channel area based on the movement of the structure’s boundaries 
and on so called mesh smoothing. The Navier-Stokes equations that solve the flow are 
formulated for these moving coordinates.

The structural mechanics portion of the model does not require the ALE method, and 
COMSOL Multiphysics solves it in a fixed coordinate system as usual. However, the 
strains the model computes in this way are the only source for computing the 
deformed coordinates with ALE.
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Figure 4-13: Fluid flows into this horizontal flow channel from the left, and it enters with 
a parabolic velocity profile. A narrow vertical structure in the channel (the straight 
vertical structure) forces the flow into a narrower path. Due to fluid pressure and viscous 
drag, the originally vertical structure bends (the vertical structure shifted to the right). 
This simulation models the fluid flow in a deformed, moving mesh that follows the 
movement of the bending structure.

Model Definition

In this example the flow channel is 100 µm high and 300 µm long. The vertical 
structure—5 µm wide, 50 µm high, and with a semicircular top—sits 100 µm away 
from the channel’s left boundary. Assume that the structure is long in the direction 
perpendicular to the image. 

The fluid is a water-like substance with a density ρ = 1000 kg/m3 and dynamic 
viscosity η = 0.001 Pa·s. To demonstrate the desired techniques, assume the structure 
consists of a flexible material with a density ρ = 7850 kg/m3 and Young’s modulus E 
= 200 kPa.

The model consists of a fluid part, solved with the Navier-Stokes equations in the flow 
channel, and a structural mechanics part, which you solve in the obstacle. A Moving 
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Mesh (ALE) application mode makes sure the flow domain is deformed along with the 
obstacle.

Transient effects are taken into account in both the fluid and the structure. The 
structural deformations are modeled using large deformations in the Plane Strain 
application mode. The displacements and displacement velocities are denoted u, v, ut, 
and vt, respectively. Fluid flow is described by the Navier-Stokes equations, where the 
velocity components and pressure are denoted u2, v2, and p2, respectively. 

F L U I D  F L O W

The fluid flow in the channel is described by the Navier-Stokes equations for the 
velocity field, u = (u, v), and the pressure,  p, in the spatial (deformed) moving 
coordinate system:

 (4-5)

In these equations, I denotes the unit diagonal matrix and F is the volume force 
affecting the fluid. Assume that no gravitation or other volume forces affect the fluid, 
so that F = 0. The coordinate system velocity is um = (um, vm). 

At the channel entrance on the left, the flow has fully developed laminar characteristics 
with a parabolic velocity profile but its amplitude changes with time. At first flow 
increases rapidly, reaching its peak value at 0.215 s; thereafter it gradually decreases to 
a steady-state value of 5 cm/s. The centerline velocity in the x direction, uin (see 
Figure 4-16 on page 300), with the steady-state amplitude U comes from the equation

 (4-6)

where  t must be expressed in seconds.

At the outflow (right-hand boundary), the condition is p = 0. On the solid (non 
deforming) walls, no-slip conditions are imposed, u = 0, v = 0, while on the deforming 
interface the velocities equal the deformation rate, u0 = ut and v0 = vt.

S T R U C T U R A L  M E C H A N I C S

The structural deformations are solved for using an elastic formulation and a nonlinear 
geometry formulation to allow large deformations.

ρ
t∂

∂u ∇ p– I η ∇u ∇u( )T
+( )+[ ]⋅– ρ u um )–( ∇⋅( )u+ F=

∇– u⋅ 0=

uin
U t2⋅

0.04 t2
–( )

2
0.1t( )2

+

-----------------------------------------------------------=
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For boundary conditions, the obstacle is fixed to the bottom of the fluid channel. All 
other object boundaries experience a load from the fluid, given by

 (4-7)

where n is the normal vector to the boundary. This load represents a sum of pressure 
and viscous forces.

M OV I N G  M E S H

The motion of the deformed mesh is modeled using Winslow smoothing. For more 
information on this formulation, please refer to “The Moving Mesh Application 
Mode” on page 401 in the COMSOL Multiphysics Modeling Guide. This is the 
default smoothing when using the predefined Fluid-Structure Interaction coupled 
application modes. The boundary conditions control the displacement of the moving 
mesh with respect to the initial geometry. At the boundaries of the obstacle, this 
displacement is the same as the structural deformation. At the exterior boundaries of 
the flow domain, the deformation is set to zero in all directions.

Results and Discussion

Figure 4-14 shows the geometry deformation and flow at t = 4 s when the system is 
close to its steady state. Due to the channel’s small dimensions, the Reynolds number 
of the flow is small (R << 100), and the flow stays laminar in most of the area. The 
swirls are restricted to a small area behind the structure. The amount of deformation 

FT n– p– I η ∇u ∇u( )T
+( )+( )⋅=
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as well as the size and location of the swirls depend on the magnitude of the inflow 
velocity.

Figure 4-14: Flow velocity and geometry deformation at t = 4 s. The streamlines indicate 
the flow direction and the color scale indicates flow-velocity magnitude. Here the geometry 
deformation is scaled by unity.

Figure 4-15 shows the mesh velocity at t = 0.15 s. The boundaries of the narrow 
structure are the only moving boundaries of the flow channel. Therefore the mesh 
velocity also has its largest values near the structure. Depending on the current state of 
the deformation—whether it is increasing, decreasing or stationary—the mesh velocity 
can have a very different distribution. Figure 4-16 further illustrates this point; it 
compares the average inflow velocity to the horizontal mesh velocity and the 
horizontal mesh displacement just beside the top of the structure at the physical point 
(1.05·10−4, 0.5·10−4). Most of the time the deformation follows the inflow velocity 
quite closely. Whenever the inflow velocity starts to decrease, the deformation also 
decreases, which you can observe as the negative values on the horizontal mesh 
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velocity. Toward the end of the simulation, when inflow and structure deformation 
approach their steady-state values, the mesh velocity also decreases to zero.

Figure 4-15: Mesh velocity (arrows) and mesh and geometry deformation at t = 0.15 s. 
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Figure 4-16: Inflow velocity, horizontal mesh velocity, and mesh deformation. The curve 
with triangles shows the average x direction velocity at the inflow boundary (m/s); the 
curve with circles shows 104× mesh displacement in the x direction (dx_ale; m) at the 
geometry point (1.05·10-4, 0.5·10-4); and the curve with squares shows 103× mesh velocity 
in the x direction (xt; m/s), also at the point (1.05·10-4, 0.5·10-4).

Figure 4-17 and Figure 4-18 compare the meshes at different times. The first image 
shows the initial mesh, which you generate prior to solving the model. This mesh is 
equally distributed around the top of the structure. The second image shows the mesh 
in its deformed form. Because the structure deforms more in the horizontal direction, 
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the mesh also changes more in this direction: On the left, the mesh elements are 
stretched; on the right, they are compressed in the x direction.

Figure 4-17: Initial (undeformed) geometry and mesh near the top of the structure.

Figure 4-18: Deformed geometry and deformed mesh near the top of the structure at t = 2 s.
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Modeling in COMSOL Multiphysics

This example implements the model using three application modes, which the 
predefined Fluid-Structure Interaction multiphysics entry sets up automatically. First, 
the Incompressible Navier-Stokes application mode computes the fluid dynamics. It is 
active only in the area of the flow channel.

Second, the Plane Strain application mode solves the model’s structural mechanics 
portion. You activate it only in the area of the narrow structure. To get a more accurate 
computation of the large strains, the large deformation analysis type is the default 
setting. The deformation velocity solved with this application mode acts as the 
boundary condition for the Incompressible Navier-Stokes and the Moving Mesh 
(ALE) application modes.

Third, the Moving Mesh (ALE) application mode solves for the deformed mesh

Model Library path: MEMS_Module/Microfluidics_Models/
fluid_structure_interaction

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 In the Model Navigator, select 2D from the Space dimension list.

2 From the Application Modes list, select MEMS Module>Fluid-Structure Interaction> 
Plane Strain with Fluid Interaction>Transient analysis.

3 Click OK to close the Model Navigator.

G E O M E T R Y  M O D E L I N G

1 Shift-click the Rectangle/Square button on the Draw toolbar.

2 In the Width edit field type 3e-4, and in the Height edit field type 1e-4. Click OK.

3 Click the Zoom Extents button on the Main toolbar.

4 From the Options menu, choose Axes/Grid Settings.

5 On the Grid page, clear the Auto check box, then go to the X spacing and Y spacing 
edit fields and in each one type 2.5e-6. Click OK.
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6 Click the Zoom Window button on the Main toolbar, then left-click and drag the 
mouse approximately from the point (0.9·10−4, −0.1·10−4) to 
(1.2·10−4, 0.7·10−4).

7 Click the 2nd Degree Bézier Curve button on the Draw toolbar, then left-click nine 
points as in the following table; when done, right-click to complete the curve.

8 Click the Zoom Extents button on the Main toolbar.

P H Y S I C S  S E T T I N G S

1 From the Options menu, choose Constants.

2 In the Constants dialog box, define the following constants with names, expressions, 
and (optionally) descriptions; when done, click OK.

3 From the Options menu, choose Scalar Expressions.

4 Define the following expression (the description is optional); when done, click OK.

Subdomain Settings
1 In the Multiphysics menu, make sure Incompressible Navier-Stokes (mmglf) is selected.

POINT X Y

1 1e-4 0

2 1e-4 4.00e-5

3 1e-4 4.75e-5

4 1e-4 5.00e-5

5 1.025e-4 5.00e-5

6 1.05-4 5.00e-5

7 1.05-4 4.75e-5

8 1.05-4 4.00e-5

9 1.05-4 0

NAME EXPRESSION DESCRIPTION

eta 1e-3[Pa*s] Fluid viscosity

rho 1000[kg/m^3] Fluid density

U 3.33[cm/s] Inlet mean velocity at steady state

E 200[kPa] Young’s modulus

NAME EXPRESSION DESCRIPTION

u_in U*t^2/
sqrt(t^4-0.07[s^2]*t^2+0.0016[s^4])

Inlet mean velocity
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2 From Physics menu, select Subdomain Settings.

3 Select Subdomain 1. From the Group list, select Fluid domain, then apply the 
following settings:

4 Select Subdomain 2, then select Solid domain from the Group list. This deactivates 
the incompressible Navier-Stokes equations in Subdomain 2 (the solid).

5 Click OK to close the dialog box.

6 From the Multiphysics menu, select Plane Strain (smpn).

7 From the Physics menu, select Subdomain Settings.

8 Select Subdomain 1, then select Fluid domain from the Group list to deactivate the 
structural mechanics equations in the fluid.

9 Select Subdomain 2, then select Solid domain from the Group list. In the E edit field 
for the Young’s modulus, type E.

10 Click OK to close the dialog box.

11 From the Multiphysics menu, select Moving Mesh (ALE).

12 From the Physics menu, open the Subdomain Settings dialog box.

13 Apply the following settings by selecting from the Group list.

For the fluid domain, this means that the displacements are free. In the solid 
domain, the deformation of the solid determines the mesh displacement.

Boundary Conditions
1 From the Multiphysics menu, select Incompressible Navier-Stokes (mmglf).

2 From the Physics menu, open the Boundary Settings dialog box.

3 Select Boundaries 7–10, then select Structural velocity from the Group list.

PROPERTY VALUE

 ρ rho

 η eta

SETTINGS SUBDOMAIN 1 SUBDOMAIN 2

Group Fluid domain Solid domain
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4 For the remaining active boundaries, apply the following settings:

5 Click OK.

6 From the Multiphysics menu, select Plane Strain (smpn).

7 In the Boundary Settings dialog box, select Boundary 4. Then select Fixed from the 
Constraint condition list.

8 Select Boundaries 7–10, then select Fluid load from the Group list. This sets up the 
edge loads using the Lagrange multipliers and specifies them to be defined as force/
area.

9 Click OK.

10 From the Multiphysics menu, select Moving Mesh (ALE).

11 In the Boundary Settings dialog box, select the following groups from the Group list 
to apply the appropriate mesh displacements:

M E S H  G E N E R A T I O N

1 From the Mesh menu, choose Free Mesh Parameters.

2 On the Global page, select Coarser from the Predefined mesh sizes list.

3 Click the Custom mesh size button, then set the Element growth rate to 1.2.

4 Click Remesh. When the mesher has finished, click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 In the Times edit field type 0:0.005:0.4 0.41:0.01:0.8 0.85:0.05:4.

3 Click OK.

4 Click the Solve button on the Main toolbar.

SETTINGS BOUNDARY 1 BOUNDARY 6 ALL OTHERS

Boundary type Inlet Outlet Wall

Boundary condition Laminar inflow Pressure, no 
viscous stress

No slip

U0 u_in

p0 0

SETTINGS BOUNDARIES 7–10 ALL OTHERS

Group Structural displacement Fixed
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P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To reproduce the plot in Figure 4-14 (this is also the plot that appears in the Model 

Navigator and when you open the prepared model file), follow these steps:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, find the Plot type area. Select the Surface, Boundary, and 

Streamline check boxes; clear all the other check boxes.

3 Click the Surface tab. From the Predefined quantities list on the Surface Data page, 
select Incompressible Navier-Stokes (mmglf)>Velocity field.

4 Click the Boundary tab. Type 1 in the Expression edit field on the Boundary Data page.

5 Click the Uniform color option button, then click the Color button. Set the color to 
black, then click OK to close the Boundary Color dialog box.

6 Click the Streamline tab. From the Predefined quantities list on the Streamline Data 
page, select Incompressible Navier-Stokes (mmglf)>Velocity field.

7 Click the Specify start point coordinates option button. In the X and Y edit fields 
enter these expressions:

8 Click OK to close the Plot Parameters dialog box and generate the plot.

X linspace(0,0,15) linspace(1.2e-4,1.2e-4,3)

Y linspace(0,1e-4,15) linspace(0,0.35e-4,3)
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Introduction

At the macroscopic level, systems usually mix fluids using mechanical actuators or 
turbulent 3D flow. At the microscale level, however, neither of these approaches is 
practical or even possible. This model demonstrates the mixing of fluids using 
laminar-layered flow in a MEMS mixer.

To characterize the fluid flow’s turbulent behavior scientists generally use the Reynolds 
number

where ρ is the fluid density, u is flow velocity, L is a characteristic length, and η is the 
fluid’s dynamic viscosity. Turbulent flow takes place when the Reynolds number is 
high, typically when Re > 2000. At MEMS scales, the width of a channel is in the range 
of 100 µm and the velocity is approximately 1 cm/s. In this case, for water-like 
substances Re is close to unity. The fluid flow is thus clearly laminar, so effective mixing 
of fluids in MEMS devices requires other means.

Figure 4-19 shows a section of a component that uses layered flow to improve mixing. 
The mixer has several lamellae of microchannels, and the two fluids being mixed are 
alternated for every second layer. Pressure forces the fluid to travels in the channels 
from back to front. The fluid enters a larger space, the mixing chamber (visible at the 
front of the image). The figure does not include this chamber, but it covers the area 
beyond where the grid of the microchannel ends. Near the ends of the microchannels 
the mixing chamber has distinct lamellae of the two fluids, but this separation vanishes 
towards the end of the chamber.

Re ρuL
η

-----------=
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Figure 4-19: Geometry of a lamella mixer (mixing chamber not visible).

Model Definition

This model analyzes the steady-state condition of the fluid flow as well as the 
convection and diffusion of a dissolved substance in a lamella mixer. The geometry in 
Figure 4-20 corresponds to Figure 4-19 except it includes only a small vertical section 
of the mixer with a height of 30 µm. The model starts from a plane in the middle of 
the channel bending to the left and ends at a plane in the middle of the channel 
bending to the right.

Each microchannel in the mixer has a quadratic cross section with a side of 20 µm. 
Because of the chosen geometry, microchannel height in the model is only 10 µm. To 
create the curved channel shape, the model uses concentric circles with inner radii of 
240 µm, 270 µm, and 300 µm. Except for the direction of the curvature, the 
geometry and dimensions of the channel layers are the same.
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The fluid exiting the microchannels enters a mixing chamber of length is 200 µm and 
width 80 µm.

Figure 4-20: The model geometry for a lamella mixer takes advantage of symmetry so it is 
not necessary to model the entire height of the device.

You solve the fluid flow in the channels and in the chamber with the incompressible 
Navier-Stokes equations

 (4-8)

where ρ is fluid density, u = (u, v, w) is the flow-velocity field, p is fluid pressure, I is 
the unit diagonal matrix, η is the fluid’s dynamic viscosity, and F = (fx, fy, fy) is a 
volume force affecting the fluid. In this model, the fluid is water with ρ = 1000 kg/
m3, η = 0.001 Pa·s, and F = 0 because there are no volume forces.

The system applies a pressure of 10 Pa on all six microchannel inputs to drive the flow 
through the mixing chamber to where there is zero pressure. At the chamber exit the 
flow velocity has components only in the normal direction of the boundary.

ρ
t∂

∂u ∇ p–( )I η ∇u ∇u( )T
+( )+[ ]⋅– ρu ∇⋅ u+ F=

∇– u⋅ 0=
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On the microchannel and mixing-chamber walls, the no-slip boundary condition 
applies. However, in the vertical direction, due to the geometry, you can use a 
symmetry boundary condition.

The following convection-diffusion equation describes the concentration of the 
dissolved substances in the fluid: 

 (4-9)

where c is the concentration, D is the diffusion coefficient, and R is the reaction rate. 
In this model, D = 10−10 m2/s, and R = 0 because the concentration is not affected 
by any reactions.

There is a concentration of 50 mol/m3 on the input boundaries of the channels 
curving to the left, but the channels curving to the left have zero concentration. At the 
output boundary of the mixing chamber the substance flows through the boundary by 
convection. The walls of the channels and the chamber are insulated for this dissolved 
substance, and on the top and bottom boundaries you use a symmetry boundary 
condition.

Results and Discussion

Figure 4-21 details fluid flow in the mixer. On a PC screen you can see a gradual 
change in the color of the slices, which indicates a laminar parabolic flow. The 
streamlines do not show swirls, and there are only small changes in the flow direction. 
The figure also shows that the maximum velocity of the microchannels is at the 
model’s boundary because it is located in the middle of the channel. In the mixing 
chamber, the change of flow velocity is visible only in horizontal direction because the 
chamber is high and flow at the model boundaries is unchanged.

∂c
∂t
----- ∇ D∇c–( )⋅+ R u ∇c⋅–=
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The peak velocity is roughly 1.4 mm/s in the microchannels and 0.5 mm/s in the 
mixing chamber. Given the corresponding lengths (20 µm and 80 µm), the Reynolds 
numbers are Re = 0.028 and Re = 0.04, so the flow is clearly laminar.

Figure 4-21: Fluid flow in the lamella mixer.

Figure 4-22 shows the concentration distribution on the model boundaries. The 
inflow channels see a constant concentration of 0 or 50 mol/m3 depending on the 
channel. Mixing starts when the fluid enters the mixing chamber. At the entrance there 
is a clear separation of the concentration, but this diminishes toward the end of the 
chamber. On the sides of the mixing chamber where the flow velocity is smaller the 
mixing is better than at its center. The mixing, however, is not perfect, and a reduced 
flow velocity, a longer mixing chamber, or some other means to increase mixing is 
preferable.
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Figure 4-22: Concentration plot on the boundaries of the lamella mixer model.

To get another point of view, examine Figure 4-23, which shows the concentration 
profile at the chamber’s centerline. Near the channels the transition is very rapid, but 
closer to the chamber’s end the profile has a flatter sigmoid shape. On the chamber’s 
sides the concentration profile has the same shape, but its amplitude is between 
approximately 17  mol/m3 and 33 mol/m3.

If you generalize the concentration profile to cover the entire component (Figure 4-19 
on page 308), the profile would be a wave-like curve where concentration would 
alternate between its minimum and maximum values with a spatial frequency related 
to the layer thickness.
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Figure 4-23: Concentration profile along a line in the z direction in the middle of the 
mixing chamber at various distances from the microchannels: 20 µm (solid), 80 µm 
(dotted), 140 µm (dashed), and 200 µm (dash-dotted).

Modeling in COMSOL Multiphysics

In COMSOL Multiphysics you build the model with two application modes: The 
Incompressible Navier-Stokes application mode solves the fluid flow, and the 
Convection and Diffusion application mode solves the transport of the concentration 
within the fluid. For both modes use the default values for the equation forms: For the 
Incompressible Navier-Stokes application mode the default value is the full stress 
tensor formulation in Equation 4-8; for the Convection and Diffusion application 
mode the default value is the non-conservative equation form in Equation 4-9. The 
selection for the Convection and Diffusion application mode ensures that no artificial 
accumulation of concentration arises when solving the model.

Because the concentration does not affect the fluid flow it is not necessary to solve the 
application modes simultaneously. By solving them sequentially, first using the 
Navier-Stokes equations, you improve the solution’s convergence and reduce the 
solution time. Using this technique it takes only a few minutes to solve this model.
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It is good practice to save the solution steps in a solver script using the Solver Manager. 
You can then use this script when trying different values for pressure, concentration, 
and diffusion coefficients.

To create the 3D geometry (in this example named Geom1), start with three 2D 
geometries named Geom2, Geom3, and Temp and extrude the 2D drawings. The 
geometry Temp is a temporary drawing area for creating initial objects that you copy 
to Geom2 and Geom3, which are work planes in the xy-plane located at z = 0 and z = 
0.2·10−4 m, respectively. They show the geometry viewed from the top so that the 
upper channels curve to the right and the lower channels curve to the left.

Model Library path: MEMS_Module/Microfluidics_Models/lamella_mixer

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator, and on the New page click the Multiphysics button.

2 Click Add Geometry. From the Space dimension list, select 3D. Click OK.

3 From the list of application modes, select 
MEMS Module>Microfluidics>Incompressible Navier-Stokes>Steady-state analysis. 
Click Add.

4 From the list of application modes, select 
MEMS Module>Microfluidics>Convection and Diffusion. Click Add.

5 Click Add Geometry. From the Space dimension list, select 2D. Click OK. This action 
creates the geometry Geom2 (2D).

6 Click Add Geometry, then click OK. This creates the geometry Geom3 (2D).

7 Click Add Geometry. In the Geometry Name edit field, type Temp. Click OK.

8 Click OK to close the Model Navigator. 

COMSOL Multiphysics opens in the Draw mode with the geometry Temp activated.

G E O M E T R Y  M O D E L I N G

Initial Drawings
1 From the Options menu, select Axes/Grid Settings.
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2 On the Axis page, enter x-y limits settings as given in this table; when done, click OK.

You are now ready to draw the initial geometries.

1 Draw six concentric circles centered at the point (−2.4e-4, 0) with radii 2.4e-4, 
2.6e-4, 2.7e-4, 2.9e-4, 3.0e-4, and 3.2e-4, respectively. To do so, shift-click on the 
Ellipse/Circle (Centered) button on the Draw toolbar and enter the data in the dialog 
box.

2 Shift-click on the Rectangle/Square button on the Draw toolbar, then enter the 
following Size and Position settings:

3 Click OK.

4 From the Edit menu, choose Select All.

5 Click the Union button on the Draw toolbar.

6 Click the Split Object button on the Draw toolbar.

2D Geometries
1 In the Temp geometry, select the objects CO5, CO9, and CO13 (first select CO5 

and then Ctrl-click on the other two objects).

2 From the Edit menu, choose Copy.

3 Click the Geom2 tab.

4 From the Edit menu, choose Paste. In the dialog box that appears, leave the 
displacement values at zero. Click OK.

5 Click the Zoom Extents button on the Main toolbar.

NAME VALUE

x min -25e-5

x max 25e-5

y min -25e-5

y max 25e-5

NAME VALUE

Width 3.2e-4

Height 2e-4

Base Corner

x -2.4e-4

y 0
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6 Select the new objects CO1, CO2, and CO3.

7 Click the Mirror button on the Draw toolbar. In the dialog box that appears, click 
OK.

8 From the Edit menu, choose Cut.

9 Click the Geom3 tab.

10 From the Edit menu, choose Paste.

11 In the dialog box that appears, type 0.8e-4 in the x edit field; leave the y edit field 
at zero. Click OK.

12 Click the Zoom Extents button on the Main toolbar.

13 From the Draw menu, select Work-Plane Settings.

14 On the Quick page, type 0.2e-4 in the z edit field. Click OK.

15 Click the Geom2 tab.

16 Shift-click the Rectangle/Square button, then enter the following Size and Position 
settings:

17 Click OK.

18 Click the Zoom Extents button on the Main toolbar.

3D Geometry

1 Click the Geom2 tab.

2 From the Draw menu, choose Extrude.

3 From the Objects to extrude list, select CO1, CO2, and CO3.

4 In the Distance edit field, type 1e-5. Click OK.

5 Click the Geom2 tab.

6 From the Draw menu, choose Extrude.

7 From the Objects to extrude list, select R1.

8 In the Distance edit field, type 3e-5. Click OK.

NAME VALUE

Width 0.8e-4

Height 2e-4

Base Corner

x 0

y -2e-4
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9 Click the Geom3 tab.

10 From the Draw menu, choose Extrude.

11 In the Objects to extrude list, select all of them.

12 In the Distance edit field, type 1e-5. Click OK.

13 When the software activates Geom1, click the Zoom Extents button on the Main 
toolbar.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, choose Constants.

2 Define the following constants (the descriptions are optional); when done, click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Multiphysics menu, select 1 Geom1: Incompressible Navier-Stokes (mmglf).

2 From the Physics menu, select Subdomain Settings.

3 From the Subdomain selection list, select all the subdomains.

4 In the Density edit field, type rho. 

5 In the Dynamic viscosity edit field, type eta.

6 Click OK.

7 From the Multiphysics menu, select 2 Geom1: Convection and Diffusion (chcd).

8 From the Physics menu, select Subdomain Settings.

9 In the D (isotropic) edit field, type D_i.

10 In the u edit field type u, in the v edit field type v, and in the w edit field type w.

11 Click OK to close the Subdomain Settings dialog box.

Boundary Conditions
1 From the Multiphysics menu, select 1 Geom1: Incompressible Navier-Stokes (mmglf).

NAME EXPRESSION DESCRIPTION

p0 10[Pa] Driving pressure

rho 1e3[kg/m^3] Density of water

eta 1e-3[Pa*s] Dynamic viscosity of water

c0 50[mol/m^3] Input concentration

D_i 1e-10[m^2/s] Isotropic diffusion coefficient of the 
substance in water
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2 From the Physics menu, select Boundary Settings.

3 Enter boundary settings from the following table. When done, click OK. For the 
exterior boundaries that are not explicitly mentioned, the default no-slip boundary 
condition applies.

4 From the Multiphysics menu, select 2 Geom4: Convection and Diffusion (chcd).

5 From the Physics menu, select Boundary Settings.

6 Enter boundary settings from the following table. The Insulation/Symmetry 
condition is the default and need not be set. Do not specify any conditions for the 
interior boundaries (number 19, 21, 27, 28, 33, and 34). When done, click OK.

M E S H  G E N E R A T I O N

1 Activate Geom1.

2 From the Mesh menu, choose Free Mesh Parameters.

3 From the Predefined mesh sizes list on the Global page, select Extremely fine.

4 Click OK to close the Free Mesh Parameters dialog box.

5 Click the Initialize Mesh button on the Main toolbar.

C O M P U T I N G  T H E  S O L U T I O N

Solve the model with the default solver. You can review the default settings in the Solver 

Parameters dialog box.

The first time you solve the model, it is a good idea to record the solution steps and 
use them later when solving the model with different values. To automate this process, 
use solver scripting.

1 Click the Solver Manager button on the Main toolbar.

SETTINGS BOUNDARIES 1, 6, 
11, 38, 41, 42 

BOUNDARIES 3, 8, 13, 
17, 18, 24, 31, 37

BOUNDARY 16

Boundary type Inlet Wall Outlet

Boundary condition Pressure, no 
viscous stress

Slip Pressure, no 
viscous stress

p0 p0 0

SETTINGS BOUNDARIES 1, 6, 11 BOUNDARIES 38, 41, 42 BOUNDARY 16 ALL OTHERS

Boundary 
condition

Concentration Concentration Convective 
flux

Insulation/ 
Symmetry

c0 0 c0
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2 Click the Script tab.

3 Select the Automatically add commands when solving check box.

4 Click the Solve For tab.

5 In the Solve for variables list, select Geom1 (3D)>Incompressible Navier-Stokes (mmglf).

6 Click Solve.

7 Click the Initial Value tab.

8 In the Values of variables not solved for and linearization point area, click the 
Current solution button.

9 Click the Solve For tab.

10 In the Solve for variables list, select Geom1 (3D)>Convection and Diffusion (chcd).

11 Click Solve.

12 Click the Script tab.

13 Clear the Automatically add commands when solving check box.

14 Click OK.

If you want to solve the model with other parameter values, follow the steps below. 
Alternatively, you can go through the steps already listed. In the latter case, remember 
to skip the tasks (Steps 2 and 3) that would add extra lines to the script.

1 Click the Solver Manager button on the Main toolbar.

2 Click the Script tab.

3 Select the Solve using a script check box.

4 Click Solve.

5 Clear the Solve using a script check box.

6 Click OK.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

First inspect the fluid flow by reproducing the plot in Figure 4-21.

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, go to the Plot type area and select the Slice, Streamline, and 
Geometry edges check boxes. Clear all the other check boxes.

3 Click the Slice tab.

4 From the Predefined quantities list in the Slice data area, select 
Incompressible Navier-Stokes (mmglf)>Velocity field.
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5 From the Unit list, select mm/s.

6 In the Slice positioning area, set x levels to 0 and y levels to 5.

7 Click the Streamline tab.

8 From the Predefined quantities list, select 
Incompressible Navier-Stokes (mmglf)>Velocity field.

9 From the Streamline plot type list, select Magnitude controlled.

10 On the Density page, set the Min distance to 0.01 and the Max distance to 0.025.

11 Click OK.

12 Click the Go to Default 3D View button on the Camera toolbar, then click the 
Zoom Extents button on the Main toolbar.

Next, reproduce the plot of the concentration field given in Figure 4-22.

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, go to the Plot type area and select the Boundary and Geometry 

edges check boxes. Clear all the other check boxes.

3 On the Boundary page, go to the Predefined quantities list and select 
Convection and Diffusion (chcd)>Concentration, c. Click OK.

4 Click the Go to Default 3D View button on the Camera toolbar, then click the 
Zoom Extents button on the Main toolbar.

Finally draw the concentration profiles on the centerline of mixing chamber displayed 
in Figure 4-23.

1 From the Postprocessing menu, choose Cross-Section Plot Parameters.

2 On the Line/Extrusion page, select Convection and Diffusion (chcd)>Concentration, c 
from the Predefined quantities list.

3 From the x-axis data list, select z. Enter the following Cross-section line data:

4 Click Apply.

5 Click the General tab.

SETTING VALUE SETTING VALUE

x0 4e-5 x1 4e-5

y0 -2e-5 y1 -2e-5

z0 0 z1 3e-5

Line resolution 200
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6 Select the Keep current plot check box.

7 Click the Line/Extrusion tab.

8 Change the values in the y0 and y1 edit fields to -8e-5.

9 Click the Line Settings button. Set Line style to Dotted line, then click OK.

10 Click Apply.

11 Change the values in the y0 and y1 edit fields to -14e-5.

12 Click the Line Settings button. Set Line style to Dashed line, then click OK.

13 Click Apply.

14 Change the values in the y0 and y1 edit fields to -20e-5.

15 Click the Line Settings button. Set Line style to Dash-dot line, then click OK.

16 Click OK to close the Cross-Section Plot Parameters dialog box and generate the plot.
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E l e c t r o o smo t i c  F l ow i n  a  B i o c h i p

This model was developed by Dr. Jordan MacInnes at the University of Sheffield, UK. 
The modeling work at his department has been combined with experimental studies.

Introduction

Miniature laboratories (Ref. 1) are required to efficiently analyze the information in 
human DNA, and they can facilitate tailor-made diagnosis and treatment of hereditary 
diseases for individuals. A problem that arises in these lab-on-chip devices concerns the 
transport of the liquid samples and other solutions in the chip, which are of very small 
dimensions. Moving parts of micrometer scale make the chips very expensive and 
fragile and are therefore to be avoided if at all possible. An alternative method for 
transporting fluid in the samples is through electrokinetic effects, where charged ions 
in the solutions are subjected to an electric field. These ions can drag the entire 
solution through the channels in the microchip from one analyzing point to the other.

Two mechanisms can drive the flow of a saline solution in an electric field. In the 
presence of solid surfaces, like the micromachined surfaces of the channels of a biochip, 
a charged solution is formed close to the wall surfaces. This layer is referred to as a 
diffuse double layer. Depending on the material used, it is formed by negatively or 
positively charged groups on the wall’s surfaces. The electric field displaces the charged 
liquid in the charged double layer generating an electroosmotic flow. Figure 4-24 
shows the velocity field shortly after the application of the electric field.

Figure 4-24: Velocity field near a solid wall. The fluid flows in the direction of the electric 
field.
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A force is imposed on the positively charged solution close to the wall surface, and the 
fluid starts to flow in the direction of the electric field. The velocity gradients 
perpendicular to the wall give rise to viscous transport in this direction. In the absence 
of other forces, the velocity profile eventually becomes almost uniform in the cross 
section perpendicular to the wall. The time constant of the overall flow is roughly 1 ms, 
while the flow in the double layer responds to changes far more rapidly. The layer 
model of MacInnes (Ref. 1) replaces the double layer with the Helmholtz- 
Smoluchowski relationship between wall velocity and wall electric field (Ref. 2).

The second effect arises due to differences in mobility and charge of the ionic species. 
Negatively and positively charged ions migrate in different directions, and these ions 
drag water molecules, to different extents, through the channel system. Water is 
dragged by the sodium ions, which can coordinate more water molecules than the 
chloride ions in the solution. This type of flow is called electrophoretic flow; 
Figure 4-25 depicts its basic principle.

Figure 4-25: Electrophoretic flow.

This particular model does not include the mass balances of dissolved species in the 
sample (see Ref. 1), but you could easily add these through the Electrokinetic Flow 
application mode. As another possible model extension, you could use a 
time-dependent expression for the voltage at the inlet and outlet boundaries.

Model Definition

The flow in the chip is given by the electroosmotic effect just described. To simulate 
this type of flow, the model must couple the electric potential distribution in the ionic 
solution in the chip and the equations for fluid flow. 

Figure 4-26 shows the chip’s geometry. The potential difference imposed between its 
different parts produces a flow in the vertical or horizontal direction, depending on 
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the direction of the imposed field. Mode A generates a horizontal flow from right to 
left in the main channel; Mode B generates a flow that is vertical in the vertical channels 
and horizontal, from right to left, in the part of the main channel that unites the 
vertical branches.

Figure 4-26: Geometry and electric field setup in the two modes: Mode A, where the flow 
is expected to flow in the horizontal branch, and Mode B, with flow in the vertical branch.

You set the potentials at the open boundaries, where the fluid is allowed to enter or 
leave the channel system. The wall boundaries are denoted diffuse layer boundaries. 
From the published work of Dr. MacInnes (Ref. 1), you can expect the flow to be 
laminar and of low Reynolds number. This implies that you can use the Stokes Flow 
application mode. The Stokes flow equations are almost the same as the Navier-Stokes 
equations with the exception that they assume that the inertial term is zero. 
Therefore they describe flow with a very low Reynolds number and very small inertial 
forces. Unlike the Navier-Stokes equations, the Stokes equations form a nearly linear 
system of equations.

The Stokes flow equations are

 (10)

where η denotes the dynamic viscosity (Pa·s), u is the velocity (m/s), ρ denotes the 
fluid’s density (kg/m3), and p is the pressure (Pa).

The boundary conditions, according to the notations just given, are

Mode A Mode B

248V

79V

213V

283V

diffuse layer
boundary

flow path

193V

114V 79V

0V

diffuse layer
boundary

flow path

ρu ∇⋅ u

ρ
t∂

∂u ∇ pI– η+ ∇u ∇u( )T
+( )[ ]⋅– F=

∇ u⋅ 0=
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where ε0 denotes the permittivity of free space (F/m), εr is the relative permittivity of 
water (dimensionless), ζ0 refers to the zeta potential at the channel wall (V), and V 
denotes the potential (V). For a more detailed review of the diffuse layer wall boundary 
condition, see Ref. 1 and Ref. 3.

Assuming that there are no concentration gradients for the ions carrying the current, 
it is possible to express the current balance in the channel through Ohm’s law and the 
balance equation for current density:

Here σ denotes the conductivity (S/m) and the expression within the brackets 
represents the current density (A/m2).

The corresponding boundary conditions for the current balance are

where V0 corresponds to the voltage shown in the previous figure at the neutral 
boundaries. At these boundaries, the potential and current distribution in the chip 
determine if the fluid enters or exits the chip or stays at rest.

The relevant material properties for water are listed in the following table.

PROPERTY VALUE DESCRIPTION

 ρ 103 kg/m3 Fluid density

 η 10-3 kg/(m·s) Dynamic viscosity

 σ 0.11845 S/m Electric conductivity

 εr 80.2 Relative permittivity

 ζ0 0.1 V Zeta potential

u
ε0εrζ0

η
---------------- V∇=    diffuse layer, wall

pI– η+ ∇u ∇u( )T
+( )[ ] n⋅ 0=   voltage boundary and inlet 

p 0= η ∇u ∇u( )T
+( )[ ] n⋅ 0=,  outlet  

∇ σ∇V–( )⋅ 0=

σ∇– V n⋅ 0= diffuse layer, wall                                 
V V0= voltage boundary, inlet or outlet
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Results

Figure 4-27 shows the potential distribution for Mode A in the chip. From this plot it 
is clear that the largest potential differences are in the horizontal direction. This also 
implies that the main flow is in the same direction.

Figure 4-27: Potential distribution in the chip when electric field from mode A is applied.

The plot in Figure 4-28 shows that the average velocity in the channel is approximately 
1 mm/s. The largest velocity is at the corner walls where the electric field is large. This 
clearly shows the effect of the driving force located at the walls. In normal 
pressure-driven flow, the velocity at the solid surfaces is zero. In fact, looking at the 
pressure field, you would find that it is constant in the channels.

Studying the velocity flow lines in the channel, Figure 4-29 shows that flow takes a 
small deviation at the T-junctions in the chip. This can also be detected in the color 
scale of the velocity, which decreases in the middle of the junction.

Regulating the potential can quickly and efficiently change the path of the flow in the 
channels. This makes it possible to mix different solutions in different branches of the 
chip. Figure 4-30 shows a different flow direction with the same magnitude as the 
potential configuration given in Mode A. In this plot you can also find the corner 
effects and the low-velocity regions in the T-junctions, as the channel width increases.
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Figure 4-31 shows that the flow decreases in the outer parts of the turns while a 
maximum is seen in the inner parts. This maximum is larger in this case compared to 
the first case. This is because the electric field is much stronger around the corners 
compared to the straight path in the first simulation.
E L E C T R O O S M O T I C  F L O W  I N  A  B I O C H I P  |  327



328 |  C H A P T E
Figure 4-28: Velocity distribution in the chip with the electric field from Mode A applied.

Figure 4-29: Close-up of the velocity field. The surface color is given by the modulus of the 
velocity vector and the flow lines by the velocity field.
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Figure 4-30: Flow distribution in the chip with the electric field from Mode B applied.

Figure 4-31: Close-up of the flow distribution near the T-junctions.
E L E C T R O O S M O T I C  F L O W  I N  A  B I O C H I P  |  329



330 |  C H A P T E
References

1. J.M. MacInnes, “Computation of Reacting Electrokinetic Flow in Microchannel 
Geometries,” J. Chem. Eng. Sci., vol. 57, no. 21, pp. 4539–4558, 2002.

2. R.F. Probstein, Physicochemical Hydrodynamics, Wiley-Interscience, 1994.

3. W. Menz, J. Mohr, and O. Paul, Microsystems Technology, Wiley-VCH Verlag 
GmbH, 2001.

Model Library path: MEMS Module/Microfluidics_Models/
electroosmotic_biochip

Modeling Using the Graphical User Interface

1 In the Model Navigator, select 2D in the Space dimension list.

2 From the Application Modes list, select 
MEMS Module>Microfluidics>Electroosmotic Flow>Stokes Flow.

3 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

2 Define the following constants for water’s material properties; when done, click OK.

G E O M E T R Y  M O D E L I N G

You can easily create the geometry using the CAD tools in COMSOL Multiphysics.

1 Press the Shift key and click the Rectangle/Square button on the Draw toolbar.

2 In the Size area of the Rectangle dialog box, enter the Width 0.25e-3 and the Height 
5.35e-3. In the Position area, set x to 2.5e-3 and y to 2.5e-4. Click OK.

NAME EXPRESSION DESCRIPTION

eta 1e-3[Pa*s] Dynamic viscosity

rho 1e3[kg/m^3] Density

sigma 0.11845[S/m] Conductivity

eps_r 80.2[F/m] Relative permittivity

zeta0 0.1[V] Zeta potential
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3 Repeat this procedure to create two additional rectangles with the following 
properties:

4 Click the Zoom Extents button on the Main toolbar.

5 Press Ctrl+A to select all geometry objects.

6 Click the Union button on the Draw toolbar.

7 Click the Delete Interior Boundaries button.

8 From the Draw menu, select Fillet/Chamfer.

9 In the drawing area, Ctrl-click to select the four vertices connecting the vertical 
channels with the horizontal one (Vertices 3, 5, 8, and 10).

10 In the Fillet/Chamfer dialog box, specify the fillet Radius 0.5e-4.

11 Click OK to close the dialog box.

This completes the geometry modeling stage.

SETTINGS RECTANGLE 2 RECTANGLE 3

Width 0.25e-3 1.45e-2

Height 5.35e-3 2.5e-4

x 5e-3 0

y -5.35e-3 0
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P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Multiphysics menu, select 1 Stokes Flow (mmglf).

2 From the Physics menu, open the Subdomain Settings dialog box.

3 Select Subdomain 1.

4 In the ρ edit field, type rho, and in the η edit field, type eta. Click OK.

5 In the Multiphysics menu, switch to the 2 Conductive Media DC (emdc) application 
mode.

6 From the Physics menu, open the Subdomain Settings dialog box.

7 In the σ edit field, type sigma. Click OK.

Boundary Conditions
1 From the Multiphysics menu, select 1 Stokes Flow (mmglf).

2 From the Physics menu, open the Boundary Settings dialog box.

3 Specify boundary conditions according to the following table; when done, click OK.

4 From the Multiphysics menu, select 2 Conductive Media DC (emdc).

5 From the Physics menu, open the Boundary Settings dialog box.

6 Enter boundary conditions according to the following table; when done, click OK.

SETTINGS BOUNDARY 1 BOUNDARIES 2–4, 6–8, 10, 11, 13–16 BOUNDARIES 5, 9, 12

Boundary 
type

Outlet Wall Open boundary

 Boundary 
condition

Pressure, no 
viscous stress

Electroosmotic velocity Normal stress

 p0 0

 Ex Ex_emdc

 Ey Ey_emdc

 ζ zeta0

f0 0

SETTINGS BOUNDARY 1 BOUNDARY 5 BOUNDARY 9 BOUNDARY 12 BOUNDARIES 2-4, 
6-8, 10, 11, 13-16

Type Electric 
potential

Electric 
potential

Electric 
potential

Electric 
potential

Electric 
insulation

V0 283 248 213 79
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M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters.

2 Click the Custom mesh size button, then set the Mesh curvature factor to 0.6.

3 Click the Boundary tab. From the Boundary selection list, select 1, 5, 9, and 12.

4 In Maximum element size edit field, type 1e-4.

5 Click the Remesh button to generate the mesh.

6 When the mesher has finished, click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Follow these instructions to generate the plot in Figure 4-27:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, make sure that only the Surface and Geometry edges plot types 
are selected.

3 On the Surface page, select Conductive Media DC (emdc)>Electric potential from the 
Predefined quantities list on the Surface Data page.

4 Click Apply.

Proceed to generate the plots in Figure 4-28 and Figure 4-29 with these steps:

1 On the Surface page, select Stokes Flow (mmglf)>Velocity field from the Predefined 

quantities list on the Surface Data page. From the Unit list, select mm/s.

2 Click Apply to obtain the plot in Figure 4-28.

3 On the Streamline page, select the Streamline plot check box.

4 From the Predefined quantities list on the Streamline Data page, select 
Stokes Flow (mmglf)>Velocity field.

5 From the Streamline plot type list, select Magnitude controlled. Set the Density to 9.

6 On the Line Color page, click first the Uniform color option button and then the Color 
button. In the Streamline Color dialog box, select the black swatch, then click OK.

7 Click the Advanced button. Set the Maximum number of integration steps to 4000.

8 Click OK to close the Advanced Streamline Parameters dialog box.

9 Click OK in the Plot Parameters dialog box.

10 From the Options menu, select Axes/Grid Settings. 
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11 On the Axis page, specify the following settings:

12 Click OK to generate the plot in Figure 4-29.

P H Y S I C S  S E T T I N G S — M O D E  B

Now switch the electric field to Mode B (see the right panel of Figure 4-26).

Boundary Conditions
1 From the Multiphysics menu, select 2 Conductive Media DC (emdc).

2 From the Physics menu, open the Boundary Settings dialog box.

3 Modify the boundary conditions according to the table below; when done, click OK.

C O M P U T I N G  T H E  S O L U T I O N — M O D E  B

Click the Restart button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N — M O D E  B

The plot that appears in the drawing area when the solver has finished reproduces the 
one in Figure 4-31. To generate the plot in Figure 4-30, follow these steps:

1 Click the Plot Parameters button on the Main toolbar.

2 On the Streamline page, clear the Streamline plot check box, then click OK.

3 Click the Zoom Extents button on the Main toolbar.

x min 2e-3

x max 6e-3

y min -1e-3

y max 1e-3

SETTINGS BOUNDARY 1 BOUNDARY 5 BOUNDARY 9

Boundary condition Electric potential Electric potential Electric potential

V0 114 193 0
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L ow - V o l t a g e  E l e c t r o o smo t i c  
M i c r o pump

Micropumps, especially those based on electroosmotic flow (EOF), are essential 
components in microfluidic lab-on-a-chip devices, because they contain no moving 
parts and are relatively easy to integrate in microfluidic circuits during fabrication. One 
major drawback in the conventional design of electroosmotic micropumps is the use 
of a high driving voltage. Therefore, the development of a low-voltage cascade EOF 
pump is interesting, because it could draw power from batteries and be suitable for 
portable devices (Ref. 1).

This model, simulated in 2D, shows how to use the MEMS Module to study the 
electroosmotic flow described by the electroosmotically-induced boundary velocity.

The model uses the predefined Electroosmotic Flow multiphysics coupling, which 
builds on the Stokes Flow and the Conductive Media DC application modes.

Introduction

When a polar liquid (such as water) and a solid (such as glass) come into contact, the 
solid surface acquires an electric charge, which influences the charge distribution 
within the liquid and causes a 2-layer charge distribution called the electric double 
layer or EDL (Ref. 2). The charges close to the wall are strongly drawn toward the 
surface, but the application of an electric field can change the charge distribution 
deeper in the fluid (Figure 4-32).

Figure 4-32: Diagram of an electric double layer and the principle of electroosmotic flow.
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Because the thickness of the electric double layer is typically on the order of 
nanometers, you can model the electroosmotic flow velocity, ueof, as a boundary 
velocity

 (4-11)

where µeof is the fluid’s empirically obtained electroosmotic mobility, and E is the 
strength of the electric field tangential to the surface. Due to the fluid’s viscous force, 
all the fluid in the channel moves at once.

To study the electroosmotic pumping effect, this discussion works with results 
published by A. Brask and others (Ref. 1) as well as Y. Takamura and others (Ref. 3). 
The original pump was designed to work as an effective pressure source for low applied 
voltages. The main idea is to connect multiple pumps in series to build up pressure 
(Figure 4-33). Each elementary pump consists of ten narrow channels followed by a 
wide single channel. The EOF in the narrow channel section acts as a high-pressure 
pump with a forward electric field. In the wide channel section the electric field is 
reversed, but here the induced back pressure is small compared to the pressure 
produced by the narrow channel section. After flowing through one such pump 
section, the accumulated voltage is zero while the electroosmotically generated 
pressure maintains a net flow. This feature ensures a low operating voltage, which is an 
attractive feature that allows the pump to be operated by batteries.

Figure 4-33: Top view of the low-voltage cascade EOF pump with three steps (adapted from 
Ref. 1 and Ref. 3).

ueof µeofE µeof∇V= =
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Model Definition

The model geometry (Figure 4-34) contains only half of one pump section (Ref. 1). 
The flow pattern in the upper half of this section equals that in the lower half, thus 
reducing the geometry’s complexity.

Figure 4-34: The 2D geometry. To more clearly show the dimensions, this diagram extends 
the aspect ratio in the y direction.

The governing equations for flow, defined by the Stokes flow are:

where u is the velocity, η is the viscosity, and p is the pressure inside the fluid. 

The model uses the Pressure boundary condition for the inlet and the outlets. To 
analyze the free-flow condition, there are no pressure gradients in the flow. The 
Neutral boundary condition for the outlets would be more precise, but in practice it 
leads to numerical instabilities and less accurate results. In addition, a model can use 
the Velocity boundary condition in a parametric analysis to study the maximum back 
pressure against which the pump can operate. The electroosmotic velocity boundary 
condition is assigned on the other boundaries. This defines the boundary velocity 
according to Equation 4-11.

For a conductive material, you can calculate the electric potential from the equation

where σ is the electric conductivity of the fluid and V is the electric potential. The 
model employs the Electric potential boundary condition to set the potential equal to 

∇– η ∇u ∇uT
+( ) ∇p+⋅ 0=

∇ u⋅ 0=

∇– σ∇V⋅ 0=
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V0 = 10 V on the electrode and to V0/2 on the channel ends. At all other boundaries, 
the model uses the Electric insulation boundary condition.

Further, the model assumes that the fluid in the pump is water with the following 
material properties: density, ρ = 1000 kg/m3; dynamic viscosity, η = 0.001 Pa·s; 
electroosmotic mobility, µeo = 0.06 mm2/(V·s); relative permittivity, εr = 78.5; and 
isotropic electric conductivity, σ = 0.01 S/m.

You start the modeling by selecting a predefined Electroosmotic Flow multiphysics 
coupling from the Model Navigator, which adds the two application modes to the 
model. You can then build the model using the predefined index groups in the 
Boundary Settings dialog boxes. For example, you can assign boundaries to the 
Electrode, Outlet, or Electroosmosis groups, which automatically set up the actual 
boundary conditions discussed earlier in this section.

Results and Discussion

Figure 4-35 shows the flow field when there is no applied pressure. The flow 
streamlines show an interesting curved behavior close to the electrode caused by the 
stronger electric field. Even though the electroosmotic velocity always points 
downward, the larger number of small channels forces a net flow through the pump: 
the flow through the left channel is directed upward and that through the smaller 
channels downward.

Figure 4-36 further illustrates this effect. In the absence of an applied pressure, the 
smaller channels have flat flow-velocity profiles. In the wider channel, in contrast, the 
forced flow leads to a laminar flow profile. Note also that at the wider channel’s 
boundaries, electroosmosis leads to a boundary flow in the opposite direction.

Figure 4-37 plots the flow through the pump against an applied back pressure. It gives 
an estimate of the strength of a single pump step. Increasing the back pressure 
decreases the flow, with the graph intersecting the zero line at 124 Pa. To obtain the 
pump’s total strength, multiply this value by the number of steps. For the pump 
depicted in Figure 4-33, the result corresponds to a total maximum back pressure of 
roughly 372 Pa.
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Figure 4-35: Flow streamlines.

Figure 4-36: The inlet (solid) and outlet (dashed) velocity profiles.
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Figure 4-37: Influx versus back pressure.

Modeling in COMSOL Multiphysics

To solve this model using the MEMS Module in COMSOL Multiphysics, you need 
the Stokes Flow and Conductive Media DC application modes. However, to simplify 
the model set-up, use the predefined Electroosmotic Flow multiphysics coupling, 
which adds those two application modes and implements the required couplings 
between the fluid and the electric field.

Because the flow has no effect on the electric field, you can first solve for the electric 
potential and then use that solution when computing the flow and pressure fields.

The first solution for the total flux is rather inaccurate. Thus it is a good idea to refine 
the solution using weak constraints. The advantage of this option is that it computes 
the fluxes very accurately; for more information on this topic, see the section “Using 
Weak Constraints” on page 300 in the COMSOL Multiphysics Modeling Guide.

This example involves a parametric study to find the maximum back pressure against 
which the pump can operate. For this analysis you add an integration variable that 
calculates the flux through the inlet channel, which you plot as a function of the 
applied back pressure.
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Model Library path:  

MEMS Module/Microfluidics_Models/electroosmotic_micropump_2d

Modeling Using the Graphical User Interface 

M O D E L  N A V I G A T O R

1 In the Model Navigator, click the New tab.

2 From the Space dimension list, select 2D.

3 From the Application Modes list, select 
MEMS Module>Microfluidics>Electroosmotic Flow>Stokes Flow.

4 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

2 Define the following constants (the descriptions are optional); when done, click OK.

G E O M E T R Y

You can import the geometry as a COMSOL Multiphysics binary file, 
electroosmotic_micropump.mphbin. Step-by-step instructions for how to manually 
create the geometry are available in an appendix on page 347.

NAME EXPRESSION DESCRIPTION

sigma 0.01[S/m] Electric conductivity, water

V0 10[V] Applied voltage

d 20[um] Device thickness

eps_r 78.5 Relative permittivity, water

mu_eo 0.06[mm^2/(V*s)] Electroosmotic mobility

p0 0[Pa] Outlet pressure
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1 From the File menu, select Import>CAD Data From File.

2 From the Files of type list, select COMSOL Multiphysics file (*.mphtxt; *.mphbin; ...).

3 Browse to the directory where the file electroosmotic_micropump_2d.mphbin is 
stored (the same directory as the model file, that is, models/MEMS_Module/
Microfluidics_Models under the COMSOL Multiphysics installation folder).

4 Click Import.

P H Y S I C S  S E T T I N G S

Subdomain Settings—Conductive Media DC
1 From the Multiphysics menu, select 2 Conductive Media DC (emdc).

2 From the Physics menu, select Subdomain Settings.

3 From the Subdomain selection list, select all the subdomains (press Ctrl+A).

4 In the d edit field, type d.

5 In the σ edit field, type sigma to specify an isotropic conductivity.

6 Click OK.

Boundary Conditions—Conductive Media DC
1 From the Physics menu, select Boundary Settings.

2 Click in the Boundary selection list, then press Ctrl+A to select all boundaries.

3 From the Group list, select Electroosmosis.

4 Select Boundary 16.

5 From the Group list, select Electrode. In the V0 edit field, type V0.

6 Select the inlet and all outlet boundaries (Boundaries 2, 11, 20, 25, 30, 35, 40, 45, 
50, 55, and 60). Note that you can easily do this by clicking and dragging in the 
drawing area to enclose the desired boundaries. From the Group list select Electrode, 
then type V0/2 in the V0 edit field.

7 On the Groups page, type Middle potential in the Name edit field.

8 Click OK.

Subdomain Settings—Stokes Flow 
1 From the Multiphysics menu, select 1 Stokes Flow (mmglf).

2 From the Physics menu, select Subdomain Settings.

3 Select all the subdomains (press Ctrl+A).

4 On the Physics page, the default settings apply to water, so you need only set the 
Channel thickness to d.
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5 On the Microfluidic page, set the Relative permittivity εr to eps_r.

6 Click OK.

Boundary Conditions—Stokes Flow
1 From the Physics menu, select Boundary Settings.

2 Specify boundary conditions as in the following table. The table lists only those 
Boundary type and Boundary condition settings that you explicitly need to change, 
having chosen the appropriate entry from the Group list.

Again, click and drag in the drawing area to quickly select all Outlet boundaries. To 
conveniently select the Electroosmosis boundaries, first select Boundary 1 and then 
select the Select by group check box.

3 Click OK.

M E S H  G E N E R A T I O N

For this model, a mixed mesh is suitable: use mapped quad meshes for the elongated 
channels and a free mesh for the rest of the geometry.

1 From the Mesh menu, select Mapped Mesh Parameters.

2 Click the Boundary tab. For all of the boundaries in the following table, select the 
Constrained edge element distribution check box, then enter a value in the Number of 

edge elements edit field as indicated in the table. Note that the boundaries in the last 
row are all in the same line at the lower ends of the narrow channels; you can select 
all of them most easily by using the mouse to enclose them in the drawing area.

SETTINGS BOUNDARY 2 BOUNDARIES 11, 20, 25, 30, 
35, 40, 45, 50, 55, 60

ALL OTHERS

 Group Inlet Outlet Electroosmosis

 Boundary condition Pressure Pressure, no viscous 
stress

 p0 0 p0

 µeo mu_eo

BOUNDARIES NUMBER OF EDGE ELEMENTS

1 90

2 20

10, 19, 24, 29, 34, 39, 44, 49, 54, 59 80

11, 20, 25, 30, 35, 40, 45, 50, 55, 60 8
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3 Click the Subdomain tab. Select Subdomains 1, 4, and 7–15 (the channels).

4 Click the Mesh Selected button, then click OK.

5 From the Mesh menu, select Free Mesh Parameters.

6 On the Global page, select Extra fine from the Predefined mesh sizes list.

7 Click the Subdomain tab. Select Subdomains 2, 3, 5, and 6.

8 In the Subdomain mesh parameters area, set the Maximum element size to 1e-5.

9 Click the Mesh Selected button, then click OK.

As you can verify in the Mesh Statistics dialog box (that you open from the Mesh menu), 
the completed mesh consists of about 8200 quadrilateral and 6887 triangular 
elements.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Manager button on the Main toolbar.

2 Click the Solve For tab.

3 From the Solve for variables list, select Conductive Media DC (emdc).

4 Click Solve. Doing so should result in roughly 48,600 degrees of freedom, and the 
solution time should be a couple of seconds.

5 Click the Initial Value tab. In the Value of variables not solved for and linearization 

point area, click the Current solution button.

6 Click the Solve For tab. In the Solve for variables list select Stokes Flow (mmglf).

7 Click Solve. The solution time for this solving stage should be roughly four times 
longer than for the electrostatics part (this time you solve for about 117,700 DOFs).

8 Click OK.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

First study the velocity-field distribution inside the pump by reproducing the 
combined surface and streamline plot given in Figure 4-35.

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, select the Surface, Arrow, Streamline, and Geometry edges check 
boxes in the Plot type area. Clear all the others.

3 Click the Surface tab. On the Surface Data page, verify that the selection in the 
Predefined quantities list is Stokes Flow (mmglf)>Velocity field. From the Unit list, 
select mm/s.
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4 Click the Arrow tab. On the Subdomain Data page, verify that the selection in the 
Predefined quantities list again is Stokes Flow (mmglf)>Velocity field.

5 In the Arrow positioning area, click the Vector with coordinates option button for 
x points. In the associated edit field type -2.5e-5:1e-5:2.5e-5 
1.975e-4:2e-5:3.775e-4.

6 In the Arrow parameters area, select 3D arrow from the Arrow type list. Click the Color 
button. In the Arrow Color dialog box, click the black swatch, then click OK.

7 Click the Streamline tab. On the Streamline Data page, verify that the selection in the 
Predefined quantities list is Stokes Flow (mmglf)>Velocity field. From the Streamline 

plot type list, select Uniform density. Set the Separating distance to 0.02.

8 Click OK to generate the plot.

Next use domain plots to analyze the inlet and outlet velocity profiles.

1 From the Postprocessing menu, select Domain Plot Parameters.

2 On the General page, click the Title/Axis button at the bottom of the dialog box. Go 
to the Axis settings for line and point plots area. Select the option button next to the 
edit field for the First axis label, then enter the text Normalized channel width. 
Click OK.

3 Select the Keep current plot check box.

4 Click Line/Extrusion tab. 

5 In the Plot type area, click the Line plot button. Select Boundary 2.

6 In the y-axis data area, select Stokes Flow (mmglf)>y-velocity from the Predefined 

quantities list. From the Unit list, select mm/s.

7 In x-axis data area, click the Expression option button, then click the associated 
Expression button. In the Expression edit field, type s (this is a predefined variable 
for the normalized distance along the boundary). Click OK.

8 Click Apply to generate the first graph.

9 Select Boundary 11.

10 Click the Line Settings button. From the Line style list, select Dashed line. Click OK.

11 Click OK to reproduce the plot in Figure 4-36.

Next study the total fluxes through the inlet and outlets.

1 From the Postprocessing menu, select Boundary Integration.

2 From the Boundary selection list, select 2.
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3 In the Expression to integrate area, type (-nx*u-ny*v)*d in the Expression edit field 
and nl/s in the Unit edit field to obtain the result expressed in nanoliters per second. 
The constant d gives the structure’s thickness, while −nx and −ny are the x- and 
y-components of the inward-pointing normal vector.

4 Click Apply.

This setup should result in a value of 0.638 nl/s, a value that appears in the message 
log at the bottom of the user interface.

Next, compute the total flux through the outlets.

5 Using the mouse, select the outlet boundaries (Boundaries 11, 20, 25, 30, 35, 40, 
45, 50, 55, and 60).

6 Click OK.

The resulting value of  −0.618 nl/s differs slightly from the value for the inlet. You can 
evaluate all the other boundaries and observe that due to numerical inaccuracies the 
walls appear to leak slightly. Reducing this mass “leak” requires a finer mesh. For the 
purpose of the present analysis, assume the error to be small enough (roughly 3%) to 
continue the analysis.

F I N D I N G  T H E  M A X I M U M  B A C K  P R E S S U R E

Finally make a parametric study where you vary the back pressure and identify the 
maximum back pressure from a plot of flux vs. pressure. Start by defining a global 
integration variable for the influx.

1 From Options menu, select Integration Coupling Variables>Boundary Variables.

2 From the Boundary selection list, select 2.

3 In the Name edit field type Inflow, and in the Expression edit field type 
(-nx*u-ny*v)*d (that is, the same expression you used for the flux studies).

4 Click OK.

5 Click the Solver Parameters button on the Main toolbar.

6 From the Solver list, select Parametric. In the Parameter name edit field, type p0 and 
in the Parameter values edit field, type 0:10:200.

7 Click OK.

8 Click the Solve button on the Main toolbar. Solving this parametric study can take 
several minutes.

Next, plot the inflow as a function of the back pressure (see Figure 4-37).

1 From the Postprocessing menu, select Global Variables Plot.
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2 In the Expression field, type Inflow*1[m^3/nl], then click the Add Entered 

Expression button immediately to the right of the edit field. Multiplying the 
boundary integration variable Inflow (which has no unit, but by its definition is the 
inflow value measured in m3/s) by the factor 1[m^3/nl] gives the result in 
nanoliters/second.

3 Click the Title/Axis button. Enter the Title Inflow vs. back pressure, the 
First axis label Back pressure [Pa], and the Second axis label Inflow [nl/s].

4 Click OK to close the Title/Axis Settings dialog box.

5 Click OK to close the Global Variables Plot dialog box and generate the plot.

By zooming in on the plot you can see that the inflow changes sign (that is, turns into 
an net outflow) around 124 Pa. 

Appendix—Geometry Modeling

Follow these instructions to create the geometry by hand.

1 Shift-click the Rectangle/Square button on the Draw toolbar on the left side of the 
user interface and create the following rectangles:

PROPERTY R1 R2 R3 R4

Width 50e-6 405e-6 185e-6 5e-6

Height 630e-6 200e-6 230e-6 400e-6

x -25e-6 -25e-6 195e-6 195e-6

y 0 430e-6 400e-6 0
L O W - V O L T A G E  E L E C T R O O S M O T I C  M I C R O P U M P  |  347



348 |  C H A P T E
2 Click the Zoom Extents button on the Main toolbar.

The geometry before creating the array of narrow channels.

3 Select R4, then click the Array button on the Draw toolbar.

4 In the Displacement area, for x enter 20e-6 and for y enter 0. In the Array size area, 
for x enter 10 and for y enter 1. Click OK.

The geometry after creating the array of channels.
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E l e c t r o o smo t i c  M i c r om i x e r

This model was originally done in COMSOL Multiphysics by H. Chen, Y. T. Zhang, 
I. Mezic, C. D. Meinhart, and L. Petzold of the University of California, Santa Barbara 
(Ref. 1 and Ref. 2).

Microlaboratories for biochemical applications often require rapid mixing of different 
fluid streams. At the microscale, flow is usually highly ordered laminar flow, and the 
lack of turbulence makes diffusion the primary mechanism for mixing. While 
diffusional mixing of small molecules (and therefore of rapidly diffusing species) can 
occur in a matter of seconds over distances of tens of micrometers, mixing of larger 
molecules such as peptides, proteins, and high molecular-weight nucleic acids can 
require equilibration times from minutes to hours over comparable distances. Such 
delays are impractically long for many chemical analyses. These problems have led to 
an intense search for more efficient mixers for microfluidic systems.

Most microscale mixing devices are either passive mixers that use geometrical stirring, 
or active mixers that use moving parts or external forces, such as pressure or electric 
field.

In a passive mixer, one way of increasing the mixing is by “shredding” two or several 
fluids into very thin alternating layers, which decreases the average diffusion length for 
the molecules between the different fluids. However, these mixers often require very 
long mixing channels because the different fluids often run in parallel. Another way of 
improving mixing efficiency is to use active mixers with moving parts that stir the 
fluids. At the microscale level moving parts in an active mixer are very fragile. One 
alternative is to use electroosmotic effects to achieve a mixing effect that is 
perpendicular to the main direction of the flow. 

This model takes advantage of electroosmosis to mix fluids. The system applies a 
time-dependent electric field, and the resulting electroosmosis perturbs the parallel 
streamlines in the otherwise highly ordered laminar flow. 

Model Definition

This example of a rather simple micromixer geometry (Figure 4-38) combines two 
fluids entering from different inlets into a single 10 µm wide channel. The fluids then 
enter a ring-shaped mixing chamber that has four microelectrodes placed on the outer 
wall at angular positions of 45, 135, −45, and −135 degrees, respectively. Assume that 
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the aspect ratio (channel depth to width) is large enough that you can model the mixer 
using a 2D cross-sectional geometry. The material parameters relevant for the model 
are given in Table 4-4.

Figure 4-38: Geometry of the micromixer with four symmetric electrodes on the wall of the 
mixing chamber. This example does not model the two inlet channels. Here you assume a 
parabolic inflow at the beginning of the computational domain (the gray area).

The Navier-Stokes equations for incompressible flow describe the flow in the channels:

Here η denotes the dynamic viscosity (kg/(m·s)), u is the velocity (m/s), ρ equals the 
fluid density (kg/m3), and p refers to the pressure (Pa).

Because you do not model the two inlet channels, assume that the entrance channel 
starts at a position where the flow has a fully developed laminar profile. The mixed fluid 
flows freely out of the right end boundary, where you specify vanishing total stress 
components normal to the boundary:

When brought into contact with an electrolyte, most solid surfaces acquire a surface 
charge. In response to the spontaneously formed surface charge, a charged solution 
forms close to the liquid-solid interface. Known as an electric double layer, it forms 
because of the charged groups located on the surface that faces the solution. When the 
operator applies an electric field, the electric field generating the electroosmotic flow 
displaces the charged liquid in the electric double layer. This scheme imposes a force 
on the positively charged solution close to the wall surface, and the fluid starts to flow 

ρ
t∂

∂u ∇ η ∇u ∇u( )T
+( )⋅– ρu ∇⋅ u ∇p+ + 0=

∇ u⋅ 0=

n pI– η ∇u ∇u( )T
+( )+[ ]⋅ 0=
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in the direction of the electric field. The velocity gradients perpendicular to the wall 
give rise to viscous transport in this direction. In the absence of other forces, the 
velocity profile eventually becomes almost uniform in the cross section perpendicular 
to the wall.

This model replaces the thin electric double layer with the Helmholtz-Smoluchowski 
relation between the electroosmotic velocity and the tangential component of the 
applied electric field:

In this equation, εw = ε0εr denotes the fluid’s electric permittivity (F/m), ζ0 represents 
the zeta potential at the channel wall (V), and V equals the potential (V). This equation 
applies on all boundaries except for the entrance and the outlet.

Assuming that there are no concentration gradients in the ions that carry the current, 
you can express the current balance in the channel with Ohm’s law and the balance 
equation for current density

where σ denotes conductivity (S/m) and the expression within parentheses represents 
the current density (A/m2).

The electric potentials on the four electrodes are sinusoidal in time with the same 
maximum value (V0 = 0.1 V) and the same frequency (8 Hz), but they alternate in 
polarity. Potentials on electrodes 1 and 3 are V0 sin(2πf t), whereas potentials on 
electrodes 2 and 4 are −V0 sin(2π f t) (see Figure 4-38).

Assume all other boundaries are insulated. The insulation boundary condition

sets the normal component of the electric field to zero.

At the upper half of the inlet (see Figure 4-38) the solute has a given concentration, 
c0; at the lower half the concentration is zero. Thus, assume that the concentration 
changes abruptly from zero to c0 at the middle of the inlet boundary. The mixed 
solution flows out from the right outlet by convection, and all other boundaries are 
assumed insulated. 

Inside the mixer, the following convection-diffusion equation describes the 
concentration of the dissolved substances in the fluid:

u
εwζ0

η
------------ VT∇=

∇ σ∇V–( )⋅ 0=

σ∇– V n⋅ 0=
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 (4-12)

Here c is the concentration, D represents the diffusion coefficient, R denotes the 
reaction rate, and u equals the flow velocity. In this model R = 0 because the 
concentration is not affected by any reactions.

Results and Discussion

Figure 4-39 shows a typical instantaneous streamline pattern. It reveals that 
electroosmotic recirculation of the fluid vigorously stirs the flow, typically in the form 
of two rotating vortices near the electrodes.

The fundamental processes of effective mixing involve a combination of repeated 
stretching and folding of fluid elements in combination with diffusion at small scales. 
As the system applies the AC field (Figure 4-40), the resulting electroosmotic flow 
perturbs the laminar pressure-driven flow such that it pushes the combined stream 
pattern up and down at the beginning of the mixing chamber, causing extensive 
folding and stretching of material lines.

TABLE 4-4:  MODEL INPUT DATA

PARAMETER VALUE DESCRIPTION

 ρ 1000 kg/m3 Density of the fluid

 η 10-3 Pa·s Dynamic viscosity of the fluid

 U0 0.1 mm/s Average velocity through the inlet

 εr 80.2 Relative electric permittivity of the fluid

 ζ -0.1 V Zeta potential on the wall-fluid boundary

 σ 0.11845 S/m Conductivity of the ionic solution

 D 10-11 m2/s Diffusion coefficient

 c0 1 mol/m3 Initial concentration

∂c
∂t
----- ∇ D∇c–( )⋅+ R u ∇c⋅–=
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Figure 4-39: Fluid streamlines in an electroosmotic micromixer at t = 0.0375 s.

Figure 4-40: Electric potential lines for an electroosmotic micromixer. The contour lines 
show the shape when the device uses maximal potentials (±V0).
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The following plots further exemplify how the mixer operates. Figure 4-41 shows the 
concentration at steady state when the electric field is not applied. The flow is laminar 
and the diffusion coefficient is very small, so the two fluids are well separated also at 
the outlet. When the alternating electric field is applied, the mixing increases 
considerably owing to the alternating swirls in the flow. Figure 4-42 depicts the system 
at the instant when the electric field and the electroosmotic velocity have their largest 
magnitudes during the cycle (that is, when |sin ωt| = 1). From the plot you can 
estimate that the concentration at the output fluctuates with the same frequency as the 
electric field. Thus, this mixer should be further improved to get a steadier output.

Figure 4-41: Steady-state solution in the absence of an electric field.
R  4 :  M I C R O F L U I D I C S  M O D E L S



Figure 4-42: Time-dependent solution at the time when the alternating electric field has 
its largest magnitude.

This example demonstrates a rather simple and effective use of electrokinetic forces for 
mixing. The scheme is easy to implement, and you can easily control both the 
amplitude and the frequency. At low Reynold numbers the inertial forces are small, 
which makes it possible to calculate stationary streamlines patterns using the 
parametric solver to control amplitude.

Modeling in COMSOL Multiphysics

Cummings and others (Ref. 3) have shown that in order to use the 
Helmholtz-Smoluchowski equation at the fluid-solid boundaries, the electric field 
must be at least quasi-static to neglect transient effects. In other words, the time scale 
of the unsteady electric field must be much larger than that of the transient flow. Y. T. 
Zhang and others (Ref. 1) estimated that the time scale of the transient effect in the 
modeled micromixer (with a channel width of 10 microns) is roughly 0.0127 s. In this 
simulation the frequency of the applied electric potential is 8 Hz, which corresponds 
to a time scale of the electric field 10 times larger than that of the flow.
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Because you can model the time-dependent electric field as a product of a stationary 
electric field and a time-dependent phase factor (sinωt), it is possible to reduce the 
simulation time and memory requirements by dividing the solution into two stages. In 
the first, calculate the amplitude of the electric potential field and the initial state for 
the time-dependent flow model using a stationary solver. In the second stage, you 
deactivate the DC Conductive Media application mode and calculate the transient 
solution for the Incompressible Navier-Stokes and the Convection and Diffusion 
application modes. You obtain the tangential electric field components used in the 
electroosmotic velocity boundary condition by multiplying the stationary DC solution 
by sinωt. This approach is permissible because there is only a one-way coupling 
between the electric field and the fluid fields.
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Model Library path: MEMS_Module/Microfluidics_Models/
electroosmotic_mixer

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 In the Model Navigator, go to the New page and in the Space dimension list select 2D.

2 Click the Multiphysics button.
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3 In the Application Modes list, select MEMS Module>Microfluidics>Incompressible 

Navier-Stokes>Transient analysis. Click Add.

4 In the Application Modes list, select MEMS Module>Electrostatics>Conductive Media DC. 
Click Add.

5 In the Application Modes list, select MEMS Module>Microfluidics>Convection and 

Diffusion>Transient analysis. Click Add.

6 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

2 In the dialog box that opens, define the following constants (the descriptions are 
optional); when done, click OK.

You need the constant t (used in the scalar expressions below) when first solving the 
model using a stationary solver. In the time-dependent simulation, the internal time 
variable, t, overwrites this constant (the red color is just a warning signalling that t is 
an internal variable).

G E O M E T R Y  M O D E L I N G

1 Shift-click the Rectangle/Square button on the Draw toolbar.

NAME EXPRESSION DESCRIPTION

U0 0.1[mm/s] Mean inflow velocity

sigma_w 0.11845[S/m] Conductivity of the ionic solution

eps_r 80.2 Relative permittivity of the fluid

zeta -0.1[V] Zeta potential

V0 0.1[V] Maximum value of the AC potential

freq 8[Hz] Frequency of the AC potential

omega 2*pi[rad]*freq Angular frequency of the AC potential

t 0[s] Start time

D 1e-11[m^2/s] Diffusion coefficient of the solution

c0 1[mol/m^3] Initial concentration
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2 In the Rectangle dialog box that appears, enter these properties; when done, click 
OK.

3 Click the Zoom Extents button on the Main toolbar.

4 Shift-click the Ellipse/Circle (Centered) button on the Draw toolbar.

5 In the Circle dialog box that appears, enter these properties; when done, click OK.

6 Repeat Steps 4 and 5 for another circle centered at (0, 0) and with a radius of 5e-6. 
Click OK.

7 Select all the geometry objects (for example by pressing Ctrl+A).

8 From the Draw menu, select Create Composite Object.

9 In the Set formula edit field, enter the expression (R1+C1)-C2.

10 Clear the Keep interior boundaries check box, then click OK.

11 Shift-click the Rectangle/Square (Centered) button in the Draw toolbar.

(Steps 12 to 15 create boundaries for the four electrodes.)

12 In the Square dialog box, enter these properties; when done, click OK.

PARAMETER VALUE

Width 80e-6

Height 10e-6

Base Center

x position 0

y position 0

PARAMETER VALUE

Radius 15e-6

Base Center

x position 0

y position 0

PARAMETER VALUE

Width 22.27e-6

Base Center

x position 0

y position 0
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13 Select all the geometry objects (press Ctrl+A).

14 From the Draw menu select Create Composite Object.

15 In the Set formula edit field, enter the expression (CO1*SQ1)+CO1. Verify that the 
Keep interior boundaries check box is cleared. Click OK.

16 Shift-click the Point button on the Draw toolbar. Specify values according to the 
following table; when finished, click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Multiphysics menu, select 1 Incompressible Navier-Stokes (mmglf).

2 From the Physics menu, select Subdomain Settings.

3 Select Subdomain 1.

4 On the Physics page, verify that the default values are as in the following table:

5 On the Microfluidic page, type eps_r in the εr edit field; when done, click OK.

6 From the Multiphysics menu, select 2 Conductive Media DC (emdc).

7 From the Physics menu, select Subdomain Settings.

8 In the σ edit field, type sigma_w, then click OK.

9 From the Multiphysics menu, select 3 Convection and Diffusion (chcd).

10 From the Physics menu, select Subdomain Settings.

PARAMETER VALUE

Coordinate x -4e-5

Coordinate y 0

Name PT1

PROPERTY VALUE

 ρ 1e3

 η 1e-3

 Fx 0

 Fy 0
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11 Specify the following properties; when done, click OK.

Boundary Conditions
1 From the Multiphysics menu, choose 1 Incompressible Navier-Stokes (mmglf).

2 From the Physics menu, select Boundary Settings.

3 Enter the boundary conditions in the following table; when done, click OK.

4 From the Multiphysics menu, select 2 Conductive Media DC (emdc).

5 From the Physics menu, select Boundary Settings.

6 Specify the boundary conditions in the following table; when done, click OK.

7 From the Multiphysics menu, select 3 Convection and Diffusion (chcd).

8 From the Physics menu, select Boundary Settings.

PROPERTY VALUE

D (isotropic) D

R 0

u u

v v

SETTINGS BOUNDARIES 1, 3 BOUNDARIES 2, 4–6, 8–23 BOUNDARY 7

Boundary type Inlet Wall Outlet

Boundary 
condition

Laminar inflow Electroosmotic velocity Normal stress

 U0 U0

Lentr 1e-5

Constrain end 
points to zero

Yes

 Ex Ex_emdc*sin(omega*t)

 Ey Ey_emdc*sin(omega*t)

 ζ zeta

f0 0

SETTINGS BOUNDARIES 10, 21 BOUNDARIES 11, 20 BOUNDARIES 1–9,12–19, 22, 23

Boundary condition Electric potential Electric potential Electric insulation

V0 -V0 V0
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9 Enter these boundary conditions; when done, click OK.

The concentration condition on Boundaries 1 and 3 give a sharp but smooth 
concentration gradient in the middle of the channel entrance.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters.

2 On the Global page, select Extra fine from the Predefined mesh sizes list.

3 Click the Custom mesh size option button. Set the Maximum element size scaling 

factor to 0.25.

4 Click the Boundary tab. Select Boundaries 10, 11, 20, and 21 (the electrodes).

5 In the Boundary mesh parameters area, set the Maximum element size to 0.2e-6 and 
the Element growth rate to 1.1. These settings result in a finer mesh near the 
electrodes.

6 Click the Point tab. Select Point 2. 

7 In the Point mesh parameters area, set the Maximum element size to 1e-7 and the 
Element growth rate to 1.1. With these settings, the concentration gradient at the 
entrance is properly resolved.

8 Click OK to close the Free Mesh Parameters dialog box.

9 Click the Initialize Mesh button on the Main toolbar.

C O M P U T I N G  T H E  S O L U T I O N

Start by computing the stationary solution for velocity, pressure, concentration, and 
electric potential amplitude. In the transient simulation stage, you then solve only the 
Incompressible Navier-Stokes and the Convection and Diffusion application modes.

1 Click the Solver Parameters button on the Main toolbar.

2 From the Analysis list, select Stationary, then click Apply.

3 Click the Solve button on the Main toolbar.

4 Click the Solve button on the Main toolbar to compute the initial solutions for all 
application modes.

5 In the Solver Parameters dialog box, restore the Analysis list selection to Transient.

SETTINGS BOUNDARIES 1, 3 BOUNDARIES 2, 4–6, 8–23 BOUNDARY 7

Boundary 
condition

Concentration Insulation/Symmetry Convective flux

c0 c0*flc2hs(y[1/m],1e-7)
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6 In the Time stepping area, type 0:0.125/60:0.5 in the Times edit field.

7 Click OK.

8 Click the Solver Manager button on the Main toolbar.

9 On the Initial Value page, click the Store Solution button.

10 In the Initial value area click the Stored solution option button.

11 On the Solve For page, select Incompressible Navier-Stokes (mmglf) and Convection 

and Diffusion (chcd) (first select one, then Ctrl-click the other).

12 Click OK.

13 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

First study the swirls in the flow (see Figure 4-39 on page 353):

1 Click the Plot Parameters button on the Main toolbar.

2 In the Plot type area on the General page, select only Streamline and Geometry edges.

3 From the Solution at time list, select 0.0375.

4 Click the Streamline tab. From the Predefined quantities list on the Streamline Data 
page, select Incompressible Navier-Stokes (mmglf)>Velocity field.

5 From the Streamline plot type list, select Uniform density.

6 Set the Separating distance to 0.01, then click Apply.

Next visualize the electric potential (see Figure 4-40 on page 353):

1 Click the General tab. In the Plot type area, select only Contour and Geometry edges.

2 Click the Contour tab. On the Contour Data, page find the Predefined quantities list 
and select Conductive Media DC (emdc)>Electric potential.

3 In the Contour levels area, click the Vector with isolevels option button; in the 
associated edit field, type linspace(-0.1,0.1,20).

4 In the Contour color area click the Uniform color option button.

5 Clear the Color scale check box.

6 Click Apply.

Finally examine the mixing of the fluid:

1 On the General page, select the Surface and Streamline check boxes and clear the 
Contour check box in the Plot type area.
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2 From the Solution at time list, select the time you want: 0 corresponds to the steady 
state value, and at 0.46875 the electric field has it maximum amplitude.

3 Click the Surface tab. From the Predefined quantities list, select Convection and 

Diffusion (chcd)>Concentration, c.

4 Click Apply to generate the plot. 

5 When you are done, click OK to close the Plot Parameters dialog box.
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S t a r - S h ap ed M i c r o c h ann e l  Ch i p

Lab-on-a-chip devices have become quite popular for analyses in fields such as 
biochemistry and bioengineering as well as MEMS in general. Through various 
techniques they incorporate all the equipment involved in a chemical process such as 
chemical reactors, heat exchangers, separators, and mixers.

This example involves the design of an infuser, a device that feeds a reactor or analysis 
equipment with a specific amount of fluid. Controlling pressure is an accurate way to 
introduce a set quantity of fluid at a certain velocity to some piece of equipment.

Flushing the equipment can also be important. Optimizing such an infuser to 
maximize its use would involve spending the least amount of time (and fluid) flushing 
the equipment. Modeling this process in the time domain can lead to an optimization 
of the infusing pressure, microchannel design, and time control.

This model demonstrates two useful tools in COMSOL Multiphysics modeling:

• The ability to easily define a time-dependent boundary condition

• The ability to easily extrude meshes into 3D to save memory

Model Definition

This exercise arbitrarily sets the geometry and conditions of the microchannel 
lab-on-a-chip (Figure 4-43). The differential pressure at the five inlets relative to the 
outlet pressure is time-controlled so that the inlet flow passes from one to the next in 
a smooth way. At any particular instant, one of the inlet flows dominates, although flow 
could be significant from more than one inlet. The pressure at the outlet is set to zero.
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Figure 4-43: Model geometry for a star-shaped infuser with five inlets and one outlet. The 
model sets up a varying pressure differential at each inlet in the time domain in such a 
way that the dominant inlet flow alternates among them.

The example models only fluid flow whose velocity is of a magnitude that suggests 
laminar behavior. This implies that you can get a numerical solution of the full 
momentum balance and continuity equations for incompressible flow with a 
reasonable number of elements. The equations you must solve are the Navier-Stokes 
equations in the time domain

where ρ denotes density (kg/m3), u is the velocity (m/s), η denotes dynamic viscosity 
(Pa·s), and p equals pressure (Pa). The fluid in this case is water, with the 
corresponding density and viscosity values.

The boundary conditions for the inlets and the outlet assume a set pressure; they also 
assume vanishing viscous stress:

Set the pressure at the outlet to zero; at the inlets, use the time-dependent expressions

Outlet

Inlets

ρ
t∂

∂u ∇ η ∇u ∇u( )T
+( )⋅– ρu ∇⋅ u ∇p+ + 0=

∇ u⋅ 0=

∇ η ∇u ∇u( )T
+( )⋅[ ] n⋅ 0=

p pi=

pi 50 10 πt α+( )  Pasin+=
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where  t is time (s), and k is a value between zero and one. This simplified example sets 
the phase α to 0, π/4, π/2, 3π/4, or π, depending on the inlet boundary.

Apply the no-slip condition to all other boundaries; it states that the velocity is zero in 
the x, y, and z directions at the wall:

Results

Figure 4-44 shows the velocity field as a combined slice and arrow plot through the 
middle of the geometry at t = 0.5 s. The figure also displays the pressures at the walls. 
Setting up and observing this plot as an animation gives an informative qualitative 
description of the process as the largest pressure differential rolls from one inlet to the 
next.

Figure 4-44: The velocity field in a microchannel infuser through the middle of the 
geometry. The plot also shows pressure at the walls.

Figure 4-45 and Figure 4-46 display the pressure and velocity field’s x component (the 
direction of the long channel), respectively. The model includes a point in the middle 
of the geometry, just prior to the outlet, to investigate these two parameters. The 
figures show almost perfect sine curves (more frequent time sampling in the initial 

u 0 0 0, ,( )=
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stages would improve the graphs) for both of them. These results are close to those 
obtained with a refined mesh.

Figure 4-45: Pressure as a function of time at a point located just before the outlet.

Figure 4-46: Velocity in the x direction as a function of time at a point located just before 
the outlet.

Modeling in COMSOL Multiphysics

This example illustrates how to use time-dependent boundary conditions to simulate 
a changing process. You can implement this scenario using a boundary condition that 
is a function of time. The user interface provides direct access to the built-in time 
variable (t) and the mathematical functions you need.
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In 3D models, results at the walls are important but they can also hide what occurs 
within the geometry. This example also illustrates how to better display results with the 
help of suppressed (hidden) boundaries.

Finally, this model approaches meshing in a way that deviates from the default settings. 
In most cases COMSOL Multiphysics automatically generate a 3D mesh made 
completely of tetrahedrons. Here—as is the case in many other microchannels and 
minichannels—the top and the bottom boundaries are significant in modeling the flow 
profile because the distance between them is of the same magnitude as that between 
the two sides. This means that you must model the device in 3D. However, because 
the microchannel’s height does not change along its length, the software does not 
require much meshing to resolve this dimension.

As an alternative to its default meshing, it is possible to extrude a mesh. To illustrate 
this concept, you create the mesh in this model by first taking a cross section of the full 
geometry to construct a 2D geometry. After meshing that, you then extrude both the 
geometry and the mesh in the height dimension. This approach allows for some mesh 
and memory conservation.

Model Library path: MEMS_Module/Microfluidics_Models/star_chip

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics.

2 On the New page in the Model Navigator, select 3D from the Space dimension list.

3 From the Application Modes list, select 
MEMS Module>Microfluidics>Incompressible Navier-Stokes>Transient analysis.

4 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.
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2 Enter the following variable names, expressions, and (optionally) descriptions; when 
done, click OK.

3 From the Options menu, select Expressions>Scalar Expressions.

4 Define the following expressions (the descriptions are optional); when done, click 
OK.

G E O M E T R Y  M O D E L I N G

1 From the Draw menu, choose Work-Plane Settings.

2 Click OK to use the default Quick work plane (the xy-plane at z = 0).

3 From the Options menu, select Axes/Grid settings.

4 On the Axis page, enter the following settings:

NAME EXPRESSION DESCRIPTION

eta 1e-3[Pa*s] Dynamic viscosity

rho 1e3[kg/m^3] Density

p0 50[Pa] Pressure offset

p1 10[Pa] Pressure amplitude

omega pi[rad/s] Angular velocity

NAME EXPRESSION DESCRIPTION

p_in_rm p0+p1*sin(omega*t) Pressure, rightmost inlet

p_in_ir p0+p1*sin(omega*t+pi/4) Pressure, inner right inlet

p_in_c p0+p1*sin(omega*t+pi/2) Pressure, central inlet

p_in_il p0+p1*sin(omega*t+3*pi/4) Pressure, inner left inlet

p_in_lm p0+p1*sin(omega*t+pi) Pressure, leftmost inlet

PROPERTY VALUE

x min -2e-4

x max 4e-4

y min -1.5e-4

y max 2e-4
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5 On the Grid page, clear the Auto check box. In the x-y grid area, specify the grid 
properties according to the following table; when done, click OK.

6 Click the Line button on the Draw toolbar.

7 Click on the points in the drawing area with the following (x, y) coordinate pairs in 
the given order:

8 Once you have clicked on the last point and have closed the geometry, right-click to 
create the 2D object.

9 Click the Mirror button on the Draw toolbar.

10 In the Point on line edit fields, enter 0.825e-4 as the x value and 0.125e-4 as the 
y value. In the Normal vector edit fields, enter 0 as the x value and 1 as the y value. 
Click OK.

11 Select both objects by pressing Ctrl+A.

12 Click the Union button on the Draw toolbar.

PROPERTY VALUE

x spacing 2.5e-5

Extra x -11.5e-5 -9.7e-5 -3e-5 3e-5

y spacing 2.5e-5

Extra y 1.25e-5 3e-5 5.5e-5 11e-5

ORDER X-COORDINATE Y-COORDINATE

1 3.25e-4 0.125e-4

2 3.25e-4 0.25e-4

3 0.3e-4 0.25e-4

4 0 0.3e-4

5 0 1.5e-4

6 -0.25e-4 1.5e-4

7 -0.25e-4 0.55e-4

8 -0.97e-4 1.25e-4

9 -1.15e-4 1.1e-4

10 -0.3e-4 0.25e-4

11 -1.5e-4 0.25e-4

12 -1.5e-4 0.125e-4

13 -0.3e-4 0.125e-4
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13 Click the Delete Interior Boundaries button.

The basic 2D geometry of the microchannel infuser. 

M E S H  G E N E R A T I O N

This step appears earlier in the modeling process than you might be accustomed to 
seeing it. This happens because you are extruding a 2D mesh into 3D to create a more 
structured mesh than the one the default procedure gives.

1 From the Mesh menu, select Free Mesh Parameters.

2 From the Predefined mesh sizes list, select Finer.

3 Click Remesh, then click OK.

4 From the Mesh menu, choose Extrude Mesh.

5 On the Geometry page, type 2.5e-5 in the Distance edit field.

6 On the Mesh page, type 4 in the Number of element layers edit field.

7 Click OK.

This sequence automatically creates the 3D geometry and gives a view of the resulting 
mesh.
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ARIES 

e, no 
 

Extruding a 2D mesh into 3D.

P H Y S I C S  S E T T I N G S

Boundary Conditions
1 From the Physics menu, select Boundary Settings.

2 Specify boundary conditions as in the following table (all external boundaries not 
listed use the default no-slip condition). When done, click OK.

Subdomain Settings
1 From the Physics menu, select Subdomain Settings.

SETTINGS BOUNDARIES 
1, 5

BOUNDARY 7 BOUNDARY 9 BOUNDARY 14 BOUNDARY 16 BOUND
23,24

Boundary 
type

Inlet Inlet Inlet Inlet Inlet Outlet

Boundary 
condition

Pressure, no 
viscous 
stress

Pressure, no 
viscous 
stress

Pressure, no 
viscous 
stress

Pressure, no 
viscous 
stress

Pressure, no 
viscous 
stress

Pressur
viscous
stress

p p_in_c p_in_ir p_in_il p_in_rm p_in_lm 0
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2 For Subdomain 1, specify the settings in the following table; when done, click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 From the Analysis list, select Transient.

3 In the Times edit field, type 0:0.1:4. Click OK.

4 Click the Solve button on the Main toolbar.

The default result plot in the user interface displays the velocity field.

A slice plot of the velocity field.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Reproduce the combined pressure and velocity plot in Figure 4-44 as follows:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, select the Slice, Boundary, Arrow, and Geometry edges check 
boxes.

PROPERTY VALUE

 ρ rho

 η eta
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3 From the Solution at time list, select 0.5.

4 Clear Auto check box for the Element refinement. Type 8 in the associated edit field.

5 Click the Slice tab. From the Predefined quantities list in the Slice data area, select 
Velocity field. From the Unit list, select mm/s.

6 In the Slice positioning area, set x levels to 0, y levels to 0, and z levels to 1.

7 Click the Boundary tab. From the Predefined quantities list, select Pressure.

8 In the Boundary color area, select hot from the Colormap list.

9 Click the Arrow tab. Keep the default selection on the Subdomain Data page.

10 In the Arrow positioning area, set x points to 35, y points to 35, and z points to 1. In 
the Arrow parameters area, select 3D arrow from the Arrow type list and Normalized 
from the Arrow length list. Clear the Auto check box and set the Scale factor to 0.3.

11 Click OK to close the Plot Parameters dialog box and generate the plot.

To see both the pressure and the velocity field you must suppress some boundaries:

12 From the Options menu, select Suppress>Suppress Boundaries.

13 In the Suppress Boundaries dialog box, select Boundaries 1, 2, 4, 5, 7, 10, 11, 13, 
14, 15, 18, and 21. Click OK.

Microchannel infuser geometry after suppressing selected boundaries.
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14 Click the Postprocessing Mode button on the Main toolbar to display the solution 
again. To adjust the camera angle, click and drag in the drawing area.

Velocity and pressure fields in the microchannel infuser.

To create the two figures showing the pressure and the velocity in the x direction at a 
point just near the outlet (Figure 4-45 and Figure 4-46), perform the following steps:

15 From the Postprocessing menu, choose Cross-Section Plot Parameters.

16 On the Point page, find the Coordinates area. In the x edit field type 3.24e-4, in the 
y edit field type 0.125e-4, and in the z edit field type 0.125e-4.

17 From the Predefined quantities list, select Pressure. Click Apply to plot the pressure.

18 From the Predefined quantities list, select x-velocity. From the Unit list, select mm/s, 
then click OK to plot the velocity’s x component.
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M i c r o c h ann e l  C e l l

Introduction

This example was originally formulated by Albert Witarsa under Professor Bruce 
Finlayson’s supervision at the University of Washington in Seattle. It was part of a 
graduate course in which the assignment consisted of using mathematical modeling to 
evaluate the potential of patents in the field of microfluidics.

This model treats a so-called H-microcell for separation through diffusion. The cell 
puts two different laminar streams in contact for a controlled period of time. The 
contact surface is well defined, and by controlling the flow rate it is possible to control 
the amount of species transported from one stream to the other through diffusion.

Figure 4-47: Diagram of the H-microcell.
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Model Definition

The geometry of the microcell (Figure 4-43) is taken from Albert Witarsa’s and 
Professor Finlayson’s assignment. The cell geometry is divided in half because of 
symmetry. The design aims to avoid upsets in the flow field when the two streams, A 
and B, are united. This is to avoid the two streams mixing through convection, which 
would mix all species equally and lead to loss of control over the separation abilities. 
The transport of species between streams A and B should take place only by diffusion 
in order that species with low diffusion coefficients stay in their respective streams.

Figure 4-48: Model geometry. To avoid any type of convective mixing, the design must 
smoothly let both streams come in contact with each other. Due to symmetry, it is sufficient 
to model half the geometry.

The simulations involve solving the fluid flow in the H-cell. According to the 
specifications, the flow rate at the inlet is roughly 0.1 mm/s. This implies a low 
Reynolds number, well inside the region of laminar flow:

 (4-13)

Equation 4-13 gives a Reynolds number of 0.001 for a water solution and the channel 
dimensions given in Figure 4-43, a value typical for microchannels. Thus it is easy to 
get a numerical solution of the full momentum balance and continuity equations for 
incompressible flow with a reasonable number of elements. The equations that you 
need to solve are the Navier-Stokes equations at steady state:

 (4-14)

Here ρ denotes density (kg/m3), u is the velocity (m/s), η denotes viscosity (Pa·s), 
and p equals pressure (Pa). 

Re dρu
η

-----------=
1·10 5– 1·103 1·10 4–⋅ ⋅

1·10 3–
---------------------------------------------------------=

∇ η ∇u ∇u( )T
+( )⋅– ρ u ∇⋅( )u ∇p+ + 0=

∇ u⋅ 0=
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Separation in the H-cell involves species in relatively low concentrations compared to 
the solvent, in this case water. This means that the solute molecules interact only with 
water molecules, and it is safe to use Fick’s law to describe the diffusive transport in 
the cell. This mass-balance equation for a solute appears in the Convection and 
Diffusion application mode and reads

.  (4-15)

In this equation, D denotes the diffusion coefficient (m2/s) and c represents the 
concentration (mol/m3). In this model, you use the parametric solver to solve 
Equation 4-15 for three different values of D—1·10−11 m2/s, 5·10−11 m2/s, and 
1·10−10 m2/s— to simulate the mixing of different species.

You solve two versions of the model:

• In the first version, you assume that a change in solute concentration does not 
influence the fluid’s density and viscosity. This implies that it is possible to first solve 
the Navier-Stokes equations and then solve the mass balance equation.

• In the second version, you include a correction term in the viscosity that dependes 
quadratically on the concentration:

.  (4-16)

Here α is a constant of dimension (concentration)−2. An influence of concentration 
on viscosity of this kind is usually observed in solutions of larger molecules.

Next, consider the boundary conditions, starting with the Navier-Stokes equations. 
For the relevant boundary groupings, refer to Figure 4-49.

Figure 4-49: Model domain boundaries.

∇ D∇– c cu+( )⋅– 0=

η η0 1 α c2
+( )=

Outlet

Outlet

Symmetry plane

Inlet A

Inlet B

Wall
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At the inlets and outlets, Pressure conditions apply along with vanishing viscous stress:

 (4-17)

Setting the pressure at the outlets to zero, the pressure at the inlets represents the 
pressure drop over the cell. These inlet and outlet conditions comply with the H-cell 
being a part of a channel system of constant width, which justifies the assumption of 
developed flow.

At the symmetry plane, choosing the boundary type Symmetry  boundary sets the 
velocity component in the normal direction of the surface to zero:

 (4-18)

At the walls, No slip conditions state that the velocity is zero:

 (4-19)

For the mass balances, the assumption that solute molecules interact only with water 
molecules implies that it is sufficient to consider a single species A of concentration c. 
At the inlets, use the Concentration  boundary condition with the following values:

 (4-20)

Model the symmetry plane and cell walls with the Insulation/Symmetry condition:

 (4-21)

This equation states that the flux of species perpendicular to the boundary equals zero. 
At the outlets, the Convective flux  condition applies, stating that the diffusive 
transport perpendicular to the boundary normal is negligible:

 (4-22)

This condition eliminates concentration gradients in the flow direction.

p p0=

n η u u∇( )T
+∇( )⋅ 0=

n u⋅ 0=

t η u u∇( )T
+∇( )n⋅ 0=

u v w, ,( ) 0 0 0, ,( )      at the walls=

c c0     at inlet A=

c 0       at inlet B=

D∇– c cu+( ) n⋅ 0=      at the symmetry plane and walls

D∇– c( ) n⋅ 0      at the outlets=
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Results

Figure 4-44 shows the velocity field. The flow is symmetric and is not influenced by 
the concentration field.

Figure 4-50: Flow velocity field.

Figure 4-45 shows the concentration distribution for the lightest species in this study.

Figure 4-51: Concentration distribution for a species with diffusivity 1·10−10m2/s.
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Because of the relatively large diffusion coefficient, the degree of mixing is almost 
perfect for the lightest species. The species with a diffusion coefficient ten times smaller 
than that of the lightest species shows a different result.

Figure 4-52: Concentration distribution for a species with diffusivity 1·10−11m2/s.

The concentration distribution in Figure 4-52 indicates that the diffusion coefficient 
for the species is low enough to avoid any significant mixing between streams A and B. 
The simulation clearly shows that the H-cell can separate lighter molecules from 
heavier ones. A cascade of H-cells can achieve a very high degree of separation.

In some cases, especially those involving solutions of macromolecules, the 
macromolecule concentration has a large influence on the liquid’s viscosity. In such 
situations, the Navier-Stokes and the convection-diffusion become coupled, and they 
therefore must be solved simultaneously. Figure 4-53 shows the results of such a 
simulation, which you repeat in the second version of this model. You can see that 
changes in the concentration influence the flow field. It is clear from this plot that the 
velocity becomes asymmetric due to changes in viscosity. As a consequence of the 
modified flow field, the transport of molecules to the outlet B is also different from the 
result using a constant flow field. You can see the difference by comparing Figure 4-54 
with Figure 4-52 on page 381.
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Figure 4-53: Velocity field. The viscosity varies with the concentration according to η = 
η0(1+ α c2) with α = 0.5 (m3/mol)2. The figure shows that the velocity field is affected by 
variations in concentration. Compare it to the velocity field in Figure 4-44.

Figure 4-54: Concentration distribution for the species with diffusivity 1·10−11m2/s for 
the case where the fluid viscosity varies with concentration. Comparison with the plot in 
Figure 4-52 shows that fewer molecules of the species are transported to outlet B.
R  4 :  M I C R O F L U I D I C S  M O D E L S



Model Library path: MEMS_Module/Microfluidics_Models/
microchannel_h_cell

Modeling Using the Graphical User Interface

1 Start COMSOL Multiphysics.

2 On the New page, set the Space dimension to 3D.

3 From the list of application modes, select MEMS Module>Microfluidics> 
Flow with Species Transport>Incompressible Navier-Stokes.

4 Click the Multiphysics button, then click Add. As you can verify by inspection of the 
Multiphysics area on the right, this adds an Incompressible Navier-Stokes and a 
Convection and Diffusion application mode to the model. Later you will also see 
that a predefined coupling of the Navier-Stokes flow velocity has been included for 
the Convection and Diffusion application mode.

5 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

2 Enter the following variable names, expressions, and (optionally) descriptions in the 
Constants dialog box; when done, click OK.

G E O M E T R Y  M O D E L I N G

1 From the Draw menu, select Work-Plane Settings.

2 Use the default Quick work plane (the xy-plane at z = 0) by clicking OK.

3 From the Options menu, open the Axes/Grid settings.

NAME EXPRESSION DESCRIPTION

rho 1e3[kg/m^3] Density

eta 1e-3[Pa*s] Viscosity

D 1e-10[m^2/s] Diffusion constant

p0 2[Pa] Pressure drop

c0 1[mol/m^3] Inlet concentration

alpha 0.5[(m^3/mol)^2] Viscosity c^2-term prefactor
M I C R O C H A N N E L  C E L L  |  383



384 |  C H A P T E
4 On the Axis page, enter the following settings:

5 On the Grid page, clear the Auto check box and set both the x spacing and the 
y spacing to 1. Click OK.

6 Click the Line button on the Draw toolbar, then click the points with the x- and 
y-coordinates at (0, 6) and (0, 2).

7 Select the 2nd Degree Bezier Curve tool on the Draw toolbar and click at the 
coordinate pairs (0, 0) and (2, 0).

8 Select the Line tool and click at the coordinates (12, 0).

9 Select the 2nd Degree Bezier Curve tool and click at the coordinates (14, 0) and  
(14, 2).

10 Select the Line tool and click at the coordinates (14, 6). Continue by clicking at the 
coordinates (13, 6) and (13, 2).

11 Select the 2nd Degree Bezier Curve tool and click at the coordinates (13, 1) and (12, 
1).

12 Select the Line tool and click at the coordinates (2, 1).

13 Select the 2nd Degree Bezier Curve tool and click at the coordinates (1, 1) and (1, 2).

14 Select the Line tool and click at the coordinates (1, 6).

15 Click the right mouse button to close the set of lines and create a solid object, CO1.

You have now created half of the 2D cross section and can use copy, paste, and rotate 
operations to create the other half.

1 Click first the Copy button and then the Paste button, both on the Main toolbar. Let 
the Displacements remain at 0 and click OK to create the composite object CO2.

2 Click the Scale button on the Draw toolbar. Change the y component of the Scale 
factor to -1 (leave the other parameters at their default values). 

3 Click OK to flip CO2 over the x-axis.

4 From the Edit menu, choose Select All. (Alternatively, press Ctrl+A.)

5 Click the Create Composite Object button on the Draw toolbar.

PROPERTY VALUE

x min -1

x max 15

y min -7

y max 7
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6 Clear the Keep interior boundaries check box. Click OK.

The cross section is now finished and you can extrude it to the full 3D geometry.

7 Select Extrude from the Draw menu. Let the Distance remain equal to 1. Click OK.

The final geometry-modeling step is to scale the geometry to the correct scale.

8 Click the Scale button on the Draw toolbar.

9 Type 1e-5 in all three Scale factor edit fields. Click OK.

10 Click the Zoom Extents button on the Main toolbar.

You do not need the 2D workplane any more, so you can remove it from the model:

1 From the Multiphysics menu, choose Model Navigator.

2 In the Multiphysics area to the right, select Geom2 (2D) and then click Remove.

3 Click OK to close the Model Navigator.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Multiphysics menu, select 1 Incompressible Navier-Stokes (mmglf).

2 From the Physics menu, select Subdomain Settings.

3 Select Subdomain 1, then specify the settings in this table; when done, click OK.

4 From the Multiphysics menu, select 2 Convection and Diffusion (chcd).

5 From the Physics menu, select Subdomain Settings.

6 Select Subdomain 1.

7 In the D (isotropic) edit field, type D. Note that the velocity variables from the 
Incompressible Navier-Stokes application mode appear as predefined couplings.

8 Click OK to confirm the settings and close the dialog box.

Boundary Conditions
1 From the Multiphysics menu, select 1 Incompressible Navier-Stokes (mmglf).

2 From the Physics menu, select Boundary Settings.

PROPERTY VALUE

 ρ rho

 η eta
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3 Specify boundary conditions as in the following table; when done, click OK.

4 From the Multiphysics menu, select 2 Convection and Diffusion (chcd).

5 From the Physics menu, select Boundary Settings.

6 Specify the boundary conditions in the following table; when done, click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters.

2 From the Predefined mesh sizes list, select Extra fine.

3 Click the Remesh button.

4 When the mesher has finished, click OK.

C O M P U T I N G  T H E  S O L U T I O N

Start by first computing the solution for the velocity field and then use that solution 
for solving the mass transport problem.

1 Click the Solver Parameters button on the Main toolbar.

2 On the General page, select Direct (PARDISO) from the Linear system solver list.

3 Click OK.

4 Click the Solver Manager button on the Main toolbar.

5 On the Solve For page, select Incompressible Navier-Stokes (mmglf).

6 On the Initial Value page, click the Initial value expression option button in the 
Initial value area.

7 Click OK.

8 Click the Solve button on the Main toolbar.

SETTINGS BOUNDARIES 2, 8 BOUNDARIES 20, 22 BOUNDARY 4 ALL OTHERS

Boundary 
type

Inlet Outlet Symmetry 
boundary

Wall

Boundary 
condition

Pressure, no 
viscous stress

Pressure, no 
viscous stress

No slip

p0 p0 0 - -

SETTINGS BOUNDARY 2 BOUNDARY 8 BOUNDARIES 20, 22 ALL OTHERS

Type Concentration Concentration Convective 
flux

Insulation/ 
Symmetry

c0 c0 0 - -
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You have now computed the velocity field and can use that solution to make a 
parametric analysis for the mass transport problem with varying diffusivity.

1 Click the Solver Manager button on the Main toolbar.

2 On the Solve For page, select Convection and Diffusion (chcd).

3 Click the Initial Value tab, then click the Current solution option button in the 
Initial value area.

4 Click OK.

5 Click the Solver Parameters button on the Main toolbar.

6 From the Solver list, select Parametric.

7 In the Parameter name edit field, type D.

8 In the Parameter values edit field, type 1e-10 5e-11 1e-11.

9 Click OK.

10 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate Figure 4-44 follow these steps:

1 From the Postprocessing menu, open the Plot Parameters dialog box.

2 On the General page, select the Slice and Arrow check boxes in the Plot type area.

3 Clear the Element refinement Auto check box and type 5 in the associated edit field.

4 Click the Slice tab.

5 In the Predefined quantities list, select 
Incompressible Navier-Stokes (mmglf)>Velocity field.

6 From the Unit list, select mm/s.

7 In the Slice positioning area, set x levels to 5, y levels to 2, and z levels to 1.

8 Click the Arrow tab.

9 On the Subdomain Data page, verify that Velocity field is selected in the 
Predefined quantities list.

10 In the Arrow positioning area, set the numbers of x points, y points, and z points to 
14, 21, and 3, respectively.

11 In the Arrow parameters area, click the Color button. Select the black swatch from 
the palette in the Arrow Color dialog box, then click OK.

12 Select 3D arrow from the Arrow type list.

13 Click Apply to generate the plot.
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To generate Figure 4-45, continue with the following steps:

1 Clear the Arrow plot check box, then click the Slice tab.

2 From the Predefined quantities list, select 
Convection and Diffusion (chcd)>Concentration, c.

3 On the General page, select 1e-10 from the Parameter value list. Click OK.

Generate Figure 4-52 the same way as Figure 4-45, except use the parameter value 
1e-11.

P H Y S I C S  S E T T I N G S — S T U D Y  2

1 From the Multiphysics menu, select 1 Incompressible Navier-Stokes (mmglf).

2 From the Physics menu, select Subdomain Settings.

3 Change the viscosity expression to eta*(1+alpha*c^2). Click OK.

C O M P U T I N G  T H E  S O L U T I O N — S T U D Y  2

When the viscosity is concentration dependent you must solve all equations 
simultaneously.

1 Click the Solver Manager button on the Main toolbar.

2 On the Solve For page, select Geom1 (3D) from the Solve for variables list. Click OK.

3 Click the Solver Parameters button on the Main toolbar.

4 From the Solver list, select Stationary. Click OK.

5 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N — S T U D Y  2

Finally, generate Figure 4-53 and Figure 4-54 with the following steps:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, select the Arrow check box in the Plot type area.

3 Click the Slice tab.

4 In the Predefined quantities list, select Incompressible Navier-Stokes (mmglf)> 
Velocity field.

5 In the Unit list, select mm/s, then click Apply to generate Figure 4-53.

6 In the Predefined quantities list, select 
Convection and Diffusion (chcd)>Concentration, c.

7 On the General page, clear the Arrow check box in the Plot type area.
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8 Click OK to close the dialog box and generate Figure 4-54.
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I n k j e t  Mode l

Inkjet printers are attractive tools for printing text and images because they combine 
low cost and high resolution with acceptable speed. The working principle behind 
inkjet technology is to eject small droplets of liquid from a nozzle onto a sheet of paper. 
Important properties of a printer are its speed and the resolution of the final images. 
Designers can vary several parameters to modify a printer’s performance. For instance, 
they can vary the inkjet geometry and the type of ink to create droplets of different 
sizes. The size and speed of the ejected droplets are also strongly dependent on the 
speed at which ink is injected into the nozzle. Simulations can be very useful to 
improve the understanding of the fluid flow and to predict the optimal design of an 
inkjet for a specific application.

Although initially invented to produce images on paper, the inkjet technique has since 
been adopted for other application areas. Instruments for the precise deposition of 
microdroplets often employ inkjets. These instruments are used within the life sciences 
for diagnosis, analysis, and drug discovery. Inkjets have also been used as 3D printers 
to synthesize tissue from cells and to manufacture microelectronics. For all of these 
applications it is important to be able to accurately control the inkjet’s performance.

This example demonstrates how to use the Level Set Two-Phase Flow, Laminar 
application mode available in the MEMS Module to model the fluid flow within an 
inkjet. The application mode uses the Navier-Stokes equations to describe the 
momentum transport and conservation of mass. Surface tension is included in the 
momentum equations. A reinitialized, conservative level set method represents and 
moves the interface between the air and ink.

Model Definition

Figure 4-55 shows the geometry of the inkjet studied in this example. Because of its 
symmetry you can use an axisymmetric 2D model. Initially, the space between the inlet 
and the nozzle is filled with ink. Additional ink is injected through the inlet during a 
period of 10 µs, and it consequently forces ink to flow out of the nozzle. When the 
injection stops, a droplet of ink snaps off and continues to travel until it hits the target.
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Figure 4-55: Geometry of the inkjet.

TR A N S P O R T  O F  M A S S  A N D  M O M E N T U M

The Navier-Stokes equations describe the transport of mass and momentum for fluids 
of constant density. It is possible to model both ink and air as being incompressible as 
long as the fluid velocity is small compared to the speed of sound. In this model, you 
must add a term to account for surface tension. The Navier-Stokes equations with 
surface tension are

Here, ρ denotes density (kg/m3), µ equals the dynamic viscosity (Ns/m2), u 
represents the velocity (m/s), and p denotes pressure (Pa). Fst is the surface tension 
force, which is

where I is the identity matrix, n is the interface normal, σ equals the surface tension 
coefficient (N/m), and δ equals a Dirac delta function that is nonzero only at the fluid 
interface.

Inlet

Nozzle

Outlet

Target

ρ
t∂

∂u u u∇⋅+⎝ ⎠
⎛ ⎞ ∇ µ ∇u ∇uT+( )( ) ∇p+⋅– Fst=

∇ u⋅( ) 0=

Fst ∇ T⋅=

T σ I nnT( )–( )δ=
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The following table gives the physical parameters of ink and air:

R E P R E S E N T A T I O N  A N D  C O N V E C T I O N  O F  T H E  F L U I D  I N T E R F A C E

In this model you use a reinitialized, conservative level set method to describe and 
convect the interface. The 0.5 contour of the level set function  defines the interface, 
where equals 0 in air and 1 in ink. In a transition layer close to the interface, goes 
smoothly from 0 to 1. The normal to the interface is

The interface moves with the fluid velocity, u, at the interface. The following equation 
describes the reinitialized convection of the level set function:

 (4-23)

The thickness of the transition layer is proportional to ε. For this model you can use 
ε = 2h, where h is the mesh size. You then obtain a sharper interface in the regions 
where the mesh is finer. In this example you use a structured mesh. For unstructured 
meshes, avoid letting ε depend on h.

The parameter γ determines the amount of reinitialization. If the velocity gradients are 
small at the fluid interface you can choose γ = 1. In this example the velocity gradients 
at the interface are significant, and you must therefore choose a larger value for γ to 
keep the thickness of the transition layer constant. 

The application mode uses the level set function to smooth the density and viscosity 
jump across the interface by letting

To simplify the calculation of the surface tension force the delta function is 
approximated by

MEDIUM DENSITY DYNAMIC VISCOSITY SURFACE TENSION 

ink 103 kg/m3 0.01 Ns/m2 0.07 N/m

air 1.225 kg/m3 1.789·10-5 Ns/m2

φ
φ φ

n ∇φ
∇φ

----------=

φ∂
t∂

------ ∇ φu( )⋅ γ ∇ φ 1 φ–( ) ∇φ
∇φ
----------⎝ ⎠

⎛ ⎞⋅⎝ ⎠
⎛ ⎞ ε∇ ∇φ⋅–+ + 0=

ρ ρair ρink ρair–( )φ+=

µ µair µink µair–( )φ+=

δ 6 φ 1 φ–( ) φ∇=
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I N I T I A L  C O N D I T I O N S

Figure 4-56 shows at t = 0, that is, the initial distribution of ink and air. The velocity 
is initially 0.

Figure 4-56: Initial distribution of ink. Black corresponds to ink and white corresponds to 
air.

B O U N D A R Y  C O N D I T I O N S

Inlet
The inlet velocity in the z direction increases from 0 to the parabolic profile

during the first 2 µs. The velocity is then v(r) for 10 µs and finally decreases to 0 for 
another 2 µs. You can obtain this effect by using the smooth step function H(t – δ1 ,δ2), 
which is 0 for t > δ1 − δ2, increases from 0 to 1 as t goes from δ1 − δ2 to δ1 + δ2, and 
it is 1 for t > δ1 + δ2 as shown in Figure 4-57. 

φ

v r( ) 4.5 r 1 10 4–⋅+
2 10 4–⋅

----------------------------⎝ ⎠
⎛ ⎞ 1 r 1 10 4–⋅+

2 10 4–⋅
----------------------------–⎝ ⎠

⎛ ⎞=
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Figure 4-57: Smooth step function f(t) = H(t – δ1,δ2).

The time-dependent velocity profile in the z direction can then be defined as

where t is given in seconds.

For the level set equation, use  as the boundary condition.

Outlet
Set a constant pressure at the outlet. The value of the pressure given here is not 
important because the velocity depends only on the pressure gradient. You thus obtain 
the same velocity field regardless of whether the pressure is set to 1 atm or to 0.

Walls
On all other boundaries except the target, set no-slip conditions. If you use a no-slip 
condition at the target, the interface cannot move along the boundary. Therefore, use 
instead the wetted wall condition. The wetted wall boundary conditions allows a small 
amount of slip, according to 

where λ is the slip length, in this example 1·10−5 m. Where the fluid interface attaches 
to the wall, the angle between the fluid interface and the wall (the contact angle) is 
assumed to be π/2.

δ1

1

0 δ2

t

f(t)

δ2

v r t,( ) H t 1 10 6–⋅– 1, 10 6–⋅( ) H t 13 10 6–⋅ 1 10 6–⋅,–( )–( ) v r( )⋅=

φ 1=

u λ
z∂

∂u
–=
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Results and Discussion

Figure 4-58 and Figure 4-59 show the ink surface and the velocity field at different 
times. The droplet hits the target after approximately 140 µs.

Figure 4-58: Position of air/ink interface and velocity field at various times.

t = 0 s t = 10 µs

t = 20 µs t = 30 µs

t = 40 µs t = 60 µs
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Figure 4-59: Position of air/ink interface and velocity field at various times.

Figure 4-60 illustrates the mass of ink that is further than 0.7·10−3 m from the inlet. 
The figure shows that the mass of the ejected droplet is approximately 2.0·10−10 kg.

t = 80 µs t = 100 µs

t = 120 µs t = 140 µs

t = 160 µs t = 180 µs
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Figure 4-60: Amount of ink just above the nozzle.

This example studies only one inkjet model, but it is easy to modify the model in 
several ways. You can, for example, change properties such as the geometry or the inlet 
velocity and study the influence on the size and the speed of the ejected droplets. You 
can also investigate how the inkjet would perform if the ink were replaced by a 
different fluid. It is also easy to add forces such as gravitation to the model.

Modeling in COMSOL Multiphysics

You can easily set up the model using the application mode Level Set Two-Phase flow, 
Laminar. This application mode sets up the equations automatically, and you need only 
specify physical parameters of the fluids and initial and boundary conditions.

Use a structured mesh and refine it in the regions where the fluid interface passes. 

The simulation involves two computations. First, you calculate the initial level set 
function. Then you store the solution, switch the Analysis Type to Transient, and start 
the time-dependent simulation of the fluid motion.

To calculate the droplet’s mass, use an integration coupling variable. To visualize the 
droplet in 3D, revolve the 2D axisymmetric solution to a 3D geometry.
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Model Library path: MEMS_Module/Microfluidics_Models/inkjet

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 In the Model Navigator, go to the Space dimension list and select Axial symmetry (2D).

2 From the list of application modes, select  
MEMS Module>Microfluidics>Level Set and Laminar Flow. Click OK.

G E O M E T R Y  M O D E L I N G

1 From the Draw menu, select Specify Objects>Line.

2 Select Closed polyline (solid) from the Style list.

3 In the r edit field, enter 0 1e-4 1e-4 2.5e-5 2.5e-5 1e-4 1e-4 2e-4 2e-4 0, 
and in the z edit field 0 0 2e-4 5.75e-4 6e-4 6e-4 1.5e-3 1.5e-3 1.6e-3 
1.6e-3.

4 Click OK.

5 Click the Zoom Extents button on the Main toolbar.

6 Shift-click the Rectangle/Square button on the Draw toolbar. Type 1e-4 in the Width 
edit field, 2e-4 in the Height edit field, and 0 in both the r and the z edit field. Make 
sure Corner is selected in the Base list, then click OK.

7 Repeat the previous step three times to specify three more rectangles according to 
the following table: 

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

WIDTH HEIGHT BASE R Z

2.5e-5 2.5e-5 Corner 0 5.75e-4

2.5e-5 9e-4 Corner 0 6e-4

7.5e-5 1e-4 Corner 2.5e-5 1.5e-3
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2 Define the following constants (the descriptions are optional):

3 Click OK.

4 From the Options menu, select Expressions>Scalar Expressions.

5 Define the following expressions:

6 Click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 In the Model Tree, right-click Level Set and Laminar Flow (mmglf) and select 

Subdomain Settings.

Note: There are a number of different ways to open the Subdomain Settings and the 
Boundary Settings dialog boxes. This description assumes that you have the Model Tree 
visible in Overview mode. To open the Model Tree, click the Model Tree button on the 
Main toolbar, then click the Overview button on the toolbar at the top of the 
Model Tree.

NAME EXPRESSION DESCRIPTION

rhoair 1.225[kg/m^3] Density of air

rhoink 1e3[kg/m^3] Density of ink

etaair 1.7894e-5[Pa*s] Viscosity of air

etaink 1e-2[Pa*s] Viscosity of ink

sigma 0.07[N/m] Surface tension

lambdaslip 10[um] Slip length

NAME EXPRESSION DESCRIPTION

inletr 4.5[m/s]*((r[1/m]+1e-4)/2e-4)* 
(1-((r[1/m]+1e-4)/2e-4))

inlett flc2hs(t[1/s]-1e-6,1e-6)- 
flc2hs(t[1/s]-13e-6,1e-6)

inletvel inletr*inlett Inlet velocity
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2 Select Subdomain 1 and press Ctrl+A to select all the subdomains. Enter physical 
parameters according to the following table.

3 On the Sources/Sinks page, type sigma in the Surface tension coefficient edit field.

4 Click the Init tab. Select Subdomains 1, 2, and 3 and click the Fluid 2 button. These 
subdomains are initially filled with ink.

5 Click OK.

Boundary Conditions
1 In the Model Tree right-click Level Set and Laminar Flow (mmglf) and select Boundary 

Settings. Set boundary conditions according to the following table.

2 Select Boundary 8, then select the Interior boundaries check box. From the 
Boundary condition list, select Initial fluid interface.

3 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Mapped Mesh Parameters.

2 Click the Boundary tab.

QUANTITY VALUE/EXPRESSION DESCRIPTION

 ρ1 rhoair Density, fluid 1

 η1 etaair Dynamic viscosity, fluid 1

 ρ2 rhoink Density, fluid 2

 η2 etaink Dynamic viscosity, fluid 2

SETTINGS BOUNDARIES 
1, 3, 5, 7, 9

BOUNDARY 2 BOUNDARY 
24

BOUNDARIES 
11, 18, 23

BOUNDARIES 
12, 13, 15, 19, 
20, 22

Boundary 
type

Symmetry 
boundary

Inlet Outlet Wall Wall

Boundary 
condition

Axial 
symmetry

Velocity Pressure, no 
viscous 
stress

Wetted wall No slip

 U0 inletvel

 p0 0

0 1

 θ pi/2

 β lambdaslip

φ
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3 Select Boundaries 1, 2, 3, 5, 7, 9, 15, and 22, then select the Constrained edge 

element distribution check box. Next select each boundary separately and specify the 
Number of edge elements according to this table:

4 Click Remesh, then click OK.

C O M P U T I N G  T H E  S O L U T I O N

First reinitialize to obtain the correct shape of in the transition layer.

1 Click the Solver Parameters button on the Main toolbar.

2 On the General page, type 0 2e-6 in the Times edit field.

3 From the Linear system solver list, select Direct (PARDISO). While the solution times 
are comparable, the PARDISO solver is more memory efficient than the default 
linear system solver, UMFPACK.

4 Click OK.

5 Click the Solve button on the Main toolbar. This creates a good initial solution for 
the level set function.

Use the obtained solution as an initial condition to the simulation of the droplet 
motion.

1 Click the Solver Manager button on the Main toolbar.

2 On the Initial Value page, click the Store Solution button. Select the time 2e-6, then 
click OK.

3 In the Initial value area, select Stored solution.

4 From the Solution at time list, select 2e-6. Click OK.

5 Click the Solver Parameters button on the Main toolbar.

6 On the General page, type 0:1e-5:2e-4 in the Times edit field. Click OK.

7 From the Physics menu, select Properties. Change the Analysis type to Transient, then 
click OK.

8 Click the Solve button on the Main toolbar.

Boundary 1 2 3 5 7 9 15 22

Number of edge elements 10 10 8 10 180 20 20 10

φ φ
I N K J E T  M O D E L  |  401



402 |  C H A P T E
Note: The calculations take at least 4 hours. If you do not obtain a solution because 
of memory limitations in your computer, perform Steps 1–4 in the following list. Skip 
these steps if you do obtain a solution.

1 Click the Solver Parameters button on the Main toolbar.

2 From the Linear system solver list, select Direct (SPOOLES).

This solver uses less memory but is slightly slower compared to the UMFPACK 
solver.

3 Click the Advanced tab, then select the Store solution on file check box. Click OK.

4 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To visualize the solution in 3D, perform these steps:

1 From the Draw menu, select Revolve.

2 In the Objects to revolve list, select all the elements (select any object and then press 
Ctrl+A). Click OK.

3 In the Model Tree, click Geom1 to return to the 2D model.

4 Select Options>Extrusion Coupling Variables>Subdomain Variables.

5 Select any subdomain and then press Ctrl+A to select all the subdomains.

6 In the Name edit field, type phi3d, and in the Expression edit field type phi.

7 Click the General transformation option button.

8 Type vel3d in the Name edit field on the second row and sqrt(u^2+v^2) in the 
corresponding Expression edit field.

9 Select General transformation for this variable as well.

10 Click the Destination tab. In the Geometry list, select Geom2. In the Level list, select 
Subdomain.

11 Select any subdomain then press Ctrl+A to select all the subdomains.

12 Select the Use selected subdomains as destination check box.

13 In the x edit field, type sqrt(x^2+z^2).

14 From the Variable list, select phi3d.

15 Select the Use selected subdomains as destination check box and type 
sqrt(x^2+z^2) in the x edit field. Click OK.
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16 From the Solve menu, select Update Model.

17 Click the Plot Parameters button on the Main toolbar.

18 On the General page, clear the Geometry edges check box and select the Isosurface 
check box.

19 Clear the Auto check box for Element refinement, then type 4 in the associated edit 
field.

20 Click the Slice tab. In the Expression edit field, type vel3d; in the x levels edit field, 
type 0; and in the z levels edit field, type 1.

21 Click the Isosurface tab. In the Expression edit field, type phi3d. Select 
Vector with isolevels, then type 0.5 in the corresponding edit field.

22 Click the Uniform color option button, then click the Color button. Choose a gray 
color to plot the ink/air interface. Click OK.

23 Click the General tab. In the Solution at time list, select 0. Click OK to plot the initial 
position of the interface.

24 Click the Scene Light button on the Camera toolbar.

25 To plot the solution at other times, click the Plot Parameters button and select other 
values from the Solution at time list. Click Apply to plot the solution at the 
corresponding time.

26 Click OK.

Go through the following steps to calculate the mass of the ejected droplet.

1 Click the Geom1 tab.

2 Choose Options>Integration Coupling Variables>Subdomain Variables.

3 Select one of the subdomains, then press Ctrl+A to select them all.

4 In the first Name edit field, type mass_droplet. In the corresponding Expression 
field, type rhoink*phi*(z>7e-4)*2*pi*r. Click OK.

5 From the Solve menu, select Update Model.

6 From the Postprocessing menu, select Global Variables Plot.

7 In the Expression edit field, type mass_droplet, then click the 
Add Entered Expression button (the one marked >).

8 Click OK to generate the plot.
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F i l l i n g  o f  a  C ap i l l a r y  Chann e l

Introduction

Surface tension and wall adhesive forces are often used to transport fluid through 
microchannels in MEMS devices or to measure, transport and position small amounts 
of fluid using micropipettes. Multiphase flow through a porous medium and droplets 
on solid walls are other examples where wall adhesion and surface tension strongly 
influence the dynamics of the flow.

To model the adhesive forces at the walls correctly, the treatment of the boundary 
conditions is important. If you fix the velocity to zero on the walls, the interface cannot 
move along the walls. Instead, you need to allow a non-zero slip velocity and to add a 
frictional force at the wall. With such a boundary condition, it is possible to explicitly 
set the contact angle, that is, the angle between the fluid interface and the wall. The 
correct value of the contact angle depends on properties of the fluids and the wall. You 
can determine the contact angle experimentally or calculate it from the surface energies 
related to the different phase interfaces using Young’s law.

This example studies a narrow vertical cylinder placed on top of a reservoir filled with 
water. Because of wall adhesion and surface tension at the air/water interface, water 
rises through the channel. The model calculates the pressure field, the velocity field, 
and the water surface’s shape and position. It uses a level set method to track the air/
water interface and shows how to add friction and specify the contact angle at the 
channel walls.

Model Definition

The model consists of a capillary channel of radius 0.15 mm attached to a water 
reservoir. Water can flow freely into the reservoir. Because both the channel and the 
reservoir are cylindrical, you can use the axisymmetric model illustrated in Figure 4-61. 
Initially, the thin cylinder is filled with air. The wall adhesion causes water to creep up 
along the cylinder boundaries. The deformation of the water surface induces surface 
tension at the air/water interface, which in turn creates a pressure jump across the 
interface. The pressure variations cause water and air to move upward. The fluids 
continue to rise until the capillary forces are balanced by the gravity force that builds 
up as the water rises in the channel. In the present example, the capillary forces 
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dominate over gravity throughout the simulation. Consequently, the interface moves 
upwards during the entire simulation.

Figure 4-61: Axisymmetric geometry description.

M A S S  A N D  M O M E N T U M  TR A N S P O R T

The Navier-Stokes equations describe the transport of mass and momentum for fluids 
of constant density. In order to account for capillary effects, it is crucial to include 
surface tension in the model. The Navier-Stokes equations are then

Here, ρ denotes the density (kg/m3), η equals the dynamic viscosity (Ns/m2), u 
represents the velocity (m/s), p denotes the pressure (Pa), and g is the gravity vector 
(m/s2). Fst is the surface tension force that acts at the air/water interface and is
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hydrostatic pressure

ρ
t∂
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Here, I is the identity matrix, n is the interface normal, σ equals the surface tension 
coefficient (N/m), and δ equals a Dirac delta function that is nonzero only at the fluid 
interface. When you use the finite element method to solve the Navier-Stokes 
equations, you multiply the equations by test functions and then integrate over the 
computational domain. If you use integration by parts, you can move derivatives of T 
to the test functions. This is used in the Level Set and Laminar Flow application mode 
and results in an integral over the computational domain plus a boundary integral of 
the form

,  (4-24)

where θ is the contact angle (see Figure 4-62). If you apply a no-slip boundary 
condition, the boundary term vanishes because test(u) = 0 on that boundary, and you 
cannot specify the contact angle. Instead, the interface remains fixed on the wall. 
However, if you allow a small amount of slip, it is possible to specify the contact angle. 
The Wetted wall boundary condition adds the term given by Equation 4-24 and 
consequently allows you to set the contact angle.

R E P R E S E N T A T I O N  A N D  C O N V E C T I O N  O F  T H E  F L U I D  I N T E R F A C E

The Level Set Two-Phase Flow, Laminar application mode automatically sets up the 
equations for the convection of the interface, calculates normal and curvature of the 
interface, and adds surface tension and gravitation to the Navier-Stokes equations.

The application mode represents the interface as the 0.5 contour of the level set 
function . In air, and in water . You can thus think of the level set 
function as the volume fraction of water. The transport of the interface is given by

The application mode uses the level set function to smooth the density and viscosity 
jump across the interface by letting

The delta function is approximated by

T σ I nnT( )–( )δ=

test u( ) σ nwall n θcos( )–( )δ[ ]⋅ Sd
∂Ω
∫

φ φ 0= φ 1=

φ∂
t∂

------ ∇ φu( )⋅ γ ∇ φ 1 φ–( ) ∇φ
∇φ

----------⎝ ⎠
⎛ ⎞⋅⎝ ⎠

⎛ ⎞ ε∇ ∇φ⋅–+ + 0=

ρ ρair ρwater ρair–( )φ+=

µ µair µwater µair–( )φ+=
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and the interface normal is calculated from

I N I T I A L  C O N D I T I O N S

Initially, the reservoir is filled with water and the capillary channel is filled with air. The 
initial velocity is zero.

B O U N D A R Y  C O N D I T I O N S

Inlet
The hydrostatic pressure, p = ρgz, gives the pressure at the inflow boundary. Only 
water enters through the inlet, so the level set function, that is, the volume fraction of 
water, is 1 here.

Outlet
At the outlet, the pressure is equal to zero, that is, equal to the pressure at the top of 
the inflow boundary. Because it is an outflow boundary, you do not have to set any 
condition on the level set function.

Walls
The boundary condition Wetted wall is suitable for solid walls in contact with a fluid 
interface. It sets the velocity component normal to the wall to zero, that is,

and adds a frictional boundary force

Here, β is the slip length. The boundary condition also allows you to specify the 
contact angle θ, that is, the angle between the wall and the fluid interface (see 
Figure 4-62 according to “Mass and Momentum Transport” on page 405). In this 
example, the contact angle is 67.5° and the slip length equals the mesh element size, h.

δ 6 φ 1 φ–( ) φ∇=

n ∇φ
∇φ
----------=

u nwall⋅ 0=

Ffr
η
β
---– u=
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Figure 4-62: Definition of the contact angle θ.

Results and Discussion

Figure 4-63 shows the interface and the velocity field at different times. Initially, the 
shape of the interface changes dynamically (see Figure 4-64). After about 0.6 ms the 
shape of the water surface remains constant and forms a rising concave meniscus. Note 
that the slip velocity at the walls is almost zero, except close to the fluid interface/wall 
contact point.

Air

Water

Wall
θ
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Figure 4-63: Interface and velocity field at different times.

Figure 4-64 shows how the interface dynamically deforms during the first 0.2 ms as a 
result of the surface tension at the water surface.

t = 0

t = 1.0 mst = 0.8 mst = 0.6 ms

t = 0.4 mst = 0.2 ms
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Figure 4-64: Snapshots of the position of the interface during the first 0.2 ms.
R  4 :  M I C R O F L U I D I C S  M O D E L S



Figure 4-65 shows the pressure profile at t = 0.6 ms. At the fluid interface there is a 
pressure jump of roughly 300 Pa. The jump is caused by the surface tension, and forces 
water and air to rise through the channel.

Figure 4-65: Pressure at t = 0.6 ms.

You can easily calculate the position of the interface/wall contact point by integrating 
the level set function along the thin cylinder wall. Figure 4-66 shows the position of 
the contact point as a function of time. After 0.6 ms, the contact point moves with an 
almost constant speed.

Figure 4-66: Position of the interface/wall contact point as a function of time. The velocity 
is approximately constant after t = 0.6 ms.

Finally, you can verify the obtained contact angle. It is defined by cos θ = nTnwall.
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In this case, the normal to the wall is nwall = (1, 0). The contact angle is thus 
θ = acos  nr, where nr is the radial component of the interface normal. At t = 0.6 ms, 
the contact angle is 1.16 rad = 66°, which can be compared with the imposed contact 
angle of 3π/8 = 1.18 = 67.5°. The contact angle approaches the imposed value if you 
refine the mesh further.

Figure 4-67: Plot of acos(nr). At the wall, this gives the contact angle. In this case 
θ = 1.16 rad = 66°. 

Modeling in COMSOL Multiphysics

It is straightforward to set up the model with the Level Set Two-Phase Flow, Laminar 
application mode. At the walls in contact with the fluid interface, use the Wetted wall 
boundary condition.

Model Library path:  
MEMS_Module/Microfluidics_Models/capillary_filling

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 In the Model Navigator, go to the Space dimension list and select Axial symmetry (2D).

2 From the list of application modes, select  
MEMS Module>Microfluidics>Level Set Two-Phase Flow, Laminar.
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3 In the Application mode name edit field, type twophase, then click OK.

G E O M E T R Y  M O D E L I N G

1 Shift-click the Rectangle/Square button on the Draw toolbar. Type 3e-4 in the Width 
edit field, 1.5e-4 in the Height edit field, 0 in the r edit field, and -1.5e-4 in the 
z edit field. Click OK. Click the Zoom Extents button on the Main toolbar.

2 Create another rectangle with these settings: 

3 Click the Zoom Extents button on the Main toolbar.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

2 Define the following constants:

3 Click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 In the Model Tree, right-click Level Set Two-Phase Flow, Laminar (twophase) and select 

Subdomain Settings.

Note: There are a number of different ways to open the Subdomain Settings and the 
Boundary Settings dialog boxes. This description assumes that you have the Model Tree 
visible in Overview mode. To open the Model Tree click the Model Tree button on the 
Main toolbar, then click the Overview button on the toolbar at the top of the Model 

Tree.

WIDTH HEIGHT BASE R Z

1.5e-4 5e-4 Corner 0 0

NAME EXPRESSION DESCRIPTION

theta (3*pi/8)[rad] Contact angle

p_ref 1e5[Pa] Reference pressure

T_ref 293[K] Temperature

sigma 0.073[N/m] Surface tension coefficient

g 9.81[m/s^2] Acceleration due to gravity
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2 Press Ctrl and select both subdomains. In the Fluid 1 area, click the Load button. 
Select Liquids and Gases>Gases>Air, 1 atm from the Materials list and click OK. 

3 Click the Load button in the Fluid 2 area. Select Liquids and Gases>Liquids>Water, 

liquid and click OK. 

4 For both fluids, replace p and T in the expressions for the Dynamic viscosity and 
Density by p_ref and T_ref.

5 Go to the Sources/Sinks page. Type sigma in the Surface tension coefficient edit field 
and -g in the Gravity, z component edit field.

6 Click the Init tab. Select Subdomain 1 and select the option button Fluid 2.

7 Click OK.

Boundary Conditions
1 In the Model Tree right-click Level Set Two-Phase Flow, Laminar (twophase) and select 

Boundary Settings.

2 Assign boundary conditions for the exterior boundaries according to the following 
table.

3 Select Boundary 4 and select the Interior boundaries check box. Select the boundary 
condition Initial fluid interface.

4 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu select Mapped Mesh Parameters.

2 Select both subdomains and select Extremely fine from the Predefined mesh sizes list.

3 Click the Mesh Selected button, then click OK.

SETTINGS BOUNDARIES 1, 3 BOUNDARY 8 BOUNDARY 5 BOUNDARIES 6, 7

Boundary 
type

Symmetry 
boundary

Inlet Outlet Wall

Boundary 
condition

Axial symmetry Pressure, no 
viscous stress

Pressure, no 
viscous stress

Wetted wall

 p0 rho_twophase*z* 
gz_twophase

0

 0 1

 θ theta

 β h

φ
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C O M P U T I N G  T H E  S O L U T I O N

First reinitialize to obtain the correct shape of in the transition layer.

1 From the Solve menu select Solver Parameters.

2 Click the General tab and enter 1e-3 in the Times edit field. Click OK.

3 Click the Solve button on the Main toolbar. This creates a good initial solution to 
the level set function.

Use the obtained solution as an initial condition to the simulation of the droplet 
motion.

1 Click the Solver Manager button on the Main toolbar.

2 Click the Store Solution button. Select the time 0.001. Click OK.

3 In the Initial value area click the Stored solution option button.

4 Select 0.001 from the Solution at time list, then click OK.

5 Click the Solver Parameters button on the Main toolbar.

6 Click the General tab, then enter 0:0.25e-4:1e-3 in the Times edit field. Click OK.

7 From the Physics menu, select Properties.

8 Change the Analysis type to Transient, then click OK.

9 Click the Solve button on the Main toolbar.

Note: The calculations take 2–3 hours.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, clear the Surface check box and select the Contour and Arrow 
check boxes.

3 On the Contour page, go to the Contour levels area and click the Vector with isolevels 

option button. Type 0.5 in the corresponding edit field.

4 Click the Arrow tab. From the Predefined quantities list on the Subdomain Data page, 
select Velocity field. In the Number of points edit field for z points, type 30.

5 Click Apply.

φ φ
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6 On the General page, select a value from the Solution at time list and then click Apply 
to visualize the result at the corresponding value. Repeat to view the solution at 
other times.

7 Click OK.

8 To create a movie from the plots at the different times, click the Animate button on 
the Plot toolbar.

To create filled contour plots as in Figure 4-64, perform the following steps:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, clear the Arrow check box in the Plot type area.

3 On the Contour page, select the Filled check box.

4 Click OK.

Next, create the pressure plot in Figure 4-65.

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, clear the Contour check box and select the Surface check box 
in the Plot type area. In the Solution to use area, select 6e-4 from the Solution at time 
list.

3 Click the Surface tab. From the Predefined quantities list on the Surface Data page, 
select Pressure.

4 Click OK.

Follow the next steps to calculate and plot the position of the contact point as in 
Figure 4-66.

1 From the Options menu, select Integration Coupling Variables>Boundary Variables.

2 Select Boundary 6. Type cont_pos in the Name edit field on the first row of the 
table and phi in the corresponding Expression edit field. Click OK.

3 From the Solve menu, select Update Model.

4 From the Postprocessing menu, select Global Variables Plot.

5 Type cont_pos in the Expression edit field, then click the Add Entered Expression 
button next to the edit field. Click OK to generate the plot.

Finally, check the obtained contact angle.

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, clear the Surface check box and select the Contour check box 
in the Plot type area.
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3 Click the Contour tab. On the Color Data page, click the Color data option button.

4 Clear the Filled check box.

5 In the Expression edit field, type acos(normr_twophase), then click OK.
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Hyd r o c a r b on Deha l o g e n a t i o n  i n  a  
T o r t u ou s  M i c r o r e a c t o r

Introduction

Removing halogen groups from hydrocarbons is an important reaction step in several 
chemical processes. One application is water purification. Other examples involve 
organic synthesis, where the removal of halogen groups serves as a starting point for 
carbon-carbon coupling reactions. Typically, the carbon-halogen bond scission is 
activated by precious metal catalysts based on platinum or palladium.

The model presented here shows hydrocarbon dehalogenation as it occurs in a 
microreactor. The reactants are transported from the fluid bulk to the catalytic surfaces 
at the reactor walls, where they react. A first model is set up in Reaction Engineering 
Lab, where two competing reactions are analyzed. Subsequently, the reaction kinetics 
are exported to the MEMS Module, where a space-dependent model of the 
microreactor is set up and solved.

Note: This model requires the COMSOL Reaction Engineering Lab and the MEMS 
Module.

Model Definition

The adsorption of halogenated hydrocarbons onto the surface of a platinum catalyst 
leads to cleavage of the carbon halogen bond. The hydrocarbon fragments then 
undergo either hydrogenation or coupling reactions. Figure 4-68 illustrates the overall 
reactions for a brominated hydrocarbon species.

 (4-25)

Figure 4-68: The dehalogenation of RBr can result either in hydrogenation or coupling of 
the hydrocarbon fragments.

R-H
k1R-Br

[Pt]

R-R2R-Br
k2

[Pt]
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The reaction rates are:

 (4-26)

and

 (4-27)

where the rate constants are given by the Arrhenius expression:

 (4-28)

In Equation 4-28, A is the frequency factor, and E the activation energy (J/mol). The 
table below lists the values of the Arrhenius parameters for the two reactions.

I D E A L  R E A C T O R  M O D E L

The mass balance equation for a flow-through reactor is given by

 (4-29)

where F is the molar flow rate (mol/s), V the reactor volume (m3), and Ri the net 
reaction term (mol/(m3· s)). If the reactor has constant cross-section and constant 
flow velocity, the left hand side of Equation 4-29 can be rewritten as

 (4-30)

The reactor mass balance thus becomes

 (4-31)

where τ represents the residence time (s). The assumption of constant flow velocity is 
valid for incompressible liquids or liquids where the effect of temperature on the 
density is small. Equation 4-31 is identical to the balance equation of the batch reactor, 

TABLE 4-5:  ARRHENIUS PARAMETERS

FREQUENCY 
FACTOR

ACTIVATION 
ENERGY

Reaction 1 2e-3 10e3

Reaction 2 1e-3 30e3

r1 k1cRBr=

r2 k2cRBr
2

=

kj Aj
Ej

RgT
------------–

⎝ ⎠
⎜ ⎟
⎛ ⎞

exp=

dFi

dV
--------- Ri=

dFi

dV
--------- u

dci

dx
--------

dci

dτ
--------= =

dci

dτ
-------- Ri=
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except that residence time replaces the reaction time. You can therefore make use of 
the Batch reactor type when solving the model in the Reaction Engineering Lab.

The ideal reactor model assumes by default that reactions take place in the entire 
reactor volume. In the 3D microreactor model, reactions occur at catalytic surfaces 
located at the reactor walls. In order to make the ideal model represent a reactor with 
surface reactions, Equation 4-31 has to be scaled by the reactive area per reactor 
volume. Scaling the ideal reactor equations by the dimensions of the microreactor 
makes the 1D and 3D models comparable. The area to volume ratio is

 (4-32)

where W is the width of the channel (m), H the channel height (m), and L the length 
of a reactive section (m). The scaled ideal reactor equation is then

 (4-33)

Note that the net reaction term (Ri) in this case represents surface reactions 
(mol/(m2· s)).

S P A C E - D E P E N D E N T  M O D E L

The microreactor considered in this example consists of a tortuous channel, fitted with 
inlet and outlet adapter sections, as illustrated in Figure 4-69. 

Figure 4-69: Microreactor geometry.
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In the straight sections of the reactor, the channel walls are in part coated with 
platinum catalyst. As water with small amounts of a brominated hydrocarbon flows 
through the reactor, dehalogenation reactions occur at the catalytic surfaces. 

M O M E N T U M  B A L A N C E S

The flow in the channel is described by the Navier-Stokes equations:

 (4-34)

where ρ denotes density (kg/m3), u represents the velocity (m/s), η denotes viscosity 
(kg/(m· s)), and p equals pressure (Pa).

A pressure difference drives the flow through the reactor, as indicated by the boundary 
conditions

 (4-35)

Each pressure condition is specified along with a vanishing viscous stress condition at 
the boundary

At the wall the velocity is zero

 (4-36)

M A S S  B A L A N C E S

The mass balances set up and solved are the diffusion-convection equations at steady 
state:

 (4-37)

where Di denotes the diffusion coefficient (m2/s), ci is the species concentration 
(mol/m3), and u equals the velocity vector (m/s).

No reactions take place in the fluid bulk. Rather, the reactions take place on the 
catalytic surfaces. The boundary fluxes at the catalytic surfaces thus become

 (4-38)

∇ η– ∇u ∇u( )T
+( ) pI+[ ]⋅ ρ u ∇⋅( )u–=

∇ u⋅ 0=

p pinlet= inlet

p 0= outlet

η ∇u ∇u( )T
+( )n 0=

u 0= walls

∇ Di∇– ci ciu+( )⋅ 0=

n Di∇– ci ciu+( )⋅ Ri=
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where Ri represents the reaction term. Note that these boundary conditions are set up 
automatically as you export the reaction kinetics from the Reaction Engineering Lab 
to COMSOL Multiphysics.

Inlet conditions are equal to the inlet concentrations

 (4-39)

At the outlet, you can set the convective flux condition, assuming that the transport of 
mass across the boundary is dominated by convection

 (4-40)

All other boundaries use the insulating condition

 (4-41)

Results

First review the results of the ideal reactor model, which you set up and solve in the 
Reaction Engineering Lab.

Figure 4-70 through Figure 4-72 show concentration profiles of reactant and 
products as function of residence time, evaluated at 288 K, 343 K, and 363 K.

Figure 4-70: Concentration of the RBr, RH, and RR species as function of residence time. 
Reactions occur at 288 K.

c cin=

n D∇– c( )⋅ 0=

n D∇– c cu+( )⋅ 0=
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Figure 4-71: Concentration of the RBr, RH, and RR species as function of residence time. 
Reactions occur at 343 K.

Figure 4-72: Concentration of the RBr, RH, and RR species as function of residence time. 
Reactions occur at 363 K.

The hydrocarbon coupling reaction has the higher activation energy and is hence more 
temperature sensitive than the hydrogenation reaction (see Table 4-5). The 
concentration plots of the ideal reactors outline the effect quite clearly. At 288 K, the 
hydrogenation product RH is dominant, while at 363 K the coupling product is the 
more prominent. Notably, at 343 K, the concentration dependency on the reaction 
rates becomes accentuated, so that RBr dominates only at shorter τ and RH at longer 
τ.
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Although the primary goal may be to remove the halogenated reactant, RBr, it may 
also be important to set reaction conditions in such a way that the most favorable 
by-product is formed. The present model shows how such design aspects can readily 
be investigated in the Reaction Engineering Lab.

The next set of results refer to the space-dependent model of a tortuous microreactor, 
set up and solved in COMSOL Multiphysics.

Figure 4-73 shows the velocity of the laminar flow field in the reactor. The flow is 
driven by a pressure difference of 1500 Pa between inlet and outlet. The resulting 
maximum velocity is close to 5 mm/s.

Figure 4-73: Velocity field in the reactor where the pressure difference between inlet and 
outlet is 1500 Pa.
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Figure 4-74 shows the concentration distribution of the reactant RBr in the reactor. 
At relatively low temperature, 288 K, the outlet concentration is 10.6 mol/m3.

Figure 4-74: Concentration distribution of the halogenated reactant RBr. Fluid 
properties and reaction rates are evaluated at 288 K.

Running the reactor at 363 K, the outlet concentration of RBr is still 6.7 mol/m3.

Figure 4-75: Concentration distribution of the halogenated reactant RBr. Fluid 
properties and reaction rates are evaluated at 363 K.

Judging from the results of the ideal reactor models, a more pronounced temperature 
effect would be expected. The reason for this apparently moderate influence on 
conversion is that the increased temperature also affects the flow.
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Raising the temperature from 282 K to 363 K decreases the viscosity of water from 
1.36·10−3 to 3.17·10−4. This is automatically taken into account by the temperature 
dependent fluid properties. As the flow through the reactor is driven by a constant 
pressure difference, the velocity will increase as viscosity decreases. Results show that 
the maximum fluid velocity at 363 K is ~3.6 times greater than at 282 K, resulting in 
a shorter residence time.

The following path shows the location of the COMSOL Multiphysics model:

Model Library path: MEMS_Module/Microfluidics_Models/tortuous_reactor

Modeling Using COMSOL Multiphysics

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics by clicking the desktop icon.

2 Select 3D from the Space dimension list.

3 In the list of application modes select MEMS Module>Microfluidics>Incompressible 

Navier-Stokes.

4 Click OK.

G E O M E T R Y  M O D E L I N G

Select the menu item File>Import CAD Data From File. Browse to the file 
tortuous_reactor.mphbin and click Import.

P H Y S I C S  S E T T I N G S

Subdomain Settings—Incompressible Navier-Stokes
1 Choose Physics>Subdomain Settings.

2 In the Subdomain selection list, select all subdomains by pressing Ctrl+A and clicking 
the list.

3 Go to the Material/Coefficients Library by clicking the Load button.

4 Browse to Liquids and Gases>Liquids>Water, liquid and click OK to load the 
properties.

5 Click OK.
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Boundary Conditions—Incompressible Navier-Stokes
1 Choose Physics>Boundary Settings.

2 Enter the following boundary conditions:

Leave all other boundaries at their default setting (Wall, No slip).

3 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 Choose Options>Constants then enter the following data:

2 Click OK.

M E S H  G E N E R A T I O N

1 Select the menu item Mesh>Free Mesh Parameters.

2 On the Global page select Finer from the Predefined mesh sizes list.

3 Click the Boundary page, select Boundary 8, and click the Mesh Selected button.

4 Choose Mesh>Swept Mesh Parameters.

5 Select Subdomains 2–19 and 21 from the Subdomain selection list by pressing Ctrl 
and clicking the list.

6 Click the Mesh Selected button.

7 Click OK to close the Swept Mesh Parameters dialog.

8 Go to the Free Mesh Parameters dialog, and click the Subdomain page.

9 Select Subdomains 1 and 20 from the Subdomain selection list by pressing Ctrl and 
clicking the list.

10 Click the Mesh Selected button.

SETTINGS BOUNDARY 6 BOUNDARY 104

Boundary type Inlet Outlet

Boundary condition Pressure, no 
viscous stress

Pressure, no 
viscous stress

p0 delta_p 0

NAME EXPRESSION DESCRIPTION

delta_p 1.5[kPa] Inlet overpressure

T 288[K] Temperature
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11 Click OK to close the Free Mesh Parameters dialog box.

C O M P U T I N G  T H E  S O L U T I O N

1 Solve the problem by clicking the Solve button (=) on the Main toolbar.

2 Select the menu item Solve>Solver Manager.

3 Press the Store Solution button and the click OK.

P O S T P R O C E S S I N G  T H E  S O L U T I O N

The following steps reproduce Figure 4-73:

1 Choose Postprocessing>Plot Parameters.

2 On the Slice page, select the Slice plot check box.

3 Type 0 in the x-levels edit field and 1 in the z-levels edit field.

4 Click OK.

Modeling Using the COMSOL Reaction Engineering Lab

1 In the main user interface of COMSOL Multiphysics, choose 
File>Reaction Engineering Lab.

The main user interface of COMSOL Reaction Engineering Lab opens up.

2 Click the COMSOL Reaction Engineering Lab window.

O P T I O N S  A N D  S E T T I N G S

1 Click the Model Settings button on the Main toolbar.

2 On the General page type 288 in the Temperature edit field.

3 Click Close.
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4 Choose Model>Constants then enter the following data:

5 Click OK.

R E A C T I O N S  I N T E R F A C E

1 Click the Reaction Settings button on the Main toolbar.

2 Make sure the Reactions page is active. Create two entries in the Reaction selection 

list by clicking the New button twice.

3 Enter the following reaction formulas by first selecting the appropriate row in the 
Reaction selection list and then entering the corresponding text in the Formula edit 
field.

4 Select row 1 from the Reaction selection list.

5 Select the Use Arrhenius expression check box.

6 Enter 2e-3 in the A edit field and 10e3 in the E edit field.

7 Select row 2 from the Reaction Selection list.

8 Select the Use Arrhenius expression check box.

9 Enter 1e-1 in the A edit field and 30e3 in the E edit field.

10 Select Reaction 1 from the Reaction selection list and type kf_1*c_RBr/H in the r 
edit field. 

11 Select Reaction 2 from the Reaction selection list and type kf_2*c_RBr^2/H in the 
r edit field.

You have now modified the automatically generated reaction rates by dividing with 
the scale factor H, according to Equation 4-33.

S P E C I E S  I N T E R F A C E

1 Click the Species tab.

2 Select RBr from the Species selection list and type 50 in the c0 edit field.

3 Click Close.

NAME EXPRESSION DESCRIPTION

H 5e-6 Reactor channel height (m)

REACTION ID # REACTION FORMULA

1 RBr=>RH

2 2RBr=>RR
H Y D R O C A R B O N  D E H A L O G E N A T I O N  I N  A  TO R T U O U S  M I C R O R E A C T O R  |  429



430 |  C H A P T E
C O M P U T I N G  T H E  S O L U T I O N

1 Open the Simulation>Solver Parameters dialog box.

2 Type 1 in the Times edit field.

3 Click OK.

4 Click the Solve Problem button (=) on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The results of Figure 4-70 are shown in the default plot. To generate the results shown 
in Figure 4-71 follow these steps.

1 Click the Model Settings button on the Main toolbar.

2 On the General page type 343 in the Temperature edit field.

3 Click Close.

4 Click the Solve Problem button.

To generate the results shown in Figure 4-72:

1 Click the Model Settings button on the Main toolbar.

2 On the General page type 363 in the Temperature edit field.

3 Click Close.

4 Click the Solve Problem button.

E X P O R T  S E T T I N G S

You will now proceed to export the reaction kinetics to the reacting boundaries in the 
Multiphysics model. Recall that the rate constants are temperature dependent. To 
export a temperature variable while only exporting mass balances, follow these steps:

1 Click the Model Settings button on the Main toolbar.

2 On the General page type Temp in the Temperature edit field.

3 Click Close.

This will export a variable name Temp rather than a constant temperature, which would 
otherwise be the case.

Recall also that the reaction rates were scaled in order to make the 1D ideal reactor 
comparable to the 3D microreactor. As you are about to export the reaction kinetics 
to the 3D model, the effect of the scaling should first be removed.
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1 Choose Model>Constants then set the scaling factor H to 1:

2 Click OK.

Now, move on to export the reaction model.

1 Click the Export to COMSOL Multiphysics button on the Main toolbar.

2 The Export to COMSOL Multiphysics dialog box appears.

3 Select Boundary in the Domain level drop down list.

4 Go to the Export mass balance area, and in the Application mode list select Convection 

and Diffusion: New.

5 In the Group name edit field type reactions.

6 Move to the Export energy balance area and clear the check box in the upper left 
corner.

7 Click the Export button at the bottom of the dialog box.

Modeling Using COMSOL Multiphysics

It is now time to investigate the chemistry taking place in a space-dependent model.

Click the COMSOL Multiphysics window.

Subdomain Settings—Convection and Diffusion
1 From the Multiphysics menu select Convection and Diffusion (chcd).

2 From the Physics menu select Subdomain Settings.

3 In the Subdomain selection list, select all subdomains by pressing Ctrl+A and clicking 
the list.

4 On the c_RBr page type the following:

5 Type in the same entries on the c_RH page and the c_RR page.

NAME EXPRESSION DESCRIPTION

H 1 reactor channel height (m)

EDIT FIELD VALUE

Diffusion coefficient D

x-velocity u

y-velocity v

z-velocity w
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6 Click OK.

Boundary Conditions—Convection and Diffusion
1 From the Physics menu select Boundary Settings.

2 In the Boundary selection list, select 27, 41, 57, 71, and 87 by pressing Ctrl and 
clicking the entries. These boundaries represent the reactive surfaces.

3 Select reactions from the Group list.

This associates the exported kinetics from Reaction Engineering Lab with the 
catalytic surfaces. The Flux boundary condition is automatically set on all mass 
balance pages, and the appropriate reaction terms appear in the Inward flux edit 
fields.

4 Enter the remaining boundary conditions for each of the species c_RBr, c_RH, and 
c_RR according to the following table:

5 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu select Constants.

2 Add entries to complete the list of constants as follows:

3 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Select the menu item Solve>Solver Manager.

SETTINGS BOUNDARY 6 BOUNDARY 104 ALL OTHERS

Boundary 
condition

Concentration Convective flux Insulation/Symmetry

c_RBr0 50

c_RH0 0

c_RR0 0

NAME EXPRESSION DESCRIPTION

delta_p 1.5[kPa] Inlet overpressure

T 288[K] Temperature

D 1e-6[m^2/s]*exp(-2000[K]/T) Diffusivity

Temp T Temperature
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2 In the Values of variables not solved for and linearization point, click the Stored 
solution option button.

3 Click the Solve For tab.

4 Select only the Convection and Diffusion (chcd) folder in the Solve for variables tree.

5 Click OK.

6 Solve the problem by clicking the Solve button (=) on the Main toolbar.

PO S T P R O C E S S I N G  T H E  S O L U T I O N

The following steps reproduce Figure 4-74:

1 Choose Postprocessing>Plot Parameters.

2 On the Boundary page, select the Boundary plot check box.

3 Type c_RBr in the Expression edit field.

4 Click OK.

To reproduce the results in Figure 4-75, change the variable T in the Constants dialog 
box to 363[K], and solve for the flow and mass balances as outlined above.
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M o d e l s  o f  P i e z o e l e c t r i c  D e v i c e s
The piezoelectric effect is a transfer of electric energy to mechanical energy and 
vice versa. It arises in many crystalline materials, and some of them—for example, 
quartz, Rochelle salt, and lead titanate zirconate ceramics—display the 
phenomenon strongly enough that it can be useful.

The direct piezoelectric effect consists of an electric polarization in a fixed direction 
when the piezoelectric crystal is deformed. The polarization is proportional to the 
deformation and causes an electric potential difference over the crystal. 

The inverse piezoelectric effect, on the other hand, constitutes the opposite of the 
direct effect. This means that an applied electric field induces a deformation of the 
crystal.

The following models show the application of the MEMS Module for modeling 
piezoelectric effects in a static linear analysis:

• An axisymmetric example of a piecoceramic tube that models both the direct and 
the inverse piezoelectric effect

• A 3D shear bender example modeling the inverse piezoelectric effect

• A 3D model of a composite piezoelectric transducer
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P i e z o c e r am i c  Tub e

Introduction

This example performs a static 2D axisymmetric analysis of a piezoelectric actuator 
using the 2D Piezo Axial Symmetry application mode. It models a radially polarized 
piezoelectric tube as described by S. Peelamedu and others (Ref. 1). One application 
area where radially polarized tubes are employed is in nozzles for fluid control in inkjet 
printers.

Model Definition

G E O M E T RY

The tube has a height of 0.62 mm and an inner and outer radius of 0.38 mm and 
0.62 mm, respectively.

M A T E R I A L

The material properties for the piezoceramic (PZT-5H) are:

c

127 80.2 84.7 0 0 0
127 84.7 0 0 0

117 0 0 0
23.0 0 0

sym 23.0 0
23.5

GPa=

e
0 0 0 0 17.03448 0
0 0 0 17.03448 0 0

6.22812– 6.22812– 23.– 2403 0 0 0

  C/m2
=

ε
1.5 0 0
0 1.5 0
0 0 1.3

10 8–   F/m⋅=
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B O U N D A R Y  C O N D I T I O N S

This model studies two cases, each of which studies different boundary conditions. 
Case 1 represents the inverse piezoelectric effect, and case 2 represents the direct 
piezoelectric effect.

Case 1:

• Structural mechanics boundary condition—constrain the bottom surface from 
moving axially (in the z-direction).

• Electrostatics boundary condition—apply a 1 V potential difference between the 
tube’s inner and outer surfaces.

Case 2:

• Structural mechanics boundary condition—constrain the bottom surface from 
moving axially (in the z direction), but also add an internal fluid pressure of 
0.1 MPa.

• Electrostatics boundary condition—ground the inner and outer surfaces.
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Results and Discussion

The image in Figure 5-1 shows the deformation due to the applied voltage difference 
in Case 1. For the same case, Figure 5-2 shows the radial displacement as a function of 
the tube thickness at the top boundary. 

Figure 5-1: The deformed shape and radial displacement of a piezoceramic-tube actuator 
due to the radial electric field for Case 1.
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Figure 5-2: The radial displacement as a function of the tube thickness due to the radial 
electric field (Case 1).

For the second case, Figure 5-3 shows the deformed shape in Case 2. For that same 
case, Figure 5-4 shows the radial displacement as a function of tube thickness. These 
results show good agreement with those from S. Peelamedu (Ref. 1).
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Figure 5-3: The deformed shape and radial displacement in a piezoceramic-tube 
actuatordue to an internal pressure of 0.1 MPa (Case 2).
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Figure 5-4: The radial displacement as function of the tube thickness due to an internal 
pressure of 0.1 MPa (Case 2).

Modeling in COMSOL Multiphysics

C O N S T I T U T I V E  E Q U A T I O N  A N D  M A T E R I A L  D A T A

You specify the material parameters for the piezoelectric material in the 
Subdomain Settings dialog box in the piezoelectric application mode. Then select the 
stress-charge form for the constitutive equation because this suits the form in which 
you give the material data. Further, enter the elasticity matrix into the ce matrix, enter 
the piezoelectric coupling matrix into the e matrix, and enter the relative permittivities 
into the εrS matrix.

You enter the material properties in this example such that the polarization is in the 
z direction (in a 3D Cartesian coordinate system), which is a common orientation for 
published material data. This orientation means that you must rotate the material so 
that its polarization direction is aligned with the r-direction (radially polarized). To do 
so, use the material-orientation feature in the Piezo Axial Symmetry application mode. 
By selecting the material orientation as the zx-plane, you rotate the material so that its 
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z direction is aligned with the r direction of the model, and the material’s x direction 
is aligned with the model’s z direction.

The piezoceramic material in this example (PZT-5H) is a transversely isotropic 
material, which is a special class of orthotropic materials. Such a material has the same 
properties in one plane (isotropic behavior) and different properties in the direction 
normal to this plane. Thus you can use either the zx-plane material orientation or the 
zy-plane material orientation; both give the same solution.

M E S H I N G

The rectangular geometry is well suited for quadrilaterals, and the model uses a 
6-by-6-element grid.

Reference

1. S. Peelamedu et al., Numerical Approach for Axisymmetric Piezoceramic 
Geometries towards Fluid Control Applications, Univ. Toledo, OH, Mechanical, 
Industrial and Manufacturing Engineering Dept., 2000.

Model Library path: MEMS_Module/Piezo_Models/piezoceramic_tube

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics. This invokes the Model Navigator, which you can also 
open from an already running COMSOL Multiphysics session by choosing New 

from the File menu.

2 Select Axial Symmetry (2D) from the Space dimension list.

3 Select MEMS Module>Structural Mechanics>Piezo Axial Symmetry>Static analysis from 
the list of application modes.

4 Click OK to close the Model Navigator. Note that this gives you second-order 
elements, Lagrange - Quadratic, by default.

G E O M E T RY  M O D E L I N G

Define the model geometry in Draw mode.
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1 Shift-click the Rectangle/Square button in the Draw toolbar to open the Rectangle 
dialog box.

2 Type 0.24e-3 in the Width edit field and 0.62e-3 in the Height edit field. In the 
Position area, type 0.38e-3 in the r edit field and 0 in the z edit field. This creates a 
rectangle with opposite corners at (0.38e-3, 0) and (0.62e-3, 0.62e-3).

3 Click the Zoom Extents button.

P H Y S I C S  S E T T I N G S  F O R  M O D E L  C A S E  1

Boundary Conditions
1 Open the Boundary Settings dialog box by choosing Boundary Settings from the 

Physics menu.

2 Select Boundary 2 from the Boundary selection list.

3 Select Roller from the Constraint condition list on the Constraint page.

4 Select all boundaries by pressing Ctrl+A.

5 Select Zero charge/Symmetry from the Boundary condition list on the Electric BC page.

6 Select Boundary 1 and then select Ground from the Boundary condition list.

7 Select Boundary 4 and then select Electric potential from the Boundary condition list 
and type 1 in the Electric potential edit field.

8 Click OK to close the dialog box.
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Subdomain Settings
1 Open the Subdomain Settings dialog box by selecting Subdomain Settings from the 

Physics menu.

2 Select Subdomain 1 and click the Structural tab.

3 Select zx plane from the Material orientation list.

4 Click the Edit button associated with cE and enter the following values into the 
Elasticity matrix dialog box; when done, click OK. 

Entries for the elasticity matrix.

1.27e11 8.02e10 8.47e10 0 0 0

1.27e11 8.47e10 0 0 0

1.27e11 0 0 0

2.30e10 0 0

2.30e10 0

2.30e10
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5 Click the Edit button associated with e and enter the following values into the 
Coupling matrix dialog box; when done, click OK. 

Entries for the coupling matrix.

6 Click the Edit button associated with εrS and enter the following values into the 
Relative permittivity matrix dialog box; when done, click OK. 

Entries for the relative permittivity matrix.

7 Click OK again to close the Subdomain Settings dialog box.

M E S H  G E N E R AT I O N

1 From the Mesh menu choose Mapped Mesh Parameters.

2 Click the Boundary tab.

3 Select Boundary 1 and click the Constrained edge element distribution button.

4 Enter 6 in the Number of edge elements edit field.

0 0 0 0 17.03448 0

0 0 0 17.03448 0 0

-6.22812 -6.22812 -23.2403 0 0 0

1694

1694

1468
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5 Repeat this for the remaining three boundaries.

6 Click the Remesh button.

The meshed geometry for the piezoceramic-tube actuator.

7 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.
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PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Choose Plot Parameters from the Postprocessing menu to open the Plot Parameters 
dialog box.

2 On the General page, find the Plot type area, then select the Deformed shape and 
Surface check boxes.

3 Click the Surface tab.

4 Select r-displacement from the Predefined quantities list and click OK (this step 
reproduces Figure 5-1).

5 Choose Cross-Section Plot Parameters from the Postprocessing menu.

6 Click the Line/Extrusion tab.

7 Select r-displacement from the Predefined quantities list.

8 Go to the Cross-section line data area. In the r0 edit field enter 3.8e-4. Similarly set 
r1 to 6.2e-4 and then both z0 and z1 to 3e-4.

9 Click OK (this step reproduces Figure 5-2).

P H Y S I C S  S E T T I N G S  F O R  M O D E L  C A S E  2

Boundary Conditions
1 Open the Boundary Settings dialog box by selecting Boundary Settings from the 

Physics menu. In this dialog box you can select boundaries and enter expressions for 
boundary conditions.

2 Select Boundary 1 from the Boundary selection list.

3 Enter 0.1e6 in the Fr edit field on the Load page.

4 Select Boundaries 1 and 4 and then select Ground from the Boundary condition list 
on the Electric BC page.

5 Select Boundaries 2 and 3 and then select Zero charge/Symmetry from the Boundary 

condition list on the Electric BC page.

6 Click OK to close the dialog box.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Choose Plot Parameters from the Postprocessing menu to open the Plot Parameters 
dialog box.
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2 On the General page select the Deformed shape and Geometry edges check boxes in 
the Plot type area.

3 Click the Surface tab and select r-displacement from the Predefined quantities list and 
click OK (this reproduces Figure 5-3).

4 Choose Cross-Section Plot Parameters from the Postprocessing menu.

5 Click the Line/Extrusion tab.

6 Select r-displacement from the Predefined quantities list.

7 Go to the Cross-section line data area. In the r0 edit field enter 3.8e-4. Similarly set 
r1 to 6.2e-4 and then both z0 and z1 to 3e-4.

8 Click OK (this reproduces Figure 5-4).
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P i e z o e l e c t r i c  S h e a r  A c t u a t e d  Beam

Introduction

This example performs a static analysis on a piezoelectric actuator based on the 
movement of a cantilever beam, using the static 3D Piezo Solid application mode. 
Inspired by work done by V. Piefort (Ref. 1) and A. Benjeddou (Ref. 2), it models a 
sandwich beam using the shear mode of the piezoelectric material to deflect the tip.

Model Definition

G E O M E T R Y

The model consists of a sandwiched cantilever beam 100 mm long; it consists of a rigid 
foam core 2 mm thick sandwiched by two 8-mm thick aluminum layers. Further, the 
device replaces part of the foam core with a 10-mm long piezoceramic actuator that is 
positioned between z = 55 mm and z = 65 mm (Figure 5-5). The cantilever beam is 
orientated along the x-axis.

Figure 5-5: In this geometry for the shear bender note that a piezoceramic material 
replaces part of the foam core.

B O U N D A R Y  C O N D I T I O N S

• The structural mechanics boundary conditions for this model are that the cantilever 
beam is fixed at its surfaces at x = 0 and that all other surfaces are free.

• The electrostatic boundary conditions for this model are that the system applies a 
20 V potential difference between the top and bottom surfaces of the piezoceramic 
subdomain. This gives rise to an electric field perpendicular to the poling direction 
(x-direction) and thus induces a transverse shear strain.

x
y

z
Aluminum

Foam
Piezoceramic

Aluminum

Foam
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M A T E R I A L  P R O P E R T I E S

The following table lists the material properties for the aluminum layers and the foam 
core:

The matrices later in the section contain the material properties for the piezoceramic 
(PZT-5H): cE is the elasticity matrix, e is the piezoelectric coupling matrix, and ε is the 
absolute permittivity matrix.

Note that it is necessary to recalculate the absolute permittivity matrix using the 
permittivity of vacuum ε0 to the relative permittivity matrix.

Note also that the order of the material properties is such that the polarization 
direction is in the z direction. The polarization direction of the piezoceramic material 
in this model is however aligned with the x-axis and thus a local coordinate system 
must be used in the material settings to rotate the piezoceramic material.

PROPERTY ALUMINUM FOAM

E 70 GPa 35.3 MPa

ν 0.345 0.383

ρ 2690 kg/m3 32 kg/m3

cE

126 79.5 84.1 0 0 0
126 84.1 0 0 0

117 0 0 0
23.0 0 0

sym 23.0 0
23.3

 GPa=

e
0 0 0 0 17 0
0 0 0 17 0 0
6.5– 6.5– 23.3 0 0 0

  C/m2
=

ε
1.503 0 0

0 1.503 0
0 0 1.3

10 8–   F/m⋅=
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Results

The shear deformation of the piezoceramic core layer and the flexible foam layer 
induce the bending action. Figure 5-6 shows the resulting tip deflection. The model 
calculates this deflection as 83 nm, which is in good agreement with the work in 
Ref. 1 and Ref. 2.

Figure 5-6: Tip deflection with the piezoceramic positioned at z = 60 mm.

Modeling in COMSOL Multiphysics

C O N S T I T U T I V E  E Q U A T I O N  A N D  M A T E R I A L  D A T A

You specify the material parameters for the piezoelectric material in the Subdomain 

Settings dialog box in the corresponding piezoelectric application mode. You select the 
stress-charge form for the constitutive equation because it suits the form in which you 
give the material data. Enter data for the elasticity matrix into the ce matrix; enter data 
for the piezoelectric coupling matrix into the e matrix; and enter the relative 
permittivities into the εrs matrix.
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You must also define a local coordinate system that is rotated 90 degrees about the 
y-axis. Then use this coordinate system n the piezoelectric material settings in order to 
rotate the material so that the poling direction is aligned with the x-axis.

M E S H I N G

The thin central core that holds the piezoelectric actuator and the foam normally 
creates a relatively dense isotropic mesh. You can avoid this situation by scaling the 
mesh in the z direction with a factor of three. Doing so reduces the degrees of freedom 
from approximately 85,000 to 23,000 (by a factor of approximately 3.7) and hence it 
reduces both the solution time and memory requirements.

References

1. V. Piefort, Finite Element Modelling of Piezoelectric Active Structures, Ph.D. 
thesis, Université Libre de Bruxelles, Belgium, Dept. Mechanical Engineering and 
Robotics, 2001.

2. A. Benjeddou and others, A Unified Beam Finite Element Model for Extension 
and Shear Piezoelectric Actuation Mechanisms, CNAM (Paris, France), Structural 
Mechanics and Coupled Systems Laboratory, 1997.

Model Library path: MEMS_Module/Piezo_Models/shear_bender

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics. This invokes the Model Navigator, which you can also 
open from an already running COMSOL Multiphysics session by choosing New 
from the File menu.

2 On the New page select 3D from the Space dimension list.

3 Click the Multiphysics button, then select MEMS 

Module>Structural Mechanics>Piezo Solid>Static analysis from the list of application 
modes.

4 Click OK to close the Model Navigator.

Note that this gives you second-order elements, Lagrange - Quadratic, by default.
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G E O M E T R Y  M O D E L I N G

Define the model geometry in draw mode:

1 Draw a block by first clicking the Block button on the Draw toolbar and then 
entering the following parameters in the Block dialog box:

2 Draw a second block by clicking the Block button and entering the following 
parameters:

3 Draw a third block by clicking the Block button and entering the following 
parameters:

4 Click the Zoom Extents button on the Main toolbar.

LENGTH EXPRESSION

X 0.1

Y 0.03

Z 0.018 

LENGTH EXPRESSION

X 0.1

Y 0.03

Z 0.002

AXIS BASE POINT EXPRESSION

x 0

y 0

z 0.008

LENGTH EXPRESSION

X 0.01

Y 0.03

Z 0.002

AXIS BASE POINT EXPRESSION

x 0.055

y 0

z 0.008
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The basic geometry of the shear-actuated beam consisting of three blocks.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu choose Coordinate Systems.

2 In the Coordinate System Settings dialog box click the New button, then click OK in 
the New Coordinate System dialog box to use the default coordinate name.

3 Click the General tab. Click the Define using global coordinates option button, then 
click the Rotation angle method option button.
R  5 :  M O D E L S  O F  P I E Z O E L E C T R I C  D E V I C E S



4 In the x, y, z rotation angles edit fields type 0, 90, and 0, respectively, then click OK 
to close the dialog box.

Configuring the coordinate system.

The material properties for the foam and the aluminum are specified in the Materials/

Coefficients Library dialog box:

1 From the Options menu choose Materials/Coefficients Library.

2 Click the New button.

3 Change the Name to Aluminum and specify the following set of material parameters:

PARAMETER EXPRESSION/VALUE DESCRIPTION

E 70e9 Young’s modulus 

nu 0.345 Poisson’s ratio

rho 2690 Density
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4 Click Apply.

Material property values for aluminum.

5 Click the New button.
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6 Change the Name to Foam and specify the following set of material parameters:

Material property values for foam.

7 Click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 Open the Subdomain Settings dialog box by choosing Subdomain Settings from the 

Physics menu. Go to the Structural page.

2 Select Subdomains 1 and 3 from the Subdomain selection list.

3 Select Decoupled, isotropic from the Material model list.

4 Select Aluminum from the Library material list; then click Apply.

5 Select Subdomains 2 and 5 from the Subdomain selection list.

PARAMETER EXPRESSION/VALUE DESCRIPTION

E 35.3e6 Young’s modulus

nu 0.383 Poisson’s ratio

rho 32 Density
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6 Select Decoupled, isotropic from the Material model list.

7 Select Foam from the Library material list; then click Apply.

8 Select Subdomain 4.

9 Select Coordinate system 1 from the Coordinate system list.

10 Click the Edit button associated with cE and enter the following values into the 
Elasticity matrix dialog box; when complete, click OK. 

Entries for the elasticity matrix.

11 Click the Edit button associated with e and enter the following values into the 
Coupling matrix, stress-charge form dialog box; when complete, click OK. 

Entries for the coupling matrix.

126e9 79.5e9 84.1e9 0 0 0

126e9 84.1e9 0 0 0

117e9 0 0 0

23e9 0 0

23e9 0

23e9

0 0 0 0 17 0

0 0 0 17 0 0

-6.5 -6.5 23.3 0 0 0
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12 Click the Edit button associated with εrs and enter the following values into the 
Relative permittivity matrix, stress-charge form dialog box; when complete, click OK. 

Entries for the relative permittivity matrix.

13 Click OK.

Boundary Conditions
1 Open the Boundary Settings dialog box by selecting Boundary Settings from the 

Physics menu.

2 Activate the Interior boundaries check box.

3 Fix the beam by selecting the following boundary condition on the Constraint page:.

4 Select Boundaries 14–19 from the Boundary selection list.

5 Go to the Electric BC page and select Zero charge/Symmetry from the Boundary 

condition list on the Electric BC page.

6 Select Boundary 16 and Electric potential from the Boundary condition list and enter 
20 in the Electric potential edit field.

7 Select Boundary 17 and Ground from the Boundary condition list.

8 Click OK to close the dialog box.

M E S H  G E N E R AT I O N

1 From the Mesh menu choose Free Mesh Parameters.

2 Click the Advanced tab.

3 Type 3 in the z-direction scale factor edit field.

4 Click Remesh, then click OK.

1698 0 0

1698

1468

SETTING BOUNDARIES 1, 4, 7

Constraint condition Fixed
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P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Before computing the solution change the default plot to display a boundary plot 
using the deformed shape:

1 From the Postprocessing menu choose Plot Parameters.

2 On the General page clear the Slice check box, then select the Boundary check box 
and the Deformed shape check box.

3 Click the Boundary tab and select Piezo Solid (smpz3d)>z-displacement from the 
Predefined quantities list.

4 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

To start computing the solution, click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N ,  C O N T I N U E D

Figure 5-6 on page 451 shows the resulting plot.
R  5 :  M O D E L S  O F  P I E Z O E L E C T R I C  D E V I C E S



Compo s i t e  P i e z o e l e c t r i c  T r a n s du c e r

Introduction

This example shows how to set up a piezoelectric transducer problem following the 
work of Y. Kagawa and T. Yamabuchi (Ref. 1). The composite piezoelectric ultrasonic 
transducer has a cylindrical geometry that consists of a piezoceramic (NEPEC 6) layer, 
two aluminum layers, and two adhesive layers. The layers are organized as follows: 
aluminum layer—adhesive layer—piezoceramic layer—adhesive layer—aluminum 
layer.

The system applies an AC potential on the electrode surfaces of both sides of the 
piezoceramic layer. The potential in this example has a peak value of 1V in the 
frequency range 20 kHz to 106 kHz. The goal is to compute the susceptance (the 
imaginary part of the admittance) Y = I/V, where I is the total current and V is the 
potential, for a frequency range around the four lowest eigenfrequencies of the 
structure.

The first step finds the eigenmodes, and the second step runs a frequency sweep across 
an interval that encompasses the first four eigenfrequencies. Both analyses are fully 
coupled, and COMSOL Multiphysics assembles and solves both the electric and 
mechanical parts of the problem simultaneously.

The problem is axially symmetric, and you could analyze it using an axisymmetric 
application mode in 2D. However, in order to illustrate the modeling principles for 
more complicated problems, this example is in 3D.

When creating the model geometry, you make use of the symmetry by first making a 
cut along a midplane perpendicular to the central axis and then cutting out a 10 degree 
wedge. Doing so reduces memory requirements significantly.
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Results

Figure 5-7 shows the input admittance in the transducer as a function of the excitation 
frequency.

Figure 5-7: Input admittance as a function of excitation frequency

The result is in agreement with the work in Ref. 1. A small discrepancy close to the 
eigenfrequencies appears because the simulation uses no damping.

Reference

1. Y. Kagawa and T. Yamabuchi, “Finite Element Simulation of a Composite 
Piezoelectric Ultrasonic Transducer,” IEEE Transactions on Sonics and Ultrasonics, 
vol. SU-26, no. 2, pp. 81–88, 1979.

Model Library path: MEMS_Module/Piezo_Models/composite_transducer
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Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator and click the New tab. From the Space dimension list select 
3D.

2 In the list of application modes select MEMS Module>Structural Mechanics>Piezo 

Solid>Eigenfrequency analysis.

3 Click OK.

G E O M E T R Y  M O D E L I N G

1 From the Draw menu choose Work Plane Settings.

2 This model uses the default work plane at z = 0, so simply click OK. Doing so creates 
the work plane and opens a 2D drawing area.

3 Click the Ellipse/Circle (Centered) button on the Draw toolbar. Use the right mouse 
button to create a circle centered on the origin and with a radius of approximately 
1 (the exact size is not important).

4 Double-click the circle. In the Radius edit field enter 27.5e-3. Click OK.

5 Click the Zoom Extents button on the Main toolbar.

6 Click the Line button on the Draw toolbar. Draw a line from (0, 0) to (0.03, 0). Use 
the right mouse button to finish drawing lines.

7 Copy and paste the line onto itself with no displacements (either use Ctrl+C and 
Ctrl+V or use the Edit menu items).

8 Select the Rotate toolbar button from the Draw toolbar. In the Rotation angle edit 
field enter 10. Click OK.

9 Select all objects (press Ctrl+A).

10 Click the Coerce to Solid button on the Draw toolbar.

11 Click the Split Object button on the Draw toolbar. 

12 Select the larger object and press the Delete key.
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13 Click the Zoom Extents button on the Main toolbar.

Geometry for the composite piezoelectric transducer.

M E S H  G E N E R AT I O N

This model uses prism elements by extruding a triangular mesh.

1 Click the Initialize Mesh button on the Main toolbar.

2 From the Mesh menu select Extrude Mesh.

3 In the Distance edit field enter 5e-3 5.275e-3 15.275e-3 (being careful to 
separate the entries with a space). Click OK. This step extrudes a mesh with three 
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domains corresponding to the piezoceramic (Subdomain 1), the adhesive layer 
(Subdomain 2), and the aluminum layer (Subdomain 3).

Extruding the mesh to create three subdomains.

The finalized mesh with the three subdomains. 
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O P T I O N S  A N D  S E T T I N G S

1 From the Options menu select Materials/Coefficients Library.

2 Click New.

3 Change the Name to Adhesive.

4 Enter these material properties; when done, click Apply.

5 Click the New button.

6 Change the name to Aluminum2.

7 Enter these material properties; when done, click OK. 

PARAMETER EXPRESSION/VALUE DESCRIPTION

E 1e10 Young’s modulus

nu 0.38 Poisson’s ratio

rho 1700 Density

PARAMETER EXPRESSION/VALUE DESCRIPTION

E 7.03e10 Young’s modulus

nu 0.345 Poisson’s ratio

rho 2690 Density
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Material values to enter for the aluminum.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Multiphysics menu select 1 Geom1: Piezo Solid (smpz3d).

2 From the Physics menu select Subdomain Settings and go to the Structural page.

3 From the Subdomain selection list choose 1. 

4 See that the Material Model list has value Piezoelectric, then in the Density edit field 
enter 7730.
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5 Click the Edit button associated with cE and enter the following values into the 
Elasticity matrix dialog box; when finished, click OK: 

Entries for the elasticity matrix.

6 Click the Edit button associated with e and enter the following values into the 
Coupling matrix, stress-charge form dialog box; when finished, click OK:  

Entries for the coupling matrix.

7 Click the Edit button associated with εrS and enter the following values into the 
Relative permittivity, stress-charge form dialog box; when finished, click OK:   

Entries for the relative permittivity matrix.

8 In the Subdomain selection list choose Subdomains 2 and 3.

9 From the Material Model list select Decoupled, isotropic.

10 In the Subdomain selection list choose 2.

12.8e10 6.8e10 6.6e10 0 0 0

12.8e10 6.6e10 0 0 0

11.0e10 0 0 0

2.1e10 0 0

2.1e10 0

2.1e10

0 0 0 0 0 0

0 0 0 0 0 0

-6.1 -6.1 15.7 0 0 0

993.53 0 0

993.53 0

993.53
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11 Select Adhesive from the Library material list.

12 In the Subdomain selection list choose 3.

13 Select Aluminium2 from the Library material list.

14 Click OK.

Boundary Conditions
The total potential difference between the two electrodes (only one modeled here) is 
1 V, but symmetry dictates that the potential is 0 V on the symmetry plane and 0.5 V 
on the electrode.

1 From the Physics menu choose Boundary Settings.

2 Activate the Interior boundaries check box.

3 In the Boundary selection list select all the boundaries (press Ctrl+A).

4 Go to the Electric BC page, find the Boundary condition list and select Zero charge/

Symmetry.

5 From the Boundary selection list choose Boundary 6.

6 In the Boundary condition list select Electric potential, and in the V0 edit field type 
0.5.

7 Select Boundary 3.

8 Change the boundary condition on the Electric BC page to Ground.

9 From the Boundary selection list choose Boundaries 1, 2, 3, 4, 5, 7, and 8.

10 Go to the Constraint page, and in the Constraint condition list select Symmetry plane.

The outer boundary is free to move, so you do not set any constraints.

11 Click OK.

C O M P U T I N G  T H E  E I G E N F R E Q U E N C Y  S O L U T I O N

Click the Solve button on the Main toolbar. 

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N  O F  T H E  E I G E N F R E Q U E N C I E S

The lowest eigenfrequency is at approximately 43 kHz.

1 To visualize the solution of the lowest eigenfrequency, open the Plot Parameters 

dialog box from the Postprocessing menu.

2 On the General page, clear the Slice check box.

3 On the Boundary page, select the Boundary plot check box and select Piezo Solid 

(smpz3d)>z-displacement (smpz3d) in the Predefined quantities list.
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4 On the Deform page, select the Deformed shape plot check box and see Piezo Solid 

(smpz3d)>Displacement in selected the Predefined quantities list.

5 Click OK to generate the visualization where you can see that the lowest 
eigenfrequency is at approximately 43 kHz. 

Visualization of the lowest eigenfrequency for the piezoelectric transducer.

C O M P U T I N G  T H E  F R E Q U E N C Y  R E S P O N S E  S O L U T I O N

Next sweep over a frequency range from 20 kHz to 106 kHz in steps of 2 kHz.

1 From the Physics menu select Properties.

2 In the Analysis type list select Frequency response. Click OK.

3 From the Solve menu select Solver Parameters.

4 On the General page see that the Parameter name edit field shows freq_smpz3d.

5 In the Parameter values edit field enter 20e3:2e3:106e3.

6 Click OK.

7 Click the Solve button on the Main toolbar.
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P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N  O F  T H E  F R E Q U E N C Y  R E S P O N S E

To compute the input admittance, use the current-density outflow variable, nJ, on the 
electrode surface. The total input current for the 10-degree wedge is then the surface 
integral of −imag(nJ) over one of the electrode surfaces. To obtain the total current 
for the entire structure, multiply the result by 360/10 = 36.

1 From the Options menu select Integration Coupling Variables>Boundary Variables.

2 In the Boundary selection list choose Boundary 6 (corresponding to the electrode 
surface).

3 In the top row enter I as the name of the integration variable, then in the Expression 
column enter -imag(nJ_smpz3d)*36. Click OK.

4 From the Solve menu select Update Model.

The coupling variable I has global scope, and you can access it anywhere in the 
geometry model (the mesh). Use a domain plot to plot the value of Y versus frequency.

1 From the Postprocessing menu select Domain Plot Parameters.

2 Go to the Point page.

3 In the Point selection area choose a point on the electrode surface (for this exercise, 
select 2).
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4 In the Expression edit field enter I/(2*V). Click OK to close the dialog box and plot 
the susceptance.

Plot of susceptance versus frequency for the piezoelectric transducer.

Recall that this example uses 0.5 V for the electrode potential but the overall potential 
difference is 1 V. Thus, to take symmetry into account, you must multiply the potential 
by 2.
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