HEAT TRANSFER MODULE

Version 3.4

COMSOL MULTIPHYSICS
# CONTENTS

## Chapter 1: Introduction
- Model Library Guide .......................................................... 2
- Typographical Conventions .................................................. 5

## Chapter 2: Electronics and Power-System Models
- Convection Cooling of Circuit Boards ................................. 8
  - Introduction ................................................................. 8
  - Model Definition .......................................................... 10
  - Results and Discussion ................................................... 12
  - References ...................................................................... 18
  - Modeling Using the Graphical User Interface—2D Natural Convection ........ 18
  - Modeling Using the Graphical User Interface—
    3D Natural Convection ...................................................... 22
  - Modeling Using the Graphical User Interface—
    3D Forced Convection ....................................................... 26
  - Model Definition .............................................................. 29
  - Results and Discussion ...................................................... 33
  - Modeling Using the Graphical User Interface—1D Plug Flow ............ 34
  - Modeling Using the Graphical User Interface—3D Model .............. 37

- Forced Turbulent Convection ............................................... 40
  - Introduction ................................................................. 40
  - Model Definition .............................................................. 41
  - Results for the Flow/Heat Model ........................................ 44
  - Results for the Simplified Model ....................................... 49
  - References ...................................................................... 51
  - Modeling in COMSOL Multiphysics ................................. 51
  - Modeling Using the Graphical User Interface—The Flow/Heat Model ... 51
  - Modeling Using the Graphical User Interface—Simplified Model ....... 58
<table>
<thead>
<tr>
<th>Chapter Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microchannel Heat Sink</td>
<td>61</td>
</tr>
<tr>
<td>Introduction</td>
<td>61</td>
</tr>
<tr>
<td>Model Definition</td>
<td>62</td>
</tr>
<tr>
<td>Adding Thermal Contact Resistance</td>
<td>64</td>
</tr>
<tr>
<td>Results and Discussion</td>
<td>67</td>
</tr>
<tr>
<td>References</td>
<td>69</td>
</tr>
<tr>
<td>Modeling Using the Graphical User Interface</td>
<td>70</td>
</tr>
<tr>
<td>Modeling Using the Graphical User Interface—Extended Model</td>
<td>75</td>
</tr>
<tr>
<td>Heat Transfer in a Surface-Mount Package for a Silicon Chip</td>
<td>77</td>
</tr>
<tr>
<td>Introduction</td>
<td>77</td>
</tr>
<tr>
<td>Model Definition</td>
<td>78</td>
</tr>
<tr>
<td>Results and Discussions</td>
<td>79</td>
</tr>
<tr>
<td>Modeling in COMSOL Multiphysics</td>
<td>81</td>
</tr>
<tr>
<td>Modeling Using the Graphical User Interface</td>
<td>82</td>
</tr>
<tr>
<td>Surface-Mount Resistor</td>
<td>89</td>
</tr>
<tr>
<td>Model Definition</td>
<td>89</td>
</tr>
<tr>
<td>Results and Discussion</td>
<td>92</td>
</tr>
<tr>
<td>References</td>
<td>94</td>
</tr>
<tr>
<td>Modeling Using the Graphical User Interface</td>
<td>95</td>
</tr>
<tr>
<td>Heating Circuit</td>
<td>102</td>
</tr>
<tr>
<td>Introduction</td>
<td>102</td>
</tr>
<tr>
<td>Model Definition</td>
<td>103</td>
</tr>
<tr>
<td>Results and Discussion</td>
<td>106</td>
</tr>
<tr>
<td>Modeling Using the Graphical User Interface</td>
<td>110</td>
</tr>
<tr>
<td>Rapid Thermal Annealing</td>
<td>118</td>
</tr>
<tr>
<td>Introduction</td>
<td>118</td>
</tr>
<tr>
<td>Model Definition</td>
<td>119</td>
</tr>
<tr>
<td>Results and Discussion</td>
<td>121</td>
</tr>
<tr>
<td>Reference</td>
<td>123</td>
</tr>
<tr>
<td>Modeling Using the Graphical User Interface</td>
<td>123</td>
</tr>
<tr>
<td>Thermo-Photo-Voltaic Cell</td>
<td>127</td>
</tr>
<tr>
<td>Introduction</td>
<td>127</td>
</tr>
<tr>
<td>Model Definition</td>
<td>129</td>
</tr>
</tbody>
</table>
### Chapter 4: Medical Technology Models

#### Tumor Removal

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>246</td>
</tr>
<tr>
<td>Model Definition</td>
<td>247</td>
</tr>
<tr>
<td>Results and Discussion</td>
<td>248</td>
</tr>
<tr>
<td>Reference</td>
<td>250</td>
</tr>
<tr>
<td>Modeling Using the Interface</td>
<td>250</td>
</tr>
</tbody>
</table>

#### Friction Stir Welding

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>206</td>
</tr>
<tr>
<td>Model Definition</td>
<td>207</td>
</tr>
<tr>
<td>Results and Discussion</td>
<td>209</td>
</tr>
<tr>
<td>References</td>
<td>209</td>
</tr>
<tr>
<td>Modeling Using the Interface</td>
<td>210</td>
</tr>
</tbody>
</table>

#### Continuous Casting

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>217</td>
</tr>
<tr>
<td>Model Definition</td>
<td>218</td>
</tr>
<tr>
<td>Results and Discussion</td>
<td>221</td>
</tr>
<tr>
<td>References</td>
<td>224</td>
</tr>
<tr>
<td>Modeling Using the Interface</td>
<td>225</td>
</tr>
</tbody>
</table>

#### Turbulent Flow Through a Shell-and-Tube Heat Exchanger

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>231</td>
</tr>
<tr>
<td>Model Definition</td>
<td>233</td>
</tr>
<tr>
<td>Results for the Flow/Heat Model</td>
<td>236</td>
</tr>
<tr>
<td>References</td>
<td>237</td>
</tr>
<tr>
<td>Modeling Using the Interface</td>
<td>237</td>
</tr>
</tbody>
</table>
## Microwave Cancer Therapy

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>261</td>
</tr>
<tr>
<td>Model Definition</td>
<td>261</td>
</tr>
<tr>
<td>Results and Discussion</td>
<td>265</td>
</tr>
<tr>
<td>Reference</td>
<td>267</td>
</tr>
<tr>
<td>Modeling in COMSOL Multiphysics</td>
<td>267</td>
</tr>
<tr>
<td>Modeling Using the Graphical User Interface</td>
<td>268</td>
</tr>
</tbody>
</table>

## INDEX

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>INDEX</td>
<td>275</td>
</tr>
</tbody>
</table>
The Heat Transfer Module Model Library consists of a set of models that simulate problems in various areas of heat transfer and other engineering disciplines where heat transfer plays an important role. Their purpose is to assist you in learning, by example, how to model sophisticated heat transfer processes. Through them you can tap the expertise of the top researchers in the field, examining how they approach some of the most difficult modeling problems you might encounter. You can thus get a feel for the power that COMSOL Multiphysics offers as a modeling tool. In addition to serving as a reference, the models can also give you a big head start if you are developing a model of a similar nature.

This book divides these models into three chapters:

- Electronics and power systems
- Process and manufacturing
- Medical technology

The models illustrate the application modes specific to the Heat Transfer Module, application modes unavailable in the base COMSOL Multiphysics package. These application modes come with their own graphical user interfaces that make it quick and easy to access their power. You can even modify them for custom requirements. COMSOL Multiphysics itself is very powerful and, with sufficient expertise in a
given field, you certainly could develop these modes by yourself—but why spend the hundreds or thousands of hours that would be necessary when our team of experts has already done the work for you?

Note that the model descriptions in this book do not contain every detail on how to carry out every step in the modeling process. Before tackling these in-depth models, we urge you to first read the other book in the Heat Transfer Module documentation set. Titled the Heat Transfer Module User’s Guide, it introduces you to the basic functionality in the module, covers basic modeling techniques, and includes reference material of interest to those working with problems involving heat transfer. The models it presents are far simpler than those in this Model Library and might be more appropriate for a first introduction to COMSOL Multiphysics.

In addition, to gain further information on how to work with the graphical user interface you can turn to the COMSOL Multiphysics User’s Guide or the COMSOL Multiphysics Quick Start and Quick Reference manual. An explanation on how to perform modeling with a programming language is available in the COMSOL Multiphysics Scripting Guide.

This Heat Transfer Module Model Library provides details about a large number of ready-to-run models that illustrate real-world uses of the software. Each entry comes with theoretical background as well as instructions that illustrate how to set it up. They come from our staff engineers, who have years of experience in heat transfer modeling. The terminology in the book should be familiar to you.

Finally, each example in the Heat Transfer Module Model Library as well as in the Heat Transfer Module User’s Guide comes with the software as a loadable COMSOL Multiphysics Model MPH-file (with the extension .mph). To find these files, start the Model Navigator, click the Model Library tab, and then look under the chapter headings listed earlier. These models are great to investigate if you are sufficiently familiar with COMSOL Multiphysics and its GUI but would like to learn more about how to set up a certain model. You can even use these entries as a starting point for your own models that are similar in nature.

Model Library Guide

The following table summarizes key information about the entries in this model library. The “Application Modes” column indicates which modes we chose to solve the model, and the subsequent column indicates the number of spatial dimensions in the model.
The solution time given is the elapsed time measured on a machine running Windows Vista with a 2.6 GHz AMD Athlon X2 Dual Core 500 CPU and 2 GB of RAM. For models with a sequential solution strategy, the “Solution Time” column shows the elapsed time for the longest solution step.

The next columns indicate if the model is stationary or time-dependent, which heat transfer mechanisms are involved, and if the model includes multiphysics.

<table>
<thead>
<tr>
<th>MODEL</th>
<th>PAGE</th>
<th>APPLICATION MODES</th>
<th>SPATIAL DIMENSIONS</th>
<th>SOLUTION TIME</th>
<th>STATIC</th>
<th>TIME-DEPENDENT</th>
<th>CONDUCTION</th>
<th>RADIATION</th>
<th>OUT-OF-PLANE</th>
<th>HIGHLY CONDUCTIVE LAYER</th>
<th>MULTIPHYSICS</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>ELECTRONICS AND POWER SYSTEMS</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Circuit board, forced 3D</td>
<td>8</td>
<td>General Heat Transfer, Weakly Compressible Navier-Stokes</td>
<td>3D</td>
<td>3 min</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Circuit board, natural 2D</td>
<td>8</td>
<td>General Heat Transfer, Weakly Compressible Navier-Stokes</td>
<td>2D</td>
<td>31 s</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Circuit board, natural 3D</td>
<td>8</td>
<td>General Heat Transfer, Weakly Compressible Navier-Stokes</td>
<td>3D</td>
<td>5 min</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Circuit board, simple 1D</td>
<td>29</td>
<td>General Heat Transfer</td>
<td>1D</td>
<td>1 s</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Circuit board, 3D h-coeff</td>
<td>29</td>
<td>General Heat Transfer</td>
<td>3D</td>
<td>17 s</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Forced turbulent convection</td>
<td>40</td>
<td>General Heat Transfer, k-ε Turbulence Model</td>
<td>2D</td>
<td>9 min</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Forced turbulent convection, simplified</td>
<td>40</td>
<td>General Heat Transfer</td>
<td>2D</td>
<td>1 s</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Microchannel heatsink</td>
<td>61</td>
<td>General Heat Transfer, Weakly Compressible Navier-Stokes</td>
<td>3D</td>
<td>2 min</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Microchannel heatsink, resistance</td>
<td>61</td>
<td>General Heat Transfer, Weakly Compressible Navier-Stokes</td>
<td>3D</td>
<td>2 min</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>MODEL</td>
<td>PAGE</td>
<td>APPLICATION MODES</td>
<td>SPATIAL DIMENSIONS</td>
<td>SOLUTION TIME</td>
<td>STATIC</td>
<td>TIME DEPENDENT CONDUCTION</td>
<td>CONVECTION</td>
<td>RADIATION</td>
<td>OUT-OF-PLANE</td>
<td>HIGHLY CONDUCTIVE LAYER</td>
<td>MULTIPHYSICS</td>
</tr>
<tr>
<td>-----------------------------------</td>
<td>------</td>
<td>-----------------------------------------------------------------------------------</td>
<td>--------------------</td>
<td>---------------</td>
<td>--------</td>
<td>----------------------------</td>
<td>------------</td>
<td>-----------</td>
<td>--------------</td>
<td>--------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Heating circuit</td>
<td>102</td>
<td>General Heat Transfer, Thin Conductive Shell, Solid Stress-Strain, Shell</td>
<td>3D</td>
<td>2 min</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Potcore inductor</td>
<td>142</td>
<td>General Heat Transfer, Weakly Compressible Navier-Stokes</td>
<td>2D-axi</td>
<td>3 min</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Power transformer</td>
<td>152</td>
<td>General Heat Transfer, Weakly Compressible Navier-Stokes</td>
<td>2D-axi</td>
<td>35 s</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Surface-mounted package</td>
<td>77</td>
<td>General Heat Transfer</td>
<td>3D</td>
<td>3 s</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Surface-mounted resistor</td>
<td>89</td>
<td>General Heat Transfer, Solid Stress-Strain</td>
<td>3D</td>
<td>3 min</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Thermal annealing</td>
<td>118</td>
<td>General Heat Transfer</td>
<td>3D</td>
<td>15 s</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Thermo-photovoltaic (TPV) cell</td>
<td>127</td>
<td>General Heat Transfer</td>
<td>2D</td>
<td>2 min</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td><strong>PROCESS AND MANUFACTURING</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Brake disc</td>
<td>166</td>
<td>General Heat Transfer</td>
<td>3D</td>
<td>4 min</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Chicken patties</td>
<td>179</td>
<td>General Heat Transfer, Diffusion</td>
<td>2D-axi</td>
<td>3 s</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Continuous casting</td>
<td>217</td>
<td>General Heat Transfer, Weakly Compressible Navier-Stokes</td>
<td>2D-axi</td>
<td>4 min</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Cooling flange</td>
<td>192</td>
<td>General Heat Transfer</td>
<td>3D</td>
<td>48 s</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Friction welding</td>
<td>206</td>
<td>General Heat Transfer</td>
<td>3D</td>
<td>14 s</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Turbulent heat exchanger</td>
<td>231</td>
<td>General Heat Transfer, k-ω Turbulence Model</td>
<td>2D</td>
<td>2 min</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td><strong>MEDICAL TECHNOLOGY</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Microwave cancer therapy</td>
<td>261</td>
<td>Bioheat Equation, TM Waves</td>
<td>3D</td>
<td>52 s</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Tumor ablation</td>
<td>246</td>
<td>Bioheat Equation, Conductive Media DC</td>
<td>3D</td>
<td>6 min</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
</tbody>
</table>
We welcome any questions, comments or suggestions you might have concerning these models. Contact us at info@comsol.com.

**Typographical Conventions**

All COMSOL manuals use a set of consistent typographical conventions that should make it easy for you to follow the discussion, realize what you can expect to see on the
screen, and know which data you must enter into various data-entry fields. In particular, you should be aware of these conventions:

- A **boldface** font of the shown size and style indicates that the given word(s) appear exactly that way on the COMSOL graphical user interface (for toolbar buttons in the corresponding tooltip). For instance, we often refer to the Model Navigator, which is the window that appears when you start a new modeling session in COMSOL; the corresponding window on the screen has the title **Model Navigator**. As another example, the instructions might say to click the **Multiphysics** button, and the boldface font indicates that you can expect to see a button with that exact label on the COMSOL user interface.

- The names of other items on the graphical user interface that do not have direct labels contain a leading uppercase letter. For instance, we often refer to the Draw toolbar; this vertical bar containing many icons appears on the left side of the user interface during geometry modeling. However, nowhere on the screen will you see the term “Draw” referring to this toolbar (if it were on the screen, we would print it in this manual as the **Draw** menu).

- The symbol > indicates a menu item or an item in a folder in the Model Navigator. For example, **Physics>Equation System>Subdomain Settings** is equivalent to: On the Physics menu, point to **Equation System** and then click **Subdomain Settings**.

- **COMSOL Multiphysics>Heat Transfer>Conduction** means: Open the COMSOL Multiphysics folder, open the Heat Transfer folder, and select Conduction.

- A **Code** (monospace) font indicates keyboard entries in the user interface. You might see an instruction such as “Type 1.25 in the Current density edit field.” The monospace font also indicates COMSOL Script codes.

- An **italic** font indicates the introduction of important terminology. Expect to find an explanation in the same paragraph or in the Glossary. The names of books in the COMSOL documentation set also appear using an italic font.
This chapter contains models of heat transfer in application such as electronic cooling and power systems.
Convection Cooling of Circuit Boards

Introduction

This discussion models the air cooling of circuit boards populated with multiple integrated circuits (ICs), which act as heat sources. It provides two examples as depicted in Figure 2-1: vertically aligned boards using natural convection, and horizontal boards with forced convection (fan cooling). Convective contributions caused by the induced (forced) flow of air dominate the cooling. To achieve high accuracy, the simulation models heat transport in combination with the fluid flow.

A good technique is to describe convective heat flux with a film-resistance coefficient, $h$. The heat-transfer equations then become simple to solve. However, this simplification requires that the coefficient be well determined. Many systems and conditions suffer from a lack of detailed knowledge of $h$, making accurate calculations of convective heat transfer difficult.

Instead of simplifying the equations, an alternative way to thoroughly describe the convective heat transfer is to model the heat transfer in combination with the fluid-flow field. The results then accurately describe the heat transport and temperature changes. From such simulations it is also possible to derive accurate estimations of the film...
coefficients. Such models are somewhat more complex but they are useful for unusual geometries and complex systems such as circuit-board cooling.

The following examples model the heat transfer of a circuit-board assembly using two application modes: General Heat Transfer and Weakly Compressible Navier-Stokes. The modeled scenario is based on work published by A. Ortega (Ref. 1), and this discussion also compares model results with Ortega’s experimental results. The first example simulates natural convection cooling of a vertical circuit board as depicted in Figure 2-1.

It is a good idea to first set up a 2D model for the case of natural convection. The geometry is the cross section, from the board’s back side to the next board’s back side, through the center of a row of ICs (as indicated by line A in Figure 2-1). Next create a 3D model for the same case. Due to symmetry, it is sufficient to model a unit cell, from the back side of a board to the next back side, covering the area between lines A and B in Figure 2-1. Figure 2-2 depicts the two geometries for the case of natural convection.

![Figure 2-2: The modeled geometries in 2D (a) and 3D (b).](image)

The dimensions of the original geometry are:
- Board: length (in the flow direction) 0.13 m, and the thickness is 0.002 m
- ICs: length and width are both 0.02 m, and thickness is 0.002 m
- The distance of air between the boards is 0.010 m
For the forced-convection case, set up the 3D model by rotating the geometry of Figure 2-2 (b) so that the boards are aligned horizontally.

Model Definition

The model makes use of two stationary application modes to simulate the problem: General Heat Transfer and Weakly Compressible Navier-Stokes.

The Weakly Compressible Navier-Stokes

The Weakly Compressible Navier-Stokes, describes the fluid velocity, \( \mathbf{u} \), and the pressure, \( p \) as

\[
\rho \mathbf{u} \cdot \nabla \mathbf{u} = \nabla \cdot [-p \mathbf{I} + \eta (\nabla \mathbf{u} + (\nabla \mathbf{u})^T) - (2\eta/3 - \kappa)(\nabla \cdot \mathbf{u}) \mathbf{I}] + (\rho - \rho_0)g
\]

\[
\nabla \cdot (\rho \mathbf{u}) = 0
\]

Due to heating of the fluid, deviations occur in the local density, \( \rho \), compared to the inlet density, \( \rho_0 \). This results in a local buoyancy force expressed as \((\rho - \rho_0)g\). The model also treats the viscosity, \( \eta \), as temperature dependent.

The General Heat Transfer application mode is based on the general energy balance

\[
\nabla \cdot (-k \nabla T) = Q - \rho C_p \mathbf{u} \cdot \nabla T
\]

where \( k \) represents thermal conductivity; \( C_p \) is the specific heat capacity; and \( Q \) is the heating power per unit volume, set to 1.25 MW/m\(^3\) (1 W/component) for the 3D cases. For the 2D cases, you should set it to 2/3 of that value to represent the lateral average heating power (that is, taking into account the open slots between the ICs). The material properties appear in Table 2-1.

<table>
<thead>
<tr>
<th>MATERIAL PROPERTY</th>
<th>HEAT SOURCE (SILICON)</th>
<th>CIRCUIT BOARD (FR4; REF. 2)</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \rho ) (kg/m(^3))</td>
<td>2330</td>
<td>1900</td>
</tr>
<tr>
<td>( C_p ) (J/(kg*K))</td>
<td>703</td>
<td>1369</td>
</tr>
<tr>
<td>( k ) (W/(m*K))</td>
<td>163</td>
<td>0.30</td>
</tr>
</tbody>
</table>

The model treats properties for air as temperature dependent according to the following equations (Ref. 3):

\[
\rho = (p + p_0)M_w/(RT)
\]
with \( p_0 = 101.3 \) kPa, \( M_w = 0.0288 \) kg/mol, and \( R = 8.314 \) J/(mol·K). Further,

\[
C_p = 1100 \text{ J/(kg·K)}
\]

\[
k = 10^{3.723 + 0.865 \log_{10}(T)} \text{ W/(m·K)}
\]

\[
\eta = 6.0 \times 10^{-6} + 4.0 \times 10^{-8} T \text{ Pa·s}
\]

where \( T \) must be expressed in kelvin.

Specify the boundary conditions for the flow inlet as boundary-normal flow with a known velocity field. For the natural-convection models, set the inlet velocity to zero. For the forced-convection cases, set up an inlet-velocity profile, \( u_y \), that is uniform in the (horizontal) \( x \) direction and parabolic (similar to a fully developed laminar profile) in the (vertical) \( z \) direction. In terms of an equation this reads

\[
u_z = \frac{4\tilde{z}(1 - \tilde{z})(-u_{\text{max}})}{	ilde{z}}
\]

where \( \tilde{z} = z/0.010 \) m parameterizes the height above the board and \( u_{\text{max}} \), the maximal inlet speed, equals 1 m/s. At the outlet all the models use the normal flow, zero pressure boundary condition. In addition, they apply no-slip conditions at the surfaces of the board and the ICs. At the inlet boundary then fix the temperature to 300 K (room temperature). At the outlet the models use purely convective heat flux. You should also set the lateral boundaries periodic with respect to temperature, making the temperatures equal on both boundaries at every \( y \) value. Finally, the models apply continuity of temperature and heat flux at all interior boundaries.
Results and Discussion

Natural Convection

Figure 2-3: Temperature distribution for the 2D model.

The results of the 2D model (Figure 2-3) show that the temperature of the ICs (the heat sources) increases considerably under a heating load of 1 W/component. Note that the temperature increase of the sources varies from 30 K for the lowest IC up to almost 90 K at the top IC. This is a result of the thermal “footprint” of the heat sources. Another interesting result is that the circuit board contributes a large amount of cooling power on its back side, although the thermal conductivity is quite small. This is apparent in the result plots as a temperature rise in the fluid at the right-hand boundary (that is, the back side of the next board in the stack).

The fluid flow in the 3D problem is a bit more complex to solve because of the increased number of mesh nodes necessary to resolve the flow and heat transport fields.
The results (Figure 2-4) show that the temperature increase at the hottest spot of each component is approximately two degrees higher for the 3D case than for the 2D case.

In addition, the temperature difference among the various ICs is smaller in the 3D model, which predicts a more uniform temperature rise of the ICs. The ICs have an operating temperature between 70 K and 80 K above ambient. This result is probably closer to reality compared to the 2D simulation because it also includes the horizontal gaps between the ICs. The difference in temperature rise along the board’s height is explained primarily by the fluid-flow pattern.

Figure 2-5 plots the fluid velocity for both the 2D and 3D models. The maximum fluid velocity is slightly higher in the 3D case than in the 2D case. More importantly, the flow field behaves differently in the two cases. When comparing Figure 2-5 (a) and (b),
note that the velocity fields are rather similar along the center line of the heat sources. However, there is a channeling effect from the horizontal gaps.

**FORCED CONVECTION—HORIZONTAL BOARDS**

This model includes a forced fluid inlet velocity that represents the situation when a fan cools the ICs. As Figure 2-6 shows, the temperature rise in the ICs is approximately 20 K to 35 K smaller compared to the natural-convection case due to the higher
average fluid velocity. In the forced-convection case, the temperature difference along the board is also less pronounced than for the natural convection case.

Another interesting result, visible in Figure 2-7, is that the channeling effect of the gap causes a reduction in the fluid’s flow rate above the sources. The cooling of the ICs is therefore somewhat reduced compared to an ideal case with an even flow field.
From the simulation results you can also determine the effective convection heat transfer film coefficient, \( h \). Calculate it by integrating the heat flux across the fluid boundary of the source objects. Then divide that value with the temperature difference between that of the fluid at the surface and the inlet temperature. Put in terms of an equation this reads

\[
h_i = \left( \frac{1}{\Omega_1} \int q_i \, d\Omega_1 \right) \left( \frac{1}{\Omega_2} \int T_{s,i} \, d\Omega_2 - T_{f,0} \right)^{-1}
\]

where \( \Omega_1 \) is the source surface, \( \Omega_2 \) is the fluid cross section, \( q_i \) is the heat flux, while \( T_{f,0} \) and \( T_{s,i} \) represent the inlet fluid temperature and the surface temperature of source \( i \), respectively. Thus, the value of \( h \) varies between the rows of the sources due to thermal footprints from upstream heat sources.

In the case of forced convection, it is common to use the adiabatic film resistance, \( h_{\text{ad}} \). Its definition is similar to \( h \) except it uses \( T_{\text{cup}} \) instead of \( T_{f,0} \). \( T_{\text{cup}} \) is the cross-section average of the fluid temperature, \( T_f \), upstream of each source, defined as
Figure 2-8 compares the calculated values of \( h \) and \( h_{ad} \) for the convection cases with experimentally achieved values using similar geometries.

\[
T_{\text{up}} = \left( \int (\rho \mathbf{n} \cdot \mathbf{u}) T \, d\Omega_2 \right) \left( \int (\rho \mathbf{n} \cdot \mathbf{u}) d\Omega_2 \right)^{-1}.
\]

The deviation from the experimental values for the natural convection might stem from differences in the geometry (which is not fully defined in Ref. 1).

In the forced-convection case you can compare the achieved results with experimental results by calculating the Nusselt number, \( \text{Nu} \). It follows from:

\[
\text{Nu}_L = h_{ad}(L/k)
\]

where \( L \) in this case is the length of the heat source (20 mm). The calculated Nusselt numbers for the 2D model decrease from 16 to 11 between rows 1 and 4. These values agree well with the experimentally measured ones for similar geometries, being in the range of 15 (Ref. 1).

A general conclusion you can draw from this example is that modeling can achieve accurate values of convective heat transfer film coefficients, although the values do
differ somewhat between the 2D and 3D models. In addition, the good agreement between experimental and simulated values indicates the models’ high accuracy.

References


Modeling Using the Graphical User Interface—2D Natural Convection

MODEL NAVIGATOR

1. Start COMSOL Multiphysics, and in the Model Navigator click the New tab.

2. From the Space dimension list select 2D.

3. In the list of application modes select

4. Click OK.

OPTIONS AND SETTINGS

1. From the Options menu select Constants, and in the resulting dialog box define the following names and expressions. When finished, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>q_source</td>
<td>(2/3)<em>1[W]/(20</em>20*2[mm^3])</td>
</tr>
<tr>
<td>T0</td>
<td>300[K]</td>
</tr>
<tr>
<td>rho0_air</td>
<td>1.013e5[Pa]<em>28.8[g/mol]/(8.314[J/(mol</em>K)]*T0)</td>
</tr>
<tr>
<td>Cp_air</td>
<td>1.1[kJ/(kg*K)]</td>
</tr>
</tbody>
</table>

Model Library path: Heat_Transfer_Module/
Electronics_and_Power_Systems/circuit_board_nat_2d
2. From the **Options** menu select **Expressions>Scalar Expressions**, then define the following names and expressions; when finished, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>k_air</td>
<td>$10^{-3.723+0.865\log_{10}(\text{abs}(T[\text{K}])))[\text{W/(m*K)}]}$</td>
</tr>
<tr>
<td>rho_air</td>
<td>$1.013\times10^5[\text{Pa}]<em>28.8[\text{g/mol}]/(8.314[\text{J/(mol</em>K)}]*T)$</td>
</tr>
<tr>
<td>eta_air</td>
<td>$6\times10^{-6}[\text{Pa<em>s}]+4\times10^{-8}[\text{Pa</em>s/K}]*T$</td>
</tr>
</tbody>
</table>

**GEOMETRY MODELING**

1. Create three rectangles. To do so, go to the **Draw** menu, select **Specify Objects>Rectangle**, and then enter the information from the following table; after creating each rectangle, click **OK**.

<table>
<thead>
<tr>
<th>OBJECT</th>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>BASE</th>
<th>X</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>0.002</td>
<td>0.13</td>
<td>Corner</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>R2</td>
<td>0.01</td>
<td>0.13</td>
<td>Corner</td>
<td>0.002</td>
<td>0</td>
</tr>
<tr>
<td>R3</td>
<td>0.002</td>
<td>0.02</td>
<td>Corner</td>
<td>0.002</td>
<td>0.01</td>
</tr>
</tbody>
</table>

2. Click the **Zoom Extents** button on the Main toolbar.

3. In the drawing area select the rectangle designated R3, then click the **Array** button on the Draw toolbar. In the resulting dialog box, go to the **Displacement** area and in the $y$ edit field type 0.03; go to the **Array size** area and in the $y$ edit field type 4. Click **OK**.

**PHYSICS SETTINGS**

**Subdomain Settings**

1. In the **Multiphysics** menu select the **Weakly Compressible Navier-Stokes** application mode.

2. From the **Physics** menu select **Subdomain Settings**.

3. Select Subdomains 1 and 3–6. Select **Solid domain** from the **Group** list. This deactivates the **Weakly Compressible Navier-Stokes** application mode in these subdomains.
4 Select Subdomain 2 and enter these expressions in the appropriate edit fields:

<table>
<thead>
<tr>
<th>PARAMETER</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>η</td>
<td>eta_air</td>
</tr>
<tr>
<td>F_y</td>
<td>9.81[m/s^2]*(rho_0_air-rho_htgh)</td>
</tr>
</tbody>
</table>

The density will automatically be imported from the General Heat Transfer application mode.

5 Click OK to close the Subdomain Settings dialog box.

6 In the Multiphysics menu select the General Heat Transfer application mode.

7 From the Physics menu open the Subdomain Settings dialog box.

8 Click the Conduction tab and select Subdomain 1.

9 Select Solid domain from the Group list and enter the following expressions:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>k (isotropic)</td>
<td>0.3</td>
</tr>
<tr>
<td>ρ</td>
<td>1900</td>
</tr>
<tr>
<td>C_p</td>
<td>1369</td>
</tr>
</tbody>
</table>

10 Select Subdomain 2 and enter k_air in the k (isotropic) edit field, rho_air in the ρ edit field, and C_p_air in the C_p edit field.

11 Click the Convection tab and select Ideal gas from the Fluid type list.

12 Click the Ideal gas tab.

13 Click the M_n radio button and enter 0.0288 in the M_n edit field.

14 Return to the Conduction tab and select Subdomains 3–6.

15 Select Solid domain from the Group list.

16 Click the Load button to open the Materials/Coefficients Library.

17 From the Basic Material Properties library, choose Silicon, then click OK.

18 In the Q edit field type q_source.

19 Select all subdomains. Go to the Init page, and in the Temperature edit field enter T0.

20 Click OK to close the Subdomain Settings dialog box.

Boundary Conditions

1 From the Physics menu open the Boundary Settings dialog box.
2 Set the boundary conditions as in the following table; when done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 5</th>
<th>BOUNDARY 22</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Temperature</td>
<td>Convective flux</td>
</tr>
<tr>
<td>( T_0 )</td>
<td>( T_0 )</td>
<td></td>
</tr>
<tr>
<td>Radiation type</td>
<td>None</td>
<td></td>
</tr>
</tbody>
</table>

3 In the Multiphysics menu select Weakly Compressible Navier-Stokes.

4 From the Physics menu open the Boundary Settings dialog box.

   You must only change the boundary condition at in- and outlet since no-slip is default for all boundaries.

5 Select Boundaries 5 and 22, then select Boundary type: Open Boundary, Boundary Condition: Normal stress. Leave \( f_0 \) at zero.

6 Click OK.

7 From the Physics>Periodic Conditions menu open the Periodic Boundary Conditions dialog box.

8 On the Source page select Boundary 1, go to the Expression edit field and type \( T \), then press Enter.

9 Click the Destination tab, select the check box corresponding to Boundary 27, and in the Expression edit field type \( T \).

10 Click the Source Vertices tab, find the Vertex selection list, select Vertices 1 and 2, then click the >> button.

11 Click the Destination Vertices tab. Select and add Vertices 21 and 22. Click OK.

MESH GENERATION

1 From the Mesh menu open the Free Mesh Parameters dialog box. Go to the Global page. From the Predefined mesh sizes list select Normal.

2 On the Subdomain page select Subdomain 2, then in the Maximum element size edit field type \( 1.5 \times 10^{-3} \). Click OK.

3 On the Mesh menu select Initialize Mesh.

COMPUTING THE SOLUTION

Click the Solve button on the Main toolbar to calculate the solution.
**POSTPROCESSING AND VISUALIZATION**

1. In order to create Figure 2-3 open the Plot Parameters dialog box from the Postprocessing menu.
2. Click the Surface tab.
3. On the Surface Data page, select General Heat Transfer (htgh)>Temperature from the Predefined quantities list. Click OK.
4. To achieve Figure 2-5 (a) select Weakly Compressible Navier-Stokes (chns)>Velocity field from the Predefined quantities list on the Surface Data page, then click OK.

**Modeling Using the Graphical User Interface**

**3D Natural Convection**

*Model Library path:* Heat_Transfer_Module/
Electronics_and_Power_Systems/circuit_board_nat_3d

Repeat the steps from the 2D model in the sections “Model Navigator” and “Options and Settings” with two exceptions: in the Space dimension list select 3D and q_source should be equal to $1[W]/(20*20*2[mm^3])$.

**GEOMETRY MODELING**

1. Create three blocks using data from this table. To do so, go to the Draw menu and select Block.

<table>
<thead>
<tr>
<th>OBJECT</th>
<th>LENGTH X</th>
<th>LENGTH Y</th>
<th>LENGTH Z</th>
<th>BASE X</th>
<th>BASE Y</th>
<th>BASE Z</th>
</tr>
</thead>
<tbody>
<tr>
<td>BLK1</td>
<td>0.015</td>
<td>0.002</td>
<td>0.13</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>BLK2</td>
<td>0.01</td>
<td>0.002</td>
<td>0.02</td>
<td>0</td>
<td>-0.002</td>
<td>0.01</td>
</tr>
<tr>
<td>BLK3</td>
<td>0.015</td>
<td>0.01</td>
<td>0.13</td>
<td>0</td>
<td>-0.01</td>
<td>0</td>
</tr>
</tbody>
</table>

2. Click the Zoom Extents button on the Main toolbar.
3. Select the object BLK2, then click the Array button on the Draw toolbar. Go to the Displacement area and in the z edit field type 0.03. Go to the Array size area and in the z edit field type 4. Click OK.
PHYSICS SETTINGS

Subdomain Settings
1. From the Multiphysics menu, select the Weakly Compressible Navier-Stokes application mode.
2. From the Physics menu select Subdomain Settings.
3. Select Subdomains 2–6. Select Solid domain from the Group list. This will deactivate the Weakly Compressible Navier-Stokes application mode in these subdomains.
4. Select Subdomain 1, then enter the following expressions in the appropriate edit fields:

<table>
<thead>
<tr>
<th>PARAMETER</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>η</td>
<td>eta_air</td>
</tr>
<tr>
<td>Fz</td>
<td>9.81[m/s^2]*(rho0_air-rho_htgh)</td>
</tr>
</tbody>
</table>

The density will automatically be imported from the General Heat Transfer application mode.
5. Click OK to close the Subdomain Settings dialog box.
6. In the Multiphysics menu select the General Heat Transfer application mode.
7. From the Physics menu open the Subdomain Settings dialog box.
8. Click the Conduction tab and select Subdomain 6.
9. From the Group drop down menu, select Solid domain. Then enter the following settings:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN 6</th>
</tr>
</thead>
<tbody>
<tr>
<td>k (isotropic)</td>
<td>0.3</td>
</tr>
<tr>
<td>ρ</td>
<td>1900</td>
</tr>
<tr>
<td>Cp</td>
<td>1369</td>
</tr>
</tbody>
</table>

10. Select Subdomain 1 and enter k_air in the k (isotropic) edit field and Cp_air in the Cp edit field.
11. Click the Convection tab and select Ideal gas from the Fluid type list.
12. Click the Ideal gas tab.
13. Click the M_n radio button and enter 0.0288 in the M_n edit field.
14. Click the Conduction tab, then select Subdomains 2–5.
15. From the Group drop down menu, select Solid domain.
16 Click the **Load** button to open the **Materials/Coefficients Library**.

17 From the **Basic Material Properties** library, choose **Silicon**, then click **OK**.

18 In the **Q** edit field type **q_source**.

19 Select all subdomains. Click the **Init** tab, then in the **Temperature** edit field type **T0**.

20 Click **OK** to close the **Subdomain Settings** dialog box.

**Boundary Conditions**

1 From the **Physics** menu select **Boundary Settings**.

2 Set the boundary conditions as follows; when done, click **OK**.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 3</th>
<th>BOUNDARY 4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Temperature</td>
<td>Convective flux</td>
</tr>
<tr>
<td><strong>T0</strong></td>
<td>T0</td>
<td></td>
</tr>
<tr>
<td>Radiation type</td>
<td>None</td>
<td></td>
</tr>
</tbody>
</table>

3 From the **Multiphysics** menu select **Weakly Compressible Navier-Stokes**.

4 From the **Physics** menu select **Boundary Settings**.

The default boundary condition is no-slip. Hence, only those boundaries that are not walls have to be specified.

5 Select Boundaries 3 and 4, then select **Boundary type**: **Open Boundary, Boundary Condition**: **Normal stress**. Leave **f₀** at zero.

6 Select Boundaries 1 and 34, then apply the boundary Type **Symmetry Boundary**.

7 Click **OK**.

8 From the **Physics** menu select **Periodic Conditions>Periodic Boundary Conditions**.

9 On the **Source** page select Boundary 2. In the **Expression** edit field type **T**, then press **Enter**.

10 Click the **Destination** tab, and click the check box to select Boundary 29. In the **Expression** field type **T**.

11 Click the **Source Vertices** tab. Select and add (using the **>>** button), in this order, Vertices 1, 2, 39, and 40.

12 Click the **Destination Vertices** tab. Select and add Vertices 21, 22, 43, and 44, again in the mentioned order. Click **OK**.

**MESH GENERATION**

1 From the **Mesh** menu select **Free Mesh Parameters**. On the **Global** page go to the **Predefined mesh sizes** list and select **Finer**.
2. Click the **Boundary** tab and select Boundary 2. In the **Maximum element size** edit field type $2 \times 10^{-3}$.

3. Click the **Advanced** tab. In the **x-direction scale factor** edit field type $0.5$. Click **OK**.

4. On the **Mesh** menu select **Initialize Mesh**.

**COMPUTING THE SOLUTION**

1. From the **Solve** menu open the **Solver Parameters** dialog box.

2. On the **General** page, select **Direct (PARDISO)** from the **Linear system solver** list.

3. Click **OK**.

4. Click the **Solve** button on the Main toolbar to compute the solution.

The problem is rather large because of the strong coupling between temperature and velocity and because of the dense mesh. A computer needs approximately 500 MB of free memory to solve the problem. The problems can take a few minutes to solve.

**POSTPROCESSING AND VISUALIZATION**

To generate the temperature plot in Figure 2-4, execute the following instructions:

1. From the **Postprocessing** menu open the **Plot Parameters** dialog box.

2. On the **General** page, clear the check box for the **Boundary** plot type and select the check box for the **Slice** plot type.

3. Click the **Slice** tab. Go to the **Slice data** area. In the **Predefined quantities** list select **General Heat Transfer (htgh)>Temperature**.

4. Go to the **Slice positioning** area. In the **Number of levels** edit fields for **x levels** and **z levels** type 1 and 8, respectively. For **y levels**, select the option button next to the **Vector with coordinates** edit field, then type 0 in this edit field.

5. Click **Apply** to launch the plot.

To generate the plot in Figure 2-5 (b), proceed as follows:

6. Still on the **Slice** page, select **Weakly Compressible Navier-Stokes (chns)>Velocity field** from the **Predefined quantities** list.

7. Select the option button next to the **Number of levels** edit field for **y levels**, then type 0 in this edit field. Click **Apply**.

Finally, you can reproduce the model image—that is, the plot shown in the **Model Navigator** and when the model opens—by the following modifications:
8 In the Predefined quantities list on the Slice page select General Heat Transfer (htgh)>Temperature.

9 Click the Arrow tab. Select the Arrow plot check box.

10 In the Predefined quantities list on the Subdomain Data page, leave the default selection, which is Weakly Compressible Navier-Stokes (chns)>Velocity field.

11 Go to the Arrow positioning area. In the Number of points edit fields for x points, y points, and z points type 5, 5, and 8, respectively.

12 In the Arrow parameters area, from the Arrow type list select 3D arrow, then click OK.

Modeling Using the Graphical User Interface—3D Forced Convection

Model Library path: Heat_Transfer_Module/
Electronics_and_Power_Systems/circuit_board_forced_3d

You implement this model by modifying the previous one (circuit_board_nat_3D.mph). Begin by loading or building that previous model.

GEOMETRY MODELING
1 Click the Draw Mode button on the Main toolbar to enter the Draw mode.

2 Select all objects, then select the menu item Draw>Modify>Rotate.

3 In the Rotation angle edit field type -90.

4 Go the Rotation axis direction vector area, and in the in the x, y, and z edit fields type 1, 0, and 0, respectively. Click OK.

PHYSICS SETTINGS

Subdomain Settings
Since you rotated the model geometry, and you are modeling forced convection here, the volume force that acts on the fluid will have different magnitude and direction. The volume force is represented by gravitation. However, for this problem we will neglect the gravitational force, which is a fair assumption. Therefore, zero-out the volume force present in the Weakly Compressible Navier-Stokes application mode according to the following steps:

1 From the Physics menu select Subdomain Settings.
2. Select Subdomain 2 and type 0 in the Volume force, z dir. edit field.

3. Click OK.

**Boundary Conditions**

1. From the Physics menu select Boundary Settings.

2. Select Boundary 29, and select Boundary type: Inlet and Boundary condition: Velocity.

3. Click the u₀, v₀, w₀-radio button.

4. In the y-velocity edit field type \(4 \times 10^4 z^2 \left[ \frac{1}{m^2} \right] \left[ \frac{m}{s} \right] \), then click OK.

5. From the Multiphysics menu select General Heat Transfer.

6. From the Physics menu select Boundary Settings.

7. In the dialog box that opens, set the boundary conditions as follows; when done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 5</th>
<th>BOUNDARY 29</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Convective flux</td>
<td>Temperature</td>
</tr>
<tr>
<td>T₀</td>
<td>T₀</td>
<td></td>
</tr>
<tr>
<td>Radiation type</td>
<td>None</td>
<td></td>
</tr>
</tbody>
</table>

**Mesh Generation**

1. From the Mesh menu select Free Mesh Parameters. On the Global page verify that Finer is selected from the Predefined mesh sizes list.

2. Click the Custom mesh size button and set the Resolution of narrow regions parameter to 1.

3. On the Boundary page select Boundary 7. In the Maximum element size edit field type 2.8e-3, then click OK.

4. Click the Initialize Mesh button on the Main toolbar.

**Computing the Solution**

1. From the Solve menu open the Solver Manager dialog box.

2. On the Initial Value page go to the Initial value area and select the Initial value expression option button.

3. Click OK.

4. Click the Solve button on the Main toolbar.
POSTPROCESSING AND VISUALIZATION

1 To create Figure 2-6, first go to the Postprocessing menu and open the Plot Parameters dialog box.

2 On the General page select the check box for the Slice plot type and clear the check box for the Boundary plot type.

3 Click the Slice tab, then go to the Slice data area. In the Predefined quantities list select General Heat Transfer (htgh)>Temperature.

4 Go to the Slice positioning area. In the Number of levels edit fields for x levels and y levels type 1 and 10, respectively. For z levels, select the option button next to the Vector with coordinates edit field, then type 0 in this edit field. Click Apply.

5 To produce Figure 2-7, select Weakly Compressible Navier-Stokes (chns)>Velocity field from the Predefined quantities list.

6 In the Number of levels edit field for x levels type 0. Select the option button next to the Number of levels edit field for z levels, then type 0 in this edit field. Click OK.

Generate the plot shown in the Model Navigator and when the model opens in the following way:

1 From the Postprocessing menu select Plot Parameters.

2 On the General page clear the check boxes for the Slice and Arrow plot types and then select the check boxes for the Boundary and Streamline plot types.

3 Click the Streamline tab.

4 On the Start Points tab click the Specify start point coordinates button.

5 In the x edit field type linspace(1e-3,13e-3,13).

6 In the y edit field type linspace(0.13,0.13,13).

7 In the z edit field type linspace(1.3e-3,1.3e-3,13).

8 Click the Line Color tab, then click the Use expression button.

9 Click the Color Expression button to open the Streamline Color Expression dialog box.

10 In the Expression field type T-296[K], then click OK.

11 In the Line type list, select Tube.

12 Click the Tube Radius button at the bottom of the dialog box.

13 Click the Radius data check box, and in the Predefined quantities list select General Heat Transfer (htgh)>Temperature gradient.

14 Clear the Radius scale factor>Auto check box, and in the edit field for the scale factor enter 0.5. Click OK.
15 Click the Advanced button. In the Maximum number of integration steps edit field type 1000, then click OK.

16 On the Boundary page, select General Heat Transfer (htgh)>Temperature from the Predefined quantities list.

17 Click OK.

18 From the Options menu select Suppress>Suppress Boundaries.

19 Select Boundaries 4, 5, 6, 7, 9, 29, and 35, then click OK.

20 Click the Postprocessing Mode button on the Main toolbar.

21 Click the Scene Light button on the Camera toolbar.

22 Double-click the AXIS button on the status bar at the bottom of the COMSOL Multiphysics window to disable the coordinate axes.

The two following examples illustrate simplified approaches to simulating forced-convection cooling. This discussion starts with the exact problem from the section “Forced Convection—Horizontal Boards” on page 14 and shows how to simplify it. Specifically, if you know the heat transfer film coefficient, \( h \), it is not necessary to include the flow field; the General Heat Transfer application mode is then sufficient for modeling the temperature distribution. And while the following examples take their \( h \) values from the results of the rigorous model “Convection Cooling of Circuit Boards” on page 8 (the case of forced convection), you can also use the methodology of known values or expressions for \( h \).

*Model Definition*

The dimensions of the problem geometry (Figure 2-9) and its parameters are the same as in the previous example. In brief, the system cools a stack of circuit boards with four in-line ICs, each producing 1 W of heat, through forced convection. The aim of both

---

CONVECTION COOLING OF CIRCUIT BOARDS  |  29
of the following models is to determine the temperature development of the board and ICs.

![Image of a board and ICs with 1 W/IC]

Figure 2-9: Starting geometry for the problem.

**1D Plug Flow**

First, this example sets up a 1D adiabatic plug-flow model describing the cup mixing temperature of the air (fluid), $T_{f,\text{cup}}$, in the channel between the boards during forced convection. It uses the equation

$$T_{f,\text{cup}} = \left( \frac{1}{\int (\rho \cdot \mathbf{n} \cdot \mathbf{u}) \, d\Omega_2} \right) \left( \int (\rho \cdot \mathbf{n} \cdot \mathbf{u}) \, d\Omega_2 \right)^{-1}. \quad (\text{1 W/IC})$$

The model does not include the temperature distribution in the air. In addition, the model assumes the sources are infinite in the board’s lateral direction. Thus, in principle the model describes the distribution of temperature in the flow direction along a line in the air channel. Figure 2-10 depicts the resulting 1D geometry.

![Image of a 1D geometry]

Figure 2-10: The geometry of the 1D-model.

The model uses the General Heat Transfer application mode. It sets the convective velocity to 0.667 m/s at the inlet (that is, the average velocity of the previous models) and assume that it varies with temperature according to

$$u(x) = u_0 \frac{T_{f,\text{cup}}}{T_0}. \quad (\text{1 W/IC})$$
The next equation describes the heat transfer

\[ \nabla \cdot (-k \nabla T_{\text{f,cup}}) = Q - \rho C_p u \cdot \nabla T_{\text{f,cup}} \]

where \( k \) represents the thermal conductivity, \( C_p \) gives the specific heat capacity, and \( Q \) is the heating power per unit volume. The model sets \( Q \) to zero for the subdomains between the sources while it equals 1666.67 W/m² (that is, \((2/3) \cdot 1 \text{ W/}((20 \cdot 10^{-3})^2 \text{ m}^2))\) at the source subdomains. The factor \( 2/3 \) represents the lateral average heating power, taking the open slots between the ICs into account.

The material properties are the same as those in the previous models, also taking temperature variations into account. At the inlet boundary, the temperature is fixed to 300 K, and at the outlet the model applies convective heat flux.

The goal is to calculate the ICs’ surface temperature, \( T_s \). It is a function of the fluid temperature and the adiabatic heat transfer film coefficients, \( h_{\text{ad}} \), according to

\[ T_s = \frac{q}{h_{\text{ad}}} + T_{\text{f,cup}} \]

where \( q \) is the heat flux. This equation calculates the IC surface temperature.

This example calculates values of \( h_{\text{ad}} \) using the results of the previous 3D model (“Forced Convection—Horizontal Boards” on page 14) with the formula

\[ h_{\text{ad}} = \frac{Q_{\text{tot}}}{A_{2D} (T_S - T_{\text{f,cup}})} \]

where \( A_{2D} \) is the IC’s xy-projected area, and \( Q_{\text{tot}} \) is the IC’s total heating power (in this case, 1 W).

You can easily perform these calculations using the postprocessing capabilities of COMSOL Multiphysics. Specifically, with the model “circuit_board_3d_forced” open, first calculate \( T_{\text{f,cup}} \) for each cross section of the air domain. Next calculate the total heat flux, \( Q_{\text{tot}} \), from each surface. Finally use the equation just given to derive the following values of \( h_{\text{ad}} \) (a discussion of \( h^0 \) follows shortly):

<table>
<thead>
<tr>
<th>REGION</th>
<th>( h_{\text{ad}} ) (W/(m²·K))</th>
<th>( h^0 ) (W/(m²·K))</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source 1</td>
<td>57.5</td>
<td>35.0</td>
</tr>
<tr>
<td>Source 2</td>
<td>44.4</td>
<td>22.1</td>
</tr>
<tr>
<td>Source 3</td>
<td>40.6</td>
<td>19.2</td>
</tr>
<tr>
<td>Source 4</td>
<td>39.2</td>
<td>18.0</td>
</tr>
</tbody>
</table>
SIMPLIFIED 3D MODEL

This second example sets up a transient 3D model describing the temperature of the board and ICs during startup. In this case the modeled geometry consists of the board and ICs but not the air. The simplified model makes it possible to investigate the temperature transient of a entire row of ICs.

Figure 2-11: Geometry of the 3D model.

In contrast to the model in the previous section, which used both conduction and convection, this model works only with the conduction feature of the General Heat Transfer application mode. It uses the isothermal film coefficients, $h^0$, to calculate the convective cooling. You calculate them from the results of the previous 3D model (“Forced Convection—Horizontal Boards” on page 14), doing so in a similar way as you did for the 1D-plug-flow model just described except using the formula

$$h^0 = \frac{Q_{tot}}{A_{2D}(T_S - T_0)}$$

where $T_0$ is the air’s inlet temperature. To model the heat transfer coefficient of the board, a function from the built-in Heat Transfer Coefficients library is used. The function is valid for forced convection on plates. For more information about the Heat Transfer Coefficients library, see the Heat Transfer Module User’s Guide.

Further, the material properties specified in the subdomain settings for this model are identical to those in the previous models. The initial temperature of all components is 300 K, as is the surrounding temperature. For the ICs it applies a volume heat source of 1.25 MW/m. In the heat flux boundary conditions, for the downside segments of the board and for the circuit surface boundaries, it uses the $h^0$ values.
Results and Discussion

1D Plug flow

Figure 2-12 shows the results of the 1D model for the ICs’ surface temperature.

![1D model results for the surface temperature of the ICs (dashed line) and the average temperature of the fluid (solid line).](image)

The profile agrees rather well with that of the previous 3D model, in this case experiencing a maximum surface temperature of 357 K. This indicates that you can model the heat transfer with good accuracy in a simplified way if you know the values of the film coefficient, $h_{ad}$. The simplified 1D model is thus a good predictor even though it does not simulate the temperature distribution in the fluid and the fluid flow field.

Simplified 3D model

This model results in an accurate determination of the source surface temperatures. A benefit of having an easy-to-solve model is that you can proceed and analyse the transient behavior. Figure 2-13 shows the transient 3D model results at 1000 s.
The results indicate that this amount of time is approximately sufficient to reach steady state.

*Modeling Using the Graphical User Interface—1D Plug Flow*

**Model Library path:** Heat_Transfer_Module/
Electronics_and_Power_Systems/simplified_circuit_board_1d

**Model Navigator**

1. In the Model Navigator click the **New** tab, and in the **Space dimension** list select **1D**.
2. From the list of application modes select **Heat Transfer Module>General Heat Transfer**.
3. Click **OK**.
OPTIONS AND SETTINGS

1. From the Options menu select Constants. In the dialog box, define the following names and expressions; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>v_in</td>
<td>( \frac{2}{3} \ast 1[\text{m/s}] )</td>
</tr>
<tr>
<td>T0</td>
<td>300[K]</td>
</tr>
<tr>
<td>width</td>
<td>0.01</td>
</tr>
<tr>
<td>q_s</td>
<td>( \frac{2}{3} \ast 1.25[\text{MW/m}^3]\ast2[\text{mm}] )</td>
</tr>
<tr>
<td>h1</td>
<td>57.5[W/(m*K)]</td>
</tr>
<tr>
<td>h2</td>
<td>44.4[W/(m*K)]</td>
</tr>
<tr>
<td>h3</td>
<td>40.6[W/(m*K)]</td>
</tr>
<tr>
<td>h4</td>
<td>39.2[W/(m*K)]</td>
</tr>
</tbody>
</table>

2. From the Options menu select Expressions>Scalar Expressions. In the dialog box, define the following names and expressions; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>k_f</td>
<td>( 10^{-(-3.723+0.865\ast \log_{10}(T[K]))}[\text{W/(m*K)}] )</td>
</tr>
<tr>
<td>rho_f</td>
<td>( 1.013e5[\text{Pa}]<em>28.8[\text{g/mol}]/8.314[\text{J/(mol</em>K)}]/T )</td>
</tr>
<tr>
<td>Cp_f</td>
<td>1.1[kJ/(kg*K)]</td>
</tr>
<tr>
<td>v</td>
<td>( \frac{v_{in}\ast width\ast T}{T0} )</td>
</tr>
</tbody>
</table>

GEOMETRY MODELING

1. Create three line segments. To do so, from the Draw menu select Specify Objects>Line and then enter these settings:

<table>
<thead>
<tr>
<th>LINE SEGMENT</th>
<th>X-COORDINATES</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0 0.01</td>
</tr>
<tr>
<td>2</td>
<td>0.01 0.03</td>
</tr>
<tr>
<td>3</td>
<td>0.03 0.04</td>
</tr>
</tbody>
</table>

2. Click the Zoom Extents button on the Main toolbar.

3. Copy line segments 2 and 3 by selecting these objects and pressing Ctrl+C.

4. To complete the geometry, perform a paste operation three times by pressing Ctrl+V; each time use a different Displacement in the x edit field of 0.03, 0.06, and 0.09.

5. Once again click the Zoom Extents button.
PHYSICS SETTINGS

Subdomain Settings
1 From the Physics menu select Subdomain Settings.
2 On the Init page select all subdomains, then in the \( T(t_0) \) edit field type \( T_0 \).
3 Go to Conduction page and enter these settings:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAINS 1, 3, 5, 7, 9</th>
<th>SUBDOMAINS 2, 4, 6, 8</th>
</tr>
</thead>
<tbody>
<tr>
<td>( k ) (isotropic)</td>
<td>( k_f )</td>
<td>( k_f )</td>
</tr>
<tr>
<td>( \rho )</td>
<td>( \rho_f )</td>
<td>( \rho_f )</td>
</tr>
<tr>
<td>( C_p )</td>
<td>( C_p_f )</td>
<td>( C_p_f )</td>
</tr>
<tr>
<td>( Q )</td>
<td>0</td>
<td>( q_s )</td>
</tr>
</tbody>
</table>

4 Click the Convection tab, select all subdomains, and click the Enable convective heat transfer check box. In the \( u \) edit field for the \( x \)-velocity type \( v \). Click OK.
5 From the Options menu select Expressions>Subdomain Expressions.
6 Enter the name of the subdomain expression and the expressions that define it in the various subdomains; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>SUBDOMAIN 2</th>
<th>SUBDOMAIN 4</th>
<th>SUBDOMAIN 6</th>
<th>SUBDOMAIN 8</th>
</tr>
</thead>
<tbody>
<tr>
<td>( T_s )</td>
<td>( q_s/h1+T )</td>
<td>( q_s/h2+T )</td>
<td>( q_s/h3+T )</td>
<td>( q_s/h4+T )</td>
</tr>
</tbody>
</table>

Boundary Conditions
1 From the Physics menu open the Boundary Settings dialog box.
2 Set the boundary conditions as follows; when done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 1</th>
<th>BOUNDARY 10</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Temperature</td>
<td>Convective flux</td>
</tr>
<tr>
<td>( T_0 )</td>
<td>( T_0 )</td>
<td></td>
</tr>
</tbody>
</table>

COMPUTING THE SOLUTION
Click the Solve button on the Main toolbar.

POSTPROCESSING AND VISUALIZATION
1 From the Postprocessing menu open the Plot Parameters dialog box.
2 Click the Line tab.
3 In the Expression edit field type \( T_s \), then click OK.
4 In order to reproduce Figure 2-12, go to the Postprocessing menu and select Domain Plot Parameters.
5 On the General page select the Keep current plot check box.
6 On the Line/Extrusion page select all the subdomains, then click Apply.
7 In the y-axis data area, type $T_s$ in the Expression edit field.
8 In the x-axis data area, click the Expression button. In the X-Axis Data dialog box, type $x$ in the Expression edit field. From the Unit list, select mm.
9 Click OK to close the X-Axis Data dialog box.
10 Click the Line Settings button and from the Line style list select Dashed line. Click OK.
11 Click OK to generate the figure.

**Modeling Using the Graphical User Interface—3D Model**

**Model Library path:** Heat_Transfer_Module/
Electronics_and_Power_systems/simplified_circuit_board_3d_hcoeff

**MODEL NAVIGATOR**
1 Open the Model Navigator, click the New tab, and from the Space dimension list select 3D.
2 From the list of application modes select Heat Transfer Module>General Heat Transfer, then click OK.

**OPTIONS AND SETTINGS**
In the Options menu select Constants. In the dialog box, define the following names and expressions; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>$T_0$</td>
<td>300[K]</td>
</tr>
<tr>
<td>$q_s$</td>
<td>$1[W]/(20*20^2[mm^3])$</td>
</tr>
<tr>
<td>$h_{s1}$</td>
<td>35.0[W/(m^2*K)]</td>
</tr>
<tr>
<td>$h_{s2}$</td>
<td>22.1[W/(m^2*K)]</td>
</tr>
<tr>
<td>$h_{s3}$</td>
<td>19.2[W/(m^2*K)]</td>
</tr>
<tr>
<td>$h_{s4}$</td>
<td>18.0[W/(m^2*K)]</td>
</tr>
<tr>
<td>$u_{in}$</td>
<td>1[m/s]</td>
</tr>
</tbody>
</table>
**GEOMETRY MODELING**

1. Create two blocks. To do so, from the **Draw** menu select **Block**, then enter these settings:

<table>
<thead>
<tr>
<th>OBJECT</th>
<th>LENGTH X</th>
<th>LENGTH Y</th>
<th>LENGTH Z</th>
<th>BASE X</th>
<th>BASE Y</th>
<th>BASE Z</th>
</tr>
</thead>
<tbody>
<tr>
<td>BLK1</td>
<td>0.03</td>
<td>0.03</td>
<td>0.002</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>BLK2</td>
<td>0.02</td>
<td>0.02</td>
<td>0.002</td>
<td>0.005</td>
<td>0.005</td>
<td>0.002</td>
</tr>
</tbody>
</table>

2. Click the **Zoom Extents** button on the Main toolbar.

3. Select both blocks with the mouse, then go to the **Draw** menu and select **Modify>Array**.

4. In the **Displacement** area go to the $x$ edit field and type 0.03; in the **Array size** area find the $x$ edit field and type 4. Click **OK**.

**PHYSICS SETTINGS**

**Subdomain Settings**

1. From the **Physics** menu open the **Subdomain Settings** dialog box.

2. On the **Init** page select all subdomains, then in the $T(t_0)$ edit field type $T_0$.

3. Click the **Conduction** tab and enter the following settings. For Subdomains 2, 4, 6, and 8, click the **Load** button and select **Silicon** from the **Basic Material Properties** library in the **Materials/Coefficients Library** dialog box. This defines $k$, $\rho$, and $C_p$ for those subdomains. When done, click **OK**.

<table>
<thead>
<tr>
<th>QUANTITY</th>
<th>SUBDOMAINS 1, 3, 5, 7</th>
<th>SUBDOMAINS 2, 4, 6, 8</th>
</tr>
</thead>
<tbody>
<tr>
<td>$k$ (isotropic)</td>
<td>0.3</td>
<td>163</td>
</tr>
<tr>
<td>$\rho$</td>
<td>1900</td>
<td>2330</td>
</tr>
<tr>
<td>$C_p$</td>
<td>1369</td>
<td>703</td>
</tr>
<tr>
<td>$Q$</td>
<td>0</td>
<td>$q_s$</td>
</tr>
</tbody>
</table>

**Boundary Conditions**

1. From the **Physics** menu open the **Boundary Settings** dialog box.

2. Select Boundaries 3, 4, 14, 15, 25, 26, 36, and 37. Specify a **Heat flux** boundary condition.

3. Click the **Load** button to load a heat transfer coefficient. This opens the **Materials/Coefficients Library** dialog box.

4. In the **Materials/Coefficients Library** dialog box, select **Forc. Plate, h loc, s=position, U=velocity**, and click **OK**. This brings you back to the **Boundary Settings** dialog.
5 Edit the function call expression in the \( h \) edit field to read
\[ h_{\text{loc}}(T, T_{\text{inf}, \text{htgh}}, x, u_{\text{in}}) \].

6 Type \( T_0 \) in the \( T_{\text{inf}} \) edit field for the external temperature.

7 Set the remaining boundary conditions as follows; when done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 6, 7, 9–11</th>
<th>BOUNDARIES 17, 18, 20–22</th>
<th>BOUNDARIES 28, 29, 31–33</th>
<th>BOUNDARIES 39, 40, 42–44</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Heat flux</td>
<td>Heat flux</td>
<td>Heat flux</td>
<td>Heat flux</td>
</tr>
<tr>
<td>( h )</td>
<td>( h_{s1} )</td>
<td>( h_{s2} )</td>
<td>( h_{s3} )</td>
<td>( h_{s4} )</td>
</tr>
<tr>
<td>( T_{\text{inf}} )</td>
<td>( T_0 )</td>
<td>( T_0 )</td>
<td>( T_0 )</td>
<td>( T_0 )</td>
</tr>
</tbody>
</table>

**COMPUTING THE SOLUTION**

1 From the Solve menu open the Solver Parameters dialog box.

2 In the Solver list select Time dependent. In the Times edit field type 0 1000.

3 Click the Time Stepping tab. In the Times to store in output list select Time steps from solver. Click OK.

4 Click the Solve button on the Main toolbar.

**POSTPROCESSING AND VISUALIZATION**

1 To generate an animation of temperature over time (and reproduce Figure 2-13), go to the Postprocessing menu and open the Plot Parameters dialog box.

2 On the General page, go to the Plot type area and clear the check box next to Slice, then select the check box next to Boundary.

3 On the Animate page click the Start Animation button at the bottom of the dialog box. The software now generates the animation, which might take a few seconds. To replay the animation, use the icons in the lower left corner of the COMSOL Movie Player window.
Forced Turbulent Convection

Introduction

The following set of models demonstrates how to model a conjugate heat transfer problem with COMSOL Multiphysics. The models show two different approaches. The first one uses the Turbulent Non-Isothermal Flow predefined multiphysics coupling from the Heat Transfer Module. The second approach is a simplified one making use of the Heat Transfer Coefficients library supplied with the Heat Transfer Module. In addition, this discussion shows how to modify the $k$-ε Turbulence Model application mode’s equations to take density variations into account (weakly compressible flow).

Figure 2-14 depicts the geometry: a horizontal stream of air that cools a thin and infinitely wide horizontal plate. The plate is at a uniform temperature at the bottom, and the flow is turbulent. This is a well-studied case of convection cooling that works well as a benchmark that demonstrates the accuracy of the modeling methods.

Figure 2-14: Forced convection cooling of a horizontal plate.

You can take two main approaches when simulating forced convection cooling: first, model the heat transfer by using heat transfer coefficients; second, also solve for the fluid flow field and include heat transfer in the fluid domain. The first approach works well for simple geometries such as the one in this example, for which accurate heat transfer coefficient expressions and correlations exist. For more complex geometries, however, such correlations might not describe the situation very well, and so the second approach is the best choice. If you are interested in the flow field or the temperature distribution in the fluid, the second alternative is, of course, the only choice. This exercise explains how to set up both approaches and then compares the results.
Model Definition

**SOLID AND FLUID HEAT TRANSFER—INCLUDING THE FLUID DYNAMICS**

The model works with the following equations:

- Reynolds-averaged Navier-Stokes (RANS) equations in the air domain.
- The conductive and convective heat equation in the air and the solid (copper) wall.

The Turbulent Non-Isothermal Flow predefined multiphysics coupling sets up these application modes together with applicable couplings, making it easy to model the fluid-thermal interaction.

The material properties for the fluid are those of air at atmospheric pressure, and for the solid plate those of copper. You can load these properties from the built-in materials library where the air properties are temperature dependent.

It is necessary to correct the fluid’s thermal conductivity to take into account the effect of mixing due to eddies. The turbulence results in an effective thermal conductivity, \( k_{\text{eff}} \), according to the equation

\[
  k_{\text{eff}} = k + k_T = C_p \eta_T.
\]

Here \( k \) is the physical thermal conductivity of the fluid, \( k_T \) is the turbulent conductivity, \( \eta_T \) denotes the turbulent viscosity, and \( C_p \) equals the heat capacity. With COMSOL Multiphysics you can easily obtain the effective conductivity by using the ready-made fluid group setting in the fluid domain. In the group, the variable for turbulent conductivity is already given in the General Heat Transfer application mode for the fluid.

Figure 2-15 depicts the model with its boundary conditions.

![Figure 2-15: Modeled 2D geometry with boundary conditions.](image)
The boundary conditions for the problem are:

- $k \cdot \varepsilon$ equations in the fluid domain
  - Specified velocity at the inlet
  - Pressure and no viscous stress at the outlet
  - Symmetry at the top boundary
  - Logarithmic wall function at the plate’s surface boundaries

- Heat transport equations
  - Room temperature at the inlet
  - Convection-dominated transport at the outlet
  - Symmetry at the top boundary
  - Thermal wall function at the plate/air interface
  - Fixed temperature at the bottom of the heated plate

To model the solid-fluid interfaces, the model uses the logarithmic wall function boundary condition for turbulent flow, in which an algebraic relationship—the logarithmic wall function—describes the momentum transfer at the solid-fluid interface. This means that the modeled domain ends at the top of the laminar boundary layer where the fluid experiences a significant wall-tangential velocity. This is an important aspect to consider when modeling the heat transfer. Like the fluid velocity, the temperature is not modeled in the laminar sublayer. Instead of assuming the temperature to be continuous across the layer, the model uses a thermal wall function. This creates a jump in temperature between the solid surface and the fluid due to the omitted laminar sublayer. The predefined group for the wall domains defines this wall function in the following way.

To implement the thermal wall function, the model uses two heat transfer application modes: one for the solid and one for the fluid. These are connected through a heat flux boundary condition, the thermal wall function. This means that the resistance to heat transfer through the laminar sublayer is related to that for momentum transfer for the fluid. You therefore determine the heat flux, $q$, from the equation

$$ q = \frac{\rho C_p C_\mu^{1/4} k_w^{1/2} (T_w - T)}{T^*} $$

where $\rho$ and $C_p$ are the fluid’s density and heat capacity, respectively; $C_\mu$ is a numerical constant of the turbulence model; and $k_w$ is the value of the turbulent kinematic
energy at the wall. Furthermore, $T_w$ equals the temperature of the solid at the wall, while $T$ is the fluid temperature on the other side of the omitted laminar sublayer.

The dimensionless quantity $T^+$ is related to the dimensionless wall offset, $\delta_w^+$, through the definition

$$T^+ = \frac{Pr_T}{\kappa} \ln(\delta_w^+) + \beta$$

(2-1)

where the turbulent Prandtl number $Pr_T$ is fixed to 1.0; $\kappa$ is the von Karman constant, which is set to 0.41; and $\beta$ is a model constant set to 3.27. The dimensionless wall offset is defined as

$$\delta_w^+ = \frac{C_{14}}{k_w} \frac{1}{\nu}$$

(2-2)

where $\delta_w$ is the specified wall offset, which in COMSOL Multiphysics defaults to the local mesh size at the boundary, and $\nu = \eta/\rho$ denotes the kinematic viscosity.

At the front of the hot plate a stagnation point for the flow develops. Typical for two-equation turbulence models such as the $k$-$\varepsilon$ model is an unphysical production of turbulence at stagnation points. The remedy is to apply a realizability constraint, which is a physical constraint on the turbulent viscosity. The realizability constraint makes the simulation less stable and is therefore applied only when necessary.

**CONVECTION MODELED AS A BOUNDARY CONDITION**

This simplified model uses only an energy-balance condition for the solid wall. The heat transfer at the fluid/solid interface is calculated with established theoretical correlations. This means that it is not necessary to model the fluid domain. The model determines the heat transfer at the fluid-cooled side of the wall using a heat transfer coefficient correlation from the built-in library. If the aspect of primary interest is heat transfer at the wall/fluid interface, then this method is very useful.

The simplified model uses the same geometry although it applies the heat transfer equations only inside the plate. The model works with the heat transport equations in the solid (copper) plate. For this purpose you can use a General Heat Transfer application mode from the Heat Transfer Module.
The boundary conditions for the heat transport equations are

- Fixed temperature at the bottom of the heated plate
- Flux boundary condition at the plate’s top boundary (interface with fluid) using a heat transfer coefficient.

To describe the heat transfer coefficient for atmospheric air under various conditions, this example models the heat transfer coefficient using the built-in heat transfer coefficient library, which is based on general Nusselt correlations.

**Results for the Flow/Heat Model**

The example solves the problem for a set of inlet velocities between 1 m/s and 100 m/s. Figure 2-16 depicts the temperature distribution for the inlet velocity 1 m/s.

![Figure 2-16: Temperature distribution at an inlet velocity of 1 m/s.](image-url)
The heated layer of air at the plate surface is rather thick considering the relatively high velocity. This is an effect of the turbulent thermal conductivity caused by the eddies in the flow. The next figure depicts the turbulent thermal conductivity of the air.

![Figure 2-17: Turbulent thermal conductivity of the air at an inlet velocity of 100 m/s.](image)

The turbulent conductivity is much higher than the physical thermal conductivity of air, which is $0.03 \text{ W/(m·K)}$ at 323 K. This means that the added turbulent conductivity dominates over the laminar conductivity, and hence that the turbulent eddies cause a significantly higher heat flux at the cooled surface compared to a laminar flow.
In this example you also modify the turbulent flow model to take density variations into account. The density of air decreases with temperature; the following figure shows its variation at an inlet velocity of 1 m/s.

*Figure 2-18: Fluid density at an inlet velocity of 1 m/s.*

These results point out the importance of taking density variations into account. As the density decreases, the fluid velocity increases. This effect becomes apparent in the next figure, which shows the velocity distribution at the same inlet velocity.
Figure 2-19: Velocity field at an inlet velocity of 1 m/s.

If you had treated the flow as being isothermal, the average would not have varied between the inlet and the outlet. However, for a non-isothermal flow the average velocity is inversely proportional to the average density, and it varies with changing average temperature. This means that the flow field for the fluid is different when taking density variations into account.

As the fluid heats up, its velocity increases slightly. Thus the boundary layer decreases and the local heat transfer coefficient should become larger. So if you neglect density variations when modeling forced convection cooling, the model slightly underestimates the cooling/heating power.

The accuracy in predicting the heat transfer coefficient in this example is dictated by the accuracy of the Reynolds analogy and the accuracy of the flow model. The situation this example models is very well studied, so you can readily verify the results in terms of heat transfer coefficient predictions. The following figure compares the local
$h$ coefficient from the model with an empirical expression valid for the geometry and conditions studied (assuming turbulent flow).

Figure 2-20: Local heat transfer coefficient as determined empirically (solid) and with the model (dashed) for various inlet velocities.

The model agrees well with empirical data for low to intermediate inlet velocities. The deviations at the leading edge of the plate are due to the correlation, which assumes that the boundary layer is fully developed for all $x$. However, at high inlet velocities the results do not match quite as well due to the model of the flow. The logarithmic wall function in COMSOL Multiphysics is valid under certain conditions that depend on the resolution, the velocity, and the viscosity. As displayed in Equation 2-1, the wall function uses the dimensionless wall offset, $\delta_w^+$ (defined in Equation 2-2). For the wall function to be an accurate approximation, $\delta_w^+$ for the first internal node should be larger than 30 but less than some upper limit dependent on the Reynolds number (for more details see the section “Turbulent Fluid-Thermal Interaction” on page 201 of the *Heat Transfer Module User’s Guide*). Figure 2-21 depicts the parameter $\delta_w^+$ against plate surface for various inlet velocities.
Figure 2-21: Dimensionless wall distance at the plate surface for various inlet velocities.

A maximum $\delta_w^+$ value of a few hundreds is always acceptable, whereas a value above 1000 is always questionable. Note that the value of $\delta_w^+$ exceeds 1000 when the inlet velocity is 50 m/s or higher. Hence, the mesh is a bit too coarse for this case. As a consequence, both the fluid velocity at the boundary and the heat transfer coefficient become less accurate. You can easily correct this situation by making the mesh finer at the boundary at the leading edge of the plate.

Results for the Simplified Model

Now examine the results of the much simpler model, which uses $h$ coefficients from the built-in library. This simplified case does not model the flow field or the temperature distribution in the fluid. Therefore, it is “inexpensive” to solve in terms of memory requirements and calculation time—it solves in just a few seconds. Nevertheless, the results are rather accurate because the heat transfer coefficient is based on an empirical relationship.

Figure 2-22 compares the heat flux at the plate interface as calculated by this model to that of the previous, more complex, model.
Figure 2-22: Comparison of normal total heat flux at the plate surface for the simplified (solid) and the flow/heat (dashed) models at various inlet air velocities.

The figure shows that the heat flux of the simplified model differs from the that of the flow/heat model. Because the simplified model uses well-established empirical relationships, you can consider its result more accurate. It shows the heat flux being significantly lower in the inlet region (at low values of $x$). This is a consequence of the initially laminar flow, which results in a much lower heat transfer coefficient. Then, above a certain $x$ value, the flow turns turbulent and the heat transfer coefficient grows significantly. This appears in the plot as a sudden increase in the heat flux. On the other hand, the flow/heat model assumes that the flow is turbulent in the entire geometry, and therefore the heat flux is significantly larger.

To conclude, the flow/heat approach results in rather good predictions of the local boundary heat flux compared to reference values, but it assumes that the flow is turbulent at the inlet. That method is rather straightforward to model in COMSOL Multiphysics but requires a few minutes of computational time. On the other hand, the simplified approach is very powerful for situations where you are interested only in the solid’s boundary heat flux. You can employ this approach, however, only if you can find a well-established correlation. For many geometries such correlations do not exist,
and then the flow/heat approach is useful. The choice of method for modeling convective cooling or heating depend on your needs and the particular case.

References


Modeling in COMSOL Multiphysics

The COMSOL Multiphysics implementation is straightforward using the Heat Transfer Module’s Turbulent Non-Isothermal Flow multiphysics coupling, combining the General Heat Transfer and $k$-$\varepsilon$ Turbulence Model application modes. In the following steps you begin by setting up and solving the model with the fluid included. In the next section you then simplify the model.

Model Library path: Heat_Transfer_Module/
Electronics_and_Power_Systems/forced_turbulent_convection

Modeling Using the Graphical User Interface—The Flow/Heat Model

Model Navigator

1. Open the Model Navigator, and from the Space dimension list select 2D.

2. In the list of application modes, select

   Heat Transfer Module>Fluid-Thermal Interaction>Turbulent Non-Isothermal Flow, k-$\varepsilon$.

3. Click OK.

Geometry

1. Using the Rectangle dialog box, create two rectangles with specifications according to the following table. You launch the Rectangle dialog box by shift-clicking the
Rectangle/Square button on the Draw toolbar or by choosing Specify Objects>Rectangle from the Draw menu.

<table>
<thead>
<tr>
<th>OBJECT</th>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>BASE</th>
<th>X</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>1.1</td>
<td>0.2</td>
<td>Corner</td>
<td>-0.1</td>
<td>0</td>
</tr>
<tr>
<td>R2</td>
<td>1</td>
<td>0.01</td>
<td>Corner</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

2 Click the Zoom Extents button on the Main toolbar.

You should now see the following geometry:

**CONSTANTS, EXPRESSIONS, AND VARIABLES**

1 From the Options menu, open the Constants dialog box. Specify the following names, expressions, and descriptions (optional); when finished, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>T_amb</td>
<td>293[K]</td>
<td>Surrounding air temperature</td>
</tr>
<tr>
<td>delta_T</td>
<td>100[K]</td>
<td>Plate-to-air temperature difference</td>
</tr>
<tr>
<td>T_av</td>
<td>T_amb+delta_T/2</td>
<td>Average temperature</td>
</tr>
<tr>
<td>p_ref</td>
<td>1.013e5[Pa]</td>
<td>Reference pressure</td>
</tr>
<tr>
<td>u_in</td>
<td>1[m/s]</td>
<td>Inlet velocity</td>
</tr>
</tbody>
</table>
2. Choose Options>Expressions>Scalar Expressions. Specify the following names, expressions, and descriptions (optional); when finished, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>L</td>
<td>x</td>
<td>Distance from leading edge</td>
</tr>
<tr>
<td>ReL_ref</td>
<td>u_in*L/mat1_nu0(T_av[1/K]) [m^2/s]</td>
<td>Reference Reynolds number</td>
</tr>
<tr>
<td>Pr_ref</td>
<td>mat1_eta(T_av[1/K]) [Pa<em>s]</em> mat1_Cp(T_av[1/K]) [J/(kg<em>K)] / mat1_k(T_av[1/K]) [W/(m</em>K)]</td>
<td>Reference Prandtl number</td>
</tr>
<tr>
<td>NuL_ref</td>
<td>0.037<em>ReL_ref^0.8</em>Pr_ref^0.33</td>
<td>Reference Nusselt number</td>
</tr>
<tr>
<td>h_ref</td>
<td>mat1_k(T_av[1/K]) [W/(m<em>K)]</em> NuL_ref/L</td>
<td>Handbook h coefficient</td>
</tr>
</tbody>
</table>

**PHYSICS SETTINGS**

Now it is time to set up the physics in the subdomain and the boundary conditions. In this model you load the material properties from the built-in materials library.

1. From the Multiphysics menu, select 3 k-ε Turbulence Model.
2. From the Physics menu, select Properties.
3. Set Realizability to On, then click OK.
5. Select Solid domain from the Group list underneath the Subdomain selection list.
7. Then click the Load button to open the Materials/Coefficients Library dialog box. Select Basic Material Properties>Air, 1 atm, then click OK.
8. Modify the expression in the Dynamic viscosity edit field by replacing T with Tf.
9. Next, edit the predefined entry for the density. To do so, go to the Density tab and click in the Density edit field, and replace p with p_ref and T with Tf; the entry should read
   \[ \rho_0(p_{ref}[1/Pa],Tf[1/K])[kg/m^3]. \]
10. Clear the Pressure p check box.
11. Click OK to close the Subdomain Settings dialog box.
12 Choose Physics>Boundary Settings. Then apply the following boundary conditions:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 1</th>
<th>BOUNDARIES 2, 3</th>
<th>BOUNDARIES 4, 6</th>
<th>BOUNDARY 8</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Inlet</td>
<td>Symmetry boundary</td>
<td>Wall</td>
<td>Outlet</td>
</tr>
<tr>
<td>Condition</td>
<td>Velocity</td>
<td>Logarithmic wall function</td>
<td>Pressure</td>
<td></td>
</tr>
<tr>
<td>$u_0$</td>
<td>$u_{_in}$</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>$L_T$</td>
<td>0.001</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>$I_T$</td>
<td>0.01</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>$\delta_w$</td>
<td>h</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>$p_0$</td>
<td></td>
<td></td>
<td>0</td>
<td></td>
</tr>
</tbody>
</table>

The small values of $L_T$ and $I_T$ are appropriate for essentially non-turbulent free-stream flows.

13 Click OK.

Now set up the parameters for the heat transfer.

1 From the Multiphysics menu, select 1 General Heat Transfer (htgh).
2 From the Physics menu, select Subdomain Settings.
3 Select Subdomain 2. Then select Solid domain from the Group list.
4 Select Subdomain 1. Select Fluid domain from the Group list.
5 From the Library material list, select Air, 1 atm.
6 For that material, edit the expressions for the Thermal Conductivity, the Density, and the Heat capacity by replacing $p$ with $p_{_ref}$ and $T$ with $T_f$.
7 Click the Init tab. In the $T_f(t_0)$ edit field type $T_{_amb}$, then click OK.
8 From the Physics menu, open the Boundary Settings dialog box.
9 Specify boundary conditions according to the following table. When done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 1</th>
<th>BOUNDARIES 2, 3</th>
<th>BOUNDARIES 4, 6</th>
<th>BOUNDARY 8</th>
</tr>
</thead>
<tbody>
<tr>
<td>Object</td>
<td>Inlet</td>
<td>Top and inlet bottom boundary</td>
<td>Plate surface</td>
<td>Outlet</td>
</tr>
<tr>
<td>Group</td>
<td></td>
<td></td>
<td>wall</td>
<td></td>
</tr>
<tr>
<td>Boundary condition</td>
<td>Temperature</td>
<td>Thermal insulation</td>
<td>Convective flux</td>
<td></td>
</tr>
<tr>
<td>$T_0$</td>
<td>$T_{_amb}$</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

10 From the Multiphysics menu select, 2 General Heat Transfer (htgh2).
From the **Physics** menu, select **Subdomain Settings**.

2. Select Subdomain 1, then select **Fluid domain** from the **Group** list.

3. Select Subdomain 2, then select **Solid domain** from the **Group** list. The default physical parameters correspond to copper and are correct. Click **OK**.

4. From the **Physics** menu, select **Boundary Settings**.

5. Specify the following boundary conditions; when finished, click **OK**.

### Mesh Generation

To solve the problem and get an accurate solution, the mesh must be fine at the solid/fluid interface, especially at the point of first contact. Generate such a mesh with the following steps:

1. Choose **Mesh>Free Mesh Parameters**. In the list of **Predefined mesh sizes** select **Coarse**.

2. Go to the **Boundary** page and select Boundaries 4 and 6. Set the **Maximum element size** to $3 \times 10^{-3}$ and the **Element growth rate** to 1.2.

3. Go to the **Point** page and select Point 4. Set the **Maximum element size** to $1 \times 10^{-3}$.

4. Click **Remesh** to generate the mesh. When the mesher has finished, click **OK**.

### Computing the Solution

Solve this model for a range of inlet velocities with the parametric solver. The solution procedure involves a first solution step that solves for the fluid velocity without any influence from temperature using only one inlet velocity. This is necessary to get a good initial value for the thermally coupled calculations. That solution then works in the parametric solver, which solves the problem as fully coupled for a set of inlet velocities.

1. Click the **Solver Parameters** button on the Main toolbar.

2. From the **Solver** list, select **Parametric segregated**.

3. Select the **Manual specification of segregated steps** check box.

4. Set the **Damping** for **Group 1** to 0.25.
5 In the Parameter name edit field type \( u_{in} \), and in the Parameter values edit field type 1 20 50 100.

6 Click the Parametric tab. From the Predictor list, select Constant.

7 Select the Manual tuning of parameter step size check box. In the three edit fields (Initial step size, Minimum step size, and Maximum step size) type 2, 20, and 50, respectively. These settings force the parameter solver to take larger steps than it would do by default, which in turn reduces the solution time.

8 Click OK, then click the Solve button on the Main toolbar. The software needs roughly 30 minutes to solve this setup on a 3-GHz PC.

**POSTPROCESSING AND VISUALIZATION**

Reproduce the plots in Figure 2-16–Figure 2-19 using the Plot Parameters dialog box.

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, select 1 from the Parameter value list.

3 Click Apply to generate the plot in Figure 2-16.

Proceed to generate the plot in Figure 2-17 of the turbulent thermal conductivity, \( k_T \) with the following steps:

4 On the General page, select 100 from the Parameter value list.

5 Click the Surface tab. Type \( k_T_{chcc} \) in the Expression edit field on the Surface Data page, then click Apply to generate the plot.

Next reproduce Figure 2-18 as follows:

6 While still on the Surface page, type \( \rho_{chcc} \) in the Expression edit field on the Surface Data page.

7 On the General page, select 1 from the Parameter value list. Click Apply.

To generate Figure 2-19 execute the following instructions:

8 Click the Surface tab. From the Predefined quantities list on the Surface Data page, select k-\( \epsilon \) Turbulence Model (chns)>Velocity field.

9 Click OK.

Use the Domain Plot Parameters dialog box to generate Figure 2-20–Figure 2-22:

1 From the Postprocessing menu, select Domain Plot Parameters.


3 In the y-axis data area, type abs(ntf\_flux_Tf\_chcc/(Ts-Tf)) in the Expression edit field. From the x-axis data list, select x.
4 Click the **Line Settings** button. From the **Line style** list, select **Dashed line**. Select the **Legend** check box, then click **OK**.

5 Click **Apply** to generate the first lines of the plot.

6 On the **General** page, select the **Keep current plot** check box.

7 Return to the **Line/Extrusion** page. In the **Expression** edit field, type `h_ref`.

8 Click the **Line Settings** button. From the **Line style** list, select **Solid line**. Click **OK**.

9 Click **Apply** to finalize the plot in Figure 2-20.

Next, turn to the plot in Figure 2-21:

10 On the **General** page, clear the **Keep current plot** check box.

11 On the **Line/Extrusion** page, type `dwplus_chns` in the **Expression** edit field.

12 Click **Apply**.

Finally, you reproduce the plot in Figure 2-22 with the following steps:

13 From the **Predefined quantities** list select
   
   **General Heat Transfer (htgh)>Normal total heat flux**.

14 Click the **Line Settings** button. From the **Line style** list select **Dashed line**, then click **OK**.

15 Click **OK** to close the **Domain Plot Parameters** dialog box and generate the plot.

If you want to overlay the results from the simplified model, keep the Figure 1 window open and then proceed as follows:

1 To open the other model, choose **File>Open Model Library**, browse to the location
   
   Model Library>Heat Transfer Module>Electronics and Power Systems>
   
   forced_turbulent_convection_hcoeff, and click **OK**.

2 From the **Postprocessing** menu, select **Domain Plot Parameters**.

3 On the **General** page, select **Figure 1** from the **Plot in** list and select the **Keep current plot** check box.

4 On the **Line/Extrusion** page, select Boundary 3.

5 Select **General Heat Transfer (htgh)>Normal total heat flux** from the list of **Predefined quantities**.

6 From the **x-axis data** list select `x`, then click **OK**.
Model Library path: Heat_Transfer_Module/
Electronics_and_Power_Systems/forced_turbulent_convection_hcoeff

You can build this model from scratch or modify the previous one. If you prefer to modify the previous model, simply alter the boundary settings of the second General Heat Transfer application mode and the solver settings so that you only solve for the htgh2 application mode.

To build the model from scratch, follow these steps:

**MODEL NAVIGATOR**
1. Open the Model Navigator, and from the Space dimension list select 2D.
2. In the list of application modes select Heat Transfer Module>General Heat Transfer>Steady-state analysis. Click OK.

**GEOMETRY**
For this model it suffices to draw the plate because you model only the temperature in the solid plate.

Shift-Click the Rectangle/Square button on the Draw toolbar. Create a rectangle with the following specifications; when finished, click OK.

<table>
<thead>
<tr>
<th>OBJECT</th>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>BASE</th>
<th>X</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>1</td>
<td>0.01</td>
<td>Corner</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

**CONSTANTS, EXPRESSIONS, AND VARIABLES**
From the Options menu open the Constants dialog box. Specify the following names and expressions, then click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>T_amb</td>
<td>293[K]</td>
<td>Surrounding air temperature</td>
</tr>
<tr>
<td>delta_T</td>
<td>100[K]</td>
<td>Plate-to-air temperature difference</td>
</tr>
</tbody>
</table>
PHYSICS
The default material settings are those for copper. This means you do not have to
modify the material properties. However, for the model to run smoothly, it is
important to specify a suitable initial value in the domain.

1 Select the menu item Physics>Subdomain Settings.
2 Select Subdomain 1.
3 Click the Init tab. In the \( T(t_0) \) edit field type \( T_{\text{amb}} + \delta T \), then click OK.
4 From the Physics menu open the Boundary Settings dialog box.
5 Select Boundary 2 (the bottom of the plate). In the Boundary condition list select
Temperature, then in the \( T_0 \) edit field type \( T_{\text{amb}} + \delta T \).
6 Select Boundary 3 (the fluid interface that is cooled). In the Boundary condition list
select Heat flux.
7 To load a heat transfer coefficient function from the Materials/Coefficients Library,
  click the Load button to open the Materials/Coefficients Library dialog box.
8 Select the coefficient function with the name Forc. Plate, \( h_{\text{loc}}, s=\text{position}, U=\text{velocity} \)
  from the Heat Transfer Coefficients>Air, Ext. Forced Convection folder; then
  click OK.
9 When back in the Boundary Conditions dialog box, edit the last two input variables
to the \( h_{\text{loc}} \) function so that the value in the \( h \) edit field becomes \( h_{\text{loc}}(T[1/K], T_{\text{inf htgh}}[1/K], x[1/m], u_{\text{in}})[W/(m^2*K)] \). The \( x \) coordinate and the inlet
  velocity replace the default input variables for length and velocity.
10 In the \( T_{\text{inf}} \) edit field and type \( T_{\text{amb}} \), then click OK.

SOLUTION AND POSTPROCESSING
1 Open the menu item Solve>Solver Parameters. From the Solver list select Parametric.
2 Go to the Parameter name edit field and type \( u_{\text{in}} \). In the Parameter values edit field
type \( 1 \ 20 \ 50 \ 100 \).
3 Click the Parametric tab. In the Predictor list select Constant.
4 Select Manual tuning of parameter step size check box. In all three edit fields (Initial
  step size, Minimum step size and Maximum step size) type 50. This setting forces the
  parameter solver to take steps as large as possible, which reduces the solution time.
5 Click OK, then click the Solve button on the Main toolbar. The model solves in a few
  seconds.
6 To generate the part of Figure 2.22 related to these results, select
  Postprocessing>Domain Plot Parameters. Go to the Line/Extrusion page.
7 Select Boundary 3. Select Normal total heat flux (htgh) from the list of Predefined quantities.

8 From the x-axis data list select \(x\), then click OK.
Microchannel Heat Sink

Introduction

This example models a microchannel heat sink mounted on an active electronic component. The model geometry is based on a paper by B.C. Pal and others (Ref. 1) as well as another from S.P. Jang and others (Ref. 2).

Thermal management has become a critical aspect of today’s electronic systems, which often include many high-performance circuits that dissipate large amounts of heat. Many of these components require efficient cooling to prevent overheating. Some of these components, such as processors, require a heat sink with cooling fins that are exposed to forced air from a fan. This discussion develops the model of an aluminum microchannel heat sink whose manifolds work as flow dividers to improve its cooling performance (see Figure 2-23).

This case examines the temperature field in the air, in the aluminum, and in the heat source. The air transports heat by convection and conduction. Because the geometry is fairly complicated, it is not possible to use an analytical expression for the velocity profile, so you must also model the fluid flow and couple it to the heat equation. The aluminum heat sink transports thermal energy by pure conduction. Finally, to approximate the electronic component that requires cooling, the model uses a rectangular block with a given volume heat source.

Figure 2-23: Microchannel heat sink with manifolds.
Model Definition

The model geometry consists of three subdomains: the electronic component, the aluminum heat sink, and the cooling air. Because of symmetry, it is sufficient to model just a small element of the entire geometry as shown in Figure 2.24.

In particular, the surfaces labeled “inlet” and “outlet” in the figure each constitutes a quarter of the actual inlet and outlet, respectively.

This simulation employs the General Heat Transfer and the Weakly Compressible Navier-Stokes application modes for stationary analysis. The first mode models the temperature field in the entire geometry; the second one serves only to model the airflow.

Both the component and the heat sink transport heat by pure conduction as described by the conductive heat equation

\[ \nabla \cdot (-k \nabla T) = Q \]

where \( k \) (W/(m·K)) is the thermal conductivity, \( Q \) (W/m\(^3\)) is the heat source, and \( T \) (K) denotes the temperature. The model’s heat source relates to the component’s output power, and \( Q \) equals zero for the heat sink because that device has no heat sources.

The temperature field in the air is governed by the heat equation for conduction and convection

Figure 2-24: Symmetry element for modeling the heat sink and the heat source.
\[ \rho C_p u \cdot \nabla T - \nabla \cdot (k \nabla T) = 0 \]

where \( k \) refers to the thermal conductivity (W/(m·K)), \( \rho \) is the density (kg/m\(^3\)) and \( C_p \) denotes the specific heat capacity (J/(kg·K)) for air. You obtain the velocity vector \( u \) (m/s) from the equations for the airflow as described later in this section.

The boundary conditions for the heat-transfer equations are:

- \( T = T_{in} \) at the inlet,
- \( \mathbf{q} \cdot \mathbf{n} = (\rho C_p u T) \cdot \mathbf{n}; \quad \mathbf{n} \cdot (-k \nabla T) = 0 \) at the outlet,
- \( \mathbf{n} \cdot (-k \nabla T + \rho C_p u T) = 0 \) elsewhere.

The last equation applies equally well at thermally insulated boundaries and at boundaries through which no heat flows because of symmetry. In addition, assume heat-flux continuity on all interior boundaries.

Now use the Weakly Compressible Navier-Stokes equations for the momentum equations and the equation of continuity to describe the air’s velocity and pressure field:

\[
\begin{align*}
\rho \mathbf{u} \cdot \nabla \mathbf{u} &= \nabla \cdot \left[-p \mathbf{I} + \eta \left( \nabla \mathbf{u} + (\nabla \mathbf{u})^T \right) - \frac{2\eta}{3}(\nabla \cdot \mathbf{u}) \mathbf{I} \right] + \mathbf{F} \\
\nabla \cdot (\rho \mathbf{u}) &= 0
\end{align*}
\]

where \( \eta \) denotes the dynamic viscosity (Pa·s), \( \mathbf{u} \) is the velocity (m/s), \( \rho \) is the fluid density (kg/m\(^3\)), \( p \) represents pressure (Pa), and \( \mathbf{F} \) is the volume force (N/m\(^3\)).

The air density depends on the pressure and temperature according to the ideal gas equation

\[ \rho = \frac{p}{RT} \]

where \( R \) is the mass-based gas constant, equal to 287 J/(kg·K) for air.

You can assume that the volume force, \( \mathbf{F} \), is zero because gravitational forces due to changes in density most likely have very little impact on this model.

At the inlet, the fluid enters with a parabolic velocity profile modeling fully developed laminar flow. The mean velocity is approximately 1 m/s, and the air temperature is 293 K. At the outlet the pressure is \( 10^5 \) Pa, and heat leaves through convection.
These assumptions lead to the following boundary conditions for the Weakly Compressible Navier-Stokes application mode:

\[
\begin{align*}
\mathbf{u} &= 0 \quad \text{at walls} \\
\mathbf{n} \cdot \mathbf{u} &= 0 \quad \text{at symmetry boundaries} \\
p &= p_0 \quad \text{at the outlet} \\
\mathbf{u} &= (0, 0, w) \quad \text{at the inlet}
\end{align*}
\]

Here, the outlet pressure equals \(p_0 = 1.0 \cdot 10^5\) Pa, and the \(z\)-component of the inlet velocity is

\[
w = -0.3 \cdot 10^{16} (2.5 \cdot 10^{-4} + x)(2.5 \cdot 10^{-4} - x)(1 \cdot 10^{-4} + y)(1 \cdot 10^{-4} - y) \text{ m/s}
\]

with \(x\) and \(y\) expressed in meters. The prefactor is calculated to give an average inflow speed of \(1 \text{ m/s}\) at the rectangular inlet surface measuring \(5 \cdot 10^{-4} \text{ m} \times 2 \cdot 10^{-4} \text{ m}\) and centered at \(x = 0, y = 0\). The model geometry covers only the part where \(x \geq 0, y \geq 0\).

**Adding Thermal Contact Resistance**

The model described thus far assumes perfect thermal contact at the interface between the heat source and the aluminum heat sink. A more realistic model accounts for the interface’s thermal contact resistance. That resistance is an important factor in the design of electronics cooling because it can significantly reduce a heat sink’s cooling performance. The following discussion describes how to account for the thermal contact resistance, starting from the initial model.
The analysis is based partly on reference Ref. 3, which presents an analysis of how to calculate the interface resistance for a ceramic package/aluminum heat-sink assembly.

Figure 2-25: The interface between the heat source and the heat sink.

Figure 2-25 shows the interface between the heat source and the heat sink. The surfaces of the heat sink and the ceramic heat source are not in perfect contact because of their roughness; air fills the gaps between the surfaces.

Modeling the interface with the geometry of the rough surfaces would require a very dense mesh. An alternative, more practical, way of modeling the interface is to define a thermal joint conductivity, \( h_j \) (W/(m\(^2\).K)), that is representative for the interface.

Using the thermal joint conductivity, the heat flux from the heat source to the heat sink is

\[
q_{\text{source} \rightarrow \text{sink}} = h_j (T_{\text{source}} - T_{\text{sink}}) \tag{2-3}
\]

where \( T_{\text{sink}} \) is the temperature of the aluminum heat sink at the interface, and \( T_{\text{source}} \) is the temperature of the ceramic heat source at the interface. Equation 2-3 states that the difference in temperature across the interface drives the heat flux.

Similarly, the heat flux from the heat sink to the heat source is

\[
q_{\text{sink} \rightarrow \text{source}} = h_j (T_{\text{sink}} - T_{\text{source}}) \tag{2-4}
\]

Note that \( q_{\text{sink} \rightarrow \text{source}} \) has a negative value as long as the source temperature is higher than the sink temperature.
These two heat-flux conditions maintain heat flux continuity through the interface, that is, the heat flux out of the heat source equals the heat flux into the heat sink.

Ref. 3 shows how to calculate the thermal joint conductivity of an interface that is similar to the one in this model; here follows a brief summary.

The thermal joint conductivity, \( h_j \), is defined as the sum of the conductivity through those regions that are in contact and those where there is a gap,

\[
 h_j = h_c + h_g
\]  

(2-5)

where \( h_c \) is the contact conductivity and \( h_g \) is the gap conductivity, both measured in \( \text{W/}(\text{m}^2 \cdot \text{K}) \). The contact conductivity is determined by the expression

\[
 h_c = 1.25k_s \frac{m \sigma}{H_c} \left( \frac{P}{H_c} \right)^{0.95}
\]  

(2-6)

where \( k_s \), \( m \), \( \sigma \), and \( H_c \) are parameters specifying the material and surface characteristics of the surfaces, and \( P \) is the contact pressure.

The gap conductance is

\[
 h_g = \frac{k_g}{Y + M}
\]  

(2-7)

where \( k_g \) is the thermal conductivity of the air in the gap, \( Y \) is the effective gap thickness, and \( M \) is a gas parameter that accounts for rarefaction effects at high temperatures and low pressures.

For this model you apply the value \( h_j = 5400 \text{ W/}(\text{m}^2 \cdot \text{K}) \). For more details on how to compute these properties according to Equation 2-5, Equation 2-6, and Equation 2-7, see Ref. 3.

In COMSOL Multiphysics you model thermal contact resistance by applying the Thin thermally resistive layer boundary condition:

\[
 -n_u \cdot (-k_u \nabla T_u) = \frac{k_{res}}{d_{res}} (T_d - T_u)
\]  

(2-8)

\[
 -n_d \cdot (-k_d \nabla T_d) = \frac{k_{res}}{d_{res}} (T_u - T_d)
\]

This is a so-called slit boundary condition that allows for a discontinuity in the temperature field across the boundary. The parameters of the boundary condition are
the layer thermal conductivity \( k_{\text{res}} \), and layer thickness \( d_{\text{res}} \). For this model, we only know the factor \( k_{\text{res}} / d_{\text{res}} \), which is equal to our thermal joint conductivity \( h_j \). We can specify the correct thermal joint conductivity by applying the values \( k_{\text{res}} = h_j \cdot 1.0 \) m and \( d_{\text{res}} = 1.0 \) m.

Slit boundary conditions are only available on assembly pair boundaries, which requires us to set up an assembly geometry to model contact resistance.

**Results and Discussion**

Figure 2-26 shows the resulting temperature field for the initial model. It indicates that this scheme holds the component’s temperature at roughly 337 K. The air temperature increases from 295 K to approximately 337 K on its way from the inlet to the outlet, something you could expect because the air absorbs heat energy from the aluminum. The figure also shows streamlines for the total heat flux. The streamlines show that the heat energy leaves the aluminum and escapes through the outlet.

*Figure 2-26: Temperature field and heat-flux streamlines.*
The velocity field and its streamlines appear in Figure 2-27. Again, as expected, the velocities are highest at the inlet and outlet.

Figure 2-27: Velocity field with velocity streamlines.

Figure 2-28 shows the temperature field of the extended model, which accounts for the thermal contact resistance of the interface between the heat source and sink. A small temperature jump is observed on the interface. The maximum temperature of the component is roughly 1 K higher than the result obtained with the initial model. This confirms that the interface’s thermal contact resistance does have an impact on the heat sink’s cooling performance, albeit a small one.
Most importantly, the results show that the electronic component does not overheat when operating continuously at the given power.

![Temperature field](image)

**Figure 2-28: Temperature field when accounting for the thermal contact resistance.**

**References**


**Model Library path:** Heat_Transfer_Module/ Electronics_and_Power_Systems/microchannel_heatsink
Model Library path: Heat_Transfer_Module/
Electronics_and_Power_Systems/microchannel_heatsink_res

Modeling Using the Graphical User Interface

The first part of this section describes how to build and solve the initial model, which
does not account for the thermal contact resistance at the interface between the heat
source and the heat sink.

MODEL NAVIGATOR
9 In the Model Navigator go to the New page. From the Space dimension list select 3D.
10 In the list of application modes, select Heat Transfer Module>
11 Click OK.

OPTIONS AND SETTINGS
From the Options menu select Constants. Enter these names, expressions, and
(optionally) descriptions; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>T0</td>
<td>295[K]</td>
<td>Inlet air temperature</td>
</tr>
<tr>
<td>eta_air</td>
<td>18e-6[Pa*s]</td>
<td>Dynamic viscosity, air</td>
</tr>
<tr>
<td>k_air</td>
<td>27[mW/(m*K)]</td>
<td>Thermal conductivity, air</td>
</tr>
<tr>
<td>Cp_air</td>
<td>1006[J/(kg*K)]</td>
<td>Specific heat capacity, air</td>
</tr>
<tr>
<td>p0</td>
<td>1e5[Pa]</td>
<td>Outlet air pressure</td>
</tr>
<tr>
<td>k_ceramic</td>
<td>20.9[W/(m*K)]</td>
<td>Thermal conductivity, ceramic</td>
</tr>
<tr>
<td>Q_source</td>
<td>5[W/cm^3]</td>
<td>Heat production, ceramic</td>
</tr>
</tbody>
</table>

GEOMETRY MODELING
1 Go to the Draw menu and select Work-Plane Settings.
2 On the Quick page, select the x-y option button and in the z edit field type 2.85e-3.
3 Click OK.
4 Shift-click the Rectangle/Square button on the Draw toolbar.
5. In the dialog box that appears, enter these properties; when done, click **OK**.

<table>
<thead>
<tr>
<th>OBJECT DIMENSIONS</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>1e - 3</td>
</tr>
<tr>
<td>Height</td>
<td>2e - 4</td>
</tr>
<tr>
<td>Base</td>
<td>Corner</td>
</tr>
<tr>
<td>x-position</td>
<td>0</td>
</tr>
<tr>
<td>y-position</td>
<td>0</td>
</tr>
</tbody>
</table>

6. Click the **Zoom Extents** button on the Main toolbar.

7. In the same manner, create a second rectangle with these properties:

<table>
<thead>
<tr>
<th>OBJECT DIMENSIONS</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>1e - 3</td>
</tr>
<tr>
<td>Height</td>
<td>1e - 4</td>
</tr>
<tr>
<td>Base</td>
<td>Corner</td>
</tr>
<tr>
<td>x-position</td>
<td>0</td>
</tr>
<tr>
<td>y-position</td>
<td>0</td>
</tr>
</tbody>
</table>

8. From the **Draw** menu open the **Extrude** dialog box.

9. From the **Object selection** list select **R1**. In the **Distance** edit field type -2.85e - 3, then click **OK**.

10. Click the **Geom2** tab.

11. Using the method of Steps 8 and 9, extrude the large rectangle, R1, once again but now by a **Distance** of -1.85e - 3.

12. Click the **Geom2** tab.

13. Extrude the small rectangle, R2, by a **Distance** of -1.85e - 3.

14. Click the **Geom2** tab.

15. Draw two new rectangles with the properties in the following tables:

<table>
<thead>
<tr>
<th>OBJECT DIMENSIONS</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>5e - 4</td>
</tr>
<tr>
<td>Height</td>
<td>1e - 4</td>
</tr>
<tr>
<td>Base</td>
<td>Corner</td>
</tr>
<tr>
<td>x-position</td>
<td>2.5e - 4</td>
</tr>
<tr>
<td>y-position</td>
<td>0</td>
</tr>
</tbody>
</table>
Click the Create Composite Object button on the Draw toolbar.

In the Object selection list select R3 and R4, the two rectangles you just created. Click OK to create their union, CO1.

From the Draw menu choose Extrude. Select the new composite object, CO1.

In the Distance edit field type -2.5e-4, then click OK.

Click the Create Composite Object button.

In the Set formula edit field type EXT1+EXT2+EXT3-EXT4, then click OK.

Double-click the AXIS button on the status bar at the bottom of the user interface to hide the coordinate axes.

PHYSICS SETTINGS

Go to the Options menu and select Expressions>Boundary Expressions.

Select Boundary 10 and enter the following expression; when done, click OK.

This gives a parabolic inlet-velocity profile with a maximum inflow speed of 1.875 m/s and average inflow speed of 0.833 m/s.

Subdomain Settings—Weakly Compressible Navier-Stokes

From the Multiphysics menu select Weakly Compressible Navier-Stokes (chns).

Go to the Physics menu and select Subdomain Settings.

Select Subdomains 1 and 2.

From the Group list, select Solid domain.

Select Subdomain 3 and enter eta_air in the η edit field.

Click the Init tab, then in the p(t0) edit field type p0.

Click OK.
Boundary Conditions—Weakly Compressible Navier-Stokes

1. From the Physics menu select Boundary Settings.

2. Enter settings from the following table; when done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 7, 8, 23</th>
<th>BOUNDARIES 9, 11, 12, 16, 17, 18, 20</th>
<th>BOUNDARY 10</th>
<th>BOUNDARY 19</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary type</td>
<td>Wall</td>
<td>Wall</td>
<td>Inlet</td>
<td>Outlet</td>
</tr>
<tr>
<td>Boundary condition</td>
<td>Slip</td>
<td>No slip</td>
<td>Velocity</td>
<td>Pressure, no viscous stress</td>
</tr>
<tr>
<td>( u_0 )</td>
<td>0</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>( v_0 )</td>
<td>0</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>( w_0 )</td>
<td>( w_{\text{inlet}} )</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>( p_0 )</td>
<td>( p_0 )</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Subdomain Settings—General Heat Transfer

1. Go to the Multiphysics menu and select 2 Geom1: General Heat Transfer (htgh).

2. In the Physics menu select Subdomain Settings.

3. Select Subdomain 1. From the Group list, select Solid domain.

4. Enter the following properties. When done, click OK.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>( k ) (isotropic)</td>
<td>( k_{\text{ceramic}} )</td>
</tr>
<tr>
<td>( Q )</td>
<td>( Q_{\text{source}} )</td>
</tr>
</tbody>
</table>

5. Select Subdomain 2. From the Group list, select Solid domain.

6. Click the Load button.

7. In the Materials list, select Basic Material Properties>Aluminum, then click OK.

8. Select Subdomain 3. On the Conduction page, enter the following settings (for properties not listed, keep the default settings):

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>( k ) (isotropic)</td>
<td>( k_{\text{air}} )</td>
</tr>
<tr>
<td>( C_p )</td>
<td>( C_{p_{\text{air}}} )</td>
</tr>
</tbody>
</table>

9. Click the Convection tab, then select Ideal gas from the Fluid type list.

10. Click the Ideal Gas tab.

11. From the Pressure type list, select Absolute.
Click the Init tab.
Select all three subdomains, and in the Temperature edit field enter T0.
Click OK.

Boundary Conditions—General Heat Transfer
1 Go to the Physics menu and select Boundary Settings.
2 Enter the settings from the following table; when done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 10</th>
<th>BOUNDARY 19</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Temperature</td>
<td>Convective flux</td>
</tr>
<tr>
<td>T0</td>
<td>T0</td>
<td></td>
</tr>
</tbody>
</table>

For all other boundaries, keep the default setting, thermal insulation (symmetry).

Mesh Generation
1 From the Mesh menu select Free Mesh Parameters.
2 Click the Boundary tab and select Boundaries 10, 12, and 16–20.
3 In the Maximum element size edit field type 9e-5.
4 Go the Advanced page, then in the y-direction scale factor edit field type 5.
5 Click Remesh, then click OK.

Computing the Solution
By default, COMSOL Multiphysics solves 3D models with Navier-Stokes as the ruling application mode using the GMRES iterative solver. However, for models (such as this one), with less than 100,000 degrees of freedom, the direct PARDISO solver is more efficient. Therefore, change the default settings according to the following instructions.
1 Click the Solver Parameters button on the Main toolbar.
2 On the General page of the Solver Parameters dialog box find the Linear system solver list and select Direct (PARDISO).
3 Click OK to close the Solver Parameters dialog box.
4 Click the Solve button on the Main toolbar.

Postprocessing and Visualization
The default plot shows a slice plot of the temperature field. To create Figure 2-26, which also shows the heat-flux streamlines, follow these steps:
1 Click the **Plot Parameters** button on the Main toolbar.

2 Go to the **Streamline** page and select the **Streamline plot** check box.

3 In the **Predefined quantities** list select **General Heat Transfer (htgh)>Total heat flux**.

4 In the **Streamline plot type** list select **Magnitude controlled**.

5 On the **Density** page set the **Min distance** to 0.02 and the **Max distance** to 0.12.

6 Click the **Line Color** tab. Select the **Uniform color** option button, then click the **Color** button to launch the **Streamline Color** dialog box. On the **Swatches** page, select a yellow color, then click **OK**.

7 Back on the **Streamline** page, select **Tube** from the **Line type** list, then click the **Tube Radius** button.

8 In the **Tube Radius Parameters** dialog box, clear the **Auto** check box for the **Radius scale factor**, then type 0.3 in the corresponding edit field. Click **OK**.

9 Go to the **Slice**.

10 In the **Predefined quantities** list select **General Heat Transfer (htgh)>Temperature [K]**.

11 Click **Apply**.

The following steps describe how to create Figure 2-27, which shows the velocity field and the velocity streamlines:

1 Return to the **Plot Parameters** dialog box.

2 On the **Streamline** page, in the **Predefined quantities** list select **Weakly Compressible Navier-Stokes (chns)>Velocity field**.

3 Go to the **Slice** page and in the **Predefined quantities** list select **Weakly Compressible Navier-Stokes (chns)>Velocity field**.

4 Click **OK**.

**Modeling Using the Graphical User Interface—Extended Model**

To build the extended model, which accounts for the thermal contact resistance, continue with these steps:

**OPTIONS AND SETTINGS**

1 From the **Options** menu select **Constants**. Add this constant; when done, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>h_j</td>
<td>5400[W/(m^2*K)]</td>
<td>Thermal joint conductivity</td>
</tr>
</tbody>
</table>
GEOMETRY MODELING
1. Click the Draw Mode button on the Main toolbar.
2. Select the geometry and click the Split Object button in the Draw toolbar.
3. Select the geometry objects CO3 and CO4, then click the Union button on the Draw toolbar.
4. Select the geometry objects CO1 and CO2, then click the Create Pairs button on the Draw toolbar.

Boundary Conditions—General Heat Transfer (htgh)
1. Go to the Physics menu and select Boundary Settings.
2. Click the Pairs tab and select Pair 1 (identity).
3. Select Thin thermally resistive layer from the Boundary condition list.
4. Enter the settings from thus table; when done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>k_{res}</td>
<td>h_j * 1.0 [m]</td>
</tr>
<tr>
<td>d_{res}</td>
<td>1.0 [m]</td>
</tr>
</tbody>
</table>

COMPUTING THE SOLUTION
Click the Solve button on the Main toolbar.

POSTPROCESSING AND VISUALIZATION
The default plot shows a slice plot of the temperature field and streamlines for the total heat flux. To create Figure 2-28, remove the streamlines with the following steps:
1. Click the Plot Parameters button on the Main toolbar.
2. On the Streamline page, clear the Streamline plot check box.
3. Click OK.
Heat Transfer in a Surface-Mount Package for a Silicon Chip

Introduction

All integrated circuits—especially high-speed devices—produce heat. In today’s dense electronic system layouts, heat sources are often placed close to heat-sensitive ICs. Designers of printed-circuit boards often need to consider the relative placement of heat-sensitive and heat-producing devices, so that the sensitive ones do not overheat.

One type of heat-generating device is a voltage regulator, which can produce several watts of heat and reach a temperature higher than 70°C. If the board design places such a device close to a surface-mounted package that contains a sensitive silicon chip, the regulator’s heat could cause reliability problems and failure due to overheating.

Figure 2-29: Layout of the simulated silicon device, its package, and a voltage regulator. The chip and the voltage regulator are connected through a ground plane, a pin, and the interconnect.

This simulation investigates the thermal situation for a silicon chip in a surface-mount package placed on a circuit board close to a hot voltage regulator. The chip is subjected to heat from the regulator and from internally generated heat.
Model Definition

The model is based on a SMD IC and voltage regulator layout as in Figure 2-29. The silicon chip sits in the center of the package and dissipates its heat to the surrounding environments. The chip also connects to a ground plane through an interconnect and one of the pins. A heat generating voltage regulator is placed on the same ground plane. This means that the voltage regulator may affect the silicon chip by the conducted heat and this may lead to overheating of the chip.

Heat transfers through the mounted package to the surroundings through conduction according to:

\[ \nabla \cdot (-k\nabla T) = Q. \]

\( Q \) is negligible in the circuit board, pins and package, while in the chip this model sets that parameter to a value equivalent to 20 mW. The conductivities of the components are chosen to be similar to:

- silicon, for the chip
- aluminum, for the pins
- FR4, for the pc board
- copper, for the ground plane and interconnect
- an arbitrary plastic, for the chip package

Heat dissipates from all air-exposed surfaces through forced heat convection, which is modeled using a heat transfer coefficient, \( h \):

\[ -\mathbf{n} \cdot \mathbf{q} = h(T_{\text{inf}} - T) \]

The voltage regulator is simulated by setting a fixed temperature at that surface. The thin conducting layers of the ground plane and interconnect within the package is modeled using a 2D shell approximation, according to:

\[ \nabla \cdot (-d_s k \nabla_i T) = 0 \]

where \( d_s \) is the layer’s thickness, and \( \nabla_i \) represents the nabla operator projected onto the direction of the plane. The model uses a General Heat Transfer application mode to describe the 3D heat transfer as well as the 2D shell heat transfer.
Results and Discussions

Figure 2-30 illustrates the temperature distribution through the thickness. Being a good conductor, the interconnect delivers heat to the outer edge of the package, which gives the fairly constant temperature distribution around the interconnect.

Figure 2-30: Slice plot of the temperature through the circuit board, interconnect, chip, and package. The effect of the interconnect is evident by its ability to conduct heat from the chip to the outer parts of the package.

An alternative view is achieved by using the transparency feature in the postprocessing tools of COMSOL Multiphysics. This results in a transparent 3D view of the temperature distribution, as depicted in Figure 2-31. In that figure you can see the temperature distribution around the chip and along the interconnect.
Figure 2-31: Boundary plot of the temperature created with the assistance of the transparency tool in COMSOL Multiphysics. This view also gives the temperature distribution on the chip and along the interconnect.
To get a closer look at the stationary temperature of the silicon chip, plot the temperature at the bottom boundary of the chip.

Figure 2-32: Temperature distribution on the bottom surface of the silicon chip.

The simulation predicts a maximum temperature of the silicon device of 46.6 °C. This means that the device will not overheat in the present configuration.

**Model Library path:**
Heat_Transfer_Module/Electronics_and_Power_Systems/surf_mount_pack

**Modeling in COMSOL Multiphysics**
This model uses the General Heat Transfer application mode from the Heat Transfer Module, and that application mode allows the definition of highly conductive layers.
They are thin layers that conduct heat well so you need not define them in 3D. The two layers that have this definition are:

- The interconnect between the chip and the grounded pin.
- The ground plane that is also thermally connected to the temperature constraint coming from the voltage regulator.

While the numerical method considers these two modeling domains as interior boundaries, the model still includes a thickness to take the 3D heat flux into account.

**Modeling Using the Graphical User Interface**

**MODEL NAVIGATOR**

1. Start COMSOL Multiphysics and get to the Model Navigator by double-clicking the COMSOL Multiphysics icon on the Windows desktop or, on Unix/Linux systems, enter the command `comsol`.
2. Click the New tab, and in the Space dimension list select 3D.
3. This problem is ideally suited for the Heat Transfer Module. Therefore, go to the list of application modes and select Heat Transfer Module>General Heat Transfer> Steady-state analysis, and click OK.

**CREATING THE GEOMETRY**

The 3D workspace is now ready. You can, of course, create the 3D geometry with the built-in CAD tools of COMSOL Multiphysics, but an interesting alternative is to import a ready-made geometry from a dedicated CAD tool.

1. From the File menu select Import>CAD Data From File. Find the file `surf_mount_pack.mph` or `surf_mount_pack.igs` (if you have the CAD Import Module) and click OK.
2. To get a good view click the Zoom Extents toolbar button. This should give you the left figure below.
3 Inspect the geometry by rotating it with the mouse. You may now get the figure below to the right.

To this base geometry you must add the interconnect between the pin and the chip as well as the ground plane and the temperature surface resulting from the voltage regulator. These details are all 2D surfaces that you can best add on work planes. Thus, start by adding the work plane for the interconnect, which is on the $zx$-plane at $y = 0$.

4 Open the menu item **Draw>Work-Plane Settings**, and on the **Quick** tab choose $z$-$x$ and click **OK**.

5 To see the 3D geometry projected on the 2D plane, click the **Projection of All 3D Geometries** on the Draw toolbar, and then click the **Zoom Extents** on the Main toolbar.

6 To simplify the drawing of the 2D object, and add some extra grid points. Open the menu item **Options>Axes/Grid Settings**, then click the **Grid** tab. Clear the **Auto** check box. In the following edit fields enter the these values: $x$-spacing: 0.002, **Extra x:** $5e\cdot 4$ $4.245e\cdot 3$ $4.645e\cdot 3$, $y$-spacing: 0.002, and **Extra y:** $-2e\cdot 4$ $2e\cdot 4$. Click **OK**.
7 Click the **Line** button on the Draw toolbar.

![Image showing the process of connecting chip and connector]

and click the mouse button on an appropriate series of grid points to generate the interconnect between the chip and the connector as depicted in the following figure. Remember to right-click the last corner to close the polygon to a solid.

At any instant you can double-click the highlighted geometry object to manually change the coordinates of the control points. This feature is useful for correcting drawing errors.
8 To embed the surface in the 3D workspace, select the Draw>Embed menu item and Click OK.

Now, finalize the geometry by adding the ground plane for the voltage regulator.

9 Go to the Draw>Work-Plane Settings menu item, then click the Add button at the bottom of the dialog box.

You do not know for certain the exact position of the circuit board’s top surface, so project this surface to the work plane and then use the fixed positions of this projection’s vertices to draw the two surfaces.

10 In the Work plane dialog box click the Vertices tab. Select three vertices on the corners of the circuit board’s top surface by clicking at one point at a time and adding it to the list using the >> button. Add the points in this order: C02: 3, C02: 4, C02: 8. This gives the work plane the proper orientation for the next step. Click the Apply button to view the work plane axis. Click OK, then click the Zoom Extents button on the Main toolbar.
11 Click the **Rectangle/Square** button on the Draw toolbar to draw the two rectangles shown in the next figure. Use the existing grid points to snap the rectangles while drawing them. Press Ctrl+A to select both of them.

12 Select the menu item **Draw>Embed** and then click **OK**.

**PHYSICS SETTINGS**

*Subdomain Settings*

This section deals with the setting the material’s physical properties.

1 Select the menu item **Physics>Subdomain Settings** and press Ctrl+A to select all subdomains.

2 Click the **Element** tab and select **Lagrange - Linear** from the **Predefined element type** list. Doing so saves computation time and memory.

3 Click the **Conduction** tab and then the **Load** tab to load a predefined material property set. Select **Aluminum** in the list, then click **OK**.

In COMSOL Multiphysics you can enter individual numerical values of material properties such as thermal conductivity directly in the **Subdomain Settings** dialog box. An alternative is to use predefined materials from the materials library. The next step shows how to add some new materials to the materials library.
4 Select the menu item **Options>Materials/Coefficients Library.** Click **New** and in the **Name** field enter PCB (FR4). Also set the thermal conductivity $k$ to 0.3 [W/(m·K)]. Click **OK.** Complete the new material additions as in the following list.

<table>
<thead>
<tr>
<th>MATERIAL NAME</th>
<th>THERMAL CONDUCTIVITY, $k$</th>
</tr>
</thead>
<tbody>
<tr>
<td>PCB (FR4)</td>
<td>0.3</td>
</tr>
<tr>
<td>Plastic</td>
<td>0.2</td>
</tr>
</tbody>
</table>

5 Return to the **Subdomain Settings** dialog box and highlight Subdomain 1 (the circuit board), then go to the **Library material** list and select PCB (FR4). Next select Subdomain 10 (the package) and select Plastic from the materials menu. Finally select Subdomain 11 (the chip) and click the **Load** button to load the Silicon material property set from the built-in list, and click **OK.**

6 Keep the chip highlighted and add an internal heat source ($W/m^3$) by going to the **Q** edit field and entering $2e8$, which corresponds to 20 mW for the whole volume of the device. Click **OK.**

**Boundary Conditions**

1 Select the menu item **Physics>Boundary Settings** and press Ctrl+A to select all boundaries to the exterior (the interior boundaries are grayed out).

2 We want to set a cooling rate by assuming a heat transfer coefficient of 50 W/(m$^2$·K) to the surroundings that has a temperature of 30 °C. This is done by selecting **Boundary condition: Heat flux** and specifying $h$: 50, $T_{inf}$: 30.

3 Select the surface to which the voltage regulator is connected (Boundary 141) and select **Boundary condition: Temperature.** In the $T_0$ edit field enter 50.

4 Select the ground plane (Boundary 140) and go to the **Highly Conductive Layer** tab. Select the check box **Enable heat transfer in highly conductive layer.** Specify the layer thickness $d_s$ as $1e-4$. The other material properties are those of copper, which is what the ground plane is made of.

5 Select the **Interior boundaries** check box and select the interconnect (Boundary 138). Again select the check box **Enable heat transfer in highly conductive layer** and here specify a layer thickness $d_s$ of $5e-6$. Click **OK.**

**Generating the Mesh**

1 Select the menu item **Mesh>Free Mesh Parameters.**

2 Click the **Boundary** tab and select the surfaces for the ground plane and voltage regulator (Boundaries 140 and 141). On each of these boundaries set the **Maximum element size** to $1e-4$. Click **Remesh**, then click **OK.**
COMPUTING THE SOLUTION
Because this model has a limited size you can use a direct solver. Also, for two reasons, you can utilize that the system matrices become symmetric: The model only involves conduction in the subdomain, and the boundary conditions only depend on the temperature variable $T$.

1 Select the menu item Solve>Solver Parameters. Select Direct Cholesky (TAUCS) from the Linear system solver list. Click OK.
2 Click the Solve (=) button on the Main toolbar.

VISUALIZING THE SOLUTION
The default plot shows a slice plot of the temperature throughout a number of cross sections in the device.

1 To generate Figure 2-31, click the Plot Parameters button on the top toolbar. On the General page, clear the Slice plot check box and select the Boundary plot check box. Click OK.
2 To see the interior, click the Increase Transparency button on the lower part of the left toolbar.
3 Figure 2.32 is produced by first clicking Postprocessing>Domain Plot to open the dialog box.
4 Click the Surface tab and select Boundary 134 (bottom plane of the chip) from the list. Select zx-plane from the list of x- and y-axis data, then click OK.
Surface-Mount Resistor

The drive for miniaturizing electronic devices has resulted in today’s extensive use of surface-mount electronic components. An important aspect in electronics design and the choice of materials is a product’s durability and lifetime. For surface-mount resistors and other components producing heat it is a well-known problem that temperature cycling can lead to cracks propagating through the solder joints, resulting in premature failure (Ref. 1). For electronics in general there is a strong interest in changing the soldering material from lead- or tin-based solder alloys to other mixtures.

The following multiphysics example models the heat transport and structural stresses and deformations resulting from the temperature distribution using the General Heat Transfer application mode and the Solid, Stress-Strain application mode.

Model Definition

Figure 2-33 shows a photograph of a surface-mount resistor together with a diagram of it on a printed circuit board (PCB).

Figure 2-33: A photo and diagram of a typical surface-mounted resistor soldered to a PCB.
Table 2-2 shows the dimensions of the resistor and other key components in the model including the PCB.

**TABLE 2-2: COMPONENT DIMENSIONS**

<table>
<thead>
<tr>
<th>COMPONENT</th>
<th>LENGTH</th>
<th>WIDTH</th>
<th>HEIGHT</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resistor (Alumina)</td>
<td>6 mm</td>
<td>3 mm</td>
<td>0.5 mm</td>
</tr>
<tr>
<td>PCB (FR4)</td>
<td>16 mm</td>
<td>8 mm</td>
<td>1.6 mm</td>
</tr>
<tr>
<td>Cu pad</td>
<td>2 mm</td>
<td>3 mm</td>
<td>35 µm</td>
</tr>
<tr>
<td>Ag termination</td>
<td>0.5 mm</td>
<td>3 mm</td>
<td>25 µm</td>
</tr>
<tr>
<td>Stand-off (gap to PCB)</td>
<td>-</td>
<td>-</td>
<td>105 µm</td>
</tr>
</tbody>
</table>

The simulation uses a symmetry cut along the length of the resistor so that it needs to include only half of the component (Figure 2-34).

*Figure 2-34: The simulation models only half the resistor.*

In operation, the resistor dissipates 0.2 W of power as heat. Conduction to the PCB and convection to the surrounding air provide cooling. In this model, the heat transfer occurs through conduction in the subdomains. The model simplifies the surface cooling and describes it using a heat transfer coefficient, \( h \), in this case set to 5 W/\( m^2 \cdot K \); the surrounding air temperature, \( T_{\text{inf}} \), is at 300 K. The resulting heat-transfer
equation and boundary condition (included in the model using the General Heat Transfer application mode) are

\[ \nabla \cdot (-k \nabla T) = Q \]

\[-n \cdot (-k \nabla T) = h(T_{\text{inf}} - T)\]

where \( k \) is the thermal conductivity, and \( Q \) is the heating power per unit volume of the resistor (set to 16.7 MW/m\(^3\) corresponding to 0.2 W in total).

The model handles thermal expansion using a static structural analysis using the Solid, Stress-Strain application mode (a description of the corresponding equations is available in the Structural Mechanics Module User’s Guide). The thermal and mechanical material properties in this model are:

<table>
<thead>
<tr>
<th>MATERIAL</th>
<th>E (GPa)</th>
<th>n</th>
<th>( \alpha ) (ppm)</th>
<th>k (W/(m·K))</th>
<th>( \rho ) (kg/m(^3))</th>
<th>( C_{p} ) (J/(kg·K))</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ag</td>
<td>83</td>
<td>0.37</td>
<td>18.9</td>
<td>420</td>
<td>10500</td>
<td>230</td>
</tr>
<tr>
<td>Alumina</td>
<td>300</td>
<td>0.222</td>
<td>8.0</td>
<td>27</td>
<td>3900</td>
<td>900</td>
</tr>
<tr>
<td>Cu</td>
<td>110</td>
<td>0.35</td>
<td>17</td>
<td>400</td>
<td>8700</td>
<td>385</td>
</tr>
<tr>
<td>Fr4</td>
<td>22</td>
<td>0.28</td>
<td>18</td>
<td>0.3</td>
<td>1900</td>
<td>1369</td>
</tr>
<tr>
<td>60Sn-40Pb</td>
<td>10</td>
<td>0.4</td>
<td>21</td>
<td>50</td>
<td>9000</td>
<td>150</td>
</tr>
</tbody>
</table>

The model treats properties of air as temperature dependent according to the following equations (Ref. 3):

\[ \rho = \left( \frac{p_{0}M_{w}}{RT} \right) \]

with \( p_{0} = 101.3 \) kPa, \( M_{w} = 0.0288 \) kg/mol, and \( R = 8.314 \) J/(mol·K). Further,

\[ C_{p} = 1100 \quad \text{J/(kg·K)} \]

\[ k = 10^{-3.723 + 0.865\log(T)} \quad \text{W/(m·K)} \]

The stresses are zero at 298 K. The boundary condition for the Solid, Stress-Strain application mode is that both ends, in the length direction of the circuit board, are fixed with respect to \( x, y, \) and \( z \).
**Note:** This model requires the Heat Transfer Module and the Structural Mechanics Module.

---

**Results and Discussion**

The isosurfaces in Figure 2-35 show the temperature distribution at steady state. The highest temperature is approximately 420 K, appearing in the center of the resistor. The circuit board also heats up significantly.

![Temperature distribution in the resistor and the circuit board at steady state.](image)

*Figure 2-35: Temperature distribution in the resistor and the circuit board at steady state.*
Thermal stresses appear as a result of the temperature increase; they arise from the materials' different expansion coefficients. Figure 2-36 plots the effective stress (von Mises) together with the resulting deformation of the assembly.

Figure 2-36: The thermally induced distribution of von Mises effective stress together with the deformation (magnified) and the isotherms.

The highest stresses seem to occur in the termination material. It is interesting to compare these effective stresses to the yield stress and thereby investigate whether or
not the material is irreversibly deformed. In that case the solder is the weak point. The following graph plots the stress in the solder points alone.

![Figure 2-37: Close-up of the von Mises effective stresses in the solder joint.](image)

The yield stress for solder is approximately 220 MPa. The highest effective stress seems to fall in the range near 220 MPa. This means that the assembly functions without failure for the tested power loads. However, if the heating power increases slightly, permanent deformation and possibly failure occur.

**References**


2. Courtesy of Dr. H. Lu, Centre for Numerical Modelling and Process Analysis, University of Greenwich, U.K.

Model Library path: Heat_Transfer_Module/ Electronics_and_Power_Systems/surface_resistor

**Modeling Using the Graphical User Interface**

**MODEL NAVIGATOR**
Open the **Model Navigator**. Click the **New** tab. In the **Space dimension** list select **2D**, then click **OK**.

**OPTIONS AND SETTINGS**
From the **Options** menu choose **Constants**, then define the following names and expressions. When finished, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>T_air</td>
<td>293</td>
</tr>
<tr>
<td>h_air</td>
<td>5</td>
</tr>
<tr>
<td>q_source</td>
<td>0.2/(0.5e-3<em>3e-3</em>8e-3)</td>
</tr>
<tr>
<td>p</td>
<td>1.013e5</td>
</tr>
</tbody>
</table>

**GEOMETRY MODELING**
1. From the **Draw** menu select **Work Plane Settings**.
2. On the **Quick** page go to the **Plane** area. Click the option button for the **y-z** plane.
3. Click **OK**.
4. Create four rectangles. Shift-click the **Rectangle/Square** button on the Draw toolbar for each one and enter the data from this table:

<table>
<thead>
<tr>
<th>RECTANGLE</th>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>X</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>0.002</td>
<td>35e-6</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>R2</td>
<td>5.25e-4</td>
<td>4.5e-5</td>
<td>9.75e-4</td>
<td>3.5e-5</td>
</tr>
<tr>
<td>R3</td>
<td>5.25e-4</td>
<td>5.5e-4</td>
<td>9.75e-4</td>
<td>8e-5</td>
</tr>
<tr>
<td>R4</td>
<td>6e-3</td>
<td>5e-4</td>
<td>1e-3</td>
<td>1.05e-4</td>
</tr>
</tbody>
</table>

5. Click the **Zoom Extents** button on the Main menu.
6. Copy rectangle R4 by selecting it and then pressing Ctrl+C.
7 Click the **Create Composite Object** button on the Draw toolbar. (Alternatively, select **Create Composite Object** from the **Draw** menu.)

8 In the **Set formula** edit field type \( R_3 - R_4 \), then click **OK**.

9 Paste a copy of R4 with zero displacement. To do so, press Ctrl+V, then click **OK** in the **Paste** dialog box.

10 Click the **2nd Degree Bezier Curve** button on the Draw toolbar.

11 Draw a curve between the upper corner of the termination and the left corner of the copper plate as in the figure below. You may want to zoom in the area before you start drawing the curve. Draw the line by clicking the coordinates \((9.75 \times 10^{-4}, 6.3 \times 10^{-4})\), \((8 \times 10^{-4}, 2 \times 10^{-4})\), and \((0, 3.5 \times 10^{-5})\). The coordinates that the mouse is pointing to appears in the lower left corner of the user interface.

12 After clicking the third coordinate pair click the **Line** button on the Draw toolbar. This allows you to continue the drawing with lines along the copper plate boundary and the termination boundary. Click on the coordinates \((9.75 \times 10^{-4}, 3.5 \times 10^{-5})\) and \((9.75 \times 10^{-4}, 6.3 \times 10^{-4})\). Then complete the drawing by right-clicking using the mouse. The drawing should now look like in this figure:

13 Copy the objects R1, R2, CO1, and CO2 by selecting them and pressing Ctrl+C.
14 Paste the objects by pressing Ctrl+V. Go to the displacement area, and in the x edit field type 0.006. Click OK.

15 From the Draw menu select Modify>Scale. Find the Scale factor area, then in the x edit field type -1. Go to the Scale base point area and in the x edit field type 0.007. Click OK.

16 Click the Zoom Extents button on the Main toolbar.

17 Click the Line button on the Draw toolbar and draw a line between the coordinates (0.002, 0) and (0.006, 0).

18 To finalize the geometry select all the objects by pressing Ctrl+A and click the Coerce to Solid button on the Draw toolbar.

19 Shift-click the Rectangle/Square button. Specify settings according to the following table. When done, click OK.

<table>
<thead>
<tr>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>BASE</th>
<th>X</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>16e-3</td>
<td>1.6e-3</td>
<td>Center</td>
<td>4e-3</td>
<td>-8.0e-4</td>
</tr>
</tbody>
</table>

20 Open the Extrude dialog box from the Draw menu.

21 From the Objects to extrude list select COS. In the Distance edit field type 1.5e-3, then click OK.

22 Return to the 2D geometry by clicking the Geom1 tag.

23 Open the Extrude dialog box from the Draw menu.

24 Select R1 from the Objects to extrude list and type 4e-3 in the Distance edit field. Click OK.

MESH GENERATION

1 From the Draw menu, select Create Pairs. Select both EXT1 and EXT2. Clear the Create imprints check box so that the meshes of the two extruded objects do not have to match at their shared boundary. This makes the mesh generation easier and reduces the number of elements.

2 Click OK.

3 Open the Mapped Mesh Parameters dialog box from the Mesh menu, then click the Edge tab.

4 Select 1 from the Edge selection list. Select the Constrained edge element distribution check box and enter 5 in the Number of edge elements edit field.

5 Repeat Step 4 for Edge 2, but leave the number of edge elements at its default value 10.
6 Click the **Boundary** tab and select 1 from the **Boundary selection** list.

7 Click **Mesh Selected**, then click **OK**.

8 Open the **Swept Mesh Parameters** dialog box from the **Mesh** menu.

9 Select Subdomain 1, then press Ctrl+A to select all subdomains.

10 Select the **Manual specification of element layers** check box and type 10 in the **Number of element layers** check box. Click **OK**.

11 Click the **Subdomain mode** button on the Main toolbar.

12 Select only the PCB domain, that is, the largest subdomain.

13 Click **Mesh>Interactive Meshing>Mesh Selected (Swept)**.

14 Click **Mesh>Interactive Meshing>Mesh Remaining (Swept)**.

The meshed geometry in the drawing area should now look like that in the following figure:

---

**PHYSICS SETTINGS**

1 From the **Multiphysics** menu open the **Model Navigator**.

2 In the **Multiphysics** area on the right side of the dialog box select **Geom2**. In the list of application modes on the left select **Structural Mechanics Module>Thermal-Structural Interaction>Solid, Stress-Strain with Thermal Expansion**.

3 Click **OK**.
Subdomain Settings

1. From the Multiphysics menu, select Geom2: Solid, Stress-Strain.
2. From the Physics menu select Subdomain Settings.
3. Click the Load tab (not the Load button), then select all subdomains. In the Tempref edit field type $T_{\text{air}}$.
4. Click the Material tab.
5. Select Subdomain 1. Click the Load button to open the Materials/Coefficients Library dialog box. Select Basic Material Properties>FR4 (Circuit board). Click OK.
6. Repeat the previous step for the other subdomains with materials according to the following table:

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>SUBDOMAINS 2, 8</th>
<th>SUBDOMAINS 3, 4, 9, 11</th>
<th>SUBDOMAINS 5, 10</th>
<th>SUBDOMAIN 6</th>
</tr>
</thead>
<tbody>
<tr>
<td>Material</td>
<td>Copper</td>
<td>Solder, 60Sn-40Pb</td>
<td>Ag</td>
<td>Alumina</td>
</tr>
</tbody>
</table>

7. Select Subdomain 7, then clear the Active in this domain check box.
8. Click OK to close the dialog box.
9. Change the active application mode. From the Multiphysics menu select Geom2: General Heat Transfer.
10. From the Physics menu select Subdomain Settings. Go to the Conduction page, select Subdomain 1, and then select FR4 (Circuit board) from the Library material list.
11. Repeat for the other subdomains according to:

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>SUBDOMAINS 2, 8</th>
<th>SUBDOMAINS 3, 4, 9, 11</th>
<th>SUBDOMAINS 5, 10</th>
<th>SUBDOMAIN 6</th>
<th>SUBDOMAIN 7</th>
</tr>
</thead>
<tbody>
<tr>
<td>Material</td>
<td>Copper</td>
<td>Solder, 60Sn-40Pb</td>
<td>Ag</td>
<td>Alumina</td>
<td>Air, 1atm</td>
</tr>
<tr>
<td>$Q$</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>$q_{\text{source}}$</td>
<td>0</td>
</tr>
</tbody>
</table>

12. Go to the Init page. Select all subdomains and in the Temperature edit field, type $T_{\text{air}}$. Click OK.

Boundary Conditions

1. From the Physics menu open the Boundary Settings dialog box.
2. Select the exterior boundaries in contact with air, that is, Boundaries 3, 4, 8, 12, 19, 29, 30, 44, 46, and 52–63. In the Boundary condition list select Heat flux.
3. In the Heat transfer coefficient edit field type $h_{\text{air}}$, and in the External temperature edit field type $T_{\text{air}}$. Click OK.
4 In the **Multiphysics** menu change the active application mode to **Geom2: Solid, Stress-Strain**.

5 From the **Physics** menu open the **Boundary Settings** dialog box.

6 Select Boundaries 1, 7, 10, 13, 16, 20, 33, 37, 40, and 48. Select **Symmetry plane** from the **Constraint condition** list.

7 Select Boundaries 2 and 5. Select **Fixed** from the **Constraint condition** list. Click **OK**.

**COMPUTING THE SOLUTION**

The solution procedure runs in two steps: first solving for the temperature field, then solving for the stresses. Do so by using solver scripting to record the solver commands and then run them.

1 From the **Solve** menu open the **Solver Manager** dialog box.

2 On the **Solve For** page select **Geom2>General Heat Transfer (htgh)**. Click **Apply**.

3 In the **Script** page select the **Solve using a script** check box, then click the **Add Current Solver Settings** button.

4 On the **Solve For** page select **Geom2>Solid, Stress-Strain (smsld)**.

5 In the **Initial Value** page go to the **Values of variable not solved for and linearization point area** and select the **Current solution** button. Click **OK**.

6 From the **Solve** menu open the **Solver Parameters** dialog box.

7 In the **Linear system solver** list select **Direct (SPOOLES)** to take advantage of the symmetric system matrices. Click **OK**.

8 From the **Solve** menu select the **Solver Manager**. Click the **Script** tab, then click the **Add Current Solver Settings** button. Click **OK**.

9 Click the **Solve** button on the Main toolbar. The second part of the solution script is rather memory intensive when using a direct solver. The calculations require approximately 500 MB of free memory.

**POSTPROCESSING AND VISUALIZATION**

To reproduce the temperature plot in Figure 2-35:

1 From the **Postprocessing** menu open the **Plot Parameters** dialog box.

2 Click the **General** tab.

3 In the **Plot type** area clear the **Slice** check box and select the **Isosurface** check box.

4 Click the **Isosurface** tab.

5 From the **Predefined quantities** list select **General Heat Transfer (htgh)>>Temperature**.
6. In the Isosurface levels area click the Levels button, then type 30 in the Number of levels edit field. Click the Color Data tab and select the Color data check box. From the Predefined quantities list select General Heat Transfer (htgh)>Temperature.

7. Click Apply.

8. Click the Scenelight button on the Camera toolbar to finish off the plot.

To reproduce Figure 2-36:

1. While still on the Isosurface page in the Plot Parameters dialog box, change the Number of levels to 15.

2. In the Fill style list select Wireframe.

3. Click the Subdomain tab and enable this plot type by selecting the Subdomain plot check box at the top of the dialog box. From the Predefined quantities list select Solid, Stress-Strain (smld)>von Mises stress.

4. Click the Deform tab and select the Deformed shape plot check box.

5. In Domain types to deform area clear the Boundary and Edge check boxes.

6. In the Deformation data area click the Subdomain Data tab, then select Solid, Stress-Strain (smld)>Displacement from the Predefined quantities list.

7. Click OK.

To reproduce Figure 2-37:

1. From the Options menu select Suppress>Suppress Subdomains.

2. Select Subdomains 1, 2, 5, 6, 7, 8, and 10, then click OK.

3. From the Postprocessing menu open the Plot Parameters dialog box.

4. In the General page, go to the Plot type area, clear the Isosurface and Deform check boxes. Click OK to generate the plot in Figure 2-37.
**Heating Circuit**

*Introduction*

Small heating circuits find use in many applications. For example, in manufacturing processes they heat up reactive fluids. Figure 2-38 illustrates a typical heating device for this application. The device consists of an electrically resistive layer deposited on a glass plate. The layer causes Joule heating when a voltage is applied to the circuit. The layer’s properties determine the amount of heat produced.

![Figure 2-38: Geometry of a heating device.](image)

In this particular application, you must observe three important design considerations:

- Non-invasive heating
- Minimal deflection of the heating device
- Avoidance of overheating the process fluid

The heater must also work without failure. You achieve the first and second requirements by inserting a glass plate between the heating circuit and the fluid; it acts as a conducting separator. Glass is an ideal material for both these purposes because it is nonreactive and has a low thermal-expansion coefficient.

You must also avoid overheating due to the risk of self-ignition of the reactive fluid stream. Ignition is also the main reason for separating the electrical circuit from direct contact with the fluid. The heating device is tailored for each application, making virtual prototyping very important for manufacturers.

For heating circuits in general, detachment of the resistive layer often determines the failure rate. This is caused by excessive thermally induced interfacial stresses. Once the layer has detached, it gets locally overheated, which accelerates the detachment. Finally, in the worst case, the circuit might overheat and burn. From this perspective,
it is also important to study the interfacial tension due to the different thermal-expansion coefficients of the resistive layer and the substrate as well as the differences in temperature. The geometric shape of the layer is a key parameter to design circuits that function properly. You can investigate all of the above-mentioned aspects by modeling the circuit.

This multiphysics example simulates the electrical heat generation, the heat transfer, and the mechanical stresses and deformations of a heating circuit device. The model uses the General Heat Transfer application mode of the Heat Transfer module in combination with the Shell, Conductive Media DC application mode from the AC/DC Module and the Solid, Stress-Strain and Shell application modes from the Structural Mechanics Module.

**Note:** This model requires the AC/DC Module, the Heat Transfer Module, and the Structural Mechanics Module.

---

**Model Definition**

Figure 2-39 shows a drawing of the modeled heating circuit.

*Figure 2-39: Drawing of the heating circuit deposited on a glass plate.*

The device consists of a serpentine-shaped Nichrome resistive layer, 10 µm thick and 5 mm wide, deposited on a glass plate. At each end, it has a silver contact pad measuring 10 mm × 10 mm × 10 µm. When the circuit is in use, the deposited side of the glass plate is in contact with surrounding air, and the back side is in contact with the heated fluid. Assume that the edges of the glass plate are thermally insulated.
Table 2-4 gives the resistor’s dimensions.

<table>
<thead>
<tr>
<th>OBJECT</th>
<th>DIMENSION</th>
<th>SIZE</th>
</tr>
</thead>
<tbody>
<tr>
<td>glass plate</td>
<td>length</td>
<td>130 mm</td>
</tr>
<tr>
<td></td>
<td>width</td>
<td>80 mm</td>
</tr>
<tr>
<td>pads and circuit</td>
<td>thickness</td>
<td>10 µm</td>
</tr>
</tbody>
</table>

During operation the resistive layer produces heat. Model the electrically generated heat using the Shell, Conductive Media DC application mode from the AC/DC Module. The governing equation is

\[ \nabla_t \cdot (-d \sigma \nabla_t V) = 0 \]

where \( d \) is the thin layer’s thickness (m), \( \sigma \) is the electric conductivity (S/m), \( V \) is the electric potential (V), and \( \nabla_t \) denotes the gradient operator in the tangential directions. An actual applies 12 V to the pads. In the model you achieve this effect by setting the potential at one edge of the first pad to 12 V and that of one edge of the other pad to 0 V.

To model the heat transfer in the thin conducting layer, use the Highly Conductive Layer feature of the General Heat Transfer application mode. It is then not necessary to add a separate application mode for it.

The heat power per unit area (measured in W/m\(^2\)) produced inside the thin layer is given by

\[ q_{\text{prod}} = d Q_{\text{DC}} \]  \hspace{1cm} (2-9)

where \( Q_{\text{DC}} = \mathbf{J} \cdot \mathbf{E} = \sigma |\nabla_t V|^2 \) (W/m\(^3\)) is the power density. The generated heat appears as an inward heat flux at the surface of the glass plate.

At steady state, the resistive layer dissipates the heat it generates in two ways: on its up side to the surrounding air (at 293 K), and on its down side to the glass plate. The glass plate is similarly cooled in two ways: on its circuit side by air, and on its back side by a process fluid (353 K). You model the heat fluxes to the surroundings using heat transfer film coefficients, \( h \). For the heat transfer to air, \( h = 5 \) W/(m\(^2\)-K), representing natural convection. On the glass plate’s back side, \( h = 20 \) W/(m\(^2\)-K), representing convective heat transfer to the fluid. The sides of the glass plate are insulated.
The resulting heat transfer equation for the device, together with the boundary condition used to describe the heat fluxes at the front and back sides, is

\[ \nabla \cdot (-k \nabla T) = 0 \]

\[ -\mathbf{n} \cdot (-k \nabla T) = q_0 + h(T_{\text{inf}} - T) - \nabla \epsilon \cdot (-d_a k_s \nabla T) \]

where \( \mathbf{n} \) is the normal vector of the boundary, \( k \) is the thermal conductivity (W/(m·K)), \( h \) is the heat transfer film coefficient (W/(m²·K)), and \( T_{\text{inf}} \) is the temperature (K) of the surrounding medium. The last term on the right-hand side represents the additional flux given by the thin conducting layer, and the constant \( k_s \) is the thermal conductivity in the layer (W/(m·K)). This term is only present on the boundaries where the layer is present. Similarly, the inward heat flux, \( q_0 \), is equal to \( q_{\text{prod}} \) (see Equation 2-9) at the layer but vanishes elsewhere.

The model simulates thermal expansion using static structural-mechanics analyses. It uses the Solid, Stress-Strain application mode for the glass plate, and the Shell application mode for the circuit layer. The equations of these two application modes are described in the *Structural Mechanics Module User’s Guide*. The stresses are set to zero at 293 K. You determine the boundary conditions for the Solid, Stress-Strain application mode by fixing one corner with respect to \( x \)-, \( y \)-, and \( z \)-displacements and rotation.

Table 2-5 summarizes the material properties used in the model.

<table>
<thead>
<tr>
<th>MATERIAL</th>
<th>( E ) [GPa]</th>
<th>( \nu )</th>
<th>( \alpha ) [ppm]</th>
<th>( h ) [W/(m·K)]</th>
<th>( \rho ) [kg/m³]</th>
<th>( C_p ) [J/(kg·K)]</th>
</tr>
</thead>
<tbody>
<tr>
<td>Silver</td>
<td>83</td>
<td>0.37</td>
<td>18.9</td>
<td>420</td>
<td>10,500</td>
<td>230</td>
</tr>
<tr>
<td>Nichrome</td>
<td>213</td>
<td>0.33</td>
<td>10.0</td>
<td>15</td>
<td>9,000</td>
<td>20</td>
</tr>
<tr>
<td>Glass</td>
<td>73.1</td>
<td>0.17</td>
<td>55</td>
<td>1.38</td>
<td>2,203</td>
<td>703</td>
</tr>
</tbody>
</table>

Heating Circuit | 105
Results and Discussion

Figure 2-40 shows the heat that the resistive layer generates.

![Diagram showing heat generation in the resistive layer]

Figure 2-40: Stationary heat generation in the resistive layer when 12 V is applied.

The highest heating power arises in the inner corners of the curves due to the higher current density at these spots. The total generated heat, as calculated by integration, is approximately 13.8 W.
Figure 2-41 shows the temperature of the resistive layer and the glass plate at steady state.

Figure 2-41: Temperature distribution in the heating device at steady state.

The highest temperature is approximately 430 K, and it appears in the central section of the circuit layer. It is interesting to see that the differences in temperature between the fluid side and the circuit side of the glass plate are quite small because the plate is very thin. Using boundary integration, the integral heat flux on the fluid side evaluates to approximately 8.5 W. This means that the device transfers the majority of the heat it generates—8.5 W out of 13.8 W—to the fluid, which is good from a design perspective, although the thermal resistance of the glass plate results in some losses.

The temperature rise also induces thermal stresses due to the materials’ different coefficients of thermal expansion. As a result, mechanical stresses and deformations arise in the layer and in the glass plate. Figure 2-42 shows the effective stress...
distribution in the device and the resulting deformations. During operation, the glass plate bends towards the air side.

Figure 2-42: The thermally induced von Mises effective stress plotted with the deformation.

The highest effective stress, approximately 7 MPa, appears in the corners of the silver pads. The yield stress for high quality glass is roughly 250 MPa, and for Nichrome it is 360 MPa. This means that the individual objects remain structurally intact for the simulated heating power loads.

You must also consider stresses in the interface between the resistive layer and the glass plate. Assume that the yield stress of the surface adhesion in the interface is in the region of 50 MPa—a value significantly lower than the yield stresses of the other materials in the device. If the effective stress increases above this value, the resistive layer will locally detach from the glass. Once it has detached, heat transfer is locally impeded, which can lead to overheating of the resistive layer and eventually cause the device to fail.

Figure 2-43 displays the effective forces acting on the adhesive layer during heater operation. As the figure shows, the device experiences a maximum interfacial stress that is an order of magnitude smaller than the yield stress. This means that the device will be OK in terms of adhesive stress.
Finally study the device's deflections, depicted in Figure 2-44.

Figure 2-43: The effective forces in the interface between the resistive layer and the glass plate.

Figure 2-44: Total displacement on the fluid side of the glass plate.
The maximum displacement, located at the center of the plate, is approximately 30 \( \mu \text{m} \). For high-precision applications, such as semiconductor processing, this might be a significant value that limits the device’s operating temperature.

**Model Library path:** Heat_Transfer_Module/
Electronics_and_Power_Systems/heating_circuit

---

**Modeling Using the Graphical User Interface**

**MODEL NAVIGATOR**

1. Open the Model Navigator.
2. In the **Space dimension** list select **3D**. Click the **Multiphysics** button.
3. From the list of application modes select **AC/DC Module>Statics>Shell, Conductive Media DC**. In the **Application mode name** edit field type **DC**, then click **Add**.
4. From the list of application modes select **Heat Transfer Module>General Heat Transfer**, then click **Add**.
5. Similarly add two more application modes: **Structural Mechanics Module>Solid, Stress-Strain** and **Structural Mechanics Module>Shell**. When done, click **OK**.

**OPTIONS AND SETTINGS**

From the **Options** menu select **Constants**. Define the following names, expressions, and descriptions (the descriptions are optional); when done, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>V_in</td>
<td>12[V]</td>
<td>Input voltage</td>
</tr>
<tr>
<td>d_layer</td>
<td>10[\mu m]</td>
<td>Layer thickness</td>
</tr>
<tr>
<td>sigma_Silver</td>
<td>6.3e7[S/m]</td>
<td>Electric conductivity of silver</td>
</tr>
<tr>
<td>sigma_Nichrome</td>
<td>9.3e5[S/m]</td>
<td>Electric conductivity of Nichrome</td>
</tr>
<tr>
<td>T_ref</td>
<td>293[K]</td>
<td>Reference temperature</td>
</tr>
<tr>
<td>T_air</td>
<td>T_ref</td>
<td>Air temperature</td>
</tr>
<tr>
<td>h_air</td>
<td>5[W/(m²*K)]</td>
<td>Heat transfer film coefficient, air</td>
</tr>
<tr>
<td>T_fluid</td>
<td>353[K]</td>
<td>Fluid temperature</td>
</tr>
<tr>
<td>h_fluid</td>
<td>20[W/(m²*K)]</td>
<td>Heat transfer film coefficient, fluid</td>
</tr>
</tbody>
</table>
**Geometry Modeling**

1. Create a 2D work plane at $z = 0$ by first choosing Draw>Work-Plane Settings and then clicking OK in the dialog box that appears to accept the default settings.

2. Create nine rectangles. Open the Draw>Specify Objects>Rectangle dialog box, and for each one enter the appropriate data from this table:

<table>
<thead>
<tr>
<th>RECTANGLE</th>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>X-BASE</th>
<th>Y-BASE</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>0.08</td>
<td>0.13</td>
<td>-0.02</td>
<td>-0.035</td>
</tr>
<tr>
<td>R2</td>
<td>0.01</td>
<td>0.02</td>
<td>-0.01</td>
<td>-0.01</td>
</tr>
<tr>
<td>R3</td>
<td>0.005</td>
<td>0.075</td>
<td>0.015</td>
<td>0</td>
</tr>
<tr>
<td>R4</td>
<td>0.01</td>
<td>0.005</td>
<td>0</td>
<td>0.08</td>
</tr>
<tr>
<td>R5</td>
<td>0.01</td>
<td>0.01</td>
<td>0</td>
<td>0.075</td>
</tr>
<tr>
<td>R6</td>
<td>0.005</td>
<td>0.015</td>
<td>0.045</td>
<td>0.06</td>
</tr>
<tr>
<td>R7</td>
<td>0.02</td>
<td>0.005</td>
<td>0.02</td>
<td>-0.025</td>
</tr>
<tr>
<td>R8</td>
<td>0.01</td>
<td>0.01</td>
<td>0.01</td>
<td>-0.027</td>
</tr>
<tr>
<td>R9</td>
<td>0.01</td>
<td>0.01</td>
<td>-0.013</td>
<td>-0.025</td>
</tr>
</tbody>
</table>

3. Click the Zoom Extents button on the Main toolbar.

4. Create a circle with the menu item Draw>Specify Objects>Circle. In the Radius edit field type 0.01, then click OK.

5. Create another circle the same way but with a Radius of 0.005.

6. Click the Create Composite Object button on the Draw toolbar. In the Set formula edit field type C1-C2-R2, then click OK. This step generates the composite object CO1.

7. Select CO1 by clicking on it, click the Mirror button on the Draw toolbar, then click OK. This step creates a mirror copy of CO1 called CO2.

8. Select CO2 and then click the Move button on the Draw toolbar. Go to the Displacement area, and in the y edit field type 0.015. Click OK.

9. Select both CO1 and CO2 by pressing Ctrl while clicking on the objects. Copy both by pressing Ctrl+C.

10. Paste twice by pressing Ctrl+V, specifying the displacement, and clicking OK. For the first copy specify the $y$-displacement as 0.030, and for the second specify 0.060.

11. Select CO1, copy it, and paste it with zero displacement.

12. Click the Rotate button on the Draw toolbar. In the Rotation angle edit field type -90, then click OK.
Click the **Move** button on the Draw toolbar. In the *x* edit field type 0.025, then click **OK**.

Click the **Mirror** button on the Draw toolbar. In the **Normal vector** edit field for *x* type 0, and in the *y* edit field type 1. Click **OK**.

Click the **Move** button on the Draw toolbar. In the *x* edit field type -0.015, and in the *y* edit field type 0.075. Click **OK**.

Click the **Create Composite Object** button on the Draw toolbar. In the **Set formula** edit field type CO8-R5, then click **OK**. This step generates composite object CO9.

Copy and paste CO9 with *x*- and *y*-displacements of -0.02 and -0.08, respectively.

Click the **Rotate** button on the Draw toolbar. In the *α* edit field in the Rotation angle area type 90, and in the *y* edit field in the Center point area type -0.005. Click **OK**.

Select objects CO7 and R3. Click the **Mirror** button on the Draw toolbar. In the **Normal vector** edit field for *x* type 0, and in the *y* edit field type 1. Click **OK**.

Click the **Move** button on the Draw toolbar. Specify the displacement by typing 0.015 in the *x* edit field and 0.075 in the *y* edit field, then click **OK**. These steps generate composite objects CO10 and CO11.

Select objects CO9 and R3. Using the **Move** dialog box, repeat the procedure in the previous two steps with values for the *x*- and *y*-displacements of 0.03 and 0.06. The geometry should now look like that in the following figure.

Select all objects except the glass plate (R1) and the silver tabs (R8 and R9). Click the **Create Composite Object** button on the Draw toolbar. Clear the **Keep interior boundaries** check box, then click **OK**. This step generates composite object CO14.

Select CO14, R8, and R9, then click the **Coerce to Solid** button on the Draw toolbar.
**Mesh Generation**

1. From the Mesh menu open the **Free Mesh Parameters** dialog box.
2. On the Global page go to the **Predefined mesh sizes** list and select **Coarse**.
3. On the Subdomain page select Subdomain 3, then in the Maximum element size edit field type $2 \times 10^{-3}$.
4. Click the Remesh button, then click OK.
5. From the Mesh menu open the **Extrude Mesh** dialog box. On the Geometry page find the Distance edit field and type $2 \times 10^{-3}$. From the Extrude to geometry list select Geom1.
6. Click the Mesh tab. In the Number of element layers edit field type 2, then click OK.
7. Double-click the **EQUAL** button on the status bar at the bottom of the user interface, then click the **Zoom Extents** button on the Main toolbar to expand the geometry’s z-axis.

**Physics Settings**

1. From the Options menu open the **Materials/Coefficients Library** dialog box.
2. Set up the materials silver and NiChrome. To do so, click New, then enter the settings from the following table in the corresponding edit fields. When done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>C</th>
<th>E</th>
<th>alpha</th>
<th>k</th>
<th>nu</th>
<th>rho</th>
</tr>
</thead>
<tbody>
<tr>
<td>Silver</td>
<td>230</td>
<td>83e9</td>
<td>18.9e-6</td>
<td>420</td>
<td>0.37</td>
<td>10500</td>
</tr>
<tr>
<td>Nichrome</td>
<td>230</td>
<td>213e9</td>
<td>10.0e-6</td>
<td>15</td>
<td>0.33</td>
<td>9000</td>
</tr>
</tbody>
</table>

3. Choose Options>Expressions>Scalar Expressions. In the Name edit field type q_prod, and in the Expression edit field type $d_{layer} \cdot Q_{DC}$. Enter Heat power per unit area inside thin layer in the Description edit field (optional). Click OK.

**Boundary Settings—Shell, Conductive Media DC (DC)**

1. From the Multiphysics menu select Shell, Conductive Media DC (DC).
2. From the Physics menu select Boundary Settings.
3. Select all the boundaries, then clear the **Active in this domain** check box.
4. Select Boundary 14, then click the **Active in this domain** check box. In the Electric conductivity edit field for $\sigma$ (isotropic) type sigma_Nichrome, and in the Layer thickness edit field type d_layer.
5. Repeat the previous step for Boundaries 9 and 47 but in the Electric conductivity edit field type sigma_Silver. Click OK.
6. From the Physics menu select Edge Settings.
7 Select Edge 13. In the **Boundary condition** list select **Electric potential**, then in the **Electric potential** edit field type $V_{in}$.

8 Select Edge 109. In the **Boundary condition** list select **Ground**, then click **OK**.

**Subdomain Settings—General Heat Transfer**
1 From the **Multiphysics** menu select **General Heat Transfer (htgh)**.
2 From the **Physics** menu open the **Subdomain Settings** dialog box, then select all the subdomains.
3 Go to the **Conduction** page. Click the **Load** button. From the **Materials** list select **Library1>Silica Glass**, then click **OK**.
4 Go to the **Init** page, and in the $T(t_0)$ edit field type $T_{ref}$. Click **OK**.

**Boundary Conditions—General Heat Transfer**
1 From the **Physics** menu open the **Boundary Settings** dialog box. Select Boundaries 9, 14, and 47.
2 Click the **Highly Conductive Layer** tab. Select the **Enable heat transfer in highly conductive layer** check box, then in the $d_s$ edit field type $d_{layer}$.
3 Select Boundary 14. In the **Library material** list select **Nichrome**.
4 Similarly, for Boundaries 9 and 47 select **Silver**.
5 Click the **Boundary Condition** tab. Select Boundaries 9, 14, and 47. In the **Boundary condition** list select **Heat flux**. In the $q_0$ edit field type $q_{prod}$, in the $h$ edit field type $h_{air}$, and in the $T_{inf}$ edit field type $T_{air}$.
6 Repeat the settings in the previous step for Boundary 4 but without specifying $q_0$.
7 Select Boundaries 3, 8, 13, and 46. In the **Boundary condition** list select **Heat flux**. In the $h$ edit field type $h_{fluid}$, and in the $T_{inf}$ edit field type $T_{fluid}$. Click **OK**.

**Subdomain Settings—Solid, Stress-Strain**
1 From the **Multiphysics** menu select **Solid, Stress-Strain (smsld)**.
2 From the **Physics** menu open the **Subdomain Settings** dialog box, then select all the subdomains.
3 Go to the **Material** page. In **Library material** list select **Silica Glass**.
4 Click the **Load** tab. Select the **Include thermal expansion** check box. In the **Temp** edit field type $T$ and in the **Tempref** edit field type $T_{ref}$.
5 Go to the **Element** page. In the **Predefined elements** list select **Lagrange - Linear**. Click **OK**.
**Point Settings—Solid, Stress-Strain**

1. From the Physics menu open the Point Settings dialog box.
2. Select Point 1. Select the check boxes next to $R_x$, $R_y$, and $R_z$.
3. Select Point 3, then select the $R_z$ check box.
4. Select Point 125, then select the $R_y$ and $R_z$ check boxes. Click OK.

**Boundary Settings—Shell**

1. From the Multiphysics menu select Shell (smsh).
2. From the Physics menu open the Boundary Settings dialog box.
3. Select all the boundaries, then clear the Active in this domain check box.
4. Select Boundaries 9, 14, and 47. Select the Active in this domain check box.
5. In the thickness edit field type $d_{layer}$.
6. Go to the Load page. Select the Include thermal expansion check box. In the Temp edit field type $T$ and in the Tempref edit field type $T_{ref}$.
7. Click the Material tab. Select Boundaries 9 and 47. In the Library material list select Silver.
8. Similarly, for Boundary 14 select Nichrome. Click OK.

**Computing The Solution**

This model is best solved using a script. Follow these steps to create the script and solve the model.

1. From the Solve menu open the Solver Manager.
2. On the Solve For page select Geom1 (3D)>Shell, Conductive Media DC (DC) and Geom1 (3D)>General Heat Transfer (htgh), then click Apply.
3. Go to the Script page. Select the Solve using a script check box. Then click the Add Current Solver Settings button to generate the first half of the script.
4. From the Solve menu, choose Solver Parameters.
5. In the Linear system solver list select Direct (SPOOLES) to use this solver’s ability to utilize the symmetric system matrices. Click OK.
6. Return to the Solver Manager. Go to the Initial Value page, then to the Initial value area, and click the Current solution option button.
7. Go to the Solve For page. Select Geom1>Solid, Stress-Strain (smssl) and Geom1>Shell (smsh). Click Apply.
8 On the Script page click the Add Current Solver Settings button to generate the second half of the script. Click OK to close the Solver Manager.

9 Finally, click the Solve button on the Main toolbar to compute the solution.

POSTPROCESSING AND VISUALIZATION

Generate Figure 2-40 as follows:

1 From the Postprocessing menu open the Plot Parameters dialog box.
2 On the General page clear the Slice check box, then select the Boundary check box.
3 Go to the Boundary page. In the Expression edit field type q_prod. Click OK.
4 Click the Zoom Extents button on the Main toolbar.

To calculate the total heat generated in the circuit, follow these steps:

1 From the Postprocessing menu open the Boundary Integration dialog box.
2 Select Boundaries 9, 14, and 47. In the Expression edit field type q_prod. Click OK.
   The calculated value, roughly 13.8 W, appears in the message log at the bottom of the graphical user interface.

Generate Figure 2-41 by executing these instructions:

1 From the Postprocessing menu open the Plot Parameters dialog box. On the General page go to the Plot type area and select the Slice, Boundary, and Deformed shape check boxes.
2 Go to the Slice page, and in the Predefined quantities list select Temperature (htgh). In the Slice positioning area find the x levels edit field and type 0, and in the y levels edit field type 1.
3 Click the option button for Vector with coordinates associated with z levels, then in the corresponding edit field type 0.
4 On the Boundary page find the Expression edit field and type T*q_prod/q_prod. The use of q_prod/q_prod makes the expression for the temperature valid on the resistive layer boundary only, which is the desired effect.
5 On the Deform page, go to the Deformation data area and click the Subdomain Data tab. In the Predefined quantities list select Solid, Stress-Strain (smld)>Displacement.
6 While still in the Deformation data area, click the Boundary Data tab. In the Predefined quantities list select Shell (smsh)>Displacement. Click Apply.

Calculate the total heat flux to the fluid in the following way:
From the Postprocessing menu open the Boundary Integration dialog box.

Select Boundaries 3, 8, 13, and 46. In the Expression edit field type
\[ h_{\text{fluid}}(T-T_{\text{fluid}}), \]
then click OK.

A value for the total heat flux of approximately 8.47 W appears in the message log.

To generate Figure 2-42 follow these steps:

1. While still in the Plot Parameters dialog box, go to the Slice page. In the Predefined quantities list select Solid, Stress-Strain (smsld)>von Mises stress.
2. Click the Boundary tab. In the Predefined quantities list select Shell (smsh)>von Mises stress. Click Apply.

Figure 2-43 is obtained by executing the following instructions:

1. From the Postprocessing menu select Domain Plot Parameters.
2. On the Surface page select Boundaries 9, 14, and 47. In the Expression edit field type \[ \sqrt{(T_{\text{sx}})_{\text{smsld}}^2+(T_{\text{sy}})_{\text{smsld}}^2} \]. Click Apply.

This gives a plot of the norm of the surface traction vector \((N/m^2)\) in the surface plane,

\[
\begin{bmatrix}
T_{ax} \\
T_{ay}
\end{bmatrix} = 
\begin{bmatrix}
\sigma_x & \tau_{xy} & \tau_{xz} \\
\tau_{yx} & \sigma_y & \tau_{yz} \\
0 & 0 & 1
\end{bmatrix}
\begin{bmatrix}
0 \\
0 \\
1
\end{bmatrix}
= 
\begin{bmatrix}
\tau_{xx} \\
\tau_{yx}
\end{bmatrix}
\]

Finally, to obtain Figure 2-44, proceed as follows:

1. Still on the Surface page of the Domain Plot Parameters dialog box, select Boundaries 3, 8, 13, and 46.
2. In the Predefined quantities list select Solid, Stress-Strain (smsld)>Total displacement, then click OK.
Rapid Thermal Annealing

Introduction

In the semiconductor industry, rapid thermal annealing (RTA) is a semi-conductor process step used for the activation of dopants and the interfacial reaction of metal contacts. In principle, the operation involves rapid heating of a wafer from ambient to approximately 1000–1500 K. As soon as the wafer reaches this temperature, it is held there for a few seconds and then finally quenched. A rapid process step is crucial in order to avoid too much diffusion of the dopants. Furthermore, it is also important to avoid overheating and nonuniform temperature distribution to occur. An RTA apparatus uses high-power IR lamps as heat sources (Ref. 1).

Figure 2-45: Diagram of a typical RTA (rapid thermal annealing) apparatus.

A technical difficulty lies in how to properly measure the wafer’s temperature during the process. Two commonly used technical solutions are: thermocouples and IR sensors.

To achieve an accurate measurement, it is important that the temperature sensor not be subjected to direct radiation from the lamp. Ideally positioned, the sensor only receives secondary radiation; that is, the radiation reflected and emitted by the silicon wafer. Desirable characteristics of the sensor are high accuracy and short response time. While a high-performance design requires superior electronics, the sensor geometry plays a big role. In a nutshell, the sensor needs to be large enough to register a sufficient amount of radiation but light enough to minimize its own thermal inertia. Since COMSOL Multiphysics gives you control over the geometry, a parameter optimization of the sensor could be an exciting project. But first, justify that an infrared sensor is indeed more appropriate than the inexpensive thermocouple.
Model Definition

Figure 2-45 illustrates a typical RTA configuration. In many applications, RTA makes use of double-sided heating, in which IR lamps are positioned both above and below the silicon wafer. In this example we are modeling a single-sided heating apparatus, as depicted in Figure 2-46.

Figure 2-46: The model geometry.

The components in Figure 2-46 are contained in a chamber with temperature-controlled walls with a set point of 400 K. This results in a closed cavity so you can omit the geometry of the chamber walls. Furthermore, the model assumes that this physical system is dominated by radiation and convection cooling. The convective cooling of the wafer and sensor to the gas (at 400 K) is modeled using a heat transfer coefficients, \( h \) (in this example set to 20 W/(m\(^2\)·K)).

The problem is governed by the heat equation, given below together with its boundary conditions:

\[
\rho C_p \frac{\partial T}{\partial t} + \nabla \cdot (-k \nabla T) = Q
\]

\[-\mathbf{n} \cdot (-k \nabla T) = \dot{h}(T_{\text{inf}} - T) + (\varepsilon/(1 - \varepsilon))(J_0 - \sigma T^4)\]

Here \( \rho \) is the density; \( k \) denotes the thermal conductivity; \( Q \) represents the volume heat source; \( \mathbf{n} \) is the surface normal vector; \( T_{\text{inf}} \) equals the temperature of the convection cooling gas; \( \varepsilon \) denotes the surface emissivity; \( J_0 \) is the expression for surface radiosity.
(further described in the *Heat Transfer Module User’s Guide*); and \( \sigma \) is the Stefan-Boltzmann constant.

The model simulates the lamp as a solid object with a volume heat source of 25 kW. It is insulated on all surfaces except the for the top, which faces the silicon wafer. At this surface, heat leaves the lamp as radiation only. In order to capture the lamp’s transient startup time, the model uses a low heat capacity, \( C_p \), for the solid (10 J/(kg·K)). The lamp’s other thermal properties are identical to those of copper metal (the default value in the application mode).

In this case assume that the wafer dissipates energy via radiation and convection on all surfaces. The sensor is insulated at all surfaces except the top, which is subjected to both convection and radiation. The thermal material properties are set to those of alumina.

The following table summarizes the material properties used in the model:

<table>
<thead>
<tr>
<th>MATERIAL</th>
<th>( k ) (W/(m·K))</th>
<th>( \rho ) (kg/m(^3))</th>
<th>( C_p ) (J/(kg·K))</th>
<th>( \varepsilon )</th>
</tr>
</thead>
<tbody>
<tr>
<td>IR lamp</td>
<td>400</td>
<td>8700</td>
<td>10</td>
<td>0.99</td>
</tr>
<tr>
<td>Silicon wafer (silicon)</td>
<td>163</td>
<td>2330</td>
<td>703</td>
<td>0.5</td>
</tr>
<tr>
<td>Sensor</td>
<td>27</td>
<td>2000</td>
<td>500</td>
<td>0.8</td>
</tr>
</tbody>
</table>

The model simulates the transient temperature field for 10 s of heating. The initial temperature is 400 K for all objects.
Results and Discussion

Figure 2-47 displays the temperature distribution after 10 s of heating.

![Temperature Distribution](image)

Figure 2-47: Temperatures of the lamp, wafer, and sensor after 10 s of heating.

After 10 seconds, the temperatures of the wafer and sensor differ significantly: the wafer is at 1800 K, whereas the sensor is at 1100 K.

Notice that the temperature distribution in the wafer with a delta of several hundred degrees is not very uniform and that you probably can do much better by reconfiguring the heat source. However, such a reconfiguration is not included in this model.

To investigate how well the sensor’s temperature reflects that of the wafer surface, it is useful to plot the temperature transient of the wafer surface’s center point that faces...
the lamp ($T_{\text{wafer}}$), together with the temperature at a point in the sensor top surface ($T_{\text{sensor}}$) (see Figure 2-48).

**Figure 2-48: The temperature transients of the lamp, the silicon wafer, and the sensor, together with the irradiation power at the sensor surface.**

The sensor temperature reflects that of the silicon wafer poorly. This means that the signal of a thermocouple, positioned anywhere in the sensor domain of Figure 2-46, is of little use for regulating this process.

The IR-detector transient ($S_{\text{sensirrad}}$) matches the wafer temperature characteristic quite well. A scalar amplification allows for a high accuracy measurement of the wafer temperature. The precise amplification factor is system-dependent and subject to a calibration requirement.

However, IR-sensor methodology also has drawbacks. The IR signal depends on the emissivity of the wafer, which will vary with temperature making the response nonlinear. Furthermore, the IR signal is very sensitive to geometry changes.

The bright side is that COMSOL Multiphysics does not set any limits with respect to these phenomena and allows you to study them fully.
Reference


Model Library path: Heat_Transfer_Module/Electronics_and_Power_systems/thermal_anneal

Modeling Using the Graphical User Interface

MODEL NAVIGATOR
1. Open the Model Navigator. From the Space dimension list select 3D.
2. In the list of application modes select Heat Transfer Module>General Heat Transfer>Transient analysis, then click OK.

CONSTANTS AND EXPRESSIONS
1. From the Options menu select Constants.
2. Define the following constants; when finished, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>T_wall</td>
<td>400[K]</td>
</tr>
<tr>
<td>T_gas</td>
<td>400[K]</td>
</tr>
<tr>
<td>h_gas</td>
<td>20[W/(m^2*K)]</td>
</tr>
<tr>
<td>k_sens</td>
<td>27[W/(m*K)]</td>
</tr>
<tr>
<td>rho_sens</td>
<td>2000[kg/m^3]</td>
</tr>
<tr>
<td>Cp_sens</td>
<td>500[J/(kg*K)]</td>
</tr>
<tr>
<td>e_sens</td>
<td>0.8</td>
</tr>
<tr>
<td>e_lamp</td>
<td>0.99</td>
</tr>
<tr>
<td>q_lamp</td>
<td>25[kW]/(3.14<em>0.05^2</em>1e-3[m^3])</td>
</tr>
<tr>
<td>e_wafer</td>
<td>0.5</td>
</tr>
<tr>
<td>Cp_lamp</td>
<td>10[J/(kg*K)]</td>
</tr>
<tr>
<td>amplification</td>
<td>50</td>
</tr>
</tbody>
</table>
GEOMETRY MODELING

1. Create three cylinders. To do so, open the menu item **Draw>Cylinder** and enter these settings; when finished, click **OK**.

<table>
<thead>
<tr>
<th>OBJECT</th>
<th>RADIUS</th>
<th>HEIGHT</th>
<th>AXIS BASE POINT, X</th>
<th>AXIS BASE POINT, Z</th>
</tr>
</thead>
<tbody>
<tr>
<td>CYL1</td>
<td>0.05</td>
<td>5e-4</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>CYL2</td>
<td>0.05</td>
<td>1e-3</td>
<td>0</td>
<td>-5e-2</td>
</tr>
<tr>
<td>CYL3</td>
<td>1e-2</td>
<td>1e-3</td>
<td>0.07</td>
<td>-5e-2</td>
</tr>
</tbody>
</table>

2. Click the **Zoom Extents** button on the Main toolbar.

PHYSICS SETTINGS

Subdomain Settings

1. From the **Physics** menu select **Subdomain Settings**.

2. In the **Conduction** page select Subdomain 1. In the **Cp** edit field type **Cp_lamp**, and in the **Q** edit field type **q_lamp**. Use the default values for both the conductivity and the density.

3. Select Subdomain 2, then click the **Load** button. In the **Material** list select **Basic Material Properties>Silicon**. Click **OK**.

4. Select Subdomain 3. In the **k (isotropic)** edit field type **k_sens**, in the **ρ** edit field type **ρ_sens**, and in the **Cp** edit field type **Cp_sens**.

5. Select all subdomains. Go to the **Init** page, then in the **T(t0)** edit field type **T_wall**. Click **OK**.

Boundary Conditions

1. From the **Physics** menu open the **Boundary Settings** dialog box.

2. Select Boundary 4. In the **Boundary condition** list select **Heat flux**, and in the **Radiation type** list select **Surface-to-surface**. In the **ε** edit field type **ε_lamp**, and in the **Tamb** edit field type **T_wall**.

3. Select Boundaries 5, 6, 7, 8, 10, 12, and 16.

4. In the **Boundary condition** list select **Heat flux**. In the **h** edit field type **h_gas**, and in the **Tinf** edit field type **T_gas**.

5. In the **Radiation type** list select **Surface-to-ambient**. In the **ε** edit field type **ε_wafer**, and in the **Tamb** edit field type **T_wall**.

6. Select Boundaries 7 and 16. In the **Radiation type** list change to **Surface-to-surface**.

7. Select Boundary 16 alone. Change the entry in the **ε** edit field to **ε_sens**. Click **OK**.
MESH GENERATION
1. From the Mesh menu open the Free Mesh Parameters dialog box.
2. In the Predefined mesh sizes list select Coarser. Go to the Advanced page. In the z-direction scale factor edit field type 5. Click the Remesh button, then click OK.

PREPARE POSTPROCESSING
To prepare some postprocessing operations, you need to define an integration coupling variable. In addition, a line intersecting the lamp and wafer surfaces is also helpful in later postprocessing.

1. Choose Options>Integration Coupling Variables>Boundary Variables.
2. Select Boundary 16. In the Name edit field type Sens_irrad, and in the Expression edit field type G_htgh (a predefined application mode variable representing inward radiation which includes both surface-to-surface and surface-to-ambient contributions). Click OK.
3. From the Draw menu select Line. In the edit fields for x, y, and z type 0, 0, 0, and -5e-2 1e-3, respectively. Click OK. (This step is not necessary if you loaded the geometry file).

Computing the Solution
1. From the Solve menu select Solver Parameters.
2. On the General page type 0 10 in the Times edit field.
3. In the Linear system solver list select Direct (UMFPACK).
4. Click the Time Stepping tab. In the Times to store in output list select Time steps from solver.
5. From the Consistent initialization of DAE systems list select On.
6. From the Error estimation strategy list select Exclude algebraic, then click OK.
   The last setting instructs the solver to omit the radiation calculations, which is always a stationary solution (algebraic equation), from the time-stepping error analysis. This greatly speeds up the solution process in terms of time stepping.
7. Click Solve on the Main toolbar (this should take less than a minute).

POSTPROCESSING AND VISUALIZATION
Generate Figure 2-47 by executing the following instructions:

1. From the Postprocessing menu open the Plot Parameters dialog box.
2 On the General page go to the Plot type area and clear the Slice check box, then select the Boundary check box. Click OK.

The following steps generate Figure 2-48:

1 From the Postprocessing menu open the Domain Plot Parameters dialog box.
2 On the General page select the Keep current plot check box.
3 On the Point page select Point 10.
4 Click the Line Settings button. In the Line color list select Color.
5 Click to select the Legend check box. Click OK, the click Apply.
6 Select Point 12, then click the Line Settings button. In the Line style list select Dashed line. Click OK, then click Apply.
7 Select Point 23, then click the Line Settings button. In the Line color list select Cycle, and in the Line style list select Solid line. Click OK, then click Apply.
8 In the Expression edit field type Sens_irrad*amplification.
9 Click the Line Settings button. In the Line style list select Dashed line, then click OK.
10 On the General page, click the Title/Axis button.
11 In the Title edit field type Temperature/signal transients.
12 In the Second axis label edit field type T [K]; signal intensity.
13 Click OK to finalize the plot.
Thermo-Photo-Voltaic Cell

Introduction

The following example illustrates an application that maximizes surface-to-surface radiative fluxes and minimizes conductive heat fluxes.

A thermo-photo-voltaic (TPV) cell generates electricity from the combustion of fuel and through radiation (Ref. 1). Figure 2-49 depicts the general operating principle. The fuel burns inside an emitting device that radiates intensely. Photo-voltaic (PV) cells—almost like solar cells—capture the radiation and convert it to electricity. The efficiency of a TPV device ranges from 1% to 20%. In some cases, TPVs are used in heat generators to co-generate electricity, and the efficiency is not so critical. In other cases TPVs are used as electric power sources, for example in automobiles (Ref. 2). In those cases efficiency is a major concern.

Figure 2-49: Operating principle of a TPV device (Ref. 3), and an image of a prototype system (Ref. 4).
TPV systems, unlike typical electronic systems, must maximize radiation heat transfer to improve efficiency. However, inherent radiation losses—radiation not converted to electric power—contributes to the PV cells’ increased temperature. Further, heat transfer through conduction results in increased cell temperature. PV cells have a limited operating temperature range that depends on the type of material used. Solar cells are limited to temperatures below 80 °C, whereas high-efficiency semiconductor materials can withstand as much as 1000 °C. Photovoltaic efficiency is often a function of temperature with a maximum at some temperature above ambient.

To improve system efficiency, engineers prefer to use high-efficiency PV cells, which however can be quite expensive. To reduce system costs, engineers work with smaller-area PV cells and then use mirrors to focus the radiation on them. However, there is a limit for how much you can focus the beams; if the radiation intensity becomes too high, the cells can overheat. Thus engineers must optimize system geometry and operating conditions to achieve maximum performance at minimum material costs.

The following model, which uses the General Heat Transfer application mode, investigates the influence of operating conditions (flame temperature) on system efficiency and the temperature of components in a typical TPV system. The model can also assess the influence of geometry changes.
Figure 2-50: Geometry and dimensions of the modeled TPV system.

Figure 2-50 depicts the geometry and dimensions of the system under study. To reduce the temperature, the PV cells are water cooled on their back side (at the interface with the insulation).

The following equation describes the heat fluxes, radiative flux, and conductive flux; after it comes the boundary condition equation

\[
\rho C_p \frac{\partial T}{\partial t} + \nabla (-k \nabla T) = Q
\]

\[
-\mathbf{n} \cdot (-k \nabla T) = h(T_{\text{inf}} - T) + (\varepsilon/(1 - \varepsilon))(J_0 - \sigma T^4) + q
\]

where \(\rho\) is the density, \(k\) denotes the thermal conductivity (W/(m·K)), \(Q\) represents the volume heat source (W/m\(^3\)), \(\mathbf{n}\) is the surface normal vector, \(h\) is the convective heat transfer film coefficient (W/(m\(^2\)·K)), \(T_{\text{inf}}\) equals the temperature of the convection coolant, \(\varepsilon\) equals the surface emissivity, \(J_0\) is the surface radiosity expression.
Conduction is always present on the different boundaries. The model simulates the emitter with a specific temperature, $T_{\text{heater}}$, on the inner boundary. At the outer emitter boundary, it takes radiation (surface-to-surface) into account in the boundary condition. It simulates the mirrors by taking radiation into account on all boundaries and applying a low emissivity. The inner boundaries of the PV cells and of the insulation also make use of radiation boundary conditions. However, the PV cells have a high emissivity and the insulation a low emissivity. Further, the PV cells convert a fraction of the irradiation to electricity instead of heat. Heat sinks on their inner boundaries simulate this effect according to

$$q = -G\eta_{\text{pv}}$$

where $G$ is the irradiation flux (W/m$^2$), and $\eta_{\text{pv}}$ is the PV cell’s voltaic efficiency. The latter depends on the local temperature, with a maximum of 0.2 at 800 K:

$$\eta_{\text{pv}} = \begin{cases} 0.2 \left[ 1 - \left( \frac{T}{800 \text{ K}} - 1 \right)^2 \right] & T \leq 1600 \text{ K} \\ 0 & T > 1600 \text{ K} \end{cases}$$

Figure 2-51 below illustrates this expression for temperatures above 1000 K.
At the outer boundary of the PV cells, the model applies convective water cooling by setting $h$ to $50 \text{ W/(m}^2\cdot\text{K})$, and $T_{\text{amb}}$ to 273 K. Finally, at the outer boundary of the insulation it applies convective cooling with $h$ set to $5 \text{ W/(m}^2\cdot\text{K})$ and $T_{\text{amb}}$ to 293 K.

The following table summarizes the material properties.

<table>
<thead>
<tr>
<th>COMPONENT</th>
<th>$k$ [W/(m·K)]</th>
<th>$\rho$ [kg/m$^3$]</th>
<th>$C_p$ [J/(kg·K)]</th>
<th>$\varepsilon$</th>
</tr>
</thead>
<tbody>
<tr>
<td>emitter</td>
<td>10</td>
<td>2000</td>
<td>900</td>
<td>0.99</td>
</tr>
<tr>
<td>mirror</td>
<td>10</td>
<td>5000</td>
<td>840</td>
<td>0.01</td>
</tr>
<tr>
<td>PV cell</td>
<td>93</td>
<td>2000</td>
<td>840</td>
<td>0.99</td>
</tr>
<tr>
<td>insulation</td>
<td>0.05</td>
<td>700</td>
<td>100</td>
<td>0.1</td>
</tr>
</tbody>
</table>

The model calculates the stationary solution for a range of emitter temperatures (1000 K to 2000 K) using the parametric solver.

**Results and Discussion**

The results shows that the device experiences a significant temperature distribution that varies with operating conditions. Figure 2-52 depicts the stationary distribution at operating conditions with an emitter temperature of 2000 K.

![Temperature distribution in the TPV system when the emitter temperature is 2000 K.](image)

*Figure 2-52: Temperature distribution in the TPV system when the emitter temperature is 2000 K.*
As the upper plot in Figure 2-53 shows, the PV cells reach a temperature of approximately 1800 K. This is significantly higher than their maximum operating temperature of 1600 K, above which their photovoltaic efficiency is zero (see Figure 2-51 on page 130).

It is interesting to investigate what the optimal operating temperature is. The lower plot in Figure 2-53 investigates at what temperature the system achieves the maximum electric power output. The optimal emitter temperature for this configuration seems to be between 1600 K and 1700 K, where the electric power (irradiation multiplied by voltaic efficiency) is maximum.

Figure 2-53: PV cell temperature (top) and electric output power (bottom) versus operating temperature.
The next step is to look at the temperature distribution at the optimal operating conditions (Figure 2-54).

Figure 2-54: Temperature distribution and surface irradiation flux in the system at an operating emitter temperature of 1600 K.

When the emitter is at 1600 K, the PV cells reach a temperature of approximately 1200 K, which they can withstand without any problems. Note that the insulation reaches a temperature of approximately 800 K on the outside, suggesting that the system transfers a significant amount of heat to the surrounding air.

The plot also depicts the irradiative flux, which varies significantly along the circumference of the PV cell and insulation jacket. To further investigate this effect, Figure 2-55 plots the irradiative flux along a quarter of the circumference separately at this operating condition. Clearly the variation it shows is related to the positions of the mirrors and is an effect of shadowing.
Figure 2-55: Irradiation flux along the PV cell and insulation inner surface for one quarter of the device circumference.

This plot can help optimize the mirror geometry as well as help decide how large the PV cells should be and where they should be placed.

A general conclusion is that this type of modeling can shortcut the prototype development time and optimize the operating conditions for the finalized TPV device.

References

4. Courtesy of Dr. D. Wilhelm, Paul Sherrer Institute, Switzerland.
Model Library path: Heat_Transfer_Module/Electronics_and_Power_systems/TPV_cell

Modeling Using the Graphical User Interface

**MODEL NAVIGATOR**
1. Open the **Model Navigator**, and in the **Space dimension** list select **2D**.
2. In the list of application modes select **Heat Transfer Module>General Heat Transfer**.
3. In the **Element** list select **Lagrange - Quadratic**.
4. Click **OK**.

**OPTIONS AND SETTINGS**
1. From the **Options** menu open the **Axes/Grid Settings** dialog box. Go to the **Axis** page.
   - In both the **x min** and **y min** edit fields type -0.05, and in both the **x max** and **y max** edit fields type 0.05.
2. On the **Grid** page clear the **Auto** check box. In both the **x spacing** and **y spacing** edit fields type 0.002. Click **OK**.
3. From the **Options** menu select **Constants**. In the dialog box that opens enter the following names, expressions, and (optionally) descriptions; when done, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>T_heater</td>
<td>1000[K]</td>
<td>Temperature, emitter inner boundary</td>
</tr>
<tr>
<td>Cp_air</td>
<td>1100[J/(kg*K)]</td>
<td>Specific heat capacity, air</td>
</tr>
<tr>
<td>h_air</td>
<td>5[W/(m²*K)]</td>
<td>Heat transfer coefficient, air</td>
</tr>
<tr>
<td>T_air</td>
<td>293[K]</td>
<td>Temperature, air</td>
</tr>
<tr>
<td>k_ins</td>
<td>0.05[W/(m*K)]</td>
<td>Thermal conductivity, insulation</td>
</tr>
<tr>
<td>rho_ins</td>
<td>700[kg/m³]</td>
<td>Density, insulation</td>
</tr>
<tr>
<td>Cp_ins</td>
<td>100[J/(kg*K)]</td>
<td>Specific heat capacity, insulation</td>
</tr>
<tr>
<td>e_ins</td>
<td>0.1</td>
<td>Surface emissivity, insulation</td>
</tr>
<tr>
<td>k_m</td>
<td>10[W/(m*K)]</td>
<td>Thermal conductivity, mirror</td>
</tr>
<tr>
<td>rho_m</td>
<td>5000[kg/m³]</td>
<td>Density, mirror</td>
</tr>
<tr>
<td>Cp_m</td>
<td>840[J/(kg*K)]</td>
<td>Specific heat capacity, mirror</td>
</tr>
<tr>
<td>e_m</td>
<td>0.01</td>
<td>Surface emissivity, mirror</td>
</tr>
</tbody>
</table>
Choose Options>Expressions>Scalar Expressions, then define the following expressions; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>k_emit</td>
<td>10[W/(m*K)]</td>
<td>Thermal conductivity, emitter</td>
</tr>
<tr>
<td>rho_emit</td>
<td>2000[kg/m³]</td>
<td>Density, emitter</td>
</tr>
<tr>
<td>Cp_emit</td>
<td>900[J/(kg*K)]</td>
<td>Specific heat capacity, emitter</td>
</tr>
<tr>
<td>e_emit</td>
<td>0.99</td>
<td>Surface emissivity, emitter</td>
</tr>
<tr>
<td>k_pv</td>
<td>93[W/(m*K)]</td>
<td>Thermal conductivity, PV-cell</td>
</tr>
<tr>
<td>rho_pv</td>
<td>2000[kg/m³]</td>
<td>Density, PV-cell</td>
</tr>
<tr>
<td>Cp_pv</td>
<td>840[J/(kg*K)]</td>
<td>Specific heat capacity, PV-cell</td>
</tr>
<tr>
<td>e_pv</td>
<td>0.99</td>
<td>Surface emissivity, PV-cell</td>
</tr>
<tr>
<td>h_cool</td>
<td>50[W/(m²*K)]</td>
<td>Heat transfer coefficient, cooling water</td>
</tr>
<tr>
<td>T_cool</td>
<td>273[K]</td>
<td>Temperature, cooling water</td>
</tr>
</tbody>
</table>

4 Choose Options>Expressions>Scalar Expressions, then define the following expressions; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>k_air</td>
<td>10*(-3.723+0.865<em>log10(abs(T[1/K]))) [W/(m</em>K)]</td>
<td></td>
</tr>
<tr>
<td>rho_air</td>
<td>1.013e5[Pa]<em>28.8e-3[kg/mol]/(8.31[J/(mol</em>K)]*T)</td>
<td></td>
</tr>
<tr>
<td>eta_pv</td>
<td>0.2*(1-(T/800[K]-1)^2)*(T&lt;1600[K])</td>
<td></td>
</tr>
</tbody>
</table>

GEOMETRY MODELING

1 Create two circles. To do so, choose Draw>Specify Objects>Circle. For the first circle type 0.035 in the Radius edit field, for the second type 0.037.

2 Click the Create Composite Object button on the Draw toolbar. In the Set formula edit field type C2-C1, then click OK.

3 Specify a rectangle by pressing Shift and clicking the Rectangle button on the Draw toolbar. In both the Width and Height edit fields type 0.05, and in the x-base edit field type -0.05. Click OK.

4 Select all the objects and click the Intersection button on the Draw toolbar. This creates the composite object CO2, which is a quarter of an annulus.

5 To create the first mirror, create two rectangles. Press Shift then click the Rectangle button on the Draw toolbar. Then for each rectangle enter the following settings. When done with each, click OK.

<table>
<thead>
<tr>
<th>OBJECT</th>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>BASE</th>
<th>X-BASE</th>
<th>Y-BASE</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>0.01</td>
<td>0.002</td>
<td>Center</td>
<td>-0.014</td>
<td>0.015</td>
</tr>
<tr>
<td>R2</td>
<td>0.002</td>
<td>0.006</td>
<td>Center</td>
<td>-0.014</td>
<td>0.017</td>
</tr>
</tbody>
</table>
6 Select both rectangles, then click the Create Composite Object button on the Draw toolbar. Clear the Keep interior boundaries check box, then click OK to create the union.

7 From the Draw menu open the Fillet/Chamfer dialog box.

8 In the Vertex selection list click the CO1 folder, then select Vertices 1, 2, 5, 8, 9, and 10. In the Radius edit field type 0.5e-3, then click OK. This step creates the composite object CO3.

9 Copy and paste CO3 by pressing Ctrl+C and then Ctrl+V. When pasting, specify the Displacement for x as 0.014 and for y as 0.006. Click OK.

10 Select CO3. Click the Rotate button on the Draw toolbar. In the Rotation angle edit field type 45. Go to the Center point area; in the x edit field type -0.014, and in the y edit field type 0.014. Click OK.

11 Click the Line button on the Draw toolbar. Draw a line by left-clicking at (0, 0)—you can read the position in the lower left corner of the user interface—and at (-0.046, 0.012). Finalize the line by right-clicking in the drawing area.

12 Repeat the procedure in the previous step to draw three additional lines between the coordinates (0, 0) and (-0.024, 0.040), between (0, 0) and (-0.012, 0.046), as well as between (0, 0) and (-0.04, 0.024).

13 Select the circle object CO2 and the first line, B1. Click the Coerce to Solid button on the Draw toolbar.

14 Using the mouse, select the annulus object (now named CO4) and the second line. Click Coerce to Solid.

15 Select the annulus object (now named CO2) and the third line, B3. Click Coerce to Solid.

16 Select all objects (press Ctrl+A) and click Coerce to Solid.

17 Press Ctrl+C to copy the new composite object. Press Ctrl+V, then click OK to paste it with zero displacement.

18 Click Rotate. For the Rotation angle specify 90, then click OK.

19 Repeat the paste-and-rotate procedure for 180 and 270 degrees to complete the circular object. Press Ctrl+D to deselect all objects before selecting the original composite object to make a copy and then rotate it.

20 Draw two circles using the menu item Draw>Specify Objects>Circle. For the first one type 0.04 in the Radius edit field, for the second one type 0.037.

21 Click the Zoom Extents button on the Main toolbar.
Select the two circles, click the **Create Composite Object** button on the Draw toolbar, and in the **Set formula** edit field type the expression \( C1 - C2 \). Click **OK**.

Select all objects (press Ctrl+A).

Click the **Split Object** button on the Draw toolbar.

Select the objects indicated in the following figure, then click the **Create Composite Object** button on the Draw toolbar. Clear the **Keep interior boundaries** check box, then click **OK**.

Draw two circles using the menu item **Draw>Specify Objects>Circle**. For the first one type \( 0.01 \) in the **Radius** edit field, for the second one type \( 0.011 \).

Click the **Create Composite Object** button on the Draw toolbar, then in the **Set formula** edit field type \( C2 - C1 \). Click **OK**.

To finalize the geometry select all objects, then click **Coerce to Solid**.
PHYSICS SETTINGS

Subdomain Settings
1. From the Physics menu select Subdomain Settings.
2. In the Init page select all the subdomains, then in the \( T(t_0) \) edit field enter \( T_{air} \).
3. Go to the Conduction page and specify the following settings; when done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN 1</th>
<th>SUBDOMAINS 2, 3, 6, 7, 12, 13, 17, 18</th>
<th>SUBDOMAINS 5, 8, 9, 10, 11, 14, 15, 16</th>
<th>SUBDOMAIN 19</th>
<th>SUBDOMAINS 4, 20</th>
</tr>
</thead>
<tbody>
<tr>
<td>( k )</td>
<td>( k_{ins} )</td>
<td>( k_{pv} )</td>
<td>( k_m )</td>
<td>( k_{emit} )</td>
<td>( k_{air} )</td>
</tr>
<tr>
<td>( \rho )</td>
<td>( \rho_{ins} )</td>
<td>( \rho_{pv} )</td>
<td>( \rho_{m} )</td>
<td>( \rho_{emit} )</td>
<td>( \rho_{air} )</td>
</tr>
<tr>
<td>( C_p )</td>
<td>( C_{p_{ins}} )</td>
<td>( C_{p_{pv}} )</td>
<td>( C_{p_{m}} )</td>
<td>( C_{p_{emit}} )</td>
<td>( C_{p_{air}} )</td>
</tr>
<tr>
<td>Opacity</td>
<td>Opaque</td>
<td>Opaque</td>
<td>Opaque</td>
<td>Opaque</td>
<td>Transparent</td>
</tr>
</tbody>
</table>

Boundary Conditions
1. From the Physics menu open the Boundary Settings dialog box.
2. Select the Interior boundaries check box to enable the specification of interior boundaries.
3. Select all the boundaries of the mirror objects by using the mouse to draw a box around each mirror. Press and hold the Ctrl key on the keyboard to add selections.
4. Click the Boundary Condition tab, and in the Boundary condition list select Heat source/sink. In the Radiation type list select Surface-to-surface. In the \( \varepsilon \) edit field for Surface emissivity type \( e_m \).
5. In the Boundary selection list choose 97, 98, 141, and 148 (the outer boundaries of the insulation). In the Boundary condition list select Heat flux. In the \( h \) edit field for the Heat transfer coefficient type \( h_{air} \), and in the \( T_{inf} \) edit field for External temperature type \( T_{air} \). In the Radiation type list select Surface-to-ambient. In the \( \varepsilon \) edit field type \( e_{ins} \), and in the \( T_{amb} \) edit field for Ambient temperature type \( T_{air} \).
6. In the Boundary selection list choose 101, 102, 105, 106, 133, 134, 142, 147, 167, 168, 183, and 184 (the inner boundaries of the insulation). In the Boundary condition list select Heat source/sink. In the Radiation type list select Surface-to-surface. In the \( \varepsilon \) edit field type \( e_{ins} \).
7. In the Boundary selection list choose 99, 100, 119, 120, 157, 158, 181, and 182 from the list (the outer boundaries of the cells). In the Boundary condition list select Heat source/sink. In the \( h \) edit field type \( h_{cool} \), and in the \( T_{inf} \) edit field type \( T_{cool} \).
In the **Boundary selection** list choose 103, 104, 115, 116, 155, 156, 179, and 180 (the inner boundaries of the cells). In the **Boundary condition** list select **Heat source/sink**. In the **Radiation type** list select **Surface-to-surface**. In the $q_0$ edit field for **Heat source/sink** type $-\mathcal{G}_{\text{htgh}}\times\eta_{\text{pv}}$, and in the $\epsilon$ edit field type $\epsilon_{\text{pv}}$.

In the **Boundary selection** list choose 127, 128, 143, and 146 (the outer boundaries of the emitter). In the **Boundary condition** list select **Heat source/sink**. In the **Radiation type** list select **Surface-to-surface**. In the $\epsilon$ edit field type $\epsilon_{\text{emit}}$.

Finally, in the **Boundary selection** list choose 131, 132, 144, and 145 (the inner boundaries of the emitter). In the **Boundary condition** list select **Temperature**. In the $T_0$ edit field for **Temperature** type $T_{\text{heater}}$.

Click **OK**.

**MESH**

1. From the **Mesh** menu open the **Free Mesh Parameters** dialog box.

2. In the **Predefined mesh sizes** list select **Coarser**.

3. Go to the **Boundary** page. Using the mouse, select all boundaries of the mirrors and of the emitter’s outer boundary. In the **Maximum element size** edit field type 10^{-3}.

4. Select all inner boundaries of the insulation and the PV cells (101, 102, 103, 104, 105, 106, 119, 120, 133, 134, 142, 147, 155, 156, 167, 168, 179, 180, 183, and 184). In the **Maximum element size** edit field type 2\times10^{-3}. Click **Remesh**, then click **OK**.

**COMPUTING THE SOLUTION**

1. From the **Solve** menu open the **Solver Parameters** dialog box.

2. On the **General** page, find the **Solver** list and select **Parametric**. In the **Linear system solver** list select **Direct (UMFPACK)**. In the **Parameter name** edit field type $T_{\text{heater}}$, and in the **Parameter values** edit field type 1000:100:2000.

3. On the **Parametric** page, select the **Manual tuning of parameter step size** check box. In the **Initial step size** edit field type 100. Specify a **Minimum step size** of 25 and a **Maximum step size** of 100.

4. Click the **Stationary** tab. In the **Maximum number of iterations** edit field type 50.

5. Click **OK**.

6. Click the **Solve** button on the Main toolbar.

**POSTPROCESSING AND VISUALIZATION**

Figure 2-52 is the default postprocessing plot. To reproduce the plots in Figure 2-53, follow these steps:
1. From the **Postprocessing** menu open the **Domain Plot Parameters** dialog box.

2. On the **General** page, clear the check box next to the label **Element refinement** (doing so disables automatic refinement), then in the corresponding edit field type 1.

3. Go to the **Point** page. In the **Point selection** list choose Point 6.

4. In the **Expression** edit field type $G_{htgh} \times \eta_{pv}$, then click **Apply** to generate the upper plot.

5. Click the **General** tab. In the **Plot in** list select **New figure**.

6. Return to the **Point** page. In the **Expression** edit field type $T$, then click **OK** to close the dialog box and generate the lower plot.

To generate Figure 2-54, follow these steps:

1. From the **Postprocessing** menu open the **Plot Parameters** dialog box.

2. On the **General** page find the **Parameter value** list and select **1600**.

3. Click the **Boundary** tab. Select the **Boundary plot** check box, then select the **Height data** check box.

4. A **Predefined quantities** list appears in both the **Boundary data** area and the **Height data** area. In both lists select **Surface irradiation**, then click **OK**.

5. To make the axes and the grid disappear, double-click the **AXIS** and **GRID** buttons on the status bar at the bottom of the user interface.

To reproduce Figure 2-55, follow these steps:

1. From the **Postprocessing** menu open the **Domain Plot Parameters** dialog box.

2. On the **General** page find the **Solutions to use** list and select **1600**. In the **Plot in** list select **New figure**.

3. Click the **Line/Extrusion** tab, and in the **Predefined quantities** list select **Surface irradiation**.

4. In the **Boundary selection** list choose 102, 104, 106, 116, and 134 (a quarter of the system’s inner wall). Click **OK**.
Convective Cooling of a Potcore Inductor

Introduction

The inductor is a common component in a variety of different electrical devices. Its usage ranges from power transformation to measurement systems. In small devices with many components, such as in laptop computers, heat generation can be a problem and has to be accounted for in the design. This model describes the heat transfer in a potcore inductor that is cooled by convective cooling.

Model Definition

The problem is axisymmetric, so the model only requires two space dimensions. The following figure describes the model geometry:

![Figure 2-56: 3D view of the model geometry.](image)

A varying current in the copper induces a magnetic field that is strengthened by the ferrite core. Heat is generated in the core and the winding due to resistive heating. This model does not include the resistive heating due to induced currents, but instead assumes that a specific amount of heat is generated uniformly in the core and in the copper.
The component is cooled by air that enters from the top of the geometry and exits through the center and the lower part of the outer boundary.

**Results and Discussion**

Figure 2-57 shows the temperature distribution together with an arrow plot of the velocity field. The temperature has a maximum in the copper winding where most of the heat is generated. It is clear that the air flow has a cooling effect on the temperature although this effect is not optimal. The arrow plot reveals that the air flow between the barrier and the ferrite core is very close to zero. Note also the recirculation zone in right part of the plot.

![Figure 2-57: Surface plot of the temperature and arrow plot of the velocity field.](image)

In the overall heat balance, radiation is responsible for about 10% of the total heat loss at steady state. The plot in Figure 2-58 shows a cross-sectional plot of the net radiative flux along the inner, vertical, boundary of the central hole (see Figure 2-56). Note that away from the open ends, the emitted and reflected radiation is almost balanced by the incident energy, so even if the temperature and radiation levels are high, the net flux is
small in this region. The main part of the radiative losses instead take place from the outside of the inductor.

Figure 2-58: Cross-sectional plot of the net radiative flux.

**Modeling in COMSOL Multiphysics**

This model uses the General Heat Transfer application mode to solve for the temperature distribution. To provide cooling for the component, air enters the domain at the top of the geometry at the speed of 1 m/s. To include the air flow, the model also uses the Weakly Compressible Navier-Stokes application mode. The viscosity and density of air and hence the air flow depend on the temperature; on the other hand, the temperature distribution depends on the flow around the component. This means that this multiphysics model has to be solved simultaneously.

In this axisymmetric model, some of the surfaces are exposed to heat radiation from other surfaces, which means that surface-to-surface radiation must be accounted for. This type of radiation is quite complex because it depends on radiation from both the ambient and other surfaces. However, on some surfaces this complex boundary condition can be simplified to surface-to-ambient radiation. These are the surfaces that cannot be seen from any other radiating surfaces.

**Model Library path:** Heat_Transfer_Module/ Electronics_and_Power_Systems/potcore_inductor
MODEL NAVIGATOR
1 In the Model Navigator, select Axial symmetry (2D) from the Space dimension list.
2 Click the Multiphysics button.
3 Select Heat Transfer Module>General Heat Transfer, then click Add.
4 Select Heat Transfer Module>Weakly Compressible Navier-Stokes, then click Add.
5 Click OK to close the Model Navigator.

OPTIONS AND SETTINGS
1 Open the Constants dialog box from the Options menu and enter the constants according to the following table (the descriptions are optional).

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Q_core</td>
<td>7.64e4[W/m^3]</td>
<td>Heat source in the core</td>
</tr>
<tr>
<td>Q_copper</td>
<td>8.657e5[W/m^3]</td>
<td>Heat source in the copper</td>
</tr>
<tr>
<td>p0</td>
<td>101.3[kPa]</td>
<td>Atmosphere pressure</td>
</tr>
<tr>
<td>T_amb</td>
<td>25[degC]</td>
<td>Ambient temperature</td>
</tr>
<tr>
<td>eps_ferrite</td>
<td>0.2</td>
<td>Surface emissivity of ferrite</td>
</tr>
<tr>
<td>eps_quartz</td>
<td>0.8</td>
<td>Surface emissivity of quartz</td>
</tr>
</tbody>
</table>

2 Click on OK to close the dialog box.
GEOMETRY MODELING

1 Create rectangles according to the following table by shift-clicking on the Rectangle/Square button on the Draw toolbar and then specifying their width, height, and corner position.

<table>
<thead>
<tr>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>CORNER</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.05</td>
<td>0.05</td>
<td>(0,0)</td>
</tr>
<tr>
<td>0.03</td>
<td>0.02</td>
<td>(0,0.05)</td>
</tr>
<tr>
<td>0.0185</td>
<td>0.0294</td>
<td>(0.0027,0)</td>
</tr>
<tr>
<td>0.00895</td>
<td>0.0203</td>
<td>(0.00885,0.00455)</td>
</tr>
<tr>
<td>0.002</td>
<td>0.015</td>
<td>(0.011,0.0072)</td>
</tr>
<tr>
<td>0.001</td>
<td>0.03</td>
<td>(0.03,0)</td>
</tr>
</tbody>
</table>

2 Click the Zoom Extents button on the Main toolbar to fit the model geometry to your window.

3 Draw a line from (0.05, 0) to (0.05, 0.02).

The geometry should now look like that in Figure 2-59.

Figure 2-59: The model geometry.
PHYSICS SETTINGS

Subdomain Settings—General Heat Transfer
1 Select the General Heat Transfer application mode from the Model Tree.
2 From the Physics menu, choose Subdomain Settings.
3 Select Subdomains 1 and 2, then click the Load button.
4 Select Air, 1 atm from the Basic Material Properties library, then click OK.
5 Select Subdomain 5, then click the Load button.
6 Select Copper from the Basic Material Properties library, then click OK.
7 For the remaining subdomains, specify the material properties according to the following table:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN 3 (FERRITE)</th>
<th>SUBDOMAIN 4 (MYLAR)</th>
<th>SUBDOMAIN 6 (QUARTZ)</th>
</tr>
</thead>
<tbody>
<tr>
<td>k (isotropic)</td>
<td>5</td>
<td>0.2</td>
<td>6.1</td>
</tr>
<tr>
<td>ρ</td>
<td>4800</td>
<td>1393</td>
<td>2648</td>
</tr>
<tr>
<td>C_p</td>
<td>750</td>
<td>1000</td>
<td>759</td>
</tr>
</tbody>
</table>

8 Select the copper subdomain (Subdomain 5), and enter $Q_{\text{copper}}$ in the Heat Source edit field.
9 Select the ferrite subdomain (Subdomain 3) and enter $Q_{\text{core}}$ in the Heat Source edit field.

Some of the boundaries in the model are exposed to surface-to-surface radiation. Before specifying this boundary condition you must first specify which subdomains that are opaque and which are transparent. By default, all subdomains are assumed to be opaque. For the air domain you also have to enable the convective heat transfer.

10 Select the air subdomains (Subdomains 1 and 2) and select Transparent from the Opacity list.
11 With the air domains selected, click on the Convection tab and select the Enable convective heat transfer check box.
12 Enter $u$ and $v$ in the Velocity field edit fields to couple the velocities from the Weakly Compressible Navier-Stokes application mode to the convective heat transfer.
13 Click OK.

Boundary Conditions—General Heat Transfer
1 From the Physics menu, open the Boundary Settings dialog box.
2. Select the **Interior boundaries** check box, then specify the boundary conditions according to the following tables. When done, click **OK**.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 1, 3</th>
<th>BOUNDARIES 5, 22, 23, 27</th>
<th>BOUNDARIES 2, 26</th>
<th>BOUNDARIES 7, 18, 20, 25</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Axial symmetry</td>
<td>Temperature</td>
<td>Convective flux</td>
<td>Thermal insulation</td>
</tr>
<tr>
<td>$T_0$</td>
<td>$T_{\text{amb}}$</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Radiation type</td>
<td>None</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 6, 17</th>
<th>BOUNDARY 8</th>
<th>BOUNDARIES 21, 24</th>
<th>BOUNDARY 19</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Heat source/sink</td>
<td>Heat source/sink</td>
<td>Heat source/sink</td>
<td>Heat source/sink</td>
</tr>
<tr>
<td>$T_{\text{amb}}$</td>
<td>$T_{\text{amb}}$</td>
<td>$T_{\text{amb}}$</td>
<td>$T_{\text{amb}}$</td>
<td>$T_{\text{amb}}$</td>
</tr>
<tr>
<td>Radiation type</td>
<td>Surface-to-surface</td>
<td>Surface-to-surface</td>
<td>Surface-to-surface</td>
<td>Surface-to-surface</td>
</tr>
<tr>
<td>Surface emissivity</td>
<td>$\text{eps}_{\text{ferrite}}$</td>
<td>$\text{eps}_{\text{ferrite}}$</td>
<td>$\text{eps}_{\text{quartz}}$</td>
<td>$\text{eps}_{\text{quartz}}$</td>
</tr>
</tbody>
</table>

**Subdomain Settings—Weakly Compressible Navier-Stokes**

1. Select the **Weakly Compressible Navier-Stokes** application mode from the **Model Tree**.
2. From the **Physics** menu, open the **Subdomain Settings** dialog box.
   - The solid domains can be deactivated because there is no flow in them.
3. Select Subdomains 3–6, then clear the **Active in this domain** check box.
4. Select Subdomain 1 and 2, then select **Air, 1 atm** from the **Library material** list.
5. Click the **Artificial Diffusion** button. Confirm that the **Streamline diffusion** check box is selected and that **Galerkin Least-Squares (GLS)** is selected from the list.
6. Click **OK**.
7. On the **Init** page, enter $p_0$ in the **Pressure** edit field.
8. Click **OK** to close the **Subdomain Settings** dialog box.

**Boundary Conditions—Weakly Compressible Navier-Stokes**

1. From the **Physics** menu, open the **Boundary Settings** dialog box.
2. Specify boundary conditions according to the following table. When done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 1, 3</th>
<th>BOUNDARY 5</th>
<th>BOUNDARIES 18, 22, 23, 25, 27</th>
<th>BOUNDARIES 2, 26</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary type</td>
<td>Symmetry boundary</td>
<td>Inlet</td>
<td>Wall</td>
<td>Outlet</td>
</tr>
<tr>
<td>Boundary condition</td>
<td>Axial symmetry</td>
<td>Velocity</td>
<td>No slip</td>
<td>Pressure</td>
</tr>
<tr>
<td>U₀</td>
<td>1 [m/s]</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>p₀</td>
<td>p₀</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**MESH GENERATION**

1. From the Mesh menu, open the Free Mesh Parameters dialog box.
2. On the Global page, select Extra fine from the list of Predefined mesh sizes.
3. Click the Point tab.
4. Select Point 5 and enter 5e-4 in the Maximum element size edit field.
5. Click OK.
6. Click the Initialize Mesh button on the Main toolbar.

**COMPUTING THE SOLUTION**

1. Click the Solver Parameters button on the Main toolbar.
2 On the **Stationary** page, enter 50 in the **Maximum number of iterations** edit field to make sure that the model converges directly.

3 Click **OK**.

4 Click the **Solve** button on the Main toolbar to compute the solution.

**POSTPROCESSING AND VISUALIZATION**

The default plot shows the temperature distribution. To create Figure 2-57, follow these steps:

1 Click the **Plot Parameters** button on the Main toolbar.

2 Click the **Arrow** tab.

3 Select the **Arrow plot** check box.

4 From the **Predefined quantities** list, select **Weakly Compressible Navier-Stokes (chns)>Velocity field**.

5 In the **z points** edit field, enter 18.

6 Clear the **Auto** check box for **Scale factor**, and enter 1.2 in the associated edit field.

7 Click the **Color** button. Select white from the palette, then click **OK**.

8 Click **OK**.
To view a cross-sectional plot of the surface irradiation, proceed with the following steps:

1. Open the Domain Plot Parameters dialog box from the Postprocessing menu.
2. Go to the Line/Extrusion page and select General Heat Transfer (htgh) > Radiative flux from the list of Predefined quantities.
3. Select Boundary 6, then click OK to generate the plot in Figure 2-58.
Temperature Distribution in a Disc-Type Transformer

Introduction

This example illustrates a multiphysics application that involves heat transfer and fluid flow. The model simulates the steady-state temperature distribution in an oil-cooled ring-shaped transformer. It is based on published work by J.-M. Mufuta and others (Ref. 1).

Thermal aspects have a great importance in the design of large power transformers. First, sufficient cooling is necessary to avoid overheating. Second, the ageing of electrically insulating materials in transformers is directly proportional to the increase above a certain temperature. In order to design a transformer properly, it is necessary to study both the overall cooling power and the temperature distribution, which reveals where hot spots appear. They are a limiting factor in terms of ageing.

Figure 2-60: Geometry of the transformer coils.

The metallic transformer coils (Figure 2-60) heat up during operation. Transformer oil pumped through the coils perform the necessary cooling. The oil has a viscosity and
density that vary with temperature, so heating affects the fluid-flow pattern. The model in this example simulates the steady-state temperature distribution in the transformer by modeling both the conduction-convection problem and the non-isothermal flow field. The geometry is axisymmetric, and this example models a unit cell consisting of 20 coils divided in two rows.

**Model Definition**

The model uses two stationary application modes to simulate the problem: Weakly Compressible Navier-Stokes and General Heat Transfer.

It simulates the momentum transport and mass conservation with the Weakly Compressible Navier-Stokes equations that describe the fluid velocity, \( \mathbf{u} \), and the pressure field, \( p \). In this case, the density, \( \rho \), and the viscosity, \( \eta \), are temperature dependent:

\[
\rho \mathbf{u} \cdot \nabla \mathbf{u} = \nabla \cdot (-p \mathbf{I} + \eta (\nabla \mathbf{u} + (\nabla \mathbf{u})^T) - (2\eta/3)(\nabla \cdot \mathbf{u}) \mathbf{I}) + \rho \mathbf{g} \\
\nabla \cdot (\rho \mathbf{u}) = 0
\]

Variations in density result in buoyancy forces, expressed as \( \rho \mathbf{g} \), and a continuity equation for the total mass, as expressed in the previous equations.

The General Heat Transfer application mode is based on a general energy balance:

\[
\nabla \cdot (k \nabla T) = Q - \rho C_p \mathbf{u} \cdot \nabla T
\]

Here \( k \) represents thermal conductivity, \( C_p \) is the (temperature-dependent) specific heat capacity, and \( Q \) is the heating power per unit volume. For this model, use the value 32,400 W/m\(^3\) for \( Q \). Furthermore, set the thermal conductivities for the oil and the conductor material to 0.125 W/(m·K) and 383 W/(m·K), respectively.

The temperature-dependent expressions for \( \rho \), \( \eta \), and \( C_p \) used in the model read (this information comes from the producer of the transformer oil, 10GBN: Nynäshamn Petroleum AB, Stockholm, Sweden):

\[
\rho = 875.6 - 0.63 T \text{ kg/m}^3 \\
\eta = \rho 10^{(-4.726 - 0.0091 T)} \text{ m}^2/\text{s} \\
C_p = 1960 + 4.005 T \text{ J/(kg·K)}
\]
In these expressions, $T$ refers to the temperature value in degrees Celsius.

The transformer’s cylindrical geometry allows for 2D axisymmetric modeling of a cross section as in Figure 2-61. The conductor coils are 25 mm wide and 15 mm high in cross section. The rows of coils have a radial separation of 10 mm and a vertical separation of 5 mm. The first row has a distance of 5 mm from the center. The gap between the second row and the outer wall is 10 mm.

![Figure 2-61: Model geometry using cylindrical coordinates.](image)

At the boundary in the center of the cylinder, the model uses the axisymmetry condition for both application modes.

The fluid flow application boundary conditions are as follow. At the bottom boundary (the inlet), the fluid velocity is 5 mm/s in the $z$ direction. At the top boundary (the outlet), the pressure is constant, and the $r$-velocity is zero. On the outer wall and on all coil surfaces, the fluid velocity is zero (no slip).

The boundary conditions for the heat equation application mode are:

- Oil inlet temperature of 50 °C
- Only convective heat flux at the outlet boundaries: $\mathbf{n} \cdot (-k \nabla T) = 0$
- Axisymmetry at the center ($r = 0$)
- Thermal insulation at the outer wall ($r = 0.075$)
- The outer boundaries of the top and bottom conductor are thermally insulated
The solution of the specified equations and boundary conditions gives the temperature and flow field in the transformer.

Results and Discussion

One interesting result from this simulation concerns the temperature of the hot spot. Figure 2-62 depicts the temperature distribution at steady state for both the non-isothermal and an isothermal flow model, neglecting the variation in viscosity and density.

For the non-isothermal model, the maximum temperature (at the hot spot) is 55 °C, occurring at the top inner coil, and note that the isothermal-flow model predicts a somewhat higher temperature. Also, there is no difference between the temperatures of the two columns. You can explain the differences between the models with their different fluid flows, which are affected by the temperature change.

Figure 2-62: Temperature distribution in the transformer cross section.
Figure 2-63 shows the flow field for the two cases. The fluid velocity is higher for the non-isothermal case close to the center in the upper part of the transformer. This effect is caused mainly by the reduced viscosity due to a higher temperature. The buoyancy effects can also contribute to some extent. Furthermore, the flow field is more uniform between the vertical openings. In the isothermal case, the flow field is close to identical in the two outer vertical shafts. In this case, the velocity experiences a decrease in the central shaft due to the smaller shaft area.
In the non-isothermal model it is interesting to see that there exists a radial fluid velocity between the coils.

\[\underline{\text{Non-isothermal}}\]

![Surface: r-velocity (mm/s)](image)

\[\text{Max: } 2.194\]
\[\text{Min: } -2.122\]

\textit{Figure 2-64: The radial component of the flow field in the non-isothermal case.}

Figure 2-64 and Figure 2-65 display the radial velocity in the horizontal openings between the conductors. There is a flux of oil from the outer parts toward the middle of the transformer. The radial-velocity component varies in the transformer. Generally, the fluid flows towards the center of the transformer. The flow is more pronounced in the outer and lower regions.
A general conclusion drawn from this model is that the variation in viscosity and density improve cooling. If you use modeling to optimize the transformer design with respect to hot spots, you should take the non-isothermal flow effects into account to produce more accurate simulation results.

Reference


Model Library path:

Heat_Transfer_Module/Process_and_Manufacturing/power_transformer
Modeling Using the Graphical User Interface

**MODEL NAVIGATOR**
1. In the Model Navigator, go to the *Space dimension* list and select *Axial symmetry (2D)*.
2. In the list of application modes select *Heat Transfer Module* > *Fluid-Thermal Interaction* > *Non-Isothermal Flow*.
3. Click OK.

**GEOMETRY MODELING**
1. Press the Shift key and click the *Rectangle/Square* button on the Draw toolbar.
2. In the dialog box that appears enter these rectangle properties; when done, click OK.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>0.075</td>
</tr>
<tr>
<td>Height</td>
<td>0.18</td>
</tr>
<tr>
<td>Base</td>
<td>Corner</td>
</tr>
<tr>
<td>r</td>
<td>0</td>
</tr>
<tr>
<td>z</td>
<td>0</td>
</tr>
</tbody>
</table>

3. Click the *Zoom Extents* button on the Main toolbar.
4. Similarly add a second rectangle, R2, with these properties:

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>0.025</td>
</tr>
<tr>
<td>Height</td>
<td>0.0075</td>
</tr>
<tr>
<td>Base</td>
<td>Corner</td>
</tr>
<tr>
<td>r</td>
<td>0.005</td>
</tr>
<tr>
<td>z</td>
<td>0</td>
</tr>
</tbody>
</table>

5. With R2 selected, click the *Array* button on the Draw toolbar.
6. In the *Array* dialog box, enter the following settings; when done, click OK.

<table>
<thead>
<tr>
<th>DISPLACEMENT</th>
<th>ARRAY SIZE</th>
</tr>
</thead>
<tbody>
<tr>
<td>r</td>
<td>0.035</td>
</tr>
<tr>
<td>z</td>
<td>0.1725</td>
</tr>
<tr>
<td></td>
<td>2</td>
</tr>
</tbody>
</table>
7 Add a rectangle, R6, with these properties:

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>0.025</td>
</tr>
<tr>
<td>Height</td>
<td>0.015</td>
</tr>
<tr>
<td>Base</td>
<td>Corner</td>
</tr>
<tr>
<td>r</td>
<td>0.005</td>
</tr>
<tr>
<td>z</td>
<td>0.0125</td>
</tr>
</tbody>
</table>

8 With R6 selected, click the Array button on the Draw toolbar.

9 In the Array dialog box, enter the following settings; when done, click OK.

<table>
<thead>
<tr>
<th>DISPLACEMENT</th>
<th>ARRAY SIZE</th>
</tr>
</thead>
<tbody>
<tr>
<td>r</td>
<td>0.035</td>
</tr>
<tr>
<td>z</td>
<td>0.02</td>
</tr>
</tbody>
</table>

8 With R6 selected, click the Array button on the Draw toolbar.

9 In the Array dialog box, enter the following settings; when done, click OK.

The geometry-modeling stage is now complete, with the following result:

OPTIONS AND SETTINGS

1 From the Options menu, select Constants.

2 Define the following names, expressions, and (optionally) descriptions; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>T0</td>
<td>50[degC]</td>
<td>Inlet temperature, fluid</td>
</tr>
<tr>
<td>k_f</td>
<td>0.125[W/(m*K)]</td>
<td>Thermal conductivity, fluid</td>
</tr>
</tbody>
</table>
From the **Options** menu select **Expressions>Scalar Expressions**.

Define the following names and expressions; when done, click **OK**.

Appending the operator \([1/\text{degC}]\) to the variable \(T\) extracts the temperature value in degrees Celsius.

**Subdomain Settings—Weakly Compressible Navier-Stokes**

1. From the **Multiphysics** menu, select **Weakly Compressible Navier-Stokes (chns)**.
2. From the **Physics** menu, open the **Subdomain Settings** dialog box.
3. Choose Subdomains 2–21 (select 2 in the list, hold the Shift key down, then click number 21). From the **Group** list, select **Solid domain**.
4. Select Subdomain 1.
5. On the **Physics** page, set \(\eta\) to \(\text{eta}\) and \(F_z\) to \(-9.81[m^2/s]*\rho\).
6. On the **Density** page, clear the **Pressure p** check box. Click **OK**.

**Subdomain Settings—General Heat Transfer**

1. From the **Multiphysics** menu, select **General Heat Transfer (htgh)**.
2. From the **Physics** menu, select **Subdomain Settings**.
3. Select all subdomains. Click the **Init** tab, then type \(T_0\) in the \(T(t_0)\) edit field.
4. Choose Subdomains 2–21 (select 2 in the list, hold the Shift key down, then click number 21). From the **Group** list, select **Solid domain**.
5. Click the **Conduction** tab.
Enter settings according to the following table (where the table entry is “-” leave the predefined setting):

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN I</th>
<th>SUBDOMAINS 2–21</th>
</tr>
</thead>
<tbody>
<tr>
<td>$k$ (isotropic)</td>
<td>$k_f$</td>
<td>$k_s$</td>
</tr>
<tr>
<td>$\rho$</td>
<td>$\rho$</td>
<td>-</td>
</tr>
<tr>
<td>$C_p$</td>
<td>$C_p$</td>
<td>0</td>
</tr>
<tr>
<td>$Q$</td>
<td>-</td>
<td>$Q_s$</td>
</tr>
</tbody>
</table>

Click OK.

Boundary Conditions—Weakly Compressible Navier-Stokes
1. From the Multiphysics menu, select Weakly Compressible Navier-Stokes (chns).
2. From the Physics menu, open the Boundary Settings dialog box.
3. Select all boundaries by pressing Ctrl+A. In the Boundary type list, select Wall.
4. Adjust the boundary settings according to the following table:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY I</th>
<th>BOUNDARIES 2, 35, 77</th>
<th>BOUNDARIES 3, 45, 87</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary type</td>
<td>Symmetry boundary</td>
<td>Inlet</td>
<td>Outlet</td>
</tr>
<tr>
<td>Boundary condition</td>
<td>Axial symmetry</td>
<td>Velocity</td>
<td>Pressure, no viscous stress</td>
</tr>
<tr>
<td>$v_0$</td>
<td>$v_0$</td>
<td></td>
<td></td>
</tr>
<tr>
<td>$p_0$</td>
<td>-</td>
<td></td>
<td>0</td>
</tr>
</tbody>
</table>

5. Click OK.

Boundary Conditions—General Heat Transfer
1. From the Multiphysics menu, select General Heat Transfer (htgh).
2. From the Physics menu, open the Boundary Settings dialog box.
3. Enter the following boundary conditions; when done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY I</th>
<th>BOUNDARIES 2, 35, 77</th>
<th>BOUNDARIES 3, 45, 87</th>
<th>BOUNDARIES 5, 33, 47, 75, 88</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Thermal insulation</td>
<td>Temperature</td>
<td>Convective flux</td>
<td>Thermal insulation</td>
</tr>
<tr>
<td>$T_0$</td>
<td>$T_0$</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Mesh Generation
1. From the Mesh menu, choose Free Mesh Parameters.
2. From the **Predefined mesh sizes** list, select **Coarser**.

3. Click the **Custom mesh size** button and type **4** in the **Resolution of narrow regions** edit field.

4. Click **OK**.

5. Click the **Initialize Mesh** button on the Main toolbar.

**COMPUTING THE SOLUTION**

For forced convection flows, it is often beneficial to use the stationary segregated solver.

1. Click the **Solver Parameters** button on the Main toolbar.

2. In the **Solver** list, select **Stationary segregated**, then click **OK**.

3. Click the **Solve** button on the Main toolbar.

**POSTPROCESSING AND VISUALIZATION**

To generate Figure 2-62, follow these steps:

1. Click the **Plot Parameters** button on the Main toolbar.

2. Click the **Surface** tab. On the **Surface Data** page, select **General Heat Transfer (htgh)>Temperature** from the **Predefined quantities** list. Click **Apply**.
    
    To generate Figure 2-63 (the velocity field in the fluid), do this:

3. Still on the **Surface Data** page, change the entry in the **Predefined quantities** list to **Weakly Compressible Navier-Stokes (chns)>Velocity field**. Click **Apply**.
    
    To create Figure 2-64, follow this step:

4. On the **Surface Data** page, change the selection in the **Predefined quantities** list to **Weakly Compressible Navier-Stokes (chns)>r-velocity**.
    
    5. Click **OK**.

To produce Figure 2-65 execute the following instructions:

1. From the **Postprocessing** menu open the **Cross-Section Plot Parameters** dialog box.

2. On the **Line/Extrusion** page, go to the **y-axis data** area and from the **Predefined quantities** list, select **Weakly Compressible Navier-Stokes (chns)>r-velocity**. From the **Unit** list, select **mm/s**.

3. In the **x-axis data** area, click first the lower option button and then the **Expression** button.
In the X-Axis Data dialog box, type z in the Expression edit field and cm in the Unit edit field. Click OK to close the dialog box.

Go to the Cross-section line data area. In both the r0 and r1 edit fields, type 0.0175. In the z0 edit field type 0, and in the z1 edit field type 0.18. Click Apply.

On the General page, select the Keep current plot check box.

Return to the Line/Extrusion page, and type 0.0525 in both the r0 and r1 edit fields.

Click the Line Settings button. In the resulting dialog box, go to the Line style list and select Dashed line. Click OK.

Click OK.

To set up and solve the isothermal model, do the following:

From the Options menu, select Expressions>Scalar Expressions. In all the expressions in the table, replace the variable T with T0.

Repeat the steps from the section “Computing the Solution” to solve the new model. Repeat the steps from the section “Postprocessing and Visualization” to generate the result plots.
In this chapter you find models that show heat transfer applications within the processing and manufacturing industries.
Heat Generation in a Disc Brake

Introduction

This example models the heat generation and dissipation in a disc brake of an ordinary car during panic braking and the following release period. As the brakes slow the car, they transform its kinetic energy into thermal energy, resulting in intense heating of the brake discs. If the discs overheat, the brake pads stop working and, in a worst-case scenario, can melt. Braking power starts to fade already at temperatures above 600 K.

In the model, the car (1800 kg) initially travels at 25 m/s (90 km/h) when the driver brakes hard for 2 s, causing the vehicle’s eight brake pads to slow the car down at a rate of 10 m/s². The wheels are assumed not to skid against the road surface. After this period of time, the driver releases the brake and the car travels at 5 m/s for an additional 8 s without any braking. The questions to analyze with the model are:

- How hot do the brake discs and pads become during the braking stage?
- How much do they cool down during the subsequent rest?

Model Definition

This example models the brake disc as a 3D (x, y, z) solid with shape and dimensions as in Figure 3-1. The disc has a radius of 0.14 m and a thickness of 0.013 m.

![Figure 3-1: Geometry and dimensions of the modeled brake disc, including the brake pad.](image)
Neglecting drag and other losses outside the brakes, the brakes’ retardation power is given by the negative of the time derivative of the car’s kinetic energy:

\[ P = -\frac{d}{dt}\left(\frac{mv^2}{2}\right) = -m\frac{dv}{dt} = -mR^2\omega(t)\alpha. \]

Here \( m \) is the car’s mass, \( v \) denotes its speed, \( R \) equals the wheel radius (0.25 m), \( \omega \) is the angular velocity, and \( \alpha \) is the angular acceleration. The acceleration is constant in this case, so \( \omega(t) = \omega_0 + \alpha t \).

By definition, the retardation power equals the negative of the work per unit time done by the friction forces on the discs at the interfaces between the pads and the discs for the eight brakes. You can calculate this work as eight times an integral over the contact surface of a single brake pad. The friction force per unit area, \( f_f \), is approximately constant over the surface and is directed opposite the disc velocity vector, \( \mathbf{v}_d = \mathbf{v}_d \mathbf{e}_\phi \), where \( \mathbf{e}_\phi \) denotes a unit vector in the azimuthal (angular) direction and the magnitude of \( \mathbf{v}_d \) at the distance \( r \) from the center equals \( v_d(r, t) = \omega(t)r \). Thus, writing \( \mathbf{f}_d = f_f \mathbf{e}_\phi \) gives the following result for the retardation power:

\[ P = -8\int\int f_f dA \cdot \mathbf{v}_d = 8f_f(t)\omega(t)\int\int r dA \]

You can approximate the last integral with the pad’s area, \( A \) (0.0035 \( \text{m}^2 \)), multiplied by the distance from the center of the disc to the pad’s center of mass, \( r_m \) (0.1143 m).

Combining the two expressions for \( P \) gives the following result for the magnitude of the friction force, \( f_f \):

\[ f_f = \frac{mR^2\alpha}{8r_m A} \]

(Note that \( \alpha \) is negative during retardation.)

Under the previously stated idealization that retardation is due entirely to friction in the brakes, the heat power generated per unit contact area at time \( t \) and the distance \( r \) from the center becomes

\[ q(r, t) = -f_f \cdot \mathbf{v}_d(r, t) = -\frac{mR^2\alpha}{8r_m A} r(\omega_0 + \alpha t) \]

The disc and pad dissipate the heat produced at the boundary between the brake pad and the disc by convection and radiation. This example models the rotation as convection in the disc. The local velocity vector of the disc is
\[ \mathbf{v}_d = \omega(t)(-y,x) \]

The model also includes heat conduction in the disc and the pad through the transient heat transfer equation

\[ \rho C_p \frac{\partial T}{\partial t} + \nabla \cdot (-k \nabla T) = Q - \rho C_p \mathbf{u} \cdot \nabla T \]

where \( k \) represents the thermal conductivity (W/(m·K)), \( C_p \) is the specific heat capacity (J/(kg·K)), and \( Q \) is the heating power per unit volume (W/m\(^3\)), which in this case is set to zero.

At the boundary between the disc and the pad, the brake produces heat according to the expression for \( q \) given earlier. The heat dissipation from the disc and pad surfaces to the surrounding air is described by both convection and radiation

\[ q_{\text{diss}} = -h(T - T_{\text{ref}}) - \varepsilon \sigma (T^4 - T_{\text{ref}}^4) \]

In this equation, \( h \) equals the convective film coefficient (W/(m\(^2\)·K)), \( \varepsilon \) is the material’s emissivity, and \( \sigma \) is the Stefan-Boltzmann constant (5.67\( \times \)10\(^{-8}\) W/(m\(^2\)·K\(^4\))).

To calculate the convective film coefficient as a function of the vehicle speed, \( v \), use the following formula (Ref. 1):

\[ h = \frac{0.037k}{l} \frac{Re^{0.8} Pr^{0.33}}{0.8 \left( \frac{\rho l v}{\mu} \right)^{0.8} \left( \frac{C_p k}{\mu} \right)^{0.33}} \]

Here \( l \) is the disc’s diameter. The material properties—the thermal conductivity, \( k \), the density, \( \rho \), the viscosity, \( \mu \), and the specific heat capacity, \( C_p \)—are those for air.

Table 3-1 summarizes the thermal properties, which come from (Ref. 1). You calculate the density of air at a reference temperature of 300 K using the ideal gas law.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>DISC</th>
<th>PAD</th>
<th>AIR</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \rho ) (kg/m(^3))</td>
<td>7870</td>
<td>2000</td>
<td>1.170</td>
</tr>
<tr>
<td>( C_p ) (J/(kg·K))</td>
<td>449</td>
<td>935</td>
<td>1100</td>
</tr>
<tr>
<td>( k ) (W/(m·K))</td>
<td>82</td>
<td>8.7</td>
<td>0.026</td>
</tr>
<tr>
<td>( \varepsilon )</td>
<td>0.28</td>
<td>0.8</td>
<td>-</td>
</tr>
<tr>
<td>( \mu ) (Pa·s)</td>
<td>-</td>
<td>-</td>
<td>1.8( \times )10(^{-5})</td>
</tr>
</tbody>
</table>
Results and Discussion

The surface temperatures of the disc and the pad vary with both time and position. At the contact surface between the pad and the disc the temperature increases when the brake is engaged and then decreases again as the brake is released. You can best see these results in COMSOL Multiphysics by generating an animation. Figure 3-2 displays the surface temperatures just before the end of the braking. A “hot spot” is visible at the contact between the brake pad and disc, just at the pad’s edge—this is where the temperature could become critical during braking. The figure also shows the temperature decreasing along the rotational trace after the pad. During the rest, the temperature becomes significantly lower and more uniform in the disc and the pad.

![Figure 3-2: Surface temperature of the brake disc and pad just before releasing the brake (t = 1.8 s).](image)

To investigate the position of the hot spot and the time of the temperature maximum, it is helpful to plot temperature versus time along a line from the center to the pad’s edge as in Figure 3-3. You can see that the maximum temperature is approximately 440 K. The hot spot is positioned close to the radially outer edge of the pad. The highest temperature occurs approximately 1 s after engaging the brake.
CHAPTER 3: PROCESSING AND MANUFACTURING MODELS

Figure 3-3: Temperature profile along the indicated line at the disc surface \( z = 0.013 \text{ m} \) as a function of time.

To investigate how much of the generated heat is dissipated to the air, study the surface integrals of the produced heat and the dissipated heat. These integrals give the total heat flux \( (\text{J/s}) \) for heat production, \( Q_{\text{prod}} \), and heat dissipation, \( Q_{\text{diss}} \), as functions of time for the brake disc. The time integrals of these two quantities give the total heat \( (\text{J}) \) produced and dissipated, respectively, in the brake disc. Figure 3-4 shows a plot of the total produced heat and dissipated heat versus time. You can see that 8 s after disengagement the brake has dissipated only a fraction of the produced heat. The plot indicates that the resting time must be extended significantly in order to dissipate all the generated heat.
The results of this model can help engineers investigate how much abuse, in terms of specific braking sequences, a certain disc-brake design can tolerate before overheating. It is also possible to vary the parameters affecting the heat dissipation and investigate their influence.

Reference


Model Library path:
Heat_Transfer_Module/Process_and_Manufacturing/brake_disc
Modeling Using the Graphical User Interface

MODEL NAVIGATOR
1. Open the Model Navigator. Click the New tab. From the Space dimension list select 3D.
2. From the list of application modes select Heat Transfer Module>General Heat Transfer>Transient analysis. Click OK.

OPTIONS AND SETTINGS
From the Options menu select Constants. Define the following names and expressions; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>rho_disc</td>
<td>7870[kg/m^3]</td>
</tr>
<tr>
<td>rho_pad</td>
<td>2000[kg/m^3]</td>
</tr>
<tr>
<td>C_disc</td>
<td>449[J/(kg*K)]</td>
</tr>
<tr>
<td>C_pad</td>
<td>935[J/(kg*K)]</td>
</tr>
<tr>
<td>k_disc</td>
<td>82[W/(m*K)]</td>
</tr>
<tr>
<td>k_pad</td>
<td>8.7[W/(m*K)]</td>
</tr>
<tr>
<td>e_disc</td>
<td>0.28</td>
</tr>
<tr>
<td>e_pad</td>
<td>0.8</td>
</tr>
<tr>
<td>v0</td>
<td>25[m/s]</td>
</tr>
<tr>
<td>a0</td>
<td>-10[m/s^2]</td>
</tr>
<tr>
<td>r_wheel</td>
<td>0.25[m]</td>
</tr>
<tr>
<td>omega0</td>
<td>v0/r_wheel</td>
</tr>
<tr>
<td>alpha</td>
<td>a0/r_wheel</td>
</tr>
<tr>
<td>m_car</td>
<td>1800[kg]</td>
</tr>
<tr>
<td>A_pad</td>
<td>35e-4[m^2]</td>
</tr>
<tr>
<td>r_mean</td>
<td>0.1143[m]</td>
</tr>
<tr>
<td>f_f</td>
<td>-m_car<em>r_wheel^2</em>alpha/(8<em>r_mean</em>A_pad)</td>
</tr>
<tr>
<td>t_brake</td>
<td>2[s]</td>
</tr>
<tr>
<td>T_air</td>
<td>300[K]</td>
</tr>
<tr>
<td>k_air</td>
<td>0.026[W/(m*K)]</td>
</tr>
<tr>
<td>C_air</td>
<td>1.1[J/(kg*K)]</td>
</tr>
<tr>
<td>mu_air</td>
<td>1.8e-5[Pa*s]</td>
</tr>
<tr>
<td>rho_air</td>
<td>1.013e5[Pa]<em>28.8e-3[kg/mol]/(8.314[J/(K</em>mol)]*T_air)</td>
</tr>
</tbody>
</table>
GEOMETRY MODELING

1. Create two cylinders. To do so, click the **Cylinder** button on the Draw toolbar. Then enter settings from the following table. After creating each cylinder, click **OK**.

<table>
<thead>
<tr>
<th>CYLINDER PARAMETER</th>
<th>CYL1</th>
<th>CYL2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Radius</td>
<td>0.14</td>
<td>0.08</td>
</tr>
<tr>
<td>Height</td>
<td>0.013</td>
<td>0.01</td>
</tr>
<tr>
<td>Axis base point x</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Axis base point y</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Axis base point z</td>
<td>0</td>
<td>0.013</td>
</tr>
</tbody>
</table>

2. Click the **Zoom Extents** button on the Main toolbar.

3. Create a work plane along the disc surface. From the **Draw** menu select **Work-Plane Settings**. On the **Quick** page select the **x-y** option button, and in the **z** edit field for the offset enter 0.013. Click **OK**.

4. From the **Options** menu open the **Axes/Grid Settings** dialog box.

5. On the **Axis** page and the **Grid** page, in turn, clear the **Auto** check box and enter settings from the following table; when finished, click **OK**.

<table>
<thead>
<tr>
<th>AXIS</th>
<th>GRID</th>
</tr>
</thead>
<tbody>
<tr>
<td>x min</td>
<td>x spacing</td>
</tr>
<tr>
<td>x max</td>
<td>y spacing</td>
</tr>
<tr>
<td>y min</td>
<td>y max</td>
</tr>
<tr>
<td></td>
<td>0.15</td>
</tr>
</tbody>
</table>

Next, draw the brake pad profile:

6. On the user interface, click the **Geom2** tab.

7. Click the **3rd Degree Bézier Curve** button on the Draw toolbar.

8. Draw a curve with the control points listed in the following table.

<table>
<thead>
<tr>
<th>CONTROL POINTS</th>
</tr>
</thead>
<tbody>
<tr>
<td>(0, 0.135), (0.02, 0.135), (0.05, 0.13), (0.04, 0.105), (0.03, 0.08), (0.035, 0.09), (0, 0.09), (-0.035, 0.09), (-0.03, 0.08), (-0.04, 0.105), (-0.05, 0.13), (-0.02, 0.135), (0, 0.135)</td>
</tr>
</tbody>
</table>

To find the points with the mouse, look at the coordinate indicator in the bottom left corner of the user interface. Mark each point by clicking the left mouse button. After the last point, click the right mouse button to close the curve and change it to a solid.
To complete the pad, you must make the top left and right corners sharper. Do so by changing the weights of the Bézier curves. From the **Draw** menu open the **Object Properties** dialog box, then change the weights for two of the curves using the information in the following table; when finished, click **OK**.

<table>
<thead>
<tr>
<th>CURVE</th>
<th>POINT</th>
<th>WEIGHT</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>2</td>
<td>2.5</td>
</tr>
<tr>
<td>4</td>
<td>3</td>
<td>2.5</td>
</tr>
</tbody>
</table>

The geometry in the drawing area should now look like that in the figure below.

Make sure the object is selected, then from the Draw menu select **Extrude**. In the **Distance** edit field type 0.0065, then click **OK**.
PHYSICS SETTINGS

1. From the Options menu select Expressions>Scalar Expressions. Specify the following names and expressions; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>v</td>
<td>((v_0 + a_0 \cdot t) \cdot (t &lt;= t_{\text{brake}}) + (v_0 + a_0 \cdot t_{\text{brake}}) \cdot (t &gt; t_{\text{brake}}))</td>
<td>Car speed</td>
</tr>
<tr>
<td>omega</td>
<td>(v/r_{\text{wheel}})</td>
<td>Disc angular velocity</td>
</tr>
<tr>
<td>h_air</td>
<td>(0.037 \cdot k_{\text{air}} / (0.14[m]^2)^2 \cdot (\rho_{\text{air}} \cdot 0.14[m]^2 \cdot v / \mu_{\text{air}})^{0.8} \cdot (C_{\text{air}} \cdot \mu_{\text{air}} / k_{\text{air}})^{0.33})</td>
<td>Convective film coefficient</td>
</tr>
<tr>
<td>q_prod</td>
<td>(f \cdot f_{\text{prod}} \cdot (x^2 + y^2)^{0.5} \cdot (\omega_{\text{prod}} + \alpha \cdot t) \cdot \text{flc2hs}((t_{\text{brake}} - t),[1/s],0.01))</td>
<td>Produced heat power per unit contact area</td>
</tr>
<tr>
<td>q_d_disc</td>
<td>(h_{\text{air}} \cdot (T_{\text{air}} - T) + e_{\text{disc}} \cdot \sigma_{\text{htgh}} \cdot (T_{\text{air}}^4 - T^4))</td>
<td>Dissipated heat power per unit disc area</td>
</tr>
<tr>
<td>q_d_pad</td>
<td>(h_{\text{air}} \cdot (T_{\text{air}} - T) + e_{\text{pad}} \cdot \sigma_{\text{htgh}} \cdot (T_{\text{air}}^4 - T^4))</td>
<td>Dissipated heat power per unit pad area</td>
</tr>
</tbody>
</table>

Here \(\sigma_{\text{htgh}}\) is a predefined scalar variable for the Stefan-Boltzmann constant.

2. Make sure Geom1 is the active window on the user interface.

3. Now set up some variables needed for postprocessing. From the Options menu select Integration Coupling Variables>Boundary Variables. In the Name column enter the two variables Dis_heat and Prod_heat. For certain boundaries, you must make an entry in the Expression column for one of those variables as specified in this table; when done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 11</th>
<th>BOUNDARIES 1, 2, 4-6, 8, 13-15</th>
<th>BOUNDARIES 9, 10, 12, 14, 17</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dis_heat</td>
<td>-q_d_disc</td>
<td>-q_d_pad</td>
<td></td>
</tr>
<tr>
<td>Prod_heat</td>
<td>q_prod</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Subdomain Settings

1. From the Physics menu select Subdomain Settings.

2. Select all the subdomains. Click the Init tab. In the Temperature edit field enter \(T_{\text{air}}\).

3. Go to the Conduction page. Enter the following settings:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAINS 1, 2</th>
<th>SUBDOMAIN 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>k (isotropic)</td>
<td>k_disc</td>
<td>k_pad</td>
</tr>
</tbody>
</table>
4 Select Subdomains 1 and 2. Click the Convection tab. Select the Enable convective heat transfer check box. In the \( u \) edit field for the \( x \)-velocity type \(-y\omega\), and in the \( v \) edit field for the \( y \)-velocity type \( x\omega\).

5 Select Subdomain 1. Click the Artificial Diffusion button, then select the Streamline diffusion check box. Click OK.

6 Click OK to close the Subdomain Settings dialog box.

Boundary Conditions

1 From the Physics menu open the Boundary Settings dialog box. Select the Interior boundaries check box to enable boundary conditions on interior boundaries.

2 Set the boundary conditions by entering the settings from this table; when done, click OK:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAINS 1, 2</th>
<th>SUBDOMAIN 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \rho )</td>
<td>( \rho_{\text{disc}} )</td>
<td>( \rho_{\text{pad}} )</td>
</tr>
<tr>
<td>( C_p )</td>
<td>( C_{\text{disc}} )</td>
<td>( C_{\text{pad}} )</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 3</th>
<th>BOUNDARIES 1, 2, 4–6, 8, 13–15, 18</th>
<th>BOUNDARY 11</th>
<th>BOUNDARY 9, 10, 12, 16, 17</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Thermal insulation</td>
<td>Heat flux</td>
<td>Heat source/sink</td>
<td>Heat flux</td>
</tr>
<tr>
<td>( q_0 )</td>
<td>0</td>
<td>( q_{\text{prod}} )</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>( h )</td>
<td>( h_{\text{air}} )</td>
<td>0</td>
<td>( h_{\text{air}} )</td>
<td></td>
</tr>
<tr>
<td>( T_{\text{inf}} )</td>
<td>( T_{\text{air}} )</td>
<td>0</td>
<td>( T_{\text{air}} )</td>
<td></td>
</tr>
<tr>
<td>Radiation type</td>
<td>None</td>
<td>Surface-to-ambient</td>
<td>None</td>
<td>Surface-to-ambient</td>
</tr>
<tr>
<td>( \varepsilon )</td>
<td>( e_{\text{disc}} )</td>
<td>( e_{\text{pad}} )</td>
<td></td>
<td></td>
</tr>
<tr>
<td>( T_{\text{amb}} )</td>
<td>( T_{\text{air}} )</td>
<td>( T_{\text{air}} )</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Mesh Generation

1 From the Mesh menu open the Free Mesh Parameters dialog box.

2 Click the Boundary tab. Select Boundary 4. In the Maximum element size edit field type \(10\times10\). Similarly, select Boundary 11 and type \(5\times10\).

3 Go to the Advanced page. In the z-direction scale factor edit field type 2. Click Remesh, then click OK.
**Additional Application Mode**

In order to integrate the heat produced and dissipated over time, this model uses a Weak Form, Point application mode.

1. From the **Multiphysics** menu open the **Model Navigator**.
2. In the list of application modes select **COMSOL Multiphysics>PDE Modes>Weak Form, Point>Time-dependent analysis**.
3. Change the dependent variable names. In the **Dependent variables** edit field type `uP uD`. Click **Add**, then click **OK**.
4. From the **Physics** menu open the **Point Settings** dialog box. Deactivate the application mode in all points; to do so, select all the points, then clear the **Active in this domain** check box.
5. Select Point 1, then select the **Active in this domain** check box to activate the Weak Form, Point application mode.
6. For Point 1, make the following entries in the edit fields on the **weak and dweak** pages; when done, click **OK**.

<table>
<thead>
<tr>
<th>EDIT FIELD</th>
<th>POINT 1</th>
<th>POINT 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>weak</td>
<td>uP_test*Prod_heat</td>
<td>uD_test*Dis_heat</td>
</tr>
<tr>
<td>dweak</td>
<td>uP_test*uP_time</td>
<td>uD_test*uD_time</td>
</tr>
</tbody>
</table>

**Computing the Solution**

1. From the **Solve** menu open the **Solver Parameters** dialog box. On the **General** page, go to the **Times** edit field and type `0:0.2:3 4:10`.
2. In the **Linear system solver** list select **Direct (UMFPACK)**, then click **OK**.
3. Click the **Solve** button on the Main toolbar.

**Postprocessing and Visualization**

The default plot shows the temperature at the last time step. Because the problem is time dependent, the natural way to view the solution is as an animation.

1. From the **Postprocessing** menu open the **Plot Parameters** dialog box. In the **General** page go to the **Plot type** area. Clear the **Slice** check box, then select the **Boundary** check box.
2. Go to the **Animate** page, then click the **Start Animation** button. The animation appears in a separate window.

To create Figure 3-2, continue with this step:
1 While still working in the Plot Parameters dialog box, click the General tab.
2 In the Solution at time list select 1.8, then click OK.

To create Figure 3-3, which shows the temperature along a cross section as a function of time, continue with these steps:

1 From the Postprocessing menu select Cross-Section Plot Parameters.
2 Go to the General page and find the Solutions to use area. Select all the solutions from 0 to 2.4 seconds.
3 Click the Line/Extrusion tab, go to the Plot type area, and select the Extrusion plot option button.
4 Go to the x-axis data area. In the list at the top of this area select y.
5 Still on the Line/Extrusion page, go to the Cross-section line data area. Enter settings as in the following table; when finished, click OK.

<table>
<thead>
<tr>
<th>ENTRY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>x1</td>
<td>-0.047</td>
</tr>
<tr>
<td>y1</td>
<td>0.1316</td>
</tr>
<tr>
<td>z0</td>
<td>0.013</td>
</tr>
<tr>
<td>z1</td>
<td>0.013</td>
</tr>
<tr>
<td>Line resolution</td>
<td>50</td>
</tr>
</tbody>
</table>

To create Figure 3-4, continue with these steps:

1 From the Postprocessing menu open the Domain Plot Parameters dialog box, then go to the General page. In the Plot type area click the Point plot option button. Also select the Keep current plot check box at the bottom of the dialog box.
2 Click the Title/Axis button at the bottom of the dialog box. Near the First axis label text, click the option button next to the edit field and in that field type Τιμή [s]. Click the option button for the Second axis label edit field and type $\log(Q_{\text{tot}})[J]$. Click OK.
3 Go to the Point page, then select point 1. In the Expression edit field type $\log10(uP+1)$. Click Apply, and a new figure appears.
4 In the Expression edit field type $\log10(uD+1)$. Click OK to close the Domain Plot Parameters dialog box.
Convection Cooking of Chicken Patties

Introduction

This example models the convection cooking of a chicken patty. The model was originally developed by H. Chen and others (Ref. 1).

To increase consumer convenience, many of today’s food products are precooked so that you can quickly re-heat the product, for example in a microwave oven. One industrial precooking method is air-convection cooking. This example builds a time-dependent model of the convection cooking process for a chicken patty, and it shows the temperature rise over time in the patty.

This simulation also models the moisture concentration in the patty, which is defined as the mass of water per volume of meat. From the viewpoint of product quality, it is of interest to minimize the loss of moisture during cooking. In this regard, cooking yield is a quantity that measures how much moisture, in percent, remains in the patty after the cooking process. Furthermore, the moisture concentration also influences the temperature field by heat loss due to vaporization and also by changing the patty’s thermal conductivity.

![Figure 3-5: Convection cooking of a chicken patty.](image)

Model Definition

This COMSOL Multiphysics example couples two time-dependent application modes describing the temperature and the moisture concentration, respectively. The simulation does not model the convective velocity field outside the patty because the coefficients for convective heat and moisture transfer to the surrounding air are given.

Inside the patty, diffusive processes describe both heat transfer and moisture transport. For the temperature, the heat equation describes the diffusive process as in
\[ \rho C_p \frac{\partial T}{\partial t} + \nabla \cdot (-k \nabla T) = 0 \]

where \( \rho \) is the patty’s density (kg/m\(^3\)), \( C_p \) denotes the specific heat capacity (J/(kg·K)), \( T \) is the temperature (K), and \( k \) is the thermal conductivity (W/(m·K)). This model assumes that the specific heat capacity increases with temperature according to the expression

\[ C_p = 3017.2 + 2.05\Delta T + 0.24(\Delta T)^2 + 0.002(\Delta T)^3 \quad (J/(kg·K)) \]

where \( \Delta T = (T - 0 \, ^\circ C) \) and the dimensions of the numerical coefficients are such that the dimension of \( C_p \) is as stated.

For the moisture concentration, apply the diffusion equation

\[ \frac{\partial c}{\partial t} + \nabla \cdot (-D \nabla c) = 0 \]

where \( c \) is the moisture concentration (kg/m\(^3\)), and \( D \) is the diffusion coefficient (m\(^2\)/s).

Figure 3-6 depicts the patty’s geometry, which is simple and allows for 2D axisymmetric modeling of its cross section. Additional symmetry in the cross section makes it possible to model just one quarter of the cross section.

3D to 2D-axisymmetry

These simplifications result in a simple rectangular domain with the dimension 31 mm \( \times \) 5 mm. Figure 3-7 describes the boundary numbering used when specifying the boundary conditions.
The equations describing moisture diffusion are coupled to the heat equation in the following two ways:

- The thermal conductivity, $k$, increases with moisture concentration according to $k = (0.194 + 0.436(c/\rho)) \text{ W/(m·K)}$, where the concentration, $c$, and the density, $\rho$, must be expressed in the previously stated units.

- The vaporization of water at the patty’s outer boundaries generates a heat flux out of the patty. Represent this heat flux with the term $D_m \lambda \nabla c$ in the boundary conditions for Boundaries 3 and 4, where $D_m$ is the moisture diffusion coefficient ($\text{m}^2/\text{s}$) from the patty to the surrounding air and $\lambda$ is the latent heat of vaporization ($\text{J/kg}$).

Assume symmetry for the temperature field on Boundaries 1 and 2. Air convection adds heat on Boundaries 3 and 4. According to the assumptions made earlier, add a term for the heat flux out of the patty due to moisture vaporization on Boundaries 3 and 4.

Summarizing, the boundary conditions for the general heat transfer application mode are

$$
\mathbf{n} \cdot (-k \nabla T) = 0 \\
\mathbf{n} \cdot (k \nabla T) = h_T (T_{\text{inf}} - T) + \mathbf{n} \cdot (D_m \lambda \nabla c)
$$

where $h_T$ is the heat transfer coefficient ($\text{W/(m}^2\cdot\text{K})$), and $T_{\text{inf}}$ is the oven air temperature.
The boundary conditions for the diffusion application mode are

\[ n \cdot (-D \nabla c) = 0 \quad \text{at } \partial \Omega_1 \text{ and } \partial \Omega_2 \]
\[ n \cdot (D \nabla c) = k_c (c_b - c) \quad \text{at } \partial \Omega_3 \text{ and } \partial \Omega_4 \]

where \( D \) is the moisture diffusion coefficient in the patty \((m^2/s)\), \( k_c \) refers to the mass transfer coefficient \((m/s)\), and \( c_b \) denotes the outside air (bulk) moisture concentration \((kg/m^3)\). The diffusion coefficient and the mass transfer coefficient are given, respectively, by

\[ D = \frac{k_m}{\rho C_m}, \quad k_c = \frac{h_m}{\rho C_m}, \]

where \( C_m \) equals the specific moisture capacity \((kg \text{ moisture/kg meat})\), \( k_m \) refers to the moisture conductivity \((kg/(m \cdot s))\), and \( h_m \) denotes the mass transfer coefficient in mass units \((kg/(m^2 \cdot s))\).

Assume that the patty’s temperature is 22 °C at the start of the cooking process, and the moisture concentration of the air is 22 kg/m³ on a wet basis, which means that the moisture is expressed in mass per volume of meat. Additional data are given in the modeling section below.

To obtain the temperature and moisture concentration over time, the model solves the equations with the boundary conditions discussed above.

**Results and Discussion**

The most interesting result from this simulation is the time required to heat the patty from room temperature \((22 \degree C)\) to at least 70 °C throughout the entire patty. The section at the middle of the patty (at the lower left corner of the modeling domain) takes the longest time to reach this temperature. It is also interesting to determine how much moisture remains in the patty after cooking. For this purpose, compute the cooking yield, defined as \((\text{initial moisture mass})/ (\text{final moisture mass})\).
The model shows that at an oven air temperature of 135 °C, a cooking time of 840 s is required to reach a center temperature of 70 °C. Figure 3-8 shows how the temperature increases over time.

![Figure 3-8: Temperature increase over time in the middle of the patty at an air temperature of 135 °C.](chart.png)
Figure 3-9 illustrates the resulting temperature field after 840 s. The temperature at the lower left corner is 70 °C, and the temperature rises toward the outside boundaries.

Figure 3-9: Temperature field after 840 s at a cooking temperature of 135 °C.

At this oven air temperature, the cooking yield is approximately 0.93 (93%). Figure 3-10 shows the resulting moisture concentration for these conditions. As
expected, note that the convective loss of moisture at the boundaries results in a lower moisture concentration at the outer parts of the patty compared to its inner parts.

Figure 3-10: Moisture concentration after 840 s at a cooking temperature of 135 °C.

Simulations show that an increased air temperature both shortens the time required to reach 70 °C in the middle and increases the cooking yield. The drawback, however, is that the temperature gradients in the chicken patty increase. Figure 3-11 shows the
temperature field obtained after 370 s at a cooking temperature of 218 °C; the corresponding cooking yield is 0.97 (97%).

Figure 3-11: Temperature field after 370 s at a cooking temperature of 218 °C.

Reference

Model Library path:
Heat_Transfer_Module/Process_and_Manufacturing/chicken_patties
Modeling Using the Graphical User Interface

MODEL NAVIGATOR
1 Open the Model Navigator and go to the New page. From the Space dimension list select Axial symmetry (2D).

2 From the list of application modes select

3 Click the Multiphysics button, then click Add.

4 Similarly select the application mode COMSOL Multiphysics>
   Convection and Diffusion>Diffusion>Transient analysis, then click Add.

5 Click OK.

OPTIONS AND SETTINGS
From the Options menu select Constants. Enter the following names, expressions, and (optionally) descriptions; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>T_air</td>
<td>135[degC]</td>
<td>Oven air temperature</td>
</tr>
<tr>
<td>T0</td>
<td>22[degC]</td>
<td>Initial patty temperature</td>
</tr>
<tr>
<td>rho</td>
<td>1100[kg/m^3]</td>
<td>Density of patty</td>
</tr>
<tr>
<td>h_T</td>
<td>25[W/(m^2*K)]</td>
<td>Heat transfer coefficient</td>
</tr>
<tr>
<td>c0</td>
<td>0.78*rho</td>
<td>Initial moisture concentration</td>
</tr>
<tr>
<td>c_b</td>
<td>0.02*rho</td>
<td>Air moisture concentration</td>
</tr>
<tr>
<td>C_m</td>
<td>0.003</td>
<td>Specific moisture capacity</td>
</tr>
<tr>
<td>k_m</td>
<td>1.29e-9[kg/(m*s)]</td>
<td>Moisture conductivity</td>
</tr>
<tr>
<td>h_m</td>
<td>1.67e-6[kg/(m^2*s)]</td>
<td>Mass transfer coefficient in mass units</td>
</tr>
<tr>
<td>D</td>
<td>k_m/(rho*C_m)</td>
<td>Diffusion coefficient</td>
</tr>
<tr>
<td>k_c</td>
<td>h_m/(rho*C_m)</td>
<td>Mass transfer coefficient</td>
</tr>
<tr>
<td>D_m</td>
<td>5e-10[m^2/s]</td>
<td>Surface moisture diffusivity</td>
</tr>
<tr>
<td>lda</td>
<td>2.3e6[J/kg]</td>
<td>Latent heat of vaporization</td>
</tr>
</tbody>
</table>

GEOMETRY MODELING
1 Press the Shift key and click the Rectangle/Square button on the Draw toolbar.
2 In the dialog box that appears, enter the rectangle properties given below; when done, click \textbf{OK}.

<table>
<thead>
<tr>
<th>OBJECT DIMENSIONS</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>31e-3</td>
</tr>
<tr>
<td>Height</td>
<td>5e-3</td>
</tr>
<tr>
<td>Base</td>
<td>Corner</td>
</tr>
<tr>
<td>Position, \textit{r}</td>
<td>0</td>
</tr>
<tr>
<td>Position, \textit{z}</td>
<td>0</td>
</tr>
</tbody>
</table>

3 Click the \textbf{Zoom Extents} button on the Main toolbar.

\textbf{PHYSICS SETTINGS}

From the \textbf{Options} menu select \textbf{Expressions}\textgreater\textbf{Subdomain Expressions}. In the dialog box enter the following details; when done, click \textbf{OK}.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>\textit{k}_T</td>
<td>(0.194 + 0.436\textit{[kg/mol]}/\textit{c}/\textit{rho})\textit{[W/(m*K)]}</td>
</tr>
<tr>
<td>\textit{d}T</td>
<td>(\textit{T} - 0\textit{[degC]})\textit{[1/K]}</td>
</tr>
<tr>
<td>\textit{C}_p</td>
<td>(3017.2 + 2.05\textit{d}T + 0.24\textit{d}T^2 + 0.002\textit{d}T^3)\textit{[J/(kg*K)]}</td>
</tr>
</tbody>
</table>

The unit label “\textit{[kg/mol]}” is inserted in the expression for \textit{k}_T because the dependent variable in the Diffusion application mode, the concentration \textit{c}, has the default unit \textit{mol/m}^3; the above insertion gives \textit{k}_T the correct dimension. In this model, whenever the concentration unit \textit{mol/m}^3 appears in the user interface, read instead \textit{kg/m}^3.

\textit{Boundary Conditions—General Heat Transfer}

1 From the \textbf{Multiphysics} menu select \textbf{1 General Heat Transfer (htgh)}.

2 From the \textbf{Physics} menu select \textbf{Boundary Settings}.
3 Enter the settings from the following table; when done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN 1</th>
<th>SUBDOMAIN 2</th>
<th>SUBDOMAIN 3</th>
<th>SUBDOMAIN 4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Axial symmetry</td>
<td>Thermal insulation</td>
<td>Heat flux</td>
<td>Heat flux</td>
</tr>
<tr>
<td>(q_0)</td>
<td>(D_m \cdot l_d \cdot c_z)</td>
<td>(D_m \cdot l_d \cdot c_r)</td>
<td>(h)</td>
<td>(h_T)</td>
</tr>
<tr>
<td>(T_{\text{inf}})</td>
<td>(T_{\text{air}})</td>
<td>(T_{\text{air}})</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Following standard COMSOL Multiphysics syntax, the variables \(c_z\) and \(c_r\) represent the concentration-gradient components \(\frac{\partial c}{\partial z}\) and \(\frac{\partial c}{\partial r}\), respectively.

**Note:** If the preference Highlight unexpected units is set (on the Modeling page of the Preferences dialog box that you open from the Options menu), the entries in the \(q_0\) edit field for Boundaries 3 and 4 appear in red. This is because, as just mentioned, the software expects concentrations to be given in amount of substance per unit volume (with SI unit mol/m\(^3\)). Because, in this model, the concentration is consistently expressed in mass per unit volume, you can just ignore this warning.

**Subdomain Settings—General Heat Transfer**
1 From the Physics menu select Subdomain Settings.
2 Select Subdomain 1, and note that only conductive heat transfer is enabled by default.
3 Click the Conduction tab, then enter properties for the chicken meat as in the following table:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>(k) (isotropic)</td>
<td>(k_T)</td>
</tr>
<tr>
<td>(\rho)</td>
<td>(\rho)</td>
</tr>
<tr>
<td>(C_p)</td>
<td>(C_p)</td>
</tr>
</tbody>
</table>

4 Click the Init tab. In the Temperature edit field type \(T_0\), then click OK.

**Boundary Conditions—Diffusion**
1 From the Multiphysics menu select 2 Diffusion (di).
2 From the Physics menu open the Boundary Settings dialog box. Enter boundary coefficients as in the following table; when done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 1</th>
<th>BOUNDARY 2</th>
<th>BOUNDARIES 3, 4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Axial symmetry</td>
<td>Insulation/Symmetry</td>
<td>Flux</td>
</tr>
<tr>
<td>$k_c$</td>
<td>$k_c$</td>
<td>$c_b$</td>
<td></td>
</tr>
</tbody>
</table>

Subdomain Settings - Diffusion

1 From the Physics menu open the Subdomain Settings dialog box. In the Subdomain selection list select 1, then go to the D isotropic edit field and type $D$.

2 Go to the Init page, then in the $c(t_0)$ edit field type $c_0$.

3 Click OK.

MESH GENERATION

1 From the Mesh menu select Free Mesh Parameters.

2 Click the Boundary tab. In the Boundary selection list choose 3 and 4. In the Maximum element size edit field type $1 \times 10^{-3}$.

3 Click Remesh, then click OK.

COMPUTING THE SOLUTION

1 From the Solve menu open the Solver Parameters dialog box.

2 On the General page find the Time stepping area. In the Times edit field type $0:10:900$, then click OK.

3 Click the Solve button on the Main toolbar.

POSTPROCESSING AND VISUALIZATION

The default plot shows the temperature in the chicken patty (in kelvin) at $t = 900$ s. To generate Figure 3-9, follow these steps:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, from Solution at time list select 840.

3 Click the Surface tab. On the Surface Data page, select $^\circ C$ from the Unit list.

4 Click Apply.

To generate Figure 3-10, which shows the moisture concentration, proceed as follows:
1 While still on the Surface page, in the Expression edit field type \(c*1\text{[kg/mol]}\), then press Enter.

The entry in the Unit list should now read \(\text{kg/m}^3\), which is the same as \(\text{g/liter}\).

2 Click the General tab, then click the Title button.

3 In the Title dialog box, select the option button next to the edit field, then enter the title Moisture concentration \([\text{g/liter}]\). Click OK.

4 Click OK to generate the plot.

To create Figure 3-8, which shows temperature versus time, follow these instructions:

1 From the Postprocessing menu select Domain Plot Parameters.

2 On the General page, find the Plot type area and select the Point plot option button.

3 Click the Point tab. In the Point selection list select 1 and in the Unit list select \(^{\circ}\text{C}\).

4 Click OK.

The following steps describe how to compute the cooking yield:

1 From the Postprocessing menu open the Subdomain Integration dialog box.

2 Make sure the Compute volume integral check box is selected.

3 Select Subdomain 1, then in the Expression edit field type \(\frac{(c\text{[kg/mol]}/c0)}{1.509\cdot10^{-5}\text{[m}^3]}\). The denominator, \(1.509\cdot10^{-5}\text{ m}^3\), is the value of the volume integral of the modeling geometry.

4 Click OK to obtain the cooking yield; the result (approximately 0.93) appears in the message log at the bottom of the user interface.

To investigate the model further, you can solve the problem for other air temperatures using the same steps for postprocessing.
Cooling Flange

Introduction

In the chemical industry, processes often cool reaction fluids using glass flanges. In most cases the coolant is the surrounding air. An obvious design parameter for this type of device is the cooling power, and the surface temperatures might also be of interest. Heat transfer in this type of device is dominated by convection to and from the surfaces, although the conduction within the glass flange can also influence performance. A convenient method to analyze convection cooling is to use a heat transfer coefficient, $h$. This coefficient describes the influence of the fluid-flow field and the convective fluxes. Thus it is not necessary to model the flow field, which greatly simplifies simulations.

![Operating principle of the cooling flange.](image)

Semi-empirical expressions for computing the heat transfer coefficient for different cases are available in the literature. For this model, the author obtained the heat transfer coefficient for the outer surface by using semi-empirical data available for natural convection around a cylinder. The heat transfer coefficient for the surface that faces the tube is valid for forced convection in a tube. The model uses the General Heat Transfer application mode.
Model Definition

Figure 3-13 presents a drawing of the modeled geometry.

**Figure 3-13: Drawing of the cooling flange.**

The pipe connecting the flange has an inner diameter of 16 mm and a wall thickness of 3 mm. In the flange section, the pipe is 4 mm thick. The flanges are 4 mm thick and 10 mm in height.

During operation, the hot process fluid heats the inside of the tube. The flange conducts the heat and transfers it to the surrounding air. As the air is heated, buoyancy effects cause a convective flow.

The heat transfer within the flange is described by the stationary heat equation

$$\nabla \cdot (-k \nabla T) = 0$$

where $k$ is the thermal conductivity (W/(m·K)), and $T$ is the temperature (K). On the flange’s exterior boundaries, which face the air and process fluid, the applicable boundary condition is

$$-\mathbf{n} \cdot (-k \nabla T) = q_0 + h(T_{\text{int}} - T)$$
where \( \mathbf{n} \) is the normal vector of the boundary, \( h \) is the heat transfer coefficient (W/(m\(^2\)-K)), and \( T_{\text{inf}} \) is the temperature of the surrounding medium (K). For this simulation, set \( T_{\text{inf}} \) to 298 K for the cooling air and to 363 K for the process fluid.

You can approximate the value for the heat transfer coefficient, \( h \), on the process fluid side with a constant value of 15 W/(m\(^2\)-K)) because the fluid’s velocity is close to constant and the model assumes that its temperature decreases only slightly.

The \( h \) expression on the air side is more elaborate. Assume that the free-convection process around the flange is similar to that around a cylinder. The heat transfer coefficient for a cylinder is available in the literature (Ref. 1), and you can use the expression:

\[
h = \frac{k}{L} f(\theta) Gr^{1/4}
\]

where \( k \) is the thermal conductivity of air (0.06 W/(m·K)), \( L \) is the characteristic length that in this case is the outer diameter of the flange (44 mm), and \( f(\theta) \) is an empirical coefficient tabulated in Table 3-2. (Figure 3-14 illustrates the definition of the angle \( \theta \)). Finally, \( Gr \) is the Grashof number defined as

\[
Gr = \frac{\beta g \Delta T L^3}{\mu^2}
\]

where \( \beta \) is the thermal expansion coefficient (1/K), which equals \( 1/T_{\infty} \) for an ideal gas, \( g \) is the gravitational acceleration (9.81 m/s\(^2\)), and \( \mu \) is the kinematic viscosity (18⋅10\(^{-6}\) Pa·s).

<table>
<thead>
<tr>
<th>INCIDENT ANGLE [DEG.]</th>
<th>( f(\theta) )</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0.48</td>
</tr>
<tr>
<td>90</td>
<td>0.46</td>
</tr>
<tr>
<td>100</td>
<td>0.45</td>
</tr>
<tr>
<td>110</td>
<td>0.435</td>
</tr>
<tr>
<td>120</td>
<td>0.42</td>
</tr>
<tr>
<td>130</td>
<td>0.38</td>
</tr>
<tr>
<td>140</td>
<td>0.35</td>
</tr>
<tr>
<td>150</td>
<td>0.28</td>
</tr>
<tr>
<td>160</td>
<td>0.22</td>
</tr>
<tr>
<td>180</td>
<td>0.15</td>
</tr>
</tbody>
</table>
Figure 3-14: Definition of the angle $\theta$.

Table 3-3 summarizes the material properties of the flange material.

<table>
<thead>
<tr>
<th>MATERIAL</th>
<th>$k$ [W/(m·K)]</th>
<th>$\rho$ [kg/m$^3$]</th>
<th>$C_p$ [J/(kg·K)]</th>
</tr>
</thead>
<tbody>
<tr>
<td>Silica glass</td>
<td>1.38</td>
<td>2203</td>
<td>703</td>
</tr>
</tbody>
</table>

Results and Discussion

Figure 3-16 shows the surface temperature of the flange at steady state.

Figure 3-15: Stationary surface temperature of the flange.
The temperature at the flange shoulders is approximately 14 K lower than that at the tube surface. The temperature difference between the process fluid at 363 K and the inner surface of the pipe is approximately 40 K, while that between the outer flange surface and the air stream is approximately 10 K. These values indicate that the heat transfer from the flange outer surfaces is efficient. It also indicates that the heat transfer from the fluid to the flange is a limiting factor. To improve the flange’s performance, it is a good idea to increase the tube diameter.

Figure 3-16 shows the heat transfer coefficient for the flange and pipe walls.

![Boundary: Heat transfer coefficient [W/(m^2·K)]](image)

*Figure 3-16: Heat transfer film coefficient, h, for the flange.*

As you can see, the coefficient decreases significantly along the vertical position of the flange’s outer boundary.

Calculate the flange’s total cooling power by integrating the heat flux on the outer surfaces. The entire flange, that is, taking both symmetry halves into account, has a cooling power of approximately 1.2 W.
Reference


Model Library path:
Heat_Transfer_Module/Process_and_Manufacturing/cooling_flange

Modeling Using the Graphical User Interface

MODEL NAVIGATOR
Open the Model Navigator and go to the New page. In the Space dimension list select 2D, then click OK.

OPTIONS AND SETTINGS
1. From the Options menu select Constants. Define the following names, expressions, and (optionally) descriptions; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>D</td>
<td>44[mm]</td>
<td>Outer flange diameter</td>
</tr>
<tr>
<td>k</td>
<td>0.06[W/(m*K)]</td>
<td>Thermal conductivity</td>
</tr>
<tr>
<td>Tair</td>
<td>298[K]</td>
<td>Cooling air temperature</td>
</tr>
<tr>
<td>Tinner</td>
<td>363[K]</td>
<td>Process fluid temperature</td>
</tr>
<tr>
<td>Hh</td>
<td>15[W/(m^2*K)]</td>
<td>Heat transfer coefficient</td>
</tr>
<tr>
<td>visc</td>
<td>18e-6[m^2/s]</td>
<td>Kinematic viscosity</td>
</tr>
<tr>
<td>beta</td>
<td>1/Tair</td>
<td>Thermal expansion coefficient</td>
</tr>
<tr>
<td>grav</td>
<td>9.81[m/s^2]</td>
<td>Gravitational acceleration</td>
</tr>
</tbody>
</table>

2. From the Options menu select Functions. In the dialog box that appears, click New to open the New Function dialog box.

3. In the Function name edit field, type graph. Click Interpolation and select Table in the Use data from list. Click OK.
4 Select Linear in the Interpolation method list in the Functions dialog box that appears. Enter the following values in the columns for x and f(x); when done, click OK.

<table>
<thead>
<tr>
<th>x</th>
<th>f(x)</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0.48</td>
</tr>
<tr>
<td>90</td>
<td>0.46</td>
</tr>
<tr>
<td>100</td>
<td>0.45</td>
</tr>
<tr>
<td>110</td>
<td>0.435</td>
</tr>
<tr>
<td>120</td>
<td>0.42</td>
</tr>
<tr>
<td>130</td>
<td>0.38</td>
</tr>
<tr>
<td>140</td>
<td>0.35</td>
</tr>
<tr>
<td>150</td>
<td>0.28</td>
</tr>
<tr>
<td>160</td>
<td>0.22</td>
</tr>
<tr>
<td>180</td>
<td>0.15</td>
</tr>
</tbody>
</table>

5 From the Options menu select Axes/Grid Settings.

6 Clear the Axis equal check box, then enter the properties in the following table:

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>x min</td>
<td>-1.4</td>
</tr>
<tr>
<td>x max</td>
<td>2.6</td>
</tr>
<tr>
<td>y min</td>
<td>0.2</td>
</tr>
<tr>
<td>y max</td>
<td>2.8</td>
</tr>
</tbody>
</table>

7 Go to the Grid page. Clear the Auto check box, then enter the properties in the following table; when done, click OK.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>x spacing</td>
<td>0.1</td>
</tr>
<tr>
<td>y spacing</td>
<td>0.1</td>
</tr>
</tbody>
</table>
**GEOMETRY MODELING**

Start by creating this 2D geometry:

Create the rectangle R1 with these steps:

1. Shift-click the **Rectangle/Square** button on the Draw toolbar.
2. In the dialog box that appears, enter the following settings; when done, click **OK**.

<table>
<thead>
<tr>
<th>OBJECT DIMENSIONS</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>0.8</td>
</tr>
<tr>
<td>Height</td>
<td>0.4</td>
</tr>
<tr>
<td>Base</td>
<td>Corner</td>
</tr>
<tr>
<td>x-position</td>
<td>0</td>
</tr>
<tr>
<td>y-position</td>
<td>0.8</td>
</tr>
</tbody>
</table>

Create the composite object CO1 with these steps:

1. Click the **2nd Degree Bézier Curve** button on the Draw toolbar.
2. Click on the coordinates (0, 1.2), (0.2, 1.2), and (0.2, 1.4).
3. Click the **Line** button on the Draw toolbar, then click on the coordinate (0.6, 1.4).
4. Click the **2nd Degree Bézier Curve** on the Draw toolbar.
5. Draw the Bézier curve by clicking on the coordinates (0.6, 1.4), (0.6, 1.2), and (0.8, 1.2).
6. Click the right mouse button to create the geometry object.

Create the composite object CO2 with these steps:

1. Click the **Line** button on the Draw toolbar, then click on the coordinates (0.2, 1.4), (0.2, 2.0), (0.4, 1.9), (0.6, 2.0), and (0.6, 1.4).
2. Click the right mouse button to create the geometry object.
Create the composite object CO4 with these steps:

1. Click the 2nd Degree Bézier Curve button on the Draw toolbar.
2. Click on the coordinates (0.2, 2.0), (0.2, 2.2), (0.4, 2.2), (0.6, 2.2), and (0.6, 2.0).
3. Click the Line button on the Draw toolbar, then click on the coordinates (0.4, 1.9) and (0.2, 2.0). Click the right mouse button.
   This creates a composite geometry object, CO3. To create CO4, you still must add a square and some lines to the object.
4. Shift-click the Rectangle/Square (Centered) button on the Draw toolbar.
5. In the dialog box that appears, enter the following settings; when done, click OK.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>0.1</td>
</tr>
<tr>
<td>α</td>
<td>45</td>
</tr>
<tr>
<td>Base</td>
<td>Center</td>
</tr>
<tr>
<td>x-position</td>
<td>0.4</td>
</tr>
<tr>
<td>y-position</td>
<td>2.05</td>
</tr>
</tbody>
</table>

6. Click the Line button on the Draw toolbar. Click on the left corner of the small rectangle, then click on the coordinate (0.2, 2.1). Click the right mouse button.
7. Click the Line button on the Draw toolbar, click on the right corner of the small rectangle, then click on the coordinate (0.6, 2.1). Click the right mouse button.
8. Click the Line button on the Draw toolbar, click on the upper corner of the small rectangle, then click on the coordinate (0.4, 2.2). Click the right mouse button.
9. Click the Line button on the Draw toolbar, click on the lower corner of the small rectangle, then click on the coordinate (0.4, 1.9). Click the right mouse button.
10. To create the composite object, select CO3, SQ1, B1, B2, B3, and B4, then click the Coerce to Solid button on the Draw toolbar.

Create the other two flanges with these steps:

1. Select R1, CO1, CO2, and CO4, then click the Array button on the Draw toolbar.
2. In the dialog box that appears, enter the following properties; when done, click OK.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Displacement, x</td>
<td>0.8</td>
</tr>
<tr>
<td>Displacement, y</td>
<td>0</td>
</tr>
</tbody>
</table>
1. Click the **Line** button on the Draw toolbar.

2. Click on the lower left corner of rectangle R1, then click, in order, on the coordinates \((-1.2, 0.8), (-1.2, 1.1), \) and \((-0.8, 1.1)\).

3. Click the **3rd Degree Bézier Curve** button on the Draw toolbar.

4. Click, in order, on the coordinates \((-0.4, 1.1), (-0.4, 1.2), \) and \((0, 1.2)\).

5. Click the right mouse button to create the geometry object CO10.

Conclude the geometry modeling by scaling the geometry with these steps:

1. Select all geometry objects by pressing Ctrl+A.

2. Click the **Scale** button on the Draw toolbar.

3. In the dialog box that appears, enter the following scaling properties; when done, click **OK**.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scale factor, x</td>
<td>0.01</td>
</tr>
<tr>
<td>Scale factor, y</td>
<td>0.01</td>
</tr>
<tr>
<td>Scale base point, x</td>
<td>0</td>
</tr>
<tr>
<td>Scale base point, y</td>
<td>0</td>
</tr>
</tbody>
</table>

4. Double-click the **EQUAL** button on the status bar at the bottom of the user interface.

5. Click the **Zoom Extents** button on the Main toolbar.

**Mesh Generation**

1. From the **Mesh** menu select **Mapped Mesh Parameters**.
2 On the Boundary page, select the boundaries marked in the following figure:

3 Select the Constrained edge element distribution check box (keep the default value for the Number of edge elements at 1).

4 Select the boundaries marked in the following figure:

5 Select the Constrained edge element distribution check box, then in the Number of edge elements edit field type 2.
6. Click Remesh, then click OK.
7. From the Mesh menu select Revolve Mesh.
8. In the dialog box that appears, in the $\alpha_2$ edit field type 180.
9. Click the Angle from x-axis button, and in the $\theta$ edit field type 0.
10. Click OK.

**PHYSICS SETTINGS**

1. From the Multiphysics menu select Model Navigator.
2. In the Multiphysics menu on the right side of the dialog box select Geom2 (3D).
3. From the list of application modes on the left side of the dialog box select Heat Transfer Module>General Heat Transfer>Steady-state analysis.
4. Click Add, then click OK.

**Subdomain Settings**

1. From the Physics menu, select Subdomain Settings.
2. Select all subdomains.

   Next, select the material properties from the materials library:
3. Press the Load button. In the dialog box that appears, in the Materials list select Library1>Silica Glass. Click OK.
4. Click the Init tab, then in the Temperature edit field type 323.
5. Click OK.

**Boundary Settings**

1. From the Physics menu select Boundary Settings.
2. Select the boundaries at the geometry’s ends and the symmetry boundaries, as shown in the following figure:

3. In the Boundary condition list select Thermal insulation.
4 Select the boundaries that face the inner channel, as shown in the following figure:

![Diagram]

5 In the **Boundary conditions** list select **Heat flux**, then enter the following properties:

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>h</td>
<td>Hh</td>
</tr>
<tr>
<td>$T_{\text{inf}}$</td>
<td>$T_{\text{inner}}$</td>
</tr>
</tbody>
</table>

6 Select Boundary 3, then select the **Select by group** check box. All boundaries on the outside of the geometry should now be selected, as in the following figure:

![Diagram]

7 In the **Boundary condition** list select **Heat flux**, then enter the following properties:

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>h</td>
<td>Hc</td>
</tr>
<tr>
<td>$T_{\text{inf}}$</td>
<td>$T_{\text{air}}$</td>
</tr>
</tbody>
</table>

8 Click **OK**.

9 From the **Options** menu select **Expressions>Boundary Expressions**. Keep the selection of all outward-facing boundary segments from Step 6.
10. Enter the following expressions; when done, click **OK**.

<table>
<thead>
<tr>
<th>EXPRESSION</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>angle</td>
<td>atan((y/z))*180/(\pi)+90</td>
</tr>
<tr>
<td>Gr</td>
<td>grav*(\beta)<em>((T)-(T_{air}))</em>(D^3/\text{visc}^2)</td>
</tr>
<tr>
<td>Hc</td>
<td>(k*\text{graph}(\text{angle})*\text{Gr}^{0.25}/\text{D})</td>
</tr>
</tbody>
</table>

**COMPUTING THE SOLUTION**

1. Click the **Solver Parameters** button on the Main toolbar.
2. In the **Linear system solver** list select **GMRES**.
3. In the **Preconditioner** list select **Algebraic multigrid**.
4. Click **OK**.
5. Click the **Solve** button on the Main toolbar.

**POSTPROCESSING AND VISUALIZATION**

To reproduce the plot in Figure 3-15, displaying the boundary temperature distribution, follow these instructions:

1. Click the **Plot Parameters** button on the Main toolbar.
2. Clear the **Slice** check box and select the **Boundary** check box, then click **Apply**.
3. Double-click the **GRID** button on the status bar at the bottom of the user interface.

To reproduce the plot in Figure 3-16, continue with these steps:

1. Still in the **Plot Parameters** dialog box, click the **Boundary** tab.
2. In the **Predefined quantities** list select **Heat transfer coefficient**, then click **OK**.

To integrate the heat flux over the outer surface area of the flange, do as follows:

1. From the **Postprocessing** menu open the **Boundary Integration** dialog box.
2. In order to select all outer boundaries, open the **Boundary Settings** dialog box, then select Boundary 3 and select the **Select by group** check box. Click **Cancel** to close the **Boundary Settings** dialog box.
3. Return to the **Boundary Integration** dialog box. From the **Predefined quantities** list select **Normal total heat flux**, then click **OK**.

The integrated value appears in the message log at the bottom of the user interface.
Friction Stir Welding

Introduction

Manufacturers use a modern welding method called friction stir welding to join aluminum plates. This model analyzes the heat transfer in this welding process. The model is based on a paper by M. Song and R. Kovacevic (Ref. 1).

In friction stir welding, a rotating tool moves along the weld joint and melts the aluminum through the generation of friction heat. The tool’s rotation stirs the melted aluminum such that the two plates are joined. Figure 3-17 shows the rotating tool and the aluminum plates being joined.

Figure 3-17: Two aluminum plates being joined by friction stir welding.

The rotating tool is in contact with the aluminum plates along two surfaces: the tool’s shoulder, and the tool’s pin. The tool adds heat to the aluminum plates through both interfaces.

During the welding process, the tool moves along the weld joint. This movement would require a fairly complex model if you wanted to model the tool as a moving heat source. This example takes a different approach that uses a moving coordinate system that is fixed at the tool axis (Ref. 1 also takes this approach). After making the coordinate transformation, the heat transfer problem becomes a stationary convection-conduction problem that is straightforward to model.

The model includes some simplifications. For example, the coordinate transformation assumes that the aluminum plates are infinitely long. This means that the analysis neglects effects near the edges of the plates. Neither does the model account for the stirring process in the aluminum, which is very complex because it includes phase changes and material flow from the front to the back of the rotating tool.
**Model Definition**

The model geometry is symmetric around the weld. It is therefore sufficient to model only one aluminum plate. The plate dimensions are 254 mm × 102 mm × 12.7 mm. Figure 3-18 shows the resulting model geometry:

![Figure 3-18: Model geometry for friction stir welding.](image)

The following equation describes heat transfer in the plate. As a result of fixing the coordinate system in the welding tool, the equation includes a convective term in addition to the conductive term. The equation is

\[ \nabla \cdot (-k \nabla T) = Q - \rho C_p u \cdot \nabla T \]

where \( k \) represents thermal conductivity, \( \rho \) is the density, \( C_p \) denotes specific heat capacity, and \( u \) is the velocity.

The model sets the velocity to \( u = 1.59 \times 10^{-3} \) m/s in the negative \( x \) direction.

The model simulates the heat generated in the interface between the tool’s pin and the workpiece as a surface heat source (expression adapted from Ref. 2):

\[ q_{\text{pin}}(T) = \frac{\mu}{\sqrt{3(1 + \mu^2)}} r_p \omega \bar{Y}(T) \quad (\text{W/m}^2) \]

Here \( \mu \) is the friction coefficient, \( r_p \) denotes the pin radius, \( \omega \) refers to the pin’s angular velocity (rad/s), and \( \bar{Y}(T) \) is the average shear stress of the material. As indicated, the average shear stress is a function of the temperature; for this model, you approximate this function with an interpolation function determined from experimental data given in Ref. 1 (see Figure 3-20).
Additionally, heat is generated at the interface between the tool’s shoulder and the workpiece; the following expression defines the local heat flux per unit area ($W/m^2$) at the distance $r_i$ is from the center axis of the tool:

\[ q_{\text{shoulder}}(r, T) = \begin{cases} \frac{(\mu F_n/A_s)\omega r}{T < T_{\text{melt}}} \\ 0 & T \geq T_{\text{melt}} \end{cases} \]

Here $F_n$ represents the normal force, $A_s$ is the shoulder’s surface area, and $T_{\text{melt}}$ is aluminum’s melting temperature. As before, $\mu$ is the friction coefficient and $\omega$ is the angular velocity of the tool (rad/s).

Above the melting temperature of aluminum, the friction between the tool and the aluminum plate is very low. Therefore, the model sets the heat generation from the shoulder and the pin to zero when the temperature is equal to or higher than the melting temperature.

Due to symmetry, you can set thermal insulation along the weld joint boundary.

The heat flux on the left short end, where the aluminum leaves the computational domain, is dominated by convection. You therefore set the boundary condition to convective flux at that location.

The upper and lower surfaces of the aluminum plates lose heat due to natural convection and surface-to-ambient radiation. The corresponding heat flux expressions for these surfaces are

\[ q_{\text{up}} = h_{\text{up}}(T_0 - T) + \varepsilon \sigma (T_{\text{amb}}^4 - T^4) \]
\[ q_{\text{down}} = h_{\text{down}}(T_0 - T) + \varepsilon \sigma (T_{\text{amb}}^4 - T^4) \]

where $h_{\text{up}}$ and $h_{\text{down}}$ are heat transfer coefficients for natural convection, $T_0$ is an associated reference temperature, $\varepsilon$ is the surface emissivity, $\sigma$ is the Stefan-Boltzmann constant, and $T_{\text{amb}}$ is the ambient air temperature.

You can compute values for the heat transfer coefficients using empirical expressions available in the heat-transfer literature, for example, *Heat Transfer* by A. Bejan (Ref. 3). In this model, use the values $h_{\text{up}} = 12.25 \, W/(m^2 \cdot K)$ and $h_{\text{down}} = 6.25 \, W/(m^2 \cdot K)$
Results and Discussion

Figure 3-19 shows the resulting temperature field. Consider this result as what you would see through a window fixed to the moving welding tool.

![Temperature field in the aluminum plate.](image)

The temperature is highest where the aluminum is in contact with the rotating tool. Behind the tool, the process transports hot material away, while in front of the tool, new cold material enters.

References


Model Library path:
Heat_Transfer_Module/Process_and_Manufacturing/friction_welding

Modeling Using the Graphical User Interface

MODEL NAVIGATOR
1. Open the Model Navigator and click the New tab. In the Space dimension list select 3D.
2. From the list of application modes select Heat Transfer Module>General Heat Transfer>Steady-state analysis.
3. Click OK.

OPTIONS AND SETTINGS

Constants
From the Options menu select Constants. Define the following names, expressions, and (optionally) descriptions; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>T0</td>
<td>300[K]</td>
<td>Reference temperature</td>
</tr>
<tr>
<td>T_melt</td>
<td>933[K]</td>
<td>Workpiece melting temperature</td>
</tr>
<tr>
<td>rho_pin</td>
<td>7800[kg/m^3]</td>
<td>Pin density</td>
</tr>
<tr>
<td>k_pin</td>
<td>42[W/(m*K)]</td>
<td>Thermal conductivity</td>
</tr>
<tr>
<td>Cp_pin</td>
<td>500[J/(kg*K)]</td>
<td>Specific heat capacity</td>
</tr>
<tr>
<td>h_upside</td>
<td>12.25[W/(m^2*K)]</td>
<td>Heat transfer coefficient, upside</td>
</tr>
<tr>
<td>h_downside</td>
<td>6.25[W/(m^2*K)]</td>
<td>Heat transfer coefficient, downside</td>
</tr>
<tr>
<td>epsilon</td>
<td>0.3</td>
<td>Surface emissivity</td>
</tr>
<tr>
<td>u_weld</td>
<td>1.59[mm/s]</td>
<td>Welding speed</td>
</tr>
<tr>
<td>mu</td>
<td>0.4</td>
<td>Friction coefficient</td>
</tr>
<tr>
<td>n</td>
<td>637[1/min]</td>
<td>Rotation speed (RPM)</td>
</tr>
<tr>
<td>omega</td>
<td>2*pi[rad]*n</td>
<td>Angular velocity (rad/s)</td>
</tr>
<tr>
<td>F_n</td>
<td>25[kN]</td>
<td>Normal force</td>
</tr>
<tr>
<td>r_pin</td>
<td>6[mm]</td>
<td>Pin radius</td>
</tr>
<tr>
<td>r_shoulder</td>
<td>25[mm]</td>
<td>Shoulder radius</td>
</tr>
<tr>
<td>A_s</td>
<td>pi*(r_shoulder^2-r_pin^2)</td>
<td>Shoulder surface area</td>
</tr>
</tbody>
</table>
Functions
Next, define an interpolation function for the aluminum yield stress, $\bar{Y}$, as a function of the temperature, $T$, based on experimental material data listed in Ref. 1.

1. From the Options menu open the Functions dialog box.
2. Click New.
3. In the New Function dialog box, type $\bar{Y}(T)$ in the Function name edit field.
4. Select the Interpolation option button, then click OK.
5. Back in the Functions dialog box, leave the default settings for Interpolation method and Extrapolation method. In the $x$ and $f(x)$ columns enter the following data:

<table>
<thead>
<tr>
<th>$x$</th>
<th>311</th>
<th>339</th>
<th>366</th>
<th>394</th>
<th>422</th>
<th>450</th>
<th>477</th>
<th>533</th>
<th>589</th>
<th>644</th>
</tr>
</thead>
<tbody>
<tr>
<td>$f(x)$</td>
<td>241</td>
<td>238</td>
<td>232</td>
<td>223</td>
<td>189</td>
<td>138</td>
<td>92</td>
<td>34</td>
<td>19</td>
<td>12</td>
</tr>
</tbody>
</table>

The $x$ values are temperatures (in kelvin) and the $f$ values corresponding yield stresses (in MPa) for 6061-T6 aluminum.

6. When finished, click Plot to view the resulting interpolation function (Figure 3-20), then click OK to close the Functions dialog box.

![Figure 3-20: Yield stress (MPa) vs. temperature (K) for 6061-T6 aluminum.](image)
GEOMETRY MODELING

1. Create the aluminum plate. From the Draw menu select Block.

2. In the dialog box that appears go to the Length area and enter the settings in the following table; when done, click OK.

<table>
<thead>
<tr>
<th>OBJECT DIMENSIONS</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>254e-3</td>
</tr>
<tr>
<td>Y</td>
<td>102e-3</td>
</tr>
<tr>
<td>Z</td>
<td>12.7e-3</td>
</tr>
</tbody>
</table>

3. Click the Zoom Extents button on the Main toolbar.

4. Go to the Draw menu and select Work-Plane Settings.

5. On the Quick page, select the x-y option button, then in the z edit field enter 12.7e-3. Click OK.

6. Click the Zoom Extents button on the Main toolbar.

7. Press the Shift key and click the Circle/Ellipse (Centered) button on the Draw toolbar.

8. In the dialog box that appears, enter the following circle properties; when done, click OK:

<table>
<thead>
<tr>
<th>OBJECT DIMENSIONS</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Radius</td>
<td>25e-3</td>
</tr>
<tr>
<td>Base</td>
<td>Center</td>
</tr>
<tr>
<td>x-position</td>
<td>81.5e-3</td>
</tr>
<tr>
<td>y-position</td>
<td>0</td>
</tr>
</tbody>
</table>

9. In the same manner, create a second circle with the following properties:

<table>
<thead>
<tr>
<th>OBJECT DIMENSIONS</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Radius</td>
<td>6e-3</td>
</tr>
<tr>
<td>Base</td>
<td>Center</td>
</tr>
<tr>
<td>x-position</td>
<td>81.5e-3</td>
</tr>
<tr>
<td>y-position</td>
<td>0</td>
</tr>
</tbody>
</table>

10. Press the Shift key and click the Rectangle/Square button on the Draw toolbar.
In the dialog box that appears, enter the following rectangle properties; when done, click **OK**:

<table>
<thead>
<tr>
<th>OBJECT DIMENSIONS</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>50e-3</td>
</tr>
<tr>
<td>Height</td>
<td>25e-3</td>
</tr>
<tr>
<td>Base</td>
<td>Corner</td>
</tr>
<tr>
<td>x-position</td>
<td>56.5e-3</td>
</tr>
<tr>
<td>y-position</td>
<td>-25e-3</td>
</tr>
</tbody>
</table>

Create another rectangle with the following properties:

<table>
<thead>
<tr>
<th>OBJECT DIMENSIONS</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>12e-3</td>
</tr>
<tr>
<td>Height</td>
<td>6e-3</td>
</tr>
<tr>
<td>Base</td>
<td>Corner</td>
</tr>
<tr>
<td>x-position</td>
<td>75.5e-3</td>
</tr>
<tr>
<td>y-position</td>
<td>-6e-3</td>
</tr>
</tbody>
</table>

Select the circle C1 and the rectangle R1, then click the **Difference** button on the Draw toolbar.

Similarly, select the circle C2 and the rectangle R2, then click the **Difference** button.

Select the object CO1, then from the Draw menu select **Embed**.

In the dialog that appears, click **OK**.

Return to the Geom2 geometry.

Select the object CO2, then from the Draw menu select **Extrude**.

In the dialog that appears, find the **Distance** edit field and type `-12.7e-3`.

Click **OK**.

Click the **Zoom Extents** button on the Main toolbar.

**Physics Settings**

**Boundary Expressions**

1. Go to the **Options** menu and select **Expressions>Boundary Expressions**.
Select Boundary 6, then enter the following expressions.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>R</td>
<td>sqrt((x-0.0815)^2+y^2)</td>
</tr>
<tr>
<td>q_shoulder</td>
<td>(mu<em>F_n/A_s)</em>(R*omega)*flc1hs((T_melt-T)[1/K],5)</td>
</tr>
</tbody>
</table>

Select Boundaries 7 and 11, then enter the following expressions (on the third line of the table); when finished, click **OK**.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>q_pin</td>
<td>mu/sqrt(3*(1+mu^2))<em>(r_pin</em>omega)*Ybar(T[1/K])[MPa]*flc1hs((T_melt-T)[1/K],5)</td>
</tr>
</tbody>
</table>

**Note:** The boundary expressions defined above include a smoothed step function, \( \text{flc1hs} \), which models that the generation of friction heat is zero above the melting temperature of aluminum. Using this function is computationally more stable than multiplying the expressions by the logical expression \( (T<T_{melt}) \).

**Subdomain Settings**

1. Choose **Physics>Subdomain Settings**.
2. Select Subdomain 1, then click the **Load** button.
3. From the Materials list select **Basic Material Properties>Aluminum**, then click **OK**.
4. Click the **Conduction** tab. Verify that the **Enable conductive heat transfer** check box is selected.
5. Click the **Convection** tab, then select the **Enable convective heat transfer** check box.
6. In the **x-velocity** edit field type \(-u_weld\).
7. Click the **Conduction** tab. Select Subdomain 2. Verify that the **Enable conductive heat transfer** check box is selected, then enter the following settings:

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>( k ) *(isotropic)</td>
<td>( k_{pin} )</td>
</tr>
<tr>
<td>( \rho )</td>
<td>( \rho_{pin} )</td>
</tr>
<tr>
<td>( C_p )</td>
<td>( C_{p,\text{pin}} )</td>
</tr>
</tbody>
</table>

8. Go to the **Convection** page, then select the **Enable convective heat transfer** check box.
9. In the **x-velocity** edit field type \(-u_weld\).
10 Click the Init tab.

11 Select both subdomains, and then type T0 in the T(t0) edit field for the initial value.

12 Click OK.

Boundary Settings

1 Go to the Physics menu and select Boundary Settings.

2 Select the Interior boundaries check box.

3 Enter settings as in the following table; when finished, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 1</th>
<th>BOUNDARY 3</th>
<th>BOUNDARY 4</th>
<th>BOUNDARY 6</th>
<th>BOUNDARIES 7, 11</th>
<th>BOUNDARY 13</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Convective flux</td>
<td>Heat flux</td>
<td>Heat flux</td>
<td>Heat flux</td>
<td>Heat source/sink</td>
<td>Temperature</td>
</tr>
<tr>
<td>q₀</td>
<td>q_0</td>
<td></td>
<td></td>
<td></td>
<td>q_shoulder</td>
<td>q_pin</td>
</tr>
<tr>
<td>h</td>
<td>h_downside</td>
<td>h_upside</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>T_{inf}</td>
<td>T0</td>
<td>T0</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>T₀</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>T0</td>
</tr>
<tr>
<td>Radiation type</td>
<td>Surface-to-ambient</td>
<td>Surface-to-ambient</td>
<td>None</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ε</td>
<td>epsilon</td>
<td>epsilon</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>T_{amb}</td>
<td>T0</td>
<td>T0</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

For the boundaries not mentioned in the table, the default setting (thermal insulation) applies.

MESH GENERATION

From the Mesh menu select Initialize Mesh.

COMPUTING THE SOLUTION

1 From the Solve menu open the Solver Parameters dialog box.

2 Go to the General page. In the Linear system solver list select Direct (UMFFPACK).

3 Click the Stationary tab.

4 Type 60 in the Maximum number of iterations edit field.

5 Click OK.

6 From the Solve menu choose Solve Problem.
POSTPROCESSING AND VISUALIZATION

The default plot shows a slice plot of the temperature field. To create Figure 3-19, which shows a slice plot and some temperature isosurfaces, follow these steps:

1. From the Postprocessing menu open the Plot Parameters dialog box.
2. Go to the Slice page and find the Slice positioning area.
3. In the Number of levels edit field for x levels change the value from 5 to 0.
4. From the Colormap list in the Slice color area, select Hot.
5. In the Vector with coordinates edit field for z levels type 1e-3.
6. Click Apply.
7. Go to the Isosurface page, then select the Isosurface plot check box.
8. In the Vector with isolevels edit field type 300:20:980.
9. From the Colormap list in the Isosurface color area, select Hot.
10. Click OK.
Continuous Casting

Introduction

This example simulates the process of continuous casting of a metal rod from a melted state (Figure 3-21). To optimize the casting process in terms of casting rate and cooling, it is helpful to model the thermal and fluid dynamic aspects of the process. To get accurate results, you must model the melt flow field in combination with the heat transfer and phase change. The model includes the phase transition from melt to solid, both in terms of latent heat and the varying physical properties. The following model was originally developed by J. Fjellstedt (Outokumpu Copper, R&D).

Figure 3-21: Continuous metal-casting process with an exploded view of the modeled section.

The model simplifies the rod’s 3D geometry in Figure 3-21 to an axisymmetric 2D model \((r, z)\). Figure 3-22 shows the dimensions of the 2D geometry.
CHAPTER 3: PROCESSING AND MANUFACTURING MODELS

Figure 3-22: 2D axisymmetric model of the casting process.

As the melt cools down in the mold it solidifies. The phase transition releases latent heat, which the model includes. Furthermore, for metal alloys, the transition is often spread out over a temperature range. As the material solidifies, the material properties change considerably. Finally, the model also includes the “mushy” zone—a mixture of solid and melted material that occurs due to the rather broad transition temperature of the alloy and the solidification kinetics.

This example models the casting process as being stationary using two application modes: General Heat Transfer and Weakly Compressible Navier-Stokes.

Model Definition

The process operates at steady state, because it is a continuous process. The heat transport is described by the equation:

$$\nabla \cdot (-k \nabla T) = Q - (p C_p \mathbf{u} \cdot \nabla T)$$
where $k$, $C_p$, and $Q$ denote thermal conductivity, specific heat, and heating power per unit volume (heat source term), respectively.

As the melt cools down in the mold, it solidifies. During the phase transition, a significant amount of latent heat is released. The total amount of heat released per unit mass of alloy during the transition is given by the change in enthalpy, $\Delta H$. In addition the specific heat capacity, $C_p$, also change considerably during the transition. As opposed to pure metals, an alloy generally undergoes a broad temperature transition zone, over several kelvin, in which a mixture of both solid and molten material co-exist in a “mushy” zone. To account for the latent heat related to the phase transition, replace $C_p$ in the heat equation with $(C_p + \delta \Delta H)$, where $\Delta H$ is the latent heat of the transition, and $\delta$ is a Gaussian curve given by

$$
\delta = \frac{\exp(-(T - T_m)^2/\Delta T^2)}{\Delta T \sqrt{\pi}}
$$

Here $T_m$ is the melting point and $\Delta T$ denotes the half-width of the curve, in this case set to 5 K, representing half the transition temperature span. The change in specific heat is given by:

$$
\Delta C_p = \frac{\Delta H}{T}
$$

The change in specific heat also appears during the phase transition. You represent it using COMSOL Multiphysics’ built-in smooth Heaviside step function $flc2hs$ (for more details on $flc2hs$, see Ref. 1).

This example models the laminar flow using the Weakly Compressible Navier-Stokes application mode. The application mode describes the fluid velocity, $u$, and the pressure, $p$, according to the equations:

$$
\frac{\partial u}{\partial t} + \rho u \cdot \nabla u = \nabla \cdot \left[-p I + \eta \left(\nabla u + (\nabla u)^T\right) - \frac{2\eta}{3 - \kappa}(\nabla \cdot u)I\right] + F
$$

$$
\frac{\partial \rho}{\partial t} + \nabla \cdot (\rho u) = 0
$$

where $\rho$ is the density (in this case constant), $\eta$ is the viscosity, and $\kappa$ is the dilatational viscosity (here assumed to be zero). The source term, $F$, is in this model used to dampen the velocity at the phase-change interface so that it becomes that of the solidified phase after the transition. The source term follows from the equation (see Ref. 2):
where $B$ is the volume fraction of the liquid phase; $A_{\text{mush}}$ and $\varepsilon$ represent arbitrary constants, ($A_{\text{mush}}$ should be large and $\varepsilon$ small to produce a proper damping); and $u_{\text{cast}}$ is the velocity of the cast rod. The fraction of liquid phase, $B$, is given by

$$B = \begin{cases} 
1 & \text{if } T > T_m + \Delta T \\
(T - T_m + \Delta T)/(2\Delta T) & \text{if } (T_m - \Delta T) \leq T \leq (T_m + \Delta T) \\
0 & \text{if } T < T_m - \Delta T 
\end{cases}$$

Table 3-4 reviews the material properties in this model.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>MELT</th>
<th>SOLID</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\rho$ (kg/m$^3$)</td>
<td>8500</td>
<td>8500</td>
</tr>
<tr>
<td>$C_p$ (J/(mol·K))</td>
<td>530</td>
<td>380</td>
</tr>
<tr>
<td>$k$ (W/(m·K))</td>
<td>200</td>
<td>200</td>
</tr>
<tr>
<td>$\eta$ (Ns/m$^2$)</td>
<td>0.0434</td>
<td>-</td>
</tr>
</tbody>
</table>

Furthermore, the melting temperature, $T_m$, and enthalpy, $\Delta H$, are set to 1356 K and 205 kJ/(kg·K), respectively.

The model uses the parametric solver in combination with adaptive meshing to solve the problem efficiently.
Results and Discussion

The plots in Figure 3-23 display the temperature and phase distributions, showing that the melt cools down and solidifies in the mold region. Interestingly, the transition zone stretches out towards the center of the rod because of poorer cooling in that area.

*Figure 3-23: Temperature distribution (top) and fraction of liquid phase (bottom) in the lower part of the cast at a casting rate of 1.6 mm/s.*
With the modeled casting rate, the rod is fully solidified before leaving the mold (the first section after the die). This means that the process engineers can increase the casting rate without running into problems, thus increasing the production rate.

The phase transition occurs in a very narrow zone although the model utilizes a transition half width, $\Delta T$, of 5 K. In reality it would be even more distinct if a pure metal were being cast but somewhat broader if the cast material were an alloy with a wider $\Delta T$.

It is interesting to study in detail the flow field in the melt as it exits the die. Figure 3-24 shows a zoom of this region.

![Figure 3-24: Velocity field with streamlines the lower part of the process.](image)

Notice that there is “disturbance” in the streamlines close to the die wall resulting in a vortex. This eddy flow could create problems with nonuniform surface quality in a real process. Process engineers can thus use the model to avoid these problems and find an optimal die shape.

In order to help determine how to optimize process cooling, Figure 3-25 plots the conductive heat flux. It shows that the conductive heat flux is very large in the mould zone. This is a consequence of the heat released during the phase transition, which is
cooled by the water-cooling jacket of the mould. An interesting phenomenon of the process is the peak of conductive heat flux appearing in the center of the flow at the transition zone.

Furthermore, by plotting the conductive heat flux at the outer boundary for the process as in the lower plot in Figure 3-25, you can see that a majority of the process cooling occurs in the mold. More interestingly, the heat flux varies along the mold wall.

Figure 3-25: The cooling viewed as conductive heat flux in the domains (top), and along the outer boundary (the cooling zones) after the die (bottom).
length. This information can help in optimizing the cooling of the mold (that is, the cooling rate and choice of cooling method).

The model is solved using a built-in adaptive meshing technique. This is necessary because the transition zone, where the phase change occurs, requires a fine discretization. Figure 3-26 depicts the final mesh of the model. Notice that the majority of the elements are concentrated where the phase transition occurs.

![](image)

Figure 3-26: The final computational mesh, resulting from the built-in adaptive technique.

The adaptive mesh technique allows for fast and accurate calculations even if the transition width is brought down to a low value, such as for pure metals.

References

Model Library path:
Heat_Transfer_Module/Process_and_Manufacturing/continuous_casting

Modeling Using the Graphical User Interface

MODEL NAVIGATOR
1. Open the Model Navigator and click on the New tab. In the Space dimension list select Axial symmetry (2D).
2. From the list of application modes select Heat Transfer Module>
3. Click OK.

OPTIONS AND SETTINGS
1. From the Options menu select Constants. Define the following names and expressions; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>T0</td>
<td>300[K]</td>
<td>Ambient temperature</td>
</tr>
<tr>
<td>T_in</td>
<td>1473[K]</td>
<td>Melt inlet temperature</td>
</tr>
<tr>
<td>v_cast</td>
<td>1.6[mm/s]</td>
<td>Casting speed</td>
</tr>
<tr>
<td>T_m</td>
<td>1356[K]</td>
<td>Melting temperature</td>
</tr>
<tr>
<td>dT</td>
<td>20[K]</td>
<td>Temperature transition zone half width</td>
</tr>
<tr>
<td>dH</td>
<td>205[kJ/kg]</td>
<td>Latent heat</td>
</tr>
</tbody>
</table>

2. From the Options menu select Expressions>Scalar Expressions. Define the following expressions; when finished, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>D</td>
<td>exp(-(T-T_m)^2/(dT^2))/sqrt(pi*dT^2)</td>
</tr>
<tr>
<td>B</td>
<td>(T-T_m+dT)/(2<em>dT)</em>(T&lt;==(T_m+dT))*(T&gt;=(T_m-dT))+(T&gt;(T_m+dT))</td>
</tr>
<tr>
<td>Sr</td>
<td>(1-B)^2/(B^3+1e-3)<em>1e5[kg/(m^3</em>s)]*u</td>
</tr>
<tr>
<td>Sz</td>
<td>(1-B)^2/(B^3+1e-3)<em>1e5[kg/(m^3</em>s)]*(v-v_cast)</td>
</tr>
<tr>
<td>H</td>
<td>flc2hs(T-T_m,dT)</td>
</tr>
<tr>
<td>Cp1</td>
<td>380[J/(kg<em>K)]+dH/T_m</em>H</td>
</tr>
</tbody>
</table>
GEOMETRY MODELING

1. Create six rectangles. To do so, go to the Draw menu and select Specify Objects>Rectangle. Each time you open the dialog box, enter the following data for one of the rectangles, then click OK.

<table>
<thead>
<tr>
<th>OBJECT</th>
<th>WIDTH</th>
<th>HEIGHT</th>
<th>BASE</th>
<th>Y</th>
<th>Z</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>0.065</td>
<td>0.1</td>
<td>Corner</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>R2</td>
<td>0.0625</td>
<td>0.025</td>
<td>Corner</td>
<td>0</td>
<td>0.1</td>
</tr>
<tr>
<td>R3</td>
<td>0.11575</td>
<td>0.04</td>
<td>Corner</td>
<td>0</td>
<td>0.165</td>
</tr>
<tr>
<td>R4</td>
<td>0.11575</td>
<td>0.3675</td>
<td>Corner</td>
<td>0</td>
<td>0.205</td>
</tr>
<tr>
<td>R5</td>
<td>0.11575</td>
<td>0.4</td>
<td>Corner</td>
<td>0</td>
<td>0.5725</td>
</tr>
<tr>
<td>R6</td>
<td>0.11575</td>
<td>0.6</td>
<td>Corner</td>
<td>0</td>
<td>0.9725</td>
</tr>
</tbody>
</table>

2. Click the Zoom Window button on the Main toolbar to expand the viewing area between rectangles R2 and R3.

3. Draw two lines that join R2 and R3. To do so, click the Line button on the Draw toolbar, then click the right mouse button to complete each line.

4. Select all objects by pressing Ctrl+A.

5. From the Draw menu select Coerce To>Solid to fill in the trapezoidal area between R2 and R3 and form one large solid.

PHYSICS SETTINGS

Subdomain Settings

1. In the Multiphysics menu select the Weakly Compressible Navier-Stokes application mode.

2. From the Physics menu select Subdomain Settings.

3. Select all subdomains, then enter the following expressions in the edit fields of the Physics tab:

<table>
<thead>
<tr>
<th>PARAMETER</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>η</td>
<td>0.0434</td>
</tr>
<tr>
<td>F_r</td>
<td>-Sr</td>
</tr>
<tr>
<td>F_z</td>
<td>-Sz</td>
</tr>
</tbody>
</table>

The default stabilization method for Navier-Stokes is the GLS streamline diffusion. For diffusive flows with strong source terms are the so-called bubble elements, or mini-elements, a good alternative.
3 Click the Artificial Diffusion button.
4 Clear the Streamline diffusion check box and click OK.
5 Click the Element tab, then from the Predefined elements list, select $P_1+P_1$ (Mini).
6 Click the Init tab, then in the z-velocity edit field type $v_{\text{cast}}$. Click OK.
7 In the Multiphysics menu select the General Heat Transfer application mode.
8 From the Physics menu open the Subdomain Settings dialog box.
9 Select all subdomains.
10 In the Init page, go to the Temperature edit field and type $T_{\text{in}}$.
11 Click the Conduction tab. Enter the following settings; when finished, click OK.

<table>
<thead>
<tr>
<th>PARAMETER</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>$k$ (isotropic)</td>
<td>200</td>
</tr>
<tr>
<td>$\rho$</td>
<td>8500</td>
</tr>
<tr>
<td>$C_p$</td>
<td>$C_{p1}+D*dH$</td>
</tr>
</tbody>
</table>

The predefined multiphysics coupling sets up the convective heat transfer part automatically (click the Convection tab if you want to verify the settings).

12 Click the Element tab, then from the Predefined elements list, select Lagrange–Linear.
13 Click OK.

**Boundary Conditions**
1 From the Physics menu open the Boundary Settings dialog box.
2 Set boundary conditions according to the following table. Note that $h$ is different for boundaries 20 and 21. When done, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 1, 3, 5, 7, 9, 11, 13</th>
<th>BOUNDARY 2</th>
<th>BOUNDARY 15</th>
<th>BOUNDARIES 16–19</th>
<th>BOUNDARY 20</th>
<th>BOUNDARY 21</th>
<th>BOUNDARIES 22, 23</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Axial symmetry</td>
<td>Temperature</td>
<td>Convective flux</td>
<td>Thermal insulation</td>
<td>Heat flux</td>
<td>Heat flux</td>
<td>Heat flux</td>
</tr>
<tr>
<td>$h$</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>$T_{\text{inf}}$</td>
<td></td>
<td>$T_0$</td>
<td>$T_0$</td>
<td>$T_0$</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>$T_0$</td>
<td></td>
<td>$T_{\text{in}}$</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Radiation type</td>
<td>None</td>
<td>None</td>
<td>None</td>
<td>Surface-to-ambient</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>$\varepsilon$</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>$0.8$</td>
</tr>
<tr>
<td>$T_{\text{amb}}$</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>$T_0$</td>
</tr>
</tbody>
</table>
3 In the **Multiphysics** menu select **Weakly Compressible Navier-Stokes**.

4 From the **Physics** menu open the **Boundary Settings** dialog box. Enter the following settings; when finished, click **OK**.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 1, 3, 5, 7, 9, 11, 12</th>
<th>BOUNDARY 2</th>
<th>BOUNDARIES 15, 21–23</th>
<th>BOUNDARIES 16–20</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary type</td>
<td>Symmetry boundary</td>
<td>Inlet</td>
<td>Outlet</td>
<td>Wall</td>
</tr>
<tr>
<td>Boundary condition</td>
<td>Axial symmetry</td>
<td>Pressure, no viscous stress</td>
<td>Velocity</td>
<td>No slip</td>
</tr>
<tr>
<td>$u_0$</td>
<td></td>
<td>0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>$v_0$</td>
<td></td>
<td>$v_{\text{cast}}$</td>
<td></td>
<td></td>
</tr>
<tr>
<td>$p_0$</td>
<td></td>
<td>0</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**MESH GENERATION**

1 From the **Mesh** menu select **Initialize Mesh**.

2 Click the **Refine Mesh** button on the Main toolbar.

**COMPUTING THE SOLUTION**

A three-step solution process calculates the solution. First you solve the problem using the parametric solver on the default mesh, gradually decreasing the value of $dT$. Then you use the adaptive solver to adapt the mesh. Finally, you use the Parametric solver to decrease $dT$ further down to a value of 5.

1 From the **Solve** menu open the **Solver Parameters** dialog box and go to the **General** page. In the **Solver** list select **Parametric**.

2 In the **Parameter name** edit field type $dT$, and in the **Parameter values** edit field type 300 100 50 20.

3 Click the **Stationary** tab, then in the **Maximum number of iterations** type 50.

4 Click **Apply**.

5 Click the **Solve** button on the main toolbar to compute the first solution.

6 In the **Solver Parameters** dialog select the **Stationary** solver from the **Solver** list.

7 Click to select the **Adaptive mesh refinement** check box below the **Solver** list.

8 This enables the **Adaptive** tab. Click that tab, then type 2 in the **Maximum number of refinements** edit field.

9 Click **Apply**.

10 Select **Solve>Restart** to start the adaptive solver based on the last solution.
To view the adapted mesh select the menu item **Mesh>Mesh mode**. You should now have a mesh resembling that in Figure 3-26, based on approximately 4900 elements. You can view the statistics of the mesh by using **Mesh>Mesh Statistics**.

In the **Solver Parameters** dialog select the **Parametric** solver again.

Clear the **Adaptive mesh refinement** check box.

Click the **Manual tuning of parameter step size**.

Enter 5 in the **Initial step size**, 2.5 in the **Maximum step size** and 5 in the **Maximum step size**.

Click the **Stationary** tab. Clear the **Highly nonlinear problem** check box.

Click **OK**.

To calculate the final solution, click the **Restart** button on the Main toolbar.

**POSTPROCESSING AND VISUALIZATION**

To generate the upper plot in Figure 3-23 follow these steps:

1. From the **Option** menu open the **Axes/Grid Settings** dialog box.
2. Change **z max** value to 0.65 and click **OK**.
3. From the **Postprocessing** menu open the **Plot Parameters** dialog box.
4. Go to the **Surface** page, then in the **Predefined quantities** list select **Temperature**.
5. Click the **Arrow** tab. Select the **Arrow plot** check box at the top of the dialog box to enable this type of plot. On the **Subdomain Data** page, select **Velocity field** from the **Predefined quantities** list.
6. Click **Apply**.

To generate the lower plot in Figure 3-23 continue with these steps:

1. Clear the **Arrow plot** check box, then click the **Surface** tab.
2. On the **Surface Data** page, type B in the **Expression** edit field. (This variable represents the fraction of the volume in the liquid phase.)
3. Click **Apply**.

To generate Figure 3-24 execute the following instructions:

1. Click the **Streamline** tab. Select the **Streamline plot** check box.
2. On the **Streamline Data** page, select **Velocity field** from the **Predefined quantities** list. In the **Number of start points** edit field type 33.
3 Click the Surface tab. On the Surface Data page, select Velocity field from the Predefined quantities list.

4 Click Apply.

You reproduce the upper plot in Figure 3-25 as follows:

1 While still on the Surface page, select Conductive heat flux from the Predefined quantities list on the Surface Data page.

2 Go to the General page. In the Plot type area select the Arrow check box and clear the Streamline plot check box.

3 Click the Arrow tab. Select Total heat flux from the Predefined quantities list. Click OK.

Finally, generate the lower plot in Figure 3-25 with the following steps:

1 From the Postprocessing menu select Domain Plot Parameters. Go to the Line/Extrusion page. In the Predefined quantities list select Normal conductive heat flux. In the x-axis data area locate the drop-down list box and select z.

2 Select Boundaries 20–28, then click OK.
Turbulent Flow Through a Shell-and-Tube Heat Exchanger

Introduction

In this model you will study a part of a shell-and-tube heat exchanger (see Figure 3-27), where hot water enters from above. The cooling medium, which is also commonly water, flows through the pipes and enters from the side. The tubes are assumed to be made of stainless steel.

Figure 3-27: A tube bundle from a shell-and-tube heat exchanger. The arrows indicate the flow directions.

Assuming that the cooling water is in abundant supply, the flow through the pipes has a constant temperature. Under that assumption, you can model this heat exchanger by a 2D model as shown in Figure 3-28, and the corresponding 2D domain appears in
The characteristic of a flow is often described by the Reynolds number, which is defined as

$$Re = \frac{\rho UL}{\eta}$$

where $U$ is a velocity scale and $L$ is a length scale. If the Reynolds number is low, no turbulence model is needed. If, on the other hand, the Reynolds number is high, then the flow is dominated by convection, and a turbulence model is necessary.

In this case, a suitable velocity scale is the mean inlet velocity, which is 0.5 m/s, and $L$ is set to the pipe diameter. Then, using standard values for water for the density and viscosity, the equation gives an approximate Reynolds number of 50,000, which is high enough to warrant the use of a turbulence model. See Ref. 4 for more information on flow regimes for different Reynolds numbers.

The following example demonstrates how to model a conjugate heat transfer problem with COMSOL Multiphysics, using the Turbulent Fluid-Thermal Interaction predefined multiphysics coupling from the Heat Transfer Module. It also demonstrates...
how to generate a fully developed flow field when you know the mass flow rate but not the pressure drop.

Figure 3-29: The modeled 2D region. The arrows indicate the flow.

Model Definition

**SOLID AND FLUID HEAT TRANSFER—INCLUDING THE FLUID DYNAMICS**

The governing equations in this model are:

- Reynolds Averaged Navier-Stokes (RANS) equations and a Wilcox revised $k$-$\omega$ turbulence model from 1998 in the water domain.
- Heat transport equations in the water and the solid (steel) tube walls.

The Turbulent Fluid–Thermal Interaction predefined multiphysics coupling sets up the appropriate application modes together with applicable couplings, making it easy to model the fluid-thermal interaction.

Temperature dependent properties for water and steel can be loaded from the built-in material library. It is necessary to correct the fluid’s thermal conductivity to take into account the effect of mixing due to eddies. The turbulence results in an effective thermal conductivity, $k_{\text{eff}}$, according to the equation

$$k_{\text{eff}} = k + k_T$$

where $k$ is the fluid’s physical thermal conductivity and $k_T = C_p \eta_T$ is the turbulent conductivity. $\eta_T$ denotes the turbulent dynamic viscosity, and $C_p$ is the heat capacity.
It is easy to obtain the effective conductivity in COMSOL Multiphysics by using the predefined Fluid group in the fluid domain. In this group, the variable for turbulent conductivity is already given in the heat transfer application mode for the fluid. Be careful not to confuse \( k \) in the meaning of thermal conductivity and \( k \) in the meaning of turbulent kinetic energy.

Figure 3-30 depicts the model with its boundary conditions.

![Figure 3-30: Modeled 2D geometry with boundary conditions.](image)

The boundary conditions describing the problem are:

- \( k-\omega \) equations in the fluid domain
  - Specified mass flow through the domain.
  - Pressure difference between inlet and outlet given by the mass flow
  - Normal flow at the inlet and outlet
  - Stream-wise periodic conditions for \( u, v, k \), and \( \varepsilon \).
  - Symmetry at the region borders
  - Logarithmic wall function at the pipes’ surface boundaries
• Heat transport equations
  - 50 °C temperature at the inlet
  - Convection-dominated transport at the outlet
  - Symmetry (thermal insulation) at the region borders
  - Thermal wall function at the pipe/water interfaces
  - Fixed temperature at the inside of the heat pipes

The periodicity of the flow is important because you are modeling a part of the heat exchanger where the flow is fully developed. It is hard to make a periodic configuration converge from a homogeneous initial guess, however, and therefore, an initial calculation with constant inlet velocity and fixed outlet pressure is first performed.

The logarithmic wall function boundary condition for turbulent flow is used to model the solid-fluid interfaces. An algebraic relationship—the logarithmic wall function—describes the momentum transfer at the solid-fluid interface. This means that the solid-fluid boundaries in the model actually represent lines within the logarithmic regions of the boundary layers. Similar to the fluid velocity, the temperature is not modeled in innermost part of the boundary layer. Instead of assuming continuity of the temperature across the layer, a thermal “wall function” is used. There is a jump in temperature from the solid surface to the fluid due to the omitted innermost part of the boundary layer. The predefined group for the wall domains defines this wall function in the following way.

To achieve the thermal wall function, the model uses two heat transfer application modes: one for the solid, and one for the fluid. These are connected through a heat flux boundary condition, the thermal wall function. This means that the resistance to heat transfer through the innermost part of the boundary layer is related to that for momentum transfer for the fluid. The heat flux, \( q \), is determined by the equation

\[
q = \frac{\rho C_p C_{\mu}^{1/4} k_w^{1/2} (T_w - T)}{T^*}
\]

where \( \rho \) and \( C_p \) are the fluid’s density and heat capacity, respectively; \( C_{\mu} \) is a constant of the turbulence model; and \( k_w \) is the value of the turbulent kinetic energy at the wall. \( T_w \) equals the temperature of the solid at the wall, while \( T \) is the temperature of the fluid on the other side of the omitted laminar sublayer.

The quantity \( T^* \) is related to the dimensionless wall offset and is defined as
\[ T^* = \frac{Pr T}{\kappa} \ln(\delta_w^*) + \beta \]

with the dimensionless wall offset, \( \delta_w^* \), modeled by

\[ \delta_w^* = \frac{\rho \delta_w C^{1/4}_{\mu} k^{1/2}_{w}}{\eta}. \]

The Prandtl number, \( Pr_T \), is fixed to 1.0. Further, \( \kappa \) is the von Karman constant, which is set to 0.41, and \( \beta \) is a model constant set to 3.27.

**Results for the Flow/Heat Model**

Figure 3-31 depicts the temperature distribution and velocity streamlines. As the plot shows, the flow field is periodic in the \( y \) direction. This is important because the heat transfer is strongly influenced by the details of the velocity field. Observe the low-temperature zones behind the pipes created by the recirculation zones there.

![Figure 3-31: Temperature distribution for the periodic boundary case with a specified mean mass flow.](image)

---

236 | **CHAPTER 3: PROCESSING AND MANUFACTURING MODELS**
References


Model Library path: Heat_Transfer_Module/Process_and_Manufacturing/turbulent_heat_exchanger

Modeling Using the Graphical User Interface

The COMSOL Multiphysics implementation is straightforward using the Heat Transfer Module. You build the model in several steps to ensure accurate results.

MODEL NAVIGATOR

1. Open the Model Navigator, and in the Space dimension list select 2D.

2. In the list of application modes select Heat Transfer Module>Fluid-Thermal Interaction>Turbulent Non-Isothermal Flow, k-ω.

3. Click OK.

GEOMETRY MODELING

To save time, load the CAD model as a COMSOL Multiphysics Geometry file:

1. From the File menu select Import>CAD Data From File. A dialog box opens.

2. Select All 2D CAD files from the Files of type list.


4. Click Import to load the model.
You should now see the following geometry:

![Geometry Diagram]

### CONSTANTS, EXPRESSIONS, AND VARIABLES

1. From the **Options** menu open the **Constants** dialog box. Specify the following names, expressions, and descriptions (optional), then click **OK**:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>T_in</td>
<td>323[K]</td>
<td>Inflow temperature</td>
</tr>
<tr>
<td>T_pipe</td>
<td>278[K]</td>
<td>Pipe temperature</td>
</tr>
<tr>
<td>v_in</td>
<td>-0.5[m/s]</td>
<td>Inflow velocity</td>
</tr>
<tr>
<td>rho0</td>
<td>988[kg/m³]</td>
<td>Reference density, water</td>
</tr>
<tr>
<td>L_in</td>
<td>0.025[m]</td>
<td>Width of inflow boundary</td>
</tr>
<tr>
<td>mf_in</td>
<td>L_in<em>rho0</em>v_in</td>
<td>Mass inflow</td>
</tr>
</tbody>
</table>

### PHYSICS AND BOUNDARY SETTINGS

You first make a computation without periodic boundary conditions. This yields a velocity field that can be used as an initial guess for the periodic case.

1. Choose **Physics>Subdomain Settings**. Select Subdomains 1, 3, and 4 (the pipes).
2. Select **Solid domain** from the **Group** list.
3. Select Subdomain 2 (the fluid). Select **Fluid domain** from the **Group** list.
4. Click the **Load** button to open the **Materials/Coefficients Library** dialog box. Go to **Liquids and Gases** and then to **Liquids** and select **Water, liquid**. Click **OK**.
5. Next edit the predefined entry for the dynamic viscosity. To do so, click in the **Dynamic viscosity** edit field and replace T with Tf.
6 The density and its thermodynamic relation also needs to be set up properly. Click the **Density** tab. Click in the **Density** edit field and replace $T$ with $T_f$.

7 Clear the **Density** $\rho$ is a function of: Pressure $p$ check box.

8 Click **OK** to close the **Subdomain Settings** dialog box.

9 Choose **Physics>Boundary Settings**. Then apply the following boundary settings:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 7</th>
<th>BOUNDARIES 2, 8, 11</th>
<th>BOUNDARIES 13, 14, 16, 17</th>
<th>BOUNDARY 6</th>
</tr>
</thead>
<tbody>
<tr>
<td>Object</td>
<td>Inlet</td>
<td>Symmetry boundaries</td>
<td>Pipe surfaces</td>
<td>Outlet</td>
</tr>
<tr>
<td>Boundary type</td>
<td>Inlet</td>
<td>Symmetry boundary</td>
<td>Wall</td>
<td>Outlet</td>
</tr>
<tr>
<td>Boundary condition</td>
<td>Velocity</td>
<td></td>
<td>Logarithmic wall function</td>
<td>Pressure</td>
</tr>
<tr>
<td>$u_0$</td>
<td>0</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>$v_0$</td>
<td>$v_{\text{in}}$</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>$p_0$</td>
<td></td>
<td></td>
<td></td>
<td>0</td>
</tr>
</tbody>
</table>

10 Click **OK**.

Now set up the parameters for the heat transfer.

1 In the **Multiphysics** menu select the first **General Heat Transfer** application mode (**htgh**). Then choose **Physics>Subdomain Settings**.

2 Select Subdomains 1, 3, and 4. Then select **Solid domain** from the **Group** list.

3 Select Subdomain 2. Select **Fluid domain** from the **Group** list.

4 From the **Library material** list select **Water, liquid**.

5 For that material, edit the **Thermal conductivity**, **Density**, and **Heat capacity at constant pressure** expressions by replacing $T$ with $T_f$.

6 Click **OK**.

7 From the **Physics** menu open the **Boundary Settings** dialog box.

8 Specify boundary settings according to the following table. When finished, click **OK**.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARY 7</th>
<th>BOUNDARIES 2, 8, 11</th>
<th>BOUNDARIES 13, 14, 16, 17</th>
<th>BOUNDARY 6</th>
</tr>
</thead>
<tbody>
<tr>
<td>Object</td>
<td>Inlet</td>
<td>Symmetry boundaries</td>
<td>Pipe surfaces</td>
<td>Outlet</td>
</tr>
<tr>
<td>Group</td>
<td></td>
<td></td>
<td></td>
<td>wall</td>
</tr>
</tbody>
</table>
9 In the Multiphysics menu select the second General Heat Transfer application mode (htgh2).

10 Select Physics>Subdomain Settings.

11 Select Subdomain 2, then select Fluid domain from the Group list.

12 For Subdomains 1, 3, and 4, select Solid domain from the Group list.

13 Click the Load button to open the Materials/Coefficients Library dialog box. Go to Basic Material Properties and select Steel AISI 4340. Click OK, then OK again.

14 Open the Physics>Boundary Settings dialog box and specify the following boundary conditions. When finished, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 12, 15, 18, 19</th>
<th>BOUNDARIES 13, 14, 16, 17</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Temperature</td>
<td>Thermal insulation</td>
</tr>
<tr>
<td>T₀</td>
<td>T_in</td>
<td></td>
</tr>
</tbody>
</table>

9 In the Multiphysics menu select the second General Heat Transfer application mode (htgh2).

10 Select Physics>Subdomain Settings.

11 Select Subdomain 2, then select Fluid domain from the Group list.

12 For Subdomains 1, 3, and 4, select Solid domain from the Group list.

13 Click the Load button to open the Materials/Coefficients Library dialog box. Go to Basic Material Properties and select Steel AISI 4340. Click OK, then OK again.

14 Open the Physics>Boundary Settings dialog box and specify the following boundary conditions. When finished, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 12, 15, 18, 19</th>
<th>BOUNDARIES 13, 14, 16, 17</th>
</tr>
</thead>
<tbody>
<tr>
<td>Object</td>
<td>Pipe inner temperature</td>
<td>Pipe surfaces</td>
</tr>
<tr>
<td>Group</td>
<td></td>
<td>wall</td>
</tr>
<tr>
<td>Boundary condition</td>
<td>Temperature</td>
<td></td>
</tr>
<tr>
<td>T₀</td>
<td>T_pipe</td>
<td></td>
</tr>
</tbody>
</table>

MESH GENERATION

1 Click the Initialize Mesh button on the Main toolbar.

2 Click the Refine Mesh button on the Main toolbar once to generate the final mesh.

COMPUTING THE SOLUTION

The solution procedure involves a first solution step that solves a given inlet velocity. This yields a good initial condition for the final calculation with periodic boundary conditions.

1 Choose Solve>Solver Manager.

2 On the Initial Value page, click the Store Solution button.

3 Click the Current solution option button in the Initial value area.

4 Click OK.

POSTPROCESSING AND VISUALIZATION

1 To generate Figure 3-32 open the Postprocessing>Plot Parameters dialog box.
2. On the General page clear the Surface check box, then select the Contour check box.

3. On the Contour page select Velocity field in the Predefined quantities list and click OK.

![Velocity contours for a uniform inflow velocity.](image)

Figure 3-32: Velocity contours for a uniform inflow velocity.

In Figure 3-32 it is clear that the velocity profile on the outflow boundary is not uniform; instead, it varies considerably. Because the heat exchanger system is periodic in its structure, the velocity field should be periodic. The next step is therefore to add periodic boundary condition for the $y$-velocity, $v$, $k$, and $\omega$. The mass flux is controlled by an integral constraint implemented in the Global Equations dialog box.

1. Open the Physics>Periodic Conditions>Periodic Boundary Conditions dialog box, then select Boundary 7. Select the first row in the Expression column and type $v$. Type $\log k$ on the second row in the same column and $\log \omega$ on the third row.


3. Type $\log \omega$ in the Expression edit field and select the Use selected boundaries as destination check box.

The following two steps, Steps 4 and 5, specify the relative orientation of the fields on the source and destination boundaries.
4 On the Source Vertices page add Vertices 10 and 16 to the Source vertices list in this order by selecting them in the Vertex selection list and then clicking the >> button.

5 On the Destination Vertices page add Vertices 9 and 11 to the Destination vertices list. This identifies Vertex 10 with Vertex 9, and Vertex 16 with Vertex 11.

6 On the Destination page select pconstr2 from the Constraint name list.

7 Type logk in the Expression edit field and select the Use selected boundaries as destination check box.

8 Repeat Steps 4 and 5.

9 On the Destination page select pconstr1 from the Constraint name list.

10 Type v in the Expression edit field and select the Use selected boundaries as destination check box.

11 Repeat Steps 4 and 5.

12 Click OK.

The next step is to add an integration coupling variable that evaluates the total mass flux through the inlet. It is later used in an ODE to calculate an inlet pressure.

1 In the Options menu select Integration Coupling Variables>Boundary Variables, and choose Boundary 7.

2 Select the first row in the list. Type mf in the Name edit field and rho_chns*v in the Equation f(u,ut,utt,t) edit field. Click OK.

The next step is to add an ordinary differential equation that constrains the mass flux. The ODE variable controls the inflow pressure level and yields the desired mass flow, mf_in. Also, a point pressure constraint must be added to keep the absolute pressure level fixed.

Open the Physics>Global Equations dialog box. On the States page select the first row. Type p_in in the Name (u) column, then enter mf-mf_in in the Expression column. Click OK to close the dialog box.

3 Go to the Multiphysics menu and select the k-ω Turbulence Model (chns) application mode.

4 Select Physics>Boundary Settings and choose the inlet boundary (Boundary 7). Change the Boundary type from Inlet to Stress. Set Boundary condition to Normal stress and set f0 to p_in. Click OK.

Computing the Solution

1 Click the Solver Parameters button on the Main toolbar.
2. Add \( p_{\text{in}} \) as a Component of Group 1.

3. Click OK.

4. Click the Solve button on the Main toolbar.

**Figure 3-33: Velocity contours for periodic velocity conditions.**

From Figure 3-33 it is now evident that the inflow and outflow velocity profiles match. In addition, the velocity is higher close to the pipe at the inflow region. This is clearly important when it comes to heat transfer, and it is a considerable improvement when compared to the uniform inflow profile.

**POSTPROCESSING**

1. To generate Figure 3-31 open the Postprocessing>Plot Parameters dialog box.

2. On the General page clear the Contour check box and select the Surface and Streamline check boxes.


4. On the Streamline page choose \( k-\omega \) Turbulence model (chns)>Velocity field in the Predefined quantities list. Set the Streamline plot type to Magnitude controlled.
5 Click the **Line Color** tab, then click the **Uniform color** option button. Click the **Color** button and select black, then click **OK**.

6 Click the **Advanced** button. Select the **Normalize vector field** check box, then click **OK** to close the **Advanced Streamline Parameters** dialog box.

7 Click **OK** to close the **Plot Parameters** dialog box and generate the plot.
Medical Technology Models
Tumor Removal

Introduction

One method for removing cancerous tumors from healthy tissue is to heat the malignant tissue to a critical temperature that kills the cancer cells. This example accomplishes the localized heating by inserting a four-armed electric probe through which an electric current runs. Equations for the electric field for this case appear in the Conductive Media DC application mode, and this example couples them into the bioheat equation, which models the temperature field in the tissue. The heat source resulting from the electric field is also known as resistive heating or Joule heating. The original model comes from S. Tungjitkusolmun and others (Ref. 1), but we have made some simplifications. For instance, while the original uses RF heating (with AC currents), the COMSOL Multiphysics model approximates the energy with DC currents.

This medical procedure removes the tumorous tissue by heating it above 45 °C to 50 °C. Doing so requires a local heat source, which physicians create by inserting a small electric probe. The probe is made of a trocar (the main rod) and four electrode arms as shown in Figure 4-1. The trocar is electrically insulated except near the electrode arms.

An electric current through the probe creates an electric field in the tissue. The field is strongest in the immediate vicinity of the probe and generates resistive heating, which dominates around the probe’s electrode arms because of the strong electric field.

Figure 4-1: Cylindrical modeling domain with the four-armed electric probe in the middle, which is located next to a large blood vessel.
Model Definition

This model uses the Bioheat Equation and the Conductive Media DC application modes to implement a transient analysis.

The standard temperature unit in COMSOL Multiphysics is kelvin (K). This model uses the Celsius temperature scale, which is more convenient for models involving the Bioheat Equation.

The model approximates the body tissue with a large cylinder and assumes that its boundary temperature remains at 37 °C during the entire procedure. The tumor is located near the center of the cylinder and has the same thermal properties as the surrounding tissue. The model locates the probe along the cylinder’s center line such that its electrodes span the region where the tumor is located. The geometry also includes a large blood vessel.

The bioheat equation governs heat transfer in the tissue

\[ \delta_{ts} \rho C_t \frac{\partial T}{\partial t} + \nabla \cdot (-k \nabla T) = \rho_b C_b \omega_b (T_b - T) + Q_{\text{met}} + Q_{\text{ext}} \]

where \( \delta_{ts} \) is a time-scaling coefficient; \( \rho \) is the tissue density (kg/m\(^3\)); \( C \) is the tissue’s specific heat (J/(kg·K)); and \( k \) is its thermal conductivity (W/(m·K)). On the right side of the equality, \( \rho_b \) gives the blood’s density (kg/m\(^3\)); \( C_b \) is the blood’s specific heat (J/(kg·K)); \( \omega_b \) is its perfusion rate (1/s); \( T_b \) is the arterial blood temperature (°C); while \( Q_{\text{met}} \) and \( Q_{\text{ext}} \) are the heat sources from metabolism and spatial heating, respectively (W/m\(^3\)).

In this model, the bioheat equation also models heat transfer in various parts of the probe with the appropriate values for the specific heat, \( C \) (J/(kg·K)), and thermal conductivity, \( k \) (W/(m·K)). For these parts, all terms on the right-hand side are zero.

The model next sets the boundary conditions at the outer boundaries of the cylinder and at the walls of the blood vessel to a temperature of 37 °C. Assume heat flux continuity on all other boundaries.

The initial temperature equals 37 °C in all domains.

The governing equation for the Conductive Media DC application mode is

\[ -\nabla \cdot (\sigma V V - J^e) = Q_j \]

where \( V \) is the potential (V), \( \sigma \) the electric conductivity (S/m), \( J^e \) an externally generated current density (A/m\(^2\)), \( Q_j \) the current source (A/m\(^3\)).
In this model both $J^e$ and $Q_j$ are zero. The governing equation therefore simplifies into:

$$-\nabla \cdot (\sigma \nabla V) = 0.$$  

The boundary conditions at the cylinder’s outer boundaries is ground (0 V potential). At the electrode boundaries the potential equals 23 V. Assume continuity for all other boundaries.

The boundary conditions for the Conductive Media DC application mode are:

$$V = 0 \quad \text{on the cylinder wall}$$
$$V = V_0 \quad \text{on the electrode surfaces}$$
$$\mathbf{n} \cdot (J_1 - J_2) = 0 \quad \text{on all other boundaries}$$

The boundary conditions for the bioheat equation are:

$$T = T_b \quad \text{on the cylinder wall and blood-vessel wall}$$
$$\mathbf{n} \cdot (k_1 \nabla T_1 - k_2 \nabla T_2) = 0 \quad \text{on all interior boundaries}$$

The model solves the above equations with the given boundary conditions to obtain the temperature field as a function of time.

**Results and Discussion**

The model shows how the temperature increases with time in the tissue around the electrode.
The slice plot in Figure 4-2 illustrates the temperature field 60 seconds after starting the procedure.

Figure 4-2: Temperature field at time = 60 seconds.

Figure 4-3 shows the temperature at the tip of one of the electrode arms. The temperature rises quickly until it reaches a steady-state temperature of about 90 °C.

Figure 4-3: Temperature versus time at the tip of one of the electrode arms.
It is also interesting to visualize the region where cancer cells die, that is, where the temperature has reached at least 50 °C. You can visualize this area with an isosurface for that temperature; Figure 4-4 shows one after 8 minutes.

Figure 4-4: Visualization of the region that has reached 50°C after 8 minutes.

Reference


Model Library path:
Heat_Transfer_Module/Medical_Technology/tumor_ablation

Modeling Using the Graphical User Interface

**MODEL NAVIGATOR**

1. Open the **Model Navigator**. On the **New** page, select **3D** in the **Space dimension** list.
2. Go to the **Heat Transfer Module** menu and select **Bioheat Equation>Transient analysis**.
3 Click the **Multiphysics** button and add the application mode to the model by clicking the **Add** button.

4 Similarly add the **Conductive Media DC** application mode, from the **COMSOL Multiphysics>Electromagnetics** menu.

5 Click **OK**.

**OPTIONS AND SETTINGS**

1 Define the following constants in **Constants** under the **Options** menu:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>rho_e</td>
<td>6450[kg/m^3]</td>
<td>Density</td>
</tr>
<tr>
<td>rho_t</td>
<td>21500[kg/m^3]</td>
<td></td>
</tr>
<tr>
<td>rho_l</td>
<td>1060[kg/m^3]</td>
<td></td>
</tr>
<tr>
<td>rho_b</td>
<td>1000[kg/m^3]</td>
<td>Density, blood</td>
</tr>
<tr>
<td>rho_c</td>
<td>70[kg/m^3]</td>
<td></td>
</tr>
<tr>
<td>c_e</td>
<td>840[J/(kg*K)]</td>
<td></td>
</tr>
<tr>
<td>c_t</td>
<td>132[J/(kg*K)]</td>
<td>Heat capacity, tumor</td>
</tr>
<tr>
<td>c_l</td>
<td>3600[J/(kg*K)]</td>
<td></td>
</tr>
<tr>
<td>c_b</td>
<td>4180[J/(kg*K)]</td>
<td>Heat capacity, blood</td>
</tr>
<tr>
<td>c_c</td>
<td>1045[J/(kg*K)]</td>
<td></td>
</tr>
<tr>
<td>k_e</td>
<td>18[W/(m*K)]</td>
<td></td>
</tr>
<tr>
<td>k_t</td>
<td>71[W/(m*K)]</td>
<td>Thermal conductivity, tumor</td>
</tr>
<tr>
<td>k_l</td>
<td>0.512[W/(m*K)]</td>
<td></td>
</tr>
<tr>
<td>k_b</td>
<td>0.543[W/(m*K)]</td>
<td>Thermal conductivity, blood</td>
</tr>
<tr>
<td>k_c</td>
<td>0.026[W/(m*K)]</td>
<td></td>
</tr>
<tr>
<td>sigma_e</td>
<td>1e8[S/m]</td>
<td></td>
</tr>
<tr>
<td>sigma_t</td>
<td>4e6[S/m]</td>
<td>Electric conductivity, tumor</td>
</tr>
<tr>
<td>sigma_l</td>
<td>0.333[S/m]</td>
<td></td>
</tr>
<tr>
<td>sigma_b</td>
<td>0.667[S/m]</td>
<td>Electric conductivity, blood</td>
</tr>
<tr>
<td>sigma_c</td>
<td>1e-5[S/m]</td>
<td></td>
</tr>
<tr>
<td>T_b</td>
<td>37[degC]</td>
<td>Arterial blood temperature</td>
</tr>
<tr>
<td>omega_b</td>
<td>6.4e-3[1/s]</td>
<td>Blood perfusion rate</td>
</tr>
<tr>
<td>T0</td>
<td>37[degC]</td>
<td>Initial temperature</td>
</tr>
<tr>
<td>V0</td>
<td>22[V]</td>
<td></td>
</tr>
</tbody>
</table>

2 Click **OK**.
GEOMETRY MODELING

1. Go to the **Draw** menu and select **Work-Plane Settings**.
2. Create an **x-y plane** at the **z** coordinate **0.06**.
3. Click **OK**.
4. Press the Shift key and click the **Ellipse/Circle (Centered)** button.
5. In the dialog box that appears, enter the following circle properties:

<table>
<thead>
<tr>
<th>OBJECT DIMENSIONS</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Radius</td>
<td>9.144e-4</td>
</tr>
<tr>
<td>Base</td>
<td>Center</td>
</tr>
<tr>
<td>x</td>
<td>0</td>
</tr>
<tr>
<td>y</td>
<td>0</td>
</tr>
</tbody>
</table>

6. Click **OK**.
7. Click the **Zoom Extents** button on the Main toolbar.
8. Repeat Steps 4–6 to create five additional circles, for smaller ones and a large one.

The properties of each circle appear in the following five tables:

<table>
<thead>
<tr>
<th>OBJECT DIMENSIONS</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Radius</td>
<td>2.667e-4</td>
</tr>
<tr>
<td>Base</td>
<td>Center</td>
</tr>
<tr>
<td>x</td>
<td>-5e-4</td>
</tr>
<tr>
<td>y</td>
<td>0</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>OBJECT DIMENSIONS</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Radius</td>
<td>2.667e-4</td>
</tr>
<tr>
<td>Base</td>
<td>Center</td>
</tr>
<tr>
<td>x</td>
<td>5e-4</td>
</tr>
<tr>
<td>y</td>
<td>0</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>OBJECT DIMENSIONS</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Radius</td>
<td>2.667e-4</td>
</tr>
<tr>
<td>Base</td>
<td>Center</td>
</tr>
<tr>
<td>x</td>
<td>0</td>
</tr>
<tr>
<td>y</td>
<td>-5e-4</td>
</tr>
</tbody>
</table>
Click the Zoom Extents button on the Main toolbar.

This completes the geometry needed in the 2D work plane, and the result appears in Figure 4-5.

The following steps describe how to create the 3D geometry by extruding and revolving the 2D geometry:

1. To create the conducting part of the trocar, go to the Draw menu and select Extrude.
2. In the dialog box that appears, select C1 in the Objects to extrude list and type 10e-3 in the Distance edit field.
3. Click OK.
4 To create the insulated part of the trocar, return to the Geom2 work plane, then go to the **Draw** menu and select **Extrude**.

5 Select **C1** in the **Objects to extrude** list and type **50e-3** in the **Distance** edit field.

6 Click **OK**.

7 Select the EXT2 geometry object.

8 Click the **Move** button on the Draw toolbar.

9 Enter the following displacement values; when finished, click **OK**.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>x</td>
<td>0</td>
</tr>
<tr>
<td>y</td>
<td>0</td>
</tr>
<tr>
<td>z</td>
<td>10e-3</td>
</tr>
</tbody>
</table>

To create the electrode arms, proceed as follows:

10 Return to the Geom2 work plane.

11 From the **Draw** menu select **Revolve**.

12 From the **Objects to revolve** list select **C2**.

13 Enter the following values in the dialog box; when finished, click **OK**.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>α1</td>
<td>0</td>
</tr>
<tr>
<td>α2</td>
<td>180</td>
</tr>
<tr>
<td>x (point on axis)</td>
<td>-8e-3</td>
</tr>
<tr>
<td>y (point on axis)</td>
<td>0</td>
</tr>
<tr>
<td>x (second point)</td>
<td>-8e-3</td>
</tr>
<tr>
<td>y (second point)</td>
<td>1</td>
</tr>
</tbody>
</table>
Revolve the circles C3, C4, and C5 in the same manner using the following values.

Revolve parameters for the circle C3:

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\alpha_1$</td>
<td>0</td>
</tr>
<tr>
<td>$\alpha_2$</td>
<td>-180</td>
</tr>
<tr>
<td>x (point on axis)</td>
<td>$8e^{-3}$</td>
</tr>
<tr>
<td>y (point on axis)</td>
<td>0</td>
</tr>
<tr>
<td>x (second point)</td>
<td>$8e^{-3}$</td>
</tr>
<tr>
<td>y (second point)</td>
<td>1</td>
</tr>
</tbody>
</table>

Revolve parameters for the circle C4:

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\alpha_1$</td>
<td>-180</td>
</tr>
<tr>
<td>$\alpha_2$</td>
<td>0</td>
</tr>
<tr>
<td>x (point on axis)</td>
<td>0</td>
</tr>
<tr>
<td>y (point on axis)</td>
<td>$-8e^{-3}$</td>
</tr>
<tr>
<td>x (second point)</td>
<td>1</td>
</tr>
<tr>
<td>y (second point)</td>
<td>$-8e^{-3}$</td>
</tr>
</tbody>
</table>

Revolve parameters for the circle C5:

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\alpha_1$</td>
<td>180</td>
</tr>
<tr>
<td>$\alpha_2$</td>
<td>0</td>
</tr>
<tr>
<td>x (point on axis)</td>
<td>0</td>
</tr>
<tr>
<td>y (point on axis)</td>
<td>$8e^{-3}$</td>
</tr>
<tr>
<td>x (second point)</td>
<td>1</td>
</tr>
<tr>
<td>y (second point)</td>
<td>$8e^{-3}$</td>
</tr>
</tbody>
</table>

To create the blood vessel, return to the Geom2 work plane and select C6.

Go to the Draw menu and select Extrude.

In the Distance field enter $120e^{-3}$.

Click OK.

Select the EXT3 geometry object, go to the Draw menu and select Move under Modify.
Enter the following displacement values; when finished, click OK.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>x</td>
<td>0</td>
</tr>
<tr>
<td>y</td>
<td>0</td>
</tr>
<tr>
<td>z</td>
<td>-60e-3</td>
</tr>
</tbody>
</table>

To create the large cylinder, press the Shift key and click the Cylinder button.

Enter the following cylinder properties; when finished, click OK.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Radius</td>
<td>0.05</td>
</tr>
<tr>
<td>Height</td>
<td>0.12</td>
</tr>
</tbody>
</table>

Click the Zoom Extents button on the Main toolbar.

This concludes the drawing stage. To get a better view of the geometry you have created, do as follows:

1. To hide the coordinate axes, double-click the AXIS button on the status bar at the bottom of the user interface.
2. From the Options menu select Visualization/Selection Settings.
3. Clear the Geometry labels check box, then click OK.
4. Choose Options>Suppress>Suppress Boundaries.
5. Select Boundaries 34, 47, 58, 59, 62, and 63, then click OK.
6. Click the Perspective Projection button on the Camera toolbar.
7. Finally, after rotating the geometry in the drawing area upside down you should have a view similar to that in Figure 4-1 on page 246.

**Physics Settings**

**Subdomain Settings—Bioheat Equation**

1. In the Multiphysics menu select 1 Bioheat Equation (htbh).
2. In the Physics menu select Subdomain Settings.
3. Select Subdomain 8 and clear the Active in this domain check box.
4. Enter the properties for the remaining subdomains as follows:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN 1</th>
<th>SUBDOMAINS 2, 5–7</th>
<th>SUBDOMAIN 3</th>
<th>SUBDOMAIN 4</th>
</tr>
</thead>
<tbody>
<tr>
<td>k</td>
<td>k_l</td>
<td>k_e</td>
<td>k_t</td>
<td>k_c</td>
</tr>
<tr>
<td>ρ</td>
<td>ρo_l</td>
<td>ρo_e</td>
<td>ρo_t</td>
<td>ρo_c</td>
</tr>
<tr>
<td>C</td>
<td>c_l</td>
<td>c_e</td>
<td>c_t</td>
<td>c_c</td>
</tr>
<tr>
<td>ρ_b</td>
<td>ρo_b</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>C_b</td>
<td>c_b</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ω_b</td>
<td>ωo_b</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>T_b</td>
<td>T_b</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Q_net</td>
<td>0</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Q_ext</td>
<td>Q_dc</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

5. On the Init page, select all active subdomains and in the $T(t_0)$ edit field type $T_0$.

6. To reduce the size of the computation problem, select a lower element order by choosing the Element tab and then select Lagrange - Linear from the list of Predefined elements for all active subdomains.

7. Click OK.

**Boundary Conditions—Bioheat Equation**

8. Go to the Physics menu and select Boundary Settings.

9. Enter boundary coefficients as follows:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 1–4, 34–47, 58, 59, 62, 63</th>
<th>BOUNDARY 20</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Temperature</td>
<td>Thermal insulation</td>
</tr>
<tr>
<td>$T_0$</td>
<td>$T_b$</td>
<td></td>
</tr>
</tbody>
</table>

10. Click OK.

**Subdomain Settings—Conductive Media DC**

1. Go to the Multiphysics menu and select 2 Conductive Media DC (dc).

2. Go to the Physics menu and select Subdomain Settings.

3. Enter the subdomain properties as in the following table:

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN 1</th>
<th>SUBDOMAINS 2, 5–7</th>
<th>SUBDOMAIN 3</th>
<th>SUBDOMAIN 4</th>
<th>SUBDOMAIN 8</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\sigma$ (isotropic)</td>
<td>sigma_l</td>
<td>sigma_e</td>
<td>sigma_t</td>
<td>sigma_c</td>
<td>sigma_b</td>
</tr>
</tbody>
</table>
4 Reduce the element order also for this application mode: On the Element page, select Lagrange - Linear from the list of Predefined elements for all subdomains.

5 Click OK.

Boundary Conditions—Conductive Media DC
1 From the Physics menu open the Boundary Settings dialog box.
2 Select the Interior boundaries check box and enter boundary coefficients as in the table below. You only need to set the boundary condition on the boundaries that use Electric potential. The remaining boundaries already have the correct conditions set by default, that is, Ground for outer boundaries and Continuity for interior boundaries.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>BOUNDARIES 5-16, 21-33, 35-39, 41-43, 45, 46, 48-57</th>
<th>BOUNDARIES 1-4, 20, 34, 47, 60, 61</th>
<th>BOUNDARIES 17-19, 40, 44, 58, 59, 62, 63</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Electric potential</td>
<td>Ground</td>
<td>Continuity</td>
</tr>
<tr>
<td>V</td>
<td>V0</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

3 Click OK.

Mesh Generation
1 From the Mesh menu select Free Mesh Parameters.
2 From the Predefined mesh sizes list select Fine.
3 Click the Custom mesh size button, then modify the Element growth rate from the default value to 1.7.
4 Click Remesh, then click OK.

Computing the Solution
1 Click the Solver Parameters button on the Main toolbar.
2 From the Solver list select Time dependent.
3 On the General page, type 0 600 in the Times field.
4 From the Linear system solver list select Direct (UMFPACK).
5 From the Matrix symmetry list select Nonsymmetric.
6 Go to the Time Stepping tab and select Time steps from solver in the Times to store in output list.
7 Select the Manual tuning of step size check box and type 0.01 in the Initial time step edit field and 50 in the Maximum time step edit field.
8 Click OK.
9 Click the Solve button on the Main toolbar.

**POSTPROCESSING AND VISUALIZATION**
The default plot is a slice plot of the temperature at time = 600 seconds. In order to generate Figure 4-2, follow these steps:

1 Click the Plot Parameters button on the Main toolbar.
2 On the General page select Interpolated from the Solution at time list.
3 In the Time edit field type 60.
4 Click the Slice tab and locate the Slice data area. From the Predefined quantities list select Temperature and from the Unit list select °C.
5 In the Slice positioning area set the number of x levels, y levels, and z levels to 1, 1, and 0, respectively.
6 Click Apply.

The following steps describe how to generate the plot in Figure 4-4, which shows the isosurface for the temperature 50 °C, after 8 minutes:

1 Return to the General page, then clear the Slice check box and select the Isosurface check box.
2 In the Time edit field type 480.
3 Click the Isosurface tab. On the Isosurface Data page, select Temperature from the list of Predefined quantities and select °C from the Unit list.
4 In the Isosurface levels area, type 50 in the edit field for Vector with isolevels.
5 Click OK.
6 To finish the plot, click the Scene Light button on the Plot toolbar, then click the Increase Transparency button 5–6 times.
   Clicking the Decrease Transparency button repeatedly returns the transparency settings to the original state.

To create Figure 4-3, which shows temperature versus time, do the following steps:

1 From the Postprocessing menu select Domain Plot Parameters.
2 On the General page, click the Point plot option button under Plot type.
3 On the Point page, select Point 43. From the Unit list select °C, then click OK.
The postprocessing image that is shown when you open the tumor ablation model from the model library is created with the following steps:

1. Click the **Plot Parameters** button on the Main toolbar.
2. On the **General** page, clear the **Isosurface** check box and select the **Streamline** and **Slice** check boxes.
3. On the **Streamline** page, select **Heat flux** from the list of **Predefined quantities**.
4. On the **Start Points** page, select **Specify start point coordinates**, then specify the following settings in the **x**, **y**, and **z** edit fields:

<table>
<thead>
<tr>
<th>COORD</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>x</td>
<td>linspace(0.02, 0.02, 30)</td>
</tr>
<tr>
<td>y</td>
<td>linspace(-0.04, 0.04, 10), linspace(-0.04, 0.04, 10), linspace(-0.04, 0.04, 10)</td>
</tr>
<tr>
<td>z</td>
<td>linspace(0.05, 0.05, 10), linspace(0.08, 0.08, 10), linspace(0.02, 0.02, 10)</td>
</tr>
</tbody>
</table>

5. On the **Line Color** page, select the **Use expression** option button, then click the **Color Expression** button. In the dialog box that appears, clear the **Color scale** check box (leave the default settings in the **Streamline color data** area). Click **OK**.
6. Set the **Line type** to **Tube**, then click the **Tube Radius** button. In the dialog box that appears, clear the **Auto** check box for the **Radius scale factor**, then type **0.1** in the edit field. Click **OK**.
7. Click the **Slice** tab. In the **Slice positioning** area set the number of **x levels**, **y levels**, and **z levels** to 1, 0, and 0, respectively.
8. Click **OK**.
Microwave Cancer Therapy

Introduction

Electromagnetic heating appears in a wide range of engineering problems and is ideally suited for modeling in COMSOL Multiphysics because of its multiphysics capabilities. This example comes from the area of hyperthermic oncology and it models the electromagnetic field coupled to the bioheat equation. The modeling issues and techniques are generally applicable to any problem involving electromagnetic heating.

In hyperthermic oncology, cancer is treated by applying localized heating to the tumor tissue, often in combination with chemotherapy or radiotherapy. Some of the challenges associated with the selective heating of deep-seated tumors without damaging surrounding tissue are:

- Control of heating power and spatial distribution
- Design and placement of temperature sensors

Among possible heating techniques, RF and microwave heating have attracted much attention from clinical researchers. Microwave coagulation therapy is one such technique where a thin microwave antenna is inserted into the tumor. The microwaves heat up the tumor, producing a coagulated region where the cancer cells are killed.

This model computes the temperature field, the radiation field, and the specific absorption rate (SAR)—defined as the ratio of absorbed heat power and tissue density—in liver tissue when using a thin coaxial slot antenna for microwave coagulation therapy. It closely follows the analysis found in Ref. 1. It computes the temperature distribution in the tissue using the bioheat equation.

Model Definition

Figure 4-6 shows the antenna geometry. It consists of a thin coaxial cable with a ring-shaped slot measuring 1 mm cut on the outer conductor 5 mm from the short-circuited tip. For hygienic purposes, the antenna is enclosed in a sleeve (catheter) made of PTFE (polytetrafluoroethylene). The following tables give the relevant
geometrical dimensions and material data. The antenna operates at 2.45 GHz, a frequency widely used in microwave coagulation therapy.

**TABLE 4-1: DIMENSIONS OF THE COAXIAL SLOT ANTENNA.**

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Diameter of the central conductor</td>
<td>0.29 mm</td>
</tr>
<tr>
<td>Inner diameter of the outer conductor</td>
<td>0.94 mm</td>
</tr>
<tr>
<td>Outer diameter of the outer conductor</td>
<td>1.19 mm</td>
</tr>
<tr>
<td>Diameter of catheter</td>
<td>1.79 mm</td>
</tr>
</tbody>
</table>

**TABLE 4-2: MATERIAL PROPERTIES.**

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>INNER DIELECTRIC OF COAXIAL CABLE</th>
<th>CATHETER</th>
<th>LIVER TISSUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Relative permittivity</td>
<td>2.03</td>
<td>2.60</td>
<td>43.03</td>
</tr>
<tr>
<td>Conductivity</td>
<td></td>
<td></td>
<td>1.69 S/m</td>
</tr>
</tbody>
</table>

*Figure 4-6: Antenna geometry for microwave coagulation therapy. A coaxial cable with a ring-shaped slot cut on the outer conductor is short-circuited at the tip. A plastic catheter surrounds the antenna.*

The model takes advantage of the problem’s rotational symmetry, which allows modeling in 2D using cylindrical coordinates as indicated in Figure 4-7. When
modeling in 2D, you can select a fine mesh and achieve excellent accuracy. The model uses a frequency-domain problem formulation with the complex-valued azimuthal component of the magnetic field as the unknown.

Figure 4-7: The computational domain appears as a rectangle in the rz-plane.

The radial and axial extent of the computational domain is in reality larger than indicated in Figure 4-7. This problem does not model the interior of the metallic conductors, and it models metallic parts using boundary conditions, setting the tangential component of the electric field to zero.

**DOMAIN AND BOUNDARY EQUATIONS—ELECTROMAGNETICS**

An electromagnetic wave propagating in a coaxial cable is characterized by transverse electromagnetic fields (TEM). Assuming time-harmonic fields with complex amplitudes containing the phase information, the appropriate equations are

\[
E = e^{-j\omega t} r C e^{j(\omega t - kr)}
\]

\[
H = e^{-j\omega t} r Z e^{j(\omega t - kz)}
\]

\[
P_{av} = \int_{r_{inner}}^{r_{outer}} \text{Re}\left(\frac{1}{2} \mathbf{E} \times \mathbf{H}^*\right) 2\pi r dr = e_z\pi C^2 \ln\left(\frac{r_{outer}}{r_{inner}}\right)
\]

where \(z\) is the direction of propagation, and \(r\), \(\varphi\), and \(z\) are cylindrical coordinates centered on the axis of the coaxial cable. \(P_{av}\) is the time-averaged power flow in the cable, \(Z\) is the wave impedance in the dielectric of the cable, while \(r_{inner}\) and \(r_{outer}\) are...
the dielectric’s inner and outer radii, respectively. Further, \( \omega \) denotes the angular frequency. The propagation constant, \( k \), relates to the wavelength in the medium, \( \lambda \), as

\[
k = \frac{2\pi}{\lambda}.
\]

In the tissue, the electric field also has a finite axial component whereas the magnetic field is purely in the azimuthal direction. Thus, you can model the antenna using an axisymmetric transverse magnetic (TM) formulation. The wave equation then becomes scalar in \( H_\phi \):

\[
\nabla \times \left( \left[ \epsilon_r - \frac{j\sigma}{\omega \epsilon_0} \right]^{-1} \nabla \times H_\phi \right) - \mu_r k_0^2 H_\phi = 0.
\]

The boundary conditions for the metallic surfaces are

\[ n \times E = 0. \]

The feed point is modeled using a port boundary condition with a power level set to 10 W. This is essentially a first-order low-reflecting boundary condition with an input field \( H_{\phi 0} \):

\[
 n \times \sqrt{\epsilon} E - \sqrt{\mu} H_\phi = -2 \sqrt{\mu} H_{\phi 0}
\]

where

\[
 H_{\phi 0} = \frac{P_{av} Z}{\pi r \ln \left( \frac{r_{outer}}{r_{inner}} \right)}
\]

for an input power of \( P_{av} \) deduced from the time-average power flow.

The antenna radiates into the tissue where a damped wave propagates. Because you can discretize only a finite region, you must truncate the geometry some distance from the antenna using a similar absorbing boundary condition without excitation. Apply this boundary condition to all exterior boundaries. Finally, apply a symmetry boundary condition for boundaries at \( r = 0 \):

\[
 E_r = 0, \quad \frac{\partial E_z}{\partial r} = 0.
\]
The bioheat equation describes the stationary heat transfer problem as

\[
\nabla \cdot (-k \nabla T) = \rho_b C_b \omega_b (T_b - T) + Q_{\text{met}} + Q_{\text{ext}}
\]

where \(k\) is the liver’s thermal conductivity (W/(m·K)), \(\rho_b\) represents the blood density (kg/m\(^3\)), \(C_b\) is the blood’s specific heat capacity (J/(kg·K)), and \(\omega_b\) denotes the blood perfusion rate (1/s). Further, \(Q_{\text{met}}\) is the heat source from metabolism, and \(Q_{\text{ext}}\) is an external heat source, both measured in W/m\(^3\).

This model neglects the heat source from metabolism. The external heat source is equal to the resistive heat generated by the electromagnetic field:

\[
Q_{\text{ext}} = \frac{1}{2} \Re[(\sigma - j\omega\varepsilon) \mathbf{E} \cdot \mathbf{E}^*].
\]

The model assumes that the blood perfusion rate is \(\omega_b = 0.0036\) s\(^{-1}\), and that the blood enters the liver at the body temperature \(T_b = 37\) °C and is heated to a temperature, \(T\). The blood’s specific heat capacity is \(C_b = 3639\) J/(kg·K).

For a more realistic model, you might consider letting \(\omega_b\) be a function of the temperature. At least for external body parts such as hands and feet, it is evident that a temperature increase results in an increased blood flow.

This example models the heat-transfer problem only in the liver domain. Where this domain is truncated, it uses insulation, that is

\[
\mathbf{n} \cdot \nabla T = 0.
\]

**Results and Discussion**

Figure 4-8 shows the resulting steady-state temperature distribution in the liver tissue for an input microwave power of 10 W. The temperature is highest near the antenna. It then decreases with distance from the antenna and reaches 37 °C closer to the outer boundaries of the computational domain. The perfusion of relatively cold blood seems to limit the extent of the area that is heated.
Figure 4-8: Temperature in the liver tissue.

Figure 4-9 shows the distribution of the microwave heat source. Clearly the temperature field follows the heat-source distribution quite well. That is, near the antenna the heat source is strong, which leads to high temperatures, while far from the antenna, the heat source is weaker and the blood manages to keep the tissue at normal body temperature.

Figure 4-9: The computed microwave heat-source density takes on its highest values near the tip and the slot. The scale is cut off at 1 W/cm².
Figure 4-10 plots the specific absorption rate (SAR) along a line parallel to the antenna and at a distance of 2.5 mm from the antenna axis normalized by its maximal value along the line. The results are in good agreement with those found in Ref. 1.

![Figure 4-10: Normalized SAR value along a line parallel to the antenna and at a distance 2.5 mm from the antenna axis. The tip of the antenna is located at 70 mm, and the slot is at 65 mm.](image)

Reference


Modeling in COMSOL Multiphysics

The COMSOL Multiphysics implementation is straightforward. Drawing the geometry is best done creating rectangles and setting their dimensions directly from the **Draw** menu. The scale differences together with the strong radial dependence of the electromagnetic fields make some manual adjustment of the mesh parameters necessary. In addition, 4th-order elements for the electromagnetic problem and a dense mesh in the dielectric result in well-resolved fields. The model computes the
solutions for both the electromagnetic problem and the heat transfer problem in parallel. This takes into account the coupling of the resistive heating from the electromagnetic solution into the bioheat equation. In principle, however, you could solve the two problems in sequence because there is only a 1-way coupling from the electromagnetic problem to the bioheat problem.

Model Library path: Heat_Transfer_Module/Medical_Technology/microwave_cancer_therapy

Note: This model requires the RF Module and the Heat Transfer Module.

Modeling Using the Graphical User Interface

MODEL NAVIGATOR
1. Open the Model Navigator. In the Space dimension list select Axial symmetry 2D.
2. In the list of application modes select Heat Transfer Module>Bioheat Equation>Steady-state analysis.
3. Click the Multiphysics button, then click the Add button.
4. In the list of application modes select RF Module>Electromagnetic Waves>TM Waves>Harmonic propagation.
5. In the Element list select Lagrange - Quartic.
6. Click Add, then click OK.

OPTIONS AND SETTINGS
From the Options menu select Constants. Enter the following names and expressions; when done, click OK.

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>k_liver</td>
<td>0.56[W/(kg*K)]</td>
<td>Thermal conductivity, liver</td>
</tr>
<tr>
<td>rho_blood</td>
<td>1000[kg/m^3]</td>
<td>Density, blood</td>
</tr>
<tr>
<td>C_blood</td>
<td>3639[J/(kg*K)]</td>
<td>Specific heat, blood</td>
</tr>
<tr>
<td>omega_blood</td>
<td>3.6e-3[1/s]</td>
<td>Blood perfusion rate</td>
</tr>
</tbody>
</table>
**GEOMETRY MODELING**

1. Create two rectangles. Select the menu item **Draw>Specify Objects>Rectangle**, then enter the following settings; when done with each one, click **OK**.

<table>
<thead>
<tr>
<th>Width (m)</th>
<th>Height (m)</th>
<th>Base Corner R (m)</th>
<th>Base Corner Z (m)</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.595e-3</td>
<td>0.01</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>29.405e-3</td>
<td>0.08</td>
<td>0.595e-3</td>
<td>0</td>
</tr>
</tbody>
</table>

2. From the Draw menu open the **Create Composite Object** dialog box. Clear the **Keep interior boundaries** check box. In the **Object selection** box select both rectangles, then click the **Union** button. Click **OK**.

3. Following the procedure in Step 1, specify two more rectangles with the following properties:

<table>
<thead>
<tr>
<th>Width (m)</th>
<th>Height (m)</th>
<th>Base Corner R (m)</th>
<th>Base Corner Z (m)</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.125e-3</td>
<td>1e-3</td>
<td>0.47e-3</td>
<td>0.0155</td>
</tr>
<tr>
<td>3.35e-4</td>
<td>0.0699</td>
<td>0.135e-3</td>
<td>0.0101</td>
</tr>
</tbody>
</table>

4. Add a line to the geometry. Select the menu item **Draw>Specify Objects>Line**. In the `r` edit field enter the coordinates 0 8.95e-4 8.95e-4, and in the `z` edit field enter the coordinates 9.5e-3 0.01 0.08. Click **OK**.

5. Finally specify another rectangle with these parameters:

<table>
<thead>
<tr>
<th>Width (m)</th>
<th>Height (m)</th>
<th>Base Corner R (m)</th>
<th>Base Corner Z (m)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.25e-4</td>
<td>1e-3</td>
<td>4.7e-4</td>
<td>0.0155</td>
</tr>
</tbody>
</table>

**PHYSICS SETTINGS**

*Subdomain Settings—Bioheat Equation*

1. From the **Multiphysics** menu select **1 Bioheat Equation (htbh)**.
2 From the **Physics** menu select **Subdomain Settings**.

3 Select Subdomains 2, 3, and 4, then clear the **Active in this domain** check box.

4 Select Subdomain 1, then enter the following settings; when done, click **OK**.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>( k ) (isotropic)</td>
<td>( k_{\text{liver}} )</td>
</tr>
<tr>
<td>( \rho_b )</td>
<td>( \rho_{\text{blood}} )</td>
</tr>
<tr>
<td>( C_b )</td>
<td>( C_{\text{blood}} )</td>
</tr>
<tr>
<td>( \omega_b )</td>
<td>( \omega_{\text{blood}} )</td>
</tr>
<tr>
<td>( T_b )</td>
<td>( T_{\text{blood}} )</td>
</tr>
<tr>
<td>( Q_{\text{met}} )</td>
<td>0</td>
</tr>
<tr>
<td>( Q_{\text{ext}} )</td>
<td>( Q_{av_{ \text{rfwh}} } )</td>
</tr>
</tbody>
</table>

**Boundary Conditions—Bioheat Equation**

1 From the **Physics** menu select **Boundary Settings**.

2 Select all the exterior boundaries (get them by pressing Ctrl+A, and note that the following step ignores the interior boundaries).

3 In the **Boundary condition** list select **Thermal insulation**, then click **OK**.

**Note:** Because the model neglects metabolic heat generation you set \( Q_{\text{met}} \) to 0. The variable \( Q_{av_{ \text{rfwh}} } \) is a subdomain expression for the resistive heating provided by the TM Waves application mode.

**Scalar Variables—TM Waves**

1 From the **Multiphysics** menu select **2 TM Waves (rfwh)**.

2 From the **Physics** menu select **Scalar Variables** to open the **Application Scalar Variables** dialog box.

3 Find the variable \( nu_{ \text{rfwh} } \) and set its value to \( nu \), then click **OK**.

**Boundary Conditions—TM Waves**

1 From the **Physics** menu select **Boundary Settings**.
2 Specify boundary settings according to the following table (to enter the port settings for Subdomain 8 go to the Port page); when finished, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAINS 1, 3</th>
<th>SUBDOMAINS 2, 14, 18, 20, 21</th>
<th>SUBDOMAIN 8</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary condition</td>
<td>Axial symmetry</td>
<td>Scattering boundary condition</td>
<td>Port</td>
</tr>
<tr>
<td>Wave excitation at this port</td>
<td></td>
<td></td>
<td>selected</td>
</tr>
<tr>
<td>$P_{in}$</td>
<td></td>
<td>$P_{in}$</td>
<td></td>
</tr>
<tr>
<td>Mode specification</td>
<td></td>
<td>Coaxial</td>
<td></td>
</tr>
<tr>
<td>Wave type</td>
<td></td>
<td>Spherical wave</td>
<td></td>
</tr>
</tbody>
</table>

For the (exterior) boundaries not mentioned in the table, the default condition (perfect electric conductor) applies.

Subdomain Settings—TM Waves

1 From the Physics menu select Subdomain Settings.
2 Enter the following settings; when finished, click OK.

<table>
<thead>
<tr>
<th>SETTINGS</th>
<th>SUBDOMAIN 1</th>
<th>SUBDOMAIN 2</th>
<th>SUBDOMAIN 3</th>
<th>SUBDOMAIN 4</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\varepsilon_r$ (isotropic)</td>
<td>$\varepsilon_{\text{Liver}}$</td>
<td>$\varepsilon_{\text{Cat}}$</td>
<td>$\varepsilon_{\text{Dieel}}$</td>
<td>1</td>
</tr>
<tr>
<td>$\sigma$ (isotropic)</td>
<td>$\sigma_{\text{Liver}}$</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>$\mu_r$</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>

Mesh Generation

1 From the Mesh menu open the Free Mesh Parameters dialog box.
2 Go to the Global page, click the Custom mesh size button and in the Maximum element size edit field type $3 \times 10^{-3}$.
3 Go to the Subdomain page and select Subdomain 3. In the Maximum element size edit field type $1.5 \times 10^{-4}$.
4 Click Remesh, then click OK.

Computing the Solution

Click the Solve button on the Main toolbar.

Postprocessing and Visualization

The default plot shows the temperature field. To change the unit to degrees Celsius, reproducing the plot in Figure 4-8, do as follows:
1 Click the Plot Parameters button on the Main toolbar.

2 Click the Surface tab. From the Unit list select °C, then click Apply.

The following steps describe how to visualize the resistive heating of the tissue:

1 In the Predefined quantities list select TM Waves (rfwh)>Resistive heating, time average. In the Unit edit field type W/cm^3, then click Apply.

   Heating decreases rapidly in the liver tissue, resulting in an almost uniformly blue plot. To get a better feeling for the heating at a distance from the antenna, do as follows:

2 In the Expression edit field type min(Qav_rfwh,1[W/cm^3]), then click OK.

   In the resulting plot, which reproduces that in Figure 4-9, the region around the antenna in which the time-averaged resistive heating exceeds 1 W/cm^3 has a uniform, deep red color. Outside this region, you can read off the heating distribution from the color scale on the right.

To compute the total heating power deposited in the liver, follow these steps:

1 From the Postprocessing menu open the Subdomain Integration dialog box.

2 Select Subdomain 1. From the Predefined quantities list select TM Waves (rfwh)>Resistive heating, time average.

3 Select the Compute volume integral (for axisymmetric modes) check box. Click OK.

   The result appears in the message log at the bottom of the user interface. The value of approximately 9.37 W indicates that the tissue absorbs most of the 10 W input power at stationary conditions.

These steps reproduce the plot in Figure 4-10, displaying the normalized SAR value:

1 From the Postprocessing menu open the Cross-Section Plot Parameters dialog box.

2 On the Line/Extrusion page, type Qav_rfwh/3.01[W/cm^3] in the Expression edit field. In both the r0 and r1 edit fields type 2.5e-3; in the z0 edit field type 0.08; and in the z1 edit field type 0.

3 Click the General tab, then click the Title/Axis button. In the Title/Axis Settings dialog box, select the option button next to the Title edit field, then enter the title Off-axis SAR values (distance = 2.5 mm).

4 In a similar way, enter the first axis label Insertion depth [m] and the second axis label SAR (normalized), then click OK to close the Title/Axis Settings dialog box.

5 Click OK to generate the plot.
INDEX

A  AC/DC Module 103
    application mode
    Bioheat equation 268
    Conductive Media DC 246
    General Heat Transfer 9, 29, 32, 62, 89, 153
    Solid, Stress-Strain 89
    TM waves 268
    Weakly Compressible Navier-Stokes 9, 62, 153
    axisymmetric radiation 143

B  bioheat equation 246, 247
    bioheat equation model 246, 261
    buoyancy effects 193

C  Conductive Media DC application mode 246
    conjugate heat transfer 40, 232
    contact resistance
    thermal 64
    convection
    forced 8
    natural 8
    turbulent forced 40
    convection cooling of circuit boards 8
    simplified models 29
    cup mixing temperature 30

D  deflection 102
    density
    of blood 247
    of tissue 247
    detachment 102

E  enthalpy 219

F  forced convection 8

G  General Heat Transfer application mode
    9, 29, 32, 62, 89, 153
    Grashof number 194

H  heat capacity
    of tissue 247
    heat sink
    microchannel 40
    heat transfer coefficient 29, 181, 192, 194
    heat transfer coefficients
    library of 40

I  interfacial stresses 102
    interfacial tension 103

J  Joule heating 102, 246

L  latent heat 218

M  mass transfer coefficient 182
    microchannel heat sink 40
    Model Library
    models 2

N  natural convection 8
    Nusselt number 17

P  potcore inductor 142
    printed circuit board 89

R  radiation 118, 143
    surface-to-ambient 207, 208
    surface-to-surface 127
    radiative losses 144
    RANS 41
    resistive heating 246
    Reynolds Averaged Navier-Stokes 233
    Reynolds-averaged Navier-Stokes 41

S  Solid, Stress-Strain 89
    Specific absorption rate (SAR) 261
    Structural Mechanics Module 91, 103
    surface-to-ambient radiation 207, 208
surface-to-surface radiation 127, 144

T  thermal
  contact resistance 64
  thermal conductivity
    of tissue 247
  thermal expansion coefficient 194
  thermo-photo-voltaic cell 127
  TM waves model 261
  turbulent convection 40
  turbulent kinematic viscosity 233
  turbulent viscosity 41
  typographical conventions 5

V  velocity profile
  parabolic 11
  virtual prototyping 102
  viscosity
    turbulent 41

W  Weakly Compressible Navier-Stokes application mode 9, 62, 153