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I n t r o d u c t i o n
The Earth Science Module Model Library contains write-ups and documentation 
for a number of geophysical and environmental scenarios. Many of the tools 
discussed here will help your modeling in this module and elsewhere in COMSOL 
Multiphysics. We encourage you to browse and explore. An important strength of 
COMSOL Multiphysics is the inheritance that comes from a community of 
researchers across many different disciplines. Tapping into the variety available in 
COMSOL Multiphysics will enhance your modeling. Guaranteed. 

In this library, the example models fall into five groups: fluid flow, solute transport, 
flow and deformation, heat transfer, and multiphysics. The models typically involve 
one or more application modes from the Earth Science Module. Others, such as the 
poroelasticity and electrokinetic volcano flow examples, utilize application modes 
from elsewhere in COMSOL Multiphysics. The models serve as a reference and 
also provide a head start for your own analyses. The ready-to-run models come with 
theoretical background as well as instructions that illustrate how to set it up. You 
can freely modify the model files, change the geometries and material properties, 
alter the equations, and add new physics to the file. Building on the shoulders of 
others saves time and adds insight.

Some models come from experts using COMSOL Multiphysics in their work and 
research. Others were put together by our staff engineers who have years of 
 1
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experience in Earth Science; they are your peers, using the language and terminology 
needed to get across the sophisticated concepts in these advanced topics. Many of the 
models have analytic solutions. Some are benchmark models designed to test the metal 
of dedicated physics programs. 

The model descriptions range in detail. Those that describe each step are useful as 
tutorials. Others are in-depth examples that focus on advanced or unusual options that 
you can use once you are familiar with COMSOL Multiphysics modeling. Before 
tackling the in-depth models, we urge you to take a look at a few of the basic variety. 

The Earth Science Module User’s Guide covers the equation set up, offers some 
insights on the underlying physics, and includes some fundamental modeling 
techniques for each application mode. The COMSOL Multiphysics User’s Guide and 
the COMSOL Multiphysics Quick Start manual provide additional information about 
modeling in the graphical user interface. For details about modeling with a 
programming language, look to the COMSOL Multiphysics Scripting Guide.

Each example comes with a COMSOL Multiphysics Model MPH-file that you can 
browse, modify and postprocess. This allows you to follow along with every step along 
the way whether you make the model or not. One or two of the models also includes 
application modes from other optional packages from COMSOL.

Model Library Guide

The table below summarizes key information about each entry in the Earth Science 
Module Model Library. The models are grouped according to the application area. 
The table also shows the equations used in each model. The entries with a superscript 
α denote models demonstrating some tools that are exceedingly useful in advanced 
modeling but probably offer too much challenge for a first COMSOL Multiphysics 
model. The Freezing Soil example utilizes an application mode from the Structural 
Mechanics Module denoted SME in the table.

The solution time is the elapsed time measured on a machine running Windows Vista 
with a 2.6 GHz AMD Athlon X2 Dual Core 500 CPU and 2 GB of RAM. For models 
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with a sequential solution strategy, the Solution Time column shows the elapsed time 
for the longest solution step.

TABLE 1-1:  EARTH SCIENCE MODULE MODEL LIBRARY
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FLUID FLOW

Pore Scale 8 24 s √

Finite Well 20 1 s √

Leaky Well 30 1 s √

Wellbore Storage 35 1 s √

Perforated Well 41 14 s √

Darcy-Brinkman 53 1 s √ √

Darcy-Brinkman–
Navier-Stokes

69 27 s √ √ √

Discrete Fracture 85 52 s √

Variably Saturated Flow 99 6 s √

Interpolation for 
Unsaturated Flow

115 3 min √

Two-Phase Flow: Air/Water 129 6 min √

Two-Phase Flow: Air/Oil 129 4 min √

Two-Phase Flow: Oil/Water 129 5 min √
SOLID DEFORMATION

Terzaghi Compaction 152 2 s √

Biot Poroelasticity 165 8 s √ √

Multilateral Well 183 56 s √ √

Freezing Soil* 198 5 min √ √ √
SOLUTE TRANSPORT

Solute Injection 212 3 s √ √

Buoyancy Flow Elder 228 47 s √ √

Sorbing Solute 245 23 min √ √

Pesticide Transport*** 265 39 min √ √
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*This model requires the Structural Mechanics Module.

**This model requires the AC/DC Module.

*** This model requires the COMSOL Reaction Engineering Lab.

Typographical Conventions

All COMSOL manuals use a set of consistent typographical conventions that should 
make it easy for you to follow the discussion, realize what you can expect to see on the 
screen, and know which data you must enter into various data-entry fields. In 
particular, you should be aware of these conventions:

• A boldface font of the shown size and style indicates that the given word(s) appear 
exactly that way on the COMSOL graphical user interface (for toolbar buttons in 
the corresponding tooltip). For instance, we often refer to the Model Navigator, 
which is the window that appears when you start a new modeling session in 
COMSOL; the corresponding window on the screen has the title Model Navigator. 
As another example, the instructions might say to click the Multiphysics button, and 
the boldface font indicates that you can expect to see a button with that exact label 
on the COMSOL user interface.

• The names of other items on the graphical user interface that do not have direct 
labels contain a leading uppercase letter. For instance, we often refer to the Draw 
toolbar; this vertical bar containing many icons appears on the left side of the user 
interface during geometry modeling. However, nowhere on the screen will you see 

HEAT TRANSFER

Buoyance Free 284 2 min √ √

Phase Change 303 9 s √

Free Convection 294 24 s √ √
MULTIPHYSICS

Electrokinetic Volcano 2D** 314 10 s √ √

Electrokinetic Volcano 3D** 314 2 min √ √
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the term “Draw” referring to this toolbar (if it were on the screen, we would print 
it in this manual as the Draw menu).

• The symbol > indicates a menu item or an item in a folder in the Model Navigator. 
For example, Physics>Equation System>Subdomain Settings is equivalent to: On the 
Physics menu, point to Equation System and then click Subdomain Settings. 
COMSOL Multiphysics>Heat Transfer>Conduction means: Open the COMSOL 

Multiphysics folder, open the Heat Transfer folder, and select Conduction.

• A Code (monospace) font indicates keyboard entries in the user interface. You might 
see an instruction such as “Type 1.25 in the Current density edit field.” The 
monospace font also indicates COMSOL Script codes.

• An italic font indicates the introduction of important terminology. Expect to find 
an explanation in the same paragraph or in the Glossary. The names of books in the 
COMSOL documentation set also appear using an italic font.
 |  5
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 2
F l u i d  F l o w  M o d e l s
This chapter contains a suite of models demonstrating the fluid-flow modeling 
capabilities in the Earth Science Module for modeling, for example, fluid flow to 
wells, porous media flow, and two-phase flow.
 7
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Po r e - S c a l e  F l ow

This non-conventional model of porous media flow uses the Navier-Stokes equations 
in the interstices of a porous media. The model comes from pore-scale flow 
experiments conducted by Arturo Keller, Maria Auset, and Sanya Sirivithayapakorn of 
the University of California, Santa Barbara. To produce the model geometry they 
scanned electron microscope images. This type of non-conventional pore-scale 
modeling with COMSOL Multiphysics is shedding new light on the movement of 
large particulates, colloids, moving through variable-pore geometries in the 
subsurface. Several of these researchers have published results from their COMSOL 
Multiphysics modeling in the publication Water Resources Research (Ref. 1 and Ref. 
2). 

Keller, Auset, and Sirivithayapakorn designed their lab experiments on the basis of 
scanning electron microscope (SEM) images of thinly sliced rock sections 
(Figure 2-1). They etched the geometric patterns from the images onto a solid with an 
elaborate process similar to the etching of silicon wafers. They then transferred these 
images to DXF files, which they finally imported into COMSOL Multiphysics.

Figure 2-1: Scanning electron microscope image of the repeat pattern in the silicon wafer. 
The scale at bottom indicates that pore throat and body dimensions are on the order of 
1 µm–100 µm (Ref. 1).
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It is typical to represent fluid flow in the subsurface as a continuum process using 
average or “continuous” properties for the bulk rather than detailing the shape and 
orientation of each solid particle within a porous medium. Inserting the bulk 
properties into an equation such as Darcy’s law gives an average flow rate for the total 
volume. While bulk approximations typically produce excellent estimates sufficient for 
considering flow over large areas, they miss the between-grain nuances that a close-up 
Navier-Stokes analysis describes. 

This example takes one of the 2D micromedia images of Keller, Auset, and 
Sirivithayapakorn and solves for velocities and pressures of pore fluids using the 
Navier-Stokes equations for Cartesian coordinates. The exercise imports the geometry 
as a DXF file and does not mesh any unneeded regions. Plotting includes 
3-dimensionalizing a 2D surface plot by adding height data. Boundary integration 
quantitatively evaluates fluxes. 

Model Definition

The entire model covers 640 µm × 320 µm. Water generally moves from right to left 
across the geometry. Flow is laminar in the pores and does not enter the grains. The 
inlet and outlet fluid pressures are known. Assume flow is symmetric about the top and 
bottom boundaries. The primary zone of interest is the rectangular region with an 
upper left corner at (0, 0) µm and lower right coordinates at (581.6, −265.0) µm.

Assuming fluids in the pore spaces are at constant density and also that temperature is 
constant, the Navier-Stokes and continuity equations are

where η denotes the dynamic viscosity (µg/(µm·s)), u represents the velocity (µm/s), 
ρ equals the fluid density (µg/µm3), p denotes the pressure (µg/(µm·s)), and I is the 
identity matrix. Owing to the problem’s small scale, the model does not include a body 
force that accounts for gravity.

The following equations give the mathematics that represent the model’s physical 
boundaries. The inlet pressure and the outlet pressure are known. Velocities are zero 
at the grain boundaries, which have a no-slip condition. Flow is symmetric about the 
top and bottom boundaries.

ρu ∇⋅ u ∇ pI– η ∇u ∇u( )T
+( )+[ ]⋅=

∇ u⋅ 0=
P O R E - S C A L E  F L O W  |  9
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In these equations, n is the unit normal vector, t is a unit tangential vector, and p0 is 
a specified pressure.

Results

Figure 2-2 shows the COMSOL Multiphysics solution predicted with a Navier-Stokes 
analysis for the relative velocities in the pore spaces of a micro-scale porous medium. 
Velocities are higher in the narrowest pores than at the inlet. The fluid velocities tend 
to decrease in stretches where the cross-sectional area for the flow increases.

Figure 2-2: Velocity field plot showing the velocities relative to the inlet velocity within the 
study section.

p p0 n η ∇u ∇u( )T
+( ) 0=⋅,= at Ωinlet∂

p 0 n η ∇u ∇u( )T
+( ) 0=⋅,= at Ωoutlet∂

u 0= at Ωgrains∂

n u 0 t η pI– ∇u ∇u( )T
+ +( )n 0=⋅,=⋅ at Ωsides∂
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Figure 2-3 gives the relative velocities plotted with a height that corresponds to 
pressure head. The figure clearly shows stagnant zones that exist within the dead-end 
reaches of big pores.

Figure 2-3: Relative velocities (represented with color, dimensionless) and pressure head 
(height, µm) within the study section.

The figure reveals that the highest velocities tend to occur in narrow pores with high 
pressure drops, as you might expect. Figure 2-4 shows a close-up view of a region near 
the exit, revealing that high velocities also develop in wide channels where pressure 
gradients are relatively shallow but multiple “tributaries” combine.
P O R E - S C A L E  F L O W  |  11
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Figure 2-4: Close-up of relative velocities (color) and pressure head (height) near the 
outlet.

The domain plot in Figure 2-5 shows the x-velocity at the outlet. The velocities are 
negative because the flow is moving in the negative x direction.

Figure 2-5: Velocities along the outlet boundaries.
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Model Library path: Earth_Science_Module/Fluid_Flow/pore_scale

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator, and in the Space dimension list select 2D.

2 From the list of application modes choose  
Earth Science Module>Fluid Flow>Incompressible Navier-Stokes. Click OK.

G E O M E T R Y  M O D E L I N G

1 Import the geometry from the DXF file. From the File menu select Import>DXF File, 
then navigate to pore_scale.dxf.

2 Accept the default settings for the geometry import. Click OK.
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3 From the Draw toolbar on the far left of the user interface click the Coerce to Solid 
button.

4 From the Draw toolbar select Split Object.

5 With the mouse, select the object CO2, the geometry object that corresponds to 
the open flow region.

6 Copy the geometry object by pressing Ctrl+C.

7 Select all objects by pressing Ctrl+A. Delete all objects by pressing the Delete key.

8 Paste the copied object by pressing Ctrl+V, then click OK in the Displacement dialog 
box that appears.

9 Click the Zoom Extents button on the Main toolbar to center the geometry in the 
field of view.
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O P T I O N S  A N D  S E T T I N G S

1 From the Physics menu select Model Settings.

2 Clear the Simplify expressions check box.

3 From the Base unit system list select None, then click OK.

4 From the Options menu select Constants, then enter the following names and 
expressions; when done, click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings
From the Physics menu select Subdomain Settings. Select Subdomain 1, then enter 
material properties from the following table:

Boundary Conditions
From the Physics menu select Boundary Settings. For the various boundaries in the 
following table, enter the corresponding settings:

M E S H  G E N E R A T I O N

1 From the Mesh menu open the Free Mesh Parameters dialog box, click the Global tab, 
then enter the following data:

NAME EXPRESSION

rho0 1000*1e9/(1e6)^3

eta0 0.001*1e9/1e6

p0 715

VARIABLE SUBDOMAIN 1

 ρ rho0

 η eta0

SETTINGS BOUNDARIES 1–6 BOUNDARIES 7–25 BOUNDARIES 26, 27 ALL OTHERS

Boundary type Outlet Symmetry boundary Inlet Wall

Boundary  
condition

Pressure, no  
viscous stress

- Pressure, no  
viscous stress

No slip

p0 0 p0

GLOBAL MESH PARAMETERS EXPRESSION

Maximum element size 10
P O R E - S C A L E  F L O W  |  15
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2 On the Boundary page, select Boundaries 1–6. In the Maximum element size edit field 
type 3.

3 Click the Advanced tab and set the Resolution of geometry to 20.

4 Click the Remesh button, then click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate Figure 2-2 follow these steps:

1 Click the Zoom Extents button on the Main toolbar.

2 From the Postprocessing menu open the Plot Parameters dialog box. Click the 
General tab, then select the Surface and Arrow check boxes. Click the Title button, 
enter text as desired, then click OK.

3 Click the Surface tab. In the Predefined quantities list select Velocity field.

4 Click the Arrow tab. In the Predefined quantities list select Velocity field.

5 In the Arrow positioning area, in both the x points and y points edit fields enter 40.

6 Click OK.

To generate Figure 2-3 continue with these steps:

1 Return to the Plot Parameters dialog box and the General page. Clear the Arrow 
check box (and leave the Surface check box remain selected).

2 Click the Surface tab. In the Predefined quantities list select Velocity field.

3 On the Surface page, click the Height Data tab. Select the Height data check box, and 
in the Expression edit field enter p/(rho0*9.82*1e6) to give pressure head in µm.

4 Click OK.

To generate Figure 2-4 continue with this step:

Define the area of interest. Go to the 3D Draw toolbar and activate the Dolly In/Out 
icon, or go to the Main toolbar and select the Zoom Window tool.

To generate Figure 2-5 continue with these steps:

Element growth rate 1.6

Mesh curvature factor 0.3

GLOBAL MESH PARAMETERS EXPRESSION
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1 From the Postprocessing menu open the Domain Plot Parameters dialog box (because 
you are evaluating quantities on boundaries).

2 Click the Line/Extrusion tab. In the Boundary selection list select Boundaries 1–6.

3 In the Predefined quantities list select x-velocity.

4 Go to the x-axis data area, and in the drop-down list select y. Click OK.

To generate particle tracing based on Stokes law continue with the following steps.

1 Open the Constants dialog box from the Options menu.

2 Add the following constants:

3 From the Solve menu, select Update Model.

4 Open the Plot Parameters dialog box.

5 Click the Particle Tracing tab.

6 Type -6*pi*prad*eta0*(partu-u) in the Fx edit field.

7 Type (pmass-rho0*pvol)*g-6*pi*prad*eta0*(partv-v) in the Fy edit field.

8 Set the Start Points according to the following table:

9 Click the Initial Values tab.

10 Set the Initial velocity to u and v.

11 Click the Line Color tab.

12 Click the Color button and select yellow. Click OK.

13 Click OK in the Plot Parameters dialog box.

NAME EXPRESSION

pmass 1

pvol 4/3*pi*prad^3

prad 1

g 0

START POINTS

x linspace(600,600.001,25)

y linspace(-80,-275.25)
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F l u i d  F l ow t o  We l l s

Analyzing fluid flow to and from wells is critical in managing groundwater and oil 
resources, excavating subsurface structures, and cleaning up pollution. 

The following figure shows a well withdrawing fluids from a reservoir. The well sits 
within a casing of relatively large diameter. The fluids moving to it are under pressure 
because the reservoir section that the well taps is bounded above and below, in a layer 
cake, by relatively impermeable materials or confining layers. The pumping generates 
a cone of depression in the hydraulic potential field that both expands outward and 
deepens with time. However, because the fluids completely fill the pore spaces, the 
cone of depression represents drawdown in the pressure potential rather than the fluid 
content.

Figure 2-6: Schematic flow to a well in a confined aquifer. After Hsieh (Ref. 1).

This model demonstrates three analyses of flow to wells following lectures and class 
notes from Paul Hsieh of the U.S. Geological Survey and Stanford University (Ref. 1). 
In the first example, the well has a finite radius such that the hydraulic potential inside 
it equals the potential at the edge. In the second example, the confining layers make 

confining layer

confining layer

well casing

land surface

∆h∆hw

initial head h0

head at t>0 h

rc

rw

Unpumped reservoir

Pumped reservoir

confining layer
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imperfect seals, so fluids from overlying reservoirs leak into the pumped aquifer. In the 
third analysis, the fluids inside the well or wellbore storage must be removed before 
reservoir fluids are extracted. This example compares COMSOL Multiphysics 
solutions to classic examples from Theis (Ref. 2), Hantush and Jacob (Ref. 3), and 
Papadopoulos and Cooper (Ref. 4). 

This simple sequence of 1D axisymmetric models uses the Darcy’s Law application 
mode from the Earth Science Module to analyze time-dependent flow to wells. The 
model domain is semi-infinite, but the analyses zoom in on a relatively small zone of 
interest and uses convenient commands for setting timed outputs over long durations. 

To account for the finite well radius in the first analysis, this study extends results at the 
well edge over the well interior using extrusion coupling variables. To account for 
leakage in the second example, it adds a source term to the governing equation. To 
include wellbore storage impacts in the third example, you add an ordinary differential 
equation as boundary condition using weak formulations (with a “dweak” term). The 
model also demonstrates how to include externally generated solutions or data in 
COMSOL Multiphysics plots. For a 2D example involving a point well, see “Solute 
Injection” on page 212. A 3D well analysis appears in the section “Perforated Well” 
on page 41.
F L U I D  F L O W  T O  W E L L S  |  19
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F l u i d  F l ow t o  We l l s :  F i n i t e  R ad i u s  
We l l

This first example in the model sequence “Fluid Flow to Wells” on page 18 defines 
transient flow to a well of finite radius in a confined aquifer. This discussion then 
compares the results from this analysis to the well-known solution for flow to a point 
well (Theis, Ref. 2). What distinguishes this model from the Theis problem is the well 
geometry because the analytical solution describes the well as a point source that 
produces unphysical results inside the wellbore. The COMSOL Multiphysics analysis 
produces a physically based solution in the well using extrusion-coupling variables to 
extend the results at the well edge over the well interior.

Apart from the well geometry, assumptions underlying the Theis problem apply. The 
reservoir is of infinite horizontal extent and is confined above and below by 
impermeable layers. As the well fully penetrates the reservoir, withdrawals are uniform 
along its length, making flow entirely horizontal. The problem neglects storage in the 
well. Fluids are released instantaneously from storage in the aquifer. Prior to pumping, 
the flow field is at steady state. Flow is horizontal, does not vary with depth, and 
equipotentials are axisymmetric about the wellhead. 

Taking advantage of symmetry, you can approximate the semi-infinite aquifer as a long 
line, here 10 km. A 1-km segment represents the zone of interest. The well radius is 
0.1 m. The hydraulic conductivity, K, is 10−4 m/s, and the thickness, b, is 50 m. The 
storage coefficient for pressure, S (m·s2/kg), equals Ss/ρf g. Ss is the specific storage 
for hydraulic head of 10−5 m−1, ρf represents the fluid density (kg/m3), and g is 
gravity (m/s2). The pumping rate, W, of 0.05 m3/s is constant. The initial pressure, 
p0, is 9.82·105 Pa. The period of interest is 107 s or roughly four months.

Model Definition

You typically define fluid flow in the subsurface by inserting Darcy’s law for fluid 
velocity into an equation of continuity. For a dependent variable of pressure p (kg/
(m·s2)), the governing equation reads

.S p∂
t∂

------ ∇+
K

ρf g
---------∇ p ρf gD+( )–⋅ Qs=
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The equation builds on the storage coefficient S (m·s2/kg), K is the hydraulic 
conductivity (m/s), D denotes the vertical coordinate (m); and Qs is a volumetric flow 
rate per unit volume of aquifer (1/s). In this analysis you set D to zero because the 
analysis is 1D horizontal.

The drawdown, dr (m), is

where p0 is the pressure at the onset of pumping. Fluid moves into the well with a 
velocity described by Darcy’s law

where W is the volumetric pumping rate, W (1/(m3·s)) for a cylindrical wellbore, rw 
represents the well radius, and b gives the vertical length of the pumping interval, in 
this case the aquifer thickness. The distill boundary is sufficiently far from the well that 
the pumping does not affect it.

The boundary and initial conditions for this model are:

where n is the normal to the boundary.

Implementation: Extrusion Coupling Variables

The finite element method is sufficiently robust to estimate the pressure precisely at 
the well screen, r = rw, rather than averaging over a square (finite difference) or 
reducing the well to a point (analytic). Because pressure is continuous in fluids, the 
pressure inside the well equals the pressure just outside of it.

This axisymmetric model begins at the center of the well, at r = 0. If you “turn off” 
equations inside the well, where r < rw, the well screen becomes a boundary. To see 
the pressure in the well, extrude the solution at rw through the well interior using 
coupling variables. Extrusion-coupling variables take information from one type of 

dr
p0 p–

ρf g
---------------=

K
ρf g
--------- ∇p ρf gD+( )–

W
2πrwb
-----------------=

n K
ρf g
---------∇p–⋅ W

2πrwb
-----------------–= Ω Well∂

p p0= Ω ∞∂

p p0= t 0=
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model domain (such as the boundary at the well radius) and extrude it over other 
domain types (such as the subdomain inside the well). This can be very powerful 
modeling feature. For example, with coupling variables you can express material 
properties that depend on the solution at some critical zone in the model, or define 
one boundary using results for another to give identical conditions. For more 
information on coupling variables, refer to “Using Coupling Variables” on page 255 
of the COMSOL Multiphysics User’s Guide.

Results

Figure 2-7 illustrates the COMSOL Multiphysics solution for flow to a finite radius 
well. The results at varying times for a 1000-m extent show the cone of depression the 
pumping produces. Because the solution never reaches steady state, pressures drop 
with time.

Figure 2-7: COMSOL Multiphysics solution for fluid pressure near a finite radius well 
along the line r < 1000 m. Results are for logarithmically spaced times from 0  ≤ t  ≤ 11.5 
days.
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Figure 2-8 plots the solution as drawdown versus time at five points in the aquifer; it 
also gives the Theis estimates for drawdown. Unlike the pressure solution, the 
drawdown increases with time and decreases with distance from the well. The author 
calculated the Theis estimates within COMSOL Multiphysics and added them to the 
plot.

Figure 2-8: COMSOL Multiphysics results (solid lines with circles) shown with the Theis 
(Ref. 2) analytic solution (dashed lines) for drawdown in the aquifer at r = rw, 1 m, 10 m, 
100 m, and 1000 m.

The COMSOL Multiphysics and Theis estimates are very similar outside the well. 
What happens inside the well, however, is critical in many analyses. Figure 2-9 is a 
close-up view showing that COMSOL Multiphysics gives a physically-based solution 
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inside the wellbore. The analytic estimates change unrealistically inside the wellbore 
because they represent withdrawals from a point.

Figure 2-9: COMSOL Multiphysics drawdown solution for the finite radius well (solid 
lines with circles) shown with the Theis estimates for a point well (dashed lines) along the 
line r < 0.3 m.

The solution at the well radius appears inside the wellbore via extrusion-coupling 
variables from COMSOL Multiphysics.
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Model Library path: Earth_Science_Module/Fluid_Flow/finite_well

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator. From the Space dimension list select Axial symmetry (1D).

2 In the list of application modes select  
Earth Science Module>Fluid Flow>Darcy’s Law>Pressure analysis>Transient analysis. 
Click OK.

G E O M E T R Y  M O D E L I N G

1 From the Draw menu select Specify Objects>Line. 

2 In the Coordinates: x edit field enter 0 0.1 1000 10000. Click OK.

3 On the Main toolbar click the Zoom Extents button.

O P T I O N S  A N D  S E T T I N G S

1 Select the menu item Options>Constants, then enter the following names, 
expressions, and descriptions (optional); when done, click OK.

NAME EXPRESSION DESCRIPTION

rhof 1000[kg/m^3] Fluid density

Ks 1e-4[m/s] Hydraulic conductivity

Ss 1e-5[1/m] Specific storage for hydraulic head

W 0.05[m^3/s] Pumping rate

b 50[m] Thickness

rw 0.1[m] Well radius

p0 9.82e5[Pa] Initial pressure
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2 Select the menu item Options>Expressions>Scalar Expressions, then define the 
following names and expressions; when done, click OK.

3 Open the menu item Options>Expressions>Subdomain Expressions and define the 
names on the indicated domains; when done, click OK.

4 Open the menu item Options>Extrusion Coupling Variables>Boundary Variables and 
enter the following settings:

5 Still in the same dialog box, click the Destination tab and choose the following:

6 Click OK.

P H Y S I C S  S E T T I N G S

Application Scalar Variables
Select the menu item Physics>Scalar Variables and change the elevation coordinate to 
zero (because the model is 1D axisymmetric in the horizontal), then click OK.

NAME EXPRESSION

Theis W/(4*pi*Ks*b)*Wu

u Ss*r^2/(4*Ks*t)

Wu (-0.5772+u-0.25*u^2+0.055*u^3-0.01*u^4+0.001*
u^5-log(u))*(u<1)+ 
(exp(-u)*(u^4+8.58*u^3+18.06*u^2+ 
8.64*u+0.27)/(u^4+9.57*u^3+ 25.63*u^2+21.1*u+ 
3.96)/u)*(u>=1)

NAME SUBDOMAIN 1 SUBDOMAINS 2, 3

pressure pwell p

drawdown (p0-pwell)/(rhof*g_esdl) (p0-p)/rhof/g_esdl

SOURCE NAME EXPRESSION TRANSFORMATION

Boundary 2 pwell p General

LEVEL SUBDOMAIN SELECTION

Subdomain 1

NAME EXPRESSION

D_esdl 0
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Subdomain Settings
1 From the Physics menu open the Subdomain Settings dialog box, then select 

Subdomain 1. Clear the Active in this domain check box. When the subdomain is 
deactivated, the check box should be empty.

2 Select Subdomains 2 and 3, then from the Storage term list select User defined. Go 
to the other drop-down list and change the setting from Permeability to Hydraulic 

conductivity. Enter the following expressions:

3 Click the Init tab, and in the Initial value edit field enter p0. Click OK.

Boundary Conditions
From the Physics menu select Boundary Settings, then enter the following boundary 
conditions; when done, click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu select Free Mesh Parameters. 

2 Click the Subdomain tab, select Subdomain 2, then in the Maximum element size edit 
field enter 10.

3 Click the Boundary tab, select Boundary 2, and in the Maximum element size enter 
0.001. Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 From the Solve menu open the Solver Parameters dialog box. Verify in the Solver list 
that Time dependent is selected.

2 To specify output times for the model, click on the General tab and go to the 
Time-stepping area. In the Times edit field enter 0 logspace(-2,6,81) to generate 
output data at time zero and also at 81 logarithmically spaced times from 10−2 to 
106 time units. Click OK.

3 Click the Solve button on the Main toolbar.

PROPERTY EXPRESSION

S Ss/(rhof_esdl*g_esdl)

Ks Ks

CONDITION VARIABLE BOUNDARY 2 BOUNDARY 4

Inward flux N0 -W/(2*pi*rw*b)

Pressure p0 p0
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P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate Figure 2-7 proceed as follows:

1 From the Postprocessing menu select the Domain Plot Parameters dialog box. 

2 In the Solution to use list select 0.1, 1, 10, 1e2, 1e3, 1e4, 1e5, and 1e6. Click the Title/

Axis button and enter a title as appropriate.

3 Click the Line/Extrusion tab. In the list of Predefined quantities select Pressure. Then 
choose Subdomains 1 and 2. Click OK.

To generate Figure 2-8, continue with these steps:

1 From the Postprocessing menu select Cross-Section Plot Parameters. In the resulting 
dialog box click on the Point tab, then find the y-axis data area. In the Expression edit 
field enter drawdown. In the Coordinates area go to the r edit field and enter 0.1 10 
100 100. Click Apply.

2 Click the General tab, then select the Keep current plot check box.

3 Return to the Point tab, and in the Expression edit field enter Theis. Click the Line 

Settings button; in the Line style list select Dashed line, and in the Line marker list 
select Circle. Click OK, then click Apply.

4 Focus in on the results for r < 100 m using the rubber-band tool you access with 
the Zoom Window button on the Main toolbar.

To generate Figure 2-9, continue with these steps:

1 From the Postprocessing menu select Domain Plot Parameters, then click the Line/

Extrusion tab. Go to the y-axis data area and in the Expression edit field enter 
drawdown. Click the Line Settings button and modify the line appearance as 
appropriate.

2 Click the General tab. In the Solutions to use list select 0.1 1 10 100 100 10000 100000 
and 1000000. Make sure the Keep current plot check box is selected. Click Apply.

3 Return to the Line/Extrusion tab and in the Expression edit field enter Theis. Click 
the Line Settings button, and change the line settings as appropriate, click OK, then 
click Apply.

4 Zoom in on the results for r < 0.3 m using the rubber band tool you access with the 
Zoom Window button on the Main toolbar. Click OK.

S A V I N G  T H E  M O D E L

This completes the initial well model. You will add new equations and terms in the next 
sections. To use this model for the next two analyses, please save it by going to 
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File>Save As and entering an appropriate file name. Click OK. Then leave the model file 
open.
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F l u i d  F l ow t o  We l l s :  L e a k y  We l l

In layered sedimentary sequences, confining units often sandwich viable reservoirs. 
Such is the case in Figure 2-6. If the confining units create less than perfect seals, fluids 
from an overlying reservoir can leak into the pumped reservoir below it. Often the 
pumping from the lower reservoir does not change flow in the unpumped one above. 
In these cases you can model the leakage through the imperfect confining unit as a 
distributed source of fluid to the lower reservoir, in the same fashion as recharge or 
precipitation.

This example is the second model in the series overviewed in “Fluid Flow to Wells” on 
page 18. This analysis builds on the example “Fluid Flow to Wells: Finite Radius Well” 
on page 20 to simulate pumping from a leaky aquifer. The discussion compares 
COMSOL Multiphysics results to the analytic problem of Hantush and Jacob (Ref. 1). 
The 3-part analysis builds on a lecture series from Hsieh (Ref. 2).

Model Definition

The governing equation for this problem is

where K' (1/(m·s)) and b' (m) are the hydraulic conductivity and thickness of the 
overlying confining unit, respectively. With p0 being the pressure prior to pumping, 
the term K'(p0 − p)/(b b') amounts to Darcy’s law for flow through the semi-pervious 
confining unit. The thickness of the pumped reservoir b appears in the denominator 
because the incoming fluid is distributed through the aquifer volume.

The boundary and initial conditions are the same as in the finite-well model:

S p∂
t∂

------ ∇+
K

ρf g
---------∇p–⋅ K′

ρf g
---------

p0 p–( )
bb′

--------------------=

n K
ρf g
---------∇p⋅ W

2πrwb
-----------------= ∂Ω well

p p0= ∂Ω ∞

p p0= t 0.=
 2 :  F L U I D  F L O W  M O D E L S



The geometry, the material properties, and the pumping rates come from the 
finite-well flow model. To describe the leakage through the confining layer, you specify 
its hydraulic conductivity, K', as 5·10-8 m/s and its thickness, b', as 2 m.

Results

Figure 2-10 shows the COMSOL Multiphysics solution for the distribution of 
pressures in a pumped aquifer with leakage from an overlying layer. Even for a relatively 
impermeable confining unit with hydraulic conductivity K' = K/100, the leakage is 
significant. For example, this figure depicts a far less extensive cone of depression than 
the one in Figure 2-7 which characterizes pumping in the same aquifer but without the 
leakage.

Figure 2-10: Solution for the fluid pressure near a finite-radius well in a leaky aquifer. 
Results are for logarithmically spaced times from 0 ≤ t ≤ 11.5 days along the line 
r < 1000 m.

The plot in Figure 2-11 converts the solution to the leaky aquifer to drawdown 
(defined on page 21) and plots it against time; it also shows the results for the case 
without leakage from Figure 2-8. The later time drawdown for the leaky case is almost 
constant by comparison. At early times, fluid reaching the wells comes from the storage 
in the pumped reservoirs. At later times, fluids pumped from the leaky aquifer derive 
mostly from the unpumped aquifer above it.
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Figure 2-11 also provides the analytic solution of Hantush and Jacob (Ref. 1). The 
COMSOL Multiphysics results are good fit to the analytic solution.

Figure 2-11: COMSOL Multiphysics drawdown estimates for a leaky confined aquifer 
(dashed lines) compared with the analytic solution (dots) from Hantush and Jacob (Ref. 
1). Also shown are results of simulations without the leakage (solid lines). Results are for 
r = rw, 0.1 m, 1 m, 10 m, 100 m, and 1000 m.
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Model Library path: Earth_Science_Module/Fluid_Flow/leaky_well
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Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator, and click the Model Library tab.

2 Open the Earth Science Module folder.

3 Find the Fluid Flow folder and select the file finite well.

4 Click OK.

P R E L I M I N A R I E S

Before adding to the model, create a cross-section plot of the results already in 
memory for use in a comparison plot with results from the modified model.

From the Postprocessing menu open the Cross-Section Plot Parameters dialog box. Click 
the Point tab, and in the Expression edit field enter drawdown. In the Coordinates: r edit 
field enter 0.1 1 10 100 1000. Click Apply. Leave the plotting window open.

O P T I O N S  A N D  S E T T I N G S

From the Options menu open the Constants dialog box, then add these names, 
expressions, and descriptions (optional); when done, click OK.

S U B D O M A I N  S E T T I N G S

From the Physics menu open the Subdomain Settings dialog box. Select Subdomains 2 
and 3, then enter the following name and expression; when done, click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate Figure 2-10, follow the instructions for Figure 2-7 already given.

To create Figure 2-11, first add the current results to Figure 2-8 and later the analytic 
solution. To add the current results to Figure 2-8, follow these steps:

NAME EXPRESSION DESCRIPTION

Kpr 5e-8[m/s] Hydraulic conductivity of confining layer

bpr 2[m] Thickness of confining layer

NAME EXPRESSION

Qs Kpr/(rhof*g_esdl)*(p0-p)/(b*bpr)
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1 From the Postprocessing menu open the Cross Section Plot Parameters dialog box. 
On the General tab, click the Titles/Axis button and provide new titles for the plot as 
appropriate, then click OK. Make certain that the Keep current plot check box is 
selected. If you run COMSOL Multiphysics with MATLAB, choose MATLAB Figure 
for the new plot.

2 Click the Point tab, then in the Expression edit field enter drawdown. Make sure the 
expression in the Coordinates edit field is 0.1 1 10 100 1000. Click Apply. 

If you have COMSOL Script or MATLAB, you can add the analytic solution.

3 Go the command line and enter the following code:

hold on
load leaky_analytic.txt
t = leaky_analytic(:,1);
A = leaky_analytic(:,2);
plot(t,A,'.')

the file leaky_analytic.txt should be available in your path.

4 Edit the figure axis and line settings as needed.
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F l u i d  F l ow t o  We l l s :  We l l b o r e  
S t o r a g e

Pumping from a finished well removes whatever fluids are in the well and the casing 
around it before fluids from the reservoir enter the well. The magnitude and duration 
of the wellbore storage’s impact is related to the size of the well and casing. These 
effects stand out particularly at early times, typically when engineers assess the viability 
of reservoirs. For large-scale projects with big wells, these “early time” effects can 
linger for many months and significantly inhibit production.

Wellbore storage effects have been the subject of much study in hydrogeology and 
petroleum engineering. Being particularly difficult to analyze, they are rarely 
considered in conventional numerical models. This section models wellbore storage by 
adding a time-dependent ordinary differential equation to the well boundary. The 
results shown here match the analytic solution of Papadopoulos and Cooper (Ref. 1). 
The method this analysis uses extends to account for skin effects.

Model Definition

This analysis of wellbore storage is the final example in the sequence described in 
“Fluid Flow to Wells” on page 18. It builds directly on the 1D axisymmetric model 
“Fluid Flow to Wells: Finite Radius Well” on page 20. As before, the equation 
governing the flow is

What changes is the mathematical model for flow at the well. The expression used here 
accounts for wellbore storage as follows:

where rc is the radius of the well casing; and pw(t), normalized by the specific gravity 
ρf  g, is drawdown in the well. This equation states that withdrawals from the well 
consist of two parts: First is the flux into the well from the aquifer, and second is the 
water coming from the wellbore itself. The foregoing specifies that the pressure just 

S p∂
t∂

------ ∇+
K

ρf g
---------∇p–⋅ Qs=

W K
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---------2πrwb∇p r rw=
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inside the well, pw(t), equals the pressure just outside of it, p(rw, t). In other words, 
pw(t) = pw(rw, t). A skin effect produces a discontinuity in pressure from just inside the 
well to just outside of it. To model the discontinuity, you also would add a third term 
to account for the step change.

The boundary and initial conditions for the Wellbore Storage model are

where n is the normal to the boundary.

To simplify this analysis, use material properties and pumping rates from the original 
Finite Well model and add the radius of the well casing, rc (set to 0.15 m as a start). 
With this parameterization, interesting results occur very early. To zoom in on these 
results you can reduce the simulation period.

Results

Figure 2-12 shows the COMSOL Multiphysics solution for drawdown as a function of 
time for five observation points near a well with wellbore storage impacts. The figure 
also provides results for the case without wellbore storage (see Figure 2-8). The 

n K
ρf g
---------∇p–⋅ W

πrc
2

ρf g
---------

dpw
dt

-----------+
⎝ ⎠
⎜ ⎟
⎛ ⎞

– 2πrwb( ) 1–
= Ω Well∂

p p0= Ω ∞∂

p p0= t 0=
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difference in the two solutions is the reduction in reservoir withdrawals owing to fluids 
present in the wellbore. This impact, as expected, diminishes with distance and time.

Figure 2-12: Drawdown estimates predicted with (dashed lines) and without (solid lines) 
wellbore storage. Results are for the well boundary and points at increasing distance from 
it.

Figure 2-13 compares a time series of drawdown from simulations including wellbore 
storage with different casing radii. COMSOL Multiphysics gives a near-perfect match 
to the analytic solution in Ref. 1. The solid line corresponds to the solution without 
wellbore storage. The next curve (dashed line) corresponds to a well casing with the 
same radius as the screened interval. Subsequent curves are for increasing casing radii. 
The plot shows that as the casing radius increases, the pumping removes less and less 
fluid from the reservoir for longer and longer times.
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Figure 2-13: Drawdown at the well for increasing well-casing radii (dashed lines) and 
without wellbore storage impacts (solid lines). The results almost exactly match the analytic 
solution of Papadopoulos and Cooper (Ref. 1).

Reference

1. I.S. Papadopoulos and H.H. Cooper Jr., “Drawdown in a Well of Large Diameter,” 
Water Resources Research, vol. 3, no. 1, 1967.

Model Library path: Earth_Science_Module/Fluid_Flow/wellbore_storage

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator and click the Model Library tab.

2 Find the file Earth Science Module>Fluid Flow>finite well.

3 Click OK.
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O P T I O N S  A N D  S E T T I N G S

From the Options menu open the Constants dialog box, then add the following name, 
expression, and description (optional); when done, click OK.

P H Y S I C S  S E T T I N G S

Boundary Settings
1 From the Physics menu open the Boundary Settings dialog box and remove the 

previous boundary condition on the well. To do so, go to the Boundary selection list 
and choose 2.

2 In the N0 edit field for Inward flux enter -(W+pi*rc^2*pt/(rhof_esdl*g_esdl))/
(2*pi*rw*b). Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 To solve the wellbore storage model, go to the menu item Solve>Solver Parameters 
dialog box and change the output time expression in the Times edit field to 0 
logspace(-3,2,101).

2 Solve the model as before by clicking the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The steps to generate Figure 2-12 follow the instructions outlined for Figure 2-11 in 
the previous model.

It is advisable to regenerate the original solution for the plot. To do so, go to the 
Options>Constants dialog box, change the rc value to zero, then solve the problem.

To generate Figure 2-13, follow these steps:

1 From the Postprocessing menu open the Cross-Section Plot Parameters dialog box. 
Click the Point tab, go to the y-axis data area, and check that the value in the 
Expression edit field is drawdown; if not, enter it. In the Coordinates: r edit field enter 
0.1. Click Apply.

2 To add results from a number of simulations for different well casing radii rc, click 
the General tab and select the Keep current plot check box. 

3 Now you change the value of rc for a given run and then solve and add the results 
of that simulation to the plot. Then repeat. For example, select the menu item 
Options>Constants and first change rc to 0. Click Apply. Then you solve as before and 

NAME EXPRESSION DESCRIPTION

rc 0.15[m] Radius of the well casing
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plot the results for each solution. This example uses rc = 0, 0.1, 0.15, 0.2, 0.25, and 
0.3.

4 Click OK.
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Pe r f o r a t e d  We l l

Analysis of fluid flow into wells often begins with the assumption that the intake of 
fluid is uniform along the entire length of wellbore. This assumption runs into trouble 
when applied to the modeling of perforated wells. When engineers emplace these wells 
they line a deep bore hole with impermeable materials. Later a machine pierces the 
lining so the well takes in fluids in the productive reservoir zones and nowhere else. 
The perforations are relatively small, typically less than 0.5 m long and with a diameter 
of less than 5 cm. They are typically oriented at regular intervals cycling down the 
casing axis.

Figure 2-14: Meshed model geometry (radius 6 m, height 0.3 m) with a close-up view of 
the wellbore (radius 0.1 m, height 0.3 m) with cylindrical perforations. (The geometry and 
mesh are from Dr. M. Jamiolahmady, Institute of Petroleum Engineering, Heriot-Watt 
University.)

The ability to describe how fluids funnel into tiny perforations oriented about a 
wellbore is the subject of a rapidly growing number of analyses including those in Ref. 
1, Ref. 2, and Ref. 3. Because the perforations are isolated piercings as opposed to 
rings, the flow field is not suited for axisymmetric analyses—fully 3D simulations are 
required.

This model characterizes 3D flow to a perforated well using the Darcy’s Law 
application mode. The analysis is based on a geometry contributed by the Institute of 
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Petroleum Engineering at Heriot-Watt University. Dr. Jamiolahmady, an expert in 
non-Darcy flow, used a MATLAB script to produce and mesh incrementally different 
geometries for iterative simulation and analyses. The script is available for you to use 
and modify (get it from your COMSOL customer service representative), although 
you can also build the geometry using the COMSOL Multiphysics graphical user 
interface. Readers interested in applying an iterative simulation approach can employ 
parametric solutions in COMSOL Multiphysics or scripting with MATLAB.

This example demonstrates several useful COMSOL Multiphysics features. Included 
are instructions for using Lagrange multipliers to calculate a high-accuracy flux on a 
relatively low density mesh. The model also shows how to set up boundary-integration 
coupling variables to automate flux calculations. The following sections provide an 
overview of the model, and following it come tabulated on parameter values.

Model Definition

In this model, a well sits at the center of a thin (roughly 0.25 m), horizontal 
production reservoir that is confined above and below by impermeable units 
(Figure 2-14). For simplicity, the producing zone is homogeneous and isotropic with 
respect to permeability and porosity, and the oil has constant density and viscosity. The 
geometry is a reach of reservoir with a radius of approximately 6 m, which by design 
is 60 times greater than the well radius of 0.1 m. The model assumes that the oil 
moving into the well comes uniformly from the reservoir circumference, and the 
pressure is known at all perforations. Pumping proceeds initially at a given rate. The 
withdrawals come strictly through the perforations. This example contains an analysis 
of a steady flow field.

Darcy’s law defines the velocity in the continuity equation that governs this problem. 
For a dependent variable of pressure, the governing equation reads

where κ is permeability (m2); η represents dynamic viscosity (kg/(m·s)); ρf is the fluid 
density (kg/m3); g equals the acceleration of gravity (m/s2); D denotes the coordinate 
for vertical elevation (m); and Qs is the volumetric flow rate per unit volume of 
reservoir for a fluid source (1/s).

At steady state, the flux through the circumference of the reservoir must satisfy the 
withdrawal at the well. Described by Darcy’s law, the flux is

∇ κ
η
---∇ p ρf gD+( )–⋅ Qs=
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where W is the volumetric pumping rate (1/(m3·s)); rres gives the reservoir radius 
(m); and b is the length of the well interval that takes in fluids (the so-called production 
interval).

Because all other boundaries are impermeable to flow, the boundary conditions are

where n is the normal to the boundary.

COMSOL Multiphysics Implementation—Boundary Flux

In this model you calculate the flux through the perforations using boundary 
integration-coupling variables. You can perform integration as a postprocessing step 
from the COMSOL Multiphysics menus, but creating the variables automates the 
calculations and also makes the results available for plotting.

Integration coupling variables give the value of an integral over a boundary, a 
subdomain, or a point (the source domain); they also transmit the information from 
one domain to, for example, other boundaries, subdomains, and points (the 
destination domain). You calculate the total flux through all of the perforation 
boundaries with the relationship

where Ω represents the boundary. This equation takes the absolute value because the 
flux is everywhere an outflow, but the normals to the perforations do not all point in 
the same direction. To know more about the normals to boundaries, consider the 
following. In a simple model geometry, such as a rectangle, it is straightforward that 
the normals should point outward. If you add a complicated geometry inside the 
rectangle, where should the normals point? There is no unambiguously universal rule. 

κ
η
--- ∇p( )–

W
2πrresb
---------------------=

n κ
η
--- ∇p( )⋅ W

2πrresb
---------------------–= Ω rres∂

p pwell= Ω perforations∂

n κ
η
--- ∇p( )⋅ 0= Ω casing∂

n κ
η
--- ∇p( )⋅ 0= Ω confining layer∂

flux n κ
η
---∇p⋅ Ω∂∫∑=
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You can visualize normals to boundaries by plotting them as arrows—specify nx, ny, 
and nz in the vector expression fields for boundary arrows as a postprocessing option.

COMSOL Multiphysics Implementation—High-Accuracy Flux 
Computation

You will find that the flux calculated as outlined above does not match the expected 
pumping rate. This discrepancy results from using a low-density mesh. You might try 
to a achieve a high-accuracy flux by zooming in on the region of interest with finer 
elements. However, that reasoning applied to the tiny perforations amounts to a good 
formula for a bad hit in needless computational cost.

You often can get a high-accuracy flux and save on computation time using the 
Lagrange multipliers µ that COMSOL Multiphysics generates through an integral or 
weak PDE form. The Lagrange multiplier takes on the value of the flux at boundaries 
with strong constraints that assign the same pressure everywhere along the perforation 
edges. To access the Lagrange multipliers in this problem, use the non-ideal weak 
constraints at the boundaries of the perforations. With the weak constraints, the 
boundary pressure integral over the element is constrained, rather than pointwise in 
the Lagrange points. Furthermore, a high accuracy flux can be accessed at the element 
boundary. Now you can calculate the flux with the boundary integration described 
above, except that you replace the normal equation for a boundary flux with the 
Lagrange multiplier µ. To find out more, see “Computing Accurate Fluxes” on page 
253 of the COMSOL Multiphysics User’s Guide.

Data

The data used in this model are as follows:

VARIABLE UNITS DESCRIPTION VAN GENUCHTEN

gr m/s2 Gravity 9.82

ρf kg/m3 Fluid density 900

ηf Pa·s Dynamic viscosity 0.002

κ m2 Permeability 10-11

θs Porosity/void fraction 0.2

hwell m Thickness of reservoir 0.3048

rres m Reservoir radius 6.5722

rw m Well radius 0.1095
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Results

Figure 2-15 shows the solution for oil flow to a well centered at the origin. From this 
view, the pressure distribution and velocity field appear uniform. Note that the velocity 
is almost constant in the far field.

Figure 2-15: COMSOL Multiphysics solution of Darcy flow to a perforated wellbore: 
pressure (isosurface), velocity field (slice), and velocities (arrows).

Figure 2-16 gives a close-up view of the velocity field (wire-mesh isosurfaces) and 
pressure distribution (slice) immediately around the perforations in the well. The 
velocity results in Figure 2-16 are clearly nonuniform. The flow funnels to the 
perforations produce an antisymmetric swirl over the length of the wellbore. 
Comparing the pressure estimates in Figure 2-16 with those in Figure 2-15 indicates 

W m3/s Pumping rate 0.001

pwell Pa Pressure at perforations 105

VARIABLE UNITS DESCRIPTION VAN GENUCHTEN
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that the nonuniformity produced by the perforations covers a relatively small section 
of the flow field.

Figure 2-16: Close-up view of flow to a perforated wellbore: pressure (slices) and velocity 
field (wire-mesh isosurface).

To evaluate the accuracy of the simulation, compare the total flux through the 
perforations with the known pumping rate of 0.001 m3/s. With the relatively coarse 
mesh (still with 40,000 elements), ordinary boundary integration gives a flux of 
0.0014 m3/s. A calculation in COMSOL Multiphysics with Lagrange multipliers, 
however, gives a flux of 0.00102 m3/s. Adding the Lagrange multipliers improves the 
accuracy of the calculation to within 0.01% of the known pumping rate without 
increasing computational overhead.
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Figure 2-17: Estimates of fluid flux to perforations in a wellbore.

Figure 2-17 depicts the flux to individual perforations. With this geometry and 
orientation, a given perforation withdraws anywhere from 22% to 28% of the total 
pumping. The perforations closest to the impermeable confining units (above and 
below) withdraw significantly less fluid from the reservoir than those near the 
horizontal center line of the producing layer. This leads to the economically significant 
conclusion that changes in the orientation change the producing capability of a 
perforation by 6%.
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Model Library path: Earth_Science_Module/Fluid_Flow/perforated_well

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator, and from the Space dimension list select 3D.

2 From the list of application modes select 
Earth Science Module>Fluid Flow>Darcy’s Law>Pressure analysis.

3 Click OK.

G E O M E T R Y  M O D E L I N G

1 Draw three cylinders by going to the Draw menu, selecting Cylinder and entering 
these settings:

2 Draw four small cylinders using the following data:

3 Go to the Draw toolbar on the left side of the user interface and click the Create 

Composite Object button.

4 In the Set formula edit field enter the following expression: 
CYL1+CYL2-(CYL3+CYL4+CYL5+CYL6+CYL7); when done, Click OK.

NAME CYL1 CYL2 CYL3

Radius 6.5722 1.0954 0.1095

Height 0.3048 0.3048 0.3048

NAME CYL4 CYL5 CYL6 CYL7

Radius 0.0254 0.0254 0.0254 0.0254

Height 0.1857 0.1857 0.1857 0.1857

Axis  
base point

[0 0 0.0381] [-0.1857 0 0.1905] [0 0 0.1143] [0 -0.1857 

Axis  
direction vector

[1 0 0] [1 0 0] [0 1 0] [0 1 0]
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O P T I O N S  A N D  S E T T I N G S

1 From the Physics menu select Scalar Variables.

2 In the resulting dialog box enter the following names and expressions.

3 From the Options menu open the Constants dialog box.

4 Enter the following names, expressions, and descriptions (optional); when done, 
click OK.

5 From the Options menu select Integration Coupling Variables>Boundary Variables. In 
the dialog box, create these boundary integration coupling variables, each on a 
separate row in the table; when done, click OK.

P H Y S I C S  S E T T I N G S

Application Mode Properties
1 From the Physics menu, select Properties.

NAME EXPRESSION

g_esdl 9.82

D_esdl z

NAME EXPRESSION DESCRIPTION

p_well 100[kPa] Pressure at perforations

W 0.001[m^3/s] Pumping rate

r_res 6.5722[m] Reservoir radius

h_well 0.3048[m] Thickness of reservoir

k_int 1e-11[m^2] Permeability

eta 0.002[Pa*s] Dynamic viscosity

rho_f 900[kg/m^3] Fluid density

r_well 0.1095[m] Well radius

SOURCE BOUNDARY 
SELECTION

NAME EXPRESSION INTEGRATION 
ORDER

GLOBAL 
DESTINATION

9–13, 16–21, 24, 
25, 28, 29, 32-36

flux abs(flux_esdl) 4 yes

16–18, 24, 25 lmflux1 abs(lm1) 4 yes

9–13 lmflux2 abs(lm1) 4 yes

19–21, 28, 29 lmflux3 abs(lm1) 4 yes

32–36 lmflux4 abs(lm1) 4 yes
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2 Select On in the Weak constraints list and Non-ideal in the Constraint type list, then 
click OK.

Subdomain Settings
1 Choose Physics>Subdomain Settings.

2 Select all active subdomains. In the Storage term list change Specific storage to User 

defined.

3 Enter the following material properties; when done, click OK.

Boundary Conditions
From the Physics menu, open the Boundary Settings dialog box, then enter the 
following settings; when done, click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, open the Free Mesh Parameters dialog box.

2 In the Predefined mesh sizes list select Fine.

3 Click the Subdomain tab.

4 In the Subdomain selection list choose 2.

5 Set the Maximum element size to 0.01, then click OK.

6 Click the Initialize Mesh button on the Main toolbar.

C O M P U T I N G  T H E  S O L U T I O N

1 From the Solve menu, open the Solver Parameters dialog box.

VARIABLE SUBDOMAINS 1, 2

S 0

Ks k_int

ρf rho_f

η eta

Qs 0

SETTINGS BOUNDARIES 1, 2, 22, 31 BOUNDARIES 9–13, 16–21, 
24, 25, 28, 29, 32–36 

ALL OTHERS

Type Inward flux Pressure Zero flux/Symmetry

N0 W/(2*pi*r_res*h_well) - -

p0 - p_well -
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2 The default solver cannot handle the weak constraints. Therefore go to the Linear 

system solver list and select GMRES, then go to the Preconditioner list and select 
Incomplete LU. Click OK.

3 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To create Figure 2-15 on page 45, follow these steps:

1 From the Postprocessing menu, open the Plot Parameters dialog box.

2 On the General page, go to the Plot type area and select the check boxes for Slice, 
Isosurface, and Arrow.

3 Click the Isosurface tab. On the Isosurface Data page, choose Pressure from the 
Predefined quantities list. Go to the Isosurface levels area, click the Vector with 

isolevels option button, and in the corresponding edit field enter 5e4:5e4:5.5e5.

4 Click the Slice tab. In the Slice data area, select Velocity field from the Predefined 

quantities list. In the Slice positioning area, in both the x levels and y levels edit fields 
enter 1, and in the z levels edit field enter 0.

5 Click the Arrow tab. On the Subdomain Data page, select Velocity field from the 
Predefined quantities list. In the Arrow positioning area, in both the x points and y 
points edit fields enter 15, and in the z points edit field enter 1.

6 In the Arrow parameters area, click the Color button. In the Arrow Color dialog box, 
select black, then click OK.

7 Clear the Auto check box for the Scale factor and in the associated edit field type 0.5.

8 Click OK.

To create Figure 2-16 on page 46, follow these steps:

1 From the Postprocessing menu open the Plot Parameters dialog box.

2 Go to the General page, and in the Plot type area clear the Arrow check box.

3 Click the Isosurface tab. On the Isosurface Data page, change the selection in the 
Predefined quantities list to Velocity field.

4 In the Isosurface levels area, click the Number of levels option button, then type 30 
in the associated edit field.

5 In the Coloring and fill area, select Wireframe from the Fill style list.

6 In the Isosurface color area, select hot from the Colormap list.

7 On the Slice page, change the selection in the Predefined quantities list to Pressure.

8 Click OK.
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9 Click the Zoom In button on the Main toolbar five times to zoom in on the wellbore. 
Click and drag in the drawing area to adjust the view.

To create Figure 2-17 on page 47, follow these steps:

1 Go to Options>Expressions>Boundary Expressions and define a boundary expression 
variable, lmflux, according to:

2 From the Solve menu select Update Model to update the model with the new 
expression variable.

3 From the Postprocessing menu, open the Plot Parameters dialog box.

4 On the General page, go to the Plot type area and select the check boxes for Boundary 
and Geometry edges.

5 Click the Boundary tab. In the Expression edit field, type p. 

6 In the Boundary color area, select hot from the Colormap list.

7 Click OK.

BOUNDARY SELECTION NAME EXPRESSION 

16–18, 24, 25 lmflux lmflux1

9–13 lmflux lmflux2

19–21, 28, 29 lmflux lmflux3

32–36 lmflux lmflux4
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Coup l e d  F l ow L aw s

Understanding what happens during the transition from slow flow in porous media to 
fast flow in a channel is critical in many environmental cases and applied questions. This 
type of flow appears near rivers, estuaries, wellbores, caverns, and lava tubes, to name 
a few.

Traditionally, the quantitative assessment of transitioning flows has been the domain 
of those with time and tools to work out their own code because it requires switching 
between mathematical expressions for different flow laws. Darcy’s law describes slow 
flow at a distance from the channel; the Navier-Stokes equations govern free or 
open-channel flows; and in between, where the fluid moves in porous media but shear 
is nonnegligible, the Brinkman or Forcheimer equations apply. This example 
demonstrates how to model such a transition using predefined equations in the Earth 
Science Module.

The following model examines transitioning flow by zooming in on oil movement to 
and within a perforated well. The analysis begins by coupling Darcy’s law and the 
Brinkman equations to represent flow in porous media that quickens toward a 
perforation in the well casing. Next, it examines fluid movement into and within the 
well by coupling the Navier-Stokes equations to the Darcy-Brinkman model. Albeit 
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counterintuitive, time-dependent Brinkman and Navier-Stokes are well known to be 
relatively easy to solve. This model instead analyzes a steady-state system.

Figure 2-18: Model geometry showing boundary conditions for coupling Darcy’s law (1 m 
< r < 4 m) and the Brinkman equations (0.1 m < r < 1 m).

By giving you the ability to link flow laws, modify predefined equations, and even 
freely define your own governing equations, COMSOL Multiphysics sees abundant 
use in analyzing conventional, coupled, and nonconventional flows (see Ref. 1 and 
Ref. 2).

Darcy-Brinkman: Model Definition

This Darcy-Brinkman example begins by overviewing the model setup and continues 
with the equations and the boundary conditions used in the analysis. Implementation 
details follow the mathematical background. The model triggers weak variables to 
implement the coupling between Darcy’s law and the Brinkman equations. Finally this 
discussion reviews results and outlines the mechanics for building the model. The next 
example (Transitional Flow: Darcy-Brinkman–Navier-Stokes on page 69) adds the 
Navier-Stokes equations directly on top of the Darcy–Brinkman model file.

First examine a general description of the Darcy–Brinkman model. Oil moves through 
a thin porous layer towards a perforation to a well. The fluid flow follows Darcy’s law 
in the far field (that is, 1 m < x < 4 m) and the Brinkman equations near the well 
opening (between 0.1 m < x < 1 m). The layer is 0.875 m thick and bounded above 
and below by impermeable materials that confine the permeable reservoir layer. For 
simplicity, assume the layer has homogeneous and isotropic hydraulic properties, and 
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the fluid has constant density and viscosity. You know the flux of fluid at the inlet and 
the pressure at the perforations. The flow field is steady state.

Darcy’s Law

Darcy’s law describes fluid flow driven by gradients in pressure and elevation potential. 
The dependent variable in Darcy’s law is pressure, p. The flows are slow enough that 
velocity head is negligible. For a steady state, the governing equation is

.

In this equation, κ denotes the permeability (m2), η is the dynamic viscosity (kg/
(m·s)), ρf gives the fluid density (kg/m3), and g the acceleration of gravity. Further, D 
is the coordinate for vertical elevation, and Qs is the volumetric flow rate per unit 
volume of reservoir for a fluid source (1/s). You set D to zero in this problem because 
elevation potential is negligible given that the flow field is very thin. Because this 
model deals with multiple flow laws, this equation appends the “dl” subscript to p to 
denote the Darcy’s law equation.

With a steady state, flow into the reservoir study area must equal the pumping rate. 
The Darcy velocity gives the inlet condition as 

where W is the volumetric pumping rate for the perforated interval (1/(m3·s)), rres 
equals the reservoir radius, and b is the reservoir thickness.

For a continuous solution across the interface between the zones of Darcy and 
Brinkman flow, the pressure and velocities from Darcy’s law must equal the pressure 
and velocities from the Brinkman equations. Because a Neumann statement on flux 
already defines the inlet boundary, use the following constraint on pressure for the 
Darcy–Brinkman interface:

.

In this equation, the subscript “br” denotes the Brinkman equations. This expression 
is a Dirichlet boundary statement.

With no flow through the confining units that overlie and underlie the permeable 
reservoir zone, the boundary conditions for Darcy’s law are

∇ κ
η
---∇ pdl ρf gD+( )–⋅ Qs=

udl
κ
η
---∇pdl–

W
2πrresb
---------------------= =

pdl pbr=
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where n is the normal to the boundary. 

Brinkman Equations

The Brinkman equations describe fluid flow in porous media where velocities are high 
enough that momentum transport by shear stress is important. Brinkman problems 
combine a momentum balance in the r and z directions with the continuity equation, 
giving dependent variables of directional velocities u and v as well as the pressure p. 
The Brinkman equations for steady state flow are

 (2-1)

where ρ is density (kg/m3), η gives the viscosity (kg/(m·s)) u equals the velocity vector 
(m/s), p is pressure (kg/(m·s)), ε is the porosity, and k (m/s) denotes the 
permeability. The equation can account for the influence of small gravity and 
compressibility effects in the force term, F, which in this example equals zero. Some 
argue that k in the Brinkman equations differs slightly from κ in Darcy’s law (Ref. 2), 
but this example calls for the same permeability in both flow zones.

From the Brinkman side of the Darcy–Brinkman interface you constrain velocity 
because the boundary condition on the Darcy side fixes the pressure. The velocity 
constraint on the Brinkman side of the interface reflects that velocities are dependent 
variables in the Brinkman equations but not in Darcy’s law. The boundary condition 
on velocities is

.

To implement the condition, use the Darcy velocities, udl, that COMSOL 
Multiphysics automatically calculates.

The confining layer and well casing are impermeable to flow. Approximate this 
situation with the no-slip condition

n κ
η
--- ∇pdl( )⋅ W

2πrresb
---------------------–= ∂Ω Inlet

pdl pbr= ∂Ω Darcy-Brinkman interface

n κ
η
--- ∇pdl( )⋅ 0= ∂Ω Confining layers

∇ η
ε
--- ∇ubr ∇ubr( )T

+( )⋅–⎝ ⎠
⎛ ⎞ η

k
---ubr ∇pbr F–+⎝ ⎠
⎛ ⎞– 0=

∇ ubr⋅ 0=

ubr udl=
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.

This equation eliminates all components of the velocity vector at the boundary.

Getting a unique solution to this problem requires defining the pressure at the well 
because the model prescribes flux conditions for all other boundaries. The constraint 
on pressure is the simple statement that

.

For the Brinkman problem, the boundary conditions are now

Implementation—Coupling with Weak Constraints

The two equations in this analysis are fundamentally compatible as both describe fluid 
flow, pressure distributions, and velocities. Even so, the dependent variable in Darcy’s 
law is pressure alone, whereas pressure and directional velocities are the dependent 
variables in the Brinkman equations. The difference in the number of dependent 
variables amounts to a slight incompatibility in form, which you circumvent by adding 
so-called non-ideal weak constraints on the equation system. The weak constraints 
provide new integral equations in which the Lagrange multipliers µ1 are dependent 
variables. The constraints add one Lagrange multiplier to Darcy’s law and two to the 
Brinkman equations to make up for the difference in the number of degrees of freedom 
given by the two governing equation systems on the boundaries. Adding the new 
Lagrange multipliers is easy—go to the Application Mode Properties dialog boxes, find 
the Weak constraints list, and select On. To make the weak constraints non-ideal, select 
Non-ideal from the Constraint type list.

To find out more about weak constraints and weak formulation equations, see “Using 
Weak Constraints” on page 300 in the COMSOL Multiphysics Modeling Guide.

ubr 0=

pbr pwell=

ubr udl= ∂Ω Darcy-Brinkman interface

ubr 0= ∂Ω Confining layers

ubr 0= ∂Ω Well casing

pbr pwell= ∂Ω Perforation.
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Data

The data for parameterizing the model are:

Results

Figure 2-19 shows the solution to the Darcy-Brinkman problem where Darcy’s law 
governs slow flow far from the well, but near it the Brinkman equations apply. The 
impacts of the switch between flow laws occurs at x = 1 m. The streamlines show the 

VARIABLE UNITS DESCRIPTION EXPRESSION

gr m/s2 Acceleration due to gravity 9.82

ρf kg/m3 Fluid density 900

ηf Pa·s Dynamic viscosity 0.002

ε Porosity 0.4

κ m2 Permeability 10-10

b m Thickness of layer 1

rres m Reservoir radius 4

rw m Well radius 0.1

W m3/s Pumping rate 10-3

pwell Pa Pressure at perforation 105
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fluid moving from the inlet at the right to the well on the left. The streamlines funnel 
because the flow is moving into a break or perforation in the well casing.

Figure 2-19: COMSOL Multiphysics solution for Darcy’s law (1 m < r < 4 m) and the 
Brinkman equations (0.1 m < r < 1 m). The results shown are pressure (surface plot and 
contours) and velocities (streamlines). Note that the vertical axis is expanded.

Figure 2-20 and Figure 2-21, respectively, illustrate the pressure and velocity estimates 
from the perforation to a distance of 2 m beyond the Darcy-Brinkman interface.These 
estimates vary smoothly across the Brinkman-Darcy interface. Pressure increases with 
distance from the well, and it moves the fluid to the perforation. The velocities 
decrease with distance from the well until they reach an almost constant value in the 
Darcy flow zone. The fact that the pressure estimates vary smoothly from Brinkman (r 
< 1) to Darcy (r > 1) flow indicates a stable solution.
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Figure 2-20: Pressure across the Darcy-Brinkman interface. Cross section along z = -0.5 m 
from r = 0.1 to 3.0 m.

Figure 2-21: Velocity across the Darcy-Brinkman interface. Cross section along z = -0.5 m 
from r = 0.1 to 3.0 m.
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This COMSOL Multiphysics example describes a straightforward protocol to couple 
two compatible flow laws with different dependent variables, the Darcy and Brinkman 
flow equations. Both Darcy’s law and the Brinkman equations characterize flow in 
porous media. Because Darcy’s law provides for no momentum transport by shear, it 
can overpredict flow rates in fast flow zones. Coupling to the Brinkman equations 
describes the added energy transformation.

The model is easy to modify and apply to a number of transitional flow scenarios 
including a river bottom, quickening flow near a well, and fluid moving in and around 
fractures. The next example adds the Navier-Stokes equations in the well to 
characterize the full transition between porous media and free surface flow.

References

1. M. Jamiolahmady, A. Danesh, D.H. Terhani, G.D. Henderson, and D.B. Duncan, 
“Flow around a rock perforation surrounded by damaged zone: Experiments vs. 
Theory,” IASME/WSEAS Int’l Conf., Corfu, Greece, 2004.

2. U. Shavit, R. Rosenzweig, and S. Assouline, “Free flow at the interface of porous 
surfaces: A generalization of the Taylor Brush configuration,” Transport in Porous 
Media, Kluwer Academic Publishers, 2003.

Model Library path: Earth_Science_Module/Fluid_Flow/darcy_brinkman

Modeling Using the Graphical User Interface

To begin the model, first add the Darcy’s Law and the Brinkman equation application 
modes to the model file.

M O D E L  N A V I G A T O R

1 Open the Model Navigator, and from the Space dimension list select 2D axisymmetry. 

2 In the list of application modes select  
Earth Science Module>Fluid Flow>Darcy’s Law>Pressure analysis>Steady-state analysis. 

3 In the Application mode name edit field change the name to dl. In the Dependent 

variables edit field enter pdl. 

4 Click the Multiphysics button, then click Add. Keep the window open.
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5 In the list of application modes select Earth Science Module>Fluid Flow>Brinkman 

Equations.

6 In the Application mode name edit field change the name to chbr. In the Dependent 

variables edit field enter ubr vbr pbr.

7 Click Add, then click OK.

G E O M E T R Y  M O D E L I N G

Create the geometry by drawing three rectangles and adding a line at the perforation.

1 From the Draw menu select Specify Objects>Rectangle. In the dialog box, specify 
these settings for the rectangles; in each case, when done, click OK.

2 Click the Zoom Extents button on the Main toolbar.

3 From the Draw menu select Specify Objects>Line. In the Coordinates: r edit field enter 
0.1 0.1; in the Coordinates: z edit field enter -0.45 -0.55. 

4 Click OK.

O P T I O N S  A N D  S E T T I N G S

These variables reference the different solutions for each subdomain.

Select the menu item Options>Constants and enter these names, expressions, and 
descriptions (optional); when done, click OK.

PARAMETER R1 R2 R3

width 0.1 0.9 3

height 1 1 1

r 0 0.1 1

z -1 -1 -1

NAME EXPRESSION DESCRIPTION

pwell 1e5[Pa] Pressure at perforation

W 1[l/s] Pumping rate

b 1[m] Layer thickness

perm 1e-10[m^2] Permeability

eta 0.002[Pa*s] Dynamic viscosity

rho 900[kg/m^3] Fluid density

rres 4[m] Reservoir radius
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P H Y S I C S

First set up the Darcy’s Law application mode, then follow up with the Brinkman 
equations.

Darcy’s Law Application Mode
1 In the Multiphysics menu select Darcy’s Law (dl).

2 Go to the menu item Physics>Subdomain Settings. Click the Coefficients tab. 
Deactivate the subdomain where the Brinkman equations apply; to do so, select 
Subdomains 1 and 2, then clear the Active in this domain check box.

3 Select Subdomain 3 and enter the settings from the following table in the user 
interface as shown.

4 Click the Init tab. In the Initial value edit field enter pwell.

5 Click OK.

TERM SUBDOMAIN 1

 κs perm

 ρf rho

 η eta
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6 From the Physics menu choose Boundary Settings. Enter the settings from the 
following table; when done, click OK.

7 From the Physics menu choose Properties. In the Weak constraints list select On and 
in the Constraint type list select Non-ideal; when done, click OK.

Brinkman Equations
1 In the Multiphysics menu select Brinkman Equations (chbr).

2 Go to the menu item Physics>Subdomain Settings. Click the Physics tab. Deactivate 
the subdomain where Darcy’s law and the Navier-Stokes equations applies; to do so, 
select Subdomains 1 and 3, then clear the Active in this domain check box.

SETTINGS BOUNDARY 9 BOUNDARY 12 BOUNDARIES 10, 11

Boundary condition Pressure Inward flux Zero flux/Symmetry

p0 pbr

N0 W/(2*pi*rres*b)
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3 Select Subdomain 2 and enter the following settings:

4 Click the Init tab. Enter the following settings; when done, click OK.

5 From the Physics menu choose Boundary Settings. Enter the following settings; when 
done, click OK.

6 From the Physics menu choose Properties. In the Weak constraints list choose On and 
in the Constraint type list select Non-ideal. Click OK.

TERM SUBDOMAIN 2 

 κs perm

εp 0.4

 η eta

 ρf rho

TERM SUBDOMAIN 2

ubr W/(2*pi*r*b)

vbr eps

pbr pwell

SETTINGS BOUNDARY 6 BOUNDARY 9 BOUNDARIES 4, 5, 7, 8

Boundary type Outlet Inlet Wall

Boundary condition Pressure, no 
viscous stress

Velocity No slip

p0 pwell

u u_dl

v v_dl
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M E S H  G E N E R A T I O N

The solution is sensitive to mesh size; the figures in this section arose from the 
following mesh setup.

1 From the Mesh menu select Free Mesh Parameters.

2 Click the Subdomain tab. Select Subdomain 2, then in the Maximum element size edit 
field enter 0.066. Select Subdomain 3 and specify a Maximum element size of 0.133.

3 Click the Boundary tab. Select Boundary 6 and in the Maximum element size edit field 
enter 0.005. Select Boundary 9 and specify a Maximum element size of 0.02.

4 Click OK.

5 Click the Initialize Mesh button on the Main toolbar.

We generated the figures for this chapter by also clicking Remesh, but note that 
doing so adds significant computational effort to the simulation.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

O P T I O N S  A N D  S E T T I N G S

A glance at the resulting figure indicates an incomplete view of the results—only those 
for Darcy’s law appears. To view the solutions for both application modes at the same 
time, set up a few postprocessing variables that reference the different solutions for 
each subdomain.

1 Choose the menu item Options>Expressions>Subdomain Expressions and create the 
following expressions for Subdomains 2 and 3; when done, click OK.

Here, visU displays the total velocity, visu displays the r-velocity, visv displays the 
z-velocity, and visp displays the pressure. As specified at the outset, the application 
mode name is chbr for the Brinkman equations and dl for Darcy’s law. When you 
reference an application mode variable, you give the application mode name as a suffix. 
For example, because velocity is not a dependent variable in the Darcy’s Law (dl) 
application mode but a variable COMSOL Multiphysics automatically creates for it, 

NAME SUBDOMAIN 2 SUBDOMAIN 3

visU U_chbr U_dl

visu ubr u_dl

visv vbr v_dl

visp pbr pdl
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use the suffix _dl to reference it. You do not reference the application mode name to 
reference the pressure pdl from Darcy’s law because it is a dependent variable.

2 For the variables to take effect, you must update the model. From the Solve menu 
select Update Model.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate the plot in Figure 2-19 on page 59:

1 Select the menu item Postprocessing>Plot Parameters.

2 Click the General tab. In the Plot type area select the Surface, Contour, Arrow, and 
Streamline check boxes to activate those plots. Clear the Geometry check box.

3 Click the Surface tab. On the Surface Data page, enter visp in the Expression edit 
field, in the process typing over the current information in the edit field. Go to the 
Surface color area, and in the Colormap list select hot.

4 Click the Contour tab. On the Contour Data page, enter visp in the Expression edit 
field, also here typing over the current information. In the Number of levels edit field 
enter 20. In the Contour color area click the Uniform color option button. Click the 
Color button, change the color to black, and then click OK.

5 Click the Streamline tab. On the Streamline Data page, type visu in the r component 
edit field and visv in the z component edit field.

6 Go to the Start Points page, click the Specify start point coordinates button. In the r 
edit field type 4 4 4 4 4 4 4 4. In the z edit field enter -0.85 -0.75 -0.65 
-0.55 -0.45 -0.35 -0.25 -0.15.

7 Click the Advanced button. In the Maximum number of integration steps edit field 
type 10000. In both the Integration tolerance and Stationary point stop tolerance edit 
fields type 0.00001. Click OK.

8 Click the Color button. Select the color black, then click OK.
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9 Click the Arrow tab. On the Subdomain Data page find the r edit field and enter visu, 
and in the z edit field enter visv.

10 In the Arrow positioning area click both Vector with coordinates option buttons. In 
the associated r points edit field, type  
3.5 3.5 3.5 3.5 3.5 3.5 3.5 3.5 2.5 2.5 2.5 2.5 2.5 2.5 2.5 2.5 1.5 

1.5 1.5 1.5 1.5 1.5 1.5 1.5 0.75 0.75 0.75 0.75 0.75 0.75 0.75 0.75.

11 In the corresponding z points edit field, type  
-0.85 -0.75 -0.65 -0.55 -0.45 -0.35 -0.25 -0.15 -0.85 -0.75 -0.65 

-0.55 -0.45 -0.35 -0.25 -0.15 -0.85 -0.75 -0.65 -0.55 -0.45 -0.35 

-0.25 -0.15 -0.85 -0.75 -0.65 -0.55 -0.45 -0.35 -0.35 -0.25.

12 Go to the Arrow parameters area. In the Arrow type list select cone, and in the Arrow 

length list select Normalized. Click the Color button, choose the uniform color black, 
and then click OK. Click OK to close the Plot Parameters dialog box and generate the 
plot.

To generate Figure 2-20 on page 60:

1 Select the menu item Postprocessing>Cross-Section Plot Parameters.

2 Click the Line/Extrusion tab. In the y-axis data area, type visp in the Expression edit 
field. In the Cross-section line data area, set r0 to 0.1, r1 to 3.0, and both z0 and z1 
to -0.5. Click Apply.

To generate Figure 2-21 on page 60:

1 Still on the Line/Extrusion page of the Cross-Section Plot Parameters dialog box, 
change the Expression in the y-axis data area to visU. Click OK.
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T r a n s i t i o n a l  F l ow :  Da r c y - B r i n kman–
Nav i e r - S t o k e s

This example characterizes a transition in flow regimes: slow flow in porous media 
quickens to a perforation in a well casing and ultimately moves into and up the well. 
Darcy’s law describes flow velocities at a distance from the well; closer to the 
perforation the Brinkman equations apply; the Navier-Stokes equations describe 
movement of fluid in the well. This example starts with a model that couples Darcy’s 
law with the Brinkman equations. Adding the Navier-Stokes equations in the wellbore 
produces a fully coupled simulation for three different flow laws.

Figure 2-22: Geometry and boundary conditions used in COMSOL Multiphysics to couple 
the Darcy’s law, Brinkman equations, and Navier-Stokes application modes.

The following pages describes the model. The first section reviews the Darcy, 
Brinkman, and Navier-Stokes equations and the boundary conditions. Next comes the 
solution procedure along with a data table. The final sections show results and gives 
step-by-step instructions for building the model in the COMSOL Multiphysics user 
interface.
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Model Definition

Figure 2-22 illustrates the geometry and equation coupling in this example. Flow 
moves from r = 4 m within a permeable reservoir zone and exits to a well. The fluid 
entering the well combines with fluids moving upward from a permeable reservoir layer 
below the one in the model. In the study area, Darcy’s law governs flow in the far field 
for r > 1 m. The Brinkman equations govern flow from the well casing at 0.1 m < r < 
1 m. The interface between the Darcy and Brinkman flow zones occurs at r = 1 m. 
Within the well at r < 0.1 m the Navier-Stokes equations apply. The interface between 
the Brinkman and Navier-Stokes flow zones is the perforation at the midpoint of the 
casing. Otherwise there is no flow across the casing.

The problem setup for this example is identical to the Darcy–Brinkman model from 
the previous pages except for the boundary condition at the perforation and details 
inside the well. The model is 2D axisymmetry, covering a permeable zone 1 m deep 
over a reservoir radius of 4 m. The Darcy–Brinkman example specified that flow at 
r = 4 m satisfies the pumping rate and gives the pressure at the perforation. In this 
example, let COMSOL Multiphysics solve for the fluid pressure at the perforation and 
instead fix the pressure at the top of the well. The layer is homogeneous, isotropic, thin 
(specifically, 0.875 m), bounded above and below by impermeable materials, and the 
fluid has constant density and viscosity. You know the pumping rate and the pressure 
at the outlet, and you seek a steady-state solution to the flow field.

Darcy’s Law

Darcy’s law describes fluid flow in porous media driven by gradients in pressure alone. 
You can neglect elevation gradients in this problem because the flow field is very thin. 
For flow at steady state, the governing equation is

where κ is permeability (m2), η equals the dynamic viscosity (kg/(m·s)), and Qs is the 
volumetric flow rate per unit volume of reservoir for a fluid source (1/s).

The interface between the zones governed by Darcy’s law and the Brinkman equations 
requires continuity in pressure and velocities. Because pressure is the dependent 
variable in Darcy’s law, the boundary condition at the Darcy–Brinkman interface is a 
constraint on pressure,

∇ κ
η
---∇pdl–⋅ Qs=

pdl pbr=
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where the subscripts “dl” and “br” refer to Darcy’s law and the Brinkman equations, 
respectively. 

The remaining boundary conditions include a constraint on velocity at the reservoir 
inlet and at the impermeable confining layer. At the inlet, it is sufficient to satisfy the 
pumping rate. There is no flow across the confining layer. The boundary conditions 
for the Darcy’s law problem are

where n is the normal to the boundary.

Brinkman Equations

The Brinkman equations describe flow during the transition from Darcy to 
Navier-Stokes laws. With dependent variables of directional velocities and pressure, the 
Brinkman equations are

 (2-2)

In the equations, ρ denotes fluid density (kg/m3), η is viscosity (kg/(m·s)), u 
represents the velocity vector (m/s), p is pressure (kg/(m·s)), ε is the porosity, and κ 
denotes the permeability (m2).

The Brinkman model constrains the velocity at the Darcy–Brinkman interface: the 
Brinkman velocity equals the Darcy velocity on the boundary. Except for the 
perforation, this example defines all other boundaries in the flow model with no-slip 
conditions, which is a statement about velocity. On the perforation, the model requires 
a condition that represents continuity in stress. The boundary conditions on the 
Brinkman flow zone are

n κ
η
--- ∇pdl( )⋅ W

2πrresb
---------------------–= ∂Ω Inlet

pdl pbr= ∂Ω  Darcy-Brinkman interface

n κ
η
--- ∇pdl( )⋅ 0= ∂Ω Confining layer

∇ η
ε
--- ∇ubr ∇ubr( )T

+( )⋅–⎝ ⎠
⎛ ⎞ η

κ
---ubr ∇pbr+⎝ ⎠
⎛ ⎞– 0=

∇ ubr⋅ 0.=
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Navier-Stokes Equations

The governing statement for flow in the wellbore comes from the Navier-Stokes 
equations, which combine a momentum balance with an equation of continuity:

The Navier-Stokes equations and the Brinkman equations solve for dependent 
variables u and p. The “ns” subscript denotes the Navier-Stokes equation.

From the Navier-Stokes model, the interface to the Brinkman flow zone is the 
constraint on velocity as in

.

This equation states that the velocity at the perforation just inside the well equals the 
velocity just outside of it. Linking the Navier-Stokes and Brinkman velocities 
completes a chain that interconnects three flow laws beginning at the Brinkman-Darcy 
interface. In the chain, pressures and velocities for coupled flow laws link on opposite 
sides of an interface.

The remaining boundaries in the Navier-Stokes problem are a series of constraints on 
velocity and pressure. Velocity in the well drops to zero at the well casing, which 
correspond to a no-slip condition. You also know the volume flow rate, Win, into the 
base of the well, the lower inlet. The well’s centerline is a symmetry condition. Finally, 
you know the pressure at the well’s upper outlet. In summary,

ubr udl= ∂Ω Darcy-Brinkman interface

ubr 0= ∂Ω Confining layers

ubr 0= ∂Ω Well casing

pbrI– η ∇u ∇u( )T
+( )+( )n 0= ∂Ω Perforation

∇ η ∇uns ∇uns( )T
+( )⋅– ρuns ∇⋅ uns ∇pns+ + 0=

∇ uns⋅ 0.=

uns ubr=
 2 :  F L U I D  F L O W  M O D E L S



Implementation: Navier-Stokes Initial Guess

Systems involving Navier-Stokes equations are notoriously sensitive to the initial guess, 
even for a steady-state flow model such as this one. In this example, the 
Darcy-Brinkman problem solves readily, but establishing a good initial conditions for 
the Navier-Stokes zone requires an extra measure. A series of dummy simulations with 
the parametric solver helps to obtain iteratively better guesses about the velocities and 
the pressures throughout the wellbore. The parameter that varies in the simulations is 
the fluid viscosity. You start with a viscosity several orders of magnitude higher than 
the true value and solve for decreasing viscosity values. You also can get a good initial 
guess for Navier-Stokes problems by varying velocity values with the parametric solver.

Implementation: Coupling with Weak Constraints

This model employs non-ideal weak constraints to facilitate the coupling of flow laws 
with different dependent variables. This manual provides a foundation on the use of 
non-ideal weak constraints in previous model description for the Darcy-Brinkman 
interface. Nonetheless, this section provides the following reminder.

This model couples three compatible flow laws with different dependent variables. In 
Darcy’s law the dependent variable is pressure alone, whereas pressure and directional 
velocities are dependent variables in the Brinkman and Navier-Stokes equations. To 
make up for the slight incompatibility of the equation forms, add non-ideal weak 
constraints to the equation system. The weak constraints add Lagrange multipliers that 
equalize the degrees of freedom between the three equation systems. You activate the 
non-ideal weak constraints by clicking an option in the Application Mode Properties 
dialog boxes. For more information about weak constraints and weak formulation 
equations, see “Using Weak Constraints” on page 300 in the COMSOL Multiphysics 
Modeling Guide.

uns ubr= ∂Ω Perforations

u 0= ∂Ω Casing

n u⋅
Win

πrwell2

------------------= ∂Ω Well inlet (lower)

n u⋅ 0= ∂Ω Well centerline
p pwell= ∂Ω Well outlet (upper)
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Data

The following table lists data used in this model:

Results

Figure 2-23 shows the solution to the model for flow that transitions from Darcy’s law 
in the far field (r > 1 m), to the Brinkman equations in the intermediate zone 
(0.1 m < r <1 m), to the Navier-Stokes equation in the well (r < 0.1 m). The pressure 
distribution (surface plot and contours) and velocities (arrows and streamlines) vary 
smoothly with no disruption at either the Darcy–Brinkman interface (r = 1) or the 

VARIABLE UNITS DESCRIPTION EXPRESSION

 gr m/s2 Acceleration due to gravity 9.82

 ρf kg/m3 Fluid density 900

 ηf Pa·s Dynamic viscosity 0.002

  κ m2 Permeability 1·10-10

ε Porosity 0.4

 b m Thickness of layer 0.875

 rres m Reservoir radius 4

 rwell m Well radius 0.1

 W m3/s Extraction rate from the modeled permeable 
zone

1·10-3

 Win m3/s Pumpage from underlying reservoirs moving 
through lower well inlet

1·10-4

 pwell Pa Pressure at well outlet 1·105
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Brinkman-Navier-Stokes interface (r = 0.1 m). The streamlines show fluid moving 
through the perforation and up the well.

Figure 2-23: Distribution of pressure (surface plot and contours) and velocities 
(streamlines). Fluid flow follows Darcy’s law (1 m < r < 4 m), the Brinkman equations 
(0.1 m < r < 1 m), and the Navier-Stokes equations (r < 0.1 m). The vertical axis is 
expanded for clarity.

In creating Figure 2-23 the author removed the pressure in the wellbore because it is 
almost uniform and disrupts the view of the streamlines. The small pressure drop in 
the well might seem disconcerting; however, it is reasonable and physically based. The 
well is an open channel. Within it a relatively small pressure drop can produce large 
volumetric flows because rocks do not impede fluid movement in the well.

Figure 2-24 is a close-up view of the velocity (surface plot) and pressure (contours) 
from the center of the well to r = 2 m. The figure covers the Navier-Stokes flow in the 
well, the Brinkman zone just beyond the well, and 1 m of the Darcy’s law flow zone. 
Simulating the rapid velocity change in the well requires a good initial condition. In 
COMSOL Multiphysics you can obtain a good estimate for the distribution of starting 
velocities with a quick series of dummy simulations without the need to switch model 
files.
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Figure 2-24: Close-up view of velocities (surface plot) and pressures (contours) within and 
near the wellbore. Fluid flow follows Darcy’s law (1 m < r), the Brinkman equations 
(0.1 m < r < 1 m), and the Navier-Stokes equations (r < 0.1 m). The vertical axis is 
expanded for clarity.

Figure 2-25 shows the pressure along a cross section beginning in the well 
(Navier-Stokes) and ending a small distance beyond the well casing (Brinkman). The 
pressure is almost constant within the well because the flow in the well is vertical. The 
pressure rises smoothly beyond the Brinkman-Navier-Stokes interface. It is this 
pressure gradient that drives fluid into the well perforation.
 2 :  F L U I D  F L O W  M O D E L S



Figure 2-25: Pressure distribution at z = -0.5 m along the line r = 0.05 to 0.5 m.

Figure 2-26 provides a cross section of total velocity over the full transition between 
three different flow laws. It shows high velocities at the center of the well and no break 
in the profile at either the Brinkman-Navier-Stokes interface at r = 0.1 m or at the 
Darcy-Brinkman interface at r = 1 m.

Figure 2-26: Velocity distribution at z = -0.5 m along the line r = 0.05 to 3.0 m.
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This example demonstrates modeling of flows that transition through three different 
governing equations: the Navier-Stokes equations for free flow, the Brinkman 
equations for fast porous media flow, and Darcy’s law for slow flow where you do not 
expect any energy dissipation by shear. This particular model describes the 
transitioning flow to a well, but the concept applies to many other environmental and 
applied scenarios including rivers, tubes, pipes, and springs. In the past, the transition 
between flow laws has often been the domain of academic research efforts because 
most off-the-shelf software packages focus on one flow type or another. COMSOL 
Multiphysics, though, can link together a number of different flow equations.

Model Library path: Earth_Science_Module/Fluid_Flow/darcy_brinkman_ns

Modeling Using the Graphical User Interface

To begin the model, first open the Darcy-Brinkman example and add the 
Navier-Stokes equations to the model file.

M O D E L  N A V I G A T O R

1 Open the Model Navigator and click the Model library tab. From the model tree select 
Earth Science Module>Fluid Flow>darcy brinkman. Click OK.

2 After the model loads, go to the Multiphysics menu and select Model Navigator.

3 In the list of application modes select Earth Science Module>Fluid 

Flow>Incompressible Navier-Stokes equations. In the Application mode name edit field 
replace the existing text by entering ns, and in the Dependent variables edit field 
replace the existing text with uns vns pns. Click Add.

4 Click the Application Mode Properties button. Choose On in the Weak constraints list 
and Non-ideal in the Constraint type list. Click OK.
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5 Click OK to close the Model Navigator.

A P P L I C A T I O N  S C A L A R  V A R I A B L E S

There are no scalar variables to check with the Navier-Stokes application mode.

O P T I O N S  A N D  S E T T I N G S

1 Several variables reference the different solutions for each subdomain. To set them 
up, go to the menu item Options>Constants.

2 Enter the following names, expressions, and descriptions (optional); when done, 
click OK.

3 For viewing the entire solution, add the Navier-Stokes results to the processing 
variables that already reference the Darcy’s law and Brinkman results in 
corresponding subdomains. To do so, go to the menu item 
Options>Expressions>Subdomain Expressions. In the resulting dialog box enter the 
following expressions for the three subdomains; when done, click OK.

In this table, visU describes total velocity, visu is the x-velocity, visv gives the 
y-velocity, and visp is the pressure. The application mode name is chns for the 
Navier-Stokes equations, chbr for the Brinkman equations, and dl for Darcy’s law. 
No suffix is needed to reference the dependent variable in an equation. For 
calculated variables the application mode name is a suffix. For example, because 
velocity is not a dependent variable in the Darcy’s law application mode but is a 
variable automatically created for it, reference it with the suffix _dl.

P H Y S I C S

Set up the Navier-Stokes application mode and solve it for a dummy simulation.

NAME EXPRESSION DESCRIPTION

rwell 0.1[m] Well radius

Win W/10 Pumpage from underlying reservoirs 
moving through lower well inlet

NAME SUBDOMAIN 1 SUBDOMAIN 2 SUBDOMAIN 3

visU U_chns U_chbr U_dl

visu uns ubr u_dl

visv vns vbr v_dl

visp pns pbr pdl
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Navier-Stokes Application Mode
1 From the Physics menu select Subdomain Settings.

2 Click the Physics tab. Deactivate the subdomains where the Brinkman equations 
apply; to do so, select Subdomains 2 and 3, then clear the Active in this domain check 
box.

3 Select Subdomain 1. In the η edit field for Dynamic viscosity enter 2*damp, and in 
the ρ edit field for Density enter rho.

4 Click the Init tab. Enter the following settings; when done, click OK.

5 From the Physics menu choose Boundary Settings. For the various boundaries enter 
the settings from the following table; when done, click OK.

TERM SUBDOMAIN 1

uns eps

vns W/(pi*rwell^2)

pns pwell

SETTINGS BOUNDARY 1 BOUNDARY 2 BOUNDARY 3 BOUNDARY 6 BOUNDARIES 4, 7

Boundary 
type

Symmetry 
boundary

Inlet Outlet Inlet Wall

Boundary 
condition

Axial 
symmetry

Velocity Pressure, no 
viscous stress

Velocity No slip

p0 pwell
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In the previous table, s is the arc length of a boundary, which goes from 0 at the 
start point to 1 at the end point. COMSOL Multiphysics denotes the end point with 
an arrow on the boundary. Use s to give a parabolic velocity profile at the well inlet.

Brinkman Equations
1 From the Multiphysics menu select Brinkman Equations (chbr).

2 From the Physics menu select Boundary Settings. Select Boundary 6. Select the 
Boundary type Outlet and the Boundary condition Pressure. In the p0 edit field for 
Pressure enter pns. Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu select Free Mesh Parameters.

2 Click the Subdomain tab. Select Subdomain 1, then in the Maximum element size edit 
field enter 0.02. Select Subdomain 2, then in the Maximum element size edit field 
enter 0.066. Select Subdomain 3 and specify a Maximum element size of 0.133.

u0 eps ubr

v0 (-s^2+1)*2*Win
/(pi*rwell^2)

vbr

SETTINGS BOUNDARY 1 BOUNDARY 2 BOUNDARY 3 BOUNDARY 6 BOUNDARIES 4, 7
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3 Click the Boundary tab. Select Boundary 6 and in the Maximum element size edit field 
enter 0.005. Select Boundary 9 and specify a Maximum element size of 0.02.

4 Click the Point tab. Select Points 4 and 5, then in the Maximum element size edit field 
enter 0.001. For Growth rate enter 1.1.

5 Click OK.

6 Click the Initialize Mesh button on the Main toolbar.

C O M P U T I N G  T H E  S O L U T I O N

To solve the model, first clear the old solution then iterate to solve the 3-way coupled 
problem.

1 Go to the Solve menu and return to the Solver Parameters dialog box. From the 
Solver list, click Parametric. For Parameter name enter damp. For Parameter values 
enter 0.1 0.01 0.005 0.0025 0.001. Click OK.

2 Click the Start button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate the plot in Figure 2-23 on page 75 follow these steps:

1 From the Postprocessing menu open the Plot Parameters dialog box. 

2 Click the General tab. In the Plot type area click the Surface, Contour, and Streamline 
check boxes. Clear the Geometry check box.

3 Click the Surface tab. On the Surface Data page, enter visp in the Expression edit 
field, typing over the current information. In the Surface color area, find the 
Colormap list and select hot.

4 Click the Contour tab. On the Contour Data page, enter visp in the Expression edit 
field, again typing over current information. In the Contour levels area, enter 20 in 
the Number of levels edit field. Proceed to the Contour color area. Click first the 
Uniform color option button and then the Color button. Choose black, then click OK.

5 Click the Streamline tab. On the Streamline Data page, enter visu and visv in 
r component and z component edit fields, respectively. On the Start Points page, click 
the Specify start point coordinates option button. In the r component edit field enter 
0.02 0.04 0.06 0.08 4 4 4 4 4 4 4 4, and in the z component edit field enter 
-1 -1 -1 -1 -0.85 -0.75 -0.65 -0.55 -0.45 -0.35 -0.25 -0.15. Click 
the Advanced button. In the Maximum number of integration steps edit field enter 
10000. In both the Integration tolerance and the Stationary point stop tolerance edit 
fields enter 0.00001, then click OK. Click the Color button, set the color to black, 
and then click OK.
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6 Click the Arrow tab. On the Subdomain Data page enter visu in the r component edit 
field and visv in the z component edit field. In the Arrow positioning area click both 
Vector with coordinates option buttons.

7 In the edit field associated with r points enter 
3.5 3.5 3.5 3.5 3.5 3.5 3.5 3.5 2.5 2.5 2.5 2.5 2.5 2.5 2.5 2.5  

1.5 1.5 1.5 1.5 1.5 1.5 1.5 1.5 0.75 0.75 0.75 0.75 0.75 0.75 0.75 

0.75.

8 In the edit field associated with z points enter  
-0.85 -0.75 -0.65 -0.55 -0.45 -0.35 -0.25 -0.15 -0.85 -0.75 -0.65 

-0.55 -0.45 -0.35 -0.25 -0.15 -0.85 -0.75 -0.65 -0.55 -0.45 -0.35 

-0.25 -0.15 -0.85 -0.75 -0.65 -0.55 -0.45 -0.35 -0.35 -0.25.

9 In the Arrow parameters area find the Arrow type list and select Cone. In the Arrow 

length list select Normalized. Click the Color button, set the color to black, and then 
click OK.

10 Click OK to close the Plot Parameters dialog box and generate the plot.

To generate Figure 2-24 on page 76, continue with these steps:

1 From the Postprocessing menu select Plot Parameters. 

2 On the General page, clear the Streamline and Arrow check boxes.

3 Click the Surface tab. On the Surface Data page, enter visU in the Expression edit 
field, typing over the current information. Go to the Surface color area, and in the 
Colormap list choose jet.

4 Click the Contour tab. On the Contour Data page, enter visp in the Expression edit 
field, typing over the current information. In the Contour levels area, enter 10 in the 
Number of levels edit field. In the Contour color area, click first the Uniform color 
option button, then click the Color button. Change the color to white, then click OK.

5 Click OK to close the Plot Parameters dialog box.

6 Use the Zoom Window tool on the Main toolbar to zoom in on the area of interest.

To generate Figure 2-25 on page 77, continue with these steps:

1 Select the menu item Postprocessing>Cross-Section Plot Parameters.

2 Click the Line/Extrusion tab. In the y-axis data area, enter visp in the Expression edit 
field. In the Cross-section line data area, set r0 to 0.05, r1 to 0.5, and both z0 and 
z1 to -0.5. Click Apply.

To generate Figure 2-26 on page 77, continue with these steps:
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3 In the y-axis data area, change the Expression to visU.

4 In the Cross-section line data area, change r1 to 3.0. Click OK.
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D i s c r e t e  F r a c t u r e—Porou s  Med i a  
F l ow

Fluids in fractured porous media move quickly through the fractures but also migrate, 
albeit relatively slowly, through the tiny pores within the surrounding matrix blocks. 
Some fluid transfers between the fractures and the matrix blocks, so fluid pressures are 
continuous across the fracture from block to block. Accurately predicting fracture and 
matrix flow is often critical to assessing well productivity, to delineating migrating 
pollution, and to designing pollution cleanup strategies, to name just a few uses. 

This example demonstrates a new efficient and accurate method to jointly model the 
fracture and matrix flows in a fractured block. You build it by representing the fractures 
as the boundaries between adjacent matrix blocks (Figure 2-27). Darcy’s law governs 
velocities in the matrix blocks, while you set up flow in the fractures on boundaries by 
accounting for the fracture’s thickness. Representing the fracture as an interior 
boundary is especially efficient because it eliminates the need to create a geometry with 
a high aspect ratio with a very long and narrow fracture domain that otherwise would 
require a dense mesh consisting of great number of tiny elements. 

Figure 2-27: Geometry for a COMSOL Multiphysics analysis of a discrete fracture.
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Model Definition

The geometry in Figure 2-27 is a block of fractured porous media that measures 1 m 
on each side. The fracture is far more permeable to fluid than the matrix block and has 
a thickness of 0.0001 m, which is much smaller than the block dimensions. Here the 
walls of the block are impermeable to flow except at the fracture edges, but such need 
not be the case. Fluid moves from left to right through the block entering at the lower 
fracture edge and exiting at the upper edge. The fluid initially does not move within 
the volume. Pressure at the outlet edge drops with time., while pressure at the inlet 
edge remains at the initial pressure throughout the simulation. The simulation period 
is 1000 s. At the end of this discussion a tabulation of the data values appears.

F L U I D  F L O W — M A T R I X  B L O C K

Time-dependent fluid flow in the matrix block is governed by Darcy’s law 

where the dependent variable, p, is the fluid’s pressure in the pore space (kg/(m·s2)), 
θs is the void fraction or porosity of the matrix blocks (m3/m3), χf and χp are the 
compressibilities of the fluid and solid (s2·m/kg), respectively, κm gives the 
permeability of the matrix blocks (m2), η equals the fluid’s dynamic viscosity (Pa·s), 
and D is the vertical axis (m).

In the blocks, the predefined velocity variable, uesdl (m/s), gives the Darcy velocity, 
which is a volume flow rate per unit area of porous media:

.

The fluid’s linear velocity within the small interstices in the block, ulin, is higher than 
the Darcy velocity, which describes the velocity as if it were distributed over both solids 
and voids, ulin = uesdl/θs.

Along all faces of the block the zero flow boundary condition applies:

where n is the outward pointing normal to the boundary. This means that flow going 
perpendicular to and across the boundary equals zero.

χfθs χs 1 θs–( )+[ ]∂p
∂t
------ ∇

κm
η

--------∇p⋅– 0= Ω matrix block

uesdl
κm
η

-------∇p–= Ω matrix block

n
κm
η

-------∇p–⋅ 0= Ω  block face∂
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F L U I D  F L O W — F R A C T U R E

The fracture in the model is a sequence of interior boundaries. Typically at a boundary 
you define flow across or normal to the boundary instead of along it. In this model, 
however, you employ special tangential options from COMSOL Multiphysics that 
allow for defining flow along the interior boundaries or fracture.

For this type of analysis to be valid, the equation on the fracture must solve for the 
same dependent variable as the equation for the matrix block, p. In this particular 
example, the equation for velocity in the fracture follows a modified form of that 
within the matrix block, namely Darcy’s law. You modify the equation coefficients to 
account for a relatively small resistance to flow on the fracture and the fracture 
thickness, which gives dimensional consistency between the fracture and matrix:

.

In the equation, Sfrac is the fracture-storage coefficient (s2·m/kg), κfrac describes the 
fracture’s permeability (m2), and dfrac is the fracture’s thickness (m).

Because thickness appears in the fracture flow equation, the predefined variable uesdl 
now gives the volume flow rate per unit length of fracture:

The linear velocity of the fluid within the fracture is uesdl/dfrac.

Bounding the fracture are edges that intersect the porous media block. The pressure is 
known at the inlet edge. At the outlet edge the flow rate uesdl is known. There is no 
flow through the other edges.

Implementation

To trigger flow on the fracture that interacts with flow in the matrix, you add weak 
form equations with tangential derivatives on the interior boundaries. The weak PDE 

Sfrac
∂p
∂t
------ ∇

κfrac
η

-----------dfrac∇p⋅– 0= ∂Ω fracture

uesdl
κfrac

η
------------dfrac∇p–= ∂Ω fracture.

p pinlet= ∂2Ω inlet edge

p poutlet= ∂2Ω outlet edge

κfrac
η

------------dfrac∇p 0=– ∂2Ω other edges.
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formulation is the extremely powerful and flexible integral form that underlies the 
finite element method. The tangential derivatives pTx, pTy, and pTz describe the 
change in pressure along, rather than across, the boundary. With weak PDEs, the time 
rate change in pressure goes into a dweak expression that combines with velocities and 
sources in weak expressions to completely describe the physics. To find out more about 
the use of the weak PDE form see “The Weak Form” on page 291 in the COMSOL 
Multiphysics Modeling Guide.

Results

The following figures contain screen shots from the analysis of time-dependent flow in 
a fractured porous media block. The isosurfaces in Figure 2-28 show the contours of 
fluid pressures throughout the block at the final output time of 1000 s. The pressures 
are continuous across the fracture from block to block. Even so, the bends in the 
isosurfaces indicate different flow regimes in the fracture and the matrix blocks. The 
arrows indicate velocities on the fracture. The fluid moves from inlet to the outlet 
along the fracture with a velocity field that is uniform across the block.

Figure 2-28: Results at time 1000 s for the analysis of flow in a porous media block with a 
fracture running through it: shown are the pressure (surface plot), linear velocity along 
the fracture (arrows), and maximum linear velocity (max/min). Pressure isosurfaces go 
from 91,500 to 100,000 Pa at 1500 Pa increments. The maximum velocity on the fracture 
is 1.13 m/s.
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Figure 2-29 shows the linear velocities of the fluid in the matrix along with the 
pressure surface from Figure 2-28. With no flow out of the matrix, the only fluid 
source is the fracture. The arrows indicate that fluid exits from the fracture at the inlet. 
The matrix flow feeds the fracture at the outlet. The wireframe slice plot shows that 
the linear velocity in the matrix is orders of magnitude smaller than the average linear 
velocity along the fracture at time 1000 s.

Figure 2-29: Results from the analysis of a porous media block with a discrete fracture; it 
shows fluid pressure (the isosurfaces), velocities in the matrix blocks (black arrows), and 
matrix linear velocity relative to average linear fracture velocity (slice plot).

Figure 2-30 illustrates the flow field in the fractured block evolving over the 1000 s 
simulation period. The isosurfaces stack up in the block as the pressure drop increases 
but stay centered on the fracture. At an early time, the matrix velocity and the fracture 
velocities differ by a factor of 1000. At a late time, the ratio between the linear 
velocities in the block and the velocities on the fracture are on the order of 1,000,000.
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Figure 2-30: Postprocessing images from the analysis of flow on a discrete fracture in a 
matrix block. Shown are the fluid pressure (the isosurfaces), velocities in the matrix blocks 
(black arrows), and matrix linear velocity relative to average linear fracture velocity.

Conclusions

This example shows how to model flow in a discrete fracture that interacts with fluid 
flow in the porous matrix that surrounds it. The method used here is especially efficient 
computationally. With COMSOL Multiphysics’ tangential boundary options, you can 
represent the fracture as a 2D boundary rather than a 3D model domain. This 
approach produces high-resolution results and also eliminates the need for an 
enormous number of small elements.

300 s 550 s

800 s 1000 s
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Data

The coefficients and parameters in this model are as follows:

Model Library path: Earth_Science_Module/Fluid_Flow/fracture

Modeling Using the Graphical User Interface

In this example, the geometry already exists as a COMSOL Multiphysics model file. 
Ordinarily to build a 3D model you start with the following steps.

M O D E L  N A V I G A T O R

1 Open the Model Navigator. In the Space dimension list select 3D.

2 In the list of application modes choose  
Earth Science Module>Fluid Flow>Darcy’s Law>Pressure analysis>Transient analysis.

3 Click OK.

S C A L A R  V A R I A B L E S

Because of the small model domain you can neglect the impact of gravity, so there is 
no need to alter the settings available from the Physics>Scalar Variables dialog box.

VARIABLE UNITS DESCRIPTION EXPRESSION

 θs m3/m3 Porosity of matrix blocks 0.3

 χf s2·m/kg Compressibility of the fluid 4.4·10-10

 χs s2·m/kg Compressibility of the fluid 10-8

 κm 1/m2 Permeability of matrix blocks 10-11

 df m Thickness of the fracture 0.0001

 Sf s2·m/kg Storage coefficient of the fracture  χf

 κf 1/m2 Permeability of fracture 10-7

 η kg/m·s Viscosity 0.001

 gr m/s2 Gravity 9.82

 ρf kg/in3 Fluid density 1000

 pinlet kg/m·s2 Pressure at the fracture inlet 105

 poutlet kg/m·s2 Pressure at the fracture outlet  p0 − 10t

 p0 kg/m·s2 Initial pressure distribution 105
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M O D E L  S E T T I N G S

Select the menu item Physics>Model Settings, then clear the Simplify expressions check 
box.

G E O M E T R Y

1 Go to the Draw toolbar and click the Block button. Click OK to accept the default 
dimensions, which create a unit block. Click the Zoom Extents button on the Main 
toolbar to center the block.

2 Now set up a 2D drawing plane to create the fracture. Select the menu item 
Draw>Work-Plane Settings. Click the Face Parallel tab. Expand the folder BLK1 and 
highlight Face 2. Click OK. Geometry 2 should appear with the outline of the box in 
the upper right corner. Click the Zoom Extents button on the Main toolbar to center 
the box in the window.

3 Changing the grid slightly makes it easier to draw the fracture. Select the menu item 
Options>Axes/Grid Settings. Click the Grid tab, then clear the Auto check box. In the 
x-spacing and y-spacing edit fields enter 0.25. Click OK.

4 Next draw a 3-segment line to represent the fracture. Select the menu item 
Draw>Specify Objects>Line. In the x-coordinates edit field enter the sequence 0 0.5 
0.5 1, and in the y-coordinates edit field enter 0.75 0.75 0.25 0.25. Click OK. 
This sets up segments with endpoints at (0, 0.75) (0.5, 0.75) (0.5, 0.25) (1, 0.25).
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5 Now extrude the lines by 1 m to create a 3D object. With the lines still highlighted, 
select the menu item Draw>Extrude. In both the Scale x and Scale y edit fields enter 
1. Click OK.

O P T I O N S

Define constants you need in building the model or during postprocessing.

1 Select the menu item Options>Constants, then enter the following names, 
expressions, and descriptions (optional); when done, click OK.

2 Select the menu item Options>Expressions>Scalar Expressions and enter these names, 
expressions, and descriptions (optional); when done, click OK.

3 Select the menu item Options>Expressions>Subdomain Expressions, and from the 
Subdomain selection list choose 1 and 2. Enter the following name and expression; 
when done, click OK.

4 Select the menu item Options>Expressions>Boundary Expressions. From the Boundary 

selection list select 6, 8, and 9. Enter the following name and expression; when done, 
click OK.

P H Y S I C S — M A T R I X

Use the predefined equation options to set up the flow model for the matrix blocks.

NAME EXPRESSION DESCRIPTION

p0 1e5[Pa] Initial pressure

thetas 0.3 Porosity matrix

Sfrac 4.4e-10[s^2*m/kg] Fracture storage coefficient

kfrac 1e-7[1/m^2] Fracture permeability

dfrac 0.1[mm] Fracture thickness

NAME EXPRESSION DESCRIPTION

weak_frac -kfrac/eta_esdl*dfrac* 
(pTx_test*pTx+pTy_test*pTy+pTz_test*pTz)

Fracture flow

dweak_frac Sfrac*dfrac*p_time*p_test Fracture storage

NAME EXPRESSION

matrix 1

NAME EXPRESSION

frac 1
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1 Select the menu item Physics>Subdomain Settings. From the Subdomain selection list 
choose 1 and 2. Enter the following settings; when done, click OK.

2 Select the menu item Physics>Subdomain Settings, then click the Init tab. In the Initial 

value edit field enter p0.

3 Select the menu item Physics>Boundary Settings. In the Boundary condition list verify 
that the setting is the default of Zero flux/Symmetry.

P H Y S I C S — F R A C T U R E

You must override the predefined boundary options to set up the flow model for the 
matrix blocks.

1 Select the menu item Physics>Edge Settings, then click the Pressure tab. In the Edge 

selection list choose 16 (the fracture inlet), then enter these settings:

For Edge 6 (the fracture outlet) enter these settings:

TERM SELECTION SUBDOMAINS 1, 2

Storage term Specific Storage

θs Porosity thetas

χf Compressibility - fluid 4.4e-10

χp Compressibility - solid 1e-8

κs Permeability 1e-11

ρf Density - fluid 1000

η Dynamic viscosity - fluid 0.001

QUANTITY DESCRIPTION VALUE/EXPRESSION

p0 Pressure p0

ts Starting time 0

tf Ending time 1000

QUANTITY DESCRIPTION VALUE/EXPRESSION

p0 Pressure p0-10[Pa/s]*t

ts Starting time 0

tf Ending time 1000
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2 Go to the menu item Physics>Equation Systems>Boundary Settings, then click the 
Weak tab. Highlight boundaries 6, 8, and 9, then enter the following settings:

3 Click Apply, then click Differentiate to distribute the new information.

M E S H  G E N E R A T I O N

1 Select the menu item Mesh>Free Mesh Parameters. On the Global page, in the 
Predefined mesh sizes list select Coarse. 

2 Click the Boundary tab. Select Boundaries 6, 8, and 9, then in the Maximum element 

size edit field enter 0.075.

3 Click the Edge tab. Select Edges 6 and 16, then in the Maximum element size edit 
field enter 0.025. Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Select the menu item Solve>Solver Parameters, then go to the General page.

2 Go to the Time stepping area, and in the Times edit field enter 0 1 10 50:50:1000.

3 Go to the Linear system solver area, and in the like-named list choose Conjugate 

gradients. In the Preconditioner list select Algebraic multigrid. In the Quality of 

multigrid hierarchy edit field enter 9. Click Apply, then click OK.

4 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

COMSOL Multiphysics allows you to create arbitrary variables and use them in 
postprocessing. The plots for this model use linear velocities that you first define. A 
short cut is to substitute the Darcy velocities u_esdl, v_esdl, w_esdl, and U_esdl or 
create the following variables and then update the model to recognize the new 
definitions.

TERM VALUE/EXPRESSION

weak weak_frac

dweak dweak_frac

constr 0
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1 Select the menu item Options>Expressions>Scalar Expressions. Add the following 
settings, each on its own row in the table; then click OK.

2 Select the menu item Options>Expressions>Subdomain Expressions. Select 
Subdomains 1 and 2, then enter the following settings, each on its own row in the 
table. When done, click OK.

3 Select the menu item Options>Expressions>Boundary Expressions. Select Boundaries 
6, 8, and 9, then enter the following settings, each on its own row in the table. When 
done, click OK.

4 Select the menu item Options>Integration Coupling Variables>Subdomain Variables. 
Select Subdomains 1 and 2, then enter the following settings, each on its own row 
in the table; when done, click OK.

NAME EXPRESSION

Ufrac_lin_avg Ufrac_lin_sum/area_frac

Umatrix_lin_avg Umatrix_lin_sum/volume_matrix

NAME EXPRESSION

umatrix_lin u_esdl/thetas

vmatrix_lin v_esdl/thetas

wmatrix_lin w_esdl/thetas

Umatrix_lin U_esdl/thetas

NAME EXPRESSION

ufrac_lin -kfrac/eta_esdl*pTx

vfrac_lin -kfrac/eta_esdl*pTy

wfrac_lin -kfrac/eta_esdl*pTz

Ufrac_lin sqrt(ufrac_lin^2+vfrac_lin^2+wfrac_lin^2)

NAME EXPRESSION

Umatrix_lin_sum Umatrix_lin

volume_matrix 1
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5 Select the menu item Options>Expressions>Boundary Expressions. Select Boundaries 
6, 8, and 9, then enter the following settings, each on its own row in the table; when 
done, click OK.

6 To calculate the expressions you have just defined, go to the Solve menu and select 
Update Model.

To generate Figure 2-29 on page 89:

1 Select the menu item Postprocessing>Plot Parameters and then click the General tab. 
In the Plot type area select the Isosurface, Boundary, Arrow, and Max/min marker check 
boxes.

2 Click the Isosurface tab. On both the Isosurface Data and Color Data pages, go to the 
Predefined Quantities list and select the flow solution Pressure. Select the Vector with 

isolevels option button, and in the associated edit field enter 91500:1500:100000.

3 Click the Boundary tab. Go to the Expression edit field and enter p*frac. Because 
frac equals 1 on the fracture but zero everywhere else, multiplying frac by p gives 
the fluid pressure on the fracture instead of on all boundaries.

4 Go to the Arrow page. In the Plot arrows on list select Boundaries. In the x-component 

edit field enter ufrac_lin*frac; in the y-component edit field enter 
vfrac_lin*frac; and in the z-component edit field enter wfrac_lin*frac. In the 
Arrow type list select Cone.

5 Click the Max/Min tab and make sure you are on the Subdomain Data page. Clear the 
Subdomain max/min data check box. Click the Boundary Data tab, then select the 
Boundary max/Min data check box. In the Expression edit field enter 
Ufrac_lin*frac. Click OK.

6 Enhance the image with directed light. Select the menu item Options>Visualization/

Selection Settings. Click the Lighting tab, and then select the Headlight check box. 
Click OK.

To generate Figure 2-30 on page 90:

1 Select the menu item Postprocessing>Plot Parameters, then click the General tab. In 
the Plot type area select the Isosurface, Arrow, Slice, Boundary, and Max/min marker 

check boxes. Switch among the desired output times from the figure by highlighting 
them in the Solution at time list.

NAME EXPRESSION

Ufrac_lin_sum U_esdl/dfrac

area_frac 1
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2 Click the Arrow tab. In the Plot arrows on list select Subdomains. In the x-component 

edit field enter umatrix_lin, in the y-component edit field enter vmatrix_lin, and 
in the z-component edit field enter wmatrix_lin. Go to the Arrow positioning area. 
In the Number of Points column for all three options (x, y, and z points) enter 7. In 
the Arrow type list select Cone.

3 Use a slice plot to see the linear velocity in the matrix block relative to the average 
value of the linear velocity on the fracture. Click the Slice tab and find the Slice data 

area. In the Expression edit field enter Umatrix_lin/Ufrac_lin_avg. Go to the 
Slice positioning area, and under the Number of levels column in both the y-levels and 
z-levels edit fields enter 0. For x-levels select the option button in the Vector with 

coordinates column, and in the associated edit field enter 0.9. In the Fill style list 
select Wireframe. Go to the Slice color area, and select the Colormap button, and in 
the associated drop-down list select pink.

4 Click OK.

To animate the solution sequence, select the menu item Postprocessing>Plot 

Parameters and then click the Animate tab. Change the image’s Width, Height and 
Frames per second as appropriate. Click the Start Animation button.

To create the image that appears when opening the model file, add streamlines for 
viewing the matrix and fracture velocities simultaneously. To do so, continue with 
these instructions:

1 Select the menu item Postprocessing>Plot Parameters and go to the General page. In 
the Plot type area clear the Slice and Max/min marker check boxes. Select the 
Streamline check box.

2 Click the Arrow tab. In the Plot arrows on list select Boundaries. In the x-component 

edit field enter ufrac_lin, in the y-component edit field enter vfrac_lin, and in 
the z-component edit field enter wfrac_lin.

3 Go to the Streamline page. In the x-component edit field enter umatrix_lin, in the 
y-component edit field enter vmatrix_lin, and in the z-component edit field enter 
wmatrix_lin. Go to the Start points tabbed page. In the Number of start points edit 
field type 150.

4 Click OK.
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V a r i a b l y  S a t u r a t e d  F l ow

This example uses the Richards’ Equation application mode to assess how well 
geophysical irrigation sensors detect the true level of fluid saturation in variably 
saturated soils. Andrew Hinnell, Alex Furman, and Ty Ferre from the Dept. of 
Hydrology and Water Resources at the University of Arizona brought the example to 
us. They originally worked out the problem in COMSOL Multiphysics’ PDE modes, 
but this discussion shares their elegant model reformulated in the Richards’ Equation 
application mode.

A major challenge when characterizing fluid movement in variably saturated porous 
media lies primarily in the need to describe how the capacity to transmit and store 
fluids changes as fluids enter and fill the pore spaces. Experimental data for these 
properties are difficult to obtain. Moreover, the properties that change value as the soil 
saturates happen to be equation coefficients, which makes the mathematics notoriously 
nonlinear. The Richards’ Equation application mode provides interfaces that automate 
the van Genuchten (Ref. 1) as well as the Brooks and Corey (Ref. 2) relationships for 
fluid retention and material properties that vary with the solution. This section 
discusses these interfaces and also explains how the application mode includes an 
interface that helps you use your own data or expressions to describe these properties 
(for details see “Interpolation for Unsaturated Flow” on page 115).

Figure 2-31: A variably saturated porous medium.

This example uses the model of Hinnell, Furman, and Ferre to characterize how the 
distribution of water changes around three impermeable sensors inserted into two 
different blocks of uniform soil partially saturated with water. The question for the 

Water Table

Water

Air
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model to address is this: Does the saturation localized around the sensor give a valid 
picture of the saturation within the total block?

This model demonstrates how to use the Richards’ Equation application mode 
including the van Genuchten (Ref. 1) as well as the Brooks and Corey (Ref. 2) 
interfaces. The step-by-step instructions assist you in learning how to set up two 
separate equation systems in one COMSOL Multiphysics model file and then solve 
them simultaneously. It also explains a method to automate boundary and subdomain 
integrations using coupling variables—here the integrations estimate the average 
saturation around the sensors and within the soil blocks. For an example in which the 
soil retention and permeability properties are defined with experimental data, see the 
model “Interpolation for Unsaturated Flow” on page 115.

The following pages first contains an overview of the problem setup and review the 
equations and the boundary conditions. Following are a few details about 
implementing the integration-coupling variables and then a table of the data used in 
the model. The results of the simulations follow. Finally come detailed instructions for 
how to set up this model in the COMSOL Multiphysics user interface.

Model Definition

The problem setup is as follows. Two homogeneous columns of soil, each 2 m × 2 m 
on a face, are partially saturated with water. A plot of the hydraulic properties of the 
first soil (Soil Type 1) fits the van Genuchten retention and permeability formulas. The 
other soil (Soil Type 2) has material properties that suit the Brooks and Corey 
formulas. Within each soil column are three impermeable rods, each with a 0.1 m 
radius. The rods are spaced at 0.5 m increments so they run horizontally down the 
center line of each block; see Figure 2-32. Just after the rods are emplaced, the pressure 
head is still uniform, but water begins to move vertically downward in steady drainage. 
Because all vertical slices down a block are identical, you can model a 2D cross section 
and observe the changes in the flow field for 900 s or 15 minutes.
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Figure 2-32: Soil block with three rods. Shaded plane represents a vertical cross section.

G OV E R N I N G  E Q U A T I O N

Richards’ equation describes the unsaturated-saturated flow of water in the soils. In 
this problem you can use Richards’ equation only for water because the air in the soil 
stays at atmospheric pressure because this model does not close the surface to the 
atmosphere or otherwise ramp up the air pressures. The governing equation for the 
model is

 (2-3)

Pressure head, Hp (m), is the dependent variable. C denotes specific moisture capacity 
(m−1), Se is the effective saturation, S is a storage coefficient (m−1), t is time, K is 
hydraulic conductivity (m−1·s−1), and D is the coordinate (for example x, y, or z) for 
the vertical elevation. The equation does not show the volumetric fraction of water, θ, 
which is a constitutive relation that depends on Hp. Nonlinearities appear because C, 
Se, and K change with Hp and θ.

The first term in the equation explains that fluid storage can change with time during 
both unsaturated and saturated conditions. When the soil is unsaturated, the pores fill 
with (or drain) water. After the pore spaces completely fill, there is slight compression 
of the fluid and the pore space. The specific moisture capacity C = ∂θ / ∂Hp describes 
the change in fluid volume fraction θ with pressure head. The storage coefficient 
addresses storage changes due to compression and expansion of the pore spaces and 
the water when the soil is fully wet. To model the storage coefficient, this example uses 

C SeS+[ ]
Hp∂
t∂

---------- ∇+ K∇ Hp D+( )–[ ]⋅ 0=
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the specific storage option, which sets S = ρf  g (χp + θχf). Here, ρf is the fluid density 
(kg/m3), g is acceleration of gravity, while χp and χf are the compressibilities of the 
solid particles and fluid, respectively (kg/(m·s2)).

The van Genuchten and the Brooks and Corey formulas that describe the change in C, 
Se, K, and θ with Hp require data for the saturated θs and θr liquid volume fractions 
and other dimensionless constants α, n, m, and l, which specify a particular media type. 
With the van Genuchten equations that follow, you consider the soil as being saturated 
when fluid pressure is atmospheric (that is, Hp = 0):

With the Brooks and Corey approach, an air-entry pressure distinguishes saturated 
(Hp > −1/α) and unsaturated (Hp < −1/α) soil as in

θ =
θr Se θs θr–( )+
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To find a unique solution to this problem, you must specify initial and boundary 
conditions. Initially, the column has uniform pressure head of Hp0. The boundary 
conditions are

where n is the normal to the boundary.

COMSOL Multiphysics Implementation—Integration Coupling 
Variables

Integration coupling variables in COMSOL Multiphysics calculate integrals for 
arbitrary expressions on a given type of model domain (the source) and make that 
information available elsewhere in the model (the destination). As such, you can 
classify coupling variables by the source of the information. For example, boundaries, 
subdomains, and points are different types of sources that arise within every 2D model. 
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To calculate the average value of the effective saturation, Se, at the rod and throughout 
the soil requires two types of integration coupling variables: boundary coupling 
variables for the rod-soil boundary, and subdomain coupling variables for the soil. If 
the average saturation is

,

σ denotes the domain. The expression consists of two integrals. The numerator sums 
the effective saturation values along the boundary or within the subdomain. The 
denominator sums the boundary length or subdomain area (2D).

This model makes modest use of coupling variables to calculate saturations and 
compares them during postprocessing. In that coupling variables are so clever, it is 
worth mentioning a use or two. You can use them to evaluate, for example, a flux on 
an outlet and return the information as a source term on the inlet to link physics on 
separately meshed geometries within one model. And this is just the beginning. For 
more information on this topic, refer to “Using Coupling Variables” on page 255 in 
the COMSOL Multiphysics User’s Guide.

D A T A

The following table gives the data needed to complete the two example problems:

Se =
Se σd∫

σd∫
------------------

VARIABLE UNITS DESCRIPTION VAN GENUCHTEN BROOKS & COREY

g m/s2 Gravity 9.82 9.82

ρf kg/m3 Fluid density 1000 1000

χp m s2 kg-1 Compressibility of solid particles 1e-8 1e-8

χf m s2 kg-1 Compressibility of fluid 4.4·10-10 4.4·10-10

Ks m s-1 Saturated hydraulic conductivity 8.25·10-5 5.83·10-5

θs Porosity/void fraction 0.43 0.417

θr Residual saturation 0.045 0.02

α m-1 alpha parameter 14.5 13.8

n n parameter 2.68 0.592

m m parameter 1-1/n n/a

l Pore connectivity parameter 0.5 1

Hp0 m Specified pressure -0.06 -0.2

Hp0 m Initial pressure -0.06 -0.2
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Results

Figure 2-33 and Figure 2-34 are solutions to the Richards’ equation problem of Prof. 
Ty Ferre, Andrew Hinnell, and Alex Furman from the University of Arizona’s 
Department of Hydrology and Water Resources. Each figure gives results for similar 
variably saturated flow problem posed for different soil types. Each snapshot shows 
effective fluid saturation (surface plot), pressure head (contours), and fluid velocities 
(arrows). The flow field varies around the rods but remains largely uniform over the 
remainder of each block. 

Figure 2-33: Solution for effective saturation (surface plot), pressure head (contours), and 
velocity (arrows) at 30 minutes for Soil Type 1 (van Genuchten).
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Figure 2-34: Solution for effective saturation (surface plot), pressure head (contours), and 
velocity (arrows) at 30 minutes for Soil Type 2 (Brooks and Corey).
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Figure 2-35 shows the effective saturation evolving over time at the rod-soil boundary. 
In the figure, the solid lines denote the solution for Soil Type 1, and the dashed lines 

Figure 2-35: Effective saturation around the center rod in Soil Type 1 (solid lines) and 
Soil Type 2 (dashed lines). Results are for 0 s, 60 s, 300 s, 600 s, and 900 s.

correspond to Soil Type 2. Because the boundary is a circle, the x-axis in the figure is 
an arc length, and those < 0.5 refer to the semicircle below the rods. In the results, the 
initial value of effective saturation plots as a horizontal line. The soil is wetter just above 
the rods than below them. That the saturation around Soil Type 1 extends beyond the 
arc length distance of 0.5 suggests that the entire boundary will get completely wet 
with time.

Figure 2-36 compares the average fluid saturations at the rod boundary with the 
average within the two blocks of soil. The range of effective saturation estimates at the 
rod boundary appears as a scatter plot for different time steps. The solid line is the 
integral of the effective saturation at the rod boundary. The dashed line is the integral 
of effective saturation for the block. Clearly the average effective saturation at the rods 
increases with time, but the average for the block does not change. While the effects 
shown here are more pronounced in Soil Type 1 than Soil Type 2, the results call to 
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question whether the sensors can accurately assess soil moisture if kept in situ for long 
times.

Figure 2-36: Average effective saturation at sensor circumference (solid lines) and overall 
soil block (dashed lines) for Soil Type 1 (top set) and Soil Type 2 (bottom set). Also shown 
is the range of effective saturation at the rod circumference for Soil Type 1 (circles) and 
Soil Type 2 (squares).
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Model Library path: Earth_Science_Module/Fluid_Flow/varsat

Modeling Using the Graphical User Interface

To begin the model, first set up a geometry with an x-z axis, then add two Richards’ 
Equation application modes.
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M O D E L  N A V I G A T O R

1 Open the Model Navigator, and in the Space dimension list select 2D.

2 Click the Multiphysics button.

3 Click the Add Geometry button. In the Independent variables edit field change the 
entry to read x z y in that order. Click OK.

4 In the list of application modes select Earth Science Module>Fluid Flow>Richards’ 

Equation>Pressure head analysis>Transient analysis. In the Application mode name 
edit field replace the current data with bc (for the Brooks & Corey method). Click 
the Add button and leave the dialog box open.

5 With the application mode Earth Science Module>Fluid Flow>Richards’ 

equation>Pressure head analysis>Transient analysis still selected, go to the Application 

mode name edit field and enter vg (for the van Genuchten analysis). Click Add, then 
click OK.

A P P L I C A T I O N  S C A L A R  V A R I A B L E S

To set the vertical direction in the model, go to the Physics menu and select Scalar 
Variables. Make the following modifications to the defaults, and then click OK.

G E O M E T R Y  M O D E L I N G

Create the geometry by drawing a rectangle and subtracting three circles from it.

1 Go to the Draw toolbar on the left side of the user interface and choose the Centered 

Rectangle/Square button. Draw a square centered on the origin, with an upper left 
corner at x = -1, z = 1 and a lower right corner at x = 1, z = -1. 

2 Go to the Draw menu and select Specify Objects>Circle. In the resulting dialog box 
enter these settings; when done, click OK.

3 Select the menu item Draw>Modify>Array. In the Displacement x edit field enter 0.5, 
and in the Array size x edit field enter 3. Click OK.

NAME EXPRESSION

D_vg z

D_bc z

NAME EXPRESSION

radius 0.1

x -0.5

z 0
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4 Select all the objects (press Ctrl+A). Click the Difference button on the Draw toolbar.

5 Click the Zoom Extents button on the Main toolbar to center the geometry in the 
field of view.

O P T I O N S  A N D  S E T T I N G S

Now set up variables to integrate the effective saturation in the subdomain and along 
the rod boundary.

1 Select the menu item Options>Integration Coupling Variables>Subdomain Variables. 
Enter data from the following table to create the needed variables; when done, click 
OK.

2 Select the menu item Options>Integration Coupling Variables>Boundary Variables. 
Select boundaries 9 through 12. Enter data from this table to create the needed 
variables; when done, click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings—Soil Type 1 (van Genuchten)
First set up the model for Soil Type 1, which you build with the van Genuchten 
retention and permeability relationships.

1 Select the menu item Physics>Subdomain settings. On the Coefficients page enter the 
following settings:

NAME EXPRESSION

sint_vg Se_vg

sint_bc Se_bc

sarea 1

NAME EXPRESSION

bint_vg Se_vg

bint_bc Se_bc

blength 1

TERM VAN GENUCHTEN

Constitutive relation van Genuchten

 θs 0.43

 θr 0.045

Storage term Specific storage
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2 Click the van Genuchten tab and enter these settings:

3 Click the Init tab. In the Initial value edit field for Hpt(0) enter -0.06.

4 Click OK.

Boundary conditions
From the Physics menu select Boundary Settings. Set these boundary conditions; when 
done, click OK.

Subdomain Settings—Soil Type 2 (Brooks and Corey)
Create a second application in the same model file for Soil Type 2 using the Brooks 
and Corey parameterization approach.

1 From the Multiphysics menu select Richards’ Equation (bc).

2 From the Physics menu select Subdomain Settings, then click the Coefficients tab. 
Enter the following expressions.

 χf 4.4e-10

 χp 1e-8

KS 8.25e-5

 ρf 1000

TERM VAN GENUCHTEN

 α 14.5

 n 2.68

 l 0.5

BOUNDARY BOUNDARY CONDITION VARIABLE VALUE

2, 3 Pressure head Hp0 -0.06

1, 4–16 Zero flux/Symmetry

SYMBOL BROOKS & COREY

Constitutive relation Brooks & Corey

 θs 0.417

 θr 0.02

Storage term Specific storage

 χf 4.4e-10

χp 1e-8

TERM VAN GENUCHTEN
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3 Click the Brooks & Corey tab, then enter these settings:

4 Click the Init tab. In the Initial value edit field for Hpt(0) enter -0.2.

5 Click OK.

Boundary conditions
From the Physics menu select Boundary Settings. Set these boundary conditions; when 
done, click OK.

M E S H  G E N E R A T I O N

1 Select the menu item Mesh>Free Mesh Parameters.

2 Click the Boundary tab. Select the three circles in the model domain; to do so, 
left-click the mouse in the user interface and draw a box around the circles. Then in 
the Maximum element size edit field enter 0.025. Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Select the menu item Solve>Solver Parameters. Find the Solver list, and verify that 
Time dependent is selected.

2 Remaining on the General page, go to the Time stepping area. To specify output 
times for the model, go to the Times edit field and enter 0 60 300 600 900. Click 
OK.

3 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate the plot in Figure 2-33 on page 105, follow these steps:

 KS 5.8333e-5

 ρf 1000

SYMBOL BROOKS & COREY

 α 13.8

 n 0.592

 l 1

BOUNDARY BOUNDARY CONDITION VARIABLE BROOKS & COREY

2, 3 Pressure head Hp0 -0.2

1, 4–16 Zero flux/Symmetry

SYMBOL BROOKS & COREY
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1 Select the menu item Postprocessing>Plot Parameters. 

2 Go to the General page. In the Plot type area select the Surface, Contour, and Arrow 
check boxes. 

3 Click the Surface tab. In the Surface data area go to the Expression edit field and enter 
Se_vg, typing over the current expression. Se_vg stands for effective saturation (the 
Se) calculated with the application mode named vg (_vg).

4 Click the Contour tab. In the Contour data area go to the Predefined quantities list 
and select Richards’ Equation (vg)>Pressure head. In the Contour color area select 
Uniform color option button. Click the Color button, select black, then click OK.

5 Click the Arrow tab. In the Arrow data area go to the Predefined quantities list and 
select Richards’ Equation (vg)>Velocity field. Go to the Arrow positioning area. In the 
Number of points edit fields for both x points and z points enter 40. Click the Color 
button, then choose gray; click OK.

6 Return to the General page. Click the Title button, enter a title as appropriate, and 
then click OK.

7 Click OK to close the Plot Parameters dialog box.

To create Figure 2-34 on page 106 for the Richards’ equation (bc) application mode, 
repeat the steps for Figure 2-33—except this time on the Surface page in the Expression 
edit field you enter Se_bc. 

To generate Figure  on page 107, continue with these steps:

1 Select the menu item Postprocessing>Domain Plot Parameters. 

2 Click the Line/Extrusion tab. Go to the y-axis data area, and in the Expression edit 
field enter Se_vg. In the Boundary Selection list select 9 through 12. Click Apply.

3 To add the second set of results, click the General tab and also select the Keep current 

plot check box. Then repeat the steps just outlined for Soil Type 2 (Brooks and 
Corey)—except this time return to the Line/Extrusion page and in the Expression edit 
field enter Se_bc.

4 Go back to the General page. Clear the Keep current plot check box, then click OK.

To generate Figure 2-36 on page 108, continue with these steps:

1 Select the menu item Postprocessing>Domain Plot Parameters. Go to the General 
page, then select the Keep current plot check box. Click Apply. 

2 Now you want to add the distribution of effective saturation estimates at each 
output time. On the Line/Extrusion page, go to the y-axis data area and in the 
Expression edit field enter Se_vg. In the Boundary selection list select 9 through 12.
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3 Go to the x-axis data area and select Expression option button. In the Expression edit 
field enter t, then click OK.

4 Click the Line settings button at the bottom of the dialog box. Modify the line and 
symbol settings as desired. Click OK.

5 The next step is to overlay lines for the average saturation on the boundary. Click 
the Point tab, and in the Point selection list select an arbitrary point in the model 
domain. In the Expression edit field enter bint_vg/blength. Click the Line Settings 
button, modify these settings as desired, then click OK. Click Apply.

6 Now plot the average saturation over the subdomain. Go to the Point page, and in 
the Point selection list select an arbitrary point in the model domain. In the 
Expression edit field enter sint_vg/sarea. Click the Line Settings button, modify 
these settings as desired, then click OK. Click Apply.

7 To overlay results obtained with Soil Type 2 repeat Steps 2 through 6 using the 
corresponding expressions for application mode 2. Alternatively, to generate a 
separate plot for application mode 2, click the General tab and the Plot in list and 
choose New figure. Then repeat Steps 2 through 6 for application mode 2.
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I n t e r p o l a t i o n  f o r  Un s a t u r a t e d  F l ow

Variably saturated flow models are notoriously difficult to parameterize because several 
material and hydraulic properties change values as the pressure and saturation levels 
fluctuate. Ideally, experimentalists prefer to use their hard-earned data in a model 
rather than finding best-fit analytical expressions. This example demonstrates how to 
incorporate experimental data directly into a simulation. Nathan Miller of Michigan 
State University pioneered this approach in his COMSOL Multiphysics model of fluid, 
heat, and gas movement to a turtle nest.

Figure 2-37: Analytical (lines) and interpolated (markers) estimates of properties that 
depend on Hp. Shown for the upper soil layer (dashed line) and lower soil layer (solid line) 
are: hydraulic conductivity, K (a); liquid volume fraction, θ (b); effective saturation, Se, 
(c); and specific moisture capacity, C (d).

(a) (c)

(b) (d)
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This example uses interpolation between experimental data points to estimate values 
of the equation coefficients Se, θ,  K, and C (see Equation 2-3 on page 101) that fit 
the solution for the pressure-head,  Hp, during a flow simulation.

The interpolation model described here builds on the flow model described in 
“Variably Saturated Flow” on page 99. In variably saturated transport, you define the 
equation coefficients Se, θ,  K, and C, which vary with pressure head,  Hp, using 
analytic expressions from van Genuchten (Ref. 1) and that are available in the Richards’ 
Equation application mode. For this interpolation model, the author parameterized 
the same basic flow problem by sampling from analytic calculations to obtain a 
fictitious experimental dataset and interpolating between the scattered points. At the 
close of the model, this discussion compares results from interpolated material 
properties to those obtained with analytical calculations.

Model Definition

Example 4 from the SWMS2D manual (Ref. 2) inspired the basic flow problem set out 
in this model. In that example, a ring of 0.25 m radius sits at the ground surface. 
Within it water ponds to a depth of 0.01 m. The ring is bottomless, so water moves 
from the ring into the soil. The problem examines the flow into a 1.3 m long soil 
column of radius 1.25 m. 

Figure 2-38: Geometry showing infiltration ring on top of a soil column.
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The soil is layered; the upper soil layer is 0.4 m thick, and the lower layer sits on top 
of relatively impermeable soil. At the ground surface beyond the ring, there is no entry. 
The only flow exit is a small amount of leakage from the base. The center line of the 
ring is an axis of symmetry. The distribution of pressure head is known at an initial 
time. For more information about this flow model, see the example “Variably 
Saturated Flow” on page 99.

F L U I D  F L O W

Richards’ equation governs fluid flow in variably saturated porous media. A benefit of 
the form of Richards’ equation used here is that it allows for changes in storage related 
to increasing and decreasing moisture as well as storage changes due to compression 
and expansion when the soil is fully wet. The equation is 

where C is specific moisture capacity (m−1); Se is the effective saturation; S denotes 
the storage coefficient (m−1); Hp equals the pressure head (m); t is the time (d);  Ks 

represents the hydraulic conductivity (m−1·d−1); kr gives the relative permeability; D 
is the coordinate (for example x, y, or z) for the vertical elevation; and Qs represents 
the fluid source defined by volumetric flow rate per unit volume of soil (d−1). Here S 
equals the difference between the liquid volume fraction at saturation, θs, and the 
residual liquid volume fraction, θr, or specific yield per unit length.

Changes in pressure head and elevation head drive fluid through the soil. K, θ, C, and 
Se vary under unsaturated conditions (for example, Hp < 0), and they reach a constant 
value when the system saturates (for example, Hp ≥ 0). In a typical experimental 
station, you conduct simultaneous tests to identify how the hydraulic conductivity 
function K = Ks kr (m

−1·d−1) and the volume fraction of fluid in the soil, θ, change 
with Hp. The specific moisture capacity, C, relates changes observed in the soil 
moisture, θ, to the change in pressure head, Hp. The relative permeability, kr explains 
how the transmissive properties of the soil, K, vary with pressure head, Hp. The 
effective saturation, Se, denotes the value of θ scaled to a maximum of 1.

This example employs interpolation functions with a fictional set of experimental data 
consisting of K and θ data for different values of Hp. It uses interpolation when the soil 
is unsaturated (Hp < 0) to estimate K and θ for different values of the solution, Hp. 
The model defines C by the “slope” in the θ versus Hp values. Se is a scaled version of 
the θ results. The parameterization is as follows:

C Se S+[ ]
Hp∂
t∂

---------- ∇+ Kskr∇ Hp D+( )–[ ]⋅ Qs=
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where pressure head at saturation is atmospheric (that is, Hp = 0). Here, θs and Ks 
denote the soil’s total porosity and the saturated hydraulic conductivity.

For the boundary conditions, the pressure head in the ring is constant, and no flow 
exits in the surface outside the pressure ring. The sides are impermeable. The vertical 
boundary on the inside of the ring is a line of symmetry, and the model approximates 
the small amount of leakage from the base, N0, as being 0.01Ks. In summary, the 
boundary conditions are:

where n is the outward unit normal to the boundary. Initially, the column has a 
specified distribution of pressure head of Hp0. Here, you define the initial pressures 
with an equation that approximates the distribution shown for June 1982 in 
Example 4 from SWMS2D (Ref. 2).

θ =
f Hp( )

θs
⎩
⎪
⎨
⎪
⎧

Hp 0<

Hp 0≥

Se =
θ θr–( ) θs θr–( )⁄

1⎩
⎨
⎧ Hp 0<

Hp 0≥

C =
∂θ ∂Hp⁄

0⎩
⎨
⎧ Hp 0<

Hp 0≥

kr
K
Ks
------=

f Hp( )

1⎩
⎨
⎧ Hp 0<

Hp 0≥

Hp Hp0= ∂Ω Ring

n Kskr∇ Hp D+( )–[ ]⋅ 0= ∂Ω Surface

n Kskr∇ Hp D+( )–[ ]⋅ 0= ∂Ω Sides

n Kskr∇ Hp D+( )–[ ]⋅ 0= ∂Ω Symmetry

n Kskr∇ Hp D+( )–[ ]⋅ N0= ∂Ω Base
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Implementation: Interpolation from Scattered Data

The “experimental data” are 25 data points sampled at regular Hp intervals from K and 
θ values calculated with the following formulas (Ref. 1). The data also include repeats 
of the constants for extreme pressure heads to prevent extrapolating beyond the range 
of physical property values. You can calculate the sampled distributions from

where α, n, m, and l are dimensionless constants that specify a particular media type, 
and m = 1 − 1/n.

Implementation: Interpolation from Experimental Data

This analysis finds the correct value of K = Ks kr and θ for the solution Hp using 
COMSOL Multiphysics commands to interpolate between experimental data points. 
You calculate Se based on the interpolated θ estimates, then use COMSOL 
Multiphysics’ automated differentiation commands (for example, diff and pdiff) to 
define C as the derivative of θ with respect to Hp.

Interpolation in COMSOL Multiphysics is straightforward. You open a dialog box 
from the Options menu, import data from a text file, assign a name to the interpolation 

θ =
θr Se θs θr–( )+

θs
⎩
⎪
⎨
⎪
⎧

Hp 0<

Hp 0≥

Se =

1

1 αHp
n

+[ ]
m

-------------------------------------

1⎩
⎪
⎨
⎪
⎧

Hp 0<

Hp 0≥

C =
αm

1 m–
-------------- θs θr–( )Se

1
m
-----

1 Se

1
m
-----

–
⎝ ⎠
⎜ ⎟
⎛ ⎞

m

0⎩
⎪
⎪
⎨
⎪
⎪
⎧

Hp 0<

Hp 0≥

kr = SeL 1 1 Se

1
m
-----

–
⎝ ⎠
⎜ ⎟
⎛ ⎞

m

–

2

1⎩
⎪
⎪
⎨
⎪
⎪
⎧

Hp 0<

Hp 0≥
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function, and use that name where the function is needed, here the Subdomain Settings 
dialog boxes.

The step-by-step instructions that follow create interpolation functions for each K and 
θ in two layers, giving a total of four functions. The example laid out here uses 
precreated files that contain the pressure head with corresponding property values. For 
the hydraulic conductivity function, K = Ks kr, in Subdomain 1, the name of the data 
file is K_sub1.txt. Within that file, the pressure-head data make up the first string of 
numbers, and the corresponding hydraulic-conductivity values follow. For example, 
the final five entries from K_sub1.txt read

%grid
-0.3 -0.2 -0.1 0.0 100
%data
 0.0903 0.1376 0.2199 0.4540 0.454

In this sample from the data file, grid denotes that Hp data follow, and data denotes 
that corresponding K data come next.

Note: The file gives only unsaturated properties, but you repeat the saturated 
hydraulic conductivity, Ks, of 0.454 m/d for a positive pressure head of 100 m to 
prevent interpolation beyond the range of the data.

To activate the new functions you just created, simply enter the function name (for 
example, K_sub1) along with the argument (for example, the pressure head Hp). For 
the relative permeability, kr, the command is:

kr = K_sub1(Hp)/Ks

Find out more about interpolation commands by referring to the COMSOL 
Multiphysics User’s Guide. You can use the interpolation commands with spatial data 
as well. For a model that employs these interpolation commands to map out spatially 
varying material properties, see “A Rock Fracture Flow Model” on page 270 in the 
COMSOL Multiphysics Model Library. 
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D A T A

The following table provides the constants and the expressions used in this model. The 
data come from the example in Ref. 2. The expressions for implementing the 
interpolation commands appear in the user-interface instructions.

The next table summarizes the parameters used in calculating the van Genuchten 
distributions for Se, K, and θ.

Results

Figure 2-37 on page 115 shows the values for K, θ, Se, and C estimated here by 
interpolation from “experimental” datasets consisting of 25 points sampled from 
analytic distributions (Ref. 1). The sets of interpolated and analytic estimates for the 
upper and the lower soil layers match closely.

VARIABLE UNIT DESCRIPTION UPPER LAYER LOWER LAYER

 Ks m/d Saturated hydraulic conductivity 0.298 0.454

 qs Porosity/void fraction 0.399 0.339

 qr Residual saturation 0.0001 0.0001

 Hps m Pressure head in ring 0.01

 Hp0 m Initial pressure head -(z+1.2)* 
(z<-.4)+ 
(-(z+1.2)- 
.2*(z+.4))* 
(-.4<=z)

-(z+1.2)* 
(z<-.4)+ 
(-(z+1.2)- 
.2*(z+.4))* 
(-.4<=z)

VARIABLE UNITS DESCRIPTION UPPER LAYER LOWER LAYER

 Ks m/d Saturated hydraulic conductivity 0.298 0.454

 qs Porosity/void fraction 0.399 0.339

 qr Residual saturation 0.0001 0.0001

 α m-1 alpha parameter 1.74 1.39

 n n parameter 1.3757 1.6024

 m m parameter 1-1/n

 l Pore connectivity parameter 0.5 0.5
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. 

Figure 2-39: Solution for variably saturated flow simulated with properties interpolated 
from experimental data. Results shown are effective saturation (surface plot), pressure 
head (contours), and velocity (arrows) at 0.3 days.

Figure 2-40: Solution for variably saturated flow simulated with material properties 
interpolated from experimental data. Results shown are effective saturation (surface 
plot), pressure head (contours), and velocity (arrows) at 1 day.
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The two nearby figures show the solutions of variably saturated flow modeled with 
interpolated K, θ, Se, and C values at 0.25 days and 1 day. They show effective 
saturation (surface plot), pressure head (contours), and velocities (arrows). At day 
0.25, the fluid moves primarily below the ponded region.

By the end of one day, the water moves deeper within the volume. Because very little 
fluid exits from the base, the soil gradually saturates upward with time. The results are 
so similar to values obtained with closed-form equations to define K, θ, Se, and C that 
this discussion does not repeat them; the curious reader should refer to “Variably 
Saturated Flow” on page 99.

Figure 2-41 is a plot of pressure heads simulated in COMSOL Multiphysics with linear 
and nearest neighbor interpolation to define K, θ, Se, and C from experimental data. 
It shows results for various depths along the line x = 0.2, and it also illustrates similar 
values for simulations with closed-form analytic estimates of K, θ, Se, and C. Which 
interpolation method is appropriate for a model depends on the property values and 
the number of data, among other things.

Figure 2-41: Pressure heads simulated with linear interpolation (squares) and analytic 
formulas (circles) for retention and permeability functions. Results are for x y coordinates, 
in m, (0.2, -0.1), (0.6, -0.4), and (1.0, -0.7).

This example demonstrates how to simulate variably saturated flow using 
fluid-retention and permeability values obtained by interpolation from experimental 
data, which you here import into COMSOL Multiphysics as a text file. Then use the 
COMSOL Multiphysics interpolation functions and the Richards’ equation 
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user-definition options to parameterize the model. The user-definition options also 
allow you to enter arbitrary expressions for these properties, for example, to define 
how permeability and moisture content vary during unsaturated conditions, and 
COMSOL Multiphysics can automate finding the solution.
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Model Library path: Earth_Science_Module/Fluid_Flow/interpolation

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator, and from the Space dimension list select Axial symmetry 

(2D).

2 From the list of application modes select  
Earth Science Module>Fluid Flow>Richards’ Equation>Pressure head analysis>Transient 

analysis, then click OK.

G E O M E T R Y  M O D E L I N G

Create the geometry by drawing one rectangle and adding two lines.

1 From the Draw menu select Specify Objects>Rectangle. Enter the following settings, 
then click OK.

PARAMETER EXPRESSION

width 1.25

height 1.3
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2 Go to the Main toolbar and click the Zoom Extents button.

3 Return to the Draw menu and select Specify Objects>Rectangle. Specify the following 
shape, then click OK.

4 Return to the Draw menu and select Specify Objects>Line. In the r coordinate edit 
field enter 0 0.25, and in the z coordinate edit field enter 0 0. Click OK.

O P T I O N S  A N D  S E T T I N G S

Now set up the interpolation routines. You interpolate for six datasets. Import the data 
as files and assign a name that you use elsewhere to call for the interpolated values. In 
the data files, the Hp values are the “grid,” and the corresponding parameter values are 
the “data.” The datafiles are available once the Earth Science Module has been 
installed.

1 Choose Options>Functions. In the Defined Functions area, click the New button.

2 To define the hydraulic conductivity in Subdomain 1 (the lower layer), go to the 
Function name edit field and enter K_sub1. Select Interpolation and choose File from 
the Use data from list. Click Browse. Then find the file K_sub1.txt, in Models/
Earth_Science_Module/Fluid_Flow in the COMSOL installation directory. 
Click OK.

3 Repeat this process for the files th_sub1.txt, K_sub2.txt, and th_sub2.txt. Be 
sure to click New before starting to create each new function. After you have named 
and imported data for each function, click Apply.

4 Click OK to close the Functions dialog box.

r 0

z -1.3

PARAMETER EXPRESSION

width 1.25

height 0.4

r 0

z -0.4

PARAMETER EXPRESSION
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P H Y S I C S  S E T T I N G S

Application Scalar Variables
To set the vertical direction and gravitational constant in the model, go to the Physics 
menu and select Scalar Variables. Make the following modifications to the defaults. 
Here you convert from seconds to days by multiplying by the number of seconds per 
day, and square the quantity because you are dealing with acceleration. Click OK.

Subdomain Settings
Set up the material properties and how the interpolation should proceed.

1 Choose Physics>Subdomain Settings. On the Coefficients page, enter the settings in 
the table below.

2 Click the User Defined tab and enter these settings, being sure to click Apply after you 
have finished changing the values for each subdomain.

3 Click the Init tab. In the Subdomain selection list, choose both subdomains 
simultaneously. Then enter the following expression in the Initial value edit field and, 
when done, click OK.

NAME EXPRESSION

D_esvr z

g_esvr 9.82*86400*86400

TERM SUBDOMAIN 1 SUBDOMAIN 2

Constitutive relation User defined User defined

 θs 0.339 0.399

 θr 0.0001 0.0001

Storage term User defined User defined

S 1e-8 1e-8

KS 0.454 0.298

 ρf 1000 1000

TERM SUBDOMAIN 1 SUBDOMAIN 2

 θ th_sub1(Hp_esvr[1/m]) th_sub2(Hp_esvr[1/m])

 kr K_sub1(Hp_esvr[1/m])/0.454 K_sub2(Hp_esvr[1/m])/0.298

INITIAL VALUE SUBDOMAINS 1, 2

Hp(t0) -(z+1.2)*(z<-0.4)+(-(z+1.2)-0.2*(z+0.4))*(-0.4<=z)
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Boundary Conditions
From the Physics menu choose Boundary Settings. Set the following conditions; when 
done, click OK.

M E S H  G E N E R A T I O N

1 Choose Mesh>Free Mesh Parameters.

2 On the Global page, set the Predefined mesh sizes to Finer.

3 On the Boundary page, select Boundary 4. In the Maximum element size edit field, 
enter 0.02.

4 Select Boundary 5. In the Maximum element size edit field, enter 0.002.

5 Select Boundary 6. In the Maximum element size edit field, enter 0.02.

6 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 From the Solve menu, open the Solver Parameters dialog box. In the Solver list, 
choose Time dependent if it is not already selected.

2 In the Times edit field, enter 0:0.05:0.25,0.25:0.25:1,2:1:10, to generate 
outputs at 0.05-day increments for 0.25 days, then 0.25-day increments until the 
end of day 1, and finally 1-day increments through day 10. Click OK.

3 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate the plot in Figure 2-39 on page 122, follow these steps:

1 From the Postprocessing menu select Plot Parameters.

2 Click the General tab. In the Plot type area select the Surface, Contour, and Arrow 
check boxes. In the Solution at time list select 0.3.

3 Click the Surface tab. In the Expression edit field enter Se_esvr, typing over current 
information. Note that Se_esvr stands for effective saturation (Se) calculated with 
this application mode (named esvr). 

4 Select the Contour tab. From the Predefined quantities list choose Pressure head. 
Select the option button next to the Vector with isolevels label, and in the associated 

CONDITION VARIABLE BOUNDARY EXPRESSION

Pressure head Hp0 5 0.01

Inward flux N0 2 -0.454/100

Zero flux/Symmetry 1,3,4,6–8
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edit field enter -2:0.1:2. Go to the Contour color area and click the Uniform color 
option button; click the Color button and change the color to white, then click OK.

5 Click the Arrow tab. In the list of Predefined quantities select Velocity field. Go to the 
Arrow positioning area, then in the Number of edit points edit fields for both r points 

and z points enter 25. Go to the Arrow parameters area, click the Color button, 
choose white, then click OK. Clear the Auto check box, then in the associated edit 
field enter 0.5.

6 Click Apply.

To generate Figure 2-40 on page 122, click the General tab, and in the Solution at time 

list select 1. Click OK.

To generate Figure 2-41 on page 123, continue with these steps:

1 Choose Postprocessing>Cross-Section Plot Parameters. 

2 Click the Point tab. In the Predefined quantities list select Pressure head. Go to the 
Coordinates area; in the r edit field enter 0.2 0.6 1, and in the z edit field enter 
-0.1 -0.4 -0.7. Click OK. You should now see a pop-up window designated 
Figure 1; do not close this window.

To add results from a simulation with the van Genuchten analytic formulas proceed 
as follows:

3 Choose Physics>Subdomain Settings. On the Coefficients page go to the Subdomain 

selection list and choose both 1 and 2. Find the Constitutive relation list and select 
van Genuchten.

4 Click the van Genuchten tab, then enter the following settings:

5 Click the Solve button on the Main toolbar.

6 When the simulation is finished, return to the Postprocessing>Cross-Section Plot 

Parameters dialog box, click the General tab, then select the Keep current plot check 
box. Go to the Plot in list and select Figure 1. Then click the Point tab, click the Line 

settings button, and in the Line style list select Dashed line; click OK, then click OK.

TERM SUBDOMAIN 1 SUBDOMAIN 2

 α 1.39 1.74

 n 1.6 1.38

 l 0.5 0.5
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Two -Pha s e  F l ow

The following example analyzes two-phase flow in porous media. Describing how 
fluids that do not mix then move simultaneously through one pore space is key to 
answering many environmental and industrial questions. Unfortunately, multiphase 
analyses are complicated by the need to solve for multiple dependent variables along 
with a variety of unknowns. Among them are hydraulic properties that depend on the 
pressure and saturation levels of each fluid phase.

This problem demonstrates two-phase flow following a U.S. Environmental 
Protection Agency experimental setup (Ref. 1). This straightforward experiment 
matches observations for a laboratory column to numerical estimates of two-phase 
flow. With these column experiments, the researchers evaluate flow for varying fluid 
pairs (air-water, air-oil, and oil-water) and then match the experimental results to those 
from computer simulations that employ analytic expressions for retention and 
permeability. This discussion addresses their work for the Lincoln soil and use formulas 
from Mualem (Ref. 2) and van Genuchten (Ref. 3) to give hydraulic properties.

Figure 2-42: Geometry of the two-phase flow column experiments in Hopmans and others 
(Ref. 1).
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This is a multipart example. The first part sets up the two-phase flow model for water 
and air; the equations solve for pressures. Saturation varies with the solution. An 
underlying assumption is that at least some residual air and water exist throughout the 
soil column at all times. The model tracks the gas front as it displaces a wetting fluid 
by observing saturation rather than assuming a discrete interface. The second part 
modifies the air-water simulation for air-oil and oil-water systems.

Model Definition

In the experimental setup for air and water, the experiment injects air over the surface 
of a laboratory column filled with water and sand. The incoming air (the nonwetting 
phase for this fluid pair) forces the water (the wetting phase) toward the outlet at the 
base of the column. At the inlet, air pressure increases by steps in time, and no water 
exits through the column top. In moving to the outlet, the water passes through a disc 
that is impermeable to air flow. Neither the air nor the water can pass through the 
vertical column walls. The water pressure at the outlet, which changes in time, 
corresponds to the height of fluid rise in a receiving buret. The column has a total 
length of 8.34 cm, a 6-cm radius, and the disk is 0.74 cm thick. The experiment covers 
170 hours.

This discussion lays out the two-phase flow simulation in the following order. First it 
reviews the governing equations and the analytic relationships (Ref. 2 and Ref. 3) that 
define fluid retention and permeability. Next comes a few implementation details and 
a table of the model data. The results follow. Finally come step-by-step instructions to 
build the model in the graphical user interface.

G O V E R N I N G  E Q U A T I O N S  A N D  B O U N D A R Y  C O N D I T I O N S

Two-phase flow in porous media follows separate equations for the wetting (w) and 
nonwetting (nw) fluids:

 (2-4)

 (2-5)

where θs is the total porosity or saturated volume fraction; Se is effective saturation 
function; t is time (s); κint is the intrinsic permeability of the porous medium (m2); kr 

is the relative permeability function for a given fluid; η is the fluid’s dynamic viscosity 

θs
Sew∂

t∂
------------- ∇+

κintkr w,
ηw

----------------------∇ pw ρwgD+( )–⋅ 0=

θs
Senw∂

t∂
----------------- ∇+

κintkr nw,
ηnw

-------------------------∇ pnw ρnwgD+( )–⋅ 0=
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(kg/(m·s)); p is pressure (kg/(m·s2)); ρ is the fluid density (kg/m3); g is acceleration 
of gravity; and D is the coordinate (for example, x, y, or z) of vertical elevation (m).

If the fluid distribution is continuous, neither fluid ever completely fills the soil, giving 
a volume fraction for the wetting phase, θw, and nonwetting phase, θnw, at all times. 
For the wetting phase, θ varies from zero or a small residual value θr to the total 
porosity, θs. The effective saturation, Se, comes from scaling θ with respect to θs and 
θr and so varies from 0 to 1. Both θ and Se are functions of the pressures of all fluids 
in the system. You define capillary pressure:

.  (2-6)

The pore space can be completely filled with one fluid at a given time:

.  (2-7)

How effective saturation changes with capillary pressure, therefore, is

 (2-8)

where C is the specific capacity, and the subscript “p” denotes units of pressure.

Using Equation 2-6, Equation 2-7, and Equation 2-8 in Equation 2-4 and 
Equation 2-5 simplifies the numerical model. The governing equations become:

 (2-9)

.  (2-10)

You can solve this system of equations simultaneously for pw and pnw. In this example, 
the two fluids are incompressible, but that need not be the case.

Initially, the water and air in the column follow hydrostatic distributions. The 
boundary conditions allow the water to exit only from the base of the soil column. For 
the wetting phase, the boundary conditions are

pc pnw pw–=

Sew Senw+ 1=

Cp w, Cp nw, θs
Sew∂
pc∂

-------------=–=

Cp w, t∂
∂ pnw pw–( ) ∇+

κintkr w,
ηw

----------------------∇ pw ρwgD+( )–⋅ 0=

Cp w,–
t∂

∂ pnw pw–( ) ∇+
κintkr nw,

ηnw
-------------------------∇ pnw ρnwgD+( )–⋅ 0=
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 (2-11)

where n is the normal to the boundary.

Because air enters at the column top but never exits, the boundary conditions for the 
nonwetting phase are

 (2-12)

R E T E N T I O N  A N D  P E R M E A B I L I T Y  R E L A T I O N S H I P S

You can set up this two-phase flow analysis using interpolation from experimental data, 
arbitrary mathematical formulas, and results from other equations in the model to 
define how θ, C, Se, kr, and pc vary simultaneously. The existing model uses retention 
and permeability relationships from Ref. 2 and Ref. 3 that express changes in θ, C, Se, 
and kr as a function of pc. Because pc is large and because changes in θ, C, Se, and kr 

are small, these expressions transform capillary pressure to the equivalent height of 
water or capillary pressure head as in Hc = pc/(ρwater g). The hydraulic properties 
relative to the wetting fluid are

n κ
η
---∇ pw ρwgD+( )–⋅ 0= Ω Inlet∂

n κ
η
---∇ pw ρwgD+( )–⋅ 0= Ω Sides∂

pw pw0 t( )= Ω Base∂

n κ
η
---∇ pnw ρnwgD+( )–⋅ 0= Ω Surface∂

n κ
η
---∇ pnw ρnwgD+( )–⋅ 0= Ω Sides∂

pnw pnw0 t( )= Ω Base∂
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.  (2-13)

where α, n, m, and L are the van Genuchten parameters that denote soil 
characteristics. Note that with two-phase flow, the van Genuchten-Mualem formulas 
hinge on the value of Hc.

For the nonwetting fluid, the properties

 (2-14)

arise naturally from the definitions for the wetting phase.

D I F F E R E N T  F L U I D  P A I R S

When switching between air-water, air-oil, and oil-water experiments, the authors used 
clever scaling with interfacial tensions according to Leverett (Ref. 4). The Leverett 
scaling adjusts the nonwetting phase pressure at the column top to produce the same 
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volume of wetting fluid outflow at the column bottom regardless of the fluid pair. With 
Leverett scaling, switching between fluid pairs requires using the correct fluid 
properties ρ and η for the fluid pair and adjusting the boundary and initial pressures 
according to

In these equations, σ represents the interfacial tension between the different fluids, and 
the subscripts denote the fluid pair. These values appear in a table at the end of this 
section. For example, σao/σaw equals 0.373, and σwo/σaw equals 0.534 N/m; 
further, the first nonwetting phase pressure head (in meters of water) is 0.4 m for the 
air-water system, 0.1 m for the air-oil system, and 0.2 m for the water-oil system.

Because relative permeability and retention properties for a porous medium depend on 
the fluid moving through it, switching fluid pairs also requires switching the retention 
and permeability properties in the model. This requirement can mean inserting new 
experimental data or adjusting mathematical formulas. In this model, the authors 
assessed the permeability and retention parameters were assessed by curve fitting to 
analytic formulas. They adjusted the parameters α, n, κs, and θr to get the best fit for 
each fluid. A review of the data tables that follow reveals that the ratios in the α values 
for the different fluid pairs roughly equals the σ ratios just given.

Implementation: Numerical Differentiation to Estimate C

This example employs analytic expressions to estimate the specific moisture capacity, 
C. Because C is the slope of the curve q versus Hc, it also is possible to use the 
COMSOL Multiphysics differentiation operator pdiff to define C such as in

Cp,w(pw) = pdiff(theta_w,Hc) ρwater
−1

 g
−1.

Thus you can write arbitrary expressions or use data for θ. This equation differentiates 
fluid volume fraction with respect to capillary pressure head. Here you divide by the 
weight of water to convert the expression for use in equations with dependent variable 
pressure. The same type of syntax works with the differentiation operator diff. The 
distinction between the two operators is that diff recognizes space and time 
derivatives already defined in COMSOL Multiphysics (for example, px, py, pt), whereas 
pdiff is purely symbolic and does not apply the chain rule for dependent variables.

σaw pc aw, σaw pc aw,=

σaw pc aw, σaw pc ao,=

σaw pc aw, σaw pc ow,=
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Implementation: Step Change on a Boundary

The following step-by-step instructions define the timing of the stepped nonwetting 
phase pressures at the inlet by using an interpolation function. Interpolating in 
COMSOL Multiphysics is straightforward. You open a dialog box in the Options 
menu, set up the table with the times and corresponding pressure heads, assign a name 
to the interpolation function, and use the name for where the function is needed, here 
in the Subdomain Settings dialog boxes. To activate the functions created, simply enter 
the function name (for example, pnw_t) along with the argument, that is the time t in 
parenthesis. The command is

pnw(t) = Hnw_t(t)*rhowater*g_w

The density of water appears in the equation because Ref. 1 defines the boundary 
pressure as a height of water.

Data

The data used in this model correspond to the air-water experiments for the Lincoln 
sand as reported in Ref. 1:

The van Genuchten parameters for the different fluid pairs are

VARIABLE UNITS DESCRIPTION EXPRESSION

 gr m/s2 Acceleration due to gravity 9.82

 ρfw kg/m3 Fluid density, water 1000

 ηw Pa·s Dynamic viscosity, water 1·10-3

 ρfg kg/m3 Fluid density, gas 1.28

 ηg Pa·s Dynamic viscosity, gas 1.81·10-5

 κint m2 Intrinsic permeability, column 2.48·10-12

 κs m2 Permeability, disc 1.33·10-14

 qs,w Saturated volume fraction, column 0.32

 qs,w Saturated volume fraction, disc 0.5

 pnw,top m water Initial nonwetting phase pressure head, 
inlet

0.2

VARIABLE UNITS DESCRIPTION AIR-WATER AIR-OIL OIL-WATER

 qr,w Residual volume fraction 0.021 0.00001 0.0072

 α m-1 alpha parameter 1.89 5.29 3.58
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Pressure head at the air inlet increments in time according to

At the water outlet, the fluid level in the receiving buret increases linearly in time from 
0 m to 0.1 m.

 n n parameter, column 2.811 3.002 3.1365

 L L parameter, column 0.5 0.5 0.5

 κs m-2 Permeability, disc 2.48·10-12 1.09·10-12 0.94·10-12

PRESSURE HEAD (M WATER) START TIME (HOURS)

0.4 0

0.6 21.25

0.8 45.25

1.0 69

1.5 93

2 122.5

4 155

VARIABLE UNITS DESCRIPTION AIR-WATER AIR-OIL OIL-WATER
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Results

Figure 2-43 shows an early-time snapshot from the COMSOL Multiphysics solution 
for two-phase flow in a laboratory column. The shading depicts the effective saturation 
of the nonwetting phase (air), while the arrows give the wetting phase (water) 
velocities.

Figure 2-43: Solution to two-phase flow model at 0.1 hours: nonwetting phase saturation 
(surface plot), wetting-phase velocities (arrows). Results correspond to air-water 
experiment on Lincoln soil from the US EPA (Ref. 1).

The image illustrates the nonwetting fluid entering the soil column and displacing the 
wetting fluid. The nonwetting phase enters because it is being forced into the inlet 
with a multi-step pressure change. 

Figure 2-44 shows the stepped pressure head used at the inlet boundary along with the 
capillary pressure in the column at various elevations. We specified the point locations 
during postprocessing, which circumvents the need to plan observation sites during 
input. The solution to the two-phase flow problem provided is an excellent match to 
the results of Ref. 1.

That the capillary pressure head and the air inlet pressure in Figure 2-44 track together 
is what made the laboratory setup successful. To get high resolution on the 
permeability and retention behaviors, the authors in Ref. 1 set the pressure steps large 
enough that the impact is instantaneous in the soil column. As shown in Figure 2-45, 
the permeability changes instantaneously throughout the column.
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.

Figure 2-44: Inlet air pressure head (solid lines) and capillary pressure (dashed lines) for 
air-water flow in Lincoln soil (taken from the US EPA, Ref. 1).

.

Figure 2-45: Permeability functions for water (solid lines) and air (dashed lines) for 
Lincoln soil at x = 0.03 m (taken from the US EPA, Ref. 1).
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Solutions for two-phase flow for the air-oil and oil-water systems appear in Figure 2-46 
and Figure 2-47, respectively. 

Figure 2-46: Inlet-air pressure head (solid lines) and capillary pressure (dashed lines) for 
air-oil flow in Lincoln soil (taken from the US EPA, Ref. 1).

Figure 2-47: Inlet-air pressure head (solid lines) and capillary pressure (dashed lines) for 
oil-water flow in Lincoln soil. (taken from the US EPA, Ref. 1). 
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The COMSOL Multiphysics results for the air-oil and oil-water two-phase flow 
problems prove to be excellent matches to the results shown in Ref. 1. Through 
Leverett scaling you set the inlet pressure so that the air-oil and oil-water systems 
would produce the volume outflow rate from the air-water experiment. As with the 
air-water system, the capillary pressure head and air-inlet pressure for the air-oil 
experiment track instantaneously. For the water-oil system, however, there is a lag 
between the nonwetting and wetting phase pressures.
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Model Library path: Earth_Science_Module/Fluid_Flow/two_phase_aw

Modeling Using the Graphical User Interface: Air-Water System

M O D E L  N A V I G A T O R

1 Open the Model Navigator to the New page, and in the Space dimension list select 2D.

2 From the list of application modes select  
Earth Science Module>Fluid Flow>Darcy’s Law>Pressure analysis>Transient analysis.

3 In the Dependent variables edit field enter pw, and in the Application mode name edit 
field enter w. 

4 Click the Multiphysics button, then click Add.

5 In the list of application modes once again select  
Earth Science Module>Fluid Flow>Darcy’s Law>Pressure analysis>Transient analysis.
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6 Following the procedure you just followed, change the Dependent variable to pnw 
and the Application mode name to nw. Click the Multiphysics button, then click Add.

7 Click OK.

G E O M E T R Y  M O D E L I N G

Create the geometry by drawing two rectangles.

1 From the Draw menu select Specify Objects>Rectangle. Enter the following settings; 
when done, click OK.

2 Repeat that process except with these settings:

3 Click the Zoom Extents button on the Main toolbar.

O P T I O N S

1 Select the menu item Options>Constants, then enter the following names 
expressions, and descriptions (optional); when finished, click OK.

PARAMETER VALUE

Width 0.06

Height 0.0074

x 0

z 0

PARAMETER VALUE

Width 0.06

Height 0.0834

x 0

z 0

NAME EXPRESSION DESCRIPTION

rhowater 1000[kg/m^3] Density, water

rhow 1000[kg/m^3] Density, wetting fluid

etaw 0.001*hour[Pa*s] Dynamic viscosity, wetting fluid

rhonw 1.28[kg/m^3] Density, nonwetting fluid

etanw 0.0000181*hour[Pa*s] Dynamic viscosity, nonwetting fluid

hour 3600
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2 From the Options menu select Expressions>Scalar Expressions. Enter the following 
names and expressions (they go all on one line); when done, click OK.

3 From the Options menu select Expressions>Subdomain Expressions. Enter the 
following names and expressions for the two subdomains; when done, click OK.

Now set up the stepped pressures for the nonwetting phase boundary using 
interpolation.

4 From the Options menu select Functions.

5 Click the New button. In the Function name edit field enter Hpnw_t and choose the 
option Interpolation. Click OK.

NAME EXPRESSION

pnw_top 0.2*rhowater*g_nw

pnw_in pnw_top+(.0834-z)*rhonw*g_w

pw_in -rhow*g_w*z

pw_t 0.1*rhowater*g_w/170*t

Hc (pnw-pw)/(rhowater*g_w)

Sew (1+abs(alpha*Hc)^N)^(-M)*(Hc>0)+1*(Hc<=0)

thetaw (thetar+Sew*(thetas-thetar))*(Hc>0)+thetas*(Hc<=0)

krw ((Sew^L*(1-(1-Sew^(1/M))^M)^2)+eps)*(Hc>0)+1*(Hc<=0)

Cp 1/rhowater/g_w*((alpha*M/(1-M)*(thetas-thetar)

*Sew^(1/M)*(1-Sew^(1/M))^M))*(Hc>0)

Senw 1-Sew

thetanw thetas-thetaw

krnw ((1-Sew)^L*(1-Sew^(1/M))^(2*M))*(Hc>0)+eps

TERM SUBDOMAIN 1 SUBDOMAIN 2

thetas 0.5 0.32

thetar 0.0211

kaps 1.34e-14 2.48e-12

alpha 1.89

N 2.811

M 1-1/N

L 0.5
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6 Enter the following values in the table; when finished, click OK:

P H Y S I C S

In the following stage you first set up the material properties, initial conditions, and 
boundary conditions for each phase, then link the two equations.

Application Scalar Variables
To set the vertical direction and gravitational constant in the model, go to the Physics 
menu and select Scalar Variables. Make the following modifications to the defaults; 
when done, click OK.

This step converts from seconds to days; the quantity is squared because the problem 
deals with acceleration. 

Subdomain Settings—Wetting Phase
1 From the Multiphysics menu select Darcy’s Law (w).

X Y

0 0.4

21.20 0.4

21.25 0.6

45.20 0.6

45.25 0.8

68.95 0.8

69 1.0

92.95 1.0

93 1.5

122.45 1.5

122.5 2

154.95 4

155 4

200 4

NAME EXPRESSION

D_w y

g_w 9.82*hour*hour

D_nw y

g_nw 9.82*hour*hour
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2 From the Physics menu select Subdomain Settings. Enter the following settings, then 
click Apply.

3 Click the Init tab. Select both Subdomains 1 and 2 simultaneously, and in the pw(t0) 
edit field for Pressure enter pw_in. Click OK.

Boundary Conditions—Wetting Phase
From Physics choose Boundary Settings, then set the following conditions; when done, 
click OK.

Subdomain Settings—Nonwetting Phase
1 From the Multiphysics menu select Darcy’s Law (nw).

2 From the Physics menu select Subdomain Settings. In the Subdomain selection list 
choose 1, then clear the Active in this domain check box. 

3 Select Subdomain 2. Enter the following settings.

4 Click the Init tab. Select both Subdomains 1 and 2 simultaneously, and in the pw(t0) 
edit field for Pressure enter pwn_in. Click OK.

TERM SUBDOMAIN 1 SUBDOMAIN 2

Storage term User defined User defined

S 0 Cp

κS kaps kaps*krw

ρf rhow rhow

η etaw etaw

SETTINGS BOUNDARY 2 BOUNDARIES 1, 3, 5–7

Boundary condition Pressure Zero flux/Symmetry

P0 pw_t

TERM SUBDOMAIN 2

 Storage term User defined

 S Cp

 κS kaps*krnw

 ρf rhonw

 η etanw
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Boundary Conditions—Nonwetting Phase
From the Physics menu choose Boundary Settings, then set the following conditions; 
when done, click OK.

Equation Systems
1 From the Physics menu select Equation System>Subdomain Settings. 

With the information in this dialog box, COMSOL Multiphysics transforms the 
inputs you enter to coefficients it uses to solve the finite element model. The box 
contains entries for each type of model domain: subdomains, boundaries, and points 
in a 2D problem.

2 Click the da tab. Here is where the coefficients that are multiplied by the time rate 
change in pressure appear. The 4-element matrix originally has entries on the 
diagonal: one for the wetting-phase pressure, pw, for the wetting phase equation; 
and one for nonwetting phase pressure, pnw, for the nonwetting phase equation. 
Because the two-phase problem has storage terms for both nonwetting and wetting 
phases in each equation, you fill in the matrix with the appropriate terms. Modify 
the matrix so it reads as follows:

Note that eps is a very small number.

3 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu select Free Mesh Parameters. 

2 Click the Boundary tab. Using the Ctrl key select both Boundaries 4 and 5. In the 
Maximum element size edit field enter 0.001.

3 Select Boundary 2, and in the Maximum element size edit field enter 0.005.

4 Click the Remesh button.

SETTINGS BOUNDARIES 1–4, 6, 7 BOUNDARY 5

Boundary condition Zero flux/Symmetry Pressure

p0 Hpnw_t(t)*rhowater*g_nw

PW PNW

Cp+eps -Cp+eps

-Cp+eps Cp+eps
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C O M P U T I N G  T H E  S O L U T I O N

1 From the Solver menu open the Solver Parameters dialog box. In the Solver list select 
Time dependent (if it is not already selected).

2 In the Times edit field enter 0,0:0.01:0.1,0.1:0.1:1,1:170. Click OK.

3 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate the plot in Figure 2-43, follow these steps:

1 From the Postprocessing menu open the Plot Parameters dialog box. 

2 In the Plot type area select the Surface, Contour, and Arrow check boxes. In the 
Solution at time list choose 0.1.

3 Click the Surface tab, and in the Expression edit field enter Se_nw, which stands for 
effective saturation (Se) calculated with the application mode named nw.

4 Click the Arrow tab. In the Predefined quantities list select Darcy’s Law (w)> 
Velocity field. Go to the Arrow positioning area. In the Number of points column, and 
in both the x points and y points edit fields enter 25. Go to the Arrow parameters 

area. Click the Color button, change the color to black, and click OK. Clear the Auto 
check box, and in the Scale factor edit field enter 0.5.

5 Click OK.

To generate the plot in Figure 2-44, continue with these steps:

1 From the Postprocessing menu open the Cross-Section Plot Parameters dialog box. 

2 Click the Point tab. In the Expression edit field enter Hc. In the Coordinates section, 
in the x edit field enter 0.03 0.03 0.03, and in the y edit field enter 0.02 0.04 
0.06. Click Apply.

3 Click the General tab. Select the Keep current plot check box. In the Plot in list select 
Figure 1.

4 Click the Point tab. In the Expression edit field type pnw/(rhowater*g_nw). In the 
Coordinates area, in the x edit field enter 0.03, and in the y edit field enter 0.0834. 
Click OK.

To generate the plot in Figure 2-45, continue with these steps:

1 From the Postprocessing menu open the Cross-Section Plot Parameters dialog box.

2 Click the Point tab. In the Expression edit field enter kr_w. In the Coordinates section, 
in the x edit field enter 0.03 0.03 0.03, and in the y edit field enter 0.02 0.04 
0.06. Click Apply.
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3 Click the General tab. Select the Keep Current Plot check box. In the Plot in list select 
Figure 1.

4 Click the Point tab. In the Expression edit field enter kr_nw. Click OK.

Two-Phase Flow: Switching Fluid Pairs

This is the second part of the two-phase flow example. Here you modify the air-water 
model file created in the first part of this example to simulate two-phase flow for the 
air-oil and oil-water systems discussed in Ref. 1. In the air-oil system, oil is the wetting 
phase and air is the nonwetting phase. In the oil-water system, water is the wetting 
phase.

Switching from the air-water system to the air-oil or oil-water systems requires 
changing the fluid properties and several porous-media parameters. To get the 
different fluid pairs to produce wetting-phase outflow rates that are similar to those 
produced with the air-water simulation, you scale the pressure increments at the inlet 
by interfacial tensions as discussed earlier.

Model Library path: Earth_Science_Module/Fluid_Flow/two_phase_ao

Model Library path: Earth_Science_Module/Fluid_Flow/two_phase_ow

Modeling Using the Graphical User Interface:  
Air-Oil and Oil-Water

In the following section you open the file two_phase_aw.mph and modify it for the 
air-oil and oil-water systems. The following tables and instructions describe the 
changes needed to simulate both two-phase systems.

M O D E L  N A V I G A T O R

Open the Model Navigator and click the Model Library tab. In the list of library models 
select Earth Science Module>Fluid Flow>two_phase_aw. Click OK.
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O P T I O N S

1 From the Options menu open the Constants dialog box. Modify the entries for 
density, viscosity, and add interfacial tensions as in the following table; when 
finished, click OK:

2 Open the Scalar Expressions dialog box by selecting Options>Expression. Enter the 
following expression. When you are finished, click OK.

3 Select the menu option Options>Expressions>Subdomain Expressions. In the 
Subdomain selection list choose 2. Change the values for the following expressions; 
when finished, click OK.

P H Y S I C S — N O N W E T T I N G

From the Multiphysics menu select Darcy’s law (nw).

CONSTANT AIR-OIL OIL-WATER

rhow 800[kg/m^3] 1000[kg/m^3]

etaw 0.00392*hour[Pa*s] 0.001*hour[Pa*s]

rhonw 1.28[kg/m^3] 800[kg/m^3]

etanw 0.0000181*hour[Pa*s] 0.00392*hour[Pa*s]

sigma_ao 0.0259

sigma_aw 0.0681 0.0681

sigma_ow 0.0364

TERM AIR-OIL OIL-WATER

pnw_top 0.2*rhowater*g_nw*sigma_ao/
sigma_aw

0.2*rhowater*g_nw*sigma_ow/
sigma_aw

pw_in -rhow*g_w*y -rhow*g_w*z

pw_t 0.1*rhow*g_w/
170*t*sigma_ow/sigma_aw

0.1*rhow*g_w/150*t

NAME EXPRESSION

kaps 0.94e-12

thetar 0.0072

alpha 3.58

N 3.1365
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Boundary Conditions—Nonwetting Phase
From the Physics menu select Boundary Settings. In the Boundary selection list choose 
5. Set the following conditions; when done, click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 From the Solver menu open the Solver Parameters dialog box. In the Solver list select 
Time dependent (if it is not already selected).

2 Go to the Time stepping area. In the Times edit field enter 
0,0:0.01:0.1,0.1:0.1:1,1:170. Click OK.

3 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate the plots in Figure 2-47, repeat the steps described for Figure 2-44.

BOUNDARY CONDITION VARIABLE EXPRESSION

Pressure  
(for Air/Oil model)

p0 Hpnw_t(t)* 
rhowater*g_nw*sigma_ao/sigma_aw

Pressure  
(for Oil/Water model)

p0 Hpnw_t(t)* 
rhowater*g_w*sigma_ow/sigma_aw
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F l o w  a n d  S o l i d  D e f o r m a t i o n  M o d e l s
This chapter contains models with a focus on compaction and poroelasticity.
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Compa c t i o n  and Po r o e l a s t i c i t y

Fluids that move through pore spaces in an aquifer or reservoir can shield the porous 
medium from stress because they bear part of the load from, for instance, overlying 
rocks, sediments, fluids, and buildings. Withdrawing fluids from the pore space 
increases the stress the solids bear, sometimes to the degree that the reservoir 
measurably compacts. The reduction in the pore space loops back and alters the fluid 
pressures. The feedback brings about more fluid movement, and the cycle continues.

In the Central Valley of California, only a few years of unmanaged pumping irrevocably 
lowered the ground surface by roughly 9 m and etched out extensive lateral fissures. 
This model describes the impacts of pumping for a deep basin filled with sediments 
draping an impervious bedrock step or fault block. That the step is impermeable to 
fluids is important because the contrast in material properties gives rise to steep 
pressure gradients and large strains with the potential to produce fissuring or collapse 
infrastructure elements such as well casings and pipes.

Figure 3-1: Fluid movement in a sedimentary basin with bedrock fault blocks.

This example demonstrates two methods for analyzing ground displacement 
associated with changing subsurface fluid flow. Both models come directly from the 
bedrock step problem of Leake and Hsieh (Ref. 1). The first analysis, Terzaghi 
Compaction, describes a conventional flow model and uses the results in 
postprocessing to calculate vertical compaction following Terzaghi theory (Ref. 2). 
The second example, Biot Poroelasticity, models the two-way interaction between the 
fluid movement and the solid displacement following the linear poroelastic theory of 
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Biot (Ref. 3). The poroelasticity analysis predicts a similar vertical compaction and also 
predicts the horizontal displacements that compensate for the change in vertical 
thickness. The results from poroelastic analyses such as these ones naturally fold into 
criteria that predict fissuring and compaction at the soil surface as well as failure of 
wells, pipes, and other infrastructure elements.

Following these two example models, this section shows how to use COMSOL 
Multiphysics’ Darcy’s Law application mode and the Plane Strain application mode.

Model Definition

The two models that follow analyze fluid and solid behavior within three sedimentary 
layers overlying impermeable bedrock in a basin. The bedrock is faulted, which creates 
a step near a mountain front. The sediment stack totals 420 m at the centerline of the 
basin (x = 0 m) and thins to 120 m above the step (x > 4000 m). The top two layers 
are each 20 m thick.

Figure 3-2: Model geometry showing boundary segments (from Leake and Hsieh, Ref. 1).

Pumping from the lower aquifer reduces hydraulic head down the centerline of the 
basin by 6 m per year. The head drop moves fluid away from the step. The middle layer 
is relatively impermeable. The pumping does not diminish the supply of fluids in the 
unpumped reservoir above it. The flow field is initially at steady state. The period of 
interest is 10 years.

This discussion first covers the Terzaghi Compaction model and follows with the Biot 
Poroelasticity analysis. Each model description begins with governing equations and 
boundary conditions followed by particulars related to the COMSOL Multiphysics 
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implementation. A data table comes next, concluding with step-by-step instructions 
that describe how to build the model in COMSOL Multiphysics.
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T e r z a gh i  C ompa c t i o n

Introduction

This example sets up a traditional flow model and analyzes the vertical displacement 
during postprocessing. The flow field is fully described using the Darcy velocity in an 
equation of continuity

where S is the storage coefficient (m−1), K equals hydraulic conductivity (m/s), and 
H represents hydraulic head (m). In most conventional flow models, S represents small 
changes in fluid volume and pore space in that it combines terms that describe the 
fluid’s compressibility, the solids’ compressibility, and the reservoir’s porosity. In the 
original research (Ref. 1) and in this model, S is the compressibility of the solid 
skeleton, Ssk; the original study does not consider fluid compressibility.

Because the aquifer is at equilibrium prior to pumping, you set up this model to predict 
the change in hydraulic head rather than the hydraulic head values themselves. The 
main advantage to this approach lies in establishing initial and boundary conditions. 
Here you specify that the hydraulic head decreases linearly by 60 m over ten years, then 
simply state that hydraulic head H0 is zero and remains so where heads do not change 
in time.

The boundary and initial conditions are

where n is the normal to the boundary. The letters  A through  E, taken from Leake 
and Hsieh (Ref. 1), denote the boundary (see Figure 3-2).

Terzaghi theory uses skeletal specific storage or aquifer compressibility to calculate the 
vertical compaction ∆b (m) of the aquifer sediments in a given representative volume as

S H∂
t∂

------- ∇+ K ∇H–( )⋅ 0=

n K H∇⋅ 0= Ω base∂ A
n K H∇⋅ 0= Ω other∂ B
H H0= Ω upper edge∂ C

H H0= Ω surface∂ D

H H t( )= Ω outlet   ∂ E

∆b Sskb H0 H–( )=
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where b is standard notation for the vertical thickness of aquifer sediments (m).

Model Data

The following table gives the data for the Terzaghi compaction model:

Results and Discussion

Figure 3-3 shows a Year-10 snapshot from the COMSOL Multiphysics solution to the 
Terzaghi compaction example. The results describe conventional Darcy flow toward 
the centering of a basin, moving away from a bedrock step (x > 4000 m). The shading 
represents the change in hydraulic head brought on by pumping at x = 0 m. The 
streamlines and arrows denote the direction and magnitude of the fluid velocity. The 
flow goes from vertical near the surface to horizontal at the outlet. Where the 
sediments thicken at the edge of the step, the hydraulic gradient and the fluid velocities 
change abruptly.

TABLE 3-1:  MODEL DATA

VARIABLE DESCRIPTION VALUE

 g Acceleration due to gravity 9.82 m/s2

 ρf Fluid density 1000 kg/m3

 Ssk Skeletal specific storage, aquifer layers 1·10-5 m-1

 Ssk Skeletal specific storage, confining layer 1·10-4 m-1

 Ks Hydraulic conductivity, aquifer layers 25 m/d

 Ks Hydraulic conductivity, confining layer 0.01 m/d

 H0 Initial hydraulic head 0 m

 H(t) Declining head boundary (6 m/year)·t
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Figure 3-3: COMSOL Multiphysics solution to a Terzaghi flow problem. The figure shows 
change in hydraulic head(surface plot) and fluid velocity (streamlines and arrows). Note 
that the vertical axis is expanded for clarity.

Figure 3-4 depicts the vertical compaction predicted for the flow field in Figure 3-3 
according to Terzaghi theory. In COMSOL Multiphysics you can define arbitrary 
expressions that the software evaluates throughout the solution. The 
vertical-compaction estimates from this analysis are based on such user-defined 
expressions. The predicted compaction is greatest at the basin centering and declines 
gradually to the bedrock step. The apparent discontinuity at the step results because 
the Terzaghi formulas depend linearly on the sediment thickness.
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Figure 3-4: Vertical compaction (surface plot and contours) from Terzaghi theory for the 
Year-10 flow field in Figure 3-3. The vertical axis is expanded for clarity. The coordinate 
h denotes the height above the bedrock.

References

Reference numbers for this model refer to the reference list on page 154.

Model Library path:  
Earth_Science_Module/Flow_and_Deformation/terzaghi_compaction

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

Open the Model Navigator. In the list of application modes select  
Earth Science Module>Fluid Flow>Darcy’s Law>Hydraulic head analysis>Transient analysis.
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G E O M E T R Y

1 From the Options menu select Axes/Grid Settings, then click the Axis tab. Clear the 
Axis equal check box, and enter the following x-y limits:

2 Click the Grid tab. Clear the Auto check box, then enter the following settings; when 
done, click OK.

3 Choose Draw>Specify Objects>Rectangle. Create a rectangle with a width of 5200, a 
height of 440, and a y base at -440.

4 Follow the same procedure to create another rectangle with a width of 1200, a height 
of 320, an x base at 4000, and a y base at -440.

5 Choose Draw>Create Composite Object. In the Set formula edit field, type R1-R2, 
then click OK.

6 Click the Zoom Extents button on the Main toolbar.

7 Create a break between the layers by adding lines across the rectangle. Go to the 
Draw toolbar on the left of the COMSOL Multiphysics user interface and click the 
Line symbol. Draw a line across the rectangle at y = −40; right-click to end the line. 
Draw another line across the rectangle at y = −20.

TERM EXPRESSION

x min -100

x max 5300

y min -500

y max 50

TERM EXPRESSION

x spacing 1000

Extra x 4000 5200

y spacing 100

Extra y -20 -40
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O P T I O N S  A N D  S E T T I N G S

Constants
Choose Options>Constants and enter the following names, expressions, and 
descriptions (optional); when done, click OK.

The constant SPY is useful for changing the time unit for the model from the default 
unit second to the more convenient unit year, as you do in this model. This means that 
wherever the user interface displays seconds, you should read years instead.

Subdomain Expressions
Next define expressions for the skeletal specific storage, Ssk, and the hydraulic 
conductivity, Ks.

Choose Options>Expressions>Subdomain Expressions and enter the following names 
and expressions for the designated subdomains; when done, click OK.

The factor 365 in the expressions for the hydraulic conductivity gives this property in 
the unit m/year (see Table 3-1).

P H Y S I C S

Application Scalar Variables
Because the gravity constant, g, contains the dimension time, you need to change the 
value of the corresponding application mode variable, g_esdl to convert the effective 
time unit to years.

1 Choose Physics>Scalar Variables.

2 In the Expression edit field for g_esdl, type 9.82*[m/s^2]*SPY^2. This gives a 
gravity constant expressed in m/year2.

3 In the Expression edit field for Elevation/vertical axis, type y.

4 Click OK.

NAME EXPRESSION DESCRIPTION

rho_f 1000[kg/m^3] Fluid density

SPY 1[year/s] Seconds per year

NAME SUBDOMAINS 1, 3 SUBDOMAIN 2

S_sk 1e-5 1e-4

K_s 25*365 0.01*365
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Model Settings
Choose Physics>Model Settings. Clear the Simplify expressions check box, then click OK.

Subdomain Settings
1 Choose Physics>Subdomain Settings.

2 Select all three subdomains, then enter data according to the table below.

Because the default initial condition is zero, you need not specify it explicitly.

3 From the Physics menu, select Boundary Settings.

QUANTITY SELECTION/DESCRIPTION VALUE

 S User defined S_sk

 Ks Hydraulic conductivity K_s

 ρf Density, liquid rho_f
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4 Specify boundary conditions according to the table below.

In the expression for H0 on Boundary 1 (the outlet), the rate of decline in hydraulic 
head is 6 m/year, but because of the time-unit rescaling you enter seconds instead 
of years. (If you leave out the unit bracket, you get a warning message but the result 
will still be correct because the numerical constant is specified so that the resulting 
expression has the unit displayed to the right of the edit field.)

5 Click OK.

M E S H  G E N E R A T I O N

Click the Initialize Mesh button on the Main toolbar to generate a mesh with the default 
settings.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 On the General page, go to the Time stepping area and in the Times edit field type 
0:1:10.

Because the effective time unit for the model is 1 year, the above setting instructs 
COMSOL Multiphysics to compute the solution for years 0 to 10 in 1-year 
intervals.

3 Click OK, then click the Solve button on the Main toolbar.

SETTINGS BOUNDARY 1 BOUNDARIES 2, 3, 8–11 BOUNDARIES 5, 7, 12

Boundary condition Hydraulic head Zero flow/Symmetry Hydraulic head

H0 -6[m/s]*t - 0
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PO S T P R O C E S S I N G

To generate Figure 3-3 on page 157, proceed as follows:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, verify that the selection in the Solution at time list is 10. In the 
Plot type area, select the Surface, Arrow, and Streamlines check boxes. Clear all the 
others except for Geometry edges.

3 Click the Surface tab. On the Surface Data page, find the Predefined quantities list and 
select Hydraulic head.

4 Click the Range button. Clear the Auto check box, then click OK. This step keeps the 
current range when plotting earlier time steps.

5 In the Surface color area, select cool from the Colormap list.

6 Click the Streamline tab.

7 Go to the Streamline Data page, and in the Predefined quantities list select Velocity 

field. On the Start Points page, click the Specify start point coordinates option button. 
In the x edit field, type 0, and in the y edit field, type -450:50:-50.

8 At the bottom of the Streamline page, click the Advanced button. In the Maximum 

number of integration steps edit field, type 10000, and in the Stationary point stop 

tolerance edit field, type 1e-5. Click OK.

9 Click the Line Color tab, then click the Color button. In the Streamline Color dialog 
box, select an appropriate color, then click OK.

10 Click the Arrow tab. Go to the Arrow Data page, and in the Predefined quantities list 
choose Velocity field. In the Number of points edit fields for x and y enter 25 and 15, 
respectively. Go to the Arrow parameters area. Clear the Auto check box for the 
Scale factor, then in the associated edit field type 0.2.

11 Click the Color button. In the Arrow Color dialog box, select an appropriate color, 
then click OK.

12 Click Apply to generate the plot.

To animate all the time steps, proceed with the following instructions:

13 Click the Animate tab. In the Movie settings area, change the resolution as desired, 
then click Start Animation.

14 Click OK to close the Plot Parameters dialog box.

To reproduce Figure 3-4 on page 158 you need COMSOL Script or MATLAB to 
cumulatively sum the compaction along a vertical column and then contour the results.
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To generate the plot, first create a data matrix where each entry represents a square 
10 m on a side. Then, cumulatively sum the results going up a column. Finally, contour 
the cumulative. In more detail, the procedure for this task is as follows:

1 To export the data as a matrix, choose File>Export>Postprocessing Data.

2 Click the Subdomain tab. In the Expression edit field, type -Ssk*H_esdl*10. Go to 
the Location area and click the Regular grid option button. In the Regular grid 

specification area, find the x points edit field and enter 520; then in the y points edit 
field enter 44. Now each entry represents the compaction in a thickness of 10 m.

3 Click the General tab. For Solution to use, select only the final time step, 10. In the 
Export to file edit field, type the file name terzaghi.txt. Click the Browse button 
so you can save it in your COMSOL Script working directory, then click OK.

If you are to perform the cumulative sum, all entries must have a numeric value. 
However, the terzaghi.txt file you just created contains headers, and NaN 
(not-a-number) appears where the geometry is not defined, such as at the bedrock 
step. To remove the headers and replace the NaNs with zeros, follow these steps: 

1 Open terzaghi.txt with a text editor.

2 Delete the first few lines of text down to and including the second comment line 
beginning with % Data.

3 Use the editor’s Find/Replace function to replace all instances of NaN with a 
number 0.

4 Save the file.

To perform the cumulative summation and contour the results proceed as follows:

1 Go to the COMSOL Script command line and enter the following command 
sequence (for details on the various commands, see the COMSOL Script User’s 
Guide or the COMSOL Script Command Reference):

load terzaghi.txt;
compact = cumsum(terzaghi);
contourf(compact,[min(min(compact)):0.02:max(max(compact))])
colormap('cool'); colorbar; hold on
contour(compact,[min(min(compact)):0.02:max(max(compact))],'k')

2 Click the Edit Plot button in the figure window and edit the plot title and axis labels 
to finish the plot.

To save the compaction data in a text file, compact.txt, give the following command:

save -ascii compact.txt compact
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B i o t  Po r o e l a s t i c i t y

Poroelastic models describe the linked interaction between fluids and deformation in 
porous media. The fluids in a reservoir absorb stress, which registers as fluid pressure 
or equally hydraulic head. For example, if pumping significantly reduces pore fluid 
pressures, sediments could shift due to the increased load. Because the reduction in the 
pore space brings about more fluid movement, the reservoir could compact further. It 
follows that lateral stretching must compensate for the vertical compaction.

The Biot poroelasticity analysis in this example bidirectionally couples the Darcy’s Law 
application mode in the Earth Science Module with the Plane Strain application mode 
in COMSOL Multiphysics. You also can build the model with the Plane Strain 
application mode from the Structural Mechanics Module. Unidirectional links 
between the flow and the solids equations also are possible in COMSOL Multiphysics, 
as is coupling to other physics such as temperature and solute transport.

The U.S. Geological Survey report of Leake and Hsieh (Ref. 1) inspired the Biot 
poroelasticity model of flow that produces vertical and horizontal displacements as well 
as the flow-based Terzaghi vertical compaction study already described (see “Terzaghi 
Compaction” on page 155). The geometry and model description for both analyses 
are identical; what changes is the link to the solid deformation.

Figure 3-5: Model geometry showing boundary segments (based on Leake and Hsieh, Ref. 
1).
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Model Definition

Three sedimentary layers overlay impermeable bedrock in a basin where faulting 
creates a bedrock step near the mountain front. The sediment stack totals 420 m at the 
deepest point of the basin (x = 0 m) but thins to 120 m above the step (x > 4000 m). 
The top two layers of the sequence are each 20 m thick. The first and third layers are 
aquifers; the middle layer is relatively impermeable to flow. As given by the problem 
statement, the materials here are homogeneous and isotropic within a layer.

The flow field is initially at steady state, but pumping from the lower aquifer reduces 
hydraulic head by 6 m per year at the basin center. The head drop moves fluid away 
from the step. The fluid supply in the upper reservoir is limitless. The period of interest 
is 10 years.

Governing Equations

Begin the Biot Poroelasticity analysis by adding a solids-deformation equation to the 
Terzaghi Compaction model file. Modify the fluid equation to include the time rate 
change in strain from the solid-deformation equations. Build the solids equation so 
that it includes the fluid pressure gradient.

F L U I D  F L O W

Use the Darcy’s Law application mode to estimate the flow field in the poroelastic 
model. The fluid equation is 

 (3-1)

where  is the time rate change of strain (s-1) from the equation for solid 
displacements; and αb is an empirical constant usually termed the Biot-Willis 
coefficient. Since u is a displacement vector (m), the right hand term can be intuitively 
interpreted as time rate of expansion (divergence) of the solid matrix. The volume 
fraction available for liquid will increase and thereby give rise to liquid sink, which is 
why the sign is reversed in the source term. Leake and Hsieh (Ref. 1) defined  using 
coefficients from the solids equation, the Young’s modulus, E, and Poisson’s ratio, ν. 
For a further discussion about the quantities in the above equation, see the section 
“Terzaghi Compaction” on page 155 in the Earth Science Module model library. 
Debate over poroelastic storage coefficients is heated (Ref. 4), and the subscript α here 
denotes that conventional storage terms might need redefinition for poroelasticity 
models.

Sα
H∂
t∂

------- ∇+ K∇H–[ ]⋅ α– b
∂
t∂

----- ∇ u⋅( )=

∂
t∂

----- ∇ u⋅( )

Sα
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The only differences between the Terzaghi Compaction model already described and 
this poroelastic analysis lie in material coefficients and sources; the boundary 
conditions are identical. As in the Terzaghi Compaction model, H is the offset in 
hydraulic head since an initial steady-state distribution of H0. This subtle twist 
simplifies describing the boundary conditions: the value at the outlet boundary 
becomes the decline in hydraulic head with time, and at the upper aquifer, the 
hydraulic head is fixed at H0. All other boundaries have symmetry or no-flow 
conditions. The boundary and initial conditions for the Darcy’s law analysis are

where n is the normal to the boundary. The letters A through E come from Leake and 
Hsieh (Ref. 1), each letter denoting a specific boundary (see Figure 3-2). 

S O L I D S  D E F O R M A T I O N

You can define the solids deformation on plane strain. The governing equation in 
Leake and Hsieh (Ref. 1) is

 (3-2)

where E is Young’s modulus (kg/(m·d2)), ν is Poisson’s ratio, and u is the 
displacement vector composed of orthogonal displacements u and v (m). The term 

 (N/m3) amounts to the fluid pressure gradient in the x and y directions 
multiplied by the poroelastic constant and is often described as the fluid-to-structure 
coupling expression. COMSOL Multiphysics efficiently solves the plane-strain 
problem by converting it to a convenient system of equations as described in the next 
section.

Parallel to the flow model, the poroelasticity model uses Equation 3-2 to describe 
change in stresses, σ, strains, ε, and displacement, u, from an initial state. This focus 
on change in displacement is standard in solids modeling and greatly simplifies 
specifying loads, boundaries, and initial conditions. For example, a separate body force 
for gravity need not appear because the changes in load related to the shifting of the 
water are already described in the coupling term. Moreover, Equation 3-2 defines a 
state of static equilibrium because the changes in the solid equilibrate quickly, unlike 

n K∇H⋅ 0= Ω base∂ A
n K∇H⋅ 0= Ω other∂ B
H H0= Ω upper edge∂ C

H H0= Ω surface∂ D

H H t( )= Ω outlet∂ E

E
2 1 ν+( )
---------------------∇2u E

2 1 ν+( ) 1 2ν–( )
------------------------------------------∇+ u∇( )⋅ αbρf g H∇=

αbρf g H∇
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vibrations or waves. Still the time rate of change in strain appears as a coupling term in 
the poroelastic model because the solids equation becomes quasi-static when solved 
simultaneously with a time-dependent flow model.

The boundary conditions are a series of constraints on displacement that allow for 
horizontal movement at the surface and throughout the basin. The base of the 
sediments is fixed, which means you constrain horizontal and vertical displacement to 
zero. The upper surface is free to vary in the horizontal and the vertical directions. 
There is otherwise no horizontal displacement. These conditions result in the 
following boundary expressions

where, once again, the letters A through E come from Leake and Hsieh, and denote 
the boundaries in Figure 3-2.

I M P L E M E N T A T I O N :  P L A N E  S T R A I N  A P P L I C A T I O N  M O D E

The governing equation for the bedrock step problem describes the deformation state 
of plane strain, which is the norm for 2D poroelasticity problems (Ref. 1 and Ref. 4). 
With plane strain, the directional displacements u and v are functions of location in the 
model plane. The strain, ε, normal to the plane or “into the page” equals zero. 

With the Plane Strain application mode, COMSOL Multiphysics solves Equation 3-2 
using Navier’s equations, a system of expressions that relate stresses, σ, strains, ε, and 
displacements, u, in solids. For equilibrium conditions, the stresses are

 (3-3)

where [σ] is the stress tensor, and F is the vector that contains the fluid pressure 
gradient (that is, the fluid-to-structure coupling term) and other body forces when 
present.

The stress-strain relationship for an isotropic material under plane strain conditions 
reads

u v 0= = Ω base∂ A
u 0= Ω other∂ B
u 0= Ω upper edge∂ C
free Ω surface∂ D
u 0= Ω outlet∂ E

∇– σ[ ]⋅ F=
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where τ and γ denote shear stress and shear strain, respectively. 

With small deformations, the normal strains εxx, εyy, εzz and shear strains εxy, εyz, εxz 
relate to the directional displacements u and v for plane strain analyses as follows:

 (3-4)

where strains are defined on directional displacements. 

Inserting the relationships from Equation  and Equation 3-4 into Equation 3-3 gives 
the equation that COMSOL Multiphysics solves,

where c is a tensor defined on the relationships between stresses, σ, strains, ε, and 
displacements, u.

Readers curious about the impacts of different assumptions for poroelastic analyses 
should try switching to one of the time-dependent analyses or even testing large 
deformations or elastoplastic material laws if working in the Structural Mechanics 
Module. To find out more about solids analyses, see the section dedicated to Structural 
Mechanics in the COMSOL Multiphysics Modeling Guide, or examine the Structural 
Mechanics Module User’s Guide for advanced deformation analysis. 

I M P L E M E N T A T I O N :  T I M E  R A T E  C H A N G E  I N  S T R A I N

Adding the time rate change in strain to the flow equation is easy using the integral or 
weak equation form. The weak-form equations are the fundamental form underlying 
the finite element method of COMSOL Multiphysics and as a results are exceedingly 
flexible. To find out more about weak formulations see the COMSOL Multiphysics 
User’s Guide.

σx

σy

τxy

E
1 ν+( ) 1 2ν–( )

---------------------------------------

1 ν– ν 0
ν 1 ν– 0

0 0 1 2ν–
2

----------------

εx

εy

γxy

=

εx x∂
∂u

= εy y∂
∂v

= εxy
1
2
---

y∂
∂u

x∂
∂v

+⎝ ⎠
⎛ ⎞= εxy εyx= εxz εyz= εyz 0= =

∇– c u∇( )⋅ F=
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Model Data

The coefficients and parameters for the poroelasticity model are as follows:

Results and Discussion

Figure 3-6, Figure 3-7, and Figure 3-8 are Year 2, Year 5, and Year 10 snapshots, 
respectively, from the COMSOL Multiphysics solution to a well-known problem of 
linked fluid flow and solid deformation near a bedrock step in a sedimentary basin (Ref. 
1). The shading and arrows, respectively, represent the change in hydraulic head and 
velocities brought about by pumping from the basin interior at x = 0 m. The fluid 
moves from the surface toward the well screens in the lower aquifer, with an abrupt 
change in direction and velocity near the bedrock step. In this way, the flow solution 
here is remarkably similar to the Terzaghi results in Figure 3-3.

The results for the solids displacement tell another story. In Figure 3-6, Figure 3-7, 
and Figure 3-8, contours and deformed shapes illustrate the total displacement. The 
plot sequence illustrates the evolution of lateral deformations that compensate for the 
changing surface elevation above the bedrock step.

VARIABLE DESCRIPTION VALUE

 gr Gravity 9.82 m/s2

 ρf Fluid density 1000 kg/m3

 ρs Solids density 2750 kg/m3

 Poroelastic storage coefficient, aquifer layers 1·10-6 m-1

Poroelastic storage coefficient, confining layer 1·10-5 m-1

 K Hydraulic conductivity, aquifer layers 25 m/d

 K Hydraulic conductivity, confining layer 0.01 m/d

 α Biot-Willis coefficient 1

 H0 Initial hydraulic head 0 m

 H(t) Declining head boundary (6 m/y)·t

 E Young’s modulus, aquifer layers 8·108 N/m

 E Hydraulic conductivity, confining layer 8·107 N/m

 ν Poisson’s ratio, all regions 0.25

Sα

Sα
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Figure 3-6: Solution for a poroelasticity analysis of the bedrock step problem of Leake and 
Hsieh (Ref. 1): Hydraulic head(surface plot), displacement (contours and deformations), 
and fluid velocities (arrows) at Year 2. The vertical axis is expanded for clarity.

Figure 3-7: Hydraulic head(surface plot), displacement (contours and deformations), 
and fluid velocities (arrows) at Year 5.
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Figure 3-8: Hydraulic head(surface plot), displacement (contours and deformations) and 
fluid velocities (arrows) at Year 10.

Figure 3-9 directly compares the 10-year solutions from the Biot analysis (dashed 
lines) and Terzaghi analysis (solid lines). Even at a glance you can notice the similarities 
in the deep part of the basin as well as the marked departure between the two solutions 
near the impermeable steep at the mountain front. The results shown here almost 
perfectly match Figure 3 from Leake and Hsieh (Ref. 1).
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Figure 3-9: COMSOL Multiphysics estimates of displacement from poroelastic analysis 
(dashed lines) and Terzaghi compaction (solid lines) for the bedrock step problem of Leake 
and Hsieh (Ref. 1).

In Figure 3-10, streamlines and shading represent the coupling terms that link the 
fluid and solids equations. The shading gives the time rate of change in strain or the 
structure-to-fluid link. The streamlines depict the fluid-to-structure couplings that 
depend on the fluid pressure gradient.
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Figure 3-10: The fluid-to-solid (surface plot) and solid-to-fluid (streamlines) coupling 
terms evaluated at Year 10 with the poroelastic analysis. 

The Terzaghi and Biot solutions differ most when it comes to predicting the horizontal 
strain at the edge of the bedrock step. The Biot poroelasticity analysis predicts 
horizontal strain; the Terzaghi compaction analysis does not. The horizontal strains at 
the ground surface from the Biot poroelasticity approach appear in Figure 3-11. It 
depicts negative strain or compaction immediately on the basin side of the step; the 
positive strains correspond to tension or lengthening on the mountain side.
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Figure 3-11: COMSOL Multiphysics estimates of horizontal strain from poroelastic 
analysis for the bedrock step problem of Leake and Hsieh: Year 2 (blue, solid line), Year 5 
(green, dotted line), and Year 10 (red, dashed line).

Failure criteria or expressions defining a critical threshold for stress, strain, or 
displacements facilitate evaluating whether the strain differential at the bedrock steps 
is big enough to produce fissures. Figure 3-12 plots von Mises stresses (surface plot), 
fluid velocities (streamlines), and total displacement (deformation). The von Mises 
stresses are postprocessing variables defined by COMSOL Multiphysics in all 
structural-deformation analyses. The von Mises stresses are variables in many failure 
expressions and you can also use them as yield functions in the elasto-plastic materials 
dialog boxes.
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Figure 3-12: COMSOL Multiphysics estimates of von Mises stresses (surface plot), fluid 
velocities (streamlines), and displacement (deformation) at Year 10. These results 
correspond to the porelastic analysis from Leake and Hsieh (Ref. 1). The vertical axis and 
deformation are exaggerated for clarity.

References

Reference numbers for this model refer to the reference list on page 154.

Model Library path: Earth_Science_Module/Flow_and_Deformation/
biot_poroelasticity

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 From the File menu, select Open Model Library. From the Model Library tree, select 
Earth Science Module>Flow and Deformation>terzaghi compaction. Click OK.
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2 From the Multiphysics menu, select Model Navigator. In the list of application modes 
select COMSOL Multiphysics>Structural Mechanics>Plane Strain. Click Add, then click 
OK to close the Model Navigator.

3 From the Multiphysics menu, select Darcy’s Law (esdl) (you set up the flow model 
before beginning with the solids-deformation problem).

O P T I O N S  A N D  S E T T I N G S

1 Choose Options>Constants.

2 Add the following names, expressions, and descriptions (optional) to those already 
present in the table; when done, click OK.

3 Choose Options>Expressions>Scalar Expressions. Enter the following names, 
expressions, and descriptions (optional); when done, click OK.

Here uxt and vyt are the COMSOL Multiphysics variables corresponding to ∂t∂xu 
and ∂t∂yv, respectively.

4 Choose Options>Expressions>Subdomain Expressions. Add the following expressions 
to the table; when done, click OK.

The factor SPY^2 in the expressions for Young’s modulus, E, is required for the 
time-unit conversion from seconds to years because E scales with time, T, as T−2.

The expression C_s2f, is the structure-to-fluid coupling in the fluid equation 
(Equation 3-1).

NAME EXPRESSION DESCRIPTION

rho_s 2750[kg/m^3] Solids density

alpha_b 1 Biot-Willis coefficient

NAME EXPRESSION DESCRIPTION

F_f2sx -alpha_b*rho_f*g_esdl*Hx_esdl Fluid-to-structure coupling 
expression, x direction

F_f2sy -alpha_b*rho_f*g_esdl*Hy_esdl Fluid-to-structure coupling 
expression, y direction

NAME SUBDOMAINS 1, 3 SUBDOMAIN 2

S_alpha 1e-6 1e-5

nu 0.25 0.25

E 800[MPa]*SPY^2 80[MPa]*SPY^2

C_s2f alpha_b*(uxt+vyt)
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P H Y S I C S

Application Scalar Variables
Choose Physics>Scalar Variables. Verify that the gravitational constant g_esdl has a value 
of 9.82[m/s^2]*SPY^2. When done, click OK.

Subdomain Settings
1 Choose Physics>Subdomain Settings.

2 In the Subdomain selection list, select all three subdomains, then change the entry in 
the S edit field for the storage term to S_alpha.

3 In the Qs edit field, type -alpha_b*(uxt+vyt). This term defines the right-hand 
side of Equation 3-1 on page 166.

4 Click OK to close the dialog box.

5 Return to the Multiphysics menu and select Plane Strain (pn).

6 Choose Physics>Subdomain Settings.

7 Go to the Material page. In the Subdomain selection list select all three subdomains 
and then enter these settings:

8 Click the Load tab, then select all three subdomains. In the Fx edit field, type F_f2sx, 
and in the Fy edit field, type F_f2sy.

9 Click OK.

Boundary Conditions
1 Choose Physics>Boundary Settings and then click the Constraints tab.

2 In the Boundary selection list, choose 1, 2, 3, 5, and 8–12. Click the Standard notation 
option button, select the Rx check box, and then in the associated edit field, type 0.

3 Similarly select boundaries 2, 8, and 9. This time select the Ry check box, and in the 
associated edit field type 0.

Note that the surface and sides of the upper aquifer are free so they need no 
boundary conditions.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters.

QUANTITY VALUE/EXPRESSION

 E E

 ν nu

 ρ rho_s
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2 From the Predefined mesh sizes list, select Fine. Click OK.

3 Click the Initialize Mesh button on the Main toolbar.

C O M P U T I N G  T H E  S O L U T I O N

1 The solution time should already be specified for this example. If you want to verify 
this, the setting in the Times edit field in the Solver Parameters dialog box should be 
0:1:10, corresponding to a 10-year range divided into 1-year intervals.

2 COMSOL Multiphysics saves old problems and solutions in an M-file. Sometimes 
they stack up and slow the solution. To clear out the old mesh and solution, choose 
File>Reset Model. In this case, however, the software should solve the problem 
properly without you needing to clear the memory.

3 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G

To generate the plots in Figure 3-6, Figure 3-7, and Figure 3-8, proceed as follows:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, select 2 from the Solution at time list.

3 In the Plot type area, select the Surface, Contour, Arrow, and Deformed shape check 
boxes. Clear the Streamline check box.

4 Click the Surface tab. On the Surface Data page, verify that the selection in the 
Predefined quantities list is Darcy’s Law (esdl)>Hydraulic head.

5 Click the Range button, select the Auto check box, and then click OK. 

6 Click the Contour tab. On the Contour Data page, select Plane Strain (pn)>Total 

displacement from the Predefined quantities list.

7 Go to the Contour levels area and in the Vector with isolevels edit field, type 
0:0.02:0.4.

8 Click the Arrow tab. On the Subdomain Data page, verify that the selection in the 
Predefined quantities list is Darcy’s Law (esdl)>Velocity field. Keep also the other 
settings imported from the Terzaghi Compaction model.

9 Click the Deform tab. From the Predefined quantities list on the Subdomain Data page, 
select Plane Strain (pn)>Displacement.

10 Clear the Auto check box for the Scale factor, and in the associated edit field type 100.

11 Click Apply to generate the plot in Figure 3-6.

12 Generate the plots in Figure 3-7 and Figure 3-8 by changing the selection in the 
Solution at time list in Step 2 to 5 and 10, respectively, and then clicking Apply.
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To animate all the time steps, do as follows:

1 Back in the Plot Parameters dialog box, click the Animate tab.

2 In the Movie settings area, change the resolution as desired, then click Start 
Animation.

Note: To generate the following figure you must run COMSOL Multiphysics with 
COMSOL Script or MATLAB.

To generate Figure 3-9 on page 173, contour the Terzaghi compaction estimates in 
the file compact.txt and then overlay the plot of total displacement estimates from 
the Biot poroelasticity analysis by completing the following steps:

1 Choose File>Export>Postprocessing Data.

2 Click the General tab. As the Solution to use, highlight only the final time step, 10. 
Browse to your COMSOL Script working directory and specify the export file name 
displacement.txt.

3 Click the Subdomain tab. In the Expression edit field, type -disp_pn (the negative 
of the total displacement). In the Location area, click the Regular grid option button. 
Locate the Number of points column in the Regular grid specification area and enter 
520 in the x points edit field and 44 in the y points edit field.

The resulting file, displacement.txt, contains headings, and NaN (not a number) 
appears where the geometry is not defined. You must clear these items before 
plotting the data. To do so, open displacement.txt in a text editor, delete the 
upper headers up to and including the line beginning with % Data, replace all NaN 
entries with the number 0, and then save the file.

4 To contour the compaction and displacement results, go to the COMSOL Script 
command line; if necessary, change the current working directory to the directory 
where you saved the data files compact.txt (see page 164) and 
displacement.txt; and then enter the following sequence:

load compact.txt
load displacement.txt
min_d = min(min(displacement));
max_d = max(max(displacement));
contour(compact,[min_d:0.02:max_d],'k-')
hold on
contour(displacement,[min_d:0.02:max_d],'b--')
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5 Click the Edit Plot button in the figure window and edit the plot title and axis labels 
to finish the plot.

To generate Figure 3-10 on page 174, perform these steps:

1 Click the Plot Parameters button on the Main toolbar.

2 In the Solution at time list on the General page, select the final output time, 10. In 
the Plot type area select the Surface, Arrow, and Streamlines check boxes. Clear the 
Deformed shape check box.

3 Click the Surface tab. On the Surface Data page, type C_s2f/SPY in the Expression 
edit field. Click the Range button, select the Auto check box, then click OK. Go to 
the Surface color area and make an appropriate selection in the Colormap list.

4 Click the Arrow tab. On the Subdomain Data page, select Darcy’s Law (esdl)>Velocity 

field from the Predefined quantities list. In the Arrow positioning area, enter 25 in the 
x points edit field and 15 in the y points edit field. Clear the Auto check box for the 
Scale factor, then in the associated edit field type 0.2.

5 Click the Streamline tab. On the Streamline Data page, type F_f2sx/SPY^2 in the 
x component edit field and F_f2sy/SPY^2 in the y component edit field. From the 
Streamline plot type list, select Start point controlled. On the Start Points page, click 
the Specify start point coordinates option button. In the x edit field enter 0, and in 
the y edit field enter -450:50:-50.

6 Click the Advanced button at the bottom of the dialog box. In the Maximum number 

of integration steps edit field enter 10000, then in the Stationary point stop tolerance 

edit field enter 0.00001. Click OK.

7 In the Streamline color area click the Color button. Choose an appropriate line color, 
then click OK.

8 Finally, click OK to close the Plot Parameters dialog box and generate the plot.

To reproduce the plot in Figure 3-11 on page 175, continue with these steps:

1 Choose Postprocessing>Cross-Section Plot Parameters.

2 On the General page, in the Solutions to use list select 2, 5, and 10.

3 Click the Line/Extrusion tab. Go to the y-axis data area and in the Expression edit field 
enter ux.

4 In the x-axis data area, click the lower option button, then click the Expression 
button. In the X-Axis Data dialog box, type x in the Expression edit field. Click OK.
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5 In the Cross-section line data area, enter data from the following table:

6 Click OK.

Finally, to generate Figure 3-12 on page 176, follow these instructions:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, examine the Solution at time list and verify that the final output 
time 10 is selected. In the Plot type area, select the Surface, Arrow, Streamline, and 
Deformed shape check boxes.

3 Click the Surface tab. In the Predefined quantities list on the Surface Data page, select 
Plane Strain (pn)>von Mises stress. Edit the Expression field entry so that it reads 
mises_pn/SPY^2. Go to the Surface color area and make an appropriate selection in 
the Colormap list.

4 Click the Streamline tab. In the Predefined quantities list on the Streamline Data page, 
select Darcy’s Law (esdl)>Velocity field. Accept the previously specified start points.

5 Click the Arrow tab. In the Predefined quantities list on the Subdomain Data page, 
select Darcy’s Law (esdl)>Velocity field.

6 Click OK.

x0 x1 y0 y1

1000 5000 0 0
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Open -Ho l e  Mu l t i l a t e r a l  We l l—
Poro e l a s t i c  F l ow and De f o rma t i o n

Multilateral wells—those with multiple legs that branch off from a single conduit—can 
produce oil efficiently because the legs can tap multiple productive zones and navigate 
around impermeable ones. Unfortunately, drilling engineers must often mechanically 
stabilize multilateral wells with a liner or casing, which can cost millions of dollars. 
Leaving the wellbore uncased or “open” reduces construction costs, but it runs a 
relatively high risk of catastrophic failure both during installation and after pumping 
begins. 

This COMSOL Multiphysics model examines the mechanical stability of an open-hole 
multilateral well during pumping using poroelastic simulations with Coulomb failure 
criteria. The data and geometry come from E-base, a proprietary database from 
TerraTek (www.terratek.com) that holds data concerning well and rock mechanics. 
The model itself builds on theory outlined by Roberto Suarez-Rivera of TerraTek (Ref. 
1). 

Figure 3-13: Geometry for a COMSOL Multiphysics analysis of a horizontal open-hole 
multilateral well.

80 inches

80 inches

40 inches
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The poroelastic simulations estimate 3D compaction related to pumping by taking 
subsurface fluid flow with Darcy’s law and coupling it to structural displacements with 
a stress-strain analysis. The simulation results feed into the Coulomb expression that 
maps where the compaction from the pumping is enough to have the well fail. The 
discussion in Ref. 1 couples flow and deformation analyses with failure criteria to 
predict if the well fails both during emplacement and as a result of pumping. This 
model focuses on elastic displacements brought on by changing fluid pressures when 
pumping begins. Related analyses for elasto-plastic deformations are straightforward 
using material laws automated in the Structural Mechanics Module. 

Model Definition: Flow and Deformation Simulation

The modeled geometry (Figure 3-13) is the lower half of a branching junction, a 
segment from a larger well network. The junction lies roughly 25 feet from the start 
of the well. The entire well network extends much further, perhaps hundreds of feet. 
The well is 8.5 inches in diameter and sits in a cube 80 inches on each side. Pumps 
move fluid from the reservoir into the well. Fluid exits the geometry only through the 
well. The displacement at the reservoir edge is constrained. The walls of the well, 
however, deform freely. The goal is to solve for the change in fluid pressure, stress, 
strain, and displacement that the pumping causes rather than their absolute values. 

F L U I D  F L O W

To describe fluid flow, you insert the Darcy velocity into an equation of continuity

where κ is the permeability, η is the viscosity, and p equals the pressure of the oil in the 
pore space. 

For the flow boundaries, you already know the change in fluid pressure from the well 
to the reservoir edge. The planar surface adjacent to the well (between the upper and 
lower blocks) is a symmetry boundary. Because the well is the only exit for the fluid, 
there is no flow to or from connecting well segments. In summary,

∇ κ
η
---∇p–⋅ 0=
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where n is the normal to the boundary. 

S O L I D  D E F O R M A T I O N

The system of equations that describes the solids deformation is

where u is a vector of the directional displacements u, v, and w, and the directional 
components of the gradient in fluid pressure, p, make up a vector forces, F. The 
coefficient c relates the displacements to the stresses and the strains in this way:

where ε is the strain tensor, and σ denotes the stress tensor. The terms ε and σ are 
related by σ = D ε . D, a 36-entry tensor, is a function of Young’s modulus, E, and 
Poisson’s ratio, ν. 

For the boundary conditions, the model constrains movement at all external 
boundaries. The well opening is free to deform. In summary:

.

p pr= Ω reservoir∂

n κ
η
---∇p–⋅ 0= Ω symmetry face∂

n κ
η
---∇p–⋅ 0= Ω connecting segments∂

p pw= Ω well∂

∇– c u∇( )⋅ F α p∇= =
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Results: Flow and Deformation Simulation

The following figures show results from simulations for coupled fluid flow and 
reservoir deformation following a poroelastic approach for the horizontal multilateral 
well reported in Ref. 1. 

The isosurfaces in Figure 3-14 indicate the fluid pressure throughout the well’s lower 
half. The streamlines show the fluid paths and velocities. Fluid pressure drops from the 
reservoir toward the well opening. The velocity typically increases toward the well but 
remains close to zero near the branching legs of the junction.

Figure 3-14: COMSOL Multiphysics poroelastic analysis of a multilateral well. Results 
are fluid pressure (the isosurfaces), pressure gradient (streamlines), and fluid velocities 
(streamline shading).

Results for elastic deformation appear in Figure 3-15. The surface shading denotes 
total displacement. The plot illustrates directional displacements by shifting the 
shading relative to an outline of the original geometry. For a clear view, the 
displacements are exaggerated. The uncased surface yields slightly because the 
deformed shading fills in the hollows of the well. The largest displacements occur just 
above the split in the well.
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Figure 3-15: COMSOL Multiphysics estimates of displacement. Shading indicates the 
total displacement, and the geometry appears as lines. Even as the deformed shape shifts, 
those lines remain steady; the shaded image shows movement relative to the geometry 
outlines.

Figure 3-16 plots the pressure isosurfaces and the velocity streamlines from 
Figure 3-14 with the displacements from Figure 3-15 using wire-mesh options directly 
available from the COMSOL Multiphysics postprocessing user interface.
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Figure 3-16: Poroelastic analysis near a branch in a multilateral well showing fluid 
pressures (the isosurfaces), velocity (streamtubes), total displacement (the mesh), and 
directional displacements (the deformed shape).

Failure Criterion

This model allows the evaluation of failures during postprocessing using results from 
the fluid-flow and solid-deformation simulations shown in the preceding figures. This 
discussion follows calculations that Ref. 1 uses to map calculations indicating where 
pumping could compact the reservoir enough (see Figure 3-15) that the well will fail. 
Refer to Ref. 1 to estimate the critical rock strength required to successfully emplace 
the well, and also to learn more about calibration to data.

The 3D Coulomb failure criterion in Ref. 1 relates rock failure, the three principal 
stresses (σ1, σ2, and σ3), and the fluid pressures as follows:

 (3-5)
fail σ3 p+( ) Q σ1 p+( ) N 1

σ2 σ1–( )
σ3 σ1–( )

-----------------------+⎝ ⎠
⎛ ⎞+–=

Q 1 φsin+
1 φsin–
----------------------,           N 2 φcos

1 φsin–
---------------------So==
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Here So is the Coulomb cohesion and  is the Coulomb friction angle. When properly 
calibrated, fail = 0 indicates the onset of rock failure; fail < 0 denotes catastrophic 
failure; and fail > 0 predicts stability. Because this model solves for the pressure change 
brought on by pumping as well as the stresses, strains, and displacements that the 
pressure change triggers, it calculates the expression just given using the change in 
pressure than its absolute value.

Results: Failure Criterion

The values for the fail function appear in Figure 3-17. When the fail values become 
increasingly negative, the potential for failure is higher. As expected, the fail function 
estimates show the greatest potential for failure just above the split in the well. 

Figure 3-17: Values of the fail function calculated with results from a poroelastic model 
for the branching junction in an open-hole multilateral well. A negative value for the fail 
function denotes greater potential for failure.

Conclusions

This example couples fluid flow and solid deformation for a poroelastic analysis using 
easy-to-use application modes from COMSOL Multiphysics. The analysis provides 
estimates of the pressure change brought on by pumping as well as the stresses, strains, 

φ
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and displacements that the pressure drop triggers. Combining the simulation results 
with a 3D Coulomb failure expression, maps vulnerability to mechanical failure from 
the pumping. The data and geometry for this model come from petroleum industry 
analyses by TerraTek (Ref. 1), which in turn use failure criteria to map the potential for 
failure during emplacement of the well in addition to the potential for failure when the 
well is pumped.

Data

This model uses the coefficients and parameters listed in Table 3-2.

Reference

1. R. Suarez-Rivera, B.J. Begnaud, and W.J. Martin, “Numerical analysis of open-hole 
multilateral completions minimizes the risk of costly junction failures,” Rio Oil & Gas 
Expo and Conference (IBP096_04), 2004.

Model Library path: Earth_Science_Module/Flow_and_Deformation/
multilateral_well

TABLE 3-2:  MODEL DATA

VARIABLE DESCRIPTION VALUE

 ρf Fluid density 0.0361 lb/in3

 κ Permeability 1·10-13 in2

 η Viscosity 1·10-7 psi·s

 E Young’s modulus 0.43·106 psi

 ν Poisson’s ratio 0.16

 ρs Solids density 0.0861 lb/in3

 pr Pressure in reservoir 122.45 psi

 pw Pressure in well 0 psi

 So Coulomb cohesion 850 psi

Coulomb friction angle 31 degrees

 C1 Calibration constant 1 14.7

 C2 Calibration constant 2 40

φ
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Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator.

2 From the Space dimension list, choose 3D.

3 In the list of application modes, select Earth Science Module>Fluid Flow>Darcy’s 

law>Pressure analysis. Click the Multiphysics button, then click Add.

4 In the list of application modes select COMSOL Multiphysics>Structural Mechanics> 

Solid, Stress-Strain. Click Add.

5 Click OK.

G E O M E T R Y  M O D E L I N G

In this example, the geometry already exists in a COMSOL Multiphysics model file.

1 Choose File>Import>CAD Data From File.

2 Browse to the folder Earth_Science_Module>Flow_and_Deformation in the 
Model Library root directory.

3 Select the file multilateral_well.mphbin, then click Import.

The length unit used for the CAD geometry is 1 in. Because COMSOL Multiphysics’ 
default base unit system is SI, with basic length unit 1 m, you need to scale the 
geometry by the factor 0.0254 along all three coordinate axes to keep the default base 
unit system. Alternatively, you can change the base unit system to Gravitational IPS, 
which uses the inch as basic length unit.

As a third option, which is the one exemplified in these modeling instructions, you can 
scale the geometry by a factor 1/12 and change the base unit system to British 
engineering units, with basic length unit 1 ft. Thus, complete the geometry-modeling 
stage with the following steps:

1 Click the Scale button on the Draw toolbar.

2 In the Scale factor edit fields for X, Y, and Z, type 1/12. Leave the Scale base point at 
(0, 0, 0).

3 Click OK.

4 Click the Zoom Extents button on the Main toolbar.

The length unit in the drawing area is now 1 ft.
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M O D E L  S E T T I N G S

The model data in Table 3-2 is given in pounds and inches. As long as you include the 
units when entering the data and scale the geometry if required, as just discussed, 
COMSOL Multiphysics’ unit-handling functionality allows you choose whether to use 
these units also when analyzing the model or change to some other system. Here, to 
change to British engineering units, proceed as follows:

1 From the Physics menu, select Model Settings.

2 From the Base unit system list, select British engineering units.

3 Click OK.

O P T I O N S

Constants
Define constants you need in the model or during postprocessing.

1 From the Options menu, open the Constants dialog box.

2 Enter the following constants in the following table:

NAME EXPRESSION DESCRIPTION

kappa_s 1e-13[in^2] Permeability

rho_f 0.0361[lb/in^3] Fluid density

eta 1e-7[psi*s] Dynamic viscosity

E 0.43e6[psi] Young’s modulus

nu 0.16 Poisson’s ratio

rho_s 0.0861[lb/in^3] Solids density

p_r 122.45[psi] Pressure in reservoir

p_w 0[psi] Pressure in well

So 850[psi] Coulomb cohesion

phi 31*pi[rad]/180 Friction angle

C1 14.7 Calibration constant 1

C2 40 Calibration constant 2
R  3 :  F L O W  A N D  S O L I D  D E F O R M A T I O N  M O D E L S



3 Click OK to close the Constants dialog box.

Scalar Expressions
1 From the Options menu, choose Expressions>Scalar Expressions.

2 Define the following scalar expressions (the descriptions are optional):

Note that the expression fail defined in Equation 3-5 has the dimension of stress. 
By appending the operator [1/psi] to the dimensionful expression enclosed within 
parentheses you extract its value in psi, which is what Ref. 1 uses. This way, you can 
analyze the risk for rock failure using the same criteria as in Ref. 1 independently of 
your choice of base unit system.

3 Click OK.

P H Y S I C S  S E T T I N G S — D A R C Y ’ S  L A W

Subdomain Settings
1 From the Multiphysics menu, select Darcy’s law (esdl).

NAME EXPRESSION DESCRIPTION

N 2*So*cos(phi)/(1-sin(phi)) Fail parameter

Q (1+sin(phi))/(1-sin(phi)) Fail parameter

fail (((s3_sld+C1*(p_r-p))- 
Q*(s1_sld+C1*(p_r-p))+ 
N*(1+(s2_sld-s1_sld)/ 
(s3_sld-s1_sld)))/C2)[1/psi]

Fail expression

support_x 0 Well support, x-component

support_y 0 Well support, y-component

support_z 0 Well support, z-component
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2 From the Physics menu, select Subdomain Settings.

3 Select Subdomain 1.

4 On the Coefficients page, select Permeability from the drop-down list.

5 Enter the following settings; when done, click OK.

6 On the Init page, type p_r in the p(t0) edit field, then click OK.

Boundary Conditions
1 From the Physics menu, select Boundary Settings.

2 Enter the following settings; when done, click OK.

P H Y S I C S  S E T T I N G S — S O L I D  S T R E S S  S T R A I N

Subdomain Settings
1 From the Multiphysics menu, select Solid, Stress-Strain (sld).

2 From the Physics menu, select Subdomain Settings.

3 On the Material page, enter the following settings:

4 On the Load page, enter these settings:

QUANTITY VALUE

 κs kappa_s

 ρf rho_f

 η eta

SETTINGS BOUNDARIES 1, 3, 13 BOUNDARIES 6–10 BOUNDARIES 2, 4, 5, 11, 12

Boundary condition Pressure Pressure Zero flow/Symmetry

p0 p_r p_w

QUANTITY VALUE/EXPRESSION

 E E

 ν nu

 ρ rho_s

QUANTITY VALUE/EXPRESSION

Fx -px

Fy -py

Fz -pz
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5 Click OK.

Boundary Conditions
1 From the Physics menu, select Boundary Settings.

2 On the Constraints page, enter these settings:

3 On the Load page, enter the following settings:

4 Click OK.

M E S H  G E N E R A T I O N

1 Choose Mesh>Free Mesh Parameters.

2 On the Global page, select Coarse from the Predefined mesh sizes list. Click OK.

3 Click the Initialize Mesh button on the Main toolbar.

CONSTRAINT BOUNDARY EXPRESSION

Rx 1, 3, 13 0

Ry 1–3, 5, 13 0

Rz 1, 3, 4, 11–13 0

QUANTITY BOUNDARIES EXPRESSION

Fx 6–10 -support_x

Fy 6–10 -support_y

Fz 6–10 -support_z
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C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar to start the analysis with the default solver 
settings.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate Figure 3-14 on page 186:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, go to the Plot type area and select the Isosurface and Streamline 
check boxes. Clear the Slice check box.

3 Click the Isosurface tab. On the Isosurface Data page, set the Expression to p and the 
Unit to psi.

4 Click the Streamline tab. On the Streamline Data page, choose Darcy’s Law 

(esdl)>Pressure gradient from the Predefined quantities list. On the Start Points page, 
type 60 in the Number of start points edit field. On the Line Color page, click the Use 

expression button, then click the Color Expression button. From the Predefined 

quantities list, choose Darcy’s Law (esdl)>Velocity field. Clear the Color scale check 
box, then click OK. Select Tube in the Line type list. Click the Tube Radius button, 
then clear the Auto check box for Radius scale factor and type 0.4 in the associated 
edit field. Click OK to close the Tube Radius Parameters dialog box.

5 Click Apply to generate the plot.

6 Click the Headlight button on the Camera toolbar to add directed light.

To generate Figure 3-15 on page 187:

1 In the Plot Parameters dialog box, click the General tab.

2 Clear the Isosurface and Streamline check boxes and select the Boundary and 
Deformed shape check boxes in the Plot type area.

3 Click the Boundary tab.

4 In the Boundary data area, select Solid, Stress-Strain (sld)>Total displacement from the 
Predefined quantities list. From the Unit list, select in.

5 Click the Deform tab and select Solid, Stress-Strain (sld)>Displacement from the 
Predefined quantities list on the Subdomain Data page. Click Apply.

To generate Figure 3-16 on page 188:

1 Click the General tab, then select the Isosurface and Streamline check boxes in the 
Plot type area. Leave the Boundary and Deformed shape check boxes unchanged.

2 Click the Boundary tab. From the Fill style list, select Wireframe. Click Apply.
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3 Click the Zoom In button on the Main toolbar.

To generate Figure 3-17 on page 189:

1 Click the General tab. In the Plot type area, clear the Streamline, Boundary, and 
Deformed shape check boxes. Select the Slice and Subdomain check boxes.

2 Click the Isosurface tab. On the Color Data page, enter fail in the Expression edit 
field. Click the Vector with isolevels option button and enter -20:10:20 in the 
associated edit field. From the Colormap list, choose wave. With this choice, negative 
values, zero, and positive values appear in shades of blue, white, and shades of red, 
respectively.

3 Click the Subdomain tab. In the Color data area, type fail<=-20 in the Expression 
edit field. Click the Range button. Clear the Auto check box. For min and max enter 
0.001 and 1.00, respectively. Click OK. In the Element color area, click the Uniform 

color option button, the click the Color button. Choose black, then click OK.

This string of steps begins with the expression that assigns fail values less than or 
equal to −20 with a value of 1 and those greater than −20 with a value of zero. The 
minimum and maximum data levels serve to cut off values of zero from the plot, so 
only fail less than or equal to −20 are denoted with a uniform color of black.

4 Finally go to the Slice page. In the Slice data area, type fail>21 in the Expression 
edit field. Click the Range button. Clear the Auto check box. For min and max enter 
0.001 and 1.00, respectively. Click OK. In the Number of levels edit fields in the Slice 
positioning area, set the number of x levels and z levels to 0, and the number of 
y levels to 5. In the Slice color area, click the Uniform color option button, then click 
Color. Choose a gray shade, then click OK. Choose Wireframe from the Fill style list.

5 Click OK.
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F r e e z i n g  S o i l

Introduction

When wet soil or clay is subjected to freezing temperatures, water in the interstices 
freezes. Because water expands when it freezes, the surrounding soil deforms. The 
deformation changes the pressure in the interstices. The combined impacts of the 
freezing and the deformation affect the water flow.

This model predicts 3-way interactions between stress and strain, fluid flow, and 
temperature change. This type of analysis is important in assessments related to road 
and building construction, freeze-thaw weathering, fluid flow, and a number of 
environmental applications. The model that follows comes from a COMSOL client 
who used the results to assess thermo-mechanical impacts in a transportation study.

This analysis couples equations that predict what happens when a water-filled soil core 
freezes from the center outwards. Included in the analysis are:

• Effects of a stepwise change in the thermomechanical properties at the phase 
transition temperature

• Porous fluid-flow behavior involving a temperature-driven contribution

• Stress-strain behavior including loads from thermal expansion and fluid flow

• Heat conduction including phase change and the latent heat of freezing

• Coupling effects between the above-mentioned phenomena.

This discussion assumes temperature changes are fully transient with a quasi-static 
interaction with fluid flow and solid deformation. The model uses the Darcy’s Law and 
the Convection and Conduction application modes from the Earth Science Module. 
It also employs a Stress-Strain application mode from the Structural Mechanics 
Module, an application mode that automates temperature-deformation coupling.
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Model Definition1

Figure 3-18: Experimental setup for investigations of freezing soil. A symmetry 
observation permits modeling in axisymmetry 2D.

The model geometry is based on a general test rig often used for investigating the 
properties of soil and clay (see Figure 3-18). A cylindrical container with the sample 
soil has a concentric channel, through which a coolant fluid flows. The initial 
temperature of the wet soil is +3 °C. As the coolant at −15 °C enters the pipe, a 
freezing front travels outward in the soil specimen. Because the soil is homogeneous, 
you can take advantage of the geometric symmetry and model the phenomena in 2D.

S T R E S S - S T R A I N  E Q U A T I O N S

The fundamental Navier’s equation describes a force equilibrium

 (3-6)

where σ is the stress tensor and F is a volume force.

The entries of the stress tensor for axisymmetry are

1. Model definition and material data courtesy of Dr. J.P.B.N. Derks, Ministry of Transport, Public Work &  
Water Management, the Netherlands.

3D to 2D axial symmetry

Coolant flow

0.22 m

ro=0.05 m

ri=0.006 m

Soil or clay fill

∇– σ⋅ F=
F R E E Z I N G  S O I L  |  199



200 |  C H A P T E
where τ denotes off-diagonal components of strain or shear.

The equations simplify to two force balances in the r and z directions:

 (3-7)

 (3-8)

where τ denotes off-diagonal components of strain or shear.

Flow-to-Structure Coupling
When considering the impacts of fluid flow on structural deformation, the stress tensor 
decompose into two parts

 (3-9)

where σ is the total stress, σ' is the so-called grain stress, and p is the pressure of the 
fluid moving through a porous sand or clay matrix.

In this analysis

.

Temperature-to-Structure Coupling
The thermomechanical relationship is given by the generalized Hooke’s law for an 
elastic nonisothermal material as in

.  (3-10)

Here D is the elasticity matrix, σ' represents the elastic stress, ε gives the total strain, 
and εth is the thermal strain. Further, α (K−1) is the coefficient of thermal expansion, 
T is the temperature, and Tref is the strain reference temperature.

σ

σxx

σyy

σzz

τxy

τxz

τyz
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∂σr

∂r
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∂r
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σr σθ–
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∂τrz

∂r
----------

∂σz

∂r
---------

τrz

r
------- Fz+ + + 0=

σ σ' mp+=

m 1 1 1 0 0 0
T
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σ' D ε εth–( ) ,= εth α T Tref–( )=
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Model the flow with the modified Darcy’s law

 (3-11)

where u = (u, v, w) denotes the vector of fluid velocities in the x, y, and z directions, 
and  is the suction pressure.

Temperature-to-Flow Coupling, Segregation Potential
The fluid flow and temperature relationships couple through the term 

,

where SP0 is the segregation potential (kg·m/(s2·K)), which is the ratio of the 
moisture migration velocity to the temperature gradient in a freezing soil, and κ is the 
permeability (m2). The segregation potential SP0 is a positive constant below the 
freezing point and 0 above. Experimental observations on specimens frozen under a 
temperature gradient suggest that, even though much of the pore water is frozen, 
water transport still occurs in the frozen soil past the pore freezing front in response 
to temperature-induced unfrozen water content gradients and suction gradients in 
these unfrozen water films. The migratory water freezes at the segregation freezing 
temperature, Ts, which is lower than the pore freezing temperature Tp (Ref. 1). In this 
model example, it is assumed that the segregation freezing temperature is well below 
the temperature range of the study.

Given the definition for , Equation 3-11 states that the fluid velocities depend on 
the pressure gradient and the temperature gradient for conditions below the freezing 
point. 

Structure-to-Flow Coupling
For quasi-steady flow, the following relationship holds:

,  (3-12)

where  and similar terms are the rates of strain (s−1) from the stress-strain 
equations.

Combining Equation 3-11 and Equation 3-12 gives the governing equation

,  (3-13)

u κ
η
---∇ p φs+( )–=

φs

φs SP0 T κ⁄⋅=

φs

∇ u⋅ ε· xx ε· yy ε· zz+ +( )–=

ε· xx

∇ k
η
---∇ p φs+( )–⎝ ⎠

⎛ ⎞⋅ ε· xx ε· yy ε· zz+ +( )–=
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which this example models with the Darcy’s Law application mode.

TE M P E R A T U R E  E Q U A T I O N S

This problem uses the well-known heat equation to model the transfer of heat. As 
described in the Earth Science Module User’s Guide, the heat transfer equation reads

.

Results

Figure 3-19: A snapshot of the von Mises stresses (surface plot) and displacements 
(contours) in a column of freezing soil.

ρcp
∂T
∂t
------- ∇ k∇T–( )⋅+ Q=
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Figure 3-19 shows the displacements in the solid sample and the von Mises stresses 
after 12 hours of freezing operation. It is also easy to monitor how the physical 
properties of the sand change with time and space; see Figure 3-20.

Figure 3-20: Thermal conductivity changes in a step at the freezing point. The lower curve 
corresponds to 24 minutes, and the upper curve to 7 hours and 12 minutes.

Reference

1. Jean-Marie Konrad, “Estimation of the segregation potential of fine-grained soils 
using the frost heave response of two reference soils,” Can. Geotech. J., vol. 42, 
pp. 38–50, 2005.

Modeling in COMSOL Multiphysics

Turning to the COMSOL Multiphysics Structural Mechanics Module, you choose the 
Axial Symmetry, Stress-Strain application mode to solve Equation 3-7 and 
Equation 3-8. To account for the fluid pressure according to Equation 3-9, simply add 
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to the body load vector F on the Load page in the Subdomain Settings dialog box. To 
have that application mode automatically account for the thermomechanical relations, 
Equation 3-10, select the Include thermal expansion check box on the Load page. To 
get easy access to the rates of strain (time derivatives of the strain), use a 
time-dependent stress-strain analysis. This solves Equation 3-6 with an extra term on 
the left-hand side, namely ρ ( ∂2u ) / (∂t2 ), which is the acceleration term in Newton’s 
second law. Here, u is the vector of directional deformations (in m). However, you can 
make the assumption that the time scale in the mechanical problem is much shorter 
than that for the heat transfer problem. Here you skip the time-derivative term in the 
stress/strain equation by setting ρ = 0 and still access the rates of strain as described in 
the next paragraph.

It is easy to implement the modified Darcy’s law (Equation 3-8) with the Earth 
Science Module’s Darcy’s Law application mode, and its predefined equation is

.  (3-14)

Because the vertical change is small, you can ignore gravity impacts on flow. There is, 
however, another contribution to the mass flux, namely that from the segregation 
potential (see Equation 3-13). Include this contribution by setting .

Next place the rate-of-strain expression in Equation 3-12 in the Qs term. The r, φ, and 
z components of the rate of strain, , and , are readily available in the 
time-dependent Axial Symmetry, Stress-Strain application mode as the expressions 
diff(er_stress,t), diff(ephi_stress,t), and diff(ez_stress,t). Hence, 
enter -(diff(er_stress,t)+diff(ephi_stress,t)+diff(ez_stress,t)) in the 
Qs edit field of the Darcy’s Law application mode.

The model handles the stepwise-changing material properties at the freezing point as 
well as the latent heat of freezing as described in “Phase Change” on page 303 in the 
Earth Science Module Model Library.

∂p
∂r
------–

∂p
∂z
------–

∇ κ
η
---∇ p ρf gD+( )–⎝ ⎠

⎛ ⎞⋅ Qs=

D φs gρf( )⁄=

ε· rr ε· φφ ε· zz
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Note: This model requires the Earth Science Module and the Structural Mechanics 
Module.

Model Library path: Earth_Science_Module/Flow_and_Deformation/
freezing_soil

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 In the Model Navigator, select Axial symmetry (2D) from the Space dimension list and 
then in the list of application modes select Structural Mechanics Module>Axial 

Symmetry, Stress-Strain>Static analysis. In the Application mode name edit field, type 
stress.

2 Click the Multiphysics button, then click Add.

3 Return to the list of application modes and select COMSOL Multiphysics> 
Heat Transfer>Conduction>Transient Analysis. In the Application mode name edit field 
enter heat, then click Add.
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4 In the list of application modes select Earth Science Module>Fluid Flow> 
Darcy’s Law>Pressure analysis. In the Application mode name edit field enter Darcy, 
then click Add.

5 Click OK.

O P T I O N S

1 From the Options menu select Constants and enter the following names, expressions, 
and descriptions (optional); when done, click OK.

G E O M E T R Y  M O D E L I N G

1 Shift-click the Rectangle/Square button at the top of the Draw toolbar.

2 In the Size area, set the Width to 0.044 and the Height to 0.22.

3 In the Position area, select Center from the Base list. Set r to 0.028 and z to 0.11.

4 Click OK, then click the Zoom Extents button on the Main toolbar.

NAME EXPRESSION DESCRIPTION

T_trans 0[degC] Freezing point

scale 0.5 Width of smoothed step function

rho_sa 2000[kg/m^3] Density

nu0 0.3 Poisson’s ratio

alpha_s 0.8e-6[1/K] Coefficient of thermal expansion

T_init 3[degC] Intial temperature

k_sf 4.6[W/(m*K)] Thermal conductivity below freezing point

k_s 2.6[W/(m*K)] Thermal conductivity above freezing point

Cp_sf 1000[J/(kg*K)] Heat capacity below freezing point

Cp_s 1350[J/(kg*K)] Heat capacity above freezing point

kappa_s 7.1e-5[m^2] Permeability, unfrozen sand

eta_s 0.001[Pa*s] Dynamic viscosity

E0_s 65[MPa] Young’s modulus

t_load 300[kN/m^2] Top edge load

e_load 300[kN/m^2] Side edge load

dT 0.5[K] Half width of Gauss bell curve

lam 333[kJ/kg] Latent heat of freezing

p_pore 150[kPa] Pore pressure
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E X P R E S S I O N  D E F I N I T I O N S

From the Options menu select Expressions>Scalar Expressions, then add the following 
names, expressions, and descriptions (optional); when done, click OK.

The unit brackets [1/K] and [1/s] make the function inputs dimensionless.

P H Y S I C S  S E T T I N G S

Application Scalar Variables
To include the segregation potential mass-flux term in the way described below 
Equation 3-14, you need to modify the application scalar variable DDarcy.

1 From the Physics menu, select Scalar Variables.

2 In the Expression column for D_Darcy, type (Sp0*T/kappa_s)/
(g_Darcy*rhof_Darcy).

3 Click OK to close the Application Scalar Variables dialog box.

Subdomain Settings—Axial Symmetry, Stress-Strain
1 From the Multiphysics menu, select Axial Symmetry, Stress-Strain (stress).

2 From the Physics menu, select Subdomain Settings. 

3 Select Subdomain 1, then enter the values in the following table:

4 On the Load page, select the Include thermal expansion check box.

NAME EXPRESSION DESCRIPTION

HS flc1hs((T-T_trans)[1/K],scale) Smoothed Heaviside step

k_g k_sf+(k_s-k_sf)*HS Varying thermal conductivity

D exp(-(T-T_trans)^2/dT^2)/ 
sqrt(pi*dT^2)

Smoothed Dirac delta function

Cp Cp_sf+(Cp_s-Cp_sf)*HS Varying heat capacity

T_b T_init+18[K]*(1- 
2*flc1hs(t[1/s],100))

Varying boundary temperature

Sp0 (1-HS)*1e-12[kg*m/(s^2*K)] Varying segregation potential

QUANTITY VALUE/EXPRESSION DESCRIPTION

 E E0_s Young’s modulus

 ν nu0 Poisson’s ratio

 α alpha_s Thermal expansion coeff.
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5 Specify the loads as in the following table; when done, click OK.

Boundary Conditions—Axial Symmetry, Stress-Strain
1 Select the menu Physics>Boundary Settings.

2 On the Constraint page select Boundaries 1 and 2. From the Constraint condition list 
select Roller.

3 Click the Load tab. Select Boundary 3, and set Fr to 0 and Fz to -t_load.

4 Select Boundary 4. Set Fr to -e_load and Fz to 0.

5 Click OK.

Subdomain Settings—Heat Transfer
1 From the Multiphysics menu select Heat Transfer by Conduction (heat).

2 Choose Physics>Subdomain Settings, then specify these settings:

3 On the Init page, set T(t0) to T_init. Click OK.

Boundary Conditions—Heat Transfer
1 Choose Physics>Boundary Settings and select Boundary 1. From the Boundary 

condition list select Temperature, then in the Temperature edit field type T_b.

2 Select Boundary 4. In the Boundary condition list select Temperature, then in the 
Temperature edit field type T_init. Click OK.

Subdomain Settings—Darcy’s Law
1 Select the menu item Multiphysics>Darcy’s Law (Darcy).

2 From the Physics menu, select Subdomain Settings.

QUANTITY VALUE/EXPRESSION DESCRIPTION

Fr -p2r Body load (force/volume) r dir.

Fz -p2z Body load (force/volume) z dir.

Temp T Strain temperature

Tempref T_init Strain ref. temperature

QUANTITY VALUE/EXPRESSION DESCRIPTION

 k (isotropic) k_g Thermal conductivity

 ρ rho_s Density

 Cp Cp+D*lam Heat capacity
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3 Specify the following settings; when done, click OK.

Because of the setting for D on page 207, the density value has to be nonzero but 
is otherwise irrelevant.

Boundary Conditions—Darcy’s Law
Choose Physics>Boundary Settings, then select Boundary 1. In the Boundary condition 
list select Pressure, then set p0 to p_pore. Similarly select Boundary 4 and set the 
Pressure to 0. Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters.

2 Click the Boundary tab and select Boundary 1. In the Maximum element size edit field 
enter 0.003.

3 Click Remesh. When the mesher has finished, click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 In the Times edit field, type 0:1440:43200. This provides 30 equidistant time steps 
during a total simulation time of 12 hours (43, 200 s).

3 In the Absolute tolerance edit field, type uor 1e-6 w 1e-6 T 0.001 p2 10. This 
sets up absolute tolerances of 10−6 for the displacement variables, 0.001 for the 
temperature, and 10 for the pressure. Click OK.

4 Click the Solve button on the Main toolbar to compute the solution.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To reproduce the plot in Figure 3-19, follow these steps.

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, go to the Plot type area and select the Surface, Contour, 
Deformed shape, and Geometry edges check boxes.

QUANTITY VALUE/EXPRESSION DESCRIPTION

 κs kappa_s Saturated permeability

 ρf 1 Density, liquid

 η eta_s Viscosity, liquid

 Qs -(diff(er_stress,t)+diff(ephi_stress,t) 
+diff(ez_stress,t))

Liquid source
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3 Click the Surface tab, then in the Predefined quantities list on the Surface Data page 
select Axial Symmetry, Stress-Strain (stress)>von Mises Stress.

4 From the Unit list, select kPa.

5 Click the Contour tab, and in the Predefined quantities list on the Contour Data page 
select Axial Symmetry, Stress-Strain (stress)>Total displacement.

6 From the Unit list, select mm.

7 Click OK to close the Plot Parameters dialog box and generate the plot.
R  3 :  F L O W  A N D  S O L I D  D E F O R M A T I O N  M O D E L S



 4
S o l u t e  T r a n s p o r t  M o d e l s
In this chapter you find models of solute transport, including solute injection, 
variably saturated flow, and pesticide transport and reaction.
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S o l u t e  I n j e c t i o n

Introduction

Predicting the transport of contaminants that move with subsurface fluids generally 
means analyzing at least two physics. This model tracks a contaminant that enters an 
aquifer at a point, such as an injection well or toxic spill, and spreads through the 
aquifer with time. The model has an analytic solution developed by Wilson and Miller 
(Ref. 1), which has been used to test several dedicated fluid flow and transport codes. 
The particular problem in this model comes from the MT3DMS manual of Zheng and 
Wang (Ref. 2).

The analysis models steady-state fluid flow and follows up with a transient 
solute-transport simulation; it employs the Darcy’s Law application mode and the 
Solute Transport application mode from the Earth Science Module. In COMSOL 
Multiphysics it is straightforward to specify a fluid velocity without solving a flow 
problem. This example solves for the velocities to demonstrate the mechanics of 
coupling flow and transport simulations in one model file. 

The example also shows how to use the solver settings for the combined steady-state 
and transient solution. The instructions detail how to model a point source using the 
point flux settings available in the Earth Science Module. 

The first section in this discussion gives an overview of the problem. Next it gives the 
equations and describes how the fluid flow and the solute transport application modes 
link in COMSOL Multiphysics. Next come a few implementation details including a 
table of model data. The results shown next then illustrate various postprocessing 
options. The last section describes how to build the model using the COMSOL 
Multiphysics graphical user interface.

Model Definition

In this example, there is regional flow from left to right across a 450 m × 300 m 
aquifer. The fluid moves at a Darcy velocity of 0.11 m/d. The aquifer has 
homogeneous and isotropic material properties. A point source releases a small 
amount of fluid into the aquifer at 1 m3/d, a release rate small enough that the flow 
field remains uniform. The injected fluid carries a nonreactive solute at a concentration 
of 1000 ppm. The contaminant migrates by advection and dispersion and never 
reaches a boundary. The aquifer is initially pristine with concentrations everywhere 
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equal to zero. The only source of contaminant is the injection, so flow through the 
inlet has zero concentration. The period of interest is one year.

F L U I D  F L O W

Darcy’s law describes the fluid flow in this problem. With the hydraulic-head 
formulation, the governing equation is

where K is hydraulic conductivity (m/d), H is hydraulic head (m), and Qs is the 
volume flow rate of fluid per unit volume of aquifer (d−1).

The point source is

where W is the volumetric pumping rate W (m3/d); b is the aquifer thickness; δ 
denotes the Dirac delta function, which is nonzero only in the point (xi, yi), where xi 
and yi are the well coordinates.

Because the flow field is at steady state, you can obtain a unique solution by specifying 
the model geometry, the point source, the material properties, and the boundary 
conditions. The problem statement gives the hydraulic head at the inlet and the outlet 
and indicates symmetry conditions on the sides. In the Darcy’s Law application mode, 
you express these boundary conditions as

where n is the normal to the boundary.

C O U P L I N G

The groundwater-flow and solute-transport equations given here are linked by the 
Darcy velocity, , which gives the specific flux (m/d) of fluid across an 
infinitesimal surface representing both the solids and the pore spaces. COMSOL 
Multiphysics computes the Darcy velocity vector u, which consists of the x and y 
directional velocities denoted u and v, respectively.

S O L U T E  TR A N S P O R T

The advection-dispersion equation governs solute transport in this problem:

∇ K∇H–[ ]⋅ Qs=

Qs
W
b
-----δ x xi y yi–,–( )=

n K∇H[ ]⋅ 0= ∂Ω  Sides
H Hin= ∂Ω  Inlet

H 0= ∂Ω  Outlet

u K∇H–=
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Here DL is the hydrodynamic dispersion tensor (m2/d); θs denotes the fluid volume 
fraction; c gives the dissolved concentration (kg/m3); u is the Darcy velocity (m/d); 
and Sc represents the quantity of solute added per unit volume of porous medium per 
unit time (kg/(m3·d)).

The entries for the dispersion tensor are

where DLii are the principal components of the dispersion tensor; DLji and DLji are the 
cross terms; α represents the dispersivity (m); and the subscripts “1” and “2” denote 
longitudinal and transverse flow, respectively.

In this problem, Sc represents the solute injected at the point well, which is defined by

where cQ is the concentration of the solute in the water (kg/m3). You implement the 
solute injection with the same logic as the fluid point source.

The problem statement specifies that the only contaminant source in the aquifer is the 
point well, and the boundaries are far enough from the injection well that the 
contaminant never leaves the model domain. You thus set the inlet concentration to 
zero and assign the other boundaries an advective flux. The expressions for these 
boundary conditions are

where n is the unit normal to the boundary.

θs
c∂
t∂

----- ∇ θs– DL c uc+∇[ ]⋅+ Sc=

θDLii α1
ui

2

u
------- α2

uj
2

u
-------+=

θDLij θDLji α1 α2–( )
uiuj

u
-----------= =

Sc QscQ
W
b
-----cQδ x xi y yi–,–( )= =

n θs– DL c∇[ ]⋅ 0= ∂Ω Sides

c 0= ∂Ω Inlet
n θs– DL c∇[ ]⋅ 0=   ∂Ω Outlet
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Data

Build the model with the following data:

PARAMETER NAME VALUE

 K Hydraulic conductivity 1 m/d

 ρf Fluid density 1000 kg/m3

 g Gravity 9.82 m/s2

 u Darcy velocity 0.11 m/d

 W Pumping rate 1 m3/d

 b Aquifer thickness 10 m

 Hin Inlet head 45 m

 θs Porosity 0.3

 α1 Longitudinal dispersivity 10 m

 α2 Transverse horizontal dispersivity 3 m

 cs Solute concentration at source 1000 ppm
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Results

Figure 4-1 shows the solution to the steady-state flow problem. The hydraulic head 
drops from the inlet to the outlet, and the velocity field is almost uniform, as required 
in the problem statement (Ref. 1).

Figure 4-1: COMSOL Multiphysics solution of almost uniform Darcy flow in a domain 
with a small point leak. Shown are the hydraulic head (surface plot) and velocity field 
(arrows).
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Figure 4-2: COMSOL Multiphysics results for the solute-transport problem are a near 
perfect match to the analytic solution of Ref. 1, which is shown with the numerical 
estimates of Ref. 2.

Figure 4-3 illustrates the evolution of the contaminant plume with snapshots at 
30 days, 100 days, and 360 days. The solute plume spreads in time but never reaches 
the boundary. In creating these plots, the author clipped off concentrations below 
0.1 ppm and used an expression containing logical operators to give the same shading 
to zones with concentrations of 50 ppm or greater.
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Figure 4-3: Concentrations at 30 days (top left), 100 days (top right), and 360 days 
(bottom) for 2D fluid flow and solute transport for a continuously injecting point source; 
shown are concentrations from 0.1 ppm to 50 ppm or greater.

In the user interface you can interactively view the value at a given point by either 
clicking at the point of interest or entering the point coordinates to trigger a numeric 
readout. You can also obtain numeric results for the arbitrary expressions along a line 
or within a subdomain using cross-section and domain plots. The cross sections in 
Figure 4-4 and Figure 4-5, for example, illustrate the dispersive and advective 
components of the solute flux. The flux from chemical diffusion is zero. The 
COMSOL Multiphysics solution shown here gives results along the line y = 150 m at 
10, 30, 90, 180, and 360 days.
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Figure 4-4: Advective flux along y = 150 m at 10, 30, 90, 180, and 360 days.

Figure 4-5: Dispersive flux along y = 150 m at 10, 30, 90, 180, and 360 days.
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Figure 4-6 gives the solute concentration as a combined color and height plot.

Figure 4-6: Solute concentrations from 0.1 ppm to 50 ppm at 360 days.
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Model Library path: Earth_Science_Module/Solute_Transport/
solute_injection

Modeling Using the Graphical User Interface

The first step is to open COMSOL Multiphysics and set up two application modes.
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M O D E L  N A V I G A T O R

1 Open the Model Navigator, and from the Space dimension list select 2D.

2 From the list of application modes choose  
Earth Science Module>Fluid Flow>Darcy’s Law>Hydraulic head analysis.

3 Click the Multiphysics button, then click Add.

4 From the list of application modes choose  
Earth Science Module>Solute Transport>Saturated Porous Media>Transient analysis.

5 Click Add, then click OK.

G E O M E T R Y  M O D E L I N G

1 Go to the Draw menu and select Specify Objects>Rectangle.

2 Specify a width of 450 and height of 300. Click OK.

3 Click the Zoom Extents button on the Main toolbar to center the rectangle in the 
field of view.

4 Choose the menu item Draw>Specify Objects>Point. In both the x and y edit fields 
enter 150. Click OK.

O P T I O N S  A N D  S E T T I N G S

Constants
1 From the Options menu, select Constants.

2 Enter the following names, expressions, and descriptions; when done, click OK.

Scalar Expressions
1 From the Options menu, select Scalar Expressions.

NAME EXPRESSION DESCRIPTION

W 1[m^3/s] Pumping rate

b 10[m] Aquifer thickness

H_in 45[m] Inlet head

rho_f 1000[kg/m^3] Fluid density

c_s 1[kg/m^3] Solute concentration at source

SPD 1[day/s] Seconds per day
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2 Define the following expression for the solute concentration expressed in parts per 
million:

3 Click OK.

A P P L I C A T I O N  S C A L A R  V A R I A B L E S

In the Darcy’s Law application mode (esdl), the vertical dimension D_esdl is the y-axis 
on your screen and the gravitational acceleration is g_esdl is 9.82 m/s2. Because this 
model describes a horizontal plane and the time unit is 1 day, you need to modify the 
value of g_esdl.

1 From the Physics menu, choose Scalar Variables.

2 Make the following changes; when done, click OK.

With this change of g_edsl, the effective time unit in the model becomes 1 day. 
Thus, wherever the user interface displays the time unit 1 s, read 1 day instead. This 
also applies in postprocessing, so you must multiply any quantity containing the 
dimension time to some power n by SPDn for the units displayed in the user 
interface and in plots to be correct. For example, when plotting the pressure, p, use 
the expression p/SPD^2, because pressure scales with time, T, as T−2.

P H Y S I C S  S E T T I N G S — D A R C Y ’ S  L A W

To set up the steady-state flow model you activate the Darcy’s Law application mode, 
enter material properties for the subdomain, give the boundary conditions, and then 
set the point flux.

Subdomain Settings
1 From the Multiphysics menu, select Darcy’s Law (esdl).

2 From the Physics menu select Subdomain Settings.

NAME EXPRESSION DESCRIPTION

c_ppm 1e6*c/rho_f Solute concentration in ppm

NAME EXPRESSION

D_esdl 0

g_esdl 9.82[m/s^2]*SPD^2
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3 Verify that the model defaults are the coefficient values you need; when done, click 
OK.

Boundary Conditions
From the Physics menu select Boundary Settings, then enter the following data; when 
done, click OK.

Point Settings
1 From the Physics menu select Point Settings.

2 On the Flux page, select Point 3.

3 Iin the N0 edit field for the flux, type W/b.

4 Click OK.

P H Y S I C S — S O L U T E  TR A N S P O R T

To set up the transient solute-transport model, you activate the corresponding 
application mode, enter material and solute properties for the subdomain, specify 
boundary conditions, and finish with the point flux.

Subdomain Settings
1 From the Multiphysics menu, select Solute Transport (esst).

2 From the Physics menu, select Subdomain Settings.

PROPERTY VALUE

 Ks 1

 ρf 1000

SETTINGS BOUNDARY 1 BOUNDARIES 2, 3 BOUNDARY 4

Boundary condition Hydraulic head Zero flux/
Symmetry

Hydraulic head

H0 H_in 0
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3 On the Flow and Media page specify information about the flow field and velocities 
from the Darcy’s Law (esdl) application mode.

Unless you specify otherwise, COMSOL Multiphysics denotes the x- and 
y-velocities as u and v. Because velocities are not dependent variables in the Darcy’s 
Law application mode, they are application mode variables that COMSOL 
Multiphysics evaluates using information from the solution. The software denotes 
application mode variables according to application mode name; here it is u_esdl for 
the x-velocity and v_esdl for the y-velocity.

4 On the Liquid page, set the dispersivities that describe spreading for solutes in the 
liquid phase as follows:

You normally set initial conditions on the Init page. However, the default initial 
value for solute concentrations is zero, which is the value that applies here.

5 Click OK to close the Subdomain Settings dialog box.

Boundary Conditions
1 From the Physics menu, select Boundary Settings.

2 Enter the following settings; when done, click OK.

Point Settings
1 From the Physics menu, select Point Settings.

2 On the Flux, c page, select Point 3.

3 In the N0 edit field for the flux, type c_s*W/b.

4 In the tNf edit field for the ending time, type 360.

PARAMETER EXPRESSION

 θs 0.3

 u u_esdl

 v v_esdl

PARAMETER EXPRESSION

α1 10

α2 3

SETTINGS BOUNDARY 1 BOUNDARIES 2–4

Boundary condition Concentration Advective flux

c0 0
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5 Click OK.

M E S H  G E N E R A T I O N

1 Select the menu item Mesh>Free Mesh Parameters.

2 Click the Subdomain tab, then select Subdomain 1. In the Maximum element size edit 
field enter 20.

3 Click the Point tab. Select Point 3, then for Maximum element size enter 1.

4 Click OK.

5 Go to the Main toolbar and click the Initialize Mesh button.

C O M P U T I N G  T H E  S O L U T I O N

The solution requires two steps: First solve for the steady-state solution to the flow 
problem; second solve the transient solute-transport model using the velocities from 
the flow solution.

To solve the flow problem, proceed as follows:

1 Click the Solver Manager button on the Main toolbar.

2 On the Solve For page, select Darcy’s Law (esdl); make sure it is the only application 
mode selected, then click OK.

3 Click the Solve button on the Main toolbar.

To solve for solute concentrations, continue with these steps:

1 Click the Solver Parameters button on the Main toolbar.

2 From the Analysis list, select Transient. To generate outputs in 10-day increments 
from time 0 to time 360, go to the Times edit field and enter 0:10:360. Click OK.

3 Click the Solver Manager button on the Main toolbar.

4 On the Solve For page, select only Solute Transport (esst). Click OK.

5 Click the Restart button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate Figure 4-1 proceed as follows:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, go to the Plot type area and select the Surface and Arrow check 
boxes.

3 Click the Surface tab. On the Surface Data page, choose Darcy’s Law (esdl)>Hydraulic 

head from the Predefined quantities list.
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4 On the Arrow page, click the Subdomain Data tab. From the Predefined quantities list 
choose Darcy’s Law (esdl)>Velocity field. Go to the Arrow positioning area, and in the 
Number of points edit fields for both x points and y points enter 15. Click the Color 
button. Change the selection to black, then click OK.

5 Click Apply to generate the plot.

To generate the plot in the upper left panel of Figure 4-3, continue with these steps:

1 On the General page, find the Plot type area and clear the Arrow check box. In the 
Solution at time list select 30.

2 Click the Surface tab. On the Surface Data page, enter c*(c<50)+50*(c>=50) in the 
Expression edit field. Click the Range button and clear the Auto check box. In the Min 
edit field enter 0.1, and in the Max edit field keep the default value (50). Click OK.

3 Click OK.

To generate the other two plots, follow these steps:

1 Choose Postprocessing>Plot Parameters and click the General tab.

2 From the Solution at time list select 90. Click Apply.

3 Repeat Step 2 but this time with a value of 360.

To generate Figure 4-4 continue with these steps:

1 From the Postprocessing menu select Cross-Section Plot Parameters.

2 In the Solution to use list select 10, 30, 90, 180, and 360. (You can choose multiple 
solution times by pressing the Ctrl key.)

3 Click the Line/Extrusion tab. Go to the y-axis data area and from the Predefined 

quantities list choose Solute Transport (esst)>Advective flux c. Edit the resulting entry 
in the Expression edit field to read adflux_c_esst/SPD. Edit the entry in the Unit 
edit field to read kg/(m^2*day). With these modifications, the y-axis gets the 
correct unit in the plot (recall the discussion under “Application Scalar Variables” 
on page 222).

4 In the Cross-section line data area, enter the following settings:

5 In the x-axis data area, click first the lower option button and then the Expression 
button. In the X-Axis Data dialog box, type x in the Expression edit field. Click OK.

6 Click Apply.

 x0  x1  y0  y1

0 450 150 150
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To generate Figure 4-5, continue with these steps:

1 From the Postprocessing menu select Cross-Section Plot Parameters.

2 Click the Line/Extrusion tab. Go to the y-axis data area and in the Predefined 

quantities list choose Solute Transport (esst)>Dispersive flux, c. Edit the resulting 
entry in the Expression edit field to read dflux_c_esst/SPD. Edit the entry in the 
Unit edit field to read kg/(m^2*day).

3 Click OK.

To generate Figure 4-6, proceed as follows:

1 From the Options menu select Axes/Grid Settings. Click the Grid tab and clear the Auto 

check box. Clear the Auto check box in the z grid area. In the z spacing edit field 
enter 10. Although z is not a model coordinate, you need z gridding to make a 
height plot. Click OK.

2 From the Postprocessing menu select Plot Parameters.

3 On the General page, click the Title button. In the edit field enter the title Solute 
concentrations in the range 0.1 ppm to 0.5 ppm [kg/m<sup>3</sup>]. 
Click OK.

4 Click the Surface tab. On the Surface Data page, the entry in the Expression edit field 
should read c_ppm*(c_ppm<50)+50*(c_ppm>=50). Click the Range button, then 
verify that the Auto box is cleared and that the settings are 0.1 for Min and 50 for 
Max. Click OK.

5 Still on the Surface page, click the Height Data tab and then select the Height data 
check box. In the Expression edit field use the same one as you entered on the Surface 

Data page. You can copy and paste the expression 
c_ppm*(c_ppm<50)+50*(c_ppm>=50) into the edit field.

6 Click Apply.

7 To view solutions for all time steps as a movie, click the Animate tab and then click 
the Start Animation button.
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Buoyan c y  F l ow w i t h  Da r c y ’ s  L aw—
the E l d e r  P r ob l em

Density variations can initiate flow even in a still fluid. In earth systems, density 
variations can arise from naturally occurring salts, subsurface temperature changes, or 
migrating pollution. This buoyant or density-driven flow factors into fluid movement 
in salt-lake systems, saline-disposal basins, dense contaminant and leachate plumes, and 
geothermal reservoirs, to name just a few.

This example duplicates a benchmark problem for time-dependent buoyant flow in 
porous media. Known as the Elder problem (Ref. 1), it follows a laboratory experiment 
to study thermal convection. When Voss and Souza (Ref. 2) recast the Elder problem 
for salt concentrations, it became a benchmark that many researchers have used to test 
a number of variable-density flow codes including SUTRA (Ref. 3) and SEAWAT (Ref. 
4).

This model examines the Elder problem for concentrations through a 2-way coupling 
of two application modes from the Earth Science Module: Darcy’s Law and Solute 
Transport. 

Model Definition

Figure 4-7: Geometry for modeling the Elder problem. In this cross section of 
water-saturated porous media, a high salt concentrations exist on the top right portion.
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In this model (Figure 4-7) a vertical cross section of water-saturated porous media 
extends 300 m in the x direction and 150 m in the y direction. The material properties 
are homogeneous and isotropic. A vertical line at x = 300 m represents a symmetry 
boundary with a mirror image of the cross section extending beyond it. There is no 
flow across the geometry edges. High salt concentrations exist at the upper boundary 
(along y = 150 m) from x = 150 to 300 m. Salt concentration is zero along the lower 
boundary. The water is initially stationary (with a hydrostatic pressure distribution) 
and pristine (with zero concentration). When the density increases near the 
high-concentration boundary, flow develops. The period of interest is 20 years.

F L U I D  F L O W

You can describe the fluid flow in this problem using Darcy’s law with an extra term:

where the pressure, p (in units of kg/(s2·m)), and the concentration, c (kg/m3), are 
dependent variables. In this equation ρ is the density (kg/m3); S is the storage 
coefficient (s2·m2/kg); t is the time; and θ is the porosity. The divergence operator has 
a velocity multiplied by a fluid density where κ equals the permeability (m2), η is the 
viscosity (kg/(s·m)), g is gravity (m/s2); and D is the vertical coordinate, y.

Now define density as a function of concentration according to

.

Multiplying the time-rate change in concentration by γ gives the change in mass stored 
per time as a function of concentration.

The density, ρ, appears as a multiplier to the time-rate change in pressure and also as a 
scalar multiplier of the velocity

where u is the vector of directional seepage rates, also known as Darcy velocities. 
Storage is negligible in the Elder problem, and storage changes come from variations 
in density as a function of concentration.

ρS p∂
t∂

------ θ ρ∂
c∂

------ c∂
t∂

----- ∇+ + ρκ
η
---∇ p ρgD+( )–⋅ 0=

ρ ρ0 γ c c0–( ) ρ0
ρs ρ0–

cs c0–
----------------- c c0–( )+=+=

u κ
η
---∇ p ρgD+( )–=
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The symmetry or zero flow on all boundaries fix only the change in pressure. For a 
unique solution, you must also specify a reference pressure. In this case, choose a point. 
Then, with the Darcy’s Law application mode, you express all these conditions as

where n is the normal to the boundary. 

S O L U T E  TR A N S P O R T

The governing equation for this problem is the conservative form of the Solute 
Transport application mode

where DL is the hydrodynamic dispersion tensor (m2/d); θs is the fluid volume 
fraction; c is the dissolved concentration (kg/m3); u is the Darcy velocity (m/d); and 
Sc is the quantity of solute added per unit volume of porous medium per unit time 
(kg/m3d). 

In the Elder problem, the contaminant spreads only by advection and molecular 
diffusion. With a typical transport problem, the hydrodynamic dispersion tensor, DL, 
also contains mechanical mixing owing to variations in velocity. The diagonal 
components, DLii, of the tensor are

where α is the dispersivity (m); the subscripts “1” and “2” denote longitudinal and 
transverse flow, respectively; τ is tortuosity; and Dm is the coefficient of molecular 
diffusion (m2/s). Because the Elder problem requires diffusion alone, the first two 
terms in this expression equal zero.

The only contaminant source in the model domain is the salt concentration along the 
right half of the upper boundary. The vertical edge at x = 300 m is a symmetry 
boundary. The remaining boundaries have zero flux. The initial concentration is zero. 
The following equations represent these conditions:

n κ
η
---∇ p ρgD+( )⋅ 0= ∂Ω    Sides

p 0= ∂2Ω  Point
p x y 0, ,( ) ρ0gD= t 0=

θs
c∂
t∂

----- ∇ θs– DL c uc+∇[ ]⋅+ 0=

θDLii α1
ui

2

u
------- α2

uj
2

u
------- τDm+ +=
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where n is the unit normal to the boundary.

Data

The model works with the following data:

Results and Discussion

The following results come from the COMSOL Multiphysics solution to a benchmark 
buoyancy problem often used both for temperatures (Ref. 1) and concentrations (Ref. 
2).

Figure 4-8 gives snapshots of concentrations at six times during the 20-year simulation 
period. Initially the water is pristine. By the end of the first year, concentrations spread 
by diffusion, creating a density gradient. The buoyancy flow begins at the edge of the 
salt contact, where there is a sharp contrast in fluid density. By the end of year three, 
the fingering of high concentrations into the reservoir is mature. By year 10, the salt 
concentrations have spread over roughly 60% of the model domain.

PARAMETER NAME VALUE

 ρ0 Fresh-water density 1000 kg/m3

 ρs Salt-water density 1200 kg/m3

 κ Permeability 4.85·10-13 m2

 η Dynamic viscosity 0.001 kg/(m·s)

 g Gravity 9.81 m/s2

 θs Porosity 0.1

 τDm Molecular diffusion rate 3.56·10-6 m2/s

 cs Salt-water concentration 285.7 kg/m3

 c0 Fresh-water concentration 0 kg/m3

n θs– DL c uc+∇[ ]⋅ 0= ∂Ω  Sides

c cs= ∂Ω  Salt

c x y 0, ,( ) 0= t 0=
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Figure 4-8: Snapshots of concentrations from the COMSOL Multiphysics solution to the 
buoyancy-flow benchmark developed by Voss and Souza (Ref. 2) for the Elder problem.

Figure 4-9 shows results from Elder (Ref. 1) along with numerical estimates from the 
SUTRA (Ref. 3) and SEAWAT (Ref. 4) manuals. The COMSOL Multiphysics solution 
in Figure 4-8 is in excellent agreement with that from Elder.

1 year 10 years

2 years 15 years

3 years 20 years
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Figure 4-9: Results from the Elder problem shown with concentration estimates from 
SEAWAT and SUTRA (adapted from Ref. 4).

Of interest in the Elder problem is the development of convection cells. The 
COMSOL Multiphysics plots in Figure 4-10 reveal the convection cells with the help 
of velocity streamlines, which the figure shows simultaneously with concentrations for 
Years 5, 10, 15, and 20. At early times, small convection cells develop between the 
individual fingers of the plume. At late times, a single convection cell covers the model 
domain.
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Figure 4-10: Salt concentrations (surface plot) and velocities (streamlines) from the 
COMSOL Multiphysics solution to a buoyancy benchmark problem (Ref. 2).

This example shows COMSOL Multiphysics applied to a well-known benchmark 
problem applicable to flow driven by density variations related to either temperature 
or concentration. The COMSOL Multiphysics results, here for concentration, closely 
match the benchmark solution (Ref. 2). This buoyant flow is straightforward to set up 
directly on top of a standard fluid flow and solute-transport model.
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Model Library path: Earth_Science_Module/Solute_Transport/
buoyancy_darcy_elder

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator, click the New tab, and in the Space dimension list select 2D.

2 From the list of application modes choose  
Earth Science Module>Fluid Flow>Darcy’s Law>Pressure analysis>Transient analysis. 

3 Click the Multiphysics button. Click Add.

4 From the list of application modes choose  
Earth Science Module>Solute Transport>Saturated Porous Media>Transient analysis. 
Click Add.

5 Click the Application Mode Properties button.

6 In the Equation form list select Conservative (this step moves the velocity term inside 
the divergence operator). In the Material list select Liquid. Click OK.

7 Click OK.

G E O M E T R Y  M O D E L I N G

1 Select the menu item Draw>Specify Objects>Rectangle 

2 In the dialog box that opens, go to the Width edit field and enter 300, and for the 
Height enter 150. Click OK.

3 Click the Zoom Extents button on the Main toolbar to center the rectangle in the 
field of view.

4 From the Options menu select Axes/Grid Settings. Click the Grid tab and clear the Auto 
check box. In the Extra x edit field enter 150, and in the Extra y edit field enter 150. 
Click OK.
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5 Select the menu item Draw>Specify Objects>Line. To draw a line from (x, y) = 
(150, 150) to (300, 150) enter space-separated values: for x coordinates enter 150 
300, and for y coordinates enter 150 150.

A P P L I C A T I O N  S C A L A R  V A R I A B L E S

The Darcy’s Law (esdl) application mode assumes that gravity g_esdl equals 9.82 m/s2 
and that the vertical dimension D_esdl is the screen’s y-axis. To set up these conditions, 
select the menu item Physics>Scalar Variables. In the g_esdl edit field enter 9.81, and 
for D_esdl enter y. Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu choose Constants. Then enter the following names, 
expressions, and (optionally) descriptions; when done, click OK.

NAME EXPRESSION DESCRIPTION

rho0 1000[kg/m^3] Fresh-water density

rho_s 1200[kg/m^3] Salt-water density

kappa 4.85e-13[m^2] Permeability

eta 0.001[kg/(m*s)] Dynamic viscosity

theta_s 0.1 Porosity

tauD_m 3.56e-6[m^2/s] Molecular diffusion rate

c_s 285.7[kg/m^3] Salt-water concentration at upper right 
boundary

c0 0[kg/m^3] Fresh-water concentration at upper right 
boundary
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2 From the Options menu select Expressions>Scalar Expressions. Enter the following 
names, expressions, and descriptions; when done, click OK.

P H Y S I C S  S E T T I N G S — D A R C Y ’ S  L A W

To set up the flow model, perform these steps: activate the Darcy’s Law application 
mode; enter material properties for the subdomain; insert the varying density as a 
scaling term; give the boundary conditions; and then add to the equation the time 
change in density with concentration.

Multiphysics
From the Multiphysics menu select Darcy’s Law (esdl).

Subdomain Settings
1 From the Physics menu select Subdomain Settings. Select Subdomain 1.

NAME EXPRESSION DESCRIPTION

gamma (rho_s-rho0)/(c_s-c0) Density-concentration ratio

rho rho0+gamma*c*(c>0) Density

u -kaps_esdl/eta_esdl*px Darcy velocity, x-component

v -kaps_esdl/eta_esdl* 
(py+rho*g_esdl)

Darcy velocity, y-component

c_scaled c/c_s*(c>0) Normalized dissolved concentration
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2 On the Coefficients page, enter the following values:

Here, you use the machine precision constant eps to get a small transient term that 
helps the solver to converge on a solution. The term is small enough that it has no 
effect on the solution obtained.

3 On the Scaling terms tab, enter the following settings:

Note that these settings only scale the complete equation by an overall factor (δQ is 
irrelevant because this model does not include a distributed source). This is done to 
improve convergence.

PROPERTY VALUE

 S eps

 κs kappa

ρf rho

 η eta

 Qs 0

PROPERTY VALUE

 δS rho[m^3/kg]

 δK rho[m^3/kg]
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4 On the Init page, define the initial hydrostatic pressure distribution by entering 
rho0*g_esdl*(150[m]-y) in the p(t0) edit field.

5 Click OK.

Boundary Conditions
From the Physics menu select Boundary Settings and verify that all the boundaries 
(numbers 1 through 5) are no-flow; for each boundary, the entry in the Boundary 

condition list should read Zero flux/Symmetry. When done, click OK.

Point Settings
With all boundaries being flux statements, you must set the pressure at a point to get 
a unique solution.

1 From the Physics menu select Point Settings. 

2 In the resulting dialog box click the Pressure tab. In the Point selection list select 2. 
For the two variables p0 and tp0 to go the corresponding Value/Expression edit fields 
and enter 0. Then, in the Value/Expression edit field for tpf enter 20[year]. Click OK.

Equation System Settings
1 Select the menu item Physics>Equation System>Subdomain Settings. Here you 

enhance the flow equation with the time change in density with concentration. 
Entries in the Subdomain Settings - Equation System dialog box actually change the 
way that COMSOL Multiphysics solves a problem, so following any changes, 
COMSOL Multiphysics displays a lock on the subdomain number.
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2 Click the da tab to go where COMSOL Multiphysics picks up coefficients that 
multiply the time change in the dependent variables in this problem. Edit the 
mass-coefficient entries so they read as follows:

3 Click the Differentiate button to distribute the change throughout the equation 
system.

4 Click OK.

P H Y S I C S  S E T T I N G S — S O L U T E  TR A N S P O R T

To set up the solute-transport model, you activate the application mode, enter material 
and solute properties for the subdomain, and specify boundary conditions. You must 
also change how COMSOL Multiphysics defines the dispersion tensor to exclude 
mechanical mixing. 

Multiphysics
From the Multiphysics menu select Solute Transport (esst).

Subdomain Settings
1 From the Physics menu select Subdomain Settings. 

2 Next specify the flow field and the velocities you defined earlier in the 
Options>Expressions>Scalar Expressions dialog box. You do not use the predefined 
velocities u_esdl and v_esdl from the Darcy’s Law (esdl) application mode. The reason 

P C

S_esdl gamma*theta_s

0 Cts_esst*theta_s_esst
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is that with the extra density term added inside the divergence operator, the 
predefined variables now represent mass flux instead of velocity.

In the Subdomain Settings dialog box go to Subdomain selection list and make sure 1 
is selected. Click the Flow and Media tab. Enter the expressions in the following table; 
when finished, click Apply.

3 Click the Solute tab to set the dispersivities that describe spreading for solutes in the 
liquid phase. Enter the expressions in the following table; when done, click Apply.

4 You can always set initial conditions by going to the Init page. However, the default 
initial value for solute concentrations is zero, which is the value needed here.

5 Click OK.

PROPERTY VALUE

 θs theta_s

u u

v v

PROPERTY VALUE

 α1 0

 α2 0

 TL 1

 DmL tauD_m
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Boundary Conditions
From the Physics menu select Boundary Settings. Set the conditions and enter 
expressions for the various boundaries as in this table; when done, click OK.

Equation System Settings
1 Select the menu item Physics>Equation System>Subdomain Settings, then click the 

Variables tab. Here you change the preset definitions for application-mode variables 
dictating how COMSOL Multiphysics calculates the entries of the dispersion tensor.

2 Scroll down the list of predefined variables until you find the following and edit 
them so they read as follows:

3 Click Differentiate, then click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu select Free Mesh Parameters.

2 In the resulting dialog box, click the Global tab. In the list of Predefined mesh sizes 
select Fine, then click the Custom mesh size button and in the Element growth rate 

edit field enter 1.15.

3 Switch to the Boundary page, then select boundaries 1, 3, and 5. In the Maximum 

element size edit field enter 10. For boundary 2 enter a Maximum element size of 7. 
For boundary 4 enter a Maximum element size of 5.

4 Click the Point tab, select point 3, and enter a Maximum element size of 1. For point 
5 enter a Maximum element size of 3.

5 Click Remesh. Click OK.

C O M P U T I N G  T H E  S O L U T I O N

COMSOL Multiphysics solves the flow and transport problems simultaneously.

SETTINGS BOUNDARY 2 BOUNDARY 4 BOUNDARIES 1, 3, 5

Type Concentration Concentration No flux/Symmetry

c0 c0 c_s

NAME EXPRESSION

thDLxx_c_esst theta_s_esst*tauL_c_esst*DmL_c_esst

thDLxy_c_esst 0

thDLyx_c_esst 0

thDLyy_c_esst theta_s_esst*tauL_c_esst*DmL_c_esst
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1 From the Solve menu choose Solver Parameters. Look in the Solver list and verify that 
the Time dependent solver is selected.

2 Find the Times edit field and enter 0:360*86400:360*86400*20 to generate 
outputs from 0 to 20 years in 1-year increments.

3 As the Absolute tolerance expression enter p 0.1 c 0.001. Doing so sets a different 
error tolerance for pressure than concentration because their magnitudes differ 
significantly. Click OK.

4 Click Solve on the Main toolbar. 

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate the images in Figure 4-8 proceed as follows:

1 From the Postprocessing menu select Plot Parameters.

2 Click the General tab, and in the Plot type area select the Surface and Arrow check 
boxes. Go to the Solution at time list and choose a time of interest. Click Apply.

3 Go to the Surface tab and then to the Surface Data page. In the Expression edit field 
type cscaled.

4 Click the Contour tab. Select the Contour plot check box. On the Contour Data page, 

go to the Expression edit field and enter c_scaled as before.
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5 Go to the Contour levels area. Select the Vector with isolevels option button, and in 
the corresponding edit field enter 0.2 0.6 0.8. Click Apply.

6 To view the solutions for all time steps as a movie, go to the Animate tab and click 
Start Animation.

To generate the images in Figure 4-10, follow these steps:

1 From the Postprocessing menu choose Plot Parameters.

2 Click the General tab. In the Plot type area, clear the Contour check box and select 
the Streamline check box. Make a selection in the Solution at time list as desired.

3 Click the Streamline tab and then go to the Streamline Data page. In the x component 
edit field overwrite the default value with u, and in the y component edit field enter v.

4 From the Streamline plot type list, select Magnitude controlled. On the Density page, 
set the Density to 10.

5 Click the Line Color tab. Click the Uniform color option button, then click the Color 
button. In the Streamline Color dialog box, select black, then click OK.

6 Click Apply to generate the first plot.

7 Return to the General page and select the desired solutions in the Solution at time 
list, clicking Apply inbetween to generate the plots.

8 To view solutions for all time steps as a movie, go to the Animate page and click Start 
Animation.
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V a r i a b l y  S a t u r a t e d  F l ow and 
T r an s po r t

This example details two assessments of time-dependent fluid flow and solute transport 
for a variably saturated system. In the first transport scenario, “Sorbing Solute,” a 
chemical sorbs to soil particles and biodegrades. In the second scenario, section 
“Pesticide Transport and Reaction in Soil”, the pesticide aldicarb transforms to 
daughter products that you then track. The inspiration for the two problems comes 
from the manuals of SWMS2D (Ref. 1) and HYDRUS2D (Ref. 2).

Figure 4-11: Geometry of the infiltration ring and soil column.

The two chemical-transport scenarios from this example build on top of the same 
variably saturated flow model. It uses the Richards’ equation interfaces to define 
nonlinear relationships with retention and permeability properties according to van 
Genuchten (Ref. 3). In the Richards’ Equation application mode you can also define 
these material properties by interpolation from experimental data (see “Interpolation 
for Unsaturated Flow” on page 115) and the Brooks and Corey analytic permeability 
and retention formulas (Ref. 4).
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The two variably saturated flow and solute-transport models included here are inspired 
by but do not exactly duplicate the SWMS2D and HYDRUS2D examples. The main 
distinction lies in the governing equations. SWMS2D and HYDRUS2D use a form of 
Richards’ equation that accounts for change in fluid volume fraction with time. The 
Richards’ Equation application mode also accounts for changes in storage related to 
variations in pressure head according to Bear (Ref. 5) among others. Another point of 
departure is that with the storage terms, the solute-transport equations in the Earth 
Science Module also account explicitly for time change in liquid and air content. 
Moreover, the problems here address isothermal conditions. For nonisothermal flow 
see “Free Convection in Porous Media” on page 294.

Model Definition—Sorbing Solute

In the fluid-flow model, water moves from a ring on the ground into the subsurface. 
The 0.25-m radius ring ponds the water to a depth of 0.01 m but is open to the 
ground surface. Permeable soils exist to a depth of 1.3 m. The soil in the uppermost 
0.4 m is slightly less permeable than the 1.9 m below it. The lower layer sits above 
relatively impermeable soil, so only a very small amount of leakage exits from the base. 
The flow is symmetric about the line x = 0. No flow crosses the surface outside the ring. 
According to the problem statement there is no flow across the line x = 1.25 m. The 
initial distribution of pressure heads is known. 

The water in the ring contains a dissolved solute at a constant concentration, c0. The 
solute enters the ground with the water and moves through the subsurface by 
advection and dispersion. Additionally, the solute sorbs or attaches to solid surfaces, 
which reduces the aqueous concentrations and also slows solute movement relative to 
the water. Microbial degradation also reduces both the liquid- and the solid-phase 
concentrations. The sorption and the biodegradation are linearly proportional to 
aqueous concentrations. The fluid in the ring is the only chemical source, and the 
solute is free to leave the soil column with the fluid flux. Initially the soil is free of the 
solute. You track its transport for ten days.

F L U I D  F L O W

Richards’ equation governs the saturated-unsaturated flow of water in the soil. The soil 
air is open to the atmosphere, so you can assume that pressure changes in air do not 
affect the flow and use Richards’ equation here for single-phase flow. Given by Ref. 5, 
Richards’ equation reads
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where C denotes specific moisture capacity (m−1); Se is the effective saturation of the 
soil; S is a storage coefficient (m−1); Hp represents the dependent variable pressure 
head (m); t is time (d); K equals the hydraulic conductivity function (m/d); D is the 
coordinate (for example, x, y, or z) that represents vertical elevation, and Qs is a fluid 
source defined by volumetric flow rate per unit volume of soil (d−1). In this problem, 
S = θs − θr where θs and θr denote the volume fraction of fluid at saturation and after 
drainage, respectively. 

With variably saturated flow, fluid moves through but may or may not completely fill 
the pores in the soil, and θ denotes the volume fraction of fluid within the soil. C, Se, 
and K vary with the pressure head, Hp, and with θ, making Richards’ equation 
nonlinear. The specific moisture capacity, C, relates variations in soil moisture to 
pressure head as in C = ∂θ / ∂Hp. In the governing equation, C defines storage changes 
produced by varying fluid content because C ∂Hp / ∂t = ∂θ / ∂t. Because C, the first term 
in the bracketed time coefficient, goes to zero at saturation, time change in storage 
relates to compression of the aquifer and water under saturated conditions. The 
saturated storage comes about with the effective saturation as represented by the 
second term in the time-coefficient brackets. K is a function that defines how readily 
the porous media transmits fluid. The relative permeability of the soil, kr, increases 
with fluid content giving K = Ks kr, where Ks (m/d) is the constant hydraulic 
conductivity at saturation. 

This example uses predefined interfaces for van Genuchten (Ref. 3) formulas to 
represent how the four retention and permeability properties θ, C, Se, and kr = Ks/K 
vary with the solution Hp. The van Genuchten expressions read as follows:

C SeS+[ ]
Hp∂
t∂

---------- ∇+ Kskr∇ Hp D+( )–[ ]⋅ Qs=
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where α, n, m, and l are dimensionless constants that specify a particular media type, 
and m = 1−1/n. In the equations, the system reaches saturation when fluid pressure is 
atmospheric (that is, Hp = 0). When the soil fully saturates, the four parameters reach 
constant values. 

The problem statement records all the boundary conditions you need for this model. 
The level of water in the ring is known at 0.01 m, giving a Dirichlet constraint on 
pressure head. Approximate the small leak from the base, N0, as 0.01Ks. With no flow 
crossing the surface outside of the pressure ring or the vertical walls, the following 
expressions summarize the boundary conditions:

In these expressions, n is the unit normal to the bounding surface.

A unique solution to a time-dependent problem requires an initial condition. In the 
problem statement, the initial condition came from results of another simulation. For 

θ =
θr Se θs θr–( )+

θs
⎩
⎪
⎨
⎪
⎧

Hp 0<

Hp 0≥

Se =

1

1 αHp
n

+[ ]
m

-------------------------------------

1⎩
⎪
⎨
⎪
⎧

Hp 0<

Hp 0≥

C =
αm

1 m–
-------------- θs θr–( )Se

1
m
-----

1 Se

1
m
-----

–
⎝ ⎠
⎜ ⎟
⎛ ⎞

m

0⎩
⎪
⎪
⎨
⎪
⎪
⎧

Hp 0<

Hp 0≥

kr = SeL 1 1 Se

1
m
-----

–
⎝ ⎠
⎜ ⎟
⎛ ⎞

m

–

2

1⎩
⎪
⎪
⎨
⎪
⎪
⎧

Hp 0<

Hp 0≥

Hp Hp0= ∂Ω Ring

n Kskr∇ Hp D+( )–[ ]⋅ 0= ∂Ω Surface

n Kskr∇ Hp D+( )–[ ]⋅ 0= ∂Ω Sides

n Kskr∇ Hp D+( )–[ ]⋅ 0= ∂Ω Symmetry

n Kskr∇ Hp D+( )–[ ]⋅ N0= ∂Ω Base
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this example model, you fit a simple equation to the June 1982 results shown in 
Example 4 from SWMS2D (Ref. 1) and run a short simulation without the ring to 
warm up the flow field. That simulation also assumes that there is no flow across the 
surface beneath the ring.

M U L T I P H Y S I C S  C O U P L I N G

Groundwater flow and solute transport are linked by fluid velocities. With the form of 
the transport equation that follows, the fluid velocities need come from Darcy’s law.

 (4-1)

In the expression, u is a vector of directional velocities often termed specific discharge 
(m/d). In COMSOL Multiphysics, u and v denote the velocities in the x and y 
directions, respectively, that make up u.

S O L U T E  TR A N S P O R T

The equation that governs advection, dispersion, sorption, and decay of solutes in 
groundwater is

It describes time rate change in two terms: c denotes dissolved concentration (kg/m), 
and cP is the mass of adsorbed contaminant per dry unit weight of solid (mg/kg). 
Further, θ denotes the volume fluid fraction (dimensionless), and ρb is the bulk density 
(kg/m3). Because ρb amounts to the dried solid mass per bulk volume of the solids and 
pores together, the term ρb cP gives solute mass attached to the soil as a concentration. 
In the equation, DL is the hydrodynamic dispersion tensor (m2/d); RL represents 
reactions in water (kg/(m3·d)); and RL equals reactions involving solutes attached to 
soil particles (kg/(m3·d)). Finally, Sc is solute added per unit volume of soil per unit 
time (kg/(m3·d)). 

It is far more convenient to solve the above equation only for dissolved concentration. 
This requires expanding the left side to

.

and inserting a few definitions.

In this problem, solute mass per solid mass, cP, relates to dissolved concentration, c, 
through a linear isotherm or partition coefficient kP (m

3/kg) where cP = kP c. Because 

u Kskr Hp D+( )∇=

t∂
∂ θc( )

t∂
∂ ρbcP( )+ ∇ θ– DL c uc+∇[ ]⋅ ΣRL ΣRP S+ + c= =

t∂
∂ θc( )

t∂
∂ ρbcP( )+ θ c∂

t∂
----- c θ∂

t∂
------ ρb

cp∂
c∂

-------- c∂
t∂

-----+ +=
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the relationship is linear, the derivative is kp = ∂cP / ∂c. Making those substitutions gives 
the form of the solute transport problem you solve:

.

In the equation, and denote the decay rates (d−1) for the dissolved and sorbed 
solute concentrations, respectively.

Note that you employ results from the flow equation in the solute-transport model as

.

You enter this directly into the COMSOL Multiphysics user interface using the 
time-rate change in pressure head. Note that COMSOL Multiphysics solves for 
pressure, p, and converts to Hp based on the fluid weight.

The hydrodynamic dispersion tensor, DL, describes mechanical spreading from 
groundwater movement in addition to chemical diffusion:

where DLii are the diagonal entries in the dispersion tensor; DLji and DLji are the cross 
terms; α is the dispersivity (m); the subscripts “1” and “2” denote longitudinal and 
transverse flow, respectively; Dm denotes the coefficient of molecular diffusion (m2/
d); and τL is a tortuosity factor that reduces impacts of molecular diffusion for porous 
media relative to free water. Here τL = θ 7/3 θs

−2.

The boundary and initial conditions in the sorbing-solute problem are 
straightforward. The solute enters only with the water from the ring at a concentration 
c0. The solute is free to leave, but there is only minimal leakage from the lower 
boundary and no flow from the sides. Transport is symmetric about the line x = 0. The 
boundary conditions in this problem are:

θ ρbkp+[ ] c∂
t∂

----- c θ∂
t∂

------ ∇ θ– DL c uc+∇[ ]⋅+ + θφLc ρbkpφPc S+ + c=

φL φP

c θ∂
t∂

------ cC
Hp∂
t∂

----------=

θDLii α1
ui

2

u
------- α2

uj
2

u
------- θDmτL+ +=

θDLij θDLji α1 α2–( )
uiuj

u
-----------= =
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where n is the normal to the boundary. Because the soil is pristine at the start of the 
experiment, the initial condition is one of zero concentration.

I M P L E M E N T A T I O N — L O G I C A L  O P E R A T O R S

This analysis uses logical operators to “warm up” the flow model for 0.1 days. The 
warm-up time smooths out the approximate equation for initial head to produce the 
smoothly varying, physically based velocity field needed to yield reasonable solute 
concentrations. You can use the Solver Parameters and Solver Manager dialog boxes to 
run a warm-up flow simulation first and use those results as initial conditions in the 
coupled-flow and transport problem as a follow-up step. The virtue of using logical 
operators here is that they circumvent the staged or multistep process.

Logical statements involve relational operators, which can be powerful tools for 
modeling in COMSOL Multiphysics. Multiplication of a constant or expression by a 
logical statement qualifies when, where, and how a model uses that expression or 
constant. For example, specifying c as c0*(t>1) means that the concentration equals 
c0 for all times greater than 1, whereas multiplication by (t>1)*(t<5) means all times 
between t = 1 and t = 5.

This model uses the logical expressions as boundary conditions. For the flow problem, 
you need zero flow across the boundary during the warm-up time and a constant 
pressure head of 0.01 m thereafter. If you start the simulation at t = −0.1 days, you 
then turn on the constant pressure head and concentration at the ring at t = 0 with 
these equations:

.

c c0= ∂Ω Ring

n θ– DL c∇[ ]⋅ 0= ∂Ω Surface

n θ– DL c∇[ ]⋅ 0= ∂Ω Sides

n θ– DL c uc+∇[ ]⋅ 0= ∂Ω Symmetry

n θ– DL c∇[ ]⋅ 0= ∂Ω Base

Hp
n– K– skr Hp D+( )∇[ ]⋅ 0=

Hp 0.01=
⎩
⎪
⎨
⎪
⎧

t 0<
0 t≤

∂Ω Ring

c n θsDL c∇ uc–( )⋅ 0=

c 1=
⎩
⎪
⎨
⎪
⎧

t 0<
0 t≤

∂Ω Ring
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Using logical operators, you can implement the expressions for pressure head. Use the 
general Neumann boundary condition

.

On the right side of the equation, Hp is the solution, D is the current elevation, and 
all other terms are constants that you can define arbitrarily. Here set q0 = 0, Rb = 1, 
HPb = 0.01, and Db = D for t > 0 by multiplication with logical operators. 
Hpb=0.01*(t>=0) means HPb has a value of 0.01 for all times greater than or equal 
to zero. 

For concentration, use modified logic with the flux boundary expression

.

During the flow model’s warm-up there is no solute moving from the pressure ring 
N0 = 0. This is a Neumann condition on flux. Throughout the coupled-flow and 
transport problem, however, the solute concentration cring = 1, which is a Dirichlet 
condition on concentration. The logical operators use what is known as a “stiff-spring” 
condition to implement the switch between the two boundary types.

I M P L E M E N T A T I O N — S T I F F - S P R I N G  C O N D I T I O N

A stiff-spring condition uses weighting to make a Neumann statement about flux but 
achieves a Dirichlet condition on pressure head. The stiff-spring expression

specifies the flux using a heavily weighted equivalence for concentration. Rephrased, 
the stiff-spring statement

sets cring to 1 plus some small number. Because this offers virtually no information 
about the flux, it varies freely. In this model, set N0 = 106 (c − 1) (t ≥ 0).

n– K– skr Hp D+( )∇[ ]⋅ q0 Rb Hpb Hp–( ) Db D–( )+[ ]+=

n θsDL c∇ uc–( )⋅ N0=

n θsDL c∇ uc–[ ]⋅ N0 106 cring 1–( )= =

cring 1 n+
θsDL c∇ uc–[ ]

106
---------------------------------------⋅=
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D A T A

The following table provides data for the fluid-flow model:

The inputs needed for the solute-transport model are:

Results

Figure 4-12 and Figure 4-13 give the solution to the fluid-flow problem at 0.3 and 
1 day, respectively. The images show effective saturation (surface plot), pressure head 
(contours), and velocities (arrows). The figures illustrate the soil wetting with time. As 

VARIABLE UNIT DESCRIPTION UPPER LAYER LOWER LAYER

 Ks m/d Saturated hydraulic conductivity 0.298 0.454

 θs - Porosity/void fraction 0.399 0.339

 θr - Residual saturation 0.0001 0.0001

 α m-1 alpha parameter 1.74 1.39

 n - n parameter 1.38 1.60

 m - m parameter 1-1/n 1-1/n

 l - Pore connectivity parameter n/a

  Hps m Pressure head in ring 0.01

  Hp0 m Initial pressure head -(y+1.2)* (y<-0.4)+ 
(-(y+1.2)-0.2* 
(y+0.4))* (-0.4<=y)

-(y+1.2)* (y<-0.4)+ 
(-(y+1.2)-0.2* 
(y+0.4))* (-0.4<=y)

VARIABLE UNITS DESCRIPTION VALUE

 rb kg/m3 Bulk density 1400

 kp m3/kg Partition coefficient 0.0001

 Dm m2/d Coefficient of molecular diffusion 0.00374

 τL - Tortuosity factor  θ7/3 θs
-2

 α1 m Longitudinal dispersivity 0.005

 α2 m Transverse dispersivity 0.001

 d-1 Decay rate in liquid 0.05

 d-1 Decay rate on solid 0.01

 cs kg/m3 Solute concentration in ring 1.0

 c0 kg/m3 Initial solute concentration in soil 0

φL

φP
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the arrows indicate, the velocities just below the ring are high relative to the remainder 
of the soil column.

Figure 4-12: Estimates of effective saturation (surface plot), pressure head (contours), and 
velocity (arrows) in variably saturated soil after 0.3 days.
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Figure 4-13: Estimates of effective saturation (surface plot), pressure head (contours), and 
velocity (arrows) in variably saturated soil after 1 day.

Figure 4-14 and Figure 4-15 give the concentrations for 0.25 days and 1 day, 
respectively, along with the retardation factor. They illustrate how the solute 
concentrations (surface plot) enter and move through the soil. Because the retardation 
factor depends on soil moisture, its value varies with the solution.
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Figure 4-14: Solution for dissolved concentrations (surface plot) and retardation factor 
(contours) at 0.3 days.
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Figure 4-15: Solution for dissolved concentrations (surface plot) and retardation factor 
(contours) at 1 day.

Figure 4-16 shows an image of the retardation factor. For variably saturated solute 
transport, the retardation factor changes with time. As shown in this image, the process 
of sorption has the greatest potential to slow the contaminant where the soils are 
relatively dry for this example. In that the retardation coefficient here ranges from 
roughly 1.3 to 1.6, the solute moves at approximately the velocity of the groundwater.
V A R I A B L Y  S A T U R A T E D  F L O W  A N D  TR A N S P O R T  |  257



258 |  C H A P T E
Figure 4-16: Snapshot of the retardation factor (surface and contours).
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Model Library path: Earth_Science_Module/Solute_Transport/
sorbing_solute

Modeling Using the Graphical User Interface

The following steps walk you through this model, setting up both the Richards’ 
Equation application mode and the Solute Transport application mode. You can easily 
bypass a few of the details by using the example “Interpolation for Unsaturated Flow” 
on page 115 and adding to it the transport application. To do so, open the model file, 
add the Solute Transport application mode as described in the following description 
and then skip to the section “Physics—Solute Transport”.

To start from scratch, first add the Richards’ Equation application mode:

M O D E L  N A V I G A T O R

1 Open the Model Navigator, and from the Space dimension list select Axial symmetry 

(2D).

2 In the list of application modes select Earth Science Module>Fluid Flow>Richards’ 

Equation>Pressure head analysis>Transient analysis.

3 Click the Multiphysics button, then click Add.

4 In the list of application modes select  
Earth Science Module>Solute Transport>Variably Saturated Porous Media>Transient 

analysis. Click Add.

5 Click OK.

C O N S T A N T S

First define some constants. Open the Physics>Constants list and define the following 
list (the descriptions are optional). When done, click OK.

NAME EXPRESSION DESCRIPTION

phiL 0.05[1/s] Decay rate in liquid

phiP 0.01[1/s] Decay rate on solid

rhob 1400[kg/m^3] Bulk density

kp 0.0001[m^3/kg] Partition coefficient
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A P P L I C A T I O N  S C A L A R  V A R I A B L E S

To set the vertical direction and gravitational constant in the model, go to the Physics 
menu and open the Scalar Variables dialog box. Make the following modifications to 
the defaults. Here you convert from seconds to days and square the quantity because 
you are dealing with acceleration. Then click OK.

G E O M E T R Y  M O D E L I N G

You create the geometry by drawing one rectangle and adding two lines.

1 Select the menu item Draw>Specify Objects>Rectangle. Specify the following settings, 
then click OK.

2 Go to the Main toolbar and click the Zoom Extents button. 

3 Again select Draw>Specify Objects>Rectangle. Specify the following settings, then 
click OK.

4 Select the menu item Draw>Specify Objects>Line. In the r edit field enter 0 0.25, 
and in the z edit field enter 0 0. Click OK.

P H Y S I C S — R I C H A R D S ’  E Q U A T I O N

Subdomain Settings—Richards’ Equation
1 To define the setting for the flow application mode, go to the Multiphysics menu and 

choose Richards’ Equation (esvr).

NAME EXPRESSION

D_esvr z

g_esvr 9.82*86400*86400

PARAMETER EXPRESSION

width 1.25

height 1.3

r 0

z -1.3

PARAMETER EXPRESSION

width 1.25

height 0.4

r 0

z -0.4
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2 Choose Physics>Subdomain Settings and click the Coefficients tab. Enter the 
following settings, then click Apply.

3 Click the van Genuchten tab and make the following changes:

4 Click the Init tab. Select both subdomains simultaneously using the Ctrl key, then 
in the edit field enter this expression:

5 Click OK.

Boundary Conditions—Richards’ Equation
From the Physics menu choose Boundary Settings and make these settings; when done, 
click OK.

SETTINGS SUBDOMAIN 1 SUBDOMAIN 2

 Constitutive relation van Genuchten van Genuchten

 θs 0.339 0.399

 θr 0 0.0001

 Storage term User defined User defined

 S 0.339 0.399

 KS 0.454 0.298

 ρf 1000 1000

SETTINGS SUBDOMAIN 1 SUBDOMAIN 2

 α 1.39 1.74

 n 1.6 1.38

 l 0.5 0.5

SETTING SUBDOMAINS 1, 2

HP0 -(z+1.2)*(z<-0.4)+(-(z+1.2)-0.2*(z+0.4))*(-0.4<=z)

BOUNDARIES BOUNDARY CONDITION VARIABLE EXPRESSION

1, 3, 4, 6–8 Zero flux/Symmetry

2 Inward flux N0 -0.454/100

5 Rb 1*(t>=0)

5 Mixed Hpb 0.01*(t>=0)

5 Db D_esvr*(t>=0)
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P H Y S I C S — S O L U T E  TR A N S P O R T

Enter the setting in the transport application mode by going to the Multiphysics menu 
and selecting Solute Transport (esst).

Subdomain Settings—Solute Transport
Set up the material properties.

1 Choose Physics>Subdomain Settings. On the Flow and Media page enter these 
settings.

Click Apply.

2 Click the Liquid tab and make the following changes. Click Apply after you have 
finished changing the values for each subdomain.

3 Click the Solid tab and make the following changes. Click Apply after you have 
finished changing the values for each subdomain.

4 Click OK.

SETTINGS SUBDOMAINS 1, 2

θ theta_esvr

θs thetas_esvr

u u_esvr

v v_esvr

SETTINGS SUBDOMAINS 1, 2

α1 0.005

α2 0.001

DmL 0.00374

RL -phiL*theta_esvr*c

So -c*C_esvr*pt

TERM SUBDOMAINS 1, 2

ρb rhob

KP kp

RP phiP*kp*rhob*c
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Boundary Conditions—Solute Transport
1 From the Physics menu choose Boundary Settings and make these settings; when 

done, click OK.

The factor 106 is a large number that implements the stiff-spring condition (see 
“Implementation—Stiff-Spring Condition” on page 252) and should not be 
interpreted as a physical velocity. The added unit makes the flux expression 
dimensionally correct.

M E S H  G E N E R A T I O N

1 Go to the menu item Mesh>Free Mesh Parameters. 

2 Click the Boundary tab. Select the upper surface and the break between the two soil 
layers (Boundaries 4, 5, and 6). In the Maximum element size edit field enter 0.02.

3 Click OK.

4 Click the Initialize Mesh button on the Main toolbar. 

C O M P U T I N G  T H E  S O L U T I O N

1 Select the menu item Solve>Solver Parameters. In the Solver list choose Time 

dependent if it is not already selected.

2 In the Times edit field enter -0.1,0,logspace(-3,-1,21),0.1:0.1:1,2:1:10. 
It gives you 31 logarithmically spaced inputs from 0.001 to 0.1 day; 0.1-day 
increments through Day 1; and 1-day increments until Day 10. 

3 Click the Advanced tab. Set the Type of scaling to Manual. Enter p 1e10 c 1 in the 
Manual scaling edit field. Click OK. 

4 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate the plot in Figure 4-12, follow these steps:

1 Select the menu item Postprocessing>Plot Parameters. 

2 On the General page go to the Plot type area and select the Surface, Contour, and 
Arrow check boxes. In the Solution at time list select 0.3.

BOUNDARY CONDITION VARIABLE EXPRESSION

1, 3, 6 No flux/Symmetry

2, 7, 8 Advective flux

5 Flux N0 1e6[m/s]*(-c+1)*(t>=0)
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3 Click the Surface tab, and in the Expression edit field type Se_esvr, which stands for 
the effective saturation, Se, calculated with this application mode, named esvr. 

4 Click the Contour tab, and in the list of Predefined quantities select Pressure head 

(esvR). Go to the Contour levels area. Select the option button associated with Vector 

with isolevels, then in the edit field enter -2:0.1:2. In the Contour color area click 
the Uniform color option button, click the Color button, and change the color to 
white, and click OK. Clear the Color scale check box.

5 Click the Arrow tab, and in the list of Predefined quantities select Richards’ Equation 

(esvr)>Velocity field. Go to the Arrow parameters area and click the Color button. 
Choose white as the color, then click OK. Clear the Auto check box and change the 
Scale factor to 0.5. Click Apply.

To generate Figure 4-13 on page 255, select the menu item Postprocessing>Plot 

Parameters and in the Solution at time list select 1. Click OK.

To generate the plot in Figure 4-14 on page 256, continue with these steps:

1 Select the menu item Postprocessing>Plot Parameters. 

2 In the Plot type area clear the Arrow check box. In the Solution at time list choose 0.3.

3 Click the Surface tab, and in the list of Predefined quantities select Concentration, c. 

4 Click the Contour tab, and from the list of Predefined quantities select 
Solute Transport (esst)>Retardation factor of c. Go to the Contour levels area, select 
the Vector with isolevels option button, and in the associated edit field enter 
-2:0.1:2. In the Contour color area select the Uniform color option button. Click 
the Color button, change the color to black, and click OK.

5 Click Apply, but leave this dialog box open.

To generate Figure 4-15 on page 257, return to the General tab, and in the Solution at 

time list select 1. Click OK.

1 To generate Figure 4-16 on page 258, select the menu item Postprocessing>Plot 

Parameters. In the Plot type area clear the Contour check box. In the Solution at time 
list select 0.2. Click Apply. 

2 Click the Surface tab, and in the list of Predefined quantities select 
Solute Transport (esst)>Retardation factor of c. Click OK.

S A V I N G  T H E  M O D E L

This completes the model. In the following sections you add new equations and terms. 
Save the current model by choosing File>Save As and entering a file name. Click OK.
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Pe s t i c i d e  T r a n s po r t  and Rea c t i o n  i n  
S o i l

Introduction

Aldicarb is a commercial pesticide, used on a variety of crops, including cotton, sugar 
beet, citrus fruits, potatoes, and beans. The general population may be exposed to 
aldicarb primarily through the ingestion of contaminated water and foods.

This example looks at the degradation kinetics of aldicarb and its toxic by-products, 
investigating both the degradation time-scale as well as the spatial concentration 
distribution of toxic components. In the first model the chemicals are contained in a 
water pond, treated as a perfectly mixed system. The second model tracks the detailed 
distribution of chemicals in soil as the pesticide leaches out of the pond and is 
transported in water through the ground.

The reaction kinetics describing the degradation pathways of aldicarb is exported to 
the Solute Transport application mode of the Earth Science Module. In COMSOL 
Multiphysics the solute transport is coupled to fluid flow as described by Richards’ 
equation.

Note: This model requires the COMSOL Reaction Engineering Lab and the Earth 
Science Module.

Model Definition

Aldicarb degrades by transformation to the corresponding sulfoxide and the sulfone 
(both of which are toxic), and is detoxified by hydrolysis to oximes and nitriles. The 
chain of reactions is illustrated in Figure 4-17. The toxicity of a chemical species is 
indicated by its LD50 value, signifying the dose (mg/kg) lethal to half of a test 
population of rats. As indicated, both the sulfoxide and solfone analogues of aldicarb 
are also relatively toxic.
P E S T I C I D E  TR A N S P O R T  A N D  R E A C T I O N  I N  S O I L  |  265



266 |  C H A P T E
Figure 4-17: Reaction pathways of aldicarb degradation.

Each of the j unimolecular reactions outlined above have rate expressions of the form:

Note that in this example the concentration unit is kg/m3 and the rate constants are 
expressed in 1/day.

P E R F E C T L Y  M I X E D  S Y S T E M

The first model solves for the decomposition kinetics of aldicarb occurring in a water 
pond. The pond is treated as a closed and perfectly mixed system. The reaction 
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mechanism illustrated in Figure 4-17 translates into the following mass balance 
equations:

• For aldicarb (a)

• For aldicarb sulfoxide (asx)

• For aldicarb sulfone (asn)

• For aldicarb oxime (ao)

• For aldicarb sulfoxide oxime (asxo)

• For aldicarb sulfone oxime (asno)

Solving this set of coupled ODEs outlined above provides information on the time 
scale of the degradation processes.

S P A C E -  A N D  T I M E - D E P E N D E N T  S Y S T E M

In a more detailed model, you assume that aldicarb moves from the pond into 
relatively dry soil. In the soil, the aldicarb decomposes according to the mechanism 
illustrated in Figure 4-17. In addition, the pesticide and its decay products are 
transported by advection, dispersion, sorption, and volatilization.

td

dca r1– r3–=

td

dcasx r1 r2– r4–=

td

dcasn r2 r5–=

td

dcao r3=

td

dcasxo r4=

td

dcasno r5=
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Geometry
Water is ponded by a ring sitting on the ground. The soil is layered and rests on rocks. 
Water moves through the bottom of the ring into the soil. The water level in the ring 
is known. There is no flow through the vertical walls or the surface outside of the ring.

Figure 4-18: Geometry of the infiltration ring and soil column.

Aldicarb moves with water from the pond into the soil at a constant concentration. In 
the soil, the chemicals react and also sorb onto soil particles. Aldicarb and the aldicarb 
sulfone volatilize to the atmosphere. The sorption, biodegradation, and volatilization 
proceed in linear proportion to the aqueous concentrations. The soil is initially pristine 
with zero concentration of the involved chemicals. At the ground surface outside the 
ring, there is volatilization to the atmosphere for ca and casn. The vertical axis is a line 
of symmetry. The other boundaries are posed such that the solutes can freely leave the 
soil column with the fluid flow. You can model the problem with 2D axisymmetry and 
track the solute transport for 10 days.

Fluid Flow
Richards’ equation governs the saturated-unsaturated flow of water in soil (Ref. 1) and 
is implemented in the Richards’ equation application mode:
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Here, C denotes specific moisture capacity (m−1), Se is the effective saturation of the 
soil, S is a storage coefficient (m−1), Hp represents the dependent variable pressure 
head (m), t is time (d), K equals the hydraulic conductivity function (m/d), D is the 
coordinate representing vertical elevation (for example, x, y, or z), and Qs is a fluid 
source defined by volumetric flow rate per unit volume of soil (d−1). In this problem, 
S = θs − θr, where θs and θr denote the volume fraction of fluid at saturation and after 
drainage, respectively. 

You can find more detail on the Richards’ Equation application mode in the Earth 
Science Module User’s Guide.

Mass Transport
The governing equation for solute transport describes advection and dispersion of a 
sorbing, volatilizing, and decaying solute in variably saturated soil.

 (4-2)

Equation 4-2 is implemented in the Solute Transport application mode. The first 
bracketed term explains the change in solute mass per volume per time for the liquid-, 
solid-, and air-phase concentrations. The second term explains the changes in storage 
because the water content in the soil varies in time. The third bracketed expression 
represents the overall solute flux due to liquid dispersion, diffusion (liquid and air), and 
advection with moving water. The right side explains reactions and generalized 
sources.

Solute spreading now includes mechanical dispersion in water plus molecular diffusion 
for water and air. These three processes appear in the liquid-gas dispersion tensor, 
whose entries are

 (4-3)

 (4-4)
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In this equation, DLGii are the principal components of the liquid-gas dispersion 
tensor; DLGij and DLGji are the cross terms; α is the dispersivity (m) where the 
subscripts 1 and 2 denote longitudinal and transverse flow, respectively. Dm and DG 
(m2/d) are molecular diffusion, while τL and τG give the tortuosity factors for liquid 
(water) and gas (air), respectively. 

The three solutes—aldicarb, aldicarb sulfoxide, and aldicarb sulfone—have different 
decay terms, RLi, partition coefficients, kPi, and volatilization constants, kGi. All of the 
solutes attach to soil particles. Two of the solutes volatilize; sulfoxide does not.

Results

First, review the results of the perfectly mixed reactor model, solved in the Reaction 
Engineering Lab.

Figure 4-19 shows the concentration profile of aldicarb and all of its decay products. 
Only small amounts of aldicarb remain after 10 days. Figure 4-20 shows concentration 
transients of the most toxic species aldicarb, aldicarb sulfoxide, and aldicarb sulfone, as 
well as the sum of these three components (see Figure 4-17 for LD50 values). 
Considering the summed contributions, contamination levels clearly remain high even 
after several months.

Figure 4-19: Concentration profiles (kg/m3) as reactions occur during a 100 day time 
period.
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Figure 4-20: Concentration transients of the most toxic species, aldicarb (c_a), aldicarb 
sulfoxide (c_asx), and aldicarb sulfone (c_asn).

Results shown below come from the space and time-dependent model set up and 
solved in COMSOL Multiphysics.

Figure 4-21 shows the fluid flow in soil after 0.3 days (left) and 1.0 days (right). The 
plots illustrate the wetting of the soil with time. As indicated by the arrows, the fluid 
velocities are relatively high beneath the ponded water.

Figure 4-21: The effective saturation (surface plot), pressure head (contours), and flow 
velocity (arrows) in a variably saturated soil after 0.3 days (left) and 1 day (right).
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Figure 4-22 through Figure 4-24 show the concentration distribution of aldicarb and 
the equally toxic aldicarb sulfoxide, after 1, 5, and 10 days of infiltration. Consistent 
with the evolving flow field, the main direction of transport is in the vertical direction.

Figure 4-22: Concentration of aldicarb (left) and aldicarb sulfoxide (right) after 1 day.

Figure 4-23: Concentration of aldicarb (left) and aldicarb sulfoxide (right) after 5 days.

Figure 4-24: Concentration of aldicarb (left) and aldicarb sulfoxide (right) after 10 
days.
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The distribution of aldicarb has clearly reached steady-state conditions after 10 days. 
This time frame was also predicted by the ideal reactor model. Results also show that 
the soil contamination is rather local with respect to the aldicarb source. The aldicarb 
sulfoxide, on the other hand, can be expected to affect a considerably larger soil 
volume for a significantly longer time.
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Model Library path: Earth_Science_Module/Solute_Transport/
pesticide_transport

Modeling Using the COMSOL Reaction Engineering Lab

M O D E L  N A V I G A T O R

1 Start COMSOL Reaction Engineering Lab.

2 Click New in the Model Navigator.

O P T I O N S  A N D  S E T T I N G S

1 Click the Model Settings button on the Main toolbar.

2 Select the Liquid from the Reacting fluid list.

3 Select the Calculate thermodynamic properties check box.

4 Select the Calculate species transport properties check box.

5 Click Close.

R E A C T I O N S  I N T E R F A C E

1 Click the Reaction Settings button on the Main toolbar.

2 Make sure the Reactions page is active. Create five entries in the Reaction selection 

list by clicking the New button
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3 Enter the following reaction formulas by first selecting the appropriate row in the 
Reaction selection list and then entering the corresponding text in the Formula edit 
field.

4 Type in the following rate constants by first selecting the appropriate row in the 
Reaction selection list and then entering the corresponding value in the kf edit field.

S P E C I E S  I N T E R F A C E

1 Click the Species tab.

2 Select the entry a from the Species selection list and type 1 in the c0 edit field.

3 Go to the Transport page.

4 Select all entries in the Species selection list by pressing Ctrl+A and clicking the list.

5 Click the Specify diffusivity check box and type 0.00374 in the Diffusivity edit field.

6 Click Close.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 Go to the Times edit field and enter 100. Note that the time unit in this example is 
days.

3 Click OK.

4 Compute the solution by clicking the Solve button on the Main toolbar.

REACTION ID # REACTION FORMULA

1 a=>asx

2 asx=>asn

3 a=>ao

4 asx=>asxo

5 asn=>asno

REACTION ID # FORWARD RATE CONSTANT

1 0.36

2 0.024

3 0.2

4 0.01

5 0.0524
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PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The concentration transients of all species are plotted by default as shown in 
Figure 4-19. Reproduce Figure 4-20 with the following steps:

1 Click the Plot Parameters button on the Main toolbar.

2 Remove the entries ao, asxo, asno from the Quantities to plot list by selecting them 
and clicking the < button.

3 Type c_a+c_asx+c_asn in the Expression edit field and click the associated > 
button.

4 Click OK.

Now, move on to export the reaction model to COMSOL Multiphysics and solve the 
time and space-dependent transport and reaction problem.

S P E C I E S  I N T E R F A C E

This model focuses on the concentration of the highly toxic species aldicarb (a), 
aldicarb sulfoxide (asx), and aldicarb sulfone (asn). Therefore, you can disregard the 
mass balances for the hydrogenolysis products (ao, asxo, and asno). Before exporting 
the reaction model you therefore deactivate these species.

1 Click the Reaction Settings button on the Main toolbar.

2 Click the Species page.

3 Select ao from the Species selection list and deactivate the species by clearing the 
check box immediately to the left of the species name.

4 In the same way, deactivate the species asxo and asno.

5 Click Close.

E X P O R T  S E T T I N G S

1 Click the Export to COMSOL Multiphysics button on the Main toolbar.

2 Select Axial symmetry (2D) from the Space dimension list, then click OK.

3 The Export to COMSOL Multiphysics dialog box appears.

4 Go to the Export mass balance area, and in the Application mode list select Solute 

Transport: New.

5 In the Group name edit field type reactions.

6 Move to the Export energy balance area and clear the check box in the upper left 
corner.
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7 Go to the Export momentum balance area and clear the check box in the upper left 
corner.

8 Click the Export button at the bottom of the dialog box.

Modeling Using COMSOL Multiphysics

Click the COMSOL Multiphysics window.

1 Select the menu item Multiphysics>Model Navigator.

Note how the model already contains the application mode Solute Transport, created 
by the export from Reaction Engineering Lab.

2 In the list of application modes select Earth Science Module>Fluid Flow>Richards’ 

Equation>Pressure head analysis>Transient analysis.

3 Click the Add button.

4 Click OK.

A P P L I C A T I O N  S C A L A R  V A R I A B L E S

To set the vertical direction and gravitational constant in the model, go to the Physics 
menu and choose Scalar Variables. Make the following modifications to the defaults. 
Here you convert from seconds to days and square the quantity because you are 
dealing with acceleration. When done, click OK.

G E O M E T R Y  M O D E L I N G

You create the geometry by drawing two rectangles and adding one line.

1 Select the menu item Draw>Specify Objects>Rectangle. Specify the following settings, 
then click OK.

2 Go to the Main toolbar and click the Zoom Extents button. 

NAME EXPRESSION

g_esvr 9.82*86400*86400

D_esvr z

PARAMETER EXPRESSION

Width 1.25

Height 1.3

r 0

z -1.3
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3 Again select Draw>Specify Objects>Rectangle. Specify the following settings, then 
click OK.

4 Select the menu item Draw>Specify Objects>Line. In the r edit field enter 0 0.25, 
and in the z edit field enter 0 0. Click OK.

P H Y S I C S — S O L U T E  TR A N S P O R T

1 Choose Multiphysics>Solute Transport (esst).

2 Select the menu item Physics>Properties.

3 Select Liquid/Solid/Gas from the Material drop down list, then click OK. You change 
the default settings as a three phase system is being modeled.

4 Select the menu item Physics>Subdomain Settings. In the Subdomain selection list 
simultaneously select Subdomains 1 and 2 by pressing the Ctrl key.

5 From the Group list, select reactions.

6 Go to the Flow and Media page, enter the following settings.

This couples the solute transport to the flow calculated by the Richards’ Equation 
(esvr) application mode.

7 Set the Time change in liquid volume fraction to Time change in pressure head and 
enter the following.

PARAMETER EXPRESSION

Width 1.25

Height 0.4

r 0

z -0.4

PROPERTY VALUE

 θ theta_esvr

 θs thetas_esvr

 u u_esvr

 v v_esvr

PROPERTY VALUE

 C C_esvr

 ∂Hp / ∂t pt
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8 Click the Liquid page. In the list of subdomains, simultaneously select 1 and 2 by 
pressing Ctrl. Make the changes in the following table, and note that you can copy 
and paste in the edit fields.

Note also that the DmL and RL edit fields have been filled out automatically as a result 
of the export from COMSOL Reaction Engineering Lab.

9 Click the Solid page. Select both Subdomain 1 and 2, then make the following 
changes:

10 Click the Gas page, select Subdomains 1 and 2, then make the following changes:

11 Go to the Init page and type 0 in the c_a(t0) edit field.

12 Click OK.

Boundary Conditions—Solute Transport
1 From the Physics menu choose Boundary Settings.

2 Verify that you are on the c_a page, then enter the following settings:

TERM C_A C_ASX C_ASN

α1 0.005 0.005 0.005

α2 0.0001 0.0001 0.0001

TERM C_A C_ASX C_ASN

 ρb 1300 1300 1300

 KP 0.0001 0.00005 0.0002

TERM C_A C_ASX C_ASN

kG 1.33e-7 0 1.33e-3

DmG 0.432 0.432 0.432

BOUNDARY CONDITION VARIABLE VALUE

1, 3 Axial symmetry

2, 7, 8 Advective flux

5 Flux N0 1e6*(1-c_a)*(t>=0)

6 No flow boundary volatilization d 0.005
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3 Click the c_asx page, then enter the following settings:

4 Click the c_asn page, then enter the following settings:

5 Click OK.

P H Y S I C S — R I C H A R D S ’  E Q U A T I O N

Subdomain Settings—Richards’ Equation
1 Go to the Multiphysics menu and choose Richards’ Equation (esvr).

2 Select the menu item Physics>Subdomain Settings and click the Coefficients page. 
Enter the following settings, then click Apply.

3 Click the van Genuchten page and make the following changes:

BOUNDARY CONDITION VARIABLE VALUE

1, 3, Axial symmetry

6 No flux/Symmetry

2, 7, 8 Advective flux

5 Concentration c_asx0 0

BOUNDARY CONDITION VARIABLE VALUE

1, 3 Axial symmetry

2, 7, 8 Advective flux

5 Concentration c_asn0 0

6 No flow boundary volatilization d 0.005

SETTINGS SUBDOMAIN 1 SUBDOMAIN 2

 Constitutive relation van Genuchten van Genuchten

 θs 0.339 0.399

 θr 0 0.0001

 Storage term User defined User defined

 S 0.339 0.399

 KS 0.454 0.298

 ρf 1000 1000

SETTINGS SUBDOMAIN 1 SUBDOMAIN 2

 α 1.39 1.74
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4 Click the Init page. Select both subdomains simultaneously using the Ctrl key, then 
in the edit field enter this expression:

5 Click OK.

Boundary Conditions—Richards’ Equation
1 From the Physics menu choose Boundary Settings and make these settings:

2 Click OK.

M E S H  G E N E R A T I O N

1 Go to the menu item Mesh>Free Mesh Parameters.

2 Click the Boundary page. Select the upper surface and the break between the two 
soil layers (Boundaries 4, 5, and 6). In the Maximum element size edit field enter 
0.02. 

3 Click OK.

4 Click the Initialize Mesh button on the Main toolbar. 

C O M P U T I N G  T H E  S O L U T I O N

This model has many degrees of freedom and is also nonlinear. It requires roughly an 
hour to solve on a fast computer.

1 Choose Solve>Solver Parameters.

2 In the Solver list choose Time dependent if it is not already selected.

 n 1.6 1.38

 l 0.5 0.5

SETTING SUBDOMAINS 1 AND 2

HP(t0) -(z+1.2)*(z<-0.4)+(-(z+1.2)-0.2*(z+0.4))*(-0.4<=z)

BOUNDARY BOUNDARY CONDITION VARIABLE EXPRESSION

1, 3 Axial symmetry

6–8 Zero flux/Symmetry

2 Inward flux N0 -0.454/100

5 Mixed Rb 1*(t>=0)

5 Hpb 0.01*(t>=0)

5 Db D_esvr*(t>=0)

SETTINGS SUBDOMAIN 1 SUBDOMAIN 2
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3 In the Times edit field enter -0.1,0,logspace(-3,-1,21),0.1:0.1:1,2:1:10. 
It gives you 31 logarithmically spaced inputs from 0.001 to 0.1 day; 0.1-day 
increments through Day 1; and 1-day increments until Day 10. 

4 Click the Advanced page.

5 Change the Type of scaling to Manual.

6 Type p 1e10 c_a 1 c_asx 1 c_asn 1 in the Manual scaling edit field.

7 Click OK.

8 Click the Solve button on the Main toolbar. 

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To plot the flow solution in Figure 4-21, follow these steps.

1 Select the menu item Postprocessing>Plot Parameters. 

2 On the General page go to the Plot type area and select the Surface, Contour, and 
Arrow check boxes.

3 From the Solution at time list choose 0.3.

4 Click the Surface page, and in the Expression edit field enter Se_esvr.

5 Click the Contour page, and in the Predefined quantities list choose 
Richards’ Equation (esvr)>Pressure head.

6 In the Contour color area, click the Uniform color option button. Click the Color 
button, change the color to white, and click OK.

7 Click Apply.

8 Click the Arrow page.

9 From the list of Predefined quantities select Richards’ Equation (esvr)>Velocity field.

10 Click the Color button, choose white as the desired color, then click OK.

11 Clear the Auto check box, and in the Scale factor edit field enter 0.5.

12 Click Apply.

13 To generate the solution after 1 day, go to the General page and select 1 from the 
Solution at time list, and then click OK.

To generate the plots in Figure 4-22 through Figure 4-24, continue with these steps:

1 Select the menu item Postprocessing>Plot Parameters. 

2 On the General page, clear the Arrow and Contour check boxes.

3 Click the Surface page, then type c_a in the Expression edit field.
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4 Click Apply.

5 To generate the solution after 5 days and 10 days, go to the General page and select 
the corresponding entries from the Solution at time list, and click Apply.

6 To generate plots for the aldicarb sulfoxide concentrations, click the Surface page, 
type c_asx in the Expression edit field, then click Apply.
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H e a t  T r a n s f e r  M o d e l s
The models in this chapter demonstrate phase change, buoyancy flow, and free 
convection in porous media.
 283



284 |  C H A P T E
Buoyan c y  F l ow i n  F r e e  F l u i d s

This example follows the benchmark buoyancy flow posed by de Vahl Davis (Ref. 1) 
for free fluids. Buoyancy flow of free fluids is very important in earth sciences with 
temperature and concentration affecting density in fluids that move, for example, in 
pipes, along shorelines, and within lakes. Here the buoyancy flow results from density 
that varies with a temperature change. The COMSOL Multiphysics results match 
those from the published study (Ref. 1). The model was provided by John Kamel of 
the University of Notre Dame.

This example repeatedly solves a problem of buoyant flow in a square cavity. It thereby 
analyzes different temperature distributions and convective flow patterns from 
variations in, for example, fluid properties, cavity size, and temperature drops. The 
iterative process is tuned for a fast, efficient solution using nondimensional parameters 
and a Boussinesq term for the buoyant drive with the incompressible Navier-Stokes 
equation and the Convection and Conduction application modes. Another method to 
solve for the buoyant flow of free fluids in COMSOL Multiphysics using these 
application modes is simply to trigger the non-isothermal flow option, which enables 
modeling with a fully compressible Navier-Stokes flow law.

Figure 5-1: Domain geometry and boundary conditions for the heat balance in this 
example of buoyant flow in free fluids.
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Model Definition

The previous figure illustrates the model geometry. The fluid fills a square cavity with 
impermeable walls so the fluid flows freely within it but does not exit from it. The right 
and left edges of the cavity are, respectively, the high and low temperature sources. The 
upper and lower boundaries are insulated. The temperature differential produces the 
density variation that drives the buoyant flow.

The flow and temperature application modes in this model are 2-way coupled. The 
Boussinesq term is a force defined on temperatures. The fluid velocities transport heat. 

It is possible to formulate the Navier-Stokes equations with a Boussinesq buoyancy 
term on the right-hand side to account for the lifting force due to thermal expansion:

 (5-1)

 (5-2)

In these expressions, the dependent variables for flow are u, a vector of directional 
velocities, and pressure, p. T represents temperature, T0 is a reference temperature, g 
denotes gravity acceleration, ρ0 gives the reference density, and β equals the thermal 
expansion coefficient.

The heat balance comes from the conduction-convection equation

 (5-3)

where Keq denotes the thermal conductivity, and CL is the volumetric heat capacity of 
the fluid (where CL = ρf Cp, and Cp is the specific heat capacity).

The boundaries for the Navier-Stokes equations are impermeable, no-slip conditions. 
The no-slip condition results in zero velocity at the wall, with pressure within the 
domain remaining undefined. Because the lack of information about p makes it 
difficult for the problem to converge, you arbitrarily fix the pressure at a point using 
point settings.

The boundary conditions for Convection and Conduction application mode are the 
fixed high and low temperatures on the vertical walls, with insulation conditions 
elsewhere, as shown in Figure 5-1.

ρ u ∇⋅( )u ∇p ∇+ η ∇u ∇u( )T
+( )⋅–= ρ0gβ T T0–( )+

∇ u⋅ 0=

CLu∇ T⋅ ∇– Keq T∇( )⋅ 0=
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Implementation: Nondimensional Solutions with Iterative Solver

The model addresses a wide range of cavity sizes, fluid properties, and temperature 
drops using material properties set up with nondimensional Raleigh and Prandtl 
numbers. The Raleigh number, Ra = (gβTL3)/(ηρ−1Keq CL

−1), denotes the ratio of 
buoyant to viscous forces. Here L is the length of a side wall. The Prandtl number, Pr 
= (ηρ−1)/(Keq CL 

−1), gives the ratio of kinematic viscosity to thermal diffusivity.

Setting ρ = (Ra·Pr)0.5, Cp = Pr, and η = Keq = 1 produces nondimensional p, u, and 
T. The dimensional counterpart to the solution comes from the equations

where ' denotes dimensional quantities, and U is the magnitude of the velocity vector 
u.

As Ra increases, viscous forces decrease in importance. You can examine a wide range 
of scenarios using the parametric solver and sequencing through different values of Ra 
but keeping Pr constant. At a high Ra, starting with a good initial condition and a 
well-tuned mesh becomes increasingly important. Because the parametric solver uses 
the previous solution as the initial condition for the next one, it fulfills the first of the 
two requirements. Then getting a well-tuned mesh is straightforward: simply set up 
the mesh for the most difficult problem to solve—the one with the highest value of 
Ra. To that end, the element size near the prescribed temperature boundaries 
corresponds to the thickness of the boundary layer when Ra = 106.

Results

As noted earlier, this COMSOL Multiphysics example reproduces a benchmark 
buoyant flow problem reported in Ref. 1. The composite images in Figure 5-2 
summarize temperatures (surface), velocity fields (arrows), and x-velocities (contours) 
for four Ra values. With the given definitions for the dimensionless variable, it follows 
that as Ra increases so does temperature. The results in the figure indicate how the 
vigor and complexity of the convection increase at higher values of Ra, as 
expected.These results are virtually identical to the benchmark solution except the 
COMSOL Multiphysics plots provide higher resolution than the images in the original 
publication.

xi' Lxi= , t' L
U
----t,= ui'

ui

U
-----,= p'

p

ρ0U2
--------------,= T'

T Th–

Tc Th–
-------------------=
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Figure 5-2: Dimensionless solution for buoyancy flow in a fluid-filled cavity at increasing 
Raleigh number: Temperature (surface plot), velocity field (arrows), and x-velocity 
(contours). These results from the COMSOL Multiphysics simulation and the published 
results (Ref. 1) are in excellent agreement.

Conclusions

The author built this model using predefined physics interfaces (application modes) 
from the Earth Science Module for the Navier-Stokes equations and heat transfer by 
convection and conduction. The modeling process lasted less than 1 hour including all 
the steps from geometry input to postprocessing results. 

1,000 10,000

100,000 1,000,000
B U O Y A N C Y  F L O W  I N  F R E E  F L U I D S  |  287



288 |  C H A P T E
This approach represents the buoyant drive with a Boussinesq term, but you could also 
model it with the automated non-isothermal flow options provided with the 
Navier-Stokes application mode. Using the Boussinesq approach here, however, 
demonstrates a well-established method for conserving computational effort and still 
representing buoyant flow.
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Model Library path: Earth_Science_Module/Heat_Transfer_Models/
buoyance_free

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator, click the Multiphysics button, and in the Space dimension 
list select 2D. 

2 In the list of application modes select  
Earth Science Module>Fluid Flow>Incompressible Navier-Stokes Equations. Click 
Multiphysics, then click Add.

3 In the list of application modes select  
Earth Science Module>Heat Transfer>Convection and Conduction, then click Add.

4 Click the Application Mode Properties button. In the Material list choose Mobile Fluid. 
Click OK.
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O P T I O N S  A N D  S E T T I N G S

Select the menu item Options>Expressions>Scalar Expressions, then add the following 
names, expressions, and descriptions (optional); when done, click OK.

Because this is a nondimensional model, use no unit system:

1 From the Physics menu, choose Model Settings.

2 Select None from the Base unit system list in the Model Settings dialog box.

3 Click OK.

G E O M E T R Y  M O D E L I N G

1 Go to the Draw toolbar on the left side of the user interface and select Rectangle/

Square. Fill in the dialog box to create a square with corners at (0, 0) and (1, 1). 

2 Click the Zoom Extents button on the Main toolbar to center the square within the 
viewing window.

P H Y S I C S  S E T T I N G S — F L O W

From the Multiphysics menu select Incompressible Navier-Stokes equations (chns).

Subdomain Settings
Select the menu item Physics>Subdomain Settings, select Subdomain 1, then enter the 
following settings:

NAME EXPRESSION DESCRIPTION

Ra 1e6 Raleigh number

Pr 0.71 Prandtl number

Th 1 High temperature

Tc 0 Low temperature

COEFFICIENT EXPRESSION

ρ (Ra/Pr)^.5

η 1

Fx 0

Fy (T-Tc)*(Ra/Pr)^.5
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Initial Conditions
Leave the initial conditions at their default values u = v = p = 0.

Boundary Conditions
The boundary conditions default to no-slip and need not to be altered.

Point Settings
Select the menu item Physics>Point Settings. Select Point 1, then select the Point 

constraint check box. Leave the p0 field at 0. Click OK.

P H Y S I C S  S E T T I N G S — H E A T  T R A N S F E R
From the Multiphysics menu select Convection and Conduction (eshcc).

Subdomain Settings
1 Select the menu item Physics>Subdomain Settings.

2 Go to the Materials page, and for the following parameters find the associated edit 
field and enter theses expressions:

VALUE EXPRESSION

ρL (Ra/Pr)^.5

CpL Pr

KL 1
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3 Click the Time/Convection tab. Set the velocities in the heat transfer equation to the 
fluid velocities from the flow equation by entering these expressions for u and v:

4 Click the Spreading tab, and in the Equivalent thermal conductivity list choose Volume 

average. Click OK.

Initial Conditions
The initial condition remain at the default value T = 0.

Boundary Conditions
1 Go to menu item Physics>Boundary Settings. 

2 Select Boundaries 2 and 3, then from the Boundary condition list select 
Thermal insulation.

3 Select Boundary 1. From the Boundary condition list select Temperature, then in the 
T0 edit field enter 0.

4 Select Boundary 4. From the Boundary condition list select Temperature, then in the 
T0 edit field enter 1.

M E S H  G E N E R A T I O N

1 Choose Mesh>Free Mesh Parameters.

VALUE EXPRESSION

u u

v v
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2 Click the Boundary tab. Select Boundaries 1 and 4. In the Maximum element size edit 
field enter 0.0065, and in the Element growth rate edit field enter 1.5. Click Remesh. 
Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Select the menu item Solve>Solver Parameters. In the Solver list select Parametric. 
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2 In the Parameter name edit field enter Ra, and in the Parameter values edit field enter 
1e1 1e2 1e3 1e4 1e5 1e6. Click OK.

3 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate the image in Figure 5-2 on page 287:

1 Select the menu item Postprocessing>Plot Parameters.

2 On the General page select the Surface, Contour, and Arrow check boxes. In the 
Solution to use list choose the appropriate value for Ra.

3 Click the Surface tab. In the Predefined quantities list select Temperature (eshcc).

4 Click the Contour tab. In the Predefined quantities list select x-velocity (chns). Go to 
the Contour color area, select the Uniform color option button, click the Color button, 
as the color choose white, and click OK.

5 Click the Arrow tab. In the Predefined quantities list select velocity field (chns). Go to 
the Arrow positioning area. For the Number of points, in both the x-points and y-points 

edit fields enter 15. Click Color, select black, then click OK. 

6 Click OK to close the Plot Parameters dialog box. 

To sequence through the different solutions as an animation, open the 
Postprocessing>Plot Parameters dialog box, click the Animate tab, then click the Start 
Animation button.
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F r e e  Con v e c t i o n  i n  Po r ou s  Med i a

This example describes subsurface flow in porous media driven by density variations 
that result from temperature changes. The model comes from Hossain and Wilson 
(Ref. 1) where they use a specialized in-house code to solve this free-convection 
problem. This COMSOL Multiphysics example reproduces their work using the 
Brinkman Equations application mode and the Convection and Conduction 
application mode. The results of this model match those from the published study.

Model Definition

The following figure gives the model geometry. Water in a porous media slice can 
move within the slice but not exit from it. Temperatures vary from high to low along 
the outer edges. Initially the water is stagnant, but the temperature change alters 
density to the degree that buoyant flow ensues. The problem statement specifies that 
the flow is steady state.

Figure 5-3: Domain geometry and boundary conditions for the heat balance in the 
free-convection problem. Th is a higher temperature than Tc, while s is a variable that 
represents the relative length of a boundary segment and goes from 0 to 1 along the 
segment.

You model this free-convection problem by introducing a Boussinesq buoyancy term 
defined with temperatures to the Brinkman equations, then link the resulting fluid 
velocities from the Brinkman equations to the heat transfer application mode. 
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The Boussinesq buoyancy term that appears on the right side of the Brinkman 
equation shown next accounts for the lifting force due to thermal expansion

 (5-4)

.

In these expressions, T represents temperature while T0 is a reference temperature, g 
denotes the gravity acceleration, ρ0 gives the reference density, ε is the porosity, and β 
is the thermal expansion coefficient.

The heat balance comes from the conduction-convection equation

where Keq denotes the effective thermal conductivity of the fluid-solid mixture, and 
CL is the fluid’s volumetric heat capacity. 

The boundary conditions for the Brinkman equations are all no-slip conditions. Using 
only velocity boundaries gives no information on the pressure within the domain, 
which means that the model produces estimates of the pressure change instead of the 
pressure field. However, without any seed information on pressure, the problem is 
unlikely to converge. The remedy is to arbitrarily fix the pressure at a point in the 
model using point settings. The boundary conditions for the Convection and 
Conduction application mode are the series of fixed temperatures in Figure 5-3.

Implementation: Initial Conditions for Boussinesq Approximation

The simple problem statement just given produces a strongly nonlinear problem that 
represents a difficult convergence task for most nonlinear solvers. Even without the 
new Boussinesq term, the Brinkman equations are nonlinear alone. To ease the 
numerical difficulties, you apply a relaxation factor damp in front of the Boussinesq 
term ρ0gβ(T − T0) in Equation 5-4 to gradually find a stable initial condition for 
solving the true problem. When damp = 0, the flow and temperature equations are 
uncoupled so the model easily converges. Then you gradually increase damp, using 
the previous solution as the initial guess for the next parametric step, and so on until 
you reach damp = 1. The iteration protocol is an easy process with COMSOL 
Multiphysics’ parametric solver.

∇ η
ε
--- ∇u ∇u( )T

+( )⋅–
η
κ
---u ∇p+⎝ ⎠
⎛ ⎞– ρ0gβ T T0–( )=

∇ u⋅ 0=

CLu∇ T⋅ ∇– Keq T∇( )⋅ 0=
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Results

This example reproduces a model reported by Hossain and Wilson (Ref. 1). After 
extracting the input data from the paper, the author constructed the model in less than 
an hour, including all the steps from geometry input to postprocessing of the results. 
Figure 5-4 shows the dimensionless temperature distribution throughout the porous 
media slice.

Figure 5-4: Dimensionless temperature in a porous structure subjected to temperature 
gradients and subsequent free convection. The COMSOL Multiphysics simulation (left) 
and the published results from Ref. 1 (right) are in excellent agreement.

The COMSOL Multiphysics plot (left) provides higher resolution on the results than 
the reproduction of the published data (right). Otherwise the two graphs are identical. 
Figure 5-5 gives the COMSOL Multiphysics solution for the flow field.
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Figure 5-5: Velocity field (surface color) and velocity arrows.

Reference

1. M. Anwar Hossain and M. Wilson, “Natural convection flow in a fluid-saturated 
porous medium enclosed by non-isothermal walls with heat generation,” Int. J. 
Therm. Sci., vol. 41, pp. 447–454, 2002.

Model Library path: Earth_Science_Module/Heat_Transfer_Models/
free_conv_porous

Modeling Using the Graphical User Interface

1 In the Model Navigator, click the Multiphysics button, then in the Space dimension list 
select 2D.

2 In the list of application modes select  
Earth Science Module>Fluid Flow>Brinkman Equations. Click the Add button.
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3 In the list of application modes select  
Earth Science Module>Heat Transfer>Convection and Conduction. Click Add.

4 Click OK. 

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu select Constants, then enter the following names, 
expressions, and descriptions (optional). When done, click OK.

NAME EXPRESSION DESCRIPTION

rho 1e3 Density

mu 4e-4 Dynamic viscosity

cp1 4.2e3 Heat capacity

perm 1e-3 Permeability

beta 276e-6 Thermal expansion coefficient

Tc 0 Reference temperature

g 9.81 Acceleration due to gravity

damp 1 Relaxation factor
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2 Select the menu item Options>Expressions>Scalar Expressions and add these 
definitions (the descriptions are optional). When done, click OK.

Because this is a nondimensional model, use no unit system:

1 From the Physics menu, choose Model Settings.

2 Select None from the Base unit system list in the Model Settings dialog box.

3 Click OK.

G E O M E T R Y  M O D E L I N G

1 Select the menu item Options>Axes/Grid Settings. On the Axis page enter these 
settings; when done, click OK.

2 Click the Rectangle/Square button on the Draw toolbar, then using the cursor create 
a square with the corners at (0, 0) and (0.1, 0.1). 

3 Return to the menu item Options>Axes/Grid Settings, and this time click the Grid tab. 
Clear the Auto check box, then in the Extra y edit field enter 0.01. Click OK.

4 Go back to the Draw toolbar and click the Point button. Create a point at location 
(0.1, 0.01).

NAME EXPRESSION DESCRIPTION

k1 cp1*mu/0.28 Thermal conductivity

Th Tc+0.0527 Higher temperature

PARAMETER VALUE

x min -0.03

x max 0.13

y min -0.02

y max 0.12
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P H Y S I C S  S E T T I N G S

From the Multiphysics menu select Brinkman Equations (chns).

Boundary Conditions
The boundary conditions default to No slip and need not be altered.

Subdomain Settings
Select the menu item Physics>Subdomain Settings, select subdomain 1, then enter the 
following specifications; when done, click OK.

Point Settings
From the Physics menu choose Point Settings. Select point 5 and then select the Point 

constraint check box. Leave the p0 edit field at 0. Click OK.

Initial Conditions
Leave the initial conditions will at their default values: u = v = p = 0.

QUANTITY EXPRESSION

ρ rho

η mu

εp 0.4

κ perm

Fx 0

Fy damp*rho*g*beta*(T-Tc)
R  5 :  H E A T  TR A N S F E R  M O D E L S



Boundary Conditions
1 From the Multiphysics menu select Convection and Conduction in Porous Media (eshcc). 

2 Select the menu item Physics>Boundary Settings. 

3 Select all boundaries in the list, then in the Boundary conditions list select 
Temperature. 

4 Select Boundaries 1 and 4, then in the T0 edit field enter Th-(Th-Tc)*s; for 
Boundaries 3 and 5 enter Tc in that edit field, and for boundary 2 enter Th.

Subdomain Settings
1 Select the menu item Physics>Subdomain Settings. 

2 Click the Time/Convection tab. Click the CL (User defined) button. Then enter the 
following settings in the associated edit fields:

3 Click the Spreading tab. In the Equivalent thermal conductivity list select User defined, 
and in the keq edit field enter k1.

4 Click OK.

Initial Conditions
Keep the initial condition at the default value of T = 0.

M E S H  G E N E R A T I O N

1 Select the menu item Mesh>Free Mesh Parameters.

2 From the Predefined mesh sizes list, select Fine.

3 Click the Remesh button.

4 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Select the menu item Solve>Solver Parameters. In the Solver list select Parametric.

2 In the Parameter name edit field enter damp, and in the Parameter values edit field 
enter 0:0.1:1.

3 Go to Advanced tab and set the Type of Scaling to None.

4 Click OK.

VALUE EXPRESSION

CL cp1*rho

u u

v v
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5 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate Figure 5-4, follow these steps:

1 Click the Plot Parameters button on the Main toolbar.

2 Go to the General page. In the Plot type area select the Surface and Contour check 
boxes.

3 Go to the Surface page, and in the Expression edit field enter (T-Tc)/(Th-Tc).

4 Go to the Contour page, and in the Expression edit field enter (T-Tc)/(Th-Tc).

5 Select the Uniform color option button, click the Color button, set the color as black, 
then click OK.

6 Clear the Color scale check box, then click OK.

To generate Figure 5-5, continue with these steps:

1 While still in the Plot Parameters dialog box, return to the General page. In the Plot 

type area clear the Contour check box and select the Arrow check box. Click Apply.

2 Click the Surface tab. In the Predefined quantities list select Velocity field.

3 Click the Arrow tab. Verify that the x component edit field reads u, that the y 
component edit field reads v, and that the selected color is black. Click OK.
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Pha s e  Chang e

This example demonstrates how to model a phase change and predict its impact on a 
heat transfer analysis. When a material changes phase, for instance from solid to liquid, 
energy is added to the solid. Instead of creating a temperature rise, the energy alters 
the material’s molecular structure. Equations for the latent heat of phase changes 
appear in many texts (see Ref. 1, Ref. 2, and Ref. 3) but their implementation is 
nonstandard. Heat consumed or released by a phase change affects fluid flow, magma 
movement and production, chemical reactions, mineral stability, and many other 
earth-science applications.

This 1D example uses the Conduction in Porous Media application mode from the 
Earth Science Module to examine transient temperature transfer in a rod of ice that 
heats up and changes to water. This example demonstrates how to handle material 
properties that vary as a function of temperature. A phase change with flow is the 
subject of the model “Freezing Soil” on page 198.

Figure 5-6: Material properties as a function of temperature.

This model proceeds as follows. First, estimate the ice-to-water phase change using the 
transient conduction equation with the latent heat of fusion. Next, run additional 
simulations to evaluate impacts of the temperature interval over which the phase 
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change occurs. Finally, compare the solution from the analysis with the latent heat to 
estimates that neglect it.

Model Definition

This model describes the ice-to-water phase change along a 1-cm rod of ice. At its left 
end the rod is insulated, and at the other end it touches boiling water. Values for 
thermal properties depend on the phase. For ice, density is 918 kg/m3, the specific 
heat capacity is 2052 J/(kg·K), and the thermal conductivity is 2.31 W/(m·K). For 
water, the density, specific heat capacity, and thermal conductivity are 997 kg/m3, 
4179 J/(kg·K), and 0.613 W/(m·K), respectively. Reference temperatures are 265 K 
for ice and 300 K for water. The latent heat of fusion, λ, is 333 kJ/kg. The starting 
temperature in the rod is –20 °C.

The conduction equation is

.

In the equation, Ceq is the effective volumetric heat capacity (J/K·m3), T is 
temperature (K), Keq is the effective thermal conductivity (W/m·K), and Q is a heat 
source (W/m3).

Ceq and Keq typically are volume averages of the form

where θ is the volumetric content, ρ equals density (kg/m3), and Cp is the specific heat 
capacity (J/(K·kg)) of a liquid or a solid. In this problem, however, you modify Ceq to 
account for the latent heat of fusion so that

.

It describes latent heat using the latent heat of fusion λ (J/kg) for only the normalized 
pulse around a temperature transition D (K−1). 

The integral of D must equal unity to satisfy the following

δts Ceq
∂T

t∂
------- ∇+ Keq– T∇( )⋅ ΣQ=

Ceq
ΣθiρiCpi=

Ceq
Σθiρi Cpi Dλ+( )=
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such that the pulse width denotes the range between the liquidus and solidus 
temperatures.

The boundary conditions for this model are insulating at x =0 and fixed temperature 
at x = 0.01 where 

Implementation

Because the thermal properties differ between ice and water, you create a variable H, 
which goes from unity for water to zero for ice. In this way H amounts to the volume 
fraction θ of water within a model element. Therefore, the effective properties switch 
with the phase through multiplication with H. 

The switch in H from 0 to 1 occurs over the liquid-to-solid interval using a smoothed 
Heaviside function. This model implements the Heaviside function with the 
expression H = flc2hs(T-Ttrans,dT); where the transition interval for the function 
is dT. In this way, the pulse D is the derivative of H with respect to temperature. You 
can then express D with the COMSOL Multiphysics diff operator as in  
D = diff(H,T).

To find out more about implementing this and other smoothing functions, see the 
COMSOL Multiphysics User’s Guide under “Specifying Discontinuous Functions” 
on page 149 as well as the COMSOL Multiphysics Reference Guide.

Results

Figure 5-7 shows images of the temperature distribution predicted with latent heat for 
output intervals of 100 s. The system is solid ice at t = 0, and water content increases 
with time. The distributions level out around the zero temperature point because not 

ρDλ Td
∞–

∞

∫ ρλ=

n Keq– T∇( )⋅ 0= Ω Origin∂

T T0= Ω Heat source∂
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all of the energy is going toward a temperature rise; some is being absorbed to change 
the molecular structure and change the phase.

Figure 5-7: Temperature estimates with latent heat at t = 0:15:60 and120:60:1200 s.

.

Figure 5-8: Temperature estimates without latent heat a t = 0:15:60 and120:60:1200 s.
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The solution in Figure 5-8 shows temperature estimates for the simulation without 
latent heat. The kink in the temperature curve results from differences in the thermal 
properties of ice and water.

Figure 5-9 shows results for different solid-to-liquid intervals at three times. The 
smaller the interval, the sharper the bend in the temperature profile at zero 
temperature, T. In the simulations, narrowing the temperature interval to a step 
change, for example, comes at a large computational cost. In the figure, the results for 
the wide and narrow pulses compare closely.

Figure 5-9: Temperature estimates for different temperature intervals for latent heat 
consumption. Estimates are for dT intervals of 0.1 (solid line), 0.5 (dashed line), and 2.5 
(dotted line) at t = 30 s, 300 s, and 600 s.
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Model Library path: Earth_Science_Module/Heat_Transfer/phase_change

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 In the Model Navigator go to he Space dimension list and select 1D.

2 In the list of application modes select 
Earth Science Module>Heat Transfer>Conduction>Transient analysis.

3 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 Select the menu item Options>Constants, then enter the following names, 
expressions, and descriptions (optional); when done, click OK.

2 Select the menu item Options>Expressions>Scalar Expressions and define the 
following names and expressions; when done, click OK.

G E O M E T R Y  M O D E L I N G

1 Select the menu item Draw>Specify Objects>Line. Define the end points by going to 
the x edit field and entering 0 0.01.

2 Click the Zoom Extents button on the Main toolbar to center the line in the field of 
view.

P H Y S I C S  S E T T I N G S

Boundary conditions
1 From the Physics menu select Boundary Settings.

NAME EXPRESSION DESCRIPTION

T_trans 0[degC] Transition temperature

dT 0.5[K] Transition interval

lm 333[kJ/kg] Latent heat of fusion

NAME EXPRESSION DESCRIPTION

H flc2hs((T-T_trans)[1/K],dT[1/K]) Heaviside function

D diff(H,T) Temperature transition
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2 In the Boundary selection list select 2, then in the Boundary condition list select 
Temperature.

3 To set the high temperature at the heat source go to the Temperature edit field and 
enter 100[degC].

4 To accept the boundary conditions as entered, click OK.

Subdomain settings
1 Select the menu item Physics>Subdomain Settings.

2 On the Materials page, select Subdomain 1 and enter the following liquid (L) and 
solid (P) property values; when done, click OK.

SYMBOL EXPRESSION

 θL H+eps

 ρL 997

 CpL 4179+D*lm

 KL 0.613

 θP 1-H+eps

 ρP 918

 CpP 2052+D*lm

 KP 2.31
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3 Click the Init tab and in the T(t0) edit field enter -20.

4 Click the Element tab. In the Predefined elements list choose Lagrange-Linear. 

The use of linear elements reduces computation time at a relatively small price in 
accuracy. This feature can be particularly helpful during concept-development 
stages, after which you might want to switch back to Lagrange-Quadratic elements.

M E S H  G E N E R A T I O N

1 Click the Initialize Mesh button on the Main toolbar. The mesh consists of 15 
elements, making it quite coarse. 

2 Click the Refine Mesh button on the Main toolbar three times to obtain a relatively 
fine mesh with 120 elements.

C O M P U T I N G  T H E  S O L U T I O N

1 Select the menu item Solve>Solver Parameters.

2 Go to the Times edit field and enter 0:15:60,60:60:1200. Click OK.

All the parameter values in this model have a time units of seconds, so the output 
time you enter here gives a total simulation time of 20 minutes. 

3 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate Figure 5-7, follow these steps:

1 Select the menu item Postprocessing>Domain Plot Parameters.

2 Click the Line/Extrusion tab, then in the Subdomain selection list choose 1. 

3 In the y-axis data area go to the Predefined quantities list and select Temperature.

4 From the Unit list, select °C to display the temperature in degrees Celsius.

5 Click the General tab and verify that all time steps in the Solutions to Use list are 
selected.

S A V I N G  T H E  F I L E

To save the current model, go to the menu item File>Save As, enter the file name 
phase_change, then click OK. Also leave the model file open.

Phase Change Without Latent Heat

To analyze the impact of the latent heat terms on the phase-change model, it is useful 
to estimate temperatures using the same approach but without the latent heat term.
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O P T I O N S  A N D  S E T T I N G S

From the Options menu select Constants. Find the name for latent heat (lm) and in the 
associated Expression edit field enter 0[kJ/kg]. Click OK.

C O M P U T E  T H E  S O L U T I O N

Solve the model by clicking the Solve button in the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To create Figure 5-8, use the postprocessing sequence described for Figure 5-7 on 
page 306.

Phase Change for Varying Transition Intervals

Solutions to the phase-change problem vary with the range in temperatures dT over 
which you assume the phase transition occurs. To visualize the impact of different 
transition widths, sample results from the original simulation and compare those 
estimates to results from simulations with varying dT values. 

S A M P L I N G  T H E  P R E V I O U S  R E S U L T S

To creating Figure 5-9, follow these steps:

1 Reopen the model phase_change.mph and select the menu item 
Postprocessing>Domain Plot Parameters.

2 On the General page, go to the Solutions to use list and select output times 60, 300, 
and 600. Select the Keep current plot check box.

3 Click OK to generate the plot; do not close the plot window.

O P T I O N S  A N D  S E T T I N G S

Select the menu item Options>Constants. Change dT to another value, for instance 
2.5[K]. Click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar. 

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The second part of creating Figure 5-9 is with these steps:

1 Select the menu item Postprocessing>Domain Plot Parameters and go to the General 

page. In the Solutions to use list select the same output times: 60, 300, and 600.
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2 Next click the Title>Axis button and modify the settings as appropriate. Click OK.

3 To complete the comparison plot, go to the Line/Extrusion page, click the Line 

Settings button and change the line properties to distinguish the new set of results, 
then click OK. Click OK to close the dialog box.
R  5 :  H E A T  TR A N S F E R  M O D E L S



 6
M u l t i p h y s i c s  M o d e l s
Two models in 2D and 3D of the electrokinetic and magnetic fields inside a 
volcano highlight the multiphysics modeling capabilities in COMSOL Multiphysics 
and the Earth Science Module.
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E l e c t r o k i n e t i c  a nd Magn e t i c  F i e l d s  
I n s i d e  a  Vo l c a no

This multipart example examines several coupled geophysical phenomena: the 
electrokinetic voltages generated as fluid moves through porous media; the magnetic 
field the currents produce; and the feedback from the electric field to the fluid flow. 
Investigating these effects is important in many applications (Ref. 1, Ref. 2, and Ref. 
3) such as tracking subsurface distribution and flow of fluids, estimating reservoir 
properties, predicting hydrothermal flow, and establishing innovative methods for 
mitigating subsurface contaminants, to name a few. The models described here couple 
the Darcy’s Law application mode of the Earth Science Module with COMSOL 
Multiphysics’ DC Conductive Media and Magnetostatics application modes.

In the first stages of this model, fluid-flow equations are 1-way coupled to electric-field 
equations for a 2D geometry. Here the moving fluid generates a current that in turn 
generates magnetic fields, which you calculate with a COMSOL Multiphysics 
application mode. In the second step you compare the magnetic fields just calculated 
with the COMSOL Multiphysics to those predicted with Biot-Savart’s law. After 
matching the analytic expression, you relax the restrictions of 1-way coupling and 
couple the fluid-flow and electric-field equations bidirectionally. The feedback from 
the electric field to the fluid flow equations adds electroosmotic forces to the fluid 
velocity. 

This model is based on research carried out at the University of Leipzig and ETH 
Zurich. A detailed description of the underlying physics and consequences for 
volcanological exploration appears in Ref. 4. Finally, this example develops a 3D 
version of the model using an elevation model contributed by Prof. Carl Gerstenecker 
of the Technical University of Darmstadt (Ref. 5). Both models are available in the 
Earth Science Module Model Library.

Note: These models require the AC/DC Module.
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Model Definition

Figure 6-1 shows the infiltration of rain water info a volcano conduit. The water is 
moving preferentially through highly permeable fractured rocks in a volcano’s neck. 
Very little water flows in the older impermeable parts of the edifice. Measuring the 
distribution of voltages and magnetic fields provides insight into the internal flow 
regime.

Figure 6-1: Vertical slice through a volcano with a permeable conduit.

F L U I D  F L O W

The fluid flow in this problem is steady so you describe it with the continuity equation

where u is a vector of directional fluid velocities.

In a first approximation, neglecting the electroosmotic drag, the fluid velocity is 
governed by Darcy’s law

where κ denotes the hydraulic permeability of the porous medium, and η is the fluid’s 
dynamic viscosity.

The boundary conditions for the hydraulic system are as follows: Infiltration occurs 
only at the top of the conduit assuming that water supplied to the system moves 
vertically under its own weight. This produces a seepage velocity of

∇ u⋅ 0=

u κ
η
---∇P–=
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in the y direction through the boundary. Here, ρ is the fluid density and g is 
gravitational acceleration. At the bottom of the conduit you assume an outflow of 
–uout (see details in section topography). All other boundaries are hydraulic insulating, 
u · n = 0.

E L E C T R I C  P O T E N T I A L

The equation of continuity for electric potential reads 

where J is current density.

Ohm’s law governs the flow of electric potential. After adding the current generated 
by the fluid flow, the equation for current density reads

where σ denotes the rock’s electric conductivity, and V is the electric potential.

F L O W - T O - E L E C T R I C  P O T E N T I A L  C O U P L I N G

The equation contains an electrokinetic-coupling coefficient α given by

where ε is the dielectric permittivity, ζ denotes the zeta potential of the mineral-fluid 
interface, and F0 is the formation factor, that is, the ratio between fluid and rock 
resistivity (σfluid/σ).

The electric problem is completely insulated, J · n = 0. At the earth’s surface, no 
current leaves the rock into the air. The subsurface boundaries of the modeling domain 
are sufficiently far away from the sources to be unaffected by changes near the surface.

P O I N T  S E T T I N G S  F O R  A  U N I Q U E  S O L U T I O N

Because both the hydraulic and the electric problems use only Neumann boundary 
conditions, you make the problem unique by setting p = 0, V = 0 at an arbitrary point.

u0 ρgκ
η
---=

∇ J⋅ 0=

J σ∇V– α∇P– σE Je
+= =

α εζ
ηF0
----------=
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M A G N E T I C - F I E L D  E Q U A T I O N S

To calculate the magnetic field or magnetic flux density that corresponds to the electric 
current field resulting from the hydraulic flow, use the quasi-static approximation

.

Further, using Ampere’s law with the multiphysics definition for current density gives

.

The governing equation for the magnetic field therefore reads

.

Here the only boundary condition needed is the electric insulation.

In the postprocessing steps described later in this chapter you compare these 
magnetic-flux estimates to those obtained with Biot-Savart’s law.

2D Model with Topography and Electroosmotic Force

A realistic geological model would need to account for two additional features: the 
effect of topography and the feedback of the electric field on the hydraulic flow.

In reality, the electric field influences the flow field and exerts electroosmotic drag. 
Moreover, topographical nuances figure prominently in generating the electric field. 
With a sloping surface you can no longer assume that all rainfall penetrates the ground 
surface. Instead some rainfall runs off, which affects the flow field.

E L E C T R O O S M O T I C  D R A G

To account for electroosmotic drag in Darcy’s law, use the reciprocity relations of 
Onsager (Ref. 2):

.

Here you implement the electric-field component by including it as a source term in 
COMSOL Multiphysics’ Darcy’s Law application mode. You also define a modified 
velocity vector using subdomain expressions, which you plot during postprocessing.

TO P O G R A P H Y

Users often prefer to obtain realistic topography models by importing geometries. 
Topography models can be conveniently imported by using one of COMSOL 

∇ E× 0=
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η
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Multiphysics’ CAD interfaces (for example DXF in 2D or, using the CAD Import 
Module, most of the popular 3D CAD formats, including IGES, STEP, SAT, and 
Parasolid files). In addition, COMSOL Script provides unlimited flexibility to read in 
data in ASCII or binary format. In this case you import the volcano geometry as a DXF 
file in the COMSOL Multiphysics user interface. 

The geometry features three major fracture zones: one main conduit and two parasitic 
conduits. One of the parasitic conduits developed itself fully to the surface, while the 
other one stalled and produced a cryptodome. Because the fractures zones are highly 
permeable, rainfall penetrates preferentially through the conduits that intersect the 
surface and exits the system through the conduits at depth. Owing to the topography, 
only part of a rainfall penetrates the ground surface and a fraction runs off. Assuming 
the infiltration into the ground is a function of topographic slope, the fluid velocity 
crossing the boundary is the rainfall rate, u0, multiplied by the vertical component of 
the normal vector to the boundary, ny.

At steady state, the flow moving out of the system at any point (the outflow) must 
equal the total rainfall entering at the ground surface (influx) divided by the outflow 
boundary length (outlength). In this example, you automate the calculation using 
integration coupling variables.

Results—2D Model with Topography and Electroosmotic Force

Figure 6-2 illustrates the COMSOL Multiphysics solution for fluid pressure and fluid 
velocities in the volcano where a 2-way coupling exists between fluid flow and electric 
potential. The fluid moves primarily within the fractured conduits reaching the surface. 

uin u0ny= outflow influx
outlength
-------------------------

u0ny sd
in
∫

sd
out
∫

------------------------==
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The model modifies the fluid velocities to include a term that accounts for 
electroosmotic drag generated by the electric field.

Figure 6-2: Solution for pressure distribution (surface plot) and velocities (arrows).

Figure 6-3 shows the electric self potential and the total electric current. Moving fluids 
initiate the electric potential. The plot marks negative anomalies at the top of the two 
outcropping domes. Positive potential is created at the bottom of the model, and at 
the top the cryptodome acts as a collector of hydraulic and electric flux.
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Figure 6-3: Solution for electric potential (surface plot) and current density (arrows).

Figure 6-4: Solution for magnetic flux (surface plot) and current density (arrows).
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Figure 6-4 plots the magnetic flux density with the current density. The flux densities 
are highest along the boundaries of the permeable conduits. The field is directed out 
of the plane on the left edges and into the plane on the right edge. 

Magnetic Field Postprocessing—Biot-Savart’s Law

In this section you calculate the magnetic field with the Biot-Savart formula and 
compare these estimates to the COMSOL Multiphysics solution just reported. The 
comparison provides a good check for consistency and accuracy.

Assuming constant magnetic permeability µr = 1, you can calculate the magnetic flux 
density for an arbitrary current system j with Biot-Savart’s law

where µ0 = 4π · 10−7 V·s/(A·m) is the permeability of free space. For a point 
r0 = (x0, y0) in the xy-plane, you obtain the field components

Bx and By become zero when integrating in the z direction. For the remaining 
component, the identity

applies. Combining the expressions gives

.  (6-1)

B r0( )
µ0
4π
------

j r0 r–( )×
r0 r–

---------------------------- rd∫=

Bx
µ0
4π
------

jxz–

x0 x–( )2 y0 y–( )2 z2
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3 2⁄
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To calculate the expression in Equation 6-1 for an arbitrary point (x0, y0) you use the 
COMSOL Multiphysics interpolation command postint. You create the string to be 
integrated with the sprintf command. To create Figure 6-5 with COMSOL Script 
or MATLAB, see the section “Modeling Using the Programming Language” on page 
329.

Results—Postprocessing the Magnetic Field

Figure 6-5: Left plot—Comparison of the Bz field evaluated directly from the PDE (solid 
line) and the Biot-Savart integration (o). Right plot—Relative difference between PDE 
solution and the integrated result. The rms error for the 17,700-element mesh is 4%.

Figure 6-5 plots the COMSOL Multiphysics solution and the Biot-Savart estimates. 
The results agree well with an average percent difference of 4% along the profile. In 
the example with 17,700 elements the calculation of Biot-Savart requires about twice 
as much time as solving the magnetic PDE directly.

3D Model of Fluid Flow, Electrostatics, and Magnetostatics

In a 3D model of coupled fluid flow, electrostatics, and magnetostatics for an 
approximately cylindrical/axisymmetric geometry, toroidal fields form around the 
volcanic conduits where fluid flow is fast. To examine these effects, extend the 2D 
model to 3D. You can review the model file and postprocess the results by opening the 
file volcano3d.mph in the Earth Science Module Model Library. The author created 
the 3D geometry using data provided by Carl Gerstenecker of TU Darmstadt based 
on his work with Tiede, Läufer, Wrobel, and Steineck (Ref. 5).
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Results—3D Model of Fluid Flow, Electrostatics, and Magnetostatics

Figure 6-6 is a cutaway view of the COMSOL Multiphysics solution for 3D fluid 
pressure and fluid velocities in the volcano where fluid flow and electric potential are 
2-way coupled. Again the fluid moves primarily within the fractured conduits to reach 
the surface. The fluid velocities are driven by gradients in pressure and electric 
potential. The magnetic field results from the electric current density. The visible 
toroidal effects center on the fast flow around the conduit.

Figure 6-6: COMSOL Multiphysics solution for coupled fluid flow, electrostatics, and 
magnetostatics in a volcano.
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Model Library path: Earth_Science_Module/Multiphysics/volcano_2d

Modeling Using the Graphical User Interface—2D Model

M O D E L  N A V I G A T O R

1 Open the Model Navigator, and in the Space dimension list select 2D.

2 In the list of application modes select  
Earth Science Module>Fluid Flow>Darcy’s Law>Pressure analysis.

3 Click the Multiphysics button.

4 Click the Add button to include the Darcy’s application mode in the model.

5 In the list of application modes select  
COMSOL Multiphysics>Electromagnetics>Conductive Media DC, then click Add.

6 In the list of application modes select  
AC/DC Module>Statics>Magnetostatics>In-Plane Induction Currents, Magnetic Field, 
then click Add.

7 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu select Constants, the enter the following names and 
expressions; when done, click OK.

NAME EXPRESSION DESCRIPTION

sigma1 0.1[S/m] Electric conductivity, permeable 
fracture

alpha1 5.0e-9[(F/m)*V/(Pa*s)] Electrokinetic-coupling coefficient, 
permeable fracture

kappa1 1.0E-10[m^2] Hydraulic permeability, permeable 
fracture

sigma2 0.01[S/m] Electric conductivity, impermeable 
parts
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2 From the Options menu select Expressions>Subdomain Expressions.

3 Enter the following names and expressions to define new directional components of 
fluid velocity and a resulting total velocity that account for electroosmotic drag:

G E O M E T R Y  M O D E L I N G

1 Import the volcano geometry from a DXF file. Select the menu item 
File>Import>DXF File. Find the folder COMSOL/Earth_Science_Module/
Multiphysics and then select the file volcano.dxf.

2 Accept the default settings for the geometry import. Click OK.

alpha2 5.0e-9[F*V/(Pa*s*m)] Electrokinetic-coupling coefficient, 
impermeable parts

kappa2 1.0e-12[m^2] Hydraulic permeability, impermeable 
parts

eta 8.9e-3[Pa*s] Dynamic viscosity

rho 1000[kg/m^3] Density

g 9.82[m/s^2] Acceleration due to gravity

u0 rho*g*kappa1/eta Seepage velocity

NAME EXPRESSION FOR SUBDOMAINS 1, 3, 4 EXPRESSION FOR SUBDOMAIN 2

u_new u_esdl-alpha1*Vx u_esdl-alpha2*Vx

v_new v_esdl-alpha1*Vy v_esdl-alpha2*Vy

U_new sqrt(u_new^2+v_new^2) sqrt(u_new^2+v_new^2)

NAME EXPRESSION DESCRIPTION
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3 Click the Coerce to Solid button on the Draw toolbar.

P H Y S I C S  S E T T I N G S — D A R C Y ’ S  L A W

From the Multiphysics menu select Darcy’s Law (esdl).

Application Mode Properties
1 From the Physics menu select Scalar Variables.

2 In the Description column look for Elevation/vertical axis, and in the corresponding 
Expression edit field change the entry to 0. Click OK.

Subdomain Settings
1 From the Physics menu select Subdomain Settings.

2 Enter the settings from the following table; when done, click OK.

Boundary Conditions
For the boundary condition you need two integration-coupling variables.

SETTINGS SUBDOMAINS 1, 3, 4 SUBDOMAIN 2

 κs kappa2 kappa1

 η eta eta

 Qs alpha2*(Vxx+Vyy) alpha1*(Vxx+Vyy)
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1 From the Options menu, select Integration Coupling Variables>Boundary Variables. 
Enter the following coupling variables, each on its own row in the table; when done, 
click OK.

2 From the Physics menu, select Boundary Settings.

3 Enter the following settings for the specified boundaries; when done, click OK.

Because influx and outlength are integration coupling variables, COMSOL 
Multiphysics considers the unit for the inward flux across Boundary 54 to be 
inconsistent with the model’s base unit system. You can disregard this warning.

Point Settings
1 From the Physics menu select Point Settings.

2 Select Point 2 and in the Pressure(s) edit field enter 0. Click OK.

P H Y S I C S  S E T T I N G S — C O N D U C T I V E  M E D I A  D C

From the Multiphysics menu select Conductive Media DC (dc).

Subdomain Settings
1 From the Physics menu select Subdomain Settings.

2 Enter the following settings; when done, click OK.

Boundary Conditions
1 From the Physics menu select Boundary Settings.

2 Select all the boundaries, and in the Boundary condition list select Electric insulation.

3 Click OK.

BOUNDARIES NAME EXPRESSION INTEGRATION ORDER GLOBAL DESTINATION

35–37, 56–61 influx u0*ny 4 yes

54 outlength 1 4 yes

SETTINGS BOUNDARIES 35–37, 56–61 BOUNDARY 54 ALL OTHERS

Boundary condition Inward flux Inward flux Zero flux/Symmetry

N0 u0*ny ny*influx/
outlength

SETTINGS SUBDOMAIN 1, 3, 4 SUBDOMAIN 2

 σ (isotropic) sigma2 sigma1

 J [-px*alpha2, -py*alpha2] [-px*alpha1, -py*alpha1]
E L E C T R O K I N E T I C  A N D  M A G N E T I C  F I E L D S  I N S I D E  A  V O L C A N O  |  327



328 |  C H A P T E
Point Settings
To make the system well defined, you must give the potential some reference value at 
a given point. In this case you lock the potential at Point 2.

1 From the Physics menu, select Point Settings.

2 In the Point selection list select 2.

3 Click the Electric potential button, and make sure the electric potential is set to 0.

4 Click OK.

P H Y S I C S  S E T T I N G S — I N - P L A N E  C U R R E N T S ,  M A G N E T I C  F I E L D

From the Multiphysics menu select In-Plane Currents, Magnetic Field (emqh).

Subdomain Settings
1 From the Physics menu, select Subdomain Settings.

2 Enter the following settings; when done, click OK.

Boundary Conditions
1 From the Physics menu, choose Boundary Settings.

2 Select all boundaries, and in the Boundary condition list select Electric insulation.

3 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters.

2 Click the Boundary tab.

3 Select all interior boundaries (the boundaries on the volcano surface) and the outlet 
boundary (all boundaries except for 1, 2, 63, and 112).

4 In the Maximum element size edit field, type 20.

5 Click Remesh, then click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

SETTINGS SUBDOMAINS 1, 3, 4 SUBDOMAIN 2

 σ (isotropic) sigma2 sigma1

 J [-px*alpha2, -py*alpha2] [-px*alpha1, -py*alpha1]
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Modeling Using the Programming Language

To create Figure 6-5, use the following code with COMSOL Script or MATLAB. The 
script is also available as the M-file volcano_2d_Bz_plots.m located in the same 
directory as the model MPH-file (see the Model Library path on page 324).

% Create a set of coordinates along a line in the x direction
% at an altitude of 1000 m
x0 = -2000:100:2000;
y0 = x0*0+1000;

% Evaluate the Biot-Savart integral for each point
for i = 1:length(x0)
  st = sprintf(['2e-7*(Jx_dc*(%f-y)-Jy_dc*(%f-x))/' ...
  '((%f-x)^2+(%f-y)^2)'],y0(i),x0(i),x0(i),y0(i));
  Bz(i) = postint(fem,st);
end

% For comparison, evaluate the magnetic field directly from
% the COMSOL Multiphysics solution
Bz2 = postinterp(fem,'Bz_emqh',[x0;y0]);

figure, plot(x0,Bz2,x0,Bz,'o');
xlabel('x [m]');
ylabel('Magnetic flux density B<sub>z</sub> [T]');
legend('PDE','B-S');

diff = 100*(Bz-Bz2)./Bz2;
figure, plot(x0,diff);
xlabel('x [m]');
ylabel('Relative difference [%]');

Model Library path: Earth_Science_Module/Multiphysics/volcano_3d

Modeling Using the Graphical User Interface—3D Model

M O D E L  N A V I G A T O R

1 In the Model Navigator, open the Earth Science Module folder and select 
Fluid Flow>Darcy’s Law>Pressure analysis.

2 Click Add.

3 In the AC/DC Module folder, open the Statics folder. Select and add, in turn, 
Conductive Media DC and Magnetostatics application modes.
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4 Click OK.

G E O M E T R Y  M O D E L I N G

1 From the File menu, choose Import>CAD Data From File.

2 In the Import CAD Data From File dialog box, make sure that the COMSOL Multiphysics 

file or All 3D CAD files is selected in the Files of type list.

3 From the models/Earth_Science_Module/Multiphysics directory under the 
COMSOL Multiphysics installation folder, locate the vulcano_3d.mphbin file and 
click Import.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, choose Constants.

2 Make the following entries in the Constants dialog box; when done, click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings—Darcy’s Law
1 From the Multiphysics menu, select Darcy’s Law (esdl).

2 From the Physics menu, select Subdomain Settings.

3 Select Subdomain 2, then clear the Active in this domain check box.

4 Select Subdomain 1, then type kappa1 in the Saturated permeability edit field.

NAME EXPRESSION DESCRIPTION

sigma1 0.01[S/m] Electric conductivity, permeable 
fracture

alpha1 1e-8[(F/m)*V/(Pa*s)] Electrokinetic-coupling coefficient, 
permeable fracture

kappa1 1e-12[m^2] Hydraulic permeability, permeable 
fracture

sigma2 0.1[S/m] Electric conductivity, impermeable 
parts

alpha2 1e-8[(F/m)*V/(Pa*s)] Electrokinetic-coupling coefficient, 
impermeable parts

kappa2 1e-10[m^2] Hydraulic permeability, impermeable 
parts

eta 8.9e-3[Pa*s] Dynamic viscosity

rho 1000[kg/m^3] Density

g 9.82[m/s^2] Acceleration due to gravity

u0 rho*g*kappa2/eta Seepage velocity
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5 Select Subdomain 3, then type kappa2 in the Saturated permeability edit field.

6 Select both Subdomain 1 and Subdomain 3.

7 Enter rho for the Density and eta for the Viscosity.

8 Click OK.

Boundary Conditions—Darcy’s Law
1 From the Physics menu, select Boundary Settings.

2 Select the bottom surface of the cylinder in the geometry or select Boundary 12 
from the Boundary selection list.

3 From the Boundary condition list, select Pressure. Leave the specified pressure at its 
default zero value.

4 Select the cylinder’s upper surfaces in the geometry or select Boundary 13 from the 
Boundary selection list.

5 From the Boundary condition list, select Inward flux. Set the Inward flux to -nz*u0.

6 Click OK.

Subdomain Settings—Conductive Media DC
1 From the Multiphysics menu, select Conductive Media DC (emdc).

2 From the Physics menu, select Subdomain Settings.

3 Select Subdomain 2, then clear the Active in this domain check box.

4 Select Subdomain 1. Enter sigma1 in the Electric conductivity edit field.

5 In the edit fields for the External current density, enter -alpha1*px, -alpha1*py, 
and -alpha1*pz.

6 Select Subdomain 3. Enter sigma2 in the Electric conductivity edit field.

7 In the edit fields for the External current density, enter -alpha2*px, -alpha2*py, 
and -alpha2*pz.

8 Click OK.

Boundary Conditions—Conductive Media DC
1 From the Physics menu, select Boundary Settings.

2 In the Boundary Conditions dialog box, select all boundaries and set the boundary 
condition to Electric insulation.

3 Click OK.

Point Settings—Conductive Media DC
1 From the Physics menu, select Point Settings.
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2 Select Boundary 5 and click the V0 option button. Leave the potential at 0.

3 Click OK.

Subdomain Settings—Magnetostatics
1 From the Multiphysics menu, select Magnetostatics (qa).

2 From the Physics menu, select Subdomain Settings.

3 Select Subdomains 1and 3.

4 In the edit fields for the External current density, enter Jx_emdc, Jy_emdc, and 
Jz_emdc.

5 Leave the default settings for Subdomain 2.

6 Click OK.

Boundary Conditions—Magnetostatics
Use the default boundary settings for the Magnetostatics application mode.

Application Mode Properties—Magnetostatics
You need to turn on the gauge fixing manually for this model, because it uses other 
solver settings than the default settings for the 3D Magnetostatics application mode, 
which provide numerical gauge fixing through the SOR gauge and SORU gauge pre- 
and postsmoothers.

1 From the Physics menu, choose Properties.

2 In the Application Mode Properties dialog box, select On from the Gauge fixing list.

3 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters.

2 On the Global page, select Coarse from the Predefined mesh sizes list.

3 Click Remesh, then click OK.

C O M P U T I N G  T H E  S O L U T I O N

Because the application modes are coupled only in one direction, you can solve them 
in sequence to reduce the memory consumption.

1 From the Solve menu, select Solver Parameters.

2 From the list of Linear system solver, select GMRES.

3 Set the Drop tolerance to 0.05.

4 Click OK to close the Solver Parameters dialog box.
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5 From the Solve menu, select Solver Manager.

6 On the Solve For page, select only the Darcy’s Law (esdl) application mode.

7 Click Apply.

8 Click the Script tab. Click the Add Current Solver Settings button.

9 Type fem1=fem0; in the script window to store the current solution.

10 Click the Initial Value tab.

11 In the Initial value area, click the Initial value expression evaluated using stored 

solution button.

12 In the Values of variables not solved for and linearization point area, click the 
Stored solution button.

13 Click the Solve For tab. Select only the Conductive Media DC (emdc) application mode.

14 Click Apply.

15 Click the Script tab. Click the Add Current Solver Settings button.

16 Type fem1=fem0; in the script window to store the current solution.

17 Click the Solve For tab. Select only the Magnetostatics (emqa) application mode.

18 Click Apply.

19 Click the Script tab. Click the Add Current Solver Settings button.

20 Select the Solve using a script check box, then click OK.

21 Click the Solve button ono the Main toolbar to start the simulation.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default visualization shows a pressure slice plot. To reproduce the plot shown in 
Figure 6-6, following these steps:

1 From the Postprocessing menu, select Plot Parameters.

2 Click the Subdomain tab. Select the Subdomain plot check box.

3 From the Predefined quantities list, select Darcy’s Law (esdl)>Pressure. From the Unit 
list, select MPa.

4 From the Colormap list, select hot.

5 Click the Boundary tab. Select the Boundary plot check box

6 From the Predefined quantities list, select Conductive Media DC (emdc)>Electric 

potential.

7 In the Coloring and fill frame, select Wireframe from the Fill style list.

8 Click the Arrow tab. Select the Arrow plot check box.
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9 From the Predefined quantities list on the Subdomain Data page, select Magnetostatics 

(emqa)>Magnetic field.

10 In the Arrow positioning frame, set the Number of points in x, y, and z to 21, 21, and 
7, respectively

11 In the Arrow parameters frame, click the Color button. In the Arrow Color dialog box, 
select black, then click OK.

12 Click the Slice tab. Select the Slice plot check box.

13 In the Expression edit field, type log10(normB_emqa).

14 In the Slice positioning frame, set the Number of levels for x, y, and z to 1, 0, and 0, 
respectively.

15 In the Slice color frame, clear the Color scale check box.

16 Click the General tab.

17 To look into the volcano, exclude part of the geometry in the postprocessing. Select 
the Element selection check box and enter x>0|y>0 in the Logical expression for 

inclusion edit field. This only includes parts with positive x- or y-coordinates, cutting 
away one quarter of the geometry.

18 Click OK to create the plot.
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