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 1
I n t r o d u c t i o n
The Chemical Engineering Module Model Library consists of a large number of 
models from various areas of chemical engineering. In particular, many of the 
examples come from the fields of unit operations, chemical reaction engineering, 
and transport phenomena.
 1
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Mode l  L i b r a r y  Ov e r v i ew

The purpose of this Model Library is to assist you in learning, by example, how to 
model sophisticated chemical-engineering units, processes, and phenomena. Through 
them you can tap the expertise of top researchers in the field, examining how they 
approach some of the most difficult modeling problems you might encounter. You can 
thus get a feel for the power that COMSOL Multiphysics® offers as a modeling tool. 
In addition to serving as a reference, the models can also give you a head start if you 
are developing a model of a similar nature. 

We have divided these models into nine chapters:

• Fluid Flow—Tutorials and Benchmarks

• Heat Transfer and Non-isothermal Flow—Tutorials and Benchmarks

• Multicomponent Transport—Tutorials and Benchmarks

• Mixers and Stirred Vessels

• Multiphase Flow

• Microfluidics

• Transport, Reactions, and Reaction Engineering

• Electrochemical Cells and Electrochemical Engineering

• Electrophoresis and chromatography

The first three chapters include tutorial and benchmark models that contain complete 
descriptions of the main phenomena captured by the Chemical Engineering Module—
transport phenomena. The following chapters include examples from specific 
application areas and models that are made up of coupled systems of the three 
balances—multiphysics. In this Model Library you also find advanced models of, for 
example, multiphase flow and reaction-engineering applications, including coupling 
the Chemical Engineering Module to the COMSOL Reaction Engineering Lab®.

These models illustrate various chemical-engineering-specific application modes in the 
Chemical Engineering Module. These specialized application modes are not available 
in the base COMSOL Multiphysics package, and they come with their own user 
interfaces that make it quick and easy to access their power.

Note that the model descriptions in this book do not contain every detail on how to 
carry out every step in the modeling process. Before tackling these in-depth models, 
we urge you to first read another book in the Chemical Engineering Module 
1 :  I N T R O D U C T I O N



documentation set. Titled the Chemical Engineering Module User’s Guide, it 
introduces you to the basic functionality in the module, covers basic modeling 
techniques, and includes reference material of interest to those working in chemical 
engineering. The models that it presents are far simpler than those given in the Model 
Library and might be more appropriate for your first introduction to COMSOL 
Multiphysics.

Further information on how to work with the COMSOL Multiphysics graphical user 
interface can be gained from the COMSOL Multiphysics User’s Guide or the 
COMSOL Multiphysics Quick Start  manual. An explanation on how to model with 
a programming language is available in the COMSOL Multiphysics Scripting Guide. 

This Chemical Engineering Module Model Library provides details about a large 
number of ready-to-run models that illustrate real-world uses of the module. Each 
entry comes with theoretical background as well as instructions that illustrate how to 
set it up. The models are written by our staff engineers, who have years of experience 
in chemical engineering. The terminology in the book should be familiar to you.

Finally, the software includes as loadable Model MPH-files (.mph) files all the examples 
in the Chemical Engineering Module Model Library as well as the Chemical 
Engineering Module User’s Guide. Click the Model Library tab in the Model Navigator 
to find them under the chapter headings just listed. They are great to investigate if you 
are familiar enough with the COMSOL Multiphysics structure and user interface but 
still would like an idea on how to set up a certain model. You can even use them as a 
starting point for models that are similar.

Model Library Guide

The following table summarizes key information about the entries in the Chemical 
Engineering Module Model Library as well as the Chemical Engineering Module 
User’s Guide. The solution time is the elapsed time measured on a machine running 
Windows Vista with a 2.6 GHz AMD Athlon X2 Dual Core 500 CPU and 2 GB of 
M O D E L  L I B R A R Y  O V E R V I E W  |  3
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TABLE 1-1

MODEL
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IC
 S
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Y

FLUID FL
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HEAT TR
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exchan
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exchan

MULTICO
RAM. For models with a sequential solution strategy, the Solution Time column shows 
the elapsed time for the longest solution step.

:  CHEMICAL ENGINEERING MODULE MODEL LIBRARY

PAGE APPLICATION MODES
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OW—TUTORIALS AND BENCHMARKS

l decomposition UG16 Navier-Stokes 35 s √ √ √

tutorial UG48 Weakly Compressible 
Navier-Stokes

3 s √ √ √

g duct 10 Navier-Stokes 5 s √axi √ √

l stack* 18 Navier-Stokes 124 
min

√ √ √

wtonian flow 30 Non-Newt Flow 12 s √axi √

 plates 39 Navier-Stokes 3 s √ √ √

d 46 Darcy’s Law 4 s √ √ √

 free 57 Brinkman, 
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4 s √ √ √
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ing droplet 75 Navier-Stokes, 
Conv&Conduction
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nt backstep 87 k-ε Turbulence Model 5 min √ √ √
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turbulent 
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98 Turbulent Fluid- 
Thermal

7 min √ √ √

114 Conduction 1 s √ √

eat 
ger 3d

119 Conv&Conduction 9 s √ √ √

thermal flow 129 Non-Isothermal Flow 16 s √ √ √

al heat 
ger

142 Conv&Conduction, 
Navier-Stokes

2 min √ √ √

MPONENT TRANSPORT—TUTORIALS AND BENCHMARKS
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dialysis

stefan t

maxwe

MIXERS A

laminar

turbule
time 2d

turbule
time 3d

rotating √

schema

MULTIPH

rigid bo

rising b

boiling 

droplet

bubble 

sedimen

dense s

TABLE 1-1

MODEL

P
A

R
A

M
E

T
R

IC
 S

T
U

D
Y

152 Conv&Diffusion, 
Navier-Stokes, 
Diffusion

1 s √ √ √

ube 164 Maxwell-Stefan 1 s √ √ √

ll stefan diffusion 173 Maxwell-Stefan 14 s √ √ √
ND STIRRED VESSELS

 static mixer 186 Conv&Diffusion, 
Navier-Stokes

28 min √ √ √

nt residence 197 k-ε Turbulence Model, 
Conv&Diffusion

49 s √ √ √ √

nt residence 197 k-ε Turbulence Model, 
Conv&Diffusion

34 min √ √ √ √

 disk 216 Swirl Flow 38 s √axi √

tic pump 227 Rotating 
Navier-Stokes

10 min √ √

ASE FLOW

dy motion 236 Level Set 7 s √ √ √

ubble 243 Navier-Stokes, 
Conv&Diffusion

7 s √ √ √

flow 255 Level Set Two-Phase 
Flow, Laminar, 
Conv&Conduction

36 min √ √ √

 breakup 270 Level Set Two-Phase 
Flow, Laminar

13 min √ √ √

column 279 Bubbly Flow, 
Conv&Diffusion

3 min √ √ √

tation 294 Mixture Model, 
k-ε Turbulence Model

6 min √ √ √

uspension 305 Mixture Model, 
Laminar 
PDE, General Form

7 min √ √ √
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MICROFL

biochip

capillar

electro

electro

electro

h cell √

TRANSPO

fixed be √

falling f

boat re √

monoli

nox red

porous

ELECTRO

chlor a

TABLE 1-1

MODEL

P
A

R
A

M
E

T
R

IC
 S

T
U

D
Y

UIDICS

320 Navier-Stokes, 
Conductive DC

4 s √ √ √

y filling 334 Level Set Two-Phase 
Flow, Laminar

149 
min

√axi √ √

kinetic valve 2d 348 Electrokinetic Flow, 
Navier-Stokes, 
Conductive DC

6 s √ √

kinetic valve 3d 365 Electrokinetic Flow, 
Navier-Stokes, 
Conductive DC

9 min √ √ √

osmotic flow 389 Electrokinetic Flow, 
PDE General Form

10 s √ √

403 Navier-Stokes, 
Conv&Diffusion

58 s √ √

RT, REACTIONS, AND REACTION ENGINEERING

d reactor 418 Conv&Conduction, 
Conv&Diffusion

8 s √axi √ √

ilm 433  Conv&Diffusion 2 min √ps √

actor 447 Navier-Stokes, 
Conv&Diffusion

5 s √axi √ √

thic reactor 461 Conv&Diffusion 2 s √ps √

uction 470 Navier-Stokes, 
Darcy’s Law, 
Conv&Diffusion

7 s √axi √ √

 reactor 494 Navier-Stokes, 
Conv&Diffusion, 
Brinkman

45 s √ √ √

CHEMICAL CELLS AND ELECTROCHEMICAL ENGINEERING

lkali 530 Conductive DC 1 s √ √ √
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mcfc

tumor

fc catho

pemfc

serpent

ELECTRO

capillar
electro

capillar
electro

liquid c

liquid c

liquid c

TABLE 1-1

MODEL

P
A

R
A

M
E

T
R

IC
 S

T
U

D
Y

*This model has been solved on a machine running Linux with an AMD64 processor 
and 12 GB of RAM.

Typographical Conventions

All COMSOL manuals use a set of consistent typographical conventions that should 
make it easy for you to follow the discussion, realize what you can expect to see on the 
screen, and know which data you must enter into various data-entry fields. In 
particular, you should be aware of these conventions:

• A boldface font of the shown size and style indicates that the given word(s) appear 
exactly that way on the COMSOL graphical user interface (for toolbar buttons in 

541 Conductive DC, 
Diffusion

3 s √ √ √

552 Nernst-Planck 14 s √ √

de 565 Conductive DC, 
Maxwell-Stefan, 
Darcy’s Law

30 s √ √ √

580 Conductive DC, 
Maxwell-Stefan, 
Darcy’s Law

16 s √ √ √

ine 602 Navier-Stokes, 
Maxwell-Stefan

5 min √ √ √

PHORESIS AND CHROMATOGRAPHY

y 
phoresis 1

620 Electrokinetic Flow, 
PDE General Form

11 s √ √

y 
phoresis 2

620 Electrokinetic Flow, 
PDE General Form, 
Conv&Diffusion

2 min √ √

hromatography 1 635 Conv&Diffusion 42 s √ √

hromatography 2 635 Conv&Diffusion 4 min √ √

hromatography 3 635 Conv&Diffusion 5 min √ √
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8 |  C H A P T E R  
the corresponding tooltip). For instance, we often refer to the Model Navigator, 
which is the window that appears when you start a new modeling session in 
COMSOL; the corresponding window on the screen has the title Model Navigator. 
As another example, the instructions might say to click the Multiphysics button, and 
the boldface font indicates that you can expect to see a button with that exact label 
on the COMSOL user interface.

• The names of other items on the graphical user interface that do not have direct 
labels contain a leading uppercase letter. For instance, we often refer to the Draw 
toolbar; this vertical bar containing many icons appears on the left side of the user 
interface during geometry modeling. However, nowhere on the screen will you see 
the term “Draw” referring to this toolbar (if it were on the screen, we would print 
it in this manual as the Draw menu).

• The symbol > indicates a menu item or an item in a folder in the Model Navigator. 
For example, Physics>Equation System>Subdomain Settings is equivalent to: On the 
Physics menu, point to Equation System and then click Subdomain Settings. 
COMSOL Multiphysics>Heat Transfer>Conduction means: Open the COMSOL 

Multiphysics folder, open the Heat Transfer folder, and select Conduction.

• A Code (monospace) font indicates keyboard entries in the user interface. You might 
see an instruction such as “Type 1.25 in the Current density edit field.” The 
monospace font also indicates COMSOL Script codes.

• An italic font indicates the introduction of important terminology. Expect to find 
an explanation in the same paragraph or in the Glossary. The names of books in the 
COMSOL documentation set also appear using an italic font.
1 :  I N T R O D U C T I O N



 2
F l u i d  F l o w— T u t o r i a l s  a n d  B e n c h m a r k s
This chapter contains a selection of fluid flow models. Among the examples you 
find models of laminar and turbulent flow, non-newtonian flow and porous media 
flow. There is also a two-phase flow example that accounts for surface tension. All 
models within this chapter are simple and instructive, demonstrating how you can 
use the fluid flow application modes to model different kinds of isothermal fluid 
flow. 
 9
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P r e s s u r e  R e c o v e r y  i n  a  D i v e r g i n g  
Duc t

Introduction

When the diameter of a pipe suddenly increases, as shown in Figure 2-1, the area 
available for flow increases. A fluid with relatively high velocity decelerates into a 
relatively slow moving fluid. Depending on the Reynolds number, this can cause 
turbulence, and much of the excess kinetic energy converts into heat and is therefore 
wasted. If the change of the cross section is gradual, it is possible to recover the kinetic 
energy as pressure energy.

This example presents a qualitative study of the pressure-recovery phenomenon in a 
uniformly diverging duct. It also shows the implementation of the Navier-Stokes 
equations in cylindrical coordinates. 

Figure 2-1: Geometrical representation of the modeling geometry.

Model Definition

The inlet condition is described by water flowing in a pipe with a diameter of 1 cm. 
The flow is laminar and has a fully developed laminar velocity profile, a so-called 
Hagen-Poiseuille profile. After 2 cm the water enters a uniformly diverging duct whose 
length is 5 cm and whose outlet diameter is 2 cm.

Because water is a Newtonian fluid and its density is constant at isothermal conditions, 
the Navier-Stokes equations combined with a continuity equation characterize the 
flow:
 2 :  F L U I D  F L O W — TU T O R I A L S  A N D  B E N C H M A R K S



 (2-1)

Here η denotes the dynamic viscosity (Pa·s), u represents the velocity (m/s), ρ gives 
the fluid density (kg/m3), and p denotes the pressure (Pa). The model becomes 
axisymmetrical and can be described in the r and z coordinates.

Figure 2-2: Simplification of the modeling geometry showing the symmetry axis and 
boundary labels.

The following equations describe the relevant boundary conditions at the symmetry 
axis, the outlet, the inlet, and the edge (wall) respectively:

 (2-2)

In these equations, for each boundary point n is the normal vector and t is any 
tangential vector, Furthermore, vmax is the maximum flow speed in the axial direction 
and R is the pipe radius at the inlet. The analytical expression above provides the 
velocity distribution at the inlet, a parabolic Hagen-Poiseuille profile.

Results

Figure 2-3 clearly shows that the velocity vector magnitude decreases as the 
cross-sectional area for the flow increases. You can additionally see the velocity vector 
itself by introducing arrows. The arrow plot also shows how a small radial velocity 

η u ρ u ∇⋅( )u p∇+ +∇2 0=

∇ u⋅ 0=

n u⋅ 0= at Ωsymmetry∂

η ∇u ∇u( )T
+( )n 0= p 0=, at Ωoutlet∂

u 0 vmax 1 r
R
----⎝ ⎠
⎛ ⎞ 2

–⎝ ⎠
⎛ ⎞,⎝ ⎠

⎛ ⎞= at Ωinlet∂

u 0 0,( )= at Ωedge∂
P R E S S U R E  R E C O V E R Y  I N  A  D I V E R G I N G  D U C T  |  11



12 |  C H A P T E R
component is introduced due to the expansion. Note that the radial and axial scales 
differ in the plot.

Figure 2-3: The velocity field.

Figure 2-4 shows that the pressure starts to recover when water enters the expansion 
zone after having dropped substantially in the narrow inlet zone. The pressure reaches 
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a local maximum at the end of the expansion zone (at about z = 0.1 m), after which it 
starts to drop again due to frictional and viscous losses.

Figure 2-4: Relative pressure distribution throughout the duct. Pressure drops through the 
narrow part of the duct but increases to a maximum in the region of the expansion.

In order to quantify the pressure drop over the diverging duct, integrate the pressure 
over the inlet and the outlet of the expansion zone, and divide by the respective 
cross-sectional areas. Taking the difference gives the pressure drop over the expansion 
zone:

 (2-3)

Model Library path:  

Chemical_Engineering_Module/Fluid_Flow/diverging_duct

Modeling Using the Graphical User Interface

1 Start COMSOL Multiphysics.

2 In the Model Navigator, select Axial symmetry (2D) from the Space dimension list.

∆p 5.95 mPa 2.09 mPa– 3.9 mPa= =
P R E S S U R E  R E C O V E R Y  I N  A  D I V E R G I N G  D U C T  |  13
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3 Choose the application mode  
Chemical Engineering Module>Momentum Transport>Laminar Flow> 
Incompressible Navier-Stokes.

4 Click OK. 

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Axes/Grid Settings. Specify axis and grid settings 
according to the following table:

2 Be sure to clear the Auto check box on the Grid tab, then click OK.

3 From the Options menu open the Constants dialog box. Define the following 
constants for later use; when done, click OK.

G E O M E T R Y  M O D E L I N G

1 Click the Line button on the Draw toolbar and draw a sequence of lines by using the 
left mouse button to click at points (0, 0), (0, 0.13), (0.01, 0.13), (0.01, 0.11), 
(0.005, 0.02), and (0.005, 0).

2 Click the right mouse button to close the curve and create a solid object CO1.

3 Click the Line button on the Draw toolbar and draw a line between (0, 0.11) and 
(0.01, 0.11).

4 Click the right mouse button to create an interior boundary B1.

5 Click the Line button again and draw a line between (0, 0.02) and (0.005, 0.02).

6 Click the right mouse button to create a second interior boundary B2.

This completes the geometry modeling stage. The geometry in the drawing area on 
your screen should look like that in the following figure.

AXIS GRID

r min -0.1 r spacing 0.005

r max 0.1

z min -0.005 z spacing 0.005

z max 0.135

NAME EXPRESSION DESCRIPTION

rho 998[kg/m^3] Density

eta 1.01e-3[Pa*s] Viscosity

v_max 2[cm/s] Maximum flow velocity at inlet
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P H Y S I C S  S E T T I N G S

Subdomain Settings
From the Physics menu, select Subdomain Settings. Select all three subdomains, then 
enter material properties according to the following table; when done, click OK.

Boundary Conditions
From the Physics menu, select Boundary Settings. Enter boundary conditions according 
to the following table; when done, click OK.

SETTINGS SUBDOMAINS 1–3

 ρ rho

 η eta

SETTINGS BOUNDARY 2 BOUNDARIES 1, 3, 5 BOUNDARY 7 BOUNDARIES 8–10

Boundary 
type

Inlet Symmetry 
boundary

Outlet Wall

Boundary 
condition

Velocity Axial symmetry Pressure, no 
viscous stress

No slip

u0 0
P R E S S U R E  R E C O V E R Y  I N  A  D I V E R G I N G  D U C T  |  15
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M E S H  G E N E R A T I O N

1 Click the Initialize Mesh button on the Main toolbar.

2 Click the Refine Mesh button on the Main toolbar twice.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate Figure 2-3, follow these steps:

1 From the Postprocessing menu, open the Plot Parameters dialog box. 

2 On the General page, select the Arrow check box in the Plot type area. Click OK.

3 In the Options>Axes/Grid Settings dialog box click the Axis tab and clear the Axis equal 
check box. Specify r min as -0.013 and r max as 0.02, then click OK.

Generate Figure 2-4 with the following instructions:

1 In the Plot Parameters dialog box, clear the Arrow check box on the General page.

2 Click the Surface tab. Select Incompressible Navier-Stokes (chns)>Pressure from the 
Predefined quantities list on the Surface Data page.

3 In the Unit edit field, type mPa to obtain the result in millipascals.

4 Still on the Surface page, click the Height Data page. Select the Height data check box 
and choose Incompressible Navier-Stokes (chns)>Pressure from the Predefined 

quantities list on this page.

5 Click OK, then click the Zoom Extents button on the Main toolbar.

To compute the pressure drop, as discussed on page 13, do as follows:

1 From the Postprocessing menu, select Boundary Integration.

2 Select the Compute surface integral (for axisymmetric modes) check box.

3 Select Boundary 4 (the inlet). In the Expression edit field type p/(pi*(5[mm])^2), 
that is the pressure divided by the cross-sectional area of the inlet. Integrating this 
expression over the inlet thus gives the average pressure at the inlet.

4 In the Unit of integral edit field, type mPa to obtain the result in millipascals.

v0 v_max*(1-s^2)

p0 0

SETTINGS BOUNDARY 2 BOUNDARIES 1, 3, 5 BOUNDARY 7 BOUNDARIES 8–10
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5 Click Apply. 

The average inlet pressure, roughly 5.95 mPa, appears in the message log below the 
drawing area.

6 Select Boundary 6 (the outlet), Modify the contents in the Expression edit field to 
p/(pi*(10[mm])^2), then click OK.

The average outlet pressure, approximately 2.09 mPa, appears in the message log.
P R E S S U R E  R E C O V E R Y  I N  A  D I V E R G I N G  D U C T  |  17
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F l ow i n  a  Fu e l  C e l l  S t a c k

Introduction

A key optimization parameter in a fuel cell is the design of the reactant and product 
channels and inlets and outlets. Good designs require that the electrodes are well fed 
with a reactant and that products are removed as quickly as possible. A further desire 
for a good fuel-cell design is that fuel cells are as compact as possible. This saves on 
material costs and allows them to fit into smaller spaces (such as in a car).

One important parameter for deciding good design is the fluid-flow characteristics of 
the feed stream to a fuel cell stack. This example deals with the gas channels on the air 
side of three bipolar plates. The channels in these plates are interconnected through 
cylindrical headers for the air inlet and outlet. This model solves the Navier-Stokes 
equations.

Model Definition

G E O M E T R Y

Figure 2-5 shows a 3D view of the model domain.

Figure 2-5: Diagram of the modeling geometry. The model shows the sixteen separate 
channels that are separated by the (not shown) electrodes and membrane in the 
z-dimension as well as the current collectors in the xy-plane.

inlet

outlet
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Figure 2-6 shows the shape of each channel.

Figure 2-6: A view of the model geometry (Figure 2-5) from above. Flow occurs through 
the gray-shaded areas.

D O M A I N  E Q U A T I O N S

The fluid flow is described by the Navier-Stokes equations

 (2-4)

where ρ denotes the density (kg/m3), u represents the velocity (m/s), η is the 
viscosity (Pa·s), and p is the pressure (Pa). The modeled fluid is a gas with a viscosity 
of 10−5 Pa·s and a density of 1 kg/m3.

B O U N D A R Y  C O N D I T I O N S

The model uses pressure boundary conditions for both the inlet and the outlet. The 
pressure boundary condition fixes the pressure and assumes that the viscous stress is 
zero at the boundary, that is

 (2-5)

and

.  (2-6)

The pressure, p0, is set to zero at the outlet and to the total pressure drop, dp, over 
the stack at the inlet. All other boundaries have the no slip condition

ρ
t∂

∂u ∇ η ∇u ∇u( )T
+( )⋅– ρ u ∇⋅( )u ∇p+ + 0=

∇ u⋅ 0=

n η ∇u ∇u( )T
+( )[ ]⋅ 0=

p p0=
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.  (2-7)

S O L V E R  A N D  M E S H

This model utilizes the the iterative FGMRES solver with a geometric multigrid 
preconditioner, which reduces memory requirements considerably. The solver uses 
several meshes: one base mesh and one or several coarser meshes. In this model one 
coarse level is sufficient. The solver is by default set to generate the coarser meshes 
automatically; however, in this model it is set manually. 

For the base mesh it is appropriate to resolve the channel width with two to three 
elements when using 2nd-order basis functions for the velocities. This is because the 
channel dimensions are small and the velocities are comparably small. The base mesh 
used in the model consists of approximately 31,400 elements yielding approximately 
220,000 degrees of freedom (DOF). The coarser mesh uses the same mesh but 
1st-order elements. It results in 49,000 DOF. Figure 2-7 shows a picture of the mesh.

Figure 2-7: Computational mesh.

u 0=
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Results

The pressure distribution (see Figure 2-8) is a key result. As almost all fuel cells run on 
gas streams, so the local pressure can affect their volumetric properties.

Figure 2-8: Pressure distribution in the feed channels of the fuel cell stack.
F L O W  I N  A  F U E L  C E L L  S T A C K  |  21
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A more significant result is the velocity magnitude throughout the feed channels. 
Figure 2-9 shows the flow regime for all layers. For each layer, it is apparent that the 
velocity is greatest in the innermost channel, which has the shortest length.

Figure 2-9: Velocity magnitude in the feed channels of the fuel cell stack.
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Figure 2-10 shows a close-up of the feed channels. You can see that the velocity is 
greater in the upper layers than in the lower ones.

Figure 2-10: A close-up of the velocity magnitude.

A more uniform distribution in the channels is desired. Modifying the design by 
placing the outlet header toward the bottom of the stack would be preferable.

Model Library path:  

Chemical_Engineering_Module/Fluid_Flow/fuel_cell_stack

Modeling Using the Graphical User Interface

1 Start COMSOL Multiphysics.

2 In the Model Navigator set the Space dimension to 3D.

3 In the list of application modes select Chemical Engineering Module> 
Momentum Transport>Laminar Flow>Incompressible Navier-Stokes> 
Steady-state analysis.
F L O W  I N  A  F U E L  C E L L  S T A C K  |  23
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4 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 Open the Constants dialog from the Options menu.

2 Enter the constants in the following table; when done, click OK.

G E O M E T R Y  M O D E L I N G

Start to draw a cross section of the flow channels in a 2D cross section.

1 Select Work-Plane Settings from the Draw menu.

2 Leave the default values in the dialog box and click OK.

In the 2D work plane specify suitable axis and grid settings.

3 Select Axes/Grid Settings from the Options menu.

4 On the Axis page set x-y limits according to:

5 Go to the Grid page and clear the Auto check box.

6 Specify x-y grid according to:

7 Click OK.

8 Click the Line button on the Draw toolbar.

NAME EXPRESSION

rho 1

eta 1e-5

p0 5

PROPERTY EXPRESSION

x min -0.005

x max 0.035

y min -0.005

y max 0.028

PROPERTY EXPRESSION

x spacing 1e-3

Extra x linspace(2.5e-3,4.5e-3,3) linspace(26.5e-3,28.5e-3,3)

y spacing 1e-3

Extra y
 2 :  F L U I D  F L O W — TU T O R I A L S  A N D  B E N C H M A R K S



9 Start by clicking at position (0, 0.022). Continue with points (0, 0), (0.015, 0), 
(0.015, 0.015), (0.016, 0.015), (0.016, 0), (0.031, 0), and (0.031, 0.022).

The outer shape of the channels is now finished.

10 Continue to finish the first channel by clicking the points (0.03, 0.022),  
(0.03, 0.001), (0.017, 0.001), (0.017, 0.016), (0.014, 0.016), (0.014, 0.001), 
(0.001, 0.001), and (0.001, 0.022).
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11 Continue in the same fashion to create the rest of the channel structure as shown in 
the next figure.

12 Click the points (0.0045, 0.026) and (0.0025, 0.026).

13 Close the geometry by right-clicking anywhere in the geometry.

Draw the top of the right portion of the channel system.

14 Click the Line tool on the Draw toolbar. Click the positions (0.024, 0.022), 
(0.0265, 0.026), (0.0285, 0.026), and (0.031, 0.022). Close the geometry by 
right-clicking anywhere.

15 Continue to draw a circle with radius 0.001 centered in the position 
(0.0035, 0.026) using the Ellipse/Circle(Centered) tool from the Draw toolbar.

16 Open the Create Composite Objects window from the Draw menu.
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17 Enter the formula CO1+CO2, clear the Keep interior boundaries check box, and click 
OK.

18 Select Extrude from the Draw menu.

19 Select the channel geometry (CO3) from the Objects to extrude list.

20 Set the Distance to 1e-3 and click OK.

21 Click the Array button on the Draw toolbar.

22 Set the z displacement to 2e-3 and the Array size: z to 3. Click OK.

23 Select all three object and click the Union button on the Draw toolbar.

24 Switch back to Geom2.

25 Open the Extrude window from the Draw menu.

26 Extrude the circle E1 by a distance of 7e-3. Click OK.

27 Back in the 3D geometry, click the Block button on the Draw toolbar. Specify the 
block according to the following table:

28 Click the Create Composite Objects button on the Draw toolbar.

29 Type the Set formula EXT1-BLK1 and click OK.

30 Click the Array button on the Draw toolbar. Set the x displacement to 24e-3 and the 
Array size: x to 2. Click OK.

31 Select all the geometry objects by pressing Ctrl+A. Make a union by clicking the 
Union button on the Draw toolbar.

32 Click the Delete Interior Boundaries button on the Draw toolbar.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 Open the Subdomain Settings dialog box from the Physics menu.

PROPERTY VALUE

X length 3e-3

Y length 2e-3

Z length 5e-3

x base point 2e-3

y base point 24e-3

z base point 0
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2 Select Subdomain 1, type rho in the Density edit field, and type eta in the Viscosity 
edit field.

3 Click OK.

Boundary Conditions
1 Open the Boundary Settings dialog box from the Physics menu.

2 Select the inlet boundary (Boundary 36) from the Domain selection list.

3 Select the type Inlet, then select Pressure, no viscous stress from the Boundary 

condition list. Type p0 in the Pressure edit field.

4 Select the outlet boundary (Boundary 194), and select Outlet from the Boundary 

type list. The default condition Pressure, no viscous stress is correct.

5 Click OK.

M E S H  G E N E R A T I O N

1 Open the Free Mesh Parameters dialog box from the Mesh menu.

2 On the Global page, select Normal from the Predefined mesh sizes list.

3 Click the Custom mesh size button and set the Resolution of narrow regions to 1.5.

4 Click Remesh and then click OK.

The model is solved with a geometric multigrid preconditioner. Instead of using the 
built-in automatic generation of the coarser mesh, this model uses a manual 
definition of the necessary mesh cases. In the next step you generate the second 
mesh case used by the solver:

5 Select Mesh>Mesh Cases.

6 Click the New button and select the Use same mesh as mesh case check box and select 
0 from the corresponding list. 

7 Click OK.

To complete the settings for the new mesh case, change the element type to use 
1st-order elements for all velocities and the pressure:

8 Select the menu item Physics>Subdomain Settings, and select Subdomain 1.

9 On the Element page select Lagrange-Linear from the Predefined elements list.

10 Click OK.

You have now created two mesh cases: Case 0 with the default P2–P1 element, and 
Case 1 with a lower element order using the same mesh as Case 0.
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C O M P U T I N G  T H E  S O L U T I O N

Set up the geometric multigrid preconditioner with the appropriate settings for this 
Navier-Stokes problem using the manually generated mesh hierarchy.

1 Select Solve>Solver Parameters.

2 Click the Settings button.

3 In the tree to the left in the dialog box, select Preconditioner.

4 Select Manual from the Hierarchy generation method list.

5 Click OK to close the Linear System Solver Settings dialog and click OK once more to 
close the Solver Parameters dialog box.

6 Click the Solve button on the Main toolbar. Note that computing the solution takes 
at least 30 minutes, depending on the performance of your computer.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To create Figure 2-8, perform the following steps.

1 Open the Plot Parameters dialog box from the Postprocessing menu.

2 On the General page clear the Slice check box and select the Boundary check box.

3 On the Boundary page select Incompressible Navier-Stokes (chns)>Pressure as 
Boundary data. Click Apply.

To create Figure 2-9, follow these steps:

1 On the General page clear the Boundary check box and select Slice as the plot type.

2 Clear the Element refinement auto check box and enter 4 in the corresponding edit 
field.

3 On the Slice page set Slice data to Velocity field. Set x-slice levels to 0, leave y-levels 
at 0.

4 Select the Vector with coordinates radio button for the z-levels and type 0.5e-3 
2.5e-3 4.5e-3 in the corresponding edit field.

5 Click the Range button, clear the Auto check box and set Max to 0.5. Click OK to 
close the Color Range dialog box. Click OK.

To create the view in Figure 2-9, rotate the geometry and zoom in a bit.
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Non -New t on i a n  F l ow

Introduction

This model shows the influence of shear rate dependent viscosity on the flow of a linear 
polystyrene solution. For this type of flow, you can use the Carreau viscosity model 
described by Equation 5-30 on page 134 of the Chemical Engineering Module User’s 
Guide. Due to rotational symmetry, it is possible to reduce the model dimensions from 
3D to axisymmetric 2D (see Figure 2-11).

Model Definition

For non-Newtonian flow, η denotes the viscosity (kg/(m·s)), u the velocity (m/s), ρ 
the density of the fluid (kg/m3) and p the pressure (Pa). The equations to solve are 
the momentum and continuity equations.

 (2-8)

In the Carreau model, the viscosity depends on the shear rate, , which for an 
axisymmetric model in cylindrical coordinates is defined according to Equation 2-9:

 (2-9)

The viscosity is given by Equation 2-10:

 (2-10)

where  is the infinite shear rate viscosity, η0 is the zero shear rate viscosity, λ is a 
parameter with units of time, and n is a dimensionless parameter. A solution of linear 
polystyrene in 1-chloronaphthalene has the properties listed in Table 2-1 (Ref. 1).

TABLE 2-1:  PROPERTIES OF A SOLUTION OF LINEAR POLYSTYRENE IN 1-CHLORONAPHTALENE.

PARAMETER VALUE

 0

 η0 166 Pa·s

 λ 1.73·10-2 s

ρ
t∂

∂u ∇ η ∇u ∇u( )T
+( )⋅– ρu ∇⋅ u ∇p+ + 0=

∇ u⋅ 0=

γ·

γ· 1
2
--- 2ur( )2 2 uz vr+( )2 2vz( )2 4 u

r
---⎝ ⎠
⎛ ⎞ 2

+ + +⎝ ⎠
⎛ ⎞=

η η∞ η0 η∞–( ) 1 λγ·( )2+[ ]
n 1–( )

2
-----------------

+=

η∞

η∞
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The model domain is depicted in Figure 2-11.

Figure 2-11: Model domain. The geometry can be simplified assuming axisymmetry.

The boundary conditions at the inlet and the outlet are set to fixed pressures and 
vanishing viscous stresses:

 (2-11)

and

 (2-12)

To study the effect on viscosity at different inlet pressures, the model makes use of the 
parametric solver to vary pin from 10 kPa to 210 kPa. The axis of rotation requires the 
symmetry condition:

 (2-13)

while all other boundaries impose the no-slip condition:

 (2-14)

 n 0.538

 ρ 450 kg/m3

TABLE 2-1:  PROPERTIES OF A SOLUTION OF LINEAR POLYSTYRENE IN 1-CHLORONAPHTALENE.

PARAMETER VALUE

No slip Inle

No slip

Symmetry

Outlet

p pin=

p 0=

n η ∇u ∇u( )T
+( )[ ]⋅ 0=

u n⋅ 0=

u 0=
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Results

Figure 2-12 shows that the velocity distribution is more pronounced at the inlet 
compared to the outlet. This is because the cross-section is greater at the outlet. The 
figure also shows that the region of greatest velocity is in the contraction, which means 
that the shear rate will be largest there.

Figure 2-12: Velocity field throughout the modeling domain. The distribution is more 
pronounced at the inlet as opposed to the inlet.
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Because the fluid is shear-thinning, the viscosity depends on the shear rate and is shown 
in Figure 2-13. It reaches its lowest value close to the wall in the contraction between 
the piston and the wall.

Figure 2-13: Viscosity distribution in the model domain. The lowest viscosity occurs at the 
wall in the contraction region.

Showing the result of a parametric study of the inlet pressure, Figure 2-14 contains a 
cross-sectional plot of the viscosity across the contraction (indicated by a red line in 
Figure 2-13). Sweeping through a range of inlet pressures imposes greater velocities 
on the non-Newtonian fluid. As the velocity increases, the shear rate also increases and 
the viscosity decreases. An optimal condition is to have as flat a viscosity profile as 
possible. This is hindered by also wanting to put through as high a flow rate as possible.
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Figure 2-14: Parametric study of the process, sweeping the inlet pressure from 10 kPa to 
210 kPa, while investigating a cross-sectional viscosity plot. The greater the inlet pressure 
(and pressure differential) the less the viscosity and more varied its distribution through 
the cross section.

Reference

1. R.B. Bird, W.E. Stewart, and E.N. Lightfoot, Transport Phenomena, John Wiley 
& Sons, 1960.

Model Library path:  
Chemical_Engineering_Module/Fluid_Flow/non_newtonian_flow

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics.

Increasing inlet pressure
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2 In the Model Navigator, select Axial symmetry (2D) from the Space dimension list.

3 From the list of application modes, select 
Chemical Engineering Module>Momentum Transport>Laminar Flow> 
Non-Newtonian Flow.

4 Click OK.

G E O M E T R Y  M O D E L I N G

The first step in the modeling process is to draw the geometry which is explained 
below.

1 Press the Shift key and click the Rectangle/Square button.

2 Enter the rectangle dimensions according to the values below in the corresponding 
edit fields.

3 Click OK.

4 Repeat the procedure for another rectangle with the following dimensions.

5 Click OK.

6 Click the Zoom Extents button in the Main toolbar.

7 Open Axes/Grid Settings in the Options menu.

8 Click the Grid tab.

9 Clear the Auto check box and set r spacing and z spacing to 3e-3.

10 Click the 2nd Degree Bézier Curve tool and click the coordinate sequence (0, 3e-3), 
(12e-3,3e-3), (12e-3, −9e-3), (6e-3, −9e-3), and (6e-3, −15e-3). 

11 Select the Line tool and click the coordinate (0, −15e-3).

OBJECT DIMENSIONS EXPRESSION

Width 9e-3

Height 21e-3

r-position 0

z-position 0

OBJECT DIMENSIONS EXPRESSION

Width 12e-3

Height 27e-3

r-position 6e-3

z-position -21e-3
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12 Create a solid object by clicking the right mouse button once.

13 Select the 2nd Degree Bézier Curve tool and click the coordinate sequence 
(9e-3, 6e-3), (9e-3, 3e-3), (12e-3, 3e-3), (18e-3, 3e-3), and (18e-3, −3e-3). 

14 Click the Draw Line tool and click the coordinate (18e-3, 6e-3). 

15 Click the right mouse button to create a solid object.

16 Click the Create Composite Object button. 

17 Type R1+R2-CO1-CO2 in the Set formula edit field.

18 Clear the Keep interior boundaries check box, then click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Physics menu, select Subdomain Settings.

2 On the Physics tab select Carreau model from the Viscosity model list. 

3 Type 450 in the Density edit field.

4 Click the Carreau tab. Select Subdomain 1, then specify settings according to the 
table below.

5 Click OK.

Boundary Conditions
1 From the Physics menu, select Boundary Settings.

2 Enter the boundary conditions according to the following table:

3 Click OK.

PROPERTY VALUE

 0

  η0 166

  λ 1.73e-2

  n 0.538

SETTINGS BOUNDARY 1 BOUNDARY 2 BOUNDARY 4 BOUNDARIES 3, 5–12

Boundary 
type

Symmetry 
boundary

Inlet Outlet Wall

Boundary 
condition

Axial 
Symmetry

Pressure, no 
viscous stress

Pressure, no 
viscous stress

No slip

p0 p_in 0

η∞
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M E S H  G E N E R A T I O N

1 Select the Free Mesh Parameters dialog box in the Mesh menu. 

2 Click the Point tab.

3 From the Point selection list, select Points 2, 3, 8, 9, and 11.

4 Set the Maximum element size to 1e-4.

5 Click the Boundary tab.

6 Select Boundary 2, then set the Maximum element size to 5e-4.

7 Select Boundaries 9 and 11, then set the Maximum element size to 2e-4.

8 Click OK.

9 Click the Initialize Mesh button on the Main toolbar.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 Select Parametric from the Solver list.

3 Type p_in in the Parameter name edit field and 10000:40000:210000 in the 
Parameter values edit field.

4 Click OK.

5 Click the Solve button in the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot, displayed in Figure 2-12 on page 32, shows the magnitude of the 
velocity field. 

To visualize the variations of the viscosity in a surface plot, as in Figure 2-13, follow 
these steps:

1 Click the Plot Parameters button on the Main toolbar.

2 Click the Surface tab.

3 From the Predefined quantities list on the Surface Data page, select Non-Newtonian 

Flow (chns)>Dynamic viscosity.

4 Click OK.

You can also visualize the value of the viscosity along a cross-section, perpendicular to 
the main flow, at the position of the contraction:

1 From the Options menu, select Axes/Grid Settings.

2 Click the Grid tab.
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3 Select the Auto check box and click OK.

4 From the Postprocessing menu, open the Cross-Section Plot Parameters dialog box.

5 On the General page, select all parameter values in the Solutions to use list.

6 Click the Line/Extrusion tab.

7 From the Predefined quantities list, select Non-Newtonian Flow (chns)>Dynamic 

viscosity.

8 Enter the following cross-section line data:

9 Click OK.

The resulting plot reproduces that in Figure 2-14. It shows the viscosity along the 
cross section indicated by a straight red line in Figure 2-12 at different flow rates for 
the polymer solution.

r0 7.55e-3

r1 9.97e-3

z0 0.32e-3

z1 3.79e-3
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F l ow Be twe en Two Pa r a l l e l  P l a t e s

Introduction

This example models the developing flow between two parallel plates. The purpose is 
to study the inlet effects in laminar flow at moderate Reynolds numbers, in this case 
around 40.

Although the problem might seem academic in nature, the conditions and parameters 
described in the model are fairly common in catalytic reactors, heat exchangers, micro 
reactors, and other process units.

The domain is visualized in Figure 2-15. Neglecting end effects in the z direction, you 
can assume symmetry throughout this dimension and reduce the three-dimensional 
problem to two dimensions. This reduction means that you assume that the flow 
velocity’s z-component is zero.

You model the flow just below and between two parallel plates. Fluid enters at the 
inlet, which is the lower horizontal boundary, while slip/symmetry conditions describe 
the lower vertical boundaries just below the position of the plates. The vertical plates, 
positioned 1 cm above the inlet, impose a no-slip condition on the vertical boundaries. 
Specify a pressure condition at the outlet.

Figure 2-15: The model geometry. Assuming there is no flow in the z direction, the problem 
reduces to a 2D model.
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Model Definition

This example uses the Navier-Stokes equations and the continuity equation with 
constant viscosity and density:

 (2-15)

Here η denotes the dynamic viscosity (kg/(m·s)), u the velocity (m/s), ρ the fluid 
density (kg/m3), and p the pressure (Pa).

The boundary conditions according to Figure 2-15 are:

 (2-16)

The pressure variable in this example is relative to the outlet pressure, which is set to 
zero. The model’s input data are tabulated below.

NAME EXPRESSION DESCRIPTION

 ρ 103 kg/m3 Density

 η 10-2 Pa·s Viscosity

 v0 2 cm/s Inlet velocity

ρ
t∂

∂u ∇ η ∇u ∇u( )T
+( )⋅– ρu ∇⋅ u ∇p+ + 0=

∇ u⋅ 0=

u n⋅ v0= Inlet

u n⋅ 0= Symmetry

t pI– η ∇u ∇u( )T+( )+( )n⋅ 0= Symmetry
u 0= No slip
p 0= Outlet
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Results

Figure 2-16 displays the modulus of the velocity vector. The development of the 
viscous layer as the fluid encounters the solid walls at the lateral boundaries appears 
clearly.

Figure 2-16: Flow-velocity magnitude. It is apparent that the flow develops along the 
length of the modeling domain, once it has encountered the no-slip condition at the 
parallel plate walls.

The development from a uniform velocity profile to the fully developed Poiseuille flow 
can be depicted by plotting the flow along a number of horizontal cross-sections along 
the length of the channel, as in Figure 2-17. Because the flow is incompressible, the 
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areas below the curves are the equal. The presence of nearly overlapping profiles shows 
that the flow is almost fully developed at the outlet.

Figure 2-17: Velocity profiles at equidistant positions along the length of the modeling 
domain. The flat velocity profile at the inlet gradually develops into a Poiseuille or 
parabolic profile, which is almost fully developed at the outlet.

The section below describes in detail how to reproduce this model in COMSOL 
Multiphysics.

Model Library path:  
Chemical_Engineering_Module/Fluid_Flow/parallel_plates

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics.

2 In the Model Navigator, click the New page
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3 Select Chemical Engineering Module>Momentum Transport>Laminar Flow> 
Incompressible Navier-Stokes.

4 Click OK.

O P T I O N S  A N D  S E T T I N G S

The first step of the modeling process is to create a temporary data base for the input 
data. Define the following constants in the Constants dialog box in the Option menu.

G E O M E T R Y  M O D E L I N G

1 Simultaneously press the Shift key and click the Rectangle/Square button.

2 Type the values below in the respective edit fields for the rectangle dimensions.

3 Click OK.

4 Click the Zoom Extents button on the Main toolbar.

5 Use the Draw Point button to place two points by clicking at (−0.01, 0.01) and 
(0.01, 0.01).

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Physics menu, select Subdomain Settings.

2 Select Subdomain 1.

NAME EXPRESSION DESCRIPTION

rho 1e3[kg/m^3] Fluid density

eta 0.01[Pa*s] Viscosity

v0 2[cm/s] Inlet velocity

OBJECT DIMENSIONS EXPRESSION

Width 0.02

Height 0.05

Base Corner

x -0.01

y 0
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3 Define the physical properties of the fluid, in this case the viscosity and the density, 
according to the table below.

4 Click OK.

Boundary Conditions
1 From the Physics menu, select Boundary Settings.

2 Enter boundary conditions according to the following table; when done, click OK.

M E S H  G E N E R A T I O N

In this case you want to customize some settings for the initial mesh.

1 From the Mesh menu, select Free Mesh Parameters.

2 On the Boundary page, select Boundaries 3 and 6 from the Boundary Selection list.

3 In the Maximum element size edit field, type 1e-3. This creates elements with a 
maximum edge length of 10−3 m for Edges 3 and 6.

4 Click the Remesh button.

5 When the mesher has finished, click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot, displayed in Figure 2-16 on page 41, is a surface plot of the velocity 
magnitude.

Execute the following instructions to generate the cross-section plots of the velocity 
along horizontal lines at different positions along the channel displayed in Figure 2-17.

PROPERTY VALUE

 ρ rho

 η eta

SETTINGS BOUNDARY 2 BOUNDARIES 1, 5 BOUNDARY 4 BOUNDARIES 3, 6

Type Inlet Symmetry boundary Outlet Wall

Condition Velocity - Pressure No slip

u0 0

v0 v0

p0 0
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1 From the Postprocessing menu, select Cross-Section Plot Parameters.

2 Click the Line/Extrusion tab.

3 In the y-axis data area, keep the default choice Velocity field in the 
Predefined quantities list. Type cm/s in the Unit edit field.

4 In the x-axis data area, click the lower option button, then click the Expression 
button to open the X-Axis Data dialog box.

5 From the Predefined quantities list, select Geometry and Mesh>x-coordinate. From the 
Unit list, select cm. Click OK to close the X-Axis Data dialog box.

6 Specify the Cross-section line data according to the table below.

7 Select the Multiple parallel lines check box.

8 Click the Vector with distances option button then type linspace(0.01,0.05,9) 
in the associated edit field. This gives a vector with nine equidistant elements 
between 0.01 to 0.05, which specify the y-coordinates for the lines.

9 Click OK.

The resulting plot shows how the velocity profile develops along the main direction of 
the flow. At the outlet, the flow is almost a fully developed parabolic velocity profile.

PROPERTY VALUE

x0 -0.01

x1 0.01

y0 0

y1 0
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V a r i a t i o n s  i n  Den s i t y  i n  Po r ou s  
Med i a  F l ow

Introduction

This example studies the steady flow of an ideal gas in a porous medium, taking 
variations in gas density into account. Darcy’s law describes the velocity in the porous 
structure and accounts for the conservation of mass by the ideal gas law, as expressed 
in Equation 5-57 and Equation 5-58 on page 153 of the Chemical Engineering 
Module User’s Guide.

Figure 2-18: Depiction of the model geometry. Inert gas enters a porous structure from the 
bottom-left and leaves at the top-right.

The system you study is a packed bed reactor of the type used, for example, in 
small-scale reforming or catalytic combustion processes. The model investigates 
pressure loss, flow field, and reactor properties by pumping an inert gas through it.

Model Definition

Darcy’s law in combination with the continuity equation and the ideal gas law gives 
the following equation:

 (2-17)

Inlet

Outlet

Packed bed

∇ kM
ηRT
------------ p∇p–⎝ ⎠

⎛ ⎞⋅ 0=
 2 :  F L U I D  F L O W — TU T O R I A L S  A N D  B E N C H M A R K S



Here k denotes the permeability of the porous medium (m2), M the molar mass (kg/ 
mol), η the fluid viscosity (Pa·s), R the gas constant (J/(mol·K)), T the temperature 
(K), and p the pressure (Pa).

As for boundary conditions, the pressure is 1.5 atm at the inlet and equal to the 
atmospheric pressure at the outlet, p = p0. All other boundaries are impervious, 
corresponding to the condition

The input data for the model is listed in the following table.

PROPERTY VALUE

 k 1·10-13 m2

 M 32 g/mol

 η 3.0·10-5 Pa·s

 R 8.314 J/(mol·K)

 T 355 K

 patm 1.013·105 Pa

k
η
---∇p– n⋅ 0=
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Results

Figure 2-19 below shows the pressure on the outer surface of the packed bed. Pressure 
losses are greatest close to the inlet and the outlet where the flow is large.

Figure 2-19: Pressure on the walls of the structure. The local pressure gradient is greatest 
in the inlet and outlet regions.
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Because the gas density is proportional to pressure, the gas expands as it flows from the 
inlet to the outlet. This is clearly visible in Figure 2-20, where the flow tube’s radius 
and color depend on the magnitude of the velocity vector.

Figure 2-20: Depiction of the velocity field’s streamlines at the inlet (left) and the outlet 
(right). The tangent to the streamline gives the direction of the vector, while its color scale 
and thickness indicate the velocity magnitude.

Modeling in COMSOL Multiphysics

Because the density appears inside the derivatives in the continuity equation, you must 
use a weak implementation. Chapter 2, “Application Mode Implementations,” in the 
Chemical Engineering Module User’s Guide summarizes the relevant equations. You 
can also inspect them on the Weak tab in the Subdomain Settings - Equation System 
dialog box that you open by selecting Physics>Equation System>Subdomain Settings.

Model Library path:  

Chemical_Engineering_Module/Fluid_Flow/darcy_3d

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics.

2 In the Model Navigator, select 3D from the Space dimension list.

3 From the list of application modes, choose 
Chemical Engineering Module>Momentum Transport>Porous Media Flow> 
Darcy’s law>Steady-state analysis.
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4 Click OK.

O P T I O N S  A N D  S E T T I N G S

Start by defining the constants and expressions below.

1 From the Options menu, choose Constants.

2 Define the following constants (the descriptions are optional); when done, click OK.

3 Choose Options>Expressions>Scalar Expressions.

4 Define the following expression:

5 Click OK.

G E O M E T R Y  M O D E L I N G

1 From the Draw menu, select Work-Plane Settings. 

2 Click OK to accept the default settings.

3 Press the Shift key and click the Rectangle/Square button on the Draw toolbar.

4 Set the Width of the rectangle to 0.02, the Height to 0.0025, and the lower-left 
corner position to (0, 0.0025). Click OK to create the rectangle R1.

5 Click the Zoom Extents button on the Main toolbar.

6 From the Options menu, select Axes/Grid Settings. On the Grid page, clear the Auto 
check box and type 0.0025 in the x spacing and y spacing edit fields. Click OK.

7 Click the 2nd Degree Bézier Curve button on the Draw toolbar.

8 Click, in order, the points (0, 0.0025), (0, 0), and (0.0025, 0).

9 Click the Line button, then click the point (0.0175, 0). 

10 Click the 2nd Degree Bézier Curve button.

NAME EXPRESSION DESCRIPTION

eta 3e-5[Pa*s] Viscosity

kappa 1e-13[m^2] Permeability

p_o 1.013e5[Pa] Outlet pressure

p_i 1.5*p_o Inlet pressure

M 32[g/mol] Molar mass

R 8.314[J/(mol*K)] Gas constant

T 355[K] Temperature

NAME EXPRESSION DESCRIPTION

rho p*M/(R*T) Density
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11 Click first the point (0.02, 0) and then the point (0.02, 0.0025).

12 Click the right mouse button to create a solid object, CO1.

13 Press Ctrl+A to select both solid objects, R1 and CO1, then click the Union button 
on the Draw toolbar to create the composite object CO2.

14 Click the Delete Interior Boundaries button.

The geometry in the drawing area on your screen should now look like that in the 
picture below.

15 From the Draw menu, select Extrude. In the Distance edit field, type 0.05. Click OK.

16 From the Draw menu, select Work-Plane Settings. Click the y-z button, then click OK.

17 Click the Zoom Extents button on the Main toolbar.
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18 Click the 2nd Degree Bézier Curve button. Click, in order, the points (0, 0.0025), 
(0, 0), and (0.0025, 0).

19 Click the Line button. Click, in order, the points (0.005, 0), (0.005, 0.05), and 
(0.0025, 0.05).

20 Click the 2nd Degree Bézier Curve button. Click, in order, the points (0, 0.05) and 
(0, 0.0475).

21 Click the right mouse button to create a solid object, CO2.

22 From the Draw menu, select Extrude. In the Distance edit field, type 0.02. Click OK.

23 Click the Zoom Extents button on the Main toolbar.

24 Press Ctrl+A to select the two extruded objects, then click the Intersection button 
on the Draw toolbar.
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25 Click the Geom 2 tab to return to the work plane.

26 Draw a half circle by first clicking the 2nd Degree Bézier Curve button on the Draw 
toolbar, and then clicking the points (0.005, 0.0075), (0.0025, 0.0075), 
(0.0025, 0.01), (0.0025, 0.0125), and (0.005, 0.0125).

27 Create a solid object by clicking the right mouse button.

28 With the solid object selected, select Embed from the Draw menu.

29 Click OK.

30 Press Ctrl+C to copy the object EMB1.

31 Press Ctrl+V. In the Paste dialog box enter an x displacement of 0.02 and a 
z displacement of 0.03.

32 Click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Physics menu, select Subdomain Settings.
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2 Select Subdomain 1, then specify density, permeability, and viscosity according to 
the table below.

The expression for the density includes the dependent variable p, which makes the 
problem nonlinear. The initial value for the pressure is zero by default, which results 
in a zero density in the continuity equation. To obtain convergence, you must give 
a physical guess for the pressure. In this case, use the outlet pressure,  po (1 atm).

3 Click the Init tab. In the p(t0) edit field, type p_o.

4 Click OK.

Boundary Conditions
1 From the Physics menu, select Boundary Settings.

2 Enter boundary conditions according to the following table:

3 Click OK.

M E S H  G E N E R A T I O N

Click the Initialize Mesh button on the Main toolbar.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

First plot the absolute value of the velocity vector to study the effects of expansion.

1 Click the Plot Parameters button on the Main toolbar.

2 Clear the Slice check box in the Plot type area.

3 Click the Streamline tab and select the Streamline plot check box. 

4 Select Darcy’s Law (chdl)>Velocity field from the Predefined quantities list in the 
Streamline data area.

PROPERTY VALUE

 ρ rho

 κ kappa

 η eta

SETTINGS BOUNDARY 14 BOUNDARY 6 ALL OTHERS

Type Pressure Pressure Insulation/Symmetry

p0 p_o p_i
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5 Click the Specify start point coordinates button and type the coordinates 1e-6, 
4.9e-3, and 1e-2 in the x, y, and z edit fields, respectively.

6 To set the streamline color, click the Line Color tab, then click the Use expression 
button, and click the Color Expression button. Select Darcy’s Law (chdl)>Velocity field 
from the Predefined quantities list, then click OK.

7 From the Line type list, select Tube.

8 Click the Tube Radius button. In the Tube Radius Parameters dialog box, select the 
Radius data check box. After verifying that the selection in the Predefined quantities 
list is Darcy’s Law (chdl)>Velocity field, click OK to close the dialog box.

9 Back in the Plot Parameters dialog box, click OK to generate the plot.

The resulting plot shows a single flow line from the inlet to the outlet. You can use the 
Zoom Window tool to magnify the plot close to the inlet or the outlet.

Next, reproduce the pressure plot shown in Figure 2-19.

1 Click the Plot parameters button on the Main toolbar.

2 Click the General tab.

3 Clear the Geometry edges and Streamline check boxes. Select the Boundary check 
box.
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4 Click the Boundary tab. From the Predefined quantities list, select 
Darcy’s Law>Pressure.

5 Click OK.

6 Click the Scene Light button on the Camera toolbar.
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Coup l e d  F r e e  and Po r ou s  Med i a  F l ow

Introduction

This is a model of the coupling between flow of a gas in an open channel and in a 
porous catalyst attached to one of the channel walls. The flow is described by the 
Navier-Stokes equation in the free region and the Brinkman equations in the porous 
region.

Figure 2-21: Depiction of the modeling geometry and domain. The 3D geometry can be 
reduced to a 2D representation assuming that changes through the thickness are negligible.

The coupling of free media flow with porous media flow is common in the field of 
chemical engineering. This problem type arises in filtration and separation and in 
chemical reaction engineering, for example in the modeling of porous catalysts in 
monolithic reactors. The most common way to deal with coupled free and porous 
media flow in a system is to incorporate Darcy’s law. Yet, this does not account for 
viscous effects, arising from the free media flow, that may still have an effect in the 
region close to the free-porous structure interface. Depending on pore size and 
distribution as well as the fluid’s properties, it can be an over-simplification to employ 
Darcy’s law. The Brinkman equations account for momentum transport through 
viscous effects and through pressure gradients in porous media and can be considered 
an extension of Darcy’s Law.

The system studied in this example is that of a 2D cross section of a rectangular reactor 
with a catalyst layer attached to one of its walls. Flow enters the reactor with a uniform 
velocity profile and develops throughout the length of the channel.
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Model Definition

The modeled domain and notations for the boundary conditions are shown in the 
figure below.

Figure 2-22: Modeled domain and boundary notations. Flow enters at the bottom and 
leaves at the top. The region of porous structure is not as long as the free channel.

Flow in the free channel is described by the Navier-Stokes equations:

 (2-18)

where η denotes the dynamic viscosity (Pa·s), u refers to the velocity in the open 
channel (m/s), ρ is the fluid’s density (kg/m3), and p is the pressure (Pa). In the 
porous domain, the Brinkman equations describe the flow:

 (2-19)

Here k denotes the permeability of the porous medium (m2), and εp is the porosity 
(dimensionless). As can be seen from Equation 2-18 and Equation 2-19, the 
momentum transport equations are closely related. The term on the right-hand side of 
the Navier-Stokes formulation corresponds to momentum transported by convection 

Outlet

No slipNo slip

Navier-Stokes
Brinkman boundary

Inlet

ρ∂u
∂t
------- ∇+ η– ∇u ∇u( )T

+( ) pI+[ ]⋅ ρ u ∇⋅( )u–=

∇ u⋅ 0=

ρ
εp
-----∂u

∂t
------- ∇+

η
εp
-----– ∇u ∇u( )T

+( ) pI+⋅ η
k
---u–=

∇ u⋅ 0=
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in free flow. In the Brinkman formulation, this term is replaced by a contribution 
associated with the drag force experienced by the fluid flowing through a porous 
medium. In COMSOL Multiphysics, free flow and porous media flow are effortlessly 
combined.

The boundary conditions are

 (2-20)

where the pressure level at the outlet is used as a reference value.

The following table lists the input data for the model.

PROPERTY VALUE DESCRIPTION

 η 10-5 kg/(m·s) Dynamic viscosity

 ρ 1 kg/m3 Density

 k 10-8 m2 Permeability

 v0 1 cm/s Inlet velocity

u n⋅ u0=

u 0=

p 0= η ∇u ∇u( )T+( )n 0=,

inlet   
no slip
outlet 
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Results

The velocity field in the open channel and porous structure is shown in Figure 2-23. 
It shows that there are slight disturbances in the velocity at the porous wall, which 
suggests momentum transport by viscous effects.

Figure 2-23: Velocity field in both the free channel and the porous media.

The velocity profile along a horizontal cross section in the middle of the channel is 
depicted in Figure 2-24. The plot confirms the existence of velocity gradients in the 
porous structure in that the velocity is continuous across the interface between the free 
channel and the porous structure. Further postprocessing would show that the shear 
rate perpendicular to the flow is also continuous. This implies that there is significant 
viscous momentum transfer across the interface and into the porous media, a transport 
that would not be accounted for by Darcy’s law. If you would couple Darcy’s law to 
the Navier-Stokes equations in this example, the profile would look substantially 
different. The velocity in the free channel would fall to a much smaller value in the free 
channel. Furthermore, a constant velocity equal to the flat part of the curve in 
Figure 2-24 would describe all transport in the porous media. 

Assuming that Darcy’s law describes the porous media flow adequately would be 
erroneous in this situation. This could be impractical if the velocity vector calculated 
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here is coupled to a convective term in a material balance for a reacting species. The 
regions of the porous wall close to the channel interface would be subjected to a larger 
supply of reactants than otherwise assumed if Darcy’s law would have been used.

Figure 2-24: Cross section of the velocity field (modulus of velocity) in the middle of the 
modeling domain. The gradual reduction of viscous-dominated momentum transport to 
pressure-driven is evident in the region of the porous media close to the interface.

Model Library path:  

Chemical_Engineering_Module/Fluid_Flow/porous_free

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics.

2 From the Space dimension list, select 2D.
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3 From the list of application modes, choose 
Chemical Engineering Module>Momentum Transport>Laminar Flow> 
Incompressible Navier-Stokes.

4 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

2 Define the following constants (the descriptions are optional); when done, click OK.

G E O M E T R Y  M O D E L I N G

1 Press the Shift key and click the Rectangle/Square button on the Draw toolbar.

2 Specify the following parameters in the corresponding edit fields:

3 Click OK.

4 Press the Shift key and click the Rectangle/Square button.

5 Draw a second rectangle by entering the values below:

NAME EXPRESSION DESCRIPTION

rho 1[kg/m^3] Density

eta 1e-5[Pa*s] Viscosity

epsilon 0.4 Porosity

k 1e-8[m^2] Permeability

v0 1[cm/s] Inlet velocity

PROPERTY VALUE

Width 1e-3

Height 6e-3

Base Corner

x 0

y -3e-3

PROPERTY VALUE

Width 1e-3

Height 8e-3

Base Corner

x -1e-3

y -4e-3
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6 Click OK.

7 Click the Zoom Extents button on the Main toolbar.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Physics menu, select Subdomain Settings.

2 Select Subdomain 1. 

3 Set ρ to rho and η to eta.

4 Select Subdomain 2.

5 Select the Flow in porous media (Brinkman equations) check box.

6 Set ρ to rho, η to eta, εp to epsilon, and k to k.

7 Click OK.

Boundary Conditions
1 From the Physics menu, select Boundary Settings.

2 Select the appropriate entry from the Boundary selection list and enter boundary 
conditions according to the following table:

3 Click OK.

M E S H  G E N E R A T I O N

In order to resolve the velocity profile close to the interface between the open channel 
and the porous domain, a finer mesh is required at this boundary.

1 From the Mesh menu, select Free Mesh Parameters.

2 Click the Custom mesh size option button.

3 In the Maximum element size edit field, type 2e-4.

4 Click the Boundary tab.

SETTINGS BOUNDARY 2 BOUNDARY 3

Boundary type Inlet Outlet

Boundary condition Velocity Pressure, no 
viscous stress

u0 0

v0 v0

p0 0
C O U P L E D  F R E E  A N D  P O R O U S  M E D I A  F L O W  |  63



64 |  C H A P T E R
5 Select Edge 5, then type 1e-4 in the Maximum element size edit field.

6 Click the Remesh button.

7 When the mesher has finished, click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

Postprocessing and Visualization
The default plot shows the velocity field, as illustrated in Figure 2-23. To visualize the 
velocity in a horizontal cross-section across the channel and the porous domain, follow 
these steps:

1 From the Postprocessing menu, select Cross-Section Plot Parameters.

2 Specify the following Cross-section line data:

3 Click OK to reproduce Figure 2-24.

PROPERTY VALUE

x0 -1e-3

x1 1e-3

y0 0

y1 0
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T u r bu l e n t  F l ow Th r ough a Bend i n g  
P i p e

Introduction

This example models the fluid flow through a bending pipe at high Reynolds number. 
It compares results obtained using both the k-ε and k-ω turbulence models with 
experimental data. The example contains detailed descriptions of how to make the 
modeling as accurate as possible.

Model Definition

Figure 2-25 shows the geometry of a generic bending pipe (Ref. 1). The pipe has a 
diameter of 1 meter and a total length of 6.71 m. 

Figure 2-25: Geometry of the bending pipe. The pipe diameter is 1 m.

Because of the way the geometry is generated, the modeling domain is a union of three 
subdomains as shown in Figure 2-26.

outlet

inlet
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Figure 2-26: Subdomain decomposition of the geometry.

The flow characteristics are determined by the Reynolds number, which is defined as

.

Here, ρ is the density and η denotes the dynamic viscosity, while Uref  and Lref  are the 
reference velocity and length, respectively. For this example it is suitable to choose Uref 
 as the inlet velocity and Lref  as the pipe diameter. Experimental data is available from 
Ref. 1 for Re = 3·105. At such high Reynolds number, the flow is turbulent and a 
turbulence model must be used. The Chemical Engineering Module supplies two 
RANS models: the standard k-ε turbulence model and the Wilcox revised k-ω 
turbulence model from 1998. In this model, you compare the velocity profiles 
obtained using these two turbulence models to the experimental data.

You model the fluid as a generic fluid with ρ = 1 kg/m3 and η = 1/(3·105) Pa·s. The 
closest physical correspondence is air with rather low viscosity.

B O U N D A R Y  C O N D I T I O N S

At the inlet there is a uniform flow of velocity 1 m/s in the z direction. The turbulent 
length scale is 0.07D, where D = 1 m is the pipe diameter, and the turbulent intensity 
is set to 5%, which is typical for fully turbulent internal flows. A constant pressure is 
specified at the outlet, and the flow vector is constrained to be normal to the outlet.

The model uses wall functions as boundary conditions on all other boundaries. The 
wall functions implemented in COMSOL Multiphysics are so called “lift off wall 

Ω 1

Ω 2

Ω 3

Re
ρUref Lref

η
---------------------------=
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functions,” that is, the computational domain is displaced a small distance, δw, from 
the surface. In this case, this is handled by drawing a domain with a smaller radius than 
the radius of the modeled pipe. The wall functions assume that the displacement 
expressed in viscous units, δw

+, falls between 30 and some upper limit dependent on 
the Reynolds number, in this case roughly 300. The correct procedure is for you to 
guess a displacement distance, δw, so that . If this is not the case, you 
must redraw the computational domain, choosing another value for δw. In this model, 
you set the initial guess for δw to be 1 cm, giving the computational domain a radius 
of 0.49 m compared to 0.50 m for the modeled pipe. For more information on wall 
functions, see “Logarithmic Wall Function” on page 141 of the Chemical 
Engineering Module User’s Guide.

C O R N E R  S M O O T H I N G

All nodes on the circles bounding the interior boundaries (see Figure 2-26) have two 
wall normals, one for each subdomain. The no-penetration condition of the wall 
functions results in two distinct directions in which there can be no mass flux. If this is 
not considered, the existing equations fulfill the constraints by forcing the flow to be 
stagnate at the points of intersection, which is of course unphysical. COMSOL 
Multiphysics provides corner smoothing  as an application mode property for the k-ε 
and k-ω turbulence models to deal with this issue. An extra vectorial equation is 
introduced on the boundaries, and its solution is a smoothly varying wall normal. This 
smoothed wall normal is then used in the boundary conditions for the velocities.

Results and Discussion

Figure 2-27 shows a boundary plot of the application mode variable dwplus_chns for 
δw

+. The scale is restricted to , and by rotating the plot, you can see 
that the wall is complete. If δw

+ would have fallen outside the permitted range, there 
would have been areas in the boundary plot with no results. Because there are none, 
you can conclude that the choice of δw = 0.01 m fulfills the above mentioned 
assumption for the wall functions.

30 δw
+ 300≤≤

30 δw
+ 300≤ ≤
TU R B U L E N T  F L O W  T H R O U G H  A  B E N D I N G  P I P E  |  67



68 |  C H A P T E R
Figure 2-27: Boundary plot of δw
+ from the k-ε solution.

Figure 2-28 compares the velocity, U, along the line from (1.58, 0, 0.3) to (1.58, 0, 
1.3) computed with the k-ε and k-ω turbulence models to experimental data. While 
both methods give fair results, the k-ω turbulence model is slightly more accurate at 
 2 :  F L U I D  F L O W — TU T O R I A L S  A N D  B E N C H M A R K S



the wall. This implies that k-ω gives a better prediction of the drag and hence of the 
friction loss in the pipe.

Figure 2-28: Streamwise velocity profile along the line between the points (1.58, 0, 0.3) 
and (1.58, 0, 1.3). The lines represent results from the k-ε (solid line) and k-ω (dashed 
line) models. The circles correspond to experimental data (Ref. 1).

Reference

1. I. E. Idelchik, Handbook of Hydraulic Resistance, 1996, Begell House Publishers.

Model Library path:  

Chemical_Engineering_Module/Fluid_Flow/bending_pipe

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics.

2 From the Space dimension list, select 3D. 

3 From the list of application modes choose  
Chemical Engineering Module>Momentum Transport>Turbulent Flow> 
k-ε Turbulence Model.

4 Click OK.
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G E O M E T R Y  M O D E L I N G

1 From the Draw menu, select Work-Plane Settings. Click OK.

2 Shift-click the Ellipse/Circle (Centered) button on the Draw toolbar. In the Radius edit 
field type 0.49, then click OK.

3 From the Draw menu select Revolve.

4 In the α2 edit field type 90. Click the radio button Angle from x-axis, then type 0.8 
in the x edit field. Click OK.

5 In the Model Tree select Geom2.

6 Select Extrude from the Draw menu.

7 In the Distance edit field type -1.45, then click OK.

8 From the Draw menu select Work-Plane Settings.

9 Click the Face Parallel tab and select REV1>6 from the Face selection list. Click OK.

10 Double-click the lower left circle to open the Circle dialog box. Type 0.49 in both 
the x and y edit fields. Click OK.

11 Select Extrude from the Draw menu.

12 In the Distance edit field type 4, then click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu select Constants. Enter the following settings:

2 Click OK.

3 Expand Geom1 in the Model Tree and right-click k-ε Turbulence Model (chns), then 
click Properties.

4 From the Corner smoothing list select On, then click OK.

M E S H  G E N E R A T I O N

Since the flow varies significantly less in the streamwise direction than in the radial 
direction, swept meshes are excellent where the pipe is straight. A swept mesh would 
however be inefficient in the bend and Subdomain 2 is therefore meshed using an 
unstructured mesh.

1 From the Mesh menu select Free Mesh Parameters.

2 Set Predefined mesh sizes to Coarse.

NAME EXPRESSION DESCRIPTION

Re 3e5 Reynolds number
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3 Click the Boundary tab. Select Boundaries 3 and 16, then type 0.25 in the Mesh 

curvature factor edit field.

4 Click Mesh Selected, then click OK.

5 From the Mesh menu, select Swept Mesh Parameters.

6 Select Subdomain 1, then select the Manual specification of element layers check box.

7 In the Number of element layers edit field type 6.

8 Click Mesh selected.

9 Select Subdomain 3, then select the Manual specification of element layers check box.

10 In the Number of element layers edit field type 16.

11 Click Mesh Selected, then click OK.

12 From the Mesh menu, select Free Mesh Parameters again.

13 From the Predefined mesh sizes list select Fine.

14 Click the Subdomain tab. Select Subdomain 2, then click Mesh Selected.

15 Click OK.

S U B D O M A I N  S E T T I N G S

1 From the Physics menu select Subdomain Settings.

2 Select one of the subdomains, then press Ctrl+A to select all of them.

3 In the Dynamic viscosity edit field, type 1/Re.

4 Click OK.

B O U N D A R Y  C O N D I T I O N S

1 From the Physics menu, select Boundary Settings.

2 Apply boundary conditions according to the following list.

3 Click OK.

SETTINGS BOUNDARY 3 BOUNDARY 16 ALL OTHERS

Boundary type Inlet Outlet Wall

Boundary condition Velocity Pressure Logarithmic wall function

w0 1

LT 0.07

p0 0

 δw 0.01
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C O M P U T I N G  T H E  k- ε S O L U T I O N

It is possible to solve this rather small problem using direct solvers.

1 Click the Solver Parameters button on the Main toolbar.

2 For Group 1 click the Linear Solver Settings button.

3 From the Linear system solver list select Direct (PARDISO).

4 Click OK.

5 For Group 2 click the Linear Solver Settings button.

6 From the Linear system solver list select Direct (PARDISO).

7 Click OK.

8 Click OK.

9 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  T H E  k- ε R E S U L T S

1 Click the Plot Parameters button on the Main toolbar.

2 Click the Slice tab and clear the Slice plot check box.

3 Click the Boundary tab and select the Boundary plot check box.

4 In the Expression edit field, type dwplus_chns.

5 Click the Range button.

6 Clear the Auto check box.

7 Type 30 in the Min edit field and 300 in the Max edit field.

8 Click OK twice.

This yields a plot like the one shown in Figure 2-27. Rotate the plot to verify that 
all of the pipe wall is represented.

Next, import the experimental data:

9 From the Options menu choose Functions.

10 Click the New button.

11 In the Function name edit field, type exp_data. Click the Interpolation button and 
then select File from the Use data from list.

12 Click the Browse button and locate the file 3Dpipe_exp-data_Re300e3.txt in the 
models/Chemical_Engineering_Module/Fluid_Flow folder in the COMSOL 
Multiphysics installation directory. Click Open, then click OK.

13 From the Extrapolation method list, select Constant.

14 Click OK to close the Functions dialog box.
 2 :  F L U I D  F L O W — TU T O R I A L S  A N D  B E N C H M A R K S



15 From the Solve menu, select Update Model.

16 From the Postprocessing menu, select Cross-Section Plot Parameters.

17 Click the General tab, then select the Keep current plot check box.

18 Click the Line/Extrusion tab.

19 In the Expression edit field, type exp_data(z-0.8).

20 In the Cross-section line data area, enter values according to this table:

21 Click the Expression option button, then click the Expression button.

22 In the Expression edit field, type z-0.8. Click OK, then click OK again.

23 Click the Line Settings button.

24 From the Line style list, select None and from the Line marker list, select Circle. Click 
OK.

25 Click Apply.

26 Go back to the Cross-Section Plot Parameters dialog box.

27 From the Predefined quantities list, select k-ε Turbulence model (chns)>x-velocity.

28 Click the Line Settings button. 

29 Select Solid line from the Line style list and None from the Line marker list. Click OK.

30 Click OK.

Leave the resulting plot window open; you finish the plot later on.

C O M P U T I N G  T H E  k- ω S O L U T I O N

Next re-calculate a solution using the k-ω turbulence model. When switching 
turbulence models, COMSOL Multiphysics automatically adjusts the initial values so 
that the computation starts from the existing k-ε solution.

1 Return to the COMSOL Multiphysics user interface.

2 Right-click k-ε Turbulence Model (chns) in the Model Tree, then click Properties.

3 From the Turbulence model list, select k-ω. Click OK.

4 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  T H E  k- ω S O L U T I O N

1 From the Postprocessing menu, select Cross-Section Plot Parameters.

X0 X1 Y0 Y1 Z0 Z1

1.58 1.58 0 0 0.3 1.3
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2 Click the Line Settings button. From the Line style list, select Dashed line. Click OK.

3 Click OK to obtain the plot in Figure 2-28.
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Os c i l l a t i n g  L i q u i d  C oba l t  D r op l e t

Introduction

Cemented tungsten carbides are hard metals used in steel cutting tools. They are 
produced by heating a powder consisting typically of tungsten carbide (WC) grains and 
cobalt (Co) grains. When the powder is heated, the cobalt melts but the tungsten 
carbide remains solid. The liquid cobalt glues the tungsten carbide grains together and 
forces air to flow out of the material. When the medium is cooled down, a solid hard 
metal forms. The process is called liquid phase sintering. 

You can determine the character of the flow of air and liquid cobalt by simulating a 
droplet of cobalt surrounded by air. Such a simulation reveals the relevant time scales 
and shows whether the flow is dominated by inertia or viscous forces. This example 
shows how COMSOL Multiphysics can simulate a liquid cobalt droplet using a 
reinitialized mass-conserving level set method. The model studies an initially 
ellipsoidal droplet that starts to oscillate because of the large surface tension of liquid 
cobalt. The droplet’s size corresponds to a typical size of the cobalt grains in liquid 
phase sintering, roughly 10 µm. From the results you can study the frequency and 
damping of the droplet’s oscillations. 

Model Definition

Figure 2-29 shows the initial shape of the cobalt droplet. Because of its symmetry you 
can use a 2D axisymmetric model. You can model the fluid flow of air and liquid cobalt 
with the Navier-Stokes equations in combination with a level set equation to track the 
interface between the air and cobalt. This model uses a reinitialized level set method 
both in conservative and non-conservative form.

Figure 2-29: Initial droplet shape.
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M A S S  A N D  M O M E N T U M  TR A N S P O R T

The Navier-Stokes equations describe the transport of mass and momentum of 
incompressible fluids. The Navier-Stokes equations with surface tension are

Here, ρ denotes density (kg/m3), η is the dynamic viscosity (Ns/m2), u equals the 
velocity (m/s), p is the pressure (Pa), and σ represents the surface-tension coefficient 
(N/m). In addition, n is the unit vector normal to the interface, and is 
the mean curvature of the interface. Further, δ is a Dirac delta function with support 
only at the interface, which means that δ is zero away from the interface and that the 
integral of δ equal the area of the interface. You can write the surface-tension force as

where I is the identity matrix. By using this formulation you can include surface 
tension without having to calculate derivatives of the interface normal, n.

R E P R E S E N T A T I O N  A N D  C O N V E C T I O N  O F  T H E  F L U I D  I N T E R F A C E

This model uses a level set method to describe and to convect the interface. The 0.5 
contour of a function  defines the interface. is 0 in air and 1 in cobalt. In a 
transition layer close to the interface,  goes smoothly from 0 to 1. The normal to the 
interface is then

The interface moves with the fluid velocity, u, at the interface. The following equation 
describes the reinitialized convection of the interface:

By adding the terms on the right-hand side you reinitialize the level set function. This 
means that you keep the thickness of the transition layer constant in time. 

Note that because , you can write the convective term in the conservative 
form and can thus rewrite the level set equation as

ρ
t∂

∂u u u∇⋅+⎝ ⎠
⎛ ⎞ ∇ η ∇u ∇uT+( )( ) ∇p+⋅– σκδn=

∇ u⋅ 0=

κ ∇ n⋅( )–=

σκnδ ∇ T⋅=

T σ I nnT( )–( )δ=

φ φ
φ

n ∇φ
∇φ

----------=

φ∂
t∂

------ u ∇φ⋅+ γ∇ φ– 1 φ–( ) ∇φ
∇φ
---------- ε∇φ+⎝ ⎠

⎛ ⎞⋅=

∇ u⋅ 0=
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 (2-21)

which is important to obtain numerical conservation.

The density and the viscosity are discontinuous, and the surface-tension force is 
singular at the interface. To simplify the numerical calculations, let the density and 
viscosity go smoothly between the values for air and cobalt. This is obtained by setting 

and

You can smooth the surface-tension force by letting

Here it is important that you use a reinitialized level set method. The smoothing of 
density, viscosity, and surface tension is acceptable only if the thickness of the interface 
is constant.

The following table gives the physical properties of liquid cobalt and air:

DENSITY DYNAMIC VISCOSITY SURFACE TENSION 

cobalt 7760 kg/m3 5·10-3 Pa·s 1.873 N/m

air 1.29 kg/m3 1.67·10-5 Pa·s

φ∂
t∂

------ ∇ φu( )⋅+ γ∇ φ– 1 φ–( ) ∇φ
∇φ
---------- ε∇φ+⎝ ⎠

⎛ ⎞⋅=

ρ ρair ρcobalt ρair–( )φ+=

µ µair µcobalt µair–( )φ+=

δ 6 φ 1 φ–( ) φ∇=
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I N I T I A L  C O N D I T I O N S

Initially the droplet is at rest and has an ellipsoidal shape. The initial (see 
Figure 2-30) gives the correct shape of the droplet.

Figure 2-30: Initial .

B O U N D A R Y  C O N D I T I O N S

The droplet is placed in a cylindrical box using no-slip conditions, u = 0, on all walls. 
Because there are no conditions for p on any boundary, you should fix p at a single 
point. 

Results and Discussion

The initial appears in Figure 2-30. The model shows that the droplet immediately 
starts to oscillate when it is released from its initial state. Figure 2-31 and Figure 2-32 

φ

φ

φ
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show the position of the interface and the velocity field after 5·10−7 s and 1·10−5 s, 
respectively. 

Figure 2-31: Velocity field and level set function at t = 5·10−7 s.

Figure 2-32: Velocity field and level set function at t = 10−5 s.

Figure 2-33 shows the ratio between the two semiaxes of the ellipse as a function of 
time. The figure shows results using the conservative as well as the non-conservative 
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formulation. You can see that the time scale is very small; the period of the oscillations 
is about 2·10−6 s. 

Figure 2-33: Ratio between axes as function of time. The dashed line corresponds to the 
conservative form and the solid line to the non-conservative form.

The total mass of the droplet is

Because there is no production or flow of cobalt through the boundaries, the mass 
should not change with time. To check the conservation, Figure 2-34 plots the values 
for M(  t ) using the conservative and the non-conservative equation forms.

Clearly, the conservative form results in exact conservation, while the non-conservative 
form results in a mass loss of about 0.3%.

M t( ) ρcobaltφ t( )
Ω
∫ dΩ=
 2 :  F L U I D  F L O W — TU T O R I A L S  A N D  B E N C H M A R K S



Figure 2-34: Conservation of total mass of cobalt droplet. The dashed line corresponds to 
the conservative form and the solid line to the non-conservative form.

References

1. C.J. Smithells, Smithells Metals Reference Book, Oxford, 1998.

2. E. Olsson and G. Kreiss, “A conservative level set method for two phase flow,” 
J. Comput. Phys., vol. 210, pp. 225–246, 2005.

Modeling in COMSOL Multiphysics

It is easy to set up the model using the Level Set Two-Phase Flow application mode. 
You only need to specify the physical parameters, boundary conditions, and the initial 
position of the interface. Before you can start the fluid flow calculation, you initialize 
the level set function. Then, store the solution, switch the analysis type from Transient 
initialization to Transient, and start the two-phase flow calculation.

Model Library path:  

Chemical_Engineering_Module/Fluid_Flow/oscillating_droplet
O S C I L L A T I N G  L I Q U I D  C O B A L T  D R O P L E T  |  81



82 |  C H A P T E R
Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 In the Model Navigator, select Axial symmetry (2D) from the Space dimension list.

2 From the list of application modes, select Chemical Engineering Module> 
Momentum Transport>Multiphase Flow>Level Set Two-Phase Flow, Laminar.

3 Click OK to close the Model Navigator.

G E O M E T R Y  M O D E L I N G

1 Shift-click the Rectangle/Square button on the Draw toolbar.

2 Set the Width to 1e-5, the Height to 2e-5, and z to -1e-5.

3 Click OK, then click the Zoom Extents button on the Main toolbar.

4 Shift-click the Ellipse/Circle button. Type 5e-6 in the A-semiaxes edit field and 7e-6 
in the B-semiaxes edit field. Click OK.

5 Click the Create Composite Object on the Draw toolbar.

6 In the Set formula edit field, type R1*E1+R1. Here, R1*E1 gives the intersection 
between the ellipse and the rectangle. Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

2 Define the following constants (units and descriptions are optional):

3 Click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Physics menu, select Subdomain Settings.

NAME EXPRESSION DESCRIPTION

rho_air 1.293[kg/m^3] Density of air

rho_cob 7.760e3[kg/m^3] Density of cobalt

eta_air 1.67e-5[Pa*s] Viscosity of air

eta_cob 5e-3[Pa*s] Viscosity of cobalt

sigma 1.873[N/m] Surface tension
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2 Select Subdomains 1 and 2, then enter the following physical properties: 

3 On the Sources/Sinks page, type sigma in the Surface tension coefficient edit field.

4 Go to the Init tab and select Subdomain 2 only. Select the option button Fluid 2.

5 Click OK.

Boundary Conditions
1 From the Physics menu, select Boundary Settings. 

2 Select Boundaries 1, 3, and 4, then select Symmetry boundary from the 
Boundary type list and Axial symmetry from the Boundary condition list. 

3 Select Boundaries 7 and 8. Select the Interior boundaries check box, then select the 
boundary condition Initial fluid interface. Click OK.

Point Settings
1 From the Physics menu, select Point Settings. 

2 Select Point 7. Select the Point constraint check box. Leave the value for p0 at 0.

3 Click OK.

M E S H  G E N E R A T I O N

1 Click the Initialize Mesh button on the Main toolbar.

2 Click the Refine Mesh button on the Main toolbar.

C O M P U T I N G  T H E  S O L U T I O N

First make an initial calculation to obtain a good initial value for .

1 Click the Solver Parameters button on the Main toolbar.

2 On the General page, type 0 2e-6 in the Times edit field. Click OK.

3 Click the Solve button on the Main toolbar. This creates a good initial solution to 
the level set function.

Use the obtained solution as an initial condition for the simulation of the droplet 
motion.

QUANTITY VALUE/EXPRESSION DESCRIPTION

ρ1 rho_air Density, fluid 1

 η1 eta_air Dynamic viscosity, fluid 1

 ρ2 rho_cob Density, fluid 2

 η2 eta_cob Dynamic viscosity, fluid 2

φ
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1 Click the Solver Manager button on the Main toolbar. 

2 On the Initial Value page, click the Store Solution button. 

3 Select only the time 2e-6, then click OK.

4 In the Initial value area, select Stored solution.

5 From the Solution at time list, select 2e-6. Click OK.

6 From the Physics menu, select Properties. Change the Analysis type to Transient. 
Click OK.

7 Click the Solver Parameters button on the Main toolbar.

8 On the General page, type 0:2e-7:1e-5 in the Times edit field.

9 Click the Time Stepping tab. In the Times to store in output list, select 
Time steps from solver. Click OK.

10 Click the Solve button on the Main toolbar.

The calculations take roughly 20–40 minutes.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Click the Plot Parameters button on the Main toolbar.

2 Click the Arrow tab. Select the Arrow plot check box.

3 Select Velocity field from the Predefined quantities list.

4 Type 10 in the Number of points/r points edit field and type 20 in the 
Number of points/z points edit field.

5 Click the Animate tab.

6 In the Solutions to use area, select Interpolated times from the Select via list.

7 In the Times edit field type 0:2e-7:1e-5.

8 Click the Start Animation button, then click OK to close the Plot Parameters dialog 
box.

To check the conservation, perform the following steps:

1 Choose Options>Integration Coupling Variables>Subdomain Variables.

2 Select Subdomains 1 and 2, then define a variable with the Name Mass by the 
Expression 2*pi*r*phi*rhocob.

3 Click OK.

4 From the Solve menu, select Update Model.

5 From the Postprocessing menu, select Domain Plot Parameters. 
 2 :  F L U I D  F L O W — TU T O R I A L S  A N D  B E N C H M A R K S



6 Click the Point tab and select any point.

7 In the Expression edit field, type Mass.

8 Click OK.

To plot the ratio between the r- and z-axes of the droplet perform the following steps:

1 Click the Line button on the Draw toolbar.

2 Click at the coordinate point (0, 0) and then right-click the point (1e-5, 0) to draw 
a line between (0,0) and (1e-5,0).

3 Choose Options>Integration Coupling Variables>Boundary Variables.

4 Select Boundaries 1 and 3, then define a variable with the Name radz by the 
Expression phi.

5 Select Boundaries 5 and 8, then define a variable with the Name radr by the 
Expression phi.

6 Click OK.

7 From the Solve menu, select Update Model.

8 From the Postprocessing menu select Domain Plot Parameters.

9 Click the Point tab and select any point. 

10 In the Expression edit field, type radz/radr.

11 On the General page, select New figure from the Plot in list.

12 Click OK.

In some cases the conservation of the non-conservative form is too poor. It is then 
useful to switch to the conservative form. This form results in exact mass conservation 
but is harder to solve numerically. To make a simulation using the conservative 
formulation, perform the following steps:

1 From the Physics menu, select Properties. 

2 From the Two-phase flow list, select Conservative level set. Click OK.

3 A new mesh was created when you added the line along the r-axis to the geometry. 
Click the Refine Mesh button to refine the grid.

4 Click the Solve button on the Main toolbar to start a new calculation.

In this case, the calculations take about 60–120 minutes.

5 From the Postprocessing menu, select Domain Plot Parameters.

6 Click the Point tab and select any point. 

7 In the Expression edit field, type radz/radr.
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8 Click the Line Settings button. From the Line style list, select Dashed line. Click OK.

9 Click the General tab. From the Plot in list, select Figure 2. 

10 Select the Keep current plot check box, then click Apply.

11 From the Plot in list, select Figure 1.

12 Click the Point tab and select any point. 

13 In the Expression edit field, type Mass, then click OK.

The plots in Figure 1 and Figure 2 correspond to Figure 2-33 and Figure 2-34, 
respectively.
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Tu r bu l e n t  F l ow o v e r  a  
Ba c kwa r d - F a c i n g  S t e p

Introduction

The backward-facing step is an interesting case for studying the performance and 
solution strategy of a turbulence model, because it presents both turbulent channel 
flow and recirculation. In this case, the flow is subjected to a sudden increase of the 
cross section, resulting in a separation of flow starting at the point of expansion. Spatial 
variations in the velocity field cause a production of turbulence outside the wall region 
and its interaction with the mean flow influences the size of the separation zone. The 
size of the zone, or the reattachment length, is one of the quantities that must be 
predicted accurately by a turbulence model.

The Reynolds number and the expansion ratio are two numbers that can be used to 
characterize the flow. Existing data indicate that the length of the reattachment zone 
increases with the expansion ratio. The Reynolds numbers are calculated based on the 
step height and the inlet free stream velocity. The reattachment length increases with 
Reynolds number until 1200, where it then decreases between 1200 < Re < 6600, to 
then be relatively constant for higher Reynolds numbers, when the flow is in state of 
fully developed turbulence.

Model Definition

This model treats the backward-facing step for a flow configuration with an area 
expansion ratio of 3/2. Assuming that the channel is deep enough, you can neglect 
variations in the z direction and reduce the problem from 3D to 2D. The step height, 
h, is chosen as the length scale, the inlet is set to 2h, the initial channel length to 8h, 
and the length of the channel after the expansion is set to 35h (see Figure 2-35). Do 
not confuse this h with the predefined variable h for the mesh element diameter, which 
you use in the model when specifying the logarithmic wall function.
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Figure 2-35: Model geometry.

The k-ε model describes turbulent flow in the domain. The equations for the 
momentum transport and continuity are the following:

 (2-22)

where ρ denotes the density of the fluid (kg/m3), U represents the averaged velocity 
(m/s), η the dynamic viscosity (N·s/m2), P the pressure (Pa), k the turbulence energy 
(m2/s2), and ε the dissipation rate of turbulence energy (m2/s3). The turbulence 
energy equation is given by

 (2-23)

and the dissipation equation by

 (2-24)

ρ
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The model constants in the above equations are determined from experimental data 
and are set to the values in Table 2-2.

At the inlet, set the velocity component in the x direction, u, to u0 = 18.2 m/s, and 
that in the y direction, v, to zero. Further, specify a constant pressure value of 0 at the 
outlet and logarithmic wall functions at the solid walls.

TABLE 2-2:  CONSTANTS USED IN THE TURBULENCE ENERGY AND DISSIPATION EQUATIONS

CONSTANT VALUE

0.09

1.44

1.92

 σk 1.0

1.3

Cµ

Cε1

Cε2

σε
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Results

Figure 2-36 shows the velocity field. The low flow speed near the lower corner after 
the step indicates the presence of a recirculation zone.

Figure 2-36: Velocity field (modulus of the velocity vector) of flow over a backstep.
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Figure 2-37 zooms in on the region around the backstep. The plot, displaying the 
magnitude of the velocity together with velocity streamlines, shows that a recirculation 
zone appears after the backstep.

Figure 2-37: Magnitude and streamline plot of the velocity field. The figure shows a 
recirculation region after the backstep.

You can determine the size of the recirculation zone by plotting the zero contour of 
the x-velocity and coloring it with x/h. The maximum of x/h along that contour gives 
the size of the recirculation zone. Figure 2-38 shows the corresponding plot. The 
figure shows that the obtained reattachment length is 6.3. Compare this to results 
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presented in Ref. 1. There, the reattachment length is experimentally determined to 
be 7.1, while numerical results using a k-ε turbulence model yield 6.1.

Figure 2-38: Calculation of the recirculation zone. The plot shows the contour 
corresponding to zero velocity in the x direction. The contour is colored by the scaled 
distance from the step, x/h. Its maximum value gives the recirculation length, in this case 
6.3.

The section below explains in detail how to create this model in the Chemical 
Engineering Module.

Reference

1. 1st NAFEMS Workbook of CFD Examples. Laminar and Turbulent 
Two-Dimensional Internal Flows, NAFEMS, 2000.

Model Library path:  
Chemical_Engineering_Module/Fluid_Flow/turbulent_backstep
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Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics.

2 In the Model Navigator, select 2D from the Space dimension list.

3 From the Application Modes tree, select 
Chemical Engineering Module>Momentum Transport>Turbulent Flow> 
k-ε Turbulence Model.

4 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

2 Enter the following constants; when done, click OK.

The Reynolds number value 47,648 appears in the Value column for Re.

G E O M E T R Y  M O D E L I N G

1 Press the Shift key and click the Rectangle/Square button.

2 Enter rectangle dimensions according to the table below in the appropriate edit 
fields. When done, click OK.

NAME EXPRESSION DESCRIPTION

rho 1.23[kg/m^3] Density

eta 1.79e-5[Pa*s] Viscosity

v0 18.2[m/s] Inlet peak velocity

h_step 3.81[cm] Step height

Re rho*v0*h_step/eta Reynolds number (step)

OBJECT DIMENSIONS EXPRESSION

Width 0.3048

Height 0.0762

x -0.3048

y 0.0381
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3 Repeat the procedure for another rectangle with the following dimensions:

4 Click the Zoom Extents button on the Main toolbar.

5 Click the Create Composite Object button on the Draw toolbar. 

6 In the Set formula edit field, type R1+R2.

7 Clear the Keep interior boundaries check box, then click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Physics menu, select Subdomain Settings.

2 Select Subdomain 1.

3 Type rho in the ρ edit field and eta in the η edit field.

4 Click OK.

Boundary Conditions
1 From the Physics menu, select Boundary Setting.

2 Enter boundary conditions according to the following table:

The variable h is a predefined variable for the mesh element diameter.

3 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters.

OBJECT DIMENSIONS EXPRESSION

Width 1.3335

Height 0.1143

x 0

y 0

SETTINGS BOUNDARY 1 BOUNDARIES 2, 3, 4, 5, 6 BOUNDARY 7

Boundary type Inlet Wall Outlet

Boundary condition Velocity Logarithmic wall function Pressure

 u0 v0

 v0 0

 p0 0

 δw h/2
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2 Click the Custom mesh size option button.

3 Type 3 in the Resolution of narrow regions edit field, then click OK.

4 Click the Initialize Mesh button on the Main toolbar.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button. Select the Adaptive mesh refinement check box.

2 Click the Adaptive tab.

3 Type 4 in the Maximum number of refinements edit field.

4 From the Refinement method list, select Meshinit.

5 Click OK to close the Solver Parameters dialog box.

6 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The first plot, shown in Figure 2-36, is generated automatically and shows a surface 
plot of the velocity field.

1 To visualize the mesh, click the Mesh Mode button on the Main toolbar.

Figure 2-39: Plot of the mesh obtained using adaptive mesh refinement. Note that the mesh 
can vary slightly on different computers.
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2 Click the Plot Parameters button on the Main toolbar.

3 On the General page, clear the Surface check box and select the Contour plot check 
box.

4 On the Contour page, type u in the Expression edit field.

5 Click the Vector with isolevels option button and type 0 in the associated edit field.

6 Click the Color Data tab and select the Color data check box. Type x/h_step in the 
Expression edit field.

7 Click Apply. 

You should now obtain the plot in Figure 2-38. 

8 Back in the Plot Parameters dialog box, click the General tab.

9 In the Plot type area, select the Streamline and the Surface check boxes and clear the 
Contour check box.

10 Click the Streamline tab.

11 Click the Specify start point coordinates option button. Type 0.1 in the x edit field 
and linspace(0,0.13,20) in the y edit field.

12 Click OK to generate the plot in Figure 2-37.
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H e a t  T r a n s f e r  a n d  N o n - I s o t h e r m a l  
F l o w— T u t o r i a l s  a n d  B e n c h m a r k s
This chapter contains examples of fluid flow models where the temperature varies, 
that is, non-isothermal flow models. Both laminar and turbulent flows are treated, 
and several examples demonstrate how you can set up a model accounting for heat 
transfer in solid as well as fluid domains.
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Fo r c e d  Tu r bu l e n t  C on v e c t i o n  Coo l i n g  
o f  a  Ho t  P l a t e

Introduction

The following model demonstrates how to model a conjugate heat and mass transfer 
problem with COMSOL Multiphysics. The model uses the Non-Isothermal Flow 
predefined multiphysics coupling from the Chemical Engineering Module. 

Figure 3-1 depicts the geometry: a horizontal stream of air that cools a thin and 
infinitely wide horizontal plate. The plate is at a uniform temperature at the bottom, 
and the flow is turbulent. This is a well-studied case of convection cooling that works 
well as a benchmark that demonstrates the accuracy of the modeling methods.

Figure 3-1: Forced convection cooling of a horizontal plate.

Model Definition

The model works with the following equations:

• Reynolds-averaged Navier-Stokes (RANS) equations in the air domain.

• The conductive and convective heat equation in the air and the solid (copper) wall.

The Non-Isothermal Flow predefined multiphysics coupling sets up these application 
modes together with applicable couplings, making it easy to model the fluid-thermal 
interaction.

The material properties for the fluid are those of air at atmospheric pressure, and for 
the solid plate those of copper. You can load these properties from the built-in 
materials library where the air properties are temperature dependent.

Inflow

Hot plate

Symmetry

Outflow
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It is necessary to correct the fluid’s thermal conductivity to take into account the effect 
of mixing due to eddies. The turbulence results in an effective thermal conductivity, 
keff, according to the equation

.

Here k is the physical thermal conductivity of the fluid (W/(m·K)), kT is the turbulent 
conductivity (W/(m·K)), ηT denotes the turbulent viscosity (kg/(m·s)), and Cp equals 
the heat capacity (J/(kg·K)). With COMSOL Multiphysics you can easily obtain the 
effective conductivity by using the ready-made fluid group in the fluid domain. In the 
group, the variable for turbulent conductivity is already given in the Convection and 
Conduction application mode for the fluid.

Figure 3-2 depicts the model with its boundary conditions.

Figure 3-2: Modeled 2D geometry with boundary conditions.

The boundary conditions for the problem are:

• k-ε equations in the fluid domain

- Specified velocity at the inlet

- Specified pressure at the outlet

- Symmetry at the top boundary

- Logarithmic wall function at the plate’s surface boundaries

• Heat transport equations

- Room temperature at the inlet

- Convection-dominated transport at the outlet

- Symmetry at the top boundary

- Thermal wall function at the plate/air interface

- Fixed temperature at the bottom of the heated plate

To model the solid-fluid interfaces, the model uses the logarithmic wall function 
boundary condition for turbulent flow, in which an algebraic relationship—the 

keff k kT+= kT CpηT=

Symmetry

Inflow/ Convective
Temperature outflow

Constant temperature

Logarithmic wall function
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logarithmic wall function—describes the momentum transfer at the solid-fluid 
interface. This means that the modeled domain ends at the top of the laminar 
boundary layer where the fluid experiences a significant wall-tangential velocity. This 
is an important aspect to consider when modeling the heat transfer. Like the fluid 
velocity, the temperature is not modeled in the laminar sublayer. Instead of assuming 
the temperature to be continuous across the layer, the model uses a thermal wall 
function. This creates a jump in temperature between the solid surface and the fluid 
due to the omitted laminar sublayer. The predefined group for the wall domains 
defines this wall function in the following way.

To implement the thermal wall function, the model uses two heat transfer application 
modes: one for the solid and one for the fluid. These are connected through a heat flux 
boundary condition, the thermal wall function. This means that the resistance to heat 
transfer through the laminar sublayer is related to that for momentum transfer for the 
fluid. You therefore determine the heat flux, q(W/m2), from the equation

where ρ and Cp are the fluid’s density and heat capacity, respectively;  is a numerical 
constant of the turbulence model; and kw is the value of the turbulent kinematic 
energy at the wall. Furthermore, Tw equals the temperature (K) of the solid at the wall, 
while T is the fluid temperature on the other side of the omitted laminar sublayer (K).

The dimensionless quantity T+ is related to the dimensionless wall offset, δw
+, through 

the definition

 (3-1)

where the turbulent Prandtl number PrT is fixed to 1.0; κ is the von Karman constant, 
which is set to 0.41; and β is a model constant set to 3.27. The dimensionless wall 
offset is defined as

 (3-2)

where δw is the specified wall offset, which in COMSOL Multiphysics defaults to the 
local mesh size at the boundary, and ν = η/ρ denotes the kinematic viscosity.

At the front of the hot plate a stagnation point for the flow develops. Typical for 
two-equation turbulence models such as the k-ε model is an unphysical production of 

q
ρCpCµ

1 4⁄ kw
1 2⁄ Tw T–( )

T+
---------------------------------------------------------------=

Cµ

T+ PrT

κ
---------- δw

+( ) β+ln=

δw
+ δwCµ

1 4⁄ kw
1 2⁄

ν
--------------------------------=
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turbulence at stagnation points. The remedy is to apply a realizability constraint, 
which is a physical constraint on the turbulent viscosity. The realizability constraint 
makes the simulation less stable and is therefore applied only when necessary.

Results

The example solves the problem for a set of inlet velocities between 1 m/s and 100 m/
s. Figure 3-3 depicts the temperature distribution for the inlet velocity 1 m/s.

Figure 3-3: Temperature distribution at an inlet velocity of 1 m/s.
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The heated layer of air at the plate surface is rather thick considering the relatively high 
velocity. This is an effect of the turbulent thermal conductivity caused by the eddies in 
the flow. The next figure depicts the turbulent thermal conductivity of the air.

Figure 3-4: Turbulent thermal conductivity of the air at an inlet velocity of 100 m/s.

The turbulent conductivity is very much higher than the physical thermal conductivity 
of air, which is 0.03 W/(m·K) at 323 K. This means that the added turbulent 
conductivity dominates over the laminar conductivity, and hence that the turbulent 
eddies cause a significantly higher heat flux at the cooled surface compared to a laminar 
flow.
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In this example you also modify the turbulent flow model to take density variations 
into account. The density of air decreases with temperature; the following figure shows 
its variation at an inlet velocity of 1 m/s.

Figure 3-5: Fluid density at an inlet velocity of 1 m/s.
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These results point out the importance of taking density variations into account. As the 
density decreases, the fluid velocity increases. This effect becomes apparent in the next 
figure, which shows the velocity distribution at the same inlet velocity.

Figure 3-6: Velocity field at an inlet velocity of 1 m/s.

If you had treated the flow as being isothermal, the average would not have varied 
between the inlet and the outlet. However, for a non-isothermal flow the average 
velocity is inversely proportional to the average density, and it varies with changing 
average temperature. This means that the flow field for the fluid is different when 
taking density variations into account.

As the fluid heats up, its velocity increases slightly. Thus the boundary layer decreases 
and the local heat transfer coefficient should become larger. So if you neglect density 
variations when modeling forced convection cooling, the model slightly 
underestimates the cooling/heating power.

The accuracy in predicting the heat transfer coefficient in this example is dictated by 
the accuracy of the Reynolds analogy and the accuracy of the flow model. The situation 
this example models is very well studied, so you can readily verify the results in terms 
of heat transfer coefficient predictions. The following figure compares the local 
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h coefficient from the model with an empirical expression valid for the geometry and 
conditions studied (assuming turbulent flow).

Figure 3-7: Local heat transfer coefficient as determined empirically (solid) and with the 
model (dashed) for various inlet velocities.

The model agrees well with empirical data for low to intermediate inlet velocities. The 
deviations at the leading edge of the plate are due to the correlation which assumes 
that the boundary layer is fully developed for all x. However, the region where the 
results deviates from the correlation increases in size as the inlet velocity increases. The 
logarithmic wall function in COMSOL Multiphysics is valid under certain conditions 
that depend on the resolution, the velocity, and the viscosity. As displayed in 
Equation 3-1, the wall function uses the dimensionless wall offset, δw

+ (defined in 
Equation 3-2). For the wall function to be an accurate approximation, δw

+ for the first 
internal node should be larger than 30 but less than some upper limit dependent on 
the Reynolds number (for more details see the section “Logarithmic Wall Function” 
on page 141 of the Chemical Engineering Module User’s Guide). Figure 3-8 depicts 
the parameter δw

+ against plate surface for various inlet velocities.
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Figure 3-8: Dimensionless wall offset at the plate surface for various inlet velocities.

A maximum δw
+ value of a few hundreds is always acceptable, whereas a value above 

1000 is always questionable. Note that the value of δw
+ exceeds 1000 when the inlet 

velocity is 50 m/s or higher. Hence, the mesh is too coarse for these cases. As a 
consequence, both the fluid velocity at the boundary and the heat transfer coefficient 
become less accurate. You can easily correct this situation by making the mesh finer at 
the boundary at the leading edge of the plate.

References

1. A. Bejan, Heat Transfer, 1993, John Wiley.

2. B. Sundén, “Kompendium i Värmeöverföring,” Department of Heat Transfer, 
LTH, Lund University, Sweden, p. 137, 2004 (in Swedish).
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Modeling in COMSOL Multiphysics

The COMSOL Multiphysics implementation is straightforward using the Chemical 
Engineering Module’s Non-Isothermal Flow multiphysics coupling, combining the 
Convection and Conduction and k-ε Turbulence Model application modes.

Model Library path: Chemical_Engineering_Module/
Heat_Transfer_and_Nonisothermal_Flow/forced_turbulent_convection

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator, and in the Space dimension list select 2D.

2 In the list of application modes, select Chemical Engineering Module> 
Flow With Variable Density>Non-Isothermal Flow>k-ε Turbulence Model.

3 Click OK.

G E O M E T R Y

1 Using the Rectangle dialog box, create two rectangles with specifications according 
to the following table. You launch the Rectangle dialog box by shift-clicking the 
Rectangle/Square button on the Draw toolbar or by choosing 
Specify Objects>Rectangle from the Draw menu.

2 Click the Zoom Extents button on the Main toolbar.

OBJECT WIDTH HEIGHT BASE X Y

R1 1.1 0.2 Corner -0.1 0

R2 1 0.01 Corner 0 0
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You should now see the following geometry:

C O N S T A N T S ,  E X P R E S S I O N S ,  A N D  V A R I A B L E S

1 From the Options menu, open the Constants dialog box. Specify the following 
names, expressions, and descriptions (optional); when finished, click OK.

2 Choose Options>Expressions>Scalar Expressions. Specify the following names, 
expressions, and descriptions (optional); when finished, click OK.

NAME EXPRESSION DESCRIPTION

T_amb 293[K] Surrounding air temperature

delta_T 100[K] Plate-to-air temperature difference

T_av T_amb+delta_T/2 Average temperature

p_ref 1.013e5[Pa] Reference pressure

u_in 1[m/s] Inlet velocity

NAME EXPRESSION DESCRIPTION

L x Distance from leading edge

ReL_ref u_in*L/mat1_nu0(T_av[1/
K])[m^2/s]

Reference Reynolds number
R  3 :  H E A T  TR A N S F E R  A N D  N O N - I S O T H E R M A L  F L O W — TU T O R I A L S  A N D  B E N C H M A R K S



P H Y S I C S  S E T T I N G S

Now it is time to set up the physics in the subdomain and the boundary settings. In 
this model you load the material properties from the built-in material library.

Fluid-Flow Settings (k-ε Turbulence Model)
1 From the Multiphysics menu, select 3 k-ε Turbulence Model.

2 From the Physics menu, select Properties.

3 Set Realizability to On, then click OK.

4 Choose Physics>Subdomain Settings. Select Subdomain 2 (the plate).

5 Select Solid domain from the Group list underneath the Subdomain selection list.

6 Select Subdomain 1 (the fluid). Select Fluid domain in the Group list.

7 Then click the Load button to open the Materials/Coefficients Library dialog box. 
Select Basic Material Properties>Air, 1 atm, then click OK.

8 Next, edit the predefined entry for the dynamic viscosity. To do so, click in the 
Dynamic viscosity edit field replace T with Tf.

9 The expression for the density must also be edited. Click on the Density tab.

10 Click in the Density edit field, and replace p with p_ref and T with Tf; the entry 
should read rho(p_ref[1/Pa],Tf[1/K])[kg/m^3].

11 Clear the Pressure p check box and click OK to close the Subdomain Settings dialog 
box.

Pr_ref mat1_eta(T_av[1/K])[Pa*s]* 
mat1_Cp(T_av[1/K])[J/(kg*K)]/ 
mat1_k(T_av[1/K])[W/(m*K)]

Reference Prandtl number

NuL_ref 0.037*ReL_ref^0.8*Pr_ref^0.33 Reference Nusselt number

h_ref mat1_k(T_av[1/K])[W/(m*K)]* 
NuL_ref/L

Handbook h coefficient

NAME EXPRESSION DESCRIPTION
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12 Choose Physics>Boundary Settings. Then apply the following boundary settings:

The small values of LT and IT are appropriate for essentially non turbulent 
free-stream flows. 

13 Click OK.

Heat Transfer Settings
Now set up the parameters for the heat transfer:

1 From the Multiphysics menu, select 1 Convection and Conduction (chcc).

2 From the Physics menu, select Subdomain Settings.

3 Select Subdomain 2. Then select Solid domain from the Group list.

4 Select Subdomain 1. Select Fluid domain from the Group list. 

5 From the Library material list, select Air, 1 atm.

6 For that material, edit the expressions for the Thermal Conductivity, the Density, and 
the Heat capacity by replacing p with p_ref and T with Tf.

7 Click the Init tab. In the Tf(t0) edit field type T_amb, then click OK.

8 From the Physics menu, open the Boundary Settings dialog box.

9 Specify boundary settings according to the following table. When finished, click OK.

SETTINGS BOUNDARY 1 BOUNDARIES 2, 3 BOUNDARIES 4, 6 BOUNDARY 8

Boundary 
type

Inlet Symmetry boundary Wall Outlet

Boundary 
condition

Velocity - Logarithmic wall 
function

Pressure

 u0 u_in

 v0 0

LT 0.001

IT 0.01

 δw h

 p0 0

SETTINGS BOUNDARY 1 BOUNDARIES 2, 3 BOUNDARIES 4, 6 BOUNDARY 8

Group wall

Boundary 
condition

Temperature Thermal insulation Convective flux

 T0 T_amb
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10 From the Multiphysics menu, select 2 Convection and Conduction (chcc2). 

11 From the Physics menu, select Subdomain Settings.

12 Select Subdomain 1, then select Fluid domain from the Group list.

13 Select Subdomain 2, then select Solid domain from the Group list. 

14 Click the Load button. 

15 From the Materials tree, select Basic Material Properties>Copper. Click OK.

16 Click OK.

17 From the Physics menu, select Boundary Settings.

18 Specify the following boundary conditions; when finished, click OK.

M E S H  G E N E R A T I O N

To solve the problem and get an accurate solution, the mesh must be fine at the solid/
fluid interface, especially at the point of first contact. Generate such a mesh with the 
following steps: 

1 Choose Mesh>Free Mesh Parameters. In the list of Predefined mesh sizes select Coarse.

2 Go to the Boundary page and select Boundaries 4 and 6. Set the Maximum element 

size to 3e-3 and the Element growth rate to 1.2.

3 Go to the Point page and select Point 4. Set the Maximum element size to 1e-3.

4 Click Remesh to generate the mesh. When the mesher has finished, click OK.

C O M P U T I N G  T H E  S O L U T I O N

To solve this model for a range of inlet velocities, use the parametric solver. 

1 Click the Solver Parameters button on the Main toolbar. 

2 From the Solver list, select Parametric Segregated.

3 In the Parameter name edit field type u_in, and in the Parameter values edit field 
type 1 20 50 100.

4 Select the Manual specification of segregated steps check box.

5 Set the Damping for Group 1 to 0.25.

6 Click the Parametric tab. From the Predictor list, select Constant.

SETTINGS BOUNDARY 5 BOUNDARIES 4, 6

Group wall

Boundary condition Temperature

 T0 T_amb+delta_T
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7 Select the Manual tuning of parameter step size check box. In the three edit fields 
(Initial step size, Minimum step size, and Maximum step size) type 9, 5, and 50, 
respectively. These settings force the parameter solver to take larger steps than it 
would do by default, which in turn reduces the solution time.

8 Click OK, then click the Solve button on the Main toolbar. The software needs 
roughly 30 minutes to solve this setup on a 3-GHz PC.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Reproduce the plots in Figure 3-3–Figure 3-6 using the Plot Parameters dialog box.

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, select 1 from the Parameter value list.

3 Click Apply to generate the plot in Figure 3-3.

Proceed to generate the plot in Figure 3-4 of the turbulent thermal conductivity, kT 
with the following steps:

4 On the General page, select 100 from the Parameter value list.

5 Click the Surface tab. Type kT_chcc in the Expression edit field on the Surface Data 
page, then click Apply to generate the plot.

Next reproduce Figure 3-5 as follows:

6 While still on the Surface page, type rho_chcc in the Expression edit field on the 
Surface Data page. 

7 On the General page, select 1 from the Parameter value list. Click Apply.

To generate Figure 3-6 execute the following instructions:

8 Click the Surface tab. From the Predefined quantities list on the Surface Data page, 
select k-ε Turbulence Model (chns)>Velocity field.

9 Click OK.

Use the Domain Plot Parameters dialog box to generate Figure 3-7 and Figure 3-8:

1 From the Postprocessing menu, select Domain Plot Parameters.

2 On the Line/Extrusion page, select Boundary 6.

3 In the y-axis data area, type abs(ntflux_Tf_chcc/(Ts-Tf)) in the Expression edit 
field. From the x-axis data list, select x.

4 Click the Line Settings button. From the Line style list, select Dashed line. Select the 
Legend check box, then click OK.

5 Click Apply to generate the first lines of the plot.
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6 On the General page, select the Keep current plot check box.

7 Return to the Line/Extrusion page. In the Expression edit field, type h_ref.

8 Click the Line Settings button. From the Line style list, select Solid line. Click OK.

9 Click Apply to finalize the plot in Figure 3-7.

Next, turn to the plot in Figure 3-8:

10 On the General page, clear the Keep current plot check box.

11 On the Line/Extrusion page, type dwplus_chns in the Expression edit field.

12 Click OK.
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Hea t i n g  o f  a  F i n i t e  S l a b

Introduction

This simple example covers the heating of a finite slab, modeling how the temperature 
varies with time. You first set up the problem in COMSOL Multiphysics and then 
compare it to the analytical solution given in Ref. 1.

Model Definition

The model domain is defined between x = −b and x = b. The initial temperature is 
constant, equal to T0, over the whole domain; see the figure below. At time t = 0, the 
temperature at both boundaries is lowered to T1.

Figure 3-9: Depiction of the modeling domain.

To compare the modeling results to the literature (Ref. 1), introduce new 
dimensionless variables according to the following definitions:

 (3-3)

The model equation then becomes

 (3-4)

with the associated boundary and initial conditions

 (3-5)

0T(−b,t)=T1 T(b,t)=T1

                   Finite slab

Θ
T1 T–

T1 T0–
-------------------,= η x

b
---,= τ αt
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2

∂
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Results

Figure 3-10 on page 115 shows the temperature as a function of position at the 
dimensionless times τ = 0.01, 0.04, 0.1, 0.2, 0.4, and 0.6. In this plot, the slab’s center 
is situated at x = 0 with its end faces located at x = −1 and x = 1. The temperature 
profiles shown in this graph are identical to the analytical solution given in Carslaw and 
Jaeger (Ref. 1).

Figure 3-10: Results from the simulation at different times.

Reference

1. H. S. Carslaw and J. C. Jaeger, Conduction of Heat in Solids, 2nd ed., Oxford 
University Press, p. 101, 1959.

Model Library path: Chemical_Engineering_Module/
Heat_Transfer_and_Nonisothermal_Flow/slab
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Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics.

2 From the Space dimension list, select 1D.

3 Select Chemical Engineering Module>Energy Transport>Conduction>Transient analysis 
from the application modes list.

4 Click OK.

G E O M E T R Y  M O D E L I N G

1 Choose Draw>Specify Objects>Line.

2 In the Coordinates area, type -1 1 in the x edit field.

3 In the Name edit field, type slab.

4 Click OK.

5 Click the Zoom Extents button.

P H Y S I C S  S E T T I N G S

Model Settings
Because the model uses dimensionless variables, disable unit handling.

1 From the Physics menu, select Model Settings.

2 From the Base unit list, select None.

3 Click OK.

Subdomain Settings
1 From the Physics menu, select Subdomain Settings.

2 Select Subdomain 1.

3 Enter PDE coefficients according to the following table:

4 On the Init page, set T(t0) to 1. 

5 Click OK.

PROPERTY VALUE

 k 1

 ρ 1

 Cp 1
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Boundary Conditions
1 From the Physics menu, select Boundary Settings.

2 Select both boundaries and choose Zero temperature in the Boundary condition list.

3 Click OK.

M E S H  G E N E R A T I O N

1 Click the Mesh button to initialize the mesh.

2 Click the Refine Mesh button once.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 On the General page, type 0:0.01:1 in the Times edit field.

3 Click OK.

4 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows the temperature distribution along the slab for τ = 1.

Figure 3-11: Temperature distribution along the slab at  τ = 1.

You can compare the COMSOL Multiphysics solution to that of  Ref. 1 by plotting the 
temperature for a given set of output times, as in Figure 3-10. To reproduce this plot, 
following these steps:

1 From the Postprocessing menu, select Domain Plot Parameters.

2 On the General page, select the Line/extrusion plot check box in the Plot type area.
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3 From the Solutions to use list, select the time steps 0.01, 0.04, 0.1, 0.2, 0.4, and 0.6 
by holding down the Ctrl key.

4 On the Line/Extrusion page, click the Line Settings button

5 From the Marker type list, select Cycle.

6 Select the Legend check box, then click OK to close the Line Settings dialog box.

7 Click OK to close the Domain Plot Parameters dialog box and generate the plot.
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A 3D Mode l  o f  a  MEMS Hea t  
Ex chang e r

Introduction

The model in this study deals with a micro heat exchanger made of stainless steel. 
These type of heat exchangers are found in lab-on-a-chip devices in biotechnology and 
in microreactors, for example for micro fuel cells. Because of its cross-flow 
construction, you model the heat exchanger in 3D. The model takes heat transferred 
through both convection and conduction into account. The geometry and material 
conditions of the heat exchanger are taken from Ref. 1.

Model Definition

Figure 3-12 shows the geometry of the heat exchanger. A square cross-section is used 
for the fluid channels instead of circular cross-sections, often used in macroscopic heat 
exchangers. The heat exchanger is of cross-flow configuration and can consist of about 
20 unit cells. Because the unit cells are almost identical except for edge effects in the 
outer cells, you can restrict the model to a single unit cell.

Figure 3-12: Depiction of the modeled part of the micro heat exchanger.
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The model equation is a stationary energy transport taking into consideration heat 
transfer through convection and conduction:

 (3-6)

where Cp denotes the specific heat capacity (J/(kg·K)), T is the temperature (K), k is 
the thermal conductivity (W/(m·K)), ρ is the density (kg/m3), u is the velocity (m/
s), and Q is a sink or source term that is set to zero, since there is no production or 
consumption of heat in the device.

Because the model uses the Convection and Conduction application mode, you set the 
velocity, u = (u, v, w), to zero in all directions in the solid parts of the reactor. In the 
channels, you set the velocity field to an analytical expression that approximates fully 
developed laminar flow for a channel of square cross-section. For both the hot and cold 
streams, set the velocity component in the z direction to zero. For the cold stream, the 
 y-component of the velocity is zero while the x-component is given by the expression 
below:

 (3-7)

The following figure explains the notation used in Equation 3-7.

Figure 3-13: Representation of the cross-section in the x-plane of a channel. The y and z 
coordinates in the figure appear in the analytical expression for the velocity vector; see 
Equation 3-7.

By analogy, the velocity component in the hot stream is zero in the x direction while 
the y-component is given by the following expression:

 (3-8)

ρCpu ∇⋅ T ∇ k T∇( )⋅– 0=

u 16umax=
z z0–( ) z1 z–( )

z1 z0–( )2
--------------------------------------

y y0–( ) y1 y–( )

y1 y0–( )2
---------------------------------------

z0

z1

y0 y1

Channel Solid

v 16vmax=
z z0–( ) z1 z–( )

z1 z0–( )2
--------------------------------------

x x0–( ) x1 x–( )

x1 x0–( )2
---------------------------------------
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The boundary conditions are insulating for all outer surfaces except for the inlet and 
outlet boundaries in the fluid channels. At the inlets for both the cold and hot streams 
the temperatures are constant:

 (3-9)

At the outlets, the transport of heat is dominated by convection, so the Convective flux 
boundary condition is suitable:

 (3-10)

This expression sets the conduction term in the outflow direction to zero.

Results

Figure 3-14 shows a few temperature isosurfaces in the device, which clearly reveal the 
influence of the convective term.

Figure 3-14: Isotherms through the cell unit’s geometry.

T Tcold=

T Thot=

k T∇ n⋅ 0=
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Temperature differences between the different outlets in both the hot and cold streams 
imply that the hot stream is not uniformly cooled in the different channels, see 
Figure 3-15.

Figure 3-15: Boundary plot of the temperature in the heat exchanger. The distribution of 
the temperature in the region of the respective outlets leads to the conclusion that the cooling 
is not uniform.

In order to visualize the velocity field in the flow channels, you can look at a sequence 
of cross-section plots perpendicular to the direction of the plot. The velocity profile is 
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almost identical to a fully developed velocity profile. The flow in the figure is 
normalized and the value 1 corresponds to a maximum velocity of 5 mm/s.

Figure 3-16: Normalized velocity profiles in the flow channels.

Reference

1. W. Ehrfeld, V. Hessel, and H. Löwe, Microreactors, Weinheim, 2000.

Model Library path: Chemical_Engineering_Module/
Heat_Transfer_and_Nonisothermal_Flow/mems_heat_exchanger_3d

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics.

2 From the Space dimension list, select 3D.
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3 Select the Chemical Engineering Module>Energy Transport> 
Convection and Conduction application mode.

4 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

2 Define constants according to the table below.

G E O M E T R Y  M O D E L I N G

1 From the Draw menu, select Work-Plane Settings.

2 Click the Quick tab and select y-z plane.

3 Click OK.

4 From the Options menu, select Axes/Grid Settings.

5 Clear the Auto check box.

6 Enter axis values according to the following table:

7 Click the Grid tab.

8 Clear the Auto check box.

9 Set both x spacing and y spacing to 20.

NAME EXPRESSION DESCRIPTION

k1 0.6[W/(m*K)] Thermal conductivity, fluid

C_p1 4200[J/(kg*K)] Heat capacity, fluid

rho1 1000[kg/m^3] Density, fluid

k2 15[W/(m*K)] Thermal conductivity, steel

C_p2 420[J/(kg*K)] Heat capacity, steel

rho2 7800[kg/m^3] Density, steel

T0 300[K] Inlet temperature, cold stream

T1 330[K] Inlet temperature, hot stream

u_max 5[mm/s] Maximum flow velocity, x direction

v_max 5[mm/s] Maximum flow velocity, y direction

x min -10

x max 810

y min -10

y max 110
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10 Click OK.

11 Click the Rectangle/Square button, then click the coordinates (0, 0) and (800, 60).

12 Make another rectangle with opposite corners at the points (200, 0) and (300, 40).

13 Click the Array button on the Draw toolbar.

14 Set x displacement to 120 and Array size x to 5.

15 Click OK.

16 Select all geometry objects by pressing Ctrl+A.

17 Click the Create Composite Object button on the Draw toolbar.

18 In the Set formula edit field, type R1+R2+R3+R4+R5+R6.

19 Make sure that the Keep interior boundaries check box is selected, then click OK.

The 2D cross-section is now ready, and you can extrude it to 3D:

1 From the Draw menu, select Extrude.

2 In the Distance edit field, type 800. Click OK.

3 Make a copy of the 3D object by pressing Ctrl+C.

4 Paste the copy with Ctrl+V.

5 Click the Rotate button on the Draw toolbar.

6 Set the Rotation angle to 180.

7 In the Point on rotation axis edit field, enter the following settings:

8 Specify the Rotation axis direction vector according to:

9 Click OK.

10 Select all geometry objects by pressing Ctrl+A.

11 Click the Scale button.

12 Set the Scale factor to 1e-6 in all directions.

13 Click OK.

x 0

y 0

z 60

x 1

y 1

z 0
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MAIN 12

]+4*120[um]

MAIN 7

]+4*120[um]
14 Click the Zoom Extents button on the Main toolbar.

P H Y S I C S  S E T T I N G S

Subdomain Settings
You need a number of expression variables to express the velocity profile in the 
channels.

1 From the Options menu, choose Expressions>Subdomain Expressions.

2 Specify expressions according to the tables below.

3 Click OK.

4 From the Physics menu, select Subdomain Settings.

5 Enter subdomain properties according to the following table:

NAME SUBDOMAINS 3–7 SUBDOMAINS 8–12

U_expr 16*(z-z0)*(z1-z)/(z1-z0)^2* 
(y-y0)*(y1-y)/(y1-y0)^2

-

V_expr 16*(z-z0)*(z1-z)/(z1-z0)^2* 
(x-x0)*(x1-x)/(x1-x0)^2

z0 -40[um] 80[um]

z1 80[um]+z0 80[um]+z0

x1 - 100[um]+x0

y1 100[um]+y0 -

NAME SUBDOMAIN 8 SUBDOMAIN 9 SUBDOMAIN 10 SUBDOMAIN 11 SUBDO

x0 200[um] 200[um]+1*120[um] 200[um]+2*120[um] 200[um]+3*120[um] 200[um

NAME SUBDOMAIN 3 SUBDOMAIN 4 SUBDOMAIN 5 SUBDOMAIN 6 SUBDO

y0 200[um] 200[um]+1*120[um] 200[um]+2*120[um] 200[um]+3*120[um] 200[um

SETTINGS SUBDOMAINS 1, 2 SUBDOMAINS 3–7 SUBDOMAINS 8–12

 k (isotropic) k2 k1 k1

 ρ rho2 rho1 rho1

 Cp C_p2 C_p1 C_p1

 Q 0 0 0

 u 0 u_max*U_expr 0

 v 0 0 v_max*V_expr

 w 0 0 0
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6 Click OK.

Boundary Conditions
1 From the Physics menu, select Boundary Settings.

2 Enter boundary conditions according to the following table:

3 Click OK.

M E S H  G E N E R A T I O N

Initialize the mesh by pressing the Initialize Mesh button on the Main toolbar.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 On the General page, verify the that the Linear system solver is set to GMRES.

3 Set the Preconditioner to Algebraic multigrid.

4 In the Quality of multigrid hierarchy edit field, type 2.

5 Click OK.

6 Click the Solve button on the Main toolbar.

The model is of a size close to 78,000 degrees of freedom and may need 1 Gigabyte 
of RAM in order to solve.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows slices of the temperature. You reproduce the plots in 
Figure 3-14 on page 121 with the following steps.

1 From the Postprocessing menu, select Plot Parameters.

2 On the General page, clear the Slice check box and select the Isosurface and Edge 
check boxes in the Plot type area.

3 On the Isosurface page, choose Convection and Conduction (chcc)>Temperature from 
the Predefined quantities list.

4 On the Edge page, type 1 in the Expression edit field.

5 Click OK.

SETTINGS BOUNDARIES 8, 
14, 20, 26, 32

BOUNDARIES 41, 
48, 55, 62, 69

BOUNDARIES 44, 51, 
58, 65, 72, 77–81

ALL OTHERS

Boundary 
condition

Temperature Temperature Convective flux Thermal 
insulation

T0 T0 T1
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Generate the plot in Figure 3-15 as follows:

1 From the Postprocessing menu, select Plot Parameters.

2 On the General page, clear the Isosurface check box and select the Boundary check 
box.

3 On the Boundary page, select Convection and Conduction (chcc)>Temperature from 
the Predefined quantities list.

4 Click OK.

Finally, execute the following instructions to reproduce the plots in Figure 3-16:

1 On the General page, clear the Boundary check box and select the Slice check box.

2 On the Slice page, type U_expr in the Expression edit field in the Slice data area.

3 Set x-levels to 1, and y-levels and z-levels to 0.

4 Click Apply.

5 On the General page, check the Keep current plot check box.

6 Return to the Slice page and change the Expression to V_expr.

7 Set y-levels to 1, and x-levels and z-levels to 0.

8 Click OK.
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Non - I s o t h e rma l  F l ow i n  a  Coo l i n g  
P r o c e s s

Introduction

This model highlights the predefined multiphysics coupling Non-Isothermal flow. The 
momentum transport is described by the Weakly Compressible Navier-Stokes 
application mode, which is applicable to flow with velocities less than Mach 0.3 
(approximately 100 m/s for atmospheric air). Below Mach 0.3 pressure expansion 
work done by the gas is negligible.

The following example models the flow of air over a hot fin. The fin heats the fluid, 
and both density and viscosity vary significantly due to the heating. The heat transport 
is defined in both the fin and the air whereas the momentum transport is applied only 
in the air.

Model Definition

The geometry of the domain is shown below. The depth of the flow domain is large 
making a 2D approximation valid, assuming negligible gradients in the depth.

Figure 3-17: Modeling domain of a cooling device. Air enters at the left boundary, flows 
over the fin, and the gas heats up.

The model is described by weakly compressible Navier-Stokes equations and an energy 
transport equation with both convection and conduction; see Equation 3-11 and 
Equation 3-12:

 (3-11)

 (3-12)

3D to 2D

ρu ∇⋅ u ∇ pI– η ∇u ∇u( )T
+( ) 2η 3⁄( ) ∇ u⋅( )I–+[ ]⋅ ρg+=

∇ ρu( )⋅ 0=

ρCpu∇ T⋅ ∇ k T∇( )⋅– 0=
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In these equations, η denotes the viscosity of the solution (kg/(m·s)), u is the velocity 
(m/s), ρ represents density (kg/m3), p is the pressure (Pa), k equals the thermal 
conductivity (W/(m·K)), and Cp is the heat capacity (J/(kg·K)).

Figure 3-18: Definition of boundary conditions.

At the inlet, apply a laminar profile with a maximum velocity of 0.1 m/s. The 
corresponding average velocity is then 

.  (3-13)

At the outlet, the viscous stress is assumed to be zero, and the pressure is set according 
to the atmospheric conditions:

 (3-14)

At all other boundaries, use a no-slip condition:

 (3-15)

For the energy transport, set the inlet temperature to 298 K, and at the top surface of 
the fin to 398 K.

 (3-16)

At the outlet, apply convective flux as a boundary condition. It assumes that heat 
transport is dominated by convection and follows from

 (3-17)

This implies that the gradient of T in the direction perpendicular to the outlet 
boundary is negligible. At all other boundaries, insulating conditions apply:

OutletInlet

Upper surface
of the fin

uaverage
2
3
---u

max
=

p 105 Pa=

u 0=

T T0 inlet,=

T T0 fin,=

n k T∇( )⋅ 0=
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 (3-18)

Use material properties of atmospheric air for the fluid and those of copper for the fin. 
The viscosity varies with temperature and the density follows from the ideal gas law, 
varying with temperature and pressure. The model loads material properties from the 
built-in materials database.

Results

Results from the simulation show a clear influence of temperature on the velocity 
profile emerging from variations in density. Figure 3-19 shows a temperature 
distribution in the gas phase that is fairly large and will give rise to a significant effect 
on the flow profile.

Figure 3-19: Temperature distribution in both the flowing gas and the fin.

n k T ρCpT u+∇–( )⋅ 0=
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Density varies with the inverse of the temperature, as seen in Figure 3-20.

Figure 3-20: Gas density distribution in the cooling device.

This variation has a direct influence on the velocity profile seen in Figure 3-21. At the 
outlet the flow reaches an almost fully developed profile but with an average velocity 
that is approximately 6.4% higher than the inlet value. The increased velocity is a 
consequence of the thermal gas expansion caused by the density decrease.

Figure 3-21: Velocity field distribution (left) in the cooling device and cross-sectional plots 
of the velocity field (right) at the inlet (solid line) and outlet (dashed line).
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Accounting for the temperature effects on fluid flow can be important. In this example, 
you can observe the effect of expansion as an increase in velocity.

Model Library path: Chemical_Engineering_Module/
Heat_Transfer_and_Nonisothermal_Flow/nonisothermal_flow

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics.

2 From the list of application modes, select Chemical Engineering Module> 
Flow with Variable Density>Non-Isothermal Flow>Laminar.

3 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 Open the Axes/Grid Settings dialog box from the Options menu and specify x-y limits 
according to the table below.

2 Click the Grid tab. Clear the Auto check box and specify x spacing and y spacing values 
according to the table below.

3 Click OK. These axis/grid settings produce a suitable grid for drawing the geometry.

4 From the Options menu, select Constants. 

PROPERTY VALUE

x min -0.1e-2

x max 2.9e-2

y min 0.5e-2

y max 2.5e-2

PROPERTY VALUE

x spacing 0.2e-2

y spacing 0.2e-2
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5 Define the following constants (the descriptions are optional):

6 Click OK.

G E O M E T R Y  M O D E L I N G

To draw the cooling fin, combine the Line and the 2nd Degree Bézier Curve tools. 

1 Select the Line tool on the Draw toolbar and click the coordinates (0, 2.4·10−2) and 
(0, 1.2·10−2).

2 Switch to the 2nd Degree Bézier Curve tool and click (0, 1·10−2), (0.2·10−2, 1·10−2), 
(0.4·10−2, 1·10−2), and (0.4·10−2, 1.2·10−2).

3 Switch back to the Line tool and click (0.4·10−2, 2·10−2), (0.8·10−2, 2·10−2), and 
(0.8·10−2, 1.2·10−2).

4 Click the 2nd Degree Bézier Curve tool again and click on the coordinates (0.8, 1), 
(1·10−2, 1·10−2), (1.2·10−2, 1·10−2), and (1.2·10−2, 1.2·10−2).

5 Click the Line tool and the coordinates (1.2·10−2, 2·10−2), (1.6·10−2, 2·10−2), and 
(1.6·10−2, 1.2·10−2)

6 Click the 2nd Degree Bézier Curve tool followed by the coordinates 
(1.6·10−2, 1·10−2), (1.8·10−2, 1·10−2), (2·10−2, 1·10−2), and (2·10−2, 1.2·10−2).

7 Click the Line tool followed by the coordinates the coordinates (2e-2, 2e-2), 
(2.4·10−2, 2·10−2), and (2.4·10−2, 1.2·10−2).

8 Click the 2nd Degree Bézier Curve tool followed by the coordinates 
(2.4·10−2, 1·10−2), (2.6·10−2, 1·10−2), (2.8·10−2, 1·10−2), and 
(2.8·10−2, 1.2·10−2).

9 Click the Line tool, click (2.8·10−2, 2.4·10−2) and click the right mouse button.

This creates the composite object CO1.

10 Press the Shift key and click the Rectangle/Square button. The Rectangle dialog box 
appears.

NAME EXPRESSION DESCRIPTION

u_max 0.1[m/s] Maximum inlet velocity

p0 1e5[Pa] Outlet pressure

T_in 298[K] Inlet temperature

T_hot 398[K] Fin hot side temperature
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11 Specify properties according to the following table:

12 Click OK.

13 Select the object CO1 and copy it by clicking the Copy button or by pressing Ctrl+C.

14 Click the Create Composite Object button and type R1-CO1 in the Set formula edit 
field.

15 Click OK.

16 Click the Paste button.

17 Click OK in the Paste dialog box.

18 Click the Zoom Extents button on the Main toolbar.

The final geometry is now ready.

PROPERTY VALUE

Width 14e-2

Height 2e-2

x position -4e-2

y position 0
N O N - I S O T H E R M A L  F L O W  I N  A  C O O L I N G  P R O C E S S  |  135



136 |  C H A P T E
P H Y S I C S  S E T T I N G S

Subdomain Settings—Weakly Compressible Navier-Stokes
1 From the Multiphysics menu, select Weakly Compressible Navier-Stokes (chns).

2 From the Physics menu, select Subdomain Settings.

3 Select Subdomain 2, then clear the Active in this domain check box. This action 
disables the flow application in the solid fin part of the geometry.

4 Select Subdomain 1, then click the Load button. This opens the Materials/Coefficients 

Library dialog box. 

5 From the Materials list, select Basic Material Properties>Air, 1 atm. Click OK.

6 On the Init page, type p0 in the p(t0) edit field to specify the initial pressure value.

7 Click OK.

Boundary Conditions—Weakly Compressible Navier-Stokes
1 From the Physics menu, select Boundary Settings.

2 Specify boundary conditions according to the table below.

Note that the default boundary condition is No slip at exterior boundaries.

3 Click OK.

Subdomain Settings—Heat Transfer
1 In the Multiphysics menu, switch to Convection and Conduction (chcc).

2 From the Physics menu, select Subdomain Settings. 

3 Select Subdomain 1, then select Air, 1 atm from the Library material list.

4 Select Subdomain 2, then select Solid domain from the Group list.

5 Click the Load button. In the Materials list, select Basic Material Properties>Copper, 
then click OK.

6 Click the Init tab.

7 Select both subdomains. Set T(t0) to T_in, then click OK.

SETTINGS BOUNDARY 1 BOUNDARY 19 ALL OTHERS

Type Inlet Outlet Wall

Condition Laminar inflow Pressure, no viscous stress No slip

U0 2/3*u_max

p0 p0
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Boundary Conditions—Heat Transfer
In the same way as just done, define the boundary conditions according to the table 
below in the Boundary Settings dialog box.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters.

2 From the Predefined mesh sizes list, select Finer. Click Remesh. This produces a mesh 
of approximately 2800 elements.

3 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

SETTINGS BOUNDARY 1 BOUNDARY 6 BOUNDARY 19 ALL OTHER BOUNDARIES

Boundary 
condition

Temperature Temperature Convective flux Thermal insulation

T0 T_in T_hot
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P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows the velocity field as seen in the following figure. Because of the 
reduced cross section, the velocity increases in the vicinity of the fin. Thermal 
expansion caused by the heating also accelerates the air.

To visualize the temperature field, follow these steps:

1 Select Postprocessing>Plot Parameters.

2 Click the Surface tab.

3 From the Predefined quantities list on the Surface Data page, select 
Convection and Conduction (chcc)>Temperature.
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4 Click OK to get the following plot:

The air heats up as it passes the fin. This temperature increase causes the density and 
viscosity to decrease. To visualize the density of the air follow these steps:

1 Click the Plot parameters button on the Main toolbar.

2 On the Surface page, type rho_chns in the Expression edit field. The variable 
rho_chns is the flow applications variable for density.

3 Click OK to produce the following plot:
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The density variation leads to a slight expansion of the air and a higher outlet velocity. 
You can visualize the velocity profile upstream and downstream the fin by creating a 
multiple-line cross-section plot according to the following instructions:

1 From the Postprocessing menu, select Cross-Section Plot Parameters.

2 On the Line/Extrusion page enter the Cross-section line data given in the following 
table.

3 Select the Multiple parallel lines check box.

4 Click the Vector with distances button and type 0 10e-2 in the associated edit field.

5 Click OK.

x0 -2e-2

x1 -2e-2

y0 2e-2

y1 0
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The figure shows that the velocity profile is unsymmetrical and that the maximum 
velocity shifts toward the top wall as the air passes the fin.

To investigate the influence of the density variation on the average flow rate, that is, 
the fluid expansion, integrate the velocity divided by the channel width to compute the 
average velocity at the inlet and outlet. Use the following steps:

1 From the Postprocessing menu, select Boundary Integration.

2 Select Boundary 1 (the inlet) and type u/2[cm] in the Expression edit field. By thus 
dividing the velocity with the channel height you obtain the average inlet velocity. 

3 Click Apply to see the result displayed in the message log at the bottom of the main 
COMSOL Multiphysics window. The result should be approximately 0.0667 m/s, 
(2/3 of the maximum velocity).

4 Select Boundary 19 (the outlet), then click OK. This should give you a value near 
0.0713 m/s for the average outlet velocity.

This means that the fluid has experienced an expansion of approximately 6.4%.
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MEMS Hea t  Ex c h ang e r

Introduction

One of the most common devices in unit operations is the heat exchanger, which can 
both cool and heat fluids and solid materials. Cooling is a needed process for several 
reasons: materials are sensitive to high temperatures; operating conditions might not 
be optimal for high temperatures; or it might just be for practical or environmental 
reasons that you want to keep a temperature low. Heat exchangers are most often used 
in processes to remove heat when convective cooling from fans and fins isn’t adequate. 
Heating is also used in many processes to keep a fluid at a given elevated temperature.

Model Definition

The model focuses on heat transport in a very small heat exchanger that is common in 
the field of microelectromechanical systems (MEMS). In this case, it might be a 
reactive processes that needs heating. The heat exchanger is constructed by stacking 
several pleated sheets or plates on top of each other while leaving a gap between them. 
The heating fluid circulates in the gaps between the corrugated walls where the fluid 
to be heated flows. To simplify the modeling process, this example studies only a cross 
section between two plates whose shapes in this case are sinusoidal to provide an 
optimal heat-transfer area. Figure 3-22 depicts a section of the heat exchanger.

Figure 3-22: MEMS heat-exchanger geometry (Ref. 1).

Tout

Tin
Tw
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The medium is plain water, and the operating temperature range spans from 0 °C to 
100 °C. Because the viscosity and heat capacity change significantly in this temperature 
interval, their values are obtained from temperature-dependent polynomials.

The viscosity varies according to the expression

 (3-19)

where the temperature, T, must be expressed in kelvin (K). Similarly, the heat capacity 
of water is expressed by

 (3-20)

Again, the temperature must be given in kelvin. The governing equations in this 
system are the incompressible Navier-Stokes equations accounting for the motion of 
the fluid:

 (3-21)

and the convection and conduction equation, without any heat sources, for the energy 
transport within the fluid:

 (3-22)

At the inlet, you specify a parabolic velocity profile with a known constant temperature. 
The analytic solution for a fully developed laminar flow profile between two parallel 
plates at distance 2B from each other is

 (3-23)

Here u is the local velocity and uav is the average velocity. The x-origin is taken at the 
middle of the plates. In the model, you can make use of the dimensionless boundary 
length parameter s (which goes from 0 to 1 from the start to the end of a boundary) 
to create this profile as an inlet boundary condition. The boundary conditions then 
become

 (3-24)

 (3-25)

η 0.011021 9.386·10 4– T– 2.684·10 6– T2 2.569·10 9– T3   Pa·s–+=

Cp 4190.86 0.977T– 0.019T2 5.6·10 5– T3   J/(kg·K)–+=

∇ η ∇u ∇u( )T
+( )⋅– ρ u ∇⋅( )u ∇p+ + 0=

∇ u⋅ 0=

ρCpu∇ T⋅ ∇ k T∇( )⋅– 0=

u 3
2
---u

av
1 x

B
----⎝ ⎠
⎛ ⎞ 2

–=

u n⋅ 6uav s 1 s–( )=

T Tin=
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The walls have no-slip conditions for velocity and a specified temperature condition for 
the energy transport:

 (3-26)

Finally, at the outlet boundary, the pressure (disregarding viscous stress) and the 
conductive heat flux are zero:

.  (3-27)

Results

Figure 3-23 shows the temperature profile along the length of the heat exchanger.

Figure 3-23: Temperature field along the length of the modeling domain.

To be able to calculate the heat exchanger’s overall performance, you must find the 
mean temperature at the exchanger’s outlet. The mixing-cup temperature of the fluid 
leaving the heat exchanger is calculated through

u 0=

T Tw=

p 0=

n k T∇–( )⋅ 0=
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 (3-28)

where s ∈ [ 0, 1 ] parameterizes the boundary. It is easy to compute the result in 
COMSOL Multiphysics, and the mixing cup temperature is

.  (3-29)

Reference

1. W. Ehrfeldt, V. Hessel, and H. Löwe, Microreactors, Wiley-VCH, 2000.

Model Library path: Chemical_Engineering_Module/
Heat_Transfer_and_Nonisothermal_Flow/sinusoidal_heat_exchanger

Modeling Using the Graphical User Interface

1 Open COMSOL Multiphysics.

2 In the Model Navigator, set the Space dimension to 2D.

3 From the list of application modes, select 
Chemical Engineering Module>Momentum Transport>Laminar Flow> 

Incompressible Navier-Stokes.

4 Click fist the Multiphysics button and then the Add button to add the application 
mode to the model.

5 Select the application mode Chemical Engineering Module>Energy Transport> 
Convection and Conduction.

6 Click Add, then click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

T〈 〉

Tu sd
s
∫

u sd
s
∫

------------------=

T〈 〉 5.058·10 3–

1.50·10 5–
---------------------------- 337 K= =
M E M S  H E A T  E X C H A N G E R  |  145



146 |  C H A P T E
1 Enter the following variable names, expressions, and (optionally) descriptions.

2 From the Options menu, open the Axes/Grid Settings dialog box. 

3 Set x min to -5e-5, x max to 105e-5, y min to -5e-5, and y max to 105e-5.

4 On the Grid page, clear the Auto check box.

5 Type 5e-5 in both the x spacing and y spacing edit fields, then click OK.

G E O M E T R Y  M O D E L I N G

1 Double-click the SOLID button in the status bar near the bottom of the user interface 
to clear the solidification option. This allows you to create open-ended line 
segments.

2 Click the 2nd Degree Bézier Curve button on the Draw toolbar.

3 Click on the points (0, 0.7e-3), (0.15e-3, 1e-3), and (0.3e-3, 0.7e-3).

4 Click the Line button on the Draw toolbar.

5 Draw a straight line from (0.3e-3, 0.7e-3) to (0.5e-3, 0.3e-3). Right-click to 
terminate the line. 

6 Draw a second Bézier curve through the points (0.5e-3, 0.3e-3), (0.65e-3, 0), and 
(0.8e-3, 0.30e-3).

NAME EXPRESSION DESCRIPTION

rho_c 985[kg/m^3] Fluid density

k_c 0.6[W/(m*K)] Fluid thermal conductivity

T_w 350[K] Wall temperature

T_in 300[K] Inlet temperature

u_av 15[mm/s] Average inlet velocity
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7 Finish by drawing a line with the endpoints (0.8e-3, 0.30e-3), (1e-3, 0.70e-3).

8 Press Ctrl+A to select all segments. Click the Array button and specify the following 
values; when done, click OK.

9 Open the Axes/Grid Settings dialog box under the Options menu. On the Axis page, 
select the Axis equal check box. On the Grid page clear the Auto check box, then type 
5e-5 in both the x-spacing and y-spacing edit fields. Using a space-separated format, 
enter 1.5e-4 0.00965 in the Extra x edit field and then -9e-4 -2.5e-4 3e-4 
8.5e-4 in the Extra y edit field. Click OK.

10 Click the Zoom Window button on the Main toolbar and zoom in on the left-most 
few bends of the heat exchanger.

11 Click the Line button on the Draw toolbar and draw two straight lines, the first one 
from (1.5·10−4, 8.5·10−4) to (1.5·10−4, −2.5·10−4). Zoom out and the back in on 
the right portion of the geometry and draw the second line from (9.65·10−3, 
0.3·10−3) to (9.65·10−3, −0.9·10−3).

COMPONENT DISPLACEMENT ARRAY SIZE

x 1e-3 10

y -1e-3 2
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12 Press Ctrl+A to select all the segments, then click the Coerce to Solid button on the 
Draw toolbar.

13 Click the Zoom Extents button on the Main toolbar.

P H Y S I C S  S E T T I N G S

Subdomain Expressions
1 From the Options menu, select Expressions>Subdomain Expressions.

2 Select Subdomain 1, then enter the following variable names and expressions:

3 Click OK.

Subdomain Settings—Incompressible Navier-Stokes
1 From the Multiphysics menu choose 1 Incompressible Navier-Stokes (chns).

NAME EXPRESSION

eta (0.11021-9.386e-4[1/K]*T+2.684e-6[1/K^2]*T^2 
-2.569e-9[1/K^3]*T^3)[Pa*s]

C_p (4190.86-0.977[1/K]*T+0.019[1/K^2]*T^2 
-5.6e-5[1/K^3]*T^3)[J/(kg*K)]
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2 From the Physics menu open the Subdomain Settings dialog box.

3 Select Subdomain 1, then enter material properties according to the following table:

4 Switch to the Init page, then enter u_av for the u(t0) initial value.

5 Click OK.

Boundary Conditions—Incompressible Navier-Stokes
1 From the Physics menu open the Boundary Settings dialog box, select Boundary 1, 

and select Inlet from the Boundary type list and Velocity from the Boundary condition 
list. Set the parabolic velocity profile by typing 6*s*(1-s)*u_av in the u0 edit field.

2 Select the type Outlet and the condition Pressure, no viscous stress condition for 
Boundary 40, and set p0 to 0.

3 Click OK.

Subdomain Settings—Convection and Conduction
1 From the Multiphysics menu switch to the 2 Convection and Conduction (chcc) 

application mode.

2 From the Physics menu, select Subdomain Settings.

3 Select Subdomain 1, then specify values according to the following table:

4 Click the Artificial Diffusion button. Select the Streamline Diffusion check box. Click 
OK to accept the default settings and close the Artificial Diffusion dialog box.

This step adds a weak term that gives explicit streamline diffusion to the dependent 
variable T. This stabilizes the temperature field by damping oscillations produced by 
the discretization. For a more comprehensive explanation of streamline diffusion 
stabilization consult the COMSOL Multiphysics User’s Guide.

PROPERTY VALUE

 ρ rho_c

 η eta

PROPERTY VALUE

k (isotropic) k_c

 ρ rho_c

Cp C_p

Q 0

u u

v v
M E M S  H E A T  E X C H A N G E R  |  149



150 |  C H A P T E
5 On the Init page, set the initial value T(t0) to T_w. 

6 Click OK.

Boundary Conditions—Convection and Conduction
1 Open the Boundary Settings dialog box from the Physics menu and specify conditions 

according to the following table:

2 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters.

2 From the Predefined mesh sizes list, select Finer. Click OK.

3 Click the Initialize Mesh button on the Main toolbar.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Click the Plot Parameters button on the Main toolbar to open the Plot Parameters 
dialog box.

2 On the Surface page, type T in the Expression edit field (or select Convection and 

Conduction (chcc)>Temperature from the Predefined quantities list). Click OK.

To calculate the integral in Equation 3-28, proceed as follows:

3 From the Postprocessing menu, select Boundary Integration. Select Boundary 40, 
then type T*u in the Expression edit field. Click Apply. The value appears in the 
message log at the bottom of the user interface.

4 Change the entry in the in the Expression edit field to u, then click OK.

5 Divide the value from Step 3 with that from Step 4 to obtain the mean temperature.

SETTINGS BOUNDARY 1 BOUNDARIES 2–39, 41–80 BOUNDARY 40

Type Temperature Temperature Convective flux

T0 T_in T_w
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 4
M u l t i c o m p o n e n t  T r a n s p o r t— T u t o r i a l s  
a n d  B e n c h m a r k s
There are two different ways of performing multicomponent analysis in the 
Chemical Engineering Module. One is appropriate for diluted solutions and is 
found in the Diffusion and Convection application mode. The other one can be 
used for concentrated solutions, and is found in the Maxwell-Stefan Diffusion and 
Convection application mode. The use of both of these is exemplified in this 
section.
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S e p a r a t i o n  t h r o u gh D i a l y s i s

Introduction

Dialysis is a frequently used membrane separation process. An important application is 
hemodialysis, where membranes are used as artificial kidneys for people suffering from 
renal failure. Other applications include the recovery of caustic colloidal hemicellulose 
during viscose manufacturing, and the removal of alcohol from beer (Ref. 1).

In the dialysis process, specific components are preferentially transported through a 
membrane. The process is diffusion-driven, that is, components diffuse through a 
membrane due to concentration differences between the dialysate and the permeate 
sides of the membrane. Separation between solutes is obtained as a result of differences 
in diffusion rates across the membrane arising from differences in molecular size and 
solubility.

This example looks at a process aimed at lowering the concentration of a contaminant 
component in an aqueous product stream. The dialysis equipment is made of a hollow 
fiber module, where a large number of hollow fibers act as the membrane. It focuses 
on the transport of the contaminant in the hollow fiber and through its wall.

Figure 4-1 shows a diagram of the hollow fiber assembly. A large number of hollow 
fibers are assembled in a module where the dialysate flows on the fibers’ insides while 
the permeate flows on their outsides in a co-current manner. The contaminant diffuses 
through the fiber walls to the permeate side due to a concentration gradient, whereas 
species with a higher molecular weight, those you want kept in the dialysate, are 
retained due to their low solubility and diffusivity in the membrane.

Figure 4-1: Diagram of the hollow fiber module.
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Model Definition

This example models a piece of hollow fiber through which the dialysate flows with a 
fully developed laminar parabolic velocity profile. The fiber is surrounded by a 
permeate, which flows laminarly in the same direction as the dialysate. This example 
thus models three separate phases: the dialysate, the membrane, and the permeate. The 
model domain appears in Figure 4-2. Assume there are no angular gradients, so you 
can thus use an axisymmetrical approximation.

Figure 4-2: Diagram of the dialysis fiber.

The contaminant is transported by diffusion and convection in the two liquid phases, 
whereas diffusion is the only transport mechanism in the membrane phase. You can 
formulate the following mass transport equations to describe the system:

 (4-1)

where ci denotes the concentration of the contaminant (mol/m3) in the respective 
phases, D denotes the diffusion coefficient (m2/s) in the liquid phases, and Dm is the 

∇ D– ∇c1 c1u+( )⋅ 0= in Ωdialysate

∇ D– m∇c2( )⋅ 0= in Ωmembrane

∇ D– ∇c3 c3u+( )⋅ 0= in Ωpermeate
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diffusion coefficient in the membrane, while u denotes the velocity (m/s) in the 
respective liquid phase.

The fiber is 75 times longer than its radial dimension, in this case 0.28 mm in radius 
and 21 mm in length. To avoid excessive amounts of elements and nodes you must 
scale the problem. Therefore introduce a new scaled z-coordinate, , and a 
corresponding differential for the mass transports:

 (4-2)

In the mass-transport equations, c is differentiated twice in the diffusion term, which 
implies that the diffusive flux vector’s z-component must be multiplied by (1/scale)2. 
The convective component is only differentiated once, and therefore must be 
multiplied by 1/scale. You can introduce the scaling of the diffusive part of the flux 
as an anisotropic diffusion coefficient where the diffusion in the z direction is scaled by 
the factor (1/scale)2. This gives the following diffusion-coefficient matrix:

 (4-3)

To obtain the convective part of the flux, assume fully developed laminar flow both 
inside and outside the hollow fiber. This allows you to introduce the velocity 
distributions analytically. For the interior, this example uses the following velocity 
distribution (Ref. 2):

 (4-4)

where vz is the axial component of the velocity, vmax is the maximum velocity in the 
axial direction, r represents the radial coordinate, and R1 equals the inner radius of the 
hollow fiber. The velocity vector must be multiplied by 1/scale to account for the new 
scaled z-coordinate.

ẑ

ẑ z
scale
---------------=

dz scale dẑ⋅=

D
D 0

0 D

scale2
-----------------

=

vz
dialysate vmax 1 r

R1
------⎝ ⎠
⎛ ⎞ 2

–=
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Outside the fiber the velocity profile is more complicated. You can draw a 
hexagonal-shaped unit cell of the fiber assembly (Figure 4-3):

Figure 4-3: Hexagonal-shaped unit cell of the fiber assembly.

By approximating the hexagon with a circle, you can assume that the circle indicates 
the permeate’s position of maximum velocity in the axial direction. In order to 
characterize the flow profile, the model twice integrates a momentum balance over a 
thin cylindrical shell (Ref. 2) to eventually get the following analytical expression for 
the permeate velocity distribution:

 (4-5)

Here A (1/(m·s)) is a constant defined by

.  (4-6)

In these equations, R2 and R3 are the radial coordinates of the outer fiber wall and the 
approximated circle, respectively, η (Pa·s) is the permeate’s dynamic viscosity, and 
P0 − PL (Pa) represents the pressure drop over a length L.

The contaminant must dissolve into the membrane phase in order to be transported 
through it. The interface conditions between the liquid and membrane phases for the 
concentration are described by the dimensionless partition coefficient, K:

.  (4-7)

v
ẑ
permeate A r2 R2

2– 2 R3
2 r

R2
-------⎝ ⎠
⎛ ⎞ln⋅ ⋅–⋅=

A
P0 PL–

4ηL scale⋅
-------------------------------–=

K
c2

d

c1
d

-----
c2

p

c3
p

-----= =
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Figure 4-4 shows a schematic concentration profile. Note that there are discontinuities 
in the concentration profile at the phase boundaries.

Figure 4-4: Diagram of the concentration profile across the membrane (see Equation 4-7).

To obtain a well-posed problem, you must define an appropriate set of boundary 
conditions; for the relevant notation, see Figure 4-5.

Figure 4-5: Boundaries and boundary labels for the modeled system.

At the inlet to the model domain, define concentration conditions as:
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 (4-8)

At the outlet, assume that the convective contribution to the mass transport is much 
larger than the diffusive contribution:

 (4-9)

Here n is the normal unit vector to the respective boundary. Further, assume that you 
have no transport over the symmetry boundaries:

.  (4-10)

Also assume symmetry at the horizontal boundaries of the membrane:

.  (4-11)

You can verify this assumption after solving the model by studying the very small 
vertical concentration gradient in the membrane.

M O D E L  D A T A

The input data used in this model are listed in the following table:

PROPERTY VALUE DESCRIPTION

 D 10-9 m2/s Diffusion coefficient, liquid phases

 Dm 10-9 m2/s Diffusion coefficient, membrane

 R1 0.2 mm Inner radius, hollow fiber

 R2 0.28 mm Outer radius, hollow fiber

 R3 0.7 mm Approximative radius, unit cell

 vmax 1 mm/s Maximum velocity, dialysate

 A -2·10-3 1/(m·s) Permeate velocity prefactor

 K 0.7 Partition coefficient

 c0 1 M Inlet concentration, dialysate

 M 104 m/s Stiff-spring velocity

 scale 7 Axial coordinate scale factor

c1 c0= at ∂Ωd, in

c3 0= at ∂Ωp, in

D– ∇ci ciu+( ) n⋅ ciu n   at ∂Ωd,out and ∂Ωp, out⋅=

D– ∇ci ciu+( ) n⋅ 0   at  ∂Ωd, sym and ∂Ωp, sym=

Dm– ∇c2( ) n⋅ 0   at ∂Ωm, high and ∂Ωm, low=
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Results

The surface plot in Figure 4-6 visualizes the concentration distribution throughout the 
three model domains: the dialysate region inside the hollow fiber on the left side, the 
membrane in the middle, and the permeate to the right.

As the plot shows, the concentration inside the hollow fiber decreases markedly over 
the first 10 mm from the inlet. After this the separation process is less effective. You 
can also see from the plot that it takes almost 4 mm before the concentration in the 
core part of the fiber is influenced by the filtration process. The figure further shows 
the developing diffusion layers on both sides of the fiber wall.

Figure 4-6: Concentration and flux in the three subdomains.

The figure also shows the concentration jump that arises at the boundary between the 
dialysate and the membrane. Further, the maximum concentration in the permeate 
occurs a few millimeters downstream from the inlet. If there is a risk of scaling on the 
fiber’s outer surface due to high concentration of filtrated species, it is largest at the 
location of this maximum.

Note that this example models only a short piece at the hollow fiber’s inlet end. Using 
a larger scale factor you can model the fiber’s entire length.
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Modeling in COMSOL Multiphysics

Because there are discontinuities in the concentration profile at the boundaries 
between liquid and membrane phases, you must use three separate variables to describe 
the concentration in the respective phases. To get continuous flux over the phase 
boundaries, apply a special type of boundary condition using the stiff-spring method. 
Instead of defining Dirichlet concentration conditions according to the partition 
coefficient K, which would destroy the continuity of the flux, you can define 
continuous flux conditions that, at the same time, force the concentrations to the 
desired values:

 (4-12)

Here M is a (nonphysical) velocity large enough to let the concentration differences in 
the brackets approach zero, thereby satisfying Equation 4-7. These boundary 
conditions also give a continuous flux across the interfaces provided that M is 
sufficiently large.

References

1. M. Mulder, Basic Principles of Membrane Technology, 2nd ed., Kluwer Academic 
Publishers, 1998.

2. R. B. Bird, W.E. Stewart, and E.N. Lightfoot, Transport Phenomena, John Wiley 
& Sons, 1960.

Model Library path:  

Chemical_Engineering_Module/Multicomponent_Transport/dialysis

D– ∇c1 c1u+( ) n⋅ M c2 Kc1–( )= at ∂Ωd/m

Dm– ∇c2( ) n⋅ M Kc1 c2–( )= at ∂Ωm/d

Dm– ∇c2( ) n⋅ M Kc3 c2–( )= at ∂Ωm/p

D– ∇c3 c3u+( ) n⋅ M c2 Kc3–( )= at ∂Ωp/m
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Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics.

2 In the Model Navigator click the Multiphysics button.

3 From the space Space Dimension list, select Axial symmetry (2D).

4 In the list of application modes select Chemical Engineering Module> 
Mass Transport>Convection and Diffusion. 

5 In the Dependent variables edit field, type c1. Click the Add button.

6 Repeat the procedure for the application mode Chemical Engineering Module> 
Mass Transport>Diffusion and name the dependent variable c2.

7 Finally add a second instance of the Chemical Engineering Module> 
Mass Transport>Convection and Diffusion application mode, but this time name the 
variable c3.

8 Click OK to close the Model Navigator.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

2 Define the following constants (the descriptions are optional); when done, click OK.

G E O M E T R Y  M O D E L I N G

1 Click the Rectangle/Square button on the Draw toolbar and draw a rectangle of 
arbitrary size. Repeat this procedure once to obtain two rectangles in total.

NAME EXPRESSION DESCRIPTION

D 1e-9[m^2/s] Diffusion constant, liquid phases

Dm 1e-9[m^2/s] Diffusion constant, membrane

M 1e4[m/s] Stiff-spring velocity

K 0.7 Partition coefficient

c0 1[mol/liter] Inlet concentration, dialysate

R1 0.2[mm] Inner radius, hollow fiber

R2 0.28[mm] Outer radius, hollow fiber

R3 0.7[mm] Approximate radius, unit cell

v1_max 1[mm/s] Maximum velocity, dialysate

A -2e3[1/(m*s)] Permeate velocity prefactor

scale 7 Axial coordinate scale factor
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2 Double-click on each rectangle in turn and enter the following values in the 
appropriate edit fields; when done, click OK.

3 Click the Zoom Extents button on the Main toolbar.

P H Y S I C S  S E T T I N G S

Subdomain Expressions
For postprocessing purposes, define a concentration variable, call, that evaluates to the 
concentration variables c1, c2, and c3, respectively, in Subdomains 1, 2, and 3.

1 Choose Options>Expressions>Subdomain Expressions.

2 Select Subdomain 1. Type c_all in the first Name edit field and c1 in the Expression 

edit field.

3 Select Subdomain 2. Type c2 in the Expression edit field for c_all.

4 Select Subdomain 3. Type c3 in the Expression edit field for c_all.

5 Click OK to close the Subdomain Expressions dialog box.

Subdomain Settings—Convection and Diffusion (chcd)
1 From the Multiphysics menu, select 1 Convection and Diffusion (chcd).

2 From the Physics menu, select Subdomain Settings.

3 Select Subdomains 2 and 3, then clear the Active in this domain check box.

4 Select Subdomain 1.

5 Click the D (anisotropic) button. Place the cursor in the edit field next to this button. 
In the diffusivity edit-field matrix that appears, type D in the rr-component (upper 
left) and D/scale^2 in the zz-component (lower right).

6 Click the Init tab, then type c0 in the c1(t0) edit field.

7 Click OK.

Boundary Conditions—Convection and Diffusion (chcd)
1 From the Physics menu, select Boundary Settings.

PROPERTY R1 R2

Width 2.8e-4 5e-4

Height 3e-3 3e-3

r 0 2e-4

z 0 0
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2 Enter boundary conditions according to the following table; when done, click OK.

Subdomain Settings—Diffusion (chdi)
1 From the Multiphysics menu, select 2 Diffusion (chdi).

2 From the Physics menu, select Subdomain Settings.

3 Select Subdomains 1 and 3, then clear the Active in this domain check box.

4 Select Subdomain 2, then enter the anisotropic diffusivity in the same manner as for 
the previous application mode using the following data:

Boundary Conditions—Diffusion (chdi)
1 From the Physics menu, select Boundary Settings. 

2 Enter boundary conditions according to the following table; when done, click OK.

Subdomain Settings—Convection and Diffusion (chcd2)
1 From the Multiphysics menu, select 3 Convection and Diffusion (chcd2).

2 From the Physics menu, select Subdomain Settings.

3 Select Subdomains 1 and 2, then clear the Active in this domain check box.

4 Select Subdomain 3, then enter the anisotropic diffusivity in the same manner as for 
the previous application modes using the following data:

SETTINGS BOUNDARY 1 BOUNDARY 2 BOUNDARY 3 BOUNDARY 4

Type Insulation/ 
symmetry

Concentration Convective flux Flux

c10 c0

N0 M*(c2-K*c1)

PROPERTY VALUE

D (r direction) Dm

D (z direction) Dm/(scale^2)

R 0

SETTINGS BOUNDARY 4 BOUNDARIES 5, 6 BOUNDARY 7

Type Flux Insulation/Symmetry Flux

N0 M*(K*c1-c2) M*(K*c3-c2)

PROPERTY VALUE

D (r direction) D

D (z direction) D/(scale^2)
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5 Click the Init tab, then type 0.1*c0 in the c3(t0) edit field. Click OK.

Boundary Conditions—Convection and Diffusion (chcd2)
1 From the Physics menu, select Boundary Settings.

2 Enter boundary conditions according to the following table; when done, click OK.

M E S H  G E N E R A T I O N

1 Click the Initialize Mesh button on the Main toolbar.

2 Click the Refine Mesh button once to refine the mesh.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate the plot in Figure 4-6, follow these steps:

1 Click the Plot Parameters button on the Main toolbar.

2 Click the Surface tab. In the Expression edit field, type c_all.

3 Click the Arrow tab. Select the Arrow plot check box.

4 In the Arrow parameters area, select 3D arrow from the Arrow type list.

5 On the Subdomain Data page, select Convection and Diffusion (chcd2)>Total flux, c3 
from the Predefined quantities list.

6 Return to the General page. Click the Title button.

7 In the Title dialog box, click the option button next to the edit field and enter the 
title Surface: Concentration [mol/m<sup>3</sup>]  Arrow: Total flux.

8 Click OK to close the Title dialog box.

9 Click OK to close the Plot Parameters dialog box and generate the plot.

R 0

u 0

v A*((r^2)-(R2^2)-2*(R3^2)*log(r/R2))/scale

SETTINGS BOUNDARY 7 BOUNDARY 8 BOUNDARY 9 BOUNDARY 10

Type Flux Concentration Convective flux Insulation/Symmetry

c30 0

N0 M*(c2-K*c3)

PROPERTY VALUE
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S t e f a n  Tube

Introduction

This example, taken from Ref. 6, illustrates the use of the Maxwell-Stefan Diffusion 
and Convection application mode. A multicomponent gas phase diffusion problem is 
solved as a 1D model. In this particular case, two of the three components experience 
a steady-state flux, whereas the third component has zero flux on one of the 
boundaries. The concentration profiles at steady state are modeled.

Model Definition

The Stefan tube, depicted in Figure 4-7, is a simple device used for measuring diffusion 
coefficients in binary vapors.

Figure 4-7: Schematic diagram of a Stefan tube.

At the bottom of the tube is a pool of mixture. The vapor that evaporates from this 
pool diffuses to the top of the tube, where a stream of air, flowing across the top of the 
tube, keeps the mole fraction of diffusing vapor there to be zero. The mole fraction of 
vapor above the liquid interface is in equilibrium. Because there is no horizontal flux 
inside the tube, you can analyze the problem using a 1D model. The system 
composition of acetone, methanol, and air has been extensively investigated, 
measuring both diffusion coefficients and composition at various positions within 
Stefan tubes. This makes it an ideal example for this model.

x

Air

Liquid mixture

Gas/vapor phase
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As a comparison, one experiment measured the mole fraction at the liquid interface to 
be xAc = 0.319 and xMe = 0.528 where the pressure,  p, was 99.4 kPa and the 
temperature, T, was 328.5 K. The length of the diffusion path was 0.238 m. The 
respective Maxwell-Stefan diffusion coefficients, Dij, of the three binary pairs were 
calculated and are used in the model according to Table 4-1.

To model this problem, use the Maxwell-Stefan Diffusion and Convection application 
mode for three components. It solves for the fluxes in terms of mass fractions for two 
of the three components. The mass fraction, ω, of the third is given by the two first. 
The three equations are:

 (4-13)

 (4-14)

 (4-15)

where D is the diffusion coefficient (m2/s), p is the pressure (Pa), T is the temperature 
(K), u is the velocity (m/s), x and ω are mole and mass fractions, respectively, and the 
mixture density, ρmix (kg/m3), is a function of the average mixture mole fraction, 
Mmix (kg/mol), according to Equation 4-17:

 (4-16)

 (4-17)

TABLE 4-1:  LABELS AND MAXWELL-STEFAN DIFFUSION COEFFICIENTS

COMPONENT LABEL Dij VALUE

Acetone 1  D12 8.48·10-6 m2/s

Methanol 2  D13 13.72·10-6 m2/s

Air 3  D23 19.91·10-6 m2/s

∇ ρω1 D1k xk∇ xk ωk–( ) p∇( ) p⁄( )+( )[ ]
k
∑–⋅ +

DT T∇( ) T⁄( ) ] R ρu ω1∇⋅( )–=

∇ ρω2 1( ) D2k xk∇ xk ωk–( ) p∇( ) p⁄( )+( )[ ]
k
∑–⋅ +

DT T∇( ) T⁄( ) ] R ρu ω2∇⋅( )–=

ω3 1 ω1– ω2–=

Mmix xiMi

i
∑=

ρmix
p

RT
--------Mmix=
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In this case, there is no imposed fluid velocity. However, there will appear a fluid 
velocity due to the diffusion fluxes. At the top of the tube the mass fractions are fixed, 
with the fraction of air being unity. At the bottom (at the liquid interface), the fractions 
are also fixed according to the previously mentioned experimental conditions. The fact 
that there is no air flux at the interface results in the following relation for the 
convective velocity, at steady state:

 (4-18)

where ndiff,3 is the diffusive mass flux of air (kg/(m2·s)).

Results

The steady-state mole fractions as a function of position is depicted in Figure 4-8. As 
a comparison, the results given from Ref. 6 are depicted in Figure 4-9.

Figure 4-8: Steady-state mole fractions of: acetone(-), methanol (- -), and air(- .-), in the 
Stefan tube according to the COMSOL Multiphysics model as solved using Maxwell-Stefan 
diffusivities.

u
ndiff,3
ω3ρ

--------------=
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Figure 4-9: Steady-state mole fractions of: acetone(-), methanol (- -), and air(- .-), in a 
Stefan tube according to experimental data (Ref. 6).

We can see that the COMSOL Multiphysics model emulates the results from Ref. 6 
rather well, which means the Maxwell-Stefan equations describe the mass transport 
process in the system.

A significant advantage with the Maxwell-Stefan diffusion formulation, in comparison 
with Fick’s law, is the inclusion of a conservation of mass. In the absence of chemical 
reactions (source terms) and convective contributions, the Maxwell-Stefan 
formulation results in zero net mass flux. This is not the case for the Fickian diffusion 
formulation. A consequence of the conservation of mass is that if there is a net mass 
flux. In this example, it can be described by the convective term, which you can see in 
Figure 4-10.
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Figure 4-10: Velocity of the gas mixture in the Stefan tube from the pool surface to the 
outlet.
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Model Library path:  

Chemical_Engineering_Module/Multicomponent_Transport/stefan_tube

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics.

2 On the New page, set the Space dimension to 1D.

3 Select the application mode Chemical Engineering Module>Mass Transport> 
Maxwell- Stefan Diffusion and Convection.

4 In the Dependent variables edit field, type w1, w2, and w3. Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

2 Define the following constants (the descriptions are optional); when done, click OK.

NAME EXPRESSION DESCRIPTION

p0 1.013e5[Pa] Pressure

T0 328.5[K] Temperature

Rg 8.314[J/mol] Gas constant

D12 8.48e-6[m^2/s] MS diffusion coefficient, 
acetone

D13 13.72e-6[m^2/s] MS diffusion coefficient, 
methanol

D23 19.91e-6[m^2/s] MS diffusion coefficient, 
air

M_air 28.8[g/mol] Molar mass, air

M_ace 58[g/mol] Molar mass, acetone

M_met 32[g/mol] Molar mass, ethanol

x_ace0 0.319 Acetone mole fraction at 
liquid interface

x_met0 0.528 Methanol mole fraction at 
liquid interface

x_air0 1-x_ace0-x_met0 Air mole fraction at liquid 
interface
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3 Choose Options>Expressions>Scalar Expressions.

4 Define the following scalar expression (again, the description is optional):

5 Click OK.

G E O M E T R Y  M O D E L I N G

1 Create a line between the coordinates 0 and 0.238 by using Specify Objects>Line in 
the Draw menu, typing 0 0.238 in the x edit field in the Coordinates area, and then 
click OK.

2 Click the Zoom Extents button on the Main toolbar.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Physics menu, select Subdomain Settings. Select subdomain 1.

2 On the General page, click the Edit button for the Maxwell-Stefan diffusivity matrix, 
and type D12, D13, and D23, in the edit fields for the corresponding diffusion 
coefficients.

3 Click OK to close the Maxwell-Stefan diffusion coefficients dialog box.

w_air0 x_air0*M_air/
(x_air0*M_air+x_ace0*M_ace
+x_met0*M_met)

Air mass fraction at liquid 
interface

w_ace0 x_ace0*M_ace/
(x_air0*M_air+x_ace0*M_ace
+x_met0*M_met)

Acetone mass fraction at 
liquid interface

w_met0 1-w_air0-w_ace0 Methanol mass fraction at 
liquid interface

NAME EXPRESSION DESCRIPTION

M_mix x_w1_chms*M_ace+x_w2_chms*M_met+ 
x_w3_chms*M_air

Average molar mass

NAME EXPRESSION DESCRIPTION
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4 Apply the following additional settings:

5 On the w1 page, type M_ace in the M edit field.

6 Similarly, type M_met and M_air in the M edit fields on the w2 and w3 pages.

7 Finally, type w_ace0 and w_met0 in the edit fields w1 and w2 on the Init page.

8 Click OK.

Boundary Conditions
1 From the Physics menu, select Boundary Settings.

2 Specify boundary conditions according to the following table.

3 Click OK.

M E S H  G E N E R A T I O N

Click the Refine Mesh button on the Main toolbar.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

In order to reproduce the plot in Figure 4-8, do the following:

1 From the Postprocessing menu, select Domain plot parameters.

2 On the General page, select the Keep current plot check box.

3 Click the Title/Axis button, type position [x] and mole fraction in the edit 
fields for First axis label and Second axis label, clearing the Auto button prior to typing 
in the entries. Click OK.

PROPERTY VALUE

 ρ M_mix*p0/(Rg*T0)

 p p0

 T T0

 u (-dflux_w3_chms)/(w3*rho_chms)

SETTINGS BOUNDARY 1 BOUNDARY 2

Boundary 
condition

Mass fraction Mass fraction

w1 w_ace0 0

w2 w_met0 0
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4 Select the Line/Extrusion page, select subdomain 1 and type x_w1_chms in the 
Expression edit field. Click Apply.

5 Return to the Domain plot parameters dialog box and type x_w2_chms in the 
Expression edit field.

6 Click the Line Settings button. From the Line style list, select Dashed line. Click OK.

7 Click Apply.

8 Similarly, plot x_w3_chms using line style Dash-dot line and click OK.

To reproduce Figure 4-10, proceed as follows:

9 Click the Plot Parameters button on the Main toolbar.

10 On the Line page, type u_chms in the Expression edit field. Select Use expression to 

color lines, then click OK.
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Maxwe l l - S t e f a n  D i f f u s i o n  i n  a  Fu e l  
C e l l  Un i t  C e l l

Introduction

In concentrated gases and liquids, where the concentrations of species are of the same 
order of magnitude, there is no obvious solvent-solute relationship. Fick’s law for 
diffusion accounts only for 1-way solute-solvent interactions whereas the 
Maxwell-Stefan equations account for all interactions of species in a solution. In a 
system with three components, three pair-wise interactions are present, while for a 
system of four components there are six such interactions. These interactions are 
described as Fick-analogous Maxwell-Stefan diffusion coefficients, Dij.

This example models the steady-state mass transport in the cross section of a proton 
exchange membrane fuel cell cathode. It models the mass transport in the 
3-component gas mixture using Maxwell-Stefan diffusion. The cross section includes 
the channel and current collector in the bipolar plate, at the upper boundary, while the 
active layer defines the lower boundary.

The purpose of this model is to show how to consider Maxwell-Stefan diffusion in mass 
transport.

Model Definition

Figure 4-11 describes the computational domain. The insulating boundary at the top 
of the domain is the current-collector boundary corresponding to the position of the 
bipolar plate. The vertical boundaries are symmetry boundaries, while the lower 
boundary, denoted a reactive boundary, represents the position of the active layer.

Figure 4-11: Depiction of the modeling domain with descriptions of the boundary 
conditions.
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The model equations are defined by a simple mass transport taking the divergence of 
the mass flux through diffusion and convection. This yields the following expression 
for species i:

 (4-19)

where M denotes the total molar mass of the mixture (kg/mol), Mj gives the molar 
mass of species j (kg/mol), and ωj is the mass fraction of species j. M can also be 
expressed in terms of the mass fractions, ωj. The symmetric diffusivities are strongly 
dependent on the composition and are given by these expressions (see Ref. 2 and Ref. 
3):

 (4-20)

 (4-21)

where xj is the mol fraction of species j (which can be expressed in terms of the mass 
fractions ωj), and Dij is the Maxwell-Stefan diffusivities (m2/s). Additional entries of 
the symmetric diffusivities are constructed by permutation of the indices, that is, D12 
= D21. The Maxwell-Stefan diffusivities can be described with an empirical equation 
(Ref. 4) based on the kinetic gas theory:

 (4-22)

where k is a constant with the value 3.16·10−8 Pa·m2/s, T is the temperature 
expressed in kelvin, p denotes the pressure (Pa), νi equals the molar diffusion volume 
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of species i expressed in m3/mol, and Mi is the molar mass of species i expressed in 
kg/mol. The molar diffusion volumes are given in Table 4-2 (Ref. 1).

At the reactive boundary (the electrode), the flux of oxygen is

 (4-23)

where nj represents the mass flux of j, and ic is the reaction current given by the Tafel 
expression:

.  (4-24)

Here Sa denotes the specific surface area (m2/m3), and δ is the thickness of the active 
layer (m). In the Tafel equation, F denotes Faraday’s number (C/mol), R is the gas 
constant (J/(mol·K)), T represents the temperature (K), i0 denotes the exchange 
current density (A/m2), and η is the overpotential (V). The subscript zero in the mass 
fraction for oxygen represents the reference state.

Similarly, the flux of water is

 (4-25)

where tH2O is the transport number for water (that is, the number of water molecules 
dragged with each proton migrating through the membrane).

At the reactive boundary there is no flux of nitrogen gas because it does not take part 
in the reactions. This boundary condition results in zero total flux of nitrogen in the 
entire subdomain at steady state. Included this fact in the model by specifying the 
subdomain gas velocity according to

 (4-26)

TABLE 4-2:  DIFFUSION VOLUMES

SPECIES DIFFUSION VOLUME

O2 16.6·10-6 m3/mol

H2O 12.7·10-6 m3/mol

N2 17.9·10-6 m3/mol
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At the inlet, a fixed composition is applied. This model uses a composition of air 
saturated with steam at 80 °C as according to the following table (Ref. 1).

Results

Figure 4-12 shows the mass fraction of oxygen at a 0.8 V cathode overvoltage 
(representing a short circuit of the fuel cell).

Figure 4-12: Mass fraction of oxygen at 0.8 V overvoltage of the cathode (an almost short 
circuit of the fuel cell).

The oxygen concentration in the active layer is close to zero in the positions far away 
from the inlet.

The large variation in concentration has a direct influence on the value of the diffusion 
coefficients for oxygen and the other involved species, nitrogen and water.

TABLE 4-3:  INPUT DATA FOR THE MASS FRACTIONS AT THE INLET

SPECIES MASS FRACTION

O2 0.1447

H2O 0.3789

N2 0.4764
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To illustrate the composition dependence in the diffusivities, you can plot the 
Maxwell-Stefan diffusivity of D22 (the water diffusivity); see Figure 4-13.

Figure 4-13: Variation of Maxwell-Stefan diffusivity of water, D22, within the gas 
mixture at 0.8 V overvoltage.

The water diffusivity decreases with decreasing oxygen concentration. This is probably 
due to the decreased interaction among oxygen molecules. 

Figure 4-14 shows the convective gas velocity induced by the drag and production of 
water at the reactive boundary. The induced gas velocity causes significant convective 
fluxes out from the reactive boundary, significantly reducing the concentration of 
oxygen at the boundary. This causes a poorer performance of the cell. In addition, 
there is a significant velocity peak at the corner of the inlet. This is caused by the close 
to spherical diffusion situation at that point.
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Figure 4-14: Velocity field in the fuel cell cathode gas compartment at 0.8 V cathode 
overvoltage.

This example also investigates cathode performance in terms of a polarization curve 
(Figure 4-15). At high cathode overvoltages, the total electrode current levels off. This 
is caused by mass transport limitations, which is important to consider when designing 
or operating fuel cells.
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Figure 4-15: Polarization curve for the cathode.
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Model Library path: Chemical_Engineering_Module/
Multicomponent_Transport/maxwell_stefan_diffusion
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Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics.

2 In the Model Navigator, select 2D from the Space dimension list.

3 In the list of application modes select the application mode  
Chemical Engineering Module>Mass Transport> 
Maxwell-Stefan Diffusion and Convection.

4 Type w_O2 w_H2O w_N2 in the Dependent variables edit field.

5 Click OK.

Options and Settings
1 Define the following constants and expressions in the Constants dialog box on the 

Options menu; when done, click OK.

NAME EXPRESSION DESCRIPTION

k 3.16e-8[Pa*m^2/s] MS diffusivity prefactor

F 96485[C/mol] Faraday’s constant

R 8.314[J/(mol*K)] Gas constant

v_N2 17.9e-6 Molar diffusion volume, N2

v_O2 16.6e-6 Molar diffusion volume, O2

v_H2O 12.7e-6 Molar diffusion volume, H2O

M_O2 32[g/mol] Molar mass, O2

M_H2O 18[g/mol] Molar mass, H2O

M_N2 28[g/mol] Molar mass N2

w_O20 0.1447 Inlet mass fraction, O2

w_H2O0 0.3789 Inlet mass fraction, H2O

T0 353[K] Temperature

p0 101[kPa] Pressure

D_O2_N2 k*(T0[1/K])^1.75/(p0*(v_O2^(1/
3)+v_N2^(1/3))^2)*(1[kg/mol]/
M_O2+1[kg/mol]/M_N2)^0.5

MS diffusivity, O2-N2 compon

D_O2_H2O k*(T0[1/K])^1.75/(p0*(v_O2^(1/
3)+v_H2O^(1/3))^2)*(1[kg/mol]/
M_O2+1[kg/mol]/M_H2O)^0.5

MS diffusivity, O2-H2O compo

D_H2O_N2 k*(T0[1/K])^1.75/(p0*(v_H2O^(1/
3)+v_N2^(1/3))^2)*(1[kg/mol]/
M_H2O+1[kg/mol]/M_N2)^0.5

MS diffusivity, H2O-N2 compo
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2 From the Options menu, select Expressions>Scalar Expressions.

3 Define the following expressions (the descriptions are optional); when done, click 
OK.

Geometry Modeling
1 Shift-click the Rectangle/Square button on the Draw toolbar. Specify a rectangle by 

setting its Width to 1e-3 and its Height to 2e-4. Click OK.

2 Click the Zoom Extents button on the Main toolbar.

3 Shift-click the Point button on the Draw toolbar. Add a point at the coordinates 
(5e-4,2e-4), then click OK.

Subdomain Settings
1 Select Subdomain Settings in the Physics menu.

2 Select 1 from the Subdomain selection list.

3 In the General page, type M*p0/(R*T0) in the Density edit field.

4 Type p0 in the Pressure edit field

5 Type T0 in the Temperature edit field.

6 In the u and v edit fields, type -dflux_w_N2_x_chms/(w_N2*rho_chms) and 
-dflux_w_N2_y_chms/(w_N2*rho_chms), respectively.

7 Click the Dij Edit button.

eta 0.1[V] Overpotential

S_a 1e7[1/m] Specific surface area

d 10[um] Active-layer thickness

i_0c 1[A/m^2] Exchange current density

t_H2O 3 Drag number, H2O

NAME EXPRESSION DESCRIPTION

NAME EXPRESSION

M M_O2*x_w_O2_chms+M_H2O*x_w_H2O_chms+M_N2*x_w_N2_chms

i_c -S_a*d*i_0c*exp(0.5*F*eta/(R*T0))*(abs(w_O2)/w_O20)
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8 Type D_O2_H2O, D_O2_N2, and D_H2O_N2 in the Binary diffusion coefficients matrix 
component edit fields (as in this figure).

9 Click OK.

10 Click the tabs for each species and type M_O2, M_H2O, and M_N2 in the corresponding 
Molecular weight edit fields.

11 Click the Init tab, then set the initial conditions according to the following table:

12 Click OK.

13 From the Physics menu, select Properties. In the Equation form list select 
Conservative.

14 Click OK.

Boundary Conditions
1 From the Physics menu, select Boundary Settings.

2 On the w_O2 page, specify boundary conditions as in this table:

3 On the w_H2O page, specify boundary conditions as in this table:

4 Click OK.

VARIABLE INITIAL VALUE

w_O2(t0) wO20

w_H2O(t0) wH2O0

SETTINGS BOUNDARIES 1, 3, 5 BOUNDARY 2 BOUNDARY 4

Type Insulation/Symmetry Flux Mass fraction

n0 M_O2*i_c/(4*F)

w_O20 w_O20

SETTINGS BOUNDARIES 1, 3, 5 BOUNDARY 2 BOUNDARY 4

Type Insulation/Symmetry Flux Mass fraction

n0 -M_H2O*i_c*(1/2+t_H2O)/F

w_H2O0 w_H2O0
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Mesh Generation
1 Click the Initialize Mesh button on the Main toolbar.

2 Click the Refine Mesh button to refine the mesh.

Preparing for Postprocessing
1 Choose Options>Integration Coupling Variables>Boundary Variables.

2 In the dialog box that opens, select Boundary 2. In the Name edit field, type I_tot, 
and in the Expression edit field, type i_c. Click OK.

Computing the Solution
1 Click the Solver Parameters button on the Main toolbar.

2 Select the Parametric solver.

3 In the Parameter name edit field, type eta. In the Parameter values edit field, type 
0.05:0.05:0.8. Click OK.

4 Click the Solve button on the Main toolbar.

Postprocessing and Visualization
The default plot, reproduced in Figure 4-12, shows the mass fraction of oxygen, wO2. 
Because the solution is parametric, you can view the results as an animation by clicking 
the Animate button on the Plot toolbar.

To reproduce the plot in Figure 4-13, do as follows:

1 Click the Plot Parameters button on the Main toolbar.

2 Click the Surface tab.

3 Type DE22_chms in the Expression edit field on the Surface Data page.

4 Click Apply.

To generate Figure 4-14, follow these instructions:

1 On the Surface page, type sqrt(u_chms^2+v_chms^2) in the Expression edit field.

2 Click the Streamline tab. Select the Streamline plot check box.

3 On the Streamline Data page, type u_chms and v_chms in the edit fields for 
x component and y component, respectively.

4 From the Streamline plot type list, select Magnitude controlled.

5 Click OK.

Finally, generate Figure 4-15 with these steps:

1 From the Postprocessing menu, select Domain Plot Parameters.
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2 On the Point page, type I_tot in the Expression edit field inside the y axis data area.

3 In the x axis data area, click the lower option button, then click the Expression 
button.

4 In the X Axis Data dialog box, type eta in the Expression edit field. Click OK.

5 Back in the Domain Plot Parameters dialog box, select Point 1.

6 Click OK.
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M i x e r s  a n d  S t i r r e d  V e s s e l s
This chapter contains examples of mixers and stirred vessels.
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L am i n a r  S t a t i c  M i x e r

Introduction

In static mixers, also called motionless or in-line mixers, a fluid is pumped through a 
pipe containing stationary blades. This mixing technique is particularly well suited for 
laminar flow mixing because it generates only small pressure losses in this flow regime. 
This example studies the flow in a twisted-blade static mixer. It evaluates the mixing 
performance by calculating the concentration’s standard deviation.

Model Definition

This model studies the mixing of one species dissolved in water at room temperature. 
The geometry consists of a tube with three twisted blades of alternating rotations 
(Figure 5-1).

Figure 5-1: Depiction of a laminar static mixer containing three blades with alternating 
rotations.

The tube’s radius, R, is 6 mm; the length is 14R, and the length of each blade is 3R. 
The inlet flow is laminar and fully developed with an average velocity of 1 cm/s. At the 
outlet, the model specifies a constant reference pressure of 0 Pa. The equations for the 
momentum transport are the stationary Navier-Stokes equations in 3D:
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 (5-1)

Here η denotes the dynamic viscosity (kg/(m·s)), u is the velocity (m/s), ρ represents 
the fluid density (kg/m3), and p denotes the pressure (Pa). The fluid’s properties are 
not affected by the change in concentration of the dissolved species.

The model studies the mixing performance by assuming a discontinuous concentration 
profile at the mixer’s inlet. The inlet concentration is defined as

 (5-2)

with the line x = 0 separating the two inlet sides. Diffusion and convection contribute 
to the mass flux, and the resulting mass transport equation is:

 (5-3)

Here D denotes the diffusion coefficient (m2/s), and c is the concentration (mol/m3). 

At the outlet, the mass transport is mainly driven by convection. That is, the transport 
by diffusion is neglected in the normal direction of the pipe’s cross section. Because 
the convective term leads to instabilities in the solution, you need a fine mesh to obtain 
a stable solution for the concentration field.

The low Reynolds numbers, in the mixer implies that the Navier-Stokes equations do 
not require a particularly dense mesh. You can therefore first solve the Navier-Stokes 
equations on a coarse mesh and then map the solution onto a finer mesh. In the last 
solution step you use this mapped velocity field in the convective mass-transport term.

Results

Figure 5-2 shows a slice plot of the concentration in the mixer. The slice at the bottom 
shows the lighter and darker halves of the fluid with and without the dissolved species, 
respectively. As the fluid flows upward through the system, the two solutions are mixed 
and an almost constant concentration is obtained at the outlet.

∇ η ∇u ∇u( )T
+( )⋅– ρ u ∇⋅( )u ∇p+ + 0=

∇ u⋅ 0=

cinlet

c0 x 0<

0  x 0≥⎩
⎨
⎧

=

∇ D c cu )+∇–(⋅ 0=
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Figure 5-2: Slice plot of the concentration at different distances from the inlet.
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Figure 5-3 shows the flow field responsible for the mixing. The streamlines clearly 
reveal the twisting motion in the fluid that is induced by the mixer blades.

Figure 5-3: Slice plots of the velocity magnitude field inside the mixer. The streamlines show 
the flow direction.

You can also visualize the mixing through a series of cross-section plots. Figure 5-4 
contains such a series of plots showing the concentration in the mixer’s cross section 
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along the direction of the flow. The results show that most of the mixing takes place 
where the blades change rotational direction (the three middle figures).

Figure 5-4: Cross-sectional plots of the concentration at different distances from the inlet. 
The nine plots shows the concentration at z =- 2 mm to z = 30 mm in steps of 4 mm.

References

1. R. Perry and D. Green, Perry’s Chemical Engineering Handbook, 7th ed., 
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Model Library path: Chemical_Engineering_Module/
Mixers_and_Stirred_Vessels/laminar_static_mixer
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Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open COMSOL Multiphysics.

2 In the Model Navigator select 3D from the Space dimension list; then click the 
Multiphysics button. 

3 From the list of application modes select  
Chemical Engineering>Momentum Transport>Laminar Flow.

Incompressible Navier-Stokes and add it to the model by pressing the Add button.

4 In the list of application modes select  
Chemical Engineering>Mass Transport>Convection and Diffusion and add it to the 
model with the Add button.

5 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

2 Define the following constants (the descriptions are optional); when done, click OK.

3 From the Options menu, select Visualization/Selection Settings.

4 Change the Visualization mesh from Normal to Fine.

5 Click OK.

G E O M E T R Y  M O D E L I N G

To create the twisted blades, start from a 2D work plane, then extrude and twist the 
blade cross section:

1 From the Draw menu, select Work-Plane Settings.

2 Use the default work plane by clicking OK.

3 Press Shift and click the Rectangle button on the Draw toolbar.

NAME EXPRESSION DESCRIPTION

ra 3[mm] Tube radius

rho 1e3[kg/m^3] Fluid density

eta 1e-3[Pa*s] Viscosity

u_mean 10[mm/s] Mean inlet velocity

cO 5[mol/m^3] Inlet concentration

D 5e-8[m^2/s] Diffusion coefficient
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4 Set the Width to 2.4*3e-3, the Height to 3e-3/8, and Position/Base to Center.

5 Click OK.

6 From the Draw menu, select Extrude.

7 Set the Distance to 1.5e-3 and the Twist to 30. Click OK.

The first part of the first blade in now finished.

8 Make a copy of the extrusion by pressing Ctrl+C, then paste the copy with Ctrl+V.

9 Click the Move button on the Draw toolbar.

10 Set the z-displacement to 1.5e-3, then click OK.

11 Click the Rotate button on the Draw toolbar.

12 Set the Rotation angle to -30, then click OK.

13 Select both existing geometry objects by pressing Ctrl+A.

14 Copy and paste them onto the work area.

15 Move the pasted objects 3e-3 in the z direction.

16 Rotate -60 degrees.

17 Click Paste once again. This pastes the first two parts of the blade in the original 
position.

18 Move the pasted selection 6e-3 in the z direction and rotate -120 degrees.

You have now created the first blade. Use it as template for the other two.

19 Select all the objects that make up the first blade by pressing Ctrl+A.

20 Make a copy by pressing Ctrl+C, then press Ctrl+V to paste it.

21 Move the pasted selection 9e-3 in the z direction.

22 Click the Scale button on the Draw toolbar. Set the x-scale to -1, then click OK.

23 Click the Rotate button on the Draw toolbar. Rotate the selection +90 degrees.

24 Press Ctrl+V once more to paste and move the pasted selection 18e-3 in the 
z direction.

You have created all three blades. Next make the tube using the cylinder tool.

25 Click the Cylinder button on the Draw toolbar.

26 Type 3e-3 in the Radius edit field and 42e-3 in the Height edit field.

27 In the Axis base point area, set the z position to -6e-3.

28 Set the Rotation to 15, then click OK.

The final step in creating the geometry is to perform a difference operation that 
removes the intersection of the blades and the cylinder.
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29 Select all the geometry objects defining the blades, then click the Union button.

30 Press Ctrl+A to select the two geometry objects present.

31 Create the final geometry by pressing the Difference button on the Draw toolbar.

P H Y S I C S  S E T T I N G S — I N C O M P R E S S I B L E  N A V I E R - S T O K E S

Subdomain Settings
1 From the Multiphysics menu, select 1 Incompressible Navier-Stokes (chns).

2 From the Physics menu, select Subdomain Settings.

3 Select Subdomain 1. Set the Density to rho and the Dynamic viscosity to eta.

4 On the Init page, set u(t0) to 0, v(t0) to 0, and w(t0) to u_mean.

5 Click OK.

Boundary Settings
1 From the Physics menu, select Boundary Settings.

2 Enter boundary conditions according to the following table; when done, click OK.

P H Y S I C S  S E T T I N G S — C O N V E C T I O N  A N D  D I F F U S I O N

Subdomain Settings
1 From the Multiphysics menu, select 2 Convection and Diffusion (chcd).

2 From the Physics menu, select Subdomain Settings.

3 Select Subdomain 1. Enter the following settings; when done, click OK.

SETTINGS BOUNDARY 20 BOUNDARY 23 ALL OTHERS

Type Inlet Outlet Wall

Condition Velocity Pressure, no 
viscous stress

No slip

u0 0 - -

v0 0 - -

w0 2*u_mean*(1-(x^2+y^2)/ra^2) - -

p0 - 0 -

PROPERTY VALUE

D D

R 0

u u
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Boundary Settings
1 From the Physics menu, select Boundary Settings.

2 Enter boundary conditions according to the following table; when done, click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters.

2 From the Predefined mesh sizes list, select Extra fine.

3 Click Remesh. When the mesher has finished, click OK to close the dialog box.

C O M P U T I N G  T H E  S O L U T I O N

First adjust some solver properties for a memory-efficient simulation:

1 Click the Solver Parameters button on the Main toolbar.

2 From the Linear system solver list, select Direct (SPOOLES).

3 Click OK.

Because the fluid’s properties do not change with concentration, you can solve the 
Navier-Stokes equations independently.

1 Click the Solver Manager button on the Main toolbar

2 On the Solve For page, select Incompressible Navier-Stokes from the list.

3 Click OK.

4 Click the Solve button on the Main toolbar to compute the velocity field.

The next step is to solve the mass-transport equation, which requires a denser mesh 
than the Navier-Stokes equations.

1 From the Mesh menu, select Free Mesh Parameters.

2 From the Predefined mesh sizes list, select Normal.

3 Click the Custom mesh size button, then set the Maximum mesh size to 7e-4.

4 Click Remesh. When the mesher has finished, click OK.

v v

w w

SETTINGS BOUNDARY 20 BOUNDARY 23 ALL OTHERS

Type Concentration Convective flux Insulation/Symmetry

c0 c0*flc2hs(-x[1/m],3e-4) - -

PROPERTY VALUE
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The resulting mesh consists of approximately 57,000 elements.

1 Click the Solver Manager button on the Main toolbar.

2 On the Solve For page, select Convection and Diffusion from the list.

3 On the Initial Value page, click the Store Solution button.

4 In the Initial value area, click the Stored solution option button.

5 Click OK.

6 Click the Solve button on the Main toolbar to compute the solution for the 
concentration field.

The solution to the Navier-Stokes equations on the coarser mesh is automatically 
mapped to the finer mesh before the software solves the convection and diffusion 
equation.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To reproduce the plot in Figure 5-2 take the following steps.

1 Click the Plot Parameters button on the Main toolbar.

2 On the Slice page, select the Slice plot check box.

3 In the Slice data area, select Convection and Diffusion (chcd)>Concentration, c from the 
Predefined quantities list.

4 In the Slice positioning area, set x-levels and y-levels to 0, and z-levels to 8.

5 Click Apply.

To generate the plot in Figure 5-3, continue with the following steps.

6 Still on the Slice page, select Incompressible Navier-Stokes (chns)>Velocity field from 
the Predefined quantities list on the Slice Data page.

7 On the Streamline page, select the Streamline plot check box.

8 In the Predefined quantities list in the Streamline data area, keep the default selection, 
Incompressible Navier-Stokes (chns)>Velocity field.

9 Click the Advanced button and set the Maximum number of integration steps to 4000. 
Click OK.

10 On the Line Color page, select Uniform color and click the Color button.

11 Set the color to yellow, then click OK.

12 Finalize the plot by clicking OK in the Plot Parameters dialog box.

Generate the nine plots in Figure 5-4 using the cross-section plot functionality.
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1 From the Postprocessing menu, select Cross-Section Plot Parameters.

2 On the General page, click the Slice plot option button in the Plot type area.

3 Clear the Display cross-section in main axes check box.

4 Click the Slice tab.

5 In the Slice data area, select Convection and Diffusion (chcd)>Concentration, c from the 
Predefined quantities list.

6 From the Coordinate system to plot in list, select Local (slice).

7 Use the default settings for the x- and y-coordinates of all three points that define 
the cross-section plane.

8 Set z0 = z1 = z2 = -2e-3, then click Apply.

9 Repeat the previous step with z-coordinates 2e-3 to 30e-3 with steps of 4e-3 to 
create the remaining eight plots.
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Re s i d e n c e  T ime i n  a  Tu r bu l e n t  
R e a c t o r

Introduction

Large-scale reactors usually have the economic necessity of being made out of 
stationary parts. The capital and running costs for motors and mixing equipment are 
often impediments to large-scale reactive processes such as the water treatment for 
metropolitan areas.

Baffled reactors are common in the process industry and are used to allow for slower 
reactions to fade out after an initial step. They make use of the baffled-imposed 
turbulence to provide mixing within the reactor. Even so, such reactors must be 
optimized because too much baffling can create unnecessary turbulence and pressure 
drops.

As in other reactors, an indication of residence time is a pointer toward the 
effectiveness of a reactor design. You can measure the maximum, minimum, and 
average time that a tracer element is present within a reactor to provide information 
about the reactor design and the extent of mixing. It can also show dead zones and 
areas of stagnation, which can themselves be problems through silt build-up and 
regions for secondary reactions.

This model studies the residence time in a turbulent reactor and compares a 2D 
approximation with a full 3D model of the reactor. It does so by first solving for a 
stationary turbulent flow in the reactor using the k-ε model, and then solving for a 
mass transport on top of this flow field in the time domain. Mass transport is described 
through convection and diffusion, where the turbulent viscosity from the k-ε model 
describes the species diffusion in the mass transport. A tracer species is introduced as a 
“burst” of concentration, and the model studies its journey through the reactor.

This model illustrates the use of the k-ε Turbulence Model application mode in the 
Chemical Engineering Module. It also shows the use of the Solver Manager in 
COMSOL Multiphysics, which makes it possible to solve a problem in sequential steps.
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Model Definition

Figure 5-5 shows the reactor’s 2D geometry. It is a cross section of a 3D geometry, 
showing the front view. The model is inspired by a water-treatment process where flow 
enters from the left and leaves the reactor at the right.

Figure 5-5: Depiction of the reactor geometry.

To describe turbulent flow in the reactor the model uses the k-ε model, for which the 
momentum transport and continuity equations read

 (5-4)

where ρ denotes the fluid’s density (kg/m3), U represents the average velocity (m/s), 
η is the dynamic viscosity (kg/(m·s)), P equals the pressure (Pa), k refers to the 
turbulence energy (m2/s2), ε is the dissipation rate of turbulent kinetic energy (m2/
s3), and  is a model constant. You find the turbulence energy by solving

 (5-5)

and the dissipation by solving

 (5-6)
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The model constants in the previous equations are experimentally determined. Set 
them to the values listed in Table 5-1.

The inlet has a constant velocity profile in the x direction, u0, set to 0.1 m/s, while the 
velocity in the y direction, v, is zero. At the outlet, apply a zero-pressure condition. At 
all other boundaries, logarithmic wall functions describe the boundary conditions.

Model the tracer concentration with the convection and diffusion equation

 (5-7)

where, c denotes the concentration (kg/m3), D equals its diffusion coefficient (m2/
s), and u is the velocity (m/s). The velocity is given by the stationary solution of the 
k-ε equations, and the diffusivity is given by the turbulent viscosity νT given from the 
k-ε simulation. The assumption to decouple the velocity field and the scalar transport 
equation is accurate because the concentration of tracer is low and the laminar 
diffusivity of the tracer in water can be ignored because it is typically 1000 times lower 
than the turbulent transport (compare with data given in Ref. 1).

To simulate the tracer, use a time-dependent boundary condition at the inlet:

 (5-8)

The boundary condition at the outlet is a convective-flux condition stating that all 
mass transport over the boundary occurs through convection. All other boundaries are 
insulated.

TABLE 5-1:  MODEL CONSTANTS

CONSTANT VALUE

 0.09

 1.44

 1.92

 σk 1.0

 1.3

Cµ

Cε1

Cε2

σε

t∂
∂c ∇ D c cu+∇–( )⋅+ 0=

c c0e t 3–( )2–
=
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Results

The stationary velocity field appears in Figure 5-6. Regions of circulation, and 
therefore of mixing, increase with the number of baffles. As the figure shows, dead 
zones occur in the corners and in the first baffle chambers. It is also evident from the 
flow that a stream or “short-circuit” of velocity occurs through the middle of the 
reactor. The residence time in this short-circuit, compared to velocities in the 
recirculation areas, gives an indication of the reactor’s effectiveness.

Figure 5-6: Velocity field and flow lines for the baffled reactor.

Turbulent viscosity is an important quantity in this model because it is used to simulate 
the diffusive properties in the mass transport; Figure 5-7 indicates that relative 
turbulence increases downstream in the reactor. Whereas Figure 5-6 shows the regions 
of recirculation, which are good for mixing, Figure 5-7 shows the chaotic behavior of 
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the velocity vector on a smaller scale. Both figures illustrate that the mixing is far better 
in the last baffle chambers than in the first one.

Figure 5-7: Turbulent viscosity.

Figure 5-8 combines snapshots of the concentration field. The figures clearly show 
that the tracer is kept small in the first third of the reactor. When it enters the second 
third it dilutes somewhat. In the last section of the reactor, the tracer is strongly diluted 
due to the large turbulent viscosity in that section. Regions behind the baffles, even in 
the first chambers, also show a growing amount of tracer species and the mixing effect 
that recirculation zones have on the reactor.
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Figure 5-8: Concentration snapshots at t = 10, 20, 30, 45, 65, and 90 s.

By monitoring the integral of the concentration at the outlet you can determine the 
reactor’s residence time. Figure 5-9 shows the integral of the concentration over the 
outlet. The figure shows that the residence time is roughly 100 s.
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Figure 5-9: Integrated concentration at the outlet.

C O M P A R I S O N  W I T H  A  3 D  R E A C T O R

A similar reactor modeled in 3D appears in Figure 5-10. The height dimensions are 
the same as in the 2D reactor, and it includes a depth. Notice that the inlet and outlet 
are not drawn throughout the entire depth of the model, which leads to the conclusion 
that dead zones occur toward the front and the back of the reactor.

Figure 5-10: 3D reactor geometry.

outlet

inlet
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The velocity field is shown in Figure 5-11:

Figure 5-11: Velocity field and streamlines in the 3D reactor.

This case uses identical conditions in the 3D reactor as in the 2D example just 
described. Figure 5-12 shows the resulting integral of the outlet concentration as a 
function of time, and it shows that the residence time is greater than in the 2D 
approximation.

Figure 5-12: Concentration at the outlet.
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Reference

1. J. M. Coulson, J. F. Richardson, J. R. Backhurst and J. H. Harker, Chemical 
Engineering, Vol. 1, Fourth ed., Pergamon Press, 1990.

Model Library path: Chemical_Engineering_Module/
Mixers_and_Stirred_Vessels/turbulent_residence_time_2d

Model Library path: Chemical_Engineering_Module/
Mixers_and_Stirred_Vessels/turbulent_residence_time_3d

Modeling Using the Graphical User Interface—2D Turbulent 
Reactor

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics.

2 In the Model Navigator set the Space dimension to 2D.

3 In the Application Modes tree select Chemical Engineering Module> 
Momentum Transport>Turbulent Flow>k-ε Turbulence Model.

4 Click first the Multiphysics button and then the Add button to add the selected 
application mode.

5 Select the application mode Chemical Engineering Module>Mass Transport> 
Convection and Diffusion>Transient analysis, then click Add.

6 Click OK.

G E O M E T R Y  M O D E L I N G

1 Hold the Shift key and click the Rectangle/Square button on the Draw toolbar.

2 Enter rectangle properties from this table:

PROPERTY VALUE

Width 5

Height 2
R E S I D E N C E  T I M E  I N  A  TU R B U L E N T  R E A C T O R  |  205



206 |  C H A P T E
3 Click OK.

4 Click the Zoom Extents button on the Main toolbar.

5 Using the procedure just described, draw two more rectangles with these settings:

6 Select rectangle R2, then click the Array button on the Draw toolbar.

7 Set the x-displacement to 5.6 and the x-Array size to 2. Click OK.

8 Select rectangle R3, then click the Array button.

9 Enter the following array properties, then click OK:

10 Select the two rectangles R5 and R7 by pressing the Ctrl key and clicking the 
objects.

11 Click the Move button and move the two objects -1 in the y direction, then click OK.

12 Select R1, R2, and R4 by pressing the Ctrl key and clicking the objects

13 Click the Union button on the Draw toolbar.

14 Select all the geometry objects by pressing Ctrl+A.

15 Click the Difference button on the Draw toolbar.

16 Finally, click the Delete Interior Boundaries button on the Draw toolbar and the Zoom 

Extents button on the Main toolbar.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

PROPERTY R2 R3

Width 0.6 0.1

Height 0.4 1

x-position -0.6 0.95

y-position 0.8 1

PROPERTY VALUE

x-displacement 1

y-displacement 0

x-Array size 4

y-Array size 1
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2 Define the following constants (descriptions are optional); when done, click OK.

3 From the Options menu, select Expressions>Scalar Expressions.

4 Define the following expression (the description is optional); when done, click OK.

5 From the Options menu, select Integration Coupling Variables>Boundary Variables.

6 Select Boundary 1.

7 Type c_int_in in the first cell of the Name column and c in the Expression column.

8 Select Boundary 28.

9 Type c_int_out in the second cell of the Name column and c in the Expression 
column.

10 Click OK.

P H Y S I C S  S E T T I N G S — k- ε TU R B U L E N C E  M O D E L

From the Multiphysics menu, select 1 k-ε Turbulence model (chns).

Subdomain Settings
1 From the Physics menu, select Subdomain Settings.

2 Select Subdomain 1 from the list.

3 Set the density to rho and the Dynamic viscosity to eta.

4 Click OK.

Boundary Conditions
1 From the Physics menu, select Boundary Settings.

NAME EXPRESSION DESCRIPTION

rho 1000[kg/m^3] Density

eta 1e-3[Pa*s] Viscosity

u_in 0.1[m/s] Inlet velocity

c0 1[mol/m^3] Inlet peak concentration

NAME EXPRESSION DESCRIPTION

c_in c0*exp(-(t[1/s]-3)^2) Inlet concentration
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2 Enter the following boundary settings (the logarithmic wall function condition is 
the default and you thus need not set it explicitly); when done, click OK.

The value of LT is taken from Table 5-2 in the Chemical Engineering Module 
User’s Guide.

P H Y S I C S  S E T T I N G S — C O N V E C T I O N  A N D  D I F F U S I O N

From the Multiphysics menu, select 2 Convection and diffusion (chcd).

Subdomain Settings
1 From the Physics menu, select Subdomain Settings.

2 Select Subdomain 1.

3 Enter the following settings; when done, click OK.

Boundary Conditions
1 From the Physics menu, select Boundary Settings.

2 Enter the following boundary conditions (the insulation condition is the default); 
when done, click OK.

SETTINGS BOUNDARY 1 BOUNDARY 28 ALL OTHERS

Boundary type Inlet Outlet Wall

Boundary condition Velocity Pressure, no 
viscous stress

Logarithmic 
wall function

 u0 u_in - -

 v0 0 - -

LT 0.07*0.4 - -

 p0 - 0 -

PROPERTY VALUE

D (isotropic) etaT_chns/rho

R 0

u u

v v

SETTING BOUNDARY 1 BOUNDARY 28 ALL OTHERS

Boundary condition Concentration Convective flux Insulation/
Symmetry

c0 c_in - -
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M E S H  G E N E R A T I O N

To create a mesh that resolves the overall velocity field and the complex flow structure 
at the convex corners, specify a global maximum element size as well as a local element 
size for the mesh close to the convex corners:

1 From the Mesh menu, select Free Mesh Parameters.

2 On the Global page, click the Custom mesh size button, then set the Maximum element 

size to 0.2.

3 Click the Point tab.

4 In the Point selection list, select Points 4, 5, 7, 9, 12, 14, 15, 17, 20, 22, 24, and 25 
by pressing the Ctrl key and clicking these entries.

5 Set the Maximum element size to 0.05.

6 Click Remesh.

7 When the mesher has finished, click OK.

C O M P U T I N G  T H E  S O L U T I O N

Start by computing the flow field.

1 Click the Solver Parameters button on the Main toolbar.

2 Delete segregated group 3 by clicking the Delete button for Group 3.

3 Click OK.

4 Click the Solver Manager button on the Main toolbar. 

5 On the Solve For page, select k-ε Turbulence Model from the list.

6 Click the Solve button to compute the velocity field.

Now store the stationary velocity field and compute the transient mass transport 
problem.

7 On the Solve For page, select Convection and Diffusion from the list.

8 On the Initial Value page in the Solver Manager dialog box, click the Store Solution 
button.

9 Set the Initial value and Values of variables not solved for and linearization point to 
Stored solution.

10 Click OK.

11 Click the Solver Parameters button on the Main toolbar.

12 From the Analysis list, select Transient.
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13 In the Time stepping frame set Times to 0:1:200, the Relative tolerance to 0.0001 
and the Absolute tolerance to 0.00001.

14 Click OK.

15 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate Figure 5-6, perform the following steps:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, select the Surface and Streamline check boxes in the Plot type 
area.

3 Click the Surface tab. From the Predefined quantities list on the Surface Data page, 
select k-ε Turbulence Model (chns)>Velocity field.

4 Click the Streamline tab. From the Predefined quantities list on the Streamline Data 
page, select k-ε Turbulence Model (chns)>Velocity field.

5 From the Streamline plot type list, select Magnitude controlled.

6 On the Line Color page, click the Uniform color option button.

7 Click the Color button. Select black, then click OK.

8 Click Apply to generate the plot.

Proceed to generate Figure 5-7 with the following steps:

9 On the General page, clear the Streamline check box.

10 On the Surface page, select k-ε Turbulence Model (chns)>Turbulent viscosity as the 
Surface Data.

11 Click Apply.

To generate the plots in Figure 5-8, perform the following steps:

12 On the Surface page, set the Surface Data to 
Convection and Diffusion (chcd)>Concentration, c.

13 Clear the Color scale check box in the Surface color area.

14 On the General page, select 10 from the Solution at time list, then click Apply.

15 Repeat the previous step for the times 20, 30, 45, 65, and 90.

16 When finished, click Cancel to close the Plot Parameters dialog box.

To generate the plot in Figure 5-9, perform the following steps:

1 From the Postprocessing menu, select Domain Plot Parameters.
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2 On the General page, click the Point plot button.

3 Select all the time steps in the Solutions to use list by pressing Ctrl+A.

4 On the Point page, select point 28 and type c_int_out in the Expression edit field 
in the y-axis data area.

5 Click OK.

Modeling Using the Graphical User Interface—3D Turbulent 
Reactor

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics.

2 In the Model Navigator, set the Space dimension to 3D.

3 In the Application Modes tree select Chemical Engineering Module> 
Momentum Transport>Turbulent Flow>k-ε Turbulence Model.

4 Click first the Multiphysics button and then the Add button to add the selected 
application mode.

5 Select the application mode Chemical Engineering Module>Mass Transport> 
Convection and Diffusion>Transient analysis, then click Add.

6 Click OK.

G E O M E T R Y  M O D E L I N G

1 Select the menu item File>Import>CAD Data From File.

2 Browse to the folder 
Models>Chemical_Engineering_Module>Mixers_and_Stirred_Vessels.

3 Select the file turbulent_residence_time_3d.mphbin.

4 Click Import.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

2 Define the following constants (the descriptions are optional):

NAME EXPRESSION DESCRIPTION

rho 1000[kg/m^3] Density

eta 1e-3[Pa*s] Viscosity
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3 Click OK.

4 Select the menu item Options>Expressions>Scalar Expressions and type in the 
following entry:

5 Click OK.

6 Select the menu item Options>Integration Coupling Variables>Boundary Variables.

7 From the Boundary selection list, select 1.

8 In the first row of the table, type c_int_in in the Name column and c in the 
Expression column.

9 From the Boundary selection list, select 28.

10 In the second row of the table, type c_int_out in the Name column and c in the 
Expression column.

11 Click OK.

P H Y S I C S  S E T T I N G S — C O N V E C T I O N  A N D  D I F F U S I O N

From the Multiphysics menu select 2 Convection and Diffusion (chcd).

Subdomain Settings
1 From the Physics menu, select Subdomain Settings.

2 Select Subdomain 1.

3 Type the following settings into the appropriate edit fields:

4 Click OK.

u_in 0.1[m/s] Inlet velocity

c0 1[mol/m^3] Inlet peak concentration

NAME EXPRESSION DESCRIPTION

c_in c0*exp(-(t[1/s]-3)^2) Inlet concentration

PROPERTY VALUE

D (isotropic) etaT_chns/rho

R 0

u u

v v

w w

NAME EXPRESSION DESCRIPTION
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Boundary Conditions
1 From the Physics menu, open the Boundary Settings dialog box.

2 Enter the following boundary settings; when done, click OK.

P H Y S I C S  S E T T I N G S — k- ε TU R B U L E N C E  M O D E L

From the Multiphysics menu, select 1 k-ε Turbulence model (chns).

Subdomain Settings
1 From the Physics menu, select Subdomain Settings.

2 Select Subdomain 1.

3 Set the Density to rho and the Dynamic viscosity to eta.

4 Click OK.

Boundary Conditions
1 From the Physics menu, open the Boundary Settings dialog box.

2 Enter the following boundary settings; when done, click OK.

The value of LT is taken from Table 5-2 in the Chemical Engineering Module 
User’s Guide.

M E S H  G E N E R A T I O N

1 From the Mesh menu, open the Free Mesh Parameters dialog box.

2 On the Global page, click the Custom mesh size button.

3 Set the Maximum element size to 0.2.

SETTINGS BOUNDARY 1 BOUNDARY 28 ALL OTHERS

Boundary condition Concentration Convective flux Insulation/
Symmetry

c0 c_in - -

SETTINGS BOUNDARY 1 BOUNDARY 28 BOUNDARY 3 ALL OTHERS

Boundary type Inlet Outlet Symmetry 
boundary

Wall

Boundary condition Velocity Pressure, no 
viscous stress

Logarithmic 
wall function

U0 u_in - - -

LT 0.07*0.4 - - -

p0 - 0 - -
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4 Click Remesh, then click OK.

C O M P U T I N G  T H E  S O L U T I O N

Start by computing the flow field.

1 Click the Solver Parameters button on the Main toolbar.

2 Delete segregated group 3 by clicking the Delete button for Group 3.

3 Click the Solver Manager button on the Main toolbar. 

4 On the Solve For page, select k-ε Turbulence Model from the list.

5 Click the Solve button to compute the velocity field.

Now store the stationary velocity field and compute the transient mass transport 
problem.

6 On the Solve For page, select Convection and Diffusion from the list.

7 On the Initial Value page in the Solver Manager dialog box, click the Store Solution 
button.

8 Set the Initial value and Values of variables not solved for and linearization point to 
Stored solution.

9 Click OK.

10 Click the Solver Parameters button on the Main toolbar.

11 From the Analysis list, select Transient.

12 From the Linear system solver list, select Direct (PARDISO)

13 In the Time stepping frame set Times to 0:1:500, the Relative tolerance to 0.0001 
and the Absolute tolerance to 0.00001.

14 Click OK.

15 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To create Figure 5-11, perform the following steps:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, use check boxes to select the plot type Streamline.

3 Go to the Slice page and type 1 in the y-levels edit field.

4 For the z-levels, select the Vector with coordinates option button, and type 0.49 in 
the edit field.

5 Go to the Streamline page, then click the Line Color tab.
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6 Select the Uniform color option button.

7 Click the Color button, select yellow, and click OK.

8 Select Tube from the Line type list.

9 Click the Tube radius button, clear the Auto check box and type 0.3 in the Radius 

scale factor edit field. Click OK.

10 Click the Advanced button.

11 In the Maximum number of integration steps edit field, type 1000. Click OK.

12 Click OK to close the Plot Parameters dialog box and generate the plot.

13 Click the Scene Light button on the Camera toolbar.

To create Figure 5-12, perform the following steps:

1 From the Postprocessing menu, open the Domain Plot Parameters window.

2 On the General page, press Ctrl+A to select all the time steps in the Solutions to use 
list.

3 On the Point page, select Point 52 and enter c_int_out in the y-axis data edit field.

4 Click OK.

Note: We recommend a specific set of solver parameters when applying the k-ε 
Turbulence Model application mode to 3D geometries. These solver parameters are 
provided as default if you start your modeling by first specifying the k-ε Turbulence 
Model application mode in the Model Navigator and then move on to draw your 3D 
geometry. If you do the opposite, that is, first draw your geometry and then add the 
k-ε Turbulence Model application mode by selecting the menu item 
Multiphysics>Model Navigator, you end up with a default set of solver parameters less 
suitable for the model.
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Sw i r l  F l ow A r ound a Ro t a t i n g  D i s k

Introduction

This example models a rotating disk in a tank. The model geometry is shown in 
Figure 5-13. Because the geometry is rotationally symmetric, it is possible to model it 
as a 2D cross section. However, the velocities in the angular direction differ from zero, 
so the model must include all three velocity components, even though the geometry 
is in 2D.

Figure 5-13: The original 3D geometry can be reduced to 2D because the geometry is 
rotationally symmetric.

Model Definition

D O M A I N  E Q U A T I O N S

The flow is described by the Navier-Stokes equations:

 (5-9)
ρ

t∂
∂u ∇ η ∇u ∇u( )T

+( )⋅– ρu ∇⋅ u ∇p+ + F=

∇ u⋅ 0=
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In these equations, u denotes the velocity (m/s), ρ the density (kg/m3), η the 
dynamic viscosity (Pa·s), and p the pressure (Pa). For a stationary, axisymmetric flow 
the equations reduce to (Ref. 1):

 (5-10)

Here u is the radial velocity, v the rotational velocity, and w the axial velocity (m/s). 
In the model you set the volumetric force components Fr, , and Fz to zero. The 
swirling flow is 2D even though the model includes all three velocity components.

B O U N D A R Y  C O N D I T I O N S

Figure 5-14 below shows the boundary conditions.

Figure 5-14: Boundary conditions.

On the stirrer, use the Sliding wall boundary condition to specify the velocities. The 
velocity components in the plane are zero, and that in the angular direction is equal to 
the angular velocity, ω, times the radius, r:

 (5-11)

ρ u∂u
∂r
------ v2

r
-----– w∂u

∂z
------+⎝ ⎠

⎛ ⎞ ∂p
∂r
------+ η 1

r
--- ∂
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------⎝ ⎠
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-----–

∂2u
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---------+ Fr+=

ρ u∂v
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------ uv
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------- w∂v
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------+ +⎝ ⎠

⎛ ⎞ η 1
r
--- ∂
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∂2v
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At the boundaries representing the cylinder surface a No slip condition applies, stating 
that all velocity components equal zero:

 (5-12)

At the boundary corresponding to the rotation axis, use the Axial symmetry boundary 
condition allowing flow in the tangential direction of the boundary but not in the 
normal direction. This is obtained by setting the radial velocity to zero:

 (5-13)

On the top boundary, which is a free surface, use the Symmetry condition to allow for 
flow in the axial and rotational directions only. The boundary condition is 
mathematically similar to the axial symmetry condition.

P O I N T  S E T T I N G S

Because there is no outflow boundary in this model, where the pressure would be 
specified, you need to lock the pressure to some reference pressure in a point. In this 
model, set the pressure to zero in the top right corner.

Results

The parametric solver provides the solution for four different angular velocities. 
Figure 5-15 shows the results for the smallest angular velocity, ω = 0.25π rad/s.

u 0 0 0, ,( )=

u 0=
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Figure 5-15: Results for angular velocity ω= 0.25π rad/s. The surface plot shows the 
magnitude of the velocity field and the white lines are streamlines of the velocity field.

The shape of the two recirculation zones, which are visualized with streamlines, 
changes as the angular velocity increases. Figure 5-16 shows the streamlines of the 
velocity field for higher angular velocities.

Figure 5-16: Results for angular velocities ω =  0.5π, 2π, and 4π rad/s. The surface plot 
shows the magnitude of the velocity and the white lines are streamlines of the velocity field.
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Figures 5-17 and 5-18 show isocontours of the rotational velocity component 
together with surface plots of the velocity magnitude for different angular velocities.

Figure 5-17: Isocontours for the azimuthal velocity component for angular velocity ω = 
0.25π rad/s. The surface plot shows the magnitude of the velocity.

Figure 5-18: Magnitude of the velocity field (surface) and isocontours for the azimuthal 
velocity component for angular velocities (left to right) ω = 0.5π, 2π, and 4π rad/s.
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In a final modification of the model, set the angular velocity to ω = 500π rad/s, 
inducing turbulent flow in the mixer volume. Figure 5-19 shows the turbulent 
viscosity and flow fields under these conditions.

Figure 5-19: Results for angular velocity ω = 500π rad/s. The surface plot shows the 
turbulent viscosity and the white lines are streamlines of the velocity field.

Reference

1. P.M. Gresho and R.L. Sani, Incompressible Flow and the Finite Element Method, 
vol. 2, p. 469, John Wiley and Sons Ltd, 1998.

Model Library path: Chemical_Engineering_Module/
Mixers_and_Stirred_Vessels/rotating_disk
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Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics.

2 In the Model Navigator, select Axial symmetry (2D) from the Space dimension list.

3 Select Chemical Engineering Module>Momentum Transport>Laminar Flow 
>Swirl Flow.

4 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, open the Axes/Grid Settings dialog box.

2 On the Axis page, set r-z limits according to the following table:

3 On the Grid page, clear the Auto check box.

4 Enter r-z grid settings according to the following table:

5 Click OK.

6 From the Options menu, open the Constants dialog box.

7 Enter constants according to the table below (the descriptions are optional).

8 Click OK.

r min -0.005

r max 0.025

z min -0.005

z max 0.045

r spacing 0.01

Extra r 0.001 0.008

z spacing 0.01

Extra z 0.014 0.017

NAME EXPRESSION DESCRIPTION

rho 1000[kg/m^3] Density

eta 1e-3[Pa*s] Viscosity
R  5 :  M I X E R S  A N D  S T I R R E D  VE S S E L S



G E O M E T R Y  M O D E L I N G

Use the line tool to create the geometry.

1 Click the Line button in the Draw toolbar.

2 Click the following sequence of points. (0, 0), (0.02, 0), (0.02, 0.04), 
(0.001, 0.04), (0.001, 0.017), (0.008, 0.017), (0.008, 0.014), and (0, 0.014).

3 Close the geometry by right-clicking anywhere in the geometry.

4 Click the Zoom Extents button on the Main toolbar.

S U B D O M A I N  S E T T I N G S

From the Physics menu, open the Subdomain Settings dialog box. Select Subdomain 1, 
then enter the fluid properties given by the table below. When finished, click OK.

B O U N D A R Y  C O N D I T I O N S

From the Physics menu, open the Boundary Settings dialog box. Enter the boundary 
conditions in the table below (the default condition is Wall/No slip). When finished, 
click OK.

PO I N T  S E T T I N G S

1 From the Physics menu, open the Point Settings dialog box.

2 From the Point selection list, select Point 8.

3 Select the Point constraint check box.

4 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, open the Free Mesh Parameters dialog box.

QUANTITY VALUE/EXPRESSION

 ρ rho

 η eta

SETTINGS BOUNDARY 1 BOUNDARIES 2, 8 BOUNDARIES 3–5, 7 BOUNDARY 6

Boundary 
type

Symmetry 
boundary 

Wall Wall Symmetry 
boundary

Boundary 
condition

Axial symmetry No slip Sliding wall Symmetry

Uw 0

ww omega*r
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2 Click the Custom mesh size button.

3 Set the Maximum element size to 2e-3.

4 Click the Boundary tab, then select all entries in the Boundary selection list by clicking 
in the list and then pressing Ctrl+A.

5 Set the Maximum element size to 5e-4.

6 Click Remesh. When the mesher has finished, click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 From the Solver list, select Parametric.

3 In the Parameter name edit field, type omega.

4 In the Parameter values edit field, type 0.25*pi 0.5*pi 2*pi 4*pi.

5 Click OK.

6 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To create Figure 5-15 do the following steps:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, select the Surface, Streamline, and Geometry edges check boxes 
to enable those plot types.

3 From the Parameter value list in the Solution to use area, select 0.785398 (which is 
approximately equal to 0.25π).

4 On the Surface page, verify that Swirl Flow (chns)>Velocity field is selected from the 
Predefined quantities list on the Surface Data page. From the Unit list, select mm/s.

5 On the Streamline page, select Uniform density from the Streamline plot type list.

6 In the Separating distance edit field, type 0.02.

7 Click the Line Color tab.

8 Click the Uniform color button, then click the Color button.

9 Select the white swatch, then click OK.

10 Click the Contour tab.

11 In the Number of levels edit field, type 15.

12 Click Apply in the Plot Parameters dialog box to generate the plot.
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13 To generate the plots in Figure 5-16, return to the General page and select, in turn, 
the solutions for the parameter values 0.5π, 2π, and 4π from the Parameter value list, 
clicking Apply in between.

To generate the plot in Figure 5-17, proceed as follows:

14 In the Plot type area, select the Surface, Contour, and Geometry edges check boxes 
and clear all other Plot type check boxes.

15 From the Parameter value list, select 0.785398.

16 Click the Contour tab.

17 From the Predefined quantities list, select Swirl Flow (chns)> -velocity.

18 In the Contour color area, click first the Uniform color button and then the Color 
button.

19 Select the white swatch, then click OK.

20 Click Apply in the Plot Parameters dialog box.

21 Return to the General page.

22 Select, in turn the solutions for the parameter values 0.5π, 2π, and 4π from the 
Parameter value list, clicking Apply in between to generate the corresponding plots 
in Figure 5-18.

23 When done, click Cancel or OK to close the dialog box.

Now, modify the model to simulate turbulent swirl flow.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, open the Constants dialog box.

2 Add the following constant to the list.

3 Click OK.

P H Y S I C S  S E T T I N G S

1 From the Physics menu, select Properties.

2 Select k-ε from the Turbulence model list, then click OK.

B O U N D A R Y  C O N D I T I O N S

1 From the Physics menu, open the Boundary Settings dialog box.

NAME EXPRESSION DESCRIPTION

omega 500*pi[rad/s] Angular velocity

ϕ
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2 Enter the boundary conditions given in the table below. For the boundaries that are 
not listed, the conditions you specified for the laminar case still apply.

You can ignore the unexpected base unit warning for ww. It appears because the 
constant omega is the current solver parameter.

3 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 From the Solver list, select Stationary segregated.

3 Click OK.

4 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate Figure 5-19 execute the following steps:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, select the Surface, Streamline, and Geometry edges check boxes 
and clear all other Plot type check boxes.

3 Click the Streamline tab.

4 From the Predefined quantities list, select Swirl Flow (chns)>Velocity field.

5 Click the Surface tab.

6 From the Predefined quantities list, select Swirl Flow (chns)>Turbulent viscosity.

7 Click OK to generate the plot and close the dialog box.

SETTINGS BOUNDARIES 2, 8 BOUNDARIES 3–5, 7

Type Wall Wall

Condition Logarithmic wall function Sliding wall

Uw 0

ww omega*r

100 100δw
+
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Mode l i n g  o f  Ro t a t i n g  Pa r t s

Introduction

This exercise exemplifies the use of the rotating machinery feature in the Chemical 
Engineering Module. The Rotating Machinery predefined multiphysics coupling 
allows you to model moving rotating parts in, for example, stirred tanks, mixers, and 
pumps.

This combination of application modes formulates the Navier-Stokes equations in a 
rotating coordinate system. Parts that are not rotated are expressed in the fixed 
coordinate system. The predefined coupling then takes care of the necessary 
administration to join the parts of the model that use a rotating coordinate system with 
the parts that are fixed.

You can use the rotating machinery predefined multiphysics coupling in cases where it 
is possible to divide the modeled device into rotationally invariant geometries. The 
desired operation can be, for example, to rotate an impeller in a baffled tank. This is 
exemplified in Figure 5-20, where the impeller rotates from position 1 to 2. The first 
step is to divide the geometry into two parts that are both rotationally invariant, as 
shown in Step 1a. The second step is to specify the parts to model using a rotating 
frame and the ones to model using a fixed frame (Step 1b). The predefined coupling 
then automatically does the coordinate transformation and the joining of the fixed and 
moving parts (Step 2a).

Figure 5-20: The modeling procedure in the rotating machinery application mode in the 
Chemical Engineering Module.

1 2

1a 1b 2a
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Model Definition

The model you treat in this example is that of a pump. Despite the model being 
somewhat schematic, the example contains all the components needed to describe 
more realistic geometries. Figure 5-21 shows the modeled geometry. The impeller 
rotates clockwise at a speed of 10 RPM.

The model equations are the Navier-Stokes equations formulated in a rotating frame 
in the inner subdomain and in fixed coordinates in the outer one.

At the pump’s fixed wall no-slip boundary conditions apply. The boundary conditions 
for the impeller blades are no-slip clockwise rotation conditions. At the pump inlet and 
outlet, you set the normal stress to zero.

The implementation, using the Rotating Navier-Stokes predefined multiphysics 
coupling, is quite straightforward. First you draw the geometry using two separate 
subdomains for the fixed and rotating parts. Then you activate the assembly feature, 
which makes it possible to treat the two subdomains as separate parts in an assembly. 
You then specify which part uses a rotating frame. Once you have done this, you can 
proceed to the usual steps of setting the fluid properties and the boundary conditions, 
and finally to meshing and solving the problem.

Figure 5-21: Geometry of the schematic pump. The inner subdomain is described in a 
rotating frame and the outer one in a fixed frame.

Inner
subdomain

Outer
subdomain
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Results

Figure 5-22 below shows the flow field as the modulus of the velocity vector and as 
equidistant streamlines.

Figure 5-22: The flow field after 20 seconds. The plot shows that two small eddies are 
formed when the blades enters the inlet and outlet sections.

In Figure 5-22, you can clearly see that two eddies are created as the blades of the 
pump pass inlet and outlet sections. These eddies reduce the efficiency of the pump. 
In addition, the streamlines show that a large part of the fluid rotates around the blade 
without leaving the pump. 

By decreasing the cross section of the recirculation area in the pump, it is possible to 
increase the performance of the pump as a function of the rotating speed of the blades. 
Figure 5-23 shows the velocity field for such a pump geometry. The net flow through 
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the pump compared to the case shown in Figure 5-22 is increased by almost a factor 
of 5 without increasing the rotational speed of the pump.

Figure 5-23: Velocity field for an improved geometry, where parts of the recirculation 
section has been removed.

Model Library path: Chemical_Engineering_Module/
Mixers_and_Stirred_Vessels/schematic_pump_1

Model Library path: Chemical_Engineering_Module/
Mixers_and_Stirred_Vessels/schematic_pump_2

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics.
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2 In the Model Navigator, select 2D from the Space dimension list.

3 From the list of application modes, select 
Chemical Engineering Module>Rotating Machinery>Rotating Navier-Stokes.

4 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

2 Enter the following constants; when done, click OK.

Note that in this example you specify the rotation speed in revolutions per minute.

G E O M E T R Y  M O D E L I N G

1 Shift-click the Ellipse/Circle (Centered) button on the Draw toolbar. Draw a circle of 
radius 4e-3 centered at the point (0, 0).

2 Click the Zoom Extents button in the Main toolbar.

3 Shift-click the Rectangle/Square button on the Draw toolbar. Specify a rectangle with 
the following settings; when finished, click OK.

4 Press Ctrl+A to select both objects.

5 Click the Create Composite Object button on the Draw toolbar. Clear the 
Keep interior boundaries check box. Click OK.

6 Create a second rectangle with the following properties; when finished, click OK.

7 Again, press Ctrl+A to select both objects. 

8 Click the Create Composite Object button, then click OK.

9 Shift-click the Ellipse/Circle (Centered) button on the Draw toolbar. Draw a circle of 
radius 3e-3 centered at the point (0, 0).

NAME EXPRESSION DESCRIPTION

rho 1e3[kg/m^3] Density

eta 1e-2[Pa*s] Viscosity

rpm 10[1/min] Rotation speed

OBJECT WIDTH HEIGHT BASE X BASE Y

R1 2e-3 6e-3 -4e-3 -6e-3

OBJECT WIDTH HEIGHT BASE X BASE Y

R1 6e-3 2e-3 0 2e-3
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10 Press Ctrl+A to select both objects.

11 Click the Create Composite Object button on the Draw toolbar. Activate the 
Keep interior boundaries check box. Click OK.

12 Click the Split Object button on the Draw toolbar.

13 Shift-click the Rectangle/Square button on the Draw toolbar. In the Width field type 
5e-3, and in the Height field type 1e-4. Set Base to Center, then click OK.

14 Press Ctrl+C to make a copy of the rectangle.

15 Press Ctrl+V and click OK.

16 Click the Rotate button on the Draw toolbar.

17 Set the Rotation angle to 90 degrees, then click OK.

18 Shift-click to select both rectangles. Click the Create Composite Object button on the 
Draw toolbar. Clear the Keep interior boundaries check box, then click OK.

19 Shift-click again to select the cross and the inner circle. Click the Difference button 
on the Draw toolbar.

20 Press Ctrl+A.

21 In the Draw menu, activate the Use Assembly option.

22 From the Draw menu, select Create Pairs. Click OK.

23 Click the Zoom Extents button in the main toolbar.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Multiphysics menu, select the Moving Mesh (ALE) (ale) application mode.

2 From the Physics menu, select Subdomain Settings. 

3 Select Subdomain 2.

4 In the Subdomain selection area, set the Group selection to rotate_CW.

5 Click OK.

6 From the Multiphysics menu, select Incompressible Navier-Stokes (chns).

7 From the Physics menu, select Subdomain Settings.

8 For both subdomains, set the Density to rho and the Dynamic viscosity to eta.

9 Click OK to close the Subdomain Settings dialog box.

Boundary Conditions
1 From the Physics menu, select Boundary Settings.
R  5 :  M I X E R S  A N D  S T I R R E D  VE S S E L S



2 Select boundary 15–26 (the twelve boundaries on the impeller surface).

3 In the Boundary selection area, set the Group selection to no_slip_CW.

4 Select Boundaries 2 and 6. Choose the Boundary type Open Boundary and select 
Normal stress from the Boundary condition list. Leave f0 at zero.

5 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters.

2 From the Predefined mesh sizes list, select Fine. 

3 Click OK to close the Free Mesh Parameters dialog box.

4 Click the Initialize Mesh button on the Main toolbar.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 In the Time stepping area on the General page, set Times to 0:0.5:20, Relative 

tolerance to 1e-4, and Absolute tolerance to 1e-5.

3 Click OK to close the dialog box, then click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows the magnitude of the velocity field. To reproduce the plot in 
Figure 5-22, follow these instructions:

1 From the Postprocessing menu, open the Plot Parameters dialog box.

2 On the Surface page, verify that Velocity field is selected in the Predefined quantities 
list on the Surface Data page. From the Unit list, select mm/s.

3 On the Arrow page, select the Arrow plot check box.

4 Verify that Velocity field is selected in the Predefined quantities list on the 
Subdomain Data page.

5 In the Arrow parameters area, select 3D arrow from the Arrow type list.

6 Click the Color button. In the Arrow Color dialog box, select black. Click OK.

7 On the Streamline page, select the Streamline plot check box.

8 Verify that Velocity field is selected in the Predefined quantities list on the 
Streamline Data page.

9 From the Streamline plot type list, select Uniform density. On the Density page, set 
the Separating distance to 0.02.
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10 On the Line Color page, click the Color button. In the Streamline Color dialog box, 
select white. Click OK.

11 On the General page, clear the Geometry edges check box in the Plot type area.

12 Verify that the selection in the Solution at time list is 20.

13 Click OK to close the Plot Parameters dialog box and generate the plot.
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M u l t i p h a s e  F l o w
This chapter contains examples of multiphase fluid flow. 

The first four models—Rigid Body Motion, Rising Bubble, Boiling Flow, and 
Droplet Breakup of a T-Junction—use physical descriptions where the phase 
boundary is tracked in detail. These models account for the effect of gravity, surface 
tension, and phase change; tracking the phase boundary with a level set method.

For many industrial applications, the macroscopic motion of flow is of more 
importance than the detailed dynamics of each phase interface. The examples in this 
section include the flow within a bubble column reactor, the separation of solid 
particles from water during wastewater treatment, and the dynamics of a dense 
suspension.
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R i g i d  Bod y Mo t i o n

Introduction

This is a simple tutorial model that demonstrates how to use the Level Set application 
mode to track a moving interface. The example shows how to set up the model and 
how the choice of the level set parameters effects the solution.

Model Definition

In this example you use the Level Set application mode to model a circle that rotates 
around the origin. The velocity field is given by

where ω is the angular frequency (rad/s). Figure 6-1 shows the computational domain 
together with the initial position of the interface.

Figure 6-1: Computational domain (large circle) and initial position of the interface 
(small circle).

The corresponding level set equation is given by 

 (6-1)

The interface, in this case the smaller circle, is defined by the  contour.

u ωy– ωx,( )=

t∂
∂φ u φ∇⋅+ γ∇ ε φ∇ φ 1 φ–( ) φ∇

φ∇
----------–⎝ ⎠

⎛ ⎞⋅=

φ 0.5=
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After setting up the problem using the Level Set application mode, the example 
explains how to choose the level set parameters ε and γ for optimal results.

Results

To get accurate results, it is important that you give suitable values for the parameters 
γ and ε. Most important is γ, while the default value on ε usually gives satisfying results. 
Figure 6-2 shows the initial interface and the position of the interface 1 s, for γ = 1 and 
γ = 0.01. The result using γ = 0.01 is significantly better for this problem, because less 
artificial stabilization is added. However, if γ is chosen smaller still, numerical 
instabilities lead to oscillations.

Figure 6-2: Initial interface and interface after 1 s for γ = 1 (left) and γ = 0.01 (right).

By using a constant value for ε on the entire computational domain, the solution is 
even more accurate. Figure 6-3 shows the result for γ = 0.01 and ε = 0.06. Because ε is 
constant within the entire computational domain, the thickness of the interface is 
constant.

γ = 1 γ = 0.01
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Figure 6-3: Solution at t = 1 s for γ = 0.01 and ε = 0.06.

Model Library path:  
Chemical_Engineering_Module/Multiphase_Flow/rigid_body_motion

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 In the Model Navigator, select 2D from the Space dimension list.

2 From the list of application modes, select Chemical Engineering Module> 
Momentum Transport>Multiphase Flow>Level Set.

3 Click OK.

G E O M E T R Y  M O D E L I N G

1 On the Draw toolbar, click the Ellipse/Circle (Centered) button. Click the point (0, 0) 
and drag the pointer to draw a circle with radius 0.8. Click again to create the circle. 
Click the Ellipse/Circle (Centered) button once more and create another circle 
centered at (0, 0.4) with radius 0.2.

2 Click the Zoom Extents button on the Main toolbar.
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O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

2 Define the following constant (the description is optional):

3 Click OK.

4 From the Options menu, select Expressions>Scalar Expressions. 

5 Define the following two variables:

6 Click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Physics menu, select Subdomain Settings.

2 Ctrl-click to select both Subdomain 1 and Subdomain 2.

3 Type u in the x-velocity edit field and v in the y-velocity field.

4 Click the Init tab.

5 Select Subdomain 1 and type 0 in the edit field for the initial condition.

6 Select Subdomain 2 and type 1 in the edit field for the initial condition.

7 Click OK.

Boundary Conditions
1 From the Physics menu, select Boundary Settings.

2 Select Boundaries 3, 4, 6, and 7, then select the Interior boundaries check box. 

3 From the Boundary condition list, select Initial interface.

4 Click OK.

M E S H  G E N E R A T I O N

1 Click the Initialize Mesh button on the Main toolbar. 

NAME EXPRESSION DESCRIPTION

omega 1[rad/s] Angular frequency

NAME EXPRESSION DESCRIPTION

u -y*omega x-component of velocity

v x*omega y-component of velocity
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2 In general, a relatively fine mesh is required to get accurate results for this kind of 
problem. Therefore, click the Refine Mesh button on the Main toolbar to create a 
finer grid.

C O M P U T I N G  T H E  S O L U T I O N — I N I T I A L I Z A T I O N

1 From the Solve menu, select Get Initial Value.

2 Click the Plot Parameters button on the Main toolbar.

3 Click the Surface tab. On the Surface Data page, type 5*epsilon_mmls/gamma_mmls 
in the Expression edit field. Click OK.

The maximum of 5ε/γ is a suitable time for initialization, in this case 0.3 s.

4 Click the Solver Parameters button on the Main toolbar. Type 0.3 in the Times edit 
field. Click OK.

5 Click the Solve button on the Main toolbar to solve for the initial level set function.

6 Click the Solver Manager button on the Main toolbar.

7 Click the Store Solution button.

8 From the Solution at time list, select 0.3, then click OK.

9 In the Initial value area, select Stored solution and select 0.3 from the Solution at time 
list.

10 Click OK.

C O M P U T I N G  T H E  S O L U T I O N  A N D  P O S T P R O C E S S I N G

1 Click the Solver Parameters button on the Main toolbar. Type 0:0.1:1 in the Times 
edit field. Click OK.

2 In the Model Tree, right-click Level Set (mmls) and select Properties.

3 Select Transient from the Analysis type list, then click OK.

4 Click the Solve button on the Main toolbar.

5 Click the Plot Parameters button on the Main toolbar. 

6 On the General page, clear the Surface check box and select the Contour check box.

7 Click the Contour tab.

8 Click the Vector with isolevels option button, then type 0.5 in the corresponding 
edit field.

9 Click OK. 
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10 Click the Zoom Window button on the Main toolbar if you want to inspect the 
position of the interface in more detail. Then click the Zoom Extents button to view 
the entire computational domain.

The resulting solution is quite poor. The reason is that the reinitialization parameter γ 
is too large. Therefore, change the value of  γ and compute a new solution:

1 In the Model Tree, double-click Level Set (mmls)>Subdomain Settings.

2 Click the Physics tab.

3 Select both subdomains, then type 0.01 in the γ edit field. Click OK.

4 Click the Solve button on the Main toolbar.

The solution can be improved further if  ε is constant in all domains the interface passes.

1 Click the Plot Parameters button on the Main toolbar. 

2 On the Surface page, select the Surface plot check box. 

3 On the Surface Data page, type epsilon_mmls in the Expression edit field 
(epsilon_mmls is the name of the variable for ε).

4 Click OK to create the plot in Figure 6-4.

Figure 6-4: Surface plot of the parameter ε.

As you can see, ε is constant within each of the two subdomains but differs between 
the two domains. The maximum value is about 0.06. To further improve the results, 
let ε be constant in the whole domain.

5 In the Model Tree, double-click Level Set (mmls)>Subdomain Settings.

6 Click the Physics tab.
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7 Select both subdomains and type 0.06 in the ε edit field. Click OK.

8 In the Model Tree, right-click Level Set (mmls) and select Properties. 

9 Select Transient initialization from the Analysis type list, then click OK.

10 Click the Solver Parameters button on the Main toolbar. Type 30 in the Times edit 
field. Click OK.

Note that because γ now is only 0.01, a suitable time for initialization is 30 s instead 
of 0.3 s.

11 Click the Solver Manager button on the Main toolbar.

12 In the Initial value area, click the Initial value expression option button. 

13 Click the Solve button. When the solver has finished, click the Store Solution button.

14 From the Solution at time list, select 30, then click OK.

15 In the Initial value area, click the Stored solution option button and select 30 from 
the Solution at time list. Click OK.

16 In the Model Tree, right-click Level Set (mmls) and select Properties.

17 Select Transient from the Analysis type list, then click OK.

18 Click the Solver Parameters button on the Main toolbar. Type 0:0.1:1 in the Times 
edit field. Click OK.

19 Click the Solve button on the Main toolbar.

20 Click the Plot Parameters button on the Main toolbar.

21 Clear the Surface plot check box, then click OK to generate the plot in Figure 6-3.

If you solve for a longer time, the accuracy of the solution decreases with time. To 
further improve the accuracy, you can reduce the error tolerances. You specify the 
tolerances in the Solver Parameters dialog box on General page. There, you can for 
instance set the Relative tolerance to 0.001 and the Absolute tolerance to 0.0001.
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R i s i n g  Bubb l e  Mode l e d  w i t h  t h e  L e v e l  
S e t  Me t hod

Introduction

This example shows a model of two immiscible fluids using a level set method. The 
level set method is well suited for problems with moving boundaries in which the 
geometry’s topology changes with time. A bubble of oil that travels up through water 
and finally merges with oil at the top causes this kind of topology change. For problems 
where the topology is unchanged as a function of time, as in free surface movement in 
a tank (no splashing) and impeller stirring, it is also possible to use the ALE (arbitrary 
Lagrangian-Eulerian) method.

Three different regions exist initially: the oil bubble, the oil at the top of the container, 
and the water surrounding the bubble (see Figure 6-5). The Level Set Two-Phase 
Flow application mode makes it easy to set up the model.

This model treats an oil bubble traveling through water to finally merge with oil 
already residing at the top of the container. The container is cylindrical with a diameter 
of 1 · 10−2 m and a height of 1.5 · 10−2 m. Figure 6-5 depicts the initial position of the 
two fluids. Both geometry and initial data are axisymmetric.

Figure 6-5: Initial bubble position.

Oil

Water
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The oil studied in this example has viscosity 0.0168 Pa·s and density 880 kg/m3. For 
water viscosity is 1.04 · 10−3 Pa·s and density 997 kg/m3. The driving force for the 
bubble’s movement is the difference in density between oil and water. The oil is lighter 
than water and the bubble therefore starts to rise due to gravitation. 

A level set method is used to track the interface. This means that the interface is 
represented by a certain level set or contour of the globally defined level set function, 

. The level set application modes in COMSOL Multiphysics use a smooth step 
function with the interface defined by the contour  as level set function. The 
water is located in the domain where , while the oil occupies the domain 
where . The function is continuously reinitialized so that it keeps the 
correct shape across the interface. 

Model Definition

The momentum and mass transport are governed by the Navier-Stokes equations:

 (6-2)

.  (6-3)

In the above equations, ρ (kg/m3) denotes the density, u is the velocity (m/s), t 
equals time (s), η represents the viscosity (Pa·s), p equals the pressure (Pa), σ is the 
surface tension coefficient, n is the unit normal to the interface,  is the 
curvature of the fluid interface, δ is a delta function concentrated at the interface 
between the fluids, and g is the gravity vector.

In Equation 6-2, the term σ κ nδ defines the surface tension forces and ρg is the gravity 
force. Equation 6-3 is the continuity equation, which follows from mass conservation 
and incompressibility of the fluids.

The level set method models the fluid interface by tracing the isolines of the level set 
function, . The level set or isocontour  determines the position of the 
interface.  is transported and reinitialized by the equation

,  (6-4)

where u is the fluid velocity, and γ and ε are reinitialization parameters. The parameter 
ε determines the thickness of the layer around the interface where goes from zero to 
one.

φ
φ 0.5=

0 φ 0.5≤ ≤
0.5 φ 1≤ ≤

ρ ∂u
∂t
------- u ∇u⋅+⎝ ⎠
⎛ ⎞ ∇ η ∇u ∇uT

+( )[ ]⋅– p∇+ σκnδ ρg+=

∇ u⋅ 0=

κ ∇ n⋅–=

φ φ 0.5=

φ

∂φ
∂t
------ u ∇φ⋅+ γ∇ φ– 1 φ–( ) ∇φ

∇φ
---------- ε∇φ+⎝ ⎠

⎛ ⎞⋅=

φ
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Because the level set function is a smooth step function, it is used to determine the 
density and dynamic viscosity globally by

and

where ρw, µw, ρo, and µo denote the constant density and viscosity of water and oil, 
respectively.

The application mode also uses  to calculate a smooth δ-function,

,

and to calculate the interface normal from the expression

.  (6-5)

I N I T I A L  C O N D I T I O N

At t = 0, the velocity and pressure are both zero. The initial  is given in Figure 6-6.

Figure 6-6: A surface and contour plot of the initial level set function.

B O U N D A R Y  S E T T I N G S

No-slip conditions, u = 0, are used at the top and bottom of the cylinder. Slip 
conditions are used at the vertical walls in order to allow the fluid interface to move 
along these walls.

ρ ρw ρo ρw–( )φ+=

µ µw µo µw–( )φ,+=

φ

δ 6 φ 1 φ–( ) ∇φ=

n φ∇
∇φ

----------
φ 0.5=

=

φ
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Results and Discussion

Figure 6-7 contains snapshots of the fluid interface. The snapshots show how the 
bubble travels up through the water and merges with the oil above. As the bubble rises, 
its shape remains spherical because the viscosity of the oil is large and because of the 
surface tension. As the droplet hits the water surface, it splashes and creates waves on 
the surface. 
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Figure 6-7: The initial interface position together with snapshot images showing the fluid 
interface at different times.

t = 0.04 s t = 0.08 s t = 0.12 s

t = 0.16 s t = 0.20 s t = 0.24 s

t = 0.30 s t = 0.40 s t = 0.50 s
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One way to investigate the quality of the numerical results is to check the conservation 
of mass. Because there are no reactions and no flow through the boundaries, the total 
mass of each fluid should be constant in time. Figure 6-8 shows the total mass of oil as 
a function of time. During the simulation, there is a mass loss of about 0.05%, which 
shows that mass is very well conserved by the model. The reason for the small mass loss 
is that the divergence-free condition on the velocity is not exactly fulfilled for the P2P1 
elements used for the velocity and pressure. See the section “The Level Set Method for 
Two-Phase Flow” on page 165 of the Chemical Engineering Module User’s Guide 
for information on how you can obtain exact mass conservation by using the 
application mode property Conservative level set.

Figure 6-8: Total mass of oil as a function of time. The total mass loss during the 
simulation is small, about 0.05%.

Modeling in COMSOL Multiphysics

It is straightforward to set up the model with the Level Set Two-Phase Flow 
application mode available in the Chemical Engineering Module. You first initialize the 
level set function, then store the solution, change to the Transient analysis type, and 
start the fluid flow calculation.

Model Library path: Chemical_Engineering_Module/Multiphase_Flow/
rising_bubble
R  6 :  M U L T I P H A S E  F L O W



Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 In the Model Navigator select Axial symmetry (2D) from the Space dimension list.

2 From the list of application modes select Chemical Engineering Module> 
Momentum Transport>Multiphase Flow>Level Set Two-Phase Flow, Laminar.

3 Click OK to close the Model Navigator.

G E O M E T R Y  M O D E L I N G

1 Shift-click the Rectangle/Square button on the Draw toolbar.

2 Specify the rectangle with these settings:

3 Click OK and then click the Zoom Extents button on the Main toolbar.

4 Click the 2nd Degree Bézier Curve on the Draw toolbar to draw a circular arc. Click 
the points (0, 6e-3), (2e-3, 6e-3), (2e-3, 4e-3), (2e-3, 2e-3), (0, 2e-3). The 
coordinates of the pointer appear in the lower left corner of the graphical user 
interface. Right-click to finalize the curve.

5 Click the Line button, also on the Draw toolbar. Click the points (0, 0.01) and 
(6e-3,0.01). Right-click to create the line, then double-click the line you just drew. 
Select 1 from the Curve selection list. Replace the number on the second row of the 
r column by 0.005 and click OK.

O P T I O N S  A N D  S E T T I N G S

1 Select Constants from the Options menu and enter the following constant names and 
expressions; when done, click OK.

PROPERTY EXPRESSION

Width 5e-3

Height 1.5e-2

Position, r 0

Position, z 0

NAME EXPRESSION DESCRIPTION

etaW 1.04e-3[Pa*s] Viscosity of water

etaO 0.0168[Pa*s] Viscosity of oil

rhoW 997[kg/m^3] Density of water

rhoO 880[kg/m^3] Density of oil
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2 Click Options>Integration Coupling Variables>Subdomain Variables, and select all 
three subdomains by selecting one and then clicking Ctrl+A. Enter the following 
variable in the dialog box; when done, click OK. 

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 Open the Subdomain Settings dialog box from the Physics menu and select all 

subdomains.

2 Enter fluid properties according to the following table:

3 On the Sources/Sinks page, type sigma in the Surface tension coefficient edit field and 
gz in the Gravitation, z component edit field.

4 On the Level Set page, type 0.1 in the γ edit field.

5 Click the Init tab. Select Subdomains 2 and 3, then click the option button Fluid 2.

6 Click OK.

Boundary Conditions
1 Open the Boundary Settings dialog box from the Physics menu.

2 Select Boundaries 1, 3, 4, and 5, then set the Boundary type to Symmetry boundary 
and the Boundary condition to Axial symmetry.

3 Select Boundaries 8 and 9, then set the type to Symmetry boundary and the 
condition to Symmetry.

gz -9.81[m/s^2] Gravity constant

sigma 0.073[N/m] Surface tension coefficient

NAME EXPRESSION

mass 2*pi*r*rhoO*phi

QUANTITY VALUE/EXPRESSION DESCRIPTION

 ρ1 rhoW Density, fluid 1

 η1 etaW Dynamic viscosity, fluid 1

 ρ2 rhoO Density, fluid 2

 η2 etaO Dynamic viscosity, fluid 2

NAME EXPRESSION DESCRIPTION
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4 Select Boundaries 6, 10, and 11, then select the Interior boundaries check box. Set 
Initial fluid interface as boundary condition.

For the other boundaries, the default condition (Wall, No slip) applies.

5 Click OK.

Point Settings
1 Open the Point Settings dialog box from the Physics menu.

2 Select Point 7 from the Point selection list (the lower right corner).

3 Select the Point constraint check box and leave p0 at zero. Click OK.

M E S H  G E N E R A T I O N

1 Click the Initialize Mesh button on the Main toolbar.

2 Click the Refine Mesh button twice to obtain a sufficient mesh resolution.

The resulting mesh should consist of about 6400 elements.

C O M P U T I N G  T H E  S O L U T I O N

You first have to calculate the initial level set function.

1 Open the Solver Parameters dialog box by selecting Solve>Solver Parameters.

2 In the Time stepping area, type 1e-2 in the Times edit field, 0.1 in the Relative 

tolerance edit field, and 0.01 in the Absolute tolerance edit field. Click OK.

3 Click the Solve button on the Main toolbar.

The following figure shows the plot you should obtain.

Initial level set function.

Use the obtained solution as initial condition for the motion of the rising bubble:
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4 Click the Solver Manager button on the Main toolbar.

5 On the Initial Value page, click the Store Solution button. Select 0.01, then click OK.

6 In the Initial value area, click the Stored solution option button. Select 0.01 from the 
Solution at time list.

7 Click OK.

8 From the Physics menu, select Properties. Change the Analysis type to Transient. 
Click OK.

9 Open the Solver Parameters dialog box.

10 In the Time stepping area, type 0:1e-2:0.5 in the Times edit field. Click OK.

11 Click the Solve button on the Main toolbar to compute the solution.

The solution takes 30–60 minutes to calculate.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

First plot the distribution of oil and water as in Figure 6-7:

1 Click the Plot Parameters button on the Main toolbar.

2 Clear the Surface plot check box.

3 On the Contour page, select the Contour plot check box. From the Predefined 

quantities list, select Volume fraction of fluid 2. Select the Filled check box.

4 Click the Vector with isolevels option button and type 0.5 in the corresponding edit 
field.

5 Click the General tab and select a time from the Solution at time list. Click Apply.

6 Repeat Step 5 above to plot the solution at other times.

7 Click OK.

To create the 3D images of the fluid interface, do the following steps:

1 From the Draw menu, choose Revolve.

2 Select R1, CO1, and B1 from the Objects to revolve list and click OK.

3 In the Model Tree, click Geom1 to return to the two-dimensional model.

4 Choose Options>Extrusion Coupling Variables>Subdomain Variables.

5 Select all subdomains.

6 Type phi3d in the Name edit field and phi in the Expression edit field.

7 Select General transformation.

8 Click the Destination tab.
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9 In the Geometry list, select Geom2.

10 In the Level list, select Subdomain.

11 Select all three subdomains.

12 Select the Use selected subdomains as destination check box.

13 Type sqrt(x^2+z^2) in the x edit field, then click OK.

14 From the Solve menu, choose Update Model.

15 Click the Plot Parameters button on the Main toolbar.

16 Click the General tab. Clear the Geometry edges and Slice check boxes and select the 
Isosurface check box.

17 Clear the Element refinement Auto check box and type 4 in the edit field.

18 Click the Isosurface tab.

19 Type phi3d in the Expression field. Select Vector with isolevels and type 0.5 in the 
corresponding edit field.

20 Select Uniform Color and click the Color button. Choose a blue color to plot the fluid 
interface. Click OK.

21 Click the General tab. In the Solution at time list, select 0. Click OK.

22 Click the Scene Light button on the Camera toolbar.

23 Click the Camera Parameters button on the Camera toolbar to open the Camera 

Parameters dialog box. Click the Y option button in the Camera constraint area and 
the Vertical option button in the Mouse constraint area. Click in the drawing area and 
hold the mouse button down as you move the mouse pointer to rotate the object 
to obtain the plot in Figure 6-9.

Figure 6-9: 3D plot of the initial position of the fluid interfaces.
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24 To plot the solution at other times, click the Plot Parameters button and select other 
values in the Solution at time list. Click Apply to plot the solution at the 
corresponding time.

25 To create an animation of the evolving interface, click the Animate button.

Perform the following steps to plot the mass of oil as a function of time:

1 From the Postprocessing menu, select Global Variables Plot.

2 In the Expression edit field type mass, then click the Add Entered Expression button 
(the button marked >).

3 Click OK to generate the plot in Figure 6-8.
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Bo i l i n g  F l ow

This example shows how you can make a detailed fluid flow calculation of a boiling 
fluid, using a level set approach to track the liquid-vapor interface in detail. To model 
boiling flows, you need to account for mass transfer across the phase boundary as well 
as the absorption of latent heat as the liquid evaporates. From the results, you can 
investigate flow field, the temperature evolution, as well as the transient position of the 
phase boundary.

The model is based on results presented in Ref. 1 and Ref. 2, with some modifications.

Model Definition

A liquid is initially at rest above a thin layer of vapor, where the temperature in both 
phases is that of the saturation temperature. A heat flux is applied at the bottom surface 
of the domain and, as the vapor-liquid interface heats up, liquid starts to evaporate 
causing the positions of the two phases and the interface to change. Figure 6-10 shows 
the axisymmetric model’s geometry, the boundary conditions, and the initial position 
of the two phases.

To model boiling flow, you have to couple a thermal transport with a momentum and 
a mass transport using a level set method to represent the phase boundary. In 
COMSOL Multiphysics, it is possible to set up such a model by coupling the Level Set 
Two-Phase Flow application mode with the Convection and Conduction application 
mode, which can be done directly in the graphical user interface.
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Figure 6-10: Model geometry. Liquid is initially present in the upper domain, while the 
lower domain is filled with vapor. The bottom boundary is heated, and the pressure is fixed 
at the upper boundary.

The thermal transport in the fluids is described by the following equation for the 
temperature

where ρ denotes density (kg/m3), Cp heat capacity (J/(kg·K)), k thermal conductivity 
(W/(m·K)), T temperature (K), and u fluid velocity (m/s). The first term on the 
right-hand side of the equation is a source term that accounts for latent heat liberation 
or absorption due to phase change; L denotes latent heat (J/kg), while m is the 
interfacial mass flux (kg/(m2·s)), and δ is a Dirac delta function that is nonzero at the 
phase interface only.

The interface moves as a function of the fluid flow and motion due to phase change:
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where n denotes the unit normal to the interface, directed toward the liquid phase.

The interface is defined by the level set variable  which is a smooth step function 
that takes the value 0 in the gas and 1 in the liquid, with a smooth transition between 
these values across the interface. The 0.5 contour represents the interface. With this 
representation, it is possible to describe the interface by solving the following equation 
for 

The term on the right-hand side of the equation is required to stabilize the equation 
and to preserve the same smooth profile of  across the interface. Suitable values for 
the parameters ε and γ are the size of the mesh elements and the speed of the interface, 
respectively.

Because the interface normal, n, is given by

the level set equation can be expressed as

A momentum balance gives

while the conservation of mass requires that

 (6-6)

Note that even though there is mass transfer between the two phases, the total mass of 
gas and liquid must be conserved.

The material parameters ρ, η, Cp, and k are all approximately constant within each 
phase. To smooth out the discontinuities, the Level Set Two-Phase Flow application 
mode uses the relations

 (6-7)
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B O I L I N G  F L O W  |  257



258 |  C H A P T E
 (6-8)

 (6-9)

In the heat equation, you can use the same approach for the specific heat and the 
conductivity:

where the subscripts “g” and “l” denote the gas and liquid phases, respectively. For 
numerical calculations, it can be helpful to reformulate the mass conservation equation 
using Equation 6-7 and the level set equation, neglecting the stabilizing terms. The 
resulting form of the mass conservation equation is then

 (6-10)

Finally, you must specify an expression for the interfacial mass flux. As discussed in Ref. 
1, it is not yet clear how the mass flux relates to the interface temperature. In this 
example, use the expression

 (6-11)

The result is a mass flux from liquid to vapor when the temperature at the interface is 
larger than Tsat. The constant, C (m/s), relates to the mobility of the interface. The 
larger C is, the more rapidly the boundary is allowed to move due to phase change, 
and the more rapidly the temperature approaches the saturation temperature at the 
interface. Note that you can use any expression of the modeled variables to describe 
the mass flux and that you can enter such an expression directly in the graphical user 
interface. For example, it is straightforward to let the saturation temperature depend 
on, for instance, pressure. It is also possible to use any of the more complex expressions 
discussed in Ref. 1.
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P H Y S I C A L  P A R A M E T E R S

As in Ref. 2, the liquid and vapor have the following physical properties:

The surface tension coefficient is 0.1 N/m, the gravity vector (0, −9.82) m/s2, the 
latent heat 1000 J/kg, and the saturation temperature 273 K. 

L E V E L  S E T  P A R A M E T E R S

In addition to the physical parameters, you need to assign appropriate values for the 
two level set parameters ε and γ. A suitable value for ε is the maximum mesh element 
size. The parameter γ should be approximately as large as the maximum speed of the 
interface. In this case, the speed of the interface varies significantly with time. 
Therefore, it is suitable to choose γ such that it varies with time and is equal to three 
times the average speed of the interface. To calculate the average speed of the interface, 
you can use the following expression

B O U N D A R Y  C O N D I T I O N S

At the bottom boundary, the velocity is zero and the inward heat flux is 100 W/m2. 
At the upper wall, pressure and diffusive heat flux are both zero. Symmetry conditions 
hold on the outer cylindrical boundary.

I N I T I A L  C O N D I T I O N S

Initially, a layer of vapor covers the bottom surface. The temperature equals 273 K, the 
saturation temperature while the velocity is zero.

Results and Discussion

Snapshots of the velocity field (streamlines), the temperature (contour lines) and the 
fluid interface at different times, ranging from t = 0.1 s to t = 0.95 s are seen in 
Figure 6-11. The results show how a mushroom-shaped bubble forms, with a narrow 

QUANTITY VALUE, GAS PHASE VALUE, LIQUID PHASE

Density (kg/m3) 5 200

Dynamic viscosity (Pa·s) 0.005 0.1

Conductivity (W/(m·K)) 1 40

Heat capacity (J/(kg·K)) 200 400

uinterface δ Ωd∫
δ Ωd∫

-----------------------------------------
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stream of vapor beneath it, qualitatively similar to the result obtained in Ref. 2. Note 
that it is not possible to strictly compare the results with the results in the reference, 
since the authors of Ref. 2 use a planar 2D coordinate system while an axisymmetric 
system is used here. Other differences are the initial shape of the interface, the initial 
temperature, and the boundary conditions for the temperature.

The temperature in the liquid phase remains close to the saturation temperature, which 
justifies the choice of the interfacial mass flux according to Equation 6-11.

Figure 6-11: White velocity streamlines, temperature (contour lines) and the phase 
boundary (surface plot of the level set function) at different times.

Modeling in COMSOL Multiphysics

In order to set up the model in COMSOL Multiphysics, you need two application 
modes: The Level Set Two-Phase Flow, Laminar application mode, and the 
Convection and Conduction application mode. For the Level Set Two-Phase Flow, 
Laminar application mode, you must switch on the property Weakly compressible flow. 

t = 0.1s t = 0.5 s t = 0.7 s

t = 0.8 s t = 0.9 s t = 0.95 s
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You also have to add a term in the level set equation and a source term in the heat 
transfer equation to account for phase change and release/absorption of latent heat, 
respectively. To simplify the numerical calculations, you can reformulate the continuity 
equation according to Equation 6-10.

If the velocity field varies significantly across the interface, the interface may become 
unsmooth, causing the time dependent solver to run into problems. In such cases, it 
can be useful to stop the calculation, recalculating the level set variable according to

 (6-12)

and then continue the calculation.  makes a sharper transition across the 
interface, but has the same 0.5 contour as  Use the reinitialization, according to 
Equation 6-12, only when necessary because it results in a small mass loss.
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Model Library path:  

Chemical_Engineering_Module/Multiphase_Flow/boiling_flow

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 In the Model Navigator select Axial symmetry (2D) from the Space dimension list.

2 Click the Multiphysics button.

3 From the list of application modes select Chemical Engineering Module> 
Momentum Transport>Multiphase Flow>Level Set Two-Phase Flow, Laminar. Click 
Add.

4 Select COMSOL Multiphysics>Heat Transfer>Convection and Conduction> 
Transient analysis. Click Add.

φnew 3φold
2 2φold

3
–=

φnew
φold.
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5 Click OK to close the Model Navigator.

G E O M E T R Y  M O D E L I N G

1 Press shift and click the Rectangle/Square button on the Draw toolbar.

2 Type 0.06 in the Width edit field and 0.1 in the Height edit field. Click OK.

3 From the Draw menu, select Specify Objects>Line.

4 In the r edit field, type 0 0.06.

5 In the z edit field, type 0.002 0.0015.

6 Click OK.

7 Click the Zoom Extents button on the Main toolbar.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, choose Constants.

2 Enter constants according to the following table. The units and the descriptions are 
optional.

3 Click OK.

4 From the Options menu, select Expressions>Scalar Expressions.

5 Add the following expressions:

NAME EXPRESSION DESCRIPTION

L 1000[J/kg] Latent heat of evaporation

Cp_l 400[J/(kg*K)] Heat capacity, liquid

Cp_g 200[J/(kg*K)] Heat capacity, gas

T_sat 273[K] Saturation temperature

k_l 40[W/(m*K)] Thermal conductivity, liquid

k_g 1[W/(m*K)] Thermal conductivity, gas

q 100[W/m^2] Inward heat flux, bottom boundary

C 200[m/s] Scaling constant in mass-flux expression

NAME EXPRESSION DESCRIPTION

m C*rho_chns*(T-T_sat)/T_sat Interfacial mass flux due to 
evaporation

phi_source -r*gradphi_chns*m/rho_chns Source term in the level set 
equation
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In these expressions, rho_chns and gradphi_chns are internal variables defined by 
the Level Set Two-Phase Flow application mode: rho_chns is the density and 
gradphi_chns is the magnitude of the gradient of  Moreover, the factor r in the 
source term, representing the the radial coordinate r, is required to achieve the 
correct equations for the axisymmetric geometry.

6 Click OK.

7 From the Options menu, select Integration Coupling Variables>Subdomain Variables.

8 Select both subdomains, then specify two integration coupling variables according 
to the following table:

9 Click OK.

P H Y S I C S  S E T T I N G S

Application Mode Properties
1 Open the Application Mode Properties dialog box for the Level Set Two-Phase Flow, 

Laminar (chns) application mode. 

You can open the dialog box in two different ways. Either, you first select Level Set 
Two-Phase Flow, Laminar (chns) from the Multiphysics menu, and then select 
Properties from the Physics menu. Alternatively, go to the Model Tree window, 
right-click Level Set Two-Phase Flow, Laminar (chns), and select Properties.

2 Set the property Weakly compressible flow to On.

3 Click OK.

Subdomain Settings—Fluid Flow
1 Open the Subdomain Settings dialog box for the Level Set Two-Phase Flow, Laminar 

(chns) application mode, either from the Physics menu, or using the Model Tree.

2 Select both subdomains by selecting one subdomain and then press Ctrl and A.

v_int sqrt((u+normr_chns*m/
rho_chns)^2+(v+normz_chns*m
/rho_chns)^2)

Interface speed

gamma 3*nojac(I1/I2) The level set parameter gamma

NAME EXPRESSION DESCRIPTION

NAME EXPRESSION

I1 v_int*delta_chns

I2 delta_chns

φ.
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3 Enter the following values in the different edit fields.

4 Click the Sources/Sinks tab. Type 0.1 in the σ edit field and -9.82 in the gz edit field.

5 Click the Artificial Diffusion button.

6 Select the Streamline diffusion check box and select Anisotropic Diffusion from the list.

7 Click OK.

8 Click the Level Set tab. Set ε to hmax2_chns (the largest element size in 
Subdomain 2).

9 Click the Init tab and select Subdomain 2 only. As Initial fluid in this domain, select 
Fluid 2.

10 Click OK to close the dialog box.

Boundary Conditions—Fluid Flow
1 From the Physics menu, select Boundary Settings.

2 Select Boundary 4 and select the Interior boundaries check box. From the Boundary 

condition list, select Initial fluid interface.

3 Set conditions on the other boundaries according to the following table:

4 Click OK.

Subdomain Settings—Heat Transfer
1 Open the Subdomain Settings - Convection and Conduction (cc) dialog box, either 

using the Model Tree or by selecting first 
Multiphysics>2 Convection and Conduction (cc) and then Physics>Subdomain Settings.

2 Select both subdomains. 

QUANTITY VALUE/EXPRESSION

ρ1 5

η1 0.005

ρ2 200

η2 0.1

SETTINGS BOUNDARIES 1,3 BOUNDARY 2 BOUNDARY 5 BOUNDARIES 6, 7

Boundary type Symmetry 
boundary

Wall Outlet Symmetry 
boundary

Boundary 
condition

Axial symmetry No slip Pressure Symmetry
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3 On the Physics page, enter subdomain settings according to the following table:

4 Type u and v in the Velocity field edit fields.

5 Click the Init tab. Type T_sat in the T(t0) edit field, then click OK.

Boundary Conditions—Heat Transfer
1 Open the Boundary Settings dialog box for the Convection and Conduction (cc) 

application mode.

2 Set boundary conditions as in the following table:

3 Select Boundary 2 and type q in the q0 edit field.

4 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters. 

2 Click the Subdomain tab and select both subdomains. In the Element growth rate edit 
field, type 1.005.

3 Click Remesh. When the mesher has finished, click OK.

C O M P U T I N G  T H E  S O L U T I O N

First, you must initialize the level set function. To do this, make a transient calculation 
for the level set variable only. The appropriate time for initialization is the thickness of 
the interface (about 5ε) divided by the value of the level set parameter γ. In this case, 
the thickness is about 0.005 and γ is 1. A suitable initialization time is therefore 0.005.

1 Click the Solver Parameters button on the Main toolbar.

2 Type 0.005 in the Times edit field.

QUANTITY VALUE/EXPRESSION

k (isotropic) k_g+phi*(k_l-k_g)

ρ rho_chns

Cp Cp_g+phi*(Cp_l-Cp_g)

Q -m*L*delta_chns

SETTINGS BOUNDARIES 1, 3 BOUNDARY 2 BOUNDARY 5 BOUNDARIES 6, 7

Boundary 
condition

Axial symmetry Heat flux Convective flux Thermal insulation
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3 In the Relative tolerance edit field, type 0.005 and in the Absolute tolerance edit field, 
type 0.0005. By lowering the tolerances you increase the accuracy and improve the 
stability.

4 Click the Time Stepping tab and type 1 in the Maximum BDF order edit field for 
increased stability.

5 Click OK.

6 Click the Solver Manager button on the Main toolbar.

7 Go to the Solve For page and select only phi.

8 Click OK.

9 Click the Solve button to start the initial calculation.

10 When the calculation has finished, click the Solver Manager button again.

11 On the Initial Value page, click the Store Solution button. Select the time 0.005 from 
the list, then click OK.

12 In the Initial value area, click the Stored solution option button and select 0.005 from 
the Solution at time list.

13 Click the Solve For tab. Select both application modes by clicking Geom1 (2D).

14 Click OK.

15 In the Model Tree, right click Level Set Two-Phase Flow, Laminar (chns) and select 
Properties.

16 From the Analysis type list, select Transient. Click OK.

Now you have initialized the level set function. Before you can start the fluid flow 
calculation, you must modify the level set equation to account for the phase change. 
You also need to rewrite the continuity equation according to Equation 6-10 to 
simplify the numerical solution of the equations.

1 From the Physics menu, select Equation System>Subdomain Settings.

2 Select both subdomains and click the f tab.

3 The expression on the third row represents the continuity equation. Replace the 
expression by -r*(rho2_chns-rho1_chns)*m/
rho_chns*sqrt(gradphiz_chns^2+gradphir_chns^2+eps)+r*rho_chns*div

U_chns.

4 The expression on the fourth row corresponds to the source term in the level set 
equation. Add the term phi_source to the expression. The expression should now 
read -r*u*gradphir_chns-r*v*gradphiz_chns+phi_source.
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5 Click the Differentiate button.

6 Click OK.

You also want to change the value of the level set parameter γ, so that it relates to 
the speed of the interface.

7 Open the Subdomain Settings dialog box for the Level Set Two-Phase Flow, Laminar 

(chns) application mode.

8 Go to the Level Set page, select both subdomains, and type gamma in the γ edit field.

9 Click OK.

10 Click the Solver Parameters button on the Main toolbar.

11 On the General page, type [0:0.1:0.7] in the Times edit field.

12 Click the Time Stepping tab. From the Time steps taken by solver list, select 
Intermediate. The Intermediate option ensures that the solver takes at least one time 
step within each of the specified time intervals.

13 Click OK.

14 Click the Solve button on the Main toolbar to start the calculation.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Click the Plot Parameters button on the Main toolbar.

2 Go to the Streamline page and select the Streamline plot check box.

3 From the Predefined quantities list, select Level Set Two-Phase Flow, Laminar 

(chns)>Velocity field. From the Streamline plot type list, select Uniform density.

4 On the Contour page, select the Contour plot check box.

5 From the Predefined quantities list, select 
Convection and Conduction (cc)>Temperature.

6 Click Apply.

7 On the General page, select the time you want to visualize the solution at from the 
Solution at time list.

8 Click OK.

9 To create a movie, click the Animate button on the Plot toolbar.

If the velocity field varies significantly across the interface, the time dependent solver 
sometimes becomes slow. This typically occurs if the reinitialization does not manage 
to keep the transition of the level set function across the interface sharp enough. A 
solution is to stop the solver, and manually reinitialize the level set function such that 
it becomes sharper. If the solver starts to take smaller time steps, stop the solver. Define 
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the initial value for the level set variable, , from the solution at the last time, 
, as

 (6-13)

, has the same 0.5 contour as , but a sharper transition from zero to one. 
Use the reinitialization, according to Equation 6-13, only when necessary because it 
results in a small mass loss.

1 From the Physics menu, select Equation System>Subdomain Settings.

2 Click the Init tab. For both subdomains, specify the following initial values:

3 Click OK.

4 Click the Solver Manager button and go to the Initial Value page. 

5 In the Initial value area, select Initial value expression evaluated using current solution.

6 Select 0.7 from the Solution at time list.

7 Click OK.

8 Click the Solver Parameters button. Type 0:0.01:0.1 in the Times edit field.

9 Click OK.

10 Click the Solve button on the Main toolbar.

11 While the software is solving the problem, click the Log tab to inspect how the solver 
proceeds. If the solver starts to take very small time steps (second column, Time) at 
the same time as the numbers in any of the two right most columns (number of 
time-discretization failures, Tfail, and nonlinear failures, NLfail) start to increase 
you might want to stop the calculation. In that case, go to the Progress page and 
click the Stop buttons and wait until the solver has stopped.

12 Open the Solver Manager again.

13 From the Solution at time list, select the time you want to restart the calculation 
from. Click OK.

VARIABLE EXPRESSION

u(t0) u

v(t0) v

p(t0) p

phi(t0) 3*phi^2-2*phi^3

T(t0) T

φinit
φstored

φinit 3φstored
2 2φstored

3
–=

φinit φstored
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14 Repeat Steps 10–13 until you have calculated as many time steps as you desire.
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D rop l e t  B r e a kup i n a  T - J u n c t i o n

Introduction

Emulsions consist of small liquid droplets immersed in another liquid and are widely 
used, for instance in the production of food, cosmetics, and pharmaceutical products. 
The quality of the products typically depends on the size of these droplets. This model 
studies in detail how droplets in an emulsion can be created.

The model is easily set up using the Level Set Two-Phase Flow application mode. The 
model uses the predefined wetted wall boundary condition at the solid walls, with a 
contact angle of 135°. From the results, you can determine the size of the created 
droplets and the rate with which they are produced. The results compare well with 
those presented in Ref. 1.

Model Definition

Figure 6-12 shows the geometry of the T-shaped microchannel. The fluid to be 
dispersed into small droplets, Fluid 2, enters through the vertical channel. The other 
fluid, Fluid 1, flows from the right to left through the horizontal channel. 

Figure 6-12: The geometry of the T-junction.

You can easily set up the problem with the Level Set Two-Phase Flow application 
mode. The application mode sets up a momentum transport equation, a continuity 

Inlet, Fluid 2

Inlet, Fluid 1

Outlet
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equation, and a level set equation for the level set variable. The fluid interface is defined 
by the 0.5 contour of the level set function.

The application mode uses the following equations

 (6-14)

 (6-15)

 (6-16)

In the equations above, ρ denotes density (kg/m3), u velocity (m/s), t time (s), η 
dynamic viscosity (Pa·s), p pressure (Pa) and Fst the surface tension force.  is the 
level set function and γ and ε are numerical stabilization parameters. The density and 
viscosity are calculated from 

where ρ1, ρ2, η1, and η2 are the densities and viscosities of Fluid 1 and Fluid 2.

P H Y S I C A L  P A R A M E T E R S

The two liquids have the following physical properties:

The surface tension coefficient is 5·10−3 N/m.

B O U N D A R Y  C O N D I T I O N S

Parabolic velocity profiles are specified at both inlets, while at the outflow boundary 
you specify the pressure. The Wetted wall boundary condition applies to all solid 
boundaries with the contact angle specified as 135° and a slip length equal to the mesh 
size h. The contact angle is the angle between the fluid interface and the solid wall at 
points where the fluid interface attaches to the wall. The slip length is the distance to 
the position outside the wall where the extrapolated tangential velocity component is 
zero (Figure 6-13). 

QUANTITY VALUE, FLUID 1 VALUE, FLUID 2

Density (kg/m3) 1000 1000

Dynamic viscosity (Pa·s) 0.00195 0.00671

ρ ∂u
∂t
------- u ∇u⋅+⎝ ⎠
⎛ ⎞ ∇ η ∇u ∇uT

+( )[ ]⋅– p∇+ Fst=

∇ u⋅ 0=

∂φ
∂t
------ u ∇φ⋅+ γ∇ φ– 1 φ–( ) ∇φ

∇φ
---------- ε∇φ+⎝ ⎠

⎛ ⎞⋅=

φ

ρ ρ1 ρ2 ρ1–( )φ+=

η η1 η2 η1–( )φ+=
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Figure 6-13: The contact angle, θ, and the slip length, β. 

Results and Discussion

Figure 6-14 shows the fluid interface (the level set function) and the velocity 
streamlines at various times. After 0.08 s the first droplet is formed.

Figure 6-14: Velocity streamlines and the phase boundary at t = 0.02 s, 0.04 s, 0.06 s, and 
0.08 s.

Fluid 1

Fluid 2

Wall
θ

β

u Wall
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The diameter of the produced droplet at t = 0.08 s can be calculated from

where Ω is the leftmost part of the horizontal channel, where x < −3·10−4 m. In this 
case, the results show that d = 1.45·10−4 m.

Reference

1. Graaf and others, “Lattice Boltzmann Simulations of Droplet Formation in a 
T-Shaped Microchannel,” Langmuir, vol. 22, pp. 4144–4152,  2006.

Model Library path: Chemical_Engineering_Module/Multiphase_Flow/
droplet_breakup

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 In the Model Navigator select Chemical Engineering Module> 
Momentum Transport>Multiphase Flow>Level Set Two-Phase Flow, Laminar.

2 Click OK.

G E O M E T R Y  M O D E L I N G

1 Press Shift and click the Rectangle/Square button on the Draw toolbar.

2 Type in the following values:

3 Click OK. 

4 Click the Zoom Extents button on the Main toolbar.

5 In the same way, create another rectangle with the following settings:

WIDTH HEIGHT BASE, X BASE, Y

1e-4 4e-4 0 1e-4

WIDTH HEIGHT BASE, X BASE, Y

1e-3 1e-4 -7e-4 0

d 2
φ 0.5>( ) Ωd

Ω
∫

π
--------------------------------------=
D R O P L E T  B R E A K U P  I N  A  T- J U N C T I O N  |  273



274 |  C H A P T E
6 From the Draw menu, select Specify Objects>Line.

7 In the x edit field, type 0 1e-4.

8 In the y edit field, type 2e-4 2e-4.

9 Click OK.

10 Click the Zoom Extents button.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

2 Define constants according to the following table. The units and the descriptions 
are optional.

3 Click OK.

4 From the Options menu, select Expressions>Global Expressions.

5 Add the following three expressions:

6 Click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 Open the Subdomain Settings dialog box for the Level Set Two-Phase Flow, Laminar 

application mode, either from the Physics menu, or using the Model Tree.

2 Select all subdomains by selecting one subdomain and then pressing Ctrl+A.

NAME EXPRESSION DESCRIPTION

rho1 1e3[kg/m^3] Density, Fluid 1

eta1 1.95e-3[Pa*s] Viscosity, Fluid 1

rho2 1e3[kg/m^3] Density, Fluid 2

eta2 6.71e-3[Pa*s] Viscosity, Fluid 2

vmax1 2*vmax2 Maximum inlet speed, Fluid 1

vmax2 0.0083[m/s] Maximum inlet speed, Fluid 2

sigma 5e-3[N/m] Surface tension coefficient

NAME EXPRESSION DESCRIPTION

ramp flc1hs(t[1/s]-1e-2,1e-2) Smooth step function

uin1 -vmax1*4*s*(1-s)*ramp Velocity profile, inlet 1

vin2 -vmax2*4*s*(1-s)*ramp Velocity profile, inlet 2
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3 Enter the following values in the different edit fields:

4 Click the Sources/Sinks tab. In the σ edit field, type sigma.

5 Click the Init tab. Select Subdomain 3 only. As Initial fluid in this domain, select 
Fluid 2.

6 Click OK to close the dialog box.

Boundary Conditions
1 From the Physics menu, select Boundary Settings.

2 Select Boundary 7 and select the Interior boundaries check box. From the Boundary 

condition list, select Initial fluid interface.

3 Set the conditions on the other boundaries according to the following table:

4 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Mapped Mesh Parameters. Click the Boundary tab.

2 While pressing Ctrl, select the Boundaries 1, 4, and 5. Select the Constrained edge 

element distribution check box and type 10 in the Number of edge elements edit field.

QUANTITY VALUE/EXPRESSION

ρ1 rho1

η1 eta1

ρ2 rho2

η2 eta2

SETTINGS BOUNDARY 1 BOUNDARIES 2–4, 
6, 9–11

BOUNDARY 8 BOUNDARY 12

Boundary type Outlet Wall Inlet Inlet

Boundary 
condition

Normal stress Wetted wall Velocity Velocity

f0 0

1 0

 u0 0 uin1

 v0 vin2 0

 p0

 θ 3*pi/4

 β h

φ0
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3 Select Boundary 2. Select the Constrained edge element distribution check box and 
type 100 in the Number of edge elements edit field.

4 Finally, select Boundary 6. Select the Constrained edge element distribution check 
box and type 30 in the Number of edge elements edit field.

5 Click the Remesh button. When the mesher has finished, click OK.

C O M P U T I N G  T H E  S O L U T I O N

First, you must determine the time suitable for initialization, which is given by the 
expression 5ε/γ:

1 From the Solve menu, select Get Initial Value.

2 Click the Plot Parameters button on the Main toolbar.

3 Click the Surface tab. On the Surface Data page, type 5*epsilon_chns/gamma_chns 
in the Expression edit field.

4 Click OK.

The plot shows that a suitable time for initialization is 5·10−5 s.

1 Click the Solver Parameters button on the Main toolbar.

2 In the Times edit field, type 5e-5, then click OK.

3 Click the Solve button on the Main toolbar.

4 Click the Plot Parameters button. Type phi in the Expression edit field, then click OK.

The plot shows your initialized level set function. Now continue with the fluid flow 
calculation.

1 From the Physics menu, select Properties.

2 From the Analysis type list, select Transient. Click OK.

3 Click the Solver Manager button on the Main toolbar. 

4 Click the Store Solution button. Select only 5e-5 in the dialog box that appears, then 
click OK.

5 In the Initial value area, click the Stored solution button and select 5e-5 from the 
Solution at time list.

6 Click OK.

7 Click the Solver Parameters button on the Main toolbar.

8 In the Times edit field, type 0:0.5e-2:0.08, then click OK.

9 Click the Solve button on the Main toolbar.
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10 In the Progress-Solve Problem window, click the Log tab. When the solver reaches 
t = 0.025 s it starts to take small time steps. This is an indication that the level set 
parameter γ has not been assigned a suitable value. Therefore, click the Progress tab, 
then click both Stop buttons. Click Close.

11 Click the Plot Parameters button on the Main toolbar.

12 On the Surface page, select Velocity field from the Predefined quantities list.

13 Click the General tab. From the Solution at time list, select 0.025. Click OK.

The maximal velocity is a suitable value for the level set parameter γ. The plot shows a 
maximal velocity of about 0.028 m/s, which is significantly lower than γ. By default, γ 
is 1 m/s.

1 Open the Subdomain Settings dialog box. Select all subdomains, then click the 
Level Set tab. In the γ edit field, type 0.03, then click OK.

2 Click the Solve button on the Main toolbar.

The solver now runs better, but eventually starts to become slow. Click the Stop button 
when this occurs (after 0.04 s). As you can see, the maximum velocity now exceeds 
0.03 m/s, and your value for γ is too low. Therefore, change γ to 0.1. Also, add 
artificial diffusion to the momentum equation for increased stability.

1 From the Physics menu, select Subdomain Settings.

2 In the γ edit field, type 0.1.

3 On the Sources/Sinks page, click the Artificial Diffusion button.

4 Select the Streamline diffusion check box, then select Anisotropic Diffusion from the 
list. Click OK to close the Artificial Diffusion dialog box.

5 Click OK to close the Subdomain Settings dialog box.

6 Click the Solve button on the Main toolbar. The solver needs approximately half an 
hour to calculate the solution until the final time.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Click the Plot Parameters button on the Main toolbar.

2 On the Surface page, select Volume fraction of fluid 2 from the Predefined quantities 
list.

3 On the Streamline page, select the Streamline plot check box. Select Velocity field 
from the Predefined quantities list.

4 From the Streamline plot type list, select Uniform density. In the Separating distance 
edit field, type 0.02.
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5 On the Animate page, click the Start Animation button.

6 Click OK to close the Plot Parameters dialog box.

Finally, calculate the radius of the droplet:

1 From the Options menu, select Integration Coupling Variables>Subdomain Variables.

2 Select all subdomains and specify an integration coupling variable with the Name 

area and the Expression (phi>0.5)*(x<-3e-4). Click OK.

3 From the Solve menu, select Update Model.

4 From the Postprocessing menu, select Global Variables Plot.

5 Type 2*sqrt(area/pi) in the Expression edit field. Click the Add Entered 

Expression (>) button, then click OK.

The plot shows that the diameter of the droplet is approximately 1.45·10−4 m.
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Bubb l e  C o l umn Rea c t o r

Introduction

This example illustrates multiphase flow modeling in a bubble column reactor. The 
reactor is filled with water and gas bubbles are injected from the bottom. Due to 
buoyancy, the bubbles rise, inducing a circulating motion of the liquid. Furthermore, 
as the bubbles rise through the water, gas dissolves from the bubbles into the liquid.

The Bubbly Flow application mode tracks the averaged phase concentration rather 
than each bubble in detail, and is therefore well suited to model the flow. You can easily 
couple the multiphase flow with a mass transport equation to model the transport of 
gas dissolved in the liquid.

Model Definition

This example treats a bubble column reactor of height 2.1 m and a diameter of 0.2 m. 
A cylindrical wall of diameter 0.1 m is placed within the tank to prevent gas from 
moving to the outer parts of the tank. Figure 6-15 and Figure 6-16 depict the 
geometry with boundary conditions for the corresponding axisymmetric model. Note 
that the scales of the r- and z-axes are different in the figures.

Figure 6-15: Geometry and boundary conditions, liquid phase.
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Figure 6-16: Boundary conditions, gas phase.

The Bubbly Flow application mode makes it easy to set up a multiphase flow model for 
gas bubbles rising through a liquid. It solves for the liquid velocity, the pressure, and 
the volume fraction of the gas phase. The momentum transport equation for the 
mixture is

 (6-17)

where  denotes the volume fraction of the liquid phase (m3/m3), ρl the liquid’s 
density (kg/m3), ul the liquid phase velocity (m/s), p pressure (Pa), ηl the liquid’s 
dynamic viscosity (Pa·s) and g the gravity vector (m/s2).

For low gas concentrations, the application mode approximates the mass conservation 
equation by

For the gas phase transport, the application mode solves the equation

where ug is the gas phase velocity (m/s), ρg is the gas density (kg/m3),  gives the 
volume fraction of gas, and mgl refers to the mass transfer rate from gas to liquid (kg/
(m3·s)). The gas density is calculated from the ideal gas law:

Gas outlet

Gas inlet
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φlρl t∂
∂ul φlρlul ul∇⋅+ p∇– ∇ φlηl ul∇ ul∇ T

+( )[ ] φlρlg+⋅+=

φl

∇ ul⋅ 0=

ρgφg∂
t∂

--------------- ∇ φgρgug( )⋅+ mgl–=
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where M is the molecular weight of the gas (kg/mol), R denotes the ideal gas constant 
(8.31 J/(mol·K)), pref is a reference pressure (1·105 Pa), and T the temperature (K). 
The liquid volume fraction is calculated from

and the gas velocity from

where uslip is the relative velocity between gas and liquid.

For bubbles rising through a liquid, due to buoyancy, it is valid to assume that the 
pressure forces approximately balance the viscous drag forces on a gas bubble. The 
relative velocity between the two phases can then be determined from the relation

 (6-18)

where Cd is the drag coefficient (dimensionless) and db bubble diameter (m). For large 
(db > 2 mm) gas bubbles in water, an empirical expression for the drag coefficient is 

 (6-19)

 (6-20)

Here, g denotes the magnitude of the gravity vector (m/s2) and σ the surface tension 
coefficient (N/m). The slip model defined by Equation 6-18, Equation 6-19, and 
Equation 6-20 is available as one of the predefined slip models in the application 
mode. You only need to give values for the physical parameters of gravity, density, 
bubble diameter and the surface tension coefficient. From these values, the application 
mode automatically calculates the slip velocity.

TU R B U L E N C E  M O D E L I N G

For turbulent flows, you can use the k-ε turbulence model and solve for the averaged 
velocity field. The turbulence model relevant for bubbly flows is similar to the 
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single-phase k-ε turbulence model. However, there are additional source terms in 
order to account for the extra production of turbulence due to the relative motion 
between the gas bubbles and the liquid.

When you use the k-ε turbulence model, COMSOL Multiphysics adds a turbulent 
viscosity to the physical viscosity in the momentum transport equation. The turbulent 
viscosity is modeled by

 (6-21)

where  is a model constant.

The transport equation for the turbulent kinetic energy k is

 (6-22)

and the evolution of the turbulent energy’s dissipation rate ε is governed by

 (6-23)

The term Sk accounts for the bubble induced turbulence and is given by 

For the gas phase’s velocity field, a drift velocity is added:

where

In the Bubbly Flow application mode, you can easily switch on and off the k-ε 
turbulence model, either with or without the bubble induced turbulence term Sk.

D I S S O L U T I O N  O F  G A S

You can use the two-film theory to account for the dissolution of gas. The application 
mode then calculates the mass transfer rate according to
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In the equations, k represents the mass transfer coefficient (m/s), H represents Henrys 
constant (Pa·m3/mol), c the concentration of gas dissolved in liquid (mol/m3), M the 
molecular weight (kg/mol), and a the interfacial area per volume (m2/m3). The 
interfacial area per volume depends on the volume fraction of gas but also on the 
number of bubbles per volume, n (1/m3). If you select the two-film theory model, 
the application mode automatically also solves for n. It assumes that bubbles cannot 
split or merge, while the size of each bubble can vary:

The transport equation for dissolved gas is 

 (6-24)

where D is the diffusion coefficient (m2/s). When you use a turbulence model for the 
flow field, the diffusion coefficient is 

In this example, you make the approximation that the flow field and the bubble 
number density, n, are not affected by the dissolution of gas. Therefore, you can first 
solve for the flow without inclusion of the dissolution of gas. Then you solve for the 
volume fraction of gas and the concentration of the dissolved gas, accounting for the 
mass transfer. The transport equation for the dissolved gas (Equation 6-24) is not 
included in the Bubbly Flow application mode, but you can easily set up the equation 
using a Convection and Diffusion application mode.

Results and Discussion

In this example, you first make a time-dependent simulation with no turbulence and 
without taking into account the dissolution of gas. You then continue with a turbulent, 
stationary calculation to obtain the time-averaged velocity field and volume fractions, 
both with and without the inclusion of bubble induced turbulence. Note that having 
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the laminar solution as an initial guess to the turbulent problem makes it much easier 
for the solver to converge in this case. Finally, you can account for the dissolution of 
gas.

Figure 6-17 shows results of the transient simulation, with no mass transfer from gas 
to liquid and without any turbulence modeling.The figures show the gas volume 
fraction and the velocity of the liquid phase.

Figure 6-17: Results of a time dependent simulation with no turbulence at t = 5 s, 10 s, 
and 20 s. The surface plot shows the gas volume fraction and the arrows the liquid velocity.

By using a turbulence model, it is possible to calculate the time-averaged velocity and 
gas concentration. The standard k-ε turbulence model for single phase flow can also 
be used for multiphase flows. In this case, you would then completely neglect the fact 
that bubbles produce turbulence as they rise through the liquid. The k-ε turbulence 
model can also be modified so that it does account for the effect of bubble-induced 
turbulence. Figure 6-18 and Figure 6-19 show results using the k-ε turbulence model 
with and without bubble-induced turbulence. The turbulent viscosity differs 
significantly for the two models, but the flow with respect to the speed of the liquid 
and the gas concentration is similar for both cases.
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Figure 6-18: Turbulent viscosity when bubble induced turbulence is not (left) and is 
(right) accounted for. The bubble induced turbulence results in significantly more 
turbulent viscosity at the center of the bubble column.

Figure 6-19: Liquid velocity and volume fraction of gas using single phase k-ε (left) and 
k-ε with bubble induced turbulence (right). Even though the turbulent viscosity differs 
significantly for the two turbulence models, the gas concentration and velocities are 
similar for both models.

If gas dissolves into the liquid, the gas volume fraction decreases, which Figure 6-20 
clearly shows. Finally, Figure 6-21 shows snapshots of the concentration of dissolved 
gas at t = 0 s, 10 s, and 20 s. Because the liquid circulates in the tank, the dissolved 
species is rapidly distributed within the entire tank.
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Figure 6-20: The volume fraction of gas initially (left) and after 20 s (right), accounting 
for the dissolution of gas.

Figure 6-21: Snapshots showing the concentration of gas dissolved in liquid at t = 0 s, 5 s, 
10 s, and 20 s. The four figures all use the same color scale with a maximum value of 0.83 
mol/m3.

Modeling in COMSOL Multiphysics

To model the two-phase fluid flow, use the Bubbly Flow application mode. In order 
to account for gas dissolution, you need to add a Convection and Diffusion application 
mode. It is easy to switch from a laminar to a turbulent fluid flow model by selecting 
the turbulence model in the Application Mode Properties dialog box.
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Model Library path: Chemical_Engineering_Module/Multiphase_Flow/
bubble_column

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 From the Space dimension list, select Axial symmetry (2D).

2 Select Chemical Engineering Module>Momentum Transport>Multiphase Flow> 
Bubbly Flow, Laminar>Transient analysis.

3 Click OK.

G E O M E T R Y  M O D E L I N G

1 From the Draw menu, select Specify Objects>Rectangle.

2 Enter values according to the following table:

3 Click OK.

4 Click the Zoom Extents button on the Main toolbar.

5 From the Options menu, select Axes/Grid Settings.

6 Go to the Grid tab and clear the Auto check box.

7 Type 0.05 in the r spacing as well as the z spacing edit fields.

8 Click OK.

9 On the Draw toolbar, click the Line button. Click once at each of the following 
coordinates: (0.1, 0), (0.1, 2.05), (0, 2.05), (0, −0.05), and (0.05, −0.05). The 
coordinates are displayed in the lower left corner of the graphical user interface.

10 Click 2nd Degree Bézier Curve, also on the Draw toolbar. Click the coordinates 
(0.05, −0.05), (0.1, −0.05), and (0.1, 0).

11 Right-click anywhere to create a geometry of the drawn lines and curves.

WIDTH HEIGHT BASE  r  z

0.005 2 Corner 0.05 0
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12 From the Draw menu, select Specify Objects>Circle. Enter settings according to the 
following table:

13 Click OK.

14 From the Edit menu, select Copy. Alternatively, press Ctrl+C.

15 Also from the Edit menu, select Paste, or press Ctrl+V. 

16 Type -2 in the z edit field in the dialog box that appears. Click OK.

17 On the Draw toolbar, click the Create Composite Object button. In the Set formula 
edit field, type CO1-R1-C1-C2.

18 Click OK.

19 In order to view the geometry with different scales on the r- and z-axes, double-click 
EQUAL in the status bar at the bottom of the user interface, then click the Zoom 

Window button on the Main toolbar.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Physics menu, select Subdomain Settings.

2 Select Subdomain 1. Type 28e-3 in the Molecular weight of gas edit field and -9.81 
in the z-component edit field for Gravity (the one to the right).

3 Click the Artificial Diffusion button.

4 On the Momentum Transport page, select the Isotropic diffusion check box and type 
0.05 in the corresponding edit field. 

5 Click OK.

6 On the Slip Model page, select Pressure/drag balance.

7 Select Large bubbles from the list. Type 2e-3 in the Bubble diameter edit field.

8 Click OK.

Point Settings
1 From the Physics menu, select Point Settings.

2 Select Point 11 and select the Point constraint check box. Click OK.

Boundary Conditions
1 From the Physics menu, select Boundary Settings. 

RADIUS  r  z

0.0025 0.0525 2
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2 Select Boundary 1. From the Boundary type list, select Symmetry boundary, and from 
the Boundary condition list, select Axial symmetry.

3 Select Boundary 3. From the Boundary type list, select Symmetry boundary, and from 
the Boundary condition list, select Symmetry.

4 Click the Gas Phase tab. 

5 For Boundary 1, set the boundary condition Axial symmetry.

6 Select Boundary 2 and select the boundary condition Gas flux. In the  edit field, 
type 0.01.

7 Set the boundary condition for Boundary 3 to Gas Outlet.

8 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters.

2 On the Subdomain page, set the Maximum element size to 0.02.

3 On the Boundary page, select Boundary 7. Set the Maximum element size to 0.005.

4 Click Remesh, then click OK. 

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 In the Times edit field, type 0:1:20.

3 Click OK.

4 Click the Solve button on the Main toolbar to start the calculation.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Click the Plot Parameters button on the Main toolbar.

2 Go to the Arrow tab and select the Arrow plot check box. In the r points edit field, 
type 10, and in the z points edit field, type 30.

3 Click OK to plot the right most plot of Figure 6-17.

Proceed with a turbulent-flow simulation.

P H Y S I C S  S E T T I N G S

1 From the Physics menu, select Properties. 

2 From the Analysis type list, select Stationary.

3 From the Turbulence model list, select k-ε without bubble induced turbulence.

Nρ
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4 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

When solving stationary problems consisting of several variables, you can use the 
segregated solver to reduce the memory resources used by the software and to more 
easily obtain convergence. For the segregated solver, you need to divide the dependent 
variables into different groups. The velocity and pressure variables must always belong 
to the same group, and usually it is optimal to define a separate group for the 
turbulence variables. 

1 Click the Solver Manager button on the Main toolbar.

2 In the Initial value area on the Initial Value page, select Current solution. From the 
corresponding Solution at time list, select 20.

3 Click OK.

4 Click the Solver Parameters button.

5 From the Solver list, select Stationary segregated. 

6 Click the New Group button. There should now be two groups, one containing the 
variables ul vl p rhogeff and one with logk logd.

7 Click OK.

8 Click the Solve button on the Main toolbar.
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PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Click the Plot Parameters button on the Main toolbar.

2 On the Surface page, click the Range button.

3 Clear the Auto check box and type 0.03 in the Max edit field. Click OK.

4 Click Apply to view the left plot in Figure 6-19.

5 From the list of Predefined quantities, select Bubbly Flow>Turbulent viscosity.

6 Click the Range button, select the Auto check box, and click OK.

7 On the Arrow page, clear the Arrow plot check box.

8 Click OK to create the left plot of Figure 6-18.

Next, account for additional turbulence induced by the bubbles.

P H Y S I C S  S E T T I N G S

1 From the Physics menu, select Properties. 

2 From the Turbulence model list, select k-ε with bubble induced turbulence.

3 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

You should now obtain the right plot of Figure 6-18. To create the right plot of 
Figure 6-19, perform the following steps:

1 Click the Plot Parameters button on the Main toolbar.

2 On the Surface page, select Bubbly Flow>Volume fraction of gas from the 
Predefined quantities list.

3 Click the Range button. Clear the Auto check box and type 0.03 in the Max edit field 
and -0.001 in the Min edit field. Click OK.

4 On the Arrow page, select the Arrow plot check box.

5 Click OK.

Finally, account for dissolution of gas into the liquid phase.

P H Y S I C S  S E T T I N G

1 Open the Subdomain Settings dialog box.
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2 Select Subdomain 1, then go to the Mass Transfer page. Select Two-film theory model 
from the list.

3 In the H edit field, type 2.9e3, in the k edit field, type 0.001, and in the c edit field, 
type c.

4 Click Apply.

5 Go to the Physics tab and click the Artificial Diffusion button. 

6 On the Gas Transport tab, type 10000 in the Scale, bubble density edit field.

7 Click OK.

8 Click OK.

9 From the Physics menu, select Boundary Settings.

10 Go to the Gas Phase tab, select Boundary 2, and type 10000 in the Nn edit field. Click 
OK.

11 From the Multiphysics menu, select Model Navigator.

12 Select Chemical Engineering Module>Mass Transport>Convection and Diffusion.

13 Click Add and then OK.

14 Open the Subdomain Settings dialog box for the Convection and Diffusion application 
mode, either from the Physics menu or from the Model Tree.

15 Type the following expressions in the edit fields:

16 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Manager button on the Main toolbar.

2 In the Initial value area on the Initial Value page, select Initial value expression.

3 In the Values of variables not solved for and linearization point area, select 
Current solution. 

4 On the Solve For page, select nbub only. Click OK.

5 Click the Solver Parameters button. Select Stationary segregated from the Solver list.

6 Click the Delete button for Group 2 and 3. Replace the expression in the Components 
edit field for Group 1 by nbub.

7 Click OK.

8 Click the Solve button.

D (ISOTROPIC) R U V

etaT_chbf/rhol_chbf masstrans_chbf/M_chbf ul vl
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9 In the Model Tree, right-click Bubbly flow (chbf) and select Properties.

10 From the Analysis type, select Transient. Click OK.

11 Right-click Convection and Diffusion (chcd) in the Model Tree and select Properties.

12 From the Analysis type list, select Transient. Click OK.

13 Click the Solver Manager button.

14 On the Solve For page, Ctrl-click to select both rhogeff and c.

15 Click the Initial Value tab.

16 In the Initial value area, select Current solution.

17 Click OK.

18 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Perform the following steps to create animations corresponding to the snapshots 
shown in Figure 6-20 and Figure 6-21.

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, clear the Arrow plot check box in the Plot type area.

3 Click the Animate page.

4 Select the Use camera settings from main window check box. Click the Start Animation 
button to see how the gas volume fraction changes with time due to dissolution of 
gas.

5 Click the Surface tab. From the Predefined quantities list, select 
Convection and Diffusion (chcd)>Concentration, c.

6 Click the Range button. Select the Auto check box and click OK.

7 Return to the Animate page and click the Start Animation button to create a movie 
showing how the concentration of the dissolved gas evolves in time.
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Con t am i n an t - R emova l  f r om 
Wa s t ewa t e r  i n  a  S e c onda r y  C l a r i f i e r

Introduction

Wastewater treatment is a several-step process for removing contaminants. First, large, 
solid particles are removed through sedimentation, flotation, and filtration. In a 
second step, biological treatment causes the smaller particles to aggregate, forming so 
called flocs. These flocs can more easily be removed, for instance by sedimentation. 
The present example studies the separation of flocs from water in a circular secondary 
clarifier. To model the turbulent multiphase flow in the tank, the Mixture Model 
application mode is used.

Model Definition

In a circular secondary clarifier, flocs are removed from water by sedimentation. 
Gravity causes the flocs to fall toward the tank bottom. However, the turbulent flow 
in the tank tends to mix the phases together, and thus has a negative effect on the 
separation. The object of this example is to study the complex turbulent multiphase 
flow within a circular secondary clarifier.

Figure 6-22 shows the geometry of the clarifier. The incoming sludge, consisting of a 
mixture of solid flocs and water, enters through the inlet in the middle of the tank. The 
tank contains two outlets. One is located at the center of the tank bottom. The purpose 
of the outlet is to remove the sedimented flocs from the tank. There is also a peripheral 
outlet for the purified water as shown in the figure. Figure 6-23 shows the 
corresponding axisymmetric 2D model. For simplicity, you can model the flocs as 
circular solid particles of equal size.
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Figure 6-22: Cross section of the circular clarifier.

Figure 6-23: Axisymmetric representation of the clarifier geometry.

Inlet

Sludge outlet

Peripheral outlet of purified water

Inlet

Sludge outlet

Peripheral outlet
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To solve for the mixture velocity, pressure and the phase volume fractions, you can use 
the Mixture Model application mode. The mixture model is a multiphase flow model, 
particularly well suited for suspensions, that is, mixtures of solid particles and liquid. 
Based on momentum balance and mass conservation of each phase, the mixture model 
uses the following equations:

Here u denotes mixture velocity (m/s), ρ mixture density (kg/m3), p pressure (Pa), 
cd mass fraction of the solid phase (kg/kg). Furthermore, uslip is the relative velocity 
between the two phases (m/s), τGm the sum of viscous and turbulent stress (kg/
(m·s2)), and g the gravity vector (m/s2). The mixture velocity (m/s) is defined as

where  and  denote the volume fractions of the liquid (continuous) phase and 
the solid (dispersed) phase (m3/m3), respectively, uc the liquid-phase velocity (m/s), 
ud the solid-phase velocity (m/s), ρc the liquid-phase density (kg/m3), ρd the 
solid-phase density (kg/m3), and ρ the mixture density (kg/m3). The relation 
between the velocities of the two phases is defined by 

For the slip velocity, you can use the Hadamard-Rybczynski drag law for solid particles. 
In the Mixture Model application mode, the Hadamard-Rybczynski drag is available 
as a predefined model for the slip velocity. The application mode then calculates the 
slip velocity according to 

where dd denotes the diameter of the solid particles (m). For the mixture density and 
viscosity, you use the following predefined expressions

ρut ρ u ∇⋅( )u+ p∇– ∇ ρcd 1 cd–( )uslipuslip( ) ∇ τGm ρg+⋅+⋅–=

ρc ρd–( ) ∇ φd 1 cd–( )uslip Dmd φd∇–( )⋅[ ] ρc ∇ u⋅( )+ 0=

t∂
∂ φdρd( ) ∇ φdρdud( )⋅+ 0=

u
φcρcuc φdρdud+

ρ
---------------------------------------------=

φc φd

ud uc– ucd uslip
Dmd

1 cd–( )φd
-------------------------- φd∇–= =

uslip
ρ ρd–( )dd

2

18ρη
--------------------------- p∇–=
R  6 :  M U L T I P H A S E  F L O W



To determine the turbulent viscosity, use the k-ε turbulence model. The application 
mode then calculates the particle dispersion coefficient Dmd (m2/s) from

where ηT is the turbulent viscosity (Pa·s) and σT is the (dimensionless) turbulent 
Schmidt number, in this example 0.35.

Note that the Mixture Model application mode automatically sets up all the modeling 
equations. You only need to provide the physical properties of the two phases 
according to the following table:

B O U N D A R Y  C O N D I T I O N S

At the sludge inlet, the velocity is fixed to 1.25 m/s and the solid phase concentration 
is 0.003. The velocity is also fixed at the bottom outlet, while a constant pressure is set 
on the peripheral outlet. Symmetry conditions apply at the water surface and at the 
axial symmetry line. Logarithmic wall functions with insulation of the solid phase hold 
for all solid walls.

I N I T I A L  C O N D I T I O N S

Initially, the velocity as well as the solid phase volume fraction is zero in the entire 
clarifier.

QUANTITY VALUE DESCRIPTION

ρc 1000 kg/m3 Liquid phase density

ηc 1·10-3 Pa·s Liquid phase viscosity

ρd 1100 kg/m3 Solid phase density

dd 2·10-4 m Diameter of solid particles

gz -9.82 m/s2 z-component of gravity vector

max 0.62 Solid phase maximum packing concentration

vin 1.25 m/s Inlet velocity

vout -0.05 m/s Outlet velocity

din 0.003 Volume fraction of solid phase of incoming sludge

η ηc 1
φd

φmax
------------–⎝ ⎠

⎛ ⎞
2.5φmax–

=

ρ φcρc φdρd+=

Dmd
ηT

ρσT
----------=

φ

φ

C O N T A M I N A N T - R E M O V A L  F R O M  W A S T E W A T E R  I N  A  S E C O N D A R Y  C L A R I F I E R  |  297



298 |  C H A P T E
Results and Discussion

Figure 6-24 shows streamlines of the mixture velocity and the solid phase 
concentration, measured in kg/m3, after 24 hours. At this point, the flow has reached 
a steady state. Because turbulence modeling is used, you can interpret the velocity as 
the time-averaged mixture velocity. As expected, the solid particles fall toward the 
bottom. However, the turbulent fluctuations results in diffusion of the solid phase that 
has a negative effect on the separation.

Figure 6-24: Velocity streamlines and solid phase concentration after 24 hours, when the 
flow has reached a steady state solution.

Figure 6-25 shows the solid phase volume fraction at three points, namely close to the 
inlet and close to the two outlets. The figure clearly shows that the solid phase volume 
fraction is about three times lower at the purified water outlet, compared to the 
incoming mixture.
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Figure 6-25: Comparison of the solid phase volume fraction close to the inlet (solid line), 
the sludge outlet (dashed line), and the peripheral outlet (dotted line).

The mass flux of the solid phase through the inlet is given by

and correspondingly for the outflow through the peripheral outlet

The clarifier thus removes solid particles at a rate of Min − Mout. Computing the 
removal rate from the results shows that the clarifier removes 0.518  − 0.151 = 
0.367 kg solid particles per second.

To further examine the performance of the clarifier, you can easily modify the model 
in several ways. You can, for instance, modify the geometry by adding baffles, changing 
the inlet and outlet velocities, increasing the solid phase volume fraction of the 
incoming sludge, or change the density and size of the solid particles.

Modeling in COMSOL Multiphysics

It is straightforward to set up a multiphase flow model with the Mixture Model 
application mode. To simplify the startup of the transient calculation, you can 

Min vin φdinρd Sd
inlet
∫=

Mout vout φdoutρd Sd
outlet
∫=
C O N T A M I N A N T - R E M O V A L  F R O M  W A S T E W A T E R  I N  A  S E C O N D A R Y  C L A R I F I E R  |  299



300 |  C H A P T E
gradually increase the inlet and outlet velocity and the solid phase volume fraction at 
the inlet from zero to their constant values. For this purpose, use the built-in smooth 
step function flc1hs(t,dt), which gradually increases from zero to one as t varies 
from -dt to dt.

Model Library path: Chemical_Engineering_Module/Multiphase_Flow/
sedimentation

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 From the Space dimension list, select Axial symmetry (2D).

2 Select Chemical Engineering Module>Momentum Transport>Multiphase Flow> 
Mixture Model, k-ε Turbulence Model>Transient analysis.

3 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Expressions>Scalar Expressions. Enter the following 
variables (the units and descriptions are optional):

2 Click OK.

G E O M E T R Y  M O D E L I N G

1 From the Options menu, select Axes/Grid Settings.

2 Type in the following values in the edit fields.

3 Go to the Grid tab and clear the Auto check box.

4 In both the r spacing and the z spacing edit fields, type 0.2. Click OK.

NAME EXPRESSION DESCRIPTION

v_in 1.25*flc1hs(t[1/s],0.1)[m/s] Inlet velocity

v_out -0.05*flc1hs(t[1/s],0.1)[m/s] Outlet velocity

phid_in 0.003*flc1hs(t[1/s],0.1) Inlet solid phase 
volume fraction

 r MIN  r MAX  z MIN  z MAX

-1 13 -8 1
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5 On the Draw toolbar, click the Line button while pressing the Shift button on the 
keyboard. Enter the following settings in the dialog box that appears.

6 Click OK.

7 Click the Line button once more, this time without pressing Shift.

8 Click at the following three coordinates in turn. Note that the coordinates are 
displayed in the lower left corner of the graphical interface.

9 On the Draw toolbar, click the 2nd Degree Bézier Curve, then click the points with 
the following coordinates:

10 Click the Line button, and click on the point with coordinates (1.6, −2).

11 Click the 2nd Degree Bézier Curve, the click the following coordinates:

12 Click the Line button and click on the coordinates:

13 Right-click anywhere in the drawing area to create a solid object.

14 Shift-click the Ellipse/Circle (Centered) button. Type in the following settings:

15 Click OK.

16 Click the Rectangle/Square button and click on the two points (11.2, 0) and 
(11.6, −0.4) to draw a square. When you click the second point, the status bar 
should show w=0.4, h=0.4.

 r  z STYLE

0 12 12 2 0.5 0.5 0 0 0 -3.3 -4 -7 -7.4 -7.4 Closed polyline (solid)

COORDINATE 1 COORDINATE 2 COORDINATE 3

(0, -5.4) (0.4, -5.4) (0.4, -3.4)

COORDINATE 1 COORDINATE 2

(0.4, -2.2) (1.6, -2.2)

COORDINATE 1 COORDINATE 2

(0.2, -2) (0.2, -3.4)

COORDINATE 1 COORDINATE 2

(0.2, -5.2) (0, -5.2)

RADIUS BASE R Z

0.05 Center 0 -3.4
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ic 
17 Click the Create Composite Object button on the Draw toolbar.

18 In the Set formula edit field, type CO1-CO2-C1-R1. Click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Physics menu, select Subdomain Settings.

2 Select Subdomain 1. In the Dispersed phase area, type 1100 in the ρd edit field.

3 Click the Physics tab. Type 2e-4 in the dd edit field and -9.82 in the gz edit field. 

4 Click the Mixture Model tab. From the Slip model list, select Hadamard-Rybczynski, 

solid particles.

5 Click the Init tab. Type -8 in both the logk(t0) and the logd(t0) edit fields. 

6 Click OK.

Boundary Conditions
1 From the Physics menu, select Boundary Settings.

2 On the Mixture tab, apply the following boundary conditions:

The value for the turbulent length scale, 0.4·0.07, is based on the suggested value 
for turbulent flow through a pipe given in Table 5-2 in the Chemical Engineering 
Module User’s Guide.

3 On the Dispersed Phase page, apply the following conditions; when done, click OK.

SETTINGS BOUNDARIES 
1, 4, 6

BOUNDARY 5 BOUNDARY 2 BOUNDARY 17 BOUNDARY 7 ALL OTHERS

Boundary 
type

Symmetry 
boundary

Inlet Outlet Outlet Wall Wall

Boundary 
condition

Axial 
symmetry

Velocity Velocity Pressure Slip Logarithm
wall 
function

v v_in v_out

LT 0.4*0.07

p 0

SETTINGS BOUNDARIES 1, 4, 6 BOUNDARY 5 BOUNDARIES 2, 17 ALL OTHERS

Boundary 
condition

Axial symmetry Dispersed phase 
concentration

Dispersed 
phase outlet

Insulation/
Symmetry

phid_inφd
  0
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M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters.

2 Go to the Subdomain page and type 1.1 in the Element growth rate edit field.

3 Click Remesh. When the mesher has finished, click OK. 

C O M P U T I N G  T H E  S O L U T I O N

1 From the Solve menu, select Solver Parameters. 

2 In the Times edit field, type [-0.1:0.01:-0.01 0:3600:3600*24].

3 Click OK.

4 Click the Solve button on the Main toolbar to start the calculation.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Click the Plot Parameters button on the Main toolbar.

2 On the Surface page, type phid*rhod_chmm in the Expression edit field.

3 On the Streamline page, select the Streamline plot check box. Make sure 
Mixture velocity field is selected in the Predefined quantities list.

4 From the Streamline plot type list, select Uniform density. On the Density page, type 
0.02 in the Separating distance edit field. Click the Line Color tab, select Uniform 

Color and click the Color button. Select the white color and click OK.

5 Click OK to produce the plot in Figure 6-24.

6 Click the Animate button on the Postprocessing toolbar to create a movie from the 
result. As you can see, a steady state solution has been reached.

7 Click the Draw Points for Cross-Section Point Plot, also on the Postprocessing toolbar. 
Double-click on SNAP in the status bar at the bottom of the user interface to disable 
the snap function. Click on a point close to the inlet, and two more points close to 
the two outlets. All points should lie within the computational domain.

8 From the Postprocessing menu, select Cross-Section Plot Parameters.

9 On the Point page, verify that Volume fraction of dispersed phase is selected from the 
Predefined quantities list.

10 Click the Line Settings button. From the Line style list, select Cycle. Select the Legend 
check box, then click OK.

11 Click OK. In the plot that appears you can compare the solid phase volume fraction 
at the three different points (Figure 6-25).

Finally, calculate the inflow and outflow rates of the solid phase.
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1 From the Postprocessing menu, choose Boundary Integration.

2 Select Boundary 5 (the inlet) and type v*phid*rhod_chmm in the Expression edit 
field. Select the Compute surface integral (for axisymmetric modes) check box.

3 Click Apply.

The value of the integral, which gives the solid-particle inflow rate, is displayed in 
the message log below the drawing area (approximately 0.518 kg/s).

4 Return to the Boundary Integration dialog box and select Boundary 17 (the 
peripheral outlet). Click OK to get the solid-phase mass flux through the outlet 
(approximately 0.151 kg/s).
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Two -Pha s e  F l ow Mode l i n g  o f  a  Den s e  
S u s p en s i o n

Introduction

Liquid-solid mixtures (suspensions) are important in a variety of industrial fields, such 
as oil and gas refinement, paper manufacturing, food processing, slurry transport, and 
wastewater treatment. Several different modeling approaches have been developed, 
ranging from discrete, particle-based methods to macroscopic, semi-empirical 
two-phase descriptions. Particle-based methods are suitable when there is a limited 
number of solid particles. When, on the other hand, there are many particles, it is 
better to use a macroscopic, or averaged, model that tracks the volume fractions of the 
phases.

The following example illustrates how you can set up a macroscopic two-phase flow 
model in COMSOL Multiphysics using the Mixture Model application mode. The 
model is based on the “diffusive flux” model described in Refs. 1, 2, and 3, suitable for 
liquid-solid mixtures with high concentrations of solid particles. It accounts for not 
only buoyancy effects but also shear-induced migration; that is, the tendency of 
particles to migrate toward regions of lower shear rates.

The model simulates the flow of a dense suspension consisting of light, solid particles 
in a liquid placed between two concentric cylinders. The inner cylinder rotates while 
the outer is fixed.

Model Definition

A suspension is a mixture of solid particles and a liquid. The dynamics of a suspension 
can be modeled by a momentum transport equation for the mixture, a continuity 
equation, and a transport equation for the solid phase volume fraction. The Mixture 
Model application mode automatically sets up these equations. It uses the following 
equation to model the momentum transport:

where u is the mass averaged mixture velocity (m/s), p denotes the pressure (Pa), g 
refers to the gravity vector (m/s2), cs is the dimensionless particle mass fraction, and 

ρ
t∂

∂u ρ u ∇⋅( )u+ p∇– ∇ ρcs 1 cs–( )uslipuslip( ) ∇ η u u∇ T+∇( )[ ] ρg+⋅+⋅–=
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uslip gives the relative velocity between the solid and the liquid phases (m/s). Further, 
 is the mixture density, where ρf and ρs are the pure-phase 

densities (kg/m3) of liquid and solids, respectively, and  is the solid-phase volume 
fraction (m3/m3). Finally, η represents the mixture viscosity (Ns/m2) according to the 
Krieger-type expression 

 (6-25)

where ηf is the dynamic viscosity of the pure fluid and  is the maximum packing 
concentration.

The mixture model uses the following form of the continuity equation

 (6-26)

The transport equation for the solid-phase volume fraction is

 (6-27)

The solid-phase velocity, us, is given by us = u + ( 1 − cs )  uslip. Consequently, 
Equation 6-27 is equivalent to

 (6-28)

Rao and others (Ref. 2) formulate the continuity equation and the particle transport 
in a slightly different way. Instead of the slip velocity, uslip, they define a particle flux, 
Js (kg /(m2·s)), and write the continuity equation as

 (6-29)

and the solid phase transport according to

 (6-30)

By comparing Equation 6-29 and Equation 6-30 with Equation 6-26 and 
Equation 6-28, it is clear that they are equivalent if

ρ 1 φs–( )ρf φsρs+=

φs

η ηf 1
φs

φmax
------------–⎝ ⎠

⎛ ⎞
2.5φmax–

=

φmax

ρf ρs–( ) ∇ φs 1 cs–( )uslip( )⋅[ ] ρf ∇ u⋅( )+ 0=

t∂
∂φs ∇ φsus( )⋅+ 0=

t∂
∂φs ∇ φsu φs 1 cs–( )uslip+( )⋅+ 0=

∇ u⋅
ρs ρf–

ρsρf
---------------- ∇ Js⋅( )=

φs∂
t∂

-------- ∇ φsu( )⋅+
∇ Js⋅

ρs
---------------–=
R  6 :  M U L T I P H A S E  F L O W



In this example you use the model for the particle flux, Js, as suggested by Subia and 
others (Ref. 3) and Rao and others (Ref. 2), but the open and editable format of 
COMSOL Multiphysics makes it possible to specify the expression arbitrarily.

Following Rao and others, the particle flux is

Here, ust is the settling velocity (m/s) of a single particle surrounded by fluid and  
and  are empirically fitted parameters (m2) given by

where a is the particle radius (m).

The shear rate tensor,  (1/s), is given by

and its magnitude by

which for a 2-dimensional problem is

The settling velocity, ust, for a single spherical particle surrounded by pure fluid is 
given by

uslip
Js

φsρs 1 cs–( )
-------------------------------=

Js
ρs
------ φDφ∇ γ· φ( ) φ2γ· Dµ∇ µln( )+[ ]– fhustφ+=

Dφ
Dµ

Dφ 0.41a2
=

Dµ 0.62a2
=

γ
˜

·

γ
˜

· ∇u ∇u( )T
+=

γ· 1
2
--- γ

˜

· :γ
˜

·( )=

γ· 1
2
--- 4ux

2 2 uy vx+( )2 4vy
2

+ +( )=

ust
2
9
---

a2 ρs ρf–( )
η0

----------------------------g=
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For several particles in a fluid, the settling velocity is lower. To account for the 
surrounding particles, the settling velocity for a single particle is multiplied by the 
hindering function, fh, defined as

where  is the average solid phase volume fraction in the suspension, ηf is the 
dynamic viscosity of the pure fluid (Ns/m2), and η is the mixture viscosity 
(Equation 6-25).

The following table gives the physical properties of the solid and the liquid phases. 

B O U N D A R Y  C O N D I T I O N S

The suspension is placed in a Couette device, that is, between two concentric cylinders. 
The inner cylinder rotates while the outer one is fixed. The radii of the two cylinders 
are 0.64 cm and 2.54 cm, respectively. The inner cylinder rotates at a steady rate of 
55 rpm. With the cylinder centered at (0,0), this corresponds to a velocity of

NAME VALUE DESCRIPTION

 ρs 1180 kg/m3 Density of particles

 ρf 1250 kg/m3 Density of pure fluid

 a 678 µm Particle radius

 ηf 0.589 Pa·s Viscosity of pure fluid

fh
ηf 1 φav–( )

η
----------------------------=

φav

u v,( ) 110π
60

------------- y x–,( )=
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The fluid and particle motion is small along the direction of the cylinder axes. You can 
therefore use a 2-dimensional model. Figure 6-26 shows the corresponding geometry.

Figure 6-26: Geometry of the Couette device. The inner cylinder rotates, the outer one is 
fixed.

There is no particle flux through the boundaries, and the suspension velocity satisfies 
no-slip conditions at all walls.

I N I T I A L  C O N D I T I O N S

There are two different initial particle distributions. In the first example, the particles 
are evenly distributed within the device. In the second example, the particles are 
initially gathered at the top of the device.

Results

C A S E  1 — I N I T I A L L Y  E V E N L Y  D I S T R I B U T E D  P A R T I C L E S

A suspension with particles lighter than the fluid is placed in a concentric Couette 
device. Initially, the particles are evenly distributed with a constant volume fraction of 
0.35. The shear rate in the device varies radially across the gap and thus it is expected 
that particles will migrate (shear-induced migration) from regions of high shear to 
regions of low shear (toward the outer wall). Because the particles are lighter than the 
fluid, they also rise.
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Figure 6-27: The particle concentration at different times. The particles move to 
regions with lower shear rate and rise because of buoyancy.

Figure 6-27 shows the particle concentration  in the device at t = 0 s, t = 30 s, t = 
100 s and t = 1000 s. The migration of the particles toward the outer wall is apparent. 
As a result of the shear induced migration and gravity, the solid phase volume fraction 
approaches the value for maximum packing close to the upper right outer wall. The 
suspension viscosity thus becomes high in this region. The results compare well with 
those presented in Ref. 2.

φs

φs
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C A S E  2 — P A R T I C L E S  I N I T I A L L Y  G A T H E R E D  A T  T H E  TO P  O F  T H E  D E V I C E

In this case the particles are initially gathered at the top of the device. The particle 
volume fraction is initially zero in the lower part, while it is 0.59 at the top.

Figure 6-28: Particle concentrations for t = 0 s, 10 s, 20 s, and100 s with particles initially 
at the top. Note that the same color range values are used in each of the plots.

Figure 6-28 shows the numerically predicted particle concentration at times 0 s, 10 s, 
20 s, and 100 s. Initially, the particle motion is dominated by inertia and the effect of 
the shear-induced migration is not visible. At later times, shear-induced migration 
causes the particles to move toward the outer boundary. In this case also, the results 
agree well with the results in Ref. 2.
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Modeling in COMSOL Multiphysics

To set up the model with COMSOL Multiphysics, you will use the Mixture Model 
application mode. The shear rate is discretized as an additional equation to improve 
accuracy because the particle flux contains derivatives of this quantity, which in turn 
depend on the derivatives of the velocity.

Model Library path: Chemical_Engineering_Module/Multiphase_Flow/
dense_suspension

Modeling Using the Graphical User Interface—Case 1

M O D E L  N A V I G A T O R

1 In the Model Navigator, select 2D from the Space dimension list. Click the Multiphysics 
button. 

2 From the Application Modes tree, select Chemical Engineering Module> 
Momentum Transport>Multiphase Flow>Mixture Model, Laminar> 
Transient analysis. Click Add.

3 Select COMSOL Multiphysics>PDE Modes>PDE, General Form> 
Time-dependent analysis. Type gamma in the Dependent variables edit field. Click Add.

4 Click OK to close the Model Navigator.

G E O M E T R Y  M O D E L I N G

1 Shift-click the Ellipse/Circle (Centered) button on the Draw toolbar.

2 Type 0.0064 in the Radius edit field and click OK.

3 Click the Zoom Extents button on the Main toolbar.

4 Shift-click the Ellipse/Circle (Centered) button once more to create a second circle.
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5 Type 0.0254 in the Radius edit field and click OK.

6 Click the Zoom Extents button.

7 Click the Create Composite Object button on the Draw toolbar.

8 In the Set formula edit field, type C2-C1 to cut out the smaller circle from the larger 
one. Click OK.

O P T I O N S  A N D  S E T T I N G S

1 Select Constants from the Options menu and enter the following constant names and 
expressions: 

2 Click OK.

3 From the Options menu, select Expressions>Scalar Expressions. Enter variables and 
expressions in the following table; when done, click OK.

NAME EXPRESSION DESCRIPTION

rho_s 1180[kg/m^3] Density of solid particles

rho_f 1253[kg/m^3] Density of pure fluid

eta_f 0.5889[Pa*s] Viscosity of pure fluid

phi_max 0.64 Maximum packing

g -9.82[m/s^2] Gravity constant

phi0 0.35 Average concentration

R 3.97e-4[m] Particle radius

rpm 55[1/min] Revolutions per minute

c_vel 2*pi*rpm Scaling of velocity

u_st (2/9)*g*R^2* 
(rho_s-rho_f)/eta_f

Settling velocity

D1 0.41*R^2 Model parameter D_phi

D2 0.62*R^2 Model parameter D_mu

NAME EXPRESSION DESCRIPTION

eta_phi diff(eta_chmm,phid) Derivative of viscosity 
with respect to 
concentration

J1 -rho_s*(phid*D1*(phid*gammax+ 
phidx*gamma)+phid*phid*gamma* 
D2*eta_phi*phidx/eta_chmm)

Particle flux, x 
direction
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Note: eta_chmm is the internal name for the mixture viscosity variable. To see names 
and descriptions for other internal variables, select Physics>Equation 

System>Subdomain Settings, select a subdomain, and go to the Variables page.

4 From the Options menu, select Integration Coupling Variables>Subdomain Variables. 
Select Subdomain 1 and type p_tot in the Name edit field and p in the Expression 
edit field. This defines the integral of the pressure, ptot, as the variable p_tot. Click 
OK.

P H Y S I C S  S E T T I N G S — I N C O M P R E S S I B L E  N A V I E R - S T O K E S

Subdomain Settings
1 In the Model Tree (in Overview mode), right-click the Mixture Model (chmm) node 

and click Subdomain Settings. (Alternatively, choose Mixture Model (chmm) from the 
Multiphysics menu, then select Subdomain Settings from the Physics menu.)

2 Enter the following settings in the edit fields:

3 Go to the Physics page and type g in the right Gravity edit field. This edit field 
corresponds to the y-component of the gravity vector.

4 Click the Artificial Diffusion button and clear the Streamline diffusion check box. Click 
the Dispersed Phase Transport page and clear the Isotropic diffusion check box. Click 
OK.

5 On the Mixture Model page, select User defined from the Slip model list.

6 For the Slip velocity, type J1/(phid*rho_s*(1-cd_chmm)) in the left edit field and 
J2/(phid*rho_s*(1-cd_chmm)) in the right edit field.

J2 -rho_s*(phid*D1*(phid*gammay+ 
phidy*gamma)+phid*phid*gamma* 
D2*eta_phi*phidy/eta_chmm)+ 
rho_s*f_hinder*phid*u_st

Particle flux, y 
direction

f_hinder eta_f*(1-phi0)/eta_chmm Hindering function

QUANTITY VALUE/EXPRESSION DESCRIPTION

 ρc rho_f Density of continuous phase

 ηc eta_f Dynamic viscosity of continuous phase

 ρd rho_s Density of dispersed phase

NAME EXPRESSION DESCRIPTION
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7 In the max edit field, type phi_max.

8 Click the Init tab and type phi0 in the phid(t0) edit field.

9 Click OK.

You must add a condition on the integral of the pressure, because the pressure is not 
specified on any part of the boundary.

10 From the Physics menu, select Equation System>Point Settings. Select Point 1. 

11 Click inside the Constraint (constr = 0) edit field. Five edit fields now appear. The 
third of these edit fields corresponds to the pressure equation; type p_tot in that 
field. Click in the Constraint force edit field. Type test(p_tot) in the third of the 
edit fields that appear. You have now added the constraint that the integral of the 
pressure should be equal to zero. Click OK.

Boundary Conditions
1 Open the Boundary Settings dialog box for the Mixture Model (chmm).

2 Press Ctrl while clicking all the boundaries of the interior circle. Boundaries 3, 4, 6, 
and 7 should now be selected in the Boundary selection list.

3 From the Boundary type list, select Inlet. Verify that Velocity is selected in the 
Boundary condition list. Type c_vel*y in the x-velocity edit field and -c_vel*x in 
the y-velocity edit field.

4 The default boundary condition No slip is correct for the other boundaries.

5 For boundary conditions on the dispersed phase, the default condition Insulation/

Symmetry is correct for all boundaries.

6 Click OK.

P H Y S I C S  S E T T I N G S — S H E A R  R A T E

Subdomain Settings
1 Right-click PDE, General Form (g) in the Model Tree and select Subdomain Settings.

2 Enter subdomain variables according to the following table; when done, click OK.

NAME EXPRESSION

 Γ 0 0

 F gamma-sqrt(0.5*(4*ux^2+2*(uy+vx)^2+4*vy^2)+eps)

 ea 0

 da 0

φ
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Boundary Conditions
1 Right-click PDE, General Form (g) in the Model Tree and select Boundary Settings.

2 Select any of the boundaries, then press Ctrl+A to select all of them.

3 Select Neumann boundary condition and leave the value for G at zero.

4 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar. Type [0 30 100 1000] in 
the Times edit field. Click OK.

2 Click the Solve button on the Main toolbar.

The calculation takes about one minute.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Click the Plot Parameters button on the Main toolbar. 

2 Select the Arrow tab and select the Arrow plot check box to create an arrow plot of 
the velocity field.

3 Click OK to generate the plot.

4 Click the Animate button on the Draw toolbar to create a movie corresponding to 
the plots shown in Figure 6-27.

Modeling Using the Graphical User Interface—Case 2

Next, modify the initial conditions to model the case with the particles initially 
gathered at the top. To build this model, you only have to make a few changes to the 
previous model.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Expressions>Scalar Expressions. Add a variable with 
the Name phi0_2 and the Expression flc2hs(y[1/mm]-8,2)*0.59.

2 Click OK.

P H Y S I C S  S E T T I N G S — P A R T I C L E  C O N C E N T R A T I O N  E Q U A T I O N

You must change the initial particle concentration distribution and add some isotropic 
artificial diffusion to stabilize the numerical calculations. In order to avoid dividing by 
zero in the region where the particle volume fraction is initially zero, modify the 
expression for the slip velocity.
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Subdomain Settings
1 Open Subdomain Settings dialog box for Mixture Model (chmm).

2 On the Init page, type phi0_2 in the phid(t0) edit field.

3 On the Physics page, click the Artificial Diffusion button.

4 On the Dispersed Phase Transport page, select the Isotropic diffusion check box. Type 
1 in the  edit field. This is a suitable scale for high particle volume fractions. 
Click OK.

5 On the Mixture Model page, replace the expressions for the slip velocity by J1/
(phid*rho_s*(1-cd_chmm)+eps) and J2/(phid*rho_s*(1-cd_chmm)+eps).

6 Click OK.

M E S H  G E N E R A T I O N

Click the Refine Mesh button on the Main toolbar to create a finer mesh compared to 
the one used for the previous model.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar. Type 0:10:100 in the Times 
edit field. Click OK.

2 Click the Solver Manager button on the Main toolbar. In the Initial value area, select 
Initial value expression. Click OK.

3 Click the Solve button on the Main toolbar.

The computation takes about 6 minutes.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Click the Plot Parameters button on the Main toolbar.

2 Go to the Surface page and click the Range button.

3 Clear the Auto check box and type -0.02 in the Min edit field and 0.64 in the Max 
edit field. Click OK.

4 Click OK.

5 Click the Animate button on the Draw toolbar to visualize the result shown in 
Figure 6-28 as a movie.

δscale ρ,
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 7
M i c r o f l u i d i c s  
This chapter contains examples of mass transport coupled to momentum transport, 
where typical systems of this type are found in microsystems and are often affected 
by electric fields. To transport fluid at very small scales, it is best to avoid small, 
moving parts. Instead, electric fields often transport a medium made up of an ionic 
solution. 

COMSOL Multiphysics is well suited for these types of processes for two reasons:

• Its ability to model multiphysics applications easily and quickly—often you need to 
model momentum and mass transport to a description of the electric potential 
field. Other models might also require energy transport.

• Its ability to handle equation-based modeling—the coupling between the physics 
that describes such systems can be unusual and require user-defined functions. 
Furthermore, chemical kinetics can be involved along with sudden changes in 
time-based phenomena or phases. Further, such a system could depend on an 
arbitrary description of the double charge layer at a boundary or another 
description for the electric field, so the ability to quickly type in your own 
equations is therefore useful. 
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E l e c t r o k i n e t i c  F l ow i n a  DNA Ch i p

This model was developed by Dr. Jordan MacInnes at the University of Sheffield, UK. 
The modeling work at his department has been combined with experimental studies.

Introduction

Miniature laboratories (Ref. 1) are required to efficiently analyze the information in 
human DNA, and they can facilitate tailor-made diagnosis and treatment of hereditary 
diseases for individuals. A problem that arises in these lab-on-chip devices concerns the 
transport of the liquid samples and other solutions in the chip, which are of very small 
dimensions. Moving parts of micrometer scale make the chips very expensive and 
fragile and are therefore to be avoided if at all possible. An alternative method for 
transporting fluid in the samples is through electrokinetic effects, where charged ions 
in the solutions are subjected to an electric field. These ions can drag the entire 
solution through the channels in the microchip from one analyzing point to the other.

Two mechanisms can drive the flow of a saline solution in an electric field. In the 
presence of solid surfaces, like the micromachined surfaces of the channels of a biochip, 
a charged solution is formed close to the wall surfaces. This layer is referred to as a 
diffuse double layer. Depending on the material used, it is formed by negatively or 
positively charged groups on the wall’s surfaces. The electric field displaces the charged 
liquid in the charged double layer generating an electroosmotic flow. Figure 7-1 shows 
the velocity field shortly after the application of an electric field.

Figure 7-1: Velocity field near a solid wall. The fluid flows in the direction of the electric 
field.
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A force is imposed on the positively charged solution close to the wall surface, and the 
fluid starts to flow in the direction of the electric field. The velocity gradients 
perpendicular to the wall give rise to viscous transport in this direction. In the absence 
of other forces, the velocity profile eventually becomes almost uniform in the cross 
section perpendicular to the wall. The time constant of the overall flow is roughly 1 ms, 
while the flow in the double layer responds to changes far more rapidly. The layer 
model of MacInnes (Ref. 1) replaces the double layer with the Helmholtz- 
Smoluchowski relationship between wall velocity and wall electric field (Ref. 2).

The second effect arises due to differences in mobility and charge of the ionic species. 
Negatively and positively charged ions migrate in different directions, and these ions 
drag water molecules, to different extents, through the channel system. Water is 
dragged by the sodium ions, which can coordinate more water molecules than the 
chloride ions in the solution. This type of flow is called electrophoretic flow; 
Figure 7-2 depicts its basic principle.

Figure 7-2: Electrophoretic flow.

This particular model does not include the mass transport of dissolved species in the 
sample (see Ref. 1), but you could easily add them through the Nernst-Plank 
application mode or the Convection and Diffusion application mode. As another 
possible model extension, you could use a time-dependent expression for the voltage 
at the inlet and outlet boundaries.

Model Definition

Flow in the chip occurs due to the electroosmotic effect just described. In order to 
simulate this type of flow, the model must couple the electric potential distribution in 
the ionic solution inside the chip and the Navier-Stokes equations for fluid flow. 
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Figure 7-3 shows the chip’s geometry. The potential difference imposed between its 
different parts produces a flow in the vertical or horizontal direction, depending on 
the direction of the imposed field. Mode A generates a horizontal flow from right to 
left in the main channel; Mode B generates a flow that is vertical in the vertical channels 
and horizontal, from right to left, in the part of the main channel that unites the 
vertical branches.

Figure 7-3: Geometry and electric field setup in the two modes: Mode A, where the flow is 
expected to flow in the horizontal branch, and Mode B, with flow in the vertical branch.

You set the potentials at the open boundaries, where the fluid is allowed to enter or 
leave the channel system. The wall boundaries are denoted diffuse layer boundaries. 
From the published work of Dr. MacInnes (Ref. 1) you can expect the flow to be 
laminar and of a low Reynolds number. This implies that it is adequate to use the 
Navier-Stokes equations to describe flow in the channels:

 (7-1)

Here η denotes the dynamic viscosity (Pa·s), u is the velocity (m/s), ρ equals the 
fluid’s density (kg/m3), and p is the pressure (Pa).

Mode A Mode B

248V

79V

213V

283V

diffuse layer
boundary

flow path

193V

114V 79V

0V

diffuse layer
boundary

flow path

ρ
t∂

∂u ∇ η ∇u ∇u( )T
+( )⋅– ρ u ∇⋅( )u ∇p+ + 0=

∇ u⋅ 0=
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The boundary conditions, according to this notation, are the following:

 (7-2)

where εw (F/m) denotes the permittivity of water, ζ0 (V) is the zeta potential at the 
channel wall, and V (V) refers to the applied potential. The boundary condition for the 
flow at the wall boundaries sets the velocity vector proportional to the gradient of the 
potential. For a more detailed review of the diffuse layer wall boundary condition, see 
Ref. 1 and Ref. 3.

Assuming that there are no concentration gradients for the ions carrying the current, 
it is possible to express the current balance in the channel through Ohm’s law and the 
balance equation for current density:

 (7-3)

Here σ denotes the conductivity (S/m) and the expression within the brackets 
represents the current density (A/m2).

The corresponding boundary conditions for the current balance are

 (7-4)

where V0 corresponds to the voltage shown in the previous figure at the neutral 
boundaries. At these boundaries, the potential and current distributions in the chip 
determine if the fluid enters or exits the chip or stays at rest.

The input data used in this model is listed in the following table.

TABLE 7-1:  INPUT DATA

PROPERTY VALUE DESCRIPTION

 ρ 103 kg/m3 Density

 η 10-3 Pa·s Dynamic viscosity

 σ 0.11845 S/m Electric conductivity

 εw 80.2·8.854·10-12 F/m Electric permittivity

 ζ0 0.1 V Zeta potential

                          u
εwζ0

η
------------ V             diffuse layer, wall∇=

η ∇u ∇u( )T
+( ) n⋅ 0       inlets and outlets=

∇ σ∇V–( )⋅ 0=

σ V n⋅∇– 0        diffuse layer, wall=

      V V0           inlets and outlets=
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Results

Figure 7-4 shows the potential distribution for Mode A in the chip. From this plot it 
is clear that the largest potential differences arise in the horizontal direction. This also 
implies that the main flow is in the same direction.

Figure 7-4: Potential distribution in the chip when the electric field from mode A is 
applied.

The plot in Figure 7-5 shows that the average velocity in the channel is approximately 
1 mm/s. The largest velocity occurs at the corner walls where the electric field is large. 
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This clearly shows the effect of the driving force located at the walls. For regular 
pressure-driven flow, the velocity at the solid surfaces is zero.

Figure 7-5: Velocity distribution in the chip with the electric field from Mode A applied.
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Studying the velocity flow lines in the channel, Figure 7-6 shows that flow takes a small 
deviation at the T-junctions in the chip. This can also be detected in the color scale of 
the velocity, which decreases in the middle of the junction.

Figure 7-6: Close-up of the velocity field. The surface plot shows the modulus of the velocity 
vector and the lines the streamlines of the velocity field.

Regulating the potential can quickly and efficiently change the flow path in the 
channels. This makes it possible to mix solutions in different branches of the chip. 
Figure 7-7 shows a different flow direction with the same magnitude as the potential 
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configuration given in Mode A. In this plot, you can also find the corner effects and 
the low velocity regions in the T-junctions as the channel width increases. 

Figure 7-7: Flow distribution in the chip with the electric field from Mode B applied.

Figure 7-8 shows that the flow decreases in the outer parts of the turns while a 
maximum arises in the inner parts. The maximum velocity is actually larger in this case 
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than in the previous one because the electric field is much stronger around the corners 
compared to the straight path in the first simulation.

Figure 7-8: Close-up of the flow distribution near the T-junctions.

As the model demonstrates, it is easy to treat electrokinetic flow using the Chemical 
Engineering Module.
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Model Library path: Chemical_Engineering_Module/Microfluidics/biochip
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Modeling Using the Graphical User Interface

1 In the Model Navigator, set the Space dimension to 2D.

2 From the Application Modes list, select 
Chemical Engineering Module>Momentum Transport>Laminar Flow>

Incompressible Navier-Stokes.

3 Click the Multiphysics button.

4 Click the Add button.

5 From the Application Modes list, select 
COMSOL Multiphysics>Electromagnetics>Conductive Media DC, then click Add.

6 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

2 Define the following constants; when done, click OK.

G E O M E T R Y  M O D E L I N G

Create the geometry using the CAD tools in COMSOL Multiphysics.

1 Press the Shift key and click the Rectangle/Square button on the Draw toolbar.

2 In the Size area of the Rectangle dialog box, enter the Width 0.25e-3 and the Height 
5.35e-3. In the Position area, set x to 2.5e-3 and y to 2.5e-4. Click OK.

3 Repeat this procedure to create two additional rectangles with the following 
properties:

NAME EXPRESSION DESCRIPTION

rho 1e3[kg/m^3] Density

eta 1e-3[Pa*s] Viscosity

sigma 0.11845[S/m] Electric conductivity

eps_w 80.2*8.854[pF/m] Electric permittivity

zeta0 0.1[V] Zeta potential

SETTINGS RECTANGLE 2 RECTANGLE 3

Width 0.25e-3 1.45e-2

Height 5.35e-3 2.5e-4

x 5e-3 0

y -5.35e-3 0
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4 Click the Zoom Extents button on the Main toolbar.

5 Press Ctrl+A to select all geometry objects.

6 Click the Union button on the Draw toolbar.

7 Click the Delete Interior Boundaries button.

8 From the Draw menu, select Fillet/Chamfer.

9 In the drawing area, Ctrl-click to select the four vertices connecting the vertical 
channels with the horizontal one (Vertices 3, 5, 8, and 10).

10 In the Fillet/Chamfer dialog box, specify the fillet Radius 0.5e-4.

11 Click OK to close the dialog box.

This completes the geometry modeling stage.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Multiphysics menu, select 1 Incompressible Navier-Stokes (chns).

2 From the Physics menu, open the Subdomain Settings dialog box.

3 Select Subdomain 1.

4 In the ρ edit field, type rho, and in the η edit field, type eta. Click OK.
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5 In the Multiphysics menu, switch to the 2 Conductive Media DC (dc) application mode.

6 From the Physics menu, open the Subdomain Settings dialog box.

7 In the σ edit field, type sigma. Click OK.

Boundary Conditions
1 From the Multiphysics menu, select 1 Incompressible Navier-Stokes (chns).

2 From the Physics menu, open the Boundary Settings dialog box.

3 Specify boundary conditions according to the following table; when done, click OK.

4 From the Multiphysics menu, select 2 Conductive Media DC (dc).

5 From the Physics menu, open the Boundary Settings dialog box.

6 Enter boundary conditions according to the following table; when done, click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters.

2 Click the Custom mesh size button, then set the Mesh curvature factor to 0.6.

3 Click the Boundary tab. From the Boundary selection list, select 1, 5, 9, and 12.

4 In Maximum element size edit field, type 1e-4.

5 Click the Remesh button to generate the mesh.

6 When the mesher has finished, click OK.

SETTINGS BOUNDARY 1 BOUNDARIES 2–4, 6–8, 10, 11, 13–16 BOUNDARIES 5, 9, 12

Boundary 
type

Outlet Inlet Open boundary

Boundary 
condition

Pressure, no 
viscous stress

Velocity Normal stress

u0 (eps_w*zeta0/eta)*Vx

v0 (eps_w*zeta0/eta)*Vy

p0 0

f0 0

SETTINGS BOUNDARY 1 BOUNDARY 5 BOUNDARY 9 BOUNDARY 12 BOUNDARIES 2–4, 
6–8, 10, 11, 13–16

Boundary 
condition

Electric 
potential

Electric 
potential

Electric 
potential

Electric 
potential

Electric 
insulation

V0 283 248 213 79
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C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Follow these instructions to generate the plot in Figure 7-4:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, make sure that only the Surface and Geometry edges plot types 
are selected.

3 On the Surface page, select Conductive Media DC (emdc)>Electric potential from the 
Predefined quantities list on the Surface Data page.

4 Click Apply.

Proceed to create the plots in Figure 7-5 and Figure 7-6 with these steps:

5 On the Surface page, select Incompressible Navier-Stokes (chns)>Velocity field from 
the Predefined quantities list on the Surface Data page. From the Unit list, select mm/s.

6 Click Apply to obtain the plot in Figure 7-5.

7 On the Streamline page, select the Streamline plot check box.

8 From the Predefined quantities list on the Streamline Data page, select 
Incompressible Navier-Stokes (chns)>Velocity field.

9 From the Streamline plot type list, select Magnitude controlled. Set the Density to 9.

10 On the Line Color page, click first the Uniform color option button and then the Color 
button. In the Streamline Color dialog box, select the black swatch, then click OK.

11 Click the Advanced button. Set the Maximum number of integration steps to 4000.

12 Click OK to close the Advanced Streamline Parameters dialog box.

13 Click OK in the Plot Parameters dialog box.

14 From the Options menu, select Axes/Grid Settings.

15 On the Axis page, specify these settings:

16 Click OK to generate the plot in Figure 7-6.

x min 2e-3

x max 6e-3

y min -1e-3

y max 1e-3
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P H Y S I C S  S E T T I N G S — M O D E  B

Now switch the electric field to Mode B (see the right panel of Figure 7-3).

Boundary Conditions
1 From the Multiphysics menu, select 2 Conductive Media DC (emdc).

2 From the Physics menu, open the Boundary Settings dialog box.

3 Modify the boundary conditions according to the table below; when done, click OK.

C O M P U T I N G  T H E  S O L U T I O N — M O D E  B

Click the Restart button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N — M O D E  B

The plot that appears in the drawing area when the solver has finished reproduces the 
one in Figure 7-8. To generate the plot in Figure 7-7, follow these steps:

1 Click the Plot Parameters button on the Main toolbar.

2 On the Streamline page, clear the Streamline plot check box, then click OK.

3 Click the Zoom Extents button on the Main toolbar.

SETTINGS BOUNDARY 1 BOUNDARY 5 BOUNDARY 9

Boundary condition Electric potential Electric potential Electric potential

V0 114 193 0
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F i l l i n g  o f  a  C ap i l l a r y  Chann e l

Introduction

Surface tension and wall adhesive forces are often used to transport fluid through 
microchannels in MEMS devices or to measure, transport and position small amounts 
of fluid using micropipettes. Multiphase flow through a porous medium and droplets 
on solid walls are other examples where wall adhesion and surface tension strongly 
influence the dynamics of the flow.

To model the adhesive forces at the walls correctly, the treatment of the boundary 
conditions is important. If you fix the velocity to zero on the walls, the interface cannot 
move along the walls. Instead, you need to allow a non-zero slip velocity and to add a 
frictional force at the wall. With such a boundary condition, it is possible to explicitly 
set the contact angle, that is, the angle between the fluid interface and the wall. The 
correct value of the contact angle depends on properties of the fluids and the wall. You 
can determine the contact angle experimentally or calculate it from the surface energies 
related to the different phase interfaces using Young’s law.

This example studies a narrow vertical cylinder placed on top of a reservoir filled with 
water. Because of wall adhesion and surface tension at the air/water interface, water 
rises through the channel. The model calculates the pressure field, the velocity field, 
and the water surface’s shape and position. It uses a level set method to track the air/
water interface and shows how to add friction and specify the contact angle at the 
channel walls.

Model Definition

The model consists of a capillary channel of radius 0.15 mm attached to a water 
reservoir. Water can flow freely into the reservoir. Because both the channel and the 
reservoir are cylindrical, you can use the axisymmetric model illustrated in Figure 7-9. 
Initially, the thin cylinder is filled with air. The wall adhesion causes water to creep up 
along the cylinder boundaries. The deformation of the water surface induces surface 
tension at the air/water interface, which in turn creates a pressure jump across the 
interface. The pressure variations cause water and air to move upward. The fluids 
continue to rise until the capillary forces are balanced by the gravity force that builds 
up as the water rises in the channel. In the present example, the capillary forces 
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dominate over gravity throughout the simulation. Consequently, the interface moves 
upwards during the entire simulation.

Figure 7-9: Axisymmetric geometry description.

M A S S  A N D  M O M E N T U M  TR A N S P O R T

The Navier-Stokes equations describe the transport of mass and momentum for fluids 
of constant density. In order to account for capillary effects, it is crucial to include 
surface tension in the model. The Navier-Stokes equations are then

Here, ρ denotes the density (kg/m3), η equals the dynamic viscosity (Ns/m2), u 
represents the velocity (m/s), p denotes the pressure (Pa), and g is the gravity vector 
(m/s2). Fst is the surface tension force that acts at the air/water interface and is
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Here, I is the identity matrix, n is the interface normal, σ equals the surface tension 
coefficient (N/m), and δ equals a Dirac delta function that is nonzero only at the fluid 
interface. When you use the finite element method to solve the Navier-Stokes 
equations, you multiply the equations by test functions and then integrate over the 
computational domain. If you use integration by parts, you can move derivatives of T 
to the test functions. This is used in the Level Set and Laminar Flow application mode 
and results in an integral over the computational domain plus a boundary integral of 
the form

,  (7-5)

where θ is the contact angle (see Figure 7-10). If you apply a no-slip boundary 
condition, the boundary term vanishes because test(u) = 0 on that boundary, and you 
cannot specify the contact angle. Instead, the interface remains fixed on the wall. 
However, if you allow a small amount of slip, it is possible to specify the contact angle. 
The Wetted wall boundary condition adds the term given by Equation 7-5 and 
consequently allows you to set the contact angle.

R E P R E S E N T A T I O N  A N D  C O N V E C T I O N  O F  T H E  F L U I D  I N T E R F A C E

The Level Set Two-Phase Flow, Laminar application mode automatically sets up the 
equations for the convection of the interface, calculates normal and curvature of the 
interface, and adds surface tension and gravitation to the Navier-Stokes equations.

The application mode represents the interface as the 0.5 contour of the level set 
function . In air, and in water . You can thus think of the level set 
function as the volume fraction of water. The transport of the interface is given by

The application mode uses the level set function to smooth the density and viscosity 
jump across the interface by letting

The delta function is approximated by

T σ I nnT( )–( )δ=

test u( ) σ nwall n θcos( )–( )δ[ ]⋅ Sd
∂Ω
∫

φ φ 0= φ 1=

φ∂
t∂

------ ∇ φu( )⋅ γ ∇ φ 1 φ–( ) ∇φ
∇φ

----------⎝ ⎠
⎛ ⎞⋅⎝ ⎠

⎛ ⎞ ε∇ ∇φ⋅–+ + 0=

ρ ρair ρwater ρair–( )φ+=

µ µair µwater µair–( )φ+=
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and the interface normal is calculated from

I N I T I A L  C O N D I T I O N S

Initially, the reservoir is filled with water and the capillary channel is filled with air. The 
initial velocity is zero.

B O U N D A R Y  C O N D I T I O N S

Inlet
The hydrostatic pressure, p = ρgz, gives the pressure at the inflow boundary. Only 
water enters through the inlet, so the level set function, that is, the volume fraction of 
water, is 1 here.

Outlet
At the outlet, the pressure is equal to zero, that is, equal to the pressure at the top of 
the inflow boundary. Because it is an outflow boundary, you do not have to set any 
condition on the level set function.

Walls
The boundary condition Wetted wall is suitable for solid walls in contact with a fluid 
interface. It sets the velocity component normal to the wall to zero, that is,

and adds a frictional boundary force

Here, β is the slip length. The boundary condition also allows you to specify the 
contact angle θ, that is, the angle between the wall and the fluid interface (see 
Figure 7-10 according to “Mass and Momentum Transport” on page 335). In this 
example, the contact angle is 67.5° and the slip length equals the mesh element size, h.

δ 6 φ 1 φ–( ) φ∇=

n ∇φ
∇φ
----------=

u nwall⋅ 0=

Ffr
η
β
---– u=
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Figure 7-10: Definition of the contact angle θ.

Results and Discussion

Figure 7-11 shows the interface and the velocity field at different times. Initially, the 
shape of the interface changes dynamically (see Figure 7-12). After about 0.6 ms the 
shape of the water surface remains constant and forms a rising concave meniscus. Note 
that the slip velocity at the walls is almost zero, except close to the fluid interface/wall 
contact point.

Air

Water

Wall
θ
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Figure 7-11: Interface and velocity field at different times.

Figure 7-12 shows how the interface dynamically deforms during the first 0.2 ms as a 
result of the surface tension at the water surface.

t = 0

t = 1.0 mst = 0.8 mst = 0.6 ms

t = 0.4 mst = 0.2 ms
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Figure 7-12: Snapshots of the position of the interface during the first 0.2 ms.
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Figure 7-13 shows the pressure profile at t = 0.6 ms. At the fluid interface there is a 
pressure jump of roughly 300 Pa. The jump is caused by the surface tension, and forces 
water and air to rise through the channel.

Figure 7-13: Pressure at t = 0.6 ms.

You can easily calculate the position of the interface/wall contact point by integrating 
the level set function along the thin cylinder wall. Figure 7-14 shows the position of 
the contact point as a function of time. After 0.6 ms, the contact point moves with an 
almost constant speed.

Figure 7-14: Position of the interface/wall contact point as a function of time. The velocity 
is approximately constant after t = 0.6 ms.

Finally, you can verify the obtained contact angle. It is defined by cos θ = nTnwall.
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In this case, the normal to the wall is nwall = (1, 0). The contact angle is thus 
θ = acos  nr, where nr is the radial component of the interface normal. At t = 0.6 ms, 
the contact angle is 1.16 rad = 66°, which can be compared with the imposed contact 
angle of 3π/8 = 1.18 = 67.5°. The contact angle approaches the imposed value if you 
refine the mesh further.

Figure 7-15: Plot of acos(nr). At the wall, this gives the contact angle. In this case 
θ = 1.16 rad = 66°. 

Modeling in COMSOL Multiphysics

It is straightforward to set up the model with the Level Set Two-Phase Flow, Laminar 
application mode. At the walls in contact with the fluid interface, use the Wetted wall 
boundary condition.

Model Library path:  
Chemical_Engineering_Module/Microfluidics/capillary_filling

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 In the Model Navigator, go to the Space dimension list and select Axial symmetry (2D).
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2 From the list of application modes, select  
Chemical Engineering Module>Momentum Transport>Multiphase Flow>Level Set 

Two-Phase Flow, Laminar.

3 In the Application mode name edit field, type twophase, then click OK.

G E O M E T R Y  M O D E L I N G

1 Shift-click the Rectangle/Square button on the Draw toolbar. Type 3e-4 in the Width 
edit field, 1.5e-4 in the Height edit field, 0 in the r edit field, and -1.5e-4 in the 
z edit field. Click OK. Click the Zoom Extents button on the Main toolbar.

2 Create another rectangle with these settings: 

3 Click the Zoom Extents button on the Main toolbar.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

2 Define the following constants:

3 Click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 In the Model Tree, right-click Level Set Two-Phase Flow, Laminar (twophase) and select 

Subdomain Settings.

WIDTH HEIGHT BASE R Z

1.5e-4 5e-4 Corner 0 0

NAME EXPRESSION DESCRIPTION

theta (3*pi/8)[rad] Contact angle

p_ref 1e5[Pa] Reference pressure

T_ref 293[K] Temperature

sigma 0.073[N/m] Surface tension coefficient

g 9.81[m/s^2] Acceleration due to gravity
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Note: There are a number of different ways to open the Subdomain Settings and the 
Boundary Settings dialog boxes. This description assumes that you have the Model Tree 
visible in Overview mode. To open the Model Tree click the Model Tree button on the 
Main toolbar, then click the Overview button on the toolbar at the top of the Model 

Tree.

2 Press Ctrl and select both subdomains. In the Fluid 1 area, click the Load button. 
Select Liquids and Gases>Gases>Air, 1 atm from the Materials list and click OK. 

3 Click the Load button in the Fluid 2 area. Select Liquids and Gases>Liquids>Water, 

liquid and click OK. 

4 For both fluids, replace p and T in the expressions for the Dynamic viscosity and 
Density by p_ref and T_ref.

5 Go to the Sources/Sinks page. Type sigma in the Surface tension coefficient edit field 
and -g in the Gravity, z component edit field.

6 Click the Init tab. Select Subdomain 1 and select the option button Fluid 2.

7 Click OK.

Boundary Conditions
1 In the Model Tree right-click Level Set Two-Phase Flow, Laminar (twophase) and select 

Boundary Settings.

2 Assign boundary conditions for the exterior boundaries according to the following 
table.

3 Select Boundary 4 and select the Interior boundaries check box. Select the boundary 
condition Initial fluid interface.

SETTINGS BOUNDARIES 1, 3 BOUNDARY 8 BOUNDARY 5 BOUNDARIES 6, 7

Boundary 
type

Symmetry 
boundary

Inlet Outlet Wall

Boundary 
condition

Axial symmetry Pressure, no 
viscous stress

Pressure, no 
viscous stress

Wetted wall

 p0 rho_twophase*z* 
gz_twophase

0

 0 1

 θ theta

 β h

φ
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4 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu select Mapped Mesh Parameters.

2 Select both subdomains and select Extremely fine from the Predefined mesh sizes list.

3 Click the Mesh Selected button, then click OK.

C O M P U T I N G  T H E  S O L U T I O N

First reinitialize to obtain the correct shape of in the transition layer.

1 From the Solve menu select Solver Parameters.

2 Click the General tab and enter 1e-3 in the Times edit field. Click OK.

3 Click the Solve button on the Main toolbar. This creates a good initial solution to 
the level set function.

Use the obtained solution as an initial condition to the simulation of the droplet 
motion.

1 Click the Solver Manager button on the Main toolbar.

2 Click the Store Solution button. Select the time 0.001. Click OK.

3 In the Initial value area click the Stored solution option button.

4 Select 0.001 from the Solution at time list, then click OK.

5 Click the Solver Parameters button on the Main toolbar.

6 Click the General tab, then enter 0:0.25e-4:1e-3 in the Times edit field. Click OK.

7 From the Physics menu, select Properties.

8 Change the Analysis type to Transient, then click OK.

9 Click the Solve button on the Main toolbar.

Note: The calculations take 2–3 hours.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, clear the Surface check box and select the Contour and Arrow 
check boxes.

φ φ
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3 On the Contour page, go to the Contour levels area and click the Vector with isolevels 

option button. Type 0.5 in the corresponding edit field.

4 Click the Arrow tab. From the Predefined quantities list on the Subdomain Data page, 
select Velocity field. In the Number of points edit field for z points, type 30.

5 Click Apply.

6 On the General page, select a value from the Solution at time list and then click Apply 
to visualize the result at the corresponding value. Repeat to view the solution at 
other times.

7 Click OK.

8 To create a movie from the plots at the different times, click the Animate button on 
the Plot toolbar.

To create filled contour plots as in Figure 7-12, perform the following steps:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, clear the Arrow check box in the Plot type area.

3 On the Contour page, select the Filled check box.

4 Click OK.

Next, create the pressure plot in Figure 7-13.

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, clear the Contour check box and select the Surface check box 
in the Plot type area. In the Solution to use area, select 6e-4 from the Solution at time 
list.

3 Click the Surface tab. From the Predefined quantities list on the Surface Data page, 
select Pressure.

4 Click OK.

Follow the next steps to calculate and plot the position of the contact point as in 
Figure 7-14.

1 From the Options menu, select Integration Coupling Variables>Boundary Variables.

2 Select Boundary 6. Type cont_pos in the Name edit field on the first row of the 
table and phi in the corresponding Expression edit field. Click OK.

3 From the Solve menu, select Update Model.

4 From the Postprocessing menu, select Global Variables Plot.
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5 Type cont_pos in the Expression edit field, then click the Add Entered Expression 
button next to the edit field. Click OK to generate the plot.

Finally, check the obtained contact angle.

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, clear the Surface check box and select the Contour check box 
in the Plot type area.

3 Click the Contour tab. On the Color Data page, click the Color data option button.

4 Clear the Filled check box.

5 In the Expression edit field, type acos(normr_twophase), then click OK.
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T r a n s po r t  i n  an E l e c t r o k i n e t i c  V a l v e

Introduction

This model presents an example of pressure-driven flow and electrophoresis in a 
microchannel system.

Researchers often use a device similar to the one in this model as an electrokinetic 
sample injector in biochips to obtain well-defined sample volumes of dissociated acids 
and salts and to transport these volumes. The model presents a study of a pinched 
injection cross valve during the focusing, injection, and separation stages. Inspiration 
for the model comes from a study by Ermakov and others (Ref. 1). Focusing is 
obtained through pressure-driven flow of the sample and buffer solution, which 
confines the sample in the focusing channel. When the system reaches steady state, the 
pressure-driven flow is turned off and an electric field is applied along the channels. 
This field drives the dissociated sample ions in the focusing zone at right angles to the 
focusing channel and through the injection channel. A clean separation of the sample 
ions is important, so the model examines the effect on ion separation of different 
configurations of the electric field.

This specific case does not account for electroosmosis because the channel surfaces are 
subjected to a treatment that minimizes the extension of the electric double layer. For 
a 3D version of this model, see “Transport in an Electrokinetic Valve, 3D Model” on 
page 365.
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Model Definition

Figure 7-16 shows the model domain’s geometry. The horizontal channel serves as the 
focusing channel and the vertical channel is the injection channel.

Figure 7-16: The focusing stage involves pressure-driven and electro-driven flow of the 
sample and the buffering solution from the left, top, and bottom to the right. An electric 
field is then applied over the focusing zone to induce transport down through the injection 
channel.

The device operation and hence the modeling procedure takes place in two stages: 
focusing and injection.

The focusing stage involves a buffering solution that is injected through 
pressure-driven convection and electro-driven migration into the vertical channel. The 
buffering solution neutralizes the acids contained in the sample except for a very thin 
region confined to the junction between the horizontal and vertical channels. This 
means that the dissociated ions are found only in the needle-shaped region in the 
focusing zone.

During the injection stage, convective flow is turned off and an electric field is applied 
in both the horizontal and vertical directions toward the upper end of the injection 

Focusing zone

Injection channel

Focusing channel

OutletSample
inlet

Buffer inlet

Buffer inlet
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channel (see Figure 7-17).

Figure 7-17: During the injection stage, the convective flow is turned off and an electric 
field is applied. The horizontal field prevents sample broadening while the vertical field 
injects the sample into the vertical channel in a direction opposite to the electric field.

The horizontal field focuses the sample during the initial part of the injection stage to 
produce a well-separated sample. The vertical field is applied to migrate the sample 
from the focusing channel to the injection point at the lower end of the vertical 
channel. The sample ions are negatively charged and thus migrate in the opposite 
direction to the electric field. To study the effect of sample distortion during the 
injection stage, the simulation also covers the case where the horizontal field has not 
been applied.

This study assumes that the concentration of charged samples is very low compared to 
that of other ions dissolved in the solution. This implies that the sample concentration 
does not influence the solution’s conductivity and that you can neglect the 
concentration gradients of the charge-carrying species, which are present in a much 
higher concentration than the sample ions. Such an electrolyte is referred to as a 
supporting electrolyte.

Further assume that concentration variations of the sample species are small in the 
direction perpendicular to the xy-plane, which reduces a 3D model to a 2D 

Migration of the sample

Electric field
vectors

opposite to the field
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approximation. This assumption is not entirely true for pressure-driven flow, and a 
detailed model would include the third dimension.

The model uses the Navier-Stokes equations, the equation for current balance, and a 
mass transport based on the Nernst-Planck equation. The steady-state solution for the 
focusing stage serves as the initial condition for the injection stages.

The boundary conditions are changed between the focusing and injection stages. 
Moreover, you do not solve the Navier-Stokes equations during the injection stage 
because the transport of the charged sample takes place through diffusion and 
migration (electrophoresis). The model equations are formulated below.

T H E  F O C U S I N G  S T A G E

The Navier-Stokes equations give the global momentum transport

,  (7-6)

which for incompressible flow is complemented by the mass-conservation equation

.  (7-7)

Here η denotes the dynamic viscosity (Pa·s), u represents the velocity (m/s), ρ gives 
the fluid’s density (kg/m3), and p is the pressure (Pa).

The total balance of charges for a supporting electrolyte is given by the divergence of 
the current density, which in a supporting electrolyte satisfies Ohm’s law,

,  (7-8)

where κ is the electrolyte’s conductivity (S/m) and V denotes the potential (V). 
Combined with the balance of current at steady state,

,  (7-9)

this leads to a Laplace equation for the electric potential:

.  (7-10)

The Nernst-Planck equation gives the flux vector for the sample ions with 
concentration, c (mol/m3):

.  (7-11)

ρ
t∂

∂u ∇ η ∇u ∇u( )T
+( )⋅– ρ u ∇⋅( )u ∇p+ + 0=

∇ u⋅ 0=

i κ∇V–=

∇ i⋅ 0=

∇ κ∇V–( )⋅ 0=

N D∇c– zum F c∇V– cu+=
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For the focusing stage, you solve the electrolyte mass-conservation equation at steady 
state, , in a fixed background potential:

.  (7-12)

In Equations 7-11 and 7-12, D is the diffusivity (m2/s), z is the charge number, um 
represents the mobility (mol·m2/(J·s)), and F equals Faraday’s constant (C/mol).

Turning to the boundary conditions, assume laminar flow at the inlets with specified 
average inflow velocities. At the outlet, the shear-stress tensor components normal to 
the boundary are negligible,

,  (7-13)

and the pressure is constant,

.  (7-14)

The boundary conditions for the charge balance set the potential at the inlet and outlet 
boundaries:

 (7-15)

Here the index  i runs over the inlet and outlet boundaries. Assume that all wall 
boundaries are insulating, so that

.  (7-16)

The boundary conditions for the mass transport of the sample during the focusing 
stage specify the concentration at the sample inlet and at the two buffer inlets located 
at the ends of the vertical channel:

 (7-17)

The boundary condition at the outlet states that convection is the dominating 
transport mechanism there (that is, diffusion and migration are negligible):

.  (7-18)

∇ N⋅ 0=

∇ D∇c– zum Fc∇V– cu+( )⋅ 0=

n η ∇u ∇u( )T
+( )⋅ 0=

p 0=

V V0 i,=

V∇ n⋅ 0=

c cin= at the sample inlet

c 0=   at the buffer inlets

n D c∇– zumFc V∇–( )⋅ 0=
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T H E  I N J E C T I O N  A N D  S E P A R A T I O N  S T A G E S

During the injection and separation stages, you turn off the flow and modify the 
electric-field configuration. To account for the latter change, solve Equation 7-10 
again using a new set of boundary conditions.

In the transient mass transport for the dilute species you assume the convective term 
to be zero, resulting in the equation

.  (7-19)

The boundary conditions for the current-balance equation implies that the potential is 
locked at all boundaries except for the walls:

.  (7-20)

The walls, in contrast, you assume to be electrically insulated:

.  (7-21)

The mass-transport boundary conditions are different from those during the focusing 
stage. During the injection and separation stages, you leave the inlet and outlet 
boundaries open and assume that migration is the dominating transport mechanism:

.  (7-22)

The time-dependent solution requires an initial condition for the mass transport, 
namely

 (7-23)

where the concentration comes from the steady-state solution reached at the end of 
the focusing stage.

Results and Discussion

This study covers two configurations for the potential. In the first, Mode A, the electric 
field in the injection stage is applied only over the injection channel. Figure 7-18 
depicts the resulting concentration distribution in a time sequence.

t∂
∂c ∇+ D c∇– zumFc V∇–( )⋅ 0=

V V0 i,=

V∇ n⋅ 0=

Ni n⋅ ziumi Fci V∇–( ) n⋅=

c t 0=( ) cfocus=
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Figure 7-18: The concentration distribution during the focusing (left) and injection 
stages (middle and right) in the electrokinetic valve’s junction. The separation stage is 
part of the injection stage. The right plot of the separation step shows that the detachment 
of the sample is incomplete.

The figure clearly shows that the detachment of the sample during the separation 
process is incomplete. In fact, if the separated sample is allowed to travel further down 
the injection channel, the poorly separated region remains attached to the focusing 
zone. This is clearly visible in Figure 7-19, which shows the cross-section of the 
concentration profiles at different time steps during the simulation 5 µm from the left 
wall of the injection channel. The concentration peak moves downwards along the 
injection channel, but a part of the sample remains attached to the focusing zone. This 
effect gives an unwanted distortion of the sample and a deviation from a required 
bell-curve shape for the concentration profile.

Figure 7-19: Mode-A concentration profiles along the injection channel at the times 0 s, 
0.06 s, 0.12 s, 0.18 s, 0.24 s, 0.30 s, 0.36 s, 0.42 s, 0.48 s, 0.54 s, and 0.60 s after initiation 
of the injection stage. The incomplete detachment is clearly seen in the graph.

t = 0s t = 0.06s t = 0.12s
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In Mode B, you apply an electric field in the horizontal direction, inward from both 
ends to the focusing zone, to avoid broadening of the sample top and to ensure 
complete detachment. The next two figures examine the results from that simulation.

Figure 7-20: In this case the sample has almost completely detached during the separation 
stage compared to the results in Figure 7-18. It should be mentioned that the electric field 
strength has a different distribution, which gives a slightly lower migration rate.

Figure 7-20 shows the improved detachment effect that the horizontal field has on the 
separation of the sample. This is even clearer in Figure 7-21, in which the 
concentration profile forms a nice bell curve throughout the downward transport in 
the injection channel.

Figure 7-21: Mode-B concentration profiles along the injection channel at 0 s, 0.06 s, 
0.12 s, 0.18 s, 0.24 s, 0.30 s, 0.36 s, 0.42 s, 0.48 s, 0.54 s, and 0.60 s after initiation of the 
injection stage. The separation of the sample is substantially improved compared to the 
Mode-A simulation in Figure 7-19.

This study clearly shows that modeling is extremely valuable in the investigation of 
electrophoretic transport. You can vary the configuration of the potential to obtain 
even better focusing and injection stages for the studied valve.

t = 0.12st = 0.06st = 0s
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Modeling in COMSOL Multiphysics

The COMSOL Multiphysics implementation is reasonably straightforward but 
deserves a few comments. The main strategy is to first solve the equations for the 
focusing stage using the stationary solver and then solve the equations for the injection 
stage using both the stationary and time-dependent solvers. The following list provides 
a summary of the main steps:

1 Solve the steady-state problem for the focusing stage, which involves the 
Navier-Stokes, charge-balance, and mass-transport equations.

2 Store the solution.

3 Change the boundary conditions for the charge balance and re-solve the equation 
for this balance only. Keep the solution for the concentration field unchanged.

4 Store the solution.

5 Change the boundary conditions for the mass transport.

6 Change the settings to a time-dependent problem and set the velocity components 
u and v to zero in the Electrokinetic Flow application mode.

7 Re-solve the problem.

Model Library path:  
Chemical_Engineering_Module/Microfluidics/electrokinetic_valve_2d

Modeling Using the Graphical User Interface

1 In the Model Navigator set the Space dimension to 2D.

2 In the list of application modes select  
Chemical Engineering Module>Momentum Transport>Laminar Flow>

Incompressible Navier-Stokes.
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3 Click the Multiphysics button, then click Add.

4 Similarly add two more application modes:  
Chemical Engineering Module>Mass Transport>Electrokinetic Flow>Transient analysis 
and COMSOL Multiphysics>Electromagnetics>Conductive Media DC.

Note that you must explicitly select the transient analysis type for the Electrokinetic 
Flow application mode; by not selecting an analysis type for Incompressible 
Navier-Stokes, you get the correct stationary analysis type for that application mode.

5 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

2 Define the constants in the following table; when done, click OK.

G E O M E T R Y  M O D E L I N G

1 Hold the Shift key and click the Rectangle/Square button on the Draw toolbar.

2 In the Rectangle dialog box that appears, enter the following properties; when done, 
click OK.

NAME EXPRESSION DESCRIPTION

u_av 0.2[mm/s] Average velocity, sample inlet

v_av 0.67[mm/s] Average velocity, buffer inlets

rho 1e3[kg/m^3] Fluid density

eta 1e-3[Pa*s] Fluid viscosity

D 1e-9[m^2/s] Sample ion diffusivity

Rg 8.314[J/(mol*K)] Gas constant

T 298[K] Temperature

nu D/(Rg*T) Sample ion mobility

sigma 1[S/m] Electric conductivity, electrolyte

c_in 0.05*3.5[g/l]/ 
(22+35)[g/mol]

Sample inlet concentration

PARAMETER VALUE

Width 2e-5

Height 3.2e-4

x position 0

y position -2e-4
TR A N S P O R T  I N  A N  E L E C T R O K I N E T I C  V A L V E  |  357



358 |  C H A P T E
3 Repeat this procedure for a second rectangle with the following dimensions.

4 Click the Zoom Extents button on the Main toolbar.

5 Press Ctrl+A to select both rectangles.

6 Click first the Union button and then the Delete Interior Boundaries button on the 
Draw toolbar.

7 Click the Fillet/Chamfer button on the Draw toolbar.

8 In the drawing area, Ctrl-click to select the four vertices where the horizontal and 
vertical channels meet (Vertices 4, 5, 8, and 9). 

9 In the Fillet/Chamfer dialog box, set the fillet Radius to 4e-6.

10 Click OK.

The model geometry is now complete; it should look like that in the following figure.

P H Y S I C S  S E T T I N G S — F O C U S I N G  S T A G E

Subdomain Settings
1 From the Multiphysics menu, select 1 Incompressible Navier-Stokes (chns).

2 From the Physics menu, open the Subdomain Settings dialog box.

PARAMETER VALUE

Width 3.4e-4

Height 2e-5

x position -1e-4

y position 0
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3 Select Subdomain 1, then enter these subdomain settings; when done, click OK.

4 From the Multiphysics menu, select 2 Electrokinetic Flow (chekf).

5 From the Physics menu, open the Subdomain Settings dialog box.

6 With Subdomain 1 selected, enter these subdomain settings; when done, click OK.

7 From the Multiphysics menu, select 3 Conductive Media DC (dc).

8 From the Physics menu, open the Subdomain Settings dialog box.

9 Select Subdomain 1, then set σ to sigma. Click OK.

Boundary Conditions
1 From the Multiphysics menu, select 1 Incompressible Navier-Stokes (chns).

2 From the Physics menu, select Boundary Settings.

3 Specify boundary conditions according to the following table; when done, click OK.

PROPERTY VALUE

 ρ rho

 η eta

PROPERTY VALUE

D (isotropic) D

R 0

um nu

z -1

u u

v v

V V

SETTINGS BOUNDARY 1 BOUNDARIES 5, 7 BOUNDARY 12 BOUNDARIES 
2–4, 6, 8–11, 13–16

Boundary type Inlet Inlet Outlet Wall

Boundary 
condition

Laminar 
inflow

Laminar inflow Pressure, no 
viscous stress

No slip

U0 u_av v_av

Lentr 1e-4 1e-4

Constrain end 
points to zero

Yes Yes

p0 0
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4 From the Multiphysics menu, select 2 Electrokinetic Flow (chekf).

5 Specify boundary conditions according to the following table; when done, click OK.

6 From the Multiphysics menu, select 3 Conductive Media DC (dc).

7 Specify boundary conditions according to the following table; when done, click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters.

2 Click the Custom mesh size button.

3 Set the Maximum element size to 2e-6 and the Mesh curvature factor to 0.5.

The latter setting increases the typical mesh-element size near the fillets compared 
to that obtained with the default parameter value 0.3, while maintaining a sufficient 
mesh resolution in these regions.

4 Click Remesh, then click OK.

C O M P U T I N G  T H E  S O L U T I O N — F O C U S I N G  S T A G E

First, compute the solution for the velocity field, and then use that solution when 
solving the mass-transport problem.

1 Click the Solver Manager button on the Main toolbar.

2 On the Solve For page, select Incompressible Navier-Stokes (chns) from the 
Solve for variables list.

3 Click the Solve button.

4 When the solver has finished, click the Initial Value tab.

5 Click the Current solution option button in the Initial value area, then return to the 
Solve For page.

6 From the Solve for variables list, select Conductive Media DC (dc). Click Solve.

SETTINGS BOUNDARY 1 BOUNDARIES 2–4, 6, 
8–11, 13–16

BOUNDARIES 5, 7 BOUNDARY 12

Boundary 
condition

Concentration Insulation/ 
Symmetry

Concentration Convective flux

c0 c_in 0

SETTINGS BOUNDARY 1 BOUNDARIES 2–11, 13–16 BOUNDARY 12

Boundary condition Electric potential Electric insulation Ground

V0 -1 -
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7 From the Solve for variables list, select Electrokinetic Flow (chekf). Click Solve.

8 Click the Initial Value tab.

9 Click the Store Solution button, then click OK to close the dialog box.

The focusing stage is now complete. In the next step you solve the model for the 
transient problem that describes the injection and separation stages.

P H Y S I C S  S E T T I N G S — I N J E C T I O N  S T A G E ,  M O D E  A

Subdomain Settings
1 From the Multiphysics menu, select 2 Electrokinetic Flow (chekf).

2 From the Physics menu, select Subdomain Settings.

3 Change the values for u and v to 0, then click OK.

Boundary Conditions
1 From the Physics menu, select Boundary Settings.

2 Select Boundaries 1, 5, 7, and 12 (the inlets and outlets).

3 From the Boundary condition list, select Flux.

4 In the N0 edit field, type -nmflux_c_chekf.

The predefined boundary variable nmflux_c_chekf gives the outward normal 
electrophoretic flux, Ni · n (see Equation 7-22 for its definition).

5 Click OK.

6 From the Multiphysics menu, select 3 Conductive Media DC (dc).

7 From the Physics menu, select Boundary Settings.

8 Modify the following boundary settings; when done, click OK.

C O M P U T I N G  T H E  S O L U T I O N — I N J E C T I O N  S T A G E ,  M O D E  A

1 Click the Solver Manager button on the Main toolbar.

2 Click the Script tab. Select the Automatically add commands when solving check box.

This setting instructs the software to record the subsequent solver settings and 
commands, which you can then reuse when solving Mode B.

SETTINGS BOUNDARIES 1, 12 BOUNDARY 5 BOUNDARY 7

Boundary condition Electric insulation Ground Electric potential

V0 - - -3.2
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3 Click the Initial Value tab. Click the Stored solution option button in the Initial value 
area. This makes the steady-state solution from the focusing stage the initial 
solution.

4 Click the Solve For tab. In the Solve for variables list, select Conductive Media DC (dc), 
then click Solve.

5 Click the Initial Value tab. In the Initial value area, click the Current solution option 
button.

6 Leaving the Solver Manager dialog box open, click the Solver Parameters button on 
the Main toolbar.

7 From the Analysis list, select Transient.

8 In the Times edit field, type 0:0.03:0.6.

9 Click OK to close the Solver Parameters dialog box.

10 Return to the Solver Manager and click the Solve For tab.

11 In the Solve for variables list, select Electrokinetic Flow (chekf).

12 Click OK to close the Solver Manager.

13 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N — M O D E  A

To generate the three plots in Figure 7-18 on page 354, follow these steps:

1 From the Options menu, open the Axes/Grid Settings dialog box.

2 On the Grid page, select the Auto check box.

3 On the Axis page, set x min and y min to-4e-5, and x max and y max to 6e-5. Click 
OK.

4 From the Postprocessing menu, open the Plot Parameters dialog box.

5 Click the Surface tab. On the Surface Data page, choose Electrokinetic Flow 

(chekf)>Concentration, c from the Predefined quantities list.

6 On the General page, clear the Auto check box for Element refinement and type 5 in 
the associated edit field.

7 Select 0 from the Solution at time list.

8 Click Apply to generate the plot in the left panel.

9 On the General page, select 0.06 from the Solution at time list.

10 Click Apply to generate the plot in the center panel of Figure 7-18.

11 Select 0.12 from the Solution at time list.
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12 Click OK to close the dialog box and generate the plot in the right panel.

Generate Figure 7-19 using the cross-section plot functionality:

1 From the Postprocessing menu, select Cross-Section Plot Parameters.

2 On the General page, select every other time step from the Solutions to use list 
starting with 0.

3 Click the Line/Extrusion tab.

4 In the y-axis data area, choose Electrokinetic Flow (chekf)>Concentration, c from the 
Predefined quantities list.

5 In the x-axis data area, click the lower option button, then click the Expression 
button. In the X-Axis Data dialog box, type -y in the Expression edit field. From the 
Unit list, select µm, then click OK.

6 In the Cross-section line data area, specify the following settings:

7 Click OK to close the Cross-Section Plot Parameters dialog box and generate the plot.

P H Y S I C S  S E T T I N G S — I N J E C T I O N  S T A G E ,  M O D E  B

The next step is to model the second configuration of the electric field—Mode B.

Boundary Conditions
1 From the Physics menu, select Boundary Settings.

2 Modify the following boundary settings for the Conductive Media DC application 
mode; when done, click OK.

C O M P U T I N G  T H E  S O L U T I O N — I N J E C T I O N  S T A G E ,  M O D E  B

1 Click the Solver Manager button on the Main toolbar.

2 On the Script page, select the Solve using a script check box.

PROPERTY VALUE

x0 0.1e-4

x1 0.1e-4

y0 0.25e-4

y1 -2e-4

SETTINGS BOUNDARY 1 BOUNDARY 12

Boundary condition Electric potential Ground

V0 -1 -
TR A N S P O R T  I N  A N  E L E C T R O K I N E T I C  V A L V E  |  363



364 |  C H A P T E
3 Click Solve to execute the script you see in the edit window.

4 Click OK to close the Solver Manager.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N — M O D E  B

Generate the three plots in Figure 7-20 on page 355 as follows:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, select 0 from the Solution at time list. Click Apply.

This generates the plot in the left panel.

3 Repeat Step 2 but select, in turn, 0.06 and 0.12 from the Solution at time list to 
generate the remaining two plots. When done, click Cancel to close the dialog box.

Finally, generate the plot in Figure 7-21 with the following steps:

1 From the Postprocessing menu, select Cross-Section Plot Parameters.

2 On the General page, select every other entry in the Solutions to use list starting with 
0, then click OK.
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T r a n s po r t  i n  an E l e c t r o k i n e t i c  V a l v e ,  
3D Mode l

Introduction

This model presents an example of pressure-driven flow and electrophoresis in a 
microchannel system.

Researchers often use a device similar to the one in this model as an electrokinetic 
sample injector in biochips to obtain well-defined sample volumes of dissociated acids 
and salts and to transport these volumes. The model presents a study of a pinched 
injection cross valve during the focusing, injection, and separation stages. Inspiration 
for the model comes from a study by Ermakov and others (Ref. 1). Focusing is 
obtained through pressure-driven flow of the sample and buffer solution, which 
confines the sample in the focusing channel. When the system reaches steady state, the 
pressure-driven flow is turned off and an electric field is applied along the channels. 
This field drives the dissociated sample ions in the focusing zone at right angles to the 
focusing channel and through the injection channel. A clean separation of the sample 
ions is important, so the model examines the effect on ion separation of different 
configurations of the electric field.

This specific case does not account for electroosmosis because the channel surfaces are 
subjected to a treatment that minimizes the extension of the electric double layer.

Model Definition

Figure 7-16 shows a 2D cross section of the geometry in the xz-plane and points out 
the different channels and boundaries. The horizontal channel serves as the focusing 
channel, while the vertical channel is the injection channel. The actual model is in 3D 
with rectangular pipes whose corners are rounded. For geometry dimensions refer to 
Table 7-3 on page 374.
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Figure 7-22: The focusing stage involves pressure-driven flow of both the sample and the 
buffering solution. The device applies an electric field over the focusing channel.

The device operation and hence the modeling procedure takes place in two stages: 
focusing and injection.

In the focusing stage, the device injects a buffering solution through pressure-driven 
convection into the vertical channels from the top and bottom. At the same time, it 
forces the sample solution through the horizontal focusing channel (see Figure 7-16). 
The buffering solution neutralizes the acids contained in the sample except for a very 
thin region confined to the crossing between the horizontal and vertical channels. This 
means that the dissociated ions are only in a needle-shaped region in the focusing zone.

Next, in the injection stage the device turns off the convective flow and then applies a 
vertical field to migrate the sample from the focusing channel to the injection point at 
the lower end of the vertical channel. The sample ions are negatively charged and 
migrate in opposite direction to the electric field. This model studies two different 
configurations (See Table 7-2) for the applied electric field. In the first configuration 
(Injection stage, Mode A) electric field is only applied in the vertical direction. In the 
second configuration (Injection stage, Mode B) the electric field is applied in both the 

Focusing zone

Injection channel

Focusing channel

OutletSample
inlet

Buffer inlet

Buffer inlet
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horizontal and vertical directions (Figure 7-17).The horizontal field focuses the 
sample during the initial part of the injection stage in order to obtain a well-separated 
sample. 

Figure 7-23: During the injection stage, the device turns off convective flow and applies 
an electric field. The horizontal field avoids the broadening of the sample, while the 
vertical field injects the sample into the vertical channel in the direction opposite to the 
electric field.

The model assumes that the charged sample concentration is very low compared to 
other ions dissolved in the solution. This implies that the sample concentration does 
not influence the solution’s conductivity and that you can neglect the concentration 
gradients of the charge-carrying species, which are present in a much higher 
concentration than the sample ions. Such an electrolyte is known as a supporting 
electrolyte.

TABLE 7-2:  APPLIED ELECTRIC FIELD CONFIGURATION

INLET MODE A MODE B

Sample inlet Electric insulation Electric potential, V = -1V

Outlet Electric insulation Electric potential, V = 0V

Upper buffer inlet Electric potential, V = -3.2V Electric potential, V = -3.2V

Lower buffer inlet Electric potential, V = 0V Electric potential, V = 0V

Migration of the sample

Electric field
vectors

opposite to the field
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Several equations describe the model: the Stokes flow equations, the equation for 
current balance, and a mass balance using the Nernst-Planck equation. This model uses 
the steady-state solution for the focusing stage as the initial condition for the injection 
stages.

Now consider the formulation of the model equations.

T H E  F O C U S I N G  S T A G E

The incompressible Navier-Stokes equations give the global mass a momentum 
balance in the focusing stage:

In these equations, η denotes the dynamic viscosity (kg/(m·s)), u is the velocity (m/
s), p is the pressure (Pa).

The total balance of charges for a supporting electrolyte comes from the divergence of 
the current-density vector, which in a supporting electrolyte is given by Ohm’s law:

Here κ is the electrolyte’s conductivity (S/m) and V is the potential (V). The balance 
of current at steady state then becomes

which gives

The flux vector for the sample ions comes from the Nernst-Planck equation

which leads to the following mass balance equation at steady state for species i:

Here ci is the concentration (mol/m3), Di represents the diffusivity (m2/s), zi equals 
the charge number (which equals 1 for this model), umi is the mobility (s·mol/kg), 
and F is Faraday’s constant (C/mol).

∇– η ∇u ∇u( )T
+( )⋅ ρ u ∇⋅( )u ∇p+ + 0=

∇ u⋅ 0.=

i κ V∇–=

∇ i⋅ 0=

∇ κ V∇–( )⋅ 0=

Ni Di∇ci– ziumiFci V∇– ciu+=

∇ Di∇ci– ziumiFci V∇– ciu+( )⋅ 0=
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For the pressure-driven flow, assume that the flow has fully developed laminar form in 
all inlets, that all sides have no-slip conditions, and that the fluid flows freely out from 
the end of the focusing channel.

The boundary conditions for the charge balance determine the potential at the 
respective inlet and outlet boundary

where  i denotes the index for each boundary. This model also assumes that all wall 
boundaries are insulating:

The boundary conditions for the mass balance of the sample during the focusing stage 
appear below. The equation

gives the concentration at the inlet of the sample, while the equation

gives the concentration of the buffer at the inlet of the two vertical channels, and the 
buffer inlets are at both boundaries in the vertical channel. At the outlet boundary, 
convection and migration are the dominating transport mechanisms (that is, diffusion 
is negligible), so that 

T H E  I N J E C T I O N  S T A G E

In the injection and separation stages, the device turns the flow off and changes the 
configuration of the electric field. You again solve the charge-balance equations but 
with new boundary conditions:

The mass balance for the dilute species comes from a time-dependent mass balance:

The model assumes that the convective contribution is zero.

V V0 i,=

V∇ n⋅ 0=

c cin=

c cbuffer=

Ni n⋅ ziumiFci V∇– ciu+( ) n⋅=

∇ κ V∇–( )⋅ 0=

t∂
∂c ∇+ Di∇ci– ziumiFci V∇–( )⋅ 0=
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The boundary conditions for the current-balance equation imply that the potential is 
locked at all boundaries except for the walls,

Further assume the walls are electrically insulated, which yields

As opposed to the focusing state, the boundary conditions for the mass balance are 
changed. In the injection stage, set the concentration at the inlet boundary:

For all other boundaries, assume that migration is the dominating transport 
mechanism, so that

 (7-24)

The time-dependent solution requires an initial condition for the mass balance, which 
you obtain from the steady-state solution of the focusing stage:

Results and Discussion

This example analyzes the focusing stage and two configurations for the injection 
stages. Recall that the first injection-stage configuration (Mode A) applies the electric 
field only over the injection channel while the inlet and outlet boundaries of the 
focusing channel are insulated; the second injection-stage configuration (Mode B) 
applies the electric field over both channels.

Figure 7-24 shows the steady-state concentration distribution during the focusing 
stage along with the distribution at the beginning of the injection stage. Note that the 
vertical flows from the upper and lower injection channels focus the concentration on 

V V0 i,=

V∇ n⋅ 0=

c cin=

Ni n⋅ ziumiFci V∇–( ) n⋅=

c t 0=( ) cfocus=
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a very narrow region near the crossing area of the channels. Further away from the 
crossing area, however, the concentration spreads again more equally over the channel. 

Figure 7-24: The steady-state concentration distribution during the focusing stage and 
prior to the injection stage.

Figure 7-25 and Figure 7-26 compare the concentration distribution for the two 
configurations at two times, specifically 0.06 s and 0.12 s after the beginning of the 
injection stage. The figures on the left show that for Mode A the concentration 
boundary is practically stationary in the horizontal direction. Consequently, the 
vertical electric field can continuously draw ions from the focusing channel, which 
results in poor separation and a poorly defined sample volume of the substance. For 
Mode B the situation is very different. The horizontal electric field draws the 
concentration boundary to the left, and the channels separate rapidly. Consequently, 
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this scheme draws a well-defined sample volume of the substance into the injection 
channel.

Figure 7-25: The concentration distribution at a time 0.06 s after starting the injection 
stage for the Mode A configuration (left) and Mode B configuration (right).

Figure 7-26: The concentration distribution at a time 0.12 s after starting the injection 
stage for the Mode A configuration (left) and Mode B configuration (right).

It is also possible to observe the difference between the two configurations if you look 
at the concentration along a line through the middle of the injection channel, 
examining it at several times after the start of the injection stage (Figure 7-27). The 
maximum concentration moves down the injection channel with time. The peaks are 
higher in the upper axis corresponding to Mode A, but they are much wider than for 
Mode B. A considerable amount of concentration appears at the left of the peak, and 
the sample remains attached to the focusing area—resulting in an unwanted distortion 
of the sample package. The narrow peaks of Mode B, on the other hand, form nice bell 
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curves throughout the downward transport in the injection channel, resulting in a 
well-defined sample package.

Figure 7-27: Concentration profile for Mode A (top) and Mode B (bottom) along the 
injection channel at various time steps: 0 s, 0.06 s, 0.12 s, 0.18 s, 0.24 s, 0.30 s, 0.36 s, 
0.42 s, 0.48 s, 0.54 s, and 0.6 s after initialization of the injection stage. The origin of the 
x-axis marks the centerline of the focusing channel.
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This study illustrates that modeling is extremely valuable in the investigation of 
electrophoretic transport. You can vary the configuration of the potential to obtain 
even better focusing and injection stages for the valve under study.

Modeling in COMSOL Multiphysics

A P P L I C A T I O N  M O D E S

In COMSOL Multiphysics you define the model with three application modes:

• The Incompressible Navier-Stokes application mode solves the fluid flow in the 
channels with Navier-Stokes equations.

• The Conductive Media DC application mode solves the equation for current 
balance.

• The Electrokinetic Flow application mode solves the Nernst-Planck equation.

G E O M E T R Y  M O D E L I N G

Table 7-3 gives the dimensions of the model geometry. To draw it, proceed in four 
steps:

1 Initialize the geometry with simple blocks that represent the crossing of the 
channels.

2 Create a 2D work plane geometry in which you draw the cross section of the 
channel and a few assisting objects.

3 To finalize to channel crossing, apply the revolve operator to the 2D objects and 
subtract the resulting 3D objects from the original 3D blocks.

4 Finally apply the extrude operator to the 2D channel cross section to create the 
channels.

TABLE 7-3:  MODEL DIMENSIONS

HORIZONTAL CHANNEL VERTICAL CHANNEL CROSSING AREA

Dimensions (µm)

- x 340 20 28

- y 20 20 20

- z 20 340 28

Position (µm)

- x -100 0 -4

- y 0 0 0
R  7 :  M I C R O F L U I D I C S



C O M P U T I N G  T H E  S O L U T I O N

The operation of the actual device proceeds in two stages, the focusing stage and the 
injection stage. This model simulates two settings of the injection stage so in total it 
works in three phases.

The first phase defines the subdomain settings and boundary conditions for the 
focusing phase. Then the model solves the application modes sequentially with a 
nonlinear solver in the following sequence:

1 Incompressible Navier-Stokes Flow application mode

2 Conductive Media DC application mode

3 Electrokinetic Flow application mode 

Each step uses the solution from the previous one. The model stores the last solution 
for use as the initial value for the consequent modeling.

In the second phase you change the subdomain settings and boundary conditions to 
handle the injection stage Mode A. In a real device you would turn off the convective 
flow; in the model you simulate this by setting the velocity parameters of the 
Electrokinetic Flow application mode to zero. Thus it uses no information from the 
Incompressible Navier-Stokes Flow application mode.

Solving the second phase starts from the stored solution of the first phase, and the 
model solves the Conductive Media DC application mode with a nonlinear solver. 
Then you select a time-dependent solver and solve the Electrokinetic Flow application 
mode. This solution is the result for the injection stage Mode A.

In the third phase you again change subdomain settings and boundary conditions but 
this time for the injection stage Mode B; you then solve for the final solution the same 
way as in the second phase.

- z 0 -200 -4

Rounding (µm)

- radius 4 4 4

- direction in in out

TABLE 7-3:  MODEL DIMENSIONS

HORIZONTAL CHANNEL VERTICAL CHANNEL CROSSING AREA
TR A N S P O R T  I N  A N  E L E C T R O K I N E T I C  V A L V E ,  3 D  M O D E L  |  375



376 |  C H A P T E
Reference

1. S.V. Ermakov, S.C. Jacobson, and J.M. Ramsey, Technical Proc 1999 Int’l Conf. 
on Modeling and Simulation of Microsystems, Computational Publications, 1999.

Model Library path:  
Chemical_Engineering_Module/Microfluidics/electrokinetic_valve_3d

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator, select the New page, and from the Space dimension list 
select 3D.

2 Click the Multiphysics button.

3 In the Application Modes tree, select Chemical Engineering Module>Momentum 

Transport>Laminar Flow>Incompressible Navier-Stokes. Click Add.

4 In the Application Modes tree, select COMSOL 

Multiphysics>Electromagnetics>Conductive Media DC. Click Add.

5 In the Application Modes tree, select Chemical Engineering Module>Mass 

Transport>Electrokinetic Flow>Transient analysis. Click Add.

6 Click OK.

O P T I O N S  A N D  S E T T I N G S

Next define some constants for the model.

1 From the Options menu, choose Constants.

2 In the dialog box that opens, specify names, expressions, and (optionally) 
descriptions for the following constants; when done, click OK.

NAME EXPRESSION DESCRIPTION

u_a 0.2[mm/s] Average velocity, sample inlet

w_a 0.67[mm/s] Average velocity, buffer inlets

rho 1e3[kg/m^3] Fluid density

eta 1e-3[Pa*s] Fluid viscosity

D 1e-9[m^2/s] Sample ion diffusivity
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G E O M E T R Y  M O D E L I N G

3D Geometry—Step 1
Start the geometry by creating a simple set of rectangular blocks. 

1 Click the Block tool on the 3D Draw toolbar and create two rectangular blocks using 
the settings from the following table; keep all other settings at their default values.

2 Click the Zoom Extents button on the Main toolbar.

Work Plane Geometry
Next create a 2D geometry on a work plane. After you extrude and revolve the objects, 
they shape the 3D geometry. 

1 From the Draw menu, choose Work Plane Settings.

2 On the Quick page, click the y-z option button. Type -4e-6 in the associated x edit 
field. Click OK.

3 Click the Geom2 tab to activate the 2D work plane geometry.

4 Shift-click the Rectangle/Square button on the Draw toolbar. 

5 Create a rectangle as in the following table; when done, click OK.

6 Click the Zoom Extents button on the Main toolbar.

7 Click the Fillet/Chamfer button on the Draw toolbar.

Rg 8.314[J/(mol*K)] Gas constant

T 298[K] Fluid temperature

nu D/(Rg*T) Sample ion mobility

sigma 1[S/m] Electric conductivity, electrolyte

c_in 0.05*3.5[g/l]/ 
(22+35)[g/mol]

Sample ion concentration, inlet

BLOCK AXIS BASE POINT LENGTH

X Y Z X Y Z

BLK1 -4e-6 0 -4e-6 28e-6 20e-6 28e-6

BLK2 -20e-6 0 -20e-6 60e-6 20e-6 60e-6

SIZE POSITION

WIDTH HEIGHT BASE X Y

20e-6 20e-6 Corner 0 0

NAME EXPRESSION DESCRIPTION
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8 In the dialog box go to the Vertex selection area, open the menu tree under R1, then 
select the four corners. Click the Fillet option button, and in the Radius edit field 
type 4e-6. Click OK.

9 Shift-click the Rectangle/Square button on the Draw toolbar. Create a rectangle as in 
the following table; when done, click OK.

10 Click the Create Composite Object button on the Draw toolbar.

11 Verify that the Keep interior boundaries check box is selected.

12 In the Set formula edit field, type CO1+R1. Click OK.

13 Click the Split Object button on the Draw toolbar.

Zoom-in view of the completed 2D geometry.

3D Geometry—Step 2
After creating the work plane geometry, keep Geom2 activated and use it to shape the 
3D geometry.

1 From the Draw menu, choose Revolve.

OBJECT SIZE POSITION 

WIDTH HEIGHT BASE X Y

R1 20e-6 28e-6 Corner 0 -4e-6
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2 In the resulting dialog box, enter settings as in the following figure.

Settings for the Revolve operation.

3 Click OK. The revolved object automatically becomes activated in Geom1.

4 Click the Array button on the Draw toolbar.

5 In the dialog box that appears, specify the following settings, then click OK.

6 Click the Create Composite Object button on the Draw toolbar.

7 In the Set formula edit field, type BLK2-REV1-REV2-REV3-REV4. Click Apply.

8 In the Set formula edit field, type BLK1*CO1. Click OK.

9 Click the Geom2 tab.

10 From the Draw menu, choose Extrude.

11 From the Objects to extrude list, select CO3. In the Distance edit field, type-96e-6. 
Click OK.

12 Click the Geom2 tab.

13 From the Draw menu, choose Work Plane Settings.

14 On the Quick page, click the y-z button, and in the corresponding x edit field type 
24e-6. Click OK.

15 From the Draw menu, choose Extrude.

DISPLACEMENT ARRAY SIZE

X Y Z X Y Z

28e-6 0 -28e-6 2 1 2
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16 In the dialog box that appears, set the Distance to 216e-6. Click OK.

The following figure shows the 3D geometry when you have executed this step.

3D geometry after an extrusion operation on one of the arms.

17 Click the Geom2 tab.

18 From the Draw menu, choose Work Plane Settings.

19 On the Quick page, click the x-y button. In the associated z edit field, type -4e-6. 
Click OK.

20 From the Draw menu choose Extrude. Set the Distance to -196e-6, then click OK.

21 Click the Geom2 tab.

22 From the Draw menu, choose Work Plane Settings.

23 On the Quick page, click the x-y button. In the associated z edit field type 24e-6. 
Click OK.

24 From the Draw menu, choose Extrude. Set the Distance to 96e-6, then click OK.

The completed geometry should look like that in the following figure.
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The completed 3D geometry after extrusion of all four arms. 

P H Y S I C S  S E T T I N G S — T H E  F O C U S I N G  S T A G E

Subdomain Settings
1 From the Multiphysics menu, choose 1 Geom1: Incompressible Navier-Stokes (chns).

2 From the Physics menu, choose Subdomain Settings. 

3 In the Subdomain selection list, select all the subdomains. 

4 Enter the settings from the following table. When done, click OK.

5 From the Multiphysics menu, choose 2 Geom1: Conductive Media DC (dc).

6 From the Physics menu, choose Subdomain Settings. 

7 For all subdomains, set σ to sigma. Click OK.

8 From the Multiphysics menu, choose 3 Geom1: Electrokinetic Flow (chekf).

9 From the Physics menu, choose Subdomain Settings.

PROPERTY VALUE

 ρ rho

 η eta
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10 With all subdomains still selected, enter the settings in the following table; when 
done, click OK.

Boundary Conditions
1 From the Multiphysics menu, choose 1 Geom1: Incompressible Navier-Stokes (chns).

2 From the Physics menu, choose Boundary Settings.

3 Specify the following boundary conditions (for boundaries not listed in the table, 
the default No slip condition applies); when done, click OK.

4 From the Multiphysics menu, choose 2 Geom1: Conductive Media DC (dc).

5 From the Physics menu, choose Boundary Settings.

6 Click in the Boundary selection list and press Ctrl+A to select all boundaries. From 
the Boundary condition list, select Electric insulation.

PROPERTY VALUE

D (isotropic) D

R 0

um nu

z -1

u u

v v

w w

V V

SETTINGS BOUNDARY 1 BOUNDARIES 21, 26 BOUNDARY 54

Boundary type Inlet Inlet Outlet

Boundary condition Laminar inflow Laminar inflow Pressure, no 
viscous stress

U0 u_a w_a

Lentr 1e-4 1e-4

Constrain outer edges 
to zero

Yes Yes

p0 0
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7 Edit the boundary conditions according to the following table; when done, click OK.

8 From the Multiphysics menu, choose 3 Geom1: Electrokinetic Flow (chekf).

9 From the Physics menu, choose Boundary Settings.

10 Specify boundary settings as in the following table (for boundaries not listed, the 
default Insulation/Symmetry condition applies); when done, click OK.

M E S H  G E N E R A T I O N

1 Click Geom1 to activate the 3D geometry.

2 Click the Initialize Mesh button on the Main toolbar.

C O M P U T I N G  T H E  S O L U T I O N — T H E  F O C U S I N G  S T A G E

First, compute the solution for the velocity field, and then use that solution when 
solving the mass-transport problem.

1 Click the Solver Manager button on the Main toolbar.

2 Click the Solve For tab.

3 From the Solve for variables tree, select Geom1 (3D)>Incompressible Navier-Stokes 

(chns).

4 Click the Solve button.

5 When the solver has finished, click the Initial Value tab.

6 Click the Current solution option button in the Initial value area, then return to the 
Solve For page.

7 From the Solve for variables tree, select Geom1 (3D)>Conductive Media DC (dc).

8 Click Solve 

9 From the Solve for variables tree, select Geom1 (3D)>Electrokinetic Flow (chekf).

10 Click Solve.

11 On the Initial Value page, click the Store Solution button.

SETTINGS BOUNDARY 1 BOUNDARY 54

Boundary condition Electric potential Ground

V0 -1 -

SETTINGS BOUNDARY 1 BOUNDARIES 21, 26 BOUNDARY 54

Boundary condition Concentration Concentration Convective flux

c0 c_in 0 -
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12 Click OK to close the Solver Manager.

P H Y S I C S  S E T T I N G S — I N J E C T I O N  S T A G E ,  M O D E  A

Subdomain Settings
1 From the Multiphysics menu, choose 3 Geom1: Electrokinetic Flow (chekf).

2 From the Physics menu, choose Subdomain Settings.

3 In the Subdomain selection list, select all the subdomains, then change the settings 
for velocity parameters as in the following table; when done, click OK.

Boundary Conditions
1 From the Physics menu, choose Boundary Settings.

2 Select Boundaries 1, 21, 26, and 54 (the inlets and outlets).

3 From the Boundary condition list, select Flux.

4 In the N0 edit field, type -nmflux_c_chekf.

The predefined boundary variable nmflux_c_chekf gives the outward normal 
electrophoretic flux, Ni · n.

5 Click OK.

6 From the Multiphysics menu, choose 2 Geom1: Conductive Media DC (dc).

7 From the Physics menu, choose Boundary Settings.

8 Change the boundary settings as in the following table; when done, click OK.

C O M P U T I N G  T H E  S O L U T I O N — I N J E C T I O N  S T A G E ,  M O D E  A

1 Click the Solver Manager button on the Main toolbar.

2 Click the Script tab. Select the Automatically add commands when solving check box.

This setting instructs the software to record the subsequent solver settings and 
commands, which you can then reuse when solving Mode B.

PROPERTY VALUE

u 0

v 0

w 0

SETTINGS BOUNDARIES 1, 54 BOUNDARY 21 BOUNDARY 26

Boundary condition Electric insulation Electric potential Electric potential

V0 - 0 -3.2
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3 Click the Initial Value tab. In the Initial value area, click the Stored solution option 
button. This makes the steady-state solution from the focusing stage the initial 
solution.

4 Click the Solve For tab.

5 In the Solve for variables tree, select Geom1 (3D)>Conductive Media DC (dc).

6 Click Solve.

7 Click the Solver Parameters button on the Main toolbar.

8 From the Analysis list, select Transient.

9 In the Time stepping area go to the Times edit field and enter 0:0.03:0.6.

10 Click OK.

11 Activate the Solver Manager window.

12 Click the Initial Value tab.

13 In the Initial value area, click the Current solution option button.

14 Click the Solve For tab.

15 In the Solve for variables tree, select Geom1 (3D)>Electrokinetic Flow (chekf).

16 Click Solve.

17 Click OK.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N — I N J E C T I O N  S T A G E ,  M O D E  A

Reproduce the plot in Figure 7-24 on page 371 with the following steps:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, select the Subdomain and Geometry edges check boxes in the 
Plot type area and clear all the others.

3 From the Solution at time list, select 0.

4 Click the Subdomain tab. From the Predefined quantities list on the Color Data page, 
select Electrokinetic Flow (chekf)>Concentration, c. Click Apply.

5 Click the Go to Default 3D View button on the Camera toolbar, then click the Zoom 

Extents button on the Main toolbar.

To visualize the solution at two later times, as in the left panels of Figure 7-25 and 
Figure 7-26 on page 372, do as follows:

6 Return to the Subdomain page of the Plot Parameters dialog box.

7 Clear the Color scale check box in the Element color area.
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8 Click the General tab. From the Solution at time list, select 0.06. Click Apply to 
generate the plot in the left panel.

9 From the Solution at time list, select 0.12. Click OK to generate the plot in the left 
panel.

To make an animation of the solution, click the Animate button on the Plot toolbar. 
On the Animate page of the Plot Parameters dialog box, you can customize the 
movie settings.

Generate the upper plot of Figure 7-27, by executing the following instructions:

1 From the Postprocessing menu, choose Cross-Section Plot Parameters.

2 On the General page, select Interpolated times from the Select via list.

3 In the Times edit field, type 0:0.06:0.6.

4 Click the Line/Extrusion tab.

5 In the Predefined quantities list, select Electrokinetic Flow (chekf)>Concentration, c.

6 In the x-axis data area, click the option button next to the Expression button and 
then click Expression.

7 In the Expression edit field, type 10[um]-z. Click OK.

8 In the Cross-section line data area, enter the settings listed in the following table; 
when done, click OK.

P H Y S I C S  S E T T I N G S — I N J E C T I O N  S T A G E ,  M O D E  B

Boundary Conditions
1 From the Physics menu, choose Boundary Settings.

2 Change the boundary settings for the Conductive Media DC application mode to 
those in the following table:

CROSS-SECTION LINE DATA

x0 1e-5 x1 1e-5

y0 1e-5 y1 1e-5

z0 2e-5 z1 -2e-4

Line resolution 200

SETTINGS BOUNDARY 1 BOUNDARIES 21, 54 BOUNDARY 26

Boundary condition Electric potential Electric potential Electric potential

V0 -1 0 -3.2
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3 Click OK.

C O M P U T I N G  T H E  S O L U T I O N — I N J E C T I O N  S T A G E ,  M O D E  B

1 Click the Solver Manager button on the Main toolbar.

2 On the Script page, select the Solve using a script check box.

3 Click Solve to execute the script you see in the edit window.

4 Click OK to close the Solver Manager.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N — I N J E C T I O N  S T A G E ,  M O D E  B

Generate the plots in the right panels of Figure 7-25 and Figure 7-26 on page 372 as 
follows:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, select 0.06 from the Solution at time list. Click Apply.

This generates the right plot in Figure 7-25.

3 Repeat Step 2 but select 0.12 from the Solution at time list to generate the right plot 
in Figure 7-26.

4 From the Solution at time list, select 0.

5 Click OK to close the dialog box and generate the plot you see when you open the 
model from the Model Library.
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Finally, generate the lower plot in Figure 7-27 with the following steps:

1 From the Postprocessing menu, select Cross-Section Plot Parameters.

2 Accept the settings from Mode A by clicking OK.
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E l e c t r o o smo t i c  F l ow i n  Po r ou s  Med i a

Introduction

This example treats the modeling of electroosmotic flow in porous media (Refs. 1, 2). 
The system consists of a compartment of sintered porous material and two electrodes 
that generate an electric field. The cell combines pressure-driven and electroosmotic 
flow.

The purpose of this model is to illustrate the modeling of electroosmosis and 
electrophoresis in porous media in COMSOL Multiphysics.

Model Definition

Figure 7-28 shows the system’s geometry. It is made up of a domain of porous material 
containing the electrolyte and two electrodes that generate a potential difference. The 
conductivity is very small, and the model assumes that the effects of electrochemical 
reactions at the electrode surfaces are negligible.

Figure 7-28: The modeled domain consists of an electrolyte contained in a porous structure 
and two electrodes that generate an electric field.

In the first part of the model, you solve the continuity equations for the flow velocity 
and the current density at steady state:

 (7-25)
∇ u 0=⋅
∇ i⋅ 0=
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Here u denotes the velocity (m/s) and i represents the current-density vector (A/m2). 
The velocity includes two driving forces—a pressure term and an electroosmotic term:

.  (7-26)

In this equation, εp denotes the porosity, r is the average radius of the pores (m), η 
gives the fluid’s dynamic viscosity (Pa·s), τ represents the tortuosity of the porous 
structure, εw is the fluid’s permittivity (F/m),  p gives the pressure (Pa), ζ is the zeta 
potential (V), and V equals the potential (V). The current density is given by

 (7-27)

where κ denotes the conductivity (S/m).

At the solid walls, the normal velocity component vanishes:

.  (7-28)

At the inlet and the outlet, the pressure is fixed:

 (7-29)

and

 (7-30)

The conditions for the current-density balance are insulating for all boundaries except 
the electrode surfaces. This is expressed as

 (7-31)

In the second model stage, you use the steady-state velocity and potential fields in a 
transient simulation of the concentration of a charged tracer species injected into the 
system, assuming that the tracer species does not influence the conductivity or the set 
potential in the porous structure. The-mass transport equation for the tracer reads

 (7-32)

where N is the flux vector given by the Nernst-Planck equation

u
εpr2

8ητ
----------- p

εpεwζ
ητ

--------------- V∇+∇–=

i κ V∇–=

u n⋅ 0=

p p1= inlet

p p0= outlet

i n⋅ 0       = all boundaries except the electrodes
V V1= anode surface

V 0= cathode surface

t∂
∂c ∇ N⋅+ 0=
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.  (7-33)

In this equation, D denotes the tracer’s diffusivity (m2/s), c gives its concentration 
(mol/m3), z represents the tracer’s charge number, and F is Faraday’s constant (C/
mol). The mobility, um (mol·m2/(J·s)), is given by the Nernst-Einstein equation

 (7-34)

where Rg = 8.314 J/(mol·K) is the gas constant and T (K) is the temperature.

The boundary conditions for the mass-transport equation Equation 7-32 are 
insulating, except for at the inlet and the outlet. There you use the Flux condition to 
set the diffusive and convective contributions to the flux through the boundaries to 
zero:

 (7-35)

The initial concentration is given by a distribution that is uniform in the  y direction 
and bell-shaped in the x direction:

 (7-36)

Here  ctop denotes the peak concentration, xm is the position of the peak along the 
x-axis, and σ equals the base width of the peak.

Results

The upper plot in Figure 7-29 shows the flow distribution in the porous structure 
when only the pressure gradient acts as a driving force. In the lower plot, it is instead 
the electric field that drives the flow. In both cases, the velocity is large around the 
corners of the electrodes, where the field strength is large and the effect of the decrease 
in the geometry’s cross section is most pronounced. Note by comparing the maximum 
values for the color scales that the pressure gradient is the dominating driving force.

N D c zumFc V cu+∇–∇–=

um
D

RgT
-----------=

n D c∇– cu+( )⋅ 0=       (inlet and outlet)
n N⋅ 0=               (all other boundaries)

c t=0( ) ctop 0.5
x xm–( )

σ
---------------------⎝ ⎠
⎛ ⎞

2
–⎝ ⎠
⎛ ⎞exp=
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Figure 7-29: Velocity distributions in the cell with an applied pressure difference (top) and 
an applied electric field (bottom). The scale unit for the magnitude surface plot is m/s.
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Figure 7-30 shows the concentration field in the case where both pressure and 
electroosmotic forces are included. The figure shows that the migration of the charged 
tracer also influences the transport rate. In this case, the tracer is transported both by 
the movement of the flow, due to pressure and electroosmotic terms, and the 
electrophoretic effect on the charged tracer itself. At t = 0, the tracer is introduced as 
a bell-shaped vertical distribution near the inlet. In the subsequent simulation, this 
distribution is sheared and transported by diffusion, migration, and convection.

Figure 7-30: Concentration distribution in the domain at different times after injection. 
The effects of diffusion, convection, and migration deform the initial bell-shaped pulse.

Figure 7-31 shows the cross sections of the pulse along a line at y = 2.5 mm for the 
times t = 0, 0.5 s, 1.0 s, 1.5 s, and t = 2.0 s. Diffusion smears out the pulse, while 

t=0s t=0.6s

t=1.2s t=1.8s
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migration and convection mainly translate and shear it depending on the pressure and 
the electric field.

Figure 7-31: Cross-section plot of the concentration along a horizontal line at y = 2.5 mm 
for the times t = 0, 0.5 s, 1.0 s, 1.5 s, and 2.0 s.

Despite its geometrical simplicity, this model includes the components needed to 
model complex-shaped domains.
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Modeling in COMSOL Multiphysics

The COMSOL Multiphysics implementation is straightforward, and the only aspect to 
remember is to solve the steady-state problem first and then the time-dependent 
problem. Do this by following these steps:

1 Solve the nonlinear steady-state problem for the flow and current balances.

2 Store the solution.

3 Change the solver settings to transient.

4 Solve the problem only for the concentration, using the stored solution for the 
pressure and potential fields.

Model Library path:  

Chemical_Engineering_Module/Microfluidics/electroosmotic_flow

Modeling Using the Graphical User Interface

1 Open the Model Navigator.

2 On the New page set the Space dimension to 2D.

3 In the list of application modes select 
Chemical Engineering Module>Mass Transport>Electrokinetic Flow>Transient analysis.

4 Click the Multiphysics button, then click Add.

5 In the list of application modes select 
COMSOL Multiphysics>PDE Modes>PDE, General Form.

6 Click Add.

7 In the Dependent variables edit field, type p V.

8 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Axes/Grid Settings.
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2 Enter axis and grid settings as in the following table; on the Grid page clear the Auto 
check box.

3 Click OK.

4 From the Options menu, select Constants.

5 Define the following constants; when done, click OK.

You need also three expression variables for the model.

6 From the Options menu, select Expressions/Scalar Expressions.

AXIS GRID

x min -5e-3 x spacing 0.5e-3

x max 5e-3 Extra x -1.9e-3, -1.8e-3

y min -1e-3 y spacing 0.5e-3

y max 4e-1 Extra y 1.5e-3, 1.6e-3

NAME EXPRESSION DESCRIPTION

eps_p 0.6 Porosity

a 10[um] Average pore radius

eta 1e-3[Pa*s] Dynamic viscosity

eps_w 80.2*8.854[pF/m] Electric permittivity

zeta -0.1[V] Zeta potential

p1 0.01*1.013e5[Pa] Inlet pressure

k_p eps_p*a^2/(8*eta) Prefactor, flow-velocity 
pressure term

k_V eps_p*eps_w*zeta/eta Prefactor, flow-velocity 
electroosmotic term

kappa 3.5e-4[S/m] Electric conductivity

V1 50[V] Anode potential

sigma 0.2[mm] Concentration-profile peak 
width

x_m 3[mm] Concentration-profile peak 
position

D 1e-9[m^2/s] Diffusion coefficient

Rg 8.314[J/(mol*K)] Gas constant

T 298[K] Temperature

nu D/(Rg*T) Tracer ion mobility

z 1 Tracer ion charge number
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7 Enter the expressions from this table; when done, click OK.

G E O M E T R Y  M O D E L I N G

1 Click the Rectangle/Square button on the Draw toolbar.

2 Draw a rectangle with its lower left corner at (-4e-3, 0) and its upper right corner 
at (4e-3, 3e-3).

3 Select the Line tool by clicking the Line button on the Draw toolbar.

4 Draw a line from (-2e-3, 0) to (-2e-3, 1.5e-3) by clicking at these positions.

5 Click the 2nd Degree Bézier button on the Draw toolbar.

6 Click at the positions (-2e-3, 1.6e-3), (-1.9e-3, 1.6e-3), (-1.8e-3, 1.6e-3), and  
(-1.8e-3, 1.5e-3).

7 Click the Line button and click at (-1.8e-3, 0).

8 Close the geometry by clicking anywhere with the right mouse button.

9 Click the Array button on the Draw toolbar.

10 Set the x displacement to 3.8e-3 and the Array size x to 2.

11 Click OK.

12 Click the Create Composite Objects button on the Draw toolbar.

13 In the Set formula edit field, type R1-CO1-CO2.

14 Finish the geometry by clicking OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings—Electrokinetic Flow
1 From the Multiphysics menu, select 1 Electrokinetic Flow (chekf).

2 From the Physics menu, open the Subdomain Settings dialog box.

3 Select Subdomain 1. On the c page, enter the following settings:

NAME EXPRESSION DESCRIPTION

u_flow -k_p*px+k_V*Vx Flow velocity, x-component

v_flow -k_p*py+k_V*Vy Flow velocity, y-component

c_init 1[mmol/m^3]*exp(-0.5* 
((x-x_m)/sigma)^2)

Initial concentration 
distribution

PROPERTY VALUE

D (isotropic) D

R 0
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4 Click the Init tab. In the c(t0) edit field, type c_init.

5 Click OK.

Boundary Conditions—Electrokinetic Flow
1 From the Physics menu, open the Boundary Settings dialog box.

2 Select Boundaries 1 and 10. From the Boundary condition list, select Flux. In the N0 
edit field, enter the inward-flux expression -nmflux_c_chekf. (The predefined 
variable nmflux_c_chekf gives the outward normal electrophoretic flux.)

For the remaining boundaries, the default Insulation/Symmetry condition applies.

3 Thus, click OK to confirm the settings and close the dialog box.

Subdomain Settings—PDE, General Form
1 From the Multiphysics menu, select 2 PDE, General Form (g).

2 From the Physics menu, select Subdomain Settings.

3 On the Γ page, enter the following components:

The first and second rows define the left-hand sides of the first and second of the 
Equations 7-25, respectively.

4 On the F page, set both source terms to 0.

5 Click OK.

Boundary Conditions—PDE, General Form
1 From the Physics menu, select Boundary Settings.

um nu

z z

u u_flow

v v_flow

V V

u_flow v_flow

-kappa*Vx -kappa*Vy

PROPERTY VALUE
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2 Enter the boundary conditions according to the following table. The G coefficients 
defining the normal derivatives at the boundaries consistently take the default value 
zero, and you therefore do not need to set them.

3 Click OK.

M E S H  G E N E R AT I O N

1 From the Mesh menu, select Free Mesh Parameters.

2 Click the Custom mesh size button.

3 Set the Maximum element size to 1e-4.

4 Click Remesh to generate the mesh. When the mesher has finished, click OK.

The meshed geometry.

SETTINGS BOUNDARIES 2, 
3, 6, 9

BOUNDARIES 4, 
5, 11, 12

BOUNDARIES 7, 
8, 13, 14

BOUNDARY 1 BOUNDARY 10

Type Neumann Dirichlet Dirichlet Dirichlet Dirichlet

R - 0

-V

0

-V+V1

-p

0

-p+p1

0
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C O M P U T I N G  T H E  S O L U T I O N

First solve for the two stationary fields: the pressure,  p, and the potential, V.

1 Click the Solver Parameters button on the Main toolbar.

2 From the Analysis list, select Stationary, then click Apply.

3 Click the Solver Manager button on the Main toolbar.

4 Click the Solve For tab.

5 From the Solve for variables list, select PDE, General Form (g).

6 Click the Solve button to compute the solutions for p and V. The software uses the 
initial-value expression you specified earlier as the initial solution for c, which you 
do not solve for in this step.

When the solver has finished, turn to the transient problem for the concentration, c.

7 Still on the Solve For page in the Solver Manager, select Electrokinetic Flow (chekf) 
from the Solve for variables list.

8 Click the Initial Value tab. 

9 Click the Store Solution button, then click the Stored solution option button in the 
Values of variables not solved for and linearization point area. With this setting, the p 
and V fields that you just computed serve as a stationary background when you solve 
for c.

10 Click OK to close the Solver Manager.

11 Return to the Solver Parameters dialog box.

12 From the Analysis list, select Transient.

13 In the Times edit field, type 0:0.1:2. Set the Absolute tolerance to 1e-8. 

14 Click OK.

15 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To create the upper part of Figure 7-29 follow these steps:

1 From the Postprocessing menu, open the Plot Parameters dialog box.

2 Click the Surface tab and make sure the Surface plot check box is selected.

3 On the Surface Data page, type sqrt((k_V*Vx)^2+(k_V*Vy)^2) in the Expression 
edit field.

4 Click the Arrow tab and select the Arrow plot check box.
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5 On the Subdomain Data page, enter the following settings:

6 Click Apply to generate the upper plot in Figure 7-29.

7 Change the arrow x component and y component to -k_p*px and -k_p*py, 
respectively.

8 Go to the Surface page and replace the Expression on the Surface Data page with 
sqrt((k_p*px)^2+(k_p*py)^2).

9 Click Apply to generate the lower plot.

Generate the plots in Figure 7-30 by proceeding with the following instructions:

10 Still on the Surface page, select Electrokinetic Flow (chekf)>Concentration, c from the 
Predefined quantities list (or type c in the Expression edit field).

11 Edit the Unit expression to read mmol/m^3 (that is, millimoles/cubic meter).

12 Click the Range button. In the Color Range dialog box, clear the Auto check box.

13 Set the Min and Max values to -1 and 1, respectively, then click OK. 

Note that these max and min values refer to the current plot unit, for which the 
concentration lies between 0 and 1 (neglecting the numerical error in the solution). 
Using a symmetric interval around zero gives brighter-colored surface plots at the 
price of using only half the color scale.

14 On the General page, clear the Arrow check box in the Plot type area.

15 Clear the Auto check box for Element refinement, then type 5 in the associated edit 
field.

16 Select 0 from the Solution to use list, then click Apply to generate the upper left plot.

17 Repeat the previous step using different selections from the Solution at time list to 
generate the other plots in Figure 7-30.

18 When finished, click OK or Cancel to close the Plot Parameters dialog box.

By clicking the Animate button on the Plot toolbar you can also generate a movie of 
the simulation.

Generate the plots in Figure 7-31 using the cross-section plot functionality:

1 From the Postprocessing menu, select Cross-Section Plot Parameters.

2 From the Solutions at time list, select 0, 0.5, 1, 1.5, and 2.0.

3 Click the Line/Extrusion tab.

x component k_V*Vx

y component k_V*Vy
E L E C T R O O S M O T I C  F L O W  I N  P O R O U S  M E D I A  |  401



402 |  C H A P T E
4 In the y-axis data area, verify that Concentration, c is selected from the 
Predefined quantities list.

5 In the x-axis data area, click the lower option button and then the Expression button.

6 In the X-Axis Data dialog box, select Geometry and Mesh>x-coordinate from the 
Predefined quantities list (or type x in the Expression edit field). 

7 From the Unit list, select mm, then click OK to close the X-Axis Data dialog box.

8 Set cross-section line data according to this table:

9 Click the Line Settings button. From the Line marker list, select Cycle.

10 Select the Legend check box, then click OK to close the Line Settings dialog box.

11 Click OK to generate the plot in Figure 7-31.

x0 -4e-3

x1 4e-3

y0 2.5e-3

y1 2.5e-3
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Introduction

This example was originally formulated by Albert Witarsa under Professor Bruce 
Finlayson’s supervision at the University of Washington in Seattle. It was part of a 
graduate course in which the assignment consisted of using mathematical modeling to 
evaluate the potential of patents in the field of microfluidics.

This model treats a so-called H-microcell for separation through diffusion. The cell 
puts two different laminar streams in contact for a controlled period of time. The 
contact surface is well defined, and by controlling the flow rate it is possible to control 
the amount of species transported from one stream to the other through diffusion.

Figure 7-32: Diagram of the H-microcell.
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Model Definition

The geometry of the microcell (Figure 7-33) is taken from Albert Witarsa’s and 
Professor Finlayson’s assignment. The cell geometry is divided in half because of 
symmetry. The design aims to avoid upsets in the flow field when the two streams, A 
and B, are united. This is to avoid the two streams mixing through convection, which 
would mix all species equally and lead to loss of control over the separation abilities. 
The transport of species between streams A and B should take place only by diffusion 
in order that species with low diffusion coefficients stay in their respective streams.

Figure 7-33: Model geometry. To avoid any type of convective mixing, the design must 
smoothly let both streams come in contact with each other. Due to symmetry, it is sufficient 
to model half the geometry.

The simulations involve solving the fluid flow in the H-cell. According to the 
specifications, the flow rate at the inlet is roughly 0.1 mm/s. This implies a low 
Reynolds number, well inside the region of laminar flow:

 (7-37)

Equation 7-37 gives a Reynolds number of 0.001 for a water solution and the channel 
dimensions given in Figure 7-33, a value typical for microchannels. Thus it is easy to 
get a numerical solution of the full momentum balance and continuity equations for 
incompressible flow with a reasonable number of elements. The equations that you 
need to solve are the Navier-Stokes equations at steady state:

 (7-38)

Here ρ denotes density (kg/m3), u is the velocity (m/s), η denotes viscosity (Pa·s), 
and p equals pressure (Pa). 

Re dρu
η

-----------=
1·10 5– 1·103 1·10 4–⋅ ⋅

1·10 3–
---------------------------------------------------------=

∇ η ∇u ∇u( )T
+( )⋅– ρ u ∇⋅( )u ∇p+ + 0=

∇ u⋅ 0=
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Separation in the H-cell involves species in relatively low concentrations compared to 
the solvent, in this case water. This means that the solute molecules interact only with 
water molecules, and it is safe to use Fick’s law to describe the diffusive transport in 
the cell. This mass-balance equation for a solute appears in the Convection and 
Diffusion application mode and reads

.  (7-39)

In this equation, D denotes the diffusion coefficient (m2/s) and c represents the 
concentration (mol/m3). In this model, you use the parametric solver to solve 
Equation 7-39 for three different values of D—1·10−11 m2/s, 5·10−11 m2/s, and 
1·10−10 m2/s— to simulate the mixing of different species.

You solve two versions of the model:

• In the first version, you assume that a change in solute concentration does not 
influence the fluid’s density and viscosity. This implies that it is possible to first solve 
the Navier-Stokes equations and then solve the mass balance equation.

• In the second version, you include a correction term in the viscosity that dependes 
quadratically on the concentration:

.  (7-40)

Here α is a constant of dimension (concentration)−2. An influence of concentration 
on viscosity of this kind is usually observed in solutions of larger molecules.

Next, consider the boundary conditions, starting with the Navier-Stokes equations. 
For the relevant boundary groupings, refer to Figure 7-34.

Figure 7-34: Model domain boundaries.

∇ D∇– c cu+( )⋅– 0=

η η0 1 αc2
+( )=

Outlet

Outlet

Symmetry plane

Inlet A

Inlet B

Wall
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At the inlets and outlets, Pressure conditions apply along with vanishing viscous stress:

 (7-41)

Setting the pressure at the outlets to zero, the pressure at the inlets represents the 
pressure drop over the cell. These inlet and outlet conditions comply with the H-cell 
being a part of a channel system of constant width, which justifies the assumption of 
developed flow.

At the symmetry plane, choosing the boundary type Symmetry  boundary sets the 
velocity component in the normal direction of the surface to zero:

 (7-42)

At the walls, No slip conditions state that the velocity is zero:

 (7-43)

For the mass balances, the assumption that solute molecules interact only with water 
molecules implies that it is sufficient to consider a single species A of concentration c. 
At the inlets, use the Concentration  boundary condition with the following values:

 (7-44)

Model the symmetry plane and cell walls with the Insulation/Symmetry condition:

 (7-45)

This equation states that the flux of species perpendicular to the boundary equals zero. 
At the outlets, the Convective flux  condition applies, stating that the diffusive 
transport perpendicular to the boundary normal is negligible:

 (7-46)

This condition eliminates concentration gradients in the flow direction.

p p0=

n η u u∇( )T
+∇( )⋅ 0=

n u⋅ 0=

t η u u∇( )T
+∇( )n⋅ 0=

u v w, ,( ) 0 0 0, ,( )      at the walls=

c c0     at inlet A=

c 0       at inlet B=

D∇– c cu+( ) n⋅ 0=      at the symmetry plane and walls

D∇– c( ) n⋅ 0      at the outlets=
R  7 :  M I C R O F L U I D I C S



Results

Figure 7-35 shows the velocity field. The flow is symmetric and is not influenced by 
the concentration field.

Figure 7-35: Flow velocity field.

Figure 7-36 shows the concentration distribution for the lightest species in this study.

Figure 7-36: Concentration distribution for a species with diffusivity 1·10−10m2/s.
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Because of the relatively large diffusion coefficient, the degree of mixing is almost 
perfect for the lightest species. The species with a diffusion coefficient ten times smaller 
than that of the lightest species shows a different result.

Figure 7-37: Concentration distribution for a species with diffusivity 1·10−11m2/s.

The concentration distribution in Figure 7-37 indicates that the diffusion coefficient 
for the species is low enough to avoid any significant mixing between streams A and B. 
The simulation clearly shows that the H-cell can separate lighter molecules from 
heavier ones. A cascade of H-cells can achieve a very high degree of separation.

In some cases, especially those involving solutions of macromolecules, the 
macromolecule concentration has a large influence on the liquid’s viscosity. In such 
situations, the Navier-Stokes and the convection-diffusion become coupled, and they 
therefore must be solved simultaneously. Figure 7-38 shows the results of such a 
simulation, which you repeat in the second version of this model. You can see that 
changes in the concentration influence the flow field. It is clear from this plot that the 
velocity becomes asymmetric due to changes in viscosity. As a consequence of the 
modified flow field, the transport of molecules to the outlet B is also different from the 
result using a constant flow field. You can see the difference by comparing Figure 7-39 
with Figure 7-37 on page 408.
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Figure 7-38: Velocity field. The viscosity varies with the concentration according to η = 
η0(1+ α c2) with α = 0.5 (m3/mol)2. The figure shows that the velocity field is affected by 
variations in concentration. Compare it to the velocity field in Figure 7-35.

Figure 7-39: Concentration distribution for the species with diffusivity 1·10−11m2/s for 
the case where the fluid viscosity varies with concentration. Comparison with the plot in 
Figure 7-37 shows that fewer molecules of the species are transported to outlet B.
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Model Library path: Chemical_Engineering_Module/Microfluidics/h_cell

Modeling Using the Graphical User Interface

1 Start COMSOL Multiphysics.

2 On the New page, set the Space dimension to 3D.

3 From the list of application modes, select 
Chemical Engineering Module>Momentum Transport>Laminar Flow> 
Incompressible Navier-Stokes.

4 Click the Multiphysics button, then click Add.

5 From the list of application modes, select 
Chemical Engineering Module>Mass Transport>Convection and Diffusion.

6 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

2 Enter the following variable names, expressions, and (optionally) descriptions in the 
Constants dialog box; when done, click OK.

G E O M E T R Y  M O D E L I N G

1 From the Draw menu, select Work-Plane Settings.

2 Use the default Quick work plane (the xy-plane at z = 0) by clicking OK.

3 From the Options menu, open the Axes/Grid settings.

NAME EXPRESSION DESCRIPTION

rho 1e3[kg/m^3] Density

eta 1e-3[Pa*s] Viscosity

D 1e-10[m^2/s] Diffusion constant

p0 2[Pa] Pressure drop

c0 1[mol/m^3] Inlet concentration

alpha 0.5[(m^3/mol)^2] Viscosity c^2-term prefactor
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4 On the Axis page, enter the following settings:

5 On the Grid page, clear the Auto check box and set both the x spacing and the 
y spacing to 1. Click OK.

6 Click the Line button on the Draw toolbar, then click the points with the x- and 
y-coordinates at (0, 6) and (0, 2).

7 Select the 2nd Degree Bezier Curve tool on the Draw toolbar and click at the 
coordinate pairs (0, 0) and (2, 0).

8 Select the Line tool and click at the coordinates (12, 0).

9 Select the 2nd Degree Bezier Curve tool and click at the coordinates (14, 0) and  
(14, 2).

10 Select the Line tool and click at the coordinates (14, 6). Continue by clicking at the 
coordinates (13, 6) and (13, 2).

11 Select the 2nd Degree Bezier Curve tool and click at the coordinates (13, 1) and (12, 
1).

12 Select the Line tool and click at the coordinates (2, 1).

13 Select the 2nd Degree Bezier Curve tool and click at the coordinates (1, 1) and (1, 2).

14 Select the Line tool and click at the coordinates (1, 6).

15 Click the right mouse button to close the set of lines and create a solid object, CO1.

You have now created half of the 2D cross section and can use copy, paste, and rotate 
operations to create the other half.

1 Click first the Copy button and then the Paste button, both on the Main toolbar. Let 
the Displacements remain at 0 and click OK to create the composite object CO2.

2 Click the Scale button on the Draw toolbar. Change the y component of the Scale 
factor to -1 (leave the other parameters at their default values). 

3 Click OK to flip CO2 over the x-axis.

4 From the Edit menu, choose Select All. (Alternatively, press Ctrl+A.)

5 Click the Create Composite Object button on the Draw toolbar.

PROPERTY VALUE

x min -1

x max 15

y min -7

y max 7
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6 Clear the Keep interior boundaries check box. Click OK.

The cross section is now finished and you can extrude it to the full 3D geometry.

7 Select Extrude from the Draw menu. Let the Distance remain equal to 1. Click OK.

The final geometry-modeling step is to scale the geometry to the correct scale.

8 Click the Scale button on the Draw toolbar.

9 Type 1e-5 in all three Scale factor edit fields. Click OK.

10 Click the Zoom Extents button on the Main toolbar.

You do not need the 2D workplane any more, so you can remove it from the model:

1 From the Multiphysics menu, choose Model Navigator.

2 In the Multiphysics area to the right, select Geom2 (2D) and then click Remove.

3 Click OK to close the Model Navigator.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Multiphysics menu, select 1 Incompressible Navier-Stokes (chns).

2 From the Physics menu, select Subdomain Settings.

3 Select Subdomain 1, then specify the settings in this table; when done, click OK.

4 From the Multiphysics menu, select 2 Convection and Diffusion (chcd).

5 From the Physics menu, select Subdomain Settings.

6 Select Subdomain 1.

7 Specify the following settings:

8 Click OK to confirm the settings and close the dialog box.

PROPERTY VALUE

 ρ rho

 η eta

PROPERTY VALUE

D (isotropic) D

u u

v v

w w
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Boundary Conditions
1 From the Multiphysics menu, select 1 Incompressible Navier-Stokes (chns).

2 From the Physics menu, select Boundary Settings.

3 Specify boundary conditions as in the following table; when done, click OK.

4 From the Multiphysics menu, select 2 Convection and Diffusion (chcd).

5 From the Physics menu, select Boundary Settings.

6 Specify the boundary conditions in the following table; when done, click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters.

2 From the Predefined mesh sizes list, select Extra fine.

3 Click the Remesh button.

4 When the mesher has finished, click OK.

C O M P U T I N G  T H E  S O L U T I O N

Start by first computing the solution for the velocity field and then use that solution 
for solving the mass transport problem.

1 Click the Solver Parameters button on the Main toolbar.

2 On the General page, select Direct (PARDISO) from the Linear system solver list.

3 Click OK.

4 Click the Solver Manager button on the Main toolbar.

5 On the Solve For page, select Incompressible Navier-Stokes (chns).

SETTINGS BOUNDARIES 2, 8 BOUNDARIES 20, 22 BOUNDARY 4 ALL OTHERS

Boundary 
type

Inlet Outlet Symmetry 
boundary

Wall

Boundary 
condition

Pressure, no 
viscous stress

Pressure, no 
viscous stress

No slip

p0 p0 0 - -

SETTINGS BOUNDARY 2 BOUNDARY 8 BOUNDARIES 20, 22 ALL OTHERS

Type Concentration Concentration Convective 
flux

Insulation/ 
Symmetry

c0 c0 0 - -
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6 On the Initial Value page, click the Initial value expression option button in the 
Initial value area.

7 Click OK.

8 Click the Solve button on the Main toolbar.

You have now computed the velocity field and can use that solution to make a 
parametric analysis for the mass transport problem with varying diffusivity.

1 Click the Solver Manager button on the Main toolbar.

2 On the Solve For page, select Convection and Diffusion (chcd).

3 Click the Initial Value tab, then click the Current solution option button in the 
Initial value area.

4 Click OK.

5 Click the Solver Parameters button on the Main toolbar.

6 From the Solver list, select Parametric.

7 In the Parameter name edit field, type D.

8 In the Parameter values edit field, type 1e-10 5e-11 1e-11.

9 Click OK.

10 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate Figure 7-35 follow these steps:

1 From the Postprocessing menu, open the Plot Parameters dialog box.

2 On the General page, select the Slice and Arrow check boxes in the Plot type area.

3 Clear the Element refinement Auto check box and type 5 in the associated edit field.

4 Click the Slice tab.

5 In the Predefined quantities list, select 
Incompressible Navier-Stokes (chns)>Velocity field.

6 From the Unit list, select mm/s.

7 In the Slice positioning area, set x levels to 5, y levels to 2, and z levels to 1.

8 Click the Arrow tab.

9 On the Subdomain Data page, verify that Velocity field is selected in the 
Predefined quantities list.
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10 In the Arrow positioning area, set the numbers of x points, y points, and z points to 
14, 21, and 3, respectively.

11 In the Arrow parameters area, click the Color button. Select the black swatch from 
the palette in the Arrow Color dialog box, then click OK.

12 Select 3D arrow from the Arrow type list.

13 Click Apply to generate the plot.

To generate Figure 7-36, continue with the following steps:

1 Clear the Arrow plot check box, then click the Slice tab.

2 From the Predefined quantities list, select 
Convection and Diffusion (chcd)>Concentration, c.

3 On the General page, select 1e-10 from the Parameter value list. Click OK.

Generate Figure 7-37 the same way as Figure 7-36, except use the parameter value 
1e-11.

P H Y S I C S  S E T T I N G S — S T U D Y  2

1 From the Multiphysics menu, select 1 Incompressible Navier-Stokes (chns).

2 From the Physics menu, select Subdomain Settings.

3 Change the viscosity expression to eta*(1+alpha*c^2). Click OK.

C O M P U T I N G  T H E  S O L U T I O N — S T U D Y  2

When the viscosity is concentration dependent you must solve all equations 
simultaneously.

1 Click the Solver Manager button on the Main toolbar.

2 On the Solve For page, select Geom1 (3D) from the Solve for variables list. Click OK.

3 Click the Solver Parameters button on the Main toolbar.

4 From the Solver list, select Stationary. Click OK.

5 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N — S T U D Y  2

Finally, generate Figure 7-38 and Figure 7-39 with the following steps:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, select the Arrow check box in the Plot type area.

3 Click the Slice tab.
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4 In the Predefined quantities list, select Incompressible Navier-Stokes (chns)> 
Velocity field.

5 In the Unit list, select mm/s, then click Apply to generate Figure 7-38.

6 In the Predefined quantities list, select 
Convection and Diffusion (chcd)>Concentration, c.

7 On the General page, clear the Arrow check box in the Plot type area.

8 Click OK to close the dialog box and generate Figure 7-39.
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T r a n s p o r t ,  R e a c t i o n s ,  a n d  R e a c t i o n  
E n g i n e e r i n g  
This chapter contains examples of mass transport coupled to transport of 
momentum and energy, where the systems are affected by chemical reaction 
kinetics. The Chemical Engineering Module is well suited for these types of 
processes for two reasons:

• Its ability to model multiphysics applications easily and quickly —often you need 
to model mass transport to a description of a fluid flow, both in free and porous 
media. Other models may also require energy transport. The reaction kinetics are 
often functions of concentration (mass transport), temperature (energy 
transport), and sometimes pressure (momentum transport). The multiphysics 
feature allows for all physical descriptions to be coupled and solved 
simultaneously.

• Its ability to handle equation-based modeling—chemical-kinetics equations can be 
convoluted and laborious to include. In COMSOL Multiphysics, however, you 
can quickly enter such equations. Furthermore, other material properties, such 
as diffusion coefficients and viscosity, can be functions of the dependent 
variables. It is also easy to account for such dependencies by directly entering the 
functions in the user interface.
 417
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F i x e d -B ed R e a c t o r  f o r  C a t a l y t i c  
H yd r o c a r b on Ox i d a t i o n

Introduction

This example treats the partial oxidation of o-xylene in air to phthalic anhydride (PA) 
in a multitube fixed-bed reactor—the dominating process for producing this important 
industrial chemical.

In this process, temperature is usually kept between 400–475 °C and the residence 
time varies between 0.5–5 seconds. The catalyst of choice is usually a mix of vanadium 
oxide and potassium sulfate on a silica support. The most important factor to consider 
for this process is the temperature inside the reactor. The reactions taking place in the 
reactor are highly exothermic, and the reactor needs to be cooled to avoid runaway 
conditions. The temperature distribution also affects phthalic anhydride yield. It is 
possible to control the temperature distribution by varying tube diameter, residence 
time, wall temperature (cooling rate), and the inlet temperature of the feed. This 
example covers some of these factors by creating a detailed model of the system using 
the 2D pseudo-homogeneous model as described in the literature (Ref. 3, and Ref. 4). 

Tubular reactors are usually modeled with the assumption that concentration and 
temperature gradients only occur in the axial direction. The only transport mechanism 
operating in this direction is the overall flow itself, which is considered to be of 
plug-flow type, that is, all the fluid elements are assumed to move with a uniform 
velocity along parallel streamlines. This example takes a more general approach by 
accounting for variations of the concentrations and the temperature in the axial 
direction. Through the use of effective diffusivities and conductivities, the model also 
includes the mixing in the axial direction that occurs in a reactor as a result of 
turbulence and the presence of packing.

Model Definition

Assume rotational symmetry to set up a 2D axisymmetric model.

The reaction kinetics of the rather complex process under study can, to a satisfactory 
degree, be described by the scheme in Figure 8-1 (References 1–4).
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Figure 8-1: Reaction paths. A represents o-xylene, B refers to phthalic anhydride, and C is 
the total amount of carbon monoxide and carbon dioxide.

Owing to a very high excess of oxygen, the reactions are pseudo-first-order. It follows 
that the reaction rates can be described by the equations

 (8-1)

where ρb is the catalyst bulk density (kg/m3), y0 is the mole fraction of oxygen, yA0 is 
the inlet mole fraction of o-xylene, xA is the total conversion of o-xylene, and xB is the 
conversion of o-xylene into phthalic anhydride (similarly, xC represents the total 
conversion into carbon monoxide and carbon dioxide). In the above equations, the 
conversions are dimensionless and the reaction rates have the SI unit mol/(m3·s).

The rate coefficients (mol/(kg catalyst·s) depend on temperature as described by the 
Arrhenius law

 (8-2)

where T is the reactor temperature, and Ai and Bi are characteristic parameters for each 
reaction (i = 1, 2, 3).

A schematic description of the reactor is given in Figure 8-2. The convective flow of 
gas takes place from the bottom to the top. Axisymmetry is assumed, which reduces 
the 3D geometry to two dimensions.

A 

B
(+O2)

k1

k2
C

k3

(+O2)

C

(+O2)

r1 ρb y0yA0k1 1 xA–( )=

r2 ρb y0yA0k2 xB=

r3 ρb y0yA0k3 1 xA–( )=

ki Ai
Bi–

T
---------⎝ ⎠
⎛ ⎞exp=
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Figure 8-2: Schematic representation of the reactor.

The design equations for this system—a mass transport equation and an energy 
transport equation—read (Ref. 3 and Ref. 4)

 (8-3)

Here us is the superficial velocity (m/s), ctot is the total concentration (mol/m3), ρg 
denotes the gas density (kg/m3), yA0 is the inlet mole fraction of o-xylene, λeff 
represents the bed’s effective thermal conductivity (W/(m·K)), and ∆Hi is the enthalpy 
of adsorption for reaction i. Because xA = xB + xC, it is only necessary to solve two mass 
transport equations, which results in the following design equations:

 (8-4)

The rate equations can be rewritten accordingly:

Radius R

z

r

Symmetry
axis

velocity=us
xA, xB, T

Tube wall with outside
coolant at T=Tw

∇ Deff xi us xi+∇–( )⋅ 1
ctot yA0
--------------------ri=

usρgCp∇ T⋅ ∇– λeff T∇( )⋅ ∆Hi–( )rii 1=

3
∑=

∇ Deff xB usxB+∇–( )⋅ 1
ctot yA0
--------------------rB=

∇ Deff xC usxC+∇–( )⋅ 1
ctot yA0
--------------------rC=

∇ λeff T′ usρgCpT′+∇–( )⋅ ρb ∆H1–( )rB ∆H3–( )rC+[ ]=
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 (8-5)

The boundary conditions for this system are as follows (see Figure 8-2 for the 
appropriate references):

 (8-6)

At the reactor inlet, the concentrations are zero and the temperature equals T0. At the 
outlet, assume that the convective parts of the mass transport and the heat transport 
dominate.

Results and Discussion

A temperature plot (Figure 8-3) shows a maximum not far from the reactor inlet.

Figure 8-3: Temperature distribution across the tubular half plane.

rB yA0 y0 ctot k1 1 xB– xC–( ) k2xB–[ ]=

rC yA0 y0 ctot k2xB k3 1 xB– xC–( )+[ ]=

r∂
∂xB 0 z,( )

r∂
∂xC 0 z,( ) 0     = = T∂

r∂
------- 0 z,( ) 0=

r∂
∂xB R z,( )

r∂
∂xC R z,( ) 0     = = λeff

T∂
r∂

------- R z,( ) α T T0–( )–=
F I X E D - B E D  R E A C T O R  F O R  C A T A L Y T I C  H Y D R O C A R B O N  O X I D A T I O N  |  421



422 |  C H A P T E
This so-called hotspot is a common phenomenon for systems with exothermic 
reactions to which cooling is applied. Also, note that the radial temperature gradients 
are quite large around this hotspot.

Figure 8-4 shows the composition in the reactor along the axial direction. The graphs 
give the bulk mean conversions for an inlet temperature of 627 K (354 °C). You can 
see from the middle line that the phthalic anhydride production rate falls off somewhat 
along the tube, which is a typical behavior for consecutive reactions.

Figure 8-4: Composition versus axial coordinate in the reactor.

In Figure 8-5, note that the radial temperature gradients are quite severe, as the 
temperature along the symmetry axis is well above the mean temperature. On the basis 
of this information you can draw the conclusion that a 1D model with axial mixing 
would not be good enough to describe this system.
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Figure 8-5: Temperature versus radial coordinate in the reactor (z=0.6 m) for a number 
of inlet of different inlet temperatures.

A parameter study of the inlet temperature gives the results displayed in Figure 8-6 for 
the average temperature along the reactor centerline. As this figure shows, the reactor’s 
inlet temperature affects the centerline temperature quite dramatically. A high 
temperature increases the production rate of phthalic anhydride, but it can also 
increase the production of carbon monoxide and carbon dioxide. Furthermore, too 
high a temperature might be detrimental to the catalyst, which means that good 
control of the reactor’s feed temperature is essential.
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Figure 8-6: Average temperature along the reactor centerline vs. axial coordinate for 
different inlet temperatures.

Although the results presented here describe the process running at steady-state, the 
model can be easily generalized to a time-dependent version for use in automatic 
control and start-up simulations.

Modeling in COMSOL Multiphysics

To make use of the unit-handling capabilities that COMSOL Multiphysics offers, use 
cB ≡ xB ctot and cC ≡ xC ctot as the basic dependent variables in place of the 
dimensionless conversions xB and xC. For the latter, as well as for xA = xB + xC, define 
scalar expressions to use for postprocessing. Furthermore, make the mean conversions 
over a circular cross section of the tube of area A = π R2,

,  (8-7)

available for postprocessing by defining corresponding projection coupling variables.

xα mean, z( ) 1
A
---- xα r z,( ) Ωd

Ω
∫

2

R2
------- xα r z,( ) r r,   αd

0

R

∫ A B C, ,= = =
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Model Library path: Chemical_Engineering_Module/
Transport_and_Reactions/fixed_bed_reactor

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics.

2 In the Model Navigator, click the Multiphysics button, and set the Space dimension list 
to Axial symmetry (2D). 

3 Select Chemical Engineering Module>Mass Transport>Convection and Diffusion from 
the Application Modes list. In the Dependent variables edit field type cB cC (space 
separated) and in the Application mode name edit field type massbal.

4 Click the Add button.

5 Select Chemical Engineering Module>Energy Transport>Convection and Conduction 
from the Application Modes list. Name the application mode energybal and leave 
the dependent variables to the default, T. Click Add.

6 Click OK to close the Model Navigator.
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G E O M E T R Y  M O D E L I N G

1 Click the Rectangle/Square button on the Draw toolbar and draw a rectangle of 
arbitrary dimension. Double-click on the rectangle and type the values listed below 
in the corresponding edit fields; when done, click OK.

2 Double-click the EQUAL button on the status bar at the bottom of the user interface 
to allow for different scales on the r- and z-axes.

3 Click the Zoom Extents button on the Main toolbar.

O P T I O N S  A N D  S E T T I N G S

Constants
1 In the Options>Constants dialog box, define the constants listed in the following 

table. You can either type them in or import them from a file included in the 
Chemical Engineering Module. To do the latter, click the Import Variables From File 
button, browse to the folder listed in the Model Library path on page 425, select 
the file fixed_bed_reactor_const.txt, and then click Open.

PROPERTY VALUE

Width 0.0127

Height 3

Base Corner

r 0

z 0

NAME EXPRESSION DESCRIPTION

R 1.27[cm] Tube radius

D_eff 3.19e-7[m^2/s] Effective diffusion constant

u_s 1.064[m/s] Superficial velocity

rho_b 1300[kg/m^3] Catalyst bulk density

k_eff 0.779[W/(m*K)] Effective thermal conductivity

C_p 1046[J/(kg*K)] Fluid heat capacity

rho_g 1.293[kg/m^3] Gas density

c_tot 44.85[mol/m^3] Total concentration

alpha 156[W/(m^2*K)] Heat transfer coefficient

T0 627[K] Inlet temperature

DeltaH1 -1.285[MJ/mol] Enthalpy of adsorption, reaction 1

DeltaH2 -3.276[MJ/mol] Enthalpy of adsorption, reaction 2
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2 Click OK.

Scalar Expressions
1 Define the following expressions in the Options>Expressions>Scalar Expressions 

dialog box, either by typing them in or by importing them from the file 
fixed_bed_reactor_expr.txt, which you find in the same directory as the 
constants text file.

2 Click OK.

Projection Coupling Variables
Next, define the mean conversions (see Equation 8-7) as projection coupling variables 
and make them available on the reactor centerline, which corresponds to Boundary 1. 
(For information on coupling variables in COMSOL Multiphysics, see the section 

DeltaH3 DeltaH1+DeltaH2 Enthalpy of adsorption, reaction 3

yA0 0.00924 Inlet mole fraction of o-xylene

y0 0.208 Mole fraction of oxygen

A1 1[kmol/kg]*exp(19.837)/1[h] Pre-exponential factor, reaction 1

A2 1[kmol/kg]*exp(20.86)/1[h] Pre-exponential factor, reaction 2

A3 1[kmol/kg]*exp(18.97)/1[h] Pre-exponential factor, reaction 3

B1 13588[K] Activation temperature, reaction 1

B2 15803[K] Activation temperature, reaction 2

B3 14394[K] Activation temperature, reaction 3

NAME EXPRESSION DESCRIPTION

NAME EXPRESSION DESCRIPTION

k1 A1*exp(-B1/T) Forward rate constant, reaction 1

k2 A2*exp(-B2/T) Forward rate constant, reaction 2

k3 A3*exp(-B3/T) Forward rate constant, reaction 3

r1 rho_b*yA0*y0*k1*(1-xB-xC) Reaction rate, reaction 1 (A->B)

r2 rho_b*yA0*y0*k2*xB Reaction rate, reaction 2 (B->C)

r3 rho_b*yA0*y0*k3*(1-xB-xC) Reaction rate, reaction 3 (A->C)

rB r1-r2 Net production rate of phthalic 
anhydride

rC r2+r3 Production rate of carbon oxides

xA (cB+cC)/c_tot Conversion, species A

xB cB/c_tot Conversion, species B

xC cC/c_tot Conversion, species C
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“Using Coupling Variables” on page 255 of the COMSOL Multiphysics User’s 
Guide.)

1 From the Options menu, select Projection Coupling Variables>Subdomain Variables.

2 On the Source page, select Subdomain 1 from the Subdomain selection list.

3 On the first empty row in the table, type xA_mean in the Name column and (2/
R^2)*r*xA in the Expression column. (Use the default integration order.)

4 Click the General transformation option button. In the Source transformation area, 
set x to z and y to r.

5 On the Destination page, select Boundary from the Level list.

6 Select Boundary 1 as well as the Use selected boundaries as destination check box.

7 In the Destination transformation area, set x to r.

8 Click the Source tab.

9 Repeat Steps 3–8 twice to define xB_mean and xC_mean as the radial mean values of 
the conversions xB and xC, respectively.

10 Click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings—Mass Transport
1 From the Multiphysics menu, select 1 Convection and Diffusion (massbal).

2 From the Physics menu, select Subdomain Settings. Select Subdomain 1.
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3 Specify the following subdomain settings:

4 On the cB and cC pages, in turn, click the Artificial Diffusion button. Select the 
Streamline diffusion check box. Click OK to confirm the default parameters.

5 Click OK in the Subdomain Settings dialog box.

Boundary Conditions—Mass Transport
1 Choose Physics>Boundary Settings.

2 On both the cB and the cC page, specify the following boundary conditions:

On Boundaries 1 and 4, the default Insulation/Symmetry condition applies.

3 Click OK.

Subdomain Settings—Energy Transport
1 From the Multiphysics menu, select 2 Convection and Conduction (energybal).

2 Choose Physics>Subdomain Settings.

3 For Subdomain 1, enter the settings listed in the following table:

4 Click the Artificial Diffusion button, then select the Streamline diffusion check box. 
Click OK to confirm the default parameters and close the dialog box.

5 On the Init page, set T(t0) to T0.

SPECIES CB CC

D (isotropic) D_eff D_eff

R rB/yA0 rC/yA0

u 0 0

v u_s u_s

SETTINGS BOUNDARY 2 BOUNDARY 3

Type Concentration Convective flux

cB0, cC0 0

PROPERTY VALUE

 k (isotropic) k_eff

 ρ rho_g

 Cp C_p

 Q (-DeltaH1)*rB+(-DeltaH3)*rC

 u 0 u_s
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6 Click OK.

Boundary Conditions—Energy Transport
1 Choose Physics>Boundary Settings.

2 Enter boundary conditions according to the following table:

3 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters.

2 From the Predefined mesh sizes list, select Finer.

Because of the large aspect ratio of the model geometry—the reactor is 3 meters 
long and 0.0127 meters in radius—it is necessary to rescale the mesh in the radial 
direction; use a scale factor of 200.

3 Click the Advanced tab. In the r-direction scale factor edit field, type 200.

4 Click Remesh, then click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Click the Plot Parameters button on the Main toolbar.

2 Click the Surface tab. Type T in the Expression edit field on the Surface Data page.

3 Click OK.

4 From the Postprocessing menu, select Domain Plot Parameters.

5 Click the Line/Extrusion tab and select Boundary 1.

6 In the Expression edit field, type xA_mean.

7 In the x-axis data area, select the option button next to the Expression button, then 
click the Expression button. Type z in the Expression edit field, then click OK.

8 Click the Line Settings button.

9 Select Triangle from the Line marker list. Click OK.

SETTINGS BOUNDARY 1 BOUNDARY 2 BOUNDARY 3 BOUNDARY 4

Type Axial symmetry Temperatur
e

Convective flux Heat flux

q0 -alpha*(T-T0)

T0 T0
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10 Go to the General page and click the Title/Axis button. Click the option button next 
to the Title edit field and type Mean conversions in the edit field.

11 Click the option button next to the Second axis label edit field and type  
x<sub>A,mean</sub>, x<sub>B,mean</sub>, x<sub>C,mean</sub> 

in the edit field. Click OK.

12 Click Apply.

13 Return to the Domain Plot Parameters dialog box and select the Keep current plot 
check box.

14 Click the Line/Extrusion tab and type xB_mean in the Expression edit field.

15 Click the Line Settings button and select Square from the Line marker list.

16 Click OK then click Apply.

17 Type xC_mean in the Expression edit field.

18 Click the Line Settings button and select Circle from the Line marker list. Click OK.

19 Click OK to close the Domain Plot Parameters dialog box and generate the third 
graph.

20 In the figure window, click the Edit Plot toolbar button. In the Edit Plot dialog box, 
for each line, in turn, select the Show legend check box and edit the entry in the 
Legends edit field. When done, click OK.

P A R A M E T R I C  S T U D Y

1 Click the Solver Parameters button on the Main toolbar.

2 From the Solver list, select Parametric.

3 Type T0 in the Parameter name edit field and 625 626 627 628 629 in the 
Parameter values edit field.

4 Click OK.

5 Click the Solve button on the Main toolbar.

6 From the Postprocessing menu, select Cross-Section Plot Parameters.

7 Click the Line/Extrusion tab and type T-T0 in the Expression edit field.

8 In the x-axis data area, select the option button next to the Expression button, then 
click the Expression button. Type r in the Expression edit field, select mm from the 
Unit list and click OK.
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9 In the Cross-section line data area, type in the following values:

10 Click the Line Settings button.

11 Select Cycle from the Line marker list and select the Legend check box. Click OK.

12 Click OK to create the plot in Figure 8-5.

Finally, perform the following steps to produce Figure 8-6.

1 From the Postprocessing menu, select Domain Plot Parameters.

2 On the Line/Extrusion tab, type T-T0 in the Expression edit field.

3 Click the Line Settings button and select Cycle from both the Line color and the Line 

marker list. Select the Legend check box, then click OK.

4 Go to the General page and click the Title/Axis button.

5 Type Centerline temperature in the Title edit field and select the Auto option 
button for the Second axis label. Click OK.

6 From the Plot in list, select New figure.

7 Click OK.

R0 R1 Z0 Z1

0 0.0127 0.6 0.6
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Ab s o r p t i o n  i n  a  F a l l i n g  F i lm

Introduction

The absorption process of gases in liquids is thoroughly treated in the chemical 
engineering literature (References 1–3). When modeling reactors and equipment for 
unit operations, you are dependent on experimental data for the relation between gas 
and liquid composition. In the process of measuring absorption, you have to design 
your experiments in such a way that relevant data is obtained.

In this example1, you model an experimental setup for studies of gas absorption, more 
specifically the absorption of chlorine, diluted in hydrogen, in a caustic solution 
containing low amounts of carbonate. In many electrolysis processes, hydrogen is 
generated at the cathode and is often contaminated by chlorine, which is produced at 
the anode in chloride solutions. The chlorine-contaminated hydrogen is cleaned in 
caustic soda scrubbers.

There are a number of different experimental methods for determining the absorption 
of a gas in a liquid. Most methods share the same basic principle: create a well-defined 
velocity profile in the liquid phase to obtain an analytic estimation of the diffusion 
boundary layer (References 1–3). Such a well-defined velocity profile can be obtained 
by using laminar jets, rotating drums with thin liquid films, falling films, etc. (see Ref. 
4). The mass transport properties in the gas phase are estimated from the relative 
velocity between the liquid flow and the gas flow. In most cases, the gas flow velocity 
is negligible in comparison with the liquid velocity. Consequently, the magnitude of 
the forced convection in the gas is negligible and the transport properties can be 

1. This model was developed in cooperation with Fredrik Herlitz, Eka Chemicals R&D.
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obtained from the free convection that is induced in the gas phase by the flow of the 
liquid.

Figure 8-7: Schematic view of a falling film stripper.

The model describes measuring equipment for gas absorption based on the principle 
of a falling laminar film. The setup of this apparatus appears in Figure 8-7. A liquid film 
is formed by a guiding funnel that creates an annular flow with a free liquid surface 
facing a hollow tubular region. The gas is introduced in the tube from below and is 
absorbed on the free surface of the liquid. The liquid and gas compositions are 
measured before and after entering the apparatus. This setup implies that the liquid-gas 
contact area and the convection of the phase boundary are well defined.

The model shows that it is simple to treat fairly large systems of nonlinear partial 
differential equations in COMSOL Multiphysics.

Model Definition

The model describes a falling film apparatus for the absorption of low amounts of 
chlorine in hydrogen. The gas is further contaminated with low amounts of carbon 
dioxide, which in some cases can limit the absorption rate of chlorine. To obtain a 
more transparent model, use the following assumptions about the system:

• Assume that chlorine in hydrogen is diluted to such an extent that the volume of the 
gas is not influenced by the absorption process.

• Do not account for condensation and evaporation of water in the system.

• Neglect any homogeneous gas phase reactions.

• Assume laminar flow in the liquid phase.

• Assume that the radius of the tube is large enough in comparison to the thickness 
of the falling film that tube curvature effects are negligible.

• Assume the tube to be short enough that you can neglect gravitational acceleration.
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• Assume that the contribution of diffusion to the flux of species is negligible in the 
direction of the convective flow, that is, in the vertical direction.

• Assume that the system is isothermal.

You find the thermodynamic and kinetic data for the system, as well as a detailed 
description of the chemistry, in Ref. 5. The chemical species in this example are given 
in Table 8-1.

The chemical reactions that appear in the mass balances for the species in the previous 
table are:

 (8-8)

The model accounts for the kinetics in every reaction. Denote the kinetic parameters 
in the equations above ki and k_i, for the forward and backward reaction, 
respectively, where i is the number of the reaction. Denote the equilibrium constants 
for the reactions Ki.

The assumptions listed above allow you to define the mass balance equations for the 
system from the chemical reaction formulas. In addition, you can neglect the 
component of the flow velocity vector in the horizontal direction, which makes it 
possible to obtain an analytic expression for this vector (Ref. 2). The result of this is 
that you can reduce the 3D problem to a 1D time-dependent model, using time to 

TABLE 8-1:  PARTICIPATING SPECIES

INDEX 1 2 3 4 5 6 7 8 9 10

SPECIES  Cl2  OH-  HClO  Cl-  H+  ClO-  HCO3
-  CO2  CO3

2-  H2CO3

Cl2 OH-
+ HClO Cl-+= 1( )

H2O H+ OH-
+= 2( )

HClO OH-
+ ClO- H2O+= 3( )

Cl2 H2O+ HClO HCl+= 4( )

Cl2 HCO3
-

+ CO2 HClO Cl-+ += 5( )

Cl2 CO3
2-

+ CO2 ClO- Cl-+ += 6( )

CO2 H2O+ H2CO3= 7( )

CO2 OH-
+ HCO3

-
= 8( )

HCO3
- OH-

+ CO3
2- H2O+= 9( )

HCO3
- H++ H2CO3= 10( )
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represent the space coordinate in the vertical direction. The following sketch shows the 
domain that the model includes. The domain is confined by the gas phase on the left 
side and by the wall of the tube on the right side. It is also bounded by the inlet at the 
top and the outlet at the bottom.

Figure 8-8: Schematic of the falling film at the tube wall in the experimental device.

The following general expression describes the flux vector of every species:

 (8-9)

Here Ni (mol/(m2·s)) represents the flux, Di (m
2/s) the diffusion coefficient in the 

liquid phase, and ci (mol/m3) the concentration of species i. Further, x (m) is the 
space coordinate in the horizontal direction and vy (m/s) refers to the liquid-flow 
velocity component in the vertical direction. Ref. 1 gives the velocity profile, vy, as 

 (8-10)

where vav represents the average relative velocity and δ the thickness of the film. The 
space coordinate x is 0 at the gas phase boundary and δ at the wall of the tube. The 
coordinate  y is 0 at the inlet and equal to the length of the tube, L, at the outlet.

You can now define the mass balance at steady state for the species:

 (8-11)

In this equation Rj (mol/(m3·s)) represents the reaction rate for each of the reactions 
j that the species i takes part in. You can obtain the kinetic expressions for these 
reactions from Ref. 4, and they are also listed in the modeling instructions below. The 
equations above can be expressed in the following form:

 (8-12)

Ni Di
ci∂
x∂

-------– civy,⎝ ⎠
⎛ ⎞=    in Ω i 1 … 10, ,=

vy 1.5vav 1 x
δ
---⎝ ⎠
⎛ ⎞2 

–⎝ ⎠
⎛ ⎞⋅=

∇ N⋅ i ΣRj– 0=( )   in Ω, i 1 … 10, ,=

Di
∂2ci

x2∂
----------– vy

ci∂
y∂

-------+ Rj∑– 0=⎝ ⎠
⎛ ⎞    in Ω,  i 1 … 10, ,=
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You can rewrite these equations by using the transformation y = vav t to get the 
following final system of equations in the domain:

 (8-13)

The concentration at the inlet of each involved species is 0 except for those of the 
hydrogen and hydroxide ions. The transformation from vertical coordinate to time 
implies that the boundary conditions at  y = 0 become initial conditions at t = 0, which 
thus read

 (8-14)

The outlet corresponds to the time  tf = L/vav . In this model, the parameters L and vav  
are adjusted to give  tf = 1 s.

The boundary conditions for the system at the gas phase boundary are

 (8-15)

where kga (mol/(m2·s·Pa)) denotes the mass transport coefficient in the gas phase, p 
(Pa) is the partial pressure, and H (Pa·m3/mol) refers to the Henry constant.

The boundary conditions at the tube wall are

 (8-16)

which implies that there is no flux of species out of the domain at this boundary.

1.5 1 x
δ
---⎝ ⎠
⎛ ⎞2 

–⎝ ⎠
⎛ ⎞ ci∂

t∂
------- Di

∂2ci

x2∂
----------– Rj∑– 0=    in Ω,  i 1 … 10, ,=

ci x 0,( ) 0= i 1 3 4 6 … 10, , , , ,=

c2 x 0,( ) COH=     

c5 x 0,( ) CH=

Di
∂ci

∂x
-------– 0 t,( ) 0= i 2 … 7 9 10, , , ,=

D1
∂c1
∂x
--------– 0 t,( ) kga Cl2, pCl2

c1HCl2
–( )=

D8
∂c8
∂x
--------– 0 t,( ) kga CO2, pCO2

c8HCO2
–( )=

Di
∂ci

∂x
-------– δ t,( ) 0= i 1 … 10, ,=
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Results

Table 8-9 shows the concentration of chlorine inside the film as a function of distance 
from the gas-liquid interface at  t = 1 s, which corresponds to the outlet of the tube.

Figure 8-9: Concentration profile for chlorine.

The graph shows that chlorine does not penetrate the film to a larger extent. This is 
explained by chlorine’s reaction with the hydroxide ion leading to hypochlorous acid 
and the hypochlorite ion. This reaction is very fast and limits the spreading of chlorine 
in the falling film. The low pH at the surface of the film, and thus the low content of 
hydroxide ions, allows for a high chlorine concentration. The acidic surface of the film 
reduces the scrubbing capacity in the falling film. For this reason, a scrubber is 
equipped with filling material that enhances the mixing through convection in the film.
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The reaction products from chlorine’s reaction with the hydroxide ion and water 
penetrate the falling film during the absorption process. You can see the concentration 
profile of the hypochlorite ion, from the inlet to the outlet of the tube in Figure 8-10.

Figure 8-10: Radial concentration distribution at the distances 0.1L, 0.2L, …, L from the 
tube inlet (L = tube length).

You can see from this figure that the hypochlorite ion increases in concentration 
throughout the absorption process. At a certain stage, a maximum appears in the 
profile. This maximum is caused by the consumption of hypochlorite, through the 
formation of hypochlorous acid, at the low pH at the surface of the film (x = 0). The 
low pH is caused by the reaction of chlorine with hydroxide and water.

Modeling in COMSOL Multiphysics

When modeling a stationary convection-diffusion process that has negligible 
convective transport in one direction (in this case the radial direction) and negligible 
diffusive transport in the other direction (in this case the axial direction), it is possible 
to reformulate the convection-diffusion equation by switching the axial derivative to a 
time derivative. To be able to do so, you also need to have a nonchanging velocity field 
along the axial direction. This enables us to reduce one space dimension of the 

toward the outlet
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problem, making it a much smaller 1D problem, albeit time dependent. In COMSOL 
Multiphysics this is a “pseudo-2D equation,”

,  (8-17)

where udl is the dimensionless velocity.
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Model Library path:  
Chemical_Engineering_Module/Transport_and_Reactions/falling_film

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics.

2 In the Model Navigator, select 1D from the Space dimension list.

3 From the Application Modes list, select 
Chemical Engineering Module>Pseudo 2D>Mass Transport>Convection and Diffusion.

udl
∂c
∂t
----- ∂

∂x
------ D∂c

∂x
------–⎝ ⎠

⎛ ⎞+ R=
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4 In the Dependent variables edit field, type the names of the concentration variables 
as space-separated entries: c1 c2 c3 c4 c5 c6 c7 c8 c9 c10.

5 Select Lagrange - Cubic from the Element list. Using higher order elements gives 
more accurate results compared to lower order elements.

6 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 In the Options>Axes/Grid settings dialog box, set the axis limits to x min: -1e-5 and 
x max: 11e-5.

2 Click OK.

3 Define the following constants in the Options>Constants dialog box (the descriptions 
are optional); when finished, click OK.

NAME EXPRESSION DESCRIPTION

D1 1.47e-9[m^2/s] Diffusivity, species 1

D2 3.43e-9[m^2/s] Diffusivity, species 2

D3 1.54e-9[m^2/s] Diffusivity, species 3

D4 1.565e-9[m^2/s] Diffusivity, species 4

D5 3.43e-9[m^2/s] Diffusivity, species 5

D6 3.43e-9[m^2/s] Diffusivity, species 6

D7 1.5e-9[m^2/s] Diffusivity, species 7
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D8 1.92e-9[m^2/s] Diffusivity, species 8

D9 1.5e-9[m^2/s] Diffusivity, species 9

D10 1.5e-9[m^2/s] Diffusivity, species 10

T 298[K] Temperature

k1 1.565e6[m^3/(mol*s)] Forward rate constant 1

K1 4.491e10 Equilibrium constant 1

k_1 k1/K1 Reverse rate constant 1

k2 1e9[mol/(m^3*s)] Forward rate constant 2

K2 1.002e-8[(mol/m^3)^2] Equilibrium constant 2

k_2 k2/K2 Reverse rate constant 2

k3 2.79e12[m^3/(mol*s)] Forward rate constant 3

K3 2.79e3[m^3/mol] Equilibrium constant 3

k_3 k3/K3 Reverse rate constant 3

k4 1.4527e10[1/s]*exp(-6138.6[K]/T) Forward rate constant 4

K4 4.5e10[(mol/m^3)^2] Equilibrium constant 4

k_4 k4/K4 Reverse rate constant 4

k5 5.63e7[m^3/(mol*s)]* 
exp(-4925[K]/T)

Forward rate constant 5

K5 1.092e6[mol/m^3] Equilibrium constant 5

k_5 k5/K5 Reverse rate constant 5

k6 k5 Forward rate constant 6

K6 6.569e9[mol/m^3] Equilibrium constant 6

k_6 k6/K6 Reverse rate constant 6

k7 10^(329.85-110.541*log(T[1/K])/
log(10)-17265.4[K]/T)[1/s]

Forward rate constant 7

K7 2.06e-3 Equilibrium constant 7

k_7 k7/K7 Reverse rate constant 7

k8 10^(13.635-2895[K]/T) 
[m^3/(mol*s)]/1000

Forward rate constant 8

K8 4.112e4[m^3/mol] Equilibrium constant 8

k_8 k8/K8 Reverse rate constant 8

k9 1e10[m^3/(mol*s)] Forward rate constant 9

K9 4.640[m^3/mol] Equilibrium constant 9

k_9 k9/K9 Reverse rate constant 9

k10 2.155e9[m^3/(mol*s)] Forward rate constant 10

NAME EXPRESSION DESCRIPTION
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4 Define the following expressions in the Options>Expressions>Scalar Expressions 

dialog box; when finished, click OK.

G E O M E T R Y  M O D E L I N G

Click the Line button on the Draw toolbar and draw a line from 0 to 1e-4.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Physics menu, choose Subdomain Settings. Select Subdomain 1.

2 On each species page, c1, …, c10, enter the applicable settings for diffusion constant, 
reaction rate, and dimensionless velocity from this table:

K10 5[m^3/mol] Equilibrium constant 10

k_10 k10/K10 Reverse rate constant 10

delta 0.1[mm] Film thickness

Coh 10[mol/m^3] Initial concentration, OH-

Ch K2/Coh Initial concentration, H+

kgaCl2 0.244[mol/(m^2*s*atm)] Mass transport coefficient

pCl2 3[matm] Partial pressure

HCl2 0.01636[atm*m^3/mol] Henry constant

kgaCO2 0.244[mol/(m^2*s*atm)] Mass transport coefficient

pCO2 1[matm] Partial pressure

HCO2 0.0266[atm*m^3/mol] Henry constant

NAME EXPRESSION DESCRIPTION

NAME EXPRESSION DESCRIPTION

udl 1.5*(1-(x/delta)^2) Dimensionless velocity

SPECIES  D  R  udl

1 D1 (-k1*c1*c2+k_1*c3*c4 
-k4*c1+k_4*c3*c4*c5)-(k5*c1*c7-k_5*c3*c4*c8) 
-(k6*c1*c9-k_6*c4*c6*c8)

udl

2 D2 (-k1*c1*c2+k_1*c3*c4+k2- 
k_2*c2*c5-k3*c2*c3+k_3*c6) 
-(k8*c2*c8-k_8*c7)-(k9*c2*c7-k_9*c9)

udl

3 D3 (k1*c1*c2-k_1*c3*c4-k3*c2*c3+ 
k_3*c6+k4*c1-k_4*c3*c4*c5) 
+(k5*c1*c7-k_5*c3*c4*c8)

udl
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3 On the Init page, set c2(t0) to Coh and c5(t0) to Ch.

The other concentrations are zero at the beginning of the process.

4 Click OK to close the dialog box.

Boundary Conditions
1 From the Physics menu, open the Boundary Settings dialog box. 

2 Select Boundary 1.

4 D4 (k1*c1*c2-k_1*c3*c4+k4*c1- 
k_4*c3*c4*c5)+(k5*c1*c7-k_5*c3*c4*c8) 
+(k6*c1*c9-k_6*c4*c6*c8)

udl

5 D5 (k2-k_2*c2*c5+k4*c1-k_4*c3*c4*c5) 
-(k10*c5*c7-k_10*c10)

udl

6 D6 (k3*c2*c3-k_3*c6)+(k6*c1*c9-k_6*c4*c6*c8) udl

7 D7 -(k5*c1*c7-k_5*c3*c4*c8)+ 
(k8*c2*c8-k_8*c7)-(k9*c2*c7-k_9*c9) 
-(k10*c5*c7-k_10*c10)

udl

8 D8 (k5*c1*c7-k_5*c3*c4*c8)+ 
(k6*c1*c9-k_6*c4*c6*c8)-(k7*c8-k_7*c10) 
-(k8*c2*c8-k_8*c7)

udl

9 D9 -(k6*c1*c9-k_6*c4*c6*c8)+(k9*c2*c7-k_9*c9) udl

10 D10 (k7*c8-k_7*c10)+(k10*c5*c7-k_10*c10) udl

SPECIES  D  R  udl
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3 On the pages c1 and c8, enter the corresponding settings from this table:

For the remaining species, leave the default condition (Insulation/Symmetry).

4 Click OK to close the dialog box.

M E S H  G E N E R A T I O N

1 From the Mesh menu, open the Free Mesh Parameters dialog box.

2 On the Global page, set the Element growth rate to 1.03.

3 On the Boundary page, select Boundary 1 and enter a Maximum element size of 1e-6.

4 Click the Remesh button.

5 When the mesher has finished, click OK to close the dialog box.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 In the Timestepping area, type 0:0.02:1 in the Times edit field. Set the Relative 

tolerance to 2e-6 and the Absolute tolerance to 1e-7 to improve accuracy in the time 
stepping.

3 Click OK.

PROPERTY  c1  c8

Type Flux Flux

N0 kgaCl2*(pCl2-c1*HCl2) kgaCO2*(pCO2-c8*HCO2)
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4 Click the Solve button on the Main toolbar. Because you are using cubic elements 
and low error tolerances for higher accuracy it takes a few minutes for the solver to 
finish.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate Figure 8-10, follow these steps:

1 From the Postprocessing menu, select Domain Plot Parameters.

2 On the General page, select the solutions at 0.1 s to 1.0 s with intervals of 0.1 s by 
pressing the Ctrl key and clicking at the appropriate times in the Solutions to use list.

3 Click the Title/Axis button and enter appropriate title.

4 Click OK.

5 Click the Line/Extrusion tab, then select Subdomain 1.

6 In the y-axis data area, type c6 in the Expression edit field. 

7 Set the x-axis data to x.

8 Click the Line Settings button. From the Line marker list, select Cycle. Select the 
Legend check box, then click OK.

9 Click OK.
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Boa t  R e a c t o r  f o r  L ow P r e s s u r e  
Ch em i c a l  V apo r  Depo s i t i o n

Introduction

Chemical vapor deposition (CVD) is an important step in the process of manufacturing 
microchips. A common application is the deposition of silicon on wafers at low 
pressure. Low-pressure reactors are used to get a high diffusivity of the gaseous species, 
which results in a uniform deposition thickness, because the process becomes limited 
by the deposition kinetics (Ref. 1 and Ref. 2).

Figure 8-11: Schematic of a boat reactor and the principle of the deposition process.

In this example you model the momentum and mass transport equations coupled to 
the reaction kinetics for the deposition process. You treat a low-pressure boat reactor, 
where the goal of the simulation is to describe the rate of deposition as a function of 
the fluid mechanics and kinetics in the system.

The gas, in this case silane (SiH4), enters the reactor from the left and reacts on the 
wafers to form hydrogen and silicon. The remaining mixture leaves the reactor through 
the outlet on the right. The deposition of silicon on the surface of the wafers depends 
on the local concentration of silane, which is determined by the operating conditions 
for the reactor.

You can find more details about this example in Elements of Chemical Reaction 
Engineering  by H. Scott Fogler (Ref. 1).
B O A T  R E A C T O R  F O R  L O W  P R E S S U R E  C H E M I C A L  V A P O R  D E P O S I T I O N  |  447



448 |  C H A P T E
Model Definition

First assume that the density of the gas is constant throughout the reactor. This implies 
that the reacting gas is either diluted in a carrier gas or that the conversion in the 
reactor is small. Moreover, only account for the mass transport of the reactant gas, in 
this case silane, and assume constant temperature in the reactor.

In the wafer bundle subdomain you can neglect convection transport, so that the 
reacting gas can only be transported through diffusion. To save time and 
computational memory, also simplify the geometrical description of the wafer bundle 
by modeling it as an anisotropic medium. To this end, because silane cannot diffuse 
through the physical wafers, assume that the axial diffusivity in the wafer bundle is zero. 
Furthermore, correct the diffusivity in the radial direction according to the degree of 
packing in the bundle. Finally, neglect the influence of the support boat on the 
transport process that holds the wafer bundle in place. The structure of the boat reactor 
means that you can reduce the 3D geometry to a 2D axisymmetric model. The 
modeling domain is shown in Figure 8-12.

Figure 8-12: The model geometry showing the subdomain and boundary labels.

The chemical reaction you account for in this example is given below:

 (8-18)

The rate of this reaction depends on the partial pressure of silane and the temperature 
in the reactor.

∂Ωwall

Ωff

∂Ωsym

∂Ωout

∂Ωin

Ωwb

∂Ωiw

SiH4 g( ) Si s( ) 2H2 g( )+↔
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The assumptions mentioned above in combination with the chemical reaction for the 
deposition process make it possible to define an equation system. The momentum 
equations and the continuity equations for laminar flow in cylindrical coordinates read

 (8-19)

Here η (kg/(m·s)) denotes the viscosity; ρ (kg/m3) is the density of the gas; u and v 
(m/s) refer to the velocity vector’s r- and z-components, respectively; and p (Pa) is the 
pressure.

The mass transport in the free-fluid subdomain is given by the following equation, 
expressed in cylindrical coordinates:

 (8-20)

Here D denotes the diffusivity (m2/s) and c is the concentration of silane (mol/m3). 
You obtain the corresponding mass transport equation for the wafer bundle 
subdomain by neglecting transport by convection and adding a reaction-rate term for 
the dissociation of silane:

 (8-21)

Because you neglect diffusion in the axial direction, the effective diffusivity tensor, Deff, 
only has an rr component. In the equation above, k (m/s) denotes the rate constant 
for the reaction, and Sa (m2/m3) refers to the specific surface area.

You solve the system of equations defined above by using the proper boundary 
conditions. For laminar flow, no-slip conditions apply at the reactor-wall surface and 
between the free channel and the wafer bundle:

 (8-22)

At the symmetry axis, the radial velocity component vanishes:

r∂
∂ ηr u∂

r∂
------–⎝ ⎠

⎛ ⎞
z∂

∂ ηr u∂
z∂

------–⎝ ⎠
⎛ ⎞ ρr u u∂

r∂
------ v u∂

z∂
------+⎝ ⎠

⎛ ⎞ r p∂
r∂

------+ + + 0= in Ωff

r∂
∂ ηr v∂

r∂
------–⎝ ⎠

⎛ ⎞
z∂

∂ ηr v∂
z∂

------–⎝ ⎠
⎛ ⎞ ρr u v∂

r∂
------ v v∂

z∂
------+⎝ ⎠

⎛ ⎞ r p∂
z∂

------+ + + 0= in Ωff

r u∂
r∂

------ v∂
z∂

------+⎝ ⎠
⎛ ⎞ v+ 0= in Ωff

r∂
∂ D r c∂

r∂
-----–⎝ ⎠

⎛ ⎞
z∂

∂ D r c∂
z∂

-----–⎝ ⎠
⎛ ⎞ r u c∂

r∂
----- r v c∂

z∂
-----+ + + 0= in Ωff

r∂
∂ Deff rr, r c∂

r∂
-----–⎝ ⎠

⎛ ⎞ r– kSa c= in Ωwb

u v,( ) 0 0,( )=   at Ω∂ wall, Ω∂ iw ff, ,  and  Ω∂ wb ff,
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 (8-23)

The last three conditions for the momentum equations and continuity equation are

 (8-24)

For the mass transport equations 8-20 and 8-21, the boundary conditions are

 (8-25)

where Di represents the diffusivity in Ωff or Ωwb depending on to which boundary 
segment you apply the equation. This equation implies that there is no flux 
perpendicular to these boundaries. At the inlet, the composition of the gas is known, 
which yields:

 (8-26)

At the outlet, assume that the transport of species takes place mainly by convection and 
neglect the concentration gradients perpendicular to this boundary:

 (8-27)

It remains to discuss the material parameters appearing in Equation 8-21: Deff, rr , Sa, 
and k. First, calculate the specific surface area (that is, the area per unit volume) of the 
wafer bundle, Sa, by assuming a certain pitch between the wafers; see Figure 8-13.

u 0= at Ω∂ sym

u 0=  at  Ω∂ in

v v0=  at  Ω∂ in

p p0=  at  Ω∂ out

η ∇u ∇u( )T+( )n 0=  at  Ω∂ out

Di rr,
c∂
r∂

----- Di zz,
c∂
z∂

-----–,–⎝ ⎠
⎛ ⎞ n⋅ 0=  at  Ω∂ wall, Ω∂ sym, and Ωiw∂

c c0=  at Ω∂ in

D c∂
r∂

----- D c∂
z∂

-----–,–⎝ ⎠
⎛ ⎞ n⋅ 0=  at Ω∂ out
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Figure 8-13: Calculation of the specific surface area.

Furthermore, to estimate the effective diffusivity in the radial direction inside the wafer 
bundle, multiply the diffusivity in the free-fluid subdomain by the ratio of the contact 
area between the free gas and the wafer bundle to the total lateral surface area of the 
wafer-bundle subdomain:

 (8-28)

The rate constant, k (m/s), is a function of the partial pressure of silane. At 600 °C 
and a total system pressure of 25 Pa, Ref. 2 provides the value k = 8.06·10−3 m/s.

A crucial characteristic of the reactor’s performance is the silicon deposition rate, ∆Si, 
which expresses the growth rate of the silicon layer on the wafers. The amount of 
silicon deposited on the wafers, expressed in mass per unit area per unit time, is the 
product of the rate constant, k, the silane concentration, c, and the molar mass of 
silicon, MSi (kg/mol). Dividing the so obtained quantity by the density of silicon, ρSi 
(kg/m3), gives the deposition rate:

 (8-29)

In this model, you study the radial and axial distribution of ∆Si inside the wafer bundle.

Results

Figure 8-14 shows the concentration distribution in the boat reactor, indicating that 
the conversion is quite small.

Deff rr, 1
dw
dcc
--------–⎝ ⎠

⎛ ⎞D=  in Ωwb

∆Si
kcMSi

ρSi
-----------------   (nm/min)=
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Figure 8-14: Concentration distribution in the reactor.

Figure 8-15 shows the flow distribution in the reactor.

Figure 8-15: Flow distribution in the reactor. The surface color and the arrows both 
represent the velocity.
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The plots in Figure 8-16 display the deposition rate for the inlet velocities 1 m/s (top 
panel) and 2 m/s (bottom panel).

Figure 8-16: The deposition rate in the wafer bundle for the inlet velocities 1 m/s (top) and 
2 m/s (bottom).

In both cases, the highest deposition rate is obtained near the reactor inlet and close 
to the free-fluid channel. The difference in deposition rate between the center and 
periphery of the wafers is approximately 0.1 nm/min (or roughly 2.5%), and that along 
the length of the reactor approximately 0.5 nm/min (roughly 12.5%). Thus, as 
desired, the variations in the deposition rate inside the reactor are rather small.

Moreover, comparing the plots it is evident that the deposition rate changes only 
marginally when the gas inlet velocity is doubled, showing that convection does not 
have a major influence on reactors of this type.
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Model Library path:  
Chemical_Engineering_Module/Transport_and_Reactions/boat_reactor

Modeling Using the Graphical User Interface

1 Start COMSOL Multiphysics.

2 In the Model Navigator, set Space dimension to Axial symmetry (2D).

3 From the Application Modes list, select 
Chemical Engineering Module>Momentum Transport>Laminar Flow> 
Incompressible Navier-Stokes.

4 Click the Multiphysics button and add the application mode to the model by clicking 
the Add button.

5 From the Application Modes list, select 
Chemical Engineering Module>Mass Transport>Convection and Diffusion.

6 Click the Add button to add the application mode to the model.

7 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Axes/Grid Settings.

2 Specify the axis and grid settings according to the following table:

AXIS GRID

r min -0.04 r spacing 0.02

r max 0.1 Extra r

z min -0.02 z spacing 0.02

z max 0.2 Extra z 0.035 0.145
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3 Click OK.

4 From the Options menu, select Constants. 

5 Enter the following constants (the descriptions are optional); when done, click OK.

Note the value of the Reynolds number in the Value column. The small Reynolds 
number validates the assumption of laminar flow inside the reactor.

6 Choose Options>Expressions>Scalar Expressions.

7 Define a constant by the data in the following table; when done, click OK.

NAME EXPRESSION DESCRIPTION

R_a 40[mm] Wafer radius

d_cc 2.5[mm] Wafer spacing

d_w 0.5[mm] Wafer thickness

S_a 2*(R_a^2+R_a*d_w)/
(R_a^2*d_cc)

Specific surface area

p_tot 25[Pa] Total system pressure

D_amb 5e-5[m^2/s] SiH4 diffusivity in air at 1 
atm

D D_amb*1.013e5[Pa]/p_tot Pressure-corrected diffusivity

D_eff D*(1-d_w/d_cc) Effective diffusivity in wafer 
bundle

k 8.06[mm/s] Rate constant

M_N2 28[g/mol] Molar mass, N2

M_Si 28[g/mol] Molar mass, Si

M_SiH4 32[g/mol] Molar mass, SiH4

R_g 8.314[J/(mol*K)] Ideal gas constant

T_r 600[degC] Reactor temperature

rho p_tot*(0.2*M_SiH4+0.8*M_N2)/
(R_g*T_r)

Gas density

eta 3.1e-5[Pa*s] Dynamic viscosity

c0 0.2*p_tot/(R_g*T_r) Inlet concentration, SiH4

v0 1[m/s] Inlet axial flow velocity

rho_Si 2e3[kg/m^3] Silicon density

Re R_a*v0*rho/eta Reynolds number

NAME EXPRESSION DESCRIPTION

Delta_Si c*k*M_Si/rho_Si Silicon deposition rate
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G E O M E T R Y  M O D E L I N G

1 Click the Line button on the Draw toolbar and draw a line by clicking at the 
positions (0, 0), (0.06, 0), and (0.06, 0.14) with the left mouse button.

2 Select the 2nd Degree Bézier Curve button and draw an arc by clicking at the positions 
(0.06, 0.18) and (0.02, 0.18).

3 Switch back to the Line tool and click at the positions (0, 0.18).

4 Click the right mouse button anywhere to create a solid object, CO1.

5 Draw a rectangle, R1, with the lower left corner at (0, 0.035) and upper-right 
corner at (0.04, 0.04).

6 Draw second rectangle, R2, with the lower left corner at (0,0.04) and upper-right 
corner at (0.04, 0.14).

7 Draw a third rectangle, R3, with the lower-left corner at (0, 0.14) and upper-right 
corner at (0.04, 0.145).

8 Click the Point button and click at the position (0.02, 0).

9 Click the Create Composite Object button in the toolbar and type CO1+R2-R1-R3 in 
the Set formula edit field.

10 Click OK to finalize the geometry.

P H Y S I C S  S E T T I N G S

Subdomain Settings—Incompressible Navier-Stokes
1 From the Multiphysics menu, select 1 Incompressible Navier-Stokes (chns).

2 From the Physics menu, select Subdomain Settings.

3 In the Subdomain selection list, select Subdomain 2.

4 Deactivate the Navier-Stokes application mode in Subdomain 2 by clearing the 
Active in this domain check box.

5 Select Subdomain 1. In the ρ edit field type rho and in the η edit field type eta.

6 Click OK.

Boundary Conditions—Incompressible Navier-Stokes
1 From the Physics menu, select Boundary Settings.
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2 Enter boundary conditions according to the following table:

For the remaining active boundaries (3, 8, 10–15) the default boundary type (wall) 
and condition (no slip) applies.

3 Click OK.

Subdomain Settings—Mass Transport
1 From the Multiphysics menu, select 2 Convection and Diffusion (chcd).

2 From the Physics menu, select Subdomain Settings.

SETTINGS BOUNDARIES 1, 7 BOUNDARY 2 BOUNDARY 9 BOUNDARY 12

Boundary 
type

Symmetry boundary Inlet Outlet Wall

Boundary 
condition

Axial symmetry Velocity Pressure, no 
viscous stress

No slip

u 0

v v0

p 0
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3 Enter subdomain settings according to the following table:

The figure below shows how to enter the anisotropic diffusion coefficients.

4 Click OK.

Boundary Conditions—Mass Transport
1 From the Physics menu, select Boundary Settings.

2 Enter boundary conditions according to the following table:

For the remaining boundaries, the default conditions apply.

3 Click OK.

SETTINGS SUBDOMAIN 1 SUBDOMAIN 2

D (isotropic) D

D (anisotropic) [D_eff 0;0 0]

R 0 -(k*S_a)*c

u u 0

v v 0

SETTINGS BOUNDARIES 1, 4, 7 BOUNDARY 2 BOUNDARY 9

Type Axial symmetry Concentration Convective flux

c c0
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M E S H  G E N E R A T I O N

This model requires a fairly dense mesh. Therefore, define the maximum mesh edge 
size for some of the geometry edges.

1 From the Mesh menu, select Free Mesh Parameters.

2 Go to the Boundary page and select Boundaries 2, 9, and 14 from the Boundary 

selection list.

3 In the Maximum element size edit field, type 3e-3.

4 Click Remesh, then click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 From the Solve menu, select Solver Parameters.

2 From the Solver list select Parametric.

3 In the Parameter name edit field, type v0.

4 In the Parameter values edit field, type 1 1.5 2.

5 Click OK.

6 Click the Solve button on the Main toolbar to compute the solution.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Generate the plot in Figure 8-14 with the following steps.

1 Click the Plot Parameters button on the Main toolbar.

2 In the Solution to use area, select 1 from the Parameter value list.

3 Click the Surface tab. On the Surface Data page, type c in the Expression edit field 
(alternatively, select Convection and Diffusion (chcd)>Concentration, c from the 
Predefined quantities list).

4 Click Apply.

To generate the plot in Figure 8-15, proceed as follows:

5 Return to the Plot Parameters dialog box. From the Predefined quantities list select 
Incompressible Navier-Stokes (chns)>Velocity field.

6 Click the Arrow tab. Select the Arrow plot check box.

7 Leave the default selection, Incompressible Navier-Stokes (chns)>Velocity field (chns), 
in the Predefined quantities list. This choice sets the arrows’ r-components to u and 
their z-components to v.

8 In the Arrow positioning area, set the number of z points to 25.

9 In the Arrow Parameters area, clear the Auto check box and set the Scale factor to 2.
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10 Click OK.

To create the plots in Figure 8-16, execute the following instructions.

11 From the Options menu, open the Axes/Grid Settings dialog box.

12 On the Grid page, select the Auto check box.

13 Click OK.

14 From the Postprocessing menu, select Domain Plot Parameters.

15 On the General page, click the Surface plot option button.

16 From the Solutions to use list, select the parameter value 1 only.

17 Click the Title/Axis button. Click the option button next to the Title edit field and 
enter the title Si deposition rate [nm/min]. Click OK to close the Title/Axis 

Settings dialog box.

18 Back in the Domain Plot Parameters dialog box, click the Surface tab.

19 From the Subdomain selection list, select Subdomain 2.

20 In the Expression edit field, enter the deposition rate Delta_Si.

21 In the Unit edit field, type nm/min to get a more suitable unit for the plot.

22 Click Apply to generate the upper plot in Figure 8-16.

23 On the General page, select the parameter value 2 from the Solutions to use list.

24 Click OK to generate the lower plot and close the dialog box.
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Mono l i t h i c  R e a c t o r

Introduction

The importance of monolithic reactors2 has grown rapidly over the last two decades. 
The most well-known example of a monolithic reactor is the three-way catalytic 
converter for automobiles. This reactor simultaneously transforms unburned 
hydrocarbons, carbon monoxide, and nitrogen oxides from the exhaust gases into 
carbon dioxide, nitrogen, and water.

Catalytic purification of emissions from other sources has also been developed and 
commercialized in the last decade. An important area of applications is the abatement 
of volatile organic compounds (VOC) from processes such as spray painting, offset 
printing, and coating operations. Selective catalytic reduction (SCR) of nitrogen 
oxides by ammonia is another field where monolithic reactors are used. This technique 
has been widely applied to purify effluent gases from coal burning boilers and electric 
power plants.

Yet another challenging application for monolithic reactors is the current development 
of high-temperature catalytic combustion for heat and power generation. This 
technology has proven to be a promising alternative to ordinary flame combustion for 
converting chemical energy into heat or mechanical power with a minimum level of 
emissions from combustion by-products.

A monolithic reactor consists of thin parallel straight channels of arbitrary shape 
through which the gas containing the reactants flows. The walls of the channels are 
coated with a porous ceramic containing the catalyst layer. The transition from 
reactants to products involves transport of the reactants by convective flow in the 
channels and molecular diffusion toward the channel walls. Simultaneous diffusion and 
reactions occur inside the porous washcoat, whereby the products diffuse back into the 
gas and are transported out from the reactor.

There is obviously a large number of variables in optimizing the reactor performance. 
Examples of parameters that are important for the general behavior of the reactor are 
temperature, channel geometry, flow rate, properties of the washcoat, and catalytic 
activity.

2. This model was provided by Dennis Papadias, The Royal Institute of Technology, Stockholm.
M O N O L I T H I C  R E A C T O R  |  461



462 |  C H A P T E
Figure 8-17: A: Monolithic reactor; B: Channel wall; C: Porous ceramic washcoat with 
catalyst. Figure from Ref. 1.

Model Definition

The following model simulates the catalytic abatement of a volatile organic compound 
(VOC), in this case a contaminant in a waste gas. For simple geometries the reactor 
can be described by a 2D model using time as the z-axis. Full 3D modeling is necessary 
if the channels have irregular shape or if the level of active coating is non-uniform along 
the monolith channels. 

M O D E L  A S S U M P T I O N S

In this model you consider oxidation for one type of VOC. Because the concentrations 
of contaminants from the waste gases are usually very low, the heat release from the 
oxidation is negligible. The flow in the monolith channel is laminar. Furthermore, you 
can neglect the axial diffusion of the reactants because it is small compared to the 
convective flow.

Assume identical conditions within each channel, so the model of the whole monolith 
is reduced to one channel. The transversal cross section of the channel is described by 
a circle surrounded by a square. The area between the circle and the square represents 
the washcoat of the reactor. Because of symmetry effects, the simulation only includes 
one eighth of the channel.

B O U N D A R Y  C O N D I T I O N S

The boundary conditions at the channel inlet, z = 0, are uniform concentration and a 
fully developed velocity profile. You can use the Hagen-Poiseuille law to derive the 
velocity analytically. For a circular tube this gives the parabolic profile

 (8-30)Vz 2Um 1 x2
– y2

–( )=
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In this equation, Vz describes the velocity profile (m/s) and Um is the average velocity 
given in dimensionless coordinates x and y that both run between 0 and 1. For all 
exterior boundaries, use Neumann boundary conditions for symmetry.

G A S  P H A S E  E Q U A T I O N

The equation describing the process for the gas in the monolith channel domain, Ω1, is

 (8-31)

where U(x, y) is the velocity profile in the monolith channel, D denotes the diffusion 
coefficient in the free gas (m2/s), and c refers to the concentration (mol/m3). This 
mass transport neglects the contribution of diffusion to the total flux in the axial 
direction, leading to parabolic equations that are easier to solve.

PO R O U S  C A T A L Y S T  E Q U A T I O N S

The equations

 (8-32)

describe the simultaneous reaction and diffusion in the porous network of the 
washcoat domain, Ω2. Treat the washcoat as a homogeneous medium in which the 
effective diffusion coefficient, Deff, reflects the pore properties. Neglect diffusion in the 
axial direction also in the porous catalyst. This is justified because concentration 
differences at the surface of the wash coat are whipped out by convection. Because the 
concentration of the contaminant species is very low, you can assume the reaction term 
to be of first order (linear) with respect to the concentration, c. This is expressed in the 
rate equation where R denotes the reaction rate, k the pre-exponential factor, E the 
activation energy, T the temperature, and Rg the gas constant. The temperature 
dependence of the reaction rate is accounted for through the Arrhenius law.

S C A L I N G

Choose the following scaling variables: V(x, y) = U(x, y)/Um, x = x'/Rc,  y = y'/Rc, 
z = z'/L, and C = c/C0, where Um is the mean inlet velocity,  L the reactor length, Rc 
the radius (or maximum length) of the monolith channel, and C0 the inlet 
concentration. Rearranging Equations 8-31 and 8-32 accordingly gives:

U x y,( ) c∂
z'∂

------
x'∂
∂ D c∂

x'∂
-------⎝ ⎠

⎛ ⎞
y'∂
∂ D c∂

y'∂
-------⎝ ⎠

⎛ ⎞+= Ω1

x'∂
∂ Deff

c∂
x'∂

-------⎝ ⎠
⎛ ⎞

y'∂
∂ Deff

c∂
y'∂

-------⎝ ⎠
⎛ ⎞ R+ + 0= Ω2

R ke

E
RgT
-----------–⎝ ⎠

⎛ ⎞

c–= Ω2⎩
⎪
⎪
⎨
⎪
⎪
⎧

M O N O L I T H I C  R E A C T O R  |  463



464 |  C H A P T E
 (8-33)

In this case, use the following parameter values: K1 = 0.39 cm2/s, K2 = 11.2 cm2/s, 
D = 0.88 cm2/s, and Deff = 0.02 cm2/s.

Because of the absence of a second derivative in the z direction, it is possible to 
integrate the system using a time-dependent model with time representing the  z-axis. 
This assumption is an inherent property of the Pseudo modes in the Chemical 
Engineering Module.

Note that in case of other geometric configurations for the monolith channel, you 
must compute the velocity profile separately and use the solution in the equation for 
V(x,  y).

Results

Figure 8-18 shows the outlet concentration at time 1, that is, at the outflow of the 
reactor. Observe that the concentration in the solid phase drops rapidly toward zero 
close to the monolith wall. This is because the reaction in this model is quite rapid and 
the reacting gas is mostly consumed near the outer surface. It would therefore be 
preferable to coat the channels with a smaller amount of washcoat.

V x y,( )K1
C∂
z∂

-------
x∂

∂ D C∂
x∂

-------⎝ ⎠
⎛ ⎞

y∂
∂ D C∂

y∂
-------⎝ ⎠

⎛ ⎞+= Ω1

x∂
∂ Deff

C∂
x∂

-------⎝ ⎠
⎛ ⎞

y∂
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C∂
y∂

-------⎝ ⎠
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2

L
-------------------= Ω1

K2 ke

E
RgT
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2
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⎪
⎪
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Figure 8-18: Concentration distribution at outlet

Figure 8-19 shows a slice plot along the length of the monolithic reactor and gives an 
overview of the VOC concentration within the reactor and the catalyst.

Figure 8-19: Concentration distribution along the length of the reactor.
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It is important to investigate the amount of the contaminant gas flowing out from the 
reactor. The relevant measurable quantity is the bulk (mean) contaminant 
concentration, which is given by

.  (8-34)

Evaluating the integrals over the outlet, the average concentration as a fraction of the 
inlet concentration turns out to be 0.157. To improve the catalytic purification of the 
reactor, several parameters can be altered, for example, the length of the reactor, the 
temperature, or the shape of the channels.

Reference

1. Berg, M., Catalytic Combustion over High Temperature Stable Metal Oxides, 
1996, Licentiate of engineering thesis, KTH, TRITA-KET R50.

Model Library path: Chemical_Engineering_Module/
Transport_and_Reactions/monolithic_reactor

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics.

2 In the Model Navigator, select 2D from the Space dimension list.

3 From the Application Modes list, select 
Chemical Engineering Module>Pseudo 3D>Mass Transport>Convection and Diffusion.

4 Click OK.

O P T I O N S  A N D  S E T T I N G S

Axes/Grid Settings
1 From the Options menu, select Axes/Grid Settings.

c〈 〉
Vc sd

s∫
V sd

s∫
--------------------=
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2 Specify axis and grid settings according to the following table; when done, click OK.

Model Settings
Because the model uses dimensionless scaled variables, change the base unit system 
from the default SI to none:

1 From the Physics menu, select Model Settings.

2 From the Base unit system list, select None.

3 Click OK.

Constants
1 From the Options menu, select Constants.

2 Enter the following names, expressions, and descriptions; when done, click OK.

G E O M E T R Y  M O D E L I N G

1 Click the Ellipse/Circle (Centered) button on the Draw toolbar.

2 Right-click on the origin (0, 0), hold down the right mouse-button, and drag the 
mouse sideways until the circumference snaps to x = 1. Release the button.

3 Click the Line button. Click the points (0, 0), (1.032, 1.032), and (0, 1.032). 
Finally, right-click to close the triangle to a solid object.

4 Press Ctrl+A to select all objects.

5 Click the Create Composite Object button on the Draw toolbar. In the Set formula 
edit field, type CO1+CO1*E1. Click OK to form the composite object CO2.

6 Click the Zoom Extents button on the Main toolbar.

AXIS X-Y LIMITS GRID

x min -1.5 x spacing 1

x max 1.5 Extra x 1.032

y min -1.1 y spacing 1

y max 1.1 Extra y 1.032

NAME EXPRESSION DESCRIPTION

D 0.88 Diffusion coefficient, free gas

D_eff 0.02 Effective diffusion coefficient, catalyst

K1 0.39 Flow-velocity parameter

K2 11.2 Reaction-rate parameter
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P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Physics menu, open the Subdomain Settings dialog box. 

2 Specify settings according to the following table:

3 On the Init page, set the initial concentration c(t0) to 1 for both subdomains.

4 Click OK.

Boundary Conditions
The default boundary conditions (Insulation/Symmetry) apply.

M E S H  G E N E R A T I O N

You need a finer mesh in Subdomain 2 where the reaction takes place.

1 From the Mesh menu, select Free Mesh Parameters.

2 On the Subdomain page, set the Maximum element size to 0.1 and 0.015 for 
Subdomains 1 and 2, respectively.

3 Click Remesh.

4 When the mesher has finished, click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 Verify that the Times edit field entry is 0:0.1:1.

3 Click OK to close the Solver Parameters dialog box.

4 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 The default plot, Figure 8-18, shows the outlet concentration at time 1, that is, at 
the reactor outlet.

SETTINGS SUBDOMAIN 1 SUBDOMAIN 2

D (isotropic) D D_eff

R 0 -K2*c

udl K1*2*(1-x^2-y^2) 0
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2 To see the concentration along the whole channel (from z = 0 to z = 1), click the 
Animate button. You can save the movie by clicking the Save button in the movie 
dialog box.

To produce a slice plot of the full 3D geometry as depicted in Figure 8-19, use the 
cross-section plot capabilities of COMSOL Multiphysics:

3 From the Postprocessing menu, select Domain Plot Parameters.

4 On the General page, select all solutions in the Solutions to use list.

5 Click the Surface tab and select both subdomains in the list.

6 Click OK.

7 Experiment with the Increase Transparency buttons in the figure window.

To analyze Equation 8-34, perform the integration from the user interface 
according to the following procedure:

8 From the Postprocessing menu, select Subdomain Integration.

9 Select Subdomain 1 and type c*(1-x^2-y^2) in the Expression edit field. 

10 Click Apply. The result 0.030976 appears in the message log at the bottom of the user 
interface.

11 Type (1-x^2-y^2) in the Expression edit field, then click OK. The result is 0.19635.

The average concentration thus turns out to be 0.157.
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S e l e c t i v e  C a t a l y t i c  R edu c t i o n  o f  NOx

Introduction

The removal of pollutants from high-temperature gases is often required in 
combustion processes. In this example, the selective reduction of NOx by ammonia 
occurs as flue gas passes through a honeycomb reactor. The chemical reactions take 
place on the surface of a V2O5/TiO2 catalyst that is supported on a ceramic structure.

This example shows how to use the COMSOL Reaction Engineering Lab in concert 
with the Chemical Engineering Module to readily solve advanced engineering 
problems. You can start by setting up the reaction kinetics in the Reaction Engineering 
Lab and then model the chemistry assuming that each of the channels in the monolith 
behaves as a plug-flow reactor. This gives you a notion about the magnitude of 
important design parameters such as the residence time and selectivity as a function of 
temperature. In a second part of the example, you set up a reactor model taking the 
actual geometry of a monolith channel into account by exporting the reaction model 
from Reaction Engineering Lab to the Chemical Engineering Module. In the 
space-dependent model you can solve the mass-balance equations coupled to the 
momentum balances for free flow and porous media flow.

Note: Solving the first part of this model requires the COMSOL Reaction 
Engineering Lab. 

Model Definition

NO reduction by ammonia can be summarized by the following reaction:

 (8-35)

However, ammonia can at the same time undergo oxidation:

 (8-36)

When optimizing the conversion of NO, you consequently seek to minimize the 
oxidation reaction while maintaining a reasonable reaction rate for the reduction.

4NO 4N2O2+ 6H2O+4NH3+

4NO 4N2O2+ 6H2O+4NH3+
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The heterogeneous catalytic conversion of NO to N2 is described by an Eley-Rideal 
mechanism. A key reaction step involves the reaction of gas-phase NO with 
surface-adsorbed NH3. The following rate equation (mol/(m3·s)) has been suggested 
in Ref. 1 for Equation 8-35:

 (8-37)

where

 (8-38)

and

 (8-39)

For Equation 8-36, the reaction rate (mol/(m3·s)) is given by

 (8-40)

where

 (8-41)

This example investigates the conversion of NOx through two reactor models. You 
first set up and solve a plug-flow reactor in the COMSOL Reaction Engineering Lab, 
and then you solve a space-dependent reactor model using COMSOL Multiphysics.

Assuming steady, the design equation for a plug-flow reactor is given by:

 (8-42)

where Fi is the species molar flow rate (mol/s), V represents the reactor volume (m3), 
and is Ri the species net reaction rate (mol/(m3·s)). The molar flow rate is related to 
the species concentrations, ci (mol/m3), through the volumetric flow rate, v (m3/s):

 (8-43)

r1 k1cNO
acNH3

1 acNH3+
---------------------------=

k1 A1
E1

RgT
-----------–⎝ ⎠

⎛ ⎞exp=

a A0
E0

RgT
-----------–⎝ ⎠

⎛ ⎞exp=

r2 k2cNH3=

k2 A2
E2

RgT
-----------–⎝ ⎠

⎛ ⎞exp=

Fd i

Vd
--------- Ri=

Fi vci=
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where the volumetric flow rate is given by the average flow velocity, u (m/s), 
multiplied by the reactor cross-section  A (m2):

 (8-44)

The mass balances given by Equation 8-42 are set up and solved in the Reaction 
Engineering Lab.

The plug-flow model considerably simplifies the reaction conditions compared to 
actual reactors used in industry. In the extended example, the conversion of NOx 
occurs in a honeycomb reactor, which consists of packets of thin parallel channels 
through which the flue gas flows. The ceramic channel walls are coated with a porous 
catalytic layer, in this case V2O5/TiO2.

The transport and reaction of chemical species can be divided into several steps: First 
the reactants are transported in the direction of the flow, mainly by convection in the 
open channels. The reactants diffuse towards the walls and into the porous catalyst 
where they react on the catalyst surface. Formed products subsequently diffuse out of 
the porous structure and are transported out of the reactor through the open channels.

The model setup in COMSOL Multiphysics corresponds to a single channel of the 
honeycomb structure. The model assumes the channel is cylindrical, making it possible 
to reduce the modeling domain to a 2D geometry with rotational symmetry. The 
model geometry appears in Figure 8-20.

Figure 8-20: Geometry of a reactor-channel model taking axial symmetry into account. 
Dimensions are in meters (m).
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M O M E N T U M  TR A N S P O R T

The flow in the free channel is described by the Navier-Stokes equations:

 (8-45)

where ρ denotes density (kg/m3), u represents the velocity (m/s), η denotes viscosity 
(kg/(m· s)), and p equals pressure (Pa). In the porous domain, the Brinkman 
equations describe the flow:

 (8-46)

Here εp denotes the porosity (dimensionless) and  k refers to the permeability (m2) of 
the porous medium. As you can see in Equation 8-45 and Equation 8-46, the 
momentum-balance equations are closely related. The term on the right-hand side of 
the Navier-Stokes formulation corresponds to momentum transported by convection 
in free flow. In the Brinkman formulation, this term is replaced by a contribution 
associated with the drag force experienced by the fluid as it flows through a porous 
medium. COMSOL Multiphysics effortlessly combines free flow and porous-media 
flow.

The boundary conditions are

 (8-47)

At the outlet viscous stresses are ignored and the pressure is set to 1 atmosphere.

M A S S  T R A N S P O R T

The mass-balance equations for the model are the diffusion-convection equations at 
steady state:

 (8-48)

Here Di denotes the diffusion coefficient (m2/s), ci is the species concentration, and 
u equals the velocity vector (m/s). The term  Ri corresponds to the species’ net 
reaction rate, which is a function of the reaction rates, Equation 8-37 and 
Equation 8-40, and the reaction stoichiometry.

∇ η– ∇u ∇u( )T
+( ) pI+[ ]⋅ ρ u ∇⋅( )u–=

∇ u⋅ 0=

∇ η
εp
-----– ∇u ∇u( )T

+( ) pI+⋅ η
k
---u–=

∇ u⋅ 0=

u n⋅ v0=

u 0      =

p pref  =

inlet
walls

  outlet

∇ Di∇– ci ciu+( )⋅– Ri=
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In the free channel, the inlet conditions are equal to the inlet concentrations:

 (8-49)

At the outlet, use the convective flux condition

 (8-50)

All other boundaries use the insulating or symmetry condition

 (8-51)

TR A N S P O R T  P R O P E R T I E S

Setting up momentum and mass balances requires that certain physical properties 
characteristic of the reacting fluid are determined. For instance, the Navier-Stokes 
equation (Equation 8-45) and the Brinkman equation (Equation 8-46) both require 
the fluid viscosity. Furthermore, the mass balances need species specific diffusion 
coefficients as input.

For reacting gas mixtures, the Reaction Engineering Lab makes use of kinetic gas 
theory to set up expressions for transport properties such as binary diffusivities, 
viscosity, and thermal conductivity as functions of temperature, pressure, and 
composition. In this example, the diffusivities (m2/s) are calculated using the formula:

 (8-52)

where ΩD is a collision integral

.  (8-53)

Furthermore gas viscosity (Ns/m2) is given by the expression:

 (8-54)

where Ωv is a collision integral

.  (8-55)

c cin=

n D∇– c( )⋅ 0=

n D∇– c cu+( )⋅ 0=

D 2.695 10 3– T3 MA MB+( ) 2 103M⋅ AMB( )⁄( )
pσAσBΩD

-------------------------------------------------------------------------------------------⋅ ⋅=

ΩD f T σ ε
k
--- µ, , ,⎝ ⎠

⎛ ⎞=

η 2.699 10 6– T 1 103M⋅( )
σ2Ωv

------------------------------------⋅ ⋅=

Ωv f T σ ε
k
--- µ, , ,⎝ ⎠

⎛ ⎞=
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To evaluate Equation 8-52 and Equation 8-54, you need to specify the characteristic 
length and energy minimum of the Lennard-Jones interaction potential, that is σ 
(10-10 m) and the ε/k (K), respectively. The species dipole moment, µ (Debye), can 
also be provided. Each species in the reacting gas has a characteristic set of these 
constants, and you find their values in the literature, in databases, or from experiments. 
The parameters σ, ε/k, and µ can either be entered manually in the Reaction 
Engineering Lab GUI, or you can import text files containing the data. In this model 
you import transport data using the Import CHEMKIN File feature.

The structure of a CHEMKIN transport data file is illustrated below:

The first column indicates the species name; the second column contains an index 
describing the geometrical configuration of the molecule; the third column provides 
the value for ε/k; the fourth column lists the value for σ; the fifth column gives the 
value of µ; the sixth column indicates polarizability; and the seventh column lists 
rotational relaxation collision number.

The entries given in columns 1, 3, 4, and 5 are read into the Reaction Engineering Lab 
when selecting the menu item File>Import>CHEMKIN Transport Input File.

Resources for kinetic, thermodynamic, and transport data on the CHEMKIN format 
are available on the web (see, for instance, www.comsol.com/reaction).

Results

First review the results of the plug-flow model, which you set up and solve in the 
Reaction Engineering Lab.

Figure 8-21 shows the concentrations of NO and NH3 as functions of the reactor 
volume. Reactions take place at 523 K and that the gas enters the reactor with a 
velocity of 0.3 m/s. The reactor is assumed to be a channel with a length of 0.36 m 

NO 0 97.500 3.620 0.000 0.000 0.000

NH3 0 558.300 2.900 1.470 0.000 0.000

O2 0 106.700 3.470 0.000 0.000 0.000

N2 0 71.400 3.800 0.000 0.000 0.000

H2O 0 809.100 2.640 1.880 0.000 0.000
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and a radius of 2 mm. Under these conditions, the simulations show that most of the 
NO has been converted as the gas leaves the reactor (NO converted > 99%).

Figure 8-21: Concentrations of NO and NH3 as functions of axial distance from the 
reactor inlet. S is the selectivity parameter.

The plot also shows the selectivity parameter, S, giving the ratio of reaction rates 
according to

 (8-56)

S varies between 3.6 and 2.7 along the reactor length, indicating that the reduction of 
NO is the dominating reaction pathway.

Figure 8-22 shows the initial reaction rate of NO reduction (r1) and NH3 oxidation 
(r2) in the temperature interval 450–750 K. Up to approximately 655 K, NH3 is 
mainly consumed by the desired reduction reaction, Equation 8-35. At about 670 K 
the rate of NO reduction reaches a maximum. Above this temperature the desorption 

S
r1
r2
-----=
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of NH3 from the catalyst surface becomes faster than the reaction of adsorbed NH3 
with gas-phase NO.

Figure 8-22: Initial rates of NO reduction (Reaction rate 1) and NH3 oxidation 
(Reaction rate 2) as functions of temperature for the plug-flow reactor model.

The following results come from the space-dependent reactor model, which you set up 
and solve in COMSOL Multiphysics. In this case, the chemistry takes place in a 
channel of a honeycomb reactor.

Figure 8-23 shows the fluid velocity profile, given as a function of radial position at the 
channel midpoint.

Figure 8-23: Flow velocity as a function of radial position.
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Figure 8-24 displays the concentration of NO across the reactor channel. Integrating 
the boundary flux of NO across the inlet and outlet allows you to calculate the 
conversion of NO as being 89%.

Figure 8-24: Concentration of NO across the space-dependent model domain.

It is easy to extend the model to study the effects of different design parameters such 
as reaction temperature, inlet velocity, and geometry. It can also easily take into 
account the effect of material properties such as the permeability of the porous region.

Figure 8-25 compares the results of the plug-flow model and the reactor model 
including the actual channel geometry. For the channel model, the NO concentration 
shown is the average concentration evaluated along the section of channel length 
affected by the catalytic washcoat (0.36 m). The average inlet velocity in the channel 
model is 0.3 m/s.
R  8 :  TR A N S P O R T ,  R E A C T I O N S ,  A N D  R E A C T I O N  E N G I N E E R I N G



Figure 8-25: Concentration of NO (mol/m3) along the reactor channel. The solid line 
represents data from the plug-flow model and the dashed line represents the mean 
concentration evaluated from the channel model.

The assumptions underlying the plug-flow model readily explain the differences in 
results. In the plug-flow model, reactions are assumed to occur homogeneously 
throughout the reactor volume. Because the species need not be transported to and 
from the bulk flow to the reactive washcoat, as is the case in the channel model, the 
conversion of reactants is, of course, faster.

In summary: This example illustrates the modeling of a heterogeneous catalytic process 
using the COMSOL Reaction Engineering Lab and the Chemical Engineering 
Module. The Reaction Engineering Lab helps you set up the chemical kinetics and 
expressions describing the transport properties of the reacting mixture. In COMSOL 
Multiphysics you study the reacting flow in a specific reactor geometry.

Reference

1. G. Shaub, D. Unruh, J. Wang, and T. Turek, Chemical Engineering and 
Processing, vol. 42, p. 365, 2003.

The following path gives the location of the Reaction Engineering Lab model:

Model Library path: Combustion/nox_reduction
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The following path shows the location of the COMSOL Multiphysics model:

Model Library path:  
Chemical_Engineering_Module/Transport_and_Reactions/nox_reduction

Modeling Using the COMSOL Reaction Engineering Lab

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics.

2 In the Model Navigator, go to the Space dimension list and select Axial symmetry (2D).

3 Click OK.

The main user interface of COMSOL Multiphysics opens up.

4 From the File menu, select Reaction Engineering Lab.

The main user interface of COMSOL Reaction Engineering Lab opens up.

5 Click the COMSOL Reaction Engineering Lab window.

O P T I O N S  A N D  S E T T I N G S

1 Click the Model Settings button on the Main toolbar.

2 From the Reactor type list, select Plug-flow.

3 Select the Calculate thermodynamic properties check box.

4 Select the Calculate species transport properties check box.

5 On the General page, type 523 in the Temperature edit field.

6 On the Mass Balance page, type v_av*A in the Volumetric flow rate edit field.

7 Click Close.

R E A C T I O N S  I N T E R F A C E

1 Click the Reaction Settings button on the Main toolbar.

2 Make sure the Reactions page is active. Create two entries in the Reaction selection 

list by clicking the New button twice.
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3 Enter the following reaction formulas by first selecting the appropriate row in the 
Reaction selection list and then entering the corresponding text in the Formula edit 
field:

4 Select the first row in the Reaction selection list.

5 Select the Use Arrhenius expressions check box.

6 Type 1e6 in the A edit field and 60e3 in the E edit field.

7 Modify the predefined reaction rate according to Equation 8-37 on page 471 by 
typing kf_1*c_NO*a*c_NH3/(1+a*c_NH3) in the r edit field.

You define the expression for a later on.

8 Select the second row in the Reaction selection list.

9 Select the Use Arrhenius expressions check box.

10 Type 6.8e7 in the A edit field and 85e3 in the E edit field.

11 Modify the predefined reaction rate according to Equation 8-40 on page 471 by 
typing kf_2*c_NH3 in the r edit field.

S P E C I E S  I N T E R F A C E

1 Click the Species tab.

2 Check that the Species selection list has the five entries expected from entering the 
reaction formulas just given.

3 Click the General tab. Select the appropriate entry in the Species selection list and 
then enter the corresponding value for the Molecular weight:

REACTION ID # REACTION FORMULA

1 4NO+4NH3+O2=>4N2+6H2O

2 4NH3+3O2=>2N2+6H2O

SPECIES NAME  M [kg/mol]

NO 30e-3

NH3 17e-3

O2 32e-3

N2 28e-3

H2O 18e-3
S E L E C T I V E  C A T A L Y T I C  R E D U C T I O N  O F  N O X  |  481



482 |  C H A P T E
4 Select N2 from the Species selection list and choose Solvent from the Type list.

This selection is appropriate when a species is the main component of a reaction 
mixture. Setting a species as a Solvent removes its mass balance (the concentration is 
assumed to be constant). Furthermore, the thermodynamic and transport 
properties of the reacting mixture are based on the properties of the solvent species.

5 Click the Feed Stream tab. Select the appropriate entry in the Species selection list 
and then enter the corresponding value for the Inlet molar flow:

6 Select File>Import>CHEMKIN Transport Input File and browse to the file 
nox_reduction_transport.txt then click Import.

This imports the Lennard-Jones parameters required to set up expressions for the 
fluid viscosity and species diffusivities.

7 Click the Transport page and verify that the σ, ε/kB, and µ edit fields have been 
updated with the appropriate parameter values.

As an alternative to reading in the values from file, you can type in the appropriate 
values in the σ, ε/kB, and µ edit fields:

8 Click Close.

SPECIES NAME  F0 [mol/s]

NO 3.07e-8

NH3 3.96e-8

O2 6.67e-6

N2 7.23e-5

H2O 8.78e-6

SPECIES NAME  σ [m]  ε/kB [K]   µ [D]

NO 3.62 97.5 0

NH3 2.90 558.3 1.47

O2 3.47 106.7 0

N2 3.80 71.4 0

H2O 2.64 809.1 1.88
R  8 :  TR A N S P O R T ,  R E A C T I O N S ,  A N D  R E A C T I O N  E N G I N E E R I N G



O P T I O N S  A N D  S E T T I N G S

1 Choose Model>Constants and type in the following entries:

2 Click OK.

3 Choose Model>Expressions and type in the following entries:

4 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 In the Reactor volumes edit field, type pi*0.002^2*0.36, that is, the volume of the 
monolith channel.

3 Set the Relative tolerance to 1e-9 and the Absolute tolerance to 1e-10.

4 Set the Steady-state relative tolerance to 1e-12.

5 Click OK.

6 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The concentration transients of all species are plotted by default. Reproduce 
Figure 8-21 on page 476 and the plug-flow graph of Figure 8-25 on page 479 with 
the following steps:

1 Click the Plot Parameters button on the Main toolbar.

2 Remove all entries from the Quantities to plot list by clicking the << button.

3 In the Expression edit field type c_NO, then click the > button.

NAME EXPRESSION DESCRIPTION

A0 2.68e-17 Frequency factor (1/s)

E0 -243e3 Activation energy (J/mol)

rad 2e-3 Channel radius (m)

A pi*rad^2 Channel cross section

v_av 0.3 Average gas velocity (m/s)

NAME EXPRESSION DESCRIPTION

a A0*exp(-E0/(Rg*T)) Arrhenius expression

S r_1/r_2 Selectivity parameter

z t/A Axial distance from inlet
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4 In the x-axis data area, click first the lower option button and then the Expression 
button. In the Expression edit field, type z, then click OK.

5 From the Plot in list, select New figure. Click Apply to generate the first part of 
Figure 8-25 in a separate figure window; leave this window open.

6 In the Expression edit field type c_NH3, then click the > button.

7 In the Expression edit field type S/1000, then click the > button.

8 From the Plot in list, select Main axes, then click OK to generate the plot in 
Figure 8-21.

Now move on to see how temperature affects the initial reaction rates.

O P T I O N S  A N D  S E T T I N G S

1 Click the Model Settings button on the Main toolbar.

2 On the General page, type 450+300*t in the Temperature edit field.

As you later set the simulation time to 1 second, this imposes a temperature profile 
increasing linearly from 450 K at t = 0 to 750 K at t = 1 s.

3 Click Close.

S P E C I E S  I N T E R F A C E

1 Click the Reaction Settings button on the Main toolbar.

2 Click the Species tab.

3 Click the General tab.

4 Select NO from the Species selection list, then select the Lock concentration/activity 
check box.

5 Type F0_NO/(v_av*A) in the Initial concentration edit field.

Note how you can use the default variable name for the inlet molar flow and divide 
it by the volumetric flow to create an expression for the initial concentration.

6 Select NH3 from the Species selection list and select the Lock concentration/activity 
check box.

7 Type F0_NH3/(v_av*A) in the Initial concentration edit field.

8 Click Close.

By locking the concentrations of the species affecting the reaction rates r1 and r2 
you can evaluate the initial rates as functions of temperature.
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C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 In the Reactor volumes edit field type 1.

3 Click OK.

4 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Reproduce Figure 8-22 on page 477 with the following steps:

1 Click the Plot Parameters button on the Main toolbar.

2 Remove all entries from the Quantities to plot list by clicking the << button.

3 In the Predefined quantities list, select Reaction rate 1, then click the > button.

4 In the Predefined quantities list, select Reaction rate 2, then click the > button.

5 Click the Expression option button in the x-axis data area.

6 Click the Expression button and type T in the edit field. Click OK.

7 Click OK to close the Plot Parameters dialog box and generate the plot.

Now restore some of the settings in the Reaction Engineering Lab before moving on 
to export the reaction model to COMSOL Multiphysics.

O P T I O N S  A N D  S E T T I N G S

1 Click the Model Settings button on the Main toolbar.

2 Type 523 in the Temperature edit field.

3 Click Close.

S P E C I E S  I N T E R F A C E

1 Click the Reaction Settings button on the Main toolbar.

2 Click the Species tab.

3 Select NO from the Species selection list. Clear the Lock concentration/activity check 
box and type 0 in the Initial concentration edit field.

4 Select NH3 from the Species selection list. Clear the Lock concentration/activity check 
box and type 0 in the Initial concentration edit field.

5 Click Close.

E X P O R T  S E T T I N G S

1 Click the Export to COMSOL Multiphysics button on the Main toolbar.
S E L E C T I V E  C A T A L Y T I C  R E D U C T I O N  O F  N O X  |  485



486 |  C H A P T E
2 The Export to COMSOL Multiphysics dialog box appears.

3 Go to the Export mass balance area, and in the Application mode list select Convection 

and Diffusion: New.

4 In the Group name edit field type mass.

5 Move to the Export energy balance area and clear the check box in the upper left 
corner.

6 Go to the Export momentum balance area, and in the Application mode list select 
Incompressible Navier-Stokes: New.

7 In the Group name edit field type momentum.

8 Click the Export button at the bottom of the dialog box.

Modeling Using COMSOL Multiphysics

It is now time to investigate the chemistry taking place in a space-dependent model, in 
this case in a channel of a honeycomb reactor. After drawing the model geometry you 
use the application modes (predefined balance equations) of the Chemical Engineering 
Module to set up and solve mass and momentum balances.

Click the COMSOL Multiphysics window.

G E O M E T R Y  M O D E L I N G

Remember that in the axisymmetry modes, the symmetry axis is at  r (or x) = 0, and 
that the geometry is built to the right of the axis.

1 Press the Shift key and click the Rectangle/Square button.

2 Type the following values in the corresponding edit fields for the rectangle 
dimensions:

3 Click OK.

4 Press the Shift key again and click the Rectangle/Square button.

SIZE POSITION

Width 2e-3 r 0

Height 400e-3 z 0
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5 Type the following values in the corresponding edit fields for the rectangle 
dimensions:

6 Click OK.

Now zoom in on this very narrow geometry.

7 Choose Option>Axes/Grid Settings.

8 Clear the Axis equal check box. In the r-z limits area, enter the following settings:

9 Click OK.

O P T I O N S  A N D  S E T T I N G S

Constants
1 From the Options menu, select Constants.

2 Enter the following parameter names and values in the Constants dialog box:

3 Click OK.

SIZE POSITION

Width 1e-3 r 2e-3

Height 360e-3 z 20e-3

PROPERTY VALUE

r min -0.003

r max 0.005

z min -0.01

z max 0.41

NAME EXPRESSION DESCRIPTION

v_av 0.3[m/s] Average inlet velocity

p_ref 101325[Pa] Pressure

eps_p 0.4 Porosity

k 1e-8[m^2] Permeability

k_eff 0.25 Effectiveness factor

c_NO_in 8.16e-3[mol/m^3] Inlet concentration

c_NH3_in 1.05e-2[mol/m^3] Inlet concentration

c_O2_in 1.77[mol/m^3] Inlet concentration

c_H2O_in 2.33[mol/m^3] Inlet concentration
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Projection Coupling Variables
To enable a comparison between the plug-flow and channel models, it is of interest to 
calculate the NO concentration averaged over the channel cross section as a function 
of the axial coordinate along the reactor channel. This quantity is given by the integral

To make it available for postprocessing, define a projection coupling variable, 
co_NO_mean, according to the following instructions (for a description of projection 
coupling variables, see the section “Projection Coupling Variables” on page 270 of the 
COMSOL Multiphysics User’s Guide).

1 From the Options menu, select Projection Coupling Variables>Subdomain Variables.

2 On the Source page, select Subdomain 1, then enter the following data on the first 
row of the table:

3 Click the General transformation option button. In the Source transformation area, 
set x to z and y to r.

4 Click the Destination tab. From the Level list, select Boundary.

5 Select Boundary 5, then select the Use selected boundaries as destination check box.

6 In the Destination transformation area, set x to z, then click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings—Navier-Stokes Application Mode
1 From the Multiphysics menu, select Incompressible Navier-Stokes (chns).

2 From the Physics menu, select Properties. From the Analysis type list, select 
Stationary. Click OK.

3 From the Physics menu, select Subdomain Settings.

4 Select Subdomains 1 and 2 from the Subdomain selection list by pressing Ctrl+A and 
and clicking in the list.

5 From the Group list, select momentum.

Note how the Density and Dynamic viscosity edit fields are automatically filled in as 
a result of exporting the group momentum from the Reaction Engineering Lab.

NAME EXPRESSION INTEGRATION ORDER

c_NO_mean 2/(0.002^2)*r*c_NO 4

cNO,mean z( ) 1
A
---- c x( ) Ad

Ω
∫ 2

R2
------- cNO r z,( )r rd

0

R

∫= =
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6 Click the Init tab.

7 Type p_ref in the Pressure edit field.

8 Go back to the Physics tab.

9 Select Subdomain 2 (the porous-medium subdomain) from the Subdomain selection 
list.

10 Select the Flow in porous media check box.

11 Type eps_p in the Porosity edit field and k in the Permeability edit field.

12 Click OK.

Boundary Conditions—Navier-Stokes Application Mode
1 From the Physics menu, select Boundary Settings.

2 Enter the boundary conditions according to the following table:

Here you set up a parabolic inlet-velocity profile at the channel inlet. The velocity 
expression uses the built-in parameterization variable s that is available on 
boundaries in 2D. The value of s runs from 0 to 1 along any given boundary.

3 Click OK.

Subdomain Settings—Convection and Diffusion
1 From the Multiphysics menu, select Convection and Diffusion (chcd).

2 From the Physics menu, select Properties. From the Analysis type list, select 
Stationary. Click OK.

3 From the Physics menu, select Subdomain Settings.

4 Select Subdomains 1 and 2 from the Subdomain selection list by pressing Ctrl+A and 
and clicking in the list.

5 Select mass from the Group list.

Note how the Diffusion coefficient and Reaction rate edit fields are automatically filled 
in as a result of exporting the group mass from the Reaction Engineering Lab.

SETTINGS BOUNDARY 1 BOUNDARY 2 BOUNDARY 3 ALL OTHERS

Boundary 
type

Symmetry 
boundary

Inlet Outlet Wall

Boundary 
condition

Axial symmetry Velocity Pressure, no 
viscous stress

No slip

u0 0

v0 v_av*2*(1-s^2)

p0 p_ref
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6 Click the c_NO tab.

7 Type u in the r-velocity edit field and v in the z-velocity edit field.

8 Repeat Steps 6 and 7 for the remaining species (c_NH3, c_O2, and c_H2O) by clicking 
their respective tabs.

9 Select Subdomain 1 from the Subdomain selection list.

10 Click the c_NO tab.

11 As no reaction takes place in the gas phase, type 0 in the Reaction rate edit field.

12 Repeat Step 11 for the remaining species (c_NH3, c_O2, and c_H2O) by clicking their 
respective tabs.

13 Select Subdomain 2 from the Subdomain selection list.

You must somewhat modify the gas-phase diffusivities exported from the Reaction 
Engineering Lab to represent the corresponding diffusivities in the porous domain. 
The effective diffusivity (Di,eff) in a porous material is related to the gas-phase 
diffusivity (Di) by

where,  is the porosity, σ gives the constriction factor, and τ equals the tortuosity. 
Here, the material properties are grouped into the factor 

14 Click the c_NO tab.

15 In the Diffusion coefficient edit field, modify the existing expression by typing k_eff* 
at the beginning of the expression, then click Apply.

16 Repeat Step 15 for the remaining species (c_NH3, c_O2, and c_H2O) by clicking their 
respective tabs.

17 Click OK.

Boundary Conditions—Convection and Diffusion
1 From the Physics menu, select Boundary Settings.

2 Enter the boundary conditions for each of the species c_NO, c_NH3, c_O2, and c_H2O 

according to the following table:

SETTINGS BOUNDARY 1 BOUNDARY 2 BOUNDARY 3 ALL OTHERS

Type Axial 
symmetry

Concentration Convective 
flux

Insulation/
Symmetry

c_NO0 c_NO_in

c_NH30 c_NH3_in

Di eff,
φσDi

τ
-------------=

φ
keff φσ τ⁄ .=
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3 Click OK.

M E S H  G E N E R A T I O N

Because projection coupling variables require simplex mesh elements, you must use a 
triangular mesh.

1 From the Mesh menu, choose Free Mesh Parameters.

2 On the Global page, select Extremely fine from the Predefined mesh sizes list.

To fully resolve this model requires a very dense mesh; the above setting results in 
a model size of roughly 386,000 degrees of freedom. If you want to reduce memory 
consumption and solution time at the cost of obtaining a solution which is 
numerically slightly inaccurate, you can select the mesh size Extra fine instead.

3 Click the Advanced tab. Set the r-direction scale factor to 100. This setting is 
necessary to obtain a sufficient mesh resolution in the radial direction.

4 Click the Remesh button, then click OK.

C O M P U T I N G  T H E  S O L U T I O N

It is not necessary to solve both the momentum and mass balances simultaneously 
because the fluid flow is independent of the concentration. Therefore, to save time and 
computer memory, first solve the momentum balances and then solve the mass 
balances on the existing flow profile.

1 From the Solve menu, select Solver Parameters.

2 From the Solver list, select Stationary.

3 Go to the Advanced page.

4 In the Type of scaling list, select None.

5 Click OK.

6 From the Solve menu, select Solver Manager.

7 On the Solve For page, select Incompressible Navier-Stokes in the Solve for variables 
tree.

8 Click the Solve button. The solution time is around 2 minutes.

9 On the Initial Value page click the Store Solution button.

10 Click the Stored solution option button in the Initial value area.

c_O20 c_O2_in

c_H2O0 c_H2O_in

SETTINGS BOUNDARY 1 BOUNDARY 2 BOUNDARY 3 ALL OTHERS
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11 Return to the Solve For page and select Convection and Diffusion.

12 Click OK.

13 Click the Solve button on the Main toolbar. The solution time is roughly 4 minutes.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows the concentration of NO across the modeling domain, as seen 
in Figure 8-24 on page 478.

The following steps reproduce Figure 8-23 on page 477:

1 From the Postprocessing menu, open the Cross-Section Plot Parameters dialog box.

2 On the General page, clear the Display cross-section in main axes check box.

3 On the Line/Extrusion page, select Incompressible Navier-Stokes (chns)>z-velocity 
from the Predefined quantities list.

4 In the x-axis data area, click first the lower option button and then the Expression 
button to open the X-Axis Data dialog box. Type r in the Expression edit field, then 
select mm from the Unit list. Click OK to close the dialog box.

5 In the Cross-Section Plot Parameters dialog box, go to the Cross-section line data area.

6 Type 0 in the r0 edit field and 0.003 in the r1 edit field.

7 Type 0.2 in both the z0 and z1 edit fields.

8 Click OK to close the dialog box and generate the plot.

To finish the plot in Figure 8-25 on page 479, follow these instructions.

1 From the Postprocessing menu, open the Domain Plot Parameters dialog box.

2 On the General page, select the Keep current plot check box. From the Plot in list, 
select the figure window in which you plotted the first graph (Figure 1, unless you 
had any open figure windows from previous modeling sessions). If you do not have 
the COMSOL Reaction Engineering Lab, select New window instead.

3 Go to the Line/Extrusion page and select Boundary 5. In the y-axis data area, type 
c_NO_mean in the Expression edit field.

4 Click the Line Settings button. From the Line color list, select Color, then click the 
Color button. In the Line Color dialog box, select a green color, then click OK. From 
the Line style list, select Dashed line, then click OK to close the Line Settings dialog 
box.

5 Click OK to close the Domain Plot Parameters dialog box and generate the plot.
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6 Click the Edit Plot toolbar button in the figure window, then use the Edit Plot dialog 
box to edit plot title, axis labels, and legends.

To calculate the conversion of NO to N2, perform an integration of the mass flux over 
the inlet and outlet:

1 From the Postprocessing menu, select Boundary Integration.

2 Select Boundary 2 (the inlet), and then in the Predefined quantities list select 
Convection and Diffusion>Normal total flux, c_NO.

3 Select the check box beside Compute surface integral (for axisymmetric modes).

4 Click Apply.

5 Select Boundary 3 (the outlet).

6 Click OK.

The values from the flux integrations appear in the message log at the bottom of the 
user interface. The inlet integration yields −3.08·10−8 mol/s, while outlet 
integration yields 3.5·10−9 mol/s. The flux is defined as leaving the geometry 
domain, hence the minus sign at the inlet. The conversion of NO becomes

3.08 0.35–
3.08

----------------------------- 0.89=
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Po r ou s  R e a c t o r  w i t h  I n j e c t i o n  Ne ed l e

Introduction

This model treats the flow field and species distribution in an experimental reactor for 
studies of heterogeneous catalysis. The model exemplifies the coupling of free and 
porous media flow in fixed bed reactors. The model was inspired by numerical 
experiments performed by Professor Finlayson’s graduate students in chemical 
engineering at the University of Washington in Seattle.

Model Definition

The reactor consists of a tubular structure with an injection tube whose main axis is 
perpendicular to the reactor axis. The incoming species in the main and injection tubes 
react in a fixed porous catalyst bed. The model couples the free fluid and porous media 
flow through the Navier-Stokes equations and Brinkman’s extension of Darcy’s law. 
Because of symmetry, you need only model one half of the reactor; see Figure 8-26.

Figure 8-26: The species A and B enter the reactor from the main and injection tubes, 
respectively, and react in a fixed porous catalyst bed to produce C.

In the porous bed, a reaction takes place that consumes species A and B and produces 
C:

 (8-57)

Inlet species A

Outlet A, B, C

Production of C
in porous bed

Inlet species B

A B C→+
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D O M A I N  E Q U A T I O N S

The stationary Navier-Stokes equations describe the fluid flow in the free-flow regions: 

 (8-58)

In the porous bed, use the Brinkman equations:

 (8-59)

In the above equations, η denotes the viscosity of the fluid (Ns/m2), εp is the porosity 
(dimensionless), u the velocity (m/s), ρ the density (kg/m3), p the pressure (Pa), and 
κ the permeability (m2).

Assume that the modeled species are present in low concentrations compared to the 
solvent gas. This means that you can use a Fickian approach for the diffusion term in 
the mass transport. Model the mass transport for the three species A, B, and C with the 
convection-diffusion equation

 (8-60)

In this equation, ci denotes the concentration (mol/m3), Di the diffusivity (m2 /s), 
and Ri the reaction rate for species i (mol/(m3·s)). Because the reaction takes place in 
the porous bed only, the reaction term is zero in the free-flow regions. The reaction 
rates are given by

 (8-61)

where k is the reaction rate constant.

B O U N D A R Y  C O N D I T I O N S

At the inlet boundaries, assume fully developed laminar flow. The velocities are then 
given by

 (8-62)

∇ η– ∇u ∇u( )T
+( ) pI+[ ]⋅ ρ u ∇⋅( )u–=

∇ u⋅ 0=

∇ η
εp
-----– ∇u ∇u( )T

+( ) pI+⋅ η
k
---u–=

∇ u⋅ 0=

∇ Di ci ciu+∇–( )⋅ Ri=

RA kc– AcB=

RB kc– AcB=

RC kcAcB=

n u⋅ umax 1 r
R
----⎝ ⎠
⎛ ⎞ 2

–⎝ ⎠
⎛ ⎞=
P O R O U S  R E A C T O R  W I T H  I N J E C T I O N  N E E D L E  |  495



496 |  C H A P T E
where n is the boundary normal vector, and r is the distance from the center of the 
circular cross-section of radius R. The boundary condition for the Navier-Stokes 
equations at the outlet reads

 (8-63)

where t is any tangential vector to the boundary. 

In the mass transport, the concentrations at the inlet are fixed:

 (8-64)

At the outlet, assume that convection dominates the mass transport:

 (8-65)

This implies that the gradient of ci in the direction perpendicular to the outlet 
boundary is negligible. This is a common assumption for tubular reactors with a high 
degree of transport by convection in the direction of the main reactor axis. The 
condition eliminates the need for specifying a concentration or a fixed value for the flux 
at the outlet boundary. At all other boundaries, insulating conditions apply:

 (8-66)

Results

Figure 8-27 shows the flowlines of the velocity field and slices of the modulus of the 
velocity vector. The flow is almost homogeneous in the porous part of the reactor.

t u⋅ 0=

p 0=

ci ci0 inlet,=

n Di ci ciu+∇–( )⋅ n ciu⋅=

n Di ci ciu+∇–( )⋅ 0=
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Figure 8-27: Flowlines and slices of the velocity field.

Figure 8-28 shows the pressure drop, which occurs mainly across the porous bed.

Figure 8-28: The pressure drop across the reactor.
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Figure 8-29 and Figure 8-30 show the concentrations of species A and B, respectively. 

Figure 8-29: Iso-concentration surfaces for species A.

Figure 8-30: Iso-concentration surfaces for species B.
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Figure 8-29 shows that the concentration of the injected species A decays very rapidly 
with the distance from the injection point. This implies that the porous bed is not 
optimally used. Figure 8-30 shows the iso-concentration surfaces of species B, which 
is introduced in the main channel of the reactor. The reaction is not uniformly 
distributed in the catalytic bed and has its maximum close to the radial position of the 
injection pipe. The low concentration of B at the injection point is due to dilution by 
the solvent that carries species A.

In summary, the model shows that the injection point is far too close to the porous 
bed. The reactants are not well mixed and only a fraction of the bed is utilized. A 
proper design should include a small static mixer after the injection point or a 
positioning of the injection point further upstream in order to obtain mixing through 
diffusion.

The following path shows the location of the COMSOL Multiphysics model:

Model Library path:  

Chemical_Engineering_Module/Transport_and_Reactions/porous_reactor

Modeling Using the Graphical User Interface

1 Start COMSOL Multiphysics.

2 In the Model Navigator, select 3D from the Space dimension list.

3 Click the Multiphysics button.

4 Select the application mode Chemical Engineering Module>Momentum Transport> 
Laminar Flow>Incompressible Navier-Stokes and click Add.

5 Select the application mode Chemical Engineering Module>Mass Transport> 
Convection and Diffusion. In the Dependent variables edit field, type c_A c_B c_C. 
Click Add.

6 Click OK.
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O P T I O N S  A N D  S E T T I N G S

1 Enter the following constants in the Options>Constants dialog box:

2 Click OK.

G E O M E T R Y  M O D E L I N G

1 Click the Cylinder button on the Draw toolbar and enter cylinder properties 
according to the following table:

2 Click OK.

3 Click the Zoom Extents button on the Main toolbar.

NAME EXPRESSION DESCRIPTION

rho 1[kg/m^3] Fluid density

eta 1e-5[Pa*s] Viscosity

epsilon 0.4 Porosity, catalyst bed

kappa 1e-9[m^2] Permeability, catalyst bed

w_pipe 5[cm/s] Maximal inlet velocity, species A

r_p 0.3[mm] Pipe radius

u_tube 5[cm/s] Maximal inlet velocity, species B

r_t 1[mm] Tube radius

D_A 1e-6[m^2/s] Diffusivity, species A

D_B 1e-6[m^2/s] Diffusivity, species B

D_C 1e-6[m^2/s] Diffusivity, species C

k 0.01[mol*s/m^3] Reaction rate constant

c_A0 7000[mol/m^3] Inlet concentration of A

c_B0 1000[mol/m^3] Inlet concentration of B

PROPERTY VALUE

Radius 1e-3

Height 1e-2

Axis base point x 0

Axis base point y 0

Axis base point z 0

Axis direction vector x 1

Axis direction vector y 0

Axis direction vector z 0
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4 Create three more cylinders according to:

5 Click the Block button and specify a block with the following properties:

6 Click OK.

7 Click the Create Composite Object button on the Draw toolbar. In the Set formula 
edit field, type CYL1-CYL3, then click Apply.

8 In the Set formula edit field, type CO1+CYL4. Clear the Keep interior boundaries check 
box, then click Apply.

9 In the Set formula edit field, type CO2+CYL2. Select the Keep interior boundaries 
check box, then click Apply.

10 In the Set formula edit field, type CO1-BLK1. Make sure that the Keep interior 

boundaries check box is selected, then click OK.

P H Y S I C S  S E T T I N G S

From the Multiphysics menu, select 1 Incompressible Navier-Stokes (chns).

Subdomain Settings—Navier-Stokes
1 Select Subdomain Settings from the Physics menu.

PROPERTY CYLINDER 2 CYLINDER 3 CYLINDER 4

Radius 1e-3 4e-4 3e-4

Height 3e-3 2e-3 2e-3

Axis base point x 5e-3 3e-3 3e-3

Axis base point y 0 0 0

Axis base point z 0 0 0

Axis direction vector x 1 0 0

Axis direction vector y 0 0 0

Axis direction vector z 0 1 1

PROPERTY VALUE 2

Length x 1e-2

Length y 1e-3

Length z 3e-3

Axis base point x 0

Axis base point y -1e-3

Axis base point z -1e-3
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S

2 Select Subdomain 2 from the Subdomain selection list.

3 Select the Flow in porous media (Brinkman equations) check box.

4 Type rho in the Density edit field, eta in the Dynamic viscosity edit field, epsilon 
in the Porosity edit field, and kappa in the Permeability edit field.

5 Select Subdomains 1 and 3 from the Subdomain selection list.

6 Type rho in the Density edit field and eta in the Dynamic viscosity edit field.

7 Click OK.

Boundary Settings—Navier-Stokes
To define the boundary conditions in a simple manner, define two expressions at the 
boundary level.

1 Select Expressions>Boundary Expressions from the Options menu.

2 Enter boundary expressions according to the following table:

3 Click OK.

4 From the Physics menu, open the Boundary Settings dialog box.

5 Enter boundary conditions according to the table below.

6 Click OK.

Subdomain Settings—Convection and Diffusion
1 From the Multiphysics menu, select 2 Convection and Diffusion (chcd).

2 From the Physics menu, select Subdomain Settings.

NAME BOUNDARY 1 
/EXPRESSION

BOUNDARY 8 
/EXPRESSION

r_tube sqrt(z^2+y^2)

r_pipe sqrt((x-3e-3)^2+y^2)

SETTINGS BOUNDARY 8 BOUNDARY 1 BOUNDARY 19 BOUNDARIES 2, 12, 16 ALL OTHER

Boundary 
type

Inlet Inlet Outlet Symmetry 
boundary

Wall

Boundary 
condition

Velocity Velocity Pressure, no 
viscous stress

No slip

U0 w_pipe* 
(1-r_pipe^2/
r_p^2)

u_tube* 
(1-r_tube
^2/r_t^2)

- - -

p0 - - 0 - -
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3 Select all subdomains in the Subdomain selection list by pressing Crtl+A and clicking 
the list.

4 On each of the pages c_A, c_B, and c_C, in turn, enter the appropriate settings from 
the following table:

5 Select Subdomain 2 in the Subdomain selection list.

6 On each of the pages c_A, c_B, and c_C, in turn, enter the following settings:

7 Click OK.

Boundary Settings—Convection and Diffusion
1 From the Physics menu, open the Boundary Settings dialog box.

2 On the c_A page, enter the following boundary conditions for species A:

3 On the c_B page, enter the following boundary conditions for species B:

PROPERTY  c_A  c_B  c_C

D (isotropic) D_A D_B D_C

u u u u

v v v v

w w w w

PROPERTY  c_A  c_B  c_C

R -k*c_A*c_B -k*c_A*c_B k*c_A*c_B

SETTINGS BOUNDARY 1 BOUNDARY 8 BOUNDARY 19 ALL OTHERS

Boundary 
condition

Concentration Concentration Convective 
flux

Insulation/ 
Symmetry

c_A0 0 c_A0 - -

SETTINGS BOUNDARY 1 BOUNDARY 8 BOUNDARY 19 ALL OTHERS

Boundary 
condition

Concentration Concentration Convective 
flux

Insulation/ 
Symmetry

c_B0 c_B0 0 - -
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4 On the c_C page, enter the following boundary conditions for species C:

5 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, open the Free Mesh Parameters dialog box.

2 Click the Custom mesh size option button.

3 In the Maximum element size edit field, type 4e-4.

4 Click Remesh, then click OK.

C O M P U T I N G  T H E  S O L U T I O N

Because the velocity field is independent of the concentrations, you can compute the 
velocity field first.

1 Click the Solver Manager button on the Main toolbar.

2 On the Solve For page, select Incompressible Navier-Stokes (chns).

3 Click the Solve button.

4 Click the Initial Value tab. Click the Store Solution button.

5 In the Initial value area, select the Stored solution option button.

6 Click the Solve For tab.

7 Select Convection and Diffusion (chcd) from the list.

8 Click OK.

9 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate Figure 8-27, execute the following instructions:

1 Click the Plot Parameters button on the main toolbar.

2 On the General page, select the Slice and Streamline check boxes in the Plot type area.

3 On the Slice page, select x-velocity from the Predefined quantities list.

4 Set x levels to 8.

5 Click the Streamline tab.

SETTINGS BOUNDARIES 1, 8 BOUNDARY19 ALL OTHERS

Boundary condition Concentration Convective 
flux

Insulation/ 
Symmetry

c_C0 0 - -
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6 Click the Line Color tab.

7 Click the Uniform color option button.

8 Click the Color button and select yellow. Click OK.

9 Set Line type to Tube, then open the Tube Radius Parameters dialog box.

10 Clear the Auto check box and set Radius scale factor to 0.4. Click OK to close the 
Tube radius dialog box.

11 Click OK to generate the figure.

To generate Figure 8-28; proceed as follows:

1 On the General page in the Plot Parameters dialog box, clear the Slice and Streamline 
check boxes in the Plot type area.

2 Select the Boundary check box.

3 Click the Boundary tab.

4 From the Predefined quantities list, select Pressure.

5 Click OK.

Next, generate Figure 8-29 with the following steps:

1 On the General page in the Plot Parameters dialog box, clear the Boundary check box.

2 Select the Isosurface check box.

3 Go to the Isosurface page.

4 Select Convection and Diffusion (chcd)>Concentration, c_A from the 
Predefined quantities list.

5 Type 20 in the Number of levels edit field.

6 Click OK.

Generate Figure 8-30 in the same way using c_B as isosurface data.
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C a r b on Depo s i t i o n  i n  He t e r o g en eou s  
C a t a l y s i s

Introduction

Carbon deposition onto the surface of solid catalysts is commonly observed in 
hydrocarbon processing. Carbon deposits can affect both the activity of catalysts as 
well as the flow of gas through a catalyst bed.

This example investigates the thermal decomposition of methane into hydrogen and 
solid carbon. In the first model you look at the isothermal process occurring in an ideal 
reactor, simulated in the Reaction Engineering Lab. The influence of carbon 
deposition on catalyst activity is also considered. In the second model, you study the 
effect that the carbon deposits have on the fluid flow. The second simulation takes 
place in COMSOL Multiphysics taking both time and space dependencies into 
account.

Model Definition

C H E M I S T R Y

Methane decomposes over a Ni/Al2O3 catalyst according to the overall chemical 
reaction:

 (8-67)

The following reaction rate expression has been reported in the literature (Ref. 1).

 (8-68)

where

 (8-69)

C +CH4 2H2

r k
pCH4

pH2
2

Kp
----------–

1 kH pH2+( )
2

----------------------------------------⋅=

k 20.492 104200
RgT

--------------------–⎝ ⎠
⎛ ⎞exp=
R  8 :  TR A N S P O R T ,  R E A C T I O N S ,  A N D  R E A C T I O N  E N G I N E E R I N G



 (8-70)

and

 (8-71)

I D E A L  R E A C T O R  M O D E L

The first model is set up in Reaction Engineering Lab. This treats the isothermal 
decomposition of methane (Equation 8-67) in a perfectly mixed reactor with constant 
volume. The species mass balances are summarized by:

 (8-72)

The rate term, Ri, takes into account the reaction stoichiometry, νi, the reaction rate, 
r, and the catalyst activity, a:

 (8-73)

The mass balances of the reacting species are then:

 (8-74)

 (8-75)

 (8-76)

The time dependency of the catalytic activity is expressed by the ODE:

 (8-77)

where

 (8-78)

kH
163200

RgT
-------------------- 22.426–⎝ ⎠
⎛ ⎞exp=

Kp 5.088 105 91200
RgT

----------------–⎝ ⎠
⎛ ⎞exp⋅ ⋅=

dci

dt
-------- Ri=

Ri νira=

dcCH4
dt

----------------- ra–=

dcC
dt

---------- ra=

dcH2
dt

------------- 2ra=

da
dt
------- kar2cCa–=

ka
135600

RgT
-------------------- 32.007–⎝ ⎠
⎛ ⎞exp=
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Solving the mass balances provides the evolution of the species concentrations over 
time. The fact that carbon is in the solid phase is taken into account by removing its 
effect on gas phase physical properties. The pressure in the reactor is a function of only 
the methane and hydrogen concentrations:

 (8-79)

S P A C E -  A N D  T I M E - D E P E N D E N T  M O D E L

The second model is solved in COMSOL Multiphysics and takes both fluid flow and 
the chemical reaction into account.

The flow reactor is set up in 2D, as illustrated below:

Figure 8-31: A flow reactor is set up in 2D. Methane enters from the left and reacts in the 
porous catalytic bed in the mid-section of the geometry.

Methane first flows through a free section of the reactor, and then encounters a porous 
catalytic bed where the decomposition reaction takes place.

Momentum Balances
The flow in the free channel section is described by the Navier-Stokes equations:

 (8-80)

p RgT cCH4 cH2+( )=

Inlet outlet

wall

wall

porous catalytic bed

ρ∂u
∂t
------- ∇+ η– ∇u ∇u( )T

+( ) pI+[ ]⋅ ρ u ∇⋅( )u–=

∇ u⋅ 0=
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where ρ denotes density (kg/m3), u represents the velocity (m/s), η denotes viscosity 
(kg/(m· s)), and p equals pressure (Pa). In the porous domain, the Brinkman 
equations govern the flow:

 (8-81)

where εp is the porosity and k denotes permeability (m2) of the porous media. As you 
can see in Equation 8-80 and Equation 8-81, the momentum-balance equations are 
closely related. The term on the right-hand side of the Navier-Stokes formulation 
corresponds to momentum transported by convection in free flow. In the Brinkman 
formulation, this term is replaced by a contribution associated with the drag force 
experienced by the fluid as it flows through a porous medium. COMSOL Multiphysics 
automatically combines free and porous-media flow to solve the equations 
simultaneously.

The boundary conditions for the flow are:

 (8-82)

Mass transport in the reactor is described by the diffusion-convection equations:

 (8-83)

where Di denotes the diffusion coefficient (m2/s) and ci is the species concentration. 
The term Ri corresponds to the species’ net reaction rates.

In the free channel, the inlet conditions are equal to the inlet concentrations

 (8-84)

At the outlet, you use the convective flux condition

 (8-85)

All other boundaries use the insulating or symmetry condition

 (8-86)

ρ
εp
-----∂u

∂t
------- ∇+

η
εp
-----– ∇u ∇u( )T

+( ) pI+⋅ η
k
---u–=

∇ u⋅ 0=

u n⋅ u0=

u 0      =

p 0      =

inlet
walls

 outlet

∂ci

∂t
------- ∇ Di∇– ci ciu+( )⋅+ Ri=

c cin=

n D∇– c( )⋅ 0=

n D∇– c cu+( )⋅ 0=
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Balance for Void Fraction
The void fraction of the catalytic bed decreases as carbon is deposited. This in turn 
affects the flow through the reactor. A balance for the void fraction, or porosity, of the 
bed is given by:

 (8-87)

This equation can be implemented in the PDE, General Form application mode of 
COMSOL Multiphysics, resulting in porosity distribution across the catalytic bed as a 
function of time. The initial porosity of the bed is assumed to be ε = 0.4.

The porosity is related to the permeability of the porous domain by the expression 
(Ref. 2):

 (8-88)

In this way, the porosity balance couples the mass and momentum balances describing 
the reacting system.

Results 

I D E A L  R E A C T O R  M O D E L

The upper graph of Figure 8-32 shows the concentration transients of methane, 
hydrogen and deposited carbon, as methane decomposes over a Ni/Al2O3 catalyst.

dε
dt
------ εr

Mcρsoot
---------------------–=

k k0
ε
ε0
-----⎝ ⎠
⎛ ⎞ 3.55

=
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The lower graph is a plot of the reactor pressure. Deactivation of the catalyst is not 
taken into account at this point.

Figure 8-32: Upper graph: concentration transients of methane decomposition over a Ni/
Al2O3 catalyst. Lower graph: reactor pressure. Deactivation of the catalyst is not 
considered.

Taking catalyst deactivation into account (Equation 8-77) produces the results shown 
in Figure 8-33. Under the simulated conditions a moderate drop in activity is noted 
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(upper graph), leading to a largely unaffected overall process, as can be seen by 
comparing with the concentration transients of the previous model (lower graph).

Figure 8-33: Upper graph: catalyst activity drops off as carbon deposits at the catalyst 
surface. Lower graph: concentration transients of methane, hydrogen and deposited 
carbon with no deactivation present (solid lines) and with deactivation taken into 
account (dashed lines).

S P A C E -  A N D  T I M E - D E P E N D E N T  M O D E L

The following results concern a space- and time-dependent model simulated in 
COMSOL Multiphysics. Methane decomposition occurs in a porous region where 
solid catalyst particles are packed. Figure 8-34 shows the velocity field across the 
reactor prior to carbon deposition. The 2D plot shows that the velocity profile is 
parabolic in the free channel sections and close to constant in the porous domain. The 
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line plot in the bottom graph in Figure 8-34 shows the velocity along the reactor 
centerline.

Figure 8-34: Upper graph: velocity flow field in the 2D reactor domain. Lower graph: the 
gas velocity plotted along the reactor centerline.
C A R B O N  D E P O S I T I O N  I N  H E T E R O G E N E O U S  C A T A L Y S I S  |  513



514 |  C H A P T E
Reactions take place in the packed catalytic bed located in the mid section of the 
reactor. Figure 8-35 shows the concentration profiles along the centerline of the bed.

Figure 8-35: Methane and hydrogen concentrations as a function of the bed position.

The methane and hydrogen concentrations are equal after passing approximately 
0.18 m into the bed. Figure 8-34 shows that the velocity in the bed is near 
0.67·10−3 m/s, equaling a residence time of 270 s. This result agrees with the findings 
from the ideal reactor simulation, shown in Figure 8-32.

Now, consider the effects as methane is constantly supplied to the reactor for 
1000 seconds. The initial permeability is a constant 1·10−9 m2 across the bed. Note 
how the permeability at the front end of the bed changes by four orders of magnitude 
during the first 1000 s of carbon deposition.

Figure 8-36: Permeability of the packed catalytic bed as the decomposition of methane 
proceeds for 1000 s. The time interval between each line is 100 s.
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As carbon deposits in the reacting bed, the pressure distribution across the reactor is 
affected. Figure 8-37 shows a small, linear pressure drop as unreacting gas passes 
through a clean catalyst bed.

Figure 8-37: Distribution of pressure as an unreacting gas passes a clean catalyst 
bed.Upper graph: pressure distribution across the 2D reactor domain. Lower graph: 
pressure drop along the packed catalyst bed.
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Figure 8-38 shows the pressure distribution across the reactor after methane 
decomposition has occurred for 1000 s. The pressure drop is notably greater and 
occurs across the first 10 cm of the bed.

Figure 8-38: Distribution of pressure when methane decomposition has been allowed to 
occur for 1000 s. Upper graph: pressure distribution across the 2D reactor domain. Lower 
graph: pressure drop along the packed catalyst bed.
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The following path shows the location of the Reaction Engineering Lab model:

Model Library path: Process_Chemistry/carbon_deposition

The following path shows the location of the COMSOL Multiphysics model:

Model Library path: Reaction_Engineering_Lab/Process_Chemistry/
carbon_deposition

Modeling Using the COMSOL Reaction Engineering Lab

M O D E L  N A V I G A T O R

1 Start COMSOL Reaction Engineering Lab.

2 Click New in the Model Navigator window.

R E A C T I O N S  I N T E R F A C E

1 Click the Reaction Settings button on the Main toolbar.

2 Make sure the Reactions page is active. Create a new entry in the Reaction selection 
list by clicking the New button.

3 Type CH4=>C+2H2 in the Formula edit field.

4 Modify the predefined reaction rate according to Equation 8-68 by typing the 
following in the r edit field: c_a*k*(p_CH4-p_H2^2/Kp)/(1+kh*sqrt(p_H2))^2.

You will define the parameters and constants for the rate expression later on.

S P E C I E S  I N T E R F A C E

1 Click the Species tab.

2 Create a new entry in the Species selection list by clicking the New button.
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3 Type a in the Formula edit field.

When a new species is created a mass balance equation is set up along with it, in this 
case:

The left hand side is defined internally in the software and the right hand side 
corresponds to the expression given in the R edit field.

Note also that you can remove the effect of catalyst activity from your model by 
selecting the Lock concentration/activity check box. This removes the species mass 
balance and sets the concentration of the species to the value entered in the Initial 

concentration edit field.

4 Proceed to define the equation for the catalyst activity (Equation 8-77) by selecting 
species a from the Species selection list and typing -ka*r_1^2*c_C*c_a in the R edit 
field.

5 Select the appropriate entry from the Species selection list and then enter the 
corresponding value for the Initial concentration:

6 Click Close.

O P T I O N S  A N D  S E T T I N G S

1 Click the Model Settings button on the Main toolbar.

2 On the General page type 950 in the Temperature edit field.

3 In the p edit field, modify the predefined expression for the pressure to: 
Rg*T*(c_CH4+c_H2).

The predefined expression for the pressure in the reactor is:

You remove the contributions from the carbon species and the activity parameter, as 
they do not contribute to the gas phase pressure.

4 Click Close.

5 Select the menu item Model>Expressions.

SPECIES NAME c0

CH4 50

a 1

dca

dt
--------- Ra=

p RgT ci∑=
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6 Enter the following expressions by typing them in. Alternatively, click the Import 

Variables From File button and browse to the file: 
carbon_deposition_expressions.txt:

7 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 Type 1000 in the Times edit field.

3 Click OK.

4 Compute the solution by clicking the Solve Problem button on the Main toolbar.

E X P O R T  S E T T I N G S

You will now export the reaction model from Reaction Engineering Lab to COMSOL 
Multiphysics, and see how the chemistry of methane decomposition behaves in a time 
and space dependent system. The COMSOL Multiphysics model assumes that the 
catalyst activity is constant. The deposition of carbon, however, affects reactor 
performance because the deposits affect the permeability of the porous section of the 
reactor.

1 Click the Reaction Settings button on the Main toolbar.

2 Go to the Species page.

3 Select the a from the Species selection list and select the Lock concentration/activity 
check box.

The activity is assumed to be constant and equal to one. 

NAME EXPRESSION DESCRIPTION

k 2.31e-5*exp(20.492-104200/
Rg/T)

Arrhenius expression

Kp 5.088e5*exp(-91200/Rg/T) Arrhenius expression

kh exp(163200/Rg/T-22.426) Arrhenius expression

ka 43240*exp(135600/Rg/
T-32.077)

Arrhenius expression

p_CH4 c_CH4*Rg*T/100000 CH4 pressure (bar)

p_H2 c_H2*Rg*T/100000+eps H2 pressure (bar)
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4 Select the species C from the Species selection list and then select the Lock 

concentration/activity check box.

The purpose of this setting is to avoid the automatic set up of a mass balance 
equation for the species C in COMSOL Multiphysics. The effect of the carbon 
deposition rate will be taken into account by a balance equation for the reactor bed 
void fraction (Equation 8-87), that will be set up after the export.

5 Click Close.

6 Click the Export to COMSOL Multiphysics button on the Main toolbar.

7 Select 2D from the Space dimension list and click OK.

8 The Export to COMSOL Multiphysics dialog box appears.

9 Go to the Export mass balance area, and in the Application mode list select Convection 

and Diffusion: New.

10 In the Group name edit field type reactions.

11 Move to the Export energy balance area and clear the check box in the upper left 
corner.

12 Move to the Export momentum balance area and clear the check box in the upper left 
corner.

13 Click the Export button at the bottom of the dialog box.

Modeling Using COMSOL Multiphysics

Click the COMSOL Multiphysics window.

M O D E L  N A V I G A T O R

1 Select the menu item Multiphyiscs>Model Navigator.

2 In the Application Modes tree, select Chemical Engineering Module>Momentum 

Transport>Laminar Flow>Incompressible Navier-Stokes.

3 Click the Add button.

4 In the Application Modes tree, select COMSOL Multiphysics>PDE Modes>PDE, General 

Form.

5 Type por in the Dependent variables edit field, then click the Add button.

6 Click the OK button.

G E O M E T R Y  M O D E L I N G

1 Press the Shift key and click the Rectangle/Square button.
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2 Type the following values in the corresponding edit fields for the rectangle 
dimensions.

3 Click OK.

4 Press the Shift key again and click the Rectangle/Square button.

5 Type the following values in the corresponding edit fields for the rectangle 
dimensions

6 Click OK.

7 Click the Zoom Extents button on the Main toolbar.

P H Y S I C S  S E T T I N G S

Subdomain Settings—Navier-Stokes Application Mode
1 Select Incompressible Navier-Stokes (chns) from the Multiphysics menu.

2 Select Subdomain Settings from the Physics menu.

3 Select all subdomains by pressing Ctrl+A and clicking the Subdomain selection list.

4 Type 1 in the Density edit field.

5 Type 1e-5 in the Dynamic viscosity edit field.

6 Select Subdomain 2 (the porous media subdomain) from the Subdomain selection 
list.

7 Select the Flow in porous media (Brinkman equations) check box.

8 Type por in the Porosity edit field.

9 Type kappa in the Permeability edit field.

10 Click OK.

Boundary Conditions—Navier-Stokes Application Mode
1 Select Boundary Settings from the Physics menu.

SIZE POSITION

Width 1 x 0

Height 0.1 y 0

SIZE POSITION

Width 0.4 x 0.4

Height 0.1 y 0
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2 Enter the boundary settings according to the following table:

3 Click OK.

Subdomain Settings—Convection and Diffusion
1 From the Multiphysics menu select Convection and Diffusion (chcd).

2 From the Physics menu select Subdomain Settings.

3 From the Subdomain selection list, select Subdomain 2.

4 Select reactions from the Group list.

Note how the Reaction rate edit fields are automatically filled in as a result of 
exporting the group reactions from the Reaction Engineering Lab.

5 Select all subdomains by pressing Ctrl+A and clicking the Subdomain selection list.

6 On page c_CH4 type u in the x-velocity edit field and v in the y-velocity edit field.

7 Go to page c_H2 and type u in the x-velocity edit field and v in the y-velocity edit 
field.

8 Click Apply.

9 Click the Init page and type 50 in the c_CH4(t0) edit field.

10 Click Apply.

11 Type expressions into the Diffusion coefficient edit field according to the following 
table:

12 Click OK.

Boundary Conditions—Convection and Diffusion
1 From the Physics menu select Boundary Settings.

SETTINGS BOUNDARY 1 BOUNDARY 5,6 BOUNDARY 10 ALL OTHERS

Boundary 
type

Inlet Wall Outlet Wall

Boundary 
condition

Laminar inflow Slip Pressure No slip

U0 u_in

p0 0

SUBDOMAIN PAGE / C_CH4 PAGE / C_H2

1 D_CH4 D_H2

2 k_eff*D_CH4 k_eff*D_H2

3 D_CH4 D_H2
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2 Enter the boundary conditions for the species c_CH4 and c_H2 according to the 
following table:

3 Click OK.

Subdomain Settings—PDE, General Form
1 From the Multiphysics menu select PDE, General Form (g).

2 From the Physics menu select Subdomain Settings.

3 Select 1 and 3 in the Subdomain selection list and clear the Active in this domain check 
box.

4 Select 2 in the Subdomain selection list.

5 Type 0 in the two Flux vector edit fields.

6 Type -por*r_1_rxn_chcd/M_C/rho_soot in the Source term edit field.

The above settings have reduced the general form PDE

to the form of the void fraction balance (Equation 8-87)

7 Go to the Init page.

8 Type por0 in the por(t0) edit field.

9 Click OK.

Boundary Conditions—PDE, General Form
1 From the Physics menu select Boundary Settings.

2 Select Boundaries 4, 5, 6 and 7 and select the Neumann boundary condition option 
button.

3 Click OK.

SETTINGS BOUNDARY 1 BOUNDARY 10 ALL OTHER

Boundary condition Concentration Convective flux Insulation/Symmetry

c_CH40 cCH4_in

c_H20 cH2_in

ea
∂2ϕ

∂t2
--------- da

∂ϕ
∂t
------ ∇ Γ⋅+ + F=

da
∂ϕ
∂t
------ F εr

Mcρsoot
---------------------–= =
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O P T I O N S  A N D  S E T T I N G S

1 From the Options menu select Constants.

2 Enter the following parameter names and values in the Constants dialog box, either 
by typing them in, or by clicking the Import Variables From File button and browsing 
to the file: carbon_deposition_constants.txt, followed by clicking Open.

3 Click OK.

4 From the Options menu select Expressions>Scalar Expressions.

5 Enter the following parameter names and expressions, then click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu choose Free Mesh Parameters.

2 Click the Boundary tab.

3 Select the appropriate entries in the Boundary selection list and enter the following 
mesh settings:

4 Click the Remesh button and then the OK button.

NAME EXPRESSION DESCRIPTION

u_in 0.667e-3 average inlet velocity

cCH4_in 50 inlet concentration

cH2_in 0 inlet concentration

kappa0 1e-9 permeability of clean 
catalyst

por0 0.4 porosity of clean 
catalyst bed

rho_soot 4e3 density of soot deposits

M_C 12.011e-3 molar weight of carbon

D_CH4 1e-6 diffusion coefficient

D_H2 4e-6 diffusion coefficient

k_eff 0.1 effectiveness factor

NAME EXPRESSION DESCRIPTION

kappa kappa0*(por/por0)^3.55 permeability

BOUNDARY MAXIMUM ELEMENT SIZE

2-9 5e-3
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C O M P U T I N G  T H E  S O L U T I O N

Start by computing a flow field where chemical reactions are disregarded. This is to 
have a good starting guess for the flow when solving the coupled problem.

1 From the Solve menu select Solver Parameters.

2 Select Stationary from the Solver list.

3 Click OK.

4 From the Solve menu select Solver Manager.

5 On the Solve For page, select Incompressible Navier-Stokes (chns) in the Solve for 

variables tree.

6 Click the OK button.

7 Click the Solve button on the Main toolbar.

The following steps produce a plot of the flow field:

1 From the Postprocessing menu open the Plot Parameters dialog box.

2 Go to the Surface page.

3 Select Incompressible Navier-Stokes (chns)>Velocity field from the Predefined 

quantities list.

4 Go to the Arrow page and select the Arrow plot check box.

5 Select Incompressible Navier-Stokes (chns)>Velocity field from the Predefined 

quantities list.

6 Click OK.

Proceed to solve the time-dependent problem, which takes the chemical reactions and 
carbon deposition into account.

1 From the Solve menu select Solver Parameters.

2 Select Time dependent from the Solver list.

3 Type 0:100:1000 in the Times edit field.

4 Click OK.

5 From the Solve menu select Solver Manager.

6 On the Initial Value page click the Store Solution button.

7 Click the Stored solution option button in the Values of variables not solved for and 

linearization point area.
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8 Return to the Solve For page and select Convection and Diffusion (chcd) and PDE, 

General Form (g) from the Solve for variables tree, by pressing Ctrl and clicking the 
entries.

9 Click OK.

10 Click the Solve button on the Main toolbar.

Plot gas phase concentrations of methane and hydrogen in the reactive bed:

1 From the Postprocessing menu open the Cross-Section Plot Parameters dialog box.

2 On the General page, select 1000 from the Solutions to use list.

3 Select the Keep current plot check box.

4 Go to the Line/Extrusion page.

5 Select Convection and Diffusion (chcd)>Concentration, c_CH4 from the Predefined 

quantities list.

6 Enter the following parameters in the Cross-section line data area:

7 Click Apply.

8 Select Convection and Diffusion (chcd)>Concentration, c_H2 from the Predefined 

quantities list.

9 Click OK.

In the last simulation of this example, look at how the flow is affected by the deposition 
of soot in the porous bed.

1 From the Solve menu select Solver Manager.

2 On the Initial Value page click the Store Solution button.

3 In the Store Solution window, click OK to store all solutions.

4 Click the Stored solution option button in the Values of variables not solved for and 

linearization point area.

5 Select All from the Solution at time list.

EDIT FIELD VALUE

x0 0.4

y0 0.05

x1 0.8

y1 0.05
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6 On to the Solve For page, select Incompressible Navier-Stokes (chns) in the Solve for 

variables tree.

7 Click OK.

8 Click the Solve button on the Main toolbar.

To plot the permeability in the porous bed as a function of time follow these steps:

1 From the Postprocessing menu open the Cross-Section Plot Parameters dialog box.

2 On the General page, press Ctrl+A and click the Solutions to use list.

3 Select New figure from the Plot in list.

4 Go to the Line/Extrusion page.

5 Type kappa in the Expression edit field.

6 Click OK.

7 In the Figure window, click the y log button.

Finally, plot the reactor pressure after 1000 seconds.

1 From the Postprocessing menu open the Plot Parameters dialog box.

2 Go to the General page and select 1000 from the Solutions at time list.

3 Clear the Arrow check box.

4 Go to the Surface page.

5 Select Incompressible Navier-Stokes (chns)>Pressure from the Predefined quantities 

list.

6 Click OK.
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 9
E l e c t r o c h e m i c a l  C e l l s  a n d  
E l e c t r o c h e m i c a l  E n g i n e e r i n g  
This chapter contains examples of mass transport and balances coupled to 
momentum transport and electric fields, where the systems are affected by 
electrochemical reaction kinetics. COMSOL Multiphysics is well suited for these 
types of processes for two reasons:

• Its ability to model multiphysics applications easily and quickly. Often you need to 
model mass transport to a description of the electric potential field and 
sometimes fluid flow, both in free and porous media. Other models might also 
require energy transport. The reaction kinetics are often functions of 
concentration (mass transport), temperature (energy transport), pressure 
(momentum transport), and electric potential (Ohm’s law).

• Its ability to handle equation-based modeling. Electrochemical kinetics involve 
arduous equations that you can quickly enter into COMSOL Multiphysics. 
Furthermore, these systems often include large aspect ratios so the ability to 
quickly add scaling and corrections to diffusion coefficients and other material 
properties becomes important.
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Cu r r e n t  D i s t r i b u t i o n  i n  a  
Ch l o r - A l k a l i  Memb r an e  C e l l

Introduction

The chlor-alkali membrane process is one of the largest processes in industrial 
electrolysis with production of roughly 40 million metric tons of both chlorine and 
caustic soda per year (Ref. 1). Chlorine’s largest use is in the production of vinyl 
chloride monomer, which in turn is used for the production of poly vinyl chloride 
(PVC). Among the applications of PVC are as electrical insulator in cables and as a 
material for pipes, carpets, raincoats, and many other products. The production of 
chlorine implies a simultaneous production of caustic soda (alkali), which is widely 
used in the chemical industry for alkalization and neutralization of acidic streams. 
Caustic soda is also used in alkaline batteries.

The traditional process for manufacturing chlorine and caustic soda is the mercury-cell 
process. This technology has been partly replaced by the diaphragm process, and in 
later years the membrane process has been the dominating process in retrofits and for 
new plants. The purpose of the diaphragm or membrane is to separate the products 
chlorine and caustic soda, which otherwise would react to produce hypochlorite and 
hydrochloric acid. Chlorine and caustic soda are produced at the anode and cathode, 
respectively. Figure 9-1 shows a diagram of the process.

Current density in membrane-cell technology has increased dramatically during the 
last decade as the membranes themselves have improved. This results in lower 
investment costs for greater production. However, the increase in current density 
implies an increase in power consumption if nothing is done to dampen the voltage 
increase. Advances in cell design by increased internal convection, decreased ohmic 
losses, and better membranes have allowed for large increases in current density with 
small increases in cell voltage. One of the important parameters in the design of 
modern membrane cells is the current-density distribution on the electrode surfaces. 
It is important, from the viewpoint of catalyst lifetime and minimization of losses, that 
the current density on the electrode frontal surfaces is as uniform as possible.
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This example describes the current-density distribution in a realistic structure for the 
anodes and cathodes in a membrane cell. This discussion limits the model to one unit 
cell of the entire cell. This unit cell appears on the right side in Figure 9-1.

Figure 9-1: Drawing of the unit cell.

The anode and cathode ribs are separated by the membrane, which is a cation-selective 
membrane. It is forced to adapt its shape to fit within the inter-electrode distance. The 
membrane prevents mixing between brine and chlorine on the anode side with the 
caustic soda and hydrogen on the cathode side.

A detailed description of the process of chlor-alkali electrolysis is available in Ref. 1.

Model Definition

This example models the current and potential distribution in a unit cell in the 
membrane cell sketched in Figure 9-1. This model is a secondary current-distribution 
model (see Ref. 2), which implies that you take into account the dependence of the 
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electron transfer on the local potential, and that you assume constant composition in 
the subdomains. The electron transfer reactions at the anode and cathode surfaces are:

 (9-1)

The domain in the model is half of the unit cell shown in Figure 9-1, as explained in 
Figure 9-2.

Figure 9-2: The modeling geometry with subdomain and boundary labels.

The chemical reactions show that there is gas evolution in both the anodic and 
cathodic compartments, creating a vigorous internal convection in the respective 
compartments. This makes it possible to simplify the model by neglecting the 
concentration gradients in the anolyte and catholyte. The simplification implies that 
the transport of ionic current inside the cell takes place exclusively through migration, 
that is, the electric field induces a flux of ions. For this reason you do not need to model 
the complex problem of internal free convection of the two-phase flow in order to get 
an estimation of the current-density distribution in the cell.

2Cl- Cl2 g( ) 2e-
+=    at the anode

2H2O 2e-
+ 2OH- H2 g( )+=    at the cathode

Ωc

∂Ωc

Ωm

∂Ωouter

Ωa

∂Ωa

3.5mm
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The equation that gives the transport of charged species in the electrolyte is

 (9-2)

where Ni denotes the transport vector (mol/(m2·s)), ci denotes the concentration in 
the electrolyte (mol/m3), zi represents the charge number for the ionic species, ui 
indicates the mobility of the charged species (mol·m2/(J·s)), F is Faraday’s constant 
(C/mol),  equals the potential in the electrolyte (V), and u is the velocity (m/s). If 
you neglect transport by diffusion in the electrolyte, the result is

.  (9-3)

You can obtain the current-density vector from the transport of charged species 
through Faraday’s law:

.  (9-4)

In an electrochemical system, the potential gradients are fairly moderate, which implies 
that no separation of charges takes place in the electrolyte. This means that the 
electroneutrality condition is valid in the bulk of the electrolyte:

.  (9-5)

Combining Equation 9-5 with Equation 9-3 and Equation 9-4 leads to

,  (9-6)

which you can rewrite to get Ohm’s law for electrolytes

 (9-7)

where κ is the conductivity of the electrolyte (S/m). You can now set up a balance of 
current in the three subdomains at steady state:

.  (9-8)

This gives for the three subdomains

 (9-9)

Ni Di∇ci– ziuiFci∇φ– ciu+=

φ

Ni ziui Fci∇φ– ciu+=

i F ziNi∑–=

zici∑ 0=

i F zi
2uiFci∇φ–∑–=

i κ∇φ–=

∇ i⋅ 0=

∇ κa∇φ–( )⋅ 0=   in  Ωa

∇ κm∇φ–( )⋅ 0=   in  Ωm

∇ κc∇φ–( )⋅ 0=   in  Ωc
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The indices denote the anode, the membrane, and the cathode, respectively. You solve 
these equations with the proper boundary conditions. The anode reaction is very fast, 
and small changes in potential provide large changes in current density. This implies 
that you can assume a constant potential at the anode’s surface that gives an error in 
potential of approximately 20 mV at that surface (Ref. 3).

For the cathodic reaction, you must account for the potential distribution around the 
electrode surface to get a proper current-density distribution. From the earlier 
discussion you can formulate the following boundary conditions:

 (9-10)

Here i0 denotes the exchange current density (A/m2) for the cathodic reaction, α 
represents the transfer coefficient, Rg equals the gas constant (J/(mol·K)), and T is the 
temperature (K). The last equation implies that you have no current flow out of the 
domain at the outer walls of the unit cell.

Now solve the problem for the potential in the electrolyte and the current distribution 
in the electrolyte and at the electrode surfaces.

φ φa=    at ∂Ωa

i n⋅ i0–
αF

RgT
-----------φ⎝ ⎠
⎛ ⎞exp=    at ∂Ωc

i n⋅ 0=    at ∂Ωouter
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Results

Figure 9-3 shows the potential in the anode and cathode compartments as well as in 
the membrane electrolyte. From this plot note that the largest ohmic losses arise in the 
membrane, as expected from its low conductivity.

Figure 9-3: Potential profile in the three subdomains.

An arrow plot of the current-density vector shows how the distribution is more 
uniform on the cathode than on the anode surface. 

Figure 9-4: Current-density vectors in the three subdomains.
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The modulus of the current-density vector illustrates “hot spots” in the electrolyte 
where the current density is large. These hot spots arise at the electrode edges where 
catalyst can be lost due to accelerated wear.

Figure 9-5: Current density magnitude.
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Model Library path: Chemical_Engineering_Module/
Electrochemical_Engineering/chlor_alkali

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics.
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2 In the list of application modes select COMSOL Multiphysics> 

Electromagnetics>Conductive Media DC.

3 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Axes/Grid Settings.

2 Enter the following settings; when done, click OK.

3 From the Options menu, select Constants.

4 Define the following constants (the descriptions are optional); when done, click OK.

G E O M E T R Y  M O D E L I N G

1 Click the 3rd Degree Bézier Curve button on the Draw toolbar.

2 Draw a Bézier curve by clicking on the points (−0.0035, 0.0022), (−0.002, 
0.0022), (−0.0015, 0.001), and (0, 0.001).

3 Continue by clicking the Line button and drawing a line between the points  
(0, 0.001) and (0, 0.0008).

4 Draw a second 3rd Degree Bézier Curve by clicking on the points (0, 0.0008),  
(−0.0015, 0.0008), (−0.002, 0.002), and (−0.0035, 0.002).

5 Right-click to create a solid object, CO1.

AXIS GRID

x min -4e-3 x spacing 1e-3

x max 1e-3 Extra x -3.5e-3 -1.5e-3 -1.25e-3 -0.5e-3

y min -4.5e-3 y spacing 1e-3

y max 6.5e-3 Extra y 0.8e-3 1.2e-3 1.5e-3 2.2e-3 2.7e-3 3.3e-3

NAME EXPRESSION DESCRIPTION

K_a 50[S/m] Conductivity, anode

K_c 100[S/m] Conductivity, cathode

K_m 3[S/m] Conductivity, membrane

phi0 1.19[V] Anode potential

i0 1[mA/m] Exchange current density

alpha 0.5 Transfer coefficient

F 96485[C/mol] Faraday’s constant

Rg 8.314[J/(mol*K)] Ideal gas constant

T 90[degC] Temperature
C U R R E N T  D I S T R I B U T I O N  I N  A  C H L O R - A L K A L I  M E M B R A N E  C E L L  |  537



538 |  C H A P T E
6 Double-click on the solid object to open the Object Properties dialog box.

7 From the Curve selection list, select 4. Replace the value on the third row of the x 
column to -0.0010.

8 Click OK.

At this stage you have the membrane geometry. Continue by drawing the cathode:

1 Click the 2nd Degree Bézier Curve button on the Draw toolbar.

2 Draw an arc by clicking on the points (0, 0.0012), (−0.0005, 0.0012), and 
(−0.001, 0.0015).

3 Continue by clicking the Line button and drawing lines between the points 
(−0.001, 0.0015), (−0.002, 0.0022), (−0.00125, 0.0033), and (0, 0.0027).

4 Right-click to create a solid object, CO2.

You have now created the cathode; use this object to create the anode:

1 Select the solid object CO2 and from the Edit menu select Copy.

2 Select Edit>Paste. Click OK.

3 Rotate the solid object CO3 by clicking the Rotate button on the Draw toolbar. In 
the resulting dialog box, enter 180 in the Rotation angle edit field, -0.00175 in the 
x Center point edit field, and 0.0015 in the y Center point edit field.

4 Click OK.

5 Draw a rectangle R1 with lower left corner at (-0.0035, -0.004) and upper right 
corner at (0, 0.006) (width=0.0035, height= 0.01).

6 In the Draw menu, select Create Composite Object and type R1+CO1-CO2-CO3 in the 
Set formula edit field.

7 Click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Physics menu, select Subdomain Settings.

2 Enter PDE coefficients for each Subdomain according to the following table: 

3 Click the Init tab so you can specify initial conditions.

SETTINGS SUBDOMAIN 1 SUBDOMAIN 2 SUBDOMAIN 3

 σ K_a K_m K_c
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4 Specify the initial conditions in the respective subdomains according to the 
following table:

This helps the solver reach convergence because the nonlinear solver uses the initial 
conditions as a first guess.

5 Click OK.

Boundary Conditions
1 From the Physics menu, select Boundary Settings.

2 Enter boundary coefficients according to the following table:

3 Click OK.

M E S H  G E N E R A T I O N

Initialize the mesh by clicking the Initialize Mesh button on the Main toolbar.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To reproduce the plot in Figure 9-4, perform the following steps:

1 Click the Plot Parameters button on the Main toolbar.

2 On the Arrow page, select the Arrow plot check box.

3 On the Subdomain Data page, verify that the selection in the Predefined quantities list 
is Conductive Media DC (dc)>Total current density.

4 Click the Color button. Select white as the arrow color, then click OK.

5 In the Arrow positioning area, type 40 in the Number of points edit fields for x points 
and y points.

SETTING SUBDOMAIN 1 SUBDOMAIN 2 SUBDOMAIN 3

V(t0) phi0 0.85*phi0 0.77*phi0

SETTINGS BOUNDARIES 3, 8, 9, 17 BOUNDARIES 10–12, 18 BOUNDARIES 1, 2, 
4–7, 13–16

Boundary 
condition

Electric potential Inward current flow Electric 
insulation

V0 phi0 0

Jn -i0*exp(V*alpha*F/
(Rg*T))
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6 In the Arrow parameters area, clear the Auto check box for Scale factor and type 1.5 
in the associated edit field.

7 Click Apply to generate the plot.

To reproduce the plot in Figure 9-5, proceed as follows:

8 Still on the Arrow page, clear the Arrow plot check box.

9 Click the Surface tab.

10 On the Subdomain Data page, select Conductive Media DC (dc)>Total current density, 

norm from the Predefined quantities list.

11 Click OK.
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Fu e l  C e l l  C a t h od e

Introduction

The development of fuel cells has accelerated during the last decade. The field of fuel 
cells for traction applications has experienced the largest boost in development due to 
efforts by car manufacturers. Despite funding being more limited for stationary 
applications, those types of fuel cells have also gained from the general development 
and have proven to give excellent performance in small-scale applications.

A fuel cell is a continuous electrochemical reactor that converts chemical energy to 
electric energy. It does so by physically separating the oxidation of hydrogen and 
reduction of oxygen at separate electrodes, the anode and cathode. Separation occurs 
through an ion-conducting electrolyte.

The fuel cell presented in this example is a high-temperature model for stationary 
applications. Fuel cells are named after their electrolyte medium, and this case deals 
with the molten carbonate fuel cell (MCFC). This cell operates at 650 °C where the 
fuel, which can be either hydrogen or natural gas, is oxidized at the anode. Oxygen is 
used as the oxidant, being reduced at the cathode together with carbon dioxide.

The cathode is the electrode that gives the largest contribution to energy losses in the 
cell, that is, it has the largest overvoltage. The overvoltage consists of ohmic 
overvoltages in the electrolyte and catalyst, activation overvoltage for the electron 
transfer reaction, and concentration overvoltage due to mass transfer resistance in the 
porous electrode.

This example demonstrates the applicability of multiphysics analysis in limiting the 
definition of variables to certain subdomains. You solve a model for the porous oxygen 
reducing cathode, in the fuel cell, and the electrolyte between the anode and cathode. 
The electrolyte is defined in the porous electrode and in the free electrolyte, while the 
solid phase is present only in the porous electrode subdomain.

The potential difference between the liquid and solid phases is proportional to the 
distribution of the electron transfer reaction in the electrode, the property under study.

Model Definition

The porous fuel cell cathode consists of three different phases: the solid catalyst, the 
electrolyte that transfers into the porous phase through the action of capillary forces, 
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and the gas phase in the large pores of the electrode (Figure 9-6). This exercise 
individually treats these three phases as homogeneous, defined over the whole 
electrode. Furthermore, the liquid phase is defined in the free electrolyte between the 
anode and cathode.

Figure 9-6: Depiction of the unit cell model geometry and labels from the original cell 
design of an MCFC. This exercise looks at a half-cell that is made up of an electrolyte and 
an agglomerate structure for the cathode.

Figure 9-7: Process for electric current transport. Ionic current transforms to electron 
current gradually through the thickness of the cathode.
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Detailed 
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Current
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Electronic 
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Electron transfer through: 

CO2+1/2O2+2e- CO3
2-
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The electron transfer reaction, shown in Figure 9-7, transfers the current from ionic 
conduction in the electrolyte to electronic conduction in the solid catalyst. The solid 
catalyst makes electronic contact with the current collector, which is the perforated 
plate on the top of the cathode. The perforations are required to allow gas to be 
supplied to the electrode.

The catalyst agglomerates are sketched as dotted particles in Figure 9-7, the electrolyte 
is shaded gray, while the gas-filled macropores are white. Oxygen must first dissolve 
into the electrolyte in the porous cathode to further react on the catalyst particles that 
make up the agglomerates.

You can see that there is a mass-transfer resistance in the electrolyte surrounding as well 
as inside the catalyst agglomerates. These agglomerates consist of tightly packed 
smaller catalyst particles with electrolyte in the remaining space between them. The 
mass-transport resistance is considered in the homogenization of the system by a 
function that is linearly dependent on the oxygen concentration in the gas phase. This 
function has previously been found to give good approximations of mass-transfer 
resistance in agglomerates contained in the cathode (Ref. 1).

Assume that gas in the porous electrode is transported by diffusion, and that current 
is conducted through the migration of ions in the molten carbonate electrolyte and 
electronic conduction in the catalyst. The model is based on a mass transport for 
oxygen in the gas phase and charge balances in the solid-catalyst and liquid-electrolyte 
phases.

Furthermore, by assuming that the concentration and potential gradients through the 
depth of the cell are small in comparison with the local gradients, you can state that 
symmetry is obtained perpendicular to the page in the previous figure. This 
assumption simplifies the problem from a 3D to a 2D model.

The model equations in the subdomains are:

 (9-11)

In these equations, Deff denotes the effective diffusion coefficient in the gas phase 
inside the porous electrode (m2/s), c equals the concentration in the gas inside the 
electrode (mol/m3), and k is the effective exchange current density (S/mol). The 
potential in the catalyst is denoted by  (V), while in the liquid phase it is denoted by 

∇ Deff c∇–( ) koc φs φl–( )+⋅ 0=  in Ωsl

∇ κs eff, φs∇–( ) kc φs φl–( )+⋅ 0=  in Ωsl

∇ κl eff, φl∇–( ) k– c φs φl–( )⋅ 0=  in Ωsl

∇ κl free, φl∇–( )⋅ 0=  in Ωl

φs
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. The effective conductivities are denoted by κs,eff and κl,eff in the catalyst and liquid 
phases (S/m), respectively. The conductivity in the free electrolyte is denoted by 
κl,free. Finally, ko = k/(2F), where F is Faraday’s constant (96,485 C/mol). All 
parameters are given in SI units. Overall, you now have a system of four coupled 
equations to solve in the domain. 

To obtain the boundary conditions required to solve this problem, assume symmetry 
for the lateral boundaries of the unit cell, that is, assume that the solution is identical 
for any unit cell of the cathode. 

 (9-12)

The only defined variable in the free electrolyte is the potential in the liquid phase:

.

At the position of the perforation in the collector plate, assume current is insulated for 
transferring from the catalyst or liquid phases. Furthermore, assume that the 
concentration of oxygen in the gas stream is known. This gives the following boundary 
conditions:

 (9-13)

Further, gas is unable to be transported to or from the electrode at the position of the 
current collector:

.  (9-14)

At the position of the current collector, you can arbitrarily set the potential in the solid 
catalyst to zero (because potential is relative). Furthermore, you know that no current 
is transferred from the liquid phase to the current collector because a catalyst is needed 
for this to happen. Therefore

 (9-15)

φl

Deff c∇–( ) n⋅ 0=  at  ∂Ωs 1,  and ∂Ωs 2,

κs eff, φs∇–( ) n⋅ 0=  at  ∂Ωs 1,  and ∂Ωs 2,

κl eff, φl∇–( ) n⋅ 0=  at  ∂Ωs 1,  and ∂Ωs 2,

κl free, φl∇–( ) n⋅ 0= at  ∂Ωl 1,  and ∂Ωl 2,

c c0= at  ∂Ωo

κs eff, φs∇–( ) n⋅ 0= at  ∂Ωo

κl eff, φl∇–( ) n⋅ 0= at  ∂Ωo

Deff c∇–( ) n⋅ 0= at  ∂Ωcc

φs 0= at  ∂Ωcc

κl eff, φl∇–( ) n⋅ 0= at  ∂Ωcc
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Next assume that the potential is known for the boundary facing the anode, which 
means that the total overvoltage is given at the position of this boundary. Therefore, 
total overpotential comes from the difference between the potentials of the current 
collector and the liquid phase at this boundary,

.  (9-16)

In addition, you need the boundary conditions for the concentration of oxygen in the 
gas phase and potential in the solid catalyst. The model neglects the transport of 
oxygen from the gas phase to the electrolyte. Furthermore, assume that the transport 
of current from the catalyst to the free electrolyte is negligible because this direct 
contact surface is minimal:

 (9-17)

Results

Figure 9-8 shows the electron-transfer reaction rate. The reaction rate is greater in the 
regions near the free electrolyte and the current collector. The low effective electrolyte 
conductivity inside the porous electrode forces current to be transferred from the 
electrolyte to the catalyst phase at the electrode’s lower boundary. Furthermore, the 
relatively low conductivity of the solid phase favors reactions taking place on the 
electrode’s right side, where the current collector is positioned. The oxygen 

φl φl o,= at  ∂Ωl

Deff c∇–( ) n⋅ 0= at  ∂Ωls

κs eff, φs∇–( ) n⋅ 0= at  ∂Ωls
F U E L  C E L L  C A T H O D E  |  545



546 |  C H A P T E
concentration is fairly uniform and does not affect the reaction-rate distribution. The 
average current density is approximately 1600 A/m2.

Figure 9-8: Electron-transfer reaction-rate distribution.

Figure 9-9 shows the potential distribution in the electrolyte. Note the large difference 
in conductivity between the electrolyte in the porous electrode and the free electrolyte 
due to the large difference in the potential gradient in the two subdomains.

Figure 9-9: Ionic potential distribution in the fluid electrolyte.
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Model Library path:  

Chemical_Engineering_Module/Electrochemical_Engineering/mcfc

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics.

2 From the Space dimension list, select 2D. Click the Multiphysics button.

3 From the list of application modes select 
COMSOL Multiphysics>Electromagnetics>Conductive Media DC.

4 In the Dependent variables edit field, type phi_e, and in the Application mode name 
edit field, type electrolyte. Click Add.

5 Again select the COMSOL Multiphysics>Electromagnetics>Conductive Media DC 
application mode.

6 In the Dependent variables edit field, type phi_c, and in the Application mode name 
edit field, type catalyst. Click Add.

7 In the list of application modes select 
Chemical Engineering Module>Mass Transport>Diffusion>Steady-state analysis.

8 In the Application mode name edit field, type oxygen.

9 Click Add, then click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.
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2 Enter the following constants (the descriptions are optional); when done, click OK.

G E O M E T R Y  M O D E L I N G

1 Shift-click the Rectangle/Square button on the Draw toolbar.

2 Enter properties according to the following table; when done, click OK to create the 
rectangle R1.

3 Click the Zoom Extents button on the Main toolbar.

4 By repeating Steps 1–2, create a second rectangle, R2, with the same properties 
except for the y position, which you set to -0.5e-3.

5 Click the Zoom Extents button on the Main toolbar.

6 Shift-click the Point button on the Draw toolbar.

7 In the Coordinates area of the Point dialog box, set x to 0.8e-3 and y to 0.5e-3.

8 Click OK.

NAME EXPRESSION DESCRIPTION

kappa_c 20[S/m] Effective conductivity, 
catalyst

kappa_e 5[S/m] Effective conductivity, 
electrolyte in cathode

kappa_e_free 142[S/m] Conductivity, free electrolyte

k 6.7e7[S/mol] Effective exchange current 
density

D_eff 2.8e-5[m^2/s] Effective oxygen diffusion 
coefficient, cathode

F 96485[C/mol] Faraday’s constant

k_o k/(2*F) Effective rate constant

phi_e0 0.15[V] Electrolyte potential, 
electrolyte-anode interface

c0 1.98[mol/m^3] Oxygen concentration, upper 
cathode boundary

Size Width 1.2e-3

Height 0.5e-3

Position Base Corner

x 0

y 0
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P H Y S I C S  S E T T I N G S

Subdomain Expressions
1 From the Options menu, select Expressions>Subdomain Expressions.

2 Select Subdomain 2.

3 Enter the following expressions for the electron-transfer reaction rate and the 
electronic current density, respectively (the software automatically fills in the unit 
column):

4 Click OK.

Subdomain Settings—Electrolyte Charge Balance
1 From the Multiphysics menu, select 1 Conductive Media DC (electrolyte).

2 From the Physics menu, select Subdomain Settings.

3 Specify settings according to the following table; when done, click OK.

Boundary Conditions—Electrolyte Charge Balance
1 From the Physics menu, select Boundary Settings.

2 Enter boundary conditions according to the following table; when done, click OK.

Subdomain Settings—Catalyst Charge Balance
1 From the Multiphysics menu, select 2 Conductive Media DC (catalyst).

2 From the Physics menu, select Subdomain Settings.

3 Select Subdomain 1. Clear the Active in this subdomain check box to deactivate the 
charge-balance equations for the catalyst in the electrolyte domain.

4 Select Subdomain 2.

NAME EXPRESSION UNIT

R k_o*c*(phi_c-phi_e) mol/(m3·s)

Q k*c*(phi_c-phi_e) A/m3

SETTINGS SUBDOMAIN 1 SUBDOMAIN 2

 σ kappa_e_free kappa_e

 Qj 0 Q

SETTINGS BOUNDARY 2 ALL OTHERS

Type Electric potential Electric insulation

V0 phi_e0
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5 Specify PDE properties according to the following table; when done, click OK.

Boundary Conditions—Catalyst Charge Balance
1 From the Physics menu, select Boundary Settings.

2 Enter boundary conditions according to the following table; when done, click OK.

Subdomain Settings—Oxygen Mass Transport
1 From the Multiphysics menu, select 3 Diffusion (oxygen).

2 From the Physics menu, select Subdomain Settings.

3 Select Subdomain 1. Clear the Active in this subdomain check box to deactivate the 
mass transport equation for oxygen in the electrolyte domain.

4 Select Subdomain 2.

5 Specify PDE properties according to the following table; when done, click OK.

Boundary Conditions—Mass Transport
1 From the Physics menu, select Boundary Settings.

2 Enter boundary conditions according to the following table; when done, click OK.

M E S H  G E N E R A T I O N

The model requires a fairly dense mesh. Click the Refine Mesh button on the Main 
toolbar to generate a refined mesh.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

PROPERTY VALUE

 σ kappa_c

 Q -Q

SETTINGS BOUNDARY 6 BOUNDARIES 3–5, 8

Type Ground Electric insulation

PROPERTY VALUE

D (isotropic) D_eff

R R

SETTINGS BOUNDARY 5 BOUNDARIES 3, 4, 6, 8

Type Concentration Insulation/Symmetry

c0 c0
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PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To reproduce the plot of the reaction-rate distribution displayed in Figure 9-8 on page 
546, follow these steps:

1 Click the Plot Parameters button on the Main toolbar.

2 Go to the Surface page. 

3 Type -R in the Expression edit field on the Surface Data page, then click Apply.

Finally, to visualize the electrolyte potential, as in Figure 9-9, do as follows:

4 On the Surface Data page, type phi_c in the Expression edit field.

5 Click the Height Data tab.

6 Select the Height data check box and type phi_e in the Expression edit field.

7 Click OK.
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E l e c t r o c h em i c a l  T r e a tmen t  o f  T umo r s

Introduction

The electrochemical treatment of tumors implies that diseased tissue is treated with 
direct current through the use of metallic electrodes inserted in the tumor. When tissue 
is electrolyzed, two competing reactions take place at the anode: oxygen evolution and 
chlorine production. The oxygen-evolution reaction also produces H+ ions, which 
lower the pH close to the anode. It should be stressed that chlorine production also 
leads to lowered pH through the hydrolysis of chlorine. One effect of low pH is the 
permanent destruction of hemoglobin in the tissue, which results in destruction of 
tumor tissue.

 (9-18)

One challenge in developing this method of cancer treatment is in predicting the doses 
required for tumor destruction. One possible tool for dose planning is by modeling the 
reactions that take place close to the electrodes.

This example presents a first simple model for the development of dose-planning 
methods. More advanced models for dose planning, including secondary effects of 
chlorine, are found in Ref. 1, which also presents and solves models for the cathode.

Model Definition

This model uses the Nernst-Planck application mode to predict the transport and 
reaction in the electrolysis of tumor tissue in a liver. A needle electrode is placed in the 
tumor, and transport is assumed to take place radially to and from this electrode. 
Because you can assume rotational symmetry, the computational domain reduces to a 
line (ra, rr) where ra is 1 mm and rr is 6 cm (see Figure 9-10).

2Cl- Cl2 g( ) 2e-
+=  at the anode

2H2O 4H+ O2 g( ) 4e-
+ +=  at the anode
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The species you consider in the model are the protons, chloride, and sodium. At the 
surface of the anode you account for the chlorine and oxygen evolution reactions; see 
Equation 9-18.

Figure 9-10: Diagram of the cylindrical modeling domain inside a tumor. 

This simplified model considers only a 1D model of the transport between two points, 
that is, between the two electrodes. The material balance for the species i is given by

 (9-19)

where ci is the concentration (mol/m3), Di give the diffusivities (m2/s), zi equals the 
charge, umi represents the mobility ((mol·m2)/(J· s)), and Ri is the production term 
for species i (mol/(m3·s)), F denotes Faraday’s constant (C/mol), and V is the 
potential (V). The mobility, um i, can be expressed in terms of Di, R, and T as

 (9-20)

The conservation of electric charge is obtained through the divergence of the current 
density:

Anode

Computational domain

∂ci

∂t
------- Di∆ci ziumiF ci V∇( ) Ri+∇+=

umi
Di
RT
--------.=
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 (9-21)

At the electrode surface (r = ra) you specify the fluxes for the ionic species that are 
included in the electrode reactions, H+ and Cl-. For the inert ionic species, Na+, the 
transport through the electrode surface equals zero. The expressions for molar fluxes 
at the boundary for the reacting species are

 (9-22)

where Ni is the flux, νij represents the stoichiometric coefficient for the ionic species i 
in reaction  j, and nj is the number of electrons in reaction j.

Introducing dimensionless pressure, P = p/pb, and concentration, C=c/cb, (where b 
denotes the reference concentration), you can express the current densities for the two 
reactions. For the oxygen evolution reaction it is

:  (9-23)

where jI0, is the exchange current density (A/m2) and Eeq,I is the standard electrode 
potential (V). The chlorine evolution reaction is given by the expression

 (9-24)

Using the input values nI = nI = 1, νH,I = 1, and νCl,I = −1, gives the fluxes at the 
electrode surface:

 (9-25)

 (9-26)

At the exterior boundary, assume the concentration is constant, ci = ci0, and set the 
potential to

∇ zi
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 (9-27)

where t denotes time.

The initial concentration is constant: ci = ci0. You obtain the initial potential profile 
from the solution of the domain equations and boundary conditions at t = 0, yielding

 (9-28)

where Vra0 is the potential satisfying  jI + jII = j0 and κ0 is the conductivity at t = 0.

The input data is listed in this table:

TABLE 9-1:  INPUT DATA

PARAMETER VALUE DESCRIPTION

 DNa 1.33·10-9 m2/s Diffusion coefficient, Na+

 DH 9.31·10-9 m2/s Diffusion coefficient, H+

 DCl 2.03·10-9 m2/s Diffusion coefficient, Cl-

 cNa,0 0.16 mol/liter Inlet concentration, Na+

 cH,0 10-7 mol/liter Inlet concentration, H+

 cCl,0 0.16 mol/liter Inlet concentration, Cl-

 j0 100 A/m2 Initial current density

 jI,0 10-6 A/m2 Exchange current density, reaction I

 jII,0 10 A/m2 Exchange current density, reaction II

 Vra,0 -1.4787 V Initial anode potential

 Eeq,I 1.23 V Equilibrium potential, reaction I

 Eeq,II 1.36 V Equilibrium potential, reaction II

 T 298 K Temperature

 pO2 1 atm

 pCl2 1 atm 

V0 t( ) 0.4977 0.2567 100 t
1 s
------+⎝ ⎠

⎛ ⎞ln⋅+⎝ ⎠
⎛ ⎞  V–=

V t 0=( ) Vra0
jra0ra

κ0
----------------

ra

r
-----log+=
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Results

The plot in Figure 9-11 shows the pH for different time steps. You can see that values 
below pH 2 are reached after 2160 seconds. At this pH, tumor destruction starts to 
occur very rapidly according to the experimental and theoretical findings in Ref. 1.

Figure 9-11: pH-profiles at different time steps during the treatment.
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The corresponding H+ profile in Figure 9-12 shows that the concentration maximum 
is not at the anode surface.

Figure 9-12: Proton concentration in the domain at different time steps.

This result arises because the current density is not constant over time. At high current 
densities, large amounts of protons are produced and this front moves inwards in the 
domain as the current density is lowered
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The corresponding plot for chloride (Figure 9-13) shows a continuous decrease of 
chloride concentration close to the anode surface. This in turn decreases the 
production of chlorine and increases oxygen evolution.

Figure 9-13: Chloride concentration at different time steps.

The current-density plot in Figure 9-14 shows that the total current decreases rapidly 
as the concentration overvoltage for chlorine formation increases, due to lowered 
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chloride concentration at the anode surface. The potential is then increased, which 
results in an increase in total current through increased oxygen evolution.

Figure 9-14: Total current density and current density for the competing reactions on the 
anode surface. Oxygen evolution is the lowest graph.

Reference

1. E. Nilsson, Modelling of the Electrochemical Treatment of Tumors, doctoral thesis, 
Dept. Chemical Engineering and Technology, Royal Inst. of Technology, Stockholm, 
Sweden, 2000.

Model Library path:  

Chemical_Engineering_Module/Electrochemical_Engineering/tumor
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Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics.

2 In the Model Navigator, select Axial symmetry (1D) from the Space dimension list. 

3 Select the application mode 
Chemical Engineering Module>Mass Transport>Nernst-Planck>Transient analysis. 

4 In the Dependent variables edit field, type V c_Na c_H c_Cl. Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants. Define the following constants:

NAME EXPRESSION DESCRIPTION

r_a 1[mm] Anode radius

D_Na 1.33e-9[m^2/s] Diffusivity, Na

D_H 9.31e-9[m^2/s] Diffusivity, H

D_Cl 2.03e-9[m^2/s] Diffusivity, Cl

T 298[K] Temperature

R 8.314[J/(mol*K)] Gas constant

F 96485[C/mol] Faraday’s constant

u_Na D_Na/(R*T) Mobility, Na

u_H D_H/(R*T) Mobility, H

u_Cl D_Cl/(R*T) Mobility, Cl

c_Na0 0.16[mol/liter] Initial concentration, Na

c_H0 1e-7[mol/liter] Initial concentration, H

c_Cl0 0.16[mol/liter] Initial concentration, Cl

z_Na 1 Charge number, Na

z_H 1 Charge number, H

z_Cl -1 Charge number, Cl

j_tot0 100[A/m^2] Initial total current density

j_I0 1e-6[A/m^2] Exchange current density, reaction I

j_II0 10[A/m^2] Exchange current density, reaction II

V_ra0 -1.4787[V] Initial anode potential

E_eqI 1.23[V] Equilibrium potential, reaction I
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2 Click OK.

3 From the Options menu, select Expressions>Scalar Expressions.

4 Define the following variables (the descriptions are optional); when done, click OK.

G E O M E T R Y  M O D E L I N G

1 Choose Draw>Specify Objects>Line.

2 In the r edit field, type 1e-3 6e-2. Click OK.

3 Click the Zoom Extents button on the Main toolbar.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Physics menu, select Subdomain Settings.

2 Select Subdomain 1. On the appropriate pages, set the subdomain properties 
according to this table:

E_eqII 1.36[V] Equilibrium potential, reaction II

kappa0 F^2*(u_Na*c_Na0+u_H
*c_H0+u_Cl*c_Cl0)

Initial Conductivity

NAME EXPRESSION DESCRIPTION

NAME EXPRESSION DESCRIPTION

j_I j_I0*(exp(-F*(V+E_eqI)/(2*R*T))-c_H/
c_H0*exp(F*(V+E_eqI)/(2*R*T)))

Current exchange 
density, reaction I

j_II j_II0*(c_Cl/c_Cl0*exp(-F*(V+E_eqII)/
(2*R*T))-exp(F*(V+E_eqII)/(2*R*T)))

Current exchange 
density, reaction II

V0 -(0.4977+0.2567*log(100+t/1[s])) Inlet potential

pH -log10(c_H/1[mol/liter]) pH value in tissue

PROPERTY  cNa  cH  cCl 

D D_Na D_H D_Cl

um u_Na u_H u_Cl

z z_Na z_H z_Cl
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3 Click the Init tab. Set the initial conditions for the voltage profile and the 
concentrations as follows:

4 On the Element page, select Lagrange - Quartic from the Predefined elements list.

5 Click OK.

Boundary Conditions
1 From the Physics menu, select Boundary Settings.

2 On the pages Current/Potential, cH, and cCl, specify boundary conditions according 
to the following table:

3 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters. 

2 Click the Custom mesh size button. On the Global page, set the Maximum element size 

to 5e-3.

3 Click the Boundary tab.

4 Select Boundary 1. Type 1e-5 in the Maximum element size edit field.

5 Select Boundary 2. Type 1e-4 in the Maximum element size edit field.

6 Click Remesh. When the mesher has finished, click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 In the Times edit field, type 0 3600.

3 Set the Relative tolerance to 1e-5 and the Absolute tolerance to 1e-6.

VARIABLE VALUE

V(t0) V_ra0+j_tot0*r_a*log(r_a/r)/kappa0

c_H(t0) c_H0

c_Cl(t0) c_Cl0

BOUNDARY  Current/Potential  c_H  c_Cl 

1 Current inflow Flux Flux

i0 j_I+j_II N0 j_I/F N0 -j_II/F

2 Potential Concentration Concentration

V0 V0 c0 c_H0 c0 c_Cl0
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4 On the Time Stepping page, select Time steps from solver from the 
Times to store in output list. Click OK.

5 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

You can use the software’s cross-section plotting features to plot the pH in the tissue 
surrounding the anode, as in Figure 9-11. 

1 From the Postprocessing menu, select Domain Plot Parameters.

2 On the General page, select Interpolated times from the Select via list and type 
0:600:3600 in the Times edit field.

3 Click the Line/Extrusion tab. Type pH in the Expression edit field to plot the pH value.

4 Click the Line Settings button. Select the Legend check box, then click OK.

5 Click Apply to generate the plot.

Similarly, you generate Figure 9-12 and Figure 9-13 by plotting the predefined 
quantities c_H and c_Cl instead of the pH expression.

To visualize the current contributions on the anode from the reactions 
(Figure 9-14), follow these steps: 

1 From the Postprocessing menu, select Domain Plot Parameters.

2 On the General page, select Stored output times from the Select via list. Now all 
output times in the Solution at time list should automatically be selected.

3 From the Plot in list, select New Figure.

4 Click the Title/Axis button. Type Anodic current density in the Title edit field 
and Current density [A/m<sup>2</sup>] in the Second axis label edit field. 
Click OK.

5 Select the Keep current plot check box.

6 Click the Point tab. Select Point 1.

7 First plot the total current density by typing j_I+j_II in the Expression edit field.

8 Click Apply to generate the first plot.

9 Change the Expression to j_I. Click the Line Settings button. From the Line style list, 
select Dashed line, then click OK. 

10 Click Apply to generate the second graph.

11 Change the Expression to j_II. Click the Line Settings button. From the Line style 
list, select Dash-dot line, then click OK. 
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12 Click OK to close the Domain Plot Parameters window and generate the third graph.
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Ma s s  T r a n s po r t  and E l e c t r o c h em i c a l  
R e a c t i o n  i n  a  Fu e l  C e l l  C a t h od e

Introduction

One of the most important—and most difficult—parameters to model in a fuel cell is 
the mass transport through backing and reactive layers. Gas concentrations are often 
quite large and are significantly affected by the reactions that take place. This makes 
Fickian diffusion an inappropriate assumption for modeling the mass transport.

Figure 9-15 shows an example 3D geometry of a cathode from a fuel cell with 
perforated current collectors. It is often seen in self-breathing cathodes or in small 
experimental cells. Due to the perforation layout, a 3D model is needed in the study 
of the mass transport, current, and reaction distributions.

Figure 9-15: A fuel cell cathode with a perforated current collector.

This model investigates such a geometry and the mass transport that occurs through 
Maxwell-Stefan diffusivity. It couples this mass transport to a generic, Tafel-like 
electrochemical kinetics in the reaction term at a cathode.

Gas inlet hole

Reactiv
e laye

r

Electrolyte laye
r

Unit cell
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Model Definition

Figure 9-16 shows details for a unit cell from Figure 9-15. The circular hole in the 
collector is where the gas enters the modeling domain, where the composition is 
known. The upper rectangular domain is the reaction-zone electrode. It is a porous 
structure that contains the feed-gas mixture, an electronically conducting material 
covered with an electrocatalyst, and an electrolyte. The lower domain corresponds to 
a free electrolyte ionically interconnecting the two electrodes of the fuel cell. No 
reaction takes place in this domain. Neither are there pores to allow gas to flow or 
material for electronic current—current is conducted ionically.

The reaction zone is 75 µm thick, as is the electrolyte layer. The unit cell is 
1.5 ×1.5 mm in surface, and the gas inlet hole has a radius of 1.0 mm.

Figure 9-16: The modeled fuel cell cathode unit cell. The marked zone is the surface of the 
cathode that is open to the feed gas inlet, while the rest of the top surface sits flush against 
the current collector. The top modeling subdomain is the porous cathode, while the bottom 
subdomain is the free electrolyte.

The ionic current balance in the cathode is

 (9-29)

where κl,eff is the effective electrolyte conductivity (S/m), is the electrolyte 
potential (V), Sa is the surface area (m2/m3), and ict equals the local charge transfer 
current density (A/m2). The ionic current balance in the free electrolyte between the 
anode and cathode is

κl eff, φl∇–( )∇– Saict–=

φl
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 (9-30)

where κl is the conductivity of the free electrolyte (S/m). The electronic charge 
balance is defined only in the electrode subdomain and is given by the equation

 (9-31)

where κs,eff is the effective conductivity in the solid phase (S/m), and  is the solid 
phase potential (V).

The transport of masses are given by the Maxwell-Stefan equations for oxygen (Species 
1) and water (Species 2) in the gas phase. They are defined only in the electrode 
subdomain. The final equation is the sum of all fluxes, which equals the convective 
term. This equation gives the mass balance for nitrogen (Species 3). The fluxes are 
given through

 (9-32)

where ni denotes the mass flux of component i, ρ is the density of the mixture (kg/
m3), wi is the mass fraction of species i, M and Mj are the mole masses of the mixture 
and species j (kg/mol), respectively, and u is the velocity (m/s). The material balance 
for oxygen is

,  (9-33)

and for water vapor it is

,  (9-34)

again assuming that the air is saturated so that the reaction produces no water vapor. 
The total mass flux gives the velocity vector:

.  (9-35)

The velocity vector is coupled to Darcy’s law accordingly:

κl φl∇–( )∇– 0=

κs eff, φs∇( )–( )∇– Saict=

φs
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 (9-36)

where kp is the permeability (m2), µ is the viscosity (Pa·s), and p is the pressure (Pa). 
The continuity equation for the gas flow mixture is the sum of the continuity for the 
three involved species, which in two dimension yields

.  (9-37)

The local charge transfer current density couples the current balances with the mass 
balances, according to

 (9-38)

where  is the equilibrium potential difference (V), F is Faraday’s constant (As/
mol), R is the gas constant (J/(mol·K)), T is the temperature (K), and cO2 is the 
concentration of oxygen (mol/m3).

The boundary conditions for the ionic current balances are insulating at all boundaries:

 (9-39)

except for the lowest boundary for the free electrolyte subdomain. The condition at 
this boundary sets the ionic potential:

.  (9-40)

The boundaries for the electronic current balance are those that encompass the 
electrode subdomain. The boundary conditions are all insulating except for the current 
collector boundary where the potential is set:

.  (9-41)

The boundary conditions for the material balances are also those that encompass the 
electrode subdomain and are all insulating except for the gas-channel boundary. The 
insulating condition gives

 (9-42)

while the condition at the gas-channel boundary are given by the composition of the 
inlet gas

u
kp
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.  (9-43)

For the momentum transport through Darcy’s law all boundaries are insulating:

 (9-44)

except for the gas-channel boundary, where the pressure is set:

.  (9-45)

The input data to the model appear in Table 9-2 except for the electrolyte conductivity 
in the free electrolyte domain, which you set to 5 S/m.

Results and Discussion

Figure 9-17 shows the oxygen concentration at a total potential drop over the 
modeled domain of 190 mV. The figure shows that concentration variations are small 
along the thickness of the cathode for this relatively small current density, while they 
are substantially larger along the electrode’s width.

TABLE 9-2:  MODEL PARAMETERS

 i0  Sa  T  Vcell   kl,eff  ks,eff  ε
As/mol 1/m K V V V S/m S/m

10-3 109 353 0 0 0.19 1 103 0.4

 D12 D23 D13  w1,0  w2,0  w3,0  kp  µ patm

m2/s m2/s m2/s m2 Pa·s Pa

2.75·10-5 3.5·10-5 3.5·10-5 0.145 0.476 0.379 10-13 10-5 105

wi wi 0,=

n
kp

µ
------– p∇⎝ ⎠

⎛ ⎞⋅ 0=

p patm=

∆φeq φl 0,
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Figure 9-17: Isosurfaces of the weight fraction of oxygen at a total potential drop over the 
modeled domain of 190 mV.

Figure 9-18 shows the gas velocity in the porous cathode. There is a significant velocity 
peak at the edge of the inlet orifice. This is caused by the contributions of the reactive 
layer underneath the current collector because in this region the convective flux 
dominates the mass transport. Thus it is important to model the velocity field properly. 
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In this case, the combination of circular orifice and square unit cell eliminates the 
possibility of approximating the geometry with a rotational symmetric model.

Figure 9-18: Velocity field for the gas phase in the cathode’s porous reactive layer.

The electrochemical reaction rate, represented by the local current density, is related 
to both the local overvoltage and oxygen concentration. Figure 9-19 depicts the local 
overvoltage, which is rather even throughout the cathode. This is caused by the high 
electronic conductivity in the porous material. Another observation is that the 
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maximum overvoltage is −180 mV. This means that there is a voltage loss of 100 mV 
in the electrolyte layer.

Figure 9-19: Local overvoltage in the cathode reactive layer.

Although the local overvoltage distribution is rather even, the concentration of oxygen 
is not. This means that the reaction rate is nonuniform in the reactive layer. One way 
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to study the distribution of the reaction rate is to plot the ionic current density at the 
bottom boundary of the free electrolyte. Figure 9-20 shows such a plot.

Figure 9-20: Current density perpendicular to the lower, free electrolyte boundary.

The current-density distribution shows that the variations are rather large. The rate of 
reaction and the current production are higher beneath the orifice and decrease as the 
distance to the gas inlet increases. This means that the mass transport of reactant 
dictates the electrode’s efficiency in this design and at these particular conditions.

Model Library path:  

Chemical Engineering Module/Electrochemical Engineering/fc_cathode

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics.
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2 In the Model Navigator, set the Space dimension to 2D. Click OK.

G E O M E T R Y  M O D E L I N G

1 Create a rectangle by selecting Draw>Specify Objects>Square. Type 1.5e-3 in the 
Width edit field, then click OK.

2 Click the Zoom Extents button on the Main toolbar.

3 To add a 3D geometry, open the Model Navigator from the Multiphysics menu, click 
the Add Geometry button, select 3D from the Space dimension list, and click OK twice.

4 Return to the 2D geometry by clicking the Geom1 tab.

5 To extrude the rectangle to the 3D geometry, open the Draw>Extrude dialog box. 
Type 0.75e-4 1.5e-4 in the Distance edit field, then click OK.

6 Return to Geom1 and create a circle by selecting Draw>Specify Objects>Circle. Type 
1e-3 in the Radius edit field and type 1.5e-3 in both the x and the y edit field in the 
Position area, then click OK.

7 Select both the rectangle and the circle (press Ctrl while you click the objects) and 
click the Intersection button on the Draw toolbar.

8 Choose Draw>Work-Plane Settings, type 1.5e-4 in the z edit field for the xy-plane, 
and click OK.

9 To embed the intersection object to the top surface of the 3D object in Geom2, 
select Draw>Embed and click OK.

M O D E L  N A V I G A T O R

1 From the Multiphysics menu, open the Model Navigator. 

2 Select COMSOL Multiphysics>Electromagnetics>Conducive Media DC from the list of 
application modes. Type phi_l in the Dependent variables edit field and type ionic 
in the Application mode name edit field. Click Add.

3 Repeat step 2 using the variable name phi_s and the application mode name 
electronic.

4 Select Chemical Engineering Module>Mass Transport> 
Maxwell-Stefan Diffusion and Convection. Type w_O2 w_H2O w_N2 in the Dependent 

variables edit field, then click Add.

5 Select Chemical Engineering Module>Momentum Transport>Porous Media Flow> 
Darcy’s Law, then click Add.

6 Click OK.
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O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

2 Define the following constant expressions (the descriptions are optional):

NAME EXPRESSION DESCRIPTION

F 96485[C/mol] Faraday’s constant

i0 1e-3[A/m^2] Exchange current densi

Rg 8.314[J/(mol*K)] Gas constant

S 1e9[1/m] Specific area

T 353[K] Temperature

V_cell 0[V] Potential, current col

dphi_eq 0[V] Equilibrium potential 

phi0 0.19[V] Ionic potential, elect
bottom boundary

k_l_eff 1[S/m] Effective conductivity

k_s_eff 1e3[S/m] Effective conductivity

k_l 5[S/m] Conductivity, free ele

e_por 0.4 Porosity

c_o2ref 3.6641[mol/m^3] Reference concentratio

k_d 3.16e-8[Pa*m^2/s] Empirical MS diffusivi
prefactor

p_atm 1.013e5[Pa] Ambient pressure

v_o2 16.6e-6 Molar diffusion volume

v_h2o 12.7e-6 Molar diffusion volume

v_n2 17.9e-6 Molar diffusion volume

Mo2 32[g/mol] Molar mass, O2

Mn2 28[g/mol] Molar mass, N2

M_h2o 18[g/mol] Molar mass, H2O

D_o2n2 k_d*(T[1/K])^1.75/(p_atm*(v_o2^(1/
3)+v_n2^(1/3))^2)*(1[kg/mol]/
M_o2+1[kg/mol]/M_n2)^0.5

Maxwell-Stefan diffusi

D_o2n_eff D_o2n2*(e_por^1.5) Effective MS diffusivi

D_o2h2o k_d*(T[1/K])^1.75/(p_atm*(v_o2^(1/
3)+v_h2o^(1/3))^2)*(1[kg/mol]/
M_o2+1[kg/mol]/M_h2o)^0.5

Maxwell-Stefan diffusi

D_o2h2oeff D_o2h2o*(e_por^1.5) Effective MS diffusivi
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vity

ty

2

2

2O
3 Click OK.

4 From the Options menu, select Visualization/Selection Settings. 

5 Select the Geometry labels check box, then click OK.

P H Y S I C S  S E T T I N G S

1 With Geom2 active, specify expressions according to the following table using the 
Options>Expressions>Scalar Expressions dialog box; when finished, click OK.

Subdomain Settings—Conductive Media DC (ionic)
1 In the Multiphysics menu, select the Conductive media DC (ionic) application mode.

2 From the Physics menu, select Subdomain Settings.

3 Select Subdomain 1 and type k_l in the σ edit field.

4 Select Subdomain 2 and type k_l_eff and S*i_ct in the σ and Qj edit fields, 
respectively.

5 Select both subdomains, click the Init tab, and type phi0 in the Electric potential edit 
field. Click OK.

Boundary Settings—Conductive Media DC (ionic)
1 From the Physics menu, select Boundary Settings.

D_n2h2o k_d*(T[1/K])^1.75/(p_atm*(v_h2o^(1/
3)+v_n2^(1/3))^2)*(1[kg/mol]/
M_h2o+1[kg/mol]/M_n2)^0.5

Maxwell-Stefan diffusi

D_n2h2oeff D_n2h2o*(e_por^1.5) Effective MS diffusivi

m_o2ref 0.1446 Inlet mass fraction, O

mn2 0.4761 Inlet mass fraction, N

m_h2oref 0.3793 Inlet mass fraction, H

perm 1e-13[m^2] Permeability

eta 3e-5[Pa*s] Viscosity

NAME EXPRESSION DESCRIPTION

NAME EXPRESSION

x1mf (w_O2/M_o2)/(w_O2/M_o2+w_H2O/M_h2o+w_N2/M_n2)

i_ct i0*(exp((0.5*F*((phi_s-phi_l)-dphi_eq))/(Rg*T))-x1mf*c_tot/
c_o2ref*exp((-0.5*F*((phi_s-phi_l)-dphi_eq))/(Rg*T)))

rho c_tot*(x_w_O2_chms*M_o2+x_w_H2O_chms*M_h2o+x_w_N2_chms*M_n2)

c_tot p_atm/(Rg*T)
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2 Select all boundaries (select any of the boundaries, then press Ctrl+A to select all), 
then choose Electric insulation from the Boundary condition list.

3 Select Boundary 3, choose Electric potential from the list, and type phi0 in the 
Electric potential edit field. Click OK.

Subdomain Settings—Conductive Media DC (electronic)
1 In the Multiphysics menu, select Conductive media DC (electronic).

2 From the Physics menu, select Subdomain Settings.

3 Select Subdomain 1, then clear the Active in this domain check box to disable the 
application mode.

4 Select Subdomain 2. Type k_s_eff and -S*i_ct in the σ and Qj edit fields, 
respectively.

5 Click the Init tab. Type V_cell in the Electric potential edit field, then click OK.

Boundary Settings—Conductive Media DC (electronic)
1 From the Physics menu, select Boundary Settings.

2 Select all boundaries. Choose Electric insulation from the Boundary condition list.

3 Select Boundary 7. Choose Electric potential from the list, and type V_cell in the 
Electric potential edit field. Click OK.

Subdomain Settings—Maxwell-Stefan Diffusion and Convection (chms)
1 In the Multiphysics menu, select Maxwell-Stefan Diffusion and Convection (chms).

2 From the Physics menu, select Subdomain Settings.

3 Select Subdomain 1, then clear the Active in this domain check box.

4 Select Subdomain 2. Type rho, p_atm, T, u_chdl, v_chdl, and w_chdl in the edit 
fields for Density, Pressure, Temperature, x-velocity, y-velocity, and z-velocity, 
respectively.

5 Click the Edit button for Dij and type D_o2h2oeff, D_o2n2eff, D_n2h2oeff, in the 
matrix in Row 1, Column 2 as well as in (1, 3) and in (2, 3). Click OK.

6 On the w_O2 page, type M_o2 and S*i_ct*M_o2/(4*F) in the M and R edit fields, 
respectively.

7 On the w_H2O page, type M_h2o in the M edit field.

8 On the w_N2 page, type M_n2 in the M edit field.

9 On the Init page, type m_o2ref and m_h2oref in the Mass fraction edit fields for 
w_O2 and w_H2O, respectively. Click OK.
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Boundary Conditions—Maxwell-Stefan Diffusion and Convection (chms)
1 Open the Boundary Settings dialog box and select Boundary 10.

2 On the w_O2 page select Mass fraction from the Boundary condition list, then type 
m_o2ref in the w_O20 edit field.

3 On the w_H2O page select Mass fraction from the Boundary condition list, then type 
m_h2oref in the w_H2O0 edit field. Click OK.

Subdomain Settings–Darcy’s Law (chdl)
1 Select the Darcy’s Law (chdl) application mode in the Multiphysics menu.

2 Open the Subdomain Settings dialog box, select Subdomain 1, and clear the Active in 

this domain check box.

3 Select Subdomain 2. Type rho, perm, eta, and S*i_ct*M_o2/(4*F) in the edit 
fields for Density, Permeability, Dynamic viscosity, and Source term, respectively.

4 On the Init page type p_atm in the Pressure edit field. Click OK.

Boundary Settings—Darcy’s Law (chdl)
1 Open the Boundary Settings dialog box.

2 Select Boundary 10 and choose Inflow/Outflow from the Boundary condition list.

3 Type (perm/eta)*(p_atm-p)/1[mm] in the Inward velocity edit field, then click 
OK. Here the pressure gradient in the normal direction, ∂p/∂n, is approximated by 
∆p/∆x = (p − patm)/1 mm.

M E S H

1 From the Mesh menu, open the Free Mesh Parameters dialog box.

2 On the Global page, select Extra Coarse from the Predefined mesh sizes list.

3 On the Subdomain page, select Subdomain 2. In the Maximum element size edit field, 
type 2e-4.

4 On the Edge page, select Edge 14. In the Maximum element size edit field, type 1e-4.

5 On the Advanced page, type 5 in the z-direction scale factor edit field.

6 Click Remesh. When the mesher has finished, click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar to compute the solution. The calculations 
require approximately 600 MB of free memory and take roughly 30 seconds (on an 
Intel Pentium Mobile M 1.6 GHz laptop).
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PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate Figure 9-17, follow these steps:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, clear the Slice check box and select the Isosurface check box.

3 On the Isosurface page, select Maxwell-Stefan Diffusion and Convection(chms)>Mass 

fraction, w_O2 from the Predefined quantities list, and type 10 in the Number of levels 
edit field. 

4 Click Apply to generate the plot.

To reproduce the plot in Figure 9-18, proceed as follows:

5 On the General page, clear the Isosurface check box and select the Slice check box.

6 On the Slice page, select Darcy’s Law(chdl)>Velocity field from the Predefined 

quantities list. Type 5 in both the x levels and y levels edit fields. From the Unit list, 
select mm/s.

7 Click Apply.

8 To generate Figure 9-19, type phi_s-phi_l-dphi_eq in the Expression edit field 
while still on the Slice page. Click Apply.

Finally, create Figure 9-20.

Suppress all boundaries except Boundary 3:

9 From the Options menu, select Suppress>Suppress Boundaries.

10 Select Boundary 3, then click Apply. Click the Invert Suppression button, then click 
OK. 

11 In the Plot Parameters dialog box, go to the General page. 

12 Clear the Slice check box and select the Boundary check box. 

13 On the Boundary page, select Conductive Media DC(ionic)>Current density outflow 

from the Predefined quantities list.

14 Click OK.
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P r o t o n  Ex c h ang e  Memb r an e  Fu e l  C e l l

Introduction

This example demonstrates the multiphysics modeling of a proton exchange 
membrane (PEM) fuel cell with an interdigitated flow field design. The model uses 
current balances, mass transport equations (Maxwell-Stefan diffusion for reactant, 
water and nitrogen gas), and momentum transport (gas flow) to simulate a PEM fuel 
cell’s behavior.

One main candidate for clean high-efficiency power production in future cars is the 
PEM fuel cell. In a fuel cell-powered engine, the fuel is converted to electric energy 
through electrochemical reactions instead of combustion. An electric motor, which 
generally operates at a very high efficiency, powers the vehicle. The efficiency 
limitations (approximately 40%) of the Carnot cycle are overcome in this way, and the 
theoretical efficiency is substantially higher than that for combustion engines. Thus, a 
fuel cell-powered car can run for longer distances with the same amount of fuel 
compared to a conventional car. Carbon dioxide emissions are consequently lowered, 
because smaller amounts of fuel are consumed for the same distance traveled. In 
addition, the low temperatures in the process practically eliminate the production of 
NOx and SOx.

Figure 9-21 depicts the working principle of the PEM fuel cell. Oxidation of hydrogen 
and the reduction of oxygen takes place at the anode and cathode, respectively:

 (9-46)

Electrons are released to an outer circuit at the anode, and they are received through 
the same circuit at the cathode. The electronic current is transported to and from the 
electrodes through the gas backing to the current collector and then to the outer 
electrical circuit. There is also an ionic current of protons running from the anode to 
the cathode through the electrolyte. Fuel cells are named after their electrolyte 
medium. In the PEM fuel cell, a polymeric proton exchange membrane serves as the 
electrolyte medium.

H2 2H+ 2e- at the anode+⇒

O2 4H+ 4e-
+ + 2H2O at the cathode.⇒
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Figure 9-21: Working principle of a PEM fuel cell.

The PEM fuel cell electrodes are of the gas diffusion type. They consist of a supporting 
carbon structure with gas-filled pores (denoted gas backing) and a porous active layer 
that also contains the polymer electrolyte. The electrochemical reactions take place in 
the active layer, which contains a platinum catalyst. The gas diffusion electrodes are 
designed to maximize the specific area available for the reaction, maximize the 
distribution of reactant (that is, achieve a low gas-transport resistance), and minimize 
the resistance for the proton transport to and from the active sites at the electrodes.

Mathematical modeling is an important tool in the development of fuel cells. A 
combination of modeling and experiments has shown to lower costs and accelerate the 
pace of building prototypes and understanding these new systems. A number of 
models, each with a different focus and degree of complexity, have been presented in 
the literature (see References 1–4).

Model Definition

The modeled section of the fuel cell consists of three domains: an anode (Ωa), a proton 
exchange membrane (Ωm), and a cathode (Ωc) as indicated in Figure 9-22. Each of the 
porous electrodes is in contact with an interdigitated gas distributor, which has an inlet 
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channel (∂Ωa,inlet), a current collector (∂Ωa,cc), and an outlet channel (∂Ωa,outlet). 
The same notation is used for the cathode side.

Figure 9-22: Model geometry with subdomain and boundary labels.

Humidified hydrogen and air are supplied to the inlet channels of the anode and 
cathode, respectively. Hydrogen reacts and is consumed at the anodic active layer to 
form protons that carry the ionic current to the cathode. Each proton is assumed to 
drag three molecules of water from the anode to the cathode. At the cathode, oxygen 
reacts together with the protons to form water at the active layer.

Both feed gases (humified hydrogen and humidified air) are treated as ideal and are 
transported through diffusion and convection. The electrodes are treated as 
homogeneous porous media with uniform morphological properties such as porosity 
and permeability. The gas within each of the electrodes exists as a continuous phase so 
Darcy’s law applies.

An agglomerate model describes the electrode reactions in the active catalyst layers. 
The agglomerates consist of catalyst and carbon particles embedded in polymer 
electrolyte. The equations for the agglomerate model originate from the analytical 
solution of a diffusion-reaction problem in a spherical porous particle (References 5 
and 6). At the anodic active catalyst layer, hydrogen is the diffusing and reacting species 
in the agglomerates, while oxygen is the diffusion and reacting species in the 
agglomerates at the cathode. An agglomerate model of the cathodic active catalyst 
layer of a PEM fuel cell has been presented by Broka et al. (Ref. 7).
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C H A R G E  B A L A N C E S

A Conductive Media DC application mode describes the potential distributions in the 
three subdomains using the following equations:

 (9-47)

Here κs,eff is the solid-phase effective electronic conductivity (S/m) and κm,eff is the 
membrane ionic conductivity (S/m). The potential (V) in the electrode phases is 
denoted by  and that in the membrane by . 

This example models the active layer of the two electrodes as boundaries. This means 
that you treat the charge-transfer current density expression, generally described using 
the Butler-Volmer electrochemical kinetic expression, as a boundary condition.

For the electrolyte potential equation, this results in a condition where the inward 
normal ionic current densities at the anode and cathode boundaries, ia and ic, are 
specified according to the equation

 (9-48)

where the index e stands for “a” (anode) or “c” (cathode). Further, Lact is the active 
layer’s thickness (m), εmac its porosity (the macroscopic porosity), and jagg,a and jagg,c 
are the current densities given by the agglomerate model.

A G G L O M E R A T E  M O D E L  F O R  A N O D E  A N D  C A T H O D E

The agglomerate model describes the current density in an active layer consisting of 
agglomerates of ionic conductor material and electrically conducting particles covered 
partially with catalyst. The local current density can be expressed analytically by solving 
a combination of the diffusion equation and the Butler-Volmer electrode kinetic 
equation for an agglomerate with constant electric and ionic potentials. The resulting 
equations for the current density in the anode and cathode are (Ref. 7)

 (9-49)

where, again, the index e stands for “a” (anode) or “c” (cathode), and

∇ κs eff, φs∇–( )⋅ 0= in Ωa

∇ κm eff, φm∇–( )⋅ 0=  in Ωm

∇ κs eff, φs∇–( )⋅ 0= in Ωc

φs φm

ie Lact 1 εmac–( )jagg e,=

jagg e, 6ne– F
Dagg

Ragg
2

------------
⎝ ⎠
⎜ ⎟
⎛ ⎞

1 λ e λecoth–( )βe=
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 (9-50)

 (9-51)

In these equations, Dagg is the agglomerate gas diffusivity (m2/s), Ragg is the 
agglomerate radius (m), ne is a “charge transfer” number (1 for the anode and –2 for 
the cathode), S is the specific area of the catalyst inside the agglomerate (1/m), and F 
is Faraday’s constant (C/mol). Furthermore, ci,ref are the reference concentrations of 
the species (mol/m3), ci,agg are the corresponding concentrations in the agglomerate 
surface (mol/m3), i0a and i0c are the exchange current densities (A/m2), R is the gas 
constant, T is the temperature (K), and the overvoltages at the anode and the cathode 
are given by

 (9-52)

where Eeq (V) denotes the equilibrium voltage.

You set the anodic and cathodic reference states equal to the molar fractions at the inlet 
channels of the anode and cathode, respectively, at 1 atm. The dissolved hydrogen and 
oxygen concentrations at the surface of the agglomerates are related to the molar 
fractions of the respective species in the gas phase through Henry’s law

 (9-53)

where K is Henry’s constant (Pa·m3/mol).

C H A R G E  B A L A N C E S ,  C O N T I N U E D

For the electric potential, the electrode boundary conditions are identical, setting the 
boundary normal current density but using the opposite sign. In addition, the 
potential difference between the cathode and anode current collectors corresponds to 
the total cell voltage. Choose the potential at the anode current collector as the 
reference level by setting it to zero. Then the total cell voltage serves as the boundary 
condition at the cathode current collector:

λa
i0a SRagg

2

2FcH2 ref, Dagg
---------------------------------------= λc

i0c SRagg
2

4FcO2 ref, Dagg
--------------------------------------- F

2RT
------------– ηc⎝ ⎠

⎛ ⎞exp=

βa cH2 ref, cH2 ref,
2F–

RT
----------ηa⎝ ⎠
⎛ ⎞exp–= βc cO2 agg,=

ηa φs φm– Eeq a,–= ηc φs φm– Eeq c,–=

cagg H2,

pHxH
KH

---------------=

cagg O2,

pOxO
KO

---------------=
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 (9-54)

For the other boundaries you have electric insulation boundary conditions.

PO R O U S  M E D I A  F L U I D  F L O W

To model the gas flows in the gas backings, this example uses the Darcy’s Law 
application mode. The gas velocity is given by the continuity equation according to

.  (9-55)

where ρ is the mixture density of the gas phase (kg/m3) and u denotes the gas velocity 
(m/s). Darcy’s law for porous media states that the gradient of pressure, the viscosity 
of the fluid, and the structure of the porous media determine the velocity:

 (9-56)

Here kp denotes the electrode’s permeability (m2), η represents the gas viscosity 
(Pa·s), and p is the pressure (Pa). The ideal gas law gives the gas phase’s mixture 
density, ρ:

 (9-57)

In this equation, R denotes the gas constant (J/(mol·K)), T is the temperature (K), M 
is the molar mass (kg/mol), and x is the mole fraction.

At the inlets and outlets you specify the pressure:

 (9-58)

At the electrode boundary for the anode and cathode, the gas velocity is calculated 
from the total mass flow given by the electrochemical reaction rate according to

 (9-59)

φs 0= at ∂Ωa cc,

φs Vcell= at ∂Ωc cc,

∇ ρu( )⋅ 0= in Ωa and Ωc

u
kp
η
------∇p–=

ρ p
RT
-------- Mixi

i
∑=

p pa in,= at ∂Ωa inlet,

p pref= at ∂Ωa outlet,

p pc in,= at ∂Ωc inlet,

p pref= at ∂Ωc outlet,

n u anode⋅–
janode

ρF
--------------

MH2
2

------------ λH2OMH2O+⎝ ⎠
⎛ ⎞=
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.  (9-60)

Combined with these boundary conditions, Darcy’s law determines the gas flow 
velocity and preserves the total mass conservation in the anode and cathode gas 
backing. 

M A X W E L L - S T E F A N  M A S S  T R A N S P O R T

The model takes into account two species in the anode—H2 and H2O—and three at 
the cathode—O2, H2O, and N2. The model uses one instance of the Maxwell-Stefan 
Diffusion and Convection application mode for each electrode. Maxwell-Stefan 
multicomponent diffusion is governed by the equations

 (9-61)

which the software solves for the mass fractions, wi. This particular PEM fuel cell 
model assumes that the temperature-driven diffusion is insignificant and sets the 
source term, R, to zero. For the cathode gas, with three species (oxygen = 1, water = 
2, nitrogen = 3), the mass transport is described by the following three equations 
together with Darcy’s law, describing the flow rate:

 (9-62)

 (9-63)

 (9-64)

Here p is the pressure (Pa), T is the temperature (K), and u is the velocity (m/s). The 
density of the mixture is given by Equation 9-57. The Maxwell-Stefan diffusivity 
matrix, Dij (m

2/s), is calculated from the binary diffusivities you specify in the 
application mode.

The feed-gas mass fractions are specified at the inlets. At the outlets, convective flux 
boundary conditions are applied, meaning that the flux is convection dominated. At 

n u cathode⋅–
jcathode

ρF
------------------

MO2
4

------------ 1
2
--- λ+

H2O⎝ ⎠
⎛ ⎞MH2O+=

∂
∂t
-----ρwi ∇ ρwi Dij

M
Mj
------- ∇wj wj

∇M
M

----------+⎝ ⎠
⎛ ⎞ xj wj–( )∇p

p
--------+

⎩ ⎭
⎨ ⎬
⎧ ⎫

+

j 1=

N

∑–⋅+

wiρu D+ i
T∇T

T
-------- Ri=

∇ ρw1 D1j xj∇ xj wj–( ) p∇ p⁄( )+( )[ ]
j
∑–

⎩ ⎭
⎨ ⎬
⎧ ⎫

⋅ ρu w1∇⋅( )–=

∇ ρw2 D2j xj∇ xj wj–( ) p∇ p⁄( )+( )[ ]
j
∑–

⎩ ⎭
⎨ ⎬
⎧ ⎫

⋅ ρu w2∇⋅( )–=

w3 1 w1– w2–=
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the electrode-membrane boundary, the mass fluxes of hydrogen in the cathode, and of 
oxygen and water in the cathode, are determined by the electrochemical reaction rate:

 (9-65)

 (9-66)

 (9-67)

Results

Figure 9-23 shows the current distribution in the PEM fuel cell. There are significant 
current spikes present at the corners of the current collectors.

Figure 9-23: Current density (surface plot) and current vector field (arrow plot) in the 
fuel cell operating at 0.7 V. The anode is on the left and the cathode is on the right

n– NH2 anode
⋅

janode
2F

--------------MH2=

n– NO2 cathode
⋅

jcathode
4F

-----------------MO2=

n– NH2O cathode
⋅

jcathode
F

----------------- 1
2
--- λH2O+⎝ ⎠
⎛ ⎞M

H2O
=
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To further analyze the cell’s behavior, plot the current density at the active layer as a 
function of cell height (y) as in Figure 9-24.

Figure 9-24: Current-density distribution at the active layer at the anode.

The current density is uneven with the highest density in the cell’s upper region. This 
means that the oxygen-reduction reaction rate in the cathode determines the 
current-density distribution. The maximum current density arises close to the air inlet.
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The convective fluxes generally dominate mass transport in the cell. To study the 
convective effects, plot the velocity field as in Figure 9-25.

Figure 9-25: Gas velocity field in the anode and cathode compartments.

The flow-velocity magnitude attains its highest values at the current collector corners.

Figure 9-26 shows the reactant (oxygen and hydrogen) weight fractions in the cathode 
and anode gases. Surprisingly, the hydrogen fraction increases as the anode gas flows 
from the inlet (at the bottom) to the outlet (at the top). This is the result of the 
electroosmotic drag of water through the membrane, which results in a higher flux 
than the consumption of hydrogen. This means that the resulting convective flux of 
anode gas towards the membrane causes the weight fraction of hydrogen to go up. In 
the cathode gas, there is an expected decrease in oxygen content along the flow 
direction.
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Figure 9-26: Reactant mass fractions, normalized by their inlet values, on the anode side 
(left) and cathode side (right). The reactant in the anode is hydrogen and that in the 
cathode is oxygen.

Although oxygen consumption is small, the concentration overvoltage in the 
agglomerates gives a substantial contribution to the concentration overvoltage. A 
small change in the oxygen flow gives a substantial change in cell polarization.

Figure 9-27 depicts the water mass fraction in the anode and cathode gases as well as 
the diffusive flux of water in the anode. It is apparent that water is transported through 
both diffusion and convection to the membrane on the anode side. The results show 
a minimum occurring in the upper corner of the membrane on the anode side. This is 
known to limit fuel cell performance. If the anode gas becomes too dry, the membrane 
dries out, resulting in decreasing ionic conductivity and the cell subsequently fails.

On the other hand, on the cathode side water levels increase with the direction of flow, 
and a local maximum in water current occurs in the lower corner to the membrane. 
This might also be critical because water droplets can clog the pores and effectively 
hinder gas transport to the active layer.
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Figure 9-27: Water mass fraction in the anode (left, surface plot) and the cathode (right, 
contour plot). The arrows visualize the diffusive flux vector field on the anode side.
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Model Library path:  
Chemical_Engineering_Module/Electrochemical_Engineering/pemfc

Modeling Using the Graphical User Interface

1 Start COMSOL Multiphysics.

2 In the Model Navigator, select 2D in the Space dimension list.

3 Click the Multiphysics button.

4 From the Application Modes tree, select 
COMSOL Multiphysics>Electromagnetics>Conductive Media DC.

5 Type phi_s in the Dependent variables edit field and electrodes in the 
Application mode name edit field. Click Add.

6 Select the Conductive Media DC application mode once again.

7 Type phi_m in the Dependent variables edit field and membrane in the 
Application mode name edit field. Click Add.

8 Select the application mode Chemical Engineering Module>Momentum Transport> 
Porous Media Flow>Darcy’s Law. 

9 Type p in the Dependent variables edit field and Darcy in the Application mode name 
edit field. Click Add.

10 Select the application mode Chemical Engineering Module>Mass Transport> 
Maxwell-Stefan Diffusion and Convection.

11 In the Dependent variables edit field, type wH2 wH2Oa. In the Application mode name 
edit field type MSa, then click Add.

12 Finally, add a second Maxwell-Stefan Diffusion and Convection application mode. In 
the Dependent variables edit field type wO2 wH2Oc wN2, and in the 
Application mode name edit field type MSc. Click Add, then click OK.
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G E O M E T R Y  M O D E L I N G

1 Shift-click the Rectangle/Square button on the Draw toolbar. Create the rectangle R1 
by entering the properties in the Rectangle 1 column below; when done, click OK.

2 Repeat the previous step three times using the properties listed in the remaining 
three columns to create the rectangles R2, R3, and R4.

3 Click the Zoom Extents button on the Main toolbar.

4 Select the rectangle R4, then click the Array button on the Draw toolbar.

5 In the x-displacement and y-displacement edit fields, type 7e-4 and 1.5e-3, 
respectively. Type 2 in both the x-array size and y-array size edit fields. Click OK.

6 Select the rectangle R1 and the two small rectangles to the left (Press Ctrl to make 
multiple selections).

7 Click the Create Composite Object button on the Draw toolbar. Clear the 
Keep interior boundaries check box, then click OK.

8 Select the rectangle R3 and the two small rectangles to the right. Repeat the 
previous step for these objects.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

2 Define the following constants (the descriptions are optional); when done, click OK.

OBJECT DIMENSIONS RECTANGLE 1 RECTANGLE 2 RECTANGLE 3 RECTANGLE4

Width 2.5e-4 1e-4 2.5e-4 1e-4

Height 2e-3 2e-3 2e-3 5e-4

Position base Corner Corner Corner Corner

Position x 0 2.5e-4 3.5e-4 -1e-4

NAME EXPRESSION DESCRIPTION

kappa_s 1000[S/m] Conductivity, solid phase

kappa_m 9[S/m] Conductivity, membrane

V_cell 0.7[V] Cell voltage

R 8.314[J/(mol*K)] Gas constant

T 353[K] Temperature

F 96485[C/mol] Faraday’s constant

kappa_p 1e-13[m^2] Permeability

eta 2.1e-5[Pa*s] Fluid viscosity

p_ref 1.013e5[Pa] Reference pressure
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p_a_in 1.1*p_ref Inlet pressure, anode

p_c_in 1.1*p_ref Inlet pressure, cathode

drag 3 Water drag coefficient

E_eq_a 0[V] Equilibrium potential, 
anode

E_eq_c 1[V] Equilibrium potential, 
cathode

i0_a 1e5[A/m^2] Exchange current density, 
anode

i0_c 1[A/m^2] Exchange current density, 
cathode

S 1e7[1/m] Specific surface area

R_agg 0.1[um] Aggregate radius

l_act 10[um] Active-layer length

eps_mic 0.2 Microscopic porosity 
inside agglomerate

eps_mac 0.4 Macroscopic porosity 
between agglomerates

D_agg 1.2e-10[m^2/
s]*((1-eps_mac)*(eps_mic))^
1.5

Gas diffusivity in 
agglomerate

D_effH2_H2O 0.915e-4[m^2/s]*(T/
307.1[K])^1.5*(eps_mac)^1.5

Effective binary 
diffusivity, H2_H2O

D_effO2_H2O 0.282e-4[m^2/s]/(T/
308.1[K])^1.5*(eps_mac)^1.5

Effective binary 
diffusivity, O2_H2O

D_effO2_N2 0.22e-4[m^2/s]*(T/
293.2[K])^1.5*(eps_mac)^1.5

Effective binary 
diffusivity, O2_N2

D_effH2O_N2 0.256e-4*(T/
307.5[K])^1.5*(eps_mac)^1.5

Effective binary 
diffusivity, H2O_N2

wH2_in 0.1 Inlet weight fraction, H2

wO2_in 0.21*0.8 Inlet weight fraction, O2

wH2Oc_in 0.2 Cathode inlet weight 
fraction, H2O

MH2 2[g/mol] Molar mass, H2

MO2 32[g/mol] Molar mass, O2

MH2O 18[g/mol] Molar mass, H2O

MN2 28[g/mol] Molar mass, N2

NAME EXPRESSION DESCRIPTION
R  9 :  E L E C T R O C H E M I C A L  C E L L S  A N D  E L E C T R O C H E M I C A L  E N G I N E E R I N G



3 From the Options menu, select Expressions>Scalar Expressions.

4 Enter the following expressions (the descriptions are optional); when done, click OK.

5 From the Options menu, select Expressions>Subdomain Expressions.

xH2_in (wH2_in/MH2)/(wH2_in/
MH2+(1-wH2_in)/MH2O)

Inlet mole fraction, H2

xO2_in (wO2_in/MO2)/(wO2_in/
MO2+wH2Oc_in/
MH2O+(1-wO2_in-wH2Oc_in)/
MN2)

Inlet mole fraction, O2

KH2 3.9e4[Pa*m^3/mol] Henry’s law constant, H2 
in agglomerate

KO2 3.2e4[Pa*m^3/mol] Henry’s law constant, O2 
in agglomerate

cH2_ref xH2_in*p_ref/KH2 Reference concentration, 
H2

cO2_ref xO2_in*p_ref/KO2 Reference concentration, 
O2

NAME EXPRESSION DESCRIPTION

NAME EXPRESSION DESCRIPTION

eta_a phi_s-phi_m-E_eq_a Anodic overvoltage

eta_c phi_s-phi_m-E_eq_c Cathodic overvoltage

cH2_agg p*xH2/KH2 Henrys law agglomerate 
concentration, H2

cO2_agg p*xO2/KO2 Henry’s law agglomerate 
concentration, O2

K -6*l_act*(1-eps_mac)*F*D_agg/
R_agg^2

Agglomerate current 
density subexpression

beta_a cH2_agg-cH2_ref*exp(-2*F*eta_a/
(R*T))

Anodic current density 
subexpression

lda_a sqrt(i0_a*S*R_agg^2/
(2*F*cH2_ref*D_agg))

Anodic current density 
subexpression

lda_c sqrt(i0_c*S*R_agg^2*exp(-F*eta_c/
(2*R*T))/(4*F*cO2_ref*D_agg))

Cathodic current density 
subexpression

i_a K*(1-lda_a*coth(lda_a))*beta_a Anodic current density

i_c -2*K*(1-lda_c*coth(lda_c))*cO2_agg Cathodic current density
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6 Define the following subdomain expressions; when done, click OK.

7 From the Options menu, select Expressions>Boundary Expressions.

8 Select Boundary 10. Define a variable with the Name u_a by the Expression 
i_a*(MH2/2+drag*MH2O)/(F*rho_mix).

9 Select Boundary 13. On the table’s second row, define a variable with the Name u_c 
by the Expression i_c*(MO2/4-(1/2+drag)*MH2O)/(F*rho_mix).

10 Click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings—Electrodes
1 From the Multiphysics menu, select 1 Conductive Media DC (electrodes).

2 From the Physics menu, select Subdomain Settings.

3 Select Subdomains 1 and 3. In the σ edit field, type kappa_s.

4 Select Subdomain 2. Deactivate the application mode by clearing the Active in this 

domain check box. Click OK.

Boundary Conditions—Electrodes
1 From the Physics menu, select Boundary Settings.

2 Apply the following conditions; when done, click OK.

Subdomain Settings—Membrane
1 From the Multiphysics menu, select 2 Conductive Media DC (membrane).

NAME SUBDOMAIN 1 SUBDOMAIN 2 SUBDOMAIN 3

rho_mix (x_wH2_MSa*MH2+ 
x_wH2Oa_MSa*MH2O)* 
p/(R*T)

(x_wO2_MSc*MO2+ 
x_wH2Oc_MSc*MH2O+ 
x_wN2_MSc*MN2)*p/(R*T)

E phi_s phi_m phi_s

xH2 x_wH2_MSa

xO2 x_wO2_MSc

wReact wH2 wO2

wH2O wH2Oa wH2Oc

SETTINGS BOUNDARIES 1–7, 
9, 14–16, 18–22

BOUNDARY 8 BOUNDARY 10 BOUNDARY 13 BOUNDARY 17

Type Electric 
insulation

Electric 
potential

Inward 
current flow

Inward 
current flow

Electric 
potential

Value 0 -i_a -i_c V_cell
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2 From the Physics menu, select Subdomain Settings. 

3 Select Subdomain 2. In the σ edit field, type kappa_m.

4 Select Subdomains 1 and 3. Deactivate the application mode by clearing the Active 

in this domain check box. Click OK.

Boundary Conditions—Membrane
1 From the Physics menu, select Boundary Settings. 

2 Enter boundary conditions according to the following table; when done, click OK.

Subdomain Settings—Darcy
1 From the Multiphysics menu, select 3 Darcy’s Law (Darcy).

2 From the Physics menu, select Subdomain Settings.

3 Select Subdomains 1 and 3, then apply settings according to the following table:

4 On the Init page, type p_ref in the p(t0) edit field.

5 Select Subdomain 2, then clear the Active in this domain check box.

6 Click OK.

Boundary Conditions—Darcy
1 From the Physics menu, select Boundary Settings.

2 Apply conditions according to the following table; when done, click OK.

Subdomain Settings—MSa
1 From the Multiphysics menu, select 4 Maxwell-Stefan Diffusion and Convection (MSa).

SETTINGS BOUNDARY 10 BOUNDARIES 11, 12 BOUNDARY 13

Type Inward current flow Electric insulation Inward current flow

Value i_a i_c

PROPERTY VALUE

  ρ rho_mix

  κ kappa_p

  η eta

SETTINGS BOUNDARY 1 BOUNDARIES 4, 21 BOUNDARY 22 BOUNDARY 10 BOUNDARY 13

Type Pressure 
condition

Pressure 
condition

Pressure 
condition

Inflow/
Outflow

Inflow/
Outflow

p0 p_a_in p_ref p_c_in

u0 -u_a u_c
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2 From the Physics menu, select Subdomain Settings.

3 Select Subdomains 2 and 3, then clear the Active in this domain check box.

4 Select Subdomain 1, then apply the following settings:

5 On the General page, click the Edit button for the Maxwell-Stefan diffusivity matrix. 
In the dialog box that appears, type D_effH2_H2O in the edit field. Click OK.

6 Click OK to close the Subdomain Settings dialog box.

Boundary Settings—MSa
1 From the Physics menu, select Boundary Settings.

2 Specify conditions according to the following table; when done, click OK.

Subdomain Settings—MSc
1 From the Multiphysics menu, select 5 Maxwell-Stefan Diffusion and Convection (MSc).

2 From the Physics menu, select Subdomain Settings.

3 Select Subdomains 1 and 2, then clear the Active in this domain check box.

4 Select Subdomain 3, then apply the following settings:

PAGE PROPERTY VALUE

General  ρ rho_mix

General  p p

General  T T

General  u u_Darcy

General  v v_Darcy

wH2  M MH2

wH20a  M MH2O

Init  wH2(t0) wH2_in

SETTINGS BOUNDARY 1 BOUNDARY 4 BOUNDARY 10

Type Mass fraction Convective flux Flux

wH20 wH2_in

n0 -i_a*MH2/(2*F)

PAGE PROPERTY VALUE

General  ρ rho_mix

General  p p

General  T T
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5 On the General page click the Edit button for the Maxwell-Stefan diffusivity matrix. In 
the dialog that appears, type D_effO2_H2O and D_effO2_N2 in the edit fields on the 
first row and D_effH2O_N2 in that on the second row. Click OK.

6 Click OK to close the Subdomain Settings dialog box.

Boundary Settings—MSc
1 From the Physics menu, select Boundary Settings.

2 Specify conditions according to the following table; when done, click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters.

2 Click the Boundary tab. Select Boundaries 10 and 13. Set the Maximum element size 
to 5e-5.

3 Click the Point tab. Select Points 6, 7, 14, and 15. Set the Maximum element size to 
1e-5.

General  u u_Darcy

General  v v_Darcy

wO2  M MO2

wH20c  M MH2O

wN2  M MN2

Init wO2(t0) wO2_in

Init wH2Oc(t0) wH2Oc_in

SETTINGS BOUNDARY 13 BOUNDARY 21 BOUNDARY 22

Type (wO2 
and wH2Oc))

Flux Convective flux Mass fraction

n0 (wO2) i_c*MO2/(4*F)

n0 (wH2Oc) -i_c*MH2O*(1/2+drag)/F

wO20 wO2_in

wH2Oc0 wH2Oc_in

PAGE PROPERTY VALUE
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4 Click Remesh. When the mesher has finished, click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Manager button on the Main toolbar.

2 On the Solve For page, select the two Conductive Media DC application modes and the 
Darcy’s Law application mode. Click Apply.

3 On the Script page, select the Solve using a script check box. 

4 Click the Add Current Solver Settings button.

5 On the Initial Value page, click the Current solution option button in the Initial value 
area.

6 On the Solve For page, select all the application modes by clicking on the icon 
Geom1 (2D).

7 Click Apply.

8 On the Script page, click the Add Current Solver Settings button.

9 Click Solve. 

10 When the solver has finished, click OK to close the Solver Manager.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The following steps reproduce the plot in Figure 9-23 on page 587:

1 Click the Plot Parameters button on the Draw toolbar.

2 On the Surface page, make sure the Surface plot check box is selected.

3 From the Predefined quantities list on the Surface Data page, select 
Conductive Media DC (electrodes)>Total current density, norm.

4 Click the Range button. Clear the Auto check box, then type 0 and 1e4 in the Min 
and Max edit fields, respectively. Click OK.

5 On the Arrow page, select the Arrow plot check box.

6 From the Predefined quantities list on the Subdomain Data page, select 
Conductive Media DC (electrodes)>Total current density.

7 From the Arrow type list, select 3D arrow. Click OK to generate the plot.

To generate Figure 9-24, proceed as follows:

1 From the Postprocessing menu, select Domain Plot Parameters.

2 On the Line/Extrusion page, select Boundary 10, then type i_a in the Expression edit 
field.
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3 In the x-axis data area, click the lower option button, then click Expression.

4 From the Predefined quantities list on the X-Axis Data dialog box, select 
Geometry and Mesh>y-coordinate. From the Unit list, select mm, then click OK.

5 Click OK to close the Domain Plot Parameters dialog box and generate the plot.

To generate Figure 9-25 follow these instructions:

1 Click the Plot Parameters button on the Main toolbar.

2 On the Surface page, select Darcy’s Law (Darcy)>Velocity field from the Predefined 

quantities list on the Surface Data page.

3 Click the Range button. Select the Auto check box, then click OK.

4 Click the Arrow tab. 

5 From the Predefined quantities list on the Subdomain Data page, select 
Darcy’s Law (Darcy)>Velocity field.

6 Click Apply to generate the plot.

Generate Figure 9-26 with these steps:

7 Back in the Plot Parameters dialog box, click the Surface tab.

8 In the Expression edit field on the Surface Data page, type wReact.

9 Click the Contour tab. Select the Contour plot check box.

10 In the Expression edit field, type wReact.

11 In the Contour color area, clear the Color scale check box.

12 Click Apply.

Finally, to generate Figure 9-27 do the following:

13 Still on the Contour page, select the Color scale check box. In the Expression edit field, 
type wH2Oc.

14 Click the Surface tab. In the Expression edit field on the Surface Data page, type 
wH2Oa.

15 Click the Arrow tab. From the Predefined quantities list on the Subdomain Data page, 
select Maxwell-Stefan Diffusion and Convection (MSa)>Diffusive flux, wH2Oa. Click OK.
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S e r p en t i n e  P r o t o n  Ex c h ang e  
Memb r an e  Fu e l  C e l l  C a t h od e

Introduction

During the last several years, the use of fuel cells as power sources has been 
demonstrated in cell phones, computers, cars, and apartment buildings. The 
requirements for each of these applications are diverse, and the design of fuel cell units 
are consequently also different. Despite this, the phenomena that describe the 
characteristics of the electrodes and electrolyte in a fuel cell are identical for all types. 
In most types, the costs of the components of the fuel cell unit, electrodes, electrolyte, 
and current collectors are high, which implies that the degree of utilization of catalyst 
and unit cell surface area must be maximized. Modeling is an efficient way of saving 
time and money in the design stage.

This study illustrates the use of modeling in the design of a proton exchange 
membrane fuel cell (PEMFC) cathode. The model is based on simple charge and mass 
balances in the gas diffusion electrodes and the electrolyte in the fuel cell. It can help 
optimize the electrode structure in order to minimize concentration and activation 
polarization. The phenomena described in this paper appears in all types of fuel cells.

The specific purpose of the model is to estimate the influence of the serpentine channel 
and electrode design on the current-density distribution and the distribution of 
reacting oxygen gas in the cathode.

Model Definition

The model domain consists of a unit cell of the cathode where the gas channel is 
configured in a serpentine shape (see Figure 9-28). The active layer is the domain’s 
bottom boundary. Thus the model neglects current-distribution effects along the 
thickness of the catalyst layer.
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Figure 9-28: Geometrical depiction of the serpentine PEM fuel cell cathode. Gas flows 
through the curved serpentine channels, which sit flush against the cathode layer. 
Surrounding the channels is the current collector. The bottom boundary of the cathode 
layer is the catalytic active layer.

In the gas channel section, this example models fluid flow in combination with 
diffusion and convective transport. The plate-shaped subdomain at the bottom 
represents the porous diffusion layer of the PEMFC cathode. The bottom boundary is 
the active catalyst layer where the reaction takes place. The electrode reaction in the 
active layer couples the concentration of oxygen to the electric current density. The 
electrode reaction is treated as a boundary condition at the cathode’s bottom surface.

The gas flow in the gas channel is modeled with the momentum and continuity 
equations (the Navier-Stokes equations):

 (9-68)

The pressure difference, ∆ p, drives the flow in the channel. All walls in the channel 
except the inflow and outflow have no-slip boundary conditions. The inlet and outlet 
boundary conditions are

 (9-69)

Inlet

Outlet

Gas channel

Diffusion layer

ρ
t∂

∂u ∇ η ∇u ∇u( )T
+( )⋅– ρ u ∇⋅( )u ∇p+ + 0=

∇ u⋅ 0.=

p p0 ∆p+= inlet

p p0= outlet

η ∇u ∇u( )T
+( )n 0= inlet/outlet

u 0= wall
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The mass flux in the gas phase is based on the Maxwell-Stefan diffusion and convection 
equations. It is described by this expression for species i:

 (9-70)

Here ρ denotes the density of the mixture (kg/m3), M equals the total molar mass of 
the mixture (kg), Mj represents the molar mass of species  j (kg), ωj gives the mass 
fraction of species j, and u is the velocity (m/s). You can also express M and ρ in terms 
of the mass fractions, ωj. The multicomponent Fick diffusivities, Dij, which COMSOL 
Multiphysics calculates automatically, depend strongly on the composition and are 
given by the following expressions (Ref. 2 and Ref. 3):

 (9-71)

 (9-72)

where xj denotes the molar fraction of species j and Dij are the Maxwell-Stefan 
diffusivities (m2/s). The Maxwell-Stefan diffusivities, which the user enters in 
COMSOL Multiphysics, can be described with an empirical equation based on kinetic 
gas theory (Ref. 4):

 (9-73)

Here k is a constant equal to 3.16·10−8 Pa·m2/s, T represents the temperature 
expressed in kelvin, p equals pressure (Pa), νi is the molar diffusion volume of species 
i expressed in m3/mol, and Mi is the molar mass of species i expressed in kg/mol.
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The molar diffusion volumes appear in Table 9-3 (see Ref. 1). 

In the porous cathode, the effective Maxwell-Stefan diffusivities depend on the 
porosity, ε, according to:

.  (9-74)

At the inlet, the composition is specified according to Table 9-4 (corresponding to air, 
steam saturated at 80 °C (Ref. 1)):

At the outflow, assume that convective flux dominates the mass transport. This 
boundary condition is defined by the expression

 (9-75)

where nj represents the mass flux of species j.

The electrochemical reaction at the active layer determines the flux at the reactive 
boundary, where oxygen is consumed and water is produced (and dragged) according 
to these expressions:

 (9-76)

where nj represents the mass flux of j, F denotes Faraday’s constant (C/mol), tH2O is 
the water transport number or drag number (that is, the number of water molecules 

TABLE 9-3:  MOLAR DIFFUSION VOLUMES

SPECIES DIFFUSION VOLUME

O2 16.6·10-6

H2O 12.7·10-6

N2 17.9·10-6

TABLE 9-4:  INLET COMPOSITION

SPECIES MASS FRACTION

O2 0.1447

H2O 0.3789

N2 0.4764

Deff ij, Dij ε1.5
=

ni n⋅ ρωiu( ) n⋅=

nO2 n⋅ MO22

ic

4F
-------=

nH2O2
n⋅ M– H2O

ic
F
---- 1

2
--- tH2O+⎝ ⎠
⎛ ⎞=
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dragged across the PEMFC membrane for each electron transferred), and ic is the 
current density (A/m2) given by the expression

.  (9-77)

Here Sa denotes the specific surface area (m2/m3), δ is the thickness of the active layer 
(m), R represents the gas constant (J/(mol·K)), T equals the temperature (K), i0 gives 
the exchange current density (A/m2), and η is the overpotential (V). The weight 
fraction of oxygen, ωO2, normalized with a reference fraction, is also included. 

The nitrogen flux across the reactive boundary is zero. As a consequence, there is a 
convective flux present at steady state, working counter to the nitrogen diffusive flux, 
nN2,d. This means that a gas velocity is present even in the porous domain. It is given 
by

.  (9-78)

This condition is applied in the model’s porous domain.

ic Saδi0–( )
ωO2

ωO2,0
-------------- Fη

2RT
------------⎝ ⎠
⎛ ⎞exp=

u
n– N2 d,
ρωN2

------------------=
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Results

Table 9-29 shows the composition of the gas in the porous electrode and in the 
channel.

Figure 9-29: Mass fraction in the channel and porous cathode.

In this case, the high current density results in a substantial oxygen depletion in the 
regions far away from the gas channel. The oxygen weight fraction reaches values as 
low as 0.03 in the corner to the left in the figure. There is also a substantial decrease 
in oxygen weight fraction along the gas channel from inlet to outlet, from 0.145 to 
approximately 0.1. This solution is based on applying a pressure drop of 25 Pa between 
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the inlet and outlet. Figure 9-30 depicts the resulting gas-velocity distribution in the 
gas channel.

Figure 9-30: Velocity distribution in the gas channel for a 25 Pa pressure drop between the 
inlet and outlet.

The applied pressure difference results in a maximum gas velocity of approximately 
2 m/s. A typical laminar flow profile is present in the straight sections. In the curved 
sections, on the other hand, the velocity distribution is asymmetric, resulting in an 
asymmetric concentration distribution there.

In designing the cathode it is important to exploit the expensive catalyst layer to its 
maximum. The current-density distribution gives a quantitative measure of this 
utilization. Figure 9-31 displays a top view of that distribution throughout the entire 
active layer. The current density is significantly higher below the gas channels. A 
maximum current density of 2400 kA/m2 is reached under the center of the channel 
in the inlet region. The lowest current density is only 420 kA/m2. This uneven use of 
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the active layer indicates that the thickness of the diffusion layer might need to be 
increased to optimize the electrode’s performance.

Figure 9-31: Top view of the current-density distribution on the surface of the catalytic 
active layer.

This model neglects the voltage drop in the electrode. The electronic conductivity of 
the porous electrode is typically quite high, in the range of 10,000 S/m. The 
conductivity is related to the voltage drop through the current density according to

.  (9-79)

An electrode thickness of 0.2 mm means that the maximum voltage drop across the 
electrode is in the range of 0.05 mV, which is indeed negligible.

An interesting effect in the PEMFC cathode is its water management. Water is present 
initially in the gas phase at close to saturation concentration. There is a water influx at 
the reactive boundary due to both reaction and drag. In practice, the water content 
must not become too high because water droplets would form, clog the electrode, and 

∆E
i– c
κ

-------L=
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cause performance to decrease. This is often called “flooding.” Figure 9-32 studies 
water management by plotting the water fraction in the gas.

Figure 9-32: Weight fraction of water in the cathode gas.

Clearly the water fraction increases significantly in the electrode. It reaches a maximum 
value of 0.77 in the corner at the top of the figure. It is probable that water droplets 
would start forming in this region. To avoid this problem, the design should decrease 
the inlet water fraction and increase the thickness of the diffusion layer.
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Model Library path:  

Chemical_Engineering_Module/Electrochemical_Engineering/serpentine

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics.

2 From the Space dimension list, select 2D.

3 Click OK.

G E O M E T R Y  A N D  M E S H I N G

1 Press Shift and click the Rectangle/Square button on the Draw toolbar. Create the 
rectangle R1 using data from the following table. Click OK, then repeat the 
procedure for the rectangles R2–R5.

2 Click the Zoom Extents button on the Main toolbar.

3 Shift-click the Ellipse/Circle (Centered) button on the Draw toolbar. Create the circle 
C1 using data from following table. Click OK, then repeat the procedure for C2.

4 Click Zoom Extents.

SETTINGS R1 R2 R3 R4 R5

Width 1e-3 1e-3 1e-3 1e-3 4e-3

Height 9e-3 9e-3 6e-3 6e-3 2e-3

Base Corner Corner Corner Corner Corner

x 1e-3 10e-3 4e-3 7e-3 1e-3

y 0 0 3e-3 3e-3 7e-3

SETTINGS C1 C2

Radius 2e-3 1e-3

x 3e-3 3e-3

y 9e-3 9e-3
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5 Click the Create Composite Object button on the Draw toolbar.

6 In the Set formula edit field, type C1-C2-R5, then click OK.

7 Select the generated object, then press Ctrl+C to copy it.

8 Press Ctrl+V to paste the copy. In the Paste dialog box specify an x-displacement of 
6e-3. Click OK.

9 Repeat the paste operation, this time with the x-displacement and y-displacement set 
to 3e-3 and -6e-3, respectively.

10 Select the last pasted object, click the Mirror button on the Draw toolbar, specify 0 
and 3e-3 as Point on line for x and y, respectively. Type 0 and 1 in the edit fields for 
Normal vector x and y, respectively. Click OK.

11 Delete the original object you used to create the mirror image.

Now start creating the 3D objects by extruding the 2D versions:

1 From the Draw menu, select Extrude.

2 Select all objects, type 1e-3 in the Distance edit field and click OK. 

3 Click the Coerce to Solid button on the Draw toolbar.

4 Go back to Geom1.

5 Draw an additional Rectangle with a width of 12e-3, a height of 12e-3, and starting 
with a lower left corner at the origin (0, 0).

6 Go to the Draw menu and select Extrude. Select the large rectangle R5, type -0.2e-3 
in the Distance edit field and click OK.

7 Press shift and click the two geometry objects to select both of them.

8 Click the Create Pairs (without imprints) button on the Draw toolbar. This allows 
you to mesh the two objects independently by creating an assembly with two parts 
that are connected by the identity pairs.

9 Go to the Mesh menu and select Mapped Mesh Parameters. Select Boundaries 10, 14, 
24, 25, 34, 38, and 46.

10 Select Extra fine from the Predefined mesh sizes list and click Mesh Selected. Click OK.

11 Click the Subdomain Mode button on the Main toolbar.

12 Press shift and click the subdomains of the gas channel to select these domains.

13 Click the Mesh Selected (Swept) button on the Mesh toolbar.

14 Click the Boundary Mode button on the Main toolbar.

15 Go to the Mesh menu and select Mapped Mesh Parameters. Select Boundary 3.

16 Select Finer from the Predefined mesh sizes list and click Mesh selected. Click OK.
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17 Go to the Mesh menu and select Swept Mesh Parameters. Select Subdomain 1 and 
select the Manual specification of element layers check box. Type 2 in the Number of 

element layers edit field. Click Mesh selected and then OK.

M O D E L  N A V I G A T O R

Next, add the necessary application modes:

1 From the Multiphysics menu, open the Model Navigator.

2 Select Geom2 in the Multiphysics area.

3 In the list of application modes select 
Chemical Engineering Module>Momentum Transport>Laminar Flow>Incompressible 

Navier-Stokes. Click Add.

4 In the list of application modes select 
Chemical Engineering Module>Mass Transport>Maxwell-Stefan Diffusion and 

Convection. Type w_O2 w_H2O w_N2 in the Dependent variables edit field. Click Add.

5 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

2 Define the following constants (the descriptions are optional); when done, click OK.

NAME EXPRESSION DESCRIPTION

mu 2e-5[Pa*s] Dynamic viscosity

p0 1.013e5[Pa] Outlet pressure

dp 2.5e-4*p0 Pressure drop

R 8.314[J/(mol*K)] Gas constant

T0 353[K] Temperature

F 96485[C/mol] Faraday’s constant

rho_M0 p0/(R*T0) Molar density

eta 0.2[V] Overvoltage

M_O2 32[g/mol] Molar mass, O2

M_H2O 18[g/mol] Molar mass, H2O

M_N2 28[g/mol] Molar mass, N2

v_O2 16.6e-6 Molar diffusion volume, O2

v_H2O 12.7e-6 Molar diffusion volume, H2O

v_N2 17.9e-6 Molar diffusion volume, N2

eps 0.5 Porosity, cathode
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3 From the Options menu, select Expressions>Scalar Expressions.

4 Enter the following expressions (the descriptions are optional); when done, click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings— Incompressible Navier-Stokes
1 From the Multiphysics menu, select Geom2: Incompressible Navier-Stokes (chns).

2 From the Physics menu, select Subdomain Settings. 

w_O20 0.1447 Inlet mass fraction, O2

w_H2O0 0.3789 Inlet mass fraction, H2O

k 3.16e-8[Pa*m^2/s] MS diffusivity prefactor

D_O2_H2O k*(T0[1/K])^1.75*(1[kg/
mol]/M_O2+1[kg/mol]/
M_H2O)^0.5/(p0*(v_O2^(1/
3)+v_H2O^(1/3))^2)

MS diffusivity, O2-H2O 
component

D_O2_N2 k*(T0[1/K])^1.75*(1[kg/
mol]/M_O2+1[kg/mol]/
M_N2)^0.5/(p0*(v_O2^(1/
3)+v_N2^(1/3))^2)

MS diffusivity, O2-N2 
component

D_H2O_N2 k*(T0[1/K])^1.75*(1[kg/
mol]/M_H2O+1[kg/mol]/
M_N2)^0.5/(p0*(v_H2O^(1/
3)+v_N2^(1/3))^2)

MS diffusivity, H2O-N2 
component

DO2_H2O_eff D_O2_H2O*por^1.5 Effective MS diffusivity, 
O2-H2O component

DO2_N2_eff D_O2_N2*por^1.5 Effective MS diffusivity, 
O2-N2 component

DH2O_N2_eff D_H2O_N2*por^1.5 Effective MS diffusivity, 
H2O-N2 component

S_a 1e7[1/m] Specific surface area

d 10[um] Active-layer thickness

i0 1[A/m^2] Exchange current density

t_H2O 3 Drag number, H2O

NAME EXPRESSION DESCRIPTION

NAME EXPRESSION DESCRIPTION

M_g M_O2*x_w_O2_chms+M_H2O*x_w_H2O_chms
+M_N2*x_w_N2_chms

Total molar mass

i_c -S_a*d*i0*exp(0.5*F*eta/
(R*T0))*w_O2/w_O20*(w_O2>0)

Current density
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3 Select Subdomain 1, then clear the Active in this domain check box.

4 Select Subdomains 2–8. Type rho_chms and mu in the ρ and η edit fields, 
respectively.

5 Click the Artificial diffusion button.

6 Clear the Streamline diffusion check box. Click OK.

7 Click OK.

Boundary Conditions—Incompressible Navier-Stokes
1 From the Physics menu, select Boundary Settings. 

2 Enter boundary conditions according to the following table; when done, click OK.

Subdomain Settings—Maxwell-Stefan Diffusion and Convection
1 From the Multiphysics menu, select 

Geom2: Maxwell-Stefan Diffusion and Convection (chms).

2 From the Physics menu, select Subdomain Settings.

3 On the General page, select all subdomains.

4 Type M_g*rho_M0 in the ρ edit field., Similarly, type p0, T0, u, v, and w in the edit 
fields for Pressure, Temperature, x-velocity, y-velocity, and z-velocity, respectively.

5 Select Subdomain 1 only. Replace the expression in the x-velocity edit field by 
-dflux_w_N2_x_chms/(w_N2*rho_chms).

6 Similarly type -dflux_w_N2_y_chms/(w_N2*rho_chms) and 
-dflux_w_N2_z_chms/(w_N2*rho_chms) in the y-velocity and z-velocity edit 
fields, respectively.

7 Select Subdomain 1 and click Edit. Set the Maxwell-Stefan diffusion coefficients to 
D_O2_H2O_eff, D_O2_N2_eff, and D_H2O_N2_eff(see the following image). Click 
OK.

SETTINGS BOUNDARY 8 BOUNDARY 44

Type Inlet Outlet

Condition Pressure, no viscous 
stress

Pressure, no viscous 
stress

Value p0 p0+dp p0
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8 Select Subdomains 2–8, then click Edit. Set the Maxwell-Stefan diffusion coefficients 

to D_O2_H2O, D_O2_N2, and D_H2O_N2. Click OK

9 Select all subdomains. Click the tabs for each species and set the Molecular weight to 
M_O2, M_H2O, and M_N2 respectively.

10 Click the Init tab and set the initial conditions according to the following table:

11 Click OK. 

Boundary Conditions—Maxwell-Stefan Diffusion and Convection
1 From the Physics menu, select Boundary Settings.

2 Enter boundary conditions for w_O2 as follows:

3 On the w_H2O page, enter the same boundary conditions but specify the 
Mass fraction w_H2O0.

4 Select Boundary 3. From the Boundary condition list, select Flux. In the 
Inward mass flux edit field, type -i_c*M_H2O*(1/2+t_H2O)/F.

5 Click the w_O2 tab. From the Boundary condition list, select Flux. In the 
Inward mass flux edit field, type i_c*M_O2/(4*F).

6 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

Because there is only a one-way coupling between the Navier-Stokes and 
Maxwell-Stefan equations, solve first the momentum transport and then the mass 
transport equations. In this case you set up and use a script to solve the problem.

1 Click the Solver Parameters button on the Main toolbar.

2 From the Linear system solver list, select Direct (UMFPACK).

3 Click OK.

4 Click the Solver Manager button on the Main toolbar.

5 On the Initial Value page, select Initial value expression in the Initial value area.

PROPERTY VALUE

w_O2(t0) w_O20

w_H2O(t0) w_H2O0

SETTINGS BOUNDARY 8 BOUNDARY 44

Type Mass fraction Convective flux

Value w_O20
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6 On the Solve For page, select Incompressible Navier-Stokes (chns) from the 
Solve for variables list. Click Apply.

7 On the Script page select the Solve using a script check box and click the 
Add Current Solver Settings button to generate the first part of the script.

8 Go to the Initial Value page and select Current Solution in the Initial value area.

9 On the Solve For page, select the application mode 
Maxwell-Stefan Diffusion and Convection (chms). Click Apply.

10 On the Script page, click the Add Current Solver Settings button to generate the 
second part of the solver script. Click OK.

11 Click the Solve button on the Main toolbar.

To calculate the solution, your computer needs approximately 850 MB of free 
memory. The solution converges in approximately 500 seconds on a 1.5 GHz Intel 
Pentium M processor.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Click the Plot Parameters button on the Main toolbar.

2 To generate Figure 9-29, go to the Slice page. From the Predefined quantities list, 
select Maxwell-Stefan Diffusion and Convection (chms)>Mass fraction, w_O2.

3 In the Slice positioning area, type 5 in the Number of levels edit field for y levels.

4 For x levels, click the Vector with coordinates option button to specify coordinates 
manually. In the Vector with coordinates edit field, type 1.5e-3 4.5e-3 7.5e-3 
10.5e-3. Click Apply.

To produce Figure 9-30, proceed as follows:

5 On the Slice page, select Incompressible Navier-Stokes (chns)>Velocity field from the 
Predefined quantities list. Click OK.

Reproduce the plot in Figure 9-31 with the following steps:

6 From the Postprocessing menu, select Domain Plot Parameters.

7 On the Surface page, select Boundary 3. Type i_c in the Expression edit field, then 
click OK.

Finally, generate the plot in Figure 9-32 as follows: 

8 Click the Plot Parameters button on the Main toolbar.

9 On the Slice page, select Maxwell-Stefan Diffusion and Convection (chms)>Mass 

fraction, w_H2O from the Predefined quantities list.

10 Click OK.
S E R P E N T I N E  P R O T O N  E X C H A N G E  M E M B R A N E  F U E L  C E L L  C A T H O D E  |  617



618 |  C H A P T E
 R  9 :  E L E C T R O C H E M I C A L  C E L L S  A N D  E L E C T R O C H E M I C A L  E N G I N E E R I N G



 10
E l e c t r o p h o r e s i s  a n d  C h r o m a t o g r a p h y
This chapter contains examples of mass transport coupled to momentum 
transport, where the systems are generally found in microsystems and are often 
affected by electrical fields. The diffusion of ionic species through charged media 
or carried by electrolytes can be quite difficult to model. Yet, an electric field is 
quite easy to control, which means that the flow and distribution of charged ions, 
particularly with analysis instruments, is best steered by this media. COMSOL 
Multiphysics is well suited to analyze these types of processes for two reasons:

• Its ability to model multiphysics applications easily and quickly—often you need to 
model momentum and mass transport to a description of the electric potential 
field. The system could depend on an arbitrary description of the double charge 
layer at a boundary or could depend on another description of the electric field.

• Its ability to handle equation-based modeling—the coupling between the physics 
that describes such systems can be unusual. Furthermore, chemical kinetics can 
be involved along with sudden changes in time-based phenomena or phases. The 
ability to quickly type in your own equations is therefore useful.
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E l e c t r o pho r e s i s—Tran s po r t  i n  a  
C ap i l l a r y  C o l umn

Introduction

In analytical chemistry, CZE (capillary zone electrophoresis) is the most common 
electrophoretic separation technique. A typical CZE instrument consists of a capillary, 
a detector, and a high-voltage power supply (see Figure 10-1).

Figure 10-1: Configuration of a CZE instrument.

The capillary is made of fused silica clad with a thin polymer layer to make the capillary 
flexible. The outer diameter is roughly 375 µm, and the inner diameter is between 
25 µm and 100 µm. The length of the capillary varies and can be as much as 1 m long 
while bridging two buffer reservoirs. A voltage applied between the reservoirs 
generates a field strength in the capillary of 70–100 kV/m. When a sample is 
introduced at one end of the capillary, the applied voltage induces migration of the 
different ions. Separation occurs due to differences in the ions’ electrophoretic 
mobilities.

This example illustrates the basic principles of electrophoretic separation with the help 
of two models. In Model 1, you consider a simplified system that does not include any 
protolytic equilibria, that is, the electrolyte and analyte ions are completely ionized. 
Model 2 is experimentally more realistic because it considers a buffered electrolyte. In 
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this case both the electrolyte and analyte ions can be partially ionized so the simulation 
includes protolytic equilibria.

Model Definitions

M O D E L  1

The first model demonstrates some principles of the theory of electrophoresis. The 
mass transport equation for species  i  in an electrophoretic system reads

 (10-1)

where ci denotes the concentration (mol/m3), Φi equals the migrational flux (mol/
(m2·s)), and Di refers to the diffusion coefficient (m2/s).

For an ionic species in CZE, two effects cause the migrational flux: a flow of the 
background electrolyte (BGE), usually an electroosmotic flow, and the local electric 
field strength in the column. The mass-balance analysis gives

 (10-2)

where u denotes the linear velocity (or electroosmotic flow) of the BGE (m/s), F 
refers to Faraday’s constant (96,485 C/mol), zi is the charge number of species i, umi 
gives the electrophoretic mobility of species i (mol·m2/(J·s)), and E is the local electric 
field strength within the column (V/m).

The local electric field strength in the column depends on the current density through 
the column and on the concentration profiles for the different charged species. 
Assuming that electroneutrality is maintained at all times, implies that

 (10-3)

Multiplying Equation 10-1 for each species i by zi, and summing the so obtained 
equations over all species, leads upon using Equation 10-3 to the equation

 (10-4)
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which can be integrated to give

 (10-5)

Here  j denotes the current density through the column (A/m2) and κ equals the local 
electrolyte conductivity (S/m). The latter quantity depends on the local concentration 
of the different ionic species through the equation

 (10-6)

This treatment assumes that the current through the column is constant during the 
experiment. The model also makes use of the following relationship between mobility 
and diffusion constant for an ionic species:

 (10-7)

where R is the gas constant (8.314 J/(mol·K)) and T denotes the temperature (K).

It is well known that ionic mobility decreases with increasing ionic strength in the 
solution. However, this treatment assumes that the mobility is constant and 
independent of the ionic strength of the BGE.

Input Data
This study covers the migration of two analyte ions (benzoic acid and chlorobenzoic 
acid) migrating in a BGE consisting of sodium acetate at pH = 7. Such a BGE is not 
suitable for practical use because of the extremely low buffer capacity of acetate at this 
pH. This means that you can neglect protolytic equilibria in this model.

The model domain is a uniform 2 mm long column. The two analyte ions are injected 
with a Gaussian initial concentration profile around the column center at x = 0:

.  (10-8)

This example uses the values a = 1·109 (m−2) and ci0 = 10 mol/m3 for the two analyte 
ions. The concentration of sodium acetate in the BGE is 50 mol/m3. Sodium is also 
the counter ion to the two analyte ions in the analyte zone. The BGE’s relative 

κE j Di ziF
∂ci
∂x
-------

i
∑+=

κ F2 zi umi ci

i
∑=

Di
RT umi

zi
-------------------=

ci x( ) ci0 ax2
–( )exp=
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permittivity, εr, equals 80. The current density through the column is 19.23 A/m2, 
and the mobilities for the ionic species are as listed in the following table:

To obtain the corresponding electrophoretic mobilities, umi (mol·s/kg), divide these 
quantities by Faraday’s constant, F = 96,485 C/mol.

M O D E L  2

The previous case studies the migration of ionic analytes in a BGE consisting of 
completely ionized species. A more realistic CZE-system consists of a buffered BGE 
with analytes that are only partially ionized due to the acid-base equilibrium. Consider 
a sodium acetate buffer at pH = 4.2 and the migration of the same mixture as before, 
that is, benzoic acid and o-chlorobenzoic acid. In this case you must consider the 
following equilibria:

 (10-9)

 (10-10)

 (10-11)

 (10-12)

At pH = 4.2, half of the total concentration of benzoic acid is in the acidic form and 
the other half is in the basic form; this contrasts to o-Chlorobenzoic acid, which 95% 

ION SPECIES INDEX MOBILITY

Na+ 1 5.19·10-8 m2/(V·s)

AcO- 2 4.23·10-8 m2/(V·s)

Bz- 3 3.36·10-8 m2/(V·s)

ClBz- 4 3.42·10-8 m2/(V·s)

AcOH AcO- H+    pKa AcOH( ) 4.76=+↔

KAcOH
AcO-[ ] H+[ ]

AcOH[ ]
-------------------------------- 10 1.76–  mol/m3

= =

HBz Bz- H+
+     pKa HBz( ) 4.21=↔

KHBz
Bz-[ ] H+[ ]

HBz[ ]
-------------------------- 10 1.21–  mol/m3

= =

HBzCl BzCl- H+
+     pKa HBzCl( ) 2.94=↔

KHBzCl
BzCl-[ ] H+[ ]

HBz[ ]
--------------------------------- 100.06 mol/m3

= =

H2O OH- H+
+     pKw 14=↔

Kw OH-[ ] H+[ ] 10 8–  mol/m3
= =
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is in the basic form. Therefore, at pH = 4.2 the migration velocity for o-Chlorobenzoic 
acid is almost twice that of Benzoic acid, and they are therefore easily separated.

To readily allow for a comparison of the results with those of the previous model, this 
case keeps the current density and the concentrations of all anions at the same values 
as before, that is, the total concentration of all species is adjusted with the acid 
dissociation constant.

Results and Discussion

M O D E L  1

The first model demonstrates some electrophoretic principles by studying a simplified 
system, that is, the simultaneous movement in the electric field of five ions, 
maintaining local electroneutrality and overall conservation of mass for each one. 
Figure 10-2a depicts the concentration profiles for the sodium ion and the two analyte 
ions at t = 0. The initial concentration of AcO- is constant at all points in the system.

Figure 10-2b shows the concentration profiles for the sodium, acetate, and the two 
analyte ions after 0.4 s of electrophoretic migration. The small difference in mobility 
between the two benzoic acids is not large enough to bring any significant separation 
between them. It is interesting to note that the concentration of both sodium and 
acetate is lower in the zones containing the analyte ions than in the BGE.

Figure 10-2: Concentration profiles: (a) Na+, Bz-, and BzCl- at  t = 0; (b) Na+, AcO-, 
Bz-, and BzCl- at   t = 0.5 s.

The difference in ionic composition at different locations in the column gives a 
difference in the local conductivity. Because the current is constant throughout the 
column, the variation in ionic conductivity leads to a variation in the local electric field 
strength, E. This is illustrated in Figure 10-3 for t = 0 and t = 0.4 s.

(a) (b)
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Figure 10-3: Electric field strength at  t = 0 and t = 0.4 s.

According to classical electrophoretic theory, the Kolrausch regulating function

 (10-13)

should be constant across all moving boundaries. Figure 10-4 plots this function at 
t = 0.4 s for the same conditions as in Figure 10-3. It is clearly visible that the function 
is constant across all moving fronts and that its value varies only across the stationary 
zone situated at x = 0.

Figure 10-4: The Kohlrausch regulating function at  t = 0.4 s.

K
zi ci

umi
------------

i
∑=
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M O D E L  2

The second model studies a more realistic electrophoretic experiment. Here pH is 
lowered so that the difference in pKa values between Benzoic acid and 
o-Chlorobenzoic acid is applied to achieve a separation between the two components 
in the column. The value for the current density and concentration of the ionic form 
of the analytes is the same as in the previous example. The total acetate ion 
concentration is also adjusted so that the acetate anion concentration in the BGE is the 
same as before. 

In contrast to the previous example, in this second model you also include the H+ 
concentration in the calculations. This implies that pH is allowed to vary in the column 
and that all protolytic equilibria must be satisfied simultaneously and in combination 
with the ionic mass balances and the electroneutrality condition.

Figure 10-5 shows the total concentration of the two analytes together with a pH =  
–log(cH+) = 4.2 at  t = 0. This decreases the migration velocity of Benzoic acid so that 
the two anions can now be separated after only 0.4 s of electrophoretic migration (see 
Figure 10-6.

Figure 10-5: The concentration profiles for benzoic acid (black) and o-chlorobenzoic acid 
(red) at  t = 0.
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Figure 10-6: The concentration profiles for benzoic acid (black) and o-chlorobenzoic acid 
(red) at  t = 0.4 s.

Figure 10-7 displays the pH at t = 0.4 s. As the figure shows, the value is lower in the 
analyte zones and higher in the stationary zone compared to the pH value in the BGE. 

Figure 10-7: pH in the system at  t = 0.4 s.
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Model Library path: Chemical_Engineering_Module/
Electrophoresis_and_Chromatography/capillary_electrophoresis_1

Modeling Using the Graphical User Interface—Model 1

1 Start COMSOL Multiphysics.

2 In the Model Navigator, select 1D from the Space dimension list.

3 In the list of application modes select Chemical Engineering Module> 
Mass Transport>Electrokinetic Flow>Transient analysis.

4 In the Dependent variables edit field, type c1 c2 c3 c4.

5 Click first the Multiphysics button and then the Add button.

6 Select the application mode COMSOL Multiphysics >PDE Modes>PDE, General Form.

7 In the Dependent variables edit field, type V.

8 Click Add, then click OK.

G E O M E T R Y  M O D E L I N G

1 Shift-click the Line button on the Draw toolbar.

2 Enter the Coordinates -1e-3 1e-3, then click OK.

3 Click the Zoom Extents button on the Main toolbar.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

2 Define the following constants (the descriptions are optional); when done, click OK.

NAME EXPRESSION DESCRIPTION

a 1.0e9[1/m^2] Gaussian distribution 
inverse-variance parameter

c0 10[mol/m^3] Initial peak concentration, 
analyte ions

c_BGE0 50[mol/m^3] Initial BGE concentration

u_m1 5.19e-8[m^2/(V*s)]/F Electrophoretic mobility, Na+

u_m2 4.23e-8[m^2/(V*s)]/F Electrophoretic mobility, AcO-
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3 Select Options>Expressions>Scalar Expressions.

4 Enter the following expressions; when done, click OK.

P H Y S I C S

Subdomain Settings—Electrokinetic Flow
1 From the Physics menu, select Subdomain Settings.

2 On each page listed in the table heading, enter the corresponding coefficients.

u_m3 3.36e-8[m^2/(V*s)]/F Electrophoretic mobility, Bz-

u_m4 3.42e-8[m^2/(V*s)]/F Electrophoretic mobility, ClBz-

eps_BGE 80*8.854e-12[F/m] Electric permittivity of BGE

F 96485[C/mol] Faraday’s constant

RT 2476.38[J/mol] Gas constant times temperature

D1 RT*u_m1 Diffusion coefficient, Na+

D2 RT*u_m2 Diffusion coefficient, AcO-

D3 RT*u_m3 Diffusion coefficient, Bz-

D4 RT*u_m4 Diffusion coefficient, ClBz-

j0 19.23[kA/m^2] Current density

kappa0 F^2*(u_m1+u_m2)*c_BGE0 Conductivity at boundaries

E0 j0/kappa0 Electric field at boundaries

NAME EXPRESSION DESCRIPTION

c_G c0*exp(-a*x^2) Gaussian concentration distribution

c10 2*c_G+c_BGE0 Initial concentration, Na+

c30 c_G Initial concentration, Bz-

c40 c_G Initial concentration, ClBz-

K c1/u_m1+c2/u_m2+ 
c3/u_m3+c4/u_m4

Kolrausch regulating function

QUANTITY  c1  c2  c3  c4

D D1 D2 D3 D4

um u_m1 u_m2 u_m3 u_m4

z 1 -1 -1 -1

V V V V V

NAME EXPRESSION DESCRIPTION
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3 On the Init page, set the following initial values; when done, click OK.

Boundary Conditions—Electrokinetic Flow
1 From the Multiphysics menu, select 1 Electrokinetic Flow (chekf).

2 From the Physics menu, select Boundary Settings.

3 For each species, i = 1, 2, 3, and 4, select Concentration as the Boundary condition. 
Specify the concentrations according to the following table:

4 Click OK.

Subdomain Settings—PDE, General Form
1 From the Multiphysics menu, select 2 PDE, General Form (g).

2 From the Physics menu, select Subdomain Settings.

3 Enter the following values; when done, click OK.

Boundary Conditions—PDE, General Form
1 From the Physics menu, select Boundary Settings.

2 Select Boundary 1.

3 Click the Neumann boundary condition option button, then set g to –E0.

4 Select Boundary 2. 

5 Click the Dirichlet boundary condition option button, then set R to –V.

6 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters.

VARIABLE INITIAL VALUE

c1(t0) c10

c2(t0) c_BGE0

c3(t0) c30

c4(t0) c40

QUANTITY  c1  c2  c3  c4

ci0 c10 c_BGE c30 c40

COEFFICIENTS VALUE

 Γ -Vx

 F eps_BGE*(c1-c2-c3-c4)/F
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2 On the Global page, set the Maximum element size to 2e-6.

3 Click Remesh, then click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 Set Times to 0:0.05:0.5.

3 Click the Time Stepping tab.

4 In the Advanced area, select On in the Consistent initialization of DAE systems list. Click 
OK.

5 Click the Solve button on the Main toolbar.

Model Library path: Chemical_Engineering_Module/
Electrophoresis_and_Chromatography/capillary_electrophoresis_2

Modeling Using the Graphical User Interface—Model 2

1 In the Model Navigator, select 1D from the Space dimension list.

2 In the list of application modes select Chemical Engineering Module> 
Mass Transport>Electrokinetic Flow>Transient analysis.

3 In the Dependent variables edit field, type c1 c2 c3 c4 c5.

4 Click first the Multiphysics button and then the Add button.

5 From the list of application modes, select Chemical Engineering Module> 
Mass Transport>Convection and Diffusion>Transient analysis.

6 In the Dependent variables edit field, type c6 c7 c8. Click Add.

7 From the list of application modes, select 
COMSOL Multiphysics>PDE Modes>PDE, General Form. 

8 In the Dependent variables edit field, type V. Click Add.

9 Click OK.

G E O M E T R Y  M O D E L I N G

Generate the geometry in the same way as in Model 1.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.
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2 To the constants from Model 1, add the following ones; when done, click OK.

3 From the Options menu, select Expressions>Scalar Expressions.

4 Change the expression for c10 from Model 1 to 2*c_G+c_BGE0-c50.

5 Add the following expressions to those you entered in Model 1:

6 Click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings—PDE, General Form
1 From the Physics menu, select Subdomain Settings.

2 Set Γ to -Vx and F to F*(c1-c2-c3-c4+c5)/eps_BGE.

3 Click OK.

NAME EXPRESSION DESCRIPTION

u_m5 1e-7[m^2/(V*s)]/F Electrophoretic mobility, H+

D5 RT*u_m5 Diffusion coefficient, H+

c50 0.06310[mol/m^3] Initial concentration, H+

c60 181.54[mol/m^3] Initial concentration, AcOH

K_HBz (10^(-1.21))[mol/m^3]

K_HBzCl (10^0.006)[mol/m^3]

k1_Ac 1e8[1/s] Reaction rate constant

k2_Ac 5.754e9[m^3/(mol*s)] Reaction rate constant

k1_HBz 1e8[1/s] Reaction rate constant

k2_HBz 1.622e9[m^3/(mol*s)] Reaction rate constant

k1_HBzCl 1e8[1/s] Reaction rate constant

k2_HBzCl 9.863e7[m^3/(mol*s)] Reaction rate constant

u0 1[mm/s] Flow velocity

NAME EXPRESSION DESCRIPTION

c70 c30*c50/K_HBz Initial concentration, HBz

c80 c40*c50/K_HBzCl Initial concentration, HBzCl

r_Ac k1_Ac*c6-k2_Ac*c5*c2 Reaction rate

r_Bz k1_HBz*c7-k2_HBz*c5*c3 Reaction rate

r_BzCl k1_HBzCl*c8-k2_HBzCl*c5*c4 Reaction rate

pH -log10(c5/1[mol/l]) pH value
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Boundary Conditions—PDE, General Form
Use the same boundary conditions as in Model 1.

Subdomain Settings—Electrokinetic Flow
1 From the Physics menu, select Subdomain Settings.

2 Enter the following coefficients:

3 Click the Init tab.

4 The initial conditions are the same as in Model 1 for the concentrations c1, c2, c3, 
and c4.

5 For c5 set the initial condition to c50.

6 Click OK.

Boundary Conditions—Electrokinetic Flow
1 From the Physics menu, select Boundary Settings.

2 Specify the same boundary conditions as in Model 1 for species 1–4.

3 For species 5, set the boundary condition to Concentration. In the c50 edit field, type 
c50.

4 Click OK.

Subdomain Settings—Convection and Diffusion
1 From the Physics menu, select Subdomain Settings.

2 Enter the following values:

3 Click the Init tab.

QUANTITY  c1  c2  c3  c4  c5

D D1 D2 D3 D4 D5

R r_Ac r_Bz r_BzCl r_Ac+r_Bz+r_BzCl

um u_m1 u_m2 u_m3 u_m4 u_m5

z 1 -1 -1 -1 1

u -u0 -u0 -u0 -u0 -u0

V V V V V V

QUANTITY  c6  c7  c8

D D2 D3 D4

R -r_Ac -r_Bz -r_BzCl

u -u0 -u0 -u0
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4 Enter the following initial conditions:

5 Click OK.

Boundary Condition—Convection and Diffusion
1 From the Physics menu, select Boundary Settings.

2 Select both boundaries and enter the following conditions; when done, click OK.

M E S H  G E N E R A T I O N

Generate the mesh in the same way as in Model 1.

C O M P U T I N G  T H E  S O L U T I O N

Use the same solver settings as in Model 1.

VARIABLE INITIAL VALUE

c6(t0) c60

c7(t0) c70

c8(t0) c80

PAGE  c6  c7  c8

Type Concentration Concentration Concentration

Value c60 c70 c80
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L i q u i d  Ch r oma t o g r aph y

Introduction

Chromatography is an important group of methods to separate closely related 
components of complex mixtures. The following examples simulate the separation in 
High Performance Liquid Chromatography (HPLC). In this technique an injector 
introduces a sample as a zone in a liquid mobile phase. The mobile phase containing 
the sample zone is pumped through a column containing a solid stationary phase; 
Figure 10-8 shows a diagram of such an instrument.

Figure 10-8: Diagram of an HPLC system.

The mobile and stationary phases are chosen so that the sample components are 
distributed to varying degrees between the two phases. Those components that 
strongly adsorb to the stationary phase move only slowly with the flow of the mobile 
phase, and those that are weakly adsorbed move more rapidly. As the sample zones 
migrate through the column, the components are separated into discrete zones that 
are recognized in a detector, situated after the outlet of the column.

Model Definitions

The first two models study the separation of two species under conditions of non-linear 
chromatography, where the analyte concentration is high, and in a 1D geometry. The 
first model considers only the column itself. The second model considers a complete 
system, from injector to detector. The third model examines the transport of a single 
band of solute through a column under conditions of linear chromatography, where 
the analyte concentration is low, but in a complex 3D geometry1. In addition, it factors 
in temperature rise effects due to viscous friction. 

1. Courtesy of Bernard Bunner, Waters Corporation.
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D E F I N I T I O N — M O D E L  1

The mass transport equation is valid for the analyte component during its migration 
through the chromatographic column. If you neglect the dispersion of the 
chromatographic zone during the migration, the mass transport equation takes the 
form

 (10-14)

where S denotes the surface area of the particles in the column (m2/kg), ρ denotes 
the density of the solid particles (kg/m3), ε equals the column porosity, A gives the 
inner area of the column tube, ni equals the analyte concentration in the stationary 
phase of component i (mol/m2), v is the mobile phase flow (m3/s), and ci equals the 
analyte concentration in the mobile phase of component i (mol/m3).

The ideal model for chromatography assumes that the equilibrium for the analyte 
between the mobile and stationary phases is immediate, that is,

.  (10-15)

The mass transport equation for the ideal chromatography model therefore becomes

.  (10-16)

The dispersion or band broadening of the analyte zone that is obtained during the 
migration through the column is a result of a great number of random processes that 
the analyte experiences (for example, inhomogeneous flow and diffusion in pores and 
the mobile phase). It is therefore possible to formally express the band broadening as 
a diffusion process with an effective diffusion constant, Deff. Thus, Deff is a measure of 
the chromatographic system’s efficiency for a particular analyte. This constant is closely 
related to the concept of the height equivalent of a theoretical plate, H, that is 
customarily used in chromatographic practice. It can be shown that

 (10-17)

where vzi is the migration velocity of the analyte zone through the column. A mass 
balance that includes the zone-dispersion term gives the following equation:

Sρ 1 ε–( )
ε

--------------------
∂ni
∂t

--------⋅
∂ci
∂t
-------+

v
εA
-------

∂ci
∂x
-------⋅–=

∂n
∂t
------ dn

dc
-------⎝ ⎠
⎛ ⎞ ∂ci

∂t
-------⋅=

1 Sρ 1 ε–( )
ε

-------------------- dn
dc
-------⋅+⎝ ⎠

⎛ ⎞ ∂ci

∂t
-------⋅ v

εA
-------

∂ci

∂x
-------–=

Deff
Hvzi

2
------------=
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 (10-18)

Here Φ = Sρ( 1 − ε )/ε denotes the phase ratio of the column (m2/m3), vl = v/(εA) 
gives the linear velocity of the mobile phase in the column (m/s), and Deff is the 
effective diffusion constant (m2/s).

This first example covers the migration within the column of two components. The 
adsorption isotherm for both components is assumed to follow a Langmuir adsorption 
isotherm, that is,

 (10-19)

and

 (10-20)

where Ki is the adsorption constant for component i (m3/mol), and n0i is the 
monolayer capacity of the stationary phase for component i (mol/m2).

I N P U T  D A T A

This example looks at the migration of a chromatographic zone migrating only within 
the column. The physical data for the column correspond to a 12 cm × 4 mm inner 
diameter column filled with 5 µm porous particles (εcolumn = 0.6) with a specific 
surface area of 100 m2/g, which gives a column phase ratio, Φ, of 1.533·108 m−1. 
Additional input data appear in Table 10-1.

TABLE 10-1:  INPUT DATA

NAME VALUE

 vl 2.22 mm/s

 Deff1 1⋅10-8 m2/s

 Deff2 3⋅10-8 m2/s

 K1 0.04 m3/mol

 n01 1⋅10-6 mol/m2

 K2 0.05 m3/mol

 n02 5⋅10-7 mol/m2

1 Φ dn
dc
-------⋅+⎝ ⎠

⎛ ⎞ ∂ci
∂t
-------⋅ vl

∂ci
∂x
------- Deff

∂2ci

∂x2
----------+–=

ni
n0iKici

1 Kici+
--------------------=

dni
dci
---------

n0iKi

1 Kici+( )2
----------------------------=
L I Q U I D  C H R O M A T O G R A P H Y  |  637



638 |  C H A P T E
The initial concentrations for the two components are described by the normal 
distribution

  (10-21)

where a equals 1·105 m−2, and the starting point at t = 0 is at x = 0.01 m. You first 
solve the model for the initial injector concentrations c01 = c02 = 0.1 mol/m3, which 
corresponds to the linear regime for the adsorption isotherm. In a second stage, you 
increase the injector concentrations to c01 = 1 mol/m3 and c02 = 10 mol/m3.

D E F I N I T I O N — M O D E L  2

The second example studies a complete chromatographic system. The analyte is 
introduced through an injector at t = 0 and then transported in a tube to the column 
inlet. The initial concentration at the injector is c01 = 1  mol/m3 and c02 = 10 mol/
m3. In the injector, the initial concentration profile is a pulse that is smoothed at the 
end points. When the analyte has migrated through the column, it is eluted into a tube 
and then transported to the detector. Figure 10-9 shows the setup.

Figure 10-9: Geometry of the simulated model.

The injector volume is 20 µl (corresponding to an inner diameter of 1.6 mm), and the 
volumetric flow is 1 ml/min, which gives a linear velocity through the injector of vli = 
0.0083 m/s. The tube that connects the injector and the column has an inner diameter 
of 0.25 mm and is 10 cm long. These dimensions result in a linear velocity through the 
tube of 0.333 m/s. The tube’s dimensions between the column and the detector are 
the same as the previous tube. The data characteristic for the column and the analytes 
are the same as in the previous example.

D E F I N I T I O N — M O D E L  3

This model was provided by Bernard Bunner of Waters Corporation.

A bed of particles of diameter dp = 1.7 um is packed inside a 5 cm long, 2.1 mm 
diameter stainless steel column. The bed is held in place by 1 mm thick, 2.1 mm 
diameter frits at both ends of the column. Steel tubes are attached at both ends to 

ci0 x( ) c0i e a x 0.01–( )2–⋅=

Injector, 0.01 m

Column, 0.12 m

Detector

Tube, 0.10 m Tube, 0.10 m
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provide fluid connections to the injector and detector. You will model the bed as well 
as the frits as porous subdomains. The problem’s symmetry allows for a 2D 
axisymmetric model geometry.

The analysis includes flows in the column interior and in the pipes. The model 
computes the temperature rise due to viscous friction, accounting for the temperature 
dependences in both the fluid viscosity and diffusion coefficient.

Once you have computed the velocities and temperature field, you use the solution to 
calculate the transport by convection-diffusion of a narrow band of analyte that enters 
the inlet tube, travels through the column interior, and exits via the outlet tube.

Momentum transport
Unlike the examples of model 1 and 2, you assume that the analyte concentration is 
very small, and that the analyte does not have an influence on the viscosity and density, 
so that the flow problem is steady-state. Hence, the mass balance includes the 
continuity equation:

 (10-22)

The Navier-Stokes equations govern the flow in the pipes:

 (10-23)

Here ρ is the density (kg/m3), η denotes the viscosity (kg/(m· s)), and p refers to the 
pressure (Pa). 

In the porous subdomains (that is, the packed bed and frits) the Brinkman equations 
apply:

 (10-24)

Here ε is the porosity and κ is the hydraulic permeability (m2) of the porous medium, 
for the latter you use the following formula:

 (10-25)

The momentum transport boundary conditions are axial symmetry at r = 0:

∇ u⋅ 0=

ρ u ∇⋅( )u ∇+ pI η ∇u ∇u( )T
+( )–( )+[ ]⋅ 0=

η
κ
---u ∇+ pI η

ε
--- ∇u ∇u( )T

+( )–⋅ 0=

κ
dp( )2ε3

180 1 ε–( )2
------------------------------=
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 (10-26)

and no-slip conditions at all the other interior walls of the column.

Heat transport
The trend towards higher performance has led to the use of smaller particles for beds. 
However, smaller particles create larger back pressures, which can lead to significant 
heat generation through viscous friction inside the bed. In turn, this can lead to 
significant variations in the temperature across the column—and hence in the viscosity 
and the diffusion coefficient as well.

The temperature field is computed for the column interior, the tubes, and the column 
walls. The heat transport equation is

 (10-27)

where k is the thermal conductivity, and the heat source inside the bed is modeled as

 (10-28)

Within the column walls, Equation 10-27 is reduced to a heat conduction equation.

The boundary conditions are the following: insulation on the tube walls and column 
outer walls, axial symmetry at r = 0, convective flux at the outlet, and

 (10-29)

The temperature variation of the viscosity is modeled by 

 (10-30)

The molecular diffusion coefficient depends on the viscosity according to the 
Wilke-Chang relation

 (10-31)

which together with Equation 10-30 gives

p pin=  inlet

p 0= outlet

η ∇u ∇u( )T
+( )n 0= inlet/outlet

ρcpu ∇T⋅ ∇ k∇T( ) Q+⋅=

Q v∂p
∂z
------–=

T Tin      = inlet

η 10 3– 0.02 K 1– T 293 K–( )–( )  Pa·sexp=

Dmol T( ) Dmol T0( ) T
η T( )
------------=
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 (10-32)

In this example, you model the propagation of the Gaussian analyte-concentration 
peak

 (10-33)

where c0 = 1 mol/m3, t0 = 1 s, and a0 = 5 s−2. At the inlet, the pressure is 
pin = 5.45·107 Pa, and the temperature is Tin = 303 K. 

Analyte transport
For the free flow domains, the total molar flux of analyte is

 (10-34)

where c is the molar concentration of analyte (mol/m3), u is the velocity (m/s), and 
Dmol is the diffusion coefficient (m2/s). The mass balance gives the following 
convection and diffusion transport equation for the analyte:

 (10-35)

For the porous subdomains, use the superficial volume-averaged molar flux (that is, 
the number of moles transferred per unit area and time):

 (10-36)

Here u is the superficial volume-averaged velocity of the mobile phase, ε is the 
porosity, and Deff is the effective diffusion coefficient.

Note that c in Equation 10-36 presents the intrinsic volume-averaged molar 
concentration of analyte (mol/m3), which is the number of moles per unit volume of 
the mobile phase. The resulting transport equation for the analyte in the porous 
subdomains is

 (10-37)

For the porous subdomains, model the diffusion using the Van Deemter equation

 (10-38)

Dmol 10 9– T
293 K
---------------- 0.02 K 1– T 293 K–( )( )  m2/sexp=

cin t( ) c0 a0 t t0–( )2
–[ ]exp=

N Dmol∇– c cu+=

∂c
∂t
----- ∇ N⋅+ 0=

N εDeff∇– c cu+=

ε∂c
∂t
----- ∇ N⋅+ 0=

H u( ) 1.5dp
Dmol

u
-------------

dp( )2 u
6Dmol

---------------------+ +=
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and the effective diffusion coefficient

 (10-39)

where dp is the particle diameter, and

 (10-40)

is the absolute linear velocity.

Both concentration and flux remain continuous across the boundaries of the adjacent 
porous and free-flow subdomains, as defined above. This allows you to use a single 
convection and diffusion mode for modeling the analyte transport.

Use the following boundary conditions:

• axial symmetry at r = 0

• concentration at the inlet:

 (10-41)

• convective flux at the outlet:

 (10-42)

At all other interior column and tube walls, insulation conditions apply.

Results and Discussion

M O D E L  1

Figure 10-10 shows the zones of the two components at various times (0 s, 80 s, and 
160 s) as they migrate within the column. In this example, the analyte concentration 
at t = 0 is low for both components (c0i = 0.1 mol/m3); the solution is in the linear 

Deff 0.5 u H u( )=

u 1
ε
--- u2 v+

2
=

c cin t( )=

n Dmol∇– c( )⋅ 0=
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domain of the adsorption isotherm. This implies that the zones are symmetrical and 
normally distributed.

Figure 10-10: The concentrations of components 1 (solid) and 2 (dashed) in the mobile 
phase during the migration through the column at times 0, 80, and 160 s for initial 
injector concentrations c01 = c02 = 0.1 mol/m3.

When the initial concentrations increase, c01 = 1 mol/m3 and c02 = 10 mol/m3, the 
solution enters into the nonlinear domain of the adsorption isotherm, changing the 
behavior radically (see Figure 10-11). A comparison of the zone for component 2 
between the two simulations clearly shows that both the zone width and form is 
strongly influenced by migrating into the adsorption isotherm’s nonlinear domain.

Figure 10-11: The concentrations of components 1 (solid) and 2 (dashed) in the mobile 
phase during migration through the column at times 0 s, 80 s, and 160 s for initial 
injector concentrations c01 = 1 mol/m3 and c02 = 10 mol/m3.
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M O D E L  2

The second example studies the migration process from the injector, through the 
column, and to the detector. The initial concentration of the components in the 
injector is c01 = 1 mol/m3 and c02 = 10 mol/m3, and the characteristic data for the 
column and the two components are the same as in previous example. Figure 10-12 
displays the zone for the two components at t = 4 s, 80 s, and 160 s.

Figure 10-12: The concentration of components 1 (solid lines) and 2 (dashed lines) in the 
mobile phase during migration through the column at times 4, 80, and 160 s. In the 
injector, the concentrations of the components at t = 0 are c01 = 1 mol/m3 and c02 = 
10 mol/m3.

At t = 4 s, the two components have just entered the column, and they have 
accumulated into very narrow zones close to the column inlet at x = 0.11 m. It is 
interesting to look at the concentration profile of the zones during the accumulation 
process at the column inlet. Figure 10-13 shows the concentration for component 2 
in the mobile phase and stationary phase as well as the total column concentration at 
t = 2.0 s. At this time the component has not completely entered the column and the 
concentration in the tube prior to the column inlet (x < 0.11 m) is still non-zero. The 
figure illustrates the strong accumulation at the column inlet, and, additionally, the 
zone has a non-Gaussian form. When the components have migrated through the 
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column they are transported to a detector, and Figure 10-14 shows the chromatogram 
as it is obtained by the chromatographer.

Figure 10-13: Close-up of the concentration profile of component 2 during the entrance 
into the column. The solid line corresponds to the mobile phase concentration, the dashed 
line to the stationary phase concentration, and the dash-dotted line to the sum of mobile 
and stationary phase concentrations.

Figure 10-14: The chromatogram registered by the detector. The solid and dashed lines 
show the concentrations c1 and c2, respectively, as functions of time.
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M O D E L  3

The flow discharge of 0.58 ml/min is calculated. Figure 10-15 shows the temperature 
distribution within the column. The temperature rise is caused by friction in the bed, 
and the maximum temperature increase is about 18 degrees.

Figure 10-15: Temperature distribution.

Figure 10-16 illustrates the band broadening of the peak in terms of the total analyte 
flux, Φtot, obtained by integrating over the cross-section areas of the inlet and outlet 
tubes (R denotes the tube radius):

 (10-43)Φtot z t,( ) 2π D∂c
∂z
------– cv+⎝ ⎠

⎛ ⎞ rdr  (mol/s)
0

R

∫=
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Figure 10-16: Analyte flux through inlet (blue) and outlet (green) as functions of time.
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Model Library path: Chemical_Engineering_Module/
Electrophoresis_and_Chromatography/liquid_chromatography_1

Modeling Using the Graphical User Interface—Model 1

1 Start COMSOL Multiphysics.
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2 In the Model Navigator select 1D from the Space dimension list.

3 From the Application Modes list, select Chemical Engineering Module> 
Mass Transport>Convection and Diffusion>Transient analysis. In the Dependent 

variables edit field, type c1 c2.

4 Click OK.

O P T I O N S  A N D  S E T T I N G S

Enter the following constants in the Options/Constants dialog box:

G E O M E T R Y  M O D E L I N G

1 Select Draw>Specify Objects>Line.

2 In the Coordinates edit field, type 0 0.12.

3 Click OK.

4 Click the Zoom Extents button on the Main toolbar.

P H Y S I C S  S E T T I N G S

In order to define the problem, you must define two expression variables on the 
subdomain level.

1 Select Options>Expressions>Scalar Expressions.

NAME EXPRESSION DESCRIPTION

Phi 1.533e8[1/m] Phase ratio

v_l 2.22[mm/s] Linear velocity, mobile phase

D_eff1 1e-8[m^2/s] Effective diffusion constant, component 1

D_eff2 1e-8[m^2/s] Effective diffusion constant, component 2

c01 0.1[mol/m^3] Initial injector concentration, component 1

c02 0.1[mol/m^3] Initial injector concentration, component 2

K1 0.04[m^3/mol] Adsorption constant, component 1

K2 0.05[m^3/mol] Adsorption constant, component 2

n01 1e-6[mol/m^2] Monolayer capacity, component 1

n02 5e-7[mol/m^2] Monolayer capacity, component 2

a 1e5[1/m^2] Normal-distribution parameter

x0 0.01[m] Starting point
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2 Enter expressions for dni/dci according to this table; when done, click OK.

Subdomain Settings
1 From the Physics menu, select Subdomain Settings. Select Subdomain 1.

2 Enter subdomain settings for species 1 as follows:

3 Enter subdomain settings for species 2 as follows:

4 Click the Artificial Diffusion button.

5 Select the Streamline diffusion check box.

6 Select Anisotropic diffusion from the list and type 0.05 in the Tuning parameter edit 
field. Note that artificial diffusion should be used only for species 2.

7 On the Init page, enter these initial values:

8 Click OK.

Boundary Conditions
1 From the Physics menu, select Boundary Settings.

NAME EXPRESSION

dn1_dc1 n01*K1/(1+K1*c1)^2

dn2_dc2 n02*K2/(1+K2*c2)^2

PROPERTY VALUE

δts 1+Phi*dn1_dc1

D D_eff1

R 0

u v_l

PROPERTY VALUE

δts 1+Phi*dn2_dc2

D D_eff2

R 0

u v_l

VARIABLE INITIAL VALUE

c1(t0) c01*exp(-a*(x-x0)^2)

c2(t0) c02*exp(-a*(x-x0)^2)
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2 Enter boundary conditions for species 1 as follows:

3 Enter boundary conditions for species 2 as follows:

4 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, open the Free Mesh Parameters dialog box.

2 Click the Custom mesh size button and type 3e-4 in the Maximum element size edit 
field.

3 Click Remesh. When the mesher has finished, click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 In the Time stepping area, type 0:10:180 in the Times edit field.

3 Set the Relative tolerance to 1e-4 and the Absolute tolerance to 1e-7.

4 Click OK.

5 Click the Solve button on the Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To reproduce the plots in Figure 10-10, perform the following steps:

1 From the Postprocessing menu, select Domain Plot Parameters.

2 From the Solutions to use list, select 0, 80, and 160.

3 On the Line/Extrusion page, select Subdomain 1.

4 In the Expression edit field in the y-axis data area, type c1.

5 From the x-axis data list, select x.

6 Click the Line Settings button. Set the Line color to black, then click OK.

7 Click Apply to generate the graphs of c1.

SETTINGS BOUNDARY 1 BOUNDARY 2

Type Concentration Convective flux

c10 0 -

SETTINGS BOUNDARY 1 BOUNDARY 2

Type Concentration Convective flux

c20 0 -
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8 In the Expression edit field, type c2.

9 Click the Line Settings button. Set the Line style to Dashed line, then click OK.

10 On the General page, select the Keep current plot check box.

11 Click the Title/Axis button. In the Title/Axis Settings dialog box, click the option 
buttons next to the Title and Second axis label edit fields (leave the edit fields empty). 
Click OK.

12 Click OK to finalize the plot and close the Domain Plot Parameters dialog box.

Next, increase the initial injector concentrations and solve the model again.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

2 Change the values of c01 and c02 to 1[mol/m^3] and 10[mol/m^3], respectively.

3 Click OK.

S O L V I N G  T H E  M O D E L

Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Reproduce the plots in Figure 10-11 with the following steps:

1 From the Postprocessing menu, select Domain Plot Parameters.

2 On the General page, select 0, 80, and 160 from the Solutions to use list.

3 Clear the Keep current plot check box, then click Apply to generate the c2 graphs.

4 Select the Keep current plot check box.

5 On the Line/Extrusion page, type c1 in the Expression edit field.

6 Click the Line Settings button. Set the Line style to Solid line, then click OK.

7 Click OK.

Model Library path: Chemical_Engineering_Module/
Electrophoresis_and_Chromatography/liquid_chromatography_2

Modeling Using the Graphical User Interface—Model 2

Use the same application mode settings as in Model 1.
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O P T I O N S  A N D  S E T T I N G S

In addition to the constants defined in Model 1, add the following ones:

G E O M E T R Y  M O D E L I N G

1 Click the Draw Mode button on the Main toolbar.

2 Select the existing line by clicking on it.

3 Click the Move button on the Draw toolbar.

4 In the Displacement edit field, type 0.11. Click OK.

5 Specify three more lines with the following properties:

P H Y S I C S  S E T T I N G S

Subdomain Settings
To simplify the subdomain settings, first define three variables on the subdomain level.

1 From the Options menu, select Expressions>Subdomain Expressions.

2 Define the variables A, n1, and n2 in the different subdomains as follows:

3 Click OK.

4 From the Physics menu, select Subdomain Settings.

NAME EXPRESSION DESCRIPTION

A_i 2.01e-6 Time-scaling coefficient, injector

A_t 4.91e-8 Time-scaling coefficient, tube

A_c 7.54e-6 Time-scaling coefficient, column

D1 1.0e-9[m^2] Diffusion coefficient, component 1

D2 5.0e-10[m^2] Diffusion coefficient, component 2

V 1.67e-8[m/s] Flow velocity

LINE COORDINATES

L2 0 0.01

L3 0.01 0.11

L4 0.23 0.33

VARIABLE SUBDOMAIN 1 SUBDOMAINS 2, 4 SUBDOMAIN 3

A A_i A_t A_c

n1 0 0 n01*K1*c1/(1+K1*c1)

n2 0 0 n02*K2*c2/(1+K2*c2)
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5 Enter subdomain settings for species 1 according to the following table:

Artificial stabilization for species 1 is needed in Subdomains 1 and 2.

6 From the Subdomain selection list, select Subdomains 1 and 2.

7 Click the Artificial Diffusion button.

8 Select the Streamline diffusion check box, then select Anisotropic diffusion, and type 
0.05 in the Tuning parameter edit field. Click OK.

9 Enter subdomain settings for species 2 according to the following table:

Artificial stabilization for species 2 is needed in all subdomains.

10 Select all four subdomains and click the Artificial Diffusion button.

11 Select the Streamline diffusion check box. Select Anisotropic diffusion and type 0.2 in 
the Tuning parameter edit field. Click OK.

12 The initial values in Model 2 are zero for both species in Subdomains 2, 3, and 4. 
In Subdomain 1, set c1(t0) to c01 and c2(t0) to c02.

13 Click OK.

Boundary Conditions
Use the same boundary conditions as in Model 1, that is, zero concentrations at the 
inlet (Boundary 1) and convective flux conditions at the outlet (Boundary 5) for both 
species.

Mesh Generation
1 From the Mesh menu, choose Free Mesh Parameters.

2 On the Global page click the Custom mesh size button and enter 5e-3 in the Maximum 

element size edit field.

3 Go to the Subdomain page. 

SETTINGS SUBDOMAINS 1, 2, 4 SUBDOMAIN 3

δts A A*(1+Phi*dn1_dc1)

D A*D1 A*D_eff1

u V V

SETTINGS SUBDOMAINS 1, 2, 4 SUBDOMAIN 3

δts A A*(1+Phi*dn2_dc2)

D D2*A D_eff2*A

u V V
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4 Select Subdomain 3 and type 1e-4 in the Maximum element size edit field.

5 Go to the Boundary page. 

6 Select Boundaries 1, 2, 3, and 4. Type 1e-5 in the Maximum element size edit field.

7 Click Remesh. When the mesher has finished, click OK.

C O M P U T I N G  T H E  S O L U T I O N

Keep the solver settings as in Model 1 but change the Times to 0:0.05:1.95 2:450 
in the Time stepping frame. Compute the solution by clicking the Solve button on the 
Main toolbar.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

You create Figure 10-12 on page 644 in the same way as you did Figure 10-10 on page 
643, but his time do so for output times of 4 s, 80 s, and 160 s and in Subdomain 3.

To create Figure 10-13 on page 645, follow these steps:

1 From the Postprocessing menu, select Domain Plot Parameters.

2 From the Solutions to use list, select 2.

3 Click the Line/Extrusion tab.

4 From the Subdomain selection list, select Subdomains 2 and 3.

5 In the y-axis data area, type c2 in the Expression edit field.

6 From the x-axis data list, select x.

7 Click the Line Settings button. From the Line style list, select Solid line. Click OK.

8 Click Apply to generate the graph of c2.

9 On the General page, select the Keep current plot check box.

10 Return to the Line/Extrusion page. In the y-axis data area, type Phi*n2 in the 
Expression edit field.

11 Click the Line settings button. Change Line style to Dashed line, then click OK.

12 Click Apply to generate the graph of Φn2.

13 Finally, type c2+Phi*n2 in the Expression edit field for the y-axis data.

14 Click the Line settings button. Change Line style to Dash-dot line, then click OK.

15 Click OK to plot c2 + Φn2 and close the dialog box.

16 In the figure window, use the Zoom Window tool to zoom in near the point 
connecting Subdomains 2 and 3.

To reproduce the plots in Figure 10-14 on page 645, follow these steps:
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1 From the Postprocessing menu, select Domain Plot Parameters.

2 Select all the output times in the Solutions to use list.

3 Click the Point tab.

4 From the Boundary selection list, select Boundary 5.

5 In the y-axis data area, type c1 in the Expression edit field.

6 Click the Line Settings button.

7 Click the Color button. In the Line color dialog box, select black. Click OK.

8 From the Line style list, select Solid line. Click OK.

9 Back in the Domain Plot Parameters dialog box, click Apply.

10 On the General page, select the Keep current plot check box.

11 Return to the Point page and type c2 in the Expression edit field.

12 Click the Line Settings button.

13 From the Line style list, select Dashed line. Click OK.

14 Click OK to finalize the plot and close the Domain Plot Parameters dialog box.

Model Library path: Chemical_Engineering_Module/
Electrophoresis_and_Chromatography/liquid_chromatography_3

Modeling Using the Graphical User Interface—Model 3

1 Start COMSOL Multiphysics.

2 In the Model Navigator select Axial symmetry (2D) from the Space dimension list, then 
click the Multiphysics button.

3 From the Application Modes list, select Chemical Engineering Module> 
Mass Transport>Convection and Diffusion>Transient analysis. Click Add.

4 From the Application Modes list, select Chemical Engineering Module> 
Momentum Transport>Laminar Flow>Incompressible Navier-Stokes> 
Steady-state analysis.

5 From the Element list, select P2P-1, then click Add.

6 From the Application Modes list, select Chemical Engineering Module> 
Energy Transport>Convection and Conduction>Steady-state analysis. Click Add.

7 Click OK.
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G E O M E T R Y  M O D E L I N G

1 Press the Shift key and click the Rectangle/Square button on the Draw toolbar.

2 In the Size area of the Rectangle dialog box, set the Width to 1.05e-3 and the Height 
to 5e-2. In the Position area, set r to 0 and z to -2.5e-2. Click OK to create the 
rectangle R1.

3 Repeat this procedure to create five more rectangles with the following properties:

4 Double-click the EQUAL button in the status bar at the bottom of the user interface.

5 Click the Zoom Extents button on the Main toolbar.

6 Click in the drawing area and then press Ctrl+A to select all six rectangles. Ctrl-click 
rectangle R6 to remove it from the selection.

7 Press Ctrl+C to copy the rectangles R1 through R5, then press Ctrl+V. In the Paste 
dialog box, click OK to paste the copies, R7 through R11, without displacement.

8 From the Draw menu, select Create Composite Object.

9 In the Object selection list, select R6, R7, R8, R9, R10, and R11.

10 In the Set formula edit field, edit the expression to read R6-(R7+R8+R9+R10+R11).

11 Click OK to create the composite object CO1.

The geometry-modeling stage is now complete, and the result in the drawing area on 
your screen should look as in the figure below.

SETTINGS R2 R3 R4 R5 R6

Width 1.05e-3 1.05e-3 1e-4 1e-4 2.5e-3

Height 1e-3 1e-3 2.4e-2 2.4e-2 8e-2

r 0 0 0 0 0

z 2.5e-2 -2.6e-2 2.6e-2 -5e-2 -4e-2
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O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, open the Constants dialog box.

2 Enter the following constants; when done, click OK.

3 From the Options menu, point to Expressions and select Subdomain Expressions.

4 Enter the following expressions; when done, click OK.

NAME EXPRESSION DESCRIPTION

rho 1000[kg/m^3] Fluid density

dp_bed 1.7[um] Particle size for packed bed

dp_frit 3.5[um] Particle size for frits

void_bed 0.4 Bed porosity

void_frit 0.4 Frit porosity

p_in 54.5[MPa] Inlet pressure

p_out 0[Pa] Outlet pressure

T_in 303[K] Inlet temperature

c0 1[mol/m^3] Inlet concentration peak maximum, 
c0*exp(-a0*(t-t0)^2)

t0 2[s] Peak center time

a0 5[1/s^2] Peak shape parameter

Cp 2.9[kJ/(kg*K)] Heat capacity of fluid

k_f 0.25[W/(m*K)] Thermal conductivity of fluid

k_e 0.5[W/(m*K)] Thermal conductivity of bed and frit

k_s 15[W/(m*K)] Thermal conductivity of column walls

eta0 1e-3[Pa*s] Viscosity of fluid at T=293K

D_mol0 1e-9[m^2/s] Molecular diffusion coefficient at 
T=293K

z_in -5[cm] Inlet position

z_out 5[cm] Outlet position

SUBDOMAINS NAME EXPRESSION

1–5 D_mol D_mol0*exp(0.02[1/K]*(T-293[K]))*T/(293[K])

1–5 eta eta0*exp(-0.02[1/K]*(T-293[K]))

2–4 u_lin U_chns/epsilonp_chns

2–4 H_eff 1.5*dp+D_mol/u_lin+dp^2*u_lin/(6*D_mol)

2–4 D_eff 0.5*H_eff*u_lin
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P H Y S I C S  S E T T I N G S

Subdomain Settings—Convection and Diffusion
1 From the Multiphysics menu, select 1 Convection and Diffusion (chcd).

2 From the Physics menu, select Subdomain Settings.

3 Select Subdomain 6, then clear the Active in this domain check box.

4 Select Subdomains 1–5. Set the r-velocity to u and the z-velocity to v.

5 Select Subdomains 1 and 5. In the D (isotropic) edit field, type D_mol.

6 Select Subdomains 2–4. In the D (isotropic) edit field type D_eff*epsilonp_chns, 
and in the δts edit field type epsilonp_chns.

7 Click OK.

Subdomain Settings—Incompressible Navier Stokes
1 From the Multiphysics menu, select 2 Incompressible Navier-Stokes (chns).

2 From the Physics menu, select Subdomain Settings.

3 Select Subdomain 6, then clear the Active in this domain check box.

4 Select Subdomains 1–5. In the ρ edit field type rho, and in the η edit field type eta.

5 Click the Artificial Diffusion button. Clear the Streamline diffusion check box, then 
click OK.

6 Select Subdomains 2–4. Select the Flow in porous media (Brinkman equations) check 
box, then type epsilon in the κ edit field.

7 Select Subdomains 2 and 4. In the εp edit field, type void_frit.

8 Select Subdomain 3. In the εp edit field, type void_bed.

9 Click OK.

Subdomain Settings—Convection and Conduction
1 From the Multiphysics menu, select 3 Convection and Conduction (chcc).

2 From the Physics menu, select Subdomain Settings.

3 On the Physics page, select Subdomains 1–5.

2–4 epsilon dp^2*epsilonp_chns^3/
(180*(1-epsilonp_chns)^2)

2, 4 dp dp_frit

3 dp dp_bed

SUBDOMAINS NAME EXPRESSION
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4 In the ρ edit field, type rho; in the Cp edit field, type Cp; and in the u edit fields, 
type u and v, respectively.

5 Select Subdomains 1 and 5. In the k (isotropic) edit field, type k_f.

6 Select Subdomains 2–4. In the k (isotropic) edit field, type k_e.

7 Select Subdomain 6. In the k (isotropic) edit field, type k_s.

8 Select Subdomain 3. In the Q edit field, type -v*pz.

9 Click the Init tab.

10 Select all subdomains. In the Initial value edit field, type 
T_in-(z-z_in)*(p_out-p_in)/(z_out-z_in)/(rho*Cp).

11 Click OK.

Boundary Conditions—Convection and Diffusion
1 From the Multiphysics menu, select 1 Convection and Diffusion (chcd).

2 From the Physics menu, select Boundary Settings.

3 Enter the following boundary settings:

For all other boundaries, the default boundary condition (insulation/symmetry) 
applies.

4 Click OK.

Boundary Conditions—Incompressible Navier Stokes
1 From the Multiphysics menu, select 2 Incompressible Navier-Stokes (chns).

2 From the Physics menu, select Boundary Settings.

3 Enter the following boundary settings:

For all other boundaries the default settings apply (wall/no slip).

4 Click OK.

SETTINGS BOUNDARIES 1, 3, 5, 7, 9 BOUNDARY 2 BOUNDARY 11

Boundary condition Axial symmetry Concentration Convective flux

c0 c0*exp(-a0*(t-t0)^2)

SETTINGS BOUNDARIES 1, 3, 5, 7, 9 BOUNDARY 2 BOUNDARY 11

Boundary type Symmetry boundary Stress Stress

Boundary 
condition

Axial symmetry Normal stress, 
normal flow

Normal stress

f0 p_in p_out
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Boundary Conditions—Convection and Conduction
1 From the Multiphysics menu, select 3 Convection and Conduction (chcc).

2 From the Physics menu, select Boundary Settings.

3 Enter the following boundary settings:

For all other boundaries, the default boundary condition (thermal insulation) 
applies.

4 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, choose Free Mesh Parameters.

2 On the Subdomain page, enter the following settings:

3 Click the Boundary page. Select Boundaries 4 and 10, then set the Maximum element 

size to 5e-6.

4 Click the Advanced tab. In the z-direction scale factor edit field, type 0.5.

5 Click the Remesh button.

6 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

First, compute the steady-state velocity and temperature fields. Then, using these fields 
as an initial value, compute the transient solution for the analyte concentration. Record 
the entire procedure in a Solver Manager script.

1 Click the Solver Parameters button on the Main toolbar.

2 From the Analysis list, select Stationary.

3 Click OK to close the Solver Parameters dialog box.

4 Click the Solver Manager button on the Main toolbar.

5 On the Initial Value page, go to the Initial value area and click the Initial value 

expression option button.

SETTINGS BOUNDARIES 1, 3, 5, 7, 9 BOUNDARY 2 BOUNDARY 11

Boundary condition Axial symmetry Temperature Convective flux

T0 T_in

SETTING SUBDOMAINS 1, 5 SUBDOMAINS 2, 4 SUBDOMAIN 3 SUBDOMAIN 6

Maximum element size 2.5e-5 1e-4 2e-4 3e-3
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6 On the Solve For page, select Incompressible Navier-Stokes (chns) only.

7 On the Output page, select Incompressible Navier-Stokes (chns) and Convection and 

Conduction (chcc).

8 Click Apply.

9 On the Script page, click the Add Current Solver Settings button.

10 On the Initial Value page, click the Current solution option button in the Initial value 
area.

11 On the Solve For page, select Incompressible Navier-Stokes (chns) and Convection and 

Conduction (chcc).

12 Click Apply.

13 On the Script page, click the Add Current Solver Settings button.

14 Click OK.

Before completing the solver-script generation, set up the visualization of the 
time-dependent solution.

1 From the Postprocessing menu, choose Probe Plot Parameters.

2 Click New.

3 For the Plot type choose Integration, and for the Domain type choose Boundary.

4 In the Plot name edit field, type Inlet, then click OK to close the New Probe Plot 
dialog box.

5 From the Boundary selection list, select 2. In the Expression edit field, type 
2*pi*(v*c-Dzz_c_chcd*cz)*r.

6 Click the Title/Axis button.

7 Click the option button next to the Title edit field, then enter the title Axial flux 
of analyte.

8 Click OK to close the Title/Axis Settings dialog box.

9 Select the Plot all plots in the same axis check box.

10 Click Apply.

11 Repeat Steps 2–10 to generate a second plot with the Plot name set to Outlet and 
with Boundary 11 selected from the Boundary selection list.

Continue with the transient solution set-up.

1 Click the Solver Parameters button on the Main toolbar.

2 Change the Analysis back to Transient.
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3 In the Time stepping area, type 0:1:9 in the Times edit field.

4 On the Time Stepping page, select the Manual tuning of step size check box. Set the 
Initial time step to 1e-4 and the Maximum time step to 1e-2.

5 Click OK to close the Solver Parameters dialog box.

6 Click the Solver Manager button on the Main toolbar.

7 On the Solve For page, select Convection and Diffusion (chcd) only.

8 On Output page, select all three application modes.

9 Click Apply.

10 On the Script page, click the Add Current Solver Settings button.

11 Select the Solve using a script check box.

The solver script is now complete and ready to run.

12 Click OK to close the Solver Manager, then click the Solve button on the Main toolbar 
to compute the solution.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot is the concentration-peak evolution plot shown in Figure 10-16.

To plot the temperature field, follow these steps:

1 Click the Plot Parameters button on the Main toolbar.

2 Click the Surface page. On the Surface Data page, type T in the Expression edit field.

3 Click OK.

4 Double-click the EQUAL button on the status bar at the bottom of the user interface, 
then click the Zoom Extents button on the Main toolbar to toggle the axis-scale 
status.

To reproduce Figure 10-15, follow these steps:

1 From the Postprocessing menu, select Domain Plot Parameters.

2 From the Solutions to use list, select 0.

3 Click the Surface tab.

4 Select all subdomains.

5 In the Expression edit field, type T.

6 Click OK to generate the plot and close the dialog box.
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A absorption process 433

activation energy 463

active layer 581

agglomerate model 582

anisotropic porous medium 448

annular flow 434

anode 433

application mode

convection and diffusion 560

Darcy’s law 46, 585

Navier-Stokes 40, 58, 145, 454

Arrhenius law 419, 463

B boat reactor 447

boundary condition

no-slip 39, 144, 449

boundary conditions

slip/symmetry 39

straight-out 39

breakup of droplets 270

Brinkman equations 57

C capillary channel 334

capillary forces 334, 541

carbonate 433

Carreau viscosity model 30

catalyst

agglomerate 543

layer 461

catalytic

combustion 461

converter 461

purification of emissions 461

catalytic process 418

cathode 433, 541

caustic solution 433

charge balance 543

chemical

reactions 435

species 435

chemical vapor deposition 447

CHEMKIN transport data file 475

chlor-alkali membrane cell 530

concentration

overvoltage 590

conductivity 533, 544

conjugate heat transfer 98

conservation of mass, checking 84

contact angle 334, 337

convection and conduction 143

convection and diffusion application 

mode 560

convective flow 461, 462

conversions 422

corner smoothing 67

current density 530, 553

current distribution 531

CVD 447

D Darcy’s law application mode 46, 585

dialysis 152

diaphragm process 530

diffuse double layer 320

diffusion boundary layer 433

diffusivity 450

Dirac delta function 76

discontinuities 159

DNA Chip 320

droplet 75

droplet breakup 270

dynamic viscosity 11, 40, 58

E effective diffusion coefficient 463, 543

effective exchange current density 543
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electric energy 580

electrode reactions 554

electrolysis 530, 552

electron transfer reaction 532, 541, 543

electroneutrality 533

electroosmotic flow 320

electrophoretic flow 321

element

lagrange-cubic 441

equilibrium constant 435

exchange current density 534, 554

explicit streamline diffusion 149

F falling film 433

Faraday’s constant 533

Faraday’s law 533

Fick’s law 405

fixed bed reactor 418

flux 164

continuous 159

flux of species 436

free convection 434

frictional losses 13

fuel cell 173, 541, 602

fuel cell, 3D 580

G gas absorption 433

gas constant 463

gas diffusion electrodes 581

gas evolution 532

H Hagen-Poiseuille

law 462

profile 10

heat

capacity 120, 143

source 120

Henry constant 437

hydrogen 433

hydrogen ion 437

hydroxide ion 437

hypochlorite 438

hypochlorous acid 438

I ideal gas 46

immiscible fluids 243

incompressible Navier-Stokes 143

interdigitated flow 580

internal convection 530

ion conducting electrolyte 541

K kinetic

energy 10

parameters 435

kinetic gas theory 174

L laminar film 434

laminar flow 39

laminar static mixer 186

level set method 243

mass-conserving 75

liquid phase sintering 75

low pressure CVD 447

M mass balance 435

mass transport 164, 447

Maxwell-Stefan diffusion 173, 174

MCFC 541

mean concentration 466

medium

water 143

membrane cell 530

meniscus 338

mercury cell process 530

microchips 447

migration 366, 532

molecular diffusion 461

molten carbonate fuel cell 541

momentum transport 164, 447

monolith channels 462

multitube fixed-bed reactor 418



N Navier-Stokes

cylindrical coordinates 10

Navier-Stokes application mode 40, 58, 

145, 454

Navier-Stokes equations 10, 186

with surface tension 76, 335

Nernst-Planck 351, 368

Nernst-Planck equation 368

no-slip boundary condition 39, 144, 449

O Ohm’s law for electrolytes 533

ohmic losses 535

oil bubble 243

overpotential 545

overvoltage 541

P parabolic velocity profile 143, 462

partial pressure 437

PDE coefficients 116

PEMFC 580, 602

permeability of

porous media 47, 58

permeate 152

phthalic anhydride reactor 418

plug flow 418

polystyrene 30

porosity 582, 605

porous electrode 541

porous media 46

permeability of 47

porous media flow 57

potential distribution 531, 546

pressure

drop 13

energy 10

recovery 10

proton exchange membrane fuel cell 580, 

602

proton transport 581

PVC 530

R RANS 98

reaction kinetics 418

reaction rate 463

realizability constraint 101

reattachment 87

recirculation 87

residence time 418

Reynolds number 10, 39, 66

Reynolds-averaged Navier-Stokes 98

rising bubble 243

S scaled problem 154

scaled variables 463

secondary current distribution 531

selective catalytic reduction 461

model 470

separation 87

separation process 152

shear rate 30

shear-thinning fluid 33

silane 448

silicon 447

slip/symmetry boundary condition 39

standard electrode potential 554

static mixer 186

stiff-spring method 159

straight-out boundary condition 39

streamline diffusion

explicit 149

subdomain integration 469

supporting electrolyte 367

surface tension 334

T Tafel equation 175

thermal conductivity 120

transfer coefficient 534

tubular reactor 418

turbulent flow 87

turbulent viscosity 99

twisted blade mixer 186
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two-phase flow 75

typographical conventions 7

U unit cell 531

V variables

scaled 463

velocity distribution 11

viscosity 143

turbulent 99

viscous layer 41

viscous losses 13

void fraction 510

volatile organic compound 461

W wafer bundle 450

wall adhesion 334

washcoat 461, 462

wetted wall 337

Y Young’s law 334
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