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 1
I n t r o d u c t i o n
Welcome to the CAD Import Module. This optional package extends the 
COMSOL Multiphysics® modeling environment with the ability to import 3D 
CAD models. Besides drawing a geometric model with the CAD tools built into 
COMSOL Multiphysics, an alternative is to create it with a specialized CAD 
software application and save it to a file—one that the CAD Import Module can 
open and translate into a COMSOL Multiphysics geometry object. Then you 
continue the usual modeling procedure of meshing and simulating. In addition to 
the automatic repair of CAD models, the CAD Import Module also includes 
interactive repair and defeaturing tools that you can use to prepare the CAD model 
for meshing and finite-element analysis.

The CAD Import Module supports the most common 3D CAD file formats: 
Parasolid®, SAT®, IGES, and STEP. Moreover, it provides the ability to set up a 
live connection with SolidWorks®, one of the most popular CAD programs. With 
this connection you can transfer geometric models directly from SolidWorks to 
COMSOL Multiphysics and further modify them during a modeling session.

In addition, CATIA® V4, CATIA® V5, Autodesk Inventor®, Pro/
ENGINEER®, and VDA-FS are other widely used CAD formats, and for each of 
them COMSOL offers a separate add-on to the CAD Import Module.
 1
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This documentation covers the CAD Import Module as well as all these add-ons. For 
an overview of the different products and the file formats they support see Table 1-1 
on page 5.

This chapter provides an overview and some background on the different file formats. 
It concludes on page 6 with some “quick start” instructions on using the CAD Import 
Module. Detailed descriptions on how to use various features of this module in an 
optimal way appear in Chapter 2, “Using the CAD Import Module.”

New Features in the CAD Import Module 3.4

• You can now export 3D CAD geometries to Parasolid text and binary file formats 
(*.x_t and *.x_b files). This can be useful for saving a geometry that you have 
repaired or modified using the defeaturing tools in the CAD Import Module. It also 
provides an opportunity to translate 3D CAD files from other formats into Parasolid 
files.

• An upgraded Parasolid engine provides greater robustness and faster import of 3D 
CAD geometries.

Typographical Conventions

All COMSOL manuals use a set of consistent typographical conventions that should 
make it easy for you to follow the discussion, realize what you can expect to see on the 
screen, and know which data you must enter into various data-entry fields. In 
particular, you should be aware of these conventions:

• A boldface font of the shown size and style indicates that the given word(s) appear 
exactly that way on the COMSOL graphical user interface (for toolbar buttons in 
the corresponding tooltip). For instance, we often refer to the Model Navigator, 
which is the window that appears when you start a new modeling session in 
COMSOL; the corresponding window on the screen has the title Model Navigator. 
As another example, the instructions might say to click the Multiphysics button, and 
the boldface font indicates that you can expect to see a button with that exact label 
on the COMSOL user interface.

• The names of other items on the graphical user interface that do not have direct 
labels contain a leading uppercase letter. For instance, we often refer to the Draw 
toolbar; this vertical bar containing many icons appears on the left side of the user 
interface during geometry modeling. However, nowhere on the screen will you see 
1 :  I N T R O D U C T I O N



the term “Draw” referring to this toolbar (if it were on the screen, we would print 
it in this manual as the Draw menu).

• The symbol > indicates a menu item or an item in a folder in the Model Navigator. 
For example, Physics>Equation System>Subdomain Settings is equivalent to: On the 
Physics menu, point to Equation System and then click Subdomain Settings. 
COMSOL Multiphysics>Heat Transfer>Conduction means: Open the COMSOL 

Multiphysics folder, open the Heat Transfer folder, and select Conduction.

• A Code (monospace) font indicates keyboard entries in the user interface. You might 
see an instruction such as “Type 1.25 in the Current density edit field.” The 
monospace font also indicates COMSOL Script codes.

• An italic font indicates the introduction of important terminology. Expect to find 
an explanation in the same paragraph or in the Glossary. The names of books in the 
COMSOL documentation set also appear using an italic font.
 |  3
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Ove r v i ew o f  t h e  CAD Impo r t  Modu l e

To get an overview of the module, first review some general background information 
about CAD file formats; then you can better understand the list of all file formats that 
various COMSOL products support. This section also includes some 
recommendations on which format to use together with a specific CAD program. For 
more details on the live connection with SolidWorks, see the section “SolidWorks Live 
Connection” on page 30.

CAD Software, Geometry Kernels, and File Formats

Each CAD program uses a geometry kernel to create a mathematical description of the 
objects and to calculate the results of solid-modeling operations. Parasolid and ACIS® 
are the two most common kernels, and many CAD programs license these kernels. In 
addition, some programs use their own kernel (as does COMSOL Multiphysics). Each 
of these kernels has a native file format associated with it. For example, Parasolid’s file 
format is simply called Parasolid, and the one from ACIS is called SAT.

The geometry kernel defines the type of internal representations used for 3D 
modeling, which can vary considerably among different kernels. That explains why the 
representations stored in the various file formats are also very different. The CAD 
Import Module can read all these different descriptions of objects and translate them 
into COMSOL Multiphysics geometries.

In addition to the file formats that are native to a geometry kernel, yet other formats 
are based on neutral standards that were defined to ease the exchange of geometric 
models among CAD software applications. STEP and IGES are the two most popular 
formats of this class.

Yet another class of files use surface-mesh geometry formats. They do not represent a 
model’s exact 3D geometry but store only triangular meshes of the surfaces. The most 
common examples of these types of files formats are VRML and STL.

For 2D modeling two formats are used primarily: DXF® is the native format of the 2D 
modeling program AutoCAD®, whereas GDS is a neutral standard.

This discussion presents only a short overview of CAD terms. The large number of 
applications and formats can be rather confusing. See the Glossary on page 63 for a 
short description of some CAD software, kernels, and file formats.
1 :  I N T R O D U C T I O N



File Formats Supported by COMSOL Products

The various COMSOL products can import different sets of file formats. COMSOL 
Multiphysics itself comes with support for 2D formats and the surface-mesh geometry 
formats. The CAD Import Module covers the most common needs for translating 3D 
models; it reads the native formats of the two most common kernels and the most 
popular standards. For files from other CAD software we supply additional modules as 
add-ons to the CAD Import Module. See Table 1-1 for a summary and details on 
supported versions.

* GDS Import requires COMSOL Script.

** Only import of parts is supported.

Geometric models do not always pass flawlessly between different file formats due to 
the different representations they use. This implies that the quality of a translation from 
a CAD model to a COMSOL Multiphysics geometry depends heavily on the file 
format. The smoothest way is, of course, to use the native format of your CAD system. 
If this is not possible, we in general recommend you to use Parasolid or STEP. 

TABLE 1-1:  FILE FORMATS SUPPORTED BY COMSOL PRODUCTS

PRODUCT FILE FORMAT (FILE EXTENSIONS) SUPPORTED VERSIONS

COMSOL Multiphysics STL (.stl)

VRML (.wrl, .vrml)

DXF (.dxf)

GDS (.gds)*

1.0

up to R14

2

CAD Import Module Parasolid (.x_t, .x_b)

SAT (.sat, .sab)

STEP (.step, .stp)

IGES (.igs, .iges)

up to V18

up to R17

AP203, AP214

up to 5.3

CATIA V4 Import Module CATIA V4 (.model) 4.1.9 to 4.2.4

CATIA V5 Import Module CATIA V5 (.CATPart, .CATProduct) R2 to R17

Inventor Import Module Autodesk Inventor (.ipt)** 6 to 11

Pro/E Import Module Pro/ENGINEER (.prt, .asm) 16 to Wildfire 3

VDA-FS Import Module VDA-FS (.vda) 1 and 2
O V E R V I E W  O F  T H E  C A D  I M P O R T  M O D U L E  |  5
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Qu i c k  S t a r t

Importing CAD files into the COMSOL Multiphysics modeling environment is 
straightforward. Go to the File menu and open the Import CAD Data From File dialog 
box, where you:

1 Select the type of file you want to import in the Files of type list.

2 Choose the file to import by clicking on it or specifying its name in the File name 
edit field.

3 Click Import to close the dialog box and import the geometry in the file. This action 
also opens the Import CAD Data From File progress window.

See Chapter 2, “Using the CAD Import Module,” for import options and more details 
on how to handle various types of geometries. There you can also find information on 
the SolidWorks live connection.
1 :  I N T R O D U C T I O N
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U s i n g  t h e  C A D  I m p o r t  M o d u l e
This chapter covers the use of the CAD Import Module, which requires the 
COMSOL Multiphysics package. The module provides three main features: 

• Importing CAD models from CAD-formatted files

• Interactive repair and defeaturing of imported geometries

• Controlling the live connection to the CAD program SolidWorks

See page 8 for details and examples on how to import a CAD model from a file. To 
read about repair and defeaturing functionality turn to page 16. Finally, a 
description of the SolidWorks live interface can be found on page 30.

This chapter focuses on using the CAD Import module from the COMSOL 
Multiphysics graphical user interface. For details on how to access the functionality 
described in this chapter from COMSOL Script™ or MATLAB® see Chapter 3, 
“CAD Import Module Command Reference,” on page 35.
 7
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Impo r t i n g  CAD Mode l s  f r om a F i l e

Usually a CAD model is represented by either a part or an assembly, which consists of 
multiple parts. Importing a part into COMSOL Multiphysics results in a single 
geometry object, while importing an assembly produces a collection of objects. Some 
CAD programs use the concept of multibody parts. The CAD Import Module treats 
these as assemblies. There are various ways to handle imported assemblies and to 
continue the modeling process, choices that are described further on page 11.

For both parts and assemblies, the import procedure is quite straightforward. Select 
File>Import>CAD Data From File to open the Import CAD Data From File dialog box. Here 
you choose a CAD file and merely click Import to continue with the procedure. If 
desired, there are a number of options to customize the import procedure. You can 
find a detailed description of these options on page 9.

The object that appears in the drawing area of the graphical user interface after import 
of a part is called a CAD geometry object. You can distinguish this from a COMSOL 
Multiphysics geometry object by the different coloring. Face rendering of CAD 
objects is done in a paler color than COMSOL objects, and edges for CAD objects are 
rendered gray as opposed to black for COMSOL objects.

You have the possibility to repair or defeature CAD objects. You can also carry out 
transformation operations like scaling, moving, rotation or mirroring. Any other 
geometry operation requires the CAD geometry object to be translated into a 
COMSOL Multiphysics geometry object.

Meshing and analysis can only be performed on COMSOL Multiphysics geometry 
objects. This means that conversion of all CAD objects automatically takes place when 
you leave the Draw mode. However, you can always access the CAD objects if you 
return to Draw mode.

CAD geometry objects can only be handled by the CAD Import Module. So to be 
certain that the model can be opened by COMSOL Multiphysics without the CAD 
Import Module, convert such objects to COMSOL objects before saving your model. 
Do this by selecting Draw>CAD Repair and Defeaturing>Convert to COMSOL Object.

E X A M P L E :  I M P O R T  O F  A  C A D  M O D E L  F R O M  A  F I L E

1 Open the Model Navigator and select a new 3D model. 

2 Select File>Import>CAD Data From File.
2 :  U S I N G  T H E  C A D  I M P O R T  M O D U L E



3 In the Files of type list, select STEP file.

4 Locate the COMSOL installation directory, go to the cad folder, then select the file 
demo2.stp.

5 Click Import to close the dialog box and import the geometry. This action also 
opens the Import CAD Data From File progress window.

6 Click the Headlight button on the Camera toolbar to get a more accentuated 3D 
impression of the geometry.

7 Select Draw>CAD Repair and Defeaturing>Convert to COMSOL Object.

The CAD object is translated into a COMSOL Multiphysics geometry object. You can 
now save the model and access it without requiring the CAD Import Module.

CAD Import Options

The CAD import options give you the possibility to select which type of objects to 
import from a CAD file. Objects types can be solids, faces, or lines. When importing 
face objects, you can choose how to treat these during the import procedure. You can 
import each face object separately, knit them together, or even form a solid from the 
knitted objects.
I M P O R T I N G  C A D  M O D E L S  F R O M  A  F I L E  |  9
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The CAD Import Module can also repair geometries during the import procedure 
with a tolerance you can specify, and lets you turn the repairing on or off.

To change the CAD import options click the Options button in the Import CAD Data 

From File dialog box. This opens the CAD Import Options dialog box.

• Select the Solid entities check box to import solid geometry objects.

• Select the Face entities check box to import face objects. To combine these entities 
you have three choices:

- Select the Try forming solids button to combine individual faces to solid objects.

- Select the Knit faces button to combine the individual faces to one face object.

- Select the Do not knit button to create a separate geometry object for each 
imported face.

• Select the Free point/edge entities check box to import isolated edges and points.

• Specify the tolerance to use during import in the Absolute import tolerance edit field.

• Select the Repair imported data check box to remove small gaps and tiny edges from 
the geometry.

Many geometries, especially those designed using a CAD program without finite 
element analysis, contain small anomalies: short edges, holes, or gaps. These can lead 
to large meshes or even failure of mesh generation. To avoid these problems, make sure 
the repair feature is active, and that the import tolerance is appropriate.

Repairing a CAD model means that you remove short edges, overlapping edges, and 
gaps.
 2 :  U S I N G  T H E  C A D  I M P O R T  M O D U L E



For documentation on the import options specific to the STL and VRML file formats 
see the chapter “Importing STL and VRML Files” on page 89 of the COMSOL 
Multiphysics User’s Guide.

Dealing with Assemblies

A CAD model represented as an assembly is a collection of parts. When you import 
such a model, each part becomes a CAD geometry object in COMSOL Multiphysics. 
With several geometry objects present, there are two ways to continue the modeling 
process:

• Creating a composite object. A union is made of all CAD geometry objects. As a 
result of this, the CAD objects are converted into a single COMSOL Multiphysics 
geometry object. This is usually the preferred way of modeling because it leads to 
the best convergence when solving, and the greatest accuracy. However, it is not 
always possible to create such a composite object from CAD assemblies due to 
tolerance issues in the geometry representations.

• Creating an assembly. The individual geometry objects become parts of a 
COMSOL Multiphysics assembly. These individual parts are coupled at their 
boundaries with identity or contact pairs. Creating an assembly involves an easier 
geometry operation than creating a composite object, and is thus more robust for 
dealing with tolerance issues. In addition, you have greater freedom in meshing each 
part, and you have the possibility to model structural contact between interior 
boundaries of the assembly.

C R E A T I N G  A  C O M P O S I T E  O B J E C T

If you choose to leave Draw mode after the import of a CAD assembly, COMSOL 
Multiphysics automatically creates a converted and composite object, which the 
program uses for meshing and analysis. You can return to Draw mode and still have 
access to the CAD geometry objects.

Note that the interior boundaries are kept in the process of creating a composite 
object. This means that the CAD parts become subdomains in the composite object. 
You can still apply different physics and material properties on each subdomain.

The steps involved in creating a composite object do not always succeed due to small 
edges in the objects, or small gaps between the individual parts. Often you can avoid 
these errors by manually creating the composite object and setting a repair tolerance. 
Do this in the Create Composite Object dialog box, which you can open by clicking the 
Create Composite Object button on the Draw toolbar. You can find more details on page 
I M P O R T I N G  C A D  M O D E L S  F R O M  A  F I L E  |  11
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32 of the COMSOL Multiphysics User’s Guide. Keep in mind that, after this 
operation, you no longer have access to the CAD geometry objects in Draw mode.

C R E A T I N G  A N  A S S E M B L Y

In case you want to continue working with an assembly rather than a composite object, 
you need to create identity pairs between the CAD geometry objects. This is necessary 
for the physics application modes to be able to connect the defined physics between 
these parts. There are two possibilities for doing this automatically in COMSOL 
Multiphysics:

• Identity Pairs. After import, with all objects selected, click Create Pairs on the Draw 
toolbar. 

• Identity Pairs and Imprints. After import, with all objects selected, click Create 

Pairs and Imprints on the Draw toolbar. In this case imprints are created on the 
boundaries of objects. Objects that are modified are then converted to COMSOL 
Multiphysics geometry objects.

You can also perform these operations from the Create Pairs dialog box, which you can 
access by selecting Create Pairs from the Draw menu.

If your license includes the Structural Mechanics Module or the MEMS Module, you 
can also create contact pairs using the Create Pairs dialog box. Contact pairs are used 
when modeling structural contact. You can read about this topic in the chapter 
“Contact Modeling” on page 118 of the Structural Mechanics Module User’s Guide 
or on page 136 of the MEMS Module User’s Guide.

After creating identity or contact pairs, notice that there is a check mark in front of the 
Use Assembly menu item in the Draw menu.

As an alternative approach to letting the software set up identity pairs, you can 
manually select and define couplings between object boundaries. To do this after 
import, select Draw>Use Assembly to treat the geometry model as an assembly. You can 
set up identity boundary pairs by selecting Physics>Identity Pairs, or contact pairs by 
selecting Physics>Contact Pairs.

You can find more details on creating pairs in the section “Creating Assemblies” on 
page 352 in the COMSOL Multiphysics Modeling Guide. In addition, the section 
“Meshing Assemblies” on page 365 in the same book illustrates the advantages of the 
assembly feature when meshing a geometry.
 2 :  U S I N G  T H E  C A D  I M P O R T  M O D U L E



E X A M P L E :  C R E A T I N G  A  C O M P O S I T E  O B J E C T

The following example describes how to import a CAD assembly and create a 
composite object.

1 Open the Model Navigator and select a new 3D model.

2 Select File>Import>CAD Data From File.

3 In the Files of type list, choose SAT file.

4 Locate the COMSOL installation directory, go to the cad directory, and then select the 
file demo3.sat.

5 Click Import to close the dialog box and import the geometry. This action also 
opens the Import CAD Data From File progress window.

6 Click the Headlight button on the Camera toolbar for a more emphasized 3D 
impression of the geometry.

The imported assembly consists of four parts, which were converted into four 
individual geometry objects in COMSOL Multiphysics.

7 Leave Draw mode by clicking the Boundary Mode button on the Main toolbar.

Through this act, COMSOL Multiphysics converts and combines all the geometry 
objects into the one composite object, which the program uses for meshing and 
analysis.
I M P O R T I N G  C A D  M O D E L S  F R O M  A  F I L E  |  13
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8 Click the Draw Mode button on the Main toolbar to return to Draw mode.

9 Click the Create Composite Object button on the Draw toolbar to open the Create 

Composite Object dialog box. In the Object selection list you can see that you still have 
access to four CAD objects.

If you now choose to create a composite object by taking the union of all objects in 
the Create Composite Object dialog box, you no longer have access to the CAD objects.

E X A M P L E :  C R E A T I N G  A N  A S S E M B L Y

Import the CAD assembly from the previous example and create an assembly in 
COMSOL Multiphysics.

1 Open the CAD assembly example file by repeating Steps 1–6 of the previous 
example.

2 Press Ctrl+A to select all geometry objects.

3 Click the Create Pairs button on the Draw toolbar to create identity pairs. The 
boundaries contained in these pairs turn yellow.

Now the individual parts are coupled through the identity pairs, and you can continue 
the modeling procedure as usual.

Exporting CAD Data to File

You can save a CAD geometry to a file using four different formats:

• COMSOL Multiphysics binary files (*.mphbin) and COMSOL Multiphysics text 
files (*.mphtxt)

• Parasolid binary files (*.x_b, *.xmt_bin) and Parasolid text files 
(*.x_t,*.xmt_txt)

The COMSOL Multiphysics files are native COMSOL file formats and make it 
possible to import the geometry to COMSOL Multiphysics without the CAD Import 
Module. For more information about these file formats, see “The COMSOL 
Multiphysics Files” on page 535 in the COMSOL Multiphysics Reference Guide.

Using the Parasolid file formats, you can translate CAD files from other formats and 
save a geometry, which you have modified using the repair and defeaturing tools in the 
CAD Import Module, to a widely recognized CAD file format.

To save the geometry to file, do the following steps:

1 From the File menu, choose Export>Geometry Objects To File.
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2 Browse to the directory where you want to save the file, specify a file name in the 
File name edit field, and select one of the four file formats from the Files of type list. 

3 Click OK.
I M P O R T I N G  C A D  M O D E L S  F R O M  A  F I L E  |  15
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CAD Repa i r  a nd De f e a t u r i n g

Sometimes you might find it necessary to repair and defeature the CAD geometry after 
the import is completed. This can typically be the case if the geometry contains 
inaccuracies that fall outside the import tolerance, which by default is set to 10−5. With 
the CAD Import Module’s defeaturing tools, you can also remove details that are not 
important to the finite element analysis. Repair and defeaturing are only available for 
CAD geometry objects.

CAD Repair

To access the Repair dialog box choose Draw>CAD Repair and Defeaturing>Repair.

• Click Repair to remove small entities from the selected object. Enter the tolerance 
in the Absolute tolerance edit field. Only small entities that fall within the specified 
tolerance are removed. Small entities can be short edges, small faces, sliver faces, and 
spikes.

• Click Knit to sew together selected faces. Enter the tolerance in the Absolute 

tolerance edit field. Spikes and gaps that fall within the specified tolerance are 
removed during this operation. After knitting, a solid object is automatically made 
from the knitted face objects.

The repair tool might sometimes have undesired effects because it removes all features 
that fall within the tolerance interval. To avoid this and to delete only certain features, 
use the interactive defeaturing tools (see page 22).

E X A M P L E  1 :  R E P A I R

In this example you use the repair tool to remove small faces from an imported CAD 
model of a wheel rim.
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1 Open the Model Navigator and select a new 3D model. 

2 Select File>Import>CAD Data From File.

3 In the Files of type list, select Parasolid file.

4 Locate the COMSOL installation directory, go to the cad folder, and then select the 
file repair_demo_1.x_b.

5 Click Import to close the dialog box and import the geometry. This action also 
opens the Import CAD Data From File progress window.

6 Click the Headlight button on the Camera toolbar to highlight the 3D impression of 
the geometry in a better way.

The CAD geometry includes a number of small faces, that are larger than the default 
import tolerance, and were therefore not removed during import.

Next, mesh the geometry:

7 Select Mesh>Free Mesh Parameters to open the Free Mesh Parameters dialog box.

small faces
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8 On the Global page, select the Custom mesh size option button.

9 Type 0.4 in the Resolution of narrow regions edit field.

When dealing with imported CAD models, you can often achieve a significant 
reduction in number of elements without sacrificing mesh quality by this slight 
decrease of the parameter for resolution of narrow regions.

10 Click OK to close the Free Mesh Parameters dialog box.

11 Mesh the geometry by clicking the Initialize Mesh button on the Main toolbar.

Note that, as soon as the meshing is complete, the message log displays the number 
of mesh elements, which is approximately 78,000.

12 Click the Draw Mode button on the Main toolbar.

13 Select Draw>CAD Repair and Defeaturing>Repair to open the Repair dialog box.

14 Type 1e-3 in the Absolute tolerance edit field in the Repair object area.

15 Click Repair.
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When the geometry repair is completed, you can see that not only small faces but also 
sliver faces, which were located just next to them, are removed from the model.

16 Click Close to close the Repair dialog box.

17 Mesh the geometry by clicking the Initialize Mesh button on the Main toolbar.

The message log displays now around 69,000 elements for the new mesh, which is 
significantly smaller than before repairing the geometry.

E X A M P L E  2 :  K N I T  F A C E S

In this example you use the knit faces tool to remove a gap from an imported CAD 
model of an engine piston rod.

1 Open the Model Navigator and select a new 3D model. 

2 Select File>Import>CAD Data From File.

3 In the Files of type list select Parasolid file.
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4 Locate the COMSOL installation directory, go to the cad folder, and then select the 
file repair_demo_2.x_b.

5 Click Import to close the dialog box and import the geometry. This action also 
opens the Import CAD Data From File progress window.

6 Click the Headlight button on the Camera toolbar to stress the 3D features of the 
geometry better.

The imported geometry is a face object, labeled with F1, which contains a gap. A solid 
body could not be created during import as the gap is larger than the default import 
tolerance.

7 Select Draw>CAD Repair and Defeaturing>Repair to open the Repair dialog box.

8 Enter 1e-3 in the Absolute tolerance edit field in the Knit faces and fill gaps area.

gap
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9 Click Knit.

After the operation is completed you can see that the gap is healed and a solid body is 
created. The object is listed now as a solid object, labeled CO1, in the Object selection 
list box.

10 Click Close to close the Repair dialog box.

11 Mesh the geometry by clicking the Initialize Mesh button on the Main toolbar.

The mesh consists of around 31,000 tetrahedral elements. You can further reduce the 
mesh size by defeaturing; see “Example 1: Defeaturing” on page 24 and “Example 2: 
Advanced Defeaturing” on page 26.
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CAD Defeaturing

To access the Defeaturing dialog box choose Draw>CAD Repair and 

Defeaturing>Defeaturing.

Here you are presented with a number of pages, one for each type of feature—fillets, 
small and sliver faces, spikes, and short edges—that you can search for and then delete. 
In addition to the automatic detection of features, there is an Advanced page where you 
can manually select details to remove or to detach to form a new solid body.

• The Fillets page. Specify the Maximum fillet radius and click Find. The Fillets list box 
is populated with fillets or fillet chains that have radii smaller than that specified. 
Select an item from the list and click Delete to delete the fillet.

Depending on the geometry, the software might not always recognize fillets. In 
most cases you can still use the advanced defeaturing tool to select and delete 
appropriate faces.

• The Small Faces page. Specify the Maximum face size and click Find. The Small faces 

list box is populated with faces that fit within a sphere of a radius equal to the 
maximum face size specified. Select an item from the list and click Delete to delete 
the face.

• The Sliver Faces page. Specify the Maximum face width and click Find. The Sliver Faces 
list box is populated with faces that fall within the width requirements. Select an 
item from the list and click Delete to delete the face.

If COMSOL Multiphysics notifies you in the message log that deleting fails, you can 
test using the find and remove short edges tool to delete one or both of the short edges 
of the sliver face. After this you can try again to find and remove the sliver face.
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• The Spikes page. Specify the Maximum spike width and click Find. The Spikes list box 
is populated with edges that fall within the size requirements. Select an item from 
the list and click Delete to delete the spike.

Spikes might sometimes be difficult to remove from face objects. If you encounter 
a geometry where this is the case, you can also use the Knit Faces tool, which can 
both remove spikes and fill gaps. To do this, knit the faces from the Repair dialog 
box after changing the tolerance to match the size of the spikes. You might 
experience greater success if you choose not to knit the faces during import and 
instead use the knit faces tool afterward.

• The Short Edges page. Specify the Maximum edge length and click Find. The Chains of 

short edges list box is populated with edges or chains of edges shorter than the 
specified length. Select an item from the list and click Delete to delete the edge.

• The Advanced page.

Select the faces that define the feature you would like to remove or detach from the 
geometry object. You can do this in both the Face selection list box and in the 
drawing area. Detach removes the selected faces from the solid objects and then 
forms a new solid object from them. If you are deleting a detail, select a heal method 
and click Delete. If you are detaching the detail, select a parent heal method and a 
child heal method and click Detach.

For both deleting and detaching faces there are two available heal methods for the 
wounds that these operations cause. If you select Fill a surface is calculated that 
covers the wound and includes all the edges of the wound. With the Patch heal 
method the adjacent surfaces to the wound are either shrunk or grown until the 
wound is covered.
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Due to the internal representation of surfaces in the COMSOL Multiphysics geometry 
kernel, faces might be split into two during import of CAD files. This is usually the 
case if it is possible to create the face by a revolve operation. A few examples are entire 
or partial cylinders, spheres, and cones. While the split is required for faces that 
describe a full revolution, even faces with less than a full revolution can be split during 
translation. This might have the undesired effect of introducing sliver and small faces 
in the geometry. You can remove these faces using the Delete Small Faces or Delete 
Sliver Faces tools. You can also use the Delete Details tool. Do this by selecting the 
small face, then select Fill as the heal method.

E X A M P L E  1 :  D E F E A T U R I N G

In this example you use the defeaturing tools to remove some features from an 
imported CAD model of an engine piston rod.

1 Open the Model Navigator and select a new 3D model. 

2 Select File>Import>CAD Data From File.

3 In the Files of type list, select Parasolid file.

4 Locate the COMSOL installation directory, go to the cad folder, and then select the 
file defeaturing_demo_1.x_b.

5 Click Import to close the dialog box and import the geometry. This action also 
opens the Import CAD Data From File progress window.

6 Click the Headlight button on the Camera toolbar.

7 Select Draw>CAD Repair and Defeaturing>Defeaturing to open the Defeaturing dialog 
box.

Start by removing sliver faces that were introduced during the import process.

8 On the Sliver Faces page, enter 1e-3 in the Maximum face size edit field and click Find.

The Sliver faces list displays 14 faces, which are also highlighted in the model.
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9 Select Faces 1-3 and 8-10 by holding down the Ctrl key while left-clicking on the 
items in the list.

10 Click Delete to remove the selected sliver faces.

Continue by removing some fillets present in the model.

11 On the Fillets page enter 4e-3 in the Maximum fillet radius edit field and click Find.

The Fillets list displays seven fillets that are within the specified size intervall.
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12 With all fillets selected in the list, click Delete to remove them.

13 Click Close to close the Defeaturing dialog box.

14 Mesh the geometry by clicking the Initialize Mesh button on the Main toolbar.

The mesh consists of approximately 21,000 tetrahedral elements. Compare this 
number to 31,000 elements, which is the mesh size for the same geometry before 
defeaturing (see “Example 2: Knit Faces” on page 19).

E X A M P L E  2 :  A D V A N C E D  D E F E A T U R I N G

In this example you use the advanced defeaturing tools to manually remove details 
from an imported CAD model. The piston rod CAD model from the previous example 
has already been partly defeatured and saved as a COMSOL Multiphysics geometry 
file. You import this file and continue the defeaturing by removing the remaining 
details on the face of the end where the rod attaches to the cap.

1 Open the Model Navigator and select a new 3D model. 
 2 :  U S I N G  T H E  C A D  I M P O R T  M O D U L E



2 Select File>Import>CAD Data From File.

3 In the Files of type list, select COMSOL Multiphysics file.

4 Locate the COMSOL installation directory, go to the cad folder, and then select the 
file defeaturing_demo_2.mphbin.

5 Click Import to close the dialog box and import the geometry. This action also 
opens the Import CAD Data From File progress window.

6 Click the Headlight button on the Camera toolbar to get a better 3D appearance of 
the geometry.

7 Choose Draw>CAD Repair and Defeaturing>Defeaturing to open the Defeaturing dialog 
box.

8 On the Advanced page click the object CO1 in the Face selection list to expand the 
list of faces that belong to the object.

9 Select Faces 6–9 and 11–13.

10 Select Patch from the Heal method list in the Delete details area and then click Delete.

With the hole removed continue with removing the slot that runs across the face.
C A D  R E P A I R  A N D  D E F E A T U R I N G  |  27



28 |  C H A P T E R
11 Select Faces 7–9, 16, 19, 22, 25, 35, and 38, and then repeat Step 10.

As the final step, remove the grooves that are still left on the face.

12 Select Faces 10–13, 21, 22, and then repeat Step 10.

13 Click Close to close the Defeaturing dialog box.
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14 Finish by clicking the Initialize Mesh button on the Main toolbar to mesh the part.

The mesh size is approximately 5000 elements. This mesh is around five times smaller 
than the mesh for the same geometry before defeaturing. Compare to “Example 2: 
Knit Faces” on page 19 and “Example 1: Defeaturing” on page 24.
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S o l i dWo rk s  L i v e  C onn e c t i o n

With the CAD Import Module you can set up a live connection between COMSOL 
Multiphysics and the SolidWorks CAD program. In this way, the geometry model 
present in the COMSOL Multiphysics environment mirrors the geometry model 
present in SolidWorks. The connection is truly bidirectional. On the one hand, you can 
modify a model in SolidWorks to simultaneously update the COMSOL Multiphysics 
geometry. On the other hand, you can define constants in COMSOL Multiphysics, 
values that SolidWorks can then use as geometric parameters.

A typical design and modeling process includes some or all of the following steps:

1 Create a CAD model in SolidWorks.

2 Import the geometry model to COMSOL Multiphysics by initializing the 
connection from COMSOL Multiphysics to SolidWorks.

3 Define a physics model in COMSOL Multiphysics and perform initial analysis.

4 Modify the CAD model in SolidWorks.

5 Update the geometry in COMSOL Multiphysics from the modified CAD model. 
The program maps the boundary conditions from the old geometry model to the 
new one.

6 Continue modeling in COMSOL Multiphysics.

7 Define constants in COMSOL Multiphysics that serve as parameters for the 
geometric model.

8 Update the connection between the two programs. SolidWorks reads the defined 
constants and changes the CAD model accordingly, and the connection updates the 
COMSOL Multiphysics object.

9 Perform a parameter study by repeatedly changing the values of the constants and 
updating the connection.

See the model on page 537 of the COMSOL Multiphysics Model Library for an 
example on how to effectively use the SolidWorks live connection in a practical 
example.

Note that in COMSOL Multiphysics you should not manipulate the geometry object, 
which mirrors a CAD model in SolidWorks. However, you can draw additional objects 
in COMSOL Multiphysics. This means that your model can contain both geometry 
objects imported from SolidWorks and geometry objects drawn in COMSOL 
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Multiphysics, and you can still update models in SolidWorks to affect only those 
imported objects in COMSOL Multiphysics.

The live connection transfers only the geometry from SolidWorks to COMSOL 
Multiphysics; it ignores everything else. Yet, the connection requires that both 
programs run on the same PC.

To specify options on how to translate a SolidWorks model to a COMSOL 
Multiphysics geometry object, select the menu item File>SolidWorks 

Connection>Options. The options are exactly the same as for importing CAD models 
from files and are discussed in the section “CAD Import Options” on page 9.

Note: To implement the live connection, SolidWorks needs an add-in called the 
COMSOL Multiphysics Interface, which the COMSOL Installer adds to SolidWorks. 
However, if you install SolidWorks after installing COMSOL the connection could 
fail. For details on how to set up the connection, see the chapter “Adding the 
SolidWorks Connection to the CAD Import Module” on page 18 of the COMSOL 
Installation Guide.

Example of Using the SolidWorks Live Connection

Start the SolidWorks program on your computer and open the example geometry by 
locating the COMSOL installation directory, going to the cad folder, and then opening 
the file demo4.SLDPRT.
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Set up the live connection to COMSOL Multiphysics using the following steps:

1 Open the Model Navigator and select a new 3D model.

2 From the File menu select SolidWorks Connection>Initialize.

3 A progress window opens, and the connection translates the SolidWorks model to a 
COMSOL Multiphysics geometry.

Now modify the SolidWorks model, which is mirrored in the COMSOL Multiphysics 
geometry.

1 In the feature tree on the left side of the SolidWorks window, locate the symbol 
called Equations. The constant fillet_radius is currently set to 5. This value 
determines the size of the fillet that is slightly darker than the rest of the drawing.
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2 Select Edit Equation by right-clicking on the text fillet_radius.

3 Change the value to 1, and the fillet in the model becomes very small.

4 Return to the COMSOL Multiphysics window. Select the menu item 
File>SolidWorks Connection>Update to adjust the geometry to the changes you just 
made in SolidWorks.

As another exercise, assume that this radius is too small for your modeling needs, but 
you want to control its size from within COMSOL Multiphysics. This is possible and 
illustrates the connection’s bidirectional nature.

1 In COMSOL Multiphysics select the menu item Options>Constants.
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2 Define a constant with the name fillet_radius and in the corresponding 
Expression edit field and enter 4. Click OK.

3 Select the menu item File>SolidWorks Connection>Update.

4 This action updates the fillet in the COMSOL Multiphysics geometry to the new 
value. In addition, the connection updates the value of fillet_radius and the drawing 
in SolidWorks.
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S umma r y  o f  C ommand s
cad3part on page 38

cadconvert on page 39

caddetachfac on page 40

cadfindfillets on page 41

cadfindshortedg on page 42

cadfindsliverfac on page 43

cadfindsmallfac on page 44

cadfindspikes on page 45

cadknit on page 46

cadrepair on page 47

cadrmfac on page 49

cadrmfillets on page 50

cadrmshortedg on page 51

cadrmsliverfac on page 52

cadrmsmallfac on page 53

cadrmspikes on page 54

geomexport on page 56

geomimport on page 57

geomupdate on page 60

swbody on page 61

swinit on page 62
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Command s  G r oup ed b y  Fun c t i o n

CAD Repair and Defeaturing Functions

Geometry Functions

Geometry Objects

FUNCTION PURPOSE

cadconvert Convert CAD object to COMSOL object

caddetachfac Detach faces from CAD object to form a new solid

cadfindfillets Find fillets in CAD object

cadfindshortedg Find short edges in CAD object

cadfindsliverfac Find sliver faces in CAD object

cadfindsmallfac Find small faces in CAD object

cadfindspikes Find spikes in CAD object

cadknit Knit faces and form solid CAD object

cadrepair Repair CAD object

cadrmfac Remove faces from CAD object

cadrmfillets Remove fillets from CAD object

cadrmshortedg Remove short edges from CAD object

cadrmsliverfac Remove sliver faces from CAD object

cadrmsmallfac Remove small faces from CAD object

cadrmspikes Remove spikes from CAD object

FUNCTION PURPOSE

geomimport Import geometry objects from file

geomupdate Update geometry data in FEM structure

swinit Initialize connection with SolidWorks

FUNCTION PURPOSE

cad3part CAD geometry object

swbody SolidWorks imported body
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cad3partPurpose Create a CAD geometry object.

Syntax g = cad3part

Description g = cad3part creates a CAD geometry object.

See Also geomimport
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cadconvert
cadconvertPurpose Convert CAD object to COMSOL object.

Syntax g1 = cadconvert(g)

Description g1 = cadconvert(g) converts a CAD geometry object to a COMSOL geometry 
object.

See Also cad3part, geomimport
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caddetachfacPurpose Detach faces from CAD object to form a new solid.

Syntax [g1,...] = caddetachfac(g,faces,...)

Description g1 = caddetachfac(g,faces) detaches the set of faces in the vector faces from 
the CAD object g (parent) and forms a new solid (child) with the detached faces. 
The returned cell array of CAD objects g1 includes the modified parent object and 
the new child solid object.

This function supports the following properties:

With patchchild, the function will try to heal the wound on the child body by 
growing or shrinking the faces surrounding the wound on the child body. The 
patchparent property will do the same but with the surfaces on the parent body.

Examples The following example imports the COMSOL Multiphysics geometry file 
defeaturing_demo_2.mphbin and detaches a hole defined by a set of faces:

filepath = which('defeaturing_demo_2.mphbin');
g = geomimport(filepath);
geomplot(g{1});
faces=[6 7 8 9 11 12 13];
g1 = caddetachfac(g{1},faces);
figure
geomplot(g1{1})
figure
geomplot(g1{2})

See Also cadrmfac

TABLE 3-1:  VALID PROPERTY/VALUE PAIRS

PROPERTY NAME PROPERTY VALUE DEFAULT DESCRIPTION

Healparent fill | patch patch Healing method used on the 
parent body. For details see 
cadrmfac

Healchild fill | 
patchchild | 
patchparent

patchparent Healing method used on the 
child body. For details see 
below

Out stx | ftx | 
ctx | ptx

none Output variables. For more 
information see the entry for 
geomcsg
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cadfindfillets
cadfindfilletsPurpose Find fillets in CAD object.

Syntax facesets = cadfindfillets(g,...)

Description facesets = cadfindfillets(g) finds fillets in the CAD object g. Fillets are 
defined as a set of connected faces and are returned in a cell array with vector 
elements of face indices. All fillets and chains of fillets with a radius smaller than the 
property Entsize are returned.

This function supports the following properties:

The default for Entsize is calculated as the size of the object multiplied with 
1·10−3.

Examples See the example under the function cadrmfillets.

See Also cadrmfillets, cadrmfac

TABLE 3-2:  VALID PROPERTY/VALUE PAIRS

PROPERTY NAME PROPERTY VALUE DEFAULT DESCRIPTION

Entsize positive real scalar see below Maximum fillet radius
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cadfindshortedgPurpose Find short edges in CAD object.

Syntax edgesets = cadfindshortedg(g,...)

Description edgesets = cadfindshortedg(g) finds short edges in the CAD object g.

The returned cell array edgesets contains chains of short edges as elements. Each 
element is a matrix with the edge indices in the first row and the corresponding edge 
lengths in the second row.

This function supports the following properties:

The default for Entsize is calculated as the size of the object multiplied with 
1·10−3.

Examples See the example under the function cadrmshortedg.

See Also cadrmshortedg

TABLE 3-3:  VALID PROPERTY/VALUE PAIRS

PROPERTY NAME PROPERTY VALUE DEFAULT DESCRIPTION

Entsize positive real scalar see below Maximum edge length
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cadfindsliverfac
cadfindsliverfacPurpose Find sliver faces in CAD object.

Syntax faces = cadfindsliverfac(g,...)

Description faces = cadfindsliverfac(g) finds and returns sliver faces in the CAD object g.

The returned vector faces contains the face indices.

Sliver faces are narrow but long faces with large aspect ratio, which usually give rise 
to extremely fine local meshes in their vicinity

This function supports the following properties:

The default for Entsize is calculated as the size of the object multiplied with 
1·10−3.

Examples See the example under the function cadrmsliverfac.

See Also cadrmsliverfac, cadrmfac

TABLE 3-4:  VALID PROPERTY/VALUE PAIRS

PROPERTY NAME PROPERTY VALUE DEFAULT DESCRIPTION

Entsize positive real scalar see below Maximum face width
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cadfindsmallfacPurpose Find small faces in CAD object.

Syntax faces = cadfindsmallfac(g,...)

Description faces = cadfindsmallfac(g) finds small faces in the CAD object g.

A small face is a face that fits within a sphere of specified radius, given in the property 
Entsize. The returned vector contains the face indices.

This command supports the following properties:

The default for Entsize is calculated as the size of the object multiplied with 
1·10−3.

Examples See the example under the function cadrmsmallfac.

See Also cadrmsmallfac, cadrmfac

TABLE 3-5:  VALID PROPERTY/VALUE PAIRS

PROPERTY NAME PROPERTY VALUE DEFAULT DESCRIPTION

Entsize positive real scalar see below Maximum face size
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cadfindspikes
cadfindspikesPurpose Find spikes in CAD object.

Syntax spikes = cadfindspikes(g,...)

Description spikes = cadfindspikes(g) finds spikes in the CAD object g.

The output spikes is a cell array of structure elements. There are two fields in each 
element:

• the edges field, which is a vector with the edge indices of edges that define a spike

• the width field, which contains the width of the spike

A spike is a long and narrow protrusion on an edge or corner of a face defined by 
two or three edges.

This function supports the following properties:

The default for Entsize is calculated as the size of the object multiplied with 
1·10−3.

Examples See the example under the function cadrmspikes.

See Also cadrmspikes

TABLE 3-6:  VALID PROPERTY/VALUE PAIRS

PROPERTY NAME PROPERTY VALUE DEFAULT DESCRIPTION

Entsize positive real scalar see below Maximum spike width
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cadknitPurpose Knit face CAD objects to solid.

Syntax [g1,...] = cadknit(faces,...)

Description g1 = cadknit(faces) knits the faces in the cell array faces and tries to form a 
solid CAD object. The new face and/or solid objects are returned in the cell array 
g1.

This function also removes gaps and spikes that are within the absolute tolerance 
specified in the property Repairtol.

This function supports the following properties:

Examples The following example imports the file repair_demo_2.x_b, and knits the face 
object into a solid. A gap is also removed during the operation.

filepath = which('repair_demo_2.x_b');
g = geomimport(filepath);
g1 = cadknit(g,'Repairtol',1e-3);

See Also cadrepair

TABLE 3-7:  VALID PROPERTY/VALUE PAIRS

PROPERTY NAME PROPERTY VALUE DEFAULT DESCRIPTION

Repairtol positive real 
scalar

1e-4 Absolute repair tolerance

Out stx | ftx | ctx | 
ptx

none Output variables. For 
more information see the 
entry for geomcsg.
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cadrepair
cadrepairPurpose Repair CAD object.

Syntax [g1,...] = cadrepair(g,...)

Description g1 = cadrepair(g) repairs the CAD object g.

This function supports the following properties:

The function tries to remove or repair the following defects:

• Topology with invalid sense

• Invalid edge and vertex tolerances

• Invalid manifold

• Self-intersecting manifold

• Non-G1 manifold

• Missing edge or vertex manifold

• Missing vertex

• Vertices not on curve of edge

• Edges and vertices not on surface of face

• Removal of small edges

• Removal of surface self-intersections that lie outside the face

• Splitting at edge intersections which have no vertex

• Removal of discontinuities by either splitting or smoothing

• Recalculates incorrect or missing curves for edges

• Remove small features (edges, faces, edge pinches and spikes)

The function also performs the following simplifications:

• Simplification of B-splines to analytic representations

• Simplification and merging of intersection curves

TABLE 3-8:  VALID PROPERTY/VALUE PAIRS

PROPERTY NAME PROPERTY 
VALUE

DEFAULT DESCRIPTION

Repairtol positive real 
scalar

1e-4 Absolute repair tolerance

Out stx | ftx | 
ctx | ptx

none Output variables. For more 
information see the entry for 
geomcsg.
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• Simplification of swept and spun surfaces to analytic

• Reducing degree of high order B-splines

See Also cadknit
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cadrmfacPurpose Remove faces from CAD object.

Syntax [g1,...] = cadrmfac(g,faces,...)

Description g1 = cadrmfac(g,faces) removes the faces specified with face indices in the 
vector faces from the CAD object g and returns a CAD object g1.

Only fillets that can be removed without invalidating the CAD object are removed.

This function supports the following properties:

With the Heal property set to patch the function tries to heal the wound caused by 
the removal of faces by shrinking and/or growing the surrounding faces. If the Heal 
property is set to fill the function tries to calculate a surface to cover the wound 
based on the surrounding edges.

Examples The following example imports the file defeaturing_demo_2.mphbin, and 
removes a hole from the geometry model:

filepath = which('defeaturing_demo_2.mphbin');
g = geomimport(filepath);
geomplot(g{1},'Facemode','off');
faces=[6 7 8 9 11 12 13];
g1 = cadrmfac(g{1},faces);
figure
geomplot(g1,'Facemode','off')

See Also caddetachfac

TABLE 3-9:  VALID PROPERTY/VALUE PAIRS

PROPERTY NAME PROPERTY 
VALUE

DEFAULT DESCRIPTION

Heal fill | patch patch Healing method used on the 
parent body

Out stx | ftx | 
ctx | ptx

none Output variables. For more 
information see the entry for 
geomcsg.
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cadrmfilletsPurpose Remove fillets from CAD object.

Syntax [g1,...] = cadrmfillets(g,facesets,...)

Description g1 = cadrmfillets(g,facesets) removes fillets specified in facesets from the 
CAD object g.

The cell array facesets contains vector elements with face indices of the fillets or 
fillet chains. This is typically the output from a call to the cadfindfillets 
command.

Only faces that can be removed without invalidating the object are removed.

This command supports the following properties:

With the Out property set to status the function also returns a vector whose 
elements indicate if the operation succeeded for the corresponding elements in 
facesets. Ones and zeros indicate success and failure, respectively.

Examples The following example imports the CAD object in the COMSOL Multiphysics 
geometry file defeaturing_demo_3.mphbin and finds and removes all fillets with 
a radius less than 4·10−3:

filepath = which('defeaturing_demo_3.mphbin');
g = geomimport(filepath);
geomplot(g{1});
facesets=cadfindfillets(g{1},'Entsize',4e-3);
g1 = cadrmfillets(g{1},facesets);
figure
geomplot(g1)

See Also cadfindfillets, cadrmfac

TABLE 3-10:  VALID PROPERTY/VALUE PAIRS

PROPERTY NAME PROPERTY 
VALUE

DEFAULT DESCRIPTION

Out stx | ftx | 
ctx | ptx | 
status

none Output variables. For more 
information see the entry for 
geomcsg.
R  3 :  C A D  I M P O R T  M O D U L E  C O M M A N D  R E F E R E N C E



cadrmshortedg
cadrmshortedgPurpose Remove short edges from CAD object.

Syntax [g1,...] = cadrmshortedg(g,edgesets,...)

Description g1 = cadrmshortedg(g,edgesets) removes short edges, that are specified in 
edgesets, from the CAD object g.

g = cadrmshortedg(g,edgesets,’Entsize’,length) removes edges, which 
are specified in edgesets, and that have a length shorter than length, from the 
CAD object g.

The elements of the cell array edgesets are matrices with the indices of the edges 
in the first row and the corresponding length in the second row. This is typically the 
output from a call to the cadfindshortedg function. For a single edge chain, 
edgesets can also be a matrix with two rows.

Only edges that can be removed without invalidating the geometry are removed.

This function supports the following properties:

With the Out property set to status the function also returns a vector whose 
elements indicate if the operation succeeded for the corresponding elements in 
edgesets. Ones and zeros indicate success and failure, respectively.

Examples The following example imports the geometry model from the file 
defeaturing_demo_4.x_b, finds edges shorter than 3·10−3, and finally deletes 
those edges that are shorter than 3·10−4:

filepath = which('defeaturing_demo_4.x_b');
g = geomimport(filepath);
geomplot(g{1},'Edgelabel','On');
edgesets=cadfindshortedg(g{1},'Entsize',3e-3);
g1 = cadrmshortedg(g{1},edgesets,'Entsize',3e-4);
figure
geomplot(g1,'Edgelabel','On')

See Also cadfindshortedg

TABLE 3-11:  VALID PROPERTY/VALUE PAIRS

PROPERTY NAME PROPERTY 
VALUE

DEFAULT DESCRIPTION

Entsize positive real 
scalar

max(edgesets{:,1}
(2,:))*1.0001

Length of short edge

Out stx | ftx | 
ctx | ptx | 
status

none Output variables. For 
more information see the 
entry for geomcsg.
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cadrmsliverfacPurpose Remove sliver faces from CAD object.

Syntax [g1,...] = cadrmsliverfac(g,faces,’Entsize’,width,...)

Description g1 = cadrmsliverfac(g,faces,’Entsize’,width) removes sliver faces, which 
are specified in faces, and that are narrower than width, from the CAD object g.

The vector faces contains face indices, and is typically the output from a call to the 
function findsliverfac. 

Only faces that can be removed without invalidating the geometry object are 
removed.

This function supports the following properties:

With the Out property set to status the function also returns a vector whose 
elements indicate if the operation succeeded for the corresponding elements in 
faces. Ones and zeros indicate success and failure, respectively.

Examples The following example imports the geometry model from the file 
defeaturing_demo_5.x_b, finds sliver faces narrower than 2·10−3, and deletes 
those edges that are narrower than 2·10−5:

filepath = which('defeaturing_demo_5.x_b');
g = geomimport(filepath);
geomplot(g{1},'Facelabel','On','Facemode','Off');
faces = cadfindsliverfac(g{1},'Entsize',2e-3);
[g1 relg1tog] = cadrmsliverfac(g{1},faces,...
'Entsize',2e-5,'Out','ftx');
figure
geomplot(g1,'Facelabel','On','Facemode','Off')

Connectivity information between faces of the modified and original body is 
returned in the variable relg1tog. This variable is a sparse matrix with rows and 
columns corresponding to face indices in the bodies g1 and g{1}, respectively. The 
filled positions indicate a connection between the corresponding faces.

See Also cadfindsliverfac, cadrmfac

TABLE 3-12:  VALID PROPERTY/VALUE PAIRS

PROPERTY NAME PROPERTY VALUE DEFAULT DESCRIPTION

Entsize positive real scalar - Width of sliver face

Out stx | ftx | ctx | 
ptx | status

none Output variables. For more 
information see the entry for 
geomcsg.
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cadrmsmallfacPurpose Remove small faces from CAD object.

Syntax [g1,...] = cadrmsmallfac(g,faces,’Entsize’,size,...)

Description g1 = cadrmsmallfac(g,faces) removes small faces, that are specified in faces, 
from the CAD object g.

g1 = cadrmsmallfac(g,faces,’Entsize’,size) removes small faces, that are 
specified in faces, and that are smaller than size, from the CAD object g.

The vector faces contains face indices, and is typically the output of a call to the 
function cadfindsmallfac.

Only faces that can be removed without invalidating the CAD object are removed.

This function supports the following properties:

With the Out property set to status the function also returns a vector whose 
elements indicate if the operation succeeded for the corresponding elements in 
faces. Ones and zeros indicate success and failure, respectively.

Examples The following example imports the geometry model from the file 
defeaturing_demo_6.x_b, finds faces smaller than 10−3, and deletes those faces 
that are smaller than 10−4:

filepath = which('defeaturing_demo_6.x_b');
g = geomimport(filepath);
geomplot(g{1},'Facelabel','On','Facemode','Off');
faces = cadfindsmallfac(g{1},'Entsize',1e-3);
g1 = cadrmsmallfac(g{1},faces,'Entsize',1e-4);
figure
geomplot(g1,'Facelabel','On','Facemode','Off')

See Also cadfindsmallfac, cadrmfac

TABLE 3-13:  VALID PROPERTY/VALUE PAIRS

PROPERTY NAME PROPERTY 
VALUE

DEFAULT DESCRIPTION

Entsize positive real 
scalar

- Size of small face

Out stx | ftx | 
ctx | ptx | 
status

none Output variables. For more 
information see the entry for 
geomcsg.
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cadrmspikesPurpose Remove spikes from CAD object.

Syntax [g1,...] = cadrmspikes(g,spikes,...)

Description g1 = cadrmspikes(g,spikes) removes specified spikes from the CAD object g.

g1 = cadrmspikes(g,spikes,’Entsize’,width) removes specified spikes, that 
have a width smaller than or equal to width, from the CAD object g.

The cell array spikes is typically the output from a call to the function 
cadfindspikes and has structure elements. There are two fields in each element:

• the edges field, which is a vector with the edge indices of edges that define a spike

• the width field, which contains the width of the spike.

Only spikes that can be removed without invalidating the CAD object are removed.

This function supports the following properties:

With the Out property set to status the function also returns a vector whose 
elements indicate if the operation succeeded for the corresponding elements in 
spikes. Ones and zeros indicate success and failure, respectively.

Examples The following example imports the geometry model from the file 
defeaturing_demo_7.x_b, finds and deletes spikes narrower than 10−4:

filepath = which('defeaturing_demo_7.x_b');
g = geomimport(filepath);
meshg = meshinit(g{1});
meshplot(meshg);
spikes = cadfindspikes(g{1},'Entsize',1e-4);
g1 = cadrmspikes(g{1},spikes);
meshg1 = meshinit(g1);
figure
meshplot(meshg1)

Visualize the spike by meshing the object g{1}: an extremely fine mesh is generated 
at the location of the spike.

TABLE 3-14:  VALID PROPERTY/VALUE PAIRS

PROPERTY NAME PROPERTY VALUE DEFAULT DESCRIPTION

Entsize positive real 
scalar

max(spikes
{:}.width)
*1.00001

Width of spike

Out stx | ftx | ctx 
| ptx | status

none Output variables. For more 
information see the entry for 
geomcsg.
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See Also cadfindspikes
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geomexportPurpose Export geometry objects to file.

Syntax geomexport(filename, geoms,...)

Description geomexport(filename, geoms...) exports the geometry data in the cell array 
geoms of geometry objects to a file.

filename can be any of the following formats:

Note 1: This format requires a license for the COMSOL CAD Import Module. 
Only geometries imported using the CAD Import Module (cad3part objects) can 
be exported to Parasolid format.

The following properties are supported

Report determines if a progress window appears during the call.

Examples The following example imports the DXF file demo1.dxf as a curve2 object:

filepath = which('demo1.dxf');
g = geomimport(filepath);
geomplot(g{1})

Diagnostics geomexport replaces the functionality of the 3.1 function dxfwrite.

See Also geom0, geom1, geom2, geom3, meshimport, geomexport, cad3part, 
cadrepair

TABLE 3-15:  VALID FILE FORMATS

FILE FORMAT NOTE FILE EXTENSIONS

COMSOL Multiphysics Binary .mphbin

COMSOL Multiphysics Text .mphtxt

Parasolid Binary 1 .x_b

Parasolid Text 1 .x_t

DXF .dxf

TABLE 3-16:  VALID PROPERTY/VALUE PAIRS

PROPERTY NAME PROPERTY 
VALUE

DEFAULT DESCRIPTION

Report on | off on Display a progress window
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geomimportPurpose Import geometry objects from a file.

Syntax gl = geomimport(filename,...)

Description gl = geomimport(filename,...) reads the geometry file filename and 
translates the geometry data using the specified properties into a cell array of CAD 
geometry objects gl.

filename can be any of the following formats:

Note 1: This format requires a license for the COMSOL CAD Import Module.

Note 2: This format requires a license for a format-specific module from COMSOL.

Note 3: This format requires a license for COMSOL Script.

TABLE 3-17:  SUPPORTED FILE FORMATS

FILE FORMAT NOTE FILE EXTENSIONS OBJECT TYPE IN COMSOL 
MULTIPHYSICS

Autodesk Inventor 2 .ipt CAD object

CATIA V4 2 .model CAD object

CATIA V5 2 .CATPart, .CATProduct CAD object

COMSOL Multiphysics 
Binary

.mphbin CAD and/or 
COMSOL objects

COMSOL Multiphysics 
Text

.mphtxt CAD and/or 
COMSOL objects

DXF .dxf COMSOL object

GDS 3 .gds COMSOL object

IGES 1 .igs, .iges CAD object

Parasolid 1 .x_t, .x_b CAD object

Pro/ENGINEER 2 .prt, .asm CAD object

SAT 1 .sat, .sab CAD object

STEP 1 .step, .stp CAD object

STL .stl COMSOL object

VDA-FS 2 .vda CAD object

VRML .wrl, .vrml COMSOL object
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This function supports the following properties:

When importing COMSOL Multiphysics files and those in the GDS format, the 
function ignores all properties, except for Report.

For DXF import, the default for Coercion is curve.

For STL and VRML imports, the command supports all properties in the function 
meshenrich.

Coercion can force the import process to knit boundary segments together and 
possibly try to form solid entities.

Keepbnd, Keepfree, and Keepsolid indicate which type of entities the module 
should consider in the imported data.

Repair determines if the module should process the imported data to improve the 
quality. See the cadrepair function for details on the type of repair that is done to 
geometric data. 

Repairtol is a relative tolerance. It indicates the size of entities to remove, which 
points to snap together, and similar features.

Importtol is an absolute tolerance. It indicates the size of entities to remove, which 
points to snap together, and similar features. It is used when importing a file using 
the CAD Import module, replacing Repairtol.

Report determines if a progress window should appear during the call.

TABLE 3-18:  VALID PROPERTY/VALUE PAIRS

PROPERTY NAME PROPERTY VALUE DEFAULT DESCRIPTION

Coercion solid | face | 
curve | point 
| off

solid Coerce the imported geometry

Keepbnd on | off on Keep boundary entities

Keepfree on | off off Keep free edge/point entities

Keepsolid on | off on Keep solid entities

Repair on | off on Repair imported data

Repairtol positive scalar 1e-4 Repair tolerance

Importtol positive scalar 1e-5 Absolute repair tolerance used 
when importing CAD Import 
Module formats.

Report on | off on Display a progress window
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Examples The following example imports the DXF file demo1.dxf as a curve2 object:

filepath = which('demo1.dxf');
g = geomimport(filepath);
geomplot(g{1})

Diagnostics geomimport replaces the functionality of the COMSOL Multiphysics 3.0 functions 
dxfread, igesread, stlread, and vrmlread. We no longer support those 
functions and their properties and thus do not document them.

See Also geom0, geom1, geom2, geom3, meshimport, geomexport, cad3part, 
cadrepair
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geomupdatePurpose Update geometry data contained in an FEM structure.

Syntax fem = geomupdate(fem,...)

Description fem = geomupdate(fem,...) updates geometry objects contained in the FEM 
structure fem.

If fem contains geometry objects of type swbody and there is an existing SolidWorks 
connection, the SolidWorks geometry is updated according to variables the 
geomupdate function passes, and these bodies are synchronized with SolidWorks.

Use geomanalyze to update the rest of the FEM structure after updating the 
geometry objects.

This function supports the following properties:

This function also supports all properties of geomimport.

See Also geomanalyze, geomimport

TABLE 3-19:  VALID PROPERTY/VALUE PAIRS

PROPERTY NAME PROPERTY 
VALUE

DEFAULT DESCRIPTION

Const cell array Definition of constants

Geomnum integer 1 Number of the FEM structure in 
an extended FEM structure
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swbodyPurpose Create a SolidWorks synchronized geometry object.

Syntax s3 = swbody

Description s3 = swbody creates a SolidWorks synchronized geometry object.

A swbody is a geom3 object that is generated from a SolidWorks connection and that 
can be updated from SolidWorks by calling geomupdate.

If there is no active SolidWorks connection, the swbody object acts as an ordinary 
geom3 object.

See Also geom0, geom1, geom2, geom3, geomupdate
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swinitPurpose Initialize a connection with SolidWorks.

Syntax gl = swinit(doc,...)

Description gl = swinit(doc,...) returns a cell array of SolidWorks bodies obtained from 
the open SolidWorks document doc. If doc is an empty string, the active open 
document is used.

See Also geomanalyze, geomupdate
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G l o s s a r y
This glossary contains CAD-specific terms that describe file formats and software 
packages in a general context. For geometric terms specific to COMSOL 
Multiphysics, see the glossary in the COMSOL Multiphysics User’s Guide. To find 
references that point to more information about a term, see the index.
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G l o s s a r y  o f  T e rm s
ACIS   A geometry kernel from Spatial Corp. with SAT as its native file format.

AutoCAD   A 2D CAD program from Autodesk, Inc.

Autodesk Inventor   Name of both a CAD program and its native file format (.ipt). 
from Autodesk, Inc. The kernel of this CAD program is based on ACIS.

CAD   Computer-aided design.

CATIA V4   Name of both a CAD program and its native file format (.model) from 
Dassault Systèmes S.A. It is fundamentally different to CATIA V5.

CATIA V5   Name of both a CAD program and its native file format (.CATPart, 
.CATProduct) from Dassault Systèmes S.A. It is fundamentally different to CATIA 
V4.

defeaturing   The process of removing details in the CAD geometry in order to reduce 
the size of the finite element model.

DXF   The 2D file format (.dxf) native to AutoCAD from Autodesk, Inc.

GDS   A 2D file format (.gds) based on a neutral standard.

IGES   A file format (.igs, .iges) based on a neutral standard not native to any geometry 
kernel.

NX   A CAD program (formerly known as Unigraphics) from UGS Corp. using the 
Parasolid kernel.

Parasolid   Name of both a geometry kernel and its native file format (.x_t, .x_b) from 
UGS Corp.

Pro/ENGINEER   Name of both a CAD program and its native file format (.prt, .asm) 
from Parametric Technology Corp.

SAT   The native file format (.sat, .sab) of the ACIS geometry kernel from Spatial 
Corp.
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Solid Edge   A CAD program from UGS Corp. using the Parasolid kernel.

SolidWorks   A CAD program from SolidWorks Corp. using the Parasolid kernel.

STEP   A file format (.step, .stp) based on a neutral standard not native to any geometry 
kernel.

STL   A file format (.stl) based on a neutral standard using surface-mesh 
representations.

VDA-FS   A file format (.vda) based on a neutral standard not native to any geometry 
kernel.

VRML   A file format (.wrl, .vrml) based on a neutral standard using surface mesh 
representations.
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