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 1
I n t r o d u c t i o n
The AC/DC Module Model Library consists of a set of models from various areas 
of low-frequency electromagnetic field simulations. Their purpose is to assist you 
in learning, by example, how to model sophisticated electromagnetic components, 
systems, and effects. Through them, you can tap the expertise of the top researchers 
in the field, examining how they approach some of the most difficult modeling 
problems you might encounter. You can thus get a feel for the power that 
COMSOL Multiphysics® offers as a modeling tool. In addition to serving as a 
reference, the models can also give you a big head start if you are developing a 
model of a similar nature.

We have divided these models into four groups: electrical components, general 
industrial applications, motor and drives, and tutorial models. The models also 
illustrate the use of the various electromagnetics-specific application modes from 
which we built them. These specialized modes are unavailable in the base 
COMSOL Multiphysics package, and they come with their own graphical-user 
interfaces that make it quick and easy to access their power. You can even modify 
them for custom requirements. COMSOL Multiphysics itself is very powerful and, 
with sufficient expertise in a given field, you certainly could develop these modes 
by yourself—but why spend the hundreds or thousands of hours that would be 
necessary when our team of experts has already done the work for you?
 1



2 |  C H A P T E R  1
Note that the model descriptions in this book do not contain every detail on how to 
carry out every step in the modeling process. Before tackling these in-depth models, 
we urge you to first read the second book in the AC/DC Module documentation set. 
Titled the AC/DC Module User’s Guide, it introduces you to the basic functionality 
in the module, reviews new features in the version 3.4 release, covers basic modeling 
techniques and includes reference material of interest to those working in 
electromagnetics. A third book, the AC/DC Module Reference Guide, contains 
reference material about application mode implementations and command-line 
programming. It is available in HTML and PDF format from the COMSOL Help 
Desk. For more information on how to work with the COMSOL Multiphysics 
graphical user interface, please refer to the COMSOL Multiphysics User’s Guide or the 
COMSOL Multiphysics Quick Start manual. Extensive information about command- 
line modeling using COMSOL Script is available in yet another book, the COMSOL 
Multiphysics Scripting Guide. 

The book in your hands, the AC/DC Module Model Library, provides details about 
a large number of ready-to-run models that illustrate real-world uses of the module. 
Each entry comes with theoretical background as well as instructions that illustrate 
how to set it up. They were written by our staff engineers who have years of experience 
in electromagnetics; they are your peers, using the language and terminology needed 
to get across the sophisticated concepts in these advanced topics.

Finally note that we supply these models as COMSOL Multiphysics Model MPH-files 
so you can import them into COMSOL Multiphysics for immediate execution, 
allowing you to follow along with these examples every step along the way.

Model Library Guide

The table below summarizes key information about the entries in the AC/DC Module 
Model Library. A series of columns states the application mode (such as Perpendicular 
Currents) used to solve the corresponding model. The solution time is the elapsed 
time measured on a machine running Windows Vista with a 2.6 GHz AMD Athlon X2 
Dual Core 500 CPU and 2 GB of RAM. For models with a sequential solution 
strategy, the Solution Time column shows the elapsed time for the longest solution 
step. Additional columns point out the solution properties a given example highlights. 
:  I N T R O D U C T I O N
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The choices here include the type of analysis (such as time dependent) and whether 
multiphysics or parametric studies are included.
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TUTORIAL MODELS

Eddy Currents 21* Azimuthal 
Induction 
Currents

1 s  √ 

Floating Potentials and 
Electric Shielding

33* Conductive 
Media DC

11 s  √ 

Coil with Infinite Elements 46* Azimuthal 
Induction 
Currents

3 s  √ 

Microstrip 66* Electrostatics, 
In-Plane Electric 
and Induction 
Currents, 
Potentials

5 s  √  √ 

Small-Signal Analysis of an 
Inductor

79* Azimuthal 
Induction 
Currents

5 s  √  √ 

Electromagnetic Forces on 
Parallel Current-Carrying 
Wires

8 Perpendicular 
Currents

1 s  √ 

Inductive Heating of a 
Copper Cylinder

16 Azimuthal 
Currents, Heat 
Transfer

9 s  √  √  √  √ 

Permanent Magnet 21 Magnetostatics, 
No Currents

26 s  √ 

MOTORS AND DRIVES MODELS
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Linear Electric Motor of 
the Moving Coil Type

30 Perpendicular 
Currents

2 s  √ 

Generator in 2D 39 Perpendicular 
Currents, 
Moving Mesh

2 min  √  √  √ 

Generator with 
Mechanical Dynamics and 
Symmetry

53 Perpendicular 
Currents

4 min  √  √  √ 

Generator in 3D 65 Magnetostatics, 
No Currents

6 min  √  √ 

Magnetic Brake in 3D 72 3D 
Magnetostatics

10 min √

Railgun 84 3D 
Quasi-Statics, 
Conductive 
Media DC

43 min √ √

ELECTRICAL COMPONENT 
MODELS

Tunable MEMS Capacitor 100 Electrostatics 8 s  √ 

Induction Currents from 
Circular Coils

110 Azimuthal 
Currents

10 s  √  √ 

Magnetic Field of a 
Helmholtz Coil

122 3D 
Magnetostatics

15 s  √ 

Inductance in a Coil 131 Azimuthal 
Currents

12 s  √ 

Integrated Square-Shaped 
Spiral Inductor

141 3D 
Magnetostatics

27 s  √ 

Inductance of a Power 
Inductor

153 3D Quasi-Statics 13 min  √ 

Bonding Wires to a Chip 161 3D Quasi-Statics ¤17 min  √ 

TABLE 1-1:  AC/DC MODULE MODEL LIBRARY
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* This page number refers to the AC/DC Module User’s Guide. 
¤ This model requires a 64-bit platform.

High Current Cables in a 
Circuit

170 Joule Heating 3 min √ √

Inductor in Amplifier 
Circuit

189 Azimuthal 
Currents, ODE

2 min  √  √  √  √ 

GENERAL INDUSTRIAL 
APPLICATION MODELS

Eddy Currents in 3D 202 3D Quasi-Statics 6 min  √ 

Cold Crucible 211 3D Quasi-Statics 20 s  √ 

Electric Impedance Sensor 222 Small In-Plane 
Currents

2 min  √ 

One-Sided Magnet and 
Plate

229 Magnetostatics, 
No Currents

41 s  √ 

Magnetic Signature of a 
Submarine

241 Magnetostatics, 
No Currents

9 s  √ 

3D Quadrupole Lens 252 Magnetostatics, 
No Currents

20 s  √ 

Superconducting Wire 259 PDE, General 
Form

56 s  √  √ 

RF-Heated Hot Wall 
Furnace for 
Semiconductor Processing

267 3D 
Quasi-Statics, 
General Heat 
Transfer

4 min  √  √  √ 

An RFID System 292 Magnetostatics 7 min  √ 

TABLE 1-1:  AC/DC MODULE MODEL LIBRARY
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Typographical Conventions

All COMSOL manuals use a set of consistent typographical conventions that should 
make it easy for you to follow the discussion, realize what you can expect to see on the 
screen, and know which data you must enter into various data-entry fields. In 
particular, you should be aware of these conventions:

• A boldface font of the shown size and style indicates that the given word(s) appear 
exactly that way on the COMSOL graphical user interface (for toolbar buttons in 
the corresponding tooltip). For instance, we often refer to the Model Navigator, 
which is the window that appears when you start a new modeling session in 
COMSOL; the corresponding window on the screen has the title Model Navigator. 
As another example, the instructions might say to click the Multiphysics button, and 
the boldface font indicates that you can expect to see a button with that exact label 
on the COMSOL user interface.

• The names of other items on the graphical user interface that do not have direct 
labels contain a leading uppercase letter. For instance, we often refer to the Draw 
toolbar; this vertical bar containing many icons appears on the left side of the user 
interface during geometry modeling. However, nowhere on the screen will you see 
the term “Draw” referring to this toolbar (if it were on the screen, we would print 
it in this manual as the Draw menu).

• The symbol > indicates a menu item or an item in a folder in the Model Navigator. 
For example, Physics>Equation System>Subdomain Settings is equivalent to: On the 
Physics menu, point to Equation System and then click Subdomain Settings. 
COMSOL Multiphysics>Heat Transfer>Conduction means: Open the COMSOL 

Multiphysics folder, open the Heat Transfer folder, and select Conduction.

• A Code (monospace) font indicates keyboard entries in the user interface. You might 
see an instruction such as “Type 1.25 in the Current density edit field.” The 
monospace font also indicates COMSOL Script codes.

• An italic font indicates the introduction of important terminology. Expect to find 
an explanation in the same paragraph or in the Glossary. The names of books in the 
COMSOL documentation set also appear using an italic font.
:  I N T R O D U C T I O N
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T u t o r i a l  M o d e l s
This chapter contains a selection of models that demonstrate important features 
and modeling techniques. Therefore, this chapter contains models from many 
different application areas. For pedagogical reasons, these models are kept as simple 
as possible with the main focus on the feature that they demonstrate.
 7
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E l e c t r omagne t i c  F o r c e s  on Pa r a l l e l  
C u r r e n t - C a r r y i n g  W i r e s

Introduction

One ampère is defined as the constant current in two straight parallel conductors of 
infinite length and negligible circular cross section, placed one meter apart in vacuum, 
that produces a force of 2·10−7 newton per meter of length (N/m). This model shows 
a setup of two parallel wires in the spirit of this definition, but with the difference that 
the wires do not have a negligible cross section. However, by successively shrinking the 
radius of the wires, the force would approach 2·10−7 N/m.

The force between the wires is computed using two different methods: by integrating 
the volume force density over the wire cross section and by integrating the stress tensor 
on the boundary. The results are in good agreement and are close but not equal to the 
number 2·10−7 N for the 1 ampère definition, as expected.

Model Definition

The model is built using the 2D Perpendicular Induction Currents application mode. 
The modeling plane is a cross section of the two wires and the surrounding air. 

D O M A I N  E Q U A T I O N S

The equation formulation in the 2D Perpendicular Induction Currents application 
mode assume that the only nonzero component of the magnetic vector potential is Az. 
This corresponds to all currents being perpendicular to the modeling plane. The 
following equation is solved:

where µ is the permeability of the medium and  the externally applied current.  
is set so that the applied current in the wires equals 1 A, but with different signs.

B O U N D A R Y  C O N D I T I O N S

At the exterior boundary of the air domain, Az, is fixed to zero. The interior 
boundaries between the wires and the air only assume continuity, corresponding to a 
homogeneous Neumann condition.

µ Az∇×( )∇× Jz
e

=

Jz
e Jz

e

2 :  TU T O R I A L  M O D E L S



Results and Discussion

The expression for the surface stress reads

where n1 is the boundary normal pointing out from the conductor wire and T2 the 
stress tensor of air. The closed line integral of this expression around the circumference 
of either wire evaluates to −1.92·10−7 N. The minus sign indicates that the force 
between the wires is repulsive.

The volume force density is given by 

The surface integral of the x component of the volume force on the cross section of a 
wire gives the result −1.92·10−7 N. The number of mesh elements and the finite size 
of the geometry is what ultimately limits the accuracy in the calculations.

Model Library path: ACDC_Module/Tutorial_Models/parallel_wires

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select 2D in the Space dimension list.

2 Select the AC/DC Module>Statics>Magnetostatics>Perpendicular Induction Currents, 

Vector Potential application mode.

3 Click OK.

n1T2
1
2
--- H B⋅( )n1– n1 H⋅( )BT

+=

F J B× Jz
e

– By⋅ Jz
e, Bx 0,⋅= =
E L E C T R O M A G N E T I C  F O R C E S  O N  P A R A L L E L  C U R R E N T - C A R R Y I N G  W I R E S  |  9
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O P T I O N S  A N D  S E T T I N G S

1 Choose Options>Constants, then enter the following names, expressions, and 
(optionally) descriptions; when finished, click OK.

The radius r of each wire is 0.2 m, and the cross-section area is A = π  r2. The total 
current is I0 = 1 A and the current density is J0 = I0/A.

2 Choose Options>Axes/Grid Settings, then specify axis limits and grid settings 
according to the following table; when finished, click OK.

As you can see on your computer screen, the aspect ratio of the drawing area is 
preserved. The specified min/max values apply to either the width or the height in 
such a way that the whole of the region in the xy-plane that you specify is visible. The 
latter rule still applies if the aspect ratio changes as a result of modified settings for the 
Model Tree. If you modify the size of the GUI window, however, you lose the settings 
for the axis limits.

G E O M E T R Y  M O D E L I N G

1 Draw a circle C1 with radius 0.2 centered at (−0.5, 0).

2 Draw a circle C2 with radius 0.2 centered at (0.5, 0).

NAME EXPRESSION DESCRIPTION

r 0.2[m] Wire radius

A pi*r^2 Wire area

I0 1[A] Current through wire

J0 I0/A Current density

AXIS GRID

x min -6 x spacing 0.5

x max 6 Extra x -0.3 0.7

y min -6 y spacing 0.5

y max 6 Extra y 0.2
 2 :  TU T O R I A L  M O D E L S



3 Draw a circle C3 with radius 5 centered at (0, 0).

Figure 2-1: The model geometry.

P H Y S I C S  S E T T I N G S

Boundary Conditions
The default boundary conditions are used.

Subdomain Settings
Apply an External current density and define Electromagnetic force variables according 
to the following table.

SETTINGS SUBDOMAIN 1 SUBDOMAIN 2 SUBDOMAIN 3

0 J0 -J0

Electromagnetic force variables wire1 wire2

Jz
e

E L E C T R O M A G N E T I C  F O R C E S  O N  P A R A L L E L  C U R R E N T - C A R R Y I N G  W I R E S  |  11
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Leave the other parameters at their default values.

M E S H  G E N E R A T I O N

1 Click the Initialize Mesh button on the Main toolbar to initialize the mesh.
 2 :  TU T O R I A L  M O D E L S



2 Click the Refine Mesh button to refine the mesh once.

Figure 2-2: The mesh.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows the magnetic flux density. Follow these steps to visualize the 
magnitude of the volume force density:

1 Click the Plot Parameters button on the Main toolbar.

2 Click the Surface tab. In the Expression edit field type 
sqrt(Jez_emqa^2*(Bx_emqa^2+By_emqa^2)). 

3 Click the Contour tab. Select the Contour plot check box and select Magnetic field, 

norm from the Predefined quantities list.

4 Click Apply to generate the plot.

5 To zoom in on the wires, choose Axes/Grid Settings from the Options menu. On the 
Axis page, type -1 in the x min and y min edit fields, and type 1 in the x max and 
y max edit fields. Make sure that the Axis equal check box is selected, then click OK.

Figure 2-3 shows the result. The volume force density is unevenly distributed within 
each wire due to the slightly inhomogeneous magnetic field from the other wire. If 
E L E C T R O M A G N E T I C  F O R C E S  O N  P A R A L L E L  C U R R E N T - C A R R Y I N G  W I R E S  |  13
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you decrease the radii of the wires, the force density becomes evenly distributed. In 
the definition of 1 A it is assumed that the radii are negligible. The field becomes 
homogeneous as the radii approach zero. The effects of the self-induced field of a 
wire then cancel out.

Figure 2-3: Force density and magnetic field.

To visualize the air stress tensor on the boundary, proceed as follows:

6 Return to the Contour page of the Plot Parameters dialog box and clear the Contour 

plot check box. 

7 Click the Arrow tab. Select the Arrow plot check box and select Boundaries from the 
Plot arrows on list. On the Boundary Data page select Maxwell surface stress tensor 

(wire1) from the Predefined quantities list.

8 In the Arrow parameters area clear the Scale factor: Auto check box and type 0.1 in 
the associated edit field.

9 Click OK to close the dialog box and generate the plot shown in Figure 2-4.
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Figure 2-4: Stress tensor and magnetic field.

Finally, compute the resulting forces on the wires.

1 To compute the resulting force in the x direction on the left wire using the stress 
tensor method, choose Postprocessing>Data Display>Global to open the Global Data 

Display dialog box. In the Expression to evaluate edit field type 
wire1_forcex_emqa, then click OK.

You should get a result near −1.92·10−7 (N/m) in the message log.

2 To alternatively compute the resulting force by integrating J × B, choose 
Postprocessing>Subdomain Integration. Select Subdomain 2 and type 
-Jez_emqa*By_emqa in the Expression edit field inside the Expression to integrate 
area. Finally, click OK to evaluate the integral.

The result displayed in the message log is again approximately −1.92·10−7 N/m. 
The force in the y direction should be negligible. Confirm this by integrating 
Jez_emqa*Bx_emqa on Subdomain 2.
E L E C T R O M A G N E T I C  F O R C E S  O N  P A R A L L E L  C U R R E N T - C A R R Y I N G  W I R E S  |  15
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I n du c t i v e  Hea t i n g  o f  a  Copp e r  
C y l i n d e r

Introduction

The induced currents in a copper cylinder produce heat, and when the temperature 
rises, the electric conductivity of the copper changes. Solving the heat transfer 
simultaneously with the field propagation is therefore crucial for an accurate 
description of this process.

The heating caused by the induced currents is called inductive heating. Generally 
heating due to currents is also called resistive heating or ohmic heating.

Model Definition

The system to be solved is given by

where ρ is the density, Cp is the specific heat capacity, k is the thermal conductivity, and 
Q is the inductive heating.

The electric conductivity of copper, σ, is given by the expression

where ρ0 is the resistivity at the reference temperature T0 = 293 K, α is the 
temperature coefficient of the resistivity, and T is the actual temperature in the domain. 

The time average of the inductive heating over one period, is given by

jωσ T( )A ∇ µ 1– ∇ A×( )×+ 0=

ρCp t∂
∂T ∇ k T∇⋅– Q T A,( )=

σ 1
ρ0 1 α T T0–( )+( )[ ]

---------------------------------------------------=

Q 1
2
---σ E 2

=
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Results and Discussion

The temperature after 1200 s is shown in Figure 2-5 below. The average temperature 
of the copper cylinder has increased from 293 K to 300 K during this time. The 
current in the coil has an amplitude of 1 kA.

Figure 2-5: Temperature distribution in the copper cylinder and its surroundings after 
1200 s.

Model Library path: ACDC_Module/Tutorial_Models/inductive_heating

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select the Axial symmetry (2D) in the Space dimension list.

2 Select the AC/DC Module>Electro-Thermal Interaction>Azimuthal Induction 

Heating>Transient analysis multiphysics mode.

3 Click OK.
I N D U C T I V E  H E A T I N G  O F  A  C O P P E R  C Y L I N D E R  |  17
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O P T I O N S  A N D  S E T T I N G S

1 From the Options menu choose Axes/Grid Settings.

2 Specify axis and grid settings according to the following table.

3 From the Options menu choose Constants.

4 In the Constants dialog box enter the following variable names, expressions, and 
(optionally) descriptions:

G E O M E T R Y  M O D E L I N G

1 Draw a circle C1 with radius 0.01 centered at (0.05, 0).

2 Draw a rectangle R1 with opposite corners at (0, −0.25) and (0.2, 0.25).

3 Draw a rectangle R2 with opposite corners at (0, −0.05) and (0.03, 0.05).

4 Click the Zoom Extents button on the Main toolbar.

AXIS VALUE GRID VALUE

r min -0.05 r spacing 0.05

r max 0.5 Extra r 0.03

z min -0.3 z spacing 0.05

z max 0.3 Extra z -0.01 0.01

NAME EXPRESSION DESCRIPTION

I0 1e3[A] Current

diam 0.02[m] Diameter

circ pi*diam Circumference

Js0 I0/circ Surface current density

T0 293[K] Reference temperature

r0 1.754e-8[ohm*m] Resistivity at T = T0

alpha 0.0039[1/K] Temperature coefficient

rho1 1.293[kg/m^3] Density of air

Cp1 1.01e3[J/(kg*K)] Heat capacity of air

k1 0.026[W/(m*K)] Thermal conductivity of air

rho2 8930[kg/m^3] Density of copper

Cp2 340[J/(kg*K)] Heat capacity of copper

k2 384[W/(m*K)] Thermal conductivity of 
copper
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P H Y S I C S  S E T T I N G S

Application Scalar Variables
In the Application Scalar Variables dialog box set the frequency nu_qa to 500 Hz.

Boundary Conditions
1 Select the Azimuthal Currents application mode from the Multiphysics menu.

2 Open the Boundary Settings dialog box, and select the Interior boundaries check box.

3 Enter boundary coefficients according to the following table.

4 Select the Heat Transfer application mode from the Multiphysics menu.

5 Enter boundary coefficients according to the following table.

Subdomain Settings
1 Select the Azimuthal Currents application mode from the Multiphysics menu.

2 Enter the electric conductivity according to the following table.

3 Select the Heat Transfer application mode from the Multiphysics menu.

4 Enter the expressions according to the following table.

The variable Qav_qa is the resistive heating defined by the Azimuthal Currents 
application mode. This variable is automatically inserted as the heat source in the Heat 
Transfer application mode.

SETTINGS BOUNDARIES 1, 3, 5 BOUNDARIES 2, 7, 9 BOUNDARIES 10-13

Boundary condition Axial symmetry Magnetic insulation Surface current

Js0

SETTINGS BOUNDARIES 1, 3, 5 BOUNDARIES 2, 7, 9

Boundary condition Axial symmetry Temperature

T0 T0

SETTINGS SUBDOMAIN 1 SUBDOMAIN 2 SUBDOMAIN 3

σ 0 1/(r0*(1+ alpha*(T-T0))) 0

SETTINGS SUBDOMAIN 1 SUBDOMAIN 2 SUBDOMAIN 3

k k1 k2 k2

ρ rho1 rho2 rho2

Cp Cp1 Cp2 Cp2

Jsϕ
I N D U C T I V E  H E A T I N G  O F  A  C O P P E R  C Y L I N D E R  |  19
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Initial Conditions
On the Init tab select all domains in the Domain selection list and set the initial 
conditions to T0.

M E S H  G E N E R A T I O N

Click the Initialize Mesh button on the Main toolbar.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 In the Times edit field on the General page type linspace(0,1200,21).

3 On the Advanced page, select the Use complex functions with real input check box.

4 Click OK to close the dialog box.

5 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot should closely resemble that in Figure 2-5 on page 17, which 
visualizes the temperature distribution at the end of the simulation period.

To view the temperature distribution as a function of time, click the Animate button on 
the Plot toolbar.
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Pe rmanen t  Magn e t

Introduction

In magnetostatic problems, where no currents are present, the problem can be solved 
using a scalar magnetic potential. This model illustrates this technique for a horse 
shoe-shaped permanent magnet placed near an iron rod.

Figure 2-6: A full 3D view of the geometry. Left-right and top-down symmetry is used to 
minimize the problem size.

Model Definition

In a current free region, where

it is possible to define the scalar magnetic potential, Vm, from the relation

This is analogous to the definition of the electric potential for static electric fields.

Using the constitutive relation between the magnetic flux density and magnetic field 

∇ H× 0=

H ∇Vm–=

B µ0 H M+( )=
P E R M A N E N T  M A G N E T  |  21



22 |  C H A P T E R
together with the equation

you can derive an equation for Vm,

Results and Discussion

The force on the rod is calculated by integrating the surface stress tensor over all 
boundaries of the rod. The expression for the stress tensor reads,

where n1 is the boundary normal pointing out from the rod and T2 the stress tensor 
of air. The integration gives 148 N, which corresponds to one quarter of the rod. The 
actual force on the rod is therefore four times this value, 592 N.

Model Library path: ACDC_Module/Tutorial_Models/
rod_and_permanent_magnet

Modeling Using the Graphical User Interface

Select the 3D>AC/DC Module>Statics>Magnetostatics, No Currents mode in the Model 

Navigator.

O P T I O N S  A N D  S E T T I N G S

In the Constants dialog box enter the following names and expressions.

G E O M E T R Y  M O D E L I N G

You can use symmetries to reduce the size of the model. Only one arm of the magnet 
needs to be included in the model, and a horizontal cut can also be made. Thus, only 
one quarter of the magnet and rod will be modeled.

NAME EXPRESSION DESCRIPTION

murFe 5000 Relative permeability of iron

Mpre 750000 Magnetization of magnet (A/m)

∇ B⋅ 0=

∇ µ0∇Vm µ0M0–( )⋅– 0=

n1T2
1
2
--- H B⋅( )n1– n1 H⋅( )BT

+=
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1 Create a work plane by opening the Work-Plane Settings dialog box and clicking OK 
to obtain the default work plane in the xy-plane.

2 In the Axes/Grid Settings dialog box, clear the Auto check box on the Grid tab and set 
both the grid x spacing and y spacing to 0.2.

3 Draw a rectangle R1 with corners at (0, 0.2) and (0.4, 0.4).

4 Draw another rectangle R2 with corners at (0.4, 0.2) and (0.6, 0.4).

5 Click the Ellipse/Circle (Centered) button on the Draw toolbar. Draw a circle C1 with 
center at (0.6, 0) and radius 0.2. Use the right mouse button to make sure a circle 
is obtained rather than an ellipse.

6 Draw another circle C2 also with center at (0.6, 0) but with radius 0.4.

7 Select both circles and click the Difference button to create the object CO1.

8 Draw a rectangle R3 with corners at (0.2, 0) and (0.6, 0.4), and a rectangle R4 with 
corners at (0.2, −0.4) and (1, 0).

9 Select CO1, R3, and R4 and click the Difference button to create the object CO2.

10 Select CO2 and R2 and click the Union button. Then click the Delete Interior 

Boundaries button.

11 Open the Extrude dialog box and select both R1 and CO2. Enter the Distance 0.1 
and click OK to extrude the magnet.
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12 Create the rod by combining a cylinder and a sphere. Click the Cylinder button to 
open the Cylinder dialog box, and enter the Radius 0.1 and Height 0.4. Set the Axis 

base point to (−0.3, 0, 0) and the Axis direction vector to (0, 1, 0). Click OK to create 
the cylinder.

13 Click the Sphere button and enter the Radius 0.1. Set the Axis base point to 
(−0.3, 0.4, 0) then click OK to create the sphere.

14 Half of the rod should now be removed. This can be done by subtracting a block 
from the cylinder and sphere. Click the Block button and enter the Length 
coordinates (0.4, 0.6, 0.2). Set the Axis base point to (−0.5, −0.1, −0.2), then click 
OK to create a block.

15 Open the Create Composite Object dialog box, and type the formula 
CYL1+SPH1-BLK1 in the Set formula edit field. Clear the Keep interior boundaries 
check box and then click OK.

16 Finally add a block surrounding the magnets and rod. In the Block dialog box use 
the Length coordinates (5, 2, 2) and the Axis base point (−2, 0, 0).
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P H Y S I C S  S E T T I N G S

Boundary Conditions
Along the boundaries far away from the magnet, the magnetic field should be 
tangential to the boundary as the flow lines should form closed loops around the 
magnet. The natural boundary condition is

Thus the magnetic field is made tangential to the boundary by a Neumann condition 
on the potential.

Along the symmetry boundary below the magnet, the magnetic field should also be 
tangential, and therefore you can apply the same Neumann condition there.

On the other hand, the magnetic field should be normal to the other symmetry 
boundary at the front in the figure above in order for the magnetic flow lines to form 
closed loops around the magnet. This means that the magnetic field is symmetric with 
respect to the boundary. This can be achieved by setting the potential to zero along 
the boundary, and thus making the potential antisymmetric with respect to the 
boundary.

Enter these boundary conditions according to the following table.

Subdomain Settings
In the Subdomain Settings dialog box, enter the coefficients according to the table 
below.

M E S H  G E N E R A T I O N

1 Choose Mesh>Free Mesh Parameters.

2 From the Predefined mesh sizes list select Fine. 

SETTINGS BOUNDARIES 2, 8, 24 ALL OTHERS

Boundary condition Zero potential Magnetic insulation

SETTINGS SUBDOMAIN 1 SUBDOMAIN 2 SUBDOMAIN 3 SUBDOMAIN 4

Constitutive 
relation

 µr 1 murFe murFe

 M Mpre 0 0

Force variables rod

n µ0∇Vm µ0M0–( )⋅ n B⋅ 0= =

B µ0µrH= B µ0µrH= B µ0H µ0M+= B µ0µrH=
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3 In order to make the mesh finer in the magnet and in the rod, click the Subdomain 
tab, then set the Maximum element size for Subdomains 2, 3, and 4 to 0.025.

4 Click OK to close the dialog box.

5 Click the Initialize Mesh button on the Main toolbar.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows a slice plot of the magnetic potential.

1 In the Plot Parameters dialog box, select Slice and Arrow plot. 

2 On the Slice tab set the x levels to 0 and the y levels to 0 in the Slice positioning area. 
For the z levels select Vector with coordinates and enter 0.05. Select bone from the 
Colormap list. 

3 Click the Arrow tab, select the Magnetic flux density as Arrow data. Set the x points to 
200 and the y points to 100 in the Arrow positioning area. For the z points select 
Vector with coordinates and enter 0.051. Select Arrow from the Arrow type list.

4 Click OK to close the dialog and generate the plot.

5 Click the button Goto XY View and use the zoom tool to zoom in on the magnet and 
rod.
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Force Calculation
To calculate the force on the rod, use the surface stress tensor, which is derived in 
“Electromagnetic Forces” on page 110 in the AC/DC Module User’s Guide,

where n1 is the boundary normal pointing out from the rod and T2 the stress tensor 
of air. The electromagnetic force variable rod, which was defined on the rod in the 
Subdomain Settings dialog box, generates the variables rod_forcex_emnc, 
rod_forcey_emnc, and rod_forcez_emnc, which are the forces on the rod in the x, 
y, and z directions, respectively.

To evaluate the force in the x direction, open the Global Data Display dialog box and 
enter the expression rod_forcex_emnc. The result is about 148 N. Because the model 
only includes one quarter of the rod, the actual force is four times this value, 592 N.

n1T2
1
2
--- H B⋅( )n1– n1 H⋅( )BT

+=
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  2 :  TU T O R I A L  M O D E L S



 3
M o t o r s  a n d  D r i v e s  M o d e l s
This chapter contains examples of models in the area of electric motors and drives. 
It includes static models with force computations as well as transient models with 
motion.
 29
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L i n e a r  E l e c t r i c  Mo t o r  o f  t h e  Mov i n g  
Co i l  T y p e 1

Introduction

Linear electric motors (LEMs) are electromechanical devices that produce motion in a 
straight line, without the use of any mechanism to convert rotary motion to linear 
motion. The benefits over conventional rotary-to-linear counterparts are the absence 
of mechanical gears and transmission systems, which results in a higher dynamic 
performance and improved reliability. The acceleration available from these motors is 
remarkable compared to traditional motor drives that convert rotary to linear motion.

A LEM is similar to a rotary motor whose stator and rotor have been cut along a radial 
plane and unrolled so that it provides linear thrust. The same electromagnetic force 
that produces torque in a rotary motor produces a direct linear force in a linear motor. 

The force that develops in the motor depends on the magnetic field and the current in 
the coils and of course on the shape of the different parts. A parameter of interest is 
the maximum force in standstill operation, that is, when the magnetic field is constant 
and the force depends only on the current density distribution. The current density in 
the coils is limited by the maximum temperature allowed in the coils. For a certain 
motor topology you can estimate the maximum electromagnetic force in standstill by 
first performing a heat transfer simulation to get the maximum current density, and 
then using this value in the magnetostatic problem where the forces are computed.

Model Definition

A LEM of moving coil type consists of a stationary primary and a moving secondary. 
The stationary primary is a permanent magnet assembly consisting of a double magnet 
array with altering polarities bounded inside a U-shaped iron former. The moving 
secondary is centered within the U-shaped magnet assembly, and consists of 3-phase 
core coils mounted on a T-shaped aluminum armature. The cross-sectional view of a 
moving coil is shown in the following figure.

1. Model provided by Hans Johansson and Mikael Hansson, The Royal Institute of Technology, Stockholm.
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The permanent magnets in the primary have a residual induction Br of 1.23 T, giving 
the magnetization 

The current in the coil is obtained via a heat transfer simulation. If a temperature of 
65 °C is allowed in the coil and the surrounding temperature is 25 °C, the simulation 
in the heat transfer mode gives a maximum heat source Q of 230,000 W/m3.

The heat source is equivalent to the resistive losses in the copper, which are given by 
the expression

where ρCu is the resistivity of copper, which is 1.72·10−8 Ωm. This gives the maximum 
current density Jz of 3.66 A/mm2.

E Q U A T I O N

COMSOL Multiphysics solves the problem using a magnetostatic equation for the 
magnetic potential A. This is a 2D model, so it is possible to formulate an equation for 
the z component of the potential,

where µ0 is the permeability of vacuum, µr the relative permeability, Br the remanent 
flux density, and  is the current density.

Results and Discussion

The force on the coils can be calculated either using the method of virtual 
displacement making a small perturbation and calculating the change in magnetic 
energy

M Br µ0⁄ 0.98 106A/m⋅= =

Q J E⋅ 1
ρCu
---------- Jz

2⋅= =

∇ µ0
1– µr

1– Az∇
µ0

1– µr
1– Br– y

µ0
1– µr

1– Brx

–

⎝ ⎠
⎜ ⎟
⎜ ⎟
⎜ ⎟
⎛ ⎞

⋅– Jz
e

=

Jz
e
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or using the Lorentz force expression

The resulting force in the x direction is Fx = 276 N/m. The air gap shear stress τ is the 
force developed per unit air gap area and gives an indication of the specific force 
capability. F/(l·A) is the force per moving volume. This can be compared with the 
force per moving mass, which indicates the acceleration capabilities. The air gap length 
is 40 mm and the air gap area is 190 mm2.

Model Library path: ACDC_Module/Motors_and_Drives/coil_LEM

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select 2D in the Space dimension list.

2 Select the AC/DC Module>Statics>Magnetostatics>Perpendicular Induction Currents, 

Vector Potential application mode.

3 Select Lagrange - Linear as element type in the Element list.

4 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 Set axis and grid settings according to the following table:

QUANTITY RESULT

 F/l 276 N/m

 τ 0.69 N/cm2

 F/(l·A) 1.45 N/cm3

AXIS GRID

x min -0.06 x spacing 0.002

x max 0.06 Extra x

Wm
B H⋅

2
--------------=

F J B×=
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2 In the Constants dialog box, enter the following variable names, expressions, and 
descriptions (the descriptions are optional):

G E O M E T R Y  M O D E L I N G

1 Draw a rectangle R1 with opposite corners at (−0.05, 0) and (0.05, 0.0105).

2 Draw a rectangle R2 with opposite corners at (−0.05, 0.0075) and (0.05, 0.0105).

3 Draw a rectangle R3 with opposite corners at (−0.058, 0.0035) and 
(−0.042, 0.0075).

4 Select R3 and click the Array button. Set the Displacement in the x direction to 0.02 
and the Array size in the x direction to 6.

5 Draw a rectangle R9 with opposite corners at (−0.018, 0) and (0.022, 0.0025).

6 Copy R9 into two new rectangles, pasting them at the same location.

7 Select R11 and click the Scale button on the draw toolbar. If it is difficult to select 
R11, a useful trick is to click the Create Composite Object button in the vertical 
toolbar, select the desired object in the Object selection list and click Cancel. Set the 
Scale factor in the x direction to 2/3 and the Scale factor in the y direction to 1 and 
change the Scale base point to (0.002, 0).

y min -0.01 y spacing 0.01

y max 0.03 Extra y 0.0025 0.0035 0.0075 0.0105

NAME EXPRESSION DESCRIPTION

sigCu 5.99e7[S/m] Conductivity of copper

sigFe 1.03e7[S/m] Conductivity of iron

muFe 2e3 Relative permeability of iron

Br 1.23[T] Remanent flux density of the magnets

Jin 3.66e6[A/m^2] Current density

AXIS GRID
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8 Select R10 and click the Scale button on the Draw toolbar. Set the Scale factor in the 
x direction to 1/3 and the Scale factor in the y direction to 1 and change the Scale 
base point to (0.002, 0).

9 Press Ctrl+A to select all objects and then open the Create Composite Object dialog 
box. Enter the expression (R1+...R11)*R1 in the Set formula edit field.

10 Draw a line L1 from (0.002, 0) to (0.002, 0.0025).

P H Y S I C S  S E T T I N G S

Boundary Conditions
Specify boundary conditions according to the following table.

Subdomain Settings
Specify the subdomain properties according to the following table.

SETTINGS BOUNDARIES 2, 16, 22, 25, 30, 
36, 39, 44

ALL OTHERS

Boundary condition Electric insulation Magnetic insulation

SETTINGS SUBDOMAIN 1 SUBDOMAIN 3 SUBDOMAINS 2, 6, 13 SUBDOMAINS 4, 10, 14

  B ↔ H  B = µ0µr H  B = µ0µr H  B = µ0µr H + Br  B = µ0µr H + Br

 σ 0 sigFe sigFe sigFe
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M E S H  G E N E R A T I O N

Click the Initialize Mesh button on the Main toolbar.

C O M P U T I N G  T H E  S O L U T I O N

1 Select the Adaptive mesh refinement check box in the Solver Parameters dialog box.

2 Click the Solve button on the Main toolbar to start the simulation.

µr 1 muFe 1 1

Br 0 0 0 0 0 Br 0 -Br

Je 0 0 0 0

SETTINGS SUBDOMAINS 5, 7 SUBDOMAINS 9, 11 SUBDOMAINS 8, 12

  B ↔ H  B = µ0µr H  B = µ0µr H  B = µ0µr H

 σ sigCu sigCu sigCu

 µr 1 1 1

 Br 0 0 0 0 0 0

 Je Jin -Jin 0

SETTINGS SUBDOMAIN 1 SUBDOMAIN 3 SUBDOMAINS 2, 6, 13 SUBDOMAINS 4, 10, 14
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PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 In the Plot Parameters dialog box, select Contour plot and select the magnetic 
potential as Contour data. On the Contour page set the Colormap to cool.

From the results obtained with the simulation you can compute the force on the coils 
with cemforce from the command line. This requires that you run COMSOL 
Multiphysics together with COMSOL Script or MATLAB.

1 From the File menu select Export>FEM Structure as 'fem'.

2 Give the following command at the prompt:

F = cemforce(fem,'Wm_emqa','dl',[5 7 8 9 11 12])

This gives the result

F =
 -140.5877
 3.8e+003

Note that only the force in the x direction makes sense in this case. The reason is 
that when moving the coils in the y direction, the total area of the simulation 
structure changes, which causes the energy balance to break down.

3 In this case you can also obtain the forces using the Lorentz expression
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Compute the total integrated force in the x direction with the command

Fx=postint(fem,'-Jez_emqa*By_emqa','dl',[5 7 8 9 11 12])

This gives the result

Fx =

 -137.7809

Because the model only includes half of the linear motor, you must multiply the 
results by a factor of 2 to obtain the total force density.

Modeling Using the Programming Language

% Clear the FEM and application structures.
clear fem appl

% Define the FEM structure constants.
fem.const = {...
  'sigCu',5.99e7,...
  'sigFe',1.03e7,...
  'muFe',2e3,...
  'Br0',1.23,...
  'Jin',3.66e6};

% Create the geometry by first setting all solid objects in a cell
% array and then calling geomcsg.
ss = cell(6,1);
ss{1} = rect2(-0.05,0.05,0,0.0105);
ss{2} = rect2(-0.05,0.05,0.0075,0.0105);
dx = 0;
for i1 = 3:8
  ss{i1} = rect2(-0.058+dx,-0.042+dx,0.0035,0.0075);
  dx = dx+0.02;
end
ss{9} = rect2(-0.018,0.022,0,0.0025);
ss{10} = scale(ss{9},2/3,1,0.002,0);
ss{11} = scale(ss{9},1/3,1,0.002,0);
cc{1} = curve2([0.002 0.002],[0 0.0025]);
g1 = solid2(geomcsg(ss,cc));
fem.geom = solid2(g1*ss{1});
fem.sdim = {'x' 'y'};

% Create the application structure.
appl.mode = 'PerpendicularCurrents';
appl.bnd.type = {'A0' 'tH0'};

F J B× Jin– By ,⋅ Jin Bx 0,⋅ .= =
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appl.bnd.ind = ones(1,55);
appl.bnd.ind([2 16 22 25 30 36 39 44]) = 2;
appl.equ.sigma = {'0' 'sigFe' 'sigFe' 'sigFe'...
  'sigCu' 'sigCu' 'sigCu'};
appl.equ.mur = {'1' 'muFe' '1' '1'...
  '1' '1' '1'};
appl.equ.Br = {{'0' '0'} {'0' '0'} {'0' 'Br0'}...
 {'0' '-Br0'} {'0' '0'} {'0' '0'} {'0' '0'}};
appl.equ.magconstrel = {'mur' 'mur' 'Br' 'Br' 'mur' 'mur' 'mur'};
appl.equ.Jez={'0' '0' '0' '0'...
  'Jin' '-Jin' '0'};
appl.equ.ind = [1 3 2 4 5 3 5 7 6 4 6 7 3 4];
appl.prop.elemdefault = 'lag1';

% Generate the PDE coefficients and boundary conditions for the
% FEM structure.
fem.appl = appl;
fem = multiphysics(fem);

% Generate the mesh.
fem.mesh = meshinit(fem);
fem.xmesh = meshextend(fem);

% Solve the problem using the adaptive solver with two
% refinements.
fem = adaption(fem,'ngen',3,'report','on');

% Visualize the solution.
postplot(fem,'contdata','Az','contmap','cool','geom','on')

% You can compute the forces in the same way as for the GUI-based 
% analysis.
F = cemforce(fem,'Wm','dl',[5 7 8 9 11 12])
Fx = postint(fem,'-Jez*By','dl',[5 7 8 9 11 12])
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Gene r a t o r  i n  2D

Introduction

This example shows how the circular motion of a rotor with permanent magnets 
generates an induced EMF in a stator winding. The generated voltage is calculated as 
a function of time during the rotation. The model also shows the influence on the 
voltage from material parameters, rotation velocity, and number of turns in the 
winding.

The center of the rotor consists of annealed medium carbon steel, which is a material 
with a high relative permeability. The center is surrounded with several blocks of a 
permanent magnet made of samarium and cobalt, creating a strong magnetic field. The 
stator is made of the same permeable material as the center of the rotor, confining the 
field in closed loops through the winding. The winding is wound around the stator 
poles. Figure 3-1 shows the generator with part of the stator sliced in order to show 
the winding and the rotor.

Figure 3-1: Drawing of a generator showing how the rotor, stator, and stator winding are 
constructed. The winding is also connected between the loops, interacting to give the highest 
possible voltage.

Modeling in COMSOL Multiphysics

The COMSOL Multiphysics model of the generator is a time-dependent 2D problem 
on a cross section through the generator. This is a true time-dependent model where 
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the motion of the magnetic sources in the rotor is accounted for in the boundary 
condition between the stator and rotor geometries. Thus, there is no Lorentz term in 
the equation, resulting in the PDE

where the magnetic vector potential only has a  z component.

Rotation is modeled using a deformed mesh application mode (ALE), in which the 
center part of the geometry, containing the rotor and part of the air-gap, rotates with 
a rotation transformation relative to the coordinate system of the stator. The rotation 
of the deformed mesh is defined by the transformation

The rotor and the stator are drawn as two separate geometry objects, so it is possible 
to use an assembly (see “Using Assemblies” on page 351 of the COMSOL 
Multiphysics Modeling Guide for further details). This has several advantages: the 
coupling between the rotor and the stator is done automatically, the parts are meshed 
independently, and it allows for a discontinuity in the vector potential at the interface 
between the two geometry objects (called slits). The rotor problem is solved in a 
rotating coordinate system where the rotor is fixed (the rotor frame), whereas the 
stator problem is solved in a coordinate system that is fixed with respect to the stator 
(the stator frame). An identity pair connecting the rotating rotor frame with the fixed 
stator frame is created between the rotor and the stator. The identity pair enforces 
continuity for the vector potential in the global fixed coordinate system (the stator 
frame).

The material in the stator and the center part of the rotor has a nonlinear relation 
between the magnetic flux, B and the magnetic field, H, the so called B-H curve. In 
COMSOL Multiphysics, the B-H curve is introduced as an interpolation function; see 
Figure 3-2. The function can be used in the subdomain settings. Usually B-H curves 
are specified as | B | versus | H |, but the perpendicular waves application mode must have 
| H | versus | B |. It is therefore important that the H-data is entered as f(x)-data of the 
interpolation function and the B-data entered as x-data. This relationship for | H | is 

σ A∂
t∂

------- ∇ 1
µ
---∇ A×⎝ ⎠

⎛ ⎞×+ 0=

xrot

yrot

ωt( )cos ωt( )sin–

ωt( )sin ωt( )cos

xstat

ystat

⋅=
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predefined for the material Soft Iron (without losses) in the materials library that is 
shipped with the AC/DC Module, acdc_lib.txt.

Figure 3-2: The norm of the magnetic flux, |B|, versus the norm of the magnetic field, |H|, 
for the rotor and stator materials. The inverse of this curve is used in the calculation.

The generated voltage is computed as the line integral of the electric field, E, along 
the winding. Because the winding sections are not connected in the 2D geometry, a 
proper line integral cannot be carried out. A simple approximation is to neglect the 
voltage contributions from the ends of the rotor, where the winding sections connect. 
The voltage is then obtained by taking the average z component of the E field for each 
winding cross-section, multiplying it by the axial length of the rotor, and taking the 
sum over all winding cross sections.

where L is the length of the generator in the third dimension, NN is the number of 
turns in the winding, and A is the total area of the winding cross-section.

Vi NN L
A
---- Ez Ad∫

windings
∑=
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Results and Discussion

The generated voltage in the rotor winding is a sinusoidal signal. At a rotation speed 
of 60 rpm the voltage will have an amplitude around 2.3 V for a single turn winding; 
see Figure 3-3.

Figure 3-3: The generated voltage over one quarter of a revolution. This simulation used 
a single-turn winding.
 3 :  M O T O R S  A N D  D R I V E S  M O D E L S



The norm of the magnetic flux, |B|, and the field lines of the B field are shown below 
in Figure 3-4 at time 0.20 s.

Figure 3-4: The norm and the field lines of the magnetic flux after 0.2 s of rotation. Note 
the brighter regions, which indicate the position of the permanent magnets in the rotor.

Model Library path: ACDC_Module/Motors_and_Drives/generator_2d

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 In the Model Navigator, make sure that 2D is selected in the Space dimension list.

2 In the AC/DC Module folder select Rotating Machinery>Rotating Perpendicular Currents.

3 Click OK to close the Model Navigator.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu choose Constants.
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2 In the Constants dialog box define the following constants with names and 
expressions.The description field is optional. When done, click OK.

When you enter the constant t in the table, the text turns red. The reason is that t 
is the reserved variable name for time in COMSOL Multiphysics. However, because 
of the solution procedure in this model—you first compute a stationary solution 
which you then use as the initial condition for a subsequent time-dependent 
simulation—t needs to be given a value (zero) also for the stationary case. It will 
subsequently be overridden by the t values from the transient solver.

G E O M E T R Y  M O D E L I N G

The geometry modeling of this model is rather extensive, so you can choose to import 
the generator geometry from a binary file. Select the section that you prefer.

Importing the Geometry from a Binary File
1 From the File menu, select Import>CAD Data From File.

2 In the Import CAD Data From File dialog box, make sure that either All 2D CAD files or 
COMSOL Multiphysics file is selected in the Files of type list.

3 From the COMSOL Multiphysics installation directory, go to the model library 
path given on page 43. Select the generator_2d.mphbin file, and click Import.

4 Skip the section “Creating the Geometry from Scratch” and continue at “Assemble 
the Geometry” on page 47.

Creating the Geometry from Scratch
Please follow the steps in the geometry modeling carefully. In the following sections, 
it is assumed that the boundary numbering is that resulting from these steps. After all 
geometry operations and the assembly step, there should be a total of 152 boundaries.

1 Choose Draw>Specify Objects>Circle to create circles with the following properties:

NAME EXPRESSION DESCRIPTION

t 0[s] Time for stationary solution

rpm 60[1/min] Revolutions per minute

A pi*(0.02[m])^2 Area of wires in the stator

L 0.4[m] Length of the generator

NN 1 Number of turns in stator winding

NAME RADIUS BASE X Y ROTATION ANGLE

C1 0.3 Center 0 0 22.5

C2 0.235 Center 0 0 0
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2 Choose Draw>Specify Objects>Rectangle to create rectangles with the following 
properties:

3 Open the Create Composite Object dialog box from the Draw menu or click on the 
toolbar button with the same name.

4 In the dialog box clear the Keep interior boundaries check box.

5 Type C2+C1*(R1+R2+R3+R4) in the Set formula edit field.

6 Click OK.

7 Open the Create Composite Object dialog box again and select the Keep interior 

boundaries check box.

8 Type C4+CO1-C3 in the Set formula edit field.

9 Click OK.

10 Create two new circles according to the table below.

11 Click the Zoom Extents button to get a better view of the geometry.

12 Select the circles C1 and C2.

13 Press Ctrl+C to copy the circles.

14 Press Ctrl+V to paste the circles. Make sure that the displacements are zero and click 
OK.

15 Go to Draw>Modify>Rotate and type 45 in the Rotation angle edit field before 
clicking OK.

C3 0.225 Center 0 0 0

C4 0.4 Center 0 0 0

NAME WIDTH HEIGHT BASE X Y ROTATION ANGLE

R1 0.1 1 Center 0 0 0

R2 0.1 1 Center 0 0 45

R3 0.1 1 Center 0 0 90

R4 0.1 1 Center 0 0 135

NAME RADIUS BASE X Y ROTATION ANGLE

C1 0.015 Center 0.025 0.275 0

C2 0.015 Center -0.025 0.275 0

NAME RADIUS BASE X Y ROTATION ANGLE
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16 Repeat the last two steps but with rotation angles 90, 135, 180, −45, −90, and 
−135.

17 Select all objects by pressing Ctrl+A, then click the Union toolbar button.

18 Create four circles with the following properties:

19 Create four rectangles with the following properties:

20 Open the Create Composite Object dialog box and clear the Keep interior boundaries 
check box.

21 Type C2+C1*(R1+R2+R3+R4) in the Set formula edit field.

22 Click OK.

23 Open the Create Composite Object dialog box again and select the Keep interior 

boundaries check box.

24 Type CO2+C3+C4 in the Set formula edit field.

25 Click OK.

NAME RADIUS BASE X Y ROTATION ANGLE

C1 0.215 Center 0 0 0

C2 0.15 Center 0 0 22.5

C3 0.15 Center 0 0 22.5

C4 0.225 Center 0 0 0

NAME WIDTH HEIGHT BASE X Y ROTATION ANGLE

R1 0.1 1 Center 0 0 22.5

R2 0.1 1 Center 0 0 -22.5

R3 0.1 1 Center 0 0 67.5

R4 0.1 1 Center 0 0 -67.5
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The geometry in the drawing area should now look like that in Figure 3-5.

Figure 3-5: Generator geometry.

Assemble the Geometry
1 Open the Create Pairs dialog box from the Draw menu.

2 Select both objects (CO1 and CO3), and click OK.

You have now created two separate geometry objects in an assembly. You have also 
created an identity pair connecting the physics in the rotor and the stator, taking the 
rotation into account. An interface between two assemblies is actually two groups of 
overlapping boundaries that are, without the pair connection, completely separated in 
terms of mesh and solution variables. This is necessary to allow a sliding mesh at the 
interface between the stator and rotor where the solution variable becomes 
discontinuous across that interface.

P H Y S I C S  S E T T I N G S

1 From the Options menu point to Integration Coupling Variables and click Subdomain 

Variables.
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2 In the Subdomain Integration Variables dialog box define a variable with integration 
order 4 and global destination according to the table below.

3 Click OK.

Steps 4–6 below are only necessary to check that the library you need is loaded and 
to view the interpolation function of one of the materials in this library. These steps 
can be skipped if you know that you have the library loaded. If you later notice that 
you are missing this library, just go back to these steps and add the library.

4 Open the Options menu and select Materials/Coefficients Library.

5 Make sure that the library acdc_lib.txt is loaded (click the minus in front of other 
libraries to remove their content from the view). If you cannot find the library, load 
the library by clicking the Add Library button. The file should be located under the 
data folder in the COMSOL installation directory.

6 Click OK to close the Materials/Coefficients Library dialog box.

Subdomain Settings
1 From the Multiphysics menu, select Perpendicular Induction Currents, Vector Potential 

(emqa) if it is not already selected.

2 Choose Physics>Properties.

3 In the Application Mode Properties dialog box, choose On from the Weak constraints 
list. The ideal weak constraints help conserving the magnetic flux across the 
assembly boundaries between the rotor and the stator. This allows you to specify an 
absolute tolerance for this entity when solving the time-dependent model.

4 Click OK.

5 From the Physics menu open the Subdomain Settings, then select any entry in the 
Subdomain selection list.

6 Click the Load button to open the Materials/Coefficients Library dialog box.

7 In the dialog box select the Soft Iron (without losses) material from the 
Electric (AC/DC Material Properties library.

8 Click Apply. The material Soft Iron (without losses) has now been added to the model. 
You see which materials you have added to the model under the Model item in the 
Materials tree view.

NAME EXPRESSION IN SUBDOMAINS 5–8, 13–16 EXPRESSION IN SUBDOMAINS 3, 4, 9–12, 17, 18

Vi -L*Ez_emqa/A L*Ez_emqa/A
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9 Repeat the last two steps for the materials Samarium Cobalt (Radial, inward) and 
Samarium Cobalt (Radial, outward). Before you close the dialog box, make sure that 
you see all three materials under Model in the Materials tree view.

10 Click Cancel to close the Materials/Coefficients Library dialog box.

11 Enter subdomain settings and select materials according to the table below. To 
change the constitutive relation, you need to choose the relation from the 
Constitutive relation list.

12 Click OK.

13 From the Multiphysics menu select Moving Mesh (ALE) (ale).

14 From the Physics menu open the Subdomain Settings.

15 Select Subdomains 19–28, then select the predefined group rotate_CCW from the 
Group list.

This group uses a prescribed displacement with expressions that define 
counterclockwise rotation around the origin. The default setting for all other 
subdomains is no displacement.

16 Click OK to close the dialog box.

Boundary Conditions
Leave the boundary settings at their defaults. The identity pair creates a coupling 
between the rotor and the stator in the ALE frame.

SETTINGS SUBDOMAINS 
20, 23, 24, 27

SUBDOMAINS 
21, 22, 25, 26

SUBDOMAINS 2, 28 ALL OTHER 
SUBDOMAINS

 B ↔ H B = µ0µrH + Br B = µ0µrH + Br H = f(|B|)eB B = µ0µrH

Library 
material

Samarium Cobalt 
(Radial, inward)

Samarium Cobalt 
(Radial, outward)

Soft Iron 
(without losses)
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M E S H  G E N E R A T I O N

1 Open the Free Mesh Parameters dialog box from the Mesh menu.

2 From the Predefined mesh sizes list select Finer.

3 Click the Custom mesh size option button and type 2 in the Resolution of narrow 

regions edit field.

4 Click Remesh to generate the mesh.

5 Click OK to close the dialog box.

C O M P U T I N G  T H E  S O L U T I O N

Begin by computing the initial solution for the subsequent time-dependent 
simulation.

1 Open the Solver Parameters dialog box by clicking the corresponding button on the 
Main toolbar or from the Solve menu. 

2 With the Auto select solver check box selected, select Static from the Analysis list.

3 Click OK.

4 Click the Solve button.

Next, simulate the generator with the rotor in motion. By default, the solution you just 
calculated will be used as the initial solution.

1 Open the Solver Parameters dialog box again and select Transient from the Analysis 

list.
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2 In the Times edit field type linspace(0,0.25,26), and in the Absolute tolerance 
edit field type Az 1e-3 lm1 5e3.

3 Click OK.

4 Click the Restart button.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 From the Postprocessing menu open the Plot Parameters dialog box.

2 On the General page select the solution for time 0.2 s from the Solution at time list. 
Clear the Geometry edges check box.

3 On the Surface page select Magnetic flux density, norm from the Predefined quantities 
list or type normB_emqa in the Expression edit field.

4 On the Contour page type Az in the Expression edit field and type 15 in the Levels 
edit field. Click to select the Contour plot check box.

5 In the Contour color area click the Uniform color option button, and clear the Color 

scale check box.

6 Click the Color button and select a black color. Click OK to close the Contour Color 
dialog box.

7 On the Boundary page type 1 in the Expression edit field. Click to select the Boundary 

plot check box.

8 In the Boundary color area click the Uniform color option button.
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9 Click the Color button and select a black color. Click OK to close the Boundary Color 
dialog box.

10 Click OK to close the Plot Parameters dialog box.

To view the induced voltage as a function of time, proceed with the steps below.

1 From the Postprocessing menu, select Domain Plot Parameters.

2 On the Point page select an arbitrary point in the Point selection list, then type Vi*NN 
in the Expression edit field.

3 Click OK.

To create an animation of the rotating rotor, do the following steps.

1 Open the Plot Parameters dialog box.

2 Click the Animate tab and make sure that all time steps are selected.

3 Click the Start Animation button. When the movie has been generated, the 
COMSOL Movie Player opens it.
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Gene r a t o r  w i t h  Me chan i c a l  D ynam i c s  
and S ymme t r y

Introduction

This is an extension of the generator model including an ordinary differential equation 
for the mechanical dynamics and computation of the torque resulting from the 
magnetic forces. In addition it exploits symmetry to reduce the model size to 1/8 of 
the original size. The model also involves a lumped winding resistance.

Modeling in COMSOL Multiphysics

The reader is supposed to be familiar with the generator model in the preceding 
section. Here the focus is on concepts that the previous model does not cover. The 
smallest possible model of the generator is a sector obtained by cutting radially 
through two adjacent rotor poles, see Figure 3-6.

Figure 3-6: The smallest possible sector model.
G E N E R A T O R  W I T H  M E C H A N I C A L  D Y N A M I C S  A N D  S Y M M E T R Y  |  53



54 |  C H A P T E R
Because adjacent rotor poles are magnetized radially but in opposite directions, such a 
sector model exhibits antisymmetry. This is readily accounted for in COMSOL 
Multiphysics by the support for periodic boundary conditions. In addition, the sliding 
mesh coupling must be modified to keep the coupling coordinates within the modeled 
geometry sector. There is a special sliding mesh condition for such symmetry or 
antisymmetry connections that defines one coupling operator for each sector in the 
model. In this case there are 8 such coupling operators. The first operator just 
performs a direct coupling between the rotor and stator. After a little less than half 
revolution for example, the third and fourth operator perform the coupling. This 
special sector symmetry condition requires that you use assemblies with the Moving 
Mesh application mode, similar to how it is done in the preceding generator model. 
The main difference with that model, is that you will use the fact that the magnetic 
fields do not change between the reference and moving frame, and that the mesh in 
the moving domains are not deformed, only rotated. As a consequence, you can turn 
off the moving mesh transformations for the electromagnetic application mode and 
use them only for the coupling operators. You save a significant amount of execution 
time by not performing the mesh transformations, and the result is the same.

The ODE for the mechanical dynamics

involves the torque Tz + M and the moment of inertia I0 + Irotor. M is the externally 
applied driving torque and Tz is the electromagnetic torque. The model computes the 
latter automatically by boundary integration of the cross product between the radius 
vector (x, y) and the normal Maxwell stress components (nTx, nTy) over the rotor 
boundary. Because the model depth is not unity, the torque variable must be multiplied 
with the variable L, and a factor 8 to account for the entire device.

The moment of inertia is composed of an external moment of inertia, I0 (flywheel and 
turbine), and the moment of inertia of the rotor itself, Irotor. The model computes the 
latter by subdomain integration of the material density ρ times radius vector squared 
times the model depth L. Again, the factor 8 accounts for the entire generator.

t2

2

d

d α Tz M+

I0 Irotor+
--------------------------=

Tz 8LTz
auto( )

=

Irotor 8ρL x2 y2
+( ) Ad

A
∫∫=
 3 :  M O T O R S  A N D  D R I V E S  M O D E L S



The model accounts for the lumped winding resistance by setting the winding current 
to the induced voltage divided by the winding resistance. This corresponds to a 
generator operating with the output terminals in short circuit. The model computes 
the induced voltage using a subdomain integration coupling variable.

Results and Discussion

The startup of the generator was simulated for 2 s which is sufficient for reaching 
steady state. The time evolution of the rotation angle is shown in Figure 3-7.

Figure 3-7: The time evolution of the rotation angle is shown. After about 1 s, the rotation 
angle increases linearly with time corresponding to constant rotation speed.

Model Library path: ACDC_Module/Motors_and_Drives/
generator_sector_dynamic
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Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 In the Model Navigator, make sure that 2D is selected in the Space dimension list.

2 In the AC/DC Module folder select Rotating Machinery>Rotating Perpendicular Currents.

3 In the Dependent variables edit field, enter Az X Y Z.

4 Click OK to close the Model Navigator.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu choose Constants.

2 In the Constants dialog box define the following constants with names and 
expressions. When done, click OK.

G E O M E T R Y  M O D E L I N G

1 From the File menu, select Import>CAD Data From File.

2 In the Import CAD Data From File dialog box, make sure that All 2D CAD files or 
COMSOL Multiphysics file is selected in the Files of type drop-down menu.

3 From the COMSOL Multiphysics installation directory, browse to the folder given 
on page 55. Select the file generator_2d.mphbin, then click Import.

4 Choose Draw>Specify Objects>Line and select Closed polyline (solid) in the Style list. 
Enter Coordinates x: 0 0.4*cos(67.5*pi/180) 0.4 0.4*cos(22.5*pi/180) 0 
and Coordinates y: 0 0.4*sin(67.5*pi/180) 0.4 0.4*sin(22.5*pi/180) 0.

5 Click OK to create the composite object CO3.

6 Press Ctrl+C to copy the created object.

7 Select the objects (CO1 and CO3), then click the Intersection button on the Draw 
toolbar to create the geometry object, CO4.

NAME EXPRESSION DESCRIPTION

A pi*(0.02[m])^2 Area of wires in the stator

L 0.4[m] Length of the generator

NN 1 Number of turns in stator winding

M 1400[N*m] Externally applied torque

Rc 1e-4[ohm] Resistance of winding

I0 100[kg*m^2] External moment of inertia
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8 Press Ctrl+V to paste the polyline object, just click OK in the dialog box that appears. 
Then select the pasted object and the second imported object (CO1 and CO2).

9 Click the Intersection button on the Draw toolbar.

10 Click the Zoom Extents button on the Main toolbar. You now have a 1/8 sector of 
the original generator model geometry, with one object for the rotor and one for 
the stator.

11 Select both remaining objects and click the Create Pairs button on the Draw toolbar.

12 From the Physics menu, choose Identity Pairs>Identity Boundary Pairs.

13 Select Pair 1 and click the Interchange source and destination button between the 
Source boundaries and Destination boundaries fields.

14 Click OK. It is important that the source side of the assembly pair is on the fixed side, 
and that the destination side is on the moving side. Otherwise the solver does not 
detect the motion.

P H Y S I C S  S E T T I N G S

Global Expressions
1 From the Options menu, point to Expressions and click Global Expressions.

2 In the Global Expressions dialog box, define the following expression:

3 Click OK. The unit specification in the expression is there to keep the correct unit of 
the torque.

Subdomain Expressions
1 From the Options menu, point to Expressions and click Subdomain Expressions.

2 In the Subdomain Expressions dialog box, define the following expressions:

3 Add another variable rho for the material density and set it to 7870[kg/m^3] in 
Subdomain 1 and to 8400[kg/m^3] in Subdomains 2 and 4.

4 Click OK.

NAME EXPRESSION DESCRIPTION

Tz 8*L[1/m]*F_torquez_emqa Total torque for the entire device

NAME EXPRESSION IN SUBDOMAINS 1–4 EXPRESSION IN ALL OTHER SUBDOMAINS

u -y*alphat 0

v x*alphat 0
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Integration Coupling Variables
1 In the Options menu, point to Integration Coupling Variables and select Subdomain 

Variables.

2 In the Subdomain Integration Variables dialog box, define variables according to the 
table below with default global destination and default integration order 4. 

3 Click OK.

Because of the use of coupling variables, COMSOL Multiphysics cannot determine the 
unit for other variables that directly or indirectly depend on these coupling variables. 
This causes the warnings for inconsistent units in the specification of the magnetic 
potential and external current density. You can disregard these warnings.

Subdomain Settings (Moving Mesh Application Mode)
1 From the Physics menu, open the Subdomain Settings dialog box.

2 Select Subdomains 1–4. From the Group list, select the predefined group called 
angle_CCW. This group uses the variable named omega as a counter-clock-wise 
rotation. You later declare this variable as an ODE variable.

3 Click OK to close the dialog box.

Application Mode Properties (Perpendicular Induction Currents)
1 From the Multiphysics menu, select Perpendicular Induction Currents, 

Vector Potential (emqa) to switch application mode.

2 From the Physics menu, choose Properties.

3 Choose On from the Weak constraints list and Frame (ref) from the Frame list.

4 Click OK.

Subdomain Settings
1 Open the Subdomain Settings dialog box from the Physics menu.

2 Select any entry from the Subdomain selection list, then click the Load button to open 
the Materials/Coefficients Library dialog box.

3 In the Materials tree, open the Electric (AC/DC) Material Properties library and select 
Soft Iron (without losses).

NAME EXPRESSION IN SUBDOMAINS 1, 2, 4 EXPRESSION IN SUBDOMAINS 7, 8

Vi 8*L*NN*Ez_emqa/A

I 8*L*rho*(x^2+y^2)
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4 Click Apply. The material Soft Iron (without losses) is added to the model. You see 
which materials you have added to the model under the Model item in the Materials 
tree view.

5 Repeat the two last steps for the materials Samarium Cobalt (Radial, inward) and 
Samarium Cobalt (Radial, outward). Before you close the dialog box, make sure that 
you see all three materials under Model in the Materials tree view.

6 Click Cancel to close the Materials/Coefficients Library dialog box.

7 Enter subdomain settings and select materials according to the table below. To 
change the constitutive relation, you need to choose the relation from the 
Constitutive relation list.

8 Select Subdomains 7 and 8, and enter NN*Vi/(Rc*A) in the External current density 
edit field.

9 Click the Forces tab. Select Subdomains 1, 2, and 4 from the Subdomain selection 

list, then set the Name field to F. This setting generates variables for the force and 
torque on the selected subdomains. The torque variable gets the name 
F_torquez_emqa.

10 Click OK.

Boundary Conditions
1 In the Boundary Settings dialog box, enter the following settings:

2 Click the Weak Constr. tab, select the Boundaries 1–4, 7, 8, 15, 16, 19–21 and 23, 
and clear the Use weak constraints check box. It is not necessary to use weak 
constraint on these boundaries, and they actually disturb the weak constraints on the 
sliding mesh boundaries if activated.

3 Click the Pairs tab and select Pair 1.

4 From the Boundary condition list, select Sector antisymmetry, then enter 8 in the 
Number of sectors edit field.

SETTINGS SUBDOMAIN 4 SUBDOMAIN 2 SUBDOMAIN 1, 6 ALL OTHERS

 B ↔ H B = µ0µrH + Br B = µ0µrH + Br H = f(|B|)eB B = µ0µrH

Library 
material

Samarium Cobalt 
(Radial, inward)

Samarium Cobalt 
(Radial, outward)

Soft Iron 
(without losses)

SETTINGS BOUNDARIES 1–4, 7, 8, 15, 16, 19, 20

Boundary condition Periodic condition

Type of periodicity Antiperiodicity
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5 Click OK.

Periodic Point Conditions
You need to make the Lagrange multiplier variable lm1, associated with the weak 
boundary constraint, antisymmetric.

1 Choose Physics>Periodic Conditions>Periodic Point Conditions.

2 On the Source page, select Point 4 from the Point selection list, then enter lm1 in the 
first row in the Expression column and press Return.

3 Click the Source Vertices tab, and click the >> button to use Point 4 as source vertex.

4 Click the Destination tab, then select Point 11.

5 Select the Use selected points as destination check box, then enter the expression 
-lm1.

6 Click the Destination Vertices tab, then click the >> button to add Point 11.

7 Click OK.

Space-Independent Equations
1 From the Physics menu, open the Space-Independent Equations dialog box and enter 

entities according to the following table. The description field is optional.

2 Click OK.

M E S H  G E N E R A T I O N

You get the best performance for periodic boundary conditions if the mesh is identical 
for the source and destination boundaries of the periodic condition. The steps below 
use the Copy mesh feature to ensure an identical mesh.

1 In the Free Mesh Parameters dialog box, select the Predefined mesh sizes option 
button, then select Finer from the list.

2 On the Boundary page, select Boundaries 2, 5–8, 10–12, 14, and 19–21 from the 
Boundary selection list and enter a Maximum element size of 0.005.

3 Click the Mesh Selected button.

4 Select Boundaries 1 and 2. The click the Copy Mesh button on the Mesh toolbar, 
which is located on the toolbar on the left side of the COMSOL Multiphysics 
window.

NAME EQUATION INIT(U) INIT(UT) DESCRIPTION

omega omegatt-(M+Tz)/(I+I0) 0 0 Rotation angle
 3 :  M O T O R S  A N D  D R I V E S  M O D E L S



5 Repeat this step for the remaining four boundary pairs: 3 and 7, 4 and 8, 15 and 19, 
and 16 and 20. The mesh on the right side and the mesh on the left side are now 
identical.

6 Click OK to close the Free Mesh Parameters dialog box. This was only open under the 
copy mesh operation in order to have a numbered list of boundaries available.

7 Finally, click the Mesh Remaining (Free) button on the Mesh toolbar, to mesh the rest 
of the geometry. The resulting mesh looks like the one in the figure below.

C O M P U T I N G  T H E  S O L U T I O N

1 In the Solver Parameters dialog box, select Stationary from the Solver area.

2 Click OK.

3 Open the Solver Manager and go to the Solve For page.

4 Clear the variable omega under ODE.

5 Click OK.

6 Click the Solve button on the Main toolbar.

7 Open the Solver Parameters dialog box again, and select Time dependent from the 
Solver list.
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8 In the Times edit field type linspace(0,2,101), and in the Absolute tolerance edit 
field type Az 1e-3 lm1 5e3 omega 0.015. This sets different tolerances for each 
variable.

9 Click OK.

10 Open the Solver Manager, click the Solve For tab, and select all variables.

11 Click OK.

12 Click the Restart button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Open the Plot Parameters dialog box. From the Solution at time list on the General 

page, select the solution for time 0.2 s.

2 On the Contour page, select Magnetic potential, z component from the Predefined 

quantities list and type 15 in the Levels edit field. Select the Contour plot check box.

3 In the Contour color area, click the Uniform color button. Click the Color button. 
Select a black color, then click OK to close the Contour Color dialog box. Clear the 
Color scale check box.

4 Click OK to close the Plot Parameters dialog box.
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You should now see the following surface plot of the norm of the magnetic flux with 
contours indicating magnetic flux field lines.

Figure 3-8: Magnetic flux norm (surface) and field lines (contours) at t = 0.2 s.

To view the rotation angle as a function of time, proceed with the steps below.

1 From the Postprocessing menu, select Global Variables Plot.

2 In the Predefined quantities area, choose Rotation angle, then click the > button.

3 Click Apply to generate Figure 3-7 on page 55.

Using the same dialog box, create plots for omegat, Tz, (M+Tz)/(I+I0), and Vi/Rc 
to plot angular velocity, electromagnetic torque, acceleration, and winding current, 
respectively, by repeating the steps given below for the angular velocity.

1 Select the item in the Quantities to plot frame and click the < button to remove it 
from the list.

2 In the Expression edit field enter omegat.

3 Click the > button to the right of the edit field.

4 Click Apply to view the plot.

To create an animation of the rotating rotor, perform the following steps:
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1 Open the Plot Parameters dialog box, click the Animate tab, and make sure that all 
time steps are selected.

2 Click the Start Animation button. When the movie has been generated, the 
COMSOL Movie Player opens it.
 3 :  M O T O R S  A N D  D R I V E S  M O D E L S



Gene r a t o r  i n  3D

Introduction

This model is a 3D version of the 2D generator model on page 39, so most of the 
details about the model are explained there. The main difference is that this is a static 
example, calculating the magnetic fields around and inside the generator.

Modeling in COMSOL Multiphysics

The model has some differences compared to the 2D generator model. The PDE is 
simplified to solve for the magnetic scalar potential, Vm, instead of the vector potential, 
A. It is based on the assumption that currents can be neglected, which holds true when 
the generator terminals are open. The equation for Vm becomes

The stator and center of the rotor are made of annealed medium-carbon steel (soft 
iron), which is a nonlinear magnetic material. This is implemented in COMSOL 
Multiphysics as an interpolation function of the B-H curve of the material. The 
difference compared to the 2D version is that the norm of the magnet flux, |B|, has to 
be calculated from the norm of the magnetic field, |H|, in this model.

Results and Discussion

Figure 3-9 shows the norm of the magnetic flux for a slice through a centered cross 
section of the generator. The plot also shows the streamlines of the magnetic flux. The 
starting points of the streamlines have been carefully selected to show the closed loops 

∇– µ Vm∇ Br–( )⋅ 0=
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between neighboring stator and rotor poles. A few streamlines are also plotted at the 
edge of the generator to illustrate the field there.

Figure 3-9: A combined slice and streamline plot of the magnetic flux density.

Model Library path: ACDC_Module/Motors_and_Drives/generator_3d

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select 3D in the Space dimension list.

2 In the AC/DC Module folder, select Statics>Magnetostatics, No Currents.

3 Click OK to close the Model Navigator.

G E O M E T R Y  M O D E L I N G

1 Go to Draw>Work-Plane Settings.

2 In the dialog box that appears, click OK.
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3 Go to Draw>Specify Objects>Circle to create circles with the following properties:

4 Go to Draw>Specify Objects>Rectangle to create rectangles with the following 
properties:

5 In the Create Composite Object dialog box, clear the Keep interior boundaries check 
box.

6 Enter the formula C2+C1*(R1+R2+R3+R4).

7 Click OK.

8 Create a circle with the following properties:

9 Draw four rectangles with the following properties:

10 In the Create Composite Object dialog box, enter the formula C1*(R1+R2+R3+R4).

11 Click OK.

12 Create a circle with the following properties:

NAME RADIUS BASE X Y ROTATION ANGLE

C1 0.3 Center 0 0 22.5

C1 0.235 Center 0 0 0

NAME WIDTH HEIGHT BASE X Y ROTATION ANGLE

R1 0.1 1 Center 0 0 0

R2 0.1 1 Center 0 0 45

R3 0.1 1 Center 0 0 90

R4 0.1 1 Center 0 0 135

NAME RADIUS BASE X Y ROTATION ANGLE

C1 0.215 Center 0 0 0

NAME WIDTH HEIGHT BASE X Y ROTATION ANGLE

R1 0.1 1 Center 0 0 22.5

R2 0.1 1 Center 0 0 -22.5

R3 0.1 1 Center 0 0 67.5

R4 0.1 1 Center 0 0 -67.5

NAME RADIUS BASE X Y ROTATION ANGLE

C1 0.15 Center 0 0 22.5
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13 In the Create Composite Object dialog box, make sure that the Keep interior 

boundaries check box is not selected.

14 Enter the formula C1+CO2.

15 Click OK.

16 Draw a circle with parameters according to the table below.

17 Click the Zoom Extents button to get a better view of the geometry.

18 Go to Draw>Extrude.

19 In the dialog box that appears, select all objects and type 0.4 in the Distance edit 
field.

20 Click OK.

21 Use the Cylinder tool to create cylinders with parameters according to the table 
below.

NAME RADIUS BASE X Y ROTATION ANGLE

C1 0.15 Center 0 0 22.5

NAME AXIS BASE POINT Z RADIUS HEIGHT

CYL1 -0.2 0.4 0.2

CYL2 0 0.4 0.4

CYL3 0.4 0.4 0.2
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22 Click the Zoom Extents button to get a better view of the geometry.

P H Y S I C S  S E T T I N G S

Constants
1 From the Options menu, select Constants.

2 In the Constants dialog box, define the following constants with names, expressions, 
and (optionally) descriptions; when done, click OK.

Scalar Expressions
1 From the Options menu, select Expressions>Scalar Expressions.

2 In the Scalar Expressions dialog box, define the following expression; when done, 
click OK.

NAME EXPRESSION DESCRIPTION

BrSmCo 0.84[T] Remanent flux in permanent magnets

murSmCo 1 Relative permeability in permanent magnets

NAME EXPRESSION DESCRIPTION

R sqrt(x^2+y^2) Radial coordinate
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Subdomain Settings
1 Enter subdomain settings for the active subdomains according to the table below. 

For Subdomains 2 and 7, choose the material from the Electric (AC/DC) Material 

Properties library in the Materials/Coefficients Library dialog box, which you open by 
clicking Load.

2 Click OK.

Boundary Conditions
In the Boundary Settings dialog box, apply the Magnetic insulation condition to all 
boundaries, then click OK.

M E S H  G E N E R A T I O N

1 In the Free Mesh Parameters dialog box, select Finer from the Predefined mesh sizes 

list. 

2 Click Remesh, then click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar to compute the solution.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Open the Plot Parameters dialog box.

2 On the General page, select the check boxes for Slice plot and Streamline plot.

3 Click the Slice tab. From the Predefined quantities list, select Magnetic flux density, 

norm.

4 Type 0 in the edit field for x levels, and type 1 in the edit field for z levels.

5 Click the Streamline tab and select Magnetic flux density in the Predefined quantities 
list.

SETTINGS SUBDOMAINS 
1, 3, 4

SUBDOMAINS 
5, 9, 10, 13

SUBDOMAINS 
6, 8, 11, 12

SUBDOMAINS 2, 7

Library 
material

Soft Iron (without 
losses)

 B ↔ H  B = µ0µrH  B = µ0µrH + Br  B = µ0µrH + Br  B = f(|H|)eH

 µr 1 murSmCo muSmCo

 Brx -BrSmCo*x/R BrSmCo*x/R

 Bry -BrSmCo*y/R BrSmCo*y/R
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6 Click the Specify start point coordinates button and enter the values according to the 
table below.

7 Select Tube in the Line type list, then click OK.

FIELD EXPRESSION

x 0 0 0 0 0 0 0

y 0.35 0.35 0.35 0.35 0.35 0.3 0.2

z linspace(0.1,0.59,7)
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Magne t i c  B r a k e  i n  3D

Introduction

A magnet brake in its simplest form consists of a disk of conductive material and a 
permanent magnet. The magnet generates a constant magnetic field, in which the disk 
is rotating. When a conductor moves in a magnetic field it induces currents, and the 
Lorentz forces from the currents slow the disk.

Model Definition

This 3D problem is solved using a stationary formulation for the electromagnetic part 
coupled to an ordinary differential equation for the rotational rigid body dynamics. It 
also illustrates the proper use of a Lorentz type induced current density term. An 
ungauged A-V formulation is used to solve the electromagnetic part in a fast and 
memory efficient way. 

For a disk rotating with angular velocity ω about the z-axis, the velocity v at a point 
(x, y) is given by

Maxwell-Ampères law, expressed using a magnetic vector potential A, a scalar electric 
potential V, and an induced current density term of Lorentz type is the fundamental 
field equation used in this model. It is complemented by a current balance but no 
explicit gauging is provided.

v ω y x 0, ,–( )=
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Such a formulation is inherently singular because the divergence of the magnetic vector 
potential is not uniquely determined and there is an infinite number of possible 
solutions to the problem. All such solutions yield the same magnetic flux and current 
densities, however. It is further known that the above formulation, when solved using 
an iterative solver, converges quickly and robustly provided that any explicitly supplied 
source current density (zero here) is divergence free and no direct coarse grid solver is 
involved in the solution scheme.

The induced Lorentz current density term is a common source of confusion in 
electromagnetic modeling. In situations when the moving domain is of bounded 
extent in the direction of the motion or varies in this direction or contains magnetic 
sources that also move, Lorentz terms cannot be used. This is because the part of the 
magnetic flux generated by moving sources must not be included in the Lorentz term. 
In this situation, the induced current distribution is stationary (it stays where the 
magnet is and does not move with the spinning disk). Thus, the moving domain does 
not contain any magnetic sources that move along with it and it is unbounded and 
invariant in the direction of the motion.

The magnetic and electric boundary conditions on external boundaries are

Now consider how the system evolves over time. The induced torque slows the disk 
down, described by an ordinary differential equation (ODE) for the angular velocity ω.

,

Where the torque Tz is obtained as the z component of the vector

and the moment of inertia I for a disk with radius r and unit thickness equals

Here m is the disk mass and ρ is the density.

∇ µ 1– ∇ A×( ) σv ∇ A×( ) σ∇V+×–× 0=

∇– σv ∇ A×( ) σ∇V+×–( )⋅ 0=

n A× 0 ,= n J⋅ 0=

ωd
dt
------- Tz

I
-------=

T r J B×( )dV×
disk
∫=

I mr2

2
----- ρr4π

2
------------= =
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Results and Discussion

The COMSOL Multiphysics model is set up for a 1 cm thick copper disk with a radius 
of 10 cm and an initial angular speed of 1000 rpm. The magnet consists of a 1 T, hard 
(µr = 1) permanent magnet connected to an iron yoke with a 1.5 cm air gap in which 
the copper disk spins. The figures below show the induced eddy current density and 
the time evolution of the angular velocity, braking torque and dissipated power 
repectively.

The eddy current magnitude and direction at t = 0 s.
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The time evolution of the angular velocity.

The time evolution of the braking torque.
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The time evolution of the dissipated power.

Model Library path: ACDC_Module/Motors_and_Drives/magnetic_brake_3d

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select 3D from the Space dimension list.

2 In the AC/DC Module folder, select Statics>Magnetostatics, Ungauged AV. This node 
contains an application mode that solves for magnetic (A) and electric (V) potentials 
using solver settings for a special ungauged technique.

3 Click OK to close the Model Navigator.

G E O M E T R Y  M O D E L I N G

1 Use the Cylinder tool to create a cylinder with Radius 0.1, Height 0.01 and Axis base 

point z: -0.005. All other parameters are kept at their defaults.

Use the Sphere tool to create a sphere with a Radius of 0.3 and other parameters at 
their defaults. 

2 Go to Draw>Work-Plane Settings.

3 In the dialog box that appears, select the y-z plane at x = 0. Click OK.
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4 Go to Draw>Specify Objects>Rectangle to create rectangles with the following 
properties:

5 From the Draw menu, open the Create Composite Object dialog box.

6 Clear the Keep interior boundaries check box.

7 Enter the formula R1+R2 in the Set formula edit field.

8 Click OK.

9 With the newly formed composite object selected, click the Mirror button, change 
the Normal vector to (0,1) and click OK.

10 Create another rectangle with the following properties:

11 You now have three objects, which together form the cross section of the magnet.

NAME WIDTH HEIGHT BASE X0 Y0

R1 0.02 -0.0075+0.06 Corner 0.06 -0.06

R2 0.06 0.02 Corner 0.08 -0.06

NAME WIDTH HEIGHT BASE X0 Y0

R1 0.02 0.08 Corner 0.12 -0.04
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12 Select all three objects and select Extrude from the Draw menu. Extrude a distance 
of 0.02.

13 In the 3D view, with the extrusion objects selected, click the Move toolbar button 
and move the objects -0.01 in the x direction.

O P T I O N S  A N D  S E T T I N G S

Constants
1 From the Options menu, choose Constants.

2 Enter the following constants; when done, click OK.

Expression Variables
1 On the Options menu, point to Expressions and then click Scalar Expressions.

NAME EXPRESSION DESCRIPTION

rpm 1000[1/min] Initial rpm value

W0 2*pi*rpm Initial angular velocity

I0 0[kg*m^2] External inertia
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2 Enter Lorentz force variables according to the following table; when done, click OK.

3 On the Options menu, point to Expressions and then click Subdomain Expressions.

4 Enter the following subdomain expression; when done, click OK.

Coupling Variables
Define integration coupling variables for the torque and the moment of inertia.

1 On the Options menu, point to Integration Coupling Variables and then click 
Subdomain Variables.

2 Enter the following variables; when done, click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Physics menu, choose Subdomain Settings.

2 Enter subdomain settings for the active subdomains according to the table below. 
To change the constitutive relation, you need to choose the relation from the 
Constitutive relation list. Click the Load button to access the material libraries. For 
subdomain 2, you can use the predefined material Copper that you find in the Basic 

Material Properties material library.

NAME EXPRESSION

Fx Jy_emqav*Bz_emqav-Jz_emqav*By_emqav

Fy Jz_emqav*Bx_emqav-Jx_emqav*Bz_emqav

Fz Jx_emqav*By_emqav-Jy_emqav*Bx_emqav

NAME SUBDOMAINS 3–5

core 1

NAME SUBDOMAIN 2

Iz 8700*(x^2+y^2)

Tqz x*Fy-y*Fx

SETTINGS SUBDOMAIN 1 SUBDOMAIN 2 SUBDOMAINS 3,4 SUBDOMAIN 5

Material Copper

Velocity x 0 -y*W 0 0

Velocity y 0 x*W 0 0

Velocity z 0 0 0 0
M A G N E T I C  B R A K E  I N  3 D  |  79



80 |  C H A P T E R
Boundary Conditions
Use the default magnetic boundary condition but change the electric boundary 
condition to Electric insulation.

Space-Independent Equations
1 From the Physics menu, open the Space-Independent Equations dialog box and enter 

entities according to the following table. The description field is optional.

Make sure that SI is selected in the Base unit system list.

2 Click OK.

M E S H  G E N E R A T I O N

1 Go to Subdomain Mode by clicking the Subdomain Mode toolbar button.

2 Select Subdomain 2 (copper disk) only.

3 Open the Free Mesh Parameters dialog box by selecting Free Mesh Parameters from 
the Mesh menu.

4 Select Extremely fine from the list of Predefined mesh sizes.

5 Click the Mesh Selected button to mesh just the disk.

6 Select Coarser from the list of Predefined mesh sizes.

7 Click OK.

8 Click the Mesh Remaining (Free) button on the Mesh toolbar to mesh the rest of the 
geometry.

Electric 
conductivity

1 5.998e7[S/m] 1 1

Constitutive 
relation

B = µ0µrH B = µ0µrH B = µ0µrH B = µ0µrH + Br

Rel. permeability 1 1 4000 1

Rem. flux density x 0

Rem. flux density y 0

Rem. flux density z 1

NAME EQUATION INIT(U) INIT(UT) DESCRIPTION

W Wt-Tqz/(Iz+I0) W0 0 Rotation angle

SETTINGS SUBDOMAIN 1 SUBDOMAIN 2 SUBDOMAINS 3,4 SUBDOMAIN 5
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C O M P U T I N G  T H E  S O L U T I O N

1 Open the Solver Parameters dialog box by clicking the corresponding button on the 
Main toolbar or select it from the Solve menu.

2 Set Solver to Time dependent.

3 In the Times edit field type 0:1:25.

4 In the Relative tolerance edit field type 0.001.

5 In the Absolute tolerance edit field type W 0.1 V 1e-5 tAxAyAz10 1e-7 
tAxAyAz20 1e-7 tAxAyAz21 1e-7.

6 Click the Time Stepping tab and set Time steps taken by solver to Intermediate.

7 Click OK to close the Solver Parameters dialog box.

8 Open the Probe Plot Parameters dialog box from the Postprocessing menu.

9 Click New and select Global from the Plot type list.

10 Type Omega for Plot name.

11 Click OK.

12 Type W in the Expression edit field.

13 Click New and select the Global from the Plot type list.

14 Type Torque for Plot name.

15 Click OK.

16 Type -Tqz in the Expression edit field.

17 Click New and select Integration as Plot type and Subdomain as Domain type.

18 Type Power for Plot name.

19 Click OK.

20 Type Q_emqav in the Expression edit field and select Subdomain 2 from the 
Subdomain selection list.

21 Click OK.

22 Click the Solve button on the Main toolbar to compute the solution. The model 
takes of the order of 10–20 minutes and uses less than 1 GB of memory to solve on 
a standard PC. The probe plots already shown in the results section appear as the 
solution is in progress.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Open the Plot Parameters dialog box from the Postprocessing menu.
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2 Clear the check box for Slice plot and select the ones for Subdomain, Boundary, Edge, 
and Arrow plots on the General page. Select 0 from the Solution at time list.

3 Click the Subdomain tab. Type core in the Expression field. Set the Element color to 

Uniform color. Click the Color button and choose a medium gray color from the 
palette.

4 Click the Boundary tab. Type normJ_emqav in the Expression field.

5 Click the Edge tab. Type 1 in the Expression field. Select gray from the Colormap list 
and clear the Color scale check box.

6 Click the Arrow tab. Select Boundaries from the Plot arrows on list. Click the 
Boundary Data tab and enter Jx_emqav, Jy_emqav, and Jz_emqav, respectively, in 
the edit fields. Set the Arrow type to 3D arrow. Clear the Auto check box for Scale 
factor and enter 2 in the associated edit field.

7 Move the Plot Parameters dialog box to the side but keep it open. 

8 From the Options menu, select Suppress>Suppress Subdomains.

9 Select Subdomains 1 and 2.

10 Click OK.

11 From the Options menu, select Suppress>Suppress Boundaries.

12 Select all boundaries except numbers 5–8, 32, and 35.

13 Click OK.

14 From the Options menu, select Suppress>Suppress Edges.

15 Select Edges 1–5, 21, 31, 44–47, 50–54, 57, and 76.

16 Click OK.

17 Click OK in the Plot Parameters dialog box.

18 Click the Scene Light button on the Camera toolbar.
 3 :  M O T O R S  A N D  D R I V E S  M O D E L S



19 In the status bar at the bottom of the main window, double-click AXIS.
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Ra i l g un

Introduction

A railgun is a type of magnetic accelerator gun that utilizes an electromagnetic force to 
propel an electrically conductive projectile (armature) that is initially part of the 
current path. The current flowing through the rails sets up a magnetic field between 
them and through the projectile perpendicular to the current in it. This results in an 
acceleration of the projectile along the rails. As no ferromagnetic materials are 
involved, there are no saturation effects and the muzzle speed of the projectile is only 
limited by the available electric power and the structural and thermal durability of the 
device. In theory, muzzle speeds of several km/s are possible.

Model Definition

This 3D problem is solved using a transient inductive formulation for the 
electromagnetic part coupled to an ordinary differential equation for the lumped 
kinematics of the armature. The railgun is a predominantly inductive and resistive 
device where the input power is transformed into three different entities:

• Joule heating
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• Magnetic energy as more and more of the rails become energized as the armature 
moves forward

• Kinetic energy of the armature

As the current is limited by inductive and resistive effects, capacitive effects do not play 
any major role in the dynamics of the railgun itself. A practical railgun implementation 
may be driven by a high energy capacitor bank that can be included as a driving circuit 
(not implemented here).

Maxwell-Ampères law, expressed using a magnetic vector potential A and a scalar 
electric potential V, is the fundamental field equation used in this model. It is 
complemented by a DC current balance.

The armature is not modeled as a separate domain but as a moving conductivity 
distribution that is interpolated on a fixed mesh. Note that induced current terms of 
Lorentz type cannot be used in this modeling situation as the armature is of finite 
extent in the direction of motion and it carries an externally driven flux source that 
moves along with the motion. That is, part of the magnetic flux is stationary in the 
moving frame, see also the discussion in connection with the model “Magnetic Brake 
in 3D” on page 72.

The magnetic and electric boundary conditions on external boundaries are;

except for the voltage driven ends of the rails where suitable constraints are applied on 
the electric potential.

Now consider how the system evolves over time. The Lorentz force accelerates the 
armature. This is modeled as an ordinary differential equation (ODE) for the armature 
position x0.

Where M is the armature mass and the force Fx is obtained as the x-component of the 
volume integral of the Lorentz force density over the armature:

σ
t∂

∂A ∇ µ 1– ∇ A×( )×+ σ– ∇V=

∇ σ∇V( )–( )⋅ 0=

n A× 0=

n J⋅ 0=

x0d
dt

--------- Fx
M
-------=
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Results and Discussion

The COMSOL Multiphysics model is set up for an armature that is a 4 cm cube made 
of aluminum. Each rail has a cross section that is 4 cm by 2 cm and a length of 4.8 m. 
As the armature is initially inserted 4 cm, the effective length is slightly shorter. The 
rails are made of copper. The device is driven by a constant applied voltage of 300 V. 
The following figures contain snapshots of the solution and time traces of rail current, 
position, speed, and the accelerating Lorentz force.

Figure 3-10: A snapshot of the solution at t = 1.895 ms. The electric potential is plotted as 
color on the rails. Streamlines and streamline color represent the magnetic flux density and 
magnitude respectively.

F J B×( )dV

V
∫=
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The time evolution of the rail current.

The time evolution of the armature position.
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The time evolution of the armature velocity.

The time evolution of the Lorentz force is shown.

Model Library path: ACDC_Module/Motors_and_Drives/railgun_3d
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Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select 3D from the Space dimension list.

2 Click the Multiphysics button.

3 In the AC/DC Module folder, select Quasi-Statics, Magnetic> 

Induction Currents>Transient analysis.

4 Select Vector - Linear from the Element list.

5 Click Add to include the selected application mode in the list to the right.

6 In the AC/DC Module folder, select Statics>Conductive Media DC.

7 Select Lagrange - Linear in the Element list.

8 Click Add to include the selected application mode in the list to the right.

9 Click OK to close the Model Navigator.

G E O M E T R Y  M O D E L I N G

1 Go to Draw>Work-Plane Settings.

2 In the dialog box that appears, select the y-z plane at x = 0, click OK.

3 Go to Draw>Specify Objects>Circle to create a circle with a radius of 0.5 and the 
center at (0, 0).

4 Go to Draw>Specify Objects>Rectangle to create rectangles with the following 
properties:

5 Select all objects and click the Zoom Extents button on the Main toolbar.

NAME WIDTH HEIGHT BASE X0 Y0

R1 0.02 0.04 Corner -0.04 -0.02

R2 0.02 0.04 Corner 0.02 -0.02

R3 0.08 0.04 Corner -0.04 -0.02
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6 You will now have three objects that together form the cross section of the railgun.

7 Select all four objects and select Extrude from the Draw menu. Extrude a distance of 
5.

8 Click on the Geom2 tab in the main window to go back to the 2D geometry.

9 Select only the circle object and select Embed from the Draw menu.

10 Click OK.
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11 In the 3D geometry with the embedded circle object selected, click the Move toolbar 
button and move it a distance of 4.8 in the x direction.

O P T I O N S  A N D  S E T T I N G S

Constants
1 From the Options menu, choose Constants.

2 Enter the following constants; when done, click OK.

Expression Variables
1 On the Options menu, point to Expressions and then click Scalar Expressions.

NAME EXPRESSION DESCRIPTION

V 0.04^3[m^3] Armature volume

rho_Al 2700[kg/m^3] Armature density

M rho_Al*V Armature mass

w 0.04[m] Armature length

k 100 Constant in exponential factor

sigma_Al 1/2.65e-8[ohm*m] Armature conductivity

V0 300[V] Applied voltage
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2 Enter Lorentz force variables according to:

Coupling Variables
Define integration coupling variables for the force on the armature and the rail current.

1 On the Options menu, point to Integration Coupling Variables and then click 
Subdomain Variables.

2 Enter the following variable; when done, click OK.

3 On the Options menu, point to Integration Coupling Variables and then click Boundary 

Variables.

4 Enter the following variable:

5 Click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 In the Multiphysics menu, make sure that the Conductive Media DC application mode 

is selected.

2 From the Physics menu, choose Subdomain Settings.

3 Select Subdomains 1 and 5 and deselect the Active in this domain box to avoid 
solving this part of the problem in the air.

4 Enter subdomain settings for the active subdomains according to the table below.

NAME EXPRESSION DESCRIPTION

Fx Jy_emqa*Bz_emqa-Jz_emqa*By_emqa Lorentz force x

Fy Jz_emqa*Bx_emqa-Jx_emqa*Bz_emqa Lorentz force y

Fz Jx_emqa*By_emqa-Jy_emqa*Bx_emqa Lorentz force z

NAME SUBDOMAIN 3

FX Fx

NAME BOUNDARIES 1, 4

I nJ_emdc-Jix_emqa

SETTINGS SUBDOMAINS 2, 4 SUBDOMAIN 3 SUBDOMAINS 6–8

Electric 
conductivity

5.98e7 1+sigma_Al*exp(-k*(abs(x-x0)> 
(w/2))*(abs(x-x0)-(w/2)))

1
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Boundary Conditions
Use the Electric insulation boundary condition for all active boundaries except for 
Boundaries 4 and 14 where you apply an Electric potential of V0/2 and -V0/2, 
respectively.

Subdomain Settings
1 From the Multiphysics menu, select the Induction Currents application mode.

2 From the Physics menu, choose Subdomain Settings.

3 Enter subdomain settings for the active subdomains according to the table below.

Boundary Conditions
Use the default Magnetic insulation boundary condition for all active boundaries.

Space-Independent Equations
1 From the Physics menu, open the Space-Independent Equations dialog box and enter 

entities according to the following table. The description field is optional.

2 Click OK.

M E S H  G E N E R A T I O N

1 Go to Boundary Mode by clicking on the Boundary Mode button on the Main 
toolbar.

2 Select Boundaries 1, 4, 8, and 14 (the railgun inlet end).

3 Open the Free Mesh Parameters dialog box by selecting Free Mesh Parameters from 
the Mesh menu.

4 Select Coarse from the list of Predefined mesh sizes.

5 Click the Mesh Selected button to mesh the inlet end of the railgun.

SETTINGS SUBDOMAINS 1, 5 SUBDOMAINS 2, 4 SUBDOMAIN 3 SUBDOMAINS 6–8

Electric 
conductivity

1 5.98e7 1+sigma_Al* 
exp(-k*(abs(x-x0)> 
(w/2))*(abs(x-x0) 
-(w/2)))

1

Jex 0 Jx_emdc Jx_emdc Jx_emdc

Jey 0 Jy_emdc Jy_emdc Jy_emdc

Jez 0 Jz_emdc Jz_emdc Jz_emdc

NAME EQUATION INIT(U) INIT(UT) DESCRIPTION

x0 x0tt-FX/M 0.04 0 armature position
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6 Click OK.

7 Go to Subdomain Mode by clicking on the Subdomain Mode button on the Main 
toolbar.

8 Open the Swept Mesh Parameters dialog box by selecting Swept Mesh Parameters 

from the Mesh menu.

9 Select Subdomains 1–4 in the Subdomain selection list.

10 Select the Manual specification of element layers check box and specify 240 for 
Number of element layers.

11 Click the Mesh Selected button.

12 Select Subdomains 5–8 in the Subdomain selection list.

13 Select the Manual specification of element layers check box and specify 10 for Number 

of element layers.
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14 Click the Mesh Selected button.

15 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Open the Solver Parameters dialog box by clicking the corresponding button on the 
Main toolbar or select it from the Solve menu. 

2 Set Solver to Time dependent.

3 In the Times edit field type linspace(0,4e-3,20).

4 In the Absolute tolerance edit field type: tAxAyAz10 0.03e-4 V2 0.03 x0 0.01.

5 Set the Linear system solver to Direct (PARDISO).

6 Click OK to close the Solver Parameters dialog box.

7 Open the Probe Plot Parameters dialog box from the Postprocessing menu.

8 Click New and select Global from the Plot type list.

9 Type Position in the Plot name edit field.

10 Click OK.

11 Type x0 in the Expression field.

12 Click New and select Global from the Plot type list.
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13 Type Velocity for Plot name.

14 Click OK.

15 Type x0t in the Expression field.

16 Click New and select Global from the Plot type list.

17 Type Current for Plot name.

18 Click OK.

19 Type I in the Expression field.

20 Click New and select Global from the Plot type list.

21 Type Force for Plot name.

22 Click OK.

23 Type FX in the Expression field.

24 Click OK.

25 Click the Solve button on the Main toolbar to compute the solution.

The model takes on the order of 2–4 hours and uses less than 1 GB of memory to solve 
on a standard PC. The probe plots already shown in the results section appears as the 
solution is in progress.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To reproduce Figure 3-10, follow these instructions:

1 From the Options menu, select Suppress>Suppress Subdomains.

2 Select Subdomains 2, 4, 6, and 8.

3 Click OK.

4 From the Options menu, select Suppress>Suppress Boundaries.

5 Select Boundaries 1–3, 8, 10–13, 19–21, 26, 28–31, 37, and 39.

6 Click OK.

7 From the Options menu, select Suppress>Suppress Edges.

8 Select Edges 1–3, 10, 12, 14–17, 26–31, 33, 35, 36, 38, 40–45, 47, 49, 52–54, and 
59–62.

9 Click OK.

10 Open the Plot Parameters dialog box from the Postprocessing menu.

11 Clear the check box for Plot type: Slice and Geometry edges, and select the ones for 
Isosurface, Boundary, Edge and Streamline on the General page.
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12 On the General page, select the Solution at time 0.001895.

13 Click the Isosurface tab. Type sigma_emqa in the Expression field. Set the Isosurface 

levels to Vector with isolevels and enter 1e7 in the corresponding field. Set Isosurface 

color to Uniform color. Click the Color button and choose a yellow color from the 
palette. Clear the Color scale check box.

14 Click the Boundary tab. Type V2 in the Expression field. 

15 Click the Edge tab. Type 1 in the Expression field. Set Edge color to Uniform color. 
Click the Color button and choose black from the palette.

16 Click the Streamline tab.

17 Set the Streamline data fields to Bx_emqa, By_emqa, and Bz_emqa, respectively. 

18 Click the Start Points tab, select Specify start point coordinates and enter 
[linspace(0.02,5,20) linspace(0.02,5,20)], [0.01*ones(1,20) 

-0.01*ones(1,20)], 0 in the x, y, and z data fields, respectively. 

19 Click the Line Color tab, select Use expression and click the Color Expression button.

20 Type normB_emqa in the Expression field.

21 Select hot from the Colormap list.

22 Click OK to close the Streamline Color Expression dialog box.

23 Set the Line type to Tube and click the Tube Radius button.

24 Select the Radius data check box.

25 Type normB_emqa in the Expression field.

26 Clear the Auto check box for Radius scale factor and enter 0.1.

27 Click OK to close the Tube Radius Parameters dialog box.

28 Click the Advanced button and decrease the Maximum number of integration steps to 
1000.

29 Click OK to close the Advanced Streamline Parameters dialog box.

30 Click OK in the Plot Parameters dialog box.

31 Click the Scene Light button on the Camera toolbar.
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32 In the status bar at the bottom of the main window, double-click AXIS and CSYS. Use 
the mouse to adjust the view.
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E l e c t r i c a l  C o m p o n e n t  M o d e l s
This chapter contains models of electrical components. In most cases, the models 
make use of the static and quasi-static application modes in the AC/DC Module. 
 99
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Tunab l e  MEMS Capa c i t o r

Introduction

In an electrostatically tunable parallel plate capacitor you can modify the distance 
between the two plates when the applied voltage changes. For tuning of the distance 
between the plates the capacitor includes a spring that attaches to one of the plates. If 
you know the characteristics of the spring and the voltage between the plates, you can 
compute the distance between the plates. This model includes an electrostatic 
simulation for a given distance. A postprocessing step then computes the capacitance.

The capacitor in this model is a typical component in various microelectromechanical 
systems (MEMS) for electromagnetic fields in the radio frequency range 300 MHz to 
300 GHz.

Figure 4-1: The tunable MEMS capacitor consists of two metal plates. The distance 
between the plates is tuned via a spring connected to one of the plates.

Model Definition

To solve the problem, use the 3D Electrostatics application mode in the AC/DC 
Module. The capacitance is available directly as a variable for postprocessing.

D O M A I N  E Q U A T I O N S

The electric scalar potential, V, satisfies Poisson’s equation,

∇ ε0εr V∇( )⋅– ρ=
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where ε0 is the permittivity of free space, εr is the relative permittivity, and ρ is the space 
charge density. The electric field and the displacement are obtained from the gradient 
of  V:

Figure 4-2: The computational domain. The interiors of the capacitor plates and the 
connecting bars are not included.

B O U N D A R Y  C O N D I T I O N S

Potential boundary conditions are applied to the capacitor plates and bars. A port 
condition maintains the potential 1 V at the upper plate and the connecting bars, 
whereas the lower plate is kept at ground potential. For the surface of the surrounding 
box, apply conditions corresponding to zero surface charge at the boundary,

Results and Discussion

Figure 4-3 shows the computed electric field and potential distribution in the 
capacitor. The potential on each capacitor plate is constant, as dictated by the 
boundary condition. Right between the plates, the electric field is almost uniform, but 

E V∇–=

D ε0εrE=

n D⋅ 0=
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close to the edges of the plates, you can see fringing fields that change magnitude and 
direction rapidly in space.

Figure 4-3: The electric potential is shown as a surface plot while the cones indicate the 
strength and orientation of the electric field.

The capacitance, C, obtained from the simulation is approximately 0.09 pF.

Model Library path: ACDC_Module/Electrical_Components/capacitor

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select 3D in the Space dimension list.

2 In the list of application modes, select AC/DC Module>Statics>Electrostatics.

3 Click OK.
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O P T I O N S  A N D  S E T T I N G S

In the Axes/Grid Settings dialog box clear the Axis auto check box and specify axis 
settings according to the following table.

G E O M E T R Y  M O D E L I N G

The geometry of this model can be created either by drawing in a work plane and then 
extruding the 2D geometry or by using 3D primitives. The advantage of the latter 
approach is that the coordinates of the blocks can be given explicitly.

1 Draw solid blocks according to the following table.

AXIS MIN MAX

x -50 300

y -50 300

z -25 75

NAME LENGTH AXIS BASE POINT

X Y Z X Y Z

BLK1 22 60 8 0 240 46

BLK2 40 22 8 22 259 46

BLK3 176 262 8 62 19 46

BLK4 40 22 8 238 259 46

BKL5 22 60 8 278 240 46

BLK6 40 22 8 238 19 46

BLK7 22 60 8 278 0 46

BLK8 40 22 8 22 19 46

BLK9 22 229 8 0 41 0

BLK10 40 22 8 -40 139 0
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2 Draw a solid cylinder with radius 5.5 and height 38 with the axis parallel to the 
z-axis, and the base point of the axis located at (11, 250, 8).

3 Select all geometry objects using the Select All command from the Edit menu, then 
open the Create Composite Object dialog box. Be sure to clear the Keep interior 

boundaries check box and verify that all objects are selected. Then click OK to create 
a composite object as the union of all objects. The advantage with removing the 
interior boundaries in this geometry is that it makes it easier to create a high quality 
mesh later on.

4 Now, draw two more solid block objects according to the following table.

5 Using the Shift key, select both block objects, then click the Union button to form 
another composite object. The interior boundaries of this object are not kept 
because the settings in the Create Composite Object dialog box are applied for all set 
operations until modified again.

NAME LENGTH AXIS BASE POINT

X Y Z X Y Z

BLK1 176 262 8 62 19 8

BLK2 181 22 8 139 139 0
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6 Now draw a block surrounding the two objects corresponding to the two plates in 
the capacitor. Create a block of size 360-by-340-by-94, with the base point of the 
axis at (−40, −20, −20).

7 Once again open the Create Composite Object dialog box, and now enter the formula 
BLK1-(CO1+CO2) in the Set formula edit field.

8 The geometry of the model is now ready, except for the size. The capacitor 
dimensions you have entered should be given in µm. This is easily accounted for by 
clicking the Scale button and giving the value 1e-6 for all three scaling factors. Then 
click the Zoom Extents button on the Main toolbar to see the object.

P H Y S I C S  S E T T I N G S

Subdomain Settings
Because there is silica-glass between the plates, you need to modify the permittivity. 
Enter the following values for the subdomain settings:

SETTINGS SUBDOMAIN 1

εr 4.2

ρ 0
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Boundary Conditions
The lower plate is grounded while a positive potential is applied to the upper plate. The 
surrounding boundaries are kept electrically insulated. The following table shows the 
corresponding boundary settings.

M E S H  G E N E R A T I O N

1 Open the Free Mesh Parameters dialog box. On the Global tab, select Coarse from the 
Predefined mesh sizes list. Then select Custom mesh size and set the Resolution of 

narrow regions parameter to 1.5 to help the mesh generator resolve the thin regions 
in the geometry.

2 Click Remesh to initialize the mesh, then click OK to close the Free Mesh Parameters 
dialog box.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Use the electric field distribution together with a plot of the potential to visualize the 
result of the simulation. You have access to the capacitance as a variable, C11_emes, 
that you can plot or display directly.

1 Start by suppressing some boundaries not to be used for visualization. Select 
Suppress Boundaries from the Options menu. Select Boundaries 1, 2, and 4, then click 
OK.

SETTINGS BOUNDARIES 37–40, 
45, 47–51, 57

BOUNDARIES 1–4, 9, 76 ALL OTHERS

Boundary condition Ground Zero charge/Symmetry Port

Port tab Use port as input

Input property Energy method
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2 In the Plot Parameters dialog box on the General tab clear Slice, then select Boundary 
and Arrow as Plot type. Use the default settings for both plot types.

3 Choose Postprocessing>Data Display>Global to open the Global Data Display dialog 
box. Type C11_emes in the Expression edit field, then click OK to display the 
capacitance in the message log.

Modeling Using the Programming Language

% Start the modeling by clearing the fem variable in 
% the COMSOL Script or MATLAB workspace.
clear fem

% Begin by specifying space dimensions and defining a geometry.
fem.sdim = {'x','y','z'};

blks{1} = block3(22,60,8,'corner',[0 240 46]);
blks{2} = block3(40,22,8,'corner',[22 259 46]);
blks{3} = block3(176,262,8,'corner',[62 19 46]);
blks{4} = block3(40,22,8,'corner',[238 259 46]);
blks{5} = block3(22,60,8,'corner',[278 240 46]);
blks{6} = block3(40,22,8,'corner',[238 19 46]);
blks{7} = block3(22,60,8,'corner',[278 0 46]);
blks{8} = block3(40,22,8,'corner',[22 19 46]);
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blks{9} = block3(22,218,8,'corner',[0 41 0]);
blks{10} = block3(40,22,8,'corner',[-40 139 0]);
cyl1 = cylinder3(5.5,38,[11 250 8]);
co1 = geomcomp({blks{:} cyl1},'face','all','edge','all');

blk1 = block3(176,262,8,'corner',[62 19 8]);
blk2 = block3(181,22,8,'corner',[139 139 0]);
co2 = blk1 + blk2;

blk3 = block3(360,340,94,'corner',[-40 -20 -20]);
co3 = geomcomp({co1 co2 blk3},'ns',{'CO1','CO2','BLK1'}, ...
  'sf','BLK1-(CO1 + CO2)','face','all','edge','all');

fem.geom = scale(co3,1e-6,1e-6,1e-6,0,0,0);

% The application mode structure contains all the physical
% properties of the model. Create this with the following 
% commands:
clear appl

appl.mode = 'EmElectrostatics';

appl.equ.rho0 = '0';
appl.equ.epsilonr = '4.2';

% Use Energy method for capacitance calculation
clear prop
prop.input='We';
appl.prop = prop;

% Assign zero charge, port, and ground boundary conditions to 
% correct boundary numbers.
appl.bnd.inport = {0,1,0};
appl.bnd.type = {'nD0','port','V0'};
appl.bnd.ind = ones(1,76)*2;
appl.bnd.ind(1,[1:4 9 76]) = 1;
appl.bnd.ind(1,[37:40 45 47:51 57]) = 3;

% Generate the coefficients in the FEM structure.
fem.appl = appl;
fem = multiphysics(fem);

% Create a coarse mesh for the geometry with the following commands.
% The extended mesh structure contains all the necessary data
% defining the different elements.
fem.mesh = meshinit(fem, ...
  'hauto',6, ...
  'hnarrow',1.5);

fem.xmesh = meshextend(fem);
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% Solve the problem and visualize the result.
fem.sol = femstatic(fem);

% Plot the voltage on all boundaries except on number 1, 2, and 4.
% The electric field is plotted as arrows for all subdomains.
bdlList = setdiff(1:76,[1 2 4]);
postplot(fem,...
  'bdl', bdlList, ...
  'tridata',{'V','cont','on'}, ...
  'tribar', 'on', ...
  'arrowdata',{'Ex','Ey','Ez'}, ...
  'axisequal','on', ...
  'axisvisible','off')

% The capacitance value (evaluated at an arbitrary point):
I1 = postinterp(fem,'C11',[0;0;0])
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I n du c t i o n  Cu r r e n t s  f r om C i r c u l a r  
C o i l s

Introduction

A time-varying current induces a varying magnetic field. This field induces currents in 
neighboring conductors. The induced currents are called eddy currents. The following 
model illustrates this phenomenon by a time-harmonic field simulation as well as a 
transient analysis, which provides a study of the eddy currents resulting from switching 
on the source.

Two current-carrying coils are placed above a copper plate. They are surrounded by 
air, and there is a small air gap between the coils and the metal plate. A potential 
difference provides the external source. To obtain the total current density in the coils 
you must take the induced currents into account. The time-harmonic case shows the 
skin effect, that is, that the current density is high close to the surface and decreases 
rapidly inside the conductor.

Model Definition

E Q U A T I O N

To solve the problem in the AC/DC Module, use a quasi-static equation for the 
magnetic potential A.

σ A∂
t∂

------- ∇ µ0
1– µr

1– ∇ A×( )×+ σ
Vloop
2πr
-------------=
 4 :  E L E C T R I C A L  C O M P O N E N T  M O D E L S



where µ0 is the permeability of vacuum, µr the relative permeability, σ the electric 
conductivity, and Vloop is the voltage over one turn in the coil. In the time-harmonic 
case the equation reduces to

F O R C E S

It is also possible to compute the forces on the plate caused by the eddy currents. The 
following expression gives the Lorentz force on the plate:

When dealing with time-harmonic fields, you must take the complex nature of the field 
representation into special consideration. In the time domain, the force in the axial 
direction in this axisymmetric model is

where  and  are the current and magnetic flux in the frequency domain, 
obtained from the harmonic equation.

jωσA ∇ µ0
1– µr

1– ∇ A×( )×+ σ
Vloop
2πr
-------------=

F J B×=

Fz JϕBr– Re J′ϕejωt( ) Re B′re
jωt( )⋅–= =

J′ϕ B′r
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Results and Discussion

The applied voltage is constant across each wire, but the induced current makes the 
current density higher toward the end facing the copper plate. Figure 4-4 below shows 
this and also displays the field lines from the magnetic flux.

Figure 4-4: The component of the current density plotted together with the field lines of 
the magnetic flux.

ϕ
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The eddy currents in the wires and in the copper plate give rise to a force between the 
parts. Figure 4-5 below shows a plot of the force on the plate over one period.

Figure 4-5: The force on the copper plate over one period. Although the solution only gives 
the amplitude and phase, these can easily be converted to a real signal in the time domain.

Model Library path: ACDC_Module/Electrical_Components/
coil_above_plate

Harmonic Analysis in the Graphical User Interface

M O D E L  N A V I G A T O R

1 From the Space dimension list, select Axial symmetry (2D).

2 Select the AC/DC Module>Quasi-Statics, Magnetic>Azimuthal Induction Currents, Vector 

Potential>Time-harmonic analysis application mode.

3 Click OK.
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O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, choose Axes/Grid Settings.

2 Set axis and grid settings according to the following table.

G E O M E T R Y  M O D E L I N G

1 Draw the surrounding rectangle R1 with opposite corners at (0, −0.05) and 
(0.1, 0.05).

2 Draw the rectangle representing the metal plate R2 with the corners at (0, −0.02) 
and (0.08, 0). Now change the position of R2 by pressing the Move button on the 
Draw toolbar or selecting it in the Draw menu under Modify. Set the z displacement 
to −0.001.

3 Draw a circle C1 representing the first current-carrying coil, centered at 
(0.0125, 0.0025) with radius 0.0025.

AXIS GRID

r min -0.05 r spacing 0.01

r max 0.15 Extra r 0.0125

z min -0.08 z spacing 0.01

z max 0.08 Extra z 0.0025 0.005
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4 Select C1 and click the Array button. Set the Displacement in the r direction to 0.006 
and the Array size in the r direction to 2.

P H Y S I C S  S E T T I N G S

Scalar Variables
From the Physics menu, select Scalar Variables and set the frequency variable nu_emqa 
to 50.

Subdomain Settings
In this model, use the COMSOL Multiphysics materials library to specify material 
parameters in the subdomains. Only the conductivity, the permeability, and the 
permittivity are determined by the material selected.

1 From the Physics menu, open the Subdomain Settings dialog box, and select 
Subdomains 2–4.

2 Under the Electric Parameters tab, click the Load button. In the dialog box that 
appears, select Copper and click OK.

3 Enter subdomain settings according to the following table.

SETTING SUBDOMAINS 1, 2 SUBDOMAINS 3, 4

Vloop 0 1e-4
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Boundary Conditions
Set boundary conditions according to the following table.

M E S H  G E N E R A T I O N

1 Initialize the mesh by clicking the Initialize Mesh button on the Main toolbar.

2 Click the Refine Mesh button to refine the mesh.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The magnetic potential is the default visualization quantity. In this case it is of interest 
to plot the eddy currents together with the magnetic flux density. These fields are used 
to examine the magnetic forces that arise in current-carrying conductors.

1 Click the Plot Parameters button on the Main toolbar. 

2 On the General tab select Surface plot and Streamline plot.

3 On the Surface tab select Induced current density, phi component as Surface data.

4 On the Streamline tab select Magnetic flux density as Streamline data.

SETTING BOUNDARIES 1, 3, 5 BOUNDARIES 2, 7, 9

Boundary condition Axial symmetry Magnetic insulation
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5 For a better view of the current-intensive region, use the Zoom Window button on 
the Main toolbar. The current density is highest near the edge of the plate.

If you are running COMSOL Multiphysics with COMSOL Script or MATLAB, you 
can visualize the force over one period.

1 Select Export>FEM structure from the File menu.

2 Use the following commands to show the magnetic force on the plate over one 
period.

wt = linspace(0,2*pi,40);
for i = 1:length(wt)
  Fv(i) = postint(fem,'-2*pi*r*real(Jiphi_emqa)*real(Br_emqa)',... 
    'dl',2,'phase',wt(i));
end
figure
plot(wt,Fv)
xlabel('angle (wt)'),ylabel('axial force (Fz)')
I N D U C T I O N  C U R R E N T S  F R O M  C I R C U L A R  C O I L S  |  117



118 |  C H A P T E R
Transient Analysis

The previous model was an example of harmonic field variations. To study a transient 
case where the current increases abruptly from zero to a constant value, you only need 
to make a few alterations. To adapt the application mode to a transient analysis, you 
must first change the analysis type.

C O M P U T I N G  T H E  S O L U T I O N

1 Open the Solver Parameters dialog box and set the Analysis to Transient. Enter the 
vector 0 logspace(-4,-1,10) in the Times edit field.

2 Set the Absolute tolerance to 1e-8.

3 Solve the problem.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

In a way similar to the harmonic analysis, you can visualize the magnetic flux density, 
the induced currents, and the magnetic forces.

1 Open the Plot Parameters dialog box.

2 On the General tab, select Surface and Arrow plots.
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3 On the Arrow tab, set the Arrow data to the magnetic flux density. Choose 
Normalized as Arrow length, set the Arrow positioning to 25 in both directions, and 
enter 0.5 as Scale factor.

4 Use the zoom features to see the eddy current distribution.

5 Change the evaluation time under the General tab in the Plot Parameters dialog box, 
or click Start Animation under the Animate tab, to see how the current distribution 
changes in time.

Modeling Using the Programming Language

% Start modeling by defining the names of the cylindrical
% coordinates and by defining the geometry of the structure.
clear fem
fem.sdim={'r' 'z'};
fem.geom=rect2(0,0.1,-0.05,0.05)+...
        rect2(0,0.08,-0.019,-0.001)+...
        circ2(0.0125,0.0025,0.0025)+...
        circ2(0.0185,0.0025,0.0025);

% Create the application structure.
clear appl
appl.mode.class='AzimuthalCurrents';
appl.mode.type='axi';
appl.prop.analysis='harmonic';
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appl.var.nu=50;
appl.bnd.type={'ax' 'A0'};
appl.bnd.ind=[1 2 1 0 1 0 2 0 2 0 0 0 0 0 0 0 0];
appl.equ.sigma={'0' '5.99e7' '5.99e7'};
appl.equ.Vloop={'0' '0' '1e-4'};
appl.equ.ind=[1 2 3 3];
fem.appl=appl;
fem=multiphysics(fem);

% Create the mesh.
fem.mesh=meshinit(fem);
fem.mesh=meshrefine(fem);
fem.xmesh = meshextend(fem);

% Solve and visualize the solution.
fem.sol=femlin(fem);
postplot(fem,'tridata','Jiphi',...
        'arrowdata',{'Br' 'Bz'},'arrowscale',0.3,...
        'arrowstyle','normal')

% You can handle the postprocessing in exactly the same way as 
% above, when solving the problem in the graphical user interface.
wt=linspace(0,2*pi,40);
for i=1:length(wt)
  Fv(i)=postint(fem,'-2*pi*r*real(Jiphi)*real(Br)','dl',2,...
    'phase',wt(i));
end
figure
plot(wt,Fv)
xlabel('angle (wt)'),ylabel('axial force (Fz)')

% To simulate the transient case, the analysis type has
% to be modified.
fem.appl.prop.analysis='transient';

% Generate the PDE coefficients for the transient analysis.
fem=multiphysics(fem);

% Regenerate the extended mesh.
fem.xmesh = meshextend(fem);

% To solve the problem, the solver femtime is invoked. You can 
% visualize the result with the same command as in the time 
% harmonic case. To study the result at a specific output time, 
% set the parameter solnum.
fem.sol=femtime(fem,'tlist',[0 logspace(-4,-1,10)],'atol',1e-8);
postplot(fem,'tridata','Jiphi',...
        'arrowdata',{'Br' 'Bz'},'arrowscale',0.3,...
        'arrowstyle','normal','solnum',6)
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% The axial force is visualized with the following commands.
F=postint(fem,'abs(2*pi*r*Jiphi*Br)',...
  'dl',2,'solnum',1:length(fem.sol.tlist));
loglog(fem.sol.tlist(:),F(:),'k');
xlabel('time (t)');
ylabel('axial force (F_z)');
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Magne t i c  F i e l d  o f  a  He lmho l t z  C o i l

Introduction

A Helmholtz coil is a parallel pair of identical circular coils spaced one radius apart and 
wound so that the current flows through both coils in the same direction. This winding 
results in a uniform magnetic field between the coils with the primary component 
parallel to the axis of the two coils. The uniform field is the result of the sum of the 
two field components parallel to the axis of the coils and the difference between the 
components perpendicular to the same axis.

The purpose of the device is to allow scientists and engineers to perform experiments 
and tests that require a known ambient magnetic field. Helmholtz field generation can 
be static, time-varying DC, or AC, depending on the applications.

Applications include cancelling the earth’s magnetic field for certain experiments; 
generating magnetic fields for determining magnetic shielding effectiveness or 
susceptibility of electronic equipment to magnetic fields; calibration of magnetometers 
and navigational equipment; and biomagnetic studies.

Figure 4-6: The Helmholtz coil consists of two coaxial circular coils, one radius apart 
along the axial direction. The coils carry parallel currents of equal magnitude.
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Model Definition

The model is built using the 3D Magnetostatic application mode. The model 
geometry is shown in Figure 4-7.

Figure 4-7: The model geometry.

D O M A I N  E Q U A T I O N S

Assuming static currents and fields, the magnetic vector potential A must satisfy the 
following equation:

where µ is the permeability, and Je denotes the externally applied current density.

The relations between fields and potentials are given by

This model uses the following parameter value:

∇ µ 1– ∇ A×( )× Je
=

B ∇ A×=

H µ 1– B=

µ 4π 10⋅ 7–  H/m=
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The external current density is zero except in the circular coils, where a current density 
of 1 A/m2 is specified. This corresponds to a coil current of 2.5 mA. The currents are 
specified to be parallel for the two coils.

To avoid numerical instability, the application mode by default use an extra equation 
that sets the divergence of the A field to zero (gauge fixing). This model uses a more 
efficient approach where the divergence of A is numerically adjusted to zero by using 
special pre- and postsmoothers called SOR gauge. See “Solver Settings for Numerical 
Gauge Fixing in Magnetostatics” on page 92 in the AC/DC Module User’s Guide for 
more details on this topic.

B O U N D A R Y  C O N D I T I O N S

The only boundary conditions that you need to specify is for the exterior boundary, 
that is, the spherical surface, where you apply conditions corresponding to zero 
magnetic flux:

n A× 0=
 4 :  E L E C T R I C A L  C O M P O N E N T  M O D E L S



Results and Discussion

Figure 4-8 shows the magnetic flux density between the coils. You can see that the flux 
is fairly uniform between the coils, except for the region close to the edges of the coil.

Figure 4-8: The surface color plot shows the magnetic flux density. The arrows indicate the 
magnetic field (H) strength and direction.

The main property of the Helmholtz coil is that the magnetic flux becomes uniform 
in a reasonably large region with a rather simple coil system. This is illustrated in 
Figure 4-9 (a), which shows a radial flux density profile for an axial position right 
between the coils. Figure 4-9 (b) shows an axial magnetic flux density profile. The 
model clearly demonstrates the highly uniform magnetic field obtained in a Helmholtz 
coil.

In the absence of any test object, this model is fully axisymmetric and could be 
implemented as a 2D axisymmetric model, which would be much less computationally 
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demanding. However, this full 3D model has the advantage that a non axisymmetric 
test object could be included in the analysis as a slight modification of the model.

Figure 4-9: The magnetic flux density profile. In the graph at the left, the profile is taken 
along a radial cross sectional line through the axis right between the coils. In the graph on 
the right, the profile is taken along the axis. The high degree of uniformity is clearly shown.

Model Library path: ACDC_Module/Electrical_Components/helmholtz_coil

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select 3D in the Space dimension list.

2 In the list of application modes, select AC/DC Module>Statics>Magnetostatics.

3 Click OK.

O P T I O N S  A N D  S E T T I N G S

From the Options menu, open the Constants dialog box and enter the following name, 
expression, and description (optional); when done, click OK.

G E O M E T R Y  M O D E L I N G

The coils are made from squares in a 2D work plane, which you then revolve into a 3D 
geometry.

NAME EXPRESSION DESCRIPTION

J0 1[A/m^2] Current density in coil

(a) (b)
 4 :  E L E C T R I C A L  C O M P O N E N T  M O D E L S



1 From the Draw menu open the Work-Plane Settings dialog box. Click OK to obtain 
the default work plane in the xy-plane.

2 In the 2D geometry, choose Options>Axes/Grid Settings and specify the settings 
according to the following table (you must clear the Auto check box on the Grid page 
to be able to enter the grid settings).

3 Draw a square with corners at (−0.425, 0.175) and (−0.375, 0.225).

4 Draw another square with corners at (−0.425, −0.225) and (−0.375, −0.175).

5 Select both squares and use the Revolve dialog box available from the Draw menu to 
revolve into the 3D geometry.

6 Finally add a sphere with radius 1 and center at the origin to the 3D geometry.

P H Y S I C S  S E T T I N G S

Subdomain Settings
Apply the current in the coils as a given source current. Open the Subdomain Settings 
dialog box from the Physics menu and enter the source current according to the 
following table.

Boundary Conditions
Use the default Magnetic insulation boundary condition.

M E S H  G E N E R A T I O N

1 Open the Free Mesh Parameters dialog box and select Coarser from the Predefined 

mesh sizes list on the General tab. Click the Subdomain tab, select the Subdomains 2 
and 3, and set the Maximum element size to 0.05.

2 Click Remesh to generate the mesh, then click OK.

AXIS GRID

x min -0.6 x spacing 0.4

x max -0.2 Extra x

y min -0.4 y spacing 0.2

y max 0.4 Extra y -0.225 -0.175 0.175 0.225

SETTING SUBDOMAIN 1 SUBDOMAINS 2, 3

Je 0 0 0 -J0*z/sqrt(x^2+z^2) 0 J0*x/sqrt(x^2+z^2)
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C O M P U T I N G  T H E  S O L U T I O N

Because the default solver settings for this model efficiently handle the gauge fixing 
with the SOR gauge smoothers for the geometric multigrid preconditioner, simply 
click the Solve button on the Main toolbar to start solving.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Suppress the surface of the sphere, that is, Boundaries 1, 2, 3, 4, 21, 22, 31, and 32 
using the Suppress Boundaries dialog box in the Options menu.

2 On the General page of the Plot Parameters dialog box select the Slice, Boundary, and 
Arrow check boxes and clear the Geometry edges check box.

3 On the Slice page use the default Slice data, which is magnetic flux density, norm. Set 
the number of x levels to 0 and the number of z levels to 1.

4 On the Boundary page set Boundary data to 1 and select a Uniform color of your 
choice. 

5 On the Arrow page select Magnetic field as Arrow data, set the x points to 24, the 
y points to 10, and the z points to 1. Enter 0.5 as Scale factor.

6 To add some lighting to the plot open the Visualization/Selection Settings dialog box 
from the Options menu and select Scenelight on the Lighting page. Disable lights 1 
and 3.
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You can visualize the magnetic flux density profile using cross-section plots.

1 Open the Cross-Section Plot Parameters dialog box. On the General page click the 
Title/Axis button and set the title to Magnetic flux density.

2 On the Line tab use the default y-axis data which is Magnetic flux density, norm. Set 
the x-axis data to x and set x0 to -0.8 and x1 to 0.8. Click Apply to make a plot of 
the magnetic flux density along a line through the axis right between the coils.
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To make a plot in the other direction change the x-axis data to y and set x0 to 0, x1 to 
0, y0 to -0.8 and y1 to 0.8.
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I n du c t a n c e  i n  a  Co i l

Introduction

This is a model of a simple AC coil: a single-turn thick copper wire. A parametric study 
shows the current distribution in the coil at different frequencies. The skin effect 
becomes increasingly important at the higher frequencies.

Model Definition

You build the model with the Axisymmetric Quasi-statics Azimuthal Currents 
application mode, using a time-harmonic formulation. The modeling takes place in the 
rz-plane. The modeling domain only includes the part where r > 0, in a manner such 
that revolving this view around the z-axis retrieves the full 3D geometry.

D O M A I N  E Q U A T I O N S

The dependent variable in this application mode is the azimuthal component of the 
magnetic vector potential A, which obeys the following relation:

where ω denotes the angular frequency, σ the conductivity, µ the permeability, ε the 
permittivity, and Vloop the voltage applied to the coil. Outside the coil, σ is set to zero.

B O U N D A R Y  C O N D I T I O N S

The model includes boundary conditions for the exterior boundary and the symmetry 
axis. For the exterior boundary, use magnetic insulation. This implies that the magnetic 
vector potential is zero at the boundary, corresponding to a zero magnetic flux. For 
the symmetry boundary use a symmetry condition. The magnetic potential is 
continuous across the interior boundary between the copper wire and the surrounding 
air.

jωσ ω2ε–( )Aϕ ∇ µ 1– ∇ Aϕ×( )×+
σVloop

2πr
-----------------=
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Results and Discussion

Figure 4-10 and Figure 4-11 show the total current density in the coil at frequencies 
of 10 Hz and 2 kHz, respectively.

Figure 4-10: The current density at 10 Hz.

Figure 4-11: The current density at 2 kHz.
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At 10 Hz, the current density is largely inversely proportional to the radial distance; at 
2 kHz, the current is concentrated to the surface of the coil due to the skin effect.

The inductance versus frequency appears in Figure 4-12. The model discusses two 
alternative ways to calculate the inductance: the principle of virtual work and Ohm’s 
law. The difference between the two approaches is less than 0.01 percent.

Figure 4-12: The inductance as a function of the frequency calculated using the virtual 
work method.

Model Library path: ACDC_Module/Electrical_Components/inductance

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 On the New tab of the Model Navigator, select Axial symmetry (2D) in the Space 

dimension list.

2 Click on AC/DC Module, then select Quasi-Statics, Magnetic> Azimuthal Induction 
Currents, Vector Potential>Time-harmonic analysis. 

3 Click OK.
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O P T I O N S  A N D  S E T T I N G S

Start your modeling session by adjusting the main axes area to the size of the geometry 
to draw. You can also make your simulation easier by defining variables that you can 
use later when defining your problem.

1 Select Axes/Grid Settings from the Options menu to open the Axes/Grid Settings dialog 
box.

2 On the Axis tab set r min to -0.25 and r max to 0.25. Set the same interval limits 
for the z axis.

3 Now select the Grid tab and then clear the Auto check box, to manually define new 
grid settings.

4 Set r spacing to 0.05 and give the value 0.03 in the Extra r text field. Set z spacing 
to 0.05, and Extra z to 0.01.

5 Click Apply to see how the new settings are invoked. Note that the r axis settings are 
adjusted to keep the correct aspect ratio.

6 To define global constants, select Constants from the Options menu. This will open 
the Constants dialog box. This model uses only one constant parameter, namely the 
voltage applied to the coil.

7 Give Name and Expression according to the table below, by first entering the constant 
name and then the expression in the edit fields; the description is optional.

8 The numerical value of the voltage that will be used in the model is now visible in 
the dialog box.

9 Click OK to close the dialog box.

G E O M E T R Y  M O D E L I N G

You can now define the geometry of the structure, using the CAD tools that are 
available in COMSOL Multiphysics.

1 Start by drawing the half circle representing the air domain. A half circle is 
conveniently created as the union of a circle and a rectangle. First draw the circle. 
This is done by selecting Draw Objects and then Ellipse/Circle (Centered) from the 
Draw menu or by pressing the Draw Centered Ellipse button on the draw toolbar to 
the left of the main axes area. With the right mouse button, click and hold at (0, 0). 
Move the cursor to (0.2, 0) and release the button. The circle is now created.

NAME EXPRESSION DESCRIPTION

V0 1[V] Voltage applied to coil
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2 Click the Draw Rectangle button on the draw toolbar or select the corresponding 
entry in the Draw menu. Draw a rectangle with opposite corners at (0, −0.2) and 
(0.2, 0.2), this time using the left mouse button.

3 Click the Create Composite Object button or select Create Composite Object in the 
Draw menu. In the dialog box that appears, mark C1 and R1 and click the 
Intersection button, or type C1*R1 in the Set formula text field. Click OK to apply the 
changes and close the dialog box.

4 Continue by drawing the circle representing the coil. Select Draw Centered Ellipse 
again. With the right mouse button, click at (0.03, 0) and move the cursor to 
(0.03,0.01), where you release the button.

5 Double-click GRID in the status bar at the bottom of the GUI to hide the grid lines.

Figure 4-13: Geometry.

P H Y S I C S  S E T T I N G S

Scalar Variables
1 Open the Application Scalar Variables dialog box by selecting Scalar Variables from the 

Physics menu.
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2 The solution should be calculated for a range of frequencies. Type freq in the 
Expression field for nu_emqa. Leave the permittivity and the permeability of vacuum 
at their default values.

3 Click OK.

Subdomain Settings
1 Select Subdomain Settings from the Physics menu.

2 The domain properties on the Electric Parameters tab for this model are given in the 
following table. Use the default values for the properties that are not given here for 
Subdomain 2, and for all properties for Subdomain 1.

3 Click OK.

Boundary Conditions
1 Open the Boundary Settings dialog box by selecting Boundary Settings from the 

Physics menu

2 Give the boundary conditions according to the following table.

3 Click OK.

Boundary 1 is the vertical boundary along the  z-axis. The axial symmetry boundary 
condition makes sure that the solution is symmetric around this axis. The magnetic 
insulation condition sets the magnetic potential to zero along the Boundaries 2 
and 3.

Coupling Variables
Scalar coupling variables are used for integrating the current density and the magnetic 
energy, in order to calculate the inductance and resistance of the coil. 

1 Select Integration Coupling Variables>Subdomain Variables from the Options menu to 
open the Subdomain Integration Variables dialog box.

SETTINGS SUBDOMAIN 2

 σ 5.998e7

 Vloop V0

SETTINGS BOUNDARY 1 BOUNDARIES 2, 3

Boundary condition Axial symmetry Magnetic insulation

Aϕ
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2 Specify the variable names and expressions according to the following tables. Use 
the default Integration order 4 and keep the Destination global check boxes selected. 
Put each coupling variable on a separate row in the table on the Source tab.

3 Click OK.

Expression Variables
Expression variables are used for completing the inductance and resistance 
calculations.

1 Select Expressions>Scalar Expressions from the Options menu to open the Scalar 
Expressions dialog box.

2 Specify the variable names and expressions according to the following table.

3 Click OK.

M E S H  G E N E R A T I O N

In this model, as in many others dealing with electromagnetic phenomena, the effects 
on the fields near interfaces between materials are of special interest. To get accurate 
results make sure you generate a mesh that is very fine in these areas. To achieve this, 
refine the mesh once.

1 Select Initialize Mesh in the Mesh menu or use the corresponding button on the main 
toolbar above the main axes area to generate a mesh.

2 Select Refine Mesh in the Mesh menu or use the corresponding button on the main 
toolbar.

SETTING SUBDOMAINS 1, 2

Wm 2*pi*r*Wmav_emqa

SETTING SUBDOMAIN 2

Itot Jphi_emqa

NAME EXPRESSION

L_w 4*Wm/abs(Itot)^2

L_e imag(V0/Itot)/(2*pi*freq)

Resist real(V0/Itot)
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3 To see the mesh in the interesting region better, select Zoom Window from the 
Options menu. You can now draw a rectangular window around the coil and the 
cylinder to get a better view of the mesh.

Figure 4-14: The mesh for the inductance computation.

C O M P U T I N G  T H E  S O L U T I O N

1 Open the Solver Parameters dialog box by selecting Solver Parameters in the Solve 

menu, or by clicking the Solver Parameters button. In the Solver list, select 
Parametric. Type freq in the Parameter name edit field, and 
linspace(10,2000,20) in the Parameter values edit field. This means that the 
solution is computed for 20 equally-spaced values of freq, running from 10 Hz 
through 2000 Hz.

2 Click OK to close the dialog box.

3 Select Solve in the Solve menu, or click the Solve button, to compute the solution.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

After the solution is calculated, a surface plot is automatically shown for the magnetic 
flux density. The buttons on the plot toolbar are shortcuts to get plots of other types. 
Full control over the plot generation is provided in the Plot Parameters dialog box.
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1 Select Plot Parameters from the Postprocessing menu to open the Plot Parameters 
dialog box.

2 In the Plot type area on the General page, select the Surface and Geometry edges check 
boxes.

3 On the Surface page, set the Surface Expression from the list of predefined quantities 
to Total current density, phi component (Jphi_emqa).

4 Click Apply to generate the plot.

5 By default, the plot is rendered for the last entry in the frequency list. To view 
another solution, select the desired frequency from the Parameter value list on the 
General page. Click OK to generate the plot and close the dialog box.

The resistance and the inductance are calculated for all frequencies and can be 
visualized using point plots.

1 Open the Cross-Section Plot Parameters dialog box from the Postprocessing menu. 
On the General page, click Point plot and mark all the solutions. 

2 On the Point page, type Resist in the Expression edit field. The coordinates can be 
left at their default values. The value of the resistance is evaluated at the specified 
coordinates, but Resist is a scalar variable and its value is therefore independent of 
which coordinates you use, as long as they are inside the geometry. 

3 Click Apply to generate a plot of the resistance as a function of the frequency.

Figure 4-15: Resistance (Ω) as a function of frequency (Hz).

You can visualize the calculated values of the inductance in the same way as the 
resistance; Figure 4-12 on page 133, for example, shows the result for Lw, the 
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inductance calculated using the method of virtual work. To reproduce this plot in a 
new figure window do as follows:

4 Click the General tab, then select New figure from the Plot in list.

5 Return to the Point page. In the Expression edit field type L_w, then click Apply.

The relative difference between the results from the two calculation methods for the 
inductance gives an indication of the errors introduced from the discretization and 
the finite geometry. Visualize this entity by executing the following instructions:

6 Click the General tab, then select New figure from the Plot in list.

7 Return to the Point page. In the Expression edit field type abs((L_w-L_e)/L_w), 
then click OK.
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I n t e g r a t e d  S qua r e - S h ap ed S p i r a l  
I n du c t o r

Introduction

This example presents a model of a micro-scale square inductor, used for LC bandpass 
filters in microelectromechanical systems (MEMS).

The modeling is carried out in two steps. Because this is a static simulation, it is 
possible to compute the electric and magnetic fields separately. The first step computes 
the currents in the inductor. You then introduce these currents as sources for the 
magnetic flux computations in a second step.

The purpose of the model is to calculate the self-inductance of the micro-inductor. 
Given the magnetic field, you can compute the self-inductance, L, from the relation

where Wm is the magnetic energy, and I is the current. This model includes a boundary 
condition that sets the current to 1. The self-inductance L is the L11 component of the 
inductance matrix and is available as a predefined variable (L11_emqa) for 
postprocessing.

Model Definition

The model geometry consists of the spiral-shaped inductor and the air surrounding it. 
The subdomain corresponding to air can be done arbitrary large depending on the 
position of the device. Figure 4-16 below shows the inductor and air subdomains used 
in the model. The outer dimensions of the model geometry are around 0.3 mm.

L
2Wm

I2
-------------=
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Figure 4-16: Inductor geometry and the surrounding subdomain.

The model equations are the following:

In the equations above, σ denotes the electric conductivity, A the magnetic vector 
potential, V the electric scalar potential, Je the externally generated current density 
vector, µ0 the permittivity in vacuum, and µr the relative permeability.

The electric conductivity in the coil is set to 106 S/m and 1 S/m in air. The 
conductivity of air is arbitrarily set to a small value in order to avoid singularities in the 
solution, but the error becomes small as long as the value of the conductivity is small.

The constitutive relation is specified with the following expression:

where H denotes the magnetic field.

∇– σ∇V Je
–( )⋅ 0=

∇ µ0
1– µr

1– ∇ A×( )× σ V∇+ Je
=

B µ0µrH=
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The boundary conditions are of three different types corresponding to the three 
different boundary groups; see Figure 4-17 (a), (b), and (c) below.

Figure 4-17: Boundaries with the same type of boundary conditions.

The boundary condition for the boundary highlighted in Figure 4-17 (a) is a magnetic 
insulating boundary with a port boundary condition. For the boundaries in 
Figure 4-17 (b), both magnetic and electric insulation prevail. The last set of boundary 
conditions, Figure 4-17 (c), are magnetically insulating but set to a constant potential 
of 0 V (ground).

(b)(a)

(c)
I N T E G R A T E D  S Q U A R E - S H A P E D  S P I R A L  I N D U C T O R  |  143



144 |  C H A P T E R
Results

Figure 4-18 shows the electric potential in the inductor and the magnetic flux lines. 
The thickness of the flow lines represents the magnitude of the magnetic flux. As 
expected this flux is largest in the middle of the inductor.

Figure 4-18: Electric potential in the device and magnetic flux lines around the device.

The model gives a self-inductance of 7.21e-10 H.

Model Library path: ACDC_Module/Electrical_Components/inductor

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics.

2 In the Model Navigator click the Multiphysics button.

3 Select 3D from the Space dimension list.
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4 Select the AC/DC Module>Statics>Magnetostatics application mode.

5 Click the Add button.

6 Open the Application Mode Properties dialog box by clicking the corresponding 
button.

7 Set the property Potentials to Electric and magnetic.

8 Click OK.

O P T I O N S  A N D  S E T T I N G S

Give the axis settings according to the following table.

AXIS MIN MAX

x -50 300

y -50 300

z -25 25
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G E O M E T R Y  M O D E L I N G

1 Start the modeling of this geometry by creating a number of solid block objects that 
form the base of the inductor. Use the data for the blocks according to the table 
below.

The geometry in the drawing area should now look like that in the following 
picture.

NAME LENGTH AXIS BASE POINT

X Y Z X Y Z

BLK1 51 22 20 -20 99 0

BLK2 22 98 20 9 121 0

BLK3 232 22 20 9 219 0

BLK4 22 188 20 219 31 0

BKL5 192 22 20 49 9 0

BLK6 22 148 20 49 31 0

BLK7 152 22 20 49 179 0

BLK8 22 108 20 179 71 0

BLK9 112 22 20 89 49 0

BLK10 22 68 20 89 71 0

BLK11 62 22 20 89 139 0

BLK12 51 22 20 249 139 0
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2 From the Draw menu, open the Work-Plane Settings dialog box and choose BLK12 
face number 3 on the Face Parallel tab.

3 Give the axis and grid setting as in the following table.

4 Click the Line button on the Draw toolbar, and click at (−27, −120), (−27, 22), 
(0, 22), (0, 0), (−5, 0), (−5, −98), (0, −98), and (0, −120). Finally right-click to 
create a composite solid object.

5 Open the Extrude dialog box and set the Distance to 22. Click OK to create the 
extruded object.

6 Select all geometry objects, by using the Select all option from the Edit menu. Then 
open the Create Composite Object dialog box. Be sure to clear the Keep interior 

boundaries check box, and verify that all objects are selected. Then click OK to create 
the composite object as the union of all objects. 

AXIS GRID

x min -30 x spacing 5

x max 10 Extra x -27

y min -130 y spacing 5

y max 30 Extra y -98 22
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7 Now, draw a block that surrounds the inductor. Set the length of the sides to 320, 
300, and 200, for the x-, y-, and z-coordinates respectively. Set the axis base point 
to (−20, −25, −100).

8 Select both the block object and the composite object CO1 by using the Shift key.

9 Open the Create Composite Object dialog box. Select the Keep interior boundaries 
check box and click OK.

10 All distances in this model are given in µm, so you must scale the geometry with a 
factor of 10−6 in order to obtain the correct size. Do this by clicking the Scale 
button, and then giving the value 1e-6 for all three scaling factors. After that, click 
the Zoom Extents button on the Main toolbar to be able to see the object.

P H Y S I C S  S E T T I N G S

Subdomain Settings
Enter the following values in the Subdomain Settings dialog box and then click OK.

Setting the conductivity to zero in air (Subdomain 1) would lead to a numerically 
singular problem. Therefore the conductivity is arbitrarily set to 1 S/m. Although not 

SETTINGS SUBDOMAIN 1 SUBDOMAIN 2

σ 1 1e6
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physically correct, this value is much smaller than the electric conductivity in the 
inductor, 106 S/m. The electric and magnetic fields are only marginally affected by the 
value of the conductivity in air as long as it is small.

Boundary Conditions
Choose Boundary Settings from the Physics menu, and set the boundary conditions 
according to the following table.

The Boundaries 5 and 76 are the two ends of the inductor. When finished, click OK.

M E S H  G E N E R A T I O N

1 Open the Free Mesh Parameters dialog box from the Mesh menu.

2 On the Global page, select Coarser from the Predefined mesh sizes list.

3 Click the Subdomain tab. Select Subdomain 2 and type 3e-5 in the Maximum element 

size edit field.

4 Click the Remesh button to generate the mesh. Click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar to start solving

This model uses an efficient approach for handling the gauge fixing with the SOR 
gauge smoothers for the geometric multigrid preconditioner; see “Solver Settings for 
Numerical Gauge Fixing in Magnetostatics” on page 92 in the AC/DC Module User’s 
Guide for more information.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Now add a visualization of the magnetic flux density lines to illustrate the results from 
the simulation.

1 From the Options menu, choose Suppress>Suppress Boundaries.

2 In the Suppress Boundaries dialog box, select Boundaries 1–4, 10, and 75. Click OK.

3 Open the Plot Parameters dialog box and clear the Slice and Geometry edges check 
boxes, and select Streamline and Boundary as plot types.

SETTINGS BOUNDARY 5 BOUNDARIES 75,76 BOUNDARIES 1, 2, 3, 4, 10

Electric Parameters Port Ground Electric 
insulation

Magnetic Parameters Magnetic 
insulation

Magnetic 
insulation

Magnetic 
insulation

Port tab Use port as inport
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4 On the Boundary page, set the Boundary expression to V.

5 Click the Streamline tab and choose the Magnetic flux density as Streamline data and 
set the Number of start points to 31.

6 Then change the Line type to Tube and click the Tube Radius button. Select the Radius 

data check box and select Magnetic flux density, norm as Radius data. Set the Radius 

scale factor to 0.7. Click OK to close the Tube Radius Parameters dialog box.

7 Click the Use expression to color streamlines option button.

8 Click the Color Expression button and select Electric potential as Streamline color data. 
Clear the Color scale check box. Click OK to close the Streamline Color Expression 
dialog box.

9 Click the Advanced button and set the Maximum number of integration steps to 100. 
Click OK to close the Advanced Streamline Parameters dialog box.

10 Click OK to close the Plot Parameters dialog box.

11 For improved visualization click the Headlight button on the Camera toolbar.

To extract the self-inductance, select Data Display>Global from the Postprocessing menu 
and then type L11_emqa in the Expression edit field, or:

1 Open the Domain Plot Parameters dialog box from the Postprocessing menu.

2 Click the Point tab and plot Inductance matrix, element 11.
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Modeling Using the Programming Language

You can create the Inductor model from COMSOL Script or MATLAB using 
COMSOL Multiphysics command-line functions. The following script contains all the 
steps for defining the model, computing the solution, visualizing the results, and 
evaluating the inductance:

% Start by defining the geometry.
clear fem
g = { ...
    block3(51,22,20,'corner',[-20 99 0]),...
    block3(22,98,20,'corner',[9 121 0]),...
    block3(232,22,20,'corner',[9 219 0]),...
    block3(22,188,20,'corner',[219 31 0]),...
    block3(192,22,20,'corner',[49 9 0]),...
    block3(22,148,20,'corner',[49 31 0]),...
    block3(152,22,20,'corner',[49 179 0]),...
    block3(22,108,20,'corner',[179 71 0]),...
    block3(112,22,20,'corner',[89 49 0]),...
    block3(22,68,20,'corner',[89 71 0]),...
    block3(62,22,20,'corner',[89 139 0]),...
    block3(51,22,20,'corner',[249 139 0]),...
  };

l2 = line2([-25 -25 0 0 -5 -5 0 0],[-120 22 22 0 0 -98 -98 -120]);

g{end+1} = extrude(l2,'Distance',22,...
    'Wrkpln',[249 249 600;139 139 139;0 351 0]);

co1 = geomcomp(g,'face','all','edge','all');

b1 = block3(320,300,200,'corner',[-20 -25 -100]);

co2 = geomcomp({co1 b1});

fem.geom = scale(co2,1e-6,1e-6,1e-6);

% The physical properties of the model is defined in the 
% application mode structure. Continue the modeling by creating 
% this structure. The commands to use are given below.
clear appl

appl.mode='QuasiStatics';
appl.prop.analysis='static';

appl.equ.sigma={'1','1e6'};

appl.bnd.inport={'1','0','0'};
appl.bnd.eltype={'port','V0','nJ0'};
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appl.bnd.magtype='A0';
appl.bnd.ind=zeros(1,76);
appl.bnd.ind([5])=1;
appl.bnd.ind([75 76])=2;
appl.bnd.ind([1 2 3 4 10])=3;

fem.appl=appl;

fem=multiphysics(fem);

% Generate the mesh, by issuing the following command.
fem.mesh=meshinit(fem, ...
  'hauto',7, ...
  'hmaxsub',[2,3e-5]);

% Generate the extended mesh structure.
fem.xmesh=meshextend(fem);

% You can now solve the problem.
fem.sol=femlin(fem);

% Visualize the result of the simulation, with the following 
% properties to the plot function.
nBdl = setdiff(1:76,[1:4 10 75]);
postplot(fem,...
  'bdl',nBdl,...
  'cont', 'internal',...
  'tridata','V',...
  'tribar', 'on',...
  'flowtubescale',0.3,...
  'flowcolor','k',...
  'flowdata',{'Bx','By','Bz'},...
  'flowlines',50,...
  'flowback','off',...
  'flowsteps',150,...
  'scenelight','on',...
  'axisequal','on',...
  'axisvisible','off');

% The inductance can be calculated with the command
inductance=postinterp(fem,'L11',[0;0;0]);
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I n du c t a n c e  o f  a  Powe r  I n du c t o r

The model shows an inductance calculation on a large 3D geometry using 
higher-order vector elements and memory-efficient iterative solver settings.

Introduction

Power inductors are a central part of many low-frequency power applications. They 
are, for example, used in switched power supplies and DC-DC converters. The 
inductor is used in conjunction with a high-power semiconductor switch that operates 
at a certain frequency, stepping up or down the voltage on the output. The relative low 
voltage and high power consumption puts high demands on the design of the power 
supply and especially on the inductor, which must be designed with respect to 
switching frequency, current rating, and warm environments.

A power inductor usually has a magnetic core to increase its inductance value, reducing 
the demands for a high frequency while keeping the sizes small. The magnetic core also 
reduces the electromagnetic interference with other devices. There are only crude 
analytical formulas or empirical formulas available for calculating impedances, so 
computer simulations or measurements are necessary in the design of these inductors. 
This model uses a design drawn in an external CAD software, imports the geometry 
to COMSOL Multiphysics, and finally calculates the inductance from the specified 
material parameters and frequency.

Model Definition

The model uses the Quasi-static application mode taking electric induced and 
inductively induced currents into account. This formulation, often referred to as an AV 
formulation, solves both for the magnetic vector potential A and the electric potential 
V. In addition, it must also solve for the Gauge fixing on the vector potential,

At low frequencies the inductance is almost constant. For high frequencies the 
capacitive effects play a role, and the permeability usually decreases, causing a 
frequency-dependent inductance. A model limiting factor in increasing the frequency 
is the skin depth, so at a frequency in the vicinity of 10 kHz the model either needs a 

∇ A⋅ 0=
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finer mesh at the conductor boundary or an impedance boundary condition. The 
following table lists the material properties used in this model.

Using a low conductivity for the surrounding air improves the stability of the iterative 
solver. This has negligible impact on the solution.

The outer boundaries are mainly magnetic insulation and electric insulation,

For the boundaries to the conductor, one end is grounded, and the other end has a 
port boundary condition. The port boundary condition gives the impedance of the 
inductor, and you can calculate the inductance from the formula,

where ω is the angular frequency, and Im(Z11) is the imaginary part of the impedance.

C O M P U T I N G  T H E  S O L U T I O N

An analysis using the AV formulation with gauge fixing turned on consumes large 
amounts of memory when you use direct solvers like UMFPACK or SPOOLES. This 
model has almost 200,000 degrees of freedom, so an iterative solver is necessary. The 
geometric multigrid (GMG) solver with the Vanka pre- and postsmoother solves this 
problem efficiently. Different element order defines the multigrid hierarchy, which 
means that a direct solver solves the problem on linear vector and Lagrange elements. 
The iterative solver then produce the solution for the quadratic versions of these 
elements.

MATERIAL PARAMETER COPPER CORE

 σ 5.997·107 10

 εr 1 1

 µr 1 103

n A× 0=

n J⋅ 0=

L11
Im Z11( )

ω
----------------------=
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Results and Discussion

At a frequency of 1 kHz the inductance is 97 µH, and the figure below shows the 
electric potential and the magnetic flux density in a combined plot.

Figure 4-19: The final plot of the power inductor, showing the potential on the coil, the 
magnitude of the flux density inside the ferrite core, and the direction of the same as 
arrows.

Model Library path: ACDC_Module/Electrical_Components/power_inductor

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select 3D in the Space dimension list.

2 In the list of application modes, select AC/DC Module>Quasi-Statics, 

Electromagnetic>Electric and Induction Currents.

3 Click OK.
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O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, choose Material/Coefficient Library. In the dialog box that 
appears, click the New button.

2 Type Core in the Name edit field for the new material.

3 Click the Electric tab and type the values for each material parameter listed in the 
table below.

4 Click OK.

G E O M E T R Y  M O D E L I N G

1 From the File menu, choose Import>CAD Data From File.

2 In the Import CAD Data From File dialog box, make sure that the COMSOL Multiphysics 

file or All 3D CAD files is selected in the Files of type list.

MATERIAL PARAMETER CORE

 σ 10

 εr 1

 µr 1e3
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3 Locate the power_inductor.mphbin file in the model path specified on page 155, 
and click Import.

4 From the Draw menu, choose Block.

5 In the dialog box that appears, define the block properties according to the table 
below.

P H Y S I C S  S E T T I N G S

Scalar Variables
1 Open the Scalar Variables dialog box from the Physics menu.

2 Type 1e3 for the frequency, nu_emqav. Click OK.

Subdomain Settings
1 Open the Subdomain Settings dialog box from the Physics menu.

2 Select Subdomain 1 and click Electric Parameters tab. Type 1 in the edit field for the 
electric conductivity.

3 Select Subdomain 2 and select Core from the Materials list. This is the material you 
defined in the Materials library earlier.

LENGTH X LENGTH Y LENGTH Z BASE AXIS BASE POINT (X, Y, Z)

0.15 0.12 0.2 Corner (-0.07,-0.031,-0.1)
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4 Select Subdomain 3 and click the Load button. Locate and select Copper in the dialog 
box and click OK.

5 Click OK again to close the Subdomain Settings dialog box.

Boundary Conditions
1 Open the Boundary Settings dialog box from the Physics menu.

2 Select all boundaries and make sure that the default Magnetic insulation is selected 
from the Boundary condition list.

3 Click the Electric Parameters tab. Select Electric insulation from the Boundary 

condition list.

4 Select Boundary 78, which is one of the boundaries for the inductor coil. Choose 
the Ground boundary condition from the Boundary condition list.

5 Select the other coil boundary, which is number 79. Select the Port boundary 
condition.

6 Next, click the Port tab, and select the Use port as input check box. Leave the other 
settings at their defaults, which is 1 for Port number and Fixed current density for 
Input property.

7 Click OK.

M E S H  G E N E R A T I O N

1 Open the Free Mesh Parameters dialog box from the Mesh menu.

2 Select Coarse mesh size from the Predefined mesh sizes list, and click the Custom mesh 

size option button.

3 Type 1.8 in the Element growth rate edit field, 0.4 in the Mesh curvature factor edit 
field, and type 0.02 in the Mesh curvature cutoff edit field.

4 Click Remesh and then click OK.

C O M P U T I N G  T H E  S O L U T I O N

The program can use the linear order element combination for a coarse solution and 
solve for the quadratic elements using the geometric multigrid solver. The linear 
solution is then used in the preconditioning step. COMSOL Multiphysics does this 
automatically with the setting selected in step 3.

1 Open the Solver Parameters dialog box from the Solve menu.

2 Click the Settings button. In the dialog box that appears, make sure that Linear 

system solver is selected in the field to the left. Then enter 20 in the Factor in error 

estimate edit field.
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3 Select Coarse solver from the field. Choose PARDISO from the Coarse solver list. Set 
the Tolerance to 1.0e-5.

4 All other settings can be left at their default values. For details on the default 
settings, see “Solving Large 3D Problems” on page 84 of the AC/DC Module 
User’s Guide.

5 Click OK to close the Linear System Solver Settings dialog.

6 Click the Stationary tab, and then select Linear in the Linearity list. This model is 
linear, but the solver interprets the model as nonlinear, because of the coupling 
variable that the port condition introduces. Furthermore, with the additional 
dependent variable for the gauge fixing, the model has large differences in scale, 
which makes it difficult for the nonlinear solver to converge.

7 Click the Solve button.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Select Plot Parameters from the Postprocessing menu.

2 Make sure that the Slice, Boundary, Arrow, and Geometry edges check boxes are 
selected under the General tab.

3 Click on the Slice tab, and select Magnetic flux density, norm from the Predefined 

quantities list.

4 Type 1 in the x levels edit field.

5 Click on the Boundary tab, and select Electric potential from the Predefined quantities 
list.

6 Click the Arrow tab, and select Magnetic flux density from the Predefined quantities 
list.

7 In the x points, y points, and z points edit fields for the Number of points, type 20, 7, 
and 20, respectively.

8 Select the Cone in the Arrow type list.

9 Click OK.

10 It is now necessary to remove some boundaries and subdomains from the plot. 
From the Options menu choose Suppress>Boundaries. Select all boundaries that are 
part of the coil. Click Apply, then click the Invert Suppression button, and finally click 
Cancel.

11 From the Options menu, choose Suppress>Subdomains. Select Subdomain 1 and click 
OK.
I N D U C T A N C E  O F  A  P O W E R  I N D U C T O R  |  159



160 |  C H A P T E R
12 Click on the Postprocessing mode button, and the plot in Figure 4-19 on page 155 
should appear after proper rotation and zoom operations.

13 To get the inductance value, choose Data Display>Global from the Postprocessing 
menu. Type imag(Z11_emqav)/omega_emqav in the Expression edit field.

14 Click OK.

You should get a value close to 97 µH in the message log at the bottom of the user 
interface.
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Bond i n g  W i r e s  t o  a  Ch i p

Electronics manufacturers use bonding wires to connect pads on an integrated circuit 
(IC) to the pins of the package that houses it. These bonding wires introduce relatively 
large inductances that can introduce crosstalk and signal distortion. This model 
calculates the inductance and the mutual inductance between several bonding wires.

Introduction

In today’s electrical systems, high-speed communications place high demands on the 
packages that allow the connection of an IC to a circuit board. The most common 
method is to use bonding wires, which connect the pads on a semiconductor chip to 
the pins of a package. These bonding wires introduce relatively large inductances that 
can result in crosstalk and signal distortion. This model investigates the inductance of 
single wires and the mutual inductance between several bonding wires. The model 
extracts these parameters and presents them in the form of a lumped-parameter matrix, 
from which you can determine an impedance value. In addition, the harmonic nature 
of the signals results in a complex-valued matrix. Although the model extracts 
admittance or impedance parameters, you can also convert them to an S-parameter 
matrix.

Model Definition

B O N D I N G - W I R E  M O D E L

Each bonding wire carries a current that results from an applied current. One end of 
the wire connects to the package, and the other end connects to a small pad on a chip; 
these pads cause a capacitive load (not included in this model). This example studies 
four wires at the corner of a package (Figure 4-20).
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Figure 4-20: The model geometry, which studies the corner of an IC where four bonding 
wires connect a chip to a package.

The model tackles the problem using the Quasi-Statics, Electromagnetic application 
mode, where the solution variables are the electrostatic potential, V, and the magnetic 
vector potential, A. Each wire has a finite conductivity, which the model handles as a 
separate subdomain. Because this simulation investigates effects due to the wire, it 
excludes any effects from vias (vertical interconnections between layers in a multilayer 
circuit board) and pins in the package. As a result, the model applies the potential 
directly to the boundary on a side of the package close to the wire, whose other side 
ties to the chip. The chip is modeled as a grounded plate.

L U M P E D - P A R A M E T E R  C A L C U L A T I O N

This model uses the port boundary condition with the fixed current density mode to 
model the terminals that connects each bonding wire. The fixed current density mode 
sets a fixed current density, so the total current gets equal to 1 A. The voltage is taken 
as the average over each port boundary.

The extracted voltages represent a column in the impedance matrix, Z, which 
determines the relationship between the applied currents and the corresponding 
voltages with the formula
 4 :  E L E C T R I C A L  C O M P O N E N T  M O D E L S



.

Thus, when I1 = 1 and all the other currents are zero, the V vector equals the first 
column of Z. You get the full matrix by setting each of the currents to one. With this 
matrix, you can calculate other types of parameter matrices. For more information on 
lumped parameter calculations in the AC/DC Module, see “Lumped Parameters” on 
page 61 in the AC/DC Module User’s Guide.

To calculate the entire matrix, you must export the model’s entire FEM structure to 
the COMSOL Script command line. A function called rlcmatrix performs the 
calculation, which solves all the necessary port conditions to extract the parameter 
matrix. See the function rlcmatrix on page 117 in the on-line manual AC/DC 
Module Reference Guide for more information.

Results and Discussion

The inductive effects clearly dominate in this model. At a frequency of 10 MHz, the 
inductance matrix is

(in nH)

where the model calculates L from the imaginary part of the impedance matrix, Z, 
using the relationship imag(  Z ) = ω L. The L matrix is symmetric, which is a property 
most lumped parameter matrices have.

It is always important to check the extracted Z matrix before analyzing the other 
parameters, especially the ratio between the real and complex parts, and the condition 
number of the matrix. Furthermore, the boundary conditions create mirror wires 
outside the simulation domain, and they influence the extracted parameters.

V1

V2

V4

V4

Z11 Z12 Z13 Z14

Z21 Z22 Z23 Z24

Z31 Z32 Z33 Z34

Z41 Z42 Z43 Z44

I1

I2

I3

I4

⋅=

L

2.6 0.59 0.0052 0.0039
0.59 3.5 0.029 0.015

0.0052 0.029 3.7 0.96
0.0039 0.015 0.96 3.5

=
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Figure 4-21: This plot shows a slice plot, an arrow plot of the magnetic flux density, and a 
boundary plot of the current density. For this solution, the third bonding wire is used as 
input, giving the third column in the parameter matrix.

Model Library path: ACDC_Module/Electrical_Components/
bond_wires_to_chip

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 In the Model Navigator, select 3D in the Space dimension list.

2 In the AC/DC Module>Quasi-Statics, Electromagnetic folder, select the Electric and 

Induction Currents application mode.

3 Select Vector - Linear from the Element list.

4 Click OK.
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O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, choose Constants.

2 In the Constants dialog box, define the following constants with names, expressions, 
and descriptions (optional):

3 Click OK.

G E O M E T R Y  M O D E L I N G

1 From the File menu, select Import>CAD Data From File.

2 In the Import CAD Data From File dialog box, make sure that the COMSOL native 

format or All 3D CAD files is selected in the Files of type list.

3 Locate the bond_wires_to_chip.mphbin file, and click Import.

4 Click the Zoom Extents toolbar button.

P H Y S I C S  S E T T I N G S

Scalar Variables
1 From the Physics menu, choose Scalar Variables.

2 In the Scalar Variables dialog box, change the value of the frequency, nu_emqav, to 
10e6.

3 Click OK.

Subdomain Settings
1 From the Physics menu, open the Subdomain Settings dialog box.

2 Define the subdomain settings according to the following table:

3 Click OK.

Boundary Conditions
1 From the Physics menu, open the Boundary Settings dialog box.

NAME EXPRESSION DESCRIPTION

epsilonr_pcb 2.5 Relative permittivity of package material

sigma_pcb 10 Conductivity of package material (S/m)

 SETTINGS SUBDOMAINS 1, 4, 5 SUBDOMAIN 2 SUBDOMAINS 6–13

 Material Silicon Aluminum

 er epsilonr_pcb

 σ sigma_pcb
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2 Select all boundaries, click the Electrical Parameters tab, and select the Electric 

insulation boundary condition from the Boundary Condition list.

3 Select the Interior boundaries check box to allow settings on interior boundaries.

4 Enter the other boundary settings according the following two tables (leave all fields 
not specified at their default values):

5 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu choose Free Mesh Parameters.

SETTINGS BOUNDARY 30 BOUNDARY 42

Electric boundary condition Port Port

Port number 1 2

Use port as input cleared cleared

Input property Fixed current density Fixed current density

SETTINGS BOUNDARY 81 BOUNDARY 80 BOUNDARIES 33, 45, 50, 52

Magnetic boundary 
condition

Magnetic 
insulation

Magnetic 
insulation

Magnetic insulation

Electric boundary condition Port Port Ground

Port number 3 4

Use port as input selected cleared

Input property Fixed current 
density

Fixed current 
density
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2 In the Element growth rate edit field type 1.4.

3 Click the Remesh button, then click OK.

4 From the Options menu select Suppress>Suppress Boundaries. Select Boundaries 7, 8, 
10, 24, and 79. Click OK. Click the Mesh mode button to see the following figure.

C O M P U T I N G  T H E  S O L U T I O N

1 From the Solve menu, choose Solver Parameters.

2 From the Linear solver list, select the GMRES solver.

3 From the Preconditioner list, select Vanka.

4 Click the Settings button.

5 In the Linear System Settings dialog box, enter 10 in the Factor in error estimate edit 
field and 200 in the Number of iterations before restart edit field.

6 Select Preconditioner for the tree view, and enter 3 in the Number of iterations edit 
field.

7 Click OK.

8 Click OK to close the Solver Parameters dialog box.

9 Click the Solve button on the Main toolbar.
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PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 From the Postprocessing menu select Plot Parameters.

2 Make sure that the Slice, Boundary, Arrow, and Geometry edges check boxes are 
selected under the General tab.

3 Click the Slice tab, then select Magnetic flux density, norm from the Predefined 

quantities list.

4 Type 0 in the x levels edit field. Click the Vector with coordinates option button for 
the y levels. Enter 4e-3 in the corresponding edit field.

5 Click the Boundary tab, and type nJ_emqav*(nJ_emqav<5e6)+ 

5e6*(nJ_emqav>=5e6) in the Expression edit field.

6 Click the Range button. Clear the Auto check box and type 0 and 5e6 in the Min and 
Max edit fields, respectively. Click OK.

7 Click the Arrow tab, then select Magnetic flux density from the Predefined quantities 
list.

8 Click the Vector with coordinates option button for the y points. Type the coordinate 
3.9e-3 in the edit field next to that option button.

9 In the x points and z points edit fields for the Number of points type 40.

10 Select the 3D arrow in the Arrow type list.

11 Click the Color button, then select the white color from the palette. Click OK.

12 Click OK in the Plot Parameters dialog box to get the plot in Figure 4-21 on page 
164.

Modeling Using the Programming Language

Note: This section requires COMSOL Script or MATLAB.

P A R A M E T E R - M A T R I X  C A L C U L A T I O N

The rlcmatrix function goes through all the port boundary conditions, setting the 
Use port as input property on one port at a time, and solves the problem. To execute 
this script, you first need to export the FEM structure to the COMSOL Script 
command line. Do the following steps to get the full Z lumped parameter matrix. Note 
that this requires a 64-bit platform, and that the calculation of the matrix takes about 
2 hours.
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1 Export the FEM structure by pressing Ctrl+F. The COMSOL Script window opens 
automatically.

2 Enter the following at the command prompt:

Z = rlcmatrix(fem,'Z');
freq = postint(fem,'nu_emqav','edim',0,'dl',1);
L = imag(Z)/(2*pi*freq)*1e9

The output reads

L = 

     2.6482     0.5944     0.0052     0.0039
     0.5944     3.4833     0.0285     0.0149
     0.0052     0.0285     3.6593     0.9607
     0.0039     0.0149     0.9607     3.4919

This is the inductance matrix given in nH presented in “Results and Discussion” on 
page 163.
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H i gh Cu r r e n t  C ab l e s  i n  a  C i r c u i t

This model connects two high current cables to a battery in a battery charger circuit.

Introduction

When charging a car battery, a significant amount of current can pass in the cables from 
the charger to the battery. The cable has two sensitive areas that cause additional 
voltage drop; the junction between the copper wire and the clip, and the contact 
junction at the battery pole. See Figure 4-22 for a complete view over the system. At 
high currents these junctions produce a lot of heat, which can melt the cables if the 
junctions suffer from high contact resistances. The contact resistance can degrade in 
corrosive enviorments.

Figure 4-22: A view of the entire system, where the cables, clips, and poles are modeled in 
a physical model. All other components are modeled as circuit models.

Model Definition

This model uses simple circuit models for the charger and the battery. A physical model 
in a separate model file contains the copper wire, clip and battery pole. Because the 
two cables between the battery and charger are identical, two instances of this separate 
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model file represent the cables. The circuit models and the two identical physical 
models then represent the entire system.

The circuit model of the charger is simply a voltage source with a resistor in series. The 
resistor has a low value, so a significant amount of current can be delivered from the 
charger. The battery circuit model is also a voltage source but without the series 
resistor, because it can be neglected in comparison to the series resistor of the charger. 
As mentioned previously, the cables originate from the same COMSOL Multiphysics 
model, implementing two subcircuit instances in the circuit. The cable on the minus 
side of the battery also has a resistor in parallel, representing the alternative current 
paths to ground.

Figure 4-23: A block diagram over the entire charger system.

The physical model of the cable uses an imported geometry created in SolidWorks®, 
which was directly imported to COMSOL Multiphysics using the SolidWorks direct 
connection. After importing the geometry, it was exported to the COMSOL native 
format (an mphbin-file) for easier access. The cable geometry consists of a copper 
cable, a clip, and a battery pole, which the software treats as separate geometry objects 
to allow assembly modeling. Assemblies are necessary to model the relatively high 
contact resistance at the junctions between the different objects, because assemblies 
allow a discontinuity in the potential.

The contact resistance depends on several properties of the junction, like contact 
pressure, ambient conditions, and surface oxides, so it is hard to find exact values of 
the quantity. The values used here are just coarse approximations, and summarized in 
Table 4-1 on page 172. You must provide the model parameters for the contact 

14.4V

0.05

+

10.5V

+

0.05

MPH Model

MPH Model
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resistance pair conditions as an equivalent interfacial layer, where the layer thickness 
has no resemblance to reality.

The boundaries connecting to the circuit use a boundary condition called Circuit 
terminal, which is specialized for circuit connections. The SPICE import automatically 
finds the circuit terminals defined in the model and connect them to the specified 
nodes in the circuit for a particular instance. All other boundaries use the electric 
insulation boundary condition.

The wire and clip are made of copper, and the battery pole is made of a lead alloy. The 
only lead alloy present in the basic material library is a solder material, so to simplify 
the modeling this material is used as the lead alloy in the battery pole. All relevant 
material properties are summarized in the table below.

The heat generated at the junctions has to be accounted for. Using the pair condition 
called Heat flux discontinuity, you can specify a heat source that is equal to the formula

where Vsrc is the voltage at the source side of the pair, and Vdst the voltage at the 
destination side. The variable Qs_emdc returns the value of the above formula if it is 
used on the boundaries of a contact resistance pair condition. The boundaries attached 
to the charger and battery are fixed at room temperature. All other boundaries have 
thermal insulation, so the dissipation to air is neglected.

Results and Discussion

When the cables are part of the charger circuit the current flowing in the cables are 
different. An electrical system using car batteries usually has the minus side of the 
battery connected to all metal parts, which represents the alternative path to ground 

TABLE 4-1:  MODEL PARAMETERS FOR THE CONTACT RESISTANCES

JUNCTION CONTACT RESISTANCE MODEL PARAMETERS

cable-clip 100 µΩcm  σ = 106 S/m, d = 1 m

clip-pole 10 µΩcm  σ = 107 S/m, d = 1 m

TABLE 4-2:  MATERIAL PARAMETERS

MATERIAL RESISTIVITY TEMPERATURE COEFFICIENT THERMAL CONDUCTIVITY

Copper 17.8 nΩm 0.0039 K-1 400 K/(m·W)

Solder, 60Sn-40Pb 499 nΩm 0.0 K-1 50 K/(m·W)

q0 dE J⋅ d
Vsrc Vdst–

d
-----------------------------σ Vsrc Vdst–( ) σ Vsrc Vdst–( )2

= = =
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in the circuit. This results in a larger current in the cable connected to the plus side of 
the battery. The following figures show the potential distribution of both cables.

Figure 4-24: The potential distribution of the cable on the plus side of the battery. Almost 
the entire voltage drop is over the two junctions.
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Figure 4-25: The potential distribution of the cable on the minus side of the battery.

Because most of the voltage drop is over the junctions, the major part of the heat 
generation is also located there. A temperature plot of both cables confirms this. 
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Especially the cable-clip junction is sensitive to heat if the cable is soldered to the clip 
(common on less expensive cables) or if the junction has suffered from corrosion.

Figure 4-26: The temperature distribution on the plus side of the battery. The area around 
the cable-clip junction gets a high temperature that can damage a soldered junction.
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Figure 4-27: The temperature distribution on the minus side of the battery. The 
distribution is less critical here due to the alternative path for the current.

Model Library path: ACDC_Module/Electrical_Components/
high_current_cables_circuit

Modeling Using the Graphical User Interface

The modeling steps below assume that the Heat Transfer Module is not present. If it 
is, the Joule Heating multiphysics node uses the Heat Transfer Module’s version of the 
Heat Transfer by Conduction application mode. As a result, some names referring to 
components in the graphical user interface are slightly different.

M O D E L  N A V I G A T O R

1 In the Model Navigator, select 3D from the Space dimension list.

2 In the AC/DC Module>Electro-Thermal Interaction folder, select the Joule Heating 
multiphysics node.
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3 Click OK.

G E O M E T R Y  M O D E L I N G

1 From the File menu, select Import>CAD Data From File.

2 In the Import CAD Data From File dialog box, make sure that the COMSOL native 

format or All 3D CAD files is selected in the Files of type list.

3 Locate the high_currect_cable.mphbin file, and click Import.

4 Click the Zoom Extents button on the Main toolbar.

5 Select all objects by pressing Ctrl+A.

6 Click the Create Pairs and Imprints button on the Draw toolbar.

P H Y S I C S  S E T T I N G S  ( C O N D U C T I V E  M E D I A  D C )

Subdomain Settings
1 From the Physics menu, open the Subdomain Settings dialog box.

2 Select subdomains 2, 3, and 4, then click the Load button.

3 In the Materials/Coefficients Library dialog box, expand the Basic Material Properties 
library and choose Copper.

4 Click OK to close the dialog box.

5 From the Conductivity relation list, choose Linear temperature relation.

6 Select subdomain 1 and click the Load button.

7 In the Materials/Coefficients Library dialog box, expand the Basic Material Properties 
library and choose Solder, 60Sn-40Pb.

8 Click OK to close the dialog box.

9 From the Conductivity relation list, choose Linear temperature relation.

10 Click OK to close the Subdomain Settings dialog box.

Boundary Conditions
1 From the Physics menu, open the Boundary Settings dialog box.

2 Select all boundaries and choose the Electric insulation boundary condition from the 
Boundary condition list.

3 Select Boundary 1 and choose Ground from the Boundary condition list.

4 Select Boundary 163, choose Electric potential, and enter 1 in the Electric potential 
edit field.

5 Click the Pairs tab and select Pair 1 (identity) from the Pair selection area.
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6 From the Boundary condition list, choose Contact resistance and enter 1e7 in the 
Electric conductivity edit field.

7 Select the second pair, Pair 2 (identity), choose Contact resistance and enter 1e6 in 
the Electric conductivity edit field.

8 Click OK.

P H Y S I C S  S E T T I N G S  ( H E A T  TR A N S F E R  B Y  C O N D U C T I O N )

Subdomain Settings
1 From the Model Tree browser, double-click on the item Geom1>Heat Transfer by 

Conduction>Subdomain Settings. This opens the Subdomain Settings dialog box for 
the Heat Transfer application mode.

2 In the dialog box, select subdomains 2, 3 and 4, then choose Copper from the Library 

material list.

3 Select Subdomain 1, and choose Solder, 60Sn-40Pb from the Library material list.

4 Click the Init tab, select all subdomains, and enter 28[degC] in the Temperature edit 
field. The unit degC specifies the unit to degrees Celsius.

5 Click OK.

Boundary Conditions
1 From the Model Tree browser, double-click on the item Geom1>Heat Transfer by 

Conduction>Boundary Settings.

2 In the Boundary Settings dialog box, select Boundaries 1 and 163, and choose 
Temperature from the Boundary condition list.

3 Enter 28[degC] in the Temperature edit field.

4 Click the Pairs tab, select both pairs and choose Heat flux discontinuity from the 
Boundary condition list.

5 Enter Qs_emdc in the Inward heat flux edit field.

6 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu choose Free Mesh Parameters.

2 Click the Boundary tab, and select Boundaries 103, 104, 167, and 168. Then enter 
1e-3 in the Maximum element size edit field.

3 Click the Remesh button, then click OK.
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C O M P U T I N G  T H E  S O L U T I O N

This is a problem that benefits from a segregated solver approach, both regarding 
stability and memory consumption.

1 From the Solve menu, choose Solver Parameters.

2 In the Solver Parameters dialog box, select the Stationary segregated solver.

3 Click the Settings button for group number 1.

4 In the Linear System Solver Settings dialog box, choose Direct (SPOOLES) from the 
Linear system solver list.

5 Click OK.

6 Click the Settings button for group number 2, and repeat step 4-5 for this group.

7 Select the Manual specification of segregated steps check box, and specify the steps 
according the following table.

8 Click OK.

9 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 From the Postprocessing menu, choose Plot Parameters.

2 In the Plot Parameters dialog box, clear the Slice check box, and select the Boundary 
check box.

3 Click the Boundary tab, and choose Conductive Media DC (emdc)>Electric potential 
from the Predefined quantities list.

GROUP DAMPING NUMBER OF ITERATIONS

2 0.8 1

1 1 2
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4 Click Apply to see the following plot.
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5 To plot the temperature, choose Heat Transfer by Convection (ht)>Temperature for 
the Predefined quantities list, and click OK.

P R E P A R I N G  F O R  C I R C U I T  C O N N E C T I O N

The following steps are a preparation for the SPICE connection, which has to be done 
before the model is used in a circuit.

Boundary Conditions
1 From the Model Tree browser, double-click on the item Geom1>Conductive Media DC 

(emdc)>Boundary Settings.

2 In the Boundary Settings dialog box, select Boundary 163 and choose Circuit terminal 
from the Boundary condition list.

3 Enter charger in the Group index edit field.
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4 Select Boundary 1 and choose Circuit terminal, then enter battery in the Group 

index edit field.

5 Click OK.

Save the Model
From the File menu, choose Save As, then choose a proper location for the file. The file 
name should be high_current_cable.mph to be compatible with the modeling steps 
in the next section.

Modeling the Entire Circuit

The following steps assume that you continue from the previous section.

M O D E L  N A V I G A T O R

1 From the File menu, choose New.

2 In the Model Navigator dialog box, click OK.

S P I C E  I M P O R T

1 From the Physics menu, choose SPICE Circuit Editor.

2 In the SPICE Circuit Editor dialog box, click the Create Voltage Source toolbar button.

3 In the Create Voltage Source dialog box, enter V1 in the Device instance name edit 
field.

4 Then enter 1 0 in the Terminal names edit field, and 14.4V in the Device value edit 
field.
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5 Click OK. You should now see the following text in the text area: V1 1 0 14.4V.

6 Click the Create Resistor toolbar button.

7 In the dialog box that appears, enter R1 in the Device instance name edit field, 1 2 
in the Terminal names edit field, and 0.05 in the Device value edit field.

8 Click OK. This adds a statement representing a resistor between nodes 1 and 2 with 
a value of 0.05 Ω.

9 Click the Create Subcircuit Instance toolbar button, enter X1 in the Device instance 

name edit field, 2 3 in the Terminal names edit field, and cable in the Subcircuit 

reference name edit field.

10 Click OK. This adds a statement representing a subcircuit instance of the subcircuit 
cable between nodes 2 and 3.

11 Click the Create Voltage Source toolbar button, enter Vbattery in the Device instance 

name edit field, 3 4 in the Terminal names edit field, and 10.5V in the Device value 
edit field.

12 Click OK. This adds the voltage source representing the battery.

13 Click the Create Subcircuit Instance toolbar button, enter X2 in the Device instance 

name edit field, 0 4 in the Terminal names edit field, and cable in the Subcircuit 

reference name edit field.

14 Click OK. This statement adds a second subcircuit instance of the same subcircuit as 
X1.

15 Click the Create Resistor toolbar button, enter R2 in the Device instance name edit 
field, 4 0 in the Terminal names edit field, and 0.05 in the Device value edit field.

16 Click OK. This statement represents the alternative paths to ground in the system.

17 Click the Create Link to Model File toolbar button, enter cable in the Subcircuit 

reference name edit field, and charger battery in the Terminal names edit field.

18 Click the Select File button.

19 In the dialog box that appears, browse to the file named high_current_cable.mph 
you saved in the previous section. As an alternative, you can also browse to the 
Model Library version of the file with the same name located in the Model Library 
path of this model.
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20 Click the Create Link button. The entire netlist should look similar to the figure 
below.

21 Click OK to close the SPICE Circuit Editor dialog box. COMSOL Multiphysics now 
adds all the global variables and ODE expression that represents the netlist. For the 
subcircuit instances, it adds the model in the model file twice as two new geometries, 
using the add component feature.

C O M P U T I N G  T H E  S O L U T I O N

This is a problem that can benefit from a segregated solver approach, both regarding 
stability and memory consumption. Scaling of the circuit variables can sometimes be 
an issue, so it is also necessary to scale them manually. You set the scaling of these 
variables an order of magnitude lower than the expected value to increase the weight 
of them in the solution of the problem.

1 From the Solve menu, choose Solver Parameters.

2 In the Solver Parameters dialog box, select the Stationary segregated solver.

3 Click the Settings button for group number 1.

4 In the Linear System Solver Settings dialog box, choose Direct (SPOOLES) from the 
Linear system solver list.

5 Click OK.
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6 In the Components edit field of group number 2, enter all solution variables except 
the temperature variable T. The list below shows the variables to enter, but you enter 
them as a space-separated list in the edit field.

SOLUTION VARIABLE

V

Vconstrbattery_g2_emdc

Vconstrcharger_g2_emdc

Vconstrbattery_g3_emdc

Vconstrcharger_g3_emdc

I0_X2_cir

I2_X1_cir

I3_X1_cir

I4_X2_cir

I_V1_cir

I_VBATTERY_cir

V1_cir
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7 Select the Manual specification of segregated steps check box, and specify the steps 
according the following table.

The dialog box at this step is shown below.

8 Click the Advanced tab.

9 From the Type of scaling list, choose Manual.

GROUP DAMPING NUMBER OF ITERATIONS

2 0.8 1

1 1 2
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10 Enter a space-separated list containing all solution variables followed by its scale. 
The entire solution variable-value pair is listed in the table below.

The beginning of the space-separated list will then be

T 300 V 10 Vconstrbattery_g2_emdc 0.1 Vconstrcharger_g2_emdc ...

11 Click OK to close the Solver Parameters dialog box.

12 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Click the Geom2 tab in the main user interface.

2 From the Postprocessing menu, choose Plot Parameters.

3 In the Plot Parameters dialog box, clear the Slice check box, and select the Boundary 
check box.

4 Click the Boundary tab, and choose Conductive Media DC (emdc)>Electric potential 
from the Predefined quantities list.

SOLUTION VARIABLE SCALE VALUE

T 300

V 10

Vconstrbattery_g2_emdc 0.1

Vconstrcharger_g2_emdc 0.1

Vconstrbattery_g3_emdc 0.1

Vconstrcharger_g3_emdc 0.1

I0_X2_cir 0.1

I2_X1_cir 0.1

I3_X1_cir 0.1

I4_X2_cir 0.1

I_V1_cir 0.1
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5 Click Apply to see the following plot, which is also shown in the section “Results and 
Discussion” on page 172.

6 Repeat these steps for the temperature and for both variables in the last geometry 
to get the other plots in the “Results and Discussion” section.
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I n du c t o r  i n  Amp l i f i e r  C i r c u i t

This model studies a finite element inductor inserted in an electrical amplifier circuit.

Introduction

Modern electronic systems are very complex and depend heavily on computer aided 
design in the development and manufacturing process. Common tools for such 
calculations are based on the SPICE format originally developed at Berkeley University 
(Ref. 1). The SPICE format consists of a standardized set of models for describing 
electrical devices—especially semiconductor devices such as transistors, diodes, and 
thyristors. SPICE also includes a simple, easy-to-read text format for circuit netlists and 
model parameter specifications. Although the netlist format is essentially the same as it 
was from the beginning, the set of models and model parameters are constantly 
changing, with new models being added according to the latest achievements in 
semiconductor device development. When the devices are scaled down, new effects 
appear that have to be properly modeled. The new models are the result of ongoing 
research in device modeling.

When an engineer is designing a new electronic component, like a capacitor or an 
inductor, the SPICE parameters for that device are not known. They are either 
extracted from finite element tools, such as COMSOL Multiphysics, or from 
measurements on a prototype. To speed up the design process it can be convenient to 
include the finite element model in the SPICE circuit simulation, calculating the device 
behavior in an actual circuit.

This model takes a simple amplifier circuit and exchanges one of its components with 
a finite element model of an inductor with a magnetic core. COMSOL Multiphysics 
calculates the transient behavior of the entire system. A script adds the circuit elements 
as ODE equations to the inductor model along with the necessary model parameters 
for the SPICE devices in the circuit.

Model Definition

The inductor model uses the Azimuthal induction currents application mode of the 
AC/DC Module, solving for the magnetic potential A.

σ A∂
t∂

------- ∇ µ0
1– µr

1– ∇ A×( )×+ Je=
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where µ0 is the permeability of vacuum, µr the relative permeability, and σ the electric 
conductivity.

Because the inductor has a large number of turns it is not efficient to model each turn 
as a separate wire. Instead the entire coil is treated as a block with a constant external 
current density corresponding to the current in each wire. The conductivity in this 
block is zero to avoid eddy currents, which is motivated with the fact that no currents 
can flow between the individual wires. The eddy currents within each wire is neglected.

C O N N E C T I O N  T O  A  S P I C E  C I R C U I T

The electrical circuit is a standard amplifier circuit with one bipolar transistor, biasing 
resistors, input filter, and output filter, see the figure below.

The input is a sine signal of 1 V and 10 kHz. The SPICE netlist for this circuit is shown 
below.

* BJT Amplifier circuit
.OPTIONS TNOM=27
.TEMP 27
Vin    1    0    sin(0 1 10kHz)
Vcc    4    0    15
Rg     1    2    100
Cin    2    3    10u
R1     4    3    47k
R2     3    0    10k
X1     4    5    inductor
RE     7    0    1k
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Cout   5    6    10u
Rl     6    0    10k
Q1     5    3    7    BJT
.MODEL BJT  NPN(Is=15f Ise=15f Isc=0 Bf=260 Br=6.1 
+ Ikf=.3 Xtb=1.5 Ne=1.3 Nc=2 Rc=1  Rb=10 Eg=1.11  
+ Cjc=7.5p Mjc=.35 Vjc=.75 Fc=.5 Cje=20p Mje=0.4 Vje=0.75
+ Vaf=75 Xtf=3 Xti=3)
.SUBCKT inductor V_coil I_coil COMSOL: *
.ENDS
.END

The device X1 refers to a subcircuit defined at the end of the file. The subcircuit 
definition is part of the SPICE standard to define blocks of circuits that can be reused 
in the main circuit. The special implementation used here defines a subcircuit that 
really is a Comsol Multiphysics model, referenced with the option 
COMSOL: <file name> | <application mode name> | *. The asterisk means that 
COMSOL Multiphysics looks for the first occurrence of the specified parameters 
V_coil and I_coil in the current model. These parameters are the variables that links 
the model with the circuits, and must be defined in the model in a certain way. The 
variable V_coil must give the voltage over the device, defined in the global scope. 
I_coil must be a global variable used in the model as a current through the device.

The script can also handle model files with more than two terminals. It is then 
necessary to define each terminal as a floating-potential boundary condition. Note that 
any use of the ground boundary condition will connect those boundaries directly to 
the ground node of the circuit, labeled 0.

The model parameters of the transistor do not correspond to a real device, but the 
numbers are nevertheless chosen so as to be realistic.

The import of the SPICE netlist does not fully support the SPICE format; especially 
for the semiconductor device models, it only supports a limited set of parameters. 
Supplying unsupported parameters does not give an error message, but the parameter 
is not used in the circuit model. For example, the transit time capacitance and the 
temperature dependence are not supported for the transistor model.

Results and Discussion

Biasing of an amplifier is often a complicated compromise, especially if you only use 
resistors. Adding an inductor as the collector impedance simplifies the biasing design, 
since the instantaneous voltage on the collector of the transistor can be higher than the 
supply voltage, which is not possible with resistors. Amplifiers using inductors can be 
quite narrow banded.
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Before starting the transient simulation, proper initial conditions have to be calculated. 
For this model it is sufficient to ramp the supply voltage to 15 V with the nonlinear 
parametric solver. After the ramp, the DC bias conditions have been calculated 
properly and this solution can be used as initial condition for the transient simulation. 
After 0.2 ms the magnetic field and contour lines of the vector potential should look 
like Figure 4-28 below.

Figure 4-28: Magnetic flux density (color) after the bias point calculation.
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Using the global variable plot, input signal, output signal, and inductor voltage can 
easily be plotted in the same graph.

Figure 4-29: Input signal (U_VIN_cir), output signal (U_RL_cir), and inductor 
voltage (U_X1_cir) as a function of time.

The output signal is about 1.5 times the input signal in amplitude.

Reference

1. “The SPICE home page,” http://bwrc.eecs.berkeley.edu/Classes/IcBook/
SPICE.

Model Library path: ACDC_Module/Electrical_Components/
amplifier_and_inductor
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Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 In the Model Navigator, select Axial symmetry (2D) from the Space dimension list.

2 In the AC/DC Module folder, select Statics>Magnetostatics>Azimuthal Induction 

Currents, Vector Potential.

3 Click OK to close the Model Navigator.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, choose Constants.

1 In the Constants dialog box, define the following constants with names and 
expressions. The description field is optional.

2 Click OK.

3 From the Options menu, choose Expressions>Global Expressions.

4 In the Global Expressions dialog box, define the following variables with names and 
expressions. The description field is optional.

5 Click OK.

G E O M E T R Y  M O D E L I N G

1 Choose Draw>Specify Objects>Circle to create a circle with the following properties:

NAME EXPRESSION DESCRIPTION

t 0[s] Time for stationary solution

N 1e3 Turns in coil

freq 10[kHz] Frequency

r_coil 0.05[mm] Wire radius in coil

sigma_coil 5e7[S/m] Wire conductivity

NAME EXPRESSION DESCRIPTION

I_coil 1[A] Current in coil

J_coil I_coil*N/A Equivalent current density in coil

NAME RADIUS BASE R Z

C1 0.03 Center 0 0
 4 :  E L E C T R I C A L  C O M P O N E N T  M O D E L S



2 Choose Draw>Specify Objects>Rectangle to create rectangles with the following 
properties:

3 Click the Zoom Extents toolbar button to see the objects.

4 Select the circle and the third rectangle (C1 and R3), and click the Intersection 
toolbar button.

5 Open the Fillet/Chamfer dialog box from the Draw menu.

6 In the dialog box, expand rectangle R1 and select Vertices 2 and 3. Then expand 
rectangle R2 and select all vertices there. Hold down the Ctrl key to do multiple 
selections.

7 In the Radius edit field type 5e-4.

8 Click OK.

P H Y S I C S  S E T T I N G S

Variables
1 From the Options menu, point to Integration Coupling Variables and click Subdomain 

Variables.

2 In the Subdomain Integration Variables dialog box, define two variables with 
integration order 4 and global destination according to the table below.

3 Click OK.

Subdomain Settings
1 Open the Subdomain Settings from the Physics menu.

2 Select Subdomain 2 and click the Load button to open the Materials/Coefficients 

Library dialog box.

NAME WIDTH HEIGHT BASE R Z

R1 5e-3 2e-2 Corner 0 -1e-2

R2 3e-3 2e-2 Corner 7.5e-3 -1e-2

R3 0.04 0.08 Corner 0 -0.04

NAME EXPRESSION IN SUBDOMAIN 3

V_coil N*2*pi*r*I_coil/(A*sigma_coil*pi*r_coil^2)

A 1
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3 In the dialog box, select the Soft Iron (without losses) material under the 
acdc_lib.txt library. (You may have to scroll both vertically and horizontally to 
see the library name.)

4 Click OK to close the Materials/Coefficients Library dialog box.

5 Select Subdomain 3 and enter J_coil in the External current density edit field.

6 Click the Init tab, select all subdomains, and type 1 in the edit field for the initial 
value.

7 Click OK.

Boundary Conditions
1 Open the Boundary Settings from the Physics menu.

2 Select Boundaries 1, 2, and 4, then choose Axial symmetry from the 
Boundary condition list. For all other boundaries keep the default condition, 
Magnetic insulation.

3 Click OK.

M E S H  G E N E R A T I O N

1 Open the Free Mesh Parameters dialog box from the Mesh menu.

2 Click the Custom mesh size option button and type 4 in the Resolution of narrow 

regions edit field.

3 Click Remesh and then OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solve button.

2 From the File menu, choose Save As. Save the model to the file name 
amplifier_and_inductor_nocircuit.mph.

This completes the first part of the model.

S P I C E  I M P O R T

1 From the Physics menu, choose SPICE Circuit Editor.

2 In the SPICE Circuit Editor dialog box, click on the Load Netlist from File toolbar 
button.

3 Browse to the file amplifier.cir, located in the model library path 
AC/DC_Module/Electrical_Components/amplifier_and_inductor.
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4 Click Import Netlist. The entire file replaces the content of the SPICE netlist text area.

5 Click OK to close the SPICE Circuit Editor dialog box.

An alternative to importing text files is to manually type in the code in the SPICE 
circuit editor:

* BJT Amplifier circuit
.OPTIONS TNOM=27
.TEMP 27
Vin    1    0    sin(0 1 10kHz)
Vcc    4    0    15
Rg     1    2    100
Cin    2    3    10u
R1     4    3    47k
R2     3    0    10k
X1     4    5    inductor
RE     7    0    1k
Cout   5    6    10u
Rl     6    0    10k
Q1     5    3    7    BJT
.MODEL BJT  NPN(Is=15f Ise=15f Isc=0 Bf=260 Br=6.1 
+ Ikf=.3 Xtb=1.5 Ne=1.3 Nc=2 Rc=1  Rb=10 Eg=1.11  
+ Cjc=7.5p Mjc=.35 Vjc=.75 Fc=.5 Cje=20p Mje=0.4 Vje=0.75
+ Vaf=75 Xtf=3 Xti=3)
.SUBCKT inductor V_coil I_coil COMSOL: *
.ENDS
.END

The model is the same as before but with global variables and ODE variables added 
that represent the amplifier circuit. The syntax of these variables are related to the 
names in the file. The variable I_R1_cir stands for the current in resistor R1, 
value_VCC_cir is the voltage value of the supply voltage generator VCC, and 
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U_X1_cir is the voltage over the device X1, which is the inductor model you created 
earlier. The variables beginning with the letter V are node potentials referenced to the 
ground node, 0, of the circuit.

As an alternative to the steps above, you can open the netlist from the model library 
path.

C O M P U T I N G  T H E  S O L U T I O N  W I T H  A  C I R C U I T

1 Open Solver Parameters from the Solve menu.

2 In the Solver Parameters dialog box, select Parametric from the Solver list.

3 In the Parameter name edit field type value_VCC_cir, and in the Parameter values 
edit field type 1:15.

4 Click OK.

5 Click the Restart button.

This solving step ramps the supply voltage stored in value_VCC_cir up to 15 V. The 
ramp is necessary to handle the highly nonlinear effects in the bipolar transistor model. 
The circuit is now at its bias point, and the plot should look like Figure 4-28 on page 
192.

Transient Case
We will now make a transient calculation. In the previous static case we have no 
induced electric field, but when we change it to a transient case, the induced electric 
field needs to be added as a contribution to the coil voltage V_coil, in addition to the 
resistive effects. In the application mode the induced electric field is available as the 
variable Ephi_emqa, and is computed as the time derivative of the magnetic potential.

1 From the Options menu point to Integration Coupling Variables and click Subdomain 

Variables.
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2 In the Subdomain Integration Variables dialog box change the expression for the 
V_coil variable so it matches the expression below.

3 Click OK.

4 Open Solver Parameters from the Solve menu.

5 In the Solver Parameters dialog box select Transient from the Analysis list.

6 Type linspace(0,5e-4,101) in the Times edit field, type 1e-4 in the Relative 

tolerance edit field, and type 1e-6 in the Absolute tolerance edit field. The last steps 
are because the accuracy obtained with default error tolerances is not sufficient in 
this model.

7 Click OK.

8 Click the Restart toolbar button.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Open Global Variables Plot from the Postprocessing menu.

2 From the Predefined quantities list select the variables U_X1_cir, U_VIN_cir, and 
U_RL_cir. Click the > button to add the selected variables to the Quantities to plot list.

NAME EXPRESSION IN SUBDOMAIN 3

V_coil N*2*pi*r*(I_coil/(sigma_coil*pi*r_coil^2)-Ephi_emqa)/A
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3 From the Solutions to use list, select all the time steps from 4e-4 to 5e-4.

4 Click the Line settings button. In the dialog box that appears, select Cycle from the 
Line marker list, and select the Legend check box. Click OK.

5 Click OK to see the plot in Figure 4-29 on page 193.
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G e n e r a l  I n d u s t r i a l  A p p l i c a t i o n  M o d e l s
In this chapter you find models of general industrial applications that do not fit 
into any of the other chapters. Typically, these models deal with eddy currents, 
electric impedance, and other static or low-to-intermediate frequency applications.
 201
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Eddy Cu r r e n t s  i n  3D

Introduction

Induced eddy currents and associated thermal loads is of interest in many high power 
AC applications. This example is of general nature and illustrates some of the involved 
physics as well as suitable modeling techniques in the AC/DC Module.

Model Definition

A metallic plate is placed near a 50 Hz AC conductor. The resulting eddy current 
distribution in the plate depends on the conductivity and permeability of the plate. 
Four different materials will be considered: copper, aluminum, stainless steel, and 
magnetic iron.The model consists of a single wire and a plate with dimensions as 
shown below.

10 mm

60 mm

100 mm

24 kA, 50 Hz

100 mm
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As you cannot afford meshing an infinite volume, it is necessary to specify a finite 
volume to mesh and solve for. In this case, it makes sense to enclose the wire and the 
plate in a cylinder with the wire on the axis of this cylinder.

The conductor is modeled as a line current with 0° phase and an effective value of 
24 kA.

In the subdomains the magnetic vector potential is calculated from

where σ is the conductivity, ε the permittivity, and µ the permeability.

An important parameter in eddy current modeling is the skin depth, δ.

jωσ ω2ε–( )A ∇ 1
µ
---∇ A×⎝ ⎠

⎛ ⎞×+ 0=

δ 2
ωµσ
-----------=
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The table below lists the skin depth for the different materials at a frequency of 50 Hz.

The combination of a high permeability and a high conductivity can make it impossible 
to resolve the skin depth when modeling. When the skin depth is small in comparison 
to the size of conducting objects, the interior of those may be excluded from the model 
and replaced with an impedance boundary condition accounting for induced surface 
currents. This condition uses the following relation between the magnetic and electric 
field at the boundary:

.

The distribution of the dissipated power, Pd, has the unit W/m2, and can be calculated 
from

where JS is the induced surface current density, and the asterisk denotes the complex 
conjugate.

MATERIAL REL. PERMEABILITY CONDUCTIVITY SKIN DEPTH

Copper 1 5.998·107 S/m 9 mm

Aluminum 1 3.774·107 S/m 12 mm

Stainless steel 1 1.137·106 S/m 67 mm

Iron 4000 1.12·107 S/m 0.34 mm

n H× ε jσ ω⁄–
µ

----------------------n E n×( )×+ 0=

Pd
1
2
--- JS E*⋅( )=
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Results and Discussion

The induced eddy current distribution for a plate made of copper is shown as 
streamlines, whereas the distribution of the ohmic losses is shown as a slice plot.

A total dissipated power of 6 W was obtained from integration through the plate. By 
repeating the simulation for different materials, the model shows that lowering the 
conductivity decreases the dissipated power. However, for high permeability materials 
like soft iron, the dissipated power is higher than in a copper despite a much lower 
conductivity.

Model Library path: AC/DC_Module/General_Industrial_Applications/
eddy_currents_3d
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Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

Create a new 3D model using the AC/DC Module>Quasi-Statics, Magnetic> 

Induction Currents application mode.

G E O M E T R Y  M O D E L I N G

The entire geometry is drawn in mm for simplicity. The final step in the geometry 
creation is a conversion of all dimensions to meters because this model uses SI units. 
Use the toolbar buttons and the Draw menu.

2D Cross Section
The geometry is created from a 2D cross section, that lies in the yz-plane of the final 
geometry.

1 Begin by specifying a yz work plane at x = 0 from the Draw menu. 

2 In the 2D work plane, draw a circle with a radius of 250 mm. 

3 Add a point at the center of the circle.

4 Draw a 60 mm tall and 100 mm wide rectangle that is centered at x = 0, 
y = 100 mm. 

Extruding to 3D
Create the 3D geometry from the cross section.

1 Select both the circle and the point and Extrude (from the Draw menu) these objects 
a distance of 300 mm.

2 Go back to the 2D view and Extrude the rectangle by 10 mm.

3 In the 3D view, select the resulting box and Move it by 145 mm in the x direction. 

The next step is to convert the length scale to meters. Select all objects and Scale them 
with the factor 1e-3 in all directions. 

P H Y S I C S  S E T T I N G S

Open the Application Scalar Variables dialog from the Physics menu, and make sure that 
the Frequency is set to 50 Hz. 

Subdomain Settings
Open the Subdomain Settings dialog box and select the plate. Click the Electric 

Parameters tab, click the Load button, and choose Copper from the Basic Material 

Properties. For the air domain, enter a small conductivity of 100 [S/m] to improve 
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convergence for the iterative solver. Any parameters not specified can be left at their 
default values.

Boundary Conditions
Leave the boundary conditions at the default settings, which is magnetic insulation.

Edge Settings
Open the Edge Settings dialog box and specify a line current of 24e3*sqrt(2) A for 
the conductor (Edge 6).

M E S H  G E N E R A T I O N

In order to resolve the skin depth while maintaining a good mesh economy, proceed 
as follows:

1 Choose Mesh>Free Mesh Parameters.

2 On the Subdomain tab, select Subdomain 2 and set the Maximum element size to 
5e-3.

3 On the Advanced tab, set the scale factor to 0.4 in the y and z directions.

4 Click the Mesh Selected button.

5 On the Global tab click the Reset to Defaults button, then select Predefined mesh sizes: 

Extremely coarse.

6 On the Subdomain tab, select Subdomain 1 and set the Maximum element size to 0.1.

7 Click the Mesh Selected button and then OK to close the dialog box.

These settings force a fine mesh in the plate but allow for a quick growth of the element 
size outside of the plate. In order not to get a too coarse mesh in the air, the settings 
limit the element size to 10 cm.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar to solve the model.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot is not what you want so open the Plot Parameters dialog box. Create 
a slice plot of the Resistive heating, time average (Qav_emqa) at x = 0.1451 only, and 
do a streamline plot of the Total current density. Change the Number of start points to 
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50. In order to plot the streamlines only in the plate, Suppress the air domain from the 
Options menu.

The final step is to calculate the total power dissipated in the plate by the induced eddy 
currents. This is done by going to the Postprocessing menu and select Subdomain 

Integration. In the dialog that appears, select the plate subdomain and from the list of 
Predefined quantities select Resistive heating, time average (Qav_emqa) before clicking 
OK. The result should be close to 6 W.

Changing to Aluminum and Stainless Steel

Repeating the analysis for aluminum and stainless steel is simple—just change the 
material properties for the plate subdomain and solve again. Aluminum is available 
from the Basic Material Properties whereas you have to enter stainless steel by typing 
the corresponding conductivity 1.137e6 (S/m) value in the dialog box.

Changing to Magnetic Iron

For magnetic iron, the skin depth is too small to be resolved with reasonable 
computational effort. The solution is to use the impedance boundary condition. 
 5 :  G E N E R A L  I N D U S T R I A L  A P P L I C A T I O N  M O D E L S



Subdomain Settings
1 Open the Subdomain Settings dialog box from the Physics menu.

2 Select the plate, then clear the Active in this domain check box. This tells the solver 
not to include this domain in the solution process and also makes the impedance 
boundary condition available on the boundaries of this domain.

3 Click OK.

Boundary Conditions
1 Open the Boundary Settings dialog box from the Physics menu.

2 Select the plate’s boundaries, then select Impedance boundary condition from the 
Boundary condition list.

3 Click the Material Properties tab, then click the Load button and select Iron in the 
Basic Materials Properties list in the Materials/Coefficients Library dialog box that 
appears. Click OK.

4 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

Use the same settings as before. Click the Solve button on the Main toolbar to solve 
the model. This takes a few minutes.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot may now give an error message as the plotted quantity no longer is 
defined in the plate domain.

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, clear the Slice and Streamline check boxes and select the 
Boundary check box in the Plot type area.

3 Click the Boundary tab. In the Boundary data area, select Surface resistive heating, 

time average from the Predefined quantities list to generate a plot of the resistive 
heating.

4 To see the results on the plate, point to Suppress in the Options menu.
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5 Select boundaries 1-5, 12 and click OK. 

The final step is to calculate the total power dissipated in the plate.

1 From the Postprocessing menu, select Boundary Integration.

2 In the Expression to integrate area, select Surface resistive heating, time average from 
the Predefined quantities list.

3 Click OK.

The result displayed in the message log should be close to 27 W.
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Co l d  C r u c i b l e 1

Introduction

A cold crucible is used for the manufacturing of alloys that require a high degree of 
purity, like titanium alloys for the aeronautic industry. The cold crucible in this model 
is made of several water-cooled copper sectors forming the container in which the alloy 
is manufactured.

Model Definition

The crucible is sketched in the figure below. The harmonic current flowing in the coils 
induces a current flowing in the opposite direction along the edge of the crucible. The 
induced currents produced in each of the sectors make the cold crucible act as field 
concentrator.

To save computation time, exploit the symmetries of the model and set up only one 
quarter of the crucible. The flow lines of the magnetic field are normal to the symmetry 
plane inserted in the figure below. To understand this, note that the geometry is 
symmetric with respect to the plane, and that the current is tangential to the plane.

1. Model made in cooperation with Roland Ernst, Centre National de la Recherche Scientifique, Grenoble, 
France.
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The first symmetry can be achieved by letting this plane be a boundary of the model. 
To this boundary, apply a boundary condition setting the tangential component of the 
magnetic field to zero. 

The following figure indicates a second symmetry plane. As the flow lines of the 
magnetic field make closed loops around the coils, the field must be tangential to the 
symmetry plane.

To model this symmetry, use a boundary condition that sets the tangential component 
of the magnetic potential to zero.

The crucible operates at 10 kHz. At this frequency the currents flow very close to the 
surface of the conducting regions. The skin depth
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is less than one millimeter, and the inner radius of the crucible is 5 cm. You can 
therefore model the currents as surface currents. 

Because the electric potential does not need to be specified to generate currents, it is 
possible to work with the potential

and thereby reduce the set of four equations for the A and V potentials to three 
equations for the Ã potential (see “3D and 2D Quasi-Statics Application Modes” on 
page 154 in the AC/DC Module User’s Guide).

Results and Discussion

To compute the surface currents flowing into and out of the end of the crucible, you 
can use integrals at that boundary. From Kirchhoff’s current law the total current 
flowing into the boundary should be equal to the currents flowing out of it. The figure 
below shows the integrations along the x side and z side, where the start and end points 
of each curve correspond to the flow in and out of the boundary, respectively.

The total inflow to the boundary is 1.38 A and the total outflow is 1.40 A, which 
agrees with Kirchhoff’s power law within 2%.

Model Library path: ACDC_Module/General_Industrial_Applications/
crucible

δ 2
ωµσ
-----------=

Ã A j
ω
---- V∇–=
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Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 In the Model Navigator, select 3D from the Space dimension list.

2 Then click on AC/DC Module>Quasi-Statics, Magnetic>Induction Currents to select the 
Quasi-Statics application mode.

3 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 In the Constants dialog box in the Options menu, enter the following names and 
expressions.

The electric conductivity σ = 1 S/m for air is obviously not the physically correct 
value, but too large a contrast between the conductivities makes it difficult for the 
numerical algorithms to find a solution. The error you make by using an incorrect 
value for the conductivity in air is negligible for the currents on the surfaces.

2 In the Application Scalar Variables dialog box in the Physics menu, set the frequency 
variable nu_emqav to 10000.

G E O M E T R Y  M O D E L I N G

Draw the crucible and inductor in a 2D work plane and then extrude them into 3D.

1 Create a work plane by opening the Work-Plane Settings dialog box in the Draw 
menu and clicking OK to obtain the default work plane in the xy-plane.

2 Open the Axes/Grid Settings dialog box from the Options menu. Enter the axis 
settings in the table below on the Axis tab.

3 Then click on the Grid tab and clear the Auto check box and enter the grid settings 
according to the table below.

NAME EXPRESSION DESCRIPTION

sigMetal 5e7[S/m] Conductivity of metal

sigAir 1[S/m] Conductivity of air

Js0 16.5[A/m] Coil surface current

AXIS GRID

x min -0.3 x spacing 0.1

x max 0.3 Extra x -0.17 
-0.16 
0.155
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4 Draw a circle C1 with radius 0.17 and a circle C2 with radius 0.16, both centered 
at the origin.

5 Select C1 and C2 and click the Difference button to create the solid object CO1.

6 Draw a circle C1 with radius 0.15 and a circle C2 with radius 0.05, both centered 
at the origin.

7 Select C1 and C2 and click the Difference button to create the solid object CO2.

8 Draw a rectangle R1 with the lower left corner at (−0.2, −0.2), Width 0.4, and 
Height 0.2.

9 Open the Create Composite Object dialog box and enter the set formula CO1-R1 to 
create the composite object CO3.

10 Draw a new rectangle R1 with the lower left corner at (−0.2, −0.2), Width 0.4, and 
Height 0.2.

11 Open the Create Composite Object dialog box and enter the set formula CO2-R1 to 
create the composite object CO1.

12 Draw a rectangle R1 with the lower left corner at (0, 0), Width 0.155, and Height 
0.01.

y min -0.2 y spacing 0.05

y max 0.2 Extra y 0.01

AXIS GRID
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13 Open the Create Composite Object dialog box and enter the set formula CO1-R1 to 
create the composite object CO2.

14 Select Extrude from the Draw menu to open the Extrude dialog box. Select the object 
CO3 and set the Distance to 0.05. Click OK to close the dialog box and create the 
extruded object EXT1.

15 Click on the Geom2 tab to return to the work plane.

16 Open the Extrude dialog box again, and select the object CO2 and set the Distance 
to 0.1 to create the extruded object EXT2.

17 Now create a region of air surrounding the crucible. Press the Block button to open 
the Block dialog box and set the Length coordinates to (1, 0.5, 0.5). Click More and 
set the coordinates of the Axis base point to (-0.5, 0, 0). Click OK to close the dialog 
box and create the block BLK1.

18 Press the Cylinder button to open the Cylinder dialog box and set the Radius to 0.5 
and the Height to 0.5. Click OK to close the dialog box and create the cylinder CYL1.

19 Open the Create Composite Object dialog box and enter the set formula BLK1*CYL1. 
Click the Apply button to create the object CO1.

20 Enter the set formula CO1-EXT1-EXT2 and click OK.
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P H Y S I C S  S E T T I N G S

Boundary Conditions
Enter boundary conditions according to the following table. Note that the impedance 
boundary condition has a Material Properties tab where you enter the conductivity. For 
the surface current, enter the x, y, and z components, which are Js0(−sinα, cosα, 0), 
where α is the azimuthal angle.

Subdomain Settings
On the Electric Parameters tab, enter properties according to the following table.

O P T I O N S  A N D  S E T T I N G S

After solving the problem, the postprocessing includes a study of how the current flows 
on the rectangular end of the crucible (Boundary 17). To prepare for that, define two 
coupling variables constituting the integrated current over a cross section of this 
boundary. Jsx_emqav is the x component of the surface current, and Isx is the 
integral of Jsx_emqav in the vertical direction across Boundary 17,

Jsz_emqav is the z component of the surface current, and Isz is the integral of 
Jsz_emqav in the horizontal direction across Boundary 17,

SETTINGS BOUNDARIES  
1, 2, 4, 16

BOUNDARIES  
3, 8

BOUNDARIES 5, 6, 7, 
14, 15

BOUNDARIES 9–13, 17

Boundary  
condition

Magnetic  
insulation

Electric  
insulation

Surface current Impedance boundary
condition

Js, x comp. (-y/sqrt(x^2+y^2))*Js0

Js, y comp. (x/sqrt(x^2+y^2))*Js0

Js, z comp. 0

σ sigMetal

µr 1

εr 1

SETTINGS SUBDOMAIN 1

σ sigAir

Isx x( ) Jsx x z,( ) zd∫=

Isz z( ) Jsz x z,( ) xd∫=
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The table below summarizes the variable definitions.

1 In the Boundary Projection Variables dialog box, select Boundary 17, enter the Name 
Isx, set the Expression to Jsx_emqa, and use the Integration order 2. Select the 
General transformation and fill in the x and y edit fields with x and z, respectively. 
The integration will be performed over the second coordinate, z, and Isx will 
therefore be a function of x.

2 On the Destination page, set the Level to Edge, and select Edge 38, which is one of 
the edges of Boundary 17, and set the Destination transformation to x.

3 Go back to the Source page and add a second projection variable, Isz, select 
Boundary 17 and set the Integrand to Jsz_emqa, the Integration order to 2. Select 
the General transformation, and fill in z and x in the fields x and y. In this case the 
integration will be performed over x.

4 On the Destination page, select Edge 40, and set the Destination transformation to z. 

M E S H  G E N E R A T I O N

To get a good quality mesh, set the maximum mesh element size manually on the 
boundaries adjacent to the thin regions in the model. 

1 Open the Free Mesh Parameters dialog box

2 Go to the Boundary page, select Boundaries 5, 7, 9, 13, 14, and 15 and set the 
Maximum element size to 0.04.

3 Initialize the mesh.

C O M P U T I N G  T H E  S O L U T I O N

1 Press the Solve button. (use the default solver)

VARIABLE TYPE SOURCE DESTINATION

Isx Projection Boundary: 17 
Integrand: Jsx_emqa 
Integration order: 2 
Source transformation, x: x 
Source transformation, y: z

Edge: 38 
Destination transformation: x

Isz Projection Boundary: 17 
Integrand: Jsz_emqa 
Integration order: 2 
Source transformation, x: z 
Source transformation, y: x

Edge: 40 
Destination transformation: z
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PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 To see the currents on the crucible, open the Suppress Boundaries dialog box from 
the Options menu and suppress Boundaries 1–4, 8, and 16.

2 Open the Plot Parameters dialog box.

3 On the General page, clear the Slice check box and select the Boundary and Arrow 

check boxes in the Plot type area.

4 Click the Boundary tab and select Surface current density, norm from the Predefined 

quantities list on the Boundary Data page.

5 Click the Arrow tab. From the Plot arrows on list, select Boundaries. In the Arrow 

parameters area, set the Arrow type to arrow. Clear the Auto check box, and set the 
Scale factor to 3.

To verify the current conservation on the end boundary of the crucible, Boundary 17, 
make use of the coupling variables Isx and Isz:

1 From the Postprocessing menu, open the Domain Plot Parameters dialog box.

2 Click the Line tab and select Edge 38. Enter the Line expression abs(Isx), then click 
Apply to generate the plot.

3 The left side of the plot corresponds to x = 0.15 and the right side to x = 0.05. The 
value at x = 0.15 is the total current flowing in through the right edge of the 
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boundary, and the value at x = 0.05 is the total current flowing out through the left 
edge of the boundary.
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4 Select Edge 40 and change the Line expression to abs(Isz). The left side of the plot 
corresponds to z = 0 and the right side to z = 0.1. The value at z = 0.1 is the total 
current flowing out through the top edge of the boundary.

5 By studying the plots, you can see that the current flowing in equals the current 
flowing out. To more accurately verify this, export the FEM structure to the 
COMSOL Script or MATLAB workspace by selecting Export FEM structure as 'fem' 
from the File menu. (This requires that you run COMSOL Multiphysics together 
with COMSOL Script or MATLAB.) Then enter the commands

Iinx=postinterp(fem,'abs(Isx)',0.1,'dom',38);
Iinz=postinterp(fem,'abs(Isz)',0.0,'dom',40);
Ioutx=postinterp(fem,'abs(Isx)',0.0,'dom',38);
Ioutz=postinterp(fem,'abs(Isz)',0.1,'dom',40);
(Ioutx+Ioutz)/(Iinx+Iinz)
 
ans =
 
    1.0322

The evaluation points along the edges are given in the local coordinate of the edge. As 
the length of these edges is 0.1, the coordinate lie in the range 0 to 0.1. The current 
flowing in and the current flowing out differ by less than two percent.
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E l e c t r i c  Impedan c e  S e n s o r

Introduction

Electric impedance measurements are used for imaging and detection. The 
applications range from nondestructive testing and geophysical imaging to medical 
imaging. One example is to monitor the lung function of babies in neonatal intensive 
care. The frequency ranges from less than 1 Hz to about 1 GHz depending on the 
application.

This model simulates a single electrode placed on a conducting block with an air filled 
cavity inside. The block is connected to ground on the lower face and on the sides. The 
analysis shows how the lateral position of the cavity affects the measured impedance, 
which you compute in a postprocessing step.

Figure 5-1: The electrode is placed on a conducting block with an air-filled cylindrical 
cavity inside.

Model Definition

In the AC/DC Module you solve the problem using the 2D Small In-Plane Currents 
application mode. This application mode is useful for the modeling of AC problems 
when inductive effects are negligible. A sufficient requirement for this is that the skin 
depth is large compared to the size of the geometry. The skin depth, δ, is given by
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where ω is the angular frequency, µ is the permeability, and σ is the conductivity. This 
model uses nonmagnetic materials with a frequency of  1 MHz and a typical electric 
conductivity of  1 mS/m, so the skin depth is about 15 m. The size of the geometry is 
about 1 m.

D O M A I N  E Q U A T I O N S

When induction is neglected, the electric field is curl free and can be assigned a scalar 
potential, V. The equation of continuity for the conduction and displacement currents 
then becomes

where ε0 is the permittivity of free space, and εr is the relative permittivity. The electric 
field E and displacement D are obtained from the gradient of V:

B O U N D A R Y  C O N D I T I O N S

Ground potential boundary conditions are applied on the lower and vertical edges of 
the domain. The upper edge is set to insulation except at the electrode, where a 
uniformly distributed current source of 1 A is applied.

δ 2
ωµσ
-----------=

∇ σ jωεrε0+( ) V∇( )⋅– 0=

E V∇–=

D ε0εrE=

n J⋅ Jn=
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Results and Discussion

Figure 5-2 shows the calculated impedance and its phase angle as functions of air cavity 
coordinate. When the cavity passes under the electrode, a sharp peak appears in the 
impedance value.

Figure 5-2: Absolute value and phase for the impedance as functions of air cavity 
coordinate. The peaks occur when the cavity is beneath the electrode.

Model Library path: ACDC_Module/General_Industrial_Applications/
electric_impedance

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select 2D in the Space dimension list.

2 In the AC/DC Module>Quasi-Statics, Electric>In-Plane Electric Currents application 
mode.

3 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 Select Axes/Grid Settings from the Options menu to open the Axes/Grid Settings dialog 
box.

2 On the Axis tab set x min to -0.55 and x max to 0.55. Set the interval limits on the 
y-axis to -0.55 and 0.
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3 Click the Grid tab and then clear the Auto check box to manually define new grid 
settings.

4 Set x spacing to 0.1 and give the values -0.01 0.01 in the Extra x text field. Set 
y spacing to 0.1.

5 To define some global constants to be used in your model, select Constants from the 
Options menu.

6 In the Constants dialog box, enter the following variable names, expressions, and 
(optionally) descriptions:

G E O M E T R Y  M O D E L I N G

1 Click the Rectangle/Square button on the Draw toolbar or select the corresponding 
entry in the Draw menu, then draw a rectangle with opposite corners at (−0.5, −0.5) 
and (0.5, 0), using the left mouse button.

2 Click the Point button on the Draw toolbar and draw a point at (−0.01, 0) and 
another point at (0.01, 0).

NAME EXPRESSION DESCRIPTION

sig_bulk 1[mS/m] Bulk conductivity

eps_r_bulk 5 Relative permittivity in bulk

x0 0[m] x position of cavity center

y0 -0.1[m] y position of cavity center

r0 0.09[m] Cavity radius
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P H Y S I C S  S E T T I N G S

Scalar Variables
Open the dialog box by selecting Scalar Variables from the Physics menu and set the 
frequency nu_emqvw to 1e6.

Boundary Conditions
Ground potential boundary conditions are applied on the lower and vertical edges of 
the domain. The upper edge is set to insulation except at the electrode, where a port 
is defined using the fixed current density property. This applies a uniformly distributed 
current source of 1 A to the electrode. The following table shows the corresponding 
boundary settings:

Subdomain Settings
To model the cavity, use functions and logical expressions for the permittivity and 
conductivity distributions. This has the advantage that you can change the position of 
the cavity without modifying the geometry. Use the default constitutive relation,

and enter the material parameters according to the table below.

M E S H  G E N E R A T I O N

1 Open the Free Mesh Parameters dialog box.

2 Select Normal from the Predefined mesh sizes list on the Global page. Select Custom 

mesh size and specify a Maximum element size of 0.01.

3 Initialize the mesh.

SETTINGS BOUNDARY 4 BOUNDARIES 1, 2, 6 BOUNDARIES 3, 5

Boundary condition Port Ground Electric insulation

Port number 1

Use port as input selected

Input property Fixed current density

SETTINGS SUBDOMAIN 1

 σ sig_bulk*(((x-x0)^2+(y-y0)^2)>r0^2)

 εr 1+(eps_r_bulk-1)*(((x-x0)^2+(y-y0)^2)>r0^2)

D ε0εrE=
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C O M P U T I N G  T H E  S O L U T I O N

1 In the Solver Parameters dialog box, select Parametric in the Solver list.

2 Type x0 in the Parameter name edit field and linspace(-0.5,0.5,21) in the 
Parameter values edit field. Click OK.

3 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

After solving the problem, a surface plot for the electric potential appears. You can use 
the buttons on the Plot toolbar to get other types of plots. To visualize the current 
distribution on a dB scale, open the Plot Parameters dialog box.

1 Select Plot Parameters from the Postprocessing menu to open the Plot Parameters 
dialog box.

2 Select Surface as Plot type and set Parameter value to 0 on the General page.

3 On the Surface page, set the Surface Expression to 20*log10(normJ_emqvw).

4 Click Apply to generate a plot.

5 To better see the variations the color range can be changed. Click Range to open the 
Color Range dialog box.

6 Clear the Auto check box to manually define new range settings.

7 Keep the value for Max but change the Min value to -35. Click OK.
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The impedance is defined as the ratio of voltage to total current at the electrode. You 
can visualize it as a function of the cavity position using the cross-sectional domain plot 
tool available from the Postprocessing menu. The impedance is available as a 
postprocessing variable, Z11_emqvw.

1 Open the Domain Plot Parameters dialog.

2 Select all solutions from the Solution to use list by pressing Ctrl+A.

3 Now select the Point tab and set Expression to abs(Z11_emqvw) and select Point 1. 
Click Apply to get the following figure.

4 Finally, repeat the last step but set the Expression to 180*angle(Z11_emqvw)/pi to 
get the phase angle of the impedance.
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One - S i d e d  Magn e t  and P l a t e

Introduction

Permanent magnets with a one-sided flux are used to attach posters and notes to 
refrigerators and notice boards but can also be found in advanced physics applications 
like particle accelerators. The one-sided flux behavior is obtained by giving the magnet 
a magnetization that varies in the lateral direction (Ref. 1). As no currents are present, 
it is possible to model a permanent magnet using a scalar magnetic potential 
formulation. This model shows this technique to model a cylindrical one-sided 
permanent magnet. A special technique to model thin sheets of high permeability 
material was used to model a thin µ-metal plate next to the magnet. This circumvents 
the difficulty of volumetric meshing of thin extended structures in 3D.

Figure 5-3: A cylindrical magnet above a µ-metal plate is modeled.

Model Definition

In a current free region, where

you can define the scalar magnetic potential, Vm, from the relation

∇ H× 0=

H ∇Vm–=
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This is analogous to the definition of the electric potential for static electric fields.

Using the constitutive relation between the magnetic flux density and magnetic field 

together with the equation

you can derive the following equation for Vm:

It can be shown that applying a laterally periodic magnetization of 

results in a magnetic flux that only emerges on one side of the magnet.

Results and Discussion

Figure 5-4 shows the calculated magnetic flux density and direction for the one-sided 
magnet. The resulting force on the plate is considerably higher for the case with the 
one-sided magnetization compared to the case with uniform magnetization of the 
same amplitude.

B µ0 H M+( )=

∇ B⋅ 0=

∇ µ0∇Vm µ0M–( )⋅– 0=

M Mpre kx( )sin 0 Mpre kx( )cos, ,( )=
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Figure 5-4: The magnetic flux density and direction is plotted in a cross section of the 
geometry. The one-sided behavior is clearly seen as the flux does not emerge on the top of the 
magnet.

Reference

1. Shute, Mallinson, Wilton and Mapps, “One-Sided Fluxes in Planar, Cylindrical and 
Spherical Magnetized Structures,” IEEE Transactions on Magnetics, Vol 36, No. 2, 
March 2000, pp. 440–451.

Model Library path: ACDC_Module/General_Industrial_Applications/
one_sided_magnet

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Select 3D from the Space dimension list.
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2 Select the AC/DC Module>Statics>Magnetostatics, No Currents application mode. 

3 Click OK.

O P T I O N S  A N D  S E T T I N G S

In the Constants dialog box enter the following names and expressions. The description 
field is optional and can be omitted.

G E O M E T R Y  M O D E L I N G

1 Use the Cylinder tool to create a cylinder with the radius 0.01 and the height 0.005.

2 Use the Sphere tool to create a sphere with the radius 0.02.

3 Open the Work-Plane Settings dialog from the Draw menu and use the default work 
plane in the xy-plane. Set z to -0.005 and click OK.

4 First click the Projection of All 3D Geometries toolbar button and then click the Zoom 

Extents toolbar button to adapt the axis settings of the drawing board.

5 Draw a circle C1 with radius 0.01 centered at (0, 0).

6 Select C1 and then select Embed from the Draw menu and click OK.

NAME EXPRESSION DESCRIPTION

k pi/10[mm] Wave number in x direction

M_pre 5e5[A/m] Magnetization amplitude in magnet

mu_r 4e4 Relative permeability in plate

th 0.5[mm] Plate thickness
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P H Y S I C S  S E T T I N G S

Subdomain Settings
In the Subdomain Settings dialog box, change the Constitutive relation in Subdomain 2 
to allow for a premagnetization vector M and enter the values according to the table 
below.

This kind of premagnetization will result in a magnetic flux that only emerges on the 
lower side of the magnet. That is, on the side where the µ-metal plate is. Click OK.

Boundary Conditions
Along the exterior boundaries, the magnetic field should be tangential to the boundary 
as the flow lines should form closed loops around the magnet. The natural boundary 
condition from the equation is

Thus the magnetic field is made tangential to the boundary by a Neumann condition 
on the potential. On the interior boundary representing the µ-metal plate, you apply 
a special boundary condition for thin sheets of highly permeable material. Such plates 
are often used for the purpose of magnetic shielding.

Enter these boundary conditions according to the following table. To access interior 
boundaries, select the Interior boundaries check box.

Point Settings
So far the magnetic potential is not constrained anywhere and the problem has infinite 
number of solutions. Thus, you must supply a condition fixing it to a specific value 
somewhere. In the Point Settings dialog box, constrain the Magnetic potential to zero 
at Point 1.

M E S H  G E N E R A T I O N

Click the Initialize Mesh button on the Main toolbar.

SETTINGS SUBDOMAIN 2

M M_pre*sin(k*x) 0 M_pre*cos(k*x)

SETTINGS BOUNDARIES 1–4, 10, 11, 
13, 14

BOUNDARY 5 BOUNDARIES 
6–9, 12, 15

Type Magnetic insulation Magnetic shielding Continuity

Relative permeability mu_r

Thickness th

n µ0∇Vm µ0M–( )⋅ n B⋅ 0= =
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C O M P U T I N G  T H E  S O L U T I O N

There is no need to change the solver settings. The default solver settings are the 
conjugate gradients solver and the algebraic multigrid preconditioner. This is normally 
the most efficient solver setting for Poisson’s equation, which is the type of equation 
that this model solves. This problem generates symmetric matrices so this option is 
selected as default. Click the Solve button on the Main toolbar. The computation time 
is about 6 seconds on a 3 GHz P4 machine.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows a slice plot of the magnetic potential. To reproduce the plot in 
Figure 5-4 on page 231, follow these steps:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, select the Slice and Arrow check boxes in the Plot type area.

3 Click the Slice tab. In the Predefined quantities list, select Magnetic flux density, norm. 
Set the Slice positioning x levels to 0, set y levels to 1, and set z levels to 0.

4 Click the Arrow tab. From the Predefined quantities list on the Subdomain Data page, 
select Magnetic flux density.

5 In the Arrow positioning area, set the numbers of x points to 50, y points to 1, and 
z points to 50.

6 In the Arrow parameters area, select Cone from the Arrow type list.

7 Click OK to close the dialog box and generate the plot.

8 Use the Zoom Window tool on the Main toolbar to zoom in on the magnet and plate.

Magnetic Field in the Plate
The magnetic field in the plate is not available as a predefined postprocessing variable. 
To make this quantity more readily available, define extra expressions that you can use 
for postprocessing:

1 From the Options menu, select Expressions>Boundary Expressions.

2 Specify the variable names and expressions on Boundary 5 (the plate) according to 
the following table.

3 Click OK to close the dialog box.

NAME EXPRESSION

NORMH sqrt(VmTx*VmTx+VmTy*VmTy+VmTz*VmTz)

NORMB mu0_emnc*mu_r*NORMH
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4 From the Solve menu, select Update Model to compute values for the newly defined 
variables using the existing solution.

It is now possible to display the magnetic flux density in the plate using the available 
postprocessing functionality:

1 Select Plot Parameters from the Postprocessing menu or click the Plot Parameters 
button on the Main toolbar to open the Plot Parameters dialog box.

2 In the Plot type area on the General page, clear the Slice and Arrow check boxes and 
select the Boundary check box.

3 On the Boundary page, set the Expression to NORMB.

4 Click OK to generate the plot.

Force Calculation
To calculate the force on the plate, use the surface stress tensor

where n1 is the boundary normal pointing out from the plate and T2 the stress tensor 
for air.

n1T2
1
2
--- H B⋅( )n1– n1 H⋅( )BT

+=
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In this model the H and B fields are discontinuous across the plate, which makes it 
necessary to evaluate the fields on both sides of the plate.

All surfaces have an up and a down side. To find out which side is up and which is 
down, you can make an arrow plot of the components of the up normal (unx, uny, 
unz) on the boundaries. The up normal is the outward normal from the up side. In 
this case, you evaluate the fields on both sides and there is no need to know the 
direction of the up normal. The application mode defines variables for the surface 
stress tensor on the up and down side of the boundaries, for example, unTz_emnc and 
dnTz_emnc for the z component of the surface stress tensor.

Now, the x and y components of the force vanish for symmetry reasons. To find the 
force in the z direction, integrate the surface stress tensor over the plate. In the 
Boundary Integration dialog box, select Boundary 5 and enter the Expression 
unTz_emnc+dnTz_emnc. Click OK to evaluate the integral, which gives 1.2 N. This 
result is displayed in the message log at the very bottom of the user interface.

Force Calculation with Uniform Magnetization
In the Constants dialog box change the constant k to 0 in order to obtain a uniform 
magnetization of (0, 0,  Mpre). Solve and calculate the force on the plate again. What 
is the conclusion?

Modeling Using a Nonlinear Magnetic Material in the Plate

Magnetic saturation effects are important in many applications. This step of the 
modeling process shows how to include a nonlinear magnetic material with saturation 
in the plate. The relative permeability µr is a function of the magnitude, |H| of the 
magnetic field as described by the following equation:

µr 1 µrmax 1–( ) 1– µ0 H
Bsat
--------------⎝ ⎠

⎛ ⎞

1
n
---

+

1–

+=
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Bsat is the magnetic saturation flux, which for µ-metal is about 1.2 T.

Before modifying the model, we recommend that you save it under a new name. You 
do this from the File menu by selecting Save As.

O P T I O N S  A N D  S E T T I N G S

1 In the Constants dialog box enter the following names, expressions, and descriptions 
(the descriptions are optional).

2 Click OK to close the dialog box.

Expression variables are used for the nonlinear permeability.

From the Options menu, select Expressions>Boundary Expressions.

NAME EXPRESSION DESCRIPTION

k pi/10[mm] Wave number in x direction

M_pre 5e5[A/m] Magnetization amplitude in magnet

mu_rmax 4e4 Maximum relative permeability in plate

th 0.5[mm] Plate thickness

B_sat 1.2[T] Saturation flux density

N 1 Model order parameter
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1 Specify the variable names and expressions on Boundary 5 (plate) according to the 
following table.

2 Click OK to close the dialog box.

P H Y S I C S  S E T T I N G S

Initial Conditions
The nonlinear solver works by performing iterations, linearizing and solving the model 
for a sequence of operating points that converges to the final solution. For this to work 
properly in the first iteration, you need to start using an initial guess with a nonzero 
gradient:

1 From the Physics menu, open the Subdomain Settings dialog box.

2 Click the Init tab. Select all subdomains in the Subdomain selection list.

3 In the Vm(t0) edit field, type 1[A/m]*sqrt(x^2+y^2+z^2).

4 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

The computation time is about 35 seconds on a 3 GHz P4 machine.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Plot the relative permeability in the plate and the magnetic flux density using the 
available postprocessing functionality:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, select the Boundary and Arrow check boxes in the Plot type area.

3 On the Boundary page, set the Expression to mu_r.

4 For the Arrow plot, use the same settings as when generating Figure 5-4. Thus, click 
OK to close the dialog box and generate the plot.

NAME EXPRESSION

NORMH sqrt(VmTx*VmTx+VmTy*VmTy+VmTz*VmTz)

NORMB mu0_emnc*mu_r*NORMH

mu_r 1-1/(1/(1-mu_rmax)-(mu0_emnc*NORMH/B_sat)^(1/N))
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The plate has begun to saturate as the relative permeability is well below 4·104 in the 
blue areas. Try increasing the value of the premagnetization M_pre to 1e6 in the 
Constants dialog box and solve again to see a more pronounced saturation effect.

The computation time is about 100 seconds on a 3 GHz P4 machine.

Force Calculation
In the Boundary Integration dialog box, select Boundary 5 and enter the Expression 
unTz_emnc+dnTz_emnc. Click OK to evaluate the integral, which gives 3.3 N. This 
result appears in the message log at the bottom of the COMSOL Multiphysics user 
interface.
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Magne t i c  S i g n a t u r e  o f  a  S ubma r i n e

Introduction

A vessel traveling on the surface or under water gives rise to detectable local 
disturbances in the Earth’s magnetic field. These disturbances can be used to trigger 
weapon systems. The magnetic signature of a ship can be reduced by generating a 
counteracting magnetic field of suitable strength and direction based on prior 
knowledge of the magnetic properties of the vessel. An important step in the design of 
a naval ship is therefore to predict its magnetic signature. Another application where 
magnetic signatures are of great importance is in urban traffic control. Magnetic 
sensors, buried in our streets, are used to sense vehicles and control traffic lights. Ships 
and cars are both to a large extent made of sheet metal. This makes them hard to 
simulate using standard finite element analysis because volume meshes of thin 
extended structures are difficult to generate and tend to become very large. This model 
demonstrates a powerful technique that circumvents the problem by modeling the 
sheet metal as 2D faces embedded in a 3D geometry. Thus it is only necessary to create 
comparatively inexpensive 2D face meshes in addition to the 3D volume mesh used for 
the surrounding medium. A tangential projection of the 3D equation is then solved on 
the 2D face mesh.

Figure 5-5: Submarine HMAS Collins, image courtesy of Kockums AB.
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Model Definition

In magnetostatic problems, where no currents are present, the problem can be solved 
using a scalar magnetic potential. A special technique to model thin sheets of high 
permeability materials is also demonstrated. The model geometry is shown in 
Figure 5-6. It consists of face objects representing the submarine enclosed in a 3D box 
representing the surrounding water.

Figure 5-6: The model geometry.

D O M A I N  E Q U A T I O N S

In a current-free region, where

it is possible to define the scalar magnetic potential, Vm, from the relation

This is analogous to the definition of the electric potential for static electric fields. 
Using the constitutive relation between the magnetic flux density and magnetic field 

together with the equation

you can derive an equation for Vm,

∇ H× 0=

H ∇Vm–=

B µ0 H M+( )=

∇ B⋅ 0=

∇ µ0∇Vm µ0M–( )⋅– 0=
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B O U N D A R Y  C O N D I T I O N S

Along the vertical exterior boundaries of the surrounding box, the magnetic field is 
assumed to be tangential to the boundaries. The natural boundary condition from the 
equation is

Thus the magnetic field is made tangential to the boundary by a Neumann condition 
on the potential. In order to emulate the Earth’s magnetic field a potential condition 
is applied on the top boundary 

whereas the bottom boundary is set to a magnetic potential of zero.

This corresponds to a vertical magnetic flux density of about 0.5 G—a typical value for 
the Earth’s magnetic field. On the face objects representing the hull of the submarine, 
you apply a 2D tangential projection of the 3D domain equation where the thickness 
and permeability of the hull are introduced as parameters. This is readily available in 
the used formulation as a shielding boundary condition, which is useful for modeling 
of highly permeable thin sheets. Corresponding boundary conditions are available in 
the Conductive Media DC and Electrostatics application modes for modeling of thin 
sheets with high conductance and high permittivity respectively.

Results and Discussion

Figure 5-7 shows the magnetic flux density in a horizontal slice plot 7.5 m below the 
keel of the submarine. A distinct field perturbation due to the presence of the vessel 

n µ0∇Vm µ0M–( )⋅ n B⋅ 0= =

Vm 1989 A( )=

Vm 0=
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can be seen. The magnitude and direction of the tangential magnetic field in the hull 
of the vessel is shown using color and arrows.

Figure 5-7: The slice color plot shows the magnetic flux density. The arrows and boundary 
color plot show the direction and strength of the tangential magnetic field in the hull.

Model Library path: ACDC_Module/General_Industrial_Applications/
submarine

Modeling Using the Graphical User Interface

Select the 3D>AC/DC Module>Statics>Magnetostatics, No Currents application mode in 
the Model Navigator. Click OK.

Open the Work-Plane Settings dialog box from the Draw menu, use the default xy work 
plane and click OK.
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O P T I O N S  A N D  S E T T I N G S

1 On the Grid tab in the Axes/Grid Settings dialog box, clear the Auto check box and 
enter the grid settings according to the following table.

G E O M E T R Y  M O D E L I N G

1 Click the Rectangle button on the Draw toolbar to create a rectangle with its lower 
left corner at (−12.5, −2.5) with a width of 22.5 and a height of 5.

2 Click the Ellipse/Circle (Centered) button on the Draw toolbar to create a circle with 
the radius 2.5 and its center at (−12.5, 0).

3 Click the 3rd Degree Bézier Curve button on the Draw toolbar and then click in 
sequence at the following points (10.0, 2.5), (13.0, 2.5), (13.0, 1.0) and (17.0, 
1.0). Then, select the Line tool from the toolbar and click at (17.0, -1.0). Finally, go 
back to the 3rd Degree Bézier Curve tool and click at (13.0, -1.0), (13.0, -2.5) and 
(10.0, -2.5). Close the curve by clicking the right mouse button.

4 Press Ctrl+A to select all objects and then click the Union button on the toolbar.

GRID

x spacing 0.5

y spacing 0.5
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5 Click the Delete Interior Boundaries button on the Draw toolbar. Then click the 
Zoom Extents button.

6 Click the Rectangle button on the Draw toolbar to create a rectangle with its lower 
left corner at (−15, −2.5), with a width of 32 and a height of 2.5.

7 Press Ctrl+A to select all objects and then click the Difference button on the Draw 
toolbar.
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8 Click the Zoom Extents button.

9 Select the composite object CO2.

10 Open the Revolve dialog box from the Draw menu. Set the coordinates for the Second 

point to (1, 0) and click OK to revolve into the 3D geometry.

11 Go back to the work plane Geom2.

12 Select Ellipse/Circle (Centered) from the Draw menu and create an ellipse with the 
A-semiaxis 2.5 and the B-semiaxis 0.625 and its center at (0, 0).

13 With the ellipse selected, open the Extrude dialog box from the Draw menu and 
extrude it a Distance of 2 m.

14 In the 3D view, click the Move button in the Draw toolbar to move the extruded 
object a distance of 2 m in the z direction.

15 Press Ctrl+A to select all objects and then click the Union button on the toolbar.

16 Click the Delete Interior Boundaries button on the Draw toolbar.
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17 Click the Coerce to Face button on the toolbar. Then click the Zoom Extents button

18 Click the Block button on the Draw toolbar, set the Base to Center, the Axis base 

point to (0, 0, 0), and the Length to (100, 50, 50); when done, click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings
Keep the default subdomain settings.

Boundary Conditions
Along the vertical boundaries of the surrounding box, the magnetic field should be 
tangential to the boundaries. In order to emulate the Earth’s magnetic field, apply a 
potential condition of 1989 A on the top boundary. At the bottom boundary, set a 
magnetic potential of zero. On the interior boundaries representing the hull of the 
submarine, apply a special boundary condition denoted shielding. This makes use of a 
2D tangential projection of the 3D domain equation where the thickness and 
permeability of the hull are introduced as parameters. 

Enter the boundary conditions according to the following table. In order to access the 
interior boundaries, select the Interior boundaries check box.

SETTINGS BOUNDARIES 1, 2, 
5, 27

BOUNDARIES 6–26 BOUNDARY 4 BOUNDARY 3

Boundary 
condition

Magnetic 
insulation

Magnetic shielding Magnetic 
potential

Zero potential

 µr 700

 d 0.05

 Vm0 1989
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M E S H  G E N E R A T I O N

1 Open the Free Mesh Parameters dialog box.

2 Click the Custom mesh size button. Type 0.5 in the field Maximum element size 

scaling factor, and type 0.4 in the Mesh curvature factor edit field. This limits the 
maximum mesh size to one half of the default value and provides a higher resolution 
of the curvature than the default settings for a normal 3D mesh.

3 Click the Initialize Mesh button; then click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar. This starts the analysis using the default 
solver, the Conjugate gradients solver, and the default preconditioner, Algebraic 
multigrid.

The computation time is about 1 minute on a 3 GHz P4 machine.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows a slice plot of the magnetic potential with 5 slices perpendicular 
to the x axis. A more interesting plot can easily be obtained.

1 Select Plot Parameters from the Postprocessing menu to open the Plot Parameters 
dialog box and click the Slice tab.

2 Select Magnetic flux density, norm as Expression.

3 Set the numbers of x-levels and y-levels to 0.

4 For z, select Vector with coordinates and set the value to -10. Click OK to close the 
dialog and make the plot.

Tangential Magnetic Field in the Hull
The magnetic field in is available as predefined postprocessing variables available 
everywhere. Do display variables only on some boundaries, it is possible to use the 
Suppress>Boundaries option from the Options menu. Another convenient way to select 
boundaries used in a plot, is to define a new boundary variable that only has valid 
expressions on the boundaries used in the plot. 

From the Options menu, select Expressions>Boundary Expressions.
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1 Specify the variable names and expressions on the hull Boundaries 6–26, according 
to the following table.

2 Click OK to close the dialog box.

3 From the Solve menu, select Update Model in order to compute values for the newly 
defined variables using the existing solution.

The magnetic field in the hull can now be displayed using the available postprocessing 
functionality in COMSOL Multiphysics.

1 Select Plot Parameters from the Postprocessing menu to open the Plot Parameters 
dialog box.

2 On the General page, select the Slice, Boundary, and Arrow check boxes in the 
Plot type area.

3 On the Slice page, keep the previous settings.

4 On the Boundary page, type NORMH in the Expression edit field.

5 On the Arrow page, select Boundaries from the Plot arrows on list. On the 
Boundary Data page, enter HX as the x component, HY as the y component, and HZ as 
the z component.

6 In the Arrow parameters area, clear the Auto check box, then specify a Scale factor of 
0.2.

NAME EXPRESSION

NORMH normtH_emnc

HX tHx_emnc

HY tHy_emnc

HZ tHz_emnc
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7 Click OK to generate the plot.
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3D Quad r upo l e  L en s

Introduction

This is a full 3D version of the Quadrupole Lens model in the COMSOL Multiphysics 
Model Library. For a general overview of the setup and the physics, see “Quadrupole 
Lens” on page 83 in the COMSOL Multiphysics Model Library. This version of the 
model also takes fringing fields into account, and the calculation of the forces on the 
ions uses all components of their velocities.

Model Definition

The geometry of the quadrupole lens is the same as outlined in the documentation to 
the 2D model: three quadrupoles in a row, followed by 1 m of empty space, where the 
ions are left to drift. The AC/DC Module features an application mode for 
magnetostatics without currents. This reduces the memory usage considerably 
compared to the formulation including currents.

D O M A I N  E Q U A T I O N S

The magnetic field is described using the Magnetostatics equation, solving for the 
magnetic scalar potential Vm (Wb/m):

where µ0 = 4π·10−7 H/m denotes the permeability of vacuum and M is the 
magnetization (A/m). In the iron subdomain

where µr = 4000 is the relative permeability. The magnetic scalar potential is 
everywhere defined so that 

B O U N D A R Y  C O N D I T I O N S

The magnetic insulation boundary condition, reading n · B = 0, is used all around the 
iron cylinder, and at the lateral surfaces of the air domain that encloses the drift length. 
At the base surface of the same air domain, the magnetic potential is zero.

∇ µ0 Vm µ0M–∇( )⋅– 0=

∇ µ0µr Vm∇( )⋅– 0=

H Vm.∇–=
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Results

The magnetic field density and arrows showing its direction are depicted in the figure 
below.

Figure 5-8: Slice plot and arrows of the magnetic field density in the quadrupole lens.

Each ion passing through the assembly experiences Maxwell forces equal to 
F = q v × B, where v (m/s) is the velocity of the ion. To find the transverse position as 
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a function of time, solve Newton’s second law for each ion: q v × B = m a. Figure 5-9 
shows the traces of the ions as they fly through the quadrupole lens. 

Figure 5-9: Particle tracing plot of the ions. The line colors show the local force acting on 
each ion. The force grows larger (red) far away from the center of the beam line and 
smaller (blue) where two oppositely polarized quadrupoles join.

Model Library path: ACDC_Module/General_Industrial_Applications/
quadrupole_3d

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 In the Model Navigator, select 3D in the Space dimension list.

2 Select AC/DC Module>Statics>Magnetostatics, No Currents from the list of application 
modes.

3 Click OK to close the dialog box.
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O P T I O N S  A N D  S E T T I N G S

1 In the Constants dialog box, enter the following constant names, expressions, and 
(optionally) descriptions; when done, click OK to close the dialog box.

G E O M E T R Y  M O D E L I N G

1 Choose Draw>Work-Plane Settings. Click OK to get the default xy-plane.

2 Choose Draw>Specify Objects>Rectangle. Specify the following properties; when 
done, click OK.

3 Choose Draw>Modify>Rotate. Rotate the rectangle by 45 degrees around the origin. 
When done, click OK.

4 Choose Draw>Specify Objects>Circle. Specify the following properties, then click OK.

5 Press Ctrl+A to select both objects. Click the Intersection button on the Draw 
toolbar.

NAME EXPRESSION DESCRIPTION

M 11 Ion mass number

Z 5 Ion charge number

vz 0.01*3e8[m/s] Ion velocity

mp 1.672e-27[kg] Proton mass

Ze 1.602e-19[C] Proton charge

m M*mp Ion mass

q Z*Ze Ion charge

MQ 5.8e3[A/m] Quadrupole magnetization

PROPERTY EXPRESSION

Width 0.177

Height 0.07

Position: Base Corner

Position: x 0

Position: y -0.035

PROPERTY EXPRESSION

Radius 0.2

Position: Base Center

Position: x 0.2

Position: y 0.2
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6 Press Ctrl+C to make a copy of the composed object (CO1), then press Ctrl+V to 
paste it at the same location, that is with zero displacements. 

7 Rotate the copied object (CO2) by 90 degrees around the origin.

8 Paste two more copies of CO1 at the same location, and rotate them by 180 and 
270 degrees, respectively.

9 Create a circle centered at the origin with a radius of 0.2 m.

10 Create another circle centered at the origin, with a radius of 0.12 m.

11 Click the Create Composite Object button. Create an object using the formula 
C1+C2-(CO1+CO2+CO3+CO4). Click OK.

12 Once more, draw a circle centered at the origin with a radius of 0.2 m.

The geometry should now look like that in the figure below.

Figure 5-10: Work-plane view of the geometry.

13 Select all objects, then choose Draw>Extrude. Click OK to extrude the geometry to 
a height of 1 m.

14 In the 3D view, copy the object you just extruded, and paste it to the same location. 
You find the copy and paste commands in the Edit menu.
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15 Choose Draw>Modify>Scale. Scale the pasted object by a factor of 2 in the 
z direction. When done, click OK.

16 Choose Draw>Modify>Move. Move the scaled object 1 m in the z direction. When 
done, click OK.

17 Paste another copy of the first object into the geometry, but now with a 
displacement of 3 m in the z direction.

18 Choose Draw>Cylinder. Create a cylinder with the following specifications; when 
done, click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 In the Subdomain Settings dialog box, select Subdomains 1–3 and load Iron from the 

list of materials.

2 Leave the default settings in Subdomains 4 and 11–13.

3 In all the other subdomains, set the constitutive relation to B = µ0 H + µ0 M and set 
the magnetization according to the table below.

Boundary Conditions
1 In the Boundary Settings dialog box, set the boundary conditions according to the 

table below. The easiest way to do this is to first select all the exterior boundaries, 
by selecting the Select by group check box and select one of them. Apply magnetic 
insulation to all the boundaries, and change the condition on Boundary 13 back to 
zero potential.

PROPERTY EXPRESSION

Radius 0.2

Height 1

Axis base point z 4

SETTINGS SUBDOMAINS, 
5, 7, 18

SUBDOMAINS 8, 
10, 15

SUBDOMAINS, 9, 
14, 16

SUBDOMAINS 6, 
17, 19

M (x component) MQ/sqrt(2) -MQ/sqrt(2) MQ/sqrt(2) -MQ/sqrt(2)

M (y component) MQ/sqrt(2) MQ/sqrt(2) -MQ/sqrt(2) -MQ/sqrt(2)

SETTING BOUNDARY 13 ALL OTHERS

Boundary condition Zero potential Magnetic insulation
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M E S H  G E N E R A T I O N

1 In the Free Mesh Parameters dialog box, select Finer among the Predefined mesh sizes.

2 On the Subdomain tab, select Subdomains 4 and 11–13, and enter 0.03 for the 
Maximum element size.

3 On the Advanced page, set the z-direction scale factor to 0.2.

4 Click the Remesh button. When the mesher has finished, click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows the magnetic potential. Follow the instructions to get an 
overview of the magnetic field.

1 In the Plot Parameters dialog box, go to the Slice page and select Magnetic field, norm 

from the Predefined quantities list. Set the Number of levels to (1, 1, 0).

2 On the Arrow page, select the Arrow plot check box. Set the Number of points to 
(2, 2, 20) and the Scale factor to 0.2.

3 Click Apply to see the magnetic field.

To see how the ions travel through the system of quadrupoles, do the following:

1 On the General page, clear the Slice and Arrow check boxes, and select the 
Particle tracing check box.

2 On the Particle tracing page, select Electromagnetic force from the Predefined forces 
list. In the Mass edit field, type m.

3 On the Start Points page, type 0.03*cos(linspace(0,2*pi,41)) in the x edit 
field and 0.03*sin(linspace(0,2*pi,41)) in the y edit field.

4 On the Initial Values page, type vz in the rightmost Initial velocity edit field to set 
the initial z-velocity.

5 On the Line Color page, click the Use expression option button.

6 Click the Color Expression button to open the Pathline Color Expression dialog box. 
In the Expression edit field, type q*vz*normB_emnc (this is an approximate value of 
the local force acting on each ion). Click OK.

7 Click the Advanced button and set the Relative tolerance to 1e-6.

8 Click OK to close the Plot Parameters dialog box and generate the particle tracing 
plot.
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S up e r c ondu c t i n g  W i r e

Current can flow in a superconducting wire with practically zero resistance, although 
factors including temperature, current density, and magnetic field can limit this 
phenomenon. This model solves a time-dependent problem of a current building up 
in a superconducting wire close to the critical current density. This model is based on 
a suggestion by Dr. Roberto Brambilla, CESI - Superconductivity Dept., Milano, Italy.

Introduction

The Dutch physicist Heike Kamerlingh Onnes discovered superconductivity in 1911. 
He cooled mercury to the temperature of liquid helium (4 K) and observed that its 
resistivity suddenly disappeared. Research in superconductivity reached a peak during 
the 1980s in terms of activity and discoveries, especially when scientists uncovered the 
superconductivity of ceramics. In particular, it was during this decade that researchers 
discovered YBCO—a ceramic superconductor composed of yttrium, barium, copper, 
and oxygen with a critical temperature above the temperature of liquid nitrogen. 
However, researchers have not yet created a room-temperature superconductor, so 
much work remains for the broad commercialization of this area.

This model illustrates how current builds up in a cross section of a superconducting 
wire; it also shows where critical currents produce a swelling in the 
non-superconducting region.

Model Definition

The dependence of resistivity on the amount of current makes it difficult to solve the 
problem using the standard application modes in the AC/DC Module. The reason is 
this: A circular dependency arises because the current-density calculation contains the 
resistivity, leading to a resistivity that is dependent on itself. 

An alternate approach uses the magnetic field as the dependent variable, and you can 
then calculate the current as

.

The electric field is a function of the current, and Faraday’s law determines the 
complete system as in

J ∇ H×=
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where E(J) is the current-dependent electric field. The model calculates this field with 
the empirical formula

where E0 and α are constants determining the nonlinear behavior of the transition to 
zero resistivity, and JC is the critical current density, which decreases as temperature 
increases. 

For the superconductor YBCO, this model uses the following parameter values (Ref. 
1):

Systems with two curl operators are best dealt with using vector elements (edge 
elements). This is the default element for the application modes in the AC/DC 
Module that solve similar equations. This particular formulation for the 
superconducting system is not available in the AC/DC Module, so you must define it 
using the PDE, General Form application mode. In addition, the model uses 
higher-order vector elements, called curl elements in COMSOL Multiphysics. The 
resulting system becomes

.

For symmetry reasons, the current density has only a z-component.

The model controls current through the wire with its outer boundary condition. 
Because Ampere’s law must hold around the wire, a line integral around it must add 

PARAMETER VALUE

E0 0.0836168 V/m

α 1.449621256

JC 17 MA

TC 92 K

∇ E J( )× µ H∂
t∂

--------–=

E J( )
0 J JC<

E0
J JC–

JC
--------------------⎝ ⎠

⎛ ⎞
α J

J
------ J JC≥

=

Da
Hd

dt
-------- ∇+ Γ⋅ F

µ0 0

0 µ0

Hxd
td

-----------

Hyd
td

-----------

⋅ ∇+
0 Ez Jz( )

Ez Jz( )– 0
⋅⇒ 0

0
= =
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up to the current through the wire. Cylindrical symmetry results in a known magnetic 
field at the outer boundary

.

For vector elements, the Dirichlet boundary conditions add a constraint on the 
tangential component of the vector field. If the field components are called Hx and Hy, 
the tangential counterparts are tHx and tHy.

Results and Discussion

The model applies a simple transient exponential function as the current through the 
wire, reaching a final value of 1 MA. This extremely large current is necessary if the 
superconducting wire is to reach its critical current density. Figure 5-11 plots the 
current density at two times after the current starts.

Figure 5-11: The current density at t = 0.02, 0.05, and 0.1. The swelling of the ring comes 
from the transition out of the superconducting state at current densities exceeding JC.

H ld⋅∫° 2πrHφ Iwire Hφ⇒
Iwire
2πr
-------------= = =
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“3D-modelling of bulk type-II superconductors using unconstrained H-formulation,” 
6th European Conf. Applied Superconductivity (EUCAS 2003).

Model Library path: ACDC_Module/General_Industrial_Applications/
superconducting_wire

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 In the Model Navigator, select 2D from the Space dimension list.

2 Select the COMSOL Multiphysics>PDE Modes>PDE, General Form>Time-dependent 

analysis application mode.

3 In the Dependent variables edit field, type Hx Hy. Click OK.

O P T I O N S  A N D  S E T T I N G S

Because the PDE modes do not support units, disable COMSOL Multiphysics’ unit 
handling:

1 From the Physics menu, choose Model Settings.

2 From the Base unit system list, select None, then click OK.

Next, proceed with defining the model.

1 From the Options menu, choose Constants.

2 In the Constants dialog box, define the following constants with names, expressions, 
and descriptions (optional):

NAME EXPRESSION DESCRIPTION

mu0 4*pi*1e-7 Permeability of vacuum (H/m)

alpha 1.449621256 Parameter for resistivity model

Jc 1.7e7 Critical current density (A/m^2)

I0 1e6 Applied current (A)

rho_air 1e6 Resistivity of air (ohm*m)

tau 0.02 Time constant for applied current (s)
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3 Click OK.

G E O M E T R Y  M O D E L I N G

You can access all the dialog boxes for specifying primitive objects from the Draw menu 
under Specify Objects. The first column in the table below contains the labels of the 
geometric objects. These are automatically generated by COMSOL Multiphysics, and 
you do not have to enter them. Just check that you get the correct label for the objects 
that you create.

1 Draw two circles with properties according to the table below.

2 Click the Zoom Extents button on the Main toolbar.

P H Y S I C S  S E T T I N G S

1 From the Options menu, choose Expressions>Scalar Expressions.

2 In the Scalar Expressions dialog box, define the following variables with names, 
expressions, and (optionally) descriptions:

The expression HyxHxy is a predefined short form for Hyx-Hxy, the z-component of 
the curl of the H-field:

Tc 92 Critical temperature (K)

dT 4 Parameter for resistivity model (K)

dJ Jc/1e4 Parameter for resistivity model (A/m^2)

E0 0.0836168 Parameter for resistivity model (V/m)

LABEL RADIUS BASE BASE, X BASE, Y

C1 0.1 Center 0 0

C2 1 Center 0 0

NAME VALUE DESCRIPTION

Jz_sc HyxHxy Current density (A/m^2)

normH_sc sqrt(Hx^2+Hy^2) Norm of the H-field (H/m)

I1 I0*(1-exp(-t/tau)) Applied current (A)

Q_sc Ez_sc*Jz_sc Generated heat in 
superconductor (W/m^3)

NAME EXPRESSION DESCRIPTION

x∂
∂Hy

y∂
∂Hx–
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3 Click OK.

4 From the Options menu, choose Expressions>Boundary Expressions.

5 In the Boundary Expressions dialog box, define the following variable:

6 Click OK.

7 From the Options menu, choose Expressions>Subdomain Expressions.

8 In the Subdomain Expressions dialog box, define the following variable:

Boundary Conditions
1 From the Physics menu, open the Boundary Settings dialog box.

2 Enter boundary conditions according to the following table:

3 Click OK.

Subdomain Settings
1 From the Physics menu, open the Subdomain Settings dialog box.

2 Specify subdomain settings according to the following table:

NAME EXPRESSION ON BOUNDARIES 1, 2, 5, 8 ALL OTHERS

H0phi I1/(2*pi*sqrt(x^2+y^2))

NAME EXPRESSION IN 
SUBDOMAIN 1

EXPRESSION IN SUBDOMAIN 2

Ez_sc rho_air*Jz_sc E0*((Jz_sc-Jc)* 
flc2hs(Jz_sc-Jc-dJ,dJ)/Jc)^alpha

SETTINGS BOUNDARIES 2, 8 BOUNDARIES 1, 5

Boundary condition Dirichlet Dirichlet

R1 H0phi*t1x+tHx H0phi*t1x-tHx

R2 H0phi*t1y+tHy H0phi*t1y-tHy

SETTINGS SUBDOMAINS 1, 2

Γ11 0

Γ12 Ez_sc

Γ21 -Ez_sc

Γ22 0

F1 0

F2 0

Da,11 mu0
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3 Click the Element tab.

4 Make sure that both subdomains are selected, then type shcurl(2,{'Hx','Hy'}) 
in the shape edit field to use second-order vector elements when solving the model.

The shape function entry turns red when you enter a shape function using the syntax 
with curly braces, but you can disregard this indication.

5 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, choose Free Mesh Parameters.

2 From the Predefined mesh sizes list, select Coarse.

3 Click the Subdomain tab. Select Subdomain 2, then type 2e-2 in the 
Maximum element size edit field.

4 Click the Remesh button, then click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 From the Solve menu, choose Solver Parameters.

2 In the Times edit field, type linspace(0,0.1,21).

3 On the Time Stepping page, select the Manual tuning of step size check box. In the 
Initial time step edit field, type 1e-9. In the Maximum time step edit field, type 1e-3.

Da,12 0

Da,21 0

Da,22 mu0

SETTINGS SUBDOMAINS 1, 2
S U P E R C O N D U C T I N G  W I R E  |  265



266 |  C H A P T E R
4 Click OK.

5 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 From the Postprocessing menu, select Plot Parameters.

2 On the General page, make sure that the Surface and Geometry edges check boxes are 
selected in the Plot type area.

3 On the Surface page, verify that Hx is in the Expression edit field.

4 Click OK. 

You should now see the following plot in the drawing area on your screen.

5 From the Postprocessing menu, select Domain Plot Parameters.

6 On the General page, select the solutions at times 0.02, 0.05, and 0.1.

7 Click the Surface tab. From the Subdomain selection list, select Subdomain 2. In the 
Expression edit field, type Jz_sc.

8 Click OK. 

You should now see the plot shown in Figure 5-11 on page 261.
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RF -Hea t e d  Ho t  Wa l l  F u r n a c e  f o r  
S em i c ondu c t o r  P r o c e s s i n g

Introduction

Furnace reactors are used in semiconductor fabrication to grow layers of 
semiconductor materials on wafers. An important aspect is to grow the layers with a 
crystal structure that matches that of the wafer substrate. This is called epitaxial growth 
and is a key technology for the fabrication of electronic devices. For silicon carbide (a 
wide-bandgap semiconductor), epitaxial growth is one of the great challenges towards 
manufacturing reliable devices. 

The layer growth takes place with the wafers sitting in graphite susceptors (wafer 
holders) at very high temperatures in the range of 2000 °C. The susceptors are heated 
with radio-frequency (RF) coils at power levels in the 10 kW range. The design of the 
reactor chamber is crucial for maintaining a uniform temperature, efficient heating, 
and control of high-temperature regions. It is especially important that the quartz tube 
surrounding the susceptor remains at moderate temperatures.

This COMSOL Multiphysics model examines a simple furnace design that heats a 
graphite susceptor using an 8-kW RF signal at 20 kHz. It determines the temperature 
distribution over the wafer along with the temperature on the outer quartz tube. At 
these high temperatures the heat flux is dominated by radiation. The model requires 
the AC/DC Module and the Heat Transfer Module.

Model Definition

Figure 5-12 shows the furnace geometry. The quartz tube is surrounded by six coils 
that carry the RF power. The alternating field induces currents in the conductive center 
of the graphite susceptor, and these currents heat that wafer holder. The wafer is placed 
at the bottom of a chamber located inside the susceptor, where almost the entire 
bottom is made of silicon carbide to avoid contamination. The outer part of the 
susceptor is made of graphite foam, which serves as thermal insulation.
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Figure 5-12: The furnace geometry cut in half. Note that you need model only one quarter 
of the full geometry due to symmetry.
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Thanks to symmetry, you can twice divide the furnace in half and thus need include 
only a quarter of its geometry in the simulation.

Figure 5-13: The part of the geometry included in the simulation, also with the 
surrounding air domain.

The coils are made of copper, and at the frequency of interest the skin depth is in the 
order of 0.5 mm, so it is possible to model the current as a surface current. In fact, 
because the center core of the coils does not conduct current, they are actually 
constructed as tubes. These surface currents make it possible to use one of the 
AC/DC Module’s induction-current application modes, which solves only for the 
A-field. The total current used in this case is 21.5 kA, which corresponds roughly to 
8 kW of heating power.

This example solves for the temperature only in the susceptor and the quartz tube. It 
models heat flux between the susceptor and the tube with surface-to-surface radiation. 
The only part where heating occurs is in the inner part of the susceptor, which is made 
of pure graphite. The graphite foam outside has a lower thermal conductivity and zero 
electric conductivity. The bottom surface of the hole in the susceptor is modeled as a 
highly conductive layer because it is made of silicon carbide, which has a very high 
thermal conductivity. The layer’s thickness is 1 mm, which also includes the wafer 
thickness.
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The following table summarizes all the material properties used in this simulation:

The temperature dependence of the thermal conductivity is necessary due to the high 
temperature range in the susceptor.

In this model you neglect the temperature dependence of the electric conductivity. 
This enables COMSOL Multiphysics to solve the application modes sequentially, 
which saves memory. The problem can be solved fully coupled with a temperature 
dependent conductivity on high-performance computers. By using the Induction 
Heating predefined multiphysics coupling, it is easy to take the electro-thermal 
interaction into account.

Results and Discussions

The temperature difference over the wafer should be as small as possible; a large 
difference can cause nonuniform thicknesses and properties in the grown layer. The 

PARAMETER COPPER GRAPHITE GRAPHITE 
FELT

QUARTZ SILICON 
CARBIDE

Heat capacity 584 710 200 820 1200

Density 8700 1950 120 2600 3200

Thermal 
conductivity

400 150 · 
(300/T)

0.3 3 450 ·  
(300/T)^0.75

Electric 
conductivity

5.998e7 1e3 100 1e-12 1e3

Permittivity 1 1 1 4.2 10

Emissivity 0.5 1 1 0.7 0.5
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heating cycle is also interesting to view, and Figure 5-14 compares the temperature at 
the center of the wafer to that at the edge during 1 hour of heating at 8 kW.

Figure 5-14: The temperature at two locations on the wafer during a heating cycle of one 
hour.

The graphite felt around the susceptor acts as a high-temperature thermal insulator for 
the system. This makes the furnace more efficient in terms of power usage, and it also 
keeps high temperatures away from the quartz tube. The temperature distribution in 
Figure 5-15 shows how hot the quartz tube gets and how well the graphite felt 
insulates the susceptor. The maximum temperature of the quartz tube is approximately 
900 K, and that tube should be water or air cooled to further reduce its temperature; 
this model takes only radiation to the ambient into account. COMSOL Multiphysics 
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use extrusion coupling variables to copy the solution to the other symmetry half in this 
model, producing a more complete plot.

Figure 5-15: Temperature distribution for the important parts of the furnace. The coils 
are plotted only to show their location, there is no temperature information on their 
surfaces.

The temperature distribution across the wafer can often be seen in variations of the 
layer properties, so it is crucial that the temperature be uniform across the surface. The 
surface plot in Figure 5-16 shows the temperature over one half of the silicon-carbide 
 5 :  G E N E R A L  I N D U S T R I A L  A P P L I C A T I O N  M O D E L S



wafer. The 150 °C difference is rather large. Gas flow is another important source of 
nonuniformities, but this simulation does not consider it.

Figure 5-16: Temperature distribution across the surface of the wafer.

Model Library path: ACDC_Module/General_Industrial_Applications/
hot_wall_furnace

Note: This model requires both the AC/DC Module and the Heat Transfer Module.

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 In the Model Navigator, select 3D in the Space dimension list.
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2 Select AC/DC Module>Electro-Thermal Interaction>Induction Heating>Transient 

analysis.

3 Select Vector, Lagrange - Linear from the Element list.

4 Click OK to close the Model Navigator dialog box.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, choose Constants.

2 In the Constants dialog box, define the following constant with name and 
expressions. The description field is optional.

3 Click OK.

4 From the Options menu, choose Expressions>Scalar Expressions.

5 In the Scalar Expressions dialog box, define the following expressions:

Because of the use of integration coupling variables (C_coil and V_coil), 
COMSOL Multiphysics cannot determine the unit for other variables that directly 
or indirectly depend on these integration coupling variables. This causes the 
warnings for inconsistent units here and in the specification of the surface current 
density. You can disregard these warnings.

6 Click OK.

G E O M E T R Y  M O D E L I N G

The geometry modeling of this model is rather extensive, so it is possible to import the 
furnace geometry from a binary file. Select the section that you prefer.

Importing the Geometry from a Binary File
1 From the File menu, select Import>CAD Data From File.

2 In the Import CAD Data From File dialog box, make sure that either COMSOL 

Multiphysics file or All 3D CAD files is selected in the Files of type list.

NAME EXPRESSION DESCRIPTION

I_coil 2150[A] Coil current

NAME EXPRESSION DESCRIPTION

Js_coil I_coil/C_coil Surface current on coil

Pav_coil 4*2.5*0.5*real(I_coil* 
conj(V_coil))

Heating power in coils
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3 From the COMSOL Multiphysics installation directory, go to the model library 
path given on page 273. Select the hot_wall_furnace.mphbin file, and click 
Import.

4 Skip the section “Creating the Geometry from Scratch” and continue at “Physics 
Setting” on page 278.

Creating the Geometry from Scratch
1 From the Draw menu, choose Work-Plane Settings, and click the y-z option button.

2 Click OK.

3 Create three rectangles with the specifications in the table below. You create them 
easiest from the dialog box that you open by choosing Draw>Specify 

Objects>Rectangle.

4 Click the Zoom Extents toolbar button.

5 Choose Fillet/Chamfer from the Draw menu.

6 In the Fillet/Chamfer dialog box, expand rectangle R1, and select its vertex numbers 
2 and 3. Enter 5e-3 in the Radius edit field.

7 Click Apply. The former rectangle R1 is now labeled CO1.

8 Then expand rectangle R3, select its Vertices 2 and 3, and enter 0.02 in the Radius 
edit field.

9 Click OK. The former rectangle R3 is now labeled CO2.

10 Select the objects labeled R2 and CO1, and click the Difference button on the Draw 
toolbar.

11 Select the objects labeled R4 and CO2, and click the Difference button again.

12 From the Draw menu, choose Extrude.

13 In the Extrude dialog box, select the objects CO1 and CO3, and enter 0.15 in the 
Distance edit field.

14 Click OK. The program switches to the 3D view, where the extruded objects 
represents the susceptor and its thermal insulation.

NAME WIDTH HEIGHT X Y BASE

R1 0.075 0.02 0 -0.01 Corner

R2 0.1 0.05 0 -0.025 Corner

R3 0.15 0.1 0 -0.05 Corner

R4 0.1 0.05 0 -0.025 Corner
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15 From the Draw menu, choose Work-Plane Settings again, and click the z-x option 
button to use a different work plane.

16 Click OK.

17 Press Ctrl+A to select all objects in the work plane, and then press the Delete key to 
clear the work plane.

18 Create three rectangles with the specifications according to the table below.

19 Select both rectangles and click the Union toolbar button.

20 Click the Delete Interior Boundaries toolbar button to remove unnecessary 
boundaries.

21 Use the menu option Draw>Specify Objects>Circle to create three circles with the 
specifications according to the table below.

22 Create a line going from the coordinate (0.195, 0) to the coordinate (0.225,0).

23 Select the line B1 and the circle C1 and click the Coerce to Solid toolbar button.

24 Click the Split Object toolbar button and select the side of the circle labeled CO4.

25 Press the Delete key to delete this side.

26 From the Draw menu, choose Revolve.

27 Select the objects CO2, CO3, C2, C3, R3. Enter -180 in the α2 edit field.

28 Click OK. You are in the 3D view again, and now you have created the quartz tube 
and the coils. One of the coils was split in half due to the use of symmetry in this 
model. Define one last work plane to draw the items inside the susceptor.

29 From the Draw menu, choose Work-Plane Settings again, and click the x-y option 
button.

30 Click OK.

NAME WIDTH HEIGHT X Y BASE

R1 0.18 0.01 0 0.25 Corner

R2 0.01 0.25 0.17 0 Corner

R3 0.45 0.5 0 0 Corner

NAME RADIUS X Y BASE

C1 0.015 0.21 0 Center

C2 0.015 0.21 5e-2 Center

C3 0.015 0.21 1e-1 Center
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31 Press Ctrl+A to select all objects in the work plane, and then press the Delete key to 
clear the work plane.

32 Create a circles with radius 0.05 centered at the origin.

33 Create a line going from the coordinate (0, 0) to the coordinate (0.05,0).

34 Select the circle and the line, click the Coerce to Solid toolbar button, and then click 
the Split Object toolbar button.

35 Select and delete the lower part of the circle labeled CO2.

36 Create a rectangle with width 0.15, height 0.055, and the corner coordinate in the 
origin.

37 Choose Embed from the Draw menu, select all objects (CO2 and R1), and click OK.

The simulation domain is now finished. However, to improve the plot view, some parts 
of the furnace can be mirrored to the other side of the x = 0 symmetry plane. The 
mirrored part is only used for postprocessing and does not influence the simulation.

1 Select all objects except the largest cylinder. The selected objects should have the 
labels EXT1, EXT2, REV1, REV2, REV3, REV4, EMB1, and EMB2.

2 Click the Mirror toolbar button.

3 In the Mirror dialog box, set the Normal vector edit fields to (1,0,0), and click OK.
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4 Click Zoom Extents and click the Headlight toolbar button. With the proper objects 
selected the geometry should look like that in the figure below.

P H Y S I C S  S E T T I N G

Variables
1 From the Physics menu, choose Scalar Variables.

2 Enter 20e3 in the nu_emqa edit field, then click OK.

3 From the Options menu, choose Integration Coupling Variables>Edge Variables.

4 In the Edge Integration Variables dialog box, enter the following variables with names 
and expressions at the specified edges. The Global destination check box should be 
selected for all variables.

NAME EDGES EXPRESSION DESCRIPTION

C_coil 221, 222, 
230, 232

1 Gives the circumference 
of one coil

V_coil 217 Ex_emqa*t1x+ 
Ey_emqa*t1y+ 
Ez_emqa*t1z

Induced voltage along one coil

220 -(Ex_emqa*t1x+ 
Ey_emqa*t1y+ 
Ez_emqa*t1z)

Induced voltage along one coil
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5 From the Options menu, choose Extrusion Coupling Variables>Subdomain Variables.

6 In the Subdomain Extrusion Variables dialog box, select Subdomains 9, 11, and 12, 
and enter T_map in the Name column.

7 Then click the General Transformation option button. Leave the transformation 
expressions at their defaults.

8 Enter the T in the Expression column in the same row as the T_map variable.

9 Click the Destination tab. Make sure that the Geometry list has Geom1 chosen, then 
choose Subdomain in the Level list.

10 Select Subdomains 1, 2, and 3. Select the Use the selected subdomains as destination 
check box.

11 Enter -x in the x edit field for the Destination transform.

12 Click OK. The temperature in Subdomains 9, 11, and 12 are now mirrored into 
Subdomains 1, 2, and 3. The mirrored version of the temperature is available there 
as the variable T_map.

13 Choose Expressions>Boundary Expressions from the Options menu.

14 In the Boundary Expressions dialog box, define a variable named T_bnd with the 
following expressions for the specified boundary numbers. Due to the large number 
of boundaries, there is a technique is outlined below the table that selects all these 
boundaries from the geometry directly.

15 Click OK.

16 The technique involves rectangular mouse selections in 3D, just skip Steps 
16–25 if you prefer to select the boundaries by number according to the table 
above. By default the mouse controls the 3D view (panning, rotating, zooming), so 
first click the Orbit/Pan/Zoom toolbar button to disable the 3D view control.

17 Then click the Go to ZX View toolbar button to get a proper view for the selection.

18 Place the mouse pointer just outside the quartz tube and click and drag it to the 
other side of the tube that you solve for. View the left figure below for guidance, 

NAME EXPRESSION FOR BOUNDARIES 
68–94, 97, 104–112, 133–140

EXPRESSION FOR BOUNDARIES 
1–32, 51

T_bnd T T_map
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which shows the selection rectangle to draw with the mouse and the selection after 
you release the mouse button.

19 Right-click with the mouse on the selected region to lock the selection. The selected 
objects then get a blue color like the right figure above.

20 Go back to the Boundary Expressions dialog box and enter T in the Expression column 
in the same row as the T_bnd name.

21 Do a new selection starting at the same point as before, but extend it to include the 
entire tube. The selection now looks like that in the left figure below.

Start here

Stop here

Start here

Stop here
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22 The green selection shows the locked boundaries (blue before) that are scheduled 
for deselection. The pink ones are the boundaries you selected that where not 
selected before. Right-click on the selection to confirm the green deselection and 
lock the pink selection. The view should now look like the right figure above.

23 Go to the Boundary Expressions dialog box and enter T_map in the Expression column 
in the same row as the T_bnd name.

24 Click OK to close the dialog box.

25 Click the Go to Default 3D View toolbar button and then click the Orbit/Pan/Zoom 
toolbar button to restore the settings as it were before.

P H Y S I C S  S E T T I N G S

Subdomain Settings—General Heat Transfer
For multiphysics modeling with several application modes present in the model, there 
is a convenient feature on the left side of the graphical user interface. It is called the 
Model Tree, and you can show it or hide it by clicking the Model Tree toolbar button. 
Adjust the size of the Model Tree area and the size of its frames so it looks similar to 
what you see in the figure of the final geometry above. The steps below assume that 
you have the Model Tree visible and sized correctly. Also, make sure to select the Detail 
view.

1 In the Model Tree, double click on the item Geom1>General Heat Transfer (htgh)> 

Subdomain Settings.

2 In the Subdomain Settings dialog box, select Subdomain 9 and then click the Load 
button to open the Materials/Coefficients Library dialog box.

3 Select the Quartz material under the acdc_lib.txt library.

4 Click Apply. This adds the material Quartz to the model. You see which materials you 
have added to the model when you expand the Model node in the Materials list to 
the left in the Materials/Coefficients Library dialog box.
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5 Repeat the two last steps for the materials Graphite, Graphite felt, Copper, and 
Silicon Carbide. Before you close the dialog box, make sure that you see all five 
materials under Model in the Materials tree view.

6 Click Cancel to close the Materials/Coefficients Library dialog box. The selected 
materials are now available in the Library material list.

7 Choose Quartz from the Library material list.
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8 Click the Groups tab, and enter Tube in the Name edit field.

9 Click the Color tab, select the Manual control of color check box, and click the Color 
button.

10 Select the a bright purple color from the palette, or enter (255, 153, 253) under the 
RGB tab. Click OK.
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These last two steps and future steps that change the color of a group are only 
necessary to get a nicer view of the geometry, so you can skip these steps.

11 In the Subdomain Settings dialog box, define settings for the other subdomains 
according to the table below. If desired, repeat Steps 9 and 10 to define a color for 
each group.

12 Under the Groups tab, select the group default in the Group selection field. Click the 
Subdomains tab, and clear the Active in this subdomain check box.

13 Click OK to close the Subdomain Settings dialog box.

Subdomain Settings—Induction Currents
1 In the Model Tree, double click the item Geom1>Induction Currents (emqa)> 

Subdomain Settings.

SETTINGS SUBDOMAIN 11 SUBDOMAIN 12

Material Graphite felt Graphite

Group name Felt Susceptor

Color (153, 153, 153) (51, 51, 51)
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2 Define settings for the other subdomains according to the table below in the same 
as for the Heat Transfer application mode. If desired, repeat Steps 9 and 10 to define 
a color for each group.

3 Click the Subdomains tab and select Subdomains 1, 2, 3, 4, 5, 6, 8, 13, and 14. Clear 
the Active in this subdomain check box.

4 Select the remaining Subdomains 7 and 10, click the Groups tab, and type Air in the 
Name edit field.

5 Click OK to close the Subdomain Settings dialog box.

The coils are not included in this simulation since the skin-depth is very short for the 
applied frequency. The coils are instead modeled as a surface current boundary 
condition.

Boundary Conditions—General Heat Transfer
1 In the Model Tree, double click on the item Geom1>General Heat Transfer (htgh)> 

Boundary Settings.

2 In the Boundary Settings dialog box, define settings according to the table below.

3 Select Boundaries 81 and 104 again, click the Highly Conductive Layer tab, and select 
the Enable heat transfer in highly conductive layer check box.

4 In the Distance edit field type 1e-3 to set the thickness of this highly conductive 
layer.

5 Click OK to close the Boundary Settings dialog box.

SETTINGS SUBDOMAIN 9 SUBDOMAIN 11 SUBDOMAIN 12

Material Quartz Graphite felt Graphite

Group name Tube Felt Susceptor

SETTINGS BOUNDARIES 
76, 86, 91, 105–
108, 110–112, 
133, 134

BOUNDARIES 81, 
104

BOUNDARIES 73, 
94, 136, 137

BOUNDARIES 
70, 97, 135, 138–
140

Material Graphite felt Silicon Carbide Quartz Quartz

Boundary condition Heat flux Heat flux Heat flux Heat flux

Radiation type Surface-to- 
Surface

Surface-to- 
Surface

Surface-to- 
Surface

Surface-to- 
Ambient

Tamb T T T 293.15

Group name Susceptor Slide Tube_inner Tube_outer
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Boundary Conditions—Induction Currents
1 In the Model Tree double click the item Geom1>Induction Currents (emqa)>Boundary 

Settings.

2 In the Boundary Settings dialog box define settings according to the table below.

3 Click OK to close the Boundary Settings dialog box.

M E S H  P A R A M E T E R S

1 Open the Free Mesh Parameters dialog box from the Mesh menu.

2 Click the Custom mesh size option button, and enter 0.5 in the Mesh curvature factor 
edit field.

SETTINGS BOUNDARIES 60, 66, 68, 
71, 74, 77, 80, 82, 84, 87, 
90, 92, 95, 101

BOUNDARIES 65, 67, 100, 102, 113, 
114, 116, 117, 119, 120–124, 126, 127, 
129-132

ALL OTHERS

Boundary condition Electric insulation Surface current Magnetic 
insulation

Js 0

Js_coil*t2y

Js_coil*t2z

Group name Symmetry Coil
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3 Click the Boundary tab, and select all boundaries between the felt and the susceptor. 
The numbers of these boundaries are 16, 18, 23, 29, 79, 89, 109, and 134.

4 Enter 6e-3 in the Maximum element size edit field.

5 Click Remesh.

6 Click OK.

S O L V E R  P A R A M E T E R S

1 Open the Solver Parameters dialog box from the Solve menu.

2 With the Auto select solver check box selected, select Stationary from the Analysis list.

3 Click the Stationary tab and choose Linear from the Linearity list (the model is linear, 
but the automatic selection chooses the nonlinear solver for this model because of 
the coupling variables).

4 Click OK.

5 Open the Solver Manager dialog box from the Solve menu.
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6 Click the Solve For tab, and select only the Induction Currents (emqa) application 
mode in the tree view.

7 Click OK.

8 Click the Solve toolbar button.

9 When the solution process is done open the Solver Parameters dialog box again.

10 From the Analysis list, select Transient, then type 0 3600 in the Times edit field.
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11 Click the Time Stepping tab and choose Time steps from solver in the Times to store 

in output list.

12 Click OK.

13 Open the Solver Manager, select to solve only for the General Heat Transfer (htgh) 
application mode on the Solve For page.

14 Click the Initial value tab, and in the frame Values of variables not solved for and 

linearization point click the Current solution button. This ensures that the solution 
for the induction currents problem is kept while solving the transient heat transfer 
problem.

15 Click OK to close the Solver Manager.

16 Click the Solve toolbar button.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Open the Plot Parameters dialog box from the Postprocessing menu.

2 Under the General tab, clear the Slice and Geometry edges check boxes, and select the 
Boundary and Edge check boxes.

3 Click the Boundary tab and enter T_bnd in the Expression edit field.

4 Click the Range button. In the dialog box that appears, clear the Auto check box, and 
enter 0 and 2300 in the Min and Max edit field.
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5 Click the Edge tab, enter 1 in the Expression edit field, click the Uniform color option 
button, and select black color for the edges.

6 Click OK to show the plot in the main window.

To get the plot in Figure 5-15 on page 272 you need some extra steps. It is necessary 
to plot into a separate figure and to do overlaid plots. To make plots only in certain 
regions you either use Suppress>Boundaries from the Options menu, or define boundary 
expressions of the quantity you whish to plot. These techniques makes it possible to 
remove boundaries from the plot. Then you do separate plots for the susceptor, the 
tube, and the coils. Remember to select the Keep current plot check box in the Plot 

Parameters dialog. Make the plot for the coils with a uniform copper-like color. In the 
created figure you can click the Edit Plot toolbar button, and select individual 
properties for the plots you made. In Figure 5-15 on page 272 there is also a 
transparency set on the tube plot.

The next step is to generate line plots of the temperature versus time at two location 
on the silicon carbide wafer, center and periphery.

1 From the Postprocessing menu, choose Domain Plot Parameters.

2 In the Domain Plot Parameters dialog box, click the Point tab and select points 
number 64 and 102. This is the center and periphery of the SiC wafer.

3 Click the Line settings button, and choose Cycle in the Line marker list.
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4 Select the Legend check box and click OK.

5 Click OK again to get the line plot in a new figure window.

6 In the new figure, click the Edit Plot toolbar button. Select the Line (64) item from 
the tree view, and then type Center Periphery in the Legends edit field.

7 Click OK. You should now see a plot similar to that in Figure 5-14 on page 271.

The final plot is a surface plot of the temperature across SiC wafer. Because half the 
wafer is outside the simulated region you must use the boundary variable, T_bnd, to 
see the temperature.

1 Open Domain Plot Parameters, click the General tab and select only the solution at 
time 3600 from the list of time steps.

2 Click the Surface tab, select Boundaries 51 and 81, enter T_bnd in the Expression edit 
field, and choose xy-plane from the list in x- and y-axis data.

3 Click the Range button. In the dialog box that appears, enter 2100 and 2300 in the 
Min and Max edit fields, respectively.

4 Click OK twice to get the surface plot in the opened figure window.

5 In the figure, click the Edit Plot toolbar button. Select the Axis item from the tree 
view, and then enter Temperature [K] in the Title edit field.

6 Click OK to get the plot in Figure 5-16 on page 273.
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An RF ID S y s t em

This example illustrates the modeling of a reader-transponder pair for radio-frequency 
identification (RFID) applications.

Introduction

An RFID system consists of two main parts:

• A tag or transponder with a printed circuit-board (PCB) antenna

• A reader unit with a larger RF antenna

The reader antenna generates an electromagnetic field that energizes a chip 
(IC-circuit) inside the tag. The electromagnetic field is modulated by the tag’s circuit 
and the modulated signal is recovered by the reader antenna.

The transponder antenna is typically a conductor pattern on a substrate:
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and a common type of reader antenna is a larger dual coil:

I N D U C T I V E  C O U P L I N G

The coupling of the antennas is mainly inductive and is characterized by the mutual 
inductance, denoted L12. The mutual inductance is defined as the total magnetic flux 
intercepted by one antenna for a unit current flowing in the other antenna

where S2 is the area of coil number 2, B is the flux intercepted by coil 2, I1 is the 
current running in coil number 1, n = (nx, ny, nz) is the unit surface normal vector, 
and dS is an infinitesimal area element.

It is possible to transform this into a simpler line integral by using the magnetic vector 
potential:

together with the so-called Stokes theorem, stating that a surface integral of the curl 
of a field equals the closed line integral over the rim of the surface:

 

where t=(tx, ty, tz) is the unit tangent vector of the curve ΓS, and where dl is an 
infinitesimal line element.

L12

B n⋅ Sd
S2

∫∫
I1

------------------------------=

B ∇ A×=

L12

∇ A×( ) n⋅ Sd
S2

∫∫
I1

---------------------------------------------

A tdl⋅
ΓS

∫°
I1

-----------------------= =
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Because the coupling is dominated by near-field inductive effects, it is sufficient to 
compute the mutual inductance for the static case (frequency equals zero) and neglect 
capacitive effects along with wave propagation phenomena. The appropriate 
application mode to use is called 3D Magnetostatics and is available in the AC/DC 
Module. It has the magnetic vector potential A = (Ax, Ay, Az) as its unknown field 
quantity.

E D G E  C O M P U T A T I O N S

This example approximates coils and wires as edges (1-D entities) embedded in 3D 
space and the variables and techniques used are somewhat different than for a regular 
magnetostatics boundary value problem. The magnetic vector potential components 
are available at edges as the variables tAx, tAy, and tAz, which form the projection of 
the vector potential on edges. On the other hand, the bulk components are denoted 
Ax, Ay, and Az.

In COMSOL Multiphysics, each edge has a direction associated with it, and in order 
to form a closed line integral it is necessary to manually find the direction of each edge 
and flip this if needed. Flip the edge directions by the following procedure: for each 
edge that participates in a line integral or line source, define an Edge Expression esgn 
that takes the values -1 and +1 depending on if the built-in direction of the edge agrees 
with the global direction of the closed line integral. (It is up to the user to decide for 
a global direction of a closed line integral.)

Results

The computed value for the mutual inductance L12 is about 1 nH.
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The following visualization shows magnetic flux lines and the base-10 logarithm of the 
magnetic flux intensity as color.

The following visualization shows the edges of the finite elements used:
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Model Library path: ACDC_Module/General_Industrial_Applications/rfid

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 From the Model Navigator, set the Space Dimension to 3D.

2 In the list of application modes, select AC/DC Module>Statics>Magnetostatics.

3 Click OK to open the main GUI.

D R A W  M O D E

We will start by drawing the transponder antenna in a 2D work plane and then embed 
it into 3D space.

Transponder Antenna
1 From the Draw menu, select Work-Plane Settings.

2 Click the z-x plane button with y = 0.

3 Click OK to create the work plane.

4 From the Draw menu, select Specify Objects>Line.

5 In the Line dialog box, type a space separated list of vertex coordinates according to 
the following: 

X: 0.8875 0.8875 0.9125 0.9125 0.89 0.89 0.91 0.91 0.8925 0.8925 
0.9075 0.9075 0.895 0.895 0.8875

Y: 0 0.01 0.01 -0.01 -0.01 0.0075 0.0075 -0.0075 -0.0075 0.005 0.005 
-0.005 -0.005 0 0

6 Click OK to create the transponder profile.

7 Click the Zoom Extents button on the main toolbar to automatically adjust the axis 
settings to get a good view of the transponder profile.

Reader Antenna
Next, create the reader antenna.

1 From the Draw menu, select Specify Objects>Rectangle.

2 Type values for a rectangle with Width: 1.8, Height: 0.8, Base: Corner, x: 0, y: -0.4, 
Style: Curve.
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3 Click OK to create the rectangle.

4 Click the Zoom Extents button.

5 To create rounded corners, or fillets, for the rectangle, click the Fillet/Chamfer 
button.

6 In the Vertex selection list, click the object R1 (the rectangle) and select all 4 vertices 
by using Ctrl+left click or Ctrl+A.

7 Specify a Radius of 0.2.

8 Click OK to apply the fillets.

Embedding into 3D Space
Now embed the two flat shapes into 3D space.

1 From the Draw menu, select Embed.

2 Highlight both objects B1 and B2.

3 Click OK to embed the objects into 3D space.

4 Click on the edge on the larger coil to select it. Make sure it is highlighted in red.

5 Click the Move button.

6 For the y-displacement, type -0.4.

7 Click OK to displace the large coil element 0.4 m in the negative y direction.

8 To create a mirror-image of the large coil, make sure it is highlighted and click the 
Mirror button.

9 Change the Normal vector from 0 0 1 to 0 1 0.

10 Click OK to create the mirrored image.

Truncation Sphere
You also need to truncate the computational domain, because the finite element 
calculation requires a finite-sized mesh. Do this with a large sphere with center in the 
middle of the coil system.

1 From the Draw menu, select Sphere.

2 Set the Radius to 3.

3 Set the Axis base point to x: 0, y: 0, z: 0.9.

4 Click OK to create the sphere.

Make sure to save the model at this point to be able to revert to this stage if needed.
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S U B D O M A I N  S E T T I N G S

1 From the Physics menu, select Subdomain Settings.

2 The material parameter that you can alter for a magnetostatic simulation is the 
magnetic permeability µr. However, assume that the truncation sphere is filled with 
air and leave the default setting µr=1.

3 Click OK to close the dialog box.

B O U N D A R Y  S E T T I N G S

1 From the Physics menu, select Boundary Settings.

2 The default boundary condition for the faces that constitute the sphere is Magnetic 

insulation. This allows for surface currents to run across the sphere in such a way as 
to make the tangential component of the magnetic vector potential equal to zero. 
This is a good approximation in place of an infinite domain. It approximates that the 
tangential component of the vector potential approaches zero as the distance from 
the coils approaches infinity. Thus there is no need to change the boundary settings.

3 Click OK to close the dialog box.

E D G E  S E T T I N G S

Now define the driving line currents of the reader antenna. To do this you need to find 
the direction of all edges of the reader antenna and flip the direction when needed. You 
also need the suppress edges feature available from the Options menu to conveniently 
visualize and click the edges. This is a bit technical compared to regular use of the 
graphical user interface, and the reason is that edges fill up a much smaller part of the 
screen than boundaries and subdomains and hence edges are harder to select by mouse 
clicking.

To enhance the visualization of edges before you start the selection process, widen the 
appearance of the edges and turn on a smoothing feature called antialiasing. Hardware 
acceleration standards supported by many graphics cards support this edge-smoothing 
feature.

1 From the Options menu, select Preferences.

2 Click the Visualization tab and change the line width from 1.0 to 1.5.

3 Select the check box for Antialiasing.

4 Click OK to close the dialog box.

Now, to the edge suppression:
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1 From the Options menu, select Suppress>Suppress Edges. Keep this dialog open but 
move it aside while performing steps 2 and 3.

2 Click the Orbit/Pan/Zoom toolbar button on the Camera toolbar to disable this 
feature.

3 Click and drag, using the left mouse button, a rubber-band box enclosing the reader 
antenna and the transponder antenna. Make sure the edges are highlighted in red.

4 In the Suppress Edges dialog box, click Apply.

5 Click Invert Suppression.

6 Click OK to close the dialog box.

7 Click the Zoom Extents button.

8 Click the Orbit/Pan/Zoom toolbar button on the Camera toolbar to enable this 
feature.

Now visualize the direction of the edges. To do this you need to enter Postprocessing 
mode. You normally cannot do this until you have solved the problem. However, for 
these situations there is a feature to help called Update Model.

1 From the Solve menu, select Update Model. This creates a mesh and puts you in 
Postprocessing mode. Please note that for a general situation you might need to 
adjust the mesh parameter settings before selecting Update Model.

2 From the Postprocessing menu, select Plot Parameters.

3 On the General page, clear the Slice and Geometry Edges check boxes

4 Select the Plot type called Arrow.

5 Click the Arrow tab.

6 Change the Plot arrows on setting to Edges.

7 For the x component, y component, and z component type t1x, t1y, and t1z, 
respectively. These are the components of the edge tangent vector.

8 For the Arrow type, change to 3D arrow.
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9 Click OK.

To see which edge correspond to which edge number, we need to turn on the edge 
label visualization.

1 From the Options menu, select Labels>Show Edge Labels.

2 To see the edge labels you need to switch to the Edge mode. To alter between the 
Postprocessing mode and Edge mode, click the corresponding buttons on the main 
toolbar.

Apply a right-hand rule for the edge directions so that edges circling in the direction 
from the z-axis to the x-axis with the thumb pointing in the y direction are considered 
to be of positive sign.

We will now define an Edge Expression esgn that controls the flip of the edge 
directions.

1 From the Options menu, select Expressions>Edge Expressions.

Use the left mouse button to click the edges or the edge labels and to highlight them 
in red. Then click the right mouse button to lock the selection. You can undo all 
selections by pressing Ctrl+D or by selecting Deselect all from the Edit menu.

2 Select Edges 5, 7, 8, 10, 12, 14, 42, and 44. While all these are highlighted, type 
esgn for the Name and 1 for the Expression.
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3 Select Edges 6, 9, 11, 13, 41, 43, 45, and 46. While all these are highlighted, type 
-1 for the Expression. These are the edges for which you will flip the direction.

4 Click OK to close the dialog box.

5 From the Physics menu, select Edge Settings.

6 Select Edges 5 through 14 and 41 through 46.

7 In the text field for the Current in edge segment direction, type esgn.

8 Click OK to close the dialog box.

M E S H  S E T T I N G S

1 From the Mesh menu, select Free Mesh Parameters.

2 Change the Predefined mesh sizes to Extremely coarse.

3 Click the Remesh button.

4 Click OK to close the dialog box.

S O L V E R  S E T T I N G S

1 From the Solve menu, select Solver Parameters.

2 Click the Settings button in the Linear system solver area.

3 In the Linear Systems Solver Settings dialog box, select Preconditioner from the tree 
view.

4 From the Preconditioner list, select SSOR gauge.

5 Click OK twice to close both dialog boxes.

6 To solve, click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G

Visualization
1 From the Postprocessing menu, select Plot Parameters.

2 On the General page, clear the Arrow check box.

3 Select the Plot type called Slice.

4 Click the Slice tab.

5 Change the x, y, and z levels to 1, 1, and 1, respectively.

6 Click Apply.
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7 Click Zoom Extents.

8 Click the Streamline tab.

9 Select the Streamline plot check box in the upper left corner.

10 Click OK to generate the visualization.

The starting point for the magnetic field lines (streamlines) is randomized and they are 
unevenly distributed. However, you can see that the magnetic field lines are 
qualitatively following the expected pattern.

This solution was obtained using a very coarse mesh. Later you will solve for a finer 
mesh and get better accuracy.

Inductance Computation
Now compute the line integral for the close transponder antenna loop. This also 
requires that you to flip direction of edges and you will continue to define the esgn 
variable also for the transponder edges. For convenience, first suppress all edges except 
those of the transponder.

1 From the Options menu, select Suppress>Suppress Edges.

2 Click the Orbit/Pan/Zoom toolbar button on the Camera toolbar to disable this 
feature.
 5 :  G E N E R A L  I N D U S T R I A L  A P P L I C A T I O N  M O D E L S



3 Click the Zoom Extents button.

4 Click and drag, using the left mouse button, a rubber-band box enclosing the 
transponder antenna. Make sure the edges are highlighted in red.

5 In the Suppress Edges dialog box, click Apply.

6 Click Invert Suppression.

7 Click OK to close the dialog box.

8 Click the Zoom Extents button.

9 Click the Orbit/Pan/Zoom toolbar button on the Camera toolbar to enable this 
feature.

Now visualize the direction of the transponder edges.

1 From the Postprocessing menu, select Plot Parameters.

2 On the General page, clear all check boxes

3 Select Arrow and Edge for Plot type.

4 Click the Arrow page.

5 Change the Plot arrows on setting to Edges.

6 For the x, y, and z component make sure they are set to t1x, t1y, and t1z, 
respectively.

7 For the Arrow type, select 3D arrow, if not already selected.

8 Click the Edge page.

9 For the Edge color, click Uniform color. This aids in the visualization by outlining the 
edges using a uniform color.
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10 Click OK to close the dialog box and to create the visualizations.

Repeat the same steps as before to flip the edges. You can toggle between Edge mode 
and Postprocessing mode to see which edge number has a positive direction.

1 From the Options menu, select Expressions>Edge Expressions.

2 Use the left mouse button to click the edges or the edge labels and to highlight them 
in red. Then click the right mouse button to lock the selection. You can undo all 
selections by clicking Ctrl+D or select Deselect all from the Edit menu. Alternatively, 
select directly from the Edge selection list in the dialog box by pressing the Ctrl key 
while clicking with the left mouse button.

3 Select Edges 15, 17, 18, 20, 21, 23, 29, 31, and 33. While all these are highlighted, 
type 1 for the Expression corresponding to the Name esgn.

4 Select Edges 16, 19, 22, 30, 32, 34, 38, 39, and 40. While all these are highlighted, 
type -1 for the Expression corresponding to the Name esgn.

5 Click OK to close the dialog box.

Now compute the integral that gives the mutual inductance:
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The current of the reader antenna is set to unity, so there is no computation needed 
for the denominator I1.

For computing the line integral for the mutual inductance use a so-called edge 
integration coupling variable that you name L12 and that sums up the contributions 
to the closed-line integral for each individual segment.

The integrand at each segment is esgn*tA, where tA is the projection of the magnetic 
vector potential in the direction of the unit tangent vector to that edge. The magnetic 
vector potential components at edges are available as tAx, tAy, and tAz and the 
edge-tangent vector components are denoted t1x, t1y, and t1z. The tangent vector 
terminology is inherited from the fact that for a surface the tangent vector comes in 
pairs as t1x, t1y, t1z, and t2x, t2y, t2z. The projection tA is then defined by 
dot-product of the tangent vector and the magnetic potential: 
tA=tAx*t1x+tAy*t1y+tAz*t1z. Define tA as a scalar expression that is available 
globally.

1 From the Options menu, select Expressions>Scalar Expressions.

2 Define a Scalar Expression with name tA and Expression 
tAx*t1x+tAy*t1y+tAz*t1z.

3 Click OK.

To define the edge integration coupling variable:

1 From the Options menu, select Integration Coupling Variables>Edge Variables.

2 Select Edges 15–23, 29–34, and 38–40. For this selection you can use Ctrl+left 
click.

3 Define a variable with the Name L12 and Expression tA*esgn. You can leave the 
Integration order and Global destination by their defaults. The variable L12 will have 
global scope for use in postprocessing - it can be used in any of the postprocessing 
dialog boxes. 

4 Click OK.

You need to explicitly tell the software to evaluate these newly defined variables:

L12

A tdl⋅
ΓS

∫°
I1

---------------------- A tdl⋅
ΓS

∫°= =
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1 From the Solve menu, select Update Model. This re-evaluates all variables without 
re-solving.

To get the value of the mutual inductance variable L12:

1 From the Postprocessing menu, select Data Display>Global.

2 For the Expression to evaluate, type L12.

Click OK to evaluate. A value of about 9·10−10 is displayed in the history log at the 
bottom of the GUI window. This corresponds to a mutual inductance of 0.9 nH.

S O L V I N G  F O R  A  F I N E R  M E S H  U S I N G  G M G + G M R E S  S O L V E R

Next, solve the problem using the geometric multigrid (GMG) preconditioner and the 
iterative FGMRES linear system solver. The GMG preconditioner creates a hierarchy 
of meshes and solves for the coarsest mesh using a direct solver. Then it interpolates 
the results to an automatically or manually created finer mesh in a process toward a 
final solution. In this case, GMG is terminated before it reaches the final solution and 
instead the partial results is used as a so called preconditioner for the FGMRES iterative 
solver. This combination of iterative solver and preconditioner is very efficient for 
solving a large class of problems and proves efficient also for this example.

1 From the Solve menu, select Solver Parameters.

2 Change the Linear system solver to FGMRES.

3 Click the Settings button.

4 In the Linear Systems Solver Settings dialog box, select Preconditioner from the tree 
view.

5 From the Preconditioner list, select Geometric multigrid.

6 From the Hierarchy generation method list, select Refine mesh.

7 Click OK twice to close both dialog boxes.

8 Click the Solve button.

Visualization
1 From the Postprocessing menu, select Plot Parameters.

2 On the General page, clear the Arrow and Edge check boxes.

3 Select the Plot type called Slice.

4 Click OK.

5 Click Zoom Extents.
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The GMG preconditioner automatically saves all mesh refinement cases and makes 
them accessible from the Mesh menu. To see the mesh, go to the Mesh menu and 
change to Mesh case 1. Click the Mesh Mode button on the Main toolbar to visualize 
the mesh (or select Mesh Mode from the Mesh menu):
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This mesh corresponds to about 12,000 degrees of freedom.

To get an even more accurate solution now increase the order of the elements from 
linear to quadratic. This gives you a solution that would be computationally 
demanding if you had used a direct solver instead of the GMG+GMRES combination. 
In doing this you will create mesh case 2 in addition to the already created mesh cases 
0 and 1.

1 From the Mesh menu select Mesh Cases.

2 In the Mesh Case Settings dialog box click New.

3 From the Mesh cases list, select mesh case 2.

4 Select and set the check box for Use same mesh as mesh case to 1.

5 Click OK to close the dialog box.

6 From the Mesh menu verify that Mesh case 2 is the selected mesh case.

7 From the Physics menu select Subdomain Settings.

8 In the Subdomain selection list select Subdomain 1.

9 Click the Element page.

10 Change the Predefined elements from Vector-Linear to Vector-Quadratic.

11 Click OK to close the dialog box.

12 Click the Solve button. The GMG preconditioner now utilizes all three meshes. 

The resulting mesh corresponds to about 60,000 degrees of freedom and the 
computations require about 300 MB of RAM. 

You may get warnings about inverted mesh elements in the solver Progress–Log 
window. This means that some elements are numerically turned inside out due to the 
second order geometrical representation of the element edges. It typically happens at 
curved faces or edges in the geometry. In this model, it may happen at the rounded 
“corners” of the reader antenna. The problem can be avoided by using a linear 
geometry representation of the element edges. Go to the Physics menu, select Model 

Settings, and change Geometry shape order from Automatic to Linear. However, unless 
the inverted elements are located in a critical region, for example on edges where the 
mutual inductance is computed, or if the solver does not converge, you can safely 
ignore the warnings.

You can optimize the mesh even more. The mesh should accurately describe the shape 
of the antenna. This is not a problem for the transponder antenna because it consists 
of straight edges. However, the reader antenna has some curved edges, and you need 
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to manually refine the mesh adjacent to the reader antenna by setting a maximum mesh 
density for the edges that makes up the reader antenna.

1 From the Mesh menu select Mesh Cases.

2 In the Mesh Case Settings dialog box click New.

3 Click OK to close the dialog box.

4 From the Mesh menu verify that Mesh case 3 is the selected mesh case.

5 From the Mesh menu select Free Mesh Parameters.

6 Click the Edge tab. Keep this dialog open but move it aside for later use.

You now need to enable the visualization of all edges:

1 From the Options menu select Suppress>Suppress Edges.

2 Click the Suppress None button and click OK to close the dialog box.

3 Deselect the Orbit/Pan/Zoom button and enclose both the reader and transponder 
antenna with a rubber-band box resulting in them being highlighted in red.

4 Go back to the Edge page of the Free Mesh Parameters dialog box.

5 For the Maximum element size for edges, set 0.05.

6 Click the Global tab.

7 Set the Predefined mesh sizes to Coarse.

8 Click the Remesh button.

9 Click OK to close the dialog box.

Later, you can visualize the interior of the mesh to see the refined mesh around the 
reader antenna. First you need to raise the order of the elements also for this last mesh 
case.

1 From the Physics menu, select Subdomain Settings.

2 In the Subdomain selection list select Subdomain 1.

3 Click the Element tab.

4 Change the Predefined elements from Vector - Linear to Vector - Quadratic.

5 Click OK to close the dialog box. The resulting mesh has about 30,000 elements and 
corresponds to more than 180,000 degrees of freedom. The model, at this stage, 
requires about 400 MB to solve.

6 From the Solve menu, select Solver Parameters.

7 Click the Settings button in the Linear system solver area.
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8 In the Linear Systems Solver Settings dialog box, select Preconditioner from the tree 
view.

9 On the Automatic page, choose Lover element order first (all) from the Hierarchy 

generation method list. Clear the Keep generated mesh cases check box.

10 Click OK twice to close the dialog boxes.

11 Click the Solve button on the Main toolbar. Inverted mesh element warnings may 
appear.

12 From the Postprocessing menu, select Plot Parameters.

13 On the General page, select Slice and Geometry edges, clear all other Plot type check 
boxes.

14 On the Slice page, for the Slice data Expression type log10(normB_emqa). This 
visualizes the base-10 logarithm of the magnitude of the magnetic flux density.

15 Make sure the Slice positioning is set to 1, 1, and 1, for the Number of levels in the x, 
y, and z directions.

16 Click OK to close the dialog box.

To get the value of the mutual inductance variable L12, this time for the refined mesh:

1 From the Postprocessing menu, select Data Display>Global.

2 For the Expression to evaluate, type L12.
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3 Click OK to evaluate.

A value of 9.900337E-10 (this may vary slightly on different computers) is displayed in 
the history log at the bottom of the GUI window. This corresponds to a mutual 
inductance of about 1 nH (rounded).

A D V A N C E D  M E S H  V I S U A L I Z A T I O N

Start by visualizing the interior of the mesh.

1 From the Mesh menu, select the Mesh visualization parameters.

2 Clear the Boundary elements check box.

3 Select the Subdomain and Edge elements check boxes.

4 Change the Edge elements color to a red color.

5 Change the Subdomain elements, Element color to a light gray color.

6 Select the Subdomain elements, Wireframe color check box and set it to dark gray.

7 Select the Element selection check box and set the Logical expression for inclusion field 
to (y>=0.4).

8 Click OK to apply and close the dialog box.

9 Click the mesh mode button to visualize the mesh.

10 From the Options menu, select Preferences.

11 On the Visualization page, change the Line width to 1.0.

12 Click OK to close the dialog box.

13 Click the Headlight toolbar button on the Camera toolbar.

14 Click the Zoom Window button and enclose the upper part of the antenna system.
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Click Zoom Extents to start over if you zoom in too much.

The visualization shows (in red color) that the edges of the curved sections of the 
reader antennas are discretized so that the curvature is resolved quite well.

M A G N E T I C  F L U X - L I N E  V I S U A L I Z A T I O N

1 From the Options menu, select Visualization/Selection Settings.

2 On the Rendering/Selection page, change the Transparency to 1.0 (or use the Decrease 

Transparency toolbar button repeatedly).

3 Click OK to apply and close the dialog box.

4 From the Postprocessing menu, select Plot Parameters.

5 On the Slice page set the Number of levels in the x and y direction to 0 and leave the 
z direction setting at 1.

6 On the Streamline page, change the Predefined quantities to Magnetic flux density.

7 Change the Number of start points to 100. Please note that if the graphics card on 
the computer has limited memory, this operation might fail. If so, try then to reduce 
the number from 100 to, say, 50.

8 Select the Streamline plot check box in the upper-left corner.

9 Click OK to apply and close the dialog box.
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10 Click the Headlight button on the Camera toolbar to switch off the light.

Time-Harmonic Simulations

The RFID tag model also makes sense to solve in time-harmonic setting where you 
solve for a certain frequency, or frequency-sweep, instead of the case of steady-currents 
and fields.

To change the model from being static to time-harmonic is fairly straightforward and 
is described by the following steps.

1 From the Physics menu, select Properties.

2 Change the Analysis type to Time-harmonic.

3 Change the Potentials (solved for) to Electric and magnetic.

4 Make sure Gauge fixing is On.

5 Click OK to close the dialog box.

6 From the Physics menu, select Scalar Variables.

7 Change the Frequency to the desired one, say 50000 Hz. Note that the frequency 
variable is available as nu_emqa (by default).
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8 Click OK to close the dialog box.

The solver settings change when you change the analysis type. To change to GMRES 
with GMG, adjust the corresponding Solver Parameters. The default element type for 
this analysis type is linear elements: linear vector elements for the magnetic vector 
potential and linear Lagrange (isoparametric) elements for the electric potential and 
the gauge-fix variable psi. In order to change the element order for the mesh cases, 
select each mesh case you want to change the settings for and adjust the settings on 
the Element page of the Subdomain Settings dialog box. Please note that if you change 
the defaults, from linear to quadratic for this example, you might run out of memory 
unless you are using a computer with 2 GB of RAM or more.

These are all the necessary changes for solving a time-harmonic problem. Please note 
that because this problem is induction dominated, the computed value of the 
inductance, L12, do not change significantly unless the frequency is very high.

Increasing the frequency of the RFID system does increase radiation losses and 
eventually artificial reflections from the truncation sphere will appear. (So far we have 
ignored radiation losses.) When this becomes a problem you need to add absorbing 
layers or boundary conditions to the outside of the domain. In such a case, you also 
need to use the Electromagnetic Waves, Harmonic Propagation application mode 
found in the RF Module. Such high frequencies are unusual for an RFID system. 
However, if you apply the above modeling technique to another type of wire-antenna 
system you might need to take this into consideration. See the RF Module 
documentation for more information on absorbing layers (called perfectly matched 
layers or PMLs) and boundary conditions.
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