Advanced network topology: modules and complexes

Biological networks have a modular architecture.  A network module is a group of nodes in the network that work together to execute some common function.  Once you have identified the nodes in a module, you can reduce the complexity of your network by replacing the individual nodes of the module (left) with one large metanode (right).  Instead of worrying about the internal workings of the module or meta-node, you can focus on the connections in and out of the metanode: the connections of the meta-node to the rest of the network.
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This tutorial will cover methods for finding modules and complexes, a special type of module in which several individual proteins are assembled into one larger macromolecular machine.  Metanode support will be provided in Cytoscape 2.3.

1. Complexes are a special type of module: they are a group of proteins that interact to form one single piece of cellular machinery, such as the ribosome or the spliceosome.  This section illustrates a couple methods for determining complexes.  The first is the MCODE method, which follows the principle that highly-connected regions of the network are often complexes.

a. Start Cytoscape version 2.2.  Later in this section, we shall work with Cytoscape version 2.1, but for now we shall work with version 2.2.

b. Load the network galFiltered.sif and apply your favorite layout algorithm.  With spring-embedded layout, you should start with a figure such as the one shown here:                       [image: image3.wmf]
c. Under the Plugins menu, select MCODE, and Run MCODE on current network.  Shortly, the MCODE Results Summary window should appear, as shown: [image: image4.wmf]
d. The MCODE results lists thirteen putative complexes, giving the score and the number of nodes and edges in each.  For instance, in the first row, the entry 5,7 in the column Size indicates the putative complex has five nodes and seven edges..  Not all of these results will be significant.  A significant result is one with a high score (greater than one) and a decent number of nodes and edges.  In this case, the first three results may be significant, while the others are more dubious.

e. Click on the results for the first complex.  Notice that on the Cytoscape canvas, the corresponding nodes are selected, as shown: [image: image5.png]


 

f. If these nodes are a portion of a complex, then there should be some process in which they all operate.  Thus, if we explore enrichment under GO, we should see some biological process with significant enrichment for these nodes.  Explore this as follows:

i. Under the Plugins menu, select BiNGO.
ii. In the BiNGO Settings dialog box, fill in the following:

1. A network name of your choice (in this example, I used the highly-creative name of “b”).  Leave the box Get cluster from network checked.

2. Select the Hypergeometric statistics test with FDR correction.

3. Select a high cutoff p-value of 0.05.  Why?  A higher cutoff value will give us more data that we can review in detail below.

4. Select the GO categories overrepresented after correction.

5. Under Select Reference Set, select Test cluster versus network.  Why choose that and not Test cluster versus complete annotation?  Because this network is a portion of the yeast galactose utilization pathway, and thus any random collection of genes in the network are probably involved in galactose utilization.  If we want to know what specific role is played by a portion of the network, we need to look for enrichment relative to the rest of the network.

6. Select an ontology of GO Biological Process, the species Saccharomyces cerevisiae, and gene identifiers of Locus Tags.  

7. The BiNGO Settings dialog box should appear as follows: [image: image6.wmf]
8. Click Start BiNGO.  You should see a graph that appears like the one below: [image: image7.wmf]
9. Notice the dark color of the nodes “peroxisome organization and biogenesis” and “protein-peroxisome targeting”.  Recall that dark colors imply significant enrichment.  What is the p-value?  Check this with the Node Attribute browser.  Hint: with my GO network having the highly-original name “b”, the attributes I need are “adjustedPValue_b” and “description_b”.  You should end up with your Node Attribute browser appearing as follows: [image: image8.wmf]
10.  Note that according to the P values, the enrichment is most significant for “peroxisome organization and biogenesis”.  It turns out that the putative MCODE complex contains all the genes in S. cerevisiae with this GO term.  Thus, this was probably a significant hit.

11. For contrast, return to your MCODE results, select putative cluster #10, and run BiNGO on this cluster.  You should see a graph like the one shown below, and no P value of comparable significance (verify this). [image: image9.wmf]
2. Another indicator of a putative complex is that the genes in a complex are frequently co-expressed.  Here, we shall use the Dynamic Expression plugin (a.k.a. “the Movie”) to identify connected regions that are also co-expressed.

a. Return to your original network, galFiltered.sif, and load the expression matrix file gal.5936x20.mrna from your sample data directory.  This file contains experimental results on twenty different experiments.  In each experiment, some gene in the galactose utilization pathway was “perturbed”, artificially changing its level of activity and expression.

b. Under the Plugins menu, select Dynamic Expression.  You should see a window as shown: 

[image: image10.wmf]
c. Click on the Play button.  You should see a “movie” in which the nodes of your network are colored according to the expression values in each experiment in turn, as shown: [image: image11.wmf]
d. In this display, nodes with expression fold changes of 1 or greater are colored red, nodes with expression fold changes of -1 or less are colored blue,  unchanged nodes are colored white, and nodes with small fold changes are colored pink or light blue according to whether they are greater or less than zero.

e. To see a static image colored by any experiment, go to the Dynamic Expression window, and move the Conditions slider to that experiment.  To change the playing speed, adjust the Speed slider.  During playing of the “movie”, you may stop or pause at any time using the Stop and Pause buttons.

f. Press Play, and watch for any connected regions of the network that change expression levels together.  If you watch your MCODE complex, you should see that while those nodes don’t show any dramatic changes of expression, they show similar patterns.  Can you spot any others?

g. Select by name the node YDR395W, and select its first neighbors.  This should select the region of the network shown below: [image: image12.png]



h. Select these nodes to a new network, and clean up the layout.  This should yield a child network such as the one shown below: [image: image13.wmf]
i. Return to the Dynamic Expression window and click on Play to watch how these nodes change together.  You should see that with the exception or YER056CA, they show patterns of expression that are quite similar.

j. Here, we shall untangle the mystery of YER056CA.  

i. Under the Visualization menu, select Set Visual Style.

ii. When the Visual Styles popup menu appears, click on Define to define the default visual style.

iii. You should see the Set Visual Style window, as shown: [image: image14.wmf]
iv. Note that the default node color is pink, so it will be hard to discern nodes with a slight positive fold change from nodes with no expression values defined.  Change the default color to grey, click on Apply to Network, and close the Set Visual Style popup and the Visual Style popup.

v. Replay the movie.  Notice that our mystery node is grey, indicating that it has no expression value defined, but that all the nodes with defined expression values change in concert with each other.

k. What are these nodes?  Return to the Cytoscape canvas for the parent network, where YDR395W and its immediate neighbors should still be selected.  Run BiNGO, making sure that you test for enrichment relative to the current network.  You should see a network such as the one shown: [image: image15.wmf]
l. By exploring this network, you will see small P values for the nodes “Protein biosynthesis” and “Ribosomal large subunit assembly and maintenance”.  If you were to explore these nodes further under Entrez Gene at NCBI, you would see that they are all components of the large subunit of the ribosome.  Since these genes produce proteins that work together in the ribosome, it makes sense that they would be co-expressed.

m. Can you enlarge the set by identifying any other nodes connected to YDR395W and its neighbors, and showing similar expression profiles?  If you enlarge this set, do your BiNGO results become more significant?  Hint: the answer is yes.

3. This section will illustrate application of the Cytoscape jActiveModules plugin to find subnetworks of nodes for where all or most nodes show substantial responses to the same experimental conditions.  Note: this section will be done with Cytoscape 2.1, as the plugin has not yet been ported to Cytoscape 2.2.  
a. Start Cytoscape 2.1.  From your sample data directory, load the network galFiltered.sif, and apply spring-embedded layout.  Your Cytoscape window should appear as shown below.

[image: image16.wmf]
b. Load the expression data matrix galExpData.pvals from your sample data directory.  This file contains expression results for three sets of expression analysis, involving perturbation of three transcription factors involved in the yeast Galactose utilization pathway.  This file also contains a necessary ingredient for jActiveModules: p-values indicating the significance of each expression value.

c. Under the Plugins menu, select jActiveModules, and then Active Modules: Find Modules.  This will run jActiveModules with the default parameters.

d. Shortly, you should see the Conditions vs. Pathways window similar to the one shown below.  You might not get exactly the same results, because jActiveModules involves  random sampling, as we shall discuss below. [image: image17.wmf]
e. What do these results mean?

i. The plugin found five putative modules.

ii. Module #1 contains 50 nodes, has a respectable score of 4, and appears to be significant in all three experimental conditions gal1RG, gal4RG, and gal80R.  This looks like a significant hit.

iii. Module #2 contains three nodes, with a moderate score of 2, significant in all three experimental conditions.  This might not be an interesting hit, but we shall explore it further later.

iv. The remaining modules contain one node apiece, and have an unimpressive score of 1.  These are surely not significant hits, as it takes more than one node to make a module.

v. So why did we get three non-significant hits? Under the Plugins menu, select jActiveModules, and Set Parameters.  The Find Active Modules Parameters window appears as shown below: [image: image18.wmf]
1. Under General Parameters, notice the input field labeled Number of Paths.  This is where one controls the number of modules returned by jActiveModules.  The default value is 5.  So, jActiveModules will return five putative hits, even if it finds only one good one.

2. Under Annealing Parameters, notice the input field labeled Iterations.  As mentioned earlier, jActiveModules is a stochastic algorithm, and might not return the same results every time.  If you increase the number of iterations, your results will be more consistent, but will take longer to generate.

f. Let’s focus on Module 1.

i. Under the Module 1 column, go down to the experimental conditions column, and click on one of the red bars indicating which experimental conditions yielded significant results.  On the Cytoscape canvas, the nodes belonging to this module should be selected and highlighted in yellow, as shown: 

[image: image19.wmf]
ii. Click on the bars corresponding to another modules, and the nodes of that module should be highlighted instead.  Try this.

iii. Return to Module 1 and highlight the nodes.  Under the Select menu, select To New Network, and Selected nodes, All edges.  This will copy the subnetwork to a new child network, as shown: [image: image20.wmf]
iv. What does this subnetwork represent?  This is a set of connected nodes that altogether showed significant expression changes in the same experiment.  So, this is a subnetwork with an overall significant response to the experimental conditions.  As described in Ideker et al., Bioinformatics 2005 18:S233-S240, such subnetworks tend to correspond to known pathways in the literature.  

v. How do the expression values appear on this network?  Explore this with the Dynamic Expression plugin.  jActiveModules looks in particular for connected regions of significant expression changes - not necessarily large expression changes, a subtle but important difference.  For best results, change the visualization settings to color by significance, as follows:

1. Under Visualization, select Set Visual Properties, and click the Define button to change the default style.

2. In the Set Visual Properties window, locate the Map Attribute slider and change the slider value from expression to significance.  

vi. Run through the Dynamic Expression movie on this subnetwork and on the parent network.  Does the subnetwork appear somewhat enriched for significant expression changes?  It should.

Congratulations!  By now, you are almost ready to go out into the Systems Biology world and do great things!  First, have a cup of coffee to celebrate.
